Overview

Telerik Reporting Q3 2008 Send comments on this topic.
Overview

Glossary Item Box

Telerik Reporting is a unified Windows Forms and ASP.NET reporting tool that offers an easy Visual Studio based design-time experience and royalty-free run time redistribution for all of your .NET reporting needs.

New features in Telerik Reporting streamline the creation of production level reporting. Design time features such as the Report Wizard, Data Explorer and Conditional Formatting provide a true RAD report development experience.

Report Wizard

The Report Wizard steps you through building a report, from data binding to layout and styling. Wizard highlights include:

  • Automatically group and sub total on any column.
  • Convert existing Crystal and ActiveReports.
  • Choose from predefined layout formats and styles.

Powerful Data Processing Model

Flexible expressions allow you to group, sort and filter data without writing queries or event handlers. Use built-in functions, aggregates, database fields, report parameters and user defined functions to build your expressions. Expressions can be used directly as output to the report or as criteria for grouping, sorting and filtering report data. Report Parameters allow user input to be used directly in grouping, sorting and filtering expressions.

Fine Grain CSS-Like Styling

Telerik Reporting uses a built-in styling model similar to CSS. The model provides for fine-grained visual customization of all elements of a report directly in the Visual Studio designer. This CSS-like mechanism offers full control over background, colors, borders, images for every item on your report. Styles can be copied between report items directly in the Report Designer for easy, rapid report development.

Conditional Formatting

Conditional formatting lets you change the report display dynamically based on rules that you define using simple comparisons or by building more complex expressions with the Integrated Expression Builder. Highlighting text based on data values, conditionally displaying images and alternating row appearance are now codeless operations accomplished entirely in the Report Designer. Conditional formatting works together with Telerik Report Styles to achieve complex visual output with minimal effort.

Design-time Support for Visual Studio 2005/2008

Telerik Reporting is closely integrated with Visual Studio 2005/Visual Studio 2008, including:

  • Report Designer
  • HTML Preview mode for Web reports
  • Preview mode for Windows reports
  • Report Explorer with a hierarchical view of the structure of your report
  • Data Explorer with a view of the data sources of your report
  • Report Wizard guides you through designing, data binding and styling a report
  • Expression Builder to help build expressions using data fields, aggregates, user functions and more
  • Style Builder dialog for visually modifying styles and previewing the results
  • Conditional Formatting Rules dialog for building rules and styles
  • Format Builder to build and preview string formats
  • Dialogs for editing groups, filters and sorting

Rich Set of Measurement Units

Telerik Reporting supports a variety of measurement units that are used to achieve precise report layout. Measurement units can be used for any reporting element including borders, padding and font size. Available measurement units are Pixel, Point, Pica, Inch, Mm and Cm. Differing measurement units can be used, even for properties of a single report element. For example Height could be expressed in pixels and Width in inches. A default measurement unit allows you to quickly enter dimensions and positions without specifying the unit.

© 2002-2008, Telerik. All Rights Reserved.


System Requirements

Telerik Reporting Q3 2008 Send comments on this topic.
System Requirements
Installation > System Requirements

Glossary Item Box

The following page describes the system requirements needed by Telerik Reporting:

http://www.telerik.com/products/reporting/system-requirements.aspx


Trial License Limitations

Telerik Reporting Q3 2008 Send comments on this topic.
Trial License Limitations
Installation > Trial License Limitations

Glossary Item Box

Developer Licenses

Developer licenses come with modified DLLs, which work without license keys. If you have a Developer license for one or more of the Telerik products, you only need to ensure that you are using the developer build when downloading the control(s). These builds have the Dev abbreviation in their file names.

If your reports are displaying a copyright message, this means that you are using a trial version of the product. Log in to your Client.net account and download the developer build. To update your project, please take a look at the Upgrading Telerik Reporting Trial to Telerik Reporting Developer license section for step-by-step instructions.

Trial Licenses

The free trial licenses of all Telerik products are fully functional and will work for an unlimited time but with a copyright message displayed on each report page.


Upgrading Telerik Reporting v2.x Trial to Telerik Reporting v2.x Developer license

Telerik Reporting Q3 2008 Send comments on this topic.
Upgrading Telerik Reporting v2.x Trial to Telerik Reporting v2.x Developer license
Installation > Upgrading Telerik Reporting v2.x Trial to Telerik Reporting v2.x Developer license

Glossary Item Box

Follow the steps below to upgrade Telerik Reporting v2.x Trial license to a Developer (production) license.

THE PROCEDURE DESCRIBED IN THIS MANUAL IS IRREVERSIBLE AND YOU MAY LOSE YOUR DATA IF THE INSTALLATION IS NOT CARRIED OUT CORRECTLY!

1. Back up Your Old Files

We strongly suggest that you back-up your old Telerik Reporting files and folders, especially if you would like to use your old settings.

2. Obtain the Necessary File

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases".
  3. Locate Telerik Reporting product, and click on it.
  4. Click on the "Download" tab and download the file. Since you have purchased the control, make sure you are downloading the developer version of the file.

3. Uninstall the Trial Version

Uninstall the Trial version either from the Start Menu shortcut or from Add/Remove programs dialog.

3. Install the developer version

  1. Close Visual Studio or any ither IDE, which may lock the assemblies.
  2. Install the new Developer version of Telerik Reporting.
  3. Check the Changes and Backward Compatibility section for introduced changes. If there are such, they should be applied a little later in the upgrade process.
  4. Back up your application if you haven't done so already.
  5. From the newly installed files, copy the new DLLs located in the /bin folder to your application's bin folder. Replace the old trial dlls .
  6. If using VS.NET, update the control's reference in your project.
  7. Follow the steps in the Changes and Backward Compatibility section in case there are some changes between the versions.
  8. Recompile your project.
  9. Run the project.


Deploying Telerik Reporting on a Server

Telerik Reporting Q3 2008 Send comments on this topic.
Deploying Telerik Reporting on a Server
Installation > Deploying Telerik Reporting on a Server

Glossary Item Box

This article describes how to deploy Web applications, Web Sites, and Windows applications that use Telerik Reporting on a production server.
Deploying Web Applications, created on a development machine
  1. Install Telerik Reporting on your development machine if you have not done so already.
  2. Implement Telerik Reporting in your application on your development machine.
  3. During the installation of Telerik Reporting on your machine, the Telerik assemblies were added to GAC. When deploying a Web Application project using the VS2005 built-in functionality the assemblies from the GAC are not copied automatically so you need to make sure the assemblies physically exist in the bin folder of your application. To do this:
    1. In Visual Studio, expand the References folder of your project.
    2. Right-click on Telerik.Reporting.dll and select Properties.
    3. Locate the Copy Local property and set its value to True. This action will copy the assembly from the GAC to the bin folder of your application.
    4. Do the same steps for the rest of the Telerik Reporting assemblies, required to be on the server:
      i. Telerik.Reporting.dll (described above)
      ii. Telerik.Reporting.Processing.dll
      iii. Telerik.Reporting.Interfaces.dll
      iv. Telerik.ReportViewer.WebForms.dll
  4. Copy/upload the compiled application via FTP to the production server.
  5. Set the appropriate virtual directories and permissions to the folder.
  6. Run the project.

For more information on publishing web applications please see MSDN’s How to Publish Web Application Projects.

Deploying Web Sites, created on a development machine
  1. Install Telerik Reporting on your development machine if you have not done so already.
  2. Implement Telerik Reporting in your application on your development machine.
  3. During the installation of Telerik Reporting on your machine, the Telerik assemblies were added to GAC. When deploying a Web Site project using the VS2005 built-in functionality the assemblies from the GAC are not copied automatically, so you need to copy the assemblies manually from the installation’s Telerik Reporting /bin folder to a new bin folder of your application. To do this:
    1. In Visual Studio, right-click on your Web Site’s root folder and add a New Folder. Rename the folder to bin.
    2. Open a Windows Explorer and locate the bin folder in the installation of Telerik Reporting (usually C:\Program Files\Telerik\Reporting Q3 2008\bin)
    3. Copy the following Telerik Reporting assemblies, required to be on the server:
      i. Telerik.Reporting.dll
      ii. Telerik.Reporting.Processing.dll
      iii. Telerik.Reporting.Interfaces.dll
      iv. Telerik.ReportViewer.WebForms.dll
  4. Paste the assemblies in your web site’s bin folder we have created in 3a.
  5. Upload the web site via FTP to the production server.
  6. Set the appropriate virtual directories and permissions to the folder.
  7. Run the project.
Deploying Windows Forms Applications, created on a development machine
  1. Install Telerik Reporting on your development machine if you have not done so already.
  2. Implement Telerik Reporting in your application on your development machine.
  3. During the installation of Telerik Reporting on your machine, the Telerik assemblies were added to GAC. When deploying a Win Application project the assemblies from the GAC are not copied automatically so you need to make sure the assemblies physically exist in the bin folder of your application. To do this:
    1. In Visual Studio, expand the References folder of your project.
    2. Right-click on Telerik.Reporting.dll and select Properties.
    3. Locate the CopyLocal property and set its value to True. This action will copy the assembly from the GAC to the bin folder of your application.
    4. Do the same steps for the rest of the Telerik Reporting assemblies, required to be on the server:
      i. Telerik.Reporting.dll
      ii. Telerik.Reporting.Processing.dll
      iii. Telerik.Reporting.Interfaces.dll
      iv. Telerik.ReportViewer.WinForms.dll
  4. Run the project.
Other assemblies (NOT needed on the production server)

The following assemblies are used for the Reporting design time support. They are not needed at runtime, nor on the production server:

  • Telerik.Reporting.Design.dll
  • Telerik.ReportViewer.Design.dll

The following are used for converting reports created in other reporting solutions. They are not needed on the production server:
  • Telerik.ReportConverter.ActiveReports.dll
  • Telerik. ReportConverter.CrystalReports.dll
  • Telerik.ReportConverter.XtraReports.dll
These assemblies can be located in the Telerik Reporting product folder (usually C:\Program Files\Telerik\Reporting Q3 2008\bin).


Upgrading to a Newer Version of Telerik Reporting

Telerik Reporting Q3 2008 Send comments on this topic.
Upgrading to a Newer Version of Telerik Reporting
See Also
Installation > Upgrading to a Newer Version of Telerik Reporting

Glossary Item Box

There are two kinds of Telerik Reporting versions -- major and minor. Major versions such as Q3 2007, Q1 2008, etc. can coexist simultaneously on the same machine. Minor versions are also known as Service Packs. There can be only one Service Pack installed per major version, i.e. if you had v Q1 2008 and a Service Pack is released (let's say Q1 2008 SP1) you will need to un-install version Q1 2008 and then install Q1 2008 SP1.

Upgrading to a Newer Version

  1. Uninstall the old version if you are installing a Service Pack, for example from Q1 2008 to Q1 2008 SP1. Even if you forget to remove the old version, when you start the installer of the Service Pack you will be prompted to do so.
  2. Install the new version of Telerik Reporting.
  3. For all projects that need to use the new version of Telerik Reporting:
    • Web Site project:
      1. In Solution Explorer, click the "Show All Files" button.
      2. Delete all Telerik Reporting assemblies from the Bin folder.
      3. From the References tab on the Web Site’s Property Pages remove all references to Telerik Reporting assemblies. Remember the names of assemblies that you delete.
      4. Add all needed references to the new version of Telerik Reporting assemblies. They should be the same as the ones that you deleted in the previous step.
      5. Open your web.config file and make sure that you change all versions to the new one in the following instances:
        *<configSections> - this is where you can alter the rendering extensions attributes
        *<httpHandlers> - this is where the ReportViewer registers its handler
        *<assemblies> - the Reporting assemblies that are references in the web site
      6. Open your .aspx/.master pages and change the version of the ReportViewer in the Register directive
      7. Open all report resource files (each .resx file appears under the respective report file) as XML. Locate all occurrences of a Telerik Reporting Assembly and update the version number to the new one. Unlike the version name (Q1 2008) a version number is a more technical identifier such as 2.5.8.414, for example. Microsoft .NET Assemblies (dll's) have such versions. You can find out what an assembly version is by looking at its properties after you have selected it in Solution Explorer (under the References node of a Visual Studio Project). You can quickly find all occurrences of a Telerik Reporting assembly with the old version by doing the following:
      • Go to Edit -> Find and Replace -> Find in Files.
      • Look In = Current Project.
      • Find What = “Version=<the old version here>”.
      • Click Find All.
      • All matches will appear in the Find Results Window. You can navigate to each one by double-clicking it.

      Have in mind that the search string can find other occurrences of assemblies beside the Telerik ones if the version is the same (for example some .NET assemblies) so make sure you review each match carefully and change the version only if it is a Telerik Reporting assembly.

    • Class Library/Windows Forms/Web application project:
      1. In Solution Explorer, click the "Show All Files" button.
      2. Open the "References" node and locate the references to the old Telerik Reporting assemblies. In case you are installing a Service Pack you will notice that the Telerik Reporting assemblies have an yellow exclamation mark next to them, meaning that they cannot be located. That is because you have uninstalled the version that they belong to and is normal.
      3. Select the old assemblies that you located in Step 3 and hit delete to remove them. Remember the names of assemblies that you delete.
      4. Right-click on the "References" node and select "Add Reference".
      5. Add all needed references to the new version of Telerik Reporting assemblies. They should be the same as the ones that you deleted earlier.
      6. Now they should appear in the "References" node without yellow exclamation marks, meaning that they are valid.
      7. Open your web.config/app.config file and make sure that you change all versions to the new one in the following instances:
        * <configSections> - this is where you can alter the rendering extensions attribute
        * <httpHandlers> - this is where the ReportViewer registers its handle
        * <assemblies> - the Reporting assemblies that are references in the web site
      8. Open your .aspx/.master pages (for web apps only) and change the version of the ReportViewer in the Register directive
      9. Open all report resource files (each .resx file appears under the respective report file) as XML. Locate all occurrences of a Telerik Reporting Assembly and update the version number to the new one. Unlike the version name (Q1 2008) a version number is a more technical identifier such as 2.5.8.414, for example. Microsoft .NET Assemblies (dll's) have such versions. You can find out what an assembly version is by looking at its properties after you have selected it in Solution Explorer (under the References node of a Visual Studio Project). You can quickly find all occurrences of a Telerik Reporting assembly with the old version by doing the following:
        • Go to Edit -> Find and Replace -> Find in Files.
        • Look In = Current Project.
        • Find What = “Version=<the old version here>”.
        • Click Find All. All matches will appear in the Find Results Window. You can navigate to each one by double-clicking it.
        • Have in mind that the search string can find other occurrences of assemblies beside the Telerik ones if the version is the same (for example some .NET assemblies) so make sure you review each match carefully and change the version only if it is a Telerik Reporting assembly.
  1. Restart Visual Studio.
  2. Rebuild all updated projects.

See Also

Project References
Resources in .Resx File Format


Creating a Simple Report

Telerik Reporting Q3 2008 Send comments on this topic.
Creating a Simple Report
Quickstart > Creating a Simple Report

Glossary Item Box

Create the Class Library for the Reports

To create even simple reports you start by creating a class library to contain your report and a web or windows application to display the report.

It is possible to put the report definition and viewer in the same application but this route is not recommended. See this topic on best practices for more information.
  1. Select File | New | Project from the Visual Studio File menu. Select the Class Library project, give it a name and location. Click the OK button to close the dialog.

Creating the Class Library

  2. Right-click the project context menu and select Add | New Item | Telerik Report. Enter a name for the report class and click the Add button to close the dialog. In this example we name the report class file "ProductList.cs".

  3. The Telerik Report Wizard will appear automatically to help you select data and design your report quickly. Once you have the basic report layout you can go back to edit the report, add data columns and tweak the format. Click the Next button.

  4. On the Report Choice Page of the Report Wizard, select New Report and click the Next button.

  5. On the Choose Data Source page of the Report Wizard, select New Data Source and click the Next button.

  6. On the Choose a Data Source Type page of the Report Wizard select the Database icon and click the Next button.

  7. The standard Add Connection dialog will display.
  • In the Server Name edit enter "(local)\sqlexpress".
  • In Select or enter a database name choose the AdventureWorks database.
  • Optionally, you can click the "Test Connection" button to verify the connection.
  • Click OK to close the dialog. Note: The AdventureWorks database installs with Telerik Reporting and so should always be available to test with. If you are missing the samples database try repairing the Telerik Reporting installation.

  8. On the Choose a Data Connection page of the Reports Wizard select your new database connection for AdventureWorksT from the drop down list. Note: The machine name will be the name of the machine you are developing on, but shown in the figure below as "ra". Click the Next button.

  9. The Choose Your Database Objects page of the Reports Wizard will display next.
  • Click the Query Builder button.
  • In the Add Table dialog select "Product", "ProductInventory", "ProductPhoto" and "ProductProductPhoto" from the list of tables. Note: You can hold down the control key and click each of the tables to select them all at one time.
  • Click the Add button to close the dialog.

  • On the Query Builder select the fields shown in the figure below. In the Product table select "Name", "ProductNumber" and "ReorderPoint". In ProductPhoto select the "ThumbNailPhoto" column. In the ProductInventory table select the "Quantity" column.
  • Click the OK button to close the dialog.

  • In the Choose your Database Objects page of the Report Wizard leave the values shown and click the Next button. On the next page choose Standard Report Type and click the Next button.

  10. The Design Data Layout page of the Report Wizard allows you to assign database fields to sections of the report. The Report Wizard automatically places and formats the database fields in the appropriate report sections.
  • Select from the Available Fields list on the left side of the page.
  • Select "Name", "ProductNumber", "ReorderPoint" and "Quantity".
  • After selecting each field, click the Detail button to add those columns to the detail listing of the report.
  • Click the Next button.

  11. On the Choose Report Layout page of the Report Wizard unselect the Adjust report items to fit available space checkbox. Click the Next button.

  12. On the Choose Report Style page of the Report Wizard select "Civic" from the Style Sheets list on the left side of the page. Notice the style changes in the Preview portion on the right side of the page.

  13. On the Completing the Wizard page of the Report Wizard you can review the settings for the report and click the Finish button.

The initial report layout appears in the design view in Visual Studio.

Notice that the wizard has automatically provided:

  • Data bound fields in the detail section of the report.
  • Styled page and column titles.
  • A page footer with standard date and page number output.

  14. Rebuild the project.
  15. Click the Preview tab of the designer to view your report.

From here you can:

  • Extend the Simple Report Design to include conditional formatting, Shape and PictureBox report items. This topic also introduces in-place editing, copying and pasting styles, using the Data Explorer and Report Explorer.
  • Create a Windows application to display the reports.

To learn more about displaying your report in a viewer see the Displaying Reports in the Windows Viewer Quickstart.


Extending the Simple Report Design

Telerik Reporting Q3 2008 Send comments on this topic.
Extending the Simple Report Design
Quickstart > Extending the Simple Report Design

Glossary Item Box

This topic will extend the example Creating a Simple Report to show several unique Telerik Reporting features including:

  • In Place Editing.
  • Copying and pasting styles.
  • Conditional formatting.
  • Navigating and sizing report items.
  • Resizing report sections.
  • Adding Text, Shape and PictureBox report items to the report designer.
  • Using the Data Explorer.
  • Using the Report Explorer.

Use the report design created in Creating a Simple Report as a starting point.

  1. Double click the "ProductList" TextBox report item in the report header. This will activate the "in place" editor, allowing you to enter text right in the designer without having to find the appropriate property in the Property Window. Add a space so the TextBox reads "Product List".

  2. Zoom to 150% from the Zoom Combo Box in the lower left corner of the design surface. From the ToolBox window drag a TextBox item to the report header just to the right of the "Quantity" column. While dragging the TextBox, the Snap Lines will aid you in positioning it so it aligns nicely with its neighbours. Double-click the TextBox and enter "Reorder".

  4. Right-click the "Quantity" TextBox and select Copy Style from the context menu. Right-click the "Reorder" field and select Paste Style from the context menu.

  5. In these next steps you define a circle Shape item that reacts to changes in the data so that when inventory falls below 50% of the "reorder point" quantity the circle will be filled in red.

From the ToolBox window drag a Shape item to the detail section just below the "Reorder" column. In the Properties window set the Size.Width property to ".1" and the Size.Height property to ".1". Right click the Shape item and select Conditional Formatting from the context menu.

  6. The Conditional Formatting Rules dialog will display.
  • Click the New Rule button.
  • The Edit Formatting Rule dialog will display.
  • Click the New button to create a rule. Use the drop down lists to set Expression to Fields.Quantity, Operator to "<" and Value to "<Expression>". When you select "<Expression>" the Edit Expression dialog displays. This dialog allows you to select from predefined data (i.e. constants, database fields, report parameters, etc.) and create an expression with them.
  • Select Fields from the list on the bottom right of the dialog.
  • Double-click "ReorderPoint" from the bottom middle list to add it to the expression.
  • Add to the expression at the top of the dialog so the complete expression reads "= Fields.ReorderPoint * .5". This rule will fire when the quantity of a product falls below half of the ReorderPoint value. Click OK to close the Edit Expression dialog.

  • On the Edit Formatting Rule dialog click the Style button to display the Style Builder dialog.
  • Click Background from the list on the left and select "Red" from the Background Color drop down list.
  • Click OK to close the dialog.
    Click OK twice more to close the remaining rule dialogs.

  7. Press F6 to build the report.
  8. Click the Preview button to display the report. Scroll through the data and notice that the "Quantity" values that are below 50% of the "Reorder point" are displayed in red.

  9. The last set of steps to building this report design add an image item to the report and format the page footer. These last steps also use the Data Explorer and the Report Explorer.

From the Telerik Reporting menu select the Data Explorer.

  10. Select the "ThumbNailPhoto" column from the Data Explorer list and drag it to the detail section of the report designer, just to the right of the "Reorder" column. Notice that this step automatically creates a PictureBox report item.
  11. After dropping the ThumbNailPhoto the DetailSection will be automatically resized to accommodate the entire PictureBox item:

  12. The Report Explorer provides a hierarchical view of all the report sections and items in the report design. This allows you to easily locate items that might otherwise be difficult to find in a visually complex report.

From the Telerik Reporting menu select the Report Explorer.

  12. Click "pageFooterSection1" to select the report page footer.
  13. In the Properties window set the Style.BackgroundColor property to "LightGray".

  15. Rebuild the project.
  16. Click the Preview button to view the report. Scroll through the report pages to find records that have images.


Displaying Reports in the Windows Viewer

Telerik Reporting Q3 2008 Send comments on this topic.
Displaying Reports in the Windows Viewer
Quickstart > Displaying Reports in the Windows Viewer

Glossary Item Box

  1. Select File | New | Project from the Visual Studio 2005 File menu. Select the Windows Application project, give it a name and location. Click the OK button to close the dialog.

  2. Right-click the project References and select Add Reference from the context menu. Select the reference for the class library containing your report from the list on the Projects tab. Note: If the class library resides in another solution you will need to use the Browse tab and navigate to the assembly containing the report.

  3. From the ToolBox drag a ReportViewer control to the Windows form.
  4. Set the Dock property to Fill so that the viewer takes up the entire window area.
  5. Set the Report property from the drop down list. This will be the report that was defined in the class library.

    Once the report is selected, notice that a component representing the report appears in the tray below Windows form designer. The component allows you to access the properties of the report in your report viewing application, providing access to report parameters, styles and page settings.
  6. Add a call to the report viewers RefreshReport() method, just after the call to InitializeComponent() in the form constructor.
    [C#] Calling RefreshReport() Copy Code
    public Form1()
    {
    InitializeComponent();
    reportViewer1.RefreshReport();
    }

    [VB] Calling RefreshReport() Copy Code
    Public Sub New()
    InitializeComponent()
    reportViewer1.RefreshReport()
    End Sub
  7. Right-click the Windows report viewing application and select Set as Startup Project from the context menu.
  8. Press F5 to run the report.


Report Designer

Telerik Reporting Q3 2008 Send comments on this topic.
Report Designer
Reporting Designer User Interface > Report Designer

Glossary Item Box

The Telerik Report Designer has the following elements:

  • Telerik Reporting Menu: The menu lets you run the Report Explorer, Data Explorer and Report Wizard.
  • Report selector button: Located in the upper left hand of the report designer. Clicking this button makes the report active in the Properties window.
  • Rulers: on the top and left side of the designer provide a point of reference to the report layout. Click in the ruler area to display a line vertically or horizontally across the report. You may also drag in the ruler area to select an area vertically or horizontally across the entire report. This can be particularly useful when you want to select everything in a particular column or set of columns vertically.
  • Report Sections: The high level report design consists of report sections for the report header, report footer, page header, page footer, detail, group header and group footer. Each section can be resized by dragging the sizing grips at the top of each section and collapsed using the button located to the left of each section. Most sections except the detail can be deleted by selecting the section and hitting the delete key. To delete a group section, delete its group component located in the tray below the designer.
  • Context Menu: This menu will conditionally display contents depending on the area that was right-clicked. In the figure below the menu is invoked in the area next to the report design surface.
  • Section Expand/Collapse: Use these buttons to temporarily hide a section.
  • Group Component: These components represent each group adding to the report. Click on the Group Component to access properties in the Properties Window, e.g. properties to determine what data columns are grouped on, sorting and grouping behavior.
  • View Mode Buttons: Use these buttons to switch between Design, Preview and HTML views of the report.

All of the elements below are especially designed to ease you in your Report Designing experience. They toggle various different options that help in aligning, snapping, stretching the report items and make sure they have margins and padding in mind.

  • Zoom Combobox - this enables you to easily specify the zoom percentage in which you see the design surface. You can do that by holding the Ctrl key and use the mouse wheel to zoom as well.

  • Snap Grid: Snapping and the snap grid provide you with a set of horizontal and vertical gridlines that—when you drag an object on the design surface—will snap or pull towards the closest vertical or horizontal gridlines. Objects can also snap to column and row dividers within a grid panel. Here is a workspace showing the snap grid turned on:

    Additionally, snaplines allow you to drag objects on the design surface and have them snap to the margins or alignment (red dashed line) of other objects within the same container element such as a layout panel, column and row dividers in a grid panel, as well as the padding of the container element.

    Show/hide the snap grid by using the button in the lower-left corner of the design surface, click Show snap grid . To hide the snap grid, click the button again to see the off icon.
    Turn on snapping to gridlines: In the lower-left corner of the design surface, click Turn on snapping to gridlines . To turn off snapping to gridlines, click the button again to see the off icon.
    Turn on snapping to snaplines: In the lower-left corner of the design surface, click Turn on snapping to snaplines . To turn off snapping to snaplines, click the button again to see the off icon.

    Show/Hide Dimensions: In the lower-left corner of the design surface, click Show Dimensions . To hide the dimensions, click the button again to see the off icon.

    Turn On/Off Pan: In the lower-left corner of the design surface, click Turn On Pan . To hide the "hand" and disable dragging, click the button again to see the off icon.
    Show/Hide the report MiniMap: In the lower-right corner of the design surface, click Show MiniMap. This element is especially useful when you have zoomed the report and want to focus on a specific element. To hide the map, click on the design surface to have it closed.

  • Change the alignment of an element

    Alignment determines how an element resizes. For example, a left aligned element stretches to the right as the parent layout container gets resized.

    To change the alignment of an element use the Layout toolbar and do one of the following:

    • Select two report items and change their HorizontalAlignment by clicking Left , Center , Right , or Stretch .
    • Select two report items and change their VerticalAlignment by clicking Top , Center , Bottom , or Stretch .

    You can also change alignment by moving an element on the design surface.


Telerik Reporting Menu

Telerik Reporting Q3 2008 Send comments on this topic.
Telerik Reporting Menu
Reporting Designer User Interface > Telerik Reporting Menu

Glossary Item Box

The Telerik Reporting menu can be accessed whenever an area of the report designer is selected. From here you can call:

  • Report Explorer
  • Data Explorer
  • Report Wizard
  • Upgrade Wizard (still in Beta) - allows you to easily upgrade your reports to our latest versions for best compatibility and feature richness.


Report Explorer

Telerik Reporting Q3 2008 Send comments on this topic.
Report Explorer
Reporting Designer User Interface > Report Explorer

Glossary Item Box

The Report Explorer is an aid to navigating report elements. The Report Explorer allows you to see the structure of the report and to select any item in the report. The Report Explorer can be especially handy for complex reports where components may be nested and where it would be difficult to select an item with the mouse.

In the screenshot below you can see that the report is represented by the root node of the tree. Underneath that the sections of the report and for each section the report items in the section.

The Report Explorer can also be accessed from the context menu View | Report Explorer when right-clicking the area next to the report design surface.


Data Explorer

Telerik Reporting Q3 2008 Send comments on this topic.
Data Explorer
Reporting Designer User Interface > Data Explorer

Glossary Item Box

The Data Explorer provides an overview of the database fields that are available to your report. It is available whenever you have a report open in design view.

To display the Data Explorer, select Data Explorer from the Telerik Reporting menu.

The Data Explorer window lists the data source columns defined for your report. Drag column names from the Data Explorer to the report design surface to create new data bound report items. The report designer automatically creates appropriate report items based on the column data type, e.g. if the column has character data a TextBox report item will be created, if the column has image data then a PictureBox report item will be created.


Report Wizard

Telerik Reporting Q3 2008 Send comments on this topic.
Report Wizard
Reporting Designer User Interface > Report Wizard

Glossary Item Box

The Telerik Report Wizard helps you quickly create the structure of your report. Using the wizard you can:

  • Select a data source.
  • Design a query to execute against the data source.
  • Choose the type of report to create.
  • Specify the basic layout of the report.
  • Specify the formatting for the report.

The Report Wizard runs automatically when you add a Telerik Report item to the project, but can also be run using the Telerik Reporting Menu. Each run of the Report Wizard overwrites previous definitions of the report. The Report Wizard consists of the following pages:

Page | Image | Description
Welcome Page | This page lists the tasks that can be performed with this wizard.
Report Choice Page | From here you can choose to create a new report or convert from an existing report. Select New Report to start from scratch or select Convert from existing Report to select from a list of available converters. Use the Browse button to locate the report to convert.
Choose Data Source

This page lets you use an existing data source from a list of data sources or choose New Data Source. If you choose to create new data source the wizard will walk you through an additional set of pages before continuing:

  • Choose a Data Source Type: Choose A Database or Business Object.
  • Choose a Data Connection: Define a connection string.
  • Choose your Database Objects: enter a SQL statement directly or use the supplied Query Builder.
Select Report Type

This page lets you choose the report type. Choose Standard to create a general type of report or Label if you would like to create a special purpose report such as one for printing labels for mailing envelopes.

Design Data Layout

Lets you select data columns from the data source and have them placed in the report heading and the detail sections of the report. You can also choose columns to group data by.

Select from a list located on the left in the dialog titled Available Fields. Use the Report, Group and Detail buttons to add the selected column from the Available Fields to the respective list of Displayed Fields. Use the Remove button to move fields from the Displayed Fields list back to the Available Fields list. Use the up and down arrow buttons to reorder the columns in the report.

Choose Report Layout

Choose from a list of predefined layouts to quickly structure the reports visual representation. See the Description and Preview window to get a rough idea of how the report will be layed out.

Select the Adjust report items to fit available space checkbox to have columns take all the horizontal area available. Unselect this checkbox if you want to add other columns by hand later and need the columns to take less horizontal space.

Check the Generate sub-totals to have subtotals created at group footers. Appropriate functions are used based on the data type of the column, i.e. Sum() for numeric Count() for other types.

Choose Report Style | Select from a predefined list of report styles to give your report a polished look. The preview widow provides a general idea of what a finished report will look like.
Completing the Wizard | This page provides a summary of the choices made in the wizard including the connection string and SQL statement. Click the Finish button to see the completed report or Cancel to ignore all changes.


Context Menu

Telerik Reporting Q3 2008 Send comments on this topic.
Context Menu
Reporting Designer User Interface > Context Menu

Glossary Item Box

The context menu will conditionally display items depending on the area of the report that was right-clicked. Some of the significant context menu items are:

  • View: Sub menus of View allow you to select Data Explorer and Report Explorer.
  • Style: Invokes the Edit Style dialog for the right-clicked item. From here you can set the Text, Background, Edges and Line style for the report items, sections or the report as a whole.
  • Copy, Paste, Reset Style: To copy the style from one item in the report, right-click a report item and select Copy Style, then right-click another report item and select Paste Style. Right-click and select Reset Style to restore an items previous style before the paste.
  • Page Header, Page Footer, Report Header and Report Footer: These menu items can be toggled on and off to create and remove respective sections in the report.
  • Add New Group: This menu item adds a new group to the report and new group component to the tray below the report designer.
  • Select: Variations of this menu item allow you to select the report, sections in the report or items in sections of the report. The menu choices allow you to select elements of the report that are underneath the right-clicked item.
  • Expressions: This menu item invokes the Edit Expression dialog. The dialog supplies a list of elements that can be used in your expression including Aggregates, Constants, Fields, Functions, Global Objects, Operators and Report Parameters.
  • Conditional Formatting: This menu item invokes the Conditional Formatting Rules Dialog. This dialog lets you define rules that when fired change the style formatting of the selected item.

In the figure below the menu is invoked in the area next to the report design surface.

In the example below, a TextBox was right-clicked to display this context menu. The TextBox context menu includes the Format menu item. Clicking this item displays the Format Builder dialog.


Edit Expression Dialog

Telerik Reporting Q3 2008 Send comments on this topic.
Edit Expression Dialog
Reporting Designer User Interface > Edit Expression Dialog

Glossary Item Box

The Edit Expression dialog allows you to dynamically produce a value for a report item in place of a hard coded value. The Edit Expression dialog provides a list of predefined and dynamic elements that can be used in your expression. A list of expression element categories is located in the lower left hand list of the dialog, the elements for each category are located in the lower middle of the dialog, and descriptions are displayed in the lower right hand of the dialog.

To use the Edit Expression dialog either type an expression in directly or double click the list of elements in the bottom middle list to add them to the expression. In the figure below an expression with two database Fields multiplied provide an extended price value. For a list of the supported expression elements see Using Item Binding Expressions.


Conditional Formatting Rules Dialog

Telerik Reporting Q3 2008 Send comments on this topic.
Conditional Formatting Rules Dialog
Reporting Designer User Interface > Conditional Formatting Rules Dialog

Glossary Item Box

The Conditional Formatting Rules dialog lets you define rules that when fired change the style formatting of the selected item. You can define multiple rules that will format the same report item. Each rule is made up of a set of conditions and a style to use when the conditions of the rule are met. Rules are executed in the order they appear in the ConditionalFormatting collection. You can choose whether to continue evaluating all rules in the collection or interrupt execution when a rule is satisfied.

Use the New Rule, Edit Rule and Delete Rule buttons to add, edit and delete formatting rules. Use the arrow buttons to change the order of precedence where rules higher in the list are evaluated before rules occuring later in the list. Select the Stop if true checkbox to interrupt rule processing if the rule conditions are satisfied.

The New Rule and Edit Rule buttons display the Edit Formatting Rule dialog. The top portion of the dialog contains a list of rules. Each rule consists of an Expression an Operator and a Value. Expression can be a database field defined in the Report DataSource or "<Expression>". "<Expression>" invokes the Edit Expression Dialog. Operator lists comparison operators (i.e. <, >, >=, etc.), Like, Top N, Top %, Bottom N and Bottom %. Value can be a hard coded value, "<Blank>" or "<Expression>". Rules expressions are "and-ed" together and must all be true for the rule condition to be satisfied.

The bottom portion of the Edit Formatting Rule dialog has a button to invoke the Edit Style dialog and a preview of the style. The Style button displays the Style Builder dialog that sets the formatting to be used if the rule conditions are satisfied. Here you can define the style for Text, Background, Edges and Line styles.


Format Builder Dialog

Telerik Reporting Q3 2008 Send comments on this topic.
Format Builder Dialog
Reporting Designer User Interface > Format Builder Dialog

Glossary Item Box


Edit Filter Dialog

Telerik Reporting Q3 2008 Send comments on this topic.
Edit Filter Dialog
Reporting Designer User Interface > Edit Filter Dialog

Glossary Item Box

The Edit Filters dialog allows you to specify which records will be displayed. The dialog populates the Report.Filters collection. See the example below that displays only records where the first four characters of the "Name" field must be "Tour" and the "FinishedGoodsFlag" field must be True.

Using the Edit Filters Dialog

  • To create a new filter rule click the New button.
  • Each filter consists of an Expression, an Operator and a Value. The Expression is compared against the Value column using the assigned Operator. Use the Expression drop down to choose an existing report data source field or choose <Expression> from the drop down list to invoke the Edit Expression Dialog. Select an operator from the Operator drop down list. You can enter a value directly into the Value entry or you click the drop down button to select <Blank> or <Expression>.
  • You may create multiple filter rules. All rules must be true for a given record to be displayed.
  • To remove a filter rule select the rule and click the Delete button.

For more information on filter expressions, filter operators and filtering groups vs. reports see the Filtering Report Data topic.


Edit Sorting Dialog

Telerik Reporting Q3 2008 Send comments on this topic.
Edit Sorting Dialog
Reporting Designer User Interface > Edit Sorting Dialog

Glossary Item Box

thThe Edit Sorting dialog controls the order that records are displayed in. The dialog populates the Report.Sorting property. In the example below products are sorted first by Shelf, then Bin (in descending order) and finally by product Name.

Using the Edit Sorting Dialog

  • To create a new sort click the New button.
  • Each sort consists of an Expression and a Direction. Use the Expression drop down to choose an existing report data source field or choose <Expression> from the drop down list to invoke the Edit Expression Dialog. Direction can be the default "Asc" (ascending) or select "Desc" (descending) from the Direction drop down list.
  • You may create multiple sorts, each with its own direction.
  • The order that sorting expressions are listed in the dialog control the precedence of record sorting (see the screenshot above). Use the up and down arrow buttons to reorder sorting expressions.
  • To remove a sort select the rule and click the Delete button.


Edit Grouping Dialog

Telerik Reporting Q3 2008 Send comments on this topic.
Edit Grouping Dialog
Reporting Designer User Interface > Edit Grouping Dialog

Glossary Item Box

The Edit Grouping dialog controls how sets of records are broken out and displayed with headings and subtotals. The dialog populates the Report.Grouping collection. In the example below products are grouped first by Shelf then by Bin. Headings and subtotals appear for each Shelf/Bin combination.

You can arrive at the Edit Grouping dialog either using the Report.Groups.Grouping property, or by clicking on a Group component displayed in the tray below the designer.

Using the Edit Grouping Dialog

  • To create a new grouping expression click the New button.
  • Each grouping expression consists of either a field name from the report data source or an expression. Use the Expression drop down to choose an existing report data source field or choose <Expression> from the drop down list to invoke the Edit Expression Dialog.
  • You may create multiple grouping expression. The order that grouping expressions appear in the dialog control the hierarchy that records are displayed in. In the example screenshot above "Shelf" is the first criteria and "Bin" is the second criteria. Here you see Shelf "A" repeated and all the bins that appear with Shelf "A". If "Bin" were the first criteria you would see Bin "0" repeated and Shelf "A", "B", "C"... for that bin. Use the up and down arrow keys to move grouping expressions up or down in the list.
  • To remove a grouping expression select the expression and click the Delete button.


Style Builder Dialog

Telerik Reporting Q3 2008 Send comments on this topic.
Style Builder Dialog
Reporting Designer User Interface > Style Builder Dialog

Glossary Item Box

The Style Builder dialog lets you set Text, Background, Edges and Line Style for any given report item including sections and the report as a whole. The dialog is accessed through the Style property ellipses button and is also used in conditional formatting. The dialog lets you change several style elements at one time and see the result in the Preview pane at the bottom of the dialog.

To use the Style Builder dialog choose a style element from the list on the left of the dialog. Change style characteristics in the area to the right of the list. Click the OK button to apply the style changes or the Cancel to leave the previous style untouched.


Designing Reports

Telerik Reporting Q3 2008 Send comments on this topic.
Designing Reports
See Also
Designing Reports > Designing Reports

Glossary Item Box

The Telerik Reporting package provides a complete graphical report designer that runs inside of Visual Studio 2005. Using the designer, you can perform all the tasks necessary to construct a report, including:

  • Report life cycle
  • Understanding report sections
  • Understanding report items
  • Creating a report
  • Previewing the report
  • Creating grouping levels
  • Creating page headers and footers
  • Creating report headers and footers
  • Placing and sizing report items
  • Dynamic Layout (Dock and Anchor)
  • Setting report item properties
  • Connecting data to the report

See Also

Placing and Sizing Report Items
Creating Page Headers and Footers
Creating Report Headers and Footers
Connecting Data to a Report
Adding a Data Source with the Data Source Wizard
Adding a Data Source Programmatically
Using Expressions
Previewing Reports in Design Time
Report Layout Options
Grouping Report Data
Create a New Group
Display Hierarchical Data with SubReports
Design Considerations for Report Rendering
Page Setup


Report Life Cycle

Telerik Reporting Q3 2008 Send comments on this topic.
Report Life Cycle
Designing Reports > Report Life Cycle

Glossary Item Box

Understanding the report life cycle, what happens and when it happens is crucial to effectively using Telerik Reporting.

  • The diagram shown below describes the sequence of events from designer to completed document.
  • The section "Report Lifecycle Overview" below provides further detail on the activities that occur at each stage of the report lifecycle.
  • The section "Why Report Lifecycle is Important" explains what report sections may contain data bound fields, aggregates and global objects.

Report Lifecycle Overview

  1. The report is designed in the Visual Studio Report Designer. The act of designing the report produces a report class that embodies the Report Definition.
  2. The report is processed:
    • Binds the Report Definition with data from the report data source.
    • Performs all grouping, sorting and filtering calculations.
    • Evaluates all Expressions except page header and footer section items.
    • Fires item Binding and Bound events.
    • Produces a Report Instance. Report instances may be stored and rendered at a later time.
  3. The report is rendered:
    • The Report Instance is passed to a specific rendering extension (e.g. MHTML or PDF output formats).
    • The report instance is paged if the output format supports paging.
    • Item expressions are evaluated in the page header and footer sections for every page.
    • The report is rendered to the Output Document.

Why Report Lifecycle is Important

There are many ramifications of the report lifecycle including when you can use bound data fields, aggregates and page information functions.

  • Page Headers and Footers: Item binding expressions cannot use data fields or aggregate functions. Paging is specific to rendering format and must occur during rendering, well after early report processing where data binding occurs. PageNumber and PageCount global objects are available only in this section.
  • Report Headers and Footers: Item binding expressions should use only aggregate functions. If an expression specifies a data field without an aggregate, the First() aggregate function is used by default. The First() function returns the first record of the data source for the specified field.
  • Detail Section: The detail section can contain data bound fields and any function available in the Edit Expression Dialog except PageCount and PageNumber.
  • Grouping: Item binding expressions should only use aggregate functions. If an expression specifies a data field without an aggregate, the First() aggregate function is used by default. The First() function returns the first record of the data source for the specified field.


Understanding Report Sections

Telerik Reporting Q3 2008 Send comments on this topic.
Understanding Report Sections
Designing Reports > Understanding Report Sections

Glossary Item Box

In Telerik Reporting, the design of a report is divided into sections. You can view your report in Design view to see its sections. To create useful reports, you need to understand how each section works. For example, the section in which you choose to place a data bound items determines how Telerik Reporting calculates the results.

Report sections divide the report vertically. Depending on their type they appear on specific places in the report document and the report items they contain are processed and rendered differently.

The following list is a summary of the section types and their usage:

  • Page Header - This section is printed at the top of every page. For example, use the page header to repeat the report title on every page. Since the paging of a report strongly depends on the format it is rendered to, this section and its items are processed by the corresponding rendering extension after the report data has been processed. At this moment the report data source is not available anymore and you cannot add databound items directly to the Page Header section. Due to the same reason you can use the built-in PageNumber and PageCount objects (which contain the current page number and the total report pages count) only in this section. It is possible to suppress the printing of the Page Header section on the first and last page of a report.
  • Report Header - This section is printed just once, at the beginning of the report. Use the report header for information that might normally appear on a cover page, such as a logo, a title, or a date. In the Report Header section all data fields must be aggregated, even if the data source returns only one row. Typically you should use the FIRST() function for character and date data and the SUM() function for numeric data. When you place a databound report item that uses an aggregate function in the report header, it is calculated for the entire report data.
  • Group Header - This section is printed at the beginning of each new group of records. Use the group header to print the group name. For example, in a report that is grouped by product, use the group header to print the product name. In the Group Header section all data fields must be aggregated, even if the data source returns only one row. Typically you should use the FIRST() function for character and date data and SUM() function for numeric data. When you place a databound report item that uses an aggregate function in the Group Header, it is calculated for the entire group data.
  • Detail - This section is printed once for every row in the data source. This is where you place the report items that make up the main body of the report.
  • Group Footer - This section is printed at the end of each group of records. Use a group footer to print summary information for a group. Similar to the Group Header section, you should always use aggregate functions for the databound items that are calculated for the group data.
  • Report Footer - This section is printed just once, at the end of the report. Use the report footer to print report totals or other summary information for the entire report. Similar to the Report Header section, you should always use aggregate functions for the databound items that are calculated for the entire report data.
  • Page Footer - This section is printed at the end of every page. Use a page footer to print page numbers or per-page information. Similar to the Page Header Section you cannot use databound items, but can access the PageNumber and PageCount objects.

Page header/footer sections of reports used in SubReport items are ignored by our reporting engine by default - only the master report can have page sections. In order to have a header/footer that repeats on every page, you can consider using an unbound group (a group without any grouping criteria specified) and set its GroupHeader/FooterSection.PrintOnEveryPage = True.


Understanding Report Items

Telerik Reporting Q3 2008 Send comments on this topic.
Understanding Report Items
Designing Reports > Understanding Report Items

Glossary Item Box

Telerik Reporting supplies report item components that are placed in the report designer to build report content. The report items include:

Chart: The chart lets you display data in a visually compelling way. The chart can bind to live data and display in many popular chart types, e.g. Bar, Pie, Gantt, Line, Area, Bubble, etc.

Panel: The Panel report item is used to group multiple report items together.

PictureBox: The PictureBox allows you to place images in the report using bitmap files (e.g. bmp, gif, jpg, png, ico).

TextBox: The TextBox displays text in the report, can be styled to a specific visual appearance, can be configured to grow/shrink, formatted for specific data types (e.g. date time) and can be multi-line.

CheckBox: This report item displays a check mark (small picture) and a Text field (same as the text in TextBox). It can be styled to a specific visual appearance, can be configured to grow/shrink, the text can be formatted for specific data types (e.g. date time) and can be multi-line. The Check mark and Text can be aligned vertically and horizontally. There are three predefined check mark images, but they can be replaced with others.

BarCode: The Barcode report item is used for automatic barcode generation directly from a numeric or character data without need of any barcode font being installed in the end user’s PC.

Shape: The Shape item displays visual primitives in the report including ellipse, vertical/horizontal/slanting lines, and triangles.

SubReport: The SubReport report item lets you display one report within another report. This allows you to compose complex reports from disparate report sources.


Barcode

Telerik Reporting Q3 2008 Send comments on this topic.
Barcode
Designing Reports > Understanding Report Items > Barcode

Glossary Item Box

The Barcode report item is used for automatic barcode generation directly from a numeric or character data without need of any barcode font being installed in the end user’s PC. The screenshot below shows a Barcode report item on a report at design-time:

To customize the Barcode report item you can use the following properties:

Property

Description

Angle

Specifies the rotation in degrees of the barcode from its normal position.

BarAlign

Specifies the horizontal alignment of the actual barcode inside the Barcode report item area when the Stretch property is set to false.

Checksum

When set to true – specifies that the Barcode report item should automatically compute a checksum and append it to the end of the barcode.

When set to false – no such checksum is computed, and it is assumed that the checksum is provided by the application.

Location

Specifies the X and Y coordinates of the Barcode report item in report units.

Module

Specifies the width of the narrowest bar in the barcode in report units. The value of this property is ignored when the Stretch property is set to true.

ShowText

Specifies whether to show a text representation of the barcode in the report item.

Size

Specifies the Width and Height properties of the Barcode report item.

Stretch

When set to true – specifies that the barcode should be stretched to fill the entire area of the Barcode report item. The widths of the bars and spaces are adjusted accordingly. This setting is useful for fixed-length barcodes only.

When set to false – specifies that the barcode should not be stretched and the widths of the bars and spaces are computed according to the Module property.

Style

Specifies the embedded style information for this Barcode.

StyleName

Specifies the name of a style to be used in formatting this Barcode.

Symbology

Specifies the symbology used to encode the character data of the barcode as series of bars and spaces.

Value

Specifies the data to be displayed in this barcode. This can be either a hard coded text string or an expression.

Visible

Set to False to suppress the display of the Barcode.

The following figure illustrates how the value of the BarAlign property affects the appearance of the Barcode report item when Stretch is set to false:

When the ShowText property is set to true, the placement of the text around the barcode can be controlled by the TextAlign and VerticalAlign properties of the Style property. The figure below shows different combinations of values for the TextAlign and VerticalAlign properties and how they affect the final appearance of the Barcode report item.

Symbology Specifications

BarCode | Description
Codabar | (aka Ames Code/USD-4/NW-7/2 of 7 Code): Used in libraries and blood banks
Code 11 | (USD-8): Used to identify telecommunications equipment
Code 25 Standard | Used in airline ticket marking, photofinishing
Code 25 Interleaved | Used in warehouse, industrial applications
Code 39 | (aka USD-3, 3 of 9): U.S. Government and military use, required for DoD applications
Code 39 Extended | (aka USD-3, 3 of 9): U.S. Government and military use, required for DoD applications, supports full ASCII
Code 93 | (aka USS-93): Compressed form of Code 39
Code 93 Extended | (aka USS-93): Compressed form of Code 39, supports full ASCII
Code 128 | Very dense code, used extensively worldwide
Code 128 A | Subset of Code 128
Code 128 B | Subset of Code 128
Code 128 C | Subset of Code 128
MSI | Variation of Plessey code, with similar applications
EAN 8 | Short version of EAN-13, 8 characters
EAN 13 | Used with consumer products internationally, 13 characters
EAN 128 | Used to encode shipping/product information
Postnet | Printed by U.S. Post Office on envelopes
UPC A | Used with consumer products in U.S., 12 characters
UPC E | Short version of UPC symbol, 6 characters
UPC Supplement 2 | Used to indicate magazines and newspaper issue numbers
UPC Supplement 5 | Used to mark suggested retail price of books


Checkbox

Telerik Reporting Q3 2008 Send comments on this topic.
Checkbox
Designing Reports > Understanding Report Items > Checkbox

Glossary Item Box

CheckBox

The CheckBox report item is used to display both a text and a check mark on a report. This screenshot shows a CheckBox report item with CheckAlign property set to TopCenter and text aligned to Top and left.

To customize a TextBox report item, you can use the following properties:

Property | Description
Anchor | Defines the edges of the container to which a CheckBox is bound. When a CheckBox is anchored to an edge, the distance between its closest edge and the specified edge will remain constant.
Angle | The angle used for drawing the text.
CanGrow | Set to True to make the CheckBox automatically grow to accommodate longer text than can fit in the designed size.
CanShrink | Set to True to make the CheckBox automatically shrink if the text does not fill the designed size.
CheckAlign | The alignment of the check mark on the CheckBox’s surface.
CheckedImage | An Image to be shown if the Value property is evaluated to the Checked state.
ConditionalFormatting | A collection containing rules and formatting to be applied to this report item if the rules succeed. Clicking the property editor ellipses for this property displays the Conditional Formatting Rules Dialog.
Culture | Gets or sets the culture information associated with the CheckBox.
Dock | Defines which borders of the CheckBox are bound to the container.
FalseValue | A specific value to check against for the Unchecked state.
Format | A standard .NET format string to be applied to the contents of the CheckBox.
IndeterminateImage | An Image to be shown if the Value property is evaluated to the Indeterminate state.
IndeterminateValue | A specific value to check against for the Indeterminate state.
Location | Specifies the X and Y coordinates of the report item.
MultiLine | Set to True to use carriage returns in the content of the CheckBox’s Text property to split the text into multiple lines.
Size | Specifies the Width and Height properties of the report item.
Style | Embedded style information for this CheckBox.
StyleName | The name of a style to be used in formatting this CheckBox.
Text |
TextWrap | If this Boolean is set to True the content of the CheckBox is automatically wrapped. This occurs when the content is too wide to be displayed on a single line.
TrueValue | A specific value to check against for the Checked state.
UncheckedImage | An Image to be shown if the Value property is evaluated to the Unchecked state.
Value | Represents the image to be displayed as Check Mark. This can be initialized with an expression.
Visible | Set to False to suppress the display of the CheckBox.

A view where each CheckBox is initialized with CheckAlign variing from TopLeft to BottomRight:

An implementation of the CheckBox item you can find in the EventsReport sample report.

The check mark image depends on the value of the Value property. At design time the Value property can be initialized with an expression which later at runtime is evaluated to one of the System.Windows.Forms.CheckState values.


Panel

Telerik Reporting Q3 2008 Send comments on this topic.
Panel
See Also
Designing Reports > Understanding Report Items > Panel

Glossary Item Box

The Panel report item is used to group multiple report items together. You can set properties such as Visible on the Panel to affect all of the report items hosted in that Panel. The screenshot shows a Panel containing two TextBox report items.

To customize a Panel report item, you can use the following properties:

Property | Description
Style | Embedded style information for this Panel.
StyleName | The name of a style to be used in formatting this Panel.
Visible | Set to False to suppress the display of the Panel.
ConditionalFormatting | A collection containing rules and formatting to be applied to this report item if the rules succeed. Clicking the property editor ellipses for this property displays the Conditional Formatting Rules Dialog.
Location | Specifies the X and Y coordinates of the report item.
Size | Specifies the Width and Height properties of the report item.

See Also

Using Styles to Customize Reports
Panel Class


PictureBox

Telerik Reporting Q3 2008 Send comments on this topic.
PictureBox
See Also
Designing Reports > Understanding Report Items > PictureBox

Glossary Item Box

The PictureBox report item is used to display images on a report. This screenshot shows a PictureBox report item on a report at design-time.

To customize a PictureBox report item, you can use the following properties:

Property | Description
ConditionalFormatting | A collection containing rules and formatting to be applied to this report item if the rules succeed. Clicking the property editor ellipses for this property displays the Conditional Formatting Rules Dialog.
Location | Specifies the X and Y coordinates of the report item.
MimeType | The MIME type of this PictureBox's image.
Size | Specifies the Width and Height properties of the report item.
Sizing | Constant indicating how the image should be sized if it is not the same size as the PictureBox control.
Style | Embedded style information for this PictureBox.
StyleName | The name of a style to be used in formatting this PictureBox.
Value

Value can be an expression that contains binary image data or it can be a URI (local path or Url). When a Value property is assigned a string that is not an expression (doesn't start with "=") the value is assumed to be a URI.

Click the ellipsis for this property to browse for an image file on your hard drive. Supported file types are *.bmp, *.gif, *.jpg, *.png and *.ico.

Visible | Set to False to suppress the display of the PictureBox.

Sizing Property modes:

Name | Description
AutoSize | The picturebox item size is adjusted to that of the image it contains.
Center | The image is displayed in the center of the picturebox item. If the image is larger than the picturebox item, the outside edges are clipped.
Normal | The image is placed in the upper-left corner of the picturebox item. The image is clipped if it's larger than the picturebox item which contains it.
Stretch | The image within the picturebox item is stretched or shrunk as appropriate to fit the size of the picturebox item.
ScaleProportional | The image is sized proportionally (without clipping), so that it's best fitted to the picturebox item. If the height and width ratio of the picturebox item is the same as the image's ratio it will be resized to exactly fit into the picturebox item. Otherwise the closest fitting side (height or width) of the image will be sized to the item and the other side (height or width) of the image sized proportionally (leaving empty space).

Data Binding

The type of the PictureBox.Value property is Object which allows for versatile data binding. The Value property accepts objects of type Image and strings.

Binding to a Binary Image

You can directly assign a reference to an Image to the Value property of a PictureBox:

[C#] Binding to a System.Drawing.Image Copy Code
using System.Drawing;

Image image1 = Image.FromFile(@"C:\MyPictures\MyPicture.jpg");
this.pictureBox1.Value = image1;

Image image2 = Image.FromStream(imageStream);
this.pictureBox2.Value = image2;
[VB] Binding to a System.Drawing.Image Copy Code
Imports System.Drawing

Dim image1 As Image = Image.FromFile("C:\MyPictures\MyPicture.jpg")
Me.PictureBox1.Value = image1

Dim image2 As Image = Image.FromStream(imageStream)
Me.PictureBox2.Value = image2

In fact, the Telerik Reporting Designer also relies on this method for storing a report's images. While in design-time, if you click the ellipsis of the Value property of a selected PictureBox, you will be presented with a dialog to choose the desired image. After you have selected the image, the Designer will automatically store it in the resources file for the report (.resx) and add a line of code to the InitializeComponent method that obtains a reference to the image stored in the resources and assigns it to the Value property of the PictureBox:

Designer Generated Code Copy Code
this.pictureBox1.Value = ((object)(resources.GetObject("pictureBox1.Value")));

Of course, all of this happens automatically and behind the scenes so the user does not have to worry about it.

Binding to Expression/URI

Alternatively you can assign a string value to the Value property of a PictureBox. This string value can be either an item binding expression or an URI. Both absolute and relative URIs are supported. When binding to a data field with an expression, the Value property will accept both binary and string data fields. In other words, your data source column may store the image directly or store an URI pointing to the image:

[C#] Binding to Expression/URI Copy Code
this.pictureBox1.Value = "=Fields.MyImageBinary";//a binary data column
this.pictureBox2.Value = "=Fields.MyImageURI";//a data column containing an URI
this.pictureBox3.Value = @"C:\MyPictures\MyPicture.png";//absolute file path
this.pictureBox4.Value = @".\images\MyPicture.png";//relative file path
this.pictureBox5.Value = "http://www.mysite.com/images/img1.gif";//absolute URL
this.pictureBox6.Value = "/images/img1.gif";//relative URL
[VB] Binding to Expression/URI Copy Code
Me.PictureBox1.Value = "=Fields.MyImageBinary" 'a binary data column
Me.PictureBox2.Value = "=Fields.MyImageURI" 'a data column containing an URI
Me.PictureBox3.Value = "C:\MyPictures\MyPicture.png" 'absolute file path
Me.PictureBox4.Value = ".\images\MyPicture.png" 'relative file path
Me.PictureBox5.Value = "http://www.mysite.com/images/img1.gif" 'absolute URL
Me.PictureBox6.Value = "/images/img1.gif" 'relative URL

See Also

Using Styles to Customize Reports
Using Expressions
PictureBox Class


Shape

Telerik Reporting Q3 2008 Send comments on this topic.
Shape
See Also
Designing Reports > Understanding Report Items > Shape

Glossary Item Box

The Shape report item is used to display one of a selection of predefined shapes on a report. This screenshot shows a Shape report item on a report at design-time.

To customize a Shape report item, you can use the following properties:

Property | Description
Angle | The rotation in degrees of the shape from its normal position.
ShapeType | The particular shape to draw. Can be Ellipse, Vertical Line, Horizontal Line, Slant Line, Backslant Line and Triangle.
Stretch | Set to True if the shape should be stretched to fill the Shape control, and False if it should be drawn centered in the Shape control.
Style | Embedded style information for this Shape.
StyleName | The name of a style to be used in formatting this Shape.
Visible | Set to False to suppress the display of the Shape.
Location | Specifies the X and Y coordinates of the report item.
Size | Specifies the Width and Height properties of the report item.
Parameters | This collection is used to specify the ReportParameters property of the report being shown (i.e. the report specified in the ReportSource property).

See Also

Using Styles to Customize Reports
Shape Class


SubReport

Telerik Reporting Q3 2008 Send comments on this topic.
SubReport
See Also
Designing Reports > Understanding Report Items > SubReport

Glossary Item Box

The SubReport report item lets you display one report within another report. The screen shot shows a SubReport report item at design-time. This allows you to compose complex reports from disparate report sources. The data for each sub report can be completely different. For example you could combine a product listing, a sales summary and a list of sales people each in their own sub reports, with each sub report getting data from a different source. You can also pass parameters to SubReports using the Edit Parameters collection edtior.

To customize a SubReport report item, you can use the following properties:

Property | Description
ReportSource | The type of report to display as a SubReport. Click in this property, and then click the ellipsis button to browse for a report type.
Visible | Set to False to suppress the display of the SubReport.
ConditionalFormatting | A collection containing rules and formatting to be applied to this report item if the rules succeed. Clicking the property editor ellipses for this property displays the Conditional Formatting Rules Dialog.
Location | Specifies the X and Y coordinates of the report item.
Size | Specifies the Width and Height properties of the report item.
Parameters | This collection is used to specify the ReportParameters property of the report being shown (i.e. the report specified in the ReportSource property).

Page header/footer sections of subreports are ignored by our reporting engine by default - only the master report can have page sections. In order to have a header/footer that repeats on every page, you can consider using an unbound group (a group without any grouping criteria specified) and set its GroupHeader/FooterSection.PrintOnEveryPage = True.

Passing Parameters to a SubReport

To pass parameters to a SubReport click the ellipses of the Parameters property. Each parameter consists of a Parameter Name and Parameter Value.

Click the New button to add a parameter. Assuming you have assigned the ReportSource property the Parameter Name drop down list will contain the names of parameters defined in the report. Select a Parameter Name from drop down list to choose the target for this parameter. Parameter Value takes a literal value, "<blank>" or select "<expression>" to invoke the Edit Expression dialog.

SubReport Height Issues

To remove blank vertical space in the detail section of a SubReport, set the Height of the SubReport.ReportSource DetailSection to the height of the tallest item. Sections can grow to accomodate their children but cannot shrink to hide empty space. If you want the detail section to shrink only at runtime you can set the Height property of the DetailSection in the report constructor. Place the Height property assignment code just after the IntializeComponent() method call.

See Also

SubReport Class


TextBox

Telerik Reporting Q3 2008 Send comments on this topic.
TextBox
See Also
Designing Reports > Understanding Report Items > TextBox

Glossary Item Box

The TextBox report item is used to display text on a report. This screenshot shows two TextBox report items.

The in-place editor for TextBox report items allows you to quickly enter text directly into the designer where the report item is rather than having to go look for a property in the Property Window. To activate the in-place editor, double-click the TextBox report item or select the report item and press F2. Once the in-place editor is activated:

  • CTRL-Enter creates a new line.
  • Enter accepts all changes.
  • Esc discards all changes.
  • Moving focus away from the TextBox also accepts all changes.

The screenshot below shows a TextBox with the in-place editor active.

In Place Editor

To customize a TextBox report item, you can use the following properties:

Property | Description
CanGrow | Set to True to make the TextBox automatically grow to accomodate longer text than can fit in the designed size.
CanShrink | Set to True to make the TextBox automatically shrink if the text does not fill the designed size.
ConditionalFormatting | A collection containing rules and formatting to be applied to this report item if the rules succeed. Clicking the property editor ellipses for this property displays the Conditional Formatting Rules Dialog.
Location | Specifies the X and Y coordinates of the report item.
Format | A standard .NET format string to be applied to the contents of the TextBox.
MultiLine | Set to True to use carriage returns in the contents of the TextBox to split the text into multiple lines when the TextBox is rendered.
Size | Specifies the Width and Height properties of the report item.
Style | Embedded style information for this TextBox.
StyleName | The name of a style to be used in formatting this TextBox.
TextWrap | A boolean that when set to True automatically wraps the contents of a TextBox. This occurs when the contents are too wide to be displayed on a single line.
Value | Specifies the data to be displayed in this TextBox. This can be a hard coded text string or an expression.
Visible | Set to False to suppress the display of the TextBox.

See Also

Using Styles to Customize Reports
TextBox Class


Spline Areas

Telerik Reporting Q3 2008 Send comments on this topic.
Spline Areas
Designing Reports > Understanding Report Items > Chart > Features > Spline Areas

Glossary Item Box

The new Spline Area Charts take the Spline chart a step further. Like the Spline, the Spline Area takes a limited set of known data points and interpolates the intervening values. Then the area defined by the spline curve is filled in. You define one or more series of chart items, set the chart type to SplineArea, SplineStackedArea or StackedSplineArea100 and Chart does the rest.

You can see how the same data is presented using the new chart types. SplineArea displays from the back to the front, starting with the first series. StackedSplineArea adds each area to the next without covering previous areas. StackedSplineArea100 shows each area as a percentage contributing to the whole of a category.

Spline Area Charts


Empty Values

Telerik Reporting Q3 2008 Send comments on this topic.
Empty Values
Designing Reports > Understanding Report Items > Chart > Features > Empty Values

Glossary Item Box

The Chart automatically approximates missing values between known data points, simply by setting the Empty property true on any chart series item. This works for bar, line and area based chart types. You also have complete control over the visual style of empty values. The empty value style can be articulated separately from the style for the main values.

Empty Values Approximation


Scale Breaks

Telerik Reporting Q3 2008 Send comments on this topic.
Scale Breaks
Designing Reports > Understanding Report Items > Chart > Features > Scale Breaks

Glossary Item Box

The ScaleBreaks feature allows you to "break off" large chunks of the axis so that graphs with large amplitude are easier to read. ScaleBreaks are available for both YAxis and YAxis2 of the plot area. You can tailor the maximum number of breaks, the minimum interval between data points before a break can occur, the visual size of the breaks and the visual style of the breaks.


Multi-Line Labels

Telerik Reporting Q3 2008 Send comments on this topic.
Multi-Line Labels
Designing Reports > Understanding Report Items > Chart > Features > Multi-Line Labels

Glossary Item Box

Labels in Chart can appear on multiple lines. The property editor for TextBlock.Text properties allows you to hit the enter key to start a new line. Press control-enter to accept the text and close the property editor.


Intelligent Labels

Telerik Reporting Q3 2008 Send comments on this topic.
Intelligent Labels
Designing Reports > Understanding Report Items > Chart > Features > Intelligent Labels

Glossary Item Box

For charts that have many data points or data points with values close to one another, labels tend to collide making readability a problem. The Intelligent Labels feature of Chart automatically re-aligns labels making each labeled value stand out clearly.


Strict Mode

Telerik Reporting Q3 2008 Send comments on this topic.
Strict Mode
Designing Reports > Understanding Report Items > Chart > Features > Strict Mode

Glossary Item Box

The Chart bar series now features "strict mode". This is not a property or setting, but a behavior of bar chart series where X values are respected and bars are positioned according to their XValues. If there are no series items with XValues then Chart resumes standard sequential ordering of each item. The screen shot above was produced using the following X and Y values:

Series 1

YValue | XValue
3 | 0
3 | 1
4 | 3
3 | 3
5 | 4

Series 2

YValue | XValue
1 | 5
2 | 4


Marked Zones

Telerik Reporting Q3 2008 Send comments on this topic.
Marked Zones
Designing Reports > Understanding Report Items > Chart > Features > Marked Zones

Glossary Item Box

PlotArea MarkedZones are ranges that can be labeled and filled to highlight areas of the chart or to visually group data. The MarkedZones property by default display behind the chart series. You can create any number of members for the MarkedZones collection and each marked zone is defined by a starting and ending X and Y value pairs. You can also control the labeling and appearance for each zone independently.

Chart with MarkedZones


Populate Chart Data
Designing Reports > Understanding Report Items > Chart > Chart Getting Started > Populate Chart Data

Glossary Item Box

Populate Chart Data

  1. Click the ellipses for the Chart Series Collection.
  2. Click "Series 1" in the members list on the left, then locate the Name property in the property window.
  3. Change the Name property to "Sales" and the DefaultLabelValue to "#ITEM". Name will be the series name that shows up in the legend. DefaultLabelValue will display the name of each item in the series instead of the item value.
  4. Locate the Items property in the property window.
  5. Click the ellipses button of the Items property to open the ChartSeriesItem Collection Editor.
  6. Click the Add button to add a new Item.
  7. In the property window for the new item, change the Name property to "Beverages".
  8. Change the YValue property to "10000".

Adding Chart Series Item Values and Labels

  10. Repeat the Add Item steps to add 3 new items.
  11. Replace the properties for the three new items as follows
    • Label=Produce, YValue =7500
    • Label=Poultry, YValue =9000
    • Label=Grains, YValue =11200
      12. Click OK to close the ChartSeriesItem Collection Editor.
      13. Click "Series 2" in the ChartSeries Collection Editor.
      14. Click the Remove button to remove Series 2.
      15. Click the OK button to close the ChartSeries Collection Editor.
      16. The chart will display the new data using the default formatting.


Format the Chart
Designing Reports > Understanding Report Items > Chart > Chart Getting Started > Format the Chart

Glossary Item Box

Format the Chart

  1. Invoke the Chart Wizard by selecting the Chart properties menu.
  2. Click the Axis Tab.
  3. Locate the Visual Properties section of the Axis tab.
  4. On the Select Axis drop down list select the X Axis. In the Axis Title entry enter "Product Categories". Un-check Show Ticks to remove the tick marks from the bottom of the chart.
  5. On the Select Axis drop down list select the Y Axis. Un-check Show Ticks to remove the tick marks on the left hand side of the chart.

Setting Axis Properties

  6. Click the Labels, Legend & Title tab
  7. Locate the Legend section.
  8. Uncheck the Visible check box. This will remove the Sales legend from the right side of the graph.

Setting Legend Properties

  9. On the Skins tab select the Deep Blue skin.

  10. Click the OK button to close the wizard.
  11. In the properties window, locate PlotArea.XAxis.AxisLabel.TextBlock.Visible and set it to "True".

Run the application to view the finished chart. It should look like the screen shot shown below.


Formatting the Chart

Telerik Reporting Q3 2008 Send comments on this topic.
Formatting the Chart
Designing Reports > Understanding Report Items > Chart > Chart Getting Started > Formatting the Chart

Glossary Item Box

  1. Open the Chart Wizard by selecting the Properties of the chart item. Select the Type tab and click the Horizontal Orientation radio button

  2. On the Chart Wizard Data tab Axis Labels choose the "SubCategory" from the X-Axis drop down.

  3. On the Chart Wizard Skin tab select the "Deep Blue" skin.

  4. On the Chart Wizard Labels, Legend & Title set the Legend Alignment to "Right" and Title Text to "Products".

  5. The X-Axis labels bound to the "SubCategory" column are too wide and will overflow. To make the plot area smaller to make room, set the PlotArea.Appearance.Dimensions.Margins.Left to "50%".

  6. The finished chart should look like the screenshot below.


Chart Types Overview

Telerik Reporting Q3 2008 Send comments on this topic.
Chart Types Overview
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Chart Types Overview

Glossary Item Box

There are 17 chart types:

Chart Type |  | Description | When to use
Bar | ImageTitle Click to Enlarge Click to Enlarge | Bar charts graphically display values in vertical and horizontal bars across categories. | Bar charts are useful for comparing multiple series of data (i.e. providing snapshots of data at particular points in time).
Stacked Bar | Click to Enlarge Click to Enlarge | Stacked Bar charts are used to compare contributions of values to a total across categories | Use the Stacked Bar chart when you need visibility to the combined values for each category.
Stacked Bar 100% | Click to Enlarge Click to Enlarge | Stacked Bar 100% shows the combined contribution of values as percentages where the combined total for each category is 100 percent. | Use when the relationship between values in a category is more significant than the amounts.
Pie | Click to Enlarge Click to Enlarge | The Pie chart shows slices representing fractional parts of a whole. | When you need to display the contribution of fractional parts to a whole.
Gantt | Click to Enlarge Click to Enlarge | Gantt charts, also known as Time charts, display separate events as bars along a time scale. | These charts are often used for project/time planning, where data can be plotted using a date-time scale or other numeric scale.
Bezier | Click to Enlarge Click to Enlarge | The Bezier chart displays a series of points on a curved line. Two "control points" determine the position and amount of curvature in the line between end points | The Bezier chart is often used for data modelling by taking a limited number of data points and interpolating or estimating the intervening values.
Spline | Click to Enlarge Click to Enlarge | Spline charts allow you to take a limited set of known data points and approximate intervening values. | The Spline chart, like the Bezier, is often used for data modelling by taking a limited number of data points and interpolating or estimating the intervening values.
Spline Area | Click to Enlarge Click to Enlarge | The Spline Area chart type defines one or more spline curves and fills in the area defined by the spline. | Also can be used for data modelling in that it takes a limited number of data points and interpolates the intervening values. This chart type also emphasizes the area between the spline curve and a mid-point of the spline.
Stacked Spline Area | Click to Enlarge Click to Enlarge | The Stacked Spline Area chart is a variation of the Spline Area chart. The areas are stacked so that each series adjoins but does not overlap the preceding series. | Also can be used for data modelling in that it takes a limited number of data points and interpolates the intervening values. This chart type allows the entire surface area for all sequences to be displayed at one time.
Stacked Spline Area 100% | Click to Enlarge Click to Enlarge | The Stacked Spline Area 100% chart is a variation of the Spline Area chart. The areas are stacked so that each series adjoins but does not overlap the preceding series and where the combined total for each category is 100 percent. | Also can be used for data modelling in that it takes a limited number of data points and interpolates the intervening values. This chart type allows the entire surface area for all sequences to be displayed at one time. Use this chart type when the relationship between values in a category is more significant than the amounts.
Point | Click to Enlarge Click to Enlarge | Point or "Scatter" charts are used to show correlations between two sets of values. | The Point chart is often used for scientific data modeling or financial data. Typically not used used with time dependent data where a Line chart is more suited.
Bubble | Click to Enlarge Click to Enlarge | The Bubble chart is an extension of the Point chart but each point can be a circle or oval of any size or dimension. The bubble size may be used to convey larger values. | The Bubble chart is often used for scientific data modeling or financial data.
Line | Click to Enlarge Click to Enlarge | This chart type displays a set of data points connected by a line. | A common use for the line chart is to show trends over a period of time.
Area | Click to Enlarge Click to Enlarge | The Area chart consists of a series of data points joined by a line and where the area below the line is filled | Area charts are appropriate for visualizing data that fluctuates over a period of time and can be useful for emphasizing trends.
Stacked Area | Click to Enlarge Click to Enlarge | The Stacked Area chart is a variation of the Area chart that display trends of the contribution of each value over time (or across categories). The areas are stacked so that each series adjoins but does not overlap the preceding series. | Area charts are appropriate for visualizing data that fluctuates over a period of time and where the entire area for all series data must be visible at one time.
Stacked Area 100% | Click to Enlarge Click to Enlarge | Stacked Areas 100% charts are a variation of Stacked Area charts that present values for trends as percentages, totaling to 100% for each category. | Use this chart type to visualize data that fluctuates over a period of time and where the relationship between values in a category is more significant than the amounts.
CandleStick | Click to Enlarge Click to Enlarge | The CandleStick chart combines bar and line chart styles to show a range of value movement over time. Dark colored bars show downward trends, light colored bars show upward trends and the line through the center (the "wick") shows the extreme high and low values. | Use this chart type to visualize price or currency fluctuations. Typically this chart is used to analyze stock prices or currency changes.


Bar Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Bar Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Bar Charts

Glossary Item Box

Bar charts graphically summarize and display categories of data and let the user easily compare amounts or values between different categories. Bar charts are useful for comparing multiple series of data (i.e. providing snapshots of data at particular points in time). In the examples below the categories are various sources for sales (Internet, Wholesale, Retail) that combine to make the total sales for each quarter. Chart automatically displays each series in a different color to make them easier to distinguish.

To create a Vertical Bar Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to Bar.

Vertical Bar Chart

To create a Horizontal Bar Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to Bar.

Horizontal Bar Chart


Stacked Bar Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Stacked Bar Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Stacked Bar Charts

Glossary Item Box

Stacked bar charts are used to compare contributions of values to a total across categories. In the examples below the categories are various sources for sales (Internet, Wholesale, Retail) that combine to make the total sales for each quarter. Use the Stacked Bar chart when you need visibility to the combined values for each category.

To create a Vertical Stacked Bar Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to StackedBar.

Vertical Stacked Bar Chart

To create a Horizontal Stacked Bar Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to StackedBar.

Horizontal Stacked Bar Chart

To display custom labeling on the X-Axis "Qtr 1", "Qtr 2", etc., set the Chart PlotArea.XAxis Autoscale property to False. Use the PlotArea.XAxis.Items property and for each item set the TextBlock Text property to the desired label.


Stacked Bar 100% Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Stacked Bar 100% Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Stacked Bar 100% Charts

Glossary Item Box

Stacked Bar 100 charts are used when you have three or more data series and want to compare distributions within categories, and at the same time display the differences between categories. Each bar represents 100% of the amounts for that category.

To create a Vertical Stacked Bar 100 Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to StackedBar100.

Vertical Stacked Bar 100 Chart

To create a Horizontal Stacked Bar Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to StackedBar100.

Horizontal Stacked 100 Chart

To display the label values as percentages, change the DefaultLabelValue for each chart series from "#Y" (the numeric value for each data point) to "#%" (the percentage of each data point to the category).


Pie Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Pie Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Pie Charts

Glossary Item Box

Pie charts are used to display the contribution of fractional parts to a whole. A Pie chart uses a single series of data. Multiple series of data can be defined and are each displayed in a separate pie chart.

You can tailor the look of each pie slice individually by working with the pie chart series Appearance property:

  • You can "explode" (i.e. offset) a single slice of the pie to emphasize a portion of the data by setting the pie chart series item Appearance.Exploded property to true.
  • The Appearance.FillStyle FillSettings property allows you to set the fill for each slice to Solid, Gradient, ComplexGradient, Hatch or Image. You also have control over gradients (colors, direction and angle), images (alignment, orientation), colors and shadows.
  • Control the label format and appearance for each slice using the pie chart series item Label property. The Label.TextBlock.Text can make use of built-in formats, such as "#Y" to show the values for the Y axis or "#%" to show the percentage value of a slice. The figure below uses a format similar to "Qtr 1 - #%".

To create a Pie chart set the Chart DefaultType property or ChartSeries.Type Pie.

Pie chart with a single series

Pie Chart with two series


Gantt Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Gantt Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Gantt Charts

Glossary Item Box

Gantt charts help visualize time based information. Gantt charts, also known as Time charts, display separate events, with a beginning and an end. These charts are often used for project/time planning, where data can be plotted using a date-time scale or a numerical scale.

To create a vertical Gantt Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to Gantt.

To create a horizontal Gantt Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to Gantt.

Horizontal Gantt Chart

Other Gantt chart issues:

  • To add dates to an axis or chart item, values must be converted to OleAutomation types. Use the DateTime ToOADate() function for this purpose.
  • When setting a range for an axis that involves dates, set the axis IsZeroBased property to zero. This avoids having the range calculated from the minimum date value forward, instead of a range you define.
  • Use the ValueFormat property to display values as dates.


Bezier Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Bezier Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Bezier Charts

Glossary Item Box

The Bezier chart is often used for modelling data by interpolating data points, through which curved lines pass.

To draw a Bezier chart series you add (1 + 3 x N) items to a series. So you can have 4 data points or 7, 10, 13, etc. The simplest set of data would be 4 data points: two end points and two "control points" that control the position and amount of curvature in the line between the two end points. See the figures below for examples. Each of the data points must have a X and Y value.

To create a simple vertical Bezier Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to Bezier. Create a series and add four chart items with X and Y values.

The second chart series labeled "Data Points" is included to emphasize the location of the end and control points in the Bezier series.

Horizontal Bezier Chart

To create a simple horizontal Bezier Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to Bezier. Create a series and add four chart items with X and Y values.

YValue | XValue
20 | 50
20 | 100
80 | 100
80 | 50

Another Bezier chart with control points placed evenly

YValue | XValue
20 | 50
50 | 100
80 | 100
80 | 50

Bezier chart with control points placed asymetrically


Spline Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Spline Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Spline Charts

Glossary Item Box

Spline charts allow you to take a limited set of known data points and approximate intervening values. In practice you define a series of chart items with X/Y values and Chart does the rest.

To create a simple vertical Spline Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to Spline. Create a series and add chart items with Y or X and Y values.

Vertical Spline Chart

To create a simple horizontal Spline Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to Spline. Create a series and add 3 or more chart items with X and Y values.

YValue | XValue
20 | 50
50 | -10
70 | 100
80 | 50

Horizontal Spline Chart

Another example showing the same Y data points as above, but with no X values defined displays an automatic even progression over the X axis.

YValue
20
50
70
80

Spline chart with only Y values defined


Bubble Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Bubble Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Bubble Charts

Glossary Item Box

The Bubble chart is an extension of the Point chart but each point can be a circle or oval of any size or dimension. Instead of using just the XValue and YValue, the Bubble chart uses XValue/XValue2, and YValue/YValue2 pairs to define the dimensions of each bubble. Bubble charts are commonly used to display financial information where the size of the bubble can be proportionate to the data values.

To change the size of all bubbles in a series, but to not distort the dimensions of the bubble, assign the Series.Appearance.BubbleSize property.

To create a vertical Bubble Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Bubble. Add one or more chart series to the Series collection. Add one or more chart items to the series Items collection. Populate numeric values for XValue, XValue2, YValue and YValue2 properties of each chart series item.

Vertical Bubble Chart

To create a horizontal Bubble Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Bubble. Add one or more chart series to the Series collection. Add one or more chart items to the series Items collection. Populate numeric values for XValue, XValue2, YValue and YValue2 properties of each chart series item.

Horizontal Bubble Chart


Point Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Point Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Point Charts

Glossary Item Box

Point or "Scatter" charts are used to show correlations between two sets of values. The point chart lets you observe the dependence of one value to another and is often used for scientific data modeling. The Point chart is typically not used used with time dependent data where a Line chart is more suited.

To change the display of any given point use the chart item's PointAppearance property. Here you can change the Dimensions property to control Height, Width, Margins and Paddings. The Figure property lets you choose from a set of predefined shapes other than the default Ellipse shape (e.g. Cross, Diamond, Circle, Rectangle, Triangle and several different Star marker shapes).

To create a Vertical Point Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to Point. Add one or more chart series to the Series collection. Add one or more chart items to the series Items collection. Populate numeric values for XValue and YValue properties of each chart series item.

Vertical Point Chart

To create a Horizontal Point Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to Point. Add one or more chart series to the Series collection. Add one or more chart items to the series Items collection. Populate numeric values for XValue and YValue properties of each chart series item.

Horizontal Point Chart


Spline Area Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Spline Area Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Spline Area Charts

Glossary Item Box

Spline charts allow you to take a limited set of known data points and approximate intervening values. In the Spline Area Chart the area defined by the spline curve is filled. In practice you define a series of chart items and Chart does the rest. Each series overlays the preceding, from back to front.

To create a simple vertical Spline Area Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to SplineArea. Create one or more series and add chart items with Y or X and Y values.

Veritical Spline Area Chart

To create a simple horizontal Spline Area Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to SplineArea. Create a series and add chart items with Y or X and Y values.

Horizontal Spline Area Chart


Stacked Spline Area Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Stacked Spline Area Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Stacked Spline Area Charts

Glossary Item Box

The Stacked Spline Area chart is a variation of the Spline Area chart. The areas are stacked so that each series adjoins but does not overlap the preceding series. This contrasts with the Stacked Area chart where each series overlays the preceding series.

To create a simple vertical Stacked Spline Area Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to StackedSplineArea. Create multiple chart series and add chart items with Y or X and Y values

To create a simple horizontal Stacked Spline Area Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to StackedSplineArea. Create multiple chart series and add chart items with Y or X and Y values

Horizontal Stacked Spline Area Chart


Stacked Spline Area 100% Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Stacked Spline Area 100% Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Stacked Spline Area 100% Charts

Glossary Item Box

The Stacked Spline Area 100% chart is a variation of the Spline Area chart. The areas are stacked so that each series adjoins but does not overlap the preceding series. This chart displays contributions for each data point to the category as a percentage.

To create a vertical Stacked Spline Area Chart 100% chart, set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to StackedSplineArea100.

To create a horizontal Stacked Spline Area Chart 100% chart, set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to StackedSplineArea100.

Vertical Stacked Spline Area 100% Chart

To display the label values as percentages, change the DefaultLabelValue for each chart series from "#Y" (the numeric value for each data point) to "#%" (the percentage of each data point to the category).


Line Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Line Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Line Charts

Glossary Item Box

Line charts are used to display a series of data points, typically to show trends over a period of time. One or more series of data can be used and the appearance for each series can be tailored to emphasize the data using unique colors, line thicknesses, shadow, pen style, and point marks.

To create a Vertical Line Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to Line.

Vertical Line Chart

To create a Horizontal Line Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to Line.

Horizontal Line Chart


Area Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Area Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Area Charts

Glossary Item Box

The Area chart consists of a series of data points joined by a line and where the area below the line is filled. Area charts are appropriate for visualizing data that fluctuates over a period of time and can be useful for emphasizing trends. Note: Values that don't vary too wildly work best for area charts.

Area charts display series in the order they are added, back-to-front. Depending on the Skin used, the chart can automatically differentiate each series by displaying it in a different color. The appearance for each series can also be modified directly.

To create a Vertical Area Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to Area.

Vertical Area Chart

To create a Horizontal Area Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to Area.

Horizontal Area Chart


Stacked Area Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Stacked Area Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Stacked Area Charts

Glossary Item Box

The Stacked Area chart is a variation of the Area chart that display trends of the contribution of each value over time (or across categories). The areas are stacked so that each series adjoins but does not overlap the preceding series. This contrasts with the Area chart where each series overlays the preceding series.

Depending on the Skin used, the chart can automatically differentiate each series by displaying it in a different color. The appearance for each series can also be modified directly.

To create a Vertical Stacked Area Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to StackedArea.

Vertical Stacked Area Chart

To create a Horizontal Stacked Area Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to Area.

Horizontal Stacked Area Chart


Stacked Area 100% Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Stacked Area 100% Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > Stacked Area 100% Charts

Glossary Item Box

Stacked Areas 100% charts are a variation of Stacked Area charts that present values for trends as percentages, totaling to 100% for each category

To create a Vertical Stacked Area 100% Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to StackedArea100.

Vertical Stacked Area 100% Chart

To create a Horizontal Stacked Area 100% Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to StackedArea100.

Horizontal Stacked Area 100% Chart

To display the label values as percentages, change the DefaultLabelValue for each chart series from "#Y" (the numeric value for each data point) to "#%" (the percentage of each data point to the category).


CandleStick Charts

Telerik Reporting Q3 2008 Send comments on this topic.
CandleStick Charts
Designing Reports > Understanding Report Items > Chart > Understanding Chart Types > CandleStick Charts

Glossary Item Box

The CandleStick chart combines bar and line chart styles to show a range of value movement over time. A filled bar indicates the opening value was greater than the closing value. An empty bar indicates that the closing value was greater than the opening value. The line through the center (the "wick") shows the extreme high and low values. The meaning of the Y values in a CandleStick chart are:

  • YValue = Open
  • YValue2 = Close
  • YValue 3 = Max
  • YValue 4 = Min

The "bar" portion of each chart item is formed between the YValue and YValue2 properties. The "wick" portion of the chart is defined with the YValue3 and YValue4 chart item properties.

To create a Vertical CandleStick Chart set the SeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type to CandleStick.

CandleStick Chart Type

To create a Horizontal CandleStick Chart set the SeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type to CandleStick.

Horizontal CandleStick Chart

The screenshots above use the following data points:

YValue | YValue2 | YValue3 | YValue4
6 | 7.1 | 4.5 | 8
5.5 | 7.7 | 3 | 6
21 | 9 | 8 | 23
5.5 | 6.5 | 4 | 6.5
6 | 4.5 | 3 | 7


Chart Basics

Telerik Reporting Q3 2008 Send comments on this topic.
Chart Basics
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > Chart Basics

Glossary Item Box

Charts are composed of a hierarchy of elements. Most of the elements are common across all chart types (unless otherwise noted). The illustration below shows some of the significant chart elements.

Chart Element Descriptions

Title | The heading for the chart as a whole. The position and appearance of the title is completely customizable. Read More | Legend | The legend contains a symbol and name for each series in the chart. The legend may also display a series of items. The position and appearance of the legend can also be customized. Read more
Axis Item | Axis Items are the individual points along each axis that help indicate the axis measurement and scale. Read more | Grid Lines | Vertical and horizontal lines parrallel to the X and Y axes. These grid lines form the grid, making the chart easier to read. Read more
Point Mark | The point mark is a visual cue to enhance visibility of data points on line and area charts. Read more | Chart Series | Series contains a set of data points to be drawn on the chart. This set of points contains related data. Each series can be represented by a chart type. Pie charts use only a single series. For other chart types there is no limitation to the number of series or items within each series. Read more
Item Label | The label next to each data point displaying a value or custom text. Read more | Margins | The distance between the outer edge of an item to the outer edge of the item containing it. For example, the margin for the plot area is the distance from the plot area border to the outermost border of the chart. Plot area, legend and title all have margins. Read more
Axis Label | The label next to each axis identifying the nature of data points found along that axis. Read more | Plot Area | The area enclosed between the X and Y axes. Read more
Ticks | Axis ticks are small marks that identify the position of items on the axes and the starting points of gridlines. Read more | Plot Area Border | The line that encloses the area between the X and Y axes. Read more
Axis (X and Y) | These axes form the coordinates in which the data points are placed. Chart series items are displayed along the X and Y axes. Note: Pie charts do not use axes. Read more | Background Border | The outermost line that encloses the whole chart area. Read more
Exploded Pie | A piece of the a Pie chart that is visually separated from the rest of the pie for easier distinction. Read more |  |


Background and Plot Areas

Telerik Reporting Q3 2008 Send comments on this topic.
Background and Plot Areas
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > Background and Plot Areas

Glossary Item Box

Chart Background

The background of the chart is the outermost rectangle that encloses all other elements of the chart. It stretches for the whole width and length of the output image of the chart. Using the Appearance property of the chart you can fully customize the chart background look and feel including:

  • Border visibility, color, pen style and width.
  • The Corners property lets you square or round each corner individually. The degree of rounding can be tailored.
  • FillStyle controls the fill color and type (solid, hatched, image, gradient).
  • ImageQuality and TextQuality properties can also be fine tuned.

Plot Area

The plot area is the working rectangular area between X and Y axes where data is displayed. The size of the plot depends on the chart background size and the chart margins, which define the distance between the border of the plot area and the border of the chart background. This area is represented by the Chart PlotArea property. Some unique PlotArea properties are:

  • SeriesOrientation is an enumeration that orients the entire PlotArea either Vertical or Horizontal.
  • XAxis, YAxis, and YAxis2 properties. These axis properties control the scale and appearance of both axes. See the Axes topic for more information.
  • DataTable: Displays a spreadsheet style table of the data in the chart, typically just below the chart itself. See the DataTable topic for more information.
  • EmptySeriesMessage: The predefined message that displays in the PlotArea when there is no series data defined for the chart.

  • MarkedZones: Areas in the background of the chart that can be defined, labeled and filled. MarkedZones are used to highlight or group areas on the chart.

RadChart Background and Plot Area

Like the chart as a whole, PlotArea has an Appearance property allowing customization:

  • Border visibility, color, pen style and width.
  • The Corners property lets you square or round each corner individually. The degree of rounding can be tailored.
  • FillStyle controls the fill color and type (solid, hatched, image, gradient).
  • The Dimensions property provides control of Width, Height, Margins, Paddings and if you want the dimensions to Autosize .
  • SeriesPalette is a property of the chart that lets you to choose a predefined skin color palette for each series. This can help provide a distinct look to differentiate each series.
  • The Shadow property lets you control shadow Blur, shadow Color, shadow Distance and Position relative to the plot area.


Axes

Telerik Reporting Q3 2008 Send comments on this topic.
Axes
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > Axes

Glossary Item Box

X and Y axes are included in all chart types but the Pie chart. Typically the YAxis displays values and the XAxis displays categories. For example, the YAxis might show "items sold" or "revenue", while the XAxis might show "Months" or "Products". The X axis can also display values. A second "Y" axis property YAxis2 is provided for displaying a second scale of measurements.

XAxis, YAxis and YAxis2

Axis Elements

Each axis has:

  • Grid lines display perpendicular to the axis covering the plot area.
  • Axis line
  • Axis label
  • Axis marks along the axis line
  • Item labels below the axis line

The example below shows a sample X-axis with several appearance related properties customized.

The Chart PlotArea property has sub properties XAxis, YAxis and YAxis2. Each axis object has an Appearance property used to make the customizations shown above. Some significant axis appearance related properties are:

  • The LabelAppearance property includes sub properties that control the axis label visibility, Border, Corners, Dimensions, FillStyle, Position and Shadow.
  • MajorGridlines controls the appearance of grid lines displaying over the plot area including visibility, Cap, Color, PenStyle and Width.
  • TextAppearance handles the axis item label text, most notably TextAppearance.TextProperties controls font properties and color.
Axis properties can be set from the Properties Window of Visual Studio, in the XML configuration file, or through the API. Properties for the X and Y axis are identical except where noted.

Formatting Axis

You can modify the overall appearance of an axes by changing the AutoScale and AutoShrink properties. These properties when set to true cause the axis to expand and shrink to accommodate dynamically added and removed items. This is useful when the number of items changes on-the-fly.

Turn AutoScale off if you want complete control over labeling of an axis.

Formatting Axis Labels

To display a range of values along an axis, specify for the ChartAxis a starting MinValue, an ending MaxValue, and a Step. In the example above, the YAxis has a MinValue of "0", a MaxValue of "250" and a Step of "50." The X axis is labeled explicitly by setting PlotArea.XAxis properties:

  • AutoScale = False
  • MaxValue = 3
  • MinValue = 1
  • Step = 1
  • Visible = True
  • Items is populated with with 3 ChartAxisItem objects where the Appearance.Text property contains "Non-Smokers", "Social Smokers" and "Heavy Smokers".

You can control the size and position of the labels using the axis Appearance.LabelAppearance Dimensions and Position properties.

X-Axis Properties Used in Data Binding

DataLabelsColumn: This is the name of a data source column that will supply the text that displays next to each X Axis item.

Unique YAxis and YAxis2 Properties

AxisMode: AxisMode can be Normal (the default) or Extended. Extended mode provides buffer space above the largest value for best visual formatting.

ScaleBreaks: The ScaleBreaks feature allows you to "break off" large chunks of the axis so that graphs with large amplitude are easier to read. ScaleBreaks are available for both YAxis and YAxis2 of the plot area. By default Enabled is false so scale breaks do not display. Set the maximum number of breaks using MaxBreaks and MinCollapsibleSpace to set the minimum interval between data points before a break will occur. For the lines that make up each break, Spacing controls the amount of space between lines and LineType controls the shape of the line (i.e. Sinusoid, Straight, JaggedCurve and Curve).


Axis Labels

Telerik Reporting Q3 2008 Send comments on this topic.
Axis Labels
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > Axis Labels

Glossary Item Box

Labels are displayed for each:

  • Chart axis to describe the category of values along the axis. For example "Products", "Risk Factors", time periods or geographic areas.
  • Chart axis item to describe the specific value or category for that item.

Formatting Axis Labels

  • To format the chart axis label use the PlotArea.<axis>.AxisLabel to access Appearance and TextBlock properties
  • To set the formatting for all labels on an axis use the PlotArea.<axis>.Appearance LabelAppearance and TextAppearance properties.
  • To format a label for a specific chart axis item use the PlotArea.<axis>.Items[].Appearance property.

Use the MinValue and MaxValue properties to specify the minimum and maximum values for the data to display. The MinValue property allows you to specify either negative or positive number as the minimum value. In the example below the MinValue = -50, MaxValue = 50 and Step = 10.

Formatted Y-Axis Labels

The PlotArea..Appearance.ValueFormat property automatically formats axis label values as Currency, Scientific, General, Number, Percent, ShortDate, ShortTime, LongDate, LongTime or None.

Positioning Axis Labels

You can specify the horizontal and vertical alignment of axis labels and axis item labels using the Appearance.Position property of the axis label or chart axis item respectively. Position has sub properties for AlignedPosition, Auto, X and Y.

Use AlignedPosition to automatically place the label Right, Left, Top, Center, TopRight, TopLeft, BottomRight or BottomLeft.

Use the RotationAngle property to spin axis and axis item labels to any angle. In the example below the XAxis.Appearance.LabelAppearance.RotationAngle is set to 45.

By turning off the Position.Auto property and setting Position.AlignedPosition to None you can place the axis label any where in the plot area. In the example below the PlotArea.YAxis.AxisLabel.Appearance.Position property is configured such that:

  • AlignedPosition = None
  • Auto = False
  • X = 120
  • Y = 200

The YAxis.AxisLabel.Appearance.RotationAngle = 325.

This isn't a recommended or usual approach but serves to illustrate the flexibility of the object model.

Also in the example below, the PlotArea.XAxis.AutoScale is turned off so the PlotArea.XAxis.Items collection could be populated manually. Each ChartAxisItem has its TextBlock.Text property populated with the strings "Non-Smokers", "Social Smokers" and "Heavy Smokers".


Gridlines

Telerik Reporting Q3 2008 Send comments on this topic.
Gridlines
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > Gridlines

Glossary Item Box

Gridlines are auxiliary lines that form a grid for easier reading of the chart. Gridlines can be vertical or horizontal. Vertical gridlines are controlled by the XAxis and horizontal gridlines are controlled by YAxis and YAxis2. Gridlines can be "major", e.g. falling on the labeled axis Step values. "Minor" gridlines appear for YAxis and YAxis2 that fall between Step values. See the figure below where major gridlines fall on 20 and 40 of the YAxis and minor gridlines fall between the major gridlines.

To control the visibility and general appearance of gridlines use the the PlotArea.<axis>.Appearance property to reach MajorGridLines and MinorGridlines properties. XAxis has only MajorGridLines while YAxis and YAxis2 have both MajorGridLines and MinorGridlines properties. Both major and minor gridline objects include the following properties:

  • Visible
  • Color
  • PenStyle (Solid, Dash, Dot, DashDot, DashDotDot and Custom)
  • Width

In the example below both X axis and Y axis are visible. XAxis MajorGridLines are red solid lines 3 pixels wide. YAxis MinorGridlines are shown as blue dotted lines 2 pixels wide and YAxis MajorGridLines are shown as blue solid lines 3 pixels wide.

Major and Minor Gridlines


Legends

Telerik Reporting Q3 2008 Send comments on this topic.
Legends
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > Legends

Glossary Item Box

Legends are symbols and text used to provide additional information about the chart. In a multiple series chart the legend typically describes each series to improve readability. By default Chart includes the color and name of each chart series in the legend. You can also define your own legend and control the style for the legend or each item in the legend using the Chart Legend property. Legend holds properties for:

  • Visible : If a legend is not relevant to your chart you can set this false to hide the legend.
  • Appearance : This property controls the visual style of the legend as a whole including Dimensions, Position, FillStyle, ItemAppearance, ItemMarkerAppearance, ItemTextAppearance, RotationAngle and Shadow.
  • Items: A collection containing the individual legend text and symbols for each series. Add to this collection to create your own custom legends.
  • Marker: A visual marker for the legend as a whole. Use the marker Appearance property to control properties like FillStyle, Dimensions and Position . To assign an image to the marker use the marker Appearance.FillStyle property to set FillType to Image and FillSettings.BackgroundImage to the path of the image.
  • TextBlock : Use TextBlock to control the default text and appearance.

Formatting Legends

Use the legend Appearance ItemTextAppearance property to tailor the look of all legend item text at one time and the ItemMarkerAppearance to format all of the legend markers. Particularly note the CompositionType property that handles the display order of text vs. images where valid values are ColumnImageText, ColumnTextImage, RowImageText (the default) and RowTextImage. "Column" values show the text and image one above the other. "Row" shows text and image side-by-side.

Use the ItemMarkerAppearance Figure property to select from a set of predefined marker shapes.

Use the Legend.Appearance.Position property to control where the legend should appear on the chart surface. The AlignedPosition sub property automatically places the legend in a predefined position. Or set the Auto property false and manually set the X and Y properties to place the legend in any exact position.

Use the Legend.Appearance.Dimensions property to control the legend height and width. By default the AutoSize sub property is true and dimensioning is handled for you. Set AutoSize off to manually handle Width, Height, Margins and Paddings.

Adding Custom Legends

In the collection editor for the Legend Items property add one or more items. Use the Marker property to add images or colored shapes next to the text. Use the TextBlock property to add the text description for the legend item. You can also define image maps using the ActiveRegion property of the legend or legend items.

To add images to the legend you can set the Marker.Appearance.FillStyle.FillType to Image and the Marker.Appearance.FillStyle.FillSettings.BackgroundImage to the path of an image to display. In the example below two legend items are added to the collection where the BackgroundImage contains image paths for two flags and where the TextBlock.Text properties contain corresponding descriptions. In addition the Legend.Appearance.Shadow property has Blur = 5 and Distance = 2.

Adding Legend Items


Margins

Telerik Reporting Q3 2008 Send comments on this topic.
Margins
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > Margins

Glossary Item Box

Chart margins are the distances from the outermost chart borders to the borders of the plot area.

Margins are expressed in the Chart PlotArea.Dimensions.Margins property and are specified in pixels or percentages. Percentages refer to a percentage of the Chart width. In the figure below the dimensions are populated with some values in percentages, some in fixed pixels.

To provide extra space for positioning legends, labels and title, use greater margin values for the PlotArea to provide room.


Titles

Telerik Reporting Q3 2008 Send comments on this topic.
Titles
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > Titles

Glossary Item Box

The title for the chart as a whole is controlled by the Chart.ChartTitle object. The following sub properties of ChartTitle allow you to format the text, marker and overall appearance of the title:

  • ActiveRegion: ActiveRegion contains properties for HTML Attributes, Tooltip and URL.
  • Appearance controls visibility, Border, Corners, Dimensions, FillStyle, Position, RotationAngle and Shadow for the title. Use the Position.AlignedPosition to place the title area in a predefined position (e.g. Left, Right, Center, Top, Bottom, BottomRight, BottomLeft, TopRight, TopLeft), or set the Auto property off and use the X and Y properties to place the chart title anywhere on the chart including the plot area.
  • Marker controls a small graphic for the title area. By default the marker is not visible.
  • The TextBlock properties provides fine tune control over the text and text background.

In the example below the title is customized so that the position is aligned to the top left, corners are rounded, the fill is a gradient fill radiating from the center and a shadow makes it stand out from the background.


Series Overview

Telerik Reporting Q3 2008 Send comments on this topic.
Series Overview
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > Series Overview

Glossary Item Box

Series refers to a series of data points displayed in the chart. The Chart Series object is a collection of ChartSeriesItem objects. The number of series used depends on the type of chart. A Pie chart type only uses a single series. "Stacked" charts like the Stacked Area chart use several series.

Each ChartSeries object contains a collection of ChartSeriesItem objects that contain the actual data points displayed on the chart. You can add data to a series programmatically at run time, at design time in the Properties Window of Visual Studio, declaratively in the ASP.NET HTML markup, or by binding to a data source.

Some key properties for the ChartSeries are:

  • Appearance: This property contains the common appearance related properties such as Border, Corners, FillStyle and TextAppearance. In addition there are series specific properties including LabelAppearance, LineSeriesAppearance, LegendDisplayMode, BubbleSize and PointMark.
  • DefaultLabelValue: Specifies a format for label values. This allows you to display data points as numeric amounts, percentages, totals or any format described in this MSDN article Standard Numeric Format Strings
  • Items: The collection of ChartSeriesItem objects that contain data points.
  • Name: By default this name is displayed in the legend for the series.
  • Types: Use this property to select the chart type. Valid values are Bar, StackedBar, StackedBar100, Line, Area, StackedArea, StackedArea100, Pie, Gantt, Bezier, Spline, Bubble, Point, SplineArea, StackedSplineArea and StackedSplineArea100.
  • Visible: Turn this property off to hide the series.

ChartSeries Properties Used in Data Binding

DataLabelsColumn: This is the name of a data source column that will supply the text that displays next to each data point in the chart.

DataXColumn, DataXColumn2, DataYColumn, DataYColumn2: These are the names of the columns that will contain data used for the series item XValue, XValue2, YValue and YValue2 columns respectively.


Series Items

Telerik Reporting Q3 2008 Send comments on this topic.
Series Items
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > Series Items

Glossary Item Box

Each chart series item encapsulates a single data point.

The key properties are shown in the figure below in the property category "Basic value set". For simple charts along a single axis populate the YValue property. Use the XValue property to add a second data dimension. For example, the Y values might be "Sales Volume" and the X values might be time periods or geographic regions. XValue2 and YValue2 are used by Gantt type to indicate a period of time and the Bubble chart type to show amplitude of data.

Set the Empty property to true to have Chart approximate the value. The example below has a third item with the Empty property set to True, causing the item to display by default as a unfilled dotted line with a label of 30.5 (the average of the values that come before and after, 5 and 56, respectively). The look of the empty value is controlled by the EmptyValue property for the series Appearance.

Other significant properties for the ChartSeriesItem are:

  • ActiveRegion: Contains HTML Attributes, ToolTip and URL. These properties support making image maps.
  • Appearance: This contains common visual properties Border, Corners, FillStyle and Visible. In addition the property Exploded is specific to the Pie chart property type. When true, Exploded displays a chart series item (a pie slice in this context) as slightly separated from the rest of the pie.
  • Label: Use this property to override the default item label. By default the numeric values of each data point are displayed on the chart. Here you can use the Label.TextBlock.Text to add a more specific description of the data point. You have full control over each label HTML characteristics with the Label.ActiveRegion. Control visual display and layout using the Label.Appearance property.


Series-Specific Properties

Telerik Reporting Q3 2008 Send comments on this topic.
Series-Specific Properties
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > Series-Specific Properties

Glossary Item Box

The following are properties specific to the series appearance of specific chart types.

Bubble

The BubbleSize property is specific to the Bubble chart type and allows you to increase or decrease bubble size without distorting the shape.

Lines and Splines

The LineSeriesAppearance property is specific to the Line and Spline chart types. LineSeriesAppearance has a Cap property that governs the appearance of a line terminating shape that occurs where at each data point (except the first). Valid Cap values are Flat, Square, Round, Triangle, NoAnchor, SquareAnchor, RoundAnchor, DiamondAnchor, ArrowAnchor, AnchorMask and Custom. LineSeriesAppearance also has sub properties for Color, PenStyle, Visible and Width.

The PointMark is a shape that occurs at every data point, including the first. PointMarks are off by default but can be enabled using the Pointmark.Visible property. Use the Pointmark.Figure property to choose one of the predefined shapes. Other PointMark properties include Border, Corners, Dimensions, FillStyle, RotationAngle and Shadow.

The example above shows Series 1 in red where LineSeriesAppearance properties are:

  • Cap = ArrowAnchor
  • Color = Red
  • PenStyle = Dash
  • Width = 5

Series 2 show in blue has PointMark properties set as:

  • Border.Color = 50, 0, 245, 100
  • Border.Width = 1
  • Figure = Star5
  • Visible = True
  • Dimensions.Height = 25px
  • Dimensions.Width = 25px
  • FillStyle.FillType = Solid
  • FillStyle.MainColor = 90, 100, 254, 100
  • Shadow.Blur = 1
  • Shadow.Color = DimGray
  • Shadow.Distance = 2

Pie

The StartAngle property specifies degrees for the rotation of a pie. The default value and the starting position is 0°. Positive values of the StartAngle property will rotate the pie clockwise and negative - counterclockwise.

The DiameterScale property controls the ratio between the size of the plot area and the diameter of the chart. It effectively sets the size of the pie. In the example below, DiameterScale is set to 1, .75 (the default) and .5.

When true, the ShowLabelConnectors property visually ties the label with the corresponding pie slice.

The ExplodePercent property defines the percentage of explosion of pie pieces. By default this is 20 percent. In the example below it is set to 50 percent:

The CenterXOffset and CenterYOffset properties specify the distance from the center of the plot area to the center of the pie in pixels. Use these two properties to position pie charts within the plot area.


Ticks

Telerik Reporting Q3 2008 Send comments on this topic.
Ticks
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > Ticks

Glossary Item Box

Axis ticks are the small marks that identify the position of items on the axes and the starting points of gridlines.

Vertical ticks are controlled by the XAxis and horizontal ticks are controlled by YAxis and YAxis2. Ticks can be "major", e.g. falling on the labeled axis Step values. "Minor" ticks fall between Step values for YAxis and YAxis2. See the figure below where major ticks fall on 50, 100, 150, 200, 250 of the YAxis and minor ticks fall between the major ticks.

X and Y Axis Ticks

To control the visibility and general appearance of gridlines use the the PlotArea.<axis>.Appearance property to reach MajorTick and MinorTick properties. XAxis has only a MajorTick property while YAxis and YAxis2 have both MajorTick and MinorTick properties. Both major and minor tick objects include the following properties:

  • Visible : Set this property false to hide the ticks.
  • Cap : The terminator for each tick can be Flat, Square, Round, Triangle, NoAnchor, SquareAnchor, DiamondAnchor, ArrowAnchor, AnchorMask or Custom. In the example above the Y Axis major ticks have a Square cap, minor ticks have a RoundCap and X Axis major ticks have an ArrowAnchor cap.
  • Color of the line and cap.
  • Length: The length of the tick in pixels. To reverse the direction of the ticks and have them appear above the axis line use a negative value for Length.
  • PenStyle : values can be Solid, Dash, Dot, DashDot, DashDotDot and Custom.
  • Width in pixels.

Layout

The LayoutMode property of each the X axis object specifies how axis marks are positioned with regard to series items. Layout modes change the chart appearance while the underlying data remains the same.. The available LayoutMode values are Normal, Inside and Between.


DefaultLabelValue

Telerik Reporting Q3 2008 Send comments on this topic.
DefaultLabelValue
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > DefaultLabelValue

Glossary Item Box

DefaultLabelValue specifies a format for label values that will be displayed automatically if you do not specifically assign text to a chart series item.

  • Use "#Y" or "#X" to display numbers from the X or Y axis respectively
  • Use "#%" for a percentage of the total sum (of all items).
  • Use "#SUM" to display the total of all items.
  • "#STSUM" displays the sum of a stacked series.
  • "#SERIES" displays the series name.
  • "#ITEM" displays the item name.
  • You can also use the formatting described in this MSDN article Standard Numeric Format Strings. Use curly brackets to contain the standard numeric formats. For example, you can display Y values as currency by setting DefaultLabelValue to "#Y{C}". See examples in the figure below.


BarOverLapPercent and BarWidthPercent

Telerik Reporting Q3 2008 Send comments on this topic.
BarOverLapPercent and BarWidthPercent
Designing Reports > Understanding Report Items > Chart > Understanding Chart Elements > BarOverLapPercent and BarWidthPercent

Glossary Item Box

In bar charts with multiple series BarOverLapPercent governs to what degree the bars will overlap the preceding bar series. If you enter a negative value for BarOverLapPercent , a gap appears between the bars of different series. Overlapping is especially useful when a long series of items needs to fit in a small-size chart.

BarWidthPercent controls how much space each bar takes up so that a BarWidthPercent of 100 will have all the bars in the chart taking exactly all the available width.

The maximum bar width is calculated as follows: bar width = axislength / bars count.

See the examples below to see how these two properties work together.


Chart Wizard

Telerik Reporting Q3 2008 Send comments on this topic.
Chart Wizard
Designing Reports > Understanding Report Items > Chart > Understanding Chart UI > Chart Wizard

Glossary Item Box

The Chart Wizard helps you traverse the many properties of Chart by providing the most commonly used properties in an intuitive way. The wizard can help you quickly set up the basic structure of your chart. You can invoke the chart wizard from the context menu that appears when you right-click the chart item and select Properties.

The Chart Interface consists of tabs:

  • Type
  • Data
  • Skin
  • Labels, Legend & Title
  • Axis
  • Values Data Table

The Chart Wizard


The Wizard Type Tab

Telerik Reporting Q3 2008 Send comments on this topic.
The Wizard Type Tab
Designing Reports > Understanding Report Items > Chart > Understanding Chart UI > The Wizard Type Tab

Glossary Item Box

The Type tab lets you quickly choose the chart type by providing visual cues to what each type looks like. Here you can also choose the chart orientation.

RadChart Wizard Type Tab


The Wizard Data Tab

Telerik Reporting Q3 2008 Send comments on this topic.
The Wizard Data Tab
Designing Reports > Understanding Report Items > Chart > Understanding Chart UI > The Wizard Data Tab

Glossary Item Box

The Data tab brings together the Series, Series Item, Axis labels and data binding to a single screen. Here you can add data points to your chart manually or by binding to data sources.

RadChart Wizard Data Tab

The Data tab is composed of areas:

Choose Data Source

Choose Data Source appears on the upper left hand portion of the screen. Select from an existing data source or select "<new data source" from the drop down list. If you have an existing data source selected, click the Edit button to reconfigure the data source in the Configure Data Source Wizard.

Group Column

Group Column appears on the upper right side. Select a column name from a bound data source to group by that column data.

Series

Use the Series area of the tab to add, delete and reorder chart series elements using the list box provided. Use the plus and minus buttons to add or delete a series element. Use the up and down arrows to move a series element up or down in the list. For each selected series element in the list box you can provide a name and select from the list of chart types.

If you bind to a data source the Databind Series Elements portion will be enabled and allow you to choose column names for your labels and values from the drop down lists provided. When you bind to a data source the Series list box will be populated automatically with a series for each numeric column in the data source. If you need to fine tune the behavior or appearance of a series in more depth than the Data tab provides, use the Chart Series property in the property window. In the example below the Labels for the series have been bound to a column "TenMostExpensiveProducts", which contains product descriptions. These descriptions display to the right next to each bar in the chart. Note that SeriesOrientation is Horizontal, so the X-Axis is on the left.

Labeling Series Elements

Series Items

For each series you select in the Series area list, you can add, edit, delete and reorder entries in the Series Items list. Use the plus and minus buttons to add and delete series items. Use the up and down arrows to move series items up or down in the list. For each item you can set the Name, Label and X and Y Values. X2 and Y2 values are enabled for Gantt and Bubble chart types. If you need to refine the behavior or appearance in more detail than provided by this Wizard page, use the Items collection of the Chart Series from the Property window.

Axis Labels

This section lets you choose between binding to a column in the data source and using the column data to populate the labels along an Axis. Click the Add Labels Manually link to navigate to the Axis tab. The screen shot below shows the X-Axis labels set data bound to a column "TenMostExpensiveProducts" that contains product descriptions. Note that SeriesOrientation is Horizontal, so the X-Axis items show on the left.


The Wizard Skin Tab

Telerik Reporting Q3 2008 Send comments on this topic.
The Wizard Skin Tab
Designing Reports > Understanding Report Items > Chart > Understanding Chart UI > The Wizard Skin Tab

Glossary Item Box

The Chart Skin property lets you apply a coordinated set of style changes to all the chart visual details at one time. The Skin tab of the wizard lets you visually inspect how a chart might look with a given skin. The skins displayed reflect the current chart type. In the screen shot below the chart type is Bubble.

The Chart Wizard Skin Tab


The Wizard Labels, Legend and Titles Tab

Telerik Reporting Q3 2008 Send comments on this topic.
The Wizard Labels, Legend and Titles Tab
Designing Reports > Understanding Report Items > Chart > Understanding Chart UI > The Wizard Labels, Legend and Titles Tab

Glossary Item Box

On the Labels, Legend and Titles Tab:

  • Title: From this portion of the tab set the Text for the title, toggle visibility of the title using the checkbox provided and set text direction from the drop down list. Use the Alignment drop down to move the title position between None, Left, Top, Bottom, Center, TopRight, TopLeft, BottomRight and BottomLeft.
  • Legend: Unselect the Visible checkbox to hide the legend. Use the Marker drop down to select from a predefined list of shapes. In the example below the Rectangle shape is selected. Use the Alignment drop down to move the legend position between None, Left, Top, Bottom, Center, TopRight, TopLeft, BottomRight and BottomLeft. In the example below the legend is moved to the upper right corner.
If you hide the legend, the extra space at the right of the screen remains. Use the PlotArea.Appearance.Dimensions.Margins to add or remove buffer space around the plot area.
  • Series Labels: This section lets you set label properties for a series name selected in the Series drop down list. Uncheck the Visible box to hide the series labels. Enter a value between 0 and 360 to the Rotation entry to rotate all series labels at one time. In the example below the labels are rotated 330 degrees. Positive Rotation values rotate the labels clockwise, negative values rotate the labels counter-clockwise. Positive Distance values move the labels away from the chart series items. The example below has a distance of 60.

Using the Wizard Labels, Legend and Titles Tab


The Wizard Axis Tab

Telerik Reporting Q3 2008 Send comments on this topic.
The Wizard Axis Tab
Designing Reports > Understanding Report Items > Chart > Understanding Chart UI > The Wizard Axis Tab

Glossary Item Box

The Axis tab lets you select an axis from the drop down list at the top of the page. You can then modify the properties below and they will be retained for the selected axis. Use the Copy Settings From button to replicate settings from another axis.

Visual Properties

The Visual Properties section of the page controls properties for the axis as a whole.

  • Uncheck the Visible checkbox to hide the entire axis (including labels and tick marks).
  • Axis Title text populates a single label that appears for the axis as a whole.
  • Use the Alignment property to place the axis label in a predefined position, e.g. Left, Right, Top, Bottom, Center, TopRight, TopLeft, BottomRight, BottomLeft.
  • Uncheck Show Ticks to hide the axis tick marks.
  • Uncheck Show Labels to hide the axis labels (but not the Axis Title).
  • The Value Format drop down list automatically formats axis labels as various kinds of dates, times, percentages, numbers and currency.
  • Visible Values can be All, Positive or Negative values.
  • Rotation is used to rotate the axis label text. Positive numbers spin the labels clockwise, negative numbers counter-clockwise.

Axis Labels

  • Turn off Auto Scale if you want to provide custom axis labels instead of the default numeric values. Turning off Auto Scale also lets you use the Min, Max and Step values.
  • Enter Min and Max values to control the number of series items to be displayed along that axis. Enter a Step value to control the interval between axis labels.
  • If Auto Scale is off you can use the provided list box to add, delete and reorder axis label items manually. By selecting any one of the axis label values in the listbox you can assign a text label.
  • Click the Bind Axis Labels to Database link to navigate back to the Data tab.

The Chart Wizard Axis Tab

The settings in the Axis Tab shown above result in the following X Axis labeling example:

Resulting Axis Labels


Understanding Wizard Values Data Table Tab

Telerik Reporting Q3 2008 Send comments on this topic.
Understanding Wizard Values Data Table Tab
Designing Reports > Understanding Report Items > Chart > Understanding Chart UI > Understanding Wizard Values Data Table Tab

Glossary Item Box

The Values Data Table tab of the Wizard controls the general look and positioning of the chart data table.

Data Table Drawn PlotAreaRelative

Visual Properties

  • Check Visible to display the chart data table. By default this is unchecked.
  • Select Draw Type from the drop down list to control the general size and positioning of the chart. Select AutoSize to have each cell size to the data inside of it. PlotAreaRelative places each cell just below the chart series item it represents. CellFixedSize and TableFixedSize fix the size of the cells or table irrespective of the data it contains.

Alignment

Use the Align drop down list to place the chart data table in a predefined position (e.g. Top, Bottom, BottomRight, etc.) To place the data table at exact coordinates, uncheck Auto and enter values for X and Y.

RadChart Wizard Values Data Table Tab


Building Charts

Telerik Reporting Q3 2008 Send comments on this topic.
Building Charts
See Also
Designing Reports > Understanding Report Items > Chart > Building Charts > Building Charts

Glossary Item Box

To provide flexibility and best ease-of-use, Telerik provides multiple avenues to populate chart. There are four main techniques for building the chart: interactively at design-time, declaratively in the ASP.NET HTML markup, programmatically at runtime and by data binding.

In simple scenarios or to test out a design you can use the design-time interface to build the entire chart. Collection editors provide a consistent interface and easy navigation over all your chart series and series items. You can also use the Chart Wizard to display a subset of the data.

If your design style leans towards working with the ASP.NET HTML code directly you can declaratively define your chart series and chart series items.

Most business applications display some sort of database data so Chart fully supports binding data sources to labels and data elements. The chart item also supports data binding to the X-Axis. In addition to database data, Chart can bind to XML. The chart binds to ObjectDataSource to support enterprise multi-tier scenarios. And of course you can bind your chart to arrays, collections, generic lists of simple types and lists of objects.

To create and populate the Chart ChartSeries and ChartSeriesItem collections:

  • At design time by using the editors for ChartSeries and ChartSeriesItem collections or using the Chart Wizard.
  • Binding to a datasource at run time or design time.

  • Bind to a datasource programmatically to populate the ChartSeries and ChartSeriesItem collections. See this minimal example of creating and populating a Chart programmatically or this more complex example.

See Also

Populate Chart at Design-Time
Creating Chart Programmatically
Creating Chart Programmatically - more complex example
Data Binding Chart
Data Binding Chart to an Array
Data Binding Chart to a Database Object
Data Binding Chart to a Generic List
Data Binding Chart to a Generic List of Simple Types
Data Binding Chart to a Generic List of Objects
Data Binding Chart to an ObjectDataSource
Binding to ObjectDataSource at Run-Time


Populate Chart at Design-Time

Telerik Reporting Q3 2008 Send comments on this topic.
Populate Chart at Design-Time
See Also
Designing Reports > Understanding Report Items > Chart > Building Charts > Populate Chart at Design-Time

Glossary Item Box

The chart provides two collection editors: ChartSeries Collection Editor and ChartSeriesItem Collection Editor. They allow you to easily create series and items, and set the relevant properties without writing any code.

There are two basic steps to populate the Chart with data:

  1. Click on the Chart Series property ellipses to display the ChartSeries Collection Editor. Here you can add or remove series in the Members list box on the left side of the editor. You can set the series level properties by selecting a series member and editing properties in the properties window located on the right hand side of the editor. See topics Series Overview, Series Items and Series-Specific Properties for more information. Note the Items property under the Series property category.

ChartSeries Collection Editor

  2. Click the Items property ellipses of a series to display the ChartSeriesItem Collection Editor. Here you can add or remove items in the Members list box on the left side of the editor. Select ChartSeriesItem objects in the Members list box on the left side of the editor. You can set item properties by selecting an item member and editing properties in the properties window located on the right hand side of the editor. Set the values for each item using the properties under the "Basic value set" property category. See Series Items for more information.

ChartSeriesItem Collection Editor

The running application shows ChartSeries members in the Legend and ChartSeriesItem as bars in the plot area.

This chart example also displays customization in the legend and axis labels. See Legends and Axis Labels for more information.

Completed Chart populated at Design Time

See Also

Building Charts
Creating Chart Programmatically


Creating Chart Programmatically

Telerik Reporting Q3 2008 Send comments on this topic.
Creating Chart Programmatically
See Also
Designing Reports > Understanding Report Items > Chart > Building Charts > Creating Chart Programmatically

Glossary Item Box

The steps below show how to create a minimal Chart programmatically.

See the "create a more complex chart programmatically" topic to see how multiple series are created and how appearance can be tailored at run-time.

See the topic "Multiple Chart Types in a Single Chart" to see how multiple series area created programmatically and given different ChartSeriesTypes.

Once the chart is created, the critical steps are creating the ChartSeries and ChartSeriesItem collections. There are two approaches to creating chart series objects. One is to use the default ChartSeries constructor and assign its properties. A second route is to use the Chart CreateSeries() method to set a number of important properties at once and return the constructed chart series.

  1. First add the namespaces that support the objects to be referenced. The Telerik.Reporting.Charting namespace supports the Chart declaration.

    [C#] Adding Namespaces Copy Code
    using Telerik.Reporting.Charting;
    [VB] Adding Namespaces Copy Code
    Imports Telerik.Reporting.Charting
  2. Next construct the Chart item itself.
[VB] Create the chart item, set its location, name, resolution and size Copy Code
Dim progchart As New Telerik.Reporting.Chart()
progchart.BitmapResolution = 96F
progchart.ImageFormat = System.Drawing.Imaging.ImageFormat.Emf
progchart.Location = New Telerik.Reporting.Drawing.PointU(New Telerik.Reporting.Drawing.Unit(0.326454937458038, (DirectCast((Telerik.Reporting.Drawing.UnitType.Cm), Telerik.Reporting.Drawing.UnitType))), New Telerik.Reporting.Drawing.Unit(1.83544945716858, (DirectCast((Telerik.Reporting.Drawing.UnitType.Cm), Telerik.Reporting.Drawing.UnitType))))
progchart.Name = "progchart1"
progchart.PlotArea.EmptySeriesMessage.Appearance.Visible = True
progchart.PlotArea.EmptySeriesMessage.Visible = True
progchart.Size = New Telerik.Reporting.Drawing.SizeU(New Telerik.Reporting.Drawing.Unit(9.67354488372803, (DirectCast((Telerik.Reporting.Drawing.UnitType.Cm), Telerik.Reporting.Drawing.UnitType))), New Telerik.Reporting.Drawing.Unit(6.17354536056519, (DirectCast((Telerik.Reporting.Drawing.UnitType.Cm), Telerik.Reporting.Drawing.UnitType))))

3.Construct a new ChartSeries object. Assign a name to the ChartSeries. Set the ChartSeries.Type to be Bar. Using the ChartSeries.AddItem() method, add a series of ChartSeriesItem objects to the series Items collection. AddItem() takes as parameters a double "Value" and a string "Label".

[C#] Create the ChartSeries and ChartSeriesItems Copy Code
// Create a ChartSeries and assign its name and chart type
ChartSeries chartSeries = new ChartSeries();
chartSeries.Name = "Sales";
chartSeries.Type = ChartSeriesType.Bar;
// add new items to the series,
// passing a value and a label string
chartSeries.AddItem(120, "Internet");
chartSeries.AddItem(140, "Retail");
chartSeries.AddItem(35, "Wholesale");

[VB] Create the ChartSeries and ChartSeriesItem Copy Code
' Create a ChartSeries and assign its name and chart type
Dim chartSeries As New ChartSeries()
chartSeries.Name = "Sales"
chartSeries.Type = ChartSeriesType.Bar
' add new items to the series,
' passing a value and a label string
chartSeries.AddItem(120, "Internet")
chartSeries.AddItem(140, "Retail")
chartSeries.AddItem(35, "Wholesale")
4. Finally, add the ChartSeries to the Chart Series collection and add the Chart item to the desired report section.

[C#] Add ChartSeries to Series Collection and Chart to Page Copy Code
// add the series to the Chart Series collection
progchart.Series.Add(chartSeries);
// add the Chart to the page.
detail.Items.AddRange(new Telerik.Reporting.ReportItemBase[] { progchart });

[VB] Add ChartSeries to Series Collection and Chart to Page Copy Code
' add the series to the Chart Series collection
progchart.Series.Add(chartSeries)
' add the Chart to the page.
detail.Items.AddRange(New Telerik.Reporting.ReportItemBase() {progchart})

  1. The finished chart should look like this example:

Programmatically Created Chart at Runtime

The alternative to using the ChartSeries object constructor and assigning properties is to use the Chart CreateSeries() method that lets you pass several properties in the call, including Name, MainColor, SecondColor and ChartSeriesType.

[C#] Using CreateSeries Copy Code
ChartSeries chartSeries = progchart.CreateSeries("Sales",
System.Drawing.Color.RoyalBlue,
System.Drawing.Color.LightSteelBlue,
ChartSeriesType.Bar);
[VB] Using CreateSeries Copy Code
Dim chartSeries As ChartSeries = progchart.CreateSeries("Sales", System.Drawing.Color.RoyalBlue, System.Drawing.Color.LightSteelBlue, ChartSeriesType.Bar)

See Also

Building Charts
Populate Chart at Design-Time
Creating Chart Programmatically - more complex example


Creating Chart Programmatically - more complex example

Telerik Reporting Q3 2008 Send comments on this topic.
Creating Chart Programmatically - more complex example
See Also
Designing Reports > Understanding Report Items > Chart > Building Charts > Creating Chart Programmatically - more complex example

Glossary Item Box

Programmatically Created Chart

The figure above shows a more complex chart than the minimal example of programmatically created Chart. This example demonstrates how to:

  • Create the chart, define the chart title and the title's appearance.
  • Define two different chart series, how to hide the series labels and tailor the series appearance.
  • Add multiple chart series items with data.
  • How to display point marks to highlight the data points.
  • Fill the plot area background with a gradient color.
  • Set axis line and label appearance.
[C#] Programmatically Created Chart Copy Code
// Define chart and title

Telerik.Reporting.Chart Chart = new Telerik.Reporting.Chart();
Chart.BitmapResolution = 96F;
Chart.ImageFormat = System.Drawing.Imaging.ImageFormat.Emf;
Chart.Location = new Telerik.Reporting.Drawing.PointU(new Telerik.Reporting.Drawing.Unit(0.32645493745803833, ((Telerik.Reporting.Drawing.UnitType)(Telerik.Reporting.Drawing.UnitType.Cm))), new Telerik.Reporting.Drawing.Unit(1.8354494571685791, ((Telerik.Reporting.Drawing.UnitType)(Telerik.Reporting.Drawing.UnitType.Cm))));
Chart.Name = "progchart1";
Chart.PlotArea.EmptySeriesMessage.Appearance.Visible = true;
Chart.PlotArea.EmptySeriesMessage.Visible = true;
Chart.Size = new Telerik.Reporting.Drawing.SizeU(new Telerik.Reporting.Drawing.Unit(9.6735448837280273, ((Telerik.Reporting.Drawing.UnitType)(Telerik.Reporting.Drawing.UnitType.Cm))), new Telerik.Reporting.Drawing.Unit(6.1735453605651855, ((Telerik.Reporting.Drawing.UnitType)(Telerik.Reporting.Drawing.UnitType.Cm))));
Chart.ChartTitle.TextBlock.Text = "My Chart";
Chart.ChartTitle.TextBlock.Appearance.TextProperties.Color =
System.Drawing.Color.Blue;
// Define chart series
ChartSeries chartSeries = new ChartSeries();
chartSeries.Appearance.LabelAppearance.Visible = false;
chartSeries.Name = "GDP";
chartSeries.Type = ChartSeriesType.Line;
chartSeries.Appearance.LineSeriesAppearance.Color =
System.Drawing.Color.BlueViolet;
// Define the items in the series
chartSeries.AddItem(1);
chartSeries.AddItem(1.5);
chartSeries.AddItem(2.0);
chartSeries.AddItem(2.5);
chartSeries.AddItem(3.5);
// visually enhance the data points
chartSeries.Appearance.PointMark.Dimensions.Width = 5;
chartSeries.Appearance.PointMark.Dimensions.Height = 5;
chartSeries.Appearance.PointMark.FillStyle.MainColor =
System.Drawing.Color.Black;
chartSeries.Appearance.PointMark.Visible = true;
// Define chart series
ChartSeries chartSeries2 = new ChartSeries();
chartSeries2.Appearance.LabelAppearance.Visible = false;
chartSeries2.Name = "GNP";
chartSeries2.Type = ChartSeriesType.Line;
chartSeries2.Appearance.LineSeriesAppearance.Color =
System.Drawing.Color.Green;
// Define the items in the series
chartSeries2.AddItem(2);
chartSeries2.AddItem(3);
chartSeries2.AddItem(3.5);
chartSeries2.AddItem(4);
chartSeries2.AddItem(4.5);
// visually enhance the data points
chartSeries2.Appearance.PointMark.Dimensions.Width = 5;
chartSeries2.Appearance.PointMark.Dimensions.Height = 5;
chartSeries2.Appearance.PointMark.FillStyle.MainColor =
System.Drawing.Color.Black;
chartSeries2.Appearance.PointMark.Visible = true;
// set the plot area gradient background fill
Chart.PlotArea.Appearance.FillStyle.FillType =
Telerik.Reporting.Charting.Styles.FillType.Gradient;
Chart.PlotArea.Appearance.FillStyle.MainColor =
System.Drawing.Color.FromArgb(65, 201, 254);
Chart.PlotArea.Appearance.FillStyle.SecondColor =
System.Drawing.Color.FromArgb(0, 107, 186);
// Set text and line for X axis
Chart.PlotArea.XAxis.AxisLabel.TextBlock.Text = "Years";
Chart.PlotArea.XAxis.AxisLabel.TextBlock.Appearance.TextProperties.Color =
System.Drawing.Color.Red;
Chart.PlotArea.XAxis.Appearance.Width = 3;
Chart.PlotArea.XAxis.Appearance.Color = System.Drawing.Color.Red;
// Set text and line for Y axis
Chart.PlotArea.YAxis.AxisLabel.TextBlock.Text = "%";
Chart.PlotArea.YAxis.AxisLabel.TextBlock.Appearance.TextProperties.Color =
System.Drawing.Color.Red;
Chart.PlotArea.YAxis.Appearance.Width = 3;
Chart.PlotArea.YAxis.Appearance.Color = System.Drawing.Color.Red;
// Add the series to the chart, chart to page.
Chart.Series.Add(chartSeries);
Chart.Series.Add(chartSeries2);

detail.Items.AddRange(new Telerik.Reporting.ReportItemBase[] { Chart });

[VB] Programmatically Created Chart Copy Code
' Define chart and title
Dim Chart As New Telerik.Reporting.Chart()
Chart.BitmapResolution = 96F
Chart.ImageFormat = System.Drawing.Imaging.ImageFormat.Emf
Chart.Location = New Telerik.Reporting.Drawing.PointU(New Telerik.Reporting.Drawing.Unit(0.326454937458038, (DirectCast((Telerik.Reporting.Drawing.UnitType.Cm), Telerik.Reporting.Drawing.UnitType))), New Telerik.Reporting.Drawing.Unit(1.83544945716858, (DirectCast((Telerik.Reporting.Drawing.UnitType.Cm), Telerik.Reporting.Drawing.UnitType))))
Chart.Name = "progchart1"
Chart.PlotArea.EmptySeriesMessage.Appearance.Visible = True
Chart.PlotArea.EmptySeriesMessage.Visible = True
Chart.Size = New Telerik.Reporting.Drawing.SizeU(New Telerik.Reporting.Drawing.Unit(9.67354488372803, (DirectCast((Telerik.Reporting.Drawing.UnitType.Cm), Telerik.Reporting.Drawing.UnitType))), New Telerik.Reporting.Drawing.Unit(6.17354536056519, (DirectCast((Telerik.Reporting.Drawing.UnitType.Cm), Telerik.Reporting.Drawing.UnitType))))
Chart.ChartTitle.TextBlock.Text = "My Chart"
Chart.ChartTitle.TextBlock.Appearance.TextProperties.Color = System.Drawing.Color.Blue
' Define chart series
Dim chartSeries As New ChartSeries()
chartSeries.Appearance.LabelAppearance.Visible = False
chartSeries.Name = "GDP"
chartSeries.Type = ChartSeriesType.Line
chartSeries.Appearance.LineSeriesAppearance.Color = System.Drawing.Color.BlueViolet
' Define the items in the series
chartSeries.AddItem(1)
chartSeries.AddItem(1.5)
chartSeries.AddItem(2)
chartSeries.AddItem(2.5)
chartSeries.AddItem(3.5)
' visually enhance the data points
chartSeries.Appearance.PointMark.Dimensions.Width = 5
chartSeries.Appearance.PointMark.Dimensions.Height = 5
chartSeries.Appearance.PointMark.FillStyle.MainColor = System.Drawing.Color.Black
chartSeries.Appearance.PointMark.Visible = True
' Define chart series
Dim chartSeries2 As New ChartSeries()
chartSeries2.Appearance.LabelAppearance.Visible = False
chartSeries2.Name = "GNP"
chartSeries2.Type = ChartSeriesType.Line
chartSeries2.Appearance.LineSeriesAppearance.Color = System.Drawing.Color.Green
' Define the items in the series
chartSeries2.AddItem(2)
chartSeries2.AddItem(3)
chartSeries2.AddItem(3.5)
chartSeries2.AddItem(4)
chartSeries2.AddItem(4.5)
' visually enhance the data points
chartSeries2.Appearance.PointMark.Dimensions.Width = 5
chartSeries2.Appearance.PointMark.Dimensions.Height = 5
chartSeries2.Appearance.PointMark.FillStyle.MainColor = System.Drawing.Color.Black
chartSeries2.Appearance.PointMark.Visible = True
' set the plot area gradient background fill
Chart.PlotArea.Appearance.FillStyle.FillType = Telerik.Reporting.Charting.Styles.FillType.Gradient
Chart.PlotArea.Appearance.FillStyle.MainColor = System.Drawing.Color.FromArgb(65, 201, 254)
Chart.PlotArea.Appearance.FillStyle.SecondColor = System.Drawing.Color.FromArgb(0, 107, 186)
' Set text and line for X axis
Chart.PlotArea.XAxis.AxisLabel.TextBlock.Text = "Years"
Chart.PlotArea.XAxis.AxisLabel.TextBlock.Appearance.TextProperties.Color = System.Drawing.Color.Red
Chart.PlotArea.XAxis.Appearance.Width = 3
Chart.PlotArea.XAxis.Appearance.Color = System.Drawing.Color.Red
' Set text and line for Y axis
Chart.PlotArea.YAxis.AxisLabel.TextBlock.Text = "%"
Chart.PlotArea.YAxis.AxisLabel.TextBlock.Appearance.TextProperties.Color = System.Drawing.Color.Red
Chart.PlotArea.YAxis.Appearance.Width = 3
Chart.PlotArea.YAxis.Appearance.Color = System.Drawing.Color.Red
' Add the series to the chart, chart to page.
Chart.Series.Add(chartSeries)
Chart.Series.Add(chartSeries2)

detail.Items.AddRange(New Telerik.Reporting.ReportItemBase() {Chart})

See Also

Creating Chart Programmatically


Data Binding Chart

Telerik Reporting Q3 2008 Send comments on this topic.
Data Binding Chart
See Also
Designing Reports > Understanding Report Items > Chart > Building Charts > Data Binding Chart

Glossary Item Box

Many business applications rely on database data, for example MS SQL, Oracle, MySQL, Access ODBC as well as XML data and business objects in multiple-tier scenarios. Chart allows automatic binding to all of these using either standard Microsoft supplied data source controls SqlDataSource, AccessDataSource, XmlDataSource and ObjectDataSource or any DataSourceControl implementation.

You can also bind the Chart to a data source that implements one of the following interfaces:

  • IEnumerable: Supports simple iteration of a collection. See the MSDN article for more on IEnumerable.
  • ICollection: Extends IEnumerable and supports size, enumerator, and synchronization methods for collections.
  • IList: Extends ICollection and is the base class for lists.
  • IBindingList: Extends IList an supports binding to a data source.
  • IListSource: Provides functionality to an object to return a list that can be bound to a data source.

Some of the implementations of these interfaces include:

  • Array: See Data Binding Chart to an Array for an example.
  • ArrayList.
  • CollectionBase Objects.
  • DataView, DataTable, DataSet: See Data Bindng to a Database Object, Data binding Chart to an ObjectDatasource, DataBinding to an XML file examples.
  • Generic List class: See Data Binding Chart to a Generic List for an example of binding to a generic list.

You can also bind to XML data through an XMLDataSource or directly to an XML file.

Once you have the data source defined you can use the Chart Wizard, Property Editor or code for selecting which data columns will be used to populate the chart. The key properties for binding to a data source are:

ChartSeries Properties Used in Data Binding

DataLabelsColumn: This is the name of a data source column that will supply the text that displays next to each data point in the chart.

DataXColumn, DataXColumn2, DataYColumn, DataYColumn2: These are the names of the columns that will contain data used for the series item XValue, XValue2, YValue and YValue2 columns respectively.

X-Axis Properties Used in Data Binding

DataLabelsColumn: This is the name of a data source column that will supply the text that displays next to each X Axis item.

Chart Properties Used in Data Binding

DataSource: At runtime you can assign a compatible data source (e.g. DataSourceConrol, IList, IEnumerable, ICollection...) to the DataSource property of the chart.

DataSourceID: Assign this property at design time or run time to the ID of a DataSourceControl descendant such as SqlDataSource.

DataGroupColumn: This is the name of the column in the data source that data will be grouped by. This is similar to defining a "group by" SQL expression in the underlying query.

See Also

Data Binding Chart to a Database Object
Data Binding Chart to an ObjectDataSource
Data Binding Chart to an Array
Data Binding Chart to a Generic List of Simple Types
Data Binding Chart to a Generic List of Objects
Series Overview


Data Binding Chart to an Array

Telerik Reporting Q3 2008 Send comments on this topic.
Data Binding Chart to an Array
See Also
Designing Reports > Understanding Report Items > Chart > Building Charts > Data Binding Chart to an Array

Glossary Item Box

To bind a chart to an Array object, assign the chart DataSource property to the array. The example below demonstrates data binding to an array of integers.

Databinding to an array

[C#] Databinding to an integer array Copy Code
private void chart3_NeedDataSource(object sender, System.EventArgs e)
{
Telerik.Reporting.Processing.Chart chart = sender as Telerik.Reporting.Processing.Chart;
int[] intArray = new int[4] { 10, 12, 13, 5 };
chart.DataSource = intArray;
}
[VB] Databinding to an integer arra Copy Code
Private Sub chart3_NeedDataSource(ByVal sender As Object, ByVal e As System.EventArgs)
Dim chart As Telerik.Reporting.Processing.Chart = TryCast(sender, Telerik.Reporting.Processing.Chart)
Dim intArray As Integer() = New Integer(4) {10, 12, 13, 5}
chart.DataSource = intArray
End Sub

See Also

Data Binding Chart to a Database Object
Data Binding Chart to a Generic List
Data Binding Chart to an ObjectDataSource
Data Binding Chart


Data Binding Chart to a Database Object

Telerik Reporting Q3 2008 Send comments on this topic.
Data Binding Chart to a Database Object
See Also
Designing Reports > Understanding Report Items > Chart > Building Charts > Data Binding Chart to a Database Object

Glossary Item Box

To bind to a database, create a data source object and assign the data source to the Chart.

RadChart bound to a SqlDataSource

The figure above shows a running example that starts with a default Chart with a single Series. The example code:

  • Creates a SqlDataSource , adds it to the page, assigns the Chart DataSourceID property and finally binds to the datasource.
  • Displays data for a database column by assigning the series DataYColumn or DataXColumn properties. In the example the "TotalSales" column is assigned to the DataYColumn property.
  • Displays database column data in the X axis labels by assigning the column name to the DataLabelsColumn . The example assigns "CategoryName" to the DataLabelsColumn property.

Also note how the example sets the PlotArea.Appearance.Dimensions.Margins.Bottom to 30% and the PlotArea.XAxis.Appearance.LabelAppearance.RotationAngle to 300 in order to provide room for the axis labels.

[C#] Databinding to a database datasource Copy Code
using System;
using Telerik.Reporting.Chart;

public partial class Report1 : Report
{
public Report1()
{
/// <summary>
/// Required for telerik Reporting designer support
/// </summary>
InitializeComponent();

// create a datasource
SqlDataSource sqlDataSource = new SqlDataSource();
sqlDataSource.ID = "myDataSource";
sqlDataSource.ConnectionString =
ConfigurationManager.ConnectionStrings["NorthwindConnectionString"].ConnectionString;
sqlDataSource.SelectCommand =
"SELECT CategoryName, SUM(ProductSales) AS TotalSales FROM [Product Sales for 1997] GROUP BY CategoryName";
//setup chart
BuildChart();
}
private void BuildChart()
{
// assign it to Chart
Chart1.DataSourceID = "myDataSource";
// Set the column for data and data labels:
// Each bar will show "TotalSales", each label along
// X-axis will show "CategoryName.
Chart1.Series[0].DataYColumn = "TotalSales";
Chart1.PlotArea.XAxis.DataLabelsColumn = "CategoryName";
// assign appearance related properties
Chart1.PlotArea.XAxis.Appearance.LabelAppearance.RotationAngle = 300;
Chart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Color =
System.Drawing.Color.BlueViolet;
Chart1.PlotArea.Appearance.Dimensions.Margins.Bottom =
Telerik.Reporting.Charting.Styles.Unit.Percentage(30);

}
}

[VB] Databinding to a database datasourc Copy Code
Imports System
Imports Telerik.Reporting.Chart

Public Partial Class Report1
Inherits Report
Public Sub New()
''' <summary>
''' Required for telerik Reporting designer support
''' </summary>
InitializeComponent()

' create a datasource and add it to the page
Dim sqlDataSource As New SqlDataSource()
sqlDataSource.ID = "myDataSource"
sqlDataSource.ConnectionString = ConfigurationManager.ConnectionStrings("NorthwindConnectionString").ConnectionString
sqlDataSource.SelectCommand = "SELECT CategoryName, SUM(ProductSales) AS TotalSales FROM [Product Sales for 1997] GROUP BY CategoryName"
BuildChart()
End Sub

Private Sub BuildChart()
' assign it to Chart
Chart1.DataSourceID = "myDataSource"
' Set the column for data and data labels:
' Each bar will show "TotalSales", each label along
' X-axis will show "CategoryName.
Chart1.Series(0).DataYColumn = "TotalSales"
Chart1.PlotArea.XAxis.DataLabelsColumn = "CategoryName"
' assign appearance related properties
Chart1.PlotArea.XAxis.Appearance.LabelAppearance.RotationAngle = 300
Chart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Color = System.Drawing.Color.BlueViolet
Chart1.PlotArea.Appearance.Dimensions.Margins.Bottom = Telerik.Reporting.Charting.Styles.Unit.Percentage(30)
End Sub
End Sub
End Class

See Also

Data Binding Chart
Data Binding Chart to an Array
Data Binding Chart to a Generic List
Data Binding Chart to an ObjectDataSource


Data Binding Chart to a Generic List

Telerik Reporting Q3 2008 Send comments on this topic.
Data Binding Chart to a Generic List
See Also
Designing Reports > Understanding Report Items > Chart > Building Charts > Data Binding Chart to a Generic List

Glossary Item Box

Because the Chart can be bound to objects that implement the IList interface, and generic lists implement IList, it follows that you can bind Chart to generic lists. These lists can be of simple types, e.g. int and double types, or the lists can be composed of complex objects containing multiple properties.

  • See Data Binding Chart to a Generic List of Simple Types for a minimal example binding to a list of type double.
  • See Data Binding Chart to a Generic List of Objects for a more complex example where multiple properties are used for data and labeling.

See Also

Data Binding Chart
Data Binding Chart to an Array
Data Binding Chart to a Database Object
Data Binding Chart to a Generic List of Simple Types
Data Binding Chart to a Generic List of Objects
Data Binding Chart to an ObjectDataSource


Data Binding Chart to a Generic List of Simple Types

Telerik Reporting Q3 2008 Send comments on this topic.
Data Binding Chart to a Generic List of Simple Types
See Also
Designing Reports > Understanding Report Items > Chart > Building Charts > Data Binding Chart to a Generic List of Simple Types

Glossary Item Box

The example below is the result of binding a generic List<> of double to the Chart DataSource property.

Binding to IList

[C#] Binding a Generic List Copy Code
List<double> chartData = new List<double>();
chartData.Add(34);
chartData.Add(45);
chartData.Add(56);
chartData.Add(67);
chartData.Add(78);
Chart1.DataSource = chartData;
[VB] Binding a Generic List Copy Code
Dim chartData As New List(Of Double)()
chartData.Add(34)
chartData.Add(45)
chartData.Add(56)
chartData.Add(67)
chartData.Add(78)
Chart1.DataSource = chartData

See Also

Data Binding Chart to a Generic List
Data Binding Chart to a Generic List of Objects


Data Binding Chart to a Generic List of Objects

Telerik Reporting Q3 2008 Send comments on this topic.
Data Binding Chart to a Generic List of Objects
See Also
Designing Reports > Understanding Report Items > Chart > Building Charts > Data Binding Chart to a Generic List of Objects

Glossary Item Box

You can bind to a generic lists of objects that have multiple properties. The example below binds to a list of "Product" objects that contain two properties, one property for "Name" and a second for "QuantityInStock". The Y axis binds to the QuantityInStock and the X axis label binds to the "Name" property.

Binding to Generic List of Complex Objects

The Product object is defined with a constructor that passes both Name and QuantityInStock:

[C#] The Product Object Definition Copy Code
public class Product
{
public Product(string name, int quantityInStock)
{
_name = name;
_quantityInStock = quantityInStock;
}
private string _name;
public string Name
{
get { return _name; }
set { _name = value; }
}
private int _quantityInStock;
public int QuantityInStock
{
get { return _quantityInStock; }
set { _quantityInStock = value; }
}
}
[VB] The Product Object Definition Copy Code
Public Class Product
Public Sub New(ByVal name As String, ByVal quantityInStock As Integer)
_name = name
_quantityInStock = quantityInStock
End Sub
Private _name As String
Public Property Name() As String
Get
Return _name
End Get
Set
_name = value
End Set
End Property
Private _quantityInStock As Integer
Public Property QuantityInStock() As Integer
Get
Return _quantityInStock
End Get
Set
_quantityInStock = value
End Set
End Property
End Class

After the Product object is defined the following steps configure and bind to the generic List:

  1. A generic List of Product objects is created and assigned to the Chart DataSource property.
  2. The DataYColumn property of the series is assigned the numeric "QuantityInStock" property of the Product object.
  3. The XAxis DataLabelsColumn is assigned the "Name" property of the the Product object.
  4. The Chart DataBind() method is called.
[C#] Binding to a Generic List of Objects Copy Code
List<Product> products = new List<Product>();
products.Add(new Product("Parka L", 120));
products.Add(new Product("Parka M", 100));
products.Add(new Product("Parka S", 132));
products.Add(new Product("Wool Cap", 45));
products.Add(new Product("Mittens", 67));
Chart1.DataSource = products;
Chart1.Series[0].DataYColumn = "QuantityInStock";
Chart1.PlotArea.XAxis.DataLabelsColumn = "Name";
Chart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Font
= new System.Drawing.Font("Ariel", 8);
[VB] Binding to a Generic List of Object Copy Code
Dim products As New List(Of Product)()
products.Add(New Product("Parka L", 120))
products.Add(New Product("Parka M", 100))
products.Add(New Product("Parka S", 132))
products.Add(New Product("Wool Cap", 45))
products.Add(New Product("Mittens", 67))
Chart1.DataSource = products
Chart1.Series(0).DataYColumn = "QuantityInStock"
Chart1.PlotArea.XAxis.DataLabelsColumn = "Name"
Chart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Font = New System.Drawing.Font("Ariel", 8)

See Also

Data Binding Chart to a Generic List
Data Binding Chart to a Generic List of Simple Types


Data Binding Chart to an ObjectDataSource

Telerik Reporting Q3 2008 Send comments on this topic.
Data Binding Chart to an ObjectDataSource
See Also
Designing Reports > Understanding Report Items > Chart > Building Charts > Data Binding Chart to an ObjectDataSource

Glossary Item Box

The Chart can be bound to ObjectDataSource in multi-tier application scenarios. See the MSDN article ObjectDataSource Overview for more information on where and why you would use an ObjectDataSource control.

An ObjectDataSource represents a business object and provides data to data-bound controls in multi-tier applications. The application doesn't need to know how data is obtained as long as you connect the ObjectDataSource to an object that has DataObjectAttribute and DataObjectMethodAttribute attributes defined. See the following examples for how to create the business object and how to bind Chart to ObjectDataSource:

  • Creating an object that can be consumed by ObjectDataSource.
  • Binding Chart to ObjectDataSource at programmatically at run-time.

See Also

Data Binding Chart
Data Binding Chart to an Array
Data Binding Chart to a Database Object
Data Binding Chart to a Generic List
Creating an Object that can be Consumed by ObjectDataSource
Binding to ObjectDataSource at Run-Time


Creating an Object that can be Consumed by ObjectDataSource

Telerik Reporting Q3 2008 Send comments on this topic.
Creating an Object that can be Consumed by ObjectDataSource
See Also
Designing Reports > Understanding Report Items > Chart > Building Charts > Creating an Object that can be Consumed by ObjectDataSource

Glossary Item Box

See the code below for an example object that can be consumed by ObjectDataSource. Your object needs to be marked with the DataObjectAttribute for the object to be seen by Data Source Configuration Wizard. It also needs a method to select data marked by the DataObjectMethodAttribute (see GetProducts() method in the code sample).

See Data Binding Chart to an ObjectDataSource for an example of how to use this object for binding.

[C#] A Business Object that can be consumed by ObjectDataSource Copy Code
using System;
// Supports ConfigurationManager
using System.Configuration;
// Supports DataObjectAttribute and DataObjectMethodAttribute
using System.ComponentModel;
// Supports IEnumerable
using System.Collections;
// supports sql command, connection, reader
using System.Data.SqlClient;
namespace RadChartBinding
{
[DataObjectAttribute]
public class ProductsBO
{
[DataObjectMethodAttribute(DataObjectMethodType.Select, true)]
public static IEnumerable GetProducts()
{
SqlCommand command = new SqlCommand();
command.Connection = new SqlConnection(
ConfigurationManager.ConnectionStrings["NorthwindConnectionString"].ConnectionString);
command.CommandText =
"SELECT CategoryName, SUM(ProductSales) AS TotalSales FROM [Product Sales for 1997] GROUP BY CategoryName";
command.Connection.Open();
SqlDataReader reader = command.ExecuteReader();
return reader;
}
}
}

[VB] A Business Object that can be consumed by ObjectDataSource Copy Code
Imports System
' Supports ConfigurationManager
Imports System.Configuration
' Supports DataObjectAttribute and DataObjectMethodAttribute
Imports System.ComponentModel
' Supports IEnumerable
Imports System.Collections
' supports sql command, connection, reader
Imports System.Data.SqlClient
Namespace RadChartBinding
<DataObjectAttribute()> _
Public Class ProductsBO
<DataObjectMethodAttribute(DataObjectMethodType.[Select], True)> _
Public Shared Function GetProducts() As IEnumerable
Dim command As New SqlCommand()
command.Connection = New SqlConnection(ConfigurationManager.ConnectionStrings("NorthwindConnectionString").ConnectionString)
command.CommandText = "SELECT CategoryName, SUM(ProductSales) AS TotalSales FROM [Product Sales for 1997] GROUP BY CategoryName"
command.Connection.Open()
Dim reader As SqlDataReader = command.ExecuteReader()
Return reader
End Function
End Class
End Namespace

See Also

Data Binding Chart to an ObjectDataSource
Binding to ObjectDataSource at Run-Time


Binding to ObjectDataSource at Run-Time

Telerik Reporting Q3 2008 Send comments on this topic.
Binding to ObjectDataSource at Run-Time
See Also
Designing Reports > Understanding Report Items > Chart > Building Charts > Binding to ObjectDataSource at Run-Time

Glossary Item Box

Once a business object with appropriate attributes has been created you can bind to it in code at run-time. The steps are:

  • Set the ObjectDataSource TypeName property to name of the object class, in this example "ChartBinding.ProductsBO" (Be sure to qualify the class name with the namespace).
  • Set the SelectMethod to the method marked by the DataObjectMethodAttribute.

The code below demonstrates binding to an ObjectDataSource that consumes an example object defined in the topic "Creating an Object that can be consumed by ObjectDataSource".

[C#] Binding to an ObjectDataSource Copy Code
ObjectDataSource ods = new ObjectDataSource();
ods.SelectMethod = "GetProducts";
ods.TypeName = "ChartBinding.ProductsBO";
chart.DataSource = ods.Select();
chart.Series[0].DataYColumn = "QuantityInStock";
chart.PlotArea.XAxis.DataLabelsColumn = "Name";
chart.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Font
= new System.Drawing.Font("Ariel", 8);
[VB] Binding to an ObjectDataSource Copy Code
Dim ods As New ObjectDataSource()
ods.SelectMethod = "GetProducts"
ods.TypeName = "RadChartBinding.ProductsBO"
chart.DataSource = ods.[Select]()
chart.Series(0).DataYColumn = "QuantityInStock"
chart.PlotArea.XAxis.DataLabelsColumn = "Name"
chart.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Font = New System.Drawing.Font("Ariel", 8)

See Also

Data Binding Chart to an ObjectDataSource
Creating an Object that can be Consumed by ObjectDataSource
Binding to ObjectDataSource at Run-Time


Styling Chart Elements

Telerik Reporting Q3 2008 Send comments on this topic.
Styling Chart Elements
Designing Reports > Understanding Report Items > Chart > Styling Charts > Styling Chart Elements

Glossary Item Box

The Chart offers a set of properties to modify the look and feel of its elements. See those elements marked on the image below consider the table showing where their customization properties are located in the chart properties grid.

Rad Chart Elements

Element

Properties

a. Chart Title
  • Elements -> ChartTitle -> Appearance
  • Elements -> ChartTitle -> TextBlock

b. Legend
  • Elements -> Legend -> Appearance

    • c. Legend TextBlock (Legend Title)
  • Elements -> Legend -> TextBlock
    • d. Y Axis
    • PlotArea -> YAxis -> Appearance

    e. Y Axis Label (Axis Title)
  • PlotArea -> YAxis -> AxisLabel

    • f. Y Axis Major Tick
  • PlotArea -> YAxis -> Appearance -> MajorTick

    • g. Y Axis Major GridLine
  • PlotArea -> YAxis -> Appearance -> MajorGridLines

    • h. Y Axis Minor Tick
    • PlotArea -> YAxis -> Appearance -> MinorTicк

    i. Y Axis Minor GridLine
    • PlotArea -> YAxis -> Appearance -> MinorGridLines

    j. Y Axis Label (Digit)
  • PlotArea -> YAxis -> Appearance -> LabelAppearance

    • k. X Axis
    • PlotArea -> XAxis -> Appearance

    l. X Axis Label (Axis Title)
  • PlotArea -> XAxis -> AxisLabel

    • m. X Axis Major Tick
    • PlotArea -> XAxis -> Appearance -> MajorTick

    n. X Axis Major GridLine
    • PlotArea -> XAxis -> Appearance -> MajorGridLines

    o. X Axis Label (Digit)
  • PlotArea -> XAxis -> Appearance -> LabelAppearance

    • p. Series 1
    • Data -> Series -> [series name] -> Appearance -> Appearance

    q. Series 2
  • Data -> Series -> [series name] -> Appearance -> Appearance

    • r. Series Item Label
    • Data -> Series -> [series name] -> Appearance -> Appearance -> TextAppearance

    s. PlotArea
  • Elements -> PlotArea -> Appearance

    • Common Appearance Properties

    All chart elements have common appearance settings, which are:

    • Border – border width, color and style
    • Corners – corner style and size
    • Dimensions – width, height, margin, padding
    • FillStyle – background color, image and gradients
    • Position
    • Shadow – color, distance and position
    • Visible – true or false


Setting The Background

Telerik Reporting Q3 2008 Send comments on this topic.
Setting The Background
Designing Reports > Understanding Report Items > Chart > Styling Charts > Setting The Background

Glossary Item Box

The Chart offers a variety of ways to define backgrounds. Here are the main scenarios:

1. Solid color

… -> FillStyle -> FillType -> Solid

… -> FillStyle -> MainColor ->

2. Simple 2-color gradient

… -> FillStyle -> FillType : Gradient

… -> FillStyle -> MainColor ->

… -> FillStyle -> SecondColor ->

… -> FillStyle -> FillSettings -> GradientMode ->

3. Complex Gradient

… -> FillStyle -> FillType -> ComplexGradient

… -> FillStyle -> FillSettings -> ComplexGradient -> Collection ->

… -> FillStyle -> FillSettings -> GradientAngle ->

4. Hatch (2-color pattern)

… -> FillStyle -> FillType -> Hatch

… -> FillStyle -> MainColor ->

… -> FillStyle -> SecondColor ->

… -> FillStyle -> FillSettings -> HatchStyle ->

5. Custom Image

… -> FillStyle -> FillType -> Image

… -> FillStyle -> FillSettings -> BackgroundImage ->

… -> FillStyle -> FillSettings -> ImageAlign ->

… -> FillStyle -> FillSettings -> ImageDrawMode ->

… -> FillStyle -> FillSettings -> ImageFlip ->

6. Opacity

You can achieve opacity by specifying an alpha transparency to the color, in addition to the red-green-blue values. The alpha value should come first, like this:

[transparency level0 - 255]; [red 0 - 255]; [green 0 - 255]; [blue 0 - 255]

The greater the opacity value, the less transparent the background is.


Custom Appearance Properties

Telerik Reporting Q3 2008 Send comments on this topic.
Custom Appearance Properties
Designing Reports > Understanding Report Items > Chart > Styling Charts > Custom Appearance Properties

Glossary Item Box

Apart from the common properties, every chart element may have unique appearance properties, e.g. “Figure”, “Rotation Angle”, “Text Properties”, etc. Here is a quick reference of the unique appearance properties of the chart and its elements.

Chart

Set dimensions
  • Layout -> Width
  • Layout -> Height
    • Set the chart type
    • Appearance -> DefaultType
    Set series orientation
    • Appearance -> Series Orientation
    Set a series palette
    • Appearance -> SeriesPalette
    • Appearance -> CustomPalettes
    Set a predefined chart skin
    • Appearance -> Skin
    Set a bar overlap ratio
    How much two adjacent bars overlap each other
    • Appearance -> Appearance -> BarOverlapPercent
    Set bar width
    Define how much space will occupy all bars located on the same spot on the X Axis. The value represents percent of the total available space for that X Axis value.
    • Appearance -> Appearance -> BarWidthPercent
    Set text quality
    • Appearance -> Appearance -> TextQuality
    Set alternative text (accessibility feature)
    • Appearance -> AlternativeText
    Set the image MIME type (file type)
    • Settings -> ChartImageFormat

    Chart title

    Set the form
    • Elements -> ChartTitle -> Appearance -> Figure
    Set a rotation angle
    • Elements -> ChartTitle -> Appearance -> RotationAngle
    Style the chart title marker
    • Elements -> ChartTitle -> Marker -> Appearance

    Legend

    Style the legend title
    • Elements -> Legend -> TextBlock
    Style the legend marker
    • Elements -> Legend -> Marker -> Appearance
    Style the legend items’ appearance
    • Elements -> Legend -> Appearance -> ItemAppearance
    • Elements -> Legend -> Appearance -> ItemMarkerAppearance
    • Elements -> Legend -> Appearance -> ItemTextAppearance
    Set legend items’ orientation
    • Elements -> Legend -> Appearance -> Overflow
    Set a rotation angle
    • Elements -> Legend -> Appearance -> RotationAngle

    PlotArea and Axes

    Style the empty series (no data) message
    • Elements -> PlotArea -> EmptySeriesMessage
    Set intelligent series’ label positioning
    • Elements -> PlotArea -> IntelligentLabelsEnabled
    Set the axis’ layout mode
    Determine whether the axis values’ positions match the gridlines or the values are places between the gridlines
    • Elements -> PlotArea -> [axis] -> LayoutMode
    Style the axis’ maximum value end
    • Elements -> PlotArea -> axis [axis] -> Appearance -> Cap


Step-By-Step Skinning Example

Telerik Reporting Q3 2008 Send comments on this topic.
Step-By-Step Skinning Example
Designing Reports > Understanding Report Items > Chart > Styling Charts > Step-By-Step Skinning Example

Glossary Item Box

Here is a list of the steps one has to make in order to style Chart to look like the image we used when describing the Chart elements. We start with a plain chart with no visual properties defined.

  1. Styling the chart’s borders and background
    1. Appearance -> Appearance -> Border -> Color : 0; 66; 110
    2. Appearance -> Appearance -> Border -> Width : 5
    3. Appearance -> Appearance -> FillStyle -> FillType : Gradient
    4. Appearance -> Appearance -> FillStyle -> FillSettings -> GradientMode : Center
    5. Appearance -> Appearance -> FillStyle -> MainColor : 35; 189; 254
    6. Appearance -> Appearance -> FillStyle -> SecondColor : 26; 120; 179
  2. Styling the title
    1. Elements -> ChartTitle -> Appearance -> Border -> Visible : False
    2. Elements -> ChartTitle -> Appearance -> FillStyle -> MainColor : None / Transparent
    3. Elements -> ChartTitle -> TextBlock -> Appearance -> TextProperties -> Color : White
    4. Elements -> ChartTitle -> TextBlock -> Appearance -> TextProperties -> Font : Verdana; 14pt
    5. Elements -> ChartTitle -> Appearance ->Position -> AlignedPosition : TopLeft
    6. Elements -> ChartTitle -> Appearance -> Dimensions -> Margins : 4%; 10px; 14px; 8%
  3. Styling the legend
    1. Elements -> Legend -> Appearance -> FillStyle -> MainColor : None / Transparent
    2. Elements -> Legend -> Appearance -> Border -> Visible : False
    3. Elements -> Legend -> Appearance -> ItemTextAppearance -> TextProperties -> Color : White
    4. Elements -> Legend -> TextBlock -> Text : Legend
    5. Elements -> Legend -> TextBlock -> Visible : True
    6. Elements -> Legend -> TextBlock -> Appearance -> TextProperties -> Color : LightSkyBlue
    7. Elements -> Legend -> TextBlock -> Appearance -> Position -> AlignedPosition : Top
    8. Elements -> Legend -> Appearance -> Position -> AlignedPosition -> BottomRight
    9. Elements -> Legend -> Appearance -> Dimensions -> Margins : 1px; 3%; 12%; 1px
  4. Styling the plotarea
    1. Elements -> PlotArea -> Appearance -> Border -> Color : 97; 180; 223
    2. Elements -> PlotArea -> Appearance -> FillStyle -> MainColor : 50; 255; 255; 255
    3. Elements -> PlotArea -> Appearance -> Dimensions -> Margins : 18%; 90px; 15%; 10%
  5. Styling the X Axis
    1. Elements -> PlotArea -> XAxis -> Appearance -> Color : 96; 164; 205
    2. Elements -> PlotArea -> XAxis -> Appearance -> MajorGridLines -> Color : 120; 209; 248
    3. Elements -> PlotArea -> XAxis -> Appearance -> MajorTick -> Color : 96; 164; 205
    4. Elements -> PlotArea -> XAxis -> Appearance -> TextAppearance -> TextProperties -> Color : White
    5. Elements -> PlotArea -> XAxis -> AxisLabel -> TextBlock -> Text -> X Axis
    6. Elements -> PlotArea -> XAxis -> AxisLabel -> TextBlock -> Appearance -> TextProperties -> Color : LightSkyBlue
    7. Elements -> PlotArea -> XAxis -> AxisLabel -> Appearance -> Dimensions -> Paddings : 1px; 1px; 10%; 1px
  6. Styling the Y Axis
    1. Elements -> PlotArea -> YAxis -> Appearance -> Color : 95; 165; 208
    2. Elements -> PlotArea -> YAxis -> Appearance -> MajorGridLines -> Color : 120; 209; 248
    3. Elements -> PlotArea -> YAxis -> Appearance -> MajorTick -> Color : 95; 165; 208
    4. Elements -> PlotArea -> YAxis -> Appearance -> MajorGridLines -> Color : 120; 209; 248
    5. Elements -> PlotArea -> YAxis -> Appearance -> MinorTick -> Color : 95; 165; 208
    6. Elements -> PlotArea -> YAxis -> Appearance -> TextAppearance -> TextProperties -> Color : White
    7. Elements -> PlotArea -> YAxis -> AxisLabel -> TextBlock -> Text -> Y Axis
    8. Elements -> PlotArea -> YAxis -> AxisLabel -> TextBlock -> Appearance -> TextProperties -> Color : LightSkyBlue
  7. Styling the data series
    1. Data -> Series -> Series 1 -> Appearance -> Appearance -> Border -> Color : 153; 209; 248
    2. Data -> Series -> Series 1 -> Appearance -> Appearance -> FillStyle -> MainColor : 213; 247; 255
    3. Data -> Series -> Series 1 -> Appearance -> Appearance -> FillStyle -> SecondColor : 157; 217; 238
    4. Data -> Series -> Series 1 -> Appearance -> Appearance -> TextAppearance -> TextProperties -> Color : White
    5. Data -> Series -> Series 2 -> Appearance -> Appearance -> Border -> Color : 67; 181; 229
    6. Data -> Series -> Series 2 -> Appearance -> Appearance -> FillStyle -> MainColor : 136; 221; 246
    7. Data -> Series -> Series 2 -> Appearance -> Appearance -> FillStyle -> SecondColor : 59; 161; 197
    8. Data -> Series -> Series 2 -> Appearance -> Appearance -> TextAppearance -> TextProperties -> Color : White


How Do I extend the Displayable Area for YAxis Data?

Telerik Reporting Q3 2008 Send comments on this topic.
How Do I extend the Displayable Area for YAxis Data?
Designing Reports > Understanding Report Items > Chart > How To > How Do I extend the Displayable Area for YAxis Data?

Glossary Item Box

"My data touches the upper boundary of the plot area but that makes the data harder to see. How do I extend the viewable area along the YAxis?"

Assign the YAxis AxisMode property. By default the ChartYAxisMode property value is Normal and the YAxis data fills the available space.

myChart.PlotArea.YAxis.AxisMode = ChartYAxisMode.Normal;

ChartYAxisMode is Normal

If you set the ChartYAxisMode to Extended, additional area is placed above the highest data point to make the chart easier to read.

myChart.PlotArea.YAxis.AxisMode = ChartYAxisMode.Extended;

  ChartYAxisMode is Extended


How Do I add Axis Labels Programmatically?

Telerik Reporting Q3 2008 Send comments on this topic.
How Do I add Axis Labels Programmatically?
Designing Reports > Understanding Report Items > Chart > How To > How Do I add Axis Labels Programmatically?

Glossary Item Box

To add labels along an Axis programmatically:

  • Set AutoScale to false.
  • Add a range of items to the axis.
  • Populate the Items.

[C#] Adding Axis Labels Copy Code
Chart.PlotArea.XAxis.AutoScale = false;
Chart.PlotArea.XAxis.AddRange(1, 7, 1);
Chart.PlotArea.XAxis[0].TextBlock.Text = "Mon";
Chart.PlotArea.XAxis[1].TextBlock.Text = "Tue";
Chart.PlotArea.XAxis[2].TextBlock.Text = "Wed";
Chart.PlotArea.XAxis[3].TextBlock.Text = "Thu";
Chart.PlotArea.XAxis[4].TextBlock.Text = "Fri";
Chart.PlotArea.XAxis[5].TextBlock.Text = "Sat";
Chart.PlotArea.XAxis[6].TextBlock.Text = "Sun";
[VB] Adding Axis Labels Copy Code
Chart.PlotArea.XAxis.AutoScale = False
Chart.PlotArea.XAxis.AddRange(1, 7, 1)
Chart.PlotArea.XAxis(0).TextBlock.Text = "Mon"
Chart.PlotArea.XAxis(1).TextBlock.Text = "Tue"
Chart.PlotArea.XAxis(2).TextBlock.Text = "Wed"
Chart.PlotArea.XAxis(3).TextBlock.Text = "Thu"
Chart.PlotArea.XAxis(4).TextBlock.Text = "Fri"
Chart.PlotArea.XAxis(5).TextBlock.Text = "Sat"
Chart.PlotArea.XAxis(6).TextBlock.Text = "Sun"


How Do I Assign Individual Colors to Bars?

Telerik Reporting Q3 2008 Send comments on this topic.
How Do I Assign Individual Colors to Bars?
Designing Reports > Understanding Report Items > Chart > How To > How Do I Assign Individual Colors to Bars?

Glossary Item Box

"I need each bar in a bar chart to be a different color. How do I do this?"

By default the chart is designed so that all bars from a series have the same colors. If you need each to have a different color, loop through each chart series item and assign them a color from an array. This should be done after binding the chart, so the chart series items are available.

Colors Assigned to Individual Items

[C#] Assigning Color to Chart Items Copy Code
public ChartReport()
{
/// <summary>
/// Required for telerik Reporting designer support
/// </summary>
InitializeComponent();
//
// TODO: Add any constructor code after InitializeComponent call
//
Color[] barColors = new Color[8]{
Color.Purple,
Color.SteelBlue,
Color.Aqua,
Color.Yellow,
Color.Navy,
Color.Green,
Color.Blue,
Color.Red
};
int i = 0;
foreach (ChartSeriesItem item in chart1.Series[0].Items)
{
item.Appearance.FillStyle.MainColor = barColors[i++];
}
}
}
[VB] Assigning Color to Chart Item Copy Code
Public Sub New()
''' <summary>
''' Required for telerik Reporting designer support
''' </summary>
InitializeComponent()
'
' TODO: Add any constructor code after InitializeComponent call
'
Dim barColors As Color() = New Color(8) {Color.Purple, Color.SteelBlue, Color.Aqua, Color.Yellow, Color.Navy, Color.Green, _
Color.Blue, Color.Red}

For Each item As ChartSeriesItem In chart1.Series(0).Items
item.Appearance.FillStyle.MainColor = barColors(System.Math.Max(System.Threading.Interlocked.Increment(i),i - 1))
Next
End If
End Sub


How do I make colors display with partial transparency?

Telerik Reporting Q3 2008 Send comments on this topic.
How do I make colors display with partial transparency?
Designing Reports > Understanding Report Items > Chart > How To > How do I make colors display with partial transparency?

Glossary Item Box

"If I have several series that overlap and I want partial transparency so I can see all series at one time (without it being a stacked chart), how do I set a color to be transparent?"

When defining the color, add an "alpha" channel, i.e. a percentage of transparency to the beginning of the array that defines the color. For example:

255, 0, 0 = Red

80, 255, 0, 0 = Red that is 80% transparent.

In the example below both series have a main color with a transparency of 90%.


Multiple Chart Types in a Single Chart

Telerik Reporting Q3 2008 Send comments on this topic.
Multiple Chart Types in a Single Chart
Designing Reports > Understanding Report Items > Chart > How To > Multiple Chart Types in a Single Chart

Glossary Item Box

The Chart allows you to combine several chart types in a single chart. You can use the ChartSeries Collection Editor at design-time to create the ChartSeries and set the respective ChartSeriesType. You can also add chart series and set chart type programmatically.

To designate dissimilar chart types in a single chart at design time, click on a series, then select the Type property from the drop down list.

Setting the Series Chart Type

To assign chart types to a series at run-time programmatically you can pass the ChartSeriesType in the constructor or assign the ChartSeriesType after the series is constructed. The example below passes three chart series types to the constructor.

[C#] Assigning ChartSeriesType Copy Code
ChartSeries chartSeries =
new ChartSeries("Average Temperatures", ChartSeriesType.Bar);
ChartSeries chartSeries2 =
new ChartSeries("Maximum Temperatures", ChartSeriesType.Line);
ChartSeries chartSeries3 =
new ChartSeries("Minimum Temperatures", ChartSeriesType.Bubble);
[VB] Assigning ChartSeriesType Copy Code
Dim chartSeries As New ChartSeries("Average Temperatures", ChartSeriesType.Bar)
Dim chartSeries2 As New ChartSeries("Maximum Temperatures", ChartSeriesType.Line)
Dim chartSeries3 As New ChartSeries("Minimum Temperatures", ChartSeriesType.Bubble)

Use the Axis.Range property to set minimum values, maximum values and step amount for each axis. The screen shot below shows three chart series types in the same chart. See below for the full source.

Multiple Chart Types in a Single Chart


Creating a Report

Telerik Reporting Q3 2008 Send comments on this topic.
Creating a Report
Designing Reports > Creating a Report

Glossary Item Box

Create the Class Library for the Reports

To create even simple reports you start by creating a class library to contain your report and a web or windows application to display the report.

It is possible to put the report definition and viewer in the same application but this route is not recommended. See this topic on best practices for more information.
  1. Select File | New | Project from the Visual Studio File menu. Select the Class Library project, give it a name and location. Click the OK button to close the dialog.

Creating the Class Library

  2. Right-click the project context menu and select Add | New Item | Telerik Report. Enter a name for the report class and click the Add button to close the dialog. In this example we name the report class file "ProductList.cs".

  3. The Telerik Report Wizard will appear automatically to help you select data and design your report quickly. Once you have the basic report layout you can go back to edit the report, add data columns and tweak the format. Click the Next button.

  4. On the Report Choice Page of the Report Wizard, select New Report and click the Next button.

  5. On the Choose Data Source page of the Report Wizard, select New Data Source and click the Next button.

  6. On the Choose a Data Source Type page of the Report Wizard select the Database icon and click the Next button.

  7. The standard Add Connection dialog will display.
  • In the Server Name edit enter "(local)\sqlexpress".
  • In Select or enter a database name choose the AdventureWorks database.
  • Optionally, you can click the "Test Connection" button to verify the connection.
  • Click OK to close the dialog. Note: The AdventureWorks database installs with Telerik Reporting and so should always be available to test with. If you are missing the samples database try repairing the Telerik Reporting installation.

  8. On the Choose a Data Connection page of the Reports Wizard select your new database connection for AdventureWorksT from the drop down list. Note: The machine name will be the name of the machine you are developing on, but shown in the figure below as "ra". Click the Next button.

  9. The Choose Your Database Objects page of the Reports Wizard will display next.
  • Click the Query Builder button.
  • In the Add Table dialog select "Product", "ProductInventory", "ProductPhoto" and "ProductProductPhoto" from the list of tables. Note: You can hold down the control key and click each of the tables to select them all at one time.
  • Click the Add button to close the dialog.

  • On the Query Builder select the fields shown in the figure below. In the Product table select "Name", "ProductNumber" and "ReorderPoint". In ProductPhoto select the "ThumbNailPhoto" column. In the ProductInventory table select the "Quantity" column.
  • Click the OK button to close the dialog.

  • In the Choose your Database Objects page of the Report Wizard leave the values shown and click the Next button. On the next page choose Standard Report Type and click the Next button.

  10. The Design Data Layout page of the Report Wizard allows you to assign database fields to sections of the report. The Report Wizard automatically places and formats the database fields in the appropriate report sections.
  • Select from the Available Fields list on the left side of the page.
  • Select "Name", "ProductNumber", "ReorderPoint" and "Quantity".
  • After selecting each field, click the Detail button to add those columns to the detail listing of the report.
  • Click the Next button.

  11. On the Choose Report Layout page of the Report Wizard unselect the Adjust report items to fit available space checkbox. Click the Next button.

  12. On the Choose Report Style page of the Report Wizard select "Civic" from the Style Sheets list on the left side of the page. Notice the style changes in the Preview portion on the right side of the page.

  13. On the Completing the Wizard page of the Report Wizard you can review the settings for the report and click the Finish button.

The initial report layout appears in the design view in Visual Studio.

Notice that the wizard has automatically provided:

  • Data bound fields in the detail section of the report.
  • Styled page and column titles.
  • A page footer with standard date and page number output.

  14. Rebuild the project.
  15. Click the Preview tab of the designer to view your report.

From here you can:

  • Extend the Simple Report Design to include conditional formatting, Shape and PictureBox report items. This topic also introduces in-place editing, copying and pasting styles, using the Data Explorer and Report Explorer.
  • Create a Windows application to display the reports.

To learn more about displaying your report in a viewer see the Displaying Reports in the Windows Viewer Quickstart.


Previewing Reports in Design Time

Telerik Reporting Q3 2008 Send comments on this topic.
Previewing Reports in Design Time
Designing Reports > Previewing Reports in Design Time

Glossary Item Box

Any time you have a report open in design view in Visual Studio .NET, you can preview the way that the report will look as either a Windows Forms report or an Web report.

To Preview a Report in Windows Forms View

  1. Open the report in design view.
  2. Select the Preview tab at the top of the design view window.

To Preview a Report in Web View

  1. Open the report in design view.
  2. Select the Html Preview tab at the top of the design view window.


Placing and Sizing Report Items

Telerik Reporting Q3 2008 Send comments on this topic.
Placing and Sizing Report Items
See Also
Designing Reports > Placing and Sizing Report Items

Glossary Item Box

Content on reports is displayed in report items. To use report items, you select them from the Toolbox and place them on your report.

To Place a Report Item on a Report

  1. Open the report in design view.
  2. Expand the Telerik Reporting tab of the Toolbox.
  3. Select the report item that you want to place.
  4. Drag the report item from the Toolbox to the report's design surface. Alternatively, you may select the section of the report where you want the report item to appear by clicking the section header, and then double-click the report item in the Toolbox. Or you can select the report item in the toolbox and draw a bounding rectangle to indicate the area that the report item should occupy.

To Move a Report Item

Move the mouse over the report item until you see the cross hair cursor (see image above), then click and drag the report item.

To Change the Size of a Report Item

  1. Click on the report item to select it.
  2. Click and drag one of the size handles on the edge of the report item to the desired size.

See Also

Understanding Report Items


Dynamic Layout (Dock and Anchor)

Telerik Reporting Q3 2008 Send comments on this topic.
Dynamic Layout (Dock and Anchor)
See Also
Designing Reports > Dynamic Layout (Dock and Anchor)

Glossary Item Box

Anchoring

Anchoring is used to dynamically resize report items with their container (for example section or panel). Simply put, an anchor maintains the distance between the edge of the report item and the corresponding edge of the container in which it is anchored. An item can be anchored to any combination of the edges of its container. If the item is anchored to two opposite edges of its container, it is resized when the container is resized. For example, if you anchor an item both to the top and bottom edges of its parent section, and the section height increases because of its content (for example a text box with longer text grows vertically), the item tries to keep the distance of its top edge to the top edge of the section and at the same time it tries to keep the distance of its bottom edge to the bottom edge of the section. By default, report items are not anchored.

Docking

A report item can also be docked to its container (for example a section or a panel). Docking a report item causes its edges to adhere to the edges of its container. When a report item is docked to an edge of its container, it is always positioned to flush against that edge when the container is resized.

Like with anchoring, you specify an edge where the item is docked, but unlike anchoring, the item is always resized to cover the edge it is docked to. If you dock two items to the same edge, then they will be "stacked up" one next to the other and the item with the lowest z-order(the 1st item in the items collection is considered with the lowest z-order and the last item is with the highest z-order) will be positioned closest to the edge. You can also use docking to indicate that an item should occupy the remaining area of a container which is not occupied by other items (fill).

Note that anchoring and docking are really effective only when the container can be resized. With regard to Telerik Reporting report sections and panels usually contain all report items in a report and there are a couple of reasons for why they can grow:

  • A child TextBoxitem with CanGrowenabled can grow in height to accommodate the longer text that it should display;
  • A SubReportitem can grow in width and height according to the source report it contains;
  • A PictureBoxitem with auto sizing enabled (PictureBox.SizingMode= AutoSize) can grow to fit the bigger image when needed.

Table Layout

Using Anchoring and Docking allows you to create table-like report layouts – all items inside a section can grow equally regardless of their content thus forming the “columns” of a table.

One way to achieve a table layout is by docking all of your report items to the left. In this way they will stick to the left leaving no empty space between them. They will also stick to the top and bottom edges of the section. You can then select all report items that will be part of the table and set a border in order to create a real table-like appearance.

See Also

Anchor Property
Dock Property


Creating Page Headers and Footers

Telerik Reporting Q3 2008 Send comments on this topic.
Creating Page Headers and Footers
See Also
Designing Reports > Creating Page Headers and Footers

Glossary Item Box

By default, every new report is created with a page header section and a page footer section.

  • Any control you place in the page header section is rendered at the top of each page of the report's output.
  • Any control you place in the page footer section is rendered at the bottom of each page of the report's output.

To Hide or Show the Page Header or Page Footer Section

  1. Right-click in the empty space around the sections.
  2. Select Page Header or Page Footer.

To Set the Properties for Page Headers and Footers

Select Page Header or Footer section to set the following properties:

  • PrintOnFirstPage: Set to False to suppress the page header on the first page of the report.
  • PrintOnLastPage: Set to False to suppress the page header on the last page of the report.
  • Visible: Set to False to prevent the page header from rendering. Note that this property only has an effect at runtime; the header will always be visible at design time.
  • ConditionalFormatting: A collection containing rules and formatting to be applied to this report item if the rules succeed. Clicking the property editor ellipses for this property displays the Conditional Formatting Rules Dialog.

See Also

PageFooterSection Class
PageHeaderSection Class


Creating Report Headers and Footers

Telerik Reporting Q3 2008 Send comments on this topic.
Creating Report Headers and Footers
See Also
Designing Reports > Creating Report Headers and Footers

Glossary Item Box

Reports can contain report headers and footers. By default, new reports are created without these sections.

  • Any control you place in the report header section is rendered once at the top of the entire report's output, but after the first page header section (if any).
  • Any control you place in the report footer section is rendered once at the bottom of the entire report's output, but before the last page footer section (if any).

To Hide or Show the Report Header or Report Footer Section

  1. Right-click on any section header in the report, or in the empty space around the sections.
  2. Select Report Header or Report Footer.

To Set the Properties for Report Headers and Footers

Select the Report Header or Footer section to set the following properties:

  • KeepTogether: Set to True to keep the entire section together on one printed page if possible. If there is not enough space on the current page, then rendering will skip to the top of the next page.
  • PageBreak: Specifies where to put page breaks relative to this group. You can set this to None, Before, After, or BeforeAndAfter.
  • Visible: Set to False to prevent the report header from rendering. Note that this property only has an effect at runtime; the header will always be visible at design time.
  • ConditionalFormatting: A collection containing rules and formatting to be applied to this report item if the rules succeed. Clicking the property editor ellipses for this property displays the Conditional Formatting Rules Dialog.

    • See Also

    ReportFooterSection Class
    ReportHeaderSection Class


Connecting Data to a Report

Telerik Reporting Q3 2008 Send comments on this topic.
Connecting Data to a Report
See Also
Designing Reports > Connecting Data to a Report

Glossary Item Box

For a report to be useful, it will almost always need to be connected to a data source. There are several ways you can connect a report to a data source. For example:

  • Specify the data source using the Report Wizard.
  • Drag a data adapter to the report's design surface.
  • Set a data source programmatically at run time.
  • use the NeedDataSource report event

Reports can use any of the following data sources:

  • Any component that implements IEnumerable, including System.Array, IList, ICollection, and BindingSource
  • Any component that implements IListSource, including DataTable and DataSet
  • Any component that implements ITypedList, including DataView and DataViewManager
  • Any component that implements IDbDataAdapter, including SqlDataAdapter and OleDbDataAdapter

If the DataSource reference contains more than one table, you must set the DataMember property to a string that specifies the table to bind to.

After setting a report's data source, you can connect individual report items to the data source by using item binding expressions.

See Also

DataSource Property
DataMember Property


Adding a Data Source with the Data Source Wizard

Telerik Reporting Q3 2008 Send comments on this topic.
Adding a Data Source with the Data Source Wizard
Designing Reports > Connecting Data to a Report > Adding a Data Source with the Data Source Wizard

Glossary Item Box

The Data Source Wizard is activated by clicking the DataSource property of a Report at design-time. The DataSource property lists components on the Report Designer that implement IList, IListSource or array.

Using the Data Source Wizard

If the report is in a Web Site, rather than a ASP.NET Web Application Project, an exception may be thrown. That is because the Web Site does not load some of the assemblies needed by the Wizard

Before assigning the Report DataSource property you need to create a SqlDataAdapter, Dataset or other eligible component and add it to the Report Designer. See Adding DataSources with a Data Adapter for an example walkthrough using a SqlDataAdapter at design-time.

You can also assign an adapter at run-time in the Report constructor after the call to IntializeComponent().

this.DataSource = this.sqlDataAdapter1;


Adding a Data Source with a Data Adapter

Telerik Reporting Q3 2008 Send comments on this topic.
Adding a Data Source with a Data Adapter
Designing Reports > Connecting Data to a Report > Adding a Data Source with a Data Adapter

Glossary Item Box

You can add a data source to a report by setting the DataSource property of the report to the name of a DataAdapter component (such as a SqlDataAdapter, OdbcDataAdapter, or OleDbDataAdapter). For example, to use a SqlDataAdapter to specify the data source for a report, follow these steps:

  1. You will need a SqlDataAdapter component from the Toolbox. By default, this component is not visible in the design view of a Telerik Report. Right-click the Data tab in the Toolbox and select Choose Items.
  2. In the Choose Toolbox Items dialog box, select the check box for the SqlDataAdapter item. Click OK.
  3. Drag a SqlDataAdapter component from the Toolbox to anywhere on the report.
  4. In the Data Adapter Configuration Wizard, click New Connection.
  5. In the Add Connection dialog box, enter the server name and log on information for your SQL Server. Select or enter a database name.
  6. Click OK.
  7. Click Next.
  8. Select Use SQL Statements.
  9. Click Next.
  10. Type a SQL statement that specifies the data for the report. Click Finish.
  11. Select the Report (to do this easily, click in the box at the upper left where the rulers meet).
  12. Set the DataSource property of the Report to sqlDataAdapter1.


Adding a Data Source Programmatically

Telerik Reporting Q3 2008 Send comments on this topic.
Adding a Data Source Programmatically
Designing Reports > Connecting Data to a Report > Adding a Data Source Programmatically

Glossary Item Box

You can add a data source to your report programmatically at run time by setting the report's DataSource property. For example, this code sets the property when the report is initialized:

[C#] Assigning a DataSource programmatically Copy Code
public Report1()
{
InitializeComponent();
sqlSelectCommand1 = new System.Data.SqlClient.SqlCommand();
sqlDataAdapter1 = new System.Data.SqlClient.SqlDataAdapter();
sqlConnection1 = new System.Data.SqlClient.SqlConnection();
sqlConnection1.ConnectionString =
"Data Source=(local)\\SQLEXPRESS;Initial Catalog=AdventureWorksT;Integrated Security=True";
sqlSelectCommand1.CommandText = "SELECT * FROM Production.Product";
sqlSelectCommand1.Connection = sqlConnection1;
sqlDataAdapter1.SelectCommand = sqlSelectCommand1;
this.DataSource = sqlDataAdapter1;
}
[VB] Assigning a DataSource programmatically Copy Code
Public Sub New()
InitializeComponent()
sqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
sqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
sqlConnection1 = New System.Data.SqlClient.SqlConnection()
sqlConnection1.ConnectionString = "Data Source=(local)\SQLEXPRESS;Initial Catalog=AdventureWorksT;Integrated Security=True"
sqlSelectCommand1.CommandText = "SELECT * FROM Production.Product"
sqlSelectCommand1.Connection = sqlConnection1
sqlDataAdapter1.SelectCommand = sqlSelectCommand1
Me.DataSource = sqlDataAdapter1
End Sub


Adding a Data Source through NeedDataSource report event

Telerik Reporting Q3 2008 Send comments on this topic.
Adding a Data Source through NeedDataSource report event
Designing Reports > Connecting Data to a Report > Adding a Data Source through NeedDataSource report event

Glossary Item Box

The example below shows the NeedDataSource event assigning the report DataSource at runtime. This event occurs at the start of report processing if the report has no data source set.

[C#] The NeedDataSource Event Handler Copy Code
private void Report1_NeedDataSource(object sender, System.EventArgs e)
{
string sql =
@"SELECT Production.Product.Name, Production.Product.ProductNumber FROM Production.Product";
string connectionString =
"Data Source=RA\\SQLEXPRESS;Initial Catalog=AdventureWorksT;Integrated Security=True";
SqlDataAdapter adapter = new SqlDataAdapter(sql, connectionString);
DataSet dataSet = new DataSet();
adapter.Fill(dataSet);
(sender as Telerik.Reporting.Processing.Report).DataSource = dataSet;
}
[VB] The NeedDataSource Event Handler Copy Code
Private Sub Report1_NeedDataSource(ByVal sender As Object, ByVal e As System.EventArgs)
Dim sql As String = "SELECT Production.Product.Name, Production.Product.ProductNumber FROM Production.Product"
Dim connectionString As String = "Data Source=RA\SQLEXPRESS;Initial Catalog=AdventureWorksT;Integrated Security=True"
Dim adapter As New SqlDataAdapter(sql, connectionString)
Dim dataSet As New DataSet()
adapter.Fill(dataSet)
(TryCast(sender, Telerik.Reporting.Processing.Report)).DataSource = dataSet
End Sub


Using Expressions

Telerik Reporting Q3 2008 Send comments on this topic.
Using Expressions
Designing Reports > Connecting Data to a Report > Using Expressions

Glossary Item Box

You can use item binding expressions to specify the data to display in a TextBox or a PictureBox report item. These expressions can be used in the Value property by prefixing the expression with an equals sign (=). You can enter the value directly or build expressions using the Edit Expression dialog.

If a Value property is assigned a string starting with the equal (=) sign it will be evaluated as an expression. If the equal sign is not entered the value will be interpreted as a string. For example, if 7 is entered then the value is interpreted as the string "7". To compare a numeric expression with the number 7 use the equal sign before the number 7. In the example below the TextBox on the left shows the number 10 interpreted as a string while the field on the right shows the ten being evaluated as a number. Also notice in the right-hand TextBox that brackets are automatically placed around expressions.

Programmatically the assignment differs only in prepending the equal sign:

[C#] Assigning an Expression Copy Code
// assign a string, displays in the repot as "10 * 2"
textBox2.Value = "10 * 2";
// assign an expression, displays in the report as "20"
textBox2.Value = "=10 * 2";
[VB] Assigning an Expression Copy Code
' assign a string, displays in the repot as "10 * 2"
textBox2.Value = "10 * 2"
' assign an expression, displays in the report as "20"
textBox2.Value = "=10 * 2"

The difference between string and expressions is particularly important in Filter expressions and where a TextBox is displaying numeric values with custom formats. The example below displays in the report as "1,2345.00". If the value had been a string, not an expression, the value would not be formatted and would show as "12345".

[C#] Assigning Expression and Format Copy Code
textBox.Value = "=12345";
textBox.Format = "{0:N2}";
[VB] Assigning Expression and Format Copy Code
textBox.Value = "=12345";
textBox.Format = "{0:N2}";

Aggregates

  • Avg(Expression): Returns the average of all non-null values from the specified expression. Example: Avg(Fields.ListPrice * List.Quantity).
  • Count(Expression): Returns a count of the values from the specified expression. Example: Count(Fields.EmployeeID).
  • First(Expression): Returns the first value from the specified expression. Example: First(Fields.Phone).
  • Last(Expression): Returns the last value from the specified expression. Example: Last(Fields.CustomerID).
  • Max(Expression): Returns the maximum value from all non-null values of the specified expression. Example: Max(Fields.ListPrice).
  • Min(Expression): Returns the minimum value from all non-null values of the specified expression. Example: Min(Fields.Quantity).
  • Sum(Expression): Returns a sum of the values of the specified expression. Example: Sum(Fields.ListPrice * Fields.Quantity).

Constants

Constants include True, False and Null.

Fields

Fields include all the database fields in the report DataSource.

If the database field contains spaces, enclose its name in square brackets, for example "=Fields.[My Column]"

Functions

  • CBool(System.Object): Converts an expression to Boolean value.
  • CDbl(System.Object): Converts an expression to Double value.
  • CInt(System.Object): Converts an expression to Integer value.
  • Len(System.String): Gets the number of characters in a string.
  • RowNumber(): Returns a running count of all rows in the specified scope.
  • CDate(System.Object): Converts an expression to Date value.
  • Now(): Returns the current date and time on this computer, expressed as the local time.
  • Abs(System.Object): Returns the absolute value of a specified number.
  • IIf(Expression, ReturnedIfTrue, ReturnedIfFalse): Returns one of two objects, depending on the evaluation of an expression. The first parameter is the expression. If the expression evaluates to True the second parameter is returned, if false the third parameter is returned. Example that prints sum only when vendor is not null: IIF(ISNULL(vendorid, 0)=0,'', SUM(contractamount)).
  • IsNull(Expression, ReplacementValue): Checks an expression and either returns the checked expression or a replacement value. Example where zero is returned if "Price" is null: IsNull(Fields.Price, 0).
  • CStr(System.Object): Converts an expression to string value.
  • StripHtmlTags(System.String): Strips the HTML tags from the input text.
  • SubStr(String, Start, Length): Retrieves a substring from a string. The substring starts at a specified character position and has a specified length. Example: SubStr("Telerik", 0, 3) returns "Tel".
  • Trim(System.String): Removes all leading and trailing whitespace from the passed in string.

Global Objects

  • PageCount: The total number of pages in the report. Can be used only in page header and footer.
  • PageNumber: The current page number. Can be used only in page header and footer.
  • ReportItem: The current item in which context the expression is evaluated.

Operators

  • Arithmetic operators:

+ (addition)
- (subtraction)
* (multiplication)
/ (division)
Mod (modulus)

  • String Concatenation: Use the plus "+" sign to concatenate strings. Example: Fields.FirstName + " " + Fields.LastName.
  • Comparison operators <, <=, <>, =, >, >=, Like.
  • Logical/Bitwise operators And, Not, Or.

    Report Parameters

    Any element of the Report Parameters collection can be used in an expression. Example: =Parameters.UserSelection

    User Functions

    1. User Functions: User functions allow you to extend the default behavior of the Telerik Reporting engine. User functions are public static (Public Shared in VB.NET) methods that always return a value and should always be a member of the respective report class. See the code example below.
    [C#] User Function Copy Code
    public class Report1 : Telerik.Reporting.Report
    {
    //...
    public static Image ResolveUrl(string relativeUrl)
    {
    string path = HttpContext.Current.Server.MapPath(relativeUrl);
    return Image.FromFile(path);
    }
    //...
    }
    [VB] User Function Copy Code
    Public Class Report1 Inherits Telerik.Reporting.Report
    '...
    Public Shared Function ResolveUrl(ByVal relativeUrl As String) As Image
    Dim path As String = HttpContext.Current.Server.MapPath(relativeUrl)
    Return Image.FromFile(path)
    End Function
    '...
    End Class

    Member Access

    To access a member of an object, use the . character:
    Now().ToShortDateString(): Returns a string that contains the current date in short format.
    'abc'.ToUpper(): Returns "ABC" string.
    'abc'.Length: Returns the length of the current string, 3.
    Price.ToString('$0.'): Returns the value of Price formatted according to the specified format, i.e. $123

    You can call all public members of an object.

    • © 2002-2008, Telerik. All Rights Reserved.


Filtering Report Data

Telerik Reporting Q3 2008 Send comments on this topic.
Filtering Report Data
Designing Reports > Filtering Report Data

Glossary Item Box

Filters are used to limit the number of records in a report based on specified filter rules. If the conditions of the rules are met the record is included in the report. Multiple rules can be defined that make up a filter. Filters are defined using the the Edit Filter Dialog.

Filter Rules

Each filter rule is made up of an Expression, Operator and Value.

  • Expression can be a data field from the Fields collection or defined using the Edit Expression Dialog.
  • Operator can be simple comparison operators but can also include Like and additional operators to include the top and bottom number of records and the top and bottom percentage of records. See the table of operators below.
  • Value can be a literal value, "<blank>" or an expression defined in the Edit Expression Dialog.

Operator | Description
> Expression is greater than Value
< Expression is less than Value
>= Expression is greater than or equal to Value
<= Expression is less than or equal to Value
= Expression is equal to Value
<> Expression is not equal to Value
Like | Expression is like Value. Use the "%" wildcard to represent any number of other characters. Example: Fields.ProductName Like "%Bike%" will allow all records where the "ProductName" field contains "Bike".
Top N

Return the top N number of records.

If Expression is blank the filter returns the exact number of records specified by Value. For example "Top N 5" returns exactly five records.

If Expression contains a field or expression the filter returns the top number for that expression. This filter may return more than the exact count specified in Value. For example "ProductCategory Top N 2" might return twenty records containing ProductCategory "Accesories" and "Apparel".

Bottom N

Return the bottom N number of records.

If Expression is blank the filter returns the exact number of records specified by Value. For example "Bottom N 5" returns exactly five records.

If Expression contains a field or expression the filter returns the bottom records for that expression. This filter may return more than the exact count specified in Value. For example "CountryRegion Bottom N 2" might return twenty records containing "Zambia" and "Zimbabwe".

Top %

Returns the top N percentage of records.

If Expression is blank the filter returns the percentage of total records specified in Value. If the report has an initial 1000 records and the filter is "Top % 5", 50 records are returned.

If Expression contains a field or expression the filter returns the bottom percentage records that satisfy the expression. For example if the top two percent country codes in a StateProvince table are "AS", "AU" and "CA" might return twenty records containing only those country codes.

Bottom %

Returns the bottom N percentage of records.

If Expression is blank the filter returns the percentage of total records specified in Value. If the report has an initial 1000 records and the filter is "Bottom % 5", 50 records are returned.

If Expression contains a field or expression the filter returns the bottom percentage records that satisfy the expression. For example if the bottom two percent country codes in a StateProvince table are "VI", "US" and "PW" might return twenty records containing only those country codes.

Filters used at the Group and Report Level

Filtering can be performed at the group and report level through the Filters property. Group filters are intended to limit the number of groups while Report filters limit the report data. For example, consider the simplified data in the example diagram below. The data is first grouped by Country and filtered by Continent where Continenet = 'EU'. This returns two records for Italy and Bulgaria. The data can be further constrained by adding a report filter "City LIKE R%" that returns only "Roma" and "Russe". If the filtering criteria is satisfied, then the group is included in the report. The data within the group is then further limited by the report filter.


Sorting Report Data

Telerik Reporting Q3 2008 Send comments on this topic.
Sorting Report Data
Designing Reports > Sorting Report Data

Glossary Item Box

Sorting can be performed at the group and report level through the Sorting property. Sorting for groups controls the order of grouping data, not the report detail data. Group level sorting occurs before the sorting for the report as a whole.

Each sort is made up of an Expression and a Direction.

  • Expression can be a data field from the Fields collection or an expression defined using the Edit Expression Dialog.
  • Direction can be either "Asc" (ascending) or "Desc" (descending).

Example Scenario Using Group and Report Sorting

  • A report contains ProductCategory, ProductSubCategory and ProductName data and is grouped on ProductCategory and ProductSubCategory. Based on the physical order of the data in the database and the query used to extract the data, the category, subcategory and product name may or not be in a particular order. The Category data is "Accessories", "Bikes", "Clothes" and "Components".
  • The sorting expression "=Fields.Category Desc" is added to the Category group Sorting property. The data now looks like the screenshot sample below. The "Components" category shows first in the list. Also notice that the "Name" column is unordered.

  • Next the sorting expression "=Fields.Subcategory Desc" is added to the Subcategory group Sorting property. The data is now sorted like the screenshot below with the "Wheels" subcategory displays at the top. The "Name" column is still unordered.

  • The last step is to order the report detail data using the Report Sorting property. The filter expression "=Fields.Name Asc" is added to sort the detail data.


Grouping Report Data

Telerik Reporting Q3 2008 Send comments on this topic.
Grouping Report Data
See Also
Designing Reports > Grouping Report Data

Glossary Item Box

Groups trigger breaks in the report based on changes in report data. For example, a list of products each with a category can be grouped by category. You can have multiple levels of grouping nested within the report. If a report with the list of products has a category and a subcategory, the report can show first the category, then subcategories below it. The figure below shows an "Accessories" category followed by subcategories "Bike Racks", "Bike Stands", "Bottles and Cages.

Creating Groups

Each Group has a GroupHeaderSection and GroupFooterSection associated with it. The GroupHeaderSection prints at the beginning of each group and typically has a name or description of the group. The GroupFooterSection prints after the detail data for the group and can contain summary data. You can use aggregate functions in the Expression Editor to create subtotals for each group. Each group can be filtered and sorted.

You can create a new group by:

  • Right-clicking the area next to the report designer surface and selecting Add New Group from the context menu. See Create a new group for a walkthrough of adding a group.
  • Groups can be created automatically using the Report Wizard.
  • Adding to the Report.Groups collection in the Property Window.

Group Properties

When you create a grouping level, Telerik Reporting adds a new Telerik.Reporting.Group component to the report's component tray area. Select this component to set the following properties:

  • Name: Set to a descriptive name such as groupCustomers.
  • Filters: This property determines which groups will display. This level of filtering occurs before filtering for the report as a whole occurs. The filters for the group are applied to the grouping data, not the report data itself. Filter data for the group using the Filters property ellipses to invoke the Edit Filter Dialog. See Filtering Report Data for more information.
  • GroupKeepTogether: Set to FirstDetail to ensure that the group header and the first detail record are printed on the same page of output, or All to ensure that the entire group is printed on the same page of output. If there is not enough space on the current page, then rendering will skip to the top of the next page.
  • Grouping: The grouping property controls how groups of data are broken out in the report. Click the ellipsis for this property to invoke the Edit Grouping Dialog. This dialog allows you to specify grouping criteria that determine where the grouping level breaks occur. Note: It is also possible to have groups with no grouping criteria.
  • Sorting: This property controls the sorting order for the grouping data, not the report data. This level of sorting occurs before the sorting for the report as a whole. For example, Click the ellipsis button for this property to open the Edit Sorting dialog. Click Add to add a new sort expression. For each SortExpression, set the FieldName property to the name of the field by which this group should sort records, and select either Ascending or a Descending sort order.

Data Binding in Group Header and Footer Sections

Item binding expressions should only use aggregate functions. If an expression specifies a data field without an aggregate, the First() aggregate function is used by default. Aggregates work on the subset of the report data that falls within the current group. See the topic Report Life Cycle for more information.

Group Header and Footer Section Properties

When you create a grouping level, Telerik Reporting adds a new group header section to the report. Select the header section to set the following properties:

  • KeepTogether: Set to True to keep the entire section together on one printed page if possible. If there is not enough space on the current page, then rendering will skip to the top of the next page.
  • PageBreak: Specifies where to put page breaks relative to this group. You can set this to None, Before, After, or BeforeAndAfter.
  • PrintOnEveryPage: Set to True to repeat the group header at the top of each page if the details of the group extend across multiple pages.
  • Visible: Set to False to prevent the group from rendering. Note that this property only has an effect at runtime; the group will always be visible at design time.
  • ConditionalFormatting: A collection containing rules and formatting to be applied to this report item if the rules succeed. Clicking the property editor ellipses for this property displays the Conditional Formatting Rules Dialog.

In addition, you can set style properties that are inherited by default by all report items within the group header.

See Also

Using Styles to Customize Reports
GroupFooterSection Class
GroupHeaderSection Class


Create a New Group

Telerik Reporting Q3 2008 Send comments on this topic.
Create a New Group
Designing Reports > Create a New Group

Glossary Item Box

  1. To create a new grouping, right-click the area next to report design surface and select Add New Group.

  2. Notice that a Group component has been added to the tray below the report design surface, and that sections groupHeaderSection1 and groupFooterSection1 have been added before and after the detail section. In the Properties window locate the Grouping property of the Group component and click the ellipses to display the Edit Grouping dialog.

  3. The Edit Grouping dialog has a list of criteria that signal the beginning of a new group. The criteria is in the form of expressions that can be database field names or can be an expression defined in the Expression Editor. Click the New button to create an expression and select from the drop down list. When you are finished defining expressions, click the OK button to close the dialog.

  4. Add report items to the group header and footer. In the example below the expression "=Fields.Category" is the Value property for a TextBox report item. In the group footer a TextBox Value contains an aggregate function that counts the products in the group.

  5. Press F6 to build the report.
  6. Click the Preview button to view the report. Notice the breaks between categories and the count of products at the end of each category group.

  7. To add other levels of grouping, repeat the process. Again right-click the area next to the report and select Add New Group from the context menu. Each new group adds header and footer sections inside the previous group and just outside the detail area.


Report Parameters

Telerik Reporting Q3 2008 Send comments on this topic.
Report Parameters
Designing Reports > Report Parameters

Glossary Item Box

Report Parameters allow users to specify or control the data used in a report. Report Parameters are most powerful when used in expressions to directly provide a value or to form filtering, sorting or grouping criteria.

Telerik Reporting supports the following types for the parameter values:

  • Boolean
  • DateTime
  • Integer
  • Float
  • String
  • Collection of values of one of the above types.

Report Parameters can be populated in one of the following ways:

  • At design time through the ReportParameter Collection editor.
  • At runtime when the user fills the user interface(UI) that the Report Viewer provides for each parameter.
  • Programmatically by using the ReportParameters collection or creating a new one.
  • Using a SubReports Parameters collection.

UI

Telerik Reporting provides automatic user interface (UI) to allow the end user to pass values to the report parameters. The UI is defined at design time by using the UI property of a report parameter or at runtime using the provided API. The Report Viewer shows different controls (parameter editors) to the user according to the UI settings of the report parameters.

Multi-value report parameter

Multi-value report parameters allow the users to enter/select more than one value and the parameter will return a collection of values of the type of the parameter. This parameter type is mainly used with the IN logical operator. You can specify a parameter to accept multi values through the MultiValue property of the UI.

Available values

The available values, or valid values, are a set of predefined values from which the user can choose. Usually the available values are a list of value/label pairs. When displayed in the user interface the user chooses from the labels while during the report processing the corresponding values are taken.

Available values are retrieved from a data source. You have to provide the data source, the field to be used for the values, and the field to be used for the labels. If you do not select a field, the first one from the data source will be used. If you do not choose a field for the labels, the same field that is used for the values will be used.

At design time, you can use the Data Source Configuration Wizard to select an existing or to create a new data source.

Parameter area

When at least one report parameter has a defined UI with turned on Visible property the parameter area is shown as part of the report viewer above the viewer’s toolbar. The parameter area shows one control (editor) for each parameter with UI. The end user can enter or select values in the editors. To view the report the Preview button that is also displayed in the area should be clicked.

Cascading parameters

Cascading parameters provide a way of creating dependencies between parameters to handle large amounts of input data. You can define a set of parameters where the list of values for one parameter depends on the values chosen in other parameters.

For example, the first parameter could present a list of product categories. When the user selects a category, the second parameter is updated with a list of subcategories within the category. A third parameter could then display a list of products within the selected subcategory. The value for the product parameter is used to filter the report to a particular product. The parameters which values depend on other parameters values are known as cascading, dependent or hierarchical parameters.

A parameter becomes cascading when it uses a filter for the data source which has an expression referencing another parameter(s).

When cascading parameters are defined, at runtime the editors are reordered so that if a parameter is dependant from another parameter, the dependant one is placed after the other parameter.

Using the Report Parameter Collection Editor

To add a Report Parameter use the following steps:

1. Click the ellipses on the Report.ReportParameters property. This invokes the ReportParameter Collection editor.

2. Click the Add button to create a new parameter.

3. Enter a Name.

4. Select a type of the parameter. Supported types are Boolean, DateTime, Integer, Float and String. By default String type is selected.

You can leave the Value property blank, enter a literal value or click the ellipses to invoke the Expression Edit Dialog.

Populating Report Parameters in Code

In the report viewing application you can populate the values of ReportParameters collection members prior to displaying the report.

[C#] Assigning a Report Parameter in Code Copy Code
(ReportViewer1.Report as MyReport).ReportParameters[0].Value = "123";
[VB] Assigning a Report Parameter in Code Copy Code
(TryCast(ReportViewer1.Report, MyReport)).ReportParameters(0).Value = "123"

Using Report Parameters in Expressions

Report Parameters can be used in expressions that you display directly on the report and can also be used with other elements in an expression. These expressions in turn can be used as criteria for filters, sorting and grouping.

For example if you have a "Vendor List" report you can define a "VendorSelect" parameter. To display this value directly in the report you can assign an expression to a TextBox as in the example below:

This same parameter can be used to filter the vendor listing. In the example below we set up an expression where the VendorName from the database is compared, using a Like operator to the VendorSelect parameter. The expression is appended with the "%" wildcard so that any VendorName that starts with the characters passed in the parameter will be included in the report.

To extend this example to handle sorting choices a second column "VendorID" is added to the report and a second parameter called "SortColumn" is added. In the Report Sorting property an expression is added that checks the value of SortColumn. If SortColumn is zero then the sort is by the VendorID column, otherwise the sort column is VendorName.

Defining an UI for a Report Parameter to be shown in the Report Viewer

  1. Click the ellipses on the Report.ReportParameters property. This invokes the ReportParameter Collection editor.
  2. On the left select the parameter you need to define UI on.
  3. Expand the UI property and fill the following settings to determine the type and the behavior of the editor that will be shown for the parameter:
    1. AllowBlank determines if the editor allows an empty string to be entered. This property is taken into account only for parameters of type String.
    2. AllowNull determines whether the report parameter can return Null value.
    3. AvailableValues specifies a list of values which the editor provides to the user to choose from. If not set, the user will be able to enter any values matching the type of the parameter.
    4. MultiValue determines if the editor allows the user to select/enter more than one value. Parameter with UI configured as MultiValue is suitable to be used with the IN operator.
    5. The Text property specifies the text for the parameter to be displayed in the report viewer as prompt to the end user. If not set, the Name of the parameter will be used instead.
    6. The Visible specifies whether the editor will have UI in the parameters area.

Defining AvailableValues for ReportParameter’s UI

  1. Click the ellipses on the Report.ReportParameters property. This invokes the ReportParameter Collection editor.
  2. On the left select the parameter you need to modify.
  3. Expand the UI property.
  4. Expand the AvailableValues property and fill the following settings to determine the values the end user can choose from.
    1. Set the DataSource property to specify data source from which will be loaded the available values of the editor. As data source can be used the same object types as the types used as DataSource of the report. See Connecting Data to a Report. If no DataSource is specified, available values are not loaded.
    2. If the DataSource reference contains a dataset with more than one table, you must set the DataMember property to a string that specifies the table to bind to.
    3. In the ValueMember property choose a column from the data source from which the editor to load the values.
    4. In the DisplayMember property choose a column from the data source from which the editor to draw the value labels.
    5. In the Filters you can limit the number of records in the available values based on specified filter rules. If the conditions of the rules are met the record is included. Filters are defined using the Edit Filter Dialog.
    6. Sorting can be performed on the available values through the Sorting property. Sorting controls the order of the items provided to the user to choose from.

Creating cascading parameters (example)

  1. Using the Report Wizard create a new report using a DB data source with the query: “SELECT Production.Product.ProductNumber, Production.Product.Name AS ProductName, Production.Product.ProductSubcategoryID, Production.ProductSubcategory.Name AS SubcategoryName FROM Production.Product INNER JOIN Production.ProductSubcategory ON Production.Product.ProductSubcategoryID = Production.ProductSubcategory.ProductSubcategoryID”.
  2. Click the ellipses on the Report.ReportParameters property. This invokes the ReportParameter Collection editor.
  3. Add new Report Parameter
    1. Name it ProductCategoryID.
    2. Set the Type of the parameter to Integer.
    3. Expand the UI property.
      1. Set AllowNull to false if needed.
      2. Expand the AvailableValues.
        1. Set the DataSource using the Data Source Configuration Wizard to a DB source with query “SELECT ProductCategoryID, Name AS CategoryName FROM Production.ProductCategory”
        2. It is not compulsory to set the DataMember property when the data source contains only one table.
        3. Set the DisplayMember to CategoryName column.
        4. Set the ValueMember to ProductCategoryID.
      3. Set the Multivalue to false if needed.
      4. Set the Text to Product Category.
      5. Set the Visible property to True if needed.
  4. Add new Report Parameter
    1. Name it ProductSubcategoryID.
    2. Set the Type of the parameter to Integer.
    3. Expand the UI property.
      1. Set AllowNull to false if needed.
      2. Expand the AvailableValues.
        1. Set the DataSource using the Data Source Configuration Wizard to a DB source with query “SELECT ProductCategoryID , ProductSubcategoryID, Name AS SubcategoryName FROM Production.ProductSubcategory”
        2. It is not compulsory to set the DataMember property when the data source contains only one table.
        3. Set the DisplayMember to SubcategoryName column.
        4. Set the ValueMember to ProductSubcategoryID.
        5. Click on the ellipsis on the Filters property.
          1. Add new filter.
          2. As Expression choose =Fields.ProductCategoryID.
          3. As Operator choose equals(=).
          4. As Value choose =Parameters.ProductCategoryID.
          5. Click OK.
      3. Set the Multivalue to false (or to true if you want to be able to select more than one subcategory at a time).
      4. Set the Text to Product Subcategory.
      5. Set the Visible property to True if needed.
  5. Close the ReportParameter Collection Editor.
  6. Click on the ellipsis on the Filters property of the report to open the Edit Filters dialog.
    1. Add new filter.
    2. As Expression choose =Fields.ProductSubcategoryID.
    3. As Operator choose equals(=) (or to IN operator if you have set ProductSubcategoryID parameter as multivalue parameter).
    4. As Value choose =Parameters.ProductSubcategoryID.
    5. Click OK.
  7. Preview the report. Use the Product Category and Product Subcategory parameters to filter the list of products shown in the report.


Creating Master-Detail Reports Using SubReports

Telerik Reporting Q3 2008 Send comments on this topic.
Creating Master-Detail Reports Using SubReports
Designing Reports > Creating Master-Detail Reports Using SubReports

Glossary Item Box

The following walk through demonstrates how to create a Master-Detail report using a SubReport report item to contain detail data. The master report data in this example consists of product categories from the AdventureWorksT database. The detail report displays product names and numbers. A Report Parameter is used to filter the detail report on product category.

Create the Detail Report

  1. Create a new class library named "MasterDetail" to contain the reports.

  2. Add a new Telerik Report item to the project and name it DetailReport.cs.
  3. The Report Wizard will display automatically. Accept the wizard default values until you reach the Choose a data connection page. In the Choose a Data Connection page click the New Connection button.
  4. The Add Connection dialog will display. In the Add Connection dialog:
  • Make sure the Data source is "Microsoft SQL Server". Set the Server name to "LOCALHOST\SQLEXPRESS".
  • Verify that for "Log on to the server" has "Use Windows Authentication" selected.
  • For "Connect to a database" under "Select or enter a database name" choose the AdventureWorks database (this database is installed along with Telerik Reports).
  • Click the OK button to close the Add Connection dialog.

Add Connection Dialog

  5. In the Choose Your Database Connection page note the name of your connection for use in later creating the master report. Click the Next button.
  6. In the Choose Your Database Objects page enter the following SQL statement and click the Next button.
[SQL] Selecting Products Copy Code
SELECT P.NAME,ProductID,ProductNumber,PC.ProductCategoryID
FROM Production.Product P,
Production.ProductSubcategory PS,
Production.ProductCategory PC
WHERE P.ProductSubcategoryID=PS.ProductSubcategoryID
AND PS.ProductCategoryID=PC.ProductCategoryID
  7. In the Design Data Layout page of the wizard select "ProductNumber" and "Name" fields using the Detail button.

  8. Proceed through the remaining pages of the Report Wizard, accepting the default values. Click the Finish button to close the Wizard.
  9. Right click next to the report designer and un-select the Page Header, Page Footer and Report Header so that only the detail section remains.

The detail report should now look something like this in the designer.

Configure the Report Parameter and Filter

This next set of steps creates a report parameter and a filter that uses the report parameter. The master report passes in the current ProductCategoryID for each row and the detail report prints all products that have that ProductCategoryID.

  1. In the Property Window navigate to the Report.ReportParameter property and click the ellipses.
  2. In the ReportParameter Collection Editor click the Add button. In the Name property for the parameter enter "ProductCategoryID". In the Value property for the parameter enter a zero.

  3. In the Property Window navigate to the Report.Filters property and click the ellipses.
  4. Click the New button to create a new filter. In the Expression drop down for the filter select Fields.ProductCategoryID. Leave the operator at the default equals ("=") sign. In the Value property drop down select "<Expression>".

  5. In the Edit Expression dialog locate the Report Parameters from the list of expression elements. Double-click ProductCategoryID so that the expression in the upper window reads "= Parameters.ProductCategoryID".
  6. Click the OK button to close the dialog.

Create the Master Report

The following steps create the master report. The master report will contain only a simple listing of product categories.

  1. Create a new report item in the project and name it MasterReport.cs.
  2. In the report wizard accept the default values until you reach the Choose a Data Connection page. Select the database connection you created earlier from the drop down list. Click the Next button.
  3. In the Choose your Database Objects page enter the SQL statement below and click the Next button.
[SQL] Select Product Category Copy Code
SELECT ProductCategoryID,Name FROM Production.ProductCategory
  4. In the Design Data Layout page of the wizard select the "Name" column and click the Next button. Continue taking the defaults until you finish the Wizard.

Configure the SubReport

This next set of steps tie the two reports together using a SubReport to display the detail and passing the current ProductCategoryID from each row of the master report to the detail. The detail report uses the parameter to filter the data to only products for the specified product category.

  1. Drag the sizing bar at the base of the detail section down to create some vertical room for a SubReport item.
  2. Drag a SubReport from the Toolbox to the detail section in the report designer. The project should look something like the example screen-shot below.

  3. In the Properties Window for the SubReport set the ReportSource property to the detail report.
  4. Locate the Parameters property for the SubReport and click the ellipses. The Edit Parameters dialog will display.
  5. Click the New button to define a parameter.
  6. Set the Parameter Name to ProductCategoryID and the Parameter Value to "=Fields.ProductCategoryID".
  7. Click the OK button to close the dialog.

Build the report and click the Preview button to review the completed results. Notice that product numbers and names from the detail report display under each product category from the master report.


Performance Considerations

Telerik Reporting Q3 2008 Send comments on this topic.
Performance Considerations
Designing Reports > Performance Considerations

Glossary Item Box

To determine the most efficient means for retrieving report data, consider the tradeoff between user selections applied at the database vs. selections applied to data at the report level. With large amounts of database server data you need to retrieve the smallest usable set of data to reduce network traffic, use resources effectively and to render reports quickly.

  • Selections applied at the database level are effective when the data does not need to be re-queried. This can be effective when only a narrow range of data is required. Additional trips to the database for different views of the same data increase the network traffic cost and the time needed to render the report.
  • When user selections are applied at the report level the data is cached in-memory. This can be effective when different views of the same data are required and the data is not too large.

A combination of these techniques may be the most appropriate solution. For example, consider sales data that includes sales person and sales date information. The selection at the database could query for a given date range and selections for particular sales people could be applied at the report level. The individual requirements of the report help determine the best solution.


Design Considerations for Report Rendering

Telerik Reporting Q3 2008 Send comments on this topic.
Design Considerations for Report Rendering
Designing Reports > Design Considerations for Report Rendering

Glossary Item Box

All Telerik Reporting output formats have specific characteristics that determine their usage and impose ceratin limitations, which need to be taken into consideration when designing reports. For example, the CSV rendering extension is useful for creating reports that can be used as a data source by another application or process, while layout rendering extensions produce reports in a format suitable for viewing by users.

The following rendering extension categorization shows how extensions vary:

  • Data rendering extensions: CSV
  • Logical page layout rendering extensions: HTML, Excel
  • Physical page layout rendering extensions: Image, PDF

The logical layout formats (HTML, Excel) are best suited for viewing and manipulating data, while the physical layout formats are intended for precise printing.

The following topics describe the design considerations specific to each rendering extension.

  • Design Considerations for HTML Rendering
  • Design Considerations for Image Rendering
  • Design Considerations for PDF Rendering
  • Design Considerations for Excel Rendering
  • Design Considerations for CSV Rendering
  • Design Considerations for RTF Rendering

Page Setup options can also alter the appearance of the report at design-time, run-time or when the user changes the options prior to printing a report.


Design Considerations for HTML Rendering

Telerik Reporting Q3 2008 Send comments on this topic.
Design Considerations for HTML Rendering
Designing Reports > Design Considerations for Report Rendering > Design Considerations for HTML Rendering

Glossary Item Box

The HTML rendering extension renders a report into HTML or MHTML format. It creates an html table which contains the report items. Each item is positioned into a separate cell from the table.

Since report items are located in different cells they cannot overlap. Overlapping items are positioned into adjacent cells which may break the original report layout. If there are no overlapping items the report layout is preserved. Avoid having overlapping report items at design-time if you plan to export the report to HTML. Also note that sections cannot have KeepTogether=false as it would be ignored - this is due to the fact that html is not a page oriented format.

Rendering

  • Styles specified in report item properties are injected to the HEAD tag for use in the corresponding HTML elements.
  • Each report section is rendered as a separate HTML table.
  • Columns and ColumnSpacing properties are ignored during HTML rendering.
  • The size of report items is the same as in design-time and the browser is responsible for sizing them.

Report Items render as the following HTML elements:

Report Item | HTML Element
TextBox

If CanGrow is set to true: the text value is contained in <TABLE>, <ROW> and <CELL> elements. If CanShrink is also true, the text is further wrapped in a <DIV> element.

If CanGrow is set to false the text value is contained in a <DIV> element. If CanShrink is set to true, outer and inner <DIV> elements wrap the text value to handle shrinking and growing size conditions.

If the MultiLine property is set to true, carriage return and line feed characters are replaced with <BR> tags.

Chart | <IMG>. A Portable Network Graphic (PNG) of the chart is created as the image source.
Panel | <TABLE>
PictureBox

A <DIV> surrounding an <IMG> tag. The DIV tag acts as a container that has a style to specify border, dimensions, padding, etc.

The position and scaling of the image is also affected by the Sizing property.

Normal and AutoSize: No scaling occurs and the image is rendered in the upper left corner of the PictureBox client area.

Center: Centers the area within the PictureBox client area.

Stretch: Expands the image to fill the client area.

ScaleProportional: Expands the image to fill as much of the client area as possible without distorting the image.

Checkbox

 A <TABLE> with two cell elements placed in one or two rows is generated. If the CheckAlign property is set to one of TopCenter or BottomCenter, then the two rows model is used.
If the Angle differs from zero than the Text is rendered as an image.
CanShrink and CanGrow properties are respected.
If the MultiLine property is set to true, carriage return and line feed characters are replaced with <BR> tags.
Shape | <IMG>
SubReport | <DIV>

Some report items will not render depending on the style settings for the item and the value. For example, if the TextBox item has no Value property set, it will not render. If the Value property is left blank but the Style.BackgroundColor were set to a visible color, then the DIV for the TextBox report item would be rendered. In general, if the report item will not be visible, the output is optimized and the item is not rendered.

Unlike image based output, actual item size and position cannot be calculated on the server. The report display may occur in many different browser types and versions and so the user experience may differ significantly.

All output is generated with UTF8 encoding.

Pagination

Page size is calculated approximately by taking into account the PageSettings and the design-time dimensions of report sections. Margins are ignored.

All soft page breaks of the sections are respected.

MHTML Reports

Reports can be output as MHTML (Web archive or "MIME Encapsulation of Aggregate HTML Documents") standard. MHTML is used for including resources in the same file as the HTML code. This is particularly useful when sending email because all resources, such as image and sound files, are included in a single file.


Design Considerations for Image Rendering

Telerik Reporting Q3 2008 Send comments on this topic.
Design Considerations for Image Rendering
Designing Reports > Design Considerations for Report Rendering > Design Considerations for Image Rendering

Glossary Item Box

The Image rendering extension renders a report to a bitmap or metafile. By default, the Image rendering extension produces a TIFF file of the report, which can be viewed in multiple pages. When the client receives the image, it can be displayed in an image viewer and printed.

The Image rendering extension can generate files in any of the formats supported by GDI+: BMP, EMF, GIF, JPEG, PNG, and TIFF.

The Image rendering extension processes the report by assembling all elements of the report and creates an image for each page. With extensions like the HTML rendering extension, you rely on the client browser to display the final report to the user. This can lead to varying user experiences, based on browser versions, settings and fonts. With an image, you are assured that each user is viewing the same style and layout.

Paging and Keep Together

Based on report content and page settings the report is divided into one or more pages. The actual report content is rendered on a page after margins are subtracted from the page size.

If the report body cannot fit in the available page width, a new page will be added in order to accommodate all content. At design-time, a vertical dotted line will appear to indicate the available width. Make sure report sections and items do not cross this boundary if you do not want them to be split across different pages.

If every other page in a report seems to be blank, the most probable reason is that a report item is stretching over the right page margin (appears over the dotted line in report designer) and in case it has no background or border, you will not be able to detect it, but it is still there and is causing a new page to be created.

In the vertical direction, by default sections are not split across different pages, unless their KeepTogether property is set to false. If you want to force a page break before or after a section, use the section’s PageBreak property.

Simple report items (i.e. non-container items) are always kept together on a page if possible. If not, they are rendered at the beginning of the next page. If they still cannot fit (i.e. they are longer than a whole page) they are split.

By default groups are not kept together on a single page. You can instruct the rendering engine to try to keep the entire group or the group header with the first detail on a single page if possible by setting the GroupKeepTogether property of the Group component.

If the report spans over several pages in width then its sections are stretched from the left edge of the left-most page’s printable area to the right edge of the right-most page’s printable area, as displayed in the following diagram:

Report Item Layout and Adjustments

Some report items can change their sizes dynamically.

If the CanGrow or CanShrink properties of a TextBox are set, it will grow or shrink respectively to fit its contents. The AutoSize value of a PictureBox.Sizing will cause the PictureBox item to resize matching the image size.

When report items change their size, they might cause other report items to move. For example, if a TextBox grows, it will push down all report items that are located below it. Conversely, if it shrinks, it will pull them up. Setting a report item to be invisible can be thought of as shrinking it to zero size with regard to item layout. Rearranging of report items occurs in the horizontal direction as well. For example, if an item is made invisible, all items that appear to the right will move left to fill the freed space.

Report items can be overlapped.

Page Header and Footer

Space for the Page Header and Page Footer is always reserved even if the section is not rendered for some reason. Furthermore, the height of the PageHeader and PageFooter section that is set at design-time is always preserved even if items inside it grow. The Page Header/Footer’s width is always equal to the page width minus the left and right margin. If the report has more than one column, the Page Header/Footer spans all columns.

The following table describes how individual items keep together on a page:

Report Item | Rendering Notes
TextBox and Checkbox

If CanGrow or CanShrink properties are set to true the height of the text in the Value property is measured and the adjusted so that the dimensions of the rendered string fits the content.

If the MultiLine property is set to false, carriage return and line feed characters are replaced with the replacement character "\uFFFD".

Chart | Chart is rendered as an image.
Panel | Panel is used as a container for other child items that are rendered in relation to the position of the panel. The panel itself may also have visual aspects for background color, background image and borders. These visual aspects are controlled by the Style property.
PictureBox

PictureBox is rendered as an image with the position and scaling of the image further determined by the Sizing property.

Normal and AutoSize: No scaling occurs and the image is rendered in the upper left corner of the PictureBox client area.

Center: Centers the area within the PictureBox client area.

Stretch: Expands the image to fill the client area.

ScaleProportional: Expands the image to fill as much of the client area as possible without distorting the image.

Shape

The Shape report item Style property controls visual adornment of the shape (outline color, line width, background color, etc) in CSS terms but the shapes are rendered with the help of GDI objects (pen, brush, graphics path).

SubReport | SubReport is a container that renders the detail section of the ReportSource to the main report. SubReport, like the Panel item also may itself have visual aspects that are controlled by the Style property.


Design Considerations for PDF Rendering

Telerik Reporting Q3 2008 Send comments on this topic.
Design Considerations for PDF Rendering
Designing Reports > Design Considerations for Report Rendering > Design Considerations for PDF Rendering

Glossary Item Box

The PDF Rendering Extension of Telerik Reporting produces a version 1.6 PDF file. The file can be opened with Adobe Acrobat 7.0 or later. The file is compressed using the FlateDecode filter. PDF and Image Export Formats share the same high-level layout engine. Therefore all rules and design considerations that apply for the Image Rendering Extension apply for PDF as well.

The PDF rendering extension is based on the Image rendering extension, with some differences. For information common to the Image rendering extension and the PDF rendering extension, see Design Considerations for Image Rendering. This topic describes features that are specific to the PDF rendering extension.

Limitations

The PDF Rendering extension has the following limitations:

  • Only Unicode fonts are supported.
  • PDF Security features such as encryption are not supported.


Design Considerations for Excel Rendering

Telerik Reporting Q3 2008 Send comments on this topic.
Design Considerations for Excel Rendering
Designing Reports > Design Considerations for Report Rendering > Design Considerations for Excel Rendering

Glossary Item Box

The Excel Rendering Extension of Telerik Reporting produces Excel files in the Binary Interchange File Format (BIFF, v. 8) without relying on Microsoft Office being installed. Using the BIFF8 format guarantees that exported files can be opened by Microsoft Excel 97 and later. The Excel Rendering Extension tries to reproduce as much of the original report as possible regarding layout and styling, but there are certain limitations that are imposed by the physical and logical structure of an Excel Document.

Report Item Layout

The entire report is rendered into a single Excel worksheet. There is no paging when exporting to Excel.

Avoid overlapping report items at design-time. Overlapping items will be moved down so that they do not overlap and the final result might be different from what was designed.

Try to align report items in rows and columns so that their edges coincide. The white space in a report section, that is the space unoccupied by report items, will be emulated by empty rows and columns known as spacers. The better report items are aligned horizontally and vertically with respect to one another at design-time, the less spacer rows and columns will be produced. Use the Visual Studio Formatting Toolbar to quickly align report items.

Report item sizes are calculated with some degree of rounding to improve layout, so there might be slight differences between the design-time values and the Excel document. The precision that is used it 1pt.

Have in mind that when you use the CanGrow and CanShrink properties, the Rendering Engine will utilize the AutoFit functionality of Excel. That means that cell content will resize according to Excel behavior which might not produce the expected result. Furthermore, AutoFit is applied by Excel only for horizontal text, so if you have rotated text (at an angle different than zero), the CanGrow and CanShrink properties might not behave as expected. Rotated text is realized via Excel's built-in cell rotation settings.

Multi-column reports are not supported.

Report Sections

The PageHeader section of a report will be rendered as a frozen pane of several rows on top of the worksheet.

The PageFooter section will be rendered as the true Excel document page footer, which is divided in three sections – left, middle and right. Report items will enter the respective page footer section according to their original location in design-time. PictureBox report items are not supported in the page footer.

The PageNumber and PageCount global objects should not be used when rendering to Excel, since it is not a page-oriented export format.

Styling

For compatibility, the Rendering Extension support s a predefined set of around 75 colors that can be used for Background and Foreground colors of report items. The report item’s colors are translated to the closest possible color from the predefined palette.

Excel supports only three kinds of cell border width: 0.5, 1.0, and 1.5 points. The value that is closest to the original report item border is chosen and used.

Background images are not supported.

Report Items

TextBox values are converted to string or number cells in Excel depending on the actual value. If a supported .NET string format is supplied through the Format property of the TextBox, the resulting cell is accordingly formatted respecting the Culture of the TextBox.

Item binding expressions are not converted to Excel formulas.

Chart report items are rendered as images when exporting to Excel. They are not real Excel Charts.

Shape report items are rendered as images, not Microsoft Office Drawings.

CheckBox report items are rendered as images – including check marks and text.

Page Settings

The following standard paper kinds are supported:

  • A3 (297mm x 420mm)
  • A4 (210mm x 297mm)
  • A5 (148mm x 210mm)
  • B4 (250mm x 353mm)
  • Quarto (215mm x 275mm)
  • DLEnvelope (110mm x 220mm)
  • C5Envelope (162mm x 229mm)
  • PrcEnvelopeNumber10 (324mm x 458mm)
  • PrcEnvelopeNumber9 (229mm x 324mm)
  • C6Envelope (114mm x 162mm)
  • C65Envelope (114mm x 229mm)
  • B4Envelope (250mm x 353mm)
  • B5 (176mm x 250mm)
  • B6Envelope (176mm x 125mm)
  • ItalyEnvelope (110mm x 230mm)
  • Letter (8.5” x 11”)
  • Tabloid (11” x 17”)
  • Ledger (17” x 11”)
  • Legal (8.5” x 14”)
  • Statement (5.5” x 8.5”)
  • Folio (8.5” x 13”)
  • Standard10x14 (10” x 14”)
  • Number9Envelope (3.875” x 8.875”)
  • Number10Envelope (4.125” x 9.5”)
  • Number11Envelope (4.5” x 10.375”)
  • Number12Envelope (4.75” x 11”)
  • Number14Envelope (5” x 11.5”)
  • DSheet (22” x 34”)
  • ESheet (34” x 44”)
  • MonarchEnvelope (3.875” x 7.5”)
  • PersonalEnvelope (3.625” x 6.5”)
  • USStandardFanfold (14.875” x 11”)

If any other paper size is specified, the default printer settings will be used. In this manner you can use custom paper sizes.

String Formatting

A subset of the .NET string formats (set through the TextBox.Format property) is supported by the rendering extension. Those include:

  • Standard Numeric Format Strings:
    • C or c (Currency)
    • N or n (Number)
    • G or g (General)
  • Standard DateTime Format Strings:
    • d (Short date pattern)
    • D (Long date pattern)
    • t (Short time pattern)
    • T (Long time pattern)
    • f (Full date/time pattern with short time)
    • F (Full date/time pattern with long time)
    • g (General date/time pattern with short time)
    • G (General date/time pattern with long time)
    • M or m (Month day pattern)
    • R or r (RFC1123 pattern)
    • s (Sortable date/time pattern; conforms to ISO 8601)
    • u (Universal sortable date/time pattern)
    • U (Universal sortable date/time pattern)
    • Y or y (Year month pattern)

Custom .NET format strings are not supported. Examples of custom .NET format strings are "(###) ### - ####" and “dddd - d - MMMM”.

If a valid format string is detected by the rendering extension, the raw value will be stored in the cell as a Number and an Excel Number Format will be applied. Otherwise the value will just be stored in the cell, again as a Number, but without formatting. Even unformatted, it would be possible to use the resulting cell in Excel functions.


Design Considerations for CSV Rendering

Telerik Reporting Q3 2008 Send comments on this topic.
Design Considerations for CSV Rendering
Designing Reports > Design Considerations for Report Rendering > Design Considerations for CSV Rendering

Glossary Item Box

The Comma-Separated Value (CSV) rendering extension renders reports in comma-delimited plain text files, without any formatting. It uses a string character delimiter to separate fields (, - comma) and rows (<cr><lf>). The resulting file can be opened in a spreadsheet program like Microsoft Excel or used as an import format for other programs. The exported report becomes a .csv file and returns a MIME type of text/plain.

When rendered using the default settings, a CSV report has the following characteristics:

  • The first record contains headers for all the columns in the report.
  • All rows have the same number of columns.
  • The default field delimiter string is a comma (,).
  • The record delimiter string is the carriage return and line feed (<cr><lf>).
  • The text qualifier string is a quotation mark (").
  • If the text contains an embedded delimiter string or qualifier string, the text qualifier is placed around the text, and the embedded qualifier strings are doubled.
  • Formatting and layout are ignored.

The following items are ignored during processing:

  • Page Header Section
  • Page Footer Section
  • Shape
  • PictureBox
  • Chart

The remaining report items appear as ordered in the parent’s item collection. Each item is then rendered to a column. If the report has nested report, the parent items are repeated in each record.

The following table lists the considerations applied to items when rendering to CSV:

Report Item | Rendering Behavior
TextBox | Renders the contents of the text box. The data is formatted according to the item's Format property
CheckBox | Renders the contents of the CheckBox. The Text is formatted according to the item's Format property. The first character of resulting string represents the CheckMark state: 0 is Unchecked, 1 is Checked and 2 is Indeterminate.
Detail section | Renders a record for each detail row.
Report Header Section | Renders its content at the beginning of each detail row.
Group Header Section | Renders its content at the beginning of each detail row after the Report Header content if any.
Group Footer Section | Renders its content at the end of each detail row.
Report Footer Section | Renders its content at the end of each detail row after the Group Footer content if any.


Design Considerations for RTF Rendering

Telerik Reporting Q3 2008 Send comments on this topic.
Design Considerations for RTF Rendering
Designing Reports > Design Considerations for Report Rendering > Design Considerations for RTF Rendering

Glossary Item Box

The RTF Rendering Extension of Telerik Reporting produces RTF v1.6 files. It is reccommended that the exported file is viewed with Microsoft Word 97 or later. The RTF rendering extension relies on Frames to a achieve a WYSIWYG layout and preserve the original report outlook as much as possible. Consumer applications that do not support Frames might produce unexpected results and are not reccommended.

Limitations

  • Vertical Alignment is not supported.
  • Report Background Color is not supported.
  • TextWrap = false is not supported.
  • Inset and Outset Borders are not supported.
  • Rotated Text is rendered by an image.
  • RTL Text Handling is left to the consumer application.
  • Maximum Page Width and Height is 22 inches.
  • Simple Report Items (such as TextBoxes, PictureBoxes, etc.) cannot span on multiple pages. They should fit on a single page.


Report Layout Options

Telerik Reporting Q3 2008 Send comments on this topic.
Report Layout Options
See Also
Designing Reports > Report Layout Options

Glossary Item Box

You can fine-tune the layout of your reports in several ways:

  • By customizing the page layout
  • By customizing the report width
  • By customizing the size of report sections
  • By using multiple columns to display report output

Customizing the Page Layout

The PageSettings property of the Report object allows you to customize the following properties:

Property | Description
Landscape | True to print in landscape orientation, False to print in portrait orientation.
Margins | A Telerik.Reporting.Drawing.MarginsU object, which lets you individually specify the margins at the four sides of the report.
PaperKind | The type of paper to print the report on, such as Letter, Legal, A3, or A4. Setting this automatically sets the correct dimensions in the PaperSize property.

Customizing the Report Width

You can set the overall width of the report with the Width property of the report itself. This property is only respected by formats that are not physical page oriented (MHTML and HTML). For page-oriented formats (PDF and Image formats), the report will be as wide as the printable area, which may be calculated from PageSettings.PageSize.Width - (PageSettings.Margins.Left + PageSettings.Margins.Right). If the report is wider than can fit on a single page, the designer will display thin vertical report breaks to show where the pages will divide; you can disable these by setting the Report.ShowPageGuides property to false.

Customizing the Size of Report Sections

Each section of the report (such as a report header, page header, group header, detail, or the corresponding footer sections) has a Height property which lets you set the height of the section. This property controls the actual printed area of the report.

Using Multiple Columns

The Detail section of a report includes two properties that allow you to specify multiple-column reports. The ColumnCount property specifies the number of columns to print on the report. The ColumnSpacing property specifies the spacing between columns. Regardless of the settings of these properties, header and footer sections are printed across the width of the entire report; only detail records are printed in multiple columns.

See Also

PageSettings Property
ColumnCount Property
ColumnSpacing Property
Width Property


Report Globalization

Telerik Reporting Q3 2008 Send comments on this topic.
Report Globalization
Designing Reports > Report Globalization

Glossary Item Box

Telerik Reporting offers the possibility to control the way numbers, dates and currencies are displayed and to layout text in different directions.

A report is globalized with the help of a System.Globalization.CultureInfo object. You can specify a Culture for the entire Report by setting its Culture property. This will force all TextBox items to respect the assigned Culture. But you are not limited by one culture per report. You can mix an unlimited number of cultures, by setting the Culture property of a specific TextBox. This will override the Report's Culture.

Culture Inheritance

When determining what Culture to use for formatting strings and text direction, the rendering engine will inspect the those objects in the following order:

  1. The Culture of the TextBox.
  2. If the TextBox has no Culture defined, the Culture of the Report is used.
  3. If the Report has no Culture defined, the Culture of the CurrentThread is used.
The Culture of the CurrentThread is determined by the Regional Settings of the machine the application is running on. (Control Panel->Regional Settings->Regional Options->Standards And Formats)

Culture Dependant Properties

  • String Formatting

Culture affects the way strings are formatted in Telerik Reporting. For example, if you set the British Culture (en-GB) for a TextBox and set its Format to Currency ({0:C2}) you will see values like: £43.21. Same applies for dates, times and numbers.

  • Text Direction (LTR/RTL)

Middle Eastern languages such as Hebrew and Arabic are generally written from right to left. If your TextBox will contain text written using a RTL script, then you simply need to specify the appropriate Culture, for example "he" for Hebrew and "ar" for Arabic.


Page Setup

Telerik Reporting Q3 2008 Send comments on this topic.
Page Setup
Designing Reports > Page Setup

Glossary Item Box

When you render a report you can specify page setup options at run-time or design-time. Some of these options can be changed by the user using the Page Setup dialog. Page setup options apply to all report output types.

  • Landscape or Portrait paper orientation.
  • Margin sizes.
  • Paper Kind: This option includes standard paper size configurations such as letter, legal, envelopes or labels.
  • Paper Size: If the Paper Kind is "Custom" you can specify a non-standard set of paper dimensions.


Style Inheritance and Overriding

Telerik Reporting Q3 2008 Send comments on this topic.
Style Inheritance and Overriding
Styling Reports > Style Inheritance and Overriding

Glossary Item Box

Telerik Reporting Styling is similar to CSS (Cascading Style Sheets), of which many web developers are familiar.

Styles can be defined globally using the StyleRules. They can be inherited from parent report items. They can also be explicitly defined in a report item's Style properties.

General Inheritance Rules

Child report items placed within another report item always derive their styling based on the following precedence:

Lowest Priority - Parent: If the parent control has a Style applied, then the child will inherit the parent's styling. This will be over-ruled by the higher priorities.

Second Priority - Global: If any of the global styles apply to the child (eg. the child is a TextBox and there is a TypeSelector rule for TextBox report items) then the control will use this styling. Parent styling will be ignored in this case.

Highest Priority - Inline: If the child control's Style properties have been changed from their defaults, then these properties will be honored with the highest priority. In this case, the the Global styling and the style of the parent will be ignored.

Global Styles

Styles defined with Style Rules will be applied globally in a report based on the definition of the Style Rule. A Style Rule can be defined in one of four ways:

  1. TypeSelectors target all report items of a particular type (for example TextBox or DetailSection).
  2. StyleSelectors are named styles that can be applied to report items through the report item's StyleName property.
  3. AttributeSelectors target all report items with a particular attribute (for example Font Family= Verdana).
  4. DescendantSelectors target report items which descend from (or, are placed within) other report items. For example you can define a style that should be applied to all TextBoxes in the report's DetailSection.

Inheriting from Global Styles

Report items placed within a report item that is styled using one of the Global Styles will inherit the Font, Vertical Alignment, and Horizontal alignment of the parent.

Overriding Global Styles

You can override a GlobalStyle by modifying the Style properties of an individual report item.

Resetting Global Styles

If you have overridden a style using a report item's Style properties, it is possible to reset the report item to its Global Style.

  1. Right-click the report item to open its context menu.
  2. Click Reset Style.


Using Styles to Customize Reports

Telerik Reporting Q3 2008 Send comments on this topic.
Using Styles to Customize Reports
See Also
Styling Reports > Using Styles to Customize Reports

Glossary Item Box

Telerik Reporting uses a built-in styling model that is similar to CSS. The model provides for very fine-grained visual customization of all elements of a report directly in the Visual Studio designer. This CSS-like mechanism offers full control over such things as the background, colors, borders, and images for every item on your report. You can assign styles by using CSS selectors such as Type, Attribute, Style, and Descendent.

Creating a Style Sheet for a Report

To create a style sheet for a report, follow these steps:

  1. Open the report in design view.
  2. Select the Report object.
  3. Click in the StyleSheet property, click the ellipsis button to open the StyleRule Collection Editor.
  4. Click Add to add a new StyleRule.
  5. Expand the Style property and customize your new StyleRule. For example, the screenshot below shows a StyleRule that specifies a yellow background, blue text, and bold Times New Roman font.

  6. Click in the Selectors property, click the ellipsis button to open the TypeSelector Collection Editor.
  7. Click the drop-down arrow on the Add button and select the type of selector to add:
    • A TypeSelector applies to all report items of a particular type.
    • An AttributeSelector applies to all report items with a particular attribute (such as Color=Red).
    • A StyleSelector applies to all report items with a particular style name.
    • A DescendantSelector applies to all report items descended from another report item, which in turn can be specified by any type of selector.
  8. Use the properties area of the TypeSelector Collection Editor to customize the new selector. For example, the screenshot below shows a StyleSelector named DataField which applies to TextBox report items only.

  9. Click OK when you are done adding selectors for the current StyleRule.
  10. Click OK when you are done adding StyleRules for the report's StyleSheet.

Assigning Styles to Report Items

Telerik Reporting will automatically apply styles that use TypeSelectors, AttributeSelectors, or DescendantSelectors to the appropriate report items. For example, if you add a style to the report's StyleSheet with a TypeSelector of Telerik.Reporting.TextBox, that style will be inherited by all text box report items on the report.

To apply a style that uses a StyleSelector to a report item, select the report item and set its StyleName property to the StyleName property of the StyleSelector.

Editing Individual Report Item Styles

To override the style set by the report's StyleSheet for an individual report item, select the report item and click in its Style property. Then click the ellipsis button. This action will open the Edit Style dialog box, which allows you to edit the various properties that can be set through the style sheet. Any changes you make through the Edit Style dialog box override settings made through the report's StyleSheet property.

See Also

Exporting and Reusing Style Sheets

Styling Reports
Understanding Style Selectors
Creating Style Rules


Exporting and Reusing Style Sheets

Telerik Reporting Q3 2008 Send comments on this topic.
Exporting and Reusing Style Sheets
Styling Reports > Exporting and Reusing Style Sheets

Glossary Item Box

Styles created in a report can be exported and then used in other reports. You can store one or more Styles in an exported file. The exported information is stored in an XML file.

Export a Style Sheet

[screen shot needed]

  1. Open the report in design view.
  2. Select the Report object.
  3. Click in the StyleSheet property, and then click the ellipsis button to open the StyleRule Collection Editor.
  4. Select one or more of the styles in the Members box on the left. Use Windows keyboard combinations to select more than one style.

  5. Click the Export button. This will open the Save As dialog box.
  6. Enter a name for the exported file and click Save to complete the task.

Use an Exported Style Sheet in Another Report

  1. Open the report in design view.
  2. Select the Report object.
  3. Click in the External Styles property, and then click the ellipsis button to open the Collection Editor.
  4. Click the Add icon in the upper left corner of the Collection Editor window. This will open a File Open dialog. You will be located in the current project's root directory.
  5. Browse to, and then select, the exported Style Sheet. Click Open. This action will return you to the Collection Editor window.
  6. When you are finished adding Style Sheets, click OK.

Styles that are defined by TypeSelectors or AttributeSelectors will be automatically formatted. To use styles defined by StyleSelectors, change the StyleName property of the desired report item to the appropriate style names that exist in the Style Sheets that you added.

External Style Sheet Location Kinds

There are three ways in which an external style sheet can be located:

  • Absolute Path/URL such as C:\Application1\StyleSheets\StyleSheet1.xml or http://www.mysite.com/Application1/StyleSheets/StyleSheet1.xml
  • Relative Path/URL such as .\StyleSheets\StyleSheet1.xml or ~/StyleSheets/StyleSheet1.xml
  • Resource Name such as Application1.Resources.StyleSheet1.xml

When you add a new external style sheet to the collection it will be recorded via Relative or Absolute path depending on the file's location. If the file that you chose is located inside the current project root directory the style sheet will be recorded via relative path, otherwise it will be recorded via absolute path. Later you can change the way it is serialized by changing its location kind from the combo box next to its name.

Absolute Path/URL

The external style sheet file does not have to be a part of the project since it is referenced absolutely.

Relative Path/URL

When an external style sheet is referenced relatively the path is relative to the project root folder. The project item representing the style sheet file should have its "Copy to Output Directory"="Copy Always". When you use the Collection Editor, a project item for the style sheet file will be created automatically, if it does not exists, and it will be moved to a folder named "StyleSheets" under the project root and its "Copy to Output Directory" property will be adjusted automatically as well.

Resource Name

You can reference an external style sheet as an embedded resource by its name. The name should be the case-sensitive name of the manifest resource being requested. The project item representing the style sheet file should have its "Build Action"="Embedded Resource". When you use the Collection Editor, a project item for the style sheet file will be created automatically, if it does not exists, it will be moved to a folder named "Resources" under the project root and its "Build Action" property will be adjusted automatically as well. In the end the generated name will look something like MyApplication1.Resources.StyleSheet1.xml, where MyApplication1 is the default project namespace and the file is located in the folder Resources.

Specifying an URL for the external style sheet can be done only programmatically. It is not supported directly from the Collection Editor.


Understanding Style Selectors

Telerik Reporting Q3 2008 Send comments on this topic.
Understanding Style Selectors
See Also
Styling Reports > Understanding Style Selectors

Glossary Item Box

Style Selectors are used to define how a style will be applied globally to items in a report. Each Style Rule that you create (either in code or using the StyleRule Collection Editor) must be created as one of the following four selectors:

  • TypeSelector
  • AttributeSelector
  • StyleSelector
  • DescendantSelector

TypeSelector

A TypeSelector applies to all report items of a particular type, for example a Telerik.Reporting.TextBox or a Telerik.Reporting.PageFooterSection.

When a style is defined as a TypeSelector, the formatting for that style is automatically applied to all items on the report that match the type.

AttributeSelector

An AttributeSelector applies to all report items with a particular attribute (such as Color=Red).

Using an AttributeSelector Style Rule, you could specify that any report item on the report that has children (for example. where the value of the HasChildren property is equal to True) should be Bold.

StyleSelector

A StyleSelector applies to all report items with a particular style name. When defining a StyleSelector style, use the Name property to create a name for the style. Each report item has a StyleName property. By setting the value of StyleName to the name of the StyleSelector Style Rule, that report item will display the attributes of the named style.

DescendantSelector

A DescendantSelector applies to all parent/child report item combinations. The actual Style Rule for the child can be specified by any type of Selector.

For example, you can specify that any TextBox that exists inside of a ReportHeaderSection should have a particular style using a TypeSelector within the DescendantSelector.

Alternatively, you can create multiple StyleSelector Style Rules with the same Name and that descend from different report item types, such as DetailSection or GroupSection. Report items with this Name value in their StyleName property will apply the correct style based on where they are placed in the report , even if they are moved.

See Also

Styling Reports
Using Styles to Customize Reports
Creating Style Rules


Creating Style Rules

Telerik Reporting Q3 2008 Send comments on this topic.
Creating Style Rules
Styling Reports > Creating Style Rules

Glossary Item Box

Style definitions can be stored in a Style Rule. Style Rules can be created in the designer or in code.

Style Rules are defined as one of the following four types:

  • A TypeSelector applies to all report items of a particular type.
  • An AttributeSelector applies to all report items with a particular attribute (such as Color=Red).
  • A StyleSelector applies to all report items with a particular style name.
  • A DescendantSelector applies to all report items descended from another report item, which in turn can be specified by any type of selector.

See Understanding Style Selectors for more information about the types of Style Rules.

Creating Rules Using the StyleRule Collection Editor

  1. Open the report in design view.
  2. Select the Report object.
  3. Click in the StyleSheet property, and then click the ellipsis button to open the StyleRule Collection Editor.

Creating a TypeSelector StyleRule

Using the StyleRule Collection Editor

  1. In the StyleRule Collection Editor, click Add. A new rule will be added to the Members list and you will see the Selectors and Style properties for the rule.

  1. Click the Selectors property, then click the ellipsis button that appears to the right of (Collection). This action will open TypeSelector Collection Editor.
  2. Click the drop-down arrow on the Add button to choose the type of Selector to create.
  3. Click TypeSelector from the list. Note: TypeSelector is the default type created when you click the Add button.

  4. Click the Type property of the new TypeSelector, and then click the ellipsis button.

  5. Select the Telerik.Reporting.TextBox and click OK. The StyleRule will now apply to all TextBox report items on the report.
  6. Click the plus sign next to Style to expand the Style properties.
  7. Modify any properties you wish to define formatting to be applied to the TextBox report item.
  8. Click OK to save the rules and close the editor window.

Creating a TypeSelector StyleRule in Code

The following code demonstrates the four steps required to create a TypeSelector StyleRule programmatically:

  1. Create a new StyleRule called MyStyleRule.
  2. Add a TypeSelector to the StyleRule and define the type as Telerik.Reporting.TextBox.
  3. Apply some formatting rules to the StyleRule.
  4. Add the StyleRule to the Style Sheet.
[C#] Creating a TypeSelector StyleRule Copy Code
//Create a StyleRule
Telerik.Reporting.Drawing.StyleRule myStyleRule = new Telerik.Reporting.Drawing.StyleRule();
//Add a TypeSelector
myStyleRule.Selectors.AddRange(new Telerik.Reporting.Drawing.ISelector[]
{new Telerik.Reporting.Drawing.TypeSelector(typeof(Telerik.Reporting.TextBox))});
//Add formatting
myStyleRule.Style.BackgroundColor = System.Drawing.Color.Linen;
myStyleRule.Style.Color = System.Drawing.Color.DodgerBlue;
myStyleRule.Style.Font.Name = "Courier New";
//Add rule to Style Sheet
this.StyleSheet.AddRange(new Telerik.Reporting.Drawing.StyleRule[] {myStyleRule});

[VB] Creating a TypeSelector StyleRule Copy Code
'Create a StyleRule
Dim MyStyleRule As Telerik.Reporting.Drawing.StyleRule = New Telerik.Reporting.Drawing.StyleRule
'Add a TypeSelector
MyStyleRule.Selectors.AddRange(New Telerik.Reporting.Drawing.ISelector() _
{New Telerik.Reporting.Drawing.TypeSelector(GetType(Telerik.Reporting.TextBox))})
'Add formatting
MyStyleRule.Style.BackgroundColor = System.Drawing.Color.LinenMyStyleRule.Style.Color = System.Drawing.Color.DodgerBlue
MyStyleRule.Style.Font.Name = "Courier New"
'Add rule to Style Sheet
Me.StyleSheet.AddRange(New Telerik.Reporting.Drawing.StyleRule() {MyStyleRule})

Creating a StyleSelector StyleRule

Using the StyleRule Collection Editor

  1. In the StyleRule Collection Editor, click Add. A new rule will be added to the Members list and you will see the Selectors and Style properties for the rule.
  2. Click the Selectors property, and then click the ellipsis button to open the TypeSelector Collection Editor window.
  3. Click the drop-down arrow on the Add button to choose the type of Selector to create.
  4. Click StyleSelector from the list.
  5. Type a name for the Style into the StyleName property.

  6. Click OK to return to the StyleRule Collection Editor.
  7. Expand the Style property and modify the formatting properties as desired.
  8. When finished, click OK to close the StyleRule Collection Editor.

Creating a StyleSelector StyleRule in Code

The following code demonstrates the four steps required to create a StyleSelector StyleRule programmatically:

  1. Create a new StyleRule called MyStyleRule.
  2. Add a TypeSelector to the StyleRule and give it a StyleName, such as CaptionStyle.
  3. Apply some formatting rules to the StyleRule.
  4. Add the StyleRule to the Style Sheet.
[C#] Creating a StyleSelector StyleRule Copy Code
//Create a StyleRule
Telerik.Reporting.Drawing.StyleRule myStyleRule = new Telerik.Reporting.Drawing.StyleRule();
//Add a StyleSelector
myStyleRule.Selectors.AddRange(new Telerik.Reporting.Drawing.ISelector[]
{ new Telerik.Reporting.Drawing.StyleSelector("CaptionStyle")});
//Add formatting
myStyleRule.Style.BackgroundColor = System.Drawing.Color.Linen;
myStyleRule.Style.Color = System.Drawing.Color.DodgerBlue;
myStyleRule.Style.Font.Name = "Courier New";
//Add rule to Style Sheet
this.StyleSheet.AddRange(new Telerik.Reporting.Drawing.StyleRule[] {myStyleRule});
[VB] Creating a StyleSelector StyleRule Copy Code
'Create a StyleRule
Dim MyStyleRule As Telerik.Reporting.Drawing.StyleRule = New Telerik.Reporting.Drawing.StyleRule
'Add a StyleSelector
MyStyleRule.Selectors.AddRange(New Telerik.Reporting.Drawing.ISelector() _
{New Telerik.Reporting.Drawing.StyleSelector("CaptionStyle")})
'Add(formatting)
MyStyleRule.Style.BackgroundColor = System.Drawing.Color.Linen
MyStyleRule.Style.Color = System.Drawing.Color.DodgerBlue
MyStyleRule.Style.Font.Name = "Courier New"

'Add rule to Style Sheet
Me.StyleSheet.AddRange(New Telerik.Reporting.Drawing.StyleRule() {MyStyleRule})

Applying StyleSelector StyleRules

Each report item has a StyleName property.

Type the StyleName of the desired StyleRule into the report item's StyleName property to apply the formatting of the StyleRule.

Creating a DescendantSelector StyleRule

Using the StyleRule Collection Editor

  1. In the StyleRule Collection Editor, click Add. A new rule will be added to the Members list and you will see the Selectors and Style properties for the rule.
  2. Click the Selectors property, and then click the ellipsis button to open the TypeSelector Collection Editor window.
  3. Click the drop-down arrow on the Add button to choose the type of Selector to create.
  4. Click DescendantSelector from the list.

The DescendantSelector is made up of additional Selectors.

  5. Click the Selectors property, and then click the ellipsis button to open up a new TypeSelector Collection Editor window.

In this new TypeSelector Collection Editor window, you will define the Selectors that make up the DescendantSelector.

  6. Click Add to add a new TypeSelector.
  7. Click Type, and then click the ellipsis button to open up the Select Type dialog.
  8. Select the Telerik.Reporting.DetailSection type.
  9. Add another new TypeSelector and set its type to Telerik.Reporting.TextBox.

  10. Click OK to close the window and return to the TypeSelector Collection Editor window for the DescendantSelector.
  11. Click OK to close this window and return to the StyleRule Collection Editor window.

  12. Expand the Style property to define the formatting for the DetailSection TextBox StyleRule.
  13. Click OK when complete.

Creating a DescendantSelector StyleRule in Code

The following code demonstrates the four steps required to create a DescendantSelector StyleRule programmatically:

  1. Create a new StyleRule called MyStyleRule.
  2. Create a new DescendantSelector.
  3. Add Selectors to the DescendantSelectors. If you are using TypeSelectors, define the types too.
  4. Add a TypeSelector to the StyleRule and give it a StyleName, such as CaptionStyle.
  5. Apply some formatting rules to the StyleRule.
  6. Add the StyleRule to the Style Sheet.
[C#] Creating a DescendantSelector StyleRule Copy Code
//Create StyleRule and DescendantSelector
Telerik.Reporting.Drawing.StyleRule myStyleRule = new Telerik.Reporting.Drawing.StyleRule();
Telerik.Reporting.Drawing.DescendantSelector myDescendantSelector =
new Telerik.Reporting.Drawing.DescendantSelector();
//Define the Selectors and Types of the DescendantSelector
myDescendantSelector.Selectors.AddRange(
new Telerik.Reporting.Drawing.ISelector[]
{ new Telerik.Reporting.Drawing.TypeSelector(typeof(Telerik.Reporting.ReportHeaderSection)),
new Telerik.Reporting.Drawing.TypeSelector(typeof(Telerik.Reporting.TextBox))
});
//Add the DescendantSelector to the StyleRule
myStyleRule.Selectors.AddRange(
new Telerik.Reporting.Drawing.ISelector[]
{
myDescendantSelector
});
//Apply Formatting
myStyleRule.Style.BorderStyle.Default = Telerik.Reporting.Drawing.BorderType.Ridge;
myStyleRule.Style.Color = System.Drawing.Color.Navy;
myStyleRule.Style.Font.Name = "Arial";
//Add rule to Style Sheet
this.StyleSheet.AddRange(new Telerik.Reporting.Drawing.StyleRule[] {myStyleRule});
[VB] Creating a StyleSelector StyleRule Copy Code
'Create StyleRule and DescendantSelector
Dim MyStyleRule As Telerik.Reporting.Drawing.StyleRule = New Telerik.Reporting.Drawing.StyleRule
Dim MyDescendantSelector As Telerik.Reporting.Drawing.DescendantSelector = _
New Telerik.Reporting.Drawing.DescendantSelector
'Define the Selectors and Types of the DescendantSelector
MyDescendantSelector.Selectors.AddRange(New Telerik.Reporting.Drawing.ISelector() _
{New Telerik.Reporting.Drawing.TypeSelector(GetType(Telerik.Reporting.ReportHeaderSection)), _
New Telerik.Reporting.Drawing.TypeSelector(GetType(Telerik.Reporting.TextBox))})
'Add the DescendantSelector to the StyleRule
MyStyleRule.Selectors.AddRange(New Telerik.Reporting.Drawing.ISelector() {DescendantSelector1})
'Apply formatting
MyStyleRule.Style.BorderStyle.Default = Telerik.Reporting.Drawing.BorderType.Ridge
MyStyleRule.Style.Color = System.Drawing.Color.Navy
MyStyleRule.Style.Font.Name = "Arial"
'Add the StyleRule to the Style Sheet
Me.StyleSheet.AddRange(New Telerik.Reporting.Drawing.StyleRule() {MyStyleRule})


Styling Using the Context Menu

Telerik Reporting Q3 2008 Send comments on this topic.
Styling Using the Context Menu
See Also
Styling Reports > Styling Using the Context Menu

Glossary Item Box

The context menu for a report's report item allows you to modify styles easily.

Right-clicking on a report item opens the following context menu:

Style...

The Style... option will open the Edit style dialog so that you can make changes to the formatting of the report item.

Copy Style

Copy Style will place the details of the report item's style into the clipboard.

Paste Style

Paste Style will apply the style that was copied using Copy Style. Note that the style will be applied as an Inline style, regardless of the source. This means that the report item's style properties will be modified to match the source control.

Reset Style

If a report item's style properties were modified, clicking Reset Style will remove Inline styling and reset the report item to use either the parent report item's style or any Global styling that was applied with StyleSelectors. See for more information.

See Also

Style Inheritance and Overriding

Styling Reports
Understanding Style Selectors


Conditional Formatting

Telerik Reporting Q3 2008 Send comments on this topic.
Conditional Formatting
Styling Reports > Conditional Formatting

Glossary Item Box

Conditional formatting lets you dynamically style report items based on rules that you define in the Conditional Formatting Rules Dialog. This lets you change the visual appearance of the report based on changing conditions in the report without the need for coding events. Conditional formatting applies to any report item including sections and the report itself, all using the same Conditional Formatting Rules Dialog user interface. See also the Extending the Simple Report Design Quickstart Quickstart for a walkthrough demonstration of the conditional formatting feature.

The ConditionalFormatting property contains a collection of formatting rules that are evaluated in the order they are defined. Each rule has an associated style that lets you change styling characteristics when the rule is satisfied. You can choose to stop evaluating rules if a particular rule condition is met.

Each filter condition is made up of an Expression, Operator and Value. The Expression can be a data field from the Fields collection or defined using the Edit Expression Dialog. Operator can be simple comparison operators but can also include Like and additional operators to include the top and bottom number of records and the top and bottom percentage of records. See the table of operators below. Value can a literal value, "<blank>" or an expression defined in the Edit Expression Dialog. When all the filter conditions are met, the rule is fired and the style is applied.

You can change the Text, Background, Edges and Line Style for the given item using the Style Builder dialog.


The Windows Forms Report Viewer

Telerik Reporting Q3 2008 Send comments on this topic.
The Windows Forms Report Viewer
The Windows Forms Report Viewer > The Windows Forms Report Viewer

Glossary Item Box

The Windows Forms Report Viewer is designed to render Telerik Reports within Windows Forms projects.

The toolbar on the Windows Forms Report Viewer provides basic functionality for interacting with the currently-loaded report:

  • Stop loading (useful when a large report is taking a long time to load)
  • Refresh
  • Go to first page
  • Go to previous page
  • Go to a specific page
  • Total number of pages
  • Go to next page
  • Go to last page
  • Print
  • Export
  • Zoom level


Embedding the Windows Forms Report Viewer on a Form

Telerik Reporting Q3 2008 Send comments on this topic.
Embedding the Windows Forms Report Viewer on a Form
See Also
The Windows Forms Report Viewer > Embedding the Windows Forms Report Viewer on a Form

Glossary Item Box

To create a report viewing form, drag the ReportViewer control from the Toolbox to the form design surface. To get the viewer to fill the form area, set the Dock property to Fill.

Here are some commonly used properties of ReportViewer:

  • Set the Report property of the viewer using the drop down list in the Properties Window. Be sure to reference the assembly containing the report so that the report shows up in the drop down. Also be sure to be sure to build the application to have reports show up in the drop down list.
  • To size the report contents to the ReportViewer window use the ZoomMode property. ZoomMode can be set to FullPage, PageWidth or Percent. If set to ZoomPercent, also set the ZoomPercent property.
  • To tailor the controls available in the ReportViewer, set the boolean properties ShowExportButton, ShowPageNavigationControls, ShowPrintButton, ShowProgress and ShowRefreshButton.

To run the report in the viewer, call ReportViewer.RefreshReport() from your application code.

See Also

Setting Windows Forms Report Viewer Properties
Solution Structure


Setting Windows Forms Report Viewer Properties

Telerik Reporting Q3 2008 Send comments on this topic.
Setting Windows Forms Report Viewer Properties
See Also
The Windows Forms Report Viewer > Setting Windows Forms Report Viewer Properties

Glossary Item Box

You can customize the Windows Forms Report Viewer by setting the following properties on the ReportViewer control:

Property | Description
CurrentPage | Sets the page of the report to display.
Report | Sets the type of the report to display.
ShowExportButton | Set to False to hide the Export button.
ShowPageNavigationControls | Set to False to hide the First, Previous, Current, Next, and Last controls.
ShowPrintButton | Set to False to hide the Print button.
ShowProgress | Set to False to suppress the loading indicator while the report is being generated.
ShowRefreshButton | Set to False to hide the Refresh button.
ZoomMode | Can be set to FullPage, PageWidth, or Percent.
ZoomPercent | Allows you to set the current zoom of the report if the ZoomMode is set to Percent.

See Also

ReportViewer Class


Report Viewer Localization

Telerik Reporting Q3 2008 Send comments on this topic.
Report Viewer Localization
See Also
The Windows Forms Report Viewer > Report Viewer Localization

Glossary Item Box

In the Telerik Reporting Viewers, localized resources are stored in separate RESX resource files and loaded according to the current UI culture settings. To understand how localized resources are loaded, it is useful to think of them as being organized in a hierarchical manner.

Types of Resources in the Hierarchy

  • At the top of the hierarchy sit the fallback resources for the default UI culture, which is English (“en”) by default. These are the only resources that do not have their own file. They are stored directly in the assembly of the Report Viewer.
  • Below the fallback resources are the resources for any neutral cultures. A neutral culture is associated with a language but not a region. For example, French ("fr") is a neutral culture. Note that the fallback resources are also for a neutral culture, but a special one.
  • Below those are the resources for any specific cultures. A specific culture is associated with a language and a region. For example, French Canadian ("fr-CA") is a specific culture.

When the Report Viewer tries to load any localized resource and does not find it it will travel up the hierarchy until it finds a resource file containing the requested resource.

The best way to store your resources is to generalize them as much as possible. That means to store localized strings in resource files for neutral cultures rather than specific cultures whenever possible. For instance, if you have resources for the French Belgian ("fr-BE") culture and the resources immediately above are the fallback resources in English, a problem may result when someone uses your application on a system configured for the French Canadian culture. The Report Viewer will look for a RESX file named "fr-CA", it will not find it and will load the fallback resource, which is English, instead of loading the French resources. The following picture shows this undesirable scenario.

If you follow the recommended practice of placing as many resources as possible in a neutral resource file for the "fr" culture, the French Canadian user would not see resources marked for the "fr-BE" culture, but he or she would still see strings in French. The following situation demonstrates this preferred scenario.

Naming Conventions for the Localization Resources

The Report Viewer uses the following naming convention when searching for localized RESX resource files in the main application folder:

  • For the Web Forms Report Viewer, the names of the RESX localization resource files should have the following format:

Telerik.ReportViewer.WebForms.Resources.[culture].resx

  • For the Windows Forms Report Viewer, the names of the RESX localization resource files should have the following format:

Telerik.ReportViewer.WinForms.Resources.[culture].resx

Here “[culture]” is the name of the culture for the specified localization resource. For example, to provide a localization resource for the French Belgian culture, the corresponding resource file should be named as follows:

  • For the Web Forms Report Viewer:

Telerik.ReportViewer.WebForms.Resources.fr-BE.resx

  • For the Windows Forms Report Viewer:

Telerik.ReportViewer.WinForms.Resources.fr-BE.resx

Respectively, to provide a localization resource for the French neutral culture, the corresponding resource file should be named as follows:

  • For the Web Forms Report Viewer:

Telerik.ReportViewer.WebForms.Resources.fr.resx

  • For the Windows Forms Report Viewer:

Telerik.ReportViewer.WinForms.Resources.fr.resx

It is possible to override the default resources for the language neutral culture, which are stored in the assembly of the Report Viewer. In that case the resource file should be named as follows:

  • For the Web Forms Report Viewer:

Telerik.ReportViewer.WebForms.Resources.resx

  • For the Windows Forms Report Viewer:

Telerik.ReportViewer.WinForms.Resources.resx

As described above, if for example the current UI culture is set to French Belgian, the Report Viewer will search for localized RESX resource files inside the main application folder in the following order:

  • For the Web Forms Report Viewer:
  1. Telerik.ReportViewer.WebForms.Resources.fr-BE.resx
  2. Telerik.ReportViewer.WebForms.Resources.fr.resx
  3. Telerik.ReportViewer.WebForms.Resources.resx
  • For the Windows Forms Report Viewer:
  1. Telerik.ReportViewer.WinForms.Resources.fr-BE.resx
  2. Telerik.ReportViewer.WinForms.Resources.fr.resx
  3. Telerik.ReportViewer.WinForms.Resources.resx

The above diagram illustrates a simple view of the resource fallback for a UI culture set to “fr-BE”. The Report Viewer handles the case probing the “fr-BE” RESX resource file for the requested key first, and subsequently falls back to the neutral French culture “fr”, ultimately looking in the default assembly resources for a value if a value has still not been found.

Adding Localization Resources for the Report Viewer

  • For the Web Forms Report Viewer:
  1. Add an ASP.NET folder “App_GlobalResources” to the main project of the web application or web site, if such a folder does not already exist.
  2. Add a new RESX resource file to the “App_GlobalResources” folder. Name the newly-created RESX file according to the naming convention described above.
  3. In the Property Inspector specify the following properties for the resource file:
    1. Build Action: “None”
    2. Copy to Output Directory: “Copy if newer” or “Copy always”
  4. Open the RESX resource file in the Visual Studio Resource Editor. Enter the required resource strings to translate the Report Viewer to the desired language.
  5. Repeat steps from 2 to 4 for each desired translation of the Report Viewer.
  6. Compile and run the project. When viewing a Telerik Report, the Report Viewer should be translated according to the current UI culture.
  • For the Windows Forms Report Viewer:
  1. Add a new RESX resource file to the main project of the application. Name the newly-created RESX file according to the naming convention described above.
  2. In the Property Inspector specify the following properties for the resource file:
    1. Build Action: “None”
    2. Copy to Output Directory: “Copy if newer” or “Copy always”
  3. Open the RESX resource file in the Visual Studio Resource Editor. Enter the required resource strings to translate the Report Viewer to the desired language.
  4. Repeat steps from 1 to 3 for each desired translation of the Report Viewer.
  5. Compile and run the project. When viewing a Telerik Report, the Report Viewer should be translated according to the current UI culture.

Distributing an Application with a Localized Report Viewer

In order to distribute an application that uses Telerik Reporting with a localized Report Viewer, one should distribute all of the required localization RESX resource files, in addition to the main application assemblies. For Web Sites and Web Applications the localization RESX resource files should be placed in the “App_GlobalResources”folder. For Windows Forms Applications the RESX files should be put in the same directory, where the application is installed.

See Also

Hierarchical Organization of Resources for Localization
Setting the Culture and UI Culture for Windows Forms Globalization
Setting the Culture and UI Culture for Web Forms Globalization
Security and Localized Satellite Assemblies


The Web Report Viewer

Telerik Reporting Q3 2008 Send comments on this topic.
The Web Report Viewer
The Web Report Viewer > The Web Report Viewer

Glossary Item Box

The Web Report Viewer is designed to render Telerik Reports within ASP.NET projects.

The Web ReportViewer requires session state for processing of the reports. Please make sure that you DO NOT have EnableSessionState=false in your page directive or <sessionState> Off in your web.config or machine.config files.

The toolbar on the Web Report Viewer provides basic functionality for interacting with the currently-loaded report:

  • Go to first page
  • Go to previous page
  • Go to a specific page
  • Total number of pages
  • Go to next page
  • Go to last page
  • Zoom level
  • Export: Reports can be exported to Web Archive (MSHTML), TIFF, PDF, RTF, Excel and comma delimited files. Use the drop down to select a format, then click the Export button.

  • Refresh
  • Print: "true" print functionality requires the Adobe Reader plug-in (v.6 and above) and uses Image/PDF rendering. If the Adobe Reader browser plug-in is not installed then the default browser printing is used.

In order to have the Web ReportViewer display with 100% height in Internet Explorer, you would need to remove the VS default doctype (or use a less restrictive one) and apply height to the whole DOM tree:

<style type="text/css">
html#html, body#body, form#form1, div#content, center#center
{
border: 0px solid black;
padding: 0px;
margin: 0px;
height: 100%;
}
</style>


Embedding the Web Report Viewer on a Web Form

Telerik Reporting Q3 2008 Send comments on this topic.
Embedding the Web Report Viewer on a Web Form
See Also
The Web Report Viewer > Embedding the Web Report Viewer on a Web Form

Glossary Item Box

To create a report viewing web application, drag the ReportViewer control from the Toolbox to the design surface of a web form.

Here are some commonly used properties of ReportViewer:

  • Set the Report property of the viewer using the drop down list in the Properties Window. Be sure to reference the assembly containing the report so that the report shows up in the drop down. Also be sure to be sure to build the application to have reports show up in the drop down list.
  • To size the report contents to the ReportViewer window use the ZoomMode property. ZoomMode can be set to FullPage, PageWidth or Percent. If set to ZoomPercent, also set the ZoomPercent property.
  • To tailor the controls available in the ReportViewer, set the boolean properties ShowExportGroup, ShowPageNavigationGroup, ShowPrintButton, ShowRefreshButton and ShowZoomSelect.
  • ProgressText: The text that displays in the viewer while the report is being generated. The default is "Generating report...".
  • Skin: Select from one of the predefined skins (see screenshot below). You can also create your own custom toolbar skins.

To assign the report in code:

  • To the web application add a reference to the class library that contains your reports.
    • In the Page_Load event handler add code similar to the example "Assigning a report to the viewer". In the example the report instance is created. If the Report DataSource property changes or hasn't been assigned in the designer, assign the data source after instantiating the report object. Finally assign the report object to the ReportViewer Report property.
    [C#] Assigning a report to the viewer Copy Code
    protected void Page_Load(object sender, EventArgs e)
    {
    if (!IsPostBack)
    {
    Report1 report1 =     new Report1();
    //report1.DataSource = MyDataSource;
    ReportViewer1.Report = report1;
    }
    }

    [VB] Assigning a report to the viewer Copy Code
    Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)
    If Not IsPostBack Then
    Dim report1 As New Report1()
    'report1.DataSource = MyDataSource;
    ReportViewer1.Report = report1
    End If
    End Sub

    • See Also

    Solution Structure


Setting Report Web Viewer Properties

Telerik Reporting Q3 2008 Send comments on this topic.
Setting Report Web Viewer Properties
See Also
The Web Report Viewer > Setting Report Web Viewer Properties

Glossary Item Box

You can customize the Web Report Viewer by setting the following properties on the ReportViewer control:

Property | Description
ProgressText | Customize the text used for the display while the report is being generated.
Report | Set the type of the report to display.
ShowExportGroup | Set to False to hide the Export controls.
ShowNavigationGroup | Set to False to hide the First, Previous, Current, Next, and Last controls.
ShowPrintButton | Set to False to hide the Print button.
ShowRefreshButton | Set to False to hide the Refresh button.
ShowZoomSelect | Set to False to hide the Zoom controls.
ZoomMode | Can be set to FullPage, PageWidth, or Percent.
ZoomPercent | Allows you to set the current zoom of the report if the ZoomMode is set to Percent.

See Also

ReportViewer Class


AJAX support

Telerik Reporting Q3 2008 Send comments on this topic.
AJAX support
The Web Report Viewer > AJAX support

Glossary Item Box

Telerik Web ReportViewer provides full support for ASP.NET AJAX (Asynchronous JavaScript with XMLHttpRequests).

The main idea of the AJAX framework is the elimination of full-page postbacks. In contrast, only the relevant parts of the page are updated, without a disturbing refresh. The markup that is transferred between the client machine and the server is reduced dramatically, which results in a significant performance improvement.

To enable ASP.NET AJAX with our Web ReportViewer you can use our Telerik RadAjaxManager control or the native asp:UpdatePanel control (make sure you have the ASP.NET AJAX framework installed if using .NET2.x):

Use RadAjaxManager to ajaxify the Web ReportViewer

  1. Add the instance of the ReportViewer to a RadAjaxManager control. You can optionally provide it with a loading panel, as shown below:
[ASP.NET] Enable Ajax using RadAjaxManager Copy Code
<telerik:RadAjaxManager ID="RadAjaxManager1" runat="server">
<AjaxSettings>
<telerik:AjaxSetting AjaxControlID="ReportViewer1">
<UpdatedControls>
<telerik:AjaxUpdatedControl ControlID="ReportViewer1" LoadingPanelID="RadAjaxLoadingPanel1"/>
</UpdatedControls>
</telerik:AjaxSetting>
</AjaxSettings>
</telerik:RadAjaxManager>
<telerik:RadAjaxLoadingPanel ID="RadAjaxLoadingPanel1" runat="server" Height="75px" Width="75px" Transparency="25">
<img alt="Loading..." src='<%= RadAjaxLoadingPanel.GetWebResourceUrl(Page, "Telerik.Web.UI.Skins.Default.Ajax.loading.gif") %>' style="border:0;" />
</telerik:RadAjaxLoadingPanel>

Use MS UpdatePanel to ajaxify the Web ReportViewer

1. Wrap the instance of the ReportViewer into asp:UpdatePanel ContentTemplate:

[ASP.NET] Enable Ajax by wrapping into UpdatePanel control Copy Code
<asp:ScriptManager ID="ScriptManager1" runat="server" />
<asp:UpdatePanel ID="UpdatePanel1" runat="server">
<ContentTemplate>
<telerik:ReportViewer ID="ReportViewer1" runat="server" />
</ContentTemplate>
</asp:UpdatePanel>


Client-Side API

Telerik Reporting Q3 2008 Send comments on this topic.
Client-Side API
The Web Report Viewer > Client-Side API

Glossary Item Box

1. Accessing the client-side report viewer object.

The ReportViewer control creates a client-side object with the ClientID of the viewer. You can obtain reference to it by using the following javascript code:

var viewer = <%=ReportViewer1.ClientID%>

2. API

Member | Parameters | Description
PrintReport() | N/A | Starts printing of the document. Uses the Adobe PDF Reader browser add-on if available. Otherwise uses the default print functionality of the browser.
SetZoom(zoomMode, zoomPercent) | zoomMode - · ZoomMode.Percent · ZoomMode.PageWidth · ZoomMode.FullPage zoomPercent - A value indicating the zoom percent. Used only if zoomMode is ZoomMode.Percent. | Specifies the zoom factor for the document.
set_CurrentPage(pageNumber) | pageNumber– number of the page(starts from 1). | Specifies the number of the page which has to be displayed in the viewer.
get_CurrentPage() |  | Returns the number of the page currently shown in the viewer.
get_TotalPages() |  | Returns the total count of document pages.
CanMoveToPage(pageNumber) | pageNumber – the number of the page to which you want to navigate. | Checks whether is possible to navigate to a specific page.
RefreshReport() | N/A | Refreshes the report.
ExportReport(format) | format: - “PDF”– Adobe Portable Document format. - “MHTML”– MIME HTML - “CSV” – Comma-Separated Values. - “IMAGE” – Tiff. - “RTF” – Rich Text Format v1.6. - “XLS” – Excel 97-2003. | Exports the document to one of the specified formats.
PrintAs(format) | format: - “PDF” – uses the Adobe PDF Reader add-on. - “Default” – uses the default printing capabilities of the browser. | Forces the viewer to print the document according to the specified print format.


Report Events

Telerik Reporting Q3 2008 Send comments on this topic.
Report Events
Report Events > Report Events

Glossary Item Box

Expressions, Conditional Formatting and user defined functions provide flexibility to handle most tasks. These tools are typically the most productive way to build reports and should be favored over using events. There are a few cases where additional power and flexibility is required. The Telerik Reporting event model includes events for report, section, and report item.


Understanding Events

Telerik Reporting Q3 2008 Send comments on this topic.
Understanding Events
See Also
Report Events > Understanding Events

Glossary Item Box

Delivering a Telerik Report to the end user is a process involving several stages. Knowledge of the Report Life Cycle is crucial to understanding how events work in Telerik Reporting.

Report Definition

The Report Definition is created during the first stage of the life cycle. This is the actual .NET class that represents the report. It is always a subclass Telerik.Reporting.Report and contains information about report items and their properties. Report items are represented by the private fields of the report class.

Let’s illustrate this with an example. While in design-time, if you add a TextBox to the Detail Section of the report that you are designing, a private field of type TextBox will be added to the code-behind file and some basic initialization code will be generated within the InitalizeComponent method of the report class.

The InitializeComponentmethod initializes (creates) a Report and its child items.It is a special method recognized and parsed by the Report Designer in order to display the report in design-time.

This object will later serve as the definition for creating a concrete instance of the TextBox for each row form the data source. These definition objects are of the types that reside in the Telerik.Reporting namespace, for example Telerik.Reporting.TextBox.

Report Processing

The second stage of the report life cycle involves combining the report definition with the data source. The processing engine performs all grouping, sorting and filtering calculations and iterates over all rows from the data source and creates the appropriate processing items based on the item definitions created earlier and the actual data. Based on the original item definition (Telerik.Reporting.TextBox for example) and the actual data in the current data row a new item is created. This item is known as a processing item (Telerik.Reporting.Processing.TextBox for example) and bears all characteristics of its definition item, but it is bound to the respective data field from the current data row. While the definition TextBox’s Value property may contain something like “=Fields.FirstName”, the processing item’s Text property will be equal to “John”.

The Processing Engine provides the developer with a way to intervene in this process. Just before the processing item is bound to data, the ItemDataBinding event of its definition item is raised. After the processing item has been data bound the ItemDataBound event is raised. By subscribing a listener for those events, the developer can modify the default behavior at run-time. The sender parameter of the event handler methods is in fact the processing report item.

Let us demonstrate this with a simple example. Suppose that we have a TextBox containing the job position of an employee. Assume that the TextBox’s Value property equals “=Fields.JobPosition”, where JobPosition is a column from the data source containing values like “Team Leader”, “Senior Developer”, “Junior Developer”, “Quality Assurance”, etc. For the sake of our example, suppose that we would like to color all developers in Blue.

First we need to attach to the TextBox’s ItemDataBound event.

Double-click the event in the property grid and an event handler method will be automatically generated for you.

[C#] ItemDataBound

 Copy Code
//…
this.textBox1.ItemDataBound += newSystem.EventHandler(this.textBox1_ItemDataBound);
//…
private void textBox1_ItemDataBound(object sender,System.EventArgs e)
{
}
//…
[VB] ItemDataBound Copy Code
'...
Private Sub textBox1_ItemDataBound(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles textBox1.ItemDataBound
End Sub
'...

As we mentioned earlier the sender argument is in fact the processing TextBox that has already been data bound. Its Text property will hold the job position of the current employee. The method will be called for each data row, i.e. for each employee we have in the data source. So the only thing we have left to do is cast the sender, check the position, and do the coloring if needed:

[C#] Event Handler Copy Code
private void textBox1_ItemDataBound(object sender,System.EventArgs e)
{
Telerik.Reporting.Processing.TextBox txtPosition =(Telerik.Reporting.Processing.TextBox)sender;
if(txtPosition.Text.Contains("Developer"))
{
txtPosition.Style.BackgroundColor = Color.Blue;
}
}
[VB] Event Handler Copy Code
Private Sub textBox1_ItemDataBound(ByVal sender As Object, ByVal e As EventArgs)
Dim txtPosition As Telerik.Reporting.Processing.TextBox = DirectCast(sender, Telerik.Reporting.Processing.TextBox)
If txtPosition.Text.Contains("Developer") Then
txtPosition.Style.BackgroundColor = Color.Blue
End If
End Sub
Be very careful when working inside event handlers. If by mistake you modify the reporting item (the private field of the report class, i.e. this.textBox1) instead of its processing counterpart (the sender argument), all subsequent processing items will be modeled after the modified reporting item.

Report Rendering

After processing is over, the processed report is ready for rendering in one of the many available formats.

See Also

Designing Reports
Report Life Cycle


Using Report Events

Telerik Reporting Q3 2008 Send comments on this topic.
Using Report Events
Report Events > Using Report Events

Glossary Item Box

The Report object exposes these events:

Property | Description
ItemAdded | Fires when each item is added to the report.
ItemDataBinding | Fires just before each report item is bound to data.
ItemDataBound | Fires just after each report item is bound to data.
ItemRemoved | Fires when an item is removed from the report.
NeedDataSource | Fires when the report does not have any valid data source bound to it.

The example below shows the NeedDataSource event assigning the report DataSource at runtime. This event only fires when the DataSource is null.

[C#] The NeedDataSource Event Handler Copy Code
private void Report1_NeedDataSource(object sender, System.EventArgs e)
{
string sql =
@"SELECT Production.Product.Name, Production.Product.ProductNumber FROM Production.Product";
string connectionString =
"Data Source=RA\\SQLEXPRESS;Initial Catalog=AdventureWorksT;Integrated Security=True";
SqlDataAdapter adapter = new SqlDataAdapter(sql, connectionString);
DataSet dataSet = new DataSet();
adapter.Fill(dataSet);
(sender as Telerik.Reporting.Processing.Report).DataSource = dataSet;
}
[VB] The NeedDataSource Event Handle Copy Code
Private Sub Report1_NeedDataSource(ByVal sender As Object, ByVal e As System.EventArgs)
Dim sql As String = "SELECT Production.Product.Name, Production.Product.ProductNumber FROM Production.Product"
Dim connectionString As String = "Data Source=RA\SQLEXPRESS;Initial Catalog=AdventureWorksT;Integrated Security=True"
Dim adapter As New SqlDataAdapter(sql, connectionString)
Dim dataSet As New DataSet()
adapter.Fill(dataSet)
(TryCast(sender, Telerik.Reporting.Processing.Report)).DataSource = dataSet
End Sub


Using Section Events

Telerik Reporting Q3 2008 Send comments on this topic.
Using Section Events
See Also
Report Events > Using Section Events

Glossary Item Box

The various report Section objects expose these events:

Property | Description
ItemAdded | Fires when each item is added to the section.
ItemDataBinding | Fires just before the section is bound to data.
ItemDataBound | Fires just after the section is bound to data.
ItemRemoved | Fires when an item is removed from the section.

In ItemDataBinding and ItemDataBound events use the "sender" argument of the event handler to get a reference to the section object. From the section object you can reference any of the items the section contains, i.e. TextBoxes, PictureBoxes, etc. You can also use the section DataItem property to access the data fields for the section.

Be aware that this "sender" section object is of type Telerik.Reporting.Processing.ReportItemBase, not the definition item Telerik.Reporting.ReportItemBase.

The example below demonstrates getting a reference to the detail section of the report and finding a specific TextBox within the section. The example also shows retrieving data source column values for the section and using it to alter the TextBox. In this case if the TextBox is made visible if the "Weight" field value is greater than ten. See the EventsReport in the Visual Studio 2005 examples (find the examples in Start | Telerik | Reporting | VS 2005 Examples).

[C#] Using the ItemDataBound event of a section Copy Code
private void detail_ItemDataBound(object sender, System.EventArgs e)
{
Processing.DetailSection section = sender as Processing.DetailSection;
Processing.ReportItemBase extraShipping = section.Items.Find("extraShippingCostTextBox", false)[0];
DataRowView row = section.DataItem as DataRowView;
if (null != row)
{
object val = row.Row["Weight"];
if (!(val is DBNull) && ((decimal)val) > 10)
{
extraShipping.Visible = true;
}
else
{
extraShipping.Visible = false;
}
}
}
[VB] Using the ItemDataBound event of a sectio Copy Code
Private Sub detail_ItemDataBound(ByVal sender As Object, _
ByVal e As System.EventArgs)
Dim section As Processing.DetailSection = _
TryCast(sender, Processing.DetailSection)
Dim extraShipping As Processing.ReportItemBase = _
section.Items.Find("extraShippingCostTextBox", False)(0)
Dim row As DataRowView = TryCast(section.DataItem, DataRowView)
If Nothing <> row Then
Dim val As Object = row.Row("Weight")
If Not (TypeOf val Is DBNull) AndAlso _
(DirectCast(val, Decimal)) > 10 Then
extraShipping.Visible = True
Else
extraShipping.Visible = False
End If
End If
End Sub

See Also

Display Reports with alternating style rows


Using Report Item Events

Telerik Reporting Q3 2008 Send comments on this topic.
Using Report Item Events
See Also
Report Events > Using Report Item Events

Glossary Item Box

Each report item on a report exposes these events:

Property | Description
ItemAdded | Fires when each item is added to the report.
ItemDataBinding | Fires just before the control is bound to data.
ItemDataBound | Fires just after the control is bound to data.
ItemRemoved | Fires if the control is removed from the report.

The SubReport report item exposes one additional event:

  • NeedDataSource: This event fires when the SubReport does not have a valid data source bound to it. See Display Hierarchical Data with SubReports for an example.

For an example see the FAQ topic "How do I combine values of two columns to a single TextBox?"

See Also

How do I modify TextBox visibility in the ItemDataBound of another TextBox?
How do I combine values of two columns to a single TextBox?
Change row color based on a value in the row


Creating Report Items Programmatically

Telerik Reporting Q3 2008 Send comments on this topic.
Creating Report Items Programmatically
See Also
Programmatic Control of Reports > Creating Report Items Programmatically

Glossary Item Box

Telerik Reporting offers a full API for programmatic control of reports. You can create, modify, and work with reports in code, just as you can from the Visual Studio IDE. In this section, you will see how to perform the following fundamental operations in code:

  • Creating a Report Programmatically
  • Creating Sections Programmatically
  • Creating Report Items Programmatically
  • Exporting a Report Programmatically

See Also

Telerik.Reporting Namespace


Creating a Report Programmatically

Telerik Reporting Q3 2008 Send comments on this topic.
Creating a Report Programmatically
See Also
Programmatic Control of Reports > Creating a Report Programmatically

Glossary Item Box

To create a Telerik report in code, you need to instantiate a Telerik.Reporting.Report object and set its properties. For example, this code will create a report and set up its data source:

[C#] Creating a Telerik Report in Code Copy Code
MyReport report = new MyReport();
SqlCommand sqlSelectCommand1 = new SqlCommand();
SqlDataAdapter sqlDataAdapter1 = new SqlDataAdapter();
SqlConnection sqlConnection1 = new SqlConnection();
sqlConnection1.ConnectionString =
"Data Source=(local)\\SQLEXPRESS;Initial Catalog=AdventureWorksT;Integrated Security=True";
sqlSelectCommand1.CommandText = "SELECT * FROM Sales.Store";
sqlSelectCommand1.Connection = sqlConnection1;
sqlDataAdapter1.SelectCommand = sqlSelectCommand1;
report.DataSource = sqlDataAdapter1;
[VB] Creating a Telerik Report in Code Copy Code
Dim report As New MyReport()
Dim sqlSelectCommand1 As New SqlCommand()
Dim sqlDataAdapter1 As New SqlDataAdapter()
Dim sqlConnection1 As New SqlConnection()
sqlConnection1.ConnectionString = "Data Source=(local)\SQLEXPRESS;Initial Catalog=AdventureWorksT;Integrated Security=True"
sqlSelectCommand1.CommandText = "SELECT * FROM Sales.Store"
sqlSelectCommand1.Connection = sqlConnection1
sqlDataAdapter1.SelectCommand = sqlSelectCommand1
report.DataSource = sqlDataAdapter1

See Also

Report Class


Creating Sections Programmatically

Telerik Reporting Q3 2008 Send comments on this topic.
Creating Sections Programmatically
See Also
Programmatic Control of Reports > Creating Sections Programmatically

Glossary Item Box

To create sections in code, instantiate the appropriate object, set its properties, and add it to the Report object's Items collection. The objects you will need to work with are:

  • DetailSection--for a detail section
  • GroupHeaderSection--for a group header
  • GroupFooterSection--for a group footer
  • PageHeaderSection--for a page header
  • PageFooterSection--for a page footer
  • ReportHeaderSection--for a report header
  • ReportFooterSection--for a report footer

For example, this code creates a detail section and adds it to the report:

[C#] Creating and adding a DetailSection in Code Copy Code
DetailSection detail = new DetailSection();
detail.Size = new Telerik.Reporting.Drawing.SizeU(
new Telerik.Reporting.Drawing.Unit(6, Telerik.Reporting.Drawing.UnitType.Inch),
new Telerik.Reporting.Drawing.Unit(.3, Telerik.Reporting.Drawing.UnitType.Inch));
report.Items.Add((ReportItemBase)detail);
[VB] Creating and adding a DetailSection in Code Copy Code
Dim detail As New DetailSection()
detail.Size = New Telerik.Reporting.Drawing.SizeU(_
New Telerik.Reporting.Drawing.Unit(6, Telerik.Reporting.Drawing.UnitType.Inch), _
New Telerik.Reporting.Drawing.Unit(0.3, Telerik.Reporting.Drawing.UnitType.Inch))
report.Items.Add(DirectCast(detail, ReportItemBase)

See Also

DetailSection Class
GroupHeaderSection Class
GroupFooterSection Class
PageHeaderSection Class
PageFooterSection Class
ReportHeaderSection Class
ReportFooterSection Class


Creating Report Items Programmatically

Telerik Reporting Q3 2008 Send comments on this topic.
Creating Report Items Programmatically
See Also
Programmatic Control of Reports > Creating Report Items Programmatically

Glossary Item Box

To create a report item in code, instantiate a report item object, set its properties, and add it to the Items collection of the section where you wish the control to appear. For example, this code will add two TextBox report items to a report:

[C#] Instantiating Report Items in Code Copy Code
Telerik.Reporting.TextBox textBox1 = new Telerik.Reporting.TextBox();
Telerik.Reporting.TextBox textBox2 = new Telerik.Reporting.TextBox();
textBox1.Value = "=CustomerID";
textBox1.Location = new Telerik.Reporting.Drawing.PointU(
new Telerik.Reporting.Drawing.Unit(0, Telerik.Reporting.Drawing.UnitType.Inch),
new Telerik.Reporting.Drawing.Unit(0, Telerik.Reporting.Drawing.UnitType.Inch));
textBox1.Size = new Telerik.Reporting.Drawing.SizeU(
new Telerik.Reporting.Drawing.Unit(1, Telerik.Reporting.Drawing.UnitType.Inch),
new Telerik.Reporting.Drawing.Unit(0.25, Telerik.Reporting.Drawing.UnitType.Inch));
textBox2.Value = "=Name";
textBox2.Location = new Telerik.Reporting.Drawing.PointU(
new Telerik.Reporting.Drawing.Unit(1.25, Telerik.Reporting.Drawing.UnitType.Inch),
new Telerik.Reporting.Drawing.Unit(0, Telerik.Reporting.Drawing.UnitType.Inch));
textBox2.Size = new Telerik.Reporting.Drawing.SizeU(
new Telerik.Reporting.Drawing.Unit(4.75, Telerik.Reporting.Drawing.UnitType.Inch),
new Telerik.Reporting.Drawing.Unit(0.25, Telerik.Reporting.Drawing.UnitType.Inch));
detail.Items.AddRange(new Telerik.Reporting.ReportItemBase[] {textBox1, textBox2});
[VB] Instantiating Report Items in Code Copy Code
Dim textBox1 As New Telerik.Reporting.TextBox()
Dim textBox2 As New Telerik.Reporting.TextBox()
textBox1.Value = "=CustomerID"
textBox1.Location = New Telerik.Reporting.Drawing.PointU(_
New Telerik.Reporting.Drawing.Unit(0, Telerik.Reporting.Drawing.UnitType.Inch),_
New Telerik.Reporting.Drawing.Unit(0, Telerik.Reporting.Drawing.UnitType.Inch))
textBox1.Size = New Telerik.Reporting.Drawing.SizeU(_
New Telerik.Reporting.Drawing.Unit(1, Telerik.Reporting.Drawing.UnitType.Inch),_
New Telerik.Reporting.Drawing.Unit(0.25, Telerik.Reporting.Drawing.UnitType.Inch))
textBox2.Value = "=Name"
textBox2.Location = New Telerik.Reporting.Drawing.PointU(_
New Telerik.Reporting.Drawing.Unit(1.25, Telerik.Reporting.Drawing.UnitType.Inch),_
New Telerik.Reporting.Drawing.Unit(0, Telerik.Reporting.Drawing.UnitType.Inch))
textBox2.Size = New Telerik.Reporting.Drawing.SizeU(_
New Telerik.Reporting.Drawing.Unit(4.75, Telerik.Reporting.Drawing.UnitType.Inch),_
New Telerik.Reporting.Drawing.Unit(0.25, Telerik.Reporting.Drawing.UnitType.Inch))
detail.Items.AddRange(New Telerik.Reporting.ReportItemBase() {textBox1, textBox2})

See Also

TextBox Class
PictureBox Class
Panel Class
SubReport Class
Shape Class


Exporting a Report Programmatically

Telerik Reporting Q3 2008 Send comments on this topic.
Exporting a Report Programmatically
See Also
Programmatic Control of Reports > Exporting a Report Programmatically

Glossary Item Box

Requirements

To export a report, you can use the Render method of the ReportProcessor object. This method converts the contents of the report to a byte array in the specified format, which you can then use with other classes such as MemoryStream or FileStream.

To use this method, your project must contain references to Telerik.Reporting, Telerik.Reporting.Processing, and the appropriate rendering extension.

Exporting a report to an Adobe Acrobat file:

[C#] Exporting a Report to PDF Copy Code
Report1 report1 = new Report1();
string mimType = string.Empty;
string extension = string.Empty;
Encoding encoding = null;
byte[] buffer = Telerik.Reporting.Processing.ReportProcessor.Render(
"PDF", report1, null, out mimType, out extension, out encoding);
FileStream fs = new FileStream("c:\\report1.pdf", FileMode.Create);
fs.Write(buffer, 0, buffer.Length);
fs.Flush();
fs.Close();
[VB] Exporting a Report to PDF Copy Code
Dim report1 As New Report1()
Dim mimType As String = String.Empty
Dim extension As String = String.Empty
Dim encoding As Encoding = Nothing
Dim buffer As Byte() = Telerik.Reporting.Processing.ReportProcessor.Render("PDF", report1, Nothing, mimType, extension, encoding)
Dim fs As New FileStream("c:\report1.pdf", FileMode.Create)
fs.Write(buffer, 0, buffer.Length)
fs.Flush()
fs.Close()

Exporting a report to an image file:

You can render a report in all graphic formats that GDI+ supports natively - this includes BMP, GIF, JPEG, PNG, TIFF and metafile (EMF). The WinViewer internally uses metafile for rendering the reports for viewing, and TIFF for exporting. As of now the rest are available only through code using the ReportProcessor.Render method where you should specify "IMAGE" as the export format in which the report should be rendered and the additional output format that is the actual graphic format - BMP, GIF, JPEG (uppercase just like stated above). Here is an example that renders a report as a JPEG image:

[C#] Exporting to Image Copy Code
Report1 report1 = new Report1();
string mimType = string.Empty;
string extension = string.Empty;
Encoding encoding = null;
try
{
Hashtable deviceInfo = new Hashtable();
deviceInfo["OutputFormat"] = "JPEG";
byte[] buffer = Telerik.Reporting.Processing.ReportProcessor.Render(
"IMAGE", report1, deviceInfo, out mimType, out extension, out encoding);
using (FileStream fs = new FileStream(@"c:\test.jpg", FileMode.Create))
{
fs.Write(buffer, 0, buffer.Length);
}
}
catch (Exception ex)
{
Response.Write(ex);
}
[VB] Exporting to Image Copy Code
Dim report1 As New Report1()
Dim mimType As String = String.Empty
Dim extension As String = String.Empty
Dim encoding As Encoding = Nothing
Try
Dim deviceInfo As New Hashtable()
deviceInfo("OutputFormat") = "JPEG"
Dim buffer As Byte() = Telerik.Reporting.Processing.ReportProcessor.Render("IMAGE", report1, deviceInfo, mimType, extension, encoding)
Using fs As New FileStream("c:\test.jpg", FileMode.Create)
fs.Write(buffer, 0, buffer.Length)
End Using
Catch ex As Exception
Response.Write(ex)
End Try

See Also

Render Method


Localizing Reports

Telerik Reporting Q3 2008 Send comments on this topic.
Localizing Reports
Advanced Topics > Localizing Reports

Glossary Item Box

You can localize your reports to display in the language of a specific culture. For example, your report may display in both English and Spanish (see figure below).

Telerik Reporting uses a similar methodology for localization as Visual Studio uses for Windows Forms. The designer lets you define static text for the report (e.g. column headings, titles) in each language that you specify. A resource file (resx) is automatically created for each language to store translated text. For more background information on localizing applications see the MSDN article Globalizing and Localizing Applications.

To localize a report:

  1. In the designer set the Report Localizable property to true.
  2. Select a Language property value from the drop down list in the properties window.
  3. Translate the static text into the desired language indicated by the Language property.

To run a localized report:

  1. Add Threading and Globalization namespaces to your application.
  2. Set the current thread CurrentUICulture to a new instance of CultureInfo. The CultureInfo constructor takes the culture code of the language you want to display. For example "en-US" for United States English or "es-MX" for Mexican Spanish.
  3. Optionally you can set the CurrentCulture for the current thread to the culture code of the language you wish to display. CurrentCulture affects dynamic data such as date, time and money formats. The "Birth Date" column date format in the figure above shows Month/Day/Year in English, but in Day/Month/Year format in the Spanish example.
  4. Create an instance of the report and assign it to the ReportViewer Report property.
    If you are using a ReportViewer in a Windows application, call the RefreshReport() method of the ReportViewer.
[C#] Setting the language at runtime Copy Code
using System.Threading;
using System.Globalization;
// . . .
// Set the language for static text (i.e. column headings, titles)
Thread.CurrentThread.CurrentUICulture = new CultureInfo("es-MX");
// Set the language for dynamic text (i.e. date, time, money)
Thread.CurrentThread.CurrentCulture = new CultureInfo("es-MX");
reportViewer1.Report = new Report1();
// If this is a Windows application, refresh the report
reportViewer1.RefreshReport();
Example Title Copy Code
Imports System.Threading
Imports System.Globalization
'. . .

' Set the language for static text (i.e. column headings, titles)
Thread.CurrentThread.CurrentUICulture = New CultureInfo("es-MX")
' Set the language for dynamic text (i.e. date, time, money)
Thread.CurrentThread.CurrentCulture = New CultureInfo("es-MX")
reportViewer1.Report = New Report1()
' If this is a Windows application, refresh the report
reportViewer1.RefreshReport()


Creating Multi-Column Reports

Telerik Reporting Q3 2008 Send comments on this topic.
Creating Multi-Column Reports
Advanced Topics > Creating Multi-Column Reports

Glossary Item Box

You can create a multi-column report by modifying the DetailSection.ColumnCount property. Column width is determined by the width of the report in design view. The DetailSection.ColumnSpacing property is used to set the spacing in between the columns. Column data is rendered down the page and then across.

Making a Report into a Multi-Column Report

HTML only supports one-column reports.
  1. Click the DetailSection of the report.
  2. In the Properties window, change the ColumnCount property to 4.
  3. Resize the report to match the desired width of the columns. You can do this visually or by setting the Width property of the report in the Properties window.
  4. Resize any report items so that they are not greater than the width of the report.
If the report does not render the number of columns set in ColumnCount, it is likely due to either the report width being too large or a control in the DetailSection is too large. Check for report items that are greater than the width of the report.

A Sample Multi-Column Report

Below is a report in design and then run time mode which has the following properties:

Report.Width=1.5in
DetailSection.ColumnCount=4
DetailSection.ColumnSpacing=0in.

The report has a Group. The Group is displayed along with the detail section, and therefore, is incorporated into the columns.

The report title, A Very Long Contact List, is wider than the report width and does not fully display at design time. In design mode all of the sections are the width of the report. At run time, the Page and Report Header and Footer sections span the actual width of the report, not the width of the column.

The run time report is displayed below the design time report.


Rendering Extensions

Telerik Reporting Q3 2008 Send comments on this topic.
Rendering Extensions
Configuring Telerik Reporting > Rendering Extensions

Glossary Item Box

A rendering extension is a component of the Telerik Reporting engine that transforms report data and layout into a device-specific format. By default Telerik Reporting outputs reports in the next formats: Image, PDF, HTML, MHTML, Excel and CSV. You can specify rendering extension parameters in your application’s configuration file to override the default report rendering behavior. The rendering extension parameters are specified as device information settings.

Adding device information settings to an application configuration file is useful when you want to override the default values that are provided by the reporting engine. Specifying device information settings in the configuration files affects rendering extensions globally. The settings in the configuration files are used in place of default values whenever a particular rendering extension is used. If you want to set rendering extension parameters for a specific report or rendering operation, you must specify device information programmatically using the Telerik.Reporting.Processing.ReportProcessor.Render method. For more information about specifying device information settings for a rendering operation, and to view the complete list of device information settings, see Telerik Reporting Device Information Settings.

For Windows applications the configuration file is called app.config and for ASP.NET applications – web.config. For more information about configuring a .NET application, see Configuring Applications( http://msdn2.microsoft.com/en-us/library/kza1yk3a(VS.80).aspx).
All configuration settings on Telerik Reporting engine are applied only at runtime, not in design-time.

The following table describes the rendering extensions that are included with Telerik Reporting:

Extension Name | Description | Type
IMAGE | Renders a report in a page-oriented format. The format is shown as TIFF in the Export drop-down of the report toolbar. | Telerik.Reporting.ImageRendering.ImageReport, Telerik.Reporting.Processing, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
PDF | Renders a report in the Adobe Acrobat Reader. The format is shown as Acrobat (PDF) File in the Export drop-down of the report toolbar. | Telerik.Reporting.ImageRendering.PdfReport, Telerik.Reporting.Processing, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
HTML | Renders a report in XHTML 1.1 compliant HTML. | Telerik.Reporting.HtmlRendering.HtmlRenderingExtension, Telerik.Reporting.Processing, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
MHTML | Renders a report in MHTML. The report opens in Internet Explorer. The format is shown as Web Archive in the Export drop-down of the report toolbar. | Telerik.Reporting.HtmlRendering.MHtmlRenderingExtension, Telerik.Reporting.Processing, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
XLS | Renders a report in Microsoft Excel. The report opens in Microsoft Excel 97 or later. | Telerik.Reporting.ExcelRendering.Excel97.ExcelReport, Telerik.Reporting.Processing, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
CSV | Renders a report in comma-delimited format. The report opens in a viewing tool associated with CSV file formats. | Telerik.Reporting.CsvRendering.CsvRenderingExtension, Telerik.Reporting.Processing, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
RTF | Renders a report in Rich Text Format. The report opens in Microsoft Word 97 or later. | Telerik.Reporting.ImageRendering.RtfReport, Telerik.Reporting.Processing, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be

Replace the the bold red version number above with the current version of the Telerik Reporting assembly that you are using. To see what version you are currently working with, open your project in Visual Studio, expand the References node in Solution Explorer, locate and select the Telerik.Reporting.Processing assembly reference and look at its properties in the Property Window. The Version property displays the number that you are looking for.


Configuring Telerik Reporting

Telerik Reporting Q3 2008 Send comments on this topic.
Configuring Telerik Reporting
See Also
Configuring Telerik Reporting > Configuring Telerik Reporting

Glossary Item Box

Adding Telerik Reporting Settings to an Application Configuration File

Telerik Reporting settings are defined in a custom configuration section called Telerik.Reporting. In order to process the configuration file correctly the .NET Framework requires this section to be the first child element in the <configuration> element, like this:

Config File

 Copy Code
<configuration>
<configSections>
<section
name="Telerik.Reporting" type="Telerik.Reporting.Processing.Config.ReportingConfigurationSection, Telerik.Reporting.Processing, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be"
allowLocation="true"
allowDefinition="Everywhere"/>
</configSections>
…
</configuration>

<Telerik.Reporting> Configuration Section

 Copy Code
<Telerik.Reporting>
<Extensions>
<Render>
<Extension>
<Parameters>
<Parameter/>
</Parameters>
</Extension>
</Render>
</Extensions>
</Telerik.Reporting>
For Windows applications the configuration file is called app.config and for ASP.NET applications – web.config. For more information about configuring a .NET application, see Configuring Applications( http://msdn2.microsoft.com/en-us/library/kza1yk3a(VS.80).aspx).

<Telerik.Reporting> element

Telerik.Reporting XML element is the root element of the Telerik Reporting engine settings. All the settings of the Reporting engine are nested in it.

Attributes

No attributes are defined for this element

Child elements

Extensions – Specifies a collection of extensions, for witch configuration is applied

Parent element

Configuration - Specifies the required root element in every configuration file that is used by the common language runtime and the .NET Framework applications. Only one Telerik.Reporting element can be used in the Configuration element.

<Extensions> element

Extensions XML element specifies a collection of extension types, for witch configuration is applied.

Attributes

No attributes are defined for this element

Child elements

Render – Specifies a collection of render extensions, for witch the configuration settings are applied.

Parent element

Telerik.Reporting - Specifies the root element of the Telerik Reporting configuration settings. Only one Extensions element can be used in the Telerik.Reporting element.

<Render> element

Render XML element specifies a collection of extensions, for witch configuration is applied.

Attributes

No attributes are defined for this element

Child elements

Extension – Specifies an extension, for witch the configuration settings are applied. Multiple Extension elements can be applied in the Render element

Parent element

Extensions - Specifies a collection of extension types, for witch configuration is applied. Only one Render element can be used in the Extensions element.

<Extension> element

Extension XML element specifies an extension, for witch the configuration settings are applied.

Attributes

name – Required string attribute. Name is the key attribute that determines on witch extension the configuration is to be applied. The name for every extension is defined in the class definition of the extension, in the ExtensionNameAttribute attribute.

  • type – Optional string attribute. It is used when new extension is added or a core extension is overridden with a new one. Specifies the name of the extension class to be used when an extension with the name specified in the name attribute is needed. Use the following format:

type="Fully qualified class name, assembly file name, version, culture, public key token"

For example : type="MyAssembly.MyExtension, MyAssembly, Version=1.0.0.0, Culture=neutral,PublicKeyToken=null"

  • description - Optional string attribute. Defines a description for the extension.It is used to override the default description of the extension. The reporting engine uses the description in places where the extensions are listed. For example in the Win and Web ReportViewer controls descriptions are used as labels in the dropdownwith available export formats. The default value of the description of every extension is defined in the class definition of the extension, by the ExtansionDescriptionAttribute attribute.
  • visible – Optional boolean attribute(the valid values are visible=”true” or visible=”false”). The value is used to determine if the extension must be populated in the lists of available extensions. The default value is true. You can use it to hide the export format from the list of the available render extensions.

Child elements

Parameters – Specifies a collection of parameters for the extension in the Extension element. Only one Parameters element can be used in the Extension element.

Parent element

Render - Specifies a collection of extensions, for witch the configuration is applied. Multiple Extension elements can be applied in the Render element.

<Parameters> element

Parameters XML element specifies a collection of parameters for the extension defined in the parent Extension element.

Attributes

No attributes are defined for this element

Child elements

Parameter – Specifies a parameter for the extension in the Extension element. Multiple Parameter elements can be used in the Parameters element.

Parent element

Extension - Specifies an extension, for witch the configuration is applied. Only one Parameters element can be applied in the Extension element. The default value is true. You can use it to hide the export format from the list of the available render extensions.

<Parameter> element

Parameter XML element specifies a parameter for the extension defined in the ancestor Extension element. The parameter is supplied as name/value pairs.

Attributes

  • name – the name of the parameter that is supplied. Required attribute.
  • value – the value of the parameter with the name specified. As the value can be only a string, the parameter Type must have an associatedTypeConverter that handles conversions from string. Built-in .NET value types and enums have type converters defined.

Child elements

No child elements are defined for this element.

Parent element

Parameters - Specifies a collection of parameters for the extension defined in the parent Extension element. Multiple Parameter elements can be used in the Parameters element.

An Example of a valid Telerik.Reporting Section Copy Code
<configuration>
…
<Telerik.Reporting>
<Extensions>
<Render>
<Extension name="IMAGE" description=”image”>
<Parameters>
<Parameter name="OutputFormat" value="JPEG"/>
</Parameters>
</Extension>
</Render>
</Extensions>
</Telerik.Reporting>
…
</configuration>

Configuring Multiple Entries for a Rendering Extension

You can specify multiple instances of a single rendering extension to vary rendering behavior. If you configure multiple instances, make sure that each extension name is unique. Then you can use the rendering extension programmatically by using the extension name to identify which particular instance to use for a particular rendering operation.

You should also specify the description attribute of the Extension element. The string you specify for description will be visible to users in the list of export options for the report. If you are configuring multiple versions of the same extension, be sure to provide a value for the description. Otherwise, all versions of the extension will have the same export option name.

The following example illustrates how to use the default Image rendering extension (which produces TIFF output) alongside a second instance that outputs reports in EMF. Notice that the extension name distinguishes one instance from the other:

Example Copy Code
<Telerik.Reporting>
<Extensions>
<Render>
<Extension name="TIFF_CCITT4"
type="Telerik.Reporting.ImageRendering.ImageReport, Telerik.Reporting.Processing, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be"
description="TIFF file (CCITT Group 4)">
<Parameters>
<Parameter name="TiffCompression" value="ccitt4" />
</Parameters>
</Extension>
</Render>
</Extensions>
</Telerik.Reporting>

See Also

Device Information Settings


Device Information Settings

Telerik Reporting Q3 2008 Send comments on this topic.
Device Information Settings
Configuring Telerik Reporting > Device Information Settings

Glossary Item Box

In Telerik Reporting, device information settings are used to pass rendering parameters to a rendering extension.

You can specify device information settings in a variety of ways. Programmatically, you can use the the Telerik.Reporting.Processing.ReportProcessor.Render method. You can also use the <Telerik.Reporting> configuration section to specify rendering parameters globally. For more information about specifying rendering parameters globally, see Configuring Telerik Reporting.

Image Device Information Settings

Name | Type | Description
OutputFormat | String | Defines the output format of the produced image. Supported formats are: BMP, EMF, EMFPLUS, GIF, JPEG, PNG, or TIFF. The default value is TIFF
StartPage | Integer | The first page of the report to render. A value of 0 indicates that all pages are rendered.
EndPage | Integer | The last page of the report to render.
DpiX | Integer | The resolution of the output image in x-direction. The default value is 96.
DpiY | Integer | The resolution of the output image in y-direction. The default value is 96.
TiffCompression | String | Specifies the compression scheme of the output TIFF file. Supported compression kinds are: LZW, CCITT3, CCITT4, RLE, or NONE. The default value is LZW.

PDF Device Information Settings

Name

Type

Description

FontEmbedding

String

Specifies if the fonts used in the report should be embedded in the output PDF document. Valid values are: Full, Subset, None. Specifying the Subset option will embed only font glyphs that are used, thus reducing output file size while maintaining portability. Default value: Full.

JavaScript

String

A JavaScript to be compiled and executed by the JavaScript interpreter. Netscape Communications Corporation’s Client-Side JavaScript Reference and the Adobe JavaScript for Acrobat API Reference give details on the contents and effects of JavaScript scripts.

DocumentTitle

String

The document’s title.

DocumentAuthor

String

The name of the person who created the document.

DocumentSubject

String

The subject of the document.

DocumentKeywords

String

Keywords associated with the document.

ViewerHideToolbar

Boolean

A flag specifying whether to hide the viewer application’s tool bars when the document is active. Default value: false.

ViewerHideMenubar

Boolean

A flag specifying whether to hide the viewer application’s menu bar when the document is active. Default value: false.

ViewerHideWindowUI

Boolean

A flag specifying whether to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.

ViewerFitWindow

Boolean

A flag specifying whether to resize the document’s window to fit the size of the first displayed page. Default value: false.

ViewerCenterWindow

Boolean

A flag specifying whether to position the document’s window in the center of the screen. Default value: false.

ViewerDisplayDocTitle

Boolean

A flag specifying whether the window’s title bar should display the document title taken from the DocumentTitle parameter. If false, the title bar should instead display the name of the PDF file containing the document. Default value: false.

ViewerDirection

String

The predominant reading order for text:

  • L2R: Left to right
  • R2L: Right to left (including vertical writing systems, such as Chinese, Japanese, and Korean)

This entry has no direct effect on the document’s contents or page numbering but can be used to determine the relative positioning of pages when displayed side by side or printed n-up. Default value: L2R.

ViewerPrintScaling

String

The page scaling option to be selected when a print dialog is displayed for this document. Valid values are None, which indicates that the print dialog should reflect no page scaling, and AppDefault, which indicates that applications should use the current print scaling. Default value: AppDefault.

HTML/MHTML Device Information Settings

No parameters can be specified for the HTML/MHTML rendering extension.

Excel Device Information Settings

No parameters can be specified for the HTML/MHTML rendering extension.

CSV Device Information Settings

Name | Type | Description
NoHeader | Boolean | Indicates whether the header row is excluded from the output. The default value is false.
NoStaticText | Boolean | Indicates whether static text is excluded from the output. From Telerik Reporting point of view a TextBox item which value is a string that does not start with = is considered static; otherwise it is evaluated as an expression. The default value is false.


Solution Structure

Telerik Reporting Q3 2008 Send comments on this topic.
Solution Structure
Best Practices > Solution Structure

Glossary Item Box

The most efficient way to structure your reporting solution is to first create a class library that contains your reports and then reference that class library in applications that view the reports. You can have any number of Windows or Web viewing applications that get re-use out of the same class library. This solution structure decouples your program logic from the report and its data.

In the example solution below "MyReportSolution" there are three projects.

  • "MyReportLib" is the class library that contains Telerik Reporting items. In this case the project contains only a single item "Report1.cs".
  • "MyWebApplication" is an ASP.NET application that displays the report. Notice the "MyReportLib" entry in the References for the project.
  • "MyWindowsApplication" is a Windows forms application that also references "MyReportLib".


Add data adapter and connection objects

Telerik Reporting Q3 2008 Send comments on this topic.
Add data adapter and connection objects
Frequently Asked Questions > Add data adapter and connection objects

Glossary Item Box

Data components (adapters, connections, etc.) are added to a report in the same manner they are added to a Windows Form or a Web Form. For example, to add a SQLDataAdapter and bind it to a report at design time:

  1. From the Toolbox, drag a SQLDataAdapter object onto your report. If you do not have a SQLDataAdapter in the Toolbox you can add it:
    1. Right-click the Toolbox and select "Choose Items" from the context menu.
    2. Select the .NET Framework Components tab.
    3. Find the SQLDataAdapter component in the list and select the check box.
      You can also use the "Filter:" text entry located below the list of components to speed your search. Enter a few letters of "SQLDataAdapter" to see only entries beginning with those characters.
  3. When you drop the adapter on your report, the Data Adapter Configuration Wizard will display. Follow the prompts to configure the Data Adapter. See the MSDN article Data Adapter Configuration Wizard for more information on these steps.
  4. Set the report DataSource property to the name of the SQLDataAdapter.

Alternatively, you can bind the report datasource in code. The report can be bound to a data adapter or a DataSet.

  1. Add a reference to the System.Data and System.Data.SqlClient namespaces
  2. Add the following code in the report's constructor:
[C#]  Binding a report datasource Copy Code
SqlConnection conn = new SqlConnection(
@"Server=(local)\SQLEXPRESS;Integrated Security=true;Database=AdventureWorksT");
string selectCommand = "SELECT * FROM Production.Product";
SqlDataAdapter adapter = new SqlDataAdapter(selectCommand, conn);
DataSet dataSet = new DataSet();
adapter.Fill(dataSet);
this.DataSource = dataSet;
this.DataMember = "Table";
[VB] Binding a report datasource Copy Code
Dim conn As New SqlConnection("Server=(local)\SQLEXPRESS;Integrated Security=true;Database=AdventureWorksT")
Dim selectCommand As String = "SELECT * FROM Production.Product"
Dim adapter As New SqlDataAdapter(selectCommand, conn)
Dim dataSet As New DataSet()
adapter.Fill(dataSet)
Me.DataSource = dataSet
Me.DataMember = "Table"

Or you can bind the report to the data adapter directly:

this.DataSource = adapter;

Be aware that if your data-binding occurs in the report constructor, the preview of the bound report in design-time will be unavailable.

If you want to bind a report item (a TextBox, for example) to a column from the data source:

  1. Drag the TextBox from the Telerik Reporting group in the ToolBox to the report design surface.
  2. Set the TextBox Value property to be "=" plus the name of the column in the datasource. For example if the datasource has a column named "FirstName" the Value property should be "=FirstName".

More information on data binding can be found here.


How do I display a PDF directly in the browser without exporting first?

Telerik Reporting Q3 2008 Send comments on this topic.
How do I display a PDF directly in the browser without exporting first?
Frequently Asked Questions > How do I display a PDF directly in the browser without exporting first?

Glossary Item Box

To create a PDF and open it directly within a webform, use the ReportProcessor object to create a stream of bytes and write those bytes to the ASP.NET Response object.

  1. In your web application, verify you have the following assemblies referenced and add them if you do not:
    1. Telerik.Reporting
    2. Telerik.Reporting.Processing
  2. Add the ExportToPDF() method (see code example below) to your application.
  3. Call the ExportToPDF() method. For example you might call this within a button click event handler for a "Run" button:
[C#] ExplortToPDF() Copy Code
void ExportToPDF(string reportName, Telerik.Reporting.Report reportToExport)
{
string mimeType = string.Empty;
string ext = string.Empty;
Encoding encoding = Encoding.Default;
byte[] reportBytes =
ReportProcessor.Render("PDF", reportToExport, null,
out mimeType, out ext, out encoding);
string fileName = reportName + ".pdf";
Response.Clear();
Response.ContentType = mimeType;
Response.Cache.SetCacheability(HttpCacheability.Private);
Response.Expires = -1;
Response.Buffer = false;
Response.AddHeader("Content-Disposition",
string.Format("{0};FileName=\"{1}\"", "attachment", fileName));
Response.OutputStream.Write(reportBytes, 0, reportBytes.Length);
Response.End();
}
. . .
// Sample call to ExportToPDF()
ExportToPDF("Employees List", new Report1());
[VB] ExportToPDF() Copy Code
Sub ExportToPDF(ByVal reportName As String, ByVal reportToExport As Telerik.Reporting.Report)
Dim mimeType As String = String.Empty
Dim ext As String = String.Empty
Dim encoding As Encoding = Encoding.[Default]
Dim reportBytes As Byte() = ReportProcessor.Render("PDF", reportToExport, Nothing, mimeType, ext, encoding)
Dim fileName As String = reportName + ".pdf"
Response.Clear()
Response.ContentType = mimeType
Response.Cache.SetCacheability(HttpCacheability.[Private])
Response.Expires = -1
Response.Buffer = False
Response.AddHeader("Content-Disposition", String.Format("{0};FileName=""{1}""", "attachment", fileName))
Response.OutputStream.Write(reportBytes, 0, reportBytes.Length)
Response.[End]()
End Sub

. . .
' Sample call to ExportToPDF()
ExportToPDF("Employees List", New Report1())


How do I display groups with different datasources and details sections?

Telerik Reporting Q3 2008 Send comments on this topic.
How do I display groups with different datasources and details sections?
Frequently Asked Questions > How do I display groups with different datasources and details sections?

Glossary Item Box

Usually grouping is used to group the data together by criteria. Instead, use SubReports to allow different sets of data within a single report. Using the SubReport ToolBox item you can embed several different reports in one report. Each report can use a different data source and you can arrange your “master” report to look exactly the same way as a report with groups. To use SubReport components:

  1. Create a "master" report that will act as a container for the other reports.
  2. Create reports that will be contained within the master report. Each report can have a different datasource and layout defined.
  3. Add SubReport items from the ToolBox to the "master" report detail section for each Report item created in step 2.
  4. Select the Report property from the drop down list for each SubReport.
  5. Rebuild the project.


How do I 'shrink' TextBoxes that have no data?

Telerik Reporting Q3 2008 Send comments on this topic.
How do I 'shrink' TextBoxes that have no data?
Frequently Asked Questions > How do I 'shrink' TextBoxes that have no data?

Glossary Item Box

Question: "I have three textboxes (a textbox on each "row" below each other) and have been testing the CanShrink property. Let's say the first textbox is empty but the other two are not, is it possible that the other two textboxes 'move up', the second textbox takes the first textbox place etc?"

Answer: Yes. The following shows how CanShrink and CanGrow properties change the display of a report. The example report ShrinkGrowReport.cs that ships with Telerik Reports is used as a starting point.

The figure below detail section shows TextBox items for Name and Summary fields. For the purposes of this topic the example is changed so that the detail section is surrounded by a dotted line. The Name and Summary TextBox items are surrounded by a solid line. This topic will show the report display when setting and unsetting the CanShrink and CanGrow properties.

CanShrink and CanGrow properties for both Name and Summary are set to false. Both TextBox items stay at the same dimensions as designed even though the Name TextBox has less data than needed and Summary has more text than needed to fill the area.

CanShrink and CanGrow set to false

The CanShrink property for the Name TextBox is set to true and the CanGrow property for the Summary TextBox is set to true. Here you can see that the Name and Summary TextBoxes are sized to fit the data exactly.

CanGrow and CanShrink set true

In this last example the TextBoxes are arranged vertically into a single column, with the Name TextBox appearing twice. The layout is roughly:

Name

Name

Summary

The data for the first row Name field is blanked out. The output with CanShrink true for Name and CanGrow true for Summary shows the the Name property TextBox has shrunk and the Summary information takes its place:

CanShrink and CanGrow true with fields arranged vertically


Does Telerik Reporting support XML as a datasource?

Telerik Reporting Q3 2008 Send comments on this topic.
Does Telerik Reporting support XML as a datasource?
Frequently Asked Questions > Does Telerik Reporting support XML as a datasource?

Glossary Item Box

To use XML as a report datasource, load the XML into a DataTable and assign the DataTable to the report DataSource property.


Change row color based on a value in the row

Telerik Reporting Q3 2008 Send comments on this topic.
Change row color based on a value in the row
Frequently Asked Questions > Change row color based on a value in the row

Glossary Item Box

You can change row color, or any other styling characteristic, using conditional formatting.

  1. Select the detail section of your report.
  2. Select the ConditionalFormatting property of the detail section.
  3. Click the New Rule button.
  4. Enter a condition that should be true for the row to change color. In the example below the Expression is "=Fields.FinishedGoodsFlag", Operator is equal "=" and Value is "True".
  5. Click the Style button.
  6. Click the Background style item.
  7. Choose a background color from the drop down list or ellipses color selector. Change any other style characteristics you choose.
  8. Click OK to close each of the open dialogs.


Display Reports with alternating style rows

Telerik Reporting Q3 2008 Send comments on this topic.
Display Reports with alternating style rows
Frequently Asked Questions > Display Reports with alternating style rows

Glossary Item Box

Many production level reports use an alternating row style as an aid to readability. This technique is used in the ProductCatalog sample report.

This look can be achieved with conditional formatting by setting up a rule that fires on every other line.

  1. Select the detail section of your report.
  2. Select the ConditionalFormatting property of the detail section.
  3. Click the New Rule button.
  4. Enter the expression "= RowNumber()%2"
  5. Select the equal "=" operator from the drop down list.
  6. Enter the value as "=1".
  7. Click the Style button.
  8. Click the Background style item.
  9. Enter the color as "#F0F0F0".
  10. Click OK to close each of the open dialogs.


How do I modify TextBox visibility in the ItemDataBound of another TextBox?

Telerik Reporting Q3 2008 Send comments on this topic.
How do I modify TextBox visibility in the ItemDataBound of another TextBox?
Frequently Asked Questions > How do I modify TextBox visibility in the ItemDataBound of another TextBox?

Glossary Item Box

Question: How do I modify the visibility of a TextBox in the ItemDataBound event of another TextBox? I need to turn off another TextBox’s visibility, when there isn’t any data for the TextBox to whose ItemDataBound event I hooked?

In the example below we have data columns for first and last name. If the first name doesn't exist we want to set the last name TextBox Visible property to false.

  1. Add using statements for System.Data and Telerik.Reporting.Processing. Make an alias for Telerik.Reporting.Processing to avoid conflicts with Telerik.Reporting (see code example below).
  2. Create a ItemDataBound event handler for the TextBox. To do this, select the TextBox in the designer, and in the Properties Window, Events tab, find the ItemDataBound entry and double-click.
  3. The event handler passes in "sender" which is a Telerik.Reporting.Processing.ReportItemBase that represents the TextBox during processing. From this ReportItemBase object you can derive:
    1. A DataRowView that represents the underlying data for a row being processed.
    2. A Telerik.Reporting.Processing.ReportItemBase collection that represent the other items in the report designer.
  4. Use the ReportItemBase Find() method to locate an item on the report. In the code example below Find() is used to retrieve the "tbLast" TextBox to turn off visibility if there is no first name data.
In the code example below we are referring to a Processing.TextBox, not Report1.TextBox. The Processing.TextBox represents the TextBox during processing and has a different set of properties than the Report1.TextBox used when defining the report.
[C#] ItemDataBound event handle Copy Code
using System.Data;
using Processing = Telerik.Reporting.Processing;
//. . .
// Get the detail section object from sender
Processing.ReportItemBase itemBase = (sender as Processing.ReportItemBase).Parent;
Processing.DetailSection section = (itemBase as Processing.DetailSection);
// From the section object get the DataRowView
DataRowView dataRowView = (DataRowView)section.DataItem;
if ((dataRowView["Comments"] == null) || (dataRowView["Comments"].ToString().Length == 0))
{
Processing.ReportItemBase[] lastNames = (Processing.ReportItemBase[])section.Items.Find("tbLast", false);
if (lastNames.Length > 0)
{
Processing.TextBox lastName = lastNames[0] as Processing.TextBox;
lastName.Visible = false;
}
}
[VB] ItemDataBound event handler Copy Code
Imports System.Data
Imports Processing = Telerik.Reporting.Processing

'. . .
Private Sub tbFirst_ItemDataBound(ByVal sender As Object, ByVal e As System.EventArgs)
' Get the detail section object from sender
Dim itemBase As Processing.ReportItemBase = (TryCast(sender, Processing.ReportItemBase)).Parent
Dim section As Processing.DetailSection = (TryCast(itemBase, Processing.DetailSection))
' From the section object get the DataRowView
Dim dataRowView As DataRowView = DirectCast(section.DataItem, DataRowView)
If (dataRowView("FirstName") = Nothing) OrElse (dataRowView("FirstName").ToString().Length = 0) Then
Dim lastNames As Processing.ReportItemBase() = DirectCast(section.Items.Find("tbLast", False), Processing.ReportItemBase())
If lastNames.Length > 0 Then
Dim lastName As Processing.TextBox = TryCast(lastNames(0), Processing.TextBox)
lastName.Visible = False
End If
End If
End Sub


How do I combine values of two columns to a single TextBox?

Telerik Reporting Q3 2008 Send comments on this topic.
How do I combine values of two columns to a single TextBox?
Frequently Asked Questions > How do I combine values of two columns to a single TextBox?

Glossary Item Box

Here is a basic pattern for altering report items based on data or on values from other report items. In the example below we have a data for first name and last name. We want to combine those values to make a full name column:

  1. Add using statements for System.Data and Telerik.Reporting.Processing. Make an alias for Telerik.Reporting.Processing to avoid conflicts with Telerik.Reporting (see code example below).
  2. Create a ItemDataBound event handler for the Report detail section. To do this, select the detail section in the designer and in the Properties Window, Events tab, find the ItemDataBound entry and double-click.
  3. The event handler passes in "sender" which is a Telerik.Reporting.Processing.DetailSection. From this DetailSection object you can derive:
    1. A DataRowView that represents the underlying data for a row being processed.
    2. A Telerik.Reporting.Processing.ReportItemBase collection that represent the items in the report designer.
  4. Use the ReportItemBase Find() method to locate an item on the report. In the code example below we have TextBox items for a first and last name. Using Find(), locate a third TextBox to contain a combined value.
  5. Combine DataRowView values and assign to the TextBox.
In the code example below we are referring to a Processing.TextBox, not Report1.TextBox. The Processing.TextBox represents the TextBox during processing and has a different set of properties than the Report1.TextBox used when defining the report.

[C#] ItemDataBound event handler Copy Code
using System.Data;
using Processing = Telerik.Reporting.Processing;

//...
private void detail_ItemDataBound(object sender, System.EventArgs e)
{
// Get the detail section object from sender
Processing.DetailSection section = (Processing.DetailSection)sender;
// From the section object get the DataRowView
DataRowView dataRowView = (DataRowView)section.DataItem;
// Also from the section object get the items in the report
Processing.ReportItemBase[] items =
(Processing.ReportItemBase[])section.Items.Find("tbCombined", false);
/// Get the specific report item you want to change,
/// use the dataRowView to get the underlying data,
/// then change the report item properties based on the data.
if (items.Length > 0)
{
Processing.TextBox item = items[0] as Processing.TextBox;
item.Text =
dataRowView["FirstName"].ToString()
+ " " +
dataRowView["LastName"].ToString();
}
}
[VB] ItemDataBound event handler Copy Code
Imports System.Data
Imports Processing = Telerik.Reporting.Processing

'. . .

Private Sub detail_ItemDataBound(ByVal sender As Object, ByVal e As System.EventArgs)
' Get the detail section object from sender
Dim section As Processing.DetailSection = DirectCast(sender, Processing.DetailSection)
' From the section object get the DataRowView
Dim dataRowView As DataRowView = DirectCast(section.DataItem, DataRowView)
' Also from the section object get the items in the report
Dim items As Processing.ReportItemBase() = DirectCast(section.Items.Find("tbCombined", False), Processing.ReportItemBase())
''' Get the specific report item you want to change,
''' use the dataRowView to get the underlying data,
''' then change the report item properties based on the data.
If items.Length > 0 Then
Dim item As Processing.TextBox = TryCast(items(0), Processing.TextBox)
item.Text = dataRowView("FirstName").ToString() + " " + dataRowView("LastName").ToString()
End If
End Sub


Why does the page header appear before the report header?

Telerik Reporting Q3 2008 Send comments on this topic.
Why does the page header appear before the report header?
Frequently Asked Questions > Why does the page header appear before the report header?

Glossary Item Box

A report can be viewed as "document content", consisting of detail, report header and footer sections. Similar to Word, document content is centered on the screen with page header and footer sections above and below the content. Page headers and footers are not related to the report itself, but are relative to the margins of the report's media, i.e. to the paper or screen. Usually page headers and footers are placed in the margins and contain page numbers, document dates, etc.


About the Samples

Telerik Reporting Q3 2008 Send comments on this topic.
About the Samples
Samples > About the Samples

Glossary Item Box

The Telerik Reporting Demo applications provide a set of pre-built samples designed to demonstrate the breadth of capabilities of the Telerik Reporting package.

To launch the samples in Visual Studio, select from the Start menu Telerik | Reporting | Demos. Choose from the menu to see the sample report. The Telerik Reporting Quick Start browser includes a preview of each report, a description and source code in C# and VB.NET.

You can also open the sample projects (Visual Basic or C#) in Visual Studio to see the full design and source code for each of the sample reports. To open up the sample solutions go to the Start menu and select Telerik | Reporting | VS 2005 Examples.


IExtension Interface

Telerik.Reporting.Interfaces Send comments on this topic.
IExtension Interface
See Also Members
[image]
Telerik.Reporting Namespace : IExtension Interface

Telerik Reporting extension
Namespace: Telerik.Reporting
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Interface IExtension
Visual Basic (Usage) Copy Code
Dim instance As IExtension
C#
public interface IExtension

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IExtension Members
Telerik.Reporting Namespace


IExtension Interface Members

Telerik.Reporting.Interfaces Send comments on this topic.
IExtension Interface Members
See Also Methods
[image]
Telerik.Reporting Namespace : IExtension Interface

The following tables list the members exposed by IExtension.

Public Methods

 | Name | Description
Method | Initialize | Initializes the current extension with default settings
Top

See Also

Reference

IExtension Interface
Telerik.Reporting Namespace


IExtension Interface Methods

Telerik.Reporting.Interfaces Send comments on this topic.
IExtension Interface Methods
See Also
[image]
Telerik.Reporting Namespace : IExtension Interface

For a list of all members of this type, see IExtension members.

Public Methods

 | Name | Description
Method | Initialize | Initializes the current extension with default settings
Top

See Also

Reference

IExtension Interface
Telerik.Reporting Namespace


Initialize Method

Telerik.Reporting.Interfaces Send comments on this topic.
Initialize Method
See Also
[image]
Telerik.Reporting Namespace > IExtension Interface : Initialize Method

deviceInfo
Initializes the current extension with default settings

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Sub Initialize( _
   ByVal deviceInfo As Hashtable _
)
Visual Basic (Usage) Copy Code
Dim instance As IExtension
Dim deviceInfo As Hashtable

instance.Initialize(deviceInfo)
C#
void Initialize(
   Hashtable deviceInfo
)

Parameters

deviceInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IExtension Interface
IExtension Members


Barcode Class

Telerik.Reporting Send comments on this topic.
Barcode Class
See Also Members
[image]
Telerik.Reporting Namespace : Barcode Class

Represents a barcode report item.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Barcode
   Inherits ReportItem
   Implements IArrangedItem, ILayoutItem, ISupportsRotation
Visual Basic (Usage) Copy Code
Dim instance As Barcode
C#
public class Barcode : ReportItem, IArrangedItem, ILayoutItem, ISupportsRotation

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportItem
Telerik.Reporting.Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Members
Telerik.Reporting Namespace


Barcode Class Members

Barcode Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : Barcode Class

The following tables list the members exposed by Barcode.

Public Constructors

 | Name | Description
Public Constructor | Barcode Constructor |
Top

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Angle | Gets or sets a value indicating the angle of rotation of the bar code inside the report item, specified in degrees.
Public Property | BarAlign | Gets or sets the horizontal alignment of the barcode in the report item.
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | Checksum | Gets or sets a value indicating whether the barcode should contain a checksum for validation purposes during the scanning process or not.
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Module | Gets or sets a Unit representing the width of of the narrowest bar of the barcode.
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | ShowText | Gets or sets a value indicating whether the barcode should display a human-readable text representation of the encoded value.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Stretch | Gets or sets a value indicating whether to stretch the barcode to fill the entire area of the report item item or not.
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Symbology | Gets or sets a value indicating the current symbology used to encode the Value property as series of bars and spaces.
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Value | Gets or sets the current value to be encoded in the barcode.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Gets the default size of the report item. (Inherited from ReportItem)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

Barcode Class
Telerik.Reporting Namespace


Barcode Constructor

Barcode Constructor
See Also
[image]
Telerik.Reporting Namespace > Barcode Class : Barcode Constructor

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Barcode()
C#
public Barcode()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Barcode()
C#
public Barcode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Barcode Class Properties

Barcode Class Properties
[image]
Telerik.Reporting Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Angle | Gets or sets a value indicating the angle of rotation of the bar code inside the report item, specified in degrees.
Public Property | BarAlign | Gets or sets the horizontal alignment of the barcode in the report item.
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | Checksum | Gets or sets a value indicating whether the barcode should contain a checksum for validation purposes during the scanning process or not.
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Module | Gets or sets a Unit representing the width of of the narrowest bar of the barcode.
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | ShowText | Gets or sets a value indicating whether the barcode should display a human-readable text representation of the encoded value.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Stretch | Gets or sets a value indicating whether to stretch the barcode to fill the entire area of the report item item or not.
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Symbology | Gets or sets a value indicating the current symbology used to encode the Value property as series of bars and spaces.
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Value | Gets or sets the current value to be encoded in the barcode.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Gets the default size of the report item. (Inherited from ReportItem)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Barcode Class
Telerik.Reporting Namespace


Angle Property

Angle Property
[image]
Telerik.Reporting Namespace > Barcode Class : Angle Property

Gets or sets a value indicating the angle of rotation of the bar code inside the report item, specified in degrees.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Angle As Double
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Double

instance.Angle = value

value = instance.Angle
C#
public double Angle {get; set;}

Return Value

A double value indicating the angle of rotation in degrees.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


BarAlign Property

BarAlign Property
[image]
Telerik.Reporting Namespace > Barcode Class : BarAlign Property

Gets or sets the horizontal alignment of the barcode in the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property BarAlign As HorizontalAlign
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As HorizontalAlign

instance.BarAlign = value

value = instance.BarAlign
C#
public HorizontalAlign BarAlign {get; set;}

Return Value

One of the HorizontalAlign values. The default value is HorizontalAlign.Center.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Checksum Property

Checksum Property
[image]
Telerik.Reporting Namespace > Barcode Class : Checksum Property

Gets or sets a value indicating whether the barcode should contain a checksum for validation purposes during the scanning process or not.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Checksum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Boolean

instance.Checksum = value

value = instance.Checksum
C#
public bool Checksum {get; set;}

Return Value

true if the barcode should contain a checksum for validation purposes during the scanning process, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Module Property

Module Property
[image]
Telerik.Reporting Namespace > Barcode Class : Module Property

Gets or sets a Unit representing the width of of the narrowest bar of the barcode.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Module As Unit
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Unit

instance.Module = value

value = instance.Module
C#
public Unit Module {get; set;}

Return Value

A Unit value representing the width of the narrowest bar of the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


ShowText Property

ShowText Property
[image]
Telerik.Reporting Namespace > Barcode Class : ShowText Property

Gets or sets a value indicating whether the barcode should display a human-readable text representation of the encoded value.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowText As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Boolean

instance.ShowText = value

value = instance.ShowText
C#
public bool ShowText {get; set;}

Return Value

true if the barcode should display text, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Stretch Property

Stretch Property
[image]
Telerik.Reporting Namespace > Barcode Class : Stretch Property

Gets or sets a value indicating whether to stretch the barcode to fill the entire area of the report item item or not.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Stretch As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Boolean

instance.Stretch = value

value = instance.Stretch
C#
public bool Stretch {get; set;}

Return Value

true if the barcode should be stretched, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Symbology Property

Symbology Property
[image]
Telerik.Reporting Namespace > Barcode Class : Symbology Property

Gets or sets a value indicating the current symbology used to encode the Value property as series of bars and spaces.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Symbology As Barcode.SymbologyType
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Barcode.SymbologyType

instance.Symbology = value

value = instance.Symbology
C#
public Barcode.SymbologyType Symbology {get; set;}

Return Value

A Barcode.SymbologyType enumerated value indicating the symbology associated with the current barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Value Property

Value Property
[image]
Telerik.Reporting Namespace > Barcode Class : Value Property

Gets or sets the current value to be encoded in the barcode.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}

Return Value

A String that starts with the symbol "=" is interpreted as an expression to calculate the value of the current barcode, otherwise the value is interpreted as a literal string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Chart Class

Chart Class
See Also Members
[image]
Telerik.Reporting Namespace : Chart Class

Defines the base class for all report items that can be placed in a ReportSectionBase. Items of this type have a location and a size.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Chart
   Inherits ReportItem
   Implements IChartComponent, IArrangedItem, ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As Chart
C#
public class Chart : ReportItem, IChartComponent, IArrangedItem, ILayoutItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportItem
Telerik.Reporting.Chart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Members
Telerik.Reporting Namespace


Chart Class Members

Chart Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : Chart Class

The following tables list the members exposed by Chart.

Public Constructors

 | Name | Description
Public Constructor | Chart Constructor |
Top

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Appearance | Link to visualization and design properties
Public Property | AutoLayout | Specifies AutoLayout mode to all items on the chart control.
Public Property | AutoTextWrap | Specifies AutoTextWrap mode for all wrappable text blocks of the chart control.
Public Property | BitmapResolution |
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | ChartTitle | Collection of titles for chart
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CustomPalettes |
Public Property | DataGroupColumn | Define a data source column name for grouping data
Public Property | DefaultType | Default chart type
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | ImageFormat |
Public Property | IntelligentLabelsEnabled | Toggles the use of the IntelligentLabels feature.
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Legend | Chart legend
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PlotArea | Chart plot areaa
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Series | Gets or sets the RadChart's chart series collection object.
Public Property | SeriesOrientation |
Public Property | SeriesPalette | Specifies the series palette
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Overridden.
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | RaiseNeedDataSource | Raises the Report.NeedDataSource event.
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | NeedDataSource | Occurs at the start of report processing if the chart has no data source set.
Top

See Also

Reference

Chart Class
Telerik.Reporting Namespace


Chart Constructor

Chart Constructor
[image]
Telerik.Reporting Namespace > Chart Class : Chart Constructor

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Chart()
C#
public Chart()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Chart()
C#
public Chart()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Chart Class Methods

Chart Class Methods
[image]
Telerik.Reporting Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | RaiseNeedDataSource | Raises the Report.NeedDataSource event.
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

Chart Class
Telerik.Reporting Namespace


RaiseNeedDataSource Method

RaiseNeedDataSource Method
[image]
Telerik.Reporting Namespace > Chart Class : RaiseNeedDataSource Method

sender
The subreport being processed.
e
An EventArgs that contains event data.
Raises the Report.NeedDataSource event.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaiseNeedDataSource( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim sender As Object
Dim e As EventArgs

instance.RaiseNeedDataSource(sender, e)
C#
public virtual void RaiseNeedDataSource(
   object sender,
   EventArgs e
)

Parameters

sender
The subreport being processed.
e
An EventArgs that contains event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Chart Class Properties

Chart Class Properties
[image]
Telerik.Reporting Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Appearance | Link to visualization and design properties
Public Property | AutoLayout | Specifies AutoLayout mode to all items on the chart control.
Public Property | AutoTextWrap | Specifies AutoTextWrap mode for all wrappable text blocks of the chart control.
Public Property | BitmapResolution |
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | ChartTitle | Collection of titles for chart
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CustomPalettes |
Public Property | DataGroupColumn | Define a data source column name for grouping data
Public Property | DefaultType | Default chart type
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | ImageFormat |
Public Property | IntelligentLabelsEnabled | Toggles the use of the IntelligentLabels feature.
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Legend | Chart legend
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PlotArea | Chart plot areaa
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Series | Gets or sets the RadChart's chart series collection object.
Public Property | SeriesOrientation |
Public Property | SeriesPalette | Specifies the series palette
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Overridden.
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Chart Class
Telerik.Reporting Namespace


Appearance Property

Appearance Property
[image]
Telerik.Reporting Namespace > Chart Class : Appearance Property

Link to visualization and design properties

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleChart
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As StyleChart

value = instance.Appearance
C#
public StyleChart Appearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


AutoLayout Property

AutoLayout Property
[image]
Telerik.Reporting Namespace > Chart Class : AutoLayout Property

Specifies AutoLayout mode to all items on the chart control.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoLayout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Boolean

instance.AutoLayout = value

value = instance.AutoLayout
C#
public bool AutoLayout {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


AutoTextWrap Property

AutoTextWrap Property
[image]
Telerik.Reporting Namespace > Chart Class : AutoTextWrap Property

Specifies AutoTextWrap mode for all wrappable text blocks of the chart control.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoTextWrap As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Boolean

instance.AutoTextWrap = value

value = instance.AutoTextWrap
C#
public bool AutoTextWrap {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


BitmapResolution Property

BitmapResolution Property
[image]
Telerik.Reporting Namespace > Chart Class : BitmapResolution Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property BitmapResolution As Single
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Single

instance.BitmapResolution = value

value = instance.BitmapResolution
C#
public float BitmapResolution {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ChartTitle Property

ChartTitle Property
[image]
Telerik.Reporting Namespace > Chart Class : ChartTitle Property

Collection of titles for chart

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChartTitle As ChartTitle
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ChartTitle

value = instance.ChartTitle
C#
public ChartTitle ChartTitle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


CustomPalettes Property

CustomPalettes Property
[image]
Telerik.Reporting Namespace > Chart Class : CustomPalettes Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomPalettes As CustomPalettesCollection
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As CustomPalettesCollection

value = instance.CustomPalettes
C#
public CustomPalettesCollection CustomPalettes {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


DataGroupColumn Property

DataGroupColumn Property
[image]
Telerik.Reporting Namespace > Chart Class : DataGroupColumn Property

Define a data source column name for grouping data

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataGroupColumn As String
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As String

instance.DataGroupColumn = value

value = instance.DataGroupColumn
C#
public string DataGroupColumn {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


DefaultSize Property

DefaultSize Property
[image]
Telerik.Reporting Namespace > Chart Class : DefaultSize Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property DefaultSize As SizeU
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As SizeU

value = instance.DefaultSize
C#
protected override SizeU DefaultSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


DefaultType Property

DefaultType Property
[image]
Telerik.Reporting Namespace > Chart Class : DefaultType Property

Default chart type

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultType As ChartSeriesType
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ChartSeriesType

instance.DefaultType = value

value = instance.DefaultType
C#
public ChartSeriesType DefaultType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ImageFormat Property

ImageFormat Property
[image]
Telerik.Reporting Namespace > Chart Class : ImageFormat Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageFormat As ImageFormat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ImageFormat

instance.ImageFormat = value

value = instance.ImageFormat
C#
public ImageFormat ImageFormat {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


IntelligentLabelsEnabled Property

IntelligentLabelsEnabled Property
[image]
Telerik.Reporting Namespace > Chart Class : IntelligentLabelsEnabled Property

Toggles the use of the IntelligentLabels feature.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property IntelligentLabelsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Boolean

instance.IntelligentLabelsEnabled = value

value = instance.IntelligentLabelsEnabled
C#
public bool IntelligentLabelsEnabled {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Legend Property

Legend Property
[image]
Telerik.Reporting Namespace > Chart Class : Legend Property

Chart legend

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Legend As ChartLegend
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ChartLegend

value = instance.Legend
C#
public ChartLegend Legend {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


PlotArea Property

PlotArea Property
[image]
Telerik.Reporting Namespace > Chart Class : PlotArea Property

Chart plot areaa

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PlotArea As ChartPlotArea
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ChartPlotArea

value = instance.PlotArea
C#
public ChartPlotArea PlotArea {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Series Property

Series Property
[image]
Telerik.Reporting Namespace > Chart Class : Series Property

Gets or sets the RadChart's chart series collection object.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Series As ChartSeriesCollection
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ChartSeriesCollection

value = instance.Series
C#
public ChartSeriesCollection Series {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


SeriesOrientation Property

SeriesOrientation Property
[image]
Telerik.Reporting Namespace > Chart Class : SeriesOrientation Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property SeriesOrientation As ChartSeriesOrientation
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ChartSeriesOrientation

instance.SeriesOrientation = value

value = instance.SeriesOrientation
C#
public ChartSeriesOrientation SeriesOrientation {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


SeriesPalette Property

SeriesPalette Property
[image]
Telerik.Reporting Namespace > Chart Class : SeriesPalette Property

Specifies the series palette

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property SeriesPalette As String
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As String

instance.SeriesPalette = value

value = instance.SeriesPalette
C#
public string SeriesPalette {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Chart Class Events

Chart Class Events
[image]
Telerik.Reporting Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | NeedDataSource | Occurs at the start of report processing if the chart has no data source set.
Top

See Also

Reference

Chart Class
Telerik.Reporting Namespace


NeedDataSource Event

NeedDataSource Event
[image]
Telerik.Reporting Namespace > Chart Class : NeedDataSource Event

Occurs at the start of report processing if the chart has no data source set.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event NeedDataSource() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim handler As EventHandler

AddHandler instance.NeedDataSource, handler
C#
public event EventHandler NeedDataSource()

Syntax

Visual Basic (Declaration)
Public Event NeedDataSource() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim handler As EventHandler

AddHandler instance.NeedDataSource, handler
C#
public event EventHandler NeedDataSource()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


CheckBox Class

CheckBox Class
See Also Members
[image]
Telerik.Reporting Namespace : CheckBox Class

Represents a check box report item.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class CheckBox
   Inherits TextItemBase
   Implements IArrangedItem, ILayoutItem, ISupportsRotation
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
C#
public class CheckBox : TextItemBase, IArrangedItem, ILayoutItem, ISupportsRotation

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportItem
Telerik.Reporting.TextItemBase
Telerik.Reporting.CheckBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Members
Telerik.Reporting Namespace


CheckBox Class Members

CheckBox Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : CheckBox Class

The following tables list the members exposed by CheckBox.

Public Constructors

 | Name | Description
Public Constructor | CheckBox Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Angle | Gets or sets the angle of rotation of the text in degrees. (Inherited from TextItemBase)
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically. (Inherited from TextItemBase)
Public Property | CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically. (Inherited from TextItemBase)
Public Property | CheckAlign | Gets or sets the alignment of the check mark on a CheckBox.
Public Property | CheckedImage | Gets or sets the image corresponding to an Selected CheckBox
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Culture | Gets or sets the culture information associated with the Text Item. (Inherited from TextItemBase)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | FalseValue | Gets or sets the value template corresponding to an Unchecked CheckBox
Public Property | Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | IndeterminateImage | Gets or sets the image corresponding to an Indeterminate CheckBox
Public Property | IndeterminateValue | Gets or sets the value template corresponding to an Indeterminate CheckBox
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Multiline | Gets or sets a value indicating whether this is a multiline Text Item. (Inherited from TextItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Text | Gets or sets the current text (aka label) in the check box.
Public Property | TextWrap | Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary. (Inherited from TextItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | TrueValue | Gets or sets the value template corresponding to an Selected CheckBox
Public Property | UncheckedImage | Gets or sets the image corresponding to an Unchecked CheckBox
Public Property | Value | Gets or sets the value of the check box.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Gets the default size of the report item. (Inherited from ReportItem)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

CheckBox Class
Telerik.Reporting Namespace


CheckBox Constructor

CheckBox Constructor
[image]
Telerik.Reporting Namespace > CheckBox Class : CheckBox Constructor

Overload List

Overload | Description
CheckBox Constructor() |
CheckBox Constructor(SerializationInfo,StreamingContext) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Constructor()

CheckBox Constructor()
See Also
[image]
Telerik.Reporting Namespace > CheckBox Class > CheckBox Constructor : CheckBox Constructor()

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CheckBox()
C#
public CheckBox()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CheckBox()
C#
public CheckBox()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members
Overload List


CheckBox Constructor(SerializationInfo,StreamingContext)

CheckBox Constructor(SerializationInfo,StreamingContext)
See Also
[image]
Telerik.Reporting Namespace > CheckBox Class > CheckBox Constructor : CheckBox Constructor(SerializationInfo,StreamingContext)

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As CheckBox(info, context)
C#
protected CheckBox(
   SerializationInfo info,
   StreamingContext context
)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As CheckBox(info, context)
C#
protected CheckBox(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members
Overload List


CheckBox Class Properties

CheckBox Class Properties
[image]
Telerik.Reporting Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Angle | Gets or sets the angle of rotation of the text in degrees. (Inherited from TextItemBase)
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically. (Inherited from TextItemBase)
Public Property | CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically. (Inherited from TextItemBase)
Public Property | CheckAlign | Gets or sets the alignment of the check mark on a CheckBox.
Public Property | CheckedImage | Gets or sets the image corresponding to an Selected CheckBox
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Culture | Gets or sets the culture information associated with the Text Item. (Inherited from TextItemBase)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | FalseValue | Gets or sets the value template corresponding to an Unchecked CheckBox
Public Property | Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | IndeterminateImage | Gets or sets the image corresponding to an Indeterminate CheckBox
Public Property | IndeterminateValue | Gets or sets the value template corresponding to an Indeterminate CheckBox
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Multiline | Gets or sets a value indicating whether this is a multiline Text Item. (Inherited from TextItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Text | Gets or sets the current text (aka label) in the check box.
Public Property | TextWrap | Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary. (Inherited from TextItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | TrueValue | Gets or sets the value template corresponding to an Selected CheckBox
Public Property | UncheckedImage | Gets or sets the image corresponding to an Unchecked CheckBox
Public Property | Value | Gets or sets the value of the check box.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Gets the default size of the report item. (Inherited from ReportItem)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

CheckBox Class
Telerik.Reporting Namespace


CheckAlign Property

CheckAlign Property
[image]
Telerik.Reporting Namespace > CheckBox Class : CheckAlign Property

Gets or sets the alignment of the check mark on a CheckBox.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property CheckAlign As ContentAlignment
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As ContentAlignment

instance.CheckAlign = value

value = instance.CheckAlign
C#
public ContentAlignment CheckAlign {get; set;}

Return Value

One of the ContentAlignment values. The default is MiddleLeft.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckedImage Property

CheckedImage Property
[image]
Telerik.Reporting Namespace > CheckBox Class : CheckedImage Property

Gets or sets the image corresponding to an Selected CheckBox

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property CheckedImage As Object
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Object

instance.CheckedImage = value

value = instance.CheckedImage
C#
public object CheckedImage {get; set;}

Return Value

A String started with "=" is interpreted as an expression,

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


FalseValue Property

FalseValue Property
[image]
Telerik.Reporting Namespace > CheckBox Class : FalseValue Property

Gets or sets the value template corresponding to an Unchecked CheckBox

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property FalseValue As Object
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Object

instance.FalseValue = value

value = instance.FalseValue
C#
public object FalseValue {get; set;}

Return Value

A String started with "=" is interpreted as an expression to calculate the real data, otherwise - literal string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


IndeterminateImage Property

IndeterminateImage Property
[image]
Telerik.Reporting Namespace > CheckBox Class : IndeterminateImage Property

Gets or sets the image corresponding to an Indeterminate CheckBox

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property IndeterminateImage As Object
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Object

instance.IndeterminateImage = value

value = instance.IndeterminateImage
C#
public object IndeterminateImage {get; set;}

Return Value

A String started with "=" is interpreted as an expression,

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


IndeterminateValue Property

IndeterminateValue Property
[image]
Telerik.Reporting Namespace > CheckBox Class : IndeterminateValue Property

Gets or sets the value template corresponding to an Indeterminate CheckBox

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property IndeterminateValue As Object
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Object

instance.IndeterminateValue = value

value = instance.IndeterminateValue
C#
public object IndeterminateValue {get; set;}

Return Value

A String started with "=" is interpreted as an expression to calculate the real data, otherwise - literal string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Text Property

Text Property
[image]
Telerik.Reporting Namespace > CheckBox Class : Text Property

Gets or sets the current text (aka label) in the check box.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Return Value

A String started with "=" is interpreted as an expression to calculate the real data, otherwise - literal string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


TrueValue Property

TrueValue Property
[image]
Telerik.Reporting Namespace > CheckBox Class : TrueValue Property

Gets or sets the value template corresponding to an Selected CheckBox

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property TrueValue As Object
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Object

instance.TrueValue = value

value = instance.TrueValue
C#
public object TrueValue {get; set;}

Return Value

A String started with "=" is interpreted as an expression to calculate the real data, otherwise - literal string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


UncheckedImage Property

UncheckedImage Property
[image]
Telerik.Reporting Namespace > CheckBox Class : UncheckedImage Property

Gets or sets the image corresponding to an Unchecked CheckBox

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property UncheckedImage As Object
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Object

instance.UncheckedImage = value

value = instance.UncheckedImage
C#
public object UncheckedImage {get; set;}

Return Value

A String started with "=" is interpreted as an expression,

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Value Property

Value Property
[image]
Telerik.Reporting Namespace > CheckBox Class : Value Property

Gets or sets the value of the check box.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Object

instance.Value = value

value = instance.Value
C#
public object Value {get; set;}

Return Value

A String started with "=" is interpreted as an expression to calculate the real data, otherwise - literal string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


DetailSection Class

DetailSection Class
See Also Members
[image]
Telerik.Reporting Namespace : DetailSection Class

Represents the main section of a Report. It is printed once for every record in the data source of the report.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class DetailSection
   Inherits ReportSection
   Implements ILayoutArranger, ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
C#
public class DetailSection : ReportSection, ILayoutArranger, ILayoutContainer

Remarks

The Detail section appears below PageHeaderSection and ReportHeaderSection sections and above PageFooterSection and ReportFooterSection sections.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportSectionBase
Telerik.Reporting.ReportSection
Telerik.Reporting.DetailSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Members
Telerik.Reporting Namespace


DetailSection Class Members

DetailSection Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : DetailSection Class

The following tables list the members exposed by DetailSection.

Public Constructors

 | Name | Description
Public Constructor | DetailSection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ColumnCount | Gets or sets a value that specifies how many columns are present in the DetailSection of the report.
Public Property | ColumnSpacing | Gets or sets a value indicating the space in Units between two adjacent columns.
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

DetailSection Class
Telerik.Reporting Namespace


DetailSection Constructor

DetailSection Constructor
[image]
Telerik.Reporting Namespace > DetailSection Class : DetailSection Constructor

Overload List

Overload | Description
DetailSection Constructor() |
DetailSection Constructor(SerializationInfo,StreamingContext) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


DetailSection Constructor()

DetailSection Constructor()
See Also
[image]
Telerik.Reporting Namespace > DetailSection Class > DetailSection Constructor : DetailSection Constructor()

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DetailSection()
C#
public DetailSection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DetailSection()
C#
public DetailSection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members
Overload List


DetailSection Constructor(SerializationInfo,StreamingContext)

DetailSection Constructor(SerializationInfo,StreamingContext)
See Also
[image]
Telerik.Reporting Namespace > DetailSection Class > DetailSection Constructor : DetailSection Constructor(SerializationInfo,StreamingContext)

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As DetailSection(info, context)
C#
protected DetailSection(
   SerializationInfo info,
   StreamingContext context
)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As DetailSection(info, context)
C#
protected DetailSection(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members
Overload List


DetailSection Class Properties

DetailSection Class Properties
[image]
Telerik.Reporting Namespace : DetailSection Class

For a list of all members of this type, see DetailSection members.

Public Properties

 | Name | Description
Public Property | ColumnCount | Gets or sets a value that specifies how many columns are present in the DetailSection of the report.
Public Property | ColumnSpacing | Gets or sets a value indicating the space in Units between two adjacent columns.
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DetailSection Class
Telerik.Reporting Namespace


ColumnCount Property

ColumnCount Property
[image]
Telerik.Reporting Namespace > DetailSection Class : ColumnCount Property

Gets or sets a value that specifies how many columns are present in the DetailSection of the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As Integer

instance.ColumnCount = value

value = instance.ColumnCount
C#
public int ColumnCount {get; set;}

Return Value

An integer value specifying the number of columns. The value should be equal to or greater than 1. The default is 1.

Remarks

Column widths are calculated based on the following rule: DetailWidth = ColumnWidth * ColumnCount + ColumSpacing * (ColumnCount - 1)

Multi-column reports are primarily used for printing labels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


ColumnSpacing Property

ColumnSpacing Property
[image]
Telerik.Reporting Namespace > DetailSection Class : ColumnSpacing Property

Gets or sets a value indicating the space in Units between two adjacent columns.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnSpacing As Unit
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As Unit

instance.ColumnSpacing = value

value = instance.ColumnSpacing
C#
public Unit ColumnSpacing {get; set;}

Return Value

A Unit value specifying the space between two adjacent columns. The value should be a non-negative Unit. The default is Unit.Zero

Remarks

This property should be used when there should be some blank space left between adjacent columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Group Class

Group Class
See Also Members
[image]
Telerik.Reporting Namespace : Group Class

Represents a class that defines a report group.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Group
   Inherits Component
   Implements IGroup
Visual Basic (Usage) Copy Code
Dim instance As Group
C#
public class Group : Component, IGroup

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.Group

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Members
Telerik.Reporting Namespace


Group Class Members

Group Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : Group Class

The following tables list the members exposed by Group.

Public Constructors

 | Name | Description
Public Constructor | Group Constructor | Overloaded. Initializes a new instance of the Group class with default settings.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Filters | Gets a FilterCollection that defines the filter expression(s) for the Group
Public Property | GroupFooter | Gets a GroupFooterSection representing the group's footer section.
Public Property | GroupHeader | Gets a GroupHeaderSection representing the group's header section.
Public Property | Grouping | Gets a GroupingCollection object that holds all Grouping objects for the group.
Public Property | GroupKeepTogether | Set to FirstDetail to ensure that the group header and the first detail record are printed on the same page of output, or All to ensure that the entire group is printed on the same page of output. If there is not enough space on the current page, then rendering will skip to the top of the next page.
Public Property | Report | Gets a Report representing the group's owner report.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Sorting | Gets a SortingCollection that defines the sort column(s), and their type and order for the Group
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Group Class
Telerik.Reporting Namespace


Group Constructor

Group Constructor
[image]
Telerik.Reporting Namespace > Group Class : Group Constructor

Initializes a new instance of the Group class with default settings.

Overload List

Overload | Description
Group Constructor() | Initializes a new instance of the Group class with default settings.
Group Constructor(Boolean) | Initializes a new instance of the Group class with the specified group header/footer creation option.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Group Constructor()

Group Constructor()
See Also
[image]
Telerik.Reporting Namespace > Group Class > Group Constructor : Group Constructor()

Initializes a new instance of the Group class with default settings.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Group()
C#
public Group()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Group()
C#
public Group()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members
Overload List


Group Constructor(Boolean)

Group Constructor(Boolean)
See Also
[image]
Telerik.Reporting Namespace > Group Class > Group Constructor : Group Constructor(Boolean)

createHeaderFooter
true to create a GroupHeaderSection and a GroupFooterSection; otherwise, false.
Initializes a new instance of the Group class with the specified group header/footer creation option.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal createHeaderFooter As Boolean _
)
Visual Basic (Usage) Copy Code
Dim createHeaderFooter As Boolean

Dim instance As Group(createHeaderFooter)
C#
public Group(
   bool createHeaderFooter
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal createHeaderFooter As Boolean _
)
Visual Basic (Usage) Copy Code
Dim createHeaderFooter As Boolean

Dim instance As Group(createHeaderFooter)
C#
public Group(
   bool createHeaderFooter
)

Parameters

createHeaderFooter
true to create a GroupHeaderSection and a GroupFooterSection; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members
Overload List


Group Class Properties

Group Class Properties
[image]
Telerik.Reporting Namespace : Group Class

For a list of all members of this type, see Group members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Filters | Gets a FilterCollection that defines the filter expression(s) for the Group
Public Property | GroupFooter | Gets a GroupFooterSection representing the group's footer section.
Public Property | GroupHeader | Gets a GroupHeaderSection representing the group's header section.
Public Property | Grouping | Gets a GroupingCollection object that holds all Grouping objects for the group.
Public Property | GroupKeepTogether | Set to FirstDetail to ensure that the group header and the first detail record are printed on the same page of output, or All to ensure that the entire group is printed on the same page of output. If there is not enough space on the current page, then rendering will skip to the top of the next page.
Public Property | Report | Gets a Report representing the group's owner report.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Sorting | Gets a SortingCollection that defines the sort column(s), and their type and order for the Group
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Group Class
Telerik.Reporting Namespace


Filters Property

Filters Property
[image]
Telerik.Reporting Namespace > Group Class : Filters Property

Gets a FilterCollection that defines the filter expression(s) for the Group

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filters As FilterCollection
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As FilterCollection

value = instance.Filters
C#
public FilterCollection Filters {get;}

Return Value

A FilterCollection that contains the Filter objects for the Group

Remarks

Filter expressions limit the data that is displayed in the Group

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


GroupFooter Property

GroupFooter Property
[image]
Telerik.Reporting Namespace > Group Class : GroupFooter Property

Gets a GroupFooterSection representing the group's footer section.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property GroupFooter As GroupFooterSection
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As GroupFooterSection

instance.GroupFooter = value

value = instance.GroupFooter
C#
public GroupFooterSection GroupFooter {get; set;}

Return Value

A GroupFooterSection value that reporesents the group footer section of the Group.

Remarks

The Group footer section is rendered after the detail sections of the Group.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


GroupHeader Property

GroupHeader Property
[image]
Telerik.Reporting Namespace > Group Class : GroupHeader Property

Gets a GroupHeaderSection representing the group's header section.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property GroupHeader As GroupHeaderSection
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As GroupHeaderSection

instance.GroupHeader = value

value = instance.GroupHeader
C#
public GroupHeaderSection GroupHeader {get; set;}

Return Value

A GroupHeaderSection value that reporesents the group header section of the Group.

Remarks

The Group header section is rendered before the detail sections of the Group. Typically, this section will contain report items that are bound to the data fields of the Group's grouping expressions.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Grouping Property

Grouping Property
[image]
Telerik.Reporting Namespace > Group Class : Grouping Property

Gets a GroupingCollection object that holds all Grouping objects for the group.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Grouping As GroupingCollection
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As GroupingCollection

value = instance.Grouping
C#
public GroupingCollection Grouping {get;}

Return Value

A GroupingCollection value containing the group expressions of the group.

Remarks

Groups are defined by adding one or more group expressions to the collection. Grouping can be done by one or more data fields. Each data field is represented by a group expression in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


GroupKeepTogether Property

GroupKeepTogether Property
[image]
Telerik.Reporting Namespace > Group Class : GroupKeepTogether Property

Set to FirstDetail to ensure that the group header and the first detail record are printed on the same page of output, or All to ensure that the entire group is printed on the same page of output. If there is not enough space on the current page, then rendering will skip to the top of the next page.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property GroupKeepTogether As GroupKeepTogether
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As GroupKeepTogether

instance.GroupKeepTogether = value

value = instance.GroupKeepTogether
C#
public GroupKeepTogether GroupKeepTogether {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Report Property

Report Property
[image]
Telerik.Reporting Namespace > Group Class : Report Property

Gets a Report representing the group's owner report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As Report

value = instance.Report
C#
public Report Report {get;}

Return Value

A Report value that reporesents the owner report of the Group.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Sorting Property

Sorting Property
[image]
Telerik.Reporting Namespace > Group Class : Sorting Property

Gets a SortingCollection that defines the sort column(s), and their type and order for the Group

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sorting As SortingCollection
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As SortingCollection

value = instance.Sorting
C#
public SortingCollection Sorting {get;}

Return Value

A SortingCollection that contains the Sorting objects for the Group

Remarks

Sort expressions sort the data that is displayed in the Group

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


GroupFooterSection Class

GroupFooterSection Class
See Also Members
[image]
Telerik.Reporting Namespace : GroupFooterSection Class

Represents a group footer section. Group footers are displayed at the end of a group. Group headers and footers are unified by the Group class.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class GroupFooterSection
   Inherits GroupSection
   Implements ILayoutArranger, ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As GroupFooterSection
C#
public class GroupFooterSection : GroupSection, ILayoutArranger, ILayoutContainer

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportSectionBase
Telerik.Reporting.ReportSection
Telerik.Reporting.GroupSection
Telerik.Reporting.GroupFooterSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupFooterSection Members
Telerik.Reporting Namespace


GroupFooterSection Class Members

GroupFooterSection Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : GroupFooterSection Class

The following tables list the members exposed by GroupFooterSection.

Public Constructors

 | Name | Description
Public Constructor | GroupFooterSection Constructor | Overloaded. Initializes a new instance of the GroupFooterSection class.
Top

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Group | Gets the Group object associated with this section. (Inherited from GroupSection)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PrintOnEveryPage | Indicates whether the section should be printed on every page that the group occupies. (Inherited from GroupSection)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

GroupFooterSection Class
Telerik.Reporting Namespace


GroupFooterSection Constructor

GroupFooterSection Constructor
[image]
Telerik.Reporting Namespace > GroupFooterSection Class : GroupFooterSection Constructor

Initializes a new instance of the GroupFooterSection class.

Overload List

Overload | Description
GroupFooterSection Constructor() | Initializes a new instance of the GroupFooterSection class.
GroupFooterSection Constructor(SerializationInfo,StreamingContext) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupFooterSection Class
GroupFooterSection Members


GroupFooterSection Constructor()

GroupFooterSection Constructor()
See Also
[image]
Telerik.Reporting Namespace > GroupFooterSection Class > GroupFooterSection Constructor : GroupFooterSection Constructor()

Initializes a new instance of the GroupFooterSection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupFooterSection()
C#
public GroupFooterSection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupFooterSection()
C#
public GroupFooterSection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupFooterSection Class
GroupFooterSection Members
Overload List


GroupFooterSection Constructor(SerializationInfo,StreamingContext)

GroupFooterSection Constructor(SerializationInfo,StreamingContext)
See Also
[image]
Telerik.Reporting Namespace > GroupFooterSection Class > GroupFooterSection Constructor : GroupFooterSection Constructor(SerializationInfo,StreamingContext)

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As GroupFooterSection(info, context)
C#
protected GroupFooterSection(
   SerializationInfo info,
   StreamingContext context
)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As GroupFooterSection(info, context)
C#
protected GroupFooterSection(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupFooterSection Class
GroupFooterSection Members
Overload List


GroupHeaderSection Class

GroupHeaderSection Class
See Also Members
[image]
Telerik.Reporting Namespace : GroupHeaderSection Class

Represents a group header section. Group headers are displayed at the beginning of a group. Group headers and footers are unified by the Group class.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class GroupHeaderSection
   Inherits GroupSection
   Implements ILayoutArranger, ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As GroupHeaderSection
C#
public class GroupHeaderSection : GroupSection, ILayoutArranger, ILayoutContainer

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportSectionBase
Telerik.Reporting.ReportSection
Telerik.Reporting.GroupSection
Telerik.Reporting.GroupHeaderSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupHeaderSection Members
Telerik.Reporting Namespace


GroupHeaderSection Class Members

GroupHeaderSection Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : GroupHeaderSection Class

The following tables list the members exposed by GroupHeaderSection.

Public Constructors

 | Name | Description
Public Constructor | GroupHeaderSection Constructor | Overloaded. Initializes a new instance of the GroupHeaderSection class.
Top

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Group | Gets the Group object associated with this section. (Inherited from GroupSection)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PrintOnEveryPage | Indicates whether the section should be printed on every page that the group occupies. (Inherited from GroupSection)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

GroupHeaderSection Class
Telerik.Reporting Namespace


GroupHeaderSection Constructor

GroupHeaderSection Constructor
[image]
Telerik.Reporting Namespace > GroupHeaderSection Class : GroupHeaderSection Constructor

Initializes a new instance of the GroupHeaderSection class.

Overload List

Overload | Description
GroupHeaderSection Constructor() | Initializes a new instance of the GroupHeaderSection class.
GroupHeaderSection Constructor(SerializationInfo,StreamingContext) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupHeaderSection Class
GroupHeaderSection Members


GroupHeaderSection Constructor()

GroupHeaderSection Constructor()
See Also
[image]
Telerik.Reporting Namespace > GroupHeaderSection Class > GroupHeaderSection Constructor : GroupHeaderSection Constructor()

Initializes a new instance of the GroupHeaderSection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupHeaderSection()
C#
public GroupHeaderSection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupHeaderSection()
C#
public GroupHeaderSection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupHeaderSection Class
GroupHeaderSection Members
Overload List


GroupHeaderSection Constructor(SerializationInfo,StreamingContext)

GroupHeaderSection Constructor(SerializationInfo,StreamingContext)
See Also
[image]
Telerik.Reporting Namespace > GroupHeaderSection Class > GroupHeaderSection Constructor : GroupHeaderSection Constructor(SerializationInfo,StreamingContext)

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As GroupHeaderSection(info, context)
C#
protected GroupHeaderSection(
   SerializationInfo info,
   StreamingContext context
)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As GroupHeaderSection(info, context)
C#
protected GroupHeaderSection(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupHeaderSection Class
GroupHeaderSection Members
Overload List


GroupSection Class

GroupSection Class
See Also Members
[image]
Telerik.Reporting Namespace : GroupSection Class

Base abstract class for group sections. GroupHeaderSection and GroupFooterSection inherit from this class.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class GroupSection
   Inherits ReportSection
   Implements ILayoutArranger, ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
C#
public abstract class GroupSection : ReportSection, ILayoutArranger, ILayoutContainer

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportSectionBase
Telerik.Reporting.ReportSection
Telerik.Reporting.GroupSection
Telerik.Reporting.GroupFooterSection
Telerik.Reporting.GroupHeaderSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Members
Telerik.Reporting Namespace


GroupSection Class Members

GroupSection Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : GroupSection Class

The following tables list the members exposed by GroupSection.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Group | Gets the Group object associated with this section.
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PrintOnEveryPage | Indicates whether the section should be printed on every page that the group occupies.
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

GroupSection Class
Telerik.Reporting Namespace


GroupSection Class Properties

GroupSection Class Properties
[image]
Telerik.Reporting Namespace : GroupSection Class

For a list of all members of this type, see GroupSection members.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Group | Gets the Group object associated with this section.
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PrintOnEveryPage | Indicates whether the section should be printed on every page that the group occupies.
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

GroupSection Class
Telerik.Reporting Namespace


Group Property

Group Property
[image]
Telerik.Reporting Namespace > GroupSection Class : Group Property

Gets the Group object associated with this section.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Group As Group
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As Group

value = instance.Group
C#
public Group Group {get;}

Return Value

A Group object that this section belong to.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


PrintOnEveryPage Property

PrintOnEveryPage Property
[image]
Telerik.Reporting Namespace > GroupSection Class : PrintOnEveryPage Property

Indicates whether the section should be printed on every page that the group occupies.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property PrintOnEveryPage As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As Boolean

instance.PrintOnEveryPage = value

value = instance.PrintOnEveryPage
C#
public bool PrintOnEveryPage {get; set;}

Return Value

A boolean value indicating whether the section should be printed on every page that the group occupies.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


ItemEventArgs Class

ItemEventArgs Class
See Also Members
[image]
Telerik.Reporting Namespace : ItemEventArgs Class

Provides data for the ReportItemBase.ItemAdded and ReportItemBase.ItemRemoved events.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ItemEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ItemEventArgs
C#
public class ItemEventArgs : EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.Reporting.ItemEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ItemEventArgs Members
Telerik.Reporting Namespace


ItemEventArgs Class Members

ItemEventArgs Class Members
See Also Properties
[image]
Telerik.Reporting Namespace : ItemEventArgs Class

The following tables list the members exposed by ItemEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ItemEventArgs Constructor | Initializes a new instance of the ItemEventArgs class with the specified item that is added or removed.
Top

Public Properties

 | Name | Description
Public Property | Item | Gets the report item that is added/removed.
Top

See Also

Reference

ItemEventArgs Class
Telerik.Reporting Namespace


ItemEventArgs Constructor

ItemEventArgs Constructor
[image]
Telerik.Reporting Namespace > ItemEventArgs Class : ItemEventArgs Constructor

item
A ReportItemBase that is the item being added or removed.
Initializes a new instance of the ItemEventArgs class with the specified item that is added or removed.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim item As ReportItemBase

Dim instance As ItemEventArgs(item)
C#
public ItemEventArgs(
   ReportItemBase item
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim item As ReportItemBase

Dim instance As ItemEventArgs(item)
C#
public ItemEventArgs(
   ReportItemBase item
)

Parameters

item
A ReportItemBase that is the item being added or removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ItemEventArgs Class
ItemEventArgs Members


ItemEventArgs Class Properties

ItemEventArgs Class Properties
[image]
Telerik.Reporting Namespace : ItemEventArgs Class

For a list of all members of this type, see ItemEventArgs members.

Public Properties

 | Name | Description
Public Property | Item | Gets the report item that is added/removed.
Top

See Also

Reference

ItemEventArgs Class
Telerik.Reporting Namespace


Item Property

Item Property
[image]
Telerik.Reporting Namespace > ItemEventArgs Class : Item Property

Gets the report item that is added/removed.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Item As ReportItemBase
Visual Basic (Usage) Copy Code
Dim instance As ItemEventArgs
Dim value As ReportItemBase

value = instance.Item
C#
public ReportItemBase Item {get;}

Return Value

A ReportItemBase that is the item being added or removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ItemEventArgs Class
ItemEventArgs Members


ObjectValueConverter Class

ObjectValueConverter Class
See Also Members
[image]
Telerik.Reporting Namespace : ObjectValueConverter Class

Allows a property of type Object to be edited like a string property in the Properties window

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Class ObjectValueConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As ObjectValueConverter
C#
private class ObjectValueConverter : TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Reporting.ObjectValueConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ObjectValueConverter Members
Telerik.Reporting Namespace


ObjectValueConverter Class Members

ObjectValueConverter Class Members
See Also Methods
[image]
Telerik.Reporting Namespace : ObjectValueConverter Class

The following tables list the members exposed by ObjectValueConverter.

Public Constructors

 | Name | Description
Public Constructor | ObjectValueConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden.
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. Overridden.
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ObjectValueConverter Class
Telerik.Reporting Namespace


ObjectValueConverter Constructor

ObjectValueConverter Constructor
[image]
Telerik.Reporting Namespace > ObjectValueConverter Class : ObjectValueConverter Constructor

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ObjectValueConverter()
C#
public ObjectValueConverter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ObjectValueConverter()
C#
public ObjectValueConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ObjectValueConverter Class
ObjectValueConverter Members


ObjectValueConverter Class Methods

ObjectValueConverter Class Methods
[image]
Telerik.Reporting Namespace : ObjectValueConverter Class

For a list of all members of this type, see ObjectValueConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden.
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. Overridden.
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ObjectValueConverter Class
Telerik.Reporting Namespace


CanConvertFrom Method

CanConvertFrom Method
[image]
Telerik.Reporting Namespace > ObjectValueConverter Class : CanConvertFrom Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) |
CanConvertFrom(Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) |
CanConvertFrom(Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ObjectValueConverter Class
ObjectValueConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

CanConvertFrom(ITypeDescriptorContext,Type) Method
[image]
Telerik.Reporting Namespace > ObjectValueConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
sourceType

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ObjectValueConverter
Dim context As ITypeDescriptorContext
Dim sourceType As Type
Dim value As Boolean

value = instance.CanConvertFrom(context, sourceType)
C#
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)

Parameters

context
sourceType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ObjectValueConverter Class
ObjectValueConverter Members
Overload List


ConvertFrom Method

ConvertFrom Method
[image]
Telerik.Reporting Namespace > ObjectValueConverter Class : ConvertFrom Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) |
ConvertFrom(Object) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) |
ConvertFrom(Object) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ObjectValueConverter Class
ObjectValueConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also
[image]
Telerik.Reporting Namespace > ObjectValueConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ObjectValueConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim value As Object

value = instance.ConvertFrom(context, culture, value)
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
culture
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ObjectValueConverter Class
ObjectValueConverter Members
Overload List


PageEventArgs Class

PageEventArgs Class
See Also Members
[image]
Telerik.Reporting Namespace : PageEventArgs Class

Provides data for the Report.BeginRenderPage and Report.EndRenderPage events.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PageEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As PageEventArgs
C#
public class PageEventArgs : EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.Reporting.PageEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageEventArgs Members
Telerik.Reporting Namespace


PageEventArgs Class Members

PageEventArgs Class Members
See Also Properties
[image]
Telerik.Reporting Namespace : PageEventArgs Class

The following tables list the members exposed by PageEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PageEventArgs Constructor | Initializes a new instance of the PageEventArgs class with the specified page number and page count.
Top

Public Properties

 | Name | Description
Public Property | PageCount | Gets the total number of pages of the report.
Public Property | PageNumber | Gets the number of the page that the event is beign raised for.
Top

See Also

Reference

PageEventArgs Class
Telerik.Reporting Namespace


PageEventArgs Constructor

PageEventArgs Constructor
[image]
Telerik.Reporting Namespace > PageEventArgs Class : PageEventArgs Constructor

pageNumber
The number of the page.
pageCount
The total number of pages.
Initializes a new instance of the PageEventArgs class with the specified page number and page count.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pageNumber As Integer, _
   ByVal pageCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim pageNumber As Integer
Dim pageCount As Integer

Dim instance As PageEventArgs(pageNumber, pageCount)
C#
public PageEventArgs(
   int pageNumber,
   int pageCount
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pageNumber As Integer, _
   ByVal pageCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim pageNumber As Integer
Dim pageCount As Integer

Dim instance As PageEventArgs(pageNumber, pageCount)
C#
public PageEventArgs(
   int pageNumber,
   int pageCount
)

Parameters

pageNumber
The number of the page.
pageCount
The total number of pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageEventArgs Class
PageEventArgs Members


PageEventArgs Class Properties

PageEventArgs Class Properties
[image]
Telerik.Reporting Namespace : PageEventArgs Class

For a list of all members of this type, see PageEventArgs members.

Public Properties

 | Name | Description
Public Property | PageCount | Gets the total number of pages of the report.
Public Property | PageNumber | Gets the number of the page that the event is beign raised for.
Top

See Also

Reference

PageEventArgs Class
Telerik.Reporting Namespace


PageCount Property

PageCount Property
[image]
Telerik.Reporting Namespace > PageEventArgs Class : PageCount Property

Gets the total number of pages of the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As PageEventArgs
Dim value As Integer

value = instance.PageCount
C#
public int PageCount {get;}

Return Value

A int value specifying the total number of pages of the report.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageEventArgs Class
PageEventArgs Members


PageNumber Property

PageNumber Property
[image]
Telerik.Reporting Namespace > PageEventArgs Class : PageNumber Property

Gets the number of the page that the event is beign raised for.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
Visual Basic (Usage) Copy Code
Dim instance As PageEventArgs
Dim value As Integer

value = instance.PageNumber
C#
public int PageNumber {get;}

Return Value

A int value specifying the number of the page that the event is beign raised for.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageEventArgs Class
PageEventArgs Members


PageFooterSection Class

PageFooterSection Class
See Also Members
[image]
Telerik.Reporting Namespace : PageFooterSection Class

Represents a page footer section. Page footers are displayed at the end of a page.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PageFooterSection
   Inherits PageSection
   Implements ILayoutArranger, ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As PageFooterSection
C#
public class PageFooterSection : PageSection, ILayoutArranger, ILayoutContainer

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportSectionBase
Telerik.Reporting.PageSection
Telerik.Reporting.PageFooterSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageFooterSection Members
Telerik.Reporting Namespace


PageFooterSection Class Members

PageFooterSection Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : PageFooterSection Class

The following tables list the members exposed by PageFooterSection.

Public Constructors

 | Name | Description
Public Constructor | PageFooterSection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PrintOnFirstPage | Gets or sets a value indicating whether the section should print on the first page of the report. (Inherited from PageSection)
Public Property | PrintOnLastPage | Gets or sets a value indicating whether the section should print on the last page of the report. (Inherited from PageSection)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

PageFooterSection Class
Telerik.Reporting Namespace


PageFooterSection Constructor

PageFooterSection Constructor
[image]
Telerik.Reporting Namespace > PageFooterSection Class : PageFooterSection Constructor

Overload List

Overload | Description
PageFooterSection Constructor() |
PageFooterSection Constructor(SerializationInfo,StreamingContext) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageFooterSection Class
PageFooterSection Members


PageFooterSection Constructor()

PageFooterSection Constructor()
See Also
[image]
Telerik.Reporting Namespace > PageFooterSection Class > PageFooterSection Constructor : PageFooterSection Constructor()

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PageFooterSection()
C#
public PageFooterSection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PageFooterSection()
C#
public PageFooterSection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageFooterSection Class
PageFooterSection Members
Overload List


PageFooterSection Constructor(SerializationInfo,StreamingContext)

PageFooterSection Constructor(SerializationInfo,StreamingContext)
See Also
[image]
Telerik.Reporting Namespace > PageFooterSection Class > PageFooterSection Constructor : PageFooterSection Constructor(SerializationInfo,StreamingContext)

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As PageFooterSection(info, context)
C#
protected PageFooterSection(
   SerializationInfo info,
   StreamingContext context
)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As PageFooterSection(info, context)
C#
protected PageFooterSection(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageFooterSection Class
PageFooterSection Members
Overload List


PageHeaderSection Class

PageHeaderSection Class
See Also Members
[image]
Telerik.Reporting Namespace : PageHeaderSection Class

Represents a page header section. Page headers are displayed at the beginning of a page.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PageHeaderSection
   Inherits PageSection
   Implements ILayoutArranger, ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As PageHeaderSection
C#
public class PageHeaderSection : PageSection, ILayoutArranger, ILayoutContainer

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportSectionBase
Telerik.Reporting.PageSection
Telerik.Reporting.PageHeaderSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageHeaderSection Members
Telerik.Reporting Namespace


PageHeaderSection Class Members

PageHeaderSection Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : PageHeaderSection Class

The following tables list the members exposed by PageHeaderSection.

Public Constructors

 | Name | Description
Public Constructor | PageHeaderSection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PrintOnFirstPage | Gets or sets a value indicating whether the section should print on the first page of the report. (Inherited from PageSection)
Public Property | PrintOnLastPage | Gets or sets a value indicating whether the section should print on the last page of the report. (Inherited from PageSection)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

PageHeaderSection Class
Telerik.Reporting Namespace


PageHeaderSection Constructor

PageHeaderSection Constructor
[image]
Telerik.Reporting Namespace > PageHeaderSection Class : PageHeaderSection Constructor

Overload List

Overload | Description
PageHeaderSection Constructor() |
PageHeaderSection Constructor(SerializationInfo,StreamingContext) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageHeaderSection Class
PageHeaderSection Members


PageHeaderSection Constructor()

PageHeaderSection Constructor()
See Also
[image]
Telerik.Reporting Namespace > PageHeaderSection Class > PageHeaderSection Constructor : PageHeaderSection Constructor()

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PageHeaderSection()
C#
public PageHeaderSection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PageHeaderSection()
C#
public PageHeaderSection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageHeaderSection Class
PageHeaderSection Members
Overload List


PageHeaderSection Constructor(SerializationInfo,StreamingContext)

PageHeaderSection Constructor(SerializationInfo,StreamingContext)
See Also
[image]
Telerik.Reporting Namespace > PageHeaderSection Class > PageHeaderSection Constructor : PageHeaderSection Constructor(SerializationInfo,StreamingContext)

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As PageHeaderSection(info, context)
C#
protected PageHeaderSection(
   SerializationInfo info,
   StreamingContext context
)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As PageHeaderSection(info, context)
C#
protected PageHeaderSection(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageHeaderSection Class
PageHeaderSection Members
Overload List


PageSection Class

PageSection Class
See Also Members
[image]
Telerik.Reporting Namespace : PageSection Class

Base abstract class for group sections. PageHeaderSection and PageFooterSection inherit from this class.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class PageSection
   Inherits ReportSectionBase
   Implements ILayoutArranger, ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As PageSection
C#
public abstract class PageSection : ReportSectionBase, ILayoutArranger, ILayoutContainer

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportSectionBase
Telerik.Reporting.PageSection
Telerik.Reporting.PageFooterSection
Telerik.Reporting.PageHeaderSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Members
Telerik.Reporting Namespace


PageSection Class Members

PageSection Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : PageSection Class

The following tables list the members exposed by PageSection.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PrintOnFirstPage | Gets or sets a value indicating whether the section should print on the first page of the report.
Public Property | PrintOnLastPage | Gets or sets a value indicating whether the section should print on the last page of the report.
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

PageSection Class
Telerik.Reporting Namespace


PageSection Class Properties

PageSection Class Properties
[image]
Telerik.Reporting Namespace : PageSection Class

For a list of all members of this type, see PageSection members.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PrintOnFirstPage | Gets or sets a value indicating whether the section should print on the first page of the report.
Public Property | PrintOnLastPage | Gets or sets a value indicating whether the section should print on the last page of the report.
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PageSection Class
Telerik.Reporting Namespace


PrintOnFirstPage Property

PrintOnFirstPage Property
[image]
Telerik.Reporting Namespace > PageSection Class : PrintOnFirstPage Property

Gets or sets a value indicating whether the section should print on the first page of the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property PrintOnFirstPage As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As Boolean

instance.PrintOnFirstPage = value

value = instance.PrintOnFirstPage
C#
public bool PrintOnFirstPage {get; set;}

Return Value

A boolean value indicating whether the section should print on the first page of the report.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


PrintOnLastPage Property

PrintOnLastPage Property
[image]
Telerik.Reporting Namespace > PageSection Class : PrintOnLastPage Property

Gets or sets a value indicating whether the section should print on the last page of the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property PrintOnLastPage As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As Boolean

instance.PrintOnLastPage = value

value = instance.PrintOnLastPage
C#
public bool PrintOnLastPage {get; set;}

Return Value

A boolean value indicating whether the section should print on the last page of the report.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Panel Class

Panel Class
See Also Members
[image]
Telerik.Reporting Namespace : Panel Class

Provides a grouping mechanism for organizing report items.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Panel
   Inherits ReportItem
   Implements IArrangedItem, ILayoutArranger, ILayoutContainer, ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As Panel
C#
public class Panel : ReportItem, IArrangedItem, ILayoutArranger, ILayoutContainer, ILayoutItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportItem
Telerik.Reporting.Panel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Members
Telerik.Reporting Namespace


Panel Class Members

Panel Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : Panel Class

The following tables list the members exposed by Panel.

Public Constructors

 | Name | Description
Public Constructor | Panel Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Overridden.
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Overridden.
Protected Method | OnItemRemoved | Overridden.
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

Panel Class
Telerik.Reporting Namespace


Panel Constructor

Panel Constructor
[image]
Telerik.Reporting Namespace > Panel Class : Panel Constructor

Overload List

Overload | Description
Panel Constructor() |
Panel Constructor(SerializationInfo,StreamingContext) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Panel Constructor()

Panel Constructor()
See Also
[image]
Telerik.Reporting Namespace > Panel Class > Panel Constructor : Panel Constructor()

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Panel()
C#
public Panel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Panel()
C#
public Panel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members
Overload List


Panel Constructor(SerializationInfo,StreamingContext)

Panel Constructor(SerializationInfo,StreamingContext)
See Also
[image]
Telerik.Reporting Namespace > Panel Class > Panel Constructor : Panel Constructor(SerializationInfo,StreamingContext)

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As Panel(info, context)
C#
protected Panel(
   SerializationInfo info,
   StreamingContext context
)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As Panel(info, context)
C#
protected Panel(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members
Overload List


Panel Class Methods

Panel Class Methods
[image]
Telerik.Reporting Namespace : Panel Class

For a list of all members of this type, see Panel members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Overridden.
Protected Method | OnItemRemoved | Overridden.
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

Panel Class
Telerik.Reporting Namespace


OnItemAdded Method

OnItemAdded Method
[image]
Telerik.Reporting Namespace > Panel Class : OnItemAdded Method

item

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnItemAdded( _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim item As ReportItemBase

instance.OnItemAdded(item)
C#
protected override void OnItemAdded(
   ReportItemBase item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


OnItemRemoved Method

OnItemRemoved Method
[image]
Telerik.Reporting Namespace > Panel Class : OnItemRemoved Method

item

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnItemRemoved( _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim item As ReportItemBase

instance.OnItemRemoved(item)
C#
protected override void OnItemRemoved(
   ReportItemBase item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Panel Class Properties

Panel Class Properties
[image]
Telerik.Reporting Namespace : Panel Class

For a list of all members of this type, see Panel members.

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Overridden.
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Panel Class
Telerik.Reporting Namespace


DefaultSize Property

DefaultSize Property
[image]
Telerik.Reporting Namespace > Panel Class : DefaultSize Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property DefaultSize As SizeU
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As SizeU

value = instance.DefaultSize
C#
protected override SizeU DefaultSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Parameter Class

Parameter Class
See Also Members
[image]
Telerik.Reporting Namespace : Parameter Class

Represents a parameter of nested report (subreport)

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Parameter
Visual Basic (Usage) Copy Code
Dim instance As Parameter
C#
public sealed class Parameter

Inheritance Hierarchy

System.Object
Telerik.Reporting.Parameter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Parameter Members
Telerik.Reporting Namespace


Parameter Class Members

Parameter Class Members
See Also Properties Events
[image]
Telerik.Reporting Namespace : Parameter Class

The following tables list the members exposed by Parameter.

Public Constructors

 | Name | Description
Public Constructor | Parameter Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Name |
Public Property | Value |
Top

Public Events

 | Name | Description
Public Event | PropertyChanged |
Top

See Also

Reference

Parameter Class
Telerik.Reporting Namespace


Parameter Constructor

Parameter Constructor
[image]
Telerik.Reporting Namespace > Parameter Class : Parameter Constructor

Overload List

Overload | Description
Parameter Constructor() |
Parameter Constructor(String,Object) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Parameter Class
Parameter Members


Parameter Constructor()

Parameter Constructor()
See Also
[image]
Telerik.Reporting Namespace > Parameter Class > Parameter Constructor : Parameter Constructor()

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Parameter()
C#
public Parameter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Parameter()
C#
public Parameter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Parameter Class
Parameter Members
Overload List


Parameter Constructor(String,Object)

Parameter Constructor(String,Object)
See Also
[image]
Telerik.Reporting Namespace > Parameter Class > Parameter Constructor : Parameter Constructor(String,Object)

name
value

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As Object

Dim instance As Parameter(name, value)
C#
public Parameter(
   string name,
   object value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As Object

Dim instance As Parameter(name, value)
C#
public Parameter(
   string name,
   object value
)

Parameters

name
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Parameter Class
Parameter Members
Overload List


Parameter Class Properties

Parameter Class Properties
[image]
Telerik.Reporting Namespace : Parameter Class

For a list of all members of this type, see Parameter members.

Public Properties

 | Name | Description
Public Property | Name |
Public Property | Value |
Top

See Also

Reference

Parameter Class
Telerik.Reporting Namespace


Name Property

Name Property
[image]
Telerik.Reporting Namespace > Parameter Class : Name Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Parameter
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Parameter Class
Parameter Members


Value Property

Value Property
[image]
Telerik.Reporting Namespace > Parameter Class : Value Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As Parameter
Dim value As Object

instance.Value = value

value = instance.Value
C#
public object Value {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Parameter Class
Parameter Members


Parameter Class Events

Parameter Class Events
[image]
Telerik.Reporting Namespace : Parameter Class

For a list of all members of this type, see Parameter members.

Public Events

 | Name | Description
Public Event | PropertyChanged |
Top

See Also

Reference

Parameter Class
Telerik.Reporting Namespace


PropertyChanged Event

PropertyChanged Event
[image]
Telerik.Reporting Namespace > Parameter Class : PropertyChanged Event

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged() As PropertyChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Parameter
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
C#
public event PropertyChangedEventHandler PropertyChanged()

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged() As PropertyChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Parameter
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
C#
public event PropertyChangedEventHandler PropertyChanged()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Parameter Class
Parameter Members


ParameterCollection Class

ParameterCollection Class
See Also Members
[image]
Telerik.Reporting Namespace : ParameterCollection Class

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ParameterCollection
   Inherits Collection(Of Parameter)
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection
C#
public class ParameterCollection : Collection<Parameter>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<Parameter>
Telerik.Reporting.ParameterCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Members
Telerik.Reporting Namespace


ParameterCollection Class Members

ParameterCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting Namespace : ParameterCollection Class

The following tables list the members exposed by ParameterCollection.

Public Constructors

 | Name | Description
Public Constructor | ParameterCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | AddRange |
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Top

See Also

Reference

ParameterCollection Class
Telerik.Reporting Namespace


ParameterCollection Constructor

ParameterCollection Constructor
[image]
Telerik.Reporting Namespace > ParameterCollection Class : ParameterCollection Constructor

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection()
C#
public ParameterCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection()
C#
public ParameterCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Methods

ParameterCollection Class Methods
[image]
Telerik.Reporting Namespace : ParameterCollection Class

For a list of all members of this type, see ParameterCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | AddRange |
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Top

See Also

Reference

ParameterCollection Class
Telerik.Reporting Namespace


AddRange Method

AddRange Method
[image]
Telerik.Reporting Namespace > ParameterCollection Class : AddRange Method

collection

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of Parameter) _
)
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection
Dim collection As IEnumerable(Of Parameter)

instance.AddRange(collection)
C#
public void AddRange(
   IEnumerable<Parameter> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollectionConverter Class

ParameterCollectionConverter Class
See Also Members
[image]
Telerik.Reporting Namespace : ParameterCollectionConverter Class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Class ParameterCollectionConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollectionConverter
C#
private class ParameterCollectionConverter : TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Reporting.ParameterCollectionConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollectionConverter Members
Telerik.Reporting Namespace


ParameterCollectionConverter Class Members

ParameterCollectionConverter Class Members
See Also Methods
[image]
Telerik.Reporting Namespace : ParameterCollectionConverter Class

The following tables list the members exposed by ParameterCollectionConverter.

Public Constructors

 | Name | Description
Public Constructor | ParameterCollectionConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ParameterCollectionConverter Class
Telerik.Reporting Namespace


ParameterCollectionConverter Constructor

ParameterCollectionConverter Constructor
[image]
Telerik.Reporting Namespace > ParameterCollectionConverter Class : ParameterCollectionConverter Constructor

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollectionConverter()
C#
public ParameterCollectionConverter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollectionConverter()
C#
public ParameterCollectionConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollectionConverter Class
ParameterCollectionConverter Members


ParameterCollectionConverter Class Methods

ParameterCollectionConverter Class Methods
[image]
Telerik.Reporting Namespace : ParameterCollectionConverter Class

For a list of all members of this type, see ParameterCollectionConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ParameterCollectionConverter Class
Telerik.Reporting Namespace


ConvertTo Method

ConvertTo Method
[image]
Telerik.Reporting Namespace > ParameterCollectionConverter Class : ConvertTo Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollectionConverter Class
ParameterCollectionConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also
[image]
Telerik.Reporting Namespace > ParameterCollectionConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollectionConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
culture
value
destinationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollectionConverter Class
ParameterCollectionConverter Members
Overload List


PictureBox Class

PictureBox Class
See Also Members
[image]
Telerik.Reporting Namespace : PictureBox Class

Represents a picture box report item for displaying an image.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PictureBox
   Inherits ReportItem
   Implements IArrangedItem, ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
C#
public class PictureBox : ReportItem, IArrangedItem, ILayoutItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportItem
Telerik.Reporting.PictureBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Members
Telerik.Reporting Namespace


PictureBox Class Members

PictureBox Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : PictureBox Class

The following tables list the members exposed by PictureBox.

Public Constructors

 | Name | Description
Public Constructor | PictureBox Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | MimeType | Gets or sets a string that contains the picture box's Multipurpose Internet Mail Extensions (MIME) type.
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Sizing | Gets or sets the sizing mode of the PictureBox.
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Value | Gets or sets the value associated with this PictureBox.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Overridden. This member overrides ReportItem.DefaultSize.
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

PictureBox Class
Telerik.Reporting Namespace


PictureBox Constructor

PictureBox Constructor
[image]
Telerik.Reporting Namespace > PictureBox Class : PictureBox Constructor

Overload List

Overload | Description
PictureBox Constructor() |
PictureBox Constructor(SerializationInfo,StreamingContext) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


PictureBox Constructor()

PictureBox Constructor()
See Also
[image]
Telerik.Reporting Namespace > PictureBox Class > PictureBox Constructor : PictureBox Constructor()

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PictureBox()
C#
public PictureBox()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PictureBox()
C#
public PictureBox()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members
Overload List


PictureBox Constructor(SerializationInfo,StreamingContext)

PictureBox Constructor(SerializationInfo,StreamingContext)
See Also
[image]
Telerik.Reporting Namespace > PictureBox Class > PictureBox Constructor : PictureBox Constructor(SerializationInfo,StreamingContext)

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As PictureBox(info, context)
C#
protected PictureBox(
   SerializationInfo info,
   StreamingContext context
)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As PictureBox(info, context)
C#
protected PictureBox(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members
Overload List


PictureBox Class Methods

PictureBox Class Methods
[image]
Telerik.Reporting Namespace : PictureBox Class

For a list of all members of this type, see PictureBox members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

PictureBox Class
Telerik.Reporting Namespace


Dispose Method

Dispose Method
[image]
Telerik.Reporting Namespace > PictureBox Class : Dispose Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose(Boolean) |
Dispose() | (Inherited from System.ComponentModel.Component)

Overload List

Overload | Description
Dispose(Boolean) |
Dispose() | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting Namespace > PictureBox Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members
Overload List


PictureBox Class Properties

PictureBox Class Properties
[image]
Telerik.Reporting Namespace : PictureBox Class

For a list of all members of this type, see PictureBox members.

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | MimeType | Gets or sets a string that contains the picture box's Multipurpose Internet Mail Extensions (MIME) type.
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Sizing | Gets or sets the sizing mode of the PictureBox.
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Value | Gets or sets the value associated with this PictureBox.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Overridden. This member overrides ReportItem.DefaultSize.
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PictureBox Class
Telerik.Reporting Namespace


DefaultSize Property

DefaultSize Property
[image]
Telerik.Reporting Namespace > PictureBox Class : DefaultSize Property

This member overrides ReportItem.DefaultSize.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property DefaultSize As SizeU
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As SizeU

value = instance.DefaultSize
C#
protected override SizeU DefaultSize {get;}

Return Value

A SizeU object that defines the default size of the PictureBox. It is 100 pixels wide by 100 pixels high by default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


MimeType Property

MimeType Property
[image]
Telerik.Reporting Namespace > PictureBox Class : MimeType Property

Gets or sets a string that contains the picture box's Multipurpose Internet Mail Extensions (MIME) type.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property MimeType As String
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As String

instance.MimeType = value

value = instance.MimeType
C#
public string MimeType {get; set;}

Return Value

A string that contains the picture box's Multipurpose Internet Mail Extensions (MIME) type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Sizing Property

Sizing Property
[image]
Telerik.Reporting Namespace > PictureBox Class : Sizing Property

Gets or sets the sizing mode of the PictureBox.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Sizing As ImageSizeMode
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As ImageSizeMode

instance.Sizing = value

value = instance.Sizing
C#
public ImageSizeMode Sizing {get; set;}

Return Value

A ImageSizeMode object that specifies the sizing mode of the PictureBox.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Value Property

Value Property
[image]
Telerik.Reporting Namespace > PictureBox Class : Value Property

Gets or sets the value associated with this PictureBox.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As Object

instance.Value = value

value = instance.Value
C#
public object Value {get; set;}

Return Value

A String that starts with "=" is interpreted as data expression; Image that holds an image data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Report Class

Report Class
See Also Members
[image]
Telerik.Reporting Namespace : Report Class

Represents the base class for any report in the Telerik Reporting.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Report
   Inherits ReportItemBase
   Implements IDataItem
Visual Basic (Usage) Copy Code
Dim instance As Report
C#
public class Report : ReportItemBase, IDataItem

Remarks

All reports created with Telerik Reporting inherit from the Report class. The Report comprises of one or more report sections which contain report items.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.Report

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Members
Telerik.Reporting Namespace


Report Class Members

Report Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : Report Class

The following tables list the members exposed by Report.

Public Constructors

 | Name | Description
Public Constructor | Report Constructor | Initializes a new instance of the Report class with default settings.
Top

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Culture | Gets or sets the culture information associated with the report.
Public Property | DataMember | Gets or sets the specific list in a DataSource which the Report will render.
Public Property | DataSource | Gets or sets the data source that the Report is displaying data for.
Public Property | DocumentName | Gets or sets a String representing the name of the report document.
Public Property | ExternalStyles |
Public Property | ExternalStyleSheets | Gets the collection of ExternalStyleSheets for the report.
Public Property | Filters | Gets a FilterCollection that defines the filter expression(s) for the Report
Public Property | Groups | Gets a GroupCollection that defines the groups for the Report
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageSettings | Gets or sets the page settings for the Report .
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | ReportParameters |
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Sorting | Gets a SortingCollection that defines the sort column(s), and their type and order for the Report
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | StyleSheet | Gets the StyleSheet associated with the report.
Public Property | UnitOfMeasure | Gets or sets the default unit of measure for the report.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Overridden.
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Protected Method | OnNeedDataSource |
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | NeedDataSource | Occurs at the start of report processing if the report has no data source set.
Top

See Also

Reference

Report Class
Telerik.Reporting Namespace


Report Constructor

Report Constructor
[image]
Telerik.Reporting Namespace > Report Class : Report Constructor

Initializes a new instance of the Report class with default settings.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Report()
C#
public Report()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Report()
C#
public Report()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Report Class Methods

Report Class Methods
[image]
Telerik.Reporting Namespace : Report Class

For a list of all members of this type, see Report members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Overridden.
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Protected Method | OnNeedDataSource |
Top

See Also

Reference

Report Class
Telerik.Reporting Namespace


OnItemAdded Method

OnItemAdded Method
[image]
Telerik.Reporting Namespace > Report Class : OnItemAdded Method

item

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnItemAdded( _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim item As ReportItemBase

instance.OnItemAdded(item)
C#
protected override void OnItemAdded(
   ReportItemBase item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


OnNeedDataSource Method

OnNeedDataSource Method
[image]
Telerik.Reporting Namespace > Report Class : OnNeedDataSource Method

sender
e

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnNeedDataSource( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim sender As Object
Dim e As EventArgs

instance.OnNeedDataSource(sender, e)
C#
protected virtual void OnNeedDataSource(
   object sender,
   EventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Report Class Properties

Report Class Properties
[image]
Telerik.Reporting Namespace : Report Class

For a list of all members of this type, see Report members.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Culture | Gets or sets the culture information associated with the report.
Public Property | DataMember | Gets or sets the specific list in a DataSource which the Report will render.
Public Property | DataSource | Gets or sets the data source that the Report is displaying data for.
Public Property | DocumentName | Gets or sets a String representing the name of the report document.
Public Property | ExternalStyles |
Public Property | ExternalStyleSheets | Gets the collection of ExternalStyleSheets for the report.
Public Property | Filters | Gets a FilterCollection that defines the filter expression(s) for the Report
Public Property | Groups | Gets a GroupCollection that defines the groups for the Report
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageSettings | Gets or sets the page settings for the Report .
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | ReportParameters |
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Sorting | Gets a SortingCollection that defines the sort column(s), and their type and order for the Report
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | StyleSheet | Gets the StyleSheet associated with the report.
Public Property | UnitOfMeasure | Gets or sets the default unit of measure for the report.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Report Class
Telerik.Reporting Namespace


Culture Property

Culture Property
[image]
Telerik.Reporting Namespace > Report Class : Culture Property

Gets or sets the culture information associated with the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Culture As CultureInfo
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As CultureInfo

instance.Culture = value

value = instance.Culture
C#
public CultureInfo Culture {get; set;}

Return Value

A CultureInfo representing the culture supported by the Report.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


DataMember Property

DataMember Property
[image]
Telerik.Reporting Namespace > Report Class : DataMember Property

Gets or sets the specific list in a DataSource which the Report will render.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
public string DataMember {get; set;}

Return Value

A list in a DataSource. The default is an empty string ("").

Remarks

If a DataSource contains multiple sources of data, you should set the DataMember to one of the sources. For example, if the DataSource is a DataSet or DataViewManager that contains three tables named

Customers
,
Orders
, and
OrderDetails
, you must specify the table to bind to.

If the DataSource is a DataTable, DataView, collection, or array, there is no need to set the DataMember property of the Report

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


DataSource Property

DataSource Property
[image]
Telerik.Reporting Namespace > Report Class : DataSource Property

Gets or sets the data source that the Report is displaying data for.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
public object DataSource {get; set;}

Return Value

An object that functions as a data source.

Remarks

The following data sources are valid:

  • A DataTable
  • A DataView
  • A DataSet
  • A DataViewManager
  • Any component that implements the IListSource interface
  • Any component that implements the IEnumerable interface
  • Any component that implements the IDataAdapter interface

If the DataSource reference contains more than one table, you must set the DataMember property a string that specifies the table to bind to. For example, if the DataSource is a DataSet or DataViewManager that contains three tables named

Customers
,
Orders
, and
OrderDetails
, you must specify the table to bind to.

Setting the DataSource to an object that does not implement the IListSource, IEnumerable, or IDataAdapter will cause an exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


DocumentName Property

DocumentName Property
[image]
Telerik.Reporting Namespace > Report Class : DocumentName Property

Gets or sets a String representing the name of the report document.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentName As String
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As String

instance.DocumentName = value

value = instance.DocumentName
C#
public string DocumentName {get; set;}

Return Value

A String representing the document name. The default value is the name of the Report this property belongs to.

Remarks

The value of this property is used to suggest a file name when exporting a report to one of the available export formats.

A String that starts with "=" is interpreted as an expression to evaluate the document name; otherwise it is interpreted as a literal string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ExternalStyles Property

ExternalStyles Property
[image]
Telerik.Reporting Namespace > Report Class : ExternalStyles Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExternalStyles As ICollection(Of String)
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As ICollection(Of String)

value = instance.ExternalStyles
C#
public ICollection<string> ExternalStyles {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ExternalStyleSheets Property

ExternalStyleSheets Property
[image]
Telerik.Reporting Namespace > Report Class : ExternalStyleSheets Property

Gets the collection of ExternalStyleSheets for the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExternalStyleSheets As ICollection(Of ExternalStyleSheet)
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As ICollection(Of ExternalStyleSheet)

value = instance.ExternalStyleSheets
C#
public ICollection<ExternalStyleSheet> ExternalStyleSheets {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Filters Property

Filters Property
[image]
Telerik.Reporting Namespace > Report Class : Filters Property

Gets a FilterCollection that defines the filter expression(s) for the Report

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filters As FilterCollection
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As FilterCollection

value = instance.Filters
C#
public FilterCollection Filters {get;}

Return Value

A FilterCollection that contains the Filter objects for the Report

Remarks

Filter expressions limit the data that is displayed to the user after the data is retrieved from the data source.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Groups Property

Groups Property
[image]
Telerik.Reporting Namespace > Report Class : Groups Property

Gets a GroupCollection that defines the groups for the Report

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Groups As GroupCollection
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As GroupCollection

value = instance.Groups
C#
public GroupCollection Groups {get;}

Return Value

A GroupCollection that contains the Group objects for the Report

Remarks

Grouping is used to gather all rows that match certain grouping criteria together. Grouping criteria is defined by adding one or more Grouping objects to a Group.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


PageSettings Property

PageSettings Property
[image]
Telerik.Reporting Namespace > Report Class : PageSettings Property

Gets or sets the page settings for the Report .

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property PageSettings As PageSettings
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As PageSettings

instance.PageSettings = value

value = instance.PageSettings
C#
public PageSettings PageSettings {get; set;}

Return Value

The page settings for the Report.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ReportParameters Property

ReportParameters Property
[image]
Telerik.Reporting Namespace > Report Class : ReportParameters Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportParameters As ReportParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As ReportParameterCollection

value = instance.ReportParameters
C#
public ReportParameterCollection ReportParameters {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Sorting Property

Sorting Property
[image]
Telerik.Reporting Namespace > Report Class : Sorting Property

Gets a SortingCollection that defines the sort column(s), and their type and order for the Report

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sorting As SortingCollection
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As SortingCollection

value = instance.Sorting
C#
public SortingCollection Sorting {get;}

Return Value

A SortingCollection that contains the Sorting objects for the Report

Remarks

Sort expressions sort the data that is displayed to the user after the data is retrieved from the data source.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


StyleSheet Property

StyleSheet Property
[image]
Telerik.Reporting Namespace > Report Class : StyleSheet Property

Gets the StyleSheet associated with the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StyleSheet As StyleSheet
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As StyleSheet

value = instance.StyleSheet
C#
public StyleSheet StyleSheet {get;}

Return Value

A StyleSheet object representing a collection of style rules.

Remarks

The StyleSheet property of a report can be used to define various types of styles for use by the report items.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


UnitOfMeasure Property

UnitOfMeasure Property
[image]
Telerik.Reporting Namespace > Report Class : UnitOfMeasure Property

Gets or sets the default unit of measure for the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property UnitOfMeasure As UnitType
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As UnitType

instance.UnitOfMeasure = value

value = instance.UnitOfMeasure
C#
public virtual UnitType UnitOfMeasure {get; set;}

Return Value

An UnitType representing the default unit of measure for the report.

Remarks

All newly created report items will have their locations, sizes, etc. in this UnitType.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Width Property

Width Property
[image]
Telerik.Reporting Namespace > Report Class : Width Property

Gets or sets the width of the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public Unit Width {get; set;}

Return Value

The width of the report in Units.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Report Class Events

Report Class Events
[image]
Telerik.Reporting Namespace : Report Class

For a list of all members of this type, see Report members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | NeedDataSource | Occurs at the start of report processing if the report has no data source set.
Top

See Also

Reference

Report Class
Telerik.Reporting Namespace


NeedDataSource Event

NeedDataSource Event
[image]
Telerik.Reporting Namespace > Report Class : NeedDataSource Event

Occurs at the start of report processing if the report has no data source set.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event NeedDataSource() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim handler As EventHandler

AddHandler instance.NeedDataSource, handler
C#
public event EventHandler NeedDataSource()

Syntax

Visual Basic (Declaration)
Public Event NeedDataSource() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim handler As EventHandler

AddHandler instance.NeedDataSource, handler
C#
public event EventHandler NeedDataSource()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ReportConverter Class

ReportConverter Class
See Also Members
[image]
Telerik.Reporting Namespace : ReportConverter Class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As ReportConverter
C#
public class ReportConverter : TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Reporting.ReportConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportConverter Members
Telerik.Reporting Namespace


ReportConverter Class Members

ReportConverter Class Members
See Also Methods
[image]
Telerik.Reporting Namespace : ReportConverter Class

The following tables list the members exposed by ReportConverter.

Public Constructors

 | Name | Description
Public Constructor | ReportConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden.
Public Method | CanConvertTo | Overloaded. Overridden.
Public Method | ConvertFrom | Overloaded. Overridden.
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ReportConverter Class
Telerik.Reporting Namespace


ReportConverter Constructor

ReportConverter Constructor
[image]
Telerik.Reporting Namespace > ReportConverter Class : ReportConverter Constructor

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportConverter()
C#
public ReportConverter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportConverter()
C#
public ReportConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportConverter Class
ReportConverter Members


ReportConverter Class Methods

ReportConverter Class Methods
[image]
Telerik.Reporting Namespace : ReportConverter Class

For a list of all members of this type, see ReportConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden.
Public Method | CanConvertTo | Overloaded. Overridden.
Public Method | ConvertFrom | Overloaded. Overridden.
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ReportConverter Class
Telerik.Reporting Namespace


CanConvertFrom Method

CanConvertFrom Method
[image]
Telerik.Reporting Namespace > ReportConverter Class : CanConvertFrom Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) |
CanConvertFrom(Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) |
CanConvertFrom(Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportConverter Class
ReportConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

CanConvertFrom(ITypeDescriptorContext,Type) Method
[image]
Telerik.Reporting Namespace > ReportConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
sourceType

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportConverter
Dim context As ITypeDescriptorContext
Dim sourceType As Type
Dim value As Boolean

value = instance.CanConvertFrom(context, sourceType)
C#
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)

Parameters

context
sourceType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportConverter Class
ReportConverter Members
Overload List


CanConvertTo Method

CanConvertTo Method
[image]
Telerik.Reporting Namespace > ReportConverter Class : CanConvertTo Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) |
CanConvertTo(Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) |
CanConvertTo(Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportConverter Class
ReportConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

CanConvertTo(ITypeDescriptorContext,Type) Method
[image]
Telerik.Reporting Namespace > ReportConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
destinationType

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportConverter
Dim context As ITypeDescriptorContext
Dim destinationType As Type
Dim value As Boolean

value = instance.CanConvertTo(context, destinationType)
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)

Parameters

context
destinationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportConverter Class
ReportConverter Members
Overload List


ConvertFrom Method

ConvertFrom Method
[image]
Telerik.Reporting Namespace > ReportConverter Class : ConvertFrom Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) |
ConvertFrom(Object) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) |
ConvertFrom(Object) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportConverter Class
ReportConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also
[image]
Telerik.Reporting Namespace > ReportConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ReportConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim value As Object

value = instance.ConvertFrom(context, culture, value)
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
culture
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportConverter Class
ReportConverter Members
Overload List


ConvertTo Method

ConvertTo Method
[image]
Telerik.Reporting Namespace > ReportConverter Class : ConvertTo Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportConverter Class
ReportConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also
[image]
Telerik.Reporting Namespace > ReportConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ReportConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
culture
value
destinationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportConverter Class
ReportConverter Members
Overload List


ReportFooterSection Class

ReportFooterSection Class
See Also Members
[image]
Telerik.Reporting Namespace : ReportFooterSection Class

Represents a report footer section. Report footer is displayed at the end of a report, but before the last PageFooterSection if any.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportFooterSection
   Inherits ReportSection
   Implements ILayoutArranger, ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As ReportFooterSection
C#
public class ReportFooterSection : ReportSection, ILayoutArranger, ILayoutContainer

Remarks

If you do not want a PageFooterSection displayed on the last page set the PageSection.PrintOnLastPage property to false.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportSectionBase
Telerik.Reporting.ReportSection
Telerik.Reporting.ReportFooterSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportFooterSection Members
Telerik.Reporting Namespace


ReportFooterSection Class Members

ReportFooterSection Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : ReportFooterSection Class

The following tables list the members exposed by ReportFooterSection.

Public Constructors

 | Name | Description
Public Constructor | ReportFooterSection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

ReportFooterSection Class
Telerik.Reporting Namespace


ReportFooterSection Constructor

ReportFooterSection Constructor
[image]
Telerik.Reporting Namespace > ReportFooterSection Class : ReportFooterSection Constructor

Overload List

Overload | Description
ReportFooterSection Constructor() |
ReportFooterSection Constructor(SerializationInfo,StreamingContext) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportFooterSection Class
ReportFooterSection Members


ReportFooterSection Constructor()

ReportFooterSection Constructor()
See Also
[image]
Telerik.Reporting Namespace > ReportFooterSection Class > ReportFooterSection Constructor : ReportFooterSection Constructor()

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportFooterSection()
C#
public ReportFooterSection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportFooterSection()
C#
public ReportFooterSection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportFooterSection Class
ReportFooterSection Members
Overload List


ReportFooterSection Constructor(SerializationInfo,StreamingContext)

ReportFooterSection Constructor(SerializationInfo,StreamingContext)
See Also
[image]
Telerik.Reporting Namespace > ReportFooterSection Class > ReportFooterSection Constructor : ReportFooterSection Constructor(SerializationInfo,StreamingContext)

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As ReportFooterSection(info, context)
C#
protected ReportFooterSection(
   SerializationInfo info,
   StreamingContext context
)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As ReportFooterSection(info, context)
C#
protected ReportFooterSection(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportFooterSection Class
ReportFooterSection Members
Overload List


ReportHeaderSection Class

ReportHeaderSection Class
See Also Members
[image]
Telerik.Reporting Namespace : ReportHeaderSection Class

Represents a report header section. Report header is displayed at the beginning of a report, but after the first PageHeaderSection if any.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportHeaderSection
   Inherits ReportSection
   Implements ILayoutArranger, ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As ReportHeaderSection
C#
public class ReportHeaderSection : ReportSection, ILayoutArranger, ILayoutContainer

Remarks

If you do not want a PageHeaderSection displayed on the first page set the PageSection.PrintOnFirstPage property to false.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportSectionBase
Telerik.Reporting.ReportSection
Telerik.Reporting.ReportHeaderSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportHeaderSection Members
Telerik.Reporting Namespace


ReportHeaderSection Class Members

ReportHeaderSection Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : ReportHeaderSection Class

The following tables list the members exposed by ReportHeaderSection.

Public Constructors

 | Name | Description
Public Constructor | ReportHeaderSection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

ReportHeaderSection Class
Telerik.Reporting Namespace


ReportHeaderSection Constructor

ReportHeaderSection Constructor
[image]
Telerik.Reporting Namespace > ReportHeaderSection Class : ReportHeaderSection Constructor

Overload List

Overload | Description
ReportHeaderSection Constructor() |
ReportHeaderSection Constructor(SerializationInfo,StreamingContext) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportHeaderSection Class
ReportHeaderSection Members


ReportHeaderSection Constructor()

ReportHeaderSection Constructor()
See Also
[image]
Telerik.Reporting Namespace > ReportHeaderSection Class > ReportHeaderSection Constructor : ReportHeaderSection Constructor()

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportHeaderSection()
C#
public ReportHeaderSection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportHeaderSection()
C#
public ReportHeaderSection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportHeaderSection Class
ReportHeaderSection Members
Overload List


ReportHeaderSection Constructor(SerializationInfo,StreamingContext)

ReportHeaderSection Constructor(SerializationInfo,StreamingContext)
See Also
[image]
Telerik.Reporting Namespace > ReportHeaderSection Class > ReportHeaderSection Constructor : ReportHeaderSection Constructor(SerializationInfo,StreamingContext)

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As ReportHeaderSection(info, context)
C#
protected ReportHeaderSection(
   SerializationInfo info,
   StreamingContext context
)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As ReportHeaderSection(info, context)
C#
protected ReportHeaderSection(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportHeaderSection Class
ReportHeaderSection Members
Overload List


ReportItem Class

ReportItem Class
See Also Members
[image]
Telerik.Reporting Namespace : ReportItem Class

Defines the base class for all report items that can be placed in a ReportSectionBase. Items of this type have a location and a size.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ReportItem
   Inherits ReportItemBase
   Implements IArrangedItem, ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
C#
public abstract class ReportItem : ReportItemBase, IArrangedItem, ILayoutItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportItem
Telerik.Reporting.Barcode
Telerik.Reporting.Chart
Telerik.Reporting.Panel
Telerik.Reporting.PictureBox
Telerik.Reporting.Shape
Telerik.Reporting.SubReport
Telerik.Reporting.TextItemBase

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Members
Telerik.Reporting Namespace


ReportItem Class Members

ReportItem Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : ReportItem Class

The following tables list the members exposed by ReportItem.

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent.
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area.
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item.
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent.
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item.
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container.
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item.
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Gets the default size of the report item.
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

ReportItem Class
Telerik.Reporting Namespace


ReportItem Class Properties

ReportItem Class Properties
[image]
Telerik.Reporting Namespace : ReportItem Class

For a list of all members of this type, see ReportItem members.

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent.
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area.
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item.
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent.
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item.
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container.
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item.
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Gets the default size of the report item.
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ReportItem Class
Telerik.Reporting Namespace


Anchor Property

Anchor Property
[image]
Telerik.Reporting Namespace > ReportItem Class : Anchor Property

Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Anchor As AnchorStyles
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As AnchorStyles

instance.Anchor = value

value = instance.Anchor
C#
public AnchorStyles Anchor {get; set;}

Return Value

A bitwise combination of the AnchorStyles values. The default is None.

Remarks

Use the Anchor property to define how a report is automatically resized as its parent item is resized. Anchoring a report to its parent ensures that the anchored edges remain in the same position relative to the edges of the parent when the parent control is resized.

You can anchor a report item to one or more edges of its container. For example, if you have a DetailSection with a TextBox whose Anchor property value is set to Top and Bottom, the TextBox is stretched to maintain the anchored distance to the top and bottom edges of the DetailSection as the Height of the DetailSection is increased.

Note:The Anchor and Dock properties are mutually exclusive. Only one can be set at a time, and the last one set takes precedence.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Bottom Property

Bottom Property
[image]
Telerik.Reporting Namespace > ReportItem Class : Bottom Property

Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As Unit

value = instance.Bottom
C#
public Unit Bottom {get;}

Return Value

An Unit representing the distance between the bottom edge of the report item and the top edge of its container's client area.

Remarks

The value of the Bottom property is equal to the sum of the Top property value and the Height property value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Bounds Property

Bounds Property
[image]
Telerik.Reporting Namespace > ReportItem Class : Bounds Property

Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Bounds As RectangleU
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As RectangleU

instance.Bounds = value

value = instance.Bounds
C#
public RectangleU Bounds {get; set;}

Return Value

A RectangleU relative to the parent report item that represents the size and location of the report item including its nonclient elements.

Remarks

The bounds of the report item include the nonclient elements such as borders and padding.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


DefaultSize Property

DefaultSize Property
[image]
Telerik.Reporting Namespace > ReportItem Class : DefaultSize Property

Gets the default size of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultSize As SizeU
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As SizeU

value = instance.DefaultSize
C#
protected virtual SizeU DefaultSize {get;}

Return Value

The default SizeU of the report item.

Remarks

The DefaultSize property represents the SizeU of the report item when it is initially created. You can adjust the size of the report item by setting its Size property value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Dock Property

Dock Property
[image]
Telerik.Reporting Namespace > ReportItem Class : Dock Property

Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Dock As DockStyle
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As DockStyle

instance.Dock = value

value = instance.Dock
C#
public DockStyle Dock {get; set;}

Return Value

One of the DockStyle values. The default is None.

Remarks

Use the Dock property to define how a report is automatically resized as its parent is resized. For example, setting Dock to Bottom causes the report item to align itself with the bottom edges of its parent and to resize as the parent is resized.

A report item can be docked to one edge of its parent container or can be docked to all edges and fill the parent container.

Note:The Anchor and Dock properties are mutually exclusive. Only one can be set at a time, and the last one set takes precedence.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Height Property

Height Property
[image]
Telerik.Reporting Namespace > ReportItem Class : Height Property

Gets or sets the height of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public Unit Height {get; set;}

Return Value

The height of the report item in Units.

Remarks

Changes made to the Height and Top property values cause the Bottom property value of the report item to change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Left Property

Left Property
[image]
Telerik.Reporting Namespace > ReportItem Class : Left Property

Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As Unit

instance.Left = value

value = instance.Left
C#
public Unit Left {get; set;}

Return Value

An Unit representing the distance between the left edge of the report item and the left edge of its container's client area.

Remarks

The Left property value is equivalent to the PointU.X property of the Location property value of the report item.

Changes made to the Width and Left property values cause the Right property value of the report item to change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Location Property

Location Property
[image]
Telerik.Reporting Namespace > ReportItem Class : Location Property

Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Location As PointU
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As PointU

instance.Location = value

value = instance.Location
C#
public PointU Location {get; set;}

Return Value

The PointU that represents the upper-left corner of the report item relative to the upper-left corner of its container.

Remarks

Because the PointU class is a value type (Structure in Visual Basic, struct in Visual C#), it is returned by value, meaning accessing the property returns a copy of the upper-left point of the report item. So, adjusting the PointU.X or PointU.Y properties of the PointU returned from this property will not affect the Left, Right, Top, or Bottom property values of the report item. To adjust these properties set each property value individually, or set the Location property with a new PointU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Right Property

Right Property
[image]
Telerik.Reporting Namespace > ReportItem Class : Right Property

Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As Unit

value = instance.Right
C#
public Unit Right {get;}

Return Value

An Unit representing the distance between the right edge of the report item and the left edge of its container's client area.

Remarks

The value of the Right property is equal to the sum of the Left property value and the Width property value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Size Property

Size Property
[image]
Telerik.Reporting Namespace > ReportItem Class : Size Property

Gets or sets the height and width of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Size As SizeU
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As SizeU

instance.Size = value

value = instance.Size
C#
public SizeU Size {get; set;}

Return Value

The SizeU that represents the height and width of the report item in Units.

Remarks

Because the SizeU class is a value type (Structure in Visual Basic, struct in Visual C#), it is returned by value, meaning accessing the property returns a copy of the size of the report item. So, adjusting the SizeU.Width or SizeU.Height properties of the SizeU returned from this property will not affect the Width or Height of the report item. To adjust the Width or Height of the report item, you must set the item's Width or Height property, or set the Size property with a new SizeU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Top Property

Top Property
[image]
Telerik.Reporting Namespace > ReportItem Class : Top Property

Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As Unit

instance.Top = value

value = instance.Top
C#
public Unit Top {get; set;}

Return Value

An Unit representing the distance between the top edge of the report item and the top edge of its container's client area.

Remarks

The Top property value is equivalent to the PointU.Y property of the Location property value of the report item.

Changes made to the Height and Top property values cause the Bottom property value of the report item to change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Width Property

Width Property
[image]
Telerik.Reporting Namespace > ReportItem Class : Width Property

Gets or sets the width of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public Unit Width {get; set;}

Return Value

The width of the report item in Units.

Remarks

Changes made to the Width and Left property values cause the Right property value of the report item to change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


ReportItemBase Class

ReportItemBase Class
See Also Members
[image]
Telerik.Reporting Namespace : ReportItemBase Class

Defines the base class for visual report items used for creating reports.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ReportItemBase
   Inherits Component
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
C#
public abstract class ReportItemBase : Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.Report
Telerik.Reporting.ReportItem
Telerik.Reporting.ReportSectionBase

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Members
Telerik.Reporting Namespace


ReportItemBase Class Members

ReportItemBase Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : ReportItemBase Class

The following tables list the members exposed by ReportItemBase.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting |
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items.
Public Property | Items | Gets the collection of report items contained within the report item.
Public Property | Name | Gets or sets the name of the report item.
Public Property | Parent | Gets or sets the parent container of the report item.
Public Property | Report | Gets the report this item belongs to.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item.
Public Property | StyleName | Gets or sets the name of the report item's global style.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Overridden. Returns a String that represents the current ReportItemBase.
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles |
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal |
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event.
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event.
Protected Method | OnItemValidate |
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection.
Public Event | ItemDataBinding | Occurs when the report item binds to a data source.
Public Event | ItemDataBound | Occurs after the report item binds to a data source.
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection.
Top

See Also

Reference

ReportItemBase Class
Telerik.Reporting Namespace


ReportItemBase Class Methods

ReportItemBase Class Methods
[image]
Telerik.Reporting Namespace : ReportItemBase Class

For a list of all members of this type, see ReportItemBase members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Overridden. Returns a String that represents the current ReportItemBase.
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles |
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal |
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event.
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event.
Protected Method | OnItemValidate |
Top

See Also

Reference

ReportItemBase Class
Telerik.Reporting Namespace


ClearStyles Method

ClearStyles Method
[image]
Telerik.Reporting Namespace > ReportItemBase Class : ClearStyles Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ClearStyles()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase

instance.ClearStyles()
C#
protected void ClearStyles()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


Contains Method

Contains Method
[image]
Telerik.Reporting Namespace > ReportItemBase Class : Contains Method

item
The ReportItemBase to evaluate.
Retrieves a value indicating whether the specified report item is a child of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As ReportItemBase _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim item As ReportItemBase
Dim value As Boolean

value = instance.Contains(item)
C#
public bool Contains(
   ReportItemBase item
)

Parameters

item
The ReportItemBase to evaluate.

Return Value

true if the specified report item is a child of the report item; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


Dispose Method

Dispose Method
[image]
Telerik.Reporting Namespace > ReportItemBase Class : Dispose Method

Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources.
Dispose() | (Inherited from System.ComponentModel.Component)

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources.
Dispose() | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting Namespace > ReportItemBase Class > Dispose Method : Dispose(Boolean) Method

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members
Overload List


GetObjectDataInternal Method

GetObjectDataInternal Method
[image]
Telerik.Reporting Namespace > ReportItemBase Class : GetObjectDataInternal Method

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub GetObjectDataInternal( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectDataInternal(info, context)
C#
protected virtual void GetObjectDataInternal(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


OnItemAdded Method

OnItemAdded Method
[image]
Telerik.Reporting Namespace > ReportItemBase Class : OnItemAdded Method

item
The ReportItemBase being added.
Raises the ReportItemBase.ItemAdded event.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemAdded( _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim item As ReportItemBase

instance.OnItemAdded(item)
C#
protected virtual void OnItemAdded(
   ReportItemBase item
)

Parameters

item
The ReportItemBase being added.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


OnItemRemoved Method

OnItemRemoved Method
[image]
Telerik.Reporting Namespace > ReportItemBase Class : OnItemRemoved Method

item
The ReportItemBase being removed.
Raises the ReportItemBase.ItemRemoved event.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemRemoved( _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim item As ReportItemBase

instance.OnItemRemoved(item)
C#
protected virtual void OnItemRemoved(
   ReportItemBase item
)

Parameters

item
The ReportItemBase being removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


OnItemValidate Method

OnItemValidate Method
[image]
Telerik.Reporting Namespace > ReportItemBase Class : OnItemValidate Method

item

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemValidate( _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim item As ReportItemBase

instance.OnItemValidate(item)
C#
protected virtual void OnItemValidate(
   ReportItemBase item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


ToString Method

ToString Method
[image]
Telerik.Reporting Namespace > ReportItemBase Class : ToString Method

Returns a String that represents the current ReportItemBase.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A String that contains the Name and the Type's FullName of the current ReportItemBase.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


ReportItemBase Class Properties

ReportItemBase Class Properties
[image]
Telerik.Reporting Namespace : ReportItemBase Class

For a list of all members of this type, see ReportItemBase members.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting |
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items.
Public Property | Items | Gets the collection of report items contained within the report item.
Public Property | Name | Gets or sets the name of the report item.
Public Property | Parent | Gets or sets the parent container of the report item.
Public Property | Report | Gets the report this item belongs to.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item.
Public Property | StyleName | Gets or sets the name of the report item's global style.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ReportItemBase Class
Telerik.Reporting Namespace


ConditionalFormatting Property

ConditionalFormatting Property
[image]
Telerik.Reporting Namespace > ReportItemBase Class : ConditionalFormatting Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConditionalFormatting As ConditionalFormatting
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As ConditionalFormatting

value = instance.ConditionalFormatting
C#
public ConditionalFormatting ConditionalFormatting {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


HasChildren Property

HasChildren Property
[image]
Telerik.Reporting Namespace > ReportItemBase Class : HasChildren Property

Gets a value indicating whether the report item contains one or more child items.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasChildren As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As Boolean

value = instance.HasChildren
C#
public bool HasChildren {get;}

Return Value

true if the report item contains one or more child items; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


Items Property

Items Property
[image]
Telerik.Reporting Namespace > ReportItemBase Class : Items Property

Gets the collection of report items contained within the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As ReportItemBase.ItemCollection
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As ReportItemBase.ItemCollection

value = instance.Items
C#
public ReportItemBase.ItemCollection Items {get;}

Return Value

An ReportItemBase.ItemCollection representing the collection of items contained within the item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


Name Property

Name Property
[image]
Telerik.Reporting Namespace > ReportItemBase Class : Name Property

Gets or sets the name of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As String

instance.Name = value

value = instance.Name
C#
public virtual string Name {get; set;}

Return Value

The name of the report item.

Remarks

The Name property can be used at run time to evaluate the object by name rather than type and programmatic name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


Parent Property

Parent Property
[image]
Telerik.Reporting Namespace > ReportItemBase Class : Parent Property

Gets or sets the parent container of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As ReportItemBase
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As ReportItemBase

instance.Parent = value

value = instance.Parent
C#
public ReportItemBase Parent {get; set;}

Return Value

A ReportItemBase that represents the parent item of the report item.

Remarks

Setting the Parent property value to a null reference (Nothing in Visual Basic) removes the item from the ReportItemBase.ItemCollection of its current parent item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


Report Property

Report Property
[image]
Telerik.Reporting Namespace > ReportItemBase Class : Report Property

Gets the report this item belongs to.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As Report

value = instance.Report
C#
public Report Report {get;}

Return Value

A Report object which the item belongs to.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


Style Property

Style Property
[image]
Telerik.Reporting Namespace > ReportItemBase Class : Style Property

Gets a Style object specifying the appearance of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Return Value

A Style object specifying the items's style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


StyleName Property

StyleName Property
[image]
Telerik.Reporting Namespace > ReportItemBase Class : StyleName Property

Gets or sets the name of the report item's global style.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property StyleName As String
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As String

instance.StyleName = value

value = instance.StyleName
C#
public virtual string StyleName {get; set;}

Return Value

A string value specifying the style name.

Remarks

Global styles are defined through the Report's StyleSheet property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


Visible Property

Visible Property
[image]
Telerik.Reporting Namespace > ReportItemBase Class : Visible Property

Gets or sets a value indicating whether the report item is displayed.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Return Value

true if the report item is displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


ReportItemBase Class Events

ReportItemBase Class Events
[image]
Telerik.Reporting Namespace : ReportItemBase Class

For a list of all members of this type, see ReportItemBase members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection.
Public Event | ItemDataBinding | Occurs when the report item binds to a data source.
Public Event | ItemDataBound | Occurs after the report item binds to a data source.
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection.
Top

See Also

Reference

ReportItemBase Class
Telerik.Reporting Namespace


ItemAdded Event

ItemAdded Event
[image]
Telerik.Reporting Namespace > ReportItemBase Class : ItemAdded Event

Occurs when a new report item is added to the ReportItemBase.ItemCollection.

Event Data

The event handler receives an argument of type ItemEventArgs containing data related to this event. The following ItemEventArgs properties provide information specific to this event.

Property | Description
Item | Gets the report item that is added/removed.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event ItemAdded() As ItemEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim handler As ItemEventHandler

AddHandler instance.ItemAdded, handler
C#
public event ItemEventHandler ItemAdded()

Syntax

Visual Basic (Declaration)
Public Event ItemAdded() As ItemEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim handler As ItemEventHandler

AddHandler instance.ItemAdded, handler
C#
public event ItemEventHandler ItemAdded()

Event Data

The event handler receives an argument of type ItemEventArgs containing data related to this event. The following ItemEventArgs properties provide information specific to this event.

Property | Description
Item | Gets the report item that is added/removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


ItemDataBinding Event

ItemDataBinding Event
[image]
Telerik.Reporting Namespace > ReportItemBase Class : ItemDataBinding Event

Occurs when the report item binds to a data source.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event ItemDataBinding() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim handler As EventHandler

AddHandler instance.ItemDataBinding, handler
C#
public event EventHandler ItemDataBinding()

Syntax

Visual Basic (Declaration)
Public Event ItemDataBinding() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim handler As EventHandler

AddHandler instance.ItemDataBinding, handler
C#
public event EventHandler ItemDataBinding()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


ItemDataBound Event

ItemDataBound Event
[image]
Telerik.Reporting Namespace > ReportItemBase Class : ItemDataBound Event

Occurs after the report item binds to a data source.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event ItemDataBound() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim handler As EventHandler

AddHandler instance.ItemDataBound, handler
C#
public event EventHandler ItemDataBound()

Syntax

Visual Basic (Declaration)
Public Event ItemDataBound() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim handler As EventHandler

AddHandler instance.ItemDataBound, handler
C#
public event EventHandler ItemDataBound()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


ItemRemoved Event

ItemRemoved Event
[image]
Telerik.Reporting Namespace > ReportItemBase Class : ItemRemoved Event

Occurs when a report item is removed from the ReportItemBase.ItemCollection.

Event Data

The event handler receives an argument of type ItemEventArgs containing data related to this event. The following ItemEventArgs properties provide information specific to this event.

Property | Description
Item | Gets the report item that is added/removed.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event ItemRemoved() As ItemEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim handler As ItemEventHandler

AddHandler instance.ItemRemoved, handler
C#
public event ItemEventHandler ItemRemoved()

Syntax

Visual Basic (Declaration)
Public Event ItemRemoved() As ItemEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim handler As ItemEventHandler

AddHandler instance.ItemRemoved, handler
C#
public event ItemEventHandler ItemRemoved()

Event Data

The event handler receives an argument of type ItemEventArgs containing data related to this event. The following ItemEventArgs properties provide information specific to this event.

Property | Description
Item | Gets the report item that is added/removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


ReportItemBase.ItemCollection Class

ReportItemBase.ItemCollection Class
See Also Members
[image]
Telerik.Reporting Namespace : ReportItemBase.ItemCollection Class

Represents a collection of ReportItemBase objects.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportItemBase.ItemCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
C#
public class ReportItemBase.ItemCollection : CollectionBase

Remarks

The Add, Remove, and RemoveAt methods enable you to add and remove individual items from the collection. You can also use the AddRange or Clear methods to add or remove all the items from the collection. You can determine if a ReportItemBase is a member of the collection by passing the item into the Contains method. To get the index value of the location of a ReportItemBase in the collection, pass the item into the IndexOf method. The collection can be copied into an array by calling the CopyTo method.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.Reporting.ReportItemBase.ItemCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Members
Telerik.Reporting Namespace


ReportItemBase.ItemCollection Class Members

ReportItemBase.ItemCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting Namespace : ReportItemBase.ItemCollection Class

The following tables list the members exposed by ReportItemBase.ItemCollection.

Public Constructors

 | Name | Description
Public Constructor | ReportItemBase.ItemCollection Constructor | Initializes a new instance of the ReportItemBase.ItemCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns the ReportItemBase at the specified indexed location in the collection.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the specified report item to the report item collection.
Public Method | AddRange | Adds an array of report item objects to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified report item is a member of the collection.
Public Method | ContainsKey | Determines whether the ReportItemBase.ItemCollection contains an item with the specified key.
Public Method | CopyTo | Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public Method | Find | Overloaded. Searches for report items by their ReportItemBase.Name property and builds an array of all the report items that match.
Public Method | FindItem | Searches the collection for a report item of the specified type.
Public Method | GetChildIndex | Overloaded. Retrieves the index of a report item within the item collection.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified report item in the report item collection.
Public Method | IndexOfKey | Retrieves the index of the first occurrence of the specified item within the collection.
Public Method | Insert | Inserts a specified ReportItemBase object into the ReportItemBase.ItemCollection at the specified index location.
Public Method | LoadFromPersistableMedium |
Public Method | Remove | Removes the specified report item from the item collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Public Method | RemoveByKey | Removes the child report item with the specified key.
Public Method | SaveToPersistableMedium |
Public Method | SetChildIndex | Sets the index of the specified child report item in the collection to the specified index value.
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | Overridden. Overrides the OnInsertComplete method.
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | Overridden. Overrides the OnRemoveComplete method.
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs additional custom processes when validating a value.
Top

See Also

Reference

ReportItemBase.ItemCollection Class
Telerik.Reporting Namespace


ReportItemBase.ItemCollection Constructor

ReportItemBase.ItemCollection Constructor
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : ReportItemBase.ItemCollection Constructor

owner
A ReportItemBase representing the report item that owns the report item collection.
Initializes a new instance of the ReportItemBase.ItemCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim owner As ReportItemBase

Dim instance As ReportItemBase.ItemCollection(owner)
C#
public ReportItemBase.ItemCollection(
   ReportItemBase owner
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim owner As ReportItemBase

Dim instance As ReportItemBase.ItemCollection(owner)
C#
public ReportItemBase.ItemCollection(
   ReportItemBase owner
)

Parameters

owner
A ReportItemBase representing the report item that owns the report item collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


ReportItemBase.ItemCollection Class Methods

ReportItemBase.ItemCollection Class Methods
[image]
Telerik.Reporting Namespace : ReportItemBase.ItemCollection Class

For a list of all members of this type, see ReportItemBase.ItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds the specified report item to the report item collection.
Public Method | AddRange | Adds an array of report item objects to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified report item is a member of the collection.
Public Method | ContainsKey | Determines whether the ReportItemBase.ItemCollection contains an item with the specified key.
Public Method | CopyTo | Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public Method | Find | Overloaded. Searches for report items by their ReportItemBase.Name property and builds an array of all the report items that match.
Public Method | FindItem | Searches the collection for a report item of the specified type.
Public Method | GetChildIndex | Overloaded. Retrieves the index of a report item within the item collection.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified report item in the report item collection.
Public Method | IndexOfKey | Retrieves the index of the first occurrence of the specified item within the collection.
Public Method | Insert | Inserts a specified ReportItemBase object into the ReportItemBase.ItemCollection at the specified index location.
Public Method | LoadFromPersistableMedium |
Public Method | Remove | Removes the specified report item from the item collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Public Method | RemoveByKey | Removes the child report item with the specified key.
Public Method | SaveToPersistableMedium |
Public Method | SetChildIndex | Sets the index of the specified child report item in the collection to the specified index value.
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | Overridden. Overrides the OnInsertComplete method.
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | Overridden. Overrides the OnRemoveComplete method.
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs additional custom processes when validating a value.
Top

See Also

Reference

ReportItemBase.ItemCollection Class
Telerik.Reporting Namespace


Add Method

Add Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : Add Method

item
The ReportItemBase to add to the report item collection.
Adds the specified report item to the report item collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal item As ReportItemBase _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim item As ReportItemBase
Dim value As Integer

value = instance.Add(item)
C#
public int Add(
   ReportItemBase item
)

Parameters

item
The ReportItemBase to add to the report item collection.

Return Value

The index of the added ReportItemBase

Remarks

The Add method allows you to add ReportItemBase objects to the end of the report item collection.

You can also add new ReportItemBase objects to the collection by using the AddRange method.

To remove a ReportItemBase that you previously added, use the Remove, RemoveAt, or Clear methods.

Note: A ReportItemBase can only be assigned to one ReportItemBase.ItemCollection at a time. If the ReportItemBase is already a child of another report item it is removed from that item before it is added to another item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


AddRange Method

AddRange Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : AddRange Method

items
An array of ReportItemBase objects to add to the collection.
Adds an array of report item objects to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal items() As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim items() As ReportItemBase

instance.AddRange(items)
C#
public void AddRange(
   ReportItemBase[] items
)

Parameters

items
An array of ReportItemBase objects to add to the collection.

Remarks

The ReportItemBase objects contained in the items array are appended to the end of the collection.

You can use the AddRange method to quickly add a group of ReportItemBase objects to the collection instead of manually adding each ReportItemBase to the collection using the Add method.

To remove a ReportItemBase that you previously added, use the Remove, RemoveAt, or Clear methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


Contains Method

Contains Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : Contains Method

item
The ReportItemBase to locate in the collection.
Determines whether the specified report item is a member of the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As ReportItemBase _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim item As ReportItemBase
Dim value As Boolean

value = instance.Contains(item)
C#
public bool Contains(
   ReportItemBase item
)

Parameters

item
The ReportItemBase to locate in the collection.

Return Value

true if the ReportItemBase is a member of the collection; otherwise, false.

Remarks

This method enables you to determine whether a ReportItemBase is a member of the collection before attempting to perform operations on the ReportItemBase. You can use this method to confirm that a ReportItemBase has been added to or is still a member of the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


ContainsKey Method

ContainsKey Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : ContainsKey Method

key
The key to locate in the ReportItemBase.ItemCollection.
Determines whether the ReportItemBase.ItemCollection contains an item with the specified key.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
   ByVal key As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim key As String
Dim value As Boolean

value = instance.ContainsKey(key)
C#
public bool ContainsKey(
   string key
)

Parameters

key
The key to locate in the ReportItemBase.ItemCollection.

Return Value

true if the ReportItemBase.ItemCollection contains an item with the specified key; otherwise, false.

Remarks

The ReportItemBase.Name property of a ReportItemBase corresponds to the key for a ReportItemBase in the ReportItemBase.ItemCollection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


CopyTo Method

CopyTo Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : CopyTo Method

dest
The one-dimensional Array that is the destination of the elements copied from the current collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal dest As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim dest As Array
Dim index As Integer

instance.CopyTo(dest, index)
C#
public void CopyTo(
   Array dest,
   int index
)

Parameters

dest
The one-dimensional Array that is the destination of the elements copied from the current collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


Find Method

Find Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : Find Method

Searches for report items by their ReportItemBase.Name property and builds an array of all the report items that match.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Find(String,Boolean) | Searches for report items by their ReportItemBase.Name property and builds an array of all the report items that match.
Find(Type) | Searches for report items by their Type and builds an array of all the items that match.
Find(Type,Boolean) | Searches for report items by their Type and builds an array of all the items that match.

Overload List

Overload | Description
Find(String,Boolean) | Searches for report items by their ReportItemBase.Name property and builds an array of all the report items that match.
Find(Type) | Searches for report items by their Type and builds an array of all the items that match.
Find(Type,Boolean) | Searches for report items by their Type and builds an array of all the items that match.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


Find(String,Boolean) Method

Find(String,Boolean) Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class > Find Method : Find(String,Boolean) Method

key
The key to locate in the ReportItemBase.ItemCollection.
recursive
true to search all child report items; otherwise, false.
Searches for report items by their ReportItemBase.Name property and builds an array of all the report items that match.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Find( _
   ByVal key As String, _
   ByVal recursive As Boolean _
) As ReportItemBase()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim key As String
Dim recursive As Boolean
Dim value() As ReportItemBase

value = instance.Find(key, recursive)
C#
public ReportItemBase[] Find(
   string key,
   bool recursive
)

Parameters

key
The key to locate in the ReportItemBase.ItemCollection.
recursive
true to search all child report items; otherwise, false.

Return Value

An array of type ReportItemBase containing the matching report items.

Exceptions

Exception | Description
ArgumentNullException | The key parameter is null or empty.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members
Overload List


Find(Type) Method

Find(Type) Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class > Find Method : Find(Type) Method

type
The Type to search for.
Searches for report items by their Type and builds an array of all the items that match.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Find( _
   ByVal type As Type _
) As ReportItemBase()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim type As Type
Dim value() As ReportItemBase

value = instance.Find(type)
C#
public ReportItemBase[] Find(
   Type type
)

Parameters

type
The Type to search for.

Return Value

An array of type ReportItemBase containing the matching report items.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members
Overload List


Find(Type,Boolean) Method

Find(Type,Boolean) Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class > Find Method : Find(Type,Boolean) Method

type
The Type to search for.
recursive
A value indicating whether to search all children recursively.
Searches for report items by their Type and builds an array of all the items that match.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Find( _
   ByVal type As Type, _
   ByVal recursive As Boolean _
) As ReportItemBase()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim type As Type
Dim recursive As Boolean
Dim value() As ReportItemBase

value = instance.Find(type, recursive)
C#
public ReportItemBase[] Find(
   Type type,
   bool recursive
)

Parameters

type
The Type to search for.
recursive
A value indicating whether to search all children recursively.

Return Value

An array of type ReportItemBase containing the matching report items.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members
Overload List


FindItem Method

FindItem Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : FindItem Method

type
The Type to search for.
Searches the collection for a report item of the specified type.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function FindItem( _
   ByVal type As Type _
) As ReportItemBase
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim type As Type
Dim value As ReportItemBase

value = instance.FindItem(type)
C#
public ReportItemBase FindItem(
   Type type
)

Parameters

type
The Type to search for.

Return Value

The first ReportItemBase in the collection that matches the given Type. If no item in the collection matches the given Type the method returns null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


GetChildIndex Method

GetChildIndex Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : GetChildIndex Method

Retrieves the index of a report item within the item collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetChildIndex(ReportItemBase) | Retrieves the index of a report item within the item collection.
GetChildIndex(ReportItemBase,Boolean) | Retrieves the index of the specified child report item within the item collection, and optionally raises an exception if the specified report item is not within the item collection.

Overload List

Overload | Description
GetChildIndex(ReportItemBase) | Retrieves the index of a report item within the item collection.
GetChildIndex(ReportItemBase,Boolean) | Retrieves the index of the specified child report item within the item collection, and optionally raises an exception if the specified report item is not within the item collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


GetChildIndex(ReportItemBase) Method

GetChildIndex(ReportItemBase) Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class > GetChildIndex Method : GetChildIndex(ReportItemBase) Method

child
The ReportItemBase to search for in the item collection.
Retrieves the index of a report item within the item collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function GetChildIndex( _
   ByVal child As ReportItemBase _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim child As ReportItemBase
Dim value As Integer

value = instance.GetChildIndex(child)
C#
public int GetChildIndex(
   ReportItemBase child
)

Parameters

child
The ReportItemBase to search for in the item collection.

Return Value

A zero-based index value that represents the location of the specified child report item within the item collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members
Overload List


GetChildIndex(ReportItemBase,Boolean) Method

GetChildIndex(ReportItemBase,Boolean) Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class > GetChildIndex Method : GetChildIndex(ReportItemBase,Boolean) Method

child
The ReportItemBase to search for in the item collection.
throwException
true to throw an exception if the ReportItemBase specified in the child parameter is not an item in the ReportItemBase.ItemCollection; otherwise, false.
Retrieves the index of the specified child report item within the item collection, and optionally raises an exception if the specified report item is not within the item collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Function GetChildIndex( _
   ByVal child As ReportItemBase, _
   ByVal throwException As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim child As ReportItemBase
Dim throwException As Boolean
Dim value As Integer

value = instance.GetChildIndex(child, throwException)
C#
public virtual int GetChildIndex(
   ReportItemBase child,
   bool throwException
)

Parameters

child
The ReportItemBase to search for in the item collection.
throwException
true to throw an exception if the ReportItemBase specified in the child parameter is not an item in the ReportItemBase.ItemCollection; otherwise, false.

Return Value

A zero-based index value that represents the location of the specified child report item within the item collection; otherwise -1 if the specified ReportItemBase is not found in the ReportItemBase.ItemCollection.

Exceptions

Exception | Description
ArgumentException | The child is not contained in the collection and the throwException parameter is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members
Overload List


IndexOf Method

IndexOf Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : IndexOf Method

item
The ReportItemBase to locate in the collection.
Retrieves the index of the specified report item in the report item collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As ReportItemBase _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim item As ReportItemBase
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   ReportItemBase item
)

Parameters

item
The ReportItemBase to locate in the collection.

Return Value

A zero-based index value that represents the position of the specified ReportItemBase in the ReportItemBase.ItemCollection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


IndexOfKey Method

IndexOfKey Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : IndexOfKey Method

key
The name of the report item to search for.
Retrieves the index of the first occurrence of the specified item within the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOfKey( _
   ByVal key As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim key As String
Dim value As Integer

value = instance.IndexOfKey(key)
C#
public int IndexOfKey(
   string key
)

Parameters

key
The name of the report item to search for.

Return Value

The zero-based index of the first occurrence of the report item with the specified name in the collection.

Remarks

The key comparison is not case-sensitive. If the key parameter is a null reference (Nothing in Visual Basic) or an empty string, or an item with the specified key is not found, IndexOfKey returns -1.

The ReportItemBase.Name property of a ReportItemBase corresponds to the key for a ReportItemBase in the ReportItemBase.ItemCollection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


Insert Method

Insert Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : Insert Method

index
The zero-based index location at which to insert the ReportItemBase object.
item
The ReportItemBase object to insert into the collection.
Inserts a specified ReportItemBase object into the ReportItemBase.ItemCollection at the specified index location.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim index As Integer
Dim item As ReportItemBase

instance.Insert(index, item)
C#
public void Insert(
   int index,
   ReportItemBase item
)

Parameters

index
The zero-based index location at which to insert the ReportItemBase object.
item
The ReportItemBase object to insert into the collection.

Remarks

Use the Insert method to insert a specified ReportItemBase object into the ReportItemBase.ItemCollection object at a specified index location.

To add a ReportItemBase object at the end of the ReportItemBase.ItemCollection object, use the Add method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


LoadFromPersistableMedium Method

LoadFromPersistableMedium Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : LoadFromPersistableMedium Method

media

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadFromPersistableMedium( _
   ByVal media As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim media As Object

instance.LoadFromPersistableMedium(media)
C#
public virtual void LoadFromPersistableMedium(
   object media
)

Parameters

media

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


OnInsertComplete Method

OnInsertComplete Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : OnInsertComplete Method

index
The zero-based index at which to insert value.
value
The new value of the element at index.
Overrides the OnInsertComplete method.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnInsertComplete( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim index As Integer
Dim value As Object

instance.OnInsertComplete(index, value)
C#
protected override void OnInsertComplete(
   int index,
   object value
)

Parameters

index
The zero-based index at which to insert value.
value
The new value of the element at index.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


OnRemoveComplete Method

OnRemoveComplete Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : OnRemoveComplete Method

index
The zero-based index at which value can be found.
value
The value of the element to remove from index.
Overrides the OnRemoveComplete method.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnRemoveComplete( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim index As Integer
Dim value As Object

instance.OnRemoveComplete(index, value)
C#
protected override void OnRemoveComplete(
   int index,
   object value
)

Parameters

index
The zero-based index at which value can be found.
value
The value of the element to remove from index.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


OnValidate Method

OnValidate Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : OnValidate Method

value
The object to validate.
Performs additional custom processes when validating a value.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnValidate( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim value As Object

instance.OnValidate(value)
C#
protected override void OnValidate(
   object value
)

Parameters

value
The object to validate.

Exceptions

Exception | Description
ArgumentException | The object is not an instance of the ReportItemBase class or one of its derived classes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


Remove Method

Remove Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : Remove Method

item
The ReportItemBase to remove from the ReportItemBase.ItemCollection.
Removes the specified report item from the item collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim item As ReportItemBase

instance.Remove(item)
C#
public void Remove(
   ReportItemBase item
)

Parameters

item
The ReportItemBase to remove from the ReportItemBase.ItemCollection.

Remarks

When a ReportItemBase is removed from the report item collection, all subsequent report items are moved up one position in the collection.

You can also remove a ReportItemBase by using the RemoveAt method, or remove all report items by using the Clear method.

To add new ReportItemBase objects to the collection, use the Add or AddRange methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


RemoveByKey Method

RemoveByKey Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : RemoveByKey Method

key
The name of the child report item to remove.
Removes the child report item with the specified key.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveByKey( _
   ByVal key As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim key As String

instance.RemoveByKey(key)
C#
public void RemoveByKey(
   string key
)

Parameters

key
The name of the child report item to remove.

Remarks

The ReportItemBase.Name property of a ReportItemBase corresponds to the key for a ReportItemBase in the ReportItemBase.ItemCollection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


SaveToPersistableMedium Method

SaveToPersistableMedium Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : SaveToPersistableMedium Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function SaveToPersistableMedium() As Object
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim value As Object

value = instance.SaveToPersistableMedium()
C#
public virtual object SaveToPersistableMedium()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


SetChildIndex Method

SetChildIndex Method
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : SetChildIndex Method

child
The child ReportItemBase to search for.
newIndex
The new index value of the report item.
Sets the index of the specified child report item in the collection to the specified index value.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetChildIndex( _
   ByVal child As ReportItemBase, _
   ByVal newIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim child As ReportItemBase
Dim newIndex As Integer

instance.SetChildIndex(child, newIndex)
C#
public virtual void SetChildIndex(
   ReportItemBase child,
   int newIndex
)

Parameters

child
The child ReportItemBase to search for.
newIndex
The new index value of the report item.

Remarks

When SetChildIndex is called, the ReportItemBase referred to by the child parameter is moved to the position specified by newIndex and the other ReportItemBase references in the ReportItemBase.ItemCollection are reordered to accommodate the move.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


ReportItemBase.ItemCollection Class Properties

ReportItemBase.ItemCollection Class Properties
[image]
Telerik.Reporting Namespace : ReportItemBase.ItemCollection Class

For a list of all members of this type, see ReportItemBase.ItemCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns the ReportItemBase at the specified indexed location in the collection.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

ReportItemBase.ItemCollection Class
Telerik.Reporting Namespace


Item Property

Item Property
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class : Item Property

Returns the ReportItemBase at the specified indexed location in the collection.

Overload List

Overload | Description
Item(Int32) | Returns the ReportItemBase at the specified indexed location in the collection.
Item(String) | Returns the ReportItemBase with the specified key in the collection.

Overload List

Overload | Description
Item(Int32) | Returns the ReportItemBase at the specified indexed location in the collection.
Item(String) | Returns the ReportItemBase with the specified key in the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


Item(Int32) Property

Item(Int32) Property
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class > Item Property : Item(Int32) Property

index
The index of the report item to retrieve from the report item collection.
Returns the ReportItemBase at the specified indexed location in the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Property Item( _
   ByVal index As Integer _
) As ReportItemBase
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim index As Integer
Dim value As ReportItemBase

instance.Item(index) = value

value = instance.Item(index)
C#
public ReportItemBase Item(
   int index
) {get; set;}

Parameters

index
The index of the report item to retrieve from the report item collection.

Return Value

The ReportItemBase located at the specified index location within the report item collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members
Overload List


Item(String) Property

Item(String) Property
[image]
Telerik.Reporting Namespace > ReportItemBase.ItemCollection Class > Item Property : Item(String) Property

key
The name of the report item to retrieve from the report item collection.
Returns the ReportItemBase with the specified key in the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal key As String _
) As ReportItemBase
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim key As String
Dim value As ReportItemBase

value = instance.Item(key)
C#
public ReportItemBase Item(
   string key
) {get;}

Parameters

key
The name of the report item to retrieve from the report item collection.

Return Value

The ReportItemBase with the specified key in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members
Overload List


ReportParameter Class

ReportParameter Class
See Also Members
[image]
Telerik.Reporting Namespace : ReportParameter Class

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportParameter
Visual Basic (Usage) Copy Code
Dim instance As ReportParameter
C#
public class ReportParameter

Inheritance Hierarchy

System.Object
Telerik.Reporting.ReportParameter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameter Members
Telerik.Reporting Namespace


ReportParameter Class Members

ReportParameter Class Members
See Also Properties
[image]
Telerik.Reporting Namespace : ReportParameter Class

The following tables list the members exposed by ReportParameter.

Public Constructors

 | Name | Description
Public Constructor | ReportParameter Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets a string that specifies the name of the parameter. Used to access the parameter.
Public Property | Type | Gets or sets the type of the parameter.
Public Property | UI | Gets or sets the UI settings that determine if and how parameter editor to be displayed in the viewer.
Public Property | Value | Gets or sets the value of the parameter. Can be an Expression that evaluates to an object, value of the allowed types, or IEnumerable containing values of the allowed types.
Top

See Also

Reference

ReportParameter Class
Telerik.Reporting Namespace


ReportParameter Constructor

ReportParameter Constructor
[image]
Telerik.Reporting Namespace > ReportParameter Class : ReportParameter Constructor

Overload List

Overload | Description
ReportParameter Constructor() |
ReportParameter Constructor(String,ReportParameterType,Object) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameter Class
ReportParameter Members


ReportParameter Constructor()

ReportParameter Constructor()
See Also
[image]
Telerik.Reporting Namespace > ReportParameter Class > ReportParameter Constructor : ReportParameter Constructor()

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportParameter()
C#
public ReportParameter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportParameter()
C#
public ReportParameter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameter Class
ReportParameter Members
Overload List


ReportParameter Constructor(String,ReportParameterType,Object)

ReportParameter Constructor(String,ReportParameterType,Object)
See Also
[image]
Telerik.Reporting Namespace > ReportParameter Class > ReportParameter Constructor : ReportParameter Constructor(String,ReportParameterType,Object)

name
type
value

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal type As ReportParameterType, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim type As ReportParameterType
Dim value As Object

Dim instance As ReportParameter(name, type, value)
C#
public ReportParameter(
   string name,
   ReportParameterType type,
   object value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal type As ReportParameterType, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim type As ReportParameterType
Dim value As Object

Dim instance As ReportParameter(name, type, value)
C#
public ReportParameter(
   string name,
   ReportParameterType type,
   object value
)

Parameters

name
type
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameter Class
ReportParameter Members
Overload List


ReportParameter Class Properties

ReportParameter Class Properties
[image]
Telerik.Reporting Namespace : ReportParameter Class

For a list of all members of this type, see ReportParameter members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets a string that specifies the name of the parameter. Used to access the parameter.
Public Property | Type | Gets or sets the type of the parameter.
Public Property | UI | Gets or sets the UI settings that determine if and how parameter editor to be displayed in the viewer.
Public Property | Value | Gets or sets the value of the parameter. Can be an Expression that evaluates to an object, value of the allowed types, or IEnumerable containing values of the allowed types.
Top

See Also

Reference

ReportParameter Class
Telerik.Reporting Namespace


Name Property

Name Property
[image]
Telerik.Reporting Namespace > ReportParameter Class : Name Property

Gets or sets a string that specifies the name of the parameter. Used to access the parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ReportParameter
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameter Class
ReportParameter Members


Type Property

Type Property
[image]
Telerik.Reporting Namespace > ReportParameter Class : Type Property

Gets or sets the type of the parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As ReportParameterType
Visual Basic (Usage) Copy Code
Dim instance As ReportParameter
Dim value As ReportParameterType

instance.Type = value

value = instance.Type
C#
public ReportParameterType Type {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameter Class
ReportParameter Members


UI Property

UI Property
[image]
Telerik.Reporting Namespace > ReportParameter Class : UI Property

Gets or sets the UI settings that determine if and how parameter editor to be displayed in the viewer.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UI As ReportParameterUISettings
Visual Basic (Usage) Copy Code
Dim instance As ReportParameter
Dim value As ReportParameterUISettings

value = instance.UI
C#
public ReportParameterUISettings UI {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameter Class
ReportParameter Members


Value Property

Value Property
[image]
Telerik.Reporting Namespace > ReportParameter Class : Value Property

Gets or sets the value of the parameter. Can be an Expression that evaluates to an object, value of the allowed types, or IEnumerable containing values of the allowed types.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As ReportParameter
Dim value As Object

instance.Value = value

value = instance.Value
C#
public object Value {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameter Class
ReportParameter Members


ReportParameterCollection Class

ReportParameterCollection Class
See Also Members
[image]
Telerik.Reporting Namespace : ReportParameterCollection Class

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportParameterCollection
   Inherits Collection(Of ReportParameter)
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterCollection
C#
public class ReportParameterCollection : Collection<ReportParameter>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<ReportParameter>
Telerik.Reporting.ReportParameterCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollection Members
Telerik.Reporting Namespace


ReportParameterCollection Class Members

ReportParameterCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting Namespace : ReportParameterCollection Class

The following tables list the members exposed by ReportParameterCollection.

Public Constructors

 | Name | Description
Public Constructor | ReportParameterCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Public Property | Item | Overloaded.
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange |
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Public Method | Contains | Overloaded.
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Public Method | IndexOf | Overloaded.
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Top

See Also

Reference

ReportParameterCollection Class
Telerik.Reporting Namespace


ReportParameterCollection Constructor

ReportParameterCollection Constructor
[image]
Telerik.Reporting Namespace > ReportParameterCollection Class : ReportParameterCollection Constructor

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterCollection()
C#
public ReportParameterCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterCollection()
C#
public ReportParameterCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


ReportParameterCollection Class Methods

ReportParameterCollection Class Methods
[image]
Telerik.Reporting Namespace : ReportParameterCollection Class

For a list of all members of this type, see ReportParameterCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange |
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Public Method | Contains | Overloaded.
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Public Method | IndexOf | Overloaded.
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Top

See Also

Reference

ReportParameterCollection Class
Telerik.Reporting Namespace


Add Method

Add Method
[image]
Telerik.Reporting Namespace > ReportParameterCollection Class : Add Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Add(String,ReportParameterType,String) |
Add(ReportParameter) | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)

Overload List

Overload | Description
Add(String,ReportParameterType,String) |
Add(ReportParameter) | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


Add(String,ReportParameterType,String) Method

Add(String,ReportParameterType,String) Method
[image]
Telerik.Reporting Namespace > ReportParameterCollection Class > Add Method : Add(String,ReportParameterType,String) Method

name
parameterType
value

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal name As String, _
   ByVal parameterType As ReportParameterType, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterCollection
Dim name As String
Dim parameterType As ReportParameterType
Dim value As String

instance.Add(name, parameterType, value)
C#
public void Add(
   string name,
   ReportParameterType parameterType,
   string value
)

Parameters

name
parameterType
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members
Overload List


AddRange Method

AddRange Method
[image]
Telerik.Reporting Namespace > ReportParameterCollection Class : AddRange Method

collection

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of ReportParameter) _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterCollection
Dim collection As IEnumerable(Of ReportParameter)

instance.AddRange(collection)
C#
public void AddRange(
   IEnumerable<ReportParameter> collection
)

Parameters

collection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


Contains Method

Contains Method
[image]
Telerik.Reporting Namespace > ReportParameterCollection Class : Contains Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Contains(String) |
Contains(ReportParameter) | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)

Overload List

Overload | Description
Contains(String) |
Contains(ReportParameter) | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


Contains(String) Method

Contains(String) Method
[image]
Telerik.Reporting Namespace > ReportParameterCollection Class > Contains Method : Contains(String) Method

name

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Contains( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterCollection
Dim name As String
Dim value As Boolean

value = instance.Contains(name)
C#
public bool Contains(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members
Overload List


IndexOf Method

IndexOf Method
[image]
Telerik.Reporting Namespace > ReportParameterCollection Class : IndexOf Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
IndexOf(String) |
IndexOf(ReportParameter) | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)

Overload List

Overload | Description
IndexOf(String) |
IndexOf(ReportParameter) | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


IndexOf(String) Method

IndexOf(String) Method
[image]
Telerik.Reporting Namespace > ReportParameterCollection Class > IndexOf Method : IndexOf(String) Method

name

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members
Overload List


ReportParameterCollection Class Properties

ReportParameterCollection Class Properties
[image]
Telerik.Reporting Namespace : ReportParameterCollection Class

For a list of all members of this type, see ReportParameterCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Public Property | Item | Overloaded.
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)
Top

See Also

Reference

ReportParameterCollection Class
Telerik.Reporting Namespace


Item Property

Item Property
[image]
Telerik.Reporting Namespace > ReportParameterCollection Class : Item Property

Overload List

Overload | Description
Item(String) |
Item(Int32) | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)

Overload List

Overload | Description
Item(String) |
Item(Int32) | (Inherited from System.Collections.ObjectModel.Collection<ReportParameter>)

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


Item(String) Property

Item(String) Property
[image]
Telerik.Reporting Namespace > ReportParameterCollection Class > Item Property : Item(String) Property

name

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As ReportParameter
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterCollection
Dim name As String
Dim value As ReportParameter

value = instance.Item(name)
C#
public ReportParameter Item(
   string name
) {get;}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members
Overload List


ReportParameterCollectionConverter Class

ReportParameterCollectionConverter Class
See Also Members
[image]
Telerik.Reporting Namespace : ReportParameterCollectionConverter Class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Class ReportParameterCollectionConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterCollectionConverter
C#
private class ReportParameterCollectionConverter : TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Reporting.ReportParameterCollectionConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollectionConverter Members
Telerik.Reporting Namespace


ReportParameterCollectionConverter Class Members

ReportParameterCollectionConverter Class Members
See Also Methods
[image]
Telerik.Reporting Namespace : ReportParameterCollectionConverter Class

The following tables list the members exposed by ReportParameterCollectionConverter.

Public Constructors

 | Name | Description
Public Constructor | ReportParameterCollectionConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ReportParameterCollectionConverter Class
Telerik.Reporting Namespace


ReportParameterCollectionConverter Constructor

ReportParameterCollectionConverter Constructor
[image]
Telerik.Reporting Namespace > ReportParameterCollectionConverter Class : ReportParameterCollectionConverter Constructor

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterCollectionConverter()
C#
public ReportParameterCollectionConverter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterCollectionConverter()
C#
public ReportParameterCollectionConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollectionConverter Class
ReportParameterCollectionConverter Members


ReportParameterCollectionConverter Class Methods

ReportParameterCollectionConverter Class Methods
[image]
Telerik.Reporting Namespace : ReportParameterCollectionConverter Class

For a list of all members of this type, see ReportParameterCollectionConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ReportParameterCollectionConverter Class
Telerik.Reporting Namespace


ConvertTo Method

ConvertTo Method
[image]
Telerik.Reporting Namespace > ReportParameterCollectionConverter Class : ConvertTo Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollectionConverter Class
ReportParameterCollectionConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also
[image]
Telerik.Reporting Namespace > ReportParameterCollectionConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterCollectionConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
culture
value
destinationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterCollectionConverter Class
ReportParameterCollectionConverter Members
Overload List


ReportParameterDataSource.Group Class

ReportParameterDataSource.Group Class
See Also Members
[image]
Telerik.Reporting Namespace : ReportParameterDataSource.Group Class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Class ReportParameterDataSource.Group
   Implements IGroup
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterDataSource.Group
C#
private class ReportParameterDataSource.Group : IGroup

Inheritance Hierarchy

System.Object
Telerik.Reporting.ReportParameterDataSource.Group

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterDataSource.Group Members
Telerik.Reporting Namespace


ReportParameterDataSource.Group Class Members

ReportParameterDataSource.Group Class Members
See Also Properties
[image]
Telerik.Reporting Namespace : ReportParameterDataSource.Group Class

The following tables list the members exposed by ReportParameterDataSource.Group.

Public Constructors

 | Name | Description
Public Constructor | ReportParameterDataSource.Group Constructor |
Top

Public Properties

 | Name | Description
Public Property | Filters |
Public Property | Grouping |
Public Property | Ranks |
Public Property | Sorting |
Top

See Also

Reference

ReportParameterDataSource.Group Class
Telerik.Reporting Namespace


ReportParameterDataSource.Group Constructor

ReportParameterDataSource.Group Constructor
[image]
Telerik.Reporting Namespace > ReportParameterDataSource.Group Class : ReportParameterDataSource.Group Constructor

owner

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As ReportParameterDataSource _
)
Visual Basic (Usage) Copy Code
Dim owner As ReportParameterDataSource

Dim instance As ReportParameterDataSource.Group(owner)
C#
public ReportParameterDataSource.Group(
   ReportParameterDataSource owner
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As ReportParameterDataSource _
)
Visual Basic (Usage) Copy Code
Dim owner As ReportParameterDataSource

Dim instance As ReportParameterDataSource.Group(owner)
C#
public ReportParameterDataSource.Group(
   ReportParameterDataSource owner
)

Parameters

owner

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterDataSource.Group Class
ReportParameterDataSource.Group Members


ReportParameterDataSource.Group Class Properties

ReportParameterDataSource.Group Class Properties
[image]
Telerik.Reporting Namespace : ReportParameterDataSource.Group Class

For a list of all members of this type, see ReportParameterDataSource.Group members.

Public Properties

 | Name | Description
Public Property | Filters |
Public Property | Grouping |
Public Property | Ranks |
Public Property | Sorting |
Top

See Also

Reference

ReportParameterDataSource.Group Class
Telerik.Reporting Namespace


Filters Property

Filters Property
[image]
Telerik.Reporting Namespace > ReportParameterDataSource.Group Class : Filters Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filters As IEnumerable(Of Filter)
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterDataSource.Group
Dim value As IEnumerable(Of Filter)

value = instance.Filters
C#
public IEnumerable<Filter> Filters {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterDataSource.Group Class
ReportParameterDataSource.Group Members


Grouping Property

Grouping Property
[image]
Telerik.Reporting Namespace > ReportParameterDataSource.Group Class : Grouping Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Grouping As IEnumerable(Of Grouping)
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterDataSource.Group
Dim value As IEnumerable(Of Grouping)

value = instance.Grouping
C#
public IEnumerable<Grouping> Grouping {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterDataSource.Group Class
ReportParameterDataSource.Group Members


Ranks Property

Ranks Property
[image]
Telerik.Reporting Namespace > ReportParameterDataSource.Group Class : Ranks Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Ranks As IEnumerable(Of Filter)
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterDataSource.Group
Dim value As IEnumerable(Of Filter)

value = instance.Ranks
C#
public IEnumerable<Filter> Ranks {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterDataSource.Group Class
ReportParameterDataSource.Group Members


Sorting Property

Sorting Property
[image]
Telerik.Reporting Namespace > ReportParameterDataSource.Group Class : Sorting Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sorting As IEnumerable(Of Sorting)
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterDataSource.Group
Dim value As IEnumerable(Of Sorting)

value = instance.Sorting
C#
public IEnumerable<Sorting> Sorting {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterDataSource.Group Class
ReportParameterDataSource.Group Members


ReportParameterUISettings Class

ReportParameterUISettings Class
See Also Members
[image]
Telerik.Reporting Namespace : ReportParameterUISettings Class

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportParameterUISettings
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings
C#
public class ReportParameterUISettings

Inheritance Hierarchy

System.Object
Telerik.Reporting.ReportParameterUISettings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings Members
Telerik.Reporting Namespace


ReportParameterUISettings Class Members

ReportParameterUISettings Class Members
See Also Properties Methods
[image]
Telerik.Reporting Namespace : ReportParameterUISettings Class

The following tables list the members exposed by ReportParameterUISettings.

Public Constructors

 | Name | Description
Public Constructor | ReportParameterUISettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowBlank | Determmines if the parameter allows an empty string to be passed. Only for parameters of type string.
Public Property | AllowNull | Determines if the parameter allows no value to be passed from it's editor.
Public Property | AvailableValues | Gets an object that defines a set of values the parameter can accept from.
Public Property | MultiValue | Determines if the parameter can hold more then one value.
Public Property | Text | Gets or sets the text for the parameter to be displayed in the report viewer.
Public Property | Visible | Determines whether the parameter user interface is visible.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

ReportParameterUISettings Class
Telerik.Reporting Namespace


ReportParameterUISettings Constructor

ReportParameterUISettings Constructor
[image]
Telerik.Reporting Namespace > ReportParameterUISettings Class : ReportParameterUISettings Constructor

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings()
C#
public ReportParameterUISettings()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings()
C#
public ReportParameterUISettings()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings Class
ReportParameterUISettings Members


ReportParameterUISettings Class Methods

ReportParameterUISettings Class Methods
[image]
Telerik.Reporting Namespace : ReportParameterUISettings Class

For a list of all members of this type, see ReportParameterUISettings members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

ReportParameterUISettings Class
Telerik.Reporting Namespace


ToString Method

ToString Method
[image]
Telerik.Reporting Namespace > ReportParameterUISettings Class : ToString Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings Class
ReportParameterUISettings Members


ReportParameterUISettings Class Properties

ReportParameterUISettings Class Properties
[image]
Telerik.Reporting Namespace : ReportParameterUISettings Class

For a list of all members of this type, see ReportParameterUISettings members.

Public Properties

 | Name | Description
Public Property | AllowBlank | Determmines if the parameter allows an empty string to be passed. Only for parameters of type string.
Public Property | AllowNull | Determines if the parameter allows no value to be passed from it's editor.
Public Property | AvailableValues | Gets an object that defines a set of values the parameter can accept from.
Public Property | MultiValue | Determines if the parameter can hold more then one value.
Public Property | Text | Gets or sets the text for the parameter to be displayed in the report viewer.
Public Property | Visible | Determines whether the parameter user interface is visible.
Top

See Also

Reference

ReportParameterUISettings Class
Telerik.Reporting Namespace


AllowBlank Property

AllowBlank Property
[image]
Telerik.Reporting Namespace > ReportParameterUISettings Class : AllowBlank Property

Determmines if the parameter allows an empty string to be passed. Only for parameters of type string.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowBlank As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings
Dim value As Boolean

instance.AllowBlank = value

value = instance.AllowBlank
C#
public bool AllowBlank {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings Class
ReportParameterUISettings Members


AllowNull Property

AllowNull Property
[image]
Telerik.Reporting Namespace > ReportParameterUISettings Class : AllowNull Property

Determines if the parameter allows no value to be passed from it's editor.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowNull As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings
Dim value As Boolean

instance.AllowNull = value

value = instance.AllowNull
C#
public bool AllowNull {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings Class
ReportParameterUISettings Members


AvailableValues Property

AvailableValues Property
[image]
Telerik.Reporting Namespace > ReportParameterUISettings Class : AvailableValues Property

Gets an object that defines a set of values the parameter can accept from.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AvailableValues As ReportParameterUISettings.IAvailableValues
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings
Dim value As ReportParameterUISettings.IAvailableValues

value = instance.AvailableValues
C#
public ReportParameterUISettings.IAvailableValues AvailableValues {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings Class
ReportParameterUISettings Members


MultiValue Property

MultiValue Property
[image]
Telerik.Reporting Namespace > ReportParameterUISettings Class : MultiValue Property

Determines if the parameter can hold more then one value.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property MultiValue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings
Dim value As Boolean

instance.MultiValue = value

value = instance.MultiValue
C#
public bool MultiValue {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings Class
ReportParameterUISettings Members


Text Property

Text Property
[image]
Telerik.Reporting Namespace > ReportParameterUISettings Class : Text Property

Gets or sets the text for the parameter to be displayed in the report viewer.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings Class
ReportParameterUISettings Members


Visible Property

Visible Property
[image]
Telerik.Reporting Namespace > ReportParameterUISettings Class : Visible Property

Determines whether the parameter user interface is visible.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings Class
ReportParameterUISettings Members


ReportSection Class

ReportSection Class
See Also Members
[image]
Telerik.Reporting Namespace : ReportSection Class

Base abstract class for all report sections contained in the report body. Inherited by DetailSection, GroupSection, ReportHeaderSection, ReportFooterSection,

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ReportSection
   Inherits ReportSectionBase
   Implements ILayoutArranger, ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
C#
public abstract class ReportSection : ReportSectionBase, ILayoutArranger, ILayoutContainer

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportSectionBase
Telerik.Reporting.ReportSection
Telerik.Reporting.DetailSection
Telerik.Reporting.GroupSection
Telerik.Reporting.ReportFooterSection
Telerik.Reporting.ReportHeaderSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Members
Telerik.Reporting Namespace


ReportSection Class Members

ReportSection Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : ReportSection Class

The following tables list the members exposed by ReportSection.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible.
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection.
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

ReportSection Class
Telerik.Reporting Namespace


ReportSection Class Properties

ReportSection Class Properties
[image]
Telerik.Reporting Namespace : ReportSection Class

For a list of all members of this type, see ReportSection members.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible.
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection.
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ReportSection Class
Telerik.Reporting Namespace


KeepTogether Property

KeepTogether Property
[image]
Telerik.Reporting Namespace > ReportSection Class : KeepTogether Property

Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property KeepTogether As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As Boolean

instance.KeepTogether = value

value = instance.KeepTogether
C#
public bool KeepTogether {get; set;}

Return Value

A boolean value indicating whether the rendering engine should try to keep the ReportSection on one page if possible.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


PageBreak Property

PageBreak Property
[image]
Telerik.Reporting Namespace > ReportSection Class : PageBreak Property

Gets or sets the page braking rule for this ReportSection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As PageBreak

instance.PageBreak = value

value = instance.PageBreak
C#
public PageBreak PageBreak {get; set;}

Return Value

A PageBreak object specifying the page braking rule for this ReportSection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ReportSectionBase Class

ReportSectionBase Class
See Also Members
[image]
Telerik.Reporting Namespace : ReportSectionBase Class

Defines the base class for report sections.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ReportSectionBase
   Inherits ReportItemBase
   Implements ILayoutArranger, ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As ReportSectionBase
C#
public abstract class ReportSectionBase : ReportItemBase, ILayoutArranger, ILayoutContainer

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportSectionBase
Telerik.Reporting.PageSection
Telerik.Reporting.ReportSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSectionBase Members
Telerik.Reporting Namespace


ReportSectionBase Class Members

ReportSectionBase Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : ReportSectionBase Class

The following tables list the members exposed by ReportSectionBase.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section.
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Overridden.
Protected Method | OnItemRemoved | Overridden.
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

ReportSectionBase Class
Telerik.Reporting Namespace


ReportSectionBase Class Methods

ReportSectionBase Class Methods
[image]
Telerik.Reporting Namespace : ReportSectionBase Class

For a list of all members of this type, see ReportSectionBase members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Overridden.
Protected Method | OnItemRemoved | Overridden.
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

ReportSectionBase Class
Telerik.Reporting Namespace


OnItemAdded Method

OnItemAdded Method
[image]
Telerik.Reporting Namespace > ReportSectionBase Class : OnItemAdded Method

item

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnItemAdded( _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportSectionBase
Dim item As ReportItemBase

instance.OnItemAdded(item)
C#
protected override void OnItemAdded(
   ReportItemBase item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


OnItemRemoved Method

OnItemRemoved Method
[image]
Telerik.Reporting Namespace > ReportSectionBase Class : OnItemRemoved Method

item

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnItemRemoved( _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportSectionBase
Dim item As ReportItemBase

instance.OnItemRemoved(item)
C#
protected override void OnItemRemoved(
   ReportItemBase item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


ReportSectionBase Class Properties

ReportSectionBase Class Properties
[image]
Telerik.Reporting Namespace : ReportSectionBase Class

For a list of all members of this type, see ReportSectionBase members.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section.
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ReportSectionBase Class
Telerik.Reporting Namespace


Height Property

Height Property
[image]
Telerik.Reporting Namespace > ReportSectionBase Class : Height Property

Gets or sets the height of the current section.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportSectionBase
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public Unit Height {get; set;}

Return Value

The height of the current section in Units.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


ResourceHelper Class

ResourceHelper Class
See Also Members
[image]
Telerik.Reporting Namespace : ResourceHelper Class

A class for common resource needs.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private MustInherit NotInheritable Class ResourceHelper
Visual Basic (Usage) Copy Code
Dim instance As ResourceHelper
C#
private static class ResourceHelper

Inheritance Hierarchy

System.Object
Telerik.Reporting.ResourceHelper

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ResourceHelper Members
Telerik.Reporting Namespace


ResourceHelper Class Members

ResourceHelper Class Members
See Also Methods
[image]
Telerik.Reporting Namespace : ResourceHelper Class

The following tables list the members exposed by ResourceHelper.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CalculateLocationKind |
static (Shared in Visual Basic) | CalculateRelativePath |
static (Shared in Visual Basic) | IsInside |
Top

See Also

Reference

ResourceHelper Class
Telerik.Reporting Namespace


ResourceHelper Class Methods

ResourceHelper Class Methods
[image]
Telerik.Reporting Namespace : ResourceHelper Class

For a list of all members of this type, see ResourceHelper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CalculateLocationKind |
static (Shared in Visual Basic) | CalculateRelativePath |
static (Shared in Visual Basic) | IsInside |
Top

See Also

Reference

ResourceHelper Class
Telerik.Reporting Namespace


CalculateLocationKind Method

CalculateLocationKind Method
[image]
Telerik.Reporting Namespace > ResourceHelper Class : CalculateLocationKind Method

path

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CalculateLocationKind( _
   ByVal path As String _
) As ResourceKind
Visual Basic (Usage) Copy Code
Dim path As String
Dim value As ResourceKind

value = ResourceHelper.CalculateLocationKind(path)
C#
public static ResourceKind CalculateLocationKind(
   string path
)

Parameters

path

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ResourceHelper Class
ResourceHelper Members


CalculateRelativePath Method

CalculateRelativePath Method
[image]
Telerik.Reporting Namespace > ResourceHelper Class : CalculateRelativePath Method

path
basePath

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CalculateRelativePath( _
   ByVal path As String, _
   ByVal basePath As String _
) As String
Visual Basic (Usage) Copy Code
Dim path As String
Dim basePath As String
Dim value As String

value = ResourceHelper.CalculateRelativePath(path, basePath)
C#
public static string CalculateRelativePath(
   string path,
   string basePath
)

Parameters

path
basePath

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ResourceHelper Class
ResourceHelper Members


IsInside Method

IsInside Method
[image]
Telerik.Reporting Namespace > ResourceHelper Class : IsInside Method

path
basePath

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsInside( _
   ByVal path As String, _
   ByVal basePath As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim path As String
Dim basePath As String
Dim value As Boolean

value = ResourceHelper.IsInside(path, basePath)
C#
public static bool IsInside(
   string path,
   string basePath
)

Parameters

path
basePath

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ResourceHelper Class
ResourceHelper Members


ResourceResolutionService Class

ResourceResolutionService Class
See Also Members
[image]
Telerik.Reporting Namespace : ResourceResolutionService Class

Default resource resolution service used at run-time.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Class ResourceResolutionService
   Implements IResourceResolutionService
Visual Basic (Usage) Copy Code
Dim instance As ResourceResolutionService
C#
private class ResourceResolutionService : IResourceResolutionService

Inheritance Hierarchy

System.Object
Telerik.Reporting.ResourceResolutionService

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ResourceResolutionService Members
Telerik.Reporting Namespace


ResourceResolutionService Class Members

ResourceResolutionService Class Members
[image]
Telerik.Reporting Namespace : ResourceResolutionService Class

The following tables list the members exposed by ResourceResolutionService.

Public Constructors

 | Name | Description
Public Constructor | ResourceResolutionService Constructor |
Top

See Also

Reference

ResourceResolutionService Class
Telerik.Reporting Namespace


ResourceResolutionService Constructor

ResourceResolutionService Constructor
[image]
Telerik.Reporting Namespace > ResourceResolutionService Class : ResourceResolutionService Constructor

resourceAssembly

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceAssembly As Assembly _
)
Visual Basic (Usage) Copy Code
Dim resourceAssembly As Assembly

Dim instance As ResourceResolutionService(resourceAssembly)
C#
public ResourceResolutionService(
   Assembly resourceAssembly
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceAssembly As Assembly _
)
Visual Basic (Usage) Copy Code
Dim resourceAssembly As Assembly

Dim instance As ResourceResolutionService(resourceAssembly)
C#
public ResourceResolutionService(
   Assembly resourceAssembly
)

Parameters

resourceAssembly

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ResourceResolutionService Class
ResourceResolutionService Members


Shape Class

Shape Class
See Also Members
[image]
Telerik.Reporting Namespace : Shape Class

Represents a shape report item.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Shape
   Inherits ReportItem
   Implements IArrangedItem, ILayoutItem, ISupportsRotation
Visual Basic (Usage) Copy Code
Dim instance As Shape
C#
public class Shape : ReportItem, IArrangedItem, ILayoutItem, ISupportsRotation

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportItem
Telerik.Reporting.Shape

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Members
Telerik.Reporting Namespace


Shape Class Members

Shape Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : Shape Class

The following tables list the members exposed by Shape.

Public Constructors

 | Name | Description
Public Constructor | Shape Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Angle | Gets or sets the angle of rotation of the shape in degrees.
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | ShapeType | Gets or sets the type of the shape displayed in the item.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Stretch | Gets or sets a value indicating whether to stretch the shape in the item or not.
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Overridden.
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

Shape Class
Telerik.Reporting Namespace


Shape Constructor

Shape Constructor
[image]
Telerik.Reporting Namespace > Shape Class : Shape Constructor

Overload List

Overload | Description
Shape Constructor() |
Shape Constructor(SerializationInfo,StreamingContext) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Shape Constructor()

Shape Constructor()
See Also
[image]
Telerik.Reporting Namespace > Shape Class > Shape Constructor : Shape Constructor()

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Shape()
C#
public Shape()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Shape()
C#
public Shape()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members
Overload List


Shape Constructor(SerializationInfo,StreamingContext)

Shape Constructor(SerializationInfo,StreamingContext)
See Also
[image]
Telerik.Reporting Namespace > Shape Class > Shape Constructor : Shape Constructor(SerializationInfo,StreamingContext)

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As Shape(info, context)
C#
protected Shape(
   SerializationInfo info,
   StreamingContext context
)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As Shape(info, context)
C#
protected Shape(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members
Overload List


Shape Class Properties

Shape Class Properties
[image]
Telerik.Reporting Namespace : Shape Class

For a list of all members of this type, see Shape members.

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Angle | Gets or sets the angle of rotation of the shape in degrees.
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | ShapeType | Gets or sets the type of the shape displayed in the item.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Stretch | Gets or sets a value indicating whether to stretch the shape in the item or not.
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Overridden.
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Shape Class
Telerik.Reporting Namespace


Angle Property

Angle Property
[image]
Telerik.Reporting Namespace > Shape Class : Angle Property

Gets or sets the angle of rotation of the shape in degrees.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Angle As Double
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As Double

instance.Angle = value

value = instance.Angle
C#
public double Angle {get; set;}

Return Value

A double value indicating the angle of rotation in degrees.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


DefaultSize Property

DefaultSize Property
[image]
Telerik.Reporting Namespace > Shape Class : DefaultSize Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property DefaultSize As SizeU
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As SizeU

value = instance.DefaultSize
C#
protected override SizeU DefaultSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


ShapeType Property

ShapeType Property
[image]
Telerik.Reporting Namespace > Shape Class : ShapeType Property

Gets or sets the type of the shape displayed in the item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ShapeType As ShapeBase
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As ShapeBase

instance.ShapeType = value

value = instance.ShapeType
C#
public ShapeBase ShapeType {get; set;}

Return Value

A ShapeBase object representing the type of the shape displayed in the item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Stretch Property

Stretch Property
[image]
Telerik.Reporting Namespace > Shape Class : Stretch Property

Gets or sets a value indicating whether to stretch the shape in the item or not.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Stretch As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As Boolean

instance.Stretch = value

value = instance.Stretch
C#
public bool Stretch {get; set;}

Return Value

true if the shape should be stretched; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


SubReport Class

SubReport Class
See Also Members
[image]
Telerik.Reporting Namespace : SubReport Class

Represents a report item used to embed another report into the current report.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class SubReport
   Inherits ReportItem
   Implements IArrangedItem, ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As SubReport
C#
public class SubReport : ReportItem, IArrangedItem, ILayoutItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportItem
Telerik.Reporting.SubReport

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Members
Telerik.Reporting Namespace


SubReport Class Members

SubReport Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : SubReport Class

The following tables list the members exposed by SubReport.

Public Constructors

 | Name | Description
Public Constructor | SubReport Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parameters |
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | ReportSource |
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Gets the default size of the report item. (Inherited from ReportItem)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | Overridden.
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | NeedDataSource | Occurs at the start of report processing if the inner report has no data source set.
Top

See Also

Reference

SubReport Class
Telerik.Reporting Namespace


SubReport Constructor

SubReport Constructor
[image]
Telerik.Reporting Namespace > SubReport Class : SubReport Constructor

Overload List

Overload | Description
SubReport Constructor() |
SubReport Constructor(SerializationInfo,StreamingContext) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


SubReport Constructor()

SubReport Constructor()
See Also
[image]
Telerik.Reporting Namespace > SubReport Class > SubReport Constructor : SubReport Constructor()

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SubReport()
C#
public SubReport()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SubReport()
C#
public SubReport()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members
Overload List


SubReport Constructor(SerializationInfo,StreamingContext)

SubReport Constructor(SerializationInfo,StreamingContext)
See Also
[image]
Telerik.Reporting Namespace > SubReport Class > SubReport Constructor : SubReport Constructor(SerializationInfo,StreamingContext)

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As SubReport(info, context)
C#
protected SubReport(
   SerializationInfo info,
   StreamingContext context
)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As SubReport(info, context)
C#
protected SubReport(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members
Overload List


SubReport Class Methods

SubReport Class Methods
[image]
Telerik.Reporting Namespace : SubReport Class

For a list of all members of this type, see SubReport members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | Overridden.
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

SubReport Class
Telerik.Reporting Namespace


GetObjectDataInternal Method

GetObjectDataInternal Method
[image]
Telerik.Reporting Namespace > SubReport Class : GetObjectDataInternal Method

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub GetObjectDataInternal( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectDataInternal(info, context)
C#
protected override void GetObjectDataInternal(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


SubReport Class Properties

SubReport Class Properties
[image]
Telerik.Reporting Namespace : SubReport Class

For a list of all members of this type, see SubReport members.

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parameters |
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | ReportSource |
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Gets the default size of the report item. (Inherited from ReportItem)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

SubReport Class
Telerik.Reporting Namespace


Parameters Property

Parameters Property
[image]
Telerik.Reporting Namespace > SubReport Class : Parameters Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As ParameterCollection

value = instance.Parameters
C#
public ParameterCollection Parameters {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


ReportSource Property

ReportSource Property
[image]
Telerik.Reporting Namespace > SubReport Class : ReportSource Property

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportSource As Report
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As Report

instance.ReportSource = value

value = instance.ReportSource
C#
public Report ReportSource {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


SubReport Class Events

SubReport Class Events
[image]
Telerik.Reporting Namespace : SubReport Class

For a list of all members of this type, see SubReport members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | NeedDataSource | Occurs at the start of report processing if the inner report has no data source set.
Top

See Also

Reference

SubReport Class
Telerik.Reporting Namespace


NeedDataSource Event

NeedDataSource Event
[image]
Telerik.Reporting Namespace > SubReport Class : NeedDataSource Event

Occurs at the start of report processing if the inner report has no data source set.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event NeedDataSource() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim handler As EventHandler

AddHandler instance.NeedDataSource, handler
C#
public event EventHandler NeedDataSource()

Syntax

Visual Basic (Declaration)
Public Event NeedDataSource() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim handler As EventHandler

AddHandler instance.NeedDataSource, handler
C#
public event EventHandler NeedDataSource()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


TextBox Class

TextBox Class
See Also Members
[image]
Telerik.Reporting Namespace : TextBox Class

Represents a text box report item.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBox
   Inherits TextItemBase
   Implements IArrangedItem, ILayoutItem, ISupportsRotation
Visual Basic (Usage) Copy Code
Dim instance As TextBox
C#
public class TextBox : TextItemBase, IArrangedItem, ILayoutItem, ISupportsRotation

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportItem
Telerik.Reporting.TextItemBase
Telerik.Reporting.TextBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Members
Telerik.Reporting Namespace


TextBox Class Members

TextBox Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : TextBox Class

The following tables list the members exposed by TextBox.

Public Constructors

 | Name | Description
Public Constructor | TextBox Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Angle | Gets or sets the angle of rotation of the text in degrees. (Inherited from TextItemBase)
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically. (Inherited from TextItemBase)
Public Property | CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically. (Inherited from TextItemBase)
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Culture | Gets or sets the culture information associated with the Text Item. (Inherited from TextItemBase)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Multiline | Gets or sets a value indicating whether this is a multiline Text Item. (Inherited from TextItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | TextWrap | Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary. (Inherited from TextItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Value | Gets or sets the current text in the text box.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Gets the default size of the report item. (Inherited from ReportItem)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

TextBox Class
Telerik.Reporting Namespace


TextBox Constructor

TextBox Constructor
[image]
Telerik.Reporting Namespace > TextBox Class : TextBox Constructor

Overload List

Overload | Description
TextBox Constructor() |
TextBox Constructor(SerializationInfo,StreamingContext) |

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


TextBox Constructor()

TextBox Constructor()
See Also
[image]
Telerik.Reporting Namespace > TextBox Class > TextBox Constructor : TextBox Constructor()

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBox()
C#
public TextBox()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBox()
C#
public TextBox()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members
Overload List


TextBox Constructor(SerializationInfo,StreamingContext)

TextBox Constructor(SerializationInfo,StreamingContext)
See Also
[image]
Telerik.Reporting Namespace > TextBox Class > TextBox Constructor : TextBox Constructor(SerializationInfo,StreamingContext)

info
context

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As TextBox(info, context)
C#
protected TextBox(
   SerializationInfo info,
   StreamingContext context
)

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As TextBox(info, context)
C#
protected TextBox(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members
Overload List


TextBox Class Properties

TextBox Class Properties
[image]
Telerik.Reporting Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Angle | Gets or sets the angle of rotation of the text in degrees. (Inherited from TextItemBase)
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically. (Inherited from TextItemBase)
Public Property | CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically. (Inherited from TextItemBase)
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Culture | Gets or sets the culture information associated with the Text Item. (Inherited from TextItemBase)
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Multiline | Gets or sets a value indicating whether this is a multiline Text Item. (Inherited from TextItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | TextWrap | Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary. (Inherited from TextItemBase)
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Value | Gets or sets the current text in the text box.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Gets the default size of the report item. (Inherited from ReportItem)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TextBox Class
Telerik.Reporting Namespace


Value Property

Value Property
[image]
Telerik.Reporting Namespace > TextBox Class : Value Property

Gets or sets the current text in the text box.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}

Return Value

A String that starts with "=" is interpreted as expression to calculate the value of the current TextBox; otherwise - literal string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


TextItemBase Class

TextItemBase Class
See Also Members
[image]
Telerik.Reporting Namespace : TextItemBase Class

Represents a Text Item - a base class for report items like TextBox and CheckBox.

Object Model

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class TextItemBase
   Inherits ReportItem
   Implements IArrangedItem, ILayoutItem, ISupportsRotation
Visual Basic (Usage) Copy Code
Dim instance As TextItemBase
C#
public abstract class TextItemBase : ReportItem, IArrangedItem, ILayoutItem, ISupportsRotation

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.ReportItemBase
Telerik.Reporting.ReportItem
Telerik.Reporting.TextItemBase
Telerik.Reporting.CheckBox
Telerik.Reporting.TextBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextItemBase Members
Telerik.Reporting Namespace


TextItemBase Class Members

TextItemBase Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting Namespace : TextItemBase Class

The following tables list the members exposed by TextItemBase.

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Angle | Gets or sets the angle of rotation of the text in degrees.
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically.
Public Property | CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically.
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Culture | Gets or sets the culture information associated with the Text Item.
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | Format | Gets or sets the character(s) that specify how text is formatted.
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Multiline | Gets or sets a value indicating whether this is a multiline Text Item.
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | TextWrap | Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary.
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Gets the default size of the report item. (Inherited from ReportItem)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

TextItemBase Class
Telerik.Reporting Namespace


TextItemBase Class Properties

TextItemBase Class Properties
[image]
Telerik.Reporting Namespace : TextItemBase Class

For a list of all members of this type, see TextItemBase members.

Public Properties

 | Name | Description
Public Property | Anchor | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem)
Public Property | Angle | Gets or sets the angle of rotation of the text in degrees.
Public Property | Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem)
Public Property | CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically.
Public Property | CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically.
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Culture | Gets or sets the culture information associated with the Text Item.
Public Property | Dock | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem)
Public Property | Format | Gets or sets the character(s) that specify how text is formatted.
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the report item. (Inherited from ReportItem)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem)
Public Property | Multiline | Gets or sets a value indicating whether this is a multiline Text Item.
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size | Gets or sets the height and width of the report item. (Inherited from ReportItem)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | TextWrap | Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary.
Public Property | Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Public Property | Width | Gets or sets the width of the report item. (Inherited from ReportItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DefaultSize | Gets the default size of the report item. (Inherited from ReportItem)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TextItemBase Class
Telerik.Reporting Namespace


Angle Property

Angle Property
[image]
Telerik.Reporting Namespace > TextItemBase Class : Angle Property

Gets or sets the angle of rotation of the text in degrees.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Angle As Double
Visual Basic (Usage) Copy Code
Dim instance As TextItemBase
Dim value As Double

instance.Angle = value

value = instance.Angle
C#
public double Angle {get; set;}

Return Value

A double value indicating the angle of rotation in degrees.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextItemBase Class
TextItemBase Members


CanGrow Property

CanGrow Property
[image]
Telerik.Reporting Namespace > TextItemBase Class : CanGrow Property

Gets or sets a value indicating whether the Text Item can grow vertically.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property CanGrow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextItemBase
Dim value As Boolean

instance.CanGrow = value

value = instance.CanGrow
C#
public bool CanGrow {get; set;}

Return Value

true if the Text Item can grow vertically; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextItemBase Class
TextItemBase Members


CanShrink Property

CanShrink Property
[image]
Telerik.Reporting Namespace > TextItemBase Class : CanShrink Property

Gets or sets a value indicating whether the Text Item can shrink vertically.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property CanShrink As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextItemBase
Dim value As Boolean

instance.CanShrink = value

value = instance.CanShrink
C#
public bool CanShrink {get; set;}

Return Value

true if the Text Item can shrink vertically; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextItemBase Class
TextItemBase Members


Culture Property

Culture Property
[image]
Telerik.Reporting Namespace > TextItemBase Class : Culture Property

Gets or sets the culture information associated with the Text Item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Culture As CultureInfo
Visual Basic (Usage) Copy Code
Dim instance As TextItemBase
Dim value As CultureInfo

instance.Culture = value

value = instance.Culture
C#
public CultureInfo Culture {get; set;}

Return Value

A CultureInfo representing the culture supported by the TextItemBase.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextItemBase Class
TextItemBase Members


Format Property

Format Property
[image]
Telerik.Reporting Namespace > TextItemBase Class : Format Property

Gets or sets the character(s) that specify how text is formatted.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As String
Visual Basic (Usage) Copy Code
Dim instance As TextItemBase
Dim value As String

instance.Format = value

value = instance.Format
C#
public string Format {get; set;}

Return Value

The character or characters that specify how text is formatted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextItemBase Class
TextItemBase Members


Multiline Property

Multiline Property
[image]
Telerik.Reporting Namespace > TextItemBase Class : Multiline Property

Gets or sets a value indicating whether this is a multiline Text Item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Multiline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextItemBase
Dim value As Boolean

instance.Multiline = value

value = instance.Multiline
C#
public bool Multiline {get; set;}

Return Value

true if the Text Item supports multiple lines; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextItemBase Class
TextItemBase Members


TextWrap Property

TextWrap Property
[image]
Telerik.Reporting Namespace > TextItemBase Class : TextWrap Property

Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property TextWrap As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextItemBase
Dim value As Boolean

instance.TextWrap = value

value = instance.TextWrap
C#
public bool TextWrap {get; set;}

Return Value

true if the Text Item wraps words; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextItemBase Class
TextItemBase Members


TextItemHelper Class

TextItemHelper Class
See Also Members
[image]
Telerik.Reporting Namespace : TextItemHelper Class

Represents some helpers related to the TextItemBase classes.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Class TextItemHelper
Visual Basic (Usage) Copy Code
Dim instance As TextItemHelper
C#
private class TextItemHelper

Inheritance Hierarchy

System.Object
Telerik.Reporting.TextItemHelper

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextItemHelper Members
Telerik.Reporting Namespace


TextItemHelper Class Members

TextItemHelper Class Members
[image]
Telerik.Reporting Namespace : TextItemHelper Class

The following tables list the members exposed by TextItemHelper.

Public Constructors

 | Name | Description
Public Constructor | TextItemHelper Constructor |
Top

See Also

Reference

TextItemHelper Class
Telerik.Reporting Namespace


TextItemHelper Constructor

TextItemHelper Constructor
[image]
Telerik.Reporting Namespace > TextItemHelper Class : TextItemHelper Constructor

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextItemHelper()
C#
public TextItemHelper()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextItemHelper()
C#
public TextItemHelper()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextItemHelper Class
TextItemHelper Members


IResourceResolutionService Interface

IResourceResolutionService Interface
See Also Members
[image]
Telerik.Reporting Namespace : IResourceResolutionService Interface

Provides an interface for resolving resources.
Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Interface IResourceResolutionService
Visual Basic (Usage) Copy Code
Dim instance As IResourceResolutionService
C#
private interface IResourceResolutionService

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IResourceResolutionService Members
Telerik.Reporting Namespace


IResourceResolutionService Interface Members

IResourceResolutionService Interface Members
See Also Methods
[image]
Telerik.Reporting Namespace : IResourceResolutionService Interface

The following tables list the members exposed by IResourceResolutionService.

Public Methods

 | Name | Description
Method | GetResourceAssembly |
Method | GetResourceUri |
Method | GetUri |
Top

See Also

Reference

IResourceResolutionService Interface
Telerik.Reporting Namespace


IResourceResolutionService Interface Methods

IResourceResolutionService Interface Methods
[image]
Telerik.Reporting Namespace : IResourceResolutionService Interface

For a list of all members of this type, see IResourceResolutionService members.

Public Methods

 | Name | Description
Method | GetResourceAssembly |
Method | GetResourceUri |
Method | GetUri |
Top

See Also

Reference

IResourceResolutionService Interface
Telerik.Reporting Namespace


GetResourceAssembly Method

GetResourceAssembly Method
[image]
Telerik.Reporting Namespace > IResourceResolutionService Interface : GetResourceAssembly Method

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Function GetResourceAssembly() As Assembly
Visual Basic (Usage) Copy Code
Dim instance As IResourceResolutionService
Dim value As Assembly

value = instance.GetResourceAssembly()
C#
Assembly GetResourceAssembly()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IResourceResolutionService Interface
IResourceResolutionService Members


GetResourceUri Method

GetResourceUri Method
[image]
Telerik.Reporting Namespace > IResourceResolutionService Interface : GetResourceUri Method

resourceName

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Function GetResourceUri( _
   ByVal resourceName As String _
) As Uri
Visual Basic (Usage) Copy Code
Dim instance As IResourceResolutionService
Dim resourceName As String
Dim value As Uri

value = instance.GetResourceUri(resourceName)
C#
Uri GetResourceUri(
   string resourceName
)

Parameters

resourceName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IResourceResolutionService Interface
IResourceResolutionService Members


GetUri Method

GetUri Method
[image]
Telerik.Reporting Namespace > IResourceResolutionService Interface : GetUri Method

path

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Function GetUri( _
   ByVal path As String _
) As Uri
Visual Basic (Usage) Copy Code
Dim instance As IResourceResolutionService
Dim path As String
Dim value As Uri

value = instance.GetUri(path)
C#
Uri GetUri(
   string path
)

Parameters

path

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IResourceResolutionService Interface
IResourceResolutionService Members


ReportParameterUISettings.IAvailableValues Interface

ReportParameterUISettings.IAvailableValues Interface
See Also Members
[image]
Telerik.Reporting Namespace : ReportParameterUISettings.IAvailableValues Interface

Represents the ReportParameterUISettings bindable AvailableValues
Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Interface ReportParameterUISettings.IAvailableValues
   Inherits ReportParameterUISettings.IDataSource
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings.IAvailableValues
C#
public interface ReportParameterUISettings.IAvailableValues : ReportParameterUISettings.IDataSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings.IAvailableValues Members
Telerik.Reporting Namespace


ReportParameterUISettings.IAvailableValues Interface Members

ReportParameterUISettings.IAvailableValues Interface Members
See Also Properties
[image]
Telerik.Reporting Namespace : ReportParameterUISettings.IAvailableValues Interface

The following tables list the members exposed by ReportParameterUISettings.IAvailableValues.

Public Properties

 | Name | Description
Property | DisplayMember | Gets or sets a string that specifies the property of the data source from which to draw the value labels.
Property | Filters | Gets a FilterCollection that defines the filter expression(s).
Property | Sorting | Gets a SortingCollection that defines the sort column(s), and their type and order.
Top

See Also

Reference

ReportParameterUISettings.IAvailableValues Interface
Telerik.Reporting Namespace


ReportParameterUISettings.IAvailableValues Interface Properties

ReportParameterUISettings.IAvailableValues Interface Properties
See Also
[image]
Telerik.Reporting Namespace : ReportParameterUISettings.IAvailableValues Interface

For a list of all members of this type, see ReportParameterUISettings.IAvailableValues members.

Public Properties

 | Name | Description
Property | DisplayMember | Gets or sets a string that specifies the property of the data source from which to draw the value labels.
Property | Filters | Gets a FilterCollection that defines the filter expression(s).
Property | Sorting | Gets a SortingCollection that defines the sort column(s), and their type and order.
Top

See Also

Reference

ReportParameterUISettings.IAvailableValues Interface
Telerik.Reporting Namespace


DisplayMember Property

DisplayMember Property
[image]
Telerik.Reporting Namespace > ReportParameterUISettings.IAvailableValues Interface : DisplayMember Property

Gets or sets a string that specifies the property of the data source from which to draw the value labels.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Property DisplayMember As String
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings.IAvailableValues
Dim value As String

instance.DisplayMember = value

value = instance.DisplayMember
C#
string DisplayMember {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings.IAvailableValues Interface
ReportParameterUISettings.IAvailableValues Members


Filters Property

Filters Property
[image]
Telerik.Reporting Namespace > ReportParameterUISettings.IAvailableValues Interface : Filters Property

Gets a FilterCollection that defines the filter expression(s).

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Filters As FilterCollection
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings.IAvailableValues
Dim value As FilterCollection

value = instance.Filters
C#
FilterCollection Filters {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings.IAvailableValues Interface
ReportParameterUISettings.IAvailableValues Members


Sorting Property

Sorting Property
[image]
Telerik.Reporting Namespace > ReportParameterUISettings.IAvailableValues Interface : Sorting Property

Gets a SortingCollection that defines the sort column(s), and their type and order.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Sorting As SortingCollection
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings.IAvailableValues
Dim value As SortingCollection

value = instance.Sorting
C#
SortingCollection Sorting {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings.IAvailableValues Interface
ReportParameterUISettings.IAvailableValues Members


ReportParameterUISettings.IDataSource Interface

ReportParameterUISettings.IDataSource Interface
See Also Members
[image]
Telerik.Reporting Namespace : ReportParameterUISettings.IDataSource Interface

Base interface from AvailableValues and DefaultValues data bindable properties
Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Interface ReportParameterUISettings.IDataSource
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings.IDataSource
C#
public interface ReportParameterUISettings.IDataSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings.IDataSource Members
Telerik.Reporting Namespace


ReportParameterUISettings.IDataSource Interface Members

ReportParameterUISettings.IDataSource Interface Members
See Also Properties
[image]
Telerik.Reporting Namespace : ReportParameterUISettings.IDataSource Interface

The following tables list the members exposed by ReportParameterUISettings.IDataSource.

Public Properties

 | Name | Description
Property | DataMember | Gets or sets the specific list in a DataSource.
Property | DataSource | Gets or sets the data source.
Property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value.
Top

See Also

Reference

ReportParameterUISettings.IDataSource Interface
Telerik.Reporting Namespace


ReportParameterUISettings.IDataSource Interface Properties

ReportParameterUISettings.IDataSource Interface Properties
[image]
Telerik.Reporting Namespace : ReportParameterUISettings.IDataSource Interface

For a list of all members of this type, see ReportParameterUISettings.IDataSource members.

Public Properties

 | Name | Description
Property | DataMember | Gets or sets the specific list in a DataSource.
Property | DataSource | Gets or sets the data source.
Property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value.
Top

See Also

Reference

ReportParameterUISettings.IDataSource Interface
Telerik.Reporting Namespace


DataMember Property

DataMember Property
[image]
Telerik.Reporting Namespace > ReportParameterUISettings.IDataSource Interface : DataMember Property

Gets or sets the specific list in a DataSource.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings.IDataSource
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
string DataMember {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings.IDataSource Interface
ReportParameterUISettings.IDataSource Members


DataSource Property

DataSource Property
[image]
Telerik.Reporting Namespace > ReportParameterUISettings.IDataSource Interface : DataSource Property

Gets or sets the data source.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings.IDataSource
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
object DataSource {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings.IDataSource Interface
ReportParameterUISettings.IDataSource Members


ValueMember Property

ValueMember Property
[image]
Telerik.Reporting Namespace > ReportParameterUISettings.IDataSource Interface : ValueMember Property

Gets or sets a string that specifies the property of the data source from which to draw the value.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Property ValueMember As String
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterUISettings.IDataSource
Dim value As String

instance.ValueMember = value

value = instance.ValueMember
C#
string ValueMember {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParameterUISettings.IDataSource Interface
ReportParameterUISettings.IDataSource Members


BoundsException Class

Telerik.Reporting.Processing Send comments on this topic.
BoundsException Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : BoundsException Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class BoundsException
   Inherits ArgumentException
Visual Basic (Usage) Copy Code
Dim instance As BoundsException
C#
private class BoundsException : ArgumentException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.ArgumentException
Telerik.Reporting.Barcodes.BoundsException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BoundsException Members
Telerik.Reporting.Barcodes Namespace


BoundsException Class Members

Telerik.Reporting.Processing Send comments on this topic.
BoundsException Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : BoundsException Class

The following tables list the members exposed by BoundsException.

Public Constructors

 | Name | Description
Public Constructor | BoundsException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

BoundsException Class
Telerik.Reporting.Barcodes Namespace


BoundsException Constructor

Telerik.Reporting.Processing Send comments on this topic.
BoundsException Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > BoundsException Class : BoundsException Constructor

length

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim length As Integer

Dim instance As BoundsException(length)
C#
public BoundsException(
   int length
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim length As Integer

Dim instance As BoundsException(length)
C#
public BoundsException(
   int length
)

Parameters

length

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BoundsException Class
BoundsException Members


Codabar Class

Telerik.Reporting.Processing Send comments on this topic.
Codabar Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Codabar Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Codabar
   Inherits Symbology1D
Visual Basic (Usage) Copy Code
Dim instance As Codabar
C#
private class Codabar : Symbology1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Codabar

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Codabar Members
Telerik.Reporting.Barcodes Namespace


Codabar Class Members

Telerik.Reporting.Processing Send comments on this topic.
Codabar Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Codabar Class

The following tables list the members exposed by Codabar.

Public Constructors

 | Name | Description
Public Constructor | Codabar Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Codabar Class
Telerik.Reporting.Barcodes Namespace


Codabar Constructor

Telerik.Reporting.Processing Send comments on this topic.
Codabar Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Codabar Class : Codabar Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Codabar()
C#
public Codabar()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Codabar()
C#
public Codabar()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Codabar Class
Codabar Members


Codabar Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Codabar Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Codabar Class

For a list of all members of this type, see Codabar members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Codabar Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Codabar Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Codabar
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Codabar Class
Codabar Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Codabar Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Codabar
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Codabar Class
Codabar Members


Code11 Class

Telerik.Reporting.Processing Send comments on this topic.
Code11 Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Code11 Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Code11
   Inherits Symbology1D
Visual Basic (Usage) Copy Code
Dim instance As Code11
C#
private class Code11 : Symbology1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Code11

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code11 Members
Telerik.Reporting.Barcodes Namespace


Code11 Class Members

Telerik.Reporting.Processing Send comments on this topic.
Code11 Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Code11 Class

The following tables list the members exposed by Code11.

Public Constructors

 | Name | Description
Public Constructor | Code11 Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code11 Class
Telerik.Reporting.Barcodes Namespace


Code11 Constructor

Telerik.Reporting.Processing Send comments on this topic.
Code11 Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code11 Class : Code11 Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code11()
C#
public Code11()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code11()
C#
public Code11()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code11 Class
Code11 Members


Code11 Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Code11 Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code11 Class

For a list of all members of this type, see Code11 members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code11 Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code11 Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Code11
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code11 Class
Code11 Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code11 Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Code11
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code11 Class
Code11 Members


Code128 Class

Telerik.Reporting.Processing Send comments on this topic.
Code128 Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Code128 Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Code128
   Inherits Symbology1D
Visual Basic (Usage) Copy Code
Dim instance As Code128
C#
private class Code128 : Symbology1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Code128
Telerik.Reporting.Barcodes.Code128A
Telerik.Reporting.Barcodes.Code128B
Telerik.Reporting.Barcodes.Code128C
Telerik.Reporting.Barcodes.EAN128

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128 Members
Telerik.Reporting.Barcodes Namespace


Code128 Class Members

Telerik.Reporting.Processing Send comments on this topic.
Code128 Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Code128 Class

The following tables list the members exposed by Code128.

Public Constructors

 | Name | Description
Public Constructor | Code128 Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetIndices |
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code128 Class
Telerik.Reporting.Barcodes Namespace


Code128 Constructor

Telerik.Reporting.Processing Send comments on this topic.
Code128 Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code128 Class : Code128 Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128()
C#
public Code128()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128()
C#
public Code128()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128 Class
Code128 Members


Code128 Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Code128 Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code128 Class

For a list of all members of this type, see Code128 members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetIndices |
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code128 Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code128 Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Code128
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128 Class
Code128 Members


GetIndices Method

Telerik.Reporting.Processing Send comments on this topic.
GetIndices Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code128 Class : GetIndices Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetIndices( _
   ByVal value As String _
) As Integer()
Visual Basic (Usage) Copy Code
Dim instance As Code128
Dim value As String
Dim value() As Integer

value = instance.GetIndices(value)
C#
protected virtual int[] GetIndices(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128 Class
Code128 Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code128 Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Code128
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128 Class
Code128 Members


Code128A Class

Telerik.Reporting.Processing Send comments on this topic.
Code128A Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Code128A Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Code128A
   Inherits Code128
Visual Basic (Usage) Copy Code
Dim instance As Code128A
C#
private class Code128A : Code128

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Code128
Telerik.Reporting.Barcodes.Code128A

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128A Members
Telerik.Reporting.Barcodes Namespace


Code128A Class Members

Telerik.Reporting.Processing Send comments on this topic.
Code128A Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Code128A Class

The following tables list the members exposed by Code128A.

Public Constructors

 | Name | Description
Public Constructor | Code128A Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | (Inherited from Code128)
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetIndices | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code128A Class
Telerik.Reporting.Barcodes Namespace


Code128A Constructor

Telerik.Reporting.Processing Send comments on this topic.
Code128A Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code128A Class : Code128A Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128A()
C#
public Code128A()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128A()
C#
public Code128A()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128A Class
Code128A Members


Code128A Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Code128A Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code128A Class

For a list of all members of this type, see Code128A members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | (Inherited from Code128)
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetIndices | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code128A Class
Telerik.Reporting.Barcodes Namespace


GetIndices Method

Telerik.Reporting.Processing Send comments on this topic.
GetIndices Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code128A Class : GetIndices Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetIndices( _
   ByVal value As String _
) As Integer()
Visual Basic (Usage) Copy Code
Dim instance As Code128A
Dim value As String
Dim value() As Integer

value = instance.GetIndices(value)
C#
protected override int[] GetIndices(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128A Class
Code128A Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code128A Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Code128A
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128A Class
Code128A Members


Code128B Class

Telerik.Reporting.Processing Send comments on this topic.
Code128B Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Code128B Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Code128B
   Inherits Code128
Visual Basic (Usage) Copy Code
Dim instance As Code128B
C#
private class Code128B : Code128

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Code128
Telerik.Reporting.Barcodes.Code128B

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128B Members
Telerik.Reporting.Barcodes Namespace


Code128B Class Members

Telerik.Reporting.Processing Send comments on this topic.
Code128B Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Code128B Class

The following tables list the members exposed by Code128B.

Public Constructors

 | Name | Description
Public Constructor | Code128B Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | (Inherited from Code128)
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetIndices | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code128B Class
Telerik.Reporting.Barcodes Namespace


Code128B Constructor

Telerik.Reporting.Processing Send comments on this topic.
Code128B Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code128B Class : Code128B Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128B()
C#
public Code128B()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128B()
C#
public Code128B()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128B Class
Code128B Members


Code128B Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Code128B Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code128B Class

For a list of all members of this type, see Code128B members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | (Inherited from Code128)
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetIndices | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code128B Class
Telerik.Reporting.Barcodes Namespace


GetIndices Method

Telerik.Reporting.Processing Send comments on this topic.
GetIndices Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code128B Class : GetIndices Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetIndices( _
   ByVal value As String _
) As Integer()
Visual Basic (Usage) Copy Code
Dim instance As Code128B
Dim value As String
Dim value() As Integer

value = instance.GetIndices(value)
C#
protected override int[] GetIndices(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128B Class
Code128B Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code128B Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Code128B
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128B Class
Code128B Members


Code128C Class

Telerik.Reporting.Processing Send comments on this topic.
Code128C Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Code128C Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Code128C
   Inherits Code128
Visual Basic (Usage) Copy Code
Dim instance As Code128C
C#
private class Code128C : Code128

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Code128
Telerik.Reporting.Barcodes.Code128C

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128C Members
Telerik.Reporting.Barcodes Namespace


Code128C Class Members

Telerik.Reporting.Processing Send comments on this topic.
Code128C Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Code128C Class

The following tables list the members exposed by Code128C.

Public Constructors

 | Name | Description
Public Constructor | Code128C Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | (Inherited from Code128)
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetIndices | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code128C Class
Telerik.Reporting.Barcodes Namespace


Code128C Constructor

Telerik.Reporting.Processing Send comments on this topic.
Code128C Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code128C Class : Code128C Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128C()
C#
public Code128C()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128C()
C#
public Code128C()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128C Class
Code128C Members


Code128C Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Code128C Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code128C Class

For a list of all members of this type, see Code128C members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | (Inherited from Code128)
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetIndices | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code128C Class
Telerik.Reporting.Barcodes Namespace


GetIndices Method

Telerik.Reporting.Processing Send comments on this topic.
GetIndices Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code128C Class : GetIndices Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetIndices( _
   ByVal value As String _
) As Integer()
Visual Basic (Usage) Copy Code
Dim instance As Code128C
Dim value As String
Dim value() As Integer

value = instance.GetIndices(value)
C#
protected override int[] GetIndices(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128C Class
Code128C Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code128C Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Code128C
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128C Class
Code128C Members


Code25 Class

Telerik.Reporting.Processing Send comments on this topic.
Code25 Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Code25 Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private MustInherit Class Code25
   Inherits Symbology1D
Visual Basic (Usage) Copy Code
Dim instance As Code25
C#
private abstract class Code25 : Symbology1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Code25
Telerik.Reporting.Barcodes.Code25Interleaved
Telerik.Reporting.Barcodes.Code25Standard

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25 Members
Telerik.Reporting.Barcodes Namespace


Code25 Class Members

Telerik.Reporting.Processing Send comments on this topic.
Code25 Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Code25 Class

The following tables list the members exposed by Code25.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
static (Shared in Visual Basic) | GetChecksum |
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | (Inherited from Symbology1D)
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code25 Class
Telerik.Reporting.Barcodes Namespace


Code25 Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Code25 Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code25 Class

For a list of all members of this type, see Code25 members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
static (Shared in Visual Basic) | GetChecksum |
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | (Inherited from Symbology1D)
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code25 Class
Telerik.Reporting.Barcodes Namespace


GetChecksum Method

Telerik.Reporting.Processing Send comments on this topic.
GetChecksum Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code25 Class : GetChecksum Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetChecksum( _
   ByVal value As String _
) As Char
Visual Basic (Usage) Copy Code
Dim value As String
Dim value As Char

value = Code25.GetChecksum(value)
C#
protected static char GetChecksum(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25 Class
Code25 Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code25 Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Code25
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25 Class
Code25 Members


Code25Interleaved Class

Telerik.Reporting.Processing Send comments on this topic.
Code25Interleaved Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Code25Interleaved Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Code25Interleaved
   Inherits Code25
Visual Basic (Usage) Copy Code
Dim instance As Code25Interleaved
C#
private class Code25Interleaved : Code25

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Code25
Telerik.Reporting.Barcodes.Code25Interleaved

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Interleaved Members
Telerik.Reporting.Barcodes Namespace


Code25Interleaved Class Members

Telerik.Reporting.Processing Send comments on this topic.
Code25Interleaved Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Code25Interleaved Class

The following tables list the members exposed by Code25Interleaved.

Public Constructors

 | Name | Description
Public Constructor | Code25Interleaved Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | (Inherited from Code25)
Top

See Also

Reference

Code25Interleaved Class
Telerik.Reporting.Barcodes Namespace


Code25Interleaved Constructor

Telerik.Reporting.Processing Send comments on this topic.
Code25Interleaved Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code25Interleaved Class : Code25Interleaved Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code25Interleaved()
C#
public Code25Interleaved()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code25Interleaved()
C#
public Code25Interleaved()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Interleaved Class
Code25Interleaved Members


Code25Interleaved Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Code25Interleaved Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code25Interleaved Class

For a list of all members of this type, see Code25Interleaved members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | (Inherited from Code25)
Top

See Also

Reference

Code25Interleaved Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code25Interleaved Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Code25Interleaved
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Interleaved Class
Code25Interleaved Members


Code25Standard Class

Telerik.Reporting.Processing Send comments on this topic.
Code25Standard Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Code25Standard Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Code25Standard
   Inherits Code25
Visual Basic (Usage) Copy Code
Dim instance As Code25Standard
C#
private class Code25Standard : Code25

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Code25
Telerik.Reporting.Barcodes.Code25Standard

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Standard Members
Telerik.Reporting.Barcodes Namespace


Code25Standard Class Members

Telerik.Reporting.Processing Send comments on this topic.
Code25Standard Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Code25Standard Class

The following tables list the members exposed by Code25Standard.

Public Constructors

 | Name | Description
Public Constructor | Code25Standard Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | (Inherited from Code25)
Top

See Also

Reference

Code25Standard Class
Telerik.Reporting.Barcodes Namespace


Code25Standard Constructor

Telerik.Reporting.Processing Send comments on this topic.
Code25Standard Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code25Standard Class : Code25Standard Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code25Standard()
C#
public Code25Standard()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code25Standard()
C#
public Code25Standard()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Standard Class
Code25Standard Members


Code25Standard Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Code25Standard Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code25Standard Class

For a list of all members of this type, see Code25Standard members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | (Inherited from Code25)
Top

See Also

Reference

Code25Standard Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code25Standard Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Code25Standard
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Standard Class
Code25Standard Members


Code39 Class

Telerik.Reporting.Processing Send comments on this topic.
Code39 Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Code39 Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Code39
   Inherits Symbology1D
Visual Basic (Usage) Copy Code
Dim instance As Code39
C#
private class Code39 : Symbology1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Code39
Telerik.Reporting.Barcodes.Code39Extended

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39 Members
Telerik.Reporting.Barcodes Namespace


Code39 Class Members

Telerik.Reporting.Processing Send comments on this topic.
Code39 Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Code39 Class

The following tables list the members exposed by Code39.

Public Constructors

 | Name | Description
Public Constructor | Code39 Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code39 Class
Telerik.Reporting.Barcodes Namespace


Code39 Constructor

Telerik.Reporting.Processing Send comments on this topic.
Code39 Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code39 Class : Code39 Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code39()
C#
public Code39()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code39()
C#
public Code39()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39 Class
Code39 Members


Code39 Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Code39 Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code39 Class

For a list of all members of this type, see Code39 members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code39 Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code39 Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Code39
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39 Class
Code39 Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code39 Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Code39
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39 Class
Code39 Members


Code39Extended Class

Telerik.Reporting.Processing Send comments on this topic.
Code39Extended Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Code39Extended Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Code39Extended
   Inherits Code39
Visual Basic (Usage) Copy Code
Dim instance As Code39Extended
C#
private class Code39Extended : Code39

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Code39
Telerik.Reporting.Barcodes.Code39Extended

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Extended Members
Telerik.Reporting.Barcodes Namespace


Code39Extended Class Members

Telerik.Reporting.Processing Send comments on this topic.
Code39Extended Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Code39Extended Class

The following tables list the members exposed by Code39Extended.

Public Constructors

 | Name | Description
Public Constructor | Code39Extended Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code39Extended Class
Telerik.Reporting.Barcodes Namespace


Code39Extended Constructor

Telerik.Reporting.Processing Send comments on this topic.
Code39Extended Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code39Extended Class : Code39Extended Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code39Extended()
C#
public Code39Extended()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code39Extended()
C#
public Code39Extended()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Extended Class
Code39Extended Members


Code39Extended Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Code39Extended Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code39Extended Class

For a list of all members of this type, see Code39Extended members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code39Extended Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code39Extended Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Code39Extended
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Extended Class
Code39Extended Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code39Extended Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Code39Extended
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Extended Class
Code39Extended Members


Code93 Class

Telerik.Reporting.Processing Send comments on this topic.
Code93 Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Code93 Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Code93
   Inherits Symbology1D
Visual Basic (Usage) Copy Code
Dim instance As Code93
C#
private class Code93 : Symbology1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Code93
Telerik.Reporting.Barcodes.Code93Extended

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93 Members
Telerik.Reporting.Barcodes Namespace


Code93 Class Members

Telerik.Reporting.Processing Send comments on this topic.
Code93 Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Code93 Class

The following tables list the members exposed by Code93.

Public Constructors

 | Name | Description
Public Constructor | Code93 Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code93 Class
Telerik.Reporting.Barcodes Namespace


Code93 Constructor

Telerik.Reporting.Processing Send comments on this topic.
Code93 Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code93 Class : Code93 Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code93()
C#
public Code93()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code93()
C#
public Code93()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93 Class
Code93 Members


Code93 Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Code93 Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code93 Class

For a list of all members of this type, see Code93 members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code93 Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code93 Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Code93
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93 Class
Code93 Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code93 Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Code93
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93 Class
Code93 Members


Code93Extended Class

Telerik.Reporting.Processing Send comments on this topic.
Code93Extended Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Code93Extended Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Code93Extended
   Inherits Code93
Visual Basic (Usage) Copy Code
Dim instance As Code93Extended
C#
private class Code93Extended : Code93

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Code93
Telerik.Reporting.Barcodes.Code93Extended

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93Extended Members
Telerik.Reporting.Barcodes Namespace


Code93Extended Class Members

Telerik.Reporting.Processing Send comments on this topic.
Code93Extended Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Code93Extended Class

The following tables list the members exposed by Code93Extended.

Public Constructors

 | Name | Description
Public Constructor | Code93Extended Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code93Extended Class
Telerik.Reporting.Barcodes Namespace


Code93Extended Constructor

Telerik.Reporting.Processing Send comments on this topic.
Code93Extended Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code93Extended Class : Code93Extended Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code93Extended()
C#
public Code93Extended()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code93Extended()
C#
public Code93Extended()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93Extended Class
Code93Extended Members


Code93Extended Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Code93Extended Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code93Extended Class

For a list of all members of this type, see Code93Extended members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Code93Extended Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code93Extended Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Code93Extended
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93Extended Class
Code93Extended Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Code93Extended Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Code93Extended
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93Extended Class
Code93Extended Members


CodeMSI Class

Telerik.Reporting.Processing Send comments on this topic.
CodeMSI Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : CodeMSI Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class CodeMSI
   Inherits Symbology1D
Visual Basic (Usage) Copy Code
Dim instance As CodeMSI
C#
private class CodeMSI : Symbology1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.CodeMSI

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodeMSI Members
Telerik.Reporting.Barcodes Namespace


CodeMSI Class Members

Telerik.Reporting.Processing Send comments on this topic.
CodeMSI Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : CodeMSI Class

The following tables list the members exposed by CodeMSI.

Public Constructors

 | Name | Description
Public Constructor | CodeMSI Constructor |
Top

Public Properties

 | Name | Description
Public Property | Algorithm |
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

CodeMSI Class
Telerik.Reporting.Barcodes Namespace


CodeMSI Constructor

Telerik.Reporting.Processing Send comments on this topic.
CodeMSI Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > CodeMSI Class : CodeMSI Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CodeMSI()
C#
public CodeMSI()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CodeMSI()
C#
public CodeMSI()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodeMSI Class
CodeMSI Members


CodeMSI Class Methods

Telerik.Reporting.Processing Send comments on this topic.
CodeMSI Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : CodeMSI Class

For a list of all members of this type, see CodeMSI members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

CodeMSI Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > CodeMSI Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As CodeMSI
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodeMSI Class
CodeMSI Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > CodeMSI Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As CodeMSI
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodeMSI Class
CodeMSI Members


CodeMSI Class Properties

Telerik.Reporting.Processing Send comments on this topic.
CodeMSI Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : CodeMSI Class

For a list of all members of this type, see CodeMSI members.

Public Properties

 | Name | Description
Public Property | Algorithm |
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

CodeMSI Class
Telerik.Reporting.Barcodes Namespace


Algorithm Property

Telerik.Reporting.Processing Send comments on this topic.
Algorithm Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > CodeMSI Class : Algorithm Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Algorithm As CheckMSI
Visual Basic (Usage) Copy Code
Dim instance As CodeMSI
Dim value As CheckMSI

instance.Algorithm = value

value = instance.Algorithm
C#
public CheckMSI Algorithm {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodeMSI Class
CodeMSI Members


EAN128 Class

Telerik.Reporting.Processing Send comments on this topic.
EAN128 Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : EAN128 Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class EAN128
   Inherits Code128
Visual Basic (Usage) Copy Code
Dim instance As EAN128
C#
private class EAN128 : Code128

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Code128
Telerik.Reporting.Barcodes.EAN128

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN128 Members
Telerik.Reporting.Barcodes Namespace


EAN128 Class Members

Telerik.Reporting.Processing Send comments on this topic.
EAN128 Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : EAN128 Class

The following tables list the members exposed by EAN128.

Public Constructors

 | Name | Description
Public Constructor | EAN128 Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | (Inherited from Code128)
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetIndices | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | (Inherited from Code128)
Top

See Also

Reference

EAN128 Class
Telerik.Reporting.Barcodes Namespace


EAN128 Constructor

Telerik.Reporting.Processing Send comments on this topic.
EAN128 Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN128 Class : EAN128 Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EAN128()
C#
public EAN128()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EAN128()
C#
public EAN128()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN128 Class
EAN128 Members


EAN128 Class Methods

Telerik.Reporting.Processing Send comments on this topic.
EAN128 Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : EAN128 Class

For a list of all members of this type, see EAN128 members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | (Inherited from Code128)
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetIndices | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | (Inherited from Code128)
Top

See Also

Reference

EAN128 Class
Telerik.Reporting.Barcodes Namespace


GetIndices Method

Telerik.Reporting.Processing Send comments on this topic.
GetIndices Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN128 Class : GetIndices Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetIndices( _
   ByVal value As String _
) As Integer()
Visual Basic (Usage) Copy Code
Dim instance As EAN128
Dim value As String
Dim value() As Integer

value = instance.GetIndices(value)
C#
protected override int[] GetIndices(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN128 Class
EAN128 Members


EAN13 Class

Telerik.Reporting.Processing Send comments on this topic.
EAN13 Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : EAN13 Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class EAN13
   Inherits Product1D
Visual Basic (Usage) Copy Code
Dim instance As EAN13
C#
private class EAN13 : Product1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Product1D
Telerik.Reporting.Barcodes.EAN13

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13 Members
Telerik.Reporting.Barcodes Namespace


EAN13 Class Members

Telerik.Reporting.Processing Send comments on this topic.
EAN13 Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : EAN13 Class

The following tables list the members exposed by EAN13.

Public Constructors

 | Name | Description
Public Constructor | EAN13 Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | HeadRect | (Inherited from Product1D)
Protected Property | HeadText | (Inherited from Product1D)
Protected Property | LeftRect | (Inherited from Product1D)
Protected Property | LeftText | (Inherited from Product1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | RightRect | (Inherited from Product1D)
Protected Property | RightText | (Inherited from Product1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TailRect | (Inherited from Product1D)
Protected Property | TailText | (Inherited from Product1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Product1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Product1D)
Protected Method | GetBarRect | (Inherited from Product1D)
Protected Method | GetClipRect | (Inherited from Product1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | Overloaded. Overridden.
Protected Method | GetHeadRect | (Inherited from Product1D)
Protected Method | GetHeadSize | (Inherited from Product1D)
Protected Method | GetHeadText | Overridden.
Protected Method | GetLeftRect | (Inherited from Product1D)
Protected Method | GetLeftText | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetRightRect | (Inherited from Product1D)
Protected Method | GetRightText | Overridden.
Protected Method | GetTailRect | (Inherited from Product1D)
Protected Method | GetTailSize | (Inherited from Product1D)
Protected Method | GetTailText | (Inherited from Product1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Product1D)
Protected Method | ProcessValue | (Inherited from Product1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

EAN13 Class
Telerik.Reporting.Barcodes Namespace


EAN13 Constructor

Telerik.Reporting.Processing Send comments on this topic.
EAN13 Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN13 Class : EAN13 Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EAN13()
C#
public EAN13()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EAN13()
C#
public EAN13()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13 Class
EAN13 Members


EAN13 Class Methods

Telerik.Reporting.Processing Send comments on this topic.
EAN13 Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : EAN13 Class

For a list of all members of this type, see EAN13 members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Product1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Product1D)
Protected Method | GetBarRect | (Inherited from Product1D)
Protected Method | GetClipRect | (Inherited from Product1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | Overloaded. Overridden.
Protected Method | GetHeadRect | (Inherited from Product1D)
Protected Method | GetHeadSize | (Inherited from Product1D)
Protected Method | GetHeadText | Overridden.
Protected Method | GetLeftRect | (Inherited from Product1D)
Protected Method | GetLeftText | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetRightRect | (Inherited from Product1D)
Protected Method | GetRightText | Overridden.
Protected Method | GetTailRect | (Inherited from Product1D)
Protected Method | GetTailSize | (Inherited from Product1D)
Protected Method | GetTailText | (Inherited from Product1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Product1D)
Protected Method | ProcessValue | (Inherited from Product1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

EAN13 Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN13 Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As EAN13
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13 Class
EAN13 Members


GetFormat Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN13 Class : GetFormat Method

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
GetFormat(String) |
GetFormat(String,Int32) | (Inherited from Product1D)

Overload List

Overload | Description
GetFormat(String) |
GetFormat(String,Int32) | (Inherited from Product1D)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13 Class
EAN13 Members


GetFormat(String) Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat(String) Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN13 Class > GetFormat Method : GetFormat(String) Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Protected Function GetFormat( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As EAN13
Dim value As String
Dim value As String

value = instance.GetFormat(value)
C#
protected override string GetFormat(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13 Class
EAN13 Members
Overload List


GetHeadText Method

Telerik.Reporting.Processing Send comments on this topic.
GetHeadText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN13 Class : GetHeadText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetHeadText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As EAN13
Dim value As String
Dim value As String

value = instance.GetHeadText(value)
C#
protected override string GetHeadText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13 Class
EAN13 Members


GetLeftText Method

Telerik.Reporting.Processing Send comments on this topic.
GetLeftText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN13 Class : GetLeftText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetLeftText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As EAN13
Dim value As String
Dim value As String

value = instance.GetLeftText(value)
C#
protected override string GetLeftText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13 Class
EAN13 Members


GetRightText Method

Telerik.Reporting.Processing Send comments on this topic.
GetRightText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN13 Class : GetRightText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetRightText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As EAN13
Dim value As String
Dim value As String

value = instance.GetRightText(value)
C#
protected override string GetRightText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13 Class
EAN13 Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN13 Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As EAN13
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13 Class
EAN13 Members


EAN8 Class

Telerik.Reporting.Processing Send comments on this topic.
EAN8 Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : EAN8 Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class EAN8
   Inherits Product1D
Visual Basic (Usage) Copy Code
Dim instance As EAN8
C#
private class EAN8 : Product1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Product1D
Telerik.Reporting.Barcodes.EAN8

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8 Members
Telerik.Reporting.Barcodes Namespace


EAN8 Class Members

Telerik.Reporting.Processing Send comments on this topic.
EAN8 Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : EAN8 Class

The following tables list the members exposed by EAN8.

Public Constructors

 | Name | Description
Public Constructor | EAN8 Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | HeadRect | (Inherited from Product1D)
Protected Property | HeadText | (Inherited from Product1D)
Protected Property | LeftRect | (Inherited from Product1D)
Protected Property | LeftText | (Inherited from Product1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | RightRect | (Inherited from Product1D)
Protected Property | RightText | (Inherited from Product1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TailRect | (Inherited from Product1D)
Protected Property | TailText | (Inherited from Product1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Product1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Product1D)
Protected Method | GetBarRect | (Inherited from Product1D)
Protected Method | GetClipRect | (Inherited from Product1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | Overloaded. Overridden.
Protected Method | GetHeadRect | (Inherited from Product1D)
Protected Method | GetHeadSize | (Inherited from Product1D)
Protected Method | GetHeadText | (Inherited from Product1D)
Protected Method | GetLeftRect | (Inherited from Product1D)
Protected Method | GetLeftText | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetRightRect | (Inherited from Product1D)
Protected Method | GetRightText | Overridden.
Protected Method | GetTailRect | (Inherited from Product1D)
Protected Method | GetTailSize | (Inherited from Product1D)
Protected Method | GetTailText | (Inherited from Product1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Product1D)
Protected Method | ProcessValue | (Inherited from Product1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

EAN8 Class
Telerik.Reporting.Barcodes Namespace


EAN8 Constructor

Telerik.Reporting.Processing Send comments on this topic.
EAN8 Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN8 Class : EAN8 Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EAN8()
C#
public EAN8()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EAN8()
C#
public EAN8()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8 Class
EAN8 Members


EAN8 Class Methods

Telerik.Reporting.Processing Send comments on this topic.
EAN8 Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : EAN8 Class

For a list of all members of this type, see EAN8 members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Product1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Product1D)
Protected Method | GetBarRect | (Inherited from Product1D)
Protected Method | GetClipRect | (Inherited from Product1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | Overloaded. Overridden.
Protected Method | GetHeadRect | (Inherited from Product1D)
Protected Method | GetHeadSize | (Inherited from Product1D)
Protected Method | GetHeadText | (Inherited from Product1D)
Protected Method | GetLeftRect | (Inherited from Product1D)
Protected Method | GetLeftText | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetRightRect | (Inherited from Product1D)
Protected Method | GetRightText | Overridden.
Protected Method | GetTailRect | (Inherited from Product1D)
Protected Method | GetTailSize | (Inherited from Product1D)
Protected Method | GetTailText | (Inherited from Product1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Product1D)
Protected Method | ProcessValue | (Inherited from Product1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

EAN8 Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN8 Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As EAN8
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8 Class
EAN8 Members


GetFormat Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN8 Class : GetFormat Method

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
GetFormat(String) |
GetFormat(String,Int32) | (Inherited from Product1D)

Overload List

Overload | Description
GetFormat(String) |
GetFormat(String,Int32) | (Inherited from Product1D)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8 Class
EAN8 Members


GetFormat(String) Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat(String) Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN8 Class > GetFormat Method : GetFormat(String) Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Protected Function GetFormat( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As EAN8
Dim value As String
Dim value As String

value = instance.GetFormat(value)
C#
protected override string GetFormat(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8 Class
EAN8 Members
Overload List


GetLeftText Method

Telerik.Reporting.Processing Send comments on this topic.
GetLeftText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN8 Class : GetLeftText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetLeftText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As EAN8
Dim value As String
Dim value As String

value = instance.GetLeftText(value)
C#
protected override string GetLeftText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8 Class
EAN8 Members


GetRightText Method

Telerik.Reporting.Processing Send comments on this topic.
GetRightText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN8 Class : GetRightText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetRightText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As EAN8
Dim value As String
Dim value As String

value = instance.GetRightText(value)
C#
protected override string GetRightText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8 Class
EAN8 Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > EAN8 Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As EAN8
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8 Class
EAN8 Members


FormatException Class

Telerik.Reporting.Processing Send comments on this topic.
FormatException Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : FormatException Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class FormatException
   Inherits ValidateException
Visual Basic (Usage) Copy Code
Dim instance As FormatException
C#
private class FormatException : ValidateException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.ArgumentException
Telerik.Reporting.Barcodes.ValidateException
Telerik.Reporting.Barcodes.FormatException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FormatException Members
Telerik.Reporting.Barcodes Namespace


FormatException Class Members

Telerik.Reporting.Processing Send comments on this topic.
FormatException Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : FormatException Class

The following tables list the members exposed by FormatException.

Public Constructors

 | Name | Description
Public Constructor | FormatException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

FormatException Class
Telerik.Reporting.Barcodes Namespace


FormatException Constructor

Telerik.Reporting.Processing Send comments on this topic.
FormatException Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > FormatException Class : FormatException Constructor

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As FormatException(value)
C#
public FormatException(
   string value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As FormatException(value)
C#
public FormatException(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FormatException Class
FormatException Members


GraphicsProxy Class

Telerik.Reporting.Processing Send comments on this topic.
GraphicsProxy Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : GraphicsProxy Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class GraphicsProxy
   Implements IGraphics
Visual Basic (Usage) Copy Code
Dim instance As GraphicsProxy
C#
private class GraphicsProxy : IGraphics

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.GraphicsProxy

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GraphicsProxy Members
Telerik.Reporting.Barcodes Namespace


GraphicsProxy Class Members

Telerik.Reporting.Processing Send comments on this topic.
GraphicsProxy Class Members
See Also Methods
[image]
Telerik.Reporting.Barcodes Namespace : GraphicsProxy Class

The following tables list the members exposed by GraphicsProxy.

Public Constructors

 | Name | Description
Public Constructor | GraphicsProxy Constructor |
Top

Public Methods

 | Name | Description
Public Method | DrawString |
Public Method | FillRectangle |
Public Method | MeasureString |
Public Method | Restore |
Public Method | RotateTransform |
Public Method | Save |
Public Method | SetClip |
Public Method | TranslateTransform |
Top

See Also

Reference

GraphicsProxy Class
Telerik.Reporting.Barcodes Namespace


GraphicsProxy Constructor

Telerik.Reporting.Processing Send comments on this topic.
GraphicsProxy Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > GraphicsProxy Class : GraphicsProxy Constructor

graphics

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal graphics As Graphics _
)
Visual Basic (Usage) Copy Code
Dim graphics As Graphics

Dim instance As GraphicsProxy(graphics)
C#
public GraphicsProxy(
   Graphics graphics
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal graphics As Graphics _
)
Visual Basic (Usage) Copy Code
Dim graphics As Graphics

Dim instance As GraphicsProxy(graphics)
C#
public GraphicsProxy(
   Graphics graphics
)

Parameters

graphics

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GraphicsProxy Class
GraphicsProxy Members


GraphicsProxy Class Methods

Telerik.Reporting.Processing Send comments on this topic.
GraphicsProxy Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : GraphicsProxy Class

For a list of all members of this type, see GraphicsProxy members.

Public Methods

 | Name | Description
Public Method | DrawString |
Public Method | FillRectangle |
Public Method | MeasureString |
Public Method | Restore |
Public Method | RotateTransform |
Public Method | Save |
Public Method | SetClip |
Public Method | TranslateTransform |
Top

See Also

Reference

GraphicsProxy Class
Telerik.Reporting.Barcodes Namespace


DrawString Method

Telerik.Reporting.Processing Send comments on this topic.
DrawString Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > GraphicsProxy Class : DrawString Method

s
font
brush
bounds
stringFormat

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal bounds As RectangleF, _
   ByVal stringFormat As StringFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As GraphicsProxy
Dim s As String
Dim font As Font
Dim brush As Brush
Dim bounds As RectangleF
Dim stringFormat As StringFormat

instance.DrawString(s, font, brush, bounds, stringFormat)
C#
public void DrawString(
   string s,
   Font font,
   Brush brush,
   RectangleF bounds,
   StringFormat stringFormat
)

Parameters

s
font
brush
bounds
stringFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GraphicsProxy Class
GraphicsProxy Members


FillRectangle Method

Telerik.Reporting.Processing Send comments on this topic.
FillRectangle Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > GraphicsProxy Class : FillRectangle Method

brush
rect

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub FillRectangle( _
   ByVal brush As Brush, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As GraphicsProxy
Dim brush As Brush
Dim rect As RectangleF

instance.FillRectangle(brush, rect)
C#
public void FillRectangle(
   Brush brush,
   RectangleF rect
)

Parameters

brush
rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GraphicsProxy Class
GraphicsProxy Members


MeasureString Method

Telerik.Reporting.Processing Send comments on this topic.
MeasureString Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > GraphicsProxy Class : MeasureString Method

s
font
layoutArea
format
charactersFitted
linesFilled

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function MeasureString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal layoutArea As SizeF, _
   ByVal format As StringFormat, _
   ByRef charactersFitted As Integer, _
   ByRef linesFilled As Integer _
) As SizeF
Visual Basic (Usage) Copy Code
Dim instance As GraphicsProxy
Dim s As String
Dim font As Font
Dim layoutArea As SizeF
Dim format As StringFormat
Dim charactersFitted As Integer
Dim linesFilled As Integer
Dim value As SizeF

value = instance.MeasureString(s, font, layoutArea, format, charactersFitted, linesFilled)
C#
public SizeF MeasureString(
   string s,
   Font font,
   SizeF layoutArea,
   StringFormat format,
   out int charactersFitted,
   out int linesFilled
)

Parameters

s
font
layoutArea
format
charactersFitted
linesFilled

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GraphicsProxy Class
GraphicsProxy Members


Restore Method

Telerik.Reporting.Processing Send comments on this topic.
Restore Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > GraphicsProxy Class : Restore Method

graphicsState

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub Restore( _
   ByVal graphicsState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As GraphicsProxy
Dim graphicsState As Object

instance.Restore(graphicsState)
C#
public void Restore(
   object graphicsState
)

Parameters

graphicsState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GraphicsProxy Class
GraphicsProxy Members


RotateTransform Method

Telerik.Reporting.Processing Send comments on this topic.
RotateTransform Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > GraphicsProxy Class : RotateTransform Method

angle

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub RotateTransform( _
   ByVal angle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As GraphicsProxy
Dim angle As Single

instance.RotateTransform(angle)
C#
public void RotateTransform(
   float angle
)

Parameters

angle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GraphicsProxy Class
GraphicsProxy Members


Save Method

Telerik.Reporting.Processing Send comments on this topic.
Save Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > GraphicsProxy Class : Save Method

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function Save() As Object
Visual Basic (Usage) Copy Code
Dim instance As GraphicsProxy
Dim value As Object

value = instance.Save()
C#
public object Save()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GraphicsProxy Class
GraphicsProxy Members


SetClip Method

Telerik.Reporting.Processing Send comments on this topic.
SetClip Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > GraphicsProxy Class : SetClip Method

rect
combineMode

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetClip( _
   ByVal rect As RectangleF, _
   ByVal combineMode As CombineMode _
)
Visual Basic (Usage) Copy Code
Dim instance As GraphicsProxy
Dim rect As RectangleF
Dim combineMode As CombineMode

instance.SetClip(rect, combineMode)
C#
public void SetClip(
   RectangleF rect,
   CombineMode combineMode
)

Parameters

rect
combineMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GraphicsProxy Class
GraphicsProxy Members


TranslateTransform Method

Telerik.Reporting.Processing Send comments on this topic.
TranslateTransform Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > GraphicsProxy Class : TranslateTransform Method

x
y

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub TranslateTransform( _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As GraphicsProxy
Dim x As Single
Dim y As Single

instance.TranslateTransform(x, y)
C#
public void TranslateTransform(
   float x,
   float y
)

Parameters

x
y

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GraphicsProxy Class
GraphicsProxy Members


LengthException Class

Telerik.Reporting.Processing Send comments on this topic.
LengthException Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : LengthException Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class LengthException
   Inherits ValidateException
Visual Basic (Usage) Copy Code
Dim instance As LengthException
C#
private class LengthException : ValidateException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.ArgumentException
Telerik.Reporting.Barcodes.ValidateException
Telerik.Reporting.Barcodes.LengthException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LengthException Members
Telerik.Reporting.Barcodes Namespace


LengthException Class Members

Telerik.Reporting.Processing Send comments on this topic.
LengthException Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : LengthException Class

The following tables list the members exposed by LengthException.

Public Constructors

 | Name | Description
Public Constructor | LengthException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

LengthException Class
Telerik.Reporting.Barcodes Namespace


LengthException Constructor

Telerik.Reporting.Processing Send comments on this topic.
LengthException Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > LengthException Class : LengthException Constructor

length

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim length As Integer

Dim instance As LengthException(length)
C#
public LengthException(
   int length
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim length As Integer

Dim instance As LengthException(length)
C#
public LengthException(
   int length
)

Parameters

length

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LengthException Class
LengthException Members


Postnet Class

Telerik.Reporting.Processing Send comments on this topic.
Postnet Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Postnet Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Postnet
   Inherits Symbology1D
Visual Basic (Usage) Copy Code
Dim instance As Postnet
C#
private class Postnet : Symbology1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Postnet

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Postnet Members
Telerik.Reporting.Barcodes Namespace


Postnet Class Members

Telerik.Reporting.Processing Send comments on this topic.
Postnet Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Postnet Class

The following tables list the members exposed by Postnet.

Public Constructors

 | Name | Description
Public Constructor | Postnet Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | Overridden.
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | Overridden.
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Postnet Class
Telerik.Reporting.Barcodes Namespace


Postnet Constructor

Telerik.Reporting.Processing Send comments on this topic.
Postnet Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Postnet Class : Postnet Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Postnet()
C#
public Postnet()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Postnet()
C#
public Postnet()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Postnet Class
Postnet Members


Postnet Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Postnet Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Postnet Class

For a list of all members of this type, see Postnet members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | Overridden.
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | (Inherited from Symbology1D)
Protected Method | GetLength | Overridden.
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

Postnet Class
Telerik.Reporting.Barcodes Namespace


DrawBars Method

Telerik.Reporting.Processing Send comments on this topic.
DrawBars Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Postnet Class : DrawBars Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub DrawBars( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As Postnet
Dim graphics As IGraphics
Dim bounds As RectangleF

instance.DrawBars(graphics, bounds)
C#
protected override void DrawBars(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Postnet Class
Postnet Members


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Postnet Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Postnet
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Postnet Class
Postnet Members


GetLength Method

Telerik.Reporting.Processing Send comments on this topic.
GetLength Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Postnet Class : GetLength Method

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetLength() As Single
Visual Basic (Usage) Copy Code
Dim instance As Postnet
Dim value As Single

value = instance.GetLength()
C#
protected override float GetLength()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Postnet Class
Postnet Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Postnet Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Postnet
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Postnet Class
Postnet Members


Product1D Class

Telerik.Reporting.Processing Send comments on this topic.
Product1D Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Product1D Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private MustInherit Class Product1D
   Inherits Symbology1D
Visual Basic (Usage) Copy Code
Dim instance As Product1D
C#
private abstract class Product1D : Symbology1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Product1D
Telerik.Reporting.Barcodes.EAN13
Telerik.Reporting.Barcodes.EAN8
Telerik.Reporting.Barcodes.UPCA
Telerik.Reporting.Barcodes.UPCE

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Members
Telerik.Reporting.Barcodes Namespace


Product1D Class Members

Telerik.Reporting.Processing Send comments on this topic.
Product1D Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Product1D Class

The following tables list the members exposed by Product1D.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | HeadRect |
Protected Property | HeadText |
Protected Property | LeftRect |
Protected Property | LeftText |
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | RightRect |
Protected Property | RightText |
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TailRect |
Protected Property | TailText |
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | Overridden.
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | Overridden.
Protected Method | GetBarRect | Overridden.
Protected Method | GetClipRect | Overridden.
Protected Method | GetEncoding | (Inherited from Symbology1D)
Protected Method | GetFormat | Overloaded. Overridden.
Protected Method | GetHeadRect |
Protected Method | GetHeadSize |
Protected Method | GetHeadText |
Protected Method | GetLeftRect |
Protected Method | GetLeftText |
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetRightRect |
Protected Method | GetRightText |
Protected Method | GetTailRect |
Protected Method | GetTailSize |
Protected Method | GetTailText |
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | Overridden.
Protected Method | ProcessValue | Overridden.
Protected Method | Validate | (Inherited from SymbologyBase)
Top

See Also

Reference

Product1D Class
Telerik.Reporting.Barcodes Namespace


Product1D Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Product1D Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Product1D Class

For a list of all members of this type, see Product1D members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | Overridden.
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | Overridden.
Protected Method | GetBarRect | Overridden.
Protected Method | GetClipRect | Overridden.
Protected Method | GetEncoding | (Inherited from Symbology1D)
Protected Method | GetFormat | Overloaded. Overridden.
Protected Method | GetHeadRect |
Protected Method | GetHeadSize |
Protected Method | GetHeadText |
Protected Method | GetLeftRect |
Protected Method | GetLeftText |
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetRightRect |
Protected Method | GetRightText |
Protected Method | GetTailRect |
Protected Method | GetTailSize |
Protected Method | GetTailText |
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | Overridden.
Protected Method | ProcessValue | Overridden.
Protected Method | Validate | (Inherited from SymbologyBase)
Top

See Also

Reference

Product1D Class
Telerik.Reporting.Barcodes Namespace


DrawBars Method

Telerik.Reporting.Processing Send comments on this topic.
DrawBars Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : DrawBars Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub DrawBars( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim graphics As IGraphics
Dim bounds As RectangleF

instance.DrawBars(graphics, bounds)
C#
protected override void DrawBars(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


DrawText Method

Telerik.Reporting.Processing Send comments on this topic.
DrawText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : DrawText Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub DrawText( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim graphics As IGraphics
Dim bounds As RectangleF

instance.DrawText(graphics, bounds)
C#
protected override void DrawText(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


GetBarRect Method

Telerik.Reporting.Processing Send comments on this topic.
GetBarRect Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : GetBarRect Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetBarRect( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
) As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim graphics As IGraphics
Dim bounds As RectangleF
Dim value As RectangleF

value = instance.GetBarRect(graphics, bounds)
C#
protected override RectangleF GetBarRect(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


GetClipRect Method

Telerik.Reporting.Processing Send comments on this topic.
GetClipRect Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : GetClipRect Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetClipRect( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
) As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim graphics As IGraphics
Dim bounds As RectangleF
Dim value As RectangleF

value = instance.GetClipRect(graphics, bounds)
C#
protected override RectangleF GetClipRect(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


GetFormat Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : GetFormat Method

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
GetFormat(String) |
GetFormat(String,Int32) |

Overload List

Overload | Description
GetFormat(String) |
GetFormat(String,Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


GetFormat(String) Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat(String) Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class > GetFormat Method : GetFormat(String) Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Protected Function GetFormat( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As String
Dim value As String

value = instance.GetFormat(value)
C#
protected override string GetFormat(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members
Overload List


GetFormat(String,Int32) Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat(String,Int32) Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class > GetFormat Method : GetFormat(String,Int32) Method

value
length

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Function GetFormat( _
   ByVal value As String, _
   ByVal length As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As String
Dim length As Integer
Dim value As String

value = instance.GetFormat(value, length)
C#
protected string GetFormat(
   string value,
   int length
)

Parameters

value
length

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members
Overload List


GetHeadRect Method

Telerik.Reporting.Processing Send comments on this topic.
GetHeadRect Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : GetHeadRect Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetHeadRect( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
) As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim graphics As IGraphics
Dim bounds As RectangleF
Dim value As RectangleF

value = instance.GetHeadRect(graphics, bounds)
C#
protected virtual RectangleF GetHeadRect(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


GetHeadSize Method

Telerik.Reporting.Processing Send comments on this topic.
GetHeadSize Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : GetHeadSize Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetHeadSize( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
) As SizeF
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim graphics As IGraphics
Dim bounds As RectangleF
Dim value As SizeF

value = instance.GetHeadSize(graphics, bounds)
C#
protected virtual SizeF GetHeadSize(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


GetHeadText Method

Telerik.Reporting.Processing Send comments on this topic.
GetHeadText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : GetHeadText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetHeadText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As String
Dim value As String

value = instance.GetHeadText(value)
C#
protected virtual string GetHeadText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


GetLeftRect Method

Telerik.Reporting.Processing Send comments on this topic.
GetLeftRect Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : GetLeftRect Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetLeftRect( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
) As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim graphics As IGraphics
Dim bounds As RectangleF
Dim value As RectangleF

value = instance.GetLeftRect(graphics, bounds)
C#
protected virtual RectangleF GetLeftRect(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


GetLeftText Method

Telerik.Reporting.Processing Send comments on this topic.
GetLeftText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : GetLeftText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetLeftText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As String
Dim value As String

value = instance.GetLeftText(value)
C#
protected virtual string GetLeftText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


GetRightRect Method

Telerik.Reporting.Processing Send comments on this topic.
GetRightRect Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : GetRightRect Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetRightRect( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
) As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim graphics As IGraphics
Dim bounds As RectangleF
Dim value As RectangleF

value = instance.GetRightRect(graphics, bounds)
C#
protected virtual RectangleF GetRightRect(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


GetRightText Method

Telerik.Reporting.Processing Send comments on this topic.
GetRightText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : GetRightText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetRightText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As String
Dim value As String

value = instance.GetRightText(value)
C#
protected virtual string GetRightText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


GetTailRect Method

Telerik.Reporting.Processing Send comments on this topic.
GetTailRect Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : GetTailRect Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTailRect( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
) As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim graphics As IGraphics
Dim bounds As RectangleF
Dim value As RectangleF

value = instance.GetTailRect(graphics, bounds)
C#
protected virtual RectangleF GetTailRect(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


GetTailSize Method

Telerik.Reporting.Processing Send comments on this topic.
GetTailSize Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : GetTailSize Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTailSize( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
) As SizeF
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim graphics As IGraphics
Dim bounds As RectangleF
Dim value As SizeF

value = instance.GetTailSize(graphics, bounds)
C#
protected virtual SizeF GetTailSize(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


GetTailText Method

Telerik.Reporting.Processing Send comments on this topic.
GetTailText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : GetTailText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTailText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As String
Dim value As String

value = instance.GetTailText(value)
C#
protected virtual string GetTailText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


InitRendering Method

Telerik.Reporting.Processing Send comments on this topic.
InitRendering Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : InitRendering Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub InitRendering( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim graphics As IGraphics
Dim bounds As RectangleF

instance.InitRendering(graphics, bounds)
C#
protected override void InitRendering(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


ProcessValue Method

Telerik.Reporting.Processing Send comments on this topic.
ProcessValue Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : ProcessValue Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ProcessValue( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As String

instance.ProcessValue(value)
C#
protected override void ProcessValue(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


Product1D Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Product1D Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Product1D Class

For a list of all members of this type, see Product1D members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | HeadRect |
Protected Property | HeadText |
Protected Property | LeftRect |
Protected Property | LeftText |
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | RightRect |
Protected Property | RightText |
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TailRect |
Protected Property | TailText |
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Product1D Class
Telerik.Reporting.Barcodes Namespace


HeadRect Property

Telerik.Reporting.Processing Send comments on this topic.
HeadRect Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : HeadRect Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property HeadRect As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As RectangleF

value = instance.HeadRect
C#
protected RectangleF HeadRect {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


HeadText Property

Telerik.Reporting.Processing Send comments on this topic.
HeadText Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : HeadText Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property HeadText As String
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As String

value = instance.HeadText
C#
protected string HeadText {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


LeftRect Property

Telerik.Reporting.Processing Send comments on this topic.
LeftRect Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : LeftRect Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property LeftRect As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As RectangleF

value = instance.LeftRect
C#
protected RectangleF LeftRect {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


LeftText Property

Telerik.Reporting.Processing Send comments on this topic.
LeftText Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : LeftText Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property LeftText As String
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As String

value = instance.LeftText
C#
protected string LeftText {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


RightRect Property

Telerik.Reporting.Processing Send comments on this topic.
RightRect Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : RightRect Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property RightRect As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As RectangleF

value = instance.RightRect
C#
protected RectangleF RightRect {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


RightText Property

Telerik.Reporting.Processing Send comments on this topic.
RightText Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : RightText Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property RightText As String
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As String

value = instance.RightText
C#
protected string RightText {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


TailRect Property

Telerik.Reporting.Processing Send comments on this topic.
TailRect Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : TailRect Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property TailRect As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As RectangleF

value = instance.TailRect
C#
protected RectangleF TailRect {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


TailText Property

Telerik.Reporting.Processing Send comments on this topic.
TailText Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Product1D Class : TailText Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property TailText As String
Visual Basic (Usage) Copy Code
Dim instance As Product1D
Dim value As String

value = instance.TailText
C#
protected string TailText {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product1D Class
Product1D Members


SymbolException Class

Telerik.Reporting.Processing Send comments on this topic.
SymbolException Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : SymbolException Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class SymbolException
   Inherits ValidateException
Visual Basic (Usage) Copy Code
Dim instance As SymbolException
C#
private class SymbolException : ValidateException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.ArgumentException
Telerik.Reporting.Barcodes.ValidateException
Telerik.Reporting.Barcodes.SymbolException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbolException Members
Telerik.Reporting.Barcodes Namespace


SymbolException Class Members

Telerik.Reporting.Processing Send comments on this topic.
SymbolException Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : SymbolException Class

The following tables list the members exposed by SymbolException.

Public Constructors

 | Name | Description
Public Constructor | SymbolException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

SymbolException Class
Telerik.Reporting.Barcodes Namespace


SymbolException Constructor

Telerik.Reporting.Processing Send comments on this topic.
SymbolException Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbolException Class : SymbolException Constructor

symbol

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal symbol As Char _
)
Visual Basic (Usage) Copy Code
Dim symbol As Char

Dim instance As SymbolException(symbol)
C#
public SymbolException(
   char symbol
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal symbol As Char _
)
Visual Basic (Usage) Copy Code
Dim symbol As Char

Dim instance As SymbolException(symbol)
C#
public SymbolException(
   char symbol
)

Parameters

symbol

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbolException Class
SymbolException Members


Symbology1D Class

Telerik.Reporting.Processing Send comments on this topic.
Symbology1D Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : Symbology1D Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private MustInherit Class Symbology1D
   Inherits SymbologyBase
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
C#
private abstract class Symbology1D : SymbologyBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Codabar
Telerik.Reporting.Barcodes.Code11
Telerik.Reporting.Barcodes.Code128
Telerik.Reporting.Barcodes.Code25
Telerik.Reporting.Barcodes.Code39
Telerik.Reporting.Barcodes.Code93
Telerik.Reporting.Barcodes.CodeMSI
Telerik.Reporting.Barcodes.Postnet
Telerik.Reporting.Barcodes.Product1D
Telerik.Reporting.Barcodes.UPCSupplement2
Telerik.Reporting.Barcodes.UPCSupplement5

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Members
Telerik.Reporting.Barcodes Namespace


Symbology1D Class Members

Telerik.Reporting.Processing Send comments on this topic.
Symbology1D Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : Symbology1D Class

The following tables list the members exposed by Symbology1D.

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | BarChar |
static (Shared in Visual Basic) | GapChar |
static (Shared in Visual Basic) | TagChar |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect |
Protected Property | ClipRect |
Protected Property | Pattern |
Protected Property | Symbols |
Protected Property | TextRect |
Protected Property | TextSize |
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat |
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars |
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | Overridden.
Protected Method | DrawText |
Protected Method | GetBarRect |
Protected Method | GetClipRect |
Protected Method | GetEncoding |
Protected Method | GetFormat |
Protected Method | GetLength |
Protected Method | GetTextRect |
Protected Method | GetTextSize |
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | Overridden.
Protected Method | ProcessValue | Overridden.
Protected Method | Validate | (Inherited from SymbologyBase)
Top

See Also

Reference

Symbology1D Class
Telerik.Reporting.Barcodes Namespace


Symbology1D Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Symbology1D Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Symbology1D Class

For a list of all members of this type, see Symbology1D members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat |
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars |
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | Overridden.
Protected Method | DrawText |
Protected Method | GetBarRect |
Protected Method | GetClipRect |
Protected Method | GetEncoding |
Protected Method | GetFormat |
Protected Method | GetLength |
Protected Method | GetTextRect |
Protected Method | GetTextSize |
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | Overridden.
Protected Method | ProcessValue | Overridden.
Protected Method | Validate | (Inherited from SymbologyBase)
Top

See Also

Reference

Symbology1D Class
Telerik.Reporting.Barcodes Namespace


CreateStringFormat Method

Telerik.Reporting.Processing Send comments on this topic.
CreateStringFormat Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : CreateStringFormat Method

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function CreateStringFormat() As StringFormat
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim value As StringFormat

value = instance.CreateStringFormat()
C#
protected StringFormat CreateStringFormat()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


DrawBars Method

Telerik.Reporting.Processing Send comments on this topic.
DrawBars Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : DrawBars Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DrawBars( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim graphics As IGraphics
Dim bounds As RectangleF

instance.DrawBars(graphics, bounds)
C#
protected virtual void DrawBars(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


DrawForeground Method

Telerik.Reporting.Processing Send comments on this topic.
DrawForeground Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : DrawForeground Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub DrawForeground( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim graphics As IGraphics
Dim bounds As RectangleF

instance.DrawForeground(graphics, bounds)
C#
protected override void DrawForeground(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


DrawText Method

Telerik.Reporting.Processing Send comments on this topic.
DrawText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : DrawText Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DrawText( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim graphics As IGraphics
Dim bounds As RectangleF

instance.DrawText(graphics, bounds)
C#
protected virtual void DrawText(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


GetBarRect Method

Telerik.Reporting.Processing Send comments on this topic.
GetBarRect Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : GetBarRect Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetBarRect( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
) As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim graphics As IGraphics
Dim bounds As RectangleF
Dim value As RectangleF

value = instance.GetBarRect(graphics, bounds)
C#
protected virtual RectangleF GetBarRect(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


GetClipRect Method

Telerik.Reporting.Processing Send comments on this topic.
GetClipRect Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : GetClipRect Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetClipRect( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
) As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim graphics As IGraphics
Dim bounds As RectangleF
Dim value As RectangleF

value = instance.GetClipRect(graphics, bounds)
C#
protected virtual RectangleF GetClipRect(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected virtual string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


GetFormat Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : GetFormat Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetFormat( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim value As String
Dim value As String

value = instance.GetFormat(value)
C#
protected virtual string GetFormat(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


GetLength Method

Telerik.Reporting.Processing Send comments on this topic.
GetLength Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : GetLength Method

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetLength() As Single
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim value As Single

value = instance.GetLength()
C#
protected virtual float GetLength()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


GetTextRect Method

Telerik.Reporting.Processing Send comments on this topic.
GetTextRect Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : GetTextRect Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTextRect( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
) As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim graphics As IGraphics
Dim bounds As RectangleF
Dim value As RectangleF

value = instance.GetTextRect(graphics, bounds)
C#
protected virtual RectangleF GetTextRect(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


GetTextSize Method

Telerik.Reporting.Processing Send comments on this topic.
GetTextSize Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : GetTextSize Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTextSize( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
) As SizeF
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim graphics As IGraphics
Dim bounds As RectangleF
Dim value As SizeF

value = instance.GetTextSize(graphics, bounds)
C#
protected virtual SizeF GetTextSize(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


InitRendering Method

Telerik.Reporting.Processing Send comments on this topic.
InitRendering Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : InitRendering Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub InitRendering( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim graphics As IGraphics
Dim bounds As RectangleF

instance.InitRendering(graphics, bounds)
C#
protected override void InitRendering(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


ProcessValue Method

Telerik.Reporting.Processing Send comments on this topic.
ProcessValue Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : ProcessValue Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ProcessValue( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim value As String

instance.ProcessValue(value)
C#
protected override void ProcessValue(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


Symbology1D Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Symbology1D Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Symbology1D Class

For a list of all members of this type, see Symbology1D members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect |
Protected Property | ClipRect |
Protected Property | Pattern |
Protected Property | Symbols |
Protected Property | TextRect |
Protected Property | TextSize |
Top

See Also

Reference

Symbology1D Class
Telerik.Reporting.Barcodes Namespace


BarRect Property

Telerik.Reporting.Processing Send comments on this topic.
BarRect Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : BarRect Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property BarRect As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim value As RectangleF

value = instance.BarRect
C#
protected RectangleF BarRect {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


ClipRect Property

Telerik.Reporting.Processing Send comments on this topic.
ClipRect Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : ClipRect Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ClipRect As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim value As RectangleF

value = instance.ClipRect
C#
protected RectangleF ClipRect {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


Pattern Property

Telerik.Reporting.Processing Send comments on this topic.
Pattern Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : Pattern Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Pattern As String
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim value As String

value = instance.Pattern
C#
protected string Pattern {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


Symbols Property

Telerik.Reporting.Processing Send comments on this topic.
Symbols Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : Symbols Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Symbols As String
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim value As String

value = instance.Symbols
C#
protected string Symbols {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


TextRect Property

Telerik.Reporting.Processing Send comments on this topic.
TextRect Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : TextRect Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property TextRect As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim value As RectangleF

value = instance.TextRect
C#
protected RectangleF TextRect {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


TextSize Property

Telerik.Reporting.Processing Send comments on this topic.
TextSize Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : TextSize Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property TextSize As SizeF
Visual Basic (Usage) Copy Code
Dim instance As Symbology1D
Dim value As SizeF

value = instance.TextSize
C#
protected SizeF TextSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


Symbology1D Class Fields

Telerik.Reporting.Processing Send comments on this topic.
Symbology1D Class Fields
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Symbology1D Class

For a list of all members of this type, see Symbology1D members.

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | BarChar |
static (Shared in Visual Basic) | GapChar |
static (Shared in Visual Basic) | TagChar |
Top

See Also

Reference

Symbology1D Class
Telerik.Reporting.Barcodes Namespace


BarChar Field

Telerik.Reporting.Processing Send comments on this topic.
BarChar Field
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : BarChar Field

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Shared ReadOnly BarChar As Char
Visual Basic (Usage) Copy Code
Dim value As Char

value = Symbology1D.BarChar
C#
protected static readonly char BarChar

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


GapChar Field

Telerik.Reporting.Processing Send comments on this topic.
GapChar Field
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : GapChar Field

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Shared ReadOnly GapChar As Char
Visual Basic (Usage) Copy Code
Dim value As Char

value = Symbology1D.GapChar
C#
protected static readonly char GapChar

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


TagChar Field

Telerik.Reporting.Processing Send comments on this topic.
TagChar Field
See Also
[image]
Telerik.Reporting.Barcodes Namespace > Symbology1D Class : TagChar Field

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Shared ReadOnly TagChar As Char
Visual Basic (Usage) Copy Code
Dim value As Char

value = Symbology1D.TagChar
C#
protected static readonly char TagChar

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Symbology1D Class
Symbology1D Members


SymbologyBase Class

Telerik.Reporting.Processing Send comments on this topic.
SymbologyBase Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : SymbologyBase Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private MustInherit Class SymbologyBase
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
C#
private abstract class SymbologyBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Members
Telerik.Reporting.Barcodes Namespace


SymbologyBase Class Members

Telerik.Reporting.Processing Send comments on this topic.
SymbologyBase Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : SymbologyBase Class

The following tables list the members exposed by SymbologyBase.

Public Properties

 | Name | Description
Public Property | Angle |
Public Property | BackColor |
Public Property | BarAlign |
Public Property | Checksum |
Public Property | Font |
Public Property | ForeColor |
Public Property | Module |
Public Property | ShowText |
Public Property | Stretch |
Public Property | TextHorizontalAlign |
Public Property | TextVerticalAlign |
Public Property | Value |
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded.
Top

Protected Methods

 | Name | Description
Protected Method | DrawBackground |
Protected Method | DrawException |
Protected Method | DrawForeground |
Protected Method | InitGraphics |
Protected Method | InitRendering |
Protected Method | ProcessValue |
Protected Method | Validate |
Top

See Also

Reference

SymbologyBase Class
Telerik.Reporting.Barcodes Namespace


SymbologyBase Class Methods

Telerik.Reporting.Processing Send comments on this topic.
SymbologyBase Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : SymbologyBase Class

For a list of all members of this type, see SymbologyBase members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded.
Top

Protected Methods

 | Name | Description
Protected Method | DrawBackground |
Protected Method | DrawException |
Protected Method | DrawForeground |
Protected Method | InitGraphics |
Protected Method | InitRendering |
Protected Method | ProcessValue |
Protected Method | Validate |
Top

See Also

Reference

SymbologyBase Class
Telerik.Reporting.Barcodes Namespace


Draw Method

Telerik.Reporting.Processing Send comments on this topic.
Draw Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : Draw Method

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
Draw(Graphics,RectangleF) |
Draw(IGraphics,RectangleF) |

Overload List

Overload | Description
Draw(Graphics,RectangleF) |
Draw(IGraphics,RectangleF) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


Draw(Graphics,RectangleF) Method

Telerik.Reporting.Processing Send comments on this topic.
Draw(Graphics,RectangleF) Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class > Draw Method : Draw(Graphics,RectangleF) Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Draw( _
   ByVal graphics As Graphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim graphics As Graphics
Dim bounds As RectangleF

instance.Draw(graphics, bounds)
C#
public void Draw(
   Graphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members
Overload List


Draw(IGraphics,RectangleF) Method

Telerik.Reporting.Processing Send comments on this topic.
Draw(IGraphics,RectangleF) Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class > Draw Method : Draw(IGraphics,RectangleF) Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Draw( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim graphics As IGraphics
Dim bounds As RectangleF

instance.Draw(graphics, bounds)
C#
public void Draw(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members
Overload List


DrawBackground Method

Telerik.Reporting.Processing Send comments on this topic.
DrawBackground Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : DrawBackground Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DrawBackground( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim graphics As IGraphics
Dim bounds As RectangleF

instance.DrawBackground(graphics, bounds)
C#
protected virtual void DrawBackground(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


DrawException Method

Telerik.Reporting.Processing Send comments on this topic.
DrawException Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : DrawException Method

graphics
bounds
exception

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DrawException( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF, _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim graphics As IGraphics
Dim bounds As RectangleF
Dim exception As Exception

instance.DrawException(graphics, bounds, exception)
C#
protected virtual void DrawException(
   IGraphics graphics,
   RectangleF bounds,
   Exception exception
)

Parameters

graphics
bounds
exception

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


DrawForeground Method

Telerik.Reporting.Processing Send comments on this topic.
DrawForeground Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : DrawForeground Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DrawForeground( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim graphics As IGraphics
Dim bounds As RectangleF

instance.DrawForeground(graphics, bounds)
C#
protected virtual void DrawForeground(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


InitGraphics Method

Telerik.Reporting.Processing Send comments on this topic.
InitGraphics Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : InitGraphics Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitGraphics( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim graphics As IGraphics
Dim bounds As RectangleF

instance.InitGraphics(graphics, bounds)
C#
protected virtual void InitGraphics(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


InitRendering Method

Telerik.Reporting.Processing Send comments on this topic.
InitRendering Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : InitRendering Method

graphics
bounds

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitRendering( _
   ByVal graphics As IGraphics, _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim graphics As IGraphics
Dim bounds As RectangleF

instance.InitRendering(graphics, bounds)
C#
protected virtual void InitRendering(
   IGraphics graphics,
   RectangleF bounds
)

Parameters

graphics
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


ProcessValue Method

Telerik.Reporting.Processing Send comments on this topic.
ProcessValue Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : ProcessValue Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ProcessValue( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As String

instance.ProcessValue(value)
C#
protected virtual void ProcessValue(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As String

instance.Validate(value)
C#
protected virtual void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


SymbologyBase Class Properties

Telerik.Reporting.Processing Send comments on this topic.
SymbologyBase Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : SymbologyBase Class

For a list of all members of this type, see SymbologyBase members.

Public Properties

 | Name | Description
Public Property | Angle |
Public Property | BackColor |
Public Property | BarAlign |
Public Property | Checksum |
Public Property | Font |
Public Property | ForeColor |
Public Property | Module |
Public Property | ShowText |
Public Property | Stretch |
Public Property | TextHorizontalAlign |
Public Property | TextVerticalAlign |
Public Property | Value |
Top

See Also

Reference

SymbologyBase Class
Telerik.Reporting.Barcodes Namespace


Angle Property

Telerik.Reporting.Processing Send comments on this topic.
Angle Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : Angle Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Angle As Single
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As Single

instance.Angle = value

value = instance.Angle
C#
public float Angle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


BackColor Property

Telerik.Reporting.Processing Send comments on this topic.
BackColor Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : BackColor Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
public Color BackColor {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


BarAlign Property

Telerik.Reporting.Processing Send comments on this topic.
BarAlign Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : BarAlign Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property BarAlign As StringAlignment
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As StringAlignment

instance.BarAlign = value

value = instance.BarAlign
C#
public StringAlignment BarAlign {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


Checksum Property

Telerik.Reporting.Processing Send comments on this topic.
Checksum Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : Checksum Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Checksum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As Boolean

instance.Checksum = value

value = instance.Checksum
C#
public bool Checksum {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


Font Property

Telerik.Reporting.Processing Send comments on this topic.
Font Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : Font Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As Font

instance.Font = value

value = instance.Font
C#
public Font Font {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


ForeColor Property

Telerik.Reporting.Processing Send comments on this topic.
ForeColor Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : ForeColor Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
public Color ForeColor {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


Module Property

Telerik.Reporting.Processing Send comments on this topic.
Module Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : Module Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Module As Single
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As Single

instance.Module = value

value = instance.Module
C#
public float Module {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


ShowText Property

Telerik.Reporting.Processing Send comments on this topic.
ShowText Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : ShowText Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowText As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As Boolean

instance.ShowText = value

value = instance.ShowText
C#
public bool ShowText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


Stretch Property

Telerik.Reporting.Processing Send comments on this topic.
Stretch Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : Stretch Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Stretch As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As Boolean

instance.Stretch = value

value = instance.Stretch
C#
public bool Stretch {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


TextHorizontalAlign Property

Telerik.Reporting.Processing Send comments on this topic.
TextHorizontalAlign Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : TextHorizontalAlign Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property TextHorizontalAlign As StringAlignment
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As StringAlignment

instance.TextHorizontalAlign = value

value = instance.TextHorizontalAlign
C#
public StringAlignment TextHorizontalAlign {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


TextVerticalAlign Property

Telerik.Reporting.Processing Send comments on this topic.
TextVerticalAlign Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : TextVerticalAlign Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property TextVerticalAlign As StringAlignment
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As StringAlignment

instance.TextVerticalAlign = value

value = instance.TextVerticalAlign
C#
public StringAlignment TextVerticalAlign {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


Value Property

Telerik.Reporting.Processing Send comments on this topic.
Value Property
See Also
[image]
Telerik.Reporting.Barcodes Namespace > SymbologyBase Class : Value Property

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As SymbologyBase
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SymbologyBase Class
SymbologyBase Members


UPCA Class

Telerik.Reporting.Processing Send comments on this topic.
UPCA Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : UPCA Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class UPCA
   Inherits Product1D
Visual Basic (Usage) Copy Code
Dim instance As UPCA
C#
private class UPCA : Product1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Product1D
Telerik.Reporting.Barcodes.UPCA

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCA Members
Telerik.Reporting.Barcodes Namespace


UPCA Class Members

Telerik.Reporting.Processing Send comments on this topic.
UPCA Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : UPCA Class

The following tables list the members exposed by UPCA.

Public Constructors

 | Name | Description
Public Constructor | UPCA Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | HeadRect | (Inherited from Product1D)
Protected Property | HeadText | (Inherited from Product1D)
Protected Property | LeftRect | (Inherited from Product1D)
Protected Property | LeftText | (Inherited from Product1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | RightRect | (Inherited from Product1D)
Protected Property | RightText | (Inherited from Product1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TailRect | (Inherited from Product1D)
Protected Property | TailText | (Inherited from Product1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Product1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Product1D)
Protected Method | GetBarRect | (Inherited from Product1D)
Protected Method | GetClipRect | (Inherited from Product1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | Overloaded. Overridden.
Protected Method | GetHeadRect | (Inherited from Product1D)
Protected Method | GetHeadSize | (Inherited from Product1D)
Protected Method | GetHeadText | Overridden.
Protected Method | GetLeftRect | (Inherited from Product1D)
Protected Method | GetLeftText | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetRightRect | (Inherited from Product1D)
Protected Method | GetRightText | Overridden.
Protected Method | GetTailRect | (Inherited from Product1D)
Protected Method | GetTailSize | (Inherited from Product1D)
Protected Method | GetTailText | Overridden.
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Product1D)
Protected Method | ProcessValue | (Inherited from Product1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

UPCA Class
Telerik.Reporting.Barcodes Namespace


UPCA Constructor

Telerik.Reporting.Processing Send comments on this topic.
UPCA Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCA Class : UPCA Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UPCA()
C#
public UPCA()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UPCA()
C#
public UPCA()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCA Class
UPCA Members


UPCA Class Methods

Telerik.Reporting.Processing Send comments on this topic.
UPCA Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : UPCA Class

For a list of all members of this type, see UPCA members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Product1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Product1D)
Protected Method | GetBarRect | (Inherited from Product1D)
Protected Method | GetClipRect | (Inherited from Product1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | Overloaded. Overridden.
Protected Method | GetHeadRect | (Inherited from Product1D)
Protected Method | GetHeadSize | (Inherited from Product1D)
Protected Method | GetHeadText | Overridden.
Protected Method | GetLeftRect | (Inherited from Product1D)
Protected Method | GetLeftText | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetRightRect | (Inherited from Product1D)
Protected Method | GetRightText | Overridden.
Protected Method | GetTailRect | (Inherited from Product1D)
Protected Method | GetTailSize | (Inherited from Product1D)
Protected Method | GetTailText | Overridden.
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Product1D)
Protected Method | ProcessValue | (Inherited from Product1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

UPCA Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCA Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCA
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCA Class
UPCA Members


GetFormat Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCA Class : GetFormat Method

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
GetFormat(String) |
GetFormat(String,Int32) | (Inherited from Product1D)

Overload List

Overload | Description
GetFormat(String) |
GetFormat(String,Int32) | (Inherited from Product1D)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCA Class
UPCA Members


GetFormat(String) Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat(String) Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCA Class > GetFormat Method : GetFormat(String) Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Protected Function GetFormat( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCA
Dim value As String
Dim value As String

value = instance.GetFormat(value)
C#
protected override string GetFormat(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCA Class
UPCA Members
Overload List


GetHeadText Method

Telerik.Reporting.Processing Send comments on this topic.
GetHeadText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCA Class : GetHeadText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetHeadText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCA
Dim value As String
Dim value As String

value = instance.GetHeadText(value)
C#
protected override string GetHeadText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCA Class
UPCA Members


GetLeftText Method

Telerik.Reporting.Processing Send comments on this topic.
GetLeftText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCA Class : GetLeftText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetLeftText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCA
Dim value As String
Dim value As String

value = instance.GetLeftText(value)
C#
protected override string GetLeftText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCA Class
UPCA Members


GetRightText Method

Telerik.Reporting.Processing Send comments on this topic.
GetRightText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCA Class : GetRightText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetRightText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCA
Dim value As String
Dim value As String

value = instance.GetRightText(value)
C#
protected override string GetRightText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCA Class
UPCA Members


GetTailText Method

Telerik.Reporting.Processing Send comments on this topic.
GetTailText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCA Class : GetTailText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetTailText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCA
Dim value As String
Dim value As String

value = instance.GetTailText(value)
C#
protected override string GetTailText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCA Class
UPCA Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCA Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As UPCA
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCA Class
UPCA Members


UPCE Class

Telerik.Reporting.Processing Send comments on this topic.
UPCE Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : UPCE Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class UPCE
   Inherits Product1D
Visual Basic (Usage) Copy Code
Dim instance As UPCE
C#
private class UPCE : Product1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Product1D
Telerik.Reporting.Barcodes.UPCE

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCE Members
Telerik.Reporting.Barcodes Namespace


UPCE Class Members

Telerik.Reporting.Processing Send comments on this topic.
UPCE Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : UPCE Class

The following tables list the members exposed by UPCE.

Public Constructors

 | Name | Description
Public Constructor | UPCE Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | HeadRect | (Inherited from Product1D)
Protected Property | HeadText | (Inherited from Product1D)
Protected Property | LeftRect | (Inherited from Product1D)
Protected Property | LeftText | (Inherited from Product1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | RightRect | (Inherited from Product1D)
Protected Property | RightText | (Inherited from Product1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TailRect | (Inherited from Product1D)
Protected Property | TailText | (Inherited from Product1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Product1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Product1D)
Protected Method | GetBarRect | (Inherited from Product1D)
Protected Method | GetClipRect | (Inherited from Product1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | Overloaded. Overridden.
Protected Method | GetHeadRect | (Inherited from Product1D)
Protected Method | GetHeadSize | (Inherited from Product1D)
Protected Method | GetHeadText | Overridden.
Protected Method | GetLeftRect | (Inherited from Product1D)
Protected Method | GetLeftText | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetRightRect | (Inherited from Product1D)
Protected Method | GetRightText | (Inherited from Product1D)
Protected Method | GetTailRect | (Inherited from Product1D)
Protected Method | GetTailSize | (Inherited from Product1D)
Protected Method | GetTailText | Overridden.
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Product1D)
Protected Method | ProcessValue | (Inherited from Product1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

UPCE Class
Telerik.Reporting.Barcodes Namespace


UPCE Constructor

Telerik.Reporting.Processing Send comments on this topic.
UPCE Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCE Class : UPCE Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UPCE()
C#
public UPCE()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UPCE()
C#
public UPCE()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCE Class
UPCE Members


UPCE Class Methods

Telerik.Reporting.Processing Send comments on this topic.
UPCE Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : UPCE Class

For a list of all members of this type, see UPCE members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Product1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Product1D)
Protected Method | GetBarRect | (Inherited from Product1D)
Protected Method | GetClipRect | (Inherited from Product1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | Overloaded. Overridden.
Protected Method | GetHeadRect | (Inherited from Product1D)
Protected Method | GetHeadSize | (Inherited from Product1D)
Protected Method | GetHeadText | Overridden.
Protected Method | GetLeftRect | (Inherited from Product1D)
Protected Method | GetLeftText | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetRightRect | (Inherited from Product1D)
Protected Method | GetRightText | (Inherited from Product1D)
Protected Method | GetTailRect | (Inherited from Product1D)
Protected Method | GetTailSize | (Inherited from Product1D)
Protected Method | GetTailText | Overridden.
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Product1D)
Protected Method | ProcessValue | (Inherited from Product1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

UPCE Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCE Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCE
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCE Class
UPCE Members


GetFormat Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCE Class : GetFormat Method

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
GetFormat(String) |
GetFormat(String,Int32) | (Inherited from Product1D)

Overload List

Overload | Description
GetFormat(String) |
GetFormat(String,Int32) | (Inherited from Product1D)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCE Class
UPCE Members


GetFormat(String) Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat(String) Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCE Class > GetFormat Method : GetFormat(String) Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Protected Function GetFormat( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCE
Dim value As String
Dim value As String

value = instance.GetFormat(value)
C#
protected override string GetFormat(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCE Class
UPCE Members
Overload List


GetHeadText Method

Telerik.Reporting.Processing Send comments on this topic.
GetHeadText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCE Class : GetHeadText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetHeadText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCE
Dim value As String
Dim value As String

value = instance.GetHeadText(value)
C#
protected override string GetHeadText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCE Class
UPCE Members


GetLeftText Method

Telerik.Reporting.Processing Send comments on this topic.
GetLeftText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCE Class : GetLeftText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetLeftText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCE
Dim value As String
Dim value As String

value = instance.GetLeftText(value)
C#
protected override string GetLeftText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCE Class
UPCE Members


GetTailText Method

Telerik.Reporting.Processing Send comments on this topic.
GetTailText Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCE Class : GetTailText Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetTailText( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCE
Dim value As String
Dim value As String

value = instance.GetTailText(value)
C#
protected override string GetTailText(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCE Class
UPCE Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCE Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As UPCE
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCE Class
UPCE Members


UPCSupplement2 Class

Telerik.Reporting.Processing Send comments on this topic.
UPCSupplement2 Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : UPCSupplement2 Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class UPCSupplement2
   Inherits Symbology1D
Visual Basic (Usage) Copy Code
Dim instance As UPCSupplement2
C#
private class UPCSupplement2 : Symbology1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.UPCSupplement2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCSupplement2 Members
Telerik.Reporting.Barcodes Namespace


UPCSupplement2 Class Members

Telerik.Reporting.Processing Send comments on this topic.
UPCSupplement2 Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : UPCSupplement2 Class

The following tables list the members exposed by UPCSupplement2.

Public Constructors

 | Name | Description
Public Constructor | UPCSupplement2 Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

UPCSupplement2 Class
Telerik.Reporting.Barcodes Namespace


UPCSupplement2 Constructor

Telerik.Reporting.Processing Send comments on this topic.
UPCSupplement2 Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCSupplement2 Class : UPCSupplement2 Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UPCSupplement2()
C#
public UPCSupplement2()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UPCSupplement2()
C#
public UPCSupplement2()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCSupplement2 Class
UPCSupplement2 Members


UPCSupplement2 Class Methods

Telerik.Reporting.Processing Send comments on this topic.
UPCSupplement2 Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : UPCSupplement2 Class

For a list of all members of this type, see UPCSupplement2 members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

UPCSupplement2 Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCSupplement2 Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCSupplement2
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCSupplement2 Class
UPCSupplement2 Members


GetFormat Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCSupplement2 Class : GetFormat Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetFormat( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCSupplement2
Dim value As String
Dim value As String

value = instance.GetFormat(value)
C#
protected override string GetFormat(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCSupplement2 Class
UPCSupplement2 Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCSupplement2 Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As UPCSupplement2
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCSupplement2 Class
UPCSupplement2 Members


UPCSupplement5 Class

Telerik.Reporting.Processing Send comments on this topic.
UPCSupplement5 Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : UPCSupplement5 Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class UPCSupplement5
   Inherits Symbology1D
Visual Basic (Usage) Copy Code
Dim instance As UPCSupplement5
C#
private class UPCSupplement5 : Symbology1D

Inheritance Hierarchy

System.Object
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.UPCSupplement5

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCSupplement5 Members
Telerik.Reporting.Barcodes Namespace


UPCSupplement5 Class Members

Telerik.Reporting.Processing Send comments on this topic.
UPCSupplement5 Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : UPCSupplement5 Class

The following tables list the members exposed by UPCSupplement5.

Public Constructors

 | Name | Description
Public Constructor | UPCSupplement5 Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

UPCSupplement5 Class
Telerik.Reporting.Barcodes Namespace


UPCSupplement5 Constructor

Telerik.Reporting.Processing Send comments on this topic.
UPCSupplement5 Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCSupplement5 Class : UPCSupplement5 Constructor

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UPCSupplement5()
C#
public UPCSupplement5()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UPCSupplement5()
C#
public UPCSupplement5()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCSupplement5 Class
UPCSupplement5 Members


UPCSupplement5 Class Methods

Telerik.Reporting.Processing Send comments on this topic.
UPCSupplement5 Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : UPCSupplement5 Class

For a list of all members of this type, see UPCSupplement5 members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. (Inherited from SymbologyBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStringFormat | (Inherited from Symbology1D)
Protected Method | DrawBackground | (Inherited from SymbologyBase)
Protected Method | DrawBars | (Inherited from Symbology1D)
Protected Method | DrawException | (Inherited from SymbologyBase)
Protected Method | DrawForeground | (Inherited from Symbology1D)
Protected Method | DrawText | (Inherited from Symbology1D)
Protected Method | GetBarRect | (Inherited from Symbology1D)
Protected Method | GetClipRect | (Inherited from Symbology1D)
Protected Method | GetEncoding | Overridden.
Protected Method | GetFormat | Overridden.
Protected Method | GetLength | (Inherited from Symbology1D)
Protected Method | GetTextRect | (Inherited from Symbology1D)
Protected Method | GetTextSize | (Inherited from Symbology1D)
Protected Method | InitGraphics | (Inherited from SymbologyBase)
Protected Method | InitRendering | (Inherited from Symbology1D)
Protected Method | ProcessValue | (Inherited from Symbology1D)
Protected Method | Validate | Overridden.
Top

See Also

Reference

UPCSupplement5 Class
Telerik.Reporting.Barcodes Namespace


GetEncoding Method

Telerik.Reporting.Processing Send comments on this topic.
GetEncoding Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCSupplement5 Class : GetEncoding Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetEncoding( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCSupplement5
Dim value As String
Dim value As String

value = instance.GetEncoding(value)
C#
protected override string GetEncoding(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCSupplement5 Class
UPCSupplement5 Members


GetFormat Method

Telerik.Reporting.Processing Send comments on this topic.
GetFormat Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCSupplement5 Class : GetFormat Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetFormat( _
   ByVal value As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UPCSupplement5
Dim value As String
Dim value As String

value = instance.GetFormat(value)
C#
protected override string GetFormat(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCSupplement5 Class
UPCSupplement5 Members


Validate Method

Telerik.Reporting.Processing Send comments on this topic.
Validate Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > UPCSupplement5 Class : Validate Method

value

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Validate( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As UPCSupplement5
Dim value As String

instance.Validate(value)
C#
protected override void Validate(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCSupplement5 Class
UPCSupplement5 Members


ValidateException Class

Telerik.Reporting.Processing Send comments on this topic.
ValidateException Class
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : ValidateException Class

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class ValidateException
   Inherits ArgumentException
Visual Basic (Usage) Copy Code
Dim instance As ValidateException
C#
private class ValidateException : ArgumentException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.ArgumentException
Telerik.Reporting.Barcodes.ValidateException
Telerik.Reporting.Barcodes.FormatException
Telerik.Reporting.Barcodes.LengthException
Telerik.Reporting.Barcodes.SymbolException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ValidateException Members
Telerik.Reporting.Barcodes Namespace


ValidateException Class Members

Telerik.Reporting.Processing Send comments on this topic.
ValidateException Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Barcodes Namespace : ValidateException Class

The following tables list the members exposed by ValidateException.

Public Constructors

 | Name | Description
Public Constructor | ValidateException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ValidateException Class
Telerik.Reporting.Barcodes Namespace


ValidateException Constructor

Telerik.Reporting.Processing Send comments on this topic.
ValidateException Constructor
See Also
[image]
Telerik.Reporting.Barcodes Namespace > ValidateException Class : ValidateException Constructor

message

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As ValidateException(message)
C#
public ValidateException(
   string message
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As ValidateException(message)
C#
public ValidateException(
   string message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ValidateException Class
ValidateException Members


IGraphics Interface

Telerik.Reporting.Processing Send comments on this topic.
IGraphics Interface
See Also Members
[image]
Telerik.Reporting.Barcodes Namespace : IGraphics Interface

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Interface IGraphics
Visual Basic (Usage) Copy Code
Dim instance As IGraphics
C#
private interface IGraphics

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IGraphics Members
Telerik.Reporting.Barcodes Namespace


IGraphics Interface Members

Telerik.Reporting.Processing Send comments on this topic.
IGraphics Interface Members
See Also Methods
[image]
Telerik.Reporting.Barcodes Namespace : IGraphics Interface

The following tables list the members exposed by IGraphics.

Public Methods

 | Name | Description
Method | DrawString |
Method | FillRectangle |
Method | MeasureString |
Method | Restore |
Method | RotateTransform |
Method | Save |
Method | SetClip |
Method | TranslateTransform |
Top

See Also

Reference

IGraphics Interface
Telerik.Reporting.Barcodes Namespace


IGraphics Interface Methods

Telerik.Reporting.Processing Send comments on this topic.
IGraphics Interface Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : IGraphics Interface

For a list of all members of this type, see IGraphics members.

Public Methods

 | Name | Description
Method | DrawString |
Method | FillRectangle |
Method | MeasureString |
Method | Restore |
Method | RotateTransform |
Method | Save |
Method | SetClip |
Method | TranslateTransform |
Top

See Also

Reference

IGraphics Interface
Telerik.Reporting.Barcodes Namespace


DrawString Method

Telerik.Reporting.Processing Send comments on this topic.
DrawString Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > IGraphics Interface : DrawString Method

s
font
brush
bounds
stringFormat

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Sub DrawString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal bounds As RectangleF, _
   ByVal stringFormat As StringFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As IGraphics
Dim s As String
Dim font As Font
Dim brush As Brush
Dim bounds As RectangleF
Dim stringFormat As StringFormat

instance.DrawString(s, font, brush, bounds, stringFormat)
C#
void DrawString(
   string s,
   Font font,
   Brush brush,
   RectangleF bounds,
   StringFormat stringFormat
)

Parameters

s
font
brush
bounds
stringFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IGraphics Interface
IGraphics Members


FillRectangle Method

Telerik.Reporting.Processing Send comments on this topic.
FillRectangle Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > IGraphics Interface : FillRectangle Method

brush
rect

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Sub FillRectangle( _
   ByVal brush As Brush, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As IGraphics
Dim brush As Brush
Dim rect As RectangleF

instance.FillRectangle(brush, rect)
C#
void FillRectangle(
   Brush brush,
   RectangleF rect
)

Parameters

brush
rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IGraphics Interface
IGraphics Members


MeasureString Method

Telerik.Reporting.Processing Send comments on this topic.
MeasureString Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > IGraphics Interface : MeasureString Method

s
font
layoutArea
format
charactersFitted
linesFilled

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Function MeasureString( _
   ByVal s As String, _
   ByVal font As Font, _
   ByVal layoutArea As SizeF, _
   ByVal format As StringFormat, _
   ByRef charactersFitted As Integer, _
   ByRef linesFilled As Integer _
) As SizeF
Visual Basic (Usage) Copy Code
Dim instance As IGraphics
Dim s As String
Dim font As Font
Dim layoutArea As SizeF
Dim format As StringFormat
Dim charactersFitted As Integer
Dim linesFilled As Integer
Dim value As SizeF

value = instance.MeasureString(s, font, layoutArea, format, charactersFitted, linesFilled)
C#
SizeF MeasureString(
   string s,
   Font font,
   SizeF layoutArea,
   StringFormat format,
   out int charactersFitted,
   out int linesFilled
)

Parameters

s
font
layoutArea
format
charactersFitted
linesFilled

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IGraphics Interface
IGraphics Members


Restore Method

Telerik.Reporting.Processing Send comments on this topic.
Restore Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > IGraphics Interface : Restore Method

graphicsState

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Sub Restore( _
   ByVal graphicsState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As IGraphics
Dim graphicsState As Object

instance.Restore(graphicsState)
C#
void Restore(
   object graphicsState
)

Parameters

graphicsState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IGraphics Interface
IGraphics Members


RotateTransform Method

Telerik.Reporting.Processing Send comments on this topic.
RotateTransform Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > IGraphics Interface : RotateTransform Method

angle

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Sub RotateTransform( _
   ByVal angle As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As IGraphics
Dim angle As Single

instance.RotateTransform(angle)
C#
void RotateTransform(
   float angle
)

Parameters

angle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IGraphics Interface
IGraphics Members


Save Method

Telerik.Reporting.Processing Send comments on this topic.
Save Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > IGraphics Interface : Save Method

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Function Save() As Object
Visual Basic (Usage) Copy Code
Dim instance As IGraphics
Dim value As Object

value = instance.Save()
C#
object Save()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IGraphics Interface
IGraphics Members


SetClip Method

Telerik.Reporting.Processing Send comments on this topic.
SetClip Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > IGraphics Interface : SetClip Method

rect
combineMode

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Sub SetClip( _
   ByVal rect As RectangleF, _
   ByVal combineMode As CombineMode _
)
Visual Basic (Usage) Copy Code
Dim instance As IGraphics
Dim rect As RectangleF
Dim combineMode As CombineMode

instance.SetClip(rect, combineMode)
C#
void SetClip(
   RectangleF rect,
   CombineMode combineMode
)

Parameters

rect
combineMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IGraphics Interface
IGraphics Members


TranslateTransform Method

Telerik.Reporting.Processing Send comments on this topic.
TranslateTransform Method
See Also
[image]
Telerik.Reporting.Barcodes Namespace > IGraphics Interface : TranslateTransform Method

x
y

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Sub TranslateTransform( _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As IGraphics
Dim x As Single
Dim y As Single

instance.TranslateTransform(x, y)
C#
void TranslateTransform(
   float x,
   float y
)

Parameters

x
y

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IGraphics Interface
IGraphics Members


ActiveRegion Class

ActiveRegion Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ActiveRegion Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ActiveRegion
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion
C#
public class ActiveRegion : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.ActiveRegion

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Members
Telerik.Reporting.Charting Namespace


ActiveRegion Class Members

ActiveRegion Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting.Charting Namespace : ActiveRegion Class

The following tables list the members exposed by ActiveRegion.

Public Constructors

 | Name | Description
Public Constructor | ActiveRegion Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Attributes |
Public Property | Parent |
Public Property | Region |
Public Property | Tooltip |
Public Property | Url |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | CheckPoint | Overloaded.
Public Method | GoToUrl |
Public Method | IsEmpty |
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | (Inherited from StateManagedObject)
Protected Method | SaveViewState | (Inherited from StateManagedObject)
Protected Method | TrackViewState | (Inherited from StateManagedObject)
Top

Public Events

 | Name | Description
Public Event | Click |
Top

See Also

Reference

ActiveRegion Class
Telerik.Reporting.Charting Namespace


ActiveRegion Constructor

ActiveRegion Constructor
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class : ActiveRegion Constructor

Overload List

Overload | Description
ActiveRegion Constructor() |
ActiveRegion Constructor(Object) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members


ActiveRegion Constructor()

ActiveRegion Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class > ActiveRegion Constructor : ActiveRegion Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion()
C#
public ActiveRegion()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion()
C#
public ActiveRegion()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members
Overload List


ActiveRegion Constructor(Object)

ActiveRegion Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class > ActiveRegion Constructor : ActiveRegion Constructor(Object)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As ActiveRegion(parent)
C#
public ActiveRegion(
   object parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As ActiveRegion(parent)
C#
public ActiveRegion(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members
Overload List


ActiveRegion Class Methods

ActiveRegion Class Methods
[image]
Telerik.Reporting.Charting Namespace : ActiveRegion Class

For a list of all members of this type, see ActiveRegion members.

Public Methods

 | Name | Description
Public Method | CheckPoint | Overloaded.
Public Method | GoToUrl |
Public Method | IsEmpty |
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | (Inherited from StateManagedObject)
Protected Method | SaveViewState | (Inherited from StateManagedObject)
Protected Method | TrackViewState | (Inherited from StateManagedObject)
Top

See Also

Reference

ActiveRegion Class
Telerik.Reporting.Charting Namespace


CheckPoint Method

CheckPoint Method
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class : CheckPoint Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CheckPoint(PointF,Boolean) |
CheckPoint(PointF) |

Overload List

Overload | Description
CheckPoint(PointF,Boolean) |
CheckPoint(PointF) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members


CheckPoint(PointF,Boolean) Method

CheckPoint(PointF,Boolean) Method
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class > CheckPoint Method : CheckPoint(PointF,Boolean) Method

point
onclick

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function CheckPoint( _
   ByVal point As PointF, _
   ByVal onclick As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion
Dim point As PointF
Dim onclick As Boolean
Dim value As Boolean

value = instance.CheckPoint(point, onclick)
C#
public bool CheckPoint(
   PointF point,
   bool onclick
)

Parameters

point
onclick

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members
Overload List


CheckPoint(PointF) Method

CheckPoint(PointF) Method
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class > CheckPoint Method : CheckPoint(PointF) Method

point

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function CheckPoint( _
   ByVal point As PointF _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion
Dim point As PointF
Dim value As Boolean

value = instance.CheckPoint(point)
C#
public bool CheckPoint(
   PointF point
)

Parameters

point

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members
Overload List


GoToUrl Method

GoToUrl Method
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class : GoToUrl Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub GoToUrl()
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion

instance.GoToUrl()
C#
public void GoToUrl()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members


IsEmpty Method

IsEmpty Method
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class : IsEmpty Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion
Dim value As Boolean

value = instance.IsEmpty()
C#
public bool IsEmpty()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members


ActiveRegion Class Properties

ActiveRegion Class Properties
[image]
Telerik.Reporting.Charting Namespace : ActiveRegion Class

For a list of all members of this type, see ActiveRegion members.

Public Properties

 | Name | Description
Public Property | Attributes |
Public Property | Parent |
Public Property | Region |
Public Property | Tooltip |
Public Property | Url |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ActiveRegion Class
Telerik.Reporting.Charting Namespace


Attributes Property

Attributes Property
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class : Attributes Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Attributes As String
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion
Dim value As String

instance.Attributes = value

value = instance.Attributes
C#
public string Attributes {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion
Dim value As Object

instance.Parent = value

value = instance.Parent
C#
public object Parent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members


Region Property

Region Property
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class : Region Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Region As GraphicsPath
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion
Dim value As GraphicsPath

instance.Region = value

value = instance.Region
C#
public GraphicsPath Region {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members


Tooltip Property

Tooltip Property
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class : Tooltip Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Tooltip As String
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion
Dim value As String

instance.Tooltip = value

value = instance.Tooltip
C#
public string Tooltip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members


Url Property

Url Property
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class : Url Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Url As String
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion
Dim value As String

instance.Url = value

value = instance.Url
C#
public string Url {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members


ActiveRegion Class Events

ActiveRegion Class Events
[image]
Telerik.Reporting.Charting Namespace : ActiveRegion Class

For a list of all members of this type, see ActiveRegion members.

Public Events

 | Name | Description
Public Event | Click |
Top

See Also

Reference

ActiveRegion Class
Telerik.Reporting.Charting Namespace


Click Event

Click Event
[image]
Telerik.Reporting.Charting Namespace > ActiveRegion Class : Click Event

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event Click() As RegionClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion
Dim handler As RegionClickEventHandler

AddHandler instance.Click, handler
C#
public event RegionClickEventHandler Click()

Syntax

Visual Basic (Declaration)
Public Event Click() As RegionClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ActiveRegion
Dim handler As RegionClickEventHandler

AddHandler instance.Click, handler
C#
public event RegionClickEventHandler Click()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ActiveRegion Class
ActiveRegion Members


AxisLabel Class

AxisLabel Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : AxisLabel Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class AxisLabel
   Inherits AxisLabelHidden
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As AxisLabel
C#
public class AxisLabel : AxisLabelHidden, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ChartLabel
Telerik.Reporting.Charting.AxisLabelHidden
Telerik.Reporting.Charting.AxisLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisLabel Members
Telerik.Reporting.Charting Namespace


AxisLabel Class Members

AxisLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : AxisLabel Class

The following tables list the members exposed by AxisLabel.

Public Constructors

 | Name | Description
Public Constructor | AxisLabel Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from AxisLabelHidden)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

AxisLabel Class
Telerik.Reporting.Charting Namespace


AxisLabel Constructor

AxisLabel Constructor
[image]
Telerik.Reporting.Charting Namespace > AxisLabel Class : AxisLabel Constructor

Overload List

Overload | Description
AxisLabel Constructor() |
AxisLabel Constructor(Object,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisLabel Class
AxisLabel Members


AxisLabel Constructor()

AxisLabel Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > AxisLabel Class > AxisLabel Constructor : AxisLabel Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AxisLabel()
C#
public AxisLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AxisLabel()
C#
public AxisLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisLabel Class
AxisLabel Members
Overload List


AxisLabel Constructor(Object,IContainer)

AxisLabel Constructor(Object,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > AxisLabel Class > AxisLabel Constructor : AxisLabel Constructor(Object,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer

Dim instance As AxisLabel(parent, container)
C#
public AxisLabel(
   object parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer

Dim instance As AxisLabel(parent, container)
C#
public AxisLabel(
   object parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisLabel Class
AxisLabel Members
Overload List


AxisLabelHidden Class

AxisLabelHidden Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : AxisLabelHidden Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class AxisLabelHidden
   Inherits ChartLabel
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As AxisLabelHidden
C#
public class AxisLabelHidden : ChartLabel, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ChartLabel
Telerik.Reporting.Charting.AxisLabelHidden
Telerik.Reporting.Charting.AxisLabel
Telerik.Reporting.Charting.AxisYLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisLabelHidden Members
Telerik.Reporting.Charting Namespace


AxisLabelHidden Class Members

AxisLabelHidden Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : AxisLabelHidden Class

The following tables list the members exposed by AxisLabelHidden.

Public Constructors

 | Name | Description
Public Constructor | AxisLabelHidden Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

AxisLabelHidden Class
Telerik.Reporting.Charting Namespace


AxisLabelHidden Constructor

AxisLabelHidden Constructor
[image]
Telerik.Reporting.Charting Namespace > AxisLabelHidden Class : AxisLabelHidden Constructor

Overload List

Overload | Description
AxisLabelHidden Constructor() |
AxisLabelHidden Constructor(Object) |
AxisLabelHidden Constructor(Object,IContainer,StyleLabelHidden,TextBlock,String) |
AxisLabelHidden Constructor(String) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisLabelHidden Class
AxisLabelHidden Members


AxisLabelHidden Constructor()

AxisLabelHidden Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > AxisLabelHidden Class > AxisLabelHidden Constructor : AxisLabelHidden Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AxisLabelHidden()
C#
public AxisLabelHidden()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AxisLabelHidden()
C#
public AxisLabelHidden()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisLabelHidden Class
AxisLabelHidden Members
Overload List


AxisLabelHidden Constructor(Object)

AxisLabelHidden Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > AxisLabelHidden Class > AxisLabelHidden Constructor : AxisLabelHidden Constructor(Object)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As AxisLabelHidden(parent)
C#
public AxisLabelHidden(
   object parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As AxisLabelHidden(parent)
C#
public AxisLabelHidden(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisLabelHidden Class
AxisLabelHidden Members
Overload List


AxisLabelHidden Constructor(Object,IContainer,StyleLabelHidden,TextBlock,String)

AxisLabelHidden Constructor(Object,IContainer,StyleLabelHidden,TextBlock,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > AxisLabelHidden Class > AxisLabelHidden Constructor : AxisLabelHidden Constructor(Object,IContainer,StyleLabelHidden,TextBlock,String)

parent
container
appearance
textBlock
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer, _
   ByVal appearance As StyleLabelHidden, _
   ByVal textBlock As TextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer
Dim appearance As StyleLabelHidden
Dim textBlock As TextBlock
Dim text As String

Dim instance As AxisLabelHidden(parent, container, appearance, textBlock, text)
C#
public AxisLabelHidden(
   object parent,
   IContainer container,
   StyleLabelHidden appearance,
   TextBlock textBlock,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer, _
   ByVal appearance As StyleLabelHidden, _
   ByVal textBlock As TextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer
Dim appearance As StyleLabelHidden
Dim textBlock As TextBlock
Dim text As String

Dim instance As AxisLabelHidden(parent, container, appearance, textBlock, text)
C#
public AxisLabelHidden(
   object parent,
   IContainer container,
   StyleLabelHidden appearance,
   TextBlock textBlock,
   string text
)

Parameters

parent
container
appearance
textBlock
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisLabelHidden Class
AxisLabelHidden Members
Overload List


AxisLabelHidden Constructor(String)

AxisLabelHidden Constructor(String)
See Also
[image]
Telerik.Reporting.Charting Namespace > AxisLabelHidden Class > AxisLabelHidden Constructor : AxisLabelHidden Constructor(String)

text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As AxisLabelHidden(text)
C#
public AxisLabelHidden(
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As AxisLabelHidden(text)
C#
public AxisLabelHidden(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisLabelHidden Class
AxisLabelHidden Members
Overload List


AxisLabelHidden Class Properties

AxisLabelHidden Class Properties
[image]
Telerik.Reporting.Charting Namespace : AxisLabelHidden Class

For a list of all members of this type, see AxisLabelHidden members.

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

AxisLabelHidden Class
Telerik.Reporting.Charting Namespace


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting Namespace > AxisLabelHidden Class : Visible Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AxisLabelHidden
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisLabelHidden Class
AxisLabelHidden Members


AxisSegment Class

AxisSegment Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : AxisSegment Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class AxisSegment
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As AxisSegment
C#
public class AxisSegment : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.AxisSegment

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisSegment Members
Telerik.Reporting.Charting Namespace


AxisSegment Class Members

AxisSegment Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : AxisSegment Class

The following tables list the members exposed by AxisSegment.

Public Constructors

 | Name | Description
Public Constructor | AxisSegment Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | axisSegmentPointEnd |
Protected Field | axisSegmentPointStart |
Protected Field | axisSegmentRectangle |
Top

Public Properties

 | Name | Description
Public Property | MaxValue |
Public Property | MinValue |
Public Property | Name |
Public Property | Step |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | (Inherited from StateManagedObject)
Protected Method | SaveViewState | (Inherited from StateManagedObject)
Protected Method | TrackViewState | (Inherited from StateManagedObject)
Top

See Also

Reference

AxisSegment Class
Telerik.Reporting.Charting Namespace


AxisSegment Constructor

AxisSegment Constructor
[image]
Telerik.Reporting.Charting Namespace > AxisSegment Class : AxisSegment Constructor

Overload List

Overload | Description
AxisSegment Constructor() |
AxisSegment Constructor(String) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisSegment Class
AxisSegment Members


AxisSegment Constructor()

AxisSegment Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > AxisSegment Class > AxisSegment Constructor : AxisSegment Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AxisSegment()
C#
public AxisSegment()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AxisSegment()
C#
public AxisSegment()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisSegment Class
AxisSegment Members
Overload List


AxisSegment Constructor(String)

AxisSegment Constructor(String)
See Also
[image]
Telerik.Reporting.Charting Namespace > AxisSegment Class > AxisSegment Constructor : AxisSegment Constructor(String)

name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As AxisSegment(name)
C#
public AxisSegment(
   string name
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As AxisSegment(name)
C#
public AxisSegment(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisSegment Class
AxisSegment Members
Overload List


AxisSegment Class Properties

AxisSegment Class Properties
[image]
Telerik.Reporting.Charting Namespace : AxisSegment Class

For a list of all members of this type, see AxisSegment members.

Public Properties

 | Name | Description
Public Property | MaxValue |
Public Property | MinValue |
Public Property | Name |
Public Property | Step |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

AxisSegment Class
Telerik.Reporting.Charting Namespace


MaxValue Property

MaxValue Property
[image]
Telerik.Reporting.Charting Namespace > AxisSegment Class : MaxValue Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxValue As Double
Visual Basic (Usage) Copy Code
Dim instance As AxisSegment
Dim value As Double

instance.MaxValue = value

value = instance.MaxValue
C#
public double MaxValue {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisSegment Class
AxisSegment Members


MinValue Property

MinValue Property
[image]
Telerik.Reporting.Charting Namespace > AxisSegment Class : MinValue Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property MinValue As Double
Visual Basic (Usage) Copy Code
Dim instance As AxisSegment
Dim value As Double

instance.MinValue = value

value = instance.MinValue
C#
public double MinValue {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisSegment Class
AxisSegment Members


Name Property

Name Property
[image]
Telerik.Reporting.Charting Namespace > AxisSegment Class : Name Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As AxisSegment
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisSegment Class
AxisSegment Members


Step Property

Step Property
[image]
Telerik.Reporting.Charting Namespace > AxisSegment Class : Step Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Step As Double
Visual Basic (Usage) Copy Code
Dim instance As AxisSegment
Dim value As Double

instance.Step = value

value = instance.Step
C#
public double Step {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisSegment Class
AxisSegment Members


AxisSegment Class Fields

AxisSegment Class Fields
[image]
Telerik.Reporting.Charting Namespace : AxisSegment Class

For a list of all members of this type, see AxisSegment members.

Protected Fields

 | Name | Description
Protected Field | axisSegmentPointEnd |
Protected Field | axisSegmentPointStart |
Protected Field | axisSegmentRectangle |
Top

See Also

Reference

AxisSegment Class
Telerik.Reporting.Charting Namespace


axisSegmentPointEnd Field

axisSegmentPointEnd Field
[image]
Telerik.Reporting.Charting Namespace > AxisSegment Class : axisSegmentPointEnd Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected axisSegmentPointEnd As PointF
Visual Basic (Usage) Copy Code
Dim instance As AxisSegment
Dim value As PointF

value = instance.axisSegmentPointEnd

instance.axisSegmentPointEnd = value
C#
protected PointF axisSegmentPointEnd

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisSegment Class
AxisSegment Members


axisSegmentPointStart Field

axisSegmentPointStart Field
[image]
Telerik.Reporting.Charting Namespace > AxisSegment Class : axisSegmentPointStart Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected axisSegmentPointStart As PointF
Visual Basic (Usage) Copy Code
Dim instance As AxisSegment
Dim value As PointF

value = instance.axisSegmentPointStart

instance.axisSegmentPointStart = value
C#
protected PointF axisSegmentPointStart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisSegment Class
AxisSegment Members


axisSegmentRectangle Field

axisSegmentRectangle Field
[image]
Telerik.Reporting.Charting Namespace > AxisSegment Class : axisSegmentRectangle Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected axisSegmentRectangle As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As AxisSegment
Dim value As RectangleF

value = instance.axisSegmentRectangle

instance.axisSegmentRectangle = value
C#
protected RectangleF axisSegmentRectangle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisSegment Class
AxisSegment Members


AxisSegmentCollection Class

AxisSegmentCollection Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : AxisSegmentCollection Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class AxisSegmentCollection
   Inherits ChartingStateManagedCollection(Of AxisSegment)
   Implements IChartingStateManager, IDeserializableCollection
Visual Basic (Usage) Copy Code
Dim instance As AxisSegmentCollection
C#
public class AxisSegmentCollection : ChartingStateManagedCollection<AxisSegment>, IChartingStateManager, IDeserializableCollection

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>
Telerik.Reporting.Charting.AxisSegmentCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisSegmentCollection Members
Telerik.Reporting.Charting Namespace


AxisSegmentCollection Class Members

AxisSegmentCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : AxisSegmentCollection Class

The following tables list the members exposed by AxisSegmentCollection.

Public Constructors

 | Name | Description
Public Constructor | AxisSegmentCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Property | Item | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | Remove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Top

See Also

Reference

AxisSegmentCollection Class
Telerik.Reporting.Charting Namespace


AxisSegmentCollection Constructor

AxisSegmentCollection Constructor
[image]
Telerik.Reporting.Charting Namespace > AxisSegmentCollection Class : AxisSegmentCollection Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AxisSegmentCollection()
C#
public AxisSegmentCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AxisSegmentCollection()
C#
public AxisSegmentCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisSegmentCollection Class
AxisSegmentCollection Members


AxisYLabel Class

AxisYLabel Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : AxisYLabel Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class AxisYLabel
   Inherits AxisLabelHidden
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As AxisYLabel
C#
public class AxisYLabel : AxisLabelHidden, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ChartLabel
Telerik.Reporting.Charting.AxisLabelHidden
Telerik.Reporting.Charting.AxisYLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisYLabel Members
Telerik.Reporting.Charting Namespace


AxisYLabel Class Members

AxisYLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : AxisYLabel Class

The following tables list the members exposed by AxisYLabel.

Public Constructors

 | Name | Description
Public Constructor | AxisYLabel Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from AxisLabelHidden)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

AxisYLabel Class
Telerik.Reporting.Charting Namespace


AxisYLabel Constructor

AxisYLabel Constructor
[image]
Telerik.Reporting.Charting Namespace > AxisYLabel Class : AxisYLabel Constructor

Overload List

Overload | Description
AxisYLabel Constructor() |
AxisYLabel Constructor(Object,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisYLabel Class
AxisYLabel Members


AxisYLabel Constructor()

AxisYLabel Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > AxisYLabel Class > AxisYLabel Constructor : AxisYLabel Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AxisYLabel()
C#
public AxisYLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AxisYLabel()
C#
public AxisYLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisYLabel Class
AxisYLabel Members
Overload List


AxisYLabel Constructor(Object,IContainer)

AxisYLabel Constructor(Object,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > AxisYLabel Class > AxisYLabel Constructor : AxisYLabel Constructor(Object,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer

Dim instance As AxisYLabel(parent, container)
C#
public AxisYLabel(
   object parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer

Dim instance As AxisYLabel(parent, container)
C#
public AxisYLabel(
   object parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AxisYLabel Class
AxisYLabel Members
Overload List


BindableLegendItem Class

BindableLegendItem Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : BindableLegendItem Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class BindableLegendItem
   Inherits LabelItem
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As BindableLegendItem
C#
public class BindableLegendItem : LabelItem, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ChartLabel
Telerik.Reporting.Charting.LabelItem
Telerik.Reporting.Charting.BindableLegendItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BindableLegendItem Members
Telerik.Reporting.Charting Namespace


BindableLegendItem Class Members

BindableLegendItem Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : BindableLegendItem Class

The following tables list the members exposed by BindableLegendItem.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | BindableLegendItemSource |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | Name | (Inherited from LabelItem)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

BindableLegendItem Class
Telerik.Reporting.Charting Namespace


BindableLegendItem Class Properties

BindableLegendItem Class Properties
[image]
Telerik.Reporting.Charting Namespace : BindableLegendItem Class

For a list of all members of this type, see BindableLegendItem members.

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | BindableLegendItemSource |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | Name | (Inherited from LabelItem)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

BindableLegendItem Class
Telerik.Reporting.Charting Namespace


BindableLegendItemSource Property

BindableLegendItemSource Property
[image]
Telerik.Reporting.Charting Namespace > BindableLegendItem Class : BindableLegendItemSource Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property BindableLegendItemSource As Object
Visual Basic (Usage) Copy Code
Dim instance As BindableLegendItem
Dim value As Object

instance.BindableLegendItemSource = value

value = instance.BindableLegendItemSource
C#
public object BindableLegendItemSource {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BindableLegendItem Class
BindableLegendItem Members


Chart Class

Chart Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : Chart Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Chart
   Inherits LayoutElement
   Implements IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As Chart
C#
public class Chart : LayoutElement, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.Chart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Members
Telerik.Reporting.Charting Namespace


Chart Class Members

Chart Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : Chart Class

The following tables list the members exposed by Chart.

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | Appearance |
Public Property | AutoLayout |
Public Property | AutoTextWrap |
Public Property | ChartTitle |
Public Property | Container | (Inherited from RenderedObject)
Public Property | DefaultType |
Public Property | Legend |
Public Property | NextPosition |
Public Property | OrderList |
Public Property | PlotArea |
Public Property | Series |
Public Property | SeriesPalette |
Public Property | Skin |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | AddChartSeries |
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Dispose | Overloaded.
Public Method | GetOrder | Overloaded.
Public Method | GetSeries | Overloaded.
Public Method | Insert |
Public Method | ReIndex |
Public Method | Remove | Overloaded.
Public Method | RemoveAt |
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

Chart Class
Telerik.Reporting.Charting Namespace


Chart Class Methods

Chart Class Methods
[image]
Telerik.Reporting.Charting Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | AddChartSeries |
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Dispose | Overloaded.
Public Method | GetOrder | Overloaded.
Public Method | GetSeries | Overloaded.
Public Method | Insert |
Public Method | ReIndex |
Public Method | Remove | Overloaded.
Public Method | RemoveAt |
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

Chart Class
Telerik.Reporting.Charting Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class : Add Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal element As IOrdering _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim element As IOrdering

instance.Add(element)
C#
public void Add(
   IOrdering element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


AddChartSeries Method

AddChartSeries Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class : AddChartSeries Method

series

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddChartSeries( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim series As ChartSeries

instance.AddChartSeries(series)
C#
public void AddChartSeries(
   ChartSeries series
)

Parameters

series

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class : Dispose Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Chart

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class : Finalize Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As Chart

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


GetOrder Method

GetOrder Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class : GetOrder Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetOrder(IOrdering) |
GetOrder() | (Inherited from RenderedObject)

Overload List

Overload | Description
GetOrder(IOrdering) |
GetOrder() | (Inherited from RenderedObject)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


GetOrder(IOrdering) Method

GetOrder(IOrdering) Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class > GetOrder Method : GetOrder(IOrdering) Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function GetOrder( _
   ByVal element As IOrdering _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim element As IOrdering
Dim value As Integer

value = instance.GetOrder(element)
C#
public int GetOrder(
   IOrdering element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members
Overload List


GetSeries Method

GetSeries Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class : GetSeries Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetSeries(String) |
GetSeries(Int32) |

Overload List

Overload | Description
GetSeries(String) |
GetSeries(Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


GetSeries(String) Method

GetSeries(String) Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class > GetSeries Method : GetSeries(String) Method

name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function GetSeries( _
   ByVal name As String _
) As ChartSeries
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim name As String
Dim value As ChartSeries

value = instance.GetSeries(name)
C#
public ChartSeries GetSeries(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members
Overload List


GetSeries(Int32) Method

GetSeries(Int32) Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class > GetSeries Method : GetSeries(Int32) Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function GetSeries( _
   ByVal index As Integer _
) As ChartSeries
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim index As Integer
Dim value As ChartSeries

value = instance.GetSeries(index)
C#
public ChartSeries GetSeries(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members
Overload List


Insert Method

Insert Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class : Insert Method

order
element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal order As Integer, _
   ByVal element As IOrdering _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim order As Integer
Dim element As IOrdering

instance.Insert(order, element)
C#
public void Insert(
   int order,
   IOrdering element
)

Parameters

order
element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ReIndex Method

ReIndex Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class : ReIndex Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReIndex()
Visual Basic (Usage) Copy Code
Dim instance As Chart

instance.ReIndex()
C#
public void ReIndex()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class : Remove Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Remove(IOrdering) |
Remove() | (Inherited from RenderedObject)

Overload List

Overload | Description
Remove(IOrdering) |
Remove() | (Inherited from RenderedObject)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Remove(IOrdering) Method

Remove(IOrdering) Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class > Remove Method : Remove(IOrdering) Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal element As IOrdering _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim element As IOrdering

instance.Remove(element)
C#
public void Remove(
   IOrdering element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members
Overload List


RemoveAt Method

RemoveAt Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class : RemoveAt Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > Chart Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As Chart

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Chart Class Properties

Chart Class Properties
[image]
Telerik.Reporting.Charting Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Properties

 | Name | Description
Public Property | Appearance |
Public Property | AutoLayout |
Public Property | AutoTextWrap |
Public Property | ChartTitle |
Public Property | Container | (Inherited from RenderedObject)
Public Property | DefaultType |
Public Property | Legend |
Public Property | NextPosition |
Public Property | OrderList |
Public Property | PlotArea |
Public Property | Series |
Public Property | SeriesPalette |
Public Property | Skin |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

Chart Class
Telerik.Reporting.Charting Namespace


Appearance Property

Appearance Property
[image]
Telerik.Reporting.Charting Namespace > Chart Class : Appearance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleChart
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As StyleChart

value = instance.Appearance
C#
public StyleChart Appearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


AutoLayout Property

AutoLayout Property
[image]
Telerik.Reporting.Charting Namespace > Chart Class : AutoLayout Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoLayout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Boolean

instance.AutoLayout = value

value = instance.AutoLayout
C#
public bool AutoLayout {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


AutoTextWrap Property

AutoTextWrap Property
[image]
Telerik.Reporting.Charting Namespace > Chart Class : AutoTextWrap Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoTextWrap As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Boolean

instance.AutoTextWrap = value

value = instance.AutoTextWrap
C#
public bool AutoTextWrap {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ChartTitle Property

ChartTitle Property
[image]
Telerik.Reporting.Charting Namespace > Chart Class : ChartTitle Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChartTitle As ChartTitle
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ChartTitle

value = instance.ChartTitle
C#
public ChartTitle ChartTitle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


DefaultType Property

DefaultType Property
[image]
Telerik.Reporting.Charting Namespace > Chart Class : DefaultType Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultType As ChartSeriesType
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ChartSeriesType

instance.DefaultType = value

value = instance.DefaultType
C#
public ChartSeriesType DefaultType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Legend Property

Legend Property
[image]
Telerik.Reporting.Charting Namespace > Chart Class : Legend Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Legend As ChartLegend
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ChartLegend

value = instance.Legend
C#
public ChartLegend Legend {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


NextPosition Property

NextPosition Property
[image]
Telerik.Reporting.Charting Namespace > Chart Class : NextPosition Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NextPosition As Integer
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Integer

value = instance.NextPosition
C#
public int NextPosition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


OrderList Property

OrderList Property
[image]
Telerik.Reporting.Charting Namespace > Chart Class : OrderList Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrderList As List(Of IOrdering)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As List(Of IOrdering)

value = instance.OrderList
C#
public List<IOrdering> OrderList {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


PlotArea Property

PlotArea Property
[image]
Telerik.Reporting.Charting Namespace > Chart Class : PlotArea Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PlotArea As ChartPlotArea
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ChartPlotArea

value = instance.PlotArea
C#
public ChartPlotArea PlotArea {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Series Property

Series Property
[image]
Telerik.Reporting.Charting Namespace > Chart Class : Series Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Series As ChartSeriesCollection
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ChartSeriesCollection

value = instance.Series
C#
public ChartSeriesCollection Series {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


SeriesPalette Property

SeriesPalette Property
[image]
Telerik.Reporting.Charting Namespace > Chart Class : SeriesPalette Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property SeriesPalette As String
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As String

instance.SeriesPalette = value

value = instance.SeriesPalette
C#
public string SeriesPalette {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Skin Property

Skin Property
[image]
Telerik.Reporting.Charting Namespace > Chart Class : Skin Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Skin As String
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As String

instance.Skin = value

value = instance.Skin
C#
public string Skin {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ChartAxis Class

ChartAxis Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartAxis Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ChartAxis
   Inherits RenderedObject
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
C#
public abstract class ChartAxis : RenderedObject, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.ChartAxis
Telerik.Reporting.Charting.ChartXAxis
Telerik.Reporting.Charting.ChartYAxis

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Members
Telerik.Reporting.Charting Namespace


ChartAxis Class Members

ChartAxis Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartAxis Class

The following tables list the members exposed by ChartAxis.

Protected Fields

 | Name | Description
Protected Field | chartAxisAppearance |
Protected Field | chartAxisItems |
Protected Field | chartAxisLabel |
Protected Field | chartAxisMaxAxisValue |
Protected Field | chartAxisMaxItemValue |
Protected Field | chartAxisMinAxisValue |
Protected Field | chartAxisMinItemValue |
Protected Field | chartAxisParent |
Protected Field | chartAxisPointEnd |
Protected Field | chartAxisPointStart |
Protected Field | chartAxisRealIsZeroBased |
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | pixelsPerValue |
Protected Field | zeroCoord |
Top

Public Properties

 | Name | Description
Public Property | Appearance |
Public Property | AutoScale |
Public Property | AxisLabel |
Public Property | Container | (Inherited from RenderedObject)
Public Property | IsZeroBased |
Public Property | Item |
Public Property | Items |
Public Property | LabelStep |
Public Property | MaxItemsCount |
Public Property | MaxValue |
Public Property | MinValue |
Public Property | Parent |
Public Property | Step |
Public Property | Visible |
Public Property | VisibleValues |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | AddItem | Overloaded.
Public Method | AddRange |
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clear |
Public Method | Dispose | Overloaded.
Public Method | GetItem |
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | RemoveAllItems |
Public Method | RemoveItem | Overloaded.
Public Method | RemoveLastItem |
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetItemColor |
Public Method | SetItemLabel | Overloaded.
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | AutoCalcAxisExtents |
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | DisableCachedValues |
Protected Method | Finalize | Overridden.
Protected Method | GetAxisEndCoord |
Protected Method | GetAxisStartCoord |
Protected Method | GetDistance |
Protected Method | LoadViewState | Overridden.
Protected Method | ResetMaxValue |
Protected Method | ResetMinValue |
Protected Method | ResetStep |
Protected Method | SaveViewState | Overridden.
Protected Method | SetMaxValue |
Protected Method | SetMinValue |
Protected Method | ShouldSerializeMaxValue |
Protected Method | ShouldSerializeMinValue |
Protected Method | ShouldSerializeStep |
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartAxis Class
Telerik.Reporting.Charting Namespace


ChartAxis Class Methods

ChartAxis Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartAxis Class

For a list of all members of this type, see ChartAxis members.

Public Methods

 | Name | Description
Public Method | AddItem | Overloaded.
Public Method | AddRange |
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clear |
Public Method | Dispose | Overloaded.
Public Method | GetItem |
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | RemoveAllItems |
Public Method | RemoveItem | Overloaded.
Public Method | RemoveLastItem |
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetItemColor |
Public Method | SetItemLabel | Overloaded.
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | AutoCalcAxisExtents |
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | DisableCachedValues |
Protected Method | Finalize | Overridden.
Protected Method | GetAxisEndCoord |
Protected Method | GetAxisStartCoord |
Protected Method | GetDistance |
Protected Method | LoadViewState | Overridden.
Protected Method | ResetMaxValue |
Protected Method | ResetMinValue |
Protected Method | ResetStep |
Protected Method | SaveViewState | Overridden.
Protected Method | SetMaxValue |
Protected Method | SetMinValue |
Protected Method | ShouldSerializeMaxValue |
Protected Method | ShouldSerializeMinValue |
Protected Method | ShouldSerializeStep |
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartAxis Class
Telerik.Reporting.Charting Namespace


AddItem Method

AddItem Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : AddItem Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
AddItem(ChartAxisItem,ChartAxisItem[]) |
AddItem(ChartAxisItemsCollection) |
AddItem(ChartAxisItem[]) |
AddItem(Generic List) |
AddItem(String,Color) |
AddItem(String,Color,Boolean) |

Overload List

Overload | Description
AddItem(ChartAxisItem,ChartAxisItem[]) |
AddItem(ChartAxisItemsCollection) |
AddItem(ChartAxisItem[]) |
AddItem(Generic List) |
AddItem(String,Color) |
AddItem(String,Color,Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


AddItem(ChartAxisItem,ChartAxisItem[]) Method

AddItem(ChartAxisItem,ChartAxisItem[]) Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class > AddItem Method : AddItem(ChartAxisItem,ChartAxisItem[]) Method

item
items

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal item As ChartAxisItem, _
   ByVal ParamArray items() As ChartAxisItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim item As ChartAxisItem
Dim items() As ChartAxisItem

instance.AddItem(item, items)
C#
public void AddItem(
   ChartAxisItem item,
   params ChartAxisItem[] items
)

Parameters

item
items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members
Overload List


AddItem(ChartAxisItemsCollection) Method

AddItem(ChartAxisItemsCollection) Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class > AddItem Method : AddItem(ChartAxisItemsCollection) Method

items

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal items As ChartAxisItemsCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim items As ChartAxisItemsCollection

instance.AddItem(items)
C#
public void AddItem(
   ChartAxisItemsCollection items
)

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members
Overload List


AddItem(ChartAxisItem[]) Method

AddItem(ChartAxisItem[]) Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class > AddItem Method : AddItem(ChartAxisItem[]) Method

items

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal items() As ChartAxisItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim items() As ChartAxisItem

instance.AddItem(items)
C#
public void AddItem(
   ChartAxisItem[] items
)

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members
Overload List


AddItem(Generic List) Method

AddItem(Generic List) Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class > AddItem Method : AddItem(Generic List) Method

items

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal items As List(Of ChartAxisItem) _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim items As List(Of ChartAxisItem)

instance.AddItem(items)
C#
public void AddItem(
   List<ChartAxisItem> items
)

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members
Overload List


AddItem(String,Color) Method

AddItem(String,Color) Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class > AddItem Method : AddItem(String,Color) Method

label
color

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Function AddItem( _
   ByVal label As String, _
   ByVal color As Color _
) As ChartAxisItem
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim label As String
Dim color As Color
Dim value As ChartAxisItem

value = instance.AddItem(label, color)
C#
protected ChartAxisItem AddItem(
   string label,
   Color color
)

Parameters

label
color

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members
Overload List


AddItem(String,Color,Boolean) Method

AddItem(String,Color,Boolean) Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class > AddItem Method : AddItem(String,Color,Boolean) Method

label
color
visible

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Function AddItem( _
   ByVal label As String, _
   ByVal color As Color, _
   ByVal visible As Boolean _
) As ChartAxisItem
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim label As String
Dim color As Color
Dim visible As Boolean
Dim value As ChartAxisItem

value = instance.AddItem(label, color, visible)
C#
protected ChartAxisItem AddItem(
   string label,
   Color color,
   bool visible
)

Parameters

label
color
visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members
Overload List


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : AddRange Method

minValue
maxValue
step

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal minValue As Double, _
   ByVal maxValue As Double, _
   ByVal step As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim minValue As Double
Dim maxValue As Double
Dim step As Double

instance.AddRange(minValue, maxValue, step)
C#
public void AddRange(
   double minValue,
   double maxValue,
   double step
)

Parameters

minValue
maxValue
step

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


AutoCalcAxisExtents Method

AutoCalcAxisExtents Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : AutoCalcAxisExtents Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Sub AutoCalcAxisExtents()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis

instance.AutoCalcAxisExtents()
C#
protected void AutoCalcAxisExtents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


Clear Method

Clear Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : Clear Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


DisableCachedValues Method

DisableCachedValues Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : DisableCachedValues Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DisableCachedValues()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis

instance.DisableCachedValues()
C#
protected virtual void DisableCachedValues()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : Dispose Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : Finalize Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


GetAxisEndCoord Method

GetAxisEndCoord Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : GetAxisEndCoord Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetAxisEndCoord() As Single
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Single

value = instance.GetAxisEndCoord()
C#
protected abstract float GetAxisEndCoord()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


GetAxisStartCoord Method

GetAxisStartCoord Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : GetAxisStartCoord Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetAxisStartCoord() As Single
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Single

value = instance.GetAxisStartCoord()
C#
protected abstract float GetAxisStartCoord()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


GetDistance Method

GetDistance Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : GetDistance Method

point1
point2

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetDistance( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim point1 As PointF
Dim point2 As PointF
Dim value As Single

value = instance.GetDistance(point1, point2)
C#
protected float GetDistance(
   PointF point1,
   PointF point2
)

Parameters

point1
point2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


GetItem Method

GetItem Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : GetItem Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetItem( _
   ByVal index As Integer _
) As ChartAxisItem
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim index As Integer
Dim value As ChartAxisItem

value = instance.GetItem(index)
C#
public ChartAxisItem GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


RemoveAllItems Method

RemoveAllItems Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : RemoveAllItems Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveAllItems()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis

instance.RemoveAllItems()
C#
public void RemoveAllItems()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


RemoveItem Method

RemoveItem Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : RemoveItem Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
RemoveItem(ChartAxisItem,ChartAxisItem[]) |
RemoveItem(Int32,Int32[]) |
RemoveItem(Int32) |

Overload List

Overload | Description
RemoveItem(ChartAxisItem,ChartAxisItem[]) |
RemoveItem(Int32,Int32[]) |
RemoveItem(Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


RemoveItem(ChartAxisItem,ChartAxisItem[]) Method

RemoveItem(ChartAxisItem,ChartAxisItem[]) Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class > RemoveItem Method : RemoveItem(ChartAxisItem,ChartAxisItem[]) Method

item
items

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub RemoveItem( _
   ByVal item As ChartAxisItem, _
   ByVal ParamArray items() As ChartAxisItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim item As ChartAxisItem
Dim items() As ChartAxisItem

instance.RemoveItem(item, items)
C#
public void RemoveItem(
   ChartAxisItem item,
   params ChartAxisItem[] items
)

Parameters

item
items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members
Overload List


RemoveItem(Int32,Int32[]) Method

RemoveItem(Int32,Int32[]) Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class > RemoveItem Method : RemoveItem(Int32,Int32[]) Method

index
indexes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub RemoveItem( _
   ByVal index As Integer, _
   ByVal ParamArray indexes() As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim index As Integer
Dim indexes() As Integer

instance.RemoveItem(index, indexes)
C#
public void RemoveItem(
   int index,
   params int[] indexes
)

Parameters

index
indexes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members
Overload List


RemoveItem(Int32) Method

RemoveItem(Int32) Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class > RemoveItem Method : RemoveItem(Int32) Method

itemIndex

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub RemoveItem( _
   ByVal itemIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim itemIndex As Integer

instance.RemoveItem(itemIndex)
C#
public void RemoveItem(
   int itemIndex
)

Parameters

itemIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members
Overload List


RemoveLastItem Method

RemoveLastItem Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : RemoveLastItem Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveLastItem()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis

instance.RemoveLastItem()
C#
public void RemoveLastItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


ResetMaxValue Method

ResetMaxValue Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : ResetMaxValue Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ResetMaxValue()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis

instance.ResetMaxValue()
C#
protected void ResetMaxValue()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


ResetMinValue Method

ResetMinValue Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : ResetMinValue Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ResetMinValue()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis

instance.ResetMinValue()
C#
protected void ResetMinValue()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


ResetStep Method

ResetStep Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : ResetStep Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ResetStep()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis

instance.ResetStep()
C#
protected void ResetStep()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


SetItemColor Method

SetItemColor Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : SetItemColor Method

itemIndex
newColor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetItemColor( _
   ByVal itemIndex As Integer, _
   ByVal newColor As Color _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim itemIndex As Integer
Dim newColor As Color

instance.SetItemColor(itemIndex, newColor)
C#
public void SetItemColor(
   int itemIndex,
   Color newColor
)

Parameters

itemIndex
newColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


SetItemLabel Method

SetItemLabel Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : SetItemLabel Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
SetItemLabel(Int32,String) |
SetItemLabel(Int32,ChartAxisItem) |

Overload List

Overload | Description
SetItemLabel(Int32,String) |
SetItemLabel(Int32,ChartAxisItem) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


SetItemLabel(Int32,String) Method

SetItemLabel(Int32,String) Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class > SetItemLabel Method : SetItemLabel(Int32,String) Method

itemIndex
newLabelText

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub SetItemLabel( _
   ByVal itemIndex As Integer, _
   ByVal newLabelText As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim itemIndex As Integer
Dim newLabelText As String

instance.SetItemLabel(itemIndex, newLabelText)
C#
public void SetItemLabel(
   int itemIndex,
   string newLabelText
)

Parameters

itemIndex
newLabelText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members
Overload List


SetItemLabel(Int32,ChartAxisItem) Method

SetItemLabel(Int32,ChartAxisItem) Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class > SetItemLabel Method : SetItemLabel(Int32,ChartAxisItem) Method

itemIndex
newLabel

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub SetItemLabel( _
   ByVal itemIndex As Integer, _
   ByVal newLabel As ChartAxisItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim itemIndex As Integer
Dim newLabel As ChartAxisItem

instance.SetItemLabel(itemIndex, newLabel)
C#
public void SetItemLabel(
   int itemIndex,
   ChartAxisItem newLabel
)

Parameters

itemIndex
newLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members
Overload List


SetMaxValue Method

SetMaxValue Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : SetMaxValue Method

maxValue

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SetMaxValue( _
   ByVal maxValue As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim maxValue As Double

instance.SetMaxValue(maxValue)
C#
protected void SetMaxValue(
   double maxValue
)

Parameters

maxValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


SetMinValue Method

SetMinValue Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : SetMinValue Method

minValue

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SetMinValue( _
   ByVal minValue As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim minValue As Double

instance.SetMinValue(minValue)
C#
protected void SetMinValue(
   double minValue
)

Parameters

minValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


ShouldSerializeMaxValue Method

ShouldSerializeMaxValue Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : ShouldSerializeMaxValue Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function ShouldSerializeMaxValue() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Boolean

value = instance.ShouldSerializeMaxValue()
C#
protected bool ShouldSerializeMaxValue()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


ShouldSerializeMinValue Method

ShouldSerializeMinValue Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : ShouldSerializeMinValue Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function ShouldSerializeMinValue() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Boolean

value = instance.ShouldSerializeMinValue()
C#
protected bool ShouldSerializeMinValue()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


ShouldSerializeStep Method

ShouldSerializeStep Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : ShouldSerializeStep Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function ShouldSerializeStep() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Boolean

value = instance.ShouldSerializeStep()
C#
protected bool ShouldSerializeStep()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


ChartAxis Class Properties

ChartAxis Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartAxis Class

For a list of all members of this type, see ChartAxis members.

Public Properties

 | Name | Description
Public Property | Appearance |
Public Property | AutoScale |
Public Property | AxisLabel |
Public Property | Container | (Inherited from RenderedObject)
Public Property | IsZeroBased |
Public Property | Item |
Public Property | Items |
Public Property | LabelStep |
Public Property | MaxItemsCount |
Public Property | MaxValue |
Public Property | MinValue |
Public Property | Parent |
Public Property | Step |
Public Property | Visible |
Public Property | VisibleValues |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartAxis Class
Telerik.Reporting.Charting Namespace


Appearance Property

Appearance Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : Appearance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleAxis
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As StyleAxis

value = instance.Appearance
C#
public StyleAxis Appearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


AutoScale Property

AutoScale Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : AutoScale Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoScale As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Boolean

instance.AutoScale = value

value = instance.AutoScale
C#
public bool AutoScale {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


AxisLabel Property

AxisLabel Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : AxisLabel Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AxisLabel As ChartLabel
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As ChartLabel

value = instance.AxisLabel
C#
public ChartLabel AxisLabel {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


IsZeroBased Property

IsZeroBased Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : IsZeroBased Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property IsZeroBased As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Boolean

instance.IsZeroBased = value

value = instance.IsZeroBased
C#
public bool IsZeroBased {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


Item Property

Item Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : Item Property

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ChartAxisItem
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim index As Integer
Dim value As ChartAxisItem

value = instance.Item(index)
C#
public ChartAxisItem this[
   int index
]; {get;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


Items Property

Items Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : Items Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As ChartAxisItemsCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As ChartAxisItemsCollection

value = instance.Items
C#
public ChartAxisItemsCollection Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


LabelStep Property

LabelStep Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : LabelStep Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelStep As Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Integer

instance.LabelStep = value

value = instance.LabelStep
C#
public int LabelStep {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


MaxItemsCount Property

MaxItemsCount Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : MaxItemsCount Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxItemsCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Integer

instance.MaxItemsCount = value

value = instance.MaxItemsCount
C#
public int MaxItemsCount {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


MaxValue Property

MaxValue Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : MaxValue Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxValue As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Double

instance.MaxValue = value

value = instance.MaxValue
C#
public double MaxValue {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


MinValue Property

MinValue Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : MinValue Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property MinValue As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Double

instance.MinValue = value

value = instance.MinValue
C#
public double MinValue {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As ChartPlotArea
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As ChartPlotArea

value = instance.Parent
C#
public ChartPlotArea Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


Step Property

Step Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : Step Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Step As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Double

instance.Step = value

value = instance.Step
C#
public double Step {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : Visible Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As ChartAxisVisibility
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As ChartAxisVisibility

instance.Visible = value

value = instance.Visible
C#
public ChartAxisVisibility Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


VisibleValues Property

VisibleValues Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : VisibleValues Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property VisibleValues As ChartAxisVisibleValues
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As ChartAxisVisibleValues

instance.VisibleValues = value

value = instance.VisibleValues
C#
public ChartAxisVisibleValues VisibleValues {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


ChartAxis Class Fields

ChartAxis Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartAxis Class

For a list of all members of this type, see ChartAxis members.

Protected Fields

 | Name | Description
Protected Field | chartAxisAppearance |
Protected Field | chartAxisItems |
Protected Field | chartAxisLabel |
Protected Field | chartAxisMaxAxisValue |
Protected Field | chartAxisMaxItemValue |
Protected Field | chartAxisMinAxisValue |
Protected Field | chartAxisMinItemValue |
Protected Field | chartAxisParent |
Protected Field | chartAxisPointEnd |
Protected Field | chartAxisPointStart |
Protected Field | chartAxisRealIsZeroBased |
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | pixelsPerValue |
Protected Field | zeroCoord |
Top

See Also

Reference

ChartAxis Class
Telerik.Reporting.Charting Namespace


chartAxisAppearance Field

chartAxisAppearance Field
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : chartAxisAppearance Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartAxisAppearance As StyleAxis
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As StyleAxis

value = instance.chartAxisAppearance

instance.chartAxisAppearance = value
C#
protected StyleAxis chartAxisAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


chartAxisItems Field

chartAxisItems Field
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : chartAxisItems Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartAxisItems As ChartAxisItemsCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As ChartAxisItemsCollection

value = instance.chartAxisItems

instance.chartAxisItems = value
C#
protected ChartAxisItemsCollection chartAxisItems

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


chartAxisLabel Field

chartAxisLabel Field
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : chartAxisLabel Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartAxisLabel As ChartLabel
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As ChartLabel

value = instance.chartAxisLabel

instance.chartAxisLabel = value
C#
protected ChartLabel chartAxisLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


chartAxisMaxAxisValue Field

chartAxisMaxAxisValue Field
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : chartAxisMaxAxisValue Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartAxisMaxAxisValue As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Double

value = instance.chartAxisMaxAxisValue

instance.chartAxisMaxAxisValue = value
C#
protected double chartAxisMaxAxisValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


chartAxisMaxItemValue Field

chartAxisMaxItemValue Field
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : chartAxisMaxItemValue Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartAxisMaxItemValue As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Double

value = instance.chartAxisMaxItemValue

instance.chartAxisMaxItemValue = value
C#
protected double chartAxisMaxItemValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


chartAxisMinAxisValue Field

chartAxisMinAxisValue Field
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : chartAxisMinAxisValue Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartAxisMinAxisValue As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Double

value = instance.chartAxisMinAxisValue

instance.chartAxisMinAxisValue = value
C#
protected double chartAxisMinAxisValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


chartAxisMinItemValue Field

chartAxisMinItemValue Field
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : chartAxisMinItemValue Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartAxisMinItemValue As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Double

value = instance.chartAxisMinItemValue

instance.chartAxisMinItemValue = value
C#
protected double chartAxisMinItemValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


chartAxisParent Field

chartAxisParent Field
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : chartAxisParent Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartAxisParent As ChartPlotArea
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As ChartPlotArea

value = instance.chartAxisParent

instance.chartAxisParent = value
C#
protected ChartPlotArea chartAxisParent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


chartAxisPointEnd Field

chartAxisPointEnd Field
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : chartAxisPointEnd Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartAxisPointEnd As PointF
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As PointF

value = instance.chartAxisPointEnd

instance.chartAxisPointEnd = value
C#
protected PointF chartAxisPointEnd

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


chartAxisPointStart Field

chartAxisPointStart Field
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : chartAxisPointStart Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartAxisPointStart As PointF
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As PointF

value = instance.chartAxisPointStart

instance.chartAxisPointStart = value
C#
protected PointF chartAxisPointStart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


chartAxisRealIsZeroBased Field

chartAxisRealIsZeroBased Field
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : chartAxisRealIsZeroBased Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartAxisRealIsZeroBased As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Boolean

value = instance.chartAxisRealIsZeroBased

instance.chartAxisRealIsZeroBased = value
C#
protected bool chartAxisRealIsZeroBased

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


pixelsPerValue Field

pixelsPerValue Field
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : pixelsPerValue Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected pixelsPerValue As Single
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Single

value = instance.pixelsPerValue

instance.pixelsPerValue = value
C#
protected float pixelsPerValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


zeroCoord Field

zeroCoord Field
[image]
Telerik.Reporting.Charting Namespace > ChartAxis Class : zeroCoord Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected zeroCoord As Single
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
Dim value As Single

value = instance.zeroCoord

instance.zeroCoord = value
C#
protected float zeroCoord

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxis Class
ChartAxis Members


ChartAxisItem Class

ChartAxisItem Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartAxisItem Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartAxisItem
   Inherits ChartLabel
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisItem
C#
public class ChartAxisItem : ChartLabel, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ChartLabel
Telerik.Reporting.Charting.ChartAxisItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItem Members
Telerik.Reporting.Charting Namespace


ChartAxisItem Class Members

ChartAxisItem Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartAxisItem Class

The following tables list the members exposed by ChartAxisItem.

Public Constructors

 | Name | Description
Public Constructor | ChartAxisItem Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Value |
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

ChartAxisItem Class
Telerik.Reporting.Charting Namespace


ChartAxisItem Constructor

ChartAxisItem Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItem Class : ChartAxisItem Constructor

Overload List

Overload | Description
ChartAxisItem Constructor() |
ChartAxisItem Constructor(IContainer) |
ChartAxisItem Constructor(String) |
ChartAxisItem Constructor(String,Color) |
ChartAxisItem Constructor(String,Color,Boolean) |
ChartAxisItem Constructor(String,Color,Boolean,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItem Class
ChartAxisItem Members


ChartAxisItem Constructor()

ChartAxisItem Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItem Class > ChartAxisItem Constructor : ChartAxisItem Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisItem()
C#
public ChartAxisItem()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisItem()
C#
public ChartAxisItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItem Class
ChartAxisItem Members
Overload List


ChartAxisItem Constructor(IContainer)

ChartAxisItem Constructor(IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItem Class > ChartAxisItem Constructor : ChartAxisItem Constructor(IContainer)

container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As ChartAxisItem(container)
C#
public ChartAxisItem(
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As ChartAxisItem(container)
C#
public ChartAxisItem(
   IContainer container
)

Parameters

container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItem Class
ChartAxisItem Members
Overload List


ChartAxisItem Constructor(String)

ChartAxisItem Constructor(String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItem Class > ChartAxisItem Constructor : ChartAxisItem Constructor(String)

labelText

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal labelText As String _
)
Visual Basic (Usage) Copy Code
Dim labelText As String

Dim instance As ChartAxisItem(labelText)
C#
public ChartAxisItem(
   string labelText
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal labelText As String _
)
Visual Basic (Usage) Copy Code
Dim labelText As String

Dim instance As ChartAxisItem(labelText)
C#
public ChartAxisItem(
   string labelText
)

Parameters

labelText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItem Class
ChartAxisItem Members
Overload List


ChartAxisItem Constructor(String,Color)

ChartAxisItem Constructor(String,Color)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItem Class > ChartAxisItem Constructor : ChartAxisItem Constructor(String,Color)

labelText
color

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal labelText As String, _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim labelText As String
Dim color As Color

Dim instance As ChartAxisItem(labelText, color)
C#
public ChartAxisItem(
   string labelText,
   Color color
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal labelText As String, _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim labelText As String
Dim color As Color

Dim instance As ChartAxisItem(labelText, color)
C#
public ChartAxisItem(
   string labelText,
   Color color
)

Parameters

labelText
color

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItem Class
ChartAxisItem Members
Overload List


ChartAxisItem Constructor(String,Color,Boolean)

ChartAxisItem Constructor(String,Color,Boolean)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItem Class > ChartAxisItem Constructor : ChartAxisItem Constructor(String,Color,Boolean)

label
color
visible

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal label As String, _
   ByVal color As Color, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim label As String
Dim color As Color
Dim visible As Boolean

Dim instance As ChartAxisItem(label, color, visible)
C#
public ChartAxisItem(
   string label,
   Color color,
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal label As String, _
   ByVal color As Color, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim label As String
Dim color As Color
Dim visible As Boolean

Dim instance As ChartAxisItem(label, color, visible)
C#
public ChartAxisItem(
   string label,
   Color color,
   bool visible
)

Parameters

label
color
visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItem Class
ChartAxisItem Members
Overload List


ChartAxisItem Constructor(String,Color,Boolean,IContainer)

ChartAxisItem Constructor(String,Color,Boolean,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItem Class > ChartAxisItem Constructor : ChartAxisItem Constructor(String,Color,Boolean,IContainer)

labelText
color
visible
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal labelText As String, _
   ByVal color As Color, _
   ByVal visible As Boolean, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim labelText As String
Dim color As Color
Dim visible As Boolean
Dim container As IContainer

Dim instance As ChartAxisItem(labelText, color, visible, container)
C#
public ChartAxisItem(
   string labelText,
   Color color,
   bool visible,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal labelText As String, _
   ByVal color As Color, _
   ByVal visible As Boolean, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim labelText As String
Dim color As Color
Dim visible As Boolean
Dim container As IContainer

Dim instance As ChartAxisItem(labelText, color, visible, container)
C#
public ChartAxisItem(
   string labelText,
   Color color,
   bool visible,
   IContainer container
)

Parameters

labelText
color
visible
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItem Class
ChartAxisItem Members
Overload List


ChartAxisItem Class Properties

ChartAxisItem Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartAxisItem Class

For a list of all members of this type, see ChartAxisItem members.

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Value |
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartAxisItem Class
Telerik.Reporting.Charting Namespace


Value Property

Value Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItem Class : Value Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Decimal
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisItem
Dim value As Decimal

instance.Value = value

value = instance.Value
C#
public decimal Value {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItem Class
ChartAxisItem Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItem Class : Visible Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisItem
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItem Class
ChartAxisItem Members


ChartAxisItemsCollection Class

ChartAxisItemsCollection Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartAxisItemsCollection Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartAxisItemsCollection
   Inherits ChartingStateManagedCollection(Of ChartAxisItem)
   Implements IChartingStateManager, IDeserializableCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisItemsCollection
C#
public class ChartAxisItemsCollection : ChartingStateManagedCollection<ChartAxisItem>, IChartingStateManager, IDeserializableCollection

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>
Telerik.Reporting.Charting.ChartAxisItemsCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItemsCollection Members
Telerik.Reporting.Charting Namespace


ChartAxisItemsCollection Class Members

ChartAxisItemsCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartAxisItemsCollection Class

The following tables list the members exposed by ChartAxisItemsCollection.

Public Constructors

 | Name | Description
Public Constructor | ChartAxisItemsCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Property | Item | Overridden.
Public Property | Parent |
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overridden.
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | Remove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Top

See Also

Reference

ChartAxisItemsCollection Class
Telerik.Reporting.Charting Namespace


ChartAxisItemsCollection Constructor

ChartAxisItemsCollection Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItemsCollection Class : ChartAxisItemsCollection Constructor

Overload List

Overload | Description
ChartAxisItemsCollection Constructor() |
ChartAxisItemsCollection Constructor(ChartAxis) |
ChartAxisItemsCollection Constructor(Color) |
ChartAxisItemsCollection Constructor(Font) |
ChartAxisItemsCollection Constructor(Font,Color) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItemsCollection Class
ChartAxisItemsCollection Members


ChartAxisItemsCollection Constructor()

ChartAxisItemsCollection Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItemsCollection Class > ChartAxisItemsCollection Constructor : ChartAxisItemsCollection Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisItemsCollection()
C#
public ChartAxisItemsCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisItemsCollection()
C#
public ChartAxisItemsCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItemsCollection Class
ChartAxisItemsCollection Members
Overload List


ChartAxisItemsCollection Constructor(ChartAxis)

ChartAxisItemsCollection Constructor(ChartAxis)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItemsCollection Class > ChartAxisItemsCollection Constructor : ChartAxisItemsCollection Constructor(ChartAxis)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartAxis _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartAxis

Dim instance As ChartAxisItemsCollection(parent)
C#
public ChartAxisItemsCollection(
   ChartAxis parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartAxis _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartAxis

Dim instance As ChartAxisItemsCollection(parent)
C#
public ChartAxisItemsCollection(
   ChartAxis parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItemsCollection Class
ChartAxisItemsCollection Members
Overload List


ChartAxisItemsCollection Constructor(Color)

ChartAxisItemsCollection Constructor(Color)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItemsCollection Class > ChartAxisItemsCollection Constructor : ChartAxisItemsCollection Constructor(Color)

itemColor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal itemColor As Color _
)
Visual Basic (Usage) Copy Code
Dim itemColor As Color

Dim instance As ChartAxisItemsCollection(itemColor)
C#
public ChartAxisItemsCollection(
   Color itemColor
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal itemColor As Color _
)
Visual Basic (Usage) Copy Code
Dim itemColor As Color

Dim instance As ChartAxisItemsCollection(itemColor)
C#
public ChartAxisItemsCollection(
   Color itemColor
)

Parameters

itemColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItemsCollection Class
ChartAxisItemsCollection Members
Overload List


ChartAxisItemsCollection Constructor(Font)

ChartAxisItemsCollection Constructor(Font)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItemsCollection Class > ChartAxisItemsCollection Constructor : ChartAxisItemsCollection Constructor(Font)

itemFont

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal itemFont As Font _
)
Visual Basic (Usage) Copy Code
Dim itemFont As Font

Dim instance As ChartAxisItemsCollection(itemFont)
C#
public ChartAxisItemsCollection(
   Font itemFont
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal itemFont As Font _
)
Visual Basic (Usage) Copy Code
Dim itemFont As Font

Dim instance As ChartAxisItemsCollection(itemFont)
C#
public ChartAxisItemsCollection(
   Font itemFont
)

Parameters

itemFont

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItemsCollection Class
ChartAxisItemsCollection Members
Overload List


ChartAxisItemsCollection Constructor(Font,Color)

ChartAxisItemsCollection Constructor(Font,Color)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItemsCollection Class > ChartAxisItemsCollection Constructor : ChartAxisItemsCollection Constructor(Font,Color)

itemFont
itemColor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal itemFont As Font, _
   ByVal itemColor As Color _
)
Visual Basic (Usage) Copy Code
Dim itemFont As Font
Dim itemColor As Color

Dim instance As ChartAxisItemsCollection(itemFont, itemColor)
C#
public ChartAxisItemsCollection(
   Font itemFont,
   Color itemColor
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal itemFont As Font, _
   ByVal itemColor As Color _
)
Visual Basic (Usage) Copy Code
Dim itemFont As Font
Dim itemColor As Color

Dim instance As ChartAxisItemsCollection(itemFont, itemColor)
C#
public ChartAxisItemsCollection(
   Font itemFont,
   Color itemColor
)

Parameters

itemFont
itemColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItemsCollection Class
ChartAxisItemsCollection Members
Overload List


ChartAxisItemsCollection Class Methods

ChartAxisItemsCollection Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartAxisItemsCollection Class

For a list of all members of this type, see ChartAxisItemsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overridden.
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | Remove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Top

See Also

Reference

ChartAxisItemsCollection Class
Telerik.Reporting.Charting Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItemsCollection Class : Add Method

chartAxisItem

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Add( _
   ByVal chartAxisItem As ChartAxisItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisItemsCollection
Dim chartAxisItem As ChartAxisItem

instance.Add(chartAxisItem)
C#
public override void Add(
   ChartAxisItem chartAxisItem
)

Parameters

chartAxisItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItemsCollection Class
ChartAxisItemsCollection Members


ChartAxisItemsCollection Class Properties

ChartAxisItemsCollection Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartAxisItemsCollection Class

For a list of all members of this type, see ChartAxisItemsCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Public Property | Item | Overridden.
Public Property | Parent |
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>)
Top

See Also

Reference

ChartAxisItemsCollection Class
Telerik.Reporting.Charting Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItemsCollection Class : Item Property

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Default Property Item( _
   ByVal index As Integer _
) As ChartAxisItem
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisItemsCollection
Dim index As Integer
Dim value As ChartAxisItem

instance.Item(index) = value

value = instance.Item(index)
C#
public override ChartAxisItem this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItemsCollection Class
ChartAxisItemsCollection Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > ChartAxisItemsCollection Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As ChartAxis
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisItemsCollection
Dim value As ChartAxis

instance.Parent = value

value = instance.Parent
C#
public ChartAxis Parent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartAxisItemsCollection Class
ChartAxisItemsCollection Members


ChartBaseLabel Class

ChartBaseLabel Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartBaseLabel Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartBaseLabel
   Inherits LayoutElement
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
C#
public class ChartBaseLabel : LayoutElement, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ChartLabel
Telerik.Reporting.Charting.ExtendedLabel
Telerik.Reporting.Charting.SeriesItemLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Members
Telerik.Reporting.Charting Namespace


ChartBaseLabel Class Members

ChartBaseLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartBaseLabel Class

The following tables list the members exposed by ChartBaseLabel.

Public Constructors

 | Name | Description
Public Constructor | ChartBaseLabel Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion |
Protected Field | chartBaseLabelOrderList |
Protected Field | chartBaseLabelParent |
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker |
Public Property | NextPosition |
Public Property | OrderList |
Public Property | Parent |
Public Property | TextBlock |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone |
Public Method | Dispose | Overloaded.
Public Method | GetOrder | Overloaded.
Public Method | Insert |
Public Method | ReIndex |
Public Method | Remove | Overloaded.
Public Method | RemoveAt |
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


ChartBaseLabel Constructor

ChartBaseLabel Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : ChartBaseLabel Constructor

Overload List

Overload | Description
ChartBaseLabel Constructor() |
ChartBaseLabel Constructor(IContainer) |
ChartBaseLabel Constructor(Object) |
ChartBaseLabel Constructor(Object,IContainer) |
ChartBaseLabel Constructor(Object,IContainer,TextBlock) |
ChartBaseLabel Constructor(Object,IContainer,TextBlock,LayoutStyle) |
ChartBaseLabel Constructor(String) |
ChartBaseLabel Constructor(TextBlock) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


ChartBaseLabel Constructor()

ChartBaseLabel Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class > ChartBaseLabel Constructor : ChartBaseLabel Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel()
C#
public ChartBaseLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel()
C#
public ChartBaseLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members
Overload List


ChartBaseLabel Constructor(IContainer)

ChartBaseLabel Constructor(IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class > ChartBaseLabel Constructor : ChartBaseLabel Constructor(IContainer)

container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As ChartBaseLabel(container)
C#
public ChartBaseLabel(
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As ChartBaseLabel(container)
C#
public ChartBaseLabel(
   IContainer container
)

Parameters

container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members
Overload List


ChartBaseLabel Constructor(Object)

ChartBaseLabel Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class > ChartBaseLabel Constructor : ChartBaseLabel Constructor(Object)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As ChartBaseLabel(parent)
C#
public ChartBaseLabel(
   object parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As ChartBaseLabel(parent)
C#
public ChartBaseLabel(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members
Overload List


ChartBaseLabel Constructor(Object,IContainer)

ChartBaseLabel Constructor(Object,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class > ChartBaseLabel Constructor : ChartBaseLabel Constructor(Object,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer

Dim instance As ChartBaseLabel(parent, container)
C#
public ChartBaseLabel(
   object parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer

Dim instance As ChartBaseLabel(parent, container)
C#
public ChartBaseLabel(
   object parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members
Overload List


ChartBaseLabel Constructor(Object,IContainer,TextBlock)

ChartBaseLabel Constructor(Object,IContainer,TextBlock)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class > ChartBaseLabel Constructor : ChartBaseLabel Constructor(Object,IContainer,TextBlock)

parent
container
textBlock

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer, _
   ByVal textBlock As TextBlock _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer
Dim textBlock As TextBlock

Dim instance As ChartBaseLabel(parent, container, textBlock)
C#
public ChartBaseLabel(
   object parent,
   IContainer container,
   TextBlock textBlock
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer, _
   ByVal textBlock As TextBlock _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer
Dim textBlock As TextBlock

Dim instance As ChartBaseLabel(parent, container, textBlock)
C#
public ChartBaseLabel(
   object parent,
   IContainer container,
   TextBlock textBlock
)

Parameters

parent
container
textBlock

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members
Overload List


ChartBaseLabel Constructor(Object,IContainer,TextBlock,LayoutStyle)

ChartBaseLabel Constructor(Object,IContainer,TextBlock,LayoutStyle)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class > ChartBaseLabel Constructor : ChartBaseLabel Constructor(Object,IContainer,TextBlock,LayoutStyle)

parent
container
textBlock
appearance

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer, _
   ByVal textBlock As TextBlock, _
   ByVal appearance As LayoutStyle _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer
Dim textBlock As TextBlock
Dim appearance As LayoutStyle

Dim instance As ChartBaseLabel(parent, container, textBlock, appearance)
C#
public ChartBaseLabel(
   object parent,
   IContainer container,
   TextBlock textBlock,
   LayoutStyle appearance
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer, _
   ByVal textBlock As TextBlock, _
   ByVal appearance As LayoutStyle _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer
Dim textBlock As TextBlock
Dim appearance As LayoutStyle

Dim instance As ChartBaseLabel(parent, container, textBlock, appearance)
C#
public ChartBaseLabel(
   object parent,
   IContainer container,
   TextBlock textBlock,
   LayoutStyle appearance
)

Parameters

parent
container
textBlock
appearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members
Overload List


ChartBaseLabel Constructor(String)

ChartBaseLabel Constructor(String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class > ChartBaseLabel Constructor : ChartBaseLabel Constructor(String)

text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As ChartBaseLabel(text)
C#
public ChartBaseLabel(
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As ChartBaseLabel(text)
C#
public ChartBaseLabel(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members
Overload List


ChartBaseLabel Constructor(TextBlock)

ChartBaseLabel Constructor(TextBlock)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class > ChartBaseLabel Constructor : ChartBaseLabel Constructor(TextBlock)

textBlock

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal textBlock As TextBlock _
)
Visual Basic (Usage) Copy Code
Dim textBlock As TextBlock

Dim instance As ChartBaseLabel(textBlock)
C#
public ChartBaseLabel(
   TextBlock textBlock
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal textBlock As TextBlock _
)
Visual Basic (Usage) Copy Code
Dim textBlock As TextBlock

Dim instance As ChartBaseLabel(textBlock)
C#
public ChartBaseLabel(
   TextBlock textBlock
)

Parameters

textBlock

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members
Overload List


ChartBaseLabel Class Methods

ChartBaseLabel Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartBaseLabel Class

For a list of all members of this type, see ChartBaseLabel members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone |
Public Method | Dispose | Overloaded.
Public Method | GetOrder | Overloaded.
Public Method | Insert |
Public Method | ReIndex |
Public Method | Remove | Overloaded.
Public Method | RemoveAt |
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : Add Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal element As IOrdering _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim element As IOrdering

instance.Add(element)
C#
public void Add(
   IOrdering element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : Clone Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : Dispose Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : Finalize Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


GetOrder Method

GetOrder Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : GetOrder Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetOrder(IOrdering) |
GetOrder() | (Inherited from RenderedObject)

Overload List

Overload | Description
GetOrder(IOrdering) |
GetOrder() | (Inherited from RenderedObject)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


GetOrder(IOrdering) Method

GetOrder(IOrdering) Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class > GetOrder Method : GetOrder(IOrdering) Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function GetOrder( _
   ByVal element As IOrdering _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim element As IOrdering
Dim value As Integer

value = instance.GetOrder(element)
C#
public int GetOrder(
   IOrdering element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members
Overload List


Insert Method

Insert Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : Insert Method

order
element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal order As Integer, _
   ByVal element As IOrdering _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim order As Integer
Dim element As IOrdering

instance.Insert(order, element)
C#
public void Insert(
   int order,
   IOrdering element
)

Parameters

order
element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


ReIndex Method

ReIndex Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : ReIndex Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReIndex()
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel

instance.ReIndex()
C#
public void ReIndex()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : Remove Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Remove(IOrdering) |
Remove() | (Inherited from RenderedObject)

Overload List

Overload | Description
Remove(IOrdering) |
Remove() | (Inherited from RenderedObject)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


Remove(IOrdering) Method

Remove(IOrdering) Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class > Remove Method : Remove(IOrdering) Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal element As IOrdering _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim element As IOrdering

instance.Remove(element)
C#
public void Remove(
   IOrdering element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members
Overload List


RemoveAt Method

RemoveAt Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : RemoveAt Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


ChartBaseLabel Class Properties

ChartBaseLabel Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartBaseLabel Class

For a list of all members of this type, see ChartBaseLabel members.

Public Properties

 | Name | Description
Public Property | ActiveRegion |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker |
Public Property | NextPosition |
Public Property | OrderList |
Public Property | Parent |
Public Property | TextBlock |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


ActiveRegion Property

ActiveRegion Property
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : ActiveRegion Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveRegion As ActiveRegion
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim value As ActiveRegion

instance.ActiveRegion = value

value = instance.ActiveRegion
C#
public ActiveRegion ActiveRegion {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


Marker Property

Marker Property
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : Marker Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Marker As ChartMarker
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim value As ChartMarker

value = instance.Marker
C#
public ChartMarker Marker {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


NextPosition Property

NextPosition Property
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : NextPosition Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NextPosition As Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim value As Integer

value = instance.NextPosition
C#
public int NextPosition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


OrderList Property

OrderList Property
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : OrderList Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrderList As List(Of IOrdering)
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim value As List(Of IOrdering)

value = instance.OrderList
C#
public List<IOrdering> OrderList {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim value As Object

instance.Parent = value

value = instance.Parent
C#
public object Parent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


TextBlock Property

TextBlock Property
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : TextBlock Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TextBlock As TextBlock
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim value As TextBlock

value = instance.TextBlock
C#
public virtual TextBlock TextBlock {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : Visible Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


ChartBaseLabel Class Fields

ChartBaseLabel Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartBaseLabel Class

For a list of all members of this type, see ChartBaseLabel members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion |
Protected Field | chartBaseLabelOrderList |
Protected Field | chartBaseLabelParent |
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


chartBaseLabelActiveRegion Field

chartBaseLabelActiveRegion Field
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : chartBaseLabelActiveRegion Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartBaseLabelActiveRegion As ActiveRegion
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim value As ActiveRegion

value = instance.chartBaseLabelActiveRegion

instance.chartBaseLabelActiveRegion = value
C#
protected ActiveRegion chartBaseLabelActiveRegion

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


chartBaseLabelOrderList Field

chartBaseLabelOrderList Field
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : chartBaseLabelOrderList Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartBaseLabelOrderList As List(Of IOrdering)
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim value As List(Of IOrdering)

value = instance.chartBaseLabelOrderList

instance.chartBaseLabelOrderList = value
C#
protected List<IOrdering> chartBaseLabelOrderList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


chartBaseLabelParent Field

chartBaseLabelParent Field
[image]
Telerik.Reporting.Charting Namespace > ChartBaseLabel Class : chartBaseLabelParent Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartBaseLabelParent As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartBaseLabel
Dim value As Object

value = instance.chartBaseLabelParent

instance.chartBaseLabelParent = value
C#
protected object chartBaseLabelParent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartBaseLabel Class
ChartBaseLabel Members


ChartClickEventArgs Class

ChartClickEventArgs Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartClickEventArgs Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartClickEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ChartClickEventArgs
C#
public class ChartClickEventArgs : EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.Reporting.Charting.ChartClickEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartClickEventArgs Members
Telerik.Reporting.Charting Namespace


ChartClickEventArgs Class Members

ChartClickEventArgs Class Members
See Also Properties
[image]
Telerik.Reporting.Charting Namespace : ChartClickEventArgs Class

The following tables list the members exposed by ChartClickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ChartClickEventArgs Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Element |
Public Property | Series |
Public Property | SeriesItem |
Top

See Also

Reference

ChartClickEventArgs Class
Telerik.Reporting.Charting Namespace


ChartClickEventArgs Constructor

ChartClickEventArgs Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartClickEventArgs Class : ChartClickEventArgs Constructor

Overload List

Overload | Description
ChartClickEventArgs Constructor(IActiveRegion) |
ChartClickEventArgs Constructor(IActiveRegion,ChartSeries) |
ChartClickEventArgs Constructor(IActiveRegion,ChartSeries,ChartSeriesItem) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartClickEventArgs Class
ChartClickEventArgs Members


ChartClickEventArgs Constructor(IActiveRegion)

ChartClickEventArgs Constructor(IActiveRegion)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartClickEventArgs Class > ChartClickEventArgs Constructor : ChartClickEventArgs Constructor(IActiveRegion)

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal element As IActiveRegion _
)
Visual Basic (Usage) Copy Code
Dim element As IActiveRegion

Dim instance As ChartClickEventArgs(element)
C#
public ChartClickEventArgs(
   IActiveRegion element
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal element As IActiveRegion _
)
Visual Basic (Usage) Copy Code
Dim element As IActiveRegion

Dim instance As ChartClickEventArgs(element)
C#
public ChartClickEventArgs(
   IActiveRegion element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartClickEventArgs Class
ChartClickEventArgs Members
Overload List


ChartClickEventArgs Constructor(IActiveRegion,ChartSeries)

ChartClickEventArgs Constructor(IActiveRegion,ChartSeries)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartClickEventArgs Class > ChartClickEventArgs Constructor : ChartClickEventArgs Constructor(IActiveRegion,ChartSeries)

element
series

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal element As IActiveRegion, _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim element As IActiveRegion
Dim series As ChartSeries

Dim instance As ChartClickEventArgs(element, series)
C#
public ChartClickEventArgs(
   IActiveRegion element,
   ChartSeries series
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal element As IActiveRegion, _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim element As IActiveRegion
Dim series As ChartSeries

Dim instance As ChartClickEventArgs(element, series)
C#
public ChartClickEventArgs(
   IActiveRegion element,
   ChartSeries series
)

Parameters

element
series

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartClickEventArgs Class
ChartClickEventArgs Members
Overload List


ChartClickEventArgs Constructor(IActiveRegion,ChartSeries,ChartSeriesItem)

ChartClickEventArgs Constructor(IActiveRegion,ChartSeries,ChartSeriesItem)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartClickEventArgs Class > ChartClickEventArgs Constructor : ChartClickEventArgs Constructor(IActiveRegion,ChartSeries,ChartSeriesItem)

element
series
seriesItem

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal element As IActiveRegion, _
   ByVal series As ChartSeries, _
   ByVal seriesItem As ChartSeriesItem _
)
Visual Basic (Usage) Copy Code
Dim element As IActiveRegion
Dim series As ChartSeries
Dim seriesItem As ChartSeriesItem

Dim instance As ChartClickEventArgs(element, series, seriesItem)
C#
public ChartClickEventArgs(
   IActiveRegion element,
   ChartSeries series,
   ChartSeriesItem seriesItem
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal element As IActiveRegion, _
   ByVal series As ChartSeries, _
   ByVal seriesItem As ChartSeriesItem _
)
Visual Basic (Usage) Copy Code
Dim element As IActiveRegion
Dim series As ChartSeries
Dim seriesItem As ChartSeriesItem

Dim instance As ChartClickEventArgs(element, series, seriesItem)
C#
public ChartClickEventArgs(
   IActiveRegion element,
   ChartSeries series,
   ChartSeriesItem seriesItem
)

Parameters

element
series
seriesItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartClickEventArgs Class
ChartClickEventArgs Members
Overload List


ChartClickEventArgs Class Properties

ChartClickEventArgs Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartClickEventArgs Class

For a list of all members of this type, see ChartClickEventArgs members.

Public Properties

 | Name | Description
Public Property | Element |
Public Property | Series |
Public Property | SeriesItem |
Top

See Also

Reference

ChartClickEventArgs Class
Telerik.Reporting.Charting Namespace


Element Property

Element Property
[image]
Telerik.Reporting.Charting Namespace > ChartClickEventArgs Class : Element Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Element As IActiveRegion
Visual Basic (Usage) Copy Code
Dim instance As ChartClickEventArgs
Dim value As IActiveRegion

instance.Element = value

value = instance.Element
C#
public IActiveRegion Element {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartClickEventArgs Class
ChartClickEventArgs Members


Series Property

Series Property
[image]
Telerik.Reporting.Charting Namespace > ChartClickEventArgs Class : Series Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Series As ChartSeries
Visual Basic (Usage) Copy Code
Dim instance As ChartClickEventArgs
Dim value As ChartSeries

instance.Series = value

value = instance.Series
C#
public ChartSeries Series {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartClickEventArgs Class
ChartClickEventArgs Members


SeriesItem Property

SeriesItem Property
[image]
Telerik.Reporting.Charting Namespace > ChartClickEventArgs Class : SeriesItem Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property SeriesItem As ChartSeriesItem
Visual Basic (Usage) Copy Code
Dim instance As ChartClickEventArgs
Dim value As ChartSeriesItem

instance.SeriesItem = value

value = instance.SeriesItem
C#
public ChartSeriesItem SeriesItem {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartClickEventArgs Class
ChartClickEventArgs Members


ChartDataTable Class

ChartDataTable Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartDataTable Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartDataTable
   Inherits LayoutElement
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartDataTable
C#
public class ChartDataTable : LayoutElement, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartDataTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartDataTable Members
Telerik.Reporting.Charting Namespace


ChartDataTable Class Members

ChartDataTable Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartDataTable Class

The following tables list the members exposed by ChartDataTable.

Public Constructors

 | Name | Description
Public Constructor | ChartDataTable Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

ChartDataTable Class
Telerik.Reporting.Charting Namespace


ChartDataTable Constructor

ChartDataTable Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartDataTable Class : ChartDataTable Constructor

Overload List

Overload | Description
ChartDataTable Constructor(ChartPlotArea) |
ChartDataTable Constructor(ChartPlotArea,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartDataTable Class
ChartDataTable Members


ChartDataTable Constructor(ChartPlotArea)

ChartDataTable Constructor(ChartPlotArea)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartDataTable Class > ChartDataTable Constructor : ChartDataTable Constructor(ChartPlotArea)

plotArea

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal plotArea As ChartPlotArea _
)
Visual Basic (Usage) Copy Code
Dim plotArea As ChartPlotArea

Dim instance As ChartDataTable(plotArea)
C#
public ChartDataTable(
   ChartPlotArea plotArea
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal plotArea As ChartPlotArea _
)
Visual Basic (Usage) Copy Code
Dim plotArea As ChartPlotArea

Dim instance As ChartDataTable(plotArea)
C#
public ChartDataTable(
   ChartPlotArea plotArea
)

Parameters

plotArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartDataTable Class
ChartDataTable Members
Overload List


ChartDataTable Constructor(ChartPlotArea,IContainer)

ChartDataTable Constructor(ChartPlotArea,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartDataTable Class > ChartDataTable Constructor : ChartDataTable Constructor(ChartPlotArea,IContainer)

plotArea
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal plotArea As ChartPlotArea, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim plotArea As ChartPlotArea
Dim container As IContainer

Dim instance As ChartDataTable(plotArea, container)
C#
public ChartDataTable(
   ChartPlotArea plotArea,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal plotArea As ChartPlotArea, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim plotArea As ChartPlotArea
Dim container As IContainer

Dim instance As ChartDataTable(plotArea, container)
C#
public ChartDataTable(
   ChartPlotArea plotArea,
   IContainer container
)

Parameters

plotArea
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartDataTable Class
ChartDataTable Members
Overload List


ChartDataTable Class Properties

ChartDataTable Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartDataTable Class

For a list of all members of this type, see ChartDataTable members.

Public Properties

 | Name | Description
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartDataTable Class
Telerik.Reporting.Charting Namespace


Appearance Property

Appearance Property
[image]
Telerik.Reporting.Charting Namespace > ChartDataTable Class : Appearance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleChartDataTable
Visual Basic (Usage) Copy Code
Dim instance As ChartDataTable
Dim value As StyleChartDataTable

value = instance.Appearance
C#
public StyleChartDataTable Appearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartDataTable Class
ChartDataTable Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting Namespace > ChartDataTable Class : Visible Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartDataTable
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartDataTable Class
ChartDataTable Members


ChartException Class

ChartException Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartException Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As ChartException
C#
public class ChartException : ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Telerik.Reporting.Charting.ChartException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartException Members
Telerik.Reporting.Charting Namespace


ChartException Class Members

ChartException Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartException Class

The following tables list the members exposed by ChartException.

Public Constructors

 | Name | Description
Public Constructor | ChartException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ChartException Class
Telerik.Reporting.Charting Namespace


ChartException Constructor

ChartException Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartException Class : ChartException Constructor

Overload List

Overload | Description
ChartException Constructor(String) |
ChartException Constructor(String,Exception) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartException Class
ChartException Members


ChartException Constructor(String)

ChartException Constructor(String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartException Class > ChartException Constructor : ChartException Constructor(String)

message

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As ChartException(message)
C#
public ChartException(
   string message
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As ChartException(message)
C#
public ChartException(
   string message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartException Class
ChartException Members
Overload List


ChartException Constructor(String,Exception)

ChartException Constructor(String,Exception)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartException Class > ChartException Constructor : ChartException Constructor(String,Exception)

message
inner

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim inner As Exception

Dim instance As ChartException(message, inner)
C#
public ChartException(
   string message,
   Exception inner
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim inner As Exception

Dim instance As ChartException(message, inner)
C#
public ChartException(
   string message,
   Exception inner
)

Parameters

message
inner

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartException Class
ChartException Members
Overload List


Generic ChartingStateManagedCollection Class

T
Generic ChartingStateManagedCollection Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : Generic ChartingStateManagedCollection Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ChartingStateManagedCollection(Of T As IChartingStateManagedItem)
   Implements IChartingStateManager, IDeserializableCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
C#
public abstract class ChartingStateManagedCollection<T> : IChartingStateManager, IDeserializableCollection  where T: IChartingStateManagedItem

Type Parameters

T

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.ChartingStateManagedCollection
Telerik.Reporting.Charting.AxisSegmentCollection
Telerik.Reporting.Charting.ChartAxisItemsCollection
Telerik.Reporting.Charting.ChartLabelsCollection
Telerik.Reporting.Charting.ChartMarkedZonesCollection
Telerik.Reporting.Charting.ChartSeriesCollection
Telerik.Reporting.Charting.ChartSeriesItemsCollection
Telerik.Reporting.Charting.ColorBlend
Telerik.Reporting.Charting.CustomFiguresCollection
Telerik.Reporting.Charting.CustomPalettesCollection
Telerik.Reporting.Charting.PaletteItemsCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Members
Telerik.Reporting.Charting Namespace


Generic ChartingStateManagedCollection Class Members

Generic ChartingStateManagedCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : Generic ChartingStateManagedCollection Class

The following tables list the members exposed by Generic ChartingStateManagedCollection.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | Item |
Top

Protected Properties

 | Name | Description
Protected Property | List |
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | AddRange |
Public Method | Clear |
Public Method | Contains |
Public Method | CopyTo |
Public Method | GetEnumerator |
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt |
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState |
Protected Method | OnClear |
Protected Method | OnClearComplete |
Protected Method | OnInsert |
Protected Method | OnInsertComplete |
Protected Method | OnRemove |
Protected Method | OnRemoveComplete |
Protected Method | SaveViewState |
Protected Method | SetItemDirty |
Top

See Also

Reference

Generic ChartingStateManagedCollection Class
Telerik.Reporting.Charting Namespace


Generic ChartingStateManagedCollection Class Methods

Generic ChartingStateManagedCollection Class Methods
[image]
Telerik.Reporting.Charting Namespace : Generic ChartingStateManagedCollection Class

For a list of all members of this type, see Generic ChartingStateManagedCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | AddRange |
Public Method | Clear |
Public Method | Contains |
Public Method | CopyTo |
Public Method | GetEnumerator |
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt |
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState |
Protected Method | OnClear |
Protected Method | OnClearComplete |
Protected Method | OnInsert |
Protected Method | OnInsertComplete |
Protected Method | OnRemove |
Protected Method | OnRemoveComplete |
Protected Method | SaveViewState |
Protected Method | SetItemDirty |
Top

See Also

Reference

Generic ChartingStateManagedCollection Class
Telerik.Reporting.Charting Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : Add Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Add( _
   ByVal item As T _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim item As T

instance.Add(item)
C#
public virtual void Add(
   T item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : AddRange Method

itemsToAdd

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddRange( _
   ByVal itemsToAdd() As T _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim itemsToAdd() As T

instance.AddRange(itemsToAdd)
C#
public virtual void AddRange(
   T[] itemsToAdd
)

Parameters

itemsToAdd

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


Clear Method

Clear Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : Clear Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


Contains Method

Contains Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : Contains Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Contains( _
   ByVal item As T _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim item As T
Dim value As Boolean

value = instance.Contains(item)
C#
public virtual bool Contains(
   T item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


CopyTo Method

CopyTo Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : CopyTo Method

array
arrayIndex

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As T, _
   ByVal arrayIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim array() As T
Dim arrayIndex As Integer

instance.CopyTo(array, arrayIndex)
C#
public void CopyTo(
   T[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


GetEnumerator Method

GetEnumerator Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : GetEnumerator Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of T)
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim value As IEnumerator(Of T)

value = instance.GetEnumerator()
C#
public IEnumerator<T> GetEnumerator()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


IndexOf Method

IndexOf Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : IndexOf Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As T _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim item As T
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   T item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


Insert Method

Insert Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : Insert Method

index
item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Insert( _
   ByVal index As Integer, _
   ByVal item As T _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim index As Integer
Dim item As T

instance.Insert(index, item)
C#
public virtual void Insert(
   int index,
   T item
)

Parameters

index
item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : LoadViewState Method

state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub LoadViewState( _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim state As Object

instance.LoadViewState(state)
C#
protected virtual void LoadViewState(
   object state
)

Parameters

state

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


OnClear Method

OnClear Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : OnClear Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClear()
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)

instance.OnClear()
C#
protected virtual void OnClear()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


OnClearComplete Method

OnClearComplete Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : OnClearComplete Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClearComplete()
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)

instance.OnClearComplete()
C#
protected virtual void OnClearComplete()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


OnInsert Method

OnInsert Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : OnInsert Method

index
value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnInsert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim index As Integer
Dim value As Object

instance.OnInsert(index, value)
C#
protected virtual void OnInsert(
   int index,
   object value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


OnInsertComplete Method

OnInsertComplete Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : OnInsertComplete Method

index
value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnInsertComplete( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim index As Integer
Dim value As Object

instance.OnInsertComplete(index, value)
C#
protected virtual void OnInsertComplete(
   int index,
   object value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


OnRemove Method

OnRemove Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : OnRemove Method

index
value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRemove( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim index As Integer
Dim value As Object

instance.OnRemove(index, value)
C#
protected virtual void OnRemove(
   int index,
   object value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


OnRemoveComplete Method

OnRemoveComplete Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : OnRemoveComplete Method

index
value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRemoveComplete( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim index As Integer
Dim value As Object

instance.OnRemoveComplete(index, value)
C#
protected virtual void OnRemoveComplete(
   int index,
   object value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : Remove Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Remove( _
   ByVal item As T _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim item As T
Dim value As Boolean

value = instance.Remove(item)
C#
public virtual bool Remove(
   T item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


RemoveAt Method

RemoveAt Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : RemoveAt Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim index As Integer

instance.RemoveAt(index)
C#
public virtual void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim value As Object

value = instance.SaveViewState()
C#
protected virtual object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


SetItemDirty Method

SetItemDirty Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : SetItemDirty Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetItemDirty( _
   ByVal item As T _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim item As T

instance.SetItemDirty(item)
C#
protected virtual void SetItemDirty(
   T item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : ToString Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


Generic ChartingStateManagedCollection Class Properties

Generic ChartingStateManagedCollection Class Properties
[image]
Telerik.Reporting.Charting Namespace : Generic ChartingStateManagedCollection Class

For a list of all members of this type, see Generic ChartingStateManagedCollection members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | Item |
Top

Protected Properties

 | Name | Description
Protected Property | List |
Top

See Also

Reference

Generic ChartingStateManagedCollection Class
Telerik.Reporting.Charting Namespace


Count Property

Count Property
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : Count Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


IsReadOnly Property

IsReadOnly Property
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : IsReadOnly Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


Item Property

Item Property
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : Item Property

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Default Property Item( _
   ByVal index As Integer _
) As T
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim index As Integer
Dim value As T

instance.Item(index) = value

value = instance.Item(index)
C#
public virtual T this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


List Property

List Property
[image]
Telerik.Reporting.Charting Namespace > Generic ChartingStateManagedCollection Class : List Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property List As IList(Of T)
Visual Basic (Usage) Copy Code
Dim instance As ChartingStateManagedCollection(Of T)
Dim value As IList(Of T)

value = instance.List
C#
protected IList<T> List {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic ChartingStateManagedCollection Class
Generic ChartingStateManagedCollection Members


ChartItemDataBoundEventArgs Class

ChartItemDataBoundEventArgs Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartItemDataBoundEventArgs Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartItemDataBoundEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ChartItemDataBoundEventArgs
C#
public class ChartItemDataBoundEventArgs : EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.Reporting.Charting.ChartItemDataBoundEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartItemDataBoundEventArgs Members
Telerik.Reporting.Charting Namespace


ChartItemDataBoundEventArgs Class Members

ChartItemDataBoundEventArgs Class Members
See Also Properties
[image]
Telerik.Reporting.Charting Namespace : ChartItemDataBoundEventArgs Class

The following tables list the members exposed by ChartItemDataBoundEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ChartItemDataBoundEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | ChartSeries |
Public Property | DataItem |
Public Property | SeriesItem |
Top

See Also

Reference

ChartItemDataBoundEventArgs Class
Telerik.Reporting.Charting Namespace


ChartItemDataBoundEventArgs Constructor

ChartItemDataBoundEventArgs Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartItemDataBoundEventArgs Class : ChartItemDataBoundEventArgs Constructor

seriesItem
chartSeries
dataItem

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal seriesItem As ChartSeriesItem, _
   ByVal chartSeries As ChartSeries, _
   ByVal dataItem As Object _
)
Visual Basic (Usage) Copy Code
Dim seriesItem As ChartSeriesItem
Dim chartSeries As ChartSeries
Dim dataItem As Object

Dim instance As ChartItemDataBoundEventArgs(seriesItem, chartSeries, dataItem)
C#
public ChartItemDataBoundEventArgs(
   ChartSeriesItem seriesItem,
   ChartSeries chartSeries,
   object dataItem
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal seriesItem As ChartSeriesItem, _
   ByVal chartSeries As ChartSeries, _
   ByVal dataItem As Object _
)
Visual Basic (Usage) Copy Code
Dim seriesItem As ChartSeriesItem
Dim chartSeries As ChartSeries
Dim dataItem As Object

Dim instance As ChartItemDataBoundEventArgs(seriesItem, chartSeries, dataItem)
C#
public ChartItemDataBoundEventArgs(
   ChartSeriesItem seriesItem,
   ChartSeries chartSeries,
   object dataItem
)

Parameters

seriesItem
chartSeries
dataItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartItemDataBoundEventArgs Class
ChartItemDataBoundEventArgs Members


ChartItemDataBoundEventArgs Class Properties

ChartItemDataBoundEventArgs Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartItemDataBoundEventArgs Class

For a list of all members of this type, see ChartItemDataBoundEventArgs members.

Public Properties

 | Name | Description
Public Property | ChartSeries |
Public Property | DataItem |
Public Property | SeriesItem |
Top

See Also

Reference

ChartItemDataBoundEventArgs Class
Telerik.Reporting.Charting Namespace


ChartSeries Property

ChartSeries Property
[image]
Telerik.Reporting.Charting Namespace > ChartItemDataBoundEventArgs Class : ChartSeries Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ChartSeries As ChartSeries
Visual Basic (Usage) Copy Code
Dim instance As ChartItemDataBoundEventArgs
Dim value As ChartSeries

instance.ChartSeries = value

value = instance.ChartSeries
C#
public ChartSeries ChartSeries {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartItemDataBoundEventArgs Class
ChartItemDataBoundEventArgs Members


DataItem Property

DataItem Property
[image]
Telerik.Reporting.Charting Namespace > ChartItemDataBoundEventArgs Class : DataItem Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataItem As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartItemDataBoundEventArgs
Dim value As Object

instance.DataItem = value

value = instance.DataItem
C#
public object DataItem {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartItemDataBoundEventArgs Class
ChartItemDataBoundEventArgs Members


SeriesItem Property

SeriesItem Property
[image]
Telerik.Reporting.Charting Namespace > ChartItemDataBoundEventArgs Class : SeriesItem Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property SeriesItem As ChartSeriesItem
Visual Basic (Usage) Copy Code
Dim instance As ChartItemDataBoundEventArgs
Dim value As ChartSeriesItem

instance.SeriesItem = value

value = instance.SeriesItem
C#
public ChartSeriesItem SeriesItem {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartItemDataBoundEventArgs Class
ChartItemDataBoundEventArgs Members


ChartLabel Class

ChartLabel Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartLabel Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartLabel
   Inherits ChartBaseLabel
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartLabel
C#
public class ChartLabel : ChartBaseLabel, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ChartLabel
Telerik.Reporting.Charting.AxisLabelHidden
Telerik.Reporting.Charting.ChartAxisItem
Telerik.Reporting.Charting.ChartTitle
Telerik.Reporting.Charting.EmptySeriesMessage
Telerik.Reporting.Charting.LabelItem
Telerik.Reporting.Charting.MarkedZoneLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabel Members
Telerik.Reporting.Charting Namespace


ChartLabel Class Members

ChartLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartLabel Class

The following tables list the members exposed by ChartLabel.

Public Constructors

 | Name | Description
Public Constructor | ChartLabel Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

ChartLabel Class
Telerik.Reporting.Charting Namespace


ChartLabel Constructor

ChartLabel Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartLabel Class : ChartLabel Constructor

Overload List

Overload | Description
ChartLabel Constructor() |
ChartLabel Constructor(Chart,IContainer) |
ChartLabel Constructor(Object) |
ChartLabel Constructor(Object,IContainer,StyleLabel,TextBlock,String) |
ChartLabel Constructor(String) |
ChartLabel Constructor(StyleLabel) |
ChartLabel Constructor(StyleLabel,Object) |
ChartLabel Constructor(StyleLabel,String) |
ChartLabel Constructor(StyleLabel,TextBlock) |
ChartLabel Constructor(StyleLabel,TextBlock,Object) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabel Class
ChartLabel Members


ChartLabel Constructor()

ChartLabel Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartLabel Class > ChartLabel Constructor : ChartLabel Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartLabel()
C#
public ChartLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartLabel()
C#
public ChartLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabel Class
ChartLabel Members
Overload List


ChartLabel Constructor(Chart,IContainer)

ChartLabel Constructor(Chart,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartLabel Class > ChartLabel Constructor : ChartLabel Constructor(Chart,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart
Dim container As IContainer

Dim instance As ChartLabel(parent, container)
C#
public ChartLabel(
   Chart parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart
Dim container As IContainer

Dim instance As ChartLabel(parent, container)
C#
public ChartLabel(
   Chart parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabel Class
ChartLabel Members
Overload List


ChartLabel Constructor(Object)

ChartLabel Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartLabel Class > ChartLabel Constructor : ChartLabel Constructor(Object)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As ChartLabel(parent)
C#
public ChartLabel(
   object parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As ChartLabel(parent)
C#
public ChartLabel(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabel Class
ChartLabel Members
Overload List


ChartLabel Constructor(Object,IContainer,StyleLabel,TextBlock,String)

ChartLabel Constructor(Object,IContainer,StyleLabel,TextBlock,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartLabel Class > ChartLabel Constructor : ChartLabel Constructor(Object,IContainer,StyleLabel,TextBlock,String)

parent
container
appearance
textBlock
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer, _
   ByVal appearance As StyleLabel, _
   ByVal textBlock As TextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer
Dim appearance As StyleLabel
Dim textBlock As TextBlock
Dim text As String

Dim instance As ChartLabel(parent, container, appearance, textBlock, text)
C#
public ChartLabel(
   object parent,
   IContainer container,
   StyleLabel appearance,
   TextBlock textBlock,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer, _
   ByVal appearance As StyleLabel, _
   ByVal textBlock As TextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer
Dim appearance As StyleLabel
Dim textBlock As TextBlock
Dim text As String

Dim instance As ChartLabel(parent, container, appearance, textBlock, text)
C#
public ChartLabel(
   object parent,
   IContainer container,
   StyleLabel appearance,
   TextBlock textBlock,
   string text
)

Parameters

parent
container
appearance
textBlock
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabel Class
ChartLabel Members
Overload List


ChartLabel Constructor(String)

ChartLabel Constructor(String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartLabel Class > ChartLabel Constructor : ChartLabel Constructor(String)

text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As ChartLabel(text)
C#
public ChartLabel(
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As ChartLabel(text)
C#
public ChartLabel(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabel Class
ChartLabel Members
Overload List


ChartLabel Constructor(StyleLabel)

ChartLabel Constructor(StyleLabel)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartLabel Class > ChartLabel Constructor : ChartLabel Constructor(StyleLabel)

appearance

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel

Dim instance As ChartLabel(appearance)
C#
public ChartLabel(
   StyleLabel appearance
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel

Dim instance As ChartLabel(appearance)
C#
public ChartLabel(
   StyleLabel appearance
)

Parameters

appearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabel Class
ChartLabel Members
Overload List


ChartLabel Constructor(StyleLabel,Object)

ChartLabel Constructor(StyleLabel,Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartLabel Class > ChartLabel Constructor : ChartLabel Constructor(StyleLabel,Object)

appearance
parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim parent As Object

Dim instance As ChartLabel(appearance, parent)
C#
public ChartLabel(
   StyleLabel appearance,
   object parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim parent As Object

Dim instance As ChartLabel(appearance, parent)
C#
public ChartLabel(
   StyleLabel appearance,
   object parent
)

Parameters

appearance
parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabel Class
ChartLabel Members
Overload List


ChartLabel Constructor(StyleLabel,String)

ChartLabel Constructor(StyleLabel,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartLabel Class > ChartLabel Constructor : ChartLabel Constructor(StyleLabel,String)

appearance
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim text As String

Dim instance As ChartLabel(appearance, text)
C#
public ChartLabel(
   StyleLabel appearance,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim text As String

Dim instance As ChartLabel(appearance, text)
C#
public ChartLabel(
   StyleLabel appearance,
   string text
)

Parameters

appearance
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabel Class
ChartLabel Members
Overload List


ChartLabel Constructor(StyleLabel,TextBlock)

ChartLabel Constructor(StyleLabel,TextBlock)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartLabel Class > ChartLabel Constructor : ChartLabel Constructor(StyleLabel,TextBlock)

appearance
textBlock

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal textBlock As TextBlock _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim textBlock As TextBlock

Dim instance As ChartLabel(appearance, textBlock)
C#
public ChartLabel(
   StyleLabel appearance,
   TextBlock textBlock
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal textBlock As TextBlock _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim textBlock As TextBlock

Dim instance As ChartLabel(appearance, textBlock)
C#
public ChartLabel(
   StyleLabel appearance,
   TextBlock textBlock
)

Parameters

appearance
textBlock

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabel Class
ChartLabel Members
Overload List


ChartLabel Constructor(StyleLabel,TextBlock,Object)

ChartLabel Constructor(StyleLabel,TextBlock,Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartLabel Class > ChartLabel Constructor : ChartLabel Constructor(StyleLabel,TextBlock,Object)

appearance
textBlock
parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal textBlock As TextBlock, _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim textBlock As TextBlock
Dim parent As Object

Dim instance As ChartLabel(appearance, textBlock, parent)
C#
public ChartLabel(
   StyleLabel appearance,
   TextBlock textBlock,
   object parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal textBlock As TextBlock, _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim textBlock As TextBlock
Dim parent As Object

Dim instance As ChartLabel(appearance, textBlock, parent)
C#
public ChartLabel(
   StyleLabel appearance,
   TextBlock textBlock,
   object parent
)

Parameters

appearance
textBlock
parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabel Class
ChartLabel Members
Overload List


ChartLabel Class Properties

ChartLabel Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartLabel Class

For a list of all members of this type, see ChartLabel members.

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartLabel Class
Telerik.Reporting.Charting Namespace


Appearance Property

Appearance Property
[image]
Telerik.Reporting.Charting Namespace > ChartLabel Class : Appearance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Appearance As StyleLabel
Visual Basic (Usage) Copy Code
Dim instance As ChartLabel
Dim value As StyleLabel

value = instance.Appearance
C#
public virtual StyleLabel Appearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabel Class
ChartLabel Members


ChartLabelsCollection Class

ChartLabelsCollection Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartLabelsCollection Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartLabelsCollection
   Inherits ChartingStateManagedCollection(Of LabelItem)
   Implements IChartingStateManager, IDeserializableCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection
C#
public class ChartLabelsCollection : ChartingStateManagedCollection<LabelItem>, IChartingStateManager, IDeserializableCollection

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>
Telerik.Reporting.Charting.ChartLabelsCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Members
Telerik.Reporting.Charting Namespace


ChartLabelsCollection Class Members

ChartLabelsCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartLabelsCollection Class

The following tables list the members exposed by ChartLabelsCollection.

Public Constructors

 | Name | Description
Public Constructor | ChartLabelsCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Property | Item | Overridden.
Public Property | Parent |
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overridden.
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Method | Clear |
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Method | Insert | Overridden.
Public Method | Remove | Overridden.
Public Method | RemoveAt | Overridden.
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | Overridden.
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Protected Method | OnClearComplete | Overridden.
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Protected Method | OnInsertComplete | Overridden.
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Protected Method | OnRemoveComplete | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Top

See Also

Reference

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


ChartLabelsCollection Constructor

ChartLabelsCollection Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartLabelsCollection Class : ChartLabelsCollection Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection()
C#
public ChartLabelsCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection()
C#
public ChartLabelsCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Class
ChartLabelsCollection Members


ChartLabelsCollection Class Methods

ChartLabelsCollection Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartLabelsCollection Class

For a list of all members of this type, see ChartLabelsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overridden.
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Method | Clear |
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Method | Insert | Overridden.
Public Method | Remove | Overridden.
Public Method | RemoveAt | Overridden.
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | Overridden.
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Protected Method | OnClearComplete | Overridden.
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Protected Method | OnInsertComplete | Overridden.
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Protected Method | OnRemoveComplete | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Top

See Also

Reference

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting Namespace > ChartLabelsCollection Class : Add Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Add( _
   ByVal item As LabelItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection
Dim item As LabelItem

instance.Add(item)
C#
public override void Add(
   LabelItem item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Class
ChartLabelsCollection Members


Clear Method

Clear Method
[image]
Telerik.Reporting.Charting Namespace > ChartLabelsCollection Class : Clear Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Class
ChartLabelsCollection Members


Insert Method

Insert Method
[image]
Telerik.Reporting.Charting Namespace > ChartLabelsCollection Class : Insert Method

index
item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As LabelItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection
Dim index As Integer
Dim item As LabelItem

instance.Insert(index, item)
C#
public override void Insert(
   int index,
   LabelItem item
)

Parameters

index
item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Class
ChartLabelsCollection Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartLabelsCollection Class : LoadViewState Method

state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection
Dim state As Object

instance.LoadViewState(state)
C#
protected override void LoadViewState(
   object state
)

Parameters

state

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Class
ChartLabelsCollection Members


OnClearComplete Method

OnClearComplete Method
[image]
Telerik.Reporting.Charting Namespace > ChartLabelsCollection Class : OnClearComplete Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnClearComplete()
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection

instance.OnClearComplete()
C#
protected override void OnClearComplete()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Class
ChartLabelsCollection Members


OnInsertComplete Method

OnInsertComplete Method
[image]
Telerik.Reporting.Charting Namespace > ChartLabelsCollection Class : OnInsertComplete Method

index
value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnInsertComplete( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection
Dim index As Integer
Dim value As Object

instance.OnInsertComplete(index, value)
C#
protected override void OnInsertComplete(
   int index,
   object value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Class
ChartLabelsCollection Members


OnRemoveComplete Method

OnRemoveComplete Method
[image]
Telerik.Reporting.Charting Namespace > ChartLabelsCollection Class : OnRemoveComplete Method

index
value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnRemoveComplete( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection
Dim index As Integer
Dim value As Object

instance.OnRemoveComplete(index, value)
C#
protected override void OnRemoveComplete(
   int index,
   object value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Class
ChartLabelsCollection Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Charting Namespace > ChartLabelsCollection Class : Remove Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Remove( _
   ByVal item As LabelItem _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection
Dim item As LabelItem
Dim value As Boolean

value = instance.Remove(item)
C#
public override bool Remove(
   LabelItem item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Class
ChartLabelsCollection Members


RemoveAt Method

RemoveAt Method
[image]
Telerik.Reporting.Charting Namespace > ChartLabelsCollection Class : RemoveAt Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public override void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Class
ChartLabelsCollection Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartLabelsCollection Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Class
ChartLabelsCollection Members


ChartLabelsCollection Class Properties

ChartLabelsCollection Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartLabelsCollection Class

For a list of all members of this type, see ChartLabelsCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Public Property | Item | Overridden.
Public Property | Parent |
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>)
Top

See Also

Reference

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Charting Namespace > ChartLabelsCollection Class : Item Property

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Default Property Item( _
   ByVal index As Integer _
) As LabelItem
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection
Dim index As Integer
Dim value As LabelItem

instance.Item(index) = value

value = instance.Item(index)
C#
public override LabelItem this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Class
ChartLabelsCollection Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > ChartLabelsCollection Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelsCollection
Dim value As Object

instance.Parent = value

value = instance.Parent
C#
public object Parent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLabelsCollection Class
ChartLabelsCollection Members


ChartLegend Class

ChartLegend Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartLegend Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartLegend
   Inherits ExtendedLabel
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartLegend
C#
public class ChartLegend : ExtendedLabel, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ExtendedLabel
Telerik.Reporting.Charting.ChartLegend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLegend Members
Telerik.Reporting.Charting Namespace


ChartLegend Class Members

ChartLegend Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartLegend Class

The following tables list the members exposed by ChartLegend.

Public Constructors

 | Name | Description
Public Constructor | ChartLegend Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | extendedLabelItems | (Inherited from ExtendedLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ExtendedLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Item | Overridden.
Public Property | Items | (Inherited from ExtendedLabel)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | AddCustomItemToLegend |
Public Method | AddLabel | Overloaded. (Inherited from ExtendedLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clear | (Inherited from ExtendedLabel)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetLabel | (Inherited from ExtendedLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAllLabels | (Inherited from ExtendedLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | RemoveLabel | Overloaded. (Inherited from ExtendedLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ExtendedLabel)
Protected Method | SaveViewState | (Inherited from ExtendedLabel)
Protected Method | TrackViewState | (Inherited from ExtendedLabel)
Top

See Also

Reference

ChartLegend Class
Telerik.Reporting.Charting Namespace


ChartLegend Constructor

ChartLegend Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartLegend Class : ChartLegend Constructor

Overload List

Overload | Description
ChartLegend Constructor() |
ChartLegend Constructor(Chart,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLegend Class
ChartLegend Members


ChartLegend Constructor()

ChartLegend Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartLegend Class > ChartLegend Constructor : ChartLegend Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartLegend()
C#
public ChartLegend()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartLegend()
C#
public ChartLegend()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLegend Class
ChartLegend Members
Overload List


ChartLegend Constructor(Chart,IContainer)

ChartLegend Constructor(Chart,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartLegend Class > ChartLegend Constructor : ChartLegend Constructor(Chart,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart
Dim container As IContainer

Dim instance As ChartLegend(parent, container)
C#
public ChartLegend(
   Chart parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart
Dim container As IContainer

Dim instance As ChartLegend(parent, container)
C#
public ChartLegend(
   Chart parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLegend Class
ChartLegend Members
Overload List


ChartLegend Class Methods

ChartLegend Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartLegend Class

For a list of all members of this type, see ChartLegend members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | AddCustomItemToLegend |
Public Method | AddLabel | Overloaded. (Inherited from ExtendedLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clear | (Inherited from ExtendedLabel)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetLabel | (Inherited from ExtendedLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAllLabels | (Inherited from ExtendedLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | RemoveLabel | Overloaded. (Inherited from ExtendedLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ExtendedLabel)
Protected Method | SaveViewState | (Inherited from ExtendedLabel)
Protected Method | TrackViewState | (Inherited from ExtendedLabel)
Top

See Also

Reference

ChartLegend Class
Telerik.Reporting.Charting Namespace


AddCustomItemToLegend Method

AddCustomItemToLegend Method
[image]
Telerik.Reporting.Charting Namespace > ChartLegend Class : AddCustomItemToLegend Method

description
fillStyle
figure

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddCustomItemToLegend( _
   ByVal description As String, _
   ByVal fillStyle As FillStyle, _
   ByVal figure As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegend
Dim description As String
Dim fillStyle As FillStyle
Dim figure As String

instance.AddCustomItemToLegend(description, fillStyle, figure)
C#
public void AddCustomItemToLegend(
   string description,
   FillStyle fillStyle,
   string figure
)

Parameters

description
fillStyle
figure

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLegend Class
ChartLegend Members


ChartLegend Class Properties

ChartLegend Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartLegend Class

For a list of all members of this type, see ChartLegend members.

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ExtendedLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Item | Overridden.
Public Property | Items | (Inherited from ExtendedLabel)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartLegend Class
Telerik.Reporting.Charting Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Charting Namespace > ChartLegend Class : Item Property

itemIndex

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Default Property Item( _
   ByVal itemIndex As Integer _
) As LabelItem
Visual Basic (Usage) Copy Code
Dim instance As ChartLegend
Dim itemIndex As Integer
Dim value As LabelItem

instance.Item(itemIndex) = value

value = instance.Item(itemIndex)
C#
public override LabelItem this[
   int itemIndex
]; {get; set;}

Parameters

itemIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartLegend Class
ChartLegend Members


ChartMarkedZone Class

ChartMarkedZone Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartMarkedZone Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartMarkedZone
   Inherits RenderedObject
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
C#
public class ChartMarkedZone : RenderedObject, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.ChartMarkedZone

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Members
Telerik.Reporting.Charting Namespace


ChartMarkedZone Class Members

ChartMarkedZone Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartMarkedZone Class

The following tables list the members exposed by ChartMarkedZone.

Public Constructors

 | Name | Description
Public Constructor | ChartMarkedZone Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Label |
Public Property | Name |
Public Property | ValueEndX |
Public Property | ValueEndY |
Public Property | ValueStartX |
Public Property | ValueStartY |
Public Property | Visible |
Public Property | YAxisType |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Dispose | Overloaded.
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


ChartMarkedZone Constructor

ChartMarkedZone Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : ChartMarkedZone Constructor

Overload List

Overload | Description
ChartMarkedZone Constructor() |
ChartMarkedZone Constructor(IContainer) |
ChartMarkedZone Constructor(String) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


ChartMarkedZone Constructor()

ChartMarkedZone Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class > ChartMarkedZone Constructor : ChartMarkedZone Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone()
C#
public ChartMarkedZone()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone()
C#
public ChartMarkedZone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members
Overload List


ChartMarkedZone Constructor(IContainer)

ChartMarkedZone Constructor(IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class > ChartMarkedZone Constructor : ChartMarkedZone Constructor(IContainer)

container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As ChartMarkedZone(container)
C#
public ChartMarkedZone(
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As ChartMarkedZone(container)
C#
public ChartMarkedZone(
   IContainer container
)

Parameters

container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members
Overload List


ChartMarkedZone Constructor(String)

ChartMarkedZone Constructor(String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class > ChartMarkedZone Constructor : ChartMarkedZone Constructor(String)

name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As ChartMarkedZone(name)
C#
public ChartMarkedZone(
   string name
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As ChartMarkedZone(name)
C#
public ChartMarkedZone(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members
Overload List


ChartMarkedZone Class Methods

ChartMarkedZone Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartMarkedZone Class

For a list of all members of this type, see ChartMarkedZone members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Dispose | Overloaded.
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : Dispose Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : Finalize Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : ToString Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


ChartMarkedZone Class Properties

ChartMarkedZone Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartMarkedZone Class

For a list of all members of this type, see ChartMarkedZone members.

Public Properties

 | Name | Description
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Label |
Public Property | Name |
Public Property | ValueEndX |
Public Property | ValueEndY |
Public Property | ValueStartX |
Public Property | ValueStartY |
Public Property | Visible |
Public Property | YAxisType |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


Appearance Property

Appearance Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : Appearance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleMarkedZone
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
Dim value As StyleMarkedZone

value = instance.Appearance
C#
public StyleMarkedZone Appearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


Label Property

Label Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : Label Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Label As ChartLabel
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
Dim value As ChartLabel

value = instance.Label
C#
public ChartLabel Label {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


Name Property

Name Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : Name Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


ValueEndX Property

ValueEndX Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : ValueEndX Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueEndX As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
Dim value As Double

instance.ValueEndX = value

value = instance.ValueEndX
C#
public double ValueEndX {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


ValueEndY Property

ValueEndY Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : ValueEndY Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueEndY As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
Dim value As Double

instance.ValueEndY = value

value = instance.ValueEndY
C#
public double ValueEndY {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


ValueStartX Property

ValueStartX Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : ValueStartX Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueStartX As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
Dim value As Double

instance.ValueStartX = value

value = instance.ValueStartX
C#
public double ValueStartX {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


ValueStartY Property

ValueStartY Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : ValueStartY Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueStartY As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
Dim value As Double

instance.ValueStartY = value

value = instance.ValueStartY
C#
public double ValueStartY {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : Visible Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


YAxisType Property

YAxisType Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZone Class : YAxisType Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property YAxisType As ChartYAxisType
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZone
Dim value As ChartYAxisType

instance.YAxisType = value

value = instance.YAxisType
C#
public ChartYAxisType YAxisType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZone Class
ChartMarkedZone Members


ChartMarkedZonesCollection Class

ChartMarkedZonesCollection Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartMarkedZonesCollection Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartMarkedZonesCollection
   Inherits ChartingStateManagedCollection(Of ChartMarkedZone)
   Implements IChartingStateManager, IDeserializableCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZonesCollection
C#
public class ChartMarkedZonesCollection : ChartingStateManagedCollection<ChartMarkedZone>, IChartingStateManager, IDeserializableCollection

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>
Telerik.Reporting.Charting.ChartMarkedZonesCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZonesCollection Members
Telerik.Reporting.Charting Namespace


ChartMarkedZonesCollection Class Members

ChartMarkedZonesCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartMarkedZonesCollection Class

The following tables list the members exposed by ChartMarkedZonesCollection.

Public Constructors

 | Name | Description
Public Constructor | ChartMarkedZonesCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Property | Item | Overridden.
Public Property | Parent |
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overridden.
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Method | Clear |
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Method | Insert | Overridden.
Public Method | Remove | Overridden.
Public Method | RemoveAt | Overridden.
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Top

See Also

Reference

ChartMarkedZonesCollection Class
Telerik.Reporting.Charting Namespace


ChartMarkedZonesCollection Constructor

ChartMarkedZonesCollection Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZonesCollection Class : ChartMarkedZonesCollection Constructor

Overload List

Overload | Description
ChartMarkedZonesCollection Constructor() |
ChartMarkedZonesCollection Constructor(ChartPlotArea) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZonesCollection Class
ChartMarkedZonesCollection Members


ChartMarkedZonesCollection Constructor()

ChartMarkedZonesCollection Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZonesCollection Class > ChartMarkedZonesCollection Constructor : ChartMarkedZonesCollection Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZonesCollection()
C#
public ChartMarkedZonesCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZonesCollection()
C#
public ChartMarkedZonesCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZonesCollection Class
ChartMarkedZonesCollection Members
Overload List


ChartMarkedZonesCollection Constructor(ChartPlotArea)

ChartMarkedZonesCollection Constructor(ChartPlotArea)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZonesCollection Class > ChartMarkedZonesCollection Constructor : ChartMarkedZonesCollection Constructor(ChartPlotArea)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartPlotArea _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartPlotArea

Dim instance As ChartMarkedZonesCollection(parent)
C#
public ChartMarkedZonesCollection(
   ChartPlotArea parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartPlotArea _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartPlotArea

Dim instance As ChartMarkedZonesCollection(parent)
C#
public ChartMarkedZonesCollection(
   ChartPlotArea parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZonesCollection Class
ChartMarkedZonesCollection Members
Overload List


ChartMarkedZonesCollection Class Methods

ChartMarkedZonesCollection Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartMarkedZonesCollection Class

For a list of all members of this type, see ChartMarkedZonesCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overridden.
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Method | Clear |
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Method | Insert | Overridden.
Public Method | Remove | Overridden.
Public Method | RemoveAt | Overridden.
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Top

See Also

Reference

ChartMarkedZonesCollection Class
Telerik.Reporting.Charting Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZonesCollection Class : Add Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Add( _
   ByVal item As ChartMarkedZone _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZonesCollection
Dim item As ChartMarkedZone

instance.Add(item)
C#
public override void Add(
   ChartMarkedZone item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZonesCollection Class
ChartMarkedZonesCollection Members


Clear Method

Clear Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZonesCollection Class : Clear Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZonesCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZonesCollection Class
ChartMarkedZonesCollection Members


Insert Method

Insert Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZonesCollection Class : Insert Method

index
item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As ChartMarkedZone _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZonesCollection
Dim index As Integer
Dim item As ChartMarkedZone

instance.Insert(index, item)
C#
public override void Insert(
   int index,
   ChartMarkedZone item
)

Parameters

index
item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZonesCollection Class
ChartMarkedZonesCollection Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZonesCollection Class : Remove Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Remove( _
   ByVal item As ChartMarkedZone _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZonesCollection
Dim item As ChartMarkedZone
Dim value As Boolean

value = instance.Remove(item)
C#
public override bool Remove(
   ChartMarkedZone item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZonesCollection Class
ChartMarkedZonesCollection Members


RemoveAt Method

RemoveAt Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZonesCollection Class : RemoveAt Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZonesCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public override void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZonesCollection Class
ChartMarkedZonesCollection Members


ChartMarkedZonesCollection Class Properties

ChartMarkedZonesCollection Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartMarkedZonesCollection Class

For a list of all members of this type, see ChartMarkedZonesCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Public Property | Item | Overridden.
Public Property | Parent |
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>)
Top

See Also

Reference

ChartMarkedZonesCollection Class
Telerik.Reporting.Charting Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZonesCollection Class : Item Property

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Default Property Item( _
   ByVal index As Integer _
) As ChartMarkedZone
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZonesCollection
Dim index As Integer
Dim value As ChartMarkedZone

instance.Item(index) = value

value = instance.Item(index)
C#
public override ChartMarkedZone this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZonesCollection Class
ChartMarkedZonesCollection Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarkedZonesCollection Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As ChartPlotArea
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkedZonesCollection
Dim value As ChartPlotArea

instance.Parent = value

value = instance.Parent
C#
public ChartPlotArea Parent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarkedZonesCollection Class
ChartMarkedZonesCollection Members


ChartMarker Class

ChartMarker Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartMarker Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartMarker
   Inherits LayoutElement
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartMarker
C#
public class ChartMarker : LayoutElement, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartMarker

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Members
Telerik.Reporting.Charting Namespace


ChartMarker Class Members

ChartMarker Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartMarker Class

The following tables list the members exposed by ChartMarker.

Public Constructors

 | Name | Description
Public Constructor | ChartMarker Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartMarkerActiveRegion |
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion |
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom |
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartMarker Class
Telerik.Reporting.Charting Namespace


ChartMarker Constructor

ChartMarker Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class : ChartMarker Constructor

Overload List

Overload | Description
ChartMarker Constructor() |
ChartMarker Constructor(IContainer) |
ChartMarker Constructor(Object) |
ChartMarker Constructor(Object,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members


ChartMarker Constructor()

ChartMarker Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class > ChartMarker Constructor : ChartMarker Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarker()
C#
public ChartMarker()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarker()
C#
public ChartMarker()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members
Overload List


ChartMarker Constructor(IContainer)

ChartMarker Constructor(IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class > ChartMarker Constructor : ChartMarker Constructor(IContainer)

container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As ChartMarker(container)
C#
public ChartMarker(
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As ChartMarker(container)
C#
public ChartMarker(
   IContainer container
)

Parameters

container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members
Overload List


ChartMarker Constructor(Object)

ChartMarker Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class > ChartMarker Constructor : ChartMarker Constructor(Object)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As ChartMarker(parent)
C#
public ChartMarker(
   object parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As ChartMarker(parent)
C#
public ChartMarker(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members
Overload List


ChartMarker Constructor(Object,IContainer)

ChartMarker Constructor(Object,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class > ChartMarker Constructor : ChartMarker Constructor(Object,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer

Dim instance As ChartMarker(parent, container)
C#
public ChartMarker(
   object parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer

Dim instance As ChartMarker(parent, container)
C#
public ChartMarker(
   object parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members
Overload List


ChartMarker Class Methods

ChartMarker Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartMarker Class

For a list of all members of this type, see ChartMarker members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom |
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartMarker Class
Telerik.Reporting.Charting Namespace


CopyFrom Method

CopyFrom Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class : CopyFrom Method

marker

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyFrom( _
   ByVal marker As ChartMarker _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarker
Dim marker As ChartMarker

instance.CopyFrom(marker)
C#
public void CopyFrom(
   ChartMarker marker
)

Parameters

marker

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarker
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartMarker
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarker

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members


ChartMarker Class Properties

ChartMarker Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartMarker Class

For a list of all members of this type, see ChartMarker members.

Public Properties

 | Name | Description
Public Property | ActiveRegion |
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartMarker Class
Telerik.Reporting.Charting Namespace


ActiveRegion Property

ActiveRegion Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class : ActiveRegion Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveRegion As ActiveRegion
Visual Basic (Usage) Copy Code
Dim instance As ChartMarker
Dim value As ActiveRegion

instance.ActiveRegion = value

value = instance.ActiveRegion
C#
public ActiveRegion ActiveRegion {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members


Appearance Property

Appearance Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class : Appearance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleMarker
Visual Basic (Usage) Copy Code
Dim instance As ChartMarker
Dim value As StyleMarker

value = instance.Appearance
C#
public StyleMarker Appearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartMarker
Dim value As Object

instance.Parent = value

value = instance.Parent
C#
public object Parent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class : Visible Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartMarker
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members


ChartMarker Class Fields

ChartMarker Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartMarker Class

For a list of all members of this type, see ChartMarker members.

Protected Fields

 | Name | Description
Protected Field | chartMarkerActiveRegion |
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

ChartMarker Class
Telerik.Reporting.Charting Namespace


chartMarkerActiveRegion Field

chartMarkerActiveRegion Field
[image]
Telerik.Reporting.Charting Namespace > ChartMarker Class : chartMarkerActiveRegion Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected chartMarkerActiveRegion As ActiveRegion
Visual Basic (Usage) Copy Code
Dim instance As ChartMarker
Dim value As ActiveRegion

value = instance.chartMarkerActiveRegion

instance.chartMarkerActiveRegion = value
C#
protected ActiveRegion chartMarkerActiveRegion

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarker Class
ChartMarker Members


ChartPlotArea Class

ChartPlotArea Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartPlotArea Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartPlotArea
   Inherits LayoutElement
   Implements IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
C#
public class ChartPlotArea : LayoutElement, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartPlotArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Members
Telerik.Reporting.Charting Namespace


ChartPlotArea Class Members

ChartPlotArea Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartPlotArea Class

The following tables list the members exposed by ChartPlotArea.

Public Constructors

 | Name | Description
Public Constructor | ChartPlotArea Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | Appearance |
Public Property | Chart |
Public Property | Container | (Inherited from RenderedObject)
Public Property | DataTable |
Public Property | EmptySeriesMessage |
Public Property | IntelligentLabelsEnabled |
Public Property | MarkedZones |
Public Property | Name |
Public Property | NextPosition |
Public Property | OrderList |
Public Property | Parent |
Public Property | SeriesOrientation |
Public Property | Visible |
Public Property | XAxis |
Public Property | YAxis |
Public Property | YAxis2 |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Dispose | Overloaded.
Public Method | GetOrder | Overloaded.
Public Method | Insert |
Public Method | ReIndex |
Public Method | Remove | Overloaded.
Public Method | RemoveAt |
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SeriesCollection |
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


ChartPlotArea Constructor

ChartPlotArea Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : ChartPlotArea Constructor

Overload List

Overload | Description
ChartPlotArea Constructor() |
ChartPlotArea Constructor(Chart) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


ChartPlotArea Constructor()

ChartPlotArea Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class > ChartPlotArea Constructor : ChartPlotArea Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea()
C#
public ChartPlotArea()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea()
C#
public ChartPlotArea()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members
Overload List


ChartPlotArea Constructor(Chart)

ChartPlotArea Constructor(Chart)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class > ChartPlotArea Constructor : ChartPlotArea Constructor(Chart)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart

Dim instance As ChartPlotArea(parent)
C#
public ChartPlotArea(
   Chart parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart

Dim instance As ChartPlotArea(parent)
C#
public ChartPlotArea(
   Chart parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members
Overload List


ChartPlotArea Class Methods

ChartPlotArea Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartPlotArea Class

For a list of all members of this type, see ChartPlotArea members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Dispose | Overloaded.
Public Method | GetOrder | Overloaded.
Public Method | Insert |
Public Method | ReIndex |
Public Method | Remove | Overloaded.
Public Method | RemoveAt |
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SeriesCollection |
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : Add Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal element As IOrdering _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim element As IOrdering

instance.Add(element)
C#
public void Add(
   IOrdering element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : Dispose Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : Finalize Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


GetOrder Method

GetOrder Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : GetOrder Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetOrder(IOrdering) |
GetOrder() | (Inherited from RenderedObject)

Overload List

Overload | Description
GetOrder(IOrdering) |
GetOrder() | (Inherited from RenderedObject)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


GetOrder(IOrdering) Method

GetOrder(IOrdering) Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class > GetOrder Method : GetOrder(IOrdering) Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function GetOrder( _
   ByVal element As IOrdering _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim element As IOrdering
Dim value As Integer

value = instance.GetOrder(element)
C#
public int GetOrder(
   IOrdering element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members
Overload List


Insert Method

Insert Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : Insert Method

order
element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal order As Integer, _
   ByVal element As IOrdering _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim order As Integer
Dim element As IOrdering

instance.Insert(order, element)
C#
public void Insert(
   int order,
   IOrdering element
)

Parameters

order
element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


ReIndex Method

ReIndex Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : ReIndex Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReIndex()
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea

instance.ReIndex()
C#
public void ReIndex()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : Remove Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Remove(IOrdering) |
Remove() | (Inherited from RenderedObject)

Overload List

Overload | Description
Remove(IOrdering) |
Remove() | (Inherited from RenderedObject)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


Remove(IOrdering) Method

Remove(IOrdering) Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class > Remove Method : Remove(IOrdering) Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal element As IOrdering _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim element As IOrdering

instance.Remove(element)
C#
public void Remove(
   IOrdering element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members
Overload List


RemoveAt Method

RemoveAt Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : RemoveAt Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


SeriesCollection Method

SeriesCollection Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : SeriesCollection Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function SeriesCollection() As ChartSeriesCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As ChartSeriesCollection

value = instance.SeriesCollection()
C#
public ChartSeriesCollection SeriesCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


ChartPlotArea Class Properties

ChartPlotArea Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartPlotArea Class

For a list of all members of this type, see ChartPlotArea members.

Public Properties

 | Name | Description
Public Property | Appearance |
Public Property | Chart |
Public Property | Container | (Inherited from RenderedObject)
Public Property | DataTable |
Public Property | EmptySeriesMessage |
Public Property | IntelligentLabelsEnabled |
Public Property | MarkedZones |
Public Property | Name |
Public Property | NextPosition |
Public Property | OrderList |
Public Property | Parent |
Public Property | SeriesOrientation |
Public Property | Visible |
Public Property | XAxis |
Public Property | YAxis |
Public Property | YAxis2 |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


Appearance Property

Appearance Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : Appearance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As StylePlotArea
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As StylePlotArea

value = instance.Appearance
C#
public StylePlotArea Appearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


Chart Property

Chart Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : Chart Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Chart As Chart
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As Chart

value = instance.Chart
C#
public Chart Chart {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


DataTable Property

DataTable Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : DataTable Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataTable As ChartDataTable
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As ChartDataTable

value = instance.DataTable
C#
public ChartDataTable DataTable {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


EmptySeriesMessage Property

EmptySeriesMessage Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : EmptySeriesMessage Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EmptySeriesMessage As EmptySeriesMessage
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As EmptySeriesMessage

value = instance.EmptySeriesMessage
C#
public EmptySeriesMessage EmptySeriesMessage {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


IntelligentLabelsEnabled Property

IntelligentLabelsEnabled Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : IntelligentLabelsEnabled Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property IntelligentLabelsEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As Boolean

instance.IntelligentLabelsEnabled = value

value = instance.IntelligentLabelsEnabled
C#
public bool IntelligentLabelsEnabled {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


MarkedZones Property

MarkedZones Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : MarkedZones Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MarkedZones As ChartMarkedZonesCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As ChartMarkedZonesCollection

value = instance.MarkedZones
C#
public ChartMarkedZonesCollection MarkedZones {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


Name Property

Name Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : Name Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


NextPosition Property

NextPosition Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : NextPosition Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NextPosition As Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As Integer

value = instance.NextPosition
C#
public int NextPosition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


OrderList Property

OrderList Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : OrderList Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrderList As List(Of IOrdering)
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As List(Of IOrdering)

value = instance.OrderList
C#
public List<IOrdering> OrderList {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Chart
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As Chart

value = instance.Parent
C#
public Chart Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


SeriesOrientation Property

SeriesOrientation Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : SeriesOrientation Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property SeriesOrientation As ChartSeriesOrientation
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As ChartSeriesOrientation

instance.SeriesOrientation = value

value = instance.SeriesOrientation
C#
public ChartSeriesOrientation SeriesOrientation {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : Visible Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


XAxis Property

XAxis Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : XAxis Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XAxis As ChartXAxis
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As ChartXAxis

value = instance.XAxis
C#
public ChartXAxis XAxis {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


YAxis Property

YAxis Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : YAxis Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property YAxis As ChartYAxis
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As ChartYAxis

value = instance.YAxis
C#
public ChartYAxis YAxis {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


YAxis2 Property

YAxis2 Property
[image]
Telerik.Reporting.Charting Namespace > ChartPlotArea Class : YAxis2 Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property YAxis2 As ChartYAxis
Visual Basic (Usage) Copy Code
Dim instance As ChartPlotArea
Dim value As ChartYAxis

value = instance.YAxis2
C#
public ChartYAxis YAxis2 {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPlotArea Class
ChartPlotArea Members


ChartSeries Class

ChartSeries Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartSeries Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartSeries
   Inherits RenderedObject
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
C#
public class ChartSeries : RenderedObject, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.ChartSeries

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Members
Telerik.Reporting.Charting Namespace


ChartSeries Class Members

ChartSeries Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartSeries Class

The following tables list the members exposed by ChartSeries.

Public Constructors

 | Name | Description
Public Constructor | ChartSeries Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegionAttributes |
Public Property | ActiveRegionToolTip |
Public Property | ActiveRegionUrl |
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | DataLabelsColumn |
Public Property | DataXColumn |
Public Property | DataXColumn2 |
Public Property | DataYColumn |
Public Property | DataYColumn2 |
Public Property | DataYColumn3 |
Public Property | DataYColumn4 |
Public Property | DefaultLabelValue |
Public Property | Index |
Public Property | IsActiveRegionSet |
Public Property | IsDataBound |
Public Property | Item |
Public Property | Items |
Public Property | Name |
Public Property | Parent |
Public Property | PlotArea |
Public Property | Type |
Public Property | Visible |
Public Property | YAxisType |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | AddItem | Overloaded.
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clear |
Public Method | ClearDataBoundState |
Public Method | Clone |
Public Method | CloneSeries |
Public Method | Dispose | Overloaded.
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | RemoveItem | Overloaded.
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetColors |
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetExplodes |
Public Method | SetItemColor |
Public Method | SetItemExplode |
Public Method | SetItemLabel |
Public Method | SetItems |
Public Method | SetItemValue |
Public Method | SetLabels |
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | SetValues |
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | CopyFrom |
Protected Method | CopyItems |
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartSeries Class
Telerik.Reporting.Charting Namespace


ChartSeries Constructor

ChartSeries Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : ChartSeries Constructor

Overload List

Overload | Description
ChartSeries Constructor() |
ChartSeries Constructor(ChartPlotArea) |
ChartSeries Constructor(ChartSeriesCollection) |
ChartSeries Constructor(String) |
ChartSeries Constructor(String,ChartSeriesType) |
ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection) |
ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,ChartPlotArea,StyleSeries) |
ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,ChartPlotArea,StyleSeries,String,String,String,String,String,String,String) |
ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,StyleSeries) |
ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,StyleSeries,String,String,String,String,String,String,String) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


ChartSeries Constructor()

ChartSeries Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > ChartSeries Constructor : ChartSeries Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries()
C#
public ChartSeries()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries()
C#
public ChartSeries()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


ChartSeries Constructor(ChartPlotArea)

ChartSeries Constructor(ChartPlotArea)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > ChartSeries Constructor : ChartSeries Constructor(ChartPlotArea)

plotArea

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal plotArea As ChartPlotArea _
)
Visual Basic (Usage) Copy Code
Dim plotArea As ChartPlotArea

Dim instance As ChartSeries(plotArea)
C#
public ChartSeries(
   ChartPlotArea plotArea
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal plotArea As ChartPlotArea _
)
Visual Basic (Usage) Copy Code
Dim plotArea As ChartPlotArea

Dim instance As ChartSeries(plotArea)
C#
public ChartSeries(
   ChartPlotArea plotArea
)

Parameters

plotArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


ChartSeries Constructor(ChartSeriesCollection)

ChartSeries Constructor(ChartSeriesCollection)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > ChartSeries Constructor : ChartSeries Constructor(ChartSeriesCollection)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartSeriesCollection _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartSeriesCollection

Dim instance As ChartSeries(parent)
C#
public ChartSeries(
   ChartSeriesCollection parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartSeriesCollection _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartSeriesCollection

Dim instance As ChartSeries(parent)
C#
public ChartSeries(
   ChartSeriesCollection parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


ChartSeries Constructor(String)

ChartSeries Constructor(String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > ChartSeries Constructor : ChartSeries Constructor(String)

name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As ChartSeries(name)
C#
public ChartSeries(
   string name
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As ChartSeries(name)
C#
public ChartSeries(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


ChartSeries Constructor(String,ChartSeriesType)

ChartSeries Constructor(String,ChartSeriesType)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > ChartSeries Constructor : ChartSeries Constructor(String,ChartSeriesType)

name
type

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal type As ChartSeriesType _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim type As ChartSeriesType

Dim instance As ChartSeries(name, type)
C#
public ChartSeries(
   string name,
   ChartSeriesType type
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal type As ChartSeriesType _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim type As ChartSeriesType

Dim instance As ChartSeries(name, type)
C#
public ChartSeries(
   string name,
   ChartSeriesType type
)

Parameters

name
type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection)

ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > ChartSeries Constructor : ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection)

name
type
parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal type As ChartSeriesType, _
   ByVal parent As ChartSeriesCollection _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim type As ChartSeriesType
Dim parent As ChartSeriesCollection

Dim instance As ChartSeries(name, type, parent)
C#
public ChartSeries(
   string name,
   ChartSeriesType type,
   ChartSeriesCollection parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal type As ChartSeriesType, _
   ByVal parent As ChartSeriesCollection _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim type As ChartSeriesType
Dim parent As ChartSeriesCollection

Dim instance As ChartSeries(name, type, parent)
C#
public ChartSeries(
   string name,
   ChartSeriesType type,
   ChartSeriesCollection parent
)

Parameters

name
type
parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,ChartPlotArea,StyleSeries)

ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,ChartPlotArea,StyleSeries)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > ChartSeries Constructor : ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,ChartPlotArea,StyleSeries)

seriesName
chartSeriesType
parent
yAxisType
chartPlotArea
style

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal seriesName As String, _
   ByVal chartSeriesType As ChartSeriesType, _
   ByVal parent As ChartSeriesCollection, _
   ByVal yAxisType As ChartYAxisType, _
   ByVal chartPlotArea As ChartPlotArea, _
   ByVal style As StyleSeries _
)
Visual Basic (Usage) Copy Code
Dim seriesName As String
Dim chartSeriesType As ChartSeriesType
Dim parent As ChartSeriesCollection
Dim yAxisType As ChartYAxisType
Dim chartPlotArea As ChartPlotArea
Dim style As StyleSeries

Dim instance As ChartSeries(seriesName, chartSeriesType, parent, yAxisType, chartPlotArea, style)
C#
public ChartSeries(
   string seriesName,
   ChartSeriesType chartSeriesType,
   ChartSeriesCollection parent,
   ChartYAxisType yAxisType,
   ChartPlotArea chartPlotArea,
   StyleSeries style
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal seriesName As String, _
   ByVal chartSeriesType As ChartSeriesType, _
   ByVal parent As ChartSeriesCollection, _
   ByVal yAxisType As ChartYAxisType, _
   ByVal chartPlotArea As ChartPlotArea, _
   ByVal style As StyleSeries _
)
Visual Basic (Usage) Copy Code
Dim seriesName As String
Dim chartSeriesType As ChartSeriesType
Dim parent As ChartSeriesCollection
Dim yAxisType As ChartYAxisType
Dim chartPlotArea As ChartPlotArea
Dim style As StyleSeries

Dim instance As ChartSeries(seriesName, chartSeriesType, parent, yAxisType, chartPlotArea, style)
C#
public ChartSeries(
   string seriesName,
   ChartSeriesType chartSeriesType,
   ChartSeriesCollection parent,
   ChartYAxisType yAxisType,
   ChartPlotArea chartPlotArea,
   StyleSeries style
)

Parameters

seriesName
chartSeriesType
parent
yAxisType
chartPlotArea
style

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,ChartPlotArea,StyleSeries,String,String,String,String,String,String,String)

ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,ChartPlotArea,StyleSeries,String,String,String,String,String,String,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > ChartSeries Constructor : ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,ChartPlotArea,StyleSeries,String,String,String,String,String,String,String)

seriesName
chartSeriesType
parent
yAxisType
chartPlotArea
style
dataYColumn
dataXColumn
dataYColumn2
dataXColumn2
dataYColumn3
dataYColumn4
dataLabelsColumn

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal seriesName As String, _
   ByVal chartSeriesType As ChartSeriesType, _
   ByVal parent As ChartSeriesCollection, _
   ByVal yAxisType As ChartYAxisType, _
   ByVal chartPlotArea As ChartPlotArea, _
   ByVal style As StyleSeries, _
   ByVal dataYColumn As String, _
   ByVal dataXColumn As String, _
   ByVal dataYColumn2 As String, _
   ByVal dataXColumn2 As String, _
   ByVal dataYColumn3 As String, _
   ByVal dataYColumn4 As String, _
   ByVal dataLabelsColumn As String _
)
Visual Basic (Usage) Copy Code
Dim seriesName As String
Dim chartSeriesType As ChartSeriesType
Dim parent As ChartSeriesCollection
Dim yAxisType As ChartYAxisType
Dim chartPlotArea As ChartPlotArea
Dim style As StyleSeries
Dim dataYColumn As String
Dim dataXColumn As String
Dim dataYColumn2 As String
Dim dataXColumn2 As String
Dim dataYColumn3 As String
Dim dataYColumn4 As String
Dim dataLabelsColumn As String

Dim instance As ChartSeries(seriesName, chartSeriesType, parent, yAxisType, chartPlotArea, style, dataYColumn, dataXColumn, dataYColumn2, dataXColumn2, dataYColumn3, dataYColumn4, dataLabelsColumn)
C#
public ChartSeries(
   string seriesName,
   ChartSeriesType chartSeriesType,
   ChartSeriesCollection parent,
   ChartYAxisType yAxisType,
   ChartPlotArea chartPlotArea,
   StyleSeries style,
   string dataYColumn,
   string dataXColumn,
   string dataYColumn2,
   string dataXColumn2,
   string dataYColumn3,
   string dataYColumn4,
   string dataLabelsColumn
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal seriesName As String, _
   ByVal chartSeriesType As ChartSeriesType, _
   ByVal parent As ChartSeriesCollection, _
   ByVal yAxisType As ChartYAxisType, _
   ByVal chartPlotArea As ChartPlotArea, _
   ByVal style As StyleSeries, _
   ByVal dataYColumn As String, _
   ByVal dataXColumn As String, _
   ByVal dataYColumn2 As String, _
   ByVal dataXColumn2 As String, _
   ByVal dataYColumn3 As String, _
   ByVal dataYColumn4 As String, _
   ByVal dataLabelsColumn As String _
)
Visual Basic (Usage) Copy Code
Dim seriesName As String
Dim chartSeriesType As ChartSeriesType
Dim parent As ChartSeriesCollection
Dim yAxisType As ChartYAxisType
Dim chartPlotArea As ChartPlotArea
Dim style As StyleSeries
Dim dataYColumn As String
Dim dataXColumn As String
Dim dataYColumn2 As String
Dim dataXColumn2 As String
Dim dataYColumn3 As String
Dim dataYColumn4 As String
Dim dataLabelsColumn As String

Dim instance As ChartSeries(seriesName, chartSeriesType, parent, yAxisType, chartPlotArea, style, dataYColumn, dataXColumn, dataYColumn2, dataXColumn2, dataYColumn3, dataYColumn4, dataLabelsColumn)
C#
public ChartSeries(
   string seriesName,
   ChartSeriesType chartSeriesType,
   ChartSeriesCollection parent,
   ChartYAxisType yAxisType,
   ChartPlotArea chartPlotArea,
   StyleSeries style,
   string dataYColumn,
   string dataXColumn,
   string dataYColumn2,
   string dataXColumn2,
   string dataYColumn3,
   string dataYColumn4,
   string dataLabelsColumn
)

Parameters

seriesName
chartSeriesType
parent
yAxisType
chartPlotArea
style
dataYColumn
dataXColumn
dataYColumn2
dataXColumn2
dataYColumn3
dataYColumn4
dataLabelsColumn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,StyleSeries)

ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,StyleSeries)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > ChartSeries Constructor : ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,StyleSeries)

seriesName
chartSeriesType
parent
yAxisType
style

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal seriesName As String, _
   ByVal chartSeriesType As ChartSeriesType, _
   ByVal parent As ChartSeriesCollection, _
   ByVal yAxisType As ChartYAxisType, _
   ByVal style As StyleSeries _
)
Visual Basic (Usage) Copy Code
Dim seriesName As String
Dim chartSeriesType As ChartSeriesType
Dim parent As ChartSeriesCollection
Dim yAxisType As ChartYAxisType
Dim style As StyleSeries

Dim instance As ChartSeries(seriesName, chartSeriesType, parent, yAxisType, style)
C#
public ChartSeries(
   string seriesName,
   ChartSeriesType chartSeriesType,
   ChartSeriesCollection parent,
   ChartYAxisType yAxisType,
   StyleSeries style
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal seriesName As String, _
   ByVal chartSeriesType As ChartSeriesType, _
   ByVal parent As ChartSeriesCollection, _
   ByVal yAxisType As ChartYAxisType, _
   ByVal style As StyleSeries _
)
Visual Basic (Usage) Copy Code
Dim seriesName As String
Dim chartSeriesType As ChartSeriesType
Dim parent As ChartSeriesCollection
Dim yAxisType As ChartYAxisType
Dim style As StyleSeries

Dim instance As ChartSeries(seriesName, chartSeriesType, parent, yAxisType, style)
C#
public ChartSeries(
   string seriesName,
   ChartSeriesType chartSeriesType,
   ChartSeriesCollection parent,
   ChartYAxisType yAxisType,
   StyleSeries style
)

Parameters

seriesName
chartSeriesType
parent
yAxisType
style

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,StyleSeries,String,String,String,String,String,String,String)

ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,StyleSeries,String,String,String,String,String,String,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > ChartSeries Constructor : ChartSeries Constructor(String,ChartSeriesType,ChartSeriesCollection,ChartYAxisType,StyleSeries,String,String,String,String,String,String,String)

seriesName
chartSeriesType
parent
yAxisType
style
dataYColumn
dataXColumn
dataYColumn2
dataXColumn2
dataYColumn3
dataYColumn4
dataLabelsColumn

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal seriesName As String, _
   ByVal chartSeriesType As ChartSeriesType, _
   ByVal parent As ChartSeriesCollection, _
   ByVal yAxisType As ChartYAxisType, _
   ByVal style As StyleSeries, _
   ByVal dataYColumn As String, _
   ByVal dataXColumn As String, _
   ByVal dataYColumn2 As String, _
   ByVal dataXColumn2 As String, _
   ByVal dataYColumn3 As String, _
   ByVal dataYColumn4 As String, _
   ByVal dataLabelsColumn As String _
)
Visual Basic (Usage) Copy Code
Dim seriesName As String
Dim chartSeriesType As ChartSeriesType
Dim parent As ChartSeriesCollection
Dim yAxisType As ChartYAxisType
Dim style As StyleSeries
Dim dataYColumn As String
Dim dataXColumn As String
Dim dataYColumn2 As String
Dim dataXColumn2 As String
Dim dataYColumn3 As String
Dim dataYColumn4 As String
Dim dataLabelsColumn As String

Dim instance As ChartSeries(seriesName, chartSeriesType, parent, yAxisType, style, dataYColumn, dataXColumn, dataYColumn2, dataXColumn2, dataYColumn3, dataYColumn4, dataLabelsColumn)
C#
public ChartSeries(
   string seriesName,
   ChartSeriesType chartSeriesType,
   ChartSeriesCollection parent,
   ChartYAxisType yAxisType,
   StyleSeries style,
   string dataYColumn,
   string dataXColumn,
   string dataYColumn2,
   string dataXColumn2,
   string dataYColumn3,
   string dataYColumn4,
   string dataLabelsColumn
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal seriesName As String, _
   ByVal chartSeriesType As ChartSeriesType, _
   ByVal parent As ChartSeriesCollection, _
   ByVal yAxisType As ChartYAxisType, _
   ByVal style As StyleSeries, _
   ByVal dataYColumn As String, _
   ByVal dataXColumn As String, _
   ByVal dataYColumn2 As String, _
   ByVal dataXColumn2 As String, _
   ByVal dataYColumn3 As String, _
   ByVal dataYColumn4 As String, _
   ByVal dataLabelsColumn As String _
)
Visual Basic (Usage) Copy Code
Dim seriesName As String
Dim chartSeriesType As ChartSeriesType
Dim parent As ChartSeriesCollection
Dim yAxisType As ChartYAxisType
Dim style As StyleSeries
Dim dataYColumn As String
Dim dataXColumn As String
Dim dataYColumn2 As String
Dim dataXColumn2 As String
Dim dataYColumn3 As String
Dim dataYColumn4 As String
Dim dataLabelsColumn As String

Dim instance As ChartSeries(seriesName, chartSeriesType, parent, yAxisType, style, dataYColumn, dataXColumn, dataYColumn2, dataXColumn2, dataYColumn3, dataYColumn4, dataLabelsColumn)
C#
public ChartSeries(
   string seriesName,
   ChartSeriesType chartSeriesType,
   ChartSeriesCollection parent,
   ChartYAxisType yAxisType,
   StyleSeries style,
   string dataYColumn,
   string dataXColumn,
   string dataYColumn2,
   string dataXColumn2,
   string dataYColumn3,
   string dataYColumn4,
   string dataLabelsColumn
)

Parameters

seriesName
chartSeriesType
parent
yAxisType
style
dataYColumn
dataXColumn
dataYColumn2
dataXColumn2
dataYColumn3
dataYColumn4
dataLabelsColumn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


ChartSeries Class Methods

ChartSeries Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartSeries Class

For a list of all members of this type, see ChartSeries members.

Public Methods

 | Name | Description
Public Method | AddItem | Overloaded.
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clear |
Public Method | ClearDataBoundState |
Public Method | Clone |
Public Method | CloneSeries |
Public Method | Dispose | Overloaded.
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | RemoveItem | Overloaded.
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetColors |
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetExplodes |
Public Method | SetItemColor |
Public Method | SetItemExplode |
Public Method | SetItemLabel |
Public Method | SetItems |
Public Method | SetItemValue |
Public Method | SetLabels |
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | SetValues |
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | CopyFrom |
Protected Method | CopyItems |
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartSeries Class
Telerik.Reporting.Charting Namespace


AddItem Method

AddItem Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : AddItem Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
AddItem(ChartSeriesItem,ChartSeriesItem[]) |
AddItem(ChartSeriesItemsCollection) |
AddItem(ChartSeriesItem[]) |
AddItem(Generic List) |
AddItem(Double) |
AddItem(Double,String) |
AddItem(Double,String,Color) |
AddItem(Double,String,Color,Boolean) |

Overload List

Overload | Description
AddItem(ChartSeriesItem,ChartSeriesItem[]) |
AddItem(ChartSeriesItemsCollection) |
AddItem(ChartSeriesItem[]) |
AddItem(Generic List) |
AddItem(Double) |
AddItem(Double,String) |
AddItem(Double,String,Color) |
AddItem(Double,String,Color,Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


AddItem(ChartSeriesItem,ChartSeriesItem[]) Method

AddItem(ChartSeriesItem,ChartSeriesItem[]) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > AddItem Method : AddItem(ChartSeriesItem,ChartSeriesItem[]) Method

seriesItem
seriesItems

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal seriesItem As ChartSeriesItem, _
   ByVal ParamArray seriesItems() As ChartSeriesItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim seriesItem As ChartSeriesItem
Dim seriesItems() As ChartSeriesItem

instance.AddItem(seriesItem, seriesItems)
C#
public void AddItem(
   ChartSeriesItem seriesItem,
   params ChartSeriesItem[] seriesItems
)

Parameters

seriesItem
seriesItems

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


AddItem(ChartSeriesItemsCollection) Method

AddItem(ChartSeriesItemsCollection) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > AddItem Method : AddItem(ChartSeriesItemsCollection) Method

seriesItems

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal seriesItems As ChartSeriesItemsCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim seriesItems As ChartSeriesItemsCollection

instance.AddItem(seriesItems)
C#
public void AddItem(
   ChartSeriesItemsCollection seriesItems
)

Parameters

seriesItems

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


AddItem(ChartSeriesItem[]) Method

AddItem(ChartSeriesItem[]) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > AddItem Method : AddItem(ChartSeriesItem[]) Method

seriesItems

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal seriesItems() As ChartSeriesItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim seriesItems() As ChartSeriesItem

instance.AddItem(seriesItems)
C#
public void AddItem(
   ChartSeriesItem[] seriesItems
)

Parameters

seriesItems

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


AddItem(Generic List) Method

AddItem(Generic List) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > AddItem Method : AddItem(Generic List) Method

seriesItems

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal seriesItems As List(Of ChartSeriesItem) _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim seriesItems As List(Of ChartSeriesItem)

instance.AddItem(seriesItems)
C#
public void AddItem(
   List<ChartSeriesItem> seriesItems
)

Parameters

seriesItems

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


AddItem(Double) Method

AddItem(Double) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > AddItem Method : AddItem(Double) Method

value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As Double

instance.AddItem(value)
C#
public void AddItem(
   double value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


AddItem(Double,String) Method

AddItem(Double,String) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > AddItem Method : AddItem(Double,String) Method

value
label

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal value As Double, _
   ByVal label As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As Double
Dim label As String

instance.AddItem(value, label)
C#
public void AddItem(
   double value,
   string label
)

Parameters

value
label

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


AddItem(Double,String,Color) Method

AddItem(Double,String,Color) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > AddItem Method : AddItem(Double,String,Color) Method

value
label
color

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal value As Double, _
   ByVal label As String, _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As Double
Dim label As String
Dim color As Color

instance.AddItem(value, label, color)
C#
public void AddItem(
   double value,
   string label,
   Color color
)

Parameters

value
label
color

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


AddItem(Double,String,Color,Boolean) Method

AddItem(Double,String,Color,Boolean) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > AddItem Method : AddItem(Double,String,Color,Boolean) Method

value
label
color
exploded

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal value As Double, _
   ByVal label As String, _
   ByVal color As Color, _
   ByVal exploded As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As Double
Dim label As String
Dim color As Color
Dim exploded As Boolean

instance.AddItem(value, label, color, exploded)
C#
public void AddItem(
   double value,
   string label,
   Color color,
   bool exploded
)

Parameters

value
label
color
exploded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


Clear Method

Clear Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : Clear Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


ClearDataBoundState Method

ClearDataBoundState Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : ClearDataBoundState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearDataBoundState()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries

instance.ClearDataBoundState()
C#
public void ClearDataBoundState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : Clone Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


CloneSeries Method

CloneSeries Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : CloneSeries Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function CloneSeries() As ChartSeries
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As ChartSeries

value = instance.CloneSeries()
C#
public ChartSeries CloneSeries()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


CopyFrom Method

CopyFrom Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : CopyFrom Method

originalSeries

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Sub CopyFrom( _
   ByVal originalSeries As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim originalSeries As ChartSeries

instance.CopyFrom(originalSeries)
C#
protected void CopyFrom(
   ChartSeries originalSeries
)

Parameters

originalSeries

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


CopyItems Method

CopyItems Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : CopyItems Method

originalSeries

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Sub CopyItems( _
   ByVal originalSeries As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim originalSeries As ChartSeries

instance.CopyItems(originalSeries)
C#
protected void CopyItems(
   ChartSeries originalSeries
)

Parameters

originalSeries

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : Dispose Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : Finalize Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


RemoveItem Method

RemoveItem Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : RemoveItem Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
RemoveItem(ChartSeriesItem,ChartSeriesItem[]) |
RemoveItem(Int32,Int32[]) |
RemoveItem(Int32) |

Overload List

Overload | Description
RemoveItem(ChartSeriesItem,ChartSeriesItem[]) |
RemoveItem(Int32,Int32[]) |
RemoveItem(Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


RemoveItem(ChartSeriesItem,ChartSeriesItem[]) Method

RemoveItem(ChartSeriesItem,ChartSeriesItem[]) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > RemoveItem Method : RemoveItem(ChartSeriesItem,ChartSeriesItem[]) Method

seriesItem
seriesItems

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub RemoveItem( _
   ByVal seriesItem As ChartSeriesItem, _
   ByVal ParamArray seriesItems() As ChartSeriesItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim seriesItem As ChartSeriesItem
Dim seriesItems() As ChartSeriesItem

instance.RemoveItem(seriesItem, seriesItems)
C#
public void RemoveItem(
   ChartSeriesItem seriesItem,
   params ChartSeriesItem[] seriesItems
)

Parameters

seriesItem
seriesItems

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


RemoveItem(Int32,Int32[]) Method

RemoveItem(Int32,Int32[]) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > RemoveItem Method : RemoveItem(Int32,Int32[]) Method

index
indexes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub RemoveItem( _
   ByVal index As Integer, _
   ByVal ParamArray indexes() As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim index As Integer
Dim indexes() As Integer

instance.RemoveItem(index, indexes)
C#
public void RemoveItem(
   int index,
   params int[] indexes
)

Parameters

index
indexes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


RemoveItem(Int32) Method

RemoveItem(Int32) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class > RemoveItem Method : RemoveItem(Int32) Method

itemIndex

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub RemoveItem( _
   ByVal itemIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim itemIndex As Integer

instance.RemoveItem(itemIndex)
C#
public void RemoveItem(
   int itemIndex
)

Parameters

itemIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members
Overload List


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


SetColors Method

SetColors Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : SetColors Method

colors

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetColors( _
   ByVal ParamArray colors() As Color _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim colors() As Color

instance.SetColors(colors)
C#
public void SetColors(
   params Color[] colors
)

Parameters

colors

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


SetExplodes Method

SetExplodes Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : SetExplodes Method

explodes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetExplodes( _
   ByVal ParamArray explodes() As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim explodes() As Boolean

instance.SetExplodes(explodes)
C#
public void SetExplodes(
   params bool[] explodes
)

Parameters

explodes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


SetItemColor Method

SetItemColor Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : SetItemColor Method

itemIndex
newColor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetItemColor( _
   ByVal itemIndex As Integer, _
   ByVal newColor As Color _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim itemIndex As Integer
Dim newColor As Color

instance.SetItemColor(itemIndex, newColor)
C#
public void SetItemColor(
   int itemIndex,
   Color newColor
)

Parameters

itemIndex
newColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


SetItemExplode Method

SetItemExplode Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : SetItemExplode Method

itemIndex
exploded

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetItemExplode( _
   ByVal itemIndex As Integer, _
   ByVal exploded As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim itemIndex As Integer
Dim exploded As Boolean

instance.SetItemExplode(itemIndex, exploded)
C#
public void SetItemExplode(
   int itemIndex,
   bool exploded
)

Parameters

itemIndex
exploded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


SetItemLabel Method

SetItemLabel Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : SetItemLabel Method

itemIndex
newLabel

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetItemLabel( _
   ByVal itemIndex As Integer, _
   ByVal newLabel As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim itemIndex As Integer
Dim newLabel As String

instance.SetItemLabel(itemIndex, newLabel)
C#
public void SetItemLabel(
   int itemIndex,
   string newLabel
)

Parameters

itemIndex
newLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


SetItems Method

SetItems Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : SetItems Method

seriesItems

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetItems( _
   ByVal ParamArray seriesItems() As ChartSeriesItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim seriesItems() As ChartSeriesItem

instance.SetItems(seriesItems)
C#
public void SetItems(
   params ChartSeriesItem[] seriesItems
)

Parameters

seriesItems

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


SetItemValue Method

SetItemValue Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : SetItemValue Method

itemIndex
newValue

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetItemValue( _
   ByVal itemIndex As Integer, _
   ByVal newValue As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim itemIndex As Integer
Dim newValue As Double

instance.SetItemValue(itemIndex, newValue)
C#
public void SetItemValue(
   int itemIndex,
   double newValue
)

Parameters

itemIndex
newValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


SetLabels Method

SetLabels Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : SetLabels Method

labels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetLabels( _
   ByVal ParamArray labels() As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim labels() As String

instance.SetLabels(labels)
C#
public void SetLabels(
   params string[] labels
)

Parameters

labels

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


SetValues Method

SetValues Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : SetValues Method

values

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetValues( _
   ByVal ParamArray values() As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim values() As Double

instance.SetValues(values)
C#
public void SetValues(
   params double[] values
)

Parameters

values

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : ToString Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


ChartSeries Class Properties

ChartSeries Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartSeries Class

For a list of all members of this type, see ChartSeries members.

Public Properties

 | Name | Description
Public Property | ActiveRegionAttributes |
Public Property | ActiveRegionToolTip |
Public Property | ActiveRegionUrl |
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | DataLabelsColumn |
Public Property | DataXColumn |
Public Property | DataXColumn2 |
Public Property | DataYColumn |
Public Property | DataYColumn2 |
Public Property | DataYColumn3 |
Public Property | DataYColumn4 |
Public Property | DefaultLabelValue |
Public Property | Index |
Public Property | IsActiveRegionSet |
Public Property | IsDataBound |
Public Property | Item |
Public Property | Items |
Public Property | Name |
Public Property | Parent |
Public Property | PlotArea |
Public Property | Type |
Public Property | Visible |
Public Property | YAxisType |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartSeries Class
Telerik.Reporting.Charting Namespace


ActiveRegionAttributes Property

ActiveRegionAttributes Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : ActiveRegionAttributes Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveRegionAttributes As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As String

instance.ActiveRegionAttributes = value

value = instance.ActiveRegionAttributes
C#
public string ActiveRegionAttributes {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


ActiveRegionToolTip Property

ActiveRegionToolTip Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : ActiveRegionToolTip Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveRegionToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As String

instance.ActiveRegionToolTip = value

value = instance.ActiveRegionToolTip
C#
public string ActiveRegionToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


ActiveRegionUrl Property

ActiveRegionUrl Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : ActiveRegionUrl Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveRegionUrl As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As String

instance.ActiveRegionUrl = value

value = instance.ActiveRegionUrl
C#
public string ActiveRegionUrl {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


Appearance Property

Appearance Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : Appearance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleSeries
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As StyleSeries

value = instance.Appearance
C#
public StyleSeries Appearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


DataLabelsColumn Property

DataLabelsColumn Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : DataLabelsColumn Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataLabelsColumn As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As String

instance.DataLabelsColumn = value

value = instance.DataLabelsColumn
C#
public string DataLabelsColumn {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


DataXColumn Property

DataXColumn Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : DataXColumn Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataXColumn As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As String

instance.DataXColumn = value

value = instance.DataXColumn
C#
public string DataXColumn {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


DataXColumn2 Property

DataXColumn2 Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : DataXColumn2 Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataXColumn2 As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As String

instance.DataXColumn2 = value

value = instance.DataXColumn2
C#
public string DataXColumn2 {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


DataYColumn Property

DataYColumn Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : DataYColumn Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataYColumn As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As String

instance.DataYColumn = value

value = instance.DataYColumn
C#
public string DataYColumn {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


DataYColumn2 Property

DataYColumn2 Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : DataYColumn2 Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataYColumn2 As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As String

instance.DataYColumn2 = value

value = instance.DataYColumn2
C#
public string DataYColumn2 {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


DataYColumn3 Property

DataYColumn3 Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : DataYColumn3 Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataYColumn3 As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As String

instance.DataYColumn3 = value

value = instance.DataYColumn3
C#
public string DataYColumn3 {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


DataYColumn4 Property

DataYColumn4 Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : DataYColumn4 Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataYColumn4 As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As String

instance.DataYColumn4 = value

value = instance.DataYColumn4
C#
public string DataYColumn4 {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


DefaultLabelValue Property

DefaultLabelValue Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : DefaultLabelValue Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultLabelValue As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As String

instance.DefaultLabelValue = value

value = instance.DefaultLabelValue
C#
public string DefaultLabelValue {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


Index Property

Index Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : Index Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As Integer

value = instance.Index
C#
public int Index {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


IsActiveRegionSet Property

IsActiveRegionSet Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : IsActiveRegionSet Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsActiveRegionSet As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As Boolean

value = instance.IsActiveRegionSet
C#
public bool IsActiveRegionSet {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


IsDataBound Property

IsDataBound Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : IsDataBound Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDataBound As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As Boolean

value = instance.IsDataBound
C#
public bool IsDataBound {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


Item Property

Item Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : Item Property

itemIndex

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal itemIndex As Integer _
) As ChartSeriesItem
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim itemIndex As Integer
Dim value As ChartSeriesItem

instance.Item(itemIndex) = value

value = instance.Item(itemIndex)
C#
public ChartSeriesItem this[
   int itemIndex
]; {get; set;}

Parameters

itemIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


Items Property

Items Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : Items Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As ChartSeriesItemsCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As ChartSeriesItemsCollection

value = instance.Items
C#
public ChartSeriesItemsCollection Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


Name Property

Name Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : Name Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As ChartSeriesCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As ChartSeriesCollection

value = instance.Parent
C#
public ChartSeriesCollection Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


PlotArea Property

PlotArea Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : PlotArea Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PlotArea As ChartPlotArea
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As ChartPlotArea

value = instance.PlotArea
C#
public ChartPlotArea PlotArea {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


Type Property

Type Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : Type Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As ChartSeriesType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As ChartSeriesType

instance.Type = value

value = instance.Type
C#
public ChartSeriesType Type {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : Visible Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


YAxisType Property

YAxisType Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeries Class : YAxisType Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property YAxisType As ChartYAxisType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeries
Dim value As ChartYAxisType

instance.YAxisType = value

value = instance.YAxisType
C#
public ChartYAxisType YAxisType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeries Class
ChartSeries Members


ChartSeriesCollection Class

ChartSeriesCollection Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesCollection Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartSeriesCollection
   Inherits ChartingStateManagedCollection(Of ChartSeries)
   Implements IChartingStateManager, IDeserializableCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
C#
public class ChartSeriesCollection : ChartingStateManagedCollection<ChartSeries>, IChartingStateManager, IDeserializableCollection

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>
Telerik.Reporting.Charting.ChartSeriesCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Members
Telerik.Reporting.Charting Namespace


ChartSeriesCollection Class Members

ChartSeriesCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesCollection Class

The following tables list the members exposed by ChartSeriesCollection.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Property | Item | Overridden.
Public Property | Parent |
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overridden.
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | ClearDataBoundState |
Public Method | ClearItems |
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | GetByName |
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | GetFilteredSeriesByYAxis |
Public Method | GetMaxItemsCount | Overloaded.
Public Method | GetMaxYValue |
Public Method | GetMinYValue |
Public Method | GetSeries |
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | Insert | Overridden.
Public Method | InsertSeries |
Public Method | Remove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | RemoveSeries |
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | Overridden.
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Protected Method | OnInsertComplete | Overridden.
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Top

See Also

Reference

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


ChartSeriesCollection Constructor

ChartSeriesCollection Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : ChartSeriesCollection Constructor

Overload List

Overload | Description
ChartSeriesCollection Constructor() |
ChartSeriesCollection Constructor(Chart) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


ChartSeriesCollection Constructor()

ChartSeriesCollection Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class > ChartSeriesCollection Constructor : ChartSeriesCollection Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection()
C#
public ChartSeriesCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection()
C#
public ChartSeriesCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members
Overload List


ChartSeriesCollection Constructor(Chart)

ChartSeriesCollection Constructor(Chart)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class > ChartSeriesCollection Constructor : ChartSeriesCollection Constructor(Chart)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart

Dim instance As ChartSeriesCollection(parent)
C#
public ChartSeriesCollection(
   Chart parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart

Dim instance As ChartSeriesCollection(parent)
C#
public ChartSeriesCollection(
   Chart parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members
Overload List


ChartSeriesCollection Class Methods

ChartSeriesCollection Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesCollection Class

For a list of all members of this type, see ChartSeriesCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overridden.
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | ClearDataBoundState |
Public Method | ClearItems |
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | GetByName |
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | GetFilteredSeriesByYAxis |
Public Method | GetMaxItemsCount | Overloaded.
Public Method | GetMaxYValue |
Public Method | GetMinYValue |
Public Method | GetSeries |
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | Insert | Overridden.
Public Method | InsertSeries |
Public Method | Remove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Method | RemoveSeries |
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | Overridden.
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Protected Method | OnInsertComplete | Overridden.
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Top

See Also

Reference

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : Add Method

chartSeries

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Add( _
   ByVal chartSeries As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim chartSeries As ChartSeries

instance.Add(chartSeries)
C#
public override void Add(
   ChartSeries chartSeries
)

Parameters

chartSeries

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


ClearDataBoundState Method

ClearDataBoundState Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : ClearDataBoundState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearDataBoundState()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection

instance.ClearDataBoundState()
C#
public void ClearDataBoundState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


ClearItems Method

ClearItems Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : ClearItems Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection

instance.ClearItems()
C#
public void ClearItems()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


GetByName Method

GetByName Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : GetByName Method

name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetByName( _
   ByVal name As String _
) As ChartSeries
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim name As String
Dim value As ChartSeries

value = instance.GetByName(name)
C#
public ChartSeries GetByName(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


GetFilteredSeriesByYAxis Method

GetFilteredSeriesByYAxis Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : GetFilteredSeriesByYAxis Method

yAxisType

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFilteredSeriesByYAxis( _
   ByVal yAxisType As ChartYAxisType _
) As ChartSeriesCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim yAxisType As ChartYAxisType
Dim value As ChartSeriesCollection

value = instance.GetFilteredSeriesByYAxis(yAxisType)
C#
public ChartSeriesCollection GetFilteredSeriesByYAxis(
   ChartYAxisType yAxisType
)

Parameters

yAxisType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


GetMaxItemsCount Method

GetMaxItemsCount Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : GetMaxItemsCount Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetMaxItemsCount() |
GetMaxItemsCount(ChartPlotArea) |

Overload List

Overload | Description
GetMaxItemsCount() |
GetMaxItemsCount(ChartPlotArea) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


GetMaxItemsCount() Method

GetMaxItemsCount() Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class > GetMaxItemsCount Method : GetMaxItemsCount() Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function GetMaxItemsCount() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim value As Integer

value = instance.GetMaxItemsCount()
C#
public int GetMaxItemsCount()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members
Overload List


GetMaxItemsCount(ChartPlotArea) Method

GetMaxItemsCount(ChartPlotArea) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class > GetMaxItemsCount Method : GetMaxItemsCount(ChartPlotArea) Method

plotArea

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function GetMaxItemsCount( _
   ByVal plotArea As ChartPlotArea _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim plotArea As ChartPlotArea
Dim value As Integer

value = instance.GetMaxItemsCount(plotArea)
C#
public int GetMaxItemsCount(
   ChartPlotArea plotArea
)

Parameters

plotArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members
Overload List


GetMaxYValue Method

GetMaxYValue Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : GetMaxYValue Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMaxYValue() As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim value As Double

value = instance.GetMaxYValue()
C#
public double GetMaxYValue()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


GetMinYValue Method

GetMinYValue Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : GetMinYValue Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMinYValue() As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim value As Double

value = instance.GetMinYValue()
C#
public double GetMinYValue()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


GetSeries Method

GetSeries Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : GetSeries Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSeries( _
   ByVal index As Integer _
) As ChartSeries
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim index As Integer
Dim value As ChartSeries

value = instance.GetSeries(index)
C#
public ChartSeries GetSeries(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


Insert Method

Insert Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : Insert Method

index
item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim index As Integer
Dim item As ChartSeries

instance.Insert(index, item)
C#
public override void Insert(
   int index,
   ChartSeries item
)

Parameters

index
item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


InsertSeries Method

InsertSeries Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : InsertSeries Method

index
item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub InsertSeries( _
   ByVal index As Integer, _
   ByVal item As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim index As Integer
Dim item As ChartSeries

instance.InsertSeries(index, item)
C#
public void InsertSeries(
   int index,
   ChartSeries item
)

Parameters

index
item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : LoadViewState Method

state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim state As Object

instance.LoadViewState(state)
C#
protected override void LoadViewState(
   object state
)

Parameters

state

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


OnInsertComplete Method

OnInsertComplete Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : OnInsertComplete Method

index
value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnInsertComplete( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim index As Integer
Dim value As Object

instance.OnInsertComplete(index, value)
C#
protected override void OnInsertComplete(
   int index,
   object value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


RemoveSeries Method

RemoveSeries Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : RemoveSeries Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveSeries()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection

instance.RemoveSeries()
C#
public void RemoveSeries()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


ChartSeriesCollection Class Properties

ChartSeriesCollection Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesCollection Class

For a list of all members of this type, see ChartSeriesCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Public Property | Item | Overridden.
Public Property | Parent |
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>)
Top

See Also

Reference

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : Item Property

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Default Property Item( _
   ByVal index As Integer _
) As ChartSeries
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim index As Integer
Dim value As ChartSeries

instance.Item(index) = value

value = instance.Item(index)
C#
public override ChartSeries this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesCollection Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As Chart
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesCollection
Dim value As Chart

instance.Parent = value

value = instance.Parent
C#
public Chart Parent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


ChartSeriesItem Class

ChartSeriesItem Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesItem Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartSeriesItem
   Inherits RenderedObject
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
C#
public class ChartSeriesItem : RenderedObject, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.ChartSeriesItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Members
Telerik.Reporting.Charting Namespace


ChartSeriesItem Class Members

ChartSeriesItem Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesItem Class

The following tables list the members exposed by ChartSeriesItem.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesItem Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion |
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Empty |
Public Property | Index |
Public Property | Label |
Public Property | Name |
Public Property | Parent |
Public Property | PointAppearance |
Public Property | Visible |
Public Property | XValue |
Public Property | XValue2 |
Public Property | YValue |
Public Property | YValue2 |
Public Property | YValue3 |
Public Property | YValue4 |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone |
Public Method | Dispose | Overloaded.
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


ChartSeriesItem Constructor

ChartSeriesItem Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : ChartSeriesItem Constructor

Overload List

Overload | Description
ChartSeriesItem Constructor() |
ChartSeriesItem Constructor(Boolean) |
ChartSeriesItem Constructor(ChartSeries) |
ChartSeriesItem Constructor(Double) |
ChartSeriesItem Constructor(Double,Double) |
ChartSeriesItem Constructor(Double,Double,Double,Double) |
ChartSeriesItem Constructor(Double,Double,Double,Double,Double,Double) |
ChartSeriesItem Constructor(Double,Double,StyleSeriesItem) |
ChartSeriesItem Constructor(Double,String) |
ChartSeriesItem Constructor(Double,String,Color) |
ChartSeriesItem Constructor(Double,String,Color,Boolean) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


ChartSeriesItem Constructor()

ChartSeriesItem Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class > ChartSeriesItem Constructor : ChartSeriesItem Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem()
C#
public ChartSeriesItem()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem()
C#
public ChartSeriesItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members
Overload List


ChartSeriesItem Constructor(Boolean)

ChartSeriesItem Constructor(Boolean)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class > ChartSeriesItem Constructor : ChartSeriesItem Constructor(Boolean)

isEmpty

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal isEmpty As Boolean _
)
Visual Basic (Usage) Copy Code
Dim isEmpty As Boolean

Dim instance As ChartSeriesItem(isEmpty)
C#
public ChartSeriesItem(
   bool isEmpty
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal isEmpty As Boolean _
)
Visual Basic (Usage) Copy Code
Dim isEmpty As Boolean

Dim instance As ChartSeriesItem(isEmpty)
C#
public ChartSeriesItem(
   bool isEmpty
)

Parameters

isEmpty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members
Overload List


ChartSeriesItem Constructor(ChartSeries)

ChartSeriesItem Constructor(ChartSeries)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class > ChartSeriesItem Constructor : ChartSeriesItem Constructor(ChartSeries)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartSeries

Dim instance As ChartSeriesItem(parent)
C#
public ChartSeriesItem(
   ChartSeries parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartSeries

Dim instance As ChartSeriesItem(parent)
C#
public ChartSeriesItem(
   ChartSeries parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members
Overload List


ChartSeriesItem Constructor(Double)

ChartSeriesItem Constructor(Double)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class > ChartSeriesItem Constructor : ChartSeriesItem Constructor(Double)

value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim value As Double

Dim instance As ChartSeriesItem(value)
C#
public ChartSeriesItem(
   double value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim value As Double

Dim instance As ChartSeriesItem(value)
C#
public ChartSeriesItem(
   double value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members
Overload List


ChartSeriesItem Constructor(Double,Double)

ChartSeriesItem Constructor(Double,Double)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class > ChartSeriesItem Constructor : ChartSeriesItem Constructor(Double,Double)

x
y

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double _
)
Visual Basic (Usage) Copy Code
Dim x As Double
Dim y As Double

Dim instance As ChartSeriesItem(x, y)
C#
public ChartSeriesItem(
   double x,
   double y
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double _
)
Visual Basic (Usage) Copy Code
Dim x As Double
Dim y As Double

Dim instance As ChartSeriesItem(x, y)
C#
public ChartSeriesItem(
   double x,
   double y
)

Parameters

x
y

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members
Overload List


ChartSeriesItem Constructor(Double,Double,Double,Double)

ChartSeriesItem Constructor(Double,Double,Double,Double)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class > ChartSeriesItem Constructor : ChartSeriesItem Constructor(Double,Double,Double,Double)

x
y
x2
y2

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double _
)
Visual Basic (Usage) Copy Code
Dim x As Double
Dim y As Double
Dim x2 As Double
Dim y2 As Double

Dim instance As ChartSeriesItem(x, y, x2, y2)
C#
public ChartSeriesItem(
   double x,
   double y,
   double x2,
   double y2
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double _
)
Visual Basic (Usage) Copy Code
Dim x As Double
Dim y As Double
Dim x2 As Double
Dim y2 As Double

Dim instance As ChartSeriesItem(x, y, x2, y2)
C#
public ChartSeriesItem(
   double x,
   double y,
   double x2,
   double y2
)

Parameters

x
y
x2
y2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members
Overload List


ChartSeriesItem Constructor(Double,Double,Double,Double,Double,Double)

ChartSeriesItem Constructor(Double,Double,Double,Double,Double,Double)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class > ChartSeriesItem Constructor : ChartSeriesItem Constructor(Double,Double,Double,Double,Double,Double)

x
y
x2
y2
y3
y4

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double, _
   ByVal y3 As Double, _
   ByVal y4 As Double _
)
Visual Basic (Usage) Copy Code
Dim x As Double
Dim y As Double
Dim x2 As Double
Dim y2 As Double
Dim y3 As Double
Dim y4 As Double

Dim instance As ChartSeriesItem(x, y, x2, y2, y3, y4)
C#
public ChartSeriesItem(
   double x,
   double y,
   double x2,
   double y2,
   double y3,
   double y4
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double, _
   ByVal y3 As Double, _
   ByVal y4 As Double _
)
Visual Basic (Usage) Copy Code
Dim x As Double
Dim y As Double
Dim x2 As Double
Dim y2 As Double
Dim y3 As Double
Dim y4 As Double

Dim instance As ChartSeriesItem(x, y, x2, y2, y3, y4)
C#
public ChartSeriesItem(
   double x,
   double y,
   double x2,
   double y2,
   double y3,
   double y4
)

Parameters

x
y
x2
y2
y3
y4

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members
Overload List


ChartSeriesItem Constructor(Double,Double,StyleSeriesItem)

ChartSeriesItem Constructor(Double,Double,StyleSeriesItem)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class > ChartSeriesItem Constructor : ChartSeriesItem Constructor(Double,Double,StyleSeriesItem)

x
y
style

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal style As StyleSeriesItem _
)
Visual Basic (Usage) Copy Code
Dim x As Double
Dim y As Double
Dim style As StyleSeriesItem

Dim instance As ChartSeriesItem(x, y, style)
C#
public ChartSeriesItem(
   double x,
   double y,
   StyleSeriesItem style
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal style As StyleSeriesItem _
)
Visual Basic (Usage) Copy Code
Dim x As Double
Dim y As Double
Dim style As StyleSeriesItem

Dim instance As ChartSeriesItem(x, y, style)
C#
public ChartSeriesItem(
   double x,
   double y,
   StyleSeriesItem style
)

Parameters

x
y
style

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members
Overload List


ChartSeriesItem Constructor(Double,String)

ChartSeriesItem Constructor(Double,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class > ChartSeriesItem Constructor : ChartSeriesItem Constructor(Double,String)

value
labelText

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double, _
   ByVal labelText As String _
)
Visual Basic (Usage) Copy Code
Dim value As Double
Dim labelText As String

Dim instance As ChartSeriesItem(value, labelText)
C#
public ChartSeriesItem(
   double value,
   string labelText
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double, _
   ByVal labelText As String _
)
Visual Basic (Usage) Copy Code
Dim value As Double
Dim labelText As String

Dim instance As ChartSeriesItem(value, labelText)
C#
public ChartSeriesItem(
   double value,
   string labelText
)

Parameters

value
labelText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members
Overload List


ChartSeriesItem Constructor(Double,String,Color)

ChartSeriesItem Constructor(Double,String,Color)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class > ChartSeriesItem Constructor : ChartSeriesItem Constructor(Double,String,Color)

value
label
color

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double, _
   ByVal label As String, _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim value As Double
Dim label As String
Dim color As Color

Dim instance As ChartSeriesItem(value, label, color)
C#
public ChartSeriesItem(
   double value,
   string label,
   Color color
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double, _
   ByVal label As String, _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim value As Double
Dim label As String
Dim color As Color

Dim instance As ChartSeriesItem(value, label, color)
C#
public ChartSeriesItem(
   double value,
   string label,
   Color color
)

Parameters

value
label
color

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members
Overload List


ChartSeriesItem Constructor(Double,String,Color,Boolean)

ChartSeriesItem Constructor(Double,String,Color,Boolean)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class > ChartSeriesItem Constructor : ChartSeriesItem Constructor(Double,String,Color,Boolean)

value
label
color
exploded

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double, _
   ByVal label As String, _
   ByVal color As Color, _
   ByVal exploded As Boolean _
)
Visual Basic (Usage) Copy Code
Dim value As Double
Dim label As String
Dim color As Color
Dim exploded As Boolean

Dim instance As ChartSeriesItem(value, label, color, exploded)
C#
public ChartSeriesItem(
   double value,
   string label,
   Color color,
   bool exploded
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double, _
   ByVal label As String, _
   ByVal color As Color, _
   ByVal exploded As Boolean _
)
Visual Basic (Usage) Copy Code
Dim value As Double
Dim label As String
Dim color As Color
Dim exploded As Boolean

Dim instance As ChartSeriesItem(value, label, color, exploded)
C#
public ChartSeriesItem(
   double value,
   string label,
   Color color,
   bool exploded
)

Parameters

value
label
color
exploded

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members
Overload List


ChartSeriesItem Class Methods

ChartSeriesItem Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesItem Class

For a list of all members of this type, see ChartSeriesItem members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone |
Public Method | Dispose | Overloaded.
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : Clone Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : Dispose Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : Finalize Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : ToString Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


ChartSeriesItem Class Properties

ChartSeriesItem Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesItem Class

For a list of all members of this type, see ChartSeriesItem members.

Public Properties

 | Name | Description
Public Property | ActiveRegion |
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Empty |
Public Property | Index |
Public Property | Label |
Public Property | Name |
Public Property | Parent |
Public Property | PointAppearance |
Public Property | Visible |
Public Property | XValue |
Public Property | XValue2 |
Public Property | YValue |
Public Property | YValue2 |
Public Property | YValue3 |
Public Property | YValue4 |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


ActiveRegion Property

ActiveRegion Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : ActiveRegion Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveRegion As ActiveRegion
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As ActiveRegion

instance.ActiveRegion = value

value = instance.ActiveRegion
C#
public ActiveRegion ActiveRegion {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


Appearance Property

Appearance Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : Appearance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleSeriesItem
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As StyleSeriesItem

value = instance.Appearance
C#
public StyleSeriesItem Appearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


Empty Property

Empty Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : Empty Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Empty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As Boolean

instance.Empty = value

value = instance.Empty
C#
public bool Empty {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


Index Property

Index Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : Index Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As Integer

value = instance.Index
C#
public int Index {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


Label Property

Label Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : Label Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Label As SeriesItemLabel
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As SeriesItemLabel

value = instance.Label
C#
public SeriesItemLabel Label {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


Name Property

Name Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : Name Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As ChartSeries
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As ChartSeries

instance.Parent = value

value = instance.Parent
C#
public ChartSeries Parent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


PointAppearance Property

PointAppearance Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : PointAppearance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PointAppearance As StyleMarkerSeriesPoint
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As StyleMarkerSeriesPoint

value = instance.PointAppearance
C#
public StyleMarkerSeriesPoint PointAppearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : Visible Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


XValue Property

XValue Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : XValue Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property XValue As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As Double

instance.XValue = value

value = instance.XValue
C#
public double XValue {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


XValue2 Property

XValue2 Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : XValue2 Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property XValue2 As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As Double

instance.XValue2 = value

value = instance.XValue2
C#
public double XValue2 {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


YValue Property

YValue Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : YValue Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property YValue As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As Double

instance.YValue = value

value = instance.YValue
C#
public double YValue {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


YValue2 Property

YValue2 Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : YValue2 Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property YValue2 As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As Double

instance.YValue2 = value

value = instance.YValue2
C#
public double YValue2 {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


YValue3 Property

YValue3 Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : YValue3 Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property YValue3 As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As Double

instance.YValue3 = value

value = instance.YValue3
C#
public double YValue3 {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


YValue4 Property

YValue4 Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItem Class : YValue4 Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property YValue4 As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItem
Dim value As Double

instance.YValue4 = value

value = instance.YValue4
C#
public double YValue4 {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItem Class
ChartSeriesItem Members


ChartSeriesItemsCollection Class

ChartSeriesItemsCollection Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesItemsCollection Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartSeriesItemsCollection
   Inherits ChartingStateManagedCollection(Of ChartSeriesItem)
   Implements IChartingStateManager, IDeserializableCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItemsCollection
C#
public class ChartSeriesItemsCollection : ChartingStateManagedCollection<ChartSeriesItem>, IChartingStateManager, IDeserializableCollection

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>
Telerik.Reporting.Charting.ChartSeriesItemsCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItemsCollection Members
Telerik.Reporting.Charting Namespace


ChartSeriesItemsCollection Class Members

ChartSeriesItemsCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesItemsCollection Class

The following tables list the members exposed by ChartSeriesItemsCollection.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesItemsCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Property | Item | Overridden.
Public Property | Parent |
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overridden.
Public Method | AddRange | Overloaded.
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | Remove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | Overridden.
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Top

See Also

Reference

ChartSeriesItemsCollection Class
Telerik.Reporting.Charting Namespace


ChartSeriesItemsCollection Constructor

ChartSeriesItemsCollection Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItemsCollection Class : ChartSeriesItemsCollection Constructor

Overload List

Overload | Description
ChartSeriesItemsCollection Constructor() |
ChartSeriesItemsCollection Constructor(ChartSeries) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Members


ChartSeriesItemsCollection Constructor()

ChartSeriesItemsCollection Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItemsCollection Class > ChartSeriesItemsCollection Constructor : ChartSeriesItemsCollection Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItemsCollection()
C#
public ChartSeriesItemsCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItemsCollection()
C#
public ChartSeriesItemsCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Members
Overload List


ChartSeriesItemsCollection Constructor(ChartSeries)

ChartSeriesItemsCollection Constructor(ChartSeries)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItemsCollection Class > ChartSeriesItemsCollection Constructor : ChartSeriesItemsCollection Constructor(ChartSeries)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartSeries

Dim instance As ChartSeriesItemsCollection(parent)
C#
public ChartSeriesItemsCollection(
   ChartSeries parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartSeries

Dim instance As ChartSeriesItemsCollection(parent)
C#
public ChartSeriesItemsCollection(
   ChartSeries parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Members
Overload List


ChartSeriesItemsCollection Class Methods

ChartSeriesItemsCollection Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesItemsCollection Class

For a list of all members of this type, see ChartSeriesItemsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overridden.
Public Method | AddRange | Overloaded.
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | Remove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | Overridden.
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Top

See Also

Reference

ChartSeriesItemsCollection Class
Telerik.Reporting.Charting Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItemsCollection Class : Add Method

chartSeriesItem

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Add( _
   ByVal chartSeriesItem As ChartSeriesItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItemsCollection
Dim chartSeriesItem As ChartSeriesItem

instance.Add(chartSeriesItem)
C#
public override void Add(
   ChartSeriesItem chartSeriesItem
)

Parameters

chartSeriesItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Members


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItemsCollection Class : AddRange Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
AddRange(ChartSeriesItemsCollection) |
AddRange(ChartSeriesItem[]) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)

Overload List

Overload | Description
AddRange(ChartSeriesItemsCollection) |
AddRange(ChartSeriesItem[]) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Members


AddRange(ChartSeriesItemsCollection) Method

AddRange(ChartSeriesItemsCollection) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItemsCollection Class > AddRange Method : AddRange(ChartSeriesItemsCollection) Method

chartSeriesItems

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddRange( _
   ByVal chartSeriesItems As ChartSeriesItemsCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItemsCollection
Dim chartSeriesItems As ChartSeriesItemsCollection

instance.AddRange(chartSeriesItems)
C#
public void AddRange(
   ChartSeriesItemsCollection chartSeriesItems
)

Parameters

chartSeriesItems

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Members
Overload List


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItemsCollection Class : LoadViewState Method

state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItemsCollection
Dim state As Object

instance.LoadViewState(state)
C#
protected override void LoadViewState(
   object state
)

Parameters

state

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Members


ChartSeriesItemsCollection Class Properties

ChartSeriesItemsCollection Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesItemsCollection Class

For a list of all members of this type, see ChartSeriesItemsCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Public Property | Item | Overridden.
Public Property | Parent |
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>)
Top

See Also

Reference

ChartSeriesItemsCollection Class
Telerik.Reporting.Charting Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItemsCollection Class : Item Property

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Default Property Item( _
   ByVal index As Integer _
) As ChartSeriesItem
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItemsCollection
Dim index As Integer
Dim value As ChartSeriesItem

instance.Item(index) = value

value = instance.Item(index)
C#
public override ChartSeriesItem this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItemsCollection Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As ChartSeries
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItemsCollection
Dim value As ChartSeries

instance.Parent = value

value = instance.Parent
C#
public ChartSeries Parent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Members


ChartTitle Class

ChartTitle Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartTitle Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartTitle
   Inherits ChartLabel
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartTitle
C#
public class ChartTitle : ChartLabel, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ChartLabel
Telerik.Reporting.Charting.ChartTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartTitle Members
Telerik.Reporting.Charting Namespace


ChartTitle Class Members

ChartTitle Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartTitle Class

The following tables list the members exposed by ChartTitle.

Public Constructors

 | Name | Description
Public Constructor | ChartTitle Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

ChartTitle Class
Telerik.Reporting.Charting Namespace


ChartTitle Constructor

ChartTitle Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartTitle Class : ChartTitle Constructor

Overload List

Overload | Description
ChartTitle Constructor() |
ChartTitle Constructor(Chart) |
ChartTitle Constructor(Chart,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartTitle Class
ChartTitle Members


ChartTitle Constructor()

ChartTitle Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartTitle Class > ChartTitle Constructor : ChartTitle Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartTitle()
C#
public ChartTitle()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartTitle()
C#
public ChartTitle()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartTitle Class
ChartTitle Members
Overload List


ChartTitle Constructor(Chart)

ChartTitle Constructor(Chart)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartTitle Class > ChartTitle Constructor : ChartTitle Constructor(Chart)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart

Dim instance As ChartTitle(parent)
C#
public ChartTitle(
   Chart parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart

Dim instance As ChartTitle(parent)
C#
public ChartTitle(
   Chart parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartTitle Class
ChartTitle Members
Overload List


ChartTitle Constructor(Chart,IContainer)

ChartTitle Constructor(Chart,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartTitle Class > ChartTitle Constructor : ChartTitle Constructor(Chart,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart
Dim container As IContainer

Dim instance As ChartTitle(parent, container)
C#
public ChartTitle(
   Chart parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart
Dim container As IContainer

Dim instance As ChartTitle(parent, container)
C#
public ChartTitle(
   Chart parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartTitle Class
ChartTitle Members
Overload List


ChartXAxis Class

ChartXAxis Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartXAxis Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartXAxis
   Inherits ChartAxis
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxis
C#
public class ChartXAxis : ChartAxis, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.ChartAxis
Telerik.Reporting.Charting.ChartXAxis

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Members
Telerik.Reporting.Charting Namespace


ChartXAxis Class Members

ChartXAxis Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartXAxis Class

The following tables list the members exposed by ChartXAxis.

Public Constructors

 | Name | Description
Public Constructor | ChartXAxis Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartAxisAppearance | (Inherited from ChartAxis)
Protected Field | chartAxisItems | (Inherited from ChartAxis)
Protected Field | chartAxisLabel | (Inherited from ChartAxis)
Protected Field | chartAxisMaxAxisValue | (Inherited from ChartAxis)
Protected Field | chartAxisMaxItemValue | (Inherited from ChartAxis)
Protected Field | chartAxisMinAxisValue | (Inherited from ChartAxis)
Protected Field | chartAxisMinItemValue | (Inherited from ChartAxis)
Protected Field | chartAxisParent | (Inherited from ChartAxis)
Protected Field | chartAxisPointEnd | (Inherited from ChartAxis)
Protected Field | chartAxisPointStart | (Inherited from ChartAxis)
Protected Field | chartAxisRealIsZeroBased | (Inherited from ChartAxis)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | pixelsPerValue | (Inherited from ChartAxis)
Protected Field | pixelStep |
Protected Field | zeroCoord | (Inherited from ChartAxis)
Top

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from ChartAxis)
Public Property | AutoScale | (Inherited from ChartAxis)
Public Property | AutoShrink |
Public Property | AxisLabel | (Inherited from ChartAxis)
Public Property | Container | (Inherited from RenderedObject)
Public Property | DataLabelsColumn |
Public Property | IsDataBound |
Public Property | IsZeroBased | (Inherited from ChartAxis)
Public Property | Item | (Inherited from ChartAxis)
Public Property | Items | (Inherited from ChartAxis)
Public Property | LabelStep | (Inherited from ChartAxis)
Public Property | LayoutMode |
Public Property | MaxItemsCount | (Inherited from ChartAxis)
Public Property | MaxValue | (Inherited from ChartAxis)
Public Property | MinValue | (Inherited from ChartAxis)
Public Property | Parent | (Inherited from ChartAxis)
Public Property | Step | (Inherited from ChartAxis)
Public Property | Visible | (Inherited from ChartAxis)
Public Property | VisibleValues | (Inherited from ChartAxis)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | AddItem | Overloaded.
Public Method | AddRange | (Inherited from ChartAxis)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clear | (Inherited from ChartAxis)
Public Method | ClearDataBoundState |
Public Method | Dispose | Overloaded. (Inherited from ChartAxis)
Public Method | GetItem | (Inherited from ChartAxis)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | RemoveAllItems | (Inherited from ChartAxis)
Public Method | RemoveItem | Overloaded. (Inherited from ChartAxis)
Public Method | RemoveLastItem | (Inherited from ChartAxis)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetItemColor | (Inherited from ChartAxis)
Public Method | SetItemLabel | Overloaded. (Inherited from ChartAxis)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | AutoCalcAxisExtents | (Inherited from ChartAxis)
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | DisableCachedValues | Overridden.
Protected Method | Finalize | (Inherited from ChartAxis)
Protected Method | GetAxisEndCoord | Overridden.
Protected Method | GetAxisStartCoord | Overridden.
Protected Method | GetDistance | (Inherited from ChartAxis)
Protected Method | GetPixelStep |
Protected Method | LoadViewState | (Inherited from ChartAxis)
Protected Method | ResetMaxValue | (Inherited from ChartAxis)
Protected Method | ResetMinValue | (Inherited from ChartAxis)
Protected Method | ResetStep | (Inherited from ChartAxis)
Protected Method | SaveViewState | (Inherited from ChartAxis)
Protected Method | SetMaxValue | (Inherited from ChartAxis)
Protected Method | SetMinValue | (Inherited from ChartAxis)
Protected Method | ShouldSerializeMaxValue | (Inherited from ChartAxis)
Protected Method | ShouldSerializeMinValue | (Inherited from ChartAxis)
Protected Method | ShouldSerializeStep | (Inherited from ChartAxis)
Protected Method | TrackViewState | (Inherited from ChartAxis)
Top

See Also

Reference

ChartXAxis Class
Telerik.Reporting.Charting Namespace


ChartXAxis Constructor

ChartXAxis Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class : ChartXAxis Constructor

Overload List

Overload | Description
ChartXAxis Constructor(ChartPlotArea) |
ChartXAxis Constructor(ChartPlotArea,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members


ChartXAxis Constructor(ChartPlotArea)

ChartXAxis Constructor(ChartPlotArea)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class > ChartXAxis Constructor : ChartXAxis Constructor(ChartPlotArea)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartPlotArea _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartPlotArea

Dim instance As ChartXAxis(parent)
C#
public ChartXAxis(
   ChartPlotArea parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartPlotArea _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartPlotArea

Dim instance As ChartXAxis(parent)
C#
public ChartXAxis(
   ChartPlotArea parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members
Overload List


ChartXAxis Constructor(ChartPlotArea,IContainer)

ChartXAxis Constructor(ChartPlotArea,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class > ChartXAxis Constructor : ChartXAxis Constructor(ChartPlotArea,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartPlotArea, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartPlotArea
Dim container As IContainer

Dim instance As ChartXAxis(parent, container)
C#
public ChartXAxis(
   ChartPlotArea parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartPlotArea, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartPlotArea
Dim container As IContainer

Dim instance As ChartXAxis(parent, container)
C#
public ChartXAxis(
   ChartPlotArea parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members
Overload List


ChartXAxis Class Methods

ChartXAxis Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartXAxis Class

For a list of all members of this type, see ChartXAxis members.

Public Methods

 | Name | Description
Public Method | AddItem | Overloaded.
Public Method | AddRange | (Inherited from ChartAxis)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clear | (Inherited from ChartAxis)
Public Method | ClearDataBoundState |
Public Method | Dispose | Overloaded. (Inherited from ChartAxis)
Public Method | GetItem | (Inherited from ChartAxis)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | RemoveAllItems | (Inherited from ChartAxis)
Public Method | RemoveItem | Overloaded. (Inherited from ChartAxis)
Public Method | RemoveLastItem | (Inherited from ChartAxis)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetItemColor | (Inherited from ChartAxis)
Public Method | SetItemLabel | Overloaded. (Inherited from ChartAxis)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | AutoCalcAxisExtents | (Inherited from ChartAxis)
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | DisableCachedValues | Overridden.
Protected Method | Finalize | (Inherited from ChartAxis)
Protected Method | GetAxisEndCoord | Overridden.
Protected Method | GetAxisStartCoord | Overridden.
Protected Method | GetDistance | (Inherited from ChartAxis)
Protected Method | GetPixelStep |
Protected Method | LoadViewState | (Inherited from ChartAxis)
Protected Method | ResetMaxValue | (Inherited from ChartAxis)
Protected Method | ResetMinValue | (Inherited from ChartAxis)
Protected Method | ResetStep | (Inherited from ChartAxis)
Protected Method | SaveViewState | (Inherited from ChartAxis)
Protected Method | SetMaxValue | (Inherited from ChartAxis)
Protected Method | SetMinValue | (Inherited from ChartAxis)
Protected Method | ShouldSerializeMaxValue | (Inherited from ChartAxis)
Protected Method | ShouldSerializeMinValue | (Inherited from ChartAxis)
Protected Method | ShouldSerializeStep | (Inherited from ChartAxis)
Protected Method | TrackViewState | (Inherited from ChartAxis)
Top

See Also

Reference

ChartXAxis Class
Telerik.Reporting.Charting Namespace


AddItem Method

AddItem Method
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class : AddItem Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
AddItem(String) |
AddItem(String,Color) |
AddItem(ChartAxisItem,ChartAxisItem[]) | (Inherited from ChartAxis)
AddItem(ChartAxisItemsCollection) | (Inherited from ChartAxis)
AddItem(ChartAxisItem[]) | (Inherited from ChartAxis)
AddItem(Generic List) | (Inherited from ChartAxis)
AddItem(String,Color,Boolean) | (Inherited from ChartAxis)

Overload List

Overload | Description
AddItem(String) |
AddItem(String,Color) |
AddItem(ChartAxisItem,ChartAxisItem[]) | (Inherited from ChartAxis)
AddItem(ChartAxisItemsCollection) | (Inherited from ChartAxis)
AddItem(ChartAxisItem[]) | (Inherited from ChartAxis)
AddItem(Generic List) | (Inherited from ChartAxis)
AddItem(String,Color,Boolean) | (Inherited from ChartAxis)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members


AddItem(String) Method

AddItem(String) Method
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class > AddItem Method : AddItem(String) Method

label

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal label As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxis
Dim label As String

instance.AddItem(label)
C#
public void AddItem(
   string label
)

Parameters

label

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members
Overload List


AddItem(String,Color) Method

AddItem(String,Color) Method
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class > AddItem Method : AddItem(String,Color) Method

label
color

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddItem( _
   ByVal label As String, _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxis
Dim label As String
Dim color As Color

instance.AddItem(label, color)
C#
public void AddItem(
   string label,
   Color color
)

Parameters

label
color

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members
Overload List


ClearDataBoundState Method

ClearDataBoundState Method
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class : ClearDataBoundState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearDataBoundState()
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxis

instance.ClearDataBoundState()
C#
public void ClearDataBoundState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members


DisableCachedValues Method

DisableCachedValues Method
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class : DisableCachedValues Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub DisableCachedValues()
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxis

instance.DisableCachedValues()
C#
protected override void DisableCachedValues()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members


GetAxisEndCoord Method

GetAxisEndCoord Method
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class : GetAxisEndCoord Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetAxisEndCoord() As Single
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxis
Dim value As Single

value = instance.GetAxisEndCoord()
C#
protected override float GetAxisEndCoord()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members


GetAxisStartCoord Method

GetAxisStartCoord Method
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class : GetAxisStartCoord Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetAxisStartCoord() As Single
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxis
Dim value As Single

value = instance.GetAxisStartCoord()
C#
protected override float GetAxisStartCoord()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members


GetPixelStep Method

GetPixelStep Method
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class : GetPixelStep Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetPixelStep() As Single
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxis
Dim value As Single

value = instance.GetPixelStep()
C#
protected float GetPixelStep()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members


ChartXAxis Class Properties

ChartXAxis Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartXAxis Class

For a list of all members of this type, see ChartXAxis members.

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from ChartAxis)
Public Property | AutoScale | (Inherited from ChartAxis)
Public Property | AutoShrink |
Public Property | AxisLabel | (Inherited from ChartAxis)
Public Property | Container | (Inherited from RenderedObject)
Public Property | DataLabelsColumn |
Public Property | IsDataBound |
Public Property | IsZeroBased | (Inherited from ChartAxis)
Public Property | Item | (Inherited from ChartAxis)
Public Property | Items | (Inherited from ChartAxis)
Public Property | LabelStep | (Inherited from ChartAxis)
Public Property | LayoutMode |
Public Property | MaxItemsCount | (Inherited from ChartAxis)
Public Property | MaxValue | (Inherited from ChartAxis)
Public Property | MinValue | (Inherited from ChartAxis)
Public Property | Parent | (Inherited from ChartAxis)
Public Property | Step | (Inherited from ChartAxis)
Public Property | Visible | (Inherited from ChartAxis)
Public Property | VisibleValues | (Inherited from ChartAxis)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartXAxis Class
Telerik.Reporting.Charting Namespace


AutoShrink Property

AutoShrink Property
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class : AutoShrink Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoShrink As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxis
Dim value As Boolean

instance.AutoShrink = value

value = instance.AutoShrink
C#
public bool AutoShrink {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members


DataLabelsColumn Property

DataLabelsColumn Property
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class : DataLabelsColumn Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataLabelsColumn As String
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxis
Dim value As String

instance.DataLabelsColumn = value

value = instance.DataLabelsColumn
C#
public string DataLabelsColumn {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members


IsDataBound Property

IsDataBound Property
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class : IsDataBound Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDataBound As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxis
Dim value As Boolean

value = instance.IsDataBound
C#
public bool IsDataBound {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members


LayoutMode Property

LayoutMode Property
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class : LayoutMode Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property LayoutMode As ChartAxisLayoutMode
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxis
Dim value As ChartAxisLayoutMode

instance.LayoutMode = value

value = instance.LayoutMode
C#
public ChartAxisLayoutMode LayoutMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members


ChartXAxis Class Fields

ChartXAxis Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartXAxis Class

For a list of all members of this type, see ChartXAxis members.

Protected Fields

 | Name | Description
Protected Field | chartAxisAppearance | (Inherited from ChartAxis)
Protected Field | chartAxisItems | (Inherited from ChartAxis)
Protected Field | chartAxisLabel | (Inherited from ChartAxis)
Protected Field | chartAxisMaxAxisValue | (Inherited from ChartAxis)
Protected Field | chartAxisMaxItemValue | (Inherited from ChartAxis)
Protected Field | chartAxisMinAxisValue | (Inherited from ChartAxis)
Protected Field | chartAxisMinItemValue | (Inherited from ChartAxis)
Protected Field | chartAxisParent | (Inherited from ChartAxis)
Protected Field | chartAxisPointEnd | (Inherited from ChartAxis)
Protected Field | chartAxisPointStart | (Inherited from ChartAxis)
Protected Field | chartAxisRealIsZeroBased | (Inherited from ChartAxis)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | pixelsPerValue | (Inherited from ChartAxis)
Protected Field | pixelStep |
Protected Field | zeroCoord | (Inherited from ChartAxis)
Top

See Also

Reference

ChartXAxis Class
Telerik.Reporting.Charting Namespace


pixelStep Field

pixelStep Field
[image]
Telerik.Reporting.Charting Namespace > ChartXAxis Class : pixelStep Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected pixelStep As Single
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxis
Dim value As Single

value = instance.pixelStep

instance.pixelStep = value
C#
protected float pixelStep

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartXAxis Class
ChartXAxis Members


ChartYAxis Class

ChartYAxis Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ChartYAxis Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartYAxis
   Inherits ChartAxis
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxis
C#
public class ChartYAxis : ChartAxis, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.ChartAxis
Telerik.Reporting.Charting.ChartYAxis

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartYAxis Members
Telerik.Reporting.Charting Namespace


ChartYAxis Class Members

ChartYAxis Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ChartYAxis Class

The following tables list the members exposed by ChartYAxis.

Public Constructors

 | Name | Description
Public Constructor | ChartYAxis Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | chartAxisAppearance | (Inherited from ChartAxis)
Protected Field | chartAxisItems | (Inherited from ChartAxis)
Protected Field | chartAxisLabel | (Inherited from ChartAxis)
Protected Field | chartAxisMaxAxisValue | (Inherited from ChartAxis)
Protected Field | chartAxisMaxItemValue | (Inherited from ChartAxis)
Protected Field | chartAxisMinAxisValue | (Inherited from ChartAxis)
Protected Field | chartAxisMinItemValue | (Inherited from ChartAxis)
Protected Field | chartAxisParent | (Inherited from ChartAxis)
Protected Field | chartAxisPointEnd | (Inherited from ChartAxis)
Protected Field | chartAxisPointStart | (Inherited from ChartAxis)
Protected Field | chartAxisRealIsZeroBased | (Inherited from ChartAxis)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | pixelsPerValue | (Inherited from ChartAxis)
Protected Field | zeroCoord | (Inherited from ChartAxis)
Top

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from ChartAxis)
Public Property | AutoScale | (Inherited from ChartAxis)
Public Property | AxisLabel | (Inherited from ChartAxis)
Public Property | AxisMode |
Public Property | Container | (Inherited from RenderedObject)
Public Property | IsLogarithmic |
Public Property | IsZeroBased | (Inherited from ChartAxis)
Public Property | Item | (Inherited from ChartAxis)
Public Property | Items | (Inherited from ChartAxis)
Public Property | LabelStep | (Inherited from ChartAxis)
Public Property | LogarithmBase |
Public Property | MaxItemsCount | (Inherited from ChartAxis)
Public Property | MaxValue | (Inherited from ChartAxis)
Public Property | MinValue | (Inherited from ChartAxis)
Public Property | Parent | (Inherited from ChartAxis)
Public Property | ScaleBreaks |
Public Property | Segments |
Public Property | Step | (Inherited from ChartAxis)
Public Property | Visible | (Inherited from ChartAxis)
Public Property | VisibleValues | (Inherited from ChartAxis)
Public Property | YAxisType |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | AddItem | Overloaded. (Inherited from ChartAxis)
Public Method | AddRange | (Inherited from ChartAxis)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clear | (Inherited from ChartAxis)
Public Method | Dispose | Overloaded. (Inherited from ChartAxis)
Public Method | GetItem | (Inherited from ChartAxis)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | RemoveAllItems | (Inherited from ChartAxis)
Public Method | RemoveItem | Overloaded. (Inherited from ChartAxis)
Public Method | RemoveLastItem | (Inherited from ChartAxis)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetItemColor | (Inherited from ChartAxis)
Public Method | SetItemLabel | Overloaded. (Inherited from ChartAxis)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | AutoCalcAxisExtents | (Inherited from ChartAxis)
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | DisableCachedValues | (Inherited from ChartAxis)
Protected Method | Finalize | (Inherited from ChartAxis)
Protected Method | GetAxisEndCoord | Overridden.
Protected Method | GetAxisStartCoord | Overridden.
Protected Method | GetDistance | (Inherited from ChartAxis)
Protected Method | LoadViewState | Overridden.
Protected Method | ResetMaxValue | (Inherited from ChartAxis)
Protected Method | ResetMinValue | (Inherited from ChartAxis)
Protected Method | ResetStep | (Inherited from ChartAxis)
Protected Method | SaveViewState | Overridden.
Protected Method | SetMaxValue | (Inherited from ChartAxis)
Protected Method | SetMinValue | (Inherited from ChartAxis)
Protected Method | ShouldSerializeMaxValue | (Inherited from ChartAxis)
Protected Method | ShouldSerializeMinValue | (Inherited from ChartAxis)
Protected Method | ShouldSerializeStep | (Inherited from ChartAxis)
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartYAxis Class
Telerik.Reporting.Charting Namespace


ChartYAxis Constructor

ChartYAxis Constructor
[image]
Telerik.Reporting.Charting Namespace > ChartYAxis Class : ChartYAxis Constructor

parent
type

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartPlotArea, _
   ByVal type As ChartYAxisType _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartPlotArea
Dim type As ChartYAxisType

Dim instance As ChartYAxis(parent, type)
C#
public ChartYAxis(
   ChartPlotArea parent,
   ChartYAxisType type
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartPlotArea, _
   ByVal type As ChartYAxisType _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartPlotArea
Dim type As ChartYAxisType

Dim instance As ChartYAxis(parent, type)
C#
public ChartYAxis(
   ChartPlotArea parent,
   ChartYAxisType type
)

Parameters

parent
type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartYAxis Class
ChartYAxis Members


ChartYAxis Class Methods

ChartYAxis Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartYAxis Class

For a list of all members of this type, see ChartYAxis members.

Public Methods

 | Name | Description
Public Method | AddItem | Overloaded. (Inherited from ChartAxis)
Public Method | AddRange | (Inherited from ChartAxis)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clear | (Inherited from ChartAxis)
Public Method | Dispose | Overloaded. (Inherited from ChartAxis)
Public Method | GetItem | (Inherited from ChartAxis)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | RemoveAllItems | (Inherited from ChartAxis)
Public Method | RemoveItem | Overloaded. (Inherited from ChartAxis)
Public Method | RemoveLastItem | (Inherited from ChartAxis)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetItemColor | (Inherited from ChartAxis)
Public Method | SetItemLabel | Overloaded. (Inherited from ChartAxis)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | AutoCalcAxisExtents | (Inherited from ChartAxis)
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | DisableCachedValues | (Inherited from ChartAxis)
Protected Method | Finalize | (Inherited from ChartAxis)
Protected Method | GetAxisEndCoord | Overridden.
Protected Method | GetAxisStartCoord | Overridden.
Protected Method | GetDistance | (Inherited from ChartAxis)
Protected Method | LoadViewState | Overridden.
Protected Method | ResetMaxValue | (Inherited from ChartAxis)
Protected Method | ResetMinValue | (Inherited from ChartAxis)
Protected Method | ResetStep | (Inherited from ChartAxis)
Protected Method | SaveViewState | Overridden.
Protected Method | SetMaxValue | (Inherited from ChartAxis)
Protected Method | SetMinValue | (Inherited from ChartAxis)
Protected Method | ShouldSerializeMaxValue | (Inherited from ChartAxis)
Protected Method | ShouldSerializeMinValue | (Inherited from ChartAxis)
Protected Method | ShouldSerializeStep | (Inherited from ChartAxis)
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ChartYAxis Class
Telerik.Reporting.Charting Namespace


GetAxisEndCoord Method

GetAxisEndCoord Method
[image]
Telerik.Reporting.Charting Namespace > ChartYAxis Class : GetAxisEndCoord Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetAxisEndCoord() As Single
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxis
Dim value As Single

value = instance.GetAxisEndCoord()
C#
protected override float GetAxisEndCoord()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartYAxis Class
ChartYAxis Members


GetAxisStartCoord Method

GetAxisStartCoord Method
[image]
Telerik.Reporting.Charting Namespace > ChartYAxis Class : GetAxisStartCoord Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetAxisStartCoord() As Single
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxis
Dim value As Single

value = instance.GetAxisStartCoord()
C#
protected override float GetAxisStartCoord()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartYAxis Class
ChartYAxis Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartYAxis Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxis
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartYAxis Class
ChartYAxis Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartYAxis Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxis
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartYAxis Class
ChartYAxis Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > ChartYAxis Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxis

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartYAxis Class
ChartYAxis Members


ChartYAxis Class Properties

ChartYAxis Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartYAxis Class

For a list of all members of this type, see ChartYAxis members.

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from ChartAxis)
Public Property | AutoScale | (Inherited from ChartAxis)
Public Property | AxisLabel | (Inherited from ChartAxis)
Public Property | AxisMode |
Public Property | Container | (Inherited from RenderedObject)
Public Property | IsLogarithmic |
Public Property | IsZeroBased | (Inherited from ChartAxis)
Public Property | Item | (Inherited from ChartAxis)
Public Property | Items | (Inherited from ChartAxis)
Public Property | LabelStep | (Inherited from ChartAxis)
Public Property | LogarithmBase |
Public Property | MaxItemsCount | (Inherited from ChartAxis)
Public Property | MaxValue | (Inherited from ChartAxis)
Public Property | MinValue | (Inherited from ChartAxis)
Public Property | Parent | (Inherited from ChartAxis)
Public Property | ScaleBreaks |
Public Property | Segments |
Public Property | Step | (Inherited from ChartAxis)
Public Property | Visible | (Inherited from ChartAxis)
Public Property | VisibleValues | (Inherited from ChartAxis)
Public Property | YAxisType |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartYAxis Class
Telerik.Reporting.Charting Namespace


AxisMode Property

AxisMode Property
[image]
Telerik.Reporting.Charting Namespace > ChartYAxis Class : AxisMode Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property AxisMode As ChartYAxisMode
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxis
Dim value As ChartYAxisMode

instance.AxisMode = value

value = instance.AxisMode
C#
public ChartYAxisMode AxisMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartYAxis Class
ChartYAxis Members


IsLogarithmic Property

IsLogarithmic Property
[image]
Telerik.Reporting.Charting Namespace > ChartYAxis Class : IsLogarithmic Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property IsLogarithmic As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxis
Dim value As Boolean

instance.IsLogarithmic = value

value = instance.IsLogarithmic
C#
public bool IsLogarithmic {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartYAxis Class
ChartYAxis Members


LogarithmBase Property

LogarithmBase Property
[image]
Telerik.Reporting.Charting Namespace > ChartYAxis Class : LogarithmBase Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property LogarithmBase As Double
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxis
Dim value As Double

instance.LogarithmBase = value

value = instance.LogarithmBase
C#
public double LogarithmBase {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartYAxis Class
ChartYAxis Members


ScaleBreaks Property

ScaleBreaks Property
[image]
Telerik.Reporting.Charting Namespace > ChartYAxis Class : ScaleBreaks Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ScaleBreaks As ScaleBreak
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxis
Dim value As ScaleBreak

value = instance.ScaleBreaks
C#
public ScaleBreak ScaleBreaks {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartYAxis Class
ChartYAxis Members


Segments Property

Segments Property
[image]
Telerik.Reporting.Charting Namespace > ChartYAxis Class : Segments Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Segments As AxisSegmentCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxis
Dim value As AxisSegmentCollection

value = instance.Segments
C#
public AxisSegmentCollection Segments {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartYAxis Class
ChartYAxis Members


YAxisType Property

YAxisType Property
[image]
Telerik.Reporting.Charting Namespace > ChartYAxis Class : YAxisType Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property YAxisType As ChartYAxisType
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxis
Dim value As ChartYAxisType

instance.YAxisType = value

value = instance.YAxisType
C#
public ChartYAxisType YAxisType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartYAxis Class
ChartYAxis Members


ColorBlend Class

ColorBlend Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ColorBlend Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ColorBlend
   Inherits ChartingStateManagedCollection(Of GradientElement)
   Implements IChartingStateManager, IDeserializableCollection
Visual Basic (Usage) Copy Code
Dim instance As ColorBlend
C#
public class ColorBlend : ChartingStateManagedCollection<GradientElement>, IChartingStateManager, IDeserializableCollection

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>
Telerik.Reporting.Charting.ColorBlend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Members
Telerik.Reporting.Charting Namespace


ColorBlend Class Members

ColorBlend Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ColorBlend Class

The following tables list the members exposed by ColorBlend.

Public Constructors

 | Name | Description
Public Constructor | ColorBlend Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Property | Item | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | AddRange | Overloaded.
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | Clone |
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | Equals | Overridden.
Public Method | GetBrush |
Public Method | GetColor |
Public Method | GetColors |
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | GetHashCode | Overridden.
Public Method | GetPositions |
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | LoadFrom |
Public Method | Remove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Top

See Also

Reference

ColorBlend Class
Telerik.Reporting.Charting Namespace


ColorBlend Constructor

ColorBlend Constructor
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class : ColorBlend Constructor

Overload List

Overload | Description
ColorBlend Constructor() |
ColorBlend Constructor(Color[]) |
ColorBlend Constructor(Color[],Object) |
ColorBlend Constructor(Color[],Single[]) |
ColorBlend Constructor(Color[],Single[],Object) |
ColorBlend Constructor(Object) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members


ColorBlend Constructor()

ColorBlend Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class > ColorBlend Constructor : ColorBlend Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ColorBlend()
C#
public ColorBlend()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ColorBlend()
C#
public ColorBlend()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members
Overload List


ColorBlend Constructor(Color[])

ColorBlend Constructor(Color[])
See Also
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class > ColorBlend Constructor : ColorBlend Constructor(Color[])

colors

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colors() As Color _
)
Visual Basic (Usage) Copy Code
Dim colors() As Color

Dim instance As ColorBlend(colors)
C#
public ColorBlend(
   Color[] colors
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colors() As Color _
)
Visual Basic (Usage) Copy Code
Dim colors() As Color

Dim instance As ColorBlend(colors)
C#
public ColorBlend(
   Color[] colors
)

Parameters

colors

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members
Overload List


ColorBlend Constructor(Color[],Object)

ColorBlend Constructor(Color[],Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class > ColorBlend Constructor : ColorBlend Constructor(Color[],Object)

colors
containerObject

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colors() As Color, _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim colors() As Color
Dim containerObject As Object

Dim instance As ColorBlend(colors, containerObject)
C#
public ColorBlend(
   Color[] colors,
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colors() As Color, _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim colors() As Color
Dim containerObject As Object

Dim instance As ColorBlend(colors, containerObject)
C#
public ColorBlend(
   Color[] colors,
   object containerObject
)

Parameters

colors
containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members
Overload List


ColorBlend Constructor(Color[],Single[])

ColorBlend Constructor(Color[],Single[])
See Also
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class > ColorBlend Constructor : ColorBlend Constructor(Color[],Single[])

colors
positions

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colors() As Color, _
   ByVal positions() As Single _
)
Visual Basic (Usage) Copy Code
Dim colors() As Color
Dim positions() As Single

Dim instance As ColorBlend(colors, positions)
C#
public ColorBlend(
   Color[] colors,
   float[] positions
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colors() As Color, _
   ByVal positions() As Single _
)
Visual Basic (Usage) Copy Code
Dim colors() As Color
Dim positions() As Single

Dim instance As ColorBlend(colors, positions)
C#
public ColorBlend(
   Color[] colors,
   float[] positions
)

Parameters

colors
positions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members
Overload List


ColorBlend Constructor(Color[],Single[],Object)

ColorBlend Constructor(Color[],Single[],Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class > ColorBlend Constructor : ColorBlend Constructor(Color[],Single[],Object)

colors
positions
containerObject

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colors() As Color, _
   ByVal positions() As Single, _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim colors() As Color
Dim positions() As Single
Dim containerObject As Object

Dim instance As ColorBlend(colors, positions, containerObject)
C#
public ColorBlend(
   Color[] colors,
   float[] positions,
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colors() As Color, _
   ByVal positions() As Single, _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim colors() As Color
Dim positions() As Single
Dim containerObject As Object

Dim instance As ColorBlend(colors, positions, containerObject)
C#
public ColorBlend(
   Color[] colors,
   float[] positions,
   object containerObject
)

Parameters

colors
positions
containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members
Overload List


ColorBlend Constructor(Object)

ColorBlend Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class > ColorBlend Constructor : ColorBlend Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As ColorBlend(containerObject)
C#
public ColorBlend(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As ColorBlend(containerObject)
C#
public ColorBlend(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members
Overload List


ColorBlend Class Methods

ColorBlend Class Methods
[image]
Telerik.Reporting.Charting Namespace : ColorBlend Class

For a list of all members of this type, see ColorBlend members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | AddRange | Overloaded.
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | Clone |
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | Equals | Overridden.
Public Method | GetBrush |
Public Method | GetColor |
Public Method | GetColors |
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | GetHashCode | Overridden.
Public Method | GetPositions |
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | LoadFrom |
Public Method | Remove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Top

See Also

Reference

ColorBlend Class
Telerik.Reporting.Charting Namespace


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class : AddRange Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
AddRange(ColorBlend) |
AddRange(GradientElement[]) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)

Overload List

Overload | Description
AddRange(ColorBlend) |
AddRange(GradientElement[]) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members


AddRange(ColorBlend) Method

AddRange(ColorBlend) Method
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class > AddRange Method : AddRange(ColorBlend) Method

blend

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddRange( _
   ByVal blend As ColorBlend _
)
Visual Basic (Usage) Copy Code
Dim instance As ColorBlend
Dim blend As ColorBlend

instance.AddRange(blend)
C#
public void AddRange(
   ColorBlend blend
)

Parameters

blend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members
Overload List


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class : Clone Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ColorBlend
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ColorBlend
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members


GetBrush Method

GetBrush Method
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class : GetBrush Method

rectangle
angle

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBrush( _
   ByVal rectangle As RectangleF, _
   ByVal angle As Single _
) As LinearGradientBrush
Visual Basic (Usage) Copy Code
Dim instance As ColorBlend
Dim rectangle As RectangleF
Dim angle As Single
Dim value As LinearGradientBrush

value = instance.GetBrush(rectangle, angle)
C#
public LinearGradientBrush GetBrush(
   RectangleF rectangle,
   float angle
)

Parameters

rectangle
angle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members


GetColor Method

GetColor Method
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class : GetColor Method

pos

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetColor( _
   ByVal pos As Single _
) As Color
Visual Basic (Usage) Copy Code
Dim instance As ColorBlend
Dim pos As Single
Dim value As Color

value = instance.GetColor(pos)
C#
public Color GetColor(
   float pos
)

Parameters

pos

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members


GetColors Method

GetColors Method
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class : GetColors Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetColors() As Color()
Visual Basic (Usage) Copy Code
Dim instance As ColorBlend
Dim value() As Color

value = instance.GetColors()
C#
public Color[] GetColors()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColorBlend
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members


GetPositions Method

GetPositions Method
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class : GetPositions Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPositions() As Single()
Visual Basic (Usage) Copy Code
Dim instance As ColorBlend
Dim value() As Single

value = instance.GetPositions()
C#
public float[] GetPositions()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members


LoadFrom Method

LoadFrom Method
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class : LoadFrom Method

blend

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadFrom( _
   ByVal blend As ColorBlend _
)
Visual Basic (Usage) Copy Code
Dim instance As ColorBlend
Dim blend As ColorBlend

instance.LoadFrom(blend)
C#
public void LoadFrom(
   ColorBlend blend
)

Parameters

blend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members


ComplexDataSetClass Class

ComplexDataSetClass Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ComplexDataSetClass Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ComplexDataSetClass
Visual Basic (Usage) Copy Code
Dim instance As ComplexDataSetClass
C#
public class ComplexDataSetClass

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.ComplexDataSetClass

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ComplexDataSetClass Members
Telerik.Reporting.Charting Namespace


ComplexDataSetClass Class Members

ComplexDataSetClass Class Members
See Also Methods
[image]
Telerik.Reporting.Charting Namespace : ComplexDataSetClass Class

The following tables list the members exposed by ComplexDataSetClass.

Public Constructors

 | Name | Description
Public Constructor | ComplexDataSetClass Constructor |
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded.
Public Method | GetData |
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden.
Top

See Also

Reference

ComplexDataSetClass Class
Telerik.Reporting.Charting Namespace


ComplexDataSetClass Constructor

ComplexDataSetClass Constructor
[image]
Telerik.Reporting.Charting Namespace > ComplexDataSetClass Class : ComplexDataSetClass Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ComplexDataSetClass()
C#
public ComplexDataSetClass()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ComplexDataSetClass()
C#
public ComplexDataSetClass()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ComplexDataSetClass Class
ComplexDataSetClass Members


ComplexDataSetClass Class Methods

ComplexDataSetClass Class Methods
[image]
Telerik.Reporting.Charting Namespace : ComplexDataSetClass Class

For a list of all members of this type, see ComplexDataSetClass members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded.
Public Method | GetData |
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden.
Top

See Also

Reference

ComplexDataSetClass Class
Telerik.Reporting.Charting Namespace


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting Namespace > ComplexDataSetClass Class : Dispose Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ComplexDataSetClass Class
ComplexDataSetClass Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting Namespace > ComplexDataSetClass Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ComplexDataSetClass

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ComplexDataSetClass Class
ComplexDataSetClass Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting Namespace > ComplexDataSetClass Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ComplexDataSetClass
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ComplexDataSetClass Class
ComplexDataSetClass Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting Namespace > ComplexDataSetClass Class : Finalize Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As ComplexDataSetClass

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ComplexDataSetClass Class
ComplexDataSetClass Members


GetData Method

GetData Method
[image]
Telerik.Reporting.Charting Namespace > ComplexDataSetClass Class : GetData Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetData() As DataSet
Visual Basic (Usage) Copy Code
Dim instance As ComplexDataSetClass
Dim value As DataSet

value = instance.GetData()
C#
public DataSet GetData()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ComplexDataSetClass Class
ComplexDataSetClass Members


CustomFigure Class

CustomFigure Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : CustomFigure Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class CustomFigure
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As CustomFigure
C#
public class CustomFigure : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.CustomFigure

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFigure Members
Telerik.Reporting.Charting Namespace


CustomFigure Class Members

CustomFigure Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : CustomFigure Class

The following tables list the members exposed by CustomFigure.

Public Constructors

 | Name | Description
Public Constructor | CustomFigure Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Description |
Public Property | Name |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | (Inherited from StateManagedObject)
Protected Method | SaveViewState | (Inherited from StateManagedObject)
Protected Method | TrackViewState | (Inherited from StateManagedObject)
Top

See Also

Reference

CustomFigure Class
Telerik.Reporting.Charting Namespace


CustomFigure Constructor

CustomFigure Constructor
[image]
Telerik.Reporting.Charting Namespace > CustomFigure Class : CustomFigure Constructor

Overload List

Overload | Description
CustomFigure Constructor() |
CustomFigure Constructor(String,String) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFigure Class
CustomFigure Members


CustomFigure Constructor()

CustomFigure Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > CustomFigure Class > CustomFigure Constructor : CustomFigure Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CustomFigure()
C#
public CustomFigure()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CustomFigure()
C#
public CustomFigure()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFigure Class
CustomFigure Members
Overload List


CustomFigure Constructor(String,String)

CustomFigure Constructor(String,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > CustomFigure Class > CustomFigure Constructor : CustomFigure Constructor(String,String)

name
description

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal description As String _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim description As String

Dim instance As CustomFigure(name, description)
C#
public CustomFigure(
   string name,
   string description
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal description As String _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim description As String

Dim instance As CustomFigure(name, description)
C#
public CustomFigure(
   string name,
   string description
)

Parameters

name
description

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFigure Class
CustomFigure Members
Overload List


CustomFigure Class Methods

CustomFigure Class Methods
[image]
Telerik.Reporting.Charting Namespace : CustomFigure Class

For a list of all members of this type, see CustomFigure members.

Public Methods

 | Name | Description
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | (Inherited from StateManagedObject)
Protected Method | SaveViewState | (Inherited from StateManagedObject)
Protected Method | TrackViewState | (Inherited from StateManagedObject)
Top

See Also

Reference

CustomFigure Class
Telerik.Reporting.Charting Namespace


ToString Method

ToString Method
[image]
Telerik.Reporting.Charting Namespace > CustomFigure Class : ToString Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As CustomFigure
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFigure Class
CustomFigure Members


CustomFigure Class Properties

CustomFigure Class Properties
[image]
Telerik.Reporting.Charting Namespace : CustomFigure Class

For a list of all members of this type, see CustomFigure members.

Public Properties

 | Name | Description
Public Property | Description |
Public Property | Name |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

CustomFigure Class
Telerik.Reporting.Charting Namespace


Description Property

Description Property
[image]
Telerik.Reporting.Charting Namespace > CustomFigure Class : Description Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As CustomFigure
Dim value As String

instance.Description = value

value = instance.Description
C#
public string Description {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFigure Class
CustomFigure Members


Name Property

Name Property
[image]
Telerik.Reporting.Charting Namespace > CustomFigure Class : Name Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As CustomFigure
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFigure Class
CustomFigure Members


CustomFiguresCollection Class

CustomFiguresCollection Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : CustomFiguresCollection Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class CustomFiguresCollection
   Inherits ChartingStateManagedCollection(Of CustomFigure)
   Implements IChartingStateManager, IDeserializableCollection
Visual Basic (Usage) Copy Code
Dim instance As CustomFiguresCollection
C#
public class CustomFiguresCollection : ChartingStateManagedCollection<CustomFigure>, IChartingStateManager, IDeserializableCollection

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>
Telerik.Reporting.Charting.CustomFiguresCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Members
Telerik.Reporting.Charting Namespace


CustomFiguresCollection Class Members

CustomFiguresCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : CustomFiguresCollection Class

The following tables list the members exposed by CustomFiguresCollection.

Public Constructors

 | Name | Description
Public Constructor | CustomFiguresCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Property | Item | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overridden.
Public Method | AddRange | Overridden.
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Method | Contains | Overloaded.
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Method | GetFigure | Overloaded.
Public Method | IndexOf | Overloaded.
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Method | Remove | Overloaded.
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Top

See Also

Reference

CustomFiguresCollection Class
Telerik.Reporting.Charting Namespace


CustomFiguresCollection Constructor

CustomFiguresCollection Constructor
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class : CustomFiguresCollection Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CustomFiguresCollection()
C#
public CustomFiguresCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CustomFiguresCollection()
C#
public CustomFiguresCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members


CustomFiguresCollection Class Methods

CustomFiguresCollection Class Methods
[image]
Telerik.Reporting.Charting Namespace : CustomFiguresCollection Class

For a list of all members of this type, see CustomFiguresCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overridden.
Public Method | AddRange | Overridden.
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Method | Contains | Overloaded.
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Method | GetFigure | Overloaded.
Public Method | IndexOf | Overloaded.
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Method | Remove | Overloaded.
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Top

See Also

Reference

CustomFiguresCollection Class
Telerik.Reporting.Charting Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class : Add Method

figure

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Add( _
   ByVal figure As CustomFigure _
)
Visual Basic (Usage) Copy Code
Dim instance As CustomFiguresCollection
Dim figure As CustomFigure

instance.Add(figure)
C#
public override void Add(
   CustomFigure figure
)

Parameters

figure

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class : AddRange Method

figure

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub AddRange( _
   ByVal ParamArray figure() As CustomFigure _
)
Visual Basic (Usage) Copy Code
Dim instance As CustomFiguresCollection
Dim figure() As CustomFigure

instance.AddRange(figure)
C#
public override void AddRange(
   params CustomFigure[] figure
)

Parameters

figure

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members


Contains Method

Contains Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class : Contains Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Contains(String) |
Contains(CustomFigure) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)

Overload List

Overload | Description
Contains(String) |
Contains(CustomFigure) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members


Contains(String) Method

Contains(String) Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class > Contains Method : Contains(String) Method

figureName

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Contains( _
   ByVal figureName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomFiguresCollection
Dim figureName As String
Dim value As Boolean

value = instance.Contains(figureName)
C#
public bool Contains(
   string figureName
)

Parameters

figureName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members
Overload List


GetFigure Method

GetFigure Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class : GetFigure Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetFigure(Int32) |
GetFigure(String) |

Overload List

Overload | Description
GetFigure(Int32) |
GetFigure(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members


GetFigure(Int32) Method

GetFigure(Int32) Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class > GetFigure Method : GetFigure(Int32) Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function GetFigure( _
   ByVal index As Integer _
) As CustomFigure
Visual Basic (Usage) Copy Code
Dim instance As CustomFiguresCollection
Dim index As Integer
Dim value As CustomFigure

value = instance.GetFigure(index)
C#
public CustomFigure GetFigure(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members
Overload List


GetFigure(String) Method

GetFigure(String) Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class > GetFigure Method : GetFigure(String) Method

name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function GetFigure( _
   ByVal name As String _
) As CustomFigure
Visual Basic (Usage) Copy Code
Dim instance As CustomFiguresCollection
Dim name As String
Dim value As CustomFigure

value = instance.GetFigure(name)
C#
public CustomFigure GetFigure(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members
Overload List


IndexOf Method

IndexOf Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class : IndexOf Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
IndexOf(String) |
IndexOf(CustomFigure) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)

Overload List

Overload | Description
IndexOf(String) |
IndexOf(CustomFigure) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members


IndexOf(String) Method

IndexOf(String) Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class > IndexOf Method : IndexOf(String) Method

figureName

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal figureName As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CustomFiguresCollection
Dim figureName As String
Dim value As Integer

value = instance.IndexOf(figureName)
C#
public int IndexOf(
   string figureName
)

Parameters

figureName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members
Overload List


Remove Method

Remove Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class : Remove Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Remove(String) |
Remove(CustomFigure) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)

Overload List

Overload | Description
Remove(String) |
Remove(CustomFigure) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members


Remove(String) Method

Remove(String) Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class > Remove Method : Remove(String) Method

figureName

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal figureName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As CustomFiguresCollection
Dim figureName As String

instance.Remove(figureName)
C#
public void Remove(
   string figureName
)

Parameters

figureName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members
Overload List


CustomPalettesCollection Class

CustomPalettesCollection Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : CustomPalettesCollection Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class CustomPalettesCollection
   Inherits ChartingStateManagedCollection(Of Palette)
   Implements IChartingStateManager, IDeserializableCollection
Visual Basic (Usage) Copy Code
Dim instance As CustomPalettesCollection
C#
public class CustomPalettesCollection : ChartingStateManagedCollection<Palette>, IChartingStateManager, IDeserializableCollection

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>
Telerik.Reporting.Charting.CustomPalettesCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Members
Telerik.Reporting.Charting Namespace


CustomPalettesCollection Class Members

CustomPalettesCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : CustomPalettesCollection Class

The following tables list the members exposed by CustomPalettesCollection.

Public Constructors

 | Name | Description
Public Constructor | CustomPalettesCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Property | Item | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | Contains | Overloaded.
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | GetPalette | Overloaded.
Public Method | IndexOf | Overloaded.
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | Remove | Overloaded.
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Top

See Also

Reference

CustomPalettesCollection Class
Telerik.Reporting.Charting Namespace


CustomPalettesCollection Constructor

CustomPalettesCollection Constructor
[image]
Telerik.Reporting.Charting Namespace > CustomPalettesCollection Class : CustomPalettesCollection Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CustomPalettesCollection()
C#
public CustomPalettesCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CustomPalettesCollection()
C#
public CustomPalettesCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Class
CustomPalettesCollection Members


CustomPalettesCollection Class Methods

CustomPalettesCollection Class Methods
[image]
Telerik.Reporting.Charting Namespace : CustomPalettesCollection Class

For a list of all members of this type, see CustomPalettesCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | Contains | Overloaded.
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | GetPalette | Overloaded.
Public Method | IndexOf | Overloaded.
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | Remove | Overloaded.
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Top

See Also

Reference

CustomPalettesCollection Class
Telerik.Reporting.Charting Namespace


Contains Method

Contains Method
[image]
Telerik.Reporting.Charting Namespace > CustomPalettesCollection Class : Contains Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Contains(String) |
Contains(Palette) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)

Overload List

Overload | Description
Contains(String) |
Contains(Palette) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Class
CustomPalettesCollection Members


Contains(String) Method

Contains(String) Method
[image]
Telerik.Reporting.Charting Namespace > CustomPalettesCollection Class > Contains Method : Contains(String) Method

paletteName

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Contains( _
   ByVal paletteName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomPalettesCollection
Dim paletteName As String
Dim value As Boolean

value = instance.Contains(paletteName)
C#
public bool Contains(
   string paletteName
)

Parameters

paletteName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Class
CustomPalettesCollection Members
Overload List


GetPalette Method

GetPalette Method
[image]
Telerik.Reporting.Charting Namespace > CustomPalettesCollection Class : GetPalette Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetPalette(Int32) |
GetPalette(String) |

Overload List

Overload | Description
GetPalette(Int32) |
GetPalette(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Class
CustomPalettesCollection Members


GetPalette(Int32) Method

GetPalette(Int32) Method
[image]
Telerik.Reporting.Charting Namespace > CustomPalettesCollection Class > GetPalette Method : GetPalette(Int32) Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function GetPalette( _
   ByVal index As Integer _
) As Palette
Visual Basic (Usage) Copy Code
Dim instance As CustomPalettesCollection
Dim index As Integer
Dim value As Palette

value = instance.GetPalette(index)
C#
public Palette GetPalette(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Class
CustomPalettesCollection Members
Overload List


GetPalette(String) Method

GetPalette(String) Method
[image]
Telerik.Reporting.Charting Namespace > CustomPalettesCollection Class > GetPalette Method : GetPalette(String) Method

name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function GetPalette( _
   ByVal name As String _
) As Palette
Visual Basic (Usage) Copy Code
Dim instance As CustomPalettesCollection
Dim name As String
Dim value As Palette

value = instance.GetPalette(name)
C#
public Palette GetPalette(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Class
CustomPalettesCollection Members
Overload List


IndexOf Method

IndexOf Method
[image]
Telerik.Reporting.Charting Namespace > CustomPalettesCollection Class : IndexOf Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
IndexOf(String) |
IndexOf(Palette) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)

Overload List

Overload | Description
IndexOf(String) |
IndexOf(Palette) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Class
CustomPalettesCollection Members


IndexOf(String) Method

IndexOf(String) Method
[image]
Telerik.Reporting.Charting Namespace > CustomPalettesCollection Class > IndexOf Method : IndexOf(String) Method

paletteName

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal paletteName As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CustomPalettesCollection
Dim paletteName As String
Dim value As Integer

value = instance.IndexOf(paletteName)
C#
public int IndexOf(
   string paletteName
)

Parameters

paletteName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Class
CustomPalettesCollection Members
Overload List


Remove Method

Remove Method
[image]
Telerik.Reporting.Charting Namespace > CustomPalettesCollection Class : Remove Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Remove(String) |
Remove(Palette) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)

Overload List

Overload | Description
Remove(String) |
Remove(Palette) | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Class
CustomPalettesCollection Members


Remove(String) Method

Remove(String) Method
[image]
Telerik.Reporting.Charting Namespace > CustomPalettesCollection Class > Remove Method : Remove(String) Method

paletteName

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal paletteName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As CustomPalettesCollection
Dim paletteName As String

instance.Remove(paletteName)
C#
public void Remove(
   string paletteName
)

Parameters

paletteName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Class
CustomPalettesCollection Members
Overload List


DataManager Class

DataManager Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : DataManager Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataManager
Visual Basic (Usage) Copy Code
Dim instance As DataManager
C#
public sealed class DataManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.DataManager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataManager Members
Telerik.Reporting.Charting Namespace


DataManager Class Members

DataManager Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting.Charting Namespace : DataManager Class

The following tables list the members exposed by DataManager.

Public Properties

 | Name | Description
Public Property | DataMember |
Public Property | DataSource |
Public Property | IsDataBindCalled |
Public Property | LabelsColumn |
Public Property | UseSeriesGrouping |
Public Property | ValuesXColumn |
Public Property | ValuesYColumns |
Top

Public Methods

 | Name | Description
Public Method | ClearDataSource |
Public Method | CopyFrom |
Public Method | DataBind |
Top

Public Events

 | Name | Description
Public Event | ItemDataBound |
Top

See Also

Reference

DataManager Class
Telerik.Reporting.Charting Namespace


DataManager Class Methods

DataManager Class Methods
[image]
Telerik.Reporting.Charting Namespace : DataManager Class

For a list of all members of this type, see DataManager members.

Public Methods

 | Name | Description
Public Method | ClearDataSource |
Public Method | CopyFrom |
Public Method | DataBind |
Top

See Also

Reference

DataManager Class
Telerik.Reporting.Charting Namespace


ClearDataSource Method

ClearDataSource Method
[image]
Telerik.Reporting.Charting Namespace > DataManager Class : ClearDataSource Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearDataSource()
Visual Basic (Usage) Copy Code
Dim instance As DataManager

instance.ClearDataSource()
C#
public void ClearDataSource()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataManager Class
DataManager Members


CopyFrom Method

CopyFrom Method
[image]
Telerik.Reporting.Charting Namespace > DataManager Class : CopyFrom Method

manager

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyFrom( _
   ByVal manager As DataManager _
)
Visual Basic (Usage) Copy Code
Dim instance As DataManager
Dim manager As DataManager

instance.CopyFrom(manager)
C#
public void CopyFrom(
   DataManager manager
)

Parameters

manager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataManager Class
DataManager Members


DataBind Method

DataBind Method
[image]
Telerik.Reporting.Charting Namespace > DataManager Class : DataBind Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As DataManager

instance.DataBind()
C#
public void DataBind()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataManager Class
DataManager Members


DataManager Class Properties

DataManager Class Properties
[image]
Telerik.Reporting.Charting Namespace : DataManager Class

For a list of all members of this type, see DataManager members.

Public Properties

 | Name | Description
Public Property | DataMember |
Public Property | DataSource |
Public Property | IsDataBindCalled |
Public Property | LabelsColumn |
Public Property | UseSeriesGrouping |
Public Property | ValuesXColumn |
Public Property | ValuesYColumns |
Top

See Also

Reference

DataManager Class
Telerik.Reporting.Charting Namespace


DataMember Property

DataMember Property
[image]
Telerik.Reporting.Charting Namespace > DataManager Class : DataMember Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As DataManager
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
public string DataMember {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataManager Class
DataManager Members


DataSource Property

DataSource Property
[image]
Telerik.Reporting.Charting Namespace > DataManager Class : DataSource Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As DataManager
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
public object DataSource {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataManager Class
DataManager Members


IsDataBindCalled Property

IsDataBindCalled Property
[image]
Telerik.Reporting.Charting Namespace > DataManager Class : IsDataBindCalled Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDataBindCalled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataManager
Dim value As Boolean

instance.IsDataBindCalled = value

value = instance.IsDataBindCalled
C#
public bool IsDataBindCalled {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataManager Class
DataManager Members


LabelsColumn Property

LabelsColumn Property
[image]
Telerik.Reporting.Charting Namespace > DataManager Class : LabelsColumn Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelsColumn As String
Visual Basic (Usage) Copy Code
Dim instance As DataManager
Dim value As String

instance.LabelsColumn = value

value = instance.LabelsColumn
C#
public string LabelsColumn {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataManager Class
DataManager Members


UseSeriesGrouping Property

UseSeriesGrouping Property
[image]
Telerik.Reporting.Charting Namespace > DataManager Class : UseSeriesGrouping Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property UseSeriesGrouping As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataManager
Dim value As Boolean

instance.UseSeriesGrouping = value

value = instance.UseSeriesGrouping
C#
public bool UseSeriesGrouping {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataManager Class
DataManager Members


ValuesXColumn Property

ValuesXColumn Property
[image]
Telerik.Reporting.Charting Namespace > DataManager Class : ValuesXColumn Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ValuesXColumn As String
Visual Basic (Usage) Copy Code
Dim instance As DataManager
Dim value As String

instance.ValuesXColumn = value

value = instance.ValuesXColumn
C#
public string ValuesXColumn {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataManager Class
DataManager Members


ValuesYColumns Property

ValuesYColumns Property
[image]
Telerik.Reporting.Charting Namespace > DataManager Class : ValuesYColumns Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ValuesYColumns As String()
Visual Basic (Usage) Copy Code
Dim instance As DataManager
Dim value() As String

instance.ValuesYColumns = value

value = instance.ValuesYColumns
C#
public string[] ValuesYColumns {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataManager Class
DataManager Members


DataManager Class Events

DataManager Class Events
[image]
Telerik.Reporting.Charting Namespace : DataManager Class

For a list of all members of this type, see DataManager members.

Public Events

 | Name | Description
Public Event | ItemDataBound |
Top

See Also

Reference

DataManager Class
Telerik.Reporting.Charting Namespace


ItemDataBound Event

ItemDataBound Event
[image]
Telerik.Reporting.Charting Namespace > DataManager Class : ItemDataBound Event

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event ItemDataBound() As EventHandler(Of ChartItemDataBoundEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As DataManager
Dim handler As EventHandler(Of ChartItemDataBoundEventArgs)

AddHandler instance.ItemDataBound, handler
C#
public event EventHandler<ChartItemDataBoundEventArgs> ItemDataBound()

Syntax

Visual Basic (Declaration)
Public Event ItemDataBound() As EventHandler(Of ChartItemDataBoundEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As DataManager
Dim handler As EventHandler(Of ChartItemDataBoundEventArgs)

AddHandler instance.ItemDataBound, handler
C#
public event EventHandler<ChartItemDataBoundEventArgs> ItemDataBound()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataManager Class
DataManager Members


DataSetClass Class

DataSetClass Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : DataSetClass Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class DataSetClass
Visual Basic (Usage) Copy Code
Dim instance As DataSetClass
C#
public class DataSetClass

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.DataSetClass

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataSetClass Members
Telerik.Reporting.Charting Namespace


DataSetClass Class Members

DataSetClass Class Members
See Also Methods
[image]
Telerik.Reporting.Charting Namespace : DataSetClass Class

The following tables list the members exposed by DataSetClass.

Public Constructors

 | Name | Description
Public Constructor | DataSetClass Constructor |
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded.
Public Method | GetData |
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden.
Top

See Also

Reference

DataSetClass Class
Telerik.Reporting.Charting Namespace


DataSetClass Constructor

DataSetClass Constructor
[image]
Telerik.Reporting.Charting Namespace > DataSetClass Class : DataSetClass Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataSetClass()
C#
public DataSetClass()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataSetClass()
C#
public DataSetClass()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataSetClass Class
DataSetClass Members


DataSetClass Class Methods

DataSetClass Class Methods
[image]
Telerik.Reporting.Charting Namespace : DataSetClass Class

For a list of all members of this type, see DataSetClass members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded.
Public Method | GetData |
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden.
Top

See Also

Reference

DataSetClass Class
Telerik.Reporting.Charting Namespace


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting Namespace > DataSetClass Class : Dispose Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataSetClass Class
DataSetClass Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting Namespace > DataSetClass Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As DataSetClass

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataSetClass Class
DataSetClass Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting Namespace > DataSetClass Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataSetClass
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataSetClass Class
DataSetClass Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting Namespace > DataSetClass Class : Finalize Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As DataSetClass

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataSetClass Class
DataSetClass Members


GetData Method

GetData Method
[image]
Telerik.Reporting.Charting Namespace > DataSetClass Class : GetData Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetData() As DataSet
Visual Basic (Usage) Copy Code
Dim instance As DataSetClass
Dim value As DataSet

value = instance.GetData()
C#
public DataSet GetData()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataSetClass Class
DataSetClass Members


DemoData Class

DemoData Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : DemoData Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class DemoData
Visual Basic (Usage) Copy Code
Dim instance As DemoData
C#
public class DemoData

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.DemoData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DemoData Members
Telerik.Reporting.Charting Namespace


DemoData Class Members

DemoData Class Members
See Also Fields Properties
[image]
Telerik.Reporting.Charting Namespace : DemoData Class

The following tables list the members exposed by DemoData.

Public Constructors

 | Name | Description
Public Constructor | DemoData Constructor |
Top

Public Fields

 | Name | Description
Public Field | DoubleArray |
Public Field | ObjectsArray |
Public Field | ObjectsArrayCat |
Top

Public Properties

 | Name | Description
Public Property | DoubleList |
Top

See Also

Reference

DemoData Class
Telerik.Reporting.Charting Namespace


DemoData Constructor

DemoData Constructor
[image]
Telerik.Reporting.Charting Namespace > DemoData Class : DemoData Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DemoData()
C#
public DemoData()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DemoData()
C#
public DemoData()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DemoData Class
DemoData Members


DemoData Class Properties

DemoData Class Properties
[image]
Telerik.Reporting.Charting Namespace : DemoData Class

For a list of all members of this type, see DemoData members.

Public Properties

 | Name | Description
Public Property | DoubleList |
Top

See Also

Reference

DemoData Class
Telerik.Reporting.Charting Namespace


DoubleList Property

DoubleList Property
[image]
Telerik.Reporting.Charting Namespace > DemoData Class : DoubleList Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DoubleList As List(Of Double)
Visual Basic (Usage) Copy Code
Dim instance As DemoData
Dim value As List(Of Double)

value = instance.DoubleList
C#
public List<double> DoubleList {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DemoData Class
DemoData Members


DemoData Class Fields

DemoData Class Fields
[image]
Telerik.Reporting.Charting Namespace : DemoData Class

For a list of all members of this type, see DemoData members.

Public Fields

 | Name | Description
Public Field | DoubleArray |
Public Field | ObjectsArray |
Public Field | ObjectsArrayCat |
Top

See Also

Reference

DemoData Class
Telerik.Reporting.Charting Namespace


DoubleArray Field

DoubleArray Field
[image]
Telerik.Reporting.Charting Namespace > DemoData Class : DoubleArray Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public DoubleArray As Double()
Visual Basic (Usage) Copy Code
Dim instance As DemoData
Dim value() As Double

value = instance.DoubleArray

instance.DoubleArray = value
C#
public double[] DoubleArray

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DemoData Class
DemoData Members


ObjectsArray Field

ObjectsArray Field
[image]
Telerik.Reporting.Charting Namespace > DemoData Class : ObjectsArray Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ObjectsArray As Object()
Visual Basic (Usage) Copy Code
Dim instance As DemoData
Dim value() As Object

value = instance.ObjectsArray

instance.ObjectsArray = value
C#
public object[] ObjectsArray

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DemoData Class
DemoData Members


ObjectsArrayCat Field

ObjectsArrayCat Field
[image]
Telerik.Reporting.Charting Namespace > DemoData Class : ObjectsArrayCat Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ObjectsArrayCat As Object()
Visual Basic (Usage) Copy Code
Dim instance As DemoData
Dim value() As Object

value = instance.ObjectsArrayCat

instance.ObjectsArrayCat = value
C#
public object[] ObjectsArrayCat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DemoData Class
DemoData Members


DoubleCollection Class

DoubleCollection Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : DoubleCollection Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class DoubleCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection
C#
public class DoubleCollection : CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.Reporting.Charting.DoubleCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DoubleCollection Members
Telerik.Reporting.Charting Namespace


DoubleCollection Class Members

DoubleCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : DoubleCollection Class

The following tables list the members exposed by DoubleCollection.

Public Constructors

 | Name | Description
Public Constructor | DoubleCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item |
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains |
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf |
Public Method | InitData |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | Overridden.
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | Overridden.
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | Overridden.
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden.
Top

See Also

Reference

DoubleCollection Class
Telerik.Reporting.Charting Namespace


DoubleCollection Constructor

DoubleCollection Constructor
[image]
Telerik.Reporting.Charting Namespace > DoubleCollection Class : DoubleCollection Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection()
C#
public DoubleCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection()
C#
public DoubleCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DoubleCollection Class
DoubleCollection Members


DoubleCollection Class Methods

DoubleCollection Class Methods
[image]
Telerik.Reporting.Charting Namespace : DoubleCollection Class

For a list of all members of this type, see DoubleCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains |
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf |
Public Method | InitData |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | Overridden.
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | Overridden.
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | Overridden.
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden.
Top

See Also

Reference

DoubleCollection Class
Telerik.Reporting.Charting Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting Namespace > DoubleCollection Class : Add Method

value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As Double _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection
Dim value As Double
Dim value As Integer

value = instance.Add(value)
C#
public int Add(
   double value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DoubleCollection Class
DoubleCollection Members


Contains Method

Contains Method
[image]
Telerik.Reporting.Charting Namespace > DoubleCollection Class : Contains Method

value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Double _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection
Dim value As Double
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   double value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DoubleCollection Class
DoubleCollection Members


IndexOf Method

IndexOf Method
[image]
Telerik.Reporting.Charting Namespace > DoubleCollection Class : IndexOf Method

value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Double _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection
Dim value As Double
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   double value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DoubleCollection Class
DoubleCollection Members


InitData Method

InitData Method
[image]
Telerik.Reporting.Charting Namespace > DoubleCollection Class : InitData Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub InitData()
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection

instance.InitData()
C#
public void InitData()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DoubleCollection Class
DoubleCollection Members


Insert Method

Insert Method
[image]
Telerik.Reporting.Charting Namespace > DoubleCollection Class : Insert Method

index
value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection
Dim index As Integer
Dim value As Double

instance.Insert(index, value)
C#
public void Insert(
   int index,
   double value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DoubleCollection Class
DoubleCollection Members


OnInsert Method

OnInsert Method
[image]
Telerik.Reporting.Charting Namespace > DoubleCollection Class : OnInsert Method

index
value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnInsert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection
Dim index As Integer
Dim value As Object

instance.OnInsert(index, value)
C#
protected override void OnInsert(
   int index,
   object value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DoubleCollection Class
DoubleCollection Members


OnRemove Method

OnRemove Method
[image]
Telerik.Reporting.Charting Namespace > DoubleCollection Class : OnRemove Method

index
value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnRemove( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection
Dim index As Integer
Dim value As Object

instance.OnRemove(index, value)
C#
protected override void OnRemove(
   int index,
   object value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DoubleCollection Class
DoubleCollection Members


OnSet Method

OnSet Method
[image]
Telerik.Reporting.Charting Namespace > DoubleCollection Class : OnSet Method

index
oldValue
newValue

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnSet( _
   ByVal index As Integer, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection
Dim index As Integer
Dim oldValue As Object
Dim newValue As Object

instance.OnSet(index, oldValue, newValue)
C#
protected override void OnSet(
   int index,
   object oldValue,
   object newValue
)

Parameters

index
oldValue
newValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DoubleCollection Class
DoubleCollection Members


OnValidate Method

OnValidate Method
[image]
Telerik.Reporting.Charting Namespace > DoubleCollection Class : OnValidate Method

value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnValidate( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection
Dim value As Object

instance.OnValidate(value)
C#
protected override void OnValidate(
   object value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DoubleCollection Class
DoubleCollection Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Charting Namespace > DoubleCollection Class : Remove Method

value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection
Dim value As Double

instance.Remove(value)
C#
public void Remove(
   double value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DoubleCollection Class
DoubleCollection Members


DoubleCollection Class Properties

DoubleCollection Class Properties
[image]
Telerik.Reporting.Charting Namespace : DoubleCollection Class

For a list of all members of this type, see DoubleCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item |
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

DoubleCollection Class
Telerik.Reporting.Charting Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Charting Namespace > DoubleCollection Class : Item Property

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As DoubleCollection
Dim index As Integer
Dim value As Double

instance.Item(index) = value

value = instance.Item(index)
C#
public double this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DoubleCollection Class
DoubleCollection Members


DummyWebControl Class

DummyWebControl Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : DummyWebControl Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class DummyWebControl
   Inherits WebControl
Visual Basic (Usage) Copy Code
Dim instance As DummyWebControl
C#
public class DummyWebControl : WebControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.Reporting.Charting.DummyWebControl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DummyWebControl Members
Telerik.Reporting.Charting Namespace


DummyWebControl Class Members

DummyWebControl Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting.Charting Namespace : DummyWebControl Class

The following tables list the members exposed by DummyWebControl.

Public Constructors

 | Name | Description
Public Constructor | DummyWebControl Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | (Inherited from System.Web.UI.Control)
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | RenderChildren | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

DummyWebControl Class
Telerik.Reporting.Charting Namespace


DummyWebControl Constructor

DummyWebControl Constructor
[image]
Telerik.Reporting.Charting Namespace > DummyWebControl Class : DummyWebControl Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DummyWebControl()
C#
public DummyWebControl()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DummyWebControl()
C#
public DummyWebControl()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DummyWebControl Class
DummyWebControl Members


EmptySeriesMessage Class

EmptySeriesMessage Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : EmptySeriesMessage Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class EmptySeriesMessage
   Inherits ChartLabel
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As EmptySeriesMessage
C#
public class EmptySeriesMessage : ChartLabel, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ChartLabel
Telerik.Reporting.Charting.EmptySeriesMessage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptySeriesMessage Members
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Class Members

EmptySeriesMessage Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : EmptySeriesMessage Class

The following tables list the members exposed by EmptySeriesMessage.

Public Constructors

 | Name | Description
Public Constructor | EmptySeriesMessage Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

EmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Constructor

EmptySeriesMessage Constructor
[image]
Telerik.Reporting.Charting Namespace > EmptySeriesMessage Class : EmptySeriesMessage Constructor

Overload List

Overload | Description
EmptySeriesMessage Constructor() |
EmptySeriesMessage Constructor(ChartPlotArea) |
EmptySeriesMessage Constructor(ChartPlotArea,IContainer) |
EmptySeriesMessage Constructor(IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptySeriesMessage Class
EmptySeriesMessage Members


EmptySeriesMessage Constructor()

EmptySeriesMessage Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > EmptySeriesMessage Class > EmptySeriesMessage Constructor : EmptySeriesMessage Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EmptySeriesMessage()
C#
public EmptySeriesMessage()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EmptySeriesMessage()
C#
public EmptySeriesMessage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptySeriesMessage Class
EmptySeriesMessage Members
Overload List


EmptySeriesMessage Constructor(ChartPlotArea)

EmptySeriesMessage Constructor(ChartPlotArea)
See Also
[image]
Telerik.Reporting.Charting Namespace > EmptySeriesMessage Class > EmptySeriesMessage Constructor : EmptySeriesMessage Constructor(ChartPlotArea)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartPlotArea _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartPlotArea

Dim instance As EmptySeriesMessage(parent)
C#
public EmptySeriesMessage(
   ChartPlotArea parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartPlotArea _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartPlotArea

Dim instance As EmptySeriesMessage(parent)
C#
public EmptySeriesMessage(
   ChartPlotArea parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptySeriesMessage Class
EmptySeriesMessage Members
Overload List


EmptySeriesMessage Constructor(ChartPlotArea,IContainer)

EmptySeriesMessage Constructor(ChartPlotArea,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > EmptySeriesMessage Class > EmptySeriesMessage Constructor : EmptySeriesMessage Constructor(ChartPlotArea,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartPlotArea, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartPlotArea
Dim container As IContainer

Dim instance As EmptySeriesMessage(parent, container)
C#
public EmptySeriesMessage(
   ChartPlotArea parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartPlotArea, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartPlotArea
Dim container As IContainer

Dim instance As EmptySeriesMessage(parent, container)
C#
public EmptySeriesMessage(
   ChartPlotArea parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptySeriesMessage Class
EmptySeriesMessage Members
Overload List


EmptySeriesMessage Constructor(IContainer)

EmptySeriesMessage Constructor(IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > EmptySeriesMessage Class > EmptySeriesMessage Constructor : EmptySeriesMessage Constructor(IContainer)

container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As EmptySeriesMessage(container)
C#
public EmptySeriesMessage(
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As EmptySeriesMessage(container)
C#
public EmptySeriesMessage(
   IContainer container
)

Parameters

container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptySeriesMessage Class
EmptySeriesMessage Members
Overload List


EmptySeriesMessage Class Properties

EmptySeriesMessage Class Properties
[image]
Telerik.Reporting.Charting Namespace : EmptySeriesMessage Class

For a list of all members of this type, see EmptySeriesMessage members.

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

EmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting Namespace > EmptySeriesMessage Class : Visible Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EmptySeriesMessage
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptySeriesMessage Class
EmptySeriesMessage Members


ExtendedLabel Class

ExtendedLabel Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ExtendedLabel Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ExtendedLabel
   Inherits ChartBaseLabel
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
C#
public class ExtendedLabel : ChartBaseLabel, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ExtendedLabel
Telerik.Reporting.Charting.ChartLegend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Members
Telerik.Reporting.Charting Namespace


ExtendedLabel Class Members

ExtendedLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ExtendedLabel Class

The following tables list the members exposed by ExtendedLabel.

Public Constructors

 | Name | Description
Public Constructor | ExtendedLabel Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | extendedLabelItems |
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Item |
Public Property | Items |
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | AddLabel | Overloaded.
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clear |
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetLabel |
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAllLabels |
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | RemoveLabel | Overloaded.
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


ExtendedLabel Constructor

ExtendedLabel Constructor
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class : ExtendedLabel Constructor

Overload List

Overload | Description
ExtendedLabel Constructor() |
ExtendedLabel Constructor(Object) |
ExtendedLabel Constructor(Object,IContainer,StyleExtendedLabel,TextBlock,String) |
ExtendedLabel Constructor(Object,IContainer,TextBlock) |
ExtendedLabel Constructor(String) |
ExtendedLabel Constructor(StyleExtendedLabel) |
ExtendedLabel Constructor(StyleExtendedLabel,Object) |
ExtendedLabel Constructor(StyleExtendedLabel,String) |
ExtendedLabel Constructor(TextBlock) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members


ExtendedLabel Constructor()

ExtendedLabel Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > ExtendedLabel Constructor : ExtendedLabel Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel()
C#
public ExtendedLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel()
C#
public ExtendedLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


ExtendedLabel Constructor(Object)

ExtendedLabel Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > ExtendedLabel Constructor : ExtendedLabel Constructor(Object)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As ExtendedLabel(parent)
C#
public ExtendedLabel(
   object parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As ExtendedLabel(parent)
C#
public ExtendedLabel(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


ExtendedLabel Constructor(Object,IContainer,StyleExtendedLabel,TextBlock,String)

ExtendedLabel Constructor(Object,IContainer,StyleExtendedLabel,TextBlock,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > ExtendedLabel Constructor : ExtendedLabel Constructor(Object,IContainer,StyleExtendedLabel,TextBlock,String)

parent
container
appearance
textBlock
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer, _
   ByVal appearance As StyleExtendedLabel, _
   ByVal textBlock As TextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer
Dim appearance As StyleExtendedLabel
Dim textBlock As TextBlock
Dim text As String

Dim instance As ExtendedLabel(parent, container, appearance, textBlock, text)
C#
public ExtendedLabel(
   object parent,
   IContainer container,
   StyleExtendedLabel appearance,
   TextBlock textBlock,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer, _
   ByVal appearance As StyleExtendedLabel, _
   ByVal textBlock As TextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer
Dim appearance As StyleExtendedLabel
Dim textBlock As TextBlock
Dim text As String

Dim instance As ExtendedLabel(parent, container, appearance, textBlock, text)
C#
public ExtendedLabel(
   object parent,
   IContainer container,
   StyleExtendedLabel appearance,
   TextBlock textBlock,
   string text
)

Parameters

parent
container
appearance
textBlock
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


ExtendedLabel Constructor(Object,IContainer,TextBlock)

ExtendedLabel Constructor(Object,IContainer,TextBlock)
See Also
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > ExtendedLabel Constructor : ExtendedLabel Constructor(Object,IContainer,TextBlock)

parent
container
textBlock

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer, _
   ByVal textBlock As TextBlock _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer
Dim textBlock As TextBlock

Dim instance As ExtendedLabel(parent, container, textBlock)
C#
public ExtendedLabel(
   object parent,
   IContainer container,
   TextBlock textBlock
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal container As IContainer, _
   ByVal textBlock As TextBlock _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim container As IContainer
Dim textBlock As TextBlock

Dim instance As ExtendedLabel(parent, container, textBlock)
C#
public ExtendedLabel(
   object parent,
   IContainer container,
   TextBlock textBlock
)

Parameters

parent
container
textBlock

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


ExtendedLabel Constructor(String)

ExtendedLabel Constructor(String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > ExtendedLabel Constructor : ExtendedLabel Constructor(String)

text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As ExtendedLabel(text)
C#
public ExtendedLabel(
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As ExtendedLabel(text)
C#
public ExtendedLabel(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


ExtendedLabel Constructor(StyleExtendedLabel)

ExtendedLabel Constructor(StyleExtendedLabel)
See Also
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > ExtendedLabel Constructor : ExtendedLabel Constructor(StyleExtendedLabel)

appearance

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleExtendedLabel _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleExtendedLabel

Dim instance As ExtendedLabel(appearance)
C#
public ExtendedLabel(
   StyleExtendedLabel appearance
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleExtendedLabel _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleExtendedLabel

Dim instance As ExtendedLabel(appearance)
C#
public ExtendedLabel(
   StyleExtendedLabel appearance
)

Parameters

appearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


ExtendedLabel Constructor(StyleExtendedLabel,Object)

ExtendedLabel Constructor(StyleExtendedLabel,Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > ExtendedLabel Constructor : ExtendedLabel Constructor(StyleExtendedLabel,Object)

appearance
parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleExtendedLabel, _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleExtendedLabel
Dim parent As Object

Dim instance As ExtendedLabel(appearance, parent)
C#
public ExtendedLabel(
   StyleExtendedLabel appearance,
   object parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleExtendedLabel, _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleExtendedLabel
Dim parent As Object

Dim instance As ExtendedLabel(appearance, parent)
C#
public ExtendedLabel(
   StyleExtendedLabel appearance,
   object parent
)

Parameters

appearance
parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


ExtendedLabel Constructor(StyleExtendedLabel,String)

ExtendedLabel Constructor(StyleExtendedLabel,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > ExtendedLabel Constructor : ExtendedLabel Constructor(StyleExtendedLabel,String)

appearance
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleExtendedLabel, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleExtendedLabel
Dim text As String

Dim instance As ExtendedLabel(appearance, text)
C#
public ExtendedLabel(
   StyleExtendedLabel appearance,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleExtendedLabel, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleExtendedLabel
Dim text As String

Dim instance As ExtendedLabel(appearance, text)
C#
public ExtendedLabel(
   StyleExtendedLabel appearance,
   string text
)

Parameters

appearance
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


ExtendedLabel Constructor(TextBlock)

ExtendedLabel Constructor(TextBlock)
See Also
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > ExtendedLabel Constructor : ExtendedLabel Constructor(TextBlock)

textBlock

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal textBlock As TextBlock _
)
Visual Basic (Usage) Copy Code
Dim textBlock As TextBlock

Dim instance As ExtendedLabel(textBlock)
C#
public ExtendedLabel(
   TextBlock textBlock
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal textBlock As TextBlock _
)
Visual Basic (Usage) Copy Code
Dim textBlock As TextBlock

Dim instance As ExtendedLabel(textBlock)
C#
public ExtendedLabel(
   TextBlock textBlock
)

Parameters

textBlock

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


ExtendedLabel Class Methods

ExtendedLabel Class Methods
[image]
Telerik.Reporting.Charting Namespace : ExtendedLabel Class

For a list of all members of this type, see ExtendedLabel members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | AddLabel | Overloaded.
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clear |
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetLabel |
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAllLabels |
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | RemoveLabel | Overloaded.
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


AddLabel Method

AddLabel Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class : AddLabel Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
AddLabel(LabelItem,LabelItem[]) |
AddLabel(ChartLabelsCollection) |
AddLabel(LabelItem[]) |
AddLabel(Generic List) |

Overload List

Overload | Description
AddLabel(LabelItem,LabelItem[]) |
AddLabel(ChartLabelsCollection) |
AddLabel(LabelItem[]) |
AddLabel(Generic List) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members


AddLabel(LabelItem,LabelItem[]) Method

AddLabel(LabelItem,LabelItem[]) Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > AddLabel Method : AddLabel(LabelItem,LabelItem[]) Method

Label
chartLabels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddLabel( _
   ByVal Label As LabelItem, _
   ByVal ParamArray chartLabels() As LabelItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
Dim Label As LabelItem
Dim chartLabels() As LabelItem

instance.AddLabel(Label, chartLabels)
C#
public void AddLabel(
   LabelItem Label,
   params LabelItem[] chartLabels
)

Parameters

Label
chartLabels

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


AddLabel(ChartLabelsCollection) Method

AddLabel(ChartLabelsCollection) Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > AddLabel Method : AddLabel(ChartLabelsCollection) Method

chartLabels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddLabel( _
   ByVal chartLabels As ChartLabelsCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
Dim chartLabels As ChartLabelsCollection

instance.AddLabel(chartLabels)
C#
public void AddLabel(
   ChartLabelsCollection chartLabels
)

Parameters

chartLabels

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


AddLabel(LabelItem[]) Method

AddLabel(LabelItem[]) Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > AddLabel Method : AddLabel(LabelItem[]) Method

chartLabels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddLabel( _
   ByVal chartLabels() As LabelItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
Dim chartLabels() As LabelItem

instance.AddLabel(chartLabels)
C#
public void AddLabel(
   LabelItem[] chartLabels
)

Parameters

chartLabels

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


AddLabel(Generic List) Method

AddLabel(Generic List) Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > AddLabel Method : AddLabel(Generic List) Method

labels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddLabel( _
   ByVal labels As List(Of LabelItem) _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
Dim labels As List(Of LabelItem)

instance.AddLabel(labels)
C#
public void AddLabel(
   List<LabelItem> labels
)

Parameters

labels

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


Clear Method

Clear Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class : Clear Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members


GetLabel Method

GetLabel Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class : GetLabel Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLabel( _
   ByVal index As Integer _
) As LabelItem
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
Dim index As Integer
Dim value As LabelItem

value = instance.GetLabel(index)
C#
public LabelItem GetLabel(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members


RemoveAllLabels Method

RemoveAllLabels Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class : RemoveAllLabels Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveAllLabels()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel

instance.RemoveAllLabels()
C#
public void RemoveAllLabels()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members


RemoveLabel Method

RemoveLabel Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class : RemoveLabel Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
RemoveLabel(LabelItem,LabelItem[]) |
RemoveLabel(Int32,Int32[]) |

Overload List

Overload | Description
RemoveLabel(LabelItem,LabelItem[]) |
RemoveLabel(Int32,Int32[]) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members


RemoveLabel(LabelItem,LabelItem[]) Method

RemoveLabel(LabelItem,LabelItem[]) Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > RemoveLabel Method : RemoveLabel(LabelItem,LabelItem[]) Method

Label
chartLabels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub RemoveLabel( _
   ByVal Label As LabelItem, _
   ByVal ParamArray chartLabels() As LabelItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
Dim Label As LabelItem
Dim chartLabels() As LabelItem

instance.RemoveLabel(Label, chartLabels)
C#
public void RemoveLabel(
   LabelItem Label,
   params LabelItem[] chartLabels
)

Parameters

Label
chartLabels

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


RemoveLabel(Int32,Int32[]) Method

RemoveLabel(Int32,Int32[]) Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class > RemoveLabel Method : RemoveLabel(Int32,Int32[]) Method

index
indexes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub RemoveLabel( _
   ByVal index As Integer, _
   ByVal ParamArray indexes() As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
Dim index As Integer
Dim indexes() As Integer

instance.RemoveLabel(index, indexes)
C#
public void RemoveLabel(
   int index,
   params int[] indexes
)

Parameters

index
indexes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members
Overload List


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members


ExtendedLabel Class Properties

ExtendedLabel Class Properties
[image]
Telerik.Reporting.Charting Namespace : ExtendedLabel Class

For a list of all members of this type, see ExtendedLabel members.

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Item |
Public Property | Items |
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


Appearance Property

Appearance Property
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class : Appearance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleExtendedLabel
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
Dim value As StyleExtendedLabel

value = instance.Appearance
C#
public StyleExtendedLabel Appearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members


Item Property

Item Property
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class : Item Property

itemIndex

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Default Property Item( _
   ByVal itemIndex As Integer _
) As LabelItem
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
Dim itemIndex As Integer
Dim value As LabelItem

instance.Item(itemIndex) = value

value = instance.Item(itemIndex)
C#
public virtual LabelItem this[
   int itemIndex
]; {get; set;}

Parameters

itemIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members


Items Property

Items Property
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class : Items Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As ChartLabelsCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
Dim value As ChartLabelsCollection

value = instance.Items
C#
public ChartLabelsCollection Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members


ExtendedLabel Class Fields

ExtendedLabel Class Fields
[image]
Telerik.Reporting.Charting Namespace : ExtendedLabel Class

For a list of all members of this type, see ExtendedLabel members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | extendedLabelItems |
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


extendedLabelItems Field

extendedLabelItems Field
[image]
Telerik.Reporting.Charting Namespace > ExtendedLabel Class : extendedLabelItems Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected extendedLabelItems As ChartLabelsCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLabel
Dim value As ChartLabelsCollection

value = instance.extendedLabelItems

instance.extendedLabelItems = value
C#
protected ChartLabelsCollection extendedLabelItems

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLabel Class
ExtendedLabel Members


GradientElement Class

GradientElement Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : GradientElement Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class GradientElement
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As GradientElement
C#
public class GradientElement : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.GradientElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GradientElement Members
Telerik.Reporting.Charting Namespace


GradientElement Class Members

GradientElement Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : GradientElement Class

The following tables list the members exposed by GradientElement.

Public Constructors

 | Name | Description
Public Constructor | GradientElement Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Color |
Public Property | Position |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | (Inherited from StateManagedObject)
Protected Method | SaveViewState | (Inherited from StateManagedObject)
Protected Method | TrackViewState | (Inherited from StateManagedObject)
Top

See Also

Reference

GradientElement Class
Telerik.Reporting.Charting Namespace


GradientElement Constructor

GradientElement Constructor
[image]
Telerik.Reporting.Charting Namespace > GradientElement Class : GradientElement Constructor

Overload List

Overload | Description
GradientElement Constructor() |
GradientElement Constructor(Color,Single) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GradientElement Class
GradientElement Members


GradientElement Constructor()

GradientElement Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > GradientElement Class > GradientElement Constructor : GradientElement Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GradientElement()
C#
public GradientElement()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GradientElement()
C#
public GradientElement()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GradientElement Class
GradientElement Members
Overload List


GradientElement Constructor(Color,Single)

GradientElement Constructor(Color,Single)
See Also
[image]
Telerik.Reporting.Charting Namespace > GradientElement Class > GradientElement Constructor : GradientElement Constructor(Color,Single)

color
position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal position As Single _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim position As Single

Dim instance As GradientElement(color, position)
C#
public GradientElement(
   Color color,
   float position
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal position As Single _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim position As Single

Dim instance As GradientElement(color, position)
C#
public GradientElement(
   Color color,
   float position
)

Parameters

color
position

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GradientElement Class
GradientElement Members
Overload List


GradientElement Class Methods

GradientElement Class Methods
[image]
Telerik.Reporting.Charting Namespace : GradientElement Class

For a list of all members of this type, see GradientElement members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | (Inherited from StateManagedObject)
Protected Method | SaveViewState | (Inherited from StateManagedObject)
Protected Method | TrackViewState | (Inherited from StateManagedObject)
Top

See Also

Reference

GradientElement Class
Telerik.Reporting.Charting Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting Namespace > GradientElement Class : Clone Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As GradientElement
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GradientElement Class
GradientElement Members


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting Namespace > GradientElement Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GradientElement
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GradientElement Class
GradientElement Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting Namespace > GradientElement Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As GradientElement
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GradientElement Class
GradientElement Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Charting Namespace > GradientElement Class : ToString Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As GradientElement
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GradientElement Class
GradientElement Members


GradientElement Class Properties

GradientElement Class Properties
[image]
Telerik.Reporting.Charting Namespace : GradientElement Class

For a list of all members of this type, see GradientElement members.

Public Properties

 | Name | Description
Public Property | Color |
Public Property | Position |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

GradientElement Class
Telerik.Reporting.Charting Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting Namespace > GradientElement Class : Color Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As GradientElement
Dim value As Color

instance.Color = value

value = instance.Color
C#
public Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GradientElement Class
GradientElement Members


Position Property

Position Property
[image]
Telerik.Reporting.Charting Namespace > GradientElement Class : Position Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Position As Single
Visual Basic (Usage) Copy Code
Dim instance As GradientElement
Dim value As Single

instance.Position = value

value = instance.Position
C#
public float Position {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GradientElement Class
GradientElement Members


LabelItem Class

LabelItem Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : LabelItem Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class LabelItem
   Inherits ChartLabel
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As LabelItem
C#
public class LabelItem : ChartLabel, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ChartLabel
Telerik.Reporting.Charting.LabelItem
Telerik.Reporting.Charting.BindableLegendItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelItem Members
Telerik.Reporting.Charting Namespace


LabelItem Class Members

LabelItem Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : LabelItem Class

The following tables list the members exposed by LabelItem.

Public Constructors

 | Name | Description
Public Constructor | LabelItem Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | Name |
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

LabelItem Class
Telerik.Reporting.Charting Namespace


LabelItem Constructor

LabelItem Constructor
[image]
Telerik.Reporting.Charting Namespace > LabelItem Class : LabelItem Constructor

Overload List

Overload | Description
LabelItem Constructor() |
LabelItem Constructor(Object) |
LabelItem Constructor(Object,StyleLabel,TextBlockLabelItem,String) |
LabelItem Constructor(String) |
LabelItem Constructor(StyleLabel) |
LabelItem Constructor(StyleLabel,Object) |
LabelItem Constructor(StyleLabel,String) |
LabelItem Constructor(StyleLabel,TextBlockLabelItem) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelItem Class
LabelItem Members


LabelItem Constructor()

LabelItem Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > LabelItem Class > LabelItem Constructor : LabelItem Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LabelItem()
C#
public LabelItem()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LabelItem()
C#
public LabelItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelItem Class
LabelItem Members
Overload List


LabelItem Constructor(Object)

LabelItem Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > LabelItem Class > LabelItem Constructor : LabelItem Constructor(Object)

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As LabelItem(parent)
C#
public LabelItem(
   object parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Object

Dim instance As LabelItem(parent)
C#
public LabelItem(
   object parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelItem Class
LabelItem Members
Overload List


LabelItem Constructor(Object,StyleLabel,TextBlockLabelItem,String)

LabelItem Constructor(Object,StyleLabel,TextBlockLabelItem,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > LabelItem Class > LabelItem Constructor : LabelItem Constructor(Object,StyleLabel,TextBlockLabelItem,String)

parent
appearance
textBlock
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal appearance As StyleLabel, _
   ByVal textBlock As TextBlockLabelItem, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim appearance As StyleLabel
Dim textBlock As TextBlockLabelItem
Dim text As String

Dim instance As LabelItem(parent, appearance, textBlock, text)
C#
public LabelItem(
   object parent,
   StyleLabel appearance,
   TextBlockLabelItem textBlock,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Object, _
   ByVal appearance As StyleLabel, _
   ByVal textBlock As TextBlockLabelItem, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As Object
Dim appearance As StyleLabel
Dim textBlock As TextBlockLabelItem
Dim text As String

Dim instance As LabelItem(parent, appearance, textBlock, text)
C#
public LabelItem(
   object parent,
   StyleLabel appearance,
   TextBlockLabelItem textBlock,
   string text
)

Parameters

parent
appearance
textBlock
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelItem Class
LabelItem Members
Overload List


LabelItem Constructor(String)

LabelItem Constructor(String)
See Also
[image]
Telerik.Reporting.Charting Namespace > LabelItem Class > LabelItem Constructor : LabelItem Constructor(String)

text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As LabelItem(text)
C#
public LabelItem(
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As LabelItem(text)
C#
public LabelItem(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelItem Class
LabelItem Members
Overload List


LabelItem Constructor(StyleLabel)

LabelItem Constructor(StyleLabel)
See Also
[image]
Telerik.Reporting.Charting Namespace > LabelItem Class > LabelItem Constructor : LabelItem Constructor(StyleLabel)

appearance

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel

Dim instance As LabelItem(appearance)
C#
public LabelItem(
   StyleLabel appearance
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel

Dim instance As LabelItem(appearance)
C#
public LabelItem(
   StyleLabel appearance
)

Parameters

appearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelItem Class
LabelItem Members
Overload List


LabelItem Constructor(StyleLabel,Object)

LabelItem Constructor(StyleLabel,Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > LabelItem Class > LabelItem Constructor : LabelItem Constructor(StyleLabel,Object)

appearance
parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim parent As Object

Dim instance As LabelItem(appearance, parent)
C#
public LabelItem(
   StyleLabel appearance,
   object parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim parent As Object

Dim instance As LabelItem(appearance, parent)
C#
public LabelItem(
   StyleLabel appearance,
   object parent
)

Parameters

appearance
parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelItem Class
LabelItem Members
Overload List


LabelItem Constructor(StyleLabel,String)

LabelItem Constructor(StyleLabel,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > LabelItem Class > LabelItem Constructor : LabelItem Constructor(StyleLabel,String)

appearance
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim text As String

Dim instance As LabelItem(appearance, text)
C#
public LabelItem(
   StyleLabel appearance,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim text As String

Dim instance As LabelItem(appearance, text)
C#
public LabelItem(
   StyleLabel appearance,
   string text
)

Parameters

appearance
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelItem Class
LabelItem Members
Overload List


LabelItem Constructor(StyleLabel,TextBlockLabelItem)

LabelItem Constructor(StyleLabel,TextBlockLabelItem)
See Also
[image]
Telerik.Reporting.Charting Namespace > LabelItem Class > LabelItem Constructor : LabelItem Constructor(StyleLabel,TextBlockLabelItem)

appearance
textBlock

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal textBlock As TextBlockLabelItem _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim textBlock As TextBlockLabelItem

Dim instance As LabelItem(appearance, textBlock)
C#
public LabelItem(
   StyleLabel appearance,
   TextBlockLabelItem textBlock
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal textBlock As TextBlockLabelItem _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim textBlock As TextBlockLabelItem

Dim instance As LabelItem(appearance, textBlock)
C#
public LabelItem(
   StyleLabel appearance,
   TextBlockLabelItem textBlock
)

Parameters

appearance
textBlock

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelItem Class
LabelItem Members
Overload List


LabelItem Class Properties

LabelItem Class Properties
[image]
Telerik.Reporting.Charting Namespace : LabelItem Class

For a list of all members of this type, see LabelItem members.

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | Name |
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

LabelItem Class
Telerik.Reporting.Charting Namespace


Name Property

Name Property
[image]
Telerik.Reporting.Charting Namespace > LabelItem Class : Name Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As LabelItem
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelItem Class
LabelItem Members


LayoutElement Class

LayoutElement Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : LayoutElement Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class LayoutElement
   Inherits RenderedObject
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As LayoutElement
C#
public abstract class LayoutElement : RenderedObject, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.Chart
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ChartDataTable
Telerik.Reporting.Charting.ChartMarker
Telerik.Reporting.Charting.ChartPlotArea
Telerik.Reporting.Charting.TextBlock

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutElement Members
Telerik.Reporting.Charting Namespace


LayoutElement Class Members

LayoutElement Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : LayoutElement Class

The following tables list the members exposed by LayoutElement.

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from RenderedObject)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | GetOffsetBottom |
Protected Method | GetOffsetLeft |
Protected Method | GetOffsetRight |
Protected Method | GetOffsetTop |
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

LayoutElement Class
Telerik.Reporting.Charting Namespace


LayoutElement Class Methods

LayoutElement Class Methods
[image]
Telerik.Reporting.Charting Namespace : LayoutElement Class

For a list of all members of this type, see LayoutElement members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | GetOffsetBottom |
Protected Method | GetOffsetLeft |
Protected Method | GetOffsetRight |
Protected Method | GetOffsetTop |
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

LayoutElement Class
Telerik.Reporting.Charting Namespace


GetOffsetBottom Method

GetOffsetBottom Method
[image]
Telerik.Reporting.Charting Namespace > LayoutElement Class : GetOffsetBottom Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetOffsetBottom( _
   ByVal element As Object _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As LayoutElement
Dim element As Object
Dim value As Single

value = instance.GetOffsetBottom(element)
C#
protected float GetOffsetBottom(
   object element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutElement Class
LayoutElement Members


GetOffsetLeft Method

GetOffsetLeft Method
[image]
Telerik.Reporting.Charting Namespace > LayoutElement Class : GetOffsetLeft Method

oelement

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetOffsetLeft( _
   ByVal oelement As Object _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As LayoutElement
Dim oelement As Object
Dim value As Single

value = instance.GetOffsetLeft(oelement)
C#
protected float GetOffsetLeft(
   object oelement
)

Parameters

oelement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutElement Class
LayoutElement Members


GetOffsetRight Method

GetOffsetRight Method
[image]
Telerik.Reporting.Charting Namespace > LayoutElement Class : GetOffsetRight Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetOffsetRight( _
   ByVal element As Object _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As LayoutElement
Dim element As Object
Dim value As Single

value = instance.GetOffsetRight(element)
C#
protected float GetOffsetRight(
   object element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutElement Class
LayoutElement Members


GetOffsetTop Method

GetOffsetTop Method
[image]
Telerik.Reporting.Charting Namespace > LayoutElement Class : GetOffsetTop Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetOffsetTop( _
   ByVal element As Object _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As LayoutElement
Dim element As Object
Dim value As Single

value = instance.GetOffsetTop(element)
C#
protected float GetOffsetTop(
   object element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutElement Class
LayoutElement Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > LayoutElement Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutElement
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutElement Class
LayoutElement Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > LayoutElement Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As LayoutElement
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutElement Class
LayoutElement Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > LayoutElement Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As LayoutElement

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutElement Class
LayoutElement Members


MarkedZoneLabel Class

MarkedZoneLabel Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : MarkedZoneLabel Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class MarkedZoneLabel
   Inherits ChartLabel
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As MarkedZoneLabel
C#
public class MarkedZoneLabel : ChartLabel, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ChartLabel
Telerik.Reporting.Charting.MarkedZoneLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarkedZoneLabel Members
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Class Members

MarkedZoneLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : MarkedZoneLabel Class

The following tables list the members exposed by MarkedZoneLabel.

Public Constructors

 | Name | Description
Public Constructor | MarkedZoneLabel Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

MarkedZoneLabel Class
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Constructor

MarkedZoneLabel Constructor
[image]
Telerik.Reporting.Charting Namespace > MarkedZoneLabel Class : MarkedZoneLabel Constructor

Overload List

Overload | Description
MarkedZoneLabel Constructor() |
MarkedZoneLabel Constructor(Chart,IContainer) |
MarkedZoneLabel Constructor(StyleLabel) |
MarkedZoneLabel Constructor(StyleLabel,Object) |
MarkedZoneLabel Constructor(StyleLabel,String) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarkedZoneLabel Class
MarkedZoneLabel Members


MarkedZoneLabel Constructor()

MarkedZoneLabel Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > MarkedZoneLabel Class > MarkedZoneLabel Constructor : MarkedZoneLabel Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MarkedZoneLabel()
C#
public MarkedZoneLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MarkedZoneLabel()
C#
public MarkedZoneLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarkedZoneLabel Class
MarkedZoneLabel Members
Overload List


MarkedZoneLabel Constructor(Chart,IContainer)

MarkedZoneLabel Constructor(Chart,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > MarkedZoneLabel Class > MarkedZoneLabel Constructor : MarkedZoneLabel Constructor(Chart,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart
Dim container As IContainer

Dim instance As MarkedZoneLabel(parent, container)
C#
public MarkedZoneLabel(
   Chart parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart
Dim container As IContainer

Dim instance As MarkedZoneLabel(parent, container)
C#
public MarkedZoneLabel(
   Chart parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarkedZoneLabel Class
MarkedZoneLabel Members
Overload List


MarkedZoneLabel Constructor(StyleLabel)

MarkedZoneLabel Constructor(StyleLabel)
See Also
[image]
Telerik.Reporting.Charting Namespace > MarkedZoneLabel Class > MarkedZoneLabel Constructor : MarkedZoneLabel Constructor(StyleLabel)

appearance

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel

Dim instance As MarkedZoneLabel(appearance)
C#
public MarkedZoneLabel(
   StyleLabel appearance
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel

Dim instance As MarkedZoneLabel(appearance)
C#
public MarkedZoneLabel(
   StyleLabel appearance
)

Parameters

appearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarkedZoneLabel Class
MarkedZoneLabel Members
Overload List


MarkedZoneLabel Constructor(StyleLabel,Object)

MarkedZoneLabel Constructor(StyleLabel,Object)
See Also
[image]
Telerik.Reporting.Charting Namespace > MarkedZoneLabel Class > MarkedZoneLabel Constructor : MarkedZoneLabel Constructor(StyleLabel,Object)

appearance
parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim parent As Object

Dim instance As MarkedZoneLabel(appearance, parent)
C#
public MarkedZoneLabel(
   StyleLabel appearance,
   object parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim parent As Object

Dim instance As MarkedZoneLabel(appearance, parent)
C#
public MarkedZoneLabel(
   StyleLabel appearance,
   object parent
)

Parameters

appearance
parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarkedZoneLabel Class
MarkedZoneLabel Members
Overload List


MarkedZoneLabel Constructor(StyleLabel,String)

MarkedZoneLabel Constructor(StyleLabel,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > MarkedZoneLabel Class > MarkedZoneLabel Constructor : MarkedZoneLabel Constructor(StyleLabel,String)

appearance
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim text As String

Dim instance As MarkedZoneLabel(appearance, text)
C#
public MarkedZoneLabel(
   StyleLabel appearance,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleLabel, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleLabel
Dim text As String

Dim instance As MarkedZoneLabel(appearance, text)
C#
public MarkedZoneLabel(
   StyleLabel appearance,
   string text
)

Parameters

appearance
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarkedZoneLabel Class
MarkedZoneLabel Members
Overload List


Palette Class

Palette Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : Palette Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Palette
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As Palette
C#
public class Palette : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Palette

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Members
Telerik.Reporting.Charting Namespace


Palette Class Members

Palette Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : Palette Class

The following tables list the members exposed by Palette.

Public Constructors

 | Name | Description
Public Constructor | Palette Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Item |
Public Property | Items |
Public Property | Name |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

Palette Class
Telerik.Reporting.Charting Namespace


Palette Constructor

Palette Constructor
[image]
Telerik.Reporting.Charting Namespace > Palette Class : Palette Constructor

Overload List

Overload | Description
Palette Constructor() |
Palette Constructor(String) |
Palette Constructor(String,Color[],Boolean) |
Palette Constructor(String,Color[],Color[]) |
Palette Constructor(String,ColorBlend[]) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members


Palette Constructor()

Palette Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > Palette Class > Palette Constructor : Palette Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Palette()
C#
public Palette()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Palette()
C#
public Palette()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members
Overload List


Palette Constructor(String)

Palette Constructor(String)
See Also
[image]
Telerik.Reporting.Charting Namespace > Palette Class > Palette Constructor : Palette Constructor(String)

name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As Palette(name)
C#
public Palette(
   string name
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As Palette(name)
C#
public Palette(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members
Overload List


Palette Constructor(String,Color[],Boolean)

Palette Constructor(String,Color[],Boolean)
See Also
[image]
Telerik.Reporting.Charting Namespace > Palette Class > Palette Constructor : Palette Constructor(String,Color[],Boolean)

name
colors
twoColors

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal colors() As Color, _
   ByVal twoColors As Boolean _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim colors() As Color
Dim twoColors As Boolean

Dim instance As Palette(name, colors, twoColors)
C#
public Palette(
   string name,
   Color[] colors,
   bool twoColors
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal colors() As Color, _
   ByVal twoColors As Boolean _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim colors() As Color
Dim twoColors As Boolean

Dim instance As Palette(name, colors, twoColors)
C#
public Palette(
   string name,
   Color[] colors,
   bool twoColors
)

Parameters

name
colors
twoColors

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members
Overload List


Palette Constructor(String,Color[],Color[])

Palette Constructor(String,Color[],Color[])
See Also
[image]
Telerik.Reporting.Charting Namespace > Palette Class > Palette Constructor : Palette Constructor(String,Color[],Color[])

name
mainColors
secondColors

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal mainColors() As Color, _
   ByVal secondColors() As Color _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim mainColors() As Color
Dim secondColors() As Color

Dim instance As Palette(name, mainColors, secondColors)
C#
public Palette(
   string name,
   Color[] mainColors,
   Color[] secondColors
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal mainColors() As Color, _
   ByVal secondColors() As Color _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim mainColors() As Color
Dim secondColors() As Color

Dim instance As Palette(name, mainColors, secondColors)
C#
public Palette(
   string name,
   Color[] mainColors,
   Color[] secondColors
)

Parameters

name
mainColors
secondColors

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members
Overload List


Palette Constructor(String,ColorBlend[])

Palette Constructor(String,ColorBlend[])
See Also
[image]
Telerik.Reporting.Charting Namespace > Palette Class > Palette Constructor : Palette Constructor(String,ColorBlend[])

name
addtionalColors

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal addtionalColors() As ColorBlend _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim addtionalColors() As ColorBlend

Dim instance As Palette(name, addtionalColors)
C#
public Palette(
   string name,
   ColorBlend[] addtionalColors
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal addtionalColors() As ColorBlend _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim addtionalColors() As ColorBlend

Dim instance As Palette(name, addtionalColors)
C#
public Palette(
   string name,
   ColorBlend[] addtionalColors
)

Parameters

name
addtionalColors

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members
Overload List


Palette Class Methods

Palette Class Methods
[image]
Telerik.Reporting.Charting Namespace : Palette Class

For a list of all members of this type, see Palette members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

Palette Class
Telerik.Reporting.Charting Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting Namespace > Palette Class : Clone Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As Palette
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > Palette Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Palette
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > Palette Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As Palette
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Charting Namespace > Palette Class : ToString Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Palette
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > Palette Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As Palette

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members


Palette Class Properties

Palette Class Properties
[image]
Telerik.Reporting.Charting Namespace : Palette Class

For a list of all members of this type, see Palette members.

Public Properties

 | Name | Description
Public Property | Item |
Public Property | Items |
Public Property | Name |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

Palette Class
Telerik.Reporting.Charting Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Charting Namespace > Palette Class : Item Property

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As PaletteItem
Visual Basic (Usage) Copy Code
Dim instance As Palette
Dim index As Integer
Dim value As PaletteItem

instance.Item(index) = value

value = instance.Item(index)
C#
public PaletteItem this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members


Items Property

Items Property
[image]
Telerik.Reporting.Charting Namespace > Palette Class : Items Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As PaletteItemsCollection
Visual Basic (Usage) Copy Code
Dim instance As Palette
Dim value As PaletteItemsCollection

value = instance.Items
C#
public PaletteItemsCollection Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members


Name Property

Name Property
[image]
Telerik.Reporting.Charting Namespace > Palette Class : Name Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Palette
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Palette Class
Palette Members


PaletteItem Class

PaletteItem Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : PaletteItem Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PaletteItem
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As PaletteItem
C#
public class PaletteItem : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.PaletteItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Members
Telerik.Reporting.Charting Namespace


PaletteItem Class Members

PaletteItem Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : PaletteItem Class

The following tables list the members exposed by PaletteItem.

Public Constructors

 | Name | Description
Public Constructor | PaletteItem Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AdditionalColors |
Public Property | MainColor |
Public Property | Name |
Public Property | SecondColor |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

PaletteItem Class
Telerik.Reporting.Charting Namespace


PaletteItem Constructor

PaletteItem Constructor
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class : PaletteItem Constructor

Overload List

Overload | Description
PaletteItem Constructor() |
PaletteItem Constructor(Color,Color) |
PaletteItem Constructor(ColorBlend) |
PaletteItem Constructor(String,Color,Color) |
PaletteItem Constructor(String,ColorBlend) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members


PaletteItem Constructor()

PaletteItem Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class > PaletteItem Constructor : PaletteItem Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PaletteItem()
C#
public PaletteItem()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PaletteItem()
C#
public PaletteItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members
Overload List


PaletteItem Constructor(Color,Color)

PaletteItem Constructor(Color,Color)
See Also
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class > PaletteItem Constructor : PaletteItem Constructor(Color,Color)

mainColor
secondColor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mainColor As Color, _
   ByVal secondColor As Color _
)
Visual Basic (Usage) Copy Code
Dim mainColor As Color
Dim secondColor As Color

Dim instance As PaletteItem(mainColor, secondColor)
C#
public PaletteItem(
   Color mainColor,
   Color secondColor
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mainColor As Color, _
   ByVal secondColor As Color _
)
Visual Basic (Usage) Copy Code
Dim mainColor As Color
Dim secondColor As Color

Dim instance As PaletteItem(mainColor, secondColor)
C#
public PaletteItem(
   Color mainColor,
   Color secondColor
)

Parameters

mainColor
secondColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members
Overload List


PaletteItem Constructor(ColorBlend)

PaletteItem Constructor(ColorBlend)
See Also
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class > PaletteItem Constructor : PaletteItem Constructor(ColorBlend)

additionalColors

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal additionalColors As ColorBlend _
)
Visual Basic (Usage) Copy Code
Dim additionalColors As ColorBlend

Dim instance As PaletteItem(additionalColors)
C#
public PaletteItem(
   ColorBlend additionalColors
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal additionalColors As ColorBlend _
)
Visual Basic (Usage) Copy Code
Dim additionalColors As ColorBlend

Dim instance As PaletteItem(additionalColors)
C#
public PaletteItem(
   ColorBlend additionalColors
)

Parameters

additionalColors

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members
Overload List


PaletteItem Constructor(String,Color,Color)

PaletteItem Constructor(String,Color,Color)
See Also
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class > PaletteItem Constructor : PaletteItem Constructor(String,Color,Color)

name
mainColor
secondColor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal mainColor As Color, _
   ByVal secondColor As Color _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim mainColor As Color
Dim secondColor As Color

Dim instance As PaletteItem(name, mainColor, secondColor)
C#
public PaletteItem(
   string name,
   Color mainColor,
   Color secondColor
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal mainColor As Color, _
   ByVal secondColor As Color _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim mainColor As Color
Dim secondColor As Color

Dim instance As PaletteItem(name, mainColor, secondColor)
C#
public PaletteItem(
   string name,
   Color mainColor,
   Color secondColor
)

Parameters

name
mainColor
secondColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members
Overload List


PaletteItem Constructor(String,ColorBlend)

PaletteItem Constructor(String,ColorBlend)
See Also
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class > PaletteItem Constructor : PaletteItem Constructor(String,ColorBlend)

name
additionalColors

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal additionalColors As ColorBlend _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim additionalColors As ColorBlend

Dim instance As PaletteItem(name, additionalColors)
C#
public PaletteItem(
   string name,
   ColorBlend additionalColors
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal additionalColors As ColorBlend _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim additionalColors As ColorBlend

Dim instance As PaletteItem(name, additionalColors)
C#
public PaletteItem(
   string name,
   ColorBlend additionalColors
)

Parameters

name
additionalColors

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members
Overload List


PaletteItem Class Methods

PaletteItem Class Methods
[image]
Telerik.Reporting.Charting Namespace : PaletteItem Class

For a list of all members of this type, see PaletteItem members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

PaletteItem Class
Telerik.Reporting.Charting Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class : Clone Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PaletteItem
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As PaletteItem
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As PaletteItem
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class : ToString Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PaletteItem
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As PaletteItem

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members


PaletteItem Class Properties

PaletteItem Class Properties
[image]
Telerik.Reporting.Charting Namespace : PaletteItem Class

For a list of all members of this type, see PaletteItem members.

Public Properties

 | Name | Description
Public Property | AdditionalColors |
Public Property | MainColor |
Public Property | Name |
Public Property | SecondColor |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

PaletteItem Class
Telerik.Reporting.Charting Namespace


AdditionalColors Property

AdditionalColors Property
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class : AdditionalColors Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AdditionalColors As ColorBlend
Visual Basic (Usage) Copy Code
Dim instance As PaletteItem
Dim value As ColorBlend

value = instance.AdditionalColors
C#
public ColorBlend AdditionalColors {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members


MainColor Property

MainColor Property
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class : MainColor Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property MainColor As Color
Visual Basic (Usage) Copy Code
Dim instance As PaletteItem
Dim value As Color

instance.MainColor = value

value = instance.MainColor
C#
public Color MainColor {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members


Name Property

Name Property
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class : Name Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PaletteItem
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members


SecondColor Property

SecondColor Property
[image]
Telerik.Reporting.Charting Namespace > PaletteItem Class : SecondColor Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property SecondColor As Color
Visual Basic (Usage) Copy Code
Dim instance As PaletteItem
Dim value As Color

instance.SecondColor = value

value = instance.SecondColor
C#
public Color SecondColor {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItem Class
PaletteItem Members


PaletteItemsCollection Class

PaletteItemsCollection Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : PaletteItemsCollection Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PaletteItemsCollection
   Inherits ChartingStateManagedCollection(Of PaletteItem)
   Implements IChartingStateManager, IDeserializableCollection
Visual Basic (Usage) Copy Code
Dim instance As PaletteItemsCollection
C#
public class PaletteItemsCollection : ChartingStateManagedCollection<PaletteItem>, IChartingStateManager, IDeserializableCollection

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>
Telerik.Reporting.Charting.PaletteItemsCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItemsCollection Members
Telerik.Reporting.Charting Namespace


PaletteItemsCollection Class Members

PaletteItemsCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : PaletteItemsCollection Class

The following tables list the members exposed by PaletteItemsCollection.

Public Constructors

 | Name | Description
Public Constructor | PaletteItemsCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Property | Item | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | GetItem |
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | Remove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Top

See Also

Reference

PaletteItemsCollection Class
Telerik.Reporting.Charting Namespace


PaletteItemsCollection Constructor

PaletteItemsCollection Constructor
[image]
Telerik.Reporting.Charting Namespace > PaletteItemsCollection Class : PaletteItemsCollection Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PaletteItemsCollection()
C#
public PaletteItemsCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PaletteItemsCollection()
C#
public PaletteItemsCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItemsCollection Class
PaletteItemsCollection Members


PaletteItemsCollection Class Methods

PaletteItemsCollection Class Methods
[image]
Telerik.Reporting.Charting Namespace : PaletteItemsCollection Class

For a list of all members of this type, see PaletteItemsCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | GetItem |
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | Remove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Top

See Also

Reference

PaletteItemsCollection Class
Telerik.Reporting.Charting Namespace


GetItem Method

GetItem Method
[image]
Telerik.Reporting.Charting Namespace > PaletteItemsCollection Class : GetItem Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetItem( _
   ByVal index As Integer _
) As PaletteItem
Visual Basic (Usage) Copy Code
Dim instance As PaletteItemsCollection
Dim index As Integer
Dim value As PaletteItem

value = instance.GetItem(index)
C#
public PaletteItem GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PaletteItemsCollection Class
PaletteItemsCollection Members


Product Class

Product Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : Product Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Product
Visual Basic (Usage) Copy Code
Dim instance As Product
C#
public class Product

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.Product

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product Members
Telerik.Reporting.Charting Namespace


Product Class Members

Product Class Members
See Also Properties
[image]
Telerik.Reporting.Charting Namespace : Product Class

The following tables list the members exposed by Product.

Public Constructors

 | Name | Description
Public Constructor | Product Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Amount |
Public Property | ID |
Public Property | Name |
Top

See Also

Reference

Product Class
Telerik.Reporting.Charting Namespace


Product Constructor

Product Constructor
[image]
Telerik.Reporting.Charting Namespace > Product Class : Product Constructor

Overload List

Overload | Description
Product Constructor(Int32) |
Product Constructor(Int32,String,Int32) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product Class
Product Members


Product Constructor(Int32)

Product Constructor(Int32)
See Also
[image]
Telerik.Reporting.Charting Namespace > Product Class > Product Constructor : Product Constructor(Int32)

idIn

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal idIn As Integer _
)
Visual Basic (Usage) Copy Code
Dim idIn As Integer

Dim instance As Product(idIn)
C#
public Product(
   int idIn
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal idIn As Integer _
)
Visual Basic (Usage) Copy Code
Dim idIn As Integer

Dim instance As Product(idIn)
C#
public Product(
   int idIn
)

Parameters

idIn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product Class
Product Members
Overload List


Product Constructor(Int32,String,Int32)

Product Constructor(Int32,String,Int32)
See Also
[image]
Telerik.Reporting.Charting Namespace > Product Class > Product Constructor : Product Constructor(Int32,String,Int32)

idIn
name
val

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal idIn As Integer, _
   ByVal name As String, _
   ByVal val As Integer _
)
Visual Basic (Usage) Copy Code
Dim idIn As Integer
Dim name As String
Dim val As Integer

Dim instance As Product(idIn, name, val)
C#
public Product(
   int idIn,
   string name,
   int val
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal idIn As Integer, _
   ByVal name As String, _
   ByVal val As Integer _
)
Visual Basic (Usage) Copy Code
Dim idIn As Integer
Dim name As String
Dim val As Integer

Dim instance As Product(idIn, name, val)
C#
public Product(
   int idIn,
   string name,
   int val
)

Parameters

idIn
name
val

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product Class
Product Members
Overload List


Product Class Properties

Product Class Properties
[image]
Telerik.Reporting.Charting Namespace : Product Class

For a list of all members of this type, see Product members.

Public Properties

 | Name | Description
Public Property | Amount |
Public Property | ID |
Public Property | Name |
Top

See Also

Reference

Product Class
Telerik.Reporting.Charting Namespace


Amount Property

Amount Property
[image]
Telerik.Reporting.Charting Namespace > Product Class : Amount Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Amount As Integer
Visual Basic (Usage) Copy Code
Dim instance As Product
Dim value As Integer

instance.Amount = value

value = instance.Amount
C#
public int Amount {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product Class
Product Members


ID Property

ID Property
[image]
Telerik.Reporting.Charting Namespace > Product Class : ID Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As Integer
Visual Basic (Usage) Copy Code
Dim instance As Product
Dim value As Integer

instance.ID = value

value = instance.ID
C#
public int ID {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product Class
Product Members


Name Property

Name Property
[image]
Telerik.Reporting.Charting Namespace > Product Class : Name Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Product
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Product Class
Product Members


ProductsBL Class

ProductsBL Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ProductsBL Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ProductsBL
Visual Basic (Usage) Copy Code
Dim instance As ProductsBL
C#
public class ProductsBL

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.ProductsBL

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsBL Members
Telerik.Reporting.Charting Namespace


ProductsBL Class Members

ProductsBL Class Members
See Also Methods
[image]
Telerik.Reporting.Charting Namespace : ProductsBL Class

The following tables list the members exposed by ProductsBL.

Public Constructors

 | Name | Description
Public Constructor | ProductsBL Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetProductsList |
Top

See Also

Reference

ProductsBL Class
Telerik.Reporting.Charting Namespace


ProductsBL Constructor

ProductsBL Constructor
[image]
Telerik.Reporting.Charting Namespace > ProductsBL Class : ProductsBL Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ProductsBL()
C#
public ProductsBL()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ProductsBL()
C#
public ProductsBL()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsBL Class
ProductsBL Members


ProductsBL Class Methods

ProductsBL Class Methods
[image]
Telerik.Reporting.Charting Namespace : ProductsBL Class

For a list of all members of this type, see ProductsBL members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetProductsList |
Top

See Also

Reference

ProductsBL Class
Telerik.Reporting.Charting Namespace


GetProductsList Method

GetProductsList Method
[image]
Telerik.Reporting.Charting Namespace > ProductsBL Class : GetProductsList Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetProductsList() As List(Of Product)
Visual Basic (Usage) Copy Code
Dim value As List(Of Product)

value = ProductsBL.GetProductsList()
C#
public static List<Product> GetProductsList()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsBL Class
ProductsBL Members


ProductsList Class

ProductsList Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ProductsList Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ProductsList
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ProductsList
C#
public class ProductsList : CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.Reporting.Charting.ProductsList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Members
Telerik.Reporting.Charting Namespace


ProductsList Class Members

ProductsList Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting.Charting Namespace : ProductsList Class

The following tables list the members exposed by ProductsList.

Public Constructors

 | Name | Description
Public Constructor | ProductsList Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item |
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | AddNew |
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | LoadProducts |
Public Method | Remove |
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | Overridden.
Protected Method | OnClearComplete | Overridden.
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | Overridden.
Protected Method | OnListChanged |
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | Overridden.
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | Overridden.
Protected Method | OnValidate | (Inherited from System.Collections.CollectionBase)
Top

Public Events

 | Name | Description
Public Event | ListChanged |
Top

See Also

Reference

ProductsList Class
Telerik.Reporting.Charting Namespace


ProductsList Constructor

ProductsList Constructor
[image]
Telerik.Reporting.Charting Namespace > ProductsList Class : ProductsList Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ProductsList()
C#
public ProductsList()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ProductsList()
C#
public ProductsList()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Class
ProductsList Members


ProductsList Class Methods

ProductsList Class Methods
[image]
Telerik.Reporting.Charting Namespace : ProductsList Class

For a list of all members of this type, see ProductsList members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | AddNew |
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | LoadProducts |
Public Method | Remove |
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | Overridden.
Protected Method | OnClearComplete | Overridden.
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | Overridden.
Protected Method | OnListChanged |
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | Overridden.
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | Overridden.
Protected Method | OnValidate | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

ProductsList Class
Telerik.Reporting.Charting Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting Namespace > ProductsList Class : Add Method

value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As Product _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ProductsList
Dim value As Product
Dim value As Integer

value = instance.Add(value)
C#
public int Add(
   Product value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Class
ProductsList Members


AddNew Method

AddNew Method
[image]
Telerik.Reporting.Charting Namespace > ProductsList Class : AddNew Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function AddNew() As Product
Visual Basic (Usage) Copy Code
Dim instance As ProductsList
Dim value As Product

value = instance.AddNew()
C#
public Product AddNew()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Class
ProductsList Members


LoadProducts Method

LoadProducts Method
[image]
Telerik.Reporting.Charting Namespace > ProductsList Class : LoadProducts Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadProducts()
Visual Basic (Usage) Copy Code
Dim instance As ProductsList

instance.LoadProducts()
C#
public void LoadProducts()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Class
ProductsList Members


OnClear Method

OnClear Method
[image]
Telerik.Reporting.Charting Namespace > ProductsList Class : OnClear Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnClear()
Visual Basic (Usage) Copy Code
Dim instance As ProductsList

instance.OnClear()
C#
protected override void OnClear()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Class
ProductsList Members


OnClearComplete Method

OnClearComplete Method
[image]
Telerik.Reporting.Charting Namespace > ProductsList Class : OnClearComplete Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnClearComplete()
Visual Basic (Usage) Copy Code
Dim instance As ProductsList

instance.OnClearComplete()
C#
protected override void OnClearComplete()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Class
ProductsList Members


OnInsertComplete Method

OnInsertComplete Method
[image]
Telerik.Reporting.Charting Namespace > ProductsList Class : OnInsertComplete Method

index
value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnInsertComplete( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ProductsList
Dim index As Integer
Dim value As Object

instance.OnInsertComplete(index, value)
C#
protected override void OnInsertComplete(
   int index,
   object value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Class
ProductsList Members


OnListChanged Method

OnListChanged Method
[image]
Telerik.Reporting.Charting Namespace > ProductsList Class : OnListChanged Method

ev

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnListChanged( _
   ByVal ev As ListChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ProductsList
Dim ev As ListChangedEventArgs

instance.OnListChanged(ev)
C#
protected virtual void OnListChanged(
   ListChangedEventArgs ev
)

Parameters

ev

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Class
ProductsList Members


OnRemoveComplete Method

OnRemoveComplete Method
[image]
Telerik.Reporting.Charting Namespace > ProductsList Class : OnRemoveComplete Method

index
value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnRemoveComplete( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ProductsList
Dim index As Integer
Dim value As Object

instance.OnRemoveComplete(index, value)
C#
protected override void OnRemoveComplete(
   int index,
   object value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Class
ProductsList Members


OnSetComplete Method

OnSetComplete Method
[image]
Telerik.Reporting.Charting Namespace > ProductsList Class : OnSetComplete Method

index
oldValue
newValue

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnSetComplete( _
   ByVal index As Integer, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ProductsList
Dim index As Integer
Dim oldValue As Object
Dim newValue As Object

instance.OnSetComplete(index, oldValue, newValue)
C#
protected override void OnSetComplete(
   int index,
   object oldValue,
   object newValue
)

Parameters

index
oldValue
newValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Class
ProductsList Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Charting Namespace > ProductsList Class : Remove Method

value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Product _
)
Visual Basic (Usage) Copy Code
Dim instance As ProductsList
Dim value As Product

instance.Remove(value)
C#
public void Remove(
   Product value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Class
ProductsList Members


ProductsList Class Properties

ProductsList Class Properties
[image]
Telerik.Reporting.Charting Namespace : ProductsList Class

For a list of all members of this type, see ProductsList members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item |
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

ProductsList Class
Telerik.Reporting.Charting Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Charting Namespace > ProductsList Class : Item Property

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Product
Visual Basic (Usage) Copy Code
Dim instance As ProductsList
Dim index As Integer
Dim value As Product

instance.Item(index) = value

value = instance.Item(index)
C#
public Product this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Class
ProductsList Members


ProductsList Class Events

ProductsList Class Events
[image]
Telerik.Reporting.Charting Namespace : ProductsList Class

For a list of all members of this type, see ProductsList members.

Public Events

 | Name | Description
Public Event | ListChanged |
Top

See Also

Reference

ProductsList Class
Telerik.Reporting.Charting Namespace


ListChanged Event

ListChanged Event
[image]
Telerik.Reporting.Charting Namespace > ProductsList Class : ListChanged Event

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event ListChanged() As ListChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ProductsList
Dim handler As ListChangedEventHandler

AddHandler instance.ListChanged, handler
C#
public event ListChangedEventHandler ListChanged()

Syntax

Visual Basic (Declaration)
Public Event ListChanged() As ListChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ProductsList
Dim handler As ListChangedEventHandler

AddHandler instance.ListChanged, handler
C#
public event ListChangedEventHandler ListChanged()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProductsList Class
ProductsList Members


RenderedObject Class

RenderedObject Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : RenderedObject Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class RenderedObject
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As RenderedObject
C#
public abstract class RenderedObject : StateManagedObject, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.ChartAxis
Telerik.Reporting.Charting.ChartMarkedZone
Telerik.Reporting.Charting.ChartSeries
Telerik.Reporting.Charting.ChartSeriesItem
Telerik.Reporting.Charting.LayoutElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderedObject Members
Telerik.Reporting.Charting Namespace


RenderedObject Class Members

RenderedObject Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : RenderedObject Class

The following tables list the members exposed by RenderedObject.

Protected Fields

 | Name | Description
Protected Field | objectContainer |
Top

Public Properties

 | Name | Description
Public Property | Container |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward |
Public Method | BringToFront |
Public Method | GetOrder |
Public Method | Remove |
Public Method | SendBackward |
Public Method | SendToBack |
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder |
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | (Inherited from StateManagedObject)
Protected Method | SaveViewState | (Inherited from StateManagedObject)
Protected Method | TrackViewState | (Inherited from StateManagedObject)
Top

See Also

Reference

RenderedObject Class
Telerik.Reporting.Charting Namespace


RenderedObject Class Methods

RenderedObject Class Methods
[image]
Telerik.Reporting.Charting Namespace : RenderedObject Class

For a list of all members of this type, see RenderedObject members.

Public Methods

 | Name | Description
Public Method | BringForward |
Public Method | BringToFront |
Public Method | GetOrder |
Public Method | Remove |
Public Method | SendBackward |
Public Method | SendToBack |
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder |
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | (Inherited from StateManagedObject)
Protected Method | SaveViewState | (Inherited from StateManagedObject)
Protected Method | TrackViewState | (Inherited from StateManagedObject)
Top

See Also

Reference

RenderedObject Class
Telerik.Reporting.Charting Namespace


BringForward Method

BringForward Method
[image]
Telerik.Reporting.Charting Namespace > RenderedObject Class : BringForward Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub BringForward()
Visual Basic (Usage) Copy Code
Dim instance As RenderedObject

instance.BringForward()
C#
public void BringForward()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderedObject Class
RenderedObject Members


BringToFront Method

BringToFront Method
[image]
Telerik.Reporting.Charting Namespace > RenderedObject Class : BringToFront Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
Visual Basic (Usage) Copy Code
Dim instance As RenderedObject

instance.BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderedObject Class
RenderedObject Members


GetOrder Method

GetOrder Method
[image]
Telerik.Reporting.Charting Namespace > RenderedObject Class : GetOrder Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOrder() As Integer
Visual Basic (Usage) Copy Code
Dim instance As RenderedObject
Dim value As Integer

value = instance.GetOrder()
C#
public int GetOrder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderedObject Class
RenderedObject Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Charting Namespace > RenderedObject Class : Remove Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove()
Visual Basic (Usage) Copy Code
Dim instance As RenderedObject

instance.Remove()
C#
public void Remove()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderedObject Class
RenderedObject Members


SendBackward Method

SendBackward Method
[image]
Telerik.Reporting.Charting Namespace > RenderedObject Class : SendBackward Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SendBackward()
Visual Basic (Usage) Copy Code
Dim instance As RenderedObject

instance.SendBackward()
C#
public void SendBackward()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderedObject Class
RenderedObject Members


SendToBack Method

SendToBack Method
[image]
Telerik.Reporting.Charting Namespace > RenderedObject Class : SendToBack Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
Visual Basic (Usage) Copy Code
Dim instance As RenderedObject

instance.SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderedObject Class
RenderedObject Members


SetOrder Method

SetOrder Method
[image]
Telerik.Reporting.Charting Namespace > RenderedObject Class : SetOrder Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetOrder( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As RenderedObject
Dim index As Integer

instance.SetOrder(index)
C#
public void SetOrder(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderedObject Class
RenderedObject Members


RenderedObject Class Properties

RenderedObject Class Properties
[image]
Telerik.Reporting.Charting Namespace : RenderedObject Class

For a list of all members of this type, see RenderedObject members.

Public Properties

 | Name | Description
Public Property | Container |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

RenderedObject Class
Telerik.Reporting.Charting Namespace


Container Property

Container Property
[image]
Telerik.Reporting.Charting Namespace > RenderedObject Class : Container Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Container As IContainer
Visual Basic (Usage) Copy Code
Dim instance As RenderedObject
Dim value As IContainer

instance.Container = value

value = instance.Container
C#
public IContainer Container {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderedObject Class
RenderedObject Members


RenderedObject Class Fields

RenderedObject Class Fields
[image]
Telerik.Reporting.Charting Namespace : RenderedObject Class

For a list of all members of this type, see RenderedObject members.

Protected Fields

 | Name | Description
Protected Field | objectContainer |
Top

See Also

Reference

RenderedObject Class
Telerik.Reporting.Charting Namespace


objectContainer Field

objectContainer Field
[image]
Telerik.Reporting.Charting Namespace > RenderedObject Class : objectContainer Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected objectContainer As IContainer
Visual Basic (Usage) Copy Code
Dim instance As RenderedObject
Dim value As IContainer

value = instance.objectContainer

instance.objectContainer = value
C#
protected IContainer objectContainer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderedObject Class
RenderedObject Members


ScaleBreak Class

ScaleBreak Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : ScaleBreak Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ScaleBreak
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreak
C#
public class ScaleBreak : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.ScaleBreak

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Members
Telerik.Reporting.Charting Namespace


ScaleBreak Class Members

ScaleBreak Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : ScaleBreak Class

The following tables list the members exposed by ScaleBreak.

Public Constructors

 | Name | Description
Public Constructor | ScaleBreak Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | scaleBreakParent |
Top

Public Properties

 | Name | Description
Public Property | Enabled |
Public Property | Line |
Public Property | LineStyle |
Public Property | MaxCount |
Public Property | Parent |
Public Property | Segments |
Public Property | ValueTolerance |
Public Property | Width |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ScaleBreak Class
Telerik.Reporting.Charting Namespace


ScaleBreak Constructor

ScaleBreak Constructor
[image]
Telerik.Reporting.Charting Namespace > ScaleBreak Class : ScaleBreak Constructor

parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartAxis _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartAxis

Dim instance As ScaleBreak(parent)
C#
public ScaleBreak(
   ChartAxis parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartAxis _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartAxis

Dim instance As ScaleBreak(parent)
C#
public ScaleBreak(
   ChartAxis parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Class
ScaleBreak Members


ScaleBreak Class Methods

ScaleBreak Class Methods
[image]
Telerik.Reporting.Charting Namespace : ScaleBreak Class

For a list of all members of this type, see ScaleBreak members.

Public Methods

 | Name | Description
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

ScaleBreak Class
Telerik.Reporting.Charting Namespace


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > ScaleBreak Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreak
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Class
ScaleBreak Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > ScaleBreak Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreak
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Class
ScaleBreak Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > ScaleBreak Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreak

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Class
ScaleBreak Members


ScaleBreak Class Properties

ScaleBreak Class Properties
[image]
Telerik.Reporting.Charting Namespace : ScaleBreak Class

For a list of all members of this type, see ScaleBreak members.

Public Properties

 | Name | Description
Public Property | Enabled |
Public Property | Line |
Public Property | LineStyle |
Public Property | MaxCount |
Public Property | Parent |
Public Property | Segments |
Public Property | ValueTolerance |
Public Property | Width |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ScaleBreak Class
Telerik.Reporting.Charting Namespace


Enabled Property

Enabled Property
[image]
Telerik.Reporting.Charting Namespace > ScaleBreak Class : Enabled Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreak
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public bool Enabled {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Class
ScaleBreak Members


Line Property

Line Property
[image]
Telerik.Reporting.Charting Namespace > ScaleBreak Class : Line Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Line As LineStyle
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreak
Dim value As LineStyle

instance.Line = value

value = instance.Line
C#
public LineStyle Line {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Class
ScaleBreak Members


LineStyle Property

LineStyle Property
[image]
Telerik.Reporting.Charting Namespace > ScaleBreak Class : LineStyle Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property LineStyle As ScaleBreakLineType
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreak
Dim value As ScaleBreakLineType

instance.LineStyle = value

value = instance.LineStyle
C#
public ScaleBreakLineType LineStyle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Class
ScaleBreak Members


MaxCount Property

MaxCount Property
[image]
Telerik.Reporting.Charting Namespace > ScaleBreak Class : MaxCount Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreak
Dim value As Integer

instance.MaxCount = value

value = instance.MaxCount
C#
public int MaxCount {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Class
ScaleBreak Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > ScaleBreak Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As ChartAxis
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreak
Dim value As ChartAxis

value = instance.Parent
C#
public ChartAxis Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Class
ScaleBreak Members


Segments Property

Segments Property
[image]
Telerik.Reporting.Charting Namespace > ScaleBreak Class : Segments Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Segments As AxisSegmentCollection
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreak
Dim value As AxisSegmentCollection

value = instance.Segments
C#
public AxisSegmentCollection Segments {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Class
ScaleBreak Members


ValueTolerance Property

ValueTolerance Property
[image]
Telerik.Reporting.Charting Namespace > ScaleBreak Class : ValueTolerance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueTolerance As Byte
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreak
Dim value As Byte

instance.ValueTolerance = value

value = instance.ValueTolerance
C#
public byte ValueTolerance {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Class
ScaleBreak Members


Width Property

Width Property
[image]
Telerik.Reporting.Charting Namespace > ScaleBreak Class : Width Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreak
Dim value As Integer

instance.Width = value

value = instance.Width
C#
public int Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Class
ScaleBreak Members


ScaleBreak Class Fields

ScaleBreak Class Fields
[image]
Telerik.Reporting.Charting Namespace : ScaleBreak Class

For a list of all members of this type, see ScaleBreak members.

Protected Fields

 | Name | Description
Protected Field | scaleBreakParent |
Top

See Also

Reference

ScaleBreak Class
Telerik.Reporting.Charting Namespace


scaleBreakParent Field

scaleBreakParent Field
[image]
Telerik.Reporting.Charting Namespace > ScaleBreak Class : scaleBreakParent Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected scaleBreakParent As ChartAxis
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreak
Dim value As ChartAxis

value = instance.scaleBreakParent

instance.scaleBreakParent = value
C#
protected ChartAxis scaleBreakParent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreak Class
ScaleBreak Members


SeriesItemLabel Class

SeriesItemLabel Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : SeriesItemLabel Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class SeriesItemLabel
   Inherits ChartBaseLabel
   Implements IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As SeriesItemLabel
C#
public class SeriesItemLabel : ChartBaseLabel, IActiveRegion, IChartingStateManagedItem, IChartingStateManager, IContainer, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.SeriesItemLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SeriesItemLabel Members
Telerik.Reporting.Charting Namespace


SeriesItemLabel Class Members

SeriesItemLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : SeriesItemLabel Class

The following tables list the members exposed by SeriesItemLabel.

Public Constructors

 | Name | Description
Public Constructor | SeriesItemLabel Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | Overridden.
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

SeriesItemLabel Class
Telerik.Reporting.Charting Namespace


SeriesItemLabel Constructor

SeriesItemLabel Constructor
[image]
Telerik.Reporting.Charting Namespace > SeriesItemLabel Class : SeriesItemLabel Constructor

Overload List

Overload | Description
SeriesItemLabel Constructor() |
SeriesItemLabel Constructor(ChartSeries) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SeriesItemLabel Class
SeriesItemLabel Members


SeriesItemLabel Constructor()

SeriesItemLabel Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > SeriesItemLabel Class > SeriesItemLabel Constructor : SeriesItemLabel Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SeriesItemLabel()
C#
public SeriesItemLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SeriesItemLabel()
C#
public SeriesItemLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SeriesItemLabel Class
SeriesItemLabel Members
Overload List


SeriesItemLabel Constructor(ChartSeries)

SeriesItemLabel Constructor(ChartSeries)
See Also
[image]
Telerik.Reporting.Charting Namespace > SeriesItemLabel Class > SeriesItemLabel Constructor : SeriesItemLabel Constructor(ChartSeries)

series

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As SeriesItemLabel(series)
C#
public SeriesItemLabel(
   ChartSeries series
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As SeriesItemLabel(series)
C#
public SeriesItemLabel(
   ChartSeries series
)

Parameters

series

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SeriesItemLabel Class
SeriesItemLabel Members
Overload List


SeriesItemLabel Class Methods

SeriesItemLabel Class Methods
[image]
Telerik.Reporting.Charting Namespace : SeriesItemLabel Class

For a list of all members of this type, see SeriesItemLabel members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | Overridden.
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

SeriesItemLabel Class
Telerik.Reporting.Charting Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting Namespace > SeriesItemLabel Class : Clone Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesItemLabel
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SeriesItemLabel Class
SeriesItemLabel Members


SeriesItemLabel Class Properties

SeriesItemLabel Class Properties
[image]
Telerik.Reporting.Charting Namespace : SeriesItemLabel Class

For a list of all members of this type, see SeriesItemLabel members.

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

SeriesItemLabel Class
Telerik.Reporting.Charting Namespace


Appearance Property

Appearance Property
[image]
Telerik.Reporting.Charting Namespace > SeriesItemLabel Class : Appearance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleSeriesItemLabel
Visual Basic (Usage) Copy Code
Dim instance As SeriesItemLabel
Dim value As StyleSeriesItemLabel

value = instance.Appearance
C#
public StyleSeriesItemLabel Appearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SeriesItemLabel Class
SeriesItemLabel Members


StateManagedObject Class

StateManagedObject Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : StateManagedObject Class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StateManagedObject
C#
public abstract class StateManagedObject : IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.ActiveRegion
Telerik.Reporting.Charting.AxisSegment
Telerik.Reporting.Charting.CustomFigure
Telerik.Reporting.Charting.GradientElement
Telerik.Reporting.Charting.Palette
Telerik.Reporting.Charting.PaletteItem
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.ScaleBreak
Telerik.Reporting.Charting.Styles.Corners
Telerik.Reporting.Charting.Styles.Dimensions
Telerik.Reporting.Charting.Styles.EmptyValue
Telerik.Reporting.Charting.Styles.FillSettings
Telerik.Reporting.Charting.Styles.FillStyle
Telerik.Reporting.Charting.Styles.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles.Position
Telerik.Reporting.Charting.Styles.ShadowStyle
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.TextProperties

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateManagedObject Members
Telerik.Reporting.Charting Namespace


StateManagedObject Class Members

StateManagedObject Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : StateManagedObject Class

The following tables list the members exposed by StateManagedObject.

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase |
Top

Public Methods

 | Name | Description
Public Method | SetDirty |
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState |
Protected Method | LoadViewState |
Protected Method | SaveViewState |
Protected Method | TrackViewState |
Top

See Also

Reference

StateManagedObject Class
Telerik.Reporting.Charting Namespace


StateManagedObject Class Methods

StateManagedObject Class Methods
[image]
Telerik.Reporting.Charting Namespace : StateManagedObject Class

For a list of all members of this type, see StateManagedObject members.

Public Methods

 | Name | Description
Public Method | SetDirty |
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CloneState |
Protected Method | LoadViewState |
Protected Method | SaveViewState |
Protected Method | TrackViewState |
Top

See Also

Reference

StateManagedObject Class
Telerik.Reporting.Charting Namespace


CloneState Method

CloneState Method
[image]
Telerik.Reporting.Charting Namespace > StateManagedObject Class : CloneState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Function CloneState() As StateBag
Visual Basic (Usage) Copy Code
Dim instance As StateManagedObject
Dim value As StateBag

value = instance.CloneState()
C#
protected StateBag CloneState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateManagedObject Class
StateManagedObject Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > StateManagedObject Class : LoadViewState Method

state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub LoadViewState( _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StateManagedObject
Dim state As Object

instance.LoadViewState(state)
C#
protected virtual void LoadViewState(
   object state
)

Parameters

state

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateManagedObject Class
StateManagedObject Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > StateManagedObject Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As StateManagedObject
Dim value As Object

value = instance.SaveViewState()
C#
protected virtual object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateManagedObject Class
StateManagedObject Members


SetDirty Method

SetDirty Method
[image]
Telerik.Reporting.Charting Namespace > StateManagedObject Class : SetDirty Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetDirty()
Visual Basic (Usage) Copy Code
Dim instance As StateManagedObject

instance.SetDirty()
C#
public void SetDirty()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateManagedObject Class
StateManagedObject Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Charting Namespace > StateManagedObject Class : ToString Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As StateManagedObject
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateManagedObject Class
StateManagedObject Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > StateManagedObject Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As StateManagedObject

instance.TrackViewState()
C#
protected virtual void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateManagedObject Class
StateManagedObject Members


StateManagedObject Class Properties

StateManagedObject Class Properties
[image]
Telerik.Reporting.Charting Namespace : StateManagedObject Class

For a list of all members of this type, see StateManagedObject members.

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase |
Top

See Also

Reference

StateManagedObject Class
Telerik.Reporting.Charting Namespace


ViewStateIgnoresCase Property

ViewStateIgnoresCase Property
[image]
Telerik.Reporting.Charting Namespace > StateManagedObject Class : ViewStateIgnoresCase Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ViewStateIgnoresCase As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StateManagedObject
Dim value As Boolean

value = instance.ViewStateIgnoresCase
C#
protected virtual bool ViewStateIgnoresCase {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateManagedObject Class
StateManagedObject Members


TextBlock Class

TextBlock Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : TextBlock Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBlock
   Inherits LayoutElement
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As TextBlock
C#
public class TextBlock : LayoutElement, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.TextBlock
Telerik.Reporting.Charting.TextBlockAxisItem
Telerik.Reporting.Charting.TextBlockEmptySeriesMessage
Telerik.Reporting.Charting.TextBlockHidden
Telerik.Reporting.Charting.TextBlockLabelItem
Telerik.Reporting.Charting.TextBlockMarkedZone
Telerik.Reporting.Charting.TextBlockSeriesItem
Telerik.Reporting.Charting.TextBlockTitle
Telerik.Reporting.Charting.TextBlockXAxisLabel
Telerik.Reporting.Charting.TextBlockYAxisLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Members
Telerik.Reporting.Charting Namespace


TextBlock Class Members

TextBlock Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlock Class

The following tables list the members exposed by TextBlock.

Public Constructors

 | Name | Description
Public Constructor | TextBlock Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT |
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength |
Protected Field | textBlockParent |
Top

Public Properties

 | Name | Description
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent |
Public Property | Text |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom |
Public Method | Dispose | Overloaded.
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlock Class
Telerik.Reporting.Charting Namespace


TextBlock Constructor

TextBlock Constructor
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class : TextBlock Constructor

Overload List

Overload | Description
TextBlock Constructor() |
TextBlock Constructor(ChartBaseLabel,IContainer) |
TextBlock Constructor(ChartBaseLabel,IContainer,String) |
TextBlock Constructor(ChartBaseLabel,IContainer,StyleTextBlock) |
TextBlock Constructor(ChartBaseLabel,IContainer,StyleTextBlock,String) |
TextBlock Constructor(String) |
TextBlock Constructor(StyleTextBlock) |
TextBlock Constructor(StyleTextBlock,String) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members


TextBlock Constructor()

TextBlock Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class > TextBlock Constructor : TextBlock Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlock()
C#
public TextBlock()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlock()
C#
public TextBlock()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members
Overload List


TextBlock Constructor(ChartBaseLabel,IContainer)

TextBlock Constructor(ChartBaseLabel,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class > TextBlock Constructor : TextBlock Constructor(ChartBaseLabel,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer

Dim instance As TextBlock(parent, container)
C#
public TextBlock(
   ChartBaseLabel parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer

Dim instance As TextBlock(parent, container)
C#
public TextBlock(
   ChartBaseLabel parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members
Overload List


TextBlock Constructor(ChartBaseLabel,IContainer,String)

TextBlock Constructor(ChartBaseLabel,IContainer,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class > TextBlock Constructor : TextBlock Constructor(ChartBaseLabel,IContainer,String)

parent
container
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer
Dim text As String

Dim instance As TextBlock(parent, container, text)
C#
public TextBlock(
   ChartBaseLabel parent,
   IContainer container,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer
Dim text As String

Dim instance As TextBlock(parent, container, text)
C#
public TextBlock(
   ChartBaseLabel parent,
   IContainer container,
   string text
)

Parameters

parent
container
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members
Overload List


TextBlock Constructor(ChartBaseLabel,IContainer,StyleTextBlock)

TextBlock Constructor(ChartBaseLabel,IContainer,StyleTextBlock)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class > TextBlock Constructor : TextBlock Constructor(ChartBaseLabel,IContainer,StyleTextBlock)

parent
container
appearance

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer, _
   ByVal appearance As StyleTextBlock _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer
Dim appearance As StyleTextBlock

Dim instance As TextBlock(parent, container, appearance)
C#
public TextBlock(
   ChartBaseLabel parent,
   IContainer container,
   StyleTextBlock appearance
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer, _
   ByVal appearance As StyleTextBlock _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer
Dim appearance As StyleTextBlock

Dim instance As TextBlock(parent, container, appearance)
C#
public TextBlock(
   ChartBaseLabel parent,
   IContainer container,
   StyleTextBlock appearance
)

Parameters

parent
container
appearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members
Overload List


TextBlock Constructor(ChartBaseLabel,IContainer,StyleTextBlock,String)

TextBlock Constructor(ChartBaseLabel,IContainer,StyleTextBlock,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class > TextBlock Constructor : TextBlock Constructor(ChartBaseLabel,IContainer,StyleTextBlock,String)

parent
container
appearance
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer, _
   ByVal appearance As StyleTextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer
Dim appearance As StyleTextBlock
Dim text As String

Dim instance As TextBlock(parent, container, appearance, text)
C#
public TextBlock(
   ChartBaseLabel parent,
   IContainer container,
   StyleTextBlock appearance,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer, _
   ByVal appearance As StyleTextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer
Dim appearance As StyleTextBlock
Dim text As String

Dim instance As TextBlock(parent, container, appearance, text)
C#
public TextBlock(
   ChartBaseLabel parent,
   IContainer container,
   StyleTextBlock appearance,
   string text
)

Parameters

parent
container
appearance
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members
Overload List


TextBlock Constructor(String)

TextBlock Constructor(String)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class > TextBlock Constructor : TextBlock Constructor(String)

text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As TextBlock(text)
C#
public TextBlock(
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As TextBlock(text)
C#
public TextBlock(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members
Overload List


TextBlock Constructor(StyleTextBlock)

TextBlock Constructor(StyleTextBlock)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class > TextBlock Constructor : TextBlock Constructor(StyleTextBlock)

appearance

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleTextBlock _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleTextBlock

Dim instance As TextBlock(appearance)
C#
public TextBlock(
   StyleTextBlock appearance
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleTextBlock _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleTextBlock

Dim instance As TextBlock(appearance)
C#
public TextBlock(
   StyleTextBlock appearance
)

Parameters

appearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members
Overload List


TextBlock Constructor(StyleTextBlock,String)

TextBlock Constructor(StyleTextBlock,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class > TextBlock Constructor : TextBlock Constructor(StyleTextBlock,String)

appearance
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleTextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleTextBlock
Dim text As String

Dim instance As TextBlock(appearance, text)
C#
public TextBlock(
   StyleTextBlock appearance,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleTextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleTextBlock
Dim text As String

Dim instance As TextBlock(appearance, text)
C#
public TextBlock(
   StyleTextBlock appearance,
   string text
)

Parameters

appearance
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members
Overload List


TextBlock Class Methods

TextBlock Class Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlock Class

For a list of all members of this type, see TextBlock members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom |
Public Method | Dispose | Overloaded.
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlock Class
Telerik.Reporting.Charting Namespace


CopyFrom Method

CopyFrom Method
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class : CopyFrom Method

textBlock

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyFrom( _
   ByVal textBlock As TextBlock _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBlock
Dim textBlock As TextBlock

instance.CopyFrom(textBlock)
C#
public void CopyFrom(
   TextBlock textBlock
)

Parameters

textBlock

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class : Dispose Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As TextBlock

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBlock
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class : Finalize Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As TextBlock

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members


TextBlock Class Properties

TextBlock Class Properties
[image]
Telerik.Reporting.Charting Namespace : TextBlock Class

For a list of all members of this type, see TextBlock members.

Public Properties

 | Name | Description
Public Property | Appearance |
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent |
Public Property | Text |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

TextBlock Class
Telerik.Reporting.Charting Namespace


Appearance Property

Appearance Property
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class : Appearance Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleTextBlock
Visual Basic (Usage) Copy Code
Dim instance As TextBlock
Dim value As StyleTextBlock

value = instance.Appearance
C#
public StyleTextBlock Appearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members


Parent Property

Parent Property
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class : Parent Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As ChartBaseLabel
Visual Basic (Usage) Copy Code
Dim instance As TextBlock
Dim value As ChartBaseLabel

instance.Parent = value

value = instance.Parent
C#
public ChartBaseLabel Parent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members


Text Property

Text Property
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class : Text Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As TextBlock
Dim value As String

instance.Text = value

value = instance.Text
C#
public virtual string Text {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class : Visible Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBlock
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members


TextBlock Class Fields

TextBlock Class Fields
[image]
Telerik.Reporting.Charting Namespace : TextBlock Class

For a list of all members of this type, see TextBlock members.

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT |
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength |
Protected Field | textBlockParent |
Top

See Also

Reference

TextBlock Class
Telerik.Reporting.Charting Namespace


DEFAULT_TEXT Field

DEFAULT_TEXT Field
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class : DEFAULT_TEXT Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected DEFAULT_TEXT As String
Visual Basic (Usage) Copy Code
Dim instance As TextBlock
Dim value As String

value = instance.DEFAULT_TEXT

instance.DEFAULT_TEXT = value
C#
protected string DEFAULT_TEXT

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members


textBlockCalculatedMaxLength Field

textBlockCalculatedMaxLength Field
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class : textBlockCalculatedMaxLength Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected textBlockCalculatedMaxLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As TextBlock
Dim value As Integer

value = instance.textBlockCalculatedMaxLength

instance.textBlockCalculatedMaxLength = value
C#
protected int textBlockCalculatedMaxLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members


textBlockParent Field

textBlockParent Field
[image]
Telerik.Reporting.Charting Namespace > TextBlock Class : textBlockParent Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected textBlockParent As ChartBaseLabel
Visual Basic (Usage) Copy Code
Dim instance As TextBlock
Dim value As ChartBaseLabel

value = instance.textBlockParent

instance.textBlockParent = value
C#
protected ChartBaseLabel textBlockParent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlock Class
TextBlock Members


TextBlockAxisItem Class

TextBlockAxisItem Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : TextBlockAxisItem Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBlockAxisItem
   Inherits TextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As TextBlockAxisItem
C#
public class TextBlockAxisItem : TextBlock, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.TextBlock
Telerik.Reporting.Charting.TextBlockAxisItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockAxisItem Members
Telerik.Reporting.Charting Namespace


TextBlockAxisItem Class Members

TextBlockAxisItem Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockAxisItem Class

The following tables list the members exposed by TextBlockAxisItem.

Public Constructors

 | Name | Description
Public Constructor | TextBlockAxisItem Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | (Inherited from TextBlock)
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockAxisItem Class
Telerik.Reporting.Charting Namespace


TextBlockAxisItem Constructor

TextBlockAxisItem Constructor
[image]
Telerik.Reporting.Charting Namespace > TextBlockAxisItem Class : TextBlockAxisItem Constructor

Overload List

Overload | Description
TextBlockAxisItem Constructor() |
TextBlockAxisItem Constructor(ChartAxisItem,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockAxisItem Class
TextBlockAxisItem Members


TextBlockAxisItem Constructor()

TextBlockAxisItem Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockAxisItem Class > TextBlockAxisItem Constructor : TextBlockAxisItem Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockAxisItem()
C#
public TextBlockAxisItem()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockAxisItem()
C#
public TextBlockAxisItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockAxisItem Class
TextBlockAxisItem Members
Overload List


TextBlockAxisItem Constructor(ChartAxisItem,IContainer)

TextBlockAxisItem Constructor(ChartAxisItem,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockAxisItem Class > TextBlockAxisItem Constructor : TextBlockAxisItem Constructor(ChartAxisItem,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartAxisItem, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartAxisItem
Dim container As IContainer

Dim instance As TextBlockAxisItem(parent, container)
C#
public TextBlockAxisItem(
   ChartAxisItem parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartAxisItem, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartAxisItem
Dim container As IContainer

Dim instance As TextBlockAxisItem(parent, container)
C#
public TextBlockAxisItem(
   ChartAxisItem parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockAxisItem Class
TextBlockAxisItem Members
Overload List


TextBlockEmptySeriesMessage Class

TextBlockEmptySeriesMessage Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : TextBlockEmptySeriesMessage Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBlockEmptySeriesMessage
   Inherits TextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As TextBlockEmptySeriesMessage
C#
public class TextBlockEmptySeriesMessage : TextBlock, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.TextBlock
Telerik.Reporting.Charting.TextBlockEmptySeriesMessage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockEmptySeriesMessage Members
Telerik.Reporting.Charting Namespace


TextBlockEmptySeriesMessage Class Members

TextBlockEmptySeriesMessage Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockEmptySeriesMessage Class

The following tables list the members exposed by TextBlockEmptySeriesMessage.

Public Constructors

 | Name | Description
Public Constructor | TextBlockEmptySeriesMessage Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | Overridden.
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockEmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


TextBlockEmptySeriesMessage Constructor

TextBlockEmptySeriesMessage Constructor
[image]
Telerik.Reporting.Charting Namespace > TextBlockEmptySeriesMessage Class : TextBlockEmptySeriesMessage Constructor

Overload List

Overload | Description
TextBlockEmptySeriesMessage Constructor() |
TextBlockEmptySeriesMessage Constructor(EmptySeriesMessage,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockEmptySeriesMessage Class
TextBlockEmptySeriesMessage Members


TextBlockEmptySeriesMessage Constructor()

TextBlockEmptySeriesMessage Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockEmptySeriesMessage Class > TextBlockEmptySeriesMessage Constructor : TextBlockEmptySeriesMessage Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockEmptySeriesMessage()
C#
public TextBlockEmptySeriesMessage()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockEmptySeriesMessage()
C#
public TextBlockEmptySeriesMessage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockEmptySeriesMessage Class
TextBlockEmptySeriesMessage Members
Overload List


TextBlockEmptySeriesMessage Constructor(EmptySeriesMessage,IContainer)

TextBlockEmptySeriesMessage Constructor(EmptySeriesMessage,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockEmptySeriesMessage Class > TextBlockEmptySeriesMessage Constructor : TextBlockEmptySeriesMessage Constructor(EmptySeriesMessage,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As EmptySeriesMessage, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As EmptySeriesMessage
Dim container As IContainer

Dim instance As TextBlockEmptySeriesMessage(parent, container)
C#
public TextBlockEmptySeriesMessage(
   EmptySeriesMessage parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As EmptySeriesMessage, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As EmptySeriesMessage
Dim container As IContainer

Dim instance As TextBlockEmptySeriesMessage(parent, container)
C#
public TextBlockEmptySeriesMessage(
   EmptySeriesMessage parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockEmptySeriesMessage Class
TextBlockEmptySeriesMessage Members
Overload List


TextBlockEmptySeriesMessage Class Properties

TextBlockEmptySeriesMessage Class Properties
[image]
Telerik.Reporting.Charting Namespace : TextBlockEmptySeriesMessage Class

For a list of all members of this type, see TextBlockEmptySeriesMessage members.

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | Overridden.
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

TextBlockEmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


Text Property

Text Property
[image]
Telerik.Reporting.Charting Namespace > TextBlockEmptySeriesMessage Class : Text Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As TextBlockEmptySeriesMessage
Dim value As String

instance.Text = value

value = instance.Text
C#
public override string Text {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockEmptySeriesMessage Class
TextBlockEmptySeriesMessage Members


TextBlockHidden Class

TextBlockHidden Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : TextBlockHidden Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBlockHidden
   Inherits TextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As TextBlockHidden
C#
public class TextBlockHidden : TextBlock, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.TextBlock
Telerik.Reporting.Charting.TextBlockHidden
Telerik.Reporting.Charting.TextBlockLegend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockHidden Members
Telerik.Reporting.Charting Namespace


TextBlockHidden Class Members

TextBlockHidden Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockHidden Class

The following tables list the members exposed by TextBlockHidden.

Public Constructors

 | Name | Description
Public Constructor | TextBlockHidden Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | (Inherited from TextBlock)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockHidden Class
Telerik.Reporting.Charting Namespace


TextBlockHidden Constructor

TextBlockHidden Constructor
[image]
Telerik.Reporting.Charting Namespace > TextBlockHidden Class : TextBlockHidden Constructor

Overload List

Overload | Description
TextBlockHidden Constructor() |
TextBlockHidden Constructor(ChartBaseLabel,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockHidden Class
TextBlockHidden Members


TextBlockHidden Constructor()

TextBlockHidden Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockHidden Class > TextBlockHidden Constructor : TextBlockHidden Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockHidden()
C#
public TextBlockHidden()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockHidden()
C#
public TextBlockHidden()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockHidden Class
TextBlockHidden Members
Overload List


TextBlockHidden Constructor(ChartBaseLabel,IContainer)

TextBlockHidden Constructor(ChartBaseLabel,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockHidden Class > TextBlockHidden Constructor : TextBlockHidden Constructor(ChartBaseLabel,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer

Dim instance As TextBlockHidden(parent, container)
C#
public TextBlockHidden(
   ChartBaseLabel parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer

Dim instance As TextBlockHidden(parent, container)
C#
public TextBlockHidden(
   ChartBaseLabel parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockHidden Class
TextBlockHidden Members
Overload List


TextBlockHidden Class Properties

TextBlockHidden Class Properties
[image]
Telerik.Reporting.Charting Namespace : TextBlockHidden Class

For a list of all members of this type, see TextBlockHidden members.

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | (Inherited from TextBlock)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

TextBlockHidden Class
Telerik.Reporting.Charting Namespace


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting Namespace > TextBlockHidden Class : Visible Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBlockHidden
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockHidden Class
TextBlockHidden Members


TextBlockLabelItem Class

TextBlockLabelItem Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : TextBlockLabelItem Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBlockLabelItem
   Inherits TextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As TextBlockLabelItem
C#
public class TextBlockLabelItem : TextBlock, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.TextBlock
Telerik.Reporting.Charting.TextBlockLabelItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLabelItem Members
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Class Members

TextBlockLabelItem Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockLabelItem Class

The following tables list the members exposed by TextBlockLabelItem.

Public Constructors

 | Name | Description
Public Constructor | TextBlockLabelItem Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | (Inherited from TextBlock)
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockLabelItem Class
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Constructor

TextBlockLabelItem Constructor
[image]
Telerik.Reporting.Charting Namespace > TextBlockLabelItem Class : TextBlockLabelItem Constructor

Overload List

Overload | Description
TextBlockLabelItem Constructor() |
TextBlockLabelItem Constructor(ChartBaseLabel,IContainer) |
TextBlockLabelItem Constructor(ChartBaseLabel,IContainer,String) |
TextBlockLabelItem Constructor(ChartBaseLabel,IContainer,StyleTextBlock) |
TextBlockLabelItem Constructor(ChartBaseLabel,IContainer,StyleTextBlock,String) |
TextBlockLabelItem Constructor(String) |
TextBlockLabelItem Constructor(StyleTextBlock) |
TextBlockLabelItem Constructor(StyleTextBlock,String) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLabelItem Class
TextBlockLabelItem Members


TextBlockLabelItem Constructor()

TextBlockLabelItem Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockLabelItem Class > TextBlockLabelItem Constructor : TextBlockLabelItem Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockLabelItem()
C#
public TextBlockLabelItem()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockLabelItem()
C#
public TextBlockLabelItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLabelItem Class
TextBlockLabelItem Members
Overload List


TextBlockLabelItem Constructor(ChartBaseLabel,IContainer)

TextBlockLabelItem Constructor(ChartBaseLabel,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockLabelItem Class > TextBlockLabelItem Constructor : TextBlockLabelItem Constructor(ChartBaseLabel,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer

Dim instance As TextBlockLabelItem(parent, container)
C#
public TextBlockLabelItem(
   ChartBaseLabel parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer

Dim instance As TextBlockLabelItem(parent, container)
C#
public TextBlockLabelItem(
   ChartBaseLabel parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLabelItem Class
TextBlockLabelItem Members
Overload List


TextBlockLabelItem Constructor(ChartBaseLabel,IContainer,String)

TextBlockLabelItem Constructor(ChartBaseLabel,IContainer,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockLabelItem Class > TextBlockLabelItem Constructor : TextBlockLabelItem Constructor(ChartBaseLabel,IContainer,String)

parent
container
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer
Dim text As String

Dim instance As TextBlockLabelItem(parent, container, text)
C#
public TextBlockLabelItem(
   ChartBaseLabel parent,
   IContainer container,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer
Dim text As String

Dim instance As TextBlockLabelItem(parent, container, text)
C#
public TextBlockLabelItem(
   ChartBaseLabel parent,
   IContainer container,
   string text
)

Parameters

parent
container
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLabelItem Class
TextBlockLabelItem Members
Overload List


TextBlockLabelItem Constructor(ChartBaseLabel,IContainer,StyleTextBlock)

TextBlockLabelItem Constructor(ChartBaseLabel,IContainer,StyleTextBlock)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockLabelItem Class > TextBlockLabelItem Constructor : TextBlockLabelItem Constructor(ChartBaseLabel,IContainer,StyleTextBlock)

parent
container
appearance

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer, _
   ByVal appearance As StyleTextBlock _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer
Dim appearance As StyleTextBlock

Dim instance As TextBlockLabelItem(parent, container, appearance)
C#
public TextBlockLabelItem(
   ChartBaseLabel parent,
   IContainer container,
   StyleTextBlock appearance
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer, _
   ByVal appearance As StyleTextBlock _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer
Dim appearance As StyleTextBlock

Dim instance As TextBlockLabelItem(parent, container, appearance)
C#
public TextBlockLabelItem(
   ChartBaseLabel parent,
   IContainer container,
   StyleTextBlock appearance
)

Parameters

parent
container
appearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLabelItem Class
TextBlockLabelItem Members
Overload List


TextBlockLabelItem Constructor(ChartBaseLabel,IContainer,StyleTextBlock,String)

TextBlockLabelItem Constructor(ChartBaseLabel,IContainer,StyleTextBlock,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockLabelItem Class > TextBlockLabelItem Constructor : TextBlockLabelItem Constructor(ChartBaseLabel,IContainer,StyleTextBlock,String)

parent
container
appearance
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer, _
   ByVal appearance As StyleTextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer
Dim appearance As StyleTextBlock
Dim text As String

Dim instance As TextBlockLabelItem(parent, container, appearance, text)
C#
public TextBlockLabelItem(
   ChartBaseLabel parent,
   IContainer container,
   StyleTextBlock appearance,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartBaseLabel, _
   ByVal container As IContainer, _
   ByVal appearance As StyleTextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartBaseLabel
Dim container As IContainer
Dim appearance As StyleTextBlock
Dim text As String

Dim instance As TextBlockLabelItem(parent, container, appearance, text)
C#
public TextBlockLabelItem(
   ChartBaseLabel parent,
   IContainer container,
   StyleTextBlock appearance,
   string text
)

Parameters

parent
container
appearance
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLabelItem Class
TextBlockLabelItem Members
Overload List


TextBlockLabelItem Constructor(String)

TextBlockLabelItem Constructor(String)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockLabelItem Class > TextBlockLabelItem Constructor : TextBlockLabelItem Constructor(String)

text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As TextBlockLabelItem(text)
C#
public TextBlockLabelItem(
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Dim instance As TextBlockLabelItem(text)
C#
public TextBlockLabelItem(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLabelItem Class
TextBlockLabelItem Members
Overload List


TextBlockLabelItem Constructor(StyleTextBlock)

TextBlockLabelItem Constructor(StyleTextBlock)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockLabelItem Class > TextBlockLabelItem Constructor : TextBlockLabelItem Constructor(StyleTextBlock)

appearance

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleTextBlock _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleTextBlock

Dim instance As TextBlockLabelItem(appearance)
C#
public TextBlockLabelItem(
   StyleTextBlock appearance
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleTextBlock _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleTextBlock

Dim instance As TextBlockLabelItem(appearance)
C#
public TextBlockLabelItem(
   StyleTextBlock appearance
)

Parameters

appearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLabelItem Class
TextBlockLabelItem Members
Overload List


TextBlockLabelItem Constructor(StyleTextBlock,String)

TextBlockLabelItem Constructor(StyleTextBlock,String)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockLabelItem Class > TextBlockLabelItem Constructor : TextBlockLabelItem Constructor(StyleTextBlock,String)

appearance
text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleTextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleTextBlock
Dim text As String

Dim instance As TextBlockLabelItem(appearance, text)
C#
public TextBlockLabelItem(
   StyleTextBlock appearance,
   string text
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal appearance As StyleTextBlock, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim appearance As StyleTextBlock
Dim text As String

Dim instance As TextBlockLabelItem(appearance, text)
C#
public TextBlockLabelItem(
   StyleTextBlock appearance,
   string text
)

Parameters

appearance
text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLabelItem Class
TextBlockLabelItem Members
Overload List


TextBlockLegend Class

TextBlockLegend Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : TextBlockLegend Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBlockLegend
   Inherits TextBlockHidden
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As TextBlockLegend
C#
public class TextBlockLegend : TextBlockHidden, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.TextBlock
Telerik.Reporting.Charting.TextBlockHidden
Telerik.Reporting.Charting.TextBlockLegend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLegend Members
Telerik.Reporting.Charting Namespace


TextBlockLegend Class Members

TextBlockLegend Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockLegend Class

The following tables list the members exposed by TextBlockLegend.

Public Constructors

 | Name | Description
Public Constructor | TextBlockLegend Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | (Inherited from TextBlock)
Public Property | Visible | (Inherited from TextBlockHidden)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockLegend Class
Telerik.Reporting.Charting Namespace


TextBlockLegend Constructor

TextBlockLegend Constructor
[image]
Telerik.Reporting.Charting Namespace > TextBlockLegend Class : TextBlockLegend Constructor

Overload List

Overload | Description
TextBlockLegend Constructor() |
TextBlockLegend Constructor(ExtendedLabel,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLegend Class
TextBlockLegend Members


TextBlockLegend Constructor()

TextBlockLegend Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockLegend Class > TextBlockLegend Constructor : TextBlockLegend Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockLegend()
C#
public TextBlockLegend()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockLegend()
C#
public TextBlockLegend()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLegend Class
TextBlockLegend Members
Overload List


TextBlockLegend Constructor(ExtendedLabel,IContainer)

TextBlockLegend Constructor(ExtendedLabel,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockLegend Class > TextBlockLegend Constructor : TextBlockLegend Constructor(ExtendedLabel,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ExtendedLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ExtendedLabel
Dim container As IContainer

Dim instance As TextBlockLegend(parent, container)
C#
public TextBlockLegend(
   ExtendedLabel parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ExtendedLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ExtendedLabel
Dim container As IContainer

Dim instance As TextBlockLegend(parent, container)
C#
public TextBlockLegend(
   ExtendedLabel parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockLegend Class
TextBlockLegend Members
Overload List


TextBlockMarkedZone Class

TextBlockMarkedZone Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : TextBlockMarkedZone Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBlockMarkedZone
   Inherits TextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As TextBlockMarkedZone
C#
public class TextBlockMarkedZone : TextBlock, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.TextBlock
Telerik.Reporting.Charting.TextBlockMarkedZone

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockMarkedZone Members
Telerik.Reporting.Charting Namespace


TextBlockMarkedZone Class Members

TextBlockMarkedZone Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockMarkedZone Class

The following tables list the members exposed by TextBlockMarkedZone.

Public Constructors

 | Name | Description
Public Constructor | TextBlockMarkedZone Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | (Inherited from TextBlock)
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockMarkedZone Class
Telerik.Reporting.Charting Namespace


TextBlockMarkedZone Constructor

TextBlockMarkedZone Constructor
[image]
Telerik.Reporting.Charting Namespace > TextBlockMarkedZone Class : TextBlockMarkedZone Constructor

Overload List

Overload | Description
TextBlockMarkedZone Constructor() |
TextBlockMarkedZone Constructor(MarkedZoneLabel,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockMarkedZone Class
TextBlockMarkedZone Members


TextBlockMarkedZone Constructor()

TextBlockMarkedZone Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockMarkedZone Class > TextBlockMarkedZone Constructor : TextBlockMarkedZone Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockMarkedZone()
C#
public TextBlockMarkedZone()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockMarkedZone()
C#
public TextBlockMarkedZone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockMarkedZone Class
TextBlockMarkedZone Members
Overload List


TextBlockMarkedZone Constructor(MarkedZoneLabel,IContainer)

TextBlockMarkedZone Constructor(MarkedZoneLabel,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockMarkedZone Class > TextBlockMarkedZone Constructor : TextBlockMarkedZone Constructor(MarkedZoneLabel,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As MarkedZoneLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As MarkedZoneLabel
Dim container As IContainer

Dim instance As TextBlockMarkedZone(parent, container)
C#
public TextBlockMarkedZone(
   MarkedZoneLabel parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As MarkedZoneLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As MarkedZoneLabel
Dim container As IContainer

Dim instance As TextBlockMarkedZone(parent, container)
C#
public TextBlockMarkedZone(
   MarkedZoneLabel parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockMarkedZone Class
TextBlockMarkedZone Members
Overload List


TextBlockSeriesItem Class

TextBlockSeriesItem Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : TextBlockSeriesItem Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBlockSeriesItem
   Inherits TextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As TextBlockSeriesItem
C#
public class TextBlockSeriesItem : TextBlock, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.TextBlock
Telerik.Reporting.Charting.TextBlockSeriesItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockSeriesItem Members
Telerik.Reporting.Charting Namespace


TextBlockSeriesItem Class Members

TextBlockSeriesItem Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockSeriesItem Class

The following tables list the members exposed by TextBlockSeriesItem.

Public Constructors

 | Name | Description
Public Constructor | TextBlockSeriesItem Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | (Inherited from TextBlock)
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockSeriesItem Class
Telerik.Reporting.Charting Namespace


TextBlockSeriesItem Constructor

TextBlockSeriesItem Constructor
[image]
Telerik.Reporting.Charting Namespace > TextBlockSeriesItem Class : TextBlockSeriesItem Constructor

Overload List

Overload | Description
TextBlockSeriesItem Constructor() |
TextBlockSeriesItem Constructor(SeriesItemLabel,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockSeriesItem Class
TextBlockSeriesItem Members


TextBlockSeriesItem Constructor()

TextBlockSeriesItem Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockSeriesItem Class > TextBlockSeriesItem Constructor : TextBlockSeriesItem Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockSeriesItem()
C#
public TextBlockSeriesItem()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockSeriesItem()
C#
public TextBlockSeriesItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockSeriesItem Class
TextBlockSeriesItem Members
Overload List


TextBlockSeriesItem Constructor(SeriesItemLabel,IContainer)

TextBlockSeriesItem Constructor(SeriesItemLabel,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockSeriesItem Class > TextBlockSeriesItem Constructor : TextBlockSeriesItem Constructor(SeriesItemLabel,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As SeriesItemLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As SeriesItemLabel
Dim container As IContainer

Dim instance As TextBlockSeriesItem(parent, container)
C#
public TextBlockSeriesItem(
   SeriesItemLabel parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As SeriesItemLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As SeriesItemLabel
Dim container As IContainer

Dim instance As TextBlockSeriesItem(parent, container)
C#
public TextBlockSeriesItem(
   SeriesItemLabel parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockSeriesItem Class
TextBlockSeriesItem Members
Overload List


TextBlockTitle Class

TextBlockTitle Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : TextBlockTitle Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBlockTitle
   Inherits TextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As TextBlockTitle
C#
public class TextBlockTitle : TextBlock, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.TextBlock
Telerik.Reporting.Charting.TextBlockTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockTitle Members
Telerik.Reporting.Charting Namespace


TextBlockTitle Class Members

TextBlockTitle Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockTitle Class

The following tables list the members exposed by TextBlockTitle.

Public Constructors

 | Name | Description
Public Constructor | TextBlockTitle Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | Overridden.
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockTitle Class
Telerik.Reporting.Charting Namespace


TextBlockTitle Constructor

TextBlockTitle Constructor
[image]
Telerik.Reporting.Charting Namespace > TextBlockTitle Class : TextBlockTitle Constructor

Overload List

Overload | Description
TextBlockTitle Constructor() |
TextBlockTitle Constructor(ChartTitle,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockTitle Class
TextBlockTitle Members


TextBlockTitle Constructor()

TextBlockTitle Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockTitle Class > TextBlockTitle Constructor : TextBlockTitle Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockTitle()
C#
public TextBlockTitle()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockTitle()
C#
public TextBlockTitle()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockTitle Class
TextBlockTitle Members
Overload List


TextBlockTitle Constructor(ChartTitle,IContainer)

TextBlockTitle Constructor(ChartTitle,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockTitle Class > TextBlockTitle Constructor : TextBlockTitle Constructor(ChartTitle,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartTitle, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartTitle
Dim container As IContainer

Dim instance As TextBlockTitle(parent, container)
C#
public TextBlockTitle(
   ChartTitle parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartTitle, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartTitle
Dim container As IContainer

Dim instance As TextBlockTitle(parent, container)
C#
public TextBlockTitle(
   ChartTitle parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockTitle Class
TextBlockTitle Members
Overload List


TextBlockTitle Class Properties

TextBlockTitle Class Properties
[image]
Telerik.Reporting.Charting Namespace : TextBlockTitle Class

For a list of all members of this type, see TextBlockTitle members.

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | Overridden.
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

TextBlockTitle Class
Telerik.Reporting.Charting Namespace


Text Property

Text Property
[image]
Telerik.Reporting.Charting Namespace > TextBlockTitle Class : Text Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As TextBlockTitle
Dim value As String

instance.Text = value

value = instance.Text
C#
public override string Text {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockTitle Class
TextBlockTitle Members


TextBlockXAxisLabel Class

TextBlockXAxisLabel Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : TextBlockXAxisLabel Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBlockXAxisLabel
   Inherits TextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As TextBlockXAxisLabel
C#
public class TextBlockXAxisLabel : TextBlock, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.TextBlock
Telerik.Reporting.Charting.TextBlockXAxisLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockXAxisLabel Members
Telerik.Reporting.Charting Namespace


TextBlockXAxisLabel Class Members

TextBlockXAxisLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockXAxisLabel Class

The following tables list the members exposed by TextBlockXAxisLabel.

Public Constructors

 | Name | Description
Public Constructor | TextBlockXAxisLabel Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | Overridden.
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockXAxisLabel Class
Telerik.Reporting.Charting Namespace


TextBlockXAxisLabel Constructor

TextBlockXAxisLabel Constructor
[image]
Telerik.Reporting.Charting Namespace > TextBlockXAxisLabel Class : TextBlockXAxisLabel Constructor

Overload List

Overload | Description
TextBlockXAxisLabel Constructor() |
TextBlockXAxisLabel Constructor(AxisLabel,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockXAxisLabel Class
TextBlockXAxisLabel Members


TextBlockXAxisLabel Constructor()

TextBlockXAxisLabel Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockXAxisLabel Class > TextBlockXAxisLabel Constructor : TextBlockXAxisLabel Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockXAxisLabel()
C#
public TextBlockXAxisLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockXAxisLabel()
C#
public TextBlockXAxisLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockXAxisLabel Class
TextBlockXAxisLabel Members
Overload List


TextBlockXAxisLabel Constructor(AxisLabel,IContainer)

TextBlockXAxisLabel Constructor(AxisLabel,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockXAxisLabel Class > TextBlockXAxisLabel Constructor : TextBlockXAxisLabel Constructor(AxisLabel,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As AxisLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As AxisLabel
Dim container As IContainer

Dim instance As TextBlockXAxisLabel(parent, container)
C#
public TextBlockXAxisLabel(
   AxisLabel parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As AxisLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As AxisLabel
Dim container As IContainer

Dim instance As TextBlockXAxisLabel(parent, container)
C#
public TextBlockXAxisLabel(
   AxisLabel parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockXAxisLabel Class
TextBlockXAxisLabel Members
Overload List


TextBlockXAxisLabel Class Properties

TextBlockXAxisLabel Class Properties
[image]
Telerik.Reporting.Charting Namespace : TextBlockXAxisLabel Class

For a list of all members of this type, see TextBlockXAxisLabel members.

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | Overridden.
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

TextBlockXAxisLabel Class
Telerik.Reporting.Charting Namespace


Text Property

Text Property
[image]
Telerik.Reporting.Charting Namespace > TextBlockXAxisLabel Class : Text Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As TextBlockXAxisLabel
Dim value As String

instance.Text = value

value = instance.Text
C#
public override string Text {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockXAxisLabel Class
TextBlockXAxisLabel Members


TextBlockYAxisLabel Class

TextBlockYAxisLabel Class
See Also Members
[image]
Telerik.Reporting.Charting Namespace : TextBlockYAxisLabel Class

Object Model

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBlockYAxisLabel
   Inherits TextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IOrdering
Visual Basic (Usage) Copy Code
Dim instance As TextBlockYAxisLabel
C#
public class TextBlockYAxisLabel : TextBlock, IChartingStateManagedItem, IChartingStateManager, IOrdering

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.TextBlock
Telerik.Reporting.Charting.TextBlockYAxisLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockYAxisLabel Members
Telerik.Reporting.Charting Namespace


TextBlockYAxisLabel Class Members

TextBlockYAxisLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockYAxisLabel Class

The following tables list the members exposed by TextBlockYAxisLabel.

Public Constructors

 | Name | Description
Public Constructor | TextBlockYAxisLabel Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | Overridden.
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockYAxisLabel Class
Telerik.Reporting.Charting Namespace


TextBlockYAxisLabel Constructor

TextBlockYAxisLabel Constructor
[image]
Telerik.Reporting.Charting Namespace > TextBlockYAxisLabel Class : TextBlockYAxisLabel Constructor

Overload List

Overload | Description
TextBlockYAxisLabel Constructor() |
TextBlockYAxisLabel Constructor(AxisYLabel,IContainer) |

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockYAxisLabel Class
TextBlockYAxisLabel Members


TextBlockYAxisLabel Constructor()

TextBlockYAxisLabel Constructor()
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockYAxisLabel Class > TextBlockYAxisLabel Constructor : TextBlockYAxisLabel Constructor()

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockYAxisLabel()
C#
public TextBlockYAxisLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBlockYAxisLabel()
C#
public TextBlockYAxisLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockYAxisLabel Class
TextBlockYAxisLabel Members
Overload List


TextBlockYAxisLabel Constructor(AxisYLabel,IContainer)

TextBlockYAxisLabel Constructor(AxisYLabel,IContainer)
See Also
[image]
Telerik.Reporting.Charting Namespace > TextBlockYAxisLabel Class > TextBlockYAxisLabel Constructor : TextBlockYAxisLabel Constructor(AxisYLabel,IContainer)

parent
container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As AxisYLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As AxisYLabel
Dim container As IContainer

Dim instance As TextBlockYAxisLabel(parent, container)
C#
public TextBlockYAxisLabel(
   AxisYLabel parent,
   IContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As AxisYLabel, _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim parent As AxisYLabel
Dim container As IContainer

Dim instance As TextBlockYAxisLabel(parent, container)
C#
public TextBlockYAxisLabel(
   AxisYLabel parent,
   IContainer container
)

Parameters

parent
container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockYAxisLabel Class
TextBlockYAxisLabel Members
Overload List


TextBlockYAxisLabel Class Properties

TextBlockYAxisLabel Class Properties
[image]
Telerik.Reporting.Charting Namespace : TextBlockYAxisLabel Class

For a list of all members of this type, see TextBlockYAxisLabel members.

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | Overridden.
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

TextBlockYAxisLabel Class
Telerik.Reporting.Charting Namespace


Text Property

Text Property
[image]
Telerik.Reporting.Charting Namespace > TextBlockYAxisLabel Class : Text Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As TextBlockYAxisLabel
Dim value As String

instance.Text = value

value = instance.Text
C#
public override string Text {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBlockYAxisLabel Class
TextBlockYAxisLabel Members


IActiveRegion Interface

IActiveRegion Interface
See Also Members
[image]
Telerik.Reporting.Charting Namespace : IActiveRegion Interface

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Interface IActiveRegion
Visual Basic (Usage) Copy Code
Dim instance As IActiveRegion
C#
public interface IActiveRegion

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IActiveRegion Members
Telerik.Reporting.Charting Namespace


IActiveRegion Interface Members

IActiveRegion Interface Members
See Also Properties
[image]
Telerik.Reporting.Charting Namespace : IActiveRegion Interface

The following tables list the members exposed by IActiveRegion.

Public Properties

 | Name | Description
Property | ActiveRegion |
Top

See Also

Reference

IActiveRegion Interface
Telerik.Reporting.Charting Namespace


IActiveRegion Interface Properties

IActiveRegion Interface Properties
[image]
Telerik.Reporting.Charting Namespace : IActiveRegion Interface

For a list of all members of this type, see IActiveRegion members.

Public Properties

 | Name | Description
Property | ActiveRegion |
Top

See Also

Reference

IActiveRegion Interface
Telerik.Reporting.Charting Namespace


ActiveRegion Property

ActiveRegion Property
[image]
Telerik.Reporting.Charting Namespace > IActiveRegion Interface : ActiveRegion Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ActiveRegion As ActiveRegion
Visual Basic (Usage) Copy Code
Dim instance As IActiveRegion
Dim value As ActiveRegion

value = instance.ActiveRegion
C#
ActiveRegion ActiveRegion {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IActiveRegion Interface
IActiveRegion Members


IChartComponent Interface

IChartComponent Interface
See Also Members
[image]
Telerik.Reporting.Charting Namespace : IChartComponent Interface

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Interface IChartComponent
Visual Basic (Usage) Copy Code
Dim instance As IChartComponent
C#
public interface IChartComponent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartComponent Members
Telerik.Reporting.Charting Namespace


IChartComponent Interface Members

IChartComponent Interface Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : IChartComponent Interface

The following tables list the members exposed by IChartComponent.

Public Properties

 | Name | Description
Property | Chart |
Property | TempImagesFolder |
Top

Public Methods

 | Name | Description
Method | Clone |
Method | MapPath |
Top

See Also

Reference

IChartComponent Interface
Telerik.Reporting.Charting Namespace


IChartComponent Interface Methods

IChartComponent Interface Methods
[image]
Telerik.Reporting.Charting Namespace : IChartComponent Interface

For a list of all members of this type, see IChartComponent members.

Public Methods

 | Name | Description
Method | Clone |
Method | MapPath |
Top

See Also

Reference

IChartComponent Interface
Telerik.Reporting.Charting Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting Namespace > IChartComponent Interface : Clone Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As IChartComponent
Dim value As Object

value = instance.Clone()
C#
object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartComponent Interface
IChartComponent Members


MapPath Method

MapPath Method
[image]
Telerik.Reporting.Charting Namespace > IChartComponent Interface : MapPath Method

filePath

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Function MapPath( _
   ByVal filePath As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As IChartComponent
Dim filePath As String
Dim value As String

value = instance.MapPath(filePath)
C#
string MapPath(
   string filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartComponent Interface
IChartComponent Members


IChartComponent Interface Properties

IChartComponent Interface Properties
[image]
Telerik.Reporting.Charting Namespace : IChartComponent Interface

For a list of all members of this type, see IChartComponent members.

Public Properties

 | Name | Description
Property | Chart |
Property | TempImagesFolder |
Top

See Also

Reference

IChartComponent Interface
Telerik.Reporting.Charting Namespace


Chart Property

Chart Property
[image]
Telerik.Reporting.Charting Namespace > IChartComponent Interface : Chart Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Chart As Chart
Visual Basic (Usage) Copy Code
Dim instance As IChartComponent
Dim value As Chart

value = instance.Chart
C#
Chart Chart {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartComponent Interface
IChartComponent Members


TempImagesFolder Property

TempImagesFolder Property
[image]
Telerik.Reporting.Charting Namespace > IChartComponent Interface : TempImagesFolder Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Property TempImagesFolder As String
Visual Basic (Usage) Copy Code
Dim instance As IChartComponent
Dim value As String

instance.TempImagesFolder = value

value = instance.TempImagesFolder
C#
string TempImagesFolder {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartComponent Interface
IChartComponent Members


IChartingStateManagedItem Interface

IChartingStateManagedItem Interface
See Also Members
[image]
Telerik.Reporting.Charting Namespace : IChartingStateManagedItem Interface

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Interface IChartingStateManagedItem
   Inherits IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As IChartingStateManagedItem
C#
public interface IChartingStateManagedItem : IChartingStateManager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartingStateManagedItem Members
Telerik.Reporting.Charting Namespace


IChartingStateManagedItem Interface Members

IChartingStateManagedItem Interface Members
See Also Methods
[image]
Telerik.Reporting.Charting Namespace : IChartingStateManagedItem Interface

The following tables list the members exposed by IChartingStateManagedItem.

Public Methods

 | Name | Description
Method | SetDirty |
Top

See Also

Reference

IChartingStateManagedItem Interface
Telerik.Reporting.Charting Namespace


IChartingStateManagedItem Interface Methods

IChartingStateManagedItem Interface Methods
[image]
Telerik.Reporting.Charting Namespace : IChartingStateManagedItem Interface

For a list of all members of this type, see IChartingStateManagedItem members.

Public Methods

 | Name | Description
Method | SetDirty |
Top

See Also

Reference

IChartingStateManagedItem Interface
Telerik.Reporting.Charting Namespace


SetDirty Method

SetDirty Method
[image]
Telerik.Reporting.Charting Namespace > IChartingStateManagedItem Interface : SetDirty Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub SetDirty()
Visual Basic (Usage) Copy Code
Dim instance As IChartingStateManagedItem

instance.SetDirty()
C#
void SetDirty()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartingStateManagedItem Interface
IChartingStateManagedItem Members


IChartingStateManager Interface

IChartingStateManager Interface
See Also Members
[image]
Telerik.Reporting.Charting Namespace : IChartingStateManager Interface

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Interface IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As IChartingStateManager
C#
public interface IChartingStateManager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartingStateManager Members
Telerik.Reporting.Charting Namespace


IChartingStateManager Interface Members

IChartingStateManager Interface Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : IChartingStateManager Interface

The following tables list the members exposed by IChartingStateManager.

Public Properties

 | Name | Description
Property | IsTrackingViewState |
Top

Public Methods

 | Name | Description
Method | LoadViewState |
Method | SaveViewState |
Method | TrackViewState |
Top

See Also

Reference

IChartingStateManager Interface
Telerik.Reporting.Charting Namespace


IChartingStateManager Interface Methods

IChartingStateManager Interface Methods
[image]
Telerik.Reporting.Charting Namespace : IChartingStateManager Interface

For a list of all members of this type, see IChartingStateManager members.

Public Methods

 | Name | Description
Method | LoadViewState |
Method | SaveViewState |
Method | TrackViewState |
Top

See Also

Reference

IChartingStateManager Interface
Telerik.Reporting.Charting Namespace


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting Namespace > IChartingStateManager Interface : LoadViewState Method

state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub LoadViewState( _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As IChartingStateManager
Dim state As Object

instance.LoadViewState(state)
C#
void LoadViewState(
   object state
)

Parameters

state

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartingStateManager Interface
IChartingStateManager Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting Namespace > IChartingStateManager Interface : SaveViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As IChartingStateManager
Dim value As Object

value = instance.SaveViewState()
C#
object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartingStateManager Interface
IChartingStateManager Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting Namespace > IChartingStateManager Interface : TrackViewState Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As IChartingStateManager

instance.TrackViewState()
C#
void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartingStateManager Interface
IChartingStateManager Members


IChartingStateManager Interface Properties

IChartingStateManager Interface Properties
[image]
Telerik.Reporting.Charting Namespace : IChartingStateManager Interface

For a list of all members of this type, see IChartingStateManager members.

Public Properties

 | Name | Description
Property | IsTrackingViewState |
Top

See Also

Reference

IChartingStateManager Interface
Telerik.Reporting.Charting Namespace


IsTrackingViewState Property

IsTrackingViewState Property
[image]
Telerik.Reporting.Charting Namespace > IChartingStateManager Interface : IsTrackingViewState Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsTrackingViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IChartingStateManager
Dim value As Boolean

value = instance.IsTrackingViewState
C#
bool IsTrackingViewState {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartingStateManager Interface
IChartingStateManager Members


IChartSupportsScaling Interface

IChartSupportsScaling Interface
See Also Members
[image]
Telerik.Reporting.Charting Namespace : IChartSupportsScaling Interface

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Interface IChartSupportsScaling
Visual Basic (Usage) Copy Code
Dim instance As IChartSupportsScaling
C#
private interface IChartSupportsScaling

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartSupportsScaling Members
Telerik.Reporting.Charting Namespace


IChartSupportsScaling Interface Members

IChartSupportsScaling Interface Members
See Also Properties
[image]
Telerik.Reporting.Charting Namespace : IChartSupportsScaling Interface

The following tables list the members exposed by IChartSupportsScaling.

Public Properties

 | Name | Description
Property | ScaleEnabled |
Top

See Also

Reference

IChartSupportsScaling Interface
Telerik.Reporting.Charting Namespace


IChartSupportsScaling Interface Properties

IChartSupportsScaling Interface Properties
[image]
Telerik.Reporting.Charting Namespace : IChartSupportsScaling Interface

For a list of all members of this type, see IChartSupportsScaling members.

Public Properties

 | Name | Description
Property | ScaleEnabled |
Top

See Also

Reference

IChartSupportsScaling Interface
Telerik.Reporting.Charting Namespace


ScaleEnabled Property

ScaleEnabled Property
[image]
Telerik.Reporting.Charting Namespace > IChartSupportsScaling Interface : ScaleEnabled Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ScaleEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IChartSupportsScaling
Dim value As Boolean

value = instance.ScaleEnabled
C#
bool ScaleEnabled {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IChartSupportsScaling Interface
IChartSupportsScaling Members


IContainer Interface

IContainer Interface
See Also Members
[image]
Telerik.Reporting.Charting Namespace : IContainer Interface

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Interface IContainer
Visual Basic (Usage) Copy Code
Dim instance As IContainer
C#
public interface IContainer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IContainer Members
Telerik.Reporting.Charting Namespace


IContainer Interface Members

IContainer Interface Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : IContainer Interface

The following tables list the members exposed by IContainer.

Public Properties

 | Name | Description
Property | NextPosition |
Property | OrderList |
Top

Public Methods

 | Name | Description
Method | Add |
Method | GetOrder |
Method | Insert |
Method | ReIndex |
Method | Remove |
Method | RemoveAt |
Top

See Also

Reference

IContainer Interface
Telerik.Reporting.Charting Namespace


IContainer Interface Methods

IContainer Interface Methods
[image]
Telerik.Reporting.Charting Namespace : IContainer Interface

For a list of all members of this type, see IContainer members.

Public Methods

 | Name | Description
Method | Add |
Method | GetOrder |
Method | Insert |
Method | ReIndex |
Method | Remove |
Method | RemoveAt |
Top

See Also

Reference

IContainer Interface
Telerik.Reporting.Charting Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting Namespace > IContainer Interface : Add Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub Add( _
   ByVal element As IOrdering _
)
Visual Basic (Usage) Copy Code
Dim instance As IContainer
Dim element As IOrdering

instance.Add(element)
C#
void Add(
   IOrdering element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IContainer Interface
IContainer Members


GetOrder Method

GetOrder Method
[image]
Telerik.Reporting.Charting Namespace > IContainer Interface : GetOrder Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Function GetOrder( _
   ByVal element As IOrdering _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As IContainer
Dim element As IOrdering
Dim value As Integer

value = instance.GetOrder(element)
C#
int GetOrder(
   IOrdering element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IContainer Interface
IContainer Members


Insert Method

Insert Method
[image]
Telerik.Reporting.Charting Namespace > IContainer Interface : Insert Method

order
element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub Insert( _
   ByVal order As Integer, _
   ByVal element As IOrdering _
)
Visual Basic (Usage) Copy Code
Dim instance As IContainer
Dim order As Integer
Dim element As IOrdering

instance.Insert(order, element)
C#
void Insert(
   int order,
   IOrdering element
)

Parameters

order
element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IContainer Interface
IContainer Members


ReIndex Method

ReIndex Method
[image]
Telerik.Reporting.Charting Namespace > IContainer Interface : ReIndex Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub ReIndex()
Visual Basic (Usage) Copy Code
Dim instance As IContainer

instance.ReIndex()
C#
void ReIndex()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IContainer Interface
IContainer Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Charting Namespace > IContainer Interface : Remove Method

element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub Remove( _
   ByVal element As IOrdering _
)
Visual Basic (Usage) Copy Code
Dim instance As IContainer
Dim element As IOrdering

instance.Remove(element)
C#
void Remove(
   IOrdering element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IContainer Interface
IContainer Members


RemoveAt Method

RemoveAt Method
[image]
Telerik.Reporting.Charting Namespace > IContainer Interface : RemoveAt Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As IContainer
Dim index As Integer

instance.RemoveAt(index)
C#
void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IContainer Interface
IContainer Members


IContainer Interface Properties

IContainer Interface Properties
[image]
Telerik.Reporting.Charting Namespace : IContainer Interface

For a list of all members of this type, see IContainer members.

Public Properties

 | Name | Description
Property | NextPosition |
Property | OrderList |
Top

See Also

Reference

IContainer Interface
Telerik.Reporting.Charting Namespace


NextPosition Property

NextPosition Property
[image]
Telerik.Reporting.Charting Namespace > IContainer Interface : NextPosition Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property NextPosition As Integer
Visual Basic (Usage) Copy Code
Dim instance As IContainer
Dim value As Integer

value = instance.NextPosition
C#
int NextPosition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IContainer Interface
IContainer Members


OrderList Property

OrderList Property
[image]
Telerik.Reporting.Charting Namespace > IContainer Interface : OrderList Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property OrderList As List(Of IOrdering)
Visual Basic (Usage) Copy Code
Dim instance As IContainer
Dim value As List(Of IOrdering)

value = instance.OrderList
C#
List<IOrdering> OrderList {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IContainer Interface
IContainer Members


IDeserializableCollection Interface

IDeserializableCollection Interface
See Also Members
[image]
Telerik.Reporting.Charting Namespace : IDeserializableCollection Interface

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Interface IDeserializableCollection
Visual Basic (Usage) Copy Code
Dim instance As IDeserializableCollection
C#
private interface IDeserializableCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IDeserializableCollection Members
Telerik.Reporting.Charting Namespace


IDeserializableCollection Interface Members

IDeserializableCollection Interface Members
See Also Methods
[image]
Telerik.Reporting.Charting Namespace : IDeserializableCollection Interface

The following tables list the members exposed by IDeserializableCollection.

Public Methods

 | Name | Description
Method | PopulateFromXml |
Top

See Also

Reference

IDeserializableCollection Interface
Telerik.Reporting.Charting Namespace


IDeserializableCollection Interface Methods

IDeserializableCollection Interface Methods
[image]
Telerik.Reporting.Charting Namespace : IDeserializableCollection Interface

For a list of all members of this type, see IDeserializableCollection members.

Public Methods

 | Name | Description
Method | PopulateFromXml |
Top

See Also

Reference

IDeserializableCollection Interface
Telerik.Reporting.Charting Namespace


PopulateFromXml Method

PopulateFromXml Method
[image]
Telerik.Reporting.Charting Namespace > IDeserializableCollection Interface : PopulateFromXml Method

rootElement

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub PopulateFromXml( _
   ByVal rootElement As XmlElement _
)
Visual Basic (Usage) Copy Code
Dim instance As IDeserializableCollection
Dim rootElement As XmlElement

instance.PopulateFromXml(rootElement)
C#
void PopulateFromXml(
   XmlElement rootElement
)

Parameters

rootElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IDeserializableCollection Interface
IDeserializableCollection Members


IOrdering Interface

IOrdering Interface
See Also Members
[image]
Telerik.Reporting.Charting Namespace : IOrdering Interface

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Interface IOrdering
Visual Basic (Usage) Copy Code
Dim instance As IOrdering
C#
public interface IOrdering

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IOrdering Members
Telerik.Reporting.Charting Namespace


IOrdering Interface Members

IOrdering Interface Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting Namespace : IOrdering Interface

The following tables list the members exposed by IOrdering.

Public Properties

 | Name | Description
Property | Container |
Top

Public Methods

 | Name | Description
Method | BringForward |
Method | BringToFront |
Method | GetOrder |
Method | Remove |
Method | SendBackward |
Method | SendToBack |
Method | SetOrder |
Top

See Also

Reference

IOrdering Interface
Telerik.Reporting.Charting Namespace


IOrdering Interface Methods

IOrdering Interface Methods
[image]
Telerik.Reporting.Charting Namespace : IOrdering Interface

For a list of all members of this type, see IOrdering members.

Public Methods

 | Name | Description
Method | BringForward |
Method | BringToFront |
Method | GetOrder |
Method | Remove |
Method | SendBackward |
Method | SendToBack |
Method | SetOrder |
Top

See Also

Reference

IOrdering Interface
Telerik.Reporting.Charting Namespace


BringForward Method

BringForward Method
[image]
Telerik.Reporting.Charting Namespace > IOrdering Interface : BringForward Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub BringForward()
Visual Basic (Usage) Copy Code
Dim instance As IOrdering

instance.BringForward()
C#
void BringForward()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IOrdering Interface
IOrdering Members


BringToFront Method

BringToFront Method
[image]
Telerik.Reporting.Charting Namespace > IOrdering Interface : BringToFront Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub BringToFront()
Visual Basic (Usage) Copy Code
Dim instance As IOrdering

instance.BringToFront()
C#
void BringToFront()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IOrdering Interface
IOrdering Members


GetOrder Method

GetOrder Method
[image]
Telerik.Reporting.Charting Namespace > IOrdering Interface : GetOrder Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Function GetOrder() As Integer
Visual Basic (Usage) Copy Code
Dim instance As IOrdering
Dim value As Integer

value = instance.GetOrder()
C#
int GetOrder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IOrdering Interface
IOrdering Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Charting Namespace > IOrdering Interface : Remove Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub Remove()
Visual Basic (Usage) Copy Code
Dim instance As IOrdering

instance.Remove()
C#
void Remove()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IOrdering Interface
IOrdering Members


SendBackward Method

SendBackward Method
[image]
Telerik.Reporting.Charting Namespace > IOrdering Interface : SendBackward Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub SendBackward()
Visual Basic (Usage) Copy Code
Dim instance As IOrdering

instance.SendBackward()
C#
void SendBackward()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IOrdering Interface
IOrdering Members


SendToBack Method

SendToBack Method
[image]
Telerik.Reporting.Charting Namespace > IOrdering Interface : SendToBack Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub SendToBack()
Visual Basic (Usage) Copy Code
Dim instance As IOrdering

instance.SendToBack()
C#
void SendToBack()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IOrdering Interface
IOrdering Members


SetOrder Method

SetOrder Method
[image]
Telerik.Reporting.Charting Namespace > IOrdering Interface : SetOrder Method

index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Sub SetOrder( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As IOrdering
Dim index As Integer

instance.SetOrder(index)
C#
void SetOrder(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IOrdering Interface
IOrdering Members


IOrdering Interface Properties

IOrdering Interface Properties
[image]
Telerik.Reporting.Charting Namespace : IOrdering Interface

For a list of all members of this type, see IOrdering members.

Public Properties

 | Name | Description
Property | Container |
Top

See Also

Reference

IOrdering Interface
Telerik.Reporting.Charting Namespace


Container Property

Container Property
[image]
Telerik.Reporting.Charting Namespace > IOrdering Interface : Container Property

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Property Container As IContainer
Visual Basic (Usage) Copy Code
Dim instance As IOrdering
Dim value As IContainer

instance.Container = value

value = instance.Container
C#
IContainer Container {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IOrdering Interface
IOrdering Members


PalettesCollection Structure

PalettesCollection Structure
See Also Members
[image]
Telerik.Reporting.Charting Namespace : PalettesCollection Structure

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Structure PalettesCollection
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As PalettesCollection
C#
public struct PalettesCollection : ValueType

Syntax

Visual Basic (Declaration)
Public Structure PalettesCollection
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As PalettesCollection
C#
public struct PalettesCollection : ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Telerik.Reporting.Charting.PalettesCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PalettesCollection Members
Telerik.Reporting.Charting Namespace


PalettesCollection Structure Members

PalettesCollection Structure Members
See Also Fields Methods
[image]
Telerik.Reporting.Charting Namespace : PalettesCollection Structure

The following tables list the members exposed by PalettesCollection.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Palettes |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Contains |
Public Method | Equals | (Inherited from System.ValueType)
Public Method | GetHashCode | (Inherited from System.ValueType)
static (Shared in Visual Basic) | GetPalette | Overloaded.
Public Method | ToString | (Inherited from System.ValueType)
Top

See Also

Reference

PalettesCollection Structure
Telerik.Reporting.Charting Namespace


PalettesCollection Structure Methods

PalettesCollection Structure Methods
[image]
Telerik.Reporting.Charting Namespace : PalettesCollection Structure

For a list of all members of this type, see PalettesCollection members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Contains |
Public Method | Equals | (Inherited from System.ValueType)
Public Method | GetHashCode | (Inherited from System.ValueType)
static (Shared in Visual Basic) | GetPalette | Overloaded.
Public Method | ToString | (Inherited from System.ValueType)
Top

See Also

Reference

PalettesCollection Structure
Telerik.Reporting.Charting Namespace


Contains Method

Contains Method
[image]
Telerik.Reporting.Charting Namespace > PalettesCollection Structure : Contains Method

name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Contains( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As Boolean

value = PalettesCollection.Contains(name)
C#
public static bool Contains(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PalettesCollection Structure
PalettesCollection Members


GetPalette Method

GetPalette Method
[image]
Telerik.Reporting.Charting Namespace > PalettesCollection Structure : GetPalette Method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetPalette(String) |
GetPalette(String,Chart) |

Overload List

Overload | Description
GetPalette(String) |
GetPalette(String,Chart) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PalettesCollection Structure
PalettesCollection Members


GetPalette(String) Method

GetPalette(String) Method
[image]
Telerik.Reporting.Charting Namespace > PalettesCollection Structure > GetPalette Method : GetPalette(String) Method

name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function GetPalette( _
   ByVal name As String _
) As Palette
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As Palette

value = PalettesCollection.GetPalette(name)
C#
public static Palette GetPalette(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PalettesCollection Structure
PalettesCollection Members
Overload List


GetPalette(String,Chart) Method

GetPalette(String,Chart) Method
[image]
Telerik.Reporting.Charting Namespace > PalettesCollection Structure > GetPalette Method : GetPalette(String,Chart) Method

name
chart

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function GetPalette( _
   ByVal name As String, _
   ByVal chart As Chart _
) As Palette
Visual Basic (Usage) Copy Code
Dim name As String
Dim chart As Chart
Dim value As Palette

value = PalettesCollection.GetPalette(name, chart)
C#
public static Palette GetPalette(
   string name,
   Chart chart
)

Parameters

name
chart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PalettesCollection Structure
PalettesCollection Members
Overload List


PalettesCollection Structure Fields

PalettesCollection Structure Fields
[image]
Telerik.Reporting.Charting Namespace : PalettesCollection Structure

For a list of all members of this type, see PalettesCollection members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Palettes |
Top

See Also

Reference

PalettesCollection Structure
Telerik.Reporting.Charting Namespace


Palettes Field

Palettes Field
[image]
Telerik.Reporting.Charting Namespace > PalettesCollection Structure : Palettes Field

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Palettes As List(Of String)
Visual Basic (Usage) Copy Code
Dim value As List(Of String)

value = PalettesCollection.Palettes

PalettesCollection.Palettes = value
C#
public static List<string> Palettes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PalettesCollection Structure
PalettesCollection Members


ChartMargins Class

ChartMargins Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMargins Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartMargins
   Inherits LayoutDecoratorBase
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As ChartMargins
C#
public class ChartMargins : LayoutDecoratorBase, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles.ChartMargins
Telerik.Reporting.Charting.Styles.ChartMarginsLegend
Telerik.Reporting.Charting.Styles.ChartMarginsPlotArea
Telerik.Reporting.Charting.Styles.ChartMarginsTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMargins Members
Telerik.Reporting.Charting.Styles Namespace


ChartMargins Class Members

ChartMargins Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMargins Class

The following tables list the members exposed by ChartMargins.

Public Constructors

 | Name | Description
Public Constructor | ChartMargins Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Bottom | (Inherited from LayoutDecoratorBase)
Public Property | Left | (Inherited from LayoutDecoratorBase)
Public Property | Right | (Inherited from LayoutDecoratorBase)
Public Property | Top | (Inherited from LayoutDecoratorBase)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
static (Shared in Visual Basic) | Parse | Overloaded.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Operators

Public Operator Implicit Type Conversion
Top

See Also

Reference

ChartMargins Class
Telerik.Reporting.Charting.Styles Namespace


ChartMargins Constructor

ChartMargins Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMargins Class : ChartMargins Constructor

Overload List

Overload | Description
ChartMargins Constructor() |
ChartMargins Constructor(Int32,Int32,Int32,Int32) |
ChartMargins Constructor(Object) |
ChartMargins Constructor(Object,Unit,Unit,Unit,Unit) |
ChartMargins Constructor(Unit) |
ChartMargins Constructor(Unit,Unit,Unit,Unit) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMargins Class
ChartMargins Members


ChartMargins Constructor()

ChartMargins Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMargins Class > ChartMargins Constructor : ChartMargins Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMargins()
C#
public ChartMargins()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMargins()
C#
public ChartMargins()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMargins Class
ChartMargins Members
Overload List


ChartMargins Constructor(Int32,Int32,Int32,Int32)

ChartMargins Constructor(Int32,Int32,Int32,Int32)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMargins Class > ChartMargins Constructor : ChartMargins Constructor(Int32,Int32,Int32,Int32)

top
right
bottom
left

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer, _
   ByVal left As Integer _
)
Visual Basic (Usage) Copy Code
Dim top As Integer
Dim right As Integer
Dim bottom As Integer
Dim left As Integer

Dim instance As ChartMargins(top, right, bottom, left)
C#
public ChartMargins(
   int top,
   int right,
   int bottom,
   int left
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer, _
   ByVal left As Integer _
)
Visual Basic (Usage) Copy Code
Dim top As Integer
Dim right As Integer
Dim bottom As Integer
Dim left As Integer

Dim instance As ChartMargins(top, right, bottom, left)
C#
public ChartMargins(
   int top,
   int right,
   int bottom,
   int left
)

Parameters

top
right
bottom
left

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMargins Class
ChartMargins Members
Overload List


ChartMargins Constructor(Object)

ChartMargins Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMargins Class > ChartMargins Constructor : ChartMargins Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As ChartMargins(containerObject)
C#
public ChartMargins(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As ChartMargins(containerObject)
C#
public ChartMargins(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMargins Class
ChartMargins Members
Overload List


ChartMargins Constructor(Object,Unit,Unit,Unit,Unit)

ChartMargins Constructor(Object,Unit,Unit,Unit,Unit)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMargins Class > ChartMargins Constructor : ChartMargins Constructor(Object,Unit,Unit,Unit,Unit)

containerObject
top
right
bottom
left

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object, _
   ByVal top As Unit, _
   ByVal right As Unit, _
   ByVal bottom As Unit, _
   ByVal left As Unit _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object
Dim top As Unit
Dim right As Unit
Dim bottom As Unit
Dim left As Unit

Dim instance As ChartMargins(containerObject, top, right, bottom, left)
C#
public ChartMargins(
   object containerObject,
   Unit top,
   Unit right,
   Unit bottom,
   Unit left
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object, _
   ByVal top As Unit, _
   ByVal right As Unit, _
   ByVal bottom As Unit, _
   ByVal left As Unit _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object
Dim top As Unit
Dim right As Unit
Dim bottom As Unit
Dim left As Unit

Dim instance As ChartMargins(containerObject, top, right, bottom, left)
C#
public ChartMargins(
   object containerObject,
   Unit top,
   Unit right,
   Unit bottom,
   Unit left
)

Parameters

containerObject
top
right
bottom
left

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMargins Class
ChartMargins Members
Overload List


ChartMargins Constructor(Unit)

ChartMargins Constructor(Unit)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMargins Class > ChartMargins Constructor : ChartMargins Constructor(Unit)

margin

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal margin As Unit _
)
Visual Basic (Usage) Copy Code
Dim margin As Unit

Dim instance As ChartMargins(margin)
C#
public ChartMargins(
   Unit margin
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal margin As Unit _
)
Visual Basic (Usage) Copy Code
Dim margin As Unit

Dim instance As ChartMargins(margin)
C#
public ChartMargins(
   Unit margin
)

Parameters

margin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMargins Class
ChartMargins Members
Overload List


ChartMargins Constructor(Unit,Unit,Unit,Unit)

ChartMargins Constructor(Unit,Unit,Unit,Unit)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMargins Class > ChartMargins Constructor : ChartMargins Constructor(Unit,Unit,Unit,Unit)

top
right
bottom
left

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal top As Unit, _
   ByVal right As Unit, _
   ByVal bottom As Unit, _
   ByVal left As Unit _
)
Visual Basic (Usage) Copy Code
Dim top As Unit
Dim right As Unit
Dim bottom As Unit
Dim left As Unit

Dim instance As ChartMargins(top, right, bottom, left)
C#
public ChartMargins(
   Unit top,
   Unit right,
   Unit bottom,
   Unit left
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal top As Unit, _
   ByVal right As Unit, _
   ByVal bottom As Unit, _
   ByVal left As Unit _
)
Visual Basic (Usage) Copy Code
Dim top As Unit
Dim right As Unit
Dim bottom As Unit
Dim left As Unit

Dim instance As ChartMargins(top, right, bottom, left)
C#
public ChartMargins(
   Unit top,
   Unit right,
   Unit bottom,
   Unit left
)

Parameters

top
right
bottom
left

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMargins Class
ChartMargins Members
Overload List


ChartMargins Class Methods

ChartMargins Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMargins Class

For a list of all members of this type, see ChartMargins members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
static (Shared in Visual Basic) | Parse | Overloaded.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartMargins Class
Telerik.Reporting.Charting.Styles Namespace


Parse Method

Parse Method
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMargins Class : Parse Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Parse(String) |
Parse(String,CultureInfo) |

Overload List

Overload | Description
Parse(String) |
Parse(String,CultureInfo) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMargins Class
ChartMargins Members


Parse(String) Method

Parse(String) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMargins Class > Parse Method : Parse(String) Method

value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Parse( _
   ByVal value As String _
) As ChartMargins
Visual Basic (Usage) Copy Code
Dim value As String
Dim value As ChartMargins

value = ChartMargins.Parse(value)
C#
public static ChartMargins Parse(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMargins Class
ChartMargins Members
Overload List


Parse(String,CultureInfo) Method

Parse(String,CultureInfo) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMargins Class > Parse Method : Parse(String,CultureInfo) Method

value
culture

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Parse( _
   ByVal value As String, _
   ByVal culture As CultureInfo _
) As ChartMargins
Visual Basic (Usage) Copy Code
Dim value As String
Dim culture As CultureInfo
Dim value As ChartMargins

value = ChartMargins.Parse(value, culture)
C#
public static ChartMargins Parse(
   string value,
   CultureInfo culture
)

Parameters

value
culture

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMargins Class
ChartMargins Members
Overload List


Implicit Type Conversion Operator

Implicit Type Conversion Operator
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMargins Class : Implicit Type Conversion Operator

value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal value As String _
) As ChartMargins
C#
public ChartMargins operator implicit(
   string value
)

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal value As String _
) As ChartMargins
C#
public ChartMargins operator implicit(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMargins Class
ChartMargins Members


ChartMarginsLegend Class

ChartMarginsLegend Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMarginsLegend Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartMarginsLegend
   Inherits ChartMargins
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsLegend
C#
public class ChartMarginsLegend : ChartMargins, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles.ChartMargins
Telerik.Reporting.Charting.Styles.ChartMarginsLegend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsLegend Members
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsLegend Class Members

ChartMarginsLegend Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMarginsLegend Class

The following tables list the members exposed by ChartMarginsLegend.

Public Constructors

 | Name | Description
Public Constructor | ChartMarginsLegend Constructor |
Top

Public Properties

 | Name | Description
Public Property | Bottom | (Inherited from LayoutDecoratorBase)
Public Property | Left | (Inherited from LayoutDecoratorBase)
Public Property | Right | Overridden.
Public Property | Top | (Inherited from LayoutDecoratorBase)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartMarginsLegend Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsLegend Constructor

ChartMarginsLegend Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMarginsLegend Class : ChartMarginsLegend Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsLegend()
C#
public ChartMarginsLegend()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsLegend()
C#
public ChartMarginsLegend()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsLegend Class
ChartMarginsLegend Members


ChartMarginsLegend Class Properties

ChartMarginsLegend Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMarginsLegend Class

For a list of all members of this type, see ChartMarginsLegend members.

Public Properties

 | Name | Description
Public Property | Bottom | (Inherited from LayoutDecoratorBase)
Public Property | Left | (Inherited from LayoutDecoratorBase)
Public Property | Right | Overridden.
Public Property | Top | (Inherited from LayoutDecoratorBase)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartMarginsLegend Class
Telerik.Reporting.Charting.Styles Namespace


Right Property

Right Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMarginsLegend Class : Right Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Right As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsLegend
Dim value As Unit

instance.Right = value

value = instance.Right
C#
public override Unit Right {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsLegend Class
ChartMarginsLegend Members


ChartMarginsPlotArea Class

ChartMarginsPlotArea Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMarginsPlotArea Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartMarginsPlotArea
   Inherits ChartMargins
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsPlotArea
C#
public class ChartMarginsPlotArea : ChartMargins, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles.ChartMargins
Telerik.Reporting.Charting.Styles.ChartMarginsPlotArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsPlotArea Members
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsPlotArea Class Members

ChartMarginsPlotArea Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMarginsPlotArea Class

The following tables list the members exposed by ChartMarginsPlotArea.

Public Constructors

 | Name | Description
Public Constructor | ChartMarginsPlotArea Constructor |
Top

Public Properties

 | Name | Description
Public Property | Bottom | Overridden.
Public Property | Left | Overridden.
Public Property | Right | Overridden.
Public Property | Top | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartMarginsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsPlotArea Constructor

ChartMarginsPlotArea Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMarginsPlotArea Class : ChartMarginsPlotArea Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsPlotArea()
C#
public ChartMarginsPlotArea()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsPlotArea()
C#
public ChartMarginsPlotArea()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsPlotArea Class
ChartMarginsPlotArea Members


ChartMarginsPlotArea Class Properties

ChartMarginsPlotArea Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMarginsPlotArea Class

For a list of all members of this type, see ChartMarginsPlotArea members.

Public Properties

 | Name | Description
Public Property | Bottom | Overridden.
Public Property | Left | Overridden.
Public Property | Right | Overridden.
Public Property | Top | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartMarginsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Bottom Property

Bottom Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMarginsPlotArea Class : Bottom Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Bottom As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsPlotArea
Dim value As Unit

instance.Bottom = value

value = instance.Bottom
C#
public override Unit Bottom {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsPlotArea Class
ChartMarginsPlotArea Members


Left Property

Left Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMarginsPlotArea Class : Left Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Left As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsPlotArea
Dim value As Unit

instance.Left = value

value = instance.Left
C#
public override Unit Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsPlotArea Class
ChartMarginsPlotArea Members


Right Property

Right Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMarginsPlotArea Class : Right Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Right As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsPlotArea
Dim value As Unit

instance.Right = value

value = instance.Right
C#
public override Unit Right {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsPlotArea Class
ChartMarginsPlotArea Members


Top Property

Top Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMarginsPlotArea Class : Top Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Top As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsPlotArea
Dim value As Unit

instance.Top = value

value = instance.Top
C#
public override Unit Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsPlotArea Class
ChartMarginsPlotArea Members


ChartMarginsTitle Class

ChartMarginsTitle Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMarginsTitle Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartMarginsTitle
   Inherits ChartMargins
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsTitle
C#
public class ChartMarginsTitle : ChartMargins, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles.ChartMargins
Telerik.Reporting.Charting.Styles.ChartMarginsTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsTitle Members
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsTitle Class Members

ChartMarginsTitle Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMarginsTitle Class

The following tables list the members exposed by ChartMarginsTitle.

Public Constructors

 | Name | Description
Public Constructor | ChartMarginsTitle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Bottom | Overridden.
Public Property | Left | Overridden.
Public Property | Right | Overridden.
Public Property | Top | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartMarginsTitle Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsTitle Constructor

ChartMarginsTitle Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMarginsTitle Class : ChartMarginsTitle Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsTitle()
C#
public ChartMarginsTitle()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsTitle()
C#
public ChartMarginsTitle()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsTitle Class
ChartMarginsTitle Members


ChartMarginsTitle Class Properties

ChartMarginsTitle Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMarginsTitle Class

For a list of all members of this type, see ChartMarginsTitle members.

Public Properties

 | Name | Description
Public Property | Bottom | Overridden.
Public Property | Left | Overridden.
Public Property | Right | Overridden.
Public Property | Top | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartMarginsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Bottom Property

Bottom Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMarginsTitle Class : Bottom Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Bottom As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsTitle
Dim value As Unit

instance.Bottom = value

value = instance.Bottom
C#
public override Unit Bottom {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsTitle Class
ChartMarginsTitle Members


Left Property

Left Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMarginsTitle Class : Left Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Left As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsTitle
Dim value As Unit

instance.Left = value

value = instance.Left
C#
public override Unit Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsTitle Class
ChartMarginsTitle Members


Right Property

Right Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMarginsTitle Class : Right Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Right As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsTitle
Dim value As Unit

instance.Right = value

value = instance.Right
C#
public override Unit Right {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsTitle Class
ChartMarginsTitle Members


Top Property

Top Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartMarginsTitle Class : Top Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Top As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginsTitle
Dim value As Unit

instance.Top = value

value = instance.Top
C#
public override Unit Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartMarginsTitle Class
ChartMarginsTitle Members


ChartPaddings Class

ChartPaddings Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartPaddings Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartPaddings
   Inherits LayoutDecoratorBase
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddings
C#
public class ChartPaddings : LayoutDecoratorBase, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles.ChartPaddings
Telerik.Reporting.Charting.Styles.ChartPaddingsLegend
Telerik.Reporting.Charting.Styles.ChartPaddingsTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddings Members
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Class Members

ChartPaddings Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartPaddings Class

The following tables list the members exposed by ChartPaddings.

Public Constructors

 | Name | Description
Public Constructor | ChartPaddings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Bottom | (Inherited from LayoutDecoratorBase)
Public Property | Left | (Inherited from LayoutDecoratorBase)
Public Property | Right | (Inherited from LayoutDecoratorBase)
Public Property | Top | (Inherited from LayoutDecoratorBase)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
static (Shared in Visual Basic) | Parse | Overloaded.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Operators

Public Operator Implicit Type Conversion
Top

See Also

Reference

ChartPaddings Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Constructor

ChartPaddings Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddings Class : ChartPaddings Constructor

Overload List

Overload | Description
ChartPaddings Constructor() |
ChartPaddings Constructor(Int32,Int32,Int32,Int32) |
ChartPaddings Constructor(Object) |
ChartPaddings Constructor(Object,Unit,Unit,Unit,Unit) |
ChartPaddings Constructor(Unit) |
ChartPaddings Constructor(Unit,Unit,Unit,Unit) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddings Class
ChartPaddings Members


ChartPaddings Constructor()

ChartPaddings Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddings Class > ChartPaddings Constructor : ChartPaddings Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddings()
C#
public ChartPaddings()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddings()
C#
public ChartPaddings()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddings Class
ChartPaddings Members
Overload List


ChartPaddings Constructor(Int32,Int32,Int32,Int32)

ChartPaddings Constructor(Int32,Int32,Int32,Int32)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddings Class > ChartPaddings Constructor : ChartPaddings Constructor(Int32,Int32,Int32,Int32)

top
right
bottom
left

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer, _
   ByVal left As Integer _
)
Visual Basic (Usage) Copy Code
Dim top As Integer
Dim right As Integer
Dim bottom As Integer
Dim left As Integer

Dim instance As ChartPaddings(top, right, bottom, left)
C#
public ChartPaddings(
   int top,
   int right,
   int bottom,
   int left
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer, _
   ByVal left As Integer _
)
Visual Basic (Usage) Copy Code
Dim top As Integer
Dim right As Integer
Dim bottom As Integer
Dim left As Integer

Dim instance As ChartPaddings(top, right, bottom, left)
C#
public ChartPaddings(
   int top,
   int right,
   int bottom,
   int left
)

Parameters

top
right
bottom
left

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddings Class
ChartPaddings Members
Overload List


ChartPaddings Constructor(Object)

ChartPaddings Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddings Class > ChartPaddings Constructor : ChartPaddings Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As ChartPaddings(containerObject)
C#
public ChartPaddings(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As ChartPaddings(containerObject)
C#
public ChartPaddings(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddings Class
ChartPaddings Members
Overload List


ChartPaddings Constructor(Object,Unit,Unit,Unit,Unit)

ChartPaddings Constructor(Object,Unit,Unit,Unit,Unit)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddings Class > ChartPaddings Constructor : ChartPaddings Constructor(Object,Unit,Unit,Unit,Unit)

containerObject
top
right
bottom
left

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object, _
   ByVal top As Unit, _
   ByVal right As Unit, _
   ByVal bottom As Unit, _
   ByVal left As Unit _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object
Dim top As Unit
Dim right As Unit
Dim bottom As Unit
Dim left As Unit

Dim instance As ChartPaddings(containerObject, top, right, bottom, left)
C#
public ChartPaddings(
   object containerObject,
   Unit top,
   Unit right,
   Unit bottom,
   Unit left
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object, _
   ByVal top As Unit, _
   ByVal right As Unit, _
   ByVal bottom As Unit, _
   ByVal left As Unit _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object
Dim top As Unit
Dim right As Unit
Dim bottom As Unit
Dim left As Unit

Dim instance As ChartPaddings(containerObject, top, right, bottom, left)
C#
public ChartPaddings(
   object containerObject,
   Unit top,
   Unit right,
   Unit bottom,
   Unit left
)

Parameters

containerObject
top
right
bottom
left

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddings Class
ChartPaddings Members
Overload List


ChartPaddings Constructor(Unit)

ChartPaddings Constructor(Unit)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddings Class > ChartPaddings Constructor : ChartPaddings Constructor(Unit)

margin

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal margin As Unit _
)
Visual Basic (Usage) Copy Code
Dim margin As Unit

Dim instance As ChartPaddings(margin)
C#
public ChartPaddings(
   Unit margin
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal margin As Unit _
)
Visual Basic (Usage) Copy Code
Dim margin As Unit

Dim instance As ChartPaddings(margin)
C#
public ChartPaddings(
   Unit margin
)

Parameters

margin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddings Class
ChartPaddings Members
Overload List


ChartPaddings Constructor(Unit,Unit,Unit,Unit)

ChartPaddings Constructor(Unit,Unit,Unit,Unit)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddings Class > ChartPaddings Constructor : ChartPaddings Constructor(Unit,Unit,Unit,Unit)

top
right
bottom
left

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal top As Unit, _
   ByVal right As Unit, _
   ByVal bottom As Unit, _
   ByVal left As Unit _
)
Visual Basic (Usage) Copy Code
Dim top As Unit
Dim right As Unit
Dim bottom As Unit
Dim left As Unit

Dim instance As ChartPaddings(top, right, bottom, left)
C#
public ChartPaddings(
   Unit top,
   Unit right,
   Unit bottom,
   Unit left
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal top As Unit, _
   ByVal right As Unit, _
   ByVal bottom As Unit, _
   ByVal left As Unit _
)
Visual Basic (Usage) Copy Code
Dim top As Unit
Dim right As Unit
Dim bottom As Unit
Dim left As Unit

Dim instance As ChartPaddings(top, right, bottom, left)
C#
public ChartPaddings(
   Unit top,
   Unit right,
   Unit bottom,
   Unit left
)

Parameters

top
right
bottom
left

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddings Class
ChartPaddings Members
Overload List


ChartPaddings Class Methods

ChartPaddings Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartPaddings Class

For a list of all members of this type, see ChartPaddings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
static (Shared in Visual Basic) | Parse | Overloaded.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartPaddings Class
Telerik.Reporting.Charting.Styles Namespace


Parse Method

Parse Method
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddings Class : Parse Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Parse(String) |
Parse(String,CultureInfo) |

Overload List

Overload | Description
Parse(String) |
Parse(String,CultureInfo) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddings Class
ChartPaddings Members


Parse(String) Method

Parse(String) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddings Class > Parse Method : Parse(String) Method

value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Parse( _
   ByVal value As String _
) As ChartPaddings
Visual Basic (Usage) Copy Code
Dim value As String
Dim value As ChartPaddings

value = ChartPaddings.Parse(value)
C#
public static ChartPaddings Parse(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddings Class
ChartPaddings Members
Overload List


Parse(String,CultureInfo) Method

Parse(String,CultureInfo) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddings Class > Parse Method : Parse(String,CultureInfo) Method

value
culture

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Parse( _
   ByVal value As String, _
   ByVal culture As CultureInfo _
) As ChartPaddings
Visual Basic (Usage) Copy Code
Dim value As String
Dim culture As CultureInfo
Dim value As ChartPaddings

value = ChartPaddings.Parse(value, culture)
C#
public static ChartPaddings Parse(
   string value,
   CultureInfo culture
)

Parameters

value
culture

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddings Class
ChartPaddings Members
Overload List


Implicit Type Conversion Operator

Implicit Type Conversion Operator
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddings Class : Implicit Type Conversion Operator

value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal value As String _
) As ChartPaddings
C#
public ChartPaddings operator implicit(
   string value
)

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal value As String _
) As ChartPaddings
C#
public ChartPaddings operator implicit(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddings Class
ChartPaddings Members


ChartPaddingsLegend Class

ChartPaddingsLegend Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartPaddingsLegend Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartPaddingsLegend
   Inherits ChartPaddings
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsLegend
C#
public class ChartPaddingsLegend : ChartPaddings, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles.ChartPaddings
Telerik.Reporting.Charting.Styles.ChartPaddingsLegend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddingsLegend Members
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsLegend Class Members

ChartPaddingsLegend Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartPaddingsLegend Class

The following tables list the members exposed by ChartPaddingsLegend.

Public Constructors

 | Name | Description
Public Constructor | ChartPaddingsLegend Constructor |
Top

Public Properties

 | Name | Description
Public Property | Bottom | Overridden.
Public Property | Left | Overridden.
Public Property | Right | Overridden.
Public Property | Top | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartPaddingsLegend Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsLegend Constructor

ChartPaddingsLegend Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddingsLegend Class : ChartPaddingsLegend Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsLegend()
C#
public ChartPaddingsLegend()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsLegend()
C#
public ChartPaddingsLegend()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddingsLegend Class
ChartPaddingsLegend Members


ChartPaddingsLegend Class Properties

ChartPaddingsLegend Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartPaddingsLegend Class

For a list of all members of this type, see ChartPaddingsLegend members.

Public Properties

 | Name | Description
Public Property | Bottom | Overridden.
Public Property | Left | Overridden.
Public Property | Right | Overridden.
Public Property | Top | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartPaddingsLegend Class
Telerik.Reporting.Charting.Styles Namespace


Bottom Property

Bottom Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddingsLegend Class : Bottom Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Bottom As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsLegend
Dim value As Unit

instance.Bottom = value

value = instance.Bottom
C#
public override Unit Bottom {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddingsLegend Class
ChartPaddingsLegend Members


Left Property

Left Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddingsLegend Class : Left Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Left As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsLegend
Dim value As Unit

instance.Left = value

value = instance.Left
C#
public override Unit Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddingsLegend Class
ChartPaddingsLegend Members


Right Property

Right Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddingsLegend Class : Right Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Right As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsLegend
Dim value As Unit

instance.Right = value

value = instance.Right
C#
public override Unit Right {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddingsLegend Class
ChartPaddingsLegend Members


Top Property

Top Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddingsLegend Class : Top Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Top As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsLegend
Dim value As Unit

instance.Top = value

value = instance.Top
C#
public override Unit Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddingsLegend Class
ChartPaddingsLegend Members


ChartPaddingsTitle Class

ChartPaddingsTitle Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartPaddingsTitle Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartPaddingsTitle
   Inherits ChartPaddings
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsTitle
C#
public class ChartPaddingsTitle : ChartPaddings, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles.ChartPaddings
Telerik.Reporting.Charting.Styles.ChartPaddingsTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddingsTitle Members
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsTitle Class Members

ChartPaddingsTitle Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartPaddingsTitle Class

The following tables list the members exposed by ChartPaddingsTitle.

Public Constructors

 | Name | Description
Public Constructor | ChartPaddingsTitle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Bottom | Overridden.
Public Property | Left | Overridden.
Public Property | Right | Overridden.
Public Property | Top | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartPaddingsTitle Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsTitle Constructor

ChartPaddingsTitle Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddingsTitle Class : ChartPaddingsTitle Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsTitle()
C#
public ChartPaddingsTitle()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsTitle()
C#
public ChartPaddingsTitle()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddingsTitle Class
ChartPaddingsTitle Members


ChartPaddingsTitle Class Properties

ChartPaddingsTitle Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartPaddingsTitle Class

For a list of all members of this type, see ChartPaddingsTitle members.

Public Properties

 | Name | Description
Public Property | Bottom | Overridden.
Public Property | Left | Overridden.
Public Property | Right | Overridden.
Public Property | Top | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartPaddingsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Bottom Property

Bottom Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddingsTitle Class : Bottom Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Bottom As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsTitle
Dim value As Unit

instance.Bottom = value

value = instance.Bottom
C#
public override Unit Bottom {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddingsTitle Class
ChartPaddingsTitle Members


Left Property

Left Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddingsTitle Class : Left Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Left As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsTitle
Dim value As Unit

instance.Left = value

value = instance.Left
C#
public override Unit Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddingsTitle Class
ChartPaddingsTitle Members


Right Property

Right Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddingsTitle Class : Right Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Right As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsTitle
Dim value As Unit

instance.Right = value

value = instance.Right
C#
public override Unit Right {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddingsTitle Class
ChartPaddingsTitle Members


Top Property

Top Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartPaddingsTitle Class : Top Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Top As Unit
Visual Basic (Usage) Copy Code
Dim instance As ChartPaddingsTitle
Dim value As Unit

instance.Top = value

value = instance.Top
C#
public override Unit Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartPaddingsTitle Class
ChartPaddingsTitle Members


ChartSkin Class

ChartSkin Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartSkin Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ChartSkin
Visual Basic (Usage) Copy Code
Dim instance As ChartSkin
C#
public class ChartSkin

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.Styles.ChartSkin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSkin Members
Telerik.Reporting.Charting.Styles Namespace


ChartSkin Class Members

ChartSkin Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartSkin Class

The following tables list the members exposed by ChartSkin.

Public Constructors

 | Name | Description
Public Constructor | ChartSkin Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Name |
Public Property | XmlSource |
Top

Public Methods

 | Name | Description
Public Method | ApplyTo |
Public Method | CreateFromChart |
Top

See Also

Reference

ChartSkin Class
Telerik.Reporting.Charting.Styles Namespace


ChartSkin Constructor

ChartSkin Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartSkin Class : ChartSkin Constructor

Overload List

Overload | Description
ChartSkin Constructor() |
ChartSkin Constructor(String) |
ChartSkin Constructor(XmlDocument) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSkin Class
ChartSkin Members


ChartSkin Constructor()

ChartSkin Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartSkin Class > ChartSkin Constructor : ChartSkin Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartSkin()
C#
public ChartSkin()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ChartSkin()
C#
public ChartSkin()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSkin Class
ChartSkin Members
Overload List


ChartSkin Constructor(String)

ChartSkin Constructor(String)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartSkin Class > ChartSkin Constructor : ChartSkin Constructor(String)

name

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As ChartSkin(name)
C#
public ChartSkin(
   string name
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As ChartSkin(name)
C#
public ChartSkin(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSkin Class
ChartSkin Members
Overload List


ChartSkin Constructor(XmlDocument)

ChartSkin Constructor(XmlDocument)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartSkin Class > ChartSkin Constructor : ChartSkin Constructor(XmlDocument)

source

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As XmlDocument _
)
Visual Basic (Usage) Copy Code
Dim source As XmlDocument

Dim instance As ChartSkin(source)
C#
public ChartSkin(
   XmlDocument source
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As XmlDocument _
)
Visual Basic (Usage) Copy Code
Dim source As XmlDocument

Dim instance As ChartSkin(source)
C#
public ChartSkin(
   XmlDocument source
)

Parameters

source

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSkin Class
ChartSkin Members
Overload List


ChartSkin Class Methods

ChartSkin Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartSkin Class

For a list of all members of this type, see ChartSkin members.

Public Methods

 | Name | Description
Public Method | ApplyTo |
Public Method | CreateFromChart |
Top

See Also

Reference

ChartSkin Class
Telerik.Reporting.Charting.Styles Namespace


ApplyTo Method

ApplyTo Method
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartSkin Class : ApplyTo Method

chart

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub ApplyTo( _
   ByVal chart As Chart _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSkin
Dim chart As Chart

instance.ApplyTo(chart)
C#
public void ApplyTo(
   Chart chart
)

Parameters

chart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSkin Class
ChartSkin Members


CreateFromChart Method

CreateFromChart Method
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartSkin Class : CreateFromChart Method

chart
name

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateFromChart( _
   ByVal chart As Chart, _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSkin
Dim chart As Chart
Dim name As String

instance.CreateFromChart(chart, name)
C#
public void CreateFromChart(
   Chart chart,
   string name
)

Parameters

chart
name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSkin Class
ChartSkin Members


ChartSkin Class Properties

ChartSkin Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartSkin Class

For a list of all members of this type, see ChartSkin members.

Public Properties

 | Name | Description
Public Property | Name |
Public Property | XmlSource |
Top

See Also

Reference

ChartSkin Class
Telerik.Reporting.Charting.Styles Namespace


Name Property

Name Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartSkin Class : Name Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ChartSkin
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSkin Class
ChartSkin Members


XmlSource Property

XmlSource Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ChartSkin Class : XmlSource Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlSource As XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As ChartSkin
Dim value As XmlDocument

instance.XmlSource = value

value = instance.XmlSource
C#
public XmlDocument XmlSource {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSkin Class
ChartSkin Members


Corners Class

Corners Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : Corners Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Corners
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As Corners
C#
public class Corners : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Corners

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Members
Telerik.Reporting.Charting.Styles Namespace


Corners Class Members

Corners Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : Corners Class

The following tables list the members exposed by Corners.

Public Constructors

 | Name | Description
Public Constructor | Corners Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | BottomLeft |
Public Property | BottomRight |
Public Property | RoundSize |
Public Property | TopLeft |
Public Property | TopRight |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
static (Shared in Visual Basic) | Parse | Overloaded.
Public Method | SetCornersType |
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | CopyFrom |
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Operators

Public Operator Implicit Type Conversion
Top

See Also

Reference

Corners Class
Telerik.Reporting.Charting.Styles Namespace


Corners Constructor

Corners Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class : Corners Constructor

Overload List

Overload | Description
Corners Constructor() |
Corners Constructor(CornerType,CornerType,CornerType,CornerType,Int32) |
Corners Constructor(Int32) |
Corners Constructor(Object) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members


Corners Constructor()

Corners Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class > Corners Constructor : Corners Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Corners()
C#
public Corners()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Corners()
C#
public Corners()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members
Overload List


Corners Constructor(CornerType,CornerType,CornerType,CornerType,Int32)

Corners Constructor(CornerType,CornerType,CornerType,CornerType,Int32)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class > Corners Constructor : Corners Constructor(CornerType,CornerType,CornerType,CornerType,Int32)

topLeft
topRight
bottomLeft
bottomRight
roundSize

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal topLeft As CornerType, _
   ByVal topRight As CornerType, _
   ByVal bottomLeft As CornerType, _
   ByVal bottomRight As CornerType, _
   ByVal roundSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim topLeft As CornerType
Dim topRight As CornerType
Dim bottomLeft As CornerType
Dim bottomRight As CornerType
Dim roundSize As Integer

Dim instance As Corners(topLeft, topRight, bottomLeft, bottomRight, roundSize)
C#
public Corners(
   CornerType topLeft,
   CornerType topRight,
   CornerType bottomLeft,
   CornerType bottomRight,
   int roundSize
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal topLeft As CornerType, _
   ByVal topRight As CornerType, _
   ByVal bottomLeft As CornerType, _
   ByVal bottomRight As CornerType, _
   ByVal roundSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim topLeft As CornerType
Dim topRight As CornerType
Dim bottomLeft As CornerType
Dim bottomRight As CornerType
Dim roundSize As Integer

Dim instance As Corners(topLeft, topRight, bottomLeft, bottomRight, roundSize)
C#
public Corners(
   CornerType topLeft,
   CornerType topRight,
   CornerType bottomLeft,
   CornerType bottomRight,
   int roundSize
)

Parameters

topLeft
topRight
bottomLeft
bottomRight
roundSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members
Overload List


Corners Constructor(Int32)

Corners Constructor(Int32)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class > Corners Constructor : Corners Constructor(Int32)

roundSize

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal roundSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim roundSize As Integer

Dim instance As Corners(roundSize)
C#
public Corners(
   int roundSize
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal roundSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim roundSize As Integer

Dim instance As Corners(roundSize)
C#
public Corners(
   int roundSize
)

Parameters

roundSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members
Overload List


Corners Constructor(Object)

Corners Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class > Corners Constructor : Corners Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As Corners(containerObject)
C#
public Corners(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As Corners(containerObject)
C#
public Corners(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members
Overload List


Corners Class Methods

Corners Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : Corners Class

For a list of all members of this type, see Corners members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
static (Shared in Visual Basic) | Parse | Overloaded.
Public Method | SetCornersType |
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | CopyFrom |
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

Corners Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As Corners
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members


CopyFrom Method

CopyFrom Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class : CopyFrom Method

sourceCorners

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Sub CopyFrom( _
   ByVal sourceCorners As Corners _
)
Visual Basic (Usage) Copy Code
Dim instance As Corners
Dim sourceCorners As Corners

instance.CopyFrom(sourceCorners)
C#
protected void CopyFrom(
   Corners sourceCorners
)

Parameters

sourceCorners

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Corners
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Corners
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members


Parse Method

Parse Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class : Parse Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Parse(String) |
Parse(String,CultureInfo) |

Overload List

Overload | Description
Parse(String) |
Parse(String,CultureInfo) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members


Parse(String) Method

Parse(String) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class > Parse Method : Parse(String) Method

value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Parse( _
   ByVal value As String _
) As Corners
Visual Basic (Usage) Copy Code
Dim value As String
Dim value As Corners

value = Corners.Parse(value)
C#
public static Corners Parse(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members
Overload List


Parse(String,CultureInfo) Method

Parse(String,CultureInfo) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class > Parse Method : Parse(String,CultureInfo) Method

value
culture

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Parse( _
   ByVal value As String, _
   ByVal culture As CultureInfo _
) As Corners
Visual Basic (Usage) Copy Code
Dim value As String
Dim culture As CultureInfo
Dim value As Corners

value = Corners.Parse(value, culture)
C#
public static Corners Parse(
   string value,
   CultureInfo culture
)

Parameters

value
culture

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members
Overload List


SetCornersType Method

SetCornersType Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class : SetCornersType Method

cornerType

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetCornersType( _
   ByVal cornerType As CornerType _
)
Visual Basic (Usage) Copy Code
Dim instance As Corners
Dim cornerType As CornerType

instance.SetCornersType(cornerType)
C#
public void SetCornersType(
   CornerType cornerType
)

Parameters

cornerType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members


Corners Class Properties

Corners Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : Corners Class

For a list of all members of this type, see Corners members.

Public Properties

 | Name | Description
Public Property | BottomLeft |
Public Property | BottomRight |
Public Property | RoundSize |
Public Property | TopLeft |
Public Property | TopRight |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

Corners Class
Telerik.Reporting.Charting.Styles Namespace


BottomLeft Property

BottomLeft Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class : BottomLeft Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property BottomLeft As CornerType
Visual Basic (Usage) Copy Code
Dim instance As Corners
Dim value As CornerType

instance.BottomLeft = value

value = instance.BottomLeft
C#
public CornerType BottomLeft {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members


BottomRight Property

BottomRight Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class : BottomRight Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property BottomRight As CornerType
Visual Basic (Usage) Copy Code
Dim instance As Corners
Dim value As CornerType

instance.BottomRight = value

value = instance.BottomRight
C#
public CornerType BottomRight {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members


RoundSize Property

RoundSize Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class : RoundSize Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property RoundSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As Corners
Dim value As Integer

instance.RoundSize = value

value = instance.RoundSize
C#
public int RoundSize {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members


TopLeft Property

TopLeft Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class : TopLeft Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property TopLeft As CornerType
Visual Basic (Usage) Copy Code
Dim instance As Corners
Dim value As CornerType

instance.TopLeft = value

value = instance.TopLeft
C#
public CornerType TopLeft {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members


TopRight Property

TopRight Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class : TopRight Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property TopRight As CornerType
Visual Basic (Usage) Copy Code
Dim instance As Corners
Dim value As CornerType

instance.TopRight = value

value = instance.TopRight
C#
public CornerType TopRight {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members


Implicit Type Conversion Operator

Implicit Type Conversion Operator
[image]
Telerik.Reporting.Charting.Styles Namespace > Corners Class : Implicit Type Conversion Operator

value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal value As String _
) As Corners
C#
public Corners operator implicit(
   string value
)

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal value As String _
) As Corners
C#
public Corners operator implicit(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Corners Class
Corners Members


Dimensions Class

Dimensions Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : Dimensions Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Dimensions
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
C#
public class Dimensions : StateManagedObject, IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Dimensions
Telerik.Reporting.Charting.Styles.DimensionsChart
Telerik.Reporting.Charting.Styles.DimensionsLegend
Telerik.Reporting.Charting.Styles.DimensionsMarker
Telerik.Reporting.Charting.Styles.DimensionsPlotArea
Telerik.Reporting.Charting.Styles.DimensionsSeriesPointMark
Telerik.Reporting.Charting.Styles.DimensionsTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Members
Telerik.Reporting.Charting.Styles Namespace


Dimensions Class Members

Dimensions Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : Dimensions Class

The following tables list the members exposed by Dimensions.

Public Constructors

 | Name | Description
Public Constructor | Dimensions Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins |
Protected Field | dimensionsPaddings |
Top

Public Properties

 | Name | Description
Public Property | AutoSize |
Public Property | Height |
Public Property | Margins |
Public Property | Paddings |
Public Property | Width |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | IsZero |
Public Method | SetDimensions | Overloaded.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | ResetHeight |
Protected Method | ResetWidth |
Protected Method | SaveViewState | Overridden.
Protected Method | ShouldSerializeHeight |
Protected Method | ShouldSerializeWidth |
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


Dimensions Constructor

Dimensions Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : Dimensions Constructor

Overload List

Overload | Description
Dimensions Constructor() |
Dimensions Constructor(ChartMargins) |
Dimensions Constructor(ChartMargins,ChartPaddings) |
Dimensions Constructor(ChartPaddings) |
Dimensions Constructor(Object) |
Dimensions Constructor(Single,Single) |
Dimensions Constructor(Unit,Unit) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


Dimensions Constructor()

Dimensions Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class > Dimensions Constructor : Dimensions Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Dimensions()
C#
public Dimensions()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Dimensions()
C#
public Dimensions()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members
Overload List


Dimensions Constructor(ChartMargins)

Dimensions Constructor(ChartMargins)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class > Dimensions Constructor : Dimensions Constructor(ChartMargins)

margins

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal margins As ChartMargins _
)
Visual Basic (Usage) Copy Code
Dim margins As ChartMargins

Dim instance As Dimensions(margins)
C#
public Dimensions(
   ChartMargins margins
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal margins As ChartMargins _
)
Visual Basic (Usage) Copy Code
Dim margins As ChartMargins

Dim instance As Dimensions(margins)
C#
public Dimensions(
   ChartMargins margins
)

Parameters

margins

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members
Overload List


Dimensions Constructor(ChartMargins,ChartPaddings)

Dimensions Constructor(ChartMargins,ChartPaddings)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class > Dimensions Constructor : Dimensions Constructor(ChartMargins,ChartPaddings)

margins
paddings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal margins As ChartMargins, _
   ByVal paddings As ChartPaddings _
)
Visual Basic (Usage) Copy Code
Dim margins As ChartMargins
Dim paddings As ChartPaddings

Dim instance As Dimensions(margins, paddings)
C#
public Dimensions(
   ChartMargins margins,
   ChartPaddings paddings
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal margins As ChartMargins, _
   ByVal paddings As ChartPaddings _
)
Visual Basic (Usage) Copy Code
Dim margins As ChartMargins
Dim paddings As ChartPaddings

Dim instance As Dimensions(margins, paddings)
C#
public Dimensions(
   ChartMargins margins,
   ChartPaddings paddings
)

Parameters

margins
paddings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members
Overload List


Dimensions Constructor(ChartPaddings)

Dimensions Constructor(ChartPaddings)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class > Dimensions Constructor : Dimensions Constructor(ChartPaddings)

paddings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal paddings As ChartPaddings _
)
Visual Basic (Usage) Copy Code
Dim paddings As ChartPaddings

Dim instance As Dimensions(paddings)
C#
public Dimensions(
   ChartPaddings paddings
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal paddings As ChartPaddings _
)
Visual Basic (Usage) Copy Code
Dim paddings As ChartPaddings

Dim instance As Dimensions(paddings)
C#
public Dimensions(
   ChartPaddings paddings
)

Parameters

paddings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members
Overload List


Dimensions Constructor(Object)

Dimensions Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class > Dimensions Constructor : Dimensions Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As Dimensions(containerObject)
C#
public Dimensions(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As Dimensions(containerObject)
C#
public Dimensions(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members
Overload List


Dimensions Constructor(Single,Single)

Dimensions Constructor(Single,Single)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class > Dimensions Constructor : Dimensions Constructor(Single,Single)

width
height

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim width As Single
Dim height As Single

Dim instance As Dimensions(width, height)
C#
public Dimensions(
   float width,
   float height
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim width As Single
Dim height As Single

Dim instance As Dimensions(width, height)
C#
public Dimensions(
   float width,
   float height
)

Parameters

width
height

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members
Overload List


Dimensions Constructor(Unit,Unit)

Dimensions Constructor(Unit,Unit)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class > Dimensions Constructor : Dimensions Constructor(Unit,Unit)

width
height

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Unit, _
   ByVal height As Unit _
)
Visual Basic (Usage) Copy Code
Dim width As Unit
Dim height As Unit

Dim instance As Dimensions(width, height)
C#
public Dimensions(
   Unit width,
   Unit height
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Unit, _
   ByVal height As Unit _
)
Visual Basic (Usage) Copy Code
Dim width As Unit
Dim height As Unit

Dim instance As Dimensions(width, height)
C#
public Dimensions(
   Unit width,
   Unit height
)

Parameters

width
height

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members
Overload List


Dimensions Class Methods

Dimensions Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : Dimensions Class

For a list of all members of this type, see Dimensions members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | IsZero |
Public Method | SetDimensions | Overloaded.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | ResetHeight |
Protected Method | ResetWidth |
Protected Method | SaveViewState | Overridden.
Protected Method | ShouldSerializeHeight |
Protected Method | ShouldSerializeWidth |
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


IsZero Method

IsZero Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : IsZero Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function IsZero() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim value As Boolean

value = instance.IsZero()
C#
public bool IsZero()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


ResetHeight Method

ResetHeight Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : ResetHeight Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ResetHeight()
Visual Basic (Usage) Copy Code
Dim instance As Dimensions

instance.ResetHeight()
C#
protected virtual void ResetHeight()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


ResetWidth Method

ResetWidth Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : ResetWidth Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ResetWidth()
Visual Basic (Usage) Copy Code
Dim instance As Dimensions

instance.ResetWidth()
C#
protected virtual void ResetWidth()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


SetDimensions Method

SetDimensions Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : SetDimensions Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
SetDimensions(Single,Single) |
SetDimensions(Unit,Unit) |
SetDimensions(Dimensions) |

Overload List

Overload | Description
SetDimensions(Single,Single) |
SetDimensions(Unit,Unit) |
SetDimensions(Dimensions) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


SetDimensions(Single,Single) Method

SetDimensions(Single,Single) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class > SetDimensions Method : SetDimensions(Single,Single) Method

width
height

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub SetDimensions( _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim width As Single
Dim height As Single

instance.SetDimensions(width, height)
C#
public void SetDimensions(
   float width,
   float height
)

Parameters

width
height

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members
Overload List


SetDimensions(Unit,Unit) Method

SetDimensions(Unit,Unit) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class > SetDimensions Method : SetDimensions(Unit,Unit) Method

width
height

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub SetDimensions( _
   ByVal width As Unit, _
   ByVal height As Unit _
)
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim width As Unit
Dim height As Unit

instance.SetDimensions(width, height)
C#
public void SetDimensions(
   Unit width,
   Unit height
)

Parameters

width
height

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members
Overload List


SetDimensions(Dimensions) Method

SetDimensions(Dimensions) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class > SetDimensions Method : SetDimensions(Dimensions) Method

source

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub SetDimensions( _
   ByVal source As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim source As Dimensions

instance.SetDimensions(source)
C#
public void SetDimensions(
   Dimensions source
)

Parameters

source

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members
Overload List


ShouldSerializeHeight Method

ShouldSerializeHeight Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : ShouldSerializeHeight Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeHeight() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim value As Boolean

value = instance.ShouldSerializeHeight()
C#
protected virtual bool ShouldSerializeHeight()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


ShouldSerializeWidth Method

ShouldSerializeWidth Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : ShouldSerializeWidth Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeWidth() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim value As Boolean

value = instance.ShouldSerializeWidth()
C#
protected virtual bool ShouldSerializeWidth()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As Dimensions

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


Dimensions Class Properties

Dimensions Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : Dimensions Class

For a list of all members of this type, see Dimensions members.

Public Properties

 | Name | Description
Public Property | AutoSize |
Public Property | Height |
Public Property | Margins |
Public Property | Paddings |
Public Property | Width |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


AutoSize Property

AutoSize Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : AutoSize Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim value As Boolean

instance.AutoSize = value

value = instance.AutoSize
C#
public virtual bool AutoSize {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


Height Property

Height Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : Height Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public virtual Unit Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


Margins Property

Margins Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : Margins Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Margins As ChartMargins
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim value As ChartMargins

instance.Margins = value

value = instance.Margins
C#
public virtual ChartMargins Margins {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


Paddings Property

Paddings Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : Paddings Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Paddings As ChartPaddings
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim value As ChartPaddings

instance.Paddings = value

value = instance.Paddings
C#
public virtual ChartPaddings Paddings {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


Width Property

Width Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : Width Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public virtual Unit Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


Dimensions Class Fields

Dimensions Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : Dimensions Class

For a list of all members of this type, see Dimensions members.

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins |
Protected Field | dimensionsPaddings |
Top

See Also

Reference

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


dimensionsMargins Field

dimensionsMargins Field
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : dimensionsMargins Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected dimensionsMargins As ChartMargins
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim value As ChartMargins

value = instance.dimensionsMargins

instance.dimensionsMargins = value
C#
protected ChartMargins dimensionsMargins

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


dimensionsPaddings Field

dimensionsPaddings Field
[image]
Telerik.Reporting.Charting.Styles Namespace > Dimensions Class : dimensionsPaddings Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected dimensionsPaddings As ChartPaddings
Visual Basic (Usage) Copy Code
Dim instance As Dimensions
Dim value As ChartPaddings

value = instance.dimensionsPaddings

instance.dimensionsPaddings = value
C#
protected ChartPaddings dimensionsPaddings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Dimensions Class
Dimensions Members


DimensionsChart Class

DimensionsChart Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsChart Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class DimensionsChart
   Inherits Dimensions
   Implements IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings
Visual Basic (Usage) Copy Code
Dim instance As DimensionsChart
C#
public class DimensionsChart : Dimensions, IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Dimensions
Telerik.Reporting.Charting.Styles.DimensionsChart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsChart Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsChart Class Members

DimensionsChart Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsChart Class

The following tables list the members exposed by DimensionsChart.

Public Constructors

 | Name | Description
Public Constructor | DimensionsChart Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

Public Properties

 | Name | Description
Public Property | AutoSize | (Inherited from Dimensions)
Public Property | Height | Overridden.
Public Property | Margins | (Inherited from Dimensions)
Public Property | Paddings | (Inherited from Dimensions)
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Dimensions)
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | Overridden.
Protected Method | ResetWidth | Overridden.
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsChart Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsChart Constructor

DimensionsChart Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsChart Class : DimensionsChart Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsChart()
C#
public DimensionsChart()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsChart()
C#
public DimensionsChart()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsChart Class
DimensionsChart Members


DimensionsChart Class Methods

DimensionsChart Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsChart Class

For a list of all members of this type, see DimensionsChart members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Dimensions)
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | Overridden.
Protected Method | ResetWidth | Overridden.
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsChart Class
Telerik.Reporting.Charting.Styles Namespace


ResetHeight Method

ResetHeight Method
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsChart Class : ResetHeight Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ResetHeight()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsChart

instance.ResetHeight()
C#
protected override void ResetHeight()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsChart Class
DimensionsChart Members


ResetWidth Method

ResetWidth Method
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsChart Class : ResetWidth Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ResetWidth()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsChart

instance.ResetWidth()
C#
protected override void ResetWidth()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsChart Class
DimensionsChart Members


DimensionsChart Class Properties

DimensionsChart Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsChart Class

For a list of all members of this type, see DimensionsChart members.

Public Properties

 | Name | Description
Public Property | AutoSize | (Inherited from Dimensions)
Public Property | Height | Overridden.
Public Property | Margins | (Inherited from Dimensions)
Public Property | Paddings | (Inherited from Dimensions)
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

DimensionsChart Class
Telerik.Reporting.Charting.Styles Namespace


Height Property

Height Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsChart Class : Height Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As DimensionsChart
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public override Unit Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsChart Class
DimensionsChart Members


Width Property

Width Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsChart Class : Width Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As DimensionsChart
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public override Unit Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsChart Class
DimensionsChart Members


DimensionsLegend Class

DimensionsLegend Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsLegend Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class DimensionsLegend
   Inherits Dimensions
   Implements IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings
Visual Basic (Usage) Copy Code
Dim instance As DimensionsLegend
C#
public class DimensionsLegend : Dimensions, IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Dimensions
Telerik.Reporting.Charting.Styles.DimensionsLegend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsLegend Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsLegend Class Members

DimensionsLegend Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsLegend Class

The following tables list the members exposed by DimensionsLegend.

Public Constructors

 | Name | Description
Public Constructor | DimensionsLegend Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

Public Properties

 | Name | Description
Public Property | AutoSize | (Inherited from Dimensions)
Public Property | Height | (Inherited from Dimensions)
Public Property | Margins | Overridden.
Public Property | Paddings | Overridden.
Public Property | Width | (Inherited from Dimensions)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Dimensions)
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | (Inherited from Dimensions)
Protected Method | ResetWidth | (Inherited from Dimensions)
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsLegend Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsLegend Constructor

DimensionsLegend Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsLegend Class : DimensionsLegend Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsLegend()
C#
public DimensionsLegend()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsLegend()
C#
public DimensionsLegend()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsLegend Class
DimensionsLegend Members


DimensionsLegend Class Properties

DimensionsLegend Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsLegend Class

For a list of all members of this type, see DimensionsLegend members.

Public Properties

 | Name | Description
Public Property | AutoSize | (Inherited from Dimensions)
Public Property | Height | (Inherited from Dimensions)
Public Property | Margins | Overridden.
Public Property | Paddings | Overridden.
Public Property | Width | (Inherited from Dimensions)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

DimensionsLegend Class
Telerik.Reporting.Charting.Styles Namespace


Margins Property

Margins Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsLegend Class : Margins Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Margins As ChartMargins
Visual Basic (Usage) Copy Code
Dim instance As DimensionsLegend
Dim value As ChartMargins

instance.Margins = value

value = instance.Margins
C#
public override ChartMargins Margins {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsLegend Class
DimensionsLegend Members


Paddings Property

Paddings Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsLegend Class : Paddings Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Paddings As ChartPaddings
Visual Basic (Usage) Copy Code
Dim instance As DimensionsLegend
Dim value As ChartPaddings

instance.Paddings = value

value = instance.Paddings
C#
public override ChartPaddings Paddings {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsLegend Class
DimensionsLegend Members


DimensionsMarker Class

DimensionsMarker Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsMarker Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class DimensionsMarker
   Inherits Dimensions
   Implements IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings
Visual Basic (Usage) Copy Code
Dim instance As DimensionsMarker
C#
public class DimensionsMarker : Dimensions, IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Dimensions
Telerik.Reporting.Charting.Styles.DimensionsMarker
Telerik.Reporting.Charting.Styles.DimensionsPointMarker

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsMarker Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsMarker Class Members

DimensionsMarker Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsMarker Class

The following tables list the members exposed by DimensionsMarker.

Public Constructors

 | Name | Description
Public Constructor | DimensionsMarker Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

Public Properties

 | Name | Description
Public Property | AutoSize | Overridden.
Public Property | Height | Overridden.
Public Property | Margins | (Inherited from Dimensions)
Public Property | Paddings | Overridden.
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Dimensions)
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | Overridden.
Protected Method | ResetWidth | Overridden.
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsMarker Constructor

DimensionsMarker Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsMarker Class : DimensionsMarker Constructor

Overload List

Overload | Description
DimensionsMarker Constructor() |
DimensionsMarker Constructor(Object) |
DimensionsMarker Constructor(Single,Single) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsMarker Class
DimensionsMarker Members


DimensionsMarker Constructor()

DimensionsMarker Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsMarker Class > DimensionsMarker Constructor : DimensionsMarker Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsMarker()
C#
public DimensionsMarker()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsMarker()
C#
public DimensionsMarker()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsMarker Class
DimensionsMarker Members
Overload List


DimensionsMarker Constructor(Object)

DimensionsMarker Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsMarker Class > DimensionsMarker Constructor : DimensionsMarker Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As DimensionsMarker(containerObject)
C#
public DimensionsMarker(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As DimensionsMarker(containerObject)
C#
public DimensionsMarker(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsMarker Class
DimensionsMarker Members
Overload List


DimensionsMarker Constructor(Single,Single)

DimensionsMarker Constructor(Single,Single)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsMarker Class > DimensionsMarker Constructor : DimensionsMarker Constructor(Single,Single)

width
height

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim width As Single
Dim height As Single

Dim instance As DimensionsMarker(width, height)
C#
public DimensionsMarker(
   float width,
   float height
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Single, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim width As Single
Dim height As Single

Dim instance As DimensionsMarker(width, height)
C#
public DimensionsMarker(
   float width,
   float height
)

Parameters

width
height

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsMarker Class
DimensionsMarker Members
Overload List


DimensionsMarker Class Methods

DimensionsMarker Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsMarker Class

For a list of all members of this type, see DimensionsMarker members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Dimensions)
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | Overridden.
Protected Method | ResetWidth | Overridden.
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


ResetHeight Method

ResetHeight Method
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsMarker Class : ResetHeight Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ResetHeight()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsMarker

instance.ResetHeight()
C#
protected override void ResetHeight()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsMarker Class
DimensionsMarker Members


ResetWidth Method

ResetWidth Method
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsMarker Class : ResetWidth Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ResetWidth()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsMarker

instance.ResetWidth()
C#
protected override void ResetWidth()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsMarker Class
DimensionsMarker Members


DimensionsMarker Class Properties

DimensionsMarker Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsMarker Class

For a list of all members of this type, see DimensionsMarker members.

Public Properties

 | Name | Description
Public Property | AutoSize | Overridden.
Public Property | Height | Overridden.
Public Property | Margins | (Inherited from Dimensions)
Public Property | Paddings | Overridden.
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


AutoSize Property

AutoSize Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsMarker Class : AutoSize Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property AutoSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DimensionsMarker
Dim value As Boolean

instance.AutoSize = value

value = instance.AutoSize
C#
public override bool AutoSize {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsMarker Class
DimensionsMarker Members


Height Property

Height Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsMarker Class : Height Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As DimensionsMarker
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public override Unit Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsMarker Class
DimensionsMarker Members


Paddings Property

Paddings Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsMarker Class : Paddings Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Paddings As ChartPaddings
Visual Basic (Usage) Copy Code
Dim instance As DimensionsMarker
Dim value As ChartPaddings

instance.Paddings = value

value = instance.Paddings
C#
public override ChartPaddings Paddings {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsMarker Class
DimensionsMarker Members


Width Property

Width Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsMarker Class : Width Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As DimensionsMarker
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public override Unit Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsMarker Class
DimensionsMarker Members


DimensionsPlotArea Class

DimensionsPlotArea Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsPlotArea Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class DimensionsPlotArea
   Inherits Dimensions
   Implements IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings
Visual Basic (Usage) Copy Code
Dim instance As DimensionsPlotArea
C#
public class DimensionsPlotArea : Dimensions, IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Dimensions
Telerik.Reporting.Charting.Styles.DimensionsPlotArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsPlotArea Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsPlotArea Class Members

DimensionsPlotArea Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsPlotArea Class

The following tables list the members exposed by DimensionsPlotArea.

Public Constructors

 | Name | Description
Public Constructor | DimensionsPlotArea Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

Public Properties

 | Name | Description
Public Property | AutoSize | (Inherited from Dimensions)
Public Property | Height | (Inherited from Dimensions)
Public Property | Margins | Overridden.
Public Property | Paddings | (Inherited from Dimensions)
Public Property | Width | (Inherited from Dimensions)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Dimensions)
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | (Inherited from Dimensions)
Protected Method | ResetWidth | (Inherited from Dimensions)
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsPlotArea Constructor

DimensionsPlotArea Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsPlotArea Class : DimensionsPlotArea Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsPlotArea()
C#
public DimensionsPlotArea()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsPlotArea()
C#
public DimensionsPlotArea()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsPlotArea Class
DimensionsPlotArea Members


DimensionsPlotArea Class Properties

DimensionsPlotArea Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsPlotArea Class

For a list of all members of this type, see DimensionsPlotArea members.

Public Properties

 | Name | Description
Public Property | AutoSize | (Inherited from Dimensions)
Public Property | Height | (Inherited from Dimensions)
Public Property | Margins | Overridden.
Public Property | Paddings | (Inherited from Dimensions)
Public Property | Width | (Inherited from Dimensions)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

DimensionsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Margins Property

Margins Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsPlotArea Class : Margins Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Margins As ChartMargins
Visual Basic (Usage) Copy Code
Dim instance As DimensionsPlotArea
Dim value As ChartMargins

instance.Margins = value

value = instance.Margins
C#
public override ChartMargins Margins {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsPlotArea Class
DimensionsPlotArea Members


DimensionsPointMarker Class

DimensionsPointMarker Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsPointMarker Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class DimensionsPointMarker
   Inherits DimensionsMarker
   Implements IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings
Visual Basic (Usage) Copy Code
Dim instance As DimensionsPointMarker
C#
public class DimensionsPointMarker : DimensionsMarker, IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Dimensions
Telerik.Reporting.Charting.Styles.DimensionsMarker
Telerik.Reporting.Charting.Styles.DimensionsPointMarker

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsPointMarker Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsPointMarker Class Members

DimensionsPointMarker Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsPointMarker Class

The following tables list the members exposed by DimensionsPointMarker.

Public Constructors

 | Name | Description
Public Constructor | DimensionsPointMarker Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

Public Properties

 | Name | Description
Public Property | AutoSize | (Inherited from DimensionsMarker)
Public Property | Height | (Inherited from DimensionsMarker)
Public Property | Margins | Overridden.
Public Property | Paddings | (Inherited from DimensionsMarker)
Public Property | Width | (Inherited from DimensionsMarker)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | (Inherited from DimensionsMarker)
Protected Method | ResetWidth | (Inherited from DimensionsMarker)
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsPointMarker Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsPointMarker Constructor

DimensionsPointMarker Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsPointMarker Class : DimensionsPointMarker Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsPointMarker()
C#
public DimensionsPointMarker()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsPointMarker()
C#
public DimensionsPointMarker()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsPointMarker Class
DimensionsPointMarker Members


DimensionsPointMarker Class Methods

DimensionsPointMarker Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsPointMarker Class

For a list of all members of this type, see DimensionsPointMarker members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | (Inherited from DimensionsMarker)
Protected Method | ResetWidth | (Inherited from DimensionsMarker)
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsPointMarker Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsPointMarker Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DimensionsPointMarker
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsPointMarker Class
DimensionsPointMarker Members


DimensionsPointMarker Class Properties

DimensionsPointMarker Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsPointMarker Class

For a list of all members of this type, see DimensionsPointMarker members.

Public Properties

 | Name | Description
Public Property | AutoSize | (Inherited from DimensionsMarker)
Public Property | Height | (Inherited from DimensionsMarker)
Public Property | Margins | Overridden.
Public Property | Paddings | (Inherited from DimensionsMarker)
Public Property | Width | (Inherited from DimensionsMarker)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

DimensionsPointMarker Class
Telerik.Reporting.Charting.Styles Namespace


Margins Property

Margins Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsPointMarker Class : Margins Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Margins As ChartMargins
Visual Basic (Usage) Copy Code
Dim instance As DimensionsPointMarker
Dim value As ChartMargins

instance.Margins = value

value = instance.Margins
C#
public override ChartMargins Margins {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsPointMarker Class
DimensionsPointMarker Members


DimensionsSeriesPointMark Class

DimensionsSeriesPointMark Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsSeriesPointMark Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class DimensionsSeriesPointMark
   Inherits Dimensions
   Implements IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings
Visual Basic (Usage) Copy Code
Dim instance As DimensionsSeriesPointMark
C#
public class DimensionsSeriesPointMark : Dimensions, IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Dimensions
Telerik.Reporting.Charting.Styles.DimensionsSeriesPointMark

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsSeriesPointMark Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsSeriesPointMark Class Members

DimensionsSeriesPointMark Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsSeriesPointMark Class

The following tables list the members exposed by DimensionsSeriesPointMark.

Public Constructors

 | Name | Description
Public Constructor | DimensionsSeriesPointMark Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

Public Properties

 | Name | Description
Public Property | AutoSize | (Inherited from Dimensions)
Public Property | Height | Overridden.
Public Property | Margins | Overridden.
Public Property | Paddings | Overridden.
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | Overridden.
Protected Method | ResetWidth | Overridden.
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsSeriesPointMark Constructor

DimensionsSeriesPointMark Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsSeriesPointMark Class : DimensionsSeriesPointMark Constructor

Overload List

Overload | Description
DimensionsSeriesPointMark Constructor() |
DimensionsSeriesPointMark Constructor(Object) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Members


DimensionsSeriesPointMark Constructor()

DimensionsSeriesPointMark Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsSeriesPointMark Class > DimensionsSeriesPointMark Constructor : DimensionsSeriesPointMark Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsSeriesPointMark()
C#
public DimensionsSeriesPointMark()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsSeriesPointMark()
C#
public DimensionsSeriesPointMark()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Members
Overload List


DimensionsSeriesPointMark Constructor(Object)

DimensionsSeriesPointMark Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsSeriesPointMark Class > DimensionsSeriesPointMark Constructor : DimensionsSeriesPointMark Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As DimensionsSeriesPointMark(containerObject)
C#
public DimensionsSeriesPointMark(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As DimensionsSeriesPointMark(containerObject)
C#
public DimensionsSeriesPointMark(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Members
Overload List


DimensionsSeriesPointMark Class Methods

DimensionsSeriesPointMark Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsSeriesPointMark Class

For a list of all members of this type, see DimensionsSeriesPointMark members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | Overridden.
Protected Method | ResetWidth | Overridden.
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsSeriesPointMark Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DimensionsSeriesPointMark
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Members


ResetHeight Method

ResetHeight Method
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsSeriesPointMark Class : ResetHeight Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ResetHeight()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsSeriesPointMark

instance.ResetHeight()
C#
protected override void ResetHeight()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Members


ResetWidth Method

ResetWidth Method
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsSeriesPointMark Class : ResetWidth Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ResetWidth()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsSeriesPointMark

instance.ResetWidth()
C#
protected override void ResetWidth()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Members


DimensionsSeriesPointMark Class Properties

DimensionsSeriesPointMark Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsSeriesPointMark Class

For a list of all members of this type, see DimensionsSeriesPointMark members.

Public Properties

 | Name | Description
Public Property | AutoSize | (Inherited from Dimensions)
Public Property | Height | Overridden.
Public Property | Margins | Overridden.
Public Property | Paddings | Overridden.
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


Height Property

Height Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsSeriesPointMark Class : Height Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As DimensionsSeriesPointMark
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public override Unit Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Members


Margins Property

Margins Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsSeriesPointMark Class : Margins Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Margins As ChartMargins
Visual Basic (Usage) Copy Code
Dim instance As DimensionsSeriesPointMark
Dim value As ChartMargins

instance.Margins = value

value = instance.Margins
C#
public override ChartMargins Margins {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Members


Paddings Property

Paddings Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsSeriesPointMark Class : Paddings Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Paddings As ChartPaddings
Visual Basic (Usage) Copy Code
Dim instance As DimensionsSeriesPointMark
Dim value As ChartPaddings

instance.Paddings = value

value = instance.Paddings
C#
public override ChartPaddings Paddings {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Members


Width Property

Width Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsSeriesPointMark Class : Width Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As DimensionsSeriesPointMark
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public override Unit Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Members


DimensionsTitle Class

DimensionsTitle Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsTitle Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class DimensionsTitle
   Inherits Dimensions
   Implements IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings
Visual Basic (Usage) Copy Code
Dim instance As DimensionsTitle
C#
public class DimensionsTitle : Dimensions, IChartingStateManagedItem, IChartingStateManager, ISizesAndPaddings

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Dimensions
Telerik.Reporting.Charting.Styles.DimensionsTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsTitle Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsTitle Class Members

DimensionsTitle Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsTitle Class

The following tables list the members exposed by DimensionsTitle.

Public Constructors

 | Name | Description
Public Constructor | DimensionsTitle Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

Public Properties

 | Name | Description
Public Property | AutoSize | (Inherited from Dimensions)
Public Property | Height | (Inherited from Dimensions)
Public Property | Margins | Overridden.
Public Property | Paddings | Overridden.
Public Property | Width | (Inherited from Dimensions)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Dimensions)
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | (Inherited from Dimensions)
Protected Method | ResetWidth | (Inherited from Dimensions)
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsTitle Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsTitle Constructor

DimensionsTitle Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsTitle Class : DimensionsTitle Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsTitle()
C#
public DimensionsTitle()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DimensionsTitle()
C#
public DimensionsTitle()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsTitle Class
DimensionsTitle Members


DimensionsTitle Class Properties

DimensionsTitle Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsTitle Class

For a list of all members of this type, see DimensionsTitle members.

Public Properties

 | Name | Description
Public Property | AutoSize | (Inherited from Dimensions)
Public Property | Height | (Inherited from Dimensions)
Public Property | Margins | Overridden.
Public Property | Paddings | Overridden.
Public Property | Width | (Inherited from Dimensions)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

DimensionsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Margins Property

Margins Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsTitle Class : Margins Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Margins As ChartMargins
Visual Basic (Usage) Copy Code
Dim instance As DimensionsTitle
Dim value As ChartMargins

instance.Margins = value

value = instance.Margins
C#
public override ChartMargins Margins {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsTitle Class
DimensionsTitle Members


Paddings Property

Paddings Property
[image]
Telerik.Reporting.Charting.Styles Namespace > DimensionsTitle Class : Paddings Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Paddings As ChartPaddings
Visual Basic (Usage) Copy Code
Dim instance As DimensionsTitle
Dim value As ChartPaddings

instance.Paddings = value

value = instance.Paddings
C#
public override ChartPaddings Paddings {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DimensionsTitle Class
DimensionsTitle Members


EmptyValue Class

EmptyValue Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : EmptyValue Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class EmptyValue
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As EmptyValue
C#
public class EmptyValue : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.EmptyValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptyValue Members
Telerik.Reporting.Charting.Styles Namespace


EmptyValue Class Members

EmptyValue Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : EmptyValue Class

The following tables list the members exposed by EmptyValue.

Public Constructors

 | Name | Description
Public Constructor | EmptyValue Constructor |
Top

Public Properties

 | Name | Description
Public Property | FillStyle |
Public Property | Line |
Public Property | Mode |
Public Property | PointMark |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


EmptyValue Constructor

EmptyValue Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > EmptyValue Class : EmptyValue Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EmptyValue()
C#
public EmptyValue()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EmptyValue()
C#
public EmptyValue()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptyValue Class
EmptyValue Members


EmptyValue Class Methods

EmptyValue Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : EmptyValue Class

For a list of all members of this type, see EmptyValue members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > EmptyValue Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As EmptyValue
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptyValue Class
EmptyValue Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > EmptyValue Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As EmptyValue
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptyValue Class
EmptyValue Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > EmptyValue Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As EmptyValue
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptyValue Class
EmptyValue Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > EmptyValue Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As EmptyValue

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptyValue Class
EmptyValue Members


EmptyValue Class Properties

EmptyValue Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : EmptyValue Class

For a list of all members of this type, see EmptyValue members.

Public Properties

 | Name | Description
Public Property | FillStyle |
Public Property | Line |
Public Property | Mode |
Public Property | PointMark |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Property

FillStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > EmptyValue Class : FillStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStyle
Visual Basic (Usage) Copy Code
Dim instance As EmptyValue
Dim value As FillStyle

value = instance.FillStyle
C#
public FillStyle FillStyle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptyValue Class
EmptyValue Members


Line Property

Line Property
[image]
Telerik.Reporting.Charting.Styles Namespace > EmptyValue Class : Line Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Line As StyleEmptyLineSeries
Visual Basic (Usage) Copy Code
Dim instance As EmptyValue
Dim value As StyleEmptyLineSeries

value = instance.Line
C#
public StyleEmptyLineSeries Line {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptyValue Class
EmptyValue Members


Mode Property

Mode Property
[image]
Telerik.Reporting.Charting.Styles Namespace > EmptyValue Class : Mode Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Mode As EmtyValuesMode
Visual Basic (Usage) Copy Code
Dim instance As EmptyValue
Dim value As EmtyValuesMode

instance.Mode = value

value = instance.Mode
C#
public EmtyValuesMode Mode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptyValue Class
EmptyValue Members


PointMark Property

PointMark Property
[image]
Telerik.Reporting.Charting.Styles Namespace > EmptyValue Class : PointMark Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PointMark As StyleMarkerEmptyValue
Visual Basic (Usage) Copy Code
Dim instance As EmptyValue
Dim value As StyleMarkerEmptyValue

value = instance.PointMark
C#
public StyleMarkerEmptyValue PointMark {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EmptyValue Class
EmptyValue Members


FiguresCollection Class

FiguresCollection Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : FiguresCollection Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FiguresCollection
Visual Basic (Usage) Copy Code
Dim instance As FiguresCollection
C#
public class FiguresCollection

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.Styles.FiguresCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FiguresCollection Members
Telerik.Reporting.Charting.Styles Namespace


FiguresCollection Class Members

FiguresCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FiguresCollection Class

The following tables list the members exposed by FiguresCollection.

Public Constructors

 | Name | Description
Public Constructor | FiguresCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Figures |
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Top

See Also

Reference

FiguresCollection Class
Telerik.Reporting.Charting.Styles Namespace


FiguresCollection Constructor

FiguresCollection Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > FiguresCollection Class : FiguresCollection Constructor

Overload List

Overload | Description
FiguresCollection Constructor() |
FiguresCollection Constructor(Chart) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FiguresCollection Class
FiguresCollection Members


FiguresCollection Constructor()

FiguresCollection Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FiguresCollection Class > FiguresCollection Constructor : FiguresCollection Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FiguresCollection()
C#
public FiguresCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FiguresCollection()
C#
public FiguresCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FiguresCollection Class
FiguresCollection Members
Overload List


FiguresCollection Constructor(Chart)

FiguresCollection Constructor(Chart)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FiguresCollection Class > FiguresCollection Constructor : FiguresCollection Constructor(Chart)

chart

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal chart As Chart _
)
Visual Basic (Usage) Copy Code
Dim chart As Chart

Dim instance As FiguresCollection(chart)
C#
public FiguresCollection(
   Chart chart
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal chart As Chart _
)
Visual Basic (Usage) Copy Code
Dim chart As Chart

Dim instance As FiguresCollection(chart)
C#
public FiguresCollection(
   Chart chart
)

Parameters

chart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FiguresCollection Class
FiguresCollection Members
Overload List


FiguresCollection Class Methods

FiguresCollection Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FiguresCollection Class

For a list of all members of this type, see FiguresCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Top

See Also

Reference

FiguresCollection Class
Telerik.Reporting.Charting.Styles Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FiguresCollection Class : Add Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Add(Generic List) |
Add(String) |

Overload List

Overload | Description
Add(Generic List) |
Add(String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FiguresCollection Class
FiguresCollection Members


Add(Generic List) Method

Add(Generic List) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FiguresCollection Class > Add Method : Add(Generic List) Method

list

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal list As List(Of CustomFigure) _
)
Visual Basic (Usage) Copy Code
Dim instance As FiguresCollection
Dim list As List(Of CustomFigure)

instance.Add(list)
C#
public void Add(
   List<CustomFigure> list
)

Parameters

list

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FiguresCollection Class
FiguresCollection Members
Overload List


Add(String) Method

Add(String) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FiguresCollection Class > Add Method : Add(String) Method

name

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As FiguresCollection
Dim name As String

instance.Add(name)
C#
public void Add(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FiguresCollection Class
FiguresCollection Members
Overload List


FiguresCollection Class Properties

FiguresCollection Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : FiguresCollection Class

For a list of all members of this type, see FiguresCollection members.

Public Properties

 | Name | Description
Public Property | Figures |
Top

See Also

Reference

FiguresCollection Class
Telerik.Reporting.Charting.Styles Namespace


Figures Property

Figures Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FiguresCollection Class : Figures Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Figures As List(Of String)
Visual Basic (Usage) Copy Code
Dim instance As FiguresCollection
Dim value As List(Of String)

value = instance.Figures
C#
public List<string> Figures {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FiguresCollection Class
FiguresCollection Members


FillSettings Class

FillSettings Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : FillSettings Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FillSettings
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
C#
public class FillSettings : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.FillSettings
Telerik.Reporting.Charting.Styles.FillSettingsVerticalGradient

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Members
Telerik.Reporting.Charting.Styles Namespace


FillSettings Class Members

FillSettings Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillSettings Class

The following tables list the members exposed by FillSettings.

Public Constructors

 | Name | Description
Public Constructor | FillSettings Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | fillSettingsComplexGradient |
Top

Public Properties

 | Name | Description
Public Property | BackgroundImage |
Public Property | ComplexGradient |
Public Property | GradientAngle |
Public Property | GradientMode |
Public Property | HatchStyle |
Public Property | ImageAlign |
Public Property | ImageDrawMode |
Public Property | ImageFlip |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


FillSettings Constructor

FillSettings Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : FillSettings Constructor

Overload List

Overload | Description
FillSettings Constructor() |
FillSettings Constructor(GradientFillStyle,Single,ColorBlend) |
FillSettings Constructor(HatchStyle) |
FillSettings Constructor(ImageDrawMode,String,ImageAlignModes,ImageTileModes) |
FillSettings Constructor(Object) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


FillSettings Constructor()

FillSettings Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class > FillSettings Constructor : FillSettings Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillSettings()
C#
public FillSettings()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillSettings()
C#
public FillSettings()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members
Overload List


FillSettings Constructor(GradientFillStyle,Single,ColorBlend)

FillSettings Constructor(GradientFillStyle,Single,ColorBlend)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class > FillSettings Constructor : FillSettings Constructor(GradientFillStyle,Single,ColorBlend)

lgMode
lgAngle
blend

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lgMode As GradientFillStyle, _
   ByVal lgAngle As Single, _
   ByVal blend As ColorBlend _
)
Visual Basic (Usage) Copy Code
Dim lgMode As GradientFillStyle
Dim lgAngle As Single
Dim blend As ColorBlend

Dim instance As FillSettings(lgMode, lgAngle, blend)
C#
public FillSettings(
   GradientFillStyle lgMode,
   float lgAngle,
   ColorBlend blend
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lgMode As GradientFillStyle, _
   ByVal lgAngle As Single, _
   ByVal blend As ColorBlend _
)
Visual Basic (Usage) Copy Code
Dim lgMode As GradientFillStyle
Dim lgAngle As Single
Dim blend As ColorBlend

Dim instance As FillSettings(lgMode, lgAngle, blend)
C#
public FillSettings(
   GradientFillStyle lgMode,
   float lgAngle,
   ColorBlend blend
)

Parameters

lgMode
lgAngle
blend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members
Overload List


FillSettings Constructor(HatchStyle)

FillSettings Constructor(HatchStyle)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class > FillSettings Constructor : FillSettings Constructor(HatchStyle)

style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As HatchStyle _
)
Visual Basic (Usage) Copy Code
Dim style As HatchStyle

Dim instance As FillSettings(style)
C#
public FillSettings(
   HatchStyle style
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As HatchStyle _
)
Visual Basic (Usage) Copy Code
Dim style As HatchStyle

Dim instance As FillSettings(style)
C#
public FillSettings(
   HatchStyle style
)

Parameters

style

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members
Overload List


FillSettings Constructor(ImageDrawMode,String,ImageAlignModes,ImageTileModes)

FillSettings Constructor(ImageDrawMode,String,ImageAlignModes,ImageTileModes)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class > FillSettings Constructor : FillSettings Constructor(ImageDrawMode,String,ImageAlignModes,ImageTileModes)

idMode
imageURL
aligneMode
flip

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal idMode As ImageDrawMode, _
   ByVal imageURL As String, _
   ByVal aligneMode As ImageAlignModes, _
   ByVal flip As ImageTileModes _
)
Visual Basic (Usage) Copy Code
Dim idMode As ImageDrawMode
Dim imageURL As String
Dim aligneMode As ImageAlignModes
Dim flip As ImageTileModes

Dim instance As FillSettings(idMode, imageURL, aligneMode, flip)
C#
public FillSettings(
   ImageDrawMode idMode,
   string imageURL,
   ImageAlignModes aligneMode,
   ImageTileModes flip
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal idMode As ImageDrawMode, _
   ByVal imageURL As String, _
   ByVal aligneMode As ImageAlignModes, _
   ByVal flip As ImageTileModes _
)
Visual Basic (Usage) Copy Code
Dim idMode As ImageDrawMode
Dim imageURL As String
Dim aligneMode As ImageAlignModes
Dim flip As ImageTileModes

Dim instance As FillSettings(idMode, imageURL, aligneMode, flip)
C#
public FillSettings(
   ImageDrawMode idMode,
   string imageURL,
   ImageAlignModes aligneMode,
   ImageTileModes flip
)

Parameters

idMode
imageURL
aligneMode
flip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members
Overload List


FillSettings Constructor(Object)

FillSettings Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class > FillSettings Constructor : FillSettings Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As FillSettings(containerObject)
C#
public FillSettings(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As FillSettings(containerObject)
C#
public FillSettings(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members
Overload List


FillSettings Class Methods

FillSettings Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillSettings Class

For a list of all members of this type, see FillSettings members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As FillSettings

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


FillSettings Class Properties

FillSettings Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : FillSettings Class

For a list of all members of this type, see FillSettings members.

Public Properties

 | Name | Description
Public Property | BackgroundImage |
Public Property | ComplexGradient |
Public Property | GradientAngle |
Public Property | GradientMode |
Public Property | HatchStyle |
Public Property | ImageAlign |
Public Property | ImageDrawMode |
Public Property | ImageFlip |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


BackgroundImage Property

BackgroundImage Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : BackgroundImage Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property BackgroundImage As String
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim value As String

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
public string BackgroundImage {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


ComplexGradient Property

ComplexGradient Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : ComplexGradient Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ComplexGradient As ColorBlend
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim value As ColorBlend

value = instance.ComplexGradient
C#
public ColorBlend ComplexGradient {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


GradientAngle Property

GradientAngle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : GradientAngle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property GradientAngle As Single
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim value As Single

instance.GradientAngle = value

value = instance.GradientAngle
C#
public float GradientAngle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


GradientMode Property

GradientMode Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : GradientMode Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property GradientMode As GradientFillStyle
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim value As GradientFillStyle

instance.GradientMode = value

value = instance.GradientMode
C#
public virtual GradientFillStyle GradientMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


HatchStyle Property

HatchStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : HatchStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property HatchStyle As HatchStyle
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim value As HatchStyle

instance.HatchStyle = value

value = instance.HatchStyle
C#
public HatchStyle HatchStyle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


ImageAlign Property

ImageAlign Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : ImageAlign Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageAlign As ImageAlignModes
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim value As ImageAlignModes

instance.ImageAlign = value

value = instance.ImageAlign
C#
public ImageAlignModes ImageAlign {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


ImageDrawMode Property

ImageDrawMode Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : ImageDrawMode Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageDrawMode As ImageDrawMode
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim value As ImageDrawMode

instance.ImageDrawMode = value

value = instance.ImageDrawMode
C#
public ImageDrawMode ImageDrawMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


ImageFlip Property

ImageFlip Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : ImageFlip Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageFlip As ImageTileModes
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim value As ImageTileModes

instance.ImageFlip = value

value = instance.ImageFlip
C#
public ImageTileModes ImageFlip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


FillSettings Class Fields

FillSettings Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : FillSettings Class

For a list of all members of this type, see FillSettings members.

Protected Fields

 | Name | Description
Protected Field | fillSettingsComplexGradient |
Top

See Also

Reference

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


fillSettingsComplexGradient Field

fillSettingsComplexGradient Field
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettings Class : fillSettingsComplexGradient Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected fillSettingsComplexGradient As ColorBlend
Visual Basic (Usage) Copy Code
Dim instance As FillSettings
Dim value As ColorBlend

value = instance.fillSettingsComplexGradient

instance.fillSettingsComplexGradient = value
C#
protected ColorBlend fillSettingsComplexGradient

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettings Class
FillSettings Members


FillSettingsVerticalGradient Class

FillSettingsVerticalGradient Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : FillSettingsVerticalGradient Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FillSettingsVerticalGradient
   Inherits FillSettings
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As FillSettingsVerticalGradient
C#
public class FillSettingsVerticalGradient : FillSettings, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.FillSettings
Telerik.Reporting.Charting.Styles.FillSettingsVerticalGradient

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettingsVerticalGradient Members
Telerik.Reporting.Charting.Styles Namespace


FillSettingsVerticalGradient Class Members

FillSettingsVerticalGradient Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillSettingsVerticalGradient Class

The following tables list the members exposed by FillSettingsVerticalGradient.

Public Constructors

 | Name | Description
Public Constructor | FillSettingsVerticalGradient Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | fillSettingsComplexGradient | (Inherited from FillSettings)
Top

Public Properties

 | Name | Description
Public Property | BackgroundImage | (Inherited from FillSettings)
Public Property | ComplexGradient | (Inherited from FillSettings)
Public Property | GradientAngle | (Inherited from FillSettings)
Public Property | GradientMode | Overridden.
Public Property | HatchStyle | (Inherited from FillSettings)
Public Property | ImageAlign | (Inherited from FillSettings)
Public Property | ImageDrawMode | (Inherited from FillSettings)
Public Property | ImageFlip | (Inherited from FillSettings)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillSettings)
Public Method | Equals | (Inherited from FillSettings)
Public Method | GetHashCode | (Inherited from FillSettings)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillSettings)
Protected Method | SaveViewState | (Inherited from FillSettings)
Protected Method | TrackViewState | (Inherited from FillSettings)
Top

See Also

Reference

FillSettingsVerticalGradient Class
Telerik.Reporting.Charting.Styles Namespace


FillSettingsVerticalGradient Constructor

FillSettingsVerticalGradient Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettingsVerticalGradient Class : FillSettingsVerticalGradient Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillSettingsVerticalGradient()
C#
public FillSettingsVerticalGradient()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillSettingsVerticalGradient()
C#
public FillSettingsVerticalGradient()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettingsVerticalGradient Class
FillSettingsVerticalGradient Members


FillSettingsVerticalGradient Class Properties

FillSettingsVerticalGradient Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : FillSettingsVerticalGradient Class

For a list of all members of this type, see FillSettingsVerticalGradient members.

Public Properties

 | Name | Description
Public Property | BackgroundImage | (Inherited from FillSettings)
Public Property | ComplexGradient | (Inherited from FillSettings)
Public Property | GradientAngle | (Inherited from FillSettings)
Public Property | GradientMode | Overridden.
Public Property | HatchStyle | (Inherited from FillSettings)
Public Property | ImageAlign | (Inherited from FillSettings)
Public Property | ImageDrawMode | (Inherited from FillSettings)
Public Property | ImageFlip | (Inherited from FillSettings)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

FillSettingsVerticalGradient Class
Telerik.Reporting.Charting.Styles Namespace


GradientMode Property

GradientMode Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillSettingsVerticalGradient Class : GradientMode Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property GradientMode As GradientFillStyle
Visual Basic (Usage) Copy Code
Dim instance As FillSettingsVerticalGradient
Dim value As GradientFillStyle

instance.GradientMode = value

value = instance.GradientMode
C#
public override GradientFillStyle GradientMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillSettingsVerticalGradient Class
FillSettingsVerticalGradient Members


FillStyle Class

FillStyle Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyle Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FillStyle
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As FillStyle
C#
public class FillStyle : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.FillStyle
Telerik.Reporting.Charting.Styles.FillStyleChart
Telerik.Reporting.Charting.Styles.FillStyleMarkedZones
Telerik.Reporting.Charting.Styles.FillStylePlotArea
Telerik.Reporting.Charting.Styles.FillStyleSeries
Telerik.Reporting.Charting.Styles.FillStyleSeriesPoint
Telerik.Reporting.Charting.Styles.FillStyleTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Members
Telerik.Reporting.Charting.Styles Namespace


FillStyle Class Members

FillStyle Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyle Class

The following tables list the members exposed by FillStyle.

Public Constructors

 | Name | Description
Public Constructor | FillStyle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | FillSettings |
Public Property | FillType |
Public Property | GammaCorrection |
Public Property | MainColor |
Public Property | MainColorOpacity |
Public Property | SecondColor |
Public Property | SecondColorOpacity |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Constructor

FillStyle Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : FillStyle Constructor

Overload List

Overload | Description
FillStyle Constructor() |
FillStyle Constructor(Color) |
FillStyle Constructor(Color,Color) |
FillStyle Constructor(Color,Color,FillSettings,Boolean,FillType) |
FillStyle Constructor(Color,Color,FillType) |
FillStyle Constructor(Color,FillType) |
FillStyle Constructor(Object) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


FillStyle Constructor()

FillStyle Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class > FillStyle Constructor : FillStyle Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStyle()
C#
public FillStyle()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStyle()
C#
public FillStyle()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members
Overload List


FillStyle Constructor(Color)

FillStyle Constructor(Color)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class > FillStyle Constructor : FillStyle Constructor(Color)

mainColor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mainColor As Color _
)
Visual Basic (Usage) Copy Code
Dim mainColor As Color

Dim instance As FillStyle(mainColor)
C#
public FillStyle(
   Color mainColor
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mainColor As Color _
)
Visual Basic (Usage) Copy Code
Dim mainColor As Color

Dim instance As FillStyle(mainColor)
C#
public FillStyle(
   Color mainColor
)

Parameters

mainColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members
Overload List


FillStyle Constructor(Color,Color)

FillStyle Constructor(Color,Color)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class > FillStyle Constructor : FillStyle Constructor(Color,Color)

mainColor
secondColor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mainColor As Color, _
   ByVal secondColor As Color _
)
Visual Basic (Usage) Copy Code
Dim mainColor As Color
Dim secondColor As Color

Dim instance As FillStyle(mainColor, secondColor)
C#
public FillStyle(
   Color mainColor,
   Color secondColor
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mainColor As Color, _
   ByVal secondColor As Color _
)
Visual Basic (Usage) Copy Code
Dim mainColor As Color
Dim secondColor As Color

Dim instance As FillStyle(mainColor, secondColor)
C#
public FillStyle(
   Color mainColor,
   Color secondColor
)

Parameters

mainColor
secondColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members
Overload List


FillStyle Constructor(Color,Color,FillSettings,Boolean,FillType)

FillStyle Constructor(Color,Color,FillSettings,Boolean,FillType)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class > FillStyle Constructor : FillStyle Constructor(Color,Color,FillSettings,Boolean,FillType)

mainColor
secondColor
fillSettings
gammaCorrection
fillType

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mainColor As Color, _
   ByVal secondColor As Color, _
   ByVal fillSettings As FillSettings, _
   ByVal gammaCorrection As Boolean, _
   ByVal fillType As FillType _
)
Visual Basic (Usage) Copy Code
Dim mainColor As Color
Dim secondColor As Color
Dim fillSettings As FillSettings
Dim gammaCorrection As Boolean
Dim fillType As FillType

Dim instance As FillStyle(mainColor, secondColor, fillSettings, gammaCorrection, fillType)
C#
public FillStyle(
   Color mainColor,
   Color secondColor,
   FillSettings fillSettings,
   bool gammaCorrection,
   FillType fillType
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mainColor As Color, _
   ByVal secondColor As Color, _
   ByVal fillSettings As FillSettings, _
   ByVal gammaCorrection As Boolean, _
   ByVal fillType As FillType _
)
Visual Basic (Usage) Copy Code
Dim mainColor As Color
Dim secondColor As Color
Dim fillSettings As FillSettings
Dim gammaCorrection As Boolean
Dim fillType As FillType

Dim instance As FillStyle(mainColor, secondColor, fillSettings, gammaCorrection, fillType)
C#
public FillStyle(
   Color mainColor,
   Color secondColor,
   FillSettings fillSettings,
   bool gammaCorrection,
   FillType fillType
)

Parameters

mainColor
secondColor
fillSettings
gammaCorrection
fillType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members
Overload List


FillStyle Constructor(Color,Color,FillType)

FillStyle Constructor(Color,Color,FillType)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class > FillStyle Constructor : FillStyle Constructor(Color,Color,FillType)

mainColor
secondColor
fillType

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mainColor As Color, _
   ByVal secondColor As Color, _
   ByVal fillType As FillType _
)
Visual Basic (Usage) Copy Code
Dim mainColor As Color
Dim secondColor As Color
Dim fillType As FillType

Dim instance As FillStyle(mainColor, secondColor, fillType)
C#
public FillStyle(
   Color mainColor,
   Color secondColor,
   FillType fillType
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mainColor As Color, _
   ByVal secondColor As Color, _
   ByVal fillType As FillType _
)
Visual Basic (Usage) Copy Code
Dim mainColor As Color
Dim secondColor As Color
Dim fillType As FillType

Dim instance As FillStyle(mainColor, secondColor, fillType)
C#
public FillStyle(
   Color mainColor,
   Color secondColor,
   FillType fillType
)

Parameters

mainColor
secondColor
fillType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members
Overload List


FillStyle Constructor(Color,FillType)

FillStyle Constructor(Color,FillType)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class > FillStyle Constructor : FillStyle Constructor(Color,FillType)

mainColor
fillType

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mainColor As Color, _
   ByVal fillType As FillType _
)
Visual Basic (Usage) Copy Code
Dim mainColor As Color
Dim fillType As FillType

Dim instance As FillStyle(mainColor, fillType)
C#
public FillStyle(
   Color mainColor,
   FillType fillType
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mainColor As Color, _
   ByVal fillType As FillType _
)
Visual Basic (Usage) Copy Code
Dim mainColor As Color
Dim fillType As FillType

Dim instance As FillStyle(mainColor, fillType)
C#
public FillStyle(
   Color mainColor,
   FillType fillType
)

Parameters

mainColor
fillType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members
Overload List


FillStyle Constructor(Object)

FillStyle Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class > FillStyle Constructor : FillStyle Constructor(Object)

container

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As Object _
)
Visual Basic (Usage) Copy Code
Dim container As Object

Dim instance As FillStyle(container)
C#
public FillStyle(
   object container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As Object _
)
Visual Basic (Usage) Copy Code
Dim container As Object

Dim instance As FillStyle(container)
C#
public FillStyle(
   object container
)

Parameters

container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members
Overload List


FillStyle Class Methods

FillStyle Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyle Class

For a list of all members of this type, see FillStyle members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As FillStyle
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FillStyle
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As FillStyle
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As FillStyle
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As FillStyle
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As FillStyle

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


FillStyle Class Properties

FillStyle Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyle Class

For a list of all members of this type, see FillStyle members.

Public Properties

 | Name | Description
Public Property | FillSettings |
Public Property | FillType |
Public Property | GammaCorrection |
Public Property | MainColor |
Public Property | MainColorOpacity |
Public Property | SecondColor |
Public Property | SecondColorOpacity |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


FillSettings Property

FillSettings Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : FillSettings Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property FillSettings As FillSettings
Visual Basic (Usage) Copy Code
Dim instance As FillStyle
Dim value As FillSettings

value = instance.FillSettings
C#
public virtual FillSettings FillSettings {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


FillType Property

FillType Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : FillType Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property FillType As FillType
Visual Basic (Usage) Copy Code
Dim instance As FillStyle
Dim value As FillType

instance.FillType = value

value = instance.FillType
C#
public virtual FillType FillType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


GammaCorrection Property

GammaCorrection Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : GammaCorrection Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property GammaCorrection As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FillStyle
Dim value As Boolean

instance.GammaCorrection = value

value = instance.GammaCorrection
C#
public bool GammaCorrection {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


MainColor Property

MainColor Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : MainColor Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property MainColor As Color
Visual Basic (Usage) Copy Code
Dim instance As FillStyle
Dim value As Color

instance.MainColor = value

value = instance.MainColor
C#
public virtual Color MainColor {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


MainColorOpacity Property

MainColorOpacity Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : MainColorOpacity Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MainColorOpacity As Byte
Visual Basic (Usage) Copy Code
Dim instance As FillStyle
Dim value As Byte

value = instance.MainColorOpacity
C#
public byte MainColorOpacity {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


SecondColor Property

SecondColor Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : SecondColor Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SecondColor As Color
Visual Basic (Usage) Copy Code
Dim instance As FillStyle
Dim value As Color

instance.SecondColor = value

value = instance.SecondColor
C#
public virtual Color SecondColor {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


SecondColorOpacity Property

SecondColorOpacity Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyle Class : SecondColorOpacity Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SecondColorOpacity As Byte
Visual Basic (Usage) Copy Code
Dim instance As FillStyle
Dim value As Byte

value = instance.SecondColorOpacity
C#
public byte SecondColorOpacity {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyle Class
FillStyle Members


FillStyleChart Class

FillStyleChart Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleChart Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FillStyleChart
   Inherits FillStyle
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As FillStyleChart
C#
public class FillStyleChart : FillStyle, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.FillStyle
Telerik.Reporting.Charting.Styles.FillStyleChart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleChart Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleChart Class Members

FillStyleChart Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleChart Class

The following tables list the members exposed by FillStyleChart.

Public Constructors

 | Name | Description
Public Constructor | FillStyleChart Constructor |
Top

Public Properties

 | Name | Description
Public Property | FillSettings | (Inherited from FillStyle)
Public Property | FillType | Overridden.
Public Property | GammaCorrection | (Inherited from FillStyle)
Public Property | MainColor | Overridden.
Public Property | MainColorOpacity | (Inherited from FillStyle)
Public Property | SecondColor | (Inherited from FillStyle)
Public Property | SecondColorOpacity | (Inherited from FillStyle)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillStyle)
Public Method | Equals | (Inherited from FillStyle)
Public Method | GetHashCode | (Inherited from FillStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillStyle)
Protected Method | SaveViewState | (Inherited from FillStyle)
Protected Method | TrackViewState | (Inherited from FillStyle)
Top

See Also

Reference

FillStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleChart Constructor

FillStyleChart Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleChart Class : FillStyleChart Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStyleChart()
C#
public FillStyleChart()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStyleChart()
C#
public FillStyleChart()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleChart Class
FillStyleChart Members


FillStyleChart Class Properties

FillStyleChart Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleChart Class

For a list of all members of this type, see FillStyleChart members.

Public Properties

 | Name | Description
Public Property | FillSettings | (Inherited from FillStyle)
Public Property | FillType | Overridden.
Public Property | GammaCorrection | (Inherited from FillStyle)
Public Property | MainColor | Overridden.
Public Property | MainColorOpacity | (Inherited from FillStyle)
Public Property | SecondColor | (Inherited from FillStyle)
Public Property | SecondColorOpacity | (Inherited from FillStyle)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

FillStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


FillType Property

FillType Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleChart Class : FillType Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property FillType As FillType
Visual Basic (Usage) Copy Code
Dim instance As FillStyleChart
Dim value As FillType

instance.FillType = value

value = instance.FillType
C#
public override FillType FillType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleChart Class
FillStyleChart Members


MainColor Property

MainColor Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleChart Class : MainColor Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property MainColor As Color
Visual Basic (Usage) Copy Code
Dim instance As FillStyleChart
Dim value As Color

instance.MainColor = value

value = instance.MainColor
C#
public override Color MainColor {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleChart Class
FillStyleChart Members


FillStyleMarkedZones Class

FillStyleMarkedZones Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleMarkedZones Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FillStyleMarkedZones
   Inherits FillStyle
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As FillStyleMarkedZones
C#
public class FillStyleMarkedZones : FillStyle, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.FillStyle
Telerik.Reporting.Charting.Styles.FillStyleMarkedZones

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleMarkedZones Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleMarkedZones Class Members

FillStyleMarkedZones Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleMarkedZones Class

The following tables list the members exposed by FillStyleMarkedZones.

Public Constructors

 | Name | Description
Public Constructor | FillStyleMarkedZones Constructor |
Top

Public Properties

 | Name | Description
Public Property | FillSettings | (Inherited from FillStyle)
Public Property | FillType | Overridden.
Public Property | GammaCorrection | (Inherited from FillStyle)
Public Property | MainColor | Overridden.
Public Property | MainColorOpacity | (Inherited from FillStyle)
Public Property | SecondColor | (Inherited from FillStyle)
Public Property | SecondColorOpacity | (Inherited from FillStyle)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillStyle)
Public Method | Equals | (Inherited from FillStyle)
Public Method | GetHashCode | (Inherited from FillStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillStyle)
Protected Method | SaveViewState | (Inherited from FillStyle)
Protected Method | TrackViewState | (Inherited from FillStyle)
Top

See Also

Reference

FillStyleMarkedZones Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleMarkedZones Constructor

FillStyleMarkedZones Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleMarkedZones Class : FillStyleMarkedZones Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStyleMarkedZones()
C#
public FillStyleMarkedZones()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStyleMarkedZones()
C#
public FillStyleMarkedZones()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleMarkedZones Class
FillStyleMarkedZones Members


FillStyleMarkedZones Class Properties

FillStyleMarkedZones Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleMarkedZones Class

For a list of all members of this type, see FillStyleMarkedZones members.

Public Properties

 | Name | Description
Public Property | FillSettings | (Inherited from FillStyle)
Public Property | FillType | Overridden.
Public Property | GammaCorrection | (Inherited from FillStyle)
Public Property | MainColor | Overridden.
Public Property | MainColorOpacity | (Inherited from FillStyle)
Public Property | SecondColor | (Inherited from FillStyle)
Public Property | SecondColorOpacity | (Inherited from FillStyle)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

FillStyleMarkedZones Class
Telerik.Reporting.Charting.Styles Namespace


FillType Property

FillType Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleMarkedZones Class : FillType Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property FillType As FillType
Visual Basic (Usage) Copy Code
Dim instance As FillStyleMarkedZones
Dim value As FillType

instance.FillType = value

value = instance.FillType
C#
public override FillType FillType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleMarkedZones Class
FillStyleMarkedZones Members


MainColor Property

MainColor Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleMarkedZones Class : MainColor Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property MainColor As Color
Visual Basic (Usage) Copy Code
Dim instance As FillStyleMarkedZones
Dim value As Color

instance.MainColor = value

value = instance.MainColor
C#
public override Color MainColor {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleMarkedZones Class
FillStyleMarkedZones Members


FillStylePlotArea Class

FillStylePlotArea Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStylePlotArea Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FillStylePlotArea
   Inherits FillStyle
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As FillStylePlotArea
C#
public class FillStylePlotArea : FillStyle, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.FillStyle
Telerik.Reporting.Charting.Styles.FillStylePlotArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStylePlotArea Members
Telerik.Reporting.Charting.Styles Namespace


FillStylePlotArea Class Members

FillStylePlotArea Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStylePlotArea Class

The following tables list the members exposed by FillStylePlotArea.

Public Constructors

 | Name | Description
Public Constructor | FillStylePlotArea Constructor |
Top

Public Properties

 | Name | Description
Public Property | FillSettings | (Inherited from FillStyle)
Public Property | FillType | Overridden.
Public Property | GammaCorrection | (Inherited from FillStyle)
Public Property | MainColor | Overridden.
Public Property | MainColorOpacity | (Inherited from FillStyle)
Public Property | SecondColor | Overridden.
Public Property | SecondColorOpacity | (Inherited from FillStyle)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillStyle)
Public Method | Equals | (Inherited from FillStyle)
Public Method | GetHashCode | (Inherited from FillStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillStyle)
Protected Method | SaveViewState | (Inherited from FillStyle)
Protected Method | TrackViewState | (Inherited from FillStyle)
Top

See Also

Reference

FillStylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


FillStylePlotArea Constructor

FillStylePlotArea Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStylePlotArea Class : FillStylePlotArea Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStylePlotArea()
C#
public FillStylePlotArea()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStylePlotArea()
C#
public FillStylePlotArea()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStylePlotArea Class
FillStylePlotArea Members


FillStylePlotArea Class Properties

FillStylePlotArea Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStylePlotArea Class

For a list of all members of this type, see FillStylePlotArea members.

Public Properties

 | Name | Description
Public Property | FillSettings | (Inherited from FillStyle)
Public Property | FillType | Overridden.
Public Property | GammaCorrection | (Inherited from FillStyle)
Public Property | MainColor | Overridden.
Public Property | MainColorOpacity | (Inherited from FillStyle)
Public Property | SecondColor | Overridden.
Public Property | SecondColorOpacity | (Inherited from FillStyle)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

FillStylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


FillType Property

FillType Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStylePlotArea Class : FillType Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property FillType As FillType
Visual Basic (Usage) Copy Code
Dim instance As FillStylePlotArea
Dim value As FillType

instance.FillType = value

value = instance.FillType
C#
public override FillType FillType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStylePlotArea Class
FillStylePlotArea Members


MainColor Property

MainColor Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStylePlotArea Class : MainColor Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property MainColor As Color
Visual Basic (Usage) Copy Code
Dim instance As FillStylePlotArea
Dim value As Color

instance.MainColor = value

value = instance.MainColor
C#
public override Color MainColor {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStylePlotArea Class
FillStylePlotArea Members


SecondColor Property

SecondColor Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStylePlotArea Class : SecondColor Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property SecondColor As Color
Visual Basic (Usage) Copy Code
Dim instance As FillStylePlotArea
Dim value As Color

instance.SecondColor = value

value = instance.SecondColor
C#
public override Color SecondColor {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStylePlotArea Class
FillStylePlotArea Members


FillStyleSeries Class

FillStyleSeries Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleSeries Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FillStyleSeries
   Inherits FillStyle
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As FillStyleSeries
C#
public class FillStyleSeries : FillStyle, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.FillStyle
Telerik.Reporting.Charting.Styles.FillStyleSeries

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleSeries Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeries Class Members

FillStyleSeries Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleSeries Class

The following tables list the members exposed by FillStyleSeries.

Public Constructors

 | Name | Description
Public Constructor | FillStyleSeries Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty |
Top

Public Properties

 | Name | Description
Public Property | FillSettings | (Inherited from FillStyle)
Public Property | FillType | (Inherited from FillStyle)
Public Property | GammaCorrection | (Inherited from FillStyle)
Public Property | MainColor | Overridden.
Public Property | MainColorOpacity | (Inherited from FillStyle)
Public Property | SecondColor | Overridden.
Public Property | SecondColorOpacity | (Inherited from FillStyle)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillStyle)
Public Method | Equals | (Inherited from FillStyle)
Public Method | GetHashCode | (Inherited from FillStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillStyle)
Protected Method | SaveViewState | (Inherited from FillStyle)
Protected Method | TrackViewState | (Inherited from FillStyle)
Top

See Also

Reference

FillStyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeries Constructor

FillStyleSeries Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleSeries Class : FillStyleSeries Constructor

Overload List

Overload | Description
FillStyleSeries Constructor() |
FillStyleSeries Constructor(ChartSeries) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleSeries Class
FillStyleSeries Members


FillStyleSeries Constructor()

FillStyleSeries Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleSeries Class > FillStyleSeries Constructor : FillStyleSeries Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStyleSeries()
C#
public FillStyleSeries()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStyleSeries()
C#
public FillStyleSeries()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleSeries Class
FillStyleSeries Members
Overload List


FillStyleSeries Constructor(ChartSeries)

FillStyleSeries Constructor(ChartSeries)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleSeries Class > FillStyleSeries Constructor : FillStyleSeries Constructor(ChartSeries)

series

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As FillStyleSeries(series)
C#
public FillStyleSeries(
   ChartSeries series
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As FillStyleSeries(series)
C#
public FillStyleSeries(
   ChartSeries series
)

Parameters

series

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleSeries Class
FillStyleSeries Members
Overload List


FillStyleSeries Class Properties

FillStyleSeries Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleSeries Class

For a list of all members of this type, see FillStyleSeries members.

Public Properties

 | Name | Description
Public Property | FillSettings | (Inherited from FillStyle)
Public Property | FillType | (Inherited from FillStyle)
Public Property | GammaCorrection | (Inherited from FillStyle)
Public Property | MainColor | Overridden.
Public Property | MainColorOpacity | (Inherited from FillStyle)
Public Property | SecondColor | Overridden.
Public Property | SecondColorOpacity | (Inherited from FillStyle)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

FillStyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


MainColor Property

MainColor Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleSeries Class : MainColor Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property MainColor As Color
Visual Basic (Usage) Copy Code
Dim instance As FillStyleSeries
Dim value As Color

instance.MainColor = value

value = instance.MainColor
C#
public override Color MainColor {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleSeries Class
FillStyleSeries Members


SecondColor Property

SecondColor Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleSeries Class : SecondColor Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property SecondColor As Color
Visual Basic (Usage) Copy Code
Dim instance As FillStyleSeries
Dim value As Color

instance.SecondColor = value

value = instance.SecondColor
C#
public override Color SecondColor {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleSeries Class
FillStyleSeries Members


FillStyleSeries Class Fields

FillStyleSeries Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleSeries Class

For a list of all members of this type, see FillStyleSeries members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty |
Top

See Also

Reference

FillStyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


Empty Field

Empty Field
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleSeries Class : Empty Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As FillStyleSeries
Visual Basic (Usage) Copy Code
Dim value As FillStyleSeries

value = FillStyleSeries.Empty
C#
public static readonly FillStyleSeries Empty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleSeries Class
FillStyleSeries Members


FillStyleSeriesPoint Class

FillStyleSeriesPoint Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleSeriesPoint Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FillStyleSeriesPoint
   Inherits FillStyle
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As FillStyleSeriesPoint
C#
public class FillStyleSeriesPoint : FillStyle, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.FillStyle
Telerik.Reporting.Charting.Styles.FillStyleSeriesPoint

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleSeriesPoint Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeriesPoint Class Members

FillStyleSeriesPoint Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleSeriesPoint Class

The following tables list the members exposed by FillStyleSeriesPoint.

Public Constructors

 | Name | Description
Public Constructor | FillStyleSeriesPoint Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | FillSettings | (Inherited from FillStyle)
Public Property | FillType | (Inherited from FillStyle)
Public Property | GammaCorrection | (Inherited from FillStyle)
Public Property | MainColor | (Inherited from FillStyle)
Public Property | MainColorOpacity | (Inherited from FillStyle)
Public Property | SecondColor | (Inherited from FillStyle)
Public Property | SecondColorOpacity | (Inherited from FillStyle)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillStyle)
Public Method | Equals | (Inherited from FillStyle)
Public Method | GetHashCode | (Inherited from FillStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillStyle)
Protected Method | SaveViewState | (Inherited from FillStyle)
Protected Method | TrackViewState | (Inherited from FillStyle)
Top

See Also

Reference

FillStyleSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeriesPoint Constructor

FillStyleSeriesPoint Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleSeriesPoint Class : FillStyleSeriesPoint Constructor

Overload List

Overload | Description
FillStyleSeriesPoint Constructor() |
FillStyleSeriesPoint Constructor(Object) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleSeriesPoint Class
FillStyleSeriesPoint Members


FillStyleSeriesPoint Constructor()

FillStyleSeriesPoint Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleSeriesPoint Class > FillStyleSeriesPoint Constructor : FillStyleSeriesPoint Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStyleSeriesPoint()
C#
public FillStyleSeriesPoint()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStyleSeriesPoint()
C#
public FillStyleSeriesPoint()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleSeriesPoint Class
FillStyleSeriesPoint Members
Overload List


FillStyleSeriesPoint Constructor(Object)

FillStyleSeriesPoint Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleSeriesPoint Class > FillStyleSeriesPoint Constructor : FillStyleSeriesPoint Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As FillStyleSeriesPoint(containerObject)
C#
public FillStyleSeriesPoint(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As FillStyleSeriesPoint(containerObject)
C#
public FillStyleSeriesPoint(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleSeriesPoint Class
FillStyleSeriesPoint Members
Overload List


FillStyleTitle Class

FillStyleTitle Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleTitle Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FillStyleTitle
   Inherits FillStyle
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As FillStyleTitle
C#
public class FillStyleTitle : FillStyle, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.FillStyle
Telerik.Reporting.Charting.Styles.FillStyleTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleTitle Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleTitle Class Members

FillStyleTitle Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleTitle Class

The following tables list the members exposed by FillStyleTitle.

Public Constructors

 | Name | Description
Public Constructor | FillStyleTitle Constructor |
Top

Public Properties

 | Name | Description
Public Property | FillSettings | (Inherited from FillStyle)
Public Property | FillType | Overridden.
Public Property | GammaCorrection | (Inherited from FillStyle)
Public Property | MainColor | Overridden.
Public Property | MainColorOpacity | (Inherited from FillStyle)
Public Property | SecondColor | (Inherited from FillStyle)
Public Property | SecondColorOpacity | (Inherited from FillStyle)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillStyle)
Public Method | Equals | (Inherited from FillStyle)
Public Method | GetHashCode | (Inherited from FillStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillStyle)
Protected Method | SaveViewState | (Inherited from FillStyle)
Protected Method | TrackViewState | (Inherited from FillStyle)
Top

See Also

Reference

FillStyleTitle Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleTitle Constructor

FillStyleTitle Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleTitle Class : FillStyleTitle Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStyleTitle()
C#
public FillStyleTitle()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FillStyleTitle()
C#
public FillStyleTitle()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleTitle Class
FillStyleTitle Members


FillStyleTitle Class Properties

FillStyleTitle Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleTitle Class

For a list of all members of this type, see FillStyleTitle members.

Public Properties

 | Name | Description
Public Property | FillSettings | (Inherited from FillStyle)
Public Property | FillType | Overridden.
Public Property | GammaCorrection | (Inherited from FillStyle)
Public Property | MainColor | Overridden.
Public Property | MainColorOpacity | (Inherited from FillStyle)
Public Property | SecondColor | (Inherited from FillStyle)
Public Property | SecondColorOpacity | (Inherited from FillStyle)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

FillStyleTitle Class
Telerik.Reporting.Charting.Styles Namespace


FillType Property

FillType Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleTitle Class : FillType Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property FillType As FillType
Visual Basic (Usage) Copy Code
Dim instance As FillStyleTitle
Dim value As FillType

instance.FillType = value

value = instance.FillType
C#
public override FillType FillType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleTitle Class
FillStyleTitle Members


MainColor Property

MainColor Property
[image]
Telerik.Reporting.Charting.Styles Namespace > FillStyleTitle Class : MainColor Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property MainColor As Color
Visual Basic (Usage) Copy Code
Dim instance As FillStyleTitle
Dim value As Color

instance.MainColor = value

value = instance.MainColor
C#
public override Color MainColor {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FillStyleTitle Class
FillStyleTitle Members


LayoutDecoratorBase Class

LayoutDecoratorBase Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : LayoutDecoratorBase Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class LayoutDecoratorBase
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As LayoutDecoratorBase
C#
public class LayoutDecoratorBase : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles.ChartMargins
Telerik.Reporting.Charting.Styles.ChartPaddings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Members
Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Class Members

LayoutDecoratorBase Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : LayoutDecoratorBase Class

The following tables list the members exposed by LayoutDecoratorBase.

Public Constructors

 | Name | Description
Public Constructor | LayoutDecoratorBase Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Bottom |
Public Property | Left |
Public Property | Right |
Public Property | Top |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | CopyFrom |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Operators

Public Operator Equality
Public Operator Inequality
Top

See Also

Reference

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Constructor

LayoutDecoratorBase Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class : LayoutDecoratorBase Constructor

Overload List

Overload | Description
LayoutDecoratorBase Constructor() |
LayoutDecoratorBase Constructor(Int32,Int32,Int32,Int32) |
LayoutDecoratorBase Constructor(Object) |
LayoutDecoratorBase Constructor(Object,Unit,Unit,Unit,Unit) |
LayoutDecoratorBase Constructor(Unit) |
LayoutDecoratorBase Constructor(Unit,Unit,Unit,Unit) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members


LayoutDecoratorBase Constructor()

LayoutDecoratorBase Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class > LayoutDecoratorBase Constructor : LayoutDecoratorBase Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LayoutDecoratorBase()
C#
public LayoutDecoratorBase()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LayoutDecoratorBase()
C#
public LayoutDecoratorBase()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members
Overload List


LayoutDecoratorBase Constructor(Int32,Int32,Int32,Int32)

LayoutDecoratorBase Constructor(Int32,Int32,Int32,Int32)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class > LayoutDecoratorBase Constructor : LayoutDecoratorBase Constructor(Int32,Int32,Int32,Int32)

top
right
bottom
left

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer, _
   ByVal left As Integer _
)
Visual Basic (Usage) Copy Code
Dim top As Integer
Dim right As Integer
Dim bottom As Integer
Dim left As Integer

Dim instance As LayoutDecoratorBase(top, right, bottom, left)
C#
public LayoutDecoratorBase(
   int top,
   int right,
   int bottom,
   int left
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer, _
   ByVal left As Integer _
)
Visual Basic (Usage) Copy Code
Dim top As Integer
Dim right As Integer
Dim bottom As Integer
Dim left As Integer

Dim instance As LayoutDecoratorBase(top, right, bottom, left)
C#
public LayoutDecoratorBase(
   int top,
   int right,
   int bottom,
   int left
)

Parameters

top
right
bottom
left

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members
Overload List


LayoutDecoratorBase Constructor(Object)

LayoutDecoratorBase Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class > LayoutDecoratorBase Constructor : LayoutDecoratorBase Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As LayoutDecoratorBase(containerObject)
C#
public LayoutDecoratorBase(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As LayoutDecoratorBase(containerObject)
C#
public LayoutDecoratorBase(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members
Overload List


LayoutDecoratorBase Constructor(Object,Unit,Unit,Unit,Unit)

LayoutDecoratorBase Constructor(Object,Unit,Unit,Unit,Unit)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class > LayoutDecoratorBase Constructor : LayoutDecoratorBase Constructor(Object,Unit,Unit,Unit,Unit)

containerObject
top
right
bottom
left

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object, _
   ByVal top As Unit, _
   ByVal right As Unit, _
   ByVal bottom As Unit, _
   ByVal left As Unit _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object
Dim top As Unit
Dim right As Unit
Dim bottom As Unit
Dim left As Unit

Dim instance As LayoutDecoratorBase(containerObject, top, right, bottom, left)
C#
public LayoutDecoratorBase(
   object containerObject,
   Unit top,
   Unit right,
   Unit bottom,
   Unit left
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object, _
   ByVal top As Unit, _
   ByVal right As Unit, _
   ByVal bottom As Unit, _
   ByVal left As Unit _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object
Dim top As Unit
Dim right As Unit
Dim bottom As Unit
Dim left As Unit

Dim instance As LayoutDecoratorBase(containerObject, top, right, bottom, left)
C#
public LayoutDecoratorBase(
   object containerObject,
   Unit top,
   Unit right,
   Unit bottom,
   Unit left
)

Parameters

containerObject
top
right
bottom
left

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members
Overload List


LayoutDecoratorBase Constructor(Unit)

LayoutDecoratorBase Constructor(Unit)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class > LayoutDecoratorBase Constructor : LayoutDecoratorBase Constructor(Unit)

value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Unit _
)
Visual Basic (Usage) Copy Code
Dim value As Unit

Dim instance As LayoutDecoratorBase(value)
C#
public LayoutDecoratorBase(
   Unit value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Unit _
)
Visual Basic (Usage) Copy Code
Dim value As Unit

Dim instance As LayoutDecoratorBase(value)
C#
public LayoutDecoratorBase(
   Unit value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members
Overload List


LayoutDecoratorBase Constructor(Unit,Unit,Unit,Unit)

LayoutDecoratorBase Constructor(Unit,Unit,Unit,Unit)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class > LayoutDecoratorBase Constructor : LayoutDecoratorBase Constructor(Unit,Unit,Unit,Unit)

top
right
bottom
left

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal top As Unit, _
   ByVal right As Unit, _
   ByVal bottom As Unit, _
   ByVal left As Unit _
)
Visual Basic (Usage) Copy Code
Dim top As Unit
Dim right As Unit
Dim bottom As Unit
Dim left As Unit

Dim instance As LayoutDecoratorBase(top, right, bottom, left)
C#
public LayoutDecoratorBase(
   Unit top,
   Unit right,
   Unit bottom,
   Unit left
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal top As Unit, _
   ByVal right As Unit, _
   ByVal bottom As Unit, _
   ByVal left As Unit _
)
Visual Basic (Usage) Copy Code
Dim top As Unit
Dim right As Unit
Dim bottom As Unit
Dim left As Unit

Dim instance As LayoutDecoratorBase(top, right, bottom, left)
C#
public LayoutDecoratorBase(
   Unit top,
   Unit right,
   Unit bottom,
   Unit left
)

Parameters

top
right
bottom
left

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members
Overload List


LayoutDecoratorBase Class Methods

LayoutDecoratorBase Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : LayoutDecoratorBase Class

For a list of all members of this type, see LayoutDecoratorBase members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | CopyFrom |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As LayoutDecoratorBase
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members


CopyFrom Method

CopyFrom Method
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class : CopyFrom Method

layoutDecorator

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyFrom( _
   ByVal layoutDecorator As LayoutDecoratorBase _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutDecoratorBase
Dim layoutDecorator As LayoutDecoratorBase

instance.CopyFrom(layoutDecorator)
C#
public void CopyFrom(
   LayoutDecoratorBase layoutDecorator
)

Parameters

layoutDecorator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutDecoratorBase
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutDecoratorBase
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members


LayoutDecoratorBase Class Properties

LayoutDecoratorBase Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : LayoutDecoratorBase Class

For a list of all members of this type, see LayoutDecoratorBase members.

Public Properties

 | Name | Description
Public Property | Bottom |
Public Property | Left |
Public Property | Right |
Public Property | Top |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


Bottom Property

Bottom Property
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class : Bottom Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Bottom As Unit
Visual Basic (Usage) Copy Code
Dim instance As LayoutDecoratorBase
Dim value As Unit

instance.Bottom = value

value = instance.Bottom
C#
public virtual Unit Bottom {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members


Left Property

Left Property
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class : Left Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Left As Unit
Visual Basic (Usage) Copy Code
Dim instance As LayoutDecoratorBase
Dim value As Unit

instance.Left = value

value = instance.Left
C#
public virtual Unit Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members


Right Property

Right Property
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class : Right Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Right As Unit
Visual Basic (Usage) Copy Code
Dim instance As LayoutDecoratorBase
Dim value As Unit

instance.Right = value

value = instance.Right
C#
public virtual Unit Right {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members


Top Property

Top Property
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class : Top Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Top As Unit
Visual Basic (Usage) Copy Code
Dim instance As LayoutDecoratorBase
Dim value As Unit

instance.Top = value

value = instance.Top
C#
public virtual Unit Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members


Equality Operator

Equality Operator
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class : Equality Operator

layoutDecoratorOne
layoutDecoratorTwo

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal layoutDecoratorOne As LayoutDecoratorBase, _
   ByVal layoutDecoratorTwo As LayoutDecoratorBase _
) As Boolean
C#
public bool operator ==(
   LayoutDecoratorBase layoutDecoratorOne,
   LayoutDecoratorBase layoutDecoratorTwo
)

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal layoutDecoratorOne As LayoutDecoratorBase, _
   ByVal layoutDecoratorTwo As LayoutDecoratorBase _
) As Boolean
C#
public bool operator ==(
   LayoutDecoratorBase layoutDecoratorOne,
   LayoutDecoratorBase layoutDecoratorTwo
)

Parameters

layoutDecoratorOne
layoutDecoratorTwo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members


Inequality Operator

Inequality Operator
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutDecoratorBase Class : Inequality Operator

layoutDecoratorOne
layoutDecoratorTwo

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal layoutDecoratorOne As LayoutDecoratorBase, _
   ByVal layoutDecoratorTwo As LayoutDecoratorBase _
) As Boolean
C#
public bool operator !=(
   LayoutDecoratorBase layoutDecoratorOne,
   LayoutDecoratorBase layoutDecoratorTwo
)

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal layoutDecoratorOne As LayoutDecoratorBase, _
   ByVal layoutDecoratorTwo As LayoutDecoratorBase _
) As Boolean
C#
public bool operator !=(
   LayoutDecoratorBase layoutDecoratorOne,
   LayoutDecoratorBase layoutDecoratorTwo
)

Parameters

layoutDecoratorOne
layoutDecoratorTwo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutDecoratorBase Class
LayoutDecoratorBase Members


LayoutStyle Class

LayoutStyle Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : LayoutStyle Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class LayoutStyle
   Inherits Style
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As LayoutStyle
C#
public class LayoutStyle : Style, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleChart
Telerik.Reporting.Charting.Styles.StyleChartDataTable
Telerik.Reporting.Charting.Styles.StyleLabel
Telerik.Reporting.Charting.Styles.StyleMarker
Telerik.Reporting.Charting.Styles.StylePlotArea
Telerik.Reporting.Charting.Styles.StyleTextBlock

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutStyle Members
Telerik.Reporting.Charting.Styles Namespace


LayoutStyle Class Members

LayoutStyle Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : LayoutStyle Class

The following tables list the members exposed by LayoutStyle.

Public Constructors

 | Name | Description
Public Constructor | LayoutStyle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Dimensions |
Public Property | Position |
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Style)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

LayoutStyle Class
Telerik.Reporting.Charting.Styles Namespace


LayoutStyle Constructor

LayoutStyle Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutStyle Class : LayoutStyle Constructor

Overload List

Overload | Description
LayoutStyle Constructor(Dimensions) |
LayoutStyle Constructor(Object) |
LayoutStyle Constructor(Position) |
LayoutStyle Constructor(Position,Dimensions) |
LayoutStyle Constructor(StyleBorder,Boolean,ShadowStyle,Position,Dimensions) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutStyle Class
LayoutStyle Members


LayoutStyle Constructor(Dimensions)

LayoutStyle Constructor(Dimensions)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutStyle Class > LayoutStyle Constructor : LayoutStyle Constructor(Dimensions)

dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim dimensions As Dimensions

Dim instance As LayoutStyle(dimensions)
C#
public LayoutStyle(
   Dimensions dimensions
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim dimensions As Dimensions

Dim instance As LayoutStyle(dimensions)
C#
public LayoutStyle(
   Dimensions dimensions
)

Parameters

dimensions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutStyle Class
LayoutStyle Members
Overload List


LayoutStyle Constructor(Object)

LayoutStyle Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutStyle Class > LayoutStyle Constructor : LayoutStyle Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As LayoutStyle(containerObject)
C#
public LayoutStyle(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As LayoutStyle(containerObject)
C#
public LayoutStyle(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutStyle Class
LayoutStyle Members
Overload List


LayoutStyle Constructor(Position)

LayoutStyle Constructor(Position)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutStyle Class > LayoutStyle Constructor : LayoutStyle Constructor(Position)

position

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim position As Position

Dim instance As LayoutStyle(position)
C#
public LayoutStyle(
   Position position
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim position As Position

Dim instance As LayoutStyle(position)
C#
public LayoutStyle(
   Position position
)

Parameters

position

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutStyle Class
LayoutStyle Members
Overload List


LayoutStyle Constructor(Position,Dimensions)

LayoutStyle Constructor(Position,Dimensions)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutStyle Class > LayoutStyle Constructor : LayoutStyle Constructor(Position,Dimensions)

position
dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As Position, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim position As Position
Dim dimensions As Dimensions

Dim instance As LayoutStyle(position, dimensions)
C#
public LayoutStyle(
   Position position,
   Dimensions dimensions
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As Position, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim position As Position
Dim dimensions As Dimensions

Dim instance As LayoutStyle(position, dimensions)
C#
public LayoutStyle(
   Position position,
   Dimensions dimensions
)

Parameters

position
dimensions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutStyle Class
LayoutStyle Members
Overload List


LayoutStyle Constructor(StyleBorder,Boolean,ShadowStyle,Position,Dimensions)

LayoutStyle Constructor(StyleBorder,Boolean,ShadowStyle,Position,Dimensions)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutStyle Class > LayoutStyle Constructor : LayoutStyle Constructor(StyleBorder,Boolean,ShadowStyle,Position,Dimensions)

border
visible
shadowStyle
position
dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal border As StyleBorder, _
   ByVal visible As Boolean, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal position As Position, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim border As StyleBorder
Dim visible As Boolean
Dim shadowStyle As ShadowStyle
Dim position As Position
Dim dimensions As Dimensions

Dim instance As LayoutStyle(border, visible, shadowStyle, position, dimensions)
C#
public LayoutStyle(
   StyleBorder border,
   bool visible,
   ShadowStyle shadowStyle,
   Position position,
   Dimensions dimensions
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal border As StyleBorder, _
   ByVal visible As Boolean, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal position As Position, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim border As StyleBorder
Dim visible As Boolean
Dim shadowStyle As ShadowStyle
Dim position As Position
Dim dimensions As Dimensions

Dim instance As LayoutStyle(border, visible, shadowStyle, position, dimensions)
C#
public LayoutStyle(
   StyleBorder border,
   bool visible,
   ShadowStyle shadowStyle,
   Position position,
   Dimensions dimensions
)

Parameters

border
visible
shadowStyle
position
dimensions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutStyle Class
LayoutStyle Members
Overload List


LayoutStyle Class Methods

LayoutStyle Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : LayoutStyle Class

For a list of all members of this type, see LayoutStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Style)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

LayoutStyle Class
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutStyle Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutStyle
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutStyle Class
LayoutStyle Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutStyle Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As LayoutStyle
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutStyle Class
LayoutStyle Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutStyle Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As LayoutStyle

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutStyle Class
LayoutStyle Members


LayoutStyle Class Properties

LayoutStyle Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : LayoutStyle Class

For a list of all members of this type, see LayoutStyle members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Dimensions |
Public Property | Position |
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

LayoutStyle Class
Telerik.Reporting.Charting.Styles Namespace


Dimensions Property

Dimensions Property
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutStyle Class : Dimensions Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Dimensions As Dimensions
Visual Basic (Usage) Copy Code
Dim instance As LayoutStyle
Dim value As Dimensions

value = instance.Dimensions
C#
public virtual Dimensions Dimensions {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutStyle Class
LayoutStyle Members


Position Property

Position Property
[image]
Telerik.Reporting.Charting.Styles Namespace > LayoutStyle Class : Position Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Position As Position
Visual Basic (Usage) Copy Code
Dim instance As LayoutStyle
Dim value As Position

value = instance.Position
C#
public virtual Position Position {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayoutStyle Class
LayoutStyle Members


LineStyle Class

LineStyle Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : LineStyle Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class LineStyle
   Inherits StyleBorder
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As LineStyle
C#
public class LineStyle : StyleBorder, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.ScaleBreaksLineStyle
Telerik.Reporting.Charting.Styles.StyleAxis
Telerik.Reporting.Charting.Styles.StyleGridLine
Telerik.Reporting.Charting.Styles.StyleItemLabelConnector
Telerik.Reporting.Charting.Styles.StyleLineSeries
Telerik.Reporting.Charting.Styles.StyleTick

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Members
Telerik.Reporting.Charting.Styles Namespace


LineStyle Class Members

LineStyle Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : LineStyle Class

The following tables list the members exposed by LineStyle.

Public Constructors

 | Name | Description
Public Constructor | LineStyle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleBorder)
Public Property | EndCap |
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap |
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

LineStyle Class
Telerik.Reporting.Charting.Styles Namespace


LineStyle Constructor

LineStyle Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > LineStyle Class : LineStyle Constructor

Overload List

Overload | Description
LineStyle Constructor() |
LineStyle Constructor(Boolean) |
LineStyle Constructor(Color) |
LineStyle Constructor(Color,Single) |
LineStyle Constructor(Color,Single,DashStyle) |
LineStyle Constructor(Color,Single,DashStyle,LineCap) |
LineStyle Constructor(Object) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Class
LineStyle Members


LineStyle Constructor()

LineStyle Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LineStyle Class > LineStyle Constructor : LineStyle Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LineStyle()
C#
public LineStyle()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LineStyle()
C#
public LineStyle()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Class
LineStyle Members
Overload List


LineStyle Constructor(Boolean)

LineStyle Constructor(Boolean)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LineStyle Class > LineStyle Constructor : LineStyle Constructor(Boolean)

visible

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim visible As Boolean

Dim instance As LineStyle(visible)
C#
public LineStyle(
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim visible As Boolean

Dim instance As LineStyle(visible)
C#
public LineStyle(
   bool visible
)

Parameters

visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Class
LineStyle Members
Overload List


LineStyle Constructor(Color)

LineStyle Constructor(Color)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LineStyle Class > LineStyle Constructor : LineStyle Constructor(Color)

color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim color As Color

Dim instance As LineStyle(color)
C#
public LineStyle(
   Color color
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim color As Color

Dim instance As LineStyle(color)
C#
public LineStyle(
   Color color
)

Parameters

color

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Class
LineStyle Members
Overload List


LineStyle Constructor(Color,Single)

LineStyle Constructor(Color,Single)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LineStyle Class > LineStyle Constructor : LineStyle Constructor(Color,Single)

color
width

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal width As Single _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim width As Single

Dim instance As LineStyle(color, width)
C#
public LineStyle(
   Color color,
   float width
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal width As Single _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim width As Single

Dim instance As LineStyle(color, width)
C#
public LineStyle(
   Color color,
   float width
)

Parameters

color
width

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Class
LineStyle Members
Overload List


LineStyle Constructor(Color,Single,DashStyle)

LineStyle Constructor(Color,Single,DashStyle)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LineStyle Class > LineStyle Constructor : LineStyle Constructor(Color,Single,DashStyle)

color
width
penStyle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal width As Single, _
   ByVal penStyle As DashStyle _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim width As Single
Dim penStyle As DashStyle

Dim instance As LineStyle(color, width, penStyle)
C#
public LineStyle(
   Color color,
   float width,
   DashStyle penStyle
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal width As Single, _
   ByVal penStyle As DashStyle _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim width As Single
Dim penStyle As DashStyle

Dim instance As LineStyle(color, width, penStyle)
C#
public LineStyle(
   Color color,
   float width,
   DashStyle penStyle
)

Parameters

color
width
penStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Class
LineStyle Members
Overload List


LineStyle Constructor(Color,Single,DashStyle,LineCap)

LineStyle Constructor(Color,Single,DashStyle,LineCap)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LineStyle Class > LineStyle Constructor : LineStyle Constructor(Color,Single,DashStyle,LineCap)

color
width
penStyle
endCap

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal width As Single, _
   ByVal penStyle As DashStyle, _
   ByVal endCap As LineCap _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim width As Single
Dim penStyle As DashStyle
Dim endCap As LineCap

Dim instance As LineStyle(color, width, penStyle, endCap)
C#
public LineStyle(
   Color color,
   float width,
   DashStyle penStyle,
   LineCap endCap
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal width As Single, _
   ByVal penStyle As DashStyle, _
   ByVal endCap As LineCap _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim width As Single
Dim penStyle As DashStyle
Dim endCap As LineCap

Dim instance As LineStyle(color, width, penStyle, endCap)
C#
public LineStyle(
   Color color,
   float width,
   DashStyle penStyle,
   LineCap endCap
)

Parameters

color
width
penStyle
endCap

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Class
LineStyle Members
Overload List


LineStyle Constructor(Object)

LineStyle Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > LineStyle Class > LineStyle Constructor : LineStyle Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As LineStyle(containerObject)
C#
public LineStyle(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As LineStyle(containerObject)
C#
public LineStyle(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Class
LineStyle Members
Overload List


LineStyle Class Methods

LineStyle Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : LineStyle Class

For a list of all members of this type, see LineStyle members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

LineStyle Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > LineStyle Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As LineStyle
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Class
LineStyle Members


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting.Styles Namespace > LineStyle Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LineStyle
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Class
LineStyle Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting.Styles Namespace > LineStyle Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LineStyle
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Class
LineStyle Members


LineStyle Class Properties

LineStyle Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : LineStyle Class

For a list of all members of this type, see LineStyle members.

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleBorder)
Public Property | EndCap |
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap |
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

LineStyle Class
Telerik.Reporting.Charting.Styles Namespace


EndCap Property

EndCap Property
[image]
Telerik.Reporting.Charting.Styles Namespace > LineStyle Class : EndCap Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property EndCap As LineCap
Visual Basic (Usage) Copy Code
Dim instance As LineStyle
Dim value As LineCap

instance.EndCap = value

value = instance.EndCap
C#
public virtual LineCap EndCap {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Class
LineStyle Members


StartCap Property

StartCap Property
[image]
Telerik.Reporting.Charting.Styles Namespace > LineStyle Class : StartCap Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property StartCap As LineCap
Visual Basic (Usage) Copy Code
Dim instance As LineStyle
Dim value As LineCap

instance.StartCap = value

value = instance.StartCap
C#
public virtual LineCap StartCap {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineStyle Class
LineStyle Members


Position Class

Position Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : Position Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Position
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As Position
C#
public class Position : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Position
Telerik.Reporting.Charting.Styles.PositionBottom
Telerik.Reporting.Charting.Styles.PositionCenter
Telerik.Reporting.Charting.Styles.PositionLeft
Telerik.Reporting.Charting.Styles.PositionRight
Telerik.Reporting.Charting.Styles.PositionTop
Telerik.Reporting.Charting.Styles.PositionTopLeft
Telerik.Reporting.Charting.Styles.PositionTopRight

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Members
Telerik.Reporting.Charting.Styles Namespace


Position Class Members

Position Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : Position Class

The following tables list the members exposed by Position.

Public Constructors

 | Name | Description
Public Constructor | Position Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AlignedPosition |
Public Property | Auto |
Public Property | X |
Public Property | Y |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX |
Protected Method | ResetY |
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX |
Protected Method | ShouldSerializeY |
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

Position Class
Telerik.Reporting.Charting.Styles Namespace


Position Constructor

Position Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class : Position Constructor

Overload List

Overload | Description
Position Constructor() |
Position Constructor(AlignedPositions) |
Position Constructor(AlignedPositions,Single,Single) |
Position Constructor(Object) |
Position Constructor(Single,Single) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members


Position Constructor()

Position Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class > Position Constructor : Position Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Position()
C#
public Position()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Position()
C#
public Position()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members
Overload List


Position Constructor(AlignedPositions)

Position Constructor(AlignedPositions)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class > Position Constructor : Position Constructor(AlignedPositions)

position

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As AlignedPositions _
)
Visual Basic (Usage) Copy Code
Dim position As AlignedPositions

Dim instance As Position(position)
C#
public Position(
   AlignedPositions position
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As AlignedPositions _
)
Visual Basic (Usage) Copy Code
Dim position As AlignedPositions

Dim instance As Position(position)
C#
public Position(
   AlignedPositions position
)

Parameters

position

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members
Overload List


Position Constructor(AlignedPositions,Single,Single)

Position Constructor(AlignedPositions,Single,Single)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class > Position Constructor : Position Constructor(AlignedPositions,Single,Single)

position
x
y

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As AlignedPositions, _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim position As AlignedPositions
Dim x As Single
Dim y As Single

Dim instance As Position(position, x, y)
C#
public Position(
   AlignedPositions position,
   float x,
   float y
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As AlignedPositions, _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim position As AlignedPositions
Dim x As Single
Dim y As Single

Dim instance As Position(position, x, y)
C#
public Position(
   AlignedPositions position,
   float x,
   float y
)

Parameters

position
x
y

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members
Overload List


Position Constructor(Object)

Position Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class > Position Constructor : Position Constructor(Object)

container

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As Object _
)
Visual Basic (Usage) Copy Code
Dim container As Object

Dim instance As Position(container)
C#
public Position(
   object container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As Object _
)
Visual Basic (Usage) Copy Code
Dim container As Object

Dim instance As Position(container)
C#
public Position(
   object container
)

Parameters

container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members
Overload List


Position Constructor(Single,Single)

Position Constructor(Single,Single)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class > Position Constructor : Position Constructor(Single,Single)

x
y

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim x As Single
Dim y As Single

Dim instance As Position(x, y)
C#
public Position(
   float x,
   float y
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim x As Single
Dim y As Single

Dim instance As Position(x, y)
C#
public Position(
   float x,
   float y
)

Parameters

x
y

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members
Overload List


Position Class Methods

Position Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : Position Class

For a list of all members of this type, see Position members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX |
Protected Method | ResetY |
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX |
Protected Method | ShouldSerializeY |
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

Position Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As Position
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Position
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Position
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members


ResetX Method

ResetX Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class : ResetX Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ResetX()
Visual Basic (Usage) Copy Code
Dim instance As Position

instance.ResetX()
C#
protected virtual void ResetX()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members


ResetY Method

ResetY Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class : ResetY Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ResetY()
Visual Basic (Usage) Copy Code
Dim instance As Position

instance.ResetY()
C#
protected virtual void ResetY()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members


ShouldSerializeX Method

ShouldSerializeX Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class : ShouldSerializeX Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeX() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Position
Dim value As Boolean

value = instance.ShouldSerializeX()
C#
protected virtual bool ShouldSerializeX()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members


ShouldSerializeY Method

ShouldSerializeY Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class : ShouldSerializeY Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeY() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Position
Dim value As Boolean

value = instance.ShouldSerializeY()
C#
protected virtual bool ShouldSerializeY()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members


Position Class Properties

Position Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : Position Class

For a list of all members of this type, see Position members.

Public Properties

 | Name | Description
Public Property | AlignedPosition |
Public Property | Auto |
Public Property | X |
Public Property | Y |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

Position Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

AlignedPosition Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class : AlignedPosition Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property AlignedPosition As AlignedPositions
Visual Basic (Usage) Copy Code
Dim instance As Position
Dim value As AlignedPositions

instance.AlignedPosition = value

value = instance.AlignedPosition
C#
public virtual AlignedPositions AlignedPosition {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members


Auto Property

Auto Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class : Auto Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Auto As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Position
Dim value As Boolean

instance.Auto = value

value = instance.Auto
C#
public virtual bool Auto {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members


X Property

X Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class : X Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property X As Single
Visual Basic (Usage) Copy Code
Dim instance As Position
Dim value As Single

instance.X = value

value = instance.X
C#
public virtual float X {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members


Y Property

Y Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Position Class : Y Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Y As Single
Visual Basic (Usage) Copy Code
Dim instance As Position
Dim value As Single

instance.Y = value

value = instance.Y
C#
public virtual float Y {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Position Class
Position Members


PositionBottom Class

PositionBottom Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionBottom Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PositionBottom
   Inherits Position
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As PositionBottom
C#
public class PositionBottom : Position, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Position
Telerik.Reporting.Charting.Styles.PositionBottom

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionBottom Members
Telerik.Reporting.Charting.Styles Namespace


PositionBottom Class Members

PositionBottom Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionBottom Class

The following tables list the members exposed by PositionBottom.

Public Constructors

 | Name | Description
Public Constructor | PositionBottom Constructor |
Top

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionBottom Class
Telerik.Reporting.Charting.Styles Namespace


PositionBottom Constructor

PositionBottom Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionBottom Class : PositionBottom Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionBottom()
C#
public PositionBottom()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionBottom()
C#
public PositionBottom()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionBottom Class
PositionBottom Members


PositionBottom Class Properties

PositionBottom Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionBottom Class

For a list of all members of this type, see PositionBottom members.

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionBottom Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

AlignedPosition Property
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionBottom Class : AlignedPosition Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property AlignedPosition As AlignedPositions
Visual Basic (Usage) Copy Code
Dim instance As PositionBottom
Dim value As AlignedPositions

value = instance.AlignedPosition
C#
public override AlignedPositions AlignedPosition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionBottom Class
PositionBottom Members


PositionCenter Class

PositionCenter Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionCenter Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PositionCenter
   Inherits Position
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As PositionCenter
C#
public class PositionCenter : Position, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Position
Telerik.Reporting.Charting.Styles.PositionCenter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionCenter Members
Telerik.Reporting.Charting.Styles Namespace


PositionCenter Class Members

PositionCenter Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionCenter Class

The following tables list the members exposed by PositionCenter.

Public Constructors

 | Name | Description
Public Constructor | PositionCenter Constructor |
Top

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionCenter Class
Telerik.Reporting.Charting.Styles Namespace


PositionCenter Constructor

PositionCenter Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionCenter Class : PositionCenter Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionCenter()
C#
public PositionCenter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionCenter()
C#
public PositionCenter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionCenter Class
PositionCenter Members


PositionCenter Class Properties

PositionCenter Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionCenter Class

For a list of all members of this type, see PositionCenter members.

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionCenter Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

AlignedPosition Property
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionCenter Class : AlignedPosition Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property AlignedPosition As AlignedPositions
Visual Basic (Usage) Copy Code
Dim instance As PositionCenter
Dim value As AlignedPositions

value = instance.AlignedPosition
C#
public override AlignedPositions AlignedPosition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionCenter Class
PositionCenter Members


PositionLeft Class

PositionLeft Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionLeft Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PositionLeft
   Inherits Position
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As PositionLeft
C#
public class PositionLeft : Position, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Position
Telerik.Reporting.Charting.Styles.PositionLeft

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionLeft Members
Telerik.Reporting.Charting.Styles Namespace


PositionLeft Class Members

PositionLeft Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionLeft Class

The following tables list the members exposed by PositionLeft.

Public Constructors

 | Name | Description
Public Constructor | PositionLeft Constructor |
Top

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionLeft Class
Telerik.Reporting.Charting.Styles Namespace


PositionLeft Constructor

PositionLeft Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionLeft Class : PositionLeft Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionLeft()
C#
public PositionLeft()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionLeft()
C#
public PositionLeft()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionLeft Class
PositionLeft Members


PositionLeft Class Properties

PositionLeft Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionLeft Class

For a list of all members of this type, see PositionLeft members.

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionLeft Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

AlignedPosition Property
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionLeft Class : AlignedPosition Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property AlignedPosition As AlignedPositions
Visual Basic (Usage) Copy Code
Dim instance As PositionLeft
Dim value As AlignedPositions

value = instance.AlignedPosition
C#
public override AlignedPositions AlignedPosition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionLeft Class
PositionLeft Members


PositionRight Class

PositionRight Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionRight Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PositionRight
   Inherits Position
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As PositionRight
C#
public class PositionRight : Position, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Position
Telerik.Reporting.Charting.Styles.PositionRight

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionRight Members
Telerik.Reporting.Charting.Styles Namespace


PositionRight Class Members

PositionRight Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionRight Class

The following tables list the members exposed by PositionRight.

Public Constructors

 | Name | Description
Public Constructor | PositionRight Constructor |
Top

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionRight Class
Telerik.Reporting.Charting.Styles Namespace


PositionRight Constructor

PositionRight Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionRight Class : PositionRight Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionRight()
C#
public PositionRight()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionRight()
C#
public PositionRight()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionRight Class
PositionRight Members


PositionRight Class Properties

PositionRight Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionRight Class

For a list of all members of this type, see PositionRight members.

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionRight Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

AlignedPosition Property
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionRight Class : AlignedPosition Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property AlignedPosition As AlignedPositions
Visual Basic (Usage) Copy Code
Dim instance As PositionRight
Dim value As AlignedPositions

value = instance.AlignedPosition
C#
public override AlignedPositions AlignedPosition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionRight Class
PositionRight Members


PositionTop Class

PositionTop Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionTop Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PositionTop
   Inherits Position
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As PositionTop
C#
public class PositionTop : Position, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Position
Telerik.Reporting.Charting.Styles.PositionTop

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionTop Members
Telerik.Reporting.Charting.Styles Namespace


PositionTop Class Members

PositionTop Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionTop Class

The following tables list the members exposed by PositionTop.

Public Constructors

 | Name | Description
Public Constructor | PositionTop Constructor |
Top

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionTop Class
Telerik.Reporting.Charting.Styles Namespace


PositionTop Constructor

PositionTop Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionTop Class : PositionTop Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionTop()
C#
public PositionTop()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionTop()
C#
public PositionTop()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionTop Class
PositionTop Members


PositionTop Class Properties

PositionTop Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionTop Class

For a list of all members of this type, see PositionTop members.

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionTop Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

AlignedPosition Property
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionTop Class : AlignedPosition Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property AlignedPosition As AlignedPositions
Visual Basic (Usage) Copy Code
Dim instance As PositionTop
Dim value As AlignedPositions

value = instance.AlignedPosition
C#
public override AlignedPositions AlignedPosition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionTop Class
PositionTop Members


PositionTopLeft Class

PositionTopLeft Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionTopLeft Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PositionTopLeft
   Inherits Position
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As PositionTopLeft
C#
public class PositionTopLeft : Position, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Position
Telerik.Reporting.Charting.Styles.PositionTopLeft

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionTopLeft Members
Telerik.Reporting.Charting.Styles Namespace


PositionTopLeft Class Members

PositionTopLeft Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionTopLeft Class

The following tables list the members exposed by PositionTopLeft.

Public Constructors

 | Name | Description
Public Constructor | PositionTopLeft Constructor |
Top

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionTopLeft Class
Telerik.Reporting.Charting.Styles Namespace


PositionTopLeft Constructor

PositionTopLeft Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionTopLeft Class : PositionTopLeft Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionTopLeft()
C#
public PositionTopLeft()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionTopLeft()
C#
public PositionTopLeft()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionTopLeft Class
PositionTopLeft Members


PositionTopLeft Class Properties

PositionTopLeft Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionTopLeft Class

For a list of all members of this type, see PositionTopLeft members.

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionTopLeft Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

AlignedPosition Property
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionTopLeft Class : AlignedPosition Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property AlignedPosition As AlignedPositions
Visual Basic (Usage) Copy Code
Dim instance As PositionTopLeft
Dim value As AlignedPositions

value = instance.AlignedPosition
C#
public override AlignedPositions AlignedPosition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionTopLeft Class
PositionTopLeft Members


PositionTopRight Class

PositionTopRight Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionTopRight Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PositionTopRight
   Inherits Position
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As PositionTopRight
C#
public class PositionTopRight : Position, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Position
Telerik.Reporting.Charting.Styles.PositionTopRight

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionTopRight Members
Telerik.Reporting.Charting.Styles Namespace


PositionTopRight Class Members

PositionTopRight Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionTopRight Class

The following tables list the members exposed by PositionTopRight.

Public Constructors

 | Name | Description
Public Constructor | PositionTopRight Constructor |
Top

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionTopRight Class
Telerik.Reporting.Charting.Styles Namespace


PositionTopRight Constructor

PositionTopRight Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionTopRight Class : PositionTopRight Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionTopRight()
C#
public PositionTopRight()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PositionTopRight()
C#
public PositionTopRight()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionTopRight Class
PositionTopRight Members


PositionTopRight Class Properties

PositionTopRight Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionTopRight Class

For a list of all members of this type, see PositionTopRight members.

Public Properties

 | Name | Description
Public Property | AlignedPosition | Overridden.
Public Property | Auto | (Inherited from Position)
Public Property | X | (Inherited from Position)
Public Property | Y | (Inherited from Position)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionTopRight Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

AlignedPosition Property
[image]
Telerik.Reporting.Charting.Styles Namespace > PositionTopRight Class : AlignedPosition Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property AlignedPosition As AlignedPositions
Visual Basic (Usage) Copy Code
Dim instance As PositionTopRight
Dim value As AlignedPositions

value = instance.AlignedPosition
C#
public override AlignedPositions AlignedPosition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PositionTopRight Class
PositionTopRight Members


ScaleBreaksLineStyle Class

ScaleBreaksLineStyle Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : ScaleBreaksLineStyle Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ScaleBreaksLineStyle
   Inherits LineStyle
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreaksLineStyle
C#
public class ScaleBreaksLineStyle : LineStyle, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.ScaleBreaksLineStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreaksLineStyle Members
Telerik.Reporting.Charting.Styles Namespace


ScaleBreaksLineStyle Class Members

ScaleBreaksLineStyle Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ScaleBreaksLineStyle Class

The following tables list the members exposed by ScaleBreaksLineStyle.

Public Constructors

 | Name | Description
Public Constructor | ScaleBreaksLineStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | EndCap | (Inherited from LineStyle)
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ScaleBreaksLineStyle Class
Telerik.Reporting.Charting.Styles Namespace


ScaleBreaksLineStyle Constructor

ScaleBreaksLineStyle Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > ScaleBreaksLineStyle Class : ScaleBreaksLineStyle Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreaksLineStyle()
C#
public ScaleBreaksLineStyle()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreaksLineStyle()
C#
public ScaleBreaksLineStyle()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreaksLineStyle Class
ScaleBreaksLineStyle Members


ScaleBreaksLineStyle Class Properties

ScaleBreaksLineStyle Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : ScaleBreaksLineStyle Class

For a list of all members of this type, see ScaleBreaksLineStyle members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | EndCap | (Inherited from LineStyle)
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ScaleBreaksLineStyle Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ScaleBreaksLineStyle Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreaksLineStyle
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ScaleBreaksLineStyle Class
ScaleBreaksLineStyle Members


ShadowStyle Class

ShadowStyle Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : ShadowStyle Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ShadowStyle
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyle
C#
public class ShadowStyle : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.ShadowStyle
Telerik.Reporting.Charting.Styles.ShadowStyleChart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyle Members
Telerik.Reporting.Charting.Styles Namespace


ShadowStyle Class Members

ShadowStyle Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ShadowStyle Class

The following tables list the members exposed by ShadowStyle.

Public Constructors

 | Name | Description
Public Constructor | ShadowStyle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Blur |
Public Property | Color |
Public Property | ColorOpacity |
Public Property | Distance |
Public Property | Position |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


ShadowStyle Constructor

ShadowStyle Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyle Class : ShadowStyle Constructor

Overload List

Overload | Description
ShadowStyle Constructor() |
ShadowStyle Constructor(Color,Single,Single,ShadowPosition) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyle Class
ShadowStyle Members


ShadowStyle Constructor()

ShadowStyle Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyle Class > ShadowStyle Constructor : ShadowStyle Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyle()
C#
public ShadowStyle()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyle()
C#
public ShadowStyle()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyle Class
ShadowStyle Members
Overload List


ShadowStyle Constructor(Color,Single,Single,ShadowPosition)

ShadowStyle Constructor(Color,Single,Single,ShadowPosition)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyle Class > ShadowStyle Constructor : ShadowStyle Constructor(Color,Single,Single,ShadowPosition)

shadowColor
shadowBlur
shadowDistance
shadowPosition

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal shadowColor As Color, _
   ByVal shadowBlur As Single, _
   ByVal shadowDistance As Single, _
   ByVal shadowPosition As ShadowPosition _
)
Visual Basic (Usage) Copy Code
Dim shadowColor As Color
Dim shadowBlur As Single
Dim shadowDistance As Single
Dim shadowPosition As ShadowPosition

Dim instance As ShadowStyle(shadowColor, shadowBlur, shadowDistance, shadowPosition)
C#
public ShadowStyle(
   Color shadowColor,
   float shadowBlur,
   float shadowDistance,
   ShadowPosition shadowPosition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal shadowColor As Color, _
   ByVal shadowBlur As Single, _
   ByVal shadowDistance As Single, _
   ByVal shadowPosition As ShadowPosition _
)
Visual Basic (Usage) Copy Code
Dim shadowColor As Color
Dim shadowBlur As Single
Dim shadowDistance As Single
Dim shadowPosition As ShadowPosition

Dim instance As ShadowStyle(shadowColor, shadowBlur, shadowDistance, shadowPosition)
C#
public ShadowStyle(
   Color shadowColor,
   float shadowBlur,
   float shadowDistance,
   ShadowPosition shadowPosition
)

Parameters

shadowColor
shadowBlur
shadowDistance
shadowPosition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyle Class
ShadowStyle Members
Overload List


ShadowStyle Class Methods

ShadowStyle Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ShadowStyle Class

For a list of all members of this type, see ShadowStyle members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyle Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyle
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyle Class
ShadowStyle Members


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyle Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyle
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyle Class
ShadowStyle Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyle Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyle
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyle Class
ShadowStyle Members


ShadowStyle Class Properties

ShadowStyle Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : ShadowStyle Class

For a list of all members of this type, see ShadowStyle members.

Public Properties

 | Name | Description
Public Property | Blur |
Public Property | Color |
Public Property | ColorOpacity |
Public Property | Distance |
Public Property | Position |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


Blur Property

Blur Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyle Class : Blur Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Blur As Single
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyle
Dim value As Single

instance.Blur = value

value = instance.Blur
C#
public virtual float Blur {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyle Class
ShadowStyle Members


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyle Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyle
Dim value As Color

instance.Color = value

value = instance.Color
C#
public virtual Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyle Class
ShadowStyle Members


ColorOpacity Property

ColorOpacity Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyle Class : ColorOpacity Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColorOpacity As Byte
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyle
Dim value As Byte

value = instance.ColorOpacity
C#
public byte ColorOpacity {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyle Class
ShadowStyle Members


Distance Property

Distance Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyle Class : Distance Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Distance As Single
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyle
Dim value As Single

instance.Distance = value

value = instance.Distance
C#
public virtual float Distance {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyle Class
ShadowStyle Members


Position Property

Position Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyle Class : Position Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Position As ShadowPosition
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyle
Dim value As ShadowPosition

instance.Position = value

value = instance.Position
C#
public virtual ShadowPosition Position {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyle Class
ShadowStyle Members


ShadowStyleChart Class

ShadowStyleChart Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : ShadowStyleChart Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ShadowStyleChart
   Inherits ShadowStyle
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyleChart
C#
public class ShadowStyleChart : ShadowStyle, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.ShadowStyle
Telerik.Reporting.Charting.Styles.ShadowStyleChart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyleChart Members
Telerik.Reporting.Charting.Styles Namespace


ShadowStyleChart Class Members

ShadowStyleChart Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ShadowStyleChart Class

The following tables list the members exposed by ShadowStyleChart.

Public Constructors

 | Name | Description
Public Constructor | ShadowStyleChart Constructor |
Top

Public Properties

 | Name | Description
Public Property | Blur | Overridden.
Public Property | Color | Overridden.
Public Property | ColorOpacity | (Inherited from ShadowStyle)
Public Property | Distance | Overridden.
Public Property | Position | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ShadowStyle)
Public Method | Equals | (Inherited from ShadowStyle)
Public Method | GetHashCode | (Inherited from ShadowStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ShadowStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


ShadowStyleChart Constructor

ShadowStyleChart Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyleChart Class : ShadowStyleChart Constructor

parent

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart

Dim instance As ShadowStyleChart(parent)
C#
public ShadowStyleChart(
   Chart parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As Chart _
)
Visual Basic (Usage) Copy Code
Dim parent As Chart

Dim instance As ShadowStyleChart(parent)
C#
public ShadowStyleChart(
   Chart parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyleChart Class
ShadowStyleChart Members


ShadowStyleChart Class Properties

ShadowStyleChart Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : ShadowStyleChart Class

For a list of all members of this type, see ShadowStyleChart members.

Public Properties

 | Name | Description
Public Property | Blur | Overridden.
Public Property | Color | Overridden.
Public Property | ColorOpacity | (Inherited from ShadowStyle)
Public Property | Distance | Overridden.
Public Property | Position | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ShadowStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


Blur Property

Blur Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyleChart Class : Blur Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Blur As Single
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyleChart
Dim value As Single

instance.Blur = value

value = instance.Blur
C#
public override float Blur {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyleChart Class
ShadowStyleChart Members


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyleChart Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyleChart
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyleChart Class
ShadowStyleChart Members


Distance Property

Distance Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyleChart Class : Distance Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Distance As Single
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyleChart
Dim value As Single

instance.Distance = value

value = instance.Distance
C#
public override float Distance {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyleChart Class
ShadowStyleChart Members


Position Property

Position Property
[image]
Telerik.Reporting.Charting.Styles Namespace > ShadowStyleChart Class : Position Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Position As ShadowPosition
Visual Basic (Usage) Copy Code
Dim instance As ShadowStyleChart
Dim value As ShadowPosition

instance.Position = value

value = instance.Position
C#
public override ShadowPosition Position {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShadowStyleChart Class
ShadowStyleChart Members


Style Class

Style Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : Style Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class Style
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As Style
C#
public abstract class Style : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleMarkedZone
Telerik.Reporting.Charting.Styles.StyleSeries
Telerik.Reporting.Charting.Styles.StyleSeriesItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Members
Telerik.Reporting.Charting.Styles Namespace


Style Class Members

Style Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : Style Class

The following tables list the members exposed by Style.

Public Properties

 | Name | Description
Public Property | Border |
Public Property | Shadow |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

Style Class
Telerik.Reporting.Charting.Styles Namespace


Style Class Methods

Style Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : Style Class

For a list of all members of this type, see Style members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

Style Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Style Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Style Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Style Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Style Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As Style

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


Style Class Properties

Style Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : Style Class

For a list of all members of this type, see Style members.

Public Properties

 | Name | Description
Public Property | Border |
Public Property | Shadow |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

Style Class
Telerik.Reporting.Charting.Styles Namespace


Border Property

Border Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Style Class : Border Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Border As StyleBorder
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As StyleBorder

value = instance.Border
C#
public virtual StyleBorder Border {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


Shadow Property

Shadow Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Style Class : Shadow Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Shadow As ShadowStyle
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As ShadowStyle

value = instance.Shadow
C#
public virtual ShadowStyle Shadow {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Style Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


StyleAxis Class

StyleAxis Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxis Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleAxis
   Inherits LineStyle
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
C#
public class StyleAxis : LineStyle, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleAxis
Telerik.Reporting.Charting.Styles.StyleAxisX
Telerik.Reporting.Charting.Styles.StyleAxisY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Class Members

StyleAxis Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxis Class

The following tables list the members exposed by StyleAxis.

Public Constructors

 | Name | Description
Public Constructor | StyleAxis Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | styleAxisLabelAppearance |
Protected Field | styleAxisMajorGridLines |
Protected Field | styleAxisMajorTick |
Protected Field | styleAxisMinorGridLines |
Protected Field | styleAxisMinorTick |
Protected Field | styleAxisOrientation |
Protected Field | styleAxisTextAppearance |
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | CustomFormat |
Public Property | EndCap | (Inherited from LineStyle)
Public Property | LabelAppearance |
Public Property | MajorGridLines |
Public Property | MajorTick |
Public Property | MinorGridLines |
Public Property | MinorTick |
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | TextAppearance |
Public Property | ValueFormat |
Public Property | Visible |
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Dispose | Overloaded.
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Constructor

StyleAxis Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : StyleAxis Constructor

Overload List

Overload | Description
StyleAxis Constructor() |
StyleAxis Constructor(ChartAxis) |
StyleAxis Constructor(Orientation) |
StyleAxis Constructor(Orientation,ChartAxis) |
StyleAxis Constructor(Orientation,ChartAxisVisibility) |
StyleAxis Constructor(Orientation,ChartAxisVisibility,ChartAxis) |
StyleAxis Constructor(Orientation,ChartAxisVisibility,LineStyle) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


StyleAxis Constructor()

StyleAxis Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class > StyleAxis Constructor : StyleAxis Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis()
C#
public StyleAxis()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis()
C#
public StyleAxis()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members
Overload List


StyleAxis Constructor(ChartAxis)

StyleAxis Constructor(ChartAxis)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class > StyleAxis Constructor : StyleAxis Constructor(ChartAxis)

axis

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal axis As ChartAxis _
)
Visual Basic (Usage) Copy Code
Dim axis As ChartAxis

Dim instance As StyleAxis(axis)
C#
public StyleAxis(
   ChartAxis axis
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal axis As ChartAxis _
)
Visual Basic (Usage) Copy Code
Dim axis As ChartAxis

Dim instance As StyleAxis(axis)
C#
public StyleAxis(
   ChartAxis axis
)

Parameters

axis

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members
Overload List


StyleAxis Constructor(Orientation)

StyleAxis Constructor(Orientation)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class > StyleAxis Constructor : StyleAxis Constructor(Orientation)

orientation

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim orientation As Orientation

Dim instance As StyleAxis(orientation)
C#
public StyleAxis(
   Orientation orientation
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim orientation As Orientation

Dim instance As StyleAxis(orientation)
C#
public StyleAxis(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members
Overload List


StyleAxis Constructor(Orientation,ChartAxis)

StyleAxis Constructor(Orientation,ChartAxis)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class > StyleAxis Constructor : StyleAxis Constructor(Orientation,ChartAxis)

orientation
axis

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal orientation As Orientation, _
   ByVal axis As ChartAxis _
)
Visual Basic (Usage) Copy Code
Dim orientation As Orientation
Dim axis As ChartAxis

Dim instance As StyleAxis(orientation, axis)
C#
public StyleAxis(
   Orientation orientation,
   ChartAxis axis
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal orientation As Orientation, _
   ByVal axis As ChartAxis _
)
Visual Basic (Usage) Copy Code
Dim orientation As Orientation
Dim axis As ChartAxis

Dim instance As StyleAxis(orientation, axis)
C#
public StyleAxis(
   Orientation orientation,
   ChartAxis axis
)

Parameters

orientation
axis

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members
Overload List


StyleAxis Constructor(Orientation,ChartAxisVisibility)

StyleAxis Constructor(Orientation,ChartAxisVisibility)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class > StyleAxis Constructor : StyleAxis Constructor(Orientation,ChartAxisVisibility)

orientation
visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal orientation As Orientation, _
   ByVal visibility As ChartAxisVisibility _
)
Visual Basic (Usage) Copy Code
Dim orientation As Orientation
Dim visibility As ChartAxisVisibility

Dim instance As StyleAxis(orientation, visibility)
C#
public StyleAxis(
   Orientation orientation,
   ChartAxisVisibility visibility
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal orientation As Orientation, _
   ByVal visibility As ChartAxisVisibility _
)
Visual Basic (Usage) Copy Code
Dim orientation As Orientation
Dim visibility As ChartAxisVisibility

Dim instance As StyleAxis(orientation, visibility)
C#
public StyleAxis(
   Orientation orientation,
   ChartAxisVisibility visibility
)

Parameters

orientation
visibility

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members
Overload List


StyleAxis Constructor(Orientation,ChartAxisVisibility,ChartAxis)

StyleAxis Constructor(Orientation,ChartAxisVisibility,ChartAxis)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class > StyleAxis Constructor : StyleAxis Constructor(Orientation,ChartAxisVisibility,ChartAxis)

orientation
visibility
axis

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal orientation As Orientation, _
   ByVal visibility As ChartAxisVisibility, _
   ByVal axis As ChartAxis _
)
Visual Basic (Usage) Copy Code
Dim orientation As Orientation
Dim visibility As ChartAxisVisibility
Dim axis As ChartAxis

Dim instance As StyleAxis(orientation, visibility, axis)
C#
public StyleAxis(
   Orientation orientation,
   ChartAxisVisibility visibility,
   ChartAxis axis
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal orientation As Orientation, _
   ByVal visibility As ChartAxisVisibility, _
   ByVal axis As ChartAxis _
)
Visual Basic (Usage) Copy Code
Dim orientation As Orientation
Dim visibility As ChartAxisVisibility
Dim axis As ChartAxis

Dim instance As StyleAxis(orientation, visibility, axis)
C#
public StyleAxis(
   Orientation orientation,
   ChartAxisVisibility visibility,
   ChartAxis axis
)

Parameters

orientation
visibility
axis

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members
Overload List


StyleAxis Constructor(Orientation,ChartAxisVisibility,LineStyle)

StyleAxis Constructor(Orientation,ChartAxisVisibility,LineStyle)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class > StyleAxis Constructor : StyleAxis Constructor(Orientation,ChartAxisVisibility,LineStyle)

orientation
visibility
lineStyle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal orientation As Orientation, _
   ByVal visibility As ChartAxisVisibility, _
   ByVal lineStyle As LineStyle _
)
Visual Basic (Usage) Copy Code
Dim orientation As Orientation
Dim visibility As ChartAxisVisibility
Dim lineStyle As LineStyle

Dim instance As StyleAxis(orientation, visibility, lineStyle)
C#
public StyleAxis(
   Orientation orientation,
   ChartAxisVisibility visibility,
   LineStyle lineStyle
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal orientation As Orientation, _
   ByVal visibility As ChartAxisVisibility, _
   ByVal lineStyle As LineStyle _
)
Visual Basic (Usage) Copy Code
Dim orientation As Orientation
Dim visibility As ChartAxisVisibility
Dim lineStyle As LineStyle

Dim instance As StyleAxis(orientation, visibility, lineStyle)
C#
public StyleAxis(
   Orientation orientation,
   ChartAxisVisibility visibility,
   LineStyle lineStyle
)

Parameters

orientation
visibility
lineStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members
Overload List


StyleAxis Class Methods

StyleAxis Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxis Class

For a list of all members of this type, see StyleAxis members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Dispose | Overloaded.
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : Dispose Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : Finalize Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


StyleAxis Class Properties

StyleAxis Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxis Class

For a list of all members of this type, see StyleAxis members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | CustomFormat |
Public Property | EndCap | (Inherited from LineStyle)
Public Property | LabelAppearance |
Public Property | MajorGridLines |
Public Property | MajorTick |
Public Property | MinorGridLines |
Public Property | MinorTick |
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | TextAppearance |
Public Property | ValueFormat |
Public Property | Visible |
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


CustomFormat Property

CustomFormat Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : CustomFormat Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomFormat As String
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As String

instance.CustomFormat = value

value = instance.CustomFormat
C#
public string CustomFormat {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


LabelAppearance Property

LabelAppearance Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : LabelAppearance Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LabelAppearance As StyleLabel
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As StyleLabel

value = instance.LabelAppearance
C#
public virtual StyleLabel LabelAppearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


MajorGridLines Property

MajorGridLines Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : MajorGridLines Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MajorGridLines As StyleGridLine
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As StyleGridLine

value = instance.MajorGridLines
C#
public StyleGridLine MajorGridLines {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


MajorTick Property

MajorTick Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : MajorTick Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MajorTick As StyleTickMajor
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As StyleTickMajor

value = instance.MajorTick
C#
public StyleTickMajor MajorTick {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


MinorGridLines Property

MinorGridLines Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : MinorGridLines Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property MinorGridLines As StyleGridLine
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As StyleGridLine

value = instance.MinorGridLines
C#
public virtual StyleGridLine MinorGridLines {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


MinorTick Property

MinorTick Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : MinorTick Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property MinorTick As StyleTickMinor
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As StyleTickMinor

value = instance.MinorTick
C#
public virtual StyleTickMinor MinorTick {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


TextAppearance Property

TextAppearance Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : TextAppearance Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TextAppearance As StyleAxisItemText
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As StyleAxisItemText

value = instance.TextAppearance
C#
public StyleAxisItemText TextAppearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


ValueFormat Property

ValueFormat Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : ValueFormat Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueFormat As ChartValueFormat
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As ChartValueFormat

instance.ValueFormat = value

value = instance.ValueFormat
C#
public ChartValueFormat ValueFormat {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As ChartAxisVisibility
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As ChartAxisVisibility

instance.Visible = value

value = instance.Visible
C#
public ChartAxisVisibility Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


Width Property

Width Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : Width Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As Single

instance.Width = value

value = instance.Width
C#
public override float Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


StyleAxis Class Fields

StyleAxis Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxis Class

For a list of all members of this type, see StyleAxis members.

Protected Fields

 | Name | Description
Protected Field | styleAxisLabelAppearance |
Protected Field | styleAxisMajorGridLines |
Protected Field | styleAxisMajorTick |
Protected Field | styleAxisMinorGridLines |
Protected Field | styleAxisMinorTick |
Protected Field | styleAxisOrientation |
Protected Field | styleAxisTextAppearance |
Top

See Also

Reference

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


styleAxisLabelAppearance Field

styleAxisLabelAppearance Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : styleAxisLabelAppearance Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleAxisLabelAppearance As StyleLabel
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As StyleLabel

value = instance.styleAxisLabelAppearance

instance.styleAxisLabelAppearance = value
C#
protected StyleLabel styleAxisLabelAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


styleAxisMajorGridLines Field

styleAxisMajorGridLines Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : styleAxisMajorGridLines Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleAxisMajorGridLines As StyleGridLine
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As StyleGridLine

value = instance.styleAxisMajorGridLines

instance.styleAxisMajorGridLines = value
C#
protected StyleGridLine styleAxisMajorGridLines

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


styleAxisMajorTick Field

styleAxisMajorTick Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : styleAxisMajorTick Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleAxisMajorTick As StyleTickMajor
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As StyleTickMajor

value = instance.styleAxisMajorTick

instance.styleAxisMajorTick = value
C#
protected StyleTickMajor styleAxisMajorTick

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


styleAxisMinorGridLines Field

styleAxisMinorGridLines Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : styleAxisMinorGridLines Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleAxisMinorGridLines As StyleGridLine
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As StyleGridLine

value = instance.styleAxisMinorGridLines

instance.styleAxisMinorGridLines = value
C#
protected StyleGridLine styleAxisMinorGridLines

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


styleAxisMinorTick Field

styleAxisMinorTick Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : styleAxisMinorTick Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleAxisMinorTick As StyleTickMinor
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As StyleTickMinor

value = instance.styleAxisMinorTick

instance.styleAxisMinorTick = value
C#
protected StyleTickMinor styleAxisMinorTick

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


styleAxisOrientation Field

styleAxisOrientation Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : styleAxisOrientation Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleAxisOrientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As Orientation

value = instance.styleAxisOrientation

instance.styleAxisOrientation = value
C#
protected Orientation styleAxisOrientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


styleAxisTextAppearance Field

styleAxisTextAppearance Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxis Class : styleAxisTextAppearance Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleAxisTextAppearance As StyleAxisItemText
Visual Basic (Usage) Copy Code
Dim instance As StyleAxis
Dim value As StyleAxisItemText

value = instance.styleAxisTextAppearance

instance.styleAxisTextAppearance = value
C#
protected StyleAxisItemText styleAxisTextAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxis Class
StyleAxis Members


StyleAxisItemText Class

StyleAxisItemText Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisItemText Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleAxisItemText
   Inherits StyleTextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleAxisItemText
C#
public class StyleAxisItemText : StyleTextBlock, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleTextBlock
Telerik.Reporting.Charting.Styles.StyleAxisItemText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxisItemText Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxisItemText Class Members

StyleAxisItemText Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisItemText Class

The following tables list the members exposed by StyleAxisItemText.

Public Constructors

 | Name | Description
Public Constructor | StyleAxisItemText Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockOverflow | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockRotationAngle | (Inherited from StyleTextBlock)
Top

Public Properties

 | Name | Description
Public Property | AutoTextWrap | (Inherited from StyleTextBlock)
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleTextBlock)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleTextBlock)
Public Property | FillStyle | (Inherited from StyleTextBlock)
Public Property | MaxLength | (Inherited from StyleTextBlock)
Public Property | Overflow | (Inherited from StyleTextBlock)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties | (Inherited from StyleTextBlock)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleTextBlock)
Public Method | Dispose | Overloaded. (Inherited from StyleTextBlock)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleTextBlock)
Protected Method | LoadViewState | (Inherited from StyleTextBlock)
Protected Method | ResetMaxLength | Overridden.
Protected Method | SaveViewState | (Inherited from StyleTextBlock)
Protected Method | ShouldSerializeMaxLength | Overridden.
Protected Method | TrackViewState | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleAxisItemText Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisItemText Constructor

StyleAxisItemText Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxisItemText Class : StyleAxisItemText Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleAxisItemText()
C#
public StyleAxisItemText()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleAxisItemText()
C#
public StyleAxisItemText()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxisItemText Class
StyleAxisItemText Members


StyleAxisItemText Class Methods

StyleAxisItemText Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisItemText Class

For a list of all members of this type, see StyleAxisItemText members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleTextBlock)
Public Method | Dispose | Overloaded. (Inherited from StyleTextBlock)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleTextBlock)
Protected Method | LoadViewState | (Inherited from StyleTextBlock)
Protected Method | ResetMaxLength | Overridden.
Protected Method | SaveViewState | (Inherited from StyleTextBlock)
Protected Method | ShouldSerializeMaxLength | Overridden.
Protected Method | TrackViewState | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleAxisItemText Class
Telerik.Reporting.Charting.Styles Namespace


ResetMaxLength Method

ResetMaxLength Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxisItemText Class : ResetMaxLength Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ResetMaxLength()
Visual Basic (Usage) Copy Code
Dim instance As StyleAxisItemText

instance.ResetMaxLength()
C#
protected override void ResetMaxLength()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxisItemText Class
StyleAxisItemText Members


ShouldSerializeMaxLength Method

ShouldSerializeMaxLength Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxisItemText Class : ShouldSerializeMaxLength Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function ShouldSerializeMaxLength() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleAxisItemText
Dim value As Boolean

value = instance.ShouldSerializeMaxLength()
C#
protected override bool ShouldSerializeMaxLength()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxisItemText Class
StyleAxisItemText Members


StyleAxisLabel Class

StyleAxisLabel Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisLabel Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleAxisLabel
   Inherits StyleLabelHidden
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleAxisLabel
C#
public class StyleAxisLabel : StyleLabelHidden, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleLabel
Telerik.Reporting.Charting.Styles.StyleLabelHidden
Telerik.Reporting.Charting.Styles.StyleAxisLabel
Telerik.Reporting.Charting.Styles.StyleYAxisLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxisLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxisLabel Class Members

StyleAxisLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisLabel Class

The following tables list the members exposed by StyleAxisLabel.

Public Constructors

 | Name | Description
Public Constructor | StyleAxisLabel Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from StyleLabelHidden)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleLabel)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleLabel)
Protected Method | SaveViewState | (Inherited from StyleLabel)
Protected Method | TrackViewState | (Inherited from StyleLabel)
Top

See Also

Reference

StyleAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisLabel Constructor

StyleAxisLabel Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxisLabel Class : StyleAxisLabel Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleAxisLabel()
C#
public StyleAxisLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleAxisLabel()
C#
public StyleAxisLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxisLabel Class
StyleAxisLabel Members


StyleAxisX Class

StyleAxisX Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisX Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleAxisX
   Inherits StyleAxis
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleAxisX
C#
public class StyleAxisX : StyleAxis, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleAxis
Telerik.Reporting.Charting.Styles.StyleAxisX

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxisX Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxisX Class Members

StyleAxisX Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisX Class

The following tables list the members exposed by StyleAxisX.

Public Constructors

 | Name | Description
Public Constructor | StyleAxisX Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | styleAxisLabelAppearance | (Inherited from StyleAxis)
Protected Field | styleAxisMajorGridLines | (Inherited from StyleAxis)
Protected Field | styleAxisMajorTick | (Inherited from StyleAxis)
Protected Field | styleAxisMinorGridLines | (Inherited from StyleAxis)
Protected Field | styleAxisMinorTick | (Inherited from StyleAxis)
Protected Field | styleAxisOrientation | (Inherited from StyleAxis)
Protected Field | styleAxisTextAppearance | (Inherited from StyleAxis)
Top

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleAxis)
Public Property | CustomFormat | (Inherited from StyleAxis)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | LabelAppearance | (Inherited from StyleAxis)
Public Property | MajorGridLines | (Inherited from StyleAxis)
Public Property | MajorTick | (Inherited from StyleAxis)
Public Property | MinorGridLines | Overridden.
Public Property | MinorTick | Overridden.
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | TextAppearance | (Inherited from StyleAxis)
Public Property | ValueFormat | (Inherited from StyleAxis)
Public Property | Visible | (Inherited from StyleAxis)
Public Property | Width | (Inherited from StyleAxis)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Dispose | Overloaded. (Inherited from StyleAxis)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleAxis)
Protected Method | LoadViewState | (Inherited from StyleAxis)
Protected Method | SaveViewState | (Inherited from StyleAxis)
Protected Method | TrackViewState | (Inherited from StyleAxis)
Top

See Also

Reference

StyleAxisX Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisX Constructor

StyleAxisX Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxisX Class : StyleAxisX Constructor

axis

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal axis As ChartXAxis _
)
Visual Basic (Usage) Copy Code
Dim axis As ChartXAxis

Dim instance As StyleAxisX(axis)
C#
public StyleAxisX(
   ChartXAxis axis
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal axis As ChartXAxis _
)
Visual Basic (Usage) Copy Code
Dim axis As ChartXAxis

Dim instance As StyleAxisX(axis)
C#
public StyleAxisX(
   ChartXAxis axis
)

Parameters

axis

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxisX Class
StyleAxisX Members


StyleAxisX Class Properties

StyleAxisX Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisX Class

For a list of all members of this type, see StyleAxisX members.

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleAxis)
Public Property | CustomFormat | (Inherited from StyleAxis)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | LabelAppearance | (Inherited from StyleAxis)
Public Property | MajorGridLines | (Inherited from StyleAxis)
Public Property | MajorTick | (Inherited from StyleAxis)
Public Property | MinorGridLines | Overridden.
Public Property | MinorTick | Overridden.
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | TextAppearance | (Inherited from StyleAxis)
Public Property | ValueFormat | (Inherited from StyleAxis)
Public Property | Visible | (Inherited from StyleAxis)
Public Property | Width | (Inherited from StyleAxis)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleAxisX Class
Telerik.Reporting.Charting.Styles Namespace


MinorGridLines Property

MinorGridLines Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxisX Class : MinorGridLines Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property MinorGridLines As StyleGridLine
Visual Basic (Usage) Copy Code
Dim instance As StyleAxisX
Dim value As StyleGridLine

value = instance.MinorGridLines
C#
public override StyleGridLine MinorGridLines {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxisX Class
StyleAxisX Members


MinorTick Property

MinorTick Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxisX Class : MinorTick Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property MinorTick As StyleTickMinor
Visual Basic (Usage) Copy Code
Dim instance As StyleAxisX
Dim value As StyleTickMinor

value = instance.MinorTick
C#
public override StyleTickMinor MinorTick {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxisX Class
StyleAxisX Members


StyleAxisY Class

StyleAxisY Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisY Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleAxisY
   Inherits StyleAxis
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleAxisY
C#
public class StyleAxisY : StyleAxis, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleAxis
Telerik.Reporting.Charting.Styles.StyleAxisY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxisY Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxisY Class Members

StyleAxisY Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisY Class

The following tables list the members exposed by StyleAxisY.

Public Constructors

 | Name | Description
Public Constructor | StyleAxisY Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | styleAxisLabelAppearance | (Inherited from StyleAxis)
Protected Field | styleAxisMajorGridLines | (Inherited from StyleAxis)
Protected Field | styleAxisMajorTick | (Inherited from StyleAxis)
Protected Field | styleAxisMinorGridLines | (Inherited from StyleAxis)
Protected Field | styleAxisMinorTick | (Inherited from StyleAxis)
Protected Field | styleAxisOrientation | (Inherited from StyleAxis)
Protected Field | styleAxisTextAppearance | (Inherited from StyleAxis)
Top

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleAxis)
Public Property | CustomFormat | (Inherited from StyleAxis)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | LabelAppearance | (Inherited from StyleAxis)
Public Property | MajorGridLines | (Inherited from StyleAxis)
Public Property | MajorTick | (Inherited from StyleAxis)
Public Property | MinorGridLines | (Inherited from StyleAxis)
Public Property | MinorTick | (Inherited from StyleAxis)
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | TextAppearance | (Inherited from StyleAxis)
Public Property | ValueFormat | (Inherited from StyleAxis)
Public Property | Visible | (Inherited from StyleAxis)
Public Property | Width | (Inherited from StyleAxis)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Dispose | Overloaded. (Inherited from StyleAxis)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleAxis)
Protected Method | LoadViewState | (Inherited from StyleAxis)
Protected Method | SaveViewState | (Inherited from StyleAxis)
Protected Method | TrackViewState | (Inherited from StyleAxis)
Top

See Also

Reference

StyleAxisY Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisY Constructor

StyleAxisY Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleAxisY Class : StyleAxisY Constructor

axis

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal axis As ChartYAxis _
)
Visual Basic (Usage) Copy Code
Dim axis As ChartYAxis

Dim instance As StyleAxisY(axis)
C#
public StyleAxisY(
   ChartYAxis axis
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal axis As ChartYAxis _
)
Visual Basic (Usage) Copy Code
Dim axis As ChartYAxis

Dim instance As StyleAxisY(axis)
C#
public StyleAxisY(
   ChartYAxis axis
)

Parameters

axis

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleAxisY Class
StyleAxisY Members


StyleBorder Class

StyleBorder Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleBorder Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleBorder
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleBorder
C#
public class StyleBorder : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleChartBorder
Telerik.Reporting.Charting.Styles.StyleDataTableBorder
Telerik.Reporting.Charting.Styles.StyleLegendBorder
Telerik.Reporting.Charting.Styles.StyleSeriesBorder
Telerik.Reporting.Charting.Styles.StyleTitleBorder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleBorder Class Members

StyleBorder Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleBorder Class

The following tables list the members exposed by StyleBorder.

Public Constructors

 | Name | Description
Public Constructor | StyleBorder Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Color |
Public Property | PenStyle |
Public Property | Visible |
Public Property | Width |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleBorder Constructor

StyleBorder Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class : StyleBorder Constructor

Overload List

Overload | Description
StyleBorder Constructor() |
StyleBorder Constructor(Boolean) |
StyleBorder Constructor(Color) |
StyleBorder Constructor(Color,Single) |
StyleBorder Constructor(Color,Single,DashStyle) |
StyleBorder Constructor(Object) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members


StyleBorder Constructor()

StyleBorder Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class > StyleBorder Constructor : StyleBorder Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleBorder()
C#
public StyleBorder()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleBorder()
C#
public StyleBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members
Overload List


StyleBorder Constructor(Boolean)

StyleBorder Constructor(Boolean)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class > StyleBorder Constructor : StyleBorder Constructor(Boolean)

visible

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim visible As Boolean

Dim instance As StyleBorder(visible)
C#
public StyleBorder(
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim visible As Boolean

Dim instance As StyleBorder(visible)
C#
public StyleBorder(
   bool visible
)

Parameters

visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members
Overload List


StyleBorder Constructor(Color)

StyleBorder Constructor(Color)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class > StyleBorder Constructor : StyleBorder Constructor(Color)

color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim color As Color

Dim instance As StyleBorder(color)
C#
public StyleBorder(
   Color color
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim color As Color

Dim instance As StyleBorder(color)
C#
public StyleBorder(
   Color color
)

Parameters

color

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members
Overload List


StyleBorder Constructor(Color,Single)

StyleBorder Constructor(Color,Single)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class > StyleBorder Constructor : StyleBorder Constructor(Color,Single)

color
width

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal width As Single _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim width As Single

Dim instance As StyleBorder(color, width)
C#
public StyleBorder(
   Color color,
   float width
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal width As Single _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim width As Single

Dim instance As StyleBorder(color, width)
C#
public StyleBorder(
   Color color,
   float width
)

Parameters

color
width

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members
Overload List


StyleBorder Constructor(Color,Single,DashStyle)

StyleBorder Constructor(Color,Single,DashStyle)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class > StyleBorder Constructor : StyleBorder Constructor(Color,Single,DashStyle)

color
width
penStyle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal width As Single, _
   ByVal penStyle As DashStyle _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim width As Single
Dim penStyle As DashStyle

Dim instance As StyleBorder(color, width, penStyle)
C#
public StyleBorder(
   Color color,
   float width,
   DashStyle penStyle
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal width As Single, _
   ByVal penStyle As DashStyle _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim width As Single
Dim penStyle As DashStyle

Dim instance As StyleBorder(color, width, penStyle)
C#
public StyleBorder(
   Color color,
   float width,
   DashStyle penStyle
)

Parameters

color
width
penStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members
Overload List


StyleBorder Constructor(Object)

StyleBorder Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class > StyleBorder Constructor : StyleBorder Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As StyleBorder(containerObject)
C#
public StyleBorder(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As StyleBorder(containerObject)
C#
public StyleBorder(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members
Overload List


StyleBorder Class Methods

StyleBorder Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleBorder Class

For a list of all members of this type, see StyleBorder members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleBorder Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleBorder
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleBorder
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleBorder
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members


StyleBorder Class Properties

StyleBorder Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleBorder Class

For a list of all members of this type, see StyleBorder members.

Public Properties

 | Name | Description
Public Property | Color |
Public Property | PenStyle |
Public Property | Visible |
Public Property | Width |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleBorder Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As StyleBorder
Dim value As Color

instance.Color = value

value = instance.Color
C#
public virtual Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members


PenStyle Property

PenStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class : PenStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PenStyle As DashStyle
Visual Basic (Usage) Copy Code
Dim instance As StyleBorder
Dim value As DashStyle

instance.PenStyle = value

value = instance.PenStyle
C#
public virtual DashStyle PenStyle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleBorder
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public virtual bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members


Width Property

Width Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleBorder Class : Width Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As StyleBorder
Dim value As Single

instance.Width = value

value = instance.Width
C#
public virtual float Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBorder Class
StyleBorder Members


StyleChart Class

StyleChart Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleChart Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleChart
   Inherits LayoutStyle
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleChart
C#
public class StyleChart : LayoutStyle, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleChart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Members
Telerik.Reporting.Charting.Styles Namespace


StyleChart Class Members

StyleChart Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleChart Class

The following tables list the members exposed by StyleChart.

Public Constructors

 | Name | Description
Public Constructor | StyleChart Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | BarOverlapPercent |
Public Property | BarWidthPercent |
Public Property | Border | (Inherited from Style)
Public Property | Corners |
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | FillStyle |
Public Property | ImageQuality |
Public Property | Position | Overridden.
Public Property | Shadow | (Inherited from Style)
Public Property | TextQuality |
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


StyleChart Constructor

StyleChart Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class : StyleChart Constructor

Overload List

Overload | Description
StyleChart Constructor(Chart) |
StyleChart Constructor(DimensionsChart,FillStyleChart,Corners,StyleBorder,ShadowStyle,Boolean) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members


StyleChart Constructor(Chart)

StyleChart Constructor(Chart)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class > StyleChart Constructor : StyleChart Constructor(Chart)

chart

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal chart As Chart _
)
Visual Basic (Usage) Copy Code
Dim chart As Chart

Dim instance As StyleChart(chart)
C#
public StyleChart(
   Chart chart
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal chart As Chart _
)
Visual Basic (Usage) Copy Code
Dim chart As Chart

Dim instance As StyleChart(chart)
C#
public StyleChart(
   Chart chart
)

Parameters

chart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members
Overload List


StyleChart Constructor(DimensionsChart,FillStyleChart,Corners,StyleBorder,ShadowStyle,Boolean)

StyleChart Constructor(DimensionsChart,FillStyleChart,Corners,StyleBorder,ShadowStyle,Boolean)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class > StyleChart Constructor : StyleChart Constructor(DimensionsChart,FillStyleChart,Corners,StyleBorder,ShadowStyle,Boolean)

dimensions
fillStyle
corners
border
shadowStyle
visible

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dimensions As DimensionsChart, _
   ByVal fillStyle As FillStyleChart, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim dimensions As DimensionsChart
Dim fillStyle As FillStyleChart
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleChart(dimensions, fillStyle, corners, border, shadowStyle, visible)
C#
public StyleChart(
   DimensionsChart dimensions,
   FillStyleChart fillStyle,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dimensions As DimensionsChart, _
   ByVal fillStyle As FillStyleChart, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim dimensions As DimensionsChart
Dim fillStyle As FillStyleChart
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleChart(dimensions, fillStyle, corners, border, shadowStyle, visible)
C#
public StyleChart(
   DimensionsChart dimensions,
   FillStyleChart fillStyle,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Parameters

dimensions
fillStyle
corners
border
shadowStyle
visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members
Overload List


StyleChart Class Methods

StyleChart Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleChart Class

For a list of all members of this type, see StyleChart members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleChart
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleChart
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleChart
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As StyleChart

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members


StyleChart Class Properties

StyleChart Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleChart Class

For a list of all members of this type, see StyleChart members.

Public Properties

 | Name | Description
Public Property | BarOverlapPercent |
Public Property | BarWidthPercent |
Public Property | Border | (Inherited from Style)
Public Property | Corners |
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | FillStyle |
Public Property | ImageQuality |
Public Property | Position | Overridden.
Public Property | Shadow | (Inherited from Style)
Public Property | TextQuality |
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


BarOverlapPercent Property

BarOverlapPercent Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class : BarOverlapPercent Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property BarOverlapPercent As Decimal
Visual Basic (Usage) Copy Code
Dim instance As StyleChart
Dim value As Decimal

instance.BarOverlapPercent = value

value = instance.BarOverlapPercent
C#
public decimal BarOverlapPercent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members


BarWidthPercent Property

BarWidthPercent Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class : BarWidthPercent Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property BarWidthPercent As Decimal
Visual Basic (Usage) Copy Code
Dim instance As StyleChart
Dim value As Decimal

instance.BarWidthPercent = value

value = instance.BarWidthPercent
C#
public decimal BarWidthPercent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members


Corners Property

Corners Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class : Corners Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Corners As Corners
Visual Basic (Usage) Copy Code
Dim instance As StyleChart
Dim value As Corners

instance.Corners = value

value = instance.Corners
C#
public Corners Corners {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members


FillStyle Property

FillStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class : FillStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStyleChart
Visual Basic (Usage) Copy Code
Dim instance As StyleChart
Dim value As FillStyleChart

value = instance.FillStyle
C#
public FillStyleChart FillStyle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members


ImageQuality Property

ImageQuality Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class : ImageQuality Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageQuality As ImageQuality
Visual Basic (Usage) Copy Code
Dim instance As StyleChart
Dim value As ImageQuality

instance.ImageQuality = value

value = instance.ImageQuality
C#
public ImageQuality ImageQuality {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members


Position Property

Position Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class : Position Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Position As Position
Visual Basic (Usage) Copy Code
Dim instance As StyleChart
Dim value As Position

value = instance.Position
C#
public override Position Position {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members


TextQuality Property

TextQuality Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class : TextQuality Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property TextQuality As TextQuality
Visual Basic (Usage) Copy Code
Dim instance As StyleChart
Dim value As TextQuality

instance.TextQuality = value

value = instance.TextQuality
C#
public TextQuality TextQuality {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChart Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleChart
Dim value As Boolean

value = instance.Visible
C#
public override bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChart Class
StyleChart Members


StyleChartBorder Class

StyleChartBorder Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleChartBorder Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleChartBorder
   Inherits StyleBorder
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleChartBorder
C#
public class StyleChartBorder : StyleBorder, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.StyleChartBorder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleChartBorder Class Members

StyleChartBorder Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleChartBorder Class

The following tables list the members exposed by StyleChartBorder.

Public Constructors

 | Name | Description
Public Constructor | StyleChartBorder Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleBorder)
Public Method | Equals | (Inherited from StyleBorder)
Public Method | GetHashCode | (Inherited from StyleBorder)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleChartBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleChartBorder Constructor

StyleChartBorder Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartBorder Class : StyleChartBorder Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleChartBorder()
C#
public StyleChartBorder()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleChartBorder()
C#
public StyleChartBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartBorder Class
StyleChartBorder Members


StyleChartBorder Class Properties

StyleChartBorder Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleChartBorder Class

For a list of all members of this type, see StyleChartBorder members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleChartBorder Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartBorder Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As StyleChartBorder
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartBorder Class
StyleChartBorder Members


StyleChartDataTable Class

StyleChartDataTable Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleChartDataTable Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleChartDataTable
   Inherits LayoutStyle
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
C#
public class StyleChartDataTable : LayoutStyle, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleChartDataTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Members
Telerik.Reporting.Charting.Styles Namespace


StyleChartDataTable Class Members

StyleChartDataTable Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleChartDataTable Class

The following tables list the members exposed by StyleChartDataTable.

Public Constructors

 | Name | Description
Public Constructor | StyleChartDataTable Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AutoTextWrap |
Public Property | Border | (Inherited from Style)
Public Property | CellHeight |
Public Property | CellWidth |
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | DrawHorizontalLines |
Public Property | DrawLines |
Public Property | DrawVerticalLines |
Public Property | Figure |
Public Property | FillStyle |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RenderType |
Public Property | Shadow | (Inherited from Style)
Public Property | TextHorizontalAlign |
Public Property | TextProperties |
Public Property | TextVerticalAlign |
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


StyleChartDataTable Constructor

StyleChartDataTable Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : StyleChartDataTable Constructor

Overload List

Overload | Description
StyleChartDataTable Constructor() |
StyleChartDataTable Constructor(ChartDataTable) |
StyleChartDataTable Constructor(Dimensions,FillStyle,Position,TextProperties,StyleBorder,ShadowStyle,Boolean) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


StyleChartDataTable Constructor()

StyleChartDataTable Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class > StyleChartDataTable Constructor : StyleChartDataTable Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable()
C#
public StyleChartDataTable()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable()
C#
public StyleChartDataTable()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members
Overload List


StyleChartDataTable Constructor(ChartDataTable)

StyleChartDataTable Constructor(ChartDataTable)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class > StyleChartDataTable Constructor : StyleChartDataTable Constructor(ChartDataTable)

parent

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartDataTable _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartDataTable

Dim instance As StyleChartDataTable(parent)
C#
public StyleChartDataTable(
   ChartDataTable parent
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As ChartDataTable _
)
Visual Basic (Usage) Copy Code
Dim parent As ChartDataTable

Dim instance As StyleChartDataTable(parent)
C#
public StyleChartDataTable(
   ChartDataTable parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members
Overload List


StyleChartDataTable Constructor(Dimensions,FillStyle,Position,TextProperties,StyleBorder,ShadowStyle,Boolean)

StyleChartDataTable Constructor(Dimensions,FillStyle,Position,TextProperties,StyleBorder,ShadowStyle,Boolean)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class > StyleChartDataTable Constructor : StyleChartDataTable Constructor(Dimensions,FillStyle,Position,TextProperties,StyleBorder,ShadowStyle,Boolean)

dimensions
fillStyle
position
textProperties
border
shadowStyle
visible

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dimensions As Dimensions, _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal textProperties As TextProperties, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim dimensions As Dimensions
Dim fillStyle As FillStyle
Dim position As Position
Dim textProperties As TextProperties
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleChartDataTable(dimensions, fillStyle, position, textProperties, border, shadowStyle, visible)
C#
public StyleChartDataTable(
   Dimensions dimensions,
   FillStyle fillStyle,
   Position position,
   TextProperties textProperties,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dimensions As Dimensions, _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal textProperties As TextProperties, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim dimensions As Dimensions
Dim fillStyle As FillStyle
Dim position As Position
Dim textProperties As TextProperties
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleChartDataTable(dimensions, fillStyle, position, textProperties, border, shadowStyle, visible)
C#
public StyleChartDataTable(
   Dimensions dimensions,
   FillStyle fillStyle,
   Position position,
   TextProperties textProperties,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Parameters

dimensions
fillStyle
position
textProperties
border
shadowStyle
visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members
Overload List


StyleChartDataTable Class Methods

StyleChartDataTable Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleChartDataTable Class

For a list of all members of this type, see StyleChartDataTable members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


StyleChartDataTable Class Properties

StyleChartDataTable Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleChartDataTable Class

For a list of all members of this type, see StyleChartDataTable members.

Public Properties

 | Name | Description
Public Property | AutoTextWrap |
Public Property | Border | (Inherited from Style)
Public Property | CellHeight |
Public Property | CellWidth |
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | DrawHorizontalLines |
Public Property | DrawLines |
Public Property | DrawVerticalLines |
Public Property | Figure |
Public Property | FillStyle |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RenderType |
Public Property | Shadow | (Inherited from Style)
Public Property | TextHorizontalAlign |
Public Property | TextProperties |
Public Property | TextVerticalAlign |
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


AutoTextWrap Property

AutoTextWrap Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : AutoTextWrap Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoTextWrap As AutoTextWrap
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As AutoTextWrap

instance.AutoTextWrap = value

value = instance.AutoTextWrap
C#
public AutoTextWrap AutoTextWrap {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


CellHeight Property

CellHeight Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : CellHeight Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property CellHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As Integer

instance.CellHeight = value

value = instance.CellHeight
C#
public int CellHeight {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


CellWidth Property

CellWidth Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : CellWidth Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property CellWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As Integer

instance.CellWidth = value

value = instance.CellWidth
C#
public int CellWidth {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


DrawHorizontalLines Property

DrawHorizontalLines Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : DrawHorizontalLines Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DrawHorizontalLines As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As Boolean

instance.DrawHorizontalLines = value

value = instance.DrawHorizontalLines
C#
public bool DrawHorizontalLines {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


DrawLines Property

DrawLines Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : DrawLines Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DrawLines As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As Boolean

instance.DrawLines = value

value = instance.DrawLines
C#
public bool DrawLines {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


DrawVerticalLines Property

DrawVerticalLines Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : DrawVerticalLines Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DrawVerticalLines As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As Boolean

instance.DrawVerticalLines = value

value = instance.DrawVerticalLines
C#
public bool DrawVerticalLines {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


Figure Property

Figure Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : Figure Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Figure As String
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As String

value = instance.Figure
C#
public string Figure {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


FillStyle Property

FillStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : FillStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStyle
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As FillStyle

value = instance.FillStyle
C#
public FillStyle FillStyle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


RenderType Property

RenderType Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : RenderType Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property RenderType As TableRenderType
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As TableRenderType

instance.RenderType = value

value = instance.RenderType
C#
public TableRenderType RenderType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


TextHorizontalAlign Property

TextHorizontalAlign Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : TextHorizontalAlign Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property TextHorizontalAlign As ContentHorizontalAlign
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As ContentHorizontalAlign

instance.TextHorizontalAlign = value

value = instance.TextHorizontalAlign
C#
public ContentHorizontalAlign TextHorizontalAlign {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


TextProperties Property

TextProperties Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : TextProperties Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TextProperties As TextProperties
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As TextProperties

value = instance.TextProperties
C#
public TextProperties TextProperties {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


TextVerticalAlign Property

TextVerticalAlign Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : TextVerticalAlign Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property TextVerticalAlign As ContentVerticalAlign
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As ContentVerticalAlign

instance.TextVerticalAlign = value

value = instance.TextVerticalAlign
C#
public ContentVerticalAlign TextVerticalAlign {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleChartDataTable Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleChartDataTable
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleChartDataTable Class
StyleChartDataTable Members


StyleDataTableBorder Class

StyleDataTableBorder Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleDataTableBorder Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleDataTableBorder
   Inherits StyleBorder
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleDataTableBorder
C#
public class StyleDataTableBorder : StyleBorder, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.StyleDataTableBorder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleDataTableBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleDataTableBorder Class Members

StyleDataTableBorder Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleDataTableBorder Class

The following tables list the members exposed by StyleDataTableBorder.

Public Constructors

 | Name | Description
Public Constructor | StyleDataTableBorder Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleBorder)
Public Method | Equals | (Inherited from StyleBorder)
Public Method | GetHashCode | (Inherited from StyleBorder)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleDataTableBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleDataTableBorder Constructor

StyleDataTableBorder Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleDataTableBorder Class : StyleDataTableBorder Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleDataTableBorder()
C#
public StyleDataTableBorder()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleDataTableBorder()
C#
public StyleDataTableBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleDataTableBorder Class
StyleDataTableBorder Members


StyleDataTableBorder Class Properties

StyleDataTableBorder Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleDataTableBorder Class

For a list of all members of this type, see StyleDataTableBorder members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleDataTableBorder Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleDataTableBorder Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As StyleDataTableBorder
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleDataTableBorder Class
StyleDataTableBorder Members


StyleEmptyLineSeries Class

StyleEmptyLineSeries Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleEmptyLineSeries Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleEmptyLineSeries
   Inherits StyleLineSeries
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleEmptyLineSeries
C#
public class StyleEmptyLineSeries : StyleLineSeries, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleLineSeries
Telerik.Reporting.Charting.Styles.StyleEmptyLineSeries

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleEmptyLineSeries Members
Telerik.Reporting.Charting.Styles Namespace


StyleEmptyLineSeries Class Members

StyleEmptyLineSeries Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleEmptyLineSeries Class

The following tables list the members exposed by StyleEmptyLineSeries.

Public Constructors

 | Name | Description
Public Constructor | StyleEmptyLineSeries Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | EndCap | (Inherited from LineStyle)
Public Property | PenStyle | Overridden.
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Width | (Inherited from StyleLineSeries)
Top

Protected Properties

 | Name | Description
Protected Property | IsEmptyLine | (Inherited from StyleLineSeries)
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleEmptyLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleEmptyLineSeries Constructor

StyleEmptyLineSeries Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleEmptyLineSeries Class : StyleEmptyLineSeries Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleEmptyLineSeries()
C#
public StyleEmptyLineSeries()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleEmptyLineSeries()
C#
public StyleEmptyLineSeries()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleEmptyLineSeries Class
StyleEmptyLineSeries Members


StyleEmptyLineSeries Class Properties

StyleEmptyLineSeries Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleEmptyLineSeries Class

For a list of all members of this type, see StyleEmptyLineSeries members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | EndCap | (Inherited from LineStyle)
Public Property | PenStyle | Overridden.
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Width | (Inherited from StyleLineSeries)
Top

Protected Properties

 | Name | Description
Protected Property | IsEmptyLine | (Inherited from StyleLineSeries)
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleEmptyLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleEmptyLineSeries Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As StyleEmptyLineSeries
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleEmptyLineSeries Class
StyleEmptyLineSeries Members


PenStyle Property

PenStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleEmptyLineSeries Class : PenStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property PenStyle As DashStyle
Visual Basic (Usage) Copy Code
Dim instance As StyleEmptyLineSeries
Dim value As DashStyle

instance.PenStyle = value

value = instance.PenStyle
C#
public override DashStyle PenStyle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleEmptyLineSeries Class
StyleEmptyLineSeries Members


StyleExtendedLabel Class

StyleExtendedLabel Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleExtendedLabel Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleExtendedLabel
   Inherits StyleLabel
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
C#
public class StyleExtendedLabel : StyleLabel, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleLabel
Telerik.Reporting.Charting.Styles.StyleExtendedLabel
Telerik.Reporting.Charting.Styles.StyleLabelLegend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Class Members

StyleExtendedLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleExtendedLabel Class

The following tables list the members exposed by StyleExtendedLabel.

Public Constructors

 | Name | Description
Public Constructor | StyleExtendedLabel Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | styleExtendedLabelItemAppearance |
Protected Field | styleExtendedLabelItemMarkerAppearance |
Protected Field | styleExtendedLabelItemTextAppearance |
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | GroupNameFormat |
Public Property | ItemAppearance |
Public Property | ItemMarkerAppearance |
Public Property | ItemTextAppearance |
Public Property | Location |
Public Property | Overflow |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from StyleLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Dispose | Overloaded.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Constructor

StyleExtendedLabel Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : StyleExtendedLabel Constructor

Overload List

Overload | Description
StyleExtendedLabel Constructor() |
StyleExtendedLabel Constructor(ChartSeries) |
StyleExtendedLabel Constructor(FillStyle) |
StyleExtendedLabel Constructor(FillStyle,Position) |
StyleExtendedLabel Constructor(FillStyle,Position,Dimensions) |
StyleExtendedLabel Constructor(LabelItemsCompositionTypes,Dimensions,String,FillStyle,Overflow,Position,Single,Corners,StyleBorder,ShadowStyle,Boolean) |
StyleExtendedLabel Constructor(Position) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


StyleExtendedLabel Constructor()

StyleExtendedLabel Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class > StyleExtendedLabel Constructor : StyleExtendedLabel Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel()
C#
public StyleExtendedLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel()
C#
public StyleExtendedLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members
Overload List


StyleExtendedLabel Constructor(ChartSeries)

StyleExtendedLabel Constructor(ChartSeries)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class > StyleExtendedLabel Constructor : StyleExtendedLabel Constructor(ChartSeries)

series

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As StyleExtendedLabel(series)
C#
public StyleExtendedLabel(
   ChartSeries series
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As StyleExtendedLabel(series)
C#
public StyleExtendedLabel(
   ChartSeries series
)

Parameters

series

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members
Overload List


StyleExtendedLabel Constructor(FillStyle)

StyleExtendedLabel Constructor(FillStyle)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class > StyleExtendedLabel Constructor : StyleExtendedLabel Constructor(FillStyle)

fillStyle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle

Dim instance As StyleExtendedLabel(fillStyle)
C#
public StyleExtendedLabel(
   FillStyle fillStyle
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle

Dim instance As StyleExtendedLabel(fillStyle)
C#
public StyleExtendedLabel(
   FillStyle fillStyle
)

Parameters

fillStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members
Overload List


StyleExtendedLabel Constructor(FillStyle,Position)

StyleExtendedLabel Constructor(FillStyle,Position)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class > StyleExtendedLabel Constructor : StyleExtendedLabel Constructor(FillStyle,Position)

fillStyle
position

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position

Dim instance As StyleExtendedLabel(fillStyle, position)
C#
public StyleExtendedLabel(
   FillStyle fillStyle,
   Position position
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position

Dim instance As StyleExtendedLabel(fillStyle, position)
C#
public StyleExtendedLabel(
   FillStyle fillStyle,
   Position position
)

Parameters

fillStyle
position

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members
Overload List


StyleExtendedLabel Constructor(FillStyle,Position,Dimensions)

StyleExtendedLabel Constructor(FillStyle,Position,Dimensions)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class > StyleExtendedLabel Constructor : StyleExtendedLabel Constructor(FillStyle,Position,Dimensions)

fillStyle
position
dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position
Dim dimensions As Dimensions

Dim instance As StyleExtendedLabel(fillStyle, position, dimensions)
C#
public StyleExtendedLabel(
   FillStyle fillStyle,
   Position position,
   Dimensions dimensions
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position
Dim dimensions As Dimensions

Dim instance As StyleExtendedLabel(fillStyle, position, dimensions)
C#
public StyleExtendedLabel(
   FillStyle fillStyle,
   Position position,
   Dimensions dimensions
)

Parameters

fillStyle
position
dimensions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members
Overload List


StyleExtendedLabel Constructor(LabelItemsCompositionTypes,Dimensions,String,FillStyle,Overflow,Position,Single,Corners,StyleBorder,ShadowStyle,Boolean)

StyleExtendedLabel Constructor(LabelItemsCompositionTypes,Dimensions,String,FillStyle,Overflow,Position,Single,Corners,StyleBorder,ShadowStyle,Boolean)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class > StyleExtendedLabel Constructor : StyleExtendedLabel Constructor(LabelItemsCompositionTypes,Dimensions,String,FillStyle,Overflow,Position,Single,Corners,StyleBorder,ShadowStyle,Boolean)

compositionType
dimensions
figure
fillStyle
overflow
position
rotationAngle
corners
border
shadowStyle
visible

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal compositionType As LabelItemsCompositionTypes, _
   ByVal dimensions As Dimensions, _
   ByVal figure As String, _
   ByVal fillStyle As FillStyle, _
   ByVal overflow As Overflow, _
   ByVal position As Position, _
   ByVal rotationAngle As Single, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim compositionType As LabelItemsCompositionTypes
Dim dimensions As Dimensions
Dim figure As String
Dim fillStyle As FillStyle
Dim overflow As Overflow
Dim position As Position
Dim rotationAngle As Single
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleExtendedLabel(compositionType, dimensions, figure, fillStyle, overflow, position, rotationAngle, corners, border, shadowStyle, visible)
C#
public StyleExtendedLabel(
   LabelItemsCompositionTypes compositionType,
   Dimensions dimensions,
   string figure,
   FillStyle fillStyle,
   Overflow overflow,
   Position position,
   float rotationAngle,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal compositionType As LabelItemsCompositionTypes, _
   ByVal dimensions As Dimensions, _
   ByVal figure As String, _
   ByVal fillStyle As FillStyle, _
   ByVal overflow As Overflow, _
   ByVal position As Position, _
   ByVal rotationAngle As Single, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim compositionType As LabelItemsCompositionTypes
Dim dimensions As Dimensions
Dim figure As String
Dim fillStyle As FillStyle
Dim overflow As Overflow
Dim position As Position
Dim rotationAngle As Single
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleExtendedLabel(compositionType, dimensions, figure, fillStyle, overflow, position, rotationAngle, corners, border, shadowStyle, visible)
C#
public StyleExtendedLabel(
   LabelItemsCompositionTypes compositionType,
   Dimensions dimensions,
   string figure,
   FillStyle fillStyle,
   Overflow overflow,
   Position position,
   float rotationAngle,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Parameters

compositionType
dimensions
figure
fillStyle
overflow
position
rotationAngle
corners
border
shadowStyle
visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members
Overload List


StyleExtendedLabel Constructor(Position)

StyleExtendedLabel Constructor(Position)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class > StyleExtendedLabel Constructor : StyleExtendedLabel Constructor(Position)

position

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim position As Position

Dim instance As StyleExtendedLabel(position)
C#
public StyleExtendedLabel(
   Position position
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim position As Position

Dim instance As StyleExtendedLabel(position)
C#
public StyleExtendedLabel(
   Position position
)

Parameters

position

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members
Overload List


StyleExtendedLabel Class Methods

StyleExtendedLabel Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleExtendedLabel Class

For a list of all members of this type, see StyleExtendedLabel members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Dispose | Overloaded.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : Dispose Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : Finalize Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


StyleExtendedLabel Class Properties

StyleExtendedLabel Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleExtendedLabel Class

For a list of all members of this type, see StyleExtendedLabel members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | GroupNameFormat |
Public Property | ItemAppearance |
Public Property | ItemMarkerAppearance |
Public Property | ItemTextAppearance |
Public Property | Location |
Public Property | Overflow |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from StyleLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


GroupNameFormat Property

GroupNameFormat Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : GroupNameFormat Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property GroupNameFormat As String
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
Dim value As String

instance.GroupNameFormat = value

value = instance.GroupNameFormat
C#
public string GroupNameFormat {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


ItemAppearance Property

ItemAppearance Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : ItemAppearance Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ItemAppearance As StyleLabel
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
Dim value As StyleLabel

value = instance.ItemAppearance
C#
public virtual StyleLabel ItemAppearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


ItemMarkerAppearance Property

ItemMarkerAppearance Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : ItemMarkerAppearance Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ItemMarkerAppearance As StyleMarker
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
Dim value As StyleMarker

value = instance.ItemMarkerAppearance
C#
public virtual StyleMarker ItemMarkerAppearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


ItemTextAppearance Property

ItemTextAppearance Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : ItemTextAppearance Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ItemTextAppearance As StyleTextBlock
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
Dim value As StyleTextBlock

value = instance.ItemTextAppearance
C#
public virtual StyleTextBlock ItemTextAppearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


Location Property

Location Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : Location Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Location As LabelLocation
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
Dim value As LabelLocation

instance.Location = value

value = instance.Location
C#
public LabelLocation Location {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


Overflow Property

Overflow Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : Overflow Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Overflow As Overflow
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
Dim value As Overflow

instance.Overflow = value

value = instance.Overflow
C#
public virtual Overflow Overflow {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


StyleExtendedLabel Class Fields

StyleExtendedLabel Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleExtendedLabel Class

For a list of all members of this type, see StyleExtendedLabel members.

Protected Fields

 | Name | Description
Protected Field | styleExtendedLabelItemAppearance |
Protected Field | styleExtendedLabelItemMarkerAppearance |
Protected Field | styleExtendedLabelItemTextAppearance |
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

See Also

Reference

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


styleExtendedLabelItemAppearance Field

styleExtendedLabelItemAppearance Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : styleExtendedLabelItemAppearance Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleExtendedLabelItemAppearance As StyleLabel
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
Dim value As StyleLabel

value = instance.styleExtendedLabelItemAppearance

instance.styleExtendedLabelItemAppearance = value
C#
protected StyleLabel styleExtendedLabelItemAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


styleExtendedLabelItemMarkerAppearance Field

styleExtendedLabelItemMarkerAppearance Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : styleExtendedLabelItemMarkerAppearance Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleExtendedLabelItemMarkerAppearance As StyleMarker
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
Dim value As StyleMarker

value = instance.styleExtendedLabelItemMarkerAppearance

instance.styleExtendedLabelItemMarkerAppearance = value
C#
protected StyleMarker styleExtendedLabelItemMarkerAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


styleExtendedLabelItemTextAppearance Field

styleExtendedLabelItemTextAppearance Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleExtendedLabel Class : styleExtendedLabelItemTextAppearance Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleExtendedLabelItemTextAppearance As StyleTextBlock
Visual Basic (Usage) Copy Code
Dim instance As StyleExtendedLabel
Dim value As StyleTextBlock

value = instance.styleExtendedLabelItemTextAppearance

instance.styleExtendedLabelItemTextAppearance = value
C#
protected StyleTextBlock styleExtendedLabelItemTextAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleExtendedLabel Class
StyleExtendedLabel Members


StyleGridLine Class

StyleGridLine Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLine Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleGridLine
   Inherits LineStyle
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLine
C#
public class StyleGridLine : LineStyle, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleGridLine
Telerik.Reporting.Charting.Styles.StyleGridLineHidden
Telerik.Reporting.Charting.Styles.StyleGridLineMajor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLine Members
Telerik.Reporting.Charting.Styles Namespace


StyleGridLine Class Members

StyleGridLine Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLine Class

The following tables list the members exposed by StyleGridLine.

Public Constructors

 | Name | Description
Public Constructor | StyleGridLine Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | EndCap | (Inherited from LineStyle)
Public Property | HideWithAxis |
Public Property | PenStyle | Overridden.
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleGridLine Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLine Constructor

StyleGridLine Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleGridLine Class : StyleGridLine Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLine()
C#
public StyleGridLine()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLine()
C#
public StyleGridLine()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLine Class
StyleGridLine Members


StyleGridLine Class Properties

StyleGridLine Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLine Class

For a list of all members of this type, see StyleGridLine members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | EndCap | (Inherited from LineStyle)
Public Property | HideWithAxis |
Public Property | PenStyle | Overridden.
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleGridLine Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleGridLine Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLine
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLine Class
StyleGridLine Members


HideWithAxis Property

HideWithAxis Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleGridLine Class : HideWithAxis Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property HideWithAxis As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLine
Dim value As Boolean

instance.HideWithAxis = value

value = instance.HideWithAxis
C#
public bool HideWithAxis {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLine Class
StyleGridLine Members


PenStyle Property

PenStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleGridLine Class : PenStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property PenStyle As DashStyle
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLine
Dim value As DashStyle

instance.PenStyle = value

value = instance.PenStyle
C#
public override DashStyle PenStyle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLine Class
StyleGridLine Members


Width Property

Width Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleGridLine Class : Width Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLine
Dim value As Single

instance.Width = value

value = instance.Width
C#
public override float Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLine Class
StyleGridLine Members


StyleGridLineHidden Class

StyleGridLineHidden Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLineHidden Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleGridLineHidden
   Inherits StyleGridLine
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLineHidden
C#
public class StyleGridLineHidden : StyleGridLine, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleGridLine
Telerik.Reporting.Charting.Styles.StyleGridLineHidden

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLineHidden Members
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineHidden Class Members

StyleGridLineHidden Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLineHidden Class

The following tables list the members exposed by StyleGridLineHidden.

Public Constructors

 | Name | Description
Public Constructor | StyleGridLineHidden Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleGridLine)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | HideWithAxis | (Inherited from StyleGridLine)
Public Property | PenStyle | (Inherited from StyleGridLine)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | Overridden.
Public Property | Width | (Inherited from StyleGridLine)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleGridLineHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineHidden Constructor

StyleGridLineHidden Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleGridLineHidden Class : StyleGridLineHidden Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLineHidden()
C#
public StyleGridLineHidden()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLineHidden()
C#
public StyleGridLineHidden()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLineHidden Class
StyleGridLineHidden Members


StyleGridLineHidden Class Properties

StyleGridLineHidden Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLineHidden Class

For a list of all members of this type, see StyleGridLineHidden members.

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleGridLine)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | HideWithAxis | (Inherited from StyleGridLine)
Public Property | PenStyle | (Inherited from StyleGridLine)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | Overridden.
Public Property | Width | (Inherited from StyleGridLine)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleGridLineHidden Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleGridLineHidden Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLineHidden
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLineHidden Class
StyleGridLineHidden Members


StyleGridLineMajor Class

StyleGridLineMajor Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLineMajor Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleGridLineMajor
   Inherits StyleGridLine
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLineMajor
C#
public class StyleGridLineMajor : StyleGridLine, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleGridLine
Telerik.Reporting.Charting.Styles.StyleGridLineMajor
Telerik.Reporting.Charting.Styles.StyleGridLineMajorXAxis

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLineMajor Members
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajor Class Members

StyleGridLineMajor Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLineMajor Class

The following tables list the members exposed by StyleGridLineMajor.

Public Constructors

 | Name | Description
Public Constructor | StyleGridLineMajor Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleGridLine)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | HideWithAxis | (Inherited from StyleGridLine)
Public Property | PenStyle | (Inherited from StyleGridLine)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleGridLine)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleGridLineMajor Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajor Constructor

StyleGridLineMajor Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleGridLineMajor Class : StyleGridLineMajor Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLineMajor()
C#
public StyleGridLineMajor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLineMajor()
C#
public StyleGridLineMajor()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLineMajor Class
StyleGridLineMajor Members


StyleGridLineMajorXAxis Class

StyleGridLineMajorXAxis Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLineMajorXAxis Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleGridLineMajorXAxis
   Inherits StyleGridLineMajor
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLineMajorXAxis
C#
public class StyleGridLineMajorXAxis : StyleGridLineMajor, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleGridLine
Telerik.Reporting.Charting.Styles.StyleGridLineMajor
Telerik.Reporting.Charting.Styles.StyleGridLineMajorXAxis

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLineMajorXAxis Members
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajorXAxis Class Members

StyleGridLineMajorXAxis Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLineMajorXAxis Class

The following tables list the members exposed by StyleGridLineMajorXAxis.

Public Constructors

 | Name | Description
Public Constructor | StyleGridLineMajorXAxis Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleGridLine)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | HideWithAxis | (Inherited from StyleGridLine)
Public Property | PenStyle | Overridden.
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleGridLine)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleGridLineMajorXAxis Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajorXAxis Constructor

StyleGridLineMajorXAxis Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleGridLineMajorXAxis Class : StyleGridLineMajorXAxis Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLineMajorXAxis()
C#
public StyleGridLineMajorXAxis()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLineMajorXAxis()
C#
public StyleGridLineMajorXAxis()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLineMajorXAxis Class
StyleGridLineMajorXAxis Members


StyleGridLineMajorXAxis Class Properties

StyleGridLineMajorXAxis Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLineMajorXAxis Class

For a list of all members of this type, see StyleGridLineMajorXAxis members.

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleGridLine)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | HideWithAxis | (Inherited from StyleGridLine)
Public Property | PenStyle | Overridden.
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleGridLine)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleGridLineMajorXAxis Class
Telerik.Reporting.Charting.Styles Namespace


PenStyle Property

PenStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleGridLineMajorXAxis Class : PenStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property PenStyle As DashStyle
Visual Basic (Usage) Copy Code
Dim instance As StyleGridLineMajorXAxis
Dim value As DashStyle

instance.PenStyle = value

value = instance.PenStyle
C#
public override DashStyle PenStyle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleGridLineMajorXAxis Class
StyleGridLineMajorXAxis Members


StyleItemLabelConnector Class

StyleItemLabelConnector Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleItemLabelConnector Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleItemLabelConnector
   Inherits LineStyle
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleItemLabelConnector
C#
public class StyleItemLabelConnector : LineStyle, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleItemLabelConnector

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleItemLabelConnector Members
Telerik.Reporting.Charting.Styles Namespace


StyleItemLabelConnector Class Members

StyleItemLabelConnector Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleItemLabelConnector Class

The following tables list the members exposed by StyleItemLabelConnector.

Public Constructors

 | Name | Description
Public Constructor | StyleItemLabelConnector Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | EndCap | (Inherited from LineStyle)
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleItemLabelConnector Class
Telerik.Reporting.Charting.Styles Namespace


StyleItemLabelConnector Constructor

StyleItemLabelConnector Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleItemLabelConnector Class : StyleItemLabelConnector Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleItemLabelConnector()
C#
public StyleItemLabelConnector()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleItemLabelConnector()
C#
public StyleItemLabelConnector()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleItemLabelConnector Class
StyleItemLabelConnector Members


StyleItemLabelConnector Class Properties

StyleItemLabelConnector Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleItemLabelConnector Class

For a list of all members of this type, see StyleItemLabelConnector members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | EndCap | (Inherited from LineStyle)
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleItemLabelConnector Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleItemLabelConnector Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As StyleItemLabelConnector
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleItemLabelConnector Class
StyleItemLabelConnector Members


StyleLabel Class

StyleLabel Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabel Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleLabel
   Inherits LayoutStyle
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel
C#
public class StyleLabel : LayoutStyle, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleLabel
Telerik.Reporting.Charting.Styles.StyleExtendedLabel
Telerik.Reporting.Charting.Styles.StyleLabelEmptySeriesMessage
Telerik.Reporting.Charting.Styles.StyleLabelHidden
Telerik.Reporting.Charting.Styles.StyleLabelTitle
Telerik.Reporting.Charting.Styles.StyleSeriesItemLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Class Members

StyleLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabel Class

The following tables list the members exposed by StyleLabel.

Public Constructors

 | Name | Description
Public Constructor | StyleLabel Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners |
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType |
Public Property | Corners |
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure |
Public Property | FillStyle |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle |
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Constructor

StyleLabel Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class : StyleLabel Constructor

Overload List

Overload | Description
StyleLabel Constructor() |
StyleLabel Constructor(FillStyle) |
StyleLabel Constructor(FillStyle,Corners,Position,Dimensions) |
StyleLabel Constructor(FillStyle,Position) |
StyleLabel Constructor(FillStyle,Position,Dimensions) |
StyleLabel Constructor(LabelItemsCompositionTypes,Dimensions,String,FillStyle,Position,Single,Corners,StyleBorder,ShadowStyle,Boolean) |
StyleLabel Constructor(Object) |
StyleLabel Constructor(Position) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members


StyleLabel Constructor()

StyleLabel Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class > StyleLabel Constructor : StyleLabel Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel()
C#
public StyleLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel()
C#
public StyleLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members
Overload List


StyleLabel Constructor(FillStyle)

StyleLabel Constructor(FillStyle)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class > StyleLabel Constructor : StyleLabel Constructor(FillStyle)

fillStyle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle

Dim instance As StyleLabel(fillStyle)
C#
public StyleLabel(
   FillStyle fillStyle
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle

Dim instance As StyleLabel(fillStyle)
C#
public StyleLabel(
   FillStyle fillStyle
)

Parameters

fillStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members
Overload List


StyleLabel Constructor(FillStyle,Corners,Position,Dimensions)

StyleLabel Constructor(FillStyle,Corners,Position,Dimensions)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class > StyleLabel Constructor : StyleLabel Constructor(FillStyle,Corners,Position,Dimensions)

fillStyle
corners
position
dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal corners As Corners, _
   ByVal position As Position, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim corners As Corners
Dim position As Position
Dim dimensions As Dimensions

Dim instance As StyleLabel(fillStyle, corners, position, dimensions)
C#
public StyleLabel(
   FillStyle fillStyle,
   Corners corners,
   Position position,
   Dimensions dimensions
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal corners As Corners, _
   ByVal position As Position, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim corners As Corners
Dim position As Position
Dim dimensions As Dimensions

Dim instance As StyleLabel(fillStyle, corners, position, dimensions)
C#
public StyleLabel(
   FillStyle fillStyle,
   Corners corners,
   Position position,
   Dimensions dimensions
)

Parameters

fillStyle
corners
position
dimensions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members
Overload List


StyleLabel Constructor(FillStyle,Position)

StyleLabel Constructor(FillStyle,Position)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class > StyleLabel Constructor : StyleLabel Constructor(FillStyle,Position)

fillStyle
position

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position

Dim instance As StyleLabel(fillStyle, position)
C#
public StyleLabel(
   FillStyle fillStyle,
   Position position
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position

Dim instance As StyleLabel(fillStyle, position)
C#
public StyleLabel(
   FillStyle fillStyle,
   Position position
)

Parameters

fillStyle
position

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members
Overload List


StyleLabel Constructor(FillStyle,Position,Dimensions)

StyleLabel Constructor(FillStyle,Position,Dimensions)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class > StyleLabel Constructor : StyleLabel Constructor(FillStyle,Position,Dimensions)

fillStyle
position
dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position
Dim dimensions As Dimensions

Dim instance As StyleLabel(fillStyle, position, dimensions)
C#
public StyleLabel(
   FillStyle fillStyle,
   Position position,
   Dimensions dimensions
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position
Dim dimensions As Dimensions

Dim instance As StyleLabel(fillStyle, position, dimensions)
C#
public StyleLabel(
   FillStyle fillStyle,
   Position position,
   Dimensions dimensions
)

Parameters

fillStyle
position
dimensions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members
Overload List


StyleLabel Constructor(LabelItemsCompositionTypes,Dimensions,String,FillStyle,Position,Single,Corners,StyleBorder,ShadowStyle,Boolean)

StyleLabel Constructor(LabelItemsCompositionTypes,Dimensions,String,FillStyle,Position,Single,Corners,StyleBorder,ShadowStyle,Boolean)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class > StyleLabel Constructor : StyleLabel Constructor(LabelItemsCompositionTypes,Dimensions,String,FillStyle,Position,Single,Corners,StyleBorder,ShadowStyle,Boolean)

compositionType
dimensions
figure
fillStyle
position
rotationAngle
corners
border
shadowStyle
visible

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal compositionType As LabelItemsCompositionTypes, _
   ByVal dimensions As Dimensions, _
   ByVal figure As String, _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal rotationAngle As Single, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim compositionType As LabelItemsCompositionTypes
Dim dimensions As Dimensions
Dim figure As String
Dim fillStyle As FillStyle
Dim position As Position
Dim rotationAngle As Single
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleLabel(compositionType, dimensions, figure, fillStyle, position, rotationAngle, corners, border, shadowStyle, visible)
C#
public StyleLabel(
   LabelItemsCompositionTypes compositionType,
   Dimensions dimensions,
   string figure,
   FillStyle fillStyle,
   Position position,
   float rotationAngle,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal compositionType As LabelItemsCompositionTypes, _
   ByVal dimensions As Dimensions, _
   ByVal figure As String, _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal rotationAngle As Single, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim compositionType As LabelItemsCompositionTypes
Dim dimensions As Dimensions
Dim figure As String
Dim fillStyle As FillStyle
Dim position As Position
Dim rotationAngle As Single
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleLabel(compositionType, dimensions, figure, fillStyle, position, rotationAngle, corners, border, shadowStyle, visible)
C#
public StyleLabel(
   LabelItemsCompositionTypes compositionType,
   Dimensions dimensions,
   string figure,
   FillStyle fillStyle,
   Position position,
   float rotationAngle,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Parameters

compositionType
dimensions
figure
fillStyle
position
rotationAngle
corners
border
shadowStyle
visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members
Overload List


StyleLabel Constructor(Object)

StyleLabel Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class > StyleLabel Constructor : StyleLabel Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As StyleLabel(containerObject)
C#
public StyleLabel(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As StyleLabel(containerObject)
C#
public StyleLabel(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members
Overload List


StyleLabel Constructor(Position)

StyleLabel Constructor(Position)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class > StyleLabel Constructor : StyleLabel Constructor(Position)

position

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim position As Position

Dim instance As StyleLabel(position)
C#
public StyleLabel(
   Position position
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim position As Position

Dim instance As StyleLabel(position)
C#
public StyleLabel(
   Position position
)

Parameters

position

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members
Overload List


StyleLabel Class Methods

StyleLabel Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabel Class

For a list of all members of this type, see StyleLabel members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members


StyleLabel Class Properties

StyleLabel Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabel Class

For a list of all members of this type, see StyleLabel members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType |
Public Property | Corners |
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure |
Public Property | FillStyle |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle |
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


CompositionType Property

CompositionType Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class : CompositionType Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CompositionType As LabelItemsCompositionTypes
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel
Dim value As LabelItemsCompositionTypes

instance.CompositionType = value

value = instance.CompositionType
C#
public virtual LabelItemsCompositionTypes CompositionType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members


Corners Property

Corners Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class : Corners Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Corners As Corners
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel
Dim value As Corners

instance.Corners = value

value = instance.Corners
C#
public Corners Corners {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members


Figure Property

Figure Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class : Figure Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Figure As String
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel
Dim value As String

instance.Figure = value

value = instance.Figure
C#
public virtual string Figure {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members


FillStyle Property

FillStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class : FillStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property FillStyle As FillStyle
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel
Dim value As FillStyle

value = instance.FillStyle
C#
public virtual FillStyle FillStyle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members


RotationAngle Property

RotationAngle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class : RotationAngle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property RotationAngle As Single
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel
Dim value As Single

instance.RotationAngle = value

value = instance.RotationAngle
C#
public virtual float RotationAngle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members


StyleLabel Class Fields

StyleLabel Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabel Class

For a list of all members of this type, see StyleLabel members.

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners |
Top

See Also

Reference

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


styleLabelCorners Field

styleLabelCorners Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabel Class : styleLabelCorners Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleLabelCorners As Corners
Visual Basic (Usage) Copy Code
Dim instance As StyleLabel
Dim value As Corners

value = instance.styleLabelCorners

instance.styleLabelCorners = value
C#
protected Corners styleLabelCorners

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabel Class
StyleLabel Members


StyleLabelEmptySeriesMessage Class

StyleLabelEmptySeriesMessage Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelEmptySeriesMessage Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleLabelEmptySeriesMessage
   Inherits StyleLabel
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelEmptySeriesMessage
C#
public class StyleLabelEmptySeriesMessage : StyleLabel, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleLabel
Telerik.Reporting.Charting.Styles.StyleLabelEmptySeriesMessage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelEmptySeriesMessage Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelEmptySeriesMessage Class Members

StyleLabelEmptySeriesMessage Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelEmptySeriesMessage Class

The following tables list the members exposed by StyleLabelEmptySeriesMessage.

Public Constructors

 | Name | Description
Public Constructor | StyleLabelEmptySeriesMessage Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleLabel)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleLabel)
Protected Method | SaveViewState | (Inherited from StyleLabel)
Protected Method | TrackViewState | (Inherited from StyleLabel)
Top

See Also

Reference

StyleLabelEmptySeriesMessage Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelEmptySeriesMessage Constructor

StyleLabelEmptySeriesMessage Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelEmptySeriesMessage Class : StyleLabelEmptySeriesMessage Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelEmptySeriesMessage()
C#
public StyleLabelEmptySeriesMessage()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelEmptySeriesMessage()
C#
public StyleLabelEmptySeriesMessage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelEmptySeriesMessage Class
StyleLabelEmptySeriesMessage Members


StyleLabelEmptySeriesMessage Class Properties

StyleLabelEmptySeriesMessage Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelEmptySeriesMessage Class

For a list of all members of this type, see StyleLabelEmptySeriesMessage members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleLabelEmptySeriesMessage Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelEmptySeriesMessage Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelEmptySeriesMessage
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelEmptySeriesMessage Class
StyleLabelEmptySeriesMessage Members


StyleLabelHidden Class

StyleLabelHidden Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelHidden Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleLabelHidden
   Inherits StyleLabel
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelHidden
C#
public class StyleLabelHidden : StyleLabel, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleLabel
Telerik.Reporting.Charting.Styles.StyleLabelHidden
Telerik.Reporting.Charting.Styles.StyleAxisLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelHidden Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Class Members

StyleLabelHidden Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelHidden Class

The following tables list the members exposed by StyleLabelHidden.

Public Constructors

 | Name | Description
Public Constructor | StyleLabelHidden Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleLabel)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleLabel)
Protected Method | SaveViewState | (Inherited from StyleLabel)
Protected Method | TrackViewState | (Inherited from StyleLabel)
Top

See Also

Reference

StyleLabelHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Constructor

StyleLabelHidden Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelHidden Class : StyleLabelHidden Constructor

Overload List

Overload | Description
StyleLabelHidden Constructor() |
StyleLabelHidden Constructor(FillStyle) |
StyleLabelHidden Constructor(FillStyle,Position) |
StyleLabelHidden Constructor(FillStyle,Position,Dimensions) |
StyleLabelHidden Constructor(Object) |
StyleLabelHidden Constructor(Position) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelHidden Class
StyleLabelHidden Members


StyleLabelHidden Constructor()

StyleLabelHidden Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelHidden Class > StyleLabelHidden Constructor : StyleLabelHidden Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelHidden()
C#
public StyleLabelHidden()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelHidden()
C#
public StyleLabelHidden()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelHidden Class
StyleLabelHidden Members
Overload List


StyleLabelHidden Constructor(FillStyle)

StyleLabelHidden Constructor(FillStyle)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelHidden Class > StyleLabelHidden Constructor : StyleLabelHidden Constructor(FillStyle)

fillStyle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle

Dim instance As StyleLabelHidden(fillStyle)
C#
public StyleLabelHidden(
   FillStyle fillStyle
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle

Dim instance As StyleLabelHidden(fillStyle)
C#
public StyleLabelHidden(
   FillStyle fillStyle
)

Parameters

fillStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelHidden Class
StyleLabelHidden Members
Overload List


StyleLabelHidden Constructor(FillStyle,Position)

StyleLabelHidden Constructor(FillStyle,Position)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelHidden Class > StyleLabelHidden Constructor : StyleLabelHidden Constructor(FillStyle,Position)

fillStyle
position

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position

Dim instance As StyleLabelHidden(fillStyle, position)
C#
public StyleLabelHidden(
   FillStyle fillStyle,
   Position position
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position

Dim instance As StyleLabelHidden(fillStyle, position)
C#
public StyleLabelHidden(
   FillStyle fillStyle,
   Position position
)

Parameters

fillStyle
position

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelHidden Class
StyleLabelHidden Members
Overload List


StyleLabelHidden Constructor(FillStyle,Position,Dimensions)

StyleLabelHidden Constructor(FillStyle,Position,Dimensions)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelHidden Class > StyleLabelHidden Constructor : StyleLabelHidden Constructor(FillStyle,Position,Dimensions)

fillStyle
position
dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position
Dim dimensions As Dimensions

Dim instance As StyleLabelHidden(fillStyle, position, dimensions)
C#
public StyleLabelHidden(
   FillStyle fillStyle,
   Position position,
   Dimensions dimensions
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position
Dim dimensions As Dimensions

Dim instance As StyleLabelHidden(fillStyle, position, dimensions)
C#
public StyleLabelHidden(
   FillStyle fillStyle,
   Position position,
   Dimensions dimensions
)

Parameters

fillStyle
position
dimensions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelHidden Class
StyleLabelHidden Members
Overload List


StyleLabelHidden Constructor(Object)

StyleLabelHidden Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelHidden Class > StyleLabelHidden Constructor : StyleLabelHidden Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As StyleLabelHidden(containerObject)
C#
public StyleLabelHidden(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As StyleLabelHidden(containerObject)
C#
public StyleLabelHidden(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelHidden Class
StyleLabelHidden Members
Overload List


StyleLabelHidden Constructor(Position)

StyleLabelHidden Constructor(Position)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelHidden Class > StyleLabelHidden Constructor : StyleLabelHidden Constructor(Position)

position

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim position As Position

Dim instance As StyleLabelHidden(position)
C#
public StyleLabelHidden(
   Position position
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim position As Position

Dim instance As StyleLabelHidden(position)
C#
public StyleLabelHidden(
   Position position
)

Parameters

position

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelHidden Class
StyleLabelHidden Members
Overload List


StyleLabelHidden Class Properties

StyleLabelHidden Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelHidden Class

For a list of all members of this type, see StyleLabelHidden members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleLabelHidden Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelHidden Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelHidden
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelHidden Class
StyleLabelHidden Members


StyleLabelLegend Class

StyleLabelLegend Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelLegend Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleLabelLegend
   Inherits StyleExtendedLabel
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelLegend
C#
public class StyleLabelLegend : StyleExtendedLabel, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleLabel
Telerik.Reporting.Charting.Styles.StyleExtendedLabel
Telerik.Reporting.Charting.Styles.StyleLabelLegend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelLegend Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelLegend Class Members

StyleLabelLegend Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelLegend Class

The following tables list the members exposed by StyleLabelLegend.

Public Constructors

 | Name | Description
Public Constructor | StyleLabelLegend Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | styleExtendedLabelItemAppearance | (Inherited from StyleExtendedLabel)
Protected Field | styleExtendedLabelItemMarkerAppearance | (Inherited from StyleExtendedLabel)
Protected Field | styleExtendedLabelItemTextAppearance | (Inherited from StyleExtendedLabel)
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | Overridden.
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | GroupNameFormat | (Inherited from StyleExtendedLabel)
Public Property | ItemAppearance | (Inherited from StyleExtendedLabel)
Public Property | ItemMarkerAppearance | (Inherited from StyleExtendedLabel)
Public Property | ItemTextAppearance | (Inherited from StyleExtendedLabel)
Public Property | Location | (Inherited from StyleExtendedLabel)
Public Property | Overflow | Overridden.
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from StyleLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleExtendedLabel)
Public Method | Dispose | Overloaded. (Inherited from StyleExtendedLabel)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleExtendedLabel)
Protected Method | LoadViewState | (Inherited from StyleExtendedLabel)
Protected Method | SaveViewState | (Inherited from StyleExtendedLabel)
Protected Method | TrackViewState | (Inherited from StyleExtendedLabel)
Top

See Also

Reference

StyleLabelLegend Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelLegend Constructor

StyleLabelLegend Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelLegend Class : StyleLabelLegend Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelLegend()
C#
public StyleLabelLegend()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelLegend()
C#
public StyleLabelLegend()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelLegend Class
StyleLabelLegend Members


StyleLabelLegend Class Properties

StyleLabelLegend Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelLegend Class

For a list of all members of this type, see StyleLabelLegend members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | Overridden.
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | GroupNameFormat | (Inherited from StyleExtendedLabel)
Public Property | ItemAppearance | (Inherited from StyleExtendedLabel)
Public Property | ItemMarkerAppearance | (Inherited from StyleExtendedLabel)
Public Property | ItemTextAppearance | (Inherited from StyleExtendedLabel)
Public Property | Location | (Inherited from StyleExtendedLabel)
Public Property | Overflow | Overridden.
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from StyleLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleLabelLegend Class
Telerik.Reporting.Charting.Styles Namespace


Figure Property

Figure Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelLegend Class : Figure Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Figure As String
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelLegend
Dim value As String

value = instance.Figure
C#
public override string Figure {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelLegend Class
StyleLabelLegend Members


Overflow Property

Overflow Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelLegend Class : Overflow Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Overflow As Overflow
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelLegend
Dim value As Overflow

instance.Overflow = value

value = instance.Overflow
C#
public override Overflow Overflow {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelLegend Class
StyleLabelLegend Members


StyleLabelTitle Class

StyleLabelTitle Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelTitle Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleLabelTitle
   Inherits StyleLabel
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelTitle
C#
public class StyleLabelTitle : StyleLabel, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleLabel
Telerik.Reporting.Charting.Styles.StyleLabelTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelTitle Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelTitle Class Members

StyleLabelTitle Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelTitle Class

The following tables list the members exposed by StyleLabelTitle.

Public Constructors

 | Name | Description
Public Constructor | StyleLabelTitle Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from StyleLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleLabel)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleLabel)
Protected Method | SaveViewState | (Inherited from StyleLabel)
Protected Method | TrackViewState | (Inherited from StyleLabel)
Top

See Also

Reference

StyleLabelTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelTitle Constructor

StyleLabelTitle Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelTitle Class : StyleLabelTitle Constructor

Overload List

Overload | Description
StyleLabelTitle Constructor() |
StyleLabelTitle Constructor(Chart) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelTitle Class
StyleLabelTitle Members


StyleLabelTitle Constructor()

StyleLabelTitle Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelTitle Class > StyleLabelTitle Constructor : StyleLabelTitle Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelTitle()
C#
public StyleLabelTitle()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLabelTitle()
C#
public StyleLabelTitle()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelTitle Class
StyleLabelTitle Members
Overload List


StyleLabelTitle Constructor(Chart)

StyleLabelTitle Constructor(Chart)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLabelTitle Class > StyleLabelTitle Constructor : StyleLabelTitle Constructor(Chart)

chart

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal chart As Chart _
)
Visual Basic (Usage) Copy Code
Dim chart As Chart

Dim instance As StyleLabelTitle(chart)
C#
public StyleLabelTitle(
   Chart chart
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal chart As Chart _
)
Visual Basic (Usage) Copy Code
Dim chart As Chart

Dim instance As StyleLabelTitle(chart)
C#
public StyleLabelTitle(
   Chart chart
)

Parameters

chart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLabelTitle Class
StyleLabelTitle Members
Overload List


StyleLegendBorder Class

StyleLegendBorder Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLegendBorder Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleLegendBorder
   Inherits StyleBorder
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleLegendBorder
C#
public class StyleLegendBorder : StyleBorder, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.StyleLegendBorder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLegendBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleLegendBorder Class Members

StyleLegendBorder Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLegendBorder Class

The following tables list the members exposed by StyleLegendBorder.

Public Constructors

 | Name | Description
Public Constructor | StyleLegendBorder Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleBorder)
Public Method | Equals | (Inherited from StyleBorder)
Public Method | GetHashCode | (Inherited from StyleBorder)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleLegendBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleLegendBorder Constructor

StyleLegendBorder Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLegendBorder Class : StyleLegendBorder Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLegendBorder()
C#
public StyleLegendBorder()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLegendBorder()
C#
public StyleLegendBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLegendBorder Class
StyleLegendBorder Members


StyleLegendBorder Class Properties

StyleLegendBorder Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLegendBorder Class

For a list of all members of this type, see StyleLegendBorder members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleLegendBorder Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLegendBorder Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As StyleLegendBorder
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLegendBorder Class
StyleLegendBorder Members


StyleLineSeries Class

StyleLineSeries Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLineSeries Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleLineSeries
   Inherits LineStyle
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleLineSeries
C#
public class StyleLineSeries : LineStyle, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleLineSeries
Telerik.Reporting.Charting.Styles.StyleEmptyLineSeries

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLineSeries Members
Telerik.Reporting.Charting.Styles Namespace


StyleLineSeries Class Members

StyleLineSeries Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLineSeries Class

The following tables list the members exposed by StyleLineSeries.

Public Constructors

 | Name | Description
Public Constructor | StyleLineSeries Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | EndCap | (Inherited from LineStyle)
Public Property | PenStyle | Overridden.
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | IsEmptyLine |
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleLineSeries Constructor

StyleLineSeries Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLineSeries Class : StyleLineSeries Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLineSeries()
C#
public StyleLineSeries()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleLineSeries()
C#
public StyleLineSeries()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLineSeries Class
StyleLineSeries Members


StyleLineSeries Class Properties

StyleLineSeries Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLineSeries Class

For a list of all members of this type, see StyleLineSeries members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | EndCap | (Inherited from LineStyle)
Public Property | PenStyle | Overridden.
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | IsEmptyLine |
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLineSeries Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As StyleLineSeries
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLineSeries Class
StyleLineSeries Members


IsEmptyLine Property

IsEmptyLine Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLineSeries Class : IsEmptyLine Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsEmptyLine As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleLineSeries
Dim value As Boolean

value = instance.IsEmptyLine
C#
protected bool IsEmptyLine {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLineSeries Class
StyleLineSeries Members


PenStyle Property

PenStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLineSeries Class : PenStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property PenStyle As DashStyle
Visual Basic (Usage) Copy Code
Dim instance As StyleLineSeries
Dim value As DashStyle

instance.PenStyle = value

value = instance.PenStyle
C#
public override DashStyle PenStyle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLineSeries Class
StyleLineSeries Members


Width Property

Width Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleLineSeries Class : Width Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As StyleLineSeries
Dim value As Single

instance.Width = value

value = instance.Width
C#
public override float Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleLineSeries Class
StyleLineSeries Members


StyleMarkedZone Class

StyleMarkedZone Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkedZone Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleMarkedZone
   Inherits Style
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkedZone
C#
public class StyleMarkedZone : Style, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.StyleMarkedZone

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkedZone Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkedZone Class Members

StyleMarkedZone Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkedZone Class

The following tables list the members exposed by StyleMarkedZone.

Public Constructors

 | Name | Description
Public Constructor | StyleMarkedZone Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | FillStyle |
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Style)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleMarkedZone Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkedZone Constructor

StyleMarkedZone Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkedZone Class : StyleMarkedZone Constructor

Overload List

Overload | Description
StyleMarkedZone Constructor() |
StyleMarkedZone Constructor(FillStyleMarkedZones,StyleBorder,ShadowStyle,Boolean) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkedZone Class
StyleMarkedZone Members


StyleMarkedZone Constructor()

StyleMarkedZone Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkedZone Class > StyleMarkedZone Constructor : StyleMarkedZone Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkedZone()
C#
public StyleMarkedZone()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkedZone()
C#
public StyleMarkedZone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkedZone Class
StyleMarkedZone Members
Overload List


StyleMarkedZone Constructor(FillStyleMarkedZones,StyleBorder,ShadowStyle,Boolean)

StyleMarkedZone Constructor(FillStyleMarkedZones,StyleBorder,ShadowStyle,Boolean)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkedZone Class > StyleMarkedZone Constructor : StyleMarkedZone Constructor(FillStyleMarkedZones,StyleBorder,ShadowStyle,Boolean)

fillStyle
border
shadowStyle
visible

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyleMarkedZones, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyleMarkedZones
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleMarkedZone(fillStyle, border, shadowStyle, visible)
C#
public StyleMarkedZone(
   FillStyleMarkedZones fillStyle,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyleMarkedZones, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyleMarkedZones
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleMarkedZone(fillStyle, border, shadowStyle, visible)
C#
public StyleMarkedZone(
   FillStyleMarkedZones fillStyle,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Parameters

fillStyle
border
shadowStyle
visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkedZone Class
StyleMarkedZone Members
Overload List


StyleMarkedZone Class Methods

StyleMarkedZone Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkedZone Class

For a list of all members of this type, see StyleMarkedZone members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Style)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleMarkedZone Class
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkedZone Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkedZone
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkedZone Class
StyleMarkedZone Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkedZone Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkedZone
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkedZone Class
StyleMarkedZone Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkedZone Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkedZone

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkedZone Class
StyleMarkedZone Members


StyleMarkedZone Class Properties

StyleMarkedZone Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkedZone Class

For a list of all members of this type, see StyleMarkedZone members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | FillStyle |
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleMarkedZone Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Property

FillStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkedZone Class : FillStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStyleMarkedZones
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkedZone
Dim value As FillStyleMarkedZones

value = instance.FillStyle
C#
public FillStyleMarkedZones FillStyle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkedZone Class
StyleMarkedZone Members


StyleMarker Class

StyleMarker Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarker Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleMarker
   Inherits LayoutStyle
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker
C#
public class StyleMarker : LayoutStyle, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleMarker
Telerik.Reporting.Charting.Styles.StyleMarkerEmptyValue
Telerik.Reporting.Charting.Styles.StyleMarkerLegend
Telerik.Reporting.Charting.Styles.StyleMarkerPositionNone
Telerik.Reporting.Charting.Styles.StyleMarkerSeriesPoint

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarker Class Members

StyleMarker Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarker Class

The following tables list the members exposed by StyleMarker.

Public Constructors

 | Name | Description
Public Constructor | StyleMarker Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners |
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure |
Public Property | FillStyle |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle |
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarker Constructor

StyleMarker Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class : StyleMarker Constructor

Overload List

Overload | Description
StyleMarker Constructor() |
StyleMarker Constructor(Dimensions,String,FillStyle,Position,Single,Corners,StyleBorder,ShadowStyle,Boolean) |
StyleMarker Constructor(Object) |
StyleMarker Constructor(String) |
StyleMarker Constructor(String,Dimensions,FillStyle) |
StyleMarker Constructor(String,Int32) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members


StyleMarker Constructor()

StyleMarker Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class > StyleMarker Constructor : StyleMarker Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker()
C#
public StyleMarker()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker()
C#
public StyleMarker()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members
Overload List


StyleMarker Constructor(Dimensions,String,FillStyle,Position,Single,Corners,StyleBorder,ShadowStyle,Boolean)

StyleMarker Constructor(Dimensions,String,FillStyle,Position,Single,Corners,StyleBorder,ShadowStyle,Boolean)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class > StyleMarker Constructor : StyleMarker Constructor(Dimensions,String,FillStyle,Position,Single,Corners,StyleBorder,ShadowStyle,Boolean)

dimensions
figure
fillStyle
position
rotationAngle
corners
border
shadowStyle
visible

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dimensions As Dimensions, _
   ByVal figure As String, _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal rotationAngle As Single, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim dimensions As Dimensions
Dim figure As String
Dim fillStyle As FillStyle
Dim position As Position
Dim rotationAngle As Single
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleMarker(dimensions, figure, fillStyle, position, rotationAngle, corners, border, shadowStyle, visible)
C#
public StyleMarker(
   Dimensions dimensions,
   string figure,
   FillStyle fillStyle,
   Position position,
   float rotationAngle,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dimensions As Dimensions, _
   ByVal figure As String, _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal rotationAngle As Single, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim dimensions As Dimensions
Dim figure As String
Dim fillStyle As FillStyle
Dim position As Position
Dim rotationAngle As Single
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleMarker(dimensions, figure, fillStyle, position, rotationAngle, corners, border, shadowStyle, visible)
C#
public StyleMarker(
   Dimensions dimensions,
   string figure,
   FillStyle fillStyle,
   Position position,
   float rotationAngle,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Parameters

dimensions
figure
fillStyle
position
rotationAngle
corners
border
shadowStyle
visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members
Overload List


StyleMarker Constructor(Object)

StyleMarker Constructor(Object)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class > StyleMarker Constructor : StyleMarker Constructor(Object)

containerObject

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As StyleMarker(containerObject)
C#
public StyleMarker(
   object containerObject
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal containerObject As Object _
)
Visual Basic (Usage) Copy Code
Dim containerObject As Object

Dim instance As StyleMarker(containerObject)
C#
public StyleMarker(
   object containerObject
)

Parameters

containerObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members
Overload List


StyleMarker Constructor(String)

StyleMarker Constructor(String)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class > StyleMarker Constructor : StyleMarker Constructor(String)

figureType

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal figureType As String _
)
Visual Basic (Usage) Copy Code
Dim figureType As String

Dim instance As StyleMarker(figureType)
C#
public StyleMarker(
   string figureType
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal figureType As String _
)
Visual Basic (Usage) Copy Code
Dim figureType As String

Dim instance As StyleMarker(figureType)
C#
public StyleMarker(
   string figureType
)

Parameters

figureType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members
Overload List


StyleMarker Constructor(String,Dimensions,FillStyle)

StyleMarker Constructor(String,Dimensions,FillStyle)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class > StyleMarker Constructor : StyleMarker Constructor(String,Dimensions,FillStyle)

figureType
dimensions
fillStyle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal figureType As String, _
   ByVal dimensions As Dimensions, _
   ByVal fillStyle As FillStyle _
)
Visual Basic (Usage) Copy Code
Dim figureType As String
Dim dimensions As Dimensions
Dim fillStyle As FillStyle

Dim instance As StyleMarker(figureType, dimensions, fillStyle)
C#
public StyleMarker(
   string figureType,
   Dimensions dimensions,
   FillStyle fillStyle
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal figureType As String, _
   ByVal dimensions As Dimensions, _
   ByVal fillStyle As FillStyle _
)
Visual Basic (Usage) Copy Code
Dim figureType As String
Dim dimensions As Dimensions
Dim fillStyle As FillStyle

Dim instance As StyleMarker(figureType, dimensions, fillStyle)
C#
public StyleMarker(
   string figureType,
   Dimensions dimensions,
   FillStyle fillStyle
)

Parameters

figureType
dimensions
fillStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members
Overload List


StyleMarker Constructor(String,Int32)

StyleMarker Constructor(String,Int32)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class > StyleMarker Constructor : StyleMarker Constructor(String,Int32)

figureType
pointSize

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal figureType As String, _
   ByVal pointSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim figureType As String
Dim pointSize As Integer

Dim instance As StyleMarker(figureType, pointSize)
C#
public StyleMarker(
   string figureType,
   int pointSize
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal figureType As String, _
   ByVal pointSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim figureType As String
Dim pointSize As Integer

Dim instance As StyleMarker(figureType, pointSize)
C#
public StyleMarker(
   string figureType,
   int pointSize
)

Parameters

figureType
pointSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members
Overload List


StyleMarker Class Methods

StyleMarker Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarker Class

For a list of all members of this type, see StyleMarker members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members


StyleMarker Class Properties

StyleMarker Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarker Class

For a list of all members of this type, see StyleMarker members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners |
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure |
Public Property | FillStyle |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle |
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


Corners Property

Corners Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class : Corners Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Corners As Corners
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker
Dim value As Corners

instance.Corners = value

value = instance.Corners
C#
public virtual Corners Corners {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members


Figure Property

Figure Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class : Figure Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Figure As String
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker
Dim value As String

instance.Figure = value

value = instance.Figure
C#
public virtual string Figure {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members


FillStyle Property

FillStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class : FillStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property FillStyle As FillStyle
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker
Dim value As FillStyle

value = instance.FillStyle
C#
public virtual FillStyle FillStyle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members


RotationAngle Property

RotationAngle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class : RotationAngle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property RotationAngle As Single
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker
Dim value As Single

instance.RotationAngle = value

value = instance.RotationAngle
C#
public virtual float RotationAngle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarker Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleMarker
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarker Class
StyleMarker Members


StyleMarkerEmptyValue Class

StyleMarkerEmptyValue Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerEmptyValue Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleMarkerEmptyValue
   Inherits StyleMarker
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerEmptyValue
C#
public class StyleMarkerEmptyValue : StyleMarker, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleMarker
Telerik.Reporting.Charting.Styles.StyleMarkerEmptyValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerEmptyValue Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerEmptyValue Class Members

StyleMarkerEmptyValue Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerEmptyValue Class

The following tables list the members exposed by StyleMarkerEmptyValue.

Public Constructors

 | Name | Description
Public Constructor | StyleMarkerEmptyValue Constructor |
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleMarker)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | Overridden.
Public Property | FillStyle | (Inherited from StyleMarker)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleMarker)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleMarker)
Public Method | Equals | (Inherited from StyleMarker)
Public Method | GetHashCode | (Inherited from StyleMarker)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleMarker)
Protected Method | SaveViewState | (Inherited from StyleMarker)
Protected Method | TrackViewState | (Inherited from StyleMarker)
Top

See Also

Reference

StyleMarkerEmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerEmptyValue Constructor

StyleMarkerEmptyValue Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerEmptyValue Class : StyleMarkerEmptyValue Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerEmptyValue()
C#
public StyleMarkerEmptyValue()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerEmptyValue()
C#
public StyleMarkerEmptyValue()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerEmptyValue Class
StyleMarkerEmptyValue Members


StyleMarkerEmptyValue Class Properties

StyleMarkerEmptyValue Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerEmptyValue Class

For a list of all members of this type, see StyleMarkerEmptyValue members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleMarker)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | Overridden.
Public Property | FillStyle | (Inherited from StyleMarker)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleMarker)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleMarkerEmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


Figure Property

Figure Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerEmptyValue Class : Figure Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Figure As String
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerEmptyValue
Dim value As String

instance.Figure = value

value = instance.Figure
C#
public override string Figure {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerEmptyValue Class
StyleMarkerEmptyValue Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerEmptyValue Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerEmptyValue
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerEmptyValue Class
StyleMarkerEmptyValue Members


StyleMarkerLegend Class

StyleMarkerLegend Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerLegend Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleMarkerLegend
   Inherits StyleMarker
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerLegend
C#
public class StyleMarkerLegend : StyleMarker, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleMarker
Telerik.Reporting.Charting.Styles.StyleMarkerLegend

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerLegend Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerLegend Class Members

StyleMarkerLegend Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerLegend Class

The following tables list the members exposed by StyleMarkerLegend.

Public Constructors

 | Name | Description
Public Constructor | StyleMarkerLegend Constructor |
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleMarker)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | Overridden.
Public Property | FillStyle | (Inherited from StyleMarker)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleMarker)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleMarker)
Public Method | Equals | (Inherited from StyleMarker)
Public Method | GetHashCode | (Inherited from StyleMarker)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleMarker)
Protected Method | SaveViewState | (Inherited from StyleMarker)
Protected Method | TrackViewState | (Inherited from StyleMarker)
Top

See Also

Reference

StyleMarkerLegend Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerLegend Constructor

StyleMarkerLegend Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerLegend Class : StyleMarkerLegend Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerLegend()
C#
public StyleMarkerLegend()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerLegend()
C#
public StyleMarkerLegend()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerLegend Class
StyleMarkerLegend Members


StyleMarkerLegend Class Properties

StyleMarkerLegend Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerLegend Class

For a list of all members of this type, see StyleMarkerLegend members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleMarker)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | Overridden.
Public Property | FillStyle | (Inherited from StyleMarker)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleMarker)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleMarkerLegend Class
Telerik.Reporting.Charting.Styles Namespace


Figure Property

Figure Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerLegend Class : Figure Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Figure As String
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerLegend
Dim value As String

instance.Figure = value

value = instance.Figure
C#
public override string Figure {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerLegend Class
StyleMarkerLegend Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerLegend Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerLegend
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerLegend Class
StyleMarkerLegend Members


StyleMarkerPositionNone Class

StyleMarkerPositionNone Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerPositionNone Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleMarkerPositionNone
   Inherits StyleMarker
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerPositionNone
C#
public class StyleMarkerPositionNone : StyleMarker, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleMarker
Telerik.Reporting.Charting.Styles.StyleMarkerPositionNone

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerPositionNone Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerPositionNone Class Members

StyleMarkerPositionNone Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerPositionNone Class

The following tables list the members exposed by StyleMarkerPositionNone.

Public Constructors

 | Name | Description
Public Constructor | StyleMarkerPositionNone Constructor |
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleMarker)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleMarker)
Public Property | FillStyle | (Inherited from StyleMarker)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleMarker)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleMarker)
Public Method | Equals | (Inherited from StyleMarker)
Public Method | GetHashCode | (Inherited from StyleMarker)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleMarker)
Protected Method | SaveViewState | (Inherited from StyleMarker)
Protected Method | TrackViewState | (Inherited from StyleMarker)
Top

See Also

Reference

StyleMarkerPositionNone Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerPositionNone Constructor

StyleMarkerPositionNone Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerPositionNone Class : StyleMarkerPositionNone Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerPositionNone()
C#
public StyleMarkerPositionNone()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerPositionNone()
C#
public StyleMarkerPositionNone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerPositionNone Class
StyleMarkerPositionNone Members


StyleMarkerPositionNone Class Properties

StyleMarkerPositionNone Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerPositionNone Class

For a list of all members of this type, see StyleMarkerPositionNone members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleMarker)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleMarker)
Public Property | FillStyle | (Inherited from StyleMarker)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleMarker)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleMarkerPositionNone Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerPositionNone Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerPositionNone
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerPositionNone Class
StyleMarkerPositionNone Members


StyleMarkerSeriesPoint Class

StyleMarkerSeriesPoint Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerSeriesPoint Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleMarkerSeriesPoint
   Inherits StyleMarker
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerSeriesPoint
C#
public class StyleMarkerSeriesPoint : StyleMarker, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleMarker
Telerik.Reporting.Charting.Styles.StyleMarkerSeriesPoint

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerSeriesPoint Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerSeriesPoint Class Members

StyleMarkerSeriesPoint Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerSeriesPoint Class

The following tables list the members exposed by StyleMarkerSeriesPoint.

Public Constructors

 | Name | Description
Public Constructor | StyleMarkerSeriesPoint Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleMarker)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | Overridden.
Public Property | FillStyle | (Inherited from StyleMarker)
Public Property | Position | Overridden.
Public Property | RotationAngle | (Inherited from StyleMarker)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleMarker)
Public Method | Equals | (Inherited from StyleMarker)
Public Method | GetHashCode | (Inherited from StyleMarker)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleMarker)
Protected Method | SaveViewState | (Inherited from StyleMarker)
Protected Method | TrackViewState | (Inherited from StyleMarker)
Top

See Also

Reference

StyleMarkerSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerSeriesPoint Constructor

StyleMarkerSeriesPoint Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerSeriesPoint Class : StyleMarkerSeriesPoint Constructor

Overload List

Overload | Description
StyleMarkerSeriesPoint Constructor() |
StyleMarkerSeriesPoint Constructor(ChartSeries,String) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerSeriesPoint Class
StyleMarkerSeriesPoint Members


StyleMarkerSeriesPoint Constructor()

StyleMarkerSeriesPoint Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerSeriesPoint Class > StyleMarkerSeriesPoint Constructor : StyleMarkerSeriesPoint Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerSeriesPoint()
C#
public StyleMarkerSeriesPoint()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerSeriesPoint()
C#
public StyleMarkerSeriesPoint()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerSeriesPoint Class
StyleMarkerSeriesPoint Members
Overload List


StyleMarkerSeriesPoint Constructor(ChartSeries,String)

StyleMarkerSeriesPoint Constructor(ChartSeries,String)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerSeriesPoint Class > StyleMarkerSeriesPoint Constructor : StyleMarkerSeriesPoint Constructor(ChartSeries,String)

series
subPropertyName

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries, _
   ByVal subPropertyName As String _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries
Dim subPropertyName As String

Dim instance As StyleMarkerSeriesPoint(series, subPropertyName)
C#
public StyleMarkerSeriesPoint(
   ChartSeries series,
   string subPropertyName
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries, _
   ByVal subPropertyName As String _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries
Dim subPropertyName As String

Dim instance As StyleMarkerSeriesPoint(series, subPropertyName)
C#
public StyleMarkerSeriesPoint(
   ChartSeries series,
   string subPropertyName
)

Parameters

series
subPropertyName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerSeriesPoint Class
StyleMarkerSeriesPoint Members
Overload List


StyleMarkerSeriesPoint Class Properties

StyleMarkerSeriesPoint Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerSeriesPoint Class

For a list of all members of this type, see StyleMarkerSeriesPoint members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleMarker)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | Overridden.
Public Property | FillStyle | (Inherited from StyleMarker)
Public Property | Position | Overridden.
Public Property | RotationAngle | (Inherited from StyleMarker)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleMarkerSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


Figure Property

Figure Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerSeriesPoint Class : Figure Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Figure As String
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerSeriesPoint
Dim value As String

instance.Figure = value

value = instance.Figure
C#
public override string Figure {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerSeriesPoint Class
StyleMarkerSeriesPoint Members


Position Property

Position Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerSeriesPoint Class : Position Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Position As Position
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerSeriesPoint
Dim value As Position

value = instance.Position
C#
public override Position Position {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerSeriesPoint Class
StyleMarkerSeriesPoint Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleMarkerSeriesPoint Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleMarkerSeriesPoint
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleMarkerSeriesPoint Class
StyleMarkerSeriesPoint Members


StylePlotArea Class

StylePlotArea Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StylePlotArea Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StylePlotArea
   Inherits LayoutStyle
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StylePlotArea
C#
public class StylePlotArea : LayoutStyle, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StylePlotArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StylePlotArea Members
Telerik.Reporting.Charting.Styles Namespace


StylePlotArea Class Members

StylePlotArea Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StylePlotArea Class

The following tables list the members exposed by StylePlotArea.

Public Constructors

 | Name | Description
Public Constructor | StylePlotArea Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners |
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure |
Public Property | FillStyle |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | SeriesPalette |
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


StylePlotArea Constructor

StylePlotArea Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StylePlotArea Class : StylePlotArea Constructor

Overload List

Overload | Description
StylePlotArea Constructor() |
StylePlotArea Constructor(Dimensions,FillStylePlotArea,Position,String,Corners,StyleBorder,ShadowStyle,Boolean) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StylePlotArea Class
StylePlotArea Members


StylePlotArea Constructor()

StylePlotArea Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StylePlotArea Class > StylePlotArea Constructor : StylePlotArea Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StylePlotArea()
C#
public StylePlotArea()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StylePlotArea()
C#
public StylePlotArea()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StylePlotArea Class
StylePlotArea Members
Overload List


StylePlotArea Constructor(Dimensions,FillStylePlotArea,Position,String,Corners,StyleBorder,ShadowStyle,Boolean)

StylePlotArea Constructor(Dimensions,FillStylePlotArea,Position,String,Corners,StyleBorder,ShadowStyle,Boolean)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StylePlotArea Class > StylePlotArea Constructor : StylePlotArea Constructor(Dimensions,FillStylePlotArea,Position,String,Corners,StyleBorder,ShadowStyle,Boolean)

dimensions
fillStyle
position
palette
corners
border
shadowStyle
visible

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dimensions As Dimensions, _
   ByVal fillStyle As FillStylePlotArea, _
   ByVal position As Position, _
   ByVal palette As String, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim dimensions As Dimensions
Dim fillStyle As FillStylePlotArea
Dim position As Position
Dim palette As String
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StylePlotArea(dimensions, fillStyle, position, palette, corners, border, shadowStyle, visible)
C#
public StylePlotArea(
   Dimensions dimensions,
   FillStylePlotArea fillStyle,
   Position position,
   string palette,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dimensions As Dimensions, _
   ByVal fillStyle As FillStylePlotArea, _
   ByVal position As Position, _
   ByVal palette As String, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim dimensions As Dimensions
Dim fillStyle As FillStylePlotArea
Dim position As Position
Dim palette As String
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StylePlotArea(dimensions, fillStyle, position, palette, corners, border, shadowStyle, visible)
C#
public StylePlotArea(
   Dimensions dimensions,
   FillStylePlotArea fillStyle,
   Position position,
   string palette,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Parameters

dimensions
fillStyle
position
palette
corners
border
shadowStyle
visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StylePlotArea Class
StylePlotArea Members
Overload List


StylePlotArea Class Methods

StylePlotArea Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StylePlotArea Class

For a list of all members of this type, see StylePlotArea members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StylePlotArea Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As StylePlotArea
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StylePlotArea Class
StylePlotArea Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StylePlotArea Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StylePlotArea
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StylePlotArea Class
StylePlotArea Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StylePlotArea Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As StylePlotArea
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StylePlotArea Class
StylePlotArea Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StylePlotArea Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As StylePlotArea

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StylePlotArea Class
StylePlotArea Members


StylePlotArea Class Properties

StylePlotArea Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StylePlotArea Class

For a list of all members of this type, see StylePlotArea members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners |
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure |
Public Property | FillStyle |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | SeriesPalette |
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Corners Property

Corners Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StylePlotArea Class : Corners Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Corners As Corners
Visual Basic (Usage) Copy Code
Dim instance As StylePlotArea
Dim value As Corners

instance.Corners = value

value = instance.Corners
C#
public Corners Corners {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StylePlotArea Class
StylePlotArea Members


Figure Property

Figure Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StylePlotArea Class : Figure Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Figure As String
Visual Basic (Usage) Copy Code
Dim instance As StylePlotArea
Dim value As String

value = instance.Figure
C#
public string Figure {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StylePlotArea Class
StylePlotArea Members


FillStyle Property

FillStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StylePlotArea Class : FillStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStylePlotArea
Visual Basic (Usage) Copy Code
Dim instance As StylePlotArea
Dim value As FillStylePlotArea

value = instance.FillStyle
C#
public FillStylePlotArea FillStyle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StylePlotArea Class
StylePlotArea Members


SeriesPalette Property

SeriesPalette Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StylePlotArea Class : SeriesPalette Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property SeriesPalette As String
Visual Basic (Usage) Copy Code
Dim instance As StylePlotArea
Dim value As String

instance.SeriesPalette = value

value = instance.SeriesPalette
C#
public string SeriesPalette {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StylePlotArea Class
StylePlotArea Members


StyleSeries Class

StyleSeries Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeries Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleSeries
   Inherits Style
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
C#
public class StyleSeries : Style, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.StyleSeries

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeries Class Members

StyleSeries Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeries Class

The following tables list the members exposed by StyleSeries.

Public Constructors

 | Name | Description
Public Constructor | StyleSeries Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | BarWidthPercent |
Public Property | Border | Overridden.
Public Property | BubbleSize |
Public Property | CenterXOffset |
Public Property | CenterYOffset |
Public Property | Corners |
Public Property | DiameterScale |
Public Property | EmptyValue |
Public Property | ExplodePercent |
Public Property | FillStyle |
Public Property | LabelAppearance |
Public Property | LegendDisplayMode |
Public Property | LineSeriesAppearance |
Public Property | PointDimentions |
Public Property | PointMark |
Public Property | PointRotationAngle |
Public Property | PointShape |
Public Property | Shadow | (Inherited from Style)
Public Property | ShowLabelConnectors |
Public Property | ShowLabels |
Public Property | StartAngle |
Public Property | TextAppearance |
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Dispose | Overloaded.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeries Constructor

StyleSeries Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : StyleSeries Constructor

Overload List

Overload | Description
StyleSeries Constructor() |
StyleSeries Constructor(ChartSeries) |
StyleSeries Constructor(FillStyleSeries,StyleSeriesItemLabel,StyleMarkerSeriesPoint,Corners,StyleBorder,ShadowStyle,Boolean) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


StyleSeries Constructor()

StyleSeries Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class > StyleSeries Constructor : StyleSeries Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries()
C#
public StyleSeries()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries()
C#
public StyleSeries()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members
Overload List


StyleSeries Constructor(ChartSeries)

StyleSeries Constructor(ChartSeries)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class > StyleSeries Constructor : StyleSeries Constructor(ChartSeries)

series

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As StyleSeries(series)
C#
public StyleSeries(
   ChartSeries series
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As StyleSeries(series)
C#
public StyleSeries(
   ChartSeries series
)

Parameters

series

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members
Overload List


StyleSeries Constructor(FillStyleSeries,StyleSeriesItemLabel,StyleMarkerSeriesPoint,Corners,StyleBorder,ShadowStyle,Boolean)

StyleSeries Constructor(FillStyleSeries,StyleSeriesItemLabel,StyleMarkerSeriesPoint,Corners,StyleBorder,ShadowStyle,Boolean)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class > StyleSeries Constructor : StyleSeries Constructor(FillStyleSeries,StyleSeriesItemLabel,StyleMarkerSeriesPoint,Corners,StyleBorder,ShadowStyle,Boolean)

fillStyle
styleSeriesLabel
stylePointMarker
corners
border
shadowStyle
visible

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyleSeries, _
   ByVal styleSeriesLabel As StyleSeriesItemLabel, _
   ByVal stylePointMarker As StyleMarkerSeriesPoint, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyleSeries
Dim styleSeriesLabel As StyleSeriesItemLabel
Dim stylePointMarker As StyleMarkerSeriesPoint
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleSeries(fillStyle, styleSeriesLabel, stylePointMarker, corners, border, shadowStyle, visible)
C#
public StyleSeries(
   FillStyleSeries fillStyle,
   StyleSeriesItemLabel styleSeriesLabel,
   StyleMarkerSeriesPoint stylePointMarker,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyleSeries, _
   ByVal styleSeriesLabel As StyleSeriesItemLabel, _
   ByVal stylePointMarker As StyleMarkerSeriesPoint, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyleSeries
Dim styleSeriesLabel As StyleSeriesItemLabel
Dim stylePointMarker As StyleMarkerSeriesPoint
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleSeries(fillStyle, styleSeriesLabel, stylePointMarker, corners, border, shadowStyle, visible)
C#
public StyleSeries(
   FillStyleSeries fillStyle,
   StyleSeriesItemLabel styleSeriesLabel,
   StyleMarkerSeriesPoint stylePointMarker,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Parameters

fillStyle
styleSeriesLabel
stylePointMarker
corners
border
shadowStyle
visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members
Overload List


StyleSeries Class Methods

StyleSeries Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeries Class

For a list of all members of this type, see StyleSeries members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Dispose | Overloaded.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : Dispose Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : Finalize Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


StyleSeries Class Properties

StyleSeries Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeries Class

For a list of all members of this type, see StyleSeries members.

Public Properties

 | Name | Description
Public Property | BarWidthPercent |
Public Property | Border | Overridden.
Public Property | BubbleSize |
Public Property | CenterXOffset |
Public Property | CenterYOffset |
Public Property | Corners |
Public Property | DiameterScale |
Public Property | EmptyValue |
Public Property | ExplodePercent |
Public Property | FillStyle |
Public Property | LabelAppearance |
Public Property | LegendDisplayMode |
Public Property | LineSeriesAppearance |
Public Property | PointDimentions |
Public Property | PointMark |
Public Property | PointRotationAngle |
Public Property | PointShape |
Public Property | Shadow | (Inherited from Style)
Public Property | ShowLabelConnectors |
Public Property | ShowLabels |
Public Property | StartAngle |
Public Property | TextAppearance |
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


BarWidthPercent Property

BarWidthPercent Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : BarWidthPercent Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property BarWidthPercent As Decimal
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Decimal

instance.BarWidthPercent = value

value = instance.BarWidthPercent
C#
public decimal BarWidthPercent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


Border Property

Border Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : Border Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Border As StyleBorder
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As StyleBorder

value = instance.Border
C#
public override StyleBorder Border {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


BubbleSize Property

BubbleSize Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : BubbleSize Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property BubbleSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Integer

instance.BubbleSize = value

value = instance.BubbleSize
C#
public int BubbleSize {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


CenterXOffset Property

CenterXOffset Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : CenterXOffset Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property CenterXOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Integer

instance.CenterXOffset = value

value = instance.CenterXOffset
C#
public int CenterXOffset {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


CenterYOffset Property

CenterYOffset Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : CenterYOffset Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property CenterYOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Integer

instance.CenterYOffset = value

value = instance.CenterYOffset
C#
public int CenterYOffset {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


Corners Property

Corners Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : Corners Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Corners As Corners
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Corners

instance.Corners = value

value = instance.Corners
C#
public Corners Corners {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


DiameterScale Property

DiameterScale Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : DiameterScale Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property DiameterScale As Double
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Double

instance.DiameterScale = value

value = instance.DiameterScale
C#
public double DiameterScale {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


EmptyValue Property

EmptyValue Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : EmptyValue Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EmptyValue As EmptyValue
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As EmptyValue

value = instance.EmptyValue
C#
public EmptyValue EmptyValue {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


ExplodePercent Property

ExplodePercent Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : ExplodePercent Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ExplodePercent As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Integer

instance.ExplodePercent = value

value = instance.ExplodePercent
C#
public int ExplodePercent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


FillStyle Property

FillStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : FillStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStyleSeries
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As FillStyleSeries

value = instance.FillStyle
C#
public FillStyleSeries FillStyle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


LabelAppearance Property

LabelAppearance Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : LabelAppearance Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LabelAppearance As StyleSeriesItemLabel
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As StyleSeriesItemLabel

value = instance.LabelAppearance
C#
public StyleSeriesItemLabel LabelAppearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


LegendDisplayMode Property

LegendDisplayMode Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : LegendDisplayMode Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property LegendDisplayMode As ChartSeriesLegendDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As ChartSeriesLegendDisplayMode

instance.LegendDisplayMode = value

value = instance.LegendDisplayMode
C#
public ChartSeriesLegendDisplayMode LegendDisplayMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


LineSeriesAppearance Property

LineSeriesAppearance Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : LineSeriesAppearance Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineSeriesAppearance As StyleLineSeries
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As StyleLineSeries

value = instance.LineSeriesAppearance
C#
public StyleLineSeries LineSeriesAppearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


PointDimentions Property

PointDimentions Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : PointDimentions Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property PointDimentions As DimensionsPointMarker
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As DimensionsPointMarker

instance.PointDimentions = value

value = instance.PointDimentions
C#
public DimensionsPointMarker PointDimentions {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


PointMark Property

PointMark Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : PointMark Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PointMark As StyleMarkerSeriesPoint
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As StyleMarkerSeriesPoint

value = instance.PointMark
C#
public StyleMarkerSeriesPoint PointMark {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


PointRotationAngle Property

PointRotationAngle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : PointRotationAngle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PointRotationAngle As Single
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Single

instance.PointRotationAngle = value

value = instance.PointRotationAngle
C#
public virtual float PointRotationAngle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


PointShape Property

PointShape Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : PointShape Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property PointShape As String
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As String

instance.PointShape = value

value = instance.PointShape
C#
public string PointShape {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


ShowLabelConnectors Property

ShowLabelConnectors Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : ShowLabelConnectors Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowLabelConnectors As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Boolean

instance.ShowLabelConnectors = value

value = instance.ShowLabelConnectors
C#
public bool ShowLabelConnectors {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


ShowLabels Property

ShowLabels Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : ShowLabels Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowLabels As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Boolean

instance.ShowLabels = value

value = instance.ShowLabels
C#
public bool ShowLabels {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


StartAngle Property

StartAngle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : StartAngle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property StartAngle As Double
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Double

instance.StartAngle = value

value = instance.StartAngle
C#
public double StartAngle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


TextAppearance Property

TextAppearance Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : TextAppearance Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TextAppearance As StyleSeriesItemTextBlock
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As StyleSeriesItemTextBlock

value = instance.TextAppearance
C#
public StyleSeriesItemTextBlock TextAppearance {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeries Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleSeries
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeries Class
StyleSeries Members


StyleSeriesBorder Class

StyleSeriesBorder Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesBorder Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleSeriesBorder
   Inherits StyleBorder
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesBorder
C#
public class StyleSeriesBorder : StyleBorder, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.StyleSeriesBorder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesBorder Class Members

StyleSeriesBorder Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesBorder Class

The following tables list the members exposed by StyleSeriesBorder.

Public Constructors

 | Name | Description
Public Constructor | StyleSeriesBorder Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | PenStyle | Overridden.
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleBorder)
Public Method | Equals | (Inherited from StyleBorder)
Public Method | GetHashCode | (Inherited from StyleBorder)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleSeriesBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesBorder Constructor

StyleSeriesBorder Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesBorder Class : StyleSeriesBorder Constructor

Overload List

Overload | Description
StyleSeriesBorder Constructor() |
StyleSeriesBorder Constructor(ChartSeries) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesBorder Class
StyleSeriesBorder Members


StyleSeriesBorder Constructor()

StyleSeriesBorder Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesBorder Class > StyleSeriesBorder Constructor : StyleSeriesBorder Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesBorder()
C#
public StyleSeriesBorder()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesBorder()
C#
public StyleSeriesBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesBorder Class
StyleSeriesBorder Members
Overload List


StyleSeriesBorder Constructor(ChartSeries)

StyleSeriesBorder Constructor(ChartSeries)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesBorder Class > StyleSeriesBorder Constructor : StyleSeriesBorder Constructor(ChartSeries)

series

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As StyleSeriesBorder(series)
C#
public StyleSeriesBorder(
   ChartSeries series
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As StyleSeriesBorder(series)
C#
public StyleSeriesBorder(
   ChartSeries series
)

Parameters

series

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesBorder Class
StyleSeriesBorder Members
Overload List


StyleSeriesBorder Class Properties

StyleSeriesBorder Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesBorder Class

For a list of all members of this type, see StyleSeriesBorder members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | PenStyle | Overridden.
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleSeriesBorder Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesBorder Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesBorder
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesBorder Class
StyleSeriesBorder Members


PenStyle Property

PenStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesBorder Class : PenStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property PenStyle As DashStyle
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesBorder
Dim value As DashStyle

instance.PenStyle = value

value = instance.PenStyle
C#
public override DashStyle PenStyle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesBorder Class
StyleSeriesBorder Members


StyleSeriesItem Class

StyleSeriesItem Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItem Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleSeriesItem
   Inherits Style
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem
C#
public class StyleSeriesItem : Style, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.StyleSeriesItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItem Class Members

StyleSeriesItem Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItem Class

The following tables list the members exposed by StyleSeriesItem.

Public Constructors

 | Name | Description
Public Constructor | StyleSeriesItem Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners |
Public Property | Exploded |
Public Property | FillStyle |
Public Property | PointDimentions |
Public Property | PointRotationAngle |
Public Property | PointShape |
Public Property | Shadow | Overridden.
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItem Constructor

StyleSeriesItem Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class : StyleSeriesItem Constructor

Overload List

Overload | Description
StyleSeriesItem Constructor() |
StyleSeriesItem Constructor(ChartSeries) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members


StyleSeriesItem Constructor()

StyleSeriesItem Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class > StyleSeriesItem Constructor : StyleSeriesItem Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem()
C#
public StyleSeriesItem()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem()
C#
public StyleSeriesItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members
Overload List


StyleSeriesItem Constructor(ChartSeries)

StyleSeriesItem Constructor(ChartSeries)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class > StyleSeriesItem Constructor : StyleSeriesItem Constructor(ChartSeries)

series

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As StyleSeriesItem(series)
C#
public StyleSeriesItem(
   ChartSeries series
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As StyleSeriesItem(series)
C#
public StyleSeriesItem(
   ChartSeries series
)

Parameters

series

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members
Overload List


StyleSeriesItem Class Methods

StyleSeriesItem Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItem Class

For a list of all members of this type, see StyleSeriesItem members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members


StyleSeriesItem Class Properties

StyleSeriesItem Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItem Class

For a list of all members of this type, see StyleSeriesItem members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | Corners |
Public Property | Exploded |
Public Property | FillStyle |
Public Property | PointDimentions |
Public Property | PointRotationAngle |
Public Property | PointShape |
Public Property | Shadow | Overridden.
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


Corners Property

Corners Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class : Corners Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Corners As Corners
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem
Dim value As Corners

instance.Corners = value

value = instance.Corners
C#
public Corners Corners {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members


Exploded Property

Exploded Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class : Exploded Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Exploded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem
Dim value As Boolean

instance.Exploded = value

value = instance.Exploded
C#
public bool Exploded {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members


FillStyle Property

FillStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class : FillStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStyleSeries
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem
Dim value As FillStyleSeries

value = instance.FillStyle
C#
public FillStyleSeries FillStyle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members


PointDimentions Property

PointDimentions Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class : PointDimentions Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property PointDimentions As DimensionsPointMarker
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem
Dim value As DimensionsPointMarker

instance.PointDimentions = value

value = instance.PointDimentions
C#
public DimensionsPointMarker PointDimentions {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members


PointRotationAngle Property

PointRotationAngle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class : PointRotationAngle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PointRotationAngle As Single
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem
Dim value As Single

instance.PointRotationAngle = value

value = instance.PointRotationAngle
C#
public virtual float PointRotationAngle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members


PointShape Property

PointShape Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class : PointShape Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property PointShape As String
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem
Dim value As String

instance.PointShape = value

value = instance.PointShape
C#
public string PointShape {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members


Shadow Property

Shadow Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItem Class : Shadow Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Shadow As ShadowStyle
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItem
Dim value As ShadowStyle

value = instance.Shadow
C#
public override ShadowStyle Shadow {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItem Class
StyleSeriesItem Members


StyleSeriesItemLabel Class

StyleSeriesItemLabel Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItemLabel Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleSeriesItemLabel
   Inherits StyleLabel
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemLabel
C#
public class StyleSeriesItemLabel : StyleLabel, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleLabel
Telerik.Reporting.Charting.Styles.StyleSeriesItemLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemLabel Class Members

StyleSeriesItemLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItemLabel Class

The following tables list the members exposed by StyleSeriesItemLabel.

Public Constructors

 | Name | Description
Public Constructor | StyleSeriesItemLabel Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Distance |
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | LabelConnectorStyle |
Public Property | LabelLocation |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemLabel Constructor

StyleSeriesItemLabel Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemLabel Class : StyleSeriesItemLabel Constructor

Overload List

Overload | Description
StyleSeriesItemLabel Constructor() |
StyleSeriesItemLabel Constructor(ChartSeries) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemLabel Class
StyleSeriesItemLabel Members


StyleSeriesItemLabel Constructor()

StyleSeriesItemLabel Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemLabel Class > StyleSeriesItemLabel Constructor : StyleSeriesItemLabel Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemLabel()
C#
public StyleSeriesItemLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemLabel()
C#
public StyleSeriesItemLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemLabel Class
StyleSeriesItemLabel Members
Overload List


StyleSeriesItemLabel Constructor(ChartSeries)

StyleSeriesItemLabel Constructor(ChartSeries)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemLabel Class > StyleSeriesItemLabel Constructor : StyleSeriesItemLabel Constructor(ChartSeries)

series

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As StyleSeriesItemLabel(series)
C#
public StyleSeriesItemLabel(
   ChartSeries series
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As StyleSeriesItemLabel(series)
C#
public StyleSeriesItemLabel(
   ChartSeries series
)

Parameters

series

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemLabel Class
StyleSeriesItemLabel Members
Overload List


StyleSeriesItemLabel Class Methods

StyleSeriesItemLabel Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItemLabel Class

For a list of all members of this type, see StyleSeriesItemLabel members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | Overridden.
Protected Method | SaveViewState | Overridden.
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemLabel Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemLabel
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemLabel Class
StyleSeriesItemLabel Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemLabel Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemLabel
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemLabel Class
StyleSeriesItemLabel Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemLabel Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemLabel
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemLabel Class
StyleSeriesItemLabel Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemLabel Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemLabel

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemLabel Class
StyleSeriesItemLabel Members


StyleSeriesItemLabel Class Properties

StyleSeriesItemLabel Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItemLabel Class

For a list of all members of this type, see StyleSeriesItemLabel members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Distance |
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | LabelConnectorStyle |
Public Property | LabelLocation |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


Distance Property

Distance Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemLabel Class : Distance Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Distance As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemLabel
Dim value As Integer

instance.Distance = value

value = instance.Distance
C#
public int Distance {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemLabel Class
StyleSeriesItemLabel Members


LabelConnectorStyle Property

LabelConnectorStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemLabel Class : LabelConnectorStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LabelConnectorStyle As LineStyle
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemLabel
Dim value As LineStyle

value = instance.LabelConnectorStyle
C#
public LineStyle LabelConnectorStyle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemLabel Class
StyleSeriesItemLabel Members


LabelLocation Property

LabelLocation Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemLabel Class : LabelLocation Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelLocation As StyleSeriesItemLabel.ItemLabelLocation
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemLabel
Dim value As StyleSeriesItemLabel.ItemLabelLocation

instance.LabelLocation = value

value = instance.LabelLocation
C#
public StyleSeriesItemLabel.ItemLabelLocation LabelLocation {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemLabel Class
StyleSeriesItemLabel Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemLabel Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemLabel
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemLabel Class
StyleSeriesItemLabel Members


StyleSeriesItemTextBlock Class

StyleSeriesItemTextBlock Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItemTextBlock Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleSeriesItemTextBlock
   Inherits StyleTextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemTextBlock
C#
public class StyleSeriesItemTextBlock : StyleTextBlock, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleTextBlock
Telerik.Reporting.Charting.Styles.StyleSeriesItemTextBlock

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemTextBlock Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemTextBlock Class Members

StyleSeriesItemTextBlock Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItemTextBlock Class

The following tables list the members exposed by StyleSeriesItemTextBlock.

Public Constructors

 | Name | Description
Public Constructor | StyleSeriesItemTextBlock Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockOverflow | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockRotationAngle | (Inherited from StyleTextBlock)
Top

Public Properties

 | Name | Description
Public Property | AutoTextWrap | Overridden.
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleTextBlock)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleTextBlock)
Public Property | FillStyle | (Inherited from StyleTextBlock)
Public Property | MaxLength | (Inherited from StyleTextBlock)
Public Property | Overflow | (Inherited from StyleTextBlock)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties | (Inherited from StyleTextBlock)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleTextBlock)
Public Method | Dispose | Overloaded. (Inherited from StyleTextBlock)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleTextBlock)
Protected Method | LoadViewState | (Inherited from StyleTextBlock)
Protected Method | ResetMaxLength | Overridden.
Protected Method | SaveViewState | (Inherited from StyleTextBlock)
Protected Method | ShouldSerializeMaxLength | Overridden.
Protected Method | TrackViewState | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleSeriesItemTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemTextBlock Constructor

StyleSeriesItemTextBlock Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemTextBlock Class : StyleSeriesItemTextBlock Constructor

Overload List

Overload | Description
StyleSeriesItemTextBlock Constructor() |
StyleSeriesItemTextBlock Constructor(ChartSeries) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemTextBlock Class
StyleSeriesItemTextBlock Members


StyleSeriesItemTextBlock Constructor()

StyleSeriesItemTextBlock Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemTextBlock Class > StyleSeriesItemTextBlock Constructor : StyleSeriesItemTextBlock Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemTextBlock()
C#
public StyleSeriesItemTextBlock()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemTextBlock()
C#
public StyleSeriesItemTextBlock()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemTextBlock Class
StyleSeriesItemTextBlock Members
Overload List


StyleSeriesItemTextBlock Constructor(ChartSeries)

StyleSeriesItemTextBlock Constructor(ChartSeries)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemTextBlock Class > StyleSeriesItemTextBlock Constructor : StyleSeriesItemTextBlock Constructor(ChartSeries)

series

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As StyleSeriesItemTextBlock(series)
C#
public StyleSeriesItemTextBlock(
   ChartSeries series
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal series As ChartSeries _
)
Visual Basic (Usage) Copy Code
Dim series As ChartSeries

Dim instance As StyleSeriesItemTextBlock(series)
C#
public StyleSeriesItemTextBlock(
   ChartSeries series
)

Parameters

series

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemTextBlock Class
StyleSeriesItemTextBlock Members
Overload List


StyleSeriesItemTextBlock Class Methods

StyleSeriesItemTextBlock Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItemTextBlock Class

For a list of all members of this type, see StyleSeriesItemTextBlock members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleTextBlock)
Public Method | Dispose | Overloaded. (Inherited from StyleTextBlock)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleTextBlock)
Protected Method | LoadViewState | (Inherited from StyleTextBlock)
Protected Method | ResetMaxLength | Overridden.
Protected Method | SaveViewState | (Inherited from StyleTextBlock)
Protected Method | ShouldSerializeMaxLength | Overridden.
Protected Method | TrackViewState | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleSeriesItemTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


ResetMaxLength Method

ResetMaxLength Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemTextBlock Class : ResetMaxLength Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ResetMaxLength()
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemTextBlock

instance.ResetMaxLength()
C#
protected override void ResetMaxLength()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemTextBlock Class
StyleSeriesItemTextBlock Members


ShouldSerializeMaxLength Method

ShouldSerializeMaxLength Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemTextBlock Class : ShouldSerializeMaxLength Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function ShouldSerializeMaxLength() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemTextBlock
Dim value As Boolean

value = instance.ShouldSerializeMaxLength()
C#
protected override bool ShouldSerializeMaxLength()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemTextBlock Class
StyleSeriesItemTextBlock Members


StyleSeriesItemTextBlock Class Properties

StyleSeriesItemTextBlock Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItemTextBlock Class

For a list of all members of this type, see StyleSeriesItemTextBlock members.

Public Properties

 | Name | Description
Public Property | AutoTextWrap | Overridden.
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleTextBlock)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleTextBlock)
Public Property | FillStyle | (Inherited from StyleTextBlock)
Public Property | MaxLength | (Inherited from StyleTextBlock)
Public Property | Overflow | (Inherited from StyleTextBlock)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties | (Inherited from StyleTextBlock)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleSeriesItemTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


AutoTextWrap Property

AutoTextWrap Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleSeriesItemTextBlock Class : AutoTextWrap Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property AutoTextWrap As AutoTextWrap
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemTextBlock
Dim value As AutoTextWrap

value = instance.AutoTextWrap
C#
public override AutoTextWrap AutoTextWrap {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSeriesItemTextBlock Class
StyleSeriesItemTextBlock Members


StyleTextBlock Class

StyleTextBlock Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlock Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleTextBlock
   Inherits LayoutStyle
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
C#
public class StyleTextBlock : LayoutStyle, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleTextBlock
Telerik.Reporting.Charting.Styles.StyleAxisItemText
Telerik.Reporting.Charting.Styles.StyleSeriesItemTextBlock
Telerik.Reporting.Charting.Styles.StyleTextBlockAxisLabel
Telerik.Reporting.Charting.Styles.StyleTextBlockError
Telerik.Reporting.Charting.Styles.StyleTextBlockHidden
Telerik.Reporting.Charting.Styles.StyleTextBlockTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Class Members

StyleTextBlock Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlock Class

The following tables list the members exposed by StyleTextBlock.

Public Constructors

 | Name | Description
Public Constructor | StyleTextBlock Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners |
Protected Field | styleTextBlockOverflow |
Protected Field | styleTextBlockRotationAngle |
Top

Public Properties

 | Name | Description
Public Property | AutoTextWrap |
Public Property | Border | (Inherited from Style)
Public Property | Corners |
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure |
Public Property | FillStyle |
Public Property | MaxLength |
Public Property | Overflow |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties |
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Dispose | Overloaded.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | ResetMaxLength |
Protected Method | SaveViewState | Overridden.
Protected Method | ShouldSerializeMaxLength |
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Constructor

StyleTextBlock Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : StyleTextBlock Constructor

Overload List

Overload | Description
StyleTextBlock Constructor() |
StyleTextBlock Constructor(Dimensions,FillStyle,Position,Single,TextProperties,Corners,StyleBorder,ShadowStyle,Boolean) |
StyleTextBlock Constructor(FillStyle) |
StyleTextBlock Constructor(FillStyle,Position) |
StyleTextBlock Constructor(FillStyle,Position,TextProperties) |
StyleTextBlock Constructor(FillStyle,Position,TextProperties,Dimensions) |
StyleTextBlock Constructor(FillStyle,TextProperties) |
StyleTextBlock Constructor(TextProperties) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


StyleTextBlock Constructor()

StyleTextBlock Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class > StyleTextBlock Constructor : StyleTextBlock Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock()
C#
public StyleTextBlock()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock()
C#
public StyleTextBlock()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members
Overload List


StyleTextBlock Constructor(Dimensions,FillStyle,Position,Single,TextProperties,Corners,StyleBorder,ShadowStyle,Boolean)

StyleTextBlock Constructor(Dimensions,FillStyle,Position,Single,TextProperties,Corners,StyleBorder,ShadowStyle,Boolean)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class > StyleTextBlock Constructor : StyleTextBlock Constructor(Dimensions,FillStyle,Position,Single,TextProperties,Corners,StyleBorder,ShadowStyle,Boolean)

dimensions
fillStyle
position
rotationAngle
textProperties
corners
border
shadowStyle
visible

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dimensions As Dimensions, _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal rotationAngle As Single, _
   ByVal textProperties As TextProperties, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim dimensions As Dimensions
Dim fillStyle As FillStyle
Dim position As Position
Dim rotationAngle As Single
Dim textProperties As TextProperties
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleTextBlock(dimensions, fillStyle, position, rotationAngle, textProperties, corners, border, shadowStyle, visible)
C#
public StyleTextBlock(
   Dimensions dimensions,
   FillStyle fillStyle,
   Position position,
   float rotationAngle,
   TextProperties textProperties,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dimensions As Dimensions, _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal rotationAngle As Single, _
   ByVal textProperties As TextProperties, _
   ByVal corners As Corners, _
   ByVal border As StyleBorder, _
   ByVal shadowStyle As ShadowStyle, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim dimensions As Dimensions
Dim fillStyle As FillStyle
Dim position As Position
Dim rotationAngle As Single
Dim textProperties As TextProperties
Dim corners As Corners
Dim border As StyleBorder
Dim shadowStyle As ShadowStyle
Dim visible As Boolean

Dim instance As StyleTextBlock(dimensions, fillStyle, position, rotationAngle, textProperties, corners, border, shadowStyle, visible)
C#
public StyleTextBlock(
   Dimensions dimensions,
   FillStyle fillStyle,
   Position position,
   float rotationAngle,
   TextProperties textProperties,
   Corners corners,
   StyleBorder border,
   ShadowStyle shadowStyle,
   bool visible
)

Parameters

dimensions
fillStyle
position
rotationAngle
textProperties
corners
border
shadowStyle
visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members
Overload List


StyleTextBlock Constructor(FillStyle)

StyleTextBlock Constructor(FillStyle)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class > StyleTextBlock Constructor : StyleTextBlock Constructor(FillStyle)

fillStyle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle

Dim instance As StyleTextBlock(fillStyle)
C#
public StyleTextBlock(
   FillStyle fillStyle
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle

Dim instance As StyleTextBlock(fillStyle)
C#
public StyleTextBlock(
   FillStyle fillStyle
)

Parameters

fillStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members
Overload List


StyleTextBlock Constructor(FillStyle,Position)

StyleTextBlock Constructor(FillStyle,Position)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class > StyleTextBlock Constructor : StyleTextBlock Constructor(FillStyle,Position)

fillStyle
position

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position

Dim instance As StyleTextBlock(fillStyle, position)
C#
public StyleTextBlock(
   FillStyle fillStyle,
   Position position
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position

Dim instance As StyleTextBlock(fillStyle, position)
C#
public StyleTextBlock(
   FillStyle fillStyle,
   Position position
)

Parameters

fillStyle
position

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members
Overload List


StyleTextBlock Constructor(FillStyle,Position,TextProperties)

StyleTextBlock Constructor(FillStyle,Position,TextProperties)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class > StyleTextBlock Constructor : StyleTextBlock Constructor(FillStyle,Position,TextProperties)

fillStyle
position
textProperties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal textProperties As TextProperties _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position
Dim textProperties As TextProperties

Dim instance As StyleTextBlock(fillStyle, position, textProperties)
C#
public StyleTextBlock(
   FillStyle fillStyle,
   Position position,
   TextProperties textProperties
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal textProperties As TextProperties _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position
Dim textProperties As TextProperties

Dim instance As StyleTextBlock(fillStyle, position, textProperties)
C#
public StyleTextBlock(
   FillStyle fillStyle,
   Position position,
   TextProperties textProperties
)

Parameters

fillStyle
position
textProperties

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members
Overload List


StyleTextBlock Constructor(FillStyle,Position,TextProperties,Dimensions)

StyleTextBlock Constructor(FillStyle,Position,TextProperties,Dimensions)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class > StyleTextBlock Constructor : StyleTextBlock Constructor(FillStyle,Position,TextProperties,Dimensions)

fillStyle
position
textProperties
dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal textProperties As TextProperties, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position
Dim textProperties As TextProperties
Dim dimensions As Dimensions

Dim instance As StyleTextBlock(fillStyle, position, textProperties, dimensions)
C#
public StyleTextBlock(
   FillStyle fillStyle,
   Position position,
   TextProperties textProperties,
   Dimensions dimensions
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal position As Position, _
   ByVal textProperties As TextProperties, _
   ByVal dimensions As Dimensions _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim position As Position
Dim textProperties As TextProperties
Dim dimensions As Dimensions

Dim instance As StyleTextBlock(fillStyle, position, textProperties, dimensions)
C#
public StyleTextBlock(
   FillStyle fillStyle,
   Position position,
   TextProperties textProperties,
   Dimensions dimensions
)

Parameters

fillStyle
position
textProperties
dimensions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members
Overload List


StyleTextBlock Constructor(FillStyle,TextProperties)

StyleTextBlock Constructor(FillStyle,TextProperties)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class > StyleTextBlock Constructor : StyleTextBlock Constructor(FillStyle,TextProperties)

fillStyle
textProperties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal textProperties As TextProperties _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim textProperties As TextProperties

Dim instance As StyleTextBlock(fillStyle, textProperties)
C#
public StyleTextBlock(
   FillStyle fillStyle,
   TextProperties textProperties
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fillStyle As FillStyle, _
   ByVal textProperties As TextProperties _
)
Visual Basic (Usage) Copy Code
Dim fillStyle As FillStyle
Dim textProperties As TextProperties

Dim instance As StyleTextBlock(fillStyle, textProperties)
C#
public StyleTextBlock(
   FillStyle fillStyle,
   TextProperties textProperties
)

Parameters

fillStyle
textProperties

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members
Overload List


StyleTextBlock Constructor(TextProperties)

StyleTextBlock Constructor(TextProperties)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class > StyleTextBlock Constructor : StyleTextBlock Constructor(TextProperties)

textProperties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal textProperties As TextProperties _
)
Visual Basic (Usage) Copy Code
Dim textProperties As TextProperties

Dim instance As StyleTextBlock(textProperties)
C#
public StyleTextBlock(
   TextProperties textProperties
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal textProperties As TextProperties _
)
Visual Basic (Usage) Copy Code
Dim textProperties As TextProperties

Dim instance As StyleTextBlock(textProperties)
C#
public StyleTextBlock(
   TextProperties textProperties
)

Parameters

textProperties

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members
Overload List


StyleTextBlock Class Methods

StyleTextBlock Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlock Class

For a list of all members of this type, see StyleTextBlock members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Dispose | Overloaded.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | Overridden.
Protected Method | ResetMaxLength |
Protected Method | SaveViewState | Overridden.
Protected Method | ShouldSerializeMaxLength |
Protected Method | TrackViewState | Overridden.
Top

See Also

Reference

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim value As Object

value = instance.Clone()
C#
public override object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : Dispose Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members
Overload List


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : Finalize Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


LoadViewState Method

LoadViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : LoadViewState Method

savedState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


ResetMaxLength Method

ResetMaxLength Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : ResetMaxLength Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ResetMaxLength()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock

instance.ResetMaxLength()
C#
protected virtual void ResetMaxLength()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


SaveViewState Method

SaveViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : SaveViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


ShouldSerializeMaxLength Method

ShouldSerializeMaxLength Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : ShouldSerializeMaxLength Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeMaxLength() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim value As Boolean

value = instance.ShouldSerializeMaxLength()
C#
protected virtual bool ShouldSerializeMaxLength()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


TrackViewState Method

TrackViewState Method
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : TrackViewState Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock

instance.TrackViewState()
C#
protected override void TrackViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


StyleTextBlock Class Properties

StyleTextBlock Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlock Class

For a list of all members of this type, see StyleTextBlock members.

Public Properties

 | Name | Description
Public Property | AutoTextWrap |
Public Property | Border | (Inherited from Style)
Public Property | Corners |
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure |
Public Property | FillStyle |
Public Property | MaxLength |
Public Property | Overflow |
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties |
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


AutoTextWrap Property

AutoTextWrap Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : AutoTextWrap Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoTextWrap As AutoTextWrap
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim value As AutoTextWrap

instance.AutoTextWrap = value

value = instance.AutoTextWrap
C#
public virtual AutoTextWrap AutoTextWrap {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


Corners Property

Corners Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : Corners Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Corners As Corners
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim value As Corners

instance.Corners = value

value = instance.Corners
C#
public Corners Corners {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


Figure Property

Figure Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : Figure Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Figure As String
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim value As String

value = instance.Figure
C#
public string Figure {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


FillStyle Property

FillStyle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : FillStyle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property FillStyle As FillStyle
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim value As FillStyle

value = instance.FillStyle
C#
public virtual FillStyle FillStyle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


MaxLength Property

MaxLength Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : MaxLength Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim value As Integer

instance.MaxLength = value

value = instance.MaxLength
C#
public int MaxLength {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


Overflow Property

Overflow Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : Overflow Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Overflow As Overflow
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim value As Overflow

instance.Overflow = value

value = instance.Overflow
C#
public virtual Overflow Overflow {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


TextProperties Property

TextProperties Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : TextProperties Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TextProperties As TextProperties
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim value As TextProperties

value = instance.TextProperties
C#
public virtual TextProperties TextProperties {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


StyleTextBlock Class Fields

StyleTextBlock Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlock Class

For a list of all members of this type, see StyleTextBlock members.

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners |
Protected Field | styleTextBlockOverflow |
Protected Field | styleTextBlockRotationAngle |
Top

See Also

Reference

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


styleTextBlockCorners Field

styleTextBlockCorners Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : styleTextBlockCorners Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleTextBlockCorners As Corners
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim value As Corners

value = instance.styleTextBlockCorners

instance.styleTextBlockCorners = value
C#
protected Corners styleTextBlockCorners

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


styleTextBlockOverflow Field

styleTextBlockOverflow Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : styleTextBlockOverflow Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleTextBlockOverflow As Overflow
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim value As Overflow

value = instance.styleTextBlockOverflow

instance.styleTextBlockOverflow = value
C#
protected Overflow styleTextBlockOverflow

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


styleTextBlockRotationAngle Field

styleTextBlockRotationAngle Field
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlock Class : styleTextBlockRotationAngle Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected styleTextBlockRotationAngle As Single
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlock
Dim value As Single

value = instance.styleTextBlockRotationAngle

instance.styleTextBlockRotationAngle = value
C#
protected float styleTextBlockRotationAngle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlock Class
StyleTextBlock Members


StyleTextBlockAxisLabel Class

StyleTextBlockAxisLabel Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockAxisLabel Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleTextBlockAxisLabel
   Inherits StyleTextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlockAxisLabel
C#
public class StyleTextBlockAxisLabel : StyleTextBlock, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleTextBlock
Telerik.Reporting.Charting.Styles.StyleTextBlockAxisLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlockAxisLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockAxisLabel Class Members

StyleTextBlockAxisLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockAxisLabel Class

The following tables list the members exposed by StyleTextBlockAxisLabel.

Public Constructors

 | Name | Description
Public Constructor | StyleTextBlockAxisLabel Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockOverflow | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockRotationAngle | (Inherited from StyleTextBlock)
Top

Public Properties

 | Name | Description
Public Property | AutoTextWrap | (Inherited from StyleTextBlock)
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleTextBlock)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleTextBlock)
Public Property | FillStyle | (Inherited from StyleTextBlock)
Public Property | MaxLength | (Inherited from StyleTextBlock)
Public Property | Overflow | (Inherited from StyleTextBlock)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties | (Inherited from StyleTextBlock)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleTextBlock)
Public Method | Dispose | Overloaded. (Inherited from StyleTextBlock)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleTextBlock)
Protected Method | LoadViewState | (Inherited from StyleTextBlock)
Protected Method | ResetMaxLength | (Inherited from StyleTextBlock)
Protected Method | SaveViewState | (Inherited from StyleTextBlock)
Protected Method | ShouldSerializeMaxLength | (Inherited from StyleTextBlock)
Protected Method | TrackViewState | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleTextBlockAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockAxisLabel Constructor

StyleTextBlockAxisLabel Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlockAxisLabel Class : StyleTextBlockAxisLabel Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlockAxisLabel()
C#
public StyleTextBlockAxisLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlockAxisLabel()
C#
public StyleTextBlockAxisLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlockAxisLabel Class
StyleTextBlockAxisLabel Members


StyleTextBlockError Class

StyleTextBlockError Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockError Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleTextBlockError
   Inherits StyleTextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlockError
C#
public class StyleTextBlockError : StyleTextBlock, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleTextBlock
Telerik.Reporting.Charting.Styles.StyleTextBlockError

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlockError Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockError Class Members

StyleTextBlockError Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockError Class

The following tables list the members exposed by StyleTextBlockError.

Public Constructors

 | Name | Description
Public Constructor | StyleTextBlockError Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockOverflow | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockRotationAngle | (Inherited from StyleTextBlock)
Top

Public Properties

 | Name | Description
Public Property | AutoTextWrap | (Inherited from StyleTextBlock)
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleTextBlock)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleTextBlock)
Public Property | FillStyle | (Inherited from StyleTextBlock)
Public Property | MaxLength | (Inherited from StyleTextBlock)
Public Property | Overflow | (Inherited from StyleTextBlock)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties | (Inherited from StyleTextBlock)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleTextBlock)
Public Method | Dispose | Overloaded. (Inherited from StyleTextBlock)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleTextBlock)
Protected Method | LoadViewState | (Inherited from StyleTextBlock)
Protected Method | ResetMaxLength | (Inherited from StyleTextBlock)
Protected Method | SaveViewState | (Inherited from StyleTextBlock)
Protected Method | ShouldSerializeMaxLength | (Inherited from StyleTextBlock)
Protected Method | TrackViewState | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleTextBlockError Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockError Constructor

StyleTextBlockError Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlockError Class : StyleTextBlockError Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlockError()
C#
public StyleTextBlockError()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlockError()
C#
public StyleTextBlockError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlockError Class
StyleTextBlockError Members


StyleTextBlockHidden Class

StyleTextBlockHidden Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockHidden Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleTextBlockHidden
   Inherits StyleTextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlockHidden
C#
public class StyleTextBlockHidden : StyleTextBlock, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleTextBlock
Telerik.Reporting.Charting.Styles.StyleTextBlockHidden

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlockHidden Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockHidden Class Members

StyleTextBlockHidden Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockHidden Class

The following tables list the members exposed by StyleTextBlockHidden.

Public Constructors

 | Name | Description
Public Constructor | StyleTextBlockHidden Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockOverflow | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockRotationAngle | (Inherited from StyleTextBlock)
Top

Public Properties

 | Name | Description
Public Property | AutoTextWrap | (Inherited from StyleTextBlock)
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleTextBlock)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleTextBlock)
Public Property | FillStyle | (Inherited from StyleTextBlock)
Public Property | MaxLength | (Inherited from StyleTextBlock)
Public Property | Overflow | (Inherited from StyleTextBlock)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties | (Inherited from StyleTextBlock)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleTextBlock)
Public Method | Dispose | Overloaded. (Inherited from StyleTextBlock)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleTextBlock)
Protected Method | LoadViewState | (Inherited from StyleTextBlock)
Protected Method | ResetMaxLength | (Inherited from StyleTextBlock)
Protected Method | SaveViewState | (Inherited from StyleTextBlock)
Protected Method | ShouldSerializeMaxLength | (Inherited from StyleTextBlock)
Protected Method | TrackViewState | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleTextBlockHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockHidden Constructor

StyleTextBlockHidden Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlockHidden Class : StyleTextBlockHidden Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlockHidden()
C#
public StyleTextBlockHidden()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlockHidden()
C#
public StyleTextBlockHidden()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlockHidden Class
StyleTextBlockHidden Members


StyleTextBlockHidden Class Properties

StyleTextBlockHidden Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockHidden Class

For a list of all members of this type, see StyleTextBlockHidden members.

Public Properties

 | Name | Description
Public Property | AutoTextWrap | (Inherited from StyleTextBlock)
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleTextBlock)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleTextBlock)
Public Property | FillStyle | (Inherited from StyleTextBlock)
Public Property | MaxLength | (Inherited from StyleTextBlock)
Public Property | Overflow | (Inherited from StyleTextBlock)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties | (Inherited from StyleTextBlock)
Public Property | Visible | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTextBlockHidden Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

Visible Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlockHidden Class : Visible Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlockHidden
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public override bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlockHidden Class
StyleTextBlockHidden Members


StyleTextBlockTitle Class

StyleTextBlockTitle Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockTitle Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleTextBlockTitle
   Inherits StyleTextBlock
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlockTitle
C#
public class StyleTextBlockTitle : StyleTextBlock, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleTextBlock
Telerik.Reporting.Charting.Styles.StyleTextBlockTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlockTitle Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockTitle Class Members

StyleTextBlockTitle Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockTitle Class

The following tables list the members exposed by StyleTextBlockTitle.

Public Constructors

 | Name | Description
Public Constructor | StyleTextBlockTitle Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockOverflow | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockRotationAngle | (Inherited from StyleTextBlock)
Top

Public Properties

 | Name | Description
Public Property | AutoTextWrap | (Inherited from StyleTextBlock)
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleTextBlock)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleTextBlock)
Public Property | FillStyle | (Inherited from StyleTextBlock)
Public Property | MaxLength | (Inherited from StyleTextBlock)
Public Property | Overflow | (Inherited from StyleTextBlock)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties | (Inherited from StyleTextBlock)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleTextBlock)
Public Method | Dispose | Overloaded. (Inherited from StyleTextBlock)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleTextBlock)
Protected Method | LoadViewState | (Inherited from StyleTextBlock)
Protected Method | ResetMaxLength | (Inherited from StyleTextBlock)
Protected Method | SaveViewState | (Inherited from StyleTextBlock)
Protected Method | ShouldSerializeMaxLength | (Inherited from StyleTextBlock)
Protected Method | TrackViewState | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleTextBlockTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockTitle Constructor

StyleTextBlockTitle Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTextBlockTitle Class : StyleTextBlockTitle Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlockTitle()
C#
public StyleTextBlockTitle()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTextBlockTitle()
C#
public StyleTextBlockTitle()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTextBlockTitle Class
StyleTextBlockTitle Members


StyleTick Class

StyleTick Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTick Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleTick
   Inherits LineStyle
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleTick
C#
public class StyleTick : LineStyle, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleTick
Telerik.Reporting.Charting.Styles.StyleTickMajor
Telerik.Reporting.Charting.Styles.StyleTickMinor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTick Members
Telerik.Reporting.Charting.Styles Namespace


StyleTick Class Members

StyleTick Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTick Class

The following tables list the members exposed by StyleTick.

Public Constructors

 | Name | Description
Public Constructor | StyleTick Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | EndCap | (Inherited from LineStyle)
Public Property | Length |
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTick Class
Telerik.Reporting.Charting.Styles Namespace


StyleTick Constructor

StyleTick Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTick Class : StyleTick Constructor

Overload List

Overload | Description
StyleTick Constructor() |
StyleTick Constructor(Boolean,Int32,Color) |
StyleTick Constructor(Int32) |
StyleTick Constructor(Int32,Boolean) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTick Class
StyleTick Members


StyleTick Constructor()

StyleTick Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTick Class > StyleTick Constructor : StyleTick Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTick()
C#
public StyleTick()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTick()
C#
public StyleTick()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTick Class
StyleTick Members
Overload List


StyleTick Constructor(Boolean,Int32,Color)

StyleTick Constructor(Boolean,Int32,Color)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTick Class > StyleTick Constructor : StyleTick Constructor(Boolean,Int32,Color)

visible
length
color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visible As Boolean, _
   ByVal length As Integer, _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim visible As Boolean
Dim length As Integer
Dim color As Color

Dim instance As StyleTick(visible, length, color)
C#
public StyleTick(
   bool visible,
   int length,
   Color color
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visible As Boolean, _
   ByVal length As Integer, _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim visible As Boolean
Dim length As Integer
Dim color As Color

Dim instance As StyleTick(visible, length, color)
C#
public StyleTick(
   bool visible,
   int length,
   Color color
)

Parameters

visible
length
color

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTick Class
StyleTick Members
Overload List


StyleTick Constructor(Int32)

StyleTick Constructor(Int32)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTick Class > StyleTick Constructor : StyleTick Constructor(Int32)

length

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim length As Integer

Dim instance As StyleTick(length)
C#
public StyleTick(
   int length
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim length As Integer

Dim instance As StyleTick(length)
C#
public StyleTick(
   int length
)

Parameters

length

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTick Class
StyleTick Members
Overload List


StyleTick Constructor(Int32,Boolean)

StyleTick Constructor(Int32,Boolean)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTick Class > StyleTick Constructor : StyleTick Constructor(Int32,Boolean)

length
visible

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal length As Integer, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim length As Integer
Dim visible As Boolean

Dim instance As StyleTick(length, visible)
C#
public StyleTick(
   int length,
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal length As Integer, _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim length As Integer
Dim visible As Boolean

Dim instance As StyleTick(length, visible)
C#
public StyleTick(
   int length,
   bool visible
)

Parameters

length
visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTick Class
StyleTick Members
Overload List


StyleTick Class Properties

StyleTick Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTick Class

For a list of all members of this type, see StyleTick members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | EndCap | (Inherited from LineStyle)
Public Property | Length |
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTick Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTick Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As StyleTick
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTick Class
StyleTick Members


Length Property

Length Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTick Class : Length Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Length As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleTick
Dim value As Integer

instance.Length = value

value = instance.Length
C#
public virtual int Length {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTick Class
StyleTick Members


Width Property

Width Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTick Class : Width Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As StyleTick
Dim value As Single

instance.Width = value

value = instance.Width
C#
public override float Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTick Class
StyleTick Members


StyleTickMajor Class

StyleTickMajor Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTickMajor Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleTickMajor
   Inherits StyleTick
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleTickMajor
C#
public class StyleTickMajor : StyleTick, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleTick
Telerik.Reporting.Charting.Styles.StyleTickMajor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTickMajor Members
Telerik.Reporting.Charting.Styles Namespace


StyleTickMajor Class Members

StyleTickMajor Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTickMajor Class

The following tables list the members exposed by StyleTickMajor.

Public Constructors

 | Name | Description
Public Constructor | StyleTickMajor Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleTick)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | Length | (Inherited from StyleTick)
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleTick)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTickMajor Class
Telerik.Reporting.Charting.Styles Namespace


StyleTickMajor Constructor

StyleTickMajor Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTickMajor Class : StyleTickMajor Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTickMajor()
C#
public StyleTickMajor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTickMajor()
C#
public StyleTickMajor()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTickMajor Class
StyleTickMajor Members


StyleTickMinor Class

StyleTickMinor Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTickMinor Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleTickMinor
   Inherits StyleTick
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleTickMinor
C#
public class StyleTickMinor : StyleTick, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.StyleTick
Telerik.Reporting.Charting.Styles.StyleTickMinor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTickMinor Members
Telerik.Reporting.Charting.Styles Namespace


StyleTickMinor Class Members

StyleTickMinor Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTickMinor Class

The following tables list the members exposed by StyleTickMinor.

Public Constructors

 | Name | Description
Public Constructor | StyleTickMinor Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleTick)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | Length | Overridden.
Public Property | MinorTickCount |
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleTick)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTickMinor Class
Telerik.Reporting.Charting.Styles Namespace


StyleTickMinor Constructor

StyleTickMinor Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTickMinor Class : StyleTickMinor Constructor

Overload List

Overload | Description
StyleTickMinor Constructor() |
StyleTickMinor Constructor(Boolean) |
StyleTickMinor Constructor(Boolean,Int32,MinorTickCount) |
StyleTickMinor Constructor(MinorTickCount) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTickMinor Class
StyleTickMinor Members


StyleTickMinor Constructor()

StyleTickMinor Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTickMinor Class > StyleTickMinor Constructor : StyleTickMinor Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTickMinor()
C#
public StyleTickMinor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTickMinor()
C#
public StyleTickMinor()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTickMinor Class
StyleTickMinor Members
Overload List


StyleTickMinor Constructor(Boolean)

StyleTickMinor Constructor(Boolean)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTickMinor Class > StyleTickMinor Constructor : StyleTickMinor Constructor(Boolean)

visible

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim visible As Boolean

Dim instance As StyleTickMinor(visible)
C#
public StyleTickMinor(
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim visible As Boolean

Dim instance As StyleTickMinor(visible)
C#
public StyleTickMinor(
   bool visible
)

Parameters

visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTickMinor Class
StyleTickMinor Members
Overload List


StyleTickMinor Constructor(Boolean,Int32,MinorTickCount)

StyleTickMinor Constructor(Boolean,Int32,MinorTickCount)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTickMinor Class > StyleTickMinor Constructor : StyleTickMinor Constructor(Boolean,Int32,MinorTickCount)

visible
length
count

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visible As Boolean, _
   ByVal length As Integer, _
   ByVal count As MinorTickCount _
)
Visual Basic (Usage) Copy Code
Dim visible As Boolean
Dim length As Integer
Dim count As MinorTickCount

Dim instance As StyleTickMinor(visible, length, count)
C#
public StyleTickMinor(
   bool visible,
   int length,
   MinorTickCount count
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visible As Boolean, _
   ByVal length As Integer, _
   ByVal count As MinorTickCount _
)
Visual Basic (Usage) Copy Code
Dim visible As Boolean
Dim length As Integer
Dim count As MinorTickCount

Dim instance As StyleTickMinor(visible, length, count)
C#
public StyleTickMinor(
   bool visible,
   int length,
   MinorTickCount count
)

Parameters

visible
length
count

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTickMinor Class
StyleTickMinor Members
Overload List


StyleTickMinor Constructor(MinorTickCount)

StyleTickMinor Constructor(MinorTickCount)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTickMinor Class > StyleTickMinor Constructor : StyleTickMinor Constructor(MinorTickCount)

count

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal count As MinorTickCount _
)
Visual Basic (Usage) Copy Code
Dim count As MinorTickCount

Dim instance As StyleTickMinor(count)
C#
public StyleTickMinor(
   MinorTickCount count
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal count As MinorTickCount _
)
Visual Basic (Usage) Copy Code
Dim count As MinorTickCount

Dim instance As StyleTickMinor(count)
C#
public StyleTickMinor(
   MinorTickCount count
)

Parameters

count

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTickMinor Class
StyleTickMinor Members
Overload List


StyleTickMinor Class Properties

StyleTickMinor Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTickMinor Class

For a list of all members of this type, see StyleTickMinor members.

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleTick)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | Length | Overridden.
Public Property | MinorTickCount |
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleTick)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTickMinor Class
Telerik.Reporting.Charting.Styles Namespace


Length Property

Length Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTickMinor Class : Length Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Length As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleTickMinor
Dim value As Integer

instance.Length = value

value = instance.Length
C#
public override int Length {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTickMinor Class
StyleTickMinor Members


MinorTickCount Property

MinorTickCount Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTickMinor Class : MinorTickCount Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property MinorTickCount As MinorTickCount
Visual Basic (Usage) Copy Code
Dim instance As StyleTickMinor
Dim value As MinorTickCount

instance.MinorTickCount = value

value = instance.MinorTickCount
C#
public MinorTickCount MinorTickCount {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTickMinor Class
StyleTickMinor Members


StyleTitleBorder Class

StyleTitleBorder Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTitleBorder Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleTitleBorder
   Inherits StyleBorder
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As StyleTitleBorder
C#
public class StyleTitleBorder : StyleBorder, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.StyleTitleBorder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTitleBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleTitleBorder Class Members

StyleTitleBorder Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTitleBorder Class

The following tables list the members exposed by StyleTitleBorder.

Public Constructors

 | Name | Description
Public Constructor | StyleTitleBorder Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleBorder)
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleBorder)
Public Method | Equals | (Inherited from StyleBorder)
Public Method | GetHashCode | (Inherited from StyleBorder)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTitleBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleTitleBorder Constructor

StyleTitleBorder Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleTitleBorder Class : StyleTitleBorder Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTitleBorder()
C#
public StyleTitleBorder()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleTitleBorder()
C#
public StyleTitleBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleTitleBorder Class
StyleTitleBorder Members


StyleYAxisLabel Class

StyleYAxisLabel Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleYAxisLabel Class

Object Model

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleYAxisLabel
   Inherits StyleAxisLabel
   Implements IChartingStateManagedItem, IChartingStateManager, IPosition
Visual Basic (Usage) Copy Code
Dim instance As StyleYAxisLabel
C#
public class StyleYAxisLabel : StyleAxisLabel, IChartingStateManagedItem, IChartingStateManager, IPosition

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleLabel
Telerik.Reporting.Charting.Styles.StyleLabelHidden
Telerik.Reporting.Charting.Styles.StyleAxisLabel
Telerik.Reporting.Charting.Styles.StyleYAxisLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleYAxisLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleYAxisLabel Class Members

StyleYAxisLabel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleYAxisLabel Class

The following tables list the members exposed by StyleYAxisLabel.

Public Constructors

 | Name | Description
Public Constructor | StyleYAxisLabel Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | Overridden.
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from StyleLabelHidden)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleLabel)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleLabel)
Protected Method | SaveViewState | (Inherited from StyleLabel)
Protected Method | TrackViewState | (Inherited from StyleLabel)
Top

See Also

Reference

StyleYAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleYAxisLabel Constructor

StyleYAxisLabel Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleYAxisLabel Class : StyleYAxisLabel Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleYAxisLabel()
C#
public StyleYAxisLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleYAxisLabel()
C#
public StyleYAxisLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleYAxisLabel Class
StyleYAxisLabel Members


StyleYAxisLabel Class Properties

StyleYAxisLabel Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleYAxisLabel Class

For a list of all members of this type, see StyleYAxisLabel members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | Overridden.
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from StyleLabelHidden)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleYAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


RotationAngle Property

RotationAngle Property
[image]
Telerik.Reporting.Charting.Styles Namespace > StyleYAxisLabel Class : RotationAngle Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property RotationAngle As Single
Visual Basic (Usage) Copy Code
Dim instance As StyleYAxisLabel
Dim value As Single

instance.RotationAngle = value

value = instance.RotationAngle
C#
public override float RotationAngle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleYAxisLabel Class
StyleYAxisLabel Members


TextProperties Class

TextProperties Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : TextProperties Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextProperties
   Inherits StateManagedObject
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As TextProperties
C#
public class TextProperties : StateManagedObject, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.TextProperties
Telerik.Reporting.Charting.Styles.TextPropertiesAxisItem
Telerik.Reporting.Charting.Styles.TextPropertiesAxisLabel
Telerik.Reporting.Charting.Styles.TextPropertiesError
Telerik.Reporting.Charting.Styles.TextPropertiesSeriesItem
Telerik.Reporting.Charting.Styles.TextPropertiesTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Members
Telerik.Reporting.Charting.Styles Namespace


TextProperties Class Members

TextProperties Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : TextProperties Class

The following tables list the members exposed by TextProperties.

Public Constructors

 | Name | Description
Public Constructor | TextProperties Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Color |
Public Property | Font |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Dispose | Overloaded.
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextProperties Class
Telerik.Reporting.Charting.Styles Namespace


TextProperties Constructor

TextProperties Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class : TextProperties Constructor

Overload List

Overload | Description
TextProperties Constructor() |
TextProperties Constructor(Color) |
TextProperties Constructor(Color,Font) |
TextProperties Constructor(Color,String,Single,FontStyle,GraphicsUnit) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members


TextProperties Constructor()

TextProperties Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class > TextProperties Constructor : TextProperties Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextProperties()
C#
public TextProperties()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextProperties()
C#
public TextProperties()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members
Overload List


TextProperties Constructor(Color)

TextProperties Constructor(Color)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class > TextProperties Constructor : TextProperties Constructor(Color)

color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim color As Color

Dim instance As TextProperties(color)
C#
public TextProperties(
   Color color
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim color As Color

Dim instance As TextProperties(color)
C#
public TextProperties(
   Color color
)

Parameters

color

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members
Overload List


TextProperties Constructor(Color,Font)

TextProperties Constructor(Color,Font)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class > TextProperties Constructor : TextProperties Constructor(Color,Font)

color
font

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal font As Font _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim font As Font

Dim instance As TextProperties(color, font)
C#
public TextProperties(
   Color color,
   Font font
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal font As Font _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim font As Font

Dim instance As TextProperties(color, font)
C#
public TextProperties(
   Color color,
   Font font
)

Parameters

color
font

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members
Overload List


TextProperties Constructor(Color,String,Single,FontStyle,GraphicsUnit)

TextProperties Constructor(Color,String,Single,FontStyle,GraphicsUnit)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class > TextProperties Constructor : TextProperties Constructor(Color,String,Single,FontStyle,GraphicsUnit)

color
familyName
emSize
fontStyle
grUnit

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal fontStyle As FontStyle, _
   ByVal grUnit As GraphicsUnit _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim familyName As String
Dim emSize As Single
Dim fontStyle As FontStyle
Dim grUnit As GraphicsUnit

Dim instance As TextProperties(color, familyName, emSize, fontStyle, grUnit)
C#
public TextProperties(
   Color color,
   string familyName,
   float emSize,
   FontStyle fontStyle,
   GraphicsUnit grUnit
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color, _
   ByVal familyName As String, _
   ByVal emSize As Single, _
   ByVal fontStyle As FontStyle, _
   ByVal grUnit As GraphicsUnit _
)
Visual Basic (Usage) Copy Code
Dim color As Color
Dim familyName As String
Dim emSize As Single
Dim fontStyle As FontStyle
Dim grUnit As GraphicsUnit

Dim instance As TextProperties(color, familyName, emSize, fontStyle, grUnit)
C#
public TextProperties(
   Color color,
   string familyName,
   float emSize,
   FontStyle fontStyle,
   GraphicsUnit grUnit
)

Parameters

color
familyName
emSize
fontStyle
grUnit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members
Overload List


TextProperties Class Methods

TextProperties Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : TextProperties Class

For a list of all members of this type, see TextProperties members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | Dispose | Overloaded.
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | Overridden.
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextProperties Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class : Clone Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As TextProperties
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members


Dispose Method

Dispose Method
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class : Dispose Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members


Dispose() Method

Dispose() Method
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As TextProperties

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As TextProperties
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members
Overload List


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextProperties
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members


Finalize Method

Finalize Method
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class : Finalize Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As TextProperties

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As TextProperties
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members


TextProperties Class Properties

TextProperties Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : TextProperties Class

For a list of all members of this type, see TextProperties members.

Public Properties

 | Name | Description
Public Property | Color |
Public Property | Font |
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextProperties Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As TextProperties
Dim value As Color

instance.Color = value

value = instance.Color
C#
public virtual Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members


Font Property

Font Property
[image]
Telerik.Reporting.Charting.Styles Namespace > TextProperties Class : Font Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As TextProperties
Dim value As Font

instance.Font = value

value = instance.Font
C#
public virtual Font Font {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextProperties Class
TextProperties Members


TextPropertiesAxisItem Class

TextPropertiesAxisItem Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesAxisItem Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextPropertiesAxisItem
   Inherits TextProperties
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesAxisItem
C#
public class TextPropertiesAxisItem : TextProperties, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.TextProperties
Telerik.Reporting.Charting.Styles.TextPropertiesAxisItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesAxisItem Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisItem Class Members

TextPropertiesAxisItem Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesAxisItem Class

The following tables list the members exposed by TextPropertiesAxisItem.

Public Constructors

 | Name | Description
Public Constructor | TextPropertiesAxisItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | Font | (Inherited from TextProperties)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from TextProperties)
Public Method | Dispose | Overloaded. (Inherited from TextProperties)
Public Method | Equals | (Inherited from TextProperties)
Public Method | GetHashCode | (Inherited from TextProperties)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from TextProperties)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesAxisItem Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisItem Constructor

TextPropertiesAxisItem Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > TextPropertiesAxisItem Class : TextPropertiesAxisItem Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesAxisItem()
C#
public TextPropertiesAxisItem()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesAxisItem()
C#
public TextPropertiesAxisItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesAxisItem Class
TextPropertiesAxisItem Members


TextPropertiesAxisItem Class Properties

TextPropertiesAxisItem Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesAxisItem Class

For a list of all members of this type, see TextPropertiesAxisItem members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | Font | (Inherited from TextProperties)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesAxisItem Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > TextPropertiesAxisItem Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesAxisItem
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesAxisItem Class
TextPropertiesAxisItem Members


TextPropertiesAxisLabel Class

TextPropertiesAxisLabel Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesAxisLabel Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextPropertiesAxisLabel
   Inherits TextProperties
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesAxisLabel
C#
public class TextPropertiesAxisLabel : TextProperties, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.TextProperties
Telerik.Reporting.Charting.Styles.TextPropertiesAxisLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesAxisLabel Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisLabel Class Members

TextPropertiesAxisLabel Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesAxisLabel Class

The following tables list the members exposed by TextPropertiesAxisLabel.

Public Constructors

 | Name | Description
Public Constructor | TextPropertiesAxisLabel Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | Font | (Inherited from TextProperties)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from TextProperties)
Public Method | Dispose | Overloaded. (Inherited from TextProperties)
Public Method | Equals | (Inherited from TextProperties)
Public Method | GetHashCode | (Inherited from TextProperties)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from TextProperties)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisLabel Constructor

TextPropertiesAxisLabel Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > TextPropertiesAxisLabel Class : TextPropertiesAxisLabel Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesAxisLabel()
C#
public TextPropertiesAxisLabel()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesAxisLabel()
C#
public TextPropertiesAxisLabel()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesAxisLabel Class
TextPropertiesAxisLabel Members


TextPropertiesAxisLabel Class Properties

TextPropertiesAxisLabel Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesAxisLabel Class

For a list of all members of this type, see TextPropertiesAxisLabel members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | Font | (Inherited from TextProperties)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > TextPropertiesAxisLabel Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesAxisLabel
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesAxisLabel Class
TextPropertiesAxisLabel Members


TextPropertiesError Class

TextPropertiesError Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesError Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextPropertiesError
   Inherits TextProperties
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesError
C#
public class TextPropertiesError : TextProperties, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.TextProperties
Telerik.Reporting.Charting.Styles.TextPropertiesError

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesError Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesError Class Members

TextPropertiesError Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesError Class

The following tables list the members exposed by TextPropertiesError.

Public Constructors

 | Name | Description
Public Constructor | TextPropertiesError Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | Font | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from TextProperties)
Public Method | Dispose | Overloaded. (Inherited from TextProperties)
Public Method | Equals | (Inherited from TextProperties)
Public Method | GetHashCode | (Inherited from TextProperties)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from TextProperties)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesError Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesError Constructor

TextPropertiesError Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > TextPropertiesError Class : TextPropertiesError Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesError()
C#
public TextPropertiesError()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesError()
C#
public TextPropertiesError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesError Class
TextPropertiesError Members


TextPropertiesError Class Properties

TextPropertiesError Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesError Class

For a list of all members of this type, see TextPropertiesError members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | Font | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesError Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > TextPropertiesError Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesError
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesError Class
TextPropertiesError Members


Font Property

Font Property
[image]
Telerik.Reporting.Charting.Styles Namespace > TextPropertiesError Class : Font Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesError
Dim value As Font

instance.Font = value

value = instance.Font
C#
public override Font Font {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesError Class
TextPropertiesError Members


TextPropertiesSeriesItem Class

TextPropertiesSeriesItem Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesSeriesItem Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextPropertiesSeriesItem
   Inherits TextProperties
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesSeriesItem
C#
public class TextPropertiesSeriesItem : TextProperties, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.TextProperties
Telerik.Reporting.Charting.Styles.TextPropertiesSeriesItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesSeriesItem Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesSeriesItem Class Members

TextPropertiesSeriesItem Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesSeriesItem Class

The following tables list the members exposed by TextPropertiesSeriesItem.

Public Constructors

 | Name | Description
Public Constructor | TextPropertiesSeriesItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | Font | (Inherited from TextProperties)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from TextProperties)
Public Method | Dispose | Overloaded. (Inherited from TextProperties)
Public Method | Equals | (Inherited from TextProperties)
Public Method | GetHashCode | (Inherited from TextProperties)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from TextProperties)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesSeriesItem Constructor

TextPropertiesSeriesItem Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > TextPropertiesSeriesItem Class : TextPropertiesSeriesItem Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesSeriesItem()
C#
public TextPropertiesSeriesItem()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesSeriesItem()
C#
public TextPropertiesSeriesItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesSeriesItem Class
TextPropertiesSeriesItem Members


TextPropertiesSeriesItem Class Properties

TextPropertiesSeriesItem Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesSeriesItem Class

For a list of all members of this type, see TextPropertiesSeriesItem members.

Public Properties

 | Name | Description
Public Property | Color | Overridden.
Public Property | Font | (Inherited from TextProperties)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

Color Property
[image]
Telerik.Reporting.Charting.Styles Namespace > TextPropertiesSeriesItem Class : Color Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesSeriesItem
Dim value As Color

instance.Color = value

value = instance.Color
C#
public override Color Color {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesSeriesItem Class
TextPropertiesSeriesItem Members


TextPropertiesTitle Class

TextPropertiesTitle Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesTitle Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TextPropertiesTitle
   Inherits TextProperties
   Implements IChartingStateManagedItem, IChartingStateManager
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesTitle
C#
public class TextPropertiesTitle : TextProperties, IChartingStateManagedItem, IChartingStateManager

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.TextProperties
Telerik.Reporting.Charting.Styles.TextPropertiesTitle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesTitle Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesTitle Class Members

TextPropertiesTitle Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesTitle Class

The following tables list the members exposed by TextPropertiesTitle.

Public Constructors

 | Name | Description
Public Constructor | TextPropertiesTitle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | (Inherited from TextProperties)
Public Property | Font | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from TextProperties)
Public Method | Dispose | Overloaded. (Inherited from TextProperties)
Public Method | Equals | (Inherited from TextProperties)
Public Method | GetHashCode | (Inherited from TextProperties)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from TextProperties)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesTitle Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesTitle Constructor

TextPropertiesTitle Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > TextPropertiesTitle Class : TextPropertiesTitle Constructor

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesTitle()
C#
public TextPropertiesTitle()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesTitle()
C#
public TextPropertiesTitle()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesTitle Class
TextPropertiesTitle Members


TextPropertiesTitle Class Properties

TextPropertiesTitle Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesTitle Class

For a list of all members of this type, see TextPropertiesTitle members.

Public Properties

 | Name | Description
Public Property | Color | (Inherited from TextProperties)
Public Property | Font | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesTitle Class
Telerik.Reporting.Charting.Styles Namespace


Font Property

Font Property
[image]
Telerik.Reporting.Charting.Styles Namespace > TextPropertiesTitle Class : Font Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As TextPropertiesTitle
Dim value As Font

instance.Font = value

value = instance.Font
C#
public override Font Font {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextPropertiesTitle Class
TextPropertiesTitle Members


Unit Class

Unit Class
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : Unit Class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Unit
Visual Basic (Usage) Copy Code
Dim instance As Unit
C#
public class Unit

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.Styles.Unit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Members
Telerik.Reporting.Charting.Styles Namespace


Unit Class Members

Unit Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : Unit Class

The following tables list the members exposed by Unit.

Public Constructors

 | Name | Description
Public Constructor | Unit Constructor | Overloaded.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty |
Top

Public Properties

 | Name | Description
Public Property | IsEmpty |
Public Property | Type |
Public Property | Value |
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
static (Shared in Visual Basic) | Parse | Overloaded.
static (Shared in Visual Basic) | Percentage |
static (Shared in Visual Basic) | Pixel |
Public Method | ToString | Overloaded. Overridden.
Top

Public Operators

Public Operator Equality
Public Operator Implicit Type Conversion
Public Operator Inequality
Top

See Also

Reference

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Unit Constructor

Unit Constructor
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : Unit Constructor

Overload List

Overload | Description
Unit Constructor() |
Unit Constructor(Double) |
Unit Constructor(Double,UnitType) |
Unit Constructor(Int32) |
Unit Constructor(Int32,UnitType) |
Unit Constructor(Single) |
Unit Constructor(Single,UnitType) |
Unit Constructor(String) |
Unit Constructor(String,CultureInfo) |
Unit Constructor(UnitType) |

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


Unit Constructor()

Unit Constructor()
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > Unit Constructor : Unit Constructor()

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Unit()
C#
public Unit()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Unit()
C#
public Unit()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


Unit Constructor(Double)

Unit Constructor(Double)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > Unit Constructor : Unit Constructor(Double)

value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim value As Double

Dim instance As Unit(value)
C#
public Unit(
   double value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim value As Double

Dim instance As Unit(value)
C#
public Unit(
   double value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


Unit Constructor(Double,UnitType)

Unit Constructor(Double,UnitType)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > Unit Constructor : Unit Constructor(Double,UnitType)

value
type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double, _
   ByVal type As UnitType _
)
Visual Basic (Usage) Copy Code
Dim value As Double
Dim type As UnitType

Dim instance As Unit(value, type)
C#
public Unit(
   double value,
   UnitType type
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double, _
   ByVal type As UnitType _
)
Visual Basic (Usage) Copy Code
Dim value As Double
Dim type As UnitType

Dim instance As Unit(value, type)
C#
public Unit(
   double value,
   UnitType type
)

Parameters

value
type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


Unit Constructor(Int32)

Unit Constructor(Int32)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > Unit Constructor : Unit Constructor(Int32)

value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim value As Integer

Dim instance As Unit(value)
C#
public Unit(
   int value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim value As Integer

Dim instance As Unit(value)
C#
public Unit(
   int value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


Unit Constructor(Int32,UnitType)

Unit Constructor(Int32,UnitType)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > Unit Constructor : Unit Constructor(Int32,UnitType)

value
type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Integer, _
   ByVal type As UnitType _
)
Visual Basic (Usage) Copy Code
Dim value As Integer
Dim type As UnitType

Dim instance As Unit(value, type)
C#
public Unit(
   int value,
   UnitType type
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Integer, _
   ByVal type As UnitType _
)
Visual Basic (Usage) Copy Code
Dim value As Integer
Dim type As UnitType

Dim instance As Unit(value, type)
C#
public Unit(
   int value,
   UnitType type
)

Parameters

value
type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


Unit Constructor(Single)

Unit Constructor(Single)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > Unit Constructor : Unit Constructor(Single)

value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Single _
)
Visual Basic (Usage) Copy Code
Dim value As Single

Dim instance As Unit(value)
C#
public Unit(
   float value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Single _
)
Visual Basic (Usage) Copy Code
Dim value As Single

Dim instance As Unit(value)
C#
public Unit(
   float value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


Unit Constructor(Single,UnitType)

Unit Constructor(Single,UnitType)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > Unit Constructor : Unit Constructor(Single,UnitType)

value
type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Single, _
   ByVal type As UnitType _
)
Visual Basic (Usage) Copy Code
Dim value As Single
Dim type As UnitType

Dim instance As Unit(value, type)
C#
public Unit(
   float value,
   UnitType type
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Single, _
   ByVal type As UnitType _
)
Visual Basic (Usage) Copy Code
Dim value As Single
Dim type As UnitType

Dim instance As Unit(value, type)
C#
public Unit(
   float value,
   UnitType type
)

Parameters

value
type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


Unit Constructor(String)

Unit Constructor(String)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > Unit Constructor : Unit Constructor(String)

value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As Unit(value)
C#
public Unit(
   string value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As Unit(value)
C#
public Unit(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


Unit Constructor(String,CultureInfo)

Unit Constructor(String,CultureInfo)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > Unit Constructor : Unit Constructor(String,CultureInfo)

value
culture

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal culture As CultureInfo _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim culture As CultureInfo

Dim instance As Unit(value, culture)
C#
public Unit(
   string value,
   CultureInfo culture
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal culture As CultureInfo _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim culture As CultureInfo

Dim instance As Unit(value, culture)
C#
public Unit(
   string value,
   CultureInfo culture
)

Parameters

value
culture

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


Unit Constructor(UnitType)

Unit Constructor(UnitType)
See Also
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > Unit Constructor : Unit Constructor(UnitType)

type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As UnitType _
)
Visual Basic (Usage) Copy Code
Dim type As UnitType

Dim instance As Unit(type)
C#
public Unit(
   UnitType type
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As UnitType _
)
Visual Basic (Usage) Copy Code
Dim type As UnitType

Dim instance As Unit(type)
C#
public Unit(
   UnitType type
)

Parameters

type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


Unit Class Methods

Unit Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : Unit Class

For a list of all members of this type, see Unit members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
static (Shared in Visual Basic) | Parse | Overloaded.
static (Shared in Visual Basic) | Percentage |
static (Shared in Visual Basic) | Pixel |
Public Method | ToString | Overloaded. Overridden.
Top

See Also

Reference

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Equals Method

Equals Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : Equals Method

obj

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : GetHashCode Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


Parse Method

Parse Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : Parse Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Parse(String) |
Parse(String,CultureInfo) |

Overload List

Overload | Description
Parse(String) |
Parse(String,CultureInfo) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


Parse(String) Method

Parse(String) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > Parse Method : Parse(String) Method

s

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Parse( _
   ByVal s As String _
) As Unit
Visual Basic (Usage) Copy Code
Dim s As String
Dim value As Unit

value = Unit.Parse(s)
C#
public static Unit Parse(
   string s
)

Parameters

s

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


Parse(String,CultureInfo) Method

Parse(String,CultureInfo) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > Parse Method : Parse(String,CultureInfo) Method

s
culture

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Parse( _
   ByVal s As String, _
   ByVal culture As CultureInfo _
) As Unit
Visual Basic (Usage) Copy Code
Dim s As String
Dim culture As CultureInfo
Dim value As Unit

value = Unit.Parse(s, culture)
C#
public static Unit Parse(
   string s,
   CultureInfo culture
)

Parameters

s
culture

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


Percentage Method

Percentage Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : Percentage Method

n

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Percentage( _
   ByVal n As Double _
) As Unit
Visual Basic (Usage) Copy Code
Dim n As Double
Dim value As Unit

value = Unit.Percentage(n)
C#
public static Unit Percentage(
   double n
)

Parameters

n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


Pixel Method

Pixel Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : Pixel Method

n

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Pixel( _
   ByVal n As Single _
) As Unit
Visual Basic (Usage) Copy Code
Dim n As Single
Dim value As Unit

value = Unit.Pixel(n)
C#
public static Unit Pixel(
   float n
)

Parameters

n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : ToString Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ToString() |
ToString(CultureInfo) |

Overload List

Overload | Description
ToString() |
ToString(CultureInfo) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


ToString() Method

ToString() Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > ToString Method : ToString() Method

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


ToString(CultureInfo) Method

ToString(CultureInfo) Method
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class > ToString Method : ToString(CultureInfo) Method

culture

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function ToString( _
   ByVal culture As CultureInfo _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim culture As CultureInfo
Dim value As String

value = instance.ToString(culture)
C#
public string ToString(
   CultureInfo culture
)

Parameters

culture

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members
Overload List


Unit Class Properties

Unit Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : Unit Class

For a list of all members of this type, see Unit members.

Public Properties

 | Name | Description
Public Property | IsEmpty |
Public Property | Type |
Public Property | Value |
Top

See Also

Reference

Unit Class
Telerik.Reporting.Charting.Styles Namespace


IsEmpty Property

IsEmpty Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : IsEmpty Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim value As Boolean

value = instance.IsEmpty
C#
public bool IsEmpty {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


Type Property

Type Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : Type Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As UnitType
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim value As UnitType

instance.Type = value

value = instance.Type
C#
public UnitType Type {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


Value Property

Value Property
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : Value Property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim value As Single

instance.Value = value

value = instance.Value
C#
public float Value {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


Unit Class Fields

Unit Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : Unit Class

For a list of all members of this type, see Unit members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty |
Top

See Also

Reference

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Empty Field

Empty Field
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : Empty Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Unit
Visual Basic (Usage) Copy Code
Dim value As Unit

value = Unit.Empty
C#
public static readonly Unit Empty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


Equality Operator

Equality Operator
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : Equality Operator

left
right

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal left As Unit, _
   ByVal right As Unit _
) As Boolean
C#
public bool operator ==(
   Unit left,
   Unit right
)

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal left As Unit, _
   ByVal right As Unit _
) As Boolean
C#
public bool operator ==(
   Unit left,
   Unit right
)

Parameters

left
right

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


Implicit Type Conversion Operator

Implicit Type Conversion Operator
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : Implicit Type Conversion Operator

n

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal n As Single _
) As Unit
C#
public Unit operator implicit(
   float n
)

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal n As Single _
) As Unit
C#
public Unit operator implicit(
   float n
)

Parameters

n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


Inequality Operator

Inequality Operator
[image]
Telerik.Reporting.Charting.Styles Namespace > Unit Class : Inequality Operator

left
right

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal left As Unit, _
   ByVal right As Unit _
) As Boolean
C#
public bool operator !=(
   Unit left,
   Unit right
)

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal left As Unit, _
   ByVal right As Unit _
) As Boolean
C#
public bool operator !=(
   Unit left,
   Unit right
)

Parameters

left
right

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Class
Unit Members


DefaultFigures Structure

DefaultFigures Structure
See Also Members
[image]
Telerik.Reporting.Charting.Styles Namespace : DefaultFigures Structure

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Structure DefaultFigures
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As DefaultFigures
C#
public struct DefaultFigures : ValueType

Syntax

Visual Basic (Declaration)
Public Structure DefaultFigures
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As DefaultFigures
C#
public struct DefaultFigures : ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Telerik.Reporting.Charting.Styles.DefaultFigures

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Members
Telerik.Reporting.Charting.Styles Namespace


DefaultFigures Structure Members

DefaultFigures Structure Members
See Also Fields Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DefaultFigures Structure

The following tables list the members exposed by DefaultFigures.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Circle |
static (Shared in Visual Basic) | Cross |
static (Shared in Visual Basic) | Diamond |
static (Shared in Visual Basic) | Ellipse |
static (Shared in Visual Basic) | FiguresList |
static (Shared in Visual Basic) | Rectangle |
static (Shared in Visual Basic) | Star3 |
static (Shared in Visual Basic) | Star4 |
static (Shared in Visual Basic) | Star5 |
static (Shared in Visual Basic) | Star6 |
static (Shared in Visual Basic) | Star7 |
static (Shared in Visual Basic) | Triangle |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Contains |
Public Method | Equals | (Inherited from System.ValueType)
Public Method | GetHashCode | (Inherited from System.ValueType)
Public Method | ToString | (Inherited from System.ValueType)
Top

See Also

Reference

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


DefaultFigures Structure Methods

DefaultFigures Structure Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DefaultFigures Structure

For a list of all members of this type, see DefaultFigures members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Contains |
Public Method | Equals | (Inherited from System.ValueType)
Public Method | GetHashCode | (Inherited from System.ValueType)
Public Method | ToString | (Inherited from System.ValueType)
Top

See Also

Reference

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Contains Method

Contains Method
[image]
Telerik.Reporting.Charting.Styles Namespace > DefaultFigures Structure : Contains Method

name

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Contains( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As Boolean

value = DefaultFigures.Contains(name)
C#
public static bool Contains(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Structure
DefaultFigures Members


DefaultFigures Structure Fields

DefaultFigures Structure Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : DefaultFigures Structure

For a list of all members of this type, see DefaultFigures members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Circle |
static (Shared in Visual Basic) | Cross |
static (Shared in Visual Basic) | Diamond |
static (Shared in Visual Basic) | Ellipse |
static (Shared in Visual Basic) | FiguresList |
static (Shared in Visual Basic) | Rectangle |
static (Shared in Visual Basic) | Star3 |
static (Shared in Visual Basic) | Star4 |
static (Shared in Visual Basic) | Star5 |
static (Shared in Visual Basic) | Star6 |
static (Shared in Visual Basic) | Star7 |
static (Shared in Visual Basic) | Triangle |
Top

See Also

Reference

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Circle Field

Circle Field
[image]
Telerik.Reporting.Charting.Styles Namespace > DefaultFigures Structure : Circle Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Circle As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DefaultFigures.Circle

DefaultFigures.Circle = value
C#
public static string Circle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Structure
DefaultFigures Members


Cross Field

Cross Field
[image]
Telerik.Reporting.Charting.Styles Namespace > DefaultFigures Structure : Cross Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Cross As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DefaultFigures.Cross

DefaultFigures.Cross = value
C#
public static string Cross

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Structure
DefaultFigures Members


Diamond Field

Diamond Field
[image]
Telerik.Reporting.Charting.Styles Namespace > DefaultFigures Structure : Diamond Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Diamond As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DefaultFigures.Diamond

DefaultFigures.Diamond = value
C#
public static string Diamond

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Structure
DefaultFigures Members


Ellipse Field

Ellipse Field
[image]
Telerik.Reporting.Charting.Styles Namespace > DefaultFigures Structure : Ellipse Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Ellipse As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DefaultFigures.Ellipse

DefaultFigures.Ellipse = value
C#
public static string Ellipse

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Structure
DefaultFigures Members


FiguresList Field

FiguresList Field
[image]
Telerik.Reporting.Charting.Styles Namespace > DefaultFigures Structure : FiguresList Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared FiguresList As List(Of String)
Visual Basic (Usage) Copy Code
Dim value As List(Of String)

value = DefaultFigures.FiguresList

DefaultFigures.FiguresList = value
C#
public static List<string> FiguresList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Structure
DefaultFigures Members


Rectangle Field

Rectangle Field
[image]
Telerik.Reporting.Charting.Styles Namespace > DefaultFigures Structure : Rectangle Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Rectangle As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DefaultFigures.Rectangle

DefaultFigures.Rectangle = value
C#
public static string Rectangle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Structure
DefaultFigures Members


Star3 Field

Star3 Field
[image]
Telerik.Reporting.Charting.Styles Namespace > DefaultFigures Structure : Star3 Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Star3 As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DefaultFigures.Star3

DefaultFigures.Star3 = value
C#
public static string Star3

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Structure
DefaultFigures Members


Star4 Field

Star4 Field
[image]
Telerik.Reporting.Charting.Styles Namespace > DefaultFigures Structure : Star4 Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Star4 As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DefaultFigures.Star4

DefaultFigures.Star4 = value
C#
public static string Star4

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Structure
DefaultFigures Members


Star5 Field

Star5 Field
[image]
Telerik.Reporting.Charting.Styles Namespace > DefaultFigures Structure : Star5 Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Star5 As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DefaultFigures.Star5

DefaultFigures.Star5 = value
C#
public static string Star5

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Structure
DefaultFigures Members


Star6 Field

Star6 Field
[image]
Telerik.Reporting.Charting.Styles Namespace > DefaultFigures Structure : Star6 Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Star6 As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DefaultFigures.Star6

DefaultFigures.Star6 = value
C#
public static string Star6

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Structure
DefaultFigures Members


Star7 Field

Star7 Field
[image]
Telerik.Reporting.Charting.Styles Namespace > DefaultFigures Structure : Star7 Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Star7 As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DefaultFigures.Star7

DefaultFigures.Star7 = value
C#
public static string Star7

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Structure
DefaultFigures Members


Triangle Field

Triangle Field
[image]
Telerik.Reporting.Charting.Styles Namespace > DefaultFigures Structure : Triangle Field

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Triangle As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DefaultFigures.Triangle

DefaultFigures.Triangle = value
C#
public static string Triangle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DefaultFigures Structure
DefaultFigures Members


Filter Class

Filter Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : Filter Class

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Filter
Visual Basic (Usage) Copy Code
Dim instance As Filter
C#
public class Filter

Inheritance Hierarchy

System.Object
Telerik.Reporting.Data.Filter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Filter Members
Telerik.Reporting.Data Namespace


Filter Class Members

Filter Class Members
See Also Properties Methods Events
[image]
Telerik.Reporting.Data Namespace : Filter Class

The following tables list the members exposed by Filter.

Public Constructors

 | Name | Description
Public Constructor | Filter Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Expression |
Public Property | IsEmpty |
Public Property | Operator |
Public Property | Value | If the Value starts with the equal (=) sign, it will be evaluated as an expression otherwise - as string value. For ex. if the value is 7 it is interpreted as the string "7"; To compare a numeric expression with the number 7, use the expression syntax which begins with the equal sign: =7.
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | ToString | Overridden.
Top

Public Events

 | Name | Description
Public Event | PropertyChanged |
Top

See Also

Reference

Filter Class
Telerik.Reporting.Data Namespace


Filter Constructor

Filter Constructor
[image]
Telerik.Reporting.Data Namespace > Filter Class : Filter Constructor

Overload List

Overload | Description
Filter Constructor() |
Filter Constructor(String,FilterOperator,String) |

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Filter Class
Filter Members


Filter Constructor()

Filter Constructor()
See Also
[image]
Telerik.Reporting.Data Namespace > Filter Class > Filter Constructor : Filter Constructor()

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Filter()
C#
public Filter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Filter()
C#
public Filter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Filter Class
Filter Members
Overload List


Filter Constructor(String,FilterOperator,String)

Filter Constructor(String,FilterOperator,String)
See Also
[image]
Telerik.Reporting.Data Namespace > Filter Class > Filter Constructor : Filter Constructor(String,FilterOperator,String)

expression
operator
value

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String, _
   ByVal operator As FilterOperator, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim expression As String
Dim operator As FilterOperator
Dim value As String

Dim instance As Filter(expression, operator, value)
C#
public Filter(
   string expression,
   FilterOperator operator,
   string value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String, _
   ByVal operator As FilterOperator, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim expression As String
Dim operator As FilterOperator
Dim value As String

Dim instance As Filter(expression, operator, value)
C#
public Filter(
   string expression,
   FilterOperator operator,
   string value
)

Parameters

expression
operator
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Filter Class
Filter Members
Overload List


Filter Class Methods

Filter Class Methods
[image]
Telerik.Reporting.Data Namespace : Filter Class

For a list of all members of this type, see Filter members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | ToString | Overridden.
Top

See Also

Reference

Filter Class
Telerik.Reporting.Data Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Data Namespace > Filter Class : Clone Method

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As Filter
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Filter Class
Filter Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Data Namespace > Filter Class : ToString Method

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Filter
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Filter Class
Filter Members


Filter Class Properties

Filter Class Properties
[image]
Telerik.Reporting.Data Namespace : Filter Class

For a list of all members of this type, see Filter members.

Public Properties

 | Name | Description
Public Property | Expression |
Public Property | IsEmpty |
Public Property | Operator |
Public Property | Value | If the Value starts with the equal (=) sign, it will be evaluated as an expression otherwise - as string value. For ex. if the value is 7 it is interpreted as the string "7"; To compare a numeric expression with the number 7, use the expression syntax which begins with the equal sign: =7.
Top

See Also

Reference

Filter Class
Telerik.Reporting.Data Namespace


Expression Property

Expression Property
[image]
Telerik.Reporting.Data Namespace > Filter Class : Expression Property

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Expression As String
Visual Basic (Usage) Copy Code
Dim instance As Filter
Dim value As String

instance.Expression = value

value = instance.Expression
C#
public string Expression {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Filter Class
Filter Members


IsEmpty Property

IsEmpty Property
[image]
Telerik.Reporting.Data Namespace > Filter Class : IsEmpty Property

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Filter
Dim value As Boolean

value = instance.IsEmpty
C#
public bool IsEmpty {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Filter Class
Filter Members


Operator Property

Operator Property
[image]
Telerik.Reporting.Data Namespace > Filter Class : Operator Property

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Operator As FilterOperator
Visual Basic (Usage) Copy Code
Dim instance As Filter
Dim value As FilterOperator

instance.Operator = value

value = instance.Operator
C#
public FilterOperator Operator {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Filter Class
Filter Members


Value Property

Value Property
[image]
Telerik.Reporting.Data Namespace > Filter Class : Value Property

If the Value starts with the equal (=) sign, it will be evaluated as an expression otherwise - as string value. For ex. if the value is 7 it is interpreted as the string "7"; To compare a numeric expression with the number 7, use the expression syntax which begins with the equal sign: =7.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As Filter
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Filter Class
Filter Members


Filter Class Events

Filter Class Events
[image]
Telerik.Reporting.Data Namespace : Filter Class

For a list of all members of this type, see Filter members.

Public Events

 | Name | Description
Public Event | PropertyChanged |
Top

See Also

Reference

Filter Class
Telerik.Reporting.Data Namespace


PropertyChanged Event

PropertyChanged Event
[image]
Telerik.Reporting.Data Namespace > Filter Class : PropertyChanged Event

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged() As PropertyChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Filter
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
C#
public event PropertyChangedEventHandler PropertyChanged()

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged() As PropertyChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Filter
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
C#
public event PropertyChangedEventHandler PropertyChanged()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Filter Class
Filter Members


FilterCollection Class

FilterCollection Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : FilterCollection Class

Object Model

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FilterCollection
   Inherits Collection(Of Filter)
Visual Basic (Usage) Copy Code
Dim instance As FilterCollection
C#
public class FilterCollection : Collection<Filter>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<Filter>
Telerik.Reporting.Data.FilterCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterCollection Members
Telerik.Reporting.Data Namespace


FilterCollection Class Members

FilterCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Data Namespace : FilterCollection Class

The following tables list the members exposed by FilterCollection.

Public Constructors

 | Name | Description
Public Constructor | FilterCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange |
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Top

See Also

Reference

FilterCollection Class
Telerik.Reporting.Data Namespace


FilterCollection Constructor

FilterCollection Constructor
[image]
Telerik.Reporting.Data Namespace > FilterCollection Class : FilterCollection Constructor

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FilterCollection()
C#
public FilterCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FilterCollection()
C#
public FilterCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterCollection Class
FilterCollection Members


FilterCollection Class Methods

FilterCollection Class Methods
[image]
Telerik.Reporting.Data Namespace : FilterCollection Class

For a list of all members of this type, see FilterCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange |
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Top

See Also

Reference

FilterCollection Class
Telerik.Reporting.Data Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Data Namespace > FilterCollection Class : Add Method

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Add(String,FilterOperator,String) |
Add(Filter) | (Inherited from System.Collections.ObjectModel.Collection<Filter>)

Overload List

Overload | Description
Add(String,FilterOperator,String) |
Add(Filter) | (Inherited from System.Collections.ObjectModel.Collection<Filter>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterCollection Class
FilterCollection Members


Add(String,FilterOperator,String) Method

Add(String,FilterOperator,String) Method
[image]
Telerik.Reporting.Data Namespace > FilterCollection Class > Add Method : Add(String,FilterOperator,String) Method

expression
op
value

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal expression As String, _
   ByVal op As FilterOperator, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As FilterCollection
Dim expression As String
Dim op As FilterOperator
Dim value As String

instance.Add(expression, op, value)
C#
public void Add(
   string expression,
   FilterOperator op,
   string value
)

Parameters

expression
op
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterCollection Class
FilterCollection Members
Overload List


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Data Namespace > FilterCollection Class : AddRange Method

items

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal items() As Filter _
)
Visual Basic (Usage) Copy Code
Dim instance As FilterCollection
Dim items() As Filter

instance.AddRange(items)
C#
public void AddRange(
   Filter[] items
)

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterCollection Class
FilterCollection Members


FilterExpression Class

FilterExpression Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : FilterExpression Class

Represents a string expression used for filtering.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FilterExpression
Visual Basic (Usage) Copy Code
Dim instance As FilterExpression
C#
public class FilterExpression

Inheritance Hierarchy

System.Object
Telerik.Reporting.Data.FilterExpression

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpression Members
Telerik.Reporting.Data Namespace


FilterExpression Class Members

FilterExpression Class Members
See Also Properties
[image]
Telerik.Reporting.Data Namespace : FilterExpression Class

The following tables list the members exposed by FilterExpression.

Public Constructors

 | Name | Description
Public Constructor | FilterExpression Constructor | Overloaded. Initializes a new instance of the FilterExpression with an empty expression.
Top

Public Properties

 | Name | Description
Public Property | Expression | Gets or sets the expression for the filter.
Top

See Also

Reference

FilterExpression Class
Telerik.Reporting.Data Namespace


FilterExpression Constructor

FilterExpression Constructor
[image]
Telerik.Reporting.Data Namespace > FilterExpression Class : FilterExpression Constructor

Initializes a new instance of the FilterExpression with an empty expression.

Overload List

Overload | Description
FilterExpression Constructor() | Initializes a new instance of the FilterExpression with an empty expression.
FilterExpression Constructor(String) |

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpression Class
FilterExpression Members


FilterExpression Constructor()

FilterExpression Constructor()
See Also
[image]
Telerik.Reporting.Data Namespace > FilterExpression Class > FilterExpression Constructor : FilterExpression Constructor()

Initializes a new instance of the FilterExpression with an empty expression.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FilterExpression()
C#
public FilterExpression()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FilterExpression()
C#
public FilterExpression()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpression Class
FilterExpression Members
Overload List


FilterExpression Constructor(String)

FilterExpression Constructor(String)
See Also
[image]
Telerik.Reporting.Data Namespace > FilterExpression Class > FilterExpression Constructor : FilterExpression Constructor(String)

expression

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String _
)
Visual Basic (Usage) Copy Code
Dim expression As String

Dim instance As FilterExpression(expression)
C#
public FilterExpression(
   string expression
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String _
)
Visual Basic (Usage) Copy Code
Dim expression As String

Dim instance As FilterExpression(expression)
C#
public FilterExpression(
   string expression
)

Parameters

expression

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpression Class
FilterExpression Members
Overload List


FilterExpression Class Properties

FilterExpression Class Properties
[image]
Telerik.Reporting.Data Namespace : FilterExpression Class

For a list of all members of this type, see FilterExpression members.

Public Properties

 | Name | Description
Public Property | Expression | Gets or sets the expression for the filter.
Top

See Also

Reference

FilterExpression Class
Telerik.Reporting.Data Namespace


Expression Property

Expression Property
[image]
Telerik.Reporting.Data Namespace > FilterExpression Class : Expression Property

Gets or sets the expression for the filter.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Expression As String
Visual Basic (Usage) Copy Code
Dim instance As FilterExpression
Dim value As String

instance.Expression = value

value = instance.Expression
C#
public string Expression {get; set;}

Return Value

A string value representing the filter expression.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpression Class
FilterExpression Members


FilterExpressionCollection Class

FilterExpressionCollection Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : FilterExpressionCollection Class

Represents a collection of FilterExpression objects.

Object Model

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FilterExpressionCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As FilterExpressionCollection
C#
public class FilterExpressionCollection : CollectionBase

Remarks

The Add, Remove, and RemoveAt methods enable you to add and remove individual filter expressions from the collection. You can also use the AddRange or Clear methods to add or remove all the filter expressions from the collection. You can determine if a FilterExpression is a member of the collection by passing the filter expression into the Contains method. To get the index value of the location of a FilterExpression in the collection, pass the item into the IndexOf method. The collection can be copied into an array by calling the CopyTo method.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.Reporting.Data.FilterExpressionCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Members
Telerik.Reporting.Data Namespace


FilterExpressionCollection Class Members

FilterExpressionCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Data Namespace : FilterExpressionCollection Class

The following tables list the members exposed by FilterExpressionCollection.

Public Constructors

 | Name | Description
Public Constructor | FilterExpressionCollection Constructor | Overloaded. Initializes a new instance of the FilterExpressionCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns the FilterExpression at the specified indexed location in the collection.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the specified filter expression to the filter expression collection.
Public Method | AddRange | Adds an array of filter expressions to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified filter expression is a member of the collection.
Public Method | CopyTo | Copies the entire FilterExpressionCollection to the specified array, starting at the specified index of the target array.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified filter expression in the filte expression collection.
Public Method | Insert | Inserts a specified FilterExpression object into the FilterExpressionCollection at the specified index location.
Public Method | Remove | Removes the specified filter expression from the filter expression collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Public Method | ToArray | Copies the elements of the FilterExpressionCollection to a new FilterExpression array.
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs additional custom processes when validating a value.
Top

See Also

Reference

FilterExpressionCollection Class
Telerik.Reporting.Data Namespace


FilterExpressionCollection Constructor

FilterExpressionCollection Constructor
[image]
Telerik.Reporting.Data Namespace > FilterExpressionCollection Class : FilterExpressionCollection Constructor

Initializes a new instance of the FilterExpressionCollection class.

Overload List

Overload | Description
FilterExpressionCollection Constructor() | Initializes a new instance of the FilterExpressionCollection class.
FilterExpressionCollection Constructor(FilterExpression[]) |

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Class
FilterExpressionCollection Members


FilterExpressionCollection Constructor()

FilterExpressionCollection Constructor()
See Also
[image]
Telerik.Reporting.Data Namespace > FilterExpressionCollection Class > FilterExpressionCollection Constructor : FilterExpressionCollection Constructor()

Initializes a new instance of the FilterExpressionCollection class.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FilterExpressionCollection()
C#
public FilterExpressionCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FilterExpressionCollection()
C#
public FilterExpressionCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Class
FilterExpressionCollection Members
Overload List


FilterExpressionCollection Constructor(FilterExpression[])

FilterExpressionCollection Constructor(FilterExpression[])
See Also
[image]
Telerik.Reporting.Data Namespace > FilterExpressionCollection Class > FilterExpressionCollection Constructor : FilterExpressionCollection Constructor(FilterExpression[])

items

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items() As FilterExpression _
)
Visual Basic (Usage) Copy Code
Dim items() As FilterExpression

Dim instance As FilterExpressionCollection(items)
C#
public FilterExpressionCollection(
   FilterExpression[] items
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items() As FilterExpression _
)
Visual Basic (Usage) Copy Code
Dim items() As FilterExpression

Dim instance As FilterExpressionCollection(items)
C#
public FilterExpressionCollection(
   FilterExpression[] items
)

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Class
FilterExpressionCollection Members
Overload List


FilterExpressionCollection Class Methods

FilterExpressionCollection Class Methods
[image]
Telerik.Reporting.Data Namespace : FilterExpressionCollection Class

For a list of all members of this type, see FilterExpressionCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds the specified filter expression to the filter expression collection.
Public Method | AddRange | Adds an array of filter expressions to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified filter expression is a member of the collection.
Public Method | CopyTo | Copies the entire FilterExpressionCollection to the specified array, starting at the specified index of the target array.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified filter expression in the filte expression collection.
Public Method | Insert | Inserts a specified FilterExpression object into the FilterExpressionCollection at the specified index location.
Public Method | Remove | Removes the specified filter expression from the filter expression collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Public Method | ToArray | Copies the elements of the FilterExpressionCollection to a new FilterExpression array.
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs additional custom processes when validating a value.
Top

See Also

Reference

FilterExpressionCollection Class
Telerik.Reporting.Data Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Data Namespace > FilterExpressionCollection Class : Add Method

item
The FilterExpression to add to the filter expression collection.
Adds the specified filter expression to the filter expression collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal item As FilterExpression _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As FilterExpressionCollection
Dim item As FilterExpression
Dim value As Integer

value = instance.Add(item)
C#
public int Add(
   FilterExpression item
)

Parameters

item
The FilterExpression to add to the filter expression collection.

Return Value

The index of the added FilterExpression

Remarks

The Add method allows you to add FilterExpression objects to the end of the filter expression collection.

You can also add new FilterExpression objects to the collection by using the AddRange method.

To remove a FilterExpression that you previously added, use the Remove, RemoveAt, or Clear methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Class
FilterExpressionCollection Members


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Data Namespace > FilterExpressionCollection Class : AddRange Method

items
An array of FilterExpression objects to add to the collection.
Adds an array of filter expressions to the collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal items() As FilterExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As FilterExpressionCollection
Dim items() As FilterExpression

instance.AddRange(items)
C#
public void AddRange(
   FilterExpression[] items
)

Parameters

items
An array of FilterExpression objects to add to the collection.

Remarks

The FilterExpression objects contained in the items array are appended to the end of the collection.

You can use the AddRange method to quickly add a group of FilterExpression objects to the collection instead of manually adding each FilterExpression to the collection using the Add method.

To remove a FilterExpression that you previously added, use the Remove, RemoveAt, or Clear methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Class
FilterExpressionCollection Members


Contains Method

Contains Method
[image]
Telerik.Reporting.Data Namespace > FilterExpressionCollection Class : Contains Method

item
The FilterExpression to locate in the collection.
Determines whether the specified filter expression is a member of the collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As FilterExpression _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FilterExpressionCollection
Dim item As FilterExpression
Dim value As Boolean

value = instance.Contains(item)
C#
public bool Contains(
   FilterExpression item
)

Parameters

item
The FilterExpression to locate in the collection.

Return Value

true if the FilterExpression is a member of the collection; otherwise, false.

Remarks

This method enables you to determine whether a FilterExpression is a member of the collection before attempting to perform operations on the FilterExpression. You can use this method to confirm that an FilterExpression has been added to or is still a member of the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Class
FilterExpressionCollection Members


CopyTo Method

CopyTo Method
[image]
Telerik.Reporting.Data Namespace > FilterExpressionCollection Class : CopyTo Method

array
The one-dimensional array that is the destination of the elements copied from FilterExpressionCollection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the entire FilterExpressionCollection to the specified array, starting at the specified index of the target array.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As FilterExpression, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As FilterExpressionCollection
Dim array() As FilterExpression
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   FilterExpression[] array,
   int index
)

Parameters

array
The one-dimensional array that is the destination of the elements copied from FilterExpressionCollection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Class
FilterExpressionCollection Members


IndexOf Method

IndexOf Method
[image]
Telerik.Reporting.Data Namespace > FilterExpressionCollection Class : IndexOf Method

item
The FilterExpression to locate in the collection.
Retrieves the index of the specified filter expression in the filte expression collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As FilterExpression _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As FilterExpressionCollection
Dim item As FilterExpression
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   FilterExpression item
)

Parameters

item
The FilterExpression to locate in the collection.

Return Value

A zero-based index value that represents the position of the specified FilterExpression in the FilterExpressionCollection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Class
FilterExpressionCollection Members


Insert Method

Insert Method
[image]
Telerik.Reporting.Data Namespace > FilterExpressionCollection Class : Insert Method

index
The zero-based index location at which to insert the FilterExpression object.
item
The FilterExpression object to insert into the collection.
Inserts a specified FilterExpression object into the FilterExpressionCollection at the specified index location.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As FilterExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As FilterExpressionCollection
Dim index As Integer
Dim item As FilterExpression

instance.Insert(index, item)
C#
public void Insert(
   int index,
   FilterExpression item
)

Parameters

index
The zero-based index location at which to insert the FilterExpression object.
item
The FilterExpression object to insert into the collection.

Remarks

Use the Insert method to insert a specified FilterExpression object into the FilterExpressionCollection object at a specified index location.

To add a FilterExpression object at the end of the FilterExpressionCollection object, use the Add method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Class
FilterExpressionCollection Members


OnValidate Method

OnValidate Method
[image]
Telerik.Reporting.Data Namespace > FilterExpressionCollection Class : OnValidate Method

value
The object to validate.
Performs additional custom processes when validating a value.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnValidate( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As FilterExpressionCollection
Dim value As Object

instance.OnValidate(value)
C#
protected override void OnValidate(
   object value
)

Parameters

value
The object to validate.

Exceptions

Exception | Description
ArgumentException | The object is not a FilterExpression.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Class
FilterExpressionCollection Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Data Namespace > FilterExpressionCollection Class : Remove Method

item
The FilterExpression to remove from the FilterExpressionCollection.
Removes the specified filter expression from the filter expression collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As FilterExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As FilterExpressionCollection
Dim item As FilterExpression

instance.Remove(item)
C#
public void Remove(
   FilterExpression item
)

Parameters

item
The FilterExpression to remove from the FilterExpressionCollection.

Remarks

When a FilterExpression is removed from the filter expression collection, all subsequent filter expressions are moved up one position in the collection.

You can also remove a FilterExpression by using the RemoveAt method, or remove all filter expressions by using the Clear method.

To add new FilterExpression objects to the collection, use the Add or AddRange methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Class
FilterExpressionCollection Members


ToArray Method

ToArray Method
[image]
Telerik.Reporting.Data Namespace > FilterExpressionCollection Class : ToArray Method

Copies the elements of the FilterExpressionCollection to a new FilterExpression array.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function ToArray() As FilterExpression()
Visual Basic (Usage) Copy Code
Dim instance As FilterExpressionCollection
Dim value() As FilterExpression

value = instance.ToArray()
C#
public FilterExpression[] ToArray()

Return Value

An FilterExpression array containing copies of the elements of the FilterExpressionCollection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Class
FilterExpressionCollection Members


FilterExpressionCollection Class Properties

FilterExpressionCollection Class Properties
[image]
Telerik.Reporting.Data Namespace : FilterExpressionCollection Class

For a list of all members of this type, see FilterExpressionCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns the FilterExpression at the specified indexed location in the collection.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

FilterExpressionCollection Class
Telerik.Reporting.Data Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Data Namespace > FilterExpressionCollection Class : Item Property

index
The index of the filter expression to retrieve from the filter expression collection.
Returns the FilterExpression at the specified indexed location in the collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As FilterExpression
Visual Basic (Usage) Copy Code
Dim instance As FilterExpressionCollection
Dim index As Integer
Dim value As FilterExpression

instance.Item(index) = value

value = instance.Item(index)
C#
public FilterExpression this[
   int index
]; {get; set;}

Parameters

index
The index of the filter expression to retrieve from the filter expression collection.

Return Value

The FilterExpression located at the specified index location within the filter expression collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FilterExpressionCollection Class
FilterExpressionCollection Members


GroupCollection Class

GroupCollection Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : GroupCollection Class

Object Model

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class GroupCollection
   Inherits Collection(Of Group)
Visual Basic (Usage) Copy Code
Dim instance As GroupCollection
C#
public class GroupCollection : Collection<Group>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<Group>
Telerik.Reporting.Data.GroupCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupCollection Members
Telerik.Reporting.Data Namespace


GroupCollection Class Members

GroupCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Data Namespace : GroupCollection Class

The following tables list the members exposed by GroupCollection.

Public Constructors

 | Name | Description
Public Constructor | GroupCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | AddRange |
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Top

See Also

Reference

GroupCollection Class
Telerik.Reporting.Data Namespace


GroupCollection Constructor

GroupCollection Constructor
[image]
Telerik.Reporting.Data Namespace > GroupCollection Class : GroupCollection Constructor

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupCollection()
C#
public GroupCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupCollection()
C#
public GroupCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupCollection Class
GroupCollection Members


GroupCollection Class Methods

GroupCollection Class Methods
[image]
Telerik.Reporting.Data Namespace : GroupCollection Class

For a list of all members of this type, see GroupCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | AddRange |
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Top

See Also

Reference

GroupCollection Class
Telerik.Reporting.Data Namespace


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Data Namespace > GroupCollection Class : AddRange Method

items

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal items() As Group _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupCollection
Dim items() As Group

instance.AddRange(items)
C#
public void AddRange(
   Group[] items
)

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupCollection Class
GroupCollection Members


GroupCollectionConverter Class

GroupCollectionConverter Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : GroupCollectionConverter Class

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Class GroupCollectionConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As GroupCollectionConverter
C#
private class GroupCollectionConverter : TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Reporting.Data.GroupCollectionConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupCollectionConverter Members
Telerik.Reporting.Data Namespace


GroupCollectionConverter Class Members

GroupCollectionConverter Class Members
See Also Methods
[image]
Telerik.Reporting.Data Namespace : GroupCollectionConverter Class

The following tables list the members exposed by GroupCollectionConverter.

Public Constructors

 | Name | Description
Public Constructor | GroupCollectionConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

GroupCollectionConverter Class
Telerik.Reporting.Data Namespace


GroupCollectionConverter Constructor

GroupCollectionConverter Constructor
[image]
Telerik.Reporting.Data Namespace > GroupCollectionConverter Class : GroupCollectionConverter Constructor

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupCollectionConverter()
C#
public GroupCollectionConverter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupCollectionConverter()
C#
public GroupCollectionConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupCollectionConverter Class
GroupCollectionConverter Members


GroupCollectionConverter Class Methods

GroupCollectionConverter Class Methods
[image]
Telerik.Reporting.Data Namespace : GroupCollectionConverter Class

For a list of all members of this type, see GroupCollectionConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

GroupCollectionConverter Class
Telerik.Reporting.Data Namespace


ConvertTo Method

ConvertTo Method
[image]
Telerik.Reporting.Data Namespace > GroupCollectionConverter Class : ConvertTo Method

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupCollectionConverter Class
GroupCollectionConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also
[image]
Telerik.Reporting.Data Namespace > GroupCollectionConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As GroupCollectionConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
culture
value
destinationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupCollectionConverter Class
GroupCollectionConverter Members
Overload List


GroupExpression Class

GroupExpression Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : GroupExpression Class

Represents an expression used for grouping by a field name from the data source.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class GroupExpression
Visual Basic (Usage) Copy Code
Dim instance As GroupExpression
C#
public class GroupExpression

Inheritance Hierarchy

System.Object
Telerik.Reporting.Data.GroupExpression

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpression Members
Telerik.Reporting.Data Namespace


GroupExpression Class Members

GroupExpression Class Members
See Also Properties
[image]
Telerik.Reporting.Data Namespace : GroupExpression Class

The following tables list the members exposed by GroupExpression.

Public Constructors

 | Name | Description
Public Constructor | GroupExpression Constructor | Overloaded. Initializes a new instance of the GroupExpression with an empty field name.
Top

Public Properties

 | Name | Description
Public Property | FieldName | Gets or sets the field name of this GroupExpression
Top

See Also

Reference

GroupExpression Class
Telerik.Reporting.Data Namespace


GroupExpression Constructor

GroupExpression Constructor
[image]
Telerik.Reporting.Data Namespace > GroupExpression Class : GroupExpression Constructor

Initializes a new instance of the GroupExpression with an empty field name.

Overload List

Overload | Description
GroupExpression Constructor() | Initializes a new instance of the GroupExpression with an empty field name.
GroupExpression Constructor(String) |

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpression Class
GroupExpression Members


GroupExpression Constructor()

GroupExpression Constructor()
See Also
[image]
Telerik.Reporting.Data Namespace > GroupExpression Class > GroupExpression Constructor : GroupExpression Constructor()

Initializes a new instance of the GroupExpression with an empty field name.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupExpression()
C#
public GroupExpression()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupExpression()
C#
public GroupExpression()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpression Class
GroupExpression Members
Overload List


GroupExpression Constructor(String)

GroupExpression Constructor(String)
See Also
[image]
Telerik.Reporting.Data Namespace > GroupExpression Class > GroupExpression Constructor : GroupExpression Constructor(String)

fieldName

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fieldName As String _
)
Visual Basic (Usage) Copy Code
Dim fieldName As String

Dim instance As GroupExpression(fieldName)
C#
public GroupExpression(
   string fieldName
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fieldName As String _
)
Visual Basic (Usage) Copy Code
Dim fieldName As String

Dim instance As GroupExpression(fieldName)
C#
public GroupExpression(
   string fieldName
)

Parameters

fieldName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpression Class
GroupExpression Members
Overload List


GroupExpression Class Properties

GroupExpression Class Properties
[image]
Telerik.Reporting.Data Namespace : GroupExpression Class

For a list of all members of this type, see GroupExpression members.

Public Properties

 | Name | Description
Public Property | FieldName | Gets or sets the field name of this GroupExpression
Top

See Also

Reference

GroupExpression Class
Telerik.Reporting.Data Namespace


FieldName Property

FieldName Property
[image]
Telerik.Reporting.Data Namespace > GroupExpression Class : FieldName Property

Gets or sets the field name of this GroupExpression

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldName As String
Visual Basic (Usage) Copy Code
Dim instance As GroupExpression
Dim value As String

instance.FieldName = value

value = instance.FieldName
C#
public string FieldName {get; set;}

Return Value

A string value representing the field name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpression Class
GroupExpression Members


GroupExpressionCollection Class

GroupExpressionCollection Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : GroupExpressionCollection Class

Represents a collection of GroupExpression objects.

Object Model

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class GroupExpressionCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As GroupExpressionCollection
C#
public class GroupExpressionCollection : CollectionBase

Remarks

The Add, Remove, and RemoveAt methods enable you to add and remove individual group expressions from the collection. You can also use the AddRange or Clear methods to add or remove all the group expressions from the collection. You can determine if a GroupExpression is a member of the collection by passing the group expression into the Contains method. To get the index value of the location of a GroupExpression in the collection, pass the item into the IndexOf method.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.Reporting.Data.GroupExpressionCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpressionCollection Members
Telerik.Reporting.Data Namespace


GroupExpressionCollection Class Members

GroupExpressionCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Data Namespace : GroupExpressionCollection Class

The following tables list the members exposed by GroupExpressionCollection.

Public Constructors

 | Name | Description
Public Constructor | GroupExpressionCollection Constructor | Overloaded. Initializes a new instance of the GroupExpressionCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns the GroupExpression at the specified indexed location in the collection.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the specified group expression to the group expression collection.
Public Method | AddRange | Adds an array of group expressions to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified group expression is a member of the collection.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified group expression in the group expression collection.
Public Method | Insert | Inserts a specified GroupExpression object into the GroupExpressionCollection at the specified index location.
Public Method | Remove | Removes the specified group expression from the group expression collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs additional custom processes when validating a value.
Top

See Also

Reference

GroupExpressionCollection Class
Telerik.Reporting.Data Namespace


GroupExpressionCollection Constructor

GroupExpressionCollection Constructor
[image]
Telerik.Reporting.Data Namespace > GroupExpressionCollection Class : GroupExpressionCollection Constructor

Initializes a new instance of the GroupExpressionCollection class.

Overload List

Overload | Description
GroupExpressionCollection Constructor() | Initializes a new instance of the GroupExpressionCollection class.
GroupExpressionCollection Constructor(GroupExpression[]) |

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpressionCollection Class
GroupExpressionCollection Members


GroupExpressionCollection Constructor()

GroupExpressionCollection Constructor()
See Also
[image]
Telerik.Reporting.Data Namespace > GroupExpressionCollection Class > GroupExpressionCollection Constructor : GroupExpressionCollection Constructor()

Initializes a new instance of the GroupExpressionCollection class.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupExpressionCollection()
C#
public GroupExpressionCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupExpressionCollection()
C#
public GroupExpressionCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpressionCollection Class
GroupExpressionCollection Members
Overload List


GroupExpressionCollection Constructor(GroupExpression[])

GroupExpressionCollection Constructor(GroupExpression[])
See Also
[image]
Telerik.Reporting.Data Namespace > GroupExpressionCollection Class > GroupExpressionCollection Constructor : GroupExpressionCollection Constructor(GroupExpression[])

items

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items() As GroupExpression _
)
Visual Basic (Usage) Copy Code
Dim items() As GroupExpression

Dim instance As GroupExpressionCollection(items)
C#
public GroupExpressionCollection(
   GroupExpression[] items
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items() As GroupExpression _
)
Visual Basic (Usage) Copy Code
Dim items() As GroupExpression

Dim instance As GroupExpressionCollection(items)
C#
public GroupExpressionCollection(
   GroupExpression[] items
)

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpressionCollection Class
GroupExpressionCollection Members
Overload List


GroupExpressionCollection Class Methods

GroupExpressionCollection Class Methods
[image]
Telerik.Reporting.Data Namespace : GroupExpressionCollection Class

For a list of all members of this type, see GroupExpressionCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds the specified group expression to the group expression collection.
Public Method | AddRange | Adds an array of group expressions to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified group expression is a member of the collection.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified group expression in the group expression collection.
Public Method | Insert | Inserts a specified GroupExpression object into the GroupExpressionCollection at the specified index location.
Public Method | Remove | Removes the specified group expression from the group expression collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs additional custom processes when validating a value.
Top

See Also

Reference

GroupExpressionCollection Class
Telerik.Reporting.Data Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Data Namespace > GroupExpressionCollection Class : Add Method

item
The GroupExpression to add to the group expression collection.
Adds the specified group expression to the group expression collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal item As GroupExpression _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GroupExpressionCollection
Dim item As GroupExpression
Dim value As Integer

value = instance.Add(item)
C#
public int Add(
   GroupExpression item
)

Parameters

item
The GroupExpression to add to the group expression collection.

Return Value

The index of the added GroupExpression

Remarks

The Add method allows you to add GroupExpression objects to the end of the group expression collection.

You can also add new GroupExpression objects to the collection by using the AddRange method.

To remove a GroupExpression that you previously added, use the Remove, RemoveAt, or Clear methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpressionCollection Class
GroupExpressionCollection Members


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Data Namespace > GroupExpressionCollection Class : AddRange Method

items
An array of GroupExpression objects to add to the collection.
Adds an array of group expressions to the collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal items() As GroupExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupExpressionCollection
Dim items() As GroupExpression

instance.AddRange(items)
C#
public void AddRange(
   GroupExpression[] items
)

Parameters

items
An array of GroupExpression objects to add to the collection.

Remarks

The GroupExpression objects contained in the items array are appended to the end of the collection.

You can use the AddRange method to quickly add a group of GroupExpression objects to the collection instead of manually adding each GroupExpression to the collection using the Add method.

To remove a GroupExpression that you previously added, use the Remove, RemoveAt, or Clear methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpressionCollection Class
GroupExpressionCollection Members


Contains Method

Contains Method
[image]
Telerik.Reporting.Data Namespace > GroupExpressionCollection Class : Contains Method

item
The GroupExpression to locate in the collection.
Determines whether the specified group expression is a member of the collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As GroupExpression _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GroupExpressionCollection
Dim item As GroupExpression
Dim value As Boolean

value = instance.Contains(item)
C#
public bool Contains(
   GroupExpression item
)

Parameters

item
The GroupExpression to locate in the collection.

Return Value

true if the GroupExpression is a member of the collection; otherwise, false.

Remarks

This method enables you to determine whether a GroupExpression is a member of the collection before attempting to perform operations on the GroupExpression. You can use this method to confirm that an GroupExpression has been added to or is still a member of the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpressionCollection Class
GroupExpressionCollection Members


IndexOf Method

IndexOf Method
[image]
Telerik.Reporting.Data Namespace > GroupExpressionCollection Class : IndexOf Method

item
The GroupExpression to locate in the collection.
Retrieves the index of the specified group expression in the group expression collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As GroupExpression _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GroupExpressionCollection
Dim item As GroupExpression
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   GroupExpression item
)

Parameters

item
The GroupExpression to locate in the collection.

Return Value

A zero-based index value that represents the position of the specified GroupExpression in the GroupExpressionCollection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpressionCollection Class
GroupExpressionCollection Members


Insert Method

Insert Method
[image]
Telerik.Reporting.Data Namespace > GroupExpressionCollection Class : Insert Method

index
The zero-based index location at which to insert the GroupExpression object.
item
The GroupExpression object to insert into the collection.
Inserts a specified GroupExpression object into the GroupExpressionCollection at the specified index location.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As GroupExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupExpressionCollection
Dim index As Integer
Dim item As GroupExpression

instance.Insert(index, item)
C#
public void Insert(
   int index,
   GroupExpression item
)

Parameters

index
The zero-based index location at which to insert the GroupExpression object.
item
The GroupExpression object to insert into the collection.

Remarks

Use the Insert method to insert a specified GroupExpression object into the GroupExpressionCollection object at a specified index location.

To add a GroupExpression object at the end of the GroupExpressionCollection object, use the Add method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpressionCollection Class
GroupExpressionCollection Members


OnValidate Method

OnValidate Method
[image]
Telerik.Reporting.Data Namespace > GroupExpressionCollection Class : OnValidate Method

value
The object to validate.
Performs additional custom processes when validating a value.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnValidate( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupExpressionCollection
Dim value As Object

instance.OnValidate(value)
C#
protected override void OnValidate(
   object value
)

Parameters

value
The object to validate.

Exceptions

Exception | Description
ArgumentException | The object is not a GroupExpression.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpressionCollection Class
GroupExpressionCollection Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Data Namespace > GroupExpressionCollection Class : Remove Method

item
The GroupExpression to remove from the GroupExpressionCollection.
Removes the specified group expression from the group expression collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As GroupExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupExpressionCollection
Dim item As GroupExpression

instance.Remove(item)
C#
public void Remove(
   GroupExpression item
)

Parameters

item
The GroupExpression to remove from the GroupExpressionCollection.

Remarks

When a GroupExpression is removed from the group expression collection, all subsequent group expressions are moved up one position in the collection.

You can also remove a GroupExpression by using the RemoveAt method, or remove all group expressions by using the Clear method.

To add new GroupExpression objects to the collection, use the Add or AddRange methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpressionCollection Class
GroupExpressionCollection Members


GroupExpressionCollection Class Properties

GroupExpressionCollection Class Properties
[image]
Telerik.Reporting.Data Namespace : GroupExpressionCollection Class

For a list of all members of this type, see GroupExpressionCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns the GroupExpression at the specified indexed location in the collection.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

GroupExpressionCollection Class
Telerik.Reporting.Data Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Data Namespace > GroupExpressionCollection Class : Item Property

index
The index of the group expression to retrieve from the group expression collection.
Returns the GroupExpression at the specified indexed location in the collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As GroupExpression
Visual Basic (Usage) Copy Code
Dim instance As GroupExpressionCollection
Dim index As Integer
Dim value As GroupExpression

instance.Item(index) = value

value = instance.Item(index)
C#
public GroupExpression this[
   int index
]; {get; set;}

Parameters

index
The index of the group expression to retrieve from the group expression collection.

Return Value

The GroupExpression located at the specified index location within the group expression collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupExpressionCollection Class
GroupExpressionCollection Members


Grouping Class

Grouping Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : Grouping Class

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Grouping
Visual Basic (Usage) Copy Code
Dim instance As Grouping
C#
public class Grouping

Inheritance Hierarchy

System.Object
Telerik.Reporting.Data.Grouping

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grouping Members
Telerik.Reporting.Data Namespace


Grouping Class Members

Grouping Class Members
See Also Properties Events
[image]
Telerik.Reporting.Data Namespace : Grouping Class

The following tables list the members exposed by Grouping.

Public Constructors

 | Name | Description
Public Constructor | Grouping Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Expression |
Top

Public Events

 | Name | Description
Public Event | PropertyChanged |
Top

See Also

Reference

Grouping Class
Telerik.Reporting.Data Namespace


Grouping Constructor

Grouping Constructor
[image]
Telerik.Reporting.Data Namespace > Grouping Class : Grouping Constructor

Overload List

Overload | Description
Grouping Constructor() |
Grouping Constructor(String) |

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grouping Class
Grouping Members


Grouping Constructor()

Grouping Constructor()
See Also
[image]
Telerik.Reporting.Data Namespace > Grouping Class > Grouping Constructor : Grouping Constructor()

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Grouping()
C#
public Grouping()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Grouping()
C#
public Grouping()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grouping Class
Grouping Members
Overload List


Grouping Constructor(String)

Grouping Constructor(String)
See Also
[image]
Telerik.Reporting.Data Namespace > Grouping Class > Grouping Constructor : Grouping Constructor(String)

expression

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String _
)
Visual Basic (Usage) Copy Code
Dim expression As String

Dim instance As Grouping(expression)
C#
public Grouping(
   string expression
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String _
)
Visual Basic (Usage) Copy Code
Dim expression As String

Dim instance As Grouping(expression)
C#
public Grouping(
   string expression
)

Parameters

expression

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grouping Class
Grouping Members
Overload List


Grouping Class Properties

Grouping Class Properties
[image]
Telerik.Reporting.Data Namespace : Grouping Class

For a list of all members of this type, see Grouping members.

Public Properties

 | Name | Description
Public Property | Expression |
Top

See Also

Reference

Grouping Class
Telerik.Reporting.Data Namespace


Expression Property

Expression Property
[image]
Telerik.Reporting.Data Namespace > Grouping Class : Expression Property

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Expression As String
Visual Basic (Usage) Copy Code
Dim instance As Grouping
Dim value As String

instance.Expression = value

value = instance.Expression
C#
public string Expression {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grouping Class
Grouping Members


Grouping Class Events

Grouping Class Events
[image]
Telerik.Reporting.Data Namespace : Grouping Class

For a list of all members of this type, see Grouping members.

Public Events

 | Name | Description
Public Event | PropertyChanged |
Top

See Also

Reference

Grouping Class
Telerik.Reporting.Data Namespace


PropertyChanged Event

PropertyChanged Event
[image]
Telerik.Reporting.Data Namespace > Grouping Class : PropertyChanged Event

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged() As PropertyChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grouping
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
C#
public event PropertyChangedEventHandler PropertyChanged()

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged() As PropertyChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grouping
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
C#
public event PropertyChangedEventHandler PropertyChanged()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grouping Class
Grouping Members


GroupingCollection Class

GroupingCollection Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : GroupingCollection Class

Object Model

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class GroupingCollection
   Inherits Collection(Of Grouping)
Visual Basic (Usage) Copy Code
Dim instance As GroupingCollection
C#
public class GroupingCollection : Collection<Grouping>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<Grouping>
Telerik.Reporting.Data.GroupingCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupingCollection Members
Telerik.Reporting.Data Namespace


GroupingCollection Class Members

GroupingCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Data Namespace : GroupingCollection Class

The following tables list the members exposed by GroupingCollection.

Public Constructors

 | Name | Description
Public Constructor | GroupingCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange | Overloaded.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Top

See Also

Reference

GroupingCollection Class
Telerik.Reporting.Data Namespace


GroupingCollection Constructor

GroupingCollection Constructor
[image]
Telerik.Reporting.Data Namespace > GroupingCollection Class : GroupingCollection Constructor

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupingCollection()
C#
public GroupingCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupingCollection()
C#
public GroupingCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupingCollection Class
GroupingCollection Members


GroupingCollection Class Methods

GroupingCollection Class Methods
[image]
Telerik.Reporting.Data Namespace : GroupingCollection Class

For a list of all members of this type, see GroupingCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange | Overloaded.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Top

See Also

Reference

GroupingCollection Class
Telerik.Reporting.Data Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Data Namespace > GroupingCollection Class : Add Method

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Add(String) |
Add(GroupExpression) |
Add(Grouping) | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)

Overload List

Overload | Description
Add(String) |
Add(GroupExpression) |
Add(Grouping) | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupingCollection Class
GroupingCollection Members


Add(String) Method

Add(String) Method
[image]
Telerik.Reporting.Data Namespace > GroupingCollection Class > Add Method : Add(String) Method

expression

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal expression As String _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupingCollection
Dim expression As String

instance.Add(expression)
C#
public void Add(
   string expression
)

Parameters

expression

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupingCollection Class
GroupingCollection Members
Overload List


Add(GroupExpression) Method

Add(GroupExpression) Method
[image]
Telerik.Reporting.Data Namespace > GroupingCollection Class > Add Method : Add(GroupExpression) Method

item

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal item As GroupExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupingCollection
Dim item As GroupExpression

instance.Add(item)
C#
public void Add(
   GroupExpression item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupingCollection Class
GroupingCollection Members
Overload List


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Data Namespace > GroupingCollection Class : AddRange Method

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
AddRange(Grouping[]) |
AddRange(GroupExpression) |
AddRange(GroupExpression[]) |

Overload List

Overload | Description
AddRange(Grouping[]) |
AddRange(GroupExpression) |
AddRange(GroupExpression[]) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupingCollection Class
GroupingCollection Members


AddRange(Grouping[]) Method

AddRange(Grouping[]) Method
[image]
Telerik.Reporting.Data Namespace > GroupingCollection Class > AddRange Method : AddRange(Grouping[]) Method

items

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddRange( _
   ByVal items() As Grouping _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupingCollection
Dim items() As Grouping

instance.AddRange(items)
C#
public void AddRange(
   Grouping[] items
)

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupingCollection Class
GroupingCollection Members
Overload List


AddRange(GroupExpression) Method

AddRange(GroupExpression) Method
[image]
Telerik.Reporting.Data Namespace > GroupingCollection Class > AddRange Method : AddRange(GroupExpression) Method

item

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddRange( _
   ByVal item As GroupExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupingCollection
Dim item As GroupExpression

instance.AddRange(item)
C#
public void AddRange(
   GroupExpression item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupingCollection Class
GroupingCollection Members
Overload List


AddRange(GroupExpression[]) Method

AddRange(GroupExpression[]) Method
[image]
Telerik.Reporting.Data Namespace > GroupingCollection Class > AddRange Method : AddRange(GroupExpression[]) Method

items

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddRange( _
   ByVal items() As GroupExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupingCollection
Dim items() As GroupExpression

instance.AddRange(items)
C#
public void AddRange(
   GroupExpression[] items
)

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupingCollection Class
GroupingCollection Members
Overload List


SortExpression Class

SortExpression Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : SortExpression Class

Represents an expression used for sorting by a field name and a sort order.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class SortExpression
Visual Basic (Usage) Copy Code
Dim instance As SortExpression
C#
public class SortExpression

Inheritance Hierarchy

System.Object
Telerik.Reporting.Data.SortExpression

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpression Members
Telerik.Reporting.Data Namespace


SortExpression Class Members

SortExpression Class Members
See Also Properties
[image]
Telerik.Reporting.Data Namespace : SortExpression Class

The following tables list the members exposed by SortExpression.

Public Constructors

 | Name | Description
Public Constructor | SortExpression Constructor | Overloaded. Initializes a new instance of the SortExpression with an empty field name.
Top

Public Properties

 | Name | Description
Public Property | FieldName | Gets or sets the field name of this SortExpression
Public Property | SortOrder | Gets or sets the sort order of this SortExpression
Top

See Also

Reference

SortExpression Class
Telerik.Reporting.Data Namespace


SortExpression Constructor

SortExpression Constructor
[image]
Telerik.Reporting.Data Namespace > SortExpression Class : SortExpression Constructor

Initializes a new instance of the SortExpression with an empty field name.

Overload List

Overload | Description
SortExpression Constructor() | Initializes a new instance of the SortExpression with an empty field name.
SortExpression Constructor(String) |
SortExpression Constructor(String,SortOrder) |

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpression Class
SortExpression Members


SortExpression Constructor()

SortExpression Constructor()
See Also
[image]
Telerik.Reporting.Data Namespace > SortExpression Class > SortExpression Constructor : SortExpression Constructor()

Initializes a new instance of the SortExpression with an empty field name.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SortExpression()
C#
public SortExpression()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SortExpression()
C#
public SortExpression()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpression Class
SortExpression Members
Overload List


SortExpression Constructor(String)

SortExpression Constructor(String)
See Also
[image]
Telerik.Reporting.Data Namespace > SortExpression Class > SortExpression Constructor : SortExpression Constructor(String)

fieldName

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fieldName As String _
)
Visual Basic (Usage) Copy Code
Dim fieldName As String

Dim instance As SortExpression(fieldName)
C#
public SortExpression(
   string fieldName
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fieldName As String _
)
Visual Basic (Usage) Copy Code
Dim fieldName As String

Dim instance As SortExpression(fieldName)
C#
public SortExpression(
   string fieldName
)

Parameters

fieldName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpression Class
SortExpression Members
Overload List


SortExpression Constructor(String,SortOrder)

SortExpression Constructor(String,SortOrder)
See Also
[image]
Telerik.Reporting.Data Namespace > SortExpression Class > SortExpression Constructor : SortExpression Constructor(String,SortOrder)

fieldName
sortOrder

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fieldName As String, _
   ByVal sortOrder As SortOrder _
)
Visual Basic (Usage) Copy Code
Dim fieldName As String
Dim sortOrder As SortOrder

Dim instance As SortExpression(fieldName, sortOrder)
C#
public SortExpression(
   string fieldName,
   SortOrder sortOrder
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fieldName As String, _
   ByVal sortOrder As SortOrder _
)
Visual Basic (Usage) Copy Code
Dim fieldName As String
Dim sortOrder As SortOrder

Dim instance As SortExpression(fieldName, sortOrder)
C#
public SortExpression(
   string fieldName,
   SortOrder sortOrder
)

Parameters

fieldName
sortOrder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpression Class
SortExpression Members
Overload List


SortExpression Class Properties

SortExpression Class Properties
[image]
Telerik.Reporting.Data Namespace : SortExpression Class

For a list of all members of this type, see SortExpression members.

Public Properties

 | Name | Description
Public Property | FieldName | Gets or sets the field name of this SortExpression
Public Property | SortOrder | Gets or sets the sort order of this SortExpression
Top

See Also

Reference

SortExpression Class
Telerik.Reporting.Data Namespace


FieldName Property

FieldName Property
[image]
Telerik.Reporting.Data Namespace > SortExpression Class : FieldName Property

Gets or sets the field name of this SortExpression

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldName As String
Visual Basic (Usage) Copy Code
Dim instance As SortExpression
Dim value As String

instance.FieldName = value

value = instance.FieldName
C#
public string FieldName {get; set;}

Return Value

A string value representing the field name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpression Class
SortExpression Members


SortOrder Property

SortOrder Property
[image]
Telerik.Reporting.Data Namespace > SortExpression Class : SortOrder Property

Gets or sets the sort order of this SortExpression

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property SortOrder As SortOrder
Visual Basic (Usage) Copy Code
Dim instance As SortExpression
Dim value As SortOrder

instance.SortOrder = value

value = instance.SortOrder
C#
public SortOrder SortOrder {get; set;}

Return Value

A SortOrder value representing the sort order for this sort expression.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpression Class
SortExpression Members


SortExpressionCollection Class

SortExpressionCollection Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : SortExpressionCollection Class

Represents a collection of SortExpression objects.

Object Model

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class SortExpressionCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As SortExpressionCollection
C#
public class SortExpressionCollection : CollectionBase

Remarks

The Add, Remove, and RemoveAt methods enable you to add and remove individual sort expressions from the collection. You can also use the AddRange or Clear methods to add or remove all the sort expressions from the collection. You can determine if a SortExpression is a member of the collection by passing the sort expression into the Contains method. To get the index value of the location of a SortExpression in the collection, pass the item into the IndexOf method.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.Reporting.Data.SortExpressionCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Members
Telerik.Reporting.Data Namespace


SortExpressionCollection Class Members

SortExpressionCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Data Namespace : SortExpressionCollection Class

The following tables list the members exposed by SortExpressionCollection.

Public Constructors

 | Name | Description
Public Constructor | SortExpressionCollection Constructor | Overloaded. Initializes a new instance of the SortExpressionCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns the SortExpression at the specified indexed location in the collection.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the specified sort expression to the sort expression collection.
Public Method | AddRange | Adds an array of sort expressions to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified sort expression is a member of the collection.
Public Method | CopyTo | Copies the entire SortExpressionCollection to the specified array, starting at the specified index of the target array.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified sort expression in the sort expression collection.
Public Method | Insert | Inserts a specified SortExpression object into the SortExpressionCollection at the specified index location.
Public Method | Remove | Removes the specified sort expression from the sort expression collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Public Method | ToArray | Copies the elements of the SortExpressionCollection to a new SortExpression array.
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs additional custom processes when validating a value.
Top

See Also

Reference

SortExpressionCollection Class
Telerik.Reporting.Data Namespace


SortExpressionCollection Constructor

SortExpressionCollection Constructor
[image]
Telerik.Reporting.Data Namespace > SortExpressionCollection Class : SortExpressionCollection Constructor

Initializes a new instance of the SortExpressionCollection class.

Overload List

Overload | Description
SortExpressionCollection Constructor() | Initializes a new instance of the SortExpressionCollection class.
SortExpressionCollection Constructor(SortExpression[]) |

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Class
SortExpressionCollection Members


SortExpressionCollection Constructor()

SortExpressionCollection Constructor()
See Also
[image]
Telerik.Reporting.Data Namespace > SortExpressionCollection Class > SortExpressionCollection Constructor : SortExpressionCollection Constructor()

Initializes a new instance of the SortExpressionCollection class.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SortExpressionCollection()
C#
public SortExpressionCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SortExpressionCollection()
C#
public SortExpressionCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Class
SortExpressionCollection Members
Overload List


SortExpressionCollection Constructor(SortExpression[])

SortExpressionCollection Constructor(SortExpression[])
See Also
[image]
Telerik.Reporting.Data Namespace > SortExpressionCollection Class > SortExpressionCollection Constructor : SortExpressionCollection Constructor(SortExpression[])

items

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items() As SortExpression _
)
Visual Basic (Usage) Copy Code
Dim items() As SortExpression

Dim instance As SortExpressionCollection(items)
C#
public SortExpressionCollection(
   SortExpression[] items
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items() As SortExpression _
)
Visual Basic (Usage) Copy Code
Dim items() As SortExpression

Dim instance As SortExpressionCollection(items)
C#
public SortExpressionCollection(
   SortExpression[] items
)

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Class
SortExpressionCollection Members
Overload List


SortExpressionCollection Class Methods

SortExpressionCollection Class Methods
[image]
Telerik.Reporting.Data Namespace : SortExpressionCollection Class

For a list of all members of this type, see SortExpressionCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds the specified sort expression to the sort expression collection.
Public Method | AddRange | Adds an array of sort expressions to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified sort expression is a member of the collection.
Public Method | CopyTo | Copies the entire SortExpressionCollection to the specified array, starting at the specified index of the target array.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified sort expression in the sort expression collection.
Public Method | Insert | Inserts a specified SortExpression object into the SortExpressionCollection at the specified index location.
Public Method | Remove | Removes the specified sort expression from the sort expression collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Public Method | ToArray | Copies the elements of the SortExpressionCollection to a new SortExpression array.
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs additional custom processes when validating a value.
Top

See Also

Reference

SortExpressionCollection Class
Telerik.Reporting.Data Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Data Namespace > SortExpressionCollection Class : Add Method

item
The SortExpression to add to the sort expression collection.
Adds the specified sort expression to the sort expression collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal item As SortExpression _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SortExpressionCollection
Dim item As SortExpression
Dim value As Integer

value = instance.Add(item)
C#
public int Add(
   SortExpression item
)

Parameters

item
The SortExpression to add to the sort expression collection.

Return Value

The index of the added SortExpression

Remarks

The Add method allows you to add SortExpression objects to the end of the sort expression collection.

You can also add new SortExpression objects to the collection by using the AddRange method.

To remove a SortExpression that you previously added, use the Remove, RemoveAt, or Clear methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Class
SortExpressionCollection Members


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Data Namespace > SortExpressionCollection Class : AddRange Method

items
An array of SortExpression objects to add to the collection.
Adds an array of sort expressions to the collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal items() As SortExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As SortExpressionCollection
Dim items() As SortExpression

instance.AddRange(items)
C#
public void AddRange(
   SortExpression[] items
)

Parameters

items
An array of SortExpression objects to add to the collection.

Remarks

The SortExpression objects contained in the items array are appended to the end of the collection.

You can use the AddRange method to quickly add a sort of SortExpression objects to the collection instead of manually adding each SortExpression to the collection using the Add method.

To remove a SortExpression that you previously added, use the Remove, RemoveAt, or Clear methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Class
SortExpressionCollection Members


Contains Method

Contains Method
[image]
Telerik.Reporting.Data Namespace > SortExpressionCollection Class : Contains Method

item
The SortExpression to locate in the collection.
Determines whether the specified sort expression is a member of the collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As SortExpression _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SortExpressionCollection
Dim item As SortExpression
Dim value As Boolean

value = instance.Contains(item)
C#
public bool Contains(
   SortExpression item
)

Parameters

item
The SortExpression to locate in the collection.

Return Value

true if the SortExpression is a member of the collection; otherwise, false.

Remarks

This method enables you to determine whether a SortExpression is a member of the collection before attempting to perform operations on the SortExpression. You can use this method to confirm that an SortExpression has been added to or is still a member of the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Class
SortExpressionCollection Members


CopyTo Method

CopyTo Method
[image]
Telerik.Reporting.Data Namespace > SortExpressionCollection Class : CopyTo Method

array
The one-dimensional array that is the destination of the elements copied from SortExpressionCollection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the entire SortExpressionCollection to the specified array, starting at the specified index of the target array.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As SortExpression, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As SortExpressionCollection
Dim array() As SortExpression
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   SortExpression[] array,
   int index
)

Parameters

array
The one-dimensional array that is the destination of the elements copied from SortExpressionCollection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Class
SortExpressionCollection Members


IndexOf Method

IndexOf Method
[image]
Telerik.Reporting.Data Namespace > SortExpressionCollection Class : IndexOf Method

item
The SortExpression to locate in the collection.
Retrieves the index of the specified sort expression in the sort expression collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As SortExpression _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SortExpressionCollection
Dim item As SortExpression
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   SortExpression item
)

Parameters

item
The SortExpression to locate in the collection.

Return Value

A zero-based index value that represents the position of the specified SortExpression in the SortExpressionCollection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Class
SortExpressionCollection Members


Insert Method

Insert Method
[image]
Telerik.Reporting.Data Namespace > SortExpressionCollection Class : Insert Method

index
The zero-based index location at which to insert the SortExpression object.
item
The SortExpression object to insert into the collection.
Inserts a specified SortExpression object into the SortExpressionCollection at the specified index location.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As SortExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As SortExpressionCollection
Dim index As Integer
Dim item As SortExpression

instance.Insert(index, item)
C#
public void Insert(
   int index,
   SortExpression item
)

Parameters

index
The zero-based index location at which to insert the SortExpression object.
item
The SortExpression object to insert into the collection.

Remarks

Use the Insert method to insert a specified SortExpression object into the SortExpressionCollection object at a specified index location.

To add a SortExpression object at the end of the SortExpressionCollection object, use the Add method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Class
SortExpressionCollection Members


OnValidate Method

OnValidate Method
[image]
Telerik.Reporting.Data Namespace > SortExpressionCollection Class : OnValidate Method

value
The object to validate.
Performs additional custom processes when validating a value.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnValidate( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SortExpressionCollection
Dim value As Object

instance.OnValidate(value)
C#
protected override void OnValidate(
   object value
)

Parameters

value
The object to validate.

Exceptions

Exception | Description
ArgumentException | The object is not a SortExpression.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Class
SortExpressionCollection Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Data Namespace > SortExpressionCollection Class : Remove Method

item
The SortExpression to remove from the SortExpressionCollection.
Removes the specified sort expression from the sort expression collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As SortExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As SortExpressionCollection
Dim item As SortExpression

instance.Remove(item)
C#
public void Remove(
   SortExpression item
)

Parameters

item
The SortExpression to remove from the SortExpressionCollection.

Remarks

When a SortExpression is removed from the sort expression collection, all subsequent sort expressions are moved up one position in the collection.

You can also remove a SortExpression by using the RemoveAt method, or remove all sort expressions by using the Clear method.

To add new SortExpression objects to the collection, use the Add or AddRange methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Class
SortExpressionCollection Members


ToArray Method

ToArray Method
[image]
Telerik.Reporting.Data Namespace > SortExpressionCollection Class : ToArray Method

Copies the elements of the SortExpressionCollection to a new SortExpression array.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function ToArray() As SortExpression()
Visual Basic (Usage) Copy Code
Dim instance As SortExpressionCollection
Dim value() As SortExpression

value = instance.ToArray()
C#
public SortExpression[] ToArray()

Return Value

An SortExpression array containing copies of the elements of the SortExpressionCollection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Class
SortExpressionCollection Members


SortExpressionCollection Class Properties

SortExpressionCollection Class Properties
[image]
Telerik.Reporting.Data Namespace : SortExpressionCollection Class

For a list of all members of this type, see SortExpressionCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns the SortExpression at the specified indexed location in the collection.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

SortExpressionCollection Class
Telerik.Reporting.Data Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Data Namespace > SortExpressionCollection Class : Item Property

index
The index of the sort expression to retrieve from the sort expression collection.
Returns the SortExpression at the specified indexed location in the collection.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As SortExpression
Visual Basic (Usage) Copy Code
Dim instance As SortExpressionCollection
Dim index As Integer
Dim value As SortExpression

instance.Item(index) = value

value = instance.Item(index)
C#
public SortExpression this[
   int index
]; {get; set;}

Parameters

index
The index of the sort expression to retrieve from the sort expression collection.

Return Value

The SortExpression located at the specified index location within the sort expression collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortExpressionCollection Class
SortExpressionCollection Members


Sorting Class

Sorting Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : Sorting Class

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Sorting
Visual Basic (Usage) Copy Code
Dim instance As Sorting
C#
public class Sorting

Inheritance Hierarchy

System.Object
Telerik.Reporting.Data.Sorting

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Sorting Members
Telerik.Reporting.Data Namespace


Sorting Class Members

Sorting Class Members
See Also Properties Events
[image]
Telerik.Reporting.Data Namespace : Sorting Class

The following tables list the members exposed by Sorting.

Public Constructors

 | Name | Description
Public Constructor | Sorting Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Direction |
Public Property | Expression |
Public Property | IsEmpty |
Top

Public Events

 | Name | Description
Public Event | PropertyChanged |
Top

See Also

Reference

Sorting Class
Telerik.Reporting.Data Namespace


Sorting Constructor

Sorting Constructor
[image]
Telerik.Reporting.Data Namespace > Sorting Class : Sorting Constructor

Overload List

Overload | Description
Sorting Constructor() |
Sorting Constructor(String) |
Sorting Constructor(String,SortDirection) |

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Sorting Class
Sorting Members


Sorting Constructor()

Sorting Constructor()
See Also
[image]
Telerik.Reporting.Data Namespace > Sorting Class > Sorting Constructor : Sorting Constructor()

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Sorting()
C#
public Sorting()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Sorting()
C#
public Sorting()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Sorting Class
Sorting Members
Overload List


Sorting Constructor(String)

Sorting Constructor(String)
See Also
[image]
Telerik.Reporting.Data Namespace > Sorting Class > Sorting Constructor : Sorting Constructor(String)

expression

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String _
)
Visual Basic (Usage) Copy Code
Dim expression As String

Dim instance As Sorting(expression)
C#
public Sorting(
   string expression
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String _
)
Visual Basic (Usage) Copy Code
Dim expression As String

Dim instance As Sorting(expression)
C#
public Sorting(
   string expression
)

Parameters

expression

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Sorting Class
Sorting Members
Overload List


Sorting Constructor(String,SortDirection)

Sorting Constructor(String,SortDirection)
See Also
[image]
Telerik.Reporting.Data Namespace > Sorting Class > Sorting Constructor : Sorting Constructor(String,SortDirection)

expression
direction

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String, _
   ByVal direction As SortDirection _
)
Visual Basic (Usage) Copy Code
Dim expression As String
Dim direction As SortDirection

Dim instance As Sorting(expression, direction)
C#
public Sorting(
   string expression,
   SortDirection direction
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal expression As String, _
   ByVal direction As SortDirection _
)
Visual Basic (Usage) Copy Code
Dim expression As String
Dim direction As SortDirection

Dim instance As Sorting(expression, direction)
C#
public Sorting(
   string expression,
   SortDirection direction
)

Parameters

expression
direction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Sorting Class
Sorting Members
Overload List


Sorting Class Properties

Sorting Class Properties
[image]
Telerik.Reporting.Data Namespace : Sorting Class

For a list of all members of this type, see Sorting members.

Public Properties

 | Name | Description
Public Property | Direction |
Public Property | Expression |
Public Property | IsEmpty |
Top

See Also

Reference

Sorting Class
Telerik.Reporting.Data Namespace


Direction Property

Direction Property
[image]
Telerik.Reporting.Data Namespace > Sorting Class : Direction Property

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Direction As SortDirection
Visual Basic (Usage) Copy Code
Dim instance As Sorting
Dim value As SortDirection

instance.Direction = value

value = instance.Direction
C#
public SortDirection Direction {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Sorting Class
Sorting Members


Expression Property

Expression Property
[image]
Telerik.Reporting.Data Namespace > Sorting Class : Expression Property

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Expression As String
Visual Basic (Usage) Copy Code
Dim instance As Sorting
Dim value As String

instance.Expression = value

value = instance.Expression
C#
public string Expression {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Sorting Class
Sorting Members


IsEmpty Property

IsEmpty Property
[image]
Telerik.Reporting.Data Namespace > Sorting Class : IsEmpty Property

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Sorting
Dim value As Boolean

value = instance.IsEmpty
C#
public bool IsEmpty {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Sorting Class
Sorting Members


Sorting Class Events

Sorting Class Events
[image]
Telerik.Reporting.Data Namespace : Sorting Class

For a list of all members of this type, see Sorting members.

Public Events

 | Name | Description
Public Event | PropertyChanged |
Top

See Also

Reference

Sorting Class
Telerik.Reporting.Data Namespace


PropertyChanged Event

PropertyChanged Event
[image]
Telerik.Reporting.Data Namespace > Sorting Class : PropertyChanged Event

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged() As PropertyChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Sorting
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
C#
public event PropertyChangedEventHandler PropertyChanged()

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged() As PropertyChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Sorting
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
C#
public event PropertyChangedEventHandler PropertyChanged()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Sorting Class
Sorting Members


SortingCollection Class

SortingCollection Class
See Also Members
[image]
Telerik.Reporting.Data Namespace : SortingCollection Class

Object Model

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class SortingCollection
   Inherits Collection(Of Sorting)
Visual Basic (Usage) Copy Code
Dim instance As SortingCollection
C#
public class SortingCollection : Collection<Sorting>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<Sorting>
Telerik.Reporting.Data.SortingCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortingCollection Members
Telerik.Reporting.Data Namespace


SortingCollection Class Members

SortingCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Data Namespace : SortingCollection Class

The following tables list the members exposed by SortingCollection.

Public Constructors

 | Name | Description
Public Constructor | SortingCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange | Overloaded.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Top

See Also

Reference

SortingCollection Class
Telerik.Reporting.Data Namespace


SortingCollection Constructor

SortingCollection Constructor
[image]
Telerik.Reporting.Data Namespace > SortingCollection Class : SortingCollection Constructor

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SortingCollection()
C#
public SortingCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SortingCollection()
C#
public SortingCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortingCollection Class
SortingCollection Members


SortingCollection Class Methods

SortingCollection Class Methods
[image]
Telerik.Reporting.Data Namespace : SortingCollection Class

For a list of all members of this type, see SortingCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange | Overloaded.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Top

See Also

Reference

SortingCollection Class
Telerik.Reporting.Data Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Data Namespace > SortingCollection Class : Add Method

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Add(String,SortDirection) |
Add(SortExpression) |
Add(Sorting) | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)

Overload List

Overload | Description
Add(String,SortDirection) |
Add(SortExpression) |
Add(Sorting) | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortingCollection Class
SortingCollection Members


Add(String,SortDirection) Method

Add(String,SortDirection) Method
[image]
Telerik.Reporting.Data Namespace > SortingCollection Class > Add Method : Add(String,SortDirection) Method

expression
dir

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal expression As String, _
   ByVal dir As SortDirection _
)
Visual Basic (Usage) Copy Code
Dim instance As SortingCollection
Dim expression As String
Dim dir As SortDirection

instance.Add(expression, dir)
C#
public void Add(
   string expression,
   SortDirection dir
)

Parameters

expression
dir

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortingCollection Class
SortingCollection Members
Overload List


Add(SortExpression) Method

Add(SortExpression) Method
[image]
Telerik.Reporting.Data Namespace > SortingCollection Class > Add Method : Add(SortExpression) Method

item

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal item As SortExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As SortingCollection
Dim item As SortExpression

instance.Add(item)
C#
public void Add(
   SortExpression item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortingCollection Class
SortingCollection Members
Overload List


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Data Namespace > SortingCollection Class : AddRange Method

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
AddRange(Sorting[]) |
AddRange(SortExpression[]) |

Overload List

Overload | Description
AddRange(Sorting[]) |
AddRange(SortExpression[]) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortingCollection Class
SortingCollection Members


AddRange(Sorting[]) Method

AddRange(Sorting[]) Method
[image]
Telerik.Reporting.Data Namespace > SortingCollection Class > AddRange Method : AddRange(Sorting[]) Method

items

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddRange( _
   ByVal items() As Sorting _
)
Visual Basic (Usage) Copy Code
Dim instance As SortingCollection
Dim items() As Sorting

instance.AddRange(items)
C#
public void AddRange(
   Sorting[] items
)

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortingCollection Class
SortingCollection Members
Overload List


AddRange(SortExpression[]) Method

AddRange(SortExpression[]) Method
[image]
Telerik.Reporting.Data Namespace > SortingCollection Class > AddRange Method : AddRange(SortExpression[]) Method

items

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddRange( _
   ByVal items() As SortExpression _
)
Visual Basic (Usage) Copy Code
Dim instance As SortingCollection
Dim items() As SortExpression

instance.AddRange(items)
C#
public void AddRange(
   SortExpression[] items
)

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SortingCollection Class
SortingCollection Members
Overload List


AttributeSelector Class

AttributeSelector Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : AttributeSelector Class

Represents a selector that matches a property value of a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class AttributeSelector
   Inherits AttributeSelectorBase
   Implements ISelector
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelector
C#
public class AttributeSelector : AttributeSelectorBase, ISelector

Remarks

Selectors are defined for each StyleRule in the Report.StyleSheet.

AttributeSelector should be used when you want to match all report items of a certain Type that have a property set to a certain value.

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.TypeSelector
Telerik.Reporting.Drawing.AttributeSelectorBase
Telerik.Reporting.Drawing.AttributeSelector

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelector Members
Telerik.Reporting.Drawing Namespace


AttributeSelector Class Members

AttributeSelector Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : AttributeSelector Class

The following tables list the members exposed by AttributeSelector.

Public Constructors

 | Name | Description
Public Constructor | AttributeSelector Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | attributeName | The name of the property to match. (Inherited from AttributeSelectorBase)
Protected Field | attributeValue | The value of the property to match. (Inherited from AttributeSelectorBase)
Protected Field | descriptor | The property descriptor associated with the property that this selector matches. (Inherited from AttributeSelectorBase)
Protected Field | initialized | (Inherited from TypeSelector)
Top

Public Properties

 | Name | Description
Public Property | PropertyName | Gets or sets the name of the property to match.
Public Property | PropertyValue | Gets or sets the value of the property to match.
Public Property | Type | Gets or sets the Type that this selector matches. (Inherited from TypeSelector)
Top

Public Methods

 | Name | Description
Public Method | DeepClone | Performs a deep clone of the TypeSelector. (Inherited from TypeSelector)
Public Method | Match | Matches a report item by the value of its property. (Inherited from AttributeSelectorBase)
Public Method | ToString | Overridden. This member overrides ToString
Top

Protected Methods

 | Name | Description
Protected Method | CopyTo | Copies the property name and value of the selector to the target typeSelector. (Inherited from AttributeSelectorBase)
Protected Method | OnTypeChange | Overridden. This member overrides TypeSelector.OnTypeChange. The method resets the selector.
Protected Method | ReadXml | Overridden.
Protected Method | WriteXml | Overridden.
Top

See Also

Reference

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


AttributeSelector Constructor

AttributeSelector Constructor
[image]
Telerik.Reporting.Drawing Namespace > AttributeSelector Class : AttributeSelector Constructor

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelector()
C#
public AttributeSelector()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelector()
C#
public AttributeSelector()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelector Class
AttributeSelector Members


AttributeSelector Class Methods

AttributeSelector Class Methods
[image]
Telerik.Reporting.Drawing Namespace : AttributeSelector Class

For a list of all members of this type, see AttributeSelector members.

Public Methods

 | Name | Description
Public Method | DeepClone | Performs a deep clone of the TypeSelector. (Inherited from TypeSelector)
Public Method | Match | Matches a report item by the value of its property. (Inherited from AttributeSelectorBase)
Public Method | ToString | Overridden. This member overrides ToString
Top

Protected Methods

 | Name | Description
Protected Method | CopyTo | Copies the property name and value of the selector to the target typeSelector. (Inherited from AttributeSelectorBase)
Protected Method | OnTypeChange | Overridden. This member overrides TypeSelector.OnTypeChange. The method resets the selector.
Protected Method | ReadXml | Overridden.
Protected Method | WriteXml | Overridden.
Top

See Also

Reference

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


OnTypeChange Method

OnTypeChange Method
[image]
Telerik.Reporting.Drawing Namespace > AttributeSelector Class : OnTypeChange Method

This member overrides TypeSelector.OnTypeChange. The method resets the selector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnTypeChange()
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelector

instance.OnTypeChange()
C#
protected override void OnTypeChange()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelector Class
AttributeSelector Members


ReadXml Method

ReadXml Method
[image]
Telerik.Reporting.Drawing Namespace > AttributeSelector Class : ReadXml Method

reader

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ReadXml( _
   ByVal reader As XmlReader _
)
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelector
Dim reader As XmlReader

instance.ReadXml(reader)
C#
protected override void ReadXml(
   XmlReader reader
)

Parameters

reader

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelector Class
AttributeSelector Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing Namespace > AttributeSelector Class : ToString Method

This member overrides ToString

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelector
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A string value describing the selector.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelector Class
AttributeSelector Members


WriteXml Method

WriteXml Method
[image]
Telerik.Reporting.Drawing Namespace > AttributeSelector Class : WriteXml Method

writer

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub WriteXml( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelector
Dim writer As XmlWriter

instance.WriteXml(writer)
C#
protected override void WriteXml(
   XmlWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelector Class
AttributeSelector Members


AttributeSelector Class Properties

AttributeSelector Class Properties
[image]
Telerik.Reporting.Drawing Namespace : AttributeSelector Class

For a list of all members of this type, see AttributeSelector members.

Public Properties

 | Name | Description
Public Property | PropertyName | Gets or sets the name of the property to match.
Public Property | PropertyValue | Gets or sets the value of the property to match.
Public Property | Type | Gets or sets the Type that this selector matches. (Inherited from TypeSelector)
Top

See Also

Reference

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


PropertyName Property

PropertyName Property
[image]
Telerik.Reporting.Drawing Namespace > AttributeSelector Class : PropertyName Property

Gets or sets the name of the property to match.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyName As String
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelector
Dim value As String

instance.PropertyName = value

value = instance.PropertyName
C#
public string PropertyName {get; set;}

Return Value

The name of the property to match.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelector Class
AttributeSelector Members


PropertyValue Property

PropertyValue Property
[image]
Telerik.Reporting.Drawing Namespace > AttributeSelector Class : PropertyValue Property

Gets or sets the value of the property to match.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyValue As Object
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelector
Dim value As Object

instance.PropertyValue = value

value = instance.PropertyValue
C#
public object PropertyValue {get; set;}

Return Value

The value of the property to match.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelector Class
AttributeSelector Members


AttributeSelectorBase Class

AttributeSelectorBase Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : AttributeSelectorBase Class

Provides the abstract base class for an attribute selector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class AttributeSelectorBase
   Inherits TypeSelector
   Implements ISelector
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelectorBase
C#
public abstract class AttributeSelectorBase : TypeSelector, ISelector

Remarks

Selectors are defined for each StyleRule in the Report.StyleSheet.

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.TypeSelector
Telerik.Reporting.Drawing.AttributeSelectorBase
Telerik.Reporting.Drawing.AttributeSelector
Telerik.Reporting.Drawing.StyleSelector

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelectorBase Members
Telerik.Reporting.Drawing Namespace


AttributeSelectorBase Class Members

AttributeSelectorBase Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : AttributeSelectorBase Class

The following tables list the members exposed by AttributeSelectorBase.

Protected Fields

 | Name | Description
Protected Field | attributeName | The name of the property to match.
Protected Field | attributeValue | The value of the property to match.
Protected Field | descriptor | The property descriptor associated with the property that this selector matches.
Protected Field | initialized | (Inherited from TypeSelector)
Top

Public Properties

 | Name | Description
Public Property | Type | Gets or sets the Type that this selector matches. (Inherited from TypeSelector)
Top

Public Methods

 | Name | Description
Public Method | DeepClone | Performs a deep clone of the TypeSelector. (Inherited from TypeSelector)
Public Method | Match | Overridden. Matches a report item by the value of its property.
Public Method | ToString | Creates a human-readable string that represents this TypeSelector. (Inherited from TypeSelector)
Top

Protected Methods

 | Name | Description
Protected Method | CopyTo | Overridden. Copies the property name and value of the selector to the target typeSelector.
Protected Method | OnTypeChange | Called when the TypeSelector.Type of this selector changes. (Inherited from TypeSelector)
Protected Method | ReadXml | (Inherited from TypeSelector)
Protected Method | WriteXml | (Inherited from TypeSelector)
Top

See Also

Reference

AttributeSelectorBase Class
Telerik.Reporting.Drawing Namespace


AttributeSelectorBase Class Methods

AttributeSelectorBase Class Methods
[image]
Telerik.Reporting.Drawing Namespace : AttributeSelectorBase Class

For a list of all members of this type, see AttributeSelectorBase members.

Public Methods

 | Name | Description
Public Method | DeepClone | Performs a deep clone of the TypeSelector. (Inherited from TypeSelector)
Public Method | Match | Overridden. Matches a report item by the value of its property.
Public Method | ToString | Creates a human-readable string that represents this TypeSelector. (Inherited from TypeSelector)
Top

Protected Methods

 | Name | Description
Protected Method | CopyTo | Overridden. Copies the property name and value of the selector to the target typeSelector.
Protected Method | OnTypeChange | Called when the TypeSelector.Type of this selector changes. (Inherited from TypeSelector)
Protected Method | ReadXml | (Inherited from TypeSelector)
Protected Method | WriteXml | (Inherited from TypeSelector)
Top

See Also

Reference

AttributeSelectorBase Class
Telerik.Reporting.Drawing Namespace


CopyTo Method

CopyTo Method
[image]
Telerik.Reporting.Drawing Namespace > AttributeSelectorBase Class : CopyTo Method

typeSelector
The TypeSelector to copy to.
Copies the property name and value of the selector to the target typeSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub CopyTo( _
   ByVal typeSelector As TypeSelector _
)
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelectorBase
Dim typeSelector As TypeSelector

instance.CopyTo(typeSelector)
C#
protected override void CopyTo(
   TypeSelector typeSelector
)

Parameters

typeSelector
The TypeSelector to copy to.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelectorBase Class
AttributeSelectorBase Members


Match Method

Match Method
[image]
Telerik.Reporting.Drawing Namespace > AttributeSelectorBase Class : Match Method

item
The ReportItemBase to match.
Matches a report item by the value of its property.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function Match( _
   ByVal item As ReportItemBase _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelectorBase
Dim item As ReportItemBase
Dim value As Boolean

value = instance.Match(item)
C#
public override bool Match(
   ReportItemBase item
)

Parameters

item
The ReportItemBase to match.

Return Value

true if the item's property value matches.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelectorBase Class
AttributeSelectorBase Members


AttributeSelectorBase Class Fields

AttributeSelectorBase Class Fields
[image]
Telerik.Reporting.Drawing Namespace : AttributeSelectorBase Class

For a list of all members of this type, see AttributeSelectorBase members.

Protected Fields

 | Name | Description
Protected Field | attributeName | The name of the property to match.
Protected Field | attributeValue | The value of the property to match.
Protected Field | descriptor | The property descriptor associated with the property that this selector matches.
Protected Field | initialized | (Inherited from TypeSelector)
Top

See Also

Reference

AttributeSelectorBase Class
Telerik.Reporting.Drawing Namespace


attributeName Field

attributeName Field
[image]
Telerik.Reporting.Drawing Namespace > AttributeSelectorBase Class : attributeName Field

The name of the property to match.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected attributeName As String
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelectorBase
Dim value As String

value = instance.attributeName

instance.attributeName = value
C#
protected string attributeName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelectorBase Class
AttributeSelectorBase Members


attributeValue Field

attributeValue Field
[image]
Telerik.Reporting.Drawing Namespace > AttributeSelectorBase Class : attributeValue Field

The value of the property to match.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected attributeValue As Object
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelectorBase
Dim value As Object

value = instance.attributeValue

instance.attributeValue = value
C#
protected object attributeValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelectorBase Class
AttributeSelectorBase Members


descriptor Field

descriptor Field
[image]
Telerik.Reporting.Drawing Namespace > AttributeSelectorBase Class : descriptor Field

The property descriptor associated with the property that this selector matches.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected descriptor As PropertyDescriptor
Visual Basic (Usage) Copy Code
Dim instance As AttributeSelectorBase
Dim value As PropertyDescriptor

value = instance.descriptor

instance.descriptor = value
C#
protected PropertyDescriptor descriptor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AttributeSelectorBase Class
AttributeSelectorBase Members


BackgroundImage Class

BackgroundImage Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : BackgroundImage Class

Represents a background image associated with a Style

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class BackgroundImage
   Inherits StyleBase
Visual Basic (Usage) Copy Code
Dim instance As BackgroundImage
C#
public class BackgroundImage : StyleBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.StyleBase
Telerik.Reporting.Drawing.BackgroundImage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BackgroundImage Members
Telerik.Reporting.Drawing Namespace


BackgroundImage Class Members

BackgroundImage Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : BackgroundImage Class

The following tables list the members exposed by BackgroundImage.

Public Constructors

 | Name | Description
Public Constructor | BackgroundImage Constructor | Initializes a new instance of the BackgroundImage class as a member of the given Style
Top

Public Properties

 | Name | Description
Public Property | ImageData | Gets or sets a Image containing the image data of this BackgroundImage.
Public Property | MimeType | Gets or sets the MIME type of the current BackgroundImage object.
Public Property | Repeat | Gets or sets a BackgroundRepeat value defining the repeat style of the BackgroundImage.
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

BackgroundImage Class
Telerik.Reporting.Drawing Namespace


BackgroundImage Constructor

BackgroundImage Constructor
[image]
Telerik.Reporting.Drawing Namespace > BackgroundImage Class : BackgroundImage Constructor

style
A Style value representing the parent style of the BackgroundImage.
Initializes a new instance of the BackgroundImage class as a member of the given Style

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As Style _
)
Visual Basic (Usage) Copy Code
Dim style As Style

Dim instance As BackgroundImage(style)
C#
public BackgroundImage(
   Style style
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As Style _
)
Visual Basic (Usage) Copy Code
Dim style As Style

Dim instance As BackgroundImage(style)
C#
public BackgroundImage(
   Style style
)

Parameters

style
A Style value representing the parent style of the BackgroundImage.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BackgroundImage Class
BackgroundImage Members


BackgroundImage Class Properties

BackgroundImage Class Properties
[image]
Telerik.Reporting.Drawing Namespace : BackgroundImage Class

For a list of all members of this type, see BackgroundImage members.

Public Properties

 | Name | Description
Public Property | ImageData | Gets or sets a Image containing the image data of this BackgroundImage.
Public Property | MimeType | Gets or sets the MIME type of the current BackgroundImage object.
Public Property | Repeat | Gets or sets a BackgroundRepeat value defining the repeat style of the BackgroundImage.
Top

See Also

Reference

BackgroundImage Class
Telerik.Reporting.Drawing Namespace


ImageData Property

ImageData Property
[image]
Telerik.Reporting.Drawing Namespace > BackgroundImage Class : ImageData Property

Gets or sets a Image containing the image data of this BackgroundImage.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageData As Image
Visual Basic (Usage) Copy Code
Dim instance As BackgroundImage
Dim value As Image

instance.ImageData = value

value = instance.ImageData
C#
public Image ImageData {get; set;}

Return Value

A Image objetc containing the image data of this BackgroundImage.

Remarks

Use this property if you want to bind the BackgroundImage to an image that is not in the data source.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BackgroundImage Class
BackgroundImage Members


MimeType Property

MimeType Property
[image]
Telerik.Reporting.Drawing Namespace > BackgroundImage Class : MimeType Property

Gets or sets the MIME type of the current BackgroundImage object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property MimeType As String
Visual Basic (Usage) Copy Code
Dim instance As BackgroundImage
Dim value As String

instance.MimeType = value

value = instance.MimeType
C#
public string MimeType {get; set;}

Return Value

The MIME type of the current BackgroundImage object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BackgroundImage Class
BackgroundImage Members


Repeat Property

Repeat Property
[image]
Telerik.Reporting.Drawing Namespace > BackgroundImage Class : Repeat Property

Gets or sets a BackgroundRepeat value defining the repeat style of the BackgroundImage.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Repeat As BackgroundRepeat
Visual Basic (Usage) Copy Code
Dim instance As BackgroundImage
Dim value As BackgroundRepeat

instance.Repeat = value

value = instance.Repeat
C#
public BackgroundRepeat Repeat {get; set;}

Return Value

A BackgroundRepeat value representing the repeat style of the BackgroundImage.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BackgroundImage Class
BackgroundImage Members


BorderBase Class

BorderBase Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : BorderBase Class

This class supports the Telerik Reporting infrastructure and is not intended to be used directly from your code.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BorderBase
   Inherits StyleBase
Visual Basic (Usage) Copy Code
Dim instance As BorderBase
C#
public abstract class BorderBase : StyleBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.StyleBase
Telerik.Reporting.Drawing.BorderBase
Telerik.Reporting.Drawing.BorderColor
Telerik.Reporting.Drawing.BorderStyle
Telerik.Reporting.Drawing.BorderWidth

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderBase Members
Telerik.Reporting.Drawing Namespace


BorderBase Class Members

BorderBase Class Members
See Also Methods
[image]
Telerik.Reporting.Drawing Namespace : BorderBase Class

The following tables list the members exposed by BorderBase.

Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

BorderBase Class
Telerik.Reporting.Drawing Namespace


BorderBase Class Methods

BorderBase Class Methods
[image]
Telerik.Reporting.Drawing Namespace : BorderBase Class

For a list of all members of this type, see BorderBase members.

Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

BorderBase Class
Telerik.Reporting.Drawing Namespace


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing Namespace > BorderBase Class : ToString Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ToString() |
ToString(String[]) | (Inherited from StyleBase)

Overload List

Overload | Description
ToString() |
ToString(String[]) | (Inherited from StyleBase)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderBase Class
BorderBase Members


ToString() Method

ToString() Method
[image]
Telerik.Reporting.Drawing Namespace > BorderBase Class > ToString Method : ToString() Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As BorderBase
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderBase Class
BorderBase Members
Overload List


BorderColor Class

BorderColor Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : BorderColor Class

A class used to specify the color of the border of an item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class BorderColor
   Inherits BorderBase
Visual Basic (Usage) Copy Code
Dim instance As BorderColor
C#
public class BorderColor : BorderBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.StyleBase
Telerik.Reporting.Drawing.BorderBase
Telerik.Reporting.Drawing.BorderColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderColor Members
Telerik.Reporting.Drawing Namespace


BorderColor Class Members

BorderColor Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : BorderColor Class

The following tables list the members exposed by BorderColor.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom color of the border.
Public Property | Default | Gets or sets the default color of the border.
Public Property | Left | Gets or sets the left color of the border.
Public Property | Right | Gets or sets the right color of the border.
Public Property | Top | Gets or sets the top color of the border.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overloaded. (Inherited from BorderBase)
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

BorderColor Class
Telerik.Reporting.Drawing Namespace


BorderColor Class Properties

BorderColor Class Properties
[image]
Telerik.Reporting.Drawing Namespace : BorderColor Class

For a list of all members of this type, see BorderColor members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom color of the border.
Public Property | Default | Gets or sets the default color of the border.
Public Property | Left | Gets or sets the left color of the border.
Public Property | Right | Gets or sets the right color of the border.
Public Property | Top | Gets or sets the top color of the border.
Top

See Also

Reference

BorderColor Class
Telerik.Reporting.Drawing Namespace


Bottom Property

Bottom Property
[image]
Telerik.Reporting.Drawing Namespace > BorderColor Class : Bottom Property

Gets or sets the bottom color of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Bottom As Color
Visual Basic (Usage) Copy Code
Dim instance As BorderColor
Dim value As Color

instance.Bottom = value

value = instance.Bottom
C#
public Color Bottom {get; set;}

Return Value

The bottom border Color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderColor Class
BorderColor Members


Default Property

Default Property
[image]
Telerik.Reporting.Drawing Namespace > BorderColor Class : Default Property

Gets or sets the default color of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Default As Color
Visual Basic (Usage) Copy Code
Dim instance As BorderColor
Dim value As Color

instance.Default = value

value = instance.Default
C#
public Color Default {get; set;}

Return Value

The default border Color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderColor Class
BorderColor Members


Left Property

Left Property
[image]
Telerik.Reporting.Drawing Namespace > BorderColor Class : Left Property

Gets or sets the left color of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As Color
Visual Basic (Usage) Copy Code
Dim instance As BorderColor
Dim value As Color

instance.Left = value

value = instance.Left
C#
public Color Left {get; set;}

Return Value

The left border Color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderColor Class
BorderColor Members


Right Property

Right Property
[image]
Telerik.Reporting.Drawing Namespace > BorderColor Class : Right Property

Gets or sets the right color of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Right As Color
Visual Basic (Usage) Copy Code
Dim instance As BorderColor
Dim value As Color

instance.Right = value

value = instance.Right
C#
public Color Right {get; set;}

Return Value

The right border Color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderColor Class
BorderColor Members


Top Property

Top Property
[image]
Telerik.Reporting.Drawing Namespace > BorderColor Class : Top Property

Gets or sets the top color of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As Color
Visual Basic (Usage) Copy Code
Dim instance As BorderColor
Dim value As Color

instance.Top = value

value = instance.Top
C#
public Color Top {get; set;}

Return Value

The top border Color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderColor Class
BorderColor Members


BorderStyle Class

BorderStyle Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : BorderStyle Class

A class used to specify the style of the border of an item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class BorderStyle
   Inherits BorderBase
Visual Basic (Usage) Copy Code
Dim instance As BorderStyle
C#
public class BorderStyle : BorderBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.StyleBase
Telerik.Reporting.Drawing.BorderBase
Telerik.Reporting.Drawing.BorderStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderStyle Members
Telerik.Reporting.Drawing Namespace


BorderStyle Class Members

BorderStyle Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : BorderStyle Class

The following tables list the members exposed by BorderStyle.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom style of the border.
Public Property | Default | Gets or sets the default style of the border.
Public Property | Left | Gets or sets the left style of the border.
Public Property | Right | Gets or sets the right style of the border.
Public Property | Top | Gets or sets the top style of the border.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overloaded. (Inherited from BorderBase)
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

BorderStyle Class
Telerik.Reporting.Drawing Namespace


BorderStyle Class Properties

BorderStyle Class Properties
[image]
Telerik.Reporting.Drawing Namespace : BorderStyle Class

For a list of all members of this type, see BorderStyle members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom style of the border.
Public Property | Default | Gets or sets the default style of the border.
Public Property | Left | Gets or sets the left style of the border.
Public Property | Right | Gets or sets the right style of the border.
Public Property | Top | Gets or sets the top style of the border.
Top

See Also

Reference

BorderStyle Class
Telerik.Reporting.Drawing Namespace


Bottom Property

Bottom Property
[image]
Telerik.Reporting.Drawing Namespace > BorderStyle Class : Bottom Property

Gets or sets the bottom style of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Bottom As BorderType
Visual Basic (Usage) Copy Code
Dim instance As BorderStyle
Dim value As BorderType

instance.Bottom = value

value = instance.Bottom
C#
public BorderType Bottom {get; set;}

Return Value

A BorderType object specifying the bottom border style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderStyle Class
BorderStyle Members


Default Property

Default Property
[image]
Telerik.Reporting.Drawing Namespace > BorderStyle Class : Default Property

Gets or sets the default style of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Default As BorderType
Visual Basic (Usage) Copy Code
Dim instance As BorderStyle
Dim value As BorderType

instance.Default = value

value = instance.Default
C#
public BorderType Default {get; set;}

Return Value

A BorderType object specifying the default border style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderStyle Class
BorderStyle Members


Left Property

Left Property
[image]
Telerik.Reporting.Drawing Namespace > BorderStyle Class : Left Property

Gets or sets the left style of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As BorderType
Visual Basic (Usage) Copy Code
Dim instance As BorderStyle
Dim value As BorderType

instance.Left = value

value = instance.Left
C#
public BorderType Left {get; set;}

Return Value

A BorderType object specifying the left border style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderStyle Class
BorderStyle Members


Right Property

Right Property
[image]
Telerik.Reporting.Drawing Namespace > BorderStyle Class : Right Property

Gets or sets the right style of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Right As BorderType
Visual Basic (Usage) Copy Code
Dim instance As BorderStyle
Dim value As BorderType

instance.Right = value

value = instance.Right
C#
public BorderType Right {get; set;}

Return Value

A BorderType object specifying the right border style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderStyle Class
BorderStyle Members


Top Property

Top Property
[image]
Telerik.Reporting.Drawing Namespace > BorderStyle Class : Top Property

Gets or sets the top style of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As BorderType
Visual Basic (Usage) Copy Code
Dim instance As BorderStyle
Dim value As BorderType

instance.Top = value

value = instance.Top
C#
public BorderType Top {get; set;}

Return Value

A BorderType object specifying the top border style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderStyle Class
BorderStyle Members


BorderWidth Class

BorderWidth Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : BorderWidth Class

A class used to specify the width of the border of an item.

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class BorderWidth
   Inherits BorderBase
Visual Basic (Usage) Copy Code
Dim instance As BorderWidth
C#
public class BorderWidth : BorderBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.StyleBase
Telerik.Reporting.Drawing.BorderBase
Telerik.Reporting.Drawing.BorderWidth

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderWidth Members
Telerik.Reporting.Drawing Namespace


BorderWidth Class Members

BorderWidth Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : BorderWidth Class

The following tables list the members exposed by BorderWidth.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom width of the border.
Public Property | Default | Gets or sets the default width of the border.
Public Property | Left | Gets or sets the left width of the border.
Public Property | Right | Gets or sets the right width of the border.
Public Property | Top | Gets or sets the top width of the border.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overloaded. (Inherited from BorderBase)
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

BorderWidth Class
Telerik.Reporting.Drawing Namespace


BorderWidth Class Properties

BorderWidth Class Properties
[image]
Telerik.Reporting.Drawing Namespace : BorderWidth Class

For a list of all members of this type, see BorderWidth members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom width of the border.
Public Property | Default | Gets or sets the default width of the border.
Public Property | Left | Gets or sets the left width of the border.
Public Property | Right | Gets or sets the right width of the border.
Public Property | Top | Gets or sets the top width of the border.
Top

See Also

Reference

BorderWidth Class
Telerik.Reporting.Drawing Namespace


Bottom Property

Bottom Property
[image]
Telerik.Reporting.Drawing Namespace > BorderWidth Class : Bottom Property

Gets or sets the bottom width of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Bottom As Unit
Visual Basic (Usage) Copy Code
Dim instance As BorderWidth
Dim value As Unit

instance.Bottom = value

value = instance.Bottom
C#
public Unit Bottom {get; set;}

Return Value

A Unit specifying the bottom border width.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderWidth Class
BorderWidth Members


Default Property

Default Property
[image]
Telerik.Reporting.Drawing Namespace > BorderWidth Class : Default Property

Gets or sets the default width of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Default As Unit
Visual Basic (Usage) Copy Code
Dim instance As BorderWidth
Dim value As Unit

instance.Default = value

value = instance.Default
C#
public Unit Default {get; set;}

Return Value

A Unit specifying the default border width.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderWidth Class
BorderWidth Members


Left Property

Left Property
[image]
Telerik.Reporting.Drawing Namespace > BorderWidth Class : Left Property

Gets or sets the left width of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As Unit
Visual Basic (Usage) Copy Code
Dim instance As BorderWidth
Dim value As Unit

instance.Left = value

value = instance.Left
C#
public Unit Left {get; set;}

Return Value

A Unit specifying the left border width.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderWidth Class
BorderWidth Members


Right Property

Right Property
[image]
Telerik.Reporting.Drawing Namespace > BorderWidth Class : Right Property

Gets or sets the right width of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Right As Unit
Visual Basic (Usage) Copy Code
Dim instance As BorderWidth
Dim value As Unit

instance.Right = value

value = instance.Right
C#
public Unit Right {get; set;}

Return Value

A Unit specifying the right border width.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderWidth Class
BorderWidth Members


Top Property

Top Property
[image]
Telerik.Reporting.Drawing Namespace > BorderWidth Class : Top Property

Gets or sets the top width of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As Unit
Visual Basic (Usage) Copy Code
Dim instance As BorderWidth
Dim value As Unit

instance.Top = value

value = instance.Top
C#
public Unit Top {get; set;}

Return Value

A Unit specifying the top border width.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BorderWidth Class
BorderWidth Members


ConditionalFormatting Class

ConditionalFormatting Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : ConditionalFormatting Class

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ConditionalFormatting
   Inherits Collection(Of FormattingRule)
Visual Basic (Usage) Copy Code
Dim instance As ConditionalFormatting
C#
public class ConditionalFormatting : Collection<FormattingRule>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<FormattingRule>
Telerik.Reporting.Drawing.ConditionalFormatting

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConditionalFormatting Members
Telerik.Reporting.Drawing Namespace


ConditionalFormatting Class Members

ConditionalFormatting Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : ConditionalFormatting Class

The following tables list the members exposed by ConditionalFormatting.

Public Constructors

 | Name | Description
Public Constructor | ConditionalFormatting Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | AddRange |
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Top

See Also

Reference

ConditionalFormatting Class
Telerik.Reporting.Drawing Namespace


ConditionalFormatting Constructor

ConditionalFormatting Constructor
[image]
Telerik.Reporting.Drawing Namespace > ConditionalFormatting Class : ConditionalFormatting Constructor

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ConditionalFormatting()
C#
public ConditionalFormatting()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ConditionalFormatting()
C#
public ConditionalFormatting()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConditionalFormatting Class
ConditionalFormatting Members


ConditionalFormatting Class Methods

ConditionalFormatting Class Methods
[image]
Telerik.Reporting.Drawing Namespace : ConditionalFormatting Class

For a list of all members of this type, see ConditionalFormatting members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | AddRange |
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Top

See Also

Reference

ConditionalFormatting Class
Telerik.Reporting.Drawing Namespace


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Drawing Namespace > ConditionalFormatting Class : AddRange Method

items

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal items() As FormattingRule _
)
Visual Basic (Usage) Copy Code
Dim instance As ConditionalFormatting
Dim items() As FormattingRule

instance.AddRange(items)
C#
public void AddRange(
   FormattingRule[] items
)

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConditionalFormatting Class
ConditionalFormatting Members


ConditionalFormattingConverter Class

ConditionalFormattingConverter Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : ConditionalFormattingConverter Class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Class ConditionalFormattingConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As ConditionalFormattingConverter
C#
private class ConditionalFormattingConverter : TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Reporting.Drawing.ConditionalFormattingConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConditionalFormattingConverter Members
Telerik.Reporting.Drawing Namespace


ConditionalFormattingConverter Class Members

ConditionalFormattingConverter Class Members
See Also Methods
[image]
Telerik.Reporting.Drawing Namespace : ConditionalFormattingConverter Class

The following tables list the members exposed by ConditionalFormattingConverter.

Public Constructors

 | Name | Description
Public Constructor | ConditionalFormattingConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ConditionalFormattingConverter Class
Telerik.Reporting.Drawing Namespace


ConditionalFormattingConverter Constructor

ConditionalFormattingConverter Constructor
[image]
Telerik.Reporting.Drawing Namespace > ConditionalFormattingConverter Class : ConditionalFormattingConverter Constructor

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ConditionalFormattingConverter()
C#
public ConditionalFormattingConverter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ConditionalFormattingConverter()
C#
public ConditionalFormattingConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConditionalFormattingConverter Class
ConditionalFormattingConverter Members


ConditionalFormattingConverter Class Methods

ConditionalFormattingConverter Class Methods
[image]
Telerik.Reporting.Drawing Namespace : ConditionalFormattingConverter Class

For a list of all members of this type, see ConditionalFormattingConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ConditionalFormattingConverter Class
Telerik.Reporting.Drawing Namespace


ConvertTo Method

ConvertTo Method
[image]
Telerik.Reporting.Drawing Namespace > ConditionalFormattingConverter Class : ConvertTo Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConditionalFormattingConverter Class
ConditionalFormattingConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also
[image]
Telerik.Reporting.Drawing Namespace > ConditionalFormattingConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ConditionalFormattingConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
culture
value
destinationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConditionalFormattingConverter Class
ConditionalFormattingConverter Members
Overload List


DescendantSelector Class

DescendantSelector Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : DescendantSelector Class

Represents a selector that matches an item that is a descendant of another item.

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class DescendantSelector
   Implements ISelector
Visual Basic (Usage) Copy Code
Dim instance As DescendantSelector
C#
public class DescendantSelector : ISelector

Remarks

At times, authors may want selectors to match an item that is the descendant of another item in the report item tree (e.g., "Match those TextBox elements that are contained by a Panel element"). Descendant selectors express such a relationship in a pattern.

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.DescendantSelector

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DescendantSelector Members
Telerik.Reporting.Drawing Namespace


DescendantSelector Class Members

DescendantSelector Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : DescendantSelector Class

The following tables list the members exposed by DescendantSelector.

Public Constructors

 | Name | Description
Public Constructor | DescendantSelector Constructor | Overloaded. Initializes a new instance of the DescendantSelector.
Top

Public Properties

 | Name | Description
Public Property | Selectors | Gets a SelectorCollection containig the selectors that define the descendence pattern used to match the item.
Top

Public Methods

 | Name | Description
Public Method | Match | Matches a report item based on the descendence pattern defined by the Selectors
Public Method | ToString | Overridden. This member overrides ToString
Top

See Also

Reference

DescendantSelector Class
Telerik.Reporting.Drawing Namespace


DescendantSelector Constructor

DescendantSelector Constructor
[image]
Telerik.Reporting.Drawing Namespace > DescendantSelector Class : DescendantSelector Constructor

Initializes a new instance of the DescendantSelector.

Overload List

Overload | Description
DescendantSelector Constructor() | Initializes a new instance of the DescendantSelector.
DescendantSelector Constructor(ISelector[]) | Initializes a new instance of the DescendantSelector class with the specified selectors.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DescendantSelector Class
DescendantSelector Members


DescendantSelector Constructor()

DescendantSelector Constructor()
See Also
[image]
Telerik.Reporting.Drawing Namespace > DescendantSelector Class > DescendantSelector Constructor : DescendantSelector Constructor()

Initializes a new instance of the DescendantSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DescendantSelector()
C#
public DescendantSelector()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DescendantSelector()
C#
public DescendantSelector()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DescendantSelector Class
DescendantSelector Members
Overload List


DescendantSelector Constructor(ISelector[])

DescendantSelector Constructor(ISelector[])
See Also
[image]
Telerik.Reporting.Drawing Namespace > DescendantSelector Class > DescendantSelector Constructor : DescendantSelector Constructor(ISelector[])

selectors
A ISelector array containig the selectors that define the descendence pattern used to match the item.
Initializes a new instance of the DescendantSelector class with the specified selectors.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectors() As ISelector _
)
Visual Basic (Usage) Copy Code
Dim selectors() As ISelector

Dim instance As DescendantSelector(selectors)
C#
public DescendantSelector(
   ISelector[] selectors
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectors() As ISelector _
)
Visual Basic (Usage) Copy Code
Dim selectors() As ISelector

Dim instance As DescendantSelector(selectors)
C#
public DescendantSelector(
   ISelector[] selectors
)

Parameters

selectors
A ISelector array containig the selectors that define the descendence pattern used to match the item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DescendantSelector Class
DescendantSelector Members
Overload List


DescendantSelector Class Methods

DescendantSelector Class Methods
[image]
Telerik.Reporting.Drawing Namespace : DescendantSelector Class

For a list of all members of this type, see DescendantSelector members.

Public Methods

 | Name | Description
Public Method | Match | Matches a report item based on the descendence pattern defined by the Selectors
Public Method | ToString | Overridden. This member overrides ToString
Top

See Also

Reference

DescendantSelector Class
Telerik.Reporting.Drawing Namespace


Match Method

Match Method
[image]
Telerik.Reporting.Drawing Namespace > DescendantSelector Class : Match Method

item
The ReportItemBase to match.
Matches a report item based on the descendence pattern defined by the Selectors

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Match( _
   ByVal item As ReportItemBase _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DescendantSelector
Dim item As ReportItemBase
Dim value As Boolean

value = instance.Match(item)
C#
public bool Match(
   ReportItemBase item
)

Parameters

item
The ReportItemBase to match.

Return Value

true if the item matches the descendence pattern.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DescendantSelector Class
DescendantSelector Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing Namespace > DescendantSelector Class : ToString Method

This member overrides ToString

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DescendantSelector
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A string value describing the selector.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DescendantSelector Class
DescendantSelector Members


DescendantSelector Class Properties

DescendantSelector Class Properties
[image]
Telerik.Reporting.Drawing Namespace : DescendantSelector Class

For a list of all members of this type, see DescendantSelector members.

Public Properties

 | Name | Description
Public Property | Selectors | Gets a SelectorCollection containig the selectors that define the descendence pattern used to match the item.
Top

See Also

Reference

DescendantSelector Class
Telerik.Reporting.Drawing Namespace


Selectors Property

Selectors Property
[image]
Telerik.Reporting.Drawing Namespace > DescendantSelector Class : Selectors Property

Gets a SelectorCollection containig the selectors that define the descendence pattern used to match the item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Selectors As SelectorCollection
Visual Basic (Usage) Copy Code
Dim instance As DescendantSelector
Dim value As SelectorCollection

value = instance.Selectors
C#
public SelectorCollection Selectors {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DescendantSelector Class
DescendantSelector Members


ExternalStyleSheetCollection Class

ExternalStyleSheetCollection Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : ExternalStyleSheetCollection Class

Represents a collection of ExternalStyleSheet objects.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ExternalStyleSheetCollection
   Inherits Collection(Of ExternalStyleSheet)
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetCollection
C#
public class ExternalStyleSheetCollection : Collection<ExternalStyleSheet>

Remarks

Each time an ExternalStyleSheet object is inserted, deleted or set in this collection, the Report that owns the collection is refreshed by re-applying or internal and external style sheets.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<ExternalStyleSheet>
Telerik.Reporting.Drawing.ExternalStyleSheetCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Members
Telerik.Reporting.Drawing Namespace


ExternalStyleSheetCollection Class Members

ExternalStyleSheetCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : ExternalStyleSheetCollection Class

The following tables list the members exposed by ExternalStyleSheetCollection.

Public Constructors

 | Name | Description
Public Constructor | ExternalStyleSheetCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Public Method | Contains | Overloaded.
Public Method | CopyTo | Overloaded.
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Public Method | Remove | Overloaded.
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | Overridden.
Protected Method | InsertItem | Overridden.
Protected Method | RemoveItem | Overridden.
Protected Method | SetItem | Overridden.
Top

See Also

Reference

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


ExternalStyleSheetCollection Constructor

ExternalStyleSheetCollection Constructor
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollection Class : ExternalStyleSheetCollection Constructor

report

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As Report _
)
Visual Basic (Usage) Copy Code
Dim report As Report

Dim instance As ExternalStyleSheetCollection(report)
C#
public ExternalStyleSheetCollection(
   Report report
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As Report _
)
Visual Basic (Usage) Copy Code
Dim report As Report

Dim instance As ExternalStyleSheetCollection(report)
C#
public ExternalStyleSheetCollection(
   Report report
)

Parameters

report

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Class
ExternalStyleSheetCollection Members


ExternalStyleSheetCollection Class Methods

ExternalStyleSheetCollection Class Methods
[image]
Telerik.Reporting.Drawing Namespace : ExternalStyleSheetCollection Class

For a list of all members of this type, see ExternalStyleSheetCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Public Method | Contains | Overloaded.
Public Method | CopyTo | Overloaded.
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Public Method | Remove | Overloaded.
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | Overridden.
Protected Method | InsertItem | Overridden.
Protected Method | RemoveItem | Overridden.
Protected Method | SetItem | Overridden.
Top

See Also

Reference

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollection Class : Add Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Add(String) |
Add(ExternalStyleSheet) | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)

Overload List

Overload | Description
Add(String) |
Add(ExternalStyleSheet) | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Class
ExternalStyleSheetCollection Members


Add(String) Method

Add(String) Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollection Class > Add Method : Add(String) Method

item

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal item As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetCollection
Dim item As String

instance.Add(item)
C#
public void Add(
   string item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Class
ExternalStyleSheetCollection Members
Overload List


ClearItems Method

ClearItems Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollection Class : ClearItems Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetCollection

instance.ClearItems()
C#
protected override void ClearItems()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Class
ExternalStyleSheetCollection Members


Contains Method

Contains Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollection Class : Contains Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Contains(String) |
Contains(ExternalStyleSheet) | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)

Overload List

Overload | Description
Contains(String) |
Contains(ExternalStyleSheet) | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Class
ExternalStyleSheetCollection Members


Contains(String) Method

Contains(String) Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollection Class > Contains Method : Contains(String) Method

item

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Contains( _
   ByVal item As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetCollection
Dim item As String
Dim value As Boolean

value = instance.Contains(item)
C#
public bool Contains(
   string item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Class
ExternalStyleSheetCollection Members
Overload List


CopyTo Method

CopyTo Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollection Class : CopyTo Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CopyTo(String[],Int32) |
CopyTo(ExternalStyleSheet[],Int32) | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)

Overload List

Overload | Description
CopyTo(String[],Int32) |
CopyTo(ExternalStyleSheet[],Int32) | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Class
ExternalStyleSheetCollection Members


CopyTo(String[],Int32) Method

CopyTo(String[],Int32) Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollection Class > CopyTo Method : CopyTo(String[],Int32) Method

array
arrayIndex

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub CopyTo( _
   ByVal array() As String, _
   ByVal arrayIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetCollection
Dim array() As String
Dim arrayIndex As Integer

instance.CopyTo(array, arrayIndex)
C#
public void CopyTo(
   string[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Class
ExternalStyleSheetCollection Members
Overload List


InsertItem Method

InsertItem Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollection Class : InsertItem Method

index
ess

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub InsertItem( _
   ByVal index As Integer, _
   ByVal ess As ExternalStyleSheet _
)
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetCollection
Dim index As Integer
Dim ess As ExternalStyleSheet

instance.InsertItem(index, ess)
C#
protected override void InsertItem(
   int index,
   ExternalStyleSheet ess
)

Parameters

index
ess

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Class
ExternalStyleSheetCollection Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollection Class : Remove Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Remove(String) |
Remove(ExternalStyleSheet) | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)

Overload List

Overload | Description
Remove(String) |
Remove(ExternalStyleSheet) | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Class
ExternalStyleSheetCollection Members


Remove(String) Method

Remove(String) Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollection Class > Remove Method : Remove(String) Method

item

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Remove( _
   ByVal item As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetCollection
Dim item As String
Dim value As Boolean

value = instance.Remove(item)
C#
public bool Remove(
   string item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Class
ExternalStyleSheetCollection Members
Overload List


RemoveItem Method

RemoveItem Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollection Class : RemoveItem Method

index

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RemoveItem( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetCollection
Dim index As Integer

instance.RemoveItem(index)
C#
protected override void RemoveItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Class
ExternalStyleSheetCollection Members


SetItem Method

SetItem Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollection Class : SetItem Method

index
ess

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub SetItem( _
   ByVal index As Integer, _
   ByVal ess As ExternalStyleSheet _
)
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetCollection
Dim index As Integer
Dim ess As ExternalStyleSheet

instance.SetItem(index, ess)
C#
protected override void SetItem(
   int index,
   ExternalStyleSheet ess
)

Parameters

index
ess

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollection Class
ExternalStyleSheetCollection Members


ExternalStyleSheetCollectionConverter Class

ExternalStyleSheetCollectionConverter Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : ExternalStyleSheetCollectionConverter Class

ExternalStyleSheetCollectionConverter

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Class ExternalStyleSheetCollectionConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetCollectionConverter
C#
private class ExternalStyleSheetCollectionConverter : TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Reporting.Drawing.ExternalStyleSheetCollectionConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollectionConverter Members
Telerik.Reporting.Drawing Namespace


ExternalStyleSheetCollectionConverter Class Members

ExternalStyleSheetCollectionConverter Class Members
See Also Methods
[image]
Telerik.Reporting.Drawing Namespace : ExternalStyleSheetCollectionConverter Class

The following tables list the members exposed by ExternalStyleSheetCollectionConverter.

Public Constructors

 | Name | Description
Public Constructor | ExternalStyleSheetCollectionConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ExternalStyleSheetCollectionConverter Class
Telerik.Reporting.Drawing Namespace


ExternalStyleSheetCollectionConverter Constructor

ExternalStyleSheetCollectionConverter Constructor
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollectionConverter Class : ExternalStyleSheetCollectionConverter Constructor

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetCollectionConverter()
C#
public ExternalStyleSheetCollectionConverter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetCollectionConverter()
C#
public ExternalStyleSheetCollectionConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollectionConverter Class
ExternalStyleSheetCollectionConverter Members


ExternalStyleSheetCollectionConverter Class Methods

ExternalStyleSheetCollectionConverter Class Methods
[image]
Telerik.Reporting.Drawing Namespace : ExternalStyleSheetCollectionConverter Class

For a list of all members of this type, see ExternalStyleSheetCollectionConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ExternalStyleSheetCollectionConverter Class
Telerik.Reporting.Drawing Namespace


ConvertTo Method

ConvertTo Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollectionConverter Class : ConvertTo Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollectionConverter Class
ExternalStyleSheetCollectionConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetCollectionConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetCollectionConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
culture
value
destinationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetCollectionConverter Class
ExternalStyleSheetCollectionConverter Members
Overload List


ExternalStyleSheetConverter Class

ExternalStyleSheetConverter Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : ExternalStyleSheetConverter Class

ExternalStyleSheetConverter

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Class ExternalStyleSheetConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetConverter
C#
private class ExternalStyleSheetConverter : TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Reporting.Drawing.ExternalStyleSheetConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetConverter Members
Telerik.Reporting.Drawing Namespace


ExternalStyleSheetConverter Class Members

ExternalStyleSheetConverter Class Members
See Also Methods
[image]
Telerik.Reporting.Drawing Namespace : ExternalStyleSheetConverter Class

The following tables list the members exposed by ExternalStyleSheetConverter.

Public Constructors

 | Name | Description
Public Constructor | ExternalStyleSheetConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. Overridden.
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ExternalStyleSheetConverter Class
Telerik.Reporting.Drawing Namespace


ExternalStyleSheetConverter Constructor

ExternalStyleSheetConverter Constructor
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetConverter Class : ExternalStyleSheetConverter Constructor

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetConverter()
C#
public ExternalStyleSheetConverter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetConverter()
C#
public ExternalStyleSheetConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetConverter Class
ExternalStyleSheetConverter Members


ExternalStyleSheetConverter Class Methods

ExternalStyleSheetConverter Class Methods
[image]
Telerik.Reporting.Drawing Namespace : ExternalStyleSheetConverter Class

For a list of all members of this type, see ExternalStyleSheetConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. Overridden.
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ExternalStyleSheetConverter Class
Telerik.Reporting.Drawing Namespace


CanConvertTo Method

CanConvertTo Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetConverter Class : CanConvertTo Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) |
CanConvertTo(Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) |
CanConvertTo(Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetConverter Class
ExternalStyleSheetConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

CanConvertTo(ITypeDescriptorContext,Type) Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
destinationType

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetConverter
Dim context As ITypeDescriptorContext
Dim destinationType As Type
Dim value As Boolean

value = instance.CanConvertTo(context, destinationType)
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)

Parameters

context
destinationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetConverter Class
ExternalStyleSheetConverter Members
Overload List


ConvertTo Method

ConvertTo Method
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetConverter Class : ConvertTo Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetConverter Class
ExternalStyleSheetConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also
[image]
Telerik.Reporting.Drawing Namespace > ExternalStyleSheetConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ExternalStyleSheetConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
culture
value
destinationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExternalStyleSheetConverter Class
ExternalStyleSheetConverter Members
Overload List


Font Class

Font Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : Font Class

Defines a particular format for text, including font face, size, and style attributes.

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Font
   Inherits StyleBase
Visual Basic (Usage) Copy Code
Dim instance As Font
C#
public class Font : StyleBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.StyleBase
Telerik.Reporting.Drawing.Font

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Font Members
Telerik.Reporting.Drawing Namespace


Font Class Members

Font Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : Font Class

The following tables list the members exposed by Font.

Public Constructors

 | Name | Description
Public Constructor | Font Constructor | Initializes a new instance of the Font class as a member of the given Style
Top

Public Properties

 | Name | Description
Public Property | Bold | Gets a value that indicates whether this Font is bold.
Public Property | Italic | Gets a value that indicates whether this Font is italic.
Public Property | Name | Gets or sets the face name of this Font.
Public Property | Size | Gets or sets the size of this Font measured in Units.
Public Property | Strikeout | Gets a value that indicates whether this Font specifies a horizontal line through the font.
Public Property | Style | Gets ot sets style information for this Font.
Public Property | Underline | Gets a value that indicates whether this Font is underlined.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Overridden. This member overrides ToString
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

Public Operators

Public Operator Explicit Type Conversion Converts the specified reporting Font to a Font.
Top

See Also

Reference

Font Class
Telerik.Reporting.Drawing Namespace


Font Constructor

Font Constructor
[image]
Telerik.Reporting.Drawing Namespace > Font Class : Font Constructor

style
A Style value representing the parent style of the Font.
Initializes a new instance of the Font class as a member of the given Style

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As Style _
)
Visual Basic (Usage) Copy Code
Dim style As Style

Dim instance As Font(style)
C#
public Font(
   Style style
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As Style _
)
Visual Basic (Usage) Copy Code
Dim style As Style

Dim instance As Font(style)
C#
public Font(
   Style style
)

Parameters

style
A Style value representing the parent style of the Font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Font Class
Font Members


Font Class Methods

Font Class Methods
[image]
Telerik.Reporting.Drawing Namespace : Font Class

For a list of all members of this type, see Font members.

Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Overridden. This member overrides ToString
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

Font Class
Telerik.Reporting.Drawing Namespace


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing Namespace > Font Class : ToString Method

This member overrides ToString

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ToString() | This member overrides ToString
ToString(String[]) | (Inherited from StyleBase)

Overload List

Overload | Description
ToString() | This member overrides ToString
ToString(String[]) | (Inherited from StyleBase)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Font Class
Font Members


ToString() Method

ToString() Method
[image]
Telerik.Reporting.Drawing Namespace > Font Class > ToString Method : ToString() Method

This member overrides ToString

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Font
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A string value describing the Font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Font Class
Font Members
Overload List


Font Class Properties

Font Class Properties
[image]
Telerik.Reporting.Drawing Namespace : Font Class

For a list of all members of this type, see Font members.

Public Properties

 | Name | Description
Public Property | Bold | Gets a value that indicates whether this Font is bold.
Public Property | Italic | Gets a value that indicates whether this Font is italic.
Public Property | Name | Gets or sets the face name of this Font.
Public Property | Size | Gets or sets the size of this Font measured in Units.
Public Property | Strikeout | Gets a value that indicates whether this Font specifies a horizontal line through the font.
Public Property | Style | Gets ot sets style information for this Font.
Public Property | Underline | Gets a value that indicates whether this Font is underlined.
Top

See Also

Reference

Font Class
Telerik.Reporting.Drawing Namespace


Bold Property

Bold Property
[image]
Telerik.Reporting.Drawing Namespace > Font Class : Bold Property

Gets a value that indicates whether this Font is bold.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Bold As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Font
Dim value As Boolean

instance.Bold = value

value = instance.Bold
C#
public bool Bold {get; set;}

Return Value

true if this Font is bold; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Font Class
Font Members


Italic Property

Italic Property
[image]
Telerik.Reporting.Drawing Namespace > Font Class : Italic Property

Gets a value that indicates whether this Font is italic.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Italic As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Font
Dim value As Boolean

instance.Italic = value

value = instance.Italic
C#
public bool Italic {get; set;}

Return Value

true if this Font is italic; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Font Class
Font Members


Name Property

Name Property
[image]
Telerik.Reporting.Drawing Namespace > Font Class : Name Property

Gets or sets the face name of this Font.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Font
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Return Value

A string representation of the face name of this Font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Font Class
Font Members


Size Property

Size Property
[image]
Telerik.Reporting.Drawing Namespace > Font Class : Size Property

Gets or sets the size of this Font measured in Units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Size As Unit
Visual Basic (Usage) Copy Code
Dim instance As Font
Dim value As Unit

instance.Size = value

value = instance.Size
C#
public Unit Size {get; set;}

Return Value

The Unit size of this Font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Font Class
Font Members


Strikeout Property

Strikeout Property
[image]
Telerik.Reporting.Drawing Namespace > Font Class : Strikeout Property

Gets a value that indicates whether this Font specifies a horizontal line through the font.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Strikeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Font
Dim value As Boolean

instance.Strikeout = value

value = instance.Strikeout
C#
public bool Strikeout {get; set;}

Return Value

true if this Font has a horizontal line through it; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Font Class
Font Members


Style Property

Style Property
[image]
Telerik.Reporting.Drawing Namespace > Font Class : Style Property

Gets ot sets style information for this Font.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Style As FontStyle
Visual Basic (Usage) Copy Code
Dim instance As Font
Dim value As FontStyle

instance.Style = value

value = instance.Style
C#
public FontStyle Style {get; set;}

Return Value

A FontStyle enumeration that contains style information for this Font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Font Class
Font Members


Underline Property

Underline Property
[image]
Telerik.Reporting.Drawing Namespace > Font Class : Underline Property

Gets a value that indicates whether this Font is underlined.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Underline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Font
Dim value As Boolean

instance.Underline = value

value = instance.Underline
C#
public bool Underline {get; set;}

Return Value

true if this Font is underlined; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Font Class
Font Members


Explicit Type Conversion Operator

Explicit Type Conversion Operator
[image]
Telerik.Reporting.Drawing Namespace > Font Class : Explicit Type Conversion Operator

font
The Font to convert.
Converts the specified reporting Font to a Font.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator Narrowing CType( _
   ByVal font As Font _
) As Font
C#
public Font operator explicit(
   Font font
)

Syntax

Visual Basic (Declaration)
Public Operator Narrowing CType( _
   ByVal font As Font _
) As Font
C#
public Font operator explicit(
   Font font
)

Parameters

font
The Font to convert.

Return Value

The Font that is converted from the specified reporting Font structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Font Class
Font Members


FormattingRule Class

FormattingRule Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : FormattingRule Class

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class FormattingRule
Visual Basic (Usage) Copy Code
Dim instance As FormattingRule
C#
public class FormattingRule

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.FormattingRule

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FormattingRule Members
Telerik.Reporting.Drawing Namespace


FormattingRule Class Members

FormattingRule Class Members
See Also Properties
[image]
Telerik.Reporting.Drawing Namespace : FormattingRule Class

The following tables list the members exposed by FormattingRule.

Public Constructors

 | Name | Description
Public Constructor | FormattingRule Constructor |
Top

Public Properties

 | Name | Description
Public Property | Filters |
Public Property | StopIfTrue | Indicates whether if the current rule is applied to proceed with the next FormattingRule in the ReportItemBase.ConditionalFormattings collection.
Public Property | Style |
Top

See Also

Reference

FormattingRule Class
Telerik.Reporting.Drawing Namespace


FormattingRule Constructor

FormattingRule Constructor
[image]
Telerik.Reporting.Drawing Namespace > FormattingRule Class : FormattingRule Constructor

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FormattingRule()
C#
public FormattingRule()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FormattingRule()
C#
public FormattingRule()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FormattingRule Class
FormattingRule Members


FormattingRule Class Properties

FormattingRule Class Properties
[image]
Telerik.Reporting.Drawing Namespace : FormattingRule Class

For a list of all members of this type, see FormattingRule members.

Public Properties

 | Name | Description
Public Property | Filters |
Public Property | StopIfTrue | Indicates whether if the current rule is applied to proceed with the next FormattingRule in the ReportItemBase.ConditionalFormattings collection.
Public Property | Style |
Top

See Also

Reference

FormattingRule Class
Telerik.Reporting.Drawing Namespace


Filters Property

Filters Property
[image]
Telerik.Reporting.Drawing Namespace > FormattingRule Class : Filters Property

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filters As FilterCollection
Visual Basic (Usage) Copy Code
Dim instance As FormattingRule
Dim value As FilterCollection

value = instance.Filters
C#
public FilterCollection Filters {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FormattingRule Class
FormattingRule Members


StopIfTrue Property

StopIfTrue Property
[image]
Telerik.Reporting.Drawing Namespace > FormattingRule Class : StopIfTrue Property

Indicates whether if the current rule is applied to proceed with the next FormattingRule in the ReportItemBase.ConditionalFormattings collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property StopIfTrue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FormattingRule
Dim value As Boolean

instance.StopIfTrue = value

value = instance.StopIfTrue
C#
public bool StopIfTrue {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FormattingRule Class
FormattingRule Members


Style Property

Style Property
[image]
Telerik.Reporting.Drawing Namespace > FormattingRule Class : Style Property

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As FormattingRule
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FormattingRule Class
FormattingRule Members


MarginsU Class

MarginsU Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : MarginsU Class

Mockup class -- TO BE REMOVED!!!

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class MarginsU
Visual Basic (Usage) Copy Code
Dim instance As MarginsU
C#
public class MarginsU

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.MarginsU

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarginsU Members
Telerik.Reporting.Drawing Namespace


MarginsU Class Members

MarginsU Class Members
See Also Properties
[image]
Telerik.Reporting.Drawing Namespace : MarginsU Class

The following tables list the members exposed by MarginsU.

Public Constructors

 | Name | Description
Public Constructor | MarginsU Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Bottom |
Public Property | Left |
Public Property | Right |
Public Property | Top |
Top

See Also

Reference

MarginsU Class
Telerik.Reporting.Drawing Namespace


MarginsU Constructor

MarginsU Constructor
[image]
Telerik.Reporting.Drawing Namespace > MarginsU Class : MarginsU Constructor

Overload List

Overload | Description
MarginsU Constructor() |
MarginsU Constructor(MarginsU) |
MarginsU Constructor(Unit) |
MarginsU Constructor(Unit,Unit,Unit,Unit) |

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarginsU Class
MarginsU Members


MarginsU Constructor()

MarginsU Constructor()
See Also
[image]
Telerik.Reporting.Drawing Namespace > MarginsU Class > MarginsU Constructor : MarginsU Constructor()

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MarginsU()
C#
public MarginsU()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MarginsU()
C#
public MarginsU()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarginsU Class
MarginsU Members
Overload List


MarginsU Constructor(MarginsU)

MarginsU Constructor(MarginsU)
See Also
[image]
Telerik.Reporting.Drawing Namespace > MarginsU Class > MarginsU Constructor : MarginsU Constructor(MarginsU)

margins

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal margins As MarginsU _
)
Visual Basic (Usage) Copy Code
Dim margins As MarginsU

Dim instance As MarginsU(margins)
C#
public MarginsU(
   MarginsU margins
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal margins As MarginsU _
)
Visual Basic (Usage) Copy Code
Dim margins As MarginsU

Dim instance As MarginsU(margins)
C#
public MarginsU(
   MarginsU margins
)

Parameters

margins

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarginsU Class
MarginsU Members
Overload List


MarginsU Constructor(Unit)

MarginsU Constructor(Unit)
See Also
[image]
Telerik.Reporting.Drawing Namespace > MarginsU Class > MarginsU Constructor : MarginsU Constructor(Unit)

value

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Unit _
)
Visual Basic (Usage) Copy Code
Dim value As Unit

Dim instance As MarginsU(value)
C#
public MarginsU(
   Unit value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Unit _
)
Visual Basic (Usage) Copy Code
Dim value As Unit

Dim instance As MarginsU(value)
C#
public MarginsU(
   Unit value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarginsU Class
MarginsU Members
Overload List


MarginsU Constructor(Unit,Unit,Unit,Unit)

MarginsU Constructor(Unit,Unit,Unit,Unit)
See Also
[image]
Telerik.Reporting.Drawing Namespace > MarginsU Class > MarginsU Constructor : MarginsU Constructor(Unit,Unit,Unit,Unit)

left
right
top
bottom

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Unit, _
   ByVal right As Unit, _
   ByVal top As Unit, _
   ByVal bottom As Unit _
)
Visual Basic (Usage) Copy Code
Dim left As Unit
Dim right As Unit
Dim top As Unit
Dim bottom As Unit

Dim instance As MarginsU(left, right, top, bottom)
C#
public MarginsU(
   Unit left,
   Unit right,
   Unit top,
   Unit bottom
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Unit, _
   ByVal right As Unit, _
   ByVal top As Unit, _
   ByVal bottom As Unit _
)
Visual Basic (Usage) Copy Code
Dim left As Unit
Dim right As Unit
Dim top As Unit
Dim bottom As Unit

Dim instance As MarginsU(left, right, top, bottom)
C#
public MarginsU(
   Unit left,
   Unit right,
   Unit top,
   Unit bottom
)

Parameters

left
right
top
bottom

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarginsU Class
MarginsU Members
Overload List


MarginsU Class Properties

MarginsU Class Properties
[image]
Telerik.Reporting.Drawing Namespace : MarginsU Class

For a list of all members of this type, see MarginsU members.

Public Properties

 | Name | Description
Public Property | Bottom |
Public Property | Left |
Public Property | Right |
Public Property | Top |
Top

See Also

Reference

MarginsU Class
Telerik.Reporting.Drawing Namespace


Bottom Property

Bottom Property
[image]
Telerik.Reporting.Drawing Namespace > MarginsU Class : Bottom Property

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Bottom As Unit
Visual Basic (Usage) Copy Code
Dim instance As MarginsU
Dim value As Unit

instance.Bottom = value

value = instance.Bottom
C#
public Unit Bottom {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarginsU Class
MarginsU Members


Left Property

Left Property
[image]
Telerik.Reporting.Drawing Namespace > MarginsU Class : Left Property

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As Unit
Visual Basic (Usage) Copy Code
Dim instance As MarginsU
Dim value As Unit

instance.Left = value

value = instance.Left
C#
public Unit Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarginsU Class
MarginsU Members


Right Property

Right Property
[image]
Telerik.Reporting.Drawing Namespace > MarginsU Class : Right Property

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Right As Unit
Visual Basic (Usage) Copy Code
Dim instance As MarginsU
Dim value As Unit

instance.Right = value

value = instance.Right
C#
public Unit Right {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarginsU Class
MarginsU Members


Top Property

Top Property
[image]
Telerik.Reporting.Drawing Namespace > MarginsU Class : Top Property

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As Unit
Visual Basic (Usage) Copy Code
Dim instance As MarginsU
Dim value As Unit

instance.Top = value

value = instance.Top
C#
public Unit Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MarginsU Class
MarginsU Members


Padding Class

Padding Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : Padding Class

Represents padding information associated with a report item.

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Padding
   Inherits StyleBase
Visual Basic (Usage) Copy Code
Dim instance As Padding
C#
public class Padding : StyleBase

Remarks

The padding is the internal space between the body of the item and its edge.

Padding has a different effect on report items that are containers than on report items that are not. For example, in a Panel item, the Padding property defines the spacing between the border of the Panel and its child items. For a TextBox item, the Padding property defines the spacing between the border of the TextBox item and its contained text.

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.StyleBase
Telerik.Reporting.Drawing.Padding

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Padding Members
Telerik.Reporting.Drawing Namespace


Padding Class Members

Padding Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : Padding Class

The following tables list the members exposed by Padding.

Public Constructors

 | Name | Description
Public Constructor | Padding Constructor | Initializes a new instance of the Padding class as a member of the given Style
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the padding value for the bottom edge.
Public Property | Left | Gets or sets the padding value for the left edge.
Public Property | Right | Gets or sets the padding value for the right edge.
Public Property | Top | Gets or sets the padding value for the top edge.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Overridden. This member overrides ToString
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

Padding Class
Telerik.Reporting.Drawing Namespace


Padding Constructor

Padding Constructor
[image]
Telerik.Reporting.Drawing Namespace > Padding Class : Padding Constructor

style
A Style value representing the parent style of the Padding.
Initializes a new instance of the Padding class as a member of the given Style

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As Style _
)
Visual Basic (Usage) Copy Code
Dim style As Style

Dim instance As Padding(style)
C#
public Padding(
   Style style
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As Style _
)
Visual Basic (Usage) Copy Code
Dim style As Style

Dim instance As Padding(style)
C#
public Padding(
   Style style
)

Parameters

style
A Style value representing the parent style of the Padding.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Padding Class
Padding Members


Padding Class Methods

Padding Class Methods
[image]
Telerik.Reporting.Drawing Namespace : Padding Class

For a list of all members of this type, see Padding members.

Public Methods

 | Name | Description
Public Method | ToString | Overloaded. Overridden. This member overrides ToString
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

Padding Class
Telerik.Reporting.Drawing Namespace


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing Namespace > Padding Class : ToString Method

This member overrides ToString

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ToString() | This member overrides ToString
ToString(String[]) | (Inherited from StyleBase)

Overload List

Overload | Description
ToString() | This member overrides ToString
ToString(String[]) | (Inherited from StyleBase)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Padding Class
Padding Members


ToString() Method

ToString() Method
[image]
Telerik.Reporting.Drawing Namespace > Padding Class > ToString Method : ToString() Method

This member overrides ToString

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A string value listing the Padding's members.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Padding Class
Padding Members
Overload List


Padding Class Properties

Padding Class Properties
[image]
Telerik.Reporting.Drawing Namespace : Padding Class

For a list of all members of this type, see Padding members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the padding value for the bottom edge.
Public Property | Left | Gets or sets the padding value for the left edge.
Public Property | Right | Gets or sets the padding value for the right edge.
Public Property | Top | Gets or sets the padding value for the top edge.
Top

See Also

Reference

Padding Class
Telerik.Reporting.Drawing Namespace


Bottom Property

Bottom Property
[image]
Telerik.Reporting.Drawing Namespace > Padding Class : Bottom Property

Gets or sets the padding value for the bottom edge.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Bottom As Unit
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As Unit

instance.Bottom = value

value = instance.Bottom
C#
public Unit Bottom {get; set;}

Return Value

The padding, in Units, for the bottom edge.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Padding Class
Padding Members


Left Property

Left Property
[image]
Telerik.Reporting.Drawing Namespace > Padding Class : Left Property

Gets or sets the padding value for the left edge.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As Unit
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As Unit

instance.Left = value

value = instance.Left
C#
public Unit Left {get; set;}

Return Value

The padding, in Units, for the left edge.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Padding Class
Padding Members


Right Property

Right Property
[image]
Telerik.Reporting.Drawing Namespace > Padding Class : Right Property

Gets or sets the padding value for the right edge.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Right As Unit
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As Unit

instance.Right = value

value = instance.Right
C#
public Unit Right {get; set;}

Return Value

The padding, in Units, for the right edge.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Padding Class
Padding Members


Top Property

Top Property
[image]
Telerik.Reporting.Drawing Namespace > Padding Class : Top Property

Gets or sets the padding value for the top edge.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As Unit
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As Unit

instance.Top = value

value = instance.Top
C#
public Unit Top {get; set;}

Return Value

The padding, in Units, for the top edge.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Padding Class
Padding Members


PageSettings Class

PageSettings Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : PageSettings Class

Specifies settings that apply to a single, printed page.

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PageSettings
Visual Basic (Usage) Copy Code
Dim instance As PageSettings
C#
public class PageSettings

Remarks

The PageSettings class is used to specify settings that modify the way a page will be printed.

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.PageSettings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSettings Members
Telerik.Reporting.Drawing Namespace


PageSettings Class Members

PageSettings Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : PageSettings Class

The following tables list the members exposed by PageSettings.

Public Constructors

 | Name | Description
Public Constructor | PageSettings Constructor | Overloaded. Initializes a new instance of the PageSettings class with the default settings.
Top

Public Properties

 | Name | Description
Public Property | Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.
Public Property | Margins | Gets or sets the margins for this page.
Public Property | PaperKind | Gets or sets the paper kind for the page.
Public Property | PaperSize | Gets or sets the paper size for the page.
Top

Public Methods

 | Name | Description
Public Method | Clone | This member implements Clone
Public Method | ToPageSettings | Returns a PageSettings object based on the given PrinterSettings parameter.
Public Method | Update |
Top

See Also

Reference

PageSettings Class
Telerik.Reporting.Drawing Namespace


PageSettings Constructor

PageSettings Constructor
[image]
Telerik.Reporting.Drawing Namespace > PageSettings Class : PageSettings Constructor

Initializes a new instance of the PageSettings class with the default settings.

Overload List

Overload | Description
PageSettings Constructor() | Initializes a new instance of the PageSettings class with the default settings.
PageSettings Constructor(PageSettings,PrinterSettings) | Initializes a new instance of the PageSettings class with the specified PageSettings and PrinterSettings.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSettings Class
PageSettings Members


PageSettings Constructor()

PageSettings Constructor()
See Also
[image]
Telerik.Reporting.Drawing Namespace > PageSettings Class > PageSettings Constructor : PageSettings Constructor()

Initializes a new instance of the PageSettings class with the default settings.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PageSettings()
C#
public PageSettings()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PageSettings()
C#
public PageSettings()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSettings Class
PageSettings Members
Overload List


PageSettings Constructor(PageSettings,PrinterSettings)

PageSettings Constructor(PageSettings,PrinterSettings)
See Also
[image]
Telerik.Reporting.Drawing Namespace > PageSettings Class > PageSettings Constructor : PageSettings Constructor(PageSettings,PrinterSettings)

pageSettings
A PageSettings object specifying the landscape and paper kind.
printerSettings
A PrinterSettings object specifying the papers size and margins.
Initializes a new instance of the PageSettings class with the specified PageSettings and PrinterSettings.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pageSettings As PageSettings, _
   ByVal printerSettings As PrinterSettings _
)
Visual Basic (Usage) Copy Code
Dim pageSettings As PageSettings
Dim printerSettings As PrinterSettings

Dim instance As PageSettings(pageSettings, printerSettings)
C#
public PageSettings(
   PageSettings pageSettings,
   PrinterSettings printerSettings
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pageSettings As PageSettings, _
   ByVal printerSettings As PrinterSettings _
)
Visual Basic (Usage) Copy Code
Dim pageSettings As PageSettings
Dim printerSettings As PrinterSettings

Dim instance As PageSettings(pageSettings, printerSettings)
C#
public PageSettings(
   PageSettings pageSettings,
   PrinterSettings printerSettings
)

Parameters

pageSettings
A PageSettings object specifying the landscape and paper kind.
printerSettings
A PrinterSettings object specifying the papers size and margins.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSettings Class
PageSettings Members
Overload List


PageSettings Class Methods

PageSettings Class Methods
[image]
Telerik.Reporting.Drawing Namespace : PageSettings Class

For a list of all members of this type, see PageSettings members.

Public Methods

 | Name | Description
Public Method | Clone | This member implements Clone
Public Method | ToPageSettings | Returns a PageSettings object based on the given PrinterSettings parameter.
Public Method | Update |
Top

See Also

Reference

PageSettings Class
Telerik.Reporting.Drawing Namespace


Clone Method

Clone Method
[image]
Telerik.Reporting.Drawing Namespace > PageSettings Class : Clone Method

This member implements Clone

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PageSettings
Dim value As Object

value = instance.Clone()
C#
public object Clone()

Return Value

The cloned PageSettings.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSettings Class
PageSettings Members


ToPageSettings Method

ToPageSettings Method
[image]
Telerik.Reporting.Drawing Namespace > PageSettings Class : ToPageSettings Method

printerSettings
A PrinterSettings object from which to create the PageSettings.
Returns a PageSettings object based on the given PrinterSettings parameter.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function ToPageSettings( _
   ByVal printerSettings As PrinterSettings _
) As PageSettings
Visual Basic (Usage) Copy Code
Dim instance As PageSettings
Dim printerSettings As PrinterSettings
Dim value As PageSettings

value = instance.ToPageSettings(printerSettings)
C#
public PageSettings ToPageSettings(
   PrinterSettings printerSettings
)

Parameters

printerSettings
A PrinterSettings object from which to create the PageSettings.

Return Value

A PageSettings object initialized from the printerSettings.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSettings Class
PageSettings Members


Update Method

Update Method
[image]
Telerik.Reporting.Drawing Namespace > PageSettings Class : Update Method

printerSettings

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Update( _
   ByVal printerSettings As PrinterSettings _
)
Visual Basic (Usage) Copy Code
Dim instance As PageSettings
Dim printerSettings As PrinterSettings

instance.Update(printerSettings)
C#
public void Update(
   PrinterSettings printerSettings
)

Parameters

printerSettings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSettings Class
PageSettings Members


PageSettings Class Properties

PageSettings Class Properties
[image]
Telerik.Reporting.Drawing Namespace : PageSettings Class

For a list of all members of this type, see PageSettings members.

Public Properties

 | Name | Description
Public Property | Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.
Public Property | Margins | Gets or sets the margins for this page.
Public Property | PaperKind | Gets or sets the paper kind for the page.
Public Property | PaperSize | Gets or sets the paper size for the page.
Top

See Also

Reference

PageSettings Class
Telerik.Reporting.Drawing Namespace


Landscape Property

Landscape Property
[image]
Telerik.Reporting.Drawing Namespace > PageSettings Class : Landscape Property

Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Landscape As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PageSettings
Dim value As Boolean

instance.Landscape = value

value = instance.Landscape
C#
public bool Landscape {get; set;}

Return Value

true if the page should be printed in landscape orientation; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSettings Class
PageSettings Members


Margins Property

Margins Property
[image]
Telerik.Reporting.Drawing Namespace > PageSettings Class : Margins Property

Gets or sets the margins for this page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Margins As MarginsU
Visual Basic (Usage) Copy Code
Dim instance As PageSettings
Dim value As MarginsU

instance.Margins = value

value = instance.Margins
C#
public MarginsU Margins {get; set;}

Return Value

A MarginsU that represents the margins for the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSettings Class
PageSettings Members


PaperKind Property

PaperKind Property
[image]
Telerik.Reporting.Drawing Namespace > PageSettings Class : PaperKind Property

Gets or sets the paper kind for the page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property PaperKind As PaperKind
Visual Basic (Usage) Copy Code
Dim instance As PageSettings
Dim value As PaperKind

instance.PaperKind = value

value = instance.PaperKind
C#
public PaperKind PaperKind {get; set;}

Return Value

A PaperKind that represents the kind of the paper.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSettings Class
PageSettings Members


PaperSize Property

PaperSize Property
[image]
Telerik.Reporting.Drawing Namespace > PageSettings Class : PaperSize Property

Gets or sets the paper size for the page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property PaperSize As SizeU
Visual Basic (Usage) Copy Code
Dim instance As PageSettings
Dim value As SizeU

instance.PaperSize = value

value = instance.PaperSize
C#
public SizeU PaperSize {get; set;}

Return Value

A SizeU that represents the size of the paper.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSettings Class
PageSettings Members


PointUConverter Class

PointUConverter Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : PointUConverter Class

Converts a PointU object from one data type to another. Access this class through the TypeDescriptor object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PointUConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As PointUConverter
C#
public class PointUConverter : TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Reporting.Drawing.PointUConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Members
Telerik.Reporting.Drawing Namespace


PointUConverter Class Members

PointUConverter Class Members
See Also Methods
[image]
Telerik.Reporting.Drawing Namespace : PointUConverter Class

The following tables list the members exposed by PointUConverter.

Public Constructors

 | Name | Description
Public Constructor | PointUConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Determines if this converter can convert an object in the given source type to the native type of the converter.
Public Method | CanConvertTo | Overloaded. Overridden. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the specified object to a PointU object.
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the specified object to the specified type.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Overridden. Creates an instance of this type given a set of property values for the object.
Public Method | GetCreateInstanceSupported | Overloaded. Overridden. Determines if changing a value on this object should require a call to CreateInstance to create a new value.
Public Method | GetProperties | Overloaded. Overridden. Retrieves the set of properties for this type. By default, a type does not return any properties.
Public Method | GetPropertiesSupported | Overloaded. Overridden. Determines if this object supports properties. By default, this is true.
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

PointUConverter Class
Telerik.Reporting.Drawing Namespace


PointUConverter Constructor

PointUConverter Constructor
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class : PointUConverter Constructor

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PointUConverter()
C#
public PointUConverter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PointUConverter()
C#
public PointUConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members


PointUConverter Class Methods

PointUConverter Class Methods
[image]
Telerik.Reporting.Drawing Namespace : PointUConverter Class

For a list of all members of this type, see PointUConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Determines if this converter can convert an object in the given source type to the native type of the converter.
Public Method | CanConvertTo | Overloaded. Overridden. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the specified object to a PointU object.
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the specified object to the specified type.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Overridden. Creates an instance of this type given a set of property values for the object.
Public Method | GetCreateInstanceSupported | Overloaded. Overridden. Determines if changing a value on this object should require a call to CreateInstance to create a new value.
Public Method | GetProperties | Overloaded. Overridden. Retrieves the set of properties for this type. By default, a type does not return any properties.
Public Method | GetPropertiesSupported | Overloaded. Overridden. Determines if this object supports properties. By default, this is true.
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

PointUConverter Class
Telerik.Reporting.Drawing Namespace


CanConvertFrom Method

CanConvertFrom Method
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class : CanConvertFrom Method

Determines if this converter can convert an object in the given source type to the native type of the converter.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Determines if this converter can convert an object in the given source type to the native type of the converter.
CanConvertFrom(Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Determines if this converter can convert an object in the given source type to the native type of the converter.
CanConvertFrom(Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

CanConvertFrom(ITypeDescriptorContext,Type) Method
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
sourceType
The type you want to convert from.
Determines if this converter can convert an object in the given source type to the native type of the converter.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PointUConverter
Dim context As ITypeDescriptorContext
Dim sourceType As Type
Dim value As Boolean

value = instance.CanConvertFrom(context, sourceType)
C#
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)

Parameters

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
sourceType
The type you want to convert from.

Return Value

true if this object can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members
Overload List


CanConvertTo Method

CanConvertTo Method
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class : CanConvertTo Method

Gets a value indicating whether this converter can convert an object to the given destination type using the context.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) | Gets a value indicating whether this converter can convert an object to the given destination type using the context.
CanConvertTo(Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) | Gets a value indicating whether this converter can convert an object to the given destination type using the context.
CanConvertTo(Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

CanConvertTo(ITypeDescriptorContext,Type) Method
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
An ITypeDescriptorContext object that provides a format context.
destinationType
A Type object that represents the type you want to convert to.
Gets a value indicating whether this converter can convert an object to the given destination type using the context.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PointUConverter
Dim context As ITypeDescriptorContext
Dim destinationType As Type
Dim value As Boolean

value = instance.CanConvertTo(context, destinationType)
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)

Parameters

context
An ITypeDescriptorContext object that provides a format context.
destinationType
A Type object that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members
Overload List


ConvertFrom Method

ConvertFrom Method
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class : ConvertFrom Method

Converts the specified object to a PointU object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the specified object to a PointU object.
ConvertFrom(Object) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the specified object to a PointU object.
ConvertFrom(Object) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
culture
An object that contains culture specific information, such as the language, calendar, and cultural conventions associated with a specific culture. It is based on the RFC 1766 standard.
value
The object to convert.
Converts the specified object to a PointU object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As PointUConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim value As Object

value = instance.ConvertFrom(context, culture, value)
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
culture
An object that contains culture specific information, such as the language, calendar, and cultural conventions associated with a specific culture. It is based on the RFC 1766 standard.
value
The object to convert.

Return Value

The converted object.

Exceptions

Exception | Description
ArgumentException | The conversion cannot be completed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members
Overload List


ConvertTo Method

ConvertTo Method
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class : ConvertTo Method

Converts the specified object to the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the specified object to the specified type.
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the specified object to the specified type.
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
culture
An object that contains culture specific information, such as the language, calendar, and cultural conventions associated with a specific culture. It is based on the RFC 1766 standard.
value
The object to convert.
destinationType
The type to convert the object to.
Converts the specified object to the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As PointUConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
culture
An object that contains culture specific information, such as the language, calendar, and cultural conventions associated with a specific culture. It is based on the RFC 1766 standard.
value
The object to convert.
destinationType
The type to convert the object to.

Return Value

The converted object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members
Overload List


CreateInstance Method

CreateInstance Method
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class : CreateInstance Method

Creates an instance of this type given a set of property values for the object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CreateInstance(ITypeDescriptorContext,IDictionary) | Creates an instance of this type given a set of property values for the object.
CreateInstance(IDictionary) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
CreateInstance(ITypeDescriptorContext,IDictionary) | Creates an instance of this type given a set of property values for the object.
CreateInstance(IDictionary) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members


CreateInstance(ITypeDescriptorContext,IDictionary) Method

CreateInstance(ITypeDescriptorContext,IDictionary) Method
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class > CreateInstance Method : CreateInstance(ITypeDescriptorContext,IDictionary) Method

context
A type descriptor through which additional context can be provided.
propertyValues
A dictionary of new property values. The dictionary contains a series of name-value pairs, one for each property returned from GetProperties.
Creates an instance of this type given a set of property values for the object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As PointUConverter
Dim context As ITypeDescriptorContext
Dim propertyValues As IDictionary
Dim value As Object

value = instance.CreateInstance(context, propertyValues)
C#
public override object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
)

Parameters

context
A type descriptor through which additional context can be provided.
propertyValues
A dictionary of new property values. The dictionary contains a series of name-value pairs, one for each property returned from GetProperties.

Return Value

The newly created object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members
Overload List


GetCreateInstanceSupported Method

GetCreateInstanceSupported Method
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class : GetCreateInstanceSupported Method

Determines if changing a value on this object should require a call to CreateInstance to create a new value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetCreateInstanceSupported(ITypeDescriptorContext) | Determines if changing a value on this object should require a call to CreateInstance to create a new value.
GetCreateInstanceSupported() | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
GetCreateInstanceSupported(ITypeDescriptorContext) | Determines if changing a value on this object should require a call to CreateInstance to create a new value.
GetCreateInstanceSupported() | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members


GetCreateInstanceSupported(ITypeDescriptorContext) Method

GetCreateInstanceSupported(ITypeDescriptorContext) Method
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported(ITypeDescriptorContext) Method

context
A type descriptor through which additional context can be provided.
Determines if changing a value on this object should require a call to CreateInstance to create a new value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PointUConverter
Dim context As ITypeDescriptorContext
Dim value As Boolean

value = instance.GetCreateInstanceSupported(context)
C#
public override bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
)

Parameters

context
A type descriptor through which additional context can be provided.

Return Value

true if the CreateInstance method should be called when a change is made to one or more properties of this object; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members
Overload List


GetProperties Method

GetProperties Method
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class : GetProperties Method

Retrieves the set of properties for this type. By default, a type does not return any properties.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetProperties(ITypeDescriptorContext,Object,Attribute[]) | Retrieves the set of properties for this type. By default, a type does not return any properties.
GetProperties(Object) | (Inherited from System.ComponentModel.TypeConverter)
GetProperties(ITypeDescriptorContext,Object) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
GetProperties(ITypeDescriptorContext,Object,Attribute[]) | Retrieves the set of properties for this type. By default, a type does not return any properties.
GetProperties(Object) | (Inherited from System.ComponentModel.TypeConverter)
GetProperties(ITypeDescriptorContext,Object) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

context
A type descriptor through which additional context can be provided.
value
The value of the object to get the properties for.
attributes
An array of Attribute objects that describe the properties.
Retrieves the set of properties for this type. By default, a type does not return any properties.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As PointUConverter
Dim context As ITypeDescriptorContext
Dim value As Object
Dim attributes() As Attribute
Dim value As PropertyDescriptorCollection

value = instance.GetProperties(context, value, attributes)
C#
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   Attribute[] attributes
)

Parameters

context
A type descriptor through which additional context can be provided.
value
The value of the object to get the properties for.
attributes
An array of Attribute objects that describe the properties.

Return Value

The set of properties that are exposed for this data type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members
Overload List


GetPropertiesSupported Method

GetPropertiesSupported Method
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class : GetPropertiesSupported Method

Determines if this object supports properties. By default, this is true.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetPropertiesSupported(ITypeDescriptorContext) | Determines if this object supports properties. By default, this is true.
GetPropertiesSupported() | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
GetPropertiesSupported(ITypeDescriptorContext) | Determines if this object supports properties. By default, this is true.
GetPropertiesSupported() | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members


GetPropertiesSupported(ITypeDescriptorContext) Method

GetPropertiesSupported(ITypeDescriptorContext) Method
[image]
Telerik.Reporting.Drawing Namespace > PointUConverter Class > GetPropertiesSupported Method : GetPropertiesSupported(ITypeDescriptorContext) Method

context
A type descriptor through which additional context can be provided.
Determines if this object supports properties. By default, this is true.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PointUConverter
Dim context As ITypeDescriptorContext
Dim value As Boolean

value = instance.GetPropertiesSupported(context)
C#
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
)

Parameters

context
A type descriptor through which additional context can be provided.

Return Value

true if GetProperties should be called to find the properties of this object; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointUConverter Class
PointUConverter Members
Overload List


SelectorCollection Class

SelectorCollection Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : SelectorCollection Class

Represents a collection of objects that implement ISelector

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class SelectorCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollection
C#
public class SelectorCollection : CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.Reporting.Drawing.SelectorCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollection Members
Telerik.Reporting.Drawing Namespace


SelectorCollection Class Members

SelectorCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : SelectorCollection Class

The following tables list the members exposed by SelectorCollection.

Public Constructors

 | Name | Description
Public Constructor | SelectorCollection Constructor | Overloaded. Initializes a new instance of the SelectorCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns the ISelector at the specified indexed location in the collection.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the specified selector to the selector collection.
Public Method | AddRange | Adds an array of selector objects to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified selector is a member of the collection.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified selector in the selector collection.
Public Method | Insert | Inserts a specified ISelector object into the SelectorCollection at the specified index location.
Public Method | Remove | Removes the specified selector from the selector collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs additional custom processes when validating a value.
Top

See Also

Reference

SelectorCollection Class
Telerik.Reporting.Drawing Namespace


SelectorCollection Constructor

SelectorCollection Constructor
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollection Class : SelectorCollection Constructor

Initializes a new instance of the SelectorCollection class.

Overload List

Overload | Description
SelectorCollection Constructor() | Initializes a new instance of the SelectorCollection class.
SelectorCollection Constructor(ISelector[]) |

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollection Class
SelectorCollection Members


SelectorCollection Constructor()

SelectorCollection Constructor()
See Also
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollection Class > SelectorCollection Constructor : SelectorCollection Constructor()

Initializes a new instance of the SelectorCollection class.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollection()
C#
public SelectorCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollection()
C#
public SelectorCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollection Class
SelectorCollection Members
Overload List


SelectorCollection Constructor(ISelector[])

SelectorCollection Constructor(ISelector[])
See Also
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollection Class > SelectorCollection Constructor : SelectorCollection Constructor(ISelector[])

selectors

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectors() As ISelector _
)
Visual Basic (Usage) Copy Code
Dim selectors() As ISelector

Dim instance As SelectorCollection(selectors)
C#
public SelectorCollection(
   ISelector[] selectors
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectors() As ISelector _
)
Visual Basic (Usage) Copy Code
Dim selectors() As ISelector

Dim instance As SelectorCollection(selectors)
C#
public SelectorCollection(
   ISelector[] selectors
)

Parameters

selectors

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollection Class
SelectorCollection Members
Overload List


SelectorCollection Class Methods

SelectorCollection Class Methods
[image]
Telerik.Reporting.Drawing Namespace : SelectorCollection Class

For a list of all members of this type, see SelectorCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds the specified selector to the selector collection.
Public Method | AddRange | Adds an array of selector objects to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified selector is a member of the collection.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified selector in the selector collection.
Public Method | Insert | Inserts a specified ISelector object into the SelectorCollection at the specified index location.
Public Method | Remove | Removes the specified selector from the selector collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs additional custom processes when validating a value.
Top

See Also

Reference

SelectorCollection Class
Telerik.Reporting.Drawing Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollection Class : Add Method

selector
The ISelector to add to the selector collection.
Adds the specified selector to the selector collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal selector As ISelector _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollection
Dim selector As ISelector
Dim value As Integer

value = instance.Add(selector)
C#
public int Add(
   ISelector selector
)

Parameters

selector
The ISelector to add to the selector collection.

Return Value

The index of the added ISelector

Remarks

The Add method allows you to add ISelector objects to the end of the selector collection.

You can also add new ISelector objects to the collection by using the AddRange method.

To remove a ISelector that you previously added, use the Remove, RemoveAt, or Clear methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollection Class
SelectorCollection Members


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollection Class : AddRange Method

selectors
An array of ISelector objects to add to the collection.
Adds an array of selector objects to the collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal selectors() As ISelector _
)
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollection
Dim selectors() As ISelector

instance.AddRange(selectors)
C#
public void AddRange(
   ISelector[] selectors
)

Parameters

selectors
An array of ISelector objects to add to the collection.

Remarks

The ISelector objects contained in the selectors array are appended to the end of the collection.

You can use the AddRange method to quickly add a group of ISelector objects to the collection instead of manually adding each ISelector to the collection using the Add method.

To remove a ISelector that you previously added, use the Remove, RemoveAt, or Clear methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollection Class
SelectorCollection Members


Contains Method

Contains Method
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollection Class : Contains Method

selector
The ISelector to locate in the collection.
Determines whether the specified selector is a member of the collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal selector As ISelector _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollection
Dim selector As ISelector
Dim value As Boolean

value = instance.Contains(selector)
C#
public bool Contains(
   ISelector selector
)

Parameters

selector
The ISelector to locate in the collection.

Return Value

true if the ISelector is a member of the collection; otherwise, false.

Remarks

This method enables you to determine whether a ISelector is a member of the collection before attempting to perform operations on the ISelector. You can use this method to confirm that an ISelector has been added to or is still a member of the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollection Class
SelectorCollection Members


IndexOf Method

IndexOf Method
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollection Class : IndexOf Method

selector
The ISelector to locate in the collection.
Retrieves the index of the specified selector in the selector collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal selector As ISelector _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollection
Dim selector As ISelector
Dim value As Integer

value = instance.IndexOf(selector)
C#
public int IndexOf(
   ISelector selector
)

Parameters

selector
The ISelector to locate in the collection.

Return Value

A zero-based index value that represents the position of the specified ISelector in the SelectorCollection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollection Class
SelectorCollection Members


Insert Method

Insert Method
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollection Class : Insert Method

index
The zero-based index location at which to insert the ISelector object.
selector
The ISelector object to insert into the collection.
Inserts a specified ISelector object into the SelectorCollection at the specified index location.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal selector As ISelector _
)
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollection
Dim index As Integer
Dim selector As ISelector

instance.Insert(index, selector)
C#
public void Insert(
   int index,
   ISelector selector
)

Parameters

index
The zero-based index location at which to insert the ISelector object.
selector
The ISelector object to insert into the collection.

Remarks

Use the Insert method to insert a specified ISelector object into the SelectorCollection object at a specified index location.

To add a ISelector object at the end of the SelectorCollection object, use the Add method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollection Class
SelectorCollection Members


OnValidate Method

OnValidate Method
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollection Class : OnValidate Method

value
The object to validate.
Performs additional custom processes when validating a value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnValidate( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollection
Dim value As Object

instance.OnValidate(value)
C#
protected override void OnValidate(
   object value
)

Parameters

value
The object to validate.

Exceptions

Exception | Description
ArgumentException | The object is not an implementer of the ISelector interface.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollection Class
SelectorCollection Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollection Class : Remove Method

selector
The ISelector to remove from the SelectorCollection.
Removes the specified selector from the selector collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal selector As ISelector _
)
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollection
Dim selector As ISelector

instance.Remove(selector)
C#
public void Remove(
   ISelector selector
)

Parameters

selector
The ISelector to remove from the SelectorCollection.

Remarks

When a ISelector is removed from the selector collection, all subsequent selectors are moved up one position in the collection.

You can also remove a ISelector by using the RemoveAt method, or remove all selectors by using the Clear method.

To add new ISelector objects to the collection, use the Add or AddRange methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollection Class
SelectorCollection Members


SelectorCollection Class Properties

SelectorCollection Class Properties
[image]
Telerik.Reporting.Drawing Namespace : SelectorCollection Class

For a list of all members of this type, see SelectorCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns the ISelector at the specified indexed location in the collection.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

SelectorCollection Class
Telerik.Reporting.Drawing Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollection Class : Item Property

index
The index of the selector to retrieve from the selector collection.
Returns the ISelector at the specified indexed location in the collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As ISelector
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollection
Dim index As Integer
Dim value As ISelector

instance.Item(index) = value

value = instance.Item(index)
C#
public ISelector this[
   int index
]; {get; set;}

Parameters

index
The index of the selector to retrieve from the selector collection.

Return Value

The ISelector located at the specified index location within the selector collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollection Class
SelectorCollection Members


SelectorCollectionConverter Class

SelectorCollectionConverter Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : SelectorCollectionConverter Class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Class SelectorCollectionConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollectionConverter
C#
private class SelectorCollectionConverter : TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Reporting.Drawing.SelectorCollectionConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollectionConverter Members
Telerik.Reporting.Drawing Namespace


SelectorCollectionConverter Class Members

SelectorCollectionConverter Class Members
See Also Methods
[image]
Telerik.Reporting.Drawing Namespace : SelectorCollectionConverter Class

The following tables list the members exposed by SelectorCollectionConverter.

Public Constructors

 | Name | Description
Public Constructor | SelectorCollectionConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

SelectorCollectionConverter Class
Telerik.Reporting.Drawing Namespace


SelectorCollectionConverter Constructor

SelectorCollectionConverter Constructor
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollectionConverter Class : SelectorCollectionConverter Constructor

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollectionConverter()
C#
public SelectorCollectionConverter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollectionConverter()
C#
public SelectorCollectionConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollectionConverter Class
SelectorCollectionConverter Members


SelectorCollectionConverter Class Methods

SelectorCollectionConverter Class Methods
[image]
Telerik.Reporting.Drawing Namespace : SelectorCollectionConverter Class

For a list of all members of this type, see SelectorCollectionConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

SelectorCollectionConverter Class
Telerik.Reporting.Drawing Namespace


ConvertTo Method

ConvertTo Method
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollectionConverter Class : ConvertTo Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollectionConverter Class
SelectorCollectionConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also
[image]
Telerik.Reporting.Drawing Namespace > SelectorCollectionConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As SelectorCollectionConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
culture
value
destinationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SelectorCollectionConverter Class
SelectorCollectionConverter Members
Overload List


SizeUConverter Class

SizeUConverter Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : SizeUConverter Class

Converts a SizeU object from one data type to another. Access this class through the TypeDescriptor object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class SizeUConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As SizeUConverter
C#
public class SizeUConverter : TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Reporting.Drawing.SizeUConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Members
Telerik.Reporting.Drawing Namespace


SizeUConverter Class Members

SizeUConverter Class Members
See Also Methods
[image]
Telerik.Reporting.Drawing Namespace : SizeUConverter Class

The following tables list the members exposed by SizeUConverter.

Public Constructors

 | Name | Description
Public Constructor | SizeUConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Determines if this converter can convert an object in the given source type to the native type of the converter.
Public Method | CanConvertTo | Overloaded. Overridden. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the specified object to a SizeU object.
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the specified object to the specified type.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Overridden. Creates an instance of this type given a set of property values for the object.
Public Method | GetCreateInstanceSupported | Overloaded. Overridden. Determines if changing a value on this object should require a call to CreateInstance to create a new value.
Public Method | GetProperties | Overloaded. Overridden. Retrieves the set of properties for this type. By default, a type does not return any properties.
Public Method | GetPropertiesSupported | Overloaded. Overridden. Determines if this object supports properties. By default, this is true.
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

SizeUConverter Class
Telerik.Reporting.Drawing Namespace


SizeUConverter Constructor

SizeUConverter Constructor
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class : SizeUConverter Constructor

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SizeUConverter()
C#
public SizeUConverter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SizeUConverter()
C#
public SizeUConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members


SizeUConverter Class Methods

SizeUConverter Class Methods
[image]
Telerik.Reporting.Drawing Namespace : SizeUConverter Class

For a list of all members of this type, see SizeUConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Determines if this converter can convert an object in the given source type to the native type of the converter.
Public Method | CanConvertTo | Overloaded. Overridden. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the specified object to a SizeU object.
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the specified object to the specified type.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Overridden. Creates an instance of this type given a set of property values for the object.
Public Method | GetCreateInstanceSupported | Overloaded. Overridden. Determines if changing a value on this object should require a call to CreateInstance to create a new value.
Public Method | GetProperties | Overloaded. Overridden. Retrieves the set of properties for this type. By default, a type does not return any properties.
Public Method | GetPropertiesSupported | Overloaded. Overridden. Determines if this object supports properties. By default, this is true.
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

SizeUConverter Class
Telerik.Reporting.Drawing Namespace


CanConvertFrom Method

CanConvertFrom Method
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class : CanConvertFrom Method

Determines if this converter can convert an object in the given source type to the native type of the converter.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Determines if this converter can convert an object in the given source type to the native type of the converter.
CanConvertFrom(Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Determines if this converter can convert an object in the given source type to the native type of the converter.
CanConvertFrom(Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

CanConvertFrom(ITypeDescriptorContext,Type) Method
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
sourceType
The type you want to convert from.
Determines if this converter can convert an object in the given source type to the native type of the converter.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SizeUConverter
Dim context As ITypeDescriptorContext
Dim sourceType As Type
Dim value As Boolean

value = instance.CanConvertFrom(context, sourceType)
C#
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)

Parameters

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
sourceType
The type you want to convert from.

Return Value

true if this object can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members
Overload List


CanConvertTo Method

CanConvertTo Method
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class : CanConvertTo Method

Gets a value indicating whether this converter can convert an object to the given destination type using the context.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) | Gets a value indicating whether this converter can convert an object to the given destination type using the context.
CanConvertTo(Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) | Gets a value indicating whether this converter can convert an object to the given destination type using the context.
CanConvertTo(Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

CanConvertTo(ITypeDescriptorContext,Type) Method
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
An ITypeDescriptorContext object that provides a format context.
destinationType
A Type object that represents the type you want to convert to.
Gets a value indicating whether this converter can convert an object to the given destination type using the context.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SizeUConverter
Dim context As ITypeDescriptorContext
Dim destinationType As Type
Dim value As Boolean

value = instance.CanConvertTo(context, destinationType)
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)

Parameters

context
An ITypeDescriptorContext object that provides a format context.
destinationType
A Type object that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members
Overload List


ConvertFrom Method

ConvertFrom Method
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class : ConvertFrom Method

Converts the specified object to a SizeU object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the specified object to a SizeU object.
ConvertFrom(Object) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the specified object to a SizeU object.
ConvertFrom(Object) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
culture
An object that contains culture specific information, such as the language, calendar, and cultural conventions associated with a specific culture. It is based on the RFC 1766 standard.
value
The object to convert.
Converts the specified object to a SizeU object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As SizeUConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim value As Object

value = instance.ConvertFrom(context, culture, value)
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
culture
An object that contains culture specific information, such as the language, calendar, and cultural conventions associated with a specific culture. It is based on the RFC 1766 standard.
value
The object to convert.

Return Value

The converted object.

Exceptions

Exception | Description
ArgumentException | The conversion cannot be completed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members
Overload List


ConvertTo Method

ConvertTo Method
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class : ConvertTo Method

Converts the specified object to the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the specified object to the specified type.
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the specified object to the specified type.
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
culture
An object that contains culture specific information, such as the language, calendar, and cultural conventions associated with a specific culture. It is based on the RFC 1766 standard.
value
The object to convert.
destinationType
The type to convert the object to.
Converts the specified object to the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As SizeUConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
culture
An object that contains culture specific information, such as the language, calendar, and cultural conventions associated with a specific culture. It is based on the RFC 1766 standard.
value
The object to convert.
destinationType
The type to convert the object to.

Return Value

The converted object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members
Overload List


CreateInstance Method

CreateInstance Method
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class : CreateInstance Method

Creates an instance of this type given a set of property values for the object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CreateInstance(ITypeDescriptorContext,IDictionary) | Creates an instance of this type given a set of property values for the object.
CreateInstance(IDictionary) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
CreateInstance(ITypeDescriptorContext,IDictionary) | Creates an instance of this type given a set of property values for the object.
CreateInstance(IDictionary) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members


CreateInstance(ITypeDescriptorContext,IDictionary) Method

CreateInstance(ITypeDescriptorContext,IDictionary) Method
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class > CreateInstance Method : CreateInstance(ITypeDescriptorContext,IDictionary) Method

context
A type descriptor through which additional context can be provided.
propertyValues
A dictionary of new property values. The dictionary contains a series of name-value pairs, one for each property returned from GetProperties.
Creates an instance of this type given a set of property values for the object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As SizeUConverter
Dim context As ITypeDescriptorContext
Dim propertyValues As IDictionary
Dim value As Object

value = instance.CreateInstance(context, propertyValues)
C#
public override object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
)

Parameters

context
A type descriptor through which additional context can be provided.
propertyValues
A dictionary of new property values. The dictionary contains a series of name-value pairs, one for each property returned from GetProperties.

Return Value

The newly created object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members
Overload List


GetCreateInstanceSupported Method

GetCreateInstanceSupported Method
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class : GetCreateInstanceSupported Method

Determines if changing a value on this object should require a call to CreateInstance to create a new value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetCreateInstanceSupported(ITypeDescriptorContext) | Determines if changing a value on this object should require a call to CreateInstance to create a new value.
GetCreateInstanceSupported() | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
GetCreateInstanceSupported(ITypeDescriptorContext) | Determines if changing a value on this object should require a call to CreateInstance to create a new value.
GetCreateInstanceSupported() | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members


GetCreateInstanceSupported(ITypeDescriptorContext) Method

GetCreateInstanceSupported(ITypeDescriptorContext) Method
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported(ITypeDescriptorContext) Method

context
A type descriptor through which additional context can be provided.
Determines if changing a value on this object should require a call to CreateInstance to create a new value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SizeUConverter
Dim context As ITypeDescriptorContext
Dim value As Boolean

value = instance.GetCreateInstanceSupported(context)
C#
public override bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
)

Parameters

context
A type descriptor through which additional context can be provided.

Return Value

true if the CreateInstance method should be called when a change is made to one or more properties of this object; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members
Overload List


GetProperties Method

GetProperties Method
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class : GetProperties Method

Retrieves the set of properties for this type. By default, a type does not return any properties.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetProperties(ITypeDescriptorContext,Object,Attribute[]) | Retrieves the set of properties for this type. By default, a type does not return any properties.
GetProperties(Object) | (Inherited from System.ComponentModel.TypeConverter)
GetProperties(ITypeDescriptorContext,Object) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
GetProperties(ITypeDescriptorContext,Object,Attribute[]) | Retrieves the set of properties for this type. By default, a type does not return any properties.
GetProperties(Object) | (Inherited from System.ComponentModel.TypeConverter)
GetProperties(ITypeDescriptorContext,Object) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

context
A type descriptor through which additional context can be provided.
value
The value of the object to get the properties for.
attributes
An array of Attribute objects that describe the properties.
Retrieves the set of properties for this type. By default, a type does not return any properties.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As SizeUConverter
Dim context As ITypeDescriptorContext
Dim value As Object
Dim attributes() As Attribute
Dim value As PropertyDescriptorCollection

value = instance.GetProperties(context, value, attributes)
C#
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   Attribute[] attributes
)

Parameters

context
A type descriptor through which additional context can be provided.
value
The value of the object to get the properties for.
attributes
An array of Attribute objects that describe the properties.

Return Value

The set of properties that are exposed for this data type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members
Overload List


GetPropertiesSupported Method

GetPropertiesSupported Method
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class : GetPropertiesSupported Method

Determines if this object supports properties. By default, this is true.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
GetPropertiesSupported(ITypeDescriptorContext) | Determines if this object supports properties. By default, this is true.
GetPropertiesSupported() | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
GetPropertiesSupported(ITypeDescriptorContext) | Determines if this object supports properties. By default, this is true.
GetPropertiesSupported() | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members


GetPropertiesSupported(ITypeDescriptorContext) Method

GetPropertiesSupported(ITypeDescriptorContext) Method
[image]
Telerik.Reporting.Drawing Namespace > SizeUConverter Class > GetPropertiesSupported Method : GetPropertiesSupported(ITypeDescriptorContext) Method

context
A type descriptor through which additional context can be provided.
Determines if this object supports properties. By default, this is true.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SizeUConverter
Dim context As ITypeDescriptorContext
Dim value As Boolean

value = instance.GetPropertiesSupported(context)
C#
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
)

Parameters

context
A type descriptor through which additional context can be provided.

Return Value

true if GetProperties should be called to find the properties of this object; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeUConverter Class
SizeUConverter Members
Overload List


Style Class

Style Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : Style Class

Represents the style of a report item.

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Style
   Inherits StyleBase
Visual Basic (Usage) Copy Code
Dim instance As Style
C#
public class Style : StyleBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.StyleBase
Telerik.Reporting.Drawing.Style
Telerik.Reporting.Processing.ProcessingElement.ProcessingStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Members
Telerik.Reporting.Drawing Namespace


Style Class Members

Style Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : Style Class

The following tables list the members exposed by Style.

Public Constructors

 | Name | Description
Public Constructor | Style Constructor |
Top

Public Properties

 | Name | Description
Public Property | BackgroundColor | Gets or sets the background color of the report item.
Public Property | BackgroundImage | Gets a BackgroundImage object that controls the image displayed in the background of the report item.
Public Property | BorderColor | Gets a BorderColor object used to define the border color of a report item.
Public Property | BorderStyle | Gets a BorderStyle object used to define the border style of a report item.
Public Property | BorderWidth | Gets a BorderWidth object used to define the border width of a report item.
Public Property | Color | Gets or sets the foreground color of the report item.
Public Property | Font | Gets a Font object representing the font of the report item.
Public Property | LineStyle | Gets or sets a LineStyle object used to define the line style of report items that support it, such as lines and shapes.
Public Property | LineWidth | Gets or sets a Unit representing the line width of report items that support it, such as lines and shapes.
Public Property | Padding | Gets a Padding object used to define the padding of a report item.
Public Property | TextAlign | Gets or sets the horizontal alignment of text in the report item.
Public Property | VerticalAlign | Gets or sets the vertical alignment of text in the report item.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed.
Top

Protected Properties

 | Name | Description
Protected Property | Styles |
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

Style Class
Telerik.Reporting.Drawing Namespace


Style Constructor

Style Constructor
[image]
Telerik.Reporting.Drawing Namespace > Style Class : Style Constructor

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Style()
C#
public Style()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Style()
C#
public Style()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


Style Class Properties

Style Class Properties
[image]
Telerik.Reporting.Drawing Namespace : Style Class

For a list of all members of this type, see Style members.

Public Properties

 | Name | Description
Public Property | BackgroundColor | Gets or sets the background color of the report item.
Public Property | BackgroundImage | Gets a BackgroundImage object that controls the image displayed in the background of the report item.
Public Property | BorderColor | Gets a BorderColor object used to define the border color of a report item.
Public Property | BorderStyle | Gets a BorderStyle object used to define the border style of a report item.
Public Property | BorderWidth | Gets a BorderWidth object used to define the border width of a report item.
Public Property | Color | Gets or sets the foreground color of the report item.
Public Property | Font | Gets a Font object representing the font of the report item.
Public Property | LineStyle | Gets or sets a LineStyle object used to define the line style of report items that support it, such as lines and shapes.
Public Property | LineWidth | Gets or sets a Unit representing the line width of report items that support it, such as lines and shapes.
Public Property | Padding | Gets a Padding object used to define the padding of a report item.
Public Property | TextAlign | Gets or sets the horizontal alignment of text in the report item.
Public Property | VerticalAlign | Gets or sets the vertical alignment of text in the report item.
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed.
Top

Protected Properties

 | Name | Description
Protected Property | Styles |
Top

See Also

Reference

Style Class
Telerik.Reporting.Drawing Namespace


BackgroundColor Property

BackgroundColor Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : BackgroundColor Property

Gets or sets the background color of the report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property BackgroundColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As Color

instance.BackgroundColor = value

value = instance.BackgroundColor
C#
public Color BackgroundColor {get; set;}

Return Value

A Color that represents the background color of the report item. The default is Empty, which indicates that this property is not set.

Remarks

Use the BackColor property to specify the background color of the report item. This property is set using a Color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


BackgroundImage Property

BackgroundImage Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : BackgroundImage Property

Gets a BackgroundImage object that controls the image displayed in the background of the report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackgroundImage As BackgroundImage
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As BackgroundImage

value = instance.BackgroundImage
C#
public BackgroundImage BackgroundImage {get;}

Return Value

An BackgroundImage that represents the image to display in the background of the report item. Report items have no background image by default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


BorderColor Property

BorderColor Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : BorderColor Property

Gets a BorderColor object used to define the border color of a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BorderColor As BorderColor
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As BorderColor

value = instance.BorderColor
C#
public BorderColor BorderColor {get;}

Return Value

A BorderColor representing the border color of the report item.

Remarks

You can set the border color of the item by using the properties BorderColor.Default, BorderColor.Left, BorderColor.Right, BorderColor.Top, and BorderColor.Bottom. The Default property is used to set all borders colors at once. All borders are Black by default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


BorderStyle Property

BorderStyle Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : BorderStyle Property

Gets a BorderStyle object used to define the border style of a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As BorderStyle

value = instance.BorderStyle
C#
public BorderStyle BorderStyle {get;}

Return Value

A BorderStyle representing the border style of the report item.

Remarks

You can set the border style of the item by using the properties BorderStyle.Default, BorderStyle.Left, BorderStyle.Right, BorderStyle.Top, and BorderStyle.Bottom. The Default property is used to set all borders styles at once. All borders are BorderType.None by default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


BorderWidth Property

BorderWidth Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : BorderWidth Property

Gets a BorderWidth object used to define the border width of a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BorderWidth As BorderWidth
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As BorderWidth

value = instance.BorderWidth
C#
public BorderWidth BorderWidth {get;}

Return Value

A BorderWidth representing the border width of the report item.

Remarks

You can set the border width of the item by using the properties BorderWidth.Default, BorderWidth.Left, BorderWidth.Right, BorderWidth.Top, and BorderWidth.Bottom. The Default property is used to set all borders widths at once. All borders are 1pt wide by default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


Color Property

Color Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : Color Property

Gets or sets the foreground color of the report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As Color

instance.Color = value

value = instance.Color
C#
public Color Color {get; set;}

Return Value

The foreground Color of the report item. The default is Black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


Font Property

Font Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : Font Property

Gets a Font object representing the font of the report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As Font

value = instance.Font
C#
public Font Font {get;}

Return Value

A Font object used to define the font of a report item. By default the font of a report item is Arial-Regular, 10pts.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


LineStyle Property

LineStyle Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : LineStyle Property

Gets or sets a LineStyle object used to define the line style of report items that support it, such as lines and shapes.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property LineStyle As LineStyle
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As LineStyle

instance.LineStyle = value

value = instance.LineStyle
C#
public LineStyle LineStyle {get; set;}

Return Value

A LineStyle object representing the line style of the report item. By default the line style is LineStyle.Solid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


LineWidth Property

LineWidth Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : LineWidth Property

Gets or sets a Unit representing the line width of report items that support it, such as lines and shapes.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property LineWidth As Unit
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As Unit

instance.LineWidth = value

value = instance.LineWidth
C#
public Unit LineWidth {get; set;}

Return Value

A Unit value representing the line width of the report item. By default the width is 1pt.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


Padding Property

Padding Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : Padding Property

Gets a Padding object used to define the padding of a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Padding As Padding
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As Padding

value = instance.Padding
C#
public Padding Padding {get;}

Return Value

A Padding object representing the padding of the report item.

Remarks

You can set the padding of the item by using the properties Padding.Left, Padding.Right, Padding.Top, and Padding.Bottom. Padding on all sides is Unit.Zero by default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


Styles Property

Styles Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : Styles Property

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Styles As Style.StyleCollection
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As Style.StyleCollection

value = instance.Styles
C#
protected Style.StyleCollection Styles {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


TextAlign Property

TextAlign Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : TextAlign Property

Gets or sets the horizontal alignment of text in the report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property TextAlign As HorizontalAlign
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As HorizontalAlign

instance.TextAlign = value

value = instance.TextAlign
C#
public HorizontalAlign TextAlign {get; set;}

Return Value

One of the HorizontalAlign values. The default is HorizontalAlign.Left.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


VerticalAlign Property

VerticalAlign Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : VerticalAlign Property

Gets or sets the vertical alignment of text in the report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property VerticalAlign As VerticalAlign
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As VerticalAlign

instance.VerticalAlign = value

value = instance.VerticalAlign
C#
public VerticalAlign VerticalAlign {get; set;}

Return Value

One of the VerticalAlign values. The default is VerticalAlign.Top.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


Visible Property

Visible Property
[image]
Telerik.Reporting.Drawing Namespace > Style Class : Visible Property

Gets or sets a value indicating whether the report item is displayed.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Style
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Return Value

true if the report item is displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Style Class
Style Members


StyleBase Class

StyleBase Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : StyleBase Class

This class supports the Telerik Reporting infrastructure and is not intended to be used directly from your code.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class StyleBase
Visual Basic (Usage) Copy Code
Dim instance As StyleBase
C#
public abstract class StyleBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.StyleBase
Telerik.Reporting.Drawing.BackgroundImage
Telerik.Reporting.Drawing.BorderBase
Telerik.Reporting.Drawing.Font
Telerik.Reporting.Drawing.Padding
Telerik.Reporting.Drawing.Style

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBase Members
Telerik.Reporting.Drawing Namespace


StyleBase Class Members

StyleBase Class Members
See Also Methods
[image]
Telerik.Reporting.Drawing Namespace : StyleBase Class

The following tables list the members exposed by StyleBase.

Public Methods

 | Name | Description
Public Method | ToString | Overloaded.
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml |
Protected Method | WriteXml |
Top

See Also

Reference

StyleBase Class
Telerik.Reporting.Drawing Namespace


StyleBase Class Methods

StyleBase Class Methods
[image]
Telerik.Reporting.Drawing Namespace : StyleBase Class

For a list of all members of this type, see StyleBase members.

Public Methods

 | Name | Description
Public Method | ToString | Overloaded.
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml |
Protected Method | WriteXml |
Top

See Also

Reference

StyleBase Class
Telerik.Reporting.Drawing Namespace


ReadXml Method

ReadXml Method
[image]
Telerik.Reporting.Drawing Namespace > StyleBase Class : ReadXml Method

reader

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ReadXml( _
   ByVal reader As XmlReader _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleBase
Dim reader As XmlReader

instance.ReadXml(reader)
C#
protected virtual void ReadXml(
   XmlReader reader
)

Parameters

reader

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBase Class
StyleBase Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing Namespace > StyleBase Class : ToString Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ToString(String[]) |

Overload List

Overload | Description
ToString(String[]) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBase Class
StyleBase Members


ToString(String[]) Method

ToString(String[]) Method
[image]
Telerik.Reporting.Drawing Namespace > StyleBase Class > ToString Method : ToString(String[]) Method

members

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Function ToString( _
   ByVal members() As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As StyleBase
Dim members() As String
Dim value As String

value = instance.ToString(members)
C#
protected virtual string ToString(
   string[] members
)

Parameters

members

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBase Class
StyleBase Members
Overload List


WriteXml Method

WriteXml Method
[image]
Telerik.Reporting.Drawing Namespace > StyleBase Class : WriteXml Method

writer

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub WriteXml( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleBase
Dim writer As XmlWriter

instance.WriteXml(writer)
C#
protected virtual void WriteXml(
   XmlWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleBase Class
StyleBase Members


StyleRule Class

StyleRule Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : StyleRule Class

Represents a style rule to be applied.

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleRule
Visual Basic (Usage) Copy Code
Dim instance As StyleRule
C#
public class StyleRule

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.StyleRule

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRule Members
Telerik.Reporting.Drawing Namespace


StyleRule Class Members

StyleRule Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : StyleRule Class

The following tables list the members exposed by StyleRule.

Public Constructors

 | Name | Description
Public Constructor | StyleRule Constructor | Initializes a new empty StyleRule.
Top

Public Properties

 | Name | Description
Public Property | Selectors | A collection of selectors that determine which report items the style applies to.
Public Property | Style | The Style to apply to all report items selected by the Selectors
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Returns a human-readable representation ot this StyleRule.
Top

See Also

Reference

StyleRule Class
Telerik.Reporting.Drawing Namespace


StyleRule Constructor

StyleRule Constructor
[image]
Telerik.Reporting.Drawing Namespace > StyleRule Class : StyleRule Constructor

Initializes a new empty StyleRule.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleRule()
C#
public StyleRule()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleRule()
C#
public StyleRule()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRule Class
StyleRule Members


StyleRule Class Methods

StyleRule Class Methods
[image]
Telerik.Reporting.Drawing Namespace : StyleRule Class

For a list of all members of this type, see StyleRule members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Returns a human-readable representation ot this StyleRule.
Top

See Also

Reference

StyleRule Class
Telerik.Reporting.Drawing Namespace


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing Namespace > StyleRule Class : ToString Method

Returns a human-readable representation ot this StyleRule.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As StyleRule
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A human-readable representation ot this StyleRule.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRule Class
StyleRule Members


StyleRule Class Properties

StyleRule Class Properties
[image]
Telerik.Reporting.Drawing Namespace : StyleRule Class

For a list of all members of this type, see StyleRule members.

Public Properties

 | Name | Description
Public Property | Selectors | A collection of selectors that determine which report items the style applies to.
Public Property | Style | The Style to apply to all report items selected by the Selectors
Top

See Also

Reference

StyleRule Class
Telerik.Reporting.Drawing Namespace


Selectors Property

Selectors Property
[image]
Telerik.Reporting.Drawing Namespace > StyleRule Class : Selectors Property

A collection of selectors that determine which report items the style applies to.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Selectors As SelectorCollection
Visual Basic (Usage) Copy Code
Dim instance As StyleRule
Dim value As SelectorCollection

value = instance.Selectors
C#
public SelectorCollection Selectors {get;}

Return Value

A SelectorCollection object containing all of the selectors for this rule.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRule Class
StyleRule Members


Style Property

Style Property
[image]
Telerik.Reporting.Drawing Namespace > StyleRule Class : Style Property

The Style to apply to all report items selected by the Selectors

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As StyleRule
Dim value As Style

instance.Style = value

value = instance.Style
C#
public Style Style {get; set;}

Return Value

A Style object defining the style of this StyleRule

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRule Class
StyleRule Members


StyleRuleCollection Class

StyleRuleCollection Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : StyleRuleCollection Class

Represents a collection of StyleRule objects.

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleRuleCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollection
C#
public class StyleRuleCollection : CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.Reporting.Drawing.StyleRuleCollection
Telerik.Reporting.Drawing.StyleSheet

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollection Members
Telerik.Reporting.Drawing Namespace


StyleRuleCollection Class Members

StyleRuleCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : StyleRuleCollection Class

The following tables list the members exposed by StyleRuleCollection.

Public Constructors

 | Name | Description
Public Constructor | StyleRuleCollection Constructor | Overloaded. Initializes a new instance of the StyleRuleCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns the StyleRule at the specified indexed location in the collection.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the specified style rule to the style rule collection.
Public Method | AddRange | Adds an array of style rule objects to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified style rule is a member of the collection.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified style rule in the selector collection.
Public Method | Insert | Inserts a specified StyleRule object into the StyleRuleCollection at the specified index location.
Public Method | Remove | Removes the specified style rule from the selector collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs additional custom processes when validating a value.
Top

See Also

Reference

StyleRuleCollection Class
Telerik.Reporting.Drawing Namespace


StyleRuleCollection Constructor

StyleRuleCollection Constructor
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollection Class : StyleRuleCollection Constructor

Initializes a new instance of the StyleRuleCollection class.

Overload List

Overload | Description
StyleRuleCollection Constructor() | Initializes a new instance of the StyleRuleCollection class.
StyleRuleCollection Constructor(StyleRule[]) |

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollection Class
StyleRuleCollection Members


StyleRuleCollection Constructor()

StyleRuleCollection Constructor()
See Also
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollection Class > StyleRuleCollection Constructor : StyleRuleCollection Constructor()

Initializes a new instance of the StyleRuleCollection class.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollection()
C#
public StyleRuleCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollection()
C#
public StyleRuleCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollection Class
StyleRuleCollection Members
Overload List


StyleRuleCollection Constructor(StyleRule[])

StyleRuleCollection Constructor(StyleRule[])
See Also
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollection Class > StyleRuleCollection Constructor : StyleRuleCollection Constructor(StyleRule[])

rules

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rules() As StyleRule _
)
Visual Basic (Usage) Copy Code
Dim rules() As StyleRule

Dim instance As StyleRuleCollection(rules)
C#
public StyleRuleCollection(
   StyleRule[] rules
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rules() As StyleRule _
)
Visual Basic (Usage) Copy Code
Dim rules() As StyleRule

Dim instance As StyleRuleCollection(rules)
C#
public StyleRuleCollection(
   StyleRule[] rules
)

Parameters

rules

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollection Class
StyleRuleCollection Members
Overload List


StyleRuleCollection Class Methods

StyleRuleCollection Class Methods
[image]
Telerik.Reporting.Drawing Namespace : StyleRuleCollection Class

For a list of all members of this type, see StyleRuleCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds the specified style rule to the style rule collection.
Public Method | AddRange | Adds an array of style rule objects to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified style rule is a member of the collection.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified style rule in the selector collection.
Public Method | Insert | Inserts a specified StyleRule object into the StyleRuleCollection at the specified index location.
Public Method | Remove | Removes the specified style rule from the selector collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Overridden. Performs additional custom processes when validating a value.
Top

See Also

Reference

StyleRuleCollection Class
Telerik.Reporting.Drawing Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollection Class : Add Method

rule
The StyleRule to add to the style rule collection.
Adds the specified style rule to the style rule collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal rule As StyleRule _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollection
Dim rule As StyleRule
Dim value As Integer

value = instance.Add(rule)
C#
public int Add(
   StyleRule rule
)

Parameters

rule
The StyleRule to add to the style rule collection.

Return Value

The index of the added StyleRule

Remarks

The Add method allows you to add StyleRule objects to the end of the style rule collection.

You can also add new StyleRule objects to the collection by using the AddRange method.

To remove a StyleRule that you previously added, use the Remove, RemoveAt, or Clear methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollection Class
StyleRuleCollection Members


AddRange Method

AddRange Method
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollection Class : AddRange Method

rules
An array of StyleRule objects to add to the collection.
Adds an array of style rule objects to the collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal rules() As StyleRule _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollection
Dim rules() As StyleRule

instance.AddRange(rules)
C#
public void AddRange(
   StyleRule[] rules
)

Parameters

rules
An array of StyleRule objects to add to the collection.

Remarks

The StyleRule objects contained in the rules array are appended to the end of the collection.

You can use the AddRange method to quickly add a group of StyleRule objects to the collection instead of manually adding each StyleRule to the collection using the Add method.

To remove a StyleRule that you previously added, use the Remove, RemoveAt, or Clear methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollection Class
StyleRuleCollection Members


Contains Method

Contains Method
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollection Class : Contains Method

rule
The StyleRule to locate in the collection.
Determines whether the specified style rule is a member of the collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal rule As StyleRule _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollection
Dim rule As StyleRule
Dim value As Boolean

value = instance.Contains(rule)
C#
public bool Contains(
   StyleRule rule
)

Parameters

rule
The StyleRule to locate in the collection.

Return Value

true if the StyleRule is a member of the collection; otherwise, false.

Remarks

This method enables you to determine whether a StyleRule is a member of the collection before attempting to perform operations on the StyleRule. You can use this method to confirm that an StyleRule has been added to or is still a member of the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollection Class
StyleRuleCollection Members


IndexOf Method

IndexOf Method
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollection Class : IndexOf Method

rule
The StyleRule to locate in the collection.
Retrieves the index of the specified style rule in the selector collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal rule As StyleRule _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollection
Dim rule As StyleRule
Dim value As Integer

value = instance.IndexOf(rule)
C#
public int IndexOf(
   StyleRule rule
)

Parameters

rule
The StyleRule to locate in the collection.

Return Value

A zero-based index value that represents the position of the specified StyleRule in the StyleRuleCollection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollection Class
StyleRuleCollection Members


Insert Method

Insert Method
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollection Class : Insert Method

index
The zero-based index location at which to insert the StyleRule object.
rule
The StyleRule object to insert into the collection.
Inserts a specified StyleRule object into the StyleRuleCollection at the specified index location.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal rule As StyleRule _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollection
Dim index As Integer
Dim rule As StyleRule

instance.Insert(index, rule)
C#
public void Insert(
   int index,
   StyleRule rule
)

Parameters

index
The zero-based index location at which to insert the StyleRule object.
rule
The StyleRule object to insert into the collection.

Remarks

Use the Insert method to insert a specified StyleRule object into the StyleRuleCollection object at a specified index location.

To add a StyleRule object at the end of the StyleRuleCollection object, use the Add method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollection Class
StyleRuleCollection Members


OnValidate Method

OnValidate Method
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollection Class : OnValidate Method

value
The object to validate.
Performs additional custom processes when validating a value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnValidate( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollection
Dim value As Object

instance.OnValidate(value)
C#
protected override void OnValidate(
   object value
)

Parameters

value
The object to validate.

Exceptions

Exception | Description
ArgumentException | The object is not a StyleRule.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollection Class
StyleRuleCollection Members


Remove Method

Remove Method
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollection Class : Remove Method

rule
The StyleRule to remove from the StyleRuleCollection.
Removes the specified style rule from the selector collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal rule As StyleRule _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollection
Dim rule As StyleRule

instance.Remove(rule)
C#
public void Remove(
   StyleRule rule
)

Parameters

rule
The StyleRule to remove from the StyleRuleCollection.

Remarks

When a StyleRule is removed from the style rule collection, all subsequent rules are moved up one position in the collection.

You can also remove a StyleRule by using the RemoveAt method, or remove all rules by using the Clear method.

To add new StyleRule objects to the collection, use the Add or AddRange methods.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollection Class
StyleRuleCollection Members


StyleRuleCollection Class Properties

StyleRuleCollection Class Properties
[image]
Telerik.Reporting.Drawing Namespace : StyleRuleCollection Class

For a list of all members of this type, see StyleRuleCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns the StyleRule at the specified indexed location in the collection.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

StyleRuleCollection Class
Telerik.Reporting.Drawing Namespace


Item Property

Item Property
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollection Class : Item Property

index
The index of the style rule to retrieve from the style rule collection.
Returns the StyleRule at the specified indexed location in the collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As StyleRule
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollection
Dim index As Integer
Dim value As StyleRule

instance.Item(index) = value

value = instance.Item(index)
C#
public StyleRule this[
   int index
]; {get; set;}

Parameters

index
The index of the style rule to retrieve from the style rule collection.

Return Value

The StyleRule located at the specified index location within the style rule collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollection Class
StyleRuleCollection Members


StyleRuleCollectionConverter Class

StyleRuleCollectionConverter Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : StyleRuleCollectionConverter Class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Class StyleRuleCollectionConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollectionConverter
C#
private class StyleRuleCollectionConverter : TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Reporting.Drawing.StyleRuleCollectionConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollectionConverter Members
Telerik.Reporting.Drawing Namespace


StyleRuleCollectionConverter Class Members

StyleRuleCollectionConverter Class Members
See Also Methods
[image]
Telerik.Reporting.Drawing Namespace : StyleRuleCollectionConverter Class

The following tables list the members exposed by StyleRuleCollectionConverter.

Public Constructors

 | Name | Description
Public Constructor | StyleRuleCollectionConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

StyleRuleCollectionConverter Class
Telerik.Reporting.Drawing Namespace


StyleRuleCollectionConverter Constructor

StyleRuleCollectionConverter Constructor
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollectionConverter Class : StyleRuleCollectionConverter Constructor

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollectionConverter()
C#
public StyleRuleCollectionConverter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollectionConverter()
C#
public StyleRuleCollectionConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollectionConverter Class
StyleRuleCollectionConverter Members


StyleRuleCollectionConverter Class Methods

StyleRuleCollectionConverter Class Methods
[image]
Telerik.Reporting.Drawing Namespace : StyleRuleCollectionConverter Class

For a list of all members of this type, see StyleRuleCollectionConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

StyleRuleCollectionConverter Class
Telerik.Reporting.Drawing Namespace


ConvertTo Method

ConvertTo Method
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollectionConverter Class : ConvertTo Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollectionConverter Class
StyleRuleCollectionConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also
[image]
Telerik.Reporting.Drawing Namespace > StyleRuleCollectionConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As StyleRuleCollectionConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
culture
value
destinationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleRuleCollectionConverter Class
StyleRuleCollectionConverter Members
Overload List


StyleSelector Class

StyleSelector Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : StyleSelector Class

An attribute selector based on the style name property.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleSelector
   Inherits AttributeSelectorBase
   Implements ISelector
Visual Basic (Usage) Copy Code
Dim instance As StyleSelector
C#
public class StyleSelector : AttributeSelectorBase, ISelector

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.TypeSelector
Telerik.Reporting.Drawing.AttributeSelectorBase
Telerik.Reporting.Drawing.StyleSelector

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSelector Members
Telerik.Reporting.Drawing Namespace


StyleSelector Class Members

StyleSelector Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : StyleSelector Class

The following tables list the members exposed by StyleSelector.

Public Constructors

 | Name | Description
Public Constructor | StyleSelector Constructor | Overloaded. Initializes a new StyleSelector.
Top

Protected Fields

 | Name | Description
Protected Field | attributeName | The name of the property to match. (Inherited from AttributeSelectorBase)
Protected Field | attributeValue | The value of the property to match. (Inherited from AttributeSelectorBase)
Protected Field | descriptor | The property descriptor associated with the property that this selector matches. (Inherited from AttributeSelectorBase)
Protected Field | initialized | (Inherited from TypeSelector)
Top

Public Properties

 | Name | Description
Public Property | StyleName | Gets or sets the name of the style that this selector matches.
Public Property | Type | Gets or sets the Type that this selector matches. (Inherited from TypeSelector)
Top

Public Methods

 | Name | Description
Public Method | DeepClone | Performs a deep clone of the TypeSelector. (Inherited from TypeSelector)
Public Method | Match | Matches a report item by the value of its property. (Inherited from AttributeSelectorBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this StyleSelector.
Top

Protected Methods

 | Name | Description
Protected Method | CopyTo | Copies the property name and value of the selector to the target typeSelector. (Inherited from AttributeSelectorBase)
Protected Method | OnTypeChange | Called when the TypeSelector.Type of this selector changes. (Inherited from TypeSelector)
Protected Method | ReadXml | Overridden.
Protected Method | WriteXml | Overridden.
Top

See Also

Reference

StyleSelector Class
Telerik.Reporting.Drawing Namespace


StyleSelector Constructor

StyleSelector Constructor
[image]
Telerik.Reporting.Drawing Namespace > StyleSelector Class : StyleSelector Constructor

Initializes a new StyleSelector.

Overload List

Overload | Description
StyleSelector Constructor() | Initializes a new StyleSelector.
StyleSelector Constructor(String) | Initializes a new StyleSelector with the specified style name.
StyleSelector Constructor(Type,String) | Initializes a new StyleSelector with the specified style name, that matches items of the specified Type

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSelector Class
StyleSelector Members


StyleSelector Constructor()

StyleSelector Constructor()
See Also
[image]
Telerik.Reporting.Drawing Namespace > StyleSelector Class > StyleSelector Constructor : StyleSelector Constructor()

Initializes a new StyleSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSelector()
C#
public StyleSelector()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSelector()
C#
public StyleSelector()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSelector Class
StyleSelector Members
Overload List


StyleSelector Constructor(String)

StyleSelector Constructor(String)
See Also
[image]
Telerik.Reporting.Drawing Namespace > StyleSelector Class > StyleSelector Constructor : StyleSelector Constructor(String)

name
A string value specifying the style name to match.
Initializes a new StyleSelector with the specified style name.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As StyleSelector(name)
C#
public StyleSelector(
   string name
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As StyleSelector(name)
C#
public StyleSelector(
   string name
)

Parameters

name
A string value specifying the style name to match.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSelector Class
StyleSelector Members
Overload List


StyleSelector Constructor(Type,String)

StyleSelector Constructor(Type,String)
See Also
[image]
Telerik.Reporting.Drawing Namespace > StyleSelector Class > StyleSelector Constructor : StyleSelector Constructor(Type,String)

type
The Type of items to match.
name
A string value specifying the style name to match.
Initializes a new StyleSelector with the specified style name, that matches items of the specified Type

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As Type, _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim type As Type
Dim name As String

Dim instance As StyleSelector(type, name)
C#
public StyleSelector(
   Type type,
   string name
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As Type, _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim type As Type
Dim name As String

Dim instance As StyleSelector(type, name)
C#
public StyleSelector(
   Type type,
   string name
)

Parameters

type
The Type of items to match.
name
A string value specifying the style name to match.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSelector Class
StyleSelector Members
Overload List


StyleSelector Class Methods

StyleSelector Class Methods
[image]
Telerik.Reporting.Drawing Namespace : StyleSelector Class

For a list of all members of this type, see StyleSelector members.

Public Methods

 | Name | Description
Public Method | DeepClone | Performs a deep clone of the TypeSelector. (Inherited from TypeSelector)
Public Method | Match | Matches a report item by the value of its property. (Inherited from AttributeSelectorBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this StyleSelector.
Top

Protected Methods

 | Name | Description
Protected Method | CopyTo | Copies the property name and value of the selector to the target typeSelector. (Inherited from AttributeSelectorBase)
Protected Method | OnTypeChange | Called when the TypeSelector.Type of this selector changes. (Inherited from TypeSelector)
Protected Method | ReadXml | Overridden.
Protected Method | WriteXml | Overridden.
Top

See Also

Reference

StyleSelector Class
Telerik.Reporting.Drawing Namespace


ReadXml Method

ReadXml Method
[image]
Telerik.Reporting.Drawing Namespace > StyleSelector Class : ReadXml Method

reader

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ReadXml( _
   ByVal reader As XmlReader _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleSelector
Dim reader As XmlReader

instance.ReadXml(reader)
C#
protected override void ReadXml(
   XmlReader reader
)

Parameters

reader

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSelector Class
StyleSelector Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing Namespace > StyleSelector Class : ToString Method

Returns a human-readable representation ot this StyleSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As StyleSelector
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A human-readable representation ot this StyleSelector.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSelector Class
StyleSelector Members


WriteXml Method

WriteXml Method
[image]
Telerik.Reporting.Drawing Namespace > StyleSelector Class : WriteXml Method

writer

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub WriteXml( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleSelector
Dim writer As XmlWriter

instance.WriteXml(writer)
C#
protected override void WriteXml(
   XmlWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSelector Class
StyleSelector Members


StyleSelector Class Properties

StyleSelector Class Properties
[image]
Telerik.Reporting.Drawing Namespace : StyleSelector Class

For a list of all members of this type, see StyleSelector members.

Public Properties

 | Name | Description
Public Property | StyleName | Gets or sets the name of the style that this selector matches.
Public Property | Type | Gets or sets the Type that this selector matches. (Inherited from TypeSelector)
Top

See Also

Reference

StyleSelector Class
Telerik.Reporting.Drawing Namespace


StyleName Property

StyleName Property
[image]
Telerik.Reporting.Drawing Namespace > StyleSelector Class : StyleName Property

Gets or sets the name of the style that this selector matches.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property StyleName As String
Visual Basic (Usage) Copy Code
Dim instance As StyleSelector
Dim value As String

instance.StyleName = value

value = instance.StyleName
C#
public string StyleName {get; set;}

Return Value

A string value representing the style name to match.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSelector Class
StyleSelector Members


StyleSheet Class

StyleSheet Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : StyleSheet Class

Represents a collection of styles for a ReportItemBase

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StyleSheet
   Inherits StyleRuleCollection
Visual Basic (Usage) Copy Code
Dim instance As StyleSheet
C#
public class StyleSheet : StyleRuleCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.Reporting.Drawing.StyleRuleCollection
Telerik.Reporting.Drawing.StyleSheet

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSheet Members
Telerik.Reporting.Drawing Namespace


StyleSheet Class Members

StyleSheet Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : StyleSheet Class

The following tables list the members exposed by StyleSheet.

Public Constructors

 | Name | Description
Public Constructor | StyleSheet Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns the StyleRule at the specified indexed location in the collection. (Inherited from StyleRuleCollection)
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the specified style rule to the style rule collection. (Inherited from StyleRuleCollection)
Public Method | AddRange | Adds an array of style rule objects to the collection. (Inherited from StyleRuleCollection)
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified style rule is a member of the collection. (Inherited from StyleRuleCollection)
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified style rule in the selector collection. (Inherited from StyleRuleCollection)
Public Method | Insert | Inserts a specified StyleRule object into the StyleRuleCollection at the specified index location. (Inherited from StyleRuleCollection)
Public Method | Remove | Removes the specified style rule from the selector collection. (Inherited from StyleRuleCollection)
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnChanged |
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | Overridden.
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | Overridden.
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | Overridden.
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | Overridden.
Protected Method | OnValidate | Performs additional custom processes when validating a value. (Inherited from StyleRuleCollection)
Top

See Also

Reference

StyleSheet Class
Telerik.Reporting.Drawing Namespace


StyleSheet Constructor

StyleSheet Constructor
[image]
Telerik.Reporting.Drawing Namespace > StyleSheet Class : StyleSheet Constructor

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSheet()
C#
public StyleSheet()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StyleSheet()
C#
public StyleSheet()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSheet Class
StyleSheet Members


StyleSheet Class Methods

StyleSheet Class Methods
[image]
Telerik.Reporting.Drawing Namespace : StyleSheet Class

For a list of all members of this type, see StyleSheet members.

Public Methods

 | Name | Description
Public Method | Add | Adds the specified style rule to the style rule collection. (Inherited from StyleRuleCollection)
Public Method | AddRange | Adds an array of style rule objects to the collection. (Inherited from StyleRuleCollection)
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the specified style rule is a member of the collection. (Inherited from StyleRuleCollection)
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Retrieves the index of the specified style rule in the selector collection. (Inherited from StyleRuleCollection)
Public Method | Insert | Inserts a specified StyleRule object into the StyleRuleCollection at the specified index location. (Inherited from StyleRuleCollection)
Public Method | Remove | Removes the specified style rule from the selector collection. (Inherited from StyleRuleCollection)
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnChanged |
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | Overridden.
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | Overridden.
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | Overridden.
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | Overridden.
Protected Method | OnValidate | Performs additional custom processes when validating a value. (Inherited from StyleRuleCollection)
Top

See Also

Reference

StyleSheet Class
Telerik.Reporting.Drawing Namespace


OnChanged Method

OnChanged Method
[image]
Telerik.Reporting.Drawing Namespace > StyleSheet Class : OnChanged Method

e

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleSheet
Dim e As EventArgs

instance.OnChanged(e)
C#
protected virtual void OnChanged(
   EventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSheet Class
StyleSheet Members


OnClearComplete Method

OnClearComplete Method
[image]
Telerik.Reporting.Drawing Namespace > StyleSheet Class : OnClearComplete Method

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnClearComplete()
Visual Basic (Usage) Copy Code
Dim instance As StyleSheet

instance.OnClearComplete()
C#
protected override void OnClearComplete()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSheet Class
StyleSheet Members


OnInsertComplete Method

OnInsertComplete Method
[image]
Telerik.Reporting.Drawing Namespace > StyleSheet Class : OnInsertComplete Method

index
value

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnInsertComplete( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleSheet
Dim index As Integer
Dim value As Object

instance.OnInsertComplete(index, value)
C#
protected override void OnInsertComplete(
   int index,
   object value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSheet Class
StyleSheet Members


OnRemoveComplete Method

OnRemoveComplete Method
[image]
Telerik.Reporting.Drawing Namespace > StyleSheet Class : OnRemoveComplete Method

index
value

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnRemoveComplete( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleSheet
Dim index As Integer
Dim value As Object

instance.OnRemoveComplete(index, value)
C#
protected override void OnRemoveComplete(
   int index,
   object value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSheet Class
StyleSheet Members


OnSetComplete Method

OnSetComplete Method
[image]
Telerik.Reporting.Drawing Namespace > StyleSheet Class : OnSetComplete Method

index
oldValue
newValue

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnSetComplete( _
   ByVal index As Integer, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As StyleSheet
Dim index As Integer
Dim oldValue As Object
Dim newValue As Object

instance.OnSetComplete(index, oldValue, newValue)
C#
protected override void OnSetComplete(
   int index,
   object oldValue,
   object newValue
)

Parameters

index
oldValue
newValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StyleSheet Class
StyleSheet Members


TypeSelector Class

TypeSelector Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : TypeSelector Class

Represents a selector base on a Type

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class TypeSelector
   Implements ISelector
Visual Basic (Usage) Copy Code
Dim instance As TypeSelector
C#
public class TypeSelector : ISelector

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.TypeSelector
Telerik.Reporting.Drawing.AttributeSelectorBase

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Members
Telerik.Reporting.Drawing Namespace


TypeSelector Class Members

TypeSelector Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : TypeSelector Class

The following tables list the members exposed by TypeSelector.

Public Constructors

 | Name | Description
Public Constructor | TypeSelector Constructor | Overloaded. Initializes a new instance of the TypeSelector class that matches any type of report item.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AnyType | Initializes a new type that matches any type of report item.
Top

Protected Fields

 | Name | Description
Protected Field | initialized |
Top

Public Properties

 | Name | Description
Public Property | Type | Gets or sets the Type that this selector matches.
Top

Public Methods

 | Name | Description
Public Method | DeepClone | Performs a deep clone of the TypeSelector.
static (Shared in Visual Basic) | Lookup |
Public Method | Match | Matches a ReportItemBase based on its type.
Public Method | ToString | Overridden. Creates a human-readable string that represents this TypeSelector.
Top

Protected Methods

 | Name | Description
Protected Method | CopyTo | Copies this TypeSelector to the specified typeSelector.
Protected Method | OnTypeChange | Called when the TypeSelector.Type of this selector changes.
Protected Method | ReadXml |
Protected Method | WriteXml |
Top

See Also

Reference

TypeSelector Class
Telerik.Reporting.Drawing Namespace


TypeSelector Constructor

TypeSelector Constructor
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class : TypeSelector Constructor

Initializes a new instance of the TypeSelector class that matches any type of report item.

Overload List

Overload | Description
TypeSelector Constructor() | Initializes a new instance of the TypeSelector class that matches any type of report item.
TypeSelector Constructor(Type) | Initializes a new instance of the TypeSelector class that matches items of the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members


TypeSelector Constructor()

TypeSelector Constructor()
See Also
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class > TypeSelector Constructor : TypeSelector Constructor()

Initializes a new instance of the TypeSelector class that matches any type of report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TypeSelector()
C#
public TypeSelector()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TypeSelector()
C#
public TypeSelector()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members
Overload List


TypeSelector Constructor(Type)

TypeSelector Constructor(Type)
See Also
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class > TypeSelector Constructor : TypeSelector Constructor(Type)

type
The Type that this selector matches.
Initializes a new instance of the TypeSelector class that matches items of the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As Type _
)
Visual Basic (Usage) Copy Code
Dim type As Type

Dim instance As TypeSelector(type)
C#
public TypeSelector(
   Type type
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As Type _
)
Visual Basic (Usage) Copy Code
Dim type As Type

Dim instance As TypeSelector(type)
C#
public TypeSelector(
   Type type
)

Parameters

type
The Type that this selector matches.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members
Overload List


TypeSelector Class Methods

TypeSelector Class Methods
[image]
Telerik.Reporting.Drawing Namespace : TypeSelector Class

For a list of all members of this type, see TypeSelector members.

Public Methods

 | Name | Description
Public Method | DeepClone | Performs a deep clone of the TypeSelector.
static (Shared in Visual Basic) | Lookup |
Public Method | Match | Matches a ReportItemBase based on its type.
Public Method | ToString | Overridden. Creates a human-readable string that represents this TypeSelector.
Top

Protected Methods

 | Name | Description
Protected Method | CopyTo | Copies this TypeSelector to the specified typeSelector.
Protected Method | OnTypeChange | Called when the TypeSelector.Type of this selector changes.
Protected Method | ReadXml |
Protected Method | WriteXml |
Top

See Also

Reference

TypeSelector Class
Telerik.Reporting.Drawing Namespace


CopyTo Method

CopyTo Method
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class : CopyTo Method

typeSelector
The TypeSelector to copy to.
Copies this TypeSelector to the specified typeSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CopyTo( _
   ByVal typeSelector As TypeSelector _
)
Visual Basic (Usage) Copy Code
Dim instance As TypeSelector
Dim typeSelector As TypeSelector

instance.CopyTo(typeSelector)
C#
protected virtual void CopyTo(
   TypeSelector typeSelector
)

Parameters

typeSelector
The TypeSelector to copy to.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members


DeepClone Method

DeepClone Method
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class : DeepClone Method

Performs a deep clone of the TypeSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function DeepClone() As ISelector
Visual Basic (Usage) Copy Code
Dim instance As TypeSelector
Dim value As ISelector

value = instance.DeepClone()
C#
public virtual ISelector DeepClone()

Return Value

The cloned TypeSelector

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members


Lookup Method

Lookup Method
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class : Lookup Method

name

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Lookup( _
   ByVal name As String _
) As Type
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As Type

value = TypeSelector.Lookup(name)
C#
public static Type Lookup(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members


Match Method

Match Method
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class : Match Method

item
The ReportItemBase to match.
Matches a ReportItemBase based on its type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal item As ReportItemBase _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TypeSelector
Dim item As ReportItemBase
Dim value As Boolean

value = instance.Match(item)
C#
public virtual bool Match(
   ReportItemBase item
)

Parameters

item
The ReportItemBase to match.

Return Value

true if item matches; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members


OnTypeChange Method

OnTypeChange Method
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class : OnTypeChange Method

Called when the TypeSelector.Type of this selector changes.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTypeChange()
Visual Basic (Usage) Copy Code
Dim instance As TypeSelector

instance.OnTypeChange()
C#
protected virtual void OnTypeChange()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members


ReadXml Method

ReadXml Method
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class : ReadXml Method

reader

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ReadXml( _
   ByVal reader As XmlReader _
)
Visual Basic (Usage) Copy Code
Dim instance As TypeSelector
Dim reader As XmlReader

instance.ReadXml(reader)
C#
protected virtual void ReadXml(
   XmlReader reader
)

Parameters

reader

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class : ToString Method

Creates a human-readable string that represents this TypeSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As TypeSelector
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A string that represents this TypeSelector.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members


WriteXml Method

WriteXml Method
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class : WriteXml Method

writer

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub WriteXml( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As TypeSelector
Dim writer As XmlWriter

instance.WriteXml(writer)
C#
protected virtual void WriteXml(
   XmlWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members


TypeSelector Class Properties

TypeSelector Class Properties
[image]
Telerik.Reporting.Drawing Namespace : TypeSelector Class

For a list of all members of this type, see TypeSelector members.

Public Properties

 | Name | Description
Public Property | Type | Gets or sets the Type that this selector matches.
Top

See Also

Reference

TypeSelector Class
Telerik.Reporting.Drawing Namespace


Type Property

Type Property
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class : Type Property

Gets or sets the Type that this selector matches.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As Type
Visual Basic (Usage) Copy Code
Dim instance As TypeSelector
Dim value As Type

instance.Type = value

value = instance.Type
C#
public Type Type {get; set;}

Return Value

A Type value to match.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members


TypeSelector Class Fields

TypeSelector Class Fields
[image]
Telerik.Reporting.Drawing Namespace : TypeSelector Class

For a list of all members of this type, see TypeSelector members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AnyType | Initializes a new type that matches any type of report item.
Top

Protected Fields

 | Name | Description
Protected Field | initialized |
Top

See Also

Reference

TypeSelector Class
Telerik.Reporting.Drawing Namespace


AnyType Field

AnyType Field
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class : AnyType Field

Initializes a new type that matches any type of report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly AnyType As Type
Visual Basic (Usage) Copy Code
Dim value As Type

value = TypeSelector.AnyType
C#
public static readonly Type AnyType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members


initialized Field

initialized Field
[image]
Telerik.Reporting.Drawing Namespace > TypeSelector Class : initialized Field

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected initialized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TypeSelector
Dim value As Boolean

value = instance.initialized

instance.initialized = value
C#
protected bool initialized

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TypeSelector Class
TypeSelector Members


UnitConverter Class

UnitConverter Class
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : UnitConverter Class

Converts a Unit object from one data type to another. Access this class through the TypeDescriptor object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class UnitConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As UnitConverter
C#
public class UnitConverter : TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Telerik.Reporting.Drawing.UnitConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnitConverter Members
Telerik.Reporting.Drawing Namespace


UnitConverter Class Members

UnitConverter Class Members
See Also Methods
[image]
Telerik.Reporting.Drawing Namespace : UnitConverter Class

The following tables list the members exposed by UnitConverter.

Public Constructors

 | Name | Description
Public Constructor | UnitConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Determines if this converter can convert an object in the given source type to the native type of the converter.
Public Method | CanConvertTo | Overloaded. Overridden. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the specified object to a Unit object.
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the specified object to the specified type.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

UnitConverter Class
Telerik.Reporting.Drawing Namespace


UnitConverter Constructor

UnitConverter Constructor
[image]
Telerik.Reporting.Drawing Namespace > UnitConverter Class : UnitConverter Constructor

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UnitConverter()
C#
public UnitConverter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UnitConverter()
C#
public UnitConverter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnitConverter Class
UnitConverter Members


UnitConverter Class Methods

UnitConverter Class Methods
[image]
Telerik.Reporting.Drawing Namespace : UnitConverter Class

For a list of all members of this type, see UnitConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Determines if this converter can convert an object in the given source type to the native type of the converter.
Public Method | CanConvertTo | Overloaded. Overridden. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the specified object to a Unit object.
Public Method | ConvertFromInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the specified object to the specified type.
Public Method | ConvertToInvariantString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

UnitConverter Class
Telerik.Reporting.Drawing Namespace


CanConvertFrom Method

CanConvertFrom Method
[image]
Telerik.Reporting.Drawing Namespace > UnitConverter Class : CanConvertFrom Method

Determines if this converter can convert an object in the given source type to the native type of the converter.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Determines if this converter can convert an object in the given source type to the native type of the converter.
CanConvertFrom(Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Determines if this converter can convert an object in the given source type to the native type of the converter.
CanConvertFrom(Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnitConverter Class
UnitConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

CanConvertFrom(ITypeDescriptorContext,Type) Method
[image]
Telerik.Reporting.Drawing Namespace > UnitConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
sourceType
The type you want to convert from.
Determines if this converter can convert an object in the given source type to the native type of the converter.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UnitConverter
Dim context As ITypeDescriptorContext
Dim sourceType As Type
Dim value As Boolean

value = instance.CanConvertFrom(context, sourceType)
C#
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)

Parameters

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
sourceType
The type you want to convert from.

Return Value

true if this object can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnitConverter Class
UnitConverter Members
Overload List


CanConvertTo Method

CanConvertTo Method
[image]
Telerik.Reporting.Drawing Namespace > UnitConverter Class : CanConvertTo Method

Gets a value indicating whether this converter can convert an object to the given destination type using the context.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) | Gets a value indicating whether this converter can convert an object to the given destination type using the context.
CanConvertTo(Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) | Gets a value indicating whether this converter can convert an object to the given destination type using the context.
CanConvertTo(Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnitConverter Class
UnitConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

CanConvertTo(ITypeDescriptorContext,Type) Method
[image]
Telerik.Reporting.Drawing Namespace > UnitConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
An ITypeDescriptorContext object that provides a format context.
destinationType
A Type object that represents the type you want to convert to.
Gets a value indicating whether this converter can convert an object to the given destination type using the context.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UnitConverter
Dim context As ITypeDescriptorContext
Dim destinationType As Type
Dim value As Boolean

value = instance.CanConvertTo(context, destinationType)
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)

Parameters

context
An ITypeDescriptorContext object that provides a format context.
destinationType
A Type object that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnitConverter Class
UnitConverter Members
Overload List


ConvertFrom Method

ConvertFrom Method
[image]
Telerik.Reporting.Drawing Namespace > UnitConverter Class : ConvertFrom Method

Converts the specified object to a Unit object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the specified object to a Unit object.
ConvertFrom(Object) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) | Converts the specified object to a Unit object.
ConvertFrom(Object) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnitConverter Class
UnitConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also
[image]
Telerik.Reporting.Drawing Namespace > UnitConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
culture
An object that contains culture specific information, such as the language, calendar, and cultural conventions associated with a specific culture. It is based on the RFC 1766 standard.
value
The object to convert.
Converts the specified object to a Unit object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As UnitConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim value As Object

value = instance.ConvertFrom(context, culture, value)
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)

Parameters

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
culture
An object that contains culture specific information, such as the language, calendar, and cultural conventions associated with a specific culture. It is based on the RFC 1766 standard.
value
The object to convert.

Return Value

The converted object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnitConverter Class
UnitConverter Members
Overload List


ConvertTo Method

ConvertTo Method
[image]
Telerik.Reporting.Drawing Namespace > UnitConverter Class : ConvertTo Method

Converts the specified object to the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the specified object to the specified type.
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the specified object to the specified type.
ConvertTo(Object,Type) | (Inherited from System.ComponentModel.TypeConverter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnitConverter Class
UnitConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also
[image]
Telerik.Reporting.Drawing Namespace > UnitConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
culture
An object that contains culture specific information, such as the language, calendar, and cultural conventions associated with a specific culture. It is based on the RFC 1766 standard.
value
The object to convert.
destinationType
The type to convert the object to.
Converts the specified object to the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As UnitConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)

Parameters

context
A formatter context. This object can be used to get additional information about the environment this converter is being called from. This may be a null reference (Nothing in Visual Basic), so you should always check. Also, properties on the context object may also return a null reference (Nothing in Visual Basic).
culture
An object that contains culture specific information, such as the language, calendar, and cultural conventions associated with a specific culture. It is based on the RFC 1766 standard.
value
The object to convert.
destinationType
The type to convert the object to.

Return Value

The converted object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnitConverter Class
UnitConverter Members
Overload List


ISelector Interface

ISelector Interface
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : ISelector Interface

Allows an object to implement a style selector, and represents a set of methods to match a ReportItemBase and clone the selector.
Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISelector
Visual Basic (Usage) Copy Code
Dim instance As ISelector
C#
public interface ISelector

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISelector Members
Telerik.Reporting.Drawing Namespace


ISelector Interface Members

ISelector Interface Members
See Also Methods
[image]
Telerik.Reporting.Drawing Namespace : ISelector Interface

The following tables list the members exposed by ISelector.

Public Methods

 | Name | Description
Method | Match | Matches a ReportItemBase based on certain criteria.
Top

See Also

Reference

ISelector Interface
Telerik.Reporting.Drawing Namespace


ISelector Interface Methods

ISelector Interface Methods
[image]
Telerik.Reporting.Drawing Namespace : ISelector Interface

For a list of all members of this type, see ISelector members.

Public Methods

 | Name | Description
Method | Match | Matches a ReportItemBase based on certain criteria.
Top

See Also

Reference

ISelector Interface
Telerik.Reporting.Drawing Namespace


Match Method

Match Method
[image]
Telerik.Reporting.Drawing Namespace > ISelector Interface : Match Method

item
The ReportItemBase to match.
Matches a ReportItemBase based on certain criteria.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Function Match( _
   ByVal item As ReportItemBase _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISelector
Dim item As ReportItemBase
Dim value As Boolean

value = instance.Match(item)
C#
bool Match(
   ReportItemBase item
)

Parameters

item
The ReportItemBase to match.

Return Value

true if item matches; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISelector Interface
ISelector Members


PointU Structure

PointU Structure
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : PointU Structure

Represents an ordered pair of unit-based point x- and y-coordinates that defines a point in a two-dimensional plane.

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Structure PointU
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As PointU
C#
public struct PointU : ValueType

Syntax

Visual Basic (Declaration)
Public Structure PointU
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As PointU
C#
public struct PointU : ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Telerik.Reporting.Drawing.PointU

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Members
Telerik.Reporting.Drawing Namespace


PointU Structure Members

PointU Structure Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : PointU Structure

The following tables list the members exposed by PointU.

Public Constructors

 | Name | Description
Public Constructor | PointU Constructor | Overloaded. Initializes a new instance of the PointU class with the specified coordinates.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents a new instance of the PointU class with member data left uninitialized.
Top

Public Properties

 | Name | Description
Public Property | IsEmpty | Gets a value indicating whether this PointU is empty.
Public Property | X | Gets or sets the x-coordinate of this PointU
Public Property | Y | Gets or sets the y-coordinate of this PointU
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Specifies whether this PointU contains the same coordinates as the specified Object.
Public Method | GetHashCode | Overridden. Returns a hash code for this PointU structure.
Public Method | Offset | Offsets this PointU structure by a specified amount in the x- and y-direction.
Public Method | ToString | Overloaded. Overridden. Converts this PointU to a human readable string.
Top

Public Operators

Public Operator Addition | Translates the PointU by the specified SizeU.
Public Operator Equality | Compares two PointU structures. The result specifies whether the values of the PointU.X and PointU.Y properties of the two PointU structures are equal.
Public Operator Explicit Type Conversion | Overloaded. Converts the specified reporting PointU to a PointF.
Public Operator Inequality | Determines whether the coordinates of the specified points are not equal.
Public Operator Subtraction | Translates the PointU by the negative of a specified SizeU.
Top

See Also

Reference

PointU Structure
Telerik.Reporting.Drawing Namespace


PointU Constructor

PointU Constructor
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : PointU Constructor

Initializes a new instance of the PointU class with the specified coordinates.

Overload List

Overload | Description
PointU Constructor(Point) |
PointU Constructor(PointF) |
PointU Constructor(Unit,Unit) | Initializes a new instance of the PointU class with the specified coordinates.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


PointU Constructor(Point)

PointU Constructor(Point)
See Also
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure > PointU Constructor : PointU Constructor(Point)

pt

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pt As Point _
)
Visual Basic (Usage) Copy Code
Dim pt As Point

Dim instance As PointU(pt)
C#
public PointU(
   Point pt
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pt As Point _
)
Visual Basic (Usage) Copy Code
Dim pt As Point

Dim instance As PointU(pt)
C#
public PointU(
   Point pt
)

Parameters

pt

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members
Overload List


PointU Constructor(PointF)

PointU Constructor(PointF)
See Also
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure > PointU Constructor : PointU Constructor(PointF)

pt

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pt As PointF _
)
Visual Basic (Usage) Copy Code
Dim pt As PointF

Dim instance As PointU(pt)
C#
public PointU(
   PointF pt
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pt As PointF _
)
Visual Basic (Usage) Copy Code
Dim pt As PointF

Dim instance As PointU(pt)
C#
public PointU(
   PointF pt
)

Parameters

pt

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members
Overload List


PointU Constructor(Unit,Unit)

PointU Constructor(Unit,Unit)
See Also
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure > PointU Constructor : PointU Constructor(Unit,Unit)

x
The horizontal position of the point.
y
The vertical position of the point.
Initializes a new instance of the PointU class with the specified coordinates.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Unit, _
   ByVal y As Unit _
)
Visual Basic (Usage) Copy Code
Dim x As Unit
Dim y As Unit

Dim instance As PointU(x, y)
C#
public PointU(
   Unit x,
   Unit y
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Unit, _
   ByVal y As Unit _
)
Visual Basic (Usage) Copy Code
Dim x As Unit
Dim y As Unit

Dim instance As PointU(x, y)
C#
public PointU(
   Unit x,
   Unit y
)

Parameters

x
The horizontal position of the point.
y
The vertical position of the point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members
Overload List


PointU Structure Methods

PointU Structure Methods
[image]
Telerik.Reporting.Drawing Namespace : PointU Structure

For a list of all members of this type, see PointU members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Specifies whether this PointU contains the same coordinates as the specified Object.
Public Method | GetHashCode | Overridden. Returns a hash code for this PointU structure.
Public Method | Offset | Offsets this PointU structure by a specified amount in the x- and y-direction.
Public Method | ToString | Overloaded. Overridden. Converts this PointU to a human readable string.
Top

See Also

Reference

PointU Structure
Telerik.Reporting.Drawing Namespace


Equals Method

Equals Method
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : Equals Method

obj
The Object to test.
Specifies whether this PointU contains the same coordinates as the specified Object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PointU
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj
The Object to test.

Return Value

This method returns true if obj is a PointU and has the same coordinates as this PointU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : GetHashCode Method

Returns a hash code for this PointU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PointU
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Return Value

An integer value that specifies a hash value for this PointU structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


Offset Method

Offset Method
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : Offset Method

dx
A Unit value specifying the amount to offset in the horizontal direction.
dy
A Unit value specifying the amount to offset in the vertical direction.
Offsets this PointU structure by a specified amount in the x- and y-direction.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub Offset( _
   ByVal dx As Unit, _
   ByVal dy As Unit _
)
Visual Basic (Usage) Copy Code
Dim instance As PointU
Dim dx As Unit
Dim dy As Unit

instance.Offset(dx, dy)
C#
public void Offset(
   Unit dx,
   Unit dy
)

Parameters

dx
A Unit value specifying the amount to offset in the horizontal direction.
dy
A Unit value specifying the amount to offset in the vertical direction.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : ToString Method

Converts this PointU to a human readable string.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ToString() | Converts this PointU to a human readable string.
ToString(CultureInfo) | Converts this PointU to a human readable string according to the CultureInfo specified.

Overload List

Overload | Description
ToString() | Converts this PointU to a human readable string.
ToString(CultureInfo) | Converts this PointU to a human readable string according to the CultureInfo specified.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


ToString() Method

ToString() Method
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure > ToString Method : ToString() Method

Converts this PointU to a human readable string.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public NotOverridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PointU
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A string that represents this PointU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members
Overload List


ToString(CultureInfo) Method

ToString(CultureInfo) Method
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure > ToString Method : ToString(CultureInfo) Method

culture
A CultureInfo that is used to format the string.
Converts this PointU to a human readable string according to the CultureInfo specified.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function ToString( _
   ByVal culture As CultureInfo _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PointU
Dim culture As CultureInfo
Dim value As String

value = instance.ToString(culture)
C#
public string ToString(
   CultureInfo culture
)

Parameters

culture
A CultureInfo that is used to format the string.

Return Value

A string that represents this PointU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members
Overload List


PointU Structure Properties

PointU Structure Properties
[image]
Telerik.Reporting.Drawing Namespace : PointU Structure

For a list of all members of this type, see PointU members.

Public Properties

 | Name | Description
Public Property | IsEmpty | Gets a value indicating whether this PointU is empty.
Public Property | X | Gets or sets the x-coordinate of this PointU
Public Property | Y | Gets or sets the y-coordinate of this PointU
Top

See Also

Reference

PointU Structure
Telerik.Reporting.Drawing Namespace


IsEmpty Property

IsEmpty Property
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : IsEmpty Property

Gets a value indicating whether this PointU is empty.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PointU
Dim value As Boolean

value = instance.IsEmpty
C#
public bool IsEmpty {get;}

Return Value

true if both PointU.X and PointU.Y are equal to zero; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


X Property

X Property
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : X Property

Gets or sets the x-coordinate of this PointU

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property X As Unit
Visual Basic (Usage) Copy Code
Dim instance As PointU
Dim value As Unit

instance.X = value

value = instance.X
C#
public Unit X {get; set;}

Return Value

The x-coordinate of this PointU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


Y Property

Y Property
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : Y Property

Gets or sets the y-coordinate of this PointU

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Y As Unit
Visual Basic (Usage) Copy Code
Dim instance As PointU
Dim value As Unit

instance.Y = value

value = instance.Y
C#
public Unit Y {get; set;}

Return Value

The y-coordinate of this PointU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


PointU Structure Fields

PointU Structure Fields
[image]
Telerik.Reporting.Drawing Namespace : PointU Structure

For a list of all members of this type, see PointU members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents a new instance of the PointU class with member data left uninitialized.
Top

See Also

Reference

PointU Structure
Telerik.Reporting.Drawing Namespace


Empty Field

Empty Field
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : Empty Field

Represents a new instance of the PointU class with member data left uninitialized.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As PointU
Visual Basic (Usage) Copy Code
Dim value As PointU

value = PointU.Empty
C#
public static readonly PointU Empty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


Addition Operator

Addition Operator
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : Addition Operator

pt
The PointU to translate.
size
The SizeU that specifies the numbers to add to the x- and y-coordinates of the PointU.
Translates the PointU by the specified SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal pt As PointU, _
   ByVal size As SizeU _
) As PointU
C#
public PointU operator +(
   PointU pt,
   SizeU size
)

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal pt As PointU, _
   ByVal size As SizeU _
) As PointU
C#
public PointU operator +(
   PointU pt,
   SizeU size
)

Parameters

pt
The PointU to translate.
size
The SizeU that specifies the numbers to add to the x- and y-coordinates of the PointU.

Return Value

The translated PointU.

Remarks

The op_Addition operator adds the SizeU.Width of the specified size to the x-coordinate of the PointU and the SizeU.Height to the y-coordinate of the PointU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


Equality Operator

Equality Operator
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : Equality Operator

pt1
A PointU to compare.
pt2
A PointU to compare.
Compares two PointU structures. The result specifies whether the values of the PointU.X and PointU.Y properties of the two PointU structures are equal.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal pt1 As PointU, _
   ByVal pt2 As PointU _
) As Boolean
C#
public bool operator ==(
   PointU pt1,
   PointU pt2
)

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal pt1 As PointU, _
   ByVal pt2 As PointU _
) As Boolean
C#
public bool operator ==(
   PointU pt1,
   PointU pt2
)

Parameters

pt1
A PointU to compare.
pt2
A PointU to compare.

Return Value

true if the X and Y values of the left and right PointU structures are equal; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


Explicit Type Conversion Operator

Explicit Type Conversion Operator
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : Explicit Type Conversion Operator

Converts the specified reporting PointU to a PointF.

Overload List

Overload | Description
Explicit Type Conversion(Point,PointU) | Converts the specified reporting PointU to a Point.
Explicit Type Conversion(PointF,PointU) | Converts the specified reporting PointU to a PointF.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


Inequality Operator

Inequality Operator
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : Inequality Operator

pt1
A PointU to compare.
pt2
A PointU to compare.
Determines whether the coordinates of the specified points are not equal.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal pt1 As PointU, _
   ByVal pt2 As PointU _
) As Boolean
C#
public bool operator !=(
   PointU pt1,
   PointU pt2
)

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal pt1 As PointU, _
   ByVal pt2 As PointU _
) As Boolean
C#
public bool operator !=(
   PointU pt1,
   PointU pt2
)

Parameters

pt1
A PointU to compare.
pt2
A PointU to compare.

Return Value

true to indicate the PointU.X and PointU.Y values of pt1 and pt2 are not equal; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


Subtraction Operator

Subtraction Operator
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure : Subtraction Operator

pt
The PointU to translate.
size
The SizeU that specifies the numbers to subtract from the x- and y-coordinates of the PointU.
Translates the PointU by the negative of a specified SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal pt As PointU, _
   ByVal size As SizeU _
) As PointU
C#
public PointU operator -(
   PointU pt,
   SizeU size
)

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal pt As PointU, _
   ByVal size As SizeU _
) As PointU
C#
public PointU operator -(
   PointU pt,
   SizeU size
)

Parameters

pt
The PointU to translate.
size
The SizeU that specifies the numbers to subtract from the x- and y-coordinates of the PointU.

Return Value

The translated PointU.

Remarks

The op_Subtraction operator subtracts the SizeU.Width of the specified size from the x-coordinate of the PointU and the SizeU.Height from the y-coordinate of the PointU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members


RectangleU Structure

RectangleU Structure
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : RectangleU Structure

Stores a set of four Unit-based numbers that represent the location and size of a rectangle.

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Structure RectangleU
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
C#
public struct RectangleU : ValueType

Syntax

Visual Basic (Declaration)
Public Structure RectangleU
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
C#
public struct RectangleU : ValueType

Remarks

A RectangleU is defined by its width, height, and upper-left corner.

Inheritance Hierarchy

System.Object
System.ValueType
Telerik.Reporting.Drawing.RectangleU

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Members
Telerik.Reporting.Drawing Namespace


RectangleU Structure Members

RectangleU Structure Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : RectangleU Structure

The following tables list the members exposed by RectangleU.

Public Constructors

 | Name | Description
Public Constructor | RectangleU Constructor | Overloaded. Initializes a new instance of the RectangleU class from the specified Rectangle.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an instance of the RectangleU class with its members uninitialized.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets the y-coordinate that is the sum of Y and Height of this RectangleU structure.
Public Property | Height | Gets or sets the height of this RectangleU structure.
Public Property | IsEmpty | Tests whether the X, Y, Width, and Height properties of this RectangleU have a value of zero.
Public Property | Left | Gets the x-coordinate of the left edge of this RectangleU structure.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of this RectangleU structure.
Public Property | Right | Gets the x-coordinate that is the sum of X and Width of this RectangleU structure.
Public Property | Size | Gets or sets the size of this RectangleU.
Public Property | Top | Gets the y-coordinate of the left edge of this RectangleU structure.
Public Property | Width | Gets or sets the width of this RectangleU structure.
Public Property | X | Gets or sets the x-coordinate of the upper-left corner of this RectangleU structure.
Public Property | Y | Gets or sets the y-coordinate of the upper-left corner of this RectangleU structure.
Top

Public Methods

 | Name | Description
Public Method | Contains | Overloaded. Determines if the specified point is contained within this RectangleU structure.
Public Method | Equals | Overridden. Tests whether obj is a RectangleU with the same location and size of this RectangleU.
Public Method | GetHashCode | Overridden. Returns a hash code for this RectangleU structure.
Public Method | Inflate | Overloaded. Inflates this RectangleU structure by the specified amount.
Public Method | IntersectsWith | Determines if this rectangle intersects with rect.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | ToString | Overloaded. Overridden. Converts the Location and Size of this RectangleU to a human-readable string.
Top

Public Operators

Public Operator Equality | Tests whether two RectangleU structures have equal location and size.
Public Operator Explicit Type Conversion | Overloaded. Converts the specified RectangleU structure to a Rectangle structure.
Public Operator Inequality | Tests whether two RectangleU structures differ in location or size.
Top

See Also

Reference

RectangleU Structure
Telerik.Reporting.Drawing Namespace


RectangleU Constructor

RectangleU Constructor
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : RectangleU Constructor

Initializes a new instance of the RectangleU class from the specified Rectangle.

Overload List

Overload | Description
RectangleU Constructor(PointU,SizeU) | Initializes a new instance of the RectangleU class with the specified location and size.
RectangleU Constructor(Rectangle) | Initializes a new instance of the RectangleU class from the specified Rectangle.
RectangleU Constructor(RectangleF) | Initializes a new instance of the RectangleU class from the specified RectangleF.
RectangleU Constructor(Unit,Unit,Unit,Unit) | Initializes a new instance of the RectangleU class with the specified location and size.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


RectangleU Constructor(PointU,SizeU)

RectangleU Constructor(PointU,SizeU)
See Also
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > RectangleU Constructor : RectangleU Constructor(PointU,SizeU)

location
A PointU that represents the upper-left corner of the rectangular region.
size
A SizeU that represents the width and height of the rectangular region.
Initializes a new instance of the RectangleU class with the specified location and size.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal location As PointU, _
   ByVal size As SizeU _
)
Visual Basic (Usage) Copy Code
Dim location As PointU
Dim size As SizeU

Dim instance As RectangleU(location, size)
C#
public RectangleU(
   PointU location,
   SizeU size
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal location As PointU, _
   ByVal size As SizeU _
)
Visual Basic (Usage) Copy Code
Dim location As PointU
Dim size As SizeU

Dim instance As RectangleU(location, size)
C#
public RectangleU(
   PointU location,
   SizeU size
)

Parameters

location
A PointU that represents the upper-left corner of the rectangular region.
size
A SizeU that represents the width and height of the rectangular region.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


RectangleU Constructor(Rectangle)

RectangleU Constructor(Rectangle)
See Also
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > RectangleU Constructor : RectangleU Constructor(Rectangle)

rect
A Rectangle that represents the rectangular region.
Initializes a new instance of the RectangleU class from the specified Rectangle.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rect As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim rect As Rectangle

Dim instance As RectangleU(rect)
C#
public RectangleU(
   Rectangle rect
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rect As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim rect As Rectangle

Dim instance As RectangleU(rect)
C#
public RectangleU(
   Rectangle rect
)

Parameters

rect
A Rectangle that represents the rectangular region.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


RectangleU Constructor(RectangleF)

RectangleU Constructor(RectangleF)
See Also
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > RectangleU Constructor : RectangleU Constructor(RectangleF)

rect
A RectangleF that represents the rectangular region.
Initializes a new instance of the RectangleU class from the specified RectangleF.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim rect As RectangleF

Dim instance As RectangleU(rect)
C#
public RectangleU(
   RectangleF rect
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim rect As RectangleF

Dim instance As RectangleU(rect)
C#
public RectangleU(
   RectangleF rect
)

Parameters

rect
A RectangleF that represents the rectangular region.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


RectangleU Constructor(Unit,Unit,Unit,Unit)

RectangleU Constructor(Unit,Unit,Unit,Unit)
See Also
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > RectangleU Constructor : RectangleU Constructor(Unit,Unit,Unit,Unit)

x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
Initializes a new instance of the RectangleU class with the specified location and size.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Unit, _
   ByVal y As Unit, _
   ByVal width As Unit, _
   ByVal height As Unit _
)
Visual Basic (Usage) Copy Code
Dim x As Unit
Dim y As Unit
Dim width As Unit
Dim height As Unit

Dim instance As RectangleU(x, y, width, height)
C#
public RectangleU(
   Unit x,
   Unit y,
   Unit width,
   Unit height
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Unit, _
   ByVal y As Unit, _
   ByVal width As Unit, _
   ByVal height As Unit _
)
Visual Basic (Usage) Copy Code
Dim x As Unit
Dim y As Unit
Dim width As Unit
Dim height As Unit

Dim instance As RectangleU(x, y, width, height)
C#
public RectangleU(
   Unit x,
   Unit y,
   Unit width,
   Unit height
)

Parameters

x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


RectangleU Structure Methods

RectangleU Structure Methods
[image]
Telerik.Reporting.Drawing Namespace : RectangleU Structure

For a list of all members of this type, see RectangleU members.

Public Methods

 | Name | Description
Public Method | Contains | Overloaded. Determines if the specified point is contained within this RectangleU structure.
Public Method | Equals | Overridden. Tests whether obj is a RectangleU with the same location and size of this RectangleU.
Public Method | GetHashCode | Overridden. Returns a hash code for this RectangleU structure.
Public Method | Inflate | Overloaded. Inflates this RectangleU structure by the specified amount.
Public Method | IntersectsWith | Determines if this rectangle intersects with rect.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | ToString | Overloaded. Overridden. Converts the Location and Size of this RectangleU to a human-readable string.
Top

See Also

Reference

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Contains Method

Contains Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Contains Method

Determines if the specified point is contained within this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Contains(Unit,Unit) | Determines if the specified point is contained within this RectangleU structure.
Contains(PointU) | Determines if the specified point is contained within this RectangleU structure.
Contains(RectangleU) | Determines if the rectangular region represented by rect is entirely contained within this RectangleU structure.

Overload List

Overload | Description
Contains(Unit,Unit) | Determines if the specified point is contained within this RectangleU structure.
Contains(PointU) | Determines if the specified point is contained within this RectangleU structure.
Contains(RectangleU) | Determines if the rectangular region represented by rect is entirely contained within this RectangleU structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Contains(Unit,Unit) Method

Contains(Unit,Unit) Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > Contains Method : Contains(Unit,Unit) Method

x
The x-coordinate of the point to test.
y
The x-coordinate of the point to test.
Determines if the specified point is contained within this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Contains( _
   ByVal x As Unit, _
   ByVal y As Unit _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim x As Unit
Dim y As Unit
Dim value As Boolean

value = instance.Contains(x, y)
C#
public bool Contains(
   Unit x,
   Unit y
)

Parameters

x
The x-coordinate of the point to test.
y
The x-coordinate of the point to test.

Return Value

This method returns true if the point defined by x and y is contained within this RectangleU structure; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


Contains(PointU) Method

Contains(PointU) Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > Contains Method : Contains(PointU) Method

pt
The PointU to test.
Determines if the specified point is contained within this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Contains( _
   ByVal pt As PointU _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim pt As PointU
Dim value As Boolean

value = instance.Contains(pt)
C#
public bool Contains(
   PointU pt
)

Parameters

pt
The PointU to test.

Return Value

This method returns true if the point represented by the pt parameter is contained within this RectangleU structure; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


Contains(RectangleU) Method

Contains(RectangleU) Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > Contains Method : Contains(RectangleU) Method

rect
The RectangleF to test.
Determines if the rectangular region represented by rect is entirely contained within this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Contains( _
   ByVal rect As RectangleU _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim rect As RectangleU
Dim value As Boolean

value = instance.Contains(rect)
C#
public bool Contains(
   RectangleU rect
)

Parameters

rect
The RectangleF to test.

Return Value

This method returns true if the rectangular region represented by rect is entirely contained within the rectangular region represented by this RectangleU; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


Equals Method

Equals Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Equals Method

obj
The Object to test.
Tests whether obj is a RectangleU with the same location and size of this RectangleU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj
The Object to test.

Return Value

This method returns true if obj is a RectangleU and its X, Y, Width, and Height properties are equal to the corresponding properties of this RectangleU; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : GetHashCode Method

Returns a hash code for this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Return Value

An integer value that specifies a hash value for this RectangleU structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Inflate Method

Inflate Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Inflate Method

Inflates this RectangleU structure by the specified amount.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Inflate(Unit,Unit) | Inflates this RectangleU structure by the specified amount.
Inflate(SizeU) | Inflates this RectangleU structure by the specified amount.
Inflate(RectangleU,Unit,Unit) | Inflates rect by the specified amount.

Overload List

Overload | Description
Inflate(Unit,Unit) | Inflates this RectangleU structure by the specified amount.
Inflate(SizeU) | Inflates this RectangleU structure by the specified amount.
Inflate(RectangleU,Unit,Unit) | Inflates rect by the specified amount.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Inflate(Unit,Unit) Method

Inflate(Unit,Unit) Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > Inflate Method : Inflate(Unit,Unit) Method

width
The amount to inflate this RectangleU structure horizontally.
height
The amount to inflate this RectangleU structure vertically.
Inflates this RectangleU structure by the specified amount.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Inflate( _
   ByVal width As Unit, _
   ByVal height As Unit _
)
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim width As Unit
Dim height As Unit

instance.Inflate(width, height)
C#
public void Inflate(
   Unit width,
   Unit height
)

Parameters

width
The amount to inflate this RectangleU structure horizontally.
height
The amount to inflate this RectangleU structure vertically.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


Inflate(SizeU) Method

Inflate(SizeU) Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > Inflate Method : Inflate(SizeU) Method

size
The amount to inflate this rectangle.
Inflates this RectangleU structure by the specified amount.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Inflate( _
   ByVal size As SizeU _
)
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim size As SizeU

instance.Inflate(size)
C#
public void Inflate(
   SizeU size
)

Parameters

size
The amount to inflate this rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


Inflate(RectangleU,Unit,Unit) Method

Inflate(RectangleU,Unit,Unit) Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > Inflate Method : Inflate(RectangleU,Unit,Unit) Method

rect
The RectangleU structure to inflate.
x
The amount to inflate this RectangleU structure horizontally.
y
The amount to inflate this RectangleU structure vertically.
Inflates rect by the specified amount.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Inflate( _
   ByVal rect As RectangleU, _
   ByVal x As Unit, _
   ByVal y As Unit _
) As RectangleU
Visual Basic (Usage) Copy Code
Dim rect As RectangleU
Dim x As Unit
Dim y As Unit
Dim value As RectangleU

value = RectangleU.Inflate(rect, x, y)
C#
public static RectangleU Inflate(
   RectangleU rect,
   Unit x,
   Unit y
)

Parameters

rect
The RectangleU structure to inflate.
x
The amount to inflate this RectangleU structure horizontally.
y
The amount to inflate this RectangleU structure vertically.

Return Value

The inflated RectangleU structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


IntersectsWith Method

IntersectsWith Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : IntersectsWith Method

rect
The rectangle to test.
Determines if this rectangle intersects with rect.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function IntersectsWith( _
   ByVal rect As RectangleU _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim rect As RectangleU
Dim value As Boolean

value = instance.IntersectsWith(rect)
C#
public bool IntersectsWith(
   RectangleU rect
)

Parameters

rect
The rectangle to test.

Return Value

This method returns true if there is any intersection; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Offset Method

Offset Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Offset Method

Adjusts the location of this rectangle by the specified amount.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Offset(PointU) | Adjusts the location of this rectangle by the specified amount.
Offset(Unit,Unit) | Adjusts the location of this rectangle by the specified amount.

Overload List

Overload | Description
Offset(PointU) | Adjusts the location of this rectangle by the specified amount.
Offset(Unit,Unit) | Adjusts the location of this rectangle by the specified amount.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Offset(PointU) Method

Offset(PointU) Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > Offset Method : Offset(PointU) Method

pos
The amount to offset the location.
Adjusts the location of this rectangle by the specified amount.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Offset( _
   ByVal pos As PointU _
)
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim pos As PointU

instance.Offset(pos)
C#
public void Offset(
   PointU pos
)

Parameters

pos
The amount to offset the location.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


Offset(Unit,Unit) Method

Offset(Unit,Unit) Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > Offset Method : Offset(Unit,Unit) Method

x
The amount to offset the location horizontally.
y
The amount to offset the location vertically.
Adjusts the location of this rectangle by the specified amount.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Offset( _
   ByVal x As Unit, _
   ByVal y As Unit _
)
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim x As Unit
Dim y As Unit

instance.Offset(x, y)
C#
public void Offset(
   Unit x,
   Unit y
)

Parameters

x
The amount to offset the location horizontally.
y
The amount to offset the location vertically.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : ToString Method

Converts the Location and Size of this RectangleU to a human-readable string.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ToString() | Converts the Location and Size of this RectangleU to a human-readable string.
ToString(CultureInfo) | Converts the Location and Size of this RectangleU to a human-readable string.

Overload List

Overload | Description
ToString() | Converts the Location and Size of this RectangleU to a human-readable string.
ToString(CultureInfo) | Converts the Location and Size of this RectangleU to a human-readable string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


ToString() Method

ToString() Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > ToString Method : ToString() Method

Converts the Location and Size of this RectangleU to a human-readable string.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public NotOverridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A human-readable representation of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


ToString(CultureInfo) Method

ToString(CultureInfo) Method
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > ToString Method : ToString(CultureInfo) Method

culture
A CultureInfo object according to which to format the string.
Converts the Location and Size of this RectangleU to a human-readable string.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function ToString( _
   ByVal culture As CultureInfo _
) As String
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim culture As CultureInfo
Dim value As String

value = instance.ToString(culture)
C#
public string ToString(
   CultureInfo culture
)

Parameters

culture
A CultureInfo object according to which to format the string.

Return Value

A human-readable representation of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


RectangleU Structure Properties

RectangleU Structure Properties
[image]
Telerik.Reporting.Drawing Namespace : RectangleU Structure

For a list of all members of this type, see RectangleU members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets the y-coordinate that is the sum of Y and Height of this RectangleU structure.
Public Property | Height | Gets or sets the height of this RectangleU structure.
Public Property | IsEmpty | Tests whether the X, Y, Width, and Height properties of this RectangleU have a value of zero.
Public Property | Left | Gets the x-coordinate of the left edge of this RectangleU structure.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of this RectangleU structure.
Public Property | Right | Gets the x-coordinate that is the sum of X and Width of this RectangleU structure.
Public Property | Size | Gets or sets the size of this RectangleU.
Public Property | Top | Gets the y-coordinate of the left edge of this RectangleU structure.
Public Property | Width | Gets or sets the width of this RectangleU structure.
Public Property | X | Gets or sets the x-coordinate of the upper-left corner of this RectangleU structure.
Public Property | Y | Gets or sets the y-coordinate of the upper-left corner of this RectangleU structure.
Top

See Also

Reference

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Bottom Property

Bottom Property
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Bottom Property

Gets the y-coordinate that is the sum of Y and Height of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Unit
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim value As Unit

value = instance.Bottom
C#
public Unit Bottom {get;}

Return Value

The y-coordinate that is the sum of Y and Height of this RectangleU structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Height Property

Height Property
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Height Property

Gets or sets the height of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public Unit Height {get; set;}

Return Value

The height of this RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


IsEmpty Property

IsEmpty Property
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : IsEmpty Property

Tests whether the X, Y, Width, and Height properties of this RectangleU have a value of zero.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim value As Boolean

value = instance.IsEmpty
C#
public bool IsEmpty {get;}

Return Value

This property returns true if the X, Y, Width, and Height properties of this RectangleU have a value of zero; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Left Property

Left Property
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Left Property

Gets the x-coordinate of the left edge of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Left As Unit
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim value As Unit

value = instance.Left
C#
public Unit Left {get;}

Return Value

The x-coordinate of the left edge of this RectangleU structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Location Property

Location Property
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Location Property

Gets or sets the coordinates of the upper-left corner of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Location As PointU
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim value As PointU

instance.Location = value

value = instance.Location
C#
public PointU Location {get; set;}

Return Value

A PointU that represents the upper-left corner of this RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Right Property

Right Property
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Right Property

Gets the x-coordinate that is the sum of X and Width of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Unit
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim value As Unit

value = instance.Right
C#
public Unit Right {get;}

Return Value

The x-coordinate that is the sum of X and Width of this RectangleU structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Size Property

Size Property
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Size Property

Gets or sets the size of this RectangleU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Size As SizeU
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim value As SizeU

instance.Size = value

value = instance.Size
C#
public SizeU Size {get; set;}

Return Value

A SizeU that represents the width and height of this RectangleU structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Top Property

Top Property
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Top Property

Gets the y-coordinate of the left edge of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Top As Unit
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim value As Unit

value = instance.Top
C#
public Unit Top {get;}

Return Value

The y-coordinate of the left edge of this RectangleU structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Width Property

Width Property
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Width Property

Gets or sets the width of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public Unit Width {get; set;}

Return Value

The width of this RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


X Property

X Property
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : X Property

Gets or sets the x-coordinate of the upper-left corner of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property X As Unit
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim value As Unit

instance.X = value

value = instance.X
C#
public Unit X {get; set;}

Return Value

The x-coordinate of the upper-left corner of this RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Y Property

Y Property
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Y Property

Gets or sets the y-coordinate of the upper-left corner of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Y As Unit
Visual Basic (Usage) Copy Code
Dim instance As RectangleU
Dim value As Unit

instance.Y = value

value = instance.Y
C#
public Unit Y {get; set;}

Return Value

The y-coordinate of the upper-left corner of this RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


RectangleU Structure Fields

RectangleU Structure Fields
[image]
Telerik.Reporting.Drawing Namespace : RectangleU Structure

For a list of all members of this type, see RectangleU members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an instance of the RectangleU class with its members uninitialized.
Top

See Also

Reference

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Empty Field

Empty Field
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Empty Field

Represents an instance of the RectangleU class with its members uninitialized.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As RectangleU
Visual Basic (Usage) Copy Code
Dim value As RectangleU

value = RectangleU.Empty
C#
public static readonly RectangleU Empty

Remarks

The members of the new RectangleU are left uninitialized.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Equality Operator

Equality Operator
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Equality Operator

rect1
The RectangleU structure that is to the left of the equality operator.
rect2
The RectangleU structure that is to the right of the equality operator.
Tests whether two RectangleU structures have equal location and size.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal rect1 As RectangleU, _
   ByVal rect2 As RectangleU _
) As Boolean
C#
public bool operator ==(
   RectangleU rect1,
   RectangleU rect2
)

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal rect1 As RectangleU, _
   ByVal rect2 As RectangleU _
) As Boolean
C#
public bool operator ==(
   RectangleU rect1,
   RectangleU rect2
)

Parameters

rect1
The RectangleU structure that is to the left of the equality operator.
rect2
The RectangleU structure that is to the right of the equality operator.

Return Value

This operator returns true if the two specified RectangleU structures have equal X, Y, Width, and Height properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Explicit Type Conversion Operator

Explicit Type Conversion Operator
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Explicit Type Conversion Operator

Converts the specified RectangleU structure to a Rectangle structure.

Overload List

Overload | Description
Explicit Type Conversion(Rectangle,RectangleU) | Converts the specified RectangleU structure to a Rectangle structure.
Explicit Type Conversion(RectangleF,RectangleU) | Converts the specified RectangleU structure to a RectangleF structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


Inequality Operator

Inequality Operator
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure : Inequality Operator

rect1
The RectangleU structure that is to the left of the equality operator.
rect2
The RectangleU structure that is to the right of the equality operator.
Tests whether two RectangleU structures differ in location or size.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal rect1 As RectangleU, _
   ByVal rect2 As RectangleU _
) As Boolean
C#
public bool operator !=(
   RectangleU rect1,
   RectangleU rect2
)

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal rect1 As RectangleU, _
   ByVal rect2 As RectangleU _
) As Boolean
C#
public bool operator !=(
   RectangleU rect1,
   RectangleU rect2
)

Parameters

rect1
The RectangleU structure that is to the left of the equality operator.
rect2
The RectangleU structure that is to the right of the equality operator.

Return Value

This operator returns true if any of the X, Y, Width, or Height properties of the two RectangleU structures are unequal; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members


SizeU Structure

SizeU Structure
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : SizeU Structure

Stores an ordered pair of Unit-based numbers, typically the width and height of a rectangle.

Object Model

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Structure SizeU
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As SizeU
C#
public struct SizeU : ValueType

Syntax

Visual Basic (Declaration)
Public Structure SizeU
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As SizeU
C#
public struct SizeU : ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Telerik.Reporting.Drawing.SizeU

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Members
Telerik.Reporting.Drawing Namespace


SizeU Structure Members

SizeU Structure Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : SizeU Structure

The following tables list the members exposed by SizeU.

Public Constructors

 | Name | Description
Public Constructor | SizeU Constructor | Overloaded. Initializes a new instance of the SizeU class from the specified existing Size.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Initializes a new instance of the SizeU class.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the vertical component of this SizeU.
Public Property | IsEmpty | Gets a value indicating whether this SizeU has zero width and height.
Public Property | Width | Gets or sets the horizontal component of this SizeU.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests to see whether the specified object is a SizeU with the same dimensions as this SizeU.
Public Method | GetHashCode | Overridden. Returns a hash code for this SizeU structure.
Public Method | ToString | Overloaded. Overridden. Creates a human-readable string that represents this SizeU.
Top

Public Operators

Public Operator Addition | Adds the width and height of one SizeU structure to the width and height of another SizeU structure.
Public Operator Equality | Tests whether two SizeU structures are equal.
Public Operator Explicit Type Conversion | Overloaded. Converts the specified SizeU to a SizeF.
Public Operator Inequality | Tests whether two SizeU structures are different.
Public Operator Subtraction | Subtracts the width and height of one SizeU structure from the width and height of another SizeU structure.
Top

See Also

Reference

SizeU Structure
Telerik.Reporting.Drawing Namespace


SizeU Constructor

SizeU Constructor
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure : SizeU Constructor

Initializes a new instance of the SizeU class from the specified existing Size.

Overload List

Overload | Description
SizeU Constructor(Size) | Initializes a new instance of the SizeU class from the specified existing Size.
SizeU Constructor(SizeF) | Initializes a new instance of the SizeU class from the specified existing SizeF.
SizeU Constructor(Unit,Unit) | Initializes a new instance of the SizeU class from the specified dimensions.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members


SizeU Constructor(Size)

SizeU Constructor(Size)
See Also
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure > SizeU Constructor : SizeU Constructor(Size)

size
The Size from which to create the new SizeU.
Initializes a new instance of the SizeU class from the specified existing Size.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal size As Size _
)
Visual Basic (Usage) Copy Code
Dim size As Size

Dim instance As SizeU(size)
C#
public SizeU(
   Size size
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal size As Size _
)
Visual Basic (Usage) Copy Code
Dim size As Size

Dim instance As SizeU(size)
C#
public SizeU(
   Size size
)

Parameters

size
The Size from which to create the new SizeU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members
Overload List


SizeU Constructor(SizeF)

SizeU Constructor(SizeF)
See Also
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure > SizeU Constructor : SizeU Constructor(SizeF)

size
The SizeF from which to create the new SizeU.
Initializes a new instance of the SizeU class from the specified existing SizeF.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal size As SizeF _
)
Visual Basic (Usage) Copy Code
Dim size As SizeF

Dim instance As SizeU(size)
C#
public SizeU(
   SizeF size
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal size As SizeF _
)
Visual Basic (Usage) Copy Code
Dim size As SizeF

Dim instance As SizeU(size)
C#
public SizeU(
   SizeF size
)

Parameters

size
The SizeF from which to create the new SizeU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members
Overload List


SizeU Constructor(Unit,Unit)

SizeU Constructor(Unit,Unit)
See Also
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure > SizeU Constructor : SizeU Constructor(Unit,Unit)

width
The width component of the new SizeU.
height
The height component of the new SizeU.
Initializes a new instance of the SizeU class from the specified dimensions.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Unit, _
   ByVal height As Unit _
)
Visual Basic (Usage) Copy Code
Dim width As Unit
Dim height As Unit

Dim instance As SizeU(width, height)
C#
public SizeU(
   Unit width,
   Unit height
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Unit, _
   ByVal height As Unit _
)
Visual Basic (Usage) Copy Code
Dim width As Unit
Dim height As Unit

Dim instance As SizeU(width, height)
C#
public SizeU(
   Unit width,
   Unit height
)

Parameters

width
The width component of the new SizeU.
height
The height component of the new SizeU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members
Overload List


SizeU Structure Methods

SizeU Structure Methods
[image]
Telerik.Reporting.Drawing Namespace : SizeU Structure

For a list of all members of this type, see SizeU members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests to see whether the specified object is a SizeU with the same dimensions as this SizeU.
Public Method | GetHashCode | Overridden. Returns a hash code for this SizeU structure.
Public Method | ToString | Overloaded. Overridden. Creates a human-readable string that represents this SizeU.
Top

See Also

Reference

SizeU Structure
Telerik.Reporting.Drawing Namespace


Equals Method

Equals Method
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure : Equals Method

obj
The Object to test.
Tests to see whether the specified object is a SizeU with the same dimensions as this SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SizeU
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj
The Object to test.

Return Value

This method returns true if obj is a SizeU and has the same width and height as this SizeU; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure : GetHashCode Method

Returns a hash code for this SizeU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As SizeU
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Return Value

An integer value that specifies a hash value for this SizeU structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure : ToString Method

Creates a human-readable string that represents this SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ToString() | Creates a human-readable string that represents this SizeU.
ToString(CultureInfo) | Creates a human-readable string that represents this SizeU.

Overload List

Overload | Description
ToString() | Creates a human-readable string that represents this SizeU.
ToString(CultureInfo) | Creates a human-readable string that represents this SizeU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members


ToString() Method

ToString() Method
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure > ToString Method : ToString() Method

Creates a human-readable string that represents this SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public NotOverridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As SizeU
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A string that represents this SizeU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members
Overload List


ToString(CultureInfo) Method

ToString(CultureInfo) Method
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure > ToString Method : ToString(CultureInfo) Method

culture
A CultureInfo object according to which to format the string.
Creates a human-readable string that represents this SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function ToString( _
   ByVal culture As CultureInfo _
) As String
Visual Basic (Usage) Copy Code
Dim instance As SizeU
Dim culture As CultureInfo
Dim value As String

value = instance.ToString(culture)
C#
public string ToString(
   CultureInfo culture
)

Parameters

culture
A CultureInfo object according to which to format the string.

Return Value

A string that represents this SizeU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members
Overload List


SizeU Structure Properties

SizeU Structure Properties
[image]
Telerik.Reporting.Drawing Namespace : SizeU Structure

For a list of all members of this type, see SizeU members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the vertical component of this SizeU.
Public Property | IsEmpty | Gets a value indicating whether this SizeU has zero width and height.
Public Property | Width | Gets or sets the horizontal component of this SizeU.
Top

See Also

Reference

SizeU Structure
Telerik.Reporting.Drawing Namespace


Height Property

Height Property
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure : Height Property

Gets or sets the vertical component of this SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As SizeU
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public Unit Height {get; set;}

Return Value

The vertical component of this SizeU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members


IsEmpty Property

IsEmpty Property
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure : IsEmpty Property

Gets a value indicating whether this SizeU has zero width and height.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SizeU
Dim value As Boolean

value = instance.IsEmpty
C#
public bool IsEmpty {get;}

Return Value

This property returns true when this SizeU has both a width and height of zero; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members


Width Property

Width Property
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure : Width Property

Gets or sets the horizontal component of this SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As SizeU
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public Unit Width {get; set;}

Return Value

The horizontal component of this SizeU.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members


SizeU Structure Fields

SizeU Structure Fields
[image]
Telerik.Reporting.Drawing Namespace : SizeU Structure

For a list of all members of this type, see SizeU members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Initializes a new instance of the SizeU class.
Top

See Also

Reference

SizeU Structure
Telerik.Reporting.Drawing Namespace


Empty Field

Empty Field
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure : Empty Field

Initializes a new instance of the SizeU class.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As SizeU
Visual Basic (Usage) Copy Code
Dim value As SizeU

value = SizeU.Empty
C#
public static readonly SizeU Empty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members


Addition Operator

Addition Operator
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure : Addition Operator

size1
The first SizeU to add.
size2
The second SizeU to add.
Adds the width and height of one SizeU structure to the width and height of another SizeU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal size1 As SizeU, _
   ByVal size2 As SizeU _
) As SizeU
C#
public SizeU operator +(
   SizeU size1,
   SizeU size2
)

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal size1 As SizeU, _
   ByVal size2 As SizeU _
) As SizeU
C#
public SizeU operator +(
   SizeU size1,
   SizeU size2
)

Parameters

size1
The first SizeU to add.
size2
The second SizeU to add.

Return Value

A SizeU structure that is the result of the addition operation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members


Equality Operator

Equality Operator
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure : Equality Operator

size1
The SizeU structure on the left side of the equality operator.
size2
The SizeU structure on the right side of the equality operator.
Tests whether two SizeU structures are equal.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal size1 As SizeU, _
   ByVal size2 As SizeU _
) As Boolean
C#
public bool operator ==(
   SizeU size1,
   SizeU size2
)

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal size1 As SizeU, _
   ByVal size2 As SizeU _
) As Boolean
C#
public bool operator ==(
   SizeU size1,
   SizeU size2
)

Parameters

size1
The SizeU structure on the left side of the equality operator.
size2
The SizeU structure on the right side of the equality operator.

Return Value

This operator returns true if size1 and size2 have equal width and height; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members


Explicit Type Conversion Operator

Explicit Type Conversion Operator
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure : Explicit Type Conversion Operator

Converts the specified SizeU to a SizeF.

Overload List

Overload | Description
Explicit Type Conversion(Size,SizeU) | Converts the specified SizeU to a Size.
Explicit Type Conversion(SizeF,SizeU) | Converts the specified SizeU to a SizeF.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members


Inequality Operator

Inequality Operator
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure : Inequality Operator

size1
The SizeU structure on the left side of the equality operator.
size2
The SizeU structure on the right side of the equality operator.
Tests whether two SizeU structures are different.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal size1 As SizeU, _
   ByVal size2 As SizeU _
) As Boolean
C#
public bool operator !=(
   SizeU size1,
   SizeU size2
)

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal size1 As SizeU, _
   ByVal size2 As SizeU _
) As Boolean
C#
public bool operator !=(
   SizeU size1,
   SizeU size2
)

Parameters

size1
The SizeU structure on the left side of the equality operator.
size2
The SizeU structure on the right side of the equality operator.

Return Value

This operator returns true if size1 and size2 differ either in width or height; false if size1 and size2 are equal.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members


Subtraction Operator

Subtraction Operator
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure : Subtraction Operator

size1
The SizeU on the left side of the subtraction operator.
size2
The SizeU on the right side of the subtraction operator.
Subtracts the width and height of one SizeU structure from the width and height of another SizeU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal size1 As SizeU, _
   ByVal size2 As SizeU _
) As SizeU
C#
public SizeU operator -(
   SizeU size1,
   SizeU size2
)

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal size1 As SizeU, _
   ByVal size2 As SizeU _
) As SizeU
C#
public SizeU operator -(
   SizeU size1,
   SizeU size2
)

Parameters

size1
The SizeU on the left side of the subtraction operator.
size2
The SizeU on the right side of the subtraction operator.

Return Value

A SizeU structure that is the result of the subtraction operation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members


Unit Structure

Unit Structure
See Also Members
[image]
Telerik.Reporting.Drawing Namespace : Unit Structure

A structure representing a unit of measure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Structure Unit
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As Unit
C#
public struct Unit : ValueType

Syntax

Visual Basic (Declaration)
Public Structure Unit
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As Unit
C#
public struct Unit : ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Telerik.Reporting.Drawing.Unit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Members
Telerik.Reporting.Drawing Namespace


Unit Structure Members

Unit Structure Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Drawing Namespace : Unit Structure

The following tables list the members exposed by Unit.

Public Constructors

 | Name | Description
Public Constructor | Unit Constructor | Overloaded. Initializes a new instance of the Unit structure from the specified pixels. The Unit's type is DefaultType
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Initializes a new instance of the Unit structure.
static (Shared in Visual Basic) | Zero | Initializes a new instance of the Unit structure equal to zero.
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | DefaultType | Gets or sets a UnitType representing the default units of measure for a Report.
static (Shared in Visual Basic) | DotsPerInch | Gets a double value representing the dpi of the current graphics context.
Public Property | IsEmpty | Specifies whether this Unit structure is uninitialized.
Public Property | Type | Gets the type of the Unit.
Public Property | Value | Gets the magnitude of this Unit.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Add | Overloaded. Returns a Unit that is the sum of two units and is of the specified type.
static (Shared in Visual Basic) | Cm | Overloaded. Creates a new Unit of type UnitType.Cm and magnitude equal to value.
Public Method | Divide | Divides this Unit by a specified value.
Public Method | Equals | Overridden. Tests whether obj is a Unit that equals this Unit.
static (Shared in Visual Basic) | FromPixels |
Public Method | GetHashCode | Overridden. Returns a hash code for this Unit structure.
static (Shared in Visual Basic) | Inch | Overloaded. Creates a new Unit of type UnitType.Inch and magnitude equal to value.
static (Shared in Visual Basic) | Mm | Overloaded. Creates a new Unit of type UnitType.Mm and magnitude equal to value.
Public Method | Multiply | Multiplies this Unit by a specified value.
static (Shared in Visual Basic) | Pica | Overloaded. Creates a new Unit of type UnitType.Pica and magnitude equal to value.
static (Shared in Visual Basic) | Pixel | Overloaded. Creates a new Unit of type UnitType.Pixel and magnitude equal to value.
static (Shared in Visual Basic) | Point | Overloaded. Creates a new Unit of type UnitType.Point and magnitude equal to value.
static (Shared in Visual Basic) | Subtract | Overloaded. Returns a Unit that is the difference of two units and is of the specified type.
Public Method | ToString | Overloaded. Overridden. Returns a human-readable representation ot this Unit.
Top

Public Operators

Public Operator Addition | Adds one Unit to another.
Public Operator Division | Divides a Unit by a specified value.
Public Operator Equality | Compares two units.
Public Operator Greater Than | Compares two units.
Public Operator Greater Than or Equal | Compares two units.
Public Operator Inequality | Compares two units.
Public Operator Less Than | Compares two units.
Public Operator Less Than or Equal | Compares two units.
Public Operator Multiplication | Overloaded. Multiplies a Unit by a specified value.
Public Operator Subtraction | Subtract one Unit from another.
Public Operator Unary Negation | Unary minus. Reverses the sign of Unit
Top

See Also

Reference

Unit Structure
Telerik.Reporting.Drawing Namespace


Unit Constructor

Unit Constructor
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Unit Constructor

Initializes a new instance of the Unit structure from the specified pixels. The Unit's type is DefaultType

Overload List

Overload | Description
Unit Constructor(Double) | Initializes a new instance of the Unit structure from the specified pixels. The Unit's type is DefaultType
Unit Constructor(Double,UnitType) | Initializes a new instance of the Unit structure with the specified value and type.
Unit Constructor(String) | Initializes a new instance of the Unit structure from the specified string value.
Unit Constructor(String,CultureInfo) | Initializes a new instance of the Unit structure from the specified string value and using the specified CultureInfo.
Unit Constructor(String,CultureInfo,UnitType) | Initializes a new instance of the Unit structure from the specified string value, culture, and type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Unit Constructor(Double)

Unit Constructor(Double)
See Also
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Unit Constructor : Unit Constructor(Double)

pixels
A double value specifying the magnitued of the Unit in pixels.
Initializes a new instance of the Unit structure from the specified pixels. The Unit's type is DefaultType

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pixels As Double _
)
Visual Basic (Usage) Copy Code
Dim pixels As Double

Dim instance As Unit(pixels)
C#
public Unit(
   double pixels
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pixels As Double _
)
Visual Basic (Usage) Copy Code
Dim pixels As Double

Dim instance As Unit(pixels)
C#
public Unit(
   double pixels
)

Parameters

pixels
A double value specifying the magnitued of the Unit in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Unit Constructor(Double,UnitType)

Unit Constructor(Double,UnitType)
See Also
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Unit Constructor : Unit Constructor(Double,UnitType)

value
A double value representing the magnitude of the Unit.
type
A UnitType specifying the type of the Unit.
Initializes a new instance of the Unit structure with the specified value and type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double, _
   ByVal type As UnitType _
)
Visual Basic (Usage) Copy Code
Dim value As Double
Dim type As UnitType

Dim instance As Unit(value, type)
C#
public Unit(
   double value,
   UnitType type
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double, _
   ByVal type As UnitType _
)
Visual Basic (Usage) Copy Code
Dim value As Double
Dim type As UnitType

Dim instance As Unit(value, type)
C#
public Unit(
   double value,
   UnitType type
)

Parameters

value
A double value representing the magnitude of the Unit.
type
A UnitType specifying the type of the Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Unit Constructor(String)

Unit Constructor(String)
See Also
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Unit Constructor : Unit Constructor(String)

value
A string value representing the magnitude and type of the Unit.
Initializes a new instance of the Unit structure from the specified string value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As Unit(value)
C#
public Unit(
   string value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As Unit(value)
C#
public Unit(
   string value
)

Parameters

value
A string value representing the magnitude and type of the Unit.

Remarks

Parameters passed to this constructor should be of the form "2px", "3.4in", "4cm", "2mm", "12.5pt", "4pc", etc. For more information on string representations of units see UnitType.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Unit Constructor(String,CultureInfo)

Unit Constructor(String,CultureInfo)
See Also
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Unit Constructor : Unit Constructor(String,CultureInfo)

value
A string value representing the magnitude and type of the Unit.
culture
A CultureInfo. If a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.
Initializes a new instance of the Unit structure from the specified string value and using the specified CultureInfo.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal culture As CultureInfo _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim culture As CultureInfo

Dim instance As Unit(value, culture)
C#
public Unit(
   string value,
   CultureInfo culture
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal culture As CultureInfo _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim culture As CultureInfo

Dim instance As Unit(value, culture)
C#
public Unit(
   string value,
   CultureInfo culture
)

Parameters

value
A string value representing the magnitude and type of the Unit.
culture
A CultureInfo. If a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.

Remarks

The culture parameters is used to parse the string value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Unit Constructor(String,CultureInfo,UnitType)

Unit Constructor(String,CultureInfo,UnitType)
See Also
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Unit Constructor : Unit Constructor(String,CultureInfo,UnitType)

value
A string value representing the magnitude of the Unit.
culture
A CultureInfo. If a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.
type
A UnitType specifying the type of the Unit.
Initializes a new instance of the Unit structure from the specified string value, culture, and type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal culture As CultureInfo, _
   ByVal type As UnitType _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim culture As CultureInfo
Dim type As UnitType

Dim instance As Unit(value, culture, type)
C#
public Unit(
   string value,
   CultureInfo culture,
   UnitType type
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal culture As CultureInfo, _
   ByVal type As UnitType _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim culture As CultureInfo
Dim type As UnitType

Dim instance As Unit(value, culture, type)
C#
public Unit(
   string value,
   CultureInfo culture,
   UnitType type
)

Parameters

value
A string value representing the magnitude of the Unit.
culture
A CultureInfo. If a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.
type
A UnitType specifying the type of the Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Unit Structure Methods

Unit Structure Methods
[image]
Telerik.Reporting.Drawing Namespace : Unit Structure

For a list of all members of this type, see Unit members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Add | Overloaded. Returns a Unit that is the sum of two units and is of the specified type.
static (Shared in Visual Basic) | Cm | Overloaded. Creates a new Unit of type UnitType.Cm and magnitude equal to value.
Public Method | Divide | Divides this Unit by a specified value.
Public Method | Equals | Overridden. Tests whether obj is a Unit that equals this Unit.
static (Shared in Visual Basic) | FromPixels |
Public Method | GetHashCode | Overridden. Returns a hash code for this Unit structure.
static (Shared in Visual Basic) | Inch | Overloaded. Creates a new Unit of type UnitType.Inch and magnitude equal to value.
static (Shared in Visual Basic) | Mm | Overloaded. Creates a new Unit of type UnitType.Mm and magnitude equal to value.
Public Method | Multiply | Multiplies this Unit by a specified value.
static (Shared in Visual Basic) | Pica | Overloaded. Creates a new Unit of type UnitType.Pica and magnitude equal to value.
static (Shared in Visual Basic) | Pixel | Overloaded. Creates a new Unit of type UnitType.Pixel and magnitude equal to value.
static (Shared in Visual Basic) | Point | Overloaded. Creates a new Unit of type UnitType.Point and magnitude equal to value.
static (Shared in Visual Basic) | Subtract | Overloaded. Returns a Unit that is the difference of two units and is of the specified type.
Public Method | ToString | Overloaded. Overridden. Returns a human-readable representation ot this Unit.
Top

See Also

Reference

Unit Structure
Telerik.Reporting.Drawing Namespace


Add Method

Add Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Add Method

Returns a Unit that is the sum of two units and is of the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Add(Unit,Unit,UnitType) | Returns a Unit that is the sum of two units and is of the specified type.
Add(Unit) | Adds a unit to this Unit.

Overload List

Overload | Description
Add(Unit,Unit,UnitType) | Returns a Unit that is the sum of two units and is of the specified type.
Add(Unit) | Adds a unit to this Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Add(Unit,Unit,UnitType) Method

Add(Unit,Unit,UnitType) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Add Method : Add(Unit,Unit,UnitType) Method

unit1
The first Unit.
unit2
The second Unit.
type
A UnitType specifying the type of the resultant unit.
Returns a Unit that is the sum of two units and is of the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Add( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit, _
   ByVal type As UnitType _
) As Unit
Visual Basic (Usage) Copy Code
Dim unit1 As Unit
Dim unit2 As Unit
Dim type As UnitType
Dim value As Unit

value = Unit.Add(unit1, unit2, type)
C#
public static Unit Add(
   Unit unit1,
   Unit unit2,
   UnitType type
)

Parameters

unit1
The first Unit.
unit2
The second Unit.
type
A UnitType specifying the type of the resultant unit.

Return Value

The sum of the two units.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Add(Unit) Method

Add(Unit) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Add Method : Add(Unit) Method

unit1
The Unit to add.
Adds a unit to this Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Add( _
   ByVal unit1 As Unit _
) As Unit
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim unit1 As Unit
Dim value As Unit

value = instance.Add(unit1)
C#
public Unit Add(
   Unit unit1
)

Parameters

unit1
The Unit to add.

Return Value

The sum of unit1 and this Unit in this Unit's type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Cm Method

Cm Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Cm Method

Creates a new Unit of type UnitType.Cm and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Cm(Double) | Creates a new Unit of type UnitType.Cm and magnitude equal to value.
Cm(Int32) | Creates a new Unit of type UnitType.Cm and magnitude equal to value.

Overload List

Overload | Description
Cm(Double) | Creates a new Unit of type UnitType.Cm and magnitude equal to value.
Cm(Int32) | Creates a new Unit of type UnitType.Cm and magnitude equal to value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Cm(Double) Method

Cm(Double) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Cm Method : Cm(Double) Method

value
A double value specifying the magnitude of the Unit.
Creates a new Unit of type UnitType.Cm and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Cm( _
   ByVal value As Double _
) As Unit
Visual Basic (Usage) Copy Code
Dim value As Double
Dim value As Unit

value = Unit.Cm(value)
C#
public static Unit Cm(
   double value
)

Parameters

value
A double value specifying the magnitude of the Unit.

Return Value

The created Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Cm(Int32) Method

Cm(Int32) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Cm Method : Cm(Int32) Method

value
An int value specifying the magnitude of the Unit.
Creates a new Unit of type UnitType.Cm and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Cm( _
   ByVal value As Integer _
) As Unit
Visual Basic (Usage) Copy Code
Dim value As Integer
Dim value As Unit

value = Unit.Cm(value)
C#
public static Unit Cm(
   int value
)

Parameters

value
An int value specifying the magnitude of the Unit.

Return Value

The created Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Divide Method

Divide Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Divide Method

value
A double value to divide by.
Divides this Unit by a specified value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Divide( _
   ByVal value As Double _
) As Unit
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim value As Double
Dim value As Unit

value = instance.Divide(value)
C#
public Unit Divide(
   double value
)

Parameters

value
A double value to divide by.

Return Value

The quotient resulting by dividing this Unit by the specified value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Equals Method

Equals Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Equals Method

obj
The Object to test.
Tests whether obj is a Unit that equals this Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)

Parameters

obj
The Object to test.

Return Value

This method returns true if obj is a Unit and its magnitude is equal to this Unit's magnitude; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


FromPixels Method

FromPixels Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : FromPixels Method

pixels
type

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromPixels( _
   ByVal pixels As Double, _
   ByVal type As UnitType _
) As Unit
Visual Basic (Usage) Copy Code
Dim pixels As Double
Dim type As UnitType
Dim value As Unit

value = Unit.FromPixels(pixels, type)
C#
public static Unit FromPixels(
   double pixels,
   UnitType type
)

Parameters

pixels
type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


GetHashCode Method

GetHashCode Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : GetHashCode Method

Returns a hash code for this Unit structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()

Return Value

An integer value that specifies a hash value for this Unit structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Inch Method

Inch Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Inch Method

Creates a new Unit of type UnitType.Inch and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Inch(Double) | Creates a new Unit of type UnitType.Inch and magnitude equal to value.
Inch(Int32) | Creates a new Unit of type UnitType.Inch and magnitude equal to value.

Overload List

Overload | Description
Inch(Double) | Creates a new Unit of type UnitType.Inch and magnitude equal to value.
Inch(Int32) | Creates a new Unit of type UnitType.Inch and magnitude equal to value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Inch(Double) Method

Inch(Double) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Inch Method : Inch(Double) Method

value
A double value specifying the magnitude of the Unit.
Creates a new Unit of type UnitType.Inch and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Inch( _
   ByVal value As Double _
) As Unit
Visual Basic (Usage) Copy Code
Dim value As Double
Dim value As Unit

value = Unit.Inch(value)
C#
public static Unit Inch(
   double value
)

Parameters

value
A double value specifying the magnitude of the Unit.

Return Value

The created Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Inch(Int32) Method

Inch(Int32) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Inch Method : Inch(Int32) Method

value
An int value specifying the magnitude of the Unit.
Creates a new Unit of type UnitType.Inch and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Inch( _
   ByVal value As Integer _
) As Unit
Visual Basic (Usage) Copy Code
Dim value As Integer
Dim value As Unit

value = Unit.Inch(value)
C#
public static Unit Inch(
   int value
)

Parameters

value
An int value specifying the magnitude of the Unit.

Return Value

The created Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Mm Method

Mm Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Mm Method

Creates a new Unit of type UnitType.Mm and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Mm(Double) | Creates a new Unit of type UnitType.Mm and magnitude equal to value.
Mm(Int32) | Creates a new Unit of type UnitType.Mm and magnitude equal to value.

Overload List

Overload | Description
Mm(Double) | Creates a new Unit of type UnitType.Mm and magnitude equal to value.
Mm(Int32) | Creates a new Unit of type UnitType.Mm and magnitude equal to value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Mm(Double) Method

Mm(Double) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Mm Method : Mm(Double) Method

value
A double value specifying the magnitude of the Unit.
Creates a new Unit of type UnitType.Mm and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Mm( _
   ByVal value As Double _
) As Unit
Visual Basic (Usage) Copy Code
Dim value As Double
Dim value As Unit

value = Unit.Mm(value)
C#
public static Unit Mm(
   double value
)

Parameters

value
A double value specifying the magnitude of the Unit.

Return Value

The created Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Mm(Int32) Method

Mm(Int32) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Mm Method : Mm(Int32) Method

value
An int value specifying the magnitude of the Unit.
Creates a new Unit of type UnitType.Mm and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Mm( _
   ByVal value As Integer _
) As Unit
Visual Basic (Usage) Copy Code
Dim value As Integer
Dim value As Unit

value = Unit.Mm(value)
C#
public static Unit Mm(
   int value
)

Parameters

value
An int value specifying the magnitude of the Unit.

Return Value

The created Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Multiply Method

Multiply Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Multiply Method

value
A double value to multiply by.
Multiplies this Unit by a specified value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function Multiply( _
   ByVal value As Double _
) As Unit
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim value As Double
Dim value As Unit

value = instance.Multiply(value)
C#
public Unit Multiply(
   double value
)

Parameters

value
A double value to multiply by.

Return Value

The product of multiplying this Unit by the specified value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Pica Method

Pica Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Pica Method

Creates a new Unit of type UnitType.Pica and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Pica(Double) | Creates a new Unit of type UnitType.Pica and magnitude equal to value.
Pica(Int32) | Creates a new Unit of type UnitType.Pica and magnitude equal to value.

Overload List

Overload | Description
Pica(Double) | Creates a new Unit of type UnitType.Pica and magnitude equal to value.
Pica(Int32) | Creates a new Unit of type UnitType.Pica and magnitude equal to value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Pica(Double) Method

Pica(Double) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Pica Method : Pica(Double) Method

value
A double value specifying the magnitude of the Unit.
Creates a new Unit of type UnitType.Pica and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Pica( _
   ByVal value As Double _
) As Unit
Visual Basic (Usage) Copy Code
Dim value As Double
Dim value As Unit

value = Unit.Pica(value)
C#
public static Unit Pica(
   double value
)

Parameters

value
A double value specifying the magnitude of the Unit.

Return Value

The created Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Pica(Int32) Method

Pica(Int32) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Pica Method : Pica(Int32) Method

value
An int value specifying the magnitude of the Unit.
Creates a new Unit of type UnitType.Pica and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Pica( _
   ByVal value As Integer _
) As Unit
Visual Basic (Usage) Copy Code
Dim value As Integer
Dim value As Unit

value = Unit.Pica(value)
C#
public static Unit Pica(
   int value
)

Parameters

value
An int value specifying the magnitude of the Unit.

Return Value

The created Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Pixel Method

Pixel Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Pixel Method

Creates a new Unit of type UnitType.Pixel and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Pixel(Double) | Creates a new Unit of type UnitType.Pixel and magnitude equal to value.
Pixel(Int32) | Creates a new Unit of type UnitType.Pixel and magnitude equal to value.

Overload List

Overload | Description
Pixel(Double) | Creates a new Unit of type UnitType.Pixel and magnitude equal to value.
Pixel(Int32) | Creates a new Unit of type UnitType.Pixel and magnitude equal to value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Pixel(Double) Method

Pixel(Double) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Pixel Method : Pixel(Double) Method

value
A double value specifying the magnitude of the Unit.
Creates a new Unit of type UnitType.Pixel and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Pixel( _
   ByVal value As Double _
) As Unit
Visual Basic (Usage) Copy Code
Dim value As Double
Dim value As Unit

value = Unit.Pixel(value)
C#
public static Unit Pixel(
   double value
)

Parameters

value
A double value specifying the magnitude of the Unit.

Return Value

The created Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Pixel(Int32) Method

Pixel(Int32) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Pixel Method : Pixel(Int32) Method

value
An int value specifying the magnitude of the Unit.
Creates a new Unit of type UnitType.Pixel and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Pixel( _
   ByVal value As Integer _
) As Unit
Visual Basic (Usage) Copy Code
Dim value As Integer
Dim value As Unit

value = Unit.Pixel(value)
C#
public static Unit Pixel(
   int value
)

Parameters

value
An int value specifying the magnitude of the Unit.

Return Value

The created Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Point Method

Point Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Point Method

Creates a new Unit of type UnitType.Point and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Point(Double) | Creates a new Unit of type UnitType.Point and magnitude equal to value.
Point(Int32) | Creates a new Unit of type UnitType.Point and magnitude equal to value.

Overload List

Overload | Description
Point(Double) | Creates a new Unit of type UnitType.Point and magnitude equal to value.
Point(Int32) | Creates a new Unit of type UnitType.Point and magnitude equal to value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Point(Double) Method

Point(Double) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Point Method : Point(Double) Method

value
A double value specifying the magnitude of the Unit.
Creates a new Unit of type UnitType.Point and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Point( _
   ByVal value As Double _
) As Unit
Visual Basic (Usage) Copy Code
Dim value As Double
Dim value As Unit

value = Unit.Point(value)
C#
public static Unit Point(
   double value
)

Parameters

value
A double value specifying the magnitude of the Unit.

Return Value

The created Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Point(Int32) Method

Point(Int32) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Point Method : Point(Int32) Method

value
An int value specifying the magnitude of the Unit.
Creates a new Unit of type UnitType.Point and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Point( _
   ByVal value As Integer _
) As Unit
Visual Basic (Usage) Copy Code
Dim value As Integer
Dim value As Unit

value = Unit.Point(value)
C#
public static Unit Point(
   int value
)

Parameters

value
An int value specifying the magnitude of the Unit.

Return Value

The created Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Subtract Method

Subtract Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Subtract Method

Returns a Unit that is the difference of two units and is of the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
Subtract(Unit,Unit,UnitType) | Returns a Unit that is the difference of two units and is of the specified type.
Subtract(Unit) | Subtracts a unit from this Unit.

Overload List

Overload | Description
Subtract(Unit,Unit,UnitType) | Returns a Unit that is the difference of two units and is of the specified type.
Subtract(Unit) | Subtracts a unit from this Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Subtract(Unit,Unit,UnitType) Method

Subtract(Unit,Unit,UnitType) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Subtract Method : Subtract(Unit,Unit,UnitType) Method

unit1
The Unit to subtract from.
unit2
The Unit to subtract.
type
A UnitType specifying the type of the resultant unit.
Returns a Unit that is the difference of two units and is of the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Subtract( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit, _
   ByVal type As UnitType _
) As Unit
Visual Basic (Usage) Copy Code
Dim unit1 As Unit
Dim unit2 As Unit
Dim type As UnitType
Dim value As Unit

value = Unit.Subtract(unit1, unit2, type)
C#
public static Unit Subtract(
   Unit unit1,
   Unit unit2,
   UnitType type
)

Parameters

unit1
The Unit to subtract from.
unit2
The Unit to subtract.
type
A UnitType specifying the type of the resultant unit.

Return Value

The difference of the two units in the specified unit type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Subtract(Unit) Method

Subtract(Unit) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Subtract Method : Subtract(Unit) Method

unit1
The Unit to subtract.
Subtracts a unit from this Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Subtract( _
   ByVal unit1 As Unit _
) As Unit
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim unit1 As Unit
Dim value As Unit

value = instance.Subtract(unit1)
C#
public Unit Subtract(
   Unit unit1
)

Parameters

unit1
The Unit to subtract.

Return Value

The difference of this Unit and unit1 in this Unit's type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : ToString Method

Returns a human-readable representation ot this Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Overload List

Overload | Description
ToString() | Returns a human-readable representation ot this Unit.
ToString(CultureInfo) | Returns a human-readable representation ot this Unit.

Overload List

Overload | Description
ToString() | Returns a human-readable representation ot this Unit.
ToString(CultureInfo) | Returns a human-readable representation ot this Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


ToString() Method

ToString() Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > ToString Method : ToString() Method

Returns a human-readable representation ot this Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public NotOverridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A human-readable representation ot this Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


ToString(CultureInfo) Method

ToString(CultureInfo) Method
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > ToString Method : ToString(CultureInfo) Method

culture
A CultureInfo specifying the culture to use.
Returns a human-readable representation ot this Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function ToString( _
   ByVal culture As CultureInfo _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim culture As CultureInfo
Dim value As String

value = instance.ToString(culture)
C#
public string ToString(
   CultureInfo culture
)

Parameters

culture
A CultureInfo specifying the culture to use.

Return Value

A human-readable representation ot this Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Unit Structure Properties

Unit Structure Properties
[image]
Telerik.Reporting.Drawing Namespace : Unit Structure

For a list of all members of this type, see Unit members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | DefaultType | Gets or sets a UnitType representing the default units of measure for a Report.
static (Shared in Visual Basic) | DotsPerInch | Gets a double value representing the dpi of the current graphics context.
Public Property | IsEmpty | Specifies whether this Unit structure is uninitialized.
Public Property | Type | Gets the type of the Unit.
Public Property | Value | Gets the magnitude of this Unit.
Top

See Also

Reference

Unit Structure
Telerik.Reporting.Drawing Namespace


DefaultType Property

DefaultType Property
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : DefaultType Property

Gets or sets a UnitType representing the default units of measure for a Report.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property DefaultType As UnitType
Visual Basic (Usage) Copy Code
Dim value As UnitType

Unit.DefaultType = value

value = Unit.DefaultType
C#
public static UnitType DefaultType {get; set;}

Return Value

A UnitType value that defines the default units of measure for a Report.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


DotsPerInch Property

DotsPerInch Property
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : DotsPerInch Property

Gets a double value representing the dpi of the current graphics context.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DotsPerInch As Double
Visual Basic (Usage) Copy Code
Dim value As Double

value = Unit.DotsPerInch
C#
public static double DotsPerInch {get;}

Return Value

A double value representing the dpi of the current graphics context.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


IsEmpty Property

IsEmpty Property
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : IsEmpty Property

Specifies whether this Unit structure is uninitialized.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim value As Boolean

value = instance.IsEmpty
C#
public bool IsEmpty {get;}

Return Value

This property returns true if this unit is uninitialized; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Type Property

Type Property
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Type Property

Gets the type of the Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As UnitType
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim value As UnitType

value = instance.Type
C#
public UnitType Type {get;}

Return Value

A UnitType specifying the type of this Unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Value Property

Value Property
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Value Property

Gets the magnitude of this Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Single
Visual Basic (Usage) Copy Code
Dim instance As Unit
Dim value As Single

value = instance.Value
C#
public float Value {get;}

Return Value

A float value indicating the magnitude of the Unit.

Remarks

This property makes sense only in combination with the Type property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Unit Structure Fields

Unit Structure Fields
[image]
Telerik.Reporting.Drawing Namespace : Unit Structure

For a list of all members of this type, see Unit members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Initializes a new instance of the Unit structure.
static (Shared in Visual Basic) | Zero | Initializes a new instance of the Unit structure equal to zero.
Top

See Also

Reference

Unit Structure
Telerik.Reporting.Drawing Namespace


Empty Field

Empty Field
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Empty Field

Initializes a new instance of the Unit structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Unit
Visual Basic (Usage) Copy Code
Dim value As Unit

value = Unit.Empty
C#
public static readonly Unit Empty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Zero Field

Zero Field
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Zero Field

Initializes a new instance of the Unit structure equal to zero.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Zero As Unit
Visual Basic (Usage) Copy Code
Dim value As Unit

value = Unit.Zero
C#
public static readonly Unit Zero

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Addition Operator

Addition Operator
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Addition Operator

unit1
The first Unit.
unit2
The second Unit.
Adds one Unit to another.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Unit
C#
public Unit operator +(
   Unit unit1,
   Unit unit2
)

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Unit
C#
public Unit operator +(
   Unit unit1,
   Unit unit2
)

Parameters

unit1
The first Unit.
unit2
The second Unit.

Return Value

The sum of the two units.

Remarks

If unit1 is empty the method returns unit2. If unit2 is empty the method returns unit1. Othwerwise, the method returns the sum of the two units in unit1's type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Division Operator

Division Operator
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Division Operator

unit1
The Unit to divide.
value
A double value to divide by.
Divides a Unit by a specified value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator /( _
   ByVal unit1 As Unit, _
   ByVal value As Double _
) As Unit
C#
public Unit operator /(
   Unit unit1,
   double value
)

Syntax

Visual Basic (Declaration)
Public Operator /( _
   ByVal unit1 As Unit, _
   ByVal value As Double _
) As Unit
C#
public Unit operator /(
   Unit unit1,
   double value
)

Parameters

unit1
The Unit to divide.
value
A double value to divide by.

Return Value

A Unit that is the quotient of unit1 and value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Equality Operator

Equality Operator
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Equality Operator

unit1
The first unit to compare.
unit2
The second unit to compare.
Compares two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Boolean
C#
public bool operator ==(
   Unit unit1,
   Unit unit2
)

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Boolean
C#
public bool operator ==(
   Unit unit1,
   Unit unit2
)

Parameters

unit1
The first unit to compare.
unit2
The second unit to compare.

Return Value

true if unit1 is equal to unit2; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Greater Than Operator

Greater Than Operator
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Greater Than Operator

unit1
The first unit to compare.
unit2
The second unit to compare.
Compares two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Boolean
C#
public bool operator >(
   Unit unit1,
   Unit unit2
)

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Boolean
C#
public bool operator >(
   Unit unit1,
   Unit unit2
)

Parameters

unit1
The first unit to compare.
unit2
The second unit to compare.

Return Value

true if unit1 is greater than unit2; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Greater Than or Equal Operator

Greater Than or Equal Operator
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Greater Than or Equal Operator

unit1
The first unit to compare.
unit2
The second unit to compare.
Compares two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Boolean
C#
public bool operator >=(
   Unit unit1,
   Unit unit2
)

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Boolean
C#
public bool operator >=(
   Unit unit1,
   Unit unit2
)

Parameters

unit1
The first unit to compare.
unit2
The second unit to compare.

Return Value

true if unit1 is greater than or equal to unit2; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Inequality Operator

Inequality Operator
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Inequality Operator

unit1
The first unit to compare.
unit2
The second unit to compare.
Compares two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Boolean
C#
public bool operator !=(
   Unit unit1,
   Unit unit2
)

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Boolean
C#
public bool operator !=(
   Unit unit1,
   Unit unit2
)

Parameters

unit1
The first unit to compare.
unit2
The second unit to compare.

Return Value

true if unit1 is not equal to unit2; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Less Than Operator

Less Than Operator
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Less Than Operator

unit1
The first unit to compare.
unit2
The second unit to compare.
Compares two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Boolean
C#
public bool operator <(
   Unit unit1,
   Unit unit2
)

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Boolean
C#
public bool operator <(
   Unit unit1,
   Unit unit2
)

Parameters

unit1
The first unit to compare.
unit2
The second unit to compare.

Return Value

true if unit1 is less than unit2; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Less Than or Equal Operator

Less Than or Equal Operator
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Less Than or Equal Operator

unit1
The first unit to compare.
unit2
The second unit to compare.
Compares two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Boolean
C#
public bool operator <=(
   Unit unit1,
   Unit unit2
)

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Boolean
C#
public bool operator <=(
   Unit unit1,
   Unit unit2
)

Parameters

unit1
The first unit to compare.
unit2
The second unit to compare.

Return Value

true if unit1 is less than or equal to unit2; otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Multiplication Operator

Multiplication Operator
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Multiplication Operator

Multiplies a Unit by a specified value.

Overload List

Overload | Description
Multiplication(Double,Unit) | Multiplies a value by a Unit.
Multiplication(Unit,Double) | Multiplies a Unit by a specified value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Subtraction Operator

Subtraction Operator
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Subtraction Operator

unit1
The Unit to subtract from.
unit2
The Unit to subtract.
Subtract one Unit from another.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Unit
C#
public Unit operator -(
   Unit unit1,
   Unit unit2
)

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal unit1 As Unit, _
   ByVal unit2 As Unit _
) As Unit
C#
public Unit operator -(
   Unit unit1,
   Unit unit2
)

Parameters

unit1
The Unit to subtract from.
unit2
The Unit to subtract.

Return Value

The difference of the two units.

Exceptions

Exception | Description
ArgumentException | Thrown when unit1 is empty.

Remarks

If unit2 is empty the method returns unit1. Othwerwise, the method returns the difference of the two units in unit1's type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


Unary Negation Operator

Unary Negation Operator
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure : Unary Negation Operator

unit
The unit to negate.
Unary minus. Reverses the sign of Unit

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal unit As Unit _
) As Unit
C#
public Unit operator -(
   Unit unit
)

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal unit As Unit _
) As Unit
C#
public Unit operator -(
   Unit unit
)

Parameters

unit
The unit to negate.

Return Value

A Unit of the same type as unit but with opposite sign.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members


ArrowShape Class

ArrowShape Class
See Also Members
[image]
Telerik.Reporting.Drawing.Shapes Namespace : ArrowShape Class

Represents an arrow shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class ArrowShape
   Inherits RoundedCornerShape
Visual Basic (Usage) Copy Code
Dim instance As ArrowShape
C#
public class ArrowShape : RoundedCornerShape

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.Shapes.ShapeBase
Telerik.Reporting.Drawing.Shapes.RoundedCornerShape
Telerik.Reporting.Drawing.Shapes.ArrowShape

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ArrowShape Members
Telerik.Reporting.Drawing.Shapes Namespace


ArrowShape Class Members

ArrowShape Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : ArrowShape Class

The following tables list the members exposed by ArrowShape.

Public Constructors

 | Name | Description
Public Constructor | ArrowShape Constructor | Overloaded. Initializes a new instance of the ArrowShape with zero angle of rotation.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Public Property | Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this ArrowShape.
Top

Protected Methods

 | Name | Description
Protected Method | CreateRawShape | Overridden. Creates the raw shape.
Protected Method | CreateShape | Creates the shape. (Inherited from RoundedCornerShape)
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

ArrowShape Class
Telerik.Reporting.Drawing.Shapes Namespace


ArrowShape Constructor

ArrowShape Constructor
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ArrowShape Class : ArrowShape Constructor

Initializes a new instance of the ArrowShape with zero angle of rotation.

Overload List

Overload | Description
ArrowShape Constructor() | Initializes a new instance of the ArrowShape with zero angle of rotation.
ArrowShape Constructor(Double,Int32) | Initializes a new instance of the ArrowShape with the specified angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ArrowShape Class
ArrowShape Members


ArrowShape Constructor()

ArrowShape Constructor()
See Also
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ArrowShape Class > ArrowShape Constructor : ArrowShape Constructor()

Initializes a new instance of the ArrowShape with zero angle of rotation.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ArrowShape()
C#
public ArrowShape()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ArrowShape()
C#
public ArrowShape()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ArrowShape Class
ArrowShape Members
Overload List


ArrowShape Constructor(Double,Int32)

ArrowShape Constructor(Double,Int32)
See Also
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ArrowShape Class > ArrowShape Constructor : ArrowShape Constructor(Double,Int32)

angle
A double value specifying the angle of rotation of the shape in degrees.
rounding
An int value between 0 and 100 specifying the rounding of the edges in percent.
Initializes a new instance of the ArrowShape with the specified angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal angle As Double, _
   ByVal rounding As Integer _
)
Visual Basic (Usage) Copy Code
Dim angle As Double
Dim rounding As Integer

Dim instance As ArrowShape(angle, rounding)
C#
public ArrowShape(
   double angle,
   int rounding
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal angle As Double, _
   ByVal rounding As Integer _
)
Visual Basic (Usage) Copy Code
Dim angle As Double
Dim rounding As Integer

Dim instance As ArrowShape(angle, rounding)
C#
public ArrowShape(
   double angle,
   int rounding
)

Parameters

angle
A double value specifying the angle of rotation of the shape in degrees.
rounding
An int value between 0 and 100 specifying the rounding of the edges in percent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ArrowShape Class
ArrowShape Members
Overload List


ArrowShape Class Methods

ArrowShape Class Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : ArrowShape Class

For a list of all members of this type, see ArrowShape members.

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this ArrowShape.
Top

Protected Methods

 | Name | Description
Protected Method | CreateRawShape | Overridden. Creates the raw shape.
Protected Method | CreateShape | Creates the shape. (Inherited from RoundedCornerShape)
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

ArrowShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateRawShape Method

CreateRawShape Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ArrowShape Class : CreateRawShape Method

Creates the raw shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub CreateRawShape()
Visual Basic (Usage) Copy Code
Dim instance As ArrowShape

instance.CreateRawShape()
C#
protected override void CreateRawShape()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ArrowShape Class
ArrowShape Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ArrowShape Class : ToString Method

Returns a human-readable representation ot this ArrowShape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ArrowShape
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A human-readable representation ot this ArrowShape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ArrowShape Class
ArrowShape Members


BezierSegment Class

BezierSegment Class
See Also Members
[image]
Telerik.Reporting.Drawing.Shapes Namespace : BezierSegment Class

Represents a Bezier curve segment of a shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class BezierSegment
   Implements IShapeSegment
Visual Basic (Usage) Copy Code
Dim instance As BezierSegment
C#
public class BezierSegment : IShapeSegment

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.Shapes.BezierSegment

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BezierSegment Members
Telerik.Reporting.Drawing.Shapes Namespace


BezierSegment Class Members

BezierSegment Class Members
See Also Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : BezierSegment Class

The following tables list the members exposed by BezierSegment.

Public Constructors

 | Name | Description
Public Constructor | BezierSegment Constructor | Initializes a new instance of the BezierSegment class with the specified points.
Top

Public Properties

 | Name | Description
Public Property | ControlPoint1 | Gets the first control point of this segment.
Public Property | ControlPoint2 | Gets the second control point of this segment.
Public Property | EndPoint | Gets the end point of this segment.
Public Property | Points | Gets the points of this segment.
Public Property | StartPoint | Gets the start point of this segment.
Top

See Also

Reference

BezierSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


BezierSegment Constructor

BezierSegment Constructor
[image]
Telerik.Reporting.Drawing.Shapes Namespace > BezierSegment Class : BezierSegment Constructor

points
A point array representing the points of the segment. The array should contain 4 points -- start, control1, control2 and end.
Initializes a new instance of the BezierSegment class with the specified points.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim points() As PointF

Dim instance As BezierSegment(points)
C#
public BezierSegment(
   PointF[] points
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim points() As PointF

Dim instance As BezierSegment(points)
C#
public BezierSegment(
   PointF[] points
)

Parameters

points
A point array representing the points of the segment. The array should contain 4 points -- start, control1, control2 and end.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BezierSegment Class
BezierSegment Members


BezierSegment Class Properties

BezierSegment Class Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : BezierSegment Class

For a list of all members of this type, see BezierSegment members.

Public Properties

 | Name | Description
Public Property | ControlPoint1 | Gets the first control point of this segment.
Public Property | ControlPoint2 | Gets the second control point of this segment.
Public Property | EndPoint | Gets the end point of this segment.
Public Property | Points | Gets the points of this segment.
Public Property | StartPoint | Gets the start point of this segment.
Top

See Also

Reference

BezierSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


ControlPoint1 Property

ControlPoint1 Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > BezierSegment Class : ControlPoint1 Property

Gets the first control point of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ControlPoint1 As PointF
Visual Basic (Usage) Copy Code
Dim instance As BezierSegment
Dim value As PointF

value = instance.ControlPoint1
C#
public PointF ControlPoint1 {get;}

Return Value

The first control point of the segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BezierSegment Class
BezierSegment Members


ControlPoint2 Property

ControlPoint2 Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > BezierSegment Class : ControlPoint2 Property

Gets the second control point of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ControlPoint2 As PointF
Visual Basic (Usage) Copy Code
Dim instance As BezierSegment
Dim value As PointF

value = instance.ControlPoint2
C#
public PointF ControlPoint2 {get;}

Return Value

The second control point of the segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BezierSegment Class
BezierSegment Members


EndPoint Property

EndPoint Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > BezierSegment Class : EndPoint Property

Gets the end point of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EndPoint As PointF
Visual Basic (Usage) Copy Code
Dim instance As BezierSegment
Dim value As PointF

value = instance.EndPoint
C#
public PointF EndPoint {get;}

Return Value

The end point of the segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BezierSegment Class
BezierSegment Members


Points Property

Points Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > BezierSegment Class : Points Property

Gets the points of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Points As PointF()
Visual Basic (Usage) Copy Code
Dim instance As BezierSegment
Dim value() As PointF

value = instance.Points
C#
public PointF[] Points {get;}

Return Value

A point array representing the points of the segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BezierSegment Class
BezierSegment Members


StartPoint Property

StartPoint Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > BezierSegment Class : StartPoint Property

Gets the start point of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StartPoint As PointF
Visual Basic (Usage) Copy Code
Dim instance As BezierSegment
Dim value As PointF

value = instance.StartPoint
C#
public PointF StartPoint {get;}

Return Value

The start point of the segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BezierSegment Class
BezierSegment Members


CrossShape Class

CrossShape Class
See Also Members
[image]
Telerik.Reporting.Drawing.Shapes Namespace : CrossShape Class

Represents an cross shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class CrossShape
   Inherits RoundedCornerShape
Visual Basic (Usage) Copy Code
Dim instance As CrossShape
C#
public class CrossShape : RoundedCornerShape

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.Shapes.ShapeBase
Telerik.Reporting.Drawing.Shapes.RoundedCornerShape
Telerik.Reporting.Drawing.Shapes.CrossShape

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CrossShape Members
Telerik.Reporting.Drawing.Shapes Namespace


CrossShape Class Members

CrossShape Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : CrossShape Class

The following tables list the members exposed by CrossShape.

Public Constructors

 | Name | Description
Public Constructor | CrossShape Constructor | Overloaded. Initializes a new instance of the CrossShape with zero angle of rotation.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Public Property | Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this CrossShape.
Top

Protected Methods

 | Name | Description
Protected Method | CreateRawShape | Overridden. Creates the raw shape.
Protected Method | CreateShape | Creates the shape. (Inherited from RoundedCornerShape)
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

CrossShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CrossShape Constructor

CrossShape Constructor
[image]
Telerik.Reporting.Drawing.Shapes Namespace > CrossShape Class : CrossShape Constructor

Initializes a new instance of the CrossShape with zero angle of rotation.

Overload List

Overload | Description
CrossShape Constructor() | Initializes a new instance of the CrossShape with zero angle of rotation.
CrossShape Constructor(Double,Int32) | Initializes a new instance of the CrossShape with the specified angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CrossShape Class
CrossShape Members


CrossShape Constructor()

CrossShape Constructor()
See Also
[image]
Telerik.Reporting.Drawing.Shapes Namespace > CrossShape Class > CrossShape Constructor : CrossShape Constructor()

Initializes a new instance of the CrossShape with zero angle of rotation.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CrossShape()
C#
public CrossShape()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CrossShape()
C#
public CrossShape()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CrossShape Class
CrossShape Members
Overload List


CrossShape Constructor(Double,Int32)

CrossShape Constructor(Double,Int32)
See Also
[image]
Telerik.Reporting.Drawing.Shapes Namespace > CrossShape Class > CrossShape Constructor : CrossShape Constructor(Double,Int32)

angle
A double value specifying the angle of rotation of the shape in degrees.
rounding
An int value between 0 and 100 specifying the rounding of the edges in percent.
Initializes a new instance of the CrossShape with the specified angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal angle As Double, _
   ByVal rounding As Integer _
)
Visual Basic (Usage) Copy Code
Dim angle As Double
Dim rounding As Integer

Dim instance As CrossShape(angle, rounding)
C#
public CrossShape(
   double angle,
   int rounding
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal angle As Double, _
   ByVal rounding As Integer _
)
Visual Basic (Usage) Copy Code
Dim angle As Double
Dim rounding As Integer

Dim instance As CrossShape(angle, rounding)
C#
public CrossShape(
   double angle,
   int rounding
)

Parameters

angle
A double value specifying the angle of rotation of the shape in degrees.
rounding
An int value between 0 and 100 specifying the rounding of the edges in percent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CrossShape Class
CrossShape Members
Overload List


CrossShape Class Methods

CrossShape Class Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : CrossShape Class

For a list of all members of this type, see CrossShape members.

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this CrossShape.
Top

Protected Methods

 | Name | Description
Protected Method | CreateRawShape | Overridden. Creates the raw shape.
Protected Method | CreateShape | Creates the shape. (Inherited from RoundedCornerShape)
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

CrossShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateRawShape Method

CreateRawShape Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > CrossShape Class : CreateRawShape Method

Creates the raw shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub CreateRawShape()
Visual Basic (Usage) Copy Code
Dim instance As CrossShape

instance.CreateRawShape()
C#
protected override void CreateRawShape()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CrossShape Class
CrossShape Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > CrossShape Class : ToString Method

Returns a human-readable representation ot this CrossShape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As CrossShape
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A human-readable representation ot this CrossShape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CrossShape Class
CrossShape Members


Ellipse Class

Ellipse Class
See Also Members
[image]
Telerik.Reporting.Drawing.Shapes Namespace : Ellipse Class

Represents an ellipse segment of a shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class Ellipse
   Implements IShapeSegment
Visual Basic (Usage) Copy Code
Dim instance As Ellipse
C#
public class Ellipse : IShapeSegment

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.Shapes.Ellipse

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Ellipse Members
Telerik.Reporting.Drawing.Shapes Namespace


Ellipse Class Members

Ellipse Class Members
See Also Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : Ellipse Class

The following tables list the members exposed by Ellipse.

Public Constructors

 | Name | Description
Public Constructor | Ellipse Constructor | Initializes a new instance of the Ellipse class with the specified points.
Top

Public Properties

 | Name | Description
Public Property | Points | Gets the points of this segment.
Public Property | Rectangle | Gets the bounding rectangle of the segment.
Top

See Also

Reference

Ellipse Class
Telerik.Reporting.Drawing.Shapes Namespace


Ellipse Constructor

Ellipse Constructor
[image]
Telerik.Reporting.Drawing.Shapes Namespace > Ellipse Class : Ellipse Constructor

rectangle
A RectangleF structure representing the bounding rectangle of the segment.
Initializes a new instance of the Ellipse class with the specified points.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rectangle As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim rectangle As RectangleF

Dim instance As Ellipse(rectangle)
C#
public Ellipse(
   RectangleF rectangle
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rectangle As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim rectangle As RectangleF

Dim instance As Ellipse(rectangle)
C#
public Ellipse(
   RectangleF rectangle
)

Parameters

rectangle
A RectangleF structure representing the bounding rectangle of the segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Ellipse Class
Ellipse Members


Ellipse Class Properties

Ellipse Class Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : Ellipse Class

For a list of all members of this type, see Ellipse members.

Public Properties

 | Name | Description
Public Property | Points | Gets the points of this segment.
Public Property | Rectangle | Gets the bounding rectangle of the segment.
Top

See Also

Reference

Ellipse Class
Telerik.Reporting.Drawing.Shapes Namespace


Points Property

Points Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > Ellipse Class : Points Property

Gets the points of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Points As PointF()
Visual Basic (Usage) Copy Code
Dim instance As Ellipse
Dim value() As PointF

value = instance.Points
C#
public PointF[] Points {get;}

Return Value

A point array representing the points of the segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Ellipse Class
Ellipse Members


Rectangle Property

Rectangle Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > Ellipse Class : Rectangle Property

Gets the bounding rectangle of the segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rectangle As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As Ellipse
Dim value As RectangleF

value = instance.Rectangle
C#
public RectangleF Rectangle {get;}

Return Value

A RectangleF structure representing the bounding rectangle of the segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Ellipse Class
Ellipse Members


EllipseShape Class

EllipseShape Class
See Also Members
[image]
Telerik.Reporting.Drawing.Shapes Namespace : EllipseShape Class

Represents an ellipse shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class EllipseShape
   Inherits ShapeBase
Visual Basic (Usage) Copy Code
Dim instance As EllipseShape
C#
public class EllipseShape : ShapeBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.Shapes.ShapeBase
Telerik.Reporting.Drawing.Shapes.EllipseShape

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EllipseShape Members
Telerik.Reporting.Drawing.Shapes Namespace


EllipseShape Class Members

EllipseShape Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : EllipseShape Class

The following tables list the members exposed by EllipseShape.

Public Constructors

 | Name | Description
Public Constructor | EllipseShape Constructor | Overloaded. Initializes a new instance of the EllipseShape with zero angle of rotation.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this EllipseShape.
Top

Protected Methods

 | Name | Description
Protected Method | CreateShape | Overridden. Creates the shape.
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

EllipseShape Class
Telerik.Reporting.Drawing.Shapes Namespace


EllipseShape Constructor

EllipseShape Constructor
[image]
Telerik.Reporting.Drawing.Shapes Namespace > EllipseShape Class : EllipseShape Constructor

Initializes a new instance of the EllipseShape with zero angle of rotation.

Overload List

Overload | Description
EllipseShape Constructor() | Initializes a new instance of the EllipseShape with zero angle of rotation.
EllipseShape Constructor(Double) | Initializes a new instance of the EllipseShape with the specified angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EllipseShape Class
EllipseShape Members


EllipseShape Constructor()

EllipseShape Constructor()
See Also
[image]
Telerik.Reporting.Drawing.Shapes Namespace > EllipseShape Class > EllipseShape Constructor : EllipseShape Constructor()

Initializes a new instance of the EllipseShape with zero angle of rotation.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EllipseShape()
C#
public EllipseShape()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EllipseShape()
C#
public EllipseShape()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EllipseShape Class
EllipseShape Members
Overload List


EllipseShape Constructor(Double)

EllipseShape Constructor(Double)
See Also
[image]
Telerik.Reporting.Drawing.Shapes Namespace > EllipseShape Class > EllipseShape Constructor : EllipseShape Constructor(Double)

angle
A double value specifying the angle of rotation of the shape in degrees.
Initializes a new instance of the EllipseShape with the specified angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal angle As Double _
)
Visual Basic (Usage) Copy Code
Dim angle As Double

Dim instance As EllipseShape(angle)
C#
public EllipseShape(
   double angle
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal angle As Double _
)
Visual Basic (Usage) Copy Code
Dim angle As Double

Dim instance As EllipseShape(angle)
C#
public EllipseShape(
   double angle
)

Parameters

angle
A double value specifying the angle of rotation of the shape in degrees.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EllipseShape Class
EllipseShape Members
Overload List


EllipseShape Class Methods

EllipseShape Class Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : EllipseShape Class

For a list of all members of this type, see EllipseShape members.

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this EllipseShape.
Top

Protected Methods

 | Name | Description
Protected Method | CreateShape | Overridden. Creates the shape.
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

EllipseShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateShape Method

CreateShape Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > EllipseShape Class : CreateShape Method

Creates the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub CreateShape()
Visual Basic (Usage) Copy Code
Dim instance As EllipseShape

instance.CreateShape()
C#
protected override void CreateShape()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EllipseShape Class
EllipseShape Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > EllipseShape Class : ToString Method

Returns a human-readable representation ot this EllipseShape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As EllipseShape
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A human-readable representation ot this EllipseShape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EllipseShape Class
EllipseShape Members


LineSegment Class

LineSegment Class
See Also Members
[image]
Telerik.Reporting.Drawing.Shapes Namespace : LineSegment Class

Represents line segment of a shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class LineSegment
   Implements IShapeSegment
Visual Basic (Usage) Copy Code
Dim instance As LineSegment
C#
public class LineSegment : IShapeSegment

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.Shapes.LineSegment

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineSegment Members
Telerik.Reporting.Drawing.Shapes Namespace


LineSegment Class Members

LineSegment Class Members
See Also Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : LineSegment Class

The following tables list the members exposed by LineSegment.

Public Constructors

 | Name | Description
Public Constructor | LineSegment Constructor | Initializes a new instance of the LineSegment class with the specified points.
Top

Public Properties

 | Name | Description
Public Property | EndPoint | Gets the end point of this segment.
Public Property | Length | Gets the length of the line.
Public Property | Points | Gets the points of this segment.
Public Property | StartPoint | Gets the start point of this segment.
Top

See Also

Reference

LineSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


LineSegment Constructor

LineSegment Constructor
[image]
Telerik.Reporting.Drawing.Shapes Namespace > LineSegment Class : LineSegment Constructor

point1
The start point of the line segment.
point2
The end point of the line segment.
Initializes a new instance of the LineSegment class with the specified points.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF _
)
Visual Basic (Usage) Copy Code
Dim point1 As PointF
Dim point2 As PointF

Dim instance As LineSegment(point1, point2)
C#
public LineSegment(
   PointF point1,
   PointF point2
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF _
)
Visual Basic (Usage) Copy Code
Dim point1 As PointF
Dim point2 As PointF

Dim instance As LineSegment(point1, point2)
C#
public LineSegment(
   PointF point1,
   PointF point2
)

Parameters

point1
The start point of the line segment.
point2
The end point of the line segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineSegment Class
LineSegment Members


LineSegment Class Properties

LineSegment Class Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : LineSegment Class

For a list of all members of this type, see LineSegment members.

Public Properties

 | Name | Description
Public Property | EndPoint | Gets the end point of this segment.
Public Property | Length | Gets the length of the line.
Public Property | Points | Gets the points of this segment.
Public Property | StartPoint | Gets the start point of this segment.
Top

See Also

Reference

LineSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


EndPoint Property

EndPoint Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > LineSegment Class : EndPoint Property

Gets the end point of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property EndPoint As PointF
Visual Basic (Usage) Copy Code
Dim instance As LineSegment
Dim value As PointF

instance.EndPoint = value

value = instance.EndPoint
C#
public PointF EndPoint {get; set;}

Return Value

The end point of the segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineSegment Class
LineSegment Members


Length Property

Length Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > LineSegment Class : Length Property

Gets the length of the line.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Single
Visual Basic (Usage) Copy Code
Dim instance As LineSegment
Dim value As Single

value = instance.Length
C#
public float Length {get;}

Return Value

A float value representing the lenght of the line segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineSegment Class
LineSegment Members


Points Property

Points Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > LineSegment Class : Points Property

Gets the points of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Points As PointF()
Visual Basic (Usage) Copy Code
Dim instance As LineSegment
Dim value() As PointF

value = instance.Points
C#
public PointF[] Points {get;}

Return Value

A point array representing the points of the segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineSegment Class
LineSegment Members


StartPoint Property

StartPoint Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > LineSegment Class : StartPoint Property

Gets the start point of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property StartPoint As PointF
Visual Basic (Usage) Copy Code
Dim instance As LineSegment
Dim value As PointF

instance.StartPoint = value

value = instance.StartPoint
C#
public PointF StartPoint {get; set;}

Return Value

The start point of the segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineSegment Class
LineSegment Members


LineShape Class

LineShape Class
See Also Members
[image]
Telerik.Reporting.Drawing.Shapes Namespace : LineShape Class

Represents a line shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class LineShape
   Inherits ShapeBase
Visual Basic (Usage) Copy Code
Dim instance As LineShape
C#
public class LineShape : ShapeBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.Shapes.ShapeBase
Telerik.Reporting.Drawing.Shapes.LineShape

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineShape Members
Telerik.Reporting.Drawing.Shapes Namespace


LineShape Class Members

LineShape Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : LineShape Class

The following tables list the members exposed by LineShape.

Public Constructors

 | Name | Description
Public Constructor | LineShape Constructor | Initializes a new instance of the LineShape with specified line direction.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this LineShape.
Top

Protected Methods

 | Name | Description
Protected Method | CreateShape | Overridden. Creates the shape.
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

LineShape Class
Telerik.Reporting.Drawing.Shapes Namespace


LineShape Constructor

LineShape Constructor
[image]
Telerik.Reporting.Drawing.Shapes Namespace > LineShape Class : LineShape Constructor

lineDirection
The direction of the line.
Initializes a new instance of the LineShape with specified line direction.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lineDirection As LineDirection _
)
Visual Basic (Usage) Copy Code
Dim lineDirection As LineDirection

Dim instance As LineShape(lineDirection)
C#
public LineShape(
   LineDirection lineDirection
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lineDirection As LineDirection _
)
Visual Basic (Usage) Copy Code
Dim lineDirection As LineDirection

Dim instance As LineShape(lineDirection)
C#
public LineShape(
   LineDirection lineDirection
)

Parameters

lineDirection
The direction of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineShape Class
LineShape Members


LineShape Class Methods

LineShape Class Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : LineShape Class

For a list of all members of this type, see LineShape members.

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this LineShape.
Top

Protected Methods

 | Name | Description
Protected Method | CreateShape | Overridden. Creates the shape.
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

LineShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateShape Method

CreateShape Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > LineShape Class : CreateShape Method

Creates the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub CreateShape()
Visual Basic (Usage) Copy Code
Dim instance As LineShape

instance.CreateShape()
C#
protected override void CreateShape()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineShape Class
LineShape Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > LineShape Class : ToString Method

Returns a human-readable representation ot this LineShape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As LineShape
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A human-readable representation ot this LineShape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineShape Class
LineShape Members


PolygonShape Class

PolygonShape Class
See Also Members
[image]
Telerik.Reporting.Drawing.Shapes Namespace : PolygonShape Class

Represents a polygon shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class PolygonShape
   Inherits PolygonShapeBase
Visual Basic (Usage) Copy Code
Dim instance As PolygonShape
C#
public class PolygonShape : PolygonShapeBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.Shapes.ShapeBase
Telerik.Reporting.Drawing.Shapes.RoundedCornerShape
Telerik.Reporting.Drawing.Shapes.PolygonShapeBase
Telerik.Reporting.Drawing.Shapes.PolygonShape

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PolygonShape Members
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShape Class Members

PolygonShape Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : PolygonShape Class

The following tables list the members exposed by PolygonShape.

Public Constructors

 | Name | Description
Public Constructor | PolygonShape Constructor | Overloaded. Initializes a new instance of the PolygonShape with the specified vertex count and zero angle of rotation.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Public Property | Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this PolygonShape.
Top

Protected Methods

 | Name | Description
Protected Method | CreateRawShape | Creates the raw shape. (Inherited from PolygonShapeBase)
Protected Method | CreateShape | Creates the shape. (Inherited from RoundedCornerShape)
Protected Method | GetPoints | Overridden. Gets the points of this shape.
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

PolygonShape Class
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShape Constructor

PolygonShape Constructor
[image]
Telerik.Reporting.Drawing.Shapes Namespace > PolygonShape Class : PolygonShape Constructor

Initializes a new instance of the PolygonShape with the specified vertex count and zero angle of rotation.

Overload List

Overload | Description
PolygonShape Constructor(Int32) | Initializes a new instance of the PolygonShape with the specified vertex count and zero angle of rotation.
PolygonShape Constructor(Int32,Double,Int32) | Initializes a new instance of the PolygonShape with the specified vertex count and angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PolygonShape Class
PolygonShape Members


PolygonShape Constructor(Int32)

PolygonShape Constructor(Int32)
See Also
[image]
Telerik.Reporting.Drawing.Shapes Namespace > PolygonShape Class > PolygonShape Constructor : PolygonShape Constructor(Int32)

vertexCount
The number of vertices of the shape.
Initializes a new instance of the PolygonShape with the specified vertex count and zero angle of rotation.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal vertexCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim vertexCount As Integer

Dim instance As PolygonShape(vertexCount)
C#
public PolygonShape(
   int vertexCount
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal vertexCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim vertexCount As Integer

Dim instance As PolygonShape(vertexCount)
C#
public PolygonShape(
   int vertexCount
)

Parameters

vertexCount
The number of vertices of the shape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PolygonShape Class
PolygonShape Members
Overload List


PolygonShape Constructor(Int32,Double,Int32)

PolygonShape Constructor(Int32,Double,Int32)
See Also
[image]
Telerik.Reporting.Drawing.Shapes Namespace > PolygonShape Class > PolygonShape Constructor : PolygonShape Constructor(Int32,Double,Int32)

vertexCount
The number of vertices of the shape.
angle
A double value specifying the angle of rotation of the shape in degrees.
rounding
An int value between 0 and 100 specifying the rounding of the edges in percent.
Initializes a new instance of the PolygonShape with the specified vertex count and angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal vertexCount As Integer, _
   ByVal angle As Double, _
   ByVal rounding As Integer _
)
Visual Basic (Usage) Copy Code
Dim vertexCount As Integer
Dim angle As Double
Dim rounding As Integer

Dim instance As PolygonShape(vertexCount, angle, rounding)
C#
public PolygonShape(
   int vertexCount,
   double angle,
   int rounding
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal vertexCount As Integer, _
   ByVal angle As Double, _
   ByVal rounding As Integer _
)
Visual Basic (Usage) Copy Code
Dim vertexCount As Integer
Dim angle As Double
Dim rounding As Integer

Dim instance As PolygonShape(vertexCount, angle, rounding)
C#
public PolygonShape(
   int vertexCount,
   double angle,
   int rounding
)

Parameters

vertexCount
The number of vertices of the shape.
angle
A double value specifying the angle of rotation of the shape in degrees.
rounding
An int value between 0 and 100 specifying the rounding of the edges in percent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PolygonShape Class
PolygonShape Members
Overload List


PolygonShape Class Methods

PolygonShape Class Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : PolygonShape Class

For a list of all members of this type, see PolygonShape members.

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this PolygonShape.
Top

Protected Methods

 | Name | Description
Protected Method | CreateRawShape | Creates the raw shape. (Inherited from PolygonShapeBase)
Protected Method | CreateShape | Creates the shape. (Inherited from RoundedCornerShape)
Protected Method | GetPoints | Overridden. Gets the points of this shape.
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

PolygonShape Class
Telerik.Reporting.Drawing.Shapes Namespace


GetPoints Method

GetPoints Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > PolygonShape Class : GetPoints Method

bounds
The bound of the shape.
Gets the points of this shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetPoints( _
   ByVal bounds As RectangleF _
) As PointF()
Visual Basic (Usage) Copy Code
Dim instance As PolygonShape
Dim bounds As RectangleF
Dim value() As PointF

value = instance.GetPoints(bounds)
C#
protected override PointF[] GetPoints(
   RectangleF bounds
)

Parameters

bounds
The bound of the shape.

Return Value

A point array representing the points of this shape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PolygonShape Class
PolygonShape Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > PolygonShape Class : ToString Method

Returns a human-readable representation ot this PolygonShape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PolygonShape
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A human-readable representation ot this PolygonShape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PolygonShape Class
PolygonShape Members


PolygonShapeBase Class

PolygonShapeBase Class
See Also Members
[image]
Telerik.Reporting.Drawing.Shapes Namespace : PolygonShapeBase Class

Represents the base class for all polygon shapes.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class PolygonShapeBase
   Inherits RoundedCornerShape
Visual Basic (Usage) Copy Code
Dim instance As PolygonShapeBase
C#
public abstract class PolygonShapeBase : RoundedCornerShape

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.Shapes.ShapeBase
Telerik.Reporting.Drawing.Shapes.RoundedCornerShape
Telerik.Reporting.Drawing.Shapes.PolygonShapeBase
Telerik.Reporting.Drawing.Shapes.PolygonShape
Telerik.Reporting.Drawing.Shapes.StarShape

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PolygonShapeBase Members
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShapeBase Class Members

PolygonShapeBase Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : PolygonShapeBase Class

The following tables list the members exposed by PolygonShapeBase.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Public Property | Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateRawShape | Overridden. Creates the raw shape.
Protected Method | CreateShape | Creates the shape. (Inherited from RoundedCornerShape)
Protected Method | GetPoints | Gets the points of this shape.
static (Shared in Visual Basic) | GetPointsCore | Gets the core points for this shape.
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

PolygonShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShapeBase Class Methods

PolygonShapeBase Class Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : PolygonShapeBase Class

For a list of all members of this type, see PolygonShapeBase members.

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateRawShape | Overridden. Creates the raw shape.
Protected Method | CreateShape | Creates the shape. (Inherited from RoundedCornerShape)
Protected Method | GetPoints | Gets the points of this shape.
static (Shared in Visual Basic) | GetPointsCore | Gets the core points for this shape.
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

PolygonShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateRawShape Method

CreateRawShape Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > PolygonShapeBase Class : CreateRawShape Method

Creates the raw shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub CreateRawShape()
Visual Basic (Usage) Copy Code
Dim instance As PolygonShapeBase

instance.CreateRawShape()
C#
protected override void CreateRawShape()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PolygonShapeBase Class
PolygonShapeBase Members


GetPoints Method

GetPoints Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > PolygonShapeBase Class : GetPoints Method

bounds
The bound of the shape.
Gets the points of this shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetPoints( _
   ByVal bounds As RectangleF _
) As PointF()
Visual Basic (Usage) Copy Code
Dim instance As PolygonShapeBase
Dim bounds As RectangleF
Dim value() As PointF

value = instance.GetPoints(bounds)
C#
protected abstract PointF[] GetPoints(
   RectangleF bounds
)

Parameters

bounds
The bound of the shape.

Return Value

A point array representing the points of this shape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PolygonShapeBase Class
PolygonShapeBase Members


GetPointsCore Method

GetPointsCore Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > PolygonShapeBase Class : GetPointsCore Method

center
The center of the shape.
segmentCount
The number of segments of the shape.
radius
The radius of the shape.
angle
The angle of rotation of the shape.
Gets the core points for this shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetPointsCore( _
   ByVal center As PointF, _
   ByVal segmentCount As Integer, _
   ByVal radius As Double, _
   ByVal angle As Double _
) As PointF()
Visual Basic (Usage) Copy Code
Dim center As PointF
Dim segmentCount As Integer
Dim radius As Double
Dim angle As Double
Dim value() As PointF

value = PolygonShapeBase.GetPointsCore(center, segmentCount, radius, angle)
C#
protected static PointF[] GetPointsCore(
   PointF center,
   int segmentCount,
   double radius,
   double angle
)

Parameters

center
The center of the shape.
segmentCount
The number of segments of the shape.
radius
The radius of the shape.
angle
The angle of rotation of the shape.

Return Value

A point array representing the core points of this shape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PolygonShapeBase Class
PolygonShapeBase Members


RoundedCornerShape Class

RoundedCornerShape Class
See Also Members
[image]
Telerik.Reporting.Drawing.Shapes Namespace : RoundedCornerShape Class

Represents shape with rounded corners.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class RoundedCornerShape
   Inherits ShapeBase
Visual Basic (Usage) Copy Code
Dim instance As RoundedCornerShape
C#
public abstract class RoundedCornerShape : ShapeBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.Shapes.ShapeBase
Telerik.Reporting.Drawing.Shapes.RoundedCornerShape
Telerik.Reporting.Drawing.Shapes.ArrowShape
Telerik.Reporting.Drawing.Shapes.CrossShape
Telerik.Reporting.Drawing.Shapes.PolygonShapeBase

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RoundedCornerShape Members
Telerik.Reporting.Drawing.Shapes Namespace


RoundedCornerShape Class Members

RoundedCornerShape Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : RoundedCornerShape Class

The following tables list the members exposed by RoundedCornerShape.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Public Property | Rounding | Gets or sets the rounding factor for the shape.
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateRawShape | When overriden this method should create shape that will be rounded using the RoundVertexOp operator.
Protected Method | CreateShape | Overridden. Creates the shape.
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

RoundedCornerShape Class
Telerik.Reporting.Drawing.Shapes Namespace


RoundedCornerShape Class Methods

RoundedCornerShape Class Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : RoundedCornerShape Class

For a list of all members of this type, see RoundedCornerShape members.

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateRawShape | When overriden this method should create shape that will be rounded using the RoundVertexOp operator.
Protected Method | CreateShape | Overridden. Creates the shape.
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

RoundedCornerShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateRawShape Method

CreateRawShape Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > RoundedCornerShape Class : CreateRawShape Method

When overriden this method should create shape that will be rounded using the RoundVertexOp operator.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub CreateRawShape()
Visual Basic (Usage) Copy Code
Dim instance As RoundedCornerShape

instance.CreateRawShape()
C#
protected abstract void CreateRawShape()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RoundedCornerShape Class
RoundedCornerShape Members


CreateShape Method

CreateShape Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > RoundedCornerShape Class : CreateShape Method

Creates the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub CreateShape()
Visual Basic (Usage) Copy Code
Dim instance As RoundedCornerShape

instance.CreateShape()
C#
protected override void CreateShape()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RoundedCornerShape Class
RoundedCornerShape Members


RoundedCornerShape Class Properties

RoundedCornerShape Class Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : RoundedCornerShape Class

For a list of all members of this type, see RoundedCornerShape members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Public Property | Rounding | Gets or sets the rounding factor for the shape.
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

See Also

Reference

RoundedCornerShape Class
Telerik.Reporting.Drawing.Shapes Namespace


Rounding Property

Rounding Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > RoundedCornerShape Class : Rounding Property

Gets or sets the rounding factor for the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Rounding As Integer
Visual Basic (Usage) Copy Code
Dim instance As RoundedCornerShape
Dim value As Integer

instance.Rounding = value

value = instance.Rounding
C#
public int Rounding {get; set;}

Return Value

A double value between 0 and 100 specifying the rounding factor of the shape. 0 means no rounding, 100 means full rounding.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RoundedCornerShape Class
RoundedCornerShape Members


ShapeBase Class

ShapeBase Class
See Also Members
[image]
Telerik.Reporting.Drawing.Shapes Namespace : ShapeBase Class

Base class for all shape types.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ShapeBase
Visual Basic (Usage) Copy Code
Dim instance As ShapeBase
C#
public abstract class ShapeBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.Shapes.ShapeBase
Telerik.Reporting.Drawing.Shapes.EllipseShape
Telerik.Reporting.Drawing.Shapes.LineShape
Telerik.Reporting.Drawing.Shapes.RoundedCornerShape

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShapeBase Members
Telerik.Reporting.Drawing.Shapes Namespace


ShapeBase Class Members

ShapeBase Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : ShapeBase Class

The following tables list the members exposed by ShapeBase.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape.
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians.
Top

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape.
Public Method | AddEllipse | Adds an ellipse to the shape.
Public Method | AddLine | Adds a straight line to the shape.
Public Method | AddLines | Adds a series of straight lines to the shape.
Public Method | GetEnumerator |
Top

Protected Methods

 | Name | Description
Protected Method | CreateShape | When overriden this method should create the shape.
Protected Method | RecreateShape | Recreates the shape.
Top

See Also

Reference

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


ShapeBase Class Methods

ShapeBase Class Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : ShapeBase Class

For a list of all members of this type, see ShapeBase members.

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape.
Public Method | AddEllipse | Adds an ellipse to the shape.
Public Method | AddLine | Adds a straight line to the shape.
Public Method | AddLines | Adds a series of straight lines to the shape.
Public Method | GetEnumerator |
Top

Protected Methods

 | Name | Description
Protected Method | CreateShape | When overriden this method should create the shape.
Protected Method | RecreateShape | Recreates the shape.
Top

See Also

Reference

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


AddBeziers Method

AddBeziers Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ShapeBase Class : AddBeziers Method

points
A point array representing the points of the Bezier curve.
Adds a Bezier curve to the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddBeziers( _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As ShapeBase
Dim points() As PointF

instance.AddBeziers(points)
C#
public void AddBeziers(
   PointF[] points
)

Parameters

points
A point array representing the points of the Bezier curve.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShapeBase Class
ShapeBase Members


AddEllipse Method

AddEllipse Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ShapeBase Class : AddEllipse Method

bounds
The bounding rectangle of the ellipse.
Adds an ellipse to the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddEllipse( _
   ByVal bounds As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As ShapeBase
Dim bounds As RectangleF

instance.AddEllipse(bounds)
C#
public void AddEllipse(
   RectangleF bounds
)

Parameters

bounds
The bounding rectangle of the ellipse.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShapeBase Class
ShapeBase Members


AddLine Method

AddLine Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ShapeBase Class : AddLine Method

point1
The statr point of the line.
point2
The end point of the line.
Adds a straight line to the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddLine( _
   ByVal point1 As PointF, _
   ByVal point2 As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As ShapeBase
Dim point1 As PointF
Dim point2 As PointF

instance.AddLine(point1, point2)
C#
public void AddLine(
   PointF point1,
   PointF point2
)

Parameters

point1
The statr point of the line.
point2
The end point of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShapeBase Class
ShapeBase Members


AddLines Method

AddLines Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ShapeBase Class : AddLines Method

points
A point array representing the starting and ending points of the lines.
close
A boolean value specifying whether to close the shape.
Adds a series of straight lines to the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddLines( _
   ByVal points() As PointF, _
   ByVal close As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ShapeBase
Dim points() As PointF
Dim close As Boolean

instance.AddLines(points, close)
C#
public void AddLines(
   PointF[] points,
   bool close
)

Parameters

points
A point array representing the starting and ending points of the lines.
close
A boolean value specifying whether to close the shape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShapeBase Class
ShapeBase Members


CreateShape Method

CreateShape Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ShapeBase Class : CreateShape Method

When overriden this method should create the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub CreateShape()
Visual Basic (Usage) Copy Code
Dim instance As ShapeBase

instance.CreateShape()
C#
protected abstract void CreateShape()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShapeBase Class
ShapeBase Members


GetEnumerator Method

GetEnumerator Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ShapeBase Class : GetEnumerator Method

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ShapeBase
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShapeBase Class
ShapeBase Members


RecreateShape Method

RecreateShape Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ShapeBase Class : RecreateShape Method

Recreates the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RecreateShape()
Visual Basic (Usage) Copy Code
Dim instance As ShapeBase

instance.RecreateShape()
C#
protected void RecreateShape()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShapeBase Class
ShapeBase Members


ShapeBase Class Properties

ShapeBase Class Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : ShapeBase Class

For a list of all members of this type, see ShapeBase members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape.
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians.
Top

See Also

Reference

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


AngleInRad Property

AngleInRad Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ShapeBase Class : AngleInRad Property

Gets the angle of rotation of this shape in radians.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property AngleInRad As Double
Visual Basic (Usage) Copy Code
Dim instance As ShapeBase
Dim value As Double

value = instance.AngleInRad
C#
protected double AngleInRad {get;}

Return Value

A double value representing the angle of rotation of this shape in radians.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShapeBase Class
ShapeBase Members


Bounds Property

Bounds Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > ShapeBase Class : Bounds Property

Gets or sets the bounds of this shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Bounds As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As ShapeBase
Dim value As RectangleF

instance.Bounds = value

value = instance.Bounds
C#
public RectangleF Bounds {get; set;}

Return Value

A RectangleF structure representing the bounds of this shape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShapeBase Class
ShapeBase Members


StarShape Class

StarShape Class
See Also Members
[image]
Telerik.Reporting.Drawing.Shapes Namespace : StarShape Class

Represents a star shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Class StarShape
   Inherits PolygonShapeBase
Visual Basic (Usage) Copy Code
Dim instance As StarShape
C#
public class StarShape : PolygonShapeBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.Shapes.ShapeBase
Telerik.Reporting.Drawing.Shapes.RoundedCornerShape
Telerik.Reporting.Drawing.Shapes.PolygonShapeBase
Telerik.Reporting.Drawing.Shapes.StarShape

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StarShape Members
Telerik.Reporting.Drawing.Shapes Namespace


StarShape Class Members

StarShape Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : StarShape Class

The following tables list the members exposed by StarShape.

Public Constructors

 | Name | Description
Public Constructor | StarShape Constructor | Overloaded. Initializes a new instance of the StarShape with the specified vertex count, 50% concavity, and zero angle of rotation.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Public Property | Concavity | Gets or sets a percent value specifying the concavity of the shape.
Public Property | Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this StarShape.
Top

Protected Methods

 | Name | Description
Protected Method | CreateRawShape | Creates the raw shape. (Inherited from PolygonShapeBase)
Protected Method | CreateShape | Creates the shape. (Inherited from RoundedCornerShape)
Protected Method | GetPoints | Overridden. Gets the points of this shape.
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

StarShape Class
Telerik.Reporting.Drawing.Shapes Namespace


StarShape Constructor

StarShape Constructor
[image]
Telerik.Reporting.Drawing.Shapes Namespace > StarShape Class : StarShape Constructor

Initializes a new instance of the StarShape with the specified vertex count, 50% concavity, and zero angle of rotation.

Overload List

Overload | Description
StarShape Constructor(Int32) | Initializes a new instance of the StarShape with the specified vertex count, 50% concavity, and zero angle of rotation.
StarShape Constructor(Int32,Int32,Double,Int32) | Initializes a new instance of the StarShape with the specified vertex count, concavity, and angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StarShape Class
StarShape Members


StarShape Constructor(Int32)

StarShape Constructor(Int32)
See Also
[image]
Telerik.Reporting.Drawing.Shapes Namespace > StarShape Class > StarShape Constructor : StarShape Constructor(Int32)

vertexCount
The number of vertices of the shape.
Initializes a new instance of the StarShape with the specified vertex count, 50% concavity, and zero angle of rotation.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal vertexCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim vertexCount As Integer

Dim instance As StarShape(vertexCount)
C#
public StarShape(
   int vertexCount
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal vertexCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim vertexCount As Integer

Dim instance As StarShape(vertexCount)
C#
public StarShape(
   int vertexCount
)

Parameters

vertexCount
The number of vertices of the shape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StarShape Class
StarShape Members
Overload List


StarShape Constructor(Int32,Int32,Double,Int32)

StarShape Constructor(Int32,Int32,Double,Int32)
See Also
[image]
Telerik.Reporting.Drawing.Shapes Namespace > StarShape Class > StarShape Constructor : StarShape Constructor(Int32,Int32,Double,Int32)

vertexCount
The number of vertices of the shape.
concavity
The concavity in percent of the shape.
angle
A double value specifying the angle of rotation of the shape in degrees.
rounding
An int value between 0 and 100 specifying the rounding of the edges in percent.
Initializes a new instance of the StarShape with the specified vertex count, concavity, and angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal vertexCount As Integer, _
   ByVal concavity As Integer, _
   ByVal angle As Double, _
   ByVal rounding As Integer _
)
Visual Basic (Usage) Copy Code
Dim vertexCount As Integer
Dim concavity As Integer
Dim angle As Double
Dim rounding As Integer

Dim instance As StarShape(vertexCount, concavity, angle, rounding)
C#
public StarShape(
   int vertexCount,
   int concavity,
   double angle,
   int rounding
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal vertexCount As Integer, _
   ByVal concavity As Integer, _
   ByVal angle As Double, _
   ByVal rounding As Integer _
)
Visual Basic (Usage) Copy Code
Dim vertexCount As Integer
Dim concavity As Integer
Dim angle As Double
Dim rounding As Integer

Dim instance As StarShape(vertexCount, concavity, angle, rounding)
C#
public StarShape(
   int vertexCount,
   int concavity,
   double angle,
   int rounding
)

Parameters

vertexCount
The number of vertices of the shape.
concavity
The concavity in percent of the shape.
angle
A double value specifying the angle of rotation of the shape in degrees.
rounding
An int value between 0 and 100 specifying the rounding of the edges in percent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StarShape Class
StarShape Members
Overload List


StarShape Class Methods

StarShape Class Methods
[image]
Telerik.Reporting.Drawing.Shapes Namespace : StarShape Class

For a list of all members of this type, see StarShape members.

Public Methods

 | Name | Description
Public Method | AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase)
Public Method | AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase)
Public Method | AddLine | Adds a straight line to the shape. (Inherited from ShapeBase)
Public Method | AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase)
Public Method | GetEnumerator | (Inherited from ShapeBase)
Public Method | ToString | Overridden. Returns a human-readable representation ot this StarShape.
Top

Protected Methods

 | Name | Description
Protected Method | CreateRawShape | Creates the raw shape. (Inherited from PolygonShapeBase)
Protected Method | CreateShape | Creates the shape. (Inherited from RoundedCornerShape)
Protected Method | GetPoints | Overridden. Gets the points of this shape.
Protected Method | RecreateShape | Recreates the shape. (Inherited from ShapeBase)
Top

See Also

Reference

StarShape Class
Telerik.Reporting.Drawing.Shapes Namespace


GetPoints Method

GetPoints Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > StarShape Class : GetPoints Method

bounds
The bound of the shape.
Gets the points of this shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetPoints( _
   ByVal bounds As RectangleF _
) As PointF()
Visual Basic (Usage) Copy Code
Dim instance As StarShape
Dim bounds As RectangleF
Dim value() As PointF

value = instance.GetPoints(bounds)
C#
protected override PointF[] GetPoints(
   RectangleF bounds
)

Parameters

bounds
The bound of the shape.

Return Value

A point array representing the points of this shape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StarShape Class
StarShape Members


ToString Method

ToString Method
[image]
Telerik.Reporting.Drawing.Shapes Namespace > StarShape Class : ToString Method

Returns a human-readable representation ot this StarShape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As StarShape
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Return Value

A human-readable representation ot this StarShape.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StarShape Class
StarShape Members


StarShape Class Properties

StarShape Class Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : StarShape Class

For a list of all members of this type, see StarShape members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Public Property | Concavity | Gets or sets a percent value specifying the concavity of the shape.
Public Property | Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

See Also

Reference

StarShape Class
Telerik.Reporting.Drawing.Shapes Namespace


Concavity Property

Concavity Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > StarShape Class : Concavity Property

Gets or sets a percent value specifying the concavity of the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Concavity As Integer
Visual Basic (Usage) Copy Code
Dim instance As StarShape
Dim value As Integer

instance.Concavity = value

value = instance.Concavity
C#
public int Concavity {get; set;}

Return Value

An int value between 0 and 100 specifying the concavity of the shape in percent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StarShape Class
StarShape Members


IShapeSegment Interface

IShapeSegment Interface
See Also Members
[image]
Telerik.Reporting.Drawing.Shapes Namespace : IShapeSegment Interface

Represents a shape segment.
Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Interface IShapeSegment
Visual Basic (Usage) Copy Code
Dim instance As IShapeSegment
C#
public interface IShapeSegment

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IShapeSegment Members
Telerik.Reporting.Drawing.Shapes Namespace


IShapeSegment Interface Members

IShapeSegment Interface Members
See Also Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : IShapeSegment Interface

The following tables list the members exposed by IShapeSegment.

Public Properties

 | Name | Description
Property | Points | Gets the points of this segment.
Top

See Also

Reference

IShapeSegment Interface
Telerik.Reporting.Drawing.Shapes Namespace


IShapeSegment Interface Properties

IShapeSegment Interface Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : IShapeSegment Interface

For a list of all members of this type, see IShapeSegment members.

Public Properties

 | Name | Description
Property | Points | Gets the points of this segment.
Top

See Also

Reference

IShapeSegment Interface
Telerik.Reporting.Drawing.Shapes Namespace


Points Property

Points Property
[image]
Telerik.Reporting.Drawing.Shapes Namespace > IShapeSegment Interface : Points Property

Gets the points of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Points As PointF()
Visual Basic (Usage) Copy Code
Dim instance As IShapeSegment
Dim value() As PointF

value = instance.Points
C#
PointF[] Points {get;}

Return Value

A point array representing the points of the segment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IShapeSegment Interface
IShapeSegment Members


ExtensionManagerException Class

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionManagerException Class
See Also Members
[image]
Telerik.Reporting.Interfaces Namespace : ExtensionManagerException Class

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Class ExtensionManagerException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As ExtensionManagerException
C#
public class ExtensionManagerException : ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Telerik.Reporting.Interfaces.ExtensionManagerException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionManagerException Members
Telerik.Reporting.Interfaces Namespace


ExtensionManagerException Class Members

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionManagerException Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Interfaces Namespace : ExtensionManagerException Class

The following tables list the members exposed by ExtensionManagerException.

Public Constructors

 | Name | Description
Public Constructor | ExtensionManagerException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ExtensionManagerException Class
Telerik.Reporting.Interfaces Namespace


ExtensionManagerException Constructor

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionManagerException Constructor
See Also
[image]
Telerik.Reporting.Interfaces Namespace > ExtensionManagerException Class : ExtensionManagerException Constructor

extensionTypeName
innerException

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal extensionTypeName As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim extensionTypeName As String
Dim innerException As Exception

Dim instance As ExtensionManagerException(extensionTypeName, innerException)
C#
public ExtensionManagerException(
   string extensionTypeName,
   Exception innerException
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal extensionTypeName As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim extensionTypeName As String
Dim innerException As Exception

Dim instance As ExtensionManagerException(extensionTypeName, innerException)
C#
public ExtensionManagerException(
   string extensionTypeName,
   Exception innerException
)

Parameters

extensionTypeName
innerException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionManagerException Class
ExtensionManagerException Members


ExtensionParameterException Class

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionParameterException Class
See Also Members
[image]
Telerik.Reporting.Interfaces Namespace : ExtensionParameterException Class

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Class ExtensionParameterException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As ExtensionParameterException
C#
public class ExtensionParameterException : ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Telerik.Reporting.Interfaces.ExtensionParameterException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionParameterException Members
Telerik.Reporting.Interfaces Namespace


ExtensionParameterException Class Members

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionParameterException Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Interfaces Namespace : ExtensionParameterException Class

The following tables list the members exposed by ExtensionParameterException.

Public Constructors

 | Name | Description
Public Constructor | ExtensionParameterException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ExtensionParameterException Class
Telerik.Reporting.Interfaces Namespace


ExtensionParameterException Constructor

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionParameterException Constructor
See Also
[image]
Telerik.Reporting.Interfaces Namespace > ExtensionParameterException Class : ExtensionParameterException Constructor

Overload List

Overload | Description
ExtensionParameterException Constructor(ExtensionParameterAttribute,Type) |
ExtensionParameterException Constructor(ExtensionParameterAttribute,Type,Exception) |

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionParameterException Class
ExtensionParameterException Members


ExtensionParameterException Constructor(ExtensionParameterAttribute,Type)

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionParameterException Constructor(ExtensionParameterAttribute,Type)
See Also
[image]
Telerik.Reporting.Interfaces Namespace > ExtensionParameterException Class > ExtensionParameterException Constructor : ExtensionParameterException Constructor(ExtensionParameterAttribute,Type)

parameter
extensionType

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameter As ExtensionParameterAttribute, _
   ByVal extensionType As Type _
)
Visual Basic (Usage) Copy Code
Dim parameter As ExtensionParameterAttribute
Dim extensionType As Type

Dim instance As ExtensionParameterException(parameter, extensionType)
C#
public ExtensionParameterException(
   ExtensionParameterAttribute parameter,
   Type extensionType
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameter As ExtensionParameterAttribute, _
   ByVal extensionType As Type _
)
Visual Basic (Usage) Copy Code
Dim parameter As ExtensionParameterAttribute
Dim extensionType As Type

Dim instance As ExtensionParameterException(parameter, extensionType)
C#
public ExtensionParameterException(
   ExtensionParameterAttribute parameter,
   Type extensionType
)

Parameters

parameter
extensionType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionParameterException Class
ExtensionParameterException Members
Overload List


ExtensionParameterException Constructor(ExtensionParameterAttribute,Type,Exception)

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionParameterException Constructor(ExtensionParameterAttribute,Type,Exception)
See Also
[image]
Telerik.Reporting.Interfaces Namespace > ExtensionParameterException Class > ExtensionParameterException Constructor : ExtensionParameterException Constructor(ExtensionParameterAttribute,Type,Exception)

parameter
extensionType
innerException

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameter As ExtensionParameterAttribute, _
   ByVal extensionType As Type, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim parameter As ExtensionParameterAttribute
Dim extensionType As Type
Dim innerException As Exception

Dim instance As ExtensionParameterException(parameter, extensionType, innerException)
C#
public ExtensionParameterException(
   ExtensionParameterAttribute parameter,
   Type extensionType,
   Exception innerException
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameter As ExtensionParameterAttribute, _
   ByVal extensionType As Type, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim parameter As ExtensionParameterAttribute
Dim extensionType As Type
Dim innerException As Exception

Dim instance As ExtensionParameterException(parameter, extensionType, innerException)
C#
public ExtensionParameterException(
   ExtensionParameterAttribute parameter,
   Type extensionType,
   Exception innerException
)

Parameters

parameter
extensionType
innerException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionParameterException Class
ExtensionParameterException Members
Overload List


IConverterLog Interface

Telerik.Reporting.Interfaces Send comments on this topic.
IConverterLog Interface
See Also Members
[image]
Telerik.Reporting.Interfaces Namespace : IConverterLog Interface

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Interface IConverterLog
Visual Basic (Usage) Copy Code
Dim instance As IConverterLog
C#
public interface IConverterLog

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IConverterLog Members
Telerik.Reporting.Interfaces Namespace


IConverterLog Interface Members

Telerik.Reporting.Interfaces Send comments on this topic.
IConverterLog Interface Members
See Also Methods
[image]
Telerik.Reporting.Interfaces Namespace : IConverterLog Interface

The following tables list the members exposed by IConverterLog.

Public Methods

 | Name | Description
Method | Log |
Method | LogError |
Method | LogWarning |
Top

See Also

Reference

IConverterLog Interface
Telerik.Reporting.Interfaces Namespace


IConverterLog Interface Methods

Telerik.Reporting.Interfaces Send comments on this topic.
IConverterLog Interface Methods
See Also
[image]
Telerik.Reporting.Interfaces Namespace : IConverterLog Interface

For a list of all members of this type, see IConverterLog members.

Public Methods

 | Name | Description
Method | Log |
Method | LogError |
Method | LogWarning |
Top

See Also

Reference

IConverterLog Interface
Telerik.Reporting.Interfaces Namespace


Log Method

Telerik.Reporting.Interfaces Send comments on this topic.
Log Method
See Also
[image]
Telerik.Reporting.Interfaces Namespace > IConverterLog Interface : Log Method

message

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Sub Log( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IConverterLog
Dim message As String

instance.Log(message)
C#
void Log(
   string message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IConverterLog Interface
IConverterLog Members


LogError Method

Telerik.Reporting.Interfaces Send comments on this topic.
LogError Method
See Also
[image]
Telerik.Reporting.Interfaces Namespace > IConverterLog Interface : LogError Method

message

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Sub LogError( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IConverterLog
Dim message As String

instance.LogError(message)
C#
void LogError(
   string message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IConverterLog Interface
IConverterLog Members


LogWarning Method

Telerik.Reporting.Interfaces Send comments on this topic.
LogWarning Method
See Also
[image]
Telerik.Reporting.Interfaces Namespace > IConverterLog Interface : LogWarning Method

message

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Sub LogWarning( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IConverterLog
Dim message As String

instance.LogWarning(message)
C#
void LogWarning(
   string message
)

Parameters

message

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IConverterLog Interface
IConverterLog Members


IReportConverter Interface

Telerik.Reporting.Interfaces Send comments on this topic.
IReportConverter Interface
See Also Members
[image]
Telerik.Reporting.Interfaces Namespace : IReportConverter Interface

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Interface IReportConverter
   Inherits IExtension
Visual Basic (Usage) Copy Code
Dim instance As IReportConverter
C#
public interface IReportConverter : IExtension

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportConverter Members
Telerik.Reporting.Interfaces Namespace


IReportConverter Interface Members

Telerik.Reporting.Interfaces Send comments on this topic.
IReportConverter Interface Members
See Also Methods
[image]
Telerik.Reporting.Interfaces Namespace : IReportConverter Interface

The following tables list the members exposed by IReportConverter.

Public Methods

 | Name | Description
Method | BrowseForSource |
Method | Convert |
Top

See Also

Reference

IReportConverter Interface
Telerik.Reporting.Interfaces Namespace


IReportConverter Interface Methods

Telerik.Reporting.Interfaces Send comments on this topic.
IReportConverter Interface Methods
See Also
[image]
Telerik.Reporting.Interfaces Namespace : IReportConverter Interface

For a list of all members of this type, see IReportConverter members.

Public Methods

 | Name | Description
Method | BrowseForSource |
Method | Convert |
Top

See Also

Reference

IReportConverter Interface
Telerik.Reporting.Interfaces Namespace


BrowseForSource Method

Telerik.Reporting.Interfaces Send comments on this topic.
BrowseForSource Method
See Also
[image]
Telerik.Reporting.Interfaces Namespace > IReportConverter Interface : BrowseForSource Method

serviceProvider

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function BrowseForSource( _
   ByVal serviceProvider As IServiceProvider _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IReportConverter
Dim serviceProvider As IServiceProvider
Dim value As Object

value = instance.BrowseForSource(serviceProvider)
C#
object BrowseForSource(
   IServiceProvider serviceProvider
)

Parameters

serviceProvider

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportConverter Interface
IReportConverter Members


Convert Method

Telerik.Reporting.Interfaces Send comments on this topic.
Convert Method
See Also
[image]
Telerik.Reporting.Interfaces Namespace > IReportConverter Interface : Convert Method

source
serviceProvider
log
context
Reserved for future use

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Sub Convert( _
   ByVal source As Object, _
   ByVal serviceProvider As IServiceProvider, _
   ByVal log As IConverterLog, _
   ByVal context As Hashtable _
)
Visual Basic (Usage) Copy Code
Dim instance As IReportConverter
Dim source As Object
Dim serviceProvider As IServiceProvider
Dim log As IConverterLog
Dim context As Hashtable

instance.Convert(source, serviceProvider, log, context)
C#
void Convert(
   object source,
   IServiceProvider serviceProvider,
   IConverterLog log,
   Hashtable context
)

Parameters

source
serviceProvider
log
context
Reserved for future use

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportConverter Interface
IReportConverter Members


ExtensionAttribute Class

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionAttribute Class
See Also Members
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionAttribute Class

The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ExtensionAttribute
   Inherits Attribute
Visual Basic (Usage) Copy Code
Dim instance As ExtensionAttribute
C#
public abstract class ExtensionAttribute : Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Telerik.Reporting.Interfaces.Attributes.ExtensionAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionDescriptionAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionLocalizedDescriptionAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionNameAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionParameterAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionVisibleAttribute

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionAttribute Members
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionAttribute Class Members

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionAttribute Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionAttribute Class

The following tables list the members exposed by ExtensionAttribute.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Apply |
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionAttribute Class Methods

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionAttribute Class Methods
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionAttribute Class

For a list of all members of this type, see ExtensionAttribute members.

Public Methods

 | Name | Description
Public Method | Apply |
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Apply Method

Telerik.Reporting.Interfaces Send comments on this topic.
Apply Method
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionAttribute Class : Apply Method

extInfo

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Apply( _
   ByVal extInfo As ExtensionInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionAttribute
Dim extInfo As ExtensionInfo

instance.Apply(extInfo)
C#
public abstract void Apply(
   ExtensionInfo extInfo
)

Parameters

extInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionAttribute Class
ExtensionAttribute Members


ExtensionDescriptionAttribute Class

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionDescriptionAttribute Class
See Also Members
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionDescriptionAttribute Class

The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Class ExtensionDescriptionAttribute
   Inherits ExtensionAttribute
Visual Basic (Usage) Copy Code
Dim instance As ExtensionDescriptionAttribute
C#
public class ExtensionDescriptionAttribute : ExtensionAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Telerik.Reporting.Interfaces.Attributes.ExtensionAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionDescriptionAttribute

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionDescriptionAttribute Members
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionDescriptionAttribute Class Members

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionDescriptionAttribute Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionDescriptionAttribute Class

The following tables list the members exposed by ExtensionDescriptionAttribute.

Public Constructors

 | Name | Description
Public Constructor | ExtensionDescriptionAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | Description |
Public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Apply | Overridden.
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionDescriptionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionDescriptionAttribute Constructor

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionDescriptionAttribute Constructor
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionDescriptionAttribute Class : ExtensionDescriptionAttribute Constructor

description

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal description As String _
)
Visual Basic (Usage) Copy Code
Dim description As String

Dim instance As ExtensionDescriptionAttribute(description)
C#
public ExtensionDescriptionAttribute(
   string description
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal description As String _
)
Visual Basic (Usage) Copy Code
Dim description As String

Dim instance As ExtensionDescriptionAttribute(description)
C#
public ExtensionDescriptionAttribute(
   string description
)

Parameters

description

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionDescriptionAttribute Class
ExtensionDescriptionAttribute Members


ExtensionDescriptionAttribute Class Methods

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionDescriptionAttribute Class Methods
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionDescriptionAttribute Class

For a list of all members of this type, see ExtensionDescriptionAttribute members.

Public Methods

 | Name | Description
Public Method | Apply | Overridden.
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionDescriptionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Apply Method

Telerik.Reporting.Interfaces Send comments on this topic.
Apply Method
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionDescriptionAttribute Class : Apply Method

extInfo

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Apply( _
   ByVal extInfo As ExtensionInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionDescriptionAttribute
Dim extInfo As ExtensionInfo

instance.Apply(extInfo)
C#
public override void Apply(
   ExtensionInfo extInfo
)

Parameters

extInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionDescriptionAttribute Class
ExtensionDescriptionAttribute Members


ExtensionDescriptionAttribute Class Properties

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionDescriptionAttribute Class Properties
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionDescriptionAttribute Class

For a list of all members of this type, see ExtensionDescriptionAttribute members.

Public Properties

 | Name | Description
Public Property | Description |
Public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionDescriptionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Description Property

Telerik.Reporting.Interfaces Send comments on this topic.
Description Property
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionDescriptionAttribute Class : Description Property

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionDescriptionAttribute
Dim value As String

value = instance.Description
C#
public string Description {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionDescriptionAttribute Class
ExtensionDescriptionAttribute Members


ExtensionLocalizedDescriptionAttribute Class

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionLocalizedDescriptionAttribute Class
See Also Members
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionLocalizedDescriptionAttribute Class

The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Class ExtensionLocalizedDescriptionAttribute
   Inherits ExtensionAttribute
Visual Basic (Usage) Copy Code
Dim instance As ExtensionLocalizedDescriptionAttribute
C#
public class ExtensionLocalizedDescriptionAttribute : ExtensionAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Telerik.Reporting.Interfaces.Attributes.ExtensionAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionLocalizedDescriptionAttribute

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionLocalizedDescriptionAttribute Members
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionLocalizedDescriptionAttribute Class Members

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionLocalizedDescriptionAttribute Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionLocalizedDescriptionAttribute Class

The following tables list the members exposed by ExtensionLocalizedDescriptionAttribute.

Public Constructors

 | Name | Description
Public Constructor | ExtensionLocalizedDescriptionAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | Description |
Public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Apply | Overridden.
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionLocalizedDescriptionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionLocalizedDescriptionAttribute Constructor

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionLocalizedDescriptionAttribute Constructor
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionLocalizedDescriptionAttribute Class : ExtensionLocalizedDescriptionAttribute Constructor

description

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal description As String _
)
Visual Basic (Usage) Copy Code
Dim description As String

Dim instance As ExtensionLocalizedDescriptionAttribute(description)
C#
public ExtensionLocalizedDescriptionAttribute(
   string description
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal description As String _
)
Visual Basic (Usage) Copy Code
Dim description As String

Dim instance As ExtensionLocalizedDescriptionAttribute(description)
C#
public ExtensionLocalizedDescriptionAttribute(
   string description
)

Parameters

description

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionLocalizedDescriptionAttribute Class
ExtensionLocalizedDescriptionAttribute Members


ExtensionLocalizedDescriptionAttribute Class Methods

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionLocalizedDescriptionAttribute Class Methods
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionLocalizedDescriptionAttribute Class

For a list of all members of this type, see ExtensionLocalizedDescriptionAttribute members.

Public Methods

 | Name | Description
Public Method | Apply | Overridden.
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionLocalizedDescriptionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Apply Method

Telerik.Reporting.Interfaces Send comments on this topic.
Apply Method
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionLocalizedDescriptionAttribute Class : Apply Method

extInfo

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Apply( _
   ByVal extInfo As ExtensionInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionLocalizedDescriptionAttribute
Dim extInfo As ExtensionInfo

instance.Apply(extInfo)
C#
public override void Apply(
   ExtensionInfo extInfo
)

Parameters

extInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionLocalizedDescriptionAttribute Class
ExtensionLocalizedDescriptionAttribute Members


ExtensionLocalizedDescriptionAttribute Class Properties

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionLocalizedDescriptionAttribute Class Properties
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionLocalizedDescriptionAttribute Class

For a list of all members of this type, see ExtensionLocalizedDescriptionAttribute members.

Public Properties

 | Name | Description
Public Property | Description |
Public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionLocalizedDescriptionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Description Property

Telerik.Reporting.Interfaces Send comments on this topic.
Description Property
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionLocalizedDescriptionAttribute Class : Description Property

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionLocalizedDescriptionAttribute
Dim value As String

value = instance.Description
C#
public string Description {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionLocalizedDescriptionAttribute Class
ExtensionLocalizedDescriptionAttribute Members


ExtensionNameAttribute Class

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionNameAttribute Class
See Also Members
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionNameAttribute Class

The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Class ExtensionNameAttribute
   Inherits ExtensionAttribute
Visual Basic (Usage) Copy Code
Dim instance As ExtensionNameAttribute
C#
public class ExtensionNameAttribute : ExtensionAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Telerik.Reporting.Interfaces.Attributes.ExtensionAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionNameAttribute

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionNameAttribute Members
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionNameAttribute Class Members

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionNameAttribute Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionNameAttribute Class

The following tables list the members exposed by ExtensionNameAttribute.

Public Constructors

 | Name | Description
Public Constructor | ExtensionNameAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | Name |
Public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Apply | Overridden.
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionNameAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionNameAttribute Constructor

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionNameAttribute Constructor
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionNameAttribute Class : ExtensionNameAttribute Constructor

name

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As ExtensionNameAttribute(name)
C#
public ExtensionNameAttribute(
   string name
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As ExtensionNameAttribute(name)
C#
public ExtensionNameAttribute(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionNameAttribute Class
ExtensionNameAttribute Members


ExtensionNameAttribute Class Methods

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionNameAttribute Class Methods
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionNameAttribute Class

For a list of all members of this type, see ExtensionNameAttribute members.

Public Methods

 | Name | Description
Public Method | Apply | Overridden.
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionNameAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Apply Method

Telerik.Reporting.Interfaces Send comments on this topic.
Apply Method
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionNameAttribute Class : Apply Method

extInfo

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Apply( _
   ByVal extInfo As ExtensionInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionNameAttribute
Dim extInfo As ExtensionInfo

instance.Apply(extInfo)
C#
public override void Apply(
   ExtensionInfo extInfo
)

Parameters

extInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionNameAttribute Class
ExtensionNameAttribute Members


ExtensionNameAttribute Class Properties

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionNameAttribute Class Properties
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionNameAttribute Class

For a list of all members of this type, see ExtensionNameAttribute members.

Public Properties

 | Name | Description
Public Property | Name |
Public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionNameAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Name Property

Telerik.Reporting.Interfaces Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionNameAttribute Class : Name Property

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionNameAttribute
Dim value As String

value = instance.Name
C#
public string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionNameAttribute Class
ExtensionNameAttribute Members


ExtensionParameterAttribute Class

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionParameterAttribute Class
See Also Members
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionParameterAttribute Class

The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Class ExtensionParameterAttribute
   Inherits ExtensionAttribute
Visual Basic (Usage) Copy Code
Dim instance As ExtensionParameterAttribute
C#
public class ExtensionParameterAttribute : ExtensionAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Telerik.Reporting.Interfaces.Attributes.ExtensionAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionParameterAttribute

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionParameterAttribute Members
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionParameterAttribute Class Members

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionParameterAttribute Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionParameterAttribute Class

The following tables list the members exposed by ExtensionParameterAttribute.

Public Constructors

 | Name | Description
Public Constructor | ExtensionParameterAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | DefaultValue |
Public Property | Name |
Public Property | ParamType |
Public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Apply | Overridden.
static (Shared in Visual Basic) | ApplyValues |
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionParameterAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionParameterAttribute Constructor

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionParameterAttribute Constructor
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionParameterAttribute Class : ExtensionParameterAttribute Constructor

name
paramType
defaultValue

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal paramType As Type, _
   ByVal defaultValue As Object _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim paramType As Type
Dim defaultValue As Object

Dim instance As ExtensionParameterAttribute(name, paramType, defaultValue)
C#
public ExtensionParameterAttribute(
   string name,
   Type paramType,
   object defaultValue
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal paramType As Type, _
   ByVal defaultValue As Object _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim paramType As Type
Dim defaultValue As Object

Dim instance As ExtensionParameterAttribute(name, paramType, defaultValue)
C#
public ExtensionParameterAttribute(
   string name,
   Type paramType,
   object defaultValue
)

Parameters

name
paramType
defaultValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionParameterAttribute Class
ExtensionParameterAttribute Members


ExtensionParameterAttribute Class Methods

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionParameterAttribute Class Methods
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionParameterAttribute Class

For a list of all members of this type, see ExtensionParameterAttribute members.

Public Methods

 | Name | Description
Public Method | Apply | Overridden.
static (Shared in Visual Basic) | ApplyValues |
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionParameterAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Apply Method

Telerik.Reporting.Interfaces Send comments on this topic.
Apply Method
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionParameterAttribute Class : Apply Method

extInfo

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Apply( _
   ByVal extInfo As ExtensionInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionParameterAttribute
Dim extInfo As ExtensionInfo

instance.Apply(extInfo)
C#
public override void Apply(
   ExtensionInfo extInfo
)

Parameters

extInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionParameterAttribute Class
ExtensionParameterAttribute Members


ApplyValues Method

Telerik.Reporting.Interfaces Send comments on this topic.
ApplyValues Method
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionParameterAttribute Class : ApplyValues Method

extInfo
values

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ApplyValues( _
   ByVal extInfo As ExtensionInfo, _
   ByVal values As Dictionary(Of String, String) _
)
Visual Basic (Usage) Copy Code
Dim extInfo As ExtensionInfo
Dim values As Dictionary(Of String, String)

ExtensionParameterAttribute.ApplyValues(extInfo, values)
C#
public static void ApplyValues(
   ExtensionInfo extInfo,
   Dictionary<string, string> values
)

Parameters

extInfo
values

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionParameterAttribute Class
ExtensionParameterAttribute Members


ExtensionParameterAttribute Class Properties

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionParameterAttribute Class Properties
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionParameterAttribute Class

For a list of all members of this type, see ExtensionParameterAttribute members.

Public Properties

 | Name | Description
Public Property | DefaultValue |
Public Property | Name |
Public Property | ParamType |
Public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionParameterAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


DefaultValue Property

Telerik.Reporting.Interfaces Send comments on this topic.
DefaultValue Property
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionParameterAttribute Class : DefaultValue Property

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultValue As Object
Visual Basic (Usage) Copy Code
Dim instance As ExtensionParameterAttribute
Dim value As Object

value = instance.DefaultValue
C#
public object DefaultValue {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionParameterAttribute Class
ExtensionParameterAttribute Members


Name Property

Telerik.Reporting.Interfaces Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionParameterAttribute Class : Name Property

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionParameterAttribute
Dim value As String

value = instance.Name
C#
public string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionParameterAttribute Class
ExtensionParameterAttribute Members


ParamType Property

Telerik.Reporting.Interfaces Send comments on this topic.
ParamType Property
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionParameterAttribute Class : ParamType Property

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParamType As Type
Visual Basic (Usage) Copy Code
Dim instance As ExtensionParameterAttribute
Dim value As Type

value = instance.ParamType
C#
public Type ParamType {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionParameterAttribute Class
ExtensionParameterAttribute Members


ExtensionVisibleAttribute Class

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionVisibleAttribute Class
See Also Members
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionVisibleAttribute Class

The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Class ExtensionVisibleAttribute
   Inherits ExtensionAttribute
Visual Basic (Usage) Copy Code
Dim instance As ExtensionVisibleAttribute
C#
public class ExtensionVisibleAttribute : ExtensionAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Telerik.Reporting.Interfaces.Attributes.ExtensionAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionVisibleAttribute

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionVisibleAttribute Members
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionVisibleAttribute Class Members

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionVisibleAttribute Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionVisibleAttribute Class

The following tables list the members exposed by ExtensionVisibleAttribute.

Public Constructors

 | Name | Description
Public Constructor | ExtensionVisibleAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Public Property | Visible |
Top

Public Methods

 | Name | Description
Public Method | Apply | Overridden.
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionVisibleAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionVisibleAttribute Constructor

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionVisibleAttribute Constructor
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionVisibleAttribute Class : ExtensionVisibleAttribute Constructor

visible

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim visible As Boolean

Dim instance As ExtensionVisibleAttribute(visible)
C#
public ExtensionVisibleAttribute(
   bool visible
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim visible As Boolean

Dim instance As ExtensionVisibleAttribute(visible)
C#
public ExtensionVisibleAttribute(
   bool visible
)

Parameters

visible

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionVisibleAttribute Class
ExtensionVisibleAttribute Members


ExtensionVisibleAttribute Class Methods

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionVisibleAttribute Class Methods
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionVisibleAttribute Class

For a list of all members of this type, see ExtensionVisibleAttribute members.

Public Methods

 | Name | Description
Public Method | Apply | Overridden.
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionVisibleAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Apply Method

Telerik.Reporting.Interfaces Send comments on this topic.
Apply Method
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionVisibleAttribute Class : Apply Method

extInfo

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Apply( _
   ByVal extInfo As ExtensionInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionVisibleAttribute
Dim extInfo As ExtensionInfo

instance.Apply(extInfo)
C#
public override void Apply(
   ExtensionInfo extInfo
)

Parameters

extInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionVisibleAttribute Class
ExtensionVisibleAttribute Members


ExtensionVisibleAttribute Class Properties

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionVisibleAttribute Class Properties
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionVisibleAttribute Class

For a list of all members of this type, see ExtensionVisibleAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Public Property | Visible |
Top

See Also

Reference

ExtensionVisibleAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Visible Property

Telerik.Reporting.Interfaces Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace > ExtensionVisibleAttribute Class : Visible Property

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionVisibleAttribute
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionVisibleAttribute Class
ExtensionVisibleAttribute Members


Barcode Class

Telerik.Reporting.Processing Send comments on this topic.
Barcode Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : Barcode Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class Barcode
   Inherits ReportItem
   Implements ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As Barcode
C#
public class Barcode : ReportItem, ILayoutItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportItem
Telerik.Reporting.Processing.Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Members
Telerik.Reporting.Processing Namespace


Barcode Class Members

Telerik.Reporting.Processing Send comments on this topic.
Barcode Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : Barcode Class

The following tables list the members exposed by Barcode.

Public Constructors

 | Name | Description
Public Constructor | Barcode Constructor |
Top

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Angle |
Public Property | BarAlign |
Public Property | Bounds | (Inherited from ReportItem)
Public Property | Checksum |
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Height | (Inherited from ReportItem)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Module |
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | ShowText |
Public Property | Size | (Inherited from ReportItem)
Public Property | Stretch |
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Value |
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

Barcode Class
Telerik.Reporting.Processing Namespace


Barcode Constructor

Telerik.Reporting.Processing Send comments on this topic.
Barcode Constructor
See Also
[image]
Telerik.Reporting.Processing Namespace > Barcode Class : Barcode Constructor

source

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim source As ReportItemBase

Dim instance As Barcode(source)
C#
public Barcode(
   ReportItemBase source
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim source As ReportItemBase

Dim instance As Barcode(source)
C#
public Barcode(
   ReportItemBase source
)

Parameters

source

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Barcode Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Barcode Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

Barcode Class
Telerik.Reporting.Processing Namespace


ProcessItem Method

Telerik.Reporting.Processing Send comments on this topic.
ProcessItem Method
See Also
[image]
Telerik.Reporting.Processing Namespace > Barcode Class : ProcessItem Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ProcessItem()
Visual Basic (Usage) Copy Code
Dim instance As Barcode

instance.ProcessItem()
C#
protected override void ProcessItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Barcode Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Barcode Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Angle |
Public Property | BarAlign |
Public Property | Bounds | (Inherited from ReportItem)
Public Property | Checksum |
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Height | (Inherited from ReportItem)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Module |
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | ShowText |
Public Property | Size | (Inherited from ReportItem)
Public Property | Stretch |
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Value |
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

See Also

Reference

Barcode Class
Telerik.Reporting.Processing Namespace


Angle Property

Telerik.Reporting.Processing Send comments on this topic.
Angle Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Barcode Class : Angle Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Angle As Double
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Double

instance.Angle = value

value = instance.Angle
C#
public double Angle {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


BarAlign Property

Telerik.Reporting.Processing Send comments on this topic.
BarAlign Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Barcode Class : BarAlign Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property BarAlign As HorizontalAlign
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As HorizontalAlign

instance.BarAlign = value

value = instance.BarAlign
C#
public HorizontalAlign BarAlign {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Checksum Property

Telerik.Reporting.Processing Send comments on this topic.
Checksum Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Barcode Class : Checksum Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Checksum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Boolean

instance.Checksum = value

value = instance.Checksum
C#
public bool Checksum {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Module Property

Telerik.Reporting.Processing Send comments on this topic.
Module Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Barcode Class : Module Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Module As Unit
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Unit

instance.Module = value

value = instance.Module
C#
public Unit Module {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


ShowText Property

Telerik.Reporting.Processing Send comments on this topic.
ShowText Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Barcode Class : ShowText Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowText As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Boolean

instance.ShowText = value

value = instance.ShowText
C#
public bool ShowText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Stretch Property

Telerik.Reporting.Processing Send comments on this topic.
Stretch Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Barcode Class : Stretch Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Stretch As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Boolean

instance.Stretch = value

value = instance.Stretch
C#
public bool Stretch {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Value Property

Telerik.Reporting.Processing Send comments on this topic.
Value Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Barcode Class : Value Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Object

instance.Value = value

value = instance.Value
C#
public object Value {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


BarcodeHelper Class

Telerik.Reporting.Processing Send comments on this topic.
BarcodeHelper Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : BarcodeHelper Class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private MustInherit NotInheritable Class BarcodeHelper
Visual Basic (Usage) Copy Code
Dim instance As BarcodeHelper
C#
private static class BarcodeHelper

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.BarcodeHelper

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeHelper Members
Telerik.Reporting.Processing Namespace


BarcodeHelper Class Members

Telerik.Reporting.Processing Send comments on this topic.
BarcodeHelper Class Members
See Also
[image]
Telerik.Reporting.Processing Namespace : BarcodeHelper Class

The following tables list the members exposed by BarcodeHelper.

See Also

Reference

BarcodeHelper Class
Telerik.Reporting.Processing Namespace


Chart Class

Telerik.Reporting.Processing Send comments on this topic.
Chart Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : Chart Class

Summary description for ReportItem class.

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class Chart
   Inherits ReportItem
   Implements ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As Chart
C#
public class Chart : ReportItem, ILayoutItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportItem
Telerik.Reporting.Processing.Chart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Members
Telerik.Reporting.Processing Namespace


Chart Class Members

Telerik.Reporting.Processing Send comments on this topic.
Chart Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : Chart Class

The following tables list the members exposed by Chart.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | DataSource |
Public Property | Dock | (Inherited from ReportItem)
Public Property | Height | (Inherited from ReportItem)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded.
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

Chart Class
Telerik.Reporting.Processing Namespace


Chart Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Chart Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded.
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

Chart Class
Telerik.Reporting.Processing Namespace


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.Processing Namespace > Chart Class : Dispose Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
Dispose(Boolean) |
Dispose() | (Inherited from ReportItemBase)

Overload List

Overload | Description
Dispose(Boolean) |
Dispose() | (Inherited from ReportItemBase)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Dispose(Boolean) Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose(Boolean) Method
See Also
[image]
Telerik.Reporting.Processing Namespace > Chart Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members
Overload List


ProcessItem Method

Telerik.Reporting.Processing Send comments on this topic.
ProcessItem Method
See Also
[image]
Telerik.Reporting.Processing Namespace > Chart Class : ProcessItem Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ProcessItem()
Visual Basic (Usage) Copy Code
Dim instance As Chart

instance.ProcessItem()
C#
protected override void ProcessItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Chart Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Chart Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | DataSource |
Public Property | Dock | (Inherited from ReportItem)
Public Property | Height | (Inherited from ReportItem)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

See Also

Reference

Chart Class
Telerik.Reporting.Processing Namespace


DataSource Property

Telerik.Reporting.Processing Send comments on this topic.
DataSource Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Chart Class : DataSource Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
public object DataSource {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


CheckBox Class

Telerik.Reporting.Processing Send comments on this topic.
CheckBox Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : CheckBox Class

CheckBox

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class CheckBox
   Inherits TextItemBase
   Implements ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
C#
public class CheckBox : TextItemBase, ILayoutItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportItem
Telerik.Reporting.Processing.TextItemBase
Telerik.Reporting.Processing.CheckBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Members
Telerik.Reporting.Processing Namespace


CheckBox Class Members

Telerik.Reporting.Processing Send comments on this topic.
CheckBox Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : CheckBox Class

The following tables list the members exposed by CheckBox.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | CheckAlign |
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | FalseValue |
Public Property | Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase)
Public Property | Height | (Inherited from ReportItem)
Public Property | IndeterminateValue |
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Text |
Public Property | Top | (Inherited from ReportItem)
Public Property | TrueValue |
Public Property | Value |
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

CheckBox Class
Telerik.Reporting.Processing Namespace


CheckBox Class Methods

Telerik.Reporting.Processing Send comments on this topic.
CheckBox Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

CheckBox Class
Telerik.Reporting.Processing Namespace


ProcessItem Method

Telerik.Reporting.Processing Send comments on this topic.
ProcessItem Method
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBox Class : ProcessItem Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ProcessItem()
Visual Basic (Usage) Copy Code
Dim instance As CheckBox

instance.ProcessItem()
C#
protected override void ProcessItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBox Class : ToString Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Class Properties

Telerik.Reporting.Processing Send comments on this topic.
CheckBox Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | CheckAlign |
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | FalseValue |
Public Property | Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase)
Public Property | Height | (Inherited from ReportItem)
Public Property | IndeterminateValue |
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Text |
Public Property | Top | (Inherited from ReportItem)
Public Property | TrueValue |
Public Property | Value |
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

See Also

Reference

CheckBox Class
Telerik.Reporting.Processing Namespace


CheckAlign Property

Telerik.Reporting.Processing Send comments on this topic.
CheckAlign Property
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBox Class : CheckAlign Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property CheckAlign As ContentAlignment
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As ContentAlignment

instance.CheckAlign = value

value = instance.CheckAlign
C#
public ContentAlignment CheckAlign {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


FalseValue Property

Telerik.Reporting.Processing Send comments on this topic.
FalseValue Property
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBox Class : FalseValue Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property FalseValue As Object
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Object

instance.FalseValue = value

value = instance.FalseValue
C#
public object FalseValue {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


IndeterminateValue Property

Telerik.Reporting.Processing Send comments on this topic.
IndeterminateValue Property
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBox Class : IndeterminateValue Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property IndeterminateValue As Object
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Object

instance.IndeterminateValue = value

value = instance.IndeterminateValue
C#
public object IndeterminateValue {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Text Property

Telerik.Reporting.Processing Send comments on this topic.
Text Property
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBox Class : Text Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


TrueValue Property

Telerik.Reporting.Processing Send comments on this topic.
TrueValue Property
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBox Class : TrueValue Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property TrueValue As Object
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Object

instance.TrueValue = value

value = instance.TrueValue
C#
public object TrueValue {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Value Property

Telerik.Reporting.Processing Send comments on this topic.
Value Property
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBox Class : Value Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As CheckState
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As CheckState

instance.Value = value

value = instance.Value
C#
public CheckState Value {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckBoxUtil Class

Telerik.Reporting.Processing Send comments on this topic.
CheckBoxUtil Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : CheckBoxUtil Class

CheckBoxUtil

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class CheckBoxUtil
Visual Basic (Usage) Copy Code
Dim instance As CheckBoxUtil
C#
private class CheckBoxUtil

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.CheckBoxUtil

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBoxUtil Members
Telerik.Reporting.Processing Namespace


CheckBoxUtil Class Members

Telerik.Reporting.Processing Send comments on this topic.
CheckBoxUtil Class Members
See Also Methods
[image]
Telerik.Reporting.Processing Namespace : CheckBoxUtil Class

The following tables list the members exposed by CheckBoxUtil.

Public Constructors

 | Name | Description
Public Constructor | CheckBoxUtil Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateDefaultImage | Returns one of the three default images based on the passed value.
static (Shared in Visual Basic) | GetCheckHorizontalAlignment |
static (Shared in Visual Basic) | GetCheckMarkObject | Returns one of the three image objects from the definition item based on the current Value. The object can be Image, string, byte[], etc.
static (Shared in Visual Basic) | GetCheckState |
static (Shared in Visual Basic) | GetCheckVerticalAlignment |
Top

See Also

Reference

CheckBoxUtil Class
Telerik.Reporting.Processing Namespace


CheckBoxUtil Constructor

Telerik.Reporting.Processing Send comments on this topic.
CheckBoxUtil Constructor
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBoxUtil Class : CheckBoxUtil Constructor

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CheckBoxUtil()
C#
public CheckBoxUtil()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CheckBoxUtil()
C#
public CheckBoxUtil()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBoxUtil Class
CheckBoxUtil Members


CheckBoxUtil Class Methods

Telerik.Reporting.Processing Send comments on this topic.
CheckBoxUtil Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : CheckBoxUtil Class

For a list of all members of this type, see CheckBoxUtil members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateDefaultImage | Returns one of the three default images based on the passed value.
static (Shared in Visual Basic) | GetCheckHorizontalAlignment |
static (Shared in Visual Basic) | GetCheckMarkObject | Returns one of the three image objects from the definition item based on the current Value. The object can be Image, string, byte[], etc.
static (Shared in Visual Basic) | GetCheckState |
static (Shared in Visual Basic) | GetCheckVerticalAlignment |
Top

See Also

Reference

CheckBoxUtil Class
Telerik.Reporting.Processing Namespace


CreateDefaultImage Method

Telerik.Reporting.Processing Send comments on this topic.
CreateDefaultImage Method
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBoxUtil Class : CreateDefaultImage Method

checkState
Returns one of the three default images based on the passed value.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateDefaultImage( _
   ByVal checkState As CheckState _
) As Image
Visual Basic (Usage) Copy Code
Dim checkState As CheckState
Dim value As Image

value = CheckBoxUtil.CreateDefaultImage(checkState)
C#
public static Image CreateDefaultImage(
   CheckState checkState
)

Parameters

checkState

Return Value

One of the three default images based on the current Value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBoxUtil Class
CheckBoxUtil Members


GetCheckHorizontalAlignment Method

Telerik.Reporting.Processing Send comments on this topic.
GetCheckHorizontalAlignment Method
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBoxUtil Class : GetCheckHorizontalAlignment Method

checkAlign

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetCheckHorizontalAlignment( _
   ByVal checkAlign As ContentAlignment _
) As StringAlignment
Visual Basic (Usage) Copy Code
Dim checkAlign As ContentAlignment
Dim value As StringAlignment

value = CheckBoxUtil.GetCheckHorizontalAlignment(checkAlign)
C#
public static StringAlignment GetCheckHorizontalAlignment(
   ContentAlignment checkAlign
)

Parameters

checkAlign

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBoxUtil Class
CheckBoxUtil Members


GetCheckMarkObject Method

Telerik.Reporting.Processing Send comments on this topic.
GetCheckMarkObject Method
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBoxUtil Class : GetCheckMarkObject Method

checkBoxDefinition
state
Returns one of the three image objects from the definition item based on the current Value. The object can be Image, string, byte[], etc.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetCheckMarkObject( _
   ByVal checkBoxDefinition As CheckBox, _
   ByVal state As CheckState _
) As Object
Visual Basic (Usage) Copy Code
Dim checkBoxDefinition As CheckBox
Dim state As CheckState
Dim value As Object

value = CheckBoxUtil.GetCheckMarkObject(checkBoxDefinition, state)
C#
public static object GetCheckMarkObject(
   CheckBox checkBoxDefinition,
   CheckState state
)

Parameters

checkBoxDefinition
state

Return Value

One of the three image objects from the definition item based on the current Value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBoxUtil Class
CheckBoxUtil Members


GetCheckState Method

Telerik.Reporting.Processing Send comments on this topic.
GetCheckState Method
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBoxUtil Class : GetCheckState Method

value
falseValue
trueValue
indeterminateValue

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetCheckState( _
   ByVal value As Object, _
   ByVal falseValue As Object, _
   ByVal trueValue As Object, _
   ByVal indeterminateValue As Object _
) As CheckState
Visual Basic (Usage) Copy Code
Dim value As Object
Dim falseValue As Object
Dim trueValue As Object
Dim indeterminateValue As Object
Dim value As CheckState

value = CheckBoxUtil.GetCheckState(value, falseValue, trueValue, indeterminateValue)
C#
public static CheckState GetCheckState(
   object value,
   object falseValue,
   object trueValue,
   object indeterminateValue
)

Parameters

value
falseValue
trueValue
indeterminateValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBoxUtil Class
CheckBoxUtil Members


GetCheckVerticalAlignment Method

Telerik.Reporting.Processing Send comments on this topic.
GetCheckVerticalAlignment Method
See Also
[image]
Telerik.Reporting.Processing Namespace > CheckBoxUtil Class : GetCheckVerticalAlignment Method

checkAlign

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetCheckVerticalAlignment( _
   ByVal checkAlign As ContentAlignment _
) As StringAlignment
Visual Basic (Usage) Copy Code
Dim checkAlign As ContentAlignment
Dim value As StringAlignment

value = CheckBoxUtil.GetCheckVerticalAlignment(checkAlign)
C#
public static StringAlignment GetCheckVerticalAlignment(
   ContentAlignment checkAlign
)

Parameters

checkAlign

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBoxUtil Class
CheckBoxUtil Members


DetailSection Class

Telerik.Reporting.Processing Send comments on this topic.
DetailSection Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : DetailSection Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class DetailSection
   Inherits ReportSection
   Implements ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
C#
public class DetailSection : ReportSection, ILayoutContainer

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportSectionBase
Telerik.Reporting.Processing.ReportSection
Telerik.Reporting.Processing.DetailSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Members
Telerik.Reporting.Processing Namespace


DetailSection Class Members

Telerik.Reporting.Processing Send comments on this topic.
DetailSection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : DetailSection Class

The following tables list the members exposed by DetailSection.

Public Properties

 | Name | Description
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Height | (Inherited from ReportSectionBase)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | KeepTogether | (Inherited from ReportSection)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | PageBreak | (Inherited from ReportSection)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportSectionBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItemBase)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

DetailSection Class
Telerik.Reporting.Processing Namespace


Group Class

Telerik.Reporting.Processing Send comments on this topic.
Group Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : Group Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class Group
   Inherits ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As Group
C#
public class Group : ProcessingElement

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.Group

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Members
Telerik.Reporting.Processing Namespace


Group Class Members

Telerik.Reporting.Processing Send comments on this topic.
Group Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : Group Class

The following tables list the members exposed by Group.

Public Constructors

 | Name | Description
Public Constructor | Group Constructor |
Top

Public Properties

 | Name | Description
Public Property | GroupFooter |
Public Property | GroupHeader |
Public Property | GroupKeepTogether |
Public Property | Name | (Inherited from ProcessingElement)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Dispose | (Inherited from ProcessingElement)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Top

See Also

Reference

Group Class
Telerik.Reporting.Processing Namespace


Group Constructor

Telerik.Reporting.Processing Send comments on this topic.
Group Constructor
See Also
[image]
Telerik.Reporting.Processing Namespace > Group Class : Group Constructor

groupDef

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal groupDef As Group _
)
Visual Basic (Usage) Copy Code
Dim groupDef As Group

Dim instance As Group(groupDef)
C#
public Group(
   Group groupDef
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal groupDef As Group _
)
Visual Basic (Usage) Copy Code
Dim groupDef As Group

Dim instance As Group(groupDef)
C#
public Group(
   Group groupDef
)

Parameters

groupDef

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Group Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Group Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : Group Class

For a list of all members of this type, see Group members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Dispose | (Inherited from ProcessingElement)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Top

See Also

Reference

Group Class
Telerik.Reporting.Processing Namespace


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.Processing Namespace > Group Class : ToString Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Group Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Group Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : Group Class

For a list of all members of this type, see Group members.

Public Properties

 | Name | Description
Public Property | GroupFooter |
Public Property | GroupHeader |
Public Property | GroupKeepTogether |
Public Property | Name | (Inherited from ProcessingElement)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Top

See Also

Reference

Group Class
Telerik.Reporting.Processing Namespace


GroupFooter Property

Telerik.Reporting.Processing Send comments on this topic.
GroupFooter Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Group Class : GroupFooter Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GroupFooter As GroupSection
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As GroupSection

value = instance.GroupFooter
C#
public GroupSection GroupFooter {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


GroupHeader Property

Telerik.Reporting.Processing Send comments on this topic.
GroupHeader Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Group Class : GroupHeader Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GroupHeader As GroupSection
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As GroupSection

value = instance.GroupHeader
C#
public GroupSection GroupHeader {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


GroupKeepTogether Property

Telerik.Reporting.Processing Send comments on this topic.
GroupKeepTogether Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Group Class : GroupKeepTogether Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GroupKeepTogether As GroupKeepTogether
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As GroupKeepTogether

value = instance.GroupKeepTogether
C#
public GroupKeepTogether GroupKeepTogether {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


GroupSection Class

Telerik.Reporting.Processing Send comments on this topic.
GroupSection Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : GroupSection Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class GroupSection
   Inherits ReportSection
   Implements ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
C#
public class GroupSection : ReportSection, ILayoutContainer

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportSectionBase
Telerik.Reporting.Processing.ReportSection
Telerik.Reporting.Processing.GroupSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Members
Telerik.Reporting.Processing Namespace


GroupSection Class Members

Telerik.Reporting.Processing Send comments on this topic.
GroupSection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : GroupSection Class

The following tables list the members exposed by GroupSection.

Public Properties

 | Name | Description
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Height | (Inherited from ReportSectionBase)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | KeepTogether | (Inherited from ReportSection)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | PageBreak | (Inherited from ReportSection)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | PrintOnEveryPage |
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportSectionBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItemBase)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

GroupSection Class
Telerik.Reporting.Processing Namespace


GroupSection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
GroupSection Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : GroupSection Class

For a list of all members of this type, see GroupSection members.

Public Properties

 | Name | Description
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Height | (Inherited from ReportSectionBase)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | KeepTogether | (Inherited from ReportSection)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | PageBreak | (Inherited from ReportSection)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | PrintOnEveryPage |
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportSectionBase)
Top

See Also

Reference

GroupSection Class
Telerik.Reporting.Processing Namespace


PrintOnEveryPage Property

Telerik.Reporting.Processing Send comments on this topic.
PrintOnEveryPage Property
See Also
[image]
Telerik.Reporting.Processing Namespace > GroupSection Class : PrintOnEveryPage Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintOnEveryPage As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As Boolean

value = instance.PrintOnEveryPage
C#
public bool PrintOnEveryPage {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


InheritedWidthMeasurement Class

Telerik.Reporting.Processing Send comments on this topic.
InheritedWidthMeasurement Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : InheritedWidthMeasurement Class

Inherits the width from the owner's parent

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class InheritedWidthMeasurement
   Inherits Measurements
Visual Basic (Usage) Copy Code
Dim instance As InheritedWidthMeasurement
C#
private class InheritedWidthMeasurement : Measurements

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.Measurements
Telerik.Reporting.Processing.InheritedWidthMeasurement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

InheritedWidthMeasurement Members
Telerik.Reporting.Processing Namespace


InheritedWidthMeasurement Class Members

Telerik.Reporting.Processing Send comments on this topic.
InheritedWidthMeasurement Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : InheritedWidthMeasurement Class

The following tables list the members exposed by InheritedWidthMeasurement.

Public Constructors

 | Name | Description
Public Constructor | InheritedWidthMeasurement Constructor |
Top

Public Properties

 | Name | Description
Public Property | BorderBottom | (Inherited from Measurements)
Public Property | BorderLeft | (Inherited from Measurements)
Public Property | BorderRight | (Inherited from Measurements)
Public Property | BorderTop | (Inherited from Measurements)
Public Property | Bottom | (Inherited from Measurements)
Public Property | ClientHeight | (Inherited from Measurements)
Public Property | ClientSize | (Inherited from Measurements)
Public Property | ClientWidth | (Inherited from Measurements)
Public Property | Height | (Inherited from Measurements)
Public Property | Left | (Inherited from Measurements)
Public Property | OffsetX | (Inherited from Measurements)
Public Property | OffsetY | (Inherited from Measurements)
Public Property | PadBottom | (Inherited from Measurements)
Public Property | PaddingBottom | (Inherited from Measurements)
Public Property | PaddingLeft | (Inherited from Measurements)
Public Property | PaddingRight | (Inherited from Measurements)
Public Property | PaddingTop | (Inherited from Measurements)
Public Property | PadLeft | (Inherited from Measurements)
Public Property | PadRight | (Inherited from Measurements)
Public Property | PadTop | (Inherited from Measurements)
Public Property | Right | (Inherited from Measurements)
Public Property | Top | (Inherited from Measurements)
Public Property | Width | Overridden.
Top

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from Measurements)
Top

See Also

Reference

InheritedWidthMeasurement Class
Telerik.Reporting.Processing Namespace


InheritedWidthMeasurement Constructor

Telerik.Reporting.Processing Send comments on this topic.
InheritedWidthMeasurement Constructor
See Also
[image]
Telerik.Reporting.Processing Namespace > InheritedWidthMeasurement Class : InheritedWidthMeasurement Constructor

owner

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As ProcessingElement _
)
Visual Basic (Usage) Copy Code
Dim owner As ProcessingElement

Dim instance As InheritedWidthMeasurement(owner)
C#
public InheritedWidthMeasurement(
   ProcessingElement owner
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As ProcessingElement _
)
Visual Basic (Usage) Copy Code
Dim owner As ProcessingElement

Dim instance As InheritedWidthMeasurement(owner)
C#
public InheritedWidthMeasurement(
   ProcessingElement owner
)

Parameters

owner

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

InheritedWidthMeasurement Class
InheritedWidthMeasurement Members


InheritedWidthMeasurement Class Properties

Telerik.Reporting.Processing Send comments on this topic.
InheritedWidthMeasurement Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : InheritedWidthMeasurement Class

For a list of all members of this type, see InheritedWidthMeasurement members.

Public Properties

 | Name | Description
Public Property | BorderBottom | (Inherited from Measurements)
Public Property | BorderLeft | (Inherited from Measurements)
Public Property | BorderRight | (Inherited from Measurements)
Public Property | BorderTop | (Inherited from Measurements)
Public Property | Bottom | (Inherited from Measurements)
Public Property | ClientHeight | (Inherited from Measurements)
Public Property | ClientSize | (Inherited from Measurements)
Public Property | ClientWidth | (Inherited from Measurements)
Public Property | Height | (Inherited from Measurements)
Public Property | Left | (Inherited from Measurements)
Public Property | OffsetX | (Inherited from Measurements)
Public Property | OffsetY | (Inherited from Measurements)
Public Property | PadBottom | (Inherited from Measurements)
Public Property | PaddingBottom | (Inherited from Measurements)
Public Property | PaddingLeft | (Inherited from Measurements)
Public Property | PaddingRight | (Inherited from Measurements)
Public Property | PaddingTop | (Inherited from Measurements)
Public Property | PadLeft | (Inherited from Measurements)
Public Property | PadRight | (Inherited from Measurements)
Public Property | PadTop | (Inherited from Measurements)
Public Property | Right | (Inherited from Measurements)
Public Property | Top | (Inherited from Measurements)
Public Property | Width | Overridden.
Top

See Also

Reference

InheritedWidthMeasurement Class
Telerik.Reporting.Processing Namespace


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.Processing Namespace > InheritedWidthMeasurement Class : Width Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As InheritedWidthMeasurement
Dim value As Single

instance.Width = value

value = instance.Width
C#
public override float Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

InheritedWidthMeasurement Class
InheritedWidthMeasurement Members


Measurements Class

Telerik.Reporting.Processing Send comments on this topic.
Measurements Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : Measurements Class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Measurements
Visual Basic (Usage) Copy Code
Dim instance As Measurements
C#
private class Measurements

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.Measurements
Telerik.Reporting.Processing.InheritedWidthMeasurement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Members
Telerik.Reporting.Processing Namespace


Measurements Class Members

Telerik.Reporting.Processing Send comments on this topic.
Measurements Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : Measurements Class

The following tables list the members exposed by Measurements.

Public Properties

 | Name | Description
Public Property | BorderBottom |
Public Property | BorderLeft |
Public Property | BorderRight |
Public Property | BorderTop |
Public Property | Bottom |
Public Property | ClientHeight |
Public Property | ClientSize |
Public Property | ClientWidth |
Public Property | Height |
Public Property | Left |
Public Property | OffsetX |
Public Property | OffsetY |
Public Property | PadBottom |
Public Property | PaddingBottom |
Public Property | PaddingLeft |
Public Property | PaddingRight |
Public Property | PaddingTop |
Public Property | PadLeft |
Public Property | PadRight |
Public Property | PadTop |
Public Property | Right |
Public Property | Top |
Public Property | Width | Sections and groups are always report-wide so they have to work with Report.Measurement.Width
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Measurements Class
Telerik.Reporting.Processing Namespace


Measurements Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Measurements Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : Measurements Class

For a list of all members of this type, see Measurements members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Measurements Class
Telerik.Reporting.Processing Namespace


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : ToString Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


Measurements Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Measurements Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : Measurements Class

For a list of all members of this type, see Measurements members.

Public Properties

 | Name | Description
Public Property | BorderBottom |
Public Property | BorderLeft |
Public Property | BorderRight |
Public Property | BorderTop |
Public Property | Bottom |
Public Property | ClientHeight |
Public Property | ClientSize |
Public Property | ClientWidth |
Public Property | Height |
Public Property | Left |
Public Property | OffsetX |
Public Property | OffsetY |
Public Property | PadBottom |
Public Property | PaddingBottom |
Public Property | PaddingLeft |
Public Property | PaddingRight |
Public Property | PaddingTop |
Public Property | PadLeft |
Public Property | PadRight |
Public Property | PadTop |
Public Property | Right |
Public Property | Top |
Public Property | Width | Sections and groups are always report-wide so they have to work with Report.Measurement.Width
Top

See Also

Reference

Measurements Class
Telerik.Reporting.Processing Namespace


BorderBottom Property

Telerik.Reporting.Processing Send comments on this topic.
BorderBottom Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : BorderBottom Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property BorderBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.BorderBottom = value

value = instance.BorderBottom
C#
public float BorderBottom {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


BorderLeft Property

Telerik.Reporting.Processing Send comments on this topic.
BorderLeft Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : BorderLeft Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property BorderLeft As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.BorderLeft = value

value = instance.BorderLeft
C#
public float BorderLeft {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


BorderRight Property

Telerik.Reporting.Processing Send comments on this topic.
BorderRight Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : BorderRight Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property BorderRight As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.BorderRight = value

value = instance.BorderRight
C#
public float BorderRight {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


BorderTop Property

Telerik.Reporting.Processing Send comments on this topic.
BorderTop Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : BorderTop Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property BorderTop As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.BorderTop = value

value = instance.BorderTop
C#
public float BorderTop {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : Bottom Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

value = instance.Bottom
C#
public float Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


ClientHeight Property

Telerik.Reporting.Processing Send comments on this topic.
ClientHeight Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : ClientHeight Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientHeight As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

value = instance.ClientHeight
C#
public float ClientHeight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : ClientSize Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeF
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As SizeF

value = instance.ClientSize
C#
public SizeF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


ClientWidth Property

Telerik.Reporting.Processing Send comments on this topic.
ClientWidth Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : ClientWidth Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientWidth As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

value = instance.ClientWidth
C#
public float ClientWidth {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : Height Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.Height = value

value = instance.Height
C#
public float Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : Left Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.Left = value

value = instance.Left
C#
public float Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


OffsetX Property

Telerik.Reporting.Processing Send comments on this topic.
OffsetX Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : OffsetX Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property OffsetX As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.OffsetX = value

value = instance.OffsetX
C#
public float OffsetX {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


OffsetY Property

Telerik.Reporting.Processing Send comments on this topic.
OffsetY Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : OffsetY Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property OffsetY As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.OffsetY = value

value = instance.OffsetY
C#
public float OffsetY {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : PadBottom Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

value = instance.PadBottom
C#
public float PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


PaddingBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PaddingBottom Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : PaddingBottom Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property PaddingBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.PaddingBottom = value

value = instance.PaddingBottom
C#
public float PaddingBottom {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


PaddingLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PaddingLeft Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : PaddingLeft Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property PaddingLeft As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.PaddingLeft = value

value = instance.PaddingLeft
C#
public float PaddingLeft {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


PaddingRight Property

Telerik.Reporting.Processing Send comments on this topic.
PaddingRight Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : PaddingRight Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property PaddingRight As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.PaddingRight = value

value = instance.PaddingRight
C#
public float PaddingRight {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


PaddingTop Property

Telerik.Reporting.Processing Send comments on this topic.
PaddingTop Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : PaddingTop Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property PaddingTop As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.PaddingTop = value

value = instance.PaddingTop
C#
public float PaddingTop {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : PadLeft Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

value = instance.PadLeft
C#
public float PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : PadRight Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

value = instance.PadRight
C#
public float PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : PadTop Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

value = instance.PadTop
C#
public float PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : Right Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

value = instance.Right
C#
public float Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : Top Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.Top = value

value = instance.Top
C#
public float Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Measurements Class : Width Property

Sections and groups are always report-wide so they have to work with Report.Measurement.Width

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As Measurements
Dim value As Single

instance.Width = value

value = instance.Width
C#
public virtual float Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Measurements Class
Measurements Members


PageSection Class

Telerik.Reporting.Processing Send comments on this topic.
PageSection Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : PageSection Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class PageSection
   Inherits ReportSectionBase
   Implements ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As PageSection
C#
public class PageSection : ReportSectionBase, ILayoutContainer

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportSectionBase
Telerik.Reporting.Processing.PageSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Members
Telerik.Reporting.Processing Namespace


PageSection Class Members

Telerik.Reporting.Processing Send comments on this topic.
PageSection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : PageSection Class

The following tables list the members exposed by PageSection.

Public Properties

 | Name | Description
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Height | (Inherited from ReportSectionBase)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | PrintOnFirstPage |
Public Property | PrintOnLastPage |
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportSectionBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItemBase)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

PageSection Class
Telerik.Reporting.Processing Namespace


PageSection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
PageSection Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : PageSection Class

For a list of all members of this type, see PageSection members.

Public Properties

 | Name | Description
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Height | (Inherited from ReportSectionBase)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | PrintOnFirstPage |
Public Property | PrintOnLastPage |
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportSectionBase)
Top

See Also

Reference

PageSection Class
Telerik.Reporting.Processing Namespace


PrintOnFirstPage Property

Telerik.Reporting.Processing Send comments on this topic.
PrintOnFirstPage Property
See Also
[image]
Telerik.Reporting.Processing Namespace > PageSection Class : PrintOnFirstPage Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintOnFirstPage As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As Boolean

value = instance.PrintOnFirstPage
C#
public bool PrintOnFirstPage {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


PrintOnLastPage Property

Telerik.Reporting.Processing Send comments on this topic.
PrintOnLastPage Property
See Also
[image]
Telerik.Reporting.Processing Namespace > PageSection Class : PrintOnLastPage Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintOnLastPage As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As Boolean

value = instance.PrintOnLastPage
C#
public bool PrintOnLastPage {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Panel Class

Telerik.Reporting.Processing Send comments on this topic.
Panel Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : Panel Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class Panel
   Inherits ReportItem
   Implements ILayoutContainer, ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As Panel
C#
public class Panel : ReportItem, ILayoutContainer, ILayoutItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportItem
Telerik.Reporting.Processing.Panel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Members
Telerik.Reporting.Processing Namespace


Panel Class Members

Telerik.Reporting.Processing Send comments on this topic.
Panel Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : Panel Class

The following tables list the members exposed by Panel.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Height | (Inherited from ReportItem)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

Panel Class
Telerik.Reporting.Processing Namespace


PictureBox Class

Telerik.Reporting.Processing Send comments on this topic.
PictureBox Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : PictureBox Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class PictureBox
   Inherits ReportItem
   Implements ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
C#
public class PictureBox : ReportItem, ILayoutItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportItem
Telerik.Reporting.Processing.PictureBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Members
Telerik.Reporting.Processing Namespace


PictureBox Class Members

Telerik.Reporting.Processing Send comments on this topic.
PictureBox Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : PictureBox Class

The following tables list the members exposed by PictureBox.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Height | (Inherited from ReportItem)
Public Property | Image |
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | MimeType |
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Sizing |
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

PictureBox Class
Telerik.Reporting.Processing Namespace


PictureBox Class Methods

Telerik.Reporting.Processing Send comments on this topic.
PictureBox Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : PictureBox Class

For a list of all members of this type, see PictureBox members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

PictureBox Class
Telerik.Reporting.Processing Namespace


ProcessItem Method

Telerik.Reporting.Processing Send comments on this topic.
ProcessItem Method
See Also
[image]
Telerik.Reporting.Processing Namespace > PictureBox Class : ProcessItem Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ProcessItem()
Visual Basic (Usage) Copy Code
Dim instance As PictureBox

instance.ProcessItem()
C#
protected override void ProcessItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


PictureBox Class Properties

Telerik.Reporting.Processing Send comments on this topic.
PictureBox Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : PictureBox Class

For a list of all members of this type, see PictureBox members.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Height | (Inherited from ReportItem)
Public Property | Image |
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | MimeType |
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Sizing |
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

See Also

Reference

PictureBox Class
Telerik.Reporting.Processing Namespace


Image Property

Telerik.Reporting.Processing Send comments on this topic.
Image Property
See Also
[image]
Telerik.Reporting.Processing Namespace > PictureBox Class : Image Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Image As Image
Visual Basic (Usage) Copy Code
Dim instance As PictureBox

instance.Image = value
C#
public Image Image {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


MimeType Property

Telerik.Reporting.Processing Send comments on this topic.
MimeType Property
See Also
[image]
Telerik.Reporting.Processing Namespace > PictureBox Class : MimeType Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MimeType As String
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As String

value = instance.MimeType
C#
public string MimeType {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Sizing Property

Telerik.Reporting.Processing Send comments on this topic.
Sizing Property
See Also
[image]
Telerik.Reporting.Processing Namespace > PictureBox Class : Sizing Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sizing As ImageSizeMode
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As ImageSizeMode

value = instance.Sizing
C#
public ImageSizeMode Sizing {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


PictureBoxUtil Class

Telerik.Reporting.Processing Send comments on this topic.
PictureBoxUtil Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : PictureBoxUtil Class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private MustInherit NotInheritable Class PictureBoxUtil
Visual Basic (Usage) Copy Code
Dim instance As PictureBoxUtil
C#
private static class PictureBoxUtil

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.PictureBoxUtil

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBoxUtil Members
Telerik.Reporting.Processing Namespace


PictureBoxUtil Class Members

Telerik.Reporting.Processing Send comments on this topic.
PictureBoxUtil Class Members
See Also Methods
[image]
Telerik.Reporting.Processing Namespace : PictureBoxUtil Class

The following tables list the members exposed by PictureBoxUtil.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetImageFormatWithEncoder | When there is no encoder for the passed image format, returns image format for which there is a valid encoder.
static (Shared in Visual Basic) | ImageSizeInMm |
static (Shared in Visual Basic) | ImageToArray |
static (Shared in Visual Basic) | Load | Overloaded.
Top

See Also

Reference

PictureBoxUtil Class
Telerik.Reporting.Processing Namespace


PictureBoxUtil Class Methods

Telerik.Reporting.Processing Send comments on this topic.
PictureBoxUtil Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : PictureBoxUtil Class

For a list of all members of this type, see PictureBoxUtil members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetImageFormatWithEncoder | When there is no encoder for the passed image format, returns image format for which there is a valid encoder.
static (Shared in Visual Basic) | ImageSizeInMm |
static (Shared in Visual Basic) | ImageToArray |
static (Shared in Visual Basic) | Load | Overloaded.
Top

See Also

Reference

PictureBoxUtil Class
Telerik.Reporting.Processing Namespace


GetImageFormatWithEncoder Method

Telerik.Reporting.Processing Send comments on this topic.
GetImageFormatWithEncoder Method
See Also
[image]
Telerik.Reporting.Processing Namespace > PictureBoxUtil Class : GetImageFormatWithEncoder Method

imageFormat
When there is no encoder for the passed image format, returns image format for which there is a valid encoder.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetImageFormatWithEncoder( _
   ByVal imageFormat As ImageFormat _
) As ImageFormat
Visual Basic (Usage) Copy Code
Dim imageFormat As ImageFormat
Dim value As ImageFormat

value = PictureBoxUtil.GetImageFormatWithEncoder(imageFormat)
C#
public static ImageFormat GetImageFormatWithEncoder(
   ImageFormat imageFormat
)

Parameters

imageFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBoxUtil Class
PictureBoxUtil Members


ImageSizeInMm Method

Telerik.Reporting.Processing Send comments on this topic.
ImageSizeInMm Method
See Also
[image]
Telerik.Reporting.Processing Namespace > PictureBoxUtil Class : ImageSizeInMm Method

img

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ImageSizeInMm( _
   ByVal img As Image _
) As SizeF
Visual Basic (Usage) Copy Code
Dim img As Image
Dim value As SizeF

value = PictureBoxUtil.ImageSizeInMm(img)
C#
public static SizeF ImageSizeInMm(
   Image img
)

Parameters

img

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBoxUtil Class
PictureBoxUtil Members


ImageToArray Method

Telerik.Reporting.Processing Send comments on this topic.
ImageToArray Method
See Also
[image]
Telerik.Reporting.Processing Namespace > PictureBoxUtil Class : ImageToArray Method

img

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ImageToArray( _
   ByVal img As Image _
) As Byte()
Visual Basic (Usage) Copy Code
Dim img As Image
Dim value() As Byte

value = PictureBoxUtil.ImageToArray(img)
C#
public static byte[] ImageToArray(
   Image img
)

Parameters

img

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBoxUtil Class
PictureBoxUtil Members


Load Method

Telerik.Reporting.Processing Send comments on this topic.
Load Method
See Also
[image]
Telerik.Reporting.Processing Namespace > PictureBoxUtil Class : Load Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
Load(String) |
Load(String,String) |

Overload List

Overload | Description
Load(String) |
Load(String,String) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBoxUtil Class
PictureBoxUtil Members


Load(String) Method

Telerik.Reporting.Processing Send comments on this topic.
Load(String) Method
See Also
[image]
Telerik.Reporting.Processing Namespace > PictureBoxUtil Class > Load Method : Load(String) Method

path

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Load( _
   ByVal path As String _
) As Byte()
Visual Basic (Usage) Copy Code
Dim path As String
Dim value() As Byte

value = PictureBoxUtil.Load(path)
C#
public static byte[] Load(
   string path
)

Parameters

path

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBoxUtil Class
PictureBoxUtil Members
Overload List


Load(String,String) Method

Telerik.Reporting.Processing Send comments on this topic.
Load(String,String) Method
See Also
[image]
Telerik.Reporting.Processing Namespace > PictureBoxUtil Class > Load Method : Load(String,String) Method

path
basePath

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Load( _
   ByVal path As String, _
   ByVal basePath As String _
) As Byte()
Visual Basic (Usage) Copy Code
Dim path As String
Dim basePath As String
Dim value() As Byte

value = PictureBoxUtil.Load(path, basePath)
C#
public static byte[] Load(
   string path,
   string basePath
)

Parameters

path
basePath

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBoxUtil Class
PictureBoxUtil Members
Overload List


ProcessingElement Class

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement
C#
public abstract class ProcessingElement

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.Group
Telerik.Reporting.Processing.ReportItemBase

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement Members
Telerik.Reporting.Processing Namespace


ProcessingElement Class Members

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement Class

The following tables list the members exposed by ProcessingElement.

Public Properties

 | Name | Description
Public Property | Name |
Public Property | Parent |
Public Property | Report | Nested report's Report points to itself - not the master report.
Public Property | Style |
Public Property | Visible |
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Dispose |
Protected Method | OnElementAdded |
Protected Method | OnElementRemoved |
Top

See Also

Reference

ProcessingElement Class
Telerik.Reporting.Processing Namespace


ProcessingElement Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement Class

For a list of all members of this type, see ProcessingElement members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Dispose |
Protected Method | OnElementAdded |
Protected Method | OnElementRemoved |
Top

See Also

Reference

ProcessingElement Class
Telerik.Reporting.Processing Namespace


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ProcessingElement Class : Dispose Method

disposing

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement Class
ProcessingElement Members


OnElementAdded Method

Telerik.Reporting.Processing Send comments on this topic.
OnElementAdded Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ProcessingElement Class : OnElementAdded Method

element

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnElementAdded( _
   ByVal element As ProcessingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement
Dim element As ProcessingElement

instance.OnElementAdded(element)
C#
protected virtual void OnElementAdded(
   ProcessingElement element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement Class
ProcessingElement Members


OnElementRemoved Method

Telerik.Reporting.Processing Send comments on this topic.
OnElementRemoved Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ProcessingElement Class : OnElementRemoved Method

element

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnElementRemoved( _
   ByVal element As ProcessingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement
Dim element As ProcessingElement

instance.OnElementRemoved(element)
C#
protected virtual void OnElementRemoved(
   ProcessingElement element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement Class
ProcessingElement Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ProcessingElement Class : ToString Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement Class
ProcessingElement Members


ProcessingElement Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement Class

For a list of all members of this type, see ProcessingElement members.

Public Properties

 | Name | Description
Public Property | Name |
Public Property | Parent |
Public Property | Report | Nested report's Report points to itself - not the master report.
Public Property | Style |
Public Property | Visible |
Top

See Also

Reference

ProcessingElement Class
Telerik.Reporting.Processing Namespace


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ProcessingElement Class : Name Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement Class
ProcessingElement Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ProcessingElement Class : Parent Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement
Dim value As ProcessingElement

value = instance.Parent
C#
public ProcessingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement Class
ProcessingElement Members


Report Property

Telerik.Reporting.Processing Send comments on this topic.
Report Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ProcessingElement Class : Report Property

Nested report's Report points to itself - not the master report.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement
Dim value As Report

value = instance.Report
C#
public Report Report {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement Class
ProcessingElement Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ProcessingElement Class : Style Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement Class
ProcessingElement Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ProcessingElement Class : Visible Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement Class
ProcessingElement Members


ProcessingElement.ElementIndex Class

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.ElementIndex Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.ElementIndex Class

List of the indexes of items in the elements collection

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private MustInherit Class ProcessingElement.ElementIndex
   Inherits List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement.ElementIndex
C#
private abstract class ProcessingElement.ElementIndex : List<int>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Int32>
Telerik.Reporting.Processing.ProcessingElement.ElementIndex
Telerik.Reporting.Processing.ProcessingElement.HorizontalIndex
Telerik.Reporting.Processing.ProcessingElement.VerticalIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement.ElementIndex Members
Telerik.Reporting.Processing Namespace


ProcessingElement.ElementIndex Class Members

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.ElementIndex Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.ElementIndex Class

The following tables list the members exposed by ProcessingElement.ElementIndex.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<Int32>)
Public Property | Count | (Inherited from System.Collections.Generic.List<Int32>)
Public Property | Item | (Inherited from System.Collections.Generic.List<Int32>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | AddRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Find | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<Int32>)
Top

See Also

Reference

ProcessingElement.ElementIndex Class
Telerik.Reporting.Processing Namespace


ProcessingElement.HorizontalIndex Class

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.HorizontalIndex Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.HorizontalIndex Class

List of the indexes of the elements ordered by x-position

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class ProcessingElement.HorizontalIndex
   Inherits ProcessingElement.ElementIndex
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement.HorizontalIndex
C#
private class ProcessingElement.HorizontalIndex : ProcessingElement.ElementIndex

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Int32>
Telerik.Reporting.Processing.ProcessingElement.ElementIndex
Telerik.Reporting.Processing.ProcessingElement.HorizontalIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement.HorizontalIndex Members
Telerik.Reporting.Processing Namespace


ProcessingElement.HorizontalIndex Class Members

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.HorizontalIndex Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.HorizontalIndex Class

The following tables list the members exposed by ProcessingElement.HorizontalIndex.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<Int32>)
Public Property | Count | (Inherited from System.Collections.Generic.List<Int32>)
Public Property | Item | (Inherited from System.Collections.Generic.List<Int32>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | AddRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Find | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<Int32>)
Top

See Also

Reference

ProcessingElement.HorizontalIndex Class
Telerik.Reporting.Processing Namespace


ProcessingElement.ProcessingElementCollection Class

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.ProcessingElementCollection Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.ProcessingElementCollection Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class ProcessingElement.ProcessingElementCollection
   Inherits Collection(Of ProcessingElement)
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement.ProcessingElementCollection
C#
private class ProcessingElement.ProcessingElementCollection : Collection<ProcessingElement>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<ProcessingElement>
Telerik.Reporting.Processing.ProcessingElement.ProcessingElementCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement.ProcessingElementCollection Members
Telerik.Reporting.Processing Namespace


ProcessingElement.ProcessingElementCollection Class Members

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.ProcessingElementCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.ProcessingElementCollection Class

The following tables list the members exposed by ProcessingElement.ProcessingElementCollection.

Public Constructors

 | Name | Description
Public Constructor | ProcessingElement.ProcessingElementCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | ForEach |
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Protected Method | InsertItem | Overridden.
Protected Method | RemoveItem | Overridden.
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Top

See Also

Reference

ProcessingElement.ProcessingElementCollection Class
Telerik.Reporting.Processing Namespace


ProcessingElement.ProcessingElementCollection Constructor

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.ProcessingElementCollection Constructor
See Also
[image]
Telerik.Reporting.Processing Namespace > ProcessingElement.ProcessingElementCollection Class : ProcessingElement.ProcessingElementCollection Constructor

owner

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As ProcessingElement _
)
Visual Basic (Usage) Copy Code
Dim owner As ProcessingElement

Dim instance As ProcessingElement.ProcessingElementCollection(owner)
C#
public ProcessingElement.ProcessingElementCollection(
   ProcessingElement owner
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As ProcessingElement _
)
Visual Basic (Usage) Copy Code
Dim owner As ProcessingElement

Dim instance As ProcessingElement.ProcessingElementCollection(owner)
C#
public ProcessingElement.ProcessingElementCollection(
   ProcessingElement owner
)

Parameters

owner

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement.ProcessingElementCollection Class
ProcessingElement.ProcessingElementCollection Members


ProcessingElement.ProcessingElementCollection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.ProcessingElementCollection Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.ProcessingElementCollection Class

For a list of all members of this type, see ProcessingElement.ProcessingElementCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | ForEach |
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Protected Method | InsertItem | Overridden.
Protected Method | RemoveItem | Overridden.
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Top

See Also

Reference

ProcessingElement.ProcessingElementCollection Class
Telerik.Reporting.Processing Namespace


ForEach Method

Telerik.Reporting.Processing Send comments on this topic.
ForEach Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ProcessingElement.ProcessingElementCollection Class : ForEach Method

action

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub ForEach( _
   ByVal action As Action(Of ProcessingElement) _
)
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement.ProcessingElementCollection
Dim action As Action(Of ProcessingElement)

instance.ForEach(action)
C#
public void ForEach(
   Action<ProcessingElement> action
)

Parameters

action

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement.ProcessingElementCollection Class
ProcessingElement.ProcessingElementCollection Members


InsertItem Method

Telerik.Reporting.Processing Send comments on this topic.
InsertItem Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ProcessingElement.ProcessingElementCollection Class : InsertItem Method

index
element

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub InsertItem( _
   ByVal index As Integer, _
   ByVal element As ProcessingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement.ProcessingElementCollection
Dim index As Integer
Dim element As ProcessingElement

instance.InsertItem(index, element)
C#
protected override void InsertItem(
   int index,
   ProcessingElement element
)

Parameters

index
element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement.ProcessingElementCollection Class
ProcessingElement.ProcessingElementCollection Members


RemoveItem Method

Telerik.Reporting.Processing Send comments on this topic.
RemoveItem Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ProcessingElement.ProcessingElementCollection Class : RemoveItem Method

index

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RemoveItem( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement.ProcessingElementCollection
Dim index As Integer

instance.RemoveItem(index)
C#
protected override void RemoveItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement.ProcessingElementCollection Class
ProcessingElement.ProcessingElementCollection Members


ProcessingElement.ProcessingStyle Class

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.ProcessingStyle Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.ProcessingStyle Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class ProcessingElement.ProcessingStyle
   Inherits Style
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement.ProcessingStyle
C#
private class ProcessingElement.ProcessingStyle : Style

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.StyleBase
Telerik.Reporting.Drawing.Style
Telerik.Reporting.Processing.ProcessingElement.ProcessingStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement.ProcessingStyle Members
Telerik.Reporting.Processing Namespace


ProcessingElement.ProcessingStyle Class Members

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.ProcessingStyle Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.ProcessingStyle Class

The following tables list the members exposed by ProcessingElement.ProcessingStyle.

Public Properties

 | Name | Description
Public Property | BackgroundColor | Gets or sets the background color of the report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | BackgroundImage | Gets a Telerik.Reporting.Drawing.BackgroundImage object that controls the image displayed in the background of the report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | BorderColor | Gets a Telerik.Reporting.Drawing.BorderColor object used to define the border color of a report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | BorderStyle | Gets a Telerik.Reporting.Drawing.BorderStyle object used to define the border style of a report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | BorderWidth | Gets a Telerik.Reporting.Drawing.BorderWidth object used to define the border width of a report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | Color | Gets or sets the foreground color of the report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | Font | Gets a Telerik.Reporting.Drawing.Font object representing the font of the report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | LineStyle | Gets or sets a Telerik.Reporting.Drawing.LineStyle object used to define the line style of report items that support it, such as lines and shapes. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | LineWidth | Gets or sets a Telerik.Reporting.Drawing.Unit representing the line width of report items that support it, such as lines and shapes. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | Padding | Gets a Telerik.Reporting.Drawing.Padding object used to define the padding of a report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | TextAlign | Gets or sets the horizontal alignment of text in the report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | VerticalAlign | Gets or sets the vertical alignment of text in the report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from Telerik.Reporting.Drawing.Style)
Top

Protected Properties

 | Name | Description
Protected Property | Styles | (Inherited from Telerik.Reporting.Drawing.Style)
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from Telerik.Reporting.Drawing.StyleBase)
Protected Method | WriteXml | (Inherited from Telerik.Reporting.Drawing.StyleBase)
Top

See Also

Reference

ProcessingElement.ProcessingStyle Class
Telerik.Reporting.Processing Namespace


ProcessingElement.VerticalIndex Class

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.VerticalIndex Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.VerticalIndex Class

List of the indexes of the elements ordered by y-position

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class ProcessingElement.VerticalIndex
   Inherits ProcessingElement.ElementIndex
Visual Basic (Usage) Copy Code
Dim instance As ProcessingElement.VerticalIndex
C#
private class ProcessingElement.VerticalIndex : ProcessingElement.ElementIndex

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Int32>
Telerik.Reporting.Processing.ProcessingElement.ElementIndex
Telerik.Reporting.Processing.ProcessingElement.VerticalIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ProcessingElement.VerticalIndex Members
Telerik.Reporting.Processing Namespace


ProcessingElement.VerticalIndex Class Members

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.VerticalIndex Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.VerticalIndex Class

The following tables list the members exposed by ProcessingElement.VerticalIndex.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<Int32>)
Public Property | Count | (Inherited from System.Collections.Generic.List<Int32>)
Public Property | Item | (Inherited from System.Collections.Generic.List<Int32>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | AddRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Find | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<Int32>)
Top

See Also

Reference

ProcessingElement.VerticalIndex Class
Telerik.Reporting.Processing Namespace


RenderingDefaults Class

Telerik.Reporting.Processing Send comments on this topic.
RenderingDefaults Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : RenderingDefaults Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private MustInherit NotInheritable Class RenderingDefaults
Visual Basic (Usage) Copy Code
Dim instance As RenderingDefaults
C#
private static class RenderingDefaults

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.RenderingDefaults

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Members
Telerik.Reporting.Processing Namespace


RenderingDefaults Class Members

Telerik.Reporting.Processing Send comments on this topic.
RenderingDefaults Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Processing Namespace : RenderingDefaults Class

The following tables list the members exposed by RenderingDefaults.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DefaultMeasureFormat |
static (Shared in Visual Basic) | ErrorBackColor |
static (Shared in Visual Basic) | ErrorBorderColor |
static (Shared in Visual Basic) | ErrorBorderType |
static (Shared in Visual Basic) | ErrorBorderWidth |
static (Shared in Visual Basic) | ErrorColor |
static (Shared in Visual Basic) | ErrorFontName |
static (Shared in Visual Basic) | ErrorFontSizePt |
static (Shared in Visual Basic) | ErrorFormat |
static (Shared in Visual Basic) | ErrorPadding |
static (Shared in Visual Basic) | MinErrorWidthMm |
static (Shared in Visual Basic) | TrialMessage |
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | ErrorStyle |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ApplyErrorStyle |
static (Shared in Visual Basic) | CreateCheckBoxCheckedImage |
static (Shared in Visual Basic) | CreateCheckBoxIndeterminateImage |
static (Shared in Visual Basic) | CreateCheckBoxUncheckedImage |
static (Shared in Visual Basic) | CreateErrorBackgraoundBrush |
static (Shared in Visual Basic) | CreateErrorBrush |
static (Shared in Visual Basic) | CreateErrorFont |
Top

See Also

Reference

RenderingDefaults Class
Telerik.Reporting.Processing Namespace


RenderingDefaults Class Methods

Telerik.Reporting.Processing Send comments on this topic.
RenderingDefaults Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : RenderingDefaults Class

For a list of all members of this type, see RenderingDefaults members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ApplyErrorStyle |
static (Shared in Visual Basic) | CreateCheckBoxCheckedImage |
static (Shared in Visual Basic) | CreateCheckBoxIndeterminateImage |
static (Shared in Visual Basic) | CreateCheckBoxUncheckedImage |
static (Shared in Visual Basic) | CreateErrorBackgraoundBrush |
static (Shared in Visual Basic) | CreateErrorBrush |
static (Shared in Visual Basic) | CreateErrorFont |
Top

See Also

Reference

RenderingDefaults Class
Telerik.Reporting.Processing Namespace


ApplyErrorStyle Method

Telerik.Reporting.Processing Send comments on this topic.
ApplyErrorStyle Method
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : ApplyErrorStyle Method

style

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ApplyErrorStyle( _
   ByVal style As Style _
)
Visual Basic (Usage) Copy Code
Dim style As Style

RenderingDefaults.ApplyErrorStyle(style)
C#
public static void ApplyErrorStyle(
   Style style
)

Parameters

style

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


CreateCheckBoxCheckedImage Method

Telerik.Reporting.Processing Send comments on this topic.
CreateCheckBoxCheckedImage Method
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : CreateCheckBoxCheckedImage Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateCheckBoxCheckedImage() As Image
Visual Basic (Usage) Copy Code
Dim value As Image

value = RenderingDefaults.CreateCheckBoxCheckedImage()
C#
public static Image CreateCheckBoxCheckedImage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


CreateCheckBoxIndeterminateImage Method

Telerik.Reporting.Processing Send comments on this topic.
CreateCheckBoxIndeterminateImage Method
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : CreateCheckBoxIndeterminateImage Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateCheckBoxIndeterminateImage() As Image
Visual Basic (Usage) Copy Code
Dim value As Image

value = RenderingDefaults.CreateCheckBoxIndeterminateImage()
C#
public static Image CreateCheckBoxIndeterminateImage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


CreateCheckBoxUncheckedImage Method

Telerik.Reporting.Processing Send comments on this topic.
CreateCheckBoxUncheckedImage Method
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : CreateCheckBoxUncheckedImage Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateCheckBoxUncheckedImage() As Image
Visual Basic (Usage) Copy Code
Dim value As Image

value = RenderingDefaults.CreateCheckBoxUncheckedImage()
C#
public static Image CreateCheckBoxUncheckedImage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


CreateErrorBackgraoundBrush Method

Telerik.Reporting.Processing Send comments on this topic.
CreateErrorBackgraoundBrush Method
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : CreateErrorBackgraoundBrush Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateErrorBackgraoundBrush() As Brush
Visual Basic (Usage) Copy Code
Dim value As Brush

value = RenderingDefaults.CreateErrorBackgraoundBrush()
C#
public static Brush CreateErrorBackgraoundBrush()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


CreateErrorBrush Method

Telerik.Reporting.Processing Send comments on this topic.
CreateErrorBrush Method
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : CreateErrorBrush Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateErrorBrush() As Brush
Visual Basic (Usage) Copy Code
Dim value As Brush

value = RenderingDefaults.CreateErrorBrush()
C#
public static Brush CreateErrorBrush()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


CreateErrorFont Method

Telerik.Reporting.Processing Send comments on this topic.
CreateErrorFont Method
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : CreateErrorFont Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateErrorFont() As Font
Visual Basic (Usage) Copy Code
Dim value As Font

value = RenderingDefaults.CreateErrorFont()
C#
public static Font CreateErrorFont()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


RenderingDefaults Class Properties

Telerik.Reporting.Processing Send comments on this topic.
RenderingDefaults Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : RenderingDefaults Class

For a list of all members of this type, see RenderingDefaults members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | ErrorStyle |
Top

See Also

Reference

RenderingDefaults Class
Telerik.Reporting.Processing Namespace


ErrorStyle Property

Telerik.Reporting.Processing Send comments on this topic.
ErrorStyle Property
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : ErrorStyle Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ErrorStyle As Style
Visual Basic (Usage) Copy Code
Dim value As Style

value = RenderingDefaults.ErrorStyle
C#
public static Style ErrorStyle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


RenderingDefaults Class Fields

Telerik.Reporting.Processing Send comments on this topic.
RenderingDefaults Class Fields
See Also
[image]
Telerik.Reporting.Processing Namespace : RenderingDefaults Class

For a list of all members of this type, see RenderingDefaults members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DefaultMeasureFormat |
static (Shared in Visual Basic) | ErrorBackColor |
static (Shared in Visual Basic) | ErrorBorderColor |
static (Shared in Visual Basic) | ErrorBorderType |
static (Shared in Visual Basic) | ErrorBorderWidth |
static (Shared in Visual Basic) | ErrorColor |
static (Shared in Visual Basic) | ErrorFontName |
static (Shared in Visual Basic) | ErrorFontSizePt |
static (Shared in Visual Basic) | ErrorFormat |
static (Shared in Visual Basic) | ErrorPadding |
static (Shared in Visual Basic) | MinErrorWidthMm |
static (Shared in Visual Basic) | TrialMessage |
Top

See Also

Reference

RenderingDefaults Class
Telerik.Reporting.Processing Namespace


DefaultMeasureFormat Field

Telerik.Reporting.Processing Send comments on this topic.
DefaultMeasureFormat Field
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : DefaultMeasureFormat Field

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultMeasureFormat As StringFormat
Visual Basic (Usage) Copy Code
Dim value As StringFormat

value = RenderingDefaults.DefaultMeasureFormat
C#
public static readonly StringFormat DefaultMeasureFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


ErrorBackColor Field

Telerik.Reporting.Processing Send comments on this topic.
ErrorBackColor Field
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : ErrorBackColor Field

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ErrorBackColor As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = RenderingDefaults.ErrorBackColor
C#
public static readonly Color ErrorBackColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


ErrorBorderColor Field

Telerik.Reporting.Processing Send comments on this topic.
ErrorBorderColor Field
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : ErrorBorderColor Field

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ErrorBorderColor As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = RenderingDefaults.ErrorBorderColor
C#
public static readonly Color ErrorBorderColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


ErrorBorderType Field

Telerik.Reporting.Processing Send comments on this topic.
ErrorBorderType Field
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : ErrorBorderType Field

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ErrorBorderType As BorderType
Visual Basic (Usage) Copy Code
Dim value As BorderType

value = RenderingDefaults.ErrorBorderType
C#
public static readonly BorderType ErrorBorderType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


ErrorBorderWidth Field

Telerik.Reporting.Processing Send comments on this topic.
ErrorBorderWidth Field
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : ErrorBorderWidth Field

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ErrorBorderWidth As Unit
Visual Basic (Usage) Copy Code
Dim value As Unit

value = RenderingDefaults.ErrorBorderWidth
C#
public static readonly Unit ErrorBorderWidth

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


ErrorColor Field

Telerik.Reporting.Processing Send comments on this topic.
ErrorColor Field
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : ErrorColor Field

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ErrorColor As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = RenderingDefaults.ErrorColor
C#
public static readonly Color ErrorColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


ErrorFontName Field

Telerik.Reporting.Processing Send comments on this topic.
ErrorFontName Field
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : ErrorFontName Field

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ErrorFontName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RenderingDefaults.ErrorFontName
C#
public static readonly string ErrorFontName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


ErrorFontSizePt Field

Telerik.Reporting.Processing Send comments on this topic.
ErrorFontSizePt Field
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : ErrorFontSizePt Field

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ErrorFontSizePt As Single
Visual Basic (Usage) Copy Code
Dim value As Single

value = RenderingDefaults.ErrorFontSizePt
C#
public static readonly float ErrorFontSizePt

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


ErrorFormat Field

Telerik.Reporting.Processing Send comments on this topic.
ErrorFormat Field
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : ErrorFormat Field

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ErrorFormat As StringFormat
Visual Basic (Usage) Copy Code
Dim value As StringFormat

value = RenderingDefaults.ErrorFormat
C#
public static readonly StringFormat ErrorFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


ErrorPadding Field

Telerik.Reporting.Processing Send comments on this topic.
ErrorPadding Field
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : ErrorPadding Field

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ErrorPadding As Unit
Visual Basic (Usage) Copy Code
Dim value As Unit

value = RenderingDefaults.ErrorPadding
C#
public static readonly Unit ErrorPadding

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


MinErrorWidthMm Field

Telerik.Reporting.Processing Send comments on this topic.
MinErrorWidthMm Field
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : MinErrorWidthMm Field

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared MinErrorWidthMm As Single
Visual Basic (Usage) Copy Code
Dim value As Single

value = RenderingDefaults.MinErrorWidthMm

RenderingDefaults.MinErrorWidthMm = value
C#
public static float MinErrorWidthMm

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


TrialMessage Field

Telerik.Reporting.Processing Send comments on this topic.
TrialMessage Field
See Also
[image]
Telerik.Reporting.Processing Namespace > RenderingDefaults Class : TrialMessage Field

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TrialMessage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RenderingDefaults.TrialMessage
C#
public static readonly string TrialMessage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RenderingDefaults Class
RenderingDefaults Members


Report Class

Telerik.Reporting.Processing Send comments on this topic.
Report Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : Report Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class Report
   Inherits ReportItemBase
   Implements IDataItem
Visual Basic (Usage) Copy Code
Dim instance As Report
C#
public class Report : ReportItemBase, IDataItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.Report

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Members
Telerik.Reporting.Processing Namespace


Report Class Members

Telerik.Reporting.Processing Send comments on this topic.
Report Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : Report Class

The following tables list the members exposed by Report.

Public Properties

 | Name | Description
Public Property | ColumnCount |
Public Property | ColumnSpacing |
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | DataMember |
Public Property | DataSource |
Public Property | DocumentName | Gets or sets a String representing the name of the report document.
Public Property | IsNestedReport |
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | PageFooter |
Public Property | PageHeader |
Public Property | PageSettings |
Public Property | Parameters |
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | ReportFooter |
Public Property | ReportHeader |
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | Overridden.
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | Overridden.
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

Report Class
Telerik.Reporting.Processing Namespace


Report Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Report Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : Report Class

For a list of all members of this type, see Report members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | Overridden.
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | Overridden.
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

Report Class
Telerik.Reporting.Processing Namespace


InitializeItem Method

Telerik.Reporting.Processing Send comments on this topic.
InitializeItem Method
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : InitializeItem Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub InitializeItem()
Visual Basic (Usage) Copy Code
Dim instance As Report

instance.InitializeItem()
C#
public override void InitializeItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


OnItemProcessed Method

Telerik.Reporting.Processing Send comments on this topic.
OnItemProcessed Method
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : OnItemProcessed Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnItemProcessed()
Visual Basic (Usage) Copy Code
Dim instance As Report

instance.OnItemProcessed()
C#
protected override void OnItemProcessed()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ProcessItem Method

Telerik.Reporting.Processing Send comments on this topic.
ProcessItem Method
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : ProcessItem Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ProcessItem()
Visual Basic (Usage) Copy Code
Dim instance As Report

instance.ProcessItem()
C#
protected override void ProcessItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Report Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Report Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : Report Class

For a list of all members of this type, see Report members.

Public Properties

 | Name | Description
Public Property | ColumnCount |
Public Property | ColumnSpacing |
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | DataMember |
Public Property | DataSource |
Public Property | DocumentName | Gets or sets a String representing the name of the report document.
Public Property | IsNestedReport |
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | PageFooter |
Public Property | PageHeader |
Public Property | PageSettings |
Public Property | Parameters |
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | ReportFooter |
Public Property | ReportHeader |
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width |
Top

See Also

Reference

Report Class
Telerik.Reporting.Processing Namespace


ColumnCount Property

Telerik.Reporting.Processing Send comments on this topic.
ColumnCount Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : ColumnCount Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Integer

value = instance.ColumnCount
C#
public int ColumnCount {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ColumnSpacing Property

Telerik.Reporting.Processing Send comments on this topic.
ColumnSpacing Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : ColumnSpacing Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnSpacing As Unit
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Unit

value = instance.ColumnSpacing
C#
public Unit ColumnSpacing {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


DataMember Property

Telerik.Reporting.Processing Send comments on this topic.
DataMember Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : DataMember Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
public string DataMember {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


DataSource Property

Telerik.Reporting.Processing Send comments on this topic.
DataSource Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : DataSource Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
public object DataSource {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


DocumentName Property

Telerik.Reporting.Processing Send comments on this topic.
DocumentName Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : DocumentName Property

Gets or sets a String representing the name of the report document.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentName As String
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As String

instance.DocumentName = value

value = instance.DocumentName
C#
public string DocumentName {get; set;}

Return Value

A String representing the document name. The default value is the name of the Report this property belongs to.

Remarks

The value of this property is used to suggest a file name when exporting a report to one of the available export formats.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


IsNestedReport Property

Telerik.Reporting.Processing Send comments on this topic.
IsNestedReport Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : IsNestedReport Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNestedReport As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Boolean

value = instance.IsNestedReport
C#
public bool IsNestedReport {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


PageFooter Property

Telerik.Reporting.Processing Send comments on this topic.
PageFooter Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : PageFooter Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageFooter As PageSection
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As PageSection

value = instance.PageFooter
C#
public PageSection PageFooter {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


PageHeader Property

Telerik.Reporting.Processing Send comments on this topic.
PageHeader Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : PageHeader Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageHeader As PageSection
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As PageSection

value = instance.PageHeader
C#
public PageSection PageHeader {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


PageSettings Property

Telerik.Reporting.Processing Send comments on this topic.
PageSettings Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : PageSettings Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageSettings As PageSettings
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As PageSettings

value = instance.PageSettings
C#
public PageSettings PageSettings {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Parameters Property

Telerik.Reporting.Processing Send comments on this topic.
Parameters Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : Parameters Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As IDictionary(Of String, Object)
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As IDictionary(Of String, Object)

value = instance.Parameters
C#
public IDictionary<string, object> Parameters {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ReportFooter Property

Telerik.Reporting.Processing Send comments on this topic.
ReportFooter Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : ReportFooter Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportFooter As ReportSection
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As ReportSection

value = instance.ReportFooter
C#
public ReportSection ReportFooter {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ReportHeader Property

Telerik.Reporting.Processing Send comments on this topic.
ReportHeader Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : ReportHeader Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportHeader As ReportSection
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As ReportSection

value = instance.ReportHeader
C#
public ReportSection ReportHeader {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Report Class : Width Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public Unit Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ReportItem Class

Telerik.Reporting.Processing Send comments on this topic.
ReportItem Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ReportItem Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportItem
   Inherits ReportItemBase
   Implements ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
C#
public class ReportItem : ReportItemBase, ILayoutItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportItem
Telerik.Reporting.Processing.Barcode
Telerik.Reporting.Processing.Chart
Telerik.Reporting.Processing.Panel
Telerik.Reporting.Processing.PictureBox
Telerik.Reporting.Processing.Shape
Telerik.Reporting.Processing.SubReport
Telerik.Reporting.Processing.TextItemBase

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Members
Telerik.Reporting.Processing Namespace


ReportItem Class Members

Telerik.Reporting.Processing Send comments on this topic.
ReportItem Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : ReportItem Class

The following tables list the members exposed by ReportItem.

Public Properties

 | Name | Description
Public Property | Anchor |
Public Property | Bounds |
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock |
Public Property | Height |
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left |
Public Property | Location |
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size |
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top |
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | Overridden.
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

ReportItem Class
Telerik.Reporting.Processing Namespace


ReportItem Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ReportItem Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ReportItem Class

For a list of all members of this type, see ReportItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | Overridden.
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

ReportItem Class
Telerik.Reporting.Processing Namespace


OnItemProcessed Method

Telerik.Reporting.Processing Send comments on this topic.
OnItemProcessed Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItem Class : OnItemProcessed Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnItemProcessed()
Visual Basic (Usage) Copy Code
Dim instance As ReportItem

instance.OnItemProcessed()
C#
protected override void OnItemProcessed()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


ReportItem Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ReportItem Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : ReportItem Class

For a list of all members of this type, see ReportItem members.

Public Properties

 | Name | Description
Public Property | Anchor |
Public Property | Bounds |
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock |
Public Property | Height |
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left |
Public Property | Location |
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size |
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top |
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width |
Top

See Also

Reference

ReportItem Class
Telerik.Reporting.Processing Namespace


Anchor Property

Telerik.Reporting.Processing Send comments on this topic.
Anchor Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItem Class : Anchor Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Anchor As AnchorStyles
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As AnchorStyles

value = instance.Anchor
C#
public AnchorStyles Anchor {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Bounds Property

Telerik.Reporting.Processing Send comments on this topic.
Bounds Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItem Class : Bounds Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Bounds As RectangleU
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As RectangleU

instance.Bounds = value

value = instance.Bounds
C#
public RectangleU Bounds {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Dock Property

Telerik.Reporting.Processing Send comments on this topic.
Dock Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItem Class : Dock Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dock As DockStyle
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As DockStyle

value = instance.Dock
C#
public DockStyle Dock {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItem Class : Height Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public Unit Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItem Class : Left Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As Unit

instance.Left = value

value = instance.Left
C#
public Unit Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Location Property

Telerik.Reporting.Processing Send comments on this topic.
Location Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItem Class : Location Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Location As PointU
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As PointU

instance.Location = value

value = instance.Location
C#
public PointU Location {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Size Property

Telerik.Reporting.Processing Send comments on this topic.
Size Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItem Class : Size Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Size As SizeU
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As SizeU

instance.Size = value

value = instance.Size
C#
public SizeU Size {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItem Class : Top Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As Unit

instance.Top = value

value = instance.Top
C#
public Unit Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItem Class : Width Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportItem
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public Unit Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItem Class
ReportItem Members


ReportItemBase Class

Telerik.Reporting.Processing Send comments on this topic.
ReportItemBase Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ReportItemBase Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ReportItemBase
   Inherits ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
C#
public abstract class ReportItemBase : ProcessingElement

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.Report
Telerik.Reporting.Processing.ReportItem
Telerik.Reporting.Processing.ReportSectionBase

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Members
Telerik.Reporting.Processing Namespace


ReportItemBase Class Members

Telerik.Reporting.Processing Send comments on this topic.
ReportItemBase Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : ReportItemBase Class

The following tables list the members exposed by ReportItemBase.

Public Properties

 | Name | Description
Public Property | DataItem | Gets or sets a data item that is bound to the report item.
Public Property | ItemDefinition |
Public Property | Items |
Public Property | Name | Overridden.
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded.
Public Method | InitializeItem |
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden.
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed |
Protected Method | OnItemProcessing |
Protected Method | ProcessItem |
Top

See Also

Reference

ReportItemBase Class
Telerik.Reporting.Processing Namespace


ReportItemBase Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ReportItemBase Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ReportItemBase Class

For a list of all members of this type, see ReportItemBase members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded.
Public Method | InitializeItem |
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden.
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed |
Protected Method | OnItemProcessing |
Protected Method | ProcessItem |
Top

See Also

Reference

ReportItemBase Class
Telerik.Reporting.Processing Namespace


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase Class : Dispose Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


Dispose() Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose() Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase Class > Dispose Method : Dispose() Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members
Overload List


Dispose(Boolean) Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose(Boolean) Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members
Overload List


Finalize Method

Telerik.Reporting.Processing Send comments on this topic.
Finalize Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase Class : Finalize Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase

instance.Finalize()
C#
protected override void Finalize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


InitializeItem Method

Telerik.Reporting.Processing Send comments on this topic.
InitializeItem Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase Class : InitializeItem Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub InitializeItem()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase

instance.InitializeItem()
C#
public virtual void InitializeItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


OnItemProcessed Method

Telerik.Reporting.Processing Send comments on this topic.
OnItemProcessed Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase Class : OnItemProcessed Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemProcessed()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase

instance.OnItemProcessed()
C#
protected virtual void OnItemProcessed()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


OnItemProcessing Method

Telerik.Reporting.Processing Send comments on this topic.
OnItemProcessing Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase Class : OnItemProcessing Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemProcessing()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase

instance.OnItemProcessing()
C#
protected virtual void OnItemProcessing()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


ProcessItem Method

Telerik.Reporting.Processing Send comments on this topic.
ProcessItem Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase Class : ProcessItem Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ProcessItem()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase

instance.ProcessItem()
C#
protected virtual void ProcessItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


ReportItemBase Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ReportItemBase Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : ReportItemBase Class

For a list of all members of this type, see ReportItemBase members.

Public Properties

 | Name | Description
Public Property | DataItem | Gets or sets a data item that is bound to the report item.
Public Property | ItemDefinition |
Public Property | Items |
Public Property | Name | Overridden.
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Top

See Also

Reference

ReportItemBase Class
Telerik.Reporting.Processing Namespace


DataItem Property

Telerik.Reporting.Processing Send comments on this topic.
DataItem Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase Class : DataItem Property

Gets or sets a data item that is bound to the report item.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataItem As Object
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As Object

value = instance.DataItem
C#
public object DataItem {get;}

Return Value

An Object that represents a data item of the report item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


ItemDefinition Property

Telerik.Reporting.Processing Send comments on this topic.
ItemDefinition Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase Class : ItemDefinition Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemDefinition As ReportItemBase
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As ReportItemBase

value = instance.ItemDefinition
C#
public ReportItemBase ItemDefinition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase Class : Items Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As ReportItemBase.ItemCollection
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As ReportItemBase.ItemCollection

value = instance.Items
C#
public ReportItemBase.ItemCollection Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase Class : Name Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase
Dim value As String

value = instance.Name
C#
public override string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase Class
ReportItemBase Members


ReportItemBase.ItemCollection Class

Telerik.Reporting.Processing Send comments on this topic.
ReportItemBase.ItemCollection Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ReportItemBase.ItemCollection Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportItemBase.ItemCollection
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
C#
public class ReportItemBase.ItemCollection

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ReportItemBase.ItemCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Members
Telerik.Reporting.Processing Namespace


ReportItemBase.ItemCollection Class Members

Telerik.Reporting.Processing Send comments on this topic.
ReportItemBase.ItemCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : ReportItemBase.ItemCollection Class

The following tables list the members exposed by ReportItemBase.ItemCollection.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | Contains |
Public Method | ContainsKey |
Public Method | CopyTo |
Public Method | Find |
Public Method | IndexOf |
Public Method | IndexOfKey |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt |
Top

See Also

Reference

ReportItemBase.ItemCollection Class
Telerik.Reporting.Processing Namespace


ReportItemBase.ItemCollection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ReportItemBase.ItemCollection Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ReportItemBase.ItemCollection Class

For a list of all members of this type, see ReportItemBase.ItemCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | Contains |
Public Method | ContainsKey |
Public Method | CopyTo |
Public Method | Find |
Public Method | IndexOf |
Public Method | IndexOfKey |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt |
Top

See Also

Reference

ReportItemBase.ItemCollection Class
Telerik.Reporting.Processing Namespace


Add Method

Telerik.Reporting.Processing Send comments on this topic.
Add Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : Add Method

item

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim item As ReportItemBase

instance.Add(item)
C#
public void Add(
   ReportItemBase item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


Clear Method

Telerik.Reporting.Processing Send comments on this topic.
Clear Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : Clear Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


Contains Method

Telerik.Reporting.Processing Send comments on this topic.
Contains Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : Contains Method

item

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As ReportItemBase _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim item As ReportItemBase
Dim value As Boolean

value = instance.Contains(item)
C#
public bool Contains(
   ReportItemBase item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


ContainsKey Method

Telerik.Reporting.Processing Send comments on this topic.
ContainsKey Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : ContainsKey Method

key

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
   ByVal key As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim key As String
Dim value As Boolean

value = instance.ContainsKey(key)
C#
public bool ContainsKey(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


CopyTo Method

Telerik.Reporting.Processing Send comments on this topic.
CopyTo Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : CopyTo Method

array
arrayIndex

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ReportItemBase, _
   ByVal arrayIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim array() As ReportItemBase
Dim arrayIndex As Integer

instance.CopyTo(array, arrayIndex)
C#
public void CopyTo(
   ReportItemBase[] array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


Find Method

Telerik.Reporting.Processing Send comments on this topic.
Find Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : Find Method

key
searchAllChildren

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function Find( _
   ByVal key As String, _
   ByVal searchAllChildren As Boolean _
) As ReportItemBase()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim key As String
Dim searchAllChildren As Boolean
Dim value() As ReportItemBase

value = instance.Find(key, searchAllChildren)
C#
public ReportItemBase[] Find(
   string key,
   bool searchAllChildren
)

Parameters

key
searchAllChildren

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


IndexOf Method

Telerik.Reporting.Processing Send comments on this topic.
IndexOf Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : IndexOf Method

item

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As ReportItemBase _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim item As ReportItemBase
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   ReportItemBase item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


IndexOfKey Method

Telerik.Reporting.Processing Send comments on this topic.
IndexOfKey Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : IndexOfKey Method

key

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOfKey( _
   ByVal key As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim key As String
Dim value As Integer

value = instance.IndexOfKey(key)
C#
public int IndexOfKey(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


Insert Method

Telerik.Reporting.Processing Send comments on this topic.
Insert Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : Insert Method

index
item

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As ReportItemBase _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim index As Integer
Dim item As ReportItemBase

instance.Insert(index, item)
C#
public void Insert(
   int index,
   ReportItemBase item
)

Parameters

index
item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


Remove Method

Telerik.Reporting.Processing Send comments on this topic.
Remove Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : Remove Method

item

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As ReportItemBase _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim item As ReportItemBase
Dim value As Boolean

value = instance.Remove(item)
C#
public bool Remove(
   ReportItemBase item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


RemoveAt Method

Telerik.Reporting.Processing Send comments on this topic.
RemoveAt Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : RemoveAt Method

index

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


ReportItemBase.ItemCollection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ReportItemBase.ItemCollection Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : ReportItemBase.ItemCollection Class

For a list of all members of this type, see ReportItemBase.ItemCollection members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | Item | Overloaded.
Top

See Also

Reference

ReportItemBase.ItemCollection Class
Telerik.Reporting.Processing Namespace


Count Property

Telerik.Reporting.Processing Send comments on this topic.
Count Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : Count Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


IsReadOnly Property

Telerik.Reporting.Processing Send comments on this topic.
IsReadOnly Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : IsReadOnly Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


Item Property

Telerik.Reporting.Processing Send comments on this topic.
Item Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class : Item Property

Overload List

Overload | Description
Item(Int32) |
Item(String) |

Overload List

Overload | Description
Item(Int32) |
Item(String) |

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members


Item(Int32) Property

Telerik.Reporting.Processing Send comments on this topic.
Item(Int32) Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class > Item Property : Item(Int32) Property

index

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Property Item( _
   ByVal index As Integer _
) As ReportItemBase
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim index As Integer
Dim value As ReportItemBase

instance.Item(index) = value

value = instance.Item(index)
C#
public ReportItemBase Item(
   int index
) {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members
Overload List


Item(String) Property

Telerik.Reporting.Processing Send comments on this topic.
Item(String) Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection Class > Item Property : Item(String) Property

key

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal key As String _
) As ReportItemBase
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection
Dim key As String
Dim value As ReportItemBase

value = instance.Item(key)
C#
public ReportItemBase Item(
   string key
) {get;}

Parameters

key

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection Class
ReportItemBase.ItemCollection Members
Overload List


ReportItemBase.ItemCollection.ReadOnlyCollectionException Class

Telerik.Reporting.Processing Send comments on this topic.
ReportItemBase.ItemCollection.ReadOnlyCollectionException Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ReportItemBase.ItemCollection.ReadOnlyCollectionException Class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class ReportItemBase.ItemCollection.ReadOnlyCollectionException
   Inherits ReadOnlyException
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection.ReadOnlyCollectionException
C#
private class ReportItemBase.ItemCollection.ReadOnlyCollectionException : ReadOnlyException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.Data.DataException
System.Data.ReadOnlyException
Telerik.Reporting.Processing.ReportItemBase.ItemCollection.ReadOnlyCollectionException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection.ReadOnlyCollectionException Members
Telerik.Reporting.Processing Namespace


ReportItemBase.ItemCollection.ReadOnlyCollectionException Class Members

Telerik.Reporting.Processing Send comments on this topic.
ReportItemBase.ItemCollection.ReadOnlyCollectionException Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : ReportItemBase.ItemCollection.ReadOnlyCollectionException Class

The following tables list the members exposed by ReportItemBase.ItemCollection.ReadOnlyCollectionException.

Public Constructors

 | Name | Description
Public Constructor | ReportItemBase.ItemCollection.ReadOnlyCollectionException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ReportItemBase.ItemCollection.ReadOnlyCollectionException Class
Telerik.Reporting.Processing Namespace


ReportItemBase.ItemCollection.ReadOnlyCollectionException Constructor

Telerik.Reporting.Processing Send comments on this topic.
ReportItemBase.ItemCollection.ReadOnlyCollectionException Constructor
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportItemBase.ItemCollection.ReadOnlyCollectionException Class : ReportItemBase.ItemCollection.ReadOnlyCollectionException Constructor

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection.ReadOnlyCollectionException()
C#
public ReportItemBase.ItemCollection.ReadOnlyCollectionException()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportItemBase.ItemCollection.ReadOnlyCollectionException()
C#
public ReportItemBase.ItemCollection.ReadOnlyCollectionException()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportItemBase.ItemCollection.ReadOnlyCollectionException Class
ReportItemBase.ItemCollection.ReadOnlyCollectionException Members


ReportProcessor Class

Telerik.Reporting.Processing Send comments on this topic.
ReportProcessor Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ReportProcessor Class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportProcessor
Visual Basic (Usage) Copy Code
Dim instance As ReportProcessor
C#
public sealed class ReportProcessor

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ReportProcessor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportProcessor Members
Telerik.Reporting.Processing Namespace


ReportProcessor Class Members

Telerik.Reporting.Processing Send comments on this topic.
ReportProcessor Class Members
See Also Methods
[image]
Telerik.Reporting.Processing Namespace : ReportProcessor Class

The following tables list the members exposed by ReportProcessor.

Public Constructors

 | Name | Description
Public Constructor | ReportProcessor Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ListRenderingExtensions |
static (Shared in Visual Basic) | Print | Prints a report
static (Shared in Visual Basic) | Render | Overloaded. Renders a report in the specified format
Top

See Also

Reference

ReportProcessor Class
Telerik.Reporting.Processing Namespace


ReportProcessor Constructor

Telerik.Reporting.Processing Send comments on this topic.
ReportProcessor Constructor
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportProcessor Class : ReportProcessor Constructor

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportProcessor()
C#
public ReportProcessor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportProcessor()
C#
public ReportProcessor()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportProcessor Class
ReportProcessor Members


ReportProcessor Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ReportProcessor Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ReportProcessor Class

For a list of all members of this type, see ReportProcessor members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ListRenderingExtensions |
static (Shared in Visual Basic) | Print | Prints a report
static (Shared in Visual Basic) | Render | Overloaded. Renders a report in the specified format
Top

See Also

Reference

ReportProcessor Class
Telerik.Reporting.Processing Namespace


ListRenderingExtensions Method

Telerik.Reporting.Processing Send comments on this topic.
ListRenderingExtensions Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportProcessor Class : ListRenderingExtensions Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ListRenderingExtensions() As IList(Of ExtensionInfo)
Visual Basic (Usage) Copy Code
Dim value As IList(Of ExtensionInfo)

value = ReportProcessor.ListRenderingExtensions()
C#
public static IList<ExtensionInfo> ListRenderingExtensions()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportProcessor Class
ReportProcessor Members


Print Method

Telerik.Reporting.Processing Send comments on this topic.
Print Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportProcessor Class : Print Method

report
Report to print
printerSettings
Printer to be used. If null or invalid printer settings are specified, the Print Dialog appears.
Prints a report

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Print( _
   ByVal report As Report, _
   ByVal printerSettings As PrinterSettings _
)
Visual Basic (Usage) Copy Code
Dim report As Report
Dim printerSettings As PrinterSettings

ReportProcessor.Print(report, printerSettings)
C#
public static void Print(
   Report report,
   PrinterSettings printerSettings
)

Parameters

report
Report to print
printerSettings
Printer to be used. If null or invalid printer settings are specified, the Print Dialog appears.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportProcessor Class
ReportProcessor Members


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportProcessor Class : Render Method

Renders a report in the specified format

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
Render(String,Report,Hashtable,String,String,Encoding) | Renders a report in the specified format
Render(String,Report,Hashtable,String,String,String,Encoding) | Renders a report in the specified format
Render(String,Report,Hashtable,CreateStream) | Renders a report in the specified format
Render(String,Report,Hashtable,CreateStream,String) | Renders a report in the specified format

Overload List

Overload | Description
Render(String,Report,Hashtable,String,String,Encoding) | Renders a report in the specified format
Render(String,Report,Hashtable,String,String,String,Encoding) | Renders a report in the specified format
Render(String,Report,Hashtable,CreateStream) | Renders a report in the specified format
Render(String,Report,Hashtable,CreateStream,String) | Renders a report in the specified format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportProcessor Class
ReportProcessor Members


Render(String,Report,Hashtable,String,String,Encoding) Method

Telerik.Reporting.Processing Send comments on this topic.
Render(String,Report,Hashtable,String,String,Encoding) Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportProcessor Class > Render Method : Render(String,Report,Hashtable,String,String,Encoding) Method

format
Export format
report
Report to render.
deviceInfo
Contains parameters to pass to the rendering extension.
mimeType
The MIME type of the result buffer.
extension
The file extension of the result buffer.
encoding
The character encoding of the result buffer.
Renders a report in the specified format

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Render( _
   ByVal format As String, _
   ByVal report As Report, _
   ByVal deviceInfo As Hashtable, _
   ByRef mimeType As String, _
   ByRef extension As String, _
   ByRef encoding As Encoding _
) As Byte()
Visual Basic (Usage) Copy Code
Dim format As String
Dim report As Report
Dim deviceInfo As Hashtable
Dim mimeType As String
Dim extension As String
Dim encoding As Encoding
Dim value() As Byte

value = ReportProcessor.Render(format, report, deviceInfo, mimeType, extension, encoding)
C#
public static byte[] Render(
   string format,
   Report report,
   Hashtable deviceInfo,
   out string mimeType,
   out string extension,
   out Encoding encoding
)

Parameters

format
Export format
report
Report to render.
deviceInfo
Contains parameters to pass to the rendering extension.
mimeType
The MIME type of the result buffer.
extension
The file extension of the result buffer.
encoding
The character encoding of the result buffer.

Return Value

Byte array that contains the rendered report.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportProcessor Class
ReportProcessor Members
Overload List


Render(String,Report,Hashtable,String,String,String,Encoding) Method

Telerik.Reporting.Processing Send comments on this topic.
Render(String,Report,Hashtable,String,String,String,Encoding) Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportProcessor Class > Render Method : Render(String,Report,Hashtable,String,String,String,Encoding) Method

format
Export format
report
Report to render.
deviceInfo
Contains parameters to pass to the rendering extension.
mimeType
The MIME type of the result buffer.
documentName
The name of the created document.
extension
The file extension of the result buffer.
encoding
The character encoding of the result buffer.
Renders a report in the specified format

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Render( _
   ByVal format As String, _
   ByVal report As Report, _
   ByVal deviceInfo As Hashtable, _
   ByRef mimeType As String, _
   ByRef documentName As String, _
   ByRef extension As String, _
   ByRef encoding As Encoding _
) As Byte()
Visual Basic (Usage) Copy Code
Dim format As String
Dim report As Report
Dim deviceInfo As Hashtable
Dim mimeType As String
Dim documentName As String
Dim extension As String
Dim encoding As Encoding
Dim value() As Byte

value = ReportProcessor.Render(format, report, deviceInfo, mimeType, documentName, extension, encoding)
C#
public static byte[] Render(
   string format,
   Report report,
   Hashtable deviceInfo,
   out string mimeType,
   out string documentName,
   out string extension,
   out Encoding encoding
)

Parameters

format
Export format
report
Report to render.
deviceInfo
Contains parameters to pass to the rendering extension.
mimeType
The MIME type of the result buffer.
documentName
The name of the created document.
extension
The file extension of the result buffer.
encoding
The character encoding of the result buffer.

Return Value

Byte array that contains the rendered report.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportProcessor Class
ReportProcessor Members
Overload List


Render(String,Report,Hashtable,CreateStream) Method

Telerik.Reporting.Processing Send comments on this topic.
Render(String,Report,Hashtable,CreateStream) Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportProcessor Class > Render Method : Render(String,Report,Hashtable,CreateStream) Method

format
Export format
report
Report to render
deviceInfo
Contains parameters to pass to the rendering extension.
createStreamCallback
The delegate function to call to get a stream to render into.
Renders a report in the specified format

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Render( _
   ByVal format As String, _
   ByVal report As Report, _
   ByVal deviceInfo As Hashtable, _
   ByVal createStreamCallback As CreateStream _
) As Boolean
Visual Basic (Usage) Copy Code
Dim format As String
Dim report As Report
Dim deviceInfo As Hashtable
Dim createStreamCallback As CreateStream
Dim value As Boolean

value = ReportProcessor.Render(format, report, deviceInfo, createStreamCallback)
C#
public static bool Render(
   string format,
   Report report,
   Hashtable deviceInfo,
   CreateStream createStreamCallback
)

Parameters

format
Export format
report
Report to render
deviceInfo
Contains parameters to pass to the rendering extension.
createStreamCallback
The delegate function to call to get a stream to render into.

Return Value

True if the rendering succeeds.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportProcessor Class
ReportProcessor Members
Overload List


Render(String,Report,Hashtable,CreateStream,String) Method

Telerik.Reporting.Processing Send comments on this topic.
Render(String,Report,Hashtable,CreateStream,String) Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportProcessor Class > Render Method : Render(String,Report,Hashtable,CreateStream,String) Method

format
Export format
report
Report to render
deviceInfo
Contains parameters to pass to the rendering extension.
createStreamCallback
The delegate function to call to get a stream to render into.
documentName
The name of the created document.
Renders a report in the specified format

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Render( _
   ByVal format As String, _
   ByVal report As Report, _
   ByVal deviceInfo As Hashtable, _
   ByVal createStreamCallback As CreateStream, _
   ByRef documentName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim format As String
Dim report As Report
Dim deviceInfo As Hashtable
Dim createStreamCallback As CreateStream
Dim documentName As String
Dim value As Boolean

value = ReportProcessor.Render(format, report, deviceInfo, createStreamCallback, documentName)
C#
public static bool Render(
   string format,
   Report report,
   Hashtable deviceInfo,
   CreateStream createStreamCallback,
   out string documentName
)

Parameters

format
Export format
report
Report to render
deviceInfo
Contains parameters to pass to the rendering extension.
createStreamCallback
The delegate function to call to get a stream to render into.
documentName
The name of the created document.

Return Value

True if the rendering succeeds.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportProcessor Class
ReportProcessor Members
Overload List


ReportSection Class

Telerik.Reporting.Processing Send comments on this topic.
ReportSection Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ReportSection Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportSection
   Inherits ReportSectionBase
   Implements ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
C#
public class ReportSection : ReportSectionBase, ILayoutContainer

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportSectionBase
Telerik.Reporting.Processing.ReportSection
Telerik.Reporting.Processing.DetailSection
Telerik.Reporting.Processing.GroupSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Members
Telerik.Reporting.Processing Namespace


ReportSection Class Members

Telerik.Reporting.Processing Send comments on this topic.
ReportSection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : ReportSection Class

The following tables list the members exposed by ReportSection.

Public Properties

 | Name | Description
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Height | (Inherited from ReportSectionBase)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | KeepTogether |
Public Property | Name | (Inherited from ReportItemBase)
Public Property | PageBreak |
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportSectionBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItemBase)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

ReportSection Class
Telerik.Reporting.Processing Namespace


ReportSection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ReportSection Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : ReportSection Class

For a list of all members of this type, see ReportSection members.

Public Properties

 | Name | Description
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Height | (Inherited from ReportSectionBase)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | KeepTogether |
Public Property | Name | (Inherited from ReportItemBase)
Public Property | PageBreak |
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportSectionBase)
Top

See Also

Reference

ReportSection Class
Telerik.Reporting.Processing Namespace


KeepTogether Property

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportSection Class : KeepTogether Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeepTogether As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As Boolean

value = instance.KeepTogether
C#
public bool KeepTogether {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportSection Class : PageBreak Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As PageBreak

value = instance.PageBreak
C#
public PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ReportSectionBase Class

Telerik.Reporting.Processing Send comments on this topic.
ReportSectionBase Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ReportSectionBase Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportSectionBase
   Inherits ReportItemBase
   Implements ILayoutContainer
Visual Basic (Usage) Copy Code
Dim instance As ReportSectionBase
C#
public class ReportSectionBase : ReportItemBase, ILayoutContainer

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportSectionBase
Telerik.Reporting.Processing.PageSection
Telerik.Reporting.Processing.ReportSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSectionBase Members
Telerik.Reporting.Processing Namespace


ReportSectionBase Class Members

Telerik.Reporting.Processing Send comments on this topic.
ReportSectionBase Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : ReportSectionBase Class

The following tables list the members exposed by ReportSectionBase.

Public Properties

 | Name | Description
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Height |
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItemBase)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

ReportSectionBase Class
Telerik.Reporting.Processing Namespace


ReportSectionBase Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ReportSectionBase Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : ReportSectionBase Class

For a list of all members of this type, see ReportSectionBase members.

Public Properties

 | Name | Description
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Height |
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width |
Top

See Also

Reference

ReportSectionBase Class
Telerik.Reporting.Processing Namespace


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportSectionBase Class : Height Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportSectionBase
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public Unit Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ReportSectionBase Class : Width Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportSectionBase
Dim value As Unit

value = instance.Width
C#
public Unit Width {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSectionBase Class
ReportSectionBase Members


Shape Class

Telerik.Reporting.Processing Send comments on this topic.
Shape Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : Shape Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class Shape
   Inherits ReportItem
   Implements ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As Shape
C#
public class Shape : ReportItem, ILayoutItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportItem
Telerik.Reporting.Processing.Shape

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Members
Telerik.Reporting.Processing Namespace


Shape Class Members

Telerik.Reporting.Processing Send comments on this topic.
Shape Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : Shape Class

The following tables list the members exposed by Shape.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Height | (Inherited from ReportItem)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | ShapeType |
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

Shape Class
Telerik.Reporting.Processing Namespace


Shape Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Shape Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : Shape Class

For a list of all members of this type, see Shape members.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Height | (Inherited from ReportItem)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | ShapeType |
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

See Also

Reference

Shape Class
Telerik.Reporting.Processing Namespace


ShapeType Property

Telerik.Reporting.Processing Send comments on this topic.
ShapeType Property
See Also
[image]
Telerik.Reporting.Processing Namespace > Shape Class : ShapeType Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShapeType As ShapeBase
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As ShapeBase

value = instance.ShapeType
C#
public ShapeBase ShapeType {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Stopwatch Class

Telerik.Reporting.Processing Send comments on this topic.
Stopwatch Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : Stopwatch Class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Stopwatch
Visual Basic (Usage) Copy Code
Dim instance As Stopwatch
C#
private class Stopwatch

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.Stopwatch

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Stopwatch Members
Telerik.Reporting.Processing Namespace


Stopwatch Class Members

Telerik.Reporting.Processing Send comments on this topic.
Stopwatch Class Members
See Also Methods
[image]
Telerik.Reporting.Processing Namespace : Stopwatch Class

The following tables list the members exposed by Stopwatch.

Public Constructors

 | Name | Description
Public Constructor | Stopwatch Constructor |
Top

Public Methods

 | Name | Description
Public Method | Dispose |
Top

See Also

Reference

Stopwatch Class
Telerik.Reporting.Processing Namespace


Stopwatch Constructor

Telerik.Reporting.Processing Send comments on this topic.
Stopwatch Constructor
See Also
[image]
Telerik.Reporting.Processing Namespace > Stopwatch Class : Stopwatch Constructor

name

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As Stopwatch(name)
C#
public Stopwatch(
   string name
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As Stopwatch(name)
C#
public Stopwatch(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Stopwatch Class
Stopwatch Members


Stopwatch Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Stopwatch Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : Stopwatch Class

For a list of all members of this type, see Stopwatch members.

Public Methods

 | Name | Description
Public Method | Dispose |
Top

See Also

Reference

Stopwatch Class
Telerik.Reporting.Processing Namespace


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.Processing Namespace > Stopwatch Class : Dispose Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Stopwatch

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Stopwatch Class
Stopwatch Members


SubReport Class

Telerik.Reporting.Processing Send comments on this topic.
SubReport Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : SubReport Class

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class SubReport
   Inherits ReportItem
   Implements ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As SubReport
C#
public class SubReport : ReportItem, ILayoutItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportItem
Telerik.Reporting.Processing.SubReport

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Members
Telerik.Reporting.Processing Namespace


SubReport Class Members

Telerik.Reporting.Processing Send comments on this topic.
SubReport Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : SubReport Class

The following tables list the members exposed by SubReport.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Height | (Inherited from ReportItem)
Public Property | InnerReport |
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | Overridden.
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

SubReport Class
Telerik.Reporting.Processing Namespace


SubReport Class Methods

Telerik.Reporting.Processing Send comments on this topic.
SubReport Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : SubReport Class

For a list of all members of this type, see SubReport members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | Overridden.
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

SubReport Class
Telerik.Reporting.Processing Namespace


InitializeItem Method

Telerik.Reporting.Processing Send comments on this topic.
InitializeItem Method
See Also
[image]
Telerik.Reporting.Processing Namespace > SubReport Class : InitializeItem Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub InitializeItem()
Visual Basic (Usage) Copy Code
Dim instance As SubReport

instance.InitializeItem()
C#
public override void InitializeItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


ProcessItem Method

Telerik.Reporting.Processing Send comments on this topic.
ProcessItem Method
See Also
[image]
Telerik.Reporting.Processing Namespace > SubReport Class : ProcessItem Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ProcessItem()
Visual Basic (Usage) Copy Code
Dim instance As SubReport

instance.ProcessItem()
C#
protected override void ProcessItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


SubReport Class Properties

Telerik.Reporting.Processing Send comments on this topic.
SubReport Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : SubReport Class

For a list of all members of this type, see SubReport members.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Height | (Inherited from ReportItem)
Public Property | InnerReport |
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

See Also

Reference

SubReport Class
Telerik.Reporting.Processing Namespace


InnerReport Property

Telerik.Reporting.Processing Send comments on this topic.
InnerReport Property
See Also
[image]
Telerik.Reporting.Processing Namespace > SubReport Class : InnerReport Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerReport As Report
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As Report

value = instance.InnerReport
C#
public Report InnerReport {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


TextBox Class

Telerik.Reporting.Processing Send comments on this topic.
TextBox Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : TextBox Class

Base class for TextBox and CheckBox classes

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBox
   Inherits TextItemBase
   Implements ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As TextBox
C#
public class TextBox : TextItemBase, ILayoutItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportItem
Telerik.Reporting.Processing.TextItemBase
Telerik.Reporting.Processing.TextBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Members
Telerik.Reporting.Processing Namespace


TextBox Class Members

Telerik.Reporting.Processing Send comments on this topic.
TextBox Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : TextBox Class

The following tables list the members exposed by TextBox.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase)
Public Property | Height | (Inherited from ReportItem)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Text | Gets the formatted value of the current TextBox processing item.
Public Property | Top | (Inherited from ReportItem)
Public Property | Value | Gets or sets the value of the TextBox item
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | Overridden.
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

TextBox Class
Telerik.Reporting.Processing Namespace


TextBox Class Methods

Telerik.Reporting.Processing Send comments on this topic.
TextBox Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | Overridden.
Protected Method | ProcessItem | Overridden.
Top

See Also

Reference

TextBox Class
Telerik.Reporting.Processing Namespace


OnItemProcessing Method

Telerik.Reporting.Processing Send comments on this topic.
OnItemProcessing Method
See Also
[image]
Telerik.Reporting.Processing Namespace > TextBox Class : OnItemProcessing Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnItemProcessing()
Visual Basic (Usage) Copy Code
Dim instance As TextBox

instance.OnItemProcessing()
C#
protected override void OnItemProcessing()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


ProcessItem Method

Telerik.Reporting.Processing Send comments on this topic.
ProcessItem Method
See Also
[image]
Telerik.Reporting.Processing Namespace > TextBox Class : ProcessItem Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ProcessItem()
Visual Basic (Usage) Copy Code
Dim instance As TextBox

instance.ProcessItem()
C#
protected override void ProcessItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.Processing Namespace > TextBox Class : ToString Method

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


TextBox Class Properties

Telerik.Reporting.Processing Send comments on this topic.
TextBox Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase)
Public Property | Height | (Inherited from ReportItem)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Text | Gets the formatted value of the current TextBox processing item.
Public Property | Top | (Inherited from ReportItem)
Public Property | Value | Gets or sets the value of the TextBox item
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

See Also

Reference

TextBox Class
Telerik.Reporting.Processing Namespace


Text Property

Telerik.Reporting.Processing Send comments on this topic.
Text Property
See Also
[image]
Telerik.Reporting.Processing Namespace > TextBox Class : Text Property

Gets the formatted value of the current TextBox processing item.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As String

value = instance.Text
C#
public string Text {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Value Property

Telerik.Reporting.Processing Send comments on this topic.
Value Property
See Also
[image]
Telerik.Reporting.Processing Namespace > TextBox Class : Value Property

Gets or sets the value of the TextBox item

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Object

instance.Value = value

value = instance.Value
C#
public object Value {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


TextBoxUtil Class

Telerik.Reporting.Processing Send comments on this topic.
TextBoxUtil Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : TextBoxUtil Class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private MustInherit NotInheritable Class TextBoxUtil
Visual Basic (Usage) Copy Code
Dim instance As TextBoxUtil
C#
private static class TextBoxUtil

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.TextBoxUtil

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBoxUtil Members
Telerik.Reporting.Processing Namespace


TextBoxUtil Class Members

Telerik.Reporting.Processing Send comments on this topic.
TextBoxUtil Class Members
See Also Methods
[image]
Telerik.Reporting.Processing Namespace : TextBoxUtil Class

The following tables list the members exposed by TextBoxUtil.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DrawText |
Top

See Also

Reference

TextBoxUtil Class
Telerik.Reporting.Processing Namespace


TextBoxUtil Class Methods

Telerik.Reporting.Processing Send comments on this topic.
TextBoxUtil Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : TextBoxUtil Class

For a list of all members of this type, see TextBoxUtil members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DrawText |
Top

See Also

Reference

TextBoxUtil Class
Telerik.Reporting.Processing Namespace


DrawText Method

Telerik.Reporting.Processing Send comments on this topic.
DrawText Method
See Also
[image]
Telerik.Reporting.Processing Namespace > TextBoxUtil Class : DrawText Method

text
font
brush
sizeMm
stringFormat
angle
dpi

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function DrawText( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal brush As Brush, _
   ByVal sizeMm As SizeF, _
   ByVal stringFormat As StringFormat, _
   ByVal angle As Double, _
   ByVal dpi As Integer _
) As Image
Visual Basic (Usage) Copy Code
Dim text As String
Dim font As Font
Dim brush As Brush
Dim sizeMm As SizeF
Dim stringFormat As StringFormat
Dim angle As Double
Dim dpi As Integer
Dim value As Image

value = TextBoxUtil.DrawText(text, font, brush, sizeMm, stringFormat, angle, dpi)
C#
public static Image DrawText(
   string text,
   Font font,
   Brush brush,
   SizeF sizeMm,
   StringFormat stringFormat,
   double angle,
   int dpi
)

Parameters

text
font
brush
sizeMm
stringFormat
angle
dpi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBoxUtil Class
TextBoxUtil Members


TextItemBase Class

Telerik.Reporting.Processing Send comments on this topic.
TextItemBase Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : TextItemBase Class

Base class for TextBox and CheckBox classes

Object Model

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class TextItemBase
   Inherits ReportItem
   Implements ILayoutItem
Visual Basic (Usage) Copy Code
Dim instance As TextItemBase
C#
public abstract class TextItemBase : ReportItem, ILayoutItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.ReportItem
Telerik.Reporting.Processing.TextItemBase
Telerik.Reporting.Processing.CheckBox
Telerik.Reporting.Processing.TextBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextItemBase Members
Telerik.Reporting.Processing Namespace


TextItemBase Class Members

Telerik.Reporting.Processing Send comments on this topic.
TextItemBase Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : TextItemBase Class

The following tables list the members exposed by TextItemBase.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Format | Gets or sets the character(s) that specify how text is formatted.
Public Property | Height | (Inherited from ReportItem)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

TextItemBase Class
Telerik.Reporting.Processing Namespace


TextItemBase Class Properties

Telerik.Reporting.Processing Send comments on this topic.
TextItemBase Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : TextItemBase Class

For a list of all members of this type, see TextItemBase members.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Format | Gets or sets the character(s) that specify how text is formatted.
Public Property | Height | (Inherited from ReportItem)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

See Also

Reference

TextItemBase Class
Telerik.Reporting.Processing Namespace


Format Property

Telerik.Reporting.Processing Send comments on this topic.
Format Property
See Also
[image]
Telerik.Reporting.Processing Namespace > TextItemBase Class : Format Property

Gets or sets the character(s) that specify how text is formatted.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As String
Visual Basic (Usage) Copy Code
Dim instance As TextItemBase
Dim value As String

instance.Format = value

value = instance.Format
C#
public string Format {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextItemBase Class
TextItemBase Members


IRenderingExtension Interface

Telerik.Reporting.Processing Send comments on this topic.
IRenderingExtension Interface
See Also Members
[image]
Telerik.Reporting.Processing Namespace : IRenderingExtension Interface

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRenderingExtension
   Inherits IExtension
Visual Basic (Usage) Copy Code
Dim instance As IRenderingExtension
C#
public interface IRenderingExtension : IExtension

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IRenderingExtension Members
Telerik.Reporting.Processing Namespace


IRenderingExtension Interface Members

Telerik.Reporting.Processing Send comments on this topic.
IRenderingExtension Interface Members
See Also Methods
[image]
Telerik.Reporting.Processing Namespace : IRenderingExtension Interface

The following tables list the members exposed by IRenderingExtension.

Public Methods

 | Name | Description
Method | Render |
Top

See Also

Reference

IRenderingExtension Interface
Telerik.Reporting.Processing Namespace


IRenderingExtension Interface Methods

Telerik.Reporting.Processing Send comments on this topic.
IRenderingExtension Interface Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : IRenderingExtension Interface

For a list of all members of this type, see IRenderingExtension members.

Public Methods

 | Name | Description
Method | Render |
Top

See Also

Reference

IRenderingExtension Interface
Telerik.Reporting.Processing Namespace


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.Processing Namespace > IRenderingExtension Interface : Render Method

report
renderingContext
deviceInfo
createStreamCallback
evalHeaderFooterCallback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Function Render( _
   ByVal report As Report, _
   ByVal renderingContext As Hashtable, _
   ByVal deviceInfo As Hashtable, _
   ByVal createStreamCallback As CreateStream, _
   ByVal evalHeaderFooterCallback As EvaluateHeaderFooterExpressions _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IRenderingExtension
Dim report As Report
Dim renderingContext As Hashtable
Dim deviceInfo As Hashtable
Dim createStreamCallback As CreateStream
Dim evalHeaderFooterCallback As EvaluateHeaderFooterExpressions
Dim value As Boolean

value = instance.Render(report, renderingContext, deviceInfo, createStreamCallback, evalHeaderFooterCallback)
C#
bool Render(
   Report report,
   Hashtable renderingContext,
   Hashtable deviceInfo,
   CreateStream createStreamCallback,
   EvaluateHeaderFooterExpressions evalHeaderFooterCallback
)

Parameters

report
renderingContext
deviceInfo
createStreamCallback
evalHeaderFooterCallback

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IRenderingExtension Interface
IRenderingExtension Members


IRenderStream Interface

Telerik.Reporting.Processing Send comments on this topic.
IRenderStream Interface
See Also Members
[image]
Telerik.Reporting.Processing Namespace : IRenderStream Interface

Provides support for rendering multiple streams from a rendering extension.
Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRenderStream
Visual Basic (Usage) Copy Code
Dim instance As IRenderStream
C#
public interface IRenderStream

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IRenderStream Members
Telerik.Reporting.Processing Namespace


IRenderStream Interface Members

Telerik.Reporting.Processing Send comments on this topic.
IRenderStream Interface Members
See Also Methods
[image]
Telerik.Reporting.Processing Namespace : IRenderStream Interface

The following tables list the members exposed by IRenderStream.

Public Methods

 | Name | Description
Method | Finish | Allows the rendering extension to indicate that there is no additional content to be added to the given stream.
Top

See Also

Reference

IRenderStream Interface
Telerik.Reporting.Processing Namespace


IRenderStream Interface Methods

Telerik.Reporting.Processing Send comments on this topic.
IRenderStream Interface Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : IRenderStream Interface

For a list of all members of this type, see IRenderStream members.

Public Methods

 | Name | Description
Method | Finish | Allows the rendering extension to indicate that there is no additional content to be added to the given stream.
Top

See Also

Reference

IRenderStream Interface
Telerik.Reporting.Processing Namespace


Finish Method

Telerik.Reporting.Processing Send comments on this topic.
Finish Method
See Also
[image]
Telerik.Reporting.Processing Namespace > IRenderStream Interface : Finish Method

Allows the rendering extension to indicate that there is no additional content to be added to the given stream.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Sub Finish()
Visual Basic (Usage) Copy Code
Dim instance As IRenderStream

instance.Finish()
C#
void Finish()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IRenderStream Interface
IRenderStream Members


ExtensionInfo Class

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionInfo Class
See Also Members
[image]
Telerik.Reporting.Processing Namespace : ExtensionInfo Class

Store info for an extension

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Class ExtensionInfo
Visual Basic (Usage) Copy Code
Dim instance As ExtensionInfo
C#
public class ExtensionInfo

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ExtensionInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionInfo Members
Telerik.Reporting.Processing Namespace


ExtensionInfo Class Members

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionInfo Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing Namespace : ExtensionInfo Class

The following tables list the members exposed by ExtensionInfo.

Public Properties

 | Name | Description
Public Property | DefaultValues |
Public Property | Description |
Public Property | ExtensionType |
Public Property | Name |
Public Property | Visible |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Public Method | CreateInstance | create and get an instance of extensionType
Public Method | PrepareDeviceInfo | Combines the default parameter values with the values passed by the user with type check
Top

See Also

Reference

ExtensionInfo Class
Telerik.Reporting.Processing Namespace


ExtensionInfo Class Methods

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionInfo Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ExtensionInfo Class

For a list of all members of this type, see ExtensionInfo members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
Public Method | CreateInstance | create and get an instance of extensionType
Public Method | PrepareDeviceInfo | Combines the default parameter values with the values passed by the user with type check
Top

See Also

Reference

ExtensionInfo Class
Telerik.Reporting.Processing Namespace


Create Method

Telerik.Reporting.Interfaces Send comments on this topic.
Create Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ExtensionInfo Class : Create Method

extensionType
extensionName

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal extensionType As Type, _
   ByVal extensionName As String _
) As ExtensionInfo
Visual Basic (Usage) Copy Code
Dim extensionType As Type
Dim extensionName As String
Dim value As ExtensionInfo

value = ExtensionInfo.Create(extensionType, extensionName)
C#
public static ExtensionInfo Create(
   Type extensionType,
   string extensionName
)

Parameters

extensionType
extensionName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionInfo Class
ExtensionInfo Members


CreateInstance Method

Telerik.Reporting.Interfaces Send comments on this topic.
CreateInstance Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ExtensionInfo Class : CreateInstance Method

create and get an instance of extensionType

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateInstance() As Object
Visual Basic (Usage) Copy Code
Dim instance As ExtensionInfo
Dim value As Object

value = instance.CreateInstance()
C#
public object CreateInstance()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionInfo Class
ExtensionInfo Members


PrepareDeviceInfo Method

Telerik.Reporting.Interfaces Send comments on this topic.
PrepareDeviceInfo Method
See Also
[image]
Telerik.Reporting.Processing Namespace > ExtensionInfo Class : PrepareDeviceInfo Method

deviceInfo
Combines the default parameter values with the values passed by the user with type check

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Function PrepareDeviceInfo( _
   ByVal deviceInfo As Hashtable _
) As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As ExtensionInfo
Dim deviceInfo As Hashtable
Dim value As Hashtable

value = instance.PrepareDeviceInfo(deviceInfo)
C#
public Hashtable PrepareDeviceInfo(
   Hashtable deviceInfo
)

Parameters

deviceInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionInfo Class
ExtensionInfo Members


ExtensionInfo Class Properties

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionInfo Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : ExtensionInfo Class

For a list of all members of this type, see ExtensionInfo members.

Public Properties

 | Name | Description
Public Property | DefaultValues |
Public Property | Description |
Public Property | ExtensionType |
Public Property | Name |
Public Property | Visible |
Top

See Also

Reference

ExtensionInfo Class
Telerik.Reporting.Processing Namespace


DefaultValues Property

Telerik.Reporting.Interfaces Send comments on this topic.
DefaultValues Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ExtensionInfo Class : DefaultValues Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultValues As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As ExtensionInfo
Dim value As Hashtable

value = instance.DefaultValues
C#
public Hashtable DefaultValues {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionInfo Class
ExtensionInfo Members


Description Property

Telerik.Reporting.Interfaces Send comments on this topic.
Description Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ExtensionInfo Class : Description Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionInfo
Dim value As String

instance.Description = value

value = instance.Description
C#
public string Description {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionInfo Class
ExtensionInfo Members


ExtensionType Property

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionType Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ExtensionInfo Class : ExtensionType Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtensionType As Type
Visual Basic (Usage) Copy Code
Dim instance As ExtensionInfo
Dim value As Type

instance.ExtensionType = value

value = instance.ExtensionType
C#
public Type ExtensionType {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionInfo Class
ExtensionInfo Members


Name Property

Telerik.Reporting.Interfaces Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ExtensionInfo Class : Name Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionInfo
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionInfo Class
ExtensionInfo Members


Visible Property

Telerik.Reporting.Interfaces Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.Processing Namespace > ExtensionInfo Class : Visible Property

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Interfaces (in Telerik.Reporting.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionInfo
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionInfo Class
ExtensionInfo Members


ExtensionCollection Class

Telerik.Reporting.Processing Send comments on this topic.
ExtensionCollection Class
See Also Members
[image]
Telerik.Reporting.Processing.Config Namespace : ExtensionCollection Class

Object Model

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExtensionCollection
   Inherits ConfigurationElementCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionCollection
C#
public sealed class ExtensionCollection : ConfigurationElementCollection

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.Configuration.ConfigurationElementCollection
Telerik.Reporting.Processing.Config.ExtensionCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionCollection Members
Telerik.Reporting.Processing.Config Namespace


ExtensionCollection Class Members

Telerik.Reporting.Processing Send comments on this topic.
ExtensionCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing.Config Namespace : ExtensionCollection Class

The following tables list the members exposed by ExtensionCollection.

Public Constructors

 | Name | Description
Public Constructor | ExtensionCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | CollectionType | Overridden.
Public Property | Count | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
Public Property | EmitClear | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Property | IsSynchronized | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Property | Item | Overloaded.
Public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Public Property | SyncRoot | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
Protected Property | AddElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Property | ClearElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Property | ElementName | Overridden.
Protected Property | ElementProperty | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | RemoveElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Property | ThrowOnDuplicate | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Public Methods

 | Name | Description
Public Method | AddExtensions |
Public Method | ContainsKey |
Public Method | CopyTo | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | Equals | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | GetEnumerator | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | GetHashCode | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Methods

 | Name | Description
Protected Method | BaseAdd | Overloaded. (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseClear | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseGet | Overloaded. (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseGetAllKeys | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseGetKey | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseIndexOf | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseIsRemoved | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseRemove | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseRemoveAt | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | CreateNewElement | Overloaded. Overridden.
Protected Method | DeserializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | GetElementKey | Overridden.
Protected Method | Init | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | InitializeDefault | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | IsElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | IsElementRemovable | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Reset | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | ResetModified | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | SerializeToXmlElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetReadOnly | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | Unmerge | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

See Also

Reference

ExtensionCollection Class
Telerik.Reporting.Processing.Config Namespace


ExtensionCollection Constructor

Telerik.Reporting.Processing Send comments on this topic.
ExtensionCollection Constructor
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionCollection Class : ExtensionCollection Constructor

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtensionCollection()
C#
public ExtensionCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtensionCollection()
C#
public ExtensionCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionCollection Class
ExtensionCollection Members


ExtensionCollection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ExtensionCollection Class Methods
See Also
[image]
Telerik.Reporting.Processing.Config Namespace : ExtensionCollection Class

For a list of all members of this type, see ExtensionCollection members.

Public Methods

 | Name | Description
Public Method | AddExtensions |
Public Method | ContainsKey |
Public Method | CopyTo | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | Equals | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | GetEnumerator | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | GetHashCode | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Methods

 | Name | Description
Protected Method | BaseAdd | Overloaded. (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseClear | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseGet | Overloaded. (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseGetAllKeys | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseGetKey | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseIndexOf | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseIsRemoved | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseRemove | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseRemoveAt | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | CreateNewElement | Overloaded. Overridden.
Protected Method | DeserializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | GetElementKey | Overridden.
Protected Method | Init | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | InitializeDefault | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | IsElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | IsElementRemovable | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Reset | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | ResetModified | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | SerializeToXmlElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetReadOnly | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | Unmerge | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

See Also

Reference

ExtensionCollection Class
Telerik.Reporting.Processing.Config Namespace


AddExtensions Method

Telerik.Reporting.Processing Send comments on this topic.
AddExtensions Method
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionCollection Class : AddExtensions Method

extensions

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddExtensions( _
   ByVal extensions As ExtensionCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionCollection
Dim extensions As ExtensionCollection

instance.AddExtensions(extensions)
C#
public void AddExtensions(
   ExtensionCollection extensions
)

Parameters

extensions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionCollection Class
ExtensionCollection Members


ContainsKey Method

Telerik.Reporting.Processing Send comments on this topic.
ContainsKey Method
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionCollection Class : ContainsKey Method

key

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
   ByVal key As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionCollection
Dim key As String
Dim value As Boolean

value = instance.ContainsKey(key)
C#
public bool ContainsKey(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionCollection Class
ExtensionCollection Members


CreateNewElement Method

Telerik.Reporting.Processing Send comments on this topic.
CreateNewElement Method
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionCollection Class : CreateNewElement Method

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
CreateNewElement() |
CreateNewElement(String) | (Inherited from System.Configuration.ConfigurationElementCollection)

Overload List

Overload | Description
CreateNewElement() |
CreateNewElement(String) | (Inherited from System.Configuration.ConfigurationElementCollection)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionCollection Class
ExtensionCollection Members


CreateNewElement() Method

Telerik.Reporting.Processing Send comments on this topic.
CreateNewElement() Method
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionCollection Class > CreateNewElement Method : CreateNewElement() Method

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Protected NotOverridable Function CreateNewElement() As ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As ExtensionCollection
Dim value As ConfigurationElement

value = instance.CreateNewElement()
C#
protected override ConfigurationElement CreateNewElement()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionCollection Class
ExtensionCollection Members
Overload List


GetElementKey Method

Telerik.Reporting.Processing Send comments on this topic.
GetElementKey Method
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionCollection Class : GetElementKey Method

element

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected NotOverridable Function GetElementKey( _
   ByVal element As ConfigurationElement _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ExtensionCollection
Dim element As ConfigurationElement
Dim value As Object

value = instance.GetElementKey(element)
C#
protected override object GetElementKey(
   ConfigurationElement element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionCollection Class
ExtensionCollection Members


ExtensionCollection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ExtensionCollection Class Properties
See Also
[image]
Telerik.Reporting.Processing.Config Namespace : ExtensionCollection Class

For a list of all members of this type, see ExtensionCollection members.

Public Properties

 | Name | Description
Public Property | CollectionType | Overridden.
Public Property | Count | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
Public Property | EmitClear | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Property | IsSynchronized | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Property | Item | Overloaded.
Public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Public Property | SyncRoot | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
Protected Property | AddElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Property | ClearElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Property | ElementName | Overridden.
Protected Property | ElementProperty | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | RemoveElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Property | ThrowOnDuplicate | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

See Also

Reference

ExtensionCollection Class
Telerik.Reporting.Processing.Config Namespace


CollectionType Property

Telerik.Reporting.Processing Send comments on this topic.
CollectionType Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionCollection Class : CollectionType Property

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable ReadOnly Property CollectionType As ConfigurationElementCollectionType
Visual Basic (Usage) Copy Code
Dim instance As ExtensionCollection
Dim value As ConfigurationElementCollectionType

value = instance.CollectionType
C#
public override ConfigurationElementCollectionType CollectionType {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionCollection Class
ExtensionCollection Members


ElementName Property

Telerik.Reporting.Processing Send comments on this topic.
ElementName Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionCollection Class : ElementName Property

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected NotOverridable ReadOnly Property ElementName As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionCollection
Dim value As String

value = instance.ElementName
C#
protected override string ElementName {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionCollection Class
ExtensionCollection Members


Item Property

Telerik.Reporting.Processing Send comments on this topic.
Item Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionCollection Class : Item Property

Overload List

Overload | Description
Item(Int32) |
Item(String) |
Item(ConfigurationProperty) | (Inherited from System.Configuration.ConfigurationElement)

Overload List

Overload | Description
Item(Int32) |
Item(String) |
Item(ConfigurationProperty) | (Inherited from System.Configuration.ConfigurationElement)

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionCollection Class
ExtensionCollection Members


Item(Int32) Property

Telerik.Reporting.Processing Send comments on this topic.
Item(Int32) Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionCollection Class > Item Property : Item(Int32) Property

index

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Property Item( _
   ByVal index As Integer _
) As ExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As ExtensionCollection
Dim index As Integer
Dim value As ExtensionElement

instance.Item(index) = value

value = instance.Item(index)
C#
public ExtensionElement Item(
   int index
) {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionCollection Class
ExtensionCollection Members
Overload List


Item(String) Property

Telerik.Reporting.Processing Send comments on this topic.
Item(String) Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionCollection Class > Item Property : Item(String) Property

name

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As ExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As ExtensionCollection
Dim name As String
Dim value As ExtensionElement

value = instance.Item(name)
C#
public ExtensionElement Item(
   string name
) {get;}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionCollection Class
ExtensionCollection Members
Overload List


ExtensionElement Class

Telerik.Reporting.Processing Send comments on this topic.
ExtensionElement Class
See Also Members
[image]
Telerik.Reporting.Processing.Config Namespace : ExtensionElement Class

Object Model

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExtensionElement
   Inherits ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As ExtensionElement
C#
public sealed class ExtensionElement : ConfigurationElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
Telerik.Reporting.Processing.Config.ExtensionElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionElement Members
Telerik.Reporting.Processing.Config Namespace


ExtensionElement Class Members

Telerik.Reporting.Processing Send comments on this topic.
ExtensionElement Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing.Config Namespace : ExtensionElement Class

The following tables list the members exposed by ExtensionElement.

Public Constructors

 | Name | Description
Public Constructor | ExtensionElement Constructor |
Top

Public Properties

 | Name | Description
Public Property | Description |
Public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Public Property | Name |
Public Property | Parameters |
Public Property | Type |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | ElementProperty | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Item | Overloaded. (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Configuration.ConfigurationElement)
Public Method | GetHashCode | (Inherited from System.Configuration.ConfigurationElement)
Public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
Protected Method | DeserializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Init | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | InitializeDefault | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ResetModified | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeToXmlElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Unmerge | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ExtensionElement Class
Telerik.Reporting.Processing.Config Namespace


ExtensionElement Constructor

Telerik.Reporting.Processing Send comments on this topic.
ExtensionElement Constructor
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionElement Class : ExtensionElement Constructor

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtensionElement()
C#
public ExtensionElement()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtensionElement()
C#
public ExtensionElement()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionElement Class
ExtensionElement Members


ExtensionElement Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ExtensionElement Class Properties
See Also
[image]
Telerik.Reporting.Processing.Config Namespace : ExtensionElement Class

For a list of all members of this type, see ExtensionElement members.

Public Properties

 | Name | Description
Public Property | Description |
Public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Public Property | Name |
Public Property | Parameters |
Public Property | Type |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | ElementProperty | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Item | Overloaded. (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ExtensionElement Class
Telerik.Reporting.Processing.Config Namespace


Description Property

Telerik.Reporting.Processing Send comments on this topic.
Description Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionElement Class : Description Property

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionElement
Dim value As String

instance.Description = value

value = instance.Description
C#
public string Description {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionElement Class
ExtensionElement Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionElement Class : Name Property

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionElement
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionElement Class
ExtensionElement Members


Parameters Property

Telerik.Reporting.Processing Send comments on this topic.
Parameters Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionElement Class : Parameters Property

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionElement
Dim value As ParameterCollection

value = instance.Parameters
C#
public ParameterCollection Parameters {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionElement Class
ExtensionElement Members


Type Property

Telerik.Reporting.Processing Send comments on this topic.
Type Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionElement Class : Type Property

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionElement
Dim value As String

instance.Type = value

value = instance.Type
C#
public string Type {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionElement Class
ExtensionElement Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionElement Class : Visible Property

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionElement
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionElement Class
ExtensionElement Members


ExtensionsSection Class

Telerik.Reporting.Processing Send comments on this topic.
ExtensionsSection Class
See Also Members
[image]
Telerik.Reporting.Processing.Config Namespace : ExtensionsSection Class

Object Model

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExtensionsSection
   Inherits ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As ExtensionsSection
C#
public sealed class ExtensionsSection : ConfigurationElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
Telerik.Reporting.Processing.Config.ExtensionsSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionsSection Members
Telerik.Reporting.Processing.Config Namespace


ExtensionsSection Class Members

Telerik.Reporting.Processing Send comments on this topic.
ExtensionsSection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing.Config Namespace : ExtensionsSection Class

The following tables list the members exposed by ExtensionsSection.

Public Constructors

 | Name | Description
Public Constructor | ExtensionsSection Constructor |
Top

Public Properties

 | Name | Description
Public Property | All | Returns all the extensions in the config file(Render, Delivery, ...)
Public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Public Property | Render |
Top

Protected Properties

 | Name | Description
Protected Property | ElementProperty | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Item | Overloaded. (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Configuration.ConfigurationElement)
Public Method | GetHashCode | (Inherited from System.Configuration.ConfigurationElement)
Public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
Protected Method | DeserializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Init | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | InitializeDefault | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ResetModified | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeToXmlElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Unmerge | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ExtensionsSection Class
Telerik.Reporting.Processing.Config Namespace


ExtensionsSection Constructor

Telerik.Reporting.Processing Send comments on this topic.
ExtensionsSection Constructor
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionsSection Class : ExtensionsSection Constructor

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtensionsSection()
C#
public ExtensionsSection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtensionsSection()
C#
public ExtensionsSection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionsSection Class
ExtensionsSection Members


ExtensionsSection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ExtensionsSection Class Properties
See Also
[image]
Telerik.Reporting.Processing.Config Namespace : ExtensionsSection Class

For a list of all members of this type, see ExtensionsSection members.

Public Properties

 | Name | Description
Public Property | All | Returns all the extensions in the config file(Render, Delivery, ...)
Public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Public Property | Render |
Top

Protected Properties

 | Name | Description
Protected Property | ElementProperty | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Item | Overloaded. (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ExtensionsSection Class
Telerik.Reporting.Processing.Config Namespace


All Property

Telerik.Reporting.Processing Send comments on this topic.
All Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionsSection Class : All Property

Returns all the extensions in the config file(Render, Delivery, ...)

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property All As ExtensionCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionsSection
Dim value As ExtensionCollection

value = instance.All
C#
public ExtensionCollection All {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionsSection Class
ExtensionsSection Members


Render Property

Telerik.Reporting.Processing Send comments on this topic.
Render Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ExtensionsSection Class : Render Property

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Render As ExtensionCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionsSection
Dim value As ExtensionCollection

value = instance.Render
C#
public ExtensionCollection Render {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtensionsSection Class
ExtensionsSection Members


ParameterCollection Class

Telerik.Reporting.Processing Send comments on this topic.
ParameterCollection Class
See Also Members
[image]
Telerik.Reporting.Processing.Config Namespace : ParameterCollection Class

Object Model

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ParameterCollection
   Inherits ConfigurationElementCollection
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection
C#
public sealed class ParameterCollection : ConfigurationElementCollection

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.Configuration.ConfigurationElementCollection
Telerik.Reporting.Processing.Config.ParameterCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Members
Telerik.Reporting.Processing.Config Namespace


ParameterCollection Class Members

Telerik.Reporting.Processing Send comments on this topic.
ParameterCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing.Config Namespace : ParameterCollection Class

The following tables list the members exposed by ParameterCollection.

Public Constructors

 | Name | Description
Public Constructor | ParameterCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | CollectionType | Overridden.
Public Property | Count | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
Public Property | EmitClear | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Property | IsSynchronized | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Property | Item | Overloaded.
Public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Public Property | SyncRoot | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
Protected Property | AddElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Property | ClearElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Property | ElementName | Overridden.
Protected Property | ElementProperty | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | RemoveElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Property | ThrowOnDuplicate | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Public Methods

 | Name | Description
Public Method | ContainsKey |
Public Method | CopyTo | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | Equals | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | GetEnumerator | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | GetHashCode | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Methods

 | Name | Description
Protected Method | BaseAdd | Overloaded. (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseClear | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseGet | Overloaded. (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseGetAllKeys | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseGetKey | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseIndexOf | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseIsRemoved | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseRemove | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseRemoveAt | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | CreateNewElement | Overloaded. Overridden.
Protected Method | DeserializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | GetElementKey | Overridden.
Protected Method | Init | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | InitializeDefault | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | IsElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | IsElementRemovable | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Reset | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | ResetModified | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | SerializeToXmlElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetReadOnly | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | Unmerge | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

See Also

Reference

ParameterCollection Class
Telerik.Reporting.Processing.Config Namespace


ParameterCollection Constructor

Telerik.Reporting.Processing Send comments on this topic.
ParameterCollection Constructor
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ParameterCollection Class : ParameterCollection Constructor

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection()
C#
public ParameterCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection()
C#
public ParameterCollection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ParameterCollection Class Methods
See Also
[image]
Telerik.Reporting.Processing.Config Namespace : ParameterCollection Class

For a list of all members of this type, see ParameterCollection members.

Public Methods

 | Name | Description
Public Method | ContainsKey |
Public Method | CopyTo | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | Equals | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | GetEnumerator | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | GetHashCode | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Methods

 | Name | Description
Protected Method | BaseAdd | Overloaded. (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseClear | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseGet | Overloaded. (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseGetAllKeys | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseGetKey | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseIndexOf | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseIsRemoved | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseRemove | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | BaseRemoveAt | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | CreateNewElement | Overloaded. Overridden.
Protected Method | DeserializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | GetElementKey | Overridden.
Protected Method | Init | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | InitializeDefault | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | IsElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | IsElementRemovable | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Reset | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | ResetModified | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | SerializeToXmlElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetReadOnly | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Method | Unmerge | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

See Also

Reference

ParameterCollection Class
Telerik.Reporting.Processing.Config Namespace


ContainsKey Method

Telerik.Reporting.Processing Send comments on this topic.
ContainsKey Method
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ParameterCollection Class : ContainsKey Method

key

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
   ByVal key As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection
Dim key As String
Dim value As Boolean

value = instance.ContainsKey(key)
C#
public bool ContainsKey(
   string key
)

Parameters

key

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Class
ParameterCollection Members


CreateNewElement Method

Telerik.Reporting.Processing Send comments on this topic.
CreateNewElement Method
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ParameterCollection Class : CreateNewElement Method

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
CreateNewElement() |
CreateNewElement(String) | (Inherited from System.Configuration.ConfigurationElementCollection)

Overload List

Overload | Description
CreateNewElement() |
CreateNewElement(String) | (Inherited from System.Configuration.ConfigurationElementCollection)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Class
ParameterCollection Members


CreateNewElement() Method

Telerik.Reporting.Processing Send comments on this topic.
CreateNewElement() Method
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ParameterCollection Class > CreateNewElement Method : CreateNewElement() Method

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Protected NotOverridable Function CreateNewElement() As ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection
Dim value As ConfigurationElement

value = instance.CreateNewElement()
C#
protected override ConfigurationElement CreateNewElement()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


GetElementKey Method

Telerik.Reporting.Processing Send comments on this topic.
GetElementKey Method
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ParameterCollection Class : GetElementKey Method

element

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected NotOverridable Function GetElementKey( _
   ByVal element As ConfigurationElement _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection
Dim element As ConfigurationElement
Dim value As Object

value = instance.GetElementKey(element)
C#
protected override object GetElementKey(
   ConfigurationElement element
)

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ParameterCollection Class Properties
See Also
[image]
Telerik.Reporting.Processing.Config Namespace : ParameterCollection Class

For a list of all members of this type, see ParameterCollection members.

Public Properties

 | Name | Description
Public Property | CollectionType | Overridden.
Public Property | Count | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
Public Property | EmitClear | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Property | IsSynchronized | (Inherited from System.Configuration.ConfigurationElementCollection)
Public Property | Item | Overloaded.
Public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Public Property | SyncRoot | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
Protected Property | AddElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Property | ClearElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Property | ElementName | Overridden.
Protected Property | ElementProperty | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | RemoveElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
Protected Property | ThrowOnDuplicate | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

See Also

Reference

ParameterCollection Class
Telerik.Reporting.Processing.Config Namespace


CollectionType Property

Telerik.Reporting.Processing Send comments on this topic.
CollectionType Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ParameterCollection Class : CollectionType Property

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable ReadOnly Property CollectionType As ConfigurationElementCollectionType
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection
Dim value As ConfigurationElementCollectionType

value = instance.CollectionType
C#
public override ConfigurationElementCollectionType CollectionType {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Class
ParameterCollection Members


ElementName Property

Telerik.Reporting.Processing Send comments on this topic.
ElementName Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ParameterCollection Class : ElementName Property

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected NotOverridable ReadOnly Property ElementName As String
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection
Dim value As String

value = instance.ElementName
C#
protected override string ElementName {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Item Property

Telerik.Reporting.Processing Send comments on this topic.
Item Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ParameterCollection Class : Item Property

Overload List

Overload | Description
Item(Int32) |
Item(String) |
Item(ConfigurationProperty) | (Inherited from System.Configuration.ConfigurationElement)

Overload List

Overload | Description
Item(Int32) |
Item(String) |
Item(ConfigurationProperty) | (Inherited from System.Configuration.ConfigurationElement)

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Class
ParameterCollection Members


Item(Int32) Property

Telerik.Reporting.Processing Send comments on this topic.
Item(Int32) Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ParameterCollection Class > Item Property : Item(Int32) Property

index

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Property Item( _
   ByVal index As Integer _
) As ParameterElement
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection
Dim index As Integer
Dim value As ParameterElement

instance.Item(index) = value

value = instance.Item(index)
C#
public ParameterElement Item(
   int index
) {get; set;}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


Item(String) Property

Telerik.Reporting.Processing Send comments on this topic.
Item(String) Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ParameterCollection Class > Item Property : Item(String) Property

name

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As ParameterElement
Visual Basic (Usage) Copy Code
Dim instance As ParameterCollection
Dim name As String
Dim value As ParameterElement

value = instance.Item(name)
C#
public ParameterElement Item(
   string name
) {get;}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


ParameterElement Class

Telerik.Reporting.Processing Send comments on this topic.
ParameterElement Class
See Also Members
[image]
Telerik.Reporting.Processing.Config Namespace : ParameterElement Class

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ParameterElement
   Inherits ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As ParameterElement
C#
public sealed class ParameterElement : ConfigurationElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
Telerik.Reporting.Processing.Config.ParameterElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterElement Members
Telerik.Reporting.Processing.Config Namespace


ParameterElement Class Members

Telerik.Reporting.Processing Send comments on this topic.
ParameterElement Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing.Config Namespace : ParameterElement Class

The following tables list the members exposed by ParameterElement.

Public Constructors

 | Name | Description
Public Constructor | ParameterElement Constructor |
Top

Public Properties

 | Name | Description
Public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Public Property | Name |
Public Property | Value |
Top

Protected Properties

 | Name | Description
Protected Property | ElementProperty | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Item | Overloaded. (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Configuration.ConfigurationElement)
Public Method | GetHashCode | (Inherited from System.Configuration.ConfigurationElement)
Public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
Protected Method | DeserializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Init | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | InitializeDefault | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ResetModified | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeToXmlElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Unmerge | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ParameterElement Class
Telerik.Reporting.Processing.Config Namespace


ParameterElement Constructor

Telerik.Reporting.Processing Send comments on this topic.
ParameterElement Constructor
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ParameterElement Class : ParameterElement Constructor

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ParameterElement()
C#
public ParameterElement()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ParameterElement()
C#
public ParameterElement()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterElement Class
ParameterElement Members


ParameterElement Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ParameterElement Class Properties
See Also
[image]
Telerik.Reporting.Processing.Config Namespace : ParameterElement Class

For a list of all members of this type, see ParameterElement members.

Public Properties

 | Name | Description
Public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Public Property | Name |
Public Property | Value |
Top

Protected Properties

 | Name | Description
Protected Property | ElementProperty | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Item | Overloaded. (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ParameterElement Class
Telerik.Reporting.Processing.Config Namespace


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ParameterElement Class : Name Property

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ParameterElement
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterElement Class
ParameterElement Members


Value Property

Telerik.Reporting.Processing Send comments on this topic.
Value Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ParameterElement Class : Value Property

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As ParameterElement
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParameterElement Class
ParameterElement Members


ReportingConfigurationSection Class

Telerik.Reporting.Processing Send comments on this topic.
ReportingConfigurationSection Class
See Also Members
[image]
Telerik.Reporting.Processing.Config Namespace : ReportingConfigurationSection Class

Object Model

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReportingConfigurationSection
   Inherits ConfigurationSection
Visual Basic (Usage) Copy Code
Dim instance As ReportingConfigurationSection
C#
public sealed class ReportingConfigurationSection : ConfigurationSection

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.Configuration.ConfigurationSection
Telerik.Reporting.Processing.Config.ReportingConfigurationSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportingConfigurationSection Members
Telerik.Reporting.Processing.Config Namespace


ReportingConfigurationSection Class Members

Telerik.Reporting.Processing Send comments on this topic.
ReportingConfigurationSection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing.Config Namespace : ReportingConfigurationSection Class

The following tables list the members exposed by ReportingConfigurationSection.

Public Constructors

 | Name | Description
Public Constructor | ReportingConfigurationSection Constructor |
Top

Public Properties

 | Name | Description
Public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
Public Property | Extensions |
Public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Public Property | SectionInformation | (Inherited from System.Configuration.ConfigurationSection)
Top

Protected Properties

 | Name | Description
Protected Property | ElementProperty | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Item | Overloaded. (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Configuration.ConfigurationElement)
Public Method | GetHashCode | (Inherited from System.Configuration.ConfigurationElement)
Public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
Protected Method | DeserializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | DeserializeSection | (Inherited from System.Configuration.ConfigurationSection)
Protected Method | GetRuntimeObject | (Inherited from System.Configuration.ConfigurationSection)
Protected Method | Init | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | InitializeDefault | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | IsModified | (Inherited from System.Configuration.ConfigurationSection)
Protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ResetModified | (Inherited from System.Configuration.ConfigurationSection)
Protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeSection | (Inherited from System.Configuration.ConfigurationSection)
Protected Method | SerializeToXmlElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Unmerge | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ReportingConfigurationSection Class
Telerik.Reporting.Processing.Config Namespace


ReportingConfigurationSection Constructor

Telerik.Reporting.Processing Send comments on this topic.
ReportingConfigurationSection Constructor
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ReportingConfigurationSection Class : ReportingConfigurationSection Constructor

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportingConfigurationSection()
C#
public ReportingConfigurationSection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportingConfigurationSection()
C#
public ReportingConfigurationSection()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportingConfigurationSection Class
ReportingConfigurationSection Members


ReportingConfigurationSection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ReportingConfigurationSection Class Properties
See Also
[image]
Telerik.Reporting.Processing.Config Namespace : ReportingConfigurationSection Class

For a list of all members of this type, see ReportingConfigurationSection members.

Public Properties

 | Name | Description
Public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
Public Property | Extensions |
Public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
Public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Public Property | SectionInformation | (Inherited from System.Configuration.ConfigurationSection)
Top

Protected Properties

 | Name | Description
Protected Property | ElementProperty | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Item | Overloaded. (Inherited from System.Configuration.ConfigurationElement)
Protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ReportingConfigurationSection Class
Telerik.Reporting.Processing.Config Namespace


Extensions Property

Telerik.Reporting.Processing Send comments on this topic.
Extensions Property
See Also
[image]
Telerik.Reporting.Processing.Config Namespace > ReportingConfigurationSection Class : Extensions Property

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Extensions As ExtensionsSection
Visual Basic (Usage) Copy Code
Dim instance As ReportingConfigurationSection
Dim value As ExtensionsSection

value = instance.Extensions
C#
public ExtensionsSection Extensions {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportingConfigurationSection Class
ReportingConfigurationSection Members


ReportParametersManager.Parameter Class

Telerik.Reporting.Processing Send comments on this topic.
ReportParametersManager.Parameter Class
See Also Members
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : ReportParametersManager.Parameter Class

Object Model

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class ReportParametersManager.Parameter
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
C#
private class ReportParametersManager.Parameter

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ReportParameters.ReportParametersManager.Parameter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Members
Telerik.Reporting.Processing.ReportParameters Namespace


ReportParametersManager.Parameter Class Members

Telerik.Reporting.Processing Send comments on this topic.
ReportParametersManager.Parameter Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : ReportParametersManager.Parameter Class

The following tables list the members exposed by ReportParametersManager.Parameter.

Public Constructors

 | Name | Description
Public Constructor | ReportParametersManager.Parameter Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | definition |
Protected Field | manager |
Top

Public Properties

 | Name | Description
Public Property | Definition |
Public Property | DependsOn |
Public Property | ForUpdate |
Public Property | HasUI |
Public Property | HasValue |
Public Property | ReadyToUpdate |
Public Property | ShouldUpdate |
Public Property | Updates |
Public Property | Value |
Top

Public Methods

 | Name | Description
Public Method | CreateExpressionContext |
Public Method | DetermineDependencies |
Public Method | GetParametersToUpdate |
Public Method | Initialize |
Public Method | MarkForUpdateRecursive |
Public Method | ReadValue |
Public Method | ToString | Overridden.
Public Method | ValueExpression |
Top

Protected Methods

 | Name | Description
Protected Method | AddDependencies |
Top

See Also

Reference

ReportParametersManager.Parameter Class
Telerik.Reporting.Processing.ReportParameters Namespace


ReportParametersManager.Parameter Constructor

Telerik.Reporting.Processing Send comments on this topic.
ReportParametersManager.Parameter Constructor
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : ReportParametersManager.Parameter Constructor

parameter
manager

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameter As ReportParameter, _
   ByVal manager As ReportParametersManager _
)
Visual Basic (Usage) Copy Code
Dim parameter As ReportParameter
Dim manager As ReportParametersManager

Dim instance As ReportParametersManager.Parameter(parameter, manager)
C#
public ReportParametersManager.Parameter(
   ReportParameter parameter,
   ReportParametersManager manager
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameter As ReportParameter, _
   ByVal manager As ReportParametersManager _
)
Visual Basic (Usage) Copy Code
Dim parameter As ReportParameter
Dim manager As ReportParametersManager

Dim instance As ReportParametersManager.Parameter(parameter, manager)
C#
public ReportParametersManager.Parameter(
   ReportParameter parameter,
   ReportParametersManager manager
)

Parameters

parameter
manager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


ReportParametersManager.Parameter Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ReportParametersManager.Parameter Class Methods
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : ReportParametersManager.Parameter Class

For a list of all members of this type, see ReportParametersManager.Parameter members.

Public Methods

 | Name | Description
Public Method | CreateExpressionContext |
Public Method | DetermineDependencies |
Public Method | GetParametersToUpdate |
Public Method | Initialize |
Public Method | MarkForUpdateRecursive |
Public Method | ReadValue |
Public Method | ToString | Overridden.
Public Method | ValueExpression |
Top

Protected Methods

 | Name | Description
Protected Method | AddDependencies |
Top

See Also

Reference

ReportParametersManager.Parameter Class
Telerik.Reporting.Processing.ReportParameters Namespace


AddDependencies Method

Telerik.Reporting.Processing Send comments on this topic.
AddDependencies Method
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : AddDependencies Method

expression
parameters

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub AddDependencies( _
   ByVal expression As String, _
   ByVal parameters As ReportParametersManager.ParameterCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim expression As String
Dim parameters As ReportParametersManager.ParameterCollection

instance.AddDependencies(expression, parameters)
C#
protected void AddDependencies(
   string expression,
   ReportParametersManager.ParameterCollection parameters
)

Parameters

expression
parameters

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


CreateExpressionContext Method

Telerik.Reporting.Processing Send comments on this topic.
CreateExpressionContext Method
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : CreateExpressionContext Method

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateExpressionContext() As Object
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As Object

value = instance.CreateExpressionContext()
C#
public object CreateExpressionContext()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


DetermineDependencies Method

Telerik.Reporting.Processing Send comments on this topic.
DetermineDependencies Method
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : DetermineDependencies Method

parameters

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub DetermineDependencies( _
   ByVal parameters As ReportParametersManager.ParameterCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim parameters As ReportParametersManager.ParameterCollection

instance.DetermineDependencies(parameters)
C#
public virtual void DetermineDependencies(
   ReportParametersManager.ParameterCollection parameters
)

Parameters

parameters

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


GetParametersToUpdate Method

Telerik.Reporting.Processing Send comments on this topic.
GetParametersToUpdate Method
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : GetParametersToUpdate Method

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function GetParametersToUpdate() As IEnumerable(Of ReportParametersManager.Parameter)
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As IEnumerable(Of ReportParametersManager.Parameter)

value = instance.GetParametersToUpdate()
C#
public IEnumerable<ReportParametersManager.Parameter> GetParametersToUpdate()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


Initialize Method

Telerik.Reporting.Processing Send comments on this topic.
Initialize Method
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : Initialize Method

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Initialize()
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter

instance.Initialize()
C#
public virtual void Initialize()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


MarkForUpdateRecursive Method

Telerik.Reporting.Processing Send comments on this topic.
MarkForUpdateRecursive Method
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : MarkForUpdateRecursive Method

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub MarkForUpdateRecursive()
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter

instance.MarkForUpdateRecursive()
C#
public void MarkForUpdateRecursive()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


ReadValue Method

Telerik.Reporting.Processing Send comments on this topic.
ReadValue Method
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : ReadValue Method

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ReadValue()
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter

instance.ReadValue()
C#
public virtual void ReadValue()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : ToString Method

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


ValueExpression Method

Telerik.Reporting.Processing Send comments on this topic.
ValueExpression Method
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : ValueExpression Method

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ValueExpression() As String
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As String

value = instance.ValueExpression()
C#
public string ValueExpression()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


ReportParametersManager.Parameter Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ReportParametersManager.Parameter Class Properties
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : ReportParametersManager.Parameter Class

For a list of all members of this type, see ReportParametersManager.Parameter members.

Public Properties

 | Name | Description
Public Property | Definition |
Public Property | DependsOn |
Public Property | ForUpdate |
Public Property | HasUI |
Public Property | HasValue |
Public Property | ReadyToUpdate |
Public Property | ShouldUpdate |
Public Property | Updates |
Public Property | Value |
Top

See Also

Reference

ReportParametersManager.Parameter Class
Telerik.Reporting.Processing.ReportParameters Namespace


definition Field

Telerik.Reporting.Processing Send comments on this topic.
definition Field
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : definition Field

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly definition As ReportParameter
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As ReportParameter

value = instance.definition
C#
protected readonly ReportParameter definition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


DependsOn Property

Telerik.Reporting.Processing Send comments on this topic.
DependsOn Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : DependsOn Property

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependsOn As List(Of ReportParametersManager.Parameter)
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As List(Of ReportParametersManager.Parameter)

value = instance.DependsOn
C#
public List<ReportParametersManager.Parameter> DependsOn {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


ForUpdate Property

Telerik.Reporting.Processing Send comments on this topic.
ForUpdate Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : ForUpdate Property

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property ForUpdate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As Boolean

instance.ForUpdate = value

value = instance.ForUpdate
C#
public bool ForUpdate {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


HasUI Property

Telerik.Reporting.Processing Send comments on this topic.
HasUI Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : HasUI Property

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasUI As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As Boolean

value = instance.HasUI
C#
public bool HasUI {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


HasValue Property

Telerik.Reporting.Processing Send comments on this topic.
HasValue Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : HasValue Property

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasValue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As Boolean

value = instance.HasValue
C#
public bool HasValue {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


ReadyToUpdate Property

Telerik.Reporting.Processing Send comments on this topic.
ReadyToUpdate Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : ReadyToUpdate Property

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReadyToUpdate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As Boolean

value = instance.ReadyToUpdate
C#
public bool ReadyToUpdate {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


ShouldUpdate Property

Telerik.Reporting.Processing Send comments on this topic.
ShouldUpdate Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : ShouldUpdate Property

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShouldUpdate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As Boolean

value = instance.ShouldUpdate
C#
public bool ShouldUpdate {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


Updates Property

Telerik.Reporting.Processing Send comments on this topic.
Updates Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : Updates Property

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Updates As List(Of ReportParametersManager.Parameter)
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As List(Of ReportParametersManager.Parameter)

value = instance.Updates
C#
public List<ReportParametersManager.Parameter> Updates {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


Value Property

Telerik.Reporting.Processing Send comments on this topic.
Value Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : Value Property

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As Object

value = instance.Value
C#
public virtual object Value {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


ReportParametersManager.Parameter Class Fields

Telerik.Reporting.Processing Send comments on this topic.
ReportParametersManager.Parameter Class Fields
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : ReportParametersManager.Parameter Class

For a list of all members of this type, see ReportParametersManager.Parameter members.

Protected Fields

 | Name | Description
Protected Field | definition |
Protected Field | manager |
Top

See Also

Reference

ReportParametersManager.Parameter Class
Telerik.Reporting.Processing.ReportParameters Namespace


manager Field

Telerik.Reporting.Processing Send comments on this topic.
manager Field
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.Parameter Class : manager Field

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly manager As ReportParametersManager
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.Parameter
Dim value As ReportParametersManager

value = instance.manager
C#
protected readonly ReportParametersManager manager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.Parameter Class
ReportParametersManager.Parameter Members


ReportParametersManager.ParameterCollection Class

Telerik.Reporting.Processing Send comments on this topic.
ReportParametersManager.ParameterCollection Class
See Also Members
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : ReportParametersManager.ParameterCollection Class

Object Model

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class ReportParametersManager.ParameterCollection
   Inherits Collection(Of ReportParametersManager.Parameter)
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.ParameterCollection
C#
private class ReportParametersManager.ParameterCollection : Collection<ReportParametersManager.Parameter>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>
Telerik.Reporting.Processing.ReportParameters.ReportParametersManager.ParameterCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.ParameterCollection Members
Telerik.Reporting.Processing.ReportParameters Namespace


ReportParametersManager.ParameterCollection Class Members

Telerik.Reporting.Processing Send comments on this topic.
ReportParametersManager.ParameterCollection Class Members
See Also Properties Methods
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : ReportParametersManager.ParameterCollection Class

The following tables list the members exposed by ReportParametersManager.ParameterCollection.

Public Constructors

 | Name | Description
Public Constructor | ReportParametersManager.ParameterCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Property | Item | Overloaded.
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | GetRootParameters | Returns parameters that do not depend on any other parameter (root parameters)
Public Method | IndexOf | Overloaded.
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Top

See Also

Reference

ReportParametersManager.ParameterCollection Class
Telerik.Reporting.Processing.ReportParameters Namespace


ReportParametersManager.ParameterCollection Constructor

Telerik.Reporting.Processing Send comments on this topic.
ReportParametersManager.ParameterCollection Constructor
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.ParameterCollection Class : ReportParametersManager.ParameterCollection Constructor

parameterCollection
manager

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterCollection As IEnumerable(Of ReportParameter), _
   ByVal manager As ReportParametersManager _
)
Visual Basic (Usage) Copy Code
Dim parameterCollection As IEnumerable(Of ReportParameter)
Dim manager As ReportParametersManager

Dim instance As ReportParametersManager.ParameterCollection(parameterCollection, manager)
C#
public ReportParametersManager.ParameterCollection(
   IEnumerable<ReportParameter> parameterCollection,
   ReportParametersManager manager
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterCollection As IEnumerable(Of ReportParameter), _
   ByVal manager As ReportParametersManager _
)
Visual Basic (Usage) Copy Code
Dim parameterCollection As IEnumerable(Of ReportParameter)
Dim manager As ReportParametersManager

Dim instance As ReportParametersManager.ParameterCollection(parameterCollection, manager)
C#
public ReportParametersManager.ParameterCollection(
   IEnumerable<ReportParameter> parameterCollection,
   ReportParametersManager manager
)

Parameters

parameterCollection
manager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.ParameterCollection Class
ReportParametersManager.ParameterCollection Members


ReportParametersManager.ParameterCollection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ReportParametersManager.ParameterCollection Class Methods
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : ReportParametersManager.ParameterCollection Class

For a list of all members of this type, see ReportParametersManager.ParameterCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | GetRootParameters | Returns parameters that do not depend on any other parameter (root parameters)
Public Method | IndexOf | Overloaded.
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Top

See Also

Reference

ReportParametersManager.ParameterCollection Class
Telerik.Reporting.Processing.ReportParameters Namespace


GetRootParameters Method

Telerik.Reporting.Processing Send comments on this topic.
GetRootParameters Method
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.ParameterCollection Class : GetRootParameters Method

Returns parameters that do not depend on any other parameter (root parameters)

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function GetRootParameters() As IEnumerable(Of ReportParametersManager.Parameter)
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.ParameterCollection
Dim value As IEnumerable(Of ReportParametersManager.Parameter)

value = instance.GetRootParameters()
C#
public IEnumerable<ReportParametersManager.Parameter> GetRootParameters()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.ParameterCollection Class
ReportParametersManager.ParameterCollection Members


IndexOf Method

Telerik.Reporting.Processing Send comments on this topic.
IndexOf Method
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.ParameterCollection Class : IndexOf Method

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
IndexOf(String) |
IndexOf(Parameter) | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)

Overload List

Overload | Description
IndexOf(String) |
IndexOf(Parameter) | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.ParameterCollection Class
ReportParametersManager.ParameterCollection Members


IndexOf(String) Method

Telerik.Reporting.Processing Send comments on this topic.
IndexOf(String) Method
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.ParameterCollection Class > IndexOf Method : IndexOf(String) Method

name

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.ParameterCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public int IndexOf(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.ParameterCollection Class
ReportParametersManager.ParameterCollection Members
Overload List


ReportParametersManager.ParameterCollection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ReportParametersManager.ParameterCollection Class Properties
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : ReportParametersManager.ParameterCollection Class

For a list of all members of this type, see ReportParametersManager.ParameterCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Public Property | Item | Overloaded.
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)
Top

See Also

Reference

ReportParametersManager.ParameterCollection Class
Telerik.Reporting.Processing.ReportParameters Namespace


Item Property

Telerik.Reporting.Processing Send comments on this topic.
Item Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.ParameterCollection Class : Item Property

Overload List

Overload | Description
Item(String) |
Item(Int32) | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)

Overload List

Overload | Description
Item(String) |
Item(Int32) | (Inherited from System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>)

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.ParameterCollection Class
ReportParametersManager.ParameterCollection Members


Item(String) Property

Telerik.Reporting.Processing Send comments on this topic.
Item(String) Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > ReportParametersManager.ParameterCollection Class > Item Property : Item(String) Property

name

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As ReportParametersManager.Parameter
Visual Basic (Usage) Copy Code
Dim instance As ReportParametersManager.ParameterCollection
Dim name As String
Dim value As ReportParametersManager.Parameter

value = instance.Item(name)
C#
public ReportParametersManager.Parameter Item(
   string name
) {get;}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportParametersManager.ParameterCollection Class
ReportParametersManager.ParameterCollection Members
Overload List


IReportParameterEditor Interface

Telerik.Reporting.Processing Send comments on this topic.
IReportParameterEditor Interface
See Also Members
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : IReportParameterEditor Interface

Represents an control that serves as editor shown on from the report viewer to allow entering of values of a parameter.
Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Interface IReportParameterEditor
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditor
C#
public interface IReportParameterEditor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditor Members
Telerik.Reporting.Processing.ReportParameters Namespace


IReportParameterEditor Interface Members

Telerik.Reporting.Processing Send comments on this topic.
IReportParameterEditor Interface Members
See Also Properties Methods Events
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : IReportParameterEditor Interface

The following tables list the members exposed by IReportParameterEditor.

Public Properties

 | Name | Description
Property | Name | Gets the Name of the parameter that the editor represents.
Property | Text | Gets the Text to be displayed as label of the editor.
Property | Value | Gets the value for the current parameter.
Top

Public Methods

 | Name | Description
Method | Initialize | Initializes the editor with a context object containing the parameter's UI settings
Top

Public Events

 | Name | Description
Event | ValueChange | Occurs when the value for the current parameter has changed.
Top

See Also

Reference

IReportParameterEditor Interface
Telerik.Reporting.Processing.ReportParameters Namespace


IReportParameterEditor Interface Methods

Telerik.Reporting.Processing Send comments on this topic.
IReportParameterEditor Interface Methods
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : IReportParameterEditor Interface

For a list of all members of this type, see IReportParameterEditor members.

Public Methods

 | Name | Description
Method | Initialize | Initializes the editor with a context object containing the parameter's UI settings
Top

See Also

Reference

IReportParameterEditor Interface
Telerik.Reporting.Processing.ReportParameters Namespace


Initialize Method

Telerik.Reporting.Processing Send comments on this topic.
Initialize Method
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditor Interface : Initialize Method

parameterEditorContext
Initializes the editor with a context object containing the parameter's UI settings

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Sub Initialize( _
   ByVal parameterEditorContext As IReportParameterEditorContext _
)
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditor
Dim parameterEditorContext As IReportParameterEditorContext

instance.Initialize(parameterEditorContext)
C#
void Initialize(
   IReportParameterEditorContext parameterEditorContext
)

Parameters

parameterEditorContext

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditor Interface
IReportParameterEditor Members


IReportParameterEditor Interface Properties

Telerik.Reporting.Processing Send comments on this topic.
IReportParameterEditor Interface Properties
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : IReportParameterEditor Interface

For a list of all members of this type, see IReportParameterEditor members.

Public Properties

 | Name | Description
Property | Name | Gets the Name of the parameter that the editor represents.
Property | Text | Gets the Text to be displayed as label of the editor.
Property | Value | Gets the value for the current parameter.
Top

See Also

Reference

IReportParameterEditor Interface
Telerik.Reporting.Processing.ReportParameters Namespace


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditor Interface : Name Property

Gets the Name of the parameter that the editor represents.

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditor
Dim value As String

value = instance.Name
C#
string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditor Interface
IReportParameterEditor Members


Text Property

Telerik.Reporting.Processing Send comments on this topic.
Text Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditor Interface : Text Property

Gets the Text to be displayed as label of the editor.

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditor
Dim value As String

value = instance.Text
C#
string Text {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditor Interface
IReportParameterEditor Members


Value Property

Telerik.Reporting.Processing Send comments on this topic.
Value Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditor Interface : Value Property

Gets the value for the current parameter.

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditor
Dim value As Object

value = instance.Value
C#
object Value {get;}

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Throws exception if the editor does not contain valid value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditor Interface
IReportParameterEditor Members


IReportParameterEditor Interface Events

Telerik.Reporting.Processing Send comments on this topic.
IReportParameterEditor Interface Events
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : IReportParameterEditor Interface

For a list of all members of this type, see IReportParameterEditor members.

Public Events

 | Name | Description
Event | ValueChange | Occurs when the value for the current parameter has changed.
Top

See Also

Reference

IReportParameterEditor Interface
Telerik.Reporting.Processing.ReportParameters Namespace


ValueChange Event

Telerik.Reporting.Processing Send comments on this topic.
ValueChange Event
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditor Interface : ValueChange Event

Occurs when the value for the current parameter has changed.

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Event ValueChange() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditor
Dim handler As EventHandler

AddHandler instance.ValueChange, handler
C#
event EventHandler ValueChange()

Syntax

Visual Basic (Declaration)
Event ValueChange() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditor
Dim handler As EventHandler

AddHandler instance.ValueChange, handler
C#
event EventHandler ValueChange()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditor Interface
IReportParameterEditor Members


IReportParameterEditorContext Interface

Telerik.Reporting.Processing Send comments on this topic.
IReportParameterEditorContext Interface
See Also Members
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : IReportParameterEditorContext Interface

Represents object that keeps the UI settings foar a parameter and is used to initialize a parameter editor
Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Interface IReportParameterEditorContext
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditorContext
C#
public interface IReportParameterEditorContext

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditorContext Members
Telerik.Reporting.Processing.ReportParameters Namespace
IReportParameterEditor Interface


IReportParameterEditorContext Interface Members

Telerik.Reporting.Processing Send comments on this topic.
IReportParameterEditorContext Interface Members
See Also Properties
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : IReportParameterEditorContext Interface

The following tables list the members exposed by IReportParameterEditorContext.

Public Properties

 | Name | Description
Property | AllowBlank | Determines if when the parameter is of type string it is allowed blank string to be entered
Property | AllowNull | Determines if the parameter allows no value to be passed from it's editor.
Property | AvailableValues | Gets a DataView used as predefined values that user can choose from
Property | AvailableValuesDisplayMember | Gets a string that specifies the column of the AvailableValues from which to draw the value labels.
Property | AvailableValuesValueMember | Gets a string that specifies the column of the AvailableValues from which to draw the value.
Property | DefaultValues | Gets a DataView used as initial values for the parameters
Property | DefaultValuesValueMember | Gets a string that specifies the column of the DefaultValues from which to draw the value.
Property | MultiValue | Determines if the editor allows more then one value to be entered for the parameter.
Property | Name | Gets the name of the parameter
Property | Text | Gets or sets the text for the parameter to be displayed in the editor.
Property | Type | Gets the type of the parameter
Property | Visible | Determines if the editor is visible ???? do we need this
Top

See Also

Reference

IReportParameterEditorContext Interface
Telerik.Reporting.Processing.ReportParameters Namespace
IReportParameterEditor Interface


IReportParameterEditorContext Interface Properties

Telerik.Reporting.Processing Send comments on this topic.
IReportParameterEditorContext Interface Properties
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace : IReportParameterEditorContext Interface

For a list of all members of this type, see IReportParameterEditorContext members.

Public Properties

 | Name | Description
Property | AllowBlank | Determines if when the parameter is of type string it is allowed blank string to be entered
Property | AllowNull | Determines if the parameter allows no value to be passed from it's editor.
Property | AvailableValues | Gets a DataView used as predefined values that user can choose from
Property | AvailableValuesDisplayMember | Gets a string that specifies the column of the AvailableValues from which to draw the value labels.
Property | AvailableValuesValueMember | Gets a string that specifies the column of the AvailableValues from which to draw the value.
Property | DefaultValues | Gets a DataView used as initial values for the parameters
Property | DefaultValuesValueMember | Gets a string that specifies the column of the DefaultValues from which to draw the value.
Property | MultiValue | Determines if the editor allows more then one value to be entered for the parameter.
Property | Name | Gets the name of the parameter
Property | Text | Gets or sets the text for the parameter to be displayed in the editor.
Property | Type | Gets the type of the parameter
Property | Visible | Determines if the editor is visible ???? do we need this
Top

See Also

Reference

IReportParameterEditorContext Interface
Telerik.Reporting.Processing.ReportParameters Namespace
IReportParameterEditor Interface


AllowBlank Property

Telerik.Reporting.Processing Send comments on this topic.
AllowBlank Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditorContext Interface : AllowBlank Property

Determines if when the parameter is of type string it is allowed blank string to be entered

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AllowBlank As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditorContext
Dim value As Boolean

value = instance.AllowBlank
C#
bool AllowBlank {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditorContext Interface
IReportParameterEditorContext Members


AllowNull Property

Telerik.Reporting.Processing Send comments on this topic.
AllowNull Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditorContext Interface : AllowNull Property

Determines if the parameter allows no value to be passed from it's editor.

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AllowNull As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditorContext
Dim value As Boolean

value = instance.AllowNull
C#
bool AllowNull {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditorContext Interface
IReportParameterEditorContext Members


AvailableValues Property

Telerik.Reporting.Processing Send comments on this topic.
AvailableValues Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditorContext Interface : AvailableValues Property

Gets a DataView used as predefined values that user can choose from

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AvailableValues As DataView
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditorContext
Dim value As DataView

value = instance.AvailableValues
C#
DataView AvailableValues {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditorContext Interface
IReportParameterEditorContext Members


AvailableValuesDisplayMember Property

Telerik.Reporting.Processing Send comments on this topic.
AvailableValuesDisplayMember Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditorContext Interface : AvailableValuesDisplayMember Property

Gets a string that specifies the column of the AvailableValues from which to draw the value labels.

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AvailableValuesDisplayMember As String
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditorContext
Dim value As String

value = instance.AvailableValuesDisplayMember
C#
string AvailableValuesDisplayMember {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditorContext Interface
IReportParameterEditorContext Members


AvailableValuesValueMember Property

Telerik.Reporting.Processing Send comments on this topic.
AvailableValuesValueMember Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditorContext Interface : AvailableValuesValueMember Property

Gets a string that specifies the column of the AvailableValues from which to draw the value.

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AvailableValuesValueMember As String
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditorContext
Dim value As String

value = instance.AvailableValuesValueMember
C#
string AvailableValuesValueMember {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditorContext Interface
IReportParameterEditorContext Members


DefaultValues Property

Telerik.Reporting.Processing Send comments on this topic.
DefaultValues Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditorContext Interface : DefaultValues Property

Gets a DataView used as initial values for the parameters

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DefaultValues As DataView
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditorContext
Dim value As DataView

value = instance.DefaultValues
C#
DataView DefaultValues {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditorContext Interface
IReportParameterEditorContext Members


DefaultValuesValueMember Property

Telerik.Reporting.Processing Send comments on this topic.
DefaultValuesValueMember Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditorContext Interface : DefaultValuesValueMember Property

Gets a string that specifies the column of the DefaultValues from which to draw the value.

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DefaultValuesValueMember As String
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditorContext
Dim value As String

value = instance.DefaultValuesValueMember
C#
string DefaultValuesValueMember {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditorContext Interface
IReportParameterEditorContext Members


MultiValue Property

Telerik.Reporting.Processing Send comments on this topic.
MultiValue Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditorContext Interface : MultiValue Property

Determines if the editor allows more then one value to be entered for the parameter.

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property MultiValue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditorContext
Dim value As Boolean

value = instance.MultiValue
C#
bool MultiValue {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditorContext Interface
IReportParameterEditorContext Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditorContext Interface : Name Property

Gets the name of the parameter

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditorContext
Dim value As String

value = instance.Name
C#
string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditorContext Interface
IReportParameterEditorContext Members


Text Property

Telerik.Reporting.Processing Send comments on this topic.
Text Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditorContext Interface : Text Property

Gets or sets the text for the parameter to be displayed in the editor.

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditorContext
Dim value As String

value = instance.Text
C#
string Text {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditorContext Interface
IReportParameterEditorContext Members


Type Property

Telerik.Reporting.Processing Send comments on this topic.
Type Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditorContext Interface : Type Property

Gets the type of the parameter

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As ReportParameterType
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditorContext
Dim value As ReportParameterType

value = instance.Type
C#
ReportParameterType Type {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditorContext Interface
IReportParameterEditorContext Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.Processing.ReportParameters Namespace > IReportParameterEditorContext Interface : Visible Property

Determines if the editor is visible ???? do we need this

Namespace: Telerik.Reporting.Processing.ReportParameters
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IReportParameterEditorContext
Dim value As Boolean

value = instance.Visible
C#
bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IReportParameterEditorContext Interface
IReportParameterEditorContext Members


Barcode Class

Telerik.Reporting.Processing Send comments on this topic.
Barcode Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : Barcode Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Barcode
   Inherits Barcode
   Implements IPictureContainer
Visual Basic (Usage) Copy Code
Dim instance As Barcode
C#
private class Barcode : Barcode, IPictureContainer

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.RenderingItem
Telerik.Reporting.ImageRendering.ReportItem
Telerik.Reporting.ImageRendering.Barcode
Telerik.Reporting.RtfRendering.Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Members
Telerik.Reporting.RtfRendering Namespace


Barcode Class Members

Telerik.Reporting.Processing Send comments on this topic.
Barcode Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : Barcode Class

The following tables list the members exposed by Barcode.

Public Constructors

 | Name | Description
Public Constructor | Barcode Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | Overridden.
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CreateMetafile | (Inherited from Telerik.Reporting.ImageRendering.Barcode)
Protected Method | Dispose |
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportItem)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

Barcode Class
Telerik.Reporting.RtfRendering Namespace


Barcode Constructor

Telerik.Reporting.Processing Send comments on this topic.
Barcode Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Barcode Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As Barcode(source, parent, composition)
C#
public Barcode(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As Barcode(source, parent, composition)
C#
public Barcode(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Barcode Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Barcode Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | Overridden.
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CreateMetafile | (Inherited from Telerik.Reporting.ImageRendering.Barcode)
Protected Method | Dispose |
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportItem)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

Barcode Class
Telerik.Reporting.RtfRendering Namespace


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As Barcode

instance.Init()
C#
public override void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As Barcode

instance.Render()
C#
protected override void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As Barcode

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Barcode Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Barcode Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

Barcode Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


CanvasRtf Class

Telerik.Reporting.Processing Send comments on this topic.
CanvasRtf Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : CanvasRtf Class

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class CanvasRtf
   Inherits CanvasBase
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
C#
private class CanvasRtf : CanvasBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.CanvasBase
Telerik.Reporting.RtfRendering.CanvasRtf

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Members
Telerik.Reporting.RtfRendering Namespace


CanvasRtf Class Members

Telerik.Reporting.Processing Send comments on this topic.
CanvasRtf Class Members
See Also Fields Methods
[image]
Telerik.Reporting.RtfRendering Namespace : CanvasRtf Class

The following tables list the members exposed by CanvasRtf.

Public Constructors

 | Name | Description
Public Constructor | CanvasRtf Constructor |
Top

Public Fields

 | Name | Description
Public Field | composition | (Inherited from Telerik.Reporting.ImageRendering.CanvasBase)
Top

Protected Fields

 | Name | Description
Protected Field | graphics | (Inherited from Telerik.Reporting.ImageRendering.CanvasBase)
Top

Public Methods

 | Name | Description
Public Method | AddFrameOnPage |
Public Method | CreateBaseFrame |
Public Method | CreateErrorFrame |
static (Shared in Visual Basic) | NeedsFrame |
Public Method | SetBackground |
Public Method | SetBorders |
Public Method | SetImage |
Top

Protected Methods

 | Name | Description
Protected Method | DrawBackgroundImage | (Inherited from Telerik.Reporting.ImageRendering.CanvasBase)
Protected Method | DrawImage | Overloaded. Overridden.
Protected Method | DrawPolygon | Overridden.
Protected Method | DrawRectangle | Overridden.
Protected Method | FillPolygon | Overridden.
Protected Method | FillRectangle | Overridden.
Top

See Also

Reference

CanvasRtf Class
Telerik.Reporting.RtfRendering Namespace


CanvasRtf Constructor

Telerik.Reporting.Processing Send comments on this topic.
CanvasRtf Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : CanvasRtf Constructor

composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim composition As CompositionBase

Dim instance As CanvasRtf(composition)
C#
public CanvasRtf(
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim composition As CompositionBase

Dim instance As CanvasRtf(composition)
C#
public CanvasRtf(
   CompositionBase composition
)

Parameters

composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


CanvasRtf Class Methods

Telerik.Reporting.Processing Send comments on this topic.
CanvasRtf Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : CanvasRtf Class

For a list of all members of this type, see CanvasRtf members.

Public Methods

 | Name | Description
Public Method | AddFrameOnPage |
Public Method | CreateBaseFrame |
Public Method | CreateErrorFrame |
static (Shared in Visual Basic) | NeedsFrame |
Public Method | SetBackground |
Public Method | SetBorders |
Public Method | SetImage |
Top

Protected Methods

 | Name | Description
Protected Method | DrawBackgroundImage | (Inherited from Telerik.Reporting.ImageRendering.CanvasBase)
Protected Method | DrawImage | Overloaded. Overridden.
Protected Method | DrawPolygon | Overridden.
Protected Method | DrawRectangle | Overridden.
Protected Method | FillPolygon | Overridden.
Protected Method | FillRectangle | Overridden.
Top

See Also

Reference

CanvasRtf Class
Telerik.Reporting.RtfRendering Namespace


AddFrameOnPage Method

Telerik.Reporting.Processing Send comments on this topic.
AddFrameOnPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : AddFrameOnPage Method

destRect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function AddFrameOnPage( _
   ByVal destRect As RectangleF _
) As Frame
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim destRect As RectangleF
Dim value As Frame

value = instance.AddFrameOnPage(destRect)
C#
public Frame AddFrameOnPage(
   RectangleF destRect
)

Parameters

destRect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


CreateBaseFrame Method

Telerik.Reporting.Processing Send comments on this topic.
CreateBaseFrame Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : CreateBaseFrame Method

el

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateBaseFrame( _
   ByVal el As RenderingElement _
) As Frame
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim el As RenderingElement
Dim value As Frame

value = instance.CreateBaseFrame(el)
C#
public Frame CreateBaseFrame(
   RenderingElement el
)

Parameters

el

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


CreateErrorFrame Method

Telerik.Reporting.Processing Send comments on this topic.
CreateErrorFrame Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : CreateErrorFrame Method

error
el
font
format

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateErrorFrame( _
   ByVal error As String, _
   ByVal el As RenderingElement, _
   ByVal font As Font, _
   ByVal format As StringFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim error As String
Dim el As RenderingElement
Dim font As Font
Dim format As StringFormat

instance.CreateErrorFrame(error, el, font, format)
C#
public void CreateErrorFrame(
   string error,
   RenderingElement el,
   Font font,
   StringFormat format
)

Parameters

error
el
font
format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


DrawImage Method

Telerik.Reporting.Processing Send comments on this topic.
DrawImage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : DrawImage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Overload List

Overload | Description
DrawImage(Image,RectangleF,RectangleF) |
DrawImage(Image,RectangleF,ImageSizeMode) | (Inherited from Telerik.Reporting.ImageRendering.CanvasBase)

Overload List

Overload | Description
DrawImage(Image,RectangleF,RectangleF) |
DrawImage(Image,RectangleF,ImageSizeMode) | (Inherited from Telerik.Reporting.ImageRendering.CanvasBase)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


DrawImage(Image,RectangleF,RectangleF) Method

Telerik.Reporting.Processing Send comments on this topic.
DrawImage(Image,RectangleF,RectangleF) Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class > DrawImage Method : DrawImage(Image,RectangleF,RectangleF) Method

image
destRectMm
srcRectPx

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Protected Sub DrawImage( _
   ByVal image As Image, _
   ByVal destRectMm As RectangleF, _
   ByVal srcRectPx As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim image As Image
Dim destRectMm As RectangleF
Dim srcRectPx As RectangleF

instance.DrawImage(image, destRectMm, srcRectPx)
C#
protected override void DrawImage(
   Image image,
   RectangleF destRectMm,
   RectangleF srcRectPx
)

Parameters

image
destRectMm
srcRectPx

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members
Overload List


DrawPolygon Method

Telerik.Reporting.Processing Send comments on this topic.
DrawPolygon Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : DrawPolygon Method

pen
points

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub DrawPolygon( _
   ByVal pen As Pen, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim pen As Pen
Dim points() As PointF

instance.DrawPolygon(pen, points)
C#
protected override void DrawPolygon(
   Pen pen,
   PointF[] points
)

Parameters

pen
points

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


DrawRectangle Method

Telerik.Reporting.Processing Send comments on this topic.
DrawRectangle Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : DrawRectangle Method

pen
rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub DrawRectangle( _
   ByVal pen As Pen, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim pen As Pen
Dim rect As RectangleF

instance.DrawRectangle(pen, rect)
C#
protected override void DrawRectangle(
   Pen pen,
   RectangleF rect
)

Parameters

pen
rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


FillPolygon Method

Telerik.Reporting.Processing Send comments on this topic.
FillPolygon Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : FillPolygon Method

brush
points

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub FillPolygon( _
   ByVal brush As Brush, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim brush As Brush
Dim points() As PointF

instance.FillPolygon(brush, points)
C#
protected override void FillPolygon(
   Brush brush,
   PointF[] points
)

Parameters

brush
points

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


FillRectangle Method

Telerik.Reporting.Processing Send comments on this topic.
FillRectangle Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : FillRectangle Method

brush
destRect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub FillRectangle( _
   ByVal brush As Brush, _
   ByVal destRect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim brush As Brush
Dim destRect As RectangleF

instance.FillRectangle(brush, destRect)
C#
protected override void FillRectangle(
   Brush brush,
   RectangleF destRect
)

Parameters

brush
destRect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


NeedsFrame Method

Telerik.Reporting.Processing Send comments on this topic.
NeedsFrame Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : NeedsFrame Method

el

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function NeedsFrame( _
   ByVal el As RenderingElement _
) As Boolean
Visual Basic (Usage) Copy Code
Dim el As RenderingElement
Dim value As Boolean

value = CanvasRtf.NeedsFrame(el)
C#
public static bool NeedsFrame(
   RenderingElement el
)

Parameters

el

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


SetBackground Method

Telerik.Reporting.Processing Send comments on this topic.
SetBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : SetBackground Method

frame
style

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetBackground( _
   ByVal frame As Frame, _
   ByVal style As Style _
)
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim frame As Frame
Dim style As Style

instance.SetBackground(frame, style)
C#
public void SetBackground(
   Frame frame,
   Style style
)

Parameters

frame
style

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


SetBorders Method

Telerik.Reporting.Processing Send comments on this topic.
SetBorders Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : SetBorders Method

frame
style
rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetBorders( _
   ByVal frame As Frame, _
   ByVal style As Style, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim frame As Frame
Dim style As Style
Dim rect As RectangleF

instance.SetBorders(frame, style, rect)
C#
public void SetBorders(
   Frame frame,
   Style style,
   RectangleF rect
)

Parameters

frame
style
rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


SetImage Method

Telerik.Reporting.Processing Send comments on this topic.
SetImage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : SetImage Method

frame
pictureContainer

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetImage( _
   ByVal frame As Frame, _
   ByVal pictureContainer As IPictureContainer _
)
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim frame As Frame
Dim pictureContainer As IPictureContainer

instance.SetImage(frame, pictureContainer)
C#
public void SetImage(
   Frame frame,
   IPictureContainer pictureContainer
)

Parameters

frame
pictureContainer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


Chart Class

Telerik.Reporting.Processing Send comments on this topic.
Chart Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : Chart Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Chart
   Inherits Chart
   Implements IPictureContainer
Visual Basic (Usage) Copy Code
Dim instance As Chart
C#
private class Chart : Chart, IPictureContainer

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.RenderingItem
Telerik.Reporting.ImageRendering.ReportItem
Telerik.Reporting.ImageRendering.Chart
Telerik.Reporting.RtfRendering.Chart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Members
Telerik.Reporting.RtfRendering Namespace


Chart Class Members

Telerik.Reporting.Processing Send comments on this topic.
Chart Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : Chart Class

The following tables list the members exposed by Chart.

Public Constructors

 | Name | Description
Public Constructor | Chart Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportItem)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

Chart Class
Telerik.Reporting.RtfRendering Namespace


Chart Constructor

Telerik.Reporting.Processing Send comments on this topic.
Chart Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Chart Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As Chart(source, parent, composition)
C#
public Chart(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As Chart(source, parent, composition)
C#
public Chart(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Chart Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Chart Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportItem)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

Chart Class
Telerik.Reporting.RtfRendering Namespace


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As Chart

instance.Render()
C#
protected override void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As Chart

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Chart Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Chart Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

Chart Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


CheckBox Class

Telerik.Reporting.Processing Send comments on this topic.
CheckBox Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : CheckBox Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class CheckBox
   Inherits CheckBox
   Implements IPictureContainer, ITextContainer, ITextBuilder
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
C#
private class CheckBox : CheckBox, IPictureContainer, ITextContainer, ITextBuilder

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.RenderingItem
Telerik.Reporting.ImageRendering.ReportItem
Telerik.Reporting.ImageRendering.CheckBox
Telerik.Reporting.RtfRendering.CheckBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Members
Telerik.Reporting.RtfRendering Namespace


CheckBox Class Members

Telerik.Reporting.Processing Send comments on this topic.
CheckBox Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : CheckBox Class

The following tables list the members exposed by CheckBox.

Public Constructors

 | Name | Description
Public Constructor | CheckBox Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.CheckBox)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | Overridden.
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.CheckBox)
Protected Method | EndRender | Overridden.
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.CheckBox)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

CheckBox Class
Telerik.Reporting.RtfRendering Namespace


CheckBox Constructor

Telerik.Reporting.Processing Send comments on this topic.
CheckBox Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : CheckBox Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As CheckBox(source, parent, composition)
C#
public CheckBox(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As CheckBox(source, parent, composition)
C#
public CheckBox(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Class Methods

Telerik.Reporting.Processing Send comments on this topic.
CheckBox Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.CheckBox)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | Overridden.
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.CheckBox)
Protected Method | EndRender | Overridden.
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.CheckBox)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

CheckBox Class
Telerik.Reporting.RtfRendering Namespace


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As CheckBox

instance.BeginRender()
C#
protected override void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As CheckBox

instance.EndRender()
C#
protected override void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As CheckBox

instance.Render()
C#
protected override void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As CheckBox

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Class Properties

Telerik.Reporting.Processing Send comments on this topic.
CheckBox Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

CheckBox Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CompositionRtf Class

Telerik.Reporting.Processing Send comments on this topic.
CompositionRtf Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : CompositionRtf Class

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class CompositionRtf
   Inherits CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
C#
private class CompositionRtf : CompositionBase

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.CompositionBase
Telerik.Reporting.RtfRendering.CompositionRtf

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Members
Telerik.Reporting.RtfRendering Namespace


CompositionRtf Class Members

Telerik.Reporting.Processing Send comments on this topic.
CompositionRtf Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : CompositionRtf Class

The following tables list the members exposed by CompositionRtf.

Public Fields

 | Name | Description
Public Field | CurrentVertPosition | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Top

Protected Fields

 | Name | Description
Protected Field | currentColumnIndex | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Protected Field | pageEmpty | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Protected Field | pageSaved | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Top

Public Properties

 | Name | Description
Public Property | CurrentBottom | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Property | CurrentHeight | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Property | CurrentLeft | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Property | CurrentPage |
Public Property | CurrentRight | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Property | CurrentTop | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Property | CurrentWidth | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Property | PageNumber | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Top

Protected Properties

 | Name | Description
Protected Property | Canvas | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Top

Public Methods

 | Name | Description
Public Method | CreateElement | Overridden.
Public Method | MarkPageNonEmpty | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStream | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Protected Method | Dispose |
Protected Method | DrawTrialMessage | Overridden.
Protected Method | End | Overridden.
Protected Method | NewPhysicalPage | Overridden.
Protected Method | SendPhysicalPages | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Top

See Also

Reference

CompositionRtf Class
Telerik.Reporting.RtfRendering Namespace


CompositionRtf Class Methods

Telerik.Reporting.Processing Send comments on this topic.
CompositionRtf Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : CompositionRtf Class

For a list of all members of this type, see CompositionRtf members.

Public Methods

 | Name | Description
Public Method | CreateElement | Overridden.
Public Method | MarkPageNonEmpty | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateStream | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Protected Method | Dispose |
Protected Method | DrawTrialMessage | Overridden.
Protected Method | End | Overridden.
Protected Method | NewPhysicalPage | Overridden.
Protected Method | SendPhysicalPages | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Top

See Also

Reference

CompositionRtf Class
Telerik.Reporting.RtfRendering Namespace


CreateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CreateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : CreateElement Method

item
parent

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function CreateElement( _
   ByVal item As Object, _
   ByVal parent As RenderingElement _
) As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim item As Object
Dim parent As RenderingElement
Dim value As RenderingElement

value = instance.CreateElement(item, parent)
C#
public override RenderingElement CreateElement(
   object item,
   RenderingElement parent
)

Parameters

item
parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


DrawTrialMessage Method

Telerik.Reporting.Processing Send comments on this topic.
DrawTrialMessage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : DrawTrialMessage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub DrawTrialMessage()
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf

instance.DrawTrialMessage()
C#
protected override void DrawTrialMessage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


End Method

Telerik.Reporting.Processing Send comments on this topic.
End Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : End Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub End()
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf

instance.End()
C#
protected override void End()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


NewPhysicalPage Method

Telerik.Reporting.Processing Send comments on this topic.
NewPhysicalPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : NewPhysicalPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub NewPhysicalPage()
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf

instance.NewPhysicalPage()
C#
protected override void NewPhysicalPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


CompositionRtf Class Properties

Telerik.Reporting.Processing Send comments on this topic.
CompositionRtf Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : CompositionRtf Class

For a list of all members of this type, see CompositionRtf members.

Public Properties

 | Name | Description
Public Property | CurrentBottom | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Property | CurrentHeight | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Property | CurrentLeft | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Property | CurrentPage |
Public Property | CurrentRight | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Property | CurrentTop | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Property | CurrentWidth | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Public Property | PageNumber | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Top

Protected Properties

 | Name | Description
Protected Property | Canvas | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Top

See Also

Reference

CompositionRtf Class
Telerik.Reporting.RtfRendering Namespace


CurrentPage Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPage Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : CurrentPage Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentPage As Page
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As Page

value = instance.CurrentPage
C#
public Page CurrentPage {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


DetailSection Class

Telerik.Reporting.Processing Send comments on this topic.
DetailSection Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : DetailSection Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class DetailSection
   Inherits DetailSection
   Implements IGroupItem
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
C#
private class DetailSection : DetailSection, IGroupItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.RenderingItem
Telerik.Reporting.ImageRendering.ReportSectionBase
Telerik.Reporting.ImageRendering.ReportSection
Telerik.Reporting.ImageRendering.DetailSection
Telerik.Reporting.RtfRendering.DetailSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Members
Telerik.Reporting.RtfRendering Namespace


DetailSection Class Members

Telerik.Reporting.Processing Send comments on this topic.
DetailSection Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : DetailSection Class

The following tables list the members exposed by DetailSection.

Public Constructors

 | Name | Description
Public Constructor | DetailSection Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.ReportSection)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ShouldKeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

DetailSection Class
Telerik.Reporting.RtfRendering Namespace


DetailSection Constructor

Telerik.Reporting.Processing Send comments on this topic.
DetailSection Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : DetailSection Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As DetailSection(source, parent, composition)
C#
public DetailSection(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As DetailSection(source, parent, composition)
C#
public DetailSection(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


DetailSection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
DetailSection Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : DetailSection Class

For a list of all members of this type, see DetailSection members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

DetailSection Class
Telerik.Reporting.RtfRendering Namespace


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As DetailSection

instance.Render()
C#
protected override void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As DetailSection

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


DetailSection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
DetailSection Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : DetailSection Class

For a list of all members of this type, see DetailSection members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.ReportSection)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ShouldKeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

DetailSection Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Group Class

Telerik.Reporting.Processing Send comments on this topic.
Group Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : Group Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Group
   Inherits Group
   Implements IGroupItem
Visual Basic (Usage) Copy Code
Dim instance As Group
C#
private class Group : Group, IGroupItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.Group
Telerik.Reporting.RtfRendering.Group

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Members
Telerik.Reporting.RtfRendering Namespace


Group Class Members

Telerik.Reporting.Processing Send comments on this topic.
Group Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : Group Class

The following tables list the members exposed by Group.

Public Constructors

 | Name | Description
Public Constructor | Group Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Footer | (Inherited from Telerik.Reporting.ImageRendering.Group)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Header | (Inherited from Telerik.Reporting.ImageRendering.Group)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.Group)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.Group)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.Group)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.Group)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.Group)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.Group)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.Group)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.Group)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

Group Class
Telerik.Reporting.RtfRendering Namespace


Group Constructor

Telerik.Reporting.Processing Send comments on this topic.
Group Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Group Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As Group(source, parent, composition)
C#
public Group(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As Group(source, parent, composition)
C#
public Group(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Group Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Group Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Group Class

For a list of all members of this type, see Group members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.Group)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.Group)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.Group)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.Group)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.Group)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

Group Class
Telerik.Reporting.RtfRendering Namespace


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As Group

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Group Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Group Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Group Class

For a list of all members of this type, see Group members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Footer | (Inherited from Telerik.Reporting.ImageRendering.Group)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Header | (Inherited from Telerik.Reporting.ImageRendering.Group)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.Group)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.Group)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.Group)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

Group Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


GroupSection Class

Telerik.Reporting.Processing Send comments on this topic.
GroupSection Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : GroupSection Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class GroupSection
   Inherits GroupSection
   Implements IGroupItem
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
C#
private class GroupSection : GroupSection, IGroupItem

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.RenderingItem
Telerik.Reporting.ImageRendering.ReportSectionBase
Telerik.Reporting.ImageRendering.ReportSection
Telerik.Reporting.ImageRendering.GroupSection
Telerik.Reporting.RtfRendering.GroupSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Members
Telerik.Reporting.RtfRendering Namespace


GroupSection Class Members

Telerik.Reporting.Processing Send comments on this topic.
GroupSection Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : GroupSection Class

The following tables list the members exposed by GroupSection.

Public Constructors

 | Name | Description
Public Constructor | GroupSection Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.ReportSection)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PrintOnEveryPage | (Inherited from Telerik.Reporting.ImageRendering.GroupSection)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ShouldKeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

GroupSection Class
Telerik.Reporting.RtfRendering Namespace


GroupSection Constructor

Telerik.Reporting.Processing Send comments on this topic.
GroupSection Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : GroupSection Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ReportItemBase, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ReportItemBase
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As GroupSection(source, parent, composition)
C#
public GroupSection(
   ReportItemBase source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ReportItemBase, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ReportItemBase
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As GroupSection(source, parent, composition)
C#
public GroupSection(
   ReportItemBase source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


GroupSection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
GroupSection Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : GroupSection Class

For a list of all members of this type, see GroupSection members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

GroupSection Class
Telerik.Reporting.RtfRendering Namespace


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As GroupSection

instance.Render()
C#
protected override void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As GroupSection

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


GroupSection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
GroupSection Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : GroupSection Class

For a list of all members of this type, see GroupSection members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.ReportSection)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PrintOnEveryPage | (Inherited from Telerik.Reporting.ImageRendering.GroupSection)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ShouldKeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

GroupSection Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


PageSection Class

Telerik.Reporting.Processing Send comments on this topic.
PageSection Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : PageSection Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class PageSection
   Inherits PageSection
Visual Basic (Usage) Copy Code
Dim instance As PageSection
C#
private class PageSection : PageSection

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.RenderingItem
Telerik.Reporting.ImageRendering.ReportSectionBase
Telerik.Reporting.ImageRendering.PageSection
Telerik.Reporting.RtfRendering.PageSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Members
Telerik.Reporting.RtfRendering Namespace


PageSection Class Members

Telerik.Reporting.Processing Send comments on this topic.
PageSection Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : PageSection Class

The following tables list the members exposed by PageSection.

Public Constructors

 | Name | Description
Public Constructor | PageSection Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ShouldKeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.PageSection)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

PageSection Class
Telerik.Reporting.RtfRendering Namespace


PageSection Constructor

Telerik.Reporting.Processing Send comments on this topic.
PageSection Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : PageSection Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As PageSection(source, parent, composition)
C#
public PageSection(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As PageSection(source, parent, composition)
C#
public PageSection(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


PageSection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
PageSection Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : PageSection Class

For a list of all members of this type, see PageSection members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.PageSection)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

PageSection Class
Telerik.Reporting.RtfRendering Namespace


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As PageSection

instance.Render()
C#
protected override void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As PageSection

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


PageSection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
PageSection Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : PageSection Class

For a list of all members of this type, see PageSection members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ShouldKeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

PageSection Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Panel Class

Telerik.Reporting.Processing Send comments on this topic.
Panel Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : Panel Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Panel
   Inherits Panel
Visual Basic (Usage) Copy Code
Dim instance As Panel
C#
private class Panel : Panel

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.RenderingItem
Telerik.Reporting.ImageRendering.ReportItem
Telerik.Reporting.ImageRendering.Panel
Telerik.Reporting.RtfRendering.Panel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Members
Telerik.Reporting.RtfRendering Namespace


Panel Class Members

Telerik.Reporting.Processing Send comments on this topic.
Panel Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : Panel Class

The following tables list the members exposed by Panel.

Public Constructors

 | Name | Description
Public Constructor | Panel Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportItem)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

Panel Class
Telerik.Reporting.RtfRendering Namespace


Panel Constructor

Telerik.Reporting.Processing Send comments on this topic.
Panel Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Panel Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As Panel(source, parent, composition)
C#
public Panel(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As Panel(source, parent, composition)
C#
public Panel(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Panel Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Panel Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Panel Class

For a list of all members of this type, see Panel members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportItem)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

Panel Class
Telerik.Reporting.RtfRendering Namespace


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As Panel

instance.Render()
C#
protected override void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As Panel

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Panel Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Panel Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Panel Class

For a list of all members of this type, see Panel members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

Panel Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


PictureBox Class

Telerik.Reporting.Processing Send comments on this topic.
PictureBox Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : PictureBox Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class PictureBox
   Inherits PictureBox
   Implements IPictureContainer
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
C#
private class PictureBox : PictureBox, IPictureContainer

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.RenderingItem
Telerik.Reporting.ImageRendering.ReportItem
Telerik.Reporting.ImageRendering.PictureBox
Telerik.Reporting.RtfRendering.PictureBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Members
Telerik.Reporting.RtfRendering Namespace


PictureBox Class Members

Telerik.Reporting.Processing Send comments on this topic.
PictureBox Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : PictureBox Class

The following tables list the members exposed by PictureBox.

Public Constructors

 | Name | Description
Public Constructor | PictureBox Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.PictureBox)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportItem)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

PictureBox Class
Telerik.Reporting.RtfRendering Namespace


PictureBox Constructor

Telerik.Reporting.Processing Send comments on this topic.
PictureBox Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : PictureBox Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As PictureBox(source, parent, composition)
C#
public PictureBox(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As PictureBox(source, parent, composition)
C#
public PictureBox(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


PictureBox Class Methods

Telerik.Reporting.Processing Send comments on this topic.
PictureBox Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : PictureBox Class

For a list of all members of this type, see PictureBox members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.PictureBox)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportItem)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

PictureBox Class
Telerik.Reporting.RtfRendering Namespace


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As PictureBox

instance.Render()
C#
protected override void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As PictureBox

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


PictureBox Class Properties

Telerik.Reporting.Processing Send comments on this topic.
PictureBox Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : PictureBox Class

For a list of all members of this type, see PictureBox members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

PictureBox Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Report Class

Telerik.Reporting.Processing Send comments on this topic.
Report Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : Report Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Report
   Inherits Report
Visual Basic (Usage) Copy Code
Dim instance As Report
C#
private class Report : Report

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.RenderingItem
Telerik.Reporting.ImageRendering.Report
Telerik.Reporting.RtfRendering.Report

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Members
Telerik.Reporting.RtfRendering Namespace


Report Class Members

Telerik.Reporting.Processing Send comments on this topic.
Report Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : Report Class

The following tables list the members exposed by Report.

Public Constructors

 | Name | Description
Public Constructor | Report Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.Report)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

Report Class
Telerik.Reporting.RtfRendering Namespace


Report Constructor

Telerik.Reporting.Processing Send comments on this topic.
Report Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Report Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As Report(source, parent, composition)
C#
public Report(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As Report(source, parent, composition)
C#
public Report(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Report Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Report Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Report Class

For a list of all members of this type, see Report members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.Report)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

Report Class
Telerik.Reporting.RtfRendering Namespace


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As Report

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Report Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Report Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Report Class

For a list of all members of this type, see Report members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

Report Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ReportSection Class

Telerik.Reporting.Processing Send comments on this topic.
ReportSection Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : ReportSection Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class ReportSection
   Inherits ReportSection
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
C#
private class ReportSection : ReportSection

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.RenderingItem
Telerik.Reporting.ImageRendering.ReportSectionBase
Telerik.Reporting.ImageRendering.ReportSection
Telerik.Reporting.RtfRendering.ReportSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Members
Telerik.Reporting.RtfRendering Namespace


ReportSection Class Members

Telerik.Reporting.Processing Send comments on this topic.
ReportSection Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : ReportSection Class

The following tables list the members exposed by ReportSection.

Public Constructors

 | Name | Description
Public Constructor | ReportSection Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.ReportSection)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ShouldKeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

ReportSection Class
Telerik.Reporting.RtfRendering Namespace


ReportSection Constructor

Telerik.Reporting.Processing Send comments on this topic.
ReportSection Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : ReportSection Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As ReportSection(source, parent, composition)
C#
public ReportSection(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As ReportSection(source, parent, composition)
C#
public ReportSection(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ReportSection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ReportSection Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : ReportSection Class

For a list of all members of this type, see ReportSection members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

ReportSection Class
Telerik.Reporting.RtfRendering Namespace


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As ReportSection

instance.Render()
C#
protected override void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As ReportSection

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ReportSection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ReportSection Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : ReportSection Class

For a list of all members of this type, see ReportSection members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.ReportSection)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ShouldKeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportSectionBase)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

ReportSection Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


RtfReport Class

Telerik.Reporting.Processing Send comments on this topic.
RtfReport Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : RtfReport Class

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Class RtfReport
   Inherits ImageRendererBase
   Implements IExtension, IRenderingExtension
Visual Basic (Usage) Copy Code
Dim instance As RtfReport
C#
public class RtfReport : ImageRendererBase, IExtension, IRenderingExtension

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.ImageRendererBase
Telerik.Reporting.RtfRendering.RtfReport

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RtfReport Members
Telerik.Reporting.RtfRendering Namespace


RtfReport Class Members

Telerik.Reporting.Processing Send comments on this topic.
RtfReport Class Members
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : RtfReport Class

The following tables list the members exposed by RtfReport.

Public Constructors

 | Name | Description
Public Constructor | RtfReport Constructor |
Top

See Also

Reference

RtfReport Class
Telerik.Reporting.RtfRendering Namespace


RtfReport Constructor

Telerik.Reporting.Processing Send comments on this topic.
RtfReport Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > RtfReport Class : RtfReport Constructor

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RtfReport()
C#
public RtfReport()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RtfReport()
C#
public RtfReport()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RtfReport Class
RtfReport Members


Shape Class

Telerik.Reporting.Processing Send comments on this topic.
Shape Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : Shape Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class Shape
   Inherits Shape
   Implements IPictureContainer, INoBackground
Visual Basic (Usage) Copy Code
Dim instance As Shape
C#
private class Shape : Shape, IPictureContainer, INoBackground

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.RenderingItem
Telerik.Reporting.ImageRendering.ReportItem
Telerik.Reporting.ImageRendering.Shape
Telerik.Reporting.RtfRendering.Shape

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Members
Telerik.Reporting.RtfRendering Namespace


Shape Class Members

Telerik.Reporting.Processing Send comments on this topic.
Shape Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : Shape Class

The following tables list the members exposed by Shape.

Public Constructors

 | Name | Description
Public Constructor | Shape Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | Overridden.
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose |
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportItem)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

Shape Class
Telerik.Reporting.RtfRendering Namespace


Shape Constructor

Telerik.Reporting.Processing Send comments on this topic.
Shape Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Shape Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As Shape(source, parent, composition)
C#
public Shape(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As Shape(source, parent, composition)
C#
public Shape(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Shape Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Shape Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Shape Class

For a list of all members of this type, see Shape members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | Overridden.
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose |
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.ReportItem)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

Shape Class
Telerik.Reporting.RtfRendering Namespace


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As Shape

instance.Init()
C#
public override void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As Shape

instance.Render()
C#
protected override void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As Shape

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Shape Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Shape Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Shape Class

For a list of all members of this type, see Shape members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

Shape Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


SubReport Class

Telerik.Reporting.Processing Send comments on this topic.
SubReport Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : SubReport Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class SubReport
   Inherits RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As SubReport
C#
private class SubReport : RenderingElement

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.RtfRendering.SubReport

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Members
Telerik.Reporting.RtfRendering Namespace


SubReport Class Members

Telerik.Reporting.Processing Send comments on this topic.
SubReport Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : SubReport Class

The following tables list the members exposed by SubReport.

Public Constructors

 | Name | Description
Public Constructor | SubReport Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

SubReport Class
Telerik.Reporting.RtfRendering Namespace


SubReport Constructor

Telerik.Reporting.Processing Send comments on this topic.
SubReport Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : SubReport Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As SubReport(source, parent, composition)
C#
public SubReport(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As SubReport(source, parent, composition)
C#
public SubReport(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


SubReport Class Methods

Telerik.Reporting.Processing Send comments on this topic.
SubReport Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : SubReport Class

For a list of all members of this type, see SubReport members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

SubReport Class
Telerik.Reporting.RtfRendering Namespace


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As SubReport

instance.Render()
C#
protected override void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As SubReport

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


SubReport Class Properties

Telerik.Reporting.Processing Send comments on this topic.
SubReport Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : SubReport Class

For a list of all members of this type, see SubReport members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

SubReport Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


TextBox Class

Telerik.Reporting.Processing Send comments on this topic.
TextBox Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : TextBox Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class TextBox
   Inherits TextBox
   Implements ITextContainer, ITextBuilder
Visual Basic (Usage) Copy Code
Dim instance As TextBox
C#
private class TextBox : TextBox, ITextContainer, ITextBuilder

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.RenderingItem
Telerik.Reporting.ImageRendering.ReportItem
Telerik.Reporting.ImageRendering.TextBox
Telerik.Reporting.RtfRendering.TextBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Members
Telerik.Reporting.RtfRendering Namespace


TextBox Class Members

Telerik.Reporting.Processing Send comments on this topic.
TextBox Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : TextBox Class

The following tables list the members exposed by TextBox.

Public Constructors

 | Name | Description
Public Constructor | TextBox Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.TextBox)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | Overridden.
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.TextBox)
Protected Method | EndRender | Overridden.
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.TextBox)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

TextBox Class
Telerik.Reporting.RtfRendering Namespace


TextBox Constructor

Telerik.Reporting.Processing Send comments on this topic.
TextBox Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : TextBox Constructor

source
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As TextBox(source, parent, composition)
C#
public TextBox(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ProcessingElement, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim source As ProcessingElement
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As TextBox(source, parent, composition)
C#
public TextBox(
   ProcessingElement source,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

source
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


TextBox Class Methods

Telerik.Reporting.Processing Send comments on this topic.
TextBox Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.TextBox)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | Overridden.
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.TextBox)
Protected Method | EndRender | Overridden.
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.TextBox)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | Overridden.
Top

See Also

Reference

TextBox Class
Telerik.Reporting.RtfRendering Namespace


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As TextBox

instance.BeginRender()
C#
protected override void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As TextBox

instance.EndRender()
C#
protected override void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As TextBox

instance.Render()
C#
protected override void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As TextBox

instance.RenderError()
C#
protected override void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


TextBox Class Properties

Telerik.Reporting.Processing Send comments on this topic.
TextBox Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Top

See Also

Reference

TextBox Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


TextLine Class

Telerik.Reporting.Processing Send comments on this topic.
TextLine Class
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : TextLine Class

Object Model

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Class TextLine
   Inherits TextLine
Visual Basic (Usage) Copy Code
Dim instance As TextLine
C#
private class TextLine : TextLine

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.TextLine
Telerik.Reporting.RtfRendering.TextLine

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Members
Telerik.Reporting.RtfRendering Namespace


TextLine Class Members

Telerik.Reporting.Processing Send comments on this topic.
TextLine Class Members
See Also Fields Properties Methods
[image]
Telerik.Reporting.RtfRendering Namespace : TextLine Class

The following tables list the members exposed by TextLine.

Public Constructors

 | Name | Description
Public Constructor | TextLine Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.TextLine)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Protected Property | Text | (Inherited from Telerik.Reporting.ImageRendering.TextLine)
Top

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

TextLine Class
Telerik.Reporting.RtfRendering Namespace


TextLine Constructor

Telerik.Reporting.Processing Send comments on this topic.
TextLine Constructor
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : TextLine Constructor

text
bounds
parent
composition

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal bounds As RectangleF, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim bounds As RectangleF
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As TextLine(text, bounds, parent, composition)
C#
public TextLine(
   string text,
   RectangleF bounds,
   RenderingElement parent,
   CompositionBase composition
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As String, _
   ByVal bounds As RectangleF, _
   ByVal parent As RenderingElement, _
   ByVal composition As CompositionBase _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim bounds As RectangleF
Dim parent As RenderingElement
Dim composition As CompositionBase

Dim instance As TextLine(text, bounds, parent, composition)
C#
public TextLine(
   string text,
   RectangleF bounds,
   RenderingElement parent,
   CompositionBase composition
)

Parameters

text
bounds
parent
composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


TextLine Class Methods

Telerik.Reporting.Processing Send comments on this topic.
TextLine Class Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : TextLine Class

For a list of all members of this type, see TextLine members.

Public Methods

 | Name | Description
Public Method | CalculatePage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ClipToPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | Init | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToAbsolute | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | RectangleToClient | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Method | ToString | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Methods

 | Name | Description
Protected Method | BeginRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | CalculateElement | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Dispose | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EndRender | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | EnumParents | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | KeepTogether | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToLeftOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | MoveToTopOfNextPage | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | Render | Overridden.
Protected Method | RenderBackground | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderBorder | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Method | RenderError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

TextLine Class
Telerik.Reporting.RtfRendering Namespace


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As TextLine

instance.Render()
C#
protected override void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


TextLine Class Properties

Telerik.Reporting.Processing Send comments on this topic.
TextLine Class Properties
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : TextLine Class

For a list of all members of this type, see TextLine members.

Public Properties

 | Name | Description
Public Property | AbsoluteBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteBounds | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | AbsoluteTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Bottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientRectangle | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ClientSize | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Composition | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Done | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | HasError | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Height | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Items | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ItemsAbove | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Left | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Name | (Inherited from Telerik.Reporting.ImageRendering.TextLine)
Public Property | PadBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PadTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | PageBreak | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Parent | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedBottomSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | ReservedTopSpace | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Right | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Style | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Top | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Visible | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Public Property | Width | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

Protected Properties

 | Name | Description
Protected Property | CurrentPageBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageLeft | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageRight | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | CurrentPageTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ItemsVertIndex | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedBottom | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | ReservedTop | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | Source | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Protected Property | SupportsBackground | Overridden.
Protected Property | SupportsBorder | Overridden.
Protected Property | Text | (Inherited from Telerik.Reporting.ImageRendering.TextLine)
Top

See Also

Reference

TextLine Class
Telerik.Reporting.RtfRendering Namespace


SupportsBackground Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBackground Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : SupportsBackground Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBackground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As Boolean

value = instance.SupportsBackground
C#
protected override bool SupportsBackground {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


SupportsBorder Property

Telerik.Reporting.Processing Send comments on this topic.
SupportsBorder Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : SupportsBorder Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property SupportsBorder As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As Boolean

value = instance.SupportsBorder
C#
protected override bool SupportsBorder {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


INoBackground Interface

Telerik.Reporting.Processing Send comments on this topic.
INoBackground Interface
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : INoBackground Interface

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Interface INoBackground
Visual Basic (Usage) Copy Code
Dim instance As INoBackground
C#
private interface INoBackground

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

INoBackground Members
Telerik.Reporting.RtfRendering Namespace


INoBackground Interface Members

Telerik.Reporting.Processing Send comments on this topic.
INoBackground Interface Members
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : INoBackground Interface

The following tables list the members exposed by INoBackground.

See Also

Reference

INoBackground Interface
Telerik.Reporting.RtfRendering Namespace


ITextBuilder Interface

Telerik.Reporting.Processing Send comments on this topic.
ITextBuilder Interface
See Also Members
[image]
Telerik.Reporting.RtfRendering Namespace : ITextBuilder Interface

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Interface ITextBuilder
Visual Basic (Usage) Copy Code
Dim instance As ITextBuilder
C#
private interface ITextBuilder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ITextBuilder Members
Telerik.Reporting.RtfRendering Namespace


ITextBuilder Interface Members

Telerik.Reporting.Processing Send comments on this topic.
ITextBuilder Interface Members
See Also Methods
[image]
Telerik.Reporting.RtfRendering Namespace : ITextBuilder Interface

The following tables list the members exposed by ITextBuilder.

Public Methods

 | Name | Description
Method | AppendLine |
Top

See Also

Reference

ITextBuilder Interface
Telerik.Reporting.RtfRendering Namespace


ITextBuilder Interface Methods

Telerik.Reporting.Processing Send comments on this topic.
ITextBuilder Interface Methods
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : ITextBuilder Interface

For a list of all members of this type, see ITextBuilder members.

Public Methods

 | Name | Description
Method | AppendLine |
Top

See Also

Reference

ITextBuilder Interface
Telerik.Reporting.RtfRendering Namespace


AppendLine Method

Telerik.Reporting.Processing Send comments on this topic.
AppendLine Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ITextBuilder Interface : AppendLine Method

text

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Sub AppendLine( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ITextBuilder
Dim text As String

instance.AppendLine(text)
C#
void AppendLine(
   string text
)

Parameters

text

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ITextBuilder Interface
ITextBuilder Members


AjaxHelper Class

Telerik.ReportViewer.WebForms Send comments on this topic.
AjaxHelper Class
See Also Members
[image]
Telerik.ReportViewer.WebForms Namespace : AjaxHelper Class

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Private MustInherit NotInheritable Class AjaxHelper
Visual Basic (Usage) Copy Code
Dim instance As AjaxHelper
C#
private static class AjaxHelper

Inheritance Hierarchy

System.Object
Telerik.ReportViewer.WebForms.AjaxHelper

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxHelper Members
Telerik.ReportViewer.WebForms Namespace


AjaxHelper Class Members

Telerik.ReportViewer.WebForms Send comments on this topic.
AjaxHelper Class Members
See Also Properties Methods
[image]
Telerik.ReportViewer.WebForms Namespace : AjaxHelper Class

The following tables list the members exposed by AjaxHelper.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | IsAspNetAjaxRequest |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | RegisterClientScriptInclude |
static (Shared in Visual Basic) | RegisterStartupScript |
Top

See Also

Reference

AjaxHelper Class
Telerik.ReportViewer.WebForms Namespace


AjaxHelper Class Methods

Telerik.ReportViewer.WebForms Send comments on this topic.
AjaxHelper Class Methods
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : AjaxHelper Class

For a list of all members of this type, see AjaxHelper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | RegisterClientScriptInclude |
static (Shared in Visual Basic) | RegisterStartupScript |
Top

See Also

Reference

AjaxHelper Class
Telerik.ReportViewer.WebForms Namespace


RegisterClientScriptInclude Method

Telerik.ReportViewer.WebForms Send comments on this topic.
RegisterClientScriptInclude Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > AjaxHelper Class : RegisterClientScriptInclude Method

control
script
scriptFileUrl

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub RegisterClientScriptInclude( _
   ByVal control As Control, _
   ByVal script As String, _
   ByVal scriptFileUrl As String _
)
Visual Basic (Usage) Copy Code
Dim control As Control
Dim script As String
Dim scriptFileUrl As String

AjaxHelper.RegisterClientScriptInclude(control, script, scriptFileUrl)
C#
public static void RegisterClientScriptInclude(
   Control control,
   string script,
   string scriptFileUrl
)

Parameters

control
script
scriptFileUrl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxHelper Class
AjaxHelper Members


RegisterStartupScript Method

Telerik.ReportViewer.WebForms Send comments on this topic.
RegisterStartupScript Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > AjaxHelper Class : RegisterStartupScript Method

control
key
script
renderTags

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub RegisterStartupScript( _
   ByVal control As Control, _
   ByVal key As String, _
   ByVal script As String, _
   ByVal renderTags As Boolean _
)
Visual Basic (Usage) Copy Code
Dim control As Control
Dim key As String
Dim script As String
Dim renderTags As Boolean

AjaxHelper.RegisterStartupScript(control, key, script, renderTags)
C#
public static void RegisterStartupScript(
   Control control,
   string key,
   string script,
   bool renderTags
)

Parameters

control
key
script
renderTags

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxHelper Class
AjaxHelper Members


AjaxHelper Class Properties

Telerik.ReportViewer.WebForms Send comments on this topic.
AjaxHelper Class Properties
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : AjaxHelper Class

For a list of all members of this type, see AjaxHelper members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | IsAspNetAjaxRequest |
Top

See Also

Reference

AjaxHelper Class
Telerik.ReportViewer.WebForms Namespace


IsAspNetAjaxRequest Property

Telerik.ReportViewer.WebForms Send comments on this topic.
IsAspNetAjaxRequest Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > AjaxHelper Class : IsAspNetAjaxRequest Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IsAspNetAjaxRequest As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = AjaxHelper.IsAspNetAjaxRequest
C#
public static bool IsAspNetAjaxRequest {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AjaxHelper Class
AjaxHelper Members


Constants Class

Telerik.ReportViewer.WebForms Send comments on this topic.
Constants Class
See Also Members
[image]
Telerik.ReportViewer.WebForms Namespace : Constants Class

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Private MustInherit NotInheritable Class Constants
Visual Basic (Usage) Copy Code
Dim instance As Constants
C#
private static class Constants

Inheritance Hierarchy

System.Object
Telerik.ReportViewer.WebForms.Constants

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Constants Members
Telerik.ReportViewer.WebForms Namespace


Constants Class Members

Telerik.ReportViewer.WebForms Send comments on this topic.
Constants Class Members
See Also Fields
[image]
Telerik.ReportViewer.WebForms Namespace : Constants Class

The following tables list the members exposed by Constants.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ReportViewerDesigner |
Top

See Also

Reference

Constants Class
Telerik.ReportViewer.WebForms Namespace


Constants Class Fields

Telerik.ReportViewer.WebForms Send comments on this topic.
Constants Class Fields
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : Constants Class

For a list of all members of this type, see Constants members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ReportViewerDesigner |
Top

See Also

Reference

Constants Class
Telerik.ReportViewer.WebForms Namespace


ReportViewerDesigner Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportViewerDesigner Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Constants Class : ReportViewerDesigner Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportViewerDesigner As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Constants.ReportViewerDesigner

Constants.ReportViewerDesigner = value
C#
public static string ReportViewerDesigner

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Constants Class
Constants Members


HttpHandler Class

Telerik.ReportViewer.WebForms Send comments on this topic.
HttpHandler Class
See Also Members
[image]
Telerik.ReportViewer.WebForms Namespace : HttpHandler Class

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Class HttpHandler
Visual Basic (Usage) Copy Code
Dim instance As HttpHandler
C#
public class HttpHandler

Inheritance Hierarchy

System.Object
Telerik.ReportViewer.WebForms.HttpHandler

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

HttpHandler Members
Telerik.ReportViewer.WebForms Namespace


HttpHandler Class Members

Telerik.ReportViewer.WebForms Send comments on this topic.
HttpHandler Class Members
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : HttpHandler Class

The following tables list the members exposed by HttpHandler.

Public Constructors

 | Name | Description
Public Constructor | HttpHandler Constructor |
Top

See Also

Reference

HttpHandler Class
Telerik.ReportViewer.WebForms Namespace


HttpHandler Constructor

Telerik.ReportViewer.WebForms Send comments on this topic.
HttpHandler Constructor
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > HttpHandler Class : HttpHandler Constructor

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As HttpHandler()
C#
public HttpHandler()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As HttpHandler()
C#
public HttpHandler()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

HttpHandler Class
HttpHandler Members


ParametersAreaGroup Class

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersAreaGroup Class
See Also Members
[image]
Telerik.ReportViewer.WebForms Namespace : ParametersAreaGroup Class

Summary description for RefreshGroup.

Object Model

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Private Class ParametersAreaGroup
   Inherits ToolbarGroup
Visual Basic (Usage) Copy Code
Dim instance As ParametersAreaGroup
C#
private class ParametersAreaGroup : ToolbarGroup

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.CompositeControl
Telerik.ReportViewer.WebForms.ToolbarGroup
Telerik.ReportViewer.WebForms.ParametersAreaGroup

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersAreaGroup Members
Telerik.ReportViewer.WebForms Namespace


ParametersAreaGroup Class Members

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersAreaGroup Class Members
See Also Fields Properties Methods Events
[image]
Telerik.ReportViewer.WebForms Namespace : ParametersAreaGroup Class

The following tables list the members exposed by ParametersAreaGroup.

Public Constructors

 | Name | Description
Public Constructor | ParametersAreaGroup Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | reportViewer | (Inherited from ToolbarGroup)
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ZoomMode | (Inherited from ToolbarGroup)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetChildButtonIds | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | CreateImageUrl | (Inherited from ToolbarGroup)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | Overridden.
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RecreateChildControls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | (Inherited from ToolbarGroup)
Protected Method | RenderChildren | (Inherited from ToolbarGroup)
Protected Method | RenderContents | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | RenderItemSpacer | (Inherited from ToolbarGroup)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

ParametersAreaGroup Class
Telerik.ReportViewer.WebForms Namespace


ParametersAreaGroup Constructor

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersAreaGroup Constructor
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersAreaGroup Class : ParametersAreaGroup Constructor

reportViewer

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportViewer As ReportViewer _
)
Visual Basic (Usage) Copy Code
Dim reportViewer As ReportViewer

Dim instance As ParametersAreaGroup(reportViewer)
C#
public ParametersAreaGroup(
   ReportViewer reportViewer
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportViewer As ReportViewer _
)
Visual Basic (Usage) Copy Code
Dim reportViewer As ReportViewer

Dim instance As ParametersAreaGroup(reportViewer)
C#
public ParametersAreaGroup(
   ReportViewer reportViewer
)

Parameters

reportViewer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersAreaGroup Class
ParametersAreaGroup Members


ParametersAreaGroup Class Methods

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersAreaGroup Class Methods
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ParametersAreaGroup Class

For a list of all members of this type, see ParametersAreaGroup members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetChildButtonIds | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | CreateImageUrl | (Inherited from ToolbarGroup)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | Overridden.
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RecreateChildControls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | (Inherited from ToolbarGroup)
Protected Method | RenderChildren | (Inherited from ToolbarGroup)
Protected Method | RenderContents | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | RenderItemSpacer | (Inherited from ToolbarGroup)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

ParametersAreaGroup Class
Telerik.ReportViewer.WebForms Namespace


CreateChildControls Method

Telerik.ReportViewer.WebForms Send comments on this topic.
CreateChildControls Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersAreaGroup Class : CreateChildControls Method

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub CreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As ParametersAreaGroup

instance.CreateChildControls()
C#
protected override void CreateChildControls()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersAreaGroup Class
ParametersAreaGroup Members


GetChildButtonIds Method

Telerik.ReportViewer.WebForms Send comments on this topic.
GetChildButtonIds Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersAreaGroup Class : GetChildButtonIds Method

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetChildButtonIds() As String()
Visual Basic (Usage) Copy Code
Dim instance As ParametersAreaGroup
Dim value() As String

value = instance.GetChildButtonIds()
C#
public override string[] GetChildButtonIds()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersAreaGroup Class
ParametersAreaGroup Members


OnPreRender Method

Telerik.ReportViewer.WebForms Send comments on this topic.
OnPreRender Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersAreaGroup Class : OnPreRender Method

e

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnPreRender( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ParametersAreaGroup
Dim e As EventArgs

instance.OnPreRender(e)
C#
protected override void OnPreRender(
   EventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersAreaGroup Class
ParametersAreaGroup Members


ParametersButton Class

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersButton Class
See Also Members
[image]
Telerik.ReportViewer.WebForms Namespace : ParametersButton Class

Object Model

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Private Class ParametersButton
   Inherits ToolbarButton
Visual Basic (Usage) Copy Code
Dim instance As ParametersButton
C#
private class ParametersButton : ToolbarButton

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.CompositeControl
Telerik.ReportViewer.WebForms.ToolbarButton
Telerik.ReportViewer.WebForms.ParametersButton

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersButton Members
Telerik.ReportViewer.WebForms Namespace


ParametersButton Class Members

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersButton Class Members
See Also Fields Properties Methods Events
[image]
Telerik.ReportViewer.WebForms Namespace : ParametersButton Class

The following tables list the members exposed by ParametersButton.

Public Constructors

 | Name | Description
Public Constructor | ParametersButton Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | reportViewer | (Inherited from ToolbarButton)
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientEnabled | (Inherited from ToolbarButton)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | CommandName | (Inherited from ToolbarButton)
Public Property | Controls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | TagKey | (Inherited from ToolbarButton)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | GetRegisterScript | Overridden.
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | (Inherited from System.Web.UI.Control)
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RecreateChildControls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | (Inherited from ToolbarButton)
Protected Method | RenderChildren | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | RenderRegisterScript | (Inherited from ToolbarButton)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

ParametersButton Class
Telerik.ReportViewer.WebForms Namespace


ParametersButton Constructor

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersButton Constructor
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersButton Class : ParametersButton Constructor

commandName
imageName
reportViewer

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal commandName As String, _
   ByVal imageName As String, _
   ByVal reportViewer As ReportViewer _
)
Visual Basic (Usage) Copy Code
Dim commandName As String
Dim imageName As String
Dim reportViewer As ReportViewer

Dim instance As ParametersButton(commandName, imageName, reportViewer)
C#
public ParametersButton(
   string commandName,
   string imageName,
   ReportViewer reportViewer
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal commandName As String, _
   ByVal imageName As String, _
   ByVal reportViewer As ReportViewer _
)
Visual Basic (Usage) Copy Code
Dim commandName As String
Dim imageName As String
Dim reportViewer As ReportViewer

Dim instance As ParametersButton(commandName, imageName, reportViewer)
C#
public ParametersButton(
   string commandName,
   string imageName,
   ReportViewer reportViewer
)

Parameters

commandName
imageName
reportViewer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersButton Class
ParametersButton Members


ParametersButton Class Methods

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersButton Class Methods
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ParametersButton Class

For a list of all members of this type, see ParametersButton members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | GetRegisterScript | Overridden.
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | (Inherited from System.Web.UI.Control)
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RecreateChildControls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | (Inherited from ToolbarButton)
Protected Method | RenderChildren | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | RenderRegisterScript | (Inherited from ToolbarButton)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

ParametersButton Class
Telerik.ReportViewer.WebForms Namespace


CreateChildControls Method

Telerik.ReportViewer.WebForms Send comments on this topic.
CreateChildControls Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersButton Class : CreateChildControls Method

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub CreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As ParametersButton

instance.CreateChildControls()
C#
protected override void CreateChildControls()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersButton Class
ParametersButton Members


GetRegisterScript Method

Telerik.ReportViewer.WebForms Send comments on this topic.
GetRegisterScript Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersButton Class : GetRegisterScript Method

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function GetRegisterScript() As String
Visual Basic (Usage) Copy Code
Dim instance As ParametersButton
Dim value As String

value = instance.GetRegisterScript()
C#
protected override string GetRegisterScript()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersButton Class
ParametersButton Members


ReportViewer Class

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportViewer Class
See Also Members
[image]
Telerik.ReportViewer.WebForms Namespace : ReportViewer Class

Object Model

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportViewer
   Inherits CompositeControl
   Implements IReportParameterEditorFactory
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
C#
public class ReportViewer : CompositeControl, IReportParameterEditorFactory

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.CompositeControl
Telerik.ReportViewer.WebForms.ReportViewer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Members
Telerik.ReportViewer.WebForms Namespace


ReportViewer Class Members

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportViewer Class Members
See Also Properties Methods Events
[image]
Telerik.ReportViewer.WebForms Namespace : ReportViewer Class

The following tables list the members exposed by ReportViewer.

Public Constructors

 | Name | Description
Public Constructor | ReportViewer Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | ProgressText |
Public Property | Report | Gets or sets the report displayed in the viewer.
Public Property | Resources | Use to customize the texts for labels, tooltips and messages.
Public Property | ShowExportGroup | Indicates whether Export group should be visible.
Public Property | ShowNavigationGroup | Indicates whether the page navigation controls are visible.
Public Property | ShowParametersButton | Indicates whether Parameters button should be visible.
Public Property | ShowPrintButton | Indicates whether Print button should be visible.
Public Property | ShowRefreshButton | Indicates whether the Refresh button should be visible.
Public Property | ShowZoomSelect | Indicates whether the Zoom input box should be visible.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | Gets or sets the name of the skin that is used by the viewer.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | Gets or sets the relative path of the folder containing the skins.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolbarVisible | Indicates whether the toolbar should be visible on the viewer.
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden.
Public Property | ZoomMode | Gets or sets the zoom mode of the viewer.
Public Property | ZoomPercent | Gets or sets the percentage of zoom used for the report display.
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | TagKey | Overridden.
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | Overridden.
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | Overridden.
Protected Method | OnLoad | Overridden.
Protected Method | OnPreRender | Overridden.
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RecreateChildControls | Overridden.
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | Overridden.
Protected Method | RenderChildren | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | Overridden.
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ReportViewer Constructor

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportViewer Constructor
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : ReportViewer Constructor

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer()
C#
public ReportViewer()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer()
C#
public ReportViewer()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportViewer Class Methods

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportViewer Class Methods
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ReportViewer Class

For a list of all members of this type, see ReportViewer members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | Overridden.
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | Overridden.
Protected Method | OnLoad | Overridden.
Protected Method | OnPreRender | Overridden.
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RecreateChildControls | Overridden.
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | Overridden.
Protected Method | RenderChildren | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | Overridden.
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


CreateChildControls Method

Telerik.ReportViewer.WebForms Send comments on this topic.
CreateChildControls Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : CreateChildControls Method

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub CreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer

instance.CreateChildControls()
C#
protected override void CreateChildControls()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


LoadViewState Method

Telerik.ReportViewer.WebForms Send comments on this topic.
LoadViewState Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : LoadViewState Method

savedState

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub LoadViewState( _
   ByVal savedState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim savedState As Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   object savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


OnInit Method

Telerik.ReportViewer.WebForms Send comments on this topic.
OnInit Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : OnInit Method

e

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnInit( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim e As EventArgs

instance.OnInit(e)
C#
protected override void OnInit(
   EventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


OnLoad Method

Telerik.ReportViewer.WebForms Send comments on this topic.
OnLoad Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : OnLoad Method

e

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnLoad( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim e As EventArgs

instance.OnLoad(e)
C#
protected override void OnLoad(
   EventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


OnPreRender Method

Telerik.ReportViewer.WebForms Send comments on this topic.
OnPreRender Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : OnPreRender Method

e

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnPreRender( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim e As EventArgs

instance.OnPreRender(e)
C#
protected override void OnPreRender(
   EventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


RecreateChildControls Method

Telerik.ReportViewer.WebForms Send comments on this topic.
RecreateChildControls Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : RecreateChildControls Method

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer

instance.RecreateChildControls()
C#
protected override void RecreateChildControls()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


Render Method

Telerik.ReportViewer.WebForms Send comments on this topic.
Render Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : Render Method

writer

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim writer As HtmlTextWriter

instance.Render(writer)
C#
protected override void Render(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


SaveViewState Method

Telerik.ReportViewer.WebForms Send comments on this topic.
SaveViewState Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : SaveViewState Method

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Object

value = instance.SaveViewState()
C#
protected override object SaveViewState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportViewer Class Properties

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportViewer Class Properties
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ReportViewer Class

For a list of all members of this type, see ReportViewer members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | ProgressText |
Public Property | Report | Gets or sets the report displayed in the viewer.
Public Property | Resources | Use to customize the texts for labels, tooltips and messages.
Public Property | ShowExportGroup | Indicates whether Export group should be visible.
Public Property | ShowNavigationGroup | Indicates whether the page navigation controls are visible.
Public Property | ShowParametersButton | Indicates whether Parameters button should be visible.
Public Property | ShowPrintButton | Indicates whether Print button should be visible.
Public Property | ShowRefreshButton | Indicates whether the Refresh button should be visible.
Public Property | ShowZoomSelect | Indicates whether the Zoom input box should be visible.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | Gets or sets the name of the skin that is used by the viewer.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | Gets or sets the relative path of the folder containing the skins.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolbarVisible | Indicates whether the toolbar should be visible on the viewer.
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden.
Public Property | ZoomMode | Gets or sets the zoom mode of the viewer.
Public Property | ZoomPercent | Gets or sets the percentage of zoom used for the report display.
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | TagKey | Overridden.
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


Height Property

Telerik.ReportViewer.WebForms Send comments on this topic.
Height Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : Height Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public override Unit Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ProgressText Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ProgressText Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : ProgressText Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ProgressText As String
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As String

instance.ProgressText = value

value = instance.ProgressText
C#
public string ProgressText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


Report Property

Telerik.ReportViewer.WebForms Send comments on this topic.
Report Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : Report Property

Gets or sets the report displayed in the viewer.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property Report As Report
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Report

instance.Report = value

value = instance.Report
C#
public Report Report {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


Resources Property

Telerik.ReportViewer.WebForms Send comments on this topic.
Resources Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : Resources Property

Use to customize the texts for labels, tooltips and messages.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Resources As Resources
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Resources

value = instance.Resources
C#
public Resources Resources {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowExportGroup Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ShowExportGroup Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : ShowExportGroup Property

Indicates whether Export group should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowExportGroup As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowExportGroup = value

value = instance.ShowExportGroup
C#
public bool ShowExportGroup {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowNavigationGroup Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ShowNavigationGroup Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : ShowNavigationGroup Property

Indicates whether the page navigation controls are visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowNavigationGroup As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowNavigationGroup = value

value = instance.ShowNavigationGroup
C#
public bool ShowNavigationGroup {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowParametersButton Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ShowParametersButton Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : ShowParametersButton Property

Indicates whether Parameters button should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowParametersButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowParametersButton = value

value = instance.ShowParametersButton
C#
public bool ShowParametersButton {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowPrintButton Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ShowPrintButton Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : ShowPrintButton Property

Indicates whether Print button should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowPrintButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowPrintButton = value

value = instance.ShowPrintButton
C#
public bool ShowPrintButton {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowRefreshButton Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ShowRefreshButton Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : ShowRefreshButton Property

Indicates whether the Refresh button should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowRefreshButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowRefreshButton = value

value = instance.ShowRefreshButton
C#
public bool ShowRefreshButton {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowZoomSelect Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ShowZoomSelect Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : ShowZoomSelect Property

Indicates whether the Zoom input box should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowZoomSelect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowZoomSelect = value

value = instance.ShowZoomSelect
C#
public bool ShowZoomSelect {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


Skin Property

Telerik.ReportViewer.WebForms Send comments on this topic.
Skin Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : Skin Property

Gets or sets the name of the skin that is used by the viewer.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property Skin As String
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As String

instance.Skin = value

value = instance.Skin
C#
public string Skin {get; set;}

Return Value

A string containing the name of the currently used skin. The default value is Default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


SkinsPath Property

Telerik.ReportViewer.WebForms Send comments on this topic.
SkinsPath Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : SkinsPath Property

Gets or sets the relative path of the folder containing the skins.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinsPath As String
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As String

instance.SkinsPath = value

value = instance.SkinsPath
C#
public virtual string SkinsPath {get; set;}

Return Value

A string specifying the relative path to the folder which contains ReportViewer skins. The default value is "~/ReportViewer/Skins".

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


TagKey Property

Telerik.ReportViewer.WebForms Send comments on this topic.
TagKey Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : TagKey Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property TagKey As HtmlTextWriterTag
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As HtmlTextWriterTag

value = instance.TagKey
C#
protected override HtmlTextWriterTag TagKey {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ToolbarVisible Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ToolbarVisible Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : ToolbarVisible Property

Indicates whether the toolbar should be visible on the viewer.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ToolbarVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ToolbarVisible = value

value = instance.ToolbarVisible
C#
public bool ToolbarVisible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


Width Property

Telerik.ReportViewer.WebForms Send comments on this topic.
Width Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : Width Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public override Unit Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ZoomMode Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ZoomMode Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : ZoomMode Property

Gets or sets the zoom mode of the viewer.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoomMode As ZoomMode
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As ZoomMode

instance.ZoomMode = value

value = instance.ZoomMode
C#
public ZoomMode ZoomMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ZoomPercent Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ZoomPercent Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ReportViewer Class : ZoomPercent Property

Gets or sets the percentage of zoom used for the report display.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoomPercent As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Integer

instance.ZoomPercent = value

value = instance.ZoomPercent
C#
public int ZoomPercent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


Resources Class

Telerik.ReportViewer.WebForms Send comments on this topic.
Resources Class
See Also Members
[image]
Telerik.ReportViewer.WebForms Namespace : Resources Class

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Class Resources
Visual Basic (Usage) Copy Code
Dim instance As Resources
C#
public class Resources

Inheritance Hierarchy

System.Object
Telerik.ReportViewer.WebForms.Resources

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Members
Telerik.ReportViewer.WebForms Namespace


Resources Class Members

Telerik.ReportViewer.WebForms Send comments on this topic.
Resources Class Members
See Also Properties Methods
[image]
Telerik.ReportViewer.WebForms Namespace : Resources Class

The following tables list the members exposed by Resources.

Public Constructors

 | Name | Description
Public Constructor | Resources Constructor |
Top

Public Properties

 | Name | Description
Public Property | CurrentPageToolTip | Specifies the tooltip for the current page label.
Public Property | ExportButtonText | Specifies the text for the Export button.
Public Property | ExportSelectFormatText | Specifies the <select export format> text in the Export select input.
Public Property | ExportToolTip | Specifies the tooltip for the Export button.
Public Property | FirstPageToolTip | Specifies the tooltip for the FirstPage button.
Public Property | LabelOf | Specifies the text for the 'of' conjuction label.
Public Property | LastPageToolTip | Specifies the tooltip for the LastPage button.
Public Property | NextPageToolTip | Specifies the tooltip for the NextPage button.
Public Property | ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
Public Property | PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
Public Property | PrintToolTip | Specifies the tooltip for the Print button.
Public Property | ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
Public Property | RefreshToolTip | Specifies the tooltip for the Refresh button.
Public Property | ReportParametersFalseValueLabel | Specifies the text for the False value label in a boolean parameter editor.
Public Property | ReportParametersInvalidValueText | Specifies the text for the InvalidValue error.
Public Property | ReportParametersNullText | Specifies the text for the NULL checkbox.
Public Property | ReportParametersPreviewButtonText | Specifies the text for the Preview button.
Public Property | ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
Public Property | ReportParametersSelectAValueText | Specifies the <select a value> text for a dropdown parameter editor.
Public Property | ReportParametersTrueValueLabel | Specfies the text for the True value label in a boolean parameter editor.
Public Property | ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
Public Property | ZoomToWholePage | Specifies the name for the WholePage zoom mode.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Resources Class
Telerik.ReportViewer.WebForms Namespace


Resources Constructor

Telerik.ReportViewer.WebForms Send comments on this topic.
Resources Constructor
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : Resources Constructor

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Resources()
C#
public Resources()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Resources()
C#
public Resources()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


Resources Class Methods

Telerik.ReportViewer.WebForms Send comments on this topic.
Resources Class Methods
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : Resources Class

For a list of all members of this type, see Resources members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Resources Class
Telerik.ReportViewer.WebForms Namespace


ToString Method

Telerik.ReportViewer.WebForms Send comments on this topic.
ToString Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ToString Method

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


Resources Class Properties

Telerik.ReportViewer.WebForms Send comments on this topic.
Resources Class Properties
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : Resources Class

For a list of all members of this type, see Resources members.

Public Properties

 | Name | Description
Public Property | CurrentPageToolTip | Specifies the tooltip for the current page label.
Public Property | ExportButtonText | Specifies the text for the Export button.
Public Property | ExportSelectFormatText | Specifies the <select export format> text in the Export select input.
Public Property | ExportToolTip | Specifies the tooltip for the Export button.
Public Property | FirstPageToolTip | Specifies the tooltip for the FirstPage button.
Public Property | LabelOf | Specifies the text for the 'of' conjuction label.
Public Property | LastPageToolTip | Specifies the tooltip for the LastPage button.
Public Property | NextPageToolTip | Specifies the tooltip for the NextPage button.
Public Property | ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
Public Property | PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
Public Property | PrintToolTip | Specifies the tooltip for the Print button.
Public Property | ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
Public Property | RefreshToolTip | Specifies the tooltip for the Refresh button.
Public Property | ReportParametersFalseValueLabel | Specifies the text for the False value label in a boolean parameter editor.
Public Property | ReportParametersInvalidValueText | Specifies the text for the InvalidValue error.
Public Property | ReportParametersNullText | Specifies the text for the NULL checkbox.
Public Property | ReportParametersPreviewButtonText | Specifies the text for the Preview button.
Public Property | ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
Public Property | ReportParametersSelectAValueText | Specifies the <select a value> text for a dropdown parameter editor.
Public Property | ReportParametersTrueValueLabel | Specfies the text for the True value label in a boolean parameter editor.
Public Property | ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
Public Property | ZoomToWholePage | Specifies the name for the WholePage zoom mode.
Top

See Also

Reference

Resources Class
Telerik.ReportViewer.WebForms Namespace


CurrentPageToolTip Property

Telerik.ReportViewer.WebForms Send comments on this topic.
CurrentPageToolTip Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : CurrentPageToolTip Property

Specifies the tooltip for the current page label.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property CurrentPageToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.CurrentPageToolTip = value

value = instance.CurrentPageToolTip
C#
public string CurrentPageToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ExportButtonText Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ExportButtonText Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ExportButtonText Property

Specifies the text for the Export button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ExportButtonText As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ExportButtonText = value

value = instance.ExportButtonText
C#
public string ExportButtonText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ExportSelectFormatText Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ExportSelectFormatText Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ExportSelectFormatText Property

Specifies the <select export format> text in the Export select input.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ExportSelectFormatText As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ExportSelectFormatText = value

value = instance.ExportSelectFormatText
C#
public string ExportSelectFormatText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ExportToolTip Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ExportToolTip Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ExportToolTip Property

Specifies the tooltip for the Export button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ExportToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ExportToolTip = value

value = instance.ExportToolTip
C#
public string ExportToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


FirstPageToolTip Property

Telerik.ReportViewer.WebForms Send comments on this topic.
FirstPageToolTip Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : FirstPageToolTip Property

Specifies the tooltip for the FirstPage button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property FirstPageToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.FirstPageToolTip = value

value = instance.FirstPageToolTip
C#
public string FirstPageToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


LabelOf Property

Telerik.ReportViewer.WebForms Send comments on this topic.
LabelOf Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : LabelOf Property

Specifies the text for the 'of' conjuction label.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelOf As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.LabelOf = value

value = instance.LabelOf
C#
public string LabelOf {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


LastPageToolTip Property

Telerik.ReportViewer.WebForms Send comments on this topic.
LastPageToolTip Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : LastPageToolTip Property

Specifies the tooltip for the LastPage button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property LastPageToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.LastPageToolTip = value

value = instance.LastPageToolTip
C#
public string LastPageToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


NextPageToolTip Property

Telerik.ReportViewer.WebForms Send comments on this topic.
NextPageToolTip Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : NextPageToolTip Property

Specifies the tooltip for the NextPage button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property NextPageToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.NextPageToolTip = value

value = instance.NextPageToolTip
C#
public string NextPageToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ParametersToolTip Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersToolTip Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ParametersToolTip Property

Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ParametersToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ParametersToolTip = value

value = instance.ParametersToolTip
C#
public string ParametersToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


PreviousPageToolTip Property

Telerik.ReportViewer.WebForms Send comments on this topic.
PreviousPageToolTip Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : PreviousPageToolTip Property

Specifies the tooltip for the PreviousPage button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property PreviousPageToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.PreviousPageToolTip = value

value = instance.PreviousPageToolTip
C#
public string PreviousPageToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


PrintToolTip Property

Telerik.ReportViewer.WebForms Send comments on this topic.
PrintToolTip Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : PrintToolTip Property

Specifies the tooltip for the Print button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property PrintToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.PrintToolTip = value

value = instance.PrintToolTip
C#
public string PrintToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ProcessingReportMessage Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ProcessingReportMessage Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ProcessingReportMessage Property

Specifies the text for the wait message shown while the report is being processed.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ProcessingReportMessage As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ProcessingReportMessage = value

value = instance.ProcessingReportMessage
C#
public string ProcessingReportMessage {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


RefreshToolTip Property

Telerik.ReportViewer.WebForms Send comments on this topic.
RefreshToolTip Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : RefreshToolTip Property

Specifies the tooltip for the Refresh button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property RefreshToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.RefreshToolTip = value

value = instance.RefreshToolTip
C#
public string RefreshToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersFalseValueLabel Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersFalseValueLabel Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ReportParametersFalseValueLabel Property

Specifies the text for the False value label in a boolean parameter editor.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersFalseValueLabel As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersFalseValueLabel = value

value = instance.ReportParametersFalseValueLabel
C#
public string ReportParametersFalseValueLabel {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersInvalidValueText Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersInvalidValueText Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ReportParametersInvalidValueText Property

Specifies the text for the InvalidValue error.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersInvalidValueText As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersInvalidValueText = value

value = instance.ReportParametersInvalidValueText
C#
public string ReportParametersInvalidValueText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersNullText Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersNullText Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ReportParametersNullText Property

Specifies the text for the NULL checkbox.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersNullText As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersNullText = value

value = instance.ReportParametersNullText
C#
public string ReportParametersNullText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersPreviewButtonText Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersPreviewButtonText Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ReportParametersPreviewButtonText Property

Specifies the text for the Preview button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersPreviewButtonText As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersPreviewButtonText = value

value = instance.ReportParametersPreviewButtonText
C#
public string ReportParametersPreviewButtonText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersSelectAllText Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersSelectAllText Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ReportParametersSelectAllText Property

Specifies the <select all> text for a multivalue parameter editor.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersSelectAllText As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersSelectAllText = value

value = instance.ReportParametersSelectAllText
C#
public string ReportParametersSelectAllText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersSelectAValueText Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersSelectAValueText Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ReportParametersSelectAValueText Property

Specifies the <select a value> text for a dropdown parameter editor.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersSelectAValueText As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersSelectAValueText = value

value = instance.ReportParametersSelectAValueText
C#
public string ReportParametersSelectAValueText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersTrueValueLabel Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersTrueValueLabel Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ReportParametersTrueValueLabel Property

Specfies the text for the True value label in a boolean parameter editor.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersTrueValueLabel As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersTrueValueLabel = value

value = instance.ReportParametersTrueValueLabel
C#
public string ReportParametersTrueValueLabel {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ZoomToPageWidth Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ZoomToPageWidth Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ZoomToPageWidth Property

Specifies the name for the PageWidth zoom mode.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoomToPageWidth As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ZoomToPageWidth = value

value = instance.ZoomToPageWidth
C#
public string ZoomToPageWidth {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ZoomToWholePage Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ZoomToWholePage Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources Class : ZoomToWholePage Property

Specifies the name for the WholePage zoom mode.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoomToWholePage As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ZoomToWholePage = value

value = instance.ZoomToWholePage
C#
public string ZoomToWholePage {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


Resources.Keys Class

Telerik.ReportViewer.WebForms Send comments on this topic.
Resources.Keys Class
See Also Members
[image]
Telerik.ReportViewer.WebForms Namespace : Resources.Keys Class

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Private MustInherit NotInheritable Class Resources.Keys
Visual Basic (Usage) Copy Code
Dim instance As Resources.Keys
C#
private static class Resources.Keys

Inheritance Hierarchy

System.Object
Telerik.ReportViewer.WebForms.Resources.Keys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Members
Telerik.ReportViewer.WebForms Namespace


Resources.Keys Class Members

Telerik.ReportViewer.WebForms Send comments on this topic.
Resources.Keys Class Members
See Also Fields
[image]
Telerik.ReportViewer.WebForms Namespace : Resources.Keys Class

The following tables list the members exposed by Resources.Keys.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CurrentPageToolTip |
static (Shared in Visual Basic) | ExportButtonText |
static (Shared in Visual Basic) | ExportSelectFormatText |
static (Shared in Visual Basic) | ExportToolTip |
static (Shared in Visual Basic) | FirstPageToolTip |
static (Shared in Visual Basic) | LabelOf |
static (Shared in Visual Basic) | LastPageToolTip |
static (Shared in Visual Basic) | NextPageToolTip |
static (Shared in Visual Basic) | ParametersToolTip |
static (Shared in Visual Basic) | PreviousPageToolTip |
static (Shared in Visual Basic) | PrintToolTip |
static (Shared in Visual Basic) | ProcessingReportMessage |
static (Shared in Visual Basic) | RefreshToolTip |
static (Shared in Visual Basic) | ReportParametersFalseValueLabel |
static (Shared in Visual Basic) | ReportParametersInvalidValueText |
static (Shared in Visual Basic) | ReportParametersNullText |
static (Shared in Visual Basic) | ReportParametersPreviewButtonText |
static (Shared in Visual Basic) | ReportParametersSelectAllText |
static (Shared in Visual Basic) | ReportParametersSelectAValueText |
static (Shared in Visual Basic) | ReportParametersTrueValueLabel |
static (Shared in Visual Basic) | ZoomToPageWidth |
static (Shared in Visual Basic) | ZoomToWholePage |
Top

See Also

Reference

Resources.Keys Class
Telerik.ReportViewer.WebForms Namespace


Resources.Keys Class Fields

Telerik.ReportViewer.WebForms Send comments on this topic.
Resources.Keys Class Fields
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : Resources.Keys Class

For a list of all members of this type, see Resources.Keys members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CurrentPageToolTip |
static (Shared in Visual Basic) | ExportButtonText |
static (Shared in Visual Basic) | ExportSelectFormatText |
static (Shared in Visual Basic) | ExportToolTip |
static (Shared in Visual Basic) | FirstPageToolTip |
static (Shared in Visual Basic) | LabelOf |
static (Shared in Visual Basic) | LastPageToolTip |
static (Shared in Visual Basic) | NextPageToolTip |
static (Shared in Visual Basic) | ParametersToolTip |
static (Shared in Visual Basic) | PreviousPageToolTip |
static (Shared in Visual Basic) | PrintToolTip |
static (Shared in Visual Basic) | ProcessingReportMessage |
static (Shared in Visual Basic) | RefreshToolTip |
static (Shared in Visual Basic) | ReportParametersFalseValueLabel |
static (Shared in Visual Basic) | ReportParametersInvalidValueText |
static (Shared in Visual Basic) | ReportParametersNullText |
static (Shared in Visual Basic) | ReportParametersPreviewButtonText |
static (Shared in Visual Basic) | ReportParametersSelectAllText |
static (Shared in Visual Basic) | ReportParametersSelectAValueText |
static (Shared in Visual Basic) | ReportParametersTrueValueLabel |
static (Shared in Visual Basic) | ZoomToPageWidth |
static (Shared in Visual Basic) | ZoomToWholePage |
Top

See Also

Reference

Resources.Keys Class
Telerik.ReportViewer.WebForms Namespace


CurrentPageToolTip Field

Telerik.ReportViewer.WebForms Send comments on this topic.
CurrentPageToolTip Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : CurrentPageToolTip Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared CurrentPageToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.CurrentPageToolTip

Resources.Keys.CurrentPageToolTip = value
C#
public static string CurrentPageToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ExportButtonText Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ExportButtonText Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ExportButtonText Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ExportButtonText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ExportButtonText

Resources.Keys.ExportButtonText = value
C#
public static string ExportButtonText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ExportSelectFormatText Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ExportSelectFormatText Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ExportSelectFormatText Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ExportSelectFormatText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ExportSelectFormatText

Resources.Keys.ExportSelectFormatText = value
C#
public static string ExportSelectFormatText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ExportToolTip Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ExportToolTip Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ExportToolTip Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ExportToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ExportToolTip

Resources.Keys.ExportToolTip = value
C#
public static string ExportToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


FirstPageToolTip Field

Telerik.ReportViewer.WebForms Send comments on this topic.
FirstPageToolTip Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : FirstPageToolTip Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared FirstPageToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.FirstPageToolTip

Resources.Keys.FirstPageToolTip = value
C#
public static string FirstPageToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


LabelOf Field

Telerik.ReportViewer.WebForms Send comments on this topic.
LabelOf Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : LabelOf Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared LabelOf As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.LabelOf

Resources.Keys.LabelOf = value
C#
public static string LabelOf

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


LastPageToolTip Field

Telerik.ReportViewer.WebForms Send comments on this topic.
LastPageToolTip Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : LastPageToolTip Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared LastPageToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.LastPageToolTip

Resources.Keys.LastPageToolTip = value
C#
public static string LastPageToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


NextPageToolTip Field

Telerik.ReportViewer.WebForms Send comments on this topic.
NextPageToolTip Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : NextPageToolTip Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared NextPageToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.NextPageToolTip

Resources.Keys.NextPageToolTip = value
C#
public static string NextPageToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ParametersToolTip Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersToolTip Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ParametersToolTip Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ParametersToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ParametersToolTip

Resources.Keys.ParametersToolTip = value
C#
public static string ParametersToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


PreviousPageToolTip Field

Telerik.ReportViewer.WebForms Send comments on this topic.
PreviousPageToolTip Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : PreviousPageToolTip Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared PreviousPageToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.PreviousPageToolTip

Resources.Keys.PreviousPageToolTip = value
C#
public static string PreviousPageToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


PrintToolTip Field

Telerik.ReportViewer.WebForms Send comments on this topic.
PrintToolTip Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : PrintToolTip Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared PrintToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.PrintToolTip

Resources.Keys.PrintToolTip = value
C#
public static string PrintToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ProcessingReportMessage Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ProcessingReportMessage Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ProcessingReportMessage Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ProcessingReportMessage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ProcessingReportMessage

Resources.Keys.ProcessingReportMessage = value
C#
public static string ProcessingReportMessage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


RefreshToolTip Field

Telerik.ReportViewer.WebForms Send comments on this topic.
RefreshToolTip Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : RefreshToolTip Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared RefreshToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.RefreshToolTip

Resources.Keys.RefreshToolTip = value
C#
public static string RefreshToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersFalseValueLabel Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersFalseValueLabel Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ReportParametersFalseValueLabel Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersFalseValueLabel As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersFalseValueLabel

Resources.Keys.ReportParametersFalseValueLabel = value
C#
public static string ReportParametersFalseValueLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersInvalidValueText Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersInvalidValueText Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ReportParametersInvalidValueText Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersInvalidValueText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersInvalidValueText

Resources.Keys.ReportParametersInvalidValueText = value
C#
public static string ReportParametersInvalidValueText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersNullText Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersNullText Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ReportParametersNullText Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersNullText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersNullText

Resources.Keys.ReportParametersNullText = value
C#
public static string ReportParametersNullText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersPreviewButtonText Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersPreviewButtonText Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ReportParametersPreviewButtonText Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersPreviewButtonText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersPreviewButtonText

Resources.Keys.ReportParametersPreviewButtonText = value
C#
public static string ReportParametersPreviewButtonText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersSelectAllText Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersSelectAllText Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ReportParametersSelectAllText Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersSelectAllText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersSelectAllText

Resources.Keys.ReportParametersSelectAllText = value
C#
public static string ReportParametersSelectAllText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersSelectAValueText Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersSelectAValueText Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ReportParametersSelectAValueText Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersSelectAValueText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersSelectAValueText

Resources.Keys.ReportParametersSelectAValueText = value
C#
public static string ReportParametersSelectAValueText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersTrueValueLabel Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportParametersTrueValueLabel Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ReportParametersTrueValueLabel Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersTrueValueLabel As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersTrueValueLabel

Resources.Keys.ReportParametersTrueValueLabel = value
C#
public static string ReportParametersTrueValueLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ZoomToPageWidth Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ZoomToPageWidth Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ZoomToPageWidth Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ZoomToPageWidth As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ZoomToPageWidth

Resources.Keys.ZoomToPageWidth = value
C#
public static string ZoomToPageWidth

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ZoomToWholePage Field

Telerik.ReportViewer.WebForms Send comments on this topic.
ZoomToWholePage Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > Resources.Keys Class : ZoomToWholePage Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ZoomToWholePage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ZoomToWholePage

Resources.Keys.ZoomToWholePage = value
C#
public static string ZoomToWholePage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ServerReport.SimpleDataItem Class

Telerik.ReportViewer.WebForms Send comments on this topic.
ServerReport.SimpleDataItem Class
See Also Members
[image]
Telerik.ReportViewer.WebForms Namespace : ServerReport.SimpleDataItem Class

IDataItem without Filters, Sorting, Groups and Ranks. Only DataSource and DataMember.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Private Class ServerReport.SimpleDataItem
   Implements IDataItem
Visual Basic (Usage) Copy Code
Dim instance As ServerReport.SimpleDataItem
C#
private class ServerReport.SimpleDataItem : IDataItem

Inheritance Hierarchy

System.Object
Telerik.ReportViewer.WebForms.ServerReport.SimpleDataItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ServerReport.SimpleDataItem Members
Telerik.ReportViewer.WebForms Namespace


ServerReport.SimpleDataItem Class Members

Telerik.ReportViewer.WebForms Send comments on this topic.
ServerReport.SimpleDataItem Class Members
See Also Properties
[image]
Telerik.ReportViewer.WebForms Namespace : ServerReport.SimpleDataItem Class

The following tables list the members exposed by ServerReport.SimpleDataItem.

Public Constructors

 | Name | Description
Public Constructor | ServerReport.SimpleDataItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataMember |
Public Property | DataSource |
Public Property | Filters |
Public Property | Groups |
Public Property | Ranks |
Public Property | Sorting |
Top

See Also

Reference

ServerReport.SimpleDataItem Class
Telerik.ReportViewer.WebForms Namespace


ServerReport.SimpleDataItem Constructor

Telerik.ReportViewer.WebForms Send comments on this topic.
ServerReport.SimpleDataItem Constructor
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ServerReport.SimpleDataItem Class : ServerReport.SimpleDataItem Constructor

dataSource
dataMember

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataSource As Object, _
   ByVal dataMember As String _
)
Visual Basic (Usage) Copy Code
Dim dataSource As Object
Dim dataMember As String

Dim instance As ServerReport.SimpleDataItem(dataSource, dataMember)
C#
public ServerReport.SimpleDataItem(
   object dataSource,
   string dataMember
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataSource As Object, _
   ByVal dataMember As String _
)
Visual Basic (Usage) Copy Code
Dim dataSource As Object
Dim dataMember As String

Dim instance As ServerReport.SimpleDataItem(dataSource, dataMember)
C#
public ServerReport.SimpleDataItem(
   object dataSource,
   string dataMember
)

Parameters

dataSource
dataMember

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ServerReport.SimpleDataItem Class
ServerReport.SimpleDataItem Members


ServerReport.SimpleDataItem Class Properties

Telerik.ReportViewer.WebForms Send comments on this topic.
ServerReport.SimpleDataItem Class Properties
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ServerReport.SimpleDataItem Class

For a list of all members of this type, see ServerReport.SimpleDataItem members.

Public Properties

 | Name | Description
Public Property | DataMember |
Public Property | DataSource |
Public Property | Filters |
Public Property | Groups |
Public Property | Ranks |
Public Property | Sorting |
Top

See Also

Reference

ServerReport.SimpleDataItem Class
Telerik.ReportViewer.WebForms Namespace


DataMember Property

Telerik.ReportViewer.WebForms Send comments on this topic.
DataMember Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ServerReport.SimpleDataItem Class : DataMember Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As ServerReport.SimpleDataItem
Dim value As String

value = instance.DataMember
C#
public string DataMember {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ServerReport.SimpleDataItem Class
ServerReport.SimpleDataItem Members


DataSource Property

Telerik.ReportViewer.WebForms Send comments on this topic.
DataSource Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ServerReport.SimpleDataItem Class : DataSource Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As ServerReport.SimpleDataItem
Dim value As Object

value = instance.DataSource
C#
public object DataSource {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ServerReport.SimpleDataItem Class
ServerReport.SimpleDataItem Members


Filters Property

Telerik.ReportViewer.WebForms Send comments on this topic.
Filters Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ServerReport.SimpleDataItem Class : Filters Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filters As IEnumerable(Of Filter)
Visual Basic (Usage) Copy Code
Dim instance As ServerReport.SimpleDataItem
Dim value As IEnumerable(Of Filter)

value = instance.Filters
C#
public IEnumerable<Filter> Filters {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ServerReport.SimpleDataItem Class
ServerReport.SimpleDataItem Members


Groups Property

Telerik.ReportViewer.WebForms Send comments on this topic.
Groups Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ServerReport.SimpleDataItem Class : Groups Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Groups As IEnumerable(Of IGroup)
Visual Basic (Usage) Copy Code
Dim instance As ServerReport.SimpleDataItem
Dim value As IEnumerable(Of IGroup)

value = instance.Groups
C#
public IEnumerable<IGroup> Groups {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ServerReport.SimpleDataItem Class
ServerReport.SimpleDataItem Members


Ranks Property

Telerik.ReportViewer.WebForms Send comments on this topic.
Ranks Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ServerReport.SimpleDataItem Class : Ranks Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Ranks As IEnumerable(Of Filter)
Visual Basic (Usage) Copy Code
Dim instance As ServerReport.SimpleDataItem
Dim value As IEnumerable(Of Filter)

value = instance.Ranks
C#
public IEnumerable<Filter> Ranks {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ServerReport.SimpleDataItem Class
ServerReport.SimpleDataItem Members


Sorting Property

Telerik.ReportViewer.WebForms Send comments on this topic.
Sorting Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ServerReport.SimpleDataItem Class : Sorting Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sorting As IEnumerable(Of Sorting)
Visual Basic (Usage) Copy Code
Dim instance As ServerReport.SimpleDataItem
Dim value As IEnumerable(Of Sorting)

value = instance.Sorting
C#
public IEnumerable<Sorting> Sorting {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ServerReport.SimpleDataItem Class
ServerReport.SimpleDataItem Members


ShowHideParametersGroup1 Class

Telerik.ReportViewer.WebForms Send comments on this topic.
ShowHideParametersGroup1 Class
See Also Members
[image]
Telerik.ReportViewer.WebForms Namespace : ShowHideParametersGroup1 Class

Object Model

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Private Class ShowHideParametersGroup1
   Inherits ToolbarGroup
Visual Basic (Usage) Copy Code
Dim instance As ShowHideParametersGroup1
C#
private class ShowHideParametersGroup1 : ToolbarGroup

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.CompositeControl
Telerik.ReportViewer.WebForms.ToolbarGroup
Telerik.ReportViewer.WebForms.ShowHideParametersGroup1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShowHideParametersGroup1 Members
Telerik.ReportViewer.WebForms Namespace


ShowHideParametersGroup1 Class Members

Telerik.ReportViewer.WebForms Send comments on this topic.
ShowHideParametersGroup1 Class Members
See Also Fields Properties Methods Events
[image]
Telerik.ReportViewer.WebForms Namespace : ShowHideParametersGroup1 Class

The following tables list the members exposed by ShowHideParametersGroup1.

Public Constructors

 | Name | Description
Public Constructor | ShowHideParametersGroup1 Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | reportViewer | (Inherited from ToolbarGroup)
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ZoomMode | (Inherited from ToolbarGroup)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | TagKey | Overridden.
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetChildButtonIds | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | CreateImageUrl | (Inherited from ToolbarGroup)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | Overridden.
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RecreateChildControls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | (Inherited from ToolbarGroup)
Protected Method | RenderChildren | (Inherited from ToolbarGroup)
Protected Method | RenderContents | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | RenderItemSpacer | (Inherited from ToolbarGroup)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

ShowHideParametersGroup1 Class
Telerik.ReportViewer.WebForms Namespace


ShowHideParametersGroup1 Constructor

Telerik.ReportViewer.WebForms Send comments on this topic.
ShowHideParametersGroup1 Constructor
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ShowHideParametersGroup1 Class : ShowHideParametersGroup1 Constructor

reportViewer

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportViewer As ReportViewer _
)
Visual Basic (Usage) Copy Code
Dim reportViewer As ReportViewer

Dim instance As ShowHideParametersGroup1(reportViewer)
C#
public ShowHideParametersGroup1(
   ReportViewer reportViewer
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportViewer As ReportViewer _
)
Visual Basic (Usage) Copy Code
Dim reportViewer As ReportViewer

Dim instance As ShowHideParametersGroup1(reportViewer)
C#
public ShowHideParametersGroup1(
   ReportViewer reportViewer
)

Parameters

reportViewer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShowHideParametersGroup1 Class
ShowHideParametersGroup1 Members


ShowHideParametersGroup1 Class Methods

Telerik.ReportViewer.WebForms Send comments on this topic.
ShowHideParametersGroup1 Class Methods
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ShowHideParametersGroup1 Class

For a list of all members of this type, see ShowHideParametersGroup1 members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetChildButtonIds | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | CreateImageUrl | (Inherited from ToolbarGroup)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | Overridden.
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RecreateChildControls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | (Inherited from ToolbarGroup)
Protected Method | RenderChildren | (Inherited from ToolbarGroup)
Protected Method | RenderContents | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | RenderItemSpacer | (Inherited from ToolbarGroup)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

ShowHideParametersGroup1 Class
Telerik.ReportViewer.WebForms Namespace


CreateChildControls Method

Telerik.ReportViewer.WebForms Send comments on this topic.
CreateChildControls Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ShowHideParametersGroup1 Class : CreateChildControls Method

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub CreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As ShowHideParametersGroup1

instance.CreateChildControls()
C#
protected override void CreateChildControls()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShowHideParametersGroup1 Class
ShowHideParametersGroup1 Members


GetChildButtonIds Method

Telerik.ReportViewer.WebForms Send comments on this topic.
GetChildButtonIds Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ShowHideParametersGroup1 Class : GetChildButtonIds Method

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetChildButtonIds() As String()
Visual Basic (Usage) Copy Code
Dim instance As ShowHideParametersGroup1
Dim value() As String

value = instance.GetChildButtonIds()
C#
public override string[] GetChildButtonIds()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShowHideParametersGroup1 Class
ShowHideParametersGroup1 Members


OnPreRender Method

Telerik.ReportViewer.WebForms Send comments on this topic.
OnPreRender Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ShowHideParametersGroup1 Class : OnPreRender Method

e

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnPreRender( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ShowHideParametersGroup1
Dim e As EventArgs

instance.OnPreRender(e)
C#
protected override void OnPreRender(
   EventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShowHideParametersGroup1 Class
ShowHideParametersGroup1 Members


ShowHideParametersGroup1 Class Properties

Telerik.ReportViewer.WebForms Send comments on this topic.
ShowHideParametersGroup1 Class Properties
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ShowHideParametersGroup1 Class

For a list of all members of this type, see ShowHideParametersGroup1 members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ZoomMode | (Inherited from ToolbarGroup)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | TagKey | Overridden.
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

ShowHideParametersGroup1 Class
Telerik.ReportViewer.WebForms Namespace


TagKey Property

Telerik.ReportViewer.WebForms Send comments on this topic.
TagKey Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ShowHideParametersGroup1 Class : TagKey Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property TagKey As HtmlTextWriterTag
Visual Basic (Usage) Copy Code
Dim instance As ShowHideParametersGroup1
Dim value As HtmlTextWriterTag

value = instance.TagKey
C#
protected override HtmlTextWriterTag TagKey {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShowHideParametersGroup1 Class
ShowHideParametersGroup1 Members


SRDefaultValueAttribute Class

Telerik.ReportViewer.WebForms Send comments on this topic.
SRDefaultValueAttribute Class
See Also Members
[image]
Telerik.ReportViewer.WebForms Namespace : SRDefaultValueAttribute Class

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Private Class SRDefaultValueAttribute
   Inherits DefaultValueAttribute
Visual Basic (Usage) Copy Code
Dim instance As SRDefaultValueAttribute
C#
private class SRDefaultValueAttribute : DefaultValueAttribute

Inheritance Hierarchy

System.Object
System.Attribute
System.ComponentModel.DefaultValueAttribute
Telerik.ReportViewer.WebForms.SRDefaultValueAttribute

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SRDefaultValueAttribute Members
Telerik.ReportViewer.WebForms Namespace


SRDefaultValueAttribute Class Members

Telerik.ReportViewer.WebForms Send comments on this topic.
SRDefaultValueAttribute Class Members
See Also Properties Methods
[image]
Telerik.ReportViewer.WebForms Namespace : SRDefaultValueAttribute Class

The following tables list the members exposed by SRDefaultValueAttribute.

Public Constructors

 | Name | Description
Public Constructor | SRDefaultValueAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Public Property | Value | (Inherited from System.ComponentModel.DefaultValueAttribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.ComponentModel.DefaultValueAttribute)
Public Method | GetHashCode | (Inherited from System.ComponentModel.DefaultValueAttribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

Protected Methods

 | Name | Description
Protected Method | SetValue | (Inherited from System.ComponentModel.DefaultValueAttribute)
Top

See Also

Reference

SRDefaultValueAttribute Class
Telerik.ReportViewer.WebForms Namespace


SRDefaultValueAttribute Constructor

Telerik.ReportViewer.WebForms Send comments on this topic.
SRDefaultValueAttribute Constructor
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > SRDefaultValueAttribute Class : SRDefaultValueAttribute Constructor

value

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As SRDefaultValueAttribute(value)
C#
public SRDefaultValueAttribute(
   string value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As SRDefaultValueAttribute(value)
C#
public SRDefaultValueAttribute(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SRDefaultValueAttribute Class
SRDefaultValueAttribute Members


LabelValuePair Structure

Telerik.ReportViewer.WebForms Send comments on this topic.
LabelValuePair Structure
See Also Members
[image]
Telerik.ReportViewer.WebForms Namespace : LabelValuePair Structure

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Structure LabelValuePair
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As LabelValuePair
C#
public struct LabelValuePair : ValueType

Syntax

Visual Basic (Declaration)
Public Structure LabelValuePair
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As LabelValuePair
C#
public struct LabelValuePair : ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Telerik.ReportViewer.WebForms.LabelValuePair

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelValuePair Members
Telerik.ReportViewer.WebForms Namespace


LabelValuePair Structure Members

Telerik.ReportViewer.WebForms Send comments on this topic.
LabelValuePair Structure Members
See Also Fields Methods
[image]
Telerik.ReportViewer.WebForms Namespace : LabelValuePair Structure

The following tables list the members exposed by LabelValuePair.

Public Fields

 | Name | Description
Public Field | Label |
Public Field | Value |
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.ValueType)
Public Method | GetHashCode | (Inherited from System.ValueType)
Public Method | ToString | (Inherited from System.ValueType)
Top

See Also

Reference

LabelValuePair Structure
Telerik.ReportViewer.WebForms Namespace


LabelValuePair Structure Fields

Telerik.ReportViewer.WebForms Send comments on this topic.
LabelValuePair Structure Fields
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : LabelValuePair Structure

For a list of all members of this type, see LabelValuePair members.

Public Fields

 | Name | Description
Public Field | Label |
Public Field | Value |
Top

See Also

Reference

LabelValuePair Structure
Telerik.ReportViewer.WebForms Namespace


Label Field

Telerik.ReportViewer.WebForms Send comments on this topic.
Label Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > LabelValuePair Structure : Label Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Label As String
Visual Basic (Usage) Copy Code
Dim instance As LabelValuePair
Dim value As String

value = instance.Label

instance.Label = value
C#
public string Label

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelValuePair Structure
LabelValuePair Members


Value Field

Telerik.ReportViewer.WebForms Send comments on this topic.
Value Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > LabelValuePair Structure : Value Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Value As String
Visual Basic (Usage) Copy Code
Dim instance As LabelValuePair
Dim value As String

value = instance.Value

instance.Value = value
C#
public string Value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LabelValuePair Structure
LabelValuePair Members


DrawablePage Class

Telerik.ReportViewer.WinForms Send comments on this topic.
DrawablePage Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : DrawablePage Class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class DrawablePage
Visual Basic (Usage) Copy Code
Dim instance As DrawablePage
C#
public abstract class DrawablePage

Inheritance Hierarchy

System.Object
Telerik.ReportViewer.WinForms.DrawablePage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DrawablePage Members
Telerik.ReportViewer.WinForms Namespace


DrawablePage Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
DrawablePage Class Members
See Also Properties Methods
[image]
Telerik.ReportViewer.WinForms Namespace : DrawablePage Class

The following tables list the members exposed by DrawablePage.

Public Properties

 | Name | Description
Public Property | ExternalMargin |
Public Property | Size |
Top

Public Methods

 | Name | Description
Public Method | Draw |
Top

See Also

Reference

DrawablePage Class
Telerik.ReportViewer.WinForms Namespace


DrawablePage Class Methods

Telerik.ReportViewer.WinForms Send comments on this topic.
DrawablePage Class Methods
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : DrawablePage Class

For a list of all members of this type, see DrawablePage members.

Public Methods

 | Name | Description
Public Method | Draw |
Top

See Also

Reference

DrawablePage Class
Telerik.ReportViewer.WinForms Namespace


Draw Method

Telerik.ReportViewer.WinForms Send comments on this topic.
Draw Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > DrawablePage Class : Draw Method

g

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Draw( _
   ByVal g As Graphics _
)
Visual Basic (Usage) Copy Code
Dim instance As DrawablePage
Dim g As Graphics

instance.Draw(g)
C#
public abstract void Draw(
   Graphics g
)

Parameters

g

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DrawablePage Class
DrawablePage Members


DrawablePage Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
DrawablePage Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : DrawablePage Class

For a list of all members of this type, see DrawablePage members.

Public Properties

 | Name | Description
Public Property | ExternalMargin |
Public Property | Size |
Top

See Also

Reference

DrawablePage Class
Telerik.ReportViewer.WinForms Namespace


ExternalMargin Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ExternalMargin Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > DrawablePage Class : ExternalMargin Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property ExternalMargin As Integer
Visual Basic (Usage) Copy Code
Dim instance As DrawablePage
Dim value As Integer

value = instance.ExternalMargin
C#
public abstract int ExternalMargin {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DrawablePage Class
DrawablePage Members


Size Property

Telerik.ReportViewer.WinForms Send comments on this topic.
Size Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > DrawablePage Class : Size Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Size As Size
Visual Basic (Usage) Copy Code
Dim instance As DrawablePage
Dim value As Size

value = instance.Size
C#
public abstract Size Size {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DrawablePage Class
DrawablePage Members


ExportEventArgs Class

Telerik.ReportViewer.WinForms Send comments on this topic.
ExportEventArgs Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : ExportEventArgs Class

Object Model

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExportEventArgs
   Inherits CancelEventArgs
Visual Basic (Usage) Copy Code
Dim instance As ExportEventArgs
C#
public sealed class ExportEventArgs : CancelEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
Telerik.ReportViewer.WinForms.ExportEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExportEventArgs Members
Telerik.ReportViewer.WinForms Namespace


ExportEventArgs Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
ExportEventArgs Class Members
See Also Properties
[image]
Telerik.ReportViewer.WinForms Namespace : ExportEventArgs Class

The following tables list the members exposed by ExportEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ExportEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | DeviceInfo |
Public Property | RenderingExtension |
Top

See Also

Reference

ExportEventArgs Class
Telerik.ReportViewer.WinForms Namespace


ExportEventArgs Constructor

Telerik.ReportViewer.WinForms Send comments on this topic.
ExportEventArgs Constructor
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ExportEventArgs Class : ExportEventArgs Constructor

renderingExtension

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal renderingExtension As ExtensionInfo _
)
Visual Basic (Usage) Copy Code
Dim renderingExtension As ExtensionInfo

Dim instance As ExportEventArgs(renderingExtension)
C#
public ExportEventArgs(
   ExtensionInfo renderingExtension
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal renderingExtension As ExtensionInfo _
)
Visual Basic (Usage) Copy Code
Dim renderingExtension As ExtensionInfo

Dim instance As ExportEventArgs(renderingExtension)
C#
public ExportEventArgs(
   ExtensionInfo renderingExtension
)

Parameters

renderingExtension

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExportEventArgs Class
ExportEventArgs Members


ExportEventArgs Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
ExportEventArgs Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ExportEventArgs Class

For a list of all members of this type, see ExportEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | DeviceInfo |
Public Property | RenderingExtension |
Top

See Also

Reference

ExportEventArgs Class
Telerik.ReportViewer.WinForms Namespace


DeviceInfo Property

Telerik.ReportViewer.WinForms Send comments on this topic.
DeviceInfo Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ExportEventArgs Class : DeviceInfo Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceInfo As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As ExportEventArgs
Dim value As Hashtable

instance.DeviceInfo = value

value = instance.DeviceInfo
C#
public Hashtable DeviceInfo {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExportEventArgs Class
ExportEventArgs Members


RenderingExtension Property

Telerik.ReportViewer.WinForms Send comments on this topic.
RenderingExtension Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ExportEventArgs Class : RenderingExtension Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RenderingExtension As ExtensionInfo
Visual Basic (Usage) Copy Code
Dim instance As ExportEventArgs
Dim value As ExtensionInfo

value = instance.RenderingExtension
C#
public ExtensionInfo RenderingExtension {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExportEventArgs Class
ExportEventArgs Members


ParametersArea.Composition Class

Telerik.ReportViewer.WinForms Send comments on this topic.
ParametersArea.Composition Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : ParametersArea.Composition Class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Private Class ParametersArea.Composition
Visual Basic (Usage) Copy Code
Dim instance As ParametersArea.Composition
C#
private class ParametersArea.Composition

Inheritance Hierarchy

System.Object
Telerik.ReportViewer.WinForms.ParametersArea.Composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersArea.Composition Members
Telerik.ReportViewer.WinForms Namespace


ParametersArea.Composition Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
ParametersArea.Composition Class Members
See Also Properties
[image]
Telerik.ReportViewer.WinForms Namespace : ParametersArea.Composition Class

The following tables list the members exposed by ParametersArea.Composition.

Public Constructors

 | Name | Description
Public Constructor | ParametersArea.Composition Constructor |
Top

Public Properties

 | Name | Description
Public Property | Editor |
Public Property | Label |
Top

See Also

Reference

ParametersArea.Composition Class
Telerik.ReportViewer.WinForms Namespace


ParametersArea.Composition Constructor

Telerik.ReportViewer.WinForms Send comments on this topic.
ParametersArea.Composition Constructor
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ParametersArea.Composition Class : ParametersArea.Composition Constructor

editor
label

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal editor As Control, _
   ByVal label As Label _
)
Visual Basic (Usage) Copy Code
Dim editor As Control
Dim label As Label

Dim instance As ParametersArea.Composition(editor, label)
C#
public ParametersArea.Composition(
   Control editor,
   Label label
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal editor As Control, _
   ByVal label As Label _
)
Visual Basic (Usage) Copy Code
Dim editor As Control
Dim label As Label

Dim instance As ParametersArea.Composition(editor, label)
C#
public ParametersArea.Composition(
   Control editor,
   Label label
)

Parameters

editor
label

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersArea.Composition Class
ParametersArea.Composition Members


ParametersArea.Composition Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
ParametersArea.Composition Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ParametersArea.Composition Class

For a list of all members of this type, see ParametersArea.Composition members.

Public Properties

 | Name | Description
Public Property | Editor |
Public Property | Label |
Top

See Also

Reference

ParametersArea.Composition Class
Telerik.ReportViewer.WinForms Namespace


Editor Property

Telerik.ReportViewer.WinForms Send comments on this topic.
Editor Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ParametersArea.Composition Class : Editor Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Editor As Control
Visual Basic (Usage) Copy Code
Dim instance As ParametersArea.Composition
Dim value As Control

value = instance.Editor
C#
public Control Editor {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersArea.Composition Class
ParametersArea.Composition Members


Label Property

Telerik.ReportViewer.WinForms Send comments on this topic.
Label Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ParametersArea.Composition Class : Label Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Label As Label
Visual Basic (Usage) Copy Code
Dim instance As ParametersArea.Composition
Dim value As Label

value = instance.Label
C#
public Label Label {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersArea.Composition Class
ParametersArea.Composition Members


ParametersArea.Matrix Class

Telerik.ReportViewer.WinForms Send comments on this topic.
ParametersArea.Matrix Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : ParametersArea.Matrix Class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Private Class ParametersArea.Matrix
Visual Basic (Usage) Copy Code
Dim instance As ParametersArea.Matrix
C#
private class ParametersArea.Matrix

Inheritance Hierarchy

System.Object
Telerik.ReportViewer.WinForms.ParametersArea.Matrix

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersArea.Matrix Members
Telerik.ReportViewer.WinForms Namespace


ParametersArea.Matrix Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
ParametersArea.Matrix Class Members
See Also Methods
[image]
Telerik.ReportViewer.WinForms Namespace : ParametersArea.Matrix Class

The following tables list the members exposed by ParametersArea.Matrix.

Public Constructors

 | Name | Description
Public Constructor | ParametersArea.Matrix Constructor |
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | GetWidth |
Public Method | LayoutControls |
Top

See Also

Reference

ParametersArea.Matrix Class
Telerik.ReportViewer.WinForms Namespace


ParametersArea.Matrix Constructor

Telerik.ReportViewer.WinForms Send comments on this topic.
ParametersArea.Matrix Constructor
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ParametersArea.Matrix Class : ParametersArea.Matrix Constructor

rows
columns
rowSpacing
columnSpacing
columnStick

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rows As Integer, _
   ByVal columns As Integer, _
   ByVal rowSpacing As Integer, _
   ByVal columnSpacing As Integer, _
   ByVal columnStick As Integer _
)
Visual Basic (Usage) Copy Code
Dim rows As Integer
Dim columns As Integer
Dim rowSpacing As Integer
Dim columnSpacing As Integer
Dim columnStick As Integer

Dim instance As ParametersArea.Matrix(rows, columns, rowSpacing, columnSpacing, columnStick)
C#
public ParametersArea.Matrix(
   int rows,
   int columns,
   int rowSpacing,
   int columnSpacing,
   int columnStick
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rows As Integer, _
   ByVal columns As Integer, _
   ByVal rowSpacing As Integer, _
   ByVal columnSpacing As Integer, _
   ByVal columnStick As Integer _
)
Visual Basic (Usage) Copy Code
Dim rows As Integer
Dim columns As Integer
Dim rowSpacing As Integer
Dim columnSpacing As Integer
Dim columnStick As Integer

Dim instance As ParametersArea.Matrix(rows, columns, rowSpacing, columnSpacing, columnStick)
C#
public ParametersArea.Matrix(
   int rows,
   int columns,
   int rowSpacing,
   int columnSpacing,
   int columnStick
)

Parameters

rows
columns
rowSpacing
columnSpacing
columnStick

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersArea.Matrix Class
ParametersArea.Matrix Members


ParametersArea.Matrix Class Methods

Telerik.ReportViewer.WinForms Send comments on this topic.
ParametersArea.Matrix Class Methods
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ParametersArea.Matrix Class

For a list of all members of this type, see ParametersArea.Matrix members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | GetWidth |
Public Method | LayoutControls |
Top

See Also

Reference

ParametersArea.Matrix Class
Telerik.ReportViewer.WinForms Namespace


Add Method

Telerik.ReportViewer.WinForms Send comments on this topic.
Add Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ParametersArea.Matrix Class : Add Method

control
row
column

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal control As Control, _
   ByVal row As Integer, _
   ByVal column As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ParametersArea.Matrix
Dim control As Control
Dim row As Integer
Dim column As Integer

instance.Add(control, row, column)
C#
public void Add(
   Control control,
   int row,
   int column
)

Parameters

control
row
column

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersArea.Matrix Class
ParametersArea.Matrix Members


GetWidth Method

Telerik.ReportViewer.WinForms Send comments on this topic.
GetWidth Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ParametersArea.Matrix Class : GetWidth Method

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function GetWidth() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ParametersArea.Matrix
Dim value As Integer

value = instance.GetWidth()
C#
public int GetWidth()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersArea.Matrix Class
ParametersArea.Matrix Members


LayoutControls Method

Telerik.ReportViewer.WinForms Send comments on this topic.
LayoutControls Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ParametersArea.Matrix Class : LayoutControls Method

container

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function LayoutControls( _
   ByVal container As Control _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ParametersArea.Matrix
Dim container As Control
Dim value As Integer

value = instance.LayoutControls(container)
C#
public int LayoutControls(
   Control container
)

Parameters

container

Return Value

Returns preferred height of the container

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersArea.Matrix Class
ParametersArea.Matrix Members


ReportExplorerForm Class

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportExplorerForm Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : ReportExplorerForm Class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Private Class ReportExplorerForm
   Inherits Form
Visual Basic (Usage) Copy Code
Dim instance As ReportExplorerForm
C#
private class ReportExplorerForm : Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Telerik.ReportViewer.WinForms.ReportExplorerForm

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportExplorerForm Members
Telerik.ReportViewer.WinForms Namespace


ReportExplorerForm Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportExplorerForm Class Members
See Also Properties Methods Events
[image]
Telerik.ReportViewer.WinForms Namespace : ReportExplorerForm Class

The following tables list the members exposed by ReportExplorerForm.

Public Constructors

 | Name | Description
Public Constructor | ReportExplorerForm Constructor |
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | ActiveMdiChild | (Inherited from System.Windows.Forms.Form)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | AllowTransparency | (Inherited from System.Windows.Forms.Form)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Property | DesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Property | DialogResult | (Inherited from System.Windows.Forms.Form)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiChild | (Inherited from System.Windows.Forms.Form)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | IsRestrictedWindow | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MdiChildren | (Inherited from System.Windows.Forms.Form)
Public Property | MdiParent | (Inherited from System.Windows.Forms.Form)
Public Property | Menu | (Inherited from System.Windows.Forms.Form)
Public Property | MergedMenu | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Modal | (Inherited from System.Windows.Forms.Form)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | OwnedForms | (Inherited from System.Windows.Forms.Form)
Public Property | Owner | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | RestoreBounds | (Inherited from System.Windows.Forms.Form)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevel | (Inherited from System.Windows.Forms.Form)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.Form)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Form)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.Form)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | MaximizedBounds | (Inherited from System.Windows.Forms.Form)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowWithoutActivation | (Inherited from System.Windows.Forms.Form)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Clean up any resources being used.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | ActivateMdiChild | (Inherited from System.Windows.Forms.Form)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.Form)
Protected Method | CenterToParent | (Inherited from System.Windows.Forms.Form)
Protected Method | CenterToScreen | (Inherited from System.Windows.Forms.Form)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Form)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Form)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Form)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Form)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnActivated | (Inherited from System.Windows.Forms.Form)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClosed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnClosing | (Inherited from System.Windows.Forms.Form)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Form)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDeactivate | (Inherited from System.Windows.Forms.Form)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Form)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFormClosed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnFormClosing | (Inherited from System.Windows.Forms.Form)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnInputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.Form)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | Overridden.
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMdiChildActivate | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMenuComplete | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMenuStart | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Form)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.Form)
Protected Method | OnResizeBegin | (Inherited from System.Windows.Forms.Form)
Protected Method | OnResizeEnd | (Inherited from System.Windows.Forms.Form)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnRightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnShown | (Inherited from System.Windows.Forms.Form)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.Form)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.Form)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.Form)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.Form)
Top

Public Events

 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MenuComplete | (Inherited from System.Windows.Forms.Form)
Public Event | MenuStart | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportExplorerForm Class
Telerik.ReportViewer.WinForms Namespace


ReportExplorerForm Constructor

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportExplorerForm Constructor
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportExplorerForm Class : ReportExplorerForm Constructor

reportViewer

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportViewer As ReportViewerBase _
)
Visual Basic (Usage) Copy Code
Dim reportViewer As ReportViewerBase

Dim instance As ReportExplorerForm(reportViewer)
C#
public ReportExplorerForm(
   ReportViewerBase reportViewer
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportViewer As ReportViewerBase _
)
Visual Basic (Usage) Copy Code
Dim reportViewer As ReportViewerBase

Dim instance As ReportExplorerForm(reportViewer)
C#
public ReportExplorerForm(
   ReportViewerBase reportViewer
)

Parameters

reportViewer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportExplorerForm Class
ReportExplorerForm Members


ReportExplorerForm Class Methods

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportExplorerForm Class Methods
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportExplorerForm Class

For a list of all members of this type, see ReportExplorerForm members.

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Clean up any resources being used.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | ActivateMdiChild | (Inherited from System.Windows.Forms.Form)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.Form)
Protected Method | CenterToParent | (Inherited from System.Windows.Forms.Form)
Protected Method | CenterToScreen | (Inherited from System.Windows.Forms.Form)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Form)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Form)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Form)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Form)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnActivated | (Inherited from System.Windows.Forms.Form)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClosed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnClosing | (Inherited from System.Windows.Forms.Form)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Form)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDeactivate | (Inherited from System.Windows.Forms.Form)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Form)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFormClosed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnFormClosing | (Inherited from System.Windows.Forms.Form)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnInputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.Form)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | Overridden.
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMdiChildActivate | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMenuComplete | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMenuStart | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Form)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.Form)
Protected Method | OnResizeBegin | (Inherited from System.Windows.Forms.Form)
Protected Method | OnResizeEnd | (Inherited from System.Windows.Forms.Form)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnRightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnShown | (Inherited from System.Windows.Forms.Form)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.Form)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.Form)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.Form)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

ReportExplorerForm Class
Telerik.ReportViewer.WinForms Namespace


Dispose Method

Telerik.ReportViewer.WinForms Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportExplorerForm Class : Dispose Method

Clean up any resources being used.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Overload List

Overload | Description
Dispose(Boolean) | Clean up any resources being used.
Dispose() | (Inherited from System.ComponentModel.Component)

Overload List

Overload | Description
Dispose(Boolean) | Clean up any resources being used.
Dispose() | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportExplorerForm Class
ReportExplorerForm Members


Dispose(Boolean) Method

Telerik.ReportViewer.WinForms Send comments on this topic.
Dispose(Boolean) Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportExplorerForm Class > Dispose Method : Dispose(Boolean) Method

disposing
true if managed resources should be disposed; otherwise, false.
Clean up any resources being used.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportExplorerForm
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportExplorerForm Class
ReportExplorerForm Members
Overload List


OnLoad Method

Telerik.ReportViewer.WinForms Send comments on this topic.
OnLoad Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportExplorerForm Class : OnLoad Method

e

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnLoad( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportExplorerForm
Dim e As EventArgs

instance.OnLoad(e)
C#
protected override void OnLoad(
   EventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportExplorerForm Class
ReportExplorerForm Members


ReportExplorerForm.ReportExplorerTreeView Class

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportExplorerForm.ReportExplorerTreeView Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : ReportExplorerForm.ReportExplorerTreeView Class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Private Class ReportExplorerForm.ReportExplorerTreeView
   Inherits TreeView
Visual Basic (Usage) Copy Code
Dim instance As ReportExplorerForm.ReportExplorerTreeView
C#
private class ReportExplorerForm.ReportExplorerTreeView : TreeView

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.TreeView
Telerik.ReportViewer.WinForms.ReportExplorerForm.ReportExplorerTreeView

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportExplorerForm.ReportExplorerTreeView Members
Telerik.ReportViewer.WinForms Namespace


ReportExplorerForm.ReportExplorerTreeView Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportExplorerForm.ReportExplorerTreeView Class Members
See Also Properties Methods Events
[image]
Telerik.ReportViewer.WinForms Namespace : ReportExplorerForm.ReportExplorerTreeView Class

The following tables list the members exposed by ReportExplorerForm.ReportExplorerTreeView.

Public Constructors

 | Name | Description
Public Constructor | ReportExplorerForm.ReportExplorerTreeView Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | (Inherited from System.Windows.Forms.TreeView)
Public Property | BindingContext | (Inherited from System.Windows.Forms.Control)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.TreeView)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | CheckBoxes | (Inherited from System.Windows.Forms.TreeView)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | DrawMode | (Inherited from System.Windows.Forms.TreeView)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.TreeView)
Public Property | FullRowSelect | (Inherited from System.Windows.Forms.TreeView)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HideSelection | (Inherited from System.Windows.Forms.TreeView)
Public Property | HotTracking | (Inherited from System.Windows.Forms.TreeView)
Public Property | ImageIndex | (Inherited from System.Windows.Forms.TreeView)
Public Property | ImageKey | (Inherited from System.Windows.Forms.TreeView)
Public Property | ImageList | (Inherited from System.Windows.Forms.TreeView)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | Indent | (Inherited from System.Windows.Forms.TreeView)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | ItemHeight | (Inherited from System.Windows.Forms.TreeView)
Public Property | LabelEdit | (Inherited from System.Windows.Forms.TreeView)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | LineColor | (Inherited from System.Windows.Forms.TreeView)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Nodes | (Inherited from System.Windows.Forms.TreeView)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | PathSeparator | (Inherited from System.Windows.Forms.TreeView)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Report |
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.TreeView)
Public Property | Scrollable | (Inherited from System.Windows.Forms.TreeView)
Public Property | SelectedImageIndex | (Inherited from System.Windows.Forms.TreeView)
Public Property | SelectedImageKey | (Inherited from System.Windows.Forms.TreeView)
Public Property | SelectedNode | (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowLines | (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowNodeToolTips | (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowPlusMinus | (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowRootLines | (Inherited from System.Windows.Forms.TreeView)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | StateImageList | (Inherited from System.Windows.Forms.TreeView)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TopNode | (Inherited from System.Windows.Forms.TreeView)
Public Property | TreeViewNodeSorter | (Inherited from System.Windows.Forms.TreeView)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | VisibleCount | (Inherited from System.Windows.Forms.TreeView)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.Control)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.TreeView)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.TreeView)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BeginUpdate | (Inherited from System.Windows.Forms.TreeView)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | CollapseAll | (Inherited from System.Windows.Forms.TreeView)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | EndUpdate | (Inherited from System.Windows.Forms.TreeView)
Public Method | ExpandAll | (Inherited from System.Windows.Forms.TreeView)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetNodeAt | Overloaded. (Inherited from System.Windows.Forms.TreeView)
Public Method | GetNodeCount | (Inherited from System.Windows.Forms.TreeView)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | HitTest | Overloaded. (Inherited from System.Windows.Forms.TreeView)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RefreshReport |
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | Sort | (Inherited from System.Windows.Forms.TreeView)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.TreeView)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.TreeView)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetItemRenderStyles | (Inherited from System.Windows.Forms.TreeView)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.TreeView)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAfterCheck | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnAfterCollapse | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnAfterExpand | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnAfterLabelEdit | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnAfterSelect | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBeforeCheck | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnBeforeCollapse | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnBeforeExpand | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnBeforeLabelEdit | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnBeforeSelect | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDrawNode | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnItemDrag | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNodeMouseClick | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnNodeMouseDoubleClick | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnNodeMouseHover | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRightToLeftLayoutChanged | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.Control)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.TreeView)
Top

Public Events

 | Name | Description
Public Event | AfterCheck | (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterCollapse | (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterExpand | (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterLabelEdit | (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterSelect | (Inherited from System.Windows.Forms.TreeView)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BeforeCheck | (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeCollapse | (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeExpand | (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeLabelEdit | (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeSelect | (Inherited from System.Windows.Forms.TreeView)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | DrawNode | (Inherited from System.Windows.Forms.TreeView)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | ItemDrag | (Inherited from System.Windows.Forms.TreeView)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | NodeMouseClick | (Inherited from System.Windows.Forms.TreeView)
Public Event | NodeMouseDoubleClick | (Inherited from System.Windows.Forms.TreeView)
Public Event | NodeMouseHover | (Inherited from System.Windows.Forms.TreeView)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.TreeView)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportExplorerForm.ReportExplorerTreeView Class
Telerik.ReportViewer.WinForms Namespace


ReportExplorerForm.ReportExplorerTreeView Constructor

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportExplorerForm.ReportExplorerTreeView Constructor
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportExplorerForm.ReportExplorerTreeView Class : ReportExplorerForm.ReportExplorerTreeView Constructor

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportExplorerForm.ReportExplorerTreeView()
C#
public ReportExplorerForm.ReportExplorerTreeView()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportExplorerForm.ReportExplorerTreeView()
C#
public ReportExplorerForm.ReportExplorerTreeView()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportExplorerForm.ReportExplorerTreeView Class
ReportExplorerForm.ReportExplorerTreeView Members


ReportExplorerForm.ReportExplorerTreeView Class Methods

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportExplorerForm.ReportExplorerTreeView Class Methods
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportExplorerForm.ReportExplorerTreeView Class

For a list of all members of this type, see ReportExplorerForm.ReportExplorerTreeView members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BeginUpdate | (Inherited from System.Windows.Forms.TreeView)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | CollapseAll | (Inherited from System.Windows.Forms.TreeView)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | EndUpdate | (Inherited from System.Windows.Forms.TreeView)
Public Method | ExpandAll | (Inherited from System.Windows.Forms.TreeView)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetNodeAt | Overloaded. (Inherited from System.Windows.Forms.TreeView)
Public Method | GetNodeCount | (Inherited from System.Windows.Forms.TreeView)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | HitTest | Overloaded. (Inherited from System.Windows.Forms.TreeView)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RefreshReport |
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | Sort | (Inherited from System.Windows.Forms.TreeView)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.TreeView)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.TreeView)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetItemRenderStyles | (Inherited from System.Windows.Forms.TreeView)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.TreeView)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAfterCheck | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnAfterCollapse | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnAfterExpand | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnAfterLabelEdit | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnAfterSelect | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBeforeCheck | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnBeforeCollapse | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnBeforeExpand | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnBeforeLabelEdit | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnBeforeSelect | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDrawNode | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnItemDrag | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNodeMouseClick | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnNodeMouseDoubleClick | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnNodeMouseHover | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRightToLeftLayoutChanged | (Inherited from System.Windows.Forms.TreeView)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.Control)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.TreeView)
Top

See Also

Reference

ReportExplorerForm.ReportExplorerTreeView Class
Telerik.ReportViewer.WinForms Namespace


Dispose Method

Telerik.ReportViewer.WinForms Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportExplorerForm.ReportExplorerTreeView Class : Dispose Method

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Overload List

Overload | Description
Dispose(Boolean) |
Dispose() | (Inherited from System.ComponentModel.Component)

Overload List

Overload | Description
Dispose(Boolean) |
Dispose() | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportExplorerForm.ReportExplorerTreeView Class
ReportExplorerForm.ReportExplorerTreeView Members


Dispose(Boolean) Method

Telerik.ReportViewer.WinForms Send comments on this topic.
Dispose(Boolean) Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportExplorerForm.ReportExplorerTreeView Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportExplorerForm.ReportExplorerTreeView
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportExplorerForm.ReportExplorerTreeView Class
ReportExplorerForm.ReportExplorerTreeView Members
Overload List


RefreshReport Method

Telerik.ReportViewer.WinForms Send comments on this topic.
RefreshReport Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportExplorerForm.ReportExplorerTreeView Class : RefreshReport Method

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshReport()
Visual Basic (Usage) Copy Code
Dim instance As ReportExplorerForm.ReportExplorerTreeView

instance.RefreshReport()
C#
public void RefreshReport()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportExplorerForm.ReportExplorerTreeView Class
ReportExplorerForm.ReportExplorerTreeView Members


ReportExplorerForm.ReportExplorerTreeView Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportExplorerForm.ReportExplorerTreeView Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportExplorerForm.ReportExplorerTreeView Class

For a list of all members of this type, see ReportExplorerForm.ReportExplorerTreeView members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | (Inherited from System.Windows.Forms.TreeView)
Public Property | BindingContext | (Inherited from System.Windows.Forms.Control)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.TreeView)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | CheckBoxes | (Inherited from System.Windows.Forms.TreeView)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | DrawMode | (Inherited from System.Windows.Forms.TreeView)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.TreeView)
Public Property | FullRowSelect | (Inherited from System.Windows.Forms.TreeView)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HideSelection | (Inherited from System.Windows.Forms.TreeView)
Public Property | HotTracking | (Inherited from System.Windows.Forms.TreeView)
Public Property | ImageIndex | (Inherited from System.Windows.Forms.TreeView)
Public Property | ImageKey | (Inherited from System.Windows.Forms.TreeView)
Public Property | ImageList | (Inherited from System.Windows.Forms.TreeView)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | Indent | (Inherited from System.Windows.Forms.TreeView)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | ItemHeight | (Inherited from System.Windows.Forms.TreeView)
Public Property | LabelEdit | (Inherited from System.Windows.Forms.TreeView)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | LineColor | (Inherited from System.Windows.Forms.TreeView)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Nodes | (Inherited from System.Windows.Forms.TreeView)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | PathSeparator | (Inherited from System.Windows.Forms.TreeView)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Report |
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.TreeView)
Public Property | Scrollable | (Inherited from System.Windows.Forms.TreeView)
Public Property | SelectedImageIndex | (Inherited from System.Windows.Forms.TreeView)
Public Property | SelectedImageKey | (Inherited from System.Windows.Forms.TreeView)
Public Property | SelectedNode | (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowLines | (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowNodeToolTips | (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowPlusMinus | (Inherited from System.Windows.Forms.TreeView)
Public Property | ShowRootLines | (Inherited from System.Windows.Forms.TreeView)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | StateImageList | (Inherited from System.Windows.Forms.TreeView)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TopNode | (Inherited from System.Windows.Forms.TreeView)
Public Property | TreeViewNodeSorter | (Inherited from System.Windows.Forms.TreeView)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | VisibleCount | (Inherited from System.Windows.Forms.TreeView)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.Control)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.TreeView)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.TreeView)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportExplorerForm.ReportExplorerTreeView Class
Telerik.ReportViewer.WinForms Namespace


Report Property

Telerik.ReportViewer.WinForms Send comments on this topic.
Report Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportExplorerForm.ReportExplorerTreeView Class : Report Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Report As Report
Visual Basic (Usage) Copy Code
Dim instance As ReportExplorerForm.ReportExplorerTreeView

instance.Report = value
C#
public Report Report {set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportExplorerForm.ReportExplorerTreeView Class
ReportExplorerForm.ReportExplorerTreeView Members


ReportViewer Class

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewer Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewer Class

Object Model

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportViewer
   Inherits ReportViewerBase
   Implements IReportParameterEditorFactory
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
C#
public class ReportViewer : ReportViewerBase, IReportParameterEditorFactory

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Telerik.ReportViewer.WinForms.ReportViewerBase
Telerik.ReportViewer.WinForms.ReportViewer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Members
Telerik.ReportViewer.WinForms Namespace


ReportViewer Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewer Class Members
See Also Properties Methods Events
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewer Class

The following tables list the members exposed by ReportViewer.

Public Constructors

 | Name | Description
Public Constructor | ReportViewer Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | CurrentPage | Gets or sets the current page in the viewer. (Inherited from ReportViewerBase)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | ParametersAreaVisible | Gets or sets a value that indicates whether the parameters area is displayed if any parameter editor exists. (Inherited from ReportViewerBase)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProcessingState | Gets the current processing state of the viewer (Inherited from ReportViewerBase)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Report | Gets or sets the report displayed in the viewer. (Inherited from ReportViewerBase)
Public Property | Resources | (Inherited from ReportViewerBase)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | ShowExportButton | Indicates whether Export button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowPageNavigationControls | Indicates whether the page navigation controls are visible. (Inherited from ReportViewerBase)
Public Property | ShowPageSetup | Indicates whether PageSetup button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowPageSetupButton | Indicates whether PageSetup button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowParametersButton | Indicates whether Parameters button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowPrintButton | Indicates whether Print button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowProgress | Indicates whether progress animation should be displayed while the report is rendered. (Inherited from ReportViewerBase)
Public Property | ShowRefreshButton | Indicates whether the Refresh button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowStopButton | Indicates whether the Stop button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowZoom | Indicates whether the Zoom input box should be visible. (Inherited from ReportViewerBase)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | ToolbarVisible | Indicates whether the toolbar should be visible on the viewer. (Inherited from ReportViewerBase)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TotalPages | Gets the count of the available pages in the viewer. (Inherited from ReportViewerBase)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | ZoomMode | Gets or sets the zoom mode of the viewer. (Inherited from ReportViewerBase)
Public Property | ZoomPercent | Gets or sets the percentage of zoom used for the report display. (Inherited from ReportViewerBase)
Top

Protected Properties

 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | CancelRendering | Stops background processing of the report. (Inherited from ReportViewerBase)
Public Method | CanMoveToPage | Determines whether the viewer can be navigated to a specified page. (Inherited from ReportViewerBase)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from ReportViewerBase)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | ExportReport | Exports the report in the specified format. (Inherited from ReportViewerBase)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PrintReport | Opens the print dialog for the report (Inherited from ReportViewerBase)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RefreshReport | Refreshes the report in the viewer. This method should not be called before the Form.Load() event is fired (avoid using it in the Form's constructor). (Inherited from ReportViewerBase)
Public Method | Reset | Resets the control to its default values. (Inherited from ReportViewerBase)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | ShowPageSetupDialog | Opens the page setup dialog (Inherited from ReportViewerBase)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateParameterEditor | For future use. Override this method to provide custom parameter editors and replace the defaults. (Inherited from ReportViewerBase)
Protected Method | CreateRenderingDeviceInfo | Overridden.
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | (Inherited from ReportViewerBase)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnUpdateUI | (Inherited from ReportViewerBase)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | Export | Occurs when the report in the viewer control is exported. (Inherited from ReportViewerBase)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | Print | Occurs when the report in the viewer control is printed. (Inherited from ReportViewerBase)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RenderingBegin | Occurs when the report in the viewer control is rendered. (Inherited from ReportViewerBase)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | UpdateUI | Occurs when the UI of the report viewer control is updated. (Inherited from ReportViewerBase)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportViewer Class
Telerik.ReportViewer.WinForms Namespace


ReportViewer Constructor

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewer Constructor
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewer Class : ReportViewer Constructor

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer()
C#
public ReportViewer()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer()
C#
public ReportViewer()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportViewer Class Methods

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewer Class Methods
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewer Class

For a list of all members of this type, see ReportViewer members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | CancelRendering | Stops background processing of the report. (Inherited from ReportViewerBase)
Public Method | CanMoveToPage | Determines whether the viewer can be navigated to a specified page. (Inherited from ReportViewerBase)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from ReportViewerBase)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | ExportReport | Exports the report in the specified format. (Inherited from ReportViewerBase)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PrintReport | Opens the print dialog for the report (Inherited from ReportViewerBase)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RefreshReport | Refreshes the report in the viewer. This method should not be called before the Form.Load() event is fired (avoid using it in the Form's constructor). (Inherited from ReportViewerBase)
Public Method | Reset | Resets the control to its default values. (Inherited from ReportViewerBase)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | ShowPageSetupDialog | Opens the page setup dialog (Inherited from ReportViewerBase)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateParameterEditor | For future use. Override this method to provide custom parameter editors and replace the defaults. (Inherited from ReportViewerBase)
Protected Method | CreateRenderingDeviceInfo | Overridden.
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | (Inherited from ReportViewerBase)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnUpdateUI | (Inherited from ReportViewerBase)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

ReportViewer Class
Telerik.ReportViewer.WinForms Namespace


CreateRenderingDeviceInfo Method

Telerik.ReportViewer.WinForms Send comments on this topic.
CreateRenderingDeviceInfo Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewer Class : CreateRenderingDeviceInfo Method

startPage
endPage

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function CreateRenderingDeviceInfo( _
   ByVal startPage As Integer, _
   ByVal endPage As Integer _
) As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim startPage As Integer
Dim endPage As Integer
Dim value As Hashtable

value = instance.CreateRenderingDeviceInfo(startPage, endPage)
C#
protected override Hashtable CreateRenderingDeviceInfo(
   int startPage,
   int endPage
)

Parameters

startPage
endPage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportViewerAreaBase Class

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerAreaBase Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerAreaBase Class

Object Model

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ReportViewerAreaBase
   Inherits UserControl
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerAreaBase
C#
public abstract class ReportViewerAreaBase : UserControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Telerik.ReportViewer.WinForms.ReportViewerAreaBase
Telerik.ReportViewer.WinForms.WinViewer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerAreaBase Members
Telerik.ReportViewer.WinForms Namespace


ReportViewerAreaBase Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerAreaBase Class Members
See Also Fields Properties Methods Events
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerAreaBase Class

The following tables list the members exposed by ReportViewerAreaBase.

Protected Fields

 | Name | Description
Protected Field | inLongRunningAction |
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Viewer |
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetNewPage |
Public Method | SetZoom |
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | ShowMessage | Overloaded.
Public Method | ShowWaitMessage |
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ChangeView |
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPageNavigation |
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateUIState |
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerAreaBase Class Methods

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerAreaBase Class Methods
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerAreaBase Class

For a list of all members of this type, see ReportViewerAreaBase members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetNewPage |
Public Method | SetZoom |
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | ShowMessage | Overloaded.
Public Method | ShowWaitMessage |
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ChangeView |
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPageNavigation |
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateUIState |
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


ChangeView Method

Telerik.ReportViewer.WinForms Send comments on this topic.
ChangeView Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerAreaBase Class : ChangeView Method

viewType

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ChangeView( _
   ByVal viewType As ReportViewerAreaBase.ViewType _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerAreaBase
Dim viewType As ReportViewerAreaBase.ViewType

instance.ChangeView(viewType)
C#
protected virtual void ChangeView(
   ReportViewerAreaBase.ViewType viewType
)

Parameters

viewType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerAreaBase Class
ReportViewerAreaBase Members


OnPageNavigation Method

Telerik.ReportViewer.WinForms Send comments on this topic.
OnPageNavigation Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerAreaBase Class : OnPageNavigation Method

pageNumber

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPageNavigation( _
   ByVal pageNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerAreaBase
Dim pageNumber As Integer

instance.OnPageNavigation(pageNumber)
C#
protected virtual void OnPageNavigation(
   int pageNumber
)

Parameters

pageNumber

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerAreaBase Class
ReportViewerAreaBase Members


SetNewPage Method

Telerik.ReportViewer.WinForms Send comments on this topic.
SetNewPage Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerAreaBase Class : SetNewPage Method

data

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SetNewPage( _
   ByVal data As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerAreaBase
Dim data As Stream

instance.SetNewPage(data)
C#
public abstract void SetNewPage(
   Stream data
)

Parameters

data

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerAreaBase Class
ReportViewerAreaBase Members


SetZoom Method

Telerik.ReportViewer.WinForms Send comments on this topic.
SetZoom Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerAreaBase Class : SetZoom Method

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SetZoom()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerAreaBase

instance.SetZoom()
C#
public abstract void SetZoom()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerAreaBase Class
ReportViewerAreaBase Members


ShowMessage Method

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowMessage Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerAreaBase Class : ShowMessage Method

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Overload List

Overload | Description
ShowMessage(Exception) |
ShowMessage(String,Boolean) |

Overload List

Overload | Description
ShowMessage(Exception) |
ShowMessage(String,Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerAreaBase Class
ReportViewerAreaBase Members


ShowMessage(Exception) Method

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowMessage(Exception) Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerAreaBase Class > ShowMessage Method : ShowMessage(Exception) Method

exception

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub ShowMessage( _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerAreaBase
Dim exception As Exception

instance.ShowMessage(exception)
C#
public void ShowMessage(
   Exception exception
)

Parameters

exception

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerAreaBase Class
ReportViewerAreaBase Members
Overload List


ShowMessage(String,Boolean) Method

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowMessage(String,Boolean) Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerAreaBase Class > ShowMessage Method : ShowMessage(String,Boolean) Method

text
enabled

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub ShowMessage( _
   ByVal text As String, _
   ByVal enabled As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerAreaBase
Dim text As String
Dim enabled As Boolean

instance.ShowMessage(text, enabled)
C#
public void ShowMessage(
   string text,
   bool enabled
)

Parameters

text
enabled

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerAreaBase Class
ReportViewerAreaBase Members
Overload List


ShowWaitMessage Method

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowWaitMessage Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerAreaBase Class : ShowWaitMessage Method

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Sub ShowWaitMessage()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerAreaBase

instance.ShowWaitMessage()
C#
public void ShowWaitMessage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerAreaBase Class
ReportViewerAreaBase Members


UpdateUIState Method

Telerik.ReportViewer.WinForms Send comments on this topic.
UpdateUIState Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerAreaBase Class : UpdateUIState Method

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub UpdateUIState()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerAreaBase

instance.UpdateUIState()
C#
protected virtual void UpdateUIState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerAreaBase Class
ReportViewerAreaBase Members


ReportViewerAreaBase Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerAreaBase Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerAreaBase Class

For a list of all members of this type, see ReportViewerAreaBase members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Viewer |
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

See Also

Reference

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


Viewer Property

Telerik.ReportViewer.WinForms Send comments on this topic.
Viewer Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerAreaBase Class : Viewer Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property Viewer As ReportViewerBase
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerAreaBase
Dim value As ReportViewerBase

instance.Viewer = value

value = instance.Viewer
C#
public ReportViewerBase Viewer {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerAreaBase Class
ReportViewerAreaBase Members


ReportViewerAreaBase Class Fields

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerAreaBase Class Fields
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerAreaBase Class

For a list of all members of this type, see ReportViewerAreaBase members.

Protected Fields

 | Name | Description
Protected Field | inLongRunningAction |
Top

See Also

Reference

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


inLongRunningAction Field

Telerik.ReportViewer.WinForms Send comments on this topic.
inLongRunningAction Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerAreaBase Class : inLongRunningAction Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Protected inLongRunningAction As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerAreaBase
Dim value As Boolean

value = instance.inLongRunningAction

instance.inLongRunningAction = value
C#
protected bool inLongRunningAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerAreaBase Class
ReportViewerAreaBase Members


ReportViewerBase Class

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerBase Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerBase Class

Object Model

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ReportViewerBase
   Inherits UserControl
   Implements IReportParameterEditorFactory
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
C#
public abstract class ReportViewerBase : UserControl, IReportParameterEditorFactory

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Telerik.ReportViewer.WinForms.ReportViewerBase
Telerik.ReportViewer.WinForms.ReportViewer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Members
Telerik.ReportViewer.WinForms Namespace


ReportViewerBase Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerBase Class Members
See Also Properties Methods Events
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerBase Class

The following tables list the members exposed by ReportViewerBase.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | CurrentPage | Gets or sets the current page in the viewer.
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | ParametersAreaVisible | Gets or sets a value that indicates whether the parameters area is displayed if any parameter editor exists.
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProcessingState | Gets the current processing state of the viewer
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Report | Gets or sets the report displayed in the viewer.
Public Property | Resources |
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | ShowExportButton | Indicates whether Export button should be visible.
Public Property | ShowPageNavigationControls | Indicates whether the page navigation controls are visible.
Public Property | ShowPageSetup | Indicates whether PageSetup button should be visible.
Public Property | ShowPageSetupButton | Indicates whether PageSetup button should be visible.
Public Property | ShowParametersButton | Indicates whether Parameters button should be visible.
Public Property | ShowPrintButton | Indicates whether Print button should be visible.
Public Property | ShowProgress | Indicates whether progress animation should be displayed while the report is rendered.
Public Property | ShowRefreshButton | Indicates whether the Refresh button should be visible.
Public Property | ShowStopButton | Indicates whether the Stop button should be visible.
Public Property | ShowZoom | Indicates whether the Zoom input box should be visible.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | ToolbarVisible | Indicates whether the toolbar should be visible on the viewer.
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TotalPages | Gets the count of the available pages in the viewer.
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | ZoomMode | Gets or sets the zoom mode of the viewer.
Public Property | ZoomPercent | Gets or sets the percentage of zoom used for the report display.
Top

Protected Properties

 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | CancelRendering | Stops background processing of the report.
Public Method | CanMoveToPage | Determines whether the viewer can be navigated to a specified page.
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | ExportReport | Exports the report in the specified format.
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PrintReport | Opens the print dialog for the report
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RefreshReport | Refreshes the report in the viewer. This method should not be called before the Form.Load() event is fired (avoid using it in the Form's constructor).
Public Method | Reset | Resets the control to its default values.
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | ShowPageSetupDialog | Opens the page setup dialog
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateParameterEditor | For future use. Override this method to provide custom parameter editors and replace the defaults.
Protected Method | CreateRenderingDeviceInfo |
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | Overridden.
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnUpdateUI |
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | Export | Occurs when the report in the viewer control is exported.
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | Print | Occurs when the report in the viewer control is printed.
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RenderingBegin | Occurs when the report in the viewer control is rendered.
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | UpdateUI | Occurs when the UI of the report viewer control is updated.
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerBase Class Methods

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerBase Class Methods
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerBase Class

For a list of all members of this type, see ReportViewerBase members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | CancelRendering | Stops background processing of the report.
Public Method | CanMoveToPage | Determines whether the viewer can be navigated to a specified page.
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | ExportReport | Exports the report in the specified format.
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PrintReport | Opens the print dialog for the report
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RefreshReport | Refreshes the report in the viewer. This method should not be called before the Form.Load() event is fired (avoid using it in the Form's constructor).
Public Method | Reset | Resets the control to its default values.
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | ShowPageSetupDialog | Opens the page setup dialog
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateParameterEditor | For future use. Override this method to provide custom parameter editors and replace the defaults.
Protected Method | CreateRenderingDeviceInfo |
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | Overridden.
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnUpdateUI |
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


CancelRendering Method

Telerik.ReportViewer.WinForms Send comments on this topic.
CancelRendering Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : CancelRendering Method

timeout
The number of milliseconds to wait for the background rendering to terminate. A value of -1 waits forever. A value of 0 returns immediately without waiting for the rendering to terminate.
Stops background processing of the report.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function CancelRendering( _
   ByVal timeout As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim timeout As Integer
Dim value As Boolean

value = instance.CancelRendering(timeout)
C#
public bool CancelRendering(
   int timeout
)

Parameters

timeout
The number of milliseconds to wait for the background rendering to terminate. A value of -1 waits forever. A value of 0 returns immediately without waiting for the rendering to terminate.

Return Value

A Boolean value. A value of true is returned if the background rendering has terminated. A value of false is returned if background rendering has not terminated after the amount of time specified in the millisecondsTimeout parameter has elapsed, or if the millisecondsTimeout parameter was set to 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


CanMoveToPage Method

Telerik.ReportViewer.WinForms Send comments on this topic.
CanMoveToPage Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : CanMoveToPage Method

pageIndex
The page number to determine navigation possibility.
Determines whether the viewer can be navigated to a specified page.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function CanMoveToPage( _
   ByVal pageIndex As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim pageIndex As Integer
Dim value As Boolean

value = instance.CanMoveToPage(pageIndex)
C#
public bool CanMoveToPage(
   int pageIndex
)

Parameters

pageIndex
The page number to determine navigation possibility.

Return Value

Returns true if the viewer can be moved to the specified page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


CreateParameterEditor Method

Telerik.ReportViewer.WinForms Send comments on this topic.
CreateParameterEditor Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : CreateParameterEditor Method

parameterEditorContext
Provides description of the parameter to be created.
For future use. Override this method to provide custom parameter editors and replace the defaults.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateParameterEditor( _
   ByVal parameterEditorContext As IReportParameterEditorContext _
) As IReportParameterEditor
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim parameterEditorContext As IReportParameterEditorContext
Dim value As IReportParameterEditor

value = instance.CreateParameterEditor(parameterEditorContext)
C#
protected virtual IReportParameterEditor CreateParameterEditor(
   IReportParameterEditorContext parameterEditorContext
)

Parameters

parameterEditorContext
Provides description of the parameter to be created.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


CreateRenderingDeviceInfo Method

Telerik.ReportViewer.WinForms Send comments on this topic.
CreateRenderingDeviceInfo Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : CreateRenderingDeviceInfo Method

startPage
endPage

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function CreateRenderingDeviceInfo( _
   ByVal startPage As Integer, _
   ByVal endPage As Integer _
) As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim startPage As Integer
Dim endPage As Integer
Dim value As Hashtable

value = instance.CreateRenderingDeviceInfo(startPage, endPage)
C#
protected abstract Hashtable CreateRenderingDeviceInfo(
   int startPage,
   int endPage
)

Parameters

startPage
endPage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


Dispose Method

Telerik.ReportViewer.WinForms Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : Dispose Method

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Overload List

Overload | Description
Dispose(Boolean) |
Dispose() | (Inherited from System.ComponentModel.Component)

Overload List

Overload | Description
Dispose(Boolean) |
Dispose() | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


Dispose(Boolean) Method

Telerik.ReportViewer.WinForms Send comments on this topic.
Dispose(Boolean) Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members
Overload List


ExportReport Method

Telerik.ReportViewer.WinForms Send comments on this topic.
ExportReport Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ExportReport Method

format
Export format
deviceInfo
Contains parameters to pass to the rendering extension.
Exports the report in the specified format.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Sub ExportReport( _
   ByVal format As String, _
   ByVal deviceInfo As Hashtable _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim format As String
Dim deviceInfo As Hashtable

instance.ExportReport(format, deviceInfo)
C#
public void ExportReport(
   string format,
   Hashtable deviceInfo
)

Parameters

format
Export format
deviceInfo
Contains parameters to pass to the rendering extension.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


OnLoad Method

Telerik.ReportViewer.WinForms Send comments on this topic.
OnLoad Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : OnLoad Method

e

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnLoad( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim e As EventArgs

instance.OnLoad(e)
C#
protected override void OnLoad(
   EventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


OnUpdateUI Method

Telerik.ReportViewer.WinForms Send comments on this topic.
OnUpdateUI Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : OnUpdateUI Method

sender
e

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnUpdateUI( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim sender As Object
Dim e As EventArgs

instance.OnUpdateUI(sender, e)
C#
protected virtual void OnUpdateUI(
   object sender,
   EventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


PrintReport Method

Telerik.ReportViewer.WinForms Send comments on this topic.
PrintReport Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : PrintReport Method

Opens the print dialog for the report

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Sub PrintReport()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase

instance.PrintReport()
C#
public void PrintReport()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


RefreshReport Method

Telerik.ReportViewer.WinForms Send comments on this topic.
RefreshReport Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : RefreshReport Method

Refreshes the report in the viewer. This method should not be called before the Form.Load() event is fired (avoid using it in the Form's constructor).

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshReport()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase

instance.RefreshReport()
C#
public void RefreshReport()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


Reset Method

Telerik.ReportViewer.WinForms Send comments on this topic.
Reset Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : Reset Method

Resets the control to its default values.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase

instance.Reset()
C#
public void Reset()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ShowPageSetupDialog Method

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowPageSetupDialog Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ShowPageSetupDialog Method

Opens the page setup dialog

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Sub ShowPageSetupDialog()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase

instance.ShowPageSetupDialog()
C#
public void ShowPageSetupDialog()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ReportViewerBase Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerBase Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerBase Class

For a list of all members of this type, see ReportViewerBase members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | CurrentPage | Gets or sets the current page in the viewer.
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | ParametersAreaVisible | Gets or sets a value that indicates whether the parameters area is displayed if any parameter editor exists.
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProcessingState | Gets the current processing state of the viewer
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Report | Gets or sets the report displayed in the viewer.
Public Property | Resources |
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | ShowExportButton | Indicates whether Export button should be visible.
Public Property | ShowPageNavigationControls | Indicates whether the page navigation controls are visible.
Public Property | ShowPageSetup | Indicates whether PageSetup button should be visible.
Public Property | ShowPageSetupButton | Indicates whether PageSetup button should be visible.
Public Property | ShowParametersButton | Indicates whether Parameters button should be visible.
Public Property | ShowPrintButton | Indicates whether Print button should be visible.
Public Property | ShowProgress | Indicates whether progress animation should be displayed while the report is rendered.
Public Property | ShowRefreshButton | Indicates whether the Refresh button should be visible.
Public Property | ShowStopButton | Indicates whether the Stop button should be visible.
Public Property | ShowZoom | Indicates whether the Zoom input box should be visible.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | ToolbarVisible | Indicates whether the toolbar should be visible on the viewer.
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TotalPages | Gets the count of the available pages in the viewer.
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | ZoomMode | Gets or sets the zoom mode of the viewer.
Public Property | ZoomPercent | Gets or sets the percentage of zoom used for the report display.
Top

Protected Properties

 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

See Also

Reference

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


CurrentPage Property

Telerik.ReportViewer.WinForms Send comments on this topic.
CurrentPage Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : CurrentPage Property

Gets or sets the current page in the viewer.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property CurrentPage As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Integer

instance.CurrentPage = value

value = instance.CurrentPage
C#
public int CurrentPage {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ParametersAreaVisible Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ParametersAreaVisible Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ParametersAreaVisible Property

Gets or sets a value that indicates whether the parameters area is displayed if any parameter editor exists.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ParametersAreaVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Boolean

instance.ParametersAreaVisible = value

value = instance.ParametersAreaVisible
C#
public bool ParametersAreaVisible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ProcessingState Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ProcessingState Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ProcessingState Property

Gets the current processing state of the viewer

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProcessingState As ProcessingState
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As ProcessingState

value = instance.ProcessingState
C#
public ProcessingState ProcessingState {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


Report Property

Telerik.ReportViewer.WinForms Send comments on this topic.
Report Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : Report Property

Gets or sets the report displayed in the viewer.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property Report As Report
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Report

instance.Report = value

value = instance.Report
C#
public Report Report {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


Resources Property

Telerik.ReportViewer.WinForms Send comments on this topic.
Resources Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : Resources Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Resources As Resources
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Resources

value = instance.Resources
C#
public Resources Resources {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ShowExportButton Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowExportButton Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ShowExportButton Property

Indicates whether Export button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowExportButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Boolean

instance.ShowExportButton = value

value = instance.ShowExportButton
C#
public bool ShowExportButton {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ShowPageNavigationControls Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowPageNavigationControls Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ShowPageNavigationControls Property

Indicates whether the page navigation controls are visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowPageNavigationControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Boolean

instance.ShowPageNavigationControls = value

value = instance.ShowPageNavigationControls
C#
public bool ShowPageNavigationControls {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ShowPageSetup Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowPageSetup Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ShowPageSetup Property

Indicates whether PageSetup button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowPageSetup As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Boolean

instance.ShowPageSetup = value

value = instance.ShowPageSetup
C#
public bool ShowPageSetup {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ShowPageSetupButton Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowPageSetupButton Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ShowPageSetupButton Property

Indicates whether PageSetup button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowPageSetupButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Boolean

instance.ShowPageSetupButton = value

value = instance.ShowPageSetupButton
C#
public bool ShowPageSetupButton {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ShowParametersButton Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowParametersButton Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ShowParametersButton Property

Indicates whether Parameters button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowParametersButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Boolean

instance.ShowParametersButton = value

value = instance.ShowParametersButton
C#
public bool ShowParametersButton {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ShowPrintButton Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowPrintButton Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ShowPrintButton Property

Indicates whether Print button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowPrintButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Boolean

instance.ShowPrintButton = value

value = instance.ShowPrintButton
C#
public bool ShowPrintButton {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ShowProgress Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowProgress Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ShowProgress Property

Indicates whether progress animation should be displayed while the report is rendered.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowProgress As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Boolean

instance.ShowProgress = value

value = instance.ShowProgress
C#
public bool ShowProgress {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ShowRefreshButton Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowRefreshButton Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ShowRefreshButton Property

Indicates whether the Refresh button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowRefreshButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Boolean

instance.ShowRefreshButton = value

value = instance.ShowRefreshButton
C#
public bool ShowRefreshButton {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ShowStopButton Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowStopButton Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ShowStopButton Property

Indicates whether the Stop button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowStopButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Boolean

instance.ShowStopButton = value

value = instance.ShowStopButton
C#
public bool ShowStopButton {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ShowZoom Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ShowZoom Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ShowZoom Property

Indicates whether the Zoom input box should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowZoom As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Boolean

instance.ShowZoom = value

value = instance.ShowZoom
C#
public bool ShowZoom {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ToolbarVisible Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ToolbarVisible Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ToolbarVisible Property

Indicates whether the toolbar should be visible on the viewer.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ToolbarVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Boolean

instance.ToolbarVisible = value

value = instance.ToolbarVisible
C#
public bool ToolbarVisible {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


TotalPages Property

Telerik.ReportViewer.WinForms Send comments on this topic.
TotalPages Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : TotalPages Property

Gets the count of the available pages in the viewer.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalPages As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Integer

value = instance.TotalPages
C#
public int TotalPages {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ZoomMode Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomMode Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ZoomMode Property

Gets or sets the zoom mode of the viewer.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoomMode As ZoomMode
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As ZoomMode

instance.ZoomMode = value

value = instance.ZoomMode
C#
public ZoomMode ZoomMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ZoomPercent Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomPercent Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : ZoomPercent Property

Gets or sets the percentage of zoom used for the report display.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoomPercent As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim value As Integer

instance.ZoomPercent = value

value = instance.ZoomPercent
C#
public int ZoomPercent {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ReportViewerBase Class Events

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerBase Class Events
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerBase Class

For a list of all members of this type, see ReportViewerBase members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | Export | Occurs when the report in the viewer control is exported.
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | Print | Occurs when the report in the viewer control is printed.
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RenderingBegin | Occurs when the report in the viewer control is rendered.
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | UpdateUI | Occurs when the UI of the report viewer control is updated.
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


Export Event

Telerik.ReportViewer.WinForms Send comments on this topic.
Export Event
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : Export Event

Occurs when the report in the viewer control is exported.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Event Export() As ExportEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim handler As ExportEventHandler

AddHandler instance.Export, handler
C#
public event ExportEventHandler Export()

Syntax

Visual Basic (Declaration)
Public Event Export() As ExportEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim handler As ExportEventHandler

AddHandler instance.Export, handler
C#
public event ExportEventHandler Export()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


Print Event

Telerik.ReportViewer.WinForms Send comments on this topic.
Print Event
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : Print Event

Occurs when the report in the viewer control is printed.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Event Print() As CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim handler As CancelEventHandler

AddHandler instance.Print, handler
C#
public event CancelEventHandler Print()

Syntax

Visual Basic (Declaration)
Public Event Print() As CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim handler As CancelEventHandler

AddHandler instance.Print, handler
C#
public event CancelEventHandler Print()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


RenderingBegin Event

Telerik.ReportViewer.WinForms Send comments on this topic.
RenderingBegin Event
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : RenderingBegin Event

Occurs when the report in the viewer control is rendered.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Event RenderingBegin() As CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim handler As CancelEventHandler

AddHandler instance.RenderingBegin, handler
C#
public event CancelEventHandler RenderingBegin()

Syntax

Visual Basic (Declaration)
Public Event RenderingBegin() As CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim handler As CancelEventHandler

AddHandler instance.RenderingBegin, handler
C#
public event CancelEventHandler RenderingBegin()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


UpdateUI Event

Telerik.ReportViewer.WinForms Send comments on this topic.
UpdateUI Event
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase Class : UpdateUI Event

Occurs when the UI of the report viewer control is updated.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Event UpdateUI() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim handler As EventHandler

AddHandler instance.UpdateUI, handler
C#
public event EventHandler UpdateUI()

Syntax

Visual Basic (Declaration)
Public Event UpdateUI() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase
Dim handler As EventHandler

AddHandler instance.UpdateUI, handler
C#
public event EventHandler UpdateUI()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase Class
ReportViewerBase Members


ReportViewerBase.UIState Class

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerBase.UIState Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerBase.UIState Class

Represents all the of for controling the UI of the ReportViewer: ReportToolbar and ReportViewerAreaBase

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Private NotInheritable Class ReportViewerBase.UIState
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase.UIState
C#
private sealed class ReportViewerBase.UIState

Inheritance Hierarchy

System.Object
Telerik.ReportViewer.WinForms.ReportViewerBase.UIState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase.UIState Members
Telerik.ReportViewer.WinForms Namespace


ReportViewerBase.UIState Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerBase.UIState Class Members
See Also Properties Methods
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerBase.UIState Class

The following tables list the members exposed by ReportViewerBase.UIState.

Public Properties

 | Name | Description
Public Property | CanPrintNow |
Public Property | ExportEnabled |
Public Property | PageNavigationEnabled |
Public Property | PageSetupEnabled |
Public Property | PrintEnabled |
Public Property | ProcessingState |
Public Property | RefreshEnabled |
Public Property | StopEnabled |
Public Property | ZoomEnabled |
Top

Public Methods

 | Name | Description
Public Method | IsSet |
Public Method | Set |
Top

See Also

Reference

ReportViewerBase.UIState Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerBase.UIState Class Methods

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerBase.UIState Class Methods
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerBase.UIState Class

For a list of all members of this type, see ReportViewerBase.UIState members.

Public Methods

 | Name | Description
Public Method | IsSet |
Public Method | Set |
Top

See Also

Reference

ReportViewerBase.UIState Class
Telerik.ReportViewer.WinForms Namespace


IsSet Method

Telerik.ReportViewer.WinForms Send comments on this topic.
IsSet Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase.UIState Class : IsSet Method

flags

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function IsSet( _
   ByVal flags As ToolBarFlags _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase.UIState
Dim flags As ToolBarFlags
Dim value As Boolean

value = instance.IsSet(flags)
C#
public bool IsSet(
   ToolBarFlags flags
)

Parameters

flags

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase.UIState Class
ReportViewerBase.UIState Members


Set Method

Telerik.ReportViewer.WinForms Send comments on this topic.
Set Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase.UIState Class : Set Method

flags
value

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Sub Set( _
   ByVal flags As ToolBarFlags, _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase.UIState
Dim flags As ToolBarFlags
Dim value As Boolean

instance.Set(flags, value)
C#
public void Set(
   ToolBarFlags flags,
   bool value
)

Parameters

flags
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase.UIState Class
ReportViewerBase.UIState Members


ReportViewerBase.UIState Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerBase.UIState Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerBase.UIState Class

For a list of all members of this type, see ReportViewerBase.UIState members.

Public Properties

 | Name | Description
Public Property | CanPrintNow |
Public Property | ExportEnabled |
Public Property | PageNavigationEnabled |
Public Property | PageSetupEnabled |
Public Property | PrintEnabled |
Public Property | ProcessingState |
Public Property | RefreshEnabled |
Public Property | StopEnabled |
Public Property | ZoomEnabled |
Top

See Also

Reference

ReportViewerBase.UIState Class
Telerik.ReportViewer.WinForms Namespace


CanPrintNow Property

Telerik.ReportViewer.WinForms Send comments on this topic.
CanPrintNow Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase.UIState Class : CanPrintNow Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanPrintNow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase.UIState
Dim value As Boolean

value = instance.CanPrintNow
C#
public bool CanPrintNow {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase.UIState Class
ReportViewerBase.UIState Members


ExportEnabled Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ExportEnabled Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase.UIState Class : ExportEnabled Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExportEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase.UIState
Dim value As Boolean

value = instance.ExportEnabled
C#
public bool ExportEnabled {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase.UIState Class
ReportViewerBase.UIState Members


PageNavigationEnabled Property

Telerik.ReportViewer.WinForms Send comments on this topic.
PageNavigationEnabled Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase.UIState Class : PageNavigationEnabled Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNavigationEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase.UIState
Dim value As Boolean

value = instance.PageNavigationEnabled
C#
public bool PageNavigationEnabled {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase.UIState Class
ReportViewerBase.UIState Members


PageSetupEnabled Property

Telerik.ReportViewer.WinForms Send comments on this topic.
PageSetupEnabled Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase.UIState Class : PageSetupEnabled Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageSetupEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase.UIState
Dim value As Boolean

value = instance.PageSetupEnabled
C#
public bool PageSetupEnabled {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase.UIState Class
ReportViewerBase.UIState Members


PrintEnabled Property

Telerik.ReportViewer.WinForms Send comments on this topic.
PrintEnabled Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase.UIState Class : PrintEnabled Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase.UIState
Dim value As Boolean

value = instance.PrintEnabled
C#
public bool PrintEnabled {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase.UIState Class
ReportViewerBase.UIState Members


ProcessingState Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ProcessingState Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase.UIState Class : ProcessingState Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ProcessingState As ProcessingState
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase.UIState
Dim value As ProcessingState

instance.ProcessingState = value

value = instance.ProcessingState
C#
public ProcessingState ProcessingState {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase.UIState Class
ReportViewerBase.UIState Members


RefreshEnabled Property

Telerik.ReportViewer.WinForms Send comments on this topic.
RefreshEnabled Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase.UIState Class : RefreshEnabled Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RefreshEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase.UIState
Dim value As Boolean

value = instance.RefreshEnabled
C#
public bool RefreshEnabled {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase.UIState Class
ReportViewerBase.UIState Members


StopEnabled Property

Telerik.ReportViewer.WinForms Send comments on this topic.
StopEnabled Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase.UIState Class : StopEnabled Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StopEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase.UIState
Dim value As Boolean

value = instance.StopEnabled
C#
public bool StopEnabled {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase.UIState Class
ReportViewerBase.UIState Members


ZoomEnabled Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomEnabled Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ReportViewerBase.UIState Class : ZoomEnabled Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ZoomEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerBase.UIState
Dim value As Boolean

value = instance.ZoomEnabled
C#
public bool ZoomEnabled {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerBase.UIState Class
ReportViewerBase.UIState Members


ReportViewerException Class

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerException Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerException Class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Class ReportViewerException
   Inherits Exception
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerException
C#
public class ReportViewerException : Exception

Inheritance Hierarchy

System.Object
System.Exception
Telerik.ReportViewer.WinForms.ReportViewerException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportViewerException Members
Telerik.ReportViewer.WinForms Namespace


ReportViewerException Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerException Class Members
See Also Properties Methods
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerException Class

The following tables list the members exposed by ReportViewerException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ReportViewerException Class
Telerik.ReportViewer.WinForms Namespace


Resources Class

Telerik.ReportViewer.WinForms Send comments on this topic.
Resources Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : Resources Class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Class Resources
Visual Basic (Usage) Copy Code
Dim instance As Resources
C#
public class Resources

Inheritance Hierarchy

System.Object
Telerik.ReportViewer.WinForms.Resources

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Members
Telerik.ReportViewer.WinForms Namespace


Resources Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
Resources Class Members
See Also Properties Methods
[image]
Telerik.ReportViewer.WinForms Namespace : Resources Class

The following tables list the members exposed by Resources.

Public Constructors

 | Name | Description
Public Constructor | Resources Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllFiles | Specifies the text for the AllFiles filter in the SaveFileDialog.
Public Property | CurrentPageToolTip | Specifies the tooltip for the CurrentPage label.
Public Property | ExportError | Specifies the error message on export.
Public Property | ExportToolTip | Specifies the tooltip for the Export button.
Public Property | FirstPageToolTip | Specifies the tooltip for the FirstPage button.
Public Property | GenericMessageBoxCaption | Specifies the caption of the message boxes shown by the viewer.
Public Property | LabelOf | Specifies the text for the 'of' conjuction label.
Public Property | LastPageToolTip | Specifies the tooltip for the LastPage button.
Public Property | MissingReportSource | Specifies the text for the error when the Report property is not set.
Public Property | NextPageToolTip | Specifies the tooltip for the NextPage button.
Public Property | NoPageToDisplay | Specifies the text which appears if there are no pages to display.
Public Property | PageSetupToolTip | Specifies the tooltip for the PageSetup button.
Public Property | ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
Public Property | PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
Public Property | PrintToolTip | Specifies the tooltip for the Print button.
Public Property | ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
Public Property | RefreshToolTip | Specifies the tooltip for the Refresh button.
Public Property | ReportParametersEmptyStringError | Specifies the error message when the parameter does not allow empty strings.
Public Property | ReportParametersFalseValueLabel | Specifies the text for the False value label in a boolean parameter editor.
Public Property | ReportParametersInputDataError | Specifies the message which appears when not all the parameters are set.
Public Property | ReportParametersInvalidValueText | Specifies the text for the InvalidValue error.
Public Property | ReportParametersNoValueText | Specifies the message when a value should be selected for a parameter.
Public Property | ReportParametersNullText | Specifies the text for the NULL checkbox.
Public Property | ReportParametersPreviewButtonText | Specifies the text for the Preview button.
Public Property | ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
Public Property | ReportParametersSelectAValueText | Specifies the <select a value> text for a dropdown parameter editor.
Public Property | ReportParametersTrueValueLabel | Specfies the text for the True value label in a boolean parameter editor.
Public Property | StopProcessing | Specifies the message when the report processing is canceled.
Public Property | StopToolTip | Specifies the tooltip for the Stop button.
Public Property | TotalPagesToolTip | Specifies the tooltip for the TotalPages button.
Public Property | ZoomPercentFormat | Specifies the format for the zoom percent numbers.
Public Property | ZoomToolTip | Specifies the tooltip for the Zoom select.
Public Property | ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
Public Property | ZoomToWholePage | Specifies the name for the WholePage zoom mode.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Resources Class
Telerik.ReportViewer.WinForms Namespace


Resources Constructor

Telerik.ReportViewer.WinForms Send comments on this topic.
Resources Constructor
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : Resources Constructor

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Resources()
C#
public Resources()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Resources()
C#
public Resources()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


Resources Class Methods

Telerik.ReportViewer.WinForms Send comments on this topic.
Resources Class Methods
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : Resources Class

For a list of all members of this type, see Resources members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Resources Class
Telerik.ReportViewer.WinForms Namespace


ToString Method

Telerik.ReportViewer.WinForms Send comments on this topic.
ToString Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ToString Method

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


Resources Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
Resources Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : Resources Class

For a list of all members of this type, see Resources members.

Public Properties

 | Name | Description
Public Property | AllFiles | Specifies the text for the AllFiles filter in the SaveFileDialog.
Public Property | CurrentPageToolTip | Specifies the tooltip for the CurrentPage label.
Public Property | ExportError | Specifies the error message on export.
Public Property | ExportToolTip | Specifies the tooltip for the Export button.
Public Property | FirstPageToolTip | Specifies the tooltip for the FirstPage button.
Public Property | GenericMessageBoxCaption | Specifies the caption of the message boxes shown by the viewer.
Public Property | LabelOf | Specifies the text for the 'of' conjuction label.
Public Property | LastPageToolTip | Specifies the tooltip for the LastPage button.
Public Property | MissingReportSource | Specifies the text for the error when the Report property is not set.
Public Property | NextPageToolTip | Specifies the tooltip for the NextPage button.
Public Property | NoPageToDisplay | Specifies the text which appears if there are no pages to display.
Public Property | PageSetupToolTip | Specifies the tooltip for the PageSetup button.
Public Property | ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
Public Property | PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
Public Property | PrintToolTip | Specifies the tooltip for the Print button.
Public Property | ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
Public Property | RefreshToolTip | Specifies the tooltip for the Refresh button.
Public Property | ReportParametersEmptyStringError | Specifies the error message when the parameter does not allow empty strings.
Public Property | ReportParametersFalseValueLabel | Specifies the text for the False value label in a boolean parameter editor.
Public Property | ReportParametersInputDataError | Specifies the message which appears when not all the parameters are set.
Public Property | ReportParametersInvalidValueText | Specifies the text for the InvalidValue error.
Public Property | ReportParametersNoValueText | Specifies the message when a value should be selected for a parameter.
Public Property | ReportParametersNullText | Specifies the text for the NULL checkbox.
Public Property | ReportParametersPreviewButtonText | Specifies the text for the Preview button.
Public Property | ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
Public Property | ReportParametersSelectAValueText | Specifies the <select a value> text for a dropdown parameter editor.
Public Property | ReportParametersTrueValueLabel | Specfies the text for the True value label in a boolean parameter editor.
Public Property | StopProcessing | Specifies the message when the report processing is canceled.
Public Property | StopToolTip | Specifies the tooltip for the Stop button.
Public Property | TotalPagesToolTip | Specifies the tooltip for the TotalPages button.
Public Property | ZoomPercentFormat | Specifies the format for the zoom percent numbers.
Public Property | ZoomToolTip | Specifies the tooltip for the Zoom select.
Public Property | ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
Public Property | ZoomToWholePage | Specifies the name for the WholePage zoom mode.
Top

See Also

Reference

Resources Class
Telerik.ReportViewer.WinForms Namespace


AllFiles Property

Telerik.ReportViewer.WinForms Send comments on this topic.
AllFiles Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : AllFiles Property

Specifies the text for the AllFiles filter in the SaveFileDialog.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property AllFiles As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.AllFiles = value

value = instance.AllFiles
C#
public string AllFiles {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


CurrentPageToolTip Property

Telerik.ReportViewer.WinForms Send comments on this topic.
CurrentPageToolTip Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : CurrentPageToolTip Property

Specifies the tooltip for the CurrentPage label.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property CurrentPageToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.CurrentPageToolTip = value

value = instance.CurrentPageToolTip
C#
public string CurrentPageToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ExportError Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ExportError Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ExportError Property

Specifies the error message on export.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ExportError As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ExportError = value

value = instance.ExportError
C#
public string ExportError {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ExportToolTip Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ExportToolTip Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ExportToolTip Property

Specifies the tooltip for the Export button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ExportToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ExportToolTip = value

value = instance.ExportToolTip
C#
public string ExportToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


FirstPageToolTip Property

Telerik.ReportViewer.WinForms Send comments on this topic.
FirstPageToolTip Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : FirstPageToolTip Property

Specifies the tooltip for the FirstPage button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property FirstPageToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.FirstPageToolTip = value

value = instance.FirstPageToolTip
C#
public string FirstPageToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


GenericMessageBoxCaption Property

Telerik.ReportViewer.WinForms Send comments on this topic.
GenericMessageBoxCaption Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : GenericMessageBoxCaption Property

Specifies the caption of the message boxes shown by the viewer.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property GenericMessageBoxCaption As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.GenericMessageBoxCaption = value

value = instance.GenericMessageBoxCaption
C#
public string GenericMessageBoxCaption {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


LabelOf Property

Telerik.ReportViewer.WinForms Send comments on this topic.
LabelOf Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : LabelOf Property

Specifies the text for the 'of' conjuction label.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelOf As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.LabelOf = value

value = instance.LabelOf
C#
public string LabelOf {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


LastPageToolTip Property

Telerik.ReportViewer.WinForms Send comments on this topic.
LastPageToolTip Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : LastPageToolTip Property

Specifies the tooltip for the LastPage button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property LastPageToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.LastPageToolTip = value

value = instance.LastPageToolTip
C#
public string LastPageToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


MissingReportSource Property

Telerik.ReportViewer.WinForms Send comments on this topic.
MissingReportSource Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : MissingReportSource Property

Specifies the text for the error when the Report property is not set.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property MissingReportSource As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.MissingReportSource = value

value = instance.MissingReportSource
C#
public string MissingReportSource {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


NextPageToolTip Property

Telerik.ReportViewer.WinForms Send comments on this topic.
NextPageToolTip Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : NextPageToolTip Property

Specifies the tooltip for the NextPage button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property NextPageToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.NextPageToolTip = value

value = instance.NextPageToolTip
C#
public string NextPageToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


NoPageToDisplay Property

Telerik.ReportViewer.WinForms Send comments on this topic.
NoPageToDisplay Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : NoPageToDisplay Property

Specifies the text which appears if there are no pages to display.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property NoPageToDisplay As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.NoPageToDisplay = value

value = instance.NoPageToDisplay
C#
public string NoPageToDisplay {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


PageSetupToolTip Property

Telerik.ReportViewer.WinForms Send comments on this topic.
PageSetupToolTip Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : PageSetupToolTip Property

Specifies the tooltip for the PageSetup button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property PageSetupToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.PageSetupToolTip = value

value = instance.PageSetupToolTip
C#
public string PageSetupToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ParametersToolTip Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ParametersToolTip Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ParametersToolTip Property

Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ParametersToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ParametersToolTip = value

value = instance.ParametersToolTip
C#
public string ParametersToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


PreviousPageToolTip Property

Telerik.ReportViewer.WinForms Send comments on this topic.
PreviousPageToolTip Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : PreviousPageToolTip Property

Specifies the tooltip for the PreviousPage button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property PreviousPageToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.PreviousPageToolTip = value

value = instance.PreviousPageToolTip
C#
public string PreviousPageToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


PrintToolTip Property

Telerik.ReportViewer.WinForms Send comments on this topic.
PrintToolTip Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : PrintToolTip Property

Specifies the tooltip for the Print button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property PrintToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.PrintToolTip = value

value = instance.PrintToolTip
C#
public string PrintToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ProcessingReportMessage Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ProcessingReportMessage Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ProcessingReportMessage Property

Specifies the text for the wait message shown while the report is being processed.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ProcessingReportMessage As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ProcessingReportMessage = value

value = instance.ProcessingReportMessage
C#
public string ProcessingReportMessage {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


RefreshToolTip Property

Telerik.ReportViewer.WinForms Send comments on this topic.
RefreshToolTip Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : RefreshToolTip Property

Specifies the tooltip for the Refresh button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property RefreshToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.RefreshToolTip = value

value = instance.RefreshToolTip
C#
public string RefreshToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersEmptyStringError Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersEmptyStringError Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ReportParametersEmptyStringError Property

Specifies the error message when the parameter does not allow empty strings.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersEmptyStringError As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersEmptyStringError = value

value = instance.ReportParametersEmptyStringError
C#
public string ReportParametersEmptyStringError {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersFalseValueLabel Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersFalseValueLabel Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ReportParametersFalseValueLabel Property

Specifies the text for the False value label in a boolean parameter editor.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersFalseValueLabel As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersFalseValueLabel = value

value = instance.ReportParametersFalseValueLabel
C#
public string ReportParametersFalseValueLabel {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersInputDataError Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersInputDataError Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ReportParametersInputDataError Property

Specifies the message which appears when not all the parameters are set.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersInputDataError As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersInputDataError = value

value = instance.ReportParametersInputDataError
C#
public string ReportParametersInputDataError {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersInvalidValueText Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersInvalidValueText Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ReportParametersInvalidValueText Property

Specifies the text for the InvalidValue error.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersInvalidValueText As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersInvalidValueText = value

value = instance.ReportParametersInvalidValueText
C#
public string ReportParametersInvalidValueText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersNoValueText Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersNoValueText Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ReportParametersNoValueText Property

Specifies the message when a value should be selected for a parameter.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersNoValueText As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersNoValueText = value

value = instance.ReportParametersNoValueText
C#
public string ReportParametersNoValueText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersNullText Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersNullText Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ReportParametersNullText Property

Specifies the text for the NULL checkbox.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersNullText As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersNullText = value

value = instance.ReportParametersNullText
C#
public string ReportParametersNullText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersPreviewButtonText Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersPreviewButtonText Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ReportParametersPreviewButtonText Property

Specifies the text for the Preview button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersPreviewButtonText As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersPreviewButtonText = value

value = instance.ReportParametersPreviewButtonText
C#
public string ReportParametersPreviewButtonText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersSelectAllText Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersSelectAllText Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ReportParametersSelectAllText Property

Specifies the <select all> text for a multivalue parameter editor.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersSelectAllText As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersSelectAllText = value

value = instance.ReportParametersSelectAllText
C#
public string ReportParametersSelectAllText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersSelectAValueText Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersSelectAValueText Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ReportParametersSelectAValueText Property

Specifies the <select a value> text for a dropdown parameter editor.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersSelectAValueText As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersSelectAValueText = value

value = instance.ReportParametersSelectAValueText
C#
public string ReportParametersSelectAValueText {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ReportParametersTrueValueLabel Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersTrueValueLabel Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ReportParametersTrueValueLabel Property

Specfies the text for the True value label in a boolean parameter editor.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportParametersTrueValueLabel As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ReportParametersTrueValueLabel = value

value = instance.ReportParametersTrueValueLabel
C#
public string ReportParametersTrueValueLabel {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


StopProcessing Property

Telerik.ReportViewer.WinForms Send comments on this topic.
StopProcessing Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : StopProcessing Property

Specifies the message when the report processing is canceled.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property StopProcessing As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.StopProcessing = value

value = instance.StopProcessing
C#
public string StopProcessing {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


StopToolTip Property

Telerik.ReportViewer.WinForms Send comments on this topic.
StopToolTip Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : StopToolTip Property

Specifies the tooltip for the Stop button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property StopToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.StopToolTip = value

value = instance.StopToolTip
C#
public string StopToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


TotalPagesToolTip Property

Telerik.ReportViewer.WinForms Send comments on this topic.
TotalPagesToolTip Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : TotalPagesToolTip Property

Specifies the tooltip for the TotalPages button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalPagesToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.TotalPagesToolTip = value

value = instance.TotalPagesToolTip
C#
public string TotalPagesToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ZoomPercentFormat Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomPercentFormat Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ZoomPercentFormat Property

Specifies the format for the zoom percent numbers.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoomPercentFormat As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ZoomPercentFormat = value

value = instance.ZoomPercentFormat
C#
public string ZoomPercentFormat {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ZoomToolTip Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomToolTip Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ZoomToolTip Property

Specifies the tooltip for the Zoom select.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoomToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ZoomToolTip = value

value = instance.ZoomToolTip
C#
public string ZoomToolTip {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ZoomToPageWidth Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomToPageWidth Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ZoomToPageWidth Property

Specifies the name for the PageWidth zoom mode.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoomToPageWidth As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ZoomToPageWidth = value

value = instance.ZoomToPageWidth
C#
public string ZoomToPageWidth {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


ZoomToWholePage Property

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomToWholePage Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources Class : ZoomToWholePage Property

Specifies the name for the WholePage zoom mode.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoomToWholePage As String
Visual Basic (Usage) Copy Code
Dim instance As Resources
Dim value As String

instance.ZoomToWholePage = value

value = instance.ZoomToWholePage
C#
public string ZoomToWholePage {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources Class
Resources Members


Resources.Keys Class

Telerik.ReportViewer.WinForms Send comments on this topic.
Resources.Keys Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : Resources.Keys Class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class Resources.Keys
Visual Basic (Usage) Copy Code
Dim instance As Resources.Keys
C#
public static class Resources.Keys

Inheritance Hierarchy

System.Object
Telerik.ReportViewer.WinForms.Resources.Keys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Members
Telerik.ReportViewer.WinForms Namespace


Resources.Keys Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
Resources.Keys Class Members
See Also Fields
[image]
Telerik.ReportViewer.WinForms Namespace : Resources.Keys Class

The following tables list the members exposed by Resources.Keys.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AllFiles |
static (Shared in Visual Basic) | CurrentPageToolTip |
static (Shared in Visual Basic) | ExportError |
static (Shared in Visual Basic) | ExportToolTip |
static (Shared in Visual Basic) | FirstPageToolTip |
static (Shared in Visual Basic) | GenericMessageBoxCaption |
static (Shared in Visual Basic) | LabelOf |
static (Shared in Visual Basic) | LastPageToolTip |
static (Shared in Visual Basic) | MissingReportSource |
static (Shared in Visual Basic) | NextPageToolTip |
static (Shared in Visual Basic) | NoPageToDisplay |
static (Shared in Visual Basic) | PageSetupToolTip |
static (Shared in Visual Basic) | ParametersToolTip |
static (Shared in Visual Basic) | PreviousPageToolTip |
static (Shared in Visual Basic) | PrintToolTip |
static (Shared in Visual Basic) | ProcessingReportMessage |
static (Shared in Visual Basic) | RefreshToolTip |
static (Shared in Visual Basic) | ReportParametersEmptyStringError |
static (Shared in Visual Basic) | ReportParametersFalseValueLabel |
static (Shared in Visual Basic) | ReportParametersInputDataError |
static (Shared in Visual Basic) | ReportParametersInvalidValueText |
static (Shared in Visual Basic) | ReportParametersNoValueText |
static (Shared in Visual Basic) | ReportParametersNullText |
static (Shared in Visual Basic) | ReportParametersPreviewButtonText |
static (Shared in Visual Basic) | ReportParametersSelectAllText |
static (Shared in Visual Basic) | ReportParametersSelectAValueText |
static (Shared in Visual Basic) | ReportParametersTrueValueLabel |
static (Shared in Visual Basic) | StopProcessing |
static (Shared in Visual Basic) | StopToolTip |
static (Shared in Visual Basic) | TotalPagesToolTip |
static (Shared in Visual Basic) | ZoomPercentFormat |
static (Shared in Visual Basic) | ZoomToolTip |
static (Shared in Visual Basic) | ZoomToPageWidth |
static (Shared in Visual Basic) | ZoomToWholePage |
Top

See Also

Reference

Resources.Keys Class
Telerik.ReportViewer.WinForms Namespace


Resources.Keys Class Fields

Telerik.ReportViewer.WinForms Send comments on this topic.
Resources.Keys Class Fields
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : Resources.Keys Class

For a list of all members of this type, see Resources.Keys members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AllFiles |
static (Shared in Visual Basic) | CurrentPageToolTip |
static (Shared in Visual Basic) | ExportError |
static (Shared in Visual Basic) | ExportToolTip |
static (Shared in Visual Basic) | FirstPageToolTip |
static (Shared in Visual Basic) | GenericMessageBoxCaption |
static (Shared in Visual Basic) | LabelOf |
static (Shared in Visual Basic) | LastPageToolTip |
static (Shared in Visual Basic) | MissingReportSource |
static (Shared in Visual Basic) | NextPageToolTip |
static (Shared in Visual Basic) | NoPageToDisplay |
static (Shared in Visual Basic) | PageSetupToolTip |
static (Shared in Visual Basic) | ParametersToolTip |
static (Shared in Visual Basic) | PreviousPageToolTip |
static (Shared in Visual Basic) | PrintToolTip |
static (Shared in Visual Basic) | ProcessingReportMessage |
static (Shared in Visual Basic) | RefreshToolTip |
static (Shared in Visual Basic) | ReportParametersEmptyStringError |
static (Shared in Visual Basic) | ReportParametersFalseValueLabel |
static (Shared in Visual Basic) | ReportParametersInputDataError |
static (Shared in Visual Basic) | ReportParametersInvalidValueText |
static (Shared in Visual Basic) | ReportParametersNoValueText |
static (Shared in Visual Basic) | ReportParametersNullText |
static (Shared in Visual Basic) | ReportParametersPreviewButtonText |
static (Shared in Visual Basic) | ReportParametersSelectAllText |
static (Shared in Visual Basic) | ReportParametersSelectAValueText |
static (Shared in Visual Basic) | ReportParametersTrueValueLabel |
static (Shared in Visual Basic) | StopProcessing |
static (Shared in Visual Basic) | StopToolTip |
static (Shared in Visual Basic) | TotalPagesToolTip |
static (Shared in Visual Basic) | ZoomPercentFormat |
static (Shared in Visual Basic) | ZoomToolTip |
static (Shared in Visual Basic) | ZoomToPageWidth |
static (Shared in Visual Basic) | ZoomToWholePage |
Top

See Also

Reference

Resources.Keys Class
Telerik.ReportViewer.WinForms Namespace


AllFiles Field

Telerik.ReportViewer.WinForms Send comments on this topic.
AllFiles Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : AllFiles Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared AllFiles As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.AllFiles

Resources.Keys.AllFiles = value
C#
public static string AllFiles

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


CurrentPageToolTip Field

Telerik.ReportViewer.WinForms Send comments on this topic.
CurrentPageToolTip Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : CurrentPageToolTip Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared CurrentPageToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.CurrentPageToolTip

Resources.Keys.CurrentPageToolTip = value
C#
public static string CurrentPageToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ExportError Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ExportError Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ExportError Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ExportError As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ExportError

Resources.Keys.ExportError = value
C#
public static string ExportError

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ExportToolTip Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ExportToolTip Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ExportToolTip Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ExportToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ExportToolTip

Resources.Keys.ExportToolTip = value
C#
public static string ExportToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


FirstPageToolTip Field

Telerik.ReportViewer.WinForms Send comments on this topic.
FirstPageToolTip Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : FirstPageToolTip Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared FirstPageToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.FirstPageToolTip

Resources.Keys.FirstPageToolTip = value
C#
public static string FirstPageToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


GenericMessageBoxCaption Field

Telerik.ReportViewer.WinForms Send comments on this topic.
GenericMessageBoxCaption Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : GenericMessageBoxCaption Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared GenericMessageBoxCaption As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.GenericMessageBoxCaption

Resources.Keys.GenericMessageBoxCaption = value
C#
public static string GenericMessageBoxCaption

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


LabelOf Field

Telerik.ReportViewer.WinForms Send comments on this topic.
LabelOf Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : LabelOf Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared LabelOf As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.LabelOf

Resources.Keys.LabelOf = value
C#
public static string LabelOf

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


LastPageToolTip Field

Telerik.ReportViewer.WinForms Send comments on this topic.
LastPageToolTip Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : LastPageToolTip Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared LastPageToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.LastPageToolTip

Resources.Keys.LastPageToolTip = value
C#
public static string LastPageToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


MissingReportSource Field

Telerik.ReportViewer.WinForms Send comments on this topic.
MissingReportSource Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : MissingReportSource Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared MissingReportSource As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.MissingReportSource

Resources.Keys.MissingReportSource = value
C#
public static string MissingReportSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


NextPageToolTip Field

Telerik.ReportViewer.WinForms Send comments on this topic.
NextPageToolTip Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : NextPageToolTip Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared NextPageToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.NextPageToolTip

Resources.Keys.NextPageToolTip = value
C#
public static string NextPageToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


NoPageToDisplay Field

Telerik.ReportViewer.WinForms Send comments on this topic.
NoPageToDisplay Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : NoPageToDisplay Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared NoPageToDisplay As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.NoPageToDisplay

Resources.Keys.NoPageToDisplay = value
C#
public static string NoPageToDisplay

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


PageSetupToolTip Field

Telerik.ReportViewer.WinForms Send comments on this topic.
PageSetupToolTip Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : PageSetupToolTip Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared PageSetupToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.PageSetupToolTip

Resources.Keys.PageSetupToolTip = value
C#
public static string PageSetupToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ParametersToolTip Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ParametersToolTip Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ParametersToolTip Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ParametersToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ParametersToolTip

Resources.Keys.ParametersToolTip = value
C#
public static string ParametersToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


PreviousPageToolTip Field

Telerik.ReportViewer.WinForms Send comments on this topic.
PreviousPageToolTip Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : PreviousPageToolTip Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared PreviousPageToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.PreviousPageToolTip

Resources.Keys.PreviousPageToolTip = value
C#
public static string PreviousPageToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


PrintToolTip Field

Telerik.ReportViewer.WinForms Send comments on this topic.
PrintToolTip Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : PrintToolTip Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared PrintToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.PrintToolTip

Resources.Keys.PrintToolTip = value
C#
public static string PrintToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ProcessingReportMessage Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ProcessingReportMessage Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ProcessingReportMessage Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ProcessingReportMessage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ProcessingReportMessage

Resources.Keys.ProcessingReportMessage = value
C#
public static string ProcessingReportMessage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


RefreshToolTip Field

Telerik.ReportViewer.WinForms Send comments on this topic.
RefreshToolTip Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : RefreshToolTip Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared RefreshToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.RefreshToolTip

Resources.Keys.RefreshToolTip = value
C#
public static string RefreshToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersEmptyStringError Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersEmptyStringError Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ReportParametersEmptyStringError Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersEmptyStringError As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersEmptyStringError

Resources.Keys.ReportParametersEmptyStringError = value
C#
public static string ReportParametersEmptyStringError

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersFalseValueLabel Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersFalseValueLabel Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ReportParametersFalseValueLabel Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersFalseValueLabel As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersFalseValueLabel

Resources.Keys.ReportParametersFalseValueLabel = value
C#
public static string ReportParametersFalseValueLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersInputDataError Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersInputDataError Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ReportParametersInputDataError Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersInputDataError As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersInputDataError

Resources.Keys.ReportParametersInputDataError = value
C#
public static string ReportParametersInputDataError

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersInvalidValueText Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersInvalidValueText Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ReportParametersInvalidValueText Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersInvalidValueText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersInvalidValueText

Resources.Keys.ReportParametersInvalidValueText = value
C#
public static string ReportParametersInvalidValueText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersNoValueText Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersNoValueText Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ReportParametersNoValueText Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersNoValueText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersNoValueText

Resources.Keys.ReportParametersNoValueText = value
C#
public static string ReportParametersNoValueText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersNullText Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersNullText Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ReportParametersNullText Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersNullText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersNullText

Resources.Keys.ReportParametersNullText = value
C#
public static string ReportParametersNullText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersPreviewButtonText Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersPreviewButtonText Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ReportParametersPreviewButtonText Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersPreviewButtonText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersPreviewButtonText

Resources.Keys.ReportParametersPreviewButtonText = value
C#
public static string ReportParametersPreviewButtonText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersSelectAllText Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersSelectAllText Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ReportParametersSelectAllText Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersSelectAllText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersSelectAllText

Resources.Keys.ReportParametersSelectAllText = value
C#
public static string ReportParametersSelectAllText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersSelectAValueText Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersSelectAValueText Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ReportParametersSelectAValueText Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersSelectAValueText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersSelectAValueText

Resources.Keys.ReportParametersSelectAValueText = value
C#
public static string ReportParametersSelectAValueText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ReportParametersTrueValueLabel Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportParametersTrueValueLabel Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ReportParametersTrueValueLabel Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReportParametersTrueValueLabel As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ReportParametersTrueValueLabel

Resources.Keys.ReportParametersTrueValueLabel = value
C#
public static string ReportParametersTrueValueLabel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


StopProcessing Field

Telerik.ReportViewer.WinForms Send comments on this topic.
StopProcessing Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : StopProcessing Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared StopProcessing As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.StopProcessing

Resources.Keys.StopProcessing = value
C#
public static string StopProcessing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


StopToolTip Field

Telerik.ReportViewer.WinForms Send comments on this topic.
StopToolTip Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : StopToolTip Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared StopToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.StopToolTip

Resources.Keys.StopToolTip = value
C#
public static string StopToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


TotalPagesToolTip Field

Telerik.ReportViewer.WinForms Send comments on this topic.
TotalPagesToolTip Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : TotalPagesToolTip Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared TotalPagesToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.TotalPagesToolTip

Resources.Keys.TotalPagesToolTip = value
C#
public static string TotalPagesToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ZoomPercentFormat Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomPercentFormat Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ZoomPercentFormat Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ZoomPercentFormat As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ZoomPercentFormat

Resources.Keys.ZoomPercentFormat = value
C#
public static string ZoomPercentFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ZoomToolTip Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomToolTip Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ZoomToolTip Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ZoomToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ZoomToolTip

Resources.Keys.ZoomToolTip = value
C#
public static string ZoomToolTip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ZoomToPageWidth Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomToPageWidth Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ZoomToPageWidth Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ZoomToPageWidth As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ZoomToPageWidth

Resources.Keys.ZoomToPageWidth = value
C#
public static string ZoomToPageWidth

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


ZoomToWholePage Field

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomToWholePage Field
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > Resources.Keys Class : ZoomToWholePage Field

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Shared ZoomToWholePage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Resources.Keys.ZoomToWholePage

Resources.Keys.ZoomToWholePage = value
C#
public static string ZoomToWholePage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Resources.Keys Class
Resources.Keys Members


SRDefaultValueAttribute Class

Telerik.ReportViewer.WinForms Send comments on this topic.
SRDefaultValueAttribute Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : SRDefaultValueAttribute Class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Private Class SRDefaultValueAttribute
   Inherits DefaultValueAttribute
Visual Basic (Usage) Copy Code
Dim instance As SRDefaultValueAttribute
C#
private class SRDefaultValueAttribute : DefaultValueAttribute

Inheritance Hierarchy

System.Object
System.Attribute
System.ComponentModel.DefaultValueAttribute
Telerik.ReportViewer.WinForms.SRDefaultValueAttribute

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SRDefaultValueAttribute Members
Telerik.ReportViewer.WinForms Namespace


SRDefaultValueAttribute Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
SRDefaultValueAttribute Class Members
See Also Properties Methods
[image]
Telerik.ReportViewer.WinForms Namespace : SRDefaultValueAttribute Class

The following tables list the members exposed by SRDefaultValueAttribute.

Public Constructors

 | Name | Description
Public Constructor | SRDefaultValueAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Public Property | Value | (Inherited from System.ComponentModel.DefaultValueAttribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.ComponentModel.DefaultValueAttribute)
Public Method | GetHashCode | (Inherited from System.ComponentModel.DefaultValueAttribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

Protected Methods

 | Name | Description
Protected Method | SetValue | (Inherited from System.ComponentModel.DefaultValueAttribute)
Top

See Also

Reference

SRDefaultValueAttribute Class
Telerik.ReportViewer.WinForms Namespace


SRDefaultValueAttribute Constructor

Telerik.ReportViewer.WinForms Send comments on this topic.
SRDefaultValueAttribute Constructor
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > SRDefaultValueAttribute Class : SRDefaultValueAttribute Constructor

value

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As SRDefaultValueAttribute(value)
C#
public SRDefaultValueAttribute(
   string value
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As SRDefaultValueAttribute(value)
C#
public SRDefaultValueAttribute(
   string value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SRDefaultValueAttribute Class
SRDefaultValueAttribute Members


WinViewer Class

Telerik.ReportViewer.WinForms Send comments on this topic.
WinViewer Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : WinViewer Class

Object Model

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Class WinViewer
   Inherits ReportViewerAreaBase
Visual Basic (Usage) Copy Code
Dim instance As WinViewer
C#
public class WinViewer : ReportViewerAreaBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Telerik.ReportViewer.WinForms.ReportViewerAreaBase
Telerik.ReportViewer.WinForms.WinViewer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Members
Telerik.ReportViewer.WinForms Namespace


WinViewer Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
WinViewer Class Members
See Also Fields Properties Methods Events
[image]
Telerik.ReportViewer.WinForms Namespace : WinViewer Class

The following tables list the members exposed by WinViewer.

Public Constructors

 | Name | Description
Public Constructor | WinViewer Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | inLongRunningAction | (Inherited from ReportViewerAreaBase)
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Viewer | (Inherited from ReportViewerAreaBase)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetNewPage | Overridden.
Public Method | SetZoom | Overridden.
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | ShowMessage | Overloaded. (Inherited from ReportViewerAreaBase)
Public Method | ShowWaitMessage | (Inherited from ReportViewerAreaBase)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ChangeView | Overridden.
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | Overridden.
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | Overridden.
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | Overridden.
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | Overridden.
Protected Method | OnMouseUp | Overridden.
Protected Method | OnMouseWheel | Overridden.
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPageNavigation | (Inherited from ReportViewerAreaBase)
Protected Method | OnPaint | Overridden.
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnScroll | Overridden.
Protected Method | OnSizeChanged | Overridden.
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateUIState | Overridden.
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


WinViewer Constructor

Telerik.ReportViewer.WinForms Send comments on this topic.
WinViewer Constructor
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : WinViewer Constructor

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WinViewer()
C#
public WinViewer()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WinViewer()
C#
public WinViewer()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


WinViewer Class Methods

Telerik.ReportViewer.WinForms Send comments on this topic.
WinViewer Class Methods
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : WinViewer Class

For a list of all members of this type, see WinViewer members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetNewPage | Overridden.
Public Method | SetZoom | Overridden.
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | ShowMessage | Overloaded. (Inherited from ReportViewerAreaBase)
Public Method | ShowWaitMessage | (Inherited from ReportViewerAreaBase)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ChangeView | Overridden.
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | Overridden.
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | Overridden.
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | Overridden.
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | Overridden.
Protected Method | OnMouseUp | Overridden.
Protected Method | OnMouseWheel | Overridden.
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPageNavigation | (Inherited from ReportViewerAreaBase)
Protected Method | OnPaint | Overridden.
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.UserControl)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnScroll | Overridden.
Protected Method | OnSizeChanged | Overridden.
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateUIState | Overridden.
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


ChangeView Method

Telerik.ReportViewer.WinForms Send comments on this topic.
ChangeView Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : ChangeView Method

viewType

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub ChangeView( _
   ByVal viewType As ReportViewerAreaBase.ViewType _
)
Visual Basic (Usage) Copy Code
Dim instance As WinViewer
Dim viewType As ReportViewerAreaBase.ViewType

instance.ChangeView(viewType)
C#
protected override void ChangeView(
   ReportViewerAreaBase.ViewType viewType
)

Parameters

viewType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


IsInputKey Method

Telerik.ReportViewer.WinForms Send comments on this topic.
IsInputKey Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : IsInputKey Method

keyData

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Function IsInputKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WinViewer
Dim keyData As Keys
Dim value As Boolean

value = instance.IsInputKey(keyData)
C#
protected override bool IsInputKey(
   Keys keyData
)

Parameters

keyData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


OnKeyDown Method

Telerik.ReportViewer.WinForms Send comments on this topic.
OnKeyDown Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : OnKeyDown Method

e

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WinViewer
Dim e As KeyEventArgs

instance.OnKeyDown(e)
C#
protected override void OnKeyDown(
   KeyEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


OnMouseDown Method

Telerik.ReportViewer.WinForms Send comments on this topic.
OnMouseDown Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : OnMouseDown Method

e

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnMouseDown( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WinViewer
Dim e As MouseEventArgs

instance.OnMouseDown(e)
C#
protected override void OnMouseDown(
   MouseEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


OnMouseMove Method

Telerik.ReportViewer.WinForms Send comments on this topic.
OnMouseMove Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : OnMouseMove Method

e

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnMouseMove( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WinViewer
Dim e As MouseEventArgs

instance.OnMouseMove(e)
C#
protected override void OnMouseMove(
   MouseEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


OnMouseUp Method

Telerik.ReportViewer.WinForms Send comments on this topic.
OnMouseUp Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : OnMouseUp Method

e

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnMouseUp( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WinViewer
Dim e As MouseEventArgs

instance.OnMouseUp(e)
C#
protected override void OnMouseUp(
   MouseEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


OnMouseWheel Method

Telerik.ReportViewer.WinForms Send comments on this topic.
OnMouseWheel Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : OnMouseWheel Method

e

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnMouseWheel( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WinViewer
Dim e As MouseEventArgs

instance.OnMouseWheel(e)
C#
protected override void OnMouseWheel(
   MouseEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


OnPaint Method

Telerik.ReportViewer.WinForms Send comments on this topic.
OnPaint Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : OnPaint Method

e

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnPaint( _
   ByVal e As PaintEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WinViewer
Dim e As PaintEventArgs

instance.OnPaint(e)
C#
protected override void OnPaint(
   PaintEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


OnScroll Method

Telerik.ReportViewer.WinForms Send comments on this topic.
OnScroll Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : OnScroll Method

se

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnScroll( _
   ByVal se As ScrollEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WinViewer
Dim se As ScrollEventArgs

instance.OnScroll(se)
C#
protected override void OnScroll(
   ScrollEventArgs se
)

Parameters

se

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


OnSizeChanged Method

Telerik.ReportViewer.WinForms Send comments on this topic.
OnSizeChanged Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : OnSizeChanged Method

e

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnSizeChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WinViewer
Dim e As EventArgs

instance.OnSizeChanged(e)
C#
protected override void OnSizeChanged(
   EventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


SetNewPage Method

Telerik.ReportViewer.WinForms Send comments on this topic.
SetNewPage Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : SetNewPage Method

data

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub SetNewPage( _
   ByVal data As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WinViewer
Dim data As Stream

instance.SetNewPage(data)
C#
public override void SetNewPage(
   Stream data
)

Parameters

data

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


SetZoom Method

Telerik.ReportViewer.WinForms Send comments on this topic.
SetZoom Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : SetZoom Method

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub SetZoom()
Visual Basic (Usage) Copy Code
Dim instance As WinViewer

instance.SetZoom()
C#
public override void SetZoom()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


UpdateUIState Method

Telerik.ReportViewer.WinForms Send comments on this topic.
UpdateUIState Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > WinViewer Class : UpdateUIState Method

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub UpdateUIState()
Visual Basic (Usage) Copy Code
Dim instance As WinViewer

instance.UpdateUIState()
C#
protected override void UpdateUIState()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WinViewer Class
WinViewer Members


ZoomItem Class

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomItem Class
See Also Members
[image]
Telerik.ReportViewer.WinForms Namespace : ZoomItem Class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Private NotInheritable Class ZoomItem
Visual Basic (Usage) Copy Code
Dim instance As ZoomItem
C#
private sealed class ZoomItem

Inheritance Hierarchy

System.Object
Telerik.ReportViewer.WinForms.ZoomItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ZoomItem Members
Telerik.ReportViewer.WinForms Namespace


ZoomItem Class Members

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomItem Class Members
See Also Properties Methods
[image]
Telerik.ReportViewer.WinForms Namespace : ZoomItem Class

The following tables list the members exposed by ZoomItem.

Public Constructors

 | Name | Description
Public Constructor | ZoomItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | Mode |
Public Property | Percent |
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

ZoomItem Class
Telerik.ReportViewer.WinForms Namespace


ZoomItem Constructor

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomItem Constructor
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ZoomItem Class : ZoomItem Constructor

mode
percent
displayText

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mode As ZoomMode, _
   ByVal percent As Integer, _
   ByVal displayText As String _
)
Visual Basic (Usage) Copy Code
Dim mode As ZoomMode
Dim percent As Integer
Dim displayText As String

Dim instance As ZoomItem(mode, percent, displayText)
C#
public ZoomItem(
   ZoomMode mode,
   int percent,
   string displayText
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mode As ZoomMode, _
   ByVal percent As Integer, _
   ByVal displayText As String _
)
Visual Basic (Usage) Copy Code
Dim mode As ZoomMode
Dim percent As Integer
Dim displayText As String

Dim instance As ZoomItem(mode, percent, displayText)
C#
public ZoomItem(
   ZoomMode mode,
   int percent,
   string displayText
)

Parameters

mode
percent
displayText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ZoomItem Class
ZoomItem Members


ZoomItem Class Methods

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomItem Class Methods
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ZoomItem Class

For a list of all members of this type, see ZoomItem members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

ZoomItem Class
Telerik.ReportViewer.WinForms Namespace


ToString Method

Telerik.ReportViewer.WinForms Send comments on this topic.
ToString Method
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ZoomItem Class : ToString Method

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ZoomItem
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ZoomItem Class
ZoomItem Members


ZoomItem Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomItem Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ZoomItem Class

For a list of all members of this type, see ZoomItem members.

Public Properties

 | Name | Description
Public Property | Mode |
Public Property | Percent |
Top

See Also

Reference

ZoomItem Class
Telerik.ReportViewer.WinForms Namespace


Mode Property

Telerik.ReportViewer.WinForms Send comments on this topic.
Mode Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ZoomItem Class : Mode Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Mode As ZoomMode
Visual Basic (Usage) Copy Code
Dim instance As ZoomItem
Dim value As ZoomMode

value = instance.Mode
C#
public ZoomMode Mode {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ZoomItem Class
ZoomItem Members


Percent Property

Telerik.ReportViewer.WinForms Send comments on this topic.
Percent Property
See Also
[image]
Telerik.ReportViewer.WinForms Namespace > ZoomItem Class : Percent Property

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Percent As Integer
Visual Basic (Usage) Copy Code
Dim instance As ZoomItem
Dim value As Integer

value = instance.Percent
C#
public int Percent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ZoomItem Class
ZoomItem Members


Support

Telerik Reporting Q3 2008 Send comments on this topic.
Support
For More Help > Support

Glossary Item Box

You can contact Telerik support with a technical question using your Client.NET account: http://www.telerik.com/Default.aspx?PageId=2069.

You can also send us comments on any topic in this help file by clicking the Send Comments link displayed at the top right of the page:

Alternatively, you can send an e-mail to documentation@Telerik.com with feedback or inquiries concerning our manuals.


Knowledge Base

Telerik Reporting Q3 2008 Send comments on this topic.
Knowledge Base
For More Help > Knowledge Base

Glossary Item Box

The Telerik Knowledge Base, http://www.telerik.com/KB/, lets you browse and search articles for a solution to your problem.


Forums

Telerik Reporting Q3 2008 Send comments on this topic.
Forums
For More Help > Forums

Glossary Item Box

The Telerik Product Forums, http://www.telerik.com/Forums/, provide a place where you can communicate and consult with other people who use Telerik products.


System Requirements

Telerik Reporting Q3 2008 Send comments on this topic.
System Requirements
Licensing and Distribution > Installation > System Requirements

Glossary Item Box

The Telerik Reporting package shares the installation requirements of Visual Studio 2005. Briefly, this means that your computer should have:

  • A 1 gigahertz Pentium processor
  • At least 256 megabytes of RAM
  • A 1024 x 768 16-bit display
  • A Microsoft mouse or compatible pointing device

The Telerik Reporting product requires 190 megabytes of hard drive space for a full installation. Additional space may be required to install Microsoft SQL Server Express edition.


Installing on Your Computer

Telerik Reporting Q3 2008 Send comments on this topic.
Installing on Your Computer
Licensing and Distribution > Installation > Installing on Your Computer

Glossary Item Box

Before installing Telerik Reporting, you should install Microsoft SQL Server Express Edition. Telerik Reporting uses SQL Server Express to hold important samples when you install the package.

Installing SQL Server Express

  1. Download Microsoft SQL Server Express Edition from http://msdn.microsoft.com/vstudio/express/sql/download/.
  2. Run the SQLEXPR32.EXE file that you downloaded.
  3. Accept the licensing agreement and click Next to install the SQL Server prerequisites.
  4. When the prerequisites are installed, click Next to proceed to the configuration check.

  5. The configuration check reports success for all actions. If any failures are reported, correct the problems before proceeding. Click Next.
  6. Enter your name and company name, and then click Next.
  7. Choose to install the Database Services to your local hard drive. You may also wish to install the Client Components so that you can easily interact with databases. Click Next.
  8. Select Windows Authentication Mode, and then click Next.
  9. Click Next, and then Install.
  10. Click Next, and then Finish when the installation is done.

Installing Telerik Reporting

  1. Run the Telerik Reporting Setup launcher application.

  2. At the Welcome screen, click Next.

  3. Read the license agreement, select I accept the terms in the license agreement, and then click Next.

  4. Select an installation folder, and then click Next.

  5. Choose whether you would like a complete or a custom installation, and then click Next.

  6. If you choose a custom installation, you can decide whether to install components individually and you can customize the location for each component.

  7. Click Install to install the program.

  8. Click Finish when the installation is done.


Redistributing

Telerik Reporting Q3 2008 Send comments on this topic.
Redistributing
Licensing and Distribution > Redistributing

Glossary Item Box

Your purchase of Telerik Reporting includes a run time royalty-free license to redistribute the reports in your own solutions. You can freely use and redistribute any reports that you build in your own solutions, and your end users are not required to purchase their own licenses for the reports. Some potential uses of the reports require further discussion with our sales team.

Examples of Permitted Uses

  • Applications for internal company use.
  • Commercial applications deployed for end users by Telerik customers.
  • Shrink-wrapped software in which the Telerik reports are integrated.

Examples of Uses that Require Discussion

  • Products that expose the design-time functionality of the Telerik reports.
  • Products that do not add significant functionality to the Telerik reports.
  • Open source products.

For further details, please refer to the license agreement, or send e-mail to sales@Telerik.com to discuss your planned use of the controls.


Licensing

Telerik Reporting Q3 2008 Send comments on this topic.
Licensing
Licensing and Distribution > Licensing

Glossary Item Box

Telerik End-User License Agreement

By downloading, installing or otherwise using the product identified above and/or its related materials, you agree to be bound by the terms and conditions of this License Agreement. You must check the box "I have read and agree to the License Agreement" in order to be permitted to use the product.

IMPORTANT - READ CAREFULLY: This license agreement ("LICENSE") is a legal agreement between you (either an individual or a single entity, also referred to as "LICENSEE", "YOU") and Telerik Corp., ("TELERIK"), for the software containing this LICENSE which may also include the software’s source code written in a high-level computer language, associated media, printed materials, and "online" or electronic documentation (collectively referred to as "SOFTWARE").

Any earlier license we may have granted to you for the use of earlier versions of the SOFTWARE is replaced by this LICENSE.

SOFTWARE PRODUCT LICENSE

The SOFTWARE is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties and contains confidential information and trade secrets. TELERIK retains all rights not expressly granted to you in this LICENSE.

I. GRANT OF LICENSE

TELERIK hereby grants to you, and you accept, a non-exclusive, non-transferable license to install, copy, use and modify the SOFTWARE only as authorized below. You are granted: (1) a trial license pursuant to Section 1 below; and (2) either a Developer License pursuant to Section 2 or a Developer License with Subscription and Priority Support pursuant to Section 3. Which developer license applies (i.e., Developer License or Developer License with Subscription and Priority Support) is determined at the time of the license purchase.

This license grants you no rights to the "2007 Microsoft Office System User Interface". For an appropriate license, please, contact Microsoft directly.

1. TRIAL LICENSE

You are granted a license for evaluation purposes only. You are authorized to install, copy, and use the SOFTWARE for the sole purpose of testing its functionality. You are not allowed to integrate it in end products or use it for any commercial or productive purpose.

2. DEVELOPER LICENSE

The SOFTWARE is licensed per Developer seat. This means that each individual using or otherwise accessing the SOFTWARE for development purposes must obtain the right to do so by purchasing an individual product license.

You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same licensed developer. The SOFTWARE is in "use" on a computer when it is loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard disk or other storage device) of that computer for development purposes. If you install the SOFTWARE on a network server for the sole purpose of internal distribution among licensed developers this is not considered "use" of the SOFTWARE, so long as each individual developer has purchased a license.

2-1. Redistribution rights:

You may distribute the SOFTWARE (or, where applicable, the run-time portion of the SOFTWARE) provided that:

  • You distribute the SOFTWARE, in object code form only, as part of solutions for internal company use, hosted applications, commercial solutions deployed at end-users’ sites or shrink-wrapped software (PACKAGED PRODUCTS) in which the SOFTWARE is integrated.
  • You ensure that the SOFTWARE is not distributed in any form that allows it to be reused by any application other than your solution. Technical guidelines will be provided upon request, please contact support@telerik.com for more details.
  • You duly inform your customers that they are not allowed to use the SOFTWARE independently from your solution. For use of the SOFTWARE in design-time (i.e. within a development environment such as Microsoft Visual Studio) your customers need to purchase the appropriate number of Developer Licenses from TELERIK.
  • You include a valid copyright message in your solution in a location viewable by the end-users (e.g. "About" box).
  • You assume full responsibility for your customer’s use of the SOFTWARE and must ensure that TELERIK has no obligation to such customer or liability for such customer’s use of the SOFTWARE.

All product licenses granted by you to your end user customers in accordance with the terms of this agreement are perpetual and royalty-free.

2-2. Standard Support:

As part of your Developer License you are entitled to TELERIK’s "Standard" Support Package for a limited period of time, which guarantees an initial response to (but not necessarily a complete resolution of) your issue within forty eight (48) hours during business days. Further details regarding the current terms of the Standard Support Package can be found at http://www.telerik.com/support/technical-support-options.aspx.

3. DEVELOPER LICENSE WITH SUBSCRIPTION AND PRIORITY SUPPORT

You are granted one (1) Developer License as defined above. In addition you are entitled to receive a Source Code license, a 1 Year Subscription to receive updates, and TELERIK’s Priority Support Package as described below.

3-1. Source Code

As part of the DEVELOPER LICENSE WITH SUBSCRIPTION AND PRIORITY SUPPORT you are granted the right to view and modify the SOFTWARE's source code only as authorized below:

  • The SOFTWARE's source code is provided to the licensed developer for the sole purposes of education and troubleshooting related to the use and integration of the SOFTWARE. The SOFTWARE's source code cannot be used as a basis of development of derivative works or other software products.
  • Under no circumstances may any portion of the SOFTWARE’s source code or any modified version of the source code be distributed, disclosed or otherwise made available to any third party.
  • TELERIK DOES NOT provide technical support for modified source code.
  • The SOFTWARE’s source code is provided "AS IS". Refunds are not available for licenses that include source code.
  • In the event you develop any troubleshooting-related modifications of the SOFTWARE, either independently or jointly with TELERIK, you hereby grant to TELERIK a worldwide, irrevocable, perpetual, fully paid-up, unlimited license under any and all intellectual property rights you have in such modifications, to use, disclose, modify, reproduce, license, sublicense, distribute, commercialize and to otherwise freely exploit such modifications, directly or indirectly, without restriction of any kind.
  • You acknowledge that the SOFTWARE’s source code contains valuable and proprietary trade secrets of TELERIK. All individuals employed by or belonging to your entity agree to expend every effort to insure its confidentiality. You agree to assume full responsibility for such employees’ or contractors’ use, or misuse, of such disclosed source code as if it was your use. These obligations shall not apply to any information generally available to the public, independently developed or obtained without reliance on TELERIK information, or approved in writing for release by TELERIK without restriction.

3-2. Subscription

You are entitled to receive all version updates for the SOFTWARE for a period of 1 (one) year. Further details regarding the Subscription benefits can be found at http://www.telerik.com/purchase.aspx.

3-3. Priority Support

As part of your license you are entitled to TELERIK’s "Priority" Support Package for a limited period of time, which guarantees an initial response to (but not necessarily a complete resolution of) your issue within twenty four (24) hours during business days. Further details regarding the current terms of the Priority Support Package can be found at http://www.telerik.com/support/technical-support-options.aspx.

II. LICENSE LIMITATIONS

  • At no time may the SOFTWARE be used for development purposes by individuals other than the licensed developer(s).
  • The SOFTWARE may not be distributed for use with solutions or PACKAGED PRODUCTS other than those developed by you.
  • The SOFTWARE may not be distributed as part of products that have the same or substantially the same primary functionality as the SOFTWARE. (Example for RadControls for ASP.NET: you may purchase TELERIK RadEditor for ASP.NET and create a blog application/component. However, you cannot wrap RadMenu and offer it as a SharePoint WebPart or DNN menu skin object, since its primary functionality would be substantially the same as the SOFTWARE).
  • You are not allowed to resell, transfer, rent, lease, or sublicense the SOFTWARE and your associated rights, other than to sublicense to end users the nonsublicensable, nontransferable right to use the SOFTWARE in object code form as part of your solution. Under no circumstances shall you grant further redistribution rights to the end-users of your solution.
  • You may not use the TELERIK product names, logos or trademarks to market your software.
  • You are not allowed to reverse engineer or to disassemble, decompile or "unlock", decode or otherwise reverse translate or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only, subject to applicable law to the contrary.
  • You are not allowed to use, copy, modify, or merge copies of the SOFTWARE or any accompanying documents except as permitted in this LICENSE.
  • As a condition to the exercise or your redistribution rights, you agree to indemnify, hold harmless, and defend TELERIK and its resellers from and against any and all claims or lawsuits including attorney's fees that arise or result from the use or distribution of your software.

III. DELIVERY

TELERIK shall deliver to LICENSEE a master copy of the SOFTWARE licensed hereunder in electronic format only. Documentation shall also be provided in electronic format.

IV. UPGRADES

Service Packs and Major Version updates are available in accordance with the terms set forth at http://www.telerik.com/support/technical-support-options.aspx. You may use the resulting upgraded product only in accordance with the terms of this LICENSE.

If you have purchased a "DEVELOPER LICENSE WITH SUBSCRIPTION AND PRIORITY SUPPORT" you are entitled to receive all service packs and major version updates for the SOFTWARE for a period of 1 (one) year.

V. TERMINATION

This LICENSE shall last as long as you use the SOFTWARE in compliance with this LICENSE. TELERIK may terminate this LICENSE if you fail to comply with any of the terms and conditions herein. In such event you agree to remove and destroy all copies of the SOFTWARE and any applicable source code.

TELERIK reserves the right to discontinue at any time any product, whether it is offered individually or as a part of a product suite. However, TELERIK will fulfill any contractual obligations to provide support for discontinued products that exist as of the date of discontinuation.

VI. COPYRIGHT

All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animations, video, audio, music, text, incorporated into the SOFTWARE), the accompanying printed materials, and any copies of the SOFTWARE, and any trademarks or service marks of TELERIK are owned by TELERIK or its licensors unless explicitly stated otherwise. All title and intellectual property rights in and to the content that may be accessed through use of the SOFTWARE is the property of the respective content owner and may be protected by applicable copyright or other intellectual property laws and treaties. This LICENSE grants you no rights to use such content.

The SOFTWARE may contain licensed materials from the Microsoft ASP.NET AJAX Control Toolkit. For more information on the Microsoft Public License (Ms-PL), please visit: http://www.microsoft.com/resources/sharedsource/licensingbasics/publiclicense.mspx#Ms-PL.

VII. LIMITED WARRANTY

TELERIK warrants solely that the SOFTWARE will perform substantially in accordance with the accompanying user documentation a period of ninety (90) days. TELERIK does not warrant the use of the SOFTWARE will be uninterrupted or error free at all times and in all circumstances, nor that program errors will be corrected. This limited warranty shall not apply to any error or failure resulting from (i) machine error, (ii) LICENSEE's failure to follow operating instructions, (iii) negligence or accident, or (iv) modifications to the SOFTWARE by any person or entity other than TELERIK. In the event of a breach of warranty, LICENSEE 's sole and exclusive remedy, is repair of all or any portion of the SOFTWARE. If such remedy fails of its essential purpose, LICENSEE 's sole remedy and TELERIK's maximum liability shall be a refund of the paid purchase price for the defective SOFTWARE only. This limited warranty is only valid if TELERIK receives written notice of breach of warranty no later than thirty (30) days after the warranty period expires. EXCEPT FOR THE EXPRESS WARRANTIES SET FORTH IN THIS LICENSE, TELERIK DISCLAIMS ALL OTHER WARRANTIES, EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION THE IMPLIED WARRANTIES OF TITLE, NONINFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

VIII. LIMITATION OF LIABILITY

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT WILL TELERIK BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OF OR INABILITY TO USE THE PRODUCT, INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF, AND REGARDLESS OF THE LEGAL OR EQUITABLE THEORY (CONTRACT, TORT OR OTHERWISE) UPON WHICH THE CLAIM IS BASED. IN ANY CASE, TELERIK'S ENTIRE LIABILITY UNDER ANY PROVISION OF THIS AGREEMENT SHALL NOT EXCEED IN THE AGGREGATE THE SUM OF THE LICENSE FEES LICENSEE PAID TO TELERIK FOR THE PRODUCT GIVING RISE TO SUCH DAMAGES, NOTWITHSTANDING ANY FAILURE OF ESSENTIAL PURPOSE OF ANY LIMITED REMEDY. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS EXCLUSION AND LIMITATION MAY NOT BE APPLICABLE. TELERIK IS NOT RESPONSIBLE FOR ANY LIABILITY ARISING OUT OF CONTENT PROVIDED BY LICENSEE OR A THIRD PARTY THAT IS ACCESSED THROUGH THE PRODUCT AND/OR ANY MATERIAL LINKED THROUGH SUCH CONTENT. ANY DATA INCLUDED IN A PRODUCT UPON SHIPMENT FROM TELERIK IS FOR TESTING USE ONLY AND TELERIK HEREBY DISCLAIMS ANY AND ALL LIABILITY ARISING THEREFROM. THE EXTENT OF TELERIK'S LIABILITY FOR THE LIMITED WARRANTY SECTION SHALL BE AS SET FORTH THEREIN.

IX. MISCELLANEOUS

This License will be governed by the law of the Commonwealth of Massachusetts, U.S.A., without regard to the conflict of laws principles thereof. The Uniform Computer Information Transactions Act and the United Nations Convention on the International Sale of Goods shall not apply to this Agreement. If any provision of this LICENSE is to be held unenforceable, such holding will not affect the validity of the other provisions hereof. Failure of a party to enforce any provision of this LICENSE shall not constitute or be construed as a waiver of such provision or of the right to enforce such provision.

This License represents the entire understanding between the parties with respect to its subject matter.

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, THAT YOU UNDERSTAND THIS AGREEMENT, AND UNDERSTAND THAT BY CONTINUING THE INSTALLATION OF THE SOFTWARE PRODUCT, BY LOADING OR RUNNING THE SOFTWARE PRODUCT, OR BY PLACING OR COPYING THE SOFTWARE ONTO YOUR COMPUTER HARD DRIVE, YOU AGREE TO BE BOUND BY THIS AGREEMENT'S TERMS AND CONDITIONS. YOU FURTHER AGREE THAT, EXCEPT FOR WRITTEN SEPARATE AGREEMENTS BETWEEN TELERIK AND YOU, THIS AGREEMENT IS A COMPLETE AND EXCLUSIVE STATEMENT OF THE RIGHTS AND LIABILITIES OF THE PARTIES.


Copyrights and Trademarks

Telerik Reporting Q3 2008 Send comments on this topic.
Copyrights and Trademarks
Licensing and Distribution > Copyrights and Trademarks

Glossary Item Box

Telerik Reporting is a trademark of Telerik Corp.

.NET, Visual Basic, and Visual C# are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Adobe and Adobe Acrobat are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.


Topic Not Found

Glossary Item Box

Topic Not Found

The link you just clicked was not able to connect to the target page.

Some possible reasons and remedies are as follows:

Reason | Remedy
Destination topic is not part of the area you specified in the Filtered by field. | Either select another filter or select (no filter).
The URL of the destination topic is incorrect or has changed. | Use the index or the search function instead.
Problems with the help installation. | Rerun Setup for the product this help is related to and select the 'Repair' option.

Additional help is available for filters, search, and the index.

Click Back to return to the page you were on.

The target parameters are:

Keyword:
Index Moniker:
URL:


Adding a SqlDataAdapter to the Toolbox

Telerik Reporting Q3 2008 Send comments on this topic.
Adding a SqlDataAdapter to the Toolbox

Glossary Item Box

SqlDataAdapter is not visible in the Toolbox by default in Visual Studio 2005. To add SqlDataAdapter to the Toolbox:

  • Right-click the Data tab of the Toolbox.
  • Click Choose Items from the context menu.
  • On the .NET Framework Components tab locate the SqlDataAdapter (Use the filter edit in the lower part of the screen and type "SqlD" to find the entry more quickly).
  • Check the SqlDataAdapter entry..
  • Click the OK button to close the dialog and add the SqlDataAdapter to the Toolbox window.


Inheriting from Report Items

Telerik Reporting Q3 2008 Send comments on this topic.
Inheriting from Report Items

Glossary Item Box

You can customize report items by inheriting from existing items. In the example below a new ThumbnailBox report item class is created using PictureBox as a starting point. In this simple example we set the size, Sizing property and border style in the constructor.

[C#] Inheriting From PictureBox Copy Code
using Telerik.Reporting;
namespace MyReportLib
{
public class ThumbnailBox: Telerik.Reporting.PictureBox
{
public ThumbnailBox()
{
this.Size = new Telerik.Reporting.Drawing.SizeU(
Telerik.Reporting.Drawing.Unit.Inch(0.5),
Telerik.Reporting.Drawing.Unit.Inch(0.5));
this.Sizing =
Telerik.Reporting.Drawing.ImageSizeMode.ScaleProportional;
this.Style.BorderStyle.Top = Telerik.Reporting.Drawing.BorderType.Solid;
this.Style.BorderStyle.Bottom = Telerik.Reporting.Drawing.BorderType.Solid;
this.Style.BorderStyle.Left = Telerik.Reporting.Drawing.BorderType.Solid;
this.Style.BorderStyle.Right = Telerik.Reporting.Drawing.BorderType.Solid;
}
}
}
[VB] Inheriting From PictureBox Copy Code
Imports Telerik.Reporting
Namespace MyReportLib
Public Class ThumbnailBox
Inherits Telerik.Reporting.PictureBox
Public Sub New()
Me.Size = New Telerik.Reporting.Drawing.SizeU(_
Telerik.Reporting.Drawing.Unit.Inch(0.5), _
Telerik.Reporting.Drawing.Unit.Inch(0.5))
Me.Sizing = Telerik.Reporting.Drawing.ImageSizeMode.ScaleProportional
Me.Style.BorderStyle.Top = Telerik.Reporting.Drawing.BorderType.Solid
Me.Style.BorderStyle.Bottom = Telerik.Reporting.Drawing.BorderType.Solid
Me.Style.BorderStyle.Left = Telerik.Reporting.Drawing.BorderType.Solid
Me.Style.BorderStyle.Right = Telerik.Reporting.Drawing.BorderType.Solid
End Sub
End Class
End Namespace

You can create an instance of the inherited class in the report constructor and add it to a section of the report.

[C#] Creating an Instance Copy Code
public Report1()
{
/// <summary>
/// Required for telerik Reporting designer support
/// </summary>
InitializeComponent();
ThumbnailBox thumbnailBox = new ThumbnailBox();
thumbnailBox.Value = "=ThumbNailPhoto";
this.detail.Items.Add(thumbnailBox);
}
[VB] Creating an Instanc Copy Code
Public Sub New()
''' <summary>
''' Required for telerik Reporting designer support
''' </summary>
InitializeComponent()
Dim thumbnailBox As New ThumbnailBox()
thumbnailBox.Value = "=ThumbNailPhoto"
Me.detail.Items.Add(thumbnailBox)
End Sub


Create A New Data Source

Telerik Reporting Q3 2008 Send comments on this topic.
Create A New Data Source

Glossary Item Box

To create a new data source for a report:

  • In the Properties Window for the report locate the DataSource property drop down and select Add Project Data Source.
  • In the Data Source Configuration Wizard select Database and click Next.
  • In the Choose a Data Connection page click the New Connection button.
  • In the Add Connection dialog make sure the Data source is "Microsoft SQL Server". Set the Server name to "LOCALHOST\SQLEXPRESS". Verify that for "Log on to the server" has "Use Windows Authentication" selected. For "Connect to a database" under "Select or enter a database name" enter "AdventureWorksT" (this database is installed along with Telerik Reports). Click the OK button to close the Add Connection dialog.

Add Connection Dialog

  • In the Data Source Configuration Wizard make sure the connection you just created is selected in the drop down list and click the Next button.

  • In the Choose your Database Objects page of the wizard select the table columns you want to include in the report.
  • Click the Finish button.

Choosing Database Objects


X Axis Data Binding Properties

Telerik Reporting Q3 2008 Send comments on this topic.
X Axis Data Binding Properties

Glossary Item Box

X-Axis Properties Used in Data Binding

DataLabelsColumn: This is the name of a data source column that will supply the text that displays next to each X Axis item.


Chart Data Binding Properties

Telerik Reporting Q3 2008 Send comments on this topic.
Chart Data Binding Properties

Glossary Item Box

Chart Properties Used in Data Binding

DataSource: At runtime you can assign a compatible data source (e.g. DataSourceConrol, IList, IEnumerable, ICollection...) to the DataSource property of the chart.

DataSourceID: Assign this property at design time or run time to the ID of a DataSourceControl descendant such as SqlDataSource.

DataGroupColumn: This is the name of the column in the data source that data will be grouped by. This is similar to defining a "group by" SQL expression in the underlying query.


Chart Series Data Binding Properties

Telerik Reporting Q3 2008 Send comments on this topic.
Chart Series Data Binding Properties

Glossary Item Box

ChartSeries Properties Used in Data Binding

DataLabelsColumn: This is the name of a data source column that will supply the text that displays next to each data point in the chart.

DataXColumn, DataXColumn2, DataYColumn, DataYColumn2: These are the names of the columns that will contain data used for the series item XValue, XValue2, YValue and YValue2 columns respectively.


Display Hierarchical Data with SubReports

Telerik Reporting Q3 2008 Send comments on this topic.
Display Hierarchical Data with SubReports

Glossary Item Box

SubReports can be used to display hierarchical data. This topic will demonstrate how to create and use SubReports.

Create a Report to Display Child Data

  1. Create a new Telerik report with the name ChildProducts.
  2. Remove the default PageHeader and PageFooter.
    1. In the report's Design View, right click in the report's margin area to open the context menu.
    2. Click PageHeader and PageFooter to remove them from the report.

  3. Drag two TextBox report items onto the DetailSection of the report.
  4. In the Properties window for one TextBox control, change the Value to =ProductNumber. Include the equal sign as this will be a databound control.
  5. Change the Value property of the other TextBox to =Name.
  6. Move the TextBox report items so that their tops align with the top of the detail section.
  7. Resize the Detail Section to make it the same height as the TextBox report item.

Create a Report to Display Parent Data

  1. Create a new Telerik report with the name ParentCategories.
  2. Right-click in the ParentCategories code and select View Designer.
  3. You will need a SqlDataAdapter component from the Toolbox. By default, this component is not visible in design view of a Telerik Report. Right-click the Toolbox and select Choose Items.
  4. In the Choose Toolbox Items dialog box, check the checkbox for the SqlDataAdapter item. Click OK.
  5. Drag a SqlDataAdapter component from the Toolbox and drop it anywhere on the report.
  6. In the Data Adapter Configuration Wizard, click New Connection.
  7. In the Add Connection dialog box, enter (local)\SQLEXPRESS for the Server Name. Select the AdventureWorksT database.

  8. Click OK.
  9. Click Next.
  10. Select Use SQL Statements. Click Next.
  11. Type SELECT * FROM Production.ProductCategory. Click Finish.
  12. Select the Report (to do this easily, click in the box at the upper left where the rulers meet).
  13. Set the DataSource property of the Report to sqlDataAdapter1.
  14. Drag a TextBox control from the ToolBox and drop it on the Page Header section of the report.
  15. Set the Value property of the textbox to Products by Category.
  16. Use the sizing handles on the textbox to resize it so that all of the text is visible.
  17. Open the report's Data Explorer.
  18. Drag the Name field and drop it on the Details section of the report.

  19. Resize the Name field to about 3 times it's original width.

Build the Project

It is necessary to build the project so that the parent report is able to discover the ChildProducts report.

  1. Right click the Project name in the Solution Explorer. This will open the project's Context Menu.
  2. Click Build on the Context Menu.

Add the ChildProducts report as a subreport

  1. Drag a SubReport control onto the DetailSection of the ParentCategories report.
  2. In the properties window for the SubReport control, locate the ReportSource property.
  3. Click the arrow for the drop-down list and select ChildProducts.
  4. Reposition and resize the SubReport so that the width is a little smaller than the report width.

  5. Resize the DetailsSection so that the bottom is just below the bottom of the SubReport control.

Add Code to bind the SubReport to Product data

  1. Right click the ParentCategories report Designer and select View Code.
  2. To create variables for the report to retain a SQL Query string and a DataView, add the following code below the class declaration.

To help with placement the existing class declaration is presented below in grey text.

Visual Basic Copy Code
Partial Public Class ParentReport
    Inherits Report

Private GetProductsCommandText As String = "select P.Name,ProductID,ProductNumber,PC.ProductCategoryID " & _
  " from Production.Product  P,Production.ProductSubcategory PS,Production.ProductCategory PC " & _
  " where P.ProductSubcategoryID=PS.ProductSubcategoryID and PS.ProductCategoryID=PC.ProductCategoryID"
  Private productsView As DataView
C# Copy Code
public partial class ParentCategories : Report
 {
    private string GetProductsCommandText = "select P.Name,ProductID,ProductNumber,PC.ProductCategoryID " +
       " from Production.Product P,Production.ProductSubcategory PS,Production.ProductCategory PC " +
        " where P.ProductSubcategoryID=PS.ProductSubcategoryID and PS.ProductCategoryID=PC.ProductCategoryID";
    private System.Data.DataView productsView;
  3. Return to Design View.
  4. Click the SubReport control to select it.
  5. In the properties window, click the events icon (lightning bolt) to view the SubReport events.
  6. Double click the NeedDataSource event. This will create an event handler in the code.
  7. Modify the NeedDataSource event handler as follows:
Visual Basic Copy Code

Private Sub SubReport1_NeedDataSource(ByVal sender As System.Object, ByVal e As System.EventArgs) _
 Handles SubReport1.NeedDataSource
  Dim subrpt As Telerik.Reporting.Processing.SubReport = sender
  Dim drv As DataRowView = subrpt.DataItem
  Dim categoryID As Int32 = drv.Item("ProductCategoryID")
  'Set the subreport's datasource to the filtered product list
  subrpt.Report.DataSource = GetProductDataSource(categoryID)
End Sub
C# Copy Code

private void subReport1_NeedDataSource(object sender, System.EventArgs e)
{
    Telerik.Reporting.Processing.SubReport subrpt = (Telerik.Reporting.Processing.SubReport)sender;
    DataRowView drv = (DataRowView)subrpt.DataItem;
    int categoryID = (int)drv["ProductCategoryID"];
    //Set the subreport's datasource to the filtered product list
    subrpt.Report.DataSource = GetProductDataSource(categoryID);
}

The above code will send the ID of each category to the GetProductDataSource method (below) and bind the resulting filtered data to the SubReport for that category.

  8. Paste the following code into the ParentCategories report.
Visual Basic Copy Code
Private Function GetProductDataSource(ByVal categoryID As Integer) As DataView
        'Get all of the products from the database and store them in ProductsView.
        'Once ProductsView is populated, there is no need to requery the database.
        If Me.productsView Is Nothing Then
            Dim ds As New DataSet()
            Dim adapter As New System.Data.SqlClient.SqlDataAdapter(GetProductsCommandText, Me.SqlConnection1)
            adapter.Fill(ds)
            Me.productsView = ds.Tables(0).DefaultView
        End If
        'For each category, filter the products view
        Me.productsView.RowFilter = String.Format("ProductCategoryID='{0}'", categoryID)
        Return Me.productsView
    End Function
C# Copy Code
private System.Data.DataView GetProductDataSource(int categoryID)
       {
        //Get all of the products from the database and store them in ProductsView.
        //Once ProductsView is populated, there is no need to requery the database.
        if (productsView == null)
        {
             DataSet ds = new DataSet();
            SqlDataAdapter adapter = new SqlDataAdapter(GetProductsCommandText, sqlConnection1);
            adapter.Fill(ds);
            productsView = ds.Tables[0].DefaultView;
        }
        //For each category, filter the products view
        productsView.RowFilter = string.Format("ProductCategoryID='{0}'", categoryID);
        return productsView;
      }

Add the report to Form1

  1. Open Form1 in design mode.
  2. Drag a ReportViewer control from the Toolbox and drop it on Form1.
  3. Set the Dock property of the ReportViewer control to Fill.
  4. Right-click on the form and select View Code.
  5. Modify the form's constructor as follows:
Visual Basic Copy Code
Private Sub Form1_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
        Me.ReportViewer1.Report = New ParentReport
        Me.ReportViewer1.RefreshReport()
    End Sub
C# Copy Code
public Form1()
{
    InitializeComponent();
    reportViewer1.Report = (Telerik.Reporting.Report)new Report1();
    reportViewer1.RefreshReport();
}

Run the Hierarchical Report

  1. Press F5 to run the project and view the report.


How do I dynamically modify the value of an item?

Telerik Reporting Q3 2008 Send comments on this topic.
How do I dynamically modify the value of an item?

Glossary Item Box

To change the value of a particular report item at runtime, use the item's ItemDataBound() event handler.

  1. In the report designer select the report item.
  2. In the Properties Window click the Events button.
  3. Double-click the ItemDataBound event to create an event handler.
  4. Write code similar to the example below. In the example there is a check that "sender" is a TextBox, "sender" is cast to be of type TextBox and finally the Text property of the item is assigned a value.
[C#] Editing the value of a Report item Copy Code
private void textBox1_ItemDataBound(object sender, System.EventArgs e)
{
if (sender is Telerik.Reporting.Processing.TextBox)
{
(sender as Telerik.Reporting.Processing.TextBox).Text =
"The value is changed in ItemDataBound";
}
}
[VB] Editing the value of a report item Copy Code
Private Sub textBox1_ItemDataBound(ByVal sender As Object, ByVal e As System.EventArgs)
If TypeOf sender Is Telerik.Reporting.Processing.TextBox Then
(TryCast(sender, _
Telerik.Reporting.Processing.TextBox)).Text = _
"The value is changed in ItemDataBound"
End If
End Sub


Can HTML Created with RadEditor be displayed in HTML format?

Telerik Reporting Q3 2008 Send comments on this topic.
Can HTML Created with RadEditor be displayed in HTML format?

Glossary Item Box

You can bind telerik Reporting elements to any valid DataSource field. In this case you should use a label in your report and bind it to the respective field containing the HTML saved with r.a.d.editor.


Why is only the first page of a TIFF exported?

Telerik Reporting Q3 2008 Send comments on this topic.
Why is only the first page of a TIFF exported?

Glossary Item Box

There may be some confusion is caused by the software that is being used to open the file. Telerik currently uses Microsoft Office Document Imaging. Microsoft Office Document Imaging opens and displays all pages of a multi-paged TIFF. Other tools such as the Windows Picture and Fax Viewer have slightly different interfaces and do not show the multi-page outline of the document. Instead you have to change individual pages via the Previous/Current/Next Page buttons found on the bottom toolbar.


What is the preferred report render extension for producing labels?

Telerik Reporting Q3 2008 Send comments on this topic.
What is the preferred report render extension for producing labels?

Glossary Item Box

To achieve the best results when producing labels, use the WinForms viewer. You can directly print the report from the viewer or, if you want to store the report for later use, you can export it to PDF or TIFF and print it later. The PDF and TIFF image formats are page-oriented formats. As a result, you can set properties to precisely control how pages will look when viewed in PDF or TIFF formats. That makes this formats more suitable for printing on paper.


Can I print the whole report and not just the current page?

Telerik Reporting Q3 2008 Send comments on this topic.
Can I print the whole report and not just the current page?

Glossary Item Box

Pages that will print are controlled by the Print dialog | Page Range. Here you can specify:

  • All pages
  • Current Page
  • A set of pages, e.g. "1-3".

Setting page range to print


Conditional Formatting

Telerik Reporting Q3 2008 Send comments on this topic.
Conditional Formatting

Glossary Item Box

Conditional formatting lets you change the style and display of the report dynamically based rules that you define using simple comparisons or by building more complex expressions with the Integrated Expression Builder.


Integrated Expression Builder

Telerik Reporting Q3 2008 Send comments on this topic.
Integrated Expression Builder

Glossary Item Box

The expression builder is used throughout Telerik Reporting wherever a simple value might otherwise be assigned. Use the expression builder to assign bound database fields, aggregate data, use functions and report parameters or develop more complex expressions with multiple expression elements at one time.


Filters

Telerik Reporting Q3 2008 Send comments on this topic.
Filters

Glossary Item Box

Filters lets you decide at runtime which records to show based on comparing database field data with expressions you construct with the Expression Builder, e.g. Fields.Quantity > Avg(Fields.Quantity) . A typical use would be to compare against a Report Parameter in an expression, or Fields. The screenshot below shows a filter where Category must be equal to the report parameter "Category" and the ListPrice field must be less than or equal to a "MaxPrice" report parameter.


Grouping

Telerik Reporting Q3 2008 Send comments on this topic.
Grouping

Glossary Item Box

Use groups to break up report data by one or more fields, or use Report Parameters and the Expression Builder to assign group level breaks at runtime. See Creating Grouping Levels for a walkthrough of this feature.


Report Parameters

Telerik Reporting Q3 2008 Send comments on this topic.
Report Parameters

Glossary Item Box

Report Parameters allow you to tailor report output at runtime for reports and SubReports. This feature is especially powerful when used together with reporting Groups, Filters and Sorting collections and using the integrated expression builder. You can define ReportParameters and use the parameters in expressions in your report, and assign values dynamically to parameters in your report viewing application at runtime.


Report Wizard

Telerik Reporting Q3 2008 Send comments on this topic.
Report Wizard

Glossary Item Box

The Report Wizard steps you through building a report, from data binding to layout and styling. Wizard highlights include:

  • Automatically group and sub total on any column.
  • Convert existing Crystal and ActiveReports.
  • Choose from predefined layout formats and styles.

See the Quick Start Creating a Simple Report and Extending the Simple Report Design for step by step walkthroughs using the Report Wizard.


Sorting

Telerik Reporting Q3 2008 Send comments on this topic.
Sorting

Glossary Item Box

You can sort the report data or data within a group on any column. This feature is especially powerful when combined with Report Parameters and the Integrated Expression Builder.

You can sort the report output using the Report Sorting collection and simply assign fields to sort by or use an expression. In the example below the expression being selected evaluates if the Report Parameter "Category" is "Bikes" and sorts by ProductNumber, otherwise the sort is by Name.


Glossary

Telerik Reporting Q3 2008 Send comments on this topic.
Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z


Empty Index Entry

Glossary Item Box

Empty Index Entry

The index entry you selected has no target topics associated with it.

If you have chosen a parent entry, please select a child entry.


Deployment

Telerik Reporting Q3 2008 Send comments on this topic.
Deployment

Glossary Item Box

Deprecated Assemblies

In order to simplify the usage and deployment of Telerik Reporting comes with a reduced number of assemblies. All exporting format extensions and the data processing are part of Telerik.Reporting.Processing.dll. The following assemblies are deprecated:

  • Telerik.Reporting.Data.dll
  • Telerik.Reporting.ImageRendering.dll
  • Telerik.Reporting.HtmlRendering.dll

Converter Support

Telerik.Reporting.VsPackage.dl and Interop.CRAXDRT.dll are required by the Report design time and should not be deployed on the production computer. They are used when converting reports from Active Reports and Crystal Reports to Telerik Reporting.

The ActiveReports converter works with the current ActiveReports3 version. For more information please read the knowledge base article Assembly binding rediretion for ActiveReports3 report converter. If you install any version of ActiveReports3 you will be able to run existing reports and convert them to Telerik.


Creating a Class Library to Contain Reports

Telerik Reporting Q3 2008 Send comments on this topic.
Creating a Class Library to Contain Reports

Glossary Item Box

  1. Select File | New | Project from the Visual Studio 2005 File menu. Select the Class Library project, give it a name and location. Click the OK button to close the dialog.

Creating the Class Library

  2. Right-click the project context menu and select Add | New Item | Telerik Report. Enter a name for the report class and click the Add button to close the dialog. In this example we name the report class file "ProductList.cs".

  3. The Telerik Report Wizard will appear automatically to help you select data and design your report quickly. Once you have the basic report layout you can go back to edit the report, add data columns and tweak the format. Click the Next button.

  4. On the Report Choice Page of the Report Wizard, select New Report and click the Next button.

  5. On the Choose Data Source page of the Report Wizard, select New Data Source and click the Next button.

  6. On the Choose a Data Source Type page of the Report Wizard select the Database icon and click the Next button.

  7. The standard Add Connection dialog will display.
  • In the Server Name edit enter "(local)\sqlexpress".
  • In Select or enter a database name enter "AdventureWorksT".
  • Optionally, you can click the "Test Connection" button to verify the connection.
  • Click OK to close the dialog. Note: The AdventureWorksT database installs with Telerik Reports and so should always be available to test with.

  8. On the Choose a Data Connection page of the Reports Wizard select your new database connection for AdventureWorksT from the drop down list. Note: The machine name will be the name of the machine you are developing on, but shown in the figure below as "ra". Click the Next button.

  9. The Choose Your Database Objects page of the Reports Wizard will display next.
  • Click the Query Builder button.
  • In the Add Table dialog select "Product", "ProductInventory", "ProductPhoto" and "ProductProductPhoto" from the list of tables. Note: You can hold down the control key an click each of the tables to select them all at one time.
  • Click the Add button to close the dialog.

  • On the Query Builder select the fields shown in the figure below. In the Product table select "Name", "ProductNumber" and "ReorderPoint". In ProductPhoto select the "ThumbNailPhoto" column. In the ProductInventory table select the "Quantity" column.
  • Click the OK button to close the dialog.

  • In the Choose your Database Objects page of the Report Wizard leave the values shown and click the Next button.

  10. The Design Data Layout page of the Report Wizard allows you to assign database fields to sections of the report. The Report Wizard automatically places and formats the database fields in the appropriate report sections.
  • Select from the Available Fields list on the left side of the page.
  • Select "Name", "ProductNumber", "ReorderPoint" and "Quantity".
  • After selecting each field, click the Detail button to add those columns to the detail listing of the report.
  • Click the Next button.

  11. On the Choose Report Layout page of the Report Wizard unselect the Adjust report items to fit available space checkbox. Click the Next button.

  12. On the Choose Report Style page of the Report Wizard select "Civic" from the Style Sheets list on the left side of the page. Notice the style changes in the Preview portion on the right side of the page.

  13. On the Completing the Wizard page of the Report Wizard you can review the settings for the report and click the Finish button.

The initial report layout appears in the design view in Visual Studio.

Notice that the wizard has automatically provided:

  • Data bound fields in the detail section of the report.
  • Styled page and column titles.
  • A page footer with standard date and page number output.

  14. Click F6 to build the report.
  15. Click the Preview tab of the designer to view your report.

From here you can:

  • Extend the Simple Report Design to include conditional formatting, Shape and PictureBox report items. Also this topic also introduces in-place editing, copying and pasting styles, using the Data Explorer and Report Explorer.
  • Create a Windows application to display the reports.


Chart

Telerik Reporting Q2 2008 Send comments on this topic.
Chart
See Also

Glossary Item Box

The Chart report item is used to display a chart on a report. This screenshot shows a Chart report item.

The formatting of the Chart report item is managed by a large number of properties. To customize the Chart report item, right-click the chart and select Properties from the context menu to use the Chart Wizard.

You can find the full documentation of Telerik Charting on the location below:

http://www.telerik.com/help/aspnet/chart/introduction.html

See Also

Chart Class

Charting
Telerik Charting Documentation


Using Report Output Formats

Telerik Reporting Q3 2008 Send comments on this topic.
Using Report Output Formats

Glossary Item Box

There are several output formats for reports built using Telerik Reporting. The default output formats include:

  • Web archive
  • Adobe Acrobat (PDF)
  • TIFF File
  • CSV (Comma delimited)


Excel

Telerik Reporting Q3 2008 Send comments on this topic.
Excel

Glossary Item Box


Word

Telerik Reporting Q3 2008 Send comments on this topic.
Word

Glossary Item Box


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you


Assembly Overview

Telerik.Reporting Assembly ()

Namespaces

Namespace | Description
Telerik.Reporting |
Telerik.Reporting.Charting |
Telerik.Reporting.Charting.Styles |
Telerik.Reporting.Data |
Telerik.Reporting.Drawing |
Telerik.Reporting.Drawing.Shapes |


Assembly Overview

Telerik.Reporting.Interfaces Send comments on this topic.
Telerik.Reporting.Interfaces Assembly

Namespaces

Namespace | Description
Telerik.Reporting |
Telerik.Reporting.Interfaces |
Telerik.Reporting.Interfaces.Attributes |
Telerik.Reporting.Processing |


Getting Started - Telerik.Reporting.Interfaces

Telerik.Reporting.Interfaces Send comments on this topic.
Getting Started


Introduction - Telerik.Reporting.Interfaces

Telerik.Reporting.Interfaces Send comments on this topic.
Introduction


ExtensionAttribute Class Properties

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionAttribute Class Properties
See Also
[image]
Telerik.Reporting.Interfaces.Attributes Namespace : ExtensionAttribute Class

For a list of all members of this type, see ExtensionAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

ExtensionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Telerik.Reporting.Interfaces.Attributes Namespace

Telerik.Reporting.Interfaces Send comments on this topic.
Telerik.Reporting.Interfaces.Attributes Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
ExtensionAttribute | The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base
ExtensionDescriptionAttribute | The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base
ExtensionLocalizedDescriptionAttribute | The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base
ExtensionNameAttribute | The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base
ExtensionParameterAttribute | The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base
ExtensionVisibleAttribute | The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base

See Also

Reference

Telerik.Reporting.Interfaces Assembly


Telerik.Reporting.Interfaces.Attributes Namespace Inheritance Hierarchy

Telerik.Reporting.Interfaces Send comments on this topic.
Telerik.Reporting.Interfaces.Attributes Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Attribute
Telerik.Reporting.Interfaces.Attributes.ExtensionAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionDescriptionAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionLocalizedDescriptionAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionNameAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionParameterAttribute
Telerik.Reporting.Interfaces.Attributes.ExtensionVisibleAttribute

See Also

Reference

Telerik.Reporting.Interfaces Assembly


ExtensionManagerException Class Methods

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionManagerException Class Methods
See Also
[image]
Telerik.Reporting.Interfaces Namespace : ExtensionManagerException Class

For a list of all members of this type, see ExtensionManagerException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ExtensionManagerException Class
Telerik.Reporting.Interfaces Namespace


ExtensionManagerException Class Properties

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionManagerException Class Properties
See Also
[image]
Telerik.Reporting.Interfaces Namespace : ExtensionManagerException Class

For a list of all members of this type, see ExtensionManagerException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

ExtensionManagerException Class
Telerik.Reporting.Interfaces Namespace


ExtensionParameterException Class Methods

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionParameterException Class Methods
See Also
[image]
Telerik.Reporting.Interfaces Namespace : ExtensionParameterException Class

For a list of all members of this type, see ExtensionParameterException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ExtensionParameterException Class
Telerik.Reporting.Interfaces Namespace


ExtensionParameterException Class Properties

Telerik.Reporting.Interfaces Send comments on this topic.
ExtensionParameterException Class Properties
See Also
[image]
Telerik.Reporting.Interfaces Namespace : ExtensionParameterException Class

For a list of all members of this type, see ExtensionParameterException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

ExtensionParameterException Class
Telerik.Reporting.Interfaces Namespace


Telerik.Reporting.Interfaces Namespace

Telerik.Reporting.Interfaces Send comments on this topic.
Telerik.Reporting.Interfaces Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
ExtensionManagerException |
ExtensionParameterException |

Interfaces

Interface | Description
IConverterLog |
IReportConverter |

See Also

Reference

Telerik.Reporting.Interfaces Assembly


Telerik.Reporting.Interfaces Namespace Inheritance Hierarchy

Telerik.Reporting.Interfaces Send comments on this topic.
Telerik.Reporting.Interfaces Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Telerik.Reporting.Interfaces.ExtensionManagerException
Telerik.Reporting.Interfaces.ExtensionParameterException

See Also

Reference

Telerik.Reporting.Interfaces Assembly


Telerik.Reporting.Processing Namespace (Telerik.Reporting.Interfaces)

Telerik.Reporting.Interfaces Send comments on this topic.
Telerik.Reporting.Processing Namespace (Telerik.Reporting.Interfaces)
See Also Inheritance Hierarchy

Classes

Class | Description
ExtensionInfo | Store info for an extension

See Also

Reference

Telerik.Reporting.Interfaces Assembly


Telerik.Reporting.Processing Namespace (Telerik.Reporting.Interfaces) Inheritance Hierarchy

Telerik.Reporting.Interfaces Send comments on this topic.
Telerik.Reporting.Processing Namespace (Telerik.Reporting.Interfaces) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
Telerik.Reporting.Processing.ExtensionInfo

See Also

Reference

Telerik.Reporting.Interfaces Assembly


Telerik.Reporting Namespace (Telerik.Reporting.Interfaces)

Telerik.Reporting.Interfaces Send comments on this topic.
Telerik.Reporting Namespace (Telerik.Reporting.Interfaces)
See Also Inheritance Hierarchy

Interfaces

Interface | Description
IExtension | Telerik Reporting extension

See Also

Reference

Telerik.Reporting.Interfaces Assembly


Telerik.Reporting Namespace (Telerik.Reporting.Interfaces) Inheritance Hierarchy

Telerik.Reporting.Interfaces Send comments on this topic.
Telerik.Reporting Namespace (Telerik.Reporting.Interfaces) Inheritance Hierarchy
See Also

See Also

Reference

Telerik.Reporting.Interfaces Assembly


Assembly Overview

Telerik.Reporting.Processing Send comments on this topic.
Telerik.Reporting.Processing Assembly ()

Namespaces

Namespace | Description
Telerik.Reporting.Barcodes |
Telerik.Reporting.Processing |
Telerik.Reporting.Processing.Config |
Telerik.Reporting.Processing.ReportParameters |
Telerik.Reporting.RtfRendering |


Getting Started - Telerik.Reporting.Processing

Telerik.Reporting.Processing Send comments on this topic.
Getting Started


Introduction - Telerik.Reporting.Processing

Telerik.Reporting.Processing Send comments on this topic.
Introduction


BoundsException Class Methods

Telerik.Reporting.Processing Send comments on this topic.
BoundsException Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : BoundsException Class

For a list of all members of this type, see BoundsException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

BoundsException Class
Telerik.Reporting.Barcodes Namespace


BoundsException Class Properties

Telerik.Reporting.Processing Send comments on this topic.
BoundsException Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : BoundsException Class

For a list of all members of this type, see BoundsException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

BoundsException Class
Telerik.Reporting.Barcodes Namespace


CheckMSI Enumeration

Telerik.Reporting.Processing Send comments on this topic.
CheckMSI Enumeration
See Also
[image]
Telerik.Reporting.Barcodes Namespace : CheckMSI Enumeration

Namespace: Telerik.Reporting.Barcodes
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Enum CheckMSI
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As CheckMSI
C#
public enum CheckMSI : Enum

Members

Member | Description
Modulo10 |
Modulo11 |
Modulo1010 |
Modulo1110 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Barcodes.CheckMSI

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Barcodes Namespace


Codabar Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Codabar Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Codabar Class

For a list of all members of this type, see Codabar members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Codabar Class
Telerik.Reporting.Barcodes Namespace


Code11 Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Code11 Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code11 Class

For a list of all members of this type, see Code11 members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Code11 Class
Telerik.Reporting.Barcodes Namespace


Code25 Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Code25 Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code25 Class

For a list of all members of this type, see Code25 members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Code25 Class
Telerik.Reporting.Barcodes Namespace


Code25Interleaved Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Code25Interleaved Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code25Interleaved Class

For a list of all members of this type, see Code25Interleaved members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Code25Interleaved Class
Telerik.Reporting.Barcodes Namespace


Code25Standard Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Code25Standard Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code25Standard Class

For a list of all members of this type, see Code25Standard members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Code25Standard Class
Telerik.Reporting.Barcodes Namespace


Code39 Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Code39 Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code39 Class

For a list of all members of this type, see Code39 members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Code39 Class
Telerik.Reporting.Barcodes Namespace


Code39Extended Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Code39Extended Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code39Extended Class

For a list of all members of this type, see Code39Extended members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Code39Extended Class
Telerik.Reporting.Barcodes Namespace


Code93 Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Code93 Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code93 Class

For a list of all members of this type, see Code93 members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Code93 Class
Telerik.Reporting.Barcodes Namespace


Code93Extended Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Code93Extended Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code93Extended Class

For a list of all members of this type, see Code93Extended members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Code93Extended Class
Telerik.Reporting.Barcodes Namespace


Code128 Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Code128 Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code128 Class

For a list of all members of this type, see Code128 members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Code128 Class
Telerik.Reporting.Barcodes Namespace


Code128A Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Code128A Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code128A Class

For a list of all members of this type, see Code128A members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Code128A Class
Telerik.Reporting.Barcodes Namespace


Code128B Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Code128B Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code128B Class

For a list of all members of this type, see Code128B members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Code128B Class
Telerik.Reporting.Barcodes Namespace


Code128C Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Code128C Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Code128C Class

For a list of all members of this type, see Code128C members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Code128C Class
Telerik.Reporting.Barcodes Namespace


EAN8 Class Properties

Telerik.Reporting.Processing Send comments on this topic.
EAN8 Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : EAN8 Class

For a list of all members of this type, see EAN8 members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | HeadRect | (Inherited from Product1D)
Protected Property | HeadText | (Inherited from Product1D)
Protected Property | LeftRect | (Inherited from Product1D)
Protected Property | LeftText | (Inherited from Product1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | RightRect | (Inherited from Product1D)
Protected Property | RightText | (Inherited from Product1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TailRect | (Inherited from Product1D)
Protected Property | TailText | (Inherited from Product1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

EAN8 Class
Telerik.Reporting.Barcodes Namespace


EAN13 Class Properties

Telerik.Reporting.Processing Send comments on this topic.
EAN13 Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : EAN13 Class

For a list of all members of this type, see EAN13 members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | HeadRect | (Inherited from Product1D)
Protected Property | HeadText | (Inherited from Product1D)
Protected Property | LeftRect | (Inherited from Product1D)
Protected Property | LeftText | (Inherited from Product1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | RightRect | (Inherited from Product1D)
Protected Property | RightText | (Inherited from Product1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TailRect | (Inherited from Product1D)
Protected Property | TailText | (Inherited from Product1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

EAN13 Class
Telerik.Reporting.Barcodes Namespace


EAN128 Class Properties

Telerik.Reporting.Processing Send comments on this topic.
EAN128 Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : EAN128 Class

For a list of all members of this type, see EAN128 members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

EAN128 Class
Telerik.Reporting.Barcodes Namespace


FormatException Class Methods

Telerik.Reporting.Processing Send comments on this topic.
FormatException Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : FormatException Class

For a list of all members of this type, see FormatException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

FormatException Class
Telerik.Reporting.Barcodes Namespace


FormatException Class Properties

Telerik.Reporting.Processing Send comments on this topic.
FormatException Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : FormatException Class

For a list of all members of this type, see FormatException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

FormatException Class
Telerik.Reporting.Barcodes Namespace


LengthException Class Methods

Telerik.Reporting.Processing Send comments on this topic.
LengthException Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : LengthException Class

For a list of all members of this type, see LengthException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

LengthException Class
Telerik.Reporting.Barcodes Namespace


LengthException Class Properties

Telerik.Reporting.Processing Send comments on this topic.
LengthException Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : LengthException Class

For a list of all members of this type, see LengthException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

LengthException Class
Telerik.Reporting.Barcodes Namespace


Postnet Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Postnet Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : Postnet Class

For a list of all members of this type, see Postnet members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

Postnet Class
Telerik.Reporting.Barcodes Namespace


SymbolException Class Methods

Telerik.Reporting.Processing Send comments on this topic.
SymbolException Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : SymbolException Class

For a list of all members of this type, see SymbolException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

SymbolException Class
Telerik.Reporting.Barcodes Namespace


SymbolException Class Properties

Telerik.Reporting.Processing Send comments on this topic.
SymbolException Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : SymbolException Class

For a list of all members of this type, see SymbolException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

SymbolException Class
Telerik.Reporting.Barcodes Namespace


UPCA Class Properties

Telerik.Reporting.Processing Send comments on this topic.
UPCA Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : UPCA Class

For a list of all members of this type, see UPCA members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | HeadRect | (Inherited from Product1D)
Protected Property | HeadText | (Inherited from Product1D)
Protected Property | LeftRect | (Inherited from Product1D)
Protected Property | LeftText | (Inherited from Product1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | RightRect | (Inherited from Product1D)
Protected Property | RightText | (Inherited from Product1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TailRect | (Inherited from Product1D)
Protected Property | TailText | (Inherited from Product1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

UPCA Class
Telerik.Reporting.Barcodes Namespace


UPCE Class Properties

Telerik.Reporting.Processing Send comments on this topic.
UPCE Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : UPCE Class

For a list of all members of this type, see UPCE members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | HeadRect | (Inherited from Product1D)
Protected Property | HeadText | (Inherited from Product1D)
Protected Property | LeftRect | (Inherited from Product1D)
Protected Property | LeftText | (Inherited from Product1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | RightRect | (Inherited from Product1D)
Protected Property | RightText | (Inherited from Product1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TailRect | (Inherited from Product1D)
Protected Property | TailText | (Inherited from Product1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

UPCE Class
Telerik.Reporting.Barcodes Namespace


UPCSupplement2 Class Properties

Telerik.Reporting.Processing Send comments on this topic.
UPCSupplement2 Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : UPCSupplement2 Class

For a list of all members of this type, see UPCSupplement2 members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

UPCSupplement2 Class
Telerik.Reporting.Barcodes Namespace


UPCSupplement5 Class Properties

Telerik.Reporting.Processing Send comments on this topic.
UPCSupplement5 Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : UPCSupplement5 Class

For a list of all members of this type, see UPCSupplement5 members.

Public Properties

 | Name | Description
Public Property | Angle | (Inherited from SymbologyBase)
Public Property | BackColor | (Inherited from SymbologyBase)
Public Property | BarAlign | (Inherited from SymbologyBase)
Public Property | Checksum | (Inherited from SymbologyBase)
Public Property | Font | (Inherited from SymbologyBase)
Public Property | ForeColor | (Inherited from SymbologyBase)
Public Property | Module | (Inherited from SymbologyBase)
Public Property | ShowText | (Inherited from SymbologyBase)
Public Property | Stretch | (Inherited from SymbologyBase)
Public Property | TextHorizontalAlign | (Inherited from SymbologyBase)
Public Property | TextVerticalAlign | (Inherited from SymbologyBase)
Public Property | Value | (Inherited from SymbologyBase)
Top

Protected Properties

 | Name | Description
Protected Property | BarRect | (Inherited from Symbology1D)
Protected Property | ClipRect | (Inherited from Symbology1D)
Protected Property | Pattern | (Inherited from Symbology1D)
Protected Property | Symbols | (Inherited from Symbology1D)
Protected Property | TextRect | (Inherited from Symbology1D)
Protected Property | TextSize | (Inherited from Symbology1D)
Top

See Also

Reference

UPCSupplement5 Class
Telerik.Reporting.Barcodes Namespace


ValidateException Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ValidateException Class Methods
See Also
[image]
Telerik.Reporting.Barcodes Namespace : ValidateException Class

For a list of all members of this type, see ValidateException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ValidateException Class
Telerik.Reporting.Barcodes Namespace


ValidateException Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ValidateException Class Properties
See Also
[image]
Telerik.Reporting.Barcodes Namespace : ValidateException Class

For a list of all members of this type, see ValidateException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

ValidateException Class
Telerik.Reporting.Barcodes Namespace


Telerik.Reporting.Barcodes Namespace

Telerik.Reporting.Processing Send comments on this topic.
Telerik.Reporting.Barcodes Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
BoundsException |
Codabar |
Code11 |
Code128 |
Code128A |
Code128B |
Code128C |
Code25 |
Code25Interleaved |
Code25Standard |
Code39 |
Code39Extended |
Code93 |
Code93Extended |
CodeMSI |
EAN128 |
EAN13 |
EAN8 |
FormatException |
GraphicsProxy |
LengthException |
Postnet |
Product1D |
SymbolException |
Symbology1D |
SymbologyBase |
UPCA |
UPCE |
UPCSupplement2 |
UPCSupplement5 |
ValidateException |

Interfaces

Interface | Description
IGraphics |

Enumerations

Enumeration | Description
CheckMSI |

See Also

Reference

Telerik.Reporting.Processing Assembly


Telerik.Reporting.Barcodes Namespace Inheritance Hierarchy

Telerik.Reporting.Processing Send comments on this topic.
Telerik.Reporting.Barcodes Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.ArgumentException
Telerik.Reporting.Barcodes.BoundsException
Telerik.Reporting.Barcodes.ValidateException
Telerik.Reporting.Barcodes.FormatException
Telerik.Reporting.Barcodes.LengthException
Telerik.Reporting.Barcodes.SymbolException
Telerik.Reporting.Barcodes.GraphicsProxy
Telerik.Reporting.Barcodes.SymbologyBase
Telerik.Reporting.Barcodes.Symbology1D
Telerik.Reporting.Barcodes.Codabar
Telerik.Reporting.Barcodes.Code11
Telerik.Reporting.Barcodes.Code128
Telerik.Reporting.Barcodes.Code128A
Telerik.Reporting.Barcodes.Code128B
Telerik.Reporting.Barcodes.Code128C
Telerik.Reporting.Barcodes.EAN128
Telerik.Reporting.Barcodes.Code25
Telerik.Reporting.Barcodes.Code25Interleaved
Telerik.Reporting.Barcodes.Code25Standard
Telerik.Reporting.Barcodes.Code39
Telerik.Reporting.Barcodes.Code39Extended
Telerik.Reporting.Barcodes.Code93
Telerik.Reporting.Barcodes.Code93Extended
Telerik.Reporting.Barcodes.CodeMSI
Telerik.Reporting.Barcodes.Postnet
Telerik.Reporting.Barcodes.Product1D
Telerik.Reporting.Barcodes.EAN13
Telerik.Reporting.Barcodes.EAN8
Telerik.Reporting.Barcodes.UPCA
Telerik.Reporting.Barcodes.UPCE
Telerik.Reporting.Barcodes.UPCSupplement2
Telerik.Reporting.Barcodes.UPCSupplement5

See Also

Reference

Telerik.Reporting.Processing Assembly


ExtensionElement Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ExtensionElement Class Methods
See Also
[image]
Telerik.Reporting.Processing.Config Namespace : ExtensionElement Class

For a list of all members of this type, see ExtensionElement members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Configuration.ConfigurationElement)
Public Method | GetHashCode | (Inherited from System.Configuration.ConfigurationElement)
Public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
Protected Method | DeserializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Init | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | InitializeDefault | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ResetModified | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeToXmlElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Unmerge | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ExtensionElement Class
Telerik.Reporting.Processing.Config Namespace


ExtensionsSection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ExtensionsSection Class Methods
See Also
[image]
Telerik.Reporting.Processing.Config Namespace : ExtensionsSection Class

For a list of all members of this type, see ExtensionsSection members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Configuration.ConfigurationElement)
Public Method | GetHashCode | (Inherited from System.Configuration.ConfigurationElement)
Public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
Protected Method | DeserializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Init | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | InitializeDefault | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ResetModified | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeToXmlElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Unmerge | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ExtensionsSection Class
Telerik.Reporting.Processing.Config Namespace


ParameterElement Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ParameterElement Class Methods
See Also
[image]
Telerik.Reporting.Processing.Config Namespace : ParameterElement Class

For a list of all members of this type, see ParameterElement members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Configuration.ConfigurationElement)
Public Method | GetHashCode | (Inherited from System.Configuration.ConfigurationElement)
Public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
Protected Method | DeserializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Init | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | InitializeDefault | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ResetModified | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeToXmlElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Unmerge | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ParameterElement Class
Telerik.Reporting.Processing.Config Namespace


ReportingConfigurationSection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ReportingConfigurationSection Class Methods
See Also
[image]
Telerik.Reporting.Processing.Config Namespace : ReportingConfigurationSection Class

For a list of all members of this type, see ReportingConfigurationSection members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Configuration.ConfigurationElement)
Public Method | GetHashCode | (Inherited from System.Configuration.ConfigurationElement)
Public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
Protected Method | DeserializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | DeserializeSection | (Inherited from System.Configuration.ConfigurationSection)
Protected Method | GetRuntimeObject | (Inherited from System.Configuration.ConfigurationSection)
Protected Method | Init | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | InitializeDefault | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | IsModified | (Inherited from System.Configuration.ConfigurationSection)
Protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | ResetModified | (Inherited from System.Configuration.ConfigurationSection)
Protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SerializeSection | (Inherited from System.Configuration.ConfigurationSection)
Protected Method | SerializeToXmlElement | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | SetReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Protected Method | Unmerge | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ReportingConfigurationSection Class
Telerik.Reporting.Processing.Config Namespace


Telerik.Reporting.Processing.Config Namespace

Telerik.Reporting.Processing Send comments on this topic.
Telerik.Reporting.Processing.Config Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
ExtensionCollection |
ExtensionElement |
ExtensionsSection |
ParameterCollection |
ParameterElement |
ReportingConfigurationSection |

See Also

Reference

Telerik.Reporting.Processing Assembly


Telerik.Reporting.Processing.Config Namespace Inheritance Hierarchy

Telerik.Reporting.Processing Send comments on this topic.
Telerik.Reporting.Processing.Config Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.Configuration.ConfigurationElementCollection
Telerik.Reporting.Processing.Config.ExtensionCollection
Telerik.Reporting.Processing.Config.ParameterCollection
System.Configuration.ConfigurationSection
Telerik.Reporting.Processing.Config.ReportingConfigurationSection
Telerik.Reporting.Processing.Config.ExtensionElement
Telerik.Reporting.Processing.Config.ExtensionsSection
Telerik.Reporting.Processing.Config.ParameterElement

See Also

Reference

Telerik.Reporting.Processing Assembly


CreateStream Delegate

Telerik.Reporting.Processing Send comments on this topic.
CreateStream Delegate
See Also
[image]
Telerik.Reporting.Processing Namespace : CreateStream Delegate

name
extension
encoding
mimeType

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function CreateStream( _
   ByVal name As String, _
   ByVal extension As String, _
   ByVal encoding As Encoding, _
   ByVal mimeType As String _
) As Stream
Visual Basic (Usage) Copy Code
Dim instance As New CreateStream(AddressOf HandlerMethod)
C#
public delegate Stream CreateStream(
   string name,
   string extension,
   Encoding encoding,
   string mimeType
)

Parameters

name
extension
encoding
mimeType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Processing Namespace


DetailSection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
DetailSection Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : DetailSection Class

For a list of all members of this type, see DetailSection members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItemBase)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

DetailSection Class
Telerik.Reporting.Processing Namespace


DetailSection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
DetailSection Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : DetailSection Class

For a list of all members of this type, see DetailSection members.

Public Properties

 | Name | Description
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Height | (Inherited from ReportSectionBase)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | KeepTogether | (Inherited from ReportSection)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | PageBreak | (Inherited from ReportSection)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportSectionBase)
Top

See Also

Reference

DetailSection Class
Telerik.Reporting.Processing Namespace


EvaluateHeaderFooterExpressions Delegate

Telerik.Reporting.Processing Send comments on this topic.
EvaluateHeaderFooterExpressions Delegate
See Also
[image]
Telerik.Reporting.Processing Namespace : EvaluateHeaderFooterExpressions Delegate

pageNumber
pageCount
report

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub EvaluateHeaderFooterExpressions( _
   ByVal pageNumber As Integer, _
   ByVal pageCount As Integer, _
   ByVal report As Report _
)
Visual Basic (Usage) Copy Code
Dim instance As New EvaluateHeaderFooterExpressions(AddressOf HandlerMethod)
C#
public delegate void EvaluateHeaderFooterExpressions(
   int pageNumber,
   int pageCount,
   Report report
)

Parameters

pageNumber
pageCount
report

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Processing Namespace


GroupSection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
GroupSection Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : GroupSection Class

For a list of all members of this type, see GroupSection members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItemBase)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

GroupSection Class
Telerik.Reporting.Processing Namespace


InheritedWidthMeasurement Class Methods

Telerik.Reporting.Processing Send comments on this topic.
InheritedWidthMeasurement Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : InheritedWidthMeasurement Class

For a list of all members of this type, see InheritedWidthMeasurement members.

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from Measurements)
Top

See Also

Reference

InheritedWidthMeasurement Class
Telerik.Reporting.Processing Namespace


MeasureDirection Enumeration

Telerik.Reporting.Processing Send comments on this topic.
MeasureDirection Enumeration
See Also
[image]
Telerik.Reporting.Processing Namespace : MeasureDirection Enumeration

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Private Enum MeasureDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MeasureDirection
C#
private enum MeasureDirection : Enum

Members

Member | Description
Horizontal |
Vertical |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Processing.MeasureDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Processing Namespace


PageSection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
PageSection Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : PageSection Class

For a list of all members of this type, see PageSection members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItemBase)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

PageSection Class
Telerik.Reporting.Processing Namespace


Panel Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Panel Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : Panel Class

For a list of all members of this type, see Panel members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

Panel Class
Telerik.Reporting.Processing Namespace


Panel Class Properties

Telerik.Reporting.Processing Send comments on this topic.
Panel Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : Panel Class

For a list of all members of this type, see Panel members.

Public Properties

 | Name | Description
Public Property | Anchor | (Inherited from ReportItem)
Public Property | Bounds | (Inherited from ReportItem)
Public Property | DataItem | Gets or sets a data item that is bound to the report item. (Inherited from ReportItemBase)
Public Property | Dock | (Inherited from ReportItem)
Public Property | Height | (Inherited from ReportItem)
Public Property | ItemDefinition | (Inherited from ReportItemBase)
Public Property | Items | (Inherited from ReportItemBase)
Public Property | Left | (Inherited from ReportItem)
Public Property | Location | (Inherited from ReportItem)
Public Property | Name | (Inherited from ReportItemBase)
Public Property | Parent | (Inherited from ProcessingElement)
Public Property | Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement)
Public Property | Size | (Inherited from ReportItem)
Public Property | Style | (Inherited from ProcessingElement)
Public Property | Top | (Inherited from ReportItem)
Public Property | Visible | (Inherited from ProcessingElement)
Public Property | Width | (Inherited from ReportItem)
Top

See Also

Reference

Panel Class
Telerik.Reporting.Processing Namespace


ProcessingElement.ElementIndex Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.ElementIndex Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.ElementIndex Class

For a list of all members of this type, see ProcessingElement.ElementIndex members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | AddRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Find | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<Int32>)
Top

See Also

Reference

ProcessingElement.ElementIndex Class
Telerik.Reporting.Processing Namespace


ProcessingElement.ElementIndex Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.ElementIndex Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.ElementIndex Class

For a list of all members of this type, see ProcessingElement.ElementIndex members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<Int32>)
Public Property | Count | (Inherited from System.Collections.Generic.List<Int32>)
Public Property | Item | (Inherited from System.Collections.Generic.List<Int32>)
Top

See Also

Reference

ProcessingElement.ElementIndex Class
Telerik.Reporting.Processing Namespace


ProcessingElement.HorizontalIndex Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.HorizontalIndex Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.HorizontalIndex Class

For a list of all members of this type, see ProcessingElement.HorizontalIndex members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | AddRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Find | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<Int32>)
Top

See Also

Reference

ProcessingElement.HorizontalIndex Class
Telerik.Reporting.Processing Namespace


ProcessingElement.HorizontalIndex Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.HorizontalIndex Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.HorizontalIndex Class

For a list of all members of this type, see ProcessingElement.HorizontalIndex members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<Int32>)
Public Property | Count | (Inherited from System.Collections.Generic.List<Int32>)
Public Property | Item | (Inherited from System.Collections.Generic.List<Int32>)
Top

See Also

Reference

ProcessingElement.HorizontalIndex Class
Telerik.Reporting.Processing Namespace


ProcessingElement.ProcessingElementCollection Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.ProcessingElementCollection Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.ProcessingElementCollection Class

For a list of all members of this type, see ProcessingElement.ProcessingElementCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<ProcessingElement>)
Top

See Also

Reference

ProcessingElement.ProcessingElementCollection Class
Telerik.Reporting.Processing Namespace


ProcessingElement.ProcessingStyle Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.ProcessingStyle Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.ProcessingStyle Class

For a list of all members of this type, see ProcessingElement.ProcessingStyle members.

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from Telerik.Reporting.Drawing.StyleBase)
Protected Method | WriteXml | (Inherited from Telerik.Reporting.Drawing.StyleBase)
Top

See Also

Reference

ProcessingElement.ProcessingStyle Class
Telerik.Reporting.Processing Namespace


ProcessingElement.ProcessingStyle Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.ProcessingStyle Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.ProcessingStyle Class

For a list of all members of this type, see ProcessingElement.ProcessingStyle members.

Public Properties

 | Name | Description
Public Property | BackgroundColor | Gets or sets the background color of the report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | BackgroundImage | Gets a Telerik.Reporting.Drawing.BackgroundImage object that controls the image displayed in the background of the report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | BorderColor | Gets a Telerik.Reporting.Drawing.BorderColor object used to define the border color of a report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | BorderStyle | Gets a Telerik.Reporting.Drawing.BorderStyle object used to define the border style of a report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | BorderWidth | Gets a Telerik.Reporting.Drawing.BorderWidth object used to define the border width of a report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | Color | Gets or sets the foreground color of the report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | Font | Gets a Telerik.Reporting.Drawing.Font object representing the font of the report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | LineStyle | Gets or sets a Telerik.Reporting.Drawing.LineStyle object used to define the line style of report items that support it, such as lines and shapes. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | LineWidth | Gets or sets a Telerik.Reporting.Drawing.Unit representing the line width of report items that support it, such as lines and shapes. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | Padding | Gets a Telerik.Reporting.Drawing.Padding object used to define the padding of a report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | TextAlign | Gets or sets the horizontal alignment of text in the report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | VerticalAlign | Gets or sets the vertical alignment of text in the report item. (Inherited from Telerik.Reporting.Drawing.Style)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from Telerik.Reporting.Drawing.Style)
Top

Protected Properties

 | Name | Description
Protected Property | Styles | (Inherited from Telerik.Reporting.Drawing.Style)
Top

See Also

Reference

ProcessingElement.ProcessingStyle Class
Telerik.Reporting.Processing Namespace


ProcessingElement.VerticalIndex Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.VerticalIndex Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.VerticalIndex Class

For a list of all members of this type, see ProcessingElement.VerticalIndex members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | AddRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Find | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<Int32>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<Int32>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<Int32>)
Top

See Also

Reference

ProcessingElement.VerticalIndex Class
Telerik.Reporting.Processing Namespace


ProcessingElement.VerticalIndex Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ProcessingElement.VerticalIndex Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : ProcessingElement.VerticalIndex Class

For a list of all members of this type, see ProcessingElement.VerticalIndex members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<Int32>)
Public Property | Count | (Inherited from System.Collections.Generic.List<Int32>)
Public Property | Item | (Inherited from System.Collections.Generic.List<Int32>)
Top

See Also

Reference

ProcessingElement.VerticalIndex Class
Telerik.Reporting.Processing Namespace


ReportItemBase.ItemCollection.ReadOnlyCollectionException Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ReportItemBase.ItemCollection.ReadOnlyCollectionException Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ReportItemBase.ItemCollection.ReadOnlyCollectionException Class

For a list of all members of this type, see ReportItemBase.ItemCollection.ReadOnlyCollectionException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ReportItemBase.ItemCollection.ReadOnlyCollectionException Class
Telerik.Reporting.Processing Namespace


ReportItemBase.ItemCollection.ReadOnlyCollectionException Class Properties

Telerik.Reporting.Processing Send comments on this topic.
ReportItemBase.ItemCollection.ReadOnlyCollectionException Class Properties
See Also
[image]
Telerik.Reporting.Processing Namespace : ReportItemBase.ItemCollection.ReadOnlyCollectionException Class

For a list of all members of this type, see ReportItemBase.ItemCollection.ReadOnlyCollectionException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

ReportItemBase.ItemCollection.ReadOnlyCollectionException Class
Telerik.Reporting.Processing Namespace


Telerik.Reporting.Processing.ReportParameters Namespace

Telerik.Reporting.Processing Send comments on this topic.
Telerik.Reporting.Processing.ReportParameters Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
ReportParametersManager.Parameter |
ReportParametersManager.ParameterCollection |

Interfaces

Interface | Description
IReportParameterEditor | Represents an control that serves as editor shown on from the report viewer to allow entering of values of a parameter.
IReportParameterEditorContext | Represents object that keeps the UI settings foar a parameter and is used to initialize a parameter editor

See Also

Reference

Telerik.Reporting.Processing Assembly


Telerik.Reporting.Processing.ReportParameters Namespace Inheritance Hierarchy

Telerik.Reporting.Processing Send comments on this topic.
Telerik.Reporting.Processing.ReportParameters Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<ReportParametersManager.Parameter>
Telerik.Reporting.Processing.ReportParameters.ReportParametersManager.ParameterCollection
Telerik.Reporting.Processing.ReportParameters.ReportParametersManager.Parameter

See Also

Reference

Telerik.Reporting.Processing Assembly


ReportSection Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ReportSection Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ReportSection Class

For a list of all members of this type, see ReportSection members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItemBase)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

ReportSection Class
Telerik.Reporting.Processing Namespace


ReportSectionBase Class Methods

Telerik.Reporting.Processing Send comments on this topic.
ReportSectionBase Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : ReportSectionBase Class

For a list of all members of this type, see ReportSectionBase members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItemBase)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

ReportSectionBase Class
Telerik.Reporting.Processing Namespace


Shape Class Methods

Telerik.Reporting.Processing Send comments on this topic.
Shape Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : Shape Class

For a list of all members of this type, see Shape members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

Shape Class
Telerik.Reporting.Processing Namespace


TextItemBase Class Methods

Telerik.Reporting.Processing Send comments on this topic.
TextItemBase Class Methods
See Also
[image]
Telerik.Reporting.Processing Namespace : TextItemBase Class

For a list of all members of this type, see TextItemBase members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ReportItemBase)
Public Method | InitializeItem | (Inherited from ReportItemBase)
Public Method | ToString | (Inherited from ProcessingElement)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ReportItemBase)
Protected Method | OnElementAdded | (Inherited from ProcessingElement)
Protected Method | OnElementRemoved | (Inherited from ProcessingElement)
Protected Method | OnItemProcessed | (Inherited from ReportItem)
Protected Method | OnItemProcessing | (Inherited from ReportItemBase)
Protected Method | ProcessItem | (Inherited from ReportItemBase)
Top

See Also

Reference

TextItemBase Class
Telerik.Reporting.Processing Namespace


Telerik.Reporting.Processing Namespace (Telerik.Reporting.Processing)

Telerik.Reporting.Processing Send comments on this topic.
Telerik.Reporting.Processing Namespace (Telerik.Reporting.Processing)
See Also Inheritance Hierarchy

Classes

Class | Description
Barcode |
BarcodeHelper |
Chart | Summary description for ReportItem class.
CheckBox | CheckBox
CheckBoxUtil | CheckBoxUtil
DetailSection |
Group |
GroupSection |
InheritedWidthMeasurement | Inherits the width from the owner's parent
Measurements |
PageSection |
Panel |
PictureBox |
PictureBoxUtil |
ProcessingElement |
ProcessingElement.ElementIndex | List of the indexes of items in the elements collection
ProcessingElement.HorizontalIndex | List of the indexes of the elements ordered by x-position
ProcessingElement.ProcessingElementCollection |
ProcessingElement.ProcessingStyle |
ProcessingElement.VerticalIndex | List of the indexes of the elements ordered by y-position
RenderingDefaults |
Report |
ReportItem |
ReportItemBase |
ReportItemBase.ItemCollection |
ReportItemBase.ItemCollection.ReadOnlyCollectionException |
ReportProcessor |
ReportSection |
ReportSectionBase |
Shape |
Stopwatch |
SubReport |
TextBox | Base class for TextBox and CheckBox classes
TextBoxUtil |
TextItemBase | Base class for TextBox and CheckBox classes

Interfaces

Interface | Description
IRenderingExtension |
IRenderStream | Provides support for rendering multiple streams from a rendering extension.

Delegates

Delegate | Description
CreateStream |
EvaluateHeaderFooterExpressions |

Enumerations

Enumeration | Description
MeasureDirection |

See Also

Reference

Telerik.Reporting.Processing Assembly


Telerik.Reporting.Processing Namespace (Telerik.Reporting.Processing) Inheritance Hierarchy

Telerik.Reporting.Processing Send comments on this topic.
Telerik.Reporting.Processing Namespace (Telerik.Reporting.Processing) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<Int32>
Telerik.Reporting.Processing.ProcessingElement.ElementIndex
Telerik.Reporting.Processing.ProcessingElement.HorizontalIndex
Telerik.Reporting.Processing.ProcessingElement.VerticalIndex
System.Collections.ObjectModel.Collection<ProcessingElement>
Telerik.Reporting.Processing.ProcessingElement.ProcessingElementCollection
System.Exception
System.SystemException
System.Data.DataException
System.Data.ReadOnlyException
Telerik.Reporting.Processing.ReportItemBase.ItemCollection.ReadOnlyCollectionException
Telerik.Reporting.Drawing.StyleBase
Telerik.Reporting.Drawing.Style
Telerik.Reporting.Processing.ProcessingElement.ProcessingStyle
Telerik.Reporting.Processing.BarcodeHelper
Telerik.Reporting.Processing.CheckBoxUtil
Telerik.Reporting.Processing.Measurements
Telerik.Reporting.Processing.InheritedWidthMeasurement
Telerik.Reporting.Processing.PictureBoxUtil
Telerik.Reporting.Processing.ProcessingElement
Telerik.Reporting.Processing.Group
Telerik.Reporting.Processing.ReportItemBase
Telerik.Reporting.Processing.Report
Telerik.Reporting.Processing.ReportItem
Telerik.Reporting.Processing.Barcode
Telerik.Reporting.Processing.Chart
Telerik.Reporting.Processing.Panel
Telerik.Reporting.Processing.PictureBox
Telerik.Reporting.Processing.Shape
Telerik.Reporting.Processing.SubReport
Telerik.Reporting.Processing.TextItemBase
Telerik.Reporting.Processing.CheckBox
Telerik.Reporting.Processing.TextBox
Telerik.Reporting.Processing.ReportSectionBase
Telerik.Reporting.Processing.PageSection
Telerik.Reporting.Processing.ReportSection
Telerik.Reporting.Processing.DetailSection
Telerik.Reporting.Processing.GroupSection
Telerik.Reporting.Processing.RenderingDefaults
Telerik.Reporting.Processing.ReportItemBase.ItemCollection
Telerik.Reporting.Processing.ReportProcessor
Telerik.Reporting.Processing.Stopwatch
Telerik.Reporting.Processing.TextBoxUtil

See Also

Reference

Telerik.Reporting.Processing Assembly


Barcode Class Fields

Telerik.Reporting.Processing Send comments on this topic.
Barcode Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

Barcode Class
Telerik.Reporting.RtfRendering Namespace


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As Barcode

instance.BeginRender()
C#
protected virtual void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


CreateMetafile Method

Telerik.Reporting.Processing Send comments on this topic.
CreateMetafile Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : CreateMetafile Method

size

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function CreateMetafile( _
   ByVal size As SizeF _
) As Image
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim size As SizeF
Dim value As Image

value = instance.CreateMetafile(size)
C#
protected Image CreateMetafile(
   SizeF size
)

Parameters

size

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As Barcode

instance.EndRender()
C#
protected virtual void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As Barcode

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Barcode Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


CanvasRtf Class Fields

Telerik.Reporting.Processing Send comments on this topic.
CanvasRtf Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : CanvasRtf Class

For a list of all members of this type, see CanvasRtf members.

Public Fields

 | Name | Description
Public Field | composition | (Inherited from Telerik.Reporting.ImageRendering.CanvasBase)
Top

Protected Fields

 | Name | Description
Protected Field | graphics | (Inherited from Telerik.Reporting.ImageRendering.CanvasBase)
Top

See Also

Reference

CanvasRtf Class
Telerik.Reporting.RtfRendering Namespace


composition Field

Telerik.Reporting.Processing Send comments on this topic.
composition Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : composition Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim value As CompositionBase

value = instance.composition

instance.composition = value
C#
public CompositionBase composition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


DrawBackgroundImage Method

Telerik.Reporting.Processing Send comments on this topic.
DrawBackgroundImage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : DrawBackgroundImage Method

bitmap
destRect
repeat

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub DrawBackgroundImage( _
   ByVal bitmap As Image, _
   ByVal destRect As RectangleF, _
   ByVal repeat As BackgroundRepeat _
)
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim bitmap As Image
Dim destRect As RectangleF
Dim repeat As BackgroundRepeat

instance.DrawBackgroundImage(bitmap, destRect, repeat)
C#
protected void DrawBackgroundImage(
   Image bitmap,
   RectangleF destRect,
   BackgroundRepeat repeat
)

Parameters

bitmap
destRect
repeat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


DrawImage(Image,RectangleF,ImageSizeMode) Method

Telerik.Reporting.Processing Send comments on this topic.
DrawImage(Image,RectangleF,ImageSizeMode) Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class > DrawImage Method : DrawImage(Image,RectangleF,ImageSizeMode) Method

bitmap
destRect
sizing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Sub DrawImage( _
   ByVal bitmap As Image, _
   ByVal destRect As RectangleF, _
   ByVal sizing As ImageSizeMode _
)
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim bitmap As Image
Dim destRect As RectangleF
Dim sizing As ImageSizeMode

instance.DrawImage(bitmap, destRect, sizing)
C#
protected void DrawImage(
   Image bitmap,
   RectangleF destRect,
   ImageSizeMode sizing
)

Parameters

bitmap
destRect
sizing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members
Overload List


graphics Field

Telerik.Reporting.Processing Send comments on this topic.
graphics Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CanvasRtf Class : graphics Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected graphics As Graphics
Visual Basic (Usage) Copy Code
Dim instance As CanvasRtf
Dim value As Graphics

value = instance.graphics

instance.graphics = value
C#
protected Graphics graphics

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CanvasRtf Class
CanvasRtf Members


Chart Class Fields

Telerik.Reporting.Processing Send comments on this topic.
Chart Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Chart Class

For a list of all members of this type, see Chart members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

Chart Class
Telerik.Reporting.RtfRendering Namespace


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As Chart

instance.BeginRender()
C#
protected virtual void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As Chart

instance.EndRender()
C#
protected virtual void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As Chart

instance.Init()
C#
public virtual void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As Chart

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Chart Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Chart Class
Chart Members


CheckBox Class Fields

Telerik.Reporting.Processing Send comments on this topic.
CheckBox Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

CheckBox Class
Telerik.Reporting.RtfRendering Namespace


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As CheckBox

instance.Init()
C#
public virtual void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As CheckBox

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CheckBox Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CheckBox Class
CheckBox Members


CompositionRtf Class Fields

Telerik.Reporting.Processing Send comments on this topic.
CompositionRtf Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : CompositionRtf Class

For a list of all members of this type, see CompositionRtf members.

Public Fields

 | Name | Description
Public Field | CurrentVertPosition | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Top

Protected Fields

 | Name | Description
Protected Field | currentColumnIndex | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Protected Field | pageEmpty | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Protected Field | pageSaved | (Inherited from Telerik.Reporting.ImageRendering.CompositionBase)
Top

See Also

Reference

CompositionRtf Class
Telerik.Reporting.RtfRendering Namespace


Canvas Property

Telerik.Reporting.Processing Send comments on this topic.
Canvas Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : Canvas Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Property Canvas As CanvasBase
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As CanvasBase

instance.Canvas = value

value = instance.Canvas
C#
protected CanvasBase Canvas {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


CreateStream Method

Telerik.Reporting.Processing Send comments on this topic.
CreateStream Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : CreateStream Method

name
extension
encoding
mimeType

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function CreateStream( _
   ByVal name As String, _
   ByVal extension As String, _
   ByVal encoding As Encoding, _
   ByVal mimeType As String _
) As Stream
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim name As String
Dim extension As String
Dim encoding As Encoding
Dim mimeType As String
Dim value As Stream

value = instance.CreateStream(name, extension, encoding, mimeType)
C#
protected Stream CreateStream(
   string name,
   string extension,
   Encoding encoding,
   string mimeType
)

Parameters

name
extension
encoding
mimeType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


CurrentBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : CurrentBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property CurrentBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As RoundedFloat

instance.CurrentBottom = value

value = instance.CurrentBottom
C#
public RoundedFloat CurrentBottom {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


currentColumnIndex Field

Telerik.Reporting.Processing Send comments on this topic.
currentColumnIndex Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : currentColumnIndex Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected currentColumnIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As Integer

value = instance.currentColumnIndex

instance.currentColumnIndex = value
C#
protected int currentColumnIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


CurrentHeight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentHeight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : CurrentHeight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentHeight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As RoundedFloat

value = instance.CurrentHeight
C#
public RoundedFloat CurrentHeight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


CurrentLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : CurrentLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property CurrentLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As RoundedFloat

instance.CurrentLeft = value

value = instance.CurrentLeft
C#
public RoundedFloat CurrentLeft {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


CurrentRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : CurrentRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As RoundedFloat

value = instance.CurrentRight
C#
public RoundedFloat CurrentRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


CurrentTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : CurrentTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property CurrentTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As RoundedFloat

instance.CurrentTop = value

value = instance.CurrentTop
C#
public RoundedFloat CurrentTop {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


CurrentVertPosition Field

Telerik.Reporting.Processing Send comments on this topic.
CurrentVertPosition Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : CurrentVertPosition Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public CurrentVertPosition As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As RoundedFloat

value = instance.CurrentVertPosition

instance.CurrentVertPosition = value
C#
public RoundedFloat CurrentVertPosition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


CurrentWidth Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentWidth Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : CurrentWidth Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentWidth As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As RoundedFloat

value = instance.CurrentWidth
C#
public RoundedFloat CurrentWidth {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


MarkPageNonEmpty Method

Telerik.Reporting.Processing Send comments on this topic.
MarkPageNonEmpty Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : MarkPageNonEmpty Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub MarkPageNonEmpty()
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf

instance.MarkPageNonEmpty()
C#
public void MarkPageNonEmpty()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


pageEmpty Field

Telerik.Reporting.Processing Send comments on this topic.
pageEmpty Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : pageEmpty Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected pageEmpty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As Boolean

value = instance.pageEmpty

instance.pageEmpty = value
C#
protected bool pageEmpty

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


PageNumber Property

Telerik.Reporting.Processing Send comments on this topic.
PageNumber Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : PageNumber Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As Integer

value = instance.PageNumber
C#
public int PageNumber {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


pageSaved Field

Telerik.Reporting.Processing Send comments on this topic.
pageSaved Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : pageSaved Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected pageSaved As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As Boolean

value = instance.pageSaved

instance.pageSaved = value
C#
protected bool pageSaved

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


SendPhysicalPages Method

Telerik.Reporting.Processing Send comments on this topic.
SendPhysicalPages Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : SendPhysicalPages Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SendPhysicalPages()
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf

instance.SendPhysicalPages()
C#
protected virtual void SendPhysicalPages()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > CompositionRtf Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As CompositionRtf
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CompositionRtf Class
CompositionRtf Members


DetailSection Class Fields

Telerik.Reporting.Processing Send comments on this topic.
DetailSection Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : DetailSection Class

For a list of all members of this type, see DetailSection members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

DetailSection Class
Telerik.Reporting.RtfRendering Namespace


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As DetailSection

instance.BeginRender()
C#
protected virtual void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As DetailSection

instance.EndRender()
C#
protected virtual void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As DetailSection

instance.Init()
C#
public virtual void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As DetailSection

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


ShouldKeepTogether Property

Telerik.Reporting.Processing Send comments on this topic.
ShouldKeepTogether Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : ShouldKeepTogether Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShouldKeepTogether As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As Boolean

value = instance.ShouldKeepTogether
C#
public bool ShouldKeepTogether {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > DetailSection Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As DetailSection
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DetailSection Class
DetailSection Members


Group Class Fields

Telerik.Reporting.Processing Send comments on this topic.
Group Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Group Class

For a list of all members of this type, see Group members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

Group Class
Telerik.Reporting.RtfRendering Namespace


GroupSection Class Fields

Telerik.Reporting.Processing Send comments on this topic.
GroupSection Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : GroupSection Class

For a list of all members of this type, see GroupSection members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

GroupSection Class
Telerik.Reporting.RtfRendering Namespace


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As GroupSection

instance.BeginRender()
C#
protected virtual void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As GroupSection

instance.EndRender()
C#
protected virtual void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As GroupSection

instance.Init()
C#
public virtual void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


PrintOnEveryPage Property

Telerik.Reporting.Processing Send comments on this topic.
PrintOnEveryPage Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : PrintOnEveryPage Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintOnEveryPage As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As Boolean

value = instance.PrintOnEveryPage
C#
public bool PrintOnEveryPage {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As GroupSection

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


ShouldKeepTogether Property

Telerik.Reporting.Processing Send comments on this topic.
ShouldKeepTogether Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : ShouldKeepTogether Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShouldKeepTogether As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As Boolean

value = instance.ShouldKeepTogether
C#
public bool ShouldKeepTogether {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > GroupSection Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As GroupSection
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GroupSection Class
GroupSection Members


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As Group

instance.BeginRender()
C#
protected virtual void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As Group

instance.EndRender()
C#
protected virtual void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Footer Property

Telerik.Reporting.Processing Send comments on this topic.
Footer Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Footer Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Footer As GroupSection
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As GroupSection

value = instance.Footer
C#
public GroupSection Footer {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Header Property

Telerik.Reporting.Processing Send comments on this topic.
Header Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Header Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Header As GroupSection
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As GroupSection

value = instance.Header
C#
public GroupSection Header {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As Group

instance.Init()
C#
public virtual void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As Group

instance.Render()
C#
protected virtual void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As Group

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Group Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Group
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Group Class
Group Members


PageSection Class Fields

Telerik.Reporting.Processing Send comments on this topic.
PageSection Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : PageSection Class

For a list of all members of this type, see PageSection members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

PageSection Class
Telerik.Reporting.RtfRendering Namespace


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As PageSection

instance.BeginRender()
C#
protected virtual void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As PageSection

instance.EndRender()
C#
protected virtual void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As PageSection

instance.Init()
C#
public virtual void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As PageSection

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


ShouldKeepTogether Property

Telerik.Reporting.Processing Send comments on this topic.
ShouldKeepTogether Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : ShouldKeepTogether Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShouldKeepTogether As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As Boolean

value = instance.ShouldKeepTogether
C#
public bool ShouldKeepTogether {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PageSection Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PageSection
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PageSection Class
PageSection Members


Panel Class Fields

Telerik.Reporting.Processing Send comments on this topic.
Panel Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Panel Class

For a list of all members of this type, see Panel members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

Panel Class
Telerik.Reporting.RtfRendering Namespace


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As Panel

instance.BeginRender()
C#
protected virtual void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As Panel

instance.EndRender()
C#
protected virtual void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As Panel

instance.Init()
C#
public virtual void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As Panel

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Panel Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Panel Class
Panel Members


PictureBox Class Fields

Telerik.Reporting.Processing Send comments on this topic.
PictureBox Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : PictureBox Class

For a list of all members of this type, see PictureBox members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

PictureBox Class
Telerik.Reporting.RtfRendering Namespace


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As PictureBox

instance.BeginRender()
C#
protected virtual void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As PictureBox

instance.EndRender()
C#
protected virtual void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As PictureBox

instance.Init()
C#
public virtual void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As PictureBox

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > PictureBox Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PictureBox Class
PictureBox Members


Report Class Fields

Telerik.Reporting.Processing Send comments on this topic.
Report Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Report Class

For a list of all members of this type, see Report members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

Report Class
Telerik.Reporting.RtfRendering Namespace


ReportSection Class Fields

Telerik.Reporting.Processing Send comments on this topic.
ReportSection Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : ReportSection Class

For a list of all members of this type, see ReportSection members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

ReportSection Class
Telerik.Reporting.RtfRendering Namespace


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As ReportSection

instance.BeginRender()
C#
protected virtual void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As ReportSection

instance.EndRender()
C#
protected virtual void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As ReportSection

instance.Init()
C#
public virtual void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As ReportSection

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ShouldKeepTogether Property

Telerik.Reporting.Processing Send comments on this topic.
ShouldKeepTogether Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : ShouldKeepTogether Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShouldKeepTogether As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As Boolean

value = instance.ShouldKeepTogether
C#
public bool ShouldKeepTogether {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > ReportSection Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As ReportSection
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ReportSection Class
ReportSection Members


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As Report

instance.BeginRender()
C#
protected virtual void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As Report

instance.EndRender()
C#
protected virtual void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As Report

instance.Init()
C#
public virtual void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Render Method

Telerik.Reporting.Processing Send comments on this topic.
Render Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Render Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Render()
Visual Basic (Usage) Copy Code
Dim instance As Report

instance.Render()
C#
protected virtual void Render()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As Report

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Report Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Report
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Report Class
Report Members


Shape Class Fields

Telerik.Reporting.Processing Send comments on this topic.
Shape Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : Shape Class

For a list of all members of this type, see Shape members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

Shape Class
Telerik.Reporting.RtfRendering Namespace


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As Shape

instance.BeginRender()
C#
protected virtual void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As Shape

instance.EndRender()
C#
protected virtual void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As Shape

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > Shape Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As Shape
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Shape Class
Shape Members


SubReport Class Fields

Telerik.Reporting.Processing Send comments on this topic.
SubReport Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : SubReport Class

For a list of all members of this type, see SubReport members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

SubReport Class
Telerik.Reporting.RtfRendering Namespace


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As SubReport

instance.BeginRender()
C#
protected virtual void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As SubReport

instance.EndRender()
C#
protected virtual void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As SubReport

instance.Init()
C#
public virtual void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As SubReport

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > SubReport Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As SubReport
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SubReport Class
SubReport Members


TextBox Class Fields

Telerik.Reporting.Processing Send comments on this topic.
TextBox Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

TextBox Class
Telerik.Reporting.RtfRendering Namespace


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As TextBox

instance.Init()
C#
public virtual void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As TextBox

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextBox Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


TextLine Class Fields

Telerik.Reporting.Processing Send comments on this topic.
TextLine Class Fields
See Also
[image]
Telerik.Reporting.RtfRendering Namespace : TextLine Class

For a list of all members of this type, see TextLine members.

Protected Fields

 | Name | Description
Protected Field | offsetY | (Inherited from Telerik.Reporting.ImageRendering.RenderingElement)
Top

See Also

Reference

TextLine Class
Telerik.Reporting.RtfRendering Namespace


AbsoluteBottom Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : AbsoluteBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.AbsoluteBottom
C#
public RoundedFloat AbsoluteBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


AbsoluteBounds Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteBounds Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : AbsoluteBounds Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteBounds As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RectangleRF

value = instance.AbsoluteBounds
C#
public RectangleRF AbsoluteBounds {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


AbsoluteLeft Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : AbsoluteLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.AbsoluteLeft
C#
public RoundedFloat AbsoluteLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


AbsoluteRight Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : AbsoluteRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.AbsoluteRight
C#
public RoundedFloat AbsoluteRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


AbsoluteTop Property

Telerik.Reporting.Processing Send comments on this topic.
AbsoluteTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : AbsoluteTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbsoluteTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.AbsoluteTop
C#
public RoundedFloat AbsoluteTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


BeginRender Method

Telerik.Reporting.Processing Send comments on this topic.
BeginRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : BeginRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginRender()
Visual Basic (Usage) Copy Code
Dim instance As TextLine

instance.BeginRender()
C#
protected virtual void BeginRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Bottom Property

Telerik.Reporting.Processing Send comments on this topic.
Bottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Bottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.Bottom
C#
public RoundedFloat Bottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


CalculateElement Method

Telerik.Reporting.Processing Send comments on this topic.
CalculateElement Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : CalculateElement Method

orientation
maxDistance

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CalculateElement( _
   ByVal orientation As Orientation, _
   ByVal maxDistance As RoundedFloat _
)
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim orientation As Orientation
Dim maxDistance As RoundedFloat

instance.CalculateElement(orientation, maxDistance)
C#
protected virtual void CalculateElement(
   Orientation orientation,
   RoundedFloat maxDistance
)

Parameters

orientation
maxDistance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


CalculatePage Method

Telerik.Reporting.Processing Send comments on this topic.
CalculatePage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : CalculatePage Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculatePage( _
   ByVal orientation As Orientation _
)
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim orientation As Orientation

instance.CalculatePage(orientation)
C#
public void CalculatePage(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


ClientRectangle Property

Telerik.Reporting.Processing Send comments on this topic.
ClientRectangle Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : ClientRectangle Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientRectangle As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RectangleRF

value = instance.ClientRectangle
C#
public RectangleRF ClientRectangle {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


ClientSize Property

Telerik.Reporting.Processing Send comments on this topic.
ClientSize Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : ClientSize Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSize As SizeRF
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As SizeRF

value = instance.ClientSize
C#
public SizeRF ClientSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


ClipToPage Method

Telerik.Reporting.Processing Send comments on this topic.
ClipToPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : ClipToPage Method

rect

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function ClipToPage( _
   ByVal rect As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim rect As RectangleRF
Dim value As RectangleRF

value = instance.ClipToPage(rect)
C#
public RectangleRF ClipToPage(
   RectangleRF rect
)

Parameters

rect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Composition Property

Telerik.Reporting.Processing Send comments on this topic.
Composition Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Composition Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Composition As CompositionBase
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As CompositionBase

value = instance.Composition
C#
public CompositionBase Composition {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


CurrentPageBottom Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : CurrentPageBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.CurrentPageBottom
C#
protected RoundedFloat CurrentPageBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


CurrentPageLeft Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : CurrentPageLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.CurrentPageLeft
C#
protected RoundedFloat CurrentPageLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


CurrentPageRight Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : CurrentPageRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.CurrentPageRight
C#
protected RoundedFloat CurrentPageRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


CurrentPageTop Property

Telerik.Reporting.Processing Send comments on this topic.
CurrentPageTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : CurrentPageTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CurrentPageTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.CurrentPageTop
C#
protected RoundedFloat CurrentPageTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Dispose Method

Telerik.Reporting.Processing Send comments on this topic.
Dispose Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Dispose Method

disposing

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Done Property

Telerik.Reporting.Processing Send comments on this topic.
Done Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Done Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Done As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As Boolean

value = instance.Done
C#
public virtual bool Done {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


EndRender Method

Telerik.Reporting.Processing Send comments on this topic.
EndRender Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : EndRender Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndRender()
Visual Basic (Usage) Copy Code
Dim instance As TextLine

instance.EndRender()
C#
protected virtual void EndRender()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


EnumParents Method

Telerik.Reporting.Processing Send comments on this topic.
EnumParents Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : EnumParents Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function EnumParents() As IEnumerable(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As IEnumerable(Of RenderingElement)

value = instance.EnumParents()
C#
protected IEnumerable<RenderingElement> EnumParents()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


HasError Property

Telerik.Reporting.Processing Send comments on this topic.
HasError Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : HasError Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As Boolean

value = instance.HasError
C#
public bool HasError {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Height Property

Telerik.Reporting.Processing Send comments on this topic.
Height Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Height Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

instance.Height = value

value = instance.Height
C#
public RoundedFloat Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Init Method

Telerik.Reporting.Processing Send comments on this topic.
Init Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Init Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Init()
Visual Basic (Usage) Copy Code
Dim instance As TextLine

instance.Init()
C#
public virtual void Init()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Items Property

Telerik.Reporting.Processing Send comments on this topic.
Items Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Items Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RenderingElement)
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As IList(Of RenderingElement)

value = instance.Items
C#
public IList<RenderingElement> Items {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


ItemsAbove Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsAbove Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : ItemsAbove Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemsAbove As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As List(Of Integer)

value = instance.ItemsAbove
C#
public List<int> ItemsAbove {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


ItemsVertIndex Property

Telerik.Reporting.Processing Send comments on this topic.
ItemsVertIndex Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : ItemsVertIndex Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ItemsVertIndex As List(Of Integer)
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As List(Of Integer)

value = instance.ItemsVertIndex
C#
protected List<int> ItemsVertIndex {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


KeepTogether Method

Telerik.Reporting.Processing Send comments on this topic.
KeepTogether Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : KeepTogether Method

orientation

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeepTogether( _
   ByVal orientation As Orientation _
) As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim orientation As Orientation
Dim value As RoundedFloat

value = instance.KeepTogether(orientation)
C#
protected virtual RoundedFloat KeepTogether(
   Orientation orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Left Property

Telerik.Reporting.Processing Send comments on this topic.
Left Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Left Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

instance.Left = value

value = instance.Left
C#
public RoundedFloat Left {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


MoveToLeftOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToLeftOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : MoveToLeftOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToLeftOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.MoveToLeftOfNextPage()
C#
protected RoundedFloat MoveToLeftOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


MoveToTopOfNextPage Method

Telerik.Reporting.Processing Send comments on this topic.
MoveToTopOfNextPage Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : MoveToTopOfNextPage Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Function MoveToTopOfNextPage() As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.MoveToTopOfNextPage()
C#
protected RoundedFloat MoveToTopOfNextPage()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Name Property

Telerik.Reporting.Processing Send comments on this topic.
Name Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Name Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


offsetY Field

Telerik.Reporting.Processing Send comments on this topic.
offsetY Field
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : offsetY Field

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected offsetY As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.offsetY

instance.offsetY = value
C#
protected RoundedFloat offsetY

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


PadBottom Property

Telerik.Reporting.Processing Send comments on this topic.
PadBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : PadBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadBottom As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.PadBottom
C#
public RoundedFloat PadBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


PadLeft Property

Telerik.Reporting.Processing Send comments on this topic.
PadLeft Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : PadLeft Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadLeft As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.PadLeft
C#
public RoundedFloat PadLeft {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


PadRight Property

Telerik.Reporting.Processing Send comments on this topic.
PadRight Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : PadRight Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadRight As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.PadRight
C#
public RoundedFloat PadRight {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


PadTop Property

Telerik.Reporting.Processing Send comments on this topic.
PadTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : PadTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PadTop As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.PadTop
C#
public RoundedFloat PadTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


PageBreak Property

Telerik.Reporting.Processing Send comments on this topic.
PageBreak Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : PageBreak Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PageBreak As PageBreak
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As PageBreak

value = instance.PageBreak
C#
public virtual PageBreak PageBreak {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Parent Property

Telerik.Reporting.Processing Send comments on this topic.
Parent Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Parent Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As RenderingElement
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RenderingElement

value = instance.Parent
C#
public RenderingElement Parent {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


RectangleToAbsolute Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToAbsolute Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : RectangleToAbsolute Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToAbsolute( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToAbsolute(rc)
C#
public RectangleRF RectangleToAbsolute(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


RectangleToClient Method

Telerik.Reporting.Processing Send comments on this topic.
RectangleToClient Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : RectangleToClient Method

rc

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal rc As RectangleRF _
) As RectangleRF
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim rc As RectangleRF
Dim value As RectangleRF

value = instance.RectangleToClient(rc)
C#
public RectangleRF RectangleToClient(
   RectangleRF rc
)

Parameters

rc

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


RenderBackground Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBackground Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : RenderBackground Method

bounds

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBackground( _
   ByVal bounds As RectangleRF _
)
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim bounds As RectangleRF

instance.RenderBackground(bounds)
C#
protected void RenderBackground(
   RectangleRF bounds
)

Parameters

bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


RenderBorder Method

Telerik.Reporting.Processing Send comments on this topic.
RenderBorder Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : RenderBorder Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderBorder()
Visual Basic (Usage) Copy Code
Dim instance As TextLine

instance.RenderBorder()
C#
protected void RenderBorder()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


RenderError Method

Telerik.Reporting.Processing Send comments on this topic.
RenderError Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : RenderError Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderError()
Visual Basic (Usage) Copy Code
Dim instance As TextLine

instance.RenderError()
C#
protected virtual void RenderError()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


ReservedBottom Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottom Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : ReservedBottom Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedBottom As Single
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As Single

value = instance.ReservedBottom
C#
protected virtual float ReservedBottom {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


ReservedBottomSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedBottomSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : ReservedBottomSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedBottomSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.ReservedBottomSpace
C#
public RoundedFloat ReservedBottomSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


ReservedTop Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTop Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : ReservedTop Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReservedTop As Single
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As Single

value = instance.ReservedTop
C#
protected virtual float ReservedTop {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


ReservedTopSpace Property

Telerik.Reporting.Processing Send comments on this topic.
ReservedTopSpace Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : ReservedTopSpace Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedTopSpace As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.ReservedTopSpace
C#
public RoundedFloat ReservedTopSpace {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Right Property

Telerik.Reporting.Processing Send comments on this topic.
Right Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Right Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

value = instance.Right
C#
public RoundedFloat Right {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Source Property

Telerik.Reporting.Processing Send comments on this topic.
Source Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Source Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Source As ProcessingElement
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As ProcessingElement

value = instance.Source
C#
protected ProcessingElement Source {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Style Property

Telerik.Reporting.Processing Send comments on this topic.
Style Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Style Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As Style

value = instance.Style
C#
public Style Style {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Text Property

Telerik.Reporting.Processing Send comments on this topic.
Text Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Text Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As String

value = instance.Text
C#
protected string Text {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Top Property

Telerik.Reporting.Processing Send comments on this topic.
Top Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Top Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

instance.Top = value

value = instance.Top
C#
public RoundedFloat Top {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


ToString Method

Telerik.Reporting.Processing Send comments on this topic.
ToString Method
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : ToString Method

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Visible Property

Telerik.Reporting.Processing Send comments on this topic.
Visible Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Visible Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Width Property

Telerik.Reporting.Processing Send comments on this topic.
Width Property
See Also
[image]
Telerik.Reporting.RtfRendering Namespace > TextLine Class : Width Property

Namespace: Telerik.Reporting.RtfRendering
Assembly: Telerik.Reporting.Processing (in Telerik.Reporting.Processing.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As RoundedFloat
Visual Basic (Usage) Copy Code
Dim instance As TextLine
Dim value As RoundedFloat

instance.Width = value

value = instance.Width
C#
public RoundedFloat Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextLine Class
TextLine Members


Telerik.Reporting.RtfRendering Namespace

Telerik.Reporting.Processing Send comments on this topic.
Telerik.Reporting.RtfRendering Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
Barcode |
CanvasRtf |
Chart |
CheckBox |
CompositionRtf |
DetailSection |
Group |
GroupSection |
PageSection |
Panel |
PictureBox |
Report |
ReportSection |
RtfReport |
Shape |
SubReport |
TextBox |
TextLine |

Interfaces

Interface | Description
INoBackground |
ITextBuilder |

See Also

Reference

Telerik.Reporting.Processing Assembly


Telerik.Reporting.RtfRendering Namespace Inheritance Hierarchy

Telerik.Reporting.Processing Send comments on this topic.
Telerik.Reporting.RtfRendering Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
Telerik.Reporting.ImageRendering.CanvasBase
Telerik.Reporting.RtfRendering.CanvasRtf
Telerik.Reporting.ImageRendering.CompositionBase
Telerik.Reporting.RtfRendering.CompositionRtf
Telerik.Reporting.ImageRendering.ImageRendererBase
Telerik.Reporting.RtfRendering.RtfReport
Telerik.Reporting.ImageRendering.RenderingElement
Telerik.Reporting.ImageRendering.Group
Telerik.Reporting.RtfRendering.Group
Telerik.Reporting.ImageRendering.RenderingItem
Telerik.Reporting.ImageRendering.Report
Telerik.Reporting.RtfRendering.Report
Telerik.Reporting.ImageRendering.ReportItem
Telerik.Reporting.ImageRendering.Barcode
Telerik.Reporting.RtfRendering.Barcode
Telerik.Reporting.ImageRendering.Chart
Telerik.Reporting.RtfRendering.Chart
Telerik.Reporting.ImageRendering.CheckBox
Telerik.Reporting.RtfRendering.CheckBox
Telerik.Reporting.ImageRendering.Panel
Telerik.Reporting.RtfRendering.Panel
Telerik.Reporting.ImageRendering.PictureBox
Telerik.Reporting.RtfRendering.PictureBox
Telerik.Reporting.ImageRendering.Shape
Telerik.Reporting.RtfRendering.Shape
Telerik.Reporting.ImageRendering.TextBox
Telerik.Reporting.RtfRendering.TextBox
Telerik.Reporting.ImageRendering.ReportSectionBase
Telerik.Reporting.ImageRendering.PageSection
Telerik.Reporting.RtfRendering.PageSection
Telerik.Reporting.ImageRendering.ReportSection
Telerik.Reporting.ImageRendering.DetailSection
Telerik.Reporting.RtfRendering.DetailSection
Telerik.Reporting.ImageRendering.GroupSection
Telerik.Reporting.RtfRendering.GroupSection
Telerik.Reporting.RtfRendering.ReportSection
Telerik.Reporting.ImageRendering.TextLine
Telerik.Reporting.RtfRendering.TextLine
Telerik.Reporting.RtfRendering.SubReport

See Also

Reference

Telerik.Reporting.Processing Assembly


Getting Started - Telerik.Reporting

Getting Started


Introduction - Telerik.Reporting

Introduction


Barcode.SymbologyType Enumeration

Barcode.SymbologyType Enumeration
[image]
Telerik.Reporting Namespace : Barcode.SymbologyType Enumeration

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum Barcode.SymbologyType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Barcode.SymbologyType
C#
public enum Barcode.SymbologyType : Enum

Members

Member | Description
Codabar |
Code11 |
Code25Standard |
Code25Interleaved |
Code39 |
Code39Extended |
Code93 |
Code93Extended |
Code128 |
Code128A |
Code128B |
Code128C |
CodeMSI |
EAN8 |
EAN13 |
EAN128 |
Postnet |
UPCA |
UPCE |
UPCSupplement2 |
UPCSupplement5 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Barcode.SymbologyType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting Namespace


Barcode Class Events

Barcode Class Events
[image]
Telerik.Reporting Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

Barcode Class
Telerik.Reporting Namespace


Barcode Class Methods

Barcode Class Methods
[image]
Telerik.Reporting Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

Barcode Class
Telerik.Reporting Namespace


AxisLabel Class Fields

AxisLabel Class Fields
[image]
Telerik.Reporting.Charting Namespace : AxisLabel Class

For a list of all members of this type, see AxisLabel members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

AxisLabel Class
Telerik.Reporting.Charting Namespace


AxisLabel Class Methods

AxisLabel Class Methods
[image]
Telerik.Reporting.Charting Namespace : AxisLabel Class

For a list of all members of this type, see AxisLabel members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

AxisLabel Class
Telerik.Reporting.Charting Namespace


AxisLabel Class Properties

AxisLabel Class Properties
[image]
Telerik.Reporting.Charting Namespace : AxisLabel Class

For a list of all members of this type, see AxisLabel members.

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from AxisLabelHidden)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

AxisLabel Class
Telerik.Reporting.Charting Namespace


AxisLabelHidden Class Fields

AxisLabelHidden Class Fields
[image]
Telerik.Reporting.Charting Namespace : AxisLabelHidden Class

For a list of all members of this type, see AxisLabelHidden members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

AxisLabelHidden Class
Telerik.Reporting.Charting Namespace


AxisLabelHidden Class Methods

AxisLabelHidden Class Methods
[image]
Telerik.Reporting.Charting Namespace : AxisLabelHidden Class

For a list of all members of this type, see AxisLabelHidden members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

AxisLabelHidden Class
Telerik.Reporting.Charting Namespace


AxisSegment Class Methods

AxisSegment Class Methods
[image]
Telerik.Reporting.Charting Namespace : AxisSegment Class

For a list of all members of this type, see AxisSegment members.

Public Methods

 | Name | Description
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | LoadViewState | (Inherited from StateManagedObject)
Protected Method | SaveViewState | (Inherited from StateManagedObject)
Protected Method | TrackViewState | (Inherited from StateManagedObject)
Top

See Also

Reference

AxisSegment Class
Telerik.Reporting.Charting Namespace


AxisSegmentCollection Class Methods

AxisSegmentCollection Class Methods
[image]
Telerik.Reporting.Charting Namespace : AxisSegmentCollection Class

For a list of all members of this type, see AxisSegmentCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | AddRange | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | Clear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | Contains | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | CopyTo | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | GetEnumerator | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | IndexOf | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | Insert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | Remove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | RemoveAt | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Top

Protected Methods

 | Name | Description
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | OnClear | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | OnClearComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | OnInsert | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | OnInsertComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | OnRemove | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | OnRemoveComplete | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Protected Method | SetItemDirty | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Top

See Also

Reference

AxisSegmentCollection Class
Telerik.Reporting.Charting Namespace


AxisSegmentCollection Class Properties

AxisSegmentCollection Class Properties
[image]
Telerik.Reporting.Charting Namespace : AxisSegmentCollection Class

For a list of all members of this type, see AxisSegmentCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Public Property | Item | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>)
Top

See Also

Reference

AxisSegmentCollection Class
Telerik.Reporting.Charting Namespace


AxisYLabel Class Fields

AxisYLabel Class Fields
[image]
Telerik.Reporting.Charting Namespace : AxisYLabel Class

For a list of all members of this type, see AxisYLabel members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

AxisYLabel Class
Telerik.Reporting.Charting Namespace


AxisYLabel Class Methods

AxisYLabel Class Methods
[image]
Telerik.Reporting.Charting Namespace : AxisYLabel Class

For a list of all members of this type, see AxisYLabel members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

AxisYLabel Class
Telerik.Reporting.Charting Namespace


AxisYLabel Class Properties

AxisYLabel Class Properties
[image]
Telerik.Reporting.Charting Namespace : AxisYLabel Class

For a list of all members of this type, see AxisYLabel members.

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from AxisLabelHidden)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

AxisYLabel Class
Telerik.Reporting.Charting Namespace


BindableLegendItem Class Fields

BindableLegendItem Class Fields
[image]
Telerik.Reporting.Charting Namespace : BindableLegendItem Class

For a list of all members of this type, see BindableLegendItem members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

BindableLegendItem Class
Telerik.Reporting.Charting Namespace


BindableLegendItem Class Methods

BindableLegendItem Class Methods
[image]
Telerik.Reporting.Charting Namespace : BindableLegendItem Class

For a list of all members of this type, see BindableLegendItem members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

BindableLegendItem Class
Telerik.Reporting.Charting Namespace


Chart Class Fields

Chart Class Fields
[image]
Telerik.Reporting.Charting Namespace : Chart Class

For a list of all members of this type, see Chart members.

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

Chart Class
Telerik.Reporting.Charting Namespace


ChartAxisItem Class Fields

ChartAxisItem Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartAxisItem Class

For a list of all members of this type, see ChartAxisItem members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

ChartAxisItem Class
Telerik.Reporting.Charting Namespace


ChartAxisItem Class Methods

ChartAxisItem Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartAxisItem Class

For a list of all members of this type, see ChartAxisItem members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

ChartAxisItem Class
Telerik.Reporting.Charting Namespace


ChartDataTable Class Fields

ChartDataTable Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartDataTable Class

For a list of all members of this type, see ChartDataTable members.

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

ChartDataTable Class
Telerik.Reporting.Charting Namespace


ChartDataTable Class Methods

ChartDataTable Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartDataTable Class

For a list of all members of this type, see ChartDataTable members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

ChartDataTable Class
Telerik.Reporting.Charting Namespace


ChartElementLocation Enumeration

ChartElementLocation Enumeration
[image]
Telerik.Reporting.Charting Namespace : ChartElementLocation Enumeration

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ChartElementLocation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartElementLocation
C#
public enum ChartElementLocation : Enum

Members

Member | Description
InsidePlotArea |
OutsidePlotArea |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.ChartElementLocation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting Namespace


ChartException Class Methods

ChartException Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartException Class

For a list of all members of this type, see ChartException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ChartException Class
Telerik.Reporting.Charting Namespace


ChartException Class Properties

ChartException Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartException Class

For a list of all members of this type, see ChartException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

ChartException Class
Telerik.Reporting.Charting Namespace


ChartLabel Class Fields

ChartLabel Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartLabel Class

For a list of all members of this type, see ChartLabel members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

ChartLabel Class
Telerik.Reporting.Charting Namespace


ChartLabel Class Methods

ChartLabel Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartLabel Class

For a list of all members of this type, see ChartLabel members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

ChartLabel Class
Telerik.Reporting.Charting Namespace


ChartLegend Class Fields

ChartLegend Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartLegend Class

For a list of all members of this type, see ChartLegend members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | extendedLabelItems | (Inherited from ExtendedLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

ChartLegend Class
Telerik.Reporting.Charting Namespace


ChartMarkedZone Class Fields

ChartMarkedZone Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartMarkedZone Class

For a list of all members of this type, see ChartMarkedZone members.

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


ChartPlotArea Class Fields

ChartPlotArea Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartPlotArea Class

For a list of all members of this type, see ChartPlotArea members.

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


ChartSeries Class Fields

ChartSeries Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartSeries Class

For a list of all members of this type, see ChartSeries members.

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

ChartSeries Class
Telerik.Reporting.Charting Namespace


ChartSeriesItem Class Fields

ChartSeriesItem Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesItem Class

For a list of all members of this type, see ChartSeriesItem members.

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


AddRange(ChartSeriesItem[]) Method

AddRange(ChartSeriesItem[]) Method
[image]
Telerik.Reporting.Charting Namespace > ChartSeriesItemsCollection Class > AddRange Method : AddRange(ChartSeriesItem[]) Method

itemsToAdd

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Sub AddRange( _
   ByVal itemsToAdd() As ChartSeriesItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesItemsCollection
Dim itemsToAdd() As ChartSeriesItem

instance.AddRange(itemsToAdd)
C#
public virtual void AddRange(
   ChartSeriesItem[] itemsToAdd
)

Parameters

itemsToAdd

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Members
Overload List


ChartSeriesLegendDisplayMode Enumeration

ChartSeriesLegendDisplayMode Enumeration
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesLegendDisplayMode Enumeration

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ChartSeriesLegendDisplayMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLegendDisplayMode
C#
public enum ChartSeriesLegendDisplayMode : Enum

Members

Member | Description
Nothing |
SeriesName |
ItemLabels |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.ChartSeriesLegendDisplayMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting Namespace


ChartSeriesOrientation Enumeration

ChartSeriesOrientation Enumeration
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesOrientation Enumeration

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ChartSeriesOrientation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesOrientation
C#
public enum ChartSeriesOrientation : Enum

Members

Member | Description
Vertical |
Horizontal |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.ChartSeriesOrientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting Namespace


ChartSeriesType Enumeration

ChartSeriesType Enumeration
[image]
Telerik.Reporting.Charting Namespace : ChartSeriesType Enumeration

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ChartSeriesType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesType
C#
public enum ChartSeriesType : Enum

Members

Member | Description
Bar |
StackedBar |
StackedBar100 |
Line |
Area |
StackedArea |
StackedArea100 |
Pie |
Gantt |
Bezier |
Spline |
Bubble |
Point |
SplineArea |
StackedSplineArea |
StackedSplineArea100 |
CandleStick |
StackedLine |
StackedSpline |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.ChartSeriesType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting Namespace


ChartTitle Class Fields

ChartTitle Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartTitle Class

For a list of all members of this type, see ChartTitle members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

ChartTitle Class
Telerik.Reporting.Charting Namespace


ChartTitle Class Methods

ChartTitle Class Methods
[image]
Telerik.Reporting.Charting Namespace : ChartTitle Class

For a list of all members of this type, see ChartTitle members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

ChartTitle Class
Telerik.Reporting.Charting Namespace


ChartTitle Class Properties

ChartTitle Class Properties
[image]
Telerik.Reporting.Charting Namespace : ChartTitle Class

For a list of all members of this type, see ChartTitle members.

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

ChartTitle Class
Telerik.Reporting.Charting Namespace


ChartYAxis Class Fields

ChartYAxis Class Fields
[image]
Telerik.Reporting.Charting Namespace : ChartYAxis Class

For a list of all members of this type, see ChartYAxis members.

Protected Fields

 | Name | Description
Protected Field | chartAxisAppearance | (Inherited from ChartAxis)
Protected Field | chartAxisItems | (Inherited from ChartAxis)
Protected Field | chartAxisLabel | (Inherited from ChartAxis)
Protected Field | chartAxisMaxAxisValue | (Inherited from ChartAxis)
Protected Field | chartAxisMaxItemValue | (Inherited from ChartAxis)
Protected Field | chartAxisMinAxisValue | (Inherited from ChartAxis)
Protected Field | chartAxisMinItemValue | (Inherited from ChartAxis)
Protected Field | chartAxisParent | (Inherited from ChartAxis)
Protected Field | chartAxisPointEnd | (Inherited from ChartAxis)
Protected Field | chartAxisPointStart | (Inherited from ChartAxis)
Protected Field | chartAxisRealIsZeroBased | (Inherited from ChartAxis)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | pixelsPerValue | (Inherited from ChartAxis)
Protected Field | zeroCoord | (Inherited from ChartAxis)
Top

See Also

Reference

ChartYAxis Class
Telerik.Reporting.Charting Namespace


ChartYAxisMode Enumeration

ChartYAxisMode Enumeration
[image]
Telerik.Reporting.Charting Namespace : ChartYAxisMode Enumeration

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ChartYAxisMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisMode
C#
public enum ChartYAxisMode : Enum

Members

Member | Description
Normal |
Extended |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.ChartYAxisMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting Namespace


ChartYAxisType Enumeration

ChartYAxisType Enumeration
[image]
Telerik.Reporting.Charting Namespace : ChartYAxisType Enumeration

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ChartYAxisType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisType
C#
public enum ChartYAxisType : Enum

Members

Member | Description
Primary |
Secondary |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.ChartYAxisType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting Namespace


ColorBlend Class Properties

ColorBlend Class Properties
[image]
Telerik.Reporting.Charting Namespace : ColorBlend Class

For a list of all members of this type, see ColorBlend members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Public Property | Item | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>)
Top

See Also

Reference

ColorBlend Class
Telerik.Reporting.Charting Namespace


AddRange(GradientElement[]) Method

AddRange(GradientElement[]) Method
[image]
Telerik.Reporting.Charting Namespace > ColorBlend Class > AddRange Method : AddRange(GradientElement[]) Method

itemsToAdd

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Sub AddRange( _
   ByVal itemsToAdd() As GradientElement _
)
Visual Basic (Usage) Copy Code
Dim instance As ColorBlend
Dim itemsToAdd() As GradientElement

instance.AddRange(itemsToAdd)
C#
public virtual void AddRange(
   GradientElement[] itemsToAdd
)

Parameters

itemsToAdd

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColorBlend Class
ColorBlend Members
Overload List


ContentHorizontalAlign Enumeration

ContentHorizontalAlign Enumeration
[image]
Telerik.Reporting.Charting Namespace : ContentHorizontalAlign Enumeration

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ContentHorizontalAlign
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ContentHorizontalAlign
C#
public enum ContentHorizontalAlign : Enum

Members

Member | Description
Left |
Center |
Right |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.ContentHorizontalAlign

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting Namespace


ContentVerticalAlign Enumeration

ContentVerticalAlign Enumeration
[image]
Telerik.Reporting.Charting Namespace : ContentVerticalAlign Enumeration

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ContentVerticalAlign
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ContentVerticalAlign
C#
public enum ContentVerticalAlign : Enum

Members

Member | Description
Top |
Middle |
Bottom |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.ContentVerticalAlign

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting Namespace


CustomFiguresCollection Class Properties

CustomFiguresCollection Class Properties
[image]
Telerik.Reporting.Charting Namespace : CustomFiguresCollection Class

For a list of all members of this type, see CustomFiguresCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Public Property | Item | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>)
Top

See Also

Reference

CustomFiguresCollection Class
Telerik.Reporting.Charting Namespace


Contains(CustomFigure) Method

Contains(CustomFigure) Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class > Contains Method : Contains(CustomFigure) Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Function Contains( _
   ByVal item As CustomFigure _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomFiguresCollection
Dim item As CustomFigure
Dim value As Boolean

value = instance.Contains(item)
C#
public virtual bool Contains(
   CustomFigure item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members
Overload List


IndexOf(CustomFigure) Method

IndexOf(CustomFigure) Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class > IndexOf Method : IndexOf(CustomFigure) Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal item As CustomFigure _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CustomFiguresCollection
Dim item As CustomFigure
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   CustomFigure item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members
Overload List


Remove(CustomFigure) Method

Remove(CustomFigure) Method
[image]
Telerik.Reporting.Charting Namespace > CustomFiguresCollection Class > Remove Method : Remove(CustomFigure) Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Function Remove( _
   ByVal item As CustomFigure _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomFiguresCollection
Dim item As CustomFigure
Dim value As Boolean

value = instance.Remove(item)
C#
public virtual bool Remove(
   CustomFigure item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomFiguresCollection Class
CustomFiguresCollection Members
Overload List


CustomPalettesCollection Class Properties

CustomPalettesCollection Class Properties
[image]
Telerik.Reporting.Charting Namespace : CustomPalettesCollection Class

For a list of all members of this type, see CustomPalettesCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Public Property | Item | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>)
Top

See Also

Reference

CustomPalettesCollection Class
Telerik.Reporting.Charting Namespace


Contains(Palette) Method

Contains(Palette) Method
[image]
Telerik.Reporting.Charting Namespace > CustomPalettesCollection Class > Contains Method : Contains(Palette) Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Function Contains( _
   ByVal item As Palette _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomPalettesCollection
Dim item As Palette
Dim value As Boolean

value = instance.Contains(item)
C#
public virtual bool Contains(
   Palette item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Class
CustomPalettesCollection Members
Overload List


IndexOf(Palette) Method

IndexOf(Palette) Method
[image]
Telerik.Reporting.Charting Namespace > CustomPalettesCollection Class > IndexOf Method : IndexOf(Palette) Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal item As Palette _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CustomPalettesCollection
Dim item As Palette
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   Palette item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Class
CustomPalettesCollection Members
Overload List


Remove(Palette) Method

Remove(Palette) Method
[image]
Telerik.Reporting.Charting Namespace > CustomPalettesCollection Class > Remove Method : Remove(Palette) Method

item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Function Remove( _
   ByVal item As Palette _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomPalettesCollection
Dim item As Palette
Dim value As Boolean

value = instance.Remove(item)
C#
public virtual bool Remove(
   Palette item
)

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomPalettesCollection Class
CustomPalettesCollection Members
Overload List


DummyWebControl Class Events

DummyWebControl Class Events
[image]
Telerik.Reporting.Charting Namespace : DummyWebControl Class

For a list of all members of this type, see DummyWebControl members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

DummyWebControl Class
Telerik.Reporting.Charting Namespace


DummyWebControl Class Methods

DummyWebControl Class Methods
[image]
Telerik.Reporting.Charting Namespace : DummyWebControl Class

For a list of all members of this type, see DummyWebControl members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | (Inherited from System.Web.UI.Control)
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | RenderChildren | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

DummyWebControl Class
Telerik.Reporting.Charting Namespace


DummyWebControl Class Properties

DummyWebControl Class Properties
[image]
Telerik.Reporting.Charting Namespace : DummyWebControl Class

For a list of all members of this type, see DummyWebControl members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

DummyWebControl Class
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Class Fields

EmptySeriesMessage Class Fields
[image]
Telerik.Reporting.Charting Namespace : EmptySeriesMessage Class

For a list of all members of this type, see EmptySeriesMessage members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

EmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Class Methods

EmptySeriesMessage Class Methods
[image]
Telerik.Reporting.Charting Namespace : EmptySeriesMessage Class

For a list of all members of this type, see EmptySeriesMessage members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

EmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


LabelItem Class Fields

LabelItem Class Fields
[image]
Telerik.Reporting.Charting Namespace : LabelItem Class

For a list of all members of this type, see LabelItem members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

LabelItem Class
Telerik.Reporting.Charting Namespace


LabelItem Class Methods

LabelItem Class Methods
[image]
Telerik.Reporting.Charting Namespace : LabelItem Class

For a list of all members of this type, see LabelItem members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

LabelItem Class
Telerik.Reporting.Charting Namespace


LayoutElement Class Fields

LayoutElement Class Fields
[image]
Telerik.Reporting.Charting Namespace : LayoutElement Class

For a list of all members of this type, see LayoutElement members.

Protected Fields

 | Name | Description
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

LayoutElement Class
Telerik.Reporting.Charting Namespace


LayoutElement Class Properties

LayoutElement Class Properties
[image]
Telerik.Reporting.Charting Namespace : LayoutElement Class

For a list of all members of this type, see LayoutElement members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from RenderedObject)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

LayoutElement Class
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Class Fields

MarkedZoneLabel Class Fields
[image]
Telerik.Reporting.Charting Namespace : MarkedZoneLabel Class

For a list of all members of this type, see MarkedZoneLabel members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

MarkedZoneLabel Class
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Class Methods

MarkedZoneLabel Class Methods
[image]
Telerik.Reporting.Charting Namespace : MarkedZoneLabel Class

For a list of all members of this type, see MarkedZoneLabel members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ChartBaseLabel)
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | Clone | (Inherited from ChartBaseLabel)
Public Method | Dispose | Overloaded. (Inherited from ChartBaseLabel)
Public Method | GetOrder | Overloaded. (Inherited from ChartBaseLabel)
Public Method | Insert | (Inherited from ChartBaseLabel)
Public Method | ReIndex | (Inherited from ChartBaseLabel)
Public Method | Remove | Overloaded. (Inherited from ChartBaseLabel)
Public Method | RemoveAt | (Inherited from ChartBaseLabel)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from ChartBaseLabel)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from ChartBaseLabel)
Protected Method | SaveViewState | (Inherited from ChartBaseLabel)
Protected Method | TrackViewState | (Inherited from ChartBaseLabel)
Top

See Also

Reference

MarkedZoneLabel Class
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Class Properties

MarkedZoneLabel Class Properties
[image]
Telerik.Reporting.Charting Namespace : MarkedZoneLabel Class

For a list of all members of this type, see MarkedZoneLabel members.

Public Properties

 | Name | Description
Public Property | ActiveRegion | (Inherited from ChartBaseLabel)
Public Property | Appearance | (Inherited from ChartLabel)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Marker | (Inherited from ChartBaseLabel)
Public Property | NextPosition | (Inherited from ChartBaseLabel)
Public Property | OrderList | (Inherited from ChartBaseLabel)
Public Property | Parent | (Inherited from ChartBaseLabel)
Public Property | TextBlock | (Inherited from ChartBaseLabel)
Public Property | Visible | (Inherited from ChartBaseLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

MarkedZoneLabel Class
Telerik.Reporting.Charting Namespace


PaletteItemsCollection Class Properties

PaletteItemsCollection Class Properties
[image]
Telerik.Reporting.Charting Namespace : PaletteItemsCollection Class

For a list of all members of this type, see PaletteItemsCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Property | IsReadOnly | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Public Property | Item | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Top

Protected Properties

 | Name | Description
Protected Property | List | (Inherited from Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>)
Top

See Also

Reference

PaletteItemsCollection Class
Telerik.Reporting.Charting Namespace


RegionClickEventHandler Delegate

RegionClickEventHandler Delegate
[image]
Telerik.Reporting.Charting Namespace : RegionClickEventHandler Delegate

sender

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub RegionClickEventHandler( _
   ByVal sender As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As New RegionClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void RegionClickEventHandler(
   object sender
)

Parameters

sender

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting Namespace


ScaleBreakLineType Enumeration

ScaleBreakLineType Enumeration
[image]
Telerik.Reporting.Charting Namespace : ScaleBreakLineType Enumeration

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ScaleBreakLineType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ScaleBreakLineType
C#
public enum ScaleBreakLineType : Enum

Members

Member | Description
Straight |
Curve |
JaggedCurve |
Sinusoid |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.ScaleBreakLineType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting Namespace


SeriesItemLabel Class Fields

SeriesItemLabel Class Fields
[image]
Telerik.Reporting.Charting Namespace : SeriesItemLabel Class

For a list of all members of this type, see SeriesItemLabel members.

Protected Fields

 | Name | Description
Protected Field | chartBaseLabelActiveRegion | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelOrderList | (Inherited from ChartBaseLabel)
Protected Field | chartBaseLabelParent | (Inherited from ChartBaseLabel)
Protected Field | objectContainer | (Inherited from RenderedObject)
Top

See Also

Reference

SeriesItemLabel Class
Telerik.Reporting.Charting Namespace


AlignedPositions Enumeration

AlignedPositions Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : AlignedPositions Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum AlignedPositions
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As AlignedPositions
C#
public enum AlignedPositions : Enum

Members

Member | Description
None |
Right |
Left |
Top |
Bottom |
Center |
TopRight |
TopLeft |
BottomRight |
BottomLeft |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.AlignedPositions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


AutoTextWrap Enumeration

AutoTextWrap Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : AutoTextWrap Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum AutoTextWrap
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As AutoTextWrap
C#
public enum AutoTextWrap : Enum

Members

Member | Description
Auto |
True |
False |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.AutoTextWrap

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


ChartAxisLayoutMode Enumeration

ChartAxisLayoutMode Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartAxisLayoutMode Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ChartAxisLayoutMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisLayoutMode
C#
public enum ChartAxisLayoutMode : Enum

Members

Member | Description
Normal |
Inside |
Between |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.ChartAxisLayoutMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


ChartAxisVisibility Enumeration

ChartAxisVisibility Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartAxisVisibility Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ChartAxisVisibility
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisVisibility
C#
public enum ChartAxisVisibility : Enum

Members

Member | Description
Auto |
True |
False |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.ChartAxisVisibility

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


ChartAxisVisibleValues Enumeration

ChartAxisVisibleValues Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartAxisVisibleValues Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ChartAxisVisibleValues
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisVisibleValues
C#
public enum ChartAxisVisibleValues : Enum

Members

Member | Description
All |
Positive |
Negative |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.ChartAxisVisibleValues

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


ChartGridLineLayoutMode Enumeration

ChartGridLineLayoutMode Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartGridLineLayoutMode Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ChartGridLineLayoutMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartGridLineLayoutMode
C#
public enum ChartGridLineLayoutMode : Enum

Members

Member | Description
Normal |
Expanded |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.ChartGridLineLayoutMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


ChartMargins Class Properties

ChartMargins Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMargins Class

For a list of all members of this type, see ChartMargins members.

Public Properties

 | Name | Description
Public Property | Bottom | (Inherited from LayoutDecoratorBase)
Public Property | Left | (Inherited from LayoutDecoratorBase)
Public Property | Right | (Inherited from LayoutDecoratorBase)
Public Property | Top | (Inherited from LayoutDecoratorBase)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartMargins Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsLegend Class Methods

ChartMarginsLegend Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMarginsLegend Class

For a list of all members of this type, see ChartMarginsLegend members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartMarginsLegend Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsPlotArea Class Methods

ChartMarginsPlotArea Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMarginsPlotArea Class

For a list of all members of this type, see ChartMarginsPlotArea members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartMarginsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsTitle Class Methods

ChartMarginsTitle Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartMarginsTitle Class

For a list of all members of this type, see ChartMarginsTitle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartMarginsTitle Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Class Properties

ChartPaddings Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartPaddings Class

For a list of all members of this type, see ChartPaddings members.

Public Properties

 | Name | Description
Public Property | Bottom | (Inherited from LayoutDecoratorBase)
Public Property | Left | (Inherited from LayoutDecoratorBase)
Public Property | Right | (Inherited from LayoutDecoratorBase)
Public Property | Top | (Inherited from LayoutDecoratorBase)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartPaddings Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsLegend Class Methods

ChartPaddingsLegend Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartPaddingsLegend Class

For a list of all members of this type, see ChartPaddingsLegend members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartPaddingsLegend Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsTitle Class Methods

ChartPaddingsTitle Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartPaddingsTitle Class

For a list of all members of this type, see ChartPaddingsTitle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LayoutDecoratorBase)
Public Method | CopyFrom | (Inherited from LayoutDecoratorBase)
Public Method | Equals | (Inherited from LayoutDecoratorBase)
Public Method | GetHashCode | (Inherited from LayoutDecoratorBase)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ChartPaddingsTitle Class
Telerik.Reporting.Charting.Styles Namespace


ChartValueFormat Enumeration

ChartValueFormat Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : ChartValueFormat Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ChartValueFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartValueFormat
C#
public enum ChartValueFormat : Enum

Members

Member | Description
None |
Currency |
Scientific |
General |
Number |
Percent |
ShortDate |
ShortTime |
LongDate |
LongTime |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.ChartValueFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


CornerType Enumeration

CornerType Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : CornerType Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum CornerType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As CornerType
C#
public enum CornerType : Enum

Members

Member | Description
Rectangle |
Round |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.CornerType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


DimensionsChart Class Fields

DimensionsChart Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsChart Class

For a list of all members of this type, see DimensionsChart members.

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsChart Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsLegend Class Fields

DimensionsLegend Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsLegend Class

For a list of all members of this type, see DimensionsLegend members.

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsLegend Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsLegend Class Methods

DimensionsLegend Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsLegend Class

For a list of all members of this type, see DimensionsLegend members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Dimensions)
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | (Inherited from Dimensions)
Protected Method | ResetWidth | (Inherited from Dimensions)
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsLegend Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsMarker Class Fields

DimensionsMarker Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsMarker Class

For a list of all members of this type, see DimensionsMarker members.

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsPlotArea Class Fields

DimensionsPlotArea Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsPlotArea Class

For a list of all members of this type, see DimensionsPlotArea members.

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsPlotArea Class Methods

DimensionsPlotArea Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsPlotArea Class

For a list of all members of this type, see DimensionsPlotArea members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Dimensions)
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | (Inherited from Dimensions)
Protected Method | ResetWidth | (Inherited from Dimensions)
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsPointMarker Class Fields

DimensionsPointMarker Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsPointMarker Class

For a list of all members of this type, see DimensionsPointMarker members.

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsPointMarker Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsSeriesPointMark Class Fields

DimensionsSeriesPointMark Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsSeriesPointMark Class

For a list of all members of this type, see DimensionsSeriesPointMark members.

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsTitle Class Fields

DimensionsTitle Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsTitle Class

For a list of all members of this type, see DimensionsTitle members.

Protected Fields

 | Name | Description
Protected Field | dimensionsMargins | (Inherited from Dimensions)
Protected Field | dimensionsPaddings | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsTitle Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsTitle Class Methods

DimensionsTitle Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : DimensionsTitle Class

For a list of all members of this type, see DimensionsTitle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Dimensions)
Public Method | Equals | (Inherited from Dimensions)
Public Method | GetHashCode | (Inherited from Dimensions)
Public Method | IsZero | (Inherited from Dimensions)
Public Method | SetDimensions | Overloaded. (Inherited from Dimensions)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Dimensions)
Protected Method | ResetHeight | (Inherited from Dimensions)
Protected Method | ResetWidth | (Inherited from Dimensions)
Protected Method | SaveViewState | (Inherited from Dimensions)
Protected Method | ShouldSerializeHeight | (Inherited from Dimensions)
Protected Method | ShouldSerializeWidth | (Inherited from Dimensions)
Protected Method | TrackViewState | (Inherited from Dimensions)
Top

See Also

Reference

DimensionsTitle Class
Telerik.Reporting.Charting.Styles Namespace


DrawType Enumeration

DrawType Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : DrawType Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum DrawType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DrawType
C#
public enum DrawType : Enum

Members

Member | Description
Line |
Fill |
LineAndFill |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.DrawType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


EmtyValuesMode Enumeration

EmtyValuesMode Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : EmtyValuesMode Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum EmtyValuesMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As EmtyValuesMode
C#
public enum EmtyValuesMode : Enum

Members

Member | Description
Zero |
Approximation |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.EmtyValuesMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


FillSettingsVerticalGradient Class Fields

FillSettingsVerticalGradient Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : FillSettingsVerticalGradient Class

For a list of all members of this type, see FillSettingsVerticalGradient members.

Protected Fields

 | Name | Description
Protected Field | fillSettingsComplexGradient | (Inherited from FillSettings)
Top

See Also

Reference

FillSettingsVerticalGradient Class
Telerik.Reporting.Charting.Styles Namespace


FillSettingsVerticalGradient Class Methods

FillSettingsVerticalGradient Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillSettingsVerticalGradient Class

For a list of all members of this type, see FillSettingsVerticalGradient members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillSettings)
Public Method | Equals | (Inherited from FillSettings)
Public Method | GetHashCode | (Inherited from FillSettings)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillSettings)
Protected Method | SaveViewState | (Inherited from FillSettings)
Protected Method | TrackViewState | (Inherited from FillSettings)
Top

See Also

Reference

FillSettingsVerticalGradient Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleChart Class Methods

FillStyleChart Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleChart Class

For a list of all members of this type, see FillStyleChart members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillStyle)
Public Method | Equals | (Inherited from FillStyle)
Public Method | GetHashCode | (Inherited from FillStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillStyle)
Protected Method | SaveViewState | (Inherited from FillStyle)
Protected Method | TrackViewState | (Inherited from FillStyle)
Top

See Also

Reference

FillStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleMarkedZones Class Methods

FillStyleMarkedZones Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleMarkedZones Class

For a list of all members of this type, see FillStyleMarkedZones members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillStyle)
Public Method | Equals | (Inherited from FillStyle)
Public Method | GetHashCode | (Inherited from FillStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillStyle)
Protected Method | SaveViewState | (Inherited from FillStyle)
Protected Method | TrackViewState | (Inherited from FillStyle)
Top

See Also

Reference

FillStyleMarkedZones Class
Telerik.Reporting.Charting.Styles Namespace


FillStylePlotArea Class Methods

FillStylePlotArea Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStylePlotArea Class

For a list of all members of this type, see FillStylePlotArea members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillStyle)
Public Method | Equals | (Inherited from FillStyle)
Public Method | GetHashCode | (Inherited from FillStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillStyle)
Protected Method | SaveViewState | (Inherited from FillStyle)
Protected Method | TrackViewState | (Inherited from FillStyle)
Top

See Also

Reference

FillStylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeries Class Methods

FillStyleSeries Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleSeries Class

For a list of all members of this type, see FillStyleSeries members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillStyle)
Public Method | Equals | (Inherited from FillStyle)
Public Method | GetHashCode | (Inherited from FillStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillStyle)
Protected Method | SaveViewState | (Inherited from FillStyle)
Protected Method | TrackViewState | (Inherited from FillStyle)
Top

See Also

Reference

FillStyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeriesPoint Class Methods

FillStyleSeriesPoint Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleSeriesPoint Class

For a list of all members of this type, see FillStyleSeriesPoint members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillStyle)
Public Method | Equals | (Inherited from FillStyle)
Public Method | GetHashCode | (Inherited from FillStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillStyle)
Protected Method | SaveViewState | (Inherited from FillStyle)
Protected Method | TrackViewState | (Inherited from FillStyle)
Top

See Also

Reference

FillStyleSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeriesPoint Class Properties

FillStyleSeriesPoint Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleSeriesPoint Class

For a list of all members of this type, see FillStyleSeriesPoint members.

Public Properties

 | Name | Description
Public Property | FillSettings | (Inherited from FillStyle)
Public Property | FillType | (Inherited from FillStyle)
Public Property | GammaCorrection | (Inherited from FillStyle)
Public Property | MainColor | (Inherited from FillStyle)
Public Property | MainColorOpacity | (Inherited from FillStyle)
Public Property | SecondColor | (Inherited from FillStyle)
Public Property | SecondColorOpacity | (Inherited from FillStyle)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

FillStyleSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleTitle Class Methods

FillStyleTitle Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : FillStyleTitle Class

For a list of all members of this type, see FillStyleTitle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from FillStyle)
Public Method | Equals | (Inherited from FillStyle)
Public Method | GetHashCode | (Inherited from FillStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from FillStyle)
Protected Method | SaveViewState | (Inherited from FillStyle)
Protected Method | TrackViewState | (Inherited from FillStyle)
Top

See Also

Reference

FillStyleTitle Class
Telerik.Reporting.Charting.Styles Namespace


FillType Enumeration

FillType Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : FillType Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum FillType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FillType
C#
public enum FillType : Enum

Members

Member | Description
Solid |
Gradient |
ComplexGradient |
Hatch |
Image |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.FillType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


GradientFillStyle Enumeration

GradientFillStyle Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : GradientFillStyle Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum GradientFillStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As GradientFillStyle
C#
public enum GradientFillStyle : Enum

Members

Member | Description
Horizontal |
Vertical |
ForwardDiagonal |
BackwardDiagonal |
Center |
Circle |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.GradientFillStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


ImageAlignModes Enumeration

ImageAlignModes Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : ImageAlignModes Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ImageAlignModes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ImageAlignModes
C#
public enum ImageAlignModes : Enum

Members

Member | Description
Top |
Bottom |
Right |
Left |
Center |
TopRight |
TopLeft |
BottomRight |
BottomLeft |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.ImageAlignModes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


ImageDrawMode Enumeration

ImageDrawMode Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : ImageDrawMode Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ImageDrawMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ImageDrawMode
C#
public enum ImageDrawMode : Enum

Members

Member | Description
Align |
Stretch |
Flip |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.ImageDrawMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


ImageQuality Enumeration

ImageQuality Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : ImageQuality Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ImageQuality
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ImageQuality
C#
public enum ImageQuality : Enum

Members

Member | Description
Default |
AntiAlias |
HighQuality |
None |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.ImageQuality

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


ImageTileModes Enumeration

ImageTileModes Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : ImageTileModes Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ImageTileModes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ImageTileModes
C#
public enum ImageTileModes : Enum

Members

Member | Description
Flip |
FlipX |
FlipY |
FlipXY |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.ImageTileModes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


LabelItemsCompositionTypes Enumeration

LabelItemsCompositionTypes Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : LabelItemsCompositionTypes Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum LabelItemsCompositionTypes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As LabelItemsCompositionTypes
C#
public enum LabelItemsCompositionTypes : Enum

Members

Member | Description
ColumnImageText |
ColumnTextImage |
RowImageText |
RowTextImage |
None |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.LabelItemsCompositionTypes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


LabelLocation Enumeration

LabelLocation Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : LabelLocation Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum LabelLocation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As LabelLocation
C#
public enum LabelLocation : Enum

Members

Member | Description
InsidePlotArea |
OutsidePlotArea |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.LabelLocation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


MinorTickCount Enumeration

MinorTickCount Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : MinorTickCount Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum MinorTickCount
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MinorTickCount
C#
public enum MinorTickCount : Enum

Members

Member | Description
None |
One |
Three |
Eight |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.MinorTickCount

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


Orientation Enumeration

Orientation Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : Orientation Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum Orientation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Orientation
C#
public enum Orientation : Enum

Members

Member | Description
Horizontal |
Vertical |
Undefined |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.Orientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


Overflow Enumeration

Overflow Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : Overflow Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum Overflow
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Overflow
C#
public enum Overflow : Enum

Members

Member | Description
Auto |
Row |
Column |
Manual |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.Overflow

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


PlacementDirection Enumeration

PlacementDirection Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : PlacementDirection Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum PlacementDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PlacementDirection
C#
public enum PlacementDirection : Enum

Members

Member | Description
Horizontal |
Vertical |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.PlacementDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


PositionBottom Class Methods

PositionBottom Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionBottom Class

For a list of all members of this type, see PositionBottom members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionBottom Class
Telerik.Reporting.Charting.Styles Namespace


PositionCenter Class Methods

PositionCenter Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionCenter Class

For a list of all members of this type, see PositionCenter members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionCenter Class
Telerik.Reporting.Charting.Styles Namespace


PositionLeft Class Methods

PositionLeft Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionLeft Class

For a list of all members of this type, see PositionLeft members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionLeft Class
Telerik.Reporting.Charting.Styles Namespace


PositionRight Class Methods

PositionRight Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionRight Class

For a list of all members of this type, see PositionRight members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionRight Class
Telerik.Reporting.Charting.Styles Namespace


PositionTop Class Methods

PositionTop Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionTop Class

For a list of all members of this type, see PositionTop members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionTop Class
Telerik.Reporting.Charting.Styles Namespace


PositionTopLeft Class Methods

PositionTopLeft Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionTopLeft Class

For a list of all members of this type, see PositionTopLeft members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionTopLeft Class
Telerik.Reporting.Charting.Styles Namespace


PositionTopRight Class Methods

PositionTopRight Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : PositionTopRight Class

For a list of all members of this type, see PositionTopRight members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from Position)
Public Method | Equals | (Inherited from Position)
Public Method | GetHashCode | (Inherited from Position)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ResetX | (Inherited from Position)
Protected Method | ResetY | (Inherited from Position)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | ShouldSerializeX | (Inherited from Position)
Protected Method | ShouldSerializeY | (Inherited from Position)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

PositionTopRight Class
Telerik.Reporting.Charting.Styles Namespace


ScaleBreaksLineStyle Class Methods

ScaleBreaksLineStyle Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ScaleBreaksLineStyle Class

For a list of all members of this type, see ScaleBreaksLineStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ScaleBreaksLineStyle Class
Telerik.Reporting.Charting.Styles Namespace


ShadowPosition Enumeration

ShadowPosition Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : ShadowPosition Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ShadowPosition
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ShadowPosition
C#
public enum ShadowPosition : Enum

Members

Member | Description
Right |
Left |
Top |
Bottom |
TopRight |
TopLeft |
BottomRight |
BottomLeft |
Behind |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.ShadowPosition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


ShadowStyleChart Class Methods

ShadowStyleChart Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : ShadowStyleChart Class

For a list of all members of this type, see ShadowStyleChart members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ShadowStyle)
Public Method | Equals | (Inherited from ShadowStyle)
Public Method | GetHashCode | (Inherited from ShadowStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

ShadowStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisItemText Class Fields

StyleAxisItemText Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisItemText Class

For a list of all members of this type, see StyleAxisItemText members.

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockOverflow | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockRotationAngle | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleAxisItemText Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisItemText Class Properties

StyleAxisItemText Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisItemText Class

For a list of all members of this type, see StyleAxisItemText members.

Public Properties

 | Name | Description
Public Property | AutoTextWrap | (Inherited from StyleTextBlock)
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleTextBlock)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleTextBlock)
Public Property | FillStyle | (Inherited from StyleTextBlock)
Public Property | MaxLength | (Inherited from StyleTextBlock)
Public Property | Overflow | (Inherited from StyleTextBlock)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties | (Inherited from StyleTextBlock)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleAxisItemText Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisLabel Class Fields

StyleAxisLabel Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisLabel Class

For a list of all members of this type, see StyleAxisLabel members.

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

See Also

Reference

StyleAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisLabel Class Methods

StyleAxisLabel Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisLabel Class

For a list of all members of this type, see StyleAxisLabel members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleLabel)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleLabel)
Protected Method | SaveViewState | (Inherited from StyleLabel)
Protected Method | TrackViewState | (Inherited from StyleLabel)
Top

See Also

Reference

StyleAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisLabel Class Properties

StyleAxisLabel Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisLabel Class

For a list of all members of this type, see StyleAxisLabel members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from StyleLabelHidden)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisX Class Fields

StyleAxisX Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisX Class

For a list of all members of this type, see StyleAxisX members.

Protected Fields

 | Name | Description
Protected Field | styleAxisLabelAppearance | (Inherited from StyleAxis)
Protected Field | styleAxisMajorGridLines | (Inherited from StyleAxis)
Protected Field | styleAxisMajorTick | (Inherited from StyleAxis)
Protected Field | styleAxisMinorGridLines | (Inherited from StyleAxis)
Protected Field | styleAxisMinorTick | (Inherited from StyleAxis)
Protected Field | styleAxisOrientation | (Inherited from StyleAxis)
Protected Field | styleAxisTextAppearance | (Inherited from StyleAxis)
Top

See Also

Reference

StyleAxisX Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisX Class Methods

StyleAxisX Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisX Class

For a list of all members of this type, see StyleAxisX members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Dispose | Overloaded. (Inherited from StyleAxis)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleAxis)
Protected Method | LoadViewState | (Inherited from StyleAxis)
Protected Method | SaveViewState | (Inherited from StyleAxis)
Protected Method | TrackViewState | (Inherited from StyleAxis)
Top

See Also

Reference

StyleAxisX Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisY Class Fields

StyleAxisY Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisY Class

For a list of all members of this type, see StyleAxisY members.

Protected Fields

 | Name | Description
Protected Field | styleAxisLabelAppearance | (Inherited from StyleAxis)
Protected Field | styleAxisMajorGridLines | (Inherited from StyleAxis)
Protected Field | styleAxisMajorTick | (Inherited from StyleAxis)
Protected Field | styleAxisMinorGridLines | (Inherited from StyleAxis)
Protected Field | styleAxisMinorTick | (Inherited from StyleAxis)
Protected Field | styleAxisOrientation | (Inherited from StyleAxis)
Protected Field | styleAxisTextAppearance | (Inherited from StyleAxis)
Top

See Also

Reference

StyleAxisY Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisY Class Methods

StyleAxisY Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisY Class

For a list of all members of this type, see StyleAxisY members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Dispose | Overloaded. (Inherited from StyleAxis)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleAxis)
Protected Method | LoadViewState | (Inherited from StyleAxis)
Protected Method | SaveViewState | (Inherited from StyleAxis)
Protected Method | TrackViewState | (Inherited from StyleAxis)
Top

See Also

Reference

StyleAxisY Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisY Class Properties

StyleAxisY Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleAxisY Class

For a list of all members of this type, see StyleAxisY members.

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleAxis)
Public Property | CustomFormat | (Inherited from StyleAxis)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | LabelAppearance | (Inherited from StyleAxis)
Public Property | MajorGridLines | (Inherited from StyleAxis)
Public Property | MajorTick | (Inherited from StyleAxis)
Public Property | MinorGridLines | (Inherited from StyleAxis)
Public Property | MinorTick | (Inherited from StyleAxis)
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | TextAppearance | (Inherited from StyleAxis)
Public Property | ValueFormat | (Inherited from StyleAxis)
Public Property | Visible | (Inherited from StyleAxis)
Public Property | Width | (Inherited from StyleAxis)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleAxisY Class
Telerik.Reporting.Charting.Styles Namespace


StyleChartBorder Class Methods

StyleChartBorder Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleChartBorder Class

For a list of all members of this type, see StyleChartBorder members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleBorder)
Public Method | Equals | (Inherited from StyleBorder)
Public Method | GetHashCode | (Inherited from StyleBorder)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleChartBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleDataTableBorder Class Methods

StyleDataTableBorder Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleDataTableBorder Class

For a list of all members of this type, see StyleDataTableBorder members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleBorder)
Public Method | Equals | (Inherited from StyleBorder)
Public Method | GetHashCode | (Inherited from StyleBorder)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleDataTableBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleEmptyLineSeries Class Methods

StyleEmptyLineSeries Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleEmptyLineSeries Class

For a list of all members of this type, see StyleEmptyLineSeries members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleEmptyLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLine Class Methods

StyleGridLine Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLine Class

For a list of all members of this type, see StyleGridLine members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleGridLine Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineHidden Class Methods

StyleGridLineHidden Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLineHidden Class

For a list of all members of this type, see StyleGridLineHidden members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleGridLineHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajor Class Methods

StyleGridLineMajor Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLineMajor Class

For a list of all members of this type, see StyleGridLineMajor members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleGridLineMajor Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajor Class Properties

StyleGridLineMajor Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLineMajor Class

For a list of all members of this type, see StyleGridLineMajor members.

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleGridLine)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | HideWithAxis | (Inherited from StyleGridLine)
Public Property | PenStyle | (Inherited from StyleGridLine)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleGridLine)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleGridLineMajor Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajorXAxis Class Methods

StyleGridLineMajorXAxis Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleGridLineMajorXAxis Class

For a list of all members of this type, see StyleGridLineMajorXAxis members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleGridLineMajorXAxis Class
Telerik.Reporting.Charting.Styles Namespace


StyleItemLabelConnector Class Methods

StyleItemLabelConnector Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleItemLabelConnector Class

For a list of all members of this type, see StyleItemLabelConnector members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleItemLabelConnector Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelEmptySeriesMessage Class Fields

StyleLabelEmptySeriesMessage Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelEmptySeriesMessage Class

For a list of all members of this type, see StyleLabelEmptySeriesMessage members.

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

See Also

Reference

StyleLabelEmptySeriesMessage Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelEmptySeriesMessage Class Methods

StyleLabelEmptySeriesMessage Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelEmptySeriesMessage Class

For a list of all members of this type, see StyleLabelEmptySeriesMessage members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleLabel)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleLabel)
Protected Method | SaveViewState | (Inherited from StyleLabel)
Protected Method | TrackViewState | (Inherited from StyleLabel)
Top

See Also

Reference

StyleLabelEmptySeriesMessage Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Class Fields

StyleLabelHidden Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelHidden Class

For a list of all members of this type, see StyleLabelHidden members.

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

See Also

Reference

StyleLabelHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Class Methods

StyleLabelHidden Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelHidden Class

For a list of all members of this type, see StyleLabelHidden members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleLabel)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleLabel)
Protected Method | SaveViewState | (Inherited from StyleLabel)
Protected Method | TrackViewState | (Inherited from StyleLabel)
Top

See Also

Reference

StyleLabelHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelLegend Class Fields

StyleLabelLegend Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelLegend Class

For a list of all members of this type, see StyleLabelLegend members.

Protected Fields

 | Name | Description
Protected Field | styleExtendedLabelItemAppearance | (Inherited from StyleExtendedLabel)
Protected Field | styleExtendedLabelItemMarkerAppearance | (Inherited from StyleExtendedLabel)
Protected Field | styleExtendedLabelItemTextAppearance | (Inherited from StyleExtendedLabel)
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

See Also

Reference

StyleLabelLegend Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelLegend Class Methods

StyleLabelLegend Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelLegend Class

For a list of all members of this type, see StyleLabelLegend members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleExtendedLabel)
Public Method | Dispose | Overloaded. (Inherited from StyleExtendedLabel)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleExtendedLabel)
Protected Method | LoadViewState | (Inherited from StyleExtendedLabel)
Protected Method | SaveViewState | (Inherited from StyleExtendedLabel)
Protected Method | TrackViewState | (Inherited from StyleExtendedLabel)
Top

See Also

Reference

StyleLabelLegend Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelTitle Class Fields

StyleLabelTitle Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelTitle Class

For a list of all members of this type, see StyleLabelTitle members.

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

See Also

Reference

StyleLabelTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelTitle Class Methods

StyleLabelTitle Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelTitle Class

For a list of all members of this type, see StyleLabelTitle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleLabel)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleLabel)
Protected Method | SaveViewState | (Inherited from StyleLabel)
Protected Method | TrackViewState | (Inherited from StyleLabel)
Top

See Also

Reference

StyleLabelTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelTitle Class Properties

StyleLabelTitle Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLabelTitle Class

For a list of all members of this type, see StyleLabelTitle members.

Public Properties

 | Name | Description
Public Property | Border | (Inherited from Style)
Public Property | CompositionType | (Inherited from StyleLabel)
Public Property | Corners | (Inherited from StyleLabel)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleLabel)
Public Property | FillStyle | (Inherited from StyleLabel)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | RotationAngle | (Inherited from StyleLabel)
Public Property | Shadow | (Inherited from Style)
Public Property | Visible | (Inherited from StyleLabel)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleLabelTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleLegendBorder Class Methods

StyleLegendBorder Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLegendBorder Class

For a list of all members of this type, see StyleLegendBorder members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleBorder)
Public Method | Equals | (Inherited from StyleBorder)
Public Method | GetHashCode | (Inherited from StyleBorder)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleLegendBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleLineSeries Class Methods

StyleLineSeries Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleLineSeries Class

For a list of all members of this type, see StyleLineSeries members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerEmptyValue Class Methods

StyleMarkerEmptyValue Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerEmptyValue Class

For a list of all members of this type, see StyleMarkerEmptyValue members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleMarker)
Public Method | Equals | (Inherited from StyleMarker)
Public Method | GetHashCode | (Inherited from StyleMarker)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleMarker)
Protected Method | SaveViewState | (Inherited from StyleMarker)
Protected Method | TrackViewState | (Inherited from StyleMarker)
Top

See Also

Reference

StyleMarkerEmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerLegend Class Methods

StyleMarkerLegend Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerLegend Class

For a list of all members of this type, see StyleMarkerLegend members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleMarker)
Public Method | Equals | (Inherited from StyleMarker)
Public Method | GetHashCode | (Inherited from StyleMarker)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleMarker)
Protected Method | SaveViewState | (Inherited from StyleMarker)
Protected Method | TrackViewState | (Inherited from StyleMarker)
Top

See Also

Reference

StyleMarkerLegend Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerPositionNone Class Methods

StyleMarkerPositionNone Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerPositionNone Class

For a list of all members of this type, see StyleMarkerPositionNone members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleMarker)
Public Method | Equals | (Inherited from StyleMarker)
Public Method | GetHashCode | (Inherited from StyleMarker)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleMarker)
Protected Method | SaveViewState | (Inherited from StyleMarker)
Protected Method | TrackViewState | (Inherited from StyleMarker)
Top

See Also

Reference

StyleMarkerPositionNone Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerSeriesPoint Class Methods

StyleMarkerSeriesPoint Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleMarkerSeriesPoint Class

For a list of all members of this type, see StyleMarkerSeriesPoint members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleMarker)
Public Method | Equals | (Inherited from StyleMarker)
Public Method | GetHashCode | (Inherited from StyleMarker)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleMarker)
Protected Method | SaveViewState | (Inherited from StyleMarker)
Protected Method | TrackViewState | (Inherited from StyleMarker)
Top

See Also

Reference

StyleMarkerSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesBorder Class Methods

StyleSeriesBorder Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesBorder Class

For a list of all members of this type, see StyleSeriesBorder members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleBorder)
Public Method | Equals | (Inherited from StyleBorder)
Public Method | GetHashCode | (Inherited from StyleBorder)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleSeriesBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemLabel.ItemLabelLocation Enumeration

StyleSeriesItemLabel.ItemLabelLocation Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItemLabel.ItemLabelLocation Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum StyleSeriesItemLabel.ItemLabelLocation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As StyleSeriesItemLabel.ItemLabelLocation
C#
public enum StyleSeriesItemLabel.ItemLabelLocation : Enum

Members

Member | Description
Inside |
Outside |
Auto |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.StyleSeriesItemLabel.ItemLabelLocation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemLabel Class Fields

StyleSeriesItemLabel Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItemLabel Class

For a list of all members of this type, see StyleSeriesItemLabel members.

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

See Also

Reference

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemTextBlock Class Fields

StyleSeriesItemTextBlock Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleSeriesItemTextBlock Class

For a list of all members of this type, see StyleSeriesItemTextBlock members.

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockOverflow | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockRotationAngle | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleSeriesItemTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockAxisLabel Class Fields

StyleTextBlockAxisLabel Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockAxisLabel Class

For a list of all members of this type, see StyleTextBlockAxisLabel members.

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockOverflow | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockRotationAngle | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleTextBlockAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockAxisLabel Class Methods

StyleTextBlockAxisLabel Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockAxisLabel Class

For a list of all members of this type, see StyleTextBlockAxisLabel members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleTextBlock)
Public Method | Dispose | Overloaded. (Inherited from StyleTextBlock)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleTextBlock)
Protected Method | LoadViewState | (Inherited from StyleTextBlock)
Protected Method | ResetMaxLength | (Inherited from StyleTextBlock)
Protected Method | SaveViewState | (Inherited from StyleTextBlock)
Protected Method | ShouldSerializeMaxLength | (Inherited from StyleTextBlock)
Protected Method | TrackViewState | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleTextBlockAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockAxisLabel Class Properties

StyleTextBlockAxisLabel Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockAxisLabel Class

For a list of all members of this type, see StyleTextBlockAxisLabel members.

Public Properties

 | Name | Description
Public Property | AutoTextWrap | (Inherited from StyleTextBlock)
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleTextBlock)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleTextBlock)
Public Property | FillStyle | (Inherited from StyleTextBlock)
Public Property | MaxLength | (Inherited from StyleTextBlock)
Public Property | Overflow | (Inherited from StyleTextBlock)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties | (Inherited from StyleTextBlock)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTextBlockAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockError Class Fields

StyleTextBlockError Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockError Class

For a list of all members of this type, see StyleTextBlockError members.

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockOverflow | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockRotationAngle | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleTextBlockError Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockError Class Methods

StyleTextBlockError Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockError Class

For a list of all members of this type, see StyleTextBlockError members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleTextBlock)
Public Method | Dispose | Overloaded. (Inherited from StyleTextBlock)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleTextBlock)
Protected Method | LoadViewState | (Inherited from StyleTextBlock)
Protected Method | ResetMaxLength | (Inherited from StyleTextBlock)
Protected Method | SaveViewState | (Inherited from StyleTextBlock)
Protected Method | ShouldSerializeMaxLength | (Inherited from StyleTextBlock)
Protected Method | TrackViewState | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleTextBlockError Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockError Class Properties

StyleTextBlockError Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockError Class

For a list of all members of this type, see StyleTextBlockError members.

Public Properties

 | Name | Description
Public Property | AutoTextWrap | (Inherited from StyleTextBlock)
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleTextBlock)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleTextBlock)
Public Property | FillStyle | (Inherited from StyleTextBlock)
Public Property | MaxLength | (Inherited from StyleTextBlock)
Public Property | Overflow | (Inherited from StyleTextBlock)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties | (Inherited from StyleTextBlock)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTextBlockError Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockHidden Class Fields

StyleTextBlockHidden Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockHidden Class

For a list of all members of this type, see StyleTextBlockHidden members.

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockOverflow | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockRotationAngle | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleTextBlockHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockHidden Class Methods

StyleTextBlockHidden Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockHidden Class

For a list of all members of this type, see StyleTextBlockHidden members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleTextBlock)
Public Method | Dispose | Overloaded. (Inherited from StyleTextBlock)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleTextBlock)
Protected Method | LoadViewState | (Inherited from StyleTextBlock)
Protected Method | ResetMaxLength | (Inherited from StyleTextBlock)
Protected Method | SaveViewState | (Inherited from StyleTextBlock)
Protected Method | ShouldSerializeMaxLength | (Inherited from StyleTextBlock)
Protected Method | TrackViewState | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleTextBlockHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockTitle Class Fields

StyleTextBlockTitle Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockTitle Class

For a list of all members of this type, see StyleTextBlockTitle members.

Protected Fields

 | Name | Description
Protected Field | styleTextBlockCorners | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockOverflow | (Inherited from StyleTextBlock)
Protected Field | styleTextBlockRotationAngle | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleTextBlockTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockTitle Class Methods

StyleTextBlockTitle Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockTitle Class

For a list of all members of this type, see StyleTextBlockTitle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleTextBlock)
Public Method | Dispose | Overloaded. (Inherited from StyleTextBlock)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from StyleTextBlock)
Protected Method | LoadViewState | (Inherited from StyleTextBlock)
Protected Method | ResetMaxLength | (Inherited from StyleTextBlock)
Protected Method | SaveViewState | (Inherited from StyleTextBlock)
Protected Method | ShouldSerializeMaxLength | (Inherited from StyleTextBlock)
Protected Method | TrackViewState | (Inherited from StyleTextBlock)
Top

See Also

Reference

StyleTextBlockTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockTitle Class Properties

StyleTextBlockTitle Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTextBlockTitle Class

For a list of all members of this type, see StyleTextBlockTitle members.

Public Properties

 | Name | Description
Public Property | AutoTextWrap | (Inherited from StyleTextBlock)
Public Property | Border | (Inherited from Style)
Public Property | Corners | (Inherited from StyleTextBlock)
Public Property | Dimensions | (Inherited from LayoutStyle)
Public Property | Figure | (Inherited from StyleTextBlock)
Public Property | FillStyle | (Inherited from StyleTextBlock)
Public Property | MaxLength | (Inherited from StyleTextBlock)
Public Property | Overflow | (Inherited from StyleTextBlock)
Public Property | Position | (Inherited from LayoutStyle)
Public Property | Shadow | (Inherited from Style)
Public Property | TextProperties | (Inherited from StyleTextBlock)
Public Property | Visible | (Inherited from Style)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTextBlockTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleTick Class Methods

StyleTick Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTick Class

For a list of all members of this type, see StyleTick members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTick Class
Telerik.Reporting.Charting.Styles Namespace


StyleTickMajor Class Methods

StyleTickMajor Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTickMajor Class

For a list of all members of this type, see StyleTickMajor members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTickMajor Class
Telerik.Reporting.Charting.Styles Namespace


StyleTickMajor Class Properties

StyleTickMajor Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTickMajor Class

For a list of all members of this type, see StyleTickMajor members.

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleTick)
Public Property | EndCap | (Inherited from LineStyle)
Public Property | Length | (Inherited from StyleTick)
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | StartCap | (Inherited from LineStyle)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleTick)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTickMajor Class
Telerik.Reporting.Charting.Styles Namespace


StyleTickMinor Class Methods

StyleTickMinor Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTickMinor Class

For a list of all members of this type, see StyleTickMinor members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from LineStyle)
Public Method | Equals | (Inherited from LineStyle)
Public Method | GetHashCode | (Inherited from LineStyle)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTickMinor Class
Telerik.Reporting.Charting.Styles Namespace


StyleTitleBorder Class Methods

StyleTitleBorder Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTitleBorder Class

For a list of all members of this type, see StyleTitleBorder members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleBorder)
Public Method | Equals | (Inherited from StyleBorder)
Public Method | GetHashCode | (Inherited from StyleBorder)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTitleBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleTitleBorder Class Properties

StyleTitleBorder Class Properties
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleTitleBorder Class

For a list of all members of this type, see StyleTitleBorder members.

Public Properties

 | Name | Description
Public Property | Color | (Inherited from StyleBorder)
Public Property | PenStyle | (Inherited from StyleBorder)
Public Property | Visible | (Inherited from StyleBorder)
Public Property | Width | (Inherited from StyleBorder)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

StyleTitleBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleYAxisLabel Class Fields

StyleYAxisLabel Class Fields
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleYAxisLabel Class

For a list of all members of this type, see StyleYAxisLabel members.

Protected Fields

 | Name | Description
Protected Field | styleLabelCorners | (Inherited from StyleLabel)
Top

See Also

Reference

StyleYAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleYAxisLabel Class Methods

StyleYAxisLabel Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : StyleYAxisLabel Class

For a list of all members of this type, see StyleYAxisLabel members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from StyleLabel)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | LoadViewState | (Inherited from StyleLabel)
Protected Method | SaveViewState | (Inherited from StyleLabel)
Protected Method | TrackViewState | (Inherited from StyleLabel)
Top

See Also

Reference

StyleYAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


TextDirection Enumeration

TextDirection Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : TextDirection Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum TextDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TextDirection
C#
public enum TextDirection : Enum

Members

Member | Description
RightToLeft |
LeftToRight |
TopToBottom |
BottomToTop |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.TextDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisItem Class Methods

TextPropertiesAxisItem Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesAxisItem Class

For a list of all members of this type, see TextPropertiesAxisItem members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from TextProperties)
Public Method | Dispose | Overloaded. (Inherited from TextProperties)
Public Method | Equals | (Inherited from TextProperties)
Public Method | GetHashCode | (Inherited from TextProperties)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from TextProperties)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesAxisItem Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisLabel Class Methods

TextPropertiesAxisLabel Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesAxisLabel Class

For a list of all members of this type, see TextPropertiesAxisLabel members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from TextProperties)
Public Method | Dispose | Overloaded. (Inherited from TextProperties)
Public Method | Equals | (Inherited from TextProperties)
Public Method | GetHashCode | (Inherited from TextProperties)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from TextProperties)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesError Class Methods

TextPropertiesError Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesError Class

For a list of all members of this type, see TextPropertiesError members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from TextProperties)
Public Method | Dispose | Overloaded. (Inherited from TextProperties)
Public Method | Equals | (Inherited from TextProperties)
Public Method | GetHashCode | (Inherited from TextProperties)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from TextProperties)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesError Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesSeriesItem Class Methods

TextPropertiesSeriesItem Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesSeriesItem Class

For a list of all members of this type, see TextPropertiesSeriesItem members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from TextProperties)
Public Method | Dispose | Overloaded. (Inherited from TextProperties)
Public Method | Equals | (Inherited from TextProperties)
Public Method | GetHashCode | (Inherited from TextProperties)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from TextProperties)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesTitle Class Methods

TextPropertiesTitle Class Methods
[image]
Telerik.Reporting.Charting.Styles Namespace : TextPropertiesTitle Class

For a list of all members of this type, see TextPropertiesTitle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from TextProperties)
Public Method | Dispose | Overloaded. (Inherited from TextProperties)
Public Method | Equals | (Inherited from TextProperties)
Public Method | GetHashCode | (Inherited from TextProperties)
Public Method | SetDirty | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Public Method | ToString | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | Finalize | (Inherited from TextProperties)
Protected Method | LoadViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | SaveViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Protected Method | TrackViewState | (Inherited from Telerik.Reporting.Charting.StateManagedObject)
Top

See Also

Reference

TextPropertiesTitle Class
Telerik.Reporting.Charting.Styles Namespace


TextQuality Enumeration

TextQuality Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : TextQuality Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum TextQuality
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TextQuality
C#
public enum TextQuality : Enum

Members

Member | Description
SystemDefault |
SingleBitPerPixel |
SingleBitPerPixelGridFit |
AntiAlias |
AntiAliasGridFit |
ClearTypeGridFit |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.TextQuality

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


TickLocation Enumeration

TickLocation Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : TickLocation Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum TickLocation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TickLocation
C#
public enum TickLocation : Enum

Members

Member | Description
Inside |
Outside |
Cross |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.TickLocation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


UnitType Enumeration

UnitType Enumeration
[image]
Telerik.Reporting.Charting.Styles Namespace : UnitType Enumeration

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum UnitType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As UnitType
C#
public enum UnitType : Enum

Members

Member | Description
Pixel |
Percentage |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.Styles.UnitType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting.Styles Namespace


Telerik.Reporting.Charting.Styles Namespace

Telerik.Reporting.Charting.Styles Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
ChartMargins |
ChartMarginsLegend |
ChartMarginsPlotArea |
ChartMarginsTitle |
ChartPaddings |
ChartPaddingsLegend |
ChartPaddingsTitle |
ChartSkin |
Corners |
Dimensions |
DimensionsChart |
DimensionsLegend |
DimensionsMarker |
DimensionsPlotArea |
DimensionsPointMarker |
DimensionsSeriesPointMark |
DimensionsTitle |
EmptyValue |
FiguresCollection |
FillSettings |
FillSettingsVerticalGradient |
FillStyle |
FillStyleChart |
FillStyleMarkedZones |
FillStylePlotArea |
FillStyleSeries |
FillStyleSeriesPoint |
FillStyleTitle |
LayoutDecoratorBase |
LayoutStyle |
LineStyle |
Position |
PositionBottom |
PositionCenter |
PositionLeft |
PositionRight |
PositionTop |
PositionTopLeft |
PositionTopRight |
ScaleBreaksLineStyle |
ShadowStyle |
ShadowStyleChart |
Style |
StyleAxis |
StyleAxisItemText |
StyleAxisLabel |
StyleAxisX |
StyleAxisY |
StyleBorder |
StyleChart |
StyleChartBorder |
StyleChartDataTable |
StyleDataTableBorder |
StyleEmptyLineSeries |
StyleExtendedLabel |
StyleGridLine |
StyleGridLineHidden |
StyleGridLineMajor |
StyleGridLineMajorXAxis |
StyleItemLabelConnector |
StyleLabel |
StyleLabelEmptySeriesMessage |
StyleLabelHidden |
StyleLabelLegend |
StyleLabelTitle |
StyleLegendBorder |
StyleLineSeries |
StyleMarkedZone |
StyleMarker |
StyleMarkerEmptyValue |
StyleMarkerLegend |
StyleMarkerPositionNone |
StyleMarkerSeriesPoint |
StylePlotArea |
StyleSeries |
StyleSeriesBorder |
StyleSeriesItem |
StyleSeriesItemLabel |
StyleSeriesItemTextBlock |
StyleTextBlock |
StyleTextBlockAxisLabel |
StyleTextBlockError |
StyleTextBlockHidden |
StyleTextBlockTitle |
StyleTick |
StyleTickMajor |
StyleTickMinor |
StyleTitleBorder |
StyleYAxisLabel |
TextProperties |
TextPropertiesAxisItem |
TextPropertiesAxisLabel |
TextPropertiesError |
TextPropertiesSeriesItem |
TextPropertiesTitle |
Unit |

Structures

Structure | Description
DefaultFigures |

Enumerations

Enumeration | Description
AlignedPositions |
AutoTextWrap |
ChartAxisLayoutMode |
ChartAxisVisibility |
ChartAxisVisibleValues |
ChartGridLineLayoutMode |
ChartValueFormat |
CornerType |
DrawType |
EmtyValuesMode |
FillType |
GradientFillStyle |
ImageAlignModes |
ImageDrawMode |
ImageQuality |
ImageTileModes |
LabelItemsCompositionTypes |
LabelLocation |
MinorTickCount |
Orientation |
Overflow |
PlacementDirection |
ShadowPosition |
StyleSeriesItemLabel.ItemLabelLocation |
TextDirection |
TextQuality |
TickLocation |
UnitType |

See Also

Reference

Telerik.Reporting Assembly


Telerik.Reporting.Charting.Styles Namespace Inheritance Hierarchy

Telerik.Reporting.Charting.Styles Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.Styles.Corners
Telerik.Reporting.Charting.Styles.Dimensions
Telerik.Reporting.Charting.Styles.DimensionsChart
Telerik.Reporting.Charting.Styles.DimensionsLegend
Telerik.Reporting.Charting.Styles.DimensionsMarker
Telerik.Reporting.Charting.Styles.DimensionsPointMarker
Telerik.Reporting.Charting.Styles.DimensionsPlotArea
Telerik.Reporting.Charting.Styles.DimensionsSeriesPointMark
Telerik.Reporting.Charting.Styles.DimensionsTitle
Telerik.Reporting.Charting.Styles.EmptyValue
Telerik.Reporting.Charting.Styles.FillSettings
Telerik.Reporting.Charting.Styles.FillSettingsVerticalGradient
Telerik.Reporting.Charting.Styles.FillStyle
Telerik.Reporting.Charting.Styles.FillStyleChart
Telerik.Reporting.Charting.Styles.FillStyleMarkedZones
Telerik.Reporting.Charting.Styles.FillStylePlotArea
Telerik.Reporting.Charting.Styles.FillStyleSeries
Telerik.Reporting.Charting.Styles.FillStyleSeriesPoint
Telerik.Reporting.Charting.Styles.FillStyleTitle
Telerik.Reporting.Charting.Styles.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles.ChartMargins
Telerik.Reporting.Charting.Styles.ChartMarginsLegend
Telerik.Reporting.Charting.Styles.ChartMarginsPlotArea
Telerik.Reporting.Charting.Styles.ChartMarginsTitle
Telerik.Reporting.Charting.Styles.ChartPaddings
Telerik.Reporting.Charting.Styles.ChartPaddingsLegend
Telerik.Reporting.Charting.Styles.ChartPaddingsTitle
Telerik.Reporting.Charting.Styles.Position
Telerik.Reporting.Charting.Styles.PositionBottom
Telerik.Reporting.Charting.Styles.PositionCenter
Telerik.Reporting.Charting.Styles.PositionLeft
Telerik.Reporting.Charting.Styles.PositionRight
Telerik.Reporting.Charting.Styles.PositionTop
Telerik.Reporting.Charting.Styles.PositionTopLeft
Telerik.Reporting.Charting.Styles.PositionTopRight
Telerik.Reporting.Charting.Styles.ShadowStyle
Telerik.Reporting.Charting.Styles.ShadowStyleChart
Telerik.Reporting.Charting.Styles.Style
Telerik.Reporting.Charting.Styles.LayoutStyle
Telerik.Reporting.Charting.Styles.StyleChart
Telerik.Reporting.Charting.Styles.StyleChartDataTable
Telerik.Reporting.Charting.Styles.StyleLabel
Telerik.Reporting.Charting.Styles.StyleExtendedLabel
Telerik.Reporting.Charting.Styles.StyleLabelLegend
Telerik.Reporting.Charting.Styles.StyleLabelEmptySeriesMessage
Telerik.Reporting.Charting.Styles.StyleLabelHidden
Telerik.Reporting.Charting.Styles.StyleAxisLabel
Telerik.Reporting.Charting.Styles.StyleYAxisLabel
Telerik.Reporting.Charting.Styles.StyleLabelTitle
Telerik.Reporting.Charting.Styles.StyleSeriesItemLabel
Telerik.Reporting.Charting.Styles.StyleMarker
Telerik.Reporting.Charting.Styles.StyleMarkerEmptyValue
Telerik.Reporting.Charting.Styles.StyleMarkerLegend
Telerik.Reporting.Charting.Styles.StyleMarkerPositionNone
Telerik.Reporting.Charting.Styles.StyleMarkerSeriesPoint
Telerik.Reporting.Charting.Styles.StylePlotArea
Telerik.Reporting.Charting.Styles.StyleTextBlock
Telerik.Reporting.Charting.Styles.StyleAxisItemText
Telerik.Reporting.Charting.Styles.StyleSeriesItemTextBlock
Telerik.Reporting.Charting.Styles.StyleTextBlockAxisLabel
Telerik.Reporting.Charting.Styles.StyleTextBlockError
Telerik.Reporting.Charting.Styles.StyleTextBlockHidden
Telerik.Reporting.Charting.Styles.StyleTextBlockTitle
Telerik.Reporting.Charting.Styles.StyleMarkedZone
Telerik.Reporting.Charting.Styles.StyleSeries
Telerik.Reporting.Charting.Styles.StyleSeriesItem
Telerik.Reporting.Charting.Styles.StyleBorder
Telerik.Reporting.Charting.Styles.LineStyle
Telerik.Reporting.Charting.Styles.ScaleBreaksLineStyle
Telerik.Reporting.Charting.Styles.StyleAxis
Telerik.Reporting.Charting.Styles.StyleAxisX
Telerik.Reporting.Charting.Styles.StyleAxisY
Telerik.Reporting.Charting.Styles.StyleGridLine
Telerik.Reporting.Charting.Styles.StyleGridLineHidden
Telerik.Reporting.Charting.Styles.StyleGridLineMajor
Telerik.Reporting.Charting.Styles.StyleGridLineMajorXAxis
Telerik.Reporting.Charting.Styles.StyleItemLabelConnector
Telerik.Reporting.Charting.Styles.StyleLineSeries
Telerik.Reporting.Charting.Styles.StyleEmptyLineSeries
Telerik.Reporting.Charting.Styles.StyleTick
Telerik.Reporting.Charting.Styles.StyleTickMajor
Telerik.Reporting.Charting.Styles.StyleTickMinor
Telerik.Reporting.Charting.Styles.StyleChartBorder
Telerik.Reporting.Charting.Styles.StyleDataTableBorder
Telerik.Reporting.Charting.Styles.StyleLegendBorder
Telerik.Reporting.Charting.Styles.StyleSeriesBorder
Telerik.Reporting.Charting.Styles.StyleTitleBorder
Telerik.Reporting.Charting.Styles.TextProperties
Telerik.Reporting.Charting.Styles.TextPropertiesAxisItem
Telerik.Reporting.Charting.Styles.TextPropertiesAxisLabel
Telerik.Reporting.Charting.Styles.TextPropertiesError
Telerik.Reporting.Charting.Styles.TextPropertiesSeriesItem
Telerik.Reporting.Charting.Styles.TextPropertiesTitle
Telerik.Reporting.Charting.Styles.ChartSkin
Telerik.Reporting.Charting.Styles.FiguresCollection
Telerik.Reporting.Charting.Styles.Unit

See Also

Reference

Telerik.Reporting Assembly


TableRenderType Enumeration

TableRenderType Enumeration
[image]
Telerik.Reporting.Charting Namespace : TableRenderType Enumeration

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum TableRenderType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TableRenderType
C#
public enum TableRenderType : Enum

Members

Member | Description
AutoSize |
CellFixedSize |
TableFixedSize |
PlotAreaRelative |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Charting.TableRenderType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Charting Namespace


TextBlockAxisItem Class Fields

TextBlockAxisItem Class Fields
[image]
Telerik.Reporting.Charting Namespace : TextBlockAxisItem Class

For a list of all members of this type, see TextBlockAxisItem members.

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

See Also

Reference

TextBlockAxisItem Class
Telerik.Reporting.Charting Namespace


TextBlockAxisItem Class Methods

TextBlockAxisItem Class Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockAxisItem Class

For a list of all members of this type, see TextBlockAxisItem members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockAxisItem Class
Telerik.Reporting.Charting Namespace


TextBlockAxisItem Class Properties

TextBlockAxisItem Class Properties
[image]
Telerik.Reporting.Charting Namespace : TextBlockAxisItem Class

For a list of all members of this type, see TextBlockAxisItem members.

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | (Inherited from TextBlock)
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

TextBlockAxisItem Class
Telerik.Reporting.Charting Namespace


TextBlockEmptySeriesMessage Class Fields

TextBlockEmptySeriesMessage Class Fields
[image]
Telerik.Reporting.Charting Namespace : TextBlockEmptySeriesMessage Class

For a list of all members of this type, see TextBlockEmptySeriesMessage members.

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

See Also

Reference

TextBlockEmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


TextBlockEmptySeriesMessage Class Methods

TextBlockEmptySeriesMessage Class Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockEmptySeriesMessage Class

For a list of all members of this type, see TextBlockEmptySeriesMessage members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockEmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


TextBlockHidden Class Fields

TextBlockHidden Class Fields
[image]
Telerik.Reporting.Charting Namespace : TextBlockHidden Class

For a list of all members of this type, see TextBlockHidden members.

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

See Also

Reference

TextBlockHidden Class
Telerik.Reporting.Charting Namespace


TextBlockHidden Class Methods

TextBlockHidden Class Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockHidden Class

For a list of all members of this type, see TextBlockHidden members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockHidden Class
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Class Fields

TextBlockLabelItem Class Fields
[image]
Telerik.Reporting.Charting Namespace : TextBlockLabelItem Class

For a list of all members of this type, see TextBlockLabelItem members.

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

See Also

Reference

TextBlockLabelItem Class
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Class Methods

TextBlockLabelItem Class Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockLabelItem Class

For a list of all members of this type, see TextBlockLabelItem members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockLabelItem Class
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Class Properties

TextBlockLabelItem Class Properties
[image]
Telerik.Reporting.Charting Namespace : TextBlockLabelItem Class

For a list of all members of this type, see TextBlockLabelItem members.

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | (Inherited from TextBlock)
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

TextBlockLabelItem Class
Telerik.Reporting.Charting Namespace


TextBlockLegend Class Fields

TextBlockLegend Class Fields
[image]
Telerik.Reporting.Charting Namespace : TextBlockLegend Class

For a list of all members of this type, see TextBlockLegend members.

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

See Also

Reference

TextBlockLegend Class
Telerik.Reporting.Charting Namespace


TextBlockLegend Class Methods

TextBlockLegend Class Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockLegend Class

For a list of all members of this type, see TextBlockLegend members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockLegend Class
Telerik.Reporting.Charting Namespace


TextBlockLegend Class Properties

TextBlockLegend Class Properties
[image]
Telerik.Reporting.Charting Namespace : TextBlockLegend Class

For a list of all members of this type, see TextBlockLegend members.

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | (Inherited from TextBlock)
Public Property | Visible | (Inherited from TextBlockHidden)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

TextBlockLegend Class
Telerik.Reporting.Charting Namespace


TextBlockMarkedZone Class Fields

TextBlockMarkedZone Class Fields
[image]
Telerik.Reporting.Charting Namespace : TextBlockMarkedZone Class

For a list of all members of this type, see TextBlockMarkedZone members.

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

See Also

Reference

TextBlockMarkedZone Class
Telerik.Reporting.Charting Namespace


TextBlockMarkedZone Class Methods

TextBlockMarkedZone Class Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockMarkedZone Class

For a list of all members of this type, see TextBlockMarkedZone members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockMarkedZone Class
Telerik.Reporting.Charting Namespace


TextBlockMarkedZone Class Properties

TextBlockMarkedZone Class Properties
[image]
Telerik.Reporting.Charting Namespace : TextBlockMarkedZone Class

For a list of all members of this type, see TextBlockMarkedZone members.

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | (Inherited from TextBlock)
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

TextBlockMarkedZone Class
Telerik.Reporting.Charting Namespace


TextBlockSeriesItem Class Fields

TextBlockSeriesItem Class Fields
[image]
Telerik.Reporting.Charting Namespace : TextBlockSeriesItem Class

For a list of all members of this type, see TextBlockSeriesItem members.

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

See Also

Reference

TextBlockSeriesItem Class
Telerik.Reporting.Charting Namespace


TextBlockSeriesItem Class Methods

TextBlockSeriesItem Class Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockSeriesItem Class

For a list of all members of this type, see TextBlockSeriesItem members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockSeriesItem Class
Telerik.Reporting.Charting Namespace


TextBlockSeriesItem Class Properties

TextBlockSeriesItem Class Properties
[image]
Telerik.Reporting.Charting Namespace : TextBlockSeriesItem Class

For a list of all members of this type, see TextBlockSeriesItem members.

Public Properties

 | Name | Description
Public Property | Appearance | (Inherited from TextBlock)
Public Property | Container | (Inherited from RenderedObject)
Public Property | Parent | (Inherited from TextBlock)
Public Property | Text | (Inherited from TextBlock)
Public Property | Visible | (Inherited from TextBlock)
Top

Protected Properties

 | Name | Description
Protected Property | ViewStateIgnoresCase | (Inherited from StateManagedObject)
Top

See Also

Reference

TextBlockSeriesItem Class
Telerik.Reporting.Charting Namespace


TextBlockTitle Class Fields

TextBlockTitle Class Fields
[image]
Telerik.Reporting.Charting Namespace : TextBlockTitle Class

For a list of all members of this type, see TextBlockTitle members.

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

See Also

Reference

TextBlockTitle Class
Telerik.Reporting.Charting Namespace


TextBlockTitle Class Methods

TextBlockTitle Class Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockTitle Class

For a list of all members of this type, see TextBlockTitle members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockTitle Class
Telerik.Reporting.Charting Namespace


TextBlockXAxisLabel Class Fields

TextBlockXAxisLabel Class Fields
[image]
Telerik.Reporting.Charting Namespace : TextBlockXAxisLabel Class

For a list of all members of this type, see TextBlockXAxisLabel members.

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

See Also

Reference

TextBlockXAxisLabel Class
Telerik.Reporting.Charting Namespace


TextBlockXAxisLabel Class Methods

TextBlockXAxisLabel Class Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockXAxisLabel Class

For a list of all members of this type, see TextBlockXAxisLabel members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockXAxisLabel Class
Telerik.Reporting.Charting Namespace


TextBlockYAxisLabel Class Fields

TextBlockYAxisLabel Class Fields
[image]
Telerik.Reporting.Charting Namespace : TextBlockYAxisLabel Class

For a list of all members of this type, see TextBlockYAxisLabel members.

Protected Fields

 | Name | Description
Protected Field | DEFAULT_TEXT | (Inherited from TextBlock)
Protected Field | objectContainer | (Inherited from RenderedObject)
Protected Field | textBlockCalculatedMaxLength | (Inherited from TextBlock)
Protected Field | textBlockParent | (Inherited from TextBlock)
Top

See Also

Reference

TextBlockYAxisLabel Class
Telerik.Reporting.Charting Namespace


TextBlockYAxisLabel Class Methods

TextBlockYAxisLabel Class Methods
[image]
Telerik.Reporting.Charting Namespace : TextBlockYAxisLabel Class

For a list of all members of this type, see TextBlockYAxisLabel members.

Public Methods

 | Name | Description
Public Method | BringForward | (Inherited from RenderedObject)
Public Method | BringToFront | (Inherited from RenderedObject)
Public Method | CopyFrom | (Inherited from TextBlock)
Public Method | Dispose | Overloaded. (Inherited from TextBlock)
Public Method | GetOrder | (Inherited from RenderedObject)
Public Method | Remove | (Inherited from RenderedObject)
Public Method | SendBackward | (Inherited from RenderedObject)
Public Method | SendToBack | (Inherited from RenderedObject)
Public Method | SetDirty | (Inherited from StateManagedObject)
Public Method | SetOrder | (Inherited from RenderedObject)
Public Method | ToString | (Inherited from StateManagedObject)
Top

Protected Methods

 | Name | Description
Protected Method | CloneState | (Inherited from StateManagedObject)
Protected Method | Finalize | (Inherited from TextBlock)
Protected Method | GetOffsetBottom | (Inherited from LayoutElement)
Protected Method | GetOffsetLeft | (Inherited from LayoutElement)
Protected Method | GetOffsetRight | (Inherited from LayoutElement)
Protected Method | GetOffsetTop | (Inherited from LayoutElement)
Protected Method | LoadViewState | (Inherited from LayoutElement)
Protected Method | SaveViewState | (Inherited from LayoutElement)
Protected Method | TrackViewState | (Inherited from LayoutElement)
Top

See Also

Reference

TextBlockYAxisLabel Class
Telerik.Reporting.Charting Namespace


Telerik.Reporting.Charting Namespace

Telerik.Reporting.Charting Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
ActiveRegion |
AxisLabel |
AxisLabelHidden |
AxisSegment |
AxisSegmentCollection |
AxisYLabel |
BindableLegendItem |
Chart |
ChartAxis |
ChartAxisItem |
ChartAxisItemsCollection |
ChartBaseLabel |
ChartClickEventArgs |
ChartDataTable |
ChartException |
Generic ChartingStateManagedCollection |
ChartItemDataBoundEventArgs |
ChartLabel |
ChartLabelsCollection |
ChartLegend |
ChartMarkedZone |
ChartMarkedZonesCollection |
ChartMarker |
ChartPlotArea |
ChartSeries |
ChartSeriesCollection |
ChartSeriesItem |
ChartSeriesItemsCollection |
ChartTitle |
ChartXAxis |
ChartYAxis |
ColorBlend |
ComplexDataSetClass |
CustomFigure |
CustomFiguresCollection |
CustomPalettesCollection |
DataManager |
DataSetClass |
DemoData |
DoubleCollection |
DummyWebControl |
EmptySeriesMessage |
ExtendedLabel |
GradientElement |
LabelItem |
LayoutElement |
MarkedZoneLabel |
Palette |
PaletteItem |
PaletteItemsCollection |
Product |
ProductsBL |
ProductsList |
RenderedObject |
ScaleBreak |
SeriesItemLabel |
StateManagedObject |
TextBlock |
TextBlockAxisItem |
TextBlockEmptySeriesMessage |
TextBlockHidden |
TextBlockLabelItem |
TextBlockLegend |
TextBlockMarkedZone |
TextBlockSeriesItem |
TextBlockTitle |
TextBlockXAxisLabel |
TextBlockYAxisLabel |

Interfaces

Interface | Description
IActiveRegion |
IChartComponent |
IChartingStateManagedItem |
IChartingStateManager |
IChartSupportsScaling |
IContainer |
IDeserializableCollection |
IOrdering |

Structures

Structure | Description
PalettesCollection |

Delegates

Delegate | Description
RegionClickEventHandler |

Enumerations

Enumeration | Description
ChartElementLocation |
ChartSeriesLegendDisplayMode |
ChartSeriesOrientation |
ChartSeriesType |
ChartYAxisMode |
ChartYAxisType |
ContentHorizontalAlign |
ContentVerticalAlign |
ScaleBreakLineType |
TableRenderType |

See Also

Reference

Telerik.Reporting Assembly


Telerik.Reporting.Charting Namespace Inheritance Hierarchy

Telerik.Reporting.Charting Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.Reporting.Charting.DoubleCollection
Telerik.Reporting.Charting.ProductsList
System.EventArgs
Telerik.Reporting.Charting.ChartClickEventArgs
Telerik.Reporting.Charting.ChartItemDataBoundEventArgs
System.Exception
System.ApplicationException
Telerik.Reporting.Charting.ChartException
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.Reporting.Charting.DummyWebControl
Telerik.Reporting.Charting.ChartingStateManagedCollection<T>
Telerik.Reporting.Charting.ChartingStateManagedCollection<AxisSegment>
Telerik.Reporting.Charting.AxisSegmentCollection
Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartAxisItem>
Telerik.Reporting.Charting.ChartAxisItemsCollection
Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartMarkedZone>
Telerik.Reporting.Charting.ChartMarkedZonesCollection
Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeries>
Telerik.Reporting.Charting.ChartSeriesCollection
Telerik.Reporting.Charting.ChartingStateManagedCollection<ChartSeriesItem>
Telerik.Reporting.Charting.ChartSeriesItemsCollection
Telerik.Reporting.Charting.ChartingStateManagedCollection<CustomFigure>
Telerik.Reporting.Charting.CustomFiguresCollection
Telerik.Reporting.Charting.ChartingStateManagedCollection<GradientElement>
Telerik.Reporting.Charting.ColorBlend
Telerik.Reporting.Charting.ChartingStateManagedCollection<LabelItem>
Telerik.Reporting.Charting.ChartLabelsCollection
Telerik.Reporting.Charting.ChartingStateManagedCollection<Palette>
Telerik.Reporting.Charting.CustomPalettesCollection
Telerik.Reporting.Charting.ChartingStateManagedCollection<PaletteItem>
Telerik.Reporting.Charting.PaletteItemsCollection
Telerik.Reporting.Charting.ComplexDataSetClass
Telerik.Reporting.Charting.DataManager
Telerik.Reporting.Charting.DataSetClass
Telerik.Reporting.Charting.DemoData
Telerik.Reporting.Charting.Product
Telerik.Reporting.Charting.ProductsBL
Telerik.Reporting.Charting.StateManagedObject
Telerik.Reporting.Charting.ActiveRegion
Telerik.Reporting.Charting.AxisSegment
Telerik.Reporting.Charting.CustomFigure
Telerik.Reporting.Charting.GradientElement
Telerik.Reporting.Charting.Palette
Telerik.Reporting.Charting.PaletteItem
Telerik.Reporting.Charting.RenderedObject
Telerik.Reporting.Charting.ChartAxis
Telerik.Reporting.Charting.ChartXAxis
Telerik.Reporting.Charting.ChartYAxis
Telerik.Reporting.Charting.ChartMarkedZone
Telerik.Reporting.Charting.ChartSeries
Telerik.Reporting.Charting.ChartSeriesItem
Telerik.Reporting.Charting.LayoutElement
Telerik.Reporting.Charting.Chart
Telerik.Reporting.Charting.ChartBaseLabel
Telerik.Reporting.Charting.ChartLabel
Telerik.Reporting.Charting.AxisLabelHidden
Telerik.Reporting.Charting.AxisLabel
Telerik.Reporting.Charting.AxisYLabel
Telerik.Reporting.Charting.ChartAxisItem
Telerik.Reporting.Charting.ChartTitle
Telerik.Reporting.Charting.EmptySeriesMessage
Telerik.Reporting.Charting.LabelItem
Telerik.Reporting.Charting.BindableLegendItem
Telerik.Reporting.Charting.MarkedZoneLabel
Telerik.Reporting.Charting.ExtendedLabel
Telerik.Reporting.Charting.ChartLegend
Telerik.Reporting.Charting.SeriesItemLabel
Telerik.Reporting.Charting.ChartDataTable
Telerik.Reporting.Charting.ChartMarker
Telerik.Reporting.Charting.ChartPlotArea
Telerik.Reporting.Charting.TextBlock
Telerik.Reporting.Charting.TextBlockAxisItem
Telerik.Reporting.Charting.TextBlockEmptySeriesMessage
Telerik.Reporting.Charting.TextBlockHidden
Telerik.Reporting.Charting.TextBlockLegend
Telerik.Reporting.Charting.TextBlockLabelItem
Telerik.Reporting.Charting.TextBlockMarkedZone
Telerik.Reporting.Charting.TextBlockSeriesItem
Telerik.Reporting.Charting.TextBlockTitle
Telerik.Reporting.Charting.TextBlockXAxisLabel
Telerik.Reporting.Charting.TextBlockYAxisLabel
Telerik.Reporting.Charting.ScaleBreak

See Also

Reference

Telerik.Reporting Assembly


CheckBox Class Events

CheckBox Class Events
[image]
Telerik.Reporting Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

CheckBox Class
Telerik.Reporting Namespace


CheckBox Class Methods

CheckBox Class Methods
[image]
Telerik.Reporting Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

CheckBox Class
Telerik.Reporting Namespace


FilterCollection Class Properties

FilterCollection Class Properties
[image]
Telerik.Reporting.Data Namespace : FilterCollection Class

For a list of all members of this type, see FilterCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<Filter>)
Top

See Also

Reference

FilterCollection Class
Telerik.Reporting.Data Namespace


FilterOperator Enumeration

FilterOperator Enumeration
[image]
Telerik.Reporting.Data Namespace : FilterOperator Enumeration

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum FilterOperator
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FilterOperator
C#
public enum FilterOperator : Enum

Members

Member | Description
Equal |
Like |
NotEqual |
GreaterThan |
GreaterOrEqual |
LessThan |
LessOrEqual |
TopN |
BottomN |
TopPercent |
BottomPercent |
In |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Data.FilterOperator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Data Namespace


GroupCollection Class Properties

GroupCollection Class Properties
[image]
Telerik.Reporting.Data Namespace : GroupCollection Class

For a list of all members of this type, see GroupCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<Group>)
Top

See Also

Reference

GroupCollection Class
Telerik.Reporting.Data Namespace


GroupingCollection Class Properties

GroupingCollection Class Properties
[image]
Telerik.Reporting.Data Namespace : GroupingCollection Class

For a list of all members of this type, see GroupingCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<Grouping>)
Top

See Also

Reference

GroupingCollection Class
Telerik.Reporting.Data Namespace


SortDirection Enumeration

SortDirection Enumeration
[image]
Telerik.Reporting.Data Namespace : SortDirection Enumeration

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum SortDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SortDirection
C#
public enum SortDirection : Enum

Members

Member | Description
Asc |
Desc |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Data.SortDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Data Namespace


SortingCollection Class Properties

SortingCollection Class Properties
[image]
Telerik.Reporting.Data Namespace : SortingCollection Class

For a list of all members of this type, see SortingCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<Sorting>)
Top

See Also

Reference

SortingCollection Class
Telerik.Reporting.Data Namespace


SortOrder Enumeration

SortOrder Enumeration
[image]
Telerik.Reporting.Data Namespace : SortOrder Enumeration

Specifies how items in a list are sorted.

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum SortOrder
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SortOrder
C#
public enum SortOrder : Enum

Members

Member | Description
Ascending | The items are sorted in ascending order.
Descending | The items are sorted in ascending order.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Data.SortOrder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Data Namespace


Telerik.Reporting.Data Namespace

Telerik.Reporting.Data Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
Filter |
FilterCollection |
FilterExpression | Represents a string expression used for filtering.
FilterExpressionCollection | Represents a collection of FilterExpression objects.
GroupCollection |
GroupCollectionConverter |
GroupExpression | Represents an expression used for grouping by a field name from the data source.
GroupExpressionCollection | Represents a collection of GroupExpression objects.
Grouping |
GroupingCollection |
SortExpression | Represents an expression used for sorting by a field name and a sort order.
SortExpressionCollection | Represents a collection of SortExpression objects.
Sorting |
SortingCollection |

Enumerations

Enumeration | Description
FilterOperator |
SortDirection |
SortOrder | Specifies how items in a list are sorted.

See Also

Reference

Telerik.Reporting Assembly


Telerik.Reporting.Data Namespace Inheritance Hierarchy

Telerik.Reporting.Data Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.Reporting.Data.FilterExpressionCollection
Telerik.Reporting.Data.GroupExpressionCollection
Telerik.Reporting.Data.SortExpressionCollection
System.Collections.ObjectModel.Collection<Filter>
Telerik.Reporting.Data.FilterCollection
System.Collections.ObjectModel.Collection<Grouping>
Telerik.Reporting.Data.GroupingCollection
System.Collections.ObjectModel.Collection<Sorting>
Telerik.Reporting.Data.SortingCollection
System.Collections.ObjectModel.Collection<Group>
Telerik.Reporting.Data.GroupCollection
System.ComponentModel.TypeConverter
Telerik.Reporting.Data.GroupCollectionConverter
Telerik.Reporting.Data.Filter
Telerik.Reporting.Data.FilterExpression
Telerik.Reporting.Data.GroupExpression
Telerik.Reporting.Data.Grouping
Telerik.Reporting.Data.SortExpression
Telerik.Reporting.Data.Sorting

See Also

Reference

Telerik.Reporting Assembly


DetailSection Class Events

DetailSection Class Events
[image]
Telerik.Reporting Namespace : DetailSection Class

For a list of all members of this type, see DetailSection members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

DetailSection Class
Telerik.Reporting Namespace


DetailSection Class Methods

DetailSection Class Methods
[image]
Telerik.Reporting Namespace : DetailSection Class

For a list of all members of this type, see DetailSection members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

DetailSection Class
Telerik.Reporting Namespace


AttributeSelector Class Fields

AttributeSelector Class Fields
[image]
Telerik.Reporting.Drawing Namespace : AttributeSelector Class

For a list of all members of this type, see AttributeSelector members.

Protected Fields

 | Name | Description
Protected Field | attributeName | The name of the property to match. (Inherited from AttributeSelectorBase)
Protected Field | attributeValue | The value of the property to match. (Inherited from AttributeSelectorBase)
Protected Field | descriptor | The property descriptor associated with the property that this selector matches. (Inherited from AttributeSelectorBase)
Protected Field | initialized | (Inherited from TypeSelector)
Top

See Also

Reference

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


AttributeSelectorBase Class Properties

AttributeSelectorBase Class Properties
[image]
Telerik.Reporting.Drawing Namespace : AttributeSelectorBase Class

For a list of all members of this type, see AttributeSelectorBase members.

Public Properties

 | Name | Description
Public Property | Type | Gets or sets the Type that this selector matches. (Inherited from TypeSelector)
Top

See Also

Reference

AttributeSelectorBase Class
Telerik.Reporting.Drawing Namespace


BackgroundImage Class Methods

BackgroundImage Class Methods
[image]
Telerik.Reporting.Drawing Namespace : BackgroundImage Class

For a list of all members of this type, see BackgroundImage members.

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

BackgroundImage Class
Telerik.Reporting.Drawing Namespace


BackgroundRepeat Enumeration

BackgroundRepeat Enumeration
[image]
Telerik.Reporting.Drawing Namespace : BackgroundRepeat Enumeration

Indicates how a background image will be repeated.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum BackgroundRepeat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BackgroundRepeat
C#
public enum BackgroundRepeat : Enum

Members

Member | Description
NoRepeat | The background-image will be displayed only once.
RepeatX | The background image will be repeated horizontally.
RepeatY | The background image will be repeated vertically.
Repeat | The background image will be repeated vertically and horizontally.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Drawing.BackgroundRepeat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Drawing Namespace


BorderColor Class Methods

BorderColor Class Methods
[image]
Telerik.Reporting.Drawing Namespace : BorderColor Class

For a list of all members of this type, see BorderColor members.

Public Methods

 | Name | Description
Public Method | ToString | Overloaded. (Inherited from BorderBase)
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

BorderColor Class
Telerik.Reporting.Drawing Namespace


BorderStyle Class Methods

BorderStyle Class Methods
[image]
Telerik.Reporting.Drawing Namespace : BorderStyle Class

For a list of all members of this type, see BorderStyle members.

Public Methods

 | Name | Description
Public Method | ToString | Overloaded. (Inherited from BorderBase)
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

BorderStyle Class
Telerik.Reporting.Drawing Namespace


BorderType Enumeration

BorderType Enumeration
[image]
Telerik.Reporting.Drawing Namespace : BorderType Enumeration

Specifies the type of a border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum BorderType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BorderType
C#
public enum BorderType : Enum

Members

Member | Description
None | No line.
Dotted | A dotted line.
Dashed | A dashed line.
Solid | A solid line.
Double | A double solid line.
Groove | A grooved line for a sunken border appearance.
Ridge | A ridged line for a raised border appearance.
Inset | An inset line for a sunken item appearance.
Outset | An outset line for a raised item appearance.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Drawing.BorderType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Drawing Namespace


BorderWidth Class Methods

BorderWidth Class Methods
[image]
Telerik.Reporting.Drawing Namespace : BorderWidth Class

For a list of all members of this type, see BorderWidth members.

Public Methods

 | Name | Description
Public Method | ToString | Overloaded. (Inherited from BorderBase)
Top

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

BorderWidth Class
Telerik.Reporting.Drawing Namespace


ConditionalFormatting Class Properties

ConditionalFormatting Class Properties
[image]
Telerik.Reporting.Drawing Namespace : ConditionalFormatting Class

For a list of all members of this type, see ConditionalFormatting members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<FormattingRule>)
Top

See Also

Reference

ConditionalFormatting Class
Telerik.Reporting.Drawing Namespace


ExternalStyleSheetCollection Class Properties

ExternalStyleSheetCollection Class Properties
[image]
Telerik.Reporting.Drawing Namespace : ExternalStyleSheetCollection Class

For a list of all members of this type, see ExternalStyleSheetCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<ExternalStyleSheet>)
Top

See Also

Reference

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


HorizontalAlign Enumeration

HorizontalAlign Enumeration
[image]
Telerik.Reporting.Drawing Namespace : HorizontalAlign Enumeration

Specifies the vertical alignment of an object or text in a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum HorizontalAlign
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As HorizontalAlign
C#
public enum HorizontalAlign : Enum

Members

Member | Description
Left | Specifies that the object is aligned to the left.
Center | Specifies that the object is aligned to the center.
Right | Specifies that the object is aligned to the right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Drawing.HorizontalAlign

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Drawing Namespace


ImageSizeMode Enumeration

ImageSizeMode Enumeration
[image]
Telerik.Reporting.Drawing Namespace : ImageSizeMode Enumeration

Specifies how an image is positioned within an item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ImageSizeMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ImageSizeMode
C#
public enum ImageSizeMode : Enum

Members

Member | Description
AutoSize | Grows or shrinks borders of the image item to fit the image.
Center | The image is displayed in the center of the item. If the image is larger than the item, the image is clipped
Normal | Clips the image to fit the height and width of the PictureBox.
Stretch | Resizes the image to match the height and width of the PictureBox.
ScaleProportional | Resizes the image to match the height and width of the PictureBox, preserving the aspect ratio.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Drawing.ImageSizeMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Drawing Namespace


LineStyle Enumeration

LineStyle Enumeration
[image]
Telerik.Reporting.Drawing Namespace : LineStyle Enumeration

Specifies the type of a line item

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum LineStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As LineStyle
C#
public enum LineStyle : Enum

Members

Member | Description
Solid |
Dashed |
Dotted |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Drawing.LineStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Drawing Namespace


Explicit Type Conversion(Point,PointU) Operator

Explicit Type Conversion(Point,PointU) Operator
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Point,PointU) Operator

point
The PointU to convert.
Converts the specified reporting PointU to a Point.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal point As PointU _
) As Point
C#
public Point operator explicit(
   PointU point
)

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal point As PointU _
) As Point
C#
public Point operator explicit(
   PointU point
)

Parameters

point
The PointU to convert.

Return Value

The Point that is converted from the specified reporting Point structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members
Overload List


Explicit Type Conversion(PointF,PointU) Operator

Explicit Type Conversion(PointF,PointU) Operator
[image]
Telerik.Reporting.Drawing Namespace > PointU Structure > Explicit Type Conversion Operator : Explicit Type Conversion(PointF,PointU) Operator

point
The PointU to convert.
Converts the specified reporting PointU to a PointF.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal point As PointU _
) As PointF
C#
public PointF operator explicit(
   PointU point
)

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal point As PointU _
) As PointF
C#
public PointF operator explicit(
   PointU point
)

Parameters

point
The PointU to convert.

Return Value

The PointF that is converted from the specified reporting Point structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PointU Structure
PointU Members
Overload List


Explicit Type Conversion(Rectangle,RectangleU) Operator

Explicit Type Conversion(Rectangle,RectangleU) Operator
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Rectangle,RectangleU) Operator

rect
The RectangleU structure to convert.
Converts the specified RectangleU structure to a Rectangle structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal rect As RectangleU _
) As Rectangle
C#
public Rectangle operator explicit(
   RectangleU rect
)

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal rect As RectangleU _
) As Rectangle
C#
public Rectangle operator explicit(
   RectangleU rect
)

Parameters

rect
The RectangleU structure to convert.

Return Value

The Rectangle structure that is converted from the specified RectangleU structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


Explicit Type Conversion(RectangleF,RectangleU) Operator

Explicit Type Conversion(RectangleF,RectangleU) Operator
[image]
Telerik.Reporting.Drawing Namespace > RectangleU Structure > Explicit Type Conversion Operator : Explicit Type Conversion(RectangleF,RectangleU) Operator

rect
The RectangleU structure to convert.
Converts the specified RectangleU structure to a RectangleF structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal rect As RectangleU _
) As RectangleF
C#
public RectangleF operator explicit(
   RectangleU rect
)

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal rect As RectangleU _
) As RectangleF
C#
public RectangleF operator explicit(
   RectangleU rect
)

Parameters

rect
The RectangleU structure to convert.

Return Value

The RectangleF structure that is converted from the specified RectangleU structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RectangleU Structure
RectangleU Members
Overload List


ArrowShape Class Properties

ArrowShape Class Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : ArrowShape Class

For a list of all members of this type, see ArrowShape members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Public Property | Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

See Also

Reference

ArrowShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CrossShape Class Properties

CrossShape Class Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : CrossShape Class

For a list of all members of this type, see CrossShape members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Public Property | Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

See Also

Reference

CrossShape Class
Telerik.Reporting.Drawing.Shapes Namespace


EllipseShape Class Properties

EllipseShape Class Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : EllipseShape Class

For a list of all members of this type, see EllipseShape members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

See Also

Reference

EllipseShape Class
Telerik.Reporting.Drawing.Shapes Namespace


LineDirection Enumeration

LineDirection Enumeration
[image]
Telerik.Reporting.Drawing.Shapes Namespace : LineDirection Enumeration

Represents the direction of a line in a shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum LineDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As LineDirection
C#
public enum LineDirection : Enum

Members

Member | Description
NS | Vertical line
EW | Horizontal line
NWSE | Top-Right - Bottom-Left line
NESW | Top-Left - Bottom-Right line

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Drawing.Shapes.LineDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Drawing.Shapes Namespace


LineShape Class Properties

LineShape Class Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : LineShape Class

For a list of all members of this type, see LineShape members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

See Also

Reference

LineShape Class
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShape Class Properties

PolygonShape Class Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : PolygonShape Class

For a list of all members of this type, see PolygonShape members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Public Property | Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

See Also

Reference

PolygonShape Class
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShapeBase Class Properties

PolygonShapeBase Class Properties
[image]
Telerik.Reporting.Drawing.Shapes Namespace : PolygonShapeBase Class

For a list of all members of this type, see PolygonShapeBase members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase)
Public Property | Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape)
Top

Protected Properties

 | Name | Description
Protected Property | AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase)
Top

See Also

Reference

PolygonShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


Telerik.Reporting.Drawing.Shapes Namespace

Telerik.Reporting.Drawing.Shapes Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
ArrowShape | Represents an arrow shape.
BezierSegment | Represents a Bezier curve segment of a shape.
CrossShape | Represents an cross shape.
Ellipse | Represents an ellipse segment of a shape.
EllipseShape | Represents an ellipse shape.
LineSegment | Represents line segment of a shape.
LineShape | Represents a line shape.
PolygonShape | Represents a polygon shape.
PolygonShapeBase | Represents the base class for all polygon shapes.
RoundedCornerShape | Represents shape with rounded corners.
ShapeBase | Base class for all shape types.
StarShape | Represents a star shape.

Interfaces

Interface | Description
IShapeSegment | Represents a shape segment.

Enumerations

Enumeration | Description
LineDirection | Represents the direction of a line in a shape.

See Also

Reference

Telerik.Reporting Assembly


Telerik.Reporting.Drawing.Shapes Namespace Inheritance Hierarchy

Telerik.Reporting.Drawing.Shapes Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
Telerik.Reporting.Drawing.Shapes.BezierSegment
Telerik.Reporting.Drawing.Shapes.Ellipse
Telerik.Reporting.Drawing.Shapes.LineSegment
Telerik.Reporting.Drawing.Shapes.ShapeBase
Telerik.Reporting.Drawing.Shapes.EllipseShape
Telerik.Reporting.Drawing.Shapes.LineShape
Telerik.Reporting.Drawing.Shapes.RoundedCornerShape
Telerik.Reporting.Drawing.Shapes.ArrowShape
Telerik.Reporting.Drawing.Shapes.CrossShape
Telerik.Reporting.Drawing.Shapes.PolygonShapeBase
Telerik.Reporting.Drawing.Shapes.PolygonShape
Telerik.Reporting.Drawing.Shapes.StarShape

See Also

Reference

Telerik.Reporting Assembly


Explicit Type Conversion(Size,SizeU) Operator

Explicit Type Conversion(Size,SizeU) Operator
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Size,SizeU) Operator

size
The SizeU structure to be converted.
Converts the specified SizeU to a Size.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal size As SizeU _
) As Size
C#
public Size operator explicit(
   SizeU size
)

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal size As SizeU _
) As Size
C#
public Size operator explicit(
   SizeU size
)

Parameters

size
The SizeU structure to be converted.

Return Value

The Size structure to which this operator converts.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members
Overload List


Explicit Type Conversion(SizeF,SizeU) Operator

Explicit Type Conversion(SizeF,SizeU) Operator
[image]
Telerik.Reporting.Drawing Namespace > SizeU Structure > Explicit Type Conversion Operator : Explicit Type Conversion(SizeF,SizeU) Operator

size
The SizeU structure to be converted.
Converts the specified SizeU to a SizeF.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal size As SizeU _
) As SizeF
C#
public SizeF operator explicit(
   SizeU size
)

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal size As SizeU _
) As SizeF
C#
public SizeF operator explicit(
   SizeU size
)

Parameters

size
The SizeU structure to be converted.

Return Value

The SizeF structure to which this operator converts.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SizeU Structure
SizeU Members
Overload List


Style Class Methods

Style Class Methods
[image]
Telerik.Reporting.Drawing Namespace : Style Class

For a list of all members of this type, see Style members.

Protected Methods

 | Name | Description
Protected Method | ReadXml | (Inherited from StyleBase)
Protected Method | WriteXml | (Inherited from StyleBase)
Top

See Also

Reference

Style Class
Telerik.Reporting.Drawing Namespace


StyleSelector Class Fields

StyleSelector Class Fields
[image]
Telerik.Reporting.Drawing Namespace : StyleSelector Class

For a list of all members of this type, see StyleSelector members.

Protected Fields

 | Name | Description
Protected Field | attributeName | The name of the property to match. (Inherited from AttributeSelectorBase)
Protected Field | attributeValue | The value of the property to match. (Inherited from AttributeSelectorBase)
Protected Field | descriptor | The property descriptor associated with the property that this selector matches. (Inherited from AttributeSelectorBase)
Protected Field | initialized | (Inherited from TypeSelector)
Top

See Also

Reference

StyleSelector Class
Telerik.Reporting.Drawing Namespace


StyleSheet Class Properties

StyleSheet Class Properties
[image]
Telerik.Reporting.Drawing Namespace : StyleSheet Class

For a list of all members of this type, see StyleSheet members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns the StyleRule at the specified indexed location in the collection. (Inherited from StyleRuleCollection)
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

StyleSheet Class
Telerik.Reporting.Drawing Namespace


UnitType Enumeration

UnitType Enumeration
[image]
Telerik.Reporting.Drawing Namespace : UnitType Enumeration

Represents the type of a Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum UnitType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As UnitType
C#
public enum UnitType : Enum

Members

Member | Description
Pixel | Represents pixels. String equivalent used in Unit's contructor should be "px".
Point | Represents points. String equivalent used in Unit's contructor should be "pt".
Pica | Represents picas. String equivalent used in Unit's contructor should be "pc".
Inch | Represents inches. String equivalent used in Unit's contructor should be "in".
Mm | Represents millimeters. String equivalent used in Unit's contructor should be "mm".
Cm | Represents centimeters. String equivalent used in Unit's contructor should be "cm".

Remarks

1 inch = 6 picas = 72 points.

1 centimeter = 10 millimeters.

Pixels convert to and from other units based on the dpi of the currrent graphics context.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Drawing.UnitType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Drawing Namespace


Multiplication(Double,Unit) Operator

Multiplication(Double,Unit) Operator
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Multiplication Operator : Multiplication(Double,Unit) Operator

value
The double value to multiply.
unit1
The Unit to multiply by.
Multiplies a value by a Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Operator *( _
   ByVal value As Double, _
   ByVal unit1 As Unit _
) As Unit
C#
public Unit operator *(
   double value,
   Unit unit1
)

Syntax

Visual Basic (Declaration)
Overloads Public Operator *( _
   ByVal value As Double, _
   ByVal unit1 As Unit _
) As Unit
C#
public Unit operator *(
   double value,
   Unit unit1
)

Parameters

value
The double value to multiply.
unit1
The Unit to multiply by.

Return Value

A Unit that is the product of value and unit1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


Multiplication(Unit,Double) Operator

Multiplication(Unit,Double) Operator
[image]
Telerik.Reporting.Drawing Namespace > Unit Structure > Multiplication Operator : Multiplication(Unit,Double) Operator

unit1
The Unit to multiply.
value
A double value to multiply by.
Multiplies a Unit by a specified value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Operator *( _
   ByVal unit1 As Unit, _
   ByVal value As Double _
) As Unit
C#
public Unit operator *(
   Unit unit1,
   double value
)

Syntax

Visual Basic (Declaration)
Overloads Public Operator *( _
   ByVal unit1 As Unit, _
   ByVal value As Double _
) As Unit
C#
public Unit operator *(
   Unit unit1,
   double value
)

Parameters

unit1
The Unit to multiply.
value
A double value to multiply by.

Return Value

The product of unit1 and value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Unit Structure
Unit Members
Overload List


VerticalAlign Enumeration

VerticalAlign Enumeration
[image]
Telerik.Reporting.Drawing Namespace : VerticalAlign Enumeration

Specifies the vertical alignment of an object or text in an report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum VerticalAlign
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As VerticalAlign
C#
public enum VerticalAlign : Enum

Members

Member | Description
Top | Specifies that the object is aligned to the top.
Middle | Specifies that the object is aligned to the middle.
Bottom | Specifies that the object is aligned to the bottom.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.Drawing.VerticalAlign

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting.Drawing Namespace


Telerik.Reporting.Drawing Namespace

Telerik.Reporting.Drawing Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
AttributeSelector | Represents a selector that matches a property value of a report item.
AttributeSelectorBase | Provides the abstract base class for an attribute selector.
BackgroundImage | Represents a background image associated with a Style
BorderBase | This class supports the Telerik Reporting infrastructure and is not intended to be used directly from your code.
BorderColor | A class used to specify the color of the border of an item.
BorderStyle | A class used to specify the style of the border of an item.
BorderWidth | A class used to specify the width of the border of an item.
ConditionalFormatting |
ConditionalFormattingConverter |
DescendantSelector | Represents a selector that matches an item that is a descendant of another item.
ExternalStyleSheetCollection | Represents a collection of ExternalStyleSheet objects.
ExternalStyleSheetCollectionConverter | ExternalStyleSheetCollectionConverter
ExternalStyleSheetConverter | ExternalStyleSheetConverter
Font | Defines a particular format for text, including font face, size, and style attributes.
FormattingRule |
MarginsU | Mockup class -- TO BE REMOVED!!!
Padding | Represents padding information associated with a report item.
PageSettings | Specifies settings that apply to a single, printed page.
PointUConverter | Converts a PointU object from one data type to another. Access this class through the TypeDescriptor object.
SelectorCollection | Represents a collection of objects that implement ISelector
SelectorCollectionConverter |
SizeUConverter | Converts a SizeU object from one data type to another. Access this class through the TypeDescriptor object.
Style | Represents the style of a report item.
StyleBase | This class supports the Telerik Reporting infrastructure and is not intended to be used directly from your code.
StyleRule | Represents a style rule to be applied.
StyleRuleCollection | Represents a collection of StyleRule objects.
StyleRuleCollectionConverter |
StyleSelector | An attribute selector based on the style name property.
StyleSheet | Represents a collection of styles for a ReportItemBase
TypeSelector | Represents a selector base on a Type
UnitConverter | Converts a Unit object from one data type to another. Access this class through the TypeDescriptor object.

Interfaces

Interface | Description
ISelector | Allows an object to implement a style selector, and represents a set of methods to match a ReportItemBase and clone the selector.

Structures

Structure | Description
PointU | Represents an ordered pair of unit-based point x- and y-coordinates that defines a point in a two-dimensional plane.
RectangleU | Stores a set of four Unit-based numbers that represent the location and size of a rectangle.
SizeU | Stores an ordered pair of Unit-based numbers, typically the width and height of a rectangle.
Unit | A structure representing a unit of measure.

Enumerations

Enumeration | Description
BackgroundRepeat | Indicates how a background image will be repeated.
BorderType | Specifies the type of a border.
HorizontalAlign | Specifies the vertical alignment of an object or text in a report item.
ImageSizeMode | Specifies how an image is positioned within an item.
LineStyle | Specifies the type of a line item
UnitType | Represents the type of a Unit.
VerticalAlign | Specifies the vertical alignment of an object or text in an report item.

See Also

Reference

Telerik.Reporting Assembly


Telerik.Reporting.Drawing Namespace Inheritance Hierarchy

Telerik.Reporting.Drawing Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.Reporting.Drawing.SelectorCollection
Telerik.Reporting.Drawing.StyleRuleCollection
Telerik.Reporting.Drawing.StyleSheet
System.Collections.ObjectModel.Collection<ExternalStyleSheet>
Telerik.Reporting.Drawing.ExternalStyleSheetCollection
System.Collections.ObjectModel.Collection<FormattingRule>
Telerik.Reporting.Drawing.ConditionalFormatting
System.ComponentModel.TypeConverter
Telerik.Reporting.Drawing.ConditionalFormattingConverter
Telerik.Reporting.Drawing.ExternalStyleSheetCollectionConverter
Telerik.Reporting.Drawing.ExternalStyleSheetConverter
Telerik.Reporting.Drawing.PointUConverter
Telerik.Reporting.Drawing.SelectorCollectionConverter
Telerik.Reporting.Drawing.SizeUConverter
Telerik.Reporting.Drawing.StyleRuleCollectionConverter
Telerik.Reporting.Drawing.UnitConverter
Telerik.Reporting.Drawing.DescendantSelector
Telerik.Reporting.Drawing.FormattingRule
Telerik.Reporting.Drawing.MarginsU
Telerik.Reporting.Drawing.PageSettings
Telerik.Reporting.Drawing.StyleBase
Telerik.Reporting.Drawing.BackgroundImage
Telerik.Reporting.Drawing.BorderBase
Telerik.Reporting.Drawing.BorderColor
Telerik.Reporting.Drawing.BorderStyle
Telerik.Reporting.Drawing.BorderWidth
Telerik.Reporting.Drawing.Font
Telerik.Reporting.Drawing.Padding
Telerik.Reporting.Drawing.Style
Telerik.Reporting.Drawing.StyleRule
Telerik.Reporting.Drawing.TypeSelector
Telerik.Reporting.Drawing.AttributeSelectorBase
Telerik.Reporting.Drawing.AttributeSelector
Telerik.Reporting.Drawing.StyleSelector

See Also

Reference

Telerik.Reporting Assembly


Group Class Events

Group Class Events
[image]
Telerik.Reporting Namespace : Group Class

For a list of all members of this type, see Group members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Group Class
Telerik.Reporting Namespace


Group Class Methods

Group Class Methods
[image]
Telerik.Reporting Namespace : Group Class

For a list of all members of this type, see Group members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

Group Class
Telerik.Reporting Namespace


GroupFooterSection Class Events

GroupFooterSection Class Events
[image]
Telerik.Reporting Namespace : GroupFooterSection Class

For a list of all members of this type, see GroupFooterSection members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

GroupFooterSection Class
Telerik.Reporting Namespace


GroupFooterSection Class Methods

GroupFooterSection Class Methods
[image]
Telerik.Reporting Namespace : GroupFooterSection Class

For a list of all members of this type, see GroupFooterSection members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

GroupFooterSection Class
Telerik.Reporting Namespace


GroupFooterSection Class Properties

GroupFooterSection Class Properties
[image]
Telerik.Reporting Namespace : GroupFooterSection Class

For a list of all members of this type, see GroupFooterSection members.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Group | Gets the Group object associated with this section. (Inherited from GroupSection)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PrintOnEveryPage | Indicates whether the section should be printed on every page that the group occupies. (Inherited from GroupSection)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

GroupFooterSection Class
Telerik.Reporting Namespace


GroupHeaderSection Class Events

GroupHeaderSection Class Events
[image]
Telerik.Reporting Namespace : GroupHeaderSection Class

For a list of all members of this type, see GroupHeaderSection members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

GroupHeaderSection Class
Telerik.Reporting Namespace


GroupHeaderSection Class Methods

GroupHeaderSection Class Methods
[image]
Telerik.Reporting Namespace : GroupHeaderSection Class

For a list of all members of this type, see GroupHeaderSection members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

GroupHeaderSection Class
Telerik.Reporting Namespace


GroupHeaderSection Class Properties

GroupHeaderSection Class Properties
[image]
Telerik.Reporting Namespace : GroupHeaderSection Class

For a list of all members of this type, see GroupHeaderSection members.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Group | Gets the Group object associated with this section. (Inherited from GroupSection)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PrintOnEveryPage | Indicates whether the section should be printed on every page that the group occupies. (Inherited from GroupSection)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

GroupHeaderSection Class
Telerik.Reporting Namespace


GroupKeepTogether Enumeration

GroupKeepTogether Enumeration
[image]
Telerik.Reporting Namespace : GroupKeepTogether Enumeration

GroupKeepTogether applies to a group and has similar to the ReportSection.KeepTogether meaning, but for the whole group. It indicates whether the rendering engine should try to render the whole group on a single page, the group header plus the first detail on a single page, or leave the group flow as it is. If GroupKeepTogether is set to FirstDetail -- the group header and at least one detail in this group should be on the same page; if set to All -- the whole group should be on a single page. The following rule applies: the rendering engine will try to render the group as specified, but if there is not enough space on the current page, the group is moved to the next page and it continues as long as it needs.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum GroupKeepTogether
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As GroupKeepTogether
C#
public enum GroupKeepTogether : Enum

Members

Member | Description
None | The rendering engine will leave the group flow as it is.
FirstDetail | The rendering engine should try to keep the group header and at least 1 detail on the same page.
All | The rendering engine should try to keep the whole group on the same page.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.GroupKeepTogether

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting Namespace


GroupSection Class Events

GroupSection Class Events
[image]
Telerik.Reporting Namespace : GroupSection Class

For a list of all members of this type, see GroupSection members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

GroupSection Class
Telerik.Reporting Namespace


GroupSection Class Methods

GroupSection Class Methods
[image]
Telerik.Reporting Namespace : GroupSection Class

For a list of all members of this type, see GroupSection members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

GroupSection Class
Telerik.Reporting Namespace


ItemEventHandler Delegate

ItemEventHandler Delegate
[image]
Telerik.Reporting Namespace : ItemEventHandler Delegate

sender
The item whose collection is being modified.
e
An object of the ItemEventArgs class that contains the item that is being added or removed.
Handles the events that occur when items are being added to or removed from an items collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub ItemEventHandler( _
   ByVal sender As Object, _
   ByVal e As ItemEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ItemEventHandler(AddressOf HandlerMethod)
C#
public delegate void ItemEventHandler(
   object sender,
   ItemEventArgs e
)

Parameters

sender
The item whose collection is being modified.
e
An object of the ItemEventArgs class that contains the item that is being added or removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting Namespace


PageBreak Enumeration

PageBreak Enumeration
[image]
Telerik.Reporting Namespace : PageBreak Enumeration

Specifies where to make a page break, with respect to a ReportSection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum PageBreak
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PageBreak
C#
public enum PageBreak : Enum

Members

Member | Description
None | No page break will occur.
Before | A page break will occur before the ReportSection
After | A page break will occur after the ReportSection
BeforeAndAfter | A page break will occur before and after the ReportSection

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.PageBreak

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting Namespace


PageEventHandler Delegate

PageEventHandler Delegate
[image]
Telerik.Reporting Namespace : PageEventHandler Delegate

sender
The report that owns the page.
e
An object of the PageEventArgs class that contains data for the page being rendered.
Handles the events that occur when a page rendering begins or ends.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub PageEventHandler( _
   ByVal sender As Object, _
   ByVal e As PageEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New PageEventHandler(AddressOf HandlerMethod)
C#
public delegate void PageEventHandler(
   object sender,
   PageEventArgs e
)

Parameters

sender
The report that owns the page.
e
An object of the PageEventArgs class that contains data for the page being rendered.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting Namespace


PageFooterSection Class Events

PageFooterSection Class Events
[image]
Telerik.Reporting Namespace : PageFooterSection Class

For a list of all members of this type, see PageFooterSection members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

PageFooterSection Class
Telerik.Reporting Namespace


PageFooterSection Class Methods

PageFooterSection Class Methods
[image]
Telerik.Reporting Namespace : PageFooterSection Class

For a list of all members of this type, see PageFooterSection members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

PageFooterSection Class
Telerik.Reporting Namespace


PageFooterSection Class Properties

PageFooterSection Class Properties
[image]
Telerik.Reporting Namespace : PageFooterSection Class

For a list of all members of this type, see PageFooterSection members.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PrintOnFirstPage | Gets or sets a value indicating whether the section should print on the first page of the report. (Inherited from PageSection)
Public Property | PrintOnLastPage | Gets or sets a value indicating whether the section should print on the last page of the report. (Inherited from PageSection)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PageFooterSection Class
Telerik.Reporting Namespace


PageHeaderSection Class Events

PageHeaderSection Class Events
[image]
Telerik.Reporting Namespace : PageHeaderSection Class

For a list of all members of this type, see PageHeaderSection members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

PageHeaderSection Class
Telerik.Reporting Namespace


PageHeaderSection Class Methods

PageHeaderSection Class Methods
[image]
Telerik.Reporting Namespace : PageHeaderSection Class

For a list of all members of this type, see PageHeaderSection members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

PageHeaderSection Class
Telerik.Reporting Namespace


PageHeaderSection Class Properties

PageHeaderSection Class Properties
[image]
Telerik.Reporting Namespace : PageHeaderSection Class

For a list of all members of this type, see PageHeaderSection members.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | PrintOnFirstPage | Gets or sets a value indicating whether the section should print on the first page of the report. (Inherited from PageSection)
Public Property | PrintOnLastPage | Gets or sets a value indicating whether the section should print on the last page of the report. (Inherited from PageSection)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PageHeaderSection Class
Telerik.Reporting Namespace


PageSection Class Events

PageSection Class Events
[image]
Telerik.Reporting Namespace : PageSection Class

For a list of all members of this type, see PageSection members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

PageSection Class
Telerik.Reporting Namespace


PageSection Class Methods

PageSection Class Methods
[image]
Telerik.Reporting Namespace : PageSection Class

For a list of all members of this type, see PageSection members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

PageSection Class
Telerik.Reporting Namespace


Panel Class Events

Panel Class Events
[image]
Telerik.Reporting Namespace : Panel Class

For a list of all members of this type, see Panel members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

Panel Class
Telerik.Reporting Namespace


ParameterCollection Class Properties

ParameterCollection Class Properties
[image]
Telerik.Reporting Namespace : ParameterCollection Class

For a list of all members of this type, see ParameterCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<Parameter>)
Top

See Also

Reference

ParameterCollection Class
Telerik.Reporting Namespace


PictureBox Class Events

PictureBox Class Events
[image]
Telerik.Reporting Namespace : PictureBox Class

For a list of all members of this type, see PictureBox members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

PictureBox Class
Telerik.Reporting Namespace


ReportFooterSection Class Events

ReportFooterSection Class Events
[image]
Telerik.Reporting Namespace : ReportFooterSection Class

For a list of all members of this type, see ReportFooterSection members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

ReportFooterSection Class
Telerik.Reporting Namespace


ReportFooterSection Class Methods

ReportFooterSection Class Methods
[image]
Telerik.Reporting Namespace : ReportFooterSection Class

For a list of all members of this type, see ReportFooterSection members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

ReportFooterSection Class
Telerik.Reporting Namespace


ReportFooterSection Class Properties

ReportFooterSection Class Properties
[image]
Telerik.Reporting Namespace : ReportFooterSection Class

For a list of all members of this type, see ReportFooterSection members.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ReportFooterSection Class
Telerik.Reporting Namespace


ReportHeaderSection Class Events

ReportHeaderSection Class Events
[image]
Telerik.Reporting Namespace : ReportHeaderSection Class

For a list of all members of this type, see ReportHeaderSection members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

ReportHeaderSection Class
Telerik.Reporting Namespace


ReportHeaderSection Class Methods

ReportHeaderSection Class Methods
[image]
Telerik.Reporting Namespace : ReportHeaderSection Class

For a list of all members of this type, see ReportHeaderSection members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

ReportHeaderSection Class
Telerik.Reporting Namespace


ReportHeaderSection Class Properties

ReportHeaderSection Class Properties
[image]
Telerik.Reporting Namespace : ReportHeaderSection Class

For a list of all members of this type, see ReportHeaderSection members.

Public Properties

 | Name | Description
Public Property | ConditionalFormatting | (Inherited from ReportItemBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | HasChildren | Gets a value indicating whether the report item contains one or more child items. (Inherited from ReportItemBase)
Public Property | Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase)
Public Property | Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase)
Public Property | KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection)
Public Property | Name | Gets or sets the name of the report item. (Inherited from ReportItemBase)
Public Property | PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection)
Public Property | Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase)
Public Property | Report | Gets the report this item belongs to. (Inherited from ReportItemBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase)
Public Property | StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase)
Public Property | Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ReportHeaderSection Class
Telerik.Reporting Namespace


ReportItem Class Events

ReportItem Class Events
[image]
Telerik.Reporting Namespace : ReportItem Class

For a list of all members of this type, see ReportItem members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

ReportItem Class
Telerik.Reporting Namespace


ReportItem Class Methods

ReportItem Class Methods
[image]
Telerik.Reporting Namespace : ReportItem Class

For a list of all members of this type, see ReportItem members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

ReportItem Class
Telerik.Reporting Namespace


ReportParameterType Enumeration

ReportParameterType Enumeration
[image]
Telerik.Reporting Namespace : ReportParameterType Enumeration

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Enum ReportParameterType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ReportParameterType
C#
public enum ReportParameterType : Enum

Members

Member | Description
Boolean |
DateTime |
Integer |
Float |
String |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.ReportParameterType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting Namespace


ReportSection Class Events

ReportSection Class Events
[image]
Telerik.Reporting Namespace : ReportSection Class

For a list of all members of this type, see ReportSection members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

ReportSection Class
Telerik.Reporting Namespace


ReportSection Class Methods

ReportSection Class Methods
[image]
Telerik.Reporting Namespace : ReportSection Class

For a list of all members of this type, see ReportSection members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | (Inherited from ReportSectionBase)
Protected Method | OnItemRemoved | (Inherited from ReportSectionBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

ReportSection Class
Telerik.Reporting Namespace


ReportSectionBase Class Events

ReportSectionBase Class Events
[image]
Telerik.Reporting Namespace : ReportSectionBase Class

For a list of all members of this type, see ReportSectionBase members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

ReportSectionBase Class
Telerik.Reporting Namespace


ResourceKind Enumeration

ResourceKind Enumeration
[image]
Telerik.Reporting Namespace : ResourceKind Enumeration

Specifies the way a resource is loaded.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Private Enum ResourceKind
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ResourceKind
C#
private enum ResourceKind : Enum

Members

Member | Description
Stream |
Absolute |
Relative |
ResourceName |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.Reporting.ResourceKind

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.Reporting Namespace


Shape Class Events

Shape Class Events
[image]
Telerik.Reporting Namespace : Shape Class

For a list of all members of this type, see Shape members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

Shape Class
Telerik.Reporting Namespace


Shape Class Methods

Shape Class Methods
[image]
Telerik.Reporting Namespace : Shape Class

For a list of all members of this type, see Shape members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

Shape Class
Telerik.Reporting Namespace


TextBox Class Events

TextBox Class Events
[image]
Telerik.Reporting Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

TextBox Class
Telerik.Reporting Namespace


TextBox Class Methods

TextBox Class Methods
[image]
Telerik.Reporting Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

TextBox Class
Telerik.Reporting Namespace


Culture Property

Culture Property
[image]
Telerik.Reporting Namespace > TextBox Class : Culture Property

Gets or sets the culture information associated with the TextBox.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Culture As CultureInfo
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As CultureInfo

instance.Culture = value

value = instance.Culture
C#
public CultureInfo Culture {get; set;}

Return Value

A CultureInfo representing the culture supported by the TextBox.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


Format Property

Format Property
[image]
Telerik.Reporting Namespace > TextBox Class : Format Property

Gets or sets the character(s) that specify how text is formatted.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As String
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As String

instance.Format = value

value = instance.Format
C#
public string Format {get; set;}

Return Value

The character or characters that specify how text is formatted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TextBox Class
TextBox Members


TextItemBase Class Events

TextItemBase Class Events
[image]
Telerik.Reporting Namespace : TextItemBase Class

For a list of all members of this type, see TextItemBase members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ItemAdded | Occurs when a new report item is added to the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Public Event | ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase)
Public Event | ItemRemoved | Occurs when a report item is removed from the ReportItemBase.ItemCollection. (Inherited from ReportItemBase)
Top

See Also

Reference

TextItemBase Class
Telerik.Reporting Namespace


TextItemBase Class Methods

TextItemBase Class Methods
[image]
Telerik.Reporting Namespace : TextItemBase Class

For a list of all members of this type, see TextItemBase members.

Public Methods

 | Name | Description
Public Method | Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the ReportItemBase and its child items and optionally releases the managed resources. (Inherited from ReportItemBase)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase)
Top

Protected Methods

 | Name | Description
Protected Method | ClearStyles | (Inherited from ReportItemBase)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetObjectDataInternal | (Inherited from ReportItemBase)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | OnItemAdded | Raises the ReportItemBase.ItemAdded event. (Inherited from ReportItemBase)
Protected Method | OnItemRemoved | Raises the ReportItemBase.ItemRemoved event. (Inherited from ReportItemBase)
Protected Method | OnItemValidate | (Inherited from ReportItemBase)
Top

See Also

Reference

TextItemBase Class
Telerik.Reporting Namespace


Telerik.Reporting Namespace (Telerik.Reporting)

Telerik.Reporting Namespace (Telerik.Reporting)
See Also Inheritance Hierarchy

Classes

Class | Description
Barcode | Represents a barcode report item.
Chart | Defines the base class for all report items that can be placed in a ReportSectionBase. Items of this type have a location and a size.
CheckBox | Represents a check box report item.
DetailSection | Represents the main section of a Report. It is printed once for every record in the data source of the report.
Group | Represents a class that defines a report group.
GroupFooterSection | Represents a group footer section. Group footers are displayed at the end of a group. Group headers and footers are unified by the Group class.
GroupHeaderSection | Represents a group header section. Group headers are displayed at the beginning of a group. Group headers and footers are unified by the Group class.
GroupSection | Base abstract class for group sections. GroupHeaderSection and GroupFooterSection inherit from this class.
ItemEventArgs | Provides data for the ReportItemBase.ItemAdded and ReportItemBase.ItemRemoved events.
ObjectValueConverter | Allows a property of type Object to be edited like a string property in the Properties window
PageEventArgs | Provides data for the Report.BeginRenderPage and Report.EndRenderPage events.
PageFooterSection | Represents a page footer section. Page footers are displayed at the end of a page.
PageHeaderSection | Represents a page header section. Page headers are displayed at the beginning of a page.
PageSection | Base abstract class for group sections. PageHeaderSection and PageFooterSection inherit from this class.
Panel | Provides a grouping mechanism for organizing report items.
Parameter | Represents a parameter of nested report (subreport)
ParameterCollection |
ParameterCollectionConverter |
PictureBox | Represents a picture box report item for displaying an image.
Report | Represents the base class for any report in the Telerik Reporting.
ReportConverter |
ReportFooterSection | Represents a report footer section. Report footer is displayed at the end of a report, but before the last PageFooterSection if any.
ReportHeaderSection | Represents a report header section. Report header is displayed at the beginning of a report, but after the first PageHeaderSection if any.
ReportItem | Defines the base class for all report items that can be placed in a ReportSectionBase. Items of this type have a location and a size.
ReportItemBase | Defines the base class for visual report items used for creating reports.
ReportItemBase.ItemCollection | Represents a collection of ReportItemBase objects.
ReportParameter |
ReportParameterCollection |
ReportParameterCollectionConverter |
ReportParameterDataSource.Group |
ReportParameterUISettings |
ReportSection | Base abstract class for all report sections contained in the report body. Inherited by DetailSection, GroupSection, ReportHeaderSection, ReportFooterSection,
ReportSectionBase | Defines the base class for report sections.
ResourceHelper | A class for common resource needs.
ResourceResolutionService | Default resource resolution service used at run-time.
Shape | Represents a shape report item.
SubReport | Represents a report item used to embed another report into the current report.
TextBox | Represents a text box report item.
TextItemBase | Represents a Text Item - a base class for report items like TextBox and CheckBox.
TextItemHelper | Represents some helpers related to the TextItemBase classes.

Interfaces

Interface | Description
IResourceResolutionService | Provides an interface for resolving resources.
ReportParameterUISettings.IAvailableValues | Represents the ReportParameterUISettings bindable AvailableValues
ReportParameterUISettings.IDataSource | Base interface from AvailableValues and DefaultValues data bindable properties

Delegates

Delegate | Description
ItemEventHandler | Handles the events that occur when items are being added to or removed from an items collection.
PageEventHandler | Handles the events that occur when a page rendering begins or ends.

Enumerations

Enumeration | Description
Barcode.SymbologyType |
GroupKeepTogether | GroupKeepTogether applies to a group and has similar to the ReportSection.KeepTogether meaning, but for the whole group. It indicates whether the rendering engine should try to render the whole group on a single page, the group header plus the first detail on a single page, or leave the group flow as it is. If GroupKeepTogether is set to FirstDetail -- the group header and at least one detail in this group should be on the same page; if set to All -- the whole group should be on a single page. The following rule applies: the rendering engine will try to render the group as specified, but if there is not enough space on the current page, the group is moved to the next page and it continues as long as it needs.
PageBreak | Specifies where to make a page break, with respect to a ReportSection.
ReportParameterType |
ResourceKind | Specifies the way a resource is loaded.

See Also

Reference

Telerik.Reporting Assembly


Telerik.Reporting Namespace (Telerik.Reporting) Inheritance Hierarchy

Telerik.Reporting Namespace (Telerik.Reporting) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.Reporting.ReportItemBase.ItemCollection
System.Collections.ObjectModel.Collection<Parameter>
Telerik.Reporting.ParameterCollection
System.Collections.ObjectModel.Collection<ReportParameter>
Telerik.Reporting.ReportParameterCollection
System.ComponentModel.TypeConverter
Telerik.Reporting.ObjectValueConverter
Telerik.Reporting.ParameterCollectionConverter
Telerik.Reporting.ReportConverter
Telerik.Reporting.ReportParameterCollectionConverter
System.EventArgs
Telerik.Reporting.ItemEventArgs
Telerik.Reporting.PageEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
Telerik.Reporting.Group
Telerik.Reporting.ReportItemBase
Telerik.Reporting.Report
Telerik.Reporting.ReportItem
Telerik.Reporting.Barcode
Telerik.Reporting.Chart
Telerik.Reporting.Panel
Telerik.Reporting.PictureBox
Telerik.Reporting.Shape
Telerik.Reporting.SubReport
Telerik.Reporting.TextItemBase
Telerik.Reporting.CheckBox
Telerik.Reporting.TextBox
Telerik.Reporting.ReportSectionBase
Telerik.Reporting.PageSection
Telerik.Reporting.PageFooterSection
Telerik.Reporting.PageHeaderSection
Telerik.Reporting.ReportSection
Telerik.Reporting.DetailSection
Telerik.Reporting.GroupSection
Telerik.Reporting.GroupFooterSection
Telerik.Reporting.GroupHeaderSection
Telerik.Reporting.ReportFooterSection
Telerik.Reporting.ReportHeaderSection
Telerik.Reporting.Parameter
Telerik.Reporting.ReportParameter
Telerik.Reporting.ReportParameterDataSource.Group
Telerik.Reporting.ReportParameterUISettings
Telerik.Reporting.ResourceHelper
Telerik.Reporting.ResourceResolutionService
Telerik.Reporting.TextItemHelper

See Also

Reference

Telerik.Reporting Assembly


Assembly Overview

Telerik.ReportViewer.WebForms Send comments on this topic.
Telerik.ReportViewer.WebForms Assembly

Namespaces

Namespace | Description
Telerik.ReportViewer.WebForms |


Getting Started - Telerik.ReportViewer.WebForms

Telerik.ReportViewer.WebForms Send comments on this topic.
Getting Started


Introduction - Telerik.ReportViewer.WebForms

Telerik.ReportViewer.WebForms Send comments on this topic.
Introduction


LabelValuePair Structure Methods

Telerik.ReportViewer.WebForms Send comments on this topic.
LabelValuePair Structure Methods
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : LabelValuePair Structure

For a list of all members of this type, see LabelValuePair members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.ValueType)
Public Method | GetHashCode | (Inherited from System.ValueType)
Public Method | ToString | (Inherited from System.ValueType)
Top

See Also

Reference

LabelValuePair Structure
Telerik.ReportViewer.WebForms Namespace


ParametersAreaGroup Class Events

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersAreaGroup Class Events
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ParametersAreaGroup Class

For a list of all members of this type, see ParametersAreaGroup members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

ParametersAreaGroup Class
Telerik.ReportViewer.WebForms Namespace


ParametersAreaGroup Class Fields

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersAreaGroup Class Fields
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ParametersAreaGroup Class

For a list of all members of this type, see ParametersAreaGroup members.

Protected Fields

 | Name | Description
Protected Field | reportViewer | (Inherited from ToolbarGroup)
Top

See Also

Reference

ParametersAreaGroup Class
Telerik.ReportViewer.WebForms Namespace


ParametersAreaGroup Class Properties

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersAreaGroup Class Properties
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ParametersAreaGroup Class

For a list of all members of this type, see ParametersAreaGroup members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ZoomMode | (Inherited from ToolbarGroup)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

ParametersAreaGroup Class
Telerik.ReportViewer.WebForms Namespace


CreateImageUrl Method

Telerik.ReportViewer.WebForms Send comments on this topic.
CreateImageUrl Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersAreaGroup Class : CreateImageUrl Method

imageName

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected Function CreateImageUrl( _
   ByVal imageName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ParametersAreaGroup
Dim imageName As String
Dim value As String

value = instance.CreateImageUrl(imageName)
C#
protected string CreateImageUrl(
   string imageName
)

Parameters

imageName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersAreaGroup Class
ParametersAreaGroup Members


Render Method

Telerik.ReportViewer.WebForms Send comments on this topic.
Render Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersAreaGroup Class : Render Method

writer

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Render( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ParametersAreaGroup
Dim writer As HtmlTextWriter

instance.Render(writer)
C#
protected virtual void Render(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersAreaGroup Class
ParametersAreaGroup Members


RenderChildren Method

Telerik.ReportViewer.WebForms Send comments on this topic.
RenderChildren Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersAreaGroup Class : RenderChildren Method

writer

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderChildren( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ParametersAreaGroup
Dim writer As HtmlTextWriter

instance.RenderChildren(writer)
C#
protected virtual void RenderChildren(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersAreaGroup Class
ParametersAreaGroup Members


RenderItemSpacer Method

Telerik.ReportViewer.WebForms Send comments on this topic.
RenderItemSpacer Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersAreaGroup Class : RenderItemSpacer Method

writer

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderItemSpacer( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ParametersAreaGroup
Dim writer As HtmlTextWriter

instance.RenderItemSpacer(writer)
C#
protected void RenderItemSpacer(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersAreaGroup Class
ParametersAreaGroup Members


reportViewer Field

Telerik.ReportViewer.WebForms Send comments on this topic.
reportViewer Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersAreaGroup Class : reportViewer Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected reportViewer As ReportViewer
Visual Basic (Usage) Copy Code
Dim instance As ParametersAreaGroup
Dim value As ReportViewer

value = instance.reportViewer

instance.reportViewer = value
C#
protected ReportViewer reportViewer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersAreaGroup Class
ParametersAreaGroup Members


ZoomMode Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ZoomMode Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersAreaGroup Class : ZoomMode Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoomMode As ZoomMode
Visual Basic (Usage) Copy Code
Dim instance As ParametersAreaGroup
Dim value As ZoomMode

instance.ZoomMode = value

value = instance.ZoomMode
C#
public ZoomMode ZoomMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersAreaGroup Class
ParametersAreaGroup Members


ParametersButton Class Events

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersButton Class Events
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ParametersButton Class

For a list of all members of this type, see ParametersButton members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

ParametersButton Class
Telerik.ReportViewer.WebForms Namespace


ParametersButton Class Fields

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersButton Class Fields
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ParametersButton Class

For a list of all members of this type, see ParametersButton members.

Protected Fields

 | Name | Description
Protected Field | reportViewer | (Inherited from ToolbarButton)
Top

See Also

Reference

ParametersButton Class
Telerik.ReportViewer.WebForms Namespace


ParametersButton Class Properties

Telerik.ReportViewer.WebForms Send comments on this topic.
ParametersButton Class Properties
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ParametersButton Class

For a list of all members of this type, see ParametersButton members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientEnabled | (Inherited from ToolbarButton)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | CommandName | (Inherited from ToolbarButton)
Public Property | Controls | (Inherited from System.Web.UI.WebControls.CompositeControl)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | TagKey | (Inherited from ToolbarButton)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

ParametersButton Class
Telerik.ReportViewer.WebForms Namespace


ClientEnabled Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ClientEnabled Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersButton Class : ClientEnabled Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ClientEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ParametersButton
Dim value As Boolean

instance.ClientEnabled = value

value = instance.ClientEnabled
C#
public virtual bool ClientEnabled {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersButton Class
ParametersButton Members


CommandName Property

Telerik.ReportViewer.WebForms Send comments on this topic.
CommandName Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersButton Class : CommandName Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CommandName As String
Visual Basic (Usage) Copy Code
Dim instance As ParametersButton
Dim value As String

instance.CommandName = value

value = instance.CommandName
C#
public virtual string CommandName {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersButton Class
ParametersButton Members


Render Method

Telerik.ReportViewer.WebForms Send comments on this topic.
Render Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersButton Class : Render Method

writer

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Render( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ParametersButton
Dim writer As HtmlTextWriter

instance.Render(writer)
C#
protected virtual void Render(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersButton Class
ParametersButton Members


RenderRegisterScript Method

Telerik.ReportViewer.WebForms Send comments on this topic.
RenderRegisterScript Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersButton Class : RenderRegisterScript Method

writer

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderRegisterScript( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ParametersButton
Dim writer As HtmlTextWriter

instance.RenderRegisterScript(writer)
C#
protected virtual void RenderRegisterScript(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersButton Class
ParametersButton Members


reportViewer Field

Telerik.ReportViewer.WebForms Send comments on this topic.
reportViewer Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersButton Class : reportViewer Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected reportViewer As ReportViewer
Visual Basic (Usage) Copy Code
Dim instance As ParametersButton
Dim value As ReportViewer

value = instance.reportViewer

instance.reportViewer = value
C#
protected ReportViewer reportViewer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersButton Class
ParametersButton Members


TagKey Property

Telerik.ReportViewer.WebForms Send comments on this topic.
TagKey Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ParametersButton Class : TagKey Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property TagKey As HtmlTextWriterTag
Visual Basic (Usage) Copy Code
Dim instance As ParametersButton
Dim value As HtmlTextWriterTag

value = instance.TagKey
C#
protected virtual HtmlTextWriterTag TagKey {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ParametersButton Class
ParametersButton Members


ReportViewer Class Events

Telerik.ReportViewer.WebForms Send comments on this topic.
ReportViewer Class Events
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ReportViewer Class

For a list of all members of this type, see ReportViewer members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ShowHideParametersGroup1 Class Events

Telerik.ReportViewer.WebForms Send comments on this topic.
ShowHideParametersGroup1 Class Events
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ShowHideParametersGroup1 Class

For a list of all members of this type, see ShowHideParametersGroup1 members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

ShowHideParametersGroup1 Class
Telerik.ReportViewer.WebForms Namespace


ShowHideParametersGroup1 Class Fields

Telerik.ReportViewer.WebForms Send comments on this topic.
ShowHideParametersGroup1 Class Fields
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ShowHideParametersGroup1 Class

For a list of all members of this type, see ShowHideParametersGroup1 members.

Protected Fields

 | Name | Description
Protected Field | reportViewer | (Inherited from ToolbarGroup)
Top

See Also

Reference

ShowHideParametersGroup1 Class
Telerik.ReportViewer.WebForms Namespace


CreateImageUrl Method

Telerik.ReportViewer.WebForms Send comments on this topic.
CreateImageUrl Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ShowHideParametersGroup1 Class : CreateImageUrl Method

imageName

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected Function CreateImageUrl( _
   ByVal imageName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ShowHideParametersGroup1
Dim imageName As String
Dim value As String

value = instance.CreateImageUrl(imageName)
C#
protected string CreateImageUrl(
   string imageName
)

Parameters

imageName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShowHideParametersGroup1 Class
ShowHideParametersGroup1 Members


Render Method

Telerik.ReportViewer.WebForms Send comments on this topic.
Render Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ShowHideParametersGroup1 Class : Render Method

writer

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Render( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ShowHideParametersGroup1
Dim writer As HtmlTextWriter

instance.Render(writer)
C#
protected virtual void Render(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShowHideParametersGroup1 Class
ShowHideParametersGroup1 Members


RenderChildren Method

Telerik.ReportViewer.WebForms Send comments on this topic.
RenderChildren Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ShowHideParametersGroup1 Class : RenderChildren Method

writer

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderChildren( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ShowHideParametersGroup1
Dim writer As HtmlTextWriter

instance.RenderChildren(writer)
C#
protected virtual void RenderChildren(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShowHideParametersGroup1 Class
ShowHideParametersGroup1 Members


RenderItemSpacer Method

Telerik.ReportViewer.WebForms Send comments on this topic.
RenderItemSpacer Method
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ShowHideParametersGroup1 Class : RenderItemSpacer Method

writer

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RenderItemSpacer( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ShowHideParametersGroup1
Dim writer As HtmlTextWriter

instance.RenderItemSpacer(writer)
C#
protected void RenderItemSpacer(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShowHideParametersGroup1 Class
ShowHideParametersGroup1 Members


reportViewer Field

Telerik.ReportViewer.WebForms Send comments on this topic.
reportViewer Field
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ShowHideParametersGroup1 Class : reportViewer Field

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Protected reportViewer As ReportViewer
Visual Basic (Usage) Copy Code
Dim instance As ShowHideParametersGroup1
Dim value As ReportViewer

value = instance.reportViewer

instance.reportViewer = value
C#
protected ReportViewer reportViewer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShowHideParametersGroup1 Class
ShowHideParametersGroup1 Members


ZoomMode Property

Telerik.ReportViewer.WebForms Send comments on this topic.
ZoomMode Property
See Also
[image]
Telerik.ReportViewer.WebForms Namespace > ShowHideParametersGroup1 Class : ZoomMode Property

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoomMode As ZoomMode
Visual Basic (Usage) Copy Code
Dim instance As ShowHideParametersGroup1
Dim value As ZoomMode

instance.ZoomMode = value

value = instance.ZoomMode
C#
public ZoomMode ZoomMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ShowHideParametersGroup1 Class
ShowHideParametersGroup1 Members


SRDefaultValueAttribute Class Methods

Telerik.ReportViewer.WebForms Send comments on this topic.
SRDefaultValueAttribute Class Methods
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : SRDefaultValueAttribute Class

For a list of all members of this type, see SRDefaultValueAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.ComponentModel.DefaultValueAttribute)
Public Method | GetHashCode | (Inherited from System.ComponentModel.DefaultValueAttribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

Protected Methods

 | Name | Description
Protected Method | SetValue | (Inherited from System.ComponentModel.DefaultValueAttribute)
Top

See Also

Reference

SRDefaultValueAttribute Class
Telerik.ReportViewer.WebForms Namespace


SRDefaultValueAttribute Class Properties

Telerik.ReportViewer.WebForms Send comments on this topic.
SRDefaultValueAttribute Class Properties
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : SRDefaultValueAttribute Class

For a list of all members of this type, see SRDefaultValueAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Public Property | Value | (Inherited from System.ComponentModel.DefaultValueAttribute)
Top

See Also

Reference

SRDefaultValueAttribute Class
Telerik.ReportViewer.WebForms Namespace


ZoomMode Enumeration

Telerik.ReportViewer.WebForms Send comments on this topic.
ZoomMode Enumeration
See Also
[image]
Telerik.ReportViewer.WebForms Namespace : ZoomMode Enumeration

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZoomMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ZoomMode
C#
public enum ZoomMode : Enum

Members

Member | Description
FullPage |
PageWidth |
Percent |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.ReportViewer.WebForms.ZoomMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.ReportViewer.WebForms Namespace


Telerik.ReportViewer.WebForms Namespace

Telerik.ReportViewer.WebForms Send comments on this topic.
Telerik.ReportViewer.WebForms Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
AjaxHelper |
Constants |
HttpHandler |
ParametersAreaGroup | Summary description for RefreshGroup.
ParametersButton |
ReportViewer |
Resources |
Resources.Keys |
ServerReport.SimpleDataItem | IDataItem without Filters, Sorting, Groups and Ranks. Only DataSource and DataMember.
ShowHideParametersGroup1 |
SRDefaultValueAttribute |

Structures

Structure | Description
LabelValuePair |

Enumerations

Enumeration | Description
ZoomMode |

See Also

Reference

Telerik.ReportViewer.WebForms Assembly


Telerik.ReportViewer.WebForms Namespace Inheritance Hierarchy

Telerik.ReportViewer.WebForms Send comments on this topic.
Telerik.ReportViewer.WebForms Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Attribute
System.ComponentModel.DefaultValueAttribute
Telerik.ReportViewer.WebForms.SRDefaultValueAttribute
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.CompositeControl
Telerik.ReportViewer.WebForms.ReportViewer
Telerik.ReportViewer.WebForms.ToolbarButton
Telerik.ReportViewer.WebForms.ParametersButton
Telerik.ReportViewer.WebForms.ToolbarGroup
Telerik.ReportViewer.WebForms.ParametersAreaGroup
Telerik.ReportViewer.WebForms.ShowHideParametersGroup1
Telerik.ReportViewer.WebForms.AjaxHelper
Telerik.ReportViewer.WebForms.Constants
Telerik.ReportViewer.WebForms.HttpHandler
Telerik.ReportViewer.WebForms.Resources
Telerik.ReportViewer.WebForms.Resources.Keys
Telerik.ReportViewer.WebForms.ServerReport.SimpleDataItem

See Also

Reference

Telerik.ReportViewer.WebForms Assembly


Assembly Overview

Telerik.ReportViewer.WinForms Send comments on this topic.
Telerik.ReportViewer.WinForms Assembly

Namespaces

Namespace | Description
Telerik.ReportViewer.WinForms |


Getting Started - Telerik.ReportViewer.WinForms

Telerik.ReportViewer.WinForms Send comments on this topic.
Getting Started


Introduction - Telerik.ReportViewer.WinForms

Telerik.ReportViewer.WinForms Send comments on this topic.
Introduction


ExportEventHandler Delegate

Telerik.ReportViewer.WinForms Send comments on this topic.
ExportEventHandler Delegate
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ExportEventHandler Delegate

sender
args

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub ExportEventHandler( _
   ByVal sender As Object, _
   ByVal args As ExportEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ExportEventHandler(AddressOf HandlerMethod)
C#
public delegate void ExportEventHandler(
   object sender,
   ExportEventArgs args
)

Parameters

sender
args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.ReportViewer.WinForms Namespace


ProcessingState Enumeration

Telerik.ReportViewer.WinForms Send comments on this topic.
ProcessingState Enumeration
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ProcessingState Enumeration

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Enum ProcessingState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ProcessingState
C#
public enum ProcessingState : Enum

Members

Member | Description
NoReport |
Processing |
Success |
Failure |
Partial |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.ReportViewer.WinForms.ProcessingState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.ReportViewer.WinForms Namespace


ReportExplorerForm.ReportExplorerTreeView Class Events

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportExplorerForm.ReportExplorerTreeView Class Events
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportExplorerForm.ReportExplorerTreeView Class

For a list of all members of this type, see ReportExplorerForm.ReportExplorerTreeView members.

Public Events

 | Name | Description
Public Event | AfterCheck | (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterCollapse | (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterExpand | (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterLabelEdit | (Inherited from System.Windows.Forms.TreeView)
Public Event | AfterSelect | (Inherited from System.Windows.Forms.TreeView)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BeforeCheck | (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeCollapse | (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeExpand | (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeLabelEdit | (Inherited from System.Windows.Forms.TreeView)
Public Event | BeforeSelect | (Inherited from System.Windows.Forms.TreeView)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | DrawNode | (Inherited from System.Windows.Forms.TreeView)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | ItemDrag | (Inherited from System.Windows.Forms.TreeView)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | NodeMouseClick | (Inherited from System.Windows.Forms.TreeView)
Public Event | NodeMouseDoubleClick | (Inherited from System.Windows.Forms.TreeView)
Public Event | NodeMouseHover | (Inherited from System.Windows.Forms.TreeView)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.TreeView)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportExplorerForm.ReportExplorerTreeView Class
Telerik.ReportViewer.WinForms Namespace


ReportExplorerForm Class Events

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportExplorerForm Class Events
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportExplorerForm Class

For a list of all members of this type, see ReportExplorerForm members.

Public Events

 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MenuComplete | (Inherited from System.Windows.Forms.Form)
Public Event | MenuStart | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportExplorerForm Class
Telerik.ReportViewer.WinForms Namespace


ReportExplorerForm Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportExplorerForm Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportExplorerForm Class

For a list of all members of this type, see ReportExplorerForm members.

Public Properties

 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | ActiveMdiChild | (Inherited from System.Windows.Forms.Form)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | AllowTransparency | (Inherited from System.Windows.Forms.Form)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Property | DesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Property | DialogResult | (Inherited from System.Windows.Forms.Form)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiChild | (Inherited from System.Windows.Forms.Form)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | IsRestrictedWindow | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MdiChildren | (Inherited from System.Windows.Forms.Form)
Public Property | MdiParent | (Inherited from System.Windows.Forms.Form)
Public Property | Menu | (Inherited from System.Windows.Forms.Form)
Public Property | MergedMenu | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Modal | (Inherited from System.Windows.Forms.Form)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | OwnedForms | (Inherited from System.Windows.Forms.Form)
Public Property | Owner | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | RestoreBounds | (Inherited from System.Windows.Forms.Form)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevel | (Inherited from System.Windows.Forms.Form)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.Form)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Form)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.Form)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | MaximizedBounds | (Inherited from System.Windows.Forms.Form)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowWithoutActivation | (Inherited from System.Windows.Forms.Form)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

See Also

Reference

ReportExplorerForm Class
Telerik.ReportViewer.WinForms Namespace


ReportViewer Class Events

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewer Class Events
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewer Class

For a list of all members of this type, see ReportViewer members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | Export | Occurs when the report in the viewer control is exported. (Inherited from ReportViewerBase)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | Print | Occurs when the report in the viewer control is printed. (Inherited from ReportViewerBase)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RenderingBegin | Occurs when the report in the viewer control is rendered. (Inherited from ReportViewerBase)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | UpdateUI | Occurs when the UI of the report viewer control is updated. (Inherited from ReportViewerBase)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportViewer Class
Telerik.ReportViewer.WinForms Namespace


ReportViewer Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewer Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewer Class

For a list of all members of this type, see ReportViewer members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | CurrentPage | Gets or sets the current page in the viewer. (Inherited from ReportViewerBase)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | ParametersAreaVisible | Gets or sets a value that indicates whether the parameters area is displayed if any parameter editor exists. (Inherited from ReportViewerBase)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProcessingState | Gets the current processing state of the viewer (Inherited from ReportViewerBase)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Report | Gets or sets the report displayed in the viewer. (Inherited from ReportViewerBase)
Public Property | Resources | (Inherited from ReportViewerBase)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | ShowExportButton | Indicates whether Export button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowPageNavigationControls | Indicates whether the page navigation controls are visible. (Inherited from ReportViewerBase)
Public Property | ShowPageSetup | Indicates whether PageSetup button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowPageSetupButton | Indicates whether PageSetup button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowParametersButton | Indicates whether Parameters button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowPrintButton | Indicates whether Print button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowProgress | Indicates whether progress animation should be displayed while the report is rendered. (Inherited from ReportViewerBase)
Public Property | ShowRefreshButton | Indicates whether the Refresh button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowStopButton | Indicates whether the Stop button should be visible. (Inherited from ReportViewerBase)
Public Property | ShowZoom | Indicates whether the Zoom input box should be visible. (Inherited from ReportViewerBase)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | ToolbarVisible | Indicates whether the toolbar should be visible on the viewer. (Inherited from ReportViewerBase)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TotalPages | Gets the count of the available pages in the viewer. (Inherited from ReportViewerBase)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | ZoomMode | Gets or sets the zoom mode of the viewer. (Inherited from ReportViewerBase)
Public Property | ZoomPercent | Gets or sets the percentage of zoom used for the report display. (Inherited from ReportViewerBase)
Top

Protected Properties

 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

See Also

Reference

ReportViewer Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerAreaBase.ViewType Enumeration

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerAreaBase.ViewType Enumeration
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerAreaBase.ViewType Enumeration

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Enum ReportViewerAreaBase.ViewType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ReportViewerAreaBase.ViewType
C#
public enum ReportViewerAreaBase.ViewType : Enum

Members

Member | Description
Message |
Wait |
Report |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.ReportViewer.WinForms.ReportViewerAreaBase.ViewType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.ReportViewer.WinForms Namespace


ReportViewerAreaBase Class Events

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerAreaBase Class Events
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerAreaBase Class

For a list of all members of this type, see ReportViewerAreaBase members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerException Class Methods

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerException Class Methods
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerException Class

For a list of all members of this type, see ReportViewerException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ReportViewerException Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerException Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
ReportViewerException Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ReportViewerException Class

For a list of all members of this type, see ReportViewerException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

ReportViewerException Class
Telerik.ReportViewer.WinForms Namespace


SRDefaultValueAttribute Class Methods

Telerik.ReportViewer.WinForms Send comments on this topic.
SRDefaultValueAttribute Class Methods
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : SRDefaultValueAttribute Class

For a list of all members of this type, see SRDefaultValueAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.ComponentModel.DefaultValueAttribute)
Public Method | GetHashCode | (Inherited from System.ComponentModel.DefaultValueAttribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

Protected Methods

 | Name | Description
Protected Method | SetValue | (Inherited from System.ComponentModel.DefaultValueAttribute)
Top

See Also

Reference

SRDefaultValueAttribute Class
Telerik.ReportViewer.WinForms Namespace


SRDefaultValueAttribute Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
SRDefaultValueAttribute Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : SRDefaultValueAttribute Class

For a list of all members of this type, see SRDefaultValueAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Public Property | Value | (Inherited from System.ComponentModel.DefaultValueAttribute)
Top

See Also

Reference

SRDefaultValueAttribute Class
Telerik.ReportViewer.WinForms Namespace


ToolBarFlags Enumeration

Telerik.ReportViewer.WinForms Send comments on this topic.
ToolBarFlags Enumeration
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ToolBarFlags Enumeration

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Enum ToolBarFlags
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ToolBarFlags
C#
public enum ToolBarFlags : Enum

Members

Member | Description
PageNav |
Refresh |
Export |
Print |
PageSetup |
Zoom |
Stop |
Parameters |
All |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.ReportViewer.WinForms.ToolBarFlags

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.ReportViewer.WinForms Namespace


WinViewer Class Events

Telerik.ReportViewer.WinForms Send comments on this topic.
WinViewer Class Events
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : WinViewer Class

For a list of all members of this type, see WinViewer members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


WinViewer Class Fields

Telerik.ReportViewer.WinForms Send comments on this topic.
WinViewer Class Fields
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : WinViewer Class

For a list of all members of this type, see WinViewer members.

Protected Fields

 | Name | Description
Protected Field | inLongRunningAction | (Inherited from ReportViewerAreaBase)
Top

See Also

Reference

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


WinViewer Class Properties

Telerik.ReportViewer.WinForms Send comments on this topic.
WinViewer Class Properties
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : WinViewer Class

For a list of all members of this type, see WinViewer members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Viewer | (Inherited from ReportViewerAreaBase)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.UserControl)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

See Also

Reference

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


ZoomMode Enumeration

Telerik.ReportViewer.WinForms Send comments on this topic.
ZoomMode Enumeration
See Also
[image]
Telerik.ReportViewer.WinForms Namespace : ZoomMode Enumeration

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZoomMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ZoomMode
C#
public enum ZoomMode : Enum

Members

Member | Description
FullPage |
PageWidth |
Percent |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.ReportViewer.WinForms.ZoomMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.ReportViewer.WinForms Namespace


Telerik.ReportViewer.WinForms Namespace

Telerik.ReportViewer.WinForms Send comments on this topic.
Telerik.ReportViewer.WinForms Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
DrawablePage |
ExportEventArgs |
ParametersArea.Composition |
ParametersArea.Matrix |
ReportExplorerForm |
ReportExplorerForm.ReportExplorerTreeView |
ReportViewer |
ReportViewerAreaBase |
ReportViewerBase |
ReportViewerBase.UIState | Represents all the of for controling the UI of the ReportViewer: ReportToolbar and ReportViewerAreaBase
ReportViewerException |
Resources |
Resources.Keys |
SRDefaultValueAttribute |
WinViewer |
ZoomItem |

Delegates

Delegate | Description
ExportEventHandler |

Enumerations

Enumeration | Description
ProcessingState |
ReportViewerAreaBase.ViewType |
ToolBarFlags |
ZoomMode |

See Also

Reference

Telerik.ReportViewer.WinForms Assembly


Telerik.ReportViewer.WinForms Namespace Inheritance Hierarchy

Telerik.ReportViewer.WinForms Send comments on this topic.
Telerik.ReportViewer.WinForms Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Attribute
System.ComponentModel.DefaultValueAttribute
Telerik.ReportViewer.WinForms.SRDefaultValueAttribute
System.EventArgs
System.ComponentModel.CancelEventArgs
Telerik.ReportViewer.WinForms.ExportEventArgs
System.Exception
Telerik.ReportViewer.WinForms.ReportViewerException
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Telerik.ReportViewer.WinForms.ReportExplorerForm
System.Windows.Forms.UserControl
Telerik.ReportViewer.WinForms.ReportViewerAreaBase
Telerik.ReportViewer.WinForms.WinViewer
Telerik.ReportViewer.WinForms.ReportViewerBase
Telerik.ReportViewer.WinForms.ReportViewer
System.Windows.Forms.TreeView
Telerik.ReportViewer.WinForms.ReportExplorerForm.ReportExplorerTreeView
Telerik.ReportViewer.WinForms.DrawablePage
Telerik.ReportViewer.WinForms.ParametersArea.Composition
Telerik.ReportViewer.WinForms.ParametersArea.Matrix
Telerik.ReportViewer.WinForms.ReportViewerBase.UIState
Telerik.ReportViewer.WinForms.Resources
Telerik.ReportViewer.WinForms.Resources.Keys
Telerik.ReportViewer.WinForms.ZoomItem

See Also

Reference

Telerik.ReportViewer.WinForms Assembly


PlotArea DataTable

Telerik Reporting Q3 2008 Send comments on this topic.
PlotArea DataTable

Glossary Item Box

The PlotArea can display a table of the data in the chart. See the screen shot below. By default the DataTable Visible property is false. Use the DataTable Appearance property to control the table layout including table size, cell size and cell position.

The PlotArea DataTable


PlotArea EmptySeriesMessage

Telerik Reporting Q3 2008 Send comments on this topic.
PlotArea EmptySeriesMessage

Glossary Item Box

When there are no series defined or no data within any of the series, a predefined message displays in the PlotArea.

EmptySeriesMessage contains the message text and the overall appearance of the message.


PlotArea MarkedZones

Telerik Reporting Q3 2008 Send comments on this topic.
PlotArea MarkedZones

Glossary Item Box

PlotArea MarkedZones are ranges that can be labeled and filled to highlight areas of the chart or to visually group data. The MarkedZones property by default display behind the chart series.

Chart with MarkedZones

Populate the ValueStartX, ValueEndX, ValueStartY and ValueEndY properties using the ChartMarkedZone Collection Editor:

ChartMarkedZone Collection Editor

Or you can define ChartMarkedZone objects in code and add them to the PlotArea MarkedZones collection.


The Chart User Interface

Telerik Reporting Q3 2008 Send comments on this topic.
The Chart User Interface

Glossary Item Box

To quickly set up your basic chart structure, Chart can be accessed interactively using:

  • Smart Tag menu: Use the Smart Tag menu to quickly access the Chart basics, i.e. title, series data, chart type, data binding, series palette, chart dimensions and image output type.
  • RadChart Wizard: Use the Chart Wizard when you want to reduce the number of properties that need to be viewed, but where the Smart Tag does not allow enough control. The Chart Wizard includes settings for chart Type, Data, Skin, Labels, Legend & Title, Axis and Values Data Table