How to Find Information in this Help

Telerik RadWindow v1.9 Send comments on this topic.
How to Find Information in this Help

Glossary Item Box

In this manual you can find information in the following sections:

  • Telerik RadWindow at a glance - a brief summary of the new functionality together with some of the most important existing features divided into conditional categories for clarity.
  • Getting Started - the steps you need to undertake before you start the real game (work) with Telerik RadWindow.

The rest of the manual contains information about the following:

  • Standards Compliance (Accessibility and XHTML)

  • AJAX Support

  • Installation and Deployment

  • Telerik RadWindow Overview

  • Customizing Behavior

  • Customizing Appearance

  • Telerik RadWindow Client-Side

  • API Reference

Feedback

You can send us comments on any topic by clicking on the link in the top right corner of the page:

The Send comments link

Alternatively, you can send an email to documentation@telerik.com with feedback or inquiries concerning our manuals.

Additional resources of information

In case you cannot find the needed information in this manual, you can also review the following resources:

  • online Knowledge Base - visit http://www.telerik.com/KB/ and browse or search the articles for a solution to your problem;
  • Telerik product forums at http://www.telerik.com/Forums/ - consult with other people who use our products;
    Use the in-built search on the page.
  • live examples at http://www.telerik.com/Telerik RadControls for ASP.NET/ - use the left pane to navigate to the control and functionality you need. In the right pane, toggle among the various pages (Description, C#, ASPX, etc.) to learn about the functionality displayed.
  • contact Telerik support with a technical question using your Client.NET account at http://www.telerik.com/Default.aspx?PageId=2069.
  • The Code Library is a new community resource where customers and Telerik developers can exchange code samples and share knowledge - download a growing number of samples, get hands-on experience with the Telerik RadControls for ASP.NET and submit some of your favorite implementations.

Before you ask the support for cooperation, please make sure you have passed through all steps above.

© 2002-2008 Telerik. All Rights Reserved.


Introduction

Telerik RadWindow v1.9 Send comments on this topic.
Introduction
RadWindow at a glance > Introduction

Glossary Item Box

New major version of RadWindow is now available as a part of RadControls “Prometheus” for ASP.NET. Its new architecture is based on top the ASP.NET AJAX framework in order to directly benefit from client-side behaviors and capabilities. We strongly recommend using the new version for all new development.

W3C XHTML Compliant W3C Level A Accessibility Compliant

Thank you for choosing Telerik RadWindow!

Telerik RadWindow is an unique component that can replace the standard browser dialogs and alert/prompt/confirm boxes. Developers can easily build modal and non-modal dialogs and windows, individually or in groups that mimic the behavior of the Windows taskbar.

Telerik RadWindow takes full advantage of the new features of Microsoft's next-generation IDE - Visual Studio .NET 2005, hence allowing developers to enjoy significant productivity gains, while delivering feature-rich, standards-compliant and cross-browser compatible web applications.

The product is available individually or as a part of the Telerik RadControls for ASP.NET suite - "Unleashing the power of Thin Client!".

Key Features:

  • Functionality in brief

Getting Started:

  • Getting Started
  • Differences from existing browser windows
  • Differences from Telerik RadDock

If you need further assistance, please contact clientservice@telerik.com

Revised: 4/11/2008

© 2002-2008 Telerik. All Rights Reserved.


What's New

Telerik RadWindow v1.9 Send comments on this topic.
What's New
See Also
RadWindow at a glance > What's New

Glossary Item Box

New major version of RadWindow is now available as a part of RadControls “Prometheus” for ASP.NET. Its new architecture is based on top the ASP.NET AJAX framework in order to directly benefit from client-side behaviors and capabilities. We strongly recommend using the new version for all new development.

Unlike the other Telerik RadControls for ASP.NET, Telerik RadWindow does not fully support Embedded Web Resources. The product uses files, which cannot be implemented as Embedded Web Resources and only JavaScript files are currently embedded in the assembly. Therefore, you will always need to have the RadC??ntrols folder included in your applications.

What's new in Telerik RadWindow 1.8

The current version features numerous bug fixes and performance optimizations.

What's new in Telerik RadWindow

1. New server properties:

  • ReloadOnShow - new property that specifies whether the page that is loaded in the window will be cached from the browser or not.
  • ShowPageDuringLoad - new property that gets or sets a value indicating whether the page that is loaded in the window should be shown during the loading process, or when it has finished loading (useful in scenarios where controls on the page being loaded expect the page to be visible to properly position themselves).
  • OnClientPageLoad - new property that specifies the client function to be called when a page is loaded in a Telerik RadWindow.

2. Moved client events from the RadWindowManager level to the RadWindow level - a very common request.

3. CallBackFunction changed to support the ability to fire on the RadWindow level and not on the RadWindowManager level.

4. Localization support for Telerik RadWindow popups (radalert, radconfirm, radprompt).

5. Client API Additions

  • SetStatus(str) method - displays content in the window status bar.
  • GetContentFrame() method - returns a reference to the window content iframe.

See Also

Accessibility Compliance
XHTML Compliance

© 2002-2008 Telerik. All Rights Reserved.


Functionality in brief

Telerik RadWindow v1.9 Send comments on this topic.
Functionality in brief
RadWindow at a glance > Functionality in brief

Glossary Item Box

  1. Telerik RadWindow is compatible with Atlas. See Atlas support.

  2. Full Customization of the Visual Appearance - the appearance of Telerik RadWindow can be easily customized using skins. This allows you to easily blend it with the design your web application.

    See a live example at www.telerik.com...

  3. Full Control Over Window Visibility and Location - developers have full control over the initial visibility and position of the windows, by simply setting a combination of 3 properties:
    a? Windows can be shown automatically when page loads or show on click (VisibleOnPageLoad property)
    a? Windows can be shown relative to an html element (OffsetElementId property)
    a? A clicked element can automatically open a particular Telerik RadWindow (OpenerElementId property)

    Show And Position

    See a live example at www.telerik.com...

  4. Rich Client Event Model - Telerik RadWindow provides a few client-side events, which allow you to achieve a level of interactivity that is only possible in Windows applications.

    See a live example at www.telerik.com...

  5. Various Minimization Modes - when minimized, Telerik RadWindow objects can be "docked" to an HTML element, such as a DIV or a TD. In turn, the HTML element can be styled to resemble an interface element a for example, a taskbar. As a result, developers can mimic the behavior of the Windows taskbar and have the minimized Telerik RadWindow objects conveniently arranged to a predefined location.

    See a live example at www.telerik.com...

  6. Keyboard Support - Telerik RadWindow manager can map keyboard shortcuts to commands. Shortcuts can be used to switch between active windows, maximize or close the currently active window. You can also perform additional tasks with the keyboard, since every public API method of the client RadWindowManager that does not require parameters can be associated with a shortcut.

    See a live example at www.telerik.com...

  7. Circumvents the Windows XP SP2 Popup Blocker Mechanism - an extremely important feature or Telerik RadWindow is that it is not affected by the popup blocking mechanism of Windows XP SP2. As a result developers can easily implement applications with advanced interfaces without being affected by the security settings of the user browsers.

  8. Implement Cross-Browser "Modal" Dialogs - creating cross-browser modal dialogs has always been a challenging task for developers. Thanks to the wide cross-browser support of Telerik RadWindow and the straightforward setting for modal mode (Modal property) this problem can be easily eliminated.

  9. Implement Splash Screens a in some cases developers would need to show only the content of the window, without the border and title bar. This configuration is suitable for splash screens and for windows, which should not be controlled by the user but just programmatically.

    See a live example at www.telerik.com...

  10. Predefined Alert, Confirm, and Prompt Dialogs - Telerik RadWindow provides an easy way to replace the standard dialog boxes provided by the browser. Compared with the standard browser popups Telerik RadWindow bring the following advantages:
    a? Fully customizable appearance - allows blending them into the design of the site and thus increasing usability.
    a? Re-arrangeable elements - you have complete control over the position of the popup the elements (icon, text, buttons).
    a? Control over the initial size - you can provide width and height as extra parameters.
    a? Use HTML as content - as opposed to browser popups that are only able to display text, you are free to pass HTML to be displayed in the Telerik RadWindow popups for a richer user experience and improved usability.

    See a live example at www.telerik.com...

  11. Window Caching - once a window is loaded it is not going to be destroyed when you hide it. So next time it will be shown immediately with no loading time. In case you want to run some initialization code and pre-set the elements in the window, you need to put it in the in the OnClientShow event handler.

  12. Localization Support - The elements of Telerik RadWindow such as buttons' captions, buttons' tooltips, window headers, etc., are easily localizable through an XML file. There are three default localization files - English, German and French. You can modify these files or create your own to add a new language.

  13. Templated Windows - For each Telerik RadWindow skin the appearance of the following items can be fully customized not only in terms of css, but also in terms of html content and arrangement:
    1. Minimized state
    2. Splash screen
    3. Alert box
    4. Prompt box
    5. Confirm box
    The definitions of their html templates are stored in an XML file (RadControls/Window/Skins/SKIN_NAME/CoreTemplates.xml).
    Several real-life implementation scenarios would be:
    1. Create a left-to-right skin that puts the icons of the dialog boxes on the right side, rather than on the left.
    2. Change the minimized state template to remove the close button, add additional buttons, put advanced css settings, etc.

© 2002-2008 Telerik. All Rights Reserved.


Getting Started

Telerik RadWindow v1.9 Send comments on this topic.
Getting Started
RadWindow at a glance > Getting Started

Glossary Item Box

To add Telerik RadWindow to an ASP.NET WebForm you can use either of the following approaches:

  • Drag the Telerik RadWindow icon from the Visual Studio Toolbox;

  • Write the Telerik RadWindow tag manually.
If your RadControls folder contains multiple subfolders for Telerik controls - for example, if you are using a Telerik RadControls for ASP.NET installation as opposed to a Telerik RadWindow installation - make sure you copy only the subfolders of the controls you are going to use (Window and any other controls you need). Do not copy the subfolders of controls you are not planning to use.

Adding Telerik RadWindow to a WebForm using Visual Studio .Net

  1. Drag and drop the RadWindowManager control to your page. The following RadWindowManager declaration will automatically be added in your aspx:
    ASP.NET Copy Code
    <rad:RadWindowManager
    ID="RadWindowManager1"
    runat="server">
    </rad:RadWindowManager>
  2. Now you can add RadWindows via the RadWindow Collection Editor:
    1. Select the RadWindowManager and open its Properties pane (in design mode right-click on the control and select Properties from the dropdown menu).
    2. Click on the ellipsis next to the Windows Collection in the Data section of the Properties pane. This will open the RadWindow Collection Editor.
    3. Add RadWindows in the Windows collection and set the needed properties. If you want the RadWindow to be automatically shown when the page is loaded, you will need to set the VisibleOnPageLoad property to true.
    4. Once finished, press the OK button.
    5. Make sure that the RadControls/Window folder exists in your web application. The Telerik RadWindow control still needs some resources from the folder - unlike most of the other Telerik controls that can run only by their DLL
    6. Compile and open your page in the browser.

Adding Telerik RadWindow to a WebForm manually

Alternatively you can add the RadWindows in the RadWindowManager's Windows collection by manually typing them in the RadWindowManager declaration:

Again, you must make sure that the RadControls/Window folder exists in your web application.

A small movie demonstrating how to create and configure a RadWindow is available online here.

© 2002-2008 Telerik. All Rights Reserved.


Differences from existing browser windows

Telerik RadWindow v1.9 Send comments on this topic.
Differences from existing browser windows
See Also
RadWindow at a glance > Differences from existing browser windows

Glossary Item Box

1. Cross-platform, cross-browser look and feel.

2. 100% customizable look & feel (including status bar, icons, title bar, buttons).

3. Capable of accepting and returning arguments.

4. Rich event model (on load, on resize, on close, on open).

5. Ability to dock to a toolbar .

6. Not blocked by popup blockers.

7. Shortcut support.

8. Caching of content (no need to reload on subsequent shows).

9. Splash screen capabilities.

10. Fully customizable alert/prompt/confirm boxes.

11. Persist position/size/other properties on postbacks.

See Also

What's New
Differences from Telerik RadDock

© 2002-2008 Telerik. All Rights Reserved.


Differences from Telerik RadDock

Telerik RadWindow v1.9 Send comments on this topic.
Differences from Telerik RadDock
See Also
RadWindow at a glance > Differences from Telerik RadDock

Glossary Item Box

1. Loads external documents (while dock is rendered hidden on the page which leads to potentially bigger pages).

2. Support for input parameters, and callback function that returns result.

3. Support for onload (when content in Telerik RadWindow loads).

4. Modal/Nonmodal.

5. Non-dockable.

6. a?Cacheablea? on the client.

7. Support for Shortcuts for various actions (“ESC” for close; associate opening - different windows to open with different shortcuts (“F2”, “F3”, “F4”, etc.).

8. Hierarchy a windows containing other windows.
9. A visual "window-switcher" similar to the ALT-TAB in Windows. Could be ALT-Q.

See Also

What's New
Differences from existing browser windows

© 2002-2008 Telerik. All Rights Reserved.


Which license should I use or purchase

Telerik RadWindow v1.9 Send comments on this topic.
Which license should I use or purchase
See Also
Licensing > Which license should I use or purchase

Glossary Item Box

Telerik offers several different packages for you to choose from:

Trial licenses

Description

If you are a first-time Telerik user, it would be best to create an account in our Client.NET extranet (www.telerik.com/Clientnet) and download a Trial license. The Trial licenses are fully-functional and are identical in functionality to the paid versions. Review the Which file do I need to install? section for further instructions.

Support

A trial license comes with the Bronze Support package, which guarantees a 72-hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used. Mail queries usually take longer to respond.

For more information, review the available Support Options.

Single Developer licenses

Description

A Developer license is granted per developer seat: one developer is allowed to work with the product per license. Developer licenses have no run-time limitations and allow the usage of all Telerik controls in an UNLIMITED number of custom web applications. The controls can be installed on more than one machine as long as only the licensed developer is using the product.

License Keys

Developer licenses come with special builds that work without keys and allow the developer to safely access web applications that use Telerik products. To update your application from a trial license to a Developer license, please review the instructions in the following section: Trial License v1.x to Developer License v1.x

Support

The Single Developer license comes with the Silver Support package which guarantees a 48 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used.
Mail queries usually take longer to respond.

For more information, review the available Support Options.

Single Developer Subscription license

Description

Unlike the Single Developer license, Single Developer Subscription license offers a Subscription. A Subscription license entitles you to receive, for free, all released updates and new products for the duration of one year from the date of purchase. This license is the easiest and most cost-effective way to ensure that you are using the latest versions of our products. With the Subscription license you save more than 70% on Telerik products if purchased separately.

The Single Developer Subscription license is offered for the Telerik RadControls for ASP.NET suite only. Subscriptions are not available for individual products at this time.

You can renew your subscription at approximately 50% of the original price. You will be promptly notified when the Subscription license is about to expire.

All RadControls for ASP.NET subscription holders are entitled to a license to RadControls "Prometheus" suite.

License Keys

The Developer license comes with a special build that work without keys and allow the developer to safely access web applications that use Telerik products. To update your application from Trial to a Developer license, please review the instructions in the following section: Trial License v1.x to Developer License v1.x

Support

The Single Developer Subscription license comes with the Gold Support package which guarantees a 24 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used.
Mail queries usually take longer to respond.

For more information, review the available Support Options.

Telerik maintains a public Product Roadmap, which will give you details on the upcoming products and versions for the next quarter. This guarantees that you see a good return on your investment in the Subscription license.

Source Code license

Description

The Source Code license is an excellent investment if you need to customize our controls to fit a specific requirement, or if your company wishes to own the source code for all products used.

A Source Code license is offered with purchases of five or more Single Developer or Single Developer Subscription licenses for Telerik RadControls for ASP.NET suite. If you have opted for the Subscription license, you will be receiving the source codes for all products released within one year from the date of purchase.

Source Code licenses are offered for the Telerik RadControls for ASP.NET suite only and are not available for individual products at this time.

Support

The Source Code license comes with the Gold Support package, which guarantees a 24 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used. All questions from Source code licensees are treated with priority.

For more information, review the available Support Options.

Custom Source Code modifications are not supported by Telerik.

Discounts Offered

Telerik offers the following volume discounts on all licenses:

  • 3 to 4 licenses - 10%
  • 5 to 9 licenses - 20%
  • 10 to 19 licenses - 30%
  • 20 or more - 40%

Telerik also offers discounts to qualified educational, non-profit, charity and government entities. For more information on how to qualify for a discount, visit our Special pricing page.

See Also

Sales FAQ page
Purchase Online
Support Options
Support FAQ
Client.Net FAQ
License Agreement

© 2002-2008 Telerik. All Rights Reserved.


License Agreement

Telerik RadWindow v1.9 Send comments on this topic.
License Agreement
Licensing > License Agreement

Glossary Item Box

Telerik End-User License Agreement

By purchasing, installing, or otherwise using the product identified above and/or its related materials, you agree to be bound by the terms and conditions of this License Agreement. Check the box "I have read and agree to the License Agreement" if you agree.

IMPORTANT – READ CAREFULLY: This license agreement ("LICENSE") is a legal agreement between you (either an individual or a single entity, also referred to as "LICENSEE", "YOU") and Telerik Corp., ("TELERIK"), for the software containing this LICENSE which may also include the software’s source code written in a high-level computer language, associated media, printed materials, and "online" or electronic documentation (collectively referred to as “SOFTWARE”).

Any earlier license we may have granted to you for the use of earlier versions of the SOFTWARE is replaced by this LICENSE.

SOFTWARE PRODUCT LICENSE

The SOFTWARE is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties and contains confidential information and trade secrets. TELERIK retains all rights not expressly granted to you in this LICENSE.

I. GRANT OF LICENSE

TELERIK hereby grants to you, and you accept, a non-exclusive, non-transferable license to install, copy, use and modify the SOFTWARE only as authorized below.

This license grants you no rights to the "2007 Microsoft Office System User Interface". For appropriate license, please, contact Microsoft directly.

1. TRIAL LICENSE

You are granted a license for evaluation purposes only. You are authorized to install, copy, and use the SOFTWARE for the sole purpose of testing its functionality. You are not allowed to integrate it in end products or use it for any commercial purpose.

2. DEVELOPER LICENSE

The SOFTWARE is licensed per Developer seat. This means that each individual using or otherwise accessing the SOFTWARE for development purposes must obtain the right to do so by purchasing an individual product license.

You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same licensed developer. The SOFTWARE is in "use" on a computer when it is loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard disk or other storage device) of that computer for development purposes. If you install the SOFTWARE on a network server for the sole purpose of internal distribution among licensed developers this is not considered “use” of the SOFTWARE.

2-1. Redistribution rights:

All product licenses are perpetual and royalty-free. You can ship the SOFTWARE as part of solutions for internal company use, hosted applications, commercial solutions deployed at end-users’ sites or shrink-wrapped software (PACKAGED PRODUCTS) in which the SOFTWARE is integrated.

You may distribute the SOFTWARE provided that:

  • You reasonably ensure that the SOFTWARE is not distributed in any form that allows it to be reused by any application other than your solution. Technical guidelines will be provided upon request, please contact support@telerik.com for more details.
  • You need to duly inform your customers that they are not allowed to use the SOFTWARE independently from your solution. For use of the SOFTWARE in design-time (i.e. within a development environment such as Microsoft Visual Studio) your customers need to purchase the appropriate number of Developer Licenses from TELERIK.
  • You need to include a valid copyright message in your solution in a location viewable by the end-users (e.g. "About" box).

2-2. Silver Support:

As part of your license you are entitled to "Silver" Support Package which guarantees response within 48 hours.

3. DEVELOPER LICENSE PLUS SUBSCRIPTION AND SOURCE CODE LICENSE

You are granted 1 (one) Developer License as defined above. In addition you are entitled to a 1 Year Subscription, Source Code and Gold Support Package.

3-1. Subscription

You are entitled to receive all version updates for the SOFTWARE for a period of 1 (one) year.

  • 3-2. Source Code

    As part of the DEVELOPER PLUS SUBSCRIPTION AND SOURCE CODE LICENSE you are granted the right to view and modify the SOFTWARE's source code only as authorized below:
  • The SOFTWARE's source code is provided to the licensed developer for the sole purposes of education and troubleshooting. The SOFTWARE's source code cannot be used as a basis of development of derivative works or other software products.
  • Under no circumstances may any portion of the SOFTWARE’s source code or any modified version of the source code be distributed, disclosed or otherwise made available to any third party.
  • TELERIK DOES NOT provide technical support for modified source code.
  • The SOFTWARE’s source code is provided as is. Refunds are not available for licenses that include source code.
  • In the event you develop any troubleshooting-related modifications of the SOFTWARE, either independently or jointly with TELERIK, such modifications and all rights associated therewith will be the exclusive property of TELERIK. You are granted the right to use such modifications as set forth in this agreement.
  • You acknowledge that the SOFTWARE’s source code contains valuable and proprietary trade secrets of TELERIK. All individuals employed by or belonging to your entity agree to expend every effort to insure its confidentiality. You agree to assume full responsibility for such employees’ or contractors’ use, or misuse, of such disclosed source code as if it was your use. These obligations shall not apply to any information generally available to the public, independently developed or obtained without reliance on TELERIK information, or approved in writing for release by TELERIK without restriction.

3-3. Gold Support:

As part of your license you are entitled to "Gold" Support Package which guarantees response within 24 hours.

II. OTHER RIGHTS AND LIMITATIONS

  • At no time may the SOFTWARE be used for development purposes by other individuals than the licensed developer(s).
  • The SOFTWARE may not be distributed for use with solutions or PACKAGED PRODUCTS other than those developed by you.
  • The SOFTWARE may not be distributed part of products that have the same or substantially the same primary functionality. (Example for RadControls for ASP.NET: you may purchase Telerik RadEditor for ASP.NET and create a blog application/component. However, you cannot wrap RadMenu and offer it as a SharePoint WebPart or DNN menu skin object, since its primary functionality would be substantially the same as the SOFTWARE.
  • You are not allowed to resell, transfer, rent, lease, or sublicense the SOFTWARE and your associated rights. Under no circumstances shall you grant further redistribution rights to the end-users of your solution.
  • You may not use the TELERIK product names, logos or trademarks to market YOUR SOFTWARE.
  • You are not allowed to disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.
  • You are not allowed to use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.
  • You agree to indemnify, hold harmless, and defend TELERIK and its resellers from and against any and all claims or lawsuits including attorney's fees that arise or result from the use or distribution of YOUR SOFTWARE

III. DELIVERY

TELERIK shall deliver to LICENSEE a master copy of the SOFTWARE licensed hereunder in electronic files only. Documentation shall also be provided in electronic format.

IV. UPGRADES

You are eligible for free minor upgrades (e.g. v.1.5 to v.1.8), patches, and bug-fixes for the SOFTWARE, including source code if applicable. SOFTWARE labeled as an upgrade replaces and/or supplements (and may disable) the product that formed the basis for your eligibility for the upgrade. You may use the resulting upgraded product only in accordance with the terms of this LICENSE.

If you have purchased a "DEVELOPER PLUS SUBSCRIPTION AND SOURCE CODE LICENSE” you are entitled to receive all version updates for the SOFTWARE period of 1 (one) year.

V. TERMINATION

This LICENSE shall last as long as you use the SOFTWARE in compliance with this LICENSE. TELERIK may terminate this LICENSE if you fail to comply with any of the terms and conditions herein. In such event you agree to remove and destroy all copies of the SOFTWARE and any applicable source code.

TELERIK reserves the right to discontinue at any time any product, shall it be offered individually or as a part of a product SUITE. However, TELERIK is obligated to provide the proper level of support for all discontinued products for a period of 1 (one) year after the date of discontinuance.

VI. COPYRIGHT

All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animations, video, audio, music, text, incorporated into the SOFTWARE), the accompanying printed materials, and any copies of the SOFTWARE, and any trademarks or service marks of TELERIK are owned by TELERIK. All title and intellectual property rights in and to the content that may be accessed through use of the SOFTWARE is the property of the respective content owner and may be protected by applicable copyright or other intellectual property laws and treaties. This LICENSE grants you no rights to use such content.

VII. LIMITED WARRANTY

TELERIK warrants solely that the SOFTWARE will perform substantially in accordance with the accompanying written materials for a period of ninety (90) days. TELERIK does not warrant the use of the SOFTWARE will be uninterrupted or error free at all times and in all circumstances, nor that program errors will be corrected. This limited warranty shall not apply to any error or failure resulting from (i) machine error, (ii) LICENSEE's failure to follow operating instructions, (iii) negligence or accident, or (iv) modifications to the SOFTWARE by any person or entity other than TELERIK. In the event of a breach of warranty, LICENSEE 's sole and exclusive remedy, is repair of all or any portion of the SOFTWARE. If such remedy fails of its essential purpose, LICENSEE 's sole remedy and TELERIK's maximum liability shall be a refund of the paid purchase price for the defective SOFTWARE only. This limited warranty is only valid if TELERIK receives written notice of breach of warranty within thirty days after the warranty period expires.

VIII. LIMITATION OF LIABILITY

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT WILL TELERIK BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OF OR INABILITY TO USE THE PRODUCT, INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF, AND REGARDLESS OF THE LEGAL OR EQUITABLE THEORY (CONTRACT, TORT OR OTHERWISE) UPON WHICH THE CLAIM IS BASED. IN ANY CASE, TELERIK'S ENTIRE LIABILITY UNDER ANY PROVISION OF THIS AGREEMENT SHALL NOT EXCEED IN THE AGGREGATE THE SUM OF THE LICENSE FEES LICENSEE PAID TO TELERIK FOR THE PRODUCT GIVING RISE TO SUCH DAMAGES, NOTWITHSTANDING ANY FAILURE OF ESSENTIAL PURPOSE OF ANY LIMITED REMEDY. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS EXCLUSION AND LIMITATION MAY NOT BE APPLICABLE. TELERIK IS NOT RESPONSIBLE FOR ANY LIABILITY ARISING OUT OF CONTENT PROVIDED BY LICENSEE OR A THIRD PARTY THAT IS ACCESSED THROUGH THE PRODUCT AND/OR ANY MATERIAL LINKED THROUGH SUCH CONTENT. ANY DATA INCLUDED IN A PRODUCT UPON SHIPMENT FROM TELERIK IS FOR TESTING USE ONLY AND TELERIK HEREBY DISCLAIMS ANY AND ALL LIABILITY ARISING THEREFROM. THE EXTENT OF TELERIK'S LIABILITY FOR THE LIMITED WARRANTY SECTION SHALL BE AS SET FORTH THEREIN.

IX. MISCELLANEOUS

This License will be governed by the law of the State of Massachusetts, U.S.A. If any provision of this LICENSE is to be held unenforceable, such holding will not affect the validity of the other provisions hereof. Failure of a party to enforce any provision of this LICENSE shall not constitute or be construed as a waiver of such provision or of the right to enforce such provision.

This License represents the entire understanding between the parties with respect to its subject matter.

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, THAT YOU UNDERSTAND THIS AGREEMENT, AND UNDERSTAND THAT BY CONTINUING THE INSTALLATION OF THE SOFTWARE PRODUCT, BY LOADING OR RUNNING THE SOFTWARE PRODUCT, OR BY PLACING OR COPYING THE SOFTWARE ONTO YOUR COMPUTER HARD DRIVE, YOU AGREE TO BE BOUND BY THIS AGREEMENT'S TERMS AND CONDITIONS. YOU FURTHER AGREE THAT, EXCEPT FOR WRITTEN SEPARATE AGREEMENTS BETWEEN TELERIK AND YOU, THIS AGREEMENT IS A COMPLETE AND EXCLUSIVE STATEMENT OF THE RIGHTS AND LIABILITIES OF THE PARTIES.

© 2002-2008 Telerik. All Rights Reserved.


System requirements and browser support

Telerik RadWindow v1.9 Send comments on this topic.
System requirements and browser support
Installation and deployment > Installation > System Requirements > System requirements and browser support

Glossary Item Box

System Requirements

The following page describes the system requirements needed by Telerik RadControls for ASP.NET:

http://www.telerik.com/support/requirements-and-compliance/system-requirements.aspx

Browser Support

The following page shows all browsers and versions supported by Telerik RadControls for ASP.NET:

http://www.telerik.com/support/requirements-and-compliance/browser-support.aspx

Browser Limitations

The following article explains the browser limitations and what implications they have on Telerik RadControls for ASP.NET:

http://www.telerik.com/support/browser-support/browser-issues.aspx

Files and folders needed by Telerik RadWindow and Telerik RadControls for ASP.NET to function

The following section explains the files and folders needed to be used in your application in order for Telerik RadControls for ASP.NET to function properly:

Files and folders needed by Telerik RadControls for ASP.NET

© 2002-2008 Telerik. All Rights Reserved.


Which file do I need to install?

Telerik RadWindow v1.9 Send comments on this topic.
Which file do I need to install?
See Also
Installation and deployment > Installation > Installing Telerik RadWindow on your computer > Which file do I need to install?

Glossary Item Box

Telerik offers you the following ways to install Telerik RadWindow:

  • as an individual install, or
  • as part of the complete Telerik RadControls for ASP.NET suite.

If you plan to use only Telerik RadWindow in your project, we recommend that you install Telerik RadWindow only. In case you want to use two or more products from the Telerik RadControls for ASP.NET suite, it is probably better to install the full Telerik RadControls for ASP.NET suite.

Each installation package comes in three types:

  • EXE file for automatic installation;
    The EXE files are intended for easy and automatic installation of a product. It installs the control(s) on your computer in a folder in your Program Files named Telerik, and automatically creates the necessary virtual folders and projects. Additionally, the EXE installs the help file(s) in your VS.NET IDE and in your local copy of MSDN (if you have one). The EXE files are best for first-time Telerik users and ASP.NET novices.
  • ZIP file for manual (advanced) installation;
    The ZIP is used for manual (advanced) installs and for upgrading/updating purposes. The folder structure is different from the EXE. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot. Use the ZIP file for installation on shared hosting.
  • DLL and Scripts only (a.k.a. HOTFIX) file for updating/upgrading a product to a newer version;
    This is a bare-bones upgrade option for our controls. The DLL and Scripts files contain only those files that you need to replace in your project to upgrade to the new version of a Telerik control. If you are already using a Telerik product and just want to update it, there is no need to download the complete suite - download the latest HOTFIX for the product and apply it.
The latest EXE and ZIP packages available for download already have all updates/HOTFIXES applied. There is no need to update them further.

If you already have a Telerik control installed from the EXE, you can safely install an updated version of the same control - the installer will keep your existing installation. The new files will be placed in a separate folder and the new installation does not damage the common installer files. The new Telerik RadWindow installation may have an updated help too: it is registered with the correct window namespace. You can see the updated Telerik RadWindow help in your help2 viewer.

See Also

Installing the Telerik RadControls for ASP.NET suite from EXE file
Installing the Telerik RadControls for ASP.NET suite from ZIP file
Installing Telerik RadWindow from EXE file
Installing Telerik RadWindow from ZIP file
Using the 'DLL and Scripts only' file (HOTFIX)

© 2002-2008 Telerik. All Rights Reserved.


Installing the Telerik RadControls for ASP.NET suite from EXE file

Telerik RadWindow v1.9 Send comments on this topic.
Installing the Telerik RadControls for ASP.NET suite from EXE file
See Also
Installation and deployment > Installation > Installing Telerik RadWindow on your computer > Installing the Telerik RadControls for ASP.NET suite from EXE file

Glossary Item Box

The EXE files are intended for easy and automatic installation of a product. The EXE installs the suite on your computer to a folder named Telerik in your Program Files, automatically creating the necessary virtual folders and projects. Additionally, it installs the help file(s) in the VS.NET IDE and in your local copy of MSDN, if you have one installed.

The EXE files are best for first-time Telerik users and ASP.NET novices.

The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
The EXE installation will not overwrite previous Telerik RadControls for ASP.NET installations, unless it is of the same version.

Install with Internet Information Services (IIS) Running

To install Telerik RadControls for ASP.NET on your machine from the EXE file, follow the instructions below:

  1. Log into your Client.NET account.
  2. Go to My Licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab and download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadControls EXE file and follow the instructions.

    The wizard will install the Telerik RadControls for ASP.NET component in the following folder unless you specify otherwise:
    C:\Program Files\Telerik\RadControlsQ1 2007.

The wizard will create the necessary virtual folders.

To view live examples of the Telerik RadWindow functionality, you can launch the Quick-Start Framework in either of the following ways:

  • Open Start Menu -> Programs -> Telerik -> RadControls Q1 2007 for ASP.NET -> ASP.NET 2.X -> RadControls Q1 2007 C#/VB Live Examples,
  • Double-click the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\RadControlsQ1 2007\NET2,
  • or drag the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\RadControlsQ1 2007\NET2 to start the examples in your browser.

Install without Internet Information Services (VS 2005 only)

To install Telerik RadControls on your machine from the EXE file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab to download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadControls EXE file and follow the instructions.

    The wizard will install the Telerik RadControls for ASP.NET component in the following folder unless you specify otherwise:
    C:\Program Files\Telerik\.

When Internet information Services is not running, the product installation will NOT create virtual directories for the QSF, nor will it create any shortcuts for launching the QSF on localhost. To launch the Quick-Start framework, open and Run (Ctrl+F5) its VisualStudio Web Site using the provided shortcut in the Start Menu:
Start Menu -> Programs -> Telerik -> RadControlsQ1 2007 for ASP.NET-> ASP.NET 2.X -> Open Sample Web Site in Visual Studio
VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

The Telerik RadControls for ASP.NET package adds the products automatically to the VS.NET 2005 toolbox. To learn how to add them manually, see Adding Telerik RadWindow to the Visual Studio 2005 Toolbox.

See Also

Files and folders needed by Telerik RadControls for ASP.NET
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Installing Telerik RadWindow from EXE file

Telerik RadWindow v1.9 Send comments on this topic.
Installing Telerik RadWindow from EXE file
See Also
Installation and deployment > Installation > Installing Telerik RadWindow on your computer > Installing Telerik RadWindow from EXE file

Glossary Item Box

The EXE files are intended for easy and automatic installation of a product. The EXE installs the control on your computer to a folder named Telerik in your Program Files, automatically creating the necessary virtual folders and projects. Additionally, it installs the help file(s) in the VS.NET IDE and in your local copy of MSDN, if you have such installed.

The EXE files are best for first-time Telerik users and ASP.NET novices.

The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
The EXE installation will not overwrite previous Telerik RadWindow installations, unless it is of the same version.

Install with Internet Information Services (IIS) Running

To install Telerik RadWindow on your machine from the EXE file follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadWindow.
  4. Go to the Download tab and download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadWindow_1_9.exe and follow the instructions.

The wizard will create a virtual folder "Telerik RadWindow1.9NET2" (accessible at http://localhost/Telerik/telerikradwindow1.9_NET2).

To view live examples of the Telerik RadWindow functionality, you can launch the Quick Start Framework in either of the following ways:

  • Open Start Menu -> Programs -> Telerik -> Telerik RadWindow v1.9 -> ASP.NET 2.X -> Telerik RadWindow v1.9 C#/VB Live Examples,
  • Double-click the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\Telerik RadWindow v1.9\NET2,
  • or drag the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\Telerik RadWindow v1.9\NET2 to start the examples in your browser.

Install without Internet Information Services (VS 2005 only)

To install Telerik RadWindow on your machine from the EXE file follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Locate Telerik RadWindow, and click on it.
  4. Go to the Download tab to download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadWindow_1_9.exe and follow the instructions.

When Internet information Services is not running, the product installation will NOT create virtual directories for the QSF, nor will it create any shortcuts for launching the QSF on localhost. To launch the Quick-Start framework, open and Run (Ctrl+F5) its VisualStudio Web Site using the provided shortcut in the Start Menu:
Start Menu -> Telerik -> Telerik RadWindow v1.9 -> ASP.NET 2.X -> Open Sample Web Site in Visual Studio
VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

Telerik RadWindow will be added automatically to VS.NET 2005's toolbox. Review the following instructions to add it manually: Adding Telerik RadWindow to the Visual Studio 2005 Toolbox

The wizard will install the Telerik RadWindow component in the following folder unless you specify otherwise:
\Program Files\Telerik\Telerik RadWindow1.9\NET2.

The installation folder contains the following subfolders and files:

  • "bin" - contains the .dll files

  • "Common" - contains JavaScripts and css files

  • "RadControls" - contains the clients-side JavaScript and resource files
    You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.

  • "window" - contains the running examples from the Quick-Start framework

  • LiveExamplesCS - a browser link to run the C# version of the examples locally
  • LiveExamplesVB - a browser link to run the VB.NET version of the examples locally

The information below is generic for all Telerik controls. The particular details vary for individual control installations.

The installation folders of some Telerik controls may also contain the following subfolders:

  • "DeploymentActions" - contains the files required for proper deployment of the control
  • "Help" - contains all the files required for generating Help2
  • "Img" - contains system images
  • "InstalledRelated" - contains the files required for proper installation of the control

See Also

Add/Remove Telerik RadWindow to the Global Assembly Cache
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Installing the Telerik RadControls for ASP.NET suite from ZIP file

Telerik RadWindow v1.9 Send comments on this topic.
Installing the Telerik RadControls for ASP.NET suite from ZIP file
See Also
Installation and deployment > Installation > Installing Telerik RadWindow on your computer > Installing the Telerik RadControls for ASP.NET suite from ZIP file

Glossary Item Box

Show All Show All
Hide All Hide All

The ZIP is used to install Telerik RadControls for ASP.NET manually for upgrading or updating purposes. The folder structure is different from the EXE installation. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot.

Install without IIS Running (VS 2005 only)

To install the Telerik RadControls for ASP.NET suite on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Hide What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadControls for ASP.NET - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help1
    • HelpNET20 folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadControls for ASP.NET under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadControls for ASP.NET under ASP.NET2.x
    • other files and folders.
  5. The latest package available for download has all latest updates/HOTFIXES applied. There is no need to update it further.
  6. Once the download completes, create a Telerik_RadControls folder in your IIS's inetpub/wwwroot folder.
  7. From the downloaded file, extract the files from the NET2 folder into inetpub/wwwroot/Telerik_RadControls folder. After the process ends, the inetpub/wwwroot/Telerik_RadControls folder should contain the following files and folders:
    • app_themes folder - contains the themes and skins used by Telerik's navigational controls
    • bin folder - contains the controls' .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files, needed by Telerik's controls. You will need to copy this folder in your web application only if you intend to use skins different from the Default or if you plan to modify the JavaScript files.
      Exceptions: Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell, Telerik RadUpload and Telerik RadWindow products.
    • folders, named after Telerik's controls (i.e. Calendar, Chart, Combobox, etc.) - these contain the running examples for each control from the Quick-Start framework
    • other project files and folders.
  8. Create a .NET2 virtual directory for the folder where you extracted the files. Hide How?

    This is accomplished through the Internet Information Services console on your machine:
    Start -> Settings -> Control Panel -> Administrative Tools -> Internet Information Services:
    1. Right-click the folder you have created (Telerik_RadControls).
    2. Select Properties.
    3. Click the Create button. The application name will become Telerik_RadControls.
    4. Click Apply.
    5. Click the ASP.NET tab.
    6. From the drop-down list, select your ASP.NET 2.0 version:

      ASP.NET tab under .NET2.0
    7. Click OK.
  9. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (under IIS6, Windows Server 2003) on the folder where the files were extracted. See Setting ASNET (Network Service) Permissions for more information.

To run the examples paste the following link in your browser: http://localhost/Telerik_RadControls/

To register the MS Help 2 files to VisualStudio and MSDN, please review the following link:
http://www.telerik.com/Default.aspx?PageId=2657

To add any control to the VS.NET toolbox, review Adding Telerik RadWindow to the Visual Studio 2005 Toolbox
To use any Telerik ASP.NET control in your project, review Adding Telerik RadWindow to an ASP.NET WebForm

DO NOT include/add the examples in your VS.NET project as this will break the Telerik control(s).

See Also

Files and folders needed by Telerik RadControls for ASP.NET
Trial License Limitations
Register MS Help 2 files

© 2002-2008 Telerik. All Rights Reserved.


Installing Telerik RadWindow from ZIP file

Telerik RadWindow v1.9 Send comments on this topic.
Installing Telerik RadWindow from ZIP file
See Also
Installation and deployment > Installation > Installing Telerik RadWindow on your computer > Installing Telerik RadWindow from ZIP file

Glossary Item Box

Show All Show All
Hide All Hide All

The ZIP is used to install Telerik RadWindow manually for upgrading or updating purposes. The folder structure is different from the EXE installation. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot.

Install Telerik RadWindow with IIS running

To install Telerik RadWindow on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadWindow.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Show What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadWindow - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadWindow under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadWindow under ASP.NET2.x
    The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
  5. Once the download completes, create a RadWindow folder in your IIS's inetpub/wwwroot folder.
  6. From the downloaded file, extract all files from the NET2 folder into inetpub/wwwroot/RadWindow folder. After the process ends, the inetpub/wwwroot/RadWindow/ folder should contain the following files and folders:
    • App_Themes folder - contains some .NET2.0 themes provided by Telerik
    • bin folder - contains the .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files. You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.
      Exceptions: Because of the specific control features, you will always need to copy RadControls for RadChart, RadEditor, RadSpell, RadUpload and RadWindow products.
    • window folder - contains the running examples from the Quick-Start framework
    • other project files.
  7. Create a .NET2 virtual directory for the folder where you unzipped the files. Show How?
    This is accomplished through the Internet Information Services console on your machine:
    Start -> Settings -> Control Panel -> Administrative Tools -> Internet Information Services:
    1. Right-click the folder you have created (RadWindow).
    2. Select Properties.
    3. Click the Create button. The application name will become RadWindow.
    4. Click Apply.
    5. Click the ASP.NET tab.
    6. From the drop-down list, select your ASP.NET 2.0 version:

      ASP.NET tab under .NET2.0
    7. Click OK.
  8. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (under IIS6, Windows Server 2003) on the folder where the files were unzipped. See Setting ASNET (Network Service) Permissions for more information.

To run the examples, paste the following link in your browser: http://localhost/RadWindow

Install Telerik RadWindow without or with IIS stopped (VS 2005 Only)

To install Telerik RadWindow on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadWindow.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Show What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadWindow - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadWindow under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadWindow under ASP.NET2.x
    The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
  5. From the downloaded file, extract all files from the NET2 folder into folder at a convenient location on your disk. After the process ends, the folder should contain the following files and folders:
    • App_Themes folder - contains some .NET2.0 themes provided by Telerik
    • bin folder - contains the .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files. You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.
    • window folder - contains the running examples from the Quick-Start framework
    • other project files.
  6. Open and Run (Ctrl+F5) Quick-Start Framework VisualStudio Web Site using the provided solution file ControlsExamples.sln in the NET2 folder. VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

To register the MS Help 2 files to VisualStudio and MSDN, please review the following link:
http://www.telerik.com/Default.aspx?PageId=2657

To add Telerik RadWindow to the VS.NET toolbox, review Adding Telerik RadWindow to the Visual Studio 2005 Toolbox.

To use the Telerik RadWindow in your project, please review Adding Telerik RadWindow to an ASP.NET WebForm.

DO NOT include/add the examples in your VS.NET project as this will break the Telerik control(s).

See Also

Add/Remove Telerik RadWindow to the Global Assembly Cache
Trial License Limitations
Register MS Help 2 files

© 2002-2008 Telerik. All Rights Reserved.


Using the 'DLL and Scripts only' file (HOTFIX)

Telerik RadWindow v1.9 Send comments on this topic.
Using the 'DLL and Scripts only' file (HOTFIX)
See Also
Installation and deployment > Installation > Installing Telerik RadWindow on your computer > Using the 'DLL and Scripts only' file (HOTFIX)

Glossary Item Box

Show All Show All
Hide All Hide All

The "DLL and Scripts only" file (a.k.a. HOTFIX file) is a bare-bones upgrade option for our controls - they contain only those files that you need to replace in your project to upgrade to the new version of a Telerik control. If you are already using a Telerik product, there is no need to download the complete suite - download the "DLL and scripts only" version and follow the instructions below for applying the hotfix. The "DLL and Scripts only" file contains the following folders and files:

  • bin folder - contains the DLL file(s)
  • RadControls folder - contains the clients-side JavaScript and resource files for Telerik RadWindow
If you are installing a Telerik product for the first time, we recommend that you download the complete package (EXE or ZIP file).

To update Telerik RadWindow to a new version

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases" (or "My Free Trials" if you are a trial user).
  3. Locate the control that you need to install, i.e. Telerik RadWindow, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. If you have purchased the control, you need to download the file which has the Dev abbreviation in it.
  5. Once the download completes, unzip the files at a convenient location.
  6. If the upgrade is major (i.e. from v1.x to v1.x), check the Changes and Backward Compatibility section in this manual for further instructions.
  7. Back up your application.
  8. Close Visual Studio or any ither IDE which may lock the old assembly.
  9. From the newly downloaded and unzipped files, copy the new DLL (located in the bin folder) to your web-application's bin folder. Replace the old dll.
  10. [Optional. Follow this step only if you intend to use skins different from the default or if you plan to modify the JavaScript files
    Exceptions: Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products. ]
    Copy the new RadControls folder to the root of your web-application. Replace all files and folders when asked. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate the old folder and paste the new RadControls folder over it. Replace all files and folders when asked.
  11. If you are using VS.NET, update the control's reference in your project to point to the new DLL.
  12. Recompile your project.
  13. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadWindow to the Global Assembly Cache
  14. Run the project.
  15. If you still get the older version of Telerik RadWindow Hide click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadWindow's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadWindow, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....
  16. If you get a copyright message Show click here

    The copyright message appears only when using the trial version of Telerik RadWindow (the Developer versions of Telerik's controls do not throw copyright messages).

    If you have purchased the control, then you have downloaded the wrong "DLL and Scripts only" file. Make sure you you download the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

See Also

Add/Remove Telerik RadWindow to the Global Assembly Cache
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Setting ASPNET (Network Service) Permissions

Telerik RadWindow v1.9 Send comments on this topic.
Setting ASPNET (Network Service) Permissions
Installation and deployment > Installation > Installing Telerik RadWindow on your computer > Setting ASPNET (Network Service) Permissions

Glossary Item Box

In most applications, users typically access Web applications anonymously — that is, they do not initially provide authentication credentials. In that case, the Web application has to assume (impersonate) some identity that it can use to request resources.
By default, when ASP.NET allows anonymous access, the application runs in the context of a special local (not domain) account. The user context depends on the operating system. In Windows 2000 and Windows XP, applications run under the account called ASPNET. In Windows Server 2003, the user context is called NETWORK SERVICE. These user accounts are created during the .NET Framework installation process with a unique, strong password, and are granted only limited permissions. The ASPNET or NETWORK SERVICE user can access only specific folders that are required to run a Web application, such as the \bin directory in which a Web application stores compiled files.

Full information on the topic can be found in MSDN: Security Considerations for ASP.NET Web Applications

Instructions on how to give process permissions on a folder - FAT32 file system

No need to give any permissions on the folder.

Instructions on how to give process permissions on a folder - NTFS file system

Internet Information Services v5.x - name of account: ASPNET user

  1. Right-click on the RadWindow (or Telerik_RadControls) folder and select Properties.
  2. Click on the Security tab. If you do not see the security tab, click Show here

    The Security tab is not visible because you have Simple File Sharing enabled. You will need to disable it before you continue. To do so:
    1. Open a Windows Explorer.
    2. On the Tools menu, click Folder Options, and then click the View tab.
    3. In the Advanced Settings section, clear the Use simple file sharing (Recommended) check box (at the bottom of the list).
    4. Click OK.
    5. Right-click on the folder you need to add ASPNET permissions to and select Properties. Click on the Security tab.

  3. Click on Add (to add a new user).

  4. Click on Locations to select your local machine. Your screen should look similar to the following:

    Setting ASPNET permissions

  5. Select your local machine and click OK.

  6. Type ASPNET in the textbox and click on Check Names. ASPNET should underline (if it doesn't then you don't have Microsoft's .NET framework installed).

    ASPNET user

  7. Click OK.

  8. Select the LOCAL MACHINE NAME/ASPNET user you just created (it should be named ASP.NET Machine Account (NAME/ASPNET)) and check the Full Control box to give it full permissions.

  9. Click APPLY.

  10. Click Advanced and make sure that the "Inherit from parent ..." check box is checked.

  11. Click OK to close the Advanced properties.

  12. Click OK to close the folder properties.

Internet Information Services v6.x - name of account: Network Service user

Same as above but replace ASPNET with Network Service.

© 2002-2008 Telerik. All Rights Reserved.


Trial License Limitations

Telerik RadWindow v1.9 Send comments on this topic.
Trial License Limitations
See Also
Installation and deployment > Installation > Installing Telerik RadWindow on your computer > Trial License Limitations

Glossary Item Box

Developer Licenses

Developer licenses come with modified DLLs, which work without license keys. If you have a Developer license for one or more of the Telerik components, you only need to ensure that you are using the developer build when downloading the control(s). These builds have the Dev abbreviation in their file names.

If your application is displaying a license key error, this means that you are using a trial version of the product. Log in to your Client.net account and download the developer build. To update your project, please take a look at the Upgrading the Trial License to a Production License section for step-by-step instructions.

Trial Licenses

The free trial licenses of all Telerik products are fully functional and will work for an unlimited time but with trial error messages (see below) displayed randomly on the page.

Trial error messages

The trial licenses will occasionally display the following message on your webform:

Telerik RadWindow 1.9 trial version. Copyright Telerik © 2002-2008. To remove this message, please, purchase a developer version .

See Also

License Agreement

© 2002-2008 Telerik. All Rights Reserved.


Files and folders needed by Telerik RadControls for ASP.NET

Telerik RadWindow v1.9 Send comments on this topic.
Files and folders needed by Telerik RadControls for ASP.NET
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > Files and folders needed by Telerik RadControls for ASP.NET

Glossary Item Box

Please, review the following KB article on the topic:

Which files and folders are mandatory to be on the server for Telerik RadControls for ASP.NET to function

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


The 'RadControls' Folder

Telerik RadWindow v1.9 Send comments on this topic.
The 'RadControls' Folder
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > The 'RadControls' Folder

Glossary Item Box

The RadControls folder is an essential part of Telerik RadControls for ASP.NET - it contains all resources needed for the components to function properly (i.e. images, client-side scripts, configuration files, skins, etc.).

You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files. However because of the specific control features, you will always need to copy /RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products.

Each Telerik component seeks its resources in the respective subfolder of RadControls: for example, /RadControls/Window is the folder where the resources for Telerik RadWindow reside.

Copying the RadControls folder to your web application

To work with Telerik RadControls for ASP.NET, you need to copy the RadControls folder to your web application. The folder must contain all the subfolders of the controls you are going to use. Do not copy the subfolders of controls you are not planning to use as this may cause a number of compilation errors: Visual Studio 2005 compiles all files in the web project; errors occur when missing assemblies are not found.

Do not include the RadControls folder in your VS.NET solution! Hide Why?

When the RadControls folder is included in a VB.NET project, VS.NET tends to change some files within the RadControls folder automatically. The extent of these changes depends on the IDE settings; notably, the following controls are affected:
  • Telerik RadEditor
  • Telerik RadSpell
  • Telerik RadChart
Telerik controls are written in C# - hence the several *.CS codebehind files within the RadControls/[control] folder. When such .ASCX/ASPX files are included in the project, VS.NET automatically changes the Language attribute of their Page/Control directive from cs to vb and breaks the control.

To avoid the problem:
  1. In Windows Explorer, do a filtered search to locate all ASPX and ASCX files within the RadControls folder.
  2. Once the search is over, select all files and right-click to get their properties.
  3. Select the Hidden check box and click OK.
Now Visual Studio will not see the files, so errors will not be thrown. At the same time IIS will see the files and will display them fine.

If you have already included the RadControls folder in your VS2005 project:
  1. Open your Visual Studio 2005 project.
  2. In the Solution Explorer locate the RadControls folder and expand it.
  3. Locate the problematic ascx files, right-click them and select "Exclude from project". Unfortunately, this can be done for files only (unlike VS2003), so the process should be repeated for all ascx files.
  4. Open Windows Explorer, navigate to your project's folder.
  5. Back up the RadControls folder from your project, especially any customized files you may have (ConfigFile.xml, ToolsFile.xml, any css files, images. etc).
  6. Delete the damaged RadControls folder.
  7. Navigate to the installation folder of Telerik RadWindow (for example).
  8. Copy the RadControls folder from the installation folder to the root of your web application.
  9. Rebuild and run your project.

Moving the RadControls folder within your web-application

  1. Manually copy the RadControls folder to the new location within your web application (for example, ~/Resources/).
    Do not use the VS.NET IDE to copy/move the RadControls folder to another location as it changes the namespaces of the files and changes the project language from C# to VB which in turn breaks the application! Use Windows Explorer instead.
  2. Either:
    • Specify its position in the RadControlsDir property in the control's declaration in your ASCX/ASPX file, e.g.
      Copy Code
      <radW:RadWindow
      RadControlsDir="~/Resources/RadControls/" ...>
      </      radW:RadWindow>
    • Or set the property globally from the Web.config file of the application:
      Copy Code
      <configuration>
      <appSettings>
      <add key="Telerik.WebControls.RadControlsDir" value="~/Resources/RadControls/"/>
      </appSettings>
      </      configuration>
      Notes.
      • In the above examples, the tilde "~" represents the root of your web application.
      • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.

Moving the RadControls folder outside your web-application

This is the best scenario if you want to have a single RadControls folder for several applications. This mechanism also enables different versions of Telerik products to reside in different web applications:

  1. Manually copy the RadControls to the new location.
    Do not use the VS.NET IDE to copy/move the RadControls folder to another location as it changes the namespaces of the files and changes the project language from C# to VB, which in turn breaks the application! Use Windows Explorer instead.
  2. Create a virtual directory with name RadControls under each application's root which points physically to the same physical RadControls folder. That physical folder should include all the scripts and other required settings of the controls.
    The respective RadControls virtual directory should NOT be a web application but virtual directory only! You can find more information on the topic in the following KB article: (ID#728) Error Message: Could not load type 'Telerik.WebControls.Dialogs.Dialog'.
  3. Either:
    • Specify its position in the RadControlsDir property in the control's declaration in your ASCX/ASPX file, e.g.

    • Or set the property globally from the Web.config file of the application:
      Copy Code
      <configuration>
      <appSettings>
      <add key="Telerik.WebControls.RadControlsDir" value="~/RadControls/"/>
      </appSettings>
      </      configuration>
      Notes.
      • In the above examples, the tilde "~" represents the root of your web application.
      • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.
      • Make sure you set the RadControlsDir property to "~/RadControls/" (with a slash following the folder name).

"You have not copied the RadControls folder to the root folder of your web-application" error message

When opening a page which contains Telerik RadWindow, the following error message appears:
“Telerik RadWindow v1.9: You have not copied the RadControls folder to the root folder of your web-application or you have applied an update incorrectly."

This message shows that the control is not able to locate its RadControls/window folder. It usually appears after updating the control to a newer version. The causes for the message to appear are:

  • The assembly version and the RadControls/window folder version are from different installation downloads, i.e. from different Telerik RadWindow versions.
    Example: RadWindow.NET2.DLL is version 1.9.2, whereas the Telerik RadWindow's RadControls/Window folder is from version 1.9.1 or other.
  • The proper assembly is in the bin folder of the application, but the RadControls/window folder is missing or misplaced.

To solve the problem:

  1. Check whether the RadControls folder is placed in the root of your web application and that you have NOT set the RadControlsDir property to point to another location.
  2. Check whether the RadControls/window folder contains a subfolder, named Scripts, and a subfolder which carries the version of the control as its name.
    For example, if you use Telerik RadWindow v1.9.2 - the folder should be \RadControls\Window\Scripts\1_9_2 and this version number should match the RadWindow.NET2.dll version placed in the /bin folder.
    If such discrepancy exists between the control's assembly and the RadControls folder, use a DLL and RadControls folder from a working application or download the ZIP file from your Client.net account and use the files from there.
  3. Another reason could be that some files from the RadControls/window folder are missing or damaged. Please delete the current RadControls folder and paste the original one from the same download that you have the assembly from.
  4. For some reason your project may still reference the previous version of control's DLL, and not the latest. In this case we suggest removing the old assembly reference from your VS.NET project and adding a new reference to to the new assembly.
  5. If you have added the control in the GAC (Global assembly cache), remove it by running gacUtil and then add the new version.
  6. If you are trying to move the RadControls folder through the RadControlsDir property, please review the following section for resolution:

  7. [not related to Telerik controls] Delete .NET, VS and browser caches because they can cause a problem too:

    1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
    2. Open a Windows Explorer and navigate to
      C:\Windows(WINNT)\Microsoft.NET\Framework\vYOUR_VERSION\Temporary ASP.NET Files
    3. Delete all the folders with names, corresponding to your Telerik projects.
    4. Delete your Visual Studio web project caches as well - they should be located at C:\Documents and Settings\VSWebCache.
    5. Delete your browser cache: Tools -> Internet Options -> Delete Files....

See Also

Setting the RadControlsDir property

© 2002-2008 Telerik. All Rights Reserved.


Setting the RadControlsDir property

Telerik RadWindow v1.9 Send comments on this topic.
Setting the RadControlsDir property
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > Setting the RadControlsDir property

Glossary Item Box

The RadControlsDir property can be set:

  • either from the ASPX/ASCX page where Telerik RadWindow resides (or programmatically, from the code behind),
  • or globally, for all controls in the web application, from the Web.config file.

To set RadControlsDir from the Web.config, add the following line inside the appSettings tag:

Notes.
  • In the above example, the tilde "~" represents the root of your web application.
  • You can change the location of the RadControls folder. The path given here is to serve only as an illustration.
  • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.
  • When you set the RadControlsDir property, its value does not automatically update other properties that contain URL strings. You need to update these properties manually.

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


Adding Telerik RadWindow to the Visual Studio 2005 Toolbox

Telerik RadWindow v1.9 Send comments on this topic.
Adding Telerik RadWindow to the Visual Studio 2005 Toolbox
Installation and deployment > Installation > Adding Telerik RadWindow to the Visual Studio 2005 Toolbox

Glossary Item Box

Telerik RadControls for ASP.NET are added automatically to the Visual Studio .NET 2005 Toolbox during installation. However if you are using the ZIP distribution, you can do this manually as described below.

To add Telerik RadWindow to the Toolbox manually and to be able to easily deploy the component in your WebForms in Design mode, follow the steps below:

  1. Open your application in Visual Studio 2005.
  2. Expand the Toolbox.

  3. Expand the General Section.

  4. Right-click in the General section and open Choose Items.

  5. On the .NET Framework Components tab, click Browse.

  6. Browse to the Telerik RadWindow installation folder, open the NET2 folder and from the bin subfolder, select the RadWindow.Net2.dll.

    • If the EXE was used to install Telerik RadControls for ASP.NET, the bin folder is located in
      C:\Program Files\Telerik\Telerik RadControls for ASP.NETQ1 2007\NET2\bin

    • If the ZIP was used to install Telerik RadWindow, the bin folder is located in the folder where the installation files have been unzipped (usually "\Inetpub\wwwroot\RadWindow_1_9\NET2"

  7. Click Open to confirm. The Telerik RadWindow icon should appear in the Toolbox.

  8. If you intend to use skins different from the default or if you plan to modify the JavaScript files, do not forget to copy the respective RadControls folder to the root of your application. For more information, see The 'RadControls' Folder.

© 2002-2008 Telerik. All Rights Reserved.


Adding RadControls to the Visual Studio 2008 Toolbox

Telerik RadWindow v1.9 Send comments on this topic.
Adding RadControls to the Visual Studio 2008 Toolbox
Installation and deployment > Installation > Adding RadControls to the Visual Studio 2008 Toolbox

Glossary Item Box

Telerik RadControls for ASP.NET are added automatically to the Visual Studio .NET 2008 Toolbox during installation. However if you are using the ZIP distribution, you can do this manually as described below.

To add Telerik RadControls "Prometheus" for ASP.NET to the Toolbox manually and to be able to easily deploy the component in your WebForms in Design mode, follow the steps below:

  1. Open your application in Visual Studio 2008.
  2. Expand the Toolbox.

  3. Expand the General Section.

  4. Right-click in the General section and open Choose Items.

  5. On the .NET Framework Components tab, click Browse.

  6. Browse to the Telerik RadControls for ASP.NET installation folder, open the bin35 folder and select the Telerik.Web.UI.dll.

    • If the EXE was used to install Telerik RadControls for ASP.NET, the bin35 folder is located in
      C:\Program Files\Telerik\RadControls for ASPNET\bin35

    • If the ZIP was used to install Telerik RadControls, the bin35 folder is located in the folder where the installation files have been unzipped

  7. Click Open to confirm. The icons for all controls in the suite will appear in the Toolbox. Visual Studio 2008 toolbox

© 2002-2008 Telerik. All Rights Reserved.


Using IntelliSense in Visual Studio 2005

Telerik RadWindow v1.9 Send comments on this topic.
Using IntelliSense in Visual Studio 2005
Installation and deployment > Installation > Using IntelliSense in Visual Studio 2005

Glossary Item Box

Visual Studio 2005 automatically enables IntelliSense - through reflection it detects all classes, properties and methods in the dll file(s).

For additional convenience each Telerik control is provided an XML file which contains the comments for its classes, properties and methods.

For example, when Telerik RadWindow is dragged to the webform the RadWindow.Net2.xml file is automatically added in the bin directory of the project.

In ASPX, when you start typing or when you insert a space, VisualStudio will show a dropdown with suggestions for autocomplete.

In code-behind, each time a particular class/property/method is being selected from the dropdown of the autocomplete functionality, a tooltip with the comment for this class/property/method is displayed:

Intellisense in VS2005

© 2002-2008 Telerik. All Rights Reserved.


Using IntelliSense in Visual Studio 2008

Telerik RadWindow v1.9 Send comments on this topic.
Using IntelliSense in Visual Studio 2008
Installation and deployment > Installation > Using IntelliSense in Visual Studio 2008

Glossary Item Box

Visual Studio 2008 automatically enables IntelliSense - it detects all classes, properties and methods in the DLL file and the JavaScript code.

For additional convenience each Telerik control comes with an XML file which contains the comments for its classes, properties and methods.
When the Telerik control is dragged to the webform the XML file is automatically added in the bin directory of the project.
In ASPX, when you start typing or when you insert a space, Visual Studio will show a dropdown with suggestions for autocomplete:

ASPX AutoComplete

Visual Studio 2008 provides full Javascript Intellisense completion in ASPX files, HTM files, as well as in external JS files. It provides rich support for the ASP.NET AJAX client JavaScript framework and JavaScript code built with it:

In code-behind, each time a particular class/property/method is being selected from the dropdown of the autocomplete functionality, a tooltip with the comment for this class/property/method is displayed.

© 2002-2008 Telerik. All Rights Reserved.


Upgrading Telerik RadWindow v1.x Trial to Telerik RadWindow v1.x Developer license

Telerik RadWindow v1.9 Send comments on this topic.
Upgrading Telerik RadWindow v1.x Trial to Telerik RadWindow v1.x Developer license
Installation and deployment > Installation > Upgrading Instructions > Upgrading Telerik RadWindow v1.x Trial to Telerik RadWindow v1.x Developer license

Glossary Item Box

Follow the steps below to upgrade your Telerik RadWindow v1.9 Trial license to a Developer (production) license.

THE PROCEDURE DESCRIBED IN THIS MANUAL IS IRREVERSIBLE AND YOU MAY LOSE YOUR DATA IF THE INSTALLATION IS NOT CARRIED OUT CORRECTLY!

1. Back up Your Old Files

We strongly suggest that you back-up your old Telerik RadWindow files and folders, especially if you would like to use your old settings.

2. Obtain the Necessary File

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases".
  3. Locate the control that you need to install, i.e. Telerik RadWindow, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. Since you have purchased the control, make sure you are downloading the proper file - the Developer version has the Dev abbreviation in it.

3. Install and Copy the New Files

  1. Unzip the files at a convenient location.
  2. Check the Changes and Backward Compatibility section for introduced changes. If there are such, they should be applied a little later in the upgrade process.
  3. Back up your application if you haven't done so already.
  4. Close Visual Studio or any ither IDE which may lock the old assembly.
  5. From the newly downloaded and unzipped files, copy the new DLL (RadWindow.NET2.dll located in the bin folder) to your web-application's bin folder. Replace the old dll.
  6. Locate the old RadControls/Window folder and delete it manually, i.e. using Windows Explorer. By default, the RadControls/Window folder should be in the root of your application. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate it and delete it using Windows Explorer.
    DO NOT use Visual Studio to move, copy or delete the RadControls folder as this will break the Telerik control(s).
  7. If you intend to use skins different from the default or if you plan to modify the JavaScript files, copy the new RadControls/Window folder to the same location as above.
  8. If using VS.NET, update the control's reference in your project to point to the new DLL.
  9. Follow the steps in the Changes and Backward Compatibility section in case there are some changes between the versions.
  10. Recompile your project.
  11. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadWindow to the Global Assembly Cache
  12. Run the project.
  13. If you still get the older version of Telerik RadWindow Hide click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadWindow's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadWindow, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....

  14. If you get a copyright message Hide click here

    The copyright message appears only when using the trial version of Telerik RadWindow (the Developer versions of Telerik's controls do not throw copyright messages). Make sure you have downloaded the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

5. Using the old ToolsFile.xml File and ConfigFile.xml file [valid for Telerik RadEditor and Telerik RadSpell only]

If you would like to use your old ToolsFile.xml and ConfigFile.xml files (which you backed up in #1 above), you can do so by copying them from the back-up to the RadControls\Editor folder (or RadControls\Spell respectively) of your web-application. When prompted to overwrite the other file, click "YES".

© 2002-2008 Telerik. All Rights Reserved.


Add/Remove Telerik RadWindow to the Global Assembly Cache

Telerik RadWindow v1.9 Send comments on this topic.
Add/Remove Telerik RadWindow to the Global Assembly Cache
See Also
Installation and deployment > Deploying Telerik RadWindow into ASP.NET Applications > Add/Remove Telerik RadWindow to the Global Assembly Cache

Glossary Item Box

Add to Global Assembly Cache

There are two ways to add a control to the Global Assembly Cache (GAC):

Automatic

  1. Go to Start -> Settings -> Control Panel -> Administrative Tools -> Microsoft .NET Framework 2.0 Configuration
  2. Expand the nodes and locate Assembly cache
  3. Right-click on it and select Add:

    Microsoft .NET 2.0 Configuration panel
  4. Browse to the Telerik bin directory and ctrl-highlight the needed DLL's (the demo and DictionaryConfiguration DLLs are not needed).
  5. Click Open.

Manual

  1. Run the .NET command prompt (Start -> Programs -> Microsoft VS.NET -> VS.NET Tools -> VS.NET prompt) and start the gacutil.exe tool with -i parameter (install) and the name of the control, e.g.

    Copy Code
    gacutil.exe -i "C:\Program Files\Telerik\Telerik RadWindow1.9\NET1NET2\bin\RadWindow.Net2.dll"

    You may also directly copy the dll files to the "\WINDOWS\assembly" (or "\WINNT\assembly") folder of your server - this is equivalent to the effect of the gacutil.exe utility.

  2. Change the machine.config file of the server and add a reference to the assembly in the GAC. The machine.config file is the configuration file for all web applications on the server. It is located at: "\WINDOWS\Microsoft.NET\Framework\[Framework Version]\CONFIG". It is similar in to the web.config file, but the web.config only works for the web application, in which it resides.

    Locate the <assemblies> tag (which should be under <configuration><system.web> <compilation>/<compilers>/<assemblies> ) Between the <assemblies> tag, you should enter something similar to:

    Copy Code
    <add assembly="AssemblyFileName, Version=0.0.0.0, Culture=neutral, PublicKeyToken=5edf592a9c40680c" />

    To get the information that goes into the assembly attribute (version, culture, PublicKeyToken), you can run the gacutil /l command, which will return a list of all the assemblies in the GAC. You will have to look for the one you just added and copy the entire line (minus the Custom=null part at the end).
    For example the following command:

    Copy Code
    gacutil -l RadWindow.Net2

    will return:

    Copy Code
    RadWindow, Version=1.9.0.0, Culture=neutral, PublicKeyToken=e8ab424810b6b9b5 Custom=null

    so the correct entry in the machine.config should be:

    Copy Code
    <add assembly="RadWindow.Net2, Version=1.9.0.0, Culture=neutral, PublicKeyToken=e8ab424810b6b9b5" />

After that you should be able to use the control in all the application on the server without having to copy it to the "bin" folder of each web-application.

Remove from Global Assembly Cache

In order to remove Telerik RadWindow from GAC, please use the following command:

Copy Code
gacutil.exe -u radwindow

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


Multi Targeting in Visual Studio 2008

Telerik RadWindow v1.9 Send comments on this topic.
Multi Targeting in Visual Studio 2008
See Also
Installation and deployment > Deploying Telerik RadWindow into ASP.NET Applications > Multi Targeting in Visual Studio 2008

Glossary Item Box

In Visual Studio 2008 you are able to build applications targeting multiple versions of the .NET Framework. Apart from ASP.NET 3.5, VS 2008 can open, edit and build ASP.NET 2.0 applications (applications with ASP.NET AJAX 1.0 as well). Visual Studio 2008 can also deploy these application on .NET 2.0 machines. You are able to easily build applications with RadControls targeting both ASP.NET 2.0 and ASP.NET 3.5.

See Also

External Link
See more information on how to use Multi Targeting in VS 2008

© 2002-2008 Telerik. All Rights Reserved.


Deploying Telerik RadWindow on Shared Hosting

Telerik RadWindow v1.9 Send comments on this topic.
Deploying Telerik RadWindow on Shared Hosting
Installation and deployment > Deploying Telerik RadWindow into ASP.NET Applications > Deploying Telerik RadWindow on Shared Hosting

Glossary Item Box

All Telerik controls are server controls and have to be installed on the web server in order to function properly. This also means that you will need to create the respective virtual directories and give the proper permissions (ASPNET [IIS5], NEtwork Service [IIS6]) in order to use them on the shared hosting.

If you have already created the application on your development machine

1. Copy/upload the compiled application via FTP to the production server, i.e. on the shared hosting. The application should reside in the inetpub/wwwroot folder.

2. Create a virtual directory for the application folder. Before you do this step, consult with your hosting provider on how this is to be accomplished. If the provider offers thorough instructions, use them instead of the ones below. If you do not have access to the Information Services console, ask your provider to set the application for you. If the provider does not offer instructions, then:

1. Locate the Internet Information Services console;

2. Navigate to the application folder;

3. Find the folder's Properties;

4. Create a virtual directory;

5. Remember the application name and click OK.

3. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (using IIS6 or IIS7, Windows Server 2003, Windows Vista/Longhorn) on the application folder. Again, before doing this step, consult with your hosting provider on how this is to be accomplished. If the provider offers thorough instructions, use them instead of the ones below. Otherwise, contact your provider to set the permissions for you.

4. Run the project.

Notes.

As the proper operation of some Telerik RadEditor elements need some external files to be loaded, a RadControls folder instance is needed for the control to run.

There are two possible RadControls folder usages:

  • Copy the RadControls folder within your web-application:

    Manually copy the RadControls folder to the new location within your web application (for example, ~/Resources/). Specify its position via the RadControlsDir property of the control's declaration: <radE:RadEditor RadControlsDir="~/Resources/RadControls/" ...></radE:RadEditor>, where the "~" (tilde) symbol in the path represents your web-application root directory.
  • Copy the RadControls folder outside your web-application (this is the best scenario if you would like to share the RadControls folder across multiple web applications): Manually copy the RadControls to the new location using Windows Explorer. Create a virtual directory with a preferred name (e.g. RadControls) under each application's root which points physically to the same physical RadControls folder.

    The respective RadControls virtual directory should NOT be a web application but virtual directory only! You can find more information on the topic in the following KB article: (ID#728) Error Message: Could not load type 'Telerik.WebControls.Dialogs.Dialog'.

    If the Virtual subfolder alias is different than RadControls, specify the virtual folder position via the RadControlsDir property in the editor's declaration in your ASCX/ASPX file
    <radE:RadEditor RadControlsDir="~/MyRadControls/" ...></radE:RadEditor>

    More information on the topic is available in the following help article: The 'RadControls' folder.

If you plan to deploy the controls directly on the shared hosting

1. Log in your Client.NET account.

2. Go to "My licenses" and click on "My Purchases" (or "My Free Trials" if you are a trial user).

3. Locate the needed control, and click on it.

4. Click on the "Download" tab to download the Manual installation (ZIP) file.

5. On the server, create a "Telerik" folder in your "inetpub/wwwroot" folder on the server.

6. If you intend to use skins different from the default or if you plan to modify the JavaScript files, create a new folder named RadControls in the inetpub/wwwroot/Telerik folder.

7. Follow the instructions from the first case above.

© 2002-2008 Telerik. All Rights Reserved.


Embedded Resources

Telerik RadWindow v1.9 Send comments on this topic.
Embedded Resources
Installation and deployment > Deploying Telerik RadWindow into ASP.NET Applications > Embedded Resources

Glossary Item Box

All Telerik RadControls for ASP.NET have their web resources embedded in the control assembly. Each control automatically fetches the required resources from the web. Embedded Resources are easier to manage because they require that you only maintain a single DLL for each RadControl when you upgrade versions/deploy applications. You no longer need to include the JavaScripts and the other related files with the RadControls folder in the root of your application. If you use external resources, you'll simply need to make sure you keep your DLLs and RadControls folders in sync when you upgrade and deploy.

Note that you still need the RadControls folder if you want to use a skin other than the Default.

You can control this functionality by setting the boolean property UseEmbeddedScripts.

When UseEmbeddedScripts is set to true (by default) web resources are streamed by the built-in web resource handler using a query string (like WebResource.axd?d=HTLSHE...). This scenario is suitable for easier deployment (no RadControls required).
The backside of using the embedded resources is that sometimes web resources are not cached (e.g. when your site is in debug mode <compilation debug="true" />). In addition the long query strings are adding bulk to the HTML you are sending to the client. Using external resources, i.e. the RadControls folder may nearly halve the page size due to the shorter resource paths. Your mileage may vary depending on the RadControls you are using.

If you set UseEmbeddedScripts to false, the control will use the necessary resources (files) from the RadControls folder. This is appropriate for example for cases when the web resource handler is disabled or when you have applied some modifications to the JavaScript or CSS files used by the control.

None of the functionality of the controls will change. Switching this property would only mean that you have to keep a local copy of the RadControls folder with the JS files in your application, since you are not going to use the embedded ones.
You cannot combine both methods for getting web resources, i.e. you cannot make the control take its scripts as embedded resources and skin file from RadControls.

© 2002-2008 Telerik. All Rights Reserved.


Trust level

Telerik RadWindow v1.9 Send comments on this topic.
Trust level
Installation and deployment > Deploying Telerik RadWindow into ASP.NET Applications > Trust level

Glossary Item Box

This topic refers the case you are trying to publish a site to a shared environment. The site is using the <RadControlName> component, where only the <RadControlName>.dll file exists in the /bin directory of the application along with the scripts directory (/RadControls/<ControlName>/Scripts) on the root.

All RadControls supports Medium trust level under shared hosting environment.

Note that a requirement for the RadControl is to have the trust level set to Medium at minimum - otherwise you may receive server error like the following:

Could not load type Telerik.RadWindowDesign.WindowComponentEditor from assembly mscorlib, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

To modify the trust level setting please follow the instructions below:

Locate the machine.config file placed in the \Microsoft.NET\Framework\v2.0.50727\CONFIG folder on your production server. Open it for editing and change the following line:

machine.config Copy Code
<trust level="Medium" originUrl=""/>

Further information about the different trust level options and their policies you can find in the MSDN:

http://msdn2.microsoft.com/en-us/library/tkscy493.aspx

http://msdn2.microsoft.com/en-us/library/wyts434y.aspx

© 2002-2008 Telerik. All Rights Reserved.


Troubleshooting deployment on the production server

Telerik RadWindow v1.9 Send comments on this topic.
Troubleshooting deployment on the production server
Installation and deployment > Deploying Telerik RadWindow into ASP.NET Applications > Troubleshooting deployment on the production server

Glossary Item Box

Since the Q2 2006 release our controls utilize webresources which is a new feature of ASP.NET 2.0. There are cases in which this may cause problems. For some reason requesting the webresource handler (webresource.axd) returns error number 404. This javascript files used by the control should be streamed by the web resource handler. As a result of the aforementioned error this does not happen and you may experience JavaScript errors on the client.

Here some tips how the problem can be solved:

First approach

  1. Open IIS management snap-in ( e.g. run inetmgr.exe)
  2. Right click your website and choose properties
  3. Go to the "Home Directory" tab and click the "Configuration" button
  4. A dialog should pop out and you would see the mappings listbox
  5. Find the entry for the ".axd" extension and edit it by clicking the "Edit" button
  6. In the new dialog uncheck the "Verify if file exist" checkbox - which I suspect is causing the problem.

Second approach

Alternatively, if the steps above don't solve the issue, you can try creating an empty WebResource.axd file in the site root folder.

Third approach

You can try setting UseEmbeddedScripts property to false. Thus the control will use the scripts from RadControls/Window/Scripts folder instead the embedded resource.

© 2002-2008 Telerik. All Rights Reserved.


Changes and backward compatibility

Telerik RadWindow v1.9 Send comments on this topic.
Changes and backward compatibility
Changes and Backward Compatibility > Changes and backward compatibility

Glossary Item Box

New major version of RadWindow is now available as a part of RadControls “Prometheus” for ASP.NET. Its new architecture is based on top the ASP.NET AJAX framework in order to directly benefit from client-side behaviors and capabilities. We strongly recommend using the new version for all new development.

Telerik RadWindow v1.8

There are no major changes and the product is fully backwards compatible.

© 2002-2008 Telerik. All Rights Reserved.


ASP.NET AJAX Framework

Telerik RadWindow v1.9 Send comments on this topic.
ASP.NET AJAX Framework
Changes and Backward Compatibility > ASP.NET AJAX Framework

Glossary Item Box

Show All Show All
Hide All Hide All

All Telerik controls now provide full support for the new ASP.NET AJAX framework.
Telerik's own patent-pending AJAX mechanism does not interfere in any way with the ASP.NET AJAX framework. Telerik RadAjax, as well as all built-in AJAX features of Telerik RadControls for ASP.NET work with ASP.NET AJAX without any conflict.

To enable ASP.NET AJAX with Telerik RadWindow:

  1. Make sure you have the ASP.NET AJAX framework installed.
  2. If the control is initially invisible and is shown after an ASP.NET AJAX update, you should manually register all the required CSS files in the head tag of your page. Otherwise the control will not be displayed correctly. The easiest way to do this is through a LINK element:
    Copy Code
    <link href="~/RadControls/Window/Skins/[SkinName]/styles.css" rel="stylesheet" runat="server" >
  3. Place the instance of Telerik RadWindow in an ASP.NET AJAX UpdatePanel.

To enable or disable the ASP.NET AJAX UpdatePanel, set the EnablePartialRendering property of the ScriptManager class to True or False accordingly.

Grid built-in AJAX has higher priority than external AJAX frameworks - ASP.NET AJAX and RadAjax. In case one need the Grid to be updated from an ASP:UpdatePanel, Grid's EnableAJAX should be turned off.

ASP.NET AJAX is not a Telerik product.
For further information about ASP.NET AJAX, refer to ASP.NET AJAX documentation .

Known problems related to ASP.NET AJAX interoperability

Exceptions

If you receive exceptions such as:

System.Web.HttpException: The Controls collection cannot be modified because the control contains code blocks (i.e. <% ... %>)

you need to move the code block outside of the head tag. For example:

Before: Copy Code
<head runat="server">
<script>
var controlClientObject = <%= RadControl1.ClientID %>
...
</script>
</head>

<body>
...
</body>
After: Copy Code
<head runat="server">
</head>
<body>
<script>
var controlClientObject = <%= RadControl1.ClientID %>
...
</script>
...
</body>

© 2002-2008 Telerik. All Rights Reserved.


Accessibility Compliance

Telerik RadWindow v1.9 Send comments on this topic.
Accessibility Compliance
See Also
Standards Compliance > Accessibility Compliance

Glossary Item Box

Telerik RadWindow Accessibility Compliance Level W3C Level A Accessibility Compliant

  1. Telerik RadWindow is "Level A" content compliant (in accordance with the W3C Web Accessibility Guidelines 1.0).
  2. Telerik RadWindow satisfies the requirements of "Section 508" for software accessibility. As a result, the component can be used in US Federal Institutions and other organizations that require software to be accessible to people with disabilities. Read Keyboard Support for details.
    Telerik RadWindow does not render any tables (<table> HTML tags) thus there's no need for extra headings / caption / summary attributes that are typically needed to make HTML tables accessible.

Section 508

The USA federal mandate requiring that information technology be made accessible to people with disabilities. Much of Section 508 compliance concerns making Web sites, intranets, and web-enabled applications accessible. Section 508 compliance has since become a major prerequisite not only in government related software, but also in most enterprise and corporate software solutions.

W3C Web Content Accessibility Guidelines 1.0

The main goal of these guidelines is to encourage developers in creating applications providing accessible contents. However, adhering to these guidelines will also make Web content more available to all kind of users, using different devices and interfaces: desktop browser, voice browser, mobile phone, automobile-based personal computer, etc.

In accordance with these guidelines W3C defines three levels of conformance developers may implement in order to provide some level of content compliance to their products:

a? Compliance Level "A"
a? Compliance Level "AA"
a? Compliance Level "AAA"

For more details on W3C "Web Content Accessibility Guidelines 1.0" see http://www.w3.org/TR/WAI-WEBCONTENT/

In our attempt to make our products content compliant, each web-control we develop and its QSF should strive to obtain at least one of conformance levels listed above.

See Also

Keyboard Support
XHTML Compliance

© 2002-2008 Telerik. All Rights Reserved.


XHTML Compliance

Telerik RadWindow v1.9 Send comments on this topic.
XHTML Compliance
See Also
Standards Compliance > XHTML Compliance

Glossary Item Box

Compliance Level W3C XHTML 1.1 Compliant

Telerik RadWindow provides complete XHTML compliance. The HTML markup of the component is fully XHTML 1.1 compliant.

What is XHTML

XHTML stands for EXtensible HyperText Markup Language and it is a stricter and cleaner version of HTML recommended by W3C (World Wide Web Consortium). XHTML is the effective inheritor of HTML 4.01 and although it is almost identical to its predecessor it is aimed to replace it.

See Also

Accessibility Compliance

© 2002-2008 Telerik. All Rights Reserved.


Interoperability of Telerik RadWindow with RadAjax

Telerik RadWindow v1.9 Send comments on this topic.
Interoperability of Telerik RadWindow with RadAjax
AJAX Support > Interoperability of Telerik RadWindow with RadAjax

Glossary Item Box

Remark: The built-in AJAX functionality in telerik RadGrid, RadCombobox, RadTeeview has a higher priority than telerik RadAjax. You should turn it off in order to update outside controls and use AJAX Panel or AJAX Manager.
Important note: telerik RadUpload is unable to upload files with an Ajax call. This is related to the inability of the XmlHttpRequest component to upload files. This component is the core of any Ajax framework, such as telerik RadAjax or Atlas (AJAX extensions for ASP.NET).

Telerik RadWindow is designed for seamless interoperability with the Telerik AJAX framework, the RadAjax suite enabling developers to implement the following functionality:

  • AJAXify (AJAX-enable) telerik RadWindow to work with AJAX instead of regular postbacks;
  • Update the telerik RadWindow control upon an AJAX request made by a control on the page via telerik RadAjax;
  • Make telerik RadWindow initiate an AJAX request in order to update other controls on the page.

Make telerik RadWindow work with AJAX requests (Ajax-enable Telerik RadWindow)

You can ajaxify any member of the telerik RadControls for ASP.NET suite. The ajax-enabled control will work in AJAX mode and will perform callback requests instead of regular postbacks.

To do so, you have two possible options:

  • place the instance of RadWindow into an AjaxPanel - in this case, the control will update itself and all other controls in the panel via AJAX request
  • place one AJAX Manager on the page and in its property builder set the AJAX pair, i.e. AJAX initiator and the updated control. In this case, as we want Telerik RadWindow to update itself with AJAX, it should be set as initiator and updated control.

Update telerik RadWindow upon AJAX request

Telerik RadWindow is fully compatible with the telerik RadAjax suite and can be updated via callbacks from any other control on the page without any additional coding. You have two possible options:

  • You need to have the AJAX Manager on the page and set the AJAX pair - AJAX initiator and the updated control (telerik RadWindow in this case). We recommend you do this using the visual editor in VS.NET.
  • Alternatively you can place telerik RadWindow in AJAX Panel together with the control that should update it.

Initiate an AJAX request and update other controls with Telerik RadWindow

You may want to initiate a callback request by telerik RadWindow and update other controls on the page.

To implement this functionality, you need to do the following:

  • Place AJAX Manager on the page. Open its property builder and set the AJAX pair. In this case Telerik RadWindow will be the AJAX initiator. You can set as many controls as you wish to be updated by a single request.

OR

  • Place both controls (telerik RadWindow and the control that should be updated) in AJAX Panel. telerik RadWindow will automatically start updating all controls in the panel (including itself) with AJAX requests.

More integration examples of telerik RadAjax with the other controls from the telerik RadControls for ASP.NET suite can be seen here.

© 2002-2008 Telerik. All Rights Reserved.


Overview

Telerik RadWindow v1.9 Send comments on this topic.
Overview
See Also
ASP.NET 2.0 Features > Overview

Glossary Item Box

This version of Telerik RadWindow is complied against the .NET 2.0 framework and offers new specific features for Microsoft's next-generation IDE - Visual Studio .NET 2005. The new release will enable developers to enjoy significant productivity gains, while delivering feature-rich, standards-compliant, AJAX-enabled, and cross-browser compatible web applications.

Feature Highlights

  • Support for .NET 2.0 Themes - the themes and skins features in ASP.NET 2.0 allow for easy customization of controls appearance. You can define style information in a common location called "Theme", and apply that style information globally to pages or controls in your site. Just like Master Pages, Themes improve the maintainability of your applications and eliminate the unnecessary duplication of code for shared styles.

Product Versions

With the release of Telerik RadControls for ASP.NET for .NET 2.0, Telerik will be maintaining two separate versions - one for .NET 1.x and one for .NET 2.0. The two versions will be identical in terms of features except where mandated by the platform.

See Also

Support for .NET 2.0 Themes

© 2002-2008 Telerik. All Rights Reserved.


Support for .NET 2.0 Themes

Telerik RadWindow v1.9 Send comments on this topic.
Support for .NET 2.0 Themes
See Also
ASP.NET 2.0 Features > Support for .NET 2.0 Themes

Glossary Item Box

Among the numerous innovations of the .NET 2.0 Framework are the so-called Themes. They enable the separation of a control's look from its functionality. As a result, developers will be able to completely change the look of a control in an easy declarative manner. This improves the maintainability of your applications and eliminate the unnecessary duplication of code for shared styles.

Each Theme is a folder with one or more .skin files and any additional resources (such as .CSS files, images, etc). The skin files contain XML tags that are used to configure the controls on the page. Those tags look almost identically to regular ASP.NET tags so you can very conveniently copy paste settings between the Theme and your controls file (ASPX/ASCX).

Using Themes local to the application

Themes can be local for the application (each theme resides in a separate folder under the "app_themes" folder in the root of the web application).

To use Themes you need to copy the "app_themes" directory (if available for the specific component) under the same name to your application's root directory.

The "app_themes" directory is available for copying from your Telerik Rad[Control] directory:
Example: C:\Program Files\Telerik\r.a.d.[control]\app_themes

Using Themes global to the system

Themes are globally accessible from .NET 2.0 applications if they reside in the .NET framework directory, under a special folder called "app_themes". This feature is supported by Telerik controls, however requires special lowered security settings, until standard access mechanisms are provided in .NET Framework final release.

Overriding the default Themes folder

You can change the default location of the "app_themes" folder using the ThemesDir property of Telerik RadWindow. The default value for this property is "~/app_themes/" where "~/" represents your web application root. You can change the value of the property and Telerik Rad[Control] will search its theme in the specified folder. However, since the shipped themes are created to use the app_themes folder, you should change manually the .skin files in order to reflect the change.

For example you might have to change the values of the ImagesBaseDir and CssFile, which by default start with "~/app_themes/".

Design-time support for Themes

In order to apply a Theme to r.a.d.window you could either use the "Apply Theme" dialog (available through component-associated right-click context menu) in Visual Studio .NET design mode or specify the path of Theme property in the Telerik RadWindow control Tag, which is usually found in the XML file of the Page/Control.

See Also

Overview

© 2002-2008 Telerik. All Rights Reserved.


Telerik RadWindow Basics

Telerik RadWindow v1.9 Send comments on this topic.
Telerik RadWindow Basics
See Also
Basic Definition and Structure > Telerik RadWindow Basics

Glossary Item Box

Telerik RadWindow is an unique component that can replace the standard browser dialogs and alert/prompt/confirm boxes. Developers can easily build modal and non-modal dialogs and windows, individually or in groups that mimic the behavior of the Windows taskbar. You can fully configure Telerik RadWindow with just setting its properties. No codebehind is necessary.

All window objects are handled trough a window manager. For easier customization, the common properties that are set in the manager apply to all child windows, and each individual window can override these with a new value.

Example

ASP.NET Copy Code
<rad:RadWindowManager
id="RadWindowManager1"
VisibleOnPageLoad="true"
Skin = "System"
Behavior="close"
runat="server">
<windows>
<rad:RadWindow
OffsetElementId="NavigationDiv"
NavigateUrl="ExampleFiles/denverHouse.html"
Runat="server"
Width="400px"
Height="249px"
Top = "150"
Left="640"
Id="NavigationWindow"></rad:RadWindow>
</windows>
</rad:RadWindowManager>

See Also

RadWindowManager Server-Side Object Model
RadWindow Object Server-Side Object Model

© 2002-2008 Telerik. All Rights Reserved.


Window Structure

Telerik RadWindow v1.9 Send comments on this topic.
Window Structure
Basic Definition and Structure > Window Structure

Glossary Item Box

The diagram below shows the element structure of Telerik RadWindow. The control elements are highlighted and described beneath the diagram.

  • Title Bar - contains the icon, title, and title bar buttons. Its visibility is determined in the VisibleTitleBar property.
  • Icon - the image in the upper left corner of the Telerik RadWindow title bar. It is set in the IconUrl property.
  • Title - initially displays the URL that will originally be loaded in the Telerik RadWindow and can be changed on the client.
  • Title Bar Buttons - the buttons which allow the window to be resized, expanded/collapsed, closed command, etc. Which buttons are visible depends on the specified Behavior.
  • Content Window - displays the content of the page which is set in the NavigateUrl property.
  • Status Bar - this is the area below the Content Window area. It is often used for or displaying additional information. Its visibility is determined in the VisibleStatusBar property.

© 2002-2008 Telerik. All Rights Reserved.


Keyboard Support

Telerik RadWindow v1.9 Send comments on this topic.
Keyboard Support
See Also
Customizing Behavior > Keyboard Support

Glossary Item Box

Telerik RadWindow manager supports keyboard shortcuts to commands. Shortcuts can be used to switch between active windows, to maximize or close the current active window, and other tasks - each public API method of the client RadWindowManager that does not require parameters can be associated with a shortcut.

Shortcuts are specified in the code-behind, using the Shortcuts property (of type collection) of RadWindowManager.

There are three default shortucts that are automatically enabled for RadWindowManager. If you wish to clear those, use the Shortucts.Clear() method. The default shortcuts are:
  "FocusNextWindow" => "CTRL+TAB"
  "MinimizeAll" => "CTRL+F4"
  "EscapeActiveWindow" => "ESC"

Example

C# Copy Code
RadWindowManager1.Shortcuts.Add( new WindowShortcut("MinimizeAll", "ALT+F2"));
RadWindowManager1.Shortcuts.Add( new WindowShortcut("RestoreAll", "ALT+F3"));
RadWindowManager1.Shortcuts.Add( new WindowShortcut("CloseActiveWindow", "CTRL+F4"));
RadWindowManager1.Shortcuts.Add( new WindowShortcut("MinimizeActiveWindow", "CTRL+F9"));
RadWindowManager1.Shortcuts.Add( new WindowShortcut("ToggleMaximizeActiveWindow", "CTRL+F10"));

VB.NET Copy Code
RadWindowManager1.Shortcuts.Add(New WindowShortcut("MinimizeAll", "ALT+F2"))
RadWindowManager1.Shortcuts.Add(New WindowShortcut("RestoreAll", "ALT+F3"))
RadWindowManager1.Shortcuts.Add(New WindowShortcut("CloseActiveWindow", "CTRL+F4"))
RadWindowManager1.Shortcuts.Add(New WindowShortcut("MinimizeActiveWindow", "CTRL+F9"))
RadWindowManager1.Shortcuts.Add(New WindowShortcut("ToggleMaximizeActiveWindow", "CTRL+F10"))

See Also

Accessibility Compliance

© 2002-2008 Telerik. All Rights Reserved.


Localization

Telerik RadWindow v1.9 Send comments on this topic.
Localization
See Also
Customizing Behavior > Localization

Glossary Item Box

The elements of Telerik RadWindow such as buttons' captions, buttons' tooltips, window headers, etc., are easily localizable through an XML file, named Main.xml. There are three default localization files - English, German and French, located in the "~/RadControls/Window/Localization" folder. You can modify these files or create your own to enhance the localization capabilities of Telerik RadWindow. The localization is set declaratively in an aspx/ascx file or from the codebehind. In both cases the Language property of RadWindowManager is used.

Example

ASP.NET Copy Code
<rad:radwindowmanager
id="RadWindowManager1"
runat="server"
Language="de-DE">
</rad:radwindowmanager>

VB.NET Copy Code
radWindowManager.Language = "de-DE"

C# Copy Code
radWindowManager.Language = "de-DE";

exemplary Main.xml file:

XML Copy Code
<?xml version="1.0" encoding="utf-8" ?>
- <localization>
<string id="Maximize">Maximize</string>
<string id="Minimize">Minimize</string>
<string id="Close">Close</string>
<string id="Restore">Restore</string>
<string id="PinOff">Pin Off</string>
<string id="PinOn">Pin On</string>
<string id="ConfirmMessage">Are you sure?</string>
<string id="PromptMessage">Enter value:</string>
<string id="Ok">Ok</string>
<string id="Cancel">Cancel</string>
<string id="Yes">Yes</string>
<string id="No">No</string>
<string id="Loading">Loading...</string>
<string id="Reload">Reload</string>
<string id="Alert">Telerik RadWindow alert</string>
<string id="Prompt">Telerik RadWindow prompt</string>
<string id="Confirm">Telerik RadWindow confirm</string>
</localization>

Additional localization files can be found in your Client.net account. They are available in the My Licenses - My Purchases / Individual Controls / Telerik RadWindow / Downloads

See Also

RadWindowManager Server-Side Object Model

© 2002-2008 Telerik. All Rights Reserved.


Predefined Alert, Confirm, Prompt Dialogs

Telerik RadWindow v1.9 Send comments on this topic.
Predefined Alert, Confirm, Prompt Dialogs
Customizing Behavior > Predefined Alert, Confirm, Prompt Dialogs

Glossary Item Box

Telerik RadWindow provides an easy way to replace the standard dialog boxes provided by the browser when calling the window.alert(), window.prompt() and window.confirm() commands. At present the dialog boxes are called with the radalert, radprompt and radconfirm methods, correspondingly. Compared with the standart browser popups Telerik RadWindow popups bring the following advantages:
  • The appearance of Telerik RadWindow popups is fully customizable - allows blending them into the design of the site and thus increasing usability.
  • Completely arrangeable windows - you can change their positioning, as well as the elements (icon, text, buttons) included in the popup, from the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplates.xml file.
  • Control the initial size of the popup by providing width and height as extra parameters.
  • Set HTML as content - as opposed to browser popups that are only able to display text, you are free to pass HTML to be displayed in the Telerik RadWindow popups for a richer user experience and improved usability.

Since the Telerik RadWindow popups are non-blocking, it is necessary to provide a callback function for the prompt and confirm popups in order to receive their result, for example:

<button style="width:150px" onclick = "Confirm('Are you sure?', confirmCallBackFn); return false;">SHOW CONFIRM BOX</button>

A limitation of the radconfirm is that unlike the regular browser confirmation dialog (window.confirm), it cannot block the execution thread on the server. This is so because the execution of the thread cannot be blocked by Javascript. A possible workaround for some cases can be found in the following Code Library article: Block the execution thread with radconfirm.

Please note that the approach described there work only for elements that have a click method

The Telerik RadWindow dialogs are modal, e.g. they block the content underneath and prevent the user from interacting with it, but there are ways to work around this behavior. If it is absolutely necessary that a popup is modal then the default browser popups should be used.

Function | Parameters | Description
radalert (text, oWidth, oHeight, oTitle) | text - the message to be displayed oWidth - width of the dialog oHeight - height of the dialog oTitle - title of the dialog | Displays a message box.
radconfirm (text, callBackFn, oWidth, oHeight, callerObj, oTitle) | text - the message to be displayed callBackFn - javascript function to be called when the user closes the dialog oWidth - width of the dialog oHeight - height of the dialog callerObj - provides ability to "pass" a reference to a HTML object, such as button to the callback function. oTitle - title of the dialog | Displays a box with message and Yes/No buttons.
radprompt (text, callBackFn, oWidth, oHeight, callerObj, oTitle) | text - the message to be displayed callBackFn - javascript function to be called when the user closes the dialog oWidth - width of the dialog oHeight - height of the dialog callerObj - provides ability to "pass" a reference to a HTML object, such as button to the callback function. oTitle - title of the dialog | Displays a box with message and a prompt for user data entry.
radsplash (setVisible) | setVisible - a flag to indicate whether to show or hide the splash. | Shows or hides the "splash" window.

Example

ASP.NET Copy Code
<rad:RadWindowManager id="RadWindowManager1" runat=server skin="Golden"></rad:RadWindowManager>

<table style="width: 100%;">
<tr>
<td>
<script type="text/javascript">
function confirmCallBackFn(arg)
{
alert (arg);
}

function promptCallBackFn(arg)
{
alert (arg);
}
</script>
Skin:
<asp:DropDownList AutoPostBack=true Runat=server ID="SkinDropdown"></asp:DropDownList>
<br /><br />
<button style="width: 150px; margin-bottom: 3px;" onclick = "radalert('Welcome to Telerik RadWindow!', 330, 180); return false;">SHOW ALERT BOX</button><br/>
<button style="width: 150px; margin-bottom: 3px;" onclick = "radconfirm('Are you sure?', confirmCallBackFn, 330, 180); return false;">SHOW CONFIRM BOX</button><br/>
<button style="width: 150px" onclick = "radprompt('Please enter a number here:', promptCallBackFn, 330, 180); return false;">SHOW PROMPT BOX</button>
</td>
<td style="width: 50px;"> </td>
<td style="vertical-align:top;">
<script type="text/javascript">
function TextBoxChanged()
{
var textbox = document.getElementById("TextBox");
if (textbox.value.length < 6)
{
var callBackFn = function(arg)
{
if (arg != true)
{
textbox.value = "";
textbox.focus();
}
};
radconfirm("Are you sure you want to keep the entered text<" + "span style='font-size:20px;color:red'>" + textbox.value.length + "<" + "/span> characters long?", callBackFn);
}
else radalert("<" + "span style='color:blue;font-size:15px;'>" + textbox.value + "<" + "span>");
}

function ButtonClicked(button)
{
var callBackFn = function(arg)
{
button.value = "Current #:" + arg;
}

radprompt("Please, enter numeric value ", callBackFn);
}
</script>
Enter text:<br />
<textarea id="TextBox" rows="3" cols="20" style="border: solid 1px #ccc; vertical-align: middle; height: 60px; width: 146px;float:left;"></textarea>
<input type="button" class="button" onclick="TextBoxChanged(); return false;" value="Show alert"/>
<br/>(If text is under 5 characters long,<br/> a CONFIRM box will appear)
<br/><br/><br/>
<input type="button" style="width:150px;" class="button" onclick="ButtonClicked(this); return false;" value="Click to enter #"/>
</td>
</tr>
</table>

© 2002-2008 Telerik. All Rights Reserved.


Minimize Zones

Telerik RadWindow v1.9 Send comments on this topic.
Minimize Zones
Customizing Behavior > Minimize Zones

Glossary Item Box

When minimized, Telerik RadWindow objects can be "docked" to an HTML element, such as a DIV or a TD. In turn, the HTML element can be styled to resemble an interface element a for example, a taskbar.

The properties most likely to be used for achieving this behavior (in various possible combinations) are:

Property | Description
MinimizeZoneId | The client id of the html element using the MinimizeZoneId property.
MinimizeMode | Minimization mode should be 'dock to minimize zone'.
InitialBehavior | Specifies whether the window will appear initially minimized, "normal", pinned or maximized.
VisibleOnPageLoad | Whether the window object is automatically made visible when the page is loaded.
SingleNonMinimizedWindow | If set to true, only the current active window is with normal size, all other windows are minimized to provide the most screen space.

Example:

ASP.NET Copy Code
<rad:RadWindowManager
VisibleOnPageLoad="true"
MinimizeZoneId="HorizontalMinimize"
MinimizeMode = "MinimizeZone"
InitialBehavior = "Minimize"
SingleNonMinimizedWindow = "True"
OffsetElementId="OffsetElement"
id="RadWindowManager1"
runat=server>
<windows>
<rad:RadWindow
Runat="server"
Top="20"
Left="150"
Width="370"
Height="220"
NavigateUrl="../../TestPage/Default.html"></rad:RadWindow>

<rad:RadWindow
id="Radwindow1"
Runat="server"
Width="370"
Height="220"
Top="40"
Left="170"
NavigateUrl="../../TestPage/Default.html"></rad:RadWindow>

<rad:RadWindow
id="Radwindow2"
Runat="server"
Top="60"
Left="190"
Width="370"
Height="220"
NavigateUrl="../../TestPage/Default.html"></rad:RadWindow>

<rad:RadWindow
id="Radwindow3"
Runat="server"
Top="80"
Left="210"
Width="370"
Height="220"
MinimizeZoneId="VerticalMinimize"
NavigateUrl="../../TestPage/Default.html"></rad:RadWindow>

<rad:RadWindow
id="Radwindow4"
Runat="server"
Width="370"
Height="220"
Top="100"
Left="220"
MinimizeZoneId="VerticalMinimize"
NavigateUrl="../../TestPage/Default.html"></rad:RadWindow>
</windows>
</rad:RadWindowManager>

© 2002-2008 Telerik. All Rights Reserved.


Splash Screens

Telerik RadWindow v1.9 Send comments on this topic.
Splash Screens
Customizing Behavior > Splash Screens

Glossary Item Box

Splash screens consist of image and text that are displayed while a program is being loaded. The same idea can be used for big, slow-loading web pages - e.g., present the user with an indication that the page is being loaded, and when the loading is over.

Telerik RadWindow can easily be used for the purpose by specifying the Splash property to true.

Example

ASP.NET Copy Code
<rad:RadWindowManager id="RadWindowManager1"
VisibleOnPageLoad = true
Skin = "Brown"
runat=server>
<windows>
<rad:RadWindow
id="Radwindow1"
NavigateUrl="./PageAd.html"
Runat="server"
Width="220"
Height="220"
Title="Fixed Ad Window"
Behavior = "Close"
InitialBehavior = "Pin"
OffsetElementId = "OffsetElement"
></rad:RadWindow>

<rad:RadWindow
id="Splash"
Splash = "true"
Runat="server"
></rad:RadWindow>

</windows>
</rad:RadWindowManager>

© 2002-2008 Telerik. All Rights Reserved.


Controlling the behavior of the RadWindow object

Telerik RadWindow v1.9 Send comments on this topic.
Controlling the behavior of the RadWindow object
Customizing Behavior > Controlling the behavior of the RadWindow object

Glossary Item Box

The Behavior property sets the behavior of the RadWindow object - if can be resized, has expand/collapse commands, closed command, etc.

Here are the Behavior's property values, they can be combined so you can have any combination of buttons in the window's bar:

  • None - No behavior is specified.
  • Resize - The object can be resized.
  • Minimize - The object can be minimized.
  • Close - The object can be closed.
  • Pin - The object can be pinned.
  • Maximize - The object can be maximized.
  • Move - The object can be moved.
  • Reload - The object will have a reload button.
  • Default - Default object behavior: all together.

For example, if you do not want to have the Close button but you need the Minimize and Maximize ones, you can set the Behavior="Minimize, Maximize"

You can also set the Behavior property from the codebehind:

C# Copy Code
radWindow.Behavior = RadWindowBehaviorFlags.Move |
RadWindowBehaviorFlags. Close |
RadWindowBehaviorFlags.Pin;
VB.NET Copy Code
RadWindowManager1.Windows("Radwindow2").Behavior = RadWindowBehaviorFlags.Resize Or RadWindowBehaviorFlags.Close

When setting multiple values for the Behavior property in .Net 1.x, make sure that you have the .Net 1.1. SP1 installed. The service pack introduces a fix for a bug with the .Net 1.x framework for setting multiple values for enums.

© 2002-2008 Telerik. All Rights Reserved.


Showing and Positioning

Telerik RadWindow v1.9 Send comments on this topic.
Showing and Positioning
Customizing Behavior > Showing and Positioning

Glossary Item Box

By default, windows are not visible on the page, and appear centered on the screen. However, the default behavior can be be changed just by setting a couple of properties and no code at all. Showing and initial positioning of the windows are easily controlled using three properties - VisibleOnPageLoad, OffsetElementId, OpenerElementId. The following scenarios are applicable:

1. Windows can be shown automatically when page loads. Setting the VisibleOnPageLoad property to true will automatically make the window visible when the page loads

2. Windows can be shown relative to an html element. Using the OffsetElementId allows for fine-grained control over the position of a window relative to the rest of the page element flow. This allows flexible declarative relative positioning that is independent of the screen-size and automatically adjusts to the changes in the page layout. The property should specify the ID of an HTML element, whose top left corner will be used by the window object to positions itself relatively. The offset can be additionally tuned using the Top and Left properties (to specify offsets in pixels).

3.Codeless opening of windows. While windows can be easily opened using the client-side JavaScript API, r.a.d windows also goes a step further in easing the developer. Use the OpenerElementId property to specify the ID of an HTML element that, when clicked, will automatically open the particular Telerik RadWindow object.

The OpenerElementId is of string type and expects to receive the client-side ID of the element. That is, if a server-side ASP.NET control is used (such as Button, Label, Link or another), its ClientID property should be specified. This can be done declaratively in the following manner:

ASP.NET Copy Code
< rad:RadWindow
VisibleOnPageLoad = "true"
OffsetElementId = "HtmlButton"
OpenerElementId="HtmlButton"
Runat ="server"></ rad:RadWindow >

< rad:RadWindow
VisibleOnPageLoad = "true"
OffsetElementId = " <% # ServerButton.ClientID %> "
OpenerElementId="<%# ServerButton.ClientID %> "
Runat="server"></rad:RadWindow>

The second Telerik RadWindow uses the Page's binding mechanism, and because of this it is mandatory that the DataBind() method is called (for example at the end of the Page_Load method).

Example:

Example

Show And Position

ASP.NET Copy Code
<rad:RadWindowManager visible="true" id="RadWindowManager1"
VisibleOnPageLoad = false
runat=server>
<windows>

<rad:RadWindow
VisibleOnPageLoad = "true"
OffsetElementId = "OffsetElement"
Top="23"
Left="70"
InitialBehavior = "Minimize"
NavigateUrl="../../TestPage/Default.html"
Runat="server"
Id="Radwindow1" ></rad:RadWindow>

<rad:RadWindow
VisibleOnPageLoad = "true"
OffsetElementId = "OffsetElement"
Top="42"
Left="70"
InitialBehavior = "Minimize"
NavigateUrl="../../TestPage/Default.html"
Runat="server"
ID="Radwindow2" ></rad:RadWindow>

<rad:RadWindow
VisibleOnPageLoad = "true"
OffsetElementId = "OffsetElement"
Left="174"
Top="-63"
Width="80px"
Height="230px"
NavigateUrl="EmptyPage.aspx"
Runat="server"
ID="Radwindow3" ></rad:RadWindow>

<rad:RadWindow
OpenerElementId = "<%# ServerLink.ClientID %>"
NavigateUrl="../../TestPage/Default.html"
Runat="server"
Id="Radwindow4" ></rad:RadWindow>

<rad:RadWindow
OpenerElementId = "<%# ServerLinkButton.ClientID %>"
OffsetElementId = "<%# ServerLinkButton.ClientID %>"
Top="200px"
NavigateUrl="../../TestPage/Default.html"
Runat="server"
Id="Radwindow6" ></rad:RadWindow>

<rad:RadWindow
OpenerElementId = "<%# ServerButton.ClientID %>"
OffsetElementId = "<%# ServerButton.ClientID %>"
Top="22"
id="OpenUsingServerLinkButton"
Runat="server"
NavigateUrl="../../TestPage/Default.html"></rad:RadWindow>

<rad:RadWindow
OffsetElementId = "HtmlButton"
OpenerElementId = "HtmlButton"
Left="152"
NavigateUrl="../../TestPage/Default.html"
id="OpenUsingServerLink"
Runat="server"
></rad:RadWindow>
</windows>
</rad:RadWindowManager>

© 2002-2008 Telerik. All Rights Reserved.


Personalizing the radalert, radprompt and radconfirm popups

Telerik RadWindow v1.9 Send comments on this topic.
Personalizing the radalert, radprompt and radconfirm popups
Customizing Behavior > Examples > Personalizing the radalert, radprompt and radconfirm popups

Glossary Item Box

HOW-TO

Personalize the radalert, radprompt and radconfirm dialogs .

SOLUTION

You can personalize the radalert dialog by providing the desired arguments in the radalert function:

radalert (text, oWidth, oHeight, oTitle)

Example:

radalert("Alert message", 200, 100, "Custom title")

The same approach can be used for the radconfirm and the radprompt dialogs.

© 2002-2008 Telerik. All Rights Reserved.


Opening Window in Different Scenarios

Telerik RadWindow v1.9 Send comments on this topic.
Opening Window in Different Scenarios
Customizing Behavior > Examples > Opening Window in Different Scenarios

Glossary Item Box

HOW-TO

Open RadWindow in different scenarios.

SOLUTION

Here are the basic ways to open RadWindow:

  • Using Declarative Binding. Here, you have to set the RadWindow OpenerElementId property to the ID of an element that, when clicked, will open the window, e.g.

    OpenerElementId = " <% # ServerButton.ClientID %> "

If it is a server-side element, such as asp:Button, make sure to call the RadWindowManager.DataBind() method in the codebehind:
RadWindowManager1.DataBind();

  • Using window.radopen or GetRadWindowManager().Open. These functions are essentially the same. They accept two parameters.
    • url (if no url is provided, the NavigateUrl property, set for this window on the server, will be used);
    • name of particular (existing) RadWindow to show (not providing a name as a second parameter will create a new window)
      Both functions return a reference to the RadWindow object, so it can be additionally configured using its clientside API.
  • Using radopen. Here are the possible combinations:
    • var oWnd = radopen (null, null); //Open a new window, with no url set
    • var oWnd = radopen ("http://www.google.com", null);//Open a new window, set its url to Google
    • var oWnd = radopen (null, "WindowNameHere");
      //Open an existing window, no url set -> The existing window's NavigateUrl property will be used
    • var oWnd = radopen ("http://www.google.com", "WindowNameHere");
      //Opens a specific page in existing window (will force a reload even if this very page was already loaded on last showing.
      // Good for dialogs that rely on execution of onload handlers to obtain values from parent page.)
  • Open a link in a Telerik RadWindow that might be currently invisible - this is a common case when you have defined some links (A elements) on the page that will open an URL in a particular RadWindow object.
    If the window, however, is not currently visible, the link will not open. To solve the problem simply add the following code to the onclick attribute of the link: onclick="window.radopen(null, WINDOW_NAME);"

    e.g.

    ASP.NET Copy Code
    <asp:HyperLink
    ID="Hyperlink"
    Runat=server
    onclick="window.radopen(null, 'GoogleWindow');"
    Target="GoogleWindow"
    NavigateUrl="http://www.google.com" >Open google</asp:HyperLink>

A code sample and more information are available in the following KB article: Invoking RadWindow using radopen, RadWindowManager.Open, and declaratively.

© 2002-2008 Telerik. All Rights Reserved.


Automatically Resizing RadWindow

Telerik RadWindow v1.9 Send comments on this topic.
Automatically Resizing RadWindow
Customizing Behavior > Examples > Automatically Resizing RadWindow

Glossary Item Box

HOW-TO

Automatically resize a RadWindow depending on its content.

SOLUTION

Basically you will need to do the following in the dialog that you are loading in the RadWindow:

  1. Reference the RadWindow object:

    Javascript Copy Code
    function GetRadWindow()
    {
    var oWindow = null;
    if (window.radWindow) oWindow = window.radWindow;
    else if (window.frameElement.radWindow) oWindow = window.frameElement.radWindow;
    return oWindow;
    }

  2. Insert the SizeToFit function and set it to be executed with some timeout:

    ASP.NET Copy Code
    <body topmargin=0 leftmargin=0 onload="SizeToFit()">

    <form id="Form1" method="post" runat="server">
    <script>
    function SizeToFit()
    {
    window.setTimeout(
    function()
    {
    var oWnd = GetRadWindow();
    oWnd.SetWidth(document.body.scrollWidth + 4);
    oWnd.SetHeight(document.body.scrollHeight + 70);

    }, 400);
    }
    Note that you will need to add some pixels to the RadWindow (4 / 70 in this case). This is done in order to compensate for the scrollbars that would appear in the window.

More information and a code sample are available in the following KB article: Automatically resizing a Telerik RadWindow depending on its content.

© 2002-2008 Telerik. All Rights Reserved.


Using URL Query String to Provide Arguments to RadWindow

Telerik RadWindow v1.9 Send comments on this topic.
Using URL Query String to Provide Arguments to RadWindow
Customizing Behavior > Examples > Using URL Query String to Provide Arguments to RadWindow

Glossary Item Box

HOW-TO

Use URL Query String to Provide Arguments to RadWindow.

SOLUTION

  1. On your main page you should construct the URL and use the radopen function to show the window:

    Javascript Copy Code
    function OpenDialog()
    {
    window.radopen("./ServersideArgumentsDialog.aspx?arg1=val1&arg2=val2", "DialogWindow");
    }
  2. Read the arguments provided in the url in your dialog page:
    C# Copy Code
    private void Page_Load(object sender, System.EventArgs e)
    {
    string oArgs = "";
    foreach (string key in Request.QueryString.Keys)
    {
    oArgs += key +     " = " + Request[key] + "";
    }
    ArgumentsLabel.Text = oArgs;
    }
    VB.NET Copy Code
    Private Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs)
    Dim oArgs As String = ""
    For Each key As String In Request.QueryString.Keys
    oArgs += key + " = " + Request(key) + ""
    Next
    ArgumentsLabel.Text = oArgs
    End Sub

A code sample and more information are available in the following KB article: Providing arguments to a page in RadWindow by using URL query string.

© 2002-2008 Telerik. All Rights Reserved.


Opening a RadWindow from within RadWindow

Telerik RadWindow v1.9 Send comments on this topic.
Opening a RadWindow from within RadWindow
Customizing Behavior > Examples > Opening a RadWindow from within RadWindow

Glossary Item Box

HOW-TO

Open a RadWindow from within RadWindow.

SOLUTION

Since there will be at least three windows on the screen (the browser window and the two RadWindow), you need to decide which should be the parent window of the second dialog - its direct RadWindow parent, or the top page. If you consider the desktop experience, then it will be more intuitive if the first dialog creates the second dialog within the context of the top window. This allows for the second dialog to be moved around the page, but not be confined within the borders of its (RadWindow) parent. So, the second dialog can be opened in the following two ways:
Javascript Copy Code
//One way to open a window from parent page
var oBrowserWnd = GetRadWindow().BrowserWindow;
oBrowserWnd.radopen("http://www.google.com", "ParentWindow");//A window with such name should exist in parent

or

Javascript Copy Code
//Another way to open a window from the parent page - analogous result to first!
var oManager = GetRadWindow().GetWindowManager();
oManager.Open("http://www.google.com", "ParentWindow");//A window with such name should exist in parent

A code sample and more information are available in the following KB article: Opening a Telerik RadWindow from within Telerik RadWindow.

© 2002-2008 Telerik. All Rights Reserved.


Skins

Telerik RadWindow v1.9 Send comments on this topic.
Skins
See Also
Customizing Appearance > Skins

Glossary Item Box

Telerik RadWindow's look and feel is fully customizable using skins. You can blend with the design of the rest of the site and thus increase its usability and attractiveness.
A skin is set to the RadWindowManager object, using the Skin property. All skins are located in the "~RadControls/Window/Skins" folder.

Each skin contains the following:

  • Window.css file with the css classes of the skin.
  • Modifiable CoreTemplates.xml file that holds the alert, prompt, confirm, minimize, splash templates for the skin.
  • Img folder containing images used in the skin (such as for the alert, minimize popups).
  • CssImg folder containing images referenced in the css classes (if any).
There can be only 1 skin set per page. Mixing skins is not recommended in this version.

Example

ASP.NET Copy Code
<rad:RadWindowManager
id="RadWindowManager1"
VisibleOnPageLoad="true"
Skin = "Golden"
runat="server" />
C# Copy Code
RadWindowManager1.Skin = "Office2007";

VB.NET Copy Code
RadWindowManager1.Skin = "Office2007"

See Also

Templates

© 2002-2008 Telerik. All Rights Reserved.


Introduction and contents

Telerik RadWindow v1.9 Send comments on this topic.
Introduction and contents
Customizing Appearance > Creating a skin for RadWindow > Introduction and contents

Glossary Item Box

Introduction

This tutorial is aimed at web-developers that have intermediate / advanced knowledge of Cascading Style Sheets – css selectors, pseudo-elements, floats, block-level and inline elements. We also assume that readers are acquainted with PhotoShop and XHTML basics.

A Beginner’s Cascading Style Sheets Reference, explaining CSS’ basics may be downloaded from here. Links to various CSS resources are available at the Appendix section of this document. We also provide Basics of Telerik RadControls for ASP.NET CSS Skinning Reference, containing simple tips and tricks for creating skins for our WebForms suite.

Content:

  • Step 1: Preparations
  • Step 2: Editing Window.css
  • Step 3: Advanced Skinning Techniques in Telerik RadWindow
  • Appendix

© 2002-2008 Telerik. All Rights Reserved.


Preparations

Telerik RadWindow v1.9 Send comments on this topic.
Preparations
Customizing Appearance > Creating a skin for RadWindow > Preparations

Glossary Item Box

1.1. Choosing the right skin to edit

A good practice is to modify an existing skin, rather that creating one from a scratch. It is also recommended that the skin that will be modified resembles the target design - you may compare borders, colors, fonts, rounded corners and even colors.

Take a look at the skinning example of Telerik RadWindow. We will assume that our target design is the Web 2.0 skin…

… and to achieve the above result we will revamp the WindowsXP Luna skin:

You can create an .aspx page and paste the markup below. For detailed visual explanation of the html structure, follow this link to the appendix of the tutorial.

ASP.NET Copy Code
<rad:RadWindowManager id="Singleton" runat="server" Skin="WinXPLuna">
<windows>
<rad:RadWindow VisibleOnPageLoad="true" Runat="server" Width="800" Height="600" NavigateUrl="http://www.google.com" id="Radwindow1" name="Radwindow1"></rad:RadWindow>
</windows>
</rad:RadWindowManager>

1.2. Getting the skin

Go to ~/RadControls/Window/Skins/ folder and copy the WinXPLuna folder, and rename it to MyWeb20 (as Web20 already exists) and open Window.css.

1.3. Setting the skin

In your server declaration change the skin property to MyWeb20…

ASP.NET Copy Code
<rad:RadWindowManager id="Singleton" runat="server" Skin="WinXPLuna">
<windows>
<rad:RadWindow VisibleOnPageLoad="true" Runat="server" Width="800" Height="600" NavigateUrl="http://www.google.com" id="Radwindow1" name="Radwindow1"></rad:RadWindow>
</windows>
</rad:RadWindowManager>

… and hit F5 to reload the page. The new skin will look exactly the same as WinXPLuna skin, but named MyWeb20:

Notice that the skin property is set in the RadWindowManager tag, not in the RadWindow, which means that you cannot have windows with different skins on one page.

© 2002-2008 Telerik. All Rights Reserved.


Editing Window.css

Telerik RadWindow v1.9 Send comments on this topic.
Editing Window.css
Customizing Appearance > Creating a skin for RadWindow > Editing Window.css

Glossary Item Box

Another good practice in skinning is to modify the classes gradually, top to bottom, so we will start editing the titlebar classes.

2.1. The titlebar

As Telerik RadWindow is created with tables, the titlebar is appearance is controlled by 3 classes and an additional 4th one, which facilitates the top resize functionality.

Before we start editing the style declaration we will replace the existing background images with the new ones needed for the target skin. Make sure you preserve the filenames, otherwise old images might be left behind and you will spend time chaning filenames in the css declarations. You have to perform the image replace task for all images that Telerik RadWindow consists of. We will illustrate this step only for the titlebar classes.

Hit F5 to reload the page after you are over and done with the image replacement. You will see the new images slightly (or much) displaced. To fix this, we have to set the right dimensions by editing the responding css properties, in our case these are the height and the width.

2.1.1. Top left corner

Replace [image] with [image] (CssImg/RadWWrapperHeaderLeft.gif)

CSS Copy Code
.RadWWrapperHeaderLeft
{
background: transparent url('CssImg/RadWWrapperHeaderLeft.gif') no-repeat;
width: 4px;
height: 50px;
font-size: 1px;
}

2.1.2. Center section

Replace [image] with [image] (CssImg/RadWWrapperHeaderCenter.gif')

CSS Copy Code
.RadWWrapperHeaderCenter
{
height: 47px;
text-align: left;
background: transparent url('CssImg/RadWWrapperHeaderCenter.gif') repeat-x bottom;
font-size: 1px;
}

2.1.3. Top right corner

Replace [image] with [image] (CssImg/RadWWrapperHeaderRight.gif)

CSS Copy Code
.RadWWrapperHeaderRight
{
background: transparent url('CssImg/RadWWrapperHeaderRight.gif') no-repeat;
width: 4px;
height: 50px;
font-size: 1px;
}

2.1.3. Top resizer

CSS Copy Code
.RadWHeaderTopResizer
{
height: 3px;
font-size: 1px;
background: transparent url('CssImg/RadWWrapperHeaderCenter.gif') repeat-x top;
}

There are three very important aspects that we should consider while skinning the titlebar of Telerik RadWindow, the latter being valid for the entire component:

1. The height in pixels of RadWWrapperHeaderCenter is calculated with the following formula:

RadWWrapperHeaderCenter = RadWWrapperHeaderLeft - RadWHeaderTopResizer

In our case, the overall height of the titlebar is 50 pixels and the height of RadWHeaderTopResizer is 3 pixels, so the height of RadWWrapperHeaderCenter will be 47 pixels. Also, have in mind that as RadWHeaderTopResizer selector facilitates the top resize functionality of Telerik RadWindow, it's height (as well all other outer borders of Telerik RadWindow) should not be less than 3 pixels, otherwise they become difficult to grab and drag with the mouse.

3. Notice that we use only one background image for RadWWrapperHeaderCenter and RadWHeaderTopResizer, but with different vertical alignment top and bottom and this not only reduces file number, but also handles gradients properly. However, this aspect is not important when background color is used instead of images.

2. The font-size: 1px; fix - we use it to handle properly empty cells in Internet Explorer. Another Mozilla proprietary fix will be explained later in this tutorial.

2.2 The left and right borders

Locate the following two classes and edit them according to the target design. Make sure the width you set is not less than 3-4 pixels, otherwise the resize functionality will become difficult.

CSS Copy Code
.RadWWrapperBodyLeft,
.RadWWrapperBodyRight
{
background: transparent url('CssImg/RadWWrapperBody.gif') repeat-y;
width: 4px;
font-size: 1px;
}

Notice that in the target skin both classes are united in a single definition as they are alike. In other cases you will probably need to define them separately.

2.3. The statusbar

The statusbar of Telerik RadWindow is controlled by the .RadWStatus and in our target design it is set to display none, along with its adjacent and inner elements:

CSS Copy Code
.RadWStatus,

.RadWStatusRow,

.RadWStatus input

{

display: none; /* this skin does not support status bar by design */

}

However, most of the skins support visible statusbar, and it can be easily styled using the usual css properties like border, font, color, background, etc.

2.4. The footer

Similar to the titlebar classes, the footer appearance of Telerik RadWindow is controlled by three classes as well. In our target skin, the css properties are:

CSS Copy Code
.RadWWrapperFooterLeft
{
width: 4px;
height: 20px;
background: transparent url('CssImg/RadWWrapperFooterLeft.gif') no-repeat;
position: relative;
top: -1px;
}

.RadWWrapperFooterCenter
{
background: transparent url('CssImg/RadWWrapperFooterCenter.gif') repeat-x;
position: relative;
top: -1px;
}

.RadWWrapperFooterRight
{
width: 20px;
height: 20px;
background: transparent url('CssImg/RadWWrapperFooterRight.gif') no-repeat right;
position: relative;
top: -1px;
}
Make sure you have replaced the old images with the ones of the target skin and do not forget to set the new dimensions accordingly.

© 2002-2008 Telerik. All Rights Reserved.


Advanced skinning techniques in Telerik RadWindow

Telerik RadWindow v1.9 Send comments on this topic.
Advanced skinning techniques in Telerik RadWindow
Customizing Appearance > Creating a skin for RadWindow > Advanced skinning techniques in Telerik RadWindow

Glossary Item Box

3.0.1. The :before pseudo-element

The :before and :after pseudo-elements can be used to insert generated content before or after an element's content. They are extensively explained in the section on generated text of the W3C web site.

In the case of Telerik RadWindow we use it to handle properly white-space in certain classes under Mozilla. Without this fix, Mozilla will NOT display these classes at all. Although :before and :after are valid CSS elements, currently they are not supported by Microsoft Internet Explorer:

CSS Copy Code
.RadWWrapperBodyLeft:before,
.RadWWrapperBodyRight:before,
.RadWWrapperFooterLeft:before,
.RadWWrapperHeaderLeft:before,
.RadWWrapperHeaderRight:before
{
content: " ";
display: block;
width: 4px;
font-size: 1px;
}

.RadWWrapperFooterRight:before
{
content: " ";
display: block;
width: 20px;
font-size: 1px;
}

What we do is to insert a single &nbsp; character via the content: " "; property. To make this fix work properly, we also have to set the selector to display: block;

3.0.2. Setting semi-transparent background to the modal dialog with CSS

The class that controls the modal background of Telerik RadWindow when Modal is set to true or radalert(), radprompt() or radconfirm() are used. Currently this class uses a semi-transparent image, but this could be easily overridden by a slight modification of the above class and give the Telerik RadWindow a totally new cross-browser Web2.0 looks.

Locate the .RadWModalImage class in Window.css and replace all of its css properties with the ones below:

CSS Copy Code
.RadWModalImage
{
background: black;
filter: progid:DXImageTransform.Microsoft.Alpha(opacity=50);
opacity: .5;
-moz-opacity: .5;
}

The background property specifies the background color, and the three that follow - the opacity rate. The filter property is a Microsoft proprietary one and is part of the DirectX Multimedia Filters and Transitions. You need to modify the opacity value in the brackets - it should be an integer from 0 to 100, 100 being totally opaque.

The opacity property is a valid CSS2.1 property and is supported by Opera 9x and Mozilla FireFox 2x.

The -moz-opacity property is a vendor specific one and works with older versions of Mozilla Firexox (before 2.0).

© 2002-2008 Telerik. All Rights Reserved.


Appendix

Telerik RadWindow v1.9 Send comments on this topic.
Appendix
Customizing Appearance > Creating a skin for RadWindow > Appendix

Glossary Item Box

4.1. Useful Telerik RadWindow resources

  • Telerik RadWindow overview
  • Online skinning examples
  • Basics of Telerik RadControls for ASP.NET skinning (PDF file)
  • Telerik RadWindow online help
  • Telerik RadWindow community forums

4.2. General CSS knowledge

  • World Wide Web Consortium CSS specifications
  • W3 Schools CSS tutorial
  • Guide to Cascading Style Sheets

© 2002-2008 Telerik. All Rights Reserved.


Templates

Telerik RadWindow v1.9 Send comments on this topic.
Templates
See Also
Customizing Appearance > Templates

Glossary Item Box

Telerik RadWindow provides an xml file - CoreTemplate.xml - which holds templates for splash screens, windows in minimized modes, and alert, confirm, and prompt dialog boxes. For each Telerik RadWindow skin there is a CoreTemplate.xml file located in the root folder of the skin (e.g. "~\Telerik\Telerik RadWindow1.x\NET2\RadControls\Window\Skins\Brown\CoreTemplates.xml"). You can modify CoreTemplate.xml files or create new ones in order to customize a skin.

Exemplary Structure of a CoreTemplate.xml file

The parameters provided to the template are the following:

{0} - RadWindow client ID //not generally needed
{1} - RadWindowobject reference (allows to call radWindow methods such as Close, Restore, etc.)
{2} - Path to current skin folder (allows to access images, other resources)
{3} - url to the Minimized Icon
{4} - title text
{5} - application path
{6} - Text to show (in the alert, confirm, prompt);

Template

 Exemplary Content

Splash Template
XML Copy Code
- <splashtemplate>
<![CDATA[ <div style="height: 200px; width: 400px; border: solid 1px #808080;
text-align: center; background-color: #fff;
filter: progid:DXImageTransform.Microsoft.Shadow(direction=140,color=#404040,strength=3);">
<br /><br /><br />
<div style="font-weight: bold; color: #808080; font-size: 16px;">loading...</div>
<br />
<img src="{2}Img/splash.gif" height="62" width="62" alt="" />
</div>

]]>
</splashtemplate>

Minimize Template
XML Copy Code
- <minimizetemplate>
<![CDATA[
<table border='0' id='RadWMinimized{0}' class='RadWMinimizedActive'
cellspacing='0' cellpadding='0'>
<tr>
<td style='vertical-align:middle;' nowrap><div style='padding:1px;
width:120px;overflow:hidden;padding-left: 15px;text-overflow: ellipsis;'>
<span id='RadWMinimizedTitle{0}' style="width: 100px;" onselectstart='return false;'
class='RadWTitleText'>{4}</span></div></td>
<td nowrap>
<img class='RadWButton' style='vertical-align:middle;border:0' src='{2}/Img/Restore.gif'
id='RadWMinimizedRestore{0}' onclick='{1}.Restore()'/>
</td>
<td nowrap>
<img class='RadWButton' style='vertical-align:middle;border:0' src='{2}/Img/Close.gif'
id='RadWMinimizedClose{0}' onclick='{1}.Close()'/>
</td>
</tr>
</table>

]]>
</minimizetemplate>

Alert Template
XML Copy Code
- <alerttemplate>
- <![CDATA[ <style>
BODY
{
font-family: "Times New Roman", Helvetica, Serif;
font-size: 12px;
font-weight: normal;
overflow:hidden;
background-color: #f1f2eb;
background-image: url({2}Img/pageBg.gif);
background-repeat: repeat-x;
background-position: bottom left;
}
.Button
{
background-image: url({2}Img/modalBtnBg.gif);
background-repeat: no-repeat;
background-color: #15d1f8;
border: none;
width: 61px;
height: 22px;
color: #eaeac8;
font-family: "Times New Roman", Helvetica, Serif;
font-size: 12px;
font-weight: bold;
}
.FixedDiv
{
overflow: auto;
color: #000000;
vertical-align: top;
width: 280px;
height: 160px;
}
.imageContainer
{
float: left;
height: 160px;
width: 94px;
}
.guiControls
{
float: left;
}
</style>
<br /><br />
<div class='FixedDiv'>
<div class='imageContainer'>
<img align='absmiddle' style='vertical-align:middle;border:0' src='{2}Img/AlertIcon.gif'>
</div>
<div class='guiControls'>
<br />
{6}
<br /><br /><br />
<center><button class="Button" onclick="GetRadWindow().Close();">OK</button></center>
<embed src="{2}/Img/alert.wav" height="0" width="0" style="display: none;"></embed>
</div>
</div>

]]>
</alerttemplate>

Prompt Template
XML Copy Code
- <prompttemplate>
- <![CDATA[
<script>
function OkClicked()
{
var oArg = document.getElementById("TextBox").value;
GetRadWindow().ModalDialogCallBack(oArg);
}
</script>
<style>
BODY
{
font-family: "Times New Roman", Helvetica, Serif;
font-size: 12px;
font-weight: normal;
overflow:hidden;
background-color: #f1f2eb;
background-image: url({2}Img/pageBg.gif);
background-repeat: repeat-x;
background-position: bottom left;
}
.Button
{
background-image: url({2}Img/modalBtnBg.gif);
background-repeat: no-repeat;
background-color: #15d1f8;
border: none;
width: 61px;
height: 22px;
color: #eaeac8;
font-family: "Times New Roman", Helvetica, Serif;
font-size: 12px;
font-weight: bold;
}
.FixedDiv
{
overflow: auto;
color: #000000;
vertical-align: top;
width: 280px;
height: 160px;
}
.imageContainer
{
float: left;
height: 140px;
width: 85px;
}
.guiControls
{
float: left;
}
.promptTxtBox
{
font-family: "Times New Roman", Helvetica, Serif;
font-size: 12px;
font-weight: normal;
margin-top: 5px;
border: solid 1px #5c5a4f;
width: 163px;
}
</style>
<br /><br />
<div class='FixedDiv'>
<div class='imageContainer'>
<img align='absmiddle' style='vertical-align:middle;border:0' src='{2}Img/confirmIcon.gif'>
</div>
<div class='guiControls'>
{6}
<br /><br />
< input type='textbox' value="120" id='TextBox' class="promptTxtBox">
<br /><br /><br />
<center>
<button class="Button" onclick="OkClicked()";>OK</button>
<button class="Button" onclick="GetRadWindow().Close();">Cancel</button>
</center>
<embed src="{2}/Img/alert.wav" height="0" width="0" style="display: none;"></embed>
</div>
</div>

]]>
</prompttemplate>
Confirm Template
XML Copy Code
- <confirmtemplate>
- <![CDATA[
<style>
BODY
{
font-family: "Times New Roman", Helvetica, Serif;
font-size: 12px;
font-weight: normal;
overflow:hidden;
background-color: #f1f2eb;
background-image: url({2}Img/pageBg.gif);
background-repeat: repeat-x;
background-position: bottom left;
}
.Button
{
background-image: url({2}Img/modalBtnBg.gif);
background-repeat: no-repeat;
background-color: #15d1f8;
border: none;
width: 61px;
height: 22px;
color: #eaeac8;
font-family: "Times New Roman", Helvetica, Serif;
font-size: 12px;
font-weight: bold;
}
.FixedDiv
{
overflow: auto;
color: #000000;
vertical-align: top;
width: 280px;
height: 160px;
}
.imageContainer
{
float: left;
height: 160px;
width: 85px;
}
.guiControls
{
float: left;
}
</style>
<br /><br />
<div class='FixedDiv'>
<div class='imageContainer'>
<img align='absmiddle' style='vertical-align:middle;border:0' src='{2}Img/confirmIcon.gif'>
</div>
<div class='guiControls'>
{6}
<br /><br /><br /><br />
<center>
<button class="Button" onclick="GetRadWindow().ModalDialogCallBack(true);">Yes</button>
<button class="Button" onclick="GetRadWindow().ModalDialogCallBack(false);">No</button>
</center>
<embed src="{2}/Img/alert.wav" height="0" width="0" style="display: none;"></embed>
</div>
</div>

]]>
</confirmtemplate>

See Also

Skins

© 2002-2008 Telerik. All Rights Reserved.


Using Telerik RadWindow for Editing Telerik RadGrid Records

Telerik RadWindow v1.9 Send comments on this topic.
Using Telerik RadWindow for Editing Telerik RadGrid Records
Interoperability with Other Controls > Using Telerik RadWindow for Editing Telerik RadGrid Records

Glossary Item Box

HOW-TO

Use Telerik RadWindow for editing Telerik RadGrid records.

SOLUTION

There are different ways to hook the Telerik RadWindow object to Telerik RadGrid in order to edit data in a popup fashion, and then update the edited item (passing the new values back to the main page).

Below we describe the needed steps to use Telerik RadWindow in a sample case utilizing GridButtonColumn and using async request:

  1. Traverse the GridDataItems in the ItemCreated handler of the grid and replace the [Edit] link button in GridButtonColumn (declaratively defined) with HtmlAnchor instance.
  2. Attach a javascript function to the onclick attribute of that anchor which opens Telerik RadWindow (passing the primary key for the currently created item as an argument to that function).
  3. Open the popup window calling window.radopen() and passing the primary key in the query string of the new window.
  4. In the content page of Telerik RadWindow retrieve the cell values from the grid source which correspond to the primary key from the query string and display them in editable textboxes.
  5. Edit the cell content, update the row in the grid source, close the popup window and refresh the grid calling the RadGridNamespace.AsyncRequest method (note that the grid EnableAJAX/EnableAsyncRequests property should be set to true). For more information regarding how to raise postback event from user control/webform please read this chapter from the grid online help.

More information on the subject and a sample project are available in the following KB article:

Using Telerik RadWindow for editing/inserting Telerik RadGrid records

© 2002-2008 Telerik. All Rights Reserved.


Binding to a grid - Opening Windows by Clicking Grid Items

Telerik RadWindow v1.9 Send comments on this topic.
Binding to a grid - Opening Windows by Clicking Grid Items
Interoperability with Other Controls > Binding to a grid - Opening Windows by Clicking Grid Items

Glossary Item Box

HOW-TO

Open Telerik RadWindow from DataGrid.

SOLUTION

  1. Open from asp:HyperLinkColumn

    Use the DataNavigateUrlFormatString, DataNavigateUrlField and DataNavigateUrlFormatString properties. Be careful to use the exact same syntax, e.g.:
    ASP.NET Copy Code
    <asp:HyperLinkColumn
    DataTextField="NameField"
    DataNavigateUrlField="DataField"
    DataNavigateUrlFormatString="javascript:function anon(){{window.radopen('{0}','DialogWindow');}};anon();">
    </    asp:HyperLinkColumn>
  2. Open from asp:TemplateColumn

    Use the DataBinder.Eval expression syntax, surround in single quotes so that the expression gets evaluated, e.g.:

    ASP.NET Copy Code
    <asp:TemplateColumn>
    <ItemTemplate>
    <button
    onclick='<%# "window.radopen(\"" + DataBinder.Eval(Container.DataItem,"DataField ")
    + "\",\"DialogWindow\"); return false;" %>'>
    <%#DataBinder.Eval(Container.DataItem, "NameField")%>
    </button>
    </    ItemTemplate>
  3. Open from asp:TemplateColumn (In this case, the opening is positioned to button)

    Use the same syntax as above, but provide a modified opener function that will position the window to the opening button:

    Javascript Copy Code
    function OpenPositionedWindow(oButton, url, windowName)
    {
    var oWnd = window.radopen(url,windowName);
    var oPos     = GetTopLeftPosition(oButton);
    oWnd.MoveTo(oPos.x, oPos.y     + 20); //oPos.x + parseInt(oButton.clientWidth) -> will move the window to the right end of the button
    }
    function GetTopLeftPosition(element)
    {
    var left = 0;
    var top     = 0;

    while (element.offsetParent)
    {
    left += element.offsetLeft;
    top     += element.offsetTop;
    element     = element.offsetParent;
    }
    if (element.x) left = element.x;
    if (element.y) top = element.y;
    var oPos     = new Object();
    oPos.x     = left;
    oPos.y     = top;
    return oPos;
    }

More information on the subject and a sample project are available in the following KB article:

Binding to a grid - opening windows by clicking grid items

© 2002-2008 Telerik. All Rights Reserved.


Open Telerik RadWindow from Telerik RadMenu

Telerik RadWindow v1.9 Send comments on this topic.
Open Telerik RadWindow from Telerik RadMenu
Interoperability with Other Controls > Open Telerik RadWindow from Telerik RadMenu

Glossary Item Box

HOW-TO

Open a Telerik RadWindow by clicking on a Telerik RadMenu item.

SOLUTION

You will need to decide whether you will open the Telerik RadWindow from the codebehind, e.g. after a postback or by using Javascript. In the second case, you will need to stop the postback and execute the appropriate Javascript.

Example:

ASP.NET Copy Code
<script type="text/javascript">
function clickHandler(sender, eventArgs)
{
//If you open the window by javascript, you will need to
//cancel the postback event and to execute the javascript:

//Checks which item is clicked
if (eventArgs.Item.Text == "Dialog1(JS)")
{
//open a pre-defined window from the RadWindowManager's
//Windows collection
radopen(null,"Window1");
//Cancel the postback
return false;
}
}
</script>
<radM:RadMenu ID="RadMenu1" OnClientItemClicking="clickHandler" runat="server" OnItemClick="RadMenu1_ItemClick">
<Items>
<radM:RadMenuItem ID="RadMenuItem1" runat="server" Text="Dialog2(codebehind)">
</radM:RadMenuItem>
<radM:RadMenuItem ID="RadMenuItem3" runat="server" Text="Google(codebehind)">
</radM:RadMenuItem>
<radM:RadMenuItem ID="RadMenuItem2" runat="server" Text="Dialog1(JS)">
</radM:RadMenuItem>
</Items>
</radM:RadMenu>
<rad:RadWindowManager ID=RadWindowManager1 runat=server>
<Windows>
<rad:RadWindow ID=Window1 runat=server NavigateUrl="Dialog1.aspx" />
</Windows>
</rad:RadWindowManager>

In the codebehind:

VB.NET Copy Code
Protected Sub RadMenu1_ItemClick(ByVal sender As Object, ByVal e As Telerik.WebControls.RadMenuEventArgs) Handles RadMenu1.ItemClick
'Checks which item is clicked
If e.Item.Text = "Dialog2(codebehind)" Then
'Create a new RadWindow
Dim rw As New RadWindow
'Set its properties
rw.Width = Unit.Pixel(260)
rw.Height = Unit.Pixel(300)
rw.NavigateUrl = "Dialog2.aspx"
'Make sure that the window will be shown after the postback
rw.VisibleOnPageLoad = True
'Add it to the RadWindowManager's Windows collection
RadWindowManager1.Windows.Add(rw)
End If

'Checks which item is clicked
If e.Item.Text = "Google(codebehind)" Then
'Create a new RadWindow
Dim rw1 As New RadWindow
'Set its properties
rw1.Width = Unit.Pixel(400)
rw1.Height = Unit.Pixel(400)
rw1.NavigateUrl = "http://www.google.com"
'Make sure that the window will be shown after the postback
rw1.VisibleOnPageLoad = True
'Add it to the RadWindowManager's Windows collection
RadWindowManager1.Windows.Add(rw1)
End If
End Sub

© 2002-2008 Telerik. All Rights Reserved.


Open Telerik RadWindow from Telerik RadToolBar

Telerik RadWindow v1.9 Send comments on this topic.
Open Telerik RadWindow from Telerik RadToolBar
Interoperability with Other Controls > Open Telerik RadWindow from Telerik RadToolBar

Glossary Item Box

HOW-TO

test2 Open a Telerik RadWindow by clicking on a Telerik RadToolBar item.

SOLUTION

If you will open the RadWindow by Javascript, you will need to cancel the postback in the Javascript function:

ASP.NET Copy Code
<radTlb:RadToolbar ID="RadToolbar1" runat="server">
<Items>
<radTlb:RadToolbarButton ID="RadToolbarButton1" CommandName="NewWindow" runat="server" ButtonImage="new.gif"
Hidden="False" ButtonText="openWindow"></radTlb:RadToolbarButton>
<radTlb:RadToolbarButton ID="RadToolbarButton2" CommandName="OpenWindow" runat="server" ButtonImage="Open.gif"
Hidden="False" />
</Items>
</radTlb:RadToolbar>
<rad:RadWindowManager ID="RadWindowManager" Top="200" Left="200" runat="server">
<Windows>
<rad:RadWindow ID="PredefinedWindow" Top="100" Left="100" NavigateUrl="http://www.telerik.com"
runat="server"></rad:RadWindow>
</Windows>
</rad:RadWindowManager>

<script type="text/javascript">
<%= RadToolbar1.ClientID %>.attachEvent("OnClientClick","click_handler");
function click_handler(sender, e)
{

if(sender.CommandName == 'NewWindow') //<- if you want just a particular button not to preform a postback.
{
radopen(http://www.google.com, null);
return false; // -> this line will prevent Telerik RadToolBar from performing a postback.
}
if(sender.CommandName == 'OpenWindow')
{
radopen(null,"PredefinedWindow" );
return false;
}
}

</script>

© 2002-2008 Telerik. All Rights Reserved.


Open Telerik RadWindow from Telerik RadRotator

Telerik RadWindow v1.9 Send comments on this topic.
Open Telerik RadWindow from Telerik RadRotator
Interoperability with Other Controls > Open Telerik RadWindow from Telerik RadRotator

Glossary Item Box

HOW-TO

Open a Telerik RadWindow by clicking on a Telerik RadRotator item.

SOLUTION

In the example below, a Telerik RadWindow will open when clicking an item in Telerik RadRotator.

ASP.NET Copy Code
<radR:RadRotator TransitionEffect="gradientwipe" FrameTimeout="2050" Width="468px"
Height="60px" runat="server" ContentFile="banner1.xml" ID="rotator1">
<FrameTemplate>
<img src="Images/<%# DataBinder.Eval(Container.DataItem, "filename") %>" onclick="openWin('<%# DataBinder.Eval(Container.DataItem, "filename") %>');"
alt="<%# DataBinder.Eval(Container.DataItem, "filename") %>" style="border: 0px;" />
</FrameTemplate>
</radR:RadRotator>
<rad:RadWindowManager ID="RadWindowManager1" runat="server">
</rad:RadWindowManager>

<script>
function openWin(imgname)
{
radopen("Images/"+imgname,"RadWindow1");
}
</script>

A code sample is available in the following Code Library article:

Opening a Telerik RadWindow by clicking a Telerik RadRotator item

© 2002-2008 Telerik. All Rights Reserved.


Client-Side Model

Telerik RadWindow v1.9 Send comments on this topic.
Client-Side Model
RadWindow Client-Side > Client-Side Model

Glossary Item Box

There are three properties of type string from the server-side API which are assigned the name of a client-side javascript function as a parameter. By default this is a standard function but you can add "if" clauses in its body. The table below contains description and examples of using these properties:

Property

 Description

OnClientPageLoad

Gets or sets the client function to be called when a page is loaded in a Telerik RadWindow dialog. As an argument it receives a reference to the particular window to be shown.

Example

aspx/ascx Copy Code
<rad:RadWindowManager
id= "RadWindowManager1"
runat= "server"
OnClientPageLoad = "OnClientPageLoad"
>
<windows>
<rad:RadWindow id="UserListDialog"
OpenerElementId = "<%# ServerButton.ClientID %>"
OffsetElementId = "InfoDiv"
Left= "150px"
Modal = "true"
Runat= "server"
Width= "250px"
Height= "400px"
Title= "User List Dialog"
NavigateUrl= "./Dialog.aspx">
</rad:RadWindow>
</windows>
</rad:RadWindowManager>

Javascript Copy Code
function OnClientPageLoad(radWindow)
{
alert (radWindow.Name + " has finished loading");
}

OnClientShow

Gets or sets the client function to be called when a window is being shown. As an argument it receives a reference to the particular window to be shown. Good for setting an argument to the window.

Example

aspx/ascx Copy Code
<rad:RadWindowManager
id= "RadWindowManager1"
runat= "server"
OnClientShow = "OnClientShow"
>
<windows>
<rad:RadWindow id="UserListDialog"
OpenerElementId = "<%# ServerButton.ClientID %>"
OffsetElementId = "InfoDiv"
Left= "150px"
Modal = "true"
Runat= "server"
Width= "250px"
Height= "400px"
Title= "User List Dialog"
NavigateUrl= "./Dialog.aspx">
</rad:RadWindow>
</windows>
</rad:RadWindowManager>

Javascript Copy Code
/* Called when a window is being shown. Good for
//setting an argument to the window */
function OnClientShow(radWindow)
{
alert (radWindow.Name + " is being shown");
var arg = new Object();
//An argument can be anything - string, number, object.
//If it is an object, various properties can be
//set for carrying multiple information
arg.SomeValue = "Value1";
//Set the argument object to the radWindow
radWindow.Argument = arg;
}

OnClientClose

Gets or sets the client function to be called when a window is being closed. As an argument it receives a reference to the particular window to be closed.
Good for doing cleanup work.

Example

aspx/ascx Copy Code
<rad:RadWindowManager
id= "RadWindowManager1"
runat= "server"
OnClientClose = "OnClientClose"
>
<windows>
<rad:RadWindow id="UserListDialog"
OpenerElementId = "<%# ServerButton.ClientID %>"
OffsetElementId = "InfoDiv"
Left= "150px"
Modal = "true"
Runat= "server"
Width= "250px"
Height= "400px"
Title= "User List Dialog"
NavigateUrl= "./Dialog.aspx">
</rad:RadWindow>
</windows>
</rad:RadWindowManager>

Javascript Copy Code
/* Called when a window is being closed. */
function OnClientClose(radWindow)
{
alert (radWindow.Name + " is being closed");
}

ClientCallBackFunction

Gets or sets the client function to be automatically called when a rad window is closed. The difference to the OnClientClose event is that a second argument is provided - the return value (if any) from the dialog.
Can also be called explicitly from within a rad window (good for scenarios where dialog should return values to the opening page multiple times). This function will be called only if there is a returned argument from the content page.

Example

aspx/ascx Copy Code
<rad:RadWindowManager
id= "RadWindowManager1"
runat= "server"
ClientCallBackFunction= "CallBackFunction"
>
<windows>
<rad:RadWindow id="UserListDialog"
OpenerElementId = "<%# ServerButton.ClientID %>"
OffsetElementId = "InfoDiv"
Left= "150px"
Modal = "true"
Runat= "server"
Width= "250px"
Height= "400px"
Title= "User List Dialog"
NavigateUrl= "./Dialog.aspx">
</rad:RadWindow>
</windows>
</rad:RadWindowManager>

Javascript Copy Code
/* Can be called from within a rad window */
function CallBackFunction(radWindow, returnValue)
{
//Do something with the return value!
alert (radWindow.Name + " CallBackFunction is called with
returnValue=" + returnValue);
}

See a live example at www.telerik.com...

© 2002-2008 Telerik. All Rights Reserved.


RadWindowManager Client-Side Object Model

Telerik RadWindow v1.9 Send comments on this topic.
RadWindowManager Client-Side Object Model
RadWindow Client-Side > RadWindowManager Client-Side Object Model

Glossary Item Box

On the client-side, the window manager takes care of:

  • providing of a reference to the current active window
  • opening new windows
  • taking care of the alert/confirm/prompt dialogs
  • managing the minimization modes

Client-Side RadWindowManager Methods

Property | Description
GetRadWindowManager() | Returns a reference to the window manager.
GetWindows() | Returns a reference to the array of rad window objects managed by the RadWindowManager.
GetWindowByName() | Returns a reference to a rad window. The Name is the window's serverside Id property!
GetActiveWindow() | Returns a reference to the current active window.
Open() | Opens a new or existing window. Can be used to change the url of existing window as well.
Tile() | Tiles the window objects.
Cascade() | Cascades the window objects.
ShowAll() | Shows all windows.
CloseAll() | Closes all windows.
MinimizeAll() | Minimizes all windows.
MinimizeActiveWindow() | Minimizes the current active windows.
RestoreActiveWindow() | Restores the active window (if it was minimized or maximized).

Example

Javascript Copy Code
function UseWindowManager()
{
//Getting rad window manager
var oManager = GetRadWindowManager();
//Success. Getting existing window DialogWindow using GetWindowByName
var oWnd = oManager.GetWindowByName("DialogWindow");
//Success. Setting a size and a Url to the window using its client API before showing
oWnd.SetSize(400,400);
oWnd.SetUrl("http://www.google.com");
//Success. Opening window
oWnd.Show();
//Success. Calling window RadWindowManager.GetActiveWindow (should return reference to current window
var oActive = oManager.GetActiveWindow();
//Success. Is current visible window the active one? " + (oActive != null && oActive == oWnd)
//Success. Open a new window using RadWindowManager.Open using default settings
var oNew = oManager.Open("../TestPage/Default.html", "NewWindow");
}

© 2002-2008 Telerik. All Rights Reserved.


RadWindow Object Client-Side Object Model

Telerik RadWindow v1.9 Send comments on this topic.
RadWindow Object Client-Side Object Model
RadWindow Client-Side > RadWindow Object Client-Side Object Model

Glossary Item Box

Client-Side RadWindow Model

Member | Description
SetSize(width,height) | Sets size (width and height) of window.
MoveTo(left,top) | Sets position (left, top) of window.
Center() | Centers the window in the middle of the page.
Show() | Shows the window if it was invisible. If a window does not exists, it creates it.
Hide() | Makes the window invisible.
SetVisible(isVisible) | Makes the window visible.
Minimize() | Minimizes window.
Maximize() | Maximizes window.
Restore() | Restores window to its normal (non-minimized) state.
SetUrl(url) | Changes URL of window.
GetUrl() | Gets the URL of the window.
Reload() | Reloads the content page in RadWindow. The page should come from the same server as is the parent page.
Close() | Closes window.
Argument | An object that gets transferred between the calling page and the window dialog.
AttachClientEvent(event, function) | Attaches a client event on the client. Useful to attach onminimize, onmaximize and onrestore events to the RadWindow.
BrowserWindow | Returns a reference to the parent page's document. Useful when calling functions on the parent page.
GetWindowManager() | Returns a reference to the RadWindowManager.
SetModal(isModal) | Sets modality of window. Accepts true/false as an argument, e.g. oWnd.SetModal(true);
SetActive() | Sets the window to be the active (topmost) on the page.
SetContent() | Allows dynamic content to be set to the window (rather than loading a url).
SetWidth() | Sets window width in pixels.
SetHeight() | Sets window height in pixels.
GetWidth() | Gets window width in pixels.
GetHeight() | Gets window height in pixels.
SetTitle() | Sets window title. Note that if the content page has its own title set in the @Page directive or in the <head> section, this title will override the RadWindow's one.
SetStatus() | Displays content in the window status bar.
GetContentFrame() | Returns a reference to RadWindow's content area (IFRAME). One possible use is to to call a function, that is declared in the RadWindow's page, from the parent page. Another possible use is to modify the DOM.
GetTitlebar() | Returns a reference to the window title bar HTML element.
GetStatusbar() | Returns a reference to the window status bar HTML element.
GetTopPosition() | Returns the current top coordinate of the window.
GetLeftPosition() | Returns the current left coordinate of the window.
IsModal() | Returns true if the window is modal.
IsClosed() | Returns true if the window is currently closed.
IsPinned() | Returns true if the window is currently pinned.
TogglePin() | Toggles the RadWindow's pin on/off.
IsMaximized() | Returns true if the window is currently maximized.
IsMinimized() | Returns true if the window is currently minimized.
IsVisible() | Returns true if the window is currently visible.
IsActive() | Returns true if the window is the currently active one.
SetOffsetElementId(ID) | Sets the OffsetElementId for the RadWindow.
SetOpenerElementId(ID) | Sets the OpenerElementId for the RadWindow.
OnClientClose | Sets OnClientClose for the RadWindow.
ClientCallBackFunction | Sets the ClientCallBackFunction for the RadWindow.
OnClientPageLoad | Sets the OnClientPageLoad for the RadWindow.

Examples

Javascript

 Copy Code
function UseRadWindow()
{
var oManager = GetRadWindowManager();
var oWnd = oManager.GetWindowByName("DialogWindow");
oWnd.Show();
oWnd.SetSize(400,400);
oWnd.SetUrl("http://www.yahoo.com");
oWnd.Minimize();
oWnd.Maximize();
oWnd.Restore();
}

function AlertMinimizedMaximizedState()
{
//retrieve all RadWindows on the page
var allWindows = GetRadWindowManager().GetWindowObjects();
for (var i=0; i<allWindows.length; i++)
{
var win = allWindows[i];
alert("Is minimized: " + win.IsMinimized() + "; Is maximized: " + win.IsMaximized());
}
}

//Set the ClientCallBackFunction dynamically. Useful for RadWindows created on the client.
function OpenWin()
{
var oWnd = radopen("Dialog.aspx", null);
oWnd.ClientCallBackFunction = function(MyWnd, arg)
{
//Your code here
}
}

//Set the OnClientClose dynamically. Useful for RadWindows created on the client.
function OpenWin()
{
var oWnd = radopen("Dialog.aspx", null);
oWnd.OnClientClose = function()
{
//Your code here
}
}

//Call a predefined function in opened RadWindow
function CallFn()
{
var oWnd = GetRadWindowManager().GetWindowByName("RadWindow1");
oWnd.GetContentFrame().contentWindow.CalledFn(); //CalledFn() must exists in the RadWindow's content
}

Note: the following 2 examples require the GetRadWindow() function to exist on the page.
//needed to get a reference to the RadWindow wrapper
function GetRadWindow()
{
var oWindow = null;
if (window.radWindow) oWindow = window.radWindow;
else if (window.frameElement.radWindow) oWindow = window.frameElement.radWindow;
return oWindow;
}

//Call a function in the parent page
function CallFnOnParent()
{
GetRadWindow().BrowserWindow.CalledFn(); //CalledFn() must exist in parent
}

//call function in one RadWindow from another
function CallFn()
{
//Get a reference to the parent page (Default.aspx)
var parentPage = GetRadWindow().BrowserWindow;
//get a reference to the second RadWindow
var dialogB = parentPage.GetRadWindowManager().GetWindowByName("RadWindow2");
//by using the GetContentFrame() method, call the predefined function
dialogB.GetContentFrame().contentWindow.CalledFn();
}

© 2002-2008 Telerik. All Rights Reserved.


Window Open

Telerik RadWindow v1.9 Send comments on this topic.
Window Open
RadWindow Client-Side > Examples > Window Open

Glossary Item Box

Declarative binding

1) Set the RadWindow OpenerElementId property to the ID of an element that, when clicked, should open the window, e.g.

OpenerElementId = " <% # ServerButton.ClientID %> "

2) Make sure if it is a serverside element, such as asp:Button to call the DataBind() method in the codebehind.

Using window.radopen or GetRadWindowManager().Open

These functions are essentially the same. They accept two parameters:

  1. Url. If no url is provided, the NavigateUrl property set for this window on the server will be used.
  2. Name of particular (existing) rad window to show. Not providing a name as a second parameter will create a new window.

Both functions return a reference to the RadWindow object, so it can be additionally configured using its client-side API.

radopen combinations:

Javascript Copy Code
//Open a new window, with no url set
var oWnd = radopen (null, null);

//Open a new window, set its url to Google
var oWnd = radopen ("http://www.google.com", null);

//Open an existing window, no url set -> The existing window's NavigateUrl property will be used
var oWnd = radopen (null, "WindowNameHere");

//Open Google in existing window
var oWnd = radopen ("http://www.google.com", "WindowNameHere");

Example

ASP.NET Copy Code
<script>
/* Using radopen */
function ShowExisting1()
{
//Show an existing window
window.radopen(null, "DialogWindow");
//First argument is the URL. Since no url is provided, the NavigateUrl property set on the server will be used.
}

/* Using RadWindowManager.Open */
function ShowExisting2()
{
//Call existing global function to obtain a reference to the window manager
var oManager = GetRadWindowManager();
//Show a particular existing window (not providing a name as a second parameter will create a new window)
oManager.Open (null,"DialogWindow");
}

/* Show new window */
function ShowNewWindow()
{
//Show new window
//not providing a name as a second parameter will create a new window
var oWindow = window.radopen ("http://www.google.com", null);

//Using the reference to the window its clientside methods can be called
oWindow.SetSize (400, 400);
oWindow.SetTitle ("This is a clientside title");
}
</script>

<asp:Button Runat="server" ID="ServerButton"
Text="Show window (codeless serverside binding)"
CssClass="button"
Width="250">
</asp:Button>
<br>

<button onclick="ShowExisting1();return false;"
class="Button" style="WIDTH:190px">
Show window (using radopen)
</button>
<br>

<button onclick="ShowExisting2();return false;"
class="Button" style="WIDTH:190px">
Show window (using Open)
</button>
<br>

<button onclick="ShowNewWindow();return false;"
class="Button" style="WIDTH:190px">
Show new window
</button>
<br>

<rad:RadWindowManager id="RadWindowManager1" runat="server">
<windows>
<rad:RadWindow id="DialogWindow"
OpenerElementId = "<%# ServerButton.ClientID %>"
Modal = "true"
Runat="server"
Width="500px"
Height="400px"
NavigateUrl="../TestPage/Default.html">
</rad:RadWindow>
</windows>
</rad:RadWindowManager>

See a live example at www.telerik.com

© 2002-2008 Telerik. All Rights Reserved.


Using RadWindow as a Dialog

Telerik RadWindow v1.9 Send comments on this topic.
Using RadWindow as a Dialog
RadWindow Client-Side > Examples > Using RadWindow as a Dialog

Glossary Item Box

On the main page:

  • Use OnClientShow function to set the Argument to the dialog being opened
  • Use ClientCallBackFunction function to receive a result from the dialog, and use it as necessary.

On the dialog page:

  • To get a backreference to the parent rad window, the following script should exist (be manually inserted) in the dialog page.
Javascript Copy Code
function GetRadWindow()
{
var oWindow = null;
if (window.radWindow) oWindow = window.radWindow;
else if (window.frameElement.radWindow) oWindow = window.frameElement.radWindow;
return oWindow;
}

  • The Cancel button closes the containing window like this:

Javascript Copy Code
var oWindow = GetRadWindow();
oWindow.Close();

  • The OK button invokes the callback function and provides it with a return value like this:

Javascript Copy Code
//Variant1: Invoke the calback function, pass it the result as an argument
oWindow.CallBack(oNewText);
//By default calling the CallBack method will close the RadWindow from which it is called. It//is possible to not close the window by specifying an additional parameter to the callback function: //oWindow.CallBack(oNewText,true);

//Variant2: Passing the argument to the Close method will result in the same behavior
oWindow.Close(oNewText);

//Variant3: Possible to set the Argument property of RadWindow here, and read it in the OnClientClose event handler!
oWindow.Argument = oNewText;

See a live example at www.telerik.com

If you want to return multiple values from the dialog, you will need to create the argument as a new object and assign multiple values to it:

Javascript Copy Code
var arg = new Object();
arg.NameValue = document.getElementById("NewNameArea").value;
arg.ProfessionValue = document.getElementById("NewProfessionArea").value;

A working example of this approach is available in the following Code Library article:

Returning multiple Values From a Dialog

© 2002-2008 Telerik. All Rights Reserved.


Postback And Close On Reload

Telerik RadWindow v1.9 Send comments on this topic.
Postback And Close On Reload
RadWindow Client-Side > Examples > Postback And Close On Reload

Glossary Item Box

The following scenarios are possible:

1. Postback an object of Telerik RadWindow, reload it and close it on reload. The scenario when regular browser windows call self.close().

2. Scenario is common when the Telerik RadWindow opens a Wizard that will perform some action, such as user registration (with a postback to the server), and then need to close itself automatically without the user explicitly closing it.

3. A third (similar) scenario is to reload the parent browser page after a postback, to display the changes (e.g. updated user list, for example).

At present the reload of the browser page will not automatically make the opened windows to re-appear after the postback, but this will be implemented in the future.

Example

How to implementing a self closing dialog code:

1. Include all necessary javascript to the page, e.g.

Javascript Copy Code
//This code is used to provide a reference to the radwindow "wrapper"
function GetRadWindow()
{
var oWindow = null;
if (window.radWindow) oWindow = window.radWindow; //Will work in Moz in all cases, including clasic dialog
else if (window.frameElement.radWindow) oWindow = window.frameElement.radWindow;//IE (and Moz az well)
return oWindow;
}

function CloseOnReload()
{
GetRadWindow().Close();
}

function RefreshParentPage()
{
GetRadWindow().BrowserWindow.location.reload();
}

2. Declare a asp:Label within the dialog that will be used as a placehoder for injecting the proper clientside function call depending which button is clicked.

3. Declare two asp:Button objects and assign (server) onclick event handlers.

4. In the handlers perform the needed serverside actions and then set proper Text value to the asp:Label object, e.g.

C# Copy Code
private void Button1_Click(object sender, System.EventArgs e)
{
InjectScript.Text="<script>CloseOnReload()</" + "script>";
}

private void Button2_Click(object sender, System.EventArgs e)
{
InjectScript.Text="<script>RefreshParentPage()</" + "script>";
}

VB.NET Copy Code
Private Sub Button1_Click(ByVal sender As Object, ByVal e As System.EventArgs)

InjectScript.Text="<script>CloseOnReload()</" + "script>"
End Sub
Private Sub Button2_Click(ByVal sender As Object, ByVal e As System.EventArgs)

InjectScript.Text="<script>RefreshParentPage()</" + "script>";
End Sub

A code sample and more information are available in the following KB article:

Telerik RadWindow that postbacks and manipulates opener page on its reload

© 2002-2008 Telerik. All Rights Reserved.


Calling a Dialog From Within a Dialog

Telerik RadWindow v1.9 Send comments on this topic.
Calling a Dialog From Within a Dialog
RadWindow Client-Side > Examples > Calling a Dialog From Within a Dialog

Glossary Item Box

See previous topics in this section for the applied logic. The only additional thing you have to consider is which should be the parent window of the second dialog. The variants are:

  • its direct rad window parent - then the new window can be moved only within the borders of its parent.

OR

  • the top page - then the window can be moved around the whole page. This approach brings a stronger desktop-like exerience.

The second dialog can be opened in at least two ways:

Javascript Copy Code
//One way to open a window from parent page
var oBrowserWnd = GetRadWindow().BrowserWindow;
oBrowserWnd.radopen("http://www.google.com", "ParentWindow");//A window with such name that does exist in parent

OR

Javascript Copy Code
//Another way to open a window from the parent page - analogous result to first!

var oManager = GetRadWindow().GetWindowManager();
oManager.Open("http://www.google.com", "ParentWindow");//A window with such name that does exist in parent

In both cases, you will need to have a backreference to the parent rad window, e.g. the following script should exist (be manually inserted) in the dialog page.

Javascript Copy Code
function GetRadWindow()
{
var oWindow = null;
if (window.radWindow) oWindow = window.radWindow;
else if (window.frameElement.radWindow) oWindow = window.frameElement.radWindow;
return oWindow;
}

A code sample and more information are available in the following KB article:

Opening a Telerik RadWindow from within Telerik RadWindow

© 2002-2008 Telerik. All Rights Reserved.


RadWindowManager Server-Side Object Model

Telerik RadWindow v1.9 Send comments on this topic.
RadWindowManager Server-Side Object Model
RadWindow Server-Side > RadWindowManager Server-Side Object Model

Glossary Item Box

On the server-side, the window manager has two sets of properties:

  • properties common to the window objects. Can be overridden by window objects.
  • properties specific to the window manager. Apply unconditionally to every Telerik RadWindow, such as Localization, Skin, etc.

RadWindowBase defines a set of common properties. Both RadWindowManager and RadWindow inherit from RadWindowBase. For easier customization, the common properties that are set in RadWindowManager apply to all child RadWindow controls, and each individual RadWindow can override these with a new value.

RadWindowManager defines a number of properties that are specific to it only, and control the look and behavior of all windows.

Server-side properties that are unique to RadWindowManager

Property | Description
Skin | Specifies the skin of the windows. Default skins are located in the RadControls/Window/Skins folder. New skin folders can be easily created using the default skins as a base.
Language | Specifies the localization to use for the windows - there are three default localizations - English, German and French, located in the RadControls/Window/Localization folder.
UseClassicWindows | Reverts to using the default browser dialogs for situations such as low level browsers or the page itself being displayed in a small window.
SingleNonMinimizedWindow | If set to true, automatically minimizes all windows except the current active window. Thus allows saving screen space.
Shortcuts collection | This property is used to allow associating keyboard shortcuts with RadWindowManager client commands.

Other server-side properties that are likely to be set to RadWindowManager

Property | Description
VisibleOnPageLoad | If true it will automatically make visible all windows from the windows collection when the page is loaded. By default this value is false.
OffsetElementId | The id of an html element whose upper left corner will be used by window objects to position themselves when showing. Commonly used in combination with Top and Left properties to specify additional offsets.
MinimizeZoneId | The id of an html element that will be used as a docking zone when a window is minimized.
InitialBehavior | Specifies whether the windows will be minimized or maximized initially. Values can be added together - for example in addition you can specify whether to pin the windows.
Behavior | Specifies whether the window can be maximized, minimized, resized, closed, or pinned by the user.
VisibleStatusbar | By default the status bar of the window is visible. You can hide it by setting the VisibleStatusbar property to false.
ClientCallBackFunction | The name of the client-side javascript function that will be called automatically when a RadWindow dialog is closed.
ReloadOnShow | Specifies whether the page that is loaded in the window will be cached from the browser or not.
ShowPageDuringLoad | Gets or sets a value indicating whether the page that is loaded in the window should be shown during the loading process, or when it has finished loading (useful in scenarios where controls on the page being loaded expect the page to be visible to properly position themselves).

© 2002-2008 Telerik. All Rights Reserved.


RadWindow Object Server-Side Object Model

Telerik RadWindow v1.9 Send comments on this topic.
RadWindow Object Server-Side Object Model
RadWindow Server-Side > RadWindow Object Server-Side Object Model

Glossary Item Box

Telerik RadWindow objects on the page are managed by the RadWindowManager. Both RadWindowManager and RadWindow inherit from RadWindowBase, which defines a set of common properties. For easier customization, the common properties that are set in RadWindowManager apply to all child RadWindow controls, and each individual RadWindow can override these with a new value.

RadWindow class defines the following property that is not present in RadWindowManager:

Property | Description
Splash | Specifies whether the window is used as a splash screen that is hidden at page load.

Other properties that are likely to be set to RadWindow:

Property | Description
VisibleOnPageLoad | If true it will automatically make visible the window when the page is loaded. By default this value is false.
OffsetElementId | The ID of an html element, whose upper left corner will be used by window objects to position themselves when showing. Commonly used in combination with Top and Left properties to specify additional offsets.
MinimizeZoneId | The ID of an html element that will be used as a docking zone when a window is minimized.
InitialBehavior | Specifies whether the window will be minimized or maximized initially. Values can be added together - for example in addition you can specify whether to pin the window.
Behavior | Specifies whether the window can be maximized, minimized, resized, closed, or pinned by the user.

© 2002-2008 Telerik. All Rights Reserved.


Calling radalert from Codebehind

Telerik RadWindow v1.9 Send comments on this topic.
Calling radalert from Codebehind
RadWindow Server-Side > Examples > Calling radalert from Codebehind

Glossary Item Box

HOW-TO

Call radalert from codebehind.

SOLUTION

If you need to call a radalert from codebehind, you can do it by using a label on your page where you will insert the radalert calling script. e.g:

C# Copy Code
private void Button1_Click(object sender, System.EventArgs e)
{

Label1.Text = "<script language='javascript'> window.onload = function(){radalert('Welcome to Telerik RadWindow!', 330, 210);}</script>";

}

VB.NET Copy Code
Private Sub Button1_Click(ByVal sender As Object, ByVal e As System.EventArgs)

Label1.Text = "<script language='javascript'> window.onload = function(){radalert('Welcome to Telerik RadWindow!', 330, 210);}</script>"

End Sub

The described approach will work for postbacks only and in general it is about a common ASP.NET task - how to call a Javascript function from the server. One of the approaches is described above - to populate a label with the script. In addition, for radalert to be executed, the RadWindowManager should be loaded in the page. That is why we are executing it on window.onload.

The task gets complicated if Ajax is used because the page does not reload and window.onload is fired only once (when the page is initially shown). When using Ajax you must apply an appropriate solution depending on the exact case.

© 2002-2008 Telerik. All Rights Reserved.


Setting Server-side Properties

Telerik RadWindow v1.9 Send comments on this topic.
Setting Server-side Properties
RadWindow Server-Side > Examples > Setting Server-side Properties

Glossary Item Box

It is possible to increase the flexibility of the rad windows by configuring them dynamically in the codebehind, based on external conditions on the page.

The code below shows:

  • Looping through the Windows collection of RadWindowManager
  • Setting properties to RadWindow objects
  • Creating a new RadWindow dynamically
  • Configuring the new RadWindow adding it to the Windows collection

C# Copy Code
private void Page_Load(object sender, System.EventArgs e)
{
//Set properties present only in RadWindowManager

//Set language
WindowManager.Language = "fr-FR";

//Set skin
WindowManager.Skin = "Monochrome";

//Disable standard popup (alert, prompt, confirm) templates to decrease page size
WindowManager.EnableStandardPopups = false;

//Set the same height to all windows
WindowManager.Height = Unit.Pixel(250);

//Add shortcuts to radwindow manager clientside commands
WindowManager.Shortcuts.Add( new WindowShortcut("MinimizeAll", "ALT+F2"));
WindowManager.Shortcuts.Add( new WindowShortcut("RestoreAll", "ALT+F3"));

int offsetLeft = 0;

//Loop through all windows in the WindowManager.Windows collection
foreach (RadWindow win in WindowManager.Windows)
{
//Set whether the first window will be visible on page load
win.VisibleOnPageLoad = true;

//Set MinimizeZoneId - (an HTML element where the window's minimized representation will appear)
win.MinimizeZoneId = "MinimizeZone";

//Set MinimizeMode (goes together with the MinimizeZone setting)
win.MinimizeMode = RadWindowMinimizeModes.MinimizeZone;

//Set the initial behavior (whether the window will be minimized, maximized and/or pinned)
win.InitialBehavior = RadWindowBehaviorFlags.Minimize;

//Set OffsetElementId - the id (ClientID if a runat=server is used) of a html element, which, when clicked, will automatically open/show the Telerik RadWindow
win.OffsetElementId = "OffsetElement";

//Top and Left can be used in conjunction with the OffsetElementId (if no OffsetElementId is specified, the top left corner of the browser window is used
win.Top = 15;
win.Left = offsetLeft;
offsetLeft += 100;
}

//Create a new window add it dynamically

//The window will inherit the default settings of parent WindowManager
RadWindow newWindow = new RadWindow();
newWindow.NavigateUrl = "../TestPage/Default.html";

//Set OffsetElementId - the id (ClientID if a runat=server is used) of a html element, which, when clicked, will automatically open/show the Telerik RadWindow
newWindow.OpenerElementId = OpenerButton.ClientID;

//Set OpenerElementId - the id (ClientID if a runat=server is used) of a html element, whose left and top position will be used as 0,0 of the Telerik RadWindow object when it is first shown
newWindow.OffsetElementId = OpenerButton.ClientID;

//Top and Left can be used in conjunction with the OffsetElementId (if no OffsetElementId is specified, the top left corner of the browser window is used
newWindow.Top = Unit.Pixel(22);
newWindow.Left = Unit.Pixel(0);

//Add the newly created RadWindow to the RadWindowManager's collection
WindowManager.Windows.Add(newWindow);

//Get a reference to the first window in the list
RadWindow firstWindow = WindowManager.Windows[0];
//alternative:
//Telerik.WebControls.RadWindow mywindow = RadWindowManager1.Windows["RadWindowServer"];

//Set its navigate URl to be different
firstWindow.NavigateUrl = "../TestPage/Default.html";
}

VB.NET Copy Code
Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

'Set properties present only in RadWindowManager

'Set language
WindowManager.Language = "fr-FR"

'Set skin
WindowManager.Skin = "Monochrome"

'Disable standard popup (alert, prompt, confirm) templates to decrease page size
WindowManager.EnableStandardPopups = False

'Set the same height to all windows
WindowManager.Height = Unit.Pixel(250)

'Add shortcuts to radwindow manager clientside commands
WindowManager.Shortcuts.Add(New WindowShortcut("MinimizeAll", "ALT+F2"))
WindowManager.Shortcuts.Add(New WindowShortcut("RestoreAll", "ALT+F3"))

Dim offsetLeft As Integer = 0

'Loop through all windows in the WindowManager.Windows collection
For Each win As RadWindow In WindowManager.Windows

'Set whether the first window will be visible on page load
win.VisibleOnPageLoad = True

'Set MinimizeZoneId - (an HTML element where the window's minimized representation will appear)
win.MinimizeZoneId = "MinimizeZone"

'Set MinimizeMode (goes together with the MinimizeZone setting)
win.MinimizeMode = RadWindowMinimizeModes.MinimizeZone

'Set the initial behavior (whether the window will be minimized, maximized and/or pinned)
win.InitialBehavior = RadWindowBehaviorFlags.Minimize

'Set OffsetElementId - the id (ClientID if a runat=server is used) of a html element, which, when clicked, will automatically open/show the Telerik RadWindow
win.OffsetElementId = "OffsetElement"

'Top and Left can be used in conjunction with the OffsetElementId (if no OffsetElementId is specified, the top left corner of the browser window is used
win.Top = Unit.Pixel(15)
win.Left = Unit.Pixel(offsetLeft)
offsetLeft += 100
Next win

'Create a new window and add it dynamically
'The window will inherit the default settings of parent WindowManager

Dim newWindow As RadWindow = New RadWindow
newWindow.NavigateUrl = "../TestPage/Default.html"

'Set OffsetElementId - the id (ClientID if a runat=server is used) of a html element, which, when clicked, will automatically open/show the Telerik RadWindow
newWindow.OpenerElementId = OpenerButton.ClientID

'Set OpenerElementId - the id (ClientID if a runat=server is used) of a html element, whose left and top position will be used as 0,0 of the Telerik RadWindow object when it is first shown
newWindow.OffsetElementId = OpenerButton.ClientID

'Top and Left can be used in conjunction with the OffsetElementId (if no OffsetElementId is specified, the top left corner of the browser window is used
newWindow.Top = Unit.Pixel(22)
newWindow.Left = Unit.Pixel(0)
'Add the newly created RadWindow to the RadWindowManager's collection
WindowManager.Windows.Add(newWindow)

'Get a reference to the first window in the list
Dim firstWindow As RadWindow = WindowManager.Windows(0)

'Set its navigate URl to be different
firstWindow.NavigateUrl = "../TestPage/Default.html"

End Sub

A code sample and more information are available in the following KB article:

Setting RadWindow and RadWindowManager properties serverside

© 2002-2008 Telerik. All Rights Reserved.


RadWindow Class

RadWindow Send comments on this topic.
RadWindow Class
See Also Members
[image]
Telerik.WebControls Namespace : RadWindow Class

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Class RadWindow
   Inherits RadWindowBase
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
C#
public class RadWindow : RadWindowBase

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadWindowUtils.RadControl
Telerik.RadWindowUtils.RadSkinnableControl
Telerik.WebControls.RadWindowBase
Telerik.WebControls.RadWindow

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadWindow (in RadWindow.dll)

See Also

Reference

RadWindow Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadWindow Class Members

RadWindow Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadWindow Class

The following tables list the members exposed by RadWindow.

Public Constructors

 | Name | Description
Public Constructor | RadWindow Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Behavior | Gets or sets a value indicating the behavior of this object - if can be resized, has expand/collapse commands, closed command, etc. (Inherited from RadWindowBase)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientCallBackFunction | Gets or sets the client callback function that will be called when a window dialog is being closed. (Inherited from RadWindowBase)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DestroyOnClose | Gets or sets a value indicating whether the window will be made inaccessible once it is closed. (Inherited from RadWindowBase)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | IconUrl | Gets or sets the url of the icon in the upper left corner of the RadWindow titlebar. (Inherited from RadWindowBase)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitialBehavior | Gets or sets a value indicating the initial behavior of this object - most useful to specify an initially minimized, maximized or pinned window. (Inherited from RadWindowBase)
Public Property | Left | Gets or sets the horizontal offset from the browser left side. (Inherited from RadWindowBase)
Public Property | MinimizeIconUrl | Gets or sets the url of the minimized icon of the RadWindow. (Inherited from RadWindowBase)
Public Property | MinimizeMode | Gets or sets the minimize options for the RadWindow object. SameLocation, MinimizeZone. (Inherited from RadWindowBase)
Public Property | MinimizeZoneId | Gets or sets the id (ClientID if a runat=server is used) of a html element where the windows will be "docked" when minimized. (Inherited from RadWindowBase)
Public Property | Modal | Gets or sets a value indicating whether a dialog is modal or not. (Inherited from RadWindowBase)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | NavigateUrl | Specifies the URL that will originally be loaded in the RadWindow (can be changed on the client). (Inherited from RadWindowBase)
Public Property | OffsetElementId | Gets or sets the id (ClientID if a runat=server is used) of a html element, whose left and top position will be used as 0,0 of the RadWindow object when it is first shown. (Inherited from RadWindowBase)
Public Property | OnClientClose | Gets or sets the client function to be called when a window dialog is being closed. (Inherited from RadWindowBase)
Public Property | OnClientPageLoad | Gets or sets the client function to be called when a page is loaded in a RadWindow dialog. (Inherited from RadWindowBase)
Public Property | OnClientShow | Get or sets the client function to be called when a window dialog is being opened. (Inherited from RadWindowBase)
Public Property | OpenerElementId | Gets or sets the id (ClientID if a runat=server is used) of a html element, which, when clicked, will automatically open/show the RadWindow. (Inherited from RadWindowBase)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadWindowUtils.RadControl)
Public Property | ReloadOnShow | Gets or sets a value indicating whether the page that is loaded in the window should be loaded everytime from the server or will leave the browser default behaviour (Inherited from RadWindowBase)
Public Property | ShowContentDuringLoad | Gets or sets a value indicating whether the page that is loaded in the window should be shown during the loading process, or when it has finished loading. (Inherited from RadWindowBase)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | (Inherited from Telerik.RadWindowUtils.RadSkinnableControl)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | (Inherited from Telerik.RadWindowUtils.RadSkinnableControl)
Public Property | Splash | Gets or sets a value indicating whether the window is used as a splash screen that is hidden at page load.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Title | Gets or sets the RadWindow title (can be changed on the client) (Inherited from RadWindowBase)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Top | Gets or sets the vertical distance from the browser top. (Inherited from RadWindowBase)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadWindowUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | VisibleOnPageLoad | Gets or sets a value indicating whether the window will open automatically when the aspx page is loaded on the client. (Inherited from RadWindowBase)
Public Property | VisibleStatusbar | Gets or sets a value indicating whether the window has a visible status bar or not. (Inherited from RadWindowBase)
Public Property | VisibleTitlebar | Gets or sets a value indicating whether the window has a titlebar visible. (Inherited from RadWindowBase)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadWindow Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadWindow Constructor

RadWindow Constructor
See Also
[image]
Telerik.WebControls Namespace > RadWindow Class : RadWindow Constructor

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadWindow()
C#
public RadWindow()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadWindow()
C#
public RadWindow()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindow Class
RadWindow Members

© 2002-2005, telerik. All Rights Reserved.


RadWindow Class Properties

RadWindow Class Properties
[image]
Telerik.WebControls Namespace : RadWindow Class

For a list of all members of this type, see RadWindow members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Behavior | Gets or sets a value indicating the behavior of this object - if can be resized, has expand/collapse commands, closed command, etc. (Inherited from RadWindowBase)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientCallBackFunction | Gets or sets the client callback function that will be called when a window dialog is being closed. (Inherited from RadWindowBase)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DestroyOnClose | Gets or sets a value indicating whether the window will be made inaccessible once it is closed. (Inherited from RadWindowBase)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | IconUrl | Gets or sets the url of the icon in the upper left corner of the RadWindow titlebar. (Inherited from RadWindowBase)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitialBehavior | Gets or sets a value indicating the initial behavior of this object - most useful to specify an initially minimized, maximized or pinned window. (Inherited from RadWindowBase)
Public Property | Left | Gets or sets the horizontal offset from the browser left side. (Inherited from RadWindowBase)
Public Property | MinimizeIconUrl | Gets or sets the url of the minimized icon of the RadWindow. (Inherited from RadWindowBase)
Public Property | MinimizeMode | Gets or sets the minimize options for the RadWindow object. SameLocation, MinimizeZone. (Inherited from RadWindowBase)
Public Property | MinimizeZoneId | Gets or sets the id (ClientID if a runat=server is used) of a html element where the windows will be "docked" when minimized. (Inherited from RadWindowBase)
Public Property | Modal | Gets or sets a value indicating whether a dialog is modal or not. (Inherited from RadWindowBase)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | NavigateUrl | Specifies the URL that will originally be loaded in the RadWindow (can be changed on the client). (Inherited from RadWindowBase)
Public Property | OffsetElementId | Gets or sets the id (ClientID if a runat=server is used) of a html element, whose left and top position will be used as 0,0 of the RadWindow object when it is first shown. (Inherited from RadWindowBase)
Public Property | OnClientClose | Gets or sets the client function to be called when a window dialog is being closed. (Inherited from RadWindowBase)
Public Property | OnClientPageLoad | Gets or sets the client function to be called when a page is loaded in a RadWindow dialog. (Inherited from RadWindowBase)
Public Property | OnClientShow | Get or sets the client function to be called when a window dialog is being opened. (Inherited from RadWindowBase)
Public Property | OpenerElementId | Gets or sets the id (ClientID if a runat=server is used) of a html element, which, when clicked, will automatically open/show the RadWindow. (Inherited from RadWindowBase)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadWindowUtils.RadControl)
Public Property | ReloadOnShow | Gets or sets a value indicating whether the page that is loaded in the window should be loaded everytime from the server or will leave the browser default behaviour (Inherited from RadWindowBase)
Public Property | ShowContentDuringLoad | Gets or sets a value indicating whether the page that is loaded in the window should be shown during the loading process, or when it has finished loading. (Inherited from RadWindowBase)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | (Inherited from Telerik.RadWindowUtils.RadSkinnableControl)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | (Inherited from Telerik.RadWindowUtils.RadSkinnableControl)
Public Property | Splash | Gets or sets a value indicating whether the window is used as a splash screen that is hidden at page load.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Title | Gets or sets the RadWindow title (can be changed on the client) (Inherited from RadWindowBase)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Top | Gets or sets the vertical distance from the browser top. (Inherited from RadWindowBase)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadWindowUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | VisibleOnPageLoad | Gets or sets a value indicating whether the window will open automatically when the aspx page is loaded on the client. (Inherited from RadWindowBase)
Public Property | VisibleStatusbar | Gets or sets a value indicating whether the window has a visible status bar or not. (Inherited from RadWindowBase)
Public Property | VisibleTitlebar | Gets or sets a value indicating whether the window has a titlebar visible. (Inherited from RadWindowBase)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

RadWindow Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


Splash Property

Splash Property
[image]
Telerik.WebControls Namespace > RadWindow Class : Splash Property

Gets or sets a value indicating whether the window is used as a splash screen that is hidden at page load.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property Splash As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Boolean

instance.Splash = value

value = instance.Splash
C#
public bool Splash {get; set;}

Return Value

The default value is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindow Class
RadWindow Members

© 2002-2005, telerik. All Rights Reserved.


RadWindowBase Class

RadWindowBase Class
See Also Members
[image]
Telerik.WebControls Namespace : RadWindowBase Class

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class RadWindowBase
   Inherits RadSkinnableControl
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
C#
public abstract class RadWindowBase : RadSkinnableControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadWindowUtils.RadControl
Telerik.RadWindowUtils.RadSkinnableControl
Telerik.WebControls.RadWindowBase
Telerik.WebControls.RadWindow
Telerik.WebControls.RadWindowManager

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadWindow (in RadWindow.dll)

See Also

Reference

RadWindowBase Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadWindowBase Class Members

RadWindowBase Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadWindowBase Class

The following tables list the members exposed by RadWindowBase.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Behavior | Gets or sets a value indicating the behavior of this object - if can be resized, has expand/collapse commands, closed command, etc.
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientCallBackFunction | Gets or sets the client callback function that will be called when a window dialog is being closed.
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DestroyOnClose | Gets or sets a value indicating whether the window will be made inaccessible once it is closed.
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | IconUrl | Gets or sets the url of the icon in the upper left corner of the RadWindow titlebar.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitialBehavior | Gets or sets a value indicating the initial behavior of this object - most useful to specify an initially minimized, maximized or pinned window.
Public Property | Left | Gets or sets the horizontal offset from the browser left side.
Public Property | MinimizeIconUrl | Gets or sets the url of the minimized icon of the RadWindow.
Public Property | MinimizeMode | Gets or sets the minimize options for the RadWindow object. SameLocation, MinimizeZone.
Public Property | MinimizeZoneId | Gets or sets the id (ClientID if a runat=server is used) of a html element where the windows will be "docked" when minimized.
Public Property | Modal | Gets or sets a value indicating whether a dialog is modal or not.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | NavigateUrl | Specifies the URL that will originally be loaded in the RadWindow (can be changed on the client).
Public Property | OffsetElementId | Gets or sets the id (ClientID if a runat=server is used) of a html element, whose left and top position will be used as 0,0 of the RadWindow object when it is first shown.
Public Property | OnClientClose | Gets or sets the client function to be called when a window dialog is being closed.
Public Property | OnClientPageLoad | Gets or sets the client function to be called when a page is loaded in a RadWindow dialog.
Public Property | OnClientShow | Get or sets the client function to be called when a window dialog is being opened.
Public Property | OpenerElementId | Gets or sets the id (ClientID if a runat=server is used) of a html element, which, when clicked, will automatically open/show the RadWindow.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadWindowUtils.RadControl)
Public Property | ReloadOnShow | Gets or sets a value indicating whether the page that is loaded in the window should be loaded everytime from the server or will leave the browser default behaviour
Public Property | ShowContentDuringLoad | Gets or sets a value indicating whether the page that is loaded in the window should be shown during the loading process, or when it has finished loading.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | (Inherited from Telerik.RadWindowUtils.RadSkinnableControl)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | (Inherited from Telerik.RadWindowUtils.RadSkinnableControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Title | Gets or sets the RadWindow title (can be changed on the client)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Top | Gets or sets the vertical distance from the browser top.
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadWindowUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | VisibleOnPageLoad | Gets or sets a value indicating whether the window will open automatically when the aspx page is loaded on the client.
Public Property | VisibleStatusbar | Gets or sets a value indicating whether the window has a visible status bar or not.
Public Property | VisibleTitlebar | Gets or sets a value indicating whether the window has a titlebar visible.
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadWindowBase Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadWindowBase Class Properties

RadWindowBase Class Properties
[image]
Telerik.WebControls Namespace : RadWindowBase Class

For a list of all members of this type, see RadWindowBase members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Behavior | Gets or sets a value indicating the behavior of this object - if can be resized, has expand/collapse commands, closed command, etc.
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientCallBackFunction | Gets or sets the client callback function that will be called when a window dialog is being closed.
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DestroyOnClose | Gets or sets a value indicating whether the window will be made inaccessible once it is closed.
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | IconUrl | Gets or sets the url of the icon in the upper left corner of the RadWindow titlebar.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitialBehavior | Gets or sets a value indicating the initial behavior of this object - most useful to specify an initially minimized, maximized or pinned window.
Public Property | Left | Gets or sets the horizontal offset from the browser left side.
Public Property | MinimizeIconUrl | Gets or sets the url of the minimized icon of the RadWindow.
Public Property | MinimizeMode | Gets or sets the minimize options for the RadWindow object. SameLocation, MinimizeZone.
Public Property | MinimizeZoneId | Gets or sets the id (ClientID if a runat=server is used) of a html element where the windows will be "docked" when minimized.
Public Property | Modal | Gets or sets a value indicating whether a dialog is modal or not.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | NavigateUrl | Specifies the URL that will originally be loaded in the RadWindow (can be changed on the client).
Public Property | OffsetElementId | Gets or sets the id (ClientID if a runat=server is used) of a html element, whose left and top position will be used as 0,0 of the RadWindow object when it is first shown.
Public Property | OnClientClose | Gets or sets the client function to be called when a window dialog is being closed.
Public Property | OnClientPageLoad | Gets or sets the client function to be called when a page is loaded in a RadWindow dialog.
Public Property | OnClientShow | Get or sets the client function to be called when a window dialog is being opened.
Public Property | OpenerElementId | Gets or sets the id (ClientID if a runat=server is used) of a html element, which, when clicked, will automatically open/show the RadWindow.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadWindowUtils.RadControl)
Public Property | ReloadOnShow | Gets or sets a value indicating whether the page that is loaded in the window should be loaded everytime from the server or will leave the browser default behaviour
Public Property | ShowContentDuringLoad | Gets or sets a value indicating whether the page that is loaded in the window should be shown during the loading process, or when it has finished loading.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | (Inherited from Telerik.RadWindowUtils.RadSkinnableControl)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | (Inherited from Telerik.RadWindowUtils.RadSkinnableControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Title | Gets or sets the RadWindow title (can be changed on the client)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Top | Gets or sets the vertical distance from the browser top.
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadWindowUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | VisibleOnPageLoad | Gets or sets a value indicating whether the window will open automatically when the aspx page is loaded on the client.
Public Property | VisibleStatusbar | Gets or sets a value indicating whether the window has a visible status bar or not.
Public Property | VisibleTitlebar | Gets or sets a value indicating whether the window has a titlebar visible.
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

RadWindowBase Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


Behavior Property

Behavior Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : Behavior Property

Gets or sets a value indicating the behavior of this object - if can be resized, has expand/collapse commands, closed command, etc.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property Behavior As RadWindowBehaviorFlags
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As RadWindowBehaviorFlags

instance.Behavior = value

value = instance.Behavior
C#
public RadWindowBehaviorFlags Behavior {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


ClientCallBackFunction Property

ClientCallBackFunction Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : ClientCallBackFunction Property

Gets or sets the client callback function that will be called when a window dialog is being closed.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientCallBackFunction As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.ClientCallBackFunction = value

value = instance.ClientCallBackFunction
C#
public string ClientCallBackFunction {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


DestroyOnClose Property

DestroyOnClose Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : DestroyOnClose Property

Gets or sets a value indicating whether the window will be made inaccessible once it is closed.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property DestroyOnClose As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As Boolean

instance.DestroyOnClose = value

value = instance.DestroyOnClose
C#
public bool DestroyOnClose {get; set;}

Return Value

The default value is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


IconUrl Property

IconUrl Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : IconUrl Property

Gets or sets the url of the icon in the upper left corner of the RadWindow titlebar.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property IconUrl As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.IconUrl = value

value = instance.IconUrl
C#
public string IconUrl {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


InitialBehavior Property

InitialBehavior Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : InitialBehavior Property

Gets or sets a value indicating the initial behavior of this object - most useful to specify an initially minimized, maximized or pinned window.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property InitialBehavior As RadWindowBehaviorFlags
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As RadWindowBehaviorFlags

instance.InitialBehavior = value

value = instance.InitialBehavior
C#
public RadWindowBehaviorFlags InitialBehavior {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


Left Property

Left Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : Left Property

Gets or sets the horizontal offset from the browser left side.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As Unit
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As Unit

instance.Left = value

value = instance.Left
C#
public Unit Left {get; set;}

Return Value

The default value is 0.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


MinimizeIconUrl Property

MinimizeIconUrl Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : MinimizeIconUrl Property

Gets or sets the url of the minimized icon of the RadWindow.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property MinimizeIconUrl As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.MinimizeIconUrl = value

value = instance.MinimizeIconUrl
C#
public string MinimizeIconUrl {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


MinimizeMode Property

MinimizeMode Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : MinimizeMode Property

Gets or sets the minimize options for the RadWindow object. SameLocation, MinimizeZone.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property MinimizeMode As RadWindowMinimizeModes
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As RadWindowMinimizeModes

instance.MinimizeMode = value

value = instance.MinimizeMode
C#
public RadWindowMinimizeModes MinimizeMode {get; set;}

Return Value

The default value is not set. Other possible values are the SameLocation or MinimizeZone which are members of
RadWindowMinimizeModes Enumeration.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


MinimizeZoneId Property

MinimizeZoneId Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : MinimizeZoneId Property

Gets or sets the id (ClientID if a runat=server is used) of a html element where the windows will be "docked" when minimized.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property MinimizeZoneId As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.MinimizeZoneId = value

value = instance.MinimizeZoneId
C#
public string MinimizeZoneId {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


Modal Property

Modal Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : Modal Property

Gets or sets a value indicating whether a dialog is modal or not.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property Modal As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As Boolean

instance.Modal = value

value = instance.Modal
C#
public bool Modal {get; set;}

Return Value

The default value is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


NavigateUrl Property

NavigateUrl Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : NavigateUrl Property

Specifies the URL that will originally be loaded in the RadWindow (can be changed on the client).

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property NavigateUrl As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.NavigateUrl = value

value = instance.NavigateUrl
C#
public string NavigateUrl {get; set;}

Return Value

The default is Default.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


OffsetElementId Property

OffsetElementId Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : OffsetElementId Property

Gets or sets the id (ClientID if a runat=server is used) of a html element, whose left and top position will be used as 0,0 of the RadWindow object when it is first shown.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property OffsetElementId As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.OffsetElementId = value

value = instance.OffsetElementId
C#
public string OffsetElementId {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


OnClientClose Property

OnClientClose Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : OnClientClose Property

Gets or sets the client function to be called when a window dialog is being closed.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientClose As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.OnClientClose = value

value = instance.OnClientClose
C#
public string OnClientClose {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


OnClientPageLoad Property

OnClientPageLoad Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : OnClientPageLoad Property

Gets or sets the client function to be called when a page is loaded in a RadWindow dialog.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientPageLoad As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.OnClientPageLoad = value

value = instance.OnClientPageLoad
C#
public string OnClientPageLoad {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


OnClientShow Property

OnClientShow Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : OnClientShow Property

Get or sets the client function to be called when a window dialog is being opened.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientShow As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.OnClientShow = value

value = instance.OnClientShow
C#
public string OnClientShow {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


OpenerElementId Property

OpenerElementId Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : OpenerElementId Property

Gets or sets the id (ClientID if a runat=server is used) of a html element, which, when clicked, will automatically open/show the RadWindow.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property OpenerElementId As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.OpenerElementId = value

value = instance.OpenerElementId
C#
public string OpenerElementId {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


ReloadOnShow Property

ReloadOnShow Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : ReloadOnShow Property

Gets or sets a value indicating whether the page that is loaded in the window should be loaded everytime from the server or will leave the browser default behaviour

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property ReloadOnShow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As Boolean

instance.ReloadOnShow = value

value = instance.ReloadOnShow
C#
public bool ReloadOnShow {get; set;}

Return Value

The default value is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


ShowContentDuringLoad Property

ShowContentDuringLoad Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : ShowContentDuringLoad Property

Gets or sets a value indicating whether the page that is loaded in the window should be shown during the loading process, or when it has finished loading.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowContentDuringLoad As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As Boolean

instance.ShowContentDuringLoad = value

value = instance.ShowContentDuringLoad
C#
public bool ShowContentDuringLoad {get; set;}

Return Value

The default value is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


Title Property

Title Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : Title Property

Gets or sets the RadWindow title (can be changed on the client)

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}

Return Value

The default is Default.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


Top Property

Top Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : Top Property

Gets or sets the vertical distance from the browser top.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property Top As Unit
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As Unit

instance.Top = value

value = instance.Top
C#
public Unit Top {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


VisibleOnPageLoad Property

VisibleOnPageLoad Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : VisibleOnPageLoad Property

Gets or sets a value indicating whether the window will open automatically when the aspx page is loaded on the client.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property VisibleOnPageLoad As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As Boolean

instance.VisibleOnPageLoad = value

value = instance.VisibleOnPageLoad
C#
public bool VisibleOnPageLoad {get; set;}

Return Value

The default value is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


VisibleStatusbar Property

VisibleStatusbar Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : VisibleStatusbar Property

Gets or sets a value indicating whether the window has a visible status bar or not.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property VisibleStatusbar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As Boolean

instance.VisibleStatusbar = value

value = instance.VisibleStatusbar
C#
public bool VisibleStatusbar {get; set;}

Return Value

The default value is true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


VisibleTitlebar Property

VisibleTitlebar Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : VisibleTitlebar Property

Gets or sets a value indicating whether the window has a titlebar visible.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property VisibleTitlebar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As Boolean

instance.VisibleTitlebar = value

value = instance.VisibleTitlebar
C#
public bool VisibleTitlebar {get; set;}

Return Value

The default value is true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


RadWindowManager Class

RadWindowManager Class
See Also Members
[image]
Telerik.WebControls Namespace : RadWindowManager Class

Object Model

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Class RadWindowManager
   Inherits RadWindowBase
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
C#
public class RadWindowManager : RadWindowBase

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadWindowUtils.RadControl
Telerik.RadWindowUtils.RadSkinnableControl
Telerik.WebControls.RadWindowBase
Telerik.WebControls.RadWindowManager

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadWindow (in RadWindow.dll)

See Also

Reference

RadWindowManager Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadWindowManager Class Members

RadWindowManager Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadWindowManager Class

The following tables list the members exposed by RadWindowManager.

Public Constructors

 | Name | Description
Public Constructor | RadWindowManager Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AlertTemplate | This property allows to specify the HTML for the alert popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Behavior | Gets or sets a value indicating the behavior of this object - if can be resized, has expand/collapse commands, closed command, etc. (Inherited from RadWindowBase)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientCallBackFunction | Gets or sets the client callback function that will be called when a window dialog is being closed. (Inherited from RadWindowBase)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ConfirmTemplate | This property allows to specify the HTML for the confirm popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DestroyOnClose | Gets or sets a value indicating whether the window will be made inaccessible once it is closed. (Inherited from RadWindowBase)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableStandardPopups | Gets or sets a value indicating whether RadWindow versions of the standard the browser popups (alert, prompt and confirm) will be sent to the client (optimizes rendering size if they will not be used).
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | IconUrl | Gets or sets the url of the icon in the upper left corner of the RadWindow titlebar. (Inherited from RadWindowBase)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitialBehavior | Gets or sets a value indicating the initial behavior of this object - most useful to specify an initially minimized, maximized or pinned window. (Inherited from RadWindowBase)
Public Property | Language | Gets or sets the localization (language) to be used for a RadWindow.
Public Property | Left | Gets or sets the horizontal offset from the browser left side. (Inherited from RadWindowBase)
Public Property | MinimizeIconUrl | Gets or sets the url of the minimized icon of the RadWindow. (Inherited from RadWindowBase)
Public Property | MinimizeMode | Gets or sets the minimize options for the RadWindow object. SameLocation, MinimizeZone. (Inherited from RadWindowBase)
Public Property | MinimizeTemplate | This property allows to specify the HTML for the minimize popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.
Public Property | MinimizeZoneId | Gets or sets the id (ClientID if a runat=server is used) of a html element where the windows will be "docked" when minimized. (Inherited from RadWindowBase)
Public Property | Modal | Gets or sets a value indicating whether a dialog is modal or not. (Inherited from RadWindowBase)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | NavigateUrl | Specifies the URL that will originally be loaded in the RadWindow (can be changed on the client). (Inherited from RadWindowBase)
Public Property | OffsetElementId | Gets or sets the id (ClientID if a runat=server is used) of a html element, whose left and top position will be used as 0,0 of the RadWindow object when it is first shown. (Inherited from RadWindowBase)
Public Property | OnClientClose | Gets or sets the client function to be called when a window dialog is being closed. (Inherited from RadWindowBase)
Public Property | OnClientPageLoad | Gets or sets the client function to be called when a page is loaded in a RadWindow dialog. (Inherited from RadWindowBase)
Public Property | OnClientShow | Get or sets the client function to be called when a window dialog is being opened. (Inherited from RadWindowBase)
Public Property | OpenerElementId | Gets or sets the id (ClientID if a runat=server is used) of a html element, which, when clicked, will automatically open/show the RadWindow. (Inherited from RadWindowBase)
Public Property | Overlay | Gets or sets a value indicating whether on IE a transparent IFrame will be set behind each client window, so as to avoid dropdowns and list elements on the page to 'show through' the window's titlebar.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | PreserveClientState | Gets or sets a value indicating whether window objects' state (size, location, behavior) will be persisted in a client cookie to restore state over page postbacks.
Public Property | PromptTemplate | This property allows to specify the HTML for the prompt popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.
Public Property | RadControlsDir | (Inherited from Telerik.RadWindowUtils.RadControl)
Public Property | ReloadOnShow | Gets or sets a value indicating whether the page that is loaded in the window should be loaded everytime from the server or will leave the browser default behaviour (Inherited from RadWindowBase)
Public Property | Shortcuts | This property is used to allow associating keyboard shortcuts with RadWindowManager client commands.
Public Property | ShowContentDuringLoad | Gets or sets a value indicating whether the page that is loaded in the window should be shown during the loading process, or when it has finished loading. (Inherited from RadWindowBase)
Public Property | SingleNonMinimizedWindow | Gets or sets a value indicating whether the window manager allows only a single active non-minimized window and all other windows are automatically minimized.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | Overridden. Gets or sets the name of the skin used.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | (Inherited from Telerik.RadWindowUtils.RadSkinnableControl)
Public Property | SplashTemplate | This property allows to specify the HTML for the splash popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Title | Gets or sets the RadWindow title (can be changed on the client) (Inherited from RadWindowBase)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Top | Gets or sets the vertical distance from the browser top. (Inherited from RadWindowBase)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseClassicWindows | Gets or sets a value indicating whether default browser windows should be used, instead of the RadWindow object on the client
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadWindowUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | VisibleOnPageLoad | Gets or sets a value indicating whether the window will open automatically when the aspx page is loaded on the client. (Inherited from RadWindowBase)
Public Property | VisibleStatusbar | Gets or sets a value indicating whether the window has a visible status bar or not. (Inherited from RadWindowBase)
Public Property | VisibleTitlebar | Gets or sets a value indicating whether the window has a titlebar visible. (Inherited from RadWindowBase)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Windows |
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadWindowManager Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadWindowManager Constructor

RadWindowManager Constructor
[image]
Telerik.WebControls Namespace > RadWindowManager Class : RadWindowManager Constructor

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager()
C#
public RadWindowManager()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager()
C#
public RadWindowManager()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


RadWindowManager Class Properties

RadWindowManager Class Properties
[image]
Telerik.WebControls Namespace : RadWindowManager Class

For a list of all members of this type, see RadWindowManager members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AlertTemplate | This property allows to specify the HTML for the alert popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Behavior | Gets or sets a value indicating the behavior of this object - if can be resized, has expand/collapse commands, closed command, etc. (Inherited from RadWindowBase)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientCallBackFunction | Gets or sets the client callback function that will be called when a window dialog is being closed. (Inherited from RadWindowBase)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ConfirmTemplate | This property allows to specify the HTML for the confirm popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DestroyOnClose | Gets or sets a value indicating whether the window will be made inaccessible once it is closed. (Inherited from RadWindowBase)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableStandardPopups | Gets or sets a value indicating whether RadWindow versions of the standard the browser popups (alert, prompt and confirm) will be sent to the client (optimizes rendering size if they will not be used).
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | IconUrl | Gets or sets the url of the icon in the upper left corner of the RadWindow titlebar. (Inherited from RadWindowBase)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitialBehavior | Gets or sets a value indicating the initial behavior of this object - most useful to specify an initially minimized, maximized or pinned window. (Inherited from RadWindowBase)
Public Property | Language | Gets or sets the localization (language) to be used for a RadWindow.
Public Property | Left | Gets or sets the horizontal offset from the browser left side. (Inherited from RadWindowBase)
Public Property | MinimizeIconUrl | Gets or sets the url of the minimized icon of the RadWindow. (Inherited from RadWindowBase)
Public Property | MinimizeMode | Gets or sets the minimize options for the RadWindow object. SameLocation, MinimizeZone. (Inherited from RadWindowBase)
Public Property | MinimizeTemplate | This property allows to specify the HTML for the minimize popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.
Public Property | MinimizeZoneId | Gets or sets the id (ClientID if a runat=server is used) of a html element where the windows will be "docked" when minimized. (Inherited from RadWindowBase)
Public Property | Modal | Gets or sets a value indicating whether a dialog is modal or not. (Inherited from RadWindowBase)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | NavigateUrl | Specifies the URL that will originally be loaded in the RadWindow (can be changed on the client). (Inherited from RadWindowBase)
Public Property | OffsetElementId | Gets or sets the id (ClientID if a runat=server is used) of a html element, whose left and top position will be used as 0,0 of the RadWindow object when it is first shown. (Inherited from RadWindowBase)
Public Property | OnClientClose | Gets or sets the client function to be called when a window dialog is being closed. (Inherited from RadWindowBase)
Public Property | OnClientPageLoad | Gets or sets the client function to be called when a page is loaded in a RadWindow dialog. (Inherited from RadWindowBase)
Public Property | OnClientShow | Get or sets the client function to be called when a window dialog is being opened. (Inherited from RadWindowBase)
Public Property | OpenerElementId | Gets or sets the id (ClientID if a runat=server is used) of a html element, which, when clicked, will automatically open/show the RadWindow. (Inherited from RadWindowBase)
Public Property | Overlay | Gets or sets a value indicating whether on IE a transparent IFrame will be set behind each client window, so as to avoid dropdowns and list elements on the page to 'show through' the window's titlebar.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | PreserveClientState | Gets or sets a value indicating whether window objects' state (size, location, behavior) will be persisted in a client cookie to restore state over page postbacks.
Public Property | PromptTemplate | This property allows to specify the HTML for the prompt popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.
Public Property | RadControlsDir | (Inherited from Telerik.RadWindowUtils.RadControl)
Public Property | ReloadOnShow | Gets or sets a value indicating whether the page that is loaded in the window should be loaded everytime from the server or will leave the browser default behaviour (Inherited from RadWindowBase)
Public Property | Shortcuts | This property is used to allow associating keyboard shortcuts with RadWindowManager client commands.
Public Property | ShowContentDuringLoad | Gets or sets a value indicating whether the page that is loaded in the window should be shown during the loading process, or when it has finished loading. (Inherited from RadWindowBase)
Public Property | SingleNonMinimizedWindow | Gets or sets a value indicating whether the window manager allows only a single active non-minimized window and all other windows are automatically minimized.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | Overridden. Gets or sets the name of the skin used.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | (Inherited from Telerik.RadWindowUtils.RadSkinnableControl)
Public Property | SplashTemplate | This property allows to specify the HTML for the splash popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Title | Gets or sets the RadWindow title (can be changed on the client) (Inherited from RadWindowBase)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Top | Gets or sets the vertical distance from the browser top. (Inherited from RadWindowBase)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseClassicWindows | Gets or sets a value indicating whether default browser windows should be used, instead of the RadWindow object on the client
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadWindowUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | VisibleOnPageLoad | Gets or sets a value indicating whether the window will open automatically when the aspx page is loaded on the client. (Inherited from RadWindowBase)
Public Property | VisibleStatusbar | Gets or sets a value indicating whether the window has a visible status bar or not. (Inherited from RadWindowBase)
Public Property | VisibleTitlebar | Gets or sets a value indicating whether the window has a titlebar visible. (Inherited from RadWindowBase)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Windows |
Top

See Also

Reference

RadWindowManager Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


AlertTemplate Property

AlertTemplate Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : AlertTemplate Property

This property allows to specify the HTML for the alert popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property AlertTemplate As ITemplate
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As ITemplate

instance.AlertTemplate = value

value = instance.AlertTemplate
C#
public ITemplate AlertTemplate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


ConfirmTemplate Property

ConfirmTemplate Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : ConfirmTemplate Property

This property allows to specify the HTML for the confirm popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property ConfirmTemplate As ITemplate
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As ITemplate

instance.ConfirmTemplate = value

value = instance.ConfirmTemplate
C#
public ITemplate ConfirmTemplate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


EnableStandardPopups Property

EnableStandardPopups Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : EnableStandardPopups Property

Gets or sets a value indicating whether RadWindow versions of the standard the browser popups (alert, prompt and confirm) will be sent to the client (optimizes rendering size if they will not be used).

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableStandardPopups As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As Boolean

instance.EnableStandardPopups = value

value = instance.EnableStandardPopups
C#
public bool EnableStandardPopups {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


Language Property

Language Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : Language Property

Gets or sets the localization (language) to be used for a RadWindow.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property Language As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As String

instance.Language = value

value = instance.Language
C#
public string Language {get; set;}

Return Value

The default is en-US

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


MinimizeTemplate Property

MinimizeTemplate Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : MinimizeTemplate Property

This property allows to specify the HTML for the minimize popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property MinimizeTemplate As ITemplate
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As ITemplate

instance.MinimizeTemplate = value

value = instance.MinimizeTemplate
C#
public ITemplate MinimizeTemplate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


Overlay Property

Overlay Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : Overlay Property

Gets or sets a value indicating whether on IE a transparent IFrame will be set behind each client window, so as to avoid dropdowns and list elements on the page to 'show through' the window's titlebar.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property Overlay As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As Boolean

instance.Overlay = value

value = instance.Overlay
C#
public bool Overlay {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


PreserveClientState Property

PreserveClientState Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : PreserveClientState Property

Gets or sets a value indicating whether window objects' state (size, location, behavior) will be persisted in a client cookie to restore state over page postbacks.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property PreserveClientState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As Boolean

instance.PreserveClientState = value

value = instance.PreserveClientState
C#
public bool PreserveClientState {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


PromptTemplate Property

PromptTemplate Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : PromptTemplate Property

This property allows to specify the HTML for the prompt popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property PromptTemplate As ITemplate
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As ITemplate

instance.PromptTemplate = value

value = instance.PromptTemplate
C#
public ITemplate PromptTemplate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


Shortcuts Property

Shortcuts Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : Shortcuts Property

This property is used to allow associating keyboard shortcuts with RadWindowManager client commands.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Shortcuts As WindowShortcutCollection
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As WindowShortcutCollection

value = instance.Shortcuts
C#
public WindowShortcutCollection Shortcuts {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


SingleNonMinimizedWindow Property

SingleNonMinimizedWindow Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : SingleNonMinimizedWindow Property

Gets or sets a value indicating whether the window manager allows only a single active non-minimized window and all other windows are automatically minimized.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property SingleNonMinimizedWindow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As Boolean

instance.SingleNonMinimizedWindow = value

value = instance.SingleNonMinimizedWindow
C#
public bool SingleNonMinimizedWindow {get; set;}

Return Value

The default valie is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


Skin Property

Skin Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : Skin Property

Gets or sets the name of the skin used.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Skin As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As String

instance.Skin = value

value = instance.Skin
C#
public override string Skin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


SplashTemplate Property

SplashTemplate Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : SplashTemplate Property

This property allows to specify the HTML for the splash popup, which will override the alerttemplate defined in the RadControls/Window/Skins/CURRENT_SKIN/CoreTemplate.xml file.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property SplashTemplate As ITemplate
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As ITemplate

instance.SplashTemplate = value

value = instance.SplashTemplate
C#
public ITemplate SplashTemplate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


UseClassicWindows Property

UseClassicWindows Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : UseClassicWindows Property

Gets or sets a value indicating whether default browser windows should be used, instead of the RadWindow object on the client

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property UseClassicWindows As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As Boolean

instance.UseClassicWindows = value

value = instance.UseClassicWindows
C#
public bool UseClassicWindows {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


Windows Property

Windows Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : Windows Property

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Windows As WindowCollection
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As WindowCollection

value = instance.Windows
C#
public virtual WindowCollection Windows {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


WindowCollection Class

WindowCollection Class
See Also Members
[image]
Telerik.WebControls Namespace : WindowCollection Class

Summary description for WindowCollection.

Object Model

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Class WindowCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
C#
public class WindowCollection : CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.WebControls.WindowCollection

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadWindow (in RadWindow.dll)

See Also

Reference

WindowCollection Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


WindowCollection Class Members

WindowCollection Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : WindowCollection Class

The following tables list the members exposed by WindowCollection.

Public Constructors

 | Name | Description
Public Constructor | WindowCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns a RadWindow object depending on the passed index. Only integer and string indexes are valid.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a RadWindow object to the collection of Windows.
Public Method | AddRange | Adds the elements of a RadWindow array to the end of the MenuGroup.
Public Method | Clear | Removes all RadWindow objects in the collection of Windows.
Public Method | Clone |
Public Method | CloneInner |
Public Method | Contains | Checks whether a specific RadWindow object is in the collection of Windows.
Public Method | CopyTo | Overloaded.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Returns a zero based index of a RadWindow object depending on the passed index. Only int and string indexes are valid.
Public Method | Insert | Adds a Tab object in the collection at the specified index.
Public Method | Remove | Deletes a RadWindow object from the collection.
Public Method | RemoveAt | Deletes the RadWindow object from the collection at the specified index.
Public Method | RemoveRange | Removes the specified range of elements from the MenuGroup.
Public Method | Reverse | Reverses the order of the elements in the MenuGroup or a portion of it.
Public Method | Sort | Overloaded. Sorts the elements in the MenuGroup or a portion of it.
Public Method | ToArray | Copies the elements of the MenuGroup to a new Array of RadWindow elements.
Top

See Also

Reference

WindowCollection Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


WindowCollection Constructor

WindowCollection Constructor
[image]
Telerik.WebControls Namespace > WindowCollection Class : WindowCollection Constructor

oManager

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal oManager As RadWindowManager _
)
Visual Basic (Usage) Copy Code
Dim oManager As RadWindowManager

Dim instance As WindowCollection(oManager)
C#
public WindowCollection(
   RadWindowManager oManager
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal oManager As RadWindowManager _
)
Visual Basic (Usage) Copy Code
Dim oManager As RadWindowManager

Dim instance As WindowCollection(oManager)
C#
public WindowCollection(
   RadWindowManager oManager
)

Parameters

oManager

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


WindowCollection Class Methods

WindowCollection Class Methods
[image]
Telerik.WebControls Namespace : WindowCollection Class

For a list of all members of this type, see WindowCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a RadWindow object to the collection of Windows.
Public Method | AddRange | Adds the elements of a RadWindow array to the end of the MenuGroup.
Public Method | Clear | Removes all RadWindow objects in the collection of Windows.
Public Method | Clone |
Public Method | CloneInner |
Public Method | Contains | Checks whether a specific RadWindow object is in the collection of Windows.
Public Method | CopyTo | Overloaded.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Returns a zero based index of a RadWindow object depending on the passed index. Only int and string indexes are valid.
Public Method | Insert | Adds a Tab object in the collection at the specified index.
Public Method | Remove | Deletes a RadWindow object from the collection.
Public Method | RemoveAt | Deletes the RadWindow object from the collection at the specified index.
Public Method | RemoveRange | Removes the specified range of elements from the MenuGroup.
Public Method | Reverse | Reverses the order of the elements in the MenuGroup or a portion of it.
Public Method | Sort | Overloaded. Sorts the elements in the MenuGroup or a portion of it.
Public Method | ToArray | Copies the elements of the MenuGroup to a new Array of RadWindow elements.
Top

See Also

Reference

WindowCollection Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


Add Method

Add Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : Add Method

inputItem
The RadWindow object to add to the collection.
Adds a RadWindow object to the collection of Windows.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Add( _
   ByVal inputItem As RadWindow _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim inputItem As RadWindow
Dim value As Integer

value = instance.Add(inputItem)
C#
public virtual int Add(
   RadWindow inputItem
)

Parameters

inputItem
The RadWindow object to add to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


AddRange Method

AddRange Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : AddRange Method

inputItems
Adds the elements of a RadWindow array to the end of the MenuGroup.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddRange( _
   ByVal inputItems() As RadWindow _
)
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim inputItems() As RadWindow

instance.AddRange(inputItems)
C#
public virtual void AddRange(
   RadWindow[] inputItems
)

Parameters

inputItems

Exceptions

Exception | Description
ArgumentNullException | array is a null reference.
NotSupportedException | The MenuGroup is read-only. -or- The MenuGroup has a fixed size. -or- The MenuGroup already contains one or more elements in the specified array, and the MenuGroup ensures that all elements are unique.

Remarks

Please refer to AddRange for details.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


Clear Method

Clear Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : Clear Method

Removes all RadWindow objects in the collection of Windows.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection

instance.Clear()
C#
public void Clear()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


Clone Method

Clone Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : Clone Method

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As WindowCollection
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim value As WindowCollection

value = instance.Clone()
C#
public virtual WindowCollection Clone()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


CloneInner Method

CloneInner Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : CloneInner Method

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function CloneInner() As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim value As ArrayList

value = instance.CloneInner()
C#
public virtual ArrayList CloneInner()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


Contains Method

Contains Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : Contains Method

inputItem
The RadWindow object to search.
Checks whether a specific RadWindow object is in the collection of Windows.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Contains( _
   ByVal inputItem As RadWindow _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim inputItem As RadWindow
Dim value As Boolean

value = instance.Contains(inputItem)
C#
public virtual bool Contains(
   RadWindow inputItem
)

Parameters

inputItem
The RadWindow object to search.

Return Value

True if the RadWindow is found, false otherwise.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


CopyTo Method

CopyTo Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : CopyTo Method

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Overload List

Overload | Description
CopyTo(RadWindow[],Int32) |
CopyTo(RadWindow[]) |

Overload List

Overload | Description
CopyTo(RadWindow[],Int32) |
CopyTo(RadWindow[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


CopyTo(RadWindow[],Int32) Method

CopyTo(RadWindow[],Int32) Method
[image]
Telerik.WebControls Namespace > WindowCollection Class > CopyTo Method : CopyTo(RadWindow[],Int32) Method

inputArray
startCopyIndex

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Sub CopyTo( _
   ByVal inputArray() As RadWindow, _
   ByVal startCopyIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim inputArray() As RadWindow
Dim startCopyIndex As Integer

instance.CopyTo(inputArray, startCopyIndex)
C#
public virtual void CopyTo(
   RadWindow[] inputArray,
   int startCopyIndex
)

Parameters

inputArray
startCopyIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


CopyTo(RadWindow[]) Method

CopyTo(RadWindow[]) Method
[image]
Telerik.WebControls Namespace > WindowCollection Class > CopyTo Method : CopyTo(RadWindow[]) Method

inputArray

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Sub CopyTo( _
   ByVal inputArray() As RadWindow _
)
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim inputArray() As RadWindow

instance.CopyTo(inputArray)
C#
public virtual void CopyTo(
   RadWindow[] inputArray
)

Parameters

inputArray

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


IndexOf Method

IndexOf Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : IndexOf Method

inputItem
The zero-based index or the ID of the searched RadWindow object.
Returns a zero based index of a RadWindow object depending on the passed index. Only int and string indexes are valid.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IndexOf( _
   ByVal inputItem As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim inputItem As Object
Dim value As Integer

value = instance.IndexOf(inputItem)
C#
public virtual int IndexOf(
   object inputItem
)

Parameters

inputItem
The zero-based index or the ID of the searched RadWindow object.

Return Value

A zero based index of the RadWindow object in the collection, or -1 if the RadWindow object is not found.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


Insert Method

Insert Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : Insert Method

insertIndex
The index after which the RadWindow object is inserted.
inputItem
The RadWindow object to insert.
Adds a Tab object in the collection at the specified index.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Insert( _
   ByVal insertIndex As Integer, _
   ByVal inputItem As RadWindow _
)
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim insertIndex As Integer
Dim inputItem As RadWindow

instance.Insert(insertIndex, inputItem)
C#
public virtual void Insert(
   int insertIndex,
   RadWindow inputItem
)

Parameters

insertIndex
The index after which the RadWindow object is inserted.
inputItem
The RadWindow object to insert.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


Remove Method

Remove Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : Remove Method

inputItem
The RadWindow object to remove.
Deletes a RadWindow object from the collection.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Remove( _
   ByVal inputItem As RadWindow _
)
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim inputItem As RadWindow

instance.Remove(inputItem)
C#
public virtual void Remove(
   RadWindow inputItem
)

Parameters

inputItem
The RadWindow object to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


RemoveAt Method

RemoveAt Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : RemoveAt Method

index
The index in collection at which the RadWindow object will be deleted.
Deletes the RadWindow object from the collection at the specified index.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)

Parameters

index
The index in collection at which the RadWindow object will be deleted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


RemoveRange Method

RemoveRange Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : RemoveRange Method

startIndex
itemCount
Removes the specified range of elements from the MenuGroup.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveRange( _
   ByVal startIndex As Integer, _
   ByVal itemCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim startIndex As Integer
Dim itemCount As Integer

instance.RemoveRange(startIndex, itemCount)
C#
public virtual void RemoveRange(
   int startIndex,
   int itemCount
)

Parameters

startIndex
itemCount

Exceptions

Exception | Description
ArgumentException | index and Count do not denote a valid range of elements in the MenuGroup.
ArgumentOutOfRangeException | index is less than zero. -or- Count is less than zero.
NotSupportedException | The MenuGroup is read-only. -or- The MenuGroup has a fixed size.

Remarks

Please refer to RemoveRange for details.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


Reverse Method

Reverse Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : Reverse Method

Reverses the order of the elements in the MenuGroup or a portion of it.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reverse()
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection

instance.Reverse()
C#
public virtual void Reverse()

Exceptions

Exception | Description
NotSupportedException | The MenuGroup is read-only.

Remarks

Please refer to Reverse for details.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


Sort Method

Sort Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : Sort Method

Sorts the elements in the MenuGroup or a portion of it.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Overload List

Overload | Description
Sort() | Sorts the elements in the entire MenuGroup using the IComparable implementation of each element.
Sort(IComparer) | Sorts the elements in the entire MenuGroup using the specified IComparer interface.
Sort(Int32,Int32,IComparer) | Sorts the elements in the specified range using the specified IComparer interface.

Overload List

Overload | Description
Sort() | Sorts the elements in the entire MenuGroup using the IComparable implementation of each element.
Sort(IComparer) | Sorts the elements in the entire MenuGroup using the specified IComparer interface.
Sort(Int32,Int32,IComparer) | Sorts the elements in the specified range using the specified IComparer interface.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


Sort() Method

Sort() Method
[image]
Telerik.WebControls Namespace > WindowCollection Class > Sort Method : Sort() Method

Sorts the elements in the entire MenuGroup using the IComparable implementation of each element.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Sub Sort()
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection

instance.Sort()
C#
public virtual void Sort()

Exceptions

Exception | Description
NotSupportedException | The MenuGroup is read-only.

Remarks

Please refer to Sort for details.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


Sort(IComparer) Method

Sort(IComparer) Method
[image]
Telerik.WebControls Namespace > WindowCollection Class > Sort Method : Sort(IComparer) Method

itemComparer
Sorts the elements in the entire MenuGroup using the specified IComparer interface.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Sub Sort( _
   ByVal itemComparer As IComparer _
)
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim itemComparer As IComparer

instance.Sort(itemComparer)
C#
public virtual void Sort(
   IComparer itemComparer
)

Parameters

itemComparer

Exceptions

Exception | Description
NotSupportedException | The MenuGroup is read-only.

Remarks

Please refer to Sort for details.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


Sort(Int32,Int32,IComparer) Method

Sort(Int32,Int32,IComparer) Method
[image]
Telerik.WebControls Namespace > WindowCollection Class > Sort Method : Sort(Int32,Int32,IComparer) Method

startIndex
itemCount
itemComparer
Sorts the elements in the specified range using the specified IComparer interface.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Sub Sort( _
   ByVal startIndex As Integer, _
   ByVal itemCount As Integer, _
   ByVal itemComparer As IComparer _
)
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim startIndex As Integer
Dim itemCount As Integer
Dim itemComparer As IComparer

instance.Sort(startIndex, itemCount, itemComparer)
C#
public virtual void Sort(
   int startIndex,
   int itemCount,
   IComparer itemComparer
)

Parameters

startIndex
itemCount
itemComparer

Exceptions

Exception | Description
ArgumentException | index and Count do not denote a valid range of elements in the MenuGroup.
ArgumentOutOfRangeException | index is less than zero. -or- Count is less than zero.
NotSupportedException | The MenuGroup is read-only.

Remarks

Please refer to Sort for details.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


ToArray Method

ToArray Method
[image]
Telerik.WebControls Namespace > WindowCollection Class : ToArray Method

Copies the elements of the MenuGroup to a new Array of RadWindow elements.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ToArray() As RadWindow()
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim value() As RadWindow

value = instance.ToArray()
C#
public virtual RadWindow[] ToArray()

Return Value

A one-dimensional Array of RadWindow elements containing copies of the elements of the MenuGroup.

Remarks

Please refer to ToArray for details.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


WindowCollection Class Properties

WindowCollection Class Properties
[image]
Telerik.WebControls Namespace : WindowCollection Class

For a list of all members of this type, see WindowCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Returns a RadWindow object depending on the passed index. Only integer and string indexes are valid.
Top

See Also

Reference

WindowCollection Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


Item Property

Item Property
[image]
Telerik.WebControls Namespace > WindowCollection Class : Item Property

obj
Returns a RadWindow object depending on the passed index. Only integer and string indexes are valid.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Default Property Item( _
   ByVal obj As Object _
) As RadWindow
Visual Basic (Usage) Copy Code
Dim instance As WindowCollection
Dim obj As Object
Dim value As RadWindow

instance.Item(obj) = value

value = instance.Item(obj)
C#
public virtual RadWindow this[
   object obj
]; {get; set;}

Parameters

obj

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowCollection Class
WindowCollection Members

© 2002-2005, telerik. All Rights Reserved.


WindowShortcut Class

WindowShortcut Class
See Also Members
[image]
Telerik.WebControls Namespace : WindowShortcut Class

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Class WindowShortcut
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcut
C#
public class WindowShortcut

Inheritance Hierarchy

System.Object
Telerik.WebControls.WindowShortcut

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadWindow (in RadWindow.dll)

See Also

Reference

WindowShortcut Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


WindowShortcut Class Members

WindowShortcut Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : WindowShortcut Class

The following tables list the members exposed by WindowShortcut.

Public Constructors

 | Name | Description
Public Constructor | WindowShortcut Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CommandName |
Public Property | Shortcut |
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

WindowShortcut Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


WindowShortcut Constructor

WindowShortcut Constructor
[image]
Telerik.WebControls Namespace > WindowShortcut Class : WindowShortcut Constructor

Overload List

Overload | Description
WindowShortcut Constructor() |
WindowShortcut Constructor(String,String) |

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcut Class
WindowShortcut Members

© 2002-2005, telerik. All Rights Reserved.


WindowShortcut Constructor()

WindowShortcut Constructor()
See Also
[image]
Telerik.WebControls Namespace > WindowShortcut Class > WindowShortcut Constructor : WindowShortcut Constructor()

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcut()
C#
public WindowShortcut()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcut()
C#
public WindowShortcut()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcut Class
WindowShortcut Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


WindowShortcut Constructor(String,String)

WindowShortcut Constructor(String,String)
See Also
[image]
Telerik.WebControls Namespace > WindowShortcut Class > WindowShortcut Constructor : WindowShortcut Constructor(String,String)

commandName
shortcut

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal commandName As String, _
   ByVal shortcut As String _
)
Visual Basic (Usage) Copy Code
Dim commandName As String
Dim shortcut As String

Dim instance As WindowShortcut(commandName, shortcut)
C#
public WindowShortcut(
   string commandName,
   string shortcut
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal commandName As String, _
   ByVal shortcut As String _
)
Visual Basic (Usage) Copy Code
Dim commandName As String
Dim shortcut As String

Dim instance As WindowShortcut(commandName, shortcut)
C#
public WindowShortcut(
   string commandName,
   string shortcut
)

Parameters

commandName
shortcut

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcut Class
WindowShortcut Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


WindowShortcut Class Methods

WindowShortcut Class Methods
[image]
Telerik.WebControls Namespace : WindowShortcut Class

For a list of all members of this type, see WindowShortcut members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

WindowShortcut Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


ToString Method

ToString Method
[image]
Telerik.WebControls Namespace > WindowShortcut Class : ToString Method

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcut
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcut Class
WindowShortcut Members

© 2002-2005, telerik. All Rights Reserved.


WindowShortcut Class Properties

WindowShortcut Class Properties
[image]
Telerik.WebControls Namespace : WindowShortcut Class

For a list of all members of this type, see WindowShortcut members.

Public Properties

 | Name | Description
Public Property | CommandName |
Public Property | Shortcut |
Top

See Also

Reference

WindowShortcut Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


CommandName Property

CommandName Property
[image]
Telerik.WebControls Namespace > WindowShortcut Class : CommandName Property

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property CommandName As String
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcut
Dim value As String

instance.CommandName = value

value = instance.CommandName
C#
public string CommandName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcut Class
WindowShortcut Members

© 2002-2005, telerik. All Rights Reserved.


Shortcut Property

Shortcut Property
[image]
Telerik.WebControls Namespace > WindowShortcut Class : Shortcut Property

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property Shortcut As String
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcut
Dim value As String

instance.Shortcut = value

value = instance.Shortcut
C#
public string Shortcut {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcut Class
WindowShortcut Members

© 2002-2005, telerik. All Rights Reserved.


WindowShortcutCollection Class

WindowShortcutCollection Class
See Also Members
[image]
Telerik.WebControls Namespace : WindowShortcutCollection Class

Object Model

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Class WindowShortcutCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcutCollection
C#
public class WindowShortcutCollection : CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.WebControls.WindowShortcutCollection

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadWindow (in RadWindow.dll)

See Also

Reference

WindowShortcutCollection Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


WindowShortcutCollection Class Members

WindowShortcutCollection Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : WindowShortcutCollection Class

The following tables list the members exposed by WindowShortcutCollection.

Public Constructors

 | Name | Description
Public Constructor | WindowShortcutCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains |
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf |
Public Method | Remove |
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Public Method | ToString | Overridden.
Top

See Also

Reference

WindowShortcutCollection Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


WindowShortcutCollection Constructor

WindowShortcutCollection Constructor
[image]
Telerik.WebControls Namespace > WindowShortcutCollection Class : WindowShortcutCollection Constructor

Overload List

Overload | Description
WindowShortcutCollection Constructor() |
WindowShortcutCollection Constructor(WindowShortcutCollection) |

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcutCollection Class
WindowShortcutCollection Members

© 2002-2005, telerik. All Rights Reserved.


WindowShortcutCollection Constructor()

WindowShortcutCollection Constructor()
See Also
[image]
Telerik.WebControls Namespace > WindowShortcutCollection Class > WindowShortcutCollection Constructor : WindowShortcutCollection Constructor()

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcutCollection()
C#
public WindowShortcutCollection()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcutCollection()
C#
public WindowShortcutCollection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcutCollection Class
WindowShortcutCollection Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


WindowShortcutCollection Constructor(WindowShortcutCollection)

WindowShortcutCollection Constructor(WindowShortcutCollection)
See Also
[image]
Telerik.WebControls Namespace > WindowShortcutCollection Class > WindowShortcutCollection Constructor : WindowShortcutCollection Constructor(WindowShortcutCollection)

coll

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal coll As WindowShortcutCollection _
)
Visual Basic (Usage) Copy Code
Dim coll As WindowShortcutCollection

Dim instance As WindowShortcutCollection(coll)
C#
public WindowShortcutCollection(
   WindowShortcutCollection coll
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal coll As WindowShortcutCollection _
)
Visual Basic (Usage) Copy Code
Dim coll As WindowShortcutCollection

Dim instance As WindowShortcutCollection(coll)
C#
public WindowShortcutCollection(
   WindowShortcutCollection coll
)

Parameters

coll

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcutCollection Class
WindowShortcutCollection Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


WindowShortcutCollection Class Methods

WindowShortcutCollection Class Methods
[image]
Telerik.WebControls Namespace : WindowShortcutCollection Class

For a list of all members of this type, see WindowShortcutCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains |
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf |
Public Method | Remove |
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Public Method | ToString | Overridden.
Top

See Also

Reference

WindowShortcutCollection Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


Add Method

Add Method
[image]
Telerik.WebControls Namespace > WindowShortcutCollection Class : Add Method

windowShortcut

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Add( _
   ByVal windowShortcut As WindowShortcut _
)
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcutCollection
Dim windowShortcut As WindowShortcut

instance.Add(windowShortcut)
C#
public virtual void Add(
   WindowShortcut windowShortcut
)

Parameters

windowShortcut

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcutCollection Class
WindowShortcutCollection Members

© 2002-2005, telerik. All Rights Reserved.


Contains Method

Contains Method
[image]
Telerik.WebControls Namespace > WindowShortcutCollection Class : Contains Method

windowShortcut

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal windowShortcut As WindowShortcut _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcutCollection
Dim windowShortcut As WindowShortcut
Dim value As Boolean

value = instance.Contains(windowShortcut)
C#
public bool Contains(
   WindowShortcut windowShortcut
)

Parameters

windowShortcut

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcutCollection Class
WindowShortcutCollection Members

© 2002-2005, telerik. All Rights Reserved.


IndexOf Method

IndexOf Method
[image]
Telerik.WebControls Namespace > WindowShortcutCollection Class : IndexOf Method

windowShortcut

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal windowShortcut As WindowShortcut _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcutCollection
Dim windowShortcut As WindowShortcut
Dim value As Integer

value = instance.IndexOf(windowShortcut)
C#
public int IndexOf(
   WindowShortcut windowShortcut
)

Parameters

windowShortcut

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcutCollection Class
WindowShortcutCollection Members

© 2002-2005, telerik. All Rights Reserved.


Remove Method

Remove Method
[image]
Telerik.WebControls Namespace > WindowShortcutCollection Class : Remove Method

windowShortcut

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Remove( _
   ByVal windowShortcut As WindowShortcut _
)
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcutCollection
Dim windowShortcut As WindowShortcut

instance.Remove(windowShortcut)
C#
public virtual void Remove(
   WindowShortcut windowShortcut
)

Parameters

windowShortcut

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcutCollection Class
WindowShortcutCollection Members

© 2002-2005, telerik. All Rights Reserved.


ToString Method

ToString Method
[image]
Telerik.WebControls Namespace > WindowShortcutCollection Class : ToString Method

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcutCollection
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcutCollection Class
WindowShortcutCollection Members

© 2002-2005, telerik. All Rights Reserved.


WindowShortcutCollection Class Properties

WindowShortcutCollection Class Properties
[image]
Telerik.WebControls Namespace : WindowShortcutCollection Class

For a list of all members of this type, see WindowShortcutCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item |
Top

See Also

Reference

WindowShortcutCollection Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


Item Property

Item Property
[image]
Telerik.WebControls Namespace > WindowShortcutCollection Class : Item Property

index

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As WindowShortcut
Visual Basic (Usage) Copy Code
Dim instance As WindowShortcutCollection
Dim index As Integer
Dim value As WindowShortcut

instance.Item(index) = value

value = instance.Item(index)
C#
public WindowShortcut this[
   int index
]; {get; set;}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

WindowShortcutCollection Class
WindowShortcutCollection Members

© 2002-2005, telerik. All Rights Reserved.


Ask Technical Questions

Telerik RadWindow v1.9 Send comments on this topic.
Ask Technical Questions

Glossary Item Box

In case you need to contact Telerik with a technical question, please copy the following URL in your browser or click to open the Telerik Client.NET(http://www.telerik.com/Default.aspx?PageId=2069).

© 2002-2008 Telerik. All Rights Reserved.


Caching Client-Side Scripts

Telerik RadWindow v1.9 Send comments on this topic.
Caching Client-Side Scripts

Glossary Item Box

The Telerik RadWindow client-side script (JavaScript) is extracted in an external file, which will be automatically cached by the browser. You don't have to do anything to enable this caching mechanism.

The client-side script is located in the folder "\RadControls\Window\Script\[product_version]". By default the RadControls folder is located in the root of your web-application, but you can relocate it if needed.

© 2002-2008 Telerik. All Rights Reserved.


Glossary

Telerik RadWindow v1.9 Send comments on this topic.
Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

© 2002-2008 Telerik. All Rights Reserved.


Guidelines for Specifying Domain Names.html

Telerik RadWindow v1.9 Send comments on this topic.
Guidelines for Specifying Domain Names.html

Glossary Item Box

1. Use only top-level domain names. The control will work on all other subdomains. Do not enter prefixes like www or http://.

Original domain | Right | Wrong
http://www.mysite.com | mysite.com | www.mysite.com
http://www.mysite.com | mysite.com | http://www.mysite.com
http://mysite.com | mysite.com | http://mysite.com
http://support.mysite.com | mysite.com | support.mysite.com

2. In case of a complex country-specific domain name (like www.mysite.co.uk, www.mysite.org.bg) you need to enter the actual domain name (mysite) followed by the full extension (co.uk).

Original domain | Right
http://www.mysite.co.uk | mysite.co.uk
http://www.mysite.gov.tw | mysite.gov.tw
http://www.support.mysite.biz.nl | mysite.biz.nl

3. Do not enter an IP for the live server (not the development server) in case it has a domain name.

Original domain | Right | Wrong
http://www.mysite.com | mysite.com | 123.123.123.123

© 2002-2008 Telerik. All Rights Reserved.


Guidelines for Specifying Domain Names

Telerik RadWindow v1.9 Send comments on this topic.
Guidelines for Specifying Domain Names

Glossary Item Box

To create a License key you will need to know the IP and domain/machine name by which you plan to access the control, i.e.

http://123.123.123.123/MyApplication/

http://www.mysite.com/MyApplication/

http://MachineName/MyApplication/

If you plan to sue the control on localhost or 127.0.0.1 you do not need keys - the control will work properly, but a copyright message will be displayed occasionally.

The control checks the URL by which it is accessed and compares this URL to the IP and domain name encoded in the license key. If these do not match, a copyright message will be shown.

Entering domain/machine names

Use only top-level domain names. The control will work on all other subdomains. Do not enter prefixes like www or http://

Original URL | Right | Wrong
http://www.mysite.com | mysite.com | www.mysite.com http://www.mysite.com
http://mysite.com | mysite.com | http://mysite.com
http://support.mysite.com | mysite.com | support.mysite.com
http://mydomain/ | mydomain | http://mydomain
http://machinename/ | machinename | http://machinenam

In case of a complex country-specific domain name (like www.mysite.co.uk, www.mysite.org.bg) you need to enter the actual domain name (mysite) followed by the full extension (co.uk):

Original URL | Right | Wrong
http://www.mysite.co.uk | mysite.co.uk | http://www.mysite.co.uk
http://mysite.gov.tw | mysite.gov.tw | http://mysite.gov.tw
http://www.support.mysite.biz.nl | mysite.biz.nl | http://www.support.mysite.biz.nl

If the the domain/machine name is unknown, or if the control will be used on localhost, use localhost in the domain field when creating the keys.

Entering IPs

Use only the top-level IP address. The control will work on all subdomains and ports. Do not enter prefixes like www or http://

Original URL | Right | Wrong
http://123.123.123.123/ | 123.123.123.123 | http://123.123.123.123
http://123.123.123.123:8080/ | 123.123.123.123 | 123.123.123.123:8080 http://123.123.123.123 http:// 123.123.123.123:8080

Do not enter an IP for the live server (not the development server) in case it has a domain name.

Original URL | Right | Wrong
http://www.mysite.com | mysite.com | http://123.123.123.123

If you have a dynamic DNS/IP, then it would be best to access the control by a domain name, rather than IP. In this case, use 127.0.0.1 in the IP field when creating the keys.

If the IP is unknown, or if the control is to be used on localhost only, use 127.0.0.1 in the IP field when creating the keys.

Other Important Information

If you are behind a firewall, the license ley will still work, as only the URL is checked.

The key will work for the major version of the product it was created for. For example, if the key is created for Telerik RadWindow v1.x it will NOT work on another major version (such as v1.x).

Back to Setting License Keys.

© 2002-2008 Telerik. All Rights Reserved.


More About License

Telerik RadWindow v1.9 Send comments on this topic.
More About License

Glossary Item Box

The LicenseFiles are XML files, which contain the licensing information (Company and LicenseKey) for every component of the Telerik RadControls for ASP.NET web-suite. This approach is much more convenient than setting licensing information directly in the control's properties, especially when you use multiple components on multiple pages. In case you upgrade your component, or implement the same application on a different server (domain) you have to change the Company and LicenseKey information only once – in the LicenseFile. Every Telerik component is shipped with a LicenseFile.XML located in the "~/RadControls" subfolder of the web-application. The LicenseFile property is set by default to point to this file so all you have to do is enter the required properties in the file. Below is a sample LicenseFile.XML:

<root>

<license control="editor" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY1"/>
<license control="spell" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY2"/>
<license control="menu" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY3"/>

</root>

Please, note that you may use a single LicenseFile to unlock more than one Telerik components.

If you place trial and commercial key(s), Standard or Professional edition, the editor will use the commercial key(s).

Note:The values set in the LicenseKey and Company properties of the Telerik RadEditor tag will override the ones set in the LicenseFile. If you want to use the LicenseFile approach make sure you remove the LicenseKey and Company properties from the Telerik RadEditor tag.

© 2002-2008 Telerik. All Rights Reserved.


Support Options

Telerik RadWindow v1.9 Send comments on this topic.
Support Options

Glossary Item Box

© 2002-2008 Telerik. All Rights Reserved.


Upgrading Telerik RadWindow v1.x Developer to Telerik RadWindow v1.x Developer license

Telerik RadWindow v1.9 Send comments on this topic.
Upgrading Telerik RadWindow v1.x Developer to Telerik RadWindow v1.x Developer license

Glossary Item Box

Follow the steps below to upgrade your Telerik RadWindow v1.x Developer license to Telerik RadWindow v1.9 Developer license.

These instructions are also valid for upgrading Telerik RadWindow v1.x Developer license to a newer Telerik RadWindow minor version.

THE PROCEDURE DESCRIBED IN THIS MANUAL IS IRREVERSIBLE AND YOU MAY LOSE YOUR DATA IF THE INSTALLATION IS NOT CARRIED OUT CORRECTLY!

1. Back up Your Old Files

We strongly suggest that you back-up your old Telerik RadWindow files and folders, especially if you would like to use your old settings.

2. Obtain the Necessary File

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases".
  3. Locate the control that you need to install, i.e. Telerik RadWindow, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. Since you have purchased the control, make sure you are downloading the proper file - the Developer version has the Dev abbreviation in it.

3. Install and Copy the New Files

  1. Unzip the files at a convenient location.
  2. Check the Changes and Backward Compatibility section for introduced changes. If there are such, they should be applied a little later in the upgrade process.
  3. Backup your application if you haven't done so already.
  4. Close Visual Studio or any ither IDE which may lock the old assembly.
  5. From the newly downloaded and unzipped files, copy the new DLL (RadWindow.NET2.dll located in the bin folder) to your web-application's bin folder. Replace the old dll.
  6. Locate the old RadControls/Window folder and delete it manually, i.e. using Windows Explorer. By default, the RadControls/Window folder should be in the root of your application. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate it and delete it using Windows Explorer.
    DO NOT use Visual Studio to move, copy or delete the RadControls folder as this will break the Telerik control(s).
  7. If you intend to use skins different from the default or if you plan to modify the JavaScript files, copy the new RadControls/Window folder to the same location as above.
  8. If using VS.NET, update the control's reference in your project to point to the new DLL.
  9. Follow the steps in the Changes and Backward Compatibility section in case there are some changes between the versions.
  10. Recompile your project.
  11. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadWindow to the Global Assembly Cache
  12. Run the project.
  13. If you still get the older version of Telerik RadWindow Show click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadWindow's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadWindow, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....

  14. If you get a copyright message Show click here

    The copyright message appears only when using the trial version of Telerik RadWindow (the Developer versions of Telerik's controls do not throw copyright messages). Make sure you have downloaded the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

4. Using the old ToolsFile.xml File and ConfigFile.xml file [valid for Telerik RadEditor and Telerik RadSpell only]

If you would like to use your old ToolsFile.xml and ConfigFile.xml files (which you backed up in #1 above), you can do so by copying them from the back-up to the RadControls\Editor folder (or RadControls\Spell respectively) of your web-application. When prompted to overwrite the other file, click "YES"

© 2002-2008 Telerik. All Rights Reserved.


Using IntelliSense in Visual Studio 2005

Telerik RadWindow v1.9 Send comments on this topic.
Using IntelliSense in Visual Studio 2005

Glossary Item Box

Visual Studio 2005 automatically enables IntelliSense - through reflection it detects all classes, properties and methods in the dll file(s).

For additional convenience each Telerik control is provided an XML file which contains the comments for its classes, properties and methods. For example, when Telerik RadEditor is dragged to the webform the RadEditor.Net2.xml file is automatically added in the bin directory of the project. Each time a particular class/property/method is being selected from the dropdown of the autocomplete functionality, a tooltip with the comment for this class/property/method is displayed:

Intellisense in VS2005

© 2002-2008 Telerik. All Rights Reserved.


Get more help

Telerik RadWindow v1.9 Send comments on this topic.
Get more help

Glossary Item Box

In case you cannot find the needed information in this manual, you can also review the following resources:

  • online Knowledge Base - visit http://www.telerik.com/KB/ and browse or search the articles for a solution to your problem;
  • Telerik product forums at http://www.telerik.com/Forums/ - consult with other people who use our products;
    Use the in-built search on the page.
  • live examples at http://www.telerik.com/r.a.d.controls/ - use the left pane to navigate to the control and functionality you need. In the right pane, toggle among the various pages (Description, C#, ASPX, etc.) to learn about the functionality displayed.
  • online code library - visit http://www.telerik.com/community/code-library/default.aspx adn download a growing number of samples, get hands-on experience with the RadControls and submit some of your favorite implementations.
  • contact Telerik support with a technical question using your Client.NET account at http://www.telerik.com/Default.aspx?PageId=2069.

You can also send us comments on any topic by clicking on the link in the top right corner of the page:

The Send comments link

Alternatively, you can send an email to documentation@telerik.com with feedback or inquiries concerning our manuals.

© 2002-2008 Telerik. All Rights Reserved.


Assembly Overview

RadWindow Assembly

Namespaces

Namespace | Description
Telerik.WebControls |


Getting Started - RadWindow

Getting Started

© 2002-2005, telerik. All Rights Reserved.


Introduction - RadWindow

Introduction

© 2002-2005, telerik. All Rights Reserved.


RadWindow Class Events

RadWindow Class Events
[image]
Telerik.WebControls Namespace : RadWindow Class

For a list of all members of this type, see RadWindow members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadWindow Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadWindow Class Methods

RadWindow Class Methods
[image]
Telerik.WebControls Namespace : RadWindow Class

For a list of all members of this type, see RadWindow members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadWindow Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadWindowBase Class Events

RadWindowBase Class Events
[image]
Telerik.WebControls Namespace : RadWindowBase Class

For a list of all members of this type, see RadWindowBase members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadWindowBase Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadWindowBase Class Methods

RadWindowBase Class Methods
[image]
Telerik.WebControls Namespace : RadWindowBase Class

For a list of all members of this type, see RadWindowBase members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadWindowBase Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


Skin Property

Skin Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : Skin Property

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Skin As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.Skin = value

value = instance.Skin
C#
public virtual string Skin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


SkinsPath Property

SkinsPath Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : SkinsPath Property

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinsPath As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As String

instance.SkinsPath = value

value = instance.SkinsPath
C#
public virtual string SkinsPath {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadWindowBase Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBase
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowBase Class
RadWindowBase Members

© 2002-2005, telerik. All Rights Reserved.


RadWindowBehaviorFlags Enumeration

RadWindowBehaviorFlags Enumeration
[image]
Telerik.WebControls Namespace : RadWindowBehaviorFlags Enumeration

Specifies the behaviors of the radWindow object

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Enum RadWindowBehaviorFlags
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RadWindowBehaviorFlags
C#
public enum RadWindowBehaviorFlags : Enum

Members

Member | Description
None | No behavior is specified.
Resize | The object can be resized.
Minimize | The object can be minimized.
Close | The object can be closed.
Pin | The objct can be pinned.
Maximize | The object can be maximized.
Move | The object can be moved.
Reload | The object will have a reload button.
Default | Default object behavior: all together.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.RadWindowBehaviorFlags

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadWindow (in RadWindow.dll)

See Also

Reference

Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadWindowManager Class Events

RadWindowManager Class Events
[image]
Telerik.WebControls Namespace : RadWindowManager Class

For a list of all members of this type, see RadWindowManager members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadWindowManager Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadWindowManager Class Methods

RadWindowManager Class Methods
[image]
Telerik.WebControls Namespace : RadWindowManager Class

For a list of all members of this type, see RadWindowManager members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadWindowManager Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


SkinsPath Property

SkinsPath Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : SkinsPath Property

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinsPath As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As String

instance.SkinsPath = value

value = instance.SkinsPath
C#
public virtual string SkinsPath {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadWindowManager Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindowManager
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindowManager Class
RadWindowManager Members

© 2002-2005, telerik. All Rights Reserved.


RadWindowMinimizeModes Enumeration

RadWindowMinimizeModes Enumeration
[image]
Telerik.WebControls Namespace : RadWindowMinimizeModes Enumeration

Specifies the minimize options for the radWindow object

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Enum RadWindowMinimizeModes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RadWindowMinimizeModes
C#
public enum RadWindowMinimizeModes : Enum

Members

Member | Description
SameLocation | Window is minimized but stays at the same left/top position
MinimizeZone | Window is minimized to a toolbar object that controls its minimization behavior
Default | Default

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.RadWindowMinimizeModes

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadWindow (in RadWindow.dll)

See Also

Reference

Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadWindow Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindow Class
RadWindow Members

© 2002-2005, telerik. All Rights Reserved.


Skin Property

Skin Property
[image]
Telerik.WebControls Namespace > RadWindow Class : Skin Property

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Skin As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As String

instance.Skin = value

value = instance.Skin
C#
public virtual string Skin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindow Class
RadWindow Members

© 2002-2005, telerik. All Rights Reserved.


SkinsPath Property

SkinsPath Property
[image]
Telerik.WebControls Namespace > RadWindow Class : SkinsPath Property

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinsPath As String
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As String

instance.SkinsPath = value

value = instance.SkinsPath
C#
public virtual string SkinsPath {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindow Class
RadWindow Members

© 2002-2005, telerik. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadWindow Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadWindow (in RadWindow.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadWindow
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadWindow Class
RadWindow Members

© 2002-2005, telerik. All Rights Reserved.


Telerik.WebControls Namespace

Telerik.WebControls Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
RadWindow |
RadWindowBase |
RadWindowManager |
WindowCollection | Summary description for WindowCollection.
WindowShortcut |
WindowShortcutCollection |

Enumerations

Enumeration | Description
RadWindowBehaviorFlags | Specifies the behaviors of the radWindow object
RadWindowMinimizeModes | Specifies the minimize options for the radWindow object

See Also

Reference

RadWindow Assembly

© 2002-2005, telerik. All Rights Reserved.


Telerik.WebControls Namespace Inheritance Hierarchy

Telerik.WebControls Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.WebControls.WindowCollection
Telerik.WebControls.WindowShortcutCollection
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadWindowUtils.RadControl
Telerik.RadWindowUtils.RadSkinnableControl
Telerik.WebControls.RadWindowBase
Telerik.WebControls.RadWindow
Telerik.WebControls.RadWindowManager
Telerik.WebControls.WindowShortcut

See Also

Reference

RadWindow Assembly

© 2002-2005, telerik. All Rights Reserved.


Trial License v1.0 to Developer License v1.0

Telerik RadWindow v1.9 Send comments on this topic.
Trial License v1.0 to Developer License v1.0

Glossary Item Box

Follow the steps below to upgrade your Telerik RadWindow v1.0 trial license to a Developer (production) license.

1. Back up Your Old Files

We strongly suggest that you back-up your old Telerik RadWindow files and folders.

THE PROCEDURE DESCRIBED IN THIS MANUAL IS IRREVERSIBLE AND YOU MAY LOSE YOUR DATA IF THE INSTALLATION IS NOT CARRIED OUT CORRECTLY!

2. Obtain the Necessary File

Download the DEVELOPER build from the "My licenses" section of your Client.Net account, if you haven't done so already. We suggest that you use the ZIP version.

3. Install and Copy the New Files

Unpack the ZIP file directly in your project folder, overwriting all existing files.

4. Remove the Licensing Properties

Since the Developer build does not use license keys, the following Licensing properties are no longer needed:

  • LicenseKey

  • Company

  • LicenseFile

If you are using ConfigFiles to configure your comboboxes, you need to remove all those properties otherwise you will get a Parser Error. If you are setting those properties declaratively (in the Telerik RadWindow tag) you may remove them only if you want, as they will be simply ignored.

Troubleshooting the Upgrade Process

If you still get the older version then try the following (not related to Telerik controls):

  • Sometimes the .NET Framework wrongly caches the Telerik RadControls for ASP.NET' DLLs and therefore the update may seem to have failed. Try the following to ensure that this has been the exact problem and eliminate it:

    1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
    2. Open a Windows Explorer and navigate to
    C:\Windows(WINNT)\Microsoft.NET\Framework\vYOUR_VERSION\Temporary ASP.NET Files
    3. Delete all the folders with names, corresponding to your Telerik projects, containing RadWindow, RadTreeView, etc.
  • Delete your Visual Studio web project caches as well - they should be located at C:\Documents and Settings\<YOUR USER>\VSWebCache.
  • Delete your browser cache: Tools -> Internet Options -> Delete Files....

© 2002-2008 Telerik. All Rights Reserved.