At a Glance

Telerik RadUpload v2.4 Send comments on this topic.
At a Glance

Glossary Item Box

New major version of RadUpload is now available as a part of RadControls “Prometheus” for ASP.NET. Its new architecture is based on top the ASP.NET AJAX framework in order to directly benefit from client-side behaviors and capabilities. We strongly recommend using the new version for all new development.

Thank you for choosing Telerik RadUpload!

Telerik RadUpload is a suite containing:

  • a highly efficient proprietary HttpModule, which enables uploading of files with size up to 2GB, while allocating a minimum amount of server memory.
  • UI control for single- and multi-file uploads, integrated file validation and more.
  • a Progress area control, designed to monitor file uploads or any other measurable process on the server.

Browser Support

Telerik RadUpload supports all major browsers and platforms (both on PC and Mac, where applicable):

    • Internet Explorer 5.5+;
    • all Gecko-based browsers - Mozilla 1.0+, FireFox, Netscape 7+;
    • Opera 8.0+.
    • Safari 1.3+

Key Features

    • RadMemoryOptimization - enables uploading of files with size up to 2GB, while allocating a minimum amount of server memory
    • Upload progress monitoring
    • Custom progress monitoring
    • Integrated file validation, both server-side and client-side (with some limitations)

Getting Started

  • Getting Started
  • Known Limitations

If you need further assistance, please contact clientservice@telerik.com

Revised: 4/11/2008

© 2002-2008 Telerik. All Rights Reserved.


Getting Started

Telerik RadUpload v2.4 Send comments on this topic.
Getting Started

Glossary Item Box

General Information You Need to Know

  1. RadMemoryOptimization - this is the process of freeing the server memory from the uploaded files, thus optimizing the server resources and allowing uploads of files up to 2GB.
  2. Known Limitations - this is the list of the things which cannot be done with RadUpload or RadProgressArea.
  3. Configuring the application for large file uploads - you need to modify the application's web.config in order to enable uploading files larger than 4MB.
  4. Using ASP:FileUpload and standard <input type="file"> - if RadMemoryOptimization is enabled for a page you need to use RadUploadContext in order to retreive the files uploaded with these controls. RadUpload finds its files automatically.
  5. Uploding Files with AJAX - due to certain limitations of the XmlHttpRequest component which is used in AJAX, files cannot be uploaded using these technologies. However, you can force a postback for an Ajax-enabled button in order to properly upload files.
  6. Using Forms Authentication (.NET 2.0 only) - RadUploadProgressHandler must be allowed for unauthenticated access in order to operate properly.

Configuration

  1. RadUploadHttpModule - this HttpModule contains the core functionality of RadMemoryOptimization. You need to register it in the application web.config in order to be properly used.
  2. RadUploadProgressHandler - this HttpHandler is used by RadProgressManager for async progress updates. You need to register it in the application web.config in order to be properly used.

Uploading Files

  1. Automatic file saving and validation - RadUpload can automatically save your uploaded files to a selected folder only by setting a property. The uploaded files can be automatically validated also only by setting the corresponding property.
  2. File saving with server-side script - in more complex scenarios you can save the uploaded files with server-side script and still benefit from the integrated file validation.
  3. Server-side Validation, Advanced Server-side Validation and Client-side Validation - RadUpload is able to automatically validate the extensions, the mime-types and the size of the uploaded files. If you need to create client-side validation (only for the file names) or validate the uploaded files against different criteria you can use the client-side and the server-side API.
  4. Adding Text Fields - RadUpload provides the ability to add custom fields to each file input. Using this functionality you can add fields like Title, Description, etc. to each file, uploaded with RadUpload.
  5. Customizing Appearance - you can fully customize the visual appearance of RadUpload by creating a custom skin. More information: General information about Skins, Specific details about RadUpload skinning and Styles Applied to RadUpload.

Progress Monitoring

  1. Upload Progress Monitoring - you can monitor the progress of any file upload which is handled by RadMemoryOptimization.
  2. Creating Templates - if you need RadProgressArea to render different HTML you can create a ProgressTemplate. In most of the cases you will not need to write any javascript in order to ensure the proper operation of the control.
  3. Custom Progress Monitoring - with very small amount of server-side code you can monitor the progress of any measurable server-side process, such as mathematical calculations or database queries.
  4. Customizing Appearance - you can fully customize the visual appearance of RadProgressArea by creating a custom skin.

© 2002-2008 Telerik. All Rights Reserved.


Which license should I use or purchase

Telerik RadUpload v2.4 Send comments on this topic.
Which license should I use or purchase
See Also
Licensing > Which license should I use or purchase

Glossary Item Box

Telerik offers several different packages for you to choose from:

Trial licenses

Description

If you are a first-time Telerik user, it would be best to create an account in our Client.NET extranet (www.telerik.com/Clientnet) and download a Trial license. The Trial licenses are fully-functional and are identical in functionality to the paid versions. Review the Which file do I need to install? section for further instructions.

Support

A trial license comes with the Bronze Support package, which guarantees a 72-hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used. Mail queries usually take longer to respond.

For more information, review the available Support Options.

Single Developer licenses

Description

A Developer license is granted per developer seat: one developer is allowed to work with the product per license. Developer licenses have no run-time limitations and allow the usage of all Telerik controls in an UNLIMITED number of custom web applications. The controls can be installed on more than one machine as long as only the licensed developer is using the product.

License Keys

Developer licenses come with special builds that work without keys and allow the developer to safely access web applications that use Telerik products. To update your application from a trial license to a Developer license, please review the instructions in the following section: Trial License v1.x to Developer License v2.x

Support

The Single Developer license comes with the Silver Support package which guarantees a 48 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used.
Mail queries usually take longer to respond.

For more information, review the available Support Options.

Single Developer Subscription license

Description

Unlike the Single Developer license, Single Developer Subscription license offers a Subscription. A Subscription license entitles you to receive, for free, all released updates and new products for the duration of one year from the date of purchase. This license is the easiest and most cost-effective way to ensure that you are using the latest versions of our products. With the Subscription license you save more than 70% on Telerik products if purchased separately.

The Single Developer Subscription license is offered for the Telerik RadControls for ASP.NET suite only. Subscriptions are not available for individual products at this time.

You can renew your subscription at approximately 50% of the original price. You will be promptly notified when the Subscription license is about to expire.

All RadControls for ASP.NET subscription holders are entitled to a license to RadControls "Prometheus" suite.

License Keys

The Developer license comes with a special build that work without keys and allow the developer to safely access web applications that use Telerik products. To update your application from Trial to a Developer license, please review the instructions in the following section: Trial License v1.x to Developer License v2.x

Support

The Single Developer Subscription license comes with the Gold Support package which guarantees a 24 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used.
Mail queries usually take longer to respond.

For more information, review the available Support Options.

Telerik maintains a public Product Roadmap, which will give you details on the upcoming products and versions for the next quarter. This guarantees that you see a good return on your investment in the Subscription license.

Source Code license

Description

The Source Code license is an excellent investment if you need to customize our controls to fit a specific requirement, or if your company wishes to own the source code for all products used.

A Source Code license is offered with purchases of five or more Single Developer or Single Developer Subscription licenses for Telerik RadControls for ASP.NET suite. If you have opted for the Subscription license, you will be receiving the source codes for all products released within one year from the date of purchase.

Source Code licenses are offered for the Telerik RadControls for ASP.NET suite only and are not available for individual products at this time.

Support

The Source Code license comes with the Gold Support package, which guarantees a 24 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used. All questions from Source code licensees are treated with priority.

For more information, review the available Support Options.

Custom Source Code modifications are not supported by Telerik.

Discounts Offered

Telerik offers the following volume discounts on all licenses:

  • 3 to 4 licenses - 10%
  • 5 to 9 licenses - 20%
  • 10 to 19 licenses - 30%
  • 20 or more - 40%

Telerik also offers discounts to qualified educational, non-profit, charity and government entities. For more information on how to qualify for a discount, visit our Special pricing page.

See Also

Sales FAQ page
Purchase Online
Support Options
Support FAQ
Client.Net FAQ
License Agreement

© 2002-2008 Telerik. All Rights Reserved.


License Agreement

Telerik RadUpload v2.4 Send comments on this topic.
License Agreement
Licensing > License Agreement

Glossary Item Box

Telerik End-User License Agreement

By purchasing, installing, or otherwise using the product identified above and/or its related materials, you agree to be bound by the terms and conditions of this License Agreement. Check the box "I have read and agree to the License Agreement" if you agree.

IMPORTANT – READ CAREFULLY: This license agreement ("LICENSE") is a legal agreement between you (either an individual or a single entity, also referred to as "LICENSEE", "YOU") and Telerik Corp., ("TELERIK"), for the software containing this LICENSE which may also include the software’s source code written in a high-level computer language, associated media, printed materials, and "online" or electronic documentation (collectively referred to as “SOFTWARE”).

Any earlier license we may have granted to you for the use of earlier versions of the SOFTWARE is replaced by this LICENSE.

SOFTWARE PRODUCT LICENSE

The SOFTWARE is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties and contains confidential information and trade secrets. TELERIK retains all rights not expressly granted to you in this LICENSE.

I. GRANT OF LICENSE

TELERIK hereby grants to you, and you accept, a non-exclusive, non-transferable license to install, copy, use and modify the SOFTWARE only as authorized below.

This license grants you no rights to the "2007 Microsoft Office System User Interface". For appropriate license, please, contact Microsoft directly.

1. TRIAL LICENSE

You are granted a license for evaluation purposes only. You are authorized to install, copy, and use the SOFTWARE for the sole purpose of testing its functionality. You are not allowed to integrate it in end products or use it for any commercial purpose.

2. DEVELOPER LICENSE

The SOFTWARE is licensed per Developer seat. This means that each individual using or otherwise accessing the SOFTWARE for development purposes must obtain the right to do so by purchasing an individual product license.

You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same licensed developer. The SOFTWARE is in "use" on a computer when it is loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard disk or other storage device) of that computer for development purposes. If you install the SOFTWARE on a network server for the sole purpose of internal distribution among licensed developers this is not considered “use” of the SOFTWARE.

2-1. Redistribution rights:

All product licenses are perpetual and royalty-free. You can ship the SOFTWARE as part of solutions for internal company use, hosted applications, commercial solutions deployed at end-users’ sites or shrink-wrapped software (PACKAGED PRODUCTS) in which the SOFTWARE is integrated.

You may distribute the SOFTWARE provided that:

  • You reasonably ensure that the SOFTWARE is not distributed in any form that allows it to be reused by any application other than your solution. Technical guidelines will be provided upon request, please contact support@telerik.com for more details.
  • You need to duly inform your customers that they are not allowed to use the SOFTWARE independently from your solution. For use of the SOFTWARE in design-time (i.e. within a development environment such as Microsoft Visual Studio) your customers need to purchase the appropriate number of Developer Licenses from TELERIK.
  • You need to include a valid copyright message in your solution in a location viewable by the end-users (e.g. "About" box).

2-2. Silver Support:

As part of your license you are entitled to "Silver" Support Package which guarantees response within 48 hours.

3. DEVELOPER LICENSE PLUS SUBSCRIPTION AND SOURCE CODE LICENSE

You are granted 1 (one) Developer License as defined above. In addition you are entitled to a 1 Year Subscription, Source Code and Gold Support Package.

3-1. Subscription

You are entitled to receive all version updates for the SOFTWARE for a period of 1 (one) year.

  • 3-2. Source Code

    As part of the DEVELOPER PLUS SUBSCRIPTION AND SOURCE CODE LICENSE you are granted the right to view and modify the SOFTWARE's source code only as authorized below:
  • The SOFTWARE's source code is provided to the licensed developer for the sole purposes of education and troubleshooting. The SOFTWARE's source code cannot be used as a basis of development of derivative works or other software products.
  • Under no circumstances may any portion of the SOFTWARE’s source code or any modified version of the source code be distributed, disclosed or otherwise made available to any third party.
  • TELERIK DOES NOT provide technical support for modified source code.
  • The SOFTWARE’s source code is provided as is. Refunds are not available for licenses that include source code.
  • In the event you develop any troubleshooting-related modifications of the SOFTWARE, either independently or jointly with TELERIK, such modifications and all rights associated therewith will be the exclusive property of TELERIK. You are granted the right to use such modifications as set forth in this agreement.
  • You acknowledge that the SOFTWARE’s source code contains valuable and proprietary trade secrets of TELERIK. All individuals employed by or belonging to your entity agree to expend every effort to insure its confidentiality. You agree to assume full responsibility for such employees’ or contractors’ use, or misuse, of such disclosed source code as if it was your use. These obligations shall not apply to any information generally available to the public, independently developed or obtained without reliance on TELERIK information, or approved in writing for release by TELERIK without restriction.

3-3. Gold Support:

As part of your license you are entitled to "Gold" Support Package which guarantees response within 24 hours.

II. OTHER RIGHTS AND LIMITATIONS

  • At no time may the SOFTWARE be used for development purposes by other individuals than the licensed developer(s).
  • The SOFTWARE may not be distributed for use with solutions or PACKAGED PRODUCTS other than those developed by you.
  • The SOFTWARE may not be distributed part of products that have the same or substantially the same primary functionality. (Example for RadControls for ASP.NET: you may purchase Telerik RadEditor for ASP.NET and create a blog application/component. However, you cannot wrap RadMenu and offer it as a SharePoint WebPart or DNN menu skin object, since its primary functionality would be substantially the same as the SOFTWARE.
  • You are not allowed to resell, transfer, rent, lease, or sublicense the SOFTWARE and your associated rights. Under no circumstances shall you grant further redistribution rights to the end-users of your solution.
  • You may not use the TELERIK product names, logos or trademarks to market YOUR SOFTWARE.
  • You are not allowed to disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.
  • You are not allowed to use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.
  • You agree to indemnify, hold harmless, and defend TELERIK and its resellers from and against any and all claims or lawsuits including attorney's fees that arise or result from the use or distribution of YOUR SOFTWARE

III. DELIVERY

TELERIK shall deliver to LICENSEE a master copy of the SOFTWARE licensed hereunder in electronic files only. Documentation shall also be provided in electronic format.

IV. UPGRADES

You are eligible for free minor upgrades (e.g. v.1.5 to v.1.8), patches, and bug-fixes for the SOFTWARE, including source code if applicable. SOFTWARE labeled as an upgrade replaces and/or supplements (and may disable) the product that formed the basis for your eligibility for the upgrade. You may use the resulting upgraded product only in accordance with the terms of this LICENSE.

If you have purchased a "DEVELOPER PLUS SUBSCRIPTION AND SOURCE CODE LICENSE” you are entitled to receive all version updates for the SOFTWARE period of 1 (one) year.

V. TERMINATION

This LICENSE shall last as long as you use the SOFTWARE in compliance with this LICENSE. TELERIK may terminate this LICENSE if you fail to comply with any of the terms and conditions herein. In such event you agree to remove and destroy all copies of the SOFTWARE and any applicable source code.

TELERIK reserves the right to discontinue at any time any product, shall it be offered individually or as a part of a product SUITE. However, TELERIK is obligated to provide the proper level of support for all discontinued products for a period of 1 (one) year after the date of discontinuance.

VI. COPYRIGHT

All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animations, video, audio, music, text, incorporated into the SOFTWARE), the accompanying printed materials, and any copies of the SOFTWARE, and any trademarks or service marks of TELERIK are owned by TELERIK. All title and intellectual property rights in and to the content that may be accessed through use of the SOFTWARE is the property of the respective content owner and may be protected by applicable copyright or other intellectual property laws and treaties. This LICENSE grants you no rights to use such content.

VII. LIMITED WARRANTY

TELERIK warrants solely that the SOFTWARE will perform substantially in accordance with the accompanying written materials for a period of ninety (90) days. TELERIK does not warrant the use of the SOFTWARE will be uninterrupted or error free at all times and in all circumstances, nor that program errors will be corrected. This limited warranty shall not apply to any error or failure resulting from (i) machine error, (ii) LICENSEE's failure to follow operating instructions, (iii) negligence or accident, or (iv) modifications to the SOFTWARE by any person or entity other than TELERIK. In the event of a breach of warranty, LICENSEE 's sole and exclusive remedy, is repair of all or any portion of the SOFTWARE. If such remedy fails of its essential purpose, LICENSEE 's sole remedy and TELERIK's maximum liability shall be a refund of the paid purchase price for the defective SOFTWARE only. This limited warranty is only valid if TELERIK receives written notice of breach of warranty within thirty days after the warranty period expires.

VIII. LIMITATION OF LIABILITY

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT WILL TELERIK BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OF OR INABILITY TO USE THE PRODUCT, INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF, AND REGARDLESS OF THE LEGAL OR EQUITABLE THEORY (CONTRACT, TORT OR OTHERWISE) UPON WHICH THE CLAIM IS BASED. IN ANY CASE, TELERIK'S ENTIRE LIABILITY UNDER ANY PROVISION OF THIS AGREEMENT SHALL NOT EXCEED IN THE AGGREGATE THE SUM OF THE LICENSE FEES LICENSEE PAID TO TELERIK FOR THE PRODUCT GIVING RISE TO SUCH DAMAGES, NOTWITHSTANDING ANY FAILURE OF ESSENTIAL PURPOSE OF ANY LIMITED REMEDY. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS EXCLUSION AND LIMITATION MAY NOT BE APPLICABLE. TELERIK IS NOT RESPONSIBLE FOR ANY LIABILITY ARISING OUT OF CONTENT PROVIDED BY LICENSEE OR A THIRD PARTY THAT IS ACCESSED THROUGH THE PRODUCT AND/OR ANY MATERIAL LINKED THROUGH SUCH CONTENT. ANY DATA INCLUDED IN A PRODUCT UPON SHIPMENT FROM TELERIK IS FOR TESTING USE ONLY AND TELERIK HEREBY DISCLAIMS ANY AND ALL LIABILITY ARISING THEREFROM. THE EXTENT OF TELERIK'S LIABILITY FOR THE LIMITED WARRANTY SECTION SHALL BE AS SET FORTH THEREIN.

IX. MISCELLANEOUS

This License will be governed by the law of the State of Massachusetts, U.S.A. If any provision of this LICENSE is to be held unenforceable, such holding will not affect the validity of the other provisions hereof. Failure of a party to enforce any provision of this LICENSE shall not constitute or be construed as a waiver of such provision or of the right to enforce such provision.

This License represents the entire understanding between the parties with respect to its subject matter.

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, THAT YOU UNDERSTAND THIS AGREEMENT, AND UNDERSTAND THAT BY CONTINUING THE INSTALLATION OF THE SOFTWARE PRODUCT, BY LOADING OR RUNNING THE SOFTWARE PRODUCT, OR BY PLACING OR COPYING THE SOFTWARE ONTO YOUR COMPUTER HARD DRIVE, YOU AGREE TO BE BOUND BY THIS AGREEMENT'S TERMS AND CONDITIONS. YOU FURTHER AGREE THAT, EXCEPT FOR WRITTEN SEPARATE AGREEMENTS BETWEEN TELERIK AND YOU, THIS AGREEMENT IS A COMPLETE AND EXCLUSIVE STATEMENT OF THE RIGHTS AND LIABILITIES OF THE PARTIES.

© 2002-2008 Telerik. All Rights Reserved.


System requirements and browser support

Telerik RadUpload v2.4 Send comments on this topic.
System requirements and browser support
Installation and deployment > Installation > System Requirements > System requirements and browser support

Glossary Item Box

System Requirements

The following page describes the system requirements needed by Telerik RadControls for ASP.NET:

http://www.telerik.com/support/requirements-and-compliance/system-requirements.aspx

Browser Support

The following page shows all browsers and versions supported by Telerik RadControls for ASP.NET:

http://www.telerik.com/support/requirements-and-compliance/browser-support.aspx

Browser Limitations

The following article explains the browser limitations and what implications they have on Telerik RadControls for ASP.NET:

http://www.telerik.com/support/browser-support/browser-issues.aspx

Files and folders needed by Telerik RadUpload and Telerik RadControls for ASP.NET to function

The following section explains the files and folders needed to be used in your application in order for Telerik RadControls for ASP.NET to function properly:

Files and folders needed by Telerik RadControls for ASP.NET

© 2002-2008 Telerik. All Rights Reserved.


Which file do I need to install?

Telerik RadUpload v2.4 Send comments on this topic.
Which file do I need to install?
See Also
Installation and deployment > Installation > Installing Telerik RadUpload on your computer > Which file do I need to install?

Glossary Item Box

Telerik offers you the following ways to install Telerik RadUpload:

  • as an individual install, or
  • as part of the complete Telerik RadControls for ASP.NET suite.

If you plan to use only Telerik RadUpload in your project, we recommend that you install Telerik RadUpload only. In case you want to use two or more products from the Telerik RadControls for ASP.NET suite, it is probably better to install the full Telerik RadControls for ASP.NET suite.

Each installation package comes in three types:

  • EXE file for automatic installation;
    The EXE files are intended for easy and automatic installation of a product. It installs the control(s) on your computer in a folder in your Program Files named Telerik, and automatically creates the necessary virtual folders and projects. Additionally, the EXE installs the help file(s) in your VS.NET IDE and in your local copy of MSDN (if you have one). The EXE files are best for first-time Telerik users and ASP.NET novices.
  • ZIP file for manual (advanced) installation;
    The ZIP is used for manual (advanced) installs and for upgrading/updating purposes. The folder structure is different from the EXE. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot. Use the ZIP file for installation on shared hosting.
  • DLL and Scripts only (a.k.a. HOTFIX) file for updating/upgrading a product to a newer version;
    This is a bare-bones upgrade option for our controls. The DLL and Scripts files contain only those files that you need to replace in your project to upgrade to the new version of a Telerik control. If you are already using a Telerik product and just want to update it, there is no need to download the complete suite - download the latest HOTFIX for the product and apply it.
The latest EXE and ZIP packages available for download already have all updates/HOTFIXES applied. There is no need to update them further.

If you already have a Telerik control installed from the EXE, you can safely install an updated version of the same control - the installer will keep your existing installation. The new files will be placed in a separate folder and the new installation does not damage the common installer files. The new Telerik RadUpload installation may have an updated help too: it is registered with the correct upload namespace. You can see the updated Telerik RadUpload help in your help2 viewer.

See Also

Installing the Telerik RadControls for ASP.NET suite from EXE file
Installing the Telerik RadControls for ASP.NET suite from ZIP file
Installing Telerik RadUpload from EXE file
Installing Telerik RadUpload from ZIP file
Using the 'DLL and Scripts only' file (HOTFIX)

© 2002-2008 Telerik. All Rights Reserved.


Installing the Telerik RadControls for ASP.NET suite from EXE file

Telerik RadUpload v2.4 Send comments on this topic.
Installing the Telerik RadControls for ASP.NET suite from EXE file
See Also
Installation and deployment > Installation > Installing Telerik RadUpload on your computer > Installing the Telerik RadControls for ASP.NET suite from EXE file

Glossary Item Box

The EXE files are intended for easy and automatic installation of a product. The EXE installs the suite on your computer to a folder named Telerik in your Program Files, automatically creating the necessary virtual folders and projects. Additionally, it installs the help file(s) in the VS.NET IDE and in your local copy of MSDN, if you have one installed.

The EXE files are best for first-time Telerik users and ASP.NET novices.

The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
The EXE installation will not overwrite previous Telerik RadControls for ASP.NET installations, unless it is of the same version.

Install with Internet Information Services (IIS) Running

To install Telerik RadControls for ASP.NET on your machine from the EXE file, follow the instructions below:

  1. Log into your Client.NET account.
  2. Go to My Licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab and download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadControls EXE file and follow the instructions.

    The wizard will install the Telerik RadControls for ASP.NET component in the following folder unless you specify otherwise:
    C:\Program Files\Telerik\RadControlsQ1 2007.

The wizard will create the necessary virtual folders.

To view live examples of the Telerik RadUpload functionality, you can launch the Quick-Start Framework in either of the following ways:

  • Open Start Menu -> Programs -> Telerik -> RadControls Q1 2007 for ASP.NET -> ASP.NET 2.X -> RadControls Q1 2007 C#/VB Live Examples,
  • Double-click the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\RadControlsQ1 2007\NET2,
  • or drag the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\RadControlsQ1 2007\NET2 to start the examples in your browser.

Install without Internet Information Services (VS 2005 only)

To install Telerik RadControls on your machine from the EXE file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab to download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadControls EXE file and follow the instructions.

    The wizard will install the Telerik RadControls for ASP.NET component in the following folder unless you specify otherwise:
    C:\Program Files\Telerik\.

When Internet information Services is not running, the product installation will NOT create virtual directories for the QSF, nor will it create any shortcuts for launching the QSF on localhost. To launch the Quick-Start framework, open and Run (Ctrl+F5) its VisualStudio Web Site using the provided shortcut in the Start Menu:
Start Menu -> Programs -> Telerik -> RadControlsQ1 2007 for ASP.NET-> ASP.NET 2.X -> Open Sample Web Site in Visual Studio
VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

The Telerik RadControls for ASP.NET package adds the products automatically to the VS.NET 2005 toolbox. To learn how to add them manually, see Adding Telerik RadUpload to the Visual Studio 2005 Toolbox.

See Also

Files and folders needed by Telerik RadControls for ASP.NET
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Installing Telerik RadUpload from EXE file

Telerik RadUpload v2.4 Send comments on this topic.
Installing Telerik RadUpload from EXE file
See Also
Installation and deployment > Installation > Installing Telerik RadUpload on your computer > Installing Telerik RadUpload from EXE file

Glossary Item Box

The EXE files are intended for easy and automatic installation of a product. The EXE installs the control on your computer to a folder named Telerik in your Program Files, automatically creating the necessary virtual folders and projects. Additionally, it installs the help file(s) in the VS.NET IDE and in your local copy of MSDN, if you have such installed.

The EXE files are best for first-time Telerik users and ASP.NET novices.

The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
The EXE installation will not overwrite previous Telerik RadUpload installations, unless it is of the same version.

Install with Internet Information Services (IIS) Running

To install Telerik RadUpload on your machine from the EXE file follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadUpload.
  4. Go to the Download tab and download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadUpload_2_4.exe and follow the instructions.

The wizard will create a virtual folder "Telerik RadUpload2.4NET2" (accessible at http://localhost/Telerik/telerikradupload2.4_NET2).

To view live examples of the Telerik RadUpload functionality, you can launch the Quick Start Framework in either of the following ways:

  • Open Start Menu -> Programs -> Telerik -> Telerik RadUpload v2.4 -> ASP.NET 2.X -> Telerik RadUpload v2.4 C#/VB Live Examples,
  • Double-click the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\Telerik RadUpload v2.4\NET2,
  • or drag the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\Telerik RadUpload v2.4\NET2 to start the examples in your browser.

Install without Internet Information Services (VS 2005 only)

To install Telerik RadUpload on your machine from the EXE file follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Locate Telerik RadUpload, and click on it.
  4. Go to the Download tab to download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadUpload_2_4.exe and follow the instructions.

When Internet information Services is not running, the product installation will NOT create virtual directories for the QSF, nor will it create any shortcuts for launching the QSF on localhost. To launch the Quick-Start framework, open and Run (Ctrl+F5) its VisualStudio Web Site using the provided shortcut in the Start Menu:
Start Menu -> Telerik -> Telerik RadUpload v2.4 -> ASP.NET 2.X -> Open Sample Web Site in Visual Studio
VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

Telerik RadUpload will be added automatically to VS.NET 2005's toolbox. Review the following instructions to add it manually: Adding Telerik RadUpload to the Visual Studio 2005 Toolbox

The wizard will install the Telerik RadUpload component in the following folder unless you specify otherwise:
\Program Files\Telerik\Telerik RadUpload2.4\NET2.

The installation folder contains the following subfolders and files:

  • "bin" - contains the .dll files

  • "Common" - contains JavaScripts and css files

  • "RadControls" - contains the clients-side JavaScript and resource files
    You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.

  • "upload" - contains the running examples from the Quick-Start framework

  • LiveExamplesCS - a browser link to run the C# version of the examples locally
  • LiveExamplesVB - a browser link to run the VB.NET version of the examples locally

The information below is generic for all Telerik controls. The particular details vary for individual control installations.

The installation folders of some Telerik controls may also contain the following subfolders:

  • "DeploymentActions" - contains the files required for proper deployment of the control
  • "Help" - contains all the files required for generating Help2
  • "Img" - contains system images
  • "InstalledRelated" - contains the files required for proper installation of the control

See Also

Adding Telerik RadUpload to an ASP.NET WebForm
Add/Remove Telerik RadUpload to the Global Assembly Cache
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Installing the Telerik RadControls for ASP.NET suite from ZIP file

Telerik RadUpload v2.4 Send comments on this topic.
Installing the Telerik RadControls for ASP.NET suite from ZIP file
See Also
Installation and deployment > Installation > Installing Telerik RadUpload on your computer > Installing the Telerik RadControls for ASP.NET suite from ZIP file

Glossary Item Box

Show All Show All
Hide All Hide All

The ZIP is used to install Telerik RadControls for ASP.NET manually for upgrading or updating purposes. The folder structure is different from the EXE installation. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot.

Install without IIS Running (VS 2005 only)

To install the Telerik RadControls for ASP.NET suite on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Hide What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadControls for ASP.NET - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help1
    • HelpNET20 folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadControls for ASP.NET under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadControls for ASP.NET under ASP.NET2.x
    • other files and folders.
  5. The latest package available for download has all latest updates/HOTFIXES applied. There is no need to update it further.
  6. Once the download completes, create a Telerik_RadControls folder in your IIS's inetpub/wwwroot folder.
  7. From the downloaded file, extract the files from the NET2 folder into inetpub/wwwroot/Telerik_RadControls folder. After the process ends, the inetpub/wwwroot/Telerik_RadControls folder should contain the following files and folders:
    • app_themes folder - contains the themes and skins used by Telerik's navigational controls
    • bin folder - contains the controls' .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files, needed by Telerik's controls. You will need to copy this folder in your web application only if you intend to use skins different from the Default or if you plan to modify the JavaScript files.
      Exceptions: Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell, Telerik RadUpload and Telerik RadWindow products.
    • folders, named after Telerik's controls (i.e. Calendar, Chart, Combobox, etc.) - these contain the running examples for each control from the Quick-Start framework
    • other project files and folders.
  8. Create a .NET2 virtual directory for the folder where you extracted the files. Hide How?

    This is accomplished through the Internet Information Services console on your machine:
    Start -> Settings -> Control Panel -> Administrative Tools -> Internet Information Services:
    1. Right-click the folder you have created (Telerik_RadControls).
    2. Select Properties.
    3. Click the Create button. The application name will become Telerik_RadControls.
    4. Click Apply.
    5. Click the ASP.NET tab.
    6. From the drop-down list, select your ASP.NET 2.0 version:

      ASP.NET tab under .NET2.0
    7. Click OK.
  9. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (under IIS6, Windows Server 2003) on the folder where the files were extracted. See Setting ASNET (Network Service) Permissions for more information.

To run the examples paste the following link in your browser: http://localhost/Telerik_RadControls/

To register the MS Help 2 files to VisualStudio and MSDN, please review the following link:
http://www.telerik.com/Default.aspx?PageId=2657

To add any control to the VS.NET toolbox, review Adding Telerik RadUpload to the Visual Studio 2005 Toolbox
To use any Telerik ASP.NET control in your project, review Adding Telerik RadUpload to an ASP.NET WebForm

DO NOT include/add the examples in your VS.NET project as this will break the Telerik control(s).

See Also

Files and folders needed by Telerik RadControls for ASP.NET
Trial License Limitations
Register MS Help 2 files

© 2002-2008 Telerik. All Rights Reserved.


Installing Telerik RadUpload from ZIP file

Telerik RadUpload v2.4 Send comments on this topic.
Installing Telerik RadUpload from ZIP file
See Also
Installation and deployment > Installation > Installing Telerik RadUpload on your computer > Installing Telerik RadUpload from ZIP file

Glossary Item Box

Show All Show All
Hide All Hide All

The ZIP is used to install Telerik RadUpload manually for upgrading or updating purposes. The folder structure is different from the EXE installation. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot.

Install Telerik RadUpload with IIS running

To install Telerik RadUpload on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadUpload.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Show What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadUpload - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadUpload under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadUpload under ASP.NET2.x
    The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
  5. Once the download completes, create a RadUpload folder in your IIS's inetpub/wwwroot folder.
  6. From the downloaded file, extract all files from the NET2 folder into inetpub/wwwroot/RadUpload folder. After the process ends, the inetpub/wwwroot/RadUpload/ folder should contain the following files and folders:
    • App_Themes folder - contains some .NET2.0 themes provided by Telerik
    • bin folder - contains the .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files. You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.
      Exceptions: Because of the specific control features, you will always need to copy RadControls for RadChart, RadEditor, RadSpell, RadUpload and RadWindow products.
    • upload folder - contains the running examples from the Quick-Start framework
    • other project files.
  7. Create a .NET2 virtual directory for the folder where you unzipped the files. Show How?
    This is accomplished through the Internet Information Services console on your machine:
    Start -> Settings -> Control Panel -> Administrative Tools -> Internet Information Services:
    1. Right-click the folder you have created (RadUpload).
    2. Select Properties.
    3. Click the Create button. The application name will become RadUpload.
    4. Click Apply.
    5. Click the ASP.NET tab.
    6. From the drop-down list, select your ASP.NET 2.0 version:

      ASP.NET tab under .NET2.0
    7. Click OK.
  8. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (under IIS6, Windows Server 2003) on the folder where the files were unzipped. See Setting ASNET (Network Service) Permissions for more information.

To run the examples, paste the following link in your browser: http://localhost/RadUpload

Install Telerik RadUpload without or with IIS stopped (VS 2005 Only)

To install Telerik RadUpload on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadUpload.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Show What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadUpload - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadUpload under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadUpload under ASP.NET2.x
    The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
  5. From the downloaded file, extract all files from the NET2 folder into folder at a convenient location on your disk. After the process ends, the folder should contain the following files and folders:
    • App_Themes folder - contains some .NET2.0 themes provided by Telerik
    • bin folder - contains the .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files. You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.
    • upload folder - contains the running examples from the Quick-Start framework
    • other project files.
  6. Open and Run (Ctrl+F5) Quick-Start Framework VisualStudio Web Site using the provided solution file ControlsExamples.sln in the NET2 folder. VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

To register the MS Help 2 files to VisualStudio and MSDN, please review the following link:
http://www.telerik.com/Default.aspx?PageId=2657

To add Telerik RadUpload to the VS.NET toolbox, review Adding Telerik RadUpload to the Visual Studio 2005 Toolbox.

To use the Telerik RadUpload in your project, please review Adding Telerik RadUpload to an ASP.NET WebForm.

DO NOT include/add the examples in your VS.NET project as this will break the Telerik control(s).

See Also

Adding Telerik RadUpload to an ASP.NET WebForm
Add/Remove Telerik RadUpload to the Global Assembly Cache
Trial License Limitations
Register MS Help 2 files

© 2002-2008 Telerik. All Rights Reserved.


Using the 'DLL and Scripts only' file (HOTFIX)

Telerik RadUpload v2.4 Send comments on this topic.
Using the 'DLL and Scripts only' file (HOTFIX)
See Also
Installation and deployment > Installation > Installing Telerik RadUpload on your computer > Using the 'DLL and Scripts only' file (HOTFIX)

Glossary Item Box

Show All Show All
Hide All Hide All

The "DLL and Scripts only" file (a.k.a. HOTFIX file) is a bare-bones upgrade option for our controls - they contain only those files that you need to replace in your project to upgrade to the new version of a Telerik control. If you are already using a Telerik product, there is no need to download the complete suite - download the "DLL and scripts only" version and follow the instructions below for applying the hotfix. The "DLL and Scripts only" file contains the following folders and files:

  • bin folder - contains the DLL file(s)
  • RadControls folder - contains the clients-side JavaScript and resource files for Telerik RadUpload
If you are installing a Telerik product for the first time, we recommend that you download the complete package (EXE or ZIP file).

To update Telerik RadUpload to a new version

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases" (or "My Free Trials" if you are a trial user).
  3. Locate the control that you need to install, i.e. Telerik RadUpload, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. If you have purchased the control, you need to download the file which has the Dev abbreviation in it.
  5. Once the download completes, unzip the files at a convenient location.
  6. If the upgrade is major (i.e. from v1.x to v2.x), check the Changes and Backward Compatibility section in this manual for further instructions.
  7. Back up your application.
  8. Close Visual Studio or any ither IDE which may lock the old assembly.
  9. From the newly downloaded and unzipped files, copy the new DLL (located in the bin folder) to your web-application's bin folder. Replace the old dll.
  10. [Optional. Follow this step only if you intend to use skins different from the default or if you plan to modify the JavaScript files
    Exceptions: Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products. ]
    Copy the new RadControls folder to the root of your web-application. Replace all files and folders when asked. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate the old folder and paste the new RadControls folder over it. Replace all files and folders when asked.
  11. If you are using VS.NET, update the control's reference in your project to point to the new DLL.
  12. Recompile your project.
  13. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadUpload to the Global Assembly Cache
  14. Run the project.
  15. If you still get the older version of Telerik RadUpload Hide click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadUpload's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadUpload, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....
  16. If you get a copyright message Show click here

    The copyright message appears only when using the trial version of Telerik RadUpload (the Developer versions of Telerik's controls do not throw copyright messages).

    If you have purchased the control, then you have downloaded the wrong "DLL and Scripts only" file. Make sure you you download the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

See Also

Adding Telerik RadUpload to an ASP.NET WebForm
Add/Remove Telerik RadUpload to the Global Assembly Cache
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Setting ASPNET (Network Service) Permissions

Telerik RadUpload v2.4 Send comments on this topic.
Setting ASPNET (Network Service) Permissions
Installation and deployment > Installation > Installing Telerik RadUpload on your computer > Setting ASPNET (Network Service) Permissions

Glossary Item Box

In most applications, users typically access Web applications anonymously — that is, they do not initially provide authentication credentials. In that case, the Web application has to assume (impersonate) some identity that it can use to request resources.
By default, when ASP.NET allows anonymous access, the application runs in the context of a special local (not domain) account. The user context depends on the operating system. In Windows 2000 and Windows XP, applications run under the account called ASPNET. In Windows Server 2003, the user context is called NETWORK SERVICE. These user accounts are created during the .NET Framework installation process with a unique, strong password, and are granted only limited permissions. The ASPNET or NETWORK SERVICE user can access only specific folders that are required to run a Web application, such as the \bin directory in which a Web application stores compiled files.

Full information on the topic can be found in MSDN: Security Considerations for ASP.NET Web Applications

Instructions on how to give process permissions on a folder - FAT32 file system

No need to give any permissions on the folder.

Instructions on how to give process permissions on a folder - NTFS file system

Internet Information Services v5.x - name of account: ASPNET user

  1. Right-click on the RadUpload (or Telerik_RadControls) folder and select Properties.
  2. Click on the Security tab. If you do not see the security tab, click Show here

    The Security tab is not visible because you have Simple File Sharing enabled. You will need to disable it before you continue. To do so:
    1. Open a Windows Explorer.
    2. On the Tools menu, click Folder Options, and then click the View tab.
    3. In the Advanced Settings section, clear the Use simple file sharing (Recommended) check box (at the bottom of the list).
    4. Click OK.
    5. Right-click on the folder you need to add ASPNET permissions to and select Properties. Click on the Security tab.

  3. Click on Add (to add a new user).

  4. Click on Locations to select your local machine. Your screen should look similar to the following:

    Setting ASPNET permissions

  5. Select your local machine and click OK.

  6. Type ASPNET in the textbox and click on Check Names. ASPNET should underline (if it doesn't then you don't have Microsoft's .NET framework installed).

    ASPNET user

  7. Click OK.

  8. Select the LOCAL MACHINE NAME/ASPNET user you just created (it should be named ASP.NET Machine Account (NAME/ASPNET)) and check the Full Control box to give it full permissions.

  9. Click APPLY.

  10. Click Advanced and make sure that the "Inherit from parent ..." check box is checked.

  11. Click OK to close the Advanced properties.

  12. Click OK to close the folder properties.

Internet Information Services v6.x - name of account: Network Service user

Same as above but replace ASPNET with Network Service.

© 2002-2008 Telerik. All Rights Reserved.


Trial License Limitations

Telerik RadUpload v2.4 Send comments on this topic.
Trial License Limitations
See Also
Installation and deployment > Installation > Installing Telerik RadUpload on your computer > Trial License Limitations

Glossary Item Box

Developer Licenses

Developer licenses come with modified DLLs, which work without license keys. If you have a Developer license for one or more of the Telerik components, you only need to ensure that you are using the developer build when downloading the control(s). These builds have the Dev abbreviation in their file names.

If your application is displaying a license key error, this means that you are using a trial version of the product. Log in to your Client.net account and download the developer build. To update your project, please take a look at the Upgrading the Trial License to a Production License section for step-by-step instructions.

Trial Licenses

The free trial licenses of all Telerik products are fully functional and will work for an unlimited time but with trial error messages (see below) displayed randomly on the page.

Trial error messages

The trial licenses will occasionally display the following message on your webform:

Telerik RadUpload 2.4 trial version. Copyright Telerik © 2002-2008. To remove this message, please, purchase a developer version .

See Also

License Agreement

© 2002-2008 Telerik. All Rights Reserved.


Files and folders needed by Telerik RadControls for ASP.NET

Telerik RadUpload v2.4 Send comments on this topic.
Files and folders needed by Telerik RadControls for ASP.NET
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > Files and folders needed by Telerik RadControls for ASP.NET

Glossary Item Box

Please, review the following KB article on the topic:

Which files and folders are mandatory to be on the server for Telerik RadControls for ASP.NET to function

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


The 'RadControls' Folder

Telerik RadUpload v2.4 Send comments on this topic.
The 'RadControls' Folder
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > The 'RadControls' Folder

Glossary Item Box

The RadControls folder is an essential part of Telerik RadControls for ASP.NET - it contains all resources needed for the components to function properly (i.e. images, client-side scripts, configuration files, skins, etc.).

You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files. However because of the specific control features, you will always need to copy /RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products.

Each Telerik component seeks its resources in the respective subfolder of RadControls: for example, /RadControls/Upload is the folder where the resources for Telerik RadUpload reside.

Copying the RadControls folder to your web application

To work with Telerik RadControls for ASP.NET, you need to copy the RadControls folder to your web application. The folder must contain all the subfolders of the controls you are going to use. Do not copy the subfolders of controls you are not planning to use as this may cause a number of compilation errors: Visual Studio 2005 compiles all files in the web project; errors occur when missing assemblies are not found.

Do not include the RadControls folder in your VS.NET solution! Hide Why?

When the RadControls folder is included in a VB.NET project, VS.NET tends to change some files within the RadControls folder automatically. The extent of these changes depends on the IDE settings; notably, the following controls are affected:
  • Telerik RadEditor
  • Telerik RadSpell
  • Telerik RadChart
Telerik controls are written in C# - hence the several *.CS codebehind files within the RadControls/[control] folder. When such .ASCX/ASPX files are included in the project, VS.NET automatically changes the Language attribute of their Page/Control directive from cs to vb and breaks the control.

To avoid the problem:
  1. In Windows Explorer, do a filtered search to locate all ASPX and ASCX files within the RadControls folder.
  2. Once the search is over, select all files and right-click to get their properties.
  3. Select the Hidden check box and click OK.
Now Visual Studio will not see the files, so errors will not be thrown. At the same time IIS will see the files and will display them fine.

If you have already included the RadControls folder in your VS2005 project:
  1. Open your Visual Studio 2005 project.
  2. In the Solution Explorer locate the RadControls folder and expand it.
  3. Locate the problematic ascx files, right-click them and select "Exclude from project". Unfortunately, this can be done for files only (unlike VS2003), so the process should be repeated for all ascx files.
  4. Open Windows Explorer, navigate to your project's folder.
  5. Back up the RadControls folder from your project, especially any customized files you may have (ConfigFile.xml, ToolsFile.xml, any css files, images. etc).
  6. Delete the damaged RadControls folder.
  7. Navigate to the installation folder of Telerik RadUpload (for example).
  8. Copy the RadControls folder from the installation folder to the root of your web application.
  9. Rebuild and run your project.

Moving the RadControls folder within your web-application

  1. Manually copy the RadControls folder to the new location within your web application (for example, ~/Resources/).
    Do not use the VS.NET IDE to copy/move the RadControls folder to another location as it changes the namespaces of the files and changes the project language from C# to VB which in turn breaks the application! Use Windows Explorer instead.
  2. Either:
    • Specify its position in the RadControlsDir property in the control's declaration in your ASCX/ASPX file, e.g.
      Copy Code
      <radU:RadUpload
      RadControlsDir="~/Resources/RadControls/" ...>
      </      radU:RadUpload>
    • Or set the property globally from the Web.config file of the application:
      Copy Code
      <configuration>
      <appSettings>
      <add key="Telerik.WebControls.RadControlsDir" value="~/Resources/RadControls/"/>
      </appSettings>
      </      configuration>
      Notes.
      • In the above examples, the tilde "~" represents the root of your web application.
      • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.

Moving the RadControls folder outside your web-application

This is the best scenario if you want to have a single RadControls folder for several applications. This mechanism also enables different versions of Telerik products to reside in different web applications:

  1. Manually copy the RadControls to the new location.
    Do not use the VS.NET IDE to copy/move the RadControls folder to another location as it changes the namespaces of the files and changes the project language from C# to VB, which in turn breaks the application! Use Windows Explorer instead.
  2. Create a virtual directory with name RadControls under each application's root which points physically to the same physical RadControls folder. That physical folder should include all the scripts and other required settings of the controls.
    The respective RadControls virtual directory should NOT be a web application but virtual directory only! You can find more information on the topic in the following KB article: (ID#728) Error Message: Could not load type 'Telerik.WebControls.Dialogs.Dialog'.
  3. Either:
    • Specify its position in the RadControlsDir property in the control's declaration in your ASCX/ASPX file, e.g.

    • Or set the property globally from the Web.config file of the application:
      Copy Code
      <configuration>
      <appSettings>
      <add key="Telerik.WebControls.RadControlsDir" value="~/RadControls/"/>
      </appSettings>
      </      configuration>
      Notes.
      • In the above examples, the tilde "~" represents the root of your web application.
      • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.
      • Make sure you set the RadControlsDir property to "~/RadControls/" (with a slash following the folder name).

"You have not copied the RadControls folder to the root folder of your web-application" error message

When opening a page which contains Telerik RadUpload, the following error message appears:
“Telerik RadUpload v2.4: You have not copied the RadControls folder to the root folder of your web-application or you have applied an update incorrectly."

This message shows that the control is not able to locate its RadControls/upload folder. It usually appears after updating the control to a newer version. The causes for the message to appear are:

  • The assembly version and the RadControls/upload folder version are from different installation downloads, i.e. from different Telerik RadUpload versions.
    Example: RadUpload.NET2.DLL is version 2.4.2, whereas the Telerik RadUpload's RadControls/Upload folder is from version 2.4.1 or other.
  • The proper assembly is in the bin folder of the application, but the RadControls/upload folder is missing or misplaced.

To solve the problem:

  1. Check whether the RadControls folder is placed in the root of your web application and that you have NOT set the RadControlsDir property to point to another location.
  2. Check whether the RadControls/upload folder contains a subfolder, named Scripts, and a subfolder which carries the version of the control as its name.
    For example, if you use Telerik RadUpload v2.4.2 - the folder should be \RadControls\Upload\Scripts\2_4_2 and this version number should match the RadUpload.NET2.dll version placed in the /bin folder.
    If such discrepancy exists between the control's assembly and the RadControls folder, use a DLL and RadControls folder from a working application or download the ZIP file from your Client.net account and use the files from there.
  3. Another reason could be that some files from the RadControls/upload folder are missing or damaged. Please delete the current RadControls folder and paste the original one from the same download that you have the assembly from.
  4. For some reason your project may still reference the previous version of control's DLL, and not the latest. In this case we suggest removing the old assembly reference from your VS.NET project and adding a new reference to to the new assembly.
  5. If you have added the control in the GAC (Global assembly cache), remove it by running gacUtil and then add the new version.
  6. If you are trying to move the RadControls folder through the RadControlsDir property, please review the following section for resolution:

  7. [not related to Telerik controls] Delete .NET, VS and browser caches because they can cause a problem too:

    1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
    2. Open a Windows Explorer and navigate to
      C:\Windows(WINNT)\Microsoft.NET\Framework\vYOUR_VERSION\Temporary ASP.NET Files
    3. Delete all the folders with names, corresponding to your Telerik projects.
    4. Delete your Visual Studio web project caches as well - they should be located at C:\Documents and Settings\VSWebCache.
    5. Delete your browser cache: Tools -> Internet Options -> Delete Files....

See Also

Setting the RadControlsDir property

© 2002-2008 Telerik. All Rights Reserved.


Setting the RadControlsDir property

Telerik RadUpload v2.4 Send comments on this topic.
Setting the RadControlsDir property
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > Setting the RadControlsDir property

Glossary Item Box

The RadControlsDir property can be set:

  • either from the ASPX/ASCX page where Telerik RadUpload resides (or programmatically, from the code behind),
  • or globally, for all controls in the web application, from the Web.config file.

To set RadControlsDir from the Web.config, add the following line inside the appSettings tag:

Notes.
  • In the above example, the tilde "~" represents the root of your web application.
  • You can change the location of the RadControls folder. The path given here is to serve only as an illustration.
  • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.
  • When you set the RadControlsDir property, its value does not automatically update other properties that contain URL strings. You need to update these properties manually.

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


Adding Telerik RadUpload to the Visual Studio 2005 Toolbox

Telerik RadUpload v2.4 Send comments on this topic.
Adding Telerik RadUpload to the Visual Studio 2005 Toolbox
See Also
Installation and deployment > Installation > Adding Telerik RadUpload to the Visual Studio 2005 Toolbox

Glossary Item Box

Telerik RadControls for ASP.NET are added automatically to the Visual Studio .NET 2005 Toolbox during installation. However if you are using the ZIP distribution, you can do this manually as described below.

To add Telerik RadUpload to the Toolbox manually and to be able to easily deploy the component in your WebForms in Design mode, follow the steps below:

  1. Open your application in Visual Studio 2005.
  2. Expand the Toolbox.

  3. Expand the General Section.

  4. Right-click in the General section and open Choose Items.

  5. On the .NET Framework Components tab, click Browse.

  6. Browse to the Telerik RadUpload installation folder, open the NET2 folder and from the bin subfolder, select the RadUpload.Net2.dll.

    • If the EXE was used to install Telerik RadControls for ASP.NET, the bin folder is located in
      C:\Program Files\Telerik\Telerik RadControls for ASP.NETQ1 2007\NET2\bin

    • If the ZIP was used to install Telerik RadUpload, the bin folder is located in the folder where the installation files have been unzipped (usually "\Inetpub\wwwroot\RadUpload_2_4\NET2"

  7. Click Open to confirm. The Telerik RadUpload icon should appear in the Toolbox.

  8. If you intend to use skins different from the default or if you plan to modify the JavaScript files, do not forget to copy the respective RadControls folder to the root of your application. For more information, see The 'RadControls' Folder.

See Also

Adding Telerik RadUpload to an ASP.NET WebForm

© 2002-2008 Telerik. All Rights Reserved.


Adding RadControls to the Visual Studio 2008 Toolbox

Telerik RadUpload v2.4 Send comments on this topic.
Adding RadControls to the Visual Studio 2008 Toolbox
Installation and deployment > Installation > Adding RadControls to the Visual Studio 2008 Toolbox

Glossary Item Box

Telerik RadControls for ASP.NET are added automatically to the Visual Studio .NET 2008 Toolbox during installation. However if you are using the ZIP distribution, you can do this manually as described below.

To add Telerik RadControls "Prometheus" for ASP.NET to the Toolbox manually and to be able to easily deploy the component in your WebForms in Design mode, follow the steps below:

  1. Open your application in Visual Studio 2008.
  2. Expand the Toolbox.

  3. Expand the General Section.

  4. Right-click in the General section and open Choose Items.

  5. On the .NET Framework Components tab, click Browse.

  6. Browse to the Telerik RadControls for ASP.NET installation folder, open the bin35 folder and select the Telerik.Web.UI.dll.

    • If the EXE was used to install Telerik RadControls for ASP.NET, the bin35 folder is located in
      C:\Program Files\Telerik\RadControls for ASPNET\bin35

    • If the ZIP was used to install Telerik RadControls, the bin35 folder is located in the folder where the installation files have been unzipped

  7. Click Open to confirm. The icons for all controls in the suite will appear in the Toolbox. Visual Studio 2008 toolbox

© 2002-2008 Telerik. All Rights Reserved.


Adding Telerik RadUpload to an ASP.NET WebForm

Telerik RadUpload v2.4 Send comments on this topic.
Adding Telerik RadUpload to an ASP.NET WebForm
Installation and deployment > Installation > Adding Telerik RadUpload to an ASP.NET WebForm

Glossary Item Box

To add Telerik RadUpload to an ASP.NET WebForm you can use either of the following approaches:

  • Drag the Telerik RadUpload icon from the Visual Studio Toolbox;

  • Write the Telerik RadUpload tag manually.

If you intend to use skins different from the default or if you plan to modify the JavaScript files, you also need to manually copy the Upload subfolder under the RadControls folder from the Telerik RadUpload installation folder to the root folder of your web application.

Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products.
If your RadControls folder contains multiple subfolders for Telerik controls - for example, if you are using a Telerik RadControls for ASP.NET installation as opposed to a Telerik RadUpload installation - make sure you copy only the subfolders of the controls you are going to use (Upload and any other controls you need). Do not copy the subfolders of controls you are not planning to use as this may cause a number of compilation errors: Visual Studio 2005 compiles all files in the web project; errors occur when missing assemblies are not found.

Adding Telerik RadUpload to a WebForm using Visual Studio .Net

The easiest way to deploy Telerik RadUpload is by dragging its icon from the Visual Studio .NET Toolbox in Design mode. Visual Studio will automatically copy the RadUpload.NET2.dll to the bin folder of your web-application and will create the respective references. You only have to copy the RadControls folder to the root folder of your web application as explained above.

Adding Telerik RadUpload to a WebForm manually

If you are not using Visual Studio .NET, you can deploy Telerik RadUpload manually. Follow the instructions below:

  1. Copy the RadControls folder from the Telerik RadUpload installation folder to the folder of your web application.

  2. Copy the RadUpload.NET2.dll from the bin folder of the Telerik RadUpload installation to the bin folder of your web application.

  3. Open your aspx/ascx file and add the Telerik RadUpload Register directive at the top:
    <%@ Register TagPrefix="radU" Namespace="Telerik.WebControls" Assembly="RadUpload.Net2" %>

    If you plan all pages in your application to use Telerik RadUpload you can add the following lines in your web.config file. In this case you don't need to add this directive in your pages.

    Copy Code
    <pages>
    <controls>
    <add tagPrefix="radU" namespace="Telerik.WebControls" assembly="RadUpload.Net2" />
    </controls>
    </    pages>

  4. Write the Telerik RadUpload tags in the body of the WebForm:

    Copy Code
    <radU:RadUpload ID="upload1" Runat="server">
    </    radU:RadUpload>
  5. Add any additional properties you need between the Telerik RadUpload tags.

Troubleshooting: the css styles do not apply correctly

If you have a Telerik control in a user control with output caching turned on you should manually register all the required CSS files in the head tag of your page. Otherwise the control will not be displayed correctly. The easiest way to do this is through a LINK element:

<link href="~/RadControls/Upload/Skins/[SkinName]/styles.css"rel="stylesheet"runat="server">

© 2002-2008 Telerik. All Rights Reserved.


Using IntelliSense in Visual Studio 2005

Telerik RadUpload v2.4 Send comments on this topic.
Using IntelliSense in Visual Studio 2005
Installation and deployment > Installation > Using IntelliSense in Visual Studio 2005

Glossary Item Box

Visual Studio 2005 automatically enables IntelliSense - through reflection it detects all classes, properties and methods in the dll file(s).

For additional convenience each Telerik control is provided an XML file which contains the comments for its classes, properties and methods.

For example, when Telerik RadUpload is dragged to the webform the RadUpload.Net2.xml file is automatically added in the bin directory of the project.

In ASPX, when you start typing or when you insert a space, VisualStudio will show a dropdown with suggestions for autocomplete.

In code-behind, each time a particular class/property/method is being selected from the dropdown of the autocomplete functionality, a tooltip with the comment for this class/property/method is displayed:

Intellisense in VS2005

© 2002-2008 Telerik. All Rights Reserved.


Using IntelliSense in Visual Studio 2008

Telerik RadUpload v2.4 Send comments on this topic.
Using IntelliSense in Visual Studio 2008
Installation and deployment > Installation > Using IntelliSense in Visual Studio 2008

Glossary Item Box

Visual Studio 2008 automatically enables IntelliSense - it detects all classes, properties and methods in the DLL file and the JavaScript code.

For additional convenience each Telerik control comes with an XML file which contains the comments for its classes, properties and methods.
When the Telerik control is dragged to the webform the XML file is automatically added in the bin directory of the project.
In ASPX, when you start typing or when you insert a space, Visual Studio will show a dropdown with suggestions for autocomplete:

ASPX AutoComplete

Visual Studio 2008 provides full Javascript Intellisense completion in ASPX files, HTM files, as well as in external JS files. It provides rich support for the ASP.NET AJAX client JavaScript framework and JavaScript code built with it:

In code-behind, each time a particular class/property/method is being selected from the dropdown of the autocomplete functionality, a tooltip with the comment for this class/property/method is displayed.

© 2002-2008 Telerik. All Rights Reserved.


Upgrading Telerik RadUpload v2.x Trial to Telerik RadUpload v2.x Developer license

Telerik RadUpload v2.4 Send comments on this topic.
Upgrading Telerik RadUpload v2.x Trial to Telerik RadUpload v2.x Developer license
Installation and deployment > Installation > Upgrading Instructions > Upgrading Telerik RadUpload v2.x Trial to Telerik RadUpload v2.x Developer license

Glossary Item Box

Follow the steps below to upgrade your Telerik RadUpload v2.4 Trial license to a Developer (production) license.

THE PROCEDURE DESCRIBED IN THIS MANUAL IS IRREVERSIBLE AND YOU MAY LOSE YOUR DATA IF THE INSTALLATION IS NOT CARRIED OUT CORRECTLY!

1. Back up Your Old Files

We strongly suggest that you back-up your old Telerik RadUpload files and folders, especially if you would like to use your old settings.

2. Obtain the Necessary File

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases".
  3. Locate the control that you need to install, i.e. Telerik RadUpload, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. Since you have purchased the control, make sure you are downloading the proper file - the Developer version has the Dev abbreviation in it.

3. Install and Copy the New Files

  1. Unzip the files at a convenient location.
  2. Check the Changes and Backward Compatibility section for introduced changes. If there are such, they should be applied a little later in the upgrade process.
  3. Back up your application if you haven't done so already.
  4. Close Visual Studio or any ither IDE which may lock the old assembly.
  5. From the newly downloaded and unzipped files, copy the new DLL (RadUpload.NET2.dll located in the bin folder) to your web-application's bin folder. Replace the old dll.
  6. Locate the old RadControls/Upload folder and delete it manually, i.e. using Windows Explorer. By default, the RadControls/Upload folder should be in the root of your application. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate it and delete it using Windows Explorer.
    DO NOT use Visual Studio to move, copy or delete the RadControls folder as this will break the Telerik control(s).
  7. If you intend to use skins different from the default or if you plan to modify the JavaScript files, copy the new RadControls/Upload folder to the same location as above.
  8. If using VS.NET, update the control's reference in your project to point to the new DLL.
  9. Follow the steps in the Changes and Backward Compatibility section in case there are some changes between the versions.
  10. Recompile your project.
  11. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadUpload to the Global Assembly Cache
  12. Run the project.
  13. If you still get the older version of Telerik RadUpload Hide click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadUpload's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadUpload, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....

  14. If you get a copyright message Hide click here

    The copyright message appears only when using the trial version of Telerik RadUpload (the Developer versions of Telerik's controls do not throw copyright messages). Make sure you have downloaded the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

5. Using the old ToolsFile.xml File and ConfigFile.xml file [valid for Telerik RadEditor and Telerik RadSpell only]

If you would like to use your old ToolsFile.xml and ConfigFile.xml files (which you backed up in #1 above), you can do so by copying them from the back-up to the RadControls\Editor folder (or RadControls\Spell respectively) of your web-application. When prompted to overwrite the other file, click "YES".

© 2002-2008 Telerik. All Rights Reserved.


Upgrading Telerik RadUpload v1.x Developer to Telerik RadUpload v2.x Developer license

Telerik RadUpload v2.4 Send comments on this topic.
Upgrading Telerik RadUpload v1.x Developer to Telerik RadUpload v2.x Developer license
Installation and deployment > Installation > Upgrading Instructions > Upgrading Telerik RadUpload v1.x Developer to Telerik RadUpload v2.x Developer license

Glossary Item Box

Follow the steps below to upgrade your Telerik RadUpload v1.x Developer license to Telerik RadUpload v2.4 Developer license.

These instructions are also valid for upgrading Telerik RadUpload v2.x Developer license to a newer Telerik RadUpload minor version.

THE PROCEDURE DESCRIBED IN THIS MANUAL IS IRREVERSIBLE AND YOU MAY LOSE YOUR DATA IF THE INSTALLATION IS NOT CARRIED OUT CORRECTLY!

1. Back up Your Old Files

We strongly suggest that you back-up your old Telerik RadUpload files and folders, especially if you would like to use your old settings.

2. Obtain the Necessary File

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases".
  3. Locate the control that you need to install, i.e. Telerik RadUpload, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. Since you have purchased the control, make sure you are downloading the proper file - the Developer version has the Dev abbreviation in it.

3. Install and Copy the New Files

  1. Unzip the files at a convenient location.
  2. Check the Changes and Backward Compatibility section for introduced changes. If there are such, they should be applied a little later in the upgrade process.
  3. Backup your application if you haven't done so already.
  4. Close Visual Studio or any ither IDE which may lock the old assembly.
  5. From the newly downloaded and unzipped files, copy the new DLL (RadUpload.NET2.dll located in the bin folder) to your web-application's bin folder. Replace the old dll.
  6. Locate the old RadControls/Upload folder and delete it manually, i.e. using Windows Explorer. By default, the RadControls/Upload folder should be in the root of your application. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate it and delete it using Windows Explorer.
    DO NOT use Visual Studio to move, copy or delete the RadControls folder as this will break the Telerik control(s).
  7. If you intend to use skins different from the default or if you plan to modify the JavaScript files, copy the new RadControls/Upload folder to the same location as above.
  8. If using VS.NET, update the control's reference in your project to point to the new DLL.
  9. Follow the steps in the Changes and Backward Compatibility section in case there are some changes between the versions.
  10. Recompile your project.
  11. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadUpload to the Global Assembly Cache
  12. Run the project.
  13. If you still get the older version of Telerik RadUpload Show click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadUpload's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadUpload, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....

  14. If you get a copyright message Show click here

    The copyright message appears only when using the trial version of Telerik RadUpload (the Developer versions of Telerik's controls do not throw copyright messages). Make sure you have downloaded the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

4. Using the old ToolsFile.xml File and ConfigFile.xml file [valid for Telerik RadEditor and Telerik RadSpell only]

If you would like to use your old ToolsFile.xml and ConfigFile.xml files (which you backed up in #1 above), you can do so by copying them from the back-up to the RadControls\Editor folder (or RadControls\Spell respectively) of your web-application. When prompted to overwrite the other file, click "YES"

© 2002-2008 Telerik. All Rights Reserved.


Add/Remove Telerik RadUpload to the Global Assembly Cache

Telerik RadUpload v2.4 Send comments on this topic.
Add/Remove Telerik RadUpload to the Global Assembly Cache
See Also
Installation and deployment > Deploying Telerik RadUpload into ASP.NET Applications > Add/Remove Telerik RadUpload to the Global Assembly Cache

Glossary Item Box

Add to Global Assembly Cache

There are two ways to add a control to the Global Assembly Cache (GAC):

Automatic

  1. Go to Start -> Settings -> Control Panel -> Administrative Tools -> Microsoft .NET Framework 2.0 Configuration
  2. Expand the nodes and locate Assembly cache
  3. Right-click on it and select Add:

    Microsoft .NET 2.0 Configuration panel
  4. Browse to the Telerik bin directory and ctrl-highlight the needed DLL's (the demo and DictionaryConfiguration DLLs are not needed).
  5. Click Open.

Manual

  1. Run the .NET command prompt (Start -> Programs -> Microsoft VS.NET -> VS.NET Tools -> VS.NET prompt) and start the gacutil.exe tool with -i parameter (install) and the name of the control, e.g.

    Copy Code
    gacutil.exe -i "C:\Program Files\Telerik\Telerik RadUpload2.4\NET1NET2\bin\RadUpload.Net2.dll"

    You may also directly copy the dll files to the "\WINDOWS\assembly" (or "\WINNT\assembly") folder of your server - this is equivalent to the effect of the gacutil.exe utility.

  2. Change the machine.config file of the server and add a reference to the assembly in the GAC. The machine.config file is the configuration file for all web applications on the server. It is located at: "\WINDOWS\Microsoft.NET\Framework\[Framework Version]\CONFIG". It is similar in to the web.config file, but the web.config only works for the web application, in which it resides.

    Locate the <assemblies> tag (which should be under <configuration><system.web> <compilation>/<compilers>/<assemblies> ) Between the <assemblies> tag, you should enter something similar to:

    Copy Code
    <add assembly="AssemblyFileName, Version=0.0.0.0, Culture=neutral, PublicKeyToken=5edf592a9c40680c" />

    To get the information that goes into the assembly attribute (version, culture, PublicKeyToken), you can run the gacutil /l command, which will return a list of all the assemblies in the GAC. You will have to look for the one you just added and copy the entire line (minus the Custom=null part at the end).
    For example the following command:

    Copy Code
    gacutil -l RadUpload.Net2

    will return:

    Copy Code
    RadUpload, Version=2.4.0.0, Culture=neutral, PublicKeyToken=e8ab424810b6b9b5 Custom=null

    so the correct entry in the machine.config should be:

    Copy Code
    <add assembly="RadUpload.Net2, Version=2.4.0.0, Culture=neutral, PublicKeyToken=e8ab424810b6b9b5" />

After that you should be able to use the control in all the application on the server without having to copy it to the "bin" folder of each web-application.

Remove from Global Assembly Cache

In order to remove Telerik RadUpload from GAC, please use the following command:

Copy Code
gacutil.exe -u radupload

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


Multi Targeting in Visual Studio 2008

Telerik RadUpload v2.4 Send comments on this topic.
Multi Targeting in Visual Studio 2008
See Also
Installation and deployment > Deploying Telerik RadUpload into ASP.NET Applications > Multi Targeting in Visual Studio 2008

Glossary Item Box

In Visual Studio 2008 you are able to build applications targeting multiple versions of the .NET Framework. Apart from ASP.NET 3.5, VS 2008 can open, edit and build ASP.NET 2.0 applications (applications with ASP.NET AJAX 1.0 as well). Visual Studio 2008 can also deploy these application on .NET 2.0 machines. You are able to easily build applications with RadControls targeting both ASP.NET 2.0 and ASP.NET 3.5.

See Also

External Link
See more information on how to use Multi Targeting in VS 2008

© 2002-2008 Telerik. All Rights Reserved.


Deploying Telerik RadUpload on Shared Hosting

Telerik RadUpload v2.4 Send comments on this topic.
Deploying Telerik RadUpload on Shared Hosting
Installation and deployment > Deploying Telerik RadUpload into ASP.NET Applications > Deploying Telerik RadUpload on Shared Hosting

Glossary Item Box

All Telerik controls are server controls and have to be installed on the web server in order to function properly. This also means that you will need to create the respective virtual directories and give the proper permissions (ASPNET [IIS5], NEtwork Service [IIS6]) in order to use them on the shared hosting.

If you have already created the application on your development machine

1. Copy/upload the compiled application via FTP to the production server, i.e. on the shared hosting. The application should reside in the inetpub/wwwroot folder.

2. Create a virtual directory for the application folder. Before you do this step, consult with your hosting provider on how this is to be accomplished. If the provider offers thorough instructions, use them instead of the ones below. If you do not have access to the Information Services console, ask your provider to set the application for you. If the provider does not offer instructions, then:

1. Locate the Internet Information Services console;

2. Navigate to the application folder;

3. Find the folder's Properties;

4. Create a virtual directory;

5. Remember the application name and click OK.

3. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (using IIS6 or IIS7, Windows Server 2003, Windows Vista/Longhorn) on the application folder. Again, before doing this step, consult with your hosting provider on how this is to be accomplished. If the provider offers thorough instructions, use them instead of the ones below. Otherwise, contact your provider to set the permissions for you.

4. Run the project.

Notes.

As the proper operation of some Telerik RadEditor elements need some external files to be loaded, a RadControls folder instance is needed for the control to run.

There are two possible RadControls folder usages:

  • Copy the RadControls folder within your web-application:

    Manually copy the RadControls folder to the new location within your web application (for example, ~/Resources/). Specify its position via the RadControlsDir property of the control's declaration: <radE:RadEditor RadControlsDir="~/Resources/RadControls/" ...></radE:RadEditor>, where the "~" (tilde) symbol in the path represents your web-application root directory.
  • Copy the RadControls folder outside your web-application (this is the best scenario if you would like to share the RadControls folder across multiple web applications): Manually copy the RadControls to the new location using Windows Explorer. Create a virtual directory with a preferred name (e.g. RadControls) under each application's root which points physically to the same physical RadControls folder.

    The respective RadControls virtual directory should NOT be a web application but virtual directory only! You can find more information on the topic in the following KB article: (ID#728) Error Message: Could not load type 'Telerik.WebControls.Dialogs.Dialog'.

    If the Virtual subfolder alias is different than RadControls, specify the virtual folder position via the RadControlsDir property in the editor's declaration in your ASCX/ASPX file
    <radE:RadEditor RadControlsDir="~/MyRadControls/" ...></radE:RadEditor>

    More information on the topic is available in the following help article: The 'RadControls' folder.

If you plan to deploy the controls directly on the shared hosting

1. Log in your Client.NET account.

2. Go to "My licenses" and click on "My Purchases" (or "My Free Trials" if you are a trial user).

3. Locate the needed control, and click on it.

4. Click on the "Download" tab to download the Manual installation (ZIP) file.

5. On the server, create a "Telerik" folder in your "inetpub/wwwroot" folder on the server.

6. If you intend to use skins different from the default or if you plan to modify the JavaScript files, create a new folder named RadControls in the inetpub/wwwroot/Telerik folder.

7. Follow the instructions from the first case above.

© 2002-2008 Telerik. All Rights Reserved.


Embedded Resources

Telerik RadUpload v2.4 Send comments on this topic.
Embedded Resources
Installation and deployment > Deploying Telerik RadUpload into ASP.NET Applications > Embedded Resources

Glossary Item Box

All Telerik RadControls for ASP.NET have their web resources embedded in the control assembly. Each control automatically fetches the required resources from the web. Embedded Resources are easier to manage because they require that you only maintain a single DLL for each RadControl when you upgrade versions/deploy applications. You no longer need to include the JavaScripts and the other related files with the RadControls folder in the root of your application. If you use external resources, you'll simply need to make sure you keep your DLLs and RadControls folders in sync when you upgrade and deploy.

Note that you still need the RadControls folder if you want to use a skin other than the Default.

You can control this functionality by setting the boolean property UseEmbeddedScripts.

When UseEmbeddedScripts is set to true (by default) web resources are streamed by the built-in web resource handler using a query string (like WebResource.axd?d=HTLSHE...). This scenario is suitable for easier deployment (no RadControls required).
The backside of using the embedded resources is that sometimes web resources are not cached (e.g. when your site is in debug mode <compilation debug="true" />). In addition the long query strings are adding bulk to the HTML you are sending to the client. Using external resources, i.e. the RadControls folder may nearly halve the page size due to the shorter resource paths. Your mileage may vary depending on the RadControls you are using.

If you set UseEmbeddedScripts to false, the control will use the necessary resources (files) from the RadControls folder. This is appropriate for example for cases when the web resource handler is disabled or when you have applied some modifications to the JavaScript or CSS files used by the control.

None of the functionality of the controls will change. Switching this property would only mean that you have to keep a local copy of the RadControls folder with the JS files in your application, since you are not going to use the embedded ones.
You cannot combine both methods for getting web resources, i.e. you cannot make the control take its scripts as embedded resources and skin file from RadControls.

© 2002-2008 Telerik. All Rights Reserved.


Trust level

Telerik RadUpload v2.4 Send comments on this topic.
Trust level
Installation and deployment > Deploying Telerik RadUpload into ASP.NET Applications > Trust level

Glossary Item Box

This topic refers the case you are trying to publish a site to a shared environment. The site is using the <RadControlName> component, where only the <RadControlName>.dll file exists in the /bin directory of the application along with the scripts directory (/RadControls/<ControlName>/Scripts) on the root.

All RadControls supports Medium trust level under shared hosting environment.

Note that a requirement for the RadControl is to have the trust level set to Medium at minimum - otherwise you may receive server error like the following:

Could not load type Telerik.RadUploadDesign.UploadComponentEditor from assembly mscorlib, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

To modify the trust level setting please follow the instructions below:

Locate the machine.config file placed in the \Microsoft.NET\Framework\v2.0.50727\CONFIG folder on your production server. Open it for editing and change the following line:

machine.config Copy Code
<trust level="Medium" originUrl=""/>

Further information about the different trust level options and their policies you can find in the MSDN:

http://msdn2.microsoft.com/en-us/library/tkscy493.aspx

http://msdn2.microsoft.com/en-us/library/wyts434y.aspx

© 2002-2008 Telerik. All Rights Reserved.


Troubleshooting deployment on the production server

Telerik RadUpload v2.4 Send comments on this topic.
Troubleshooting deployment on the production server
Installation and deployment > Deploying Telerik RadUpload into ASP.NET Applications > Troubleshooting deployment on the production server

Glossary Item Box

Since the Q2 2006 release our controls utilize webresources which is a new feature of ASP.NET 2.0. There are cases in which this may cause problems. For some reason requesting the webresource handler (webresource.axd) returns error number 404. This javascript files used by the control should be streamed by the web resource handler. As a result of the aforementioned error this does not happen and you may experience JavaScript errors on the client.

Here some tips how the problem can be solved:

First approach

  1. Open IIS management snap-in ( e.g. run inetmgr.exe)
  2. Right click your website and choose properties
  3. Go to the "Home Directory" tab and click the "Configuration" button
  4. A dialog should pop out and you would see the mappings listbox
  5. Find the entry for the ".axd" extension and edit it by clicking the "Edit" button
  6. In the new dialog uncheck the "Verify if file exist" checkbox - which I suspect is causing the problem.

Second approach

Alternatively, if the steps above don't solve the issue, you can try creating an empty WebResource.axd file in the site root folder.

Third approach

You can try setting UseEmbeddedScripts property to false. Thus the control will use the scripts from RadControls/Upload/Scripts folder instead the embedded resource.

© 2002-2008 Telerik. All Rights Reserved.


What is DNN (DotNetNuke)

Telerik RadUpload v2.4 Send comments on this topic.
What is DNN (DotNetNuke)
DNN > What is DNN (DotNetNuke)

Glossary Item Box

DotNetNuke (DNN) is an open source Portal and Content Management Framework, based on Microsoft's .NET technology. DNN offers a robust, extensible and fully functional framework for the development of a broad range of commercial portal applications.

For more information on DNN, visit the official DotNetNuke web site here.

DotNetNuke is able to create the most complex content management systems entirely with its built-in features, yet also allows administrators to work effectively with add-ons, third party assemblies, and custom tools. DNN modules and skins are easy to find, purchase, or build. Site customization and functionality are limitless.

© 2002-2008 Telerik. All Rights Reserved.


DNN Concepts

Telerik RadUpload v2.4 Send comments on this topic.
DNN Concepts
DNN > DNN Concepts

Glossary Item Box

What is a skinobject?

Skins Objects are active elements which can be included in the static HTML markup of a skin file to produce a dynamic user interface. There are a number of default skin objects included with DotNetNuke for common portal functions such as login, status, and navigation.

Custom skin objects are packaged and installed using the same process as Custom Modules ( Private Assemblies ). All of the necessary skin object resource files are combined with a DotNetNuke manifest file (*.dnn ) and packaged into a ZIP file. Example of a manifest file:

<?xml version="1.0" encoding="utf-8" ?>
<dotnetnuke version="2.0" type="SkinObject">
<folders>
 <folder>
  <name>CompanyName - PageTitle</name>
  <modules>
   <module>
    <controls>
     <control>
      <key>PAGETITLE</key>
      <src>PageTitle.ascx</src>
      <type>SkinObject</type>
     </control>
    </controls>
   </module>
  </modules>
  <files>
   <file>
    <name>PageTitle.ascx</name>
      </file>
   <file>
       <name>YourCompanyName.PageTitle.dll</name>
      </file>
  </files>
  </folder>
</folders>
</dotnetnuke>

For ASCX skins then you will need to specify the @Register and actual user control tag in your skin file ( ie. <dnn:Login runat="server" id="dnnLogin" /> ). If you are creating HTML skins then you simply need to specify the token ( ie. [LOGIN] ).

Skin objects support the concept of named instances. For example, if you want to have two menu controls in your skin, you can specify [MENU:1] and [MENU:2] in your skin file. In most cases you will only be using a single instance of a skin object in your skin and in this case it is fine to use a singleton instance specification ( ie. [MENU] ).

Skin objects also contain attributes. Each skin object has its own set of supported attributes. If you are creating ASCX skins then you will need to specify the attribute directly in your skin file ( ie. <dnn:Login runat=”server” id=”dnnLogin” Text=”Signin” /> ). If you are creating HTML skins then you must include your attributes specifications in a separate file – this preserves the presentation of the HTML skin file for the designer. A skin package can contain a global attributes specification named “skin.xml” (or “container.xml” for containers) which applies to all skin files in the package. In addition, you can also override the global skin attribute specification with a skin specific attribute specification by providing a “skinfilename.xml” file. The skin uploader will merge the skin attributes with the HTML presentation file to create an ASCX skin file. The following XML fragment represents the structure of the attributes file:

<Objects>
 <Object>
  <Token>[LOGIN]</Token>
  <Settings>
   <Setting>
    <Name>Text</Name>
    <Value>Sign in</Value>
   </Setting>
  </Settings>
 </Object>
</Objects>

There is a one to one correspondence of skin object declarations in your skin file (i.e. [MENU]) with the attribute specification in the XML file. This is also true for named instances.

What is a skin?

Skins are customized and interchangeable sets of graphics which allow administrators to easily change the look of their websites, without having to reorganize their content. In "skinning" a site, administrators can completely change the look of their portal without the need to reorganize content – all at the click of a button.

NOTE:

Since skins are based on ASCX files which are essentially executable once they are added to an ASPX page, there is some risk that malicious script could be inserted into the skin files – putting the entire installation in danger. Be sure to download skins only from trusted locations.

How do skins work?

DNN uses placeholders to separate the skin objects from the static markup which designers can then include in their skin. Placeholders are simply [TOKEN] text, which uniquely identify a skin object. To mitigate the performance impact of replacing these placeholders at runtime, DNN features a simple skin upload mechanism which does the substitution of placeholders with the skin objects to produce a user control file (.ascx) which can then be rendered by the engine. This pre-processing occurs only once when the skin is uploaded.

Skins can be applied at a host (the whole DNN install), portal (only one site), or tab (single page) level. Skins can also be applied at the module level (in this case they are referred to as Containers). All skin files are organized under the Portals folder. Child assignments are able to override parent assignments (i.e. a skin applied at the tab level should override a skin applied at the portal level).

A skin or container package is comprised of multiple files which constitute a complete skin:

*.htm, *.html files – abstract skin definition files which will be processed by the skin uploader to create an *.ascx file

*.ascx files – skin definition user controls which are precompiled in the format required by the skin engine.

*.css files – styles sheets related to skins

*.gif, *.jpg, *.jpeg, *.png – supporting graphics files

*.* – any other resource files required for the skin (allowable file extensions are secured by the Host “File Upload Extensions” setting)

Skin definitions can be created using two different methods, HTML or ASCX ( user controls ). Basically the only difference between the two methods is the file extension of the skin definition file and the use of tokens versus actual user control tags.

Content panes are the containers for the content modules which are automatically injected at runtime. Content panes are simply HTML tags with some custom attributes specified specifically an ID and a RUNAT=”SERVER” attribute ( ie. <TD ID=”ContentPane” RUNAT=”SERVER”>).

What is a Container?

As mentioned earlier, containers are skin definitions which can be applied to content modules. A container is defined in exactly the same manner as a skin except for the fact that there are a different set of skin objects used in containers.

What is a module?

Simply, they are modular pieces of code which provide some form of specific functionality to the user, and are grouped together in units to form complete web pages. These modules can be easily added, edited, deleted, restored, moved around on a page, or transferred to other pages. DotNetNuke installation includes over 25 free modules. These are: Account LogIn, Announcements, Banners, Contacts, Discussion, Documents, Events List/Calendar, FAQs, Feedback, IFrame, Image, Links, News Feed (RSS), Search Input, Search Results, Service Directory, Survey, Text/HTML, User Accounts, User Defined Table, Users Online, Weblog Calendar, Weblog Recent List, Weblog Referrals List, Weblogs, and XML/XSL.

© 2002-2008 Telerik. All Rights Reserved.


RadControls for DNN

Telerik RadUpload v2.4 Send comments on this topic.
RadControls for DNN
DNN > RadControls for DNN

Glossary Item Box

The Telerik RadControls suite is the most innovative and comprehensive tool set for ASP.NET development, tailored for seamless integration with the DotNetNuke project. This integrated collection of controls allows professionals to build web-solutions with the UI richness and responsiveness of desktop applications. From the WYSIWYG editor, to navigation, the RadControls DotNetNuke Edition allows you to substantially enhance the interface and usability of your DotNetNuke projects.

Telerik offers the following products for DNN:

  • RadMenu - SkinObject and a sample skin
  • RadPanelbar - SkinObject and a sample skin
  • RadTabstrip - SkinObject and and a sample skin
  • RadTreeview - SkinObject, a sample skin, and a module
  • RadEditor - HtmlEditorProvider (which can be used instead of the default DNN editor)
  • RadCalendar - SkinObject(which can be used instead of the default DNN calendar) and a module
  • RadGrid - a sample module
  • RadRotator - a module
  • RadAjax - a sample module

A SkinObject can be used as a component of a DNN skin. A SkinObject by itself is useless unless you make it a part of a skin. For example, consider the sample RadMenu skin:

SkinObject and skin
Enlarge Click to enlarge

A module can be inserted in a pane to provide some functionality. For example consider the RadCalendar module:

RadCalendar module
Enlarge Click to enlarge

© 2002-2008 Telerik. All Rights Reserved.


How to download RadUpload for DNN

Telerik RadUpload v2.4 Send comments on this topic.
How to download RadUpload for DNN
DNN > How to download RadUpload for DNN

Glossary Item Box

  1. Log in your Client.NET account.
  2. Go to Products -> RadControls for ASP.NET -> Download Trial
  3. Click on the individual products tab to expand the list of controls

    Enlarge Click to enlarge
  4. Click on a control to expand the list of available files for download

    Enlarge Click to enlarge
  5. Download the DNN module or skin

    Enlarge Click to enlarge

© 2002-2008 Telerik. All Rights Reserved.


Accessibility Compliance

Telerik RadUpload v2.4 Send comments on this topic.
Accessibility Compliance
See Also
Standards Compliance > Accessibility Compliance

Glossary Item Box

Compliance Level

  1. Telerik RadUpload is Level A compliant (in conformance with the W3C Web Accessibility Guidelines 1.0).
  2. Telerik RadUpload satisfies the requirements of "Section 508" for software accessibility. As a result the component can be used in US Federal Institutions and other organizations, which require software to be accessible to people with disabilities.

Section 508

The USA federal mandate requires that information technology be made accessible to people with disabilities. Much of Section 508 compliance concerns making Web sites, intranets, and web-enabled applications accessible. Section 508 compliance has since become a major prerequisite not only in government related software, but also in most enterprise and corporate software solutions.

W3C Web Content Accessibility Guidelines 1.0

The main goal of these guidelines is to encourage developers in creating applications providing accessible contents. Moreover, adhering to these guidelines will also make web content more accessible to all kind of users, using different devices and interfaces: desktop browser, voice browser, mobile phone, automobile-based personal computer, etc.

In accordance with these guidelines W3C defines three levels of conformance developers may implement in order to provide some level of content compliance to their products:

• Conformance Level "A"
• Conformance Level "Double-A"
• Conformance Level "Triple-A"

For more details on W3C "Web Content Accessibility Guidelines 1.0" see http://www.w3.org/TR/WAI-WEBCONTENT/

In our attempt to make our products compliant, each web-control we develop and its QSF strive to obtain at least one of conformance levels listed above.

See Also

XHTML Compliance

© 2002-2008 Telerik. All Rights Reserved.


XHTML Compliance

Telerik RadUpload v2.4 Send comments on this topic.
XHTML Compliance
See Also
Standards Compliance > XHTML Compliance

Glossary Item Box

Compliance Level

Telerik RadUpload provides complete XHTML compliance. The default HTML output generated is fully XHTML 1.1 compliant.

XHTML

XHTML stands for EXtensible HyperText Markup Language and it is a stricter and cleaner version of HTML recommended by W3C (World Wide Web Consortium). XHTML is the effective inheritor of HTML 4.01 and although it is almost identical to its predecessor it is aimed to replace it.

See Also

Accessibility Compliance

© 2002-2008 Telerik. All Rights Reserved.


Uploading Files with AJAX

Telerik RadUpload v2.4 Send comments on this topic.
Uploading Files with AJAX
AJAX Support > Uploading Files with AJAX

Glossary Item Box

RadUpload cannot upload files using AJAX calls. This is a limitation of the XmlHttpRequest component, used in all AJAX frameworks for asynchronous calls to the application. In order to upload a file you should perform a full page postback.

If you have automatically AJAX-enabled button or other control, which normally does postbacks, placed in UpdatePanel, RadAjaxPanel, RadGrid you could use one of the following workarounds to make the button to perform postbacks again.

Workaround for ASP.NET AJAX

You need to create a PostBackTrigger for the button which should initiate postback.

<asp:updatepanel runat="server" id="UpdatePanel1">
  <contenttemplate>
    <rad:radupload runat="server" id="RadUpload1" />
    <asp:button runat="server" id="ButtonSubmit" text="Postback" />
  </contenttemplate>
  <triggers>
    <asp:postbacktrigger controlid="ButtonSubmit" />
  </triggers>
</asp:updatepanel>

Workaround for RadAjaxPanel

Attach an event handler on the OnRequestStart client-side event of the RadAjaxPanel, which will disable the AJAX functionality if a specific button is clicked.

Note: The EventTarget property of the args parameter will contain the UniqueID of the clicked button.

<script type="text/javascript">
//on upload button click temporarily disables ajax to perform upload actions
function conditionalPostback(sender, args)
{
  if(args.EventTarget == "<%= ButtonSubmit.UniqueID %>")
  {
    args.EnableAjax = false;
  }
}
</script>
<rada:radajaxpanel runat="server" id="RadAjaxPanel1"
  clientevents-onrequeststart="conditionalPostback">
  <rad:radupload runat="server" id="RadUpload1" />
  <asp:button id="ButtonSubmit" runat="server" text="Upload" />
</rada:radajaxpanel>

Workaround for RadGrid

We use the same technique as in the previous workaround. Since the button which should initiate a postback is in a template, you cannot use its UniqueID directly, so we will check for its ID. Please, ensure that you have no other buttons with the same ID on your page.

Note: UpdateButton and PerformInsertButton are the IDs of the integrated in RadGrid Update and Insert buttons. If you have custom edit form with buttons with different IDs, you should use their IDs instead.

<script type="text/javascript">
//on insert and update buttons click temporarily disables ajax to perform upload actions
function conditionalPostback(e, sender)
{
  var re = new RegExp("\.UpdateButton$|\.PerformInsertButton$", "ig");
  if (sender.EventTarget.match(re))
  {
    sender.EnableAjax = false;
  }
}

</script>
<rad:radprogressmanager id="RadProgressManager1" runat="server"/>
<radg:radgrid runat="server" id="RadGrid1" enableajax="true">
  <clientsettings>
    <clientevents onrequeststart="conditionalPostback" />
  </clientsettings>
  <mastertableview>
    <columns>
      <radg:grideditcommandcolumn />
      <radg:gridtemplatecolumn uniquename="Upload">
        <itemtemplate>
           ...
        </itemtemplate>
        <edititemtemplate>
           <rad:radupload id="RadUpload1" runat="server" />
        </edititemtemplate>
      </radg:gridtemplatecolumn>
    </columns>
    <editformsettings>
      <editcolumn uniquename="EditCommandColumn1">
      </editcolumn>
    </editformsettings>
  </mastertableview>
</radg:radgrid>

Alternative workaround for both RadAjaxPanel and RadGrid

RadAjax automatically replaces all instances of "__doPostBack" inside the AJAX-enabled controls, such as those which are placed inside RadAjaxPanel. If you create a javascript function which calls __doPostBack in its body and call it instead of __doPostBack, you will be able to perform postbacks from AJAX-enabled controls.

Note: If you place the realPostBack function in an user control, make sure that it is not placed inside RadAjaxPanel or RadGrid, because they will automatically replace the call to __doPostBack in the realPostBack function body. In this case you will need to declare the realPostBack function in the ASPX page.

ASPX/ASCX

<script type="text/javascript">
function realPostBack(eventTarget, eventArgument)
{
   __doPostBack(eventTarget, eventArgument);
}
</script>
<rada:radajaxpanel runat="server" id="RadAjaxPanel1">
  <asp:button runat="server" id="ButtonSubmit" text="Upload" />
  <rad:radupload runat="server" id="RadUpload1" />
</rada:radajaxpanel>

C#

protected void Page_Load(object sender, EventArgs e)
{
  if (!IsPostback)
  {
    GetPostBackEventReference(this);
    ButtonSubmit.Attributes.Add("onclick",
      string.Format("realPostBack('{0}', ''); return false;", ButtonSubmit.UniqueID));
  }
}

VB.NET

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs) Handles Me.Load
  If Not IsPostBack Then
    GetPostBackEventReference(Me)
    ButtonSubmit.Attributes.Add("onclick", _
        String.Format("realPostBack('{0}', ''); return false;", ButtonSubmit.UniqueID))
  End If
End Sub

© 2002-2008 Telerik. All Rights Reserved.


Interoperability of Telerik RadUpload with RadAjax

Telerik RadUpload v2.4 Send comments on this topic.
Interoperability of Telerik RadUpload with RadAjax
AJAX Support > Interoperability of Telerik RadUpload with RadAjax

Glossary Item Box

Remark: The built-in AJAX functionality in telerik RadGrid, RadCombobox, RadTeeview has a higher priority than telerik RadAjax. You should turn it off in order to update outside controls and use AJAX Panel or AJAX Manager.
Important note: telerik RadUpload is unable to upload files with an Ajax call. This is related to the inability of the XmlHttpRequest component to upload files. This component is the core of any Ajax framework, such as telerik RadAjax or Atlas (AJAX extensions for ASP.NET).

Telerik RadUpload is designed for seamless interoperability with the Telerik AJAX framework, the RadAjax suite enabling developers to implement the following functionality:

  • AJAXify (AJAX-enable) telerik RadUpload to work with AJAX instead of regular postbacks;
  • Update the telerik RadUpload control upon an AJAX request made by a control on the page via telerik RadAjax;
  • Make telerik RadUpload initiate an AJAX request in order to update other controls on the page.

Make telerik RadUpload work with AJAX requests (Ajax-enable Telerik RadUpload)

You can ajaxify any member of the telerik RadControls for ASP.NET suite. The ajax-enabled control will work in AJAX mode and will perform callback requests instead of regular postbacks.

To do so, you have two possible options:

  • place the instance of RadUpload into an AjaxPanel - in this case, the control will update itself and all other controls in the panel via AJAX request
  • place one AJAX Manager on the page and in its property builder set the AJAX pair, i.e. AJAX initiator and the updated control. In this case, as we want Telerik RadUpload to update itself with AJAX, it should be set as initiator and updated control.

Update telerik RadUpload upon AJAX request

Telerik RadUpload is fully compatible with the telerik RadAjax suite and can be updated via callbacks from any other control on the page without any additional coding. You have two possible options:

  • You need to have the AJAX Manager on the page and set the AJAX pair - AJAX initiator and the updated control (telerik RadUpload in this case). We recommend you do this using the visual editor in VS.NET.
  • Alternatively you can place telerik RadUpload in AJAX Panel together with the control that should update it.

Initiate an AJAX request and update other controls with Telerik RadUpload

You may want to initiate a callback request by telerik RadUpload and update other controls on the page.

To implement this functionality, you need to do the following:

  • Place AJAX Manager on the page. Open its property builder and set the AJAX pair. In this case Telerik RadUpload will be the AJAX initiator. You can set as many controls as you wish to be updated by a single request.

OR

  • Place both controls (telerik RadUpload and the control that should be updated) in AJAX Panel. telerik RadUpload will automatically start updating all controls in the panel (including itself) with AJAX requests.

More integration examples of telerik RadAjax with the other controls from the telerik RadControls for ASP.NET suite can be seen here.

© 2002-2008 Telerik. All Rights Reserved.


ASP.NET AJAX Framework

Telerik RadUpload v2.4 Send comments on this topic.
ASP.NET AJAX Framework
AJAX Support > ASP.NET AJAX Framework

Glossary Item Box

Show All Show All
Hide All Hide All

All Telerik controls now provide full support for the new ASP.NET AJAX framework.
Telerik's own patent-pending AJAX mechanism does not interfere in any way with the ASP.NET AJAX framework. Telerik RadAjax, as well as all built-in AJAX features of Telerik RadControls for ASP.NET work with ASP.NET AJAX without any conflict.

To enable ASP.NET AJAX with Telerik RadUpload:

  1. Make sure you have the ASP.NET AJAX framework installed.
  2. If the control is initially invisible and is shown after an ASP.NET AJAX update, you should manually register all the required CSS files in the head tag of your page. Otherwise the control will not be displayed correctly. The easiest way to do this is through a LINK element:
    Copy Code
    <link href="~/RadControls/Upload/Skins/[SkinName]/styles.css" rel="stylesheet" runat="server" >
  3. Place the instance of Telerik RadUpload in an ASP.NET AJAX UpdatePanel.

To enable or disable the ASP.NET AJAX UpdatePanel, set the EnablePartialRendering property of the ScriptManager class to True or False accordingly.

Grid built-in AJAX has higher priority than external AJAX frameworks - ASP.NET AJAX and RadAjax. In case one need the Grid to be updated from an ASP:UpdatePanel, Grid's EnableAJAX should be turned off.

ASP.NET AJAX is not a Telerik product.
For further information about ASP.NET AJAX, refer to ASP.NET AJAX documentation .

Known problems related to ASP.NET AJAX interoperability

Exceptions

If you receive exceptions such as:

System.Web.HttpException: The Controls collection cannot be modified because the control contains code blocks (i.e. <% ... %>)

you need to move the code block outside of the head tag. For example:

Before: Copy Code
<head runat="server">
<script>
var controlClientObject = <%= RadControl1.ClientID %>
...
</script>
</head>

<body>
...
</body>
After: Copy Code
<head runat="server">
</head>
<body>
<script>
var controlClientObject = <%= RadControl1.ClientID %>
...
</script>
...
</body>

© 2002-2008 Telerik. All Rights Reserved.


RadMemoryOptimization

Telerik RadUpload v2.4 Send comments on this topic.
RadMemoryOptimization
Uploading Files > RadMemoryOptimization

Glossary Item Box

General Information

By default, when a file is uploaded the .NET Framework stores it in the memory, thus significantly reducing the maximum possible size of the uploaded files. Sometimes, when uploading very large files, it is possible to encounter application restarts due to reaching the upper memory limit of the .NET framework.

When RadMemoryOptimization is enabled, the uploaded files are extracted from the request stream and then stored into a temporary location on the web server hard disk, thus allowing uploads of files with size up to 2GB. During the extraction process, you can monitor the progress of the upload. The temporary files are deleted at the end of each request.

How to enable RadMemoryOptimization

In order to enable RadMemoryOptimization for a specific page you need to:

  1. Register RadUploadHttpModule in the application web.config.
  2. If you want to upload files, larger than 4MB, you should configure your application.
  3. Put a RadProgressManager control on the page which will be used for file uploads.

Note: When RadMemoryOptimization is enabled on a page, the ASP.NET FileUpload controls and the Standard File Inputs will be unable to find their files automatically. You can obtain their uploaded files by using the RadUploadContext object. RadUpload is able to find its files automatically.

Important Notes

RadMemoryOptimization is not functional when the application is hosted in IIS7. Host your project in IIS5 (Windows 2000), IIS5.1 (Windows XP), IIS6 (Windows 2003) or the VisualStudio 2005 Web Development Server (FileSystem based Web Site).

RadMemoryOptimization is not compatible with the ASP.NET application trace. If you enable the application trace the server will receive only the first 30-50kB of the selected files and then the upload will hang.

RadMemoryOptimization requires ReflectionPermission in order to operate correctly. This means that in normal circumstances you will have to run your application with Full Trust permission set, unless you create custom security policy, which allows ReflectionPermission. If you are unable to set Full Trust or custom security policy, the solution is to put the RadUpload assembly in GAC.

RadUploadContext

When RadMemoryOptimization is enabled you can access all uploaded files within the current request using the RadUploadContext object. You can obtain an instance of this object using its static (shared in VB.NET) property Current. The UploadedFiles collection of this instance contains all files, uploaded within the current request, including those selected with RadUpload controls and those, selected with regular <input type=file> elements.

VB.NET

Imports Telerik.WebControls
...
Protected Sub Button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    Dim uploadContext As RadUploadContext = RadUploadContext.Current
    ...
End Sub

C#

using Telerik.WebControls
...
protected void Button1_Click(object sender, EventArgs e)
{
    RadUploadContext uploadContext = RadUploadContext.Current;
    ...
}

You can find another example involving RadUploadContext in Saving the files, uploaded with FileUpload controls.

© 2002-2008 Telerik. All Rights Reserved.


Uploading Large Files

Telerik RadUpload v2.4 Send comments on this topic.
Uploading Large Files
Uploading Files > Uploading Large Files

Glossary Item Box

In order to allow uploading of files with size up to 2GB you should make some modifications in your application web.config file.

Important Notes

The configuration file sections and attributes are case sensitive. This means that the sections and attributes below will be incorrect if they are written using a case other than shown the examples.

maxRequestLength

Specifies the limit for the input stream buffering threshold, in KB. This limit can be used to prevent denial of service attacks that are caused, for example, by users posting large files to the server. The default value is 4096 (4 MB).

To enable large file uploads you need to change the value of this attribute to the largest allowed combined file size for your application. If someone selects and uploads files, with total size larger than maxRequestLength, he / she will get "Page not found" error (which is the default error of the Framework). Currently, RadUpload does not provide a way for handling this error.

Note: the MaxFileSize property of RadUpload specifies the maximum size for each of the uploaded files in bytes.

executionTimeout

Specifies the maximum number of seconds that a request is allowed to execute before being automatically shut down by ASP.NET. The value of this setting is ignored in debug mode. The default in .NET Framework 2.0 is 110 seconds. In the .NET Framework 1.0 and 1.1, the default is 90 seconds.

To enable large file uploads, which go on for large periods of time, you should increase the value of this property.

More Information

You can find more information about the httpRuntime configuration in the following MSDN article: http://msdn2.microsoft.com/en-us/library/e1f13641.aspx

responseDeadlockInterval

Specifies the time interval, in the format HH:MM:SS, after which the process will be restarted if the following conditions are met:

  • There are queued requests.
  • There has not been a response during this interval. The default is 3 minutes. To allow very large uploads, you may have to increase this value.

This property must be set in machine.config, not at the application level in web.config. It will affect any response deadlock in ASP.NET and should be used with caution.

responseRestartDeadlockInterval

Specifies the time, in the format HH:MM:SS, that must elapse after the last restart to cure a deadlock before the process is restarted to cure a deadlock again. This prevents thrashing on processes that require a relatively long startup time. The default is 9 minutes. To allow very large uploads, you may have to increase this value. This property must be set in machine.config, not at the application level in web.config. It will affect any response deadlock in ASP.NET and should be used with caution.

AspMaxRequestEntityAllowed

Sometimes when the application is hosted on Windows Server 2003 the settings above do not seem to have effect. In this case you need to modify the IIS metadata file, particulary the AspMaxRequestEntityAllowed property. You can find more information about that in the following KB article:

http://www.telerik.com/support/kb/article/b454K-gth-b454T-cee.aspx

Microsoft URLScan

If you are using Microsoft URLScan you will have to modify its urlscan.ini and set MaxAllowedContentLength with appropriate value.

Third party network monitoring software

If you are using any third party network monitoring software you should ensure that it is properly configured to allow file uploads with the needed length and content. For more information please, contact your network administrator.

How to modify web.config

In order to configure your application for large file uploads you need to:
  1. Open the Solution Explorer pane, navigate to the application web.config file and open it.
  2. Under the <configuration> element locate the <system.web> element. Add it if it does not exist.
  3. Under the <system.web> element locate the <httpRuntime> element. Add it if it does not exist.
  4. In the <httpRuntime> element locate the maxRequestLength and executionTimeout attributes. If they do not exist, add them and set their values:

<httpRuntime maxRequestLength="102400" executionTimeout="3600" />

The configuration, allowing uploads of files up to 100MB and upload periods up to 1 hour, should look like this:

<configuration>
  ...
  <system.web>
    <httpRuntime maxRequestLength="102400" executionTimeout="3600" />
    ...
  </system.web>
</configuration>

© 2002-2008 Telerik. All Rights Reserved.


Known Limitations

Telerik RadUpload v2.4 Send comments on this topic.
Known Limitations
Uploading Files > Known Limitations

Glossary Item Box

The controls in the Telerik RadUpload suite use and extend the existing API of the browsers and the .NET framework. However, due to some known restrictions, our controls are unable to provide the below stated functionality in certain conditions:

  1. RadUpload cannot upload files using AJAX calls. This is a limitation of the XmlHttpRequest component, used in the AJAX frameworks for asynchronous calls to the application. In order to upload a file you should perform a full page postback. We provide several workarounds which can be used to disable AJAX for certain button in most of the scenarios.
  2. RadMemoryOptimization is not compatible with the ASP.NET application trace. If you enable the application trace the server will receive only the first 30-50kB of the selected files and then the upload will hang.
  3. RadMemoryOptimization is still not compatible with IIS7 and will be disabled if you develop using Windows Vista. RadProgressArea will not be operational in this environment as well.
  4. RadUpload is unable to check the size and the mime-type of the selected files before upload because of a security restriction of the JavaScript engine in the popular browsers. You cannot access the client file system with JavaScript, hence the inability to get the file size, mime type or content.
  5. RadUpload is unable to select multiple files in one file select box. This is a limitation of the standard <input type=file> elements which are used for file selection in RadUpload. Currently, we have no plans for improving this functionality.
  6. RadUpload is unable to have initially selected files or to persist the selected files across postbacks. This is a security limitation of the standard <input type=file> elements which are used for file selection in RadUpload.
  7. RadUpload is unable to set the width of the file select boxes in Mozilla/Firefox due to a browser bug, which prevents the <input type=file> elements from applying the style which modifies their width. More information is available in Modifying File Input Appearance.
  8. RadMemoryOptimization requires ReflectionPermission in order to operate correctly. This means that in normal circumstances you will have to run your application with Full Trust permission set, unless you create custom security policy, which allows ReflectionPermission. If you are unable to set Full Trust or custom security policy, the solution is to put the RadUpload assembly in GAC.

© 2002-2008 Telerik. All Rights Reserved.


Using Forms Authentication

Telerik RadUpload v2.4 Send comments on this topic.
Using Forms Authentication
Uploading Files > Using Forms Authentication

Glossary Item Box

This topic is applicable only for .NET 2.0 applications.

RadProgressManager searches for RadUploadProgressHandler in the root directory of the application:

http://YourServerName/ApplicationName/Telerik.RadUploadProgressHandler.aspx

In order to ensure the proper operation of RadUploadProgressHandler you need to allow access to unauthenticated users to the path above. Put the following text in your application web.config:

<location path="Telerik.RadUploadProgressHandler.aspx">
    <system.web>
        <authorization>
           <allow users="*"/>
        </authorization>
    </system.web>
</location>

You can find more information about the location section in this MSDN article.

The configuration file sections and attributes are case sensitive. This means that the above sections and attributes will be incorrect if they are written using a case other than shown the example.

© 2002-2008 Telerik. All Rights Reserved.


Using TargetFolder
Uploading Files > RadUpload > Using TargetFolder

Glossary Item Box

Important notes

The selected files must be transferred to the server in order to be validated for size or mime-type. The file extensions can be validated on the client, before the upload.

To enable uploading of files, larger than 4MB, you must set the maxRequestLength attribute of the httpRuntime section in your web.config file.

Using TargetFolder

In order to use the automatic file saving, the TargetFolder property must be set to an existing virtual path. This virtual path will be internally resolved to a physical path by calling the Server.MapPath() method.

The TargetPhysicalFolder property is provided for the cases where the files must be automatically saved to a physical path. If you set both TargetFolder and TargetPhysicalFolder properties, RadUpload will use TargetPhysicalFolder.

When one of the properties above was set, the uploaded files will be validated if the validation has been enabled. Then the valid files will be saved in the specified location with their original names from the client computer. If a file with the same name already exists on the server it may be overwritten, depending the value of the OverwriteExistingFiles property.

The example below demonstrates how to implement automatic file saving. The uploaded files will be saved in the "~/MyFiles" folder, overwriting the existing files:

<rad:radupload ID="RadUpload1" Runat="server"
    OverwriteExistingFiles="true"
    TargetFolder="~/MyFiles" />
<asp:button Runat="server" ID="Button1" Text="Submit" />

The FileExists event

The FileExists event is fired when one of the TargetFolder or TargetPhysicalFolder properties was set, the OverwriteExistingFiles property was set to false and there is already a file with the same name as the currently uploaded file.

You can use this event to save the existing uploaded files with a different name.
The example below demonstrates how to rename the existing files by handling the FileExists event:
<rad:radupload ID="RadUpload1" Runat="server"
    OverwriteExistingFiles="false"
    TargetFolder="~/MyFiles"
    OnFileExists="RadUpload1_FileExists" />
<asp:button Runat="server" ID="Button1" Text="Submit" />

VB.NET

Imports Telerik.WebControls
...
Protected Sub RadUpload1_FileExists(ByVal sender As Object, ByVal e As UploadedFileEventArgs)
    Dim counter As Integer = 1

    Dim file As UploadedFile = e.UploadedFile

    Dim targetFolder As String = Server.MapPath(RadUpload1.TargetFolder)

    Dim targetFileName As String = System.IO.Path.Combine(targetFolder, _
        file.GetNameWithoutExtension & counter & file.GetExtension)

    While System.IO.File.Exists(targetFileName)
        counter += 1
        targetFileName = System.IO.Path.Combine(targetFolder, _
            file.GetNameWithoutExtension & counter & file.GetExtension)
    End While

    file.SaveAs(targetFileName)
End Sub

C#

using Telerik.WebControls;
...
protected void RadUpload1_FileExists(object sender, UploadedFileEventArgs e)
{
    int counter = 1;

    UploadedFile file = e.UploadedFile;

    string targetFolder = Server.MapPath(RadUpload1.TargetFolder);

    string targetFileName = System.IO.Path.Combine(targetFolder,
        file.GetNameWithoutExtension() + counter.ToString() + file.GetExtension());

    while (System.IO.File.Exists(targetFileName))
    {
        counter ++;
        targetFileName = System.IO.Path.Combine(targetFolder,
            file.GetNameWithoutExtension() + counter.ToString() + file.GetExtension());
    }

    file.SaveAs(targetFileName);
}

© 2002-2008 Telerik. All Rights Reserved.


Manipulating the Uploaded Files

Telerik RadUpload v2.4 Send comments on this topic.
Manipulating the Uploaded Files
Uploading Files > RadUpload > Manipulating the Uploaded Files

Glossary Item Box

Important notes

The selected files must be transferred to the server in order to be validated for size or mime-type. The file extensions can be validated on the client, before the upload.

To enable uploading of files, larger than 4MB, you must set the maxRequestLength attribute of the httpRuntime section in your web.config file.

Using the server-side API

If you need to perform additional actions on the uploaded files before saving them, you can use the server-side API. This way you can rename the uploaded files or save them into a database, or other storage medium.

Do not set TargetFolder or TargetPhysicalFolder if you decide to use the server-side API to manipulate the uploaded files. If you use both methods you may end with two copies of the uploaded files.

If the validation has been enabled, the uploaded files will be first validated. The valid files can be accessed using the UploadedFiles collection and the invalid files - using the InvalidFiles collection.

The most important methods and properties in the RadUpload server-side API are:

    • RadUpload class
      UploadedFiles - contains the uploaded files, which passed the validation, or all uploaded files if the validation was not enabled
      InvalidFiles - contains the uploaded files, which did not passed the validation
    • UploadedFile class
      ContentLength - returns the size of the uploaded file in bytes
      FileName - returns the full client-side path of the file (IE6 and some older browsers only). To get equal behavior with all browsers you should use GetName() method to obtain the name of the uploaded file.
      GetName() - returns the name of the uploaded file
      GetNameWithoutExtension() - returns the name of the uploaded file, without the extension
      GetExtension() - returns the extension of the uploaded file, including the leading dot (.)
      InputStream - provides access to the file content
      SaveAs() - saves the uploaded file to the specified location

Using the SaveAs() method

This example below demonstrates how to save the uploaded files to a location of your choice:

ASPX/ASCX

<rad:radupload ID="RadUpload1" Runat="server" />
<asp:button Runat="server" ID="Button1" Text="Submit"
    onclick="Button1_Click" />

VB.NET

Imports Telerik.WebControls
...
Protected Sub Button1_Click(ByVal sender As Object, ByVal e As System.EventArgs)
    For Each f As UploadedFile In RadUpload1.UploadedFiles
        f.SaveAs("c:\my files\" & f.GetName, True)
    Next
End Sub

C#

using Telerik.WebControls;
...
protected void Button1_Click(object sender, System.EventArgs e)
{
    foreach (UploadedFile f in RadUpload1.UploadedFiles)
    {
        f.SaveAs("c:\\my files\\" + f.GetName(), true);
    }
}

Using the InputStream property

You can use the InputStream property to access the content of the uploaded files without saving them to a temporary location. This property is useful when you want to insert the file into a database.

The following example demonstrates how to insert the uploaded files into a database using OleDb:

VB.NET

Imports System.Data.OleDb
Imports Telerik.WebControls
...
Protected Sub Button1_Click(ByVal sender As Object, ByVal e As System.EventArgs)
    For Each file As UploadedFile In RadUpload1.UploadedFiles
        Dim bytes(file.InputStream.Length) As Byte
        file.InputStream.Read(bytes, 0, file.InputStream.Length)

        Dim connection As OleDbConnection = CreateConnection()
        Try
            Dim command As OleDbCommand = New OleDbCommand(
                "INSERT INTO Images ([Name], [Size], [Content]) VALUES (?, ?, ?)",
                connection)
            command.Parameters.AddWithValue("@Name", file.GetName)
            command.Parameters.AddWithValue("@Size", bytes.Length)
            command.Parameters.AddWithValue("@Content", bytes)

            connection.Open()
            command.ExecuteNonQuery()
        Finally
            If (connection.State = Data.ConnectionState.Open) Then
                connection.Close()
            End If
        End Try
    Next
End Sub

C#

using System.Data.OleDb;
using Telerik.WebControls;
...
protected void Button1_Click(object sender, System.EventArgs e)
{
    foreach (UploadedFile file in RadUpload1.UploadedFiles)
    {
        byte[] bytes = new byte(file.InputStream.Length);
        file.InputStream.Read(bytes, 0, file.InputStream.Length);

        OleDbConnection connection = CreateConnection()
        try
        {
            OleDbCommand command = New OleDbCommand(
                "INSERT INTO Images ([Name], [Size], [Content]) VALUES (?, ?, ?)",
                connection);
            command.Parameters.AddWithValue("@Name", file.GetName());
            command.Parameters.AddWithValue("@Size", bytes.Length);
            command.Parameters.AddWithValue("@Content", bytes);

            connection.Open();
            command.ExecuteNonQuery();
        }
        finally
        {
            if (connection.State == Data.ConnectionState.Open)
            {
                connection.Close();
            }
        }
    }
}

© 2002-2008 Telerik. All Rights Reserved.


Integrated Validation

Telerik RadUpload v2.4 Send comments on this topic.
Integrated Validation
Uploading Files > RadUpload > Integrated Validation

Glossary Item Box

Important notes

The selected files must be transferred to the server in order to be validated for size or mime-type. The file extensions can be validated on the client, before the upload.

To enable uploading of files, larger than 4MB, you must set the maxRequestLength attribute of the httpRuntime section in your web.config file.

Validation

RadUpload can automatically validate the size, the extension and the mime-type of the uploaded files against your preferences. It is only necessary to set the values of the needed RadUpload validation properties:

  • Set the AllowedFileExtensions property to enable the file extension validation. You can set multiple file extensions if you set the value of this property to a comma separated list in the ASPX or a string array in the code-behind. You can also easily validate the file extensions client-side. The following example demonstrates how to set multiple file extensions in the ASPX and in the code-behind:

ASPX

<rad:radupload id="RadUpload1" runat="server"
    allowedfileextensions=".zip,.jpg,.jpeg" />

VB.NET

RadUpload1.AllowedFileExtensions = New String() {".zip", ".jpg", ".jpeg"}

C#

RadUpload1.AllowedFileExtensions = new string[] {".zip", ".jpg", ".jpeg"};

Note: you must include the leading dot (.) in the file extension.
  • Set the AllowedMimeTypes property to enable the mime-type validation.
    Note: there are several file extensions that have multiple mime-types associated with them, and the different browsers send different mime-type for the same file. For these types of files you need to set all associated mime-types of the file extension in order to ensure the proper validation.     You can set multiple mime-types the same way as setting multiple file extensions.
  • Set the MaxFileSize property a to enable the file size validation. The value of this property specifies the maximal allowed uploaded file size in bytes.

The valid files can be accessed using the UploadedFiles property. The invalid files can be accessed using the InvalidFiles property if needed.

After the validaton the valid files will be automatically saved to the specified location if one of the TargetFolder or TargetPhysicalFolder properties has been set.

This example demonstrates how to configure RadUpload to receive only ZIP files with size less than 1000000 bytes. Note that RadUpload is configured to allow all mime-types associated with the .zip file extension. The valid files will be automatically saved to the "~/My files" folder.

ASPX:

<rad:radupload id="RadUpload1" runat="server"
   allowedmimetypes="application/x-compressed,application/x-zip-compressed,application/zip,multipart/x-zip"
   maxfilesize="1000000" AllowedFileExtensions=".zip"
   targetfolder="~/My Files" />
<asp:button runat="server" id="Button1" text="Submit" onclick="Button1_Click" />

Why are my files considered invalid?

Sometimes some files are considered invalid, even if they seem valid. You can visually check the reasons for this using the following code:

VB.NET

Imports Telerik.WebControls
...
Protected Sub Button1_Click(ByVal sender As Object, ByVal e as EventArgs)
    Response.Write("Settings of " & RadUpload1.ID & "<br/>")
    Response.Write("AllowedMimeTypes " & String.Join(",", RadUpload1.AllowedMimeTypes) & "<br/>")
    Response.Write("AllowedFileExtensions " & String.Join(",", RadUpload1.AllowedFileExtensions) & "<br/>")
    Response.Write("MaxFileSize " & RadUpload1.MaxFileSize & " bytes<br/><br/>")

    For Each f As UploadedFile In RadUpload1.InvalidFiles
        Response.Write("File name: " & f.GetName() & "<br />")
        Response.Write("File extension: " & f.GetExtension() & "<br />")
        Response.Write("Mime-type: " & f.ContentType & "<br />")
        Response.Write("File size: " & f.ContentLength & " bytes<br />")
    Next
End Sub

C#

using Telerik.WebControls;
...
protected void Button1_Click(object sender, EventArgs e)
{
    Response.Write("Settings of " + RadUpload1.ID + "<br/>");
    Response.Write("AllowedMimeTypes " + string.Join(",", RadUpload1.AllowedMimeTypes) + "<br/>");
    Response.Write("AllowedFileExtensions " + string.Join(",", RadUpload1.AllowedFileExtensions) + "<br/>");
    Response.Write("MaxFileSize " + RadUpload1.MaxFileSize + " bytes<br/><br/>");

    foreach (UploadedFile f in RadUpload1.InvalidFiles)
    {
        Response.Write("File name: " + f.GetName() + "<br />");
        Response.Write("File extension: " + f.GetExtension() + "<br />");
        Response.Write("Mime-type: " + f.ContentType + "<br />");
        Response.Write("File size: " + f.ContentLength + " bytes<br />");
    }
}

© 2002-2008 Telerik. All Rights Reserved.


Custom Validation

Telerik RadUpload v2.4 Send comments on this topic.
Custom Validation
Uploading Files > RadUpload > Custom Validation

Glossary Item Box

Important notes

The selected files must be transferred to the server in order to be validated for size or mime-type. The file extensions can be validated on the client, before the upload.

To enable uploading of files, larger than 4MB, you must set the maxRequestLength attribute of the httpRuntime section in your web.config file.

Using the ValidatingFile event

RadUpload provides the ValidatingFile server-side event, which can be used to define custom validation logic and to override the internal validation if needed.

When a file is validated, the IsValid property of the event arguments must be set according the result of the validation.

Use the SkipInternalValidation property of event arguments to disable the internal validation for the specific file.

The valid files can be later accessed using the UploadedFiles property. The invalid files can be accessed using the InvalidFiles property if needed.

The example below demonstrates how to implement custom file size validation only for zip files. The rest of the uploaded files are validated against the declared maximum file size. The valid files are automatically saved in the "~/MyFiles" folder.

ASPX

<rad:radupload id="RadUpload1" runat="server"
    maxfilesize="1000000"
    targetfolder="~/MyFiles"
    onvalidatingfile="RadUpload1_ValidatingFile"></rad:radupload>
<asp:button Runat="server" ID="Button1" Text="Submit"></asp:button>

VB.NET

Imports Telerik.WebControls
...
Private Sub RadUpload1_ValidatingFile(ByVal sender As Object, ByVal e As WebControls.ValidateFileEventArgs)
    'we will check only the zip files
    If e.UploadedFile.GetExtension.ToLower = ".zip" Then
        'define the maximum file size to be 2000000 bytes
        Dim maxZipFileSize As Integer = 2000000
        'if the zip file size exceeds the maximum file size mark the file as invalid
        If e.UploadedFile.ContentLength > maxZipFileSize Then
            e.IsValid = False
        End If
        'The zip files must not be validated for file size from the internal validator
        e.SkipInternalValidation = True
    End If
End Sub

C#

using Telerik.WebControls;
...
private void RadUpload1_ValidatingFile(object sender, ValidateFileEventArgs e)
{
    //we will check only the zip files
    if (e.UploadedFile.GetExtension().ToLower() == ".zip")
    {
        //define the maximum file size to be 2000000 bytes
        int maxZipFileSize = 2000000;
        //if the zip file size exceeds the maximum file size mark the file as invalid
        if (e.UploadedFile.ContentLength > maxZipFileSize)
        {
            e.IsValid = false;
        }
        //The zip files must not be validated for file size from the internal validator
        e.SkipInternalValidation = true
    }
}

© 2002-2008 Telerik. All Rights Reserved.


Client-Side Validation

Telerik RadUpload v2.4 Send comments on this topic.
Client-Side Validation
See Also
Uploading Files > RadUpload > Client-Side Validation

Glossary Item Box

Client-side ValidateExtensions() function

RadUpload provides the ValidateExtensions client-side function for file extension validation on the client. The validation is done by integrating the RadUpload with a CustomValidator.

The CustomValidator will prevent the page from submitting when there are selected files with invalid extensions. If the validator must be activated on the server, you must handle its ServerValidate event and perform the same validation again.

NOTE: The ControlToValidate property of the CustomValidator must not be set!

Important notes

The ControlToValidate property of the CustomValidator must not be set.

The selected files must be transferred to the server in order to be validated for size or mime-type. The file extensions can be validated on the client, before the upload.

To enable uploading of files, larger than 4MB, you must set the maxRequestLength attribute of the httpRuntime section in your web.config file.

Example:

The following example demonstrates how to validate extensions of the selected files client-side and server-side.

ASPX

<rad:radupload id="RadUpload1" runat= "server"
    allowedfileextensions= ".zip,.jpg,.jpeg" />
<asp:customvalidator runat="server" id="CustomValidator1"
    display="Dynamic"
    clientvalidationfunction="ValidateRadUpload1"
    onservervalidate="CustomValidator1_ServerValidate">
        Invalid extensions.
</asp:customvalidator>
<asp:button runat="server" id="Button1" text="Submit" />
<script type="text/javascript">
function ValidateRadUpload1(source, arguments)
{
    arguments.IsValid = GetRadUpload('<%= RadUpload1.ClientID %>').ValidateExtensions();
}
</script>

VB.NET

Private Sub CustomValidator1_ServerValidate(ByVal source As Object, ByVal e As ServerValidateEventArgs)
    е.IsValid = (RadUpload1.InvalidFiles.Count = 0)
End Sub

C#

private void CustomValidator1_ServerValidate(object source, ServerValidateEventArgs e)
{
    е.IsValid = (RadUpload1.InvalidFiles.Count == 0);
}

See Also

Integrated Validation
Custom Validation

© 2002-2008 Telerik. All Rights Reserved.


Adding Text Fields

Telerik RadUpload v2.4 Send comments on this topic.
Adding Text Fields
Uploading Files > RadUpload > Adding Text Fields

Glossary Item Box

OnClientAdded event

RadUpload provides the OnClientAdded client-side event, which can be used to manipulate the rows, added by clicking the Add button. Using this event you can add any HTML element to RadUpload, including inputs.

The event handler is a function with two parameters:

  • radUpload - the client-side object instance of RadUpload which fired the event
  • args - an object with one property, containing the newly added row

<script type="text/javascript">
function addTitle(radUpload, args)
{
    var theNewRow = args.Row;
    ...
}
</script>
...
<rad:radupload id="RadUpload1" runat="server" onclientadded="addTitle" />

Important note

In order to ensure the proper operation of the event handler in all browsers you must declare the function before the RadUpload declaration.

GetID(name) method

An important client-side method of RadUpload is GetID(name) which must be used to generate the ID and the name of the additional input elements:

<script type="text/javascript">
function addTitle(radUpload, args)
{
  ...
  //Create the Title input and set its class from the used skin
  var title = document.createElement("input");
  title.className = "RadUploadInputField";
  //Generate ID and name for the title input. RadUpload will need
  // these server-side to get the value of the input
  title.id = title.name = radUpload.GetID("title");
  ...
}
</script>

Retrieving Field Values

Server-side you can get the additional text field values using the UploadedFile.GetFieldValue(name) method. You should use the same value which was passed to the GetID(name) method in order to retrieve the input value properly:

protected void Button1_Click(object sender, EventArgs e)
{
  foreach (UploadedFile f in RadUpload1.UploadedFiles)
  {
    LabelResults.Text += "File name: " + f.GetName() + "<br/>";
    //Pass the name, used to generate the ID and the name of the field
    LabelResults.Text += "Title: " + f.GetFieldValue("title") + "<br/><br/>";
  }
}

The value of the added checkboxes can be obtained using the UploadedFile.GetIsFieldChecked(name) method:

protected void Button1_Click(object sender, EventArgs e)
{
  foreach (UploadedFile f in RadUpload1.UploadedFiles)
  {
    LabelResults.Text += "File name: " + f.GetName() + "<br/>";
    //Pass the name, used to generate the ID and the name of the field
    LabelResults.Text += "Should create thumbnail: " + f.GetIsFieldChecked("thumbnail") + "<br/><br/>";
  }
}

Example: Adding a Title

The example below demonstrates how to add a Title field for each file input in RadUpload. Note that the declaration of the addTitle function is before the RadUpload declaration!

ASPX

<script type="text/javascript">
function addTitle(radUpload, args)
{
  //Get the cell which contains the file input.
  // When ControlObjectsVisibility contains the CheckBoxes flag the
  // first cell (index 0) is the cell with the checkbox, else the
  // first cell is the cell with the file input.
  var cell = args.Row.cells[1];

  //Get the skinned file input (this is a DIV tag if
  // EnableFileInputSkinning = true, otherwise <input type=file>)
  var fileInput = cell.firstChild;

  //We want the textboxes to be placed in one line (in the case
  // when EnableFileInputSkinning = true and fileInput is DIV)
  fileInput.style.display = "inline";

  //Create the Title label and set its text
  var text = document.createElement("span");
  text.innerHTML = "Title: ";
  cell.appendChild(text);

  //Create the Title input and set its class from the used skin
  var title = document.createElement("input");
  title.className = "RadUploadInputField";

  //Generate ID and name for the title input. RadUpload will need
  // these server-side to get the value of the input
  title.id = title.name = radUpload.GetID("title");

  //Append the additional input
  cell.appendChild(title);
}
</script>
...
<rad:radupload id="RadUpload1" runat="server" onclientadded="addTitle" />
<asp:button id="Button1" runat="server" text="Submit" onclick="Button1_Click" />
<p><asp:label runat="server" id="LabelResults"></asp:label></p>

VB.NET

Protected Sub Button1_Click(ByVal sender As Object, ByVal e As EventArgs)
  For Each f As UploadedFile In RadUpload1.UploadedFiles
    LabelResults.Text += "File name: " & f.GetName() & "<br/>"
    'Pass the name, used to generate the ID and the name of the field
    LabelResults.Text += "Title: " & f.GetFieldValue("title") & "<br/><br/>"
  Next
End Sub

C#

protected void Button1_Click(object sender, EventArgs e)
{
  foreach (UploadedFile f in RadUpload1.UploadedFiles)
  {
    LabelResults.Text += "Name: " + f.GetName() + "<br/>";
    //Pass the name, used to generate the ID and the name of the field
    LabelResults.Text += "Title: " + f.GetFieldValue("title") + "<br/><br/>";
  }
}

© 2002-2008 Telerik. All Rights Reserved.


Customizing the UI

Telerik RadUpload v2.4 Send comments on this topic.
Customizing the UI
See Also
Uploading Files > RadUpload > Customizing the UI

Glossary Item Box

The visibility of the RadUpload UI elements is controlled by the ControlObjectsVisibility property. Their visual appearance can be changed by setting the Skin property to the name of the skin you want to use. You can also create a custom skin.

Note: If you want to modify the width of the file inputs inside RadUpload, you may follow the instructions in Modifying File Input Appearance.

Example:

This example demonstrates how to set the RadUpload skin to "Vista" and to display only some of its user interface elements:

ASPX

<rad:radupload runat="server" id="RadUpload1"
    skin="Vista" ControlObjectsVisibility="RemoveButtons,ClearButtons,AddButton" />

VB.NET

RadUpload1.Skin = "Vista"
RadUpload1.ControlObjectsVisibility = ControlObjectsVisibility.RemoveButtons Or _
    ControlObjectsVisibility.ClearButtons Or ControlObjectsVisibility.AddButton

C#

RadUpload1.Skin = "Vista";
RadUpload1.ControlObjectsVisibility = ControlObjectsVisibility.RemoveButtons |
    ControlObjectsVisibility.ClearButtons | ControlObjectsVisibility.AddButton;

See Also

Creating RadUpload Skins

© 2002-2008 Telerik. All Rights Reserved.


MIME Types

Telerik RadUpload v2.4 Send comments on this topic.
MIME Types
Uploading Files > RadUpload > MIME Types

Glossary Item Box

IE serves different mime-types for the same files than Mozilla/Firefox - for example, the JPG files are uploaded with image/pjpeg mime-type when using IE and image/jpeg, when using Firefox.

Also the mime-type is not determined only by using the file extension. For example if you try to upload a text file, but with extension JPG, it still will be uploaded with text/plain mime-type. Since this isn't obvious at all, we usually recommend disabling the mime-type checks in RadUpload.

Extension | MIME type
.3dm | x-world/x-3dmf
.3dmf | x-world/x-3dmf
.a | application/octet-stream
.aab | application/x-authorware-bin
.aam | application/x-authorware-map
.aas | application/x-authorware-seg
.abc | text/vnd.abc
.acgi | text/html
.afl | video/animaflex
.ai | application/postscript
.aif | audio/aiff
.aif | audio/x-aiff
.aifc | audio/aiff
.aifc | audio/x-aiff
.aiff | audio/aiff
.aiff | audio/x-aiff
.aim | application/x-aim
.aip | text/x-audiosoft-intra
.ani | application/x-navi-animation
.aps | application/mime
.arc | application/octet-stream
.arj | application/arj
.arj | application/octet-stream
.art | image/x-jg
.asf | video/x-ms-asf
.asm | text/x-asm
.asp | text/asp
.asx | application/x-mplayer2
.asx | video/x-ms-asf
.asx | video/x-ms-asf-plugin
.au | audio/basic
.au | audio/x-au
.avi | application/x-troff-msvideo
.avi | video/avi
.avi | video/msvideo
.avi | video/x-msvideo
.avs | video/avs-video
.bcpio | application/x-bcpio
.bin | application/mac-binary
.bin | application/macbinary
.bin | application/octet-stream
.bin | application/x-binary
.bin | application/x-macbinary
.bm | image/bmp
.bmp | image/bmp
.bmp | image/x-windows-bmp
.boo | application/book
.book | application/book
.boz | application/x-bzip2
.bsh | application/x-bsh
.bz | application/x-bzip
.bz2 | application/x-bzip2
.c | text/plain
.c | text/x-c
.c++ | text/plain
.cat | application/vnd.ms-pki.seccat
.cc | text/plain
.cc | text/x-c
.ccad | application/clariscad
.cco | application/x-cocoa
.cdf | application/cdf
.cdf | application/x-cdf
.cdf | application/x-netcdf
.cer | application/pkix-cert
.cer | application/x-x509-ca-cert
.cha | application/x-chat
.chat | application/x-chat
.class | application/java
.class | application/java-byte-code
.class | application/x-java-class
.com | application/octet-stream
.com | text/plain
.conf | text/plain
.cpio | application/x-cpio
.cpp | text/x-c
.cpt | application/mac-compactpro
.cpt | application/x-compactpro
.cpt | application/x-cpt
.crl | application/pkcs-crl
.crl | application/pkix-crl
.crt | application/pkix-cert
.crt | application/x-x509-ca-cert
.crt | application/x-x509-user-cert
.csh | application/x-csh
.csh | text/x-script.csh
.css | application/x-pointplus
.css | text/css
.cxx | text/plain
.dcr | application/x-director
.deepv | application/x-deepv
.def | text/plain
.der | application/x-x509-ca-cert
.dif | video/x-dv
.dir | application/x-director
.dl | video/dl
.dl | video/x-dl
.doc | application/msword
.dot | application/msword
.dp | application/commonground
.drw | application/drafting
.dump | application/octet-stream
.dv | video/x-dv
.dvi | application/x-dvi
.dwf | drawing/x-dwf (old)
.dwf | model/vnd.dwf
.dwg | application/acad
.dwg | image/vnd.dwg
.dwg | image/x-dwg
.dxf | application/dxf
.dxf | image/vnd.dwg
.dxf | image/x-dwg
.dxr | application/x-director
.el | text/x-script.elisp
.elc | application/x-bytecode.elisp
.elc | application/x-elc
.env | application/x-envoy
.eps | application/postscript
.es | application/x-esrehber
.etx | text/x-setext
.evy | application/envoy
.evy | application/x-envoy
.exe | application/octet-stream
.f | text/plain
.f | text/x-fortran
.f77 | text/x-fortran
.f90 | text/plain
.f90 | text/x-fortran
.fdf | application/vnd.fdf
.fif | application/fractals
.fif | image/fif
.fli | video/fli
.fli | video/x-fli
.flo | image/florian
.flx | text/vnd.fmi.flexstor
.fmf | video/x-atomic3d-feature
.for | text/plain
.for | text/x-fortran
.fpx | image/vnd.fpx
.fpx | image/vnd.net-fpx
.frl | application/freeloader
.funk | audio/make
.g | text/plain
.g3 | image/g3fax
.gif | image/gif
.gl | video/gl
.gl | video/x-gl
.gsd | audio/x-gsm
.gsm | audio/x-gsm
.gsp | application/x-gsp
.gss | application/x-gss
.gtar | application/x-gtar
.gz | application/x-compressed
.gz | application/x-gzip
.gzip | application/x-gzip
.gzip | multipart/x-gzip
.h | text/plain
.h | text/x-h
.hdf | application/x-hdf
.help | application/x-helpfile
.hgl | application/vnd.hp-hpgl
.hh | text/plain
.hh | text/x-h
.hlb | text/x-script
.hlp | application/hlp
.hlp | application/x-helpfile
.hlp | application/x-winhelp
.hpg | application/vnd.hp-hpgl
.hpgl | application/vnd.hp-hpgl
.hqx | application/binhex
.hqx | application/binhex4
.hqx | application/mac-binhex
.hqx | application/mac-binhex40
.hqx | application/x-binhex40
.hqx | application/x-mac-binhex40
.hta | application/hta
.htc | text/x-component
.htm | text/html
.html | text/html
.htmls | text/html
.htt | text/webviewhtml
.htx | text/html
.ice | x-conference/x-cooltalk
.ico | image/x-icon
.idc | text/plain
.ief | image/ief
.iefs | image/ief
.iges | application/iges
.iges | model/iges
.igs | application/iges
.igs | model/iges
.ima | application/x-ima
.imap | application/x-httpd-imap
.inf | application/inf
.ins | application/x-internett-signup
.ip | application/x-ip2
.isu | video/x-isvideo
.it | audio/it
.iv | application/x-inventor
.ivr | i-world/i-vrml
.ivy | application/x-livescreen
.jam | audio/x-jam
.jav | text/plain
.jav | text/x-java-source
.java | text/plain
.java | text/x-java-source
.jcm | application/x-java-commerce
.jfif | image/jpeg
.jfif | image/pjpeg
.jfif-tbnl | image/jpeg
.jpe | image/jpeg
.jpe | image/pjpeg
.jpeg | image/jpeg
.jpeg | image/pjpeg
.jpg | image/jpeg
.jpg | image/pjpeg
.jps | image/x-jps
.js | application/x-javascript
.jut | image/jutvision
.kar | audio/midi
.kar | music/x-karaoke
.ksh | application/x-ksh
.ksh | text/x-script.ksh
.la | audio/nspaudio
.la | audio/x-nspaudio
.lam | audio/x-liveaudio
.latex | application/x-latex
.lha | application/lha
.lha | application/octet-stream
.lha | application/x-lha
.lhx | application/octet-stream
.list | text/plain
.lma | audio/nspaudio
.lma | audio/x-nspaudio
.log | text/plain
.lsp | application/x-lisp
.lsp | text/x-script.lisp
.lst | text/plain
.lsx | text/x-la-asf
.ltx | application/x-latex
.lzh | application/octet-stream
.lzh | application/x-lzh
.lzx | application/lzx
.lzx | application/octet-stream
.lzx | application/x-lzx
.m | text/plain
.m | text/x-m
.m1v | video/mpeg
.m2a | audio/mpeg
.m2v | video/mpeg
.m3u | audio/x-mpequrl
.man | application/x-troff-man
.map | application/x-navimap
.mar | text/plain
.mbd | application/mbedlet
.mc$ | application/x-magic-cap-package-1.0
.mcd | application/mcad
.mcd | application/x-mathcad
.mcf | image/vasa
.mcf | text/mcf
.mcp | application/netmc
.me | application/x-troff-me
.mht | message/rfc822
.mhtml | message/rfc822
.mid | application/x-midi
.mid | audio/midi
.mid | audio/x-mid
.mid | audio/x-midi
.mid | music/crescendo
.mid | x-music/x-midi
.midi | application/x-midi
.midi | audio/midi
.midi | audio/x-mid
.midi | audio/x-midi
.midi | music/crescendo
.midi | x-music/x-midi
.mif | application/x-frame
.mif | application/x-mif
.mime | message/rfc822
.mime | www/mime
.mjf | audio/x-vnd.audioexplosion.mjuicemediafile
.mjpg | video/x-motion-jpeg
.mm | application/base64
.mm | application/x-meme
.mme | application/base64
.mod | audio/mod
.mod | audio/x-mod
.moov | video/quicktime
.mov | video/quicktime
.movie | video/x-sgi-movie
.mp2 | audio/mpeg
.mp2 | audio/x-mpeg
.mp2 | video/mpeg
.mp2 | video/x-mpeg
.mp2 | video/x-mpeq2a
.mp3 | audio/mpeg3
.mp3 | audio/x-mpeg-3
.mp3 | video/mpeg
.mp3 | video/x-mpeg
.mpa | audio/mpeg
.mpa | video/mpeg
.mpc | application/x-project
.mpe | video/mpeg
.mpeg | video/mpeg
.mpg | audio/mpeg
.mpg | video/mpeg
.mpga | audio/mpeg
.mpp | application/vnd.ms-project
.mpt | application/x-project
.mpv | application/x-project
.mpx | application/x-project
.mrc | application/marc
.ms | application/x-troff-ms
.mv | video/x-sgi-movie
.my | audio/make
.mzz | application/x-vnd.audioexplosion.mzz
.nap | image/naplps
.naplps | image/naplps
.nc | application/x-netcdf
.ncm | application/vnd.nokia.configuration-message
.nif | image/x-niff
.niff | image/x-niff
.nix | application/x-mix-transfer
.nsc | application/x-conference
.nvd | application/x-navidoc
.o | application/octet-stream
.oda | application/oda
.omc | application/x-omc
.omcd | application/x-omcdatamaker
.omcr | application/x-omcregerator
.p | text/x-pascal
.p10 | application/pkcs10
.p10 | application/x-pkcs10
.p12 | application/pkcs-12
.p12 | application/x-pkcs12
.p7a | application/x-pkcs7-signature
.p7c | application/pkcs7-mime
.p7c | application/x-pkcs7-mime
.p7m | application/pkcs7-mime
.p7m | application/x-pkcs7-mime
.p7r | application/x-pkcs7-certreqresp
.p7s | application/pkcs7-signature
.part | application/pro_eng
.pas | text/pascal
.pbm | image/x-portable-bitmap
.pcl | application/vnd.hp-pcl
.pcl | application/x-pcl
.pct | image/x-pict
.pcx | image/x-pcx
.pdb | chemical/x-pdb
.pdf | application/pdf
.pfunk | audio/make
.pfunk | audio/make.my.funk
.pgm | image/x-portable-graymap
.pgm | image/x-portable-greymap
.pic | image/pict
.pict | image/pict
.pkg | application/x-newton-compatible-pkg
.pko | application/vnd.ms-pki.pko
.pl | text/plain
.pl | text/x-script.perl
.plx | application/x-pixclscript
.pm | image/x-xpixmap
.pm | text/x-script.perl-module
.pm4 | application/x-pagemaker
.pm5 | application/x-pagemaker
.png | image/png
.png | image/x-png
.pnm | application/x-portable-anymap
.pnm | image/x-portable-anymap
.pot | application/mspowerpoint
.pot | application/vnd.ms-powerpoint
.pov | model/x-pov
.ppa | application/vnd.ms-powerpoint
.ppm | image/x-portable-pixmap
.pps | application/mspowerpoint
.pps | application/vnd.ms-powerpoint
.ppt | application/mspowerpoint
.ppt | application/powerpoint
.ppt | application/vnd.ms-powerpoint
.ppt | application/x-mspowerpoint
.ppz | application/mspowerpoint
.pre | application/x-freelance
.prt | application/pro_eng
.ps | application/postscript
.psd | application/octet-stream
.pvu | paleovu/x-pv
.pwz | application/vnd.ms-powerpoint
.py | text/x-script.phyton
.pyc | applicaiton/x-bytecode.python
.qcp | audio/vnd.qcelp
.qd3 | x-world/x-3dmf
.qd3d | x-world/x-3dmf
.qif | image/x-quicktime
.qt | video/quicktime
.qtc | video/x-qtc
.qti | image/x-quicktime
.qtif | image/x-quicktime
.ra | audio/x-pn-realaudio
.ra | audio/x-pn-realaudio-plugin
.ra | audio/x-realaudio
.ram | audio/x-pn-realaudio
.ras | application/x-cmu-raster
.ras | image/cmu-raster
.ras | image/x-cmu-raster
.rast | image/cmu-raster
.rexx | text/x-script.rexx
.rf | image/vnd.rn-realflash
.rgb | image/x-rgb
.rm | application/vnd.rn-realmedia
.rm | audio/x-pn-realaudio
.rmi | audio/mid
.rmm | audio/x-pn-realaudio
.rmp | audio/x-pn-realaudio
.rmp | audio/x-pn-realaudio-plugin
.rng | application/ringing-tones
.rng | application/vnd.nokia.ringing-tone
.rnx | application/vnd.rn-realplayer
.roff | application/x-troff
.rp | image/vnd.rn-realpix
.rpm | audio/x-pn-realaudio-plugin
.rt | text/richtext
.rt | text/vnd.rn-realtext
.rtf | application/rtf
.rtf | application/x-rtf
.rtf | text/richtext
.rtx | application/rtf
.rtx | text/richtext
.rv | video/vnd.rn-realvideo
.s | text/x-asm
.s3m | audio/s3m
.saveme | application/octet-stream
.sbk | application/x-tbook
.scm | application/x-lotusscreencam
.scm | text/x-script.guile
.scm | text/x-script.scheme
.scm | video/x-scm
.sdml | text/plain
.sdp | application/sdp
.sdp | application/x-sdp
.sdr | application/sounder
.sea | application/sea
.sea | application/x-sea
.set | application/set
.sgm | text/sgml
.sgm | text/x-sgml
.sgml | text/sgml
.sgml | text/x-sgml
.sh | application/x-bsh
.sh | application/x-sh
.sh | application/x-shar
.sh | text/x-script.sh
.shar | application/x-bsh
.shar | application/x-shar
.shtml | text/html
.shtml | text/x-server-parsed-html
.sid | audio/x-psid
.sit | application/x-sit
.sit | application/x-stuffit
.skd | application/x-koan
.skm | application/x-koan
.skp | application/x-koan
.skt | application/x-koan
.sl | application/x-seelogo
.smi | application/smil
.smil | application/smil
.snd | audio/basic
.snd | audio/x-adpcm
.sol | application/solids
.spc | application/x-pkcs7-certificates
.spc | text/x-speech
.spl | application/futuresplash
.spr | application/x-sprite
.sprite | application/x-sprite
.src | application/x-wais-source
.ssi | text/x-server-parsed-html
.ssm | application/streamingmedia
.sst | application/vnd.ms-pki.certstore
.step | application/step
.stl | application/sla
.stl | application/vnd.ms-pki.stl
.stl | application/x-navistyle
.stp | application/step
.sv4cpio | application/x-sv4cpio
.sv4crc | application/x-sv4crc
.svf | image/vnd.dwg
.svf | image/x-dwg
.svr | application/x-world
.svr | x-world/x-svr
.swf | application/x-shockwave-flash
.t | application/x-troff
.talk | text/x-speech
.tar | application/x-tar
.tbk | application/toolbook
.tbk | application/x-tbook
.tcl | application/x-tcl
.tcl | text/x-script.tcl
.tcsh | text/x-script.tcsh
.tex | application/x-tex
.texi | application/x-texinfo
.texinfo | application/x-texinfo
.text | application/plain
.text | text/plain
.tgz | application/gnutar
.tgz | application/x-compressed
.tif | image/tiff
.tif | image/x-tiff
.tiff | image/tiff
.tiff | image/x-tiff
.tr | application/x-troff
.tsi | audio/tsp-audio
.tsp | application/dsptype
.tsp | audio/tsplayer
.tsv | text/tab-separated-values
.turbot | image/florian
.txt | text/plain
.uil | text/x-uil
.uni | text/uri-list
.unis | text/uri-list
.unv | application/i-deas
.uri | text/uri-list
.uris | text/uri-list
.ustar | application/x-ustar
.ustar | multipart/x-ustar
.uu | application/octet-stream
.uu | text/x-uuencode
.uue | text/x-uuencode
.vcd | application/x-cdlink
.vcs | text/x-vcalendar
.vda | application/vda
.vdo | video/vdo
.vew | application/groupwise
.viv | video/vivo
.viv | video/vnd.vivo
.vivo | video/vivo
.vivo | video/vnd.vivo
.vmd | application/vocaltec-media-desc
.vmf | application/vocaltec-media-file
.voc | audio/voc
.voc | audio/x-voc
.vos | video/vosaic
.vox | audio/voxware
.vqe | audio/x-twinvq-plugin
.vqf | audio/x-twinvq
.vql | audio/x-twinvq-plugin
.vrml | application/x-vrml
.vrml | model/vrml
.vrml | x-world/x-vrml
.vrt | x-world/x-vrt
.vsd | application/x-visio
.vst | application/x-visio
.vsw | application/x-visio
.w60 | application/wordperfect6.0
.w61 | application/wordperfect6.1
.w6w | application/msword
.wav | audio/wav
.wav | audio/x-wav
.wb1 | application/x-qpro
.wbmp | image/vnd.wap.wbmp
.web | application/vnd.xara
.wiz | application/msword
.wk1 | application/x-123
.wmf | windows/metafile
.wml | text/vnd.wap.wml
.wmlc | application/vnd.wap.wmlc
.wmls | text/vnd.wap.wmlscript
.wmlsc | application/vnd.wap.wmlscriptc
.word | application/msword
.wp | application/wordperfect
.wp5 | application/wordperfect
.wp5 | application/wordperfect6.0
.wp6 | application/wordperfect
.wpd | application/wordperfect
.wpd | application/x-wpwin
.wq1 | application/x-lotus
.wri | application/mswrite
.wri | application/x-wri
.wrl | application/x-world
.wrl | model/vrml
.wrl | x-world/x-vrml
.wrz | model/vrml
.wrz | x-world/x-vrml
.wsc | text/scriplet
.wsrc | application/x-wais-source
.wtk | application/x-wintalk
.xbm | image/x-xbitmap
.xbm | image/x-xbm
.xbm | image/xbm
.xdr | video/x-amt-demorun
.xgz | xgl/drawing
.xif | image/vnd.xiff
.xl | application/excel
.xla | application/excel
.xla | application/x-excel
.xla | application/x-msexcel
.xlb | application/excel
.xlb | application/vnd.ms-excel
.xlb | application/x-excel
.xlc | application/excel
.xlc | application/vnd.ms-excel
.xlc | application/x-excel
.xld | application/excel
.xld | application/x-excel
.xlk | application/excel
.xlk | application/x-excel
.xll | application/excel
.xll | application/vnd.ms-excel
.xll | application/x-excel
.xlm | application/excel
.xlm | application/vnd.ms-excel
.xlm | application/x-excel
.xls | application/excel
.xls | application/vnd.ms-excel
.xls | application/x-excel
.xls | application/x-msexcel
.xlt | application/excel
.xlt | application/x-excel
.xlv | application/excel
.xlv | application/x-excel
.xlw | application/excel
.xlw | application/vnd.ms-excel
.xlw | application/x-excel
.xlw | application/x-msexcel
.xm | audio/xm
.xml | application/xml
.xml | text/xml
.xmz | xgl/movie
.xpix | application/x-vnd.ls-xpix
.xpm | image/x-xpixmap
.xpm | image/xpm
.x-png | image/png
.xsr | video/x-amt-showrun
.xwd | image/x-xwd
.xwd | image/x-xwindowdump
.xyz | chemical/x-pdb
.z | application/x-compress
.z | application/x-compressed
.zip | application/x-compressed
.zip | application/x-zip-compressed
.zip | application/zip
.zip | multipart/x-zip
.zoo | application/octet-stream
.zsh | text/x-script.zsh

© 2002-2008 Telerik. All Rights Reserved.


Saving the Uploaded Files

Telerik RadUpload v2.4 Send comments on this topic.
Saving the Uploaded Files
Uploading Files > FileUpload control > Saving the Uploaded Files

Glossary Item Box

RadMemoryOptimization

Since Telerik RadUpload 2.0, RadMemoryOptimization is enabled for the FileUpload controls and the standard <input type=file> (file input) HTML elements.

In order to access the files, uploaded using the above controls you need to use the RadUploadContext.Current object:

  1. The RadUploadContext object provides the UploadedFiles collection containing all uploaded files in the current request when RadMemoryOptimization was enabled:

    Dim uploadContext As RadUploadContext = RadUploadContext.Current
  2. After that using the UniqueID property of the FileUpload control you can get and save its file:

    Dim file As UploadedFile = uploadContext.UploadedFiles(FileUpload1.UniqueID)
    If Not file Is Nothing Then
        file.SaveAs(Server.MapPath("~/MyFiles/" & file.GetName))
    End If

For more information and examples about the server-side API of RadUpload check Manipulating the Uploaded Files.

Example

This example demonstrates how to save the files uploaded with standard file inputs with enabled RadMemoryOptimization:

ASPX

<input type="file" runat="server" id="FileUpload1" />
<input type="file" runat="server" id="FileUpload2" />
<rad:radprogressmanager runat="server" id="RadProgressManager1" />
<asp:button runat="server" id="Button1" text="Submit" onclick="Button1_Click" />

VB.NET

Imports Telerik.WebControls
...
Protected Sub Button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    Dim uploadContext As RadUploadContext = RadUploadContext.Current

    Dim file As UploadedFile

    file = uploadContext.UploadedFiles(FileUpload1.UniqueID)
    If Not file Is Nothing Then
        file.SaveAs(Server.MapPath("~/MyFiles/" & file.GetName))
    End If

    file = uploadContext.UploadedFiles(FileUpload2.UniqueID)
    If Not file Is Nothing Then
        file.SaveAs(Server.MapPath("~/MyFiles/" & file.GetName))
    End If
End Sub

C#

using Telerik.WebControls;
...
protected void Button1_Click(object sender, EventArgs e)
{
    RadUploadContext uploadContext = RadUploadContext.Current;

    UploadedFile file;

    file = uploadContext.UploadedFiles[FileUpload1.UniqueID];
    if (file != null)
    {
        file.SaveAs(Server.MapPath("~/MyFiles/" + file.GetName()));
    }

    file = uploadContext.UploadedFiles[FileUpload2.UniqueID];
    if (file != null)
    {
        file.SaveAs(Server.MapPath("~/MyFiles/" + file.GetName()));
    }
}

© 2002-2008 Telerik. All Rights Reserved.


Upload Progress Monitoring
Progress Monitoring > Upload Progress Monitoring

Glossary Item Box

Important Notes

The RadProgressArea controls will be displayed only if there are selected files for upload or there is a custom progress information available.

You will need to enable RadMemoryOptimization in order to display progress for file upload. Note that RadMemoryOptimization is not operational for applications that are hosted in IIS7.

Upload Progress Monitoring

RadProgressArea is intended to provide UI for displaying the progress of file uploads or other processes which can be monitored on the server. RadProgressManager was designed to provide the Ajax mechanism for retrieving progress information from the application and to update all RadProgressArea controls on the page.

To setup a file upload progress indicator you need to:

  1. Register RadUploadHttpModule in web.config
  2. Register RadUploadProgressHandler in web.config
  3. Put on the page a RadProgressManager and a RadProgressArea controls.
  4. Put on the page a RadUpload and / or FileUpload controls, and / or standard <input type=file> elements.

Example

The following example demonstrates how to setup a file upload progress indicator using RadUpload, RadProgressManager and RadProgressArea. Instead of RadUpload you can use FileUpload controls or standard <input type=file> elements.

<rad:radupload id="RadUpload1" runat="server" />
<rad:radprogressarea id="RadProgressArea1" runat="server" />
<rad:radprogressmanager id="RadProgressManager1" runat="server" />
<asp:button id="Button1" runat="server" text="Submit" />

© 2002-2008 Telerik. All Rights Reserved.


Creating a ProgressTemplate

Telerik RadUpload v2.4 Send comments on this topic.
Creating a ProgressTemplate
Progress Monitoring > Creating a ProgressTemplate

Glossary Item Box

RadProgressArea provides a property called ProgressTemplate, used to instantiate its child controls. This is the default ProgressTemplate, integrated in the control:

<div class="RadUploadProgressArea">
<table class="RadUploadProgressTable" style="height:100;width:100%;">
<tr>
<td class="RadUploadProgressBarHolder">
<!-- Uploaded bytes progress bar -->
<asp:image id="PrimaryProgressBar" runat="server"
imageurl="~/RadControls/Upload/Skins/Default/img/progress.gif" /></td>
</tr>
<tr>
<td class="RadUploadTotalProgressData">
<!-- Uploaded bytes percent from request size -->
<asp:label id="PrimaryPercent" runat="server"></asp:label>%&nbsp;
<!-- Uploaded bytes -->
<asp:label id="PrimaryValue" runat="server"></asp:label>&nbsp;
<!-- Request size -->
<asp:label id="PrimaryTotal" runat="server"></asp:label></td>
</tr>
<tr>
<td class="RadUploadProgressBarHolder">
<!-- Uploaded files progress bar -->
<asp:image id="SecondaryProgressBar" runat="server"
imageurl="~/RadControls/Upload/Skins/Default/img/progress.gif" /></td>
</tr>
<tr>
<td class="RadUploadFileCountProgressData">
<!-- Uploaded files percent from total selected files on the page -->
<asp:label id="SecondaryPercent"></asp:label>%&nbsp;
<!-- Uploaded files -->
<asp:label id="SecondaryValue"></asp:label>&nbsp;
<!-- Total selected files on the page -->
<asp:label id="SecondaryTotal"></asp:label></td>
</tr>
<tr>
<td class="RadUploadCurrentFileName">
<!-- The currently uploaded file name -->
<asp:label id="CurrentOperation" runat="server"></asp:label></td>
</tr>
<tr>
<td class="RadUploadTotalProgressData">
<!-- Time elapsed from the beginning of the upload -->
<asp:label id="TimeElapsed" runat="server"></asp:label>&nbsp;
<!-- Time estimated to the end of the upload -->
<asp:label id="TimeEstimated" runat="server"></asp:label>&nbsp;
<!-- Upload speed -->
<asp:label id="Speed" runat="server"></asp:label></td>
</tr>
</table>
</div>

When you modify the ProgressTemplate you need to use the exact IDs for the controls inside in order to enable the ProgressArea to recognize them properly. RadProgressArea class contains public static members with the names of each control.

© 2002-2008 Telerik. All Rights Reserved.


Custom Progress Monitoring

Telerik RadUpload v2.4 Send comments on this topic.
Custom Progress Monitoring
Progress Monitoring > Custom Progress Monitoring

Glossary Item Box

RadProgressArea was designed to provide the ability to monitor the progress of file uploads or any other measurable process.

If you want to monitor only custom progress, you need to register RadUploadProgressHandler and set RadProgressManager's SuppressMissingHttpModuleError property to true in order to the avoid error messages from it.

If you want to update the elements of the default progress template you should use the following keys in the RadProgressContext.Current HashTable:

  • PrimaryTotal - the maximum value of the primary progress indicators. By default RadProgressArea displays here the request size.
  • PrimaryValue - the current value of the primary progress indicators. By default RadProgressArea displays here the uploaded bytes count.
  • PrimaryPercent - the percentage of PrimaryValue from PrimaryTotal.
  • SecondaryTotal - the maximum value of the secondary progress indicators. By default RadProgressArea displays here the number of the selected files on the page.
  • SecondaryValue - the current value of the secondary progress indicators. By default RadProgressArea displays here the count of the complete uploaded files.
  • SecondaryPercent - the percentage of SecondaryValue from SecondaryTotal
  • CurrentOperationText - the description of the current operation. By default RadProgressArea displays here the name of the currently uploaded file.
  • TimeEstimated - the estimated time until the operation completes.
  • TimeElapsed - the elapsed time from the beginning of the operation.
  • Speed - The execution speed of the process. By default RadProgressArea displays here the upload speed.

If you set some of these properties before upload they will not be used for file upload monitoring.

Example:

The following example demonstrates how to monitor both file upload and custom process using one RadProgressArea:

<input runat="server" id="File1" type="file" />
<rad:radprogressmanager id="RadProgressManager1" runat="server" />
<rad:radprogressarea id="RadProgressArea1" runat="server" />
<asp:button id="Button1" runat="server" text="Submit" />

VB.NET

Private Sub LooongMethodWhichUpdatesTheProgressContext(file as UploadedFile)
 Dim total As Integer = 100

 Dim progress As Telerik.WebControls.RadProgressContext = RadProgressContext.Current

 For i As Integer = 0 To total - 1
  'Set the values of the secondary progress
  progress("SecondaryTotal") = total.ToString()
  progress("SecondaryValue") = i.ToString()
  progress("SecondaryPercent") = i.ToString()
  progress("CurrentOperationText") = file.GetName + " is being processed..."

  If Not Response.IsClientConnected Then
   'Cancel button was clicked or the browser was closed, so stop processing
   Exit For
  End If

  'Stall the current thread for 0.05 seconds to simulate server-side processing
  System.Threading.Thread.Sleep(50)
 Next
End Sub

Protected Sub Button1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Button1.Click
 Dim file As UploadedFile = RadUploadContext.Current.UploadedFiles(File1.UniqueID)
 'Process the uploaded file
 If Not file Is Nothing Then
  LooongMethodWhichUpdatesTheProgressContext(file)
 End If
End Sub

Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
 If Not IsPostBack Then
  'Do not display SelectedFilesCount progress indicator.
  RadProgressArea1.ProgressIndicators = ProgressIndicators.CurrentFileName Or _
   ProgressIndicators.FilesCount Or _
   ProgressIndicators.FilesCountBar Or _
   ProgressIndicators.FilesCountPercent Or _
   ProgressIndicators.RequestSize Or _
   ProgressIndicators.TimeElapsed Or _
   ProgressIndicators.TimeEstimated Or _
   ProgressIndicators.TotalProgress Or _
   ProgressIndicators.TotalProgressBar Or _
   ProgressIndicators.TotalProgressPercent Or _
   ProgressIndicators.TransferSpeed

  RadProgressArea1.Localization("UploadedFiles") = "Processed "
  RadProgressArea1.Localization("TotalFiles") = ""
  RadProgressArea1.Localization("CurrentFileName") = "File: "

  Dim progress As RadProgressContext = RadProgressContext.Current
  'Prevent the secondary progress from appearing when the file is uploaded (FileCount etc.)
  progress("SecondaryTotal") = 0
  progress("SecondaryValue") = 0
  progress("SecondaryPercent") = 0
 End If
End Sub

C#

private void LooongMethodWhichUpdatesTheProgressContext(UploadedFile file)
{
   const int total = 100;

   RadProgressContext progress = RadProgressContext.Current;
   for (int i=0; i<total; i++)
   {
      progress["SecondaryTotal"] = total.ToString();
      progress["SecondaryValue"] = i.ToString();
      progress["SecondaryPercent"] = i.ToString();
      progress["CurrentOperationText"] = file.GetName() + " is being processed...";

      if (!Response.IsClientConnected)
      {
          //Cancel button was clicked or the browser was closed, so stop processing
          break;
      }

      //Stall the current thread for 0.1 seconds
      System.Threading.Thread.Sleep(100);
   }
}

private void Button1_Click(object sender, System.EventArgs e)
{
   UploadedFile file = RadUploadContext.Current.UploadedFiles[File1.UniqueID];
   if (file != null)
   {
      LooongMethodWhichUpdatesTheProgressContext(file);
   }
}

protected void Page_Load(Object sender, System.EventArgs e)
{
   if (!IsPostBack)
   {
      //Do not display SelectedFilesCount progress indicator.
      RadProgressArea1.ProgressIndicators = ProgressIndicators.CurrentFileName |
         ProgressIndicators.FilesCount |
         ProgressIndicators.FilesCountBar |
         ProgressIndicators.FilesCountPercent |
         ProgressIndicators.RequestSize |
         ProgressIndicators.TimeElapsed |
         ProgressIndicators.TimeEstimated |
         ProgressIndicators.TotalProgress |
         ProgressIndicators.TotalProgressBar |
         ProgressIndicators.TotalProgressPercent |
         ProgressIndicators.TransferSpeed;

      RadProgressArea1.Localization["UploadedFiles"] = "Processed ";
      RadProgressArea1.Localization["TotalFiles"] = "";
      RadProgressArea1.Localization["CurrentFileName"] = "File: ";

      RadProgressContext progress = RadProgressContext.Current;
      //Prevent the secondary progress from appearing when the file is uploaded (FileCount etc.)
      progress["SecondaryTotal"] = "0";
      progress["SecondaryValue"] = "0";
      progress["SecondaryPercent"] = "0";
   }
}

© 2002-2008 Telerik. All Rights Reserved.


Customizing RadProgressArea

Telerik RadUpload v2.4 Send comments on this topic.
Customizing RadProgressArea
Progress Monitoring > Customizing RadProgressArea

Glossary Item Box

The visibility of the RadProgressArea UI elements is controlled by the ProgressIndicators and DisplayCancelButton properties. The ProgressIndicators property is used to change the visibility of the standard progress indicators, such as: TotalProgressBar, TimeElapsed, TimeEstimated or TransferSpeed. The DisplayCancelButton property is used to change the visibility of the Cancel button, used to cancel the file upload.

The visual appearance of the RadProgressArea UI elements can be changed by setting the Skin property of the control. You may also modify one of the existing skins, or create one from scratch.

You can modify the positions and the HTML elements of the progress indicators by creating a ProgressTemplate.

Example:

The following example demonstrates how to set the RadProgressArea skin to "Vista" and display some of its progress indicators:

ASPX

<rad:radprogressarea runat="server" id="RadProgressArea1" skin="Vista"
    progressindicators="FilesCount,FilesCountBar,FilesCountPercent" />

VB.NET

RadProgressArea1.Skin = "Vista"
RadProgressArea1.ProgressIndicators = ProgressIndicators.FilesCount Or _
    ProgressIndicators.FilesCountBar Or ProgressIndicators.FilesCountPercent

C#

RadProgressArea1.Skin = "Vista";
RadProgressArea1.ProgressIndicators = ProgressIndicators.FilesCount |
    ProgressIndicators.FilesCountBar | ProgressIndicators.FilesCountPercent

© 2002-2008 Telerik. All Rights Reserved.


RadUploadHttpModule

Telerik RadUpload v2.4 Send comments on this topic.
RadUploadHttpModule
Configuration > RadUploadHttpModule

Glossary Item Box

If you want to use RadMemoryOptimization and RadProgressArea you must register RadUploadHttpModule in your application web.config file.

Important Notes

RadProgressManager will display error messages if it is unable to find RadUploadHttpModule.

RadUploadHttpModule is incompatible with the ASP.NET application trace.

RadUploadHttpModule is incompatible with other similar modules which handle file uploads.

The configuration file sections and attributes are case sensitive. This means that the sections and attributes below will be incorrect if they are written using a case other than shown the examples.

RadMemoryOptimization requires ReflectionPermission in order to operate correctly. This means that in normal circumstances you will have to run your application with Full Trust permission set, unless you create custom security policy, which allows ReflectionPermission. If you are unable to set Full Trust or custom security policy, the solution is to put the RadUpload assembly in GAC.

Registration

In order to register RadUploadHttpModule you need to:

  1. Open the Solution Explorer pane, navigate to the application web.config file and open it.
  2. Under the <configuration> element locate the <system.web> element. Add it if it does not exist.
  3. Under the <system.web> element locate the <httpModules> element. Add it if it does not exist.
  4. In the <httpModules> element add the following tag:
    .NET Framework 1.x

    <add name="RadUploadModule" type="Telerik.WebControls.RadUploadHttpModule, RadUpload" />

    .NET Framework 2.0

    <add name="RadUploadModule" type="Telerik.WebControls.RadUploadHttpModule, RadUpload.Net2" />

  5. If the RadUpload assembly is added in GAC you need to specify the full assembly qualified path of the RadUploadHttpModule type (note that the assembly version might be different in your case):
    .NET Framework 2.0:

    <add name="RadUploadModule" type="Telerik.WebControls.RadUploadHttpModule,
    RadUpload.Net2, Version=2.4.0.0, Culture=neutral, PublicKeyToken=e8ab424810b6b9b5"     />

The final result should look like this (.NET Framework 2.0, no GAC):

<configuration>
  ...
  <system.web>
    <httpModules>
      <add name="RadUploadModule" type="Telerik.WebControls.RadUploadHttpModule, RadUpload.Net2" />
      ...
    </httpModules>
  ...
  </system.web>
</configuration>

Configuration (optional)

By default RadUploadHttpModule saves the uploaded files in the system's temp folder. To change the location for the temporary files, add the following tag into the <appSettings> element of your application web.config file:

<add key="Telerik.RadUpload.TempFolder" value="c:\temp" />

The value is the physical path to the folder where the temporary files will be saved. You should ensure that the ASPNET user (NetworkService in Windows Server 2003) has FullControl rights on this location. You can find more information on how to do this in the Setting ASPNET (NetworkService) Permissions help topic.

Note: From version 2.3.2.0 RadUpload supports application relative paths for this setting, e.g. you could use "~/Temp".

The final result should look like this:

<configuration>
  ...
  <appSettings>
    <add key="Telerik.RadUpload.TempFolder" value="c:\temp" />
    ...
  </appSettings>
  ...
</configuration>

More Information

You can find more information about registering httpModules in this article in MSDN.

© 2002-2008 Telerik. All Rights Reserved.


RadUploadProgressHandler

Telerik RadUpload v2.4 Send comments on this topic.
RadUploadProgressHandler
Configuration > RadUploadProgressHandler

Glossary Item Box

If you want to monitor file upload progress or a custom progress you must register RadUploadProgressHandler in your application web.config file.

Important Notes

RadProgressManager will display error messages if it is unable to find RadUploadProgressHandler.

There are certain settings which should be applied if your .NET 2.0 application uses forms authentication.

If you are using URL rewriter you should exclude the following path from rewriting
http://MyServer/MyApplication/Telerik.RadUploadProgressHandler.aspx

The configuration file sections and attributes are case sensitive. This means that the sections and attributes below will be incorrect if they are written using a case other than shown the examples.

Registration

In order to register the HttpHandler you should:

In order to register RadUploadHttpModule you need to:

  1. Open the Solution Explorer pane, navigate to the application web.config file and open it.
  2. Under the <configuration> element locate the <system.web> element. Add it if it does not exist.
  3. Under the <system.web> element locate the <httpHandlers> element. Add it if it does not exist.
  4. In the <httpHandlers> element add the following tag:
    .NET Framework 1.x

    <add verb="*" path="Telerik.RadUploadProgressHandler.aspx"
      type="Telerik.WebControls.RadUploadProgressHandler, RadUpload" />

    .NET Framework 2.0

    <add verb="*" path="Telerik.RadUploadProgressHandler.aspx"
      type="Telerik.WebControls.RadUploadProgressHandler, RadUpload.Net2" />
  5. If the RadUpload assembly is added in GAC you need to specify the full assembly qualified path of the RadUploadProgressHandler type (note that the assembly version might be different in your case):
    .NET Framework 2.0:

    <add verb="*" path="Telerik.RadUploadProgressHandler.aspx"
          type="Telerik.WebControls.RadUploadProgressHandler,
          RadUpload.Net2, Version=2.4.0.0, Culture=neutral, PublicKeyToken=e8ab424810b6b9b5" />

Note: It is not necessary the aspx page in the path attribute above to exist, but you should ensure that the framework is configured to skip the ASPX file existence check.

The final result should look like this (.NET Framework 2.0, no GAC):

<configuration>
   ...
  <system.web>
    <httpHandlers>
      <add verb="*" path="Telerik.RadUploadProgressHandler.aspx"
        type="Telerik.WebControls.RadUploadProgressHandler, RadUpload.Net2" />
      ...
    </httpHandlers>
   ...
  </system.web>
</configuration>

© 2002-2008 Telerik. All Rights Reserved.


Localization

Telerik RadUpload v2.4 Send comments on this topic.
Localization
See Also
Localization > Localization

Glossary Item Box

RadUpload and RadProgressArea provide a mechanism for quick and easy localization. All button labels and messages in the controls are obtained from an external XML file. You can change the language of the controls via the Language property by setting it to some of the predefined localizations which come with Telerik RadUpload.

You can also localize the component for other languages, which are not provided with the Telerik RadUpload distribution by modifying the existing XML files. Localization subfolders are located in the "~/RadControls/Localization" folder. Each localization subfolder is named after the language it delivers and contains a xml files named RadUpload.xml and RadProgressArea.xml which contain all localizable strings.

The value of the Language property must be the name of the localization subfolder. For example if you create a localization for Bulgarian language and put it in "~/RadControls/Localization/Bulgarian" you must set the Language property like this:

<rad:radupload runat="server" id="RadUpload1"
    Language="Bulgarian" />
<rad:radprogressarea runat="server" id="RadProgressArea1"
    Language="Bulgarian" />

Note: If you have set the property EnableFileInputSkinning to false meaning that you see the standard file inputs, then localizing the "Browse" string is not possible due to the limitations of the standard file input (<input type="file">).

See Also

Customizing the UI
Language Property

© 2002-2008 Telerik. All Rights Reserved.


General Information

Telerik RadUpload v2.4 Send comments on this topic.
General Information
Skins > General Information

Glossary Item Box

Skin is a set of files which define the visual appearance of the contol's html elements. All files of a particular skin are located in a separate folder named after the skin. For example the files of the Classic skin are located by default in "~/RadControls/Upload/Skins/Classic".

To change the skin of a control you should set the value of its Skin property:

<rad:radupload runat="server" id="RadUpload1" skin="Classic" />

or from the code-behind, in any event:

RadUpload1.Skin = "Classic"

Each RadUpload skin contains a couple of CSS files which hold the definitions of the CSS classes applied to the RadUpload and RadProgressArea html elements. The CSS classes for RadUpload are defined in a file named RadUpload.css, respectively the CSS classes for RadProgressArea are defined in RadUploadProgressArea.css. Both files are located in the skin folder.

© 2002-2008 Telerik. All Rights Reserved.


Creating RadUpload Skins

Telerik RadUpload v2.4 Send comments on this topic.
Creating RadUpload Skins
See Also
Skins > Creating RadUpload Skins

Glossary Item Box

Each skin is a set of style sheets which are applied on the Telerik RadUpload structure elements. The easiest approach for creating a custom skin is to change one of the default skins to fit your needs.

The visibility of the user interface elements of the RadUpload control can be changed using the ControlObjectsVisibility property.

You can use the following screenshot as a basic reference for the elements of the RadUpload control:

RadUpload structure elements

Here is the list of CSS styles you need to define in order to create a custom skin:

  • .RadUploadTable - this style is applied on the main table containing all elements of the Telerik RadUpload interface. Marked with 1 and colored red on the screenshot.
  • .RadUploadTable TD - this style is applied on the cells of the main table. Marked with 2 and colored blue.
  • .RadUploadButtonArea - this style is applied on the area where the Add and Delete buttons are located. Marked with 3 and colored yellow.
  • .RadUploadButton - this style is applied on the buttons named Add and Delete on the screenshot.
  • .RadUploadButtonDisabled - defines the style which is applied on the disabled buttons (for example the add button is disabled when you add MaxFileInputsCount fields to a RadUpload control)
  • .RadUploadFileSelector - this style is applied to the checkbox elements.
  • .RadUploadInputField - this style is applied to the text box elements.
  • input.RealFileInput - this style is applied on the <input type=file> element. If you want to set the EnableFileInputSkinning property to true, this style must make this element transparent.
  • .RadUploadSelectButton - this style is applied on the button named Select in the screenshot.
  • .RadUploadRemoveButton - this style is applied on the button named Remove in the screenshot.
  • .RadUploadClearButton - this style is applied on the button named Clear in the screenshot.

All files of a particular skin are located in a separate folder named after the skin. For example the files of the Vista skin are located in "~/RadControls/Upload/Skins/Vista". The CSS styles must reside in a file named RadUpload.css, located in the skin folder.

The <input type=file> DHTML elements cannot be skinned because of the browser's security restrictions. In order to change their appearance Telerik RadUpload makes them transparent and puts a skinned textbox and button below. Using javascript the text in the textbox is syncronized with the text in the <input type=file> element. If you experience problems with the skin of these elements you may try setting the EnableFileInputSkinning property to false.

See Also

Customizing the UI

© 2002-2008 Telerik. All Rights Reserved.


Modifying File Input Appearance

Telerik RadUpload v2.4 Send comments on this topic.
Modifying File Input Appearance
Skins > Modifying File Input Appearance

Glossary Item Box

RadUpload is built over the standard <input type=file> (File Input) elements. This html element is very limited in functionality by the browsers, and one of its largest limitations lays in its inability to change its visual appearance. A very small amount of CSS styles can be applied to the file inputs and they are different between the different browsers.

We use the following approach for changing the appearance of the File Inputs: put a TextBox (marked as 2 in the image below) and a Button (3) below a transparent File Input (1). When the user clicks with the mouse on the Button, or types text in the TextBox, the File Input receives the mouse and keyboard events, because it is on top of all controls. Using javascript these events are set to the visible TextBox and Button in order to synchronize their content and appearance. Here is an image of the concept:
Upload elements
Note: The html elements are misaligned a bit for clarity.

When the EnableFileInputSkinning property is set to false, the TextBox and the Button aren't rendered, and the File Input is visible. I this mode a special CSS class, named input.NoSkinnedFileUnput is applied to the File Input. If you use it, you must modify this particular style in order to change the File Input's appearance. This mode is useful when you want to experiment with CSS styles in order to check if they can be applied to the element.

When the EnableFileInputSkinning property is set to true, RadUpload displays the controls as described above. The File Input have input.RealFileInput CSS class applied, the TextBox - RadUploadInputField and the Button - RadUploadSelectButton.

There are certain guidelines you must follow in order to get a properly displayed controls on the page:

  • The input.RealFileInput class must make the File Input transparent.
  • The RadUploadInputField class must have exactly the same width as the text area of the file input (marked as 4 on the image above). You can measure it if you set EnableFileInputSkinning property is set to false.
  • The RadUploadSelectButton class must have exactly the same width as the button area of the File Input (marked as 5 on the image above).
  • Last but not latest, the Mozilla/Firefox based browsers cannot change the width of the <input type=file> elements, due to a bug in the browser. However, you can use the workaround below to modify the width of the file inputs in all browsers.

Increasing File Input Width

There is another property, which can be used for increasing the file inputs width, called size. It specifies the width of the file input in characters. To apply the size property you need to handle the OnClientAdded client-side event of RadUpload.

Notes:

  • Make sure that you change the width in the RadUploadInputField class according the new width of the file input. Most probably you will find the exact width experimentally.
  • In order to ensure the proper operation of the event handler in all browsers you must declare the function before the RadUpload declaration.

<script type="text/javascript">
function increaseFileInputWidth(radUpload, args)
{
  //If the Checkboxes in RadUpload are not visible, change the index to 0
  var cell = args.Row.cells[1];
  var inputs = cell.getElementsByTagName('INPUT');
  for (var i=0; i<inputs.length; i++)
  {
    if (inputs[i].type == "file")
    {
      //Set the size property according to your preference
      inputs[i].size = 40;
    }
  }
}
</script>
<rad:radupload id="Radupload1" runat="server" onclientadded="increaseFileInputWidth"/>

© 2002-2008 Telerik. All Rights Reserved.


Modifying the Overall Appearance

Telerik RadUpload v2.4 Send comments on this topic.
Modifying the Overall Appearance
Skins > Modifying the Overall Appearance

Glossary Item Box

RadUpload renders several html tables in order to arrange its user interface elements. The scheme is below:

<table id="RadUpload_wrapper"><tr><td>
<!--The script and CSS style links go here -->
<table class="RadUploadTable">
 <tr>
  <td>
   <table id="RadUploadHolderTable"><tr><td>
    <table id="RadUploadListContainer" style="width:100;height;"><tr>
     <td>
      <input type="checkbox" class="RadUploadFileSelector" />
     </td>
     <td>
      <!-- File input, text box and a button. See the previous post for info -->
     </td>
     <td>
      <input type="button" class="RadUploadClearButton" /><!-- Clear Button -->
     </td>
     <td>
      <input type="button" class="RadUploadRemoveButton" /><!-- Remove Button -->
     </td>
    </tr></table>
   </td></tr></table>
  </td>
 </tr>
 <tr class="RadUploadButtonArea"><td>
   <table><tr><td>
    <input type="button" class="RadUploadButton" /><!-- Add Button -->
    <input type="button" class="RadUploadButton" /><!-- Delete Button -->
   </td></tr></table>
 </td></tr>
</table>
<!-- The initialization script goes here -->
</td></tr></table>

Note that the visibility of some of the elements is controlled by the ControlObjectVisibility property.

More information about the CSS styles can be found here http://msdn.microsoft.com/library/default.asp?url=/workshop/author/css/css_node_entry.asp

Sometimes, when you edit an existing skin, you may encounter CSS styles like this:

.RadUploadInputField
{
  border: solid 1px #cfcfcf;
  border-right: 0px;
  vertical-align: top;
  height: 17px;
  width: 350px;
  _width: 350px;
}
Note the double width definition. This is a common hack used when you need different CSS styles for the different browsers - Mozilla/Firefox will consider the second width style for invalid and will not apply it. However, IE will apply both styles and the second definition will have precedence.

© 2002-2008 Telerik. All Rights Reserved.


Client-Side File Size Check

Telerik RadUpload v2.4 Send comments on this topic.
Client-Side File Size Check
Frequently Asked Questions > Client-Side File Size Check

Glossary Item Box

Question

It seems that RadProgressArea „knows” the size of the uploaded files. Can you implement client-side file size check?

Answer

RadProgressArea is displayed after RadProgressManager receives the first progress information from the server, which contains the combined file size, displayed in RadProgressArea. Client-side file size check which is performed before the upload begins cannot be achieved with RadUpload.

Workaround

The example below demonstrates how to check the size of the uploaded files after the upload begins. Note that you will need to set maxRequestLength to a large value because otherwise there is a high possibility to get "Page not found" error, which cannot be handled, if the user selects very large files:

<script type="text/javascript">
function CheckUploadedFilesSize(progressArea, args)
{
  //progressArea.Confirmed is a custom variable,
  // you can use another if you want to
  if (!progressArea.Confirmed && args.ProgressData.RadUpload.RequestSize > 1000000)
  {
    if (confirm("The total size of the selected files is more than the limit." +
     " Do you want to cancel the upload?"))
    {
      progressArea.CancelRequest();
    }
    else
    {
      progressArea.Confirmed = "confirmed";
    }
  }
}
</script>
<rad:radupload runat="server" id="RadUpload1" />
<rad:radprogressarea runat="server" id="RadProgressArea1"
   onclientprogressupdating="CheckUploadedFilesSize" />
<rad:radprogressmanager runat="server" id="RadProgressManager1" />
<asp:button runat="server" id="Button1" text="Upload" />

Known Limitations

  1. The current mechanism for canceling the file upload sometimes does not notify the server for the performed action and the latter continues to process the upload request. This often happens on Windows 2003 Server and a browser, different than IE6.
  2. The upload request is canceled by refreshing the page and all entered information is lost.

© 2002-2008 Telerik. All Rights Reserved.


Resizing Images (Creating Thumbnails)

Telerik RadUpload v2.4 Send comments on this topic.
Resizing Images (Creating Thumbnails)
Frequently Asked Questions > Resizing Images (Creating Thumbnails)

Glossary Item Box

A common requirement is to resize the uploaded images. To accomplish that you may use the classes in System.Drawing namespace. Follows a simple example, which demonstrate how to save the uploaded images and create thumbnails. Check the following MSDN article for more information:

http://msdn2.microsoft.com/en-us/library/system.drawing.image.getthumbnailimage.aspx

ASPX/ASCX

<rad:radupload runat="server" id="RadUpload1" />
<asp:button runat="server" id="Button1" text="Upload" onclick="Button1_Click" />

VB.NET

Imports System.Drawing
Imports System.IO
Imports Telerik.WebControls

Public Function ThumbnailCallback() As Boolean
  Return False
End Function

Protected Sub Button1_Click(sender As Object, e As EventArgs)
  Dim target As String = Server.MapPath("~/UploadedImages")
  Dim thumbnailImageAbortDelegate As New System.Drawing.Image.GetThumbnailImageAbort(ThumbnailCallback)

  For Each file As UploadedFile In RadUpload1.UploadedFiles
    file.SaveAs(Path.Combine(target, file.GetName()))

    Dim originalImage As New Bitmap(file.InputStream)
    Try
      'You can implement additional logic which will compute
      ' width/height according your requirements
      Dim width As Integer = originalImage.Width / 2
      Dim height As Integer = originalImage.Height / 2

      Dim thumbnail As System.Drawing.Image = _
        originalImage.GetThumbnailImage(width, height, thumbnailImageAbortDelegate, IntPtr.Zero)
      Try
        Dim thumbnailFileName As String = Path.Combine(target, _
          String.Format("{0}_thumb{1}", file.GetNameWithoutExtension(), file.GetExtension()))

        thumbnail.Save(thumbnailFileName)
      Finally
        thumbnail.Dispose()
      End Try
    Finally
      originalImage.Dispose()
    End Try
  Next file
End Sub

C#

using System.Drawing;
using System.IO;
using Telerik.WebControls;
...
public bool ThumbnailCallback()
{
  return false;
}

protected void Button1_Click(object sender, EventArgs e)
{
  string target = Server.MapPath("~/UploadedImages");

  System.Drawing.Image.GetThumbnailImageAbort thumbnailImageAbortDelegate =
    new System.Drawing.Image.GetThumbnailImageAbort(ThumbnailCallback);

  foreach (UploadedFile file in RadUpload1.UploadedFiles)
  {
    file.SaveAs(Path.Combine(target, file.GetName()));

    using (Bitmap originalImage = new Bitmap(file.InputStream))
    {
      //You can implement additional logic which will compute
      // the width / height according your requirements
      int width = originalImage.Width / 2;
      int height = originalImage.Height / 2;

      using (System.Drawing.Image thumbnail =
        originalImage.GetThumbnailImage(width, height, thumbnailImageAbortDelegate, IntPtr.Zero))
      {
        string thumbnailFileName = Path.Combine(target,
          string.Format("{0}_thumb{1}", file.GetNameWithoutExtension(), file.GetExtension()));

        thumbnail.Save(thumbnailFileName);
      }
    }
  }
}

© 2002-2008 Telerik. All Rights Reserved.


Preventing Upload

Telerik RadUpload v2.4 Send comments on this topic.
Preventing Upload
Frequently Asked Questions > Preventing Upload

Glossary Item Box

Question

How to prevent the upload when the user clicks a button which is not supposed to upload files, e.g. Cancel, LogOut, etc.

Answer

RadUpload and any other control which uses <input type=file> HTML elements for file selection and upload will automatically upload all selected files when the user performs a postback. The only workaround for this problem is to clear the selected files before the postback.

Note: the code below will work only with LinkButton or other controls which use the __doPostBack function to initiate postback, such as DropDownList or CheckBox with AutoPostBack=true, not with regular ASP:Button. If you need to use ASP:Button you will have to set its property UseSubmitBehavior to false.

<script type="text/javascript">
function OnClientSubmitting(progressManager, args)
{
  var eventTarget = document.getElementById('__EVENTTARGET');
  if (eventTarget.value == '<%= ButtonCancel.UniqueID %>' ||
      eventTarget.value == '<%= OtherButtonWhichShouldNotUploadFiles.UniqueID %>')
  {
    //Clear the file inputs
    var upload = GetRadUpload('<%= RadUpload1.ClientID %>');
    var fileInputs = upload.GetFileInputs();
    for (var i=0; i<fileInputs.length; i++)
    {
      upload.ClearFileInputAt(i);
    }
  }
}
</script>
<rad:radprogressmanager runat="server" id="RadProgressManager1"
  onclientsubmitting="OnClientSubmitting" />
<rad:radupload runat="server" id="RadUpload1" />
<asp:linkbutton runat="server" id="ButtonUpload" text="Upload" />
<asp:linkbutton runat="server" id="ButtonCancel" text="Cancel" />
<asp:linkbutton runat="server" id="OtherButtonWhichShouldNotUploadFiles"
  text="Other Button Which Should Not Upload Files" />

© 2002-2008 Telerik. All Rights Reserved.


PROBLEM: Cannot Upload Large Files

Telerik RadUpload v2.4 Send comments on this topic.
PROBLEM: Cannot Upload Large Files
See Also
Troubleshooting > PROBLEM: Cannot Upload Large Files

Glossary Item Box

The following titles point to this topic in the Table of Contents:

  • "The page cannot be displayed"
  • "Server application is unavailable"
  • "System.OutOfMemoryException"
  • "Maximum request length exceeded"

The topic is referred by multiple titles because the problem described below may lead to any of the errors given in the titles.

SYMPTOMS

When you try to use the RadUpload or the standard HtmlInputFile control to upload a large file, the file may not be uploaded.

CAUSE

This problem occurs because the default value for the maxRequestLength parameter in the section of the Machine.config file is 4096 (4 megabytes). As a result, files that are larger than this value are not uploaded by default.

RESOLUTION

Follow the instructions to configure your application to be able to upload large files.

MORE INFORMATION

You may notice the following error messages if you encounter file size limits during the file upload process:

• The page cannot be displayed.

• Server Application is Unavailable

In the event log, the error message will be similar to the following: aspnet_wp.exe (PID:PIDNumber) was recycled because memory consumption exceeded the SizeLimit MB (Percentage percent of available RAM).

• Exception of type System.OutOfMemoryException was thrown.

You may also find that uploads occur very slowly. If you watch the Aspnet_wp.exe process in Windows Task Manager, you will notice that the memory delta changes by 64 KB every 1 to 2 seconds. Depending on the size of the file, this delay may cause the ASP.NET worker process to recycle because of a responseDeadlock error.

See Also

PRB: Cannot Upload Large Files When You Use the HtmlInputFile Server Control

© 2002-2008 Telerik. All Rights Reserved.


Select Button Falls Below the Text Box

Telerik RadUpload v2.4 Send comments on this topic.
Select Button Falls Below the Text Box
Troubleshooting > Select Button Falls Below the Text Box

Glossary Item Box

SYMPTOMS

Sometimes the Select button can fall below the text box, but still to be clickable in its regular place.

CAUSE

The width of some of the tables is less than the combined width of the TextBox and the Button which emulate the skin of the File Input

RESOLUTION

Follow the instructions for Modifying File Input Appearance and Modifying the Overall Appearance, or set EnableFileInputSkinning property to false.

© 2002-2008 Telerik. All Rights Reserved.


Select Button does not Work

Telerik RadUpload v2.4 Send comments on this topic.
Select Button does not Work
Troubleshooting > Select Button does not Work

Glossary Item Box

SYMPTOMS

When you try click the Select button of RadUpload it doesn't work, or you need to click somewhere else in order to bring the browser dialog.

CAUSE

The TextBox is wider or shorter than the text area of the File Input, or the Button is wider or shorter than the button area of the File Input.

RESOLUTION

Follow the instructions for Modifying File Input Appearance or set EnableFileInputSkinning property to false.

© 2002-2008 Telerik. All Rights Reserved.


The Text in the TextBox does not Scroll

Telerik RadUpload v2.4 Send comments on this topic.
The Text in the TextBox does not Scroll
Troubleshooting > The Text in the TextBox does not Scroll

Glossary Item Box

SYMPTOMS

The text in the TextBox doesn't scroll when I move the cursor with the keyboard.

CAUSE

The displayed text is in the TextBox, but the cursor is in the file input. The cursor position and the visible part of the text in the file input and the TextBox cannot be controlled using javascript.

RESOLUTION

Disable the text editing in the file input by setting ReadOnlyFileInputs property to true, or Set EnableFileInputSkinning property to false.

© 2002-2008 Telerik. All Rights Reserved.


My Files are not Uploaded

Telerik RadUpload v2.4 Send comments on this topic.
My Files are not Uploaded
Troubleshooting > My Files are not Uploaded

Glossary Item Box

SYMPTOMS

When you try to use the RadUpload the UploadedFiles collection has no files inside.

CAUSE

There are two possible reasons for the problem:

  • You have set File Validation and the the uploaded files are considered invalid.
  • You are using a Button or other control which causes postback, placed inside RadAjaxPanel (or UpdatePanel), or the Button has associated AjaxSetting (RadAjax) or a Trigger (ASP.NET AJAX)

RESOLUTION

  • If the reason for the problem was the File Validation, try tweaking the File Validation properties, such as AllowedFileExtensions, AllowedMimeTypes and MaxFileSize.
  • If the reason for the problem was RadAjax / ASP.NET ATLAS, try removing the control which makes postback (callback) from the AjaxPanel or UpdatePanel, or remove its associated AjaxSetting or Trigger, or use one of these workarounds

MORE INFORMATION

RadAjax, ASP.NET AJAX or any other similar framework for asynchronous calls uses the XmlHttpRequest component to make its callback requests to the web application, which is not able to upload files.

© 2002-2008 Telerik. All Rights Reserved.


RadProgressArea does not work

Telerik RadUpload v2.4 Send comments on this topic.
RadProgressArea does not work
Troubleshooting > RadProgressArea does not work

Glossary Item Box

SYMPTOMS

When you submit the page the RadProgressArea control is not shown.

CAUSE

There are several possible reasons for the problem:

  1. The project is hosted in IIS7. RadMemoryOptimization is not supported in IIS7 yet.
  2. RadUploadHttpModule and / or RadUploadProgressHandler are not registered in web.config.
  3. There is no RadProgressManager on the page.
  4. The files are uploaded with AJAX call.
  5. There is a URL rewriter in the application.
  6. There are other HTTP modules in the application which are designed to handle file uploads.
  7. The application level trace is enabled in web.config.
  8. The application is hosted in a web garden or web farm.

Note: Please, first upgrade to the latest available version of the control.

RESOLUTION

The resolutions of each cause follow:

  1. Host your project in IIS5 (Windows 2000), IIS5.1 (Windows XP), IIS6 (Windows 2003) or the VisualStudio 2005 Web Development Server (FileSystem based Web Site)
  2. Add RadUploadHttpModule and RadUploadProgressHandler registrations in your web.config.
  3. Add RadProgressManager on the page. You will need the RadUploadHttpModule and RadUploadProgressHandler registrations as well.
  4. RadUpload and any other upload control which uses <input type=file> html elements is unable to upload files with AJAX calls. For more information and workarounds check Uploading Files with AJAX.
  5. Configure your URL rewriter to exclude the path "/Telerik.RadUploadProgressHandler.aspx" from rewriting.
  6. Remove all HTTP modules for file upload handling except RadUploadHttpModule. It is possible that the components which use the disabled modules will be rendered inoperational.
  7. Disable the application level trace.
  8. RadProgressArea cannot be used in web garden or web farm. The files will be uploaded successfuly, but no progress will be displayed. If possible, disable the web garden.

MORE INFORMATION

Check the known limitaions for more information.

© 2002-2008 Telerik. All Rights Reserved.


RadUpload Does Not Persist Its Value

Telerik RadUpload v2.4 Send comments on this topic.
RadUpload Does Not Persist Its Value
Troubleshooting > RadUpload Does Not Persist Its Value

Glossary Item Box

SYMPTOMS

When you make a postback, RadUpload does not persist the selected files in its file inputs.

CAUSE

This problem occurs because the <input type=file> HTML elements do not persist their value between postbacks.

RESOLUTION

There is no resolution, this behavior is forced by the security restrictions of the browsers.

© 2002-2008 Telerik. All Rights Reserved.


Important Objects, Methods and Events

Telerik RadUpload v2.4 Send comments on this topic.
Important Objects, Methods and Events
Client-side Programming > Important Objects, Methods and Events

Glossary Item Box

The controls in the RadUpload suite provide rich client-side API which gives you the ability to freely manupulate the controls using JavaScript.

RadUpload

You can get the client-side object using the code below

ASPX/ASCX

<script type="text/javascript">
var upload = GetRadUpload('<%= RadUpload1.ClientID %>');
...
</script>
<rad:radupload runat="server" id="RadUpload1" />

Note: there are other methods for retrieving the RadUpload client-side object, described in Getting RadUpload Client Object

Important Methods

  • GetFileInputs() method- returns array, containing all file inputs in the RadUpload instance. Useful when you want to find how many file inputs are currently present in a particular RadUpload instance, or when you want to access their values.
  • ClearFileInputAt(index) method- Clears the selected file in a file input at the specified index in the RadUpload instance. Useful when you want to clear all file inputs for some reason, for example when the user clicks a button which should not upload files, e.g. the "Cancel" button.
  • GetID(name) method - Creates a new ID, based on the RadUpload ClientID and the name parameter. You should use this method when you are adding additional fields for each file input in a RadUpload instance.

Important Events

  • OnClientAdded event - Raised after a new file input is added to the RadUpload instance. Useful when you want to manipulate the newly added file input, e.g. when you want to add additional text fields to RadUpload, or modify the file inputs' width.
  • OnClientFileSelected event - Raised after a file is selected in RadUpload. Useful when you want to automatically add new file input if there are no empty file inputs left, or to create a client-side image preview.

© 2002-2008 Telerik. All Rights Reserved.


Getting RadUpload Client Object

Telerik RadUpload v2.4 Send comments on this topic.
Getting RadUpload Client Object
Client-side API Reference > Getting RadUpload Client Object

Glossary Item Box

There are several possible means to reference the client-side RadUpload object.

ASPX

<rad:radupload runat="server" id="RadUpload1" />
<asp:button runat="server" id="Button1" text="Show inputs count"
    onclientclick="showInputsCount()" />

  1. Through the window object of the browser (recommended):

    <script type="text/javascript">
    function showInputsCount()
    {
        var upload = window['<%= RadUpload1.ClientID %>'];
        alert("RadUpload has " + upload.GetFileInputs().length + " file inputs.");
    }
    </script>

  2. Through the GetRadUpload() function, which executes the same code as in the previous method (recommended):

    <script type="text/javascript">
    function showInputsCount()
    {
        var upload = GetRadUpload('<%= RadUpload1.ClientID %>');
        alert("RadUpload has " + upload.GetFileInputs().length + " file inputs.");
    }
    </script>

  3. Directly calling the client-side object variable (this will not work when the ClientID contains invalid for javascript characters)

    <script type="text/javascript">
    function showInputsCount()
    {
        alert("RadUpload has " + <%= RadUpload1.ClientID %>.GetFileInputs().length + " file inputs.");
    }
    </script>

© 2002-2008 Telerik. All Rights Reserved.


Members

Telerik RadUpload v2.4 Send comments on this topic.
Members
Client-side API Reference > Classes > Members

Glossary Item Box

Method | Description
CancelRequest | Cancels the current request by refreshing the page
Show | Shows the RadProgressArea
Hide | Hides the RadProgressArea
Update | Updates the RadProgressArea with the information from a ProgressData object. Fires the OnClientProgressUpdating event. If the RadProgressArea is hidden, this method will show it.
UpdateHorizontalProgressBar | Updates the width of a given progress bar element
UpdateVerticalProgressBar | Updates the height of a given progress bar element

Event | Description
OnClientProgressUpdating | This event is fired when the ProgressArea is about to be updated. Can be canceled.
OnClientProgressBarUpdating | This event is fired when the ProgressArea is about update a progress bar. Can be canceled.

© 2002-2008 Telerik. All Rights Reserved.


CancelRequest

Telerik RadUpload v2.4 Send comments on this topic.
CancelRequest
Client-side API Reference > Classes > RadProgressArea > Methods > CancelRequest

Glossary Item Box

Cancels the current request by refreshing the page. This method works only when the page is being submitted.

function CancelRequest()

Parameters:

none

Example:

This example demonstrates how to cancel the current request.

<rad:radprogressarea runat="server" id="RadProgressArea1" />

<input type="button" value="Show" onclick="myCancel" />

<script>
function myCancel()
{
<%= RadProgressArea1.ClientID %>.CancelRequest();
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


Hide

Telerik RadUpload v2.4 Send comments on this topic.
Hide
Client-side API Reference > Classes > RadProgressArea > Methods > Hide

Glossary Item Box

Hides the RadProgressArea.

function Hide()

Parameters:

none

Example:

This example demonstrates how to hide a RadProgressArea.

<rad:radprogressarea runat="server" id="RadProgressArea1" />

<input type="button" value="Hide" onclick="myHide" />

<script>
function myHide()
{
<%= RadProgressArea1.ClientID %>.Hide();
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


Show

Telerik RadUpload v2.4 Send comments on this topic.
Show
Client-side API Reference > Classes > RadProgressArea > Methods > Show

Glossary Item Box

Shows the RadProgressArea.

function Show()

Parameters:

none

Example:

This example demonstrates how to show a RadProgressArea.

<rad:radprogressarea runat="server" id="RadProgressArea1" />

<input type="button" value="Show" onclick="myShow" />

<script>
function myShow()
{
<%= RadProgressArea1.ClientID %>.Show();
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


Update

Telerik RadUpload v2.4 Send comments on this topic.
Update
Client-side API Reference > Classes > RadProgressArea > Methods > Update

Glossary Item Box

Updates the RadProgressArea with the information from a ProgressData object. Fires the OnClientProgressUpdating event. If the RadProgressArea is hidden, this method will show it by calling the Show() method.

function Update(progressData)

Parameters:

progressData

Example:

This example demonstrates how to update a RadProgressArea with a custom ProgressData object.

<rad:radprogressarea runat="server" id="RadProgressArea1" />

<input type="button" value="Update" onclick="myUpdate" />

<script>
function myUpdate()
{
var progressData =
{
PrimaryPercent : 10,
PrimaryTotal : '50kB',
PrimaryValue : '5kB',
SecondaryPercent : 50,
SecondaryTotal : '20kB',
SecondaryValue : '10kB',
CurrentOperationText : 'c:\\test.jpg',
TimeElapsed : '5seconds',
TimeEstimated : '10seconds',
TransferSpeed : '100kB/second'
}
<%= RadProgressArea1.ClientID %>.Update(progressData);
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


UpdateHorizontalProgressBar

Telerik RadUpload v2.4 Send comments on this topic.
UpdateHorizontalProgressBar
Client-side API Reference > Classes > RadProgressArea > Methods > UpdateHorizontalProgressBar

Glossary Item Box

Updates the width of a given progress bar element

function UpdateHorizontalProgressBar(element, percent)

Parameters:

element - the HTML element which represents the progress bar. By default this is an image

percent - the width of the element in percent of its parent element

Example:

See the example in OnClientProgressBarUpdating.

© 2002-2008 Telerik. All Rights Reserved.


UpdateVerticalProgressBar

Telerik RadUpload v2.4 Send comments on this topic.
UpdateVerticalProgressBar
Client-side API Reference > Classes > RadProgressArea > Methods > UpdateVerticalProgressBar

Glossary Item Box

Updates the height of a given progress bar element

function UpdateVerticalProgressBar(element, percent)

Parameters:

element - the HTML element which represents the progress bar. By default this is an image

percent - the height of the element in percent of its parent element

Example:

See the example in OnClientProgressBarUpdating.

© 2002-2008 Telerik. All Rights Reserved.


OnClientProgressUpdating

Telerik RadUpload v2.4 Send comments on this topic.
OnClientProgressUpdating
Client-side API Reference > Classes > RadProgressArea > Events > OnClientProgressUpdating

Glossary Item Box

This event is fired when the RadProgressArea is about to be updated. Can be canceled. Useful if you need to modify the ProgressData before it is applied to the RadProgressArea.

function OnClientProgressUpdating(radProgressArea, args)

Parameters:

radProgressArea - the RadProgressArea instance firing the event.

args - event arguments object.

ProgressData - contains the ProgressData object which will be used to update the RadProgressArea.

Remarks:

This event can be cancelled by returning false from the handler function.

If you cancel this event the progress area will not be updated.

Example:

This example demonstrates how to implement a confirmation dialog when updating RadProgressArea control.

...

<rad:radprogressarea runat="server" id="RadProgressArea1"
onclientprogressupdating="myOnClientProgressUpdating" />

...

<script>
function myOnClientProgressUpdating()
{
return confirm("Are you sure you want to update the Progress Area?");
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


OnClientProgressBarUpdating

Telerik RadUpload v2.4 Send comments on this topic.
OnClientProgressBarUpdating
Client-side API Reference > Classes > RadProgressArea > Events > OnClientProgressBarUpdating

Glossary Item Box

This event is fired when the RadProgressArea is about to update one of its progress bars. Can be canceled. Useful if you need to override the default behavior of the progress bars, for example to create a vertical progress bar.

function OnClientProgressBarUpdating(radProgressArea, args)

Parameters:

radProgressArea - the RadProgressArea instance firing the event.

args - event arguments object.

ProgressValue - the progress bar value.
ProgressBarElementName - can be TotalProgressBar or FilesCountBar
ProgressBarElement - the element which represents the progress bar

Remarks:

This event can be cancelled by returning false from the handler function.

If you cancel this event the corresponding progress bar will not be updated.

Example:

This example demonstrates how to create one horizontal progress bar and one vertical. In this example we added the UpdateHorizontalProgressBar call only for clarity. This is the default code which will be executed if the first "if" is omitted.

...

<rad:radprogressarea runat="server" id="RadProgressArea1"
onclientprogressbarupdating="myOnClientProgressBarUpdating" />

...

<script>
function myOnClientProgressBarUpdating(radProgressArea, args)
{
//The primary progress bar will be horizontal (default)
if (args.ProgressBarElementName == "PrimaryProgressBar")
{
radProgressArea.UpdateHorizontalProgressBar(
args.ProgressBarElement, args.ProgressValue);
//Skip the default progress bar updating
return false;
}
//The secondary progress bar will be vertical
if (args.ProgressBarElementName == "SecondaryProgressBar")
{
radProgressArea.UpdateVerticalProgressBar(
args.ProgressBarElement, args.ProgressValue);
//Skip the default progress bar updating
return false;
}
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


Members

Telerik RadUpload v2.4 Send comments on this topic.
Members
Client-side API Reference > Classes > Members

Glossary Item Box

Method | Description
StartProgressPolling | Starts the progress polling. Useful when RadProgressManager does not handle the form.submit event by itself, or when you need to start the progress monitoring before the form is submitted.

Event | Description
OnClientProgressStarted | This event is fired after the progress monitoring has started.
OnClientProgressUpdating | This event is fired when RadProgressManager is about to update the registered RadProgressArea controls with the current progress data. Can be cancelled.

© 2002-2008 Telerik. All Rights Reserved.


StartProgressPolling

Telerik RadUpload v2.4 Send comments on this topic.
StartProgressPolling
Client-side API Reference > Classes > RadProgressManager > Methods > StartProgressPolling

Glossary Item Box

Starts the progress polling. Useful when RadProgressManager does not handle the form.submit event by itself, or when you need to start the progress monitoring before the form is submitted.

function StartProgressPolling()

Parameters:

none

Example:

This example demonstrates how to start the progress polling from a button when the RadProgressManager does not handle the form.submit event.

<rad:radprogressmanager runat="server" id="RadProgressManager1"
RegisterForSubmit="false" />

<input type="button" value="Start" onclick="myStart" />

<script>
function myStart()
{
RadProgressManager.StartProgressPolling();
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


OnClientProgressStarted

Telerik RadUpload v2.4 Send comments on this topic.
OnClientProgressStarted
Client-side API Reference > Classes > RadProgressManager > Events > OnClientProgressStarted

Glossary Item Box

This event is fired after the progress monitoring is started.

function OnClientProgressStarted(radProgressManager)

Parameters:

radProgressManager - the RadProgressManager instance firing the event.

Remarks:

This event cannot be cancelled.

Example:

This example demonstrates how to implement a notification dialog when the progress monitoring starts.

...

<rad:radprogressmanager runat="server" id="RadManager1"
onclientprogressstarted="myOnClientProgressStarted" />

...

<script>
function myOnClientProgressStarted()
{
alert("The progress monitoring is starting...");
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


OnClientProgressUpdating

Telerik RadUpload v2.4 Send comments on this topic.
OnClientProgressUpdating
Client-side API Reference > Classes > RadProgressManager > Events > OnClientProgressUpdating

Glossary Item Box

This event is fired when RadProgressManager is about to update the registered RadProgressArea controls with the current progress data. Can be cancelled.

function OnClientProgressUpdating(radProgressManager)

Parameters:

radProgressManager - the RadProgressManager instance firing the event.

Remarks:

This event can be cancelled by returning false from the handler function.

If you cancel this event the progress areas on the page will not be updated.

Example:

This example demonstrates how to implement a confirmation dialog before RadProgressManager updates the RadProgressAreas on the page.

...

<rad:radprogressmanager runat="server" id="RadManager1"
onclientprogressupdating="myOnClientProgressUpdating" />

...

<script>
function myOnClientProgressUpdating()
{
return confirm("Do you want to update the progress areas on the page?");
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


Members

Telerik RadUpload v2.4 Send comments on this topic.
Members
Client-side API Reference > Classes > Members

Glossary Item Box

Method | Description
AddFileInput | Adds a new file input to the RadUpload instance.
AddFileInputAt | Adds a new file input at the specified index to the RadUpload instance
ClearFileInputAt | Clears the value of a file input at the specified index in the RadUpload instance
DeleteFileInputAt | Deletes the file input at the selected index.
DeleteSelectedFileInputs | Deletes the checked file inputs.
GetFileInputs | Gets an array, containing all file inputs in the RadUpload instance.
GetID | Gets a new ID, based on the RadUpload ClientID.
ValidateExtensions | Returns a value indicating whether the client-side validation of the selected file names succeeded.

Event | Description
OnClientAdded | This event is fired after a file input was added.
OnClientAdding | This event is fired when a new file input is being added.
OnClientClearing | This event is fired when a file input is being cleared by clicking the Clear button.
OnClientDeleting | This event is fired when a file input is being deleted.
OnClientDeletingSelected | This event is fired when the checked file inputs are being deleted.
OnClientFileSelected | This event is fired after a file was selected in a file input.

© 2002-2008 Telerik. All Rights Reserved.


AddFileInput

Telerik RadUpload v2.4 Send comments on this topic.
AddFileInput
Client-side API Reference > Classes > RadUpload > Methods > AddFileInput

Glossary Item Box

Adds a new file input to the RadUpload instance.

function AddFileInput()

Parameters:

none

Example:

This example demonstrates how to add a new file input using a button outside the RadUpload.

<rad:radupload runat="server" id="RadUpload1" />

<input type="button" value="Add" onclick="myAdd()" />

<script>
function myAdd()
{
<%= RadUpload1.ClientID %>.AddFileInput();
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


AddFileInputAt

Telerik RadUpload v2.4 Send comments on this topic.
AddFileInputAt
Client-side API Reference > Classes > RadUpload > Methods > AddFileInputAt

Glossary Item Box

Adds a new file input at the specified index to the RadUpload instance.

function AddFileInputAt(index)

Parameters:

index - The location in the array to add the file input

Example:

This example demonstrates how to add a new file input using a button outside the RadUpload.

<rad:radupload runat="server" id="RadUpload1" />

<input type="button" value="Add" onclick="myAdd()" />

<script>
function myAdd()
{
<%= RadUpload1.ClientID %>.AddFileInputAt(0);
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


ClearFileInputAt

Telerik RadUpload v2.4 Send comments on this topic.
ClearFileInputAt
Client-side API Reference > Classes > RadUpload > Methods > ClearFileInputAt

Glossary Item Box

Clears the value of a file input at the specified index in the RadUpload instance.

function ClearFileInputAt(index)

Parameters:

index - The index of the file input to clear

Example:

This example demonstrates how to clear all file inputs using a button outside the RadUpload.

<rad:radupload runat="server" id="RadUpload1" />

<input type="button" value="Clear All" onclick="myClearAll()" />

<script type="text/javascript">
function myClearAll()
{
var upload = GetRadUpload('<%= RadUpload1.ClientID %>');
var fileInputs = upload.GetFileInputs();
for (var i=0; i<fileInputs.length; i++)
{
upload.ClearFileInputAt(i);
}
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


DeleteFileInputAt

Telerik RadUpload v2.4 Send comments on this topic.
DeleteFileInputAt
Client-side API Reference > Classes > RadUpload > Methods > DeleteFileInputAt

Glossary Item Box

Deletes a file input at the selected index.

function DeleteFileInputAt(index)

Parameters:

index - the zero based index of the file input to be deleted.

Example:

This example demonstrates how to delete the first file input from a RadUpload instance.

...

<rad:radupload runat="server" id="RadUpload1" />

<input type="button" value="Delete first" onclick="myDelete()" />

...

<script>
function myDelete()
{
//The check for the file input existence is internal
<%= RadUpload1.ClientID %>.DeleteFileInputAt(0);
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


DeleteSelectedFileInputs

Telerik RadUpload v2.4 Send comments on this topic.
DeleteSelectedFileInputs
Client-side API Reference > Classes > RadUpload > Methods > DeleteSelectedFileInputs

Glossary Item Box

Deletes the checked file inputs.

function DeleteSelectedFileInputs()

Parameters:

none

Example:

This example demonstrates how to delete the checked file inputs from a RadUpload instance.

...

<rad:radupload runat="server" id="RadUpload1" />

<input type="button" value="Delete first" onclick="myDelete()" />

...

<script>
function myDelete()
{
<%= RadUpload1.ClientID %>.DeleteSelectedFileInputs();
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


GetFileInputs

Telerik RadUpload v2.4 Send comments on this topic.
GetFileInputs
Client-side API Reference > Classes > RadUpload > Methods > GetFileInputs

Glossary Item Box

Gets an array, containing all file inputs in the RadUpload instance.

function GetFileInputs()

Parameters:

none

Example:

This example demonstrates how to alert the path of each selected file in а RadUpload instance.

<rad:radupload runat="server" id="RadUpload1" />

<input type="button" value="Show Files" onclick="showFiles()" />

<script>
function showFiles()
{
var fileInputs = GetRadUpload('<%= RadUpload1.ClientID %>').GetFileInputs();
for (var i=0; i<fileInputs.length; i++)
{
alert(fileInputs[i].value);
}
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


GetID

Telerik RadUpload v2.4 Send comments on this topic.
GetID
Client-side API Reference > Classes > RadUpload > Methods > GetID

Glossary Item Box

Gets a new ID, based on the RadUpload ClientID. This method is used when adding additional fields to a RadUpload instance.

function GetID(name)

Parameters:

name - the alias of the input to be added. The value of this parameter is used server-side to get the value of the field.

Example:

This example demonstrates how to add an additional text field to a RadUpload instance. More information and complete example can be found in Adding Text Fields.

<rad:radupload runat="server" id="RadUpload1" onclientadded="addTitle" />

<script>
function addTitle(radUpload, args)
{
var cell = args.Row.cells[1];
var title = document.createElement("input");
title.id = title.name = radUpload.GetID("title");
cell.appendChild(title);
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


ValidateExtensions

Telerik RadUpload v2.4 Send comments on this topic.
ValidateExtensions
Client-side API Reference > Classes > RadUpload > Methods > ValidateExtensions

Glossary Item Box

Returns a value indicating whether the client-side validation of the selected file names succeeded.

function ValidateExtensions()

Parameters:

none

Example:

This example demonstrates how to integrate RadUpload with a CustomValidator and only allow uploading of .ZIP and .RAR files.

Note: The validator's ControlToValidate property must not be set.

<rad:radupload runat="server" id="RadUpload1"
allowedfileextensions=".zip,.rar" />

<asp:customvalidator runat="server" id="CustomValidator1" display="Dynamic" clientvalidationfunction="ValidateRadUpload1">Invalid extensions.</asp:customvalidator>

<asp:button runat="server" id="Upload" text="Upload" />

<script>
function ValidateRadUpload1(source, arguments)
{
arguments.IsValid = <%= RadUpload1.ClientID %>.ValidateExtensions();
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


OnClientAdded

Telerik RadUpload v2.4 Send comments on this topic.
OnClientAdded
Client-side API Reference > Classes > RadUpload > Events > OnClientAdded

Glossary Item Box

This event is fired after a file input was added.

function OnClientAdded(radUpload, args)

Parameters:

radUpload - the RadUpload instance firing the event.

args - an object with one property, containing the newly added row

Example:

This example demonstrates how to add an additional text field to a RadUpload instance. More information and complete example can be found in Adding Text Fields.

<rad:radupload runat="server" id="RadUpload1" onclientadded="addTitle" />

<script>
function addTitle(radUpload, args)
{
var cell = args.Row.cells[1];
var title = document.createElement("input");
title.id = title.name = radUpload.GetID("title");
cell.appendChild(title);
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


OnClientAdding

Telerik RadUpload v2.4 Send comments on this topic.
OnClientAdding
Client-side API Reference > Classes > RadUpload > Events > OnClientAdding

Glossary Item Box

This event is fired when a new file input is being added.

function OnClientAdding(radUpload)

Parameters:

radUpload - the RadUpload instance firing the event.

Remarks:

This event can be cancelled by returning false from the handler function.

Example:

This example demonstrates how to implement a confirmation dialog when adding a new item in a RadUpload control.

...

<rad:radupload runat="server" id="RadUpload1" onclientadding="myOnClientAdding" />

...

<script>
function myOnClientAdding()
{
return confirm("Are you sure you want to add a new file input?");
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


OnClientClearing

Telerik RadUpload v2.4 Send comments on this topic.
OnClientClearing
Client-side API Reference > Classes > RadUpload > Events > OnClientClearing

Glossary Item Box

This event is fired when a file input is being cleared by clicking the Clear button.

function OnClientClearing(radUpload, eventArgs)

Parameters:

radUpload - the RadUpload instance firing the event.

eventArgs - RadUploadEventArgs object that contain the event data.

Remarks:

This event can be cancelled by returning false from the handler function.

Example:

This example demonstrates how to implement a confirmation dialog when clearing an item in a RadUpload control.

...

<rad:radupload runat="server" id="RadUpload1" onclientclearing="myOnClientClearing" />

...

<script>
function myOnClientClearing(radUpload, eventArgs)
{

//Check if the input field which will be cleared has a file selected
if (eventArgs.FileInputField.value.length > 0)

{

//If there is a file selected show confirmation
return confirm("Are you sure you want to clear this field?");
}
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


OnClientDeleting

Telerik RadUpload v2.4 Send comments on this topic.
OnClientDeleting
Client-side API Reference > Classes > RadUpload > Events > OnClientDeleting

Glossary Item Box

This event is fired when a file input is being deleted.

function OnClientDeleting(radUpload, eventArgs)

Parameters:

radUpload - the RadUpload instance firing the event.

eventArgs - RadUploadEventArgs object that contain the event data.

Remarks:

This event can be cancelled by returning false from the handler function.

Example:

This example demonstrates how to implement a confirmation dialog when deleting an item in a RadUpload control.

...

<rad:radupload runat="server" id="RadUpload1" onclientdeleting="myOnClientDeleting" />

...

<script>
function myOnClientDeleting(radUpload, eventArgs)
{

//Check if the input field which will be deleted has a file selected
if (eventArgs.FileInputField.value.length > 0)

{

//If there is a file selected show confirmation
return confirm("Are you sure you want to delete this field?");
}
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


OnClientDeletingSelected

Telerik RadUpload v2.4 Send comments on this topic.
OnClientDeletingSelected
Client-side API Reference > Classes > RadUpload > Events > OnClientDeletingSelected

Glossary Item Box

This event is fired when the checked file inputs are being deleted.

function OnClientDeletingSelected(radUpload, eventArgs)

Parameters:

radUpload - the RadUpload instance firing the event.

eventArgs - RadUploadDeleteSelectedEventArgs object that contain the event data.

Remarks:

This event can be cancelled by returning false from the handler function.

Example:

This example demonstrates how to implement a confirmation dialog when deleting the selected items in a RadUpload control.

...

<rad:radupload runat="server" id="RadUpload1" onclientdeletingselected="myOnClientDeletingSelected" />

...

<script>
function myOnClientDeletingSelected(radUpload)
{

// Check if there are selected files
if (eventArgs.FileInputFields.length > 0)
{
return confirm("Are you sure you want to delete the selected fields?");
}
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


OnClientFileSelected

Telerik RadUpload v2.4 Send comments on this topic.
OnClientFileSelected
Client-side API Reference > Classes > RadUpload > Events > OnClientFileSelected

Glossary Item Box

This event is fired after a file was selected in a file input.

function OnClientSelected(radUpload, eventArgs)

Parameters:

radUpload - the RadUpload instance firing the event.

eventArgs - RadUploadEventArgs object that contain the event data.

Remarks:

This event cannot be cancelled.

Example:

This example demonstrates how to implement a simple image preview before uploading.

...

<img id="imagePreview" src="empty.gif" />
<rad:radupload runat="server" id="RadUpload1" onclientfileselected="myOnClientFileSelected" />

<script>
...

<script>
function myOnClientFileSelected(radUpload, eventArgs)
{
var image = document.getElementById("imagePreview");
if (image != null)
{
var selectedFileName = eventArgs.FileInputField.value.toLowerCase();

//Get the selected file extension
var selectedFileExt = selectedFileName.substring(selectedFileName.lastIndexOf(".") + 1);

//Check if the selected file is image
if (selectedFileExt == "gif" || selectedFileExt == "jpg")
{
//Show the image
image.src = selectedFileName;
}
else
{
//If the selected file is not an image show the blank image
image.src = "empty.gif";
}
}
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


Members

Telerik RadUpload v2.4 Send comments on this topic.
Members
Client-side API Reference > Classes > Members

Glossary Item Box

Property | Description
FileInputField | Contains the <input type="file"> object for the event.

© 2002-2008 Telerik. All Rights Reserved.


FileInputField

Telerik RadUpload v2.4 Send comments on this topic.
FileInputField
See Also
Client-side API Reference > Classes > RadUploadEventArgs > Properties > FileInputField

Glossary Item Box

This property contains the <input type="file"> object for the event.

Note: Due to the browser security restrictions the value of the <input type="file"> object cannot be changed.

See Also

RadUploadEventArgs members
OnClientClearing event
OnClientDeleting event
OnClientSelected event

© 2002-2008 Telerik. All Rights Reserved.


Members

Telerik RadUpload v2.4 Send comments on this topic.
Members
Client-side API Reference > Classes > Members

Glossary Item Box

Property | Description
FileInputFields | Contains an array of <input type="file"> object for the event.

© 2002-2008 Telerik. All Rights Reserved.


FileInputFields

Telerik RadUpload v2.4 Send comments on this topic.
FileInputFields
Client-side API Reference > Classes > RadUploadDeleteSelectedEventArgs > Properties > FileInputFields

Glossary Item Box

Contains an array of <input type="file"> object for the event.

Note: Due to the browser security restrictions the value of the <input type="file"> object cannot be changed.

Example:

This example demonstrates how to implement a confirmation dialog when deleting the selected items in a RadUpload control. The dialog is displayed only if there are selected files in the input fields for deletion.

<script>
function myOnCientDeletingSelected(radUpload, eventArgs)
{
var atLeastOneFileSelected = false;
for (var i=0; i<eventArgs.FileInputFields.length; i++)
{
if (eventArgs.FileInputFields[i].value.length > 0)
{
atLeastOneFileSelected = true;
break;
}
}
// Check if there are selected files
if (atLeastOneFileSelected)
{
return confirm("Are you sure you want to delete the selected fields?");
}
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


RadProgressArea Class

RadUpload Send comments on this topic.
RadProgressArea Class
See Also Members
[image]
Telerik.WebControls Namespace : RadProgressArea Class

Object Model

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Class RadProgressArea
   Inherits RadLocalizableControl
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
C#
public class RadProgressArea : RadLocalizableControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadUploadUtils.RadControl
Telerik.RadUploadUtils.RadSkinnableControl
Telerik.RadUploadUtils.RadLocalizableControl
Telerik.WebControls.RadProgressArea

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

RadProgressArea Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadProgressArea Class Members

RadProgressArea Class Members
See Also Fields Properties Methods Events
[image]
Telerik.WebControls Namespace : RadProgressArea Class

The following tables list the members exposed by RadProgressArea.

Public Constructors

 | Name | Description
Public Constructor | RadProgressArea Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CancelButtonName |
static (Shared in Visual Basic) | CurrentOperationName |
static (Shared in Visual Basic) | PrimaryPercentName |
static (Shared in Visual Basic) | PrimaryProgressBarName |
static (Shared in Visual Basic) | PrimaryTotalName |
static (Shared in Visual Basic) | PrimaryValueName |
static (Shared in Visual Basic) | SecondaryPercentName |
static (Shared in Visual Basic) | SecondaryProgressBarName |
static (Shared in Visual Basic) | SecondaryTotalName |
static (Shared in Visual Basic) | SecondaryValueName |
static (Shared in Visual Basic) | SpeedName |
static (Shared in Visual Basic) | TimeElapsedName |
static (Shared in Visual Basic) | TimeEstimatedName |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DisplayCancelButton |
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Language | Specifies the localization of the RadProgressArea (the language which will be used).
Public Property | Localization | Provides access to the localization strings of the control. (Inherited from Telerik.RadUploadUtils.RadLocalizableControl)
Public Property | Localization2 | Provides access to the localization strings of the control.
Public Property | LocalizationPath | (Inherited from Telerik.RadUploadUtils.RadLocalizableControl)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientProgressBarUpdating | Specifies the client-side function to be executed when a progress bar is about to be updated.
Public Property | OnClientProgressUpdating | Specifies the client-side function to be executed when the Progress Area status is about to be updated.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | ProgressIndicators |
Public Property | ProgressTemplate |
Public Property | RadControlsDir | (Inherited from Telerik.RadUploadUtils.RadControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | Overridden. Gets or sets the name of the skin used.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | Overridden. Gets or sets the relative path of the folder containing the skins.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadUploadUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | ControlCssFiles | Overridden.
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | InitScript | Overridden.
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | JavaScriptFiles | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | LocalizationFile | Overridden.
Protected Property | LocalizationLanguage | Overridden.
Protected Property | LocalizationResourceLocation | Overridden.
Protected Property | LocalizationScript | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Property | TagKey | Overridden.
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. Overridden.
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | Overridden.
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | CheckIfScriptsFolderExists | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | CheckWorkingConditions | Overloaded. (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | FormatControlMessage | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsRemoteUrl | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | IsUsingWebResourceScripts | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | Overridden.
Protected Method | RenderChildren | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | Overridden.
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

Protected Events

 | Name | Description
Protected Event | RadControlsDirChanged | (Inherited from Telerik.RadUploadUtils.RadControl)
Top

See Also

Reference

RadProgressArea Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadProgressArea Constructor

RadProgressArea Constructor
See Also
[image]
Telerik.WebControls Namespace > RadProgressArea Class : RadProgressArea Constructor

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea()
C#
public RadProgressArea()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea()
C#
public RadProgressArea()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


RadProgressArea Class Methods

RadProgressArea Class Methods
[image]
Telerik.WebControls Namespace : RadProgressArea Class

For a list of all members of this type, see RadProgressArea members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. Overridden.
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | Overridden.
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | CheckIfScriptsFolderExists | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | CheckWorkingConditions | Overloaded. (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | FormatControlMessage | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsRemoteUrl | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | IsUsingWebResourceScripts | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | Overridden.
Protected Method | RenderChildren | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | Overridden.
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

RadProgressArea Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


AddAttributesToRender Method

AddAttributesToRender Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class : AddAttributesToRender Method

writer

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub AddAttributesToRender( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim writer As HtmlTextWriter

instance.AddAttributesToRender(writer)
C#
protected override void AddAttributesToRender(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


CreateChildControls Method

CreateChildControls Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class : CreateChildControls Method

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub CreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea

instance.CreateChildControls()
C#
protected override void CreateChildControls()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


DataBind Method

DataBind Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class : DataBind Method

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Overload List

Overload | Description
DataBind() |
DataBind(Boolean) | (Inherited from System.Web.UI.Control)

Overload List

Overload | Description
DataBind() |
DataBind(Boolean) | (Inherited from System.Web.UI.Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


DataBind() Method

DataBind() Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class > DataBind Method : DataBind() Method

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea

instance.DataBind()
C#
public override void DataBind()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


Render Method

Render Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class : Render Method

writer

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim writer As HtmlTextWriter

instance.Render(writer)
C#
protected override void Render(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


RenderContents Method

RenderContents Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class : RenderContents Method

writer

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderContents( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim writer As HtmlTextWriter

instance.RenderContents(writer)
C#
protected override void RenderContents(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


RadProgressArea Class Properties

RadProgressArea Class Properties
[image]
Telerik.WebControls Namespace : RadProgressArea Class

For a list of all members of this type, see RadProgressArea members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DisplayCancelButton |
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Language | Specifies the localization of the RadProgressArea (the language which will be used).
Public Property | Localization | Provides access to the localization strings of the control. (Inherited from Telerik.RadUploadUtils.RadLocalizableControl)
Public Property | Localization2 | Provides access to the localization strings of the control.
Public Property | LocalizationPath | (Inherited from Telerik.RadUploadUtils.RadLocalizableControl)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientProgressBarUpdating | Specifies the client-side function to be executed when a progress bar is about to be updated.
Public Property | OnClientProgressUpdating | Specifies the client-side function to be executed when the Progress Area status is about to be updated.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | ProgressIndicators |
Public Property | ProgressTemplate |
Public Property | RadControlsDir | (Inherited from Telerik.RadUploadUtils.RadControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | Overridden. Gets or sets the name of the skin used.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | Overridden. Gets or sets the relative path of the folder containing the skins.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadUploadUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | ControlCssFiles | Overridden.
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | InitScript | Overridden.
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | JavaScriptFiles | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | LocalizationFile | Overridden.
Protected Property | LocalizationLanguage | Overridden.
Protected Property | LocalizationResourceLocation | Overridden.
Protected Property | LocalizationScript | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Property | TagKey | Overridden.
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadProgressArea Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


ControlCssFiles Property

ControlCssFiles Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : ControlCssFiles Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property ControlCssFiles As String()
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value() As String

value = instance.ControlCssFiles
C#
protected override string[] ControlCssFiles {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


DisplayCancelButton Property

DisplayCancelButton Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : DisplayCancelButton Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property DisplayCancelButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As Boolean

instance.DisplayCancelButton = value

value = instance.DisplayCancelButton
C#
public bool DisplayCancelButton {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


InitScript Property

InitScript Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : InitScript Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property InitScript As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As String

value = instance.InitScript
C#
protected override string InitScript {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


JavaScriptFiles Property

JavaScriptFiles Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : JavaScriptFiles Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property JavaScriptFiles As String()
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value() As String

value = instance.JavaScriptFiles
C#
protected override string[] JavaScriptFiles {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


Language Property

Language Property
See Also Example
[image]
Telerik.WebControls Namespace > RadProgressArea Class : Language Property

Specifies the localization of the RadProgressArea (the language which will be used).

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property Language As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As String

instance.Language = value

value = instance.Language
C#
public string Language {get; set;}

Return Value

The default value is en-US.

Example

C# Copy Code
&lt;radU:RadUpload Language="es-Es" ... /&gt;

Visual Basic Copy Code
<radU:RadUpload Language="es-Es" ... />

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


Localization2 Property

Localization2 Property
See Also Example
[image]
Telerik.WebControls Namespace > RadProgressArea Class : Localization2 Property

Provides access to the localization strings of the control.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Localization2 As Localization
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As Localization

value = instance.Localization2
C#
public Localization Localization2 {get;}

Return Value

Localization name/value collection.

Example

This example demonstrates how to change the localization strings of RadProgressArea object with code.
C# Copy Code
RadProgressArea1.Localization["CancelButton"] = "Cancel";
RadProgressArea1.Localization["TimeElapsed"] = "Elapsed time: ";
RadProgressArea1.Localization["TimeEstimated"] = "Estimated time: ";
RadProgressArea1.Localization["TransferSpeed"] = "Speed: ";
RadProgressArea1.Localization["CurrentFileName"] = "Uploading file: ";
RadProgressArea1.Localization["Uploaded"] = "Uploaded ";
RadProgressArea1.Localization["UploadedFiles"] = "Uploaded files: ";
RadProgressArea1.Localization["Total"] = "Total ";
RadProgressArea1.Localization["TotalFiles"] = "Total files: ";

Visual Basic Copy Code
RadProgressArea1.Localization("CancelButton") = "Cancel"
RadProgressArea1.Localization("TimeElapsed") = "Elapsed time: "
RadProgressArea1.Localization("TimeEstimated") = "Estimated time: "
RadProgressArea1.Localization("TransferSpeed") = "Speed: "
RadProgressArea1.Localization("CurrentFileName") = "Uploading file: "
RadProgressArea1.Localization("Uploaded") = "Uploaded "
RadProgressArea1.Localization("UploadedFiles") = "Uploaded files: "
RadProgressArea1.Localization("Total") = "Total "
RadProgressArea1.Localization("TotalFiles") = "Total files: "

Remarks

This property is intended to be used when there is a need to access the localization strings of the control from the code behind.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


LocalizationFile Property

LocalizationFile Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : LocalizationFile Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property LocalizationFile As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As String

value = instance.LocalizationFile
C#
protected override string LocalizationFile {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


LocalizationLanguage Property

LocalizationLanguage Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : LocalizationLanguage Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property LocalizationLanguage As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As String

value = instance.LocalizationLanguage
C#
protected override string LocalizationLanguage {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


LocalizationResourceLocation Property

LocalizationResourceLocation Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : LocalizationResourceLocation Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property LocalizationResourceLocation As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As String

value = instance.LocalizationResourceLocation
C#
protected override string LocalizationResourceLocation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


OnClientProgressBarUpdating Property

OnClientProgressBarUpdating Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : OnClientProgressBarUpdating Property

Specifies the client-side function to be executed when a progress bar is about to be updated.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientProgressBarUpdating As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As String

instance.OnClientProgressBarUpdating = value

value = instance.OnClientProgressBarUpdating
C#
public string OnClientProgressBarUpdating {get; set;}

Return Value

The default value is string.Empty.

Requirements

Microsoft .NET Framework

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


OnClientProgressUpdating Property

OnClientProgressUpdating Property
See Also Example
[image]
Telerik.WebControls Namespace > RadProgressArea Class : OnClientProgressUpdating Property

Specifies the client-side function to be executed when the Progress Area status is about to be updated.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientProgressUpdating As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As String

instance.OnClientProgressUpdating = value

value = instance.OnClientProgressUpdating
C#
public string OnClientProgressUpdating {get; set;}

Return Value

The default value is string.Empty.

Example

This example demonstrates how to set a javascript function to execute when the client side progress area is about to be updated.
C# Copy Code
&lt;radU:RadProgressArea OnClientProgressUpdating="myOnClientProgressUpdating" ... /&gt;
...
&lt;script&gt;
function myOnClientProgressUpdating()
{
   alert("The progress will be updated");
}
&lt;/script&gt;

Visual Basic Copy Code
<radU:RadProgressArea OnClientProgressUpdating="myOnClientProgressUpdating" ... />
...
<script>
function myOnClientProgressUpdating()
{
    alert("The progress will be updated");
}
</script>

Requirements

Microsoft .NET Framework

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


ProgressIndicators Property

ProgressIndicators Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : ProgressIndicators Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property ProgressIndicators As ProgressIndicators
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As ProgressIndicators

instance.ProgressIndicators = value

value = instance.ProgressIndicators
C#
public ProgressIndicators ProgressIndicators {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


ProgressTemplate Property

ProgressTemplate Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : ProgressTemplate Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property ProgressTemplate As ITemplate
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As ITemplate

instance.ProgressTemplate = value

value = instance.ProgressTemplate
C#
public ITemplate ProgressTemplate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


Skin Property

Skin Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : Skin Property

Gets or sets the name of the skin used.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Skin As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As String

instance.Skin = value

value = instance.Skin
C#
public override string Skin {get; set;}

Remarks

The RadProgressArea control contains a number of predefined skins, which can be used to specify the look of the control.

Requirements

Microsoft .NET Framework

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


SkinsPath Property

SkinsPath Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : SkinsPath Property

Gets or sets the relative path of the folder containing the skins.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property SkinsPath As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As String

instance.SkinsPath = value

value = instance.SkinsPath
C#
public override string SkinsPath {get; set;}

Return Value

A string specifying the relative path to the folder which contains RadUpload skins. The default value is "~/RadControls/Upload/Skins".

Example

If the skin folder is located in the project root and is named "Skins" the SkinsPath property should be set to: "~/Skins". Then you can create subfolders for individual skins e.g. Skins/Gold, Skins/Default etc.

Remarks

RadUpload ships with a set of predefined skins which are ready to use. They are located in RadControls/Upload/Skins.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


TagKey Property

TagKey Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : TagKey Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property TagKey As HtmlTextWriterTag
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As HtmlTextWriterTag

value = instance.TagKey
C#
protected override HtmlTextWriterTag TagKey {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


RadProgressArea Class Fields

RadProgressArea Class Fields
[image]
Telerik.WebControls Namespace : RadProgressArea Class

For a list of all members of this type, see RadProgressArea members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CancelButtonName |
static (Shared in Visual Basic) | CurrentOperationName |
static (Shared in Visual Basic) | PrimaryPercentName |
static (Shared in Visual Basic) | PrimaryProgressBarName |
static (Shared in Visual Basic) | PrimaryTotalName |
static (Shared in Visual Basic) | PrimaryValueName |
static (Shared in Visual Basic) | SecondaryPercentName |
static (Shared in Visual Basic) | SecondaryProgressBarName |
static (Shared in Visual Basic) | SecondaryTotalName |
static (Shared in Visual Basic) | SecondaryValueName |
static (Shared in Visual Basic) | SpeedName |
static (Shared in Visual Basic) | TimeElapsedName |
static (Shared in Visual Basic) | TimeEstimatedName |
Top

See Also

Reference

RadProgressArea Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


CancelButtonName Field

CancelButtonName Field
[image]
Telerik.WebControls Namespace > RadProgressArea Class : CancelButtonName Field

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CancelButtonName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RadProgressArea.CancelButtonName
C#
public static readonly string CancelButtonName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


CurrentOperationName Field

CurrentOperationName Field
[image]
Telerik.WebControls Namespace > RadProgressArea Class : CurrentOperationName Field

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CurrentOperationName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RadProgressArea.CurrentOperationName
C#
public static readonly string CurrentOperationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


PrimaryPercentName Field

PrimaryPercentName Field
[image]
Telerik.WebControls Namespace > RadProgressArea Class : PrimaryPercentName Field

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PrimaryPercentName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RadProgressArea.PrimaryPercentName
C#
public static readonly string PrimaryPercentName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


PrimaryProgressBarName Field

PrimaryProgressBarName Field
[image]
Telerik.WebControls Namespace > RadProgressArea Class : PrimaryProgressBarName Field

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PrimaryProgressBarName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RadProgressArea.PrimaryProgressBarName
C#
public static readonly string PrimaryProgressBarName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


PrimaryTotalName Field

PrimaryTotalName Field
[image]
Telerik.WebControls Namespace > RadProgressArea Class : PrimaryTotalName Field

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PrimaryTotalName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RadProgressArea.PrimaryTotalName
C#
public static readonly string PrimaryTotalName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


PrimaryValueName Field

PrimaryValueName Field
[image]
Telerik.WebControls Namespace > RadProgressArea Class : PrimaryValueName Field

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PrimaryValueName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RadProgressArea.PrimaryValueName
C#
public static readonly string PrimaryValueName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


SecondaryPercentName Field

SecondaryPercentName Field
[image]
Telerik.WebControls Namespace > RadProgressArea Class : SecondaryPercentName Field

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SecondaryPercentName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RadProgressArea.SecondaryPercentName
C#
public static readonly string SecondaryPercentName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


SecondaryProgressBarName Field

SecondaryProgressBarName Field
[image]
Telerik.WebControls Namespace > RadProgressArea Class : SecondaryProgressBarName Field

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SecondaryProgressBarName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RadProgressArea.SecondaryProgressBarName
C#
public static readonly string SecondaryProgressBarName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


SecondaryTotalName Field

SecondaryTotalName Field
[image]
Telerik.WebControls Namespace > RadProgressArea Class : SecondaryTotalName Field

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SecondaryTotalName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RadProgressArea.SecondaryTotalName
C#
public static readonly string SecondaryTotalName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


SecondaryValueName Field

SecondaryValueName Field
[image]
Telerik.WebControls Namespace > RadProgressArea Class : SecondaryValueName Field

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SecondaryValueName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RadProgressArea.SecondaryValueName
C#
public static readonly string SecondaryValueName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


SpeedName Field

SpeedName Field
[image]
Telerik.WebControls Namespace > RadProgressArea Class : SpeedName Field

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SpeedName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RadProgressArea.SpeedName
C#
public static readonly string SpeedName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


TimeElapsedName Field

TimeElapsedName Field
[image]
Telerik.WebControls Namespace > RadProgressArea Class : TimeElapsedName Field

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TimeElapsedName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RadProgressArea.TimeElapsedName
C#
public static readonly string TimeElapsedName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


TimeEstimatedName Field

TimeEstimatedName Field
[image]
Telerik.WebControls Namespace > RadProgressArea Class : TimeEstimatedName Field

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly TimeEstimatedName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = RadProgressArea.TimeEstimatedName
C#
public static readonly string TimeEstimatedName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


RadProgressContext Class

RadProgressContext Class
See Also Members
[image]
Telerik.WebControls Namespace : RadProgressContext Class

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RadProgressContext
Visual Basic (Usage) Copy Code
Dim instance As RadProgressContext
C#
public sealed class RadProgressContext

Inheritance Hierarchy

System.Object
Telerik.WebControls.RadProgressContext

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

RadProgressContext Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadProgressContext Class Members

RadProgressContext Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : RadProgressContext Class

The following tables list the members exposed by RadProgressContext.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Current |
Public Property | Item |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | RemoveProgressContext |
Public Method | Serialize |
Top

See Also

Reference

RadProgressContext Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadProgressContext Class Methods

RadProgressContext Class Methods
[image]
Telerik.WebControls Namespace : RadProgressContext Class

For a list of all members of this type, see RadProgressContext members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | RemoveProgressContext |
Public Method | Serialize |
Top

See Also

Reference

RadProgressContext Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RemoveProgressContext Method

RemoveProgressContext Method
[image]
Telerik.WebControls Namespace > RadProgressContext Class : RemoveProgressContext Method

context

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub RemoveProgressContext( _
   ByVal context As HttpContext _
)
Visual Basic (Usage) Copy Code
Dim context As HttpContext

RadProgressContext.RemoveProgressContext(context)
C#
public static void RemoveProgressContext(
   HttpContext context
)

Parameters

context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressContext Class
RadProgressContext Members

© 2002-2005, telerik. All Rights Reserved.


Serialize Method

Serialize Method
[image]
Telerik.WebControls Namespace > RadProgressContext Class : Serialize Method

writer

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize( _
   ByVal writer As TextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As RadProgressContext
Dim writer As TextWriter

instance.Serialize(writer)
C#
public void Serialize(
   TextWriter writer
)

Parameters

writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressContext Class
RadProgressContext Members

© 2002-2005, telerik. All Rights Reserved.


RadProgressContext Class Properties

RadProgressContext Class Properties
[image]
Telerik.WebControls Namespace : RadProgressContext Class

For a list of all members of this type, see RadProgressContext members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Current |
Public Property | Item |
Top

See Also

Reference

RadProgressContext Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


Current Property

Current Property
[image]
Telerik.WebControls Namespace > RadProgressContext Class : Current Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Current As RadProgressContext
Visual Basic (Usage) Copy Code
Dim value As RadProgressContext

value = RadProgressContext.Current
C#
public static RadProgressContext Current {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressContext Class
RadProgressContext Members

© 2002-2005, telerik. All Rights Reserved.


Item Property

Item Property
[image]
Telerik.WebControls Namespace > RadProgressContext Class : Item Property

key

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressContext
Dim key As String
Dim value As String

instance.Item(key) = value

value = instance.Item(key)
C#
public string this[
   string key
]; {get; set;}

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressContext Class
RadProgressContext Members

© 2002-2005, telerik. All Rights Reserved.


RadProgressManager Class

RadProgressManager Class
See Also Members
[image]
Telerik.WebControls Namespace : RadProgressManager Class

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Class RadProgressManager
   Inherits RadControl
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
C#
public class RadProgressManager : RadControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadUploadUtils.RadControl
Telerik.WebControls.RadProgressManager

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

RadProgressManager Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadProgressManager Class Members

RadProgressManager Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadProgressManager Class

The following tables list the members exposed by RadProgressManager.

Public Constructors

 | Name | Description
Public Constructor | RadProgressManager Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AjaxUrl |
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableMemoryOptimization | Gets or sets a value indicating wether the Memory Optimization will be enabled.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientProgressStarted |
Public Property | OnClientProgressUpdating |
Public Property | OnClientSubmitting |
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadUploadUtils.RadControl)
Public Property | RefreshPeriod | Gets or sets the period (in milliseconds) of the progress data refresh.
Public Property | RegisterForSubmit |
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SuppressMissingHttpModuleError | Gets or sets a value indicating wether an error message will be displayed when the RadUploadHttpModule is not registered.
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadUploadUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | ControlCssFiles | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | InitScript | Overridden.
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | JavaScriptFiles | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | LocalizationLanguage | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Property | LocalizationScript | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | ApplyUniquePageIdentifier | Adds RadUrid=[GUID] parameter to the supplied URL.
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | CheckIfScriptsFolderExists | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | CheckWorkingConditions | Overloaded. (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | FormatControlMessage | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsRemoteUrl | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | IsUsingWebResourceScripts | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | Overridden.
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | RenderChildren | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | Overridden.
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

Protected Events

 | Name | Description
Protected Event | RadControlsDirChanged | (Inherited from Telerik.RadUploadUtils.RadControl)
Top

See Also

Reference

RadProgressManager Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadProgressManager Constructor

RadProgressManager Constructor
[image]
Telerik.WebControls Namespace > RadProgressManager Class : RadProgressManager Constructor

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager()
C#
public RadProgressManager()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager()
C#
public RadProgressManager()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


RadProgressManager Class Methods

RadProgressManager Class Methods
[image]
Telerik.WebControls Namespace : RadProgressManager Class

For a list of all members of this type, see RadProgressManager members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | ApplyUniquePageIdentifier | Adds RadUrid=[GUID] parameter to the supplied URL.
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | CheckIfScriptsFolderExists | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | CheckWorkingConditions | Overloaded. (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | FormatControlMessage | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsRemoteUrl | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | IsUsingWebResourceScripts | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | Overridden.
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | RenderChildren | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | Overridden.
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

RadProgressManager Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


ApplyUniquePageIdentifier Method

ApplyUniquePageIdentifier Method
See Also Example
[image]
Telerik.WebControls Namespace > RadProgressManager Class : ApplyUniquePageIdentifier Method

url
Adds RadUrid=[GUID] parameter to the supplied URL.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function ApplyUniquePageIdentifier( _
   ByVal url As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim url As String
Dim value As String

value = instance.ApplyUniquePageIdentifier(url)
C#
public string ApplyUniquePageIdentifier(
   string url
)

Parameters

url

Example

This example demonstrates how to set the PostBackUrl property of a button in order to enable RadMemoryOptimization and RadProgressArea. This example will postback to the current page, but you could use URL of your choice.
Visual Basic Copy Code
Button1.PostBackUrl = RadProgressManager1.ApplyUniquePageIdentifier(Request.Url.PathAndQuery)
C# Copy Code
Button1.PostBackUrl = RadProgressManager1.ApplyUniquePageIdentifier(Request.Url.PathAndQuery);

Remarks

Use this method to generate proper URL for cross page postbacks which will enable RadMemoryOptimization and RadProgressArea.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


OnPreRender Method

OnPreRender Method
[image]
Telerik.WebControls Namespace > RadProgressManager Class : OnPreRender Method

e

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnPreRender( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim e As EventArgs

instance.OnPreRender(e)
C#
protected override void OnPreRender(
   EventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


RenderContents Method

RenderContents Method
[image]
Telerik.WebControls Namespace > RadProgressManager Class : RenderContents Method

writer

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub RenderContents( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim writer As HtmlTextWriter

instance.RenderContents(writer)
C#
protected override void RenderContents(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


RadProgressManager Class Properties

RadProgressManager Class Properties
[image]
Telerik.WebControls Namespace : RadProgressManager Class

For a list of all members of this type, see RadProgressManager members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AjaxUrl |
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableMemoryOptimization | Gets or sets a value indicating wether the Memory Optimization will be enabled.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientProgressStarted |
Public Property | OnClientProgressUpdating |
Public Property | OnClientSubmitting |
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadUploadUtils.RadControl)
Public Property | RefreshPeriod | Gets or sets the period (in milliseconds) of the progress data refresh.
Public Property | RegisterForSubmit |
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SuppressMissingHttpModuleError | Gets or sets a value indicating wether an error message will be displayed when the RadUploadHttpModule is not registered.
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadUploadUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | ControlCssFiles | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | InitScript | Overridden.
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | JavaScriptFiles | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | LocalizationLanguage | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Property | LocalizationScript | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadProgressManager Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


AjaxUrl Property

AjaxUrl Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : AjaxUrl Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property AjaxUrl As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As String

instance.AjaxUrl = value

value = instance.AjaxUrl
C#
public string AjaxUrl {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


EnableMemoryOptimization Property

EnableMemoryOptimization Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : EnableMemoryOptimization Property

Gets or sets a value indicating wether the Memory Optimization will be enabled.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableMemoryOptimization As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As Boolean

instance.EnableMemoryOptimization = value

value = instance.EnableMemoryOptimization
C#
public bool EnableMemoryOptimization {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


InitScript Property

InitScript Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : InitScript Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property InitScript As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As String

value = instance.InitScript
C#
protected override string InitScript {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


JavaScriptFiles Property

JavaScriptFiles Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : JavaScriptFiles Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property JavaScriptFiles As String()
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value() As String

value = instance.JavaScriptFiles
C#
protected override string[] JavaScriptFiles {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


OnClientProgressStarted Property

OnClientProgressStarted Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : OnClientProgressStarted Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientProgressStarted As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As String

instance.OnClientProgressStarted = value

value = instance.OnClientProgressStarted
C#
public string OnClientProgressStarted {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


OnClientProgressUpdating Property

OnClientProgressUpdating Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : OnClientProgressUpdating Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientProgressUpdating As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As String

instance.OnClientProgressUpdating = value

value = instance.OnClientProgressUpdating
C#
public string OnClientProgressUpdating {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


OnClientSubmitting Property

OnClientSubmitting Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : OnClientSubmitting Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientSubmitting As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As String

instance.OnClientSubmitting = value

value = instance.OnClientSubmitting
C#
public string OnClientSubmitting {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


RefreshPeriod Property

RefreshPeriod Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : RefreshPeriod Property

Gets or sets the period (in milliseconds) of the progress data refresh.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property RefreshPeriod As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As Integer

instance.RefreshPeriod = value

value = instance.RefreshPeriod
C#
public int RefreshPeriod {get; set;}

Return Value

The period of the progress data refresh in milliseconds. The default value is 500.

Remarks

The refresh period might not be exactly the same as the value specified if the AJAX request has not been completed before the upload. The minimum value is 50 ms.

Note: If the value is very low (50ms) both the client CPU and server CPU load would increase because of the increased number of AJAX requests performed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


RegisterForSubmit Property

RegisterForSubmit Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : RegisterForSubmit Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property RegisterForSubmit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As Boolean

instance.RegisterForSubmit = value

value = instance.RegisterForSubmit
C#
public bool RegisterForSubmit {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


SuppressMissingHttpModuleError Property

SuppressMissingHttpModuleError Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : SuppressMissingHttpModuleError Property

Gets or sets a value indicating wether an error message will be displayed when the RadUploadHttpModule is not registered.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property SuppressMissingHttpModuleError As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As Boolean

instance.SuppressMissingHttpModuleError = value

value = instance.SuppressMissingHttpModuleError
C#
public bool SuppressMissingHttpModuleError {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


RadUpload Class

RadUpload Class
See Also Members
[image]
Telerik.WebControls Namespace : RadUpload Class

A composite control, allowing you to upload a single or multiple files. The /// RadUpload control allows you to define the number of files to be uploaded, progress display, skin, etc.

Object Model

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Class RadUpload
   Inherits RadLocalizableControl
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
C#
public class RadUpload : RadLocalizableControl

Remarks

Use the RadUpload control to allow the upload of a single or multiple files.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadUploadUtils.RadControl
Telerik.RadUploadUtils.RadSkinnableControl
Telerik.RadUploadUtils.RadLocalizableControl
Telerik.WebControls.RadUpload

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

RadUpload Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadUpload Class Members

RadUpload Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadUpload Class

The following tables list the members exposed by RadUpload.

Public Constructors

 | Name | Description
Public Constructor | RadUpload Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AllowedFileExtensions | Gets or sets the allowed file extensions for uploading.
Public Property | AllowedMimeTypes | Gets or sets the allowed MIME types for uploading.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ControlObjectsVisibility | Gets or sets the value indicating which control objects will be displayed.
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableFileInputSkinning | Gets or sets the value indicating whether the file input fields skinning will be enabled.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | FocusOnLoad | Gets or sets the value indicating whether the first file input field of RadUpload should get the focus on itself on load.
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitialFileInputsCount | Gets or sets the initial count of file input fields, which will appear in RadUpload.
Public Property | InvalidFiles | Provides access to the invalid files uploaded by the RadUpload instance. This is populated only if a validation was set.
Public Property | Language | Gets or sets the localization language of the RadUpload user interface.
Public Property | Localization | Provides access to the localization strings of the control. (Inherited from Telerik.RadUploadUtils.RadLocalizableControl)
Public Property | LocalizationPath | (Inherited from Telerik.RadUploadUtils.RadLocalizableControl)
Public Property | MaxFileInputsCount | Gets or sets the maximum file input fields that can be added to the control.
Public Property | MaxFileSize | Gets or sets the maximum file size allowed for uploading in bytes.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientAdded | Gets or sets the name of the client-side function which will be executed after a new fileinput is added to a RadUpload instance.
Public Property | OnClientAdding | Gets or sets the name of the client-side function which will be executed before a new fileinput is added to a RadUpload instance.
Public Property | OnClientClearing | Gets or sets the name of the client-side function which will be executed before a fileinput field is cleared in a RadUpload instance using the Clear button.
Public Property | OnClientDeleting | Gets or sets the name of the client-side function which will be executed before a file input is deleted from a RadUpload instance.
Public Property | OnClientDeletingSelected | Gets or sets the name of the client-side function which will be executed before the selected file inputs are removed.
Public Property | OnClientFileSelected | Gets or sets the name of the client-side function which will be executed when a file input value changed.
Public Property | OverwriteExistingFiles | Gets or sets the value indicating whether RadUpload should overwrite existing files having same name in the TargetFolder.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadUploadUtils.RadControl)
Public Property | ReadOnlyFileInputs | Gets or sets a value indicating if the file input fields should be read-only (e.g. no typing allowed).
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | Overridden. Gets or sets the skin name for the RadUpload user interface.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | (Inherited from Telerik.RadUploadUtils.RadSkinnableControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TargetFolder | Gets or sets the virtual path of the folder, where RadUpload will automatically save the valid files after the upload completes.
Public Property | TargetPhysicalFolder | Gets or sets the physical path of the folder, where RadUpload will automatically save the valid files after the upload completes.
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UploadedFiles | Provides access to the valid files uploaded by the RadUpload instance.
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadUploadUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | ControlCssFiles | Overridden.
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | InitScript | Overridden.
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | JavaScriptFiles | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | LocalizationFile | Overridden.
Protected Property | LocalizationLanguage | Overridden.
Protected Property | LocalizationResourceLocation | Overridden.
Protected Property | LocalizationScript | Overridden.
Protected Property | SkinUrl2 |
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | CheckIfScriptsFolderExists | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | CheckWorkingConditions | Overloaded. (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | FormatControlMessage | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsRemoteUrl | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | IsUsingWebResourceScripts | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | IsValidExtension |
Protected Method | IsValidMimeType |
Protected Method | IsValidSize |
Protected Method | IsValidUploadedFile | Overloaded.
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnFileExists | Fires the FileExists event.
Protected Method | OnInit | Overridden.
Protected Method | OnLoad | Overridden.
Protected Method | OnPreRender | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OnValidatingFile | Fires the ValidatingFile event.
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | Overridden.
Protected Method | RenderChildren | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | FileExists | Occurs after an unsuccessful attempt for automatic saving of a file in the UploadedFiles collection.
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Public Event | ValidatingFile | Occurs before the internal validation of every file in the UploadedFiles collection.
Top

Protected Events

 | Name | Description
Protected Event | RadControlsDirChanged | (Inherited from Telerik.RadUploadUtils.RadControl)
Top

See Also

Reference

RadUpload Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadUpload Constructor

RadUpload Constructor
[image]
Telerik.WebControls Namespace > RadUpload Class : RadUpload Constructor

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload()
C#
public RadUpload()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload()
C#
public RadUpload()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


RadUpload Class Methods

RadUpload Class Methods
[image]
Telerik.WebControls Namespace : RadUpload Class

For a list of all members of this type, see RadUpload members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | AddedControl | (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | CheckIfScriptsFolderExists | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | CheckWorkingConditions | Overloaded. (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | FormatControlMessage | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsRemoteUrl | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | IsUsingWebResourceScripts | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | IsValidExtension |
Protected Method | IsValidMimeType |
Protected Method | IsValidSize |
Protected Method | IsValidUploadedFile | Overloaded.
Protected Method | LoadControlState | (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | MapPathSecure | (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnFileExists | Fires the FileExists event.
Protected Method | OnInit | Overridden.
Protected Method | OnLoad | Overridden.
Protected Method | OnPreRender | (Inherited from Telerik.RadUploadUtils.RadControl)
Protected Method | OnUnload | (Inherited from System.Web.UI.Control)
Protected Method | OnValidatingFile | Fires the ValidatingFile event.
Protected Method | OpenFile | (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RemovedControl | (Inherited from System.Web.UI.Control)
Protected Method | Render | Overridden.
Protected Method | RenderChildren | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

RadUpload Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


IsValidExtension Method

IsValidExtension Method
[image]
Telerik.WebControls Namespace > RadUpload Class : IsValidExtension Method

file

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function IsValidExtension( _
   ByVal file As UploadedFile _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim file As UploadedFile
Dim value As Boolean

value = instance.IsValidExtension(file)
C#
protected bool IsValidExtension(
   UploadedFile file
)

Parameters

file

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


IsValidMimeType Method

IsValidMimeType Method
[image]
Telerik.WebControls Namespace > RadUpload Class : IsValidMimeType Method

file

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function IsValidMimeType( _
   ByVal file As UploadedFile _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim file As UploadedFile
Dim value As Boolean

value = instance.IsValidMimeType(file)
C#
protected bool IsValidMimeType(
   UploadedFile file
)

Parameters

file

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


IsValidSize Method

IsValidSize Method
[image]
Telerik.WebControls Namespace > RadUpload Class : IsValidSize Method

file

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function IsValidSize( _
   ByVal file As UploadedFile _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim file As UploadedFile
Dim value As Boolean

value = instance.IsValidSize(file)
C#
protected bool IsValidSize(
   UploadedFile file
)

Parameters

file

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


IsValidUploadedFile Method

IsValidUploadedFile Method
[image]
Telerik.WebControls Namespace > RadUpload Class : IsValidUploadedFile Method

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Overload List

Overload | Description
IsValidUploadedFile(UploadedFile) |
IsValidUploadedFile(UploadedFile,Boolean,Boolean,Boolean) |

Overload List

Overload | Description
IsValidUploadedFile(UploadedFile) |
IsValidUploadedFile(UploadedFile,Boolean,Boolean,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


IsValidUploadedFile(UploadedFile) Method

IsValidUploadedFile(UploadedFile) Method
[image]
Telerik.WebControls Namespace > RadUpload Class > IsValidUploadedFile Method : IsValidUploadedFile(UploadedFile) Method

file

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Function IsValidUploadedFile( _
   ByVal file As UploadedFile _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim file As UploadedFile
Dim value As Boolean

value = instance.IsValidUploadedFile(file)
C#
protected bool IsValidUploadedFile(
   UploadedFile file
)

Parameters

file

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


IsValidUploadedFile(UploadedFile,Boolean,Boolean,Boolean) Method

IsValidUploadedFile(UploadedFile,Boolean,Boolean,Boolean) Method
See Also
[image]
Telerik.WebControls Namespace > RadUpload Class > IsValidUploadedFile Method : IsValidUploadedFile(UploadedFile,Boolean,Boolean,Boolean) Method

file
checkingFileSize
checkingFileExtension
checkingMimeType

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Function IsValidUploadedFile( _
   ByVal file As UploadedFile, _
   ByVal checkingFileSize As Boolean, _
   ByVal checkingFileExtension As Boolean, _
   ByVal checkingMimeType As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim file As UploadedFile
Dim checkingFileSize As Boolean
Dim checkingFileExtension As Boolean
Dim checkingMimeType As Boolean
Dim value As Boolean

value = instance.IsValidUploadedFile(file, checkingFileSize, checkingFileExtension, checkingMimeType)
C#
protected bool IsValidUploadedFile(
   UploadedFile file,
   bool checkingFileSize,
   bool checkingFileExtension,
   bool checkingMimeType
)

Parameters

file
checkingFileSize
checkingFileExtension
checkingMimeType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


OnFileExists Method

OnFileExists Method
[image]
Telerik.WebControls Namespace > RadUpload Class : OnFileExists Method

e
Fires the FileExists event.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Sub OnFileExists( _
   ByVal e As UploadedFileEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim e As UploadedFileEventArgs

instance.OnFileExists(e)
C#
protected void OnFileExists(
   UploadedFileEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


OnInit Method

OnInit Method
[image]
Telerik.WebControls Namespace > RadUpload Class : OnInit Method

e

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnInit( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim e As EventArgs

instance.OnInit(e)
C#
protected override void OnInit(
   EventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


OnLoad Method

OnLoad Method
[image]
Telerik.WebControls Namespace > RadUpload Class : OnLoad Method

e

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnLoad( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim e As EventArgs

instance.OnLoad(e)
C#
protected override void OnLoad(
   EventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


OnValidatingFile Method

OnValidatingFile Method
[image]
Telerik.WebControls Namespace > RadUpload Class : OnValidatingFile Method

e
Fires the ValidatingFile event.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function OnValidatingFile( _
   ByVal e As ValidateFileEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim e As ValidateFileEventArgs
Dim value As Boolean

value = instance.OnValidatingFile(e)
C#
protected bool OnValidatingFile(
   ValidateFileEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


Render Method

Render Method
[image]
Telerik.WebControls Namespace > RadUpload Class : Render Method

writer

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Render( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim writer As HtmlTextWriter

instance.Render(writer)
C#
protected override void Render(
   HtmlTextWriter writer
)

Parameters

writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


RadUpload Class Properties

RadUpload Class Properties
[image]
Telerik.WebControls Namespace : RadUpload Class

For a list of all members of this type, see RadUpload members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AllowedFileExtensions | Gets or sets the allowed file extensions for uploading.
Public Property | AllowedMimeTypes | Gets or sets the allowed MIME types for uploading.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ControlObjectsVisibility | Gets or sets the value indicating which control objects will be displayed.
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableFileInputSkinning | Gets or sets the value indicating whether the file input fields skinning will be enabled.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | FocusOnLoad | Gets or sets the value indicating whether the first file input field of RadUpload should get the focus on itself on load.
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitialFileInputsCount | Gets or sets the initial count of file input fields, which will appear in RadUpload.
Public Property | InvalidFiles | Provides access to the invalid files uploaded by the RadUpload instance. This is populated only if a validation was set.
Public Property | Language | Gets or sets the localization language of the RadUpload user interface.
Public Property | Localization | Provides access to the localization strings of the control. (Inherited from Telerik.RadUploadUtils.RadLocalizableControl)
Public Property | LocalizationPath | (Inherited from Telerik.RadUploadUtils.RadLocalizableControl)
Public Property | MaxFileInputsCount | Gets or sets the maximum file input fields that can be added to the control.
Public Property | MaxFileSize | Gets or sets the maximum file size allowed for uploading in bytes.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientAdded | Gets or sets the name of the client-side function which will be executed after a new fileinput is added to a RadUpload instance.
Public Property | OnClientAdding | Gets or sets the name of the client-side function which will be executed before a new fileinput is added to a RadUpload instance.
Public Property | OnClientClearing | Gets or sets the name of the client-side function which will be executed before a fileinput field is cleared in a RadUpload instance using the Clear button.
Public Property | OnClientDeleting | Gets or sets the name of the client-side function which will be executed before a file input is deleted from a RadUpload instance.
Public Property | OnClientDeletingSelected | Gets or sets the name of the client-side function which will be executed before the selected file inputs are removed.
Public Property | OnClientFileSelected | Gets or sets the name of the client-side function which will be executed when a file input value changed.
Public Property | OverwriteExistingFiles | Gets or sets the value indicating whether RadUpload should overwrite existing files having same name in the TargetFolder.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadUploadUtils.RadControl)
Public Property | ReadOnlyFileInputs | Gets or sets a value indicating if the file input fields should be read-only (e.g. no typing allowed).
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | Overridden. Gets or sets the skin name for the RadUpload user interface.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | (Inherited from Telerik.RadUploadUtils.RadSkinnableControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TargetFolder | Gets or sets the virtual path of the folder, where RadUpload will automatically save the valid files after the upload completes.
Public Property | TargetPhysicalFolder | Gets or sets the physical path of the folder, where RadUpload will automatically save the valid files after the upload completes.
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UploadedFiles | Provides access to the valid files uploaded by the RadUpload instance.
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadUploadUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | Context | (Inherited from System.Web.UI.Control)
Protected Property | ControlCssFiles | Overridden.
Protected Property | DesignMode | (Inherited from System.Web.UI.Control)
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | InitScript | Overridden.
Protected Property | IsChildControlStateCleared | (Inherited from System.Web.UI.Control)
Protected Property | IsEnabled | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | (Inherited from System.Web.UI.Control)
Protected Property | JavaScriptFiles | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | LocalizationFile | Overridden.
Protected Property | LocalizationLanguage | Overridden.
Protected Property | LocalizationResourceLocation | Overridden.
Protected Property | LocalizationScript | Overridden.
Protected Property | SkinUrl2 |
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadUpload Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


AllowedFileExtensions Property

AllowedFileExtensions Property
See Also Example
[image]
Telerik.WebControls Namespace > RadUpload Class : AllowedFileExtensions Property

Gets or sets the allowed file extensions for uploading.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowedFileExtensions As String()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value() As String

instance.AllowedFileExtensions = value

value = instance.AllowedFileExtensions
C#
public string[] AllowedFileExtensions {get; set;}

Return Value

The default value is empty string array. In order to check for multiple file extensions you should set an array of strings containing the allowed file extensions for uploading.

Example

This example demonstrates how to set multiple allowed file extensions in a RadUpload control.
Visual Basic Copy Code
Dim allowedFileExtensions As String() = New String(2) {".zip", ".doc", ".config"}
RadUpload1.AllowedFileExtensions = allowedFileExtensions
C# Copy Code
string[] allowedFileExtensions = new string[3] {".zip", ".doc", ".config"};
RadUpload1.AllowedFileExtensions = allowedFileExtensions;

Remarks

Set this property to empty array of strings in order to prevent the file extension checking.

Note that the file extensions must include the dot before the actual extension. See the example below.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
MaxFileSize Property
AllowedMimeTypes Property
ValidatingFile Event

© 2002-2005, telerik. All Rights Reserved.


AllowedMimeTypes Property

AllowedMimeTypes Property
See Also Example
[image]
Telerik.WebControls Namespace > RadUpload Class : AllowedMimeTypes Property

Gets or sets the allowed MIME types for uploading.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowedMimeTypes As String()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value() As String

instance.AllowedMimeTypes = value

value = instance.AllowedMimeTypes
C#
public string[] AllowedMimeTypes {get; set;}

Return Value

The default value is empty string array. In order to check for multiple mime types you should set an array of strings containing the allowed MIME types for uploading.

Example

This example demostrates how to set multiple allowed MIME types to a RadUpload control.
Visual Basic Copy Code
' For example you can Get these from your web.config file
Dim commaSeparatedMimeTypes As String = "application/octet-stream,application/msword,video/mpeg"

Dim allowedMimeTypes As String() = commaSeparatedMimeTypes.Split(",")
RadUpload1.AllowedMimeTypes = allowedMimeTypes
C# Copy Code
// For example you can get these from your web.config file
string commaSeparatedMimeTypes = "application/octet-stream,application/msword,video/mpeg";

 string[] allowedMimeTypes = commaSeparatedMimeTypes.Split(',');
RadUpload1.AllowedMimeTypes = allowedMimeTypes;

Remarks

Set this property to string.Empty in order to prevent the mime type checking.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
MaxFileSize Property
AllowedFileExtensions Property
ValidatingFile Event

© 2002-2005, telerik. All Rights Reserved.


ControlCssFiles Property

ControlCssFiles Property
[image]
Telerik.WebControls Namespace > RadUpload Class : ControlCssFiles Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property ControlCssFiles As String()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value() As String

value = instance.ControlCssFiles
C#
protected override string[] ControlCssFiles {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


ControlObjectsVisibility Property

ControlObjectsVisibility Property
See Also Example
[image]
Telerik.WebControls Namespace > RadUpload Class : ControlObjectsVisibility Property

Gets or sets the value indicating which control objects will be displayed.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property ControlObjectsVisibility As ControlObjectsVisibility
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As ControlObjectsVisibility

instance.ControlObjectsVisibility = value

value = instance.ControlObjectsVisibility
C#
public ControlObjectsVisibility ControlObjectsVisibility {get; set;}

Return Value

The default value is ControlObjectsVisibility.Default. You can set any combination of the enum values.

Example

This example demostrates how to display only the Add and Remove buttons on a RadUpload control.
Visual Basic Copy Code
RadUpload1.ControlObjectsVisibility = Telerik.WebControls.ControlObjectsVisibility.AddButton Or _
                                      Telerik.WebControls.ControlObjectsVisibility.RemoveButtons
C# Copy Code
RadUpload1.ControlObjectsVisibility = Telerik.WebControls.ControlObjectsVisibility.AddButton |
                                     Telerik.WebControls.ControlObjectsVisibility.RemoveButtons;

Remarks

ControlObjectVisibility enum members
Member | Description
None | Only the file inputs will be visible.
CheckBoxes | Display checkboxes for selecting a file input.
RemoveButtons | Display buttons for removing a file input.
ClearButtons | Display buttons for clearing a file input.
AddButton | Display button for adding a file input.
DeleteSelectedButton | Display button for removing the file inputs with checked checkboxes.
Default | CheckBoxes | RemoveButtons | AddButton | DeleteSelectedButton
All | CheckBoxes | RemoveButtons | ClearButtons | AddButton | DeleteSelectedButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
MaxFileInputsCount Property
InitialFileInputsCount Property
ControlObjectsVisibility Enumeration

© 2002-2005, telerik. All Rights Reserved.


EnableFileInputSkinning Property

EnableFileInputSkinning Property
[image]
Telerik.WebControls Namespace > RadUpload Class : EnableFileInputSkinning Property

Gets or sets the value indicating whether the file input fields skinning will be enabled.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableFileInputSkinning As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Boolean

instance.EnableFileInputSkinning = value

value = instance.EnableFileInputSkinning
C#
public bool EnableFileInputSkinning {get; set;}

Return Value

true when the file input skinning is enabled; otherwise false.

Remarks

The <input type=file> DHTML elements are not skinnable by default. If the EnableFileInputSkinning is true some browsers can have strange behaviour.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


FocusOnLoad Property

FocusOnLoad Property
[image]
Telerik.WebControls Namespace > RadUpload Class : FocusOnLoad Property

Gets or sets the value indicating whether the first file input field of RadUpload should get the focus on itself on load.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property FocusOnLoad As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Boolean

instance.FocusOnLoad = value

value = instance.FocusOnLoad
C#
public bool FocusOnLoad {get; set;}

Return Value

true when the first file input field of RadUpload should get the focus; otherwise false. The default value is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


InitialFileInputsCount Property

InitialFileInputsCount Property
[image]
Telerik.WebControls Namespace > RadUpload Class : InitialFileInputsCount Property

Gets or sets the initial count of file input fields, which will appear in RadUpload.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property InitialFileInputsCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Integer

instance.InitialFileInputsCount = value

value = instance.InitialFileInputsCount
C#
public int InitialFileInputsCount {get; set;}

Return Value

The file inputs count which will be available at startup. The default value is 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
MaxFileInputsCount Property
ControlObjectsVisibility Property

© 2002-2005, telerik. All Rights Reserved.


InitScript Property

InitScript Property
[image]
Telerik.WebControls Namespace > RadUpload Class : InitScript Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property InitScript As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

value = instance.InitScript
C#
protected override string InitScript {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


InvalidFiles Property

InvalidFiles Property
[image]
Telerik.WebControls Namespace > RadUpload Class : InvalidFiles Property

Provides access to the invalid files uploaded by the RadUpload instance. This is populated only if a validation was set.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InvalidFiles As UploadedFileCollection
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As UploadedFileCollection

value = instance.InvalidFiles
C#
public UploadedFileCollection InvalidFiles {get;}

Return Value

If the internal validation is enabled this collection contains the invalid uploaded files for the particular instance of RadUpload control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


JavaScriptFiles Property

JavaScriptFiles Property
[image]
Telerik.WebControls Namespace > RadUpload Class : JavaScriptFiles Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property JavaScriptFiles As String()
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value() As String

value = instance.JavaScriptFiles
C#
protected override string[] JavaScriptFiles {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


Language Property

Language Property
[image]
Telerik.WebControls Namespace > RadUpload Class : Language Property

Gets or sets the localization language of the RadUpload user interface.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property Language As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.Language = value

value = instance.Language
C#
public string Language {get; set;}

Return Value

A string containing the localization language of the RadUpload user inteface. The default value is en-US.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


LocalizationFile Property

LocalizationFile Property
[image]
Telerik.WebControls Namespace > RadUpload Class : LocalizationFile Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property LocalizationFile As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

value = instance.LocalizationFile
C#
protected override string LocalizationFile {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


LocalizationLanguage Property

LocalizationLanguage Property
[image]
Telerik.WebControls Namespace > RadUpload Class : LocalizationLanguage Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property LocalizationLanguage As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

value = instance.LocalizationLanguage
C#
protected override string LocalizationLanguage {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


LocalizationResourceLocation Property

LocalizationResourceLocation Property
[image]
Telerik.WebControls Namespace > RadUpload Class : LocalizationResourceLocation Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property LocalizationResourceLocation As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

value = instance.LocalizationResourceLocation
C#
protected override string LocalizationResourceLocation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


LocalizationScript Property

LocalizationScript Property
[image]
Telerik.WebControls Namespace > RadUpload Class : LocalizationScript Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected ReadOnly Property LocalizationScript As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

value = instance.LocalizationScript
C#
protected override string LocalizationScript {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


MaxFileInputsCount Property

MaxFileInputsCount Property
[image]
Telerik.WebControls Namespace > RadUpload Class : MaxFileInputsCount Property

Gets or sets the maximum file input fields that can be added to the control.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxFileInputsCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Integer

instance.MaxFileInputsCount = value

value = instance.MaxFileInputsCount
C#
public int MaxFileInputsCount {get; set;}

Return Value

The default value is 0 (unlimited).

Remarks

Using this property you can limit the maximum number of file inputs which can be added to a RadUpload instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
InitialFileInputsCount Property
ControlObjectsVisibility Property

© 2002-2005, telerik. All Rights Reserved.


MaxFileSize Property

MaxFileSize Property
[image]
Telerik.WebControls Namespace > RadUpload Class : MaxFileSize Property

Gets or sets the maximum file size allowed for uploading in bytes.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxFileSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Integer

instance.MaxFileSize = value

value = instance.MaxFileSize
C#
public int MaxFileSize {get; set;}

Return Value

The default value is 0 (unlimited).

Remarks

Set this property to 0 in order to prevent the file size checking.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
AllowedMimeTypes Property
AllowedFileExtensions Property
ValidatingFile Event

© 2002-2005, telerik. All Rights Reserved.


OnClientAdded Property

OnClientAdded Property
See Also Example
[image]
Telerik.WebControls Namespace > RadUpload Class : OnClientAdded Property

Gets or sets the name of the client-side function which will be executed after a new fileinput is added to a RadUpload instance.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientAdded As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.OnClientAdded = value

value = instance.OnClientAdded
C#
public string OnClientAdded {get; set;}

Return Value

The default value is string.Empty.

Example

This example demonstrates how to create a javascript function which is called every time when the used adds a new file input to the RadUpload instance.
C# Copy Code
&lt;radU:RadUpload OnClientAdded="myOnClientAdded" ... /&gt;
...
&lt;script&gt;
function myOnClientAdded()
{
   alert("You just added a new file input.");
}
&lt;/script&gt;

Visual Basic Copy Code
<radU:RadUpload OnClientAdded="myOnClientAdded" ... />
...
<script>
function myOnClientAdded()
{
    alert("You just added a new file input.");
}
</script>

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


OnClientAdding Property

OnClientAdding Property
See Also Example
[image]
Telerik.WebControls Namespace > RadUpload Class : OnClientAdding Property

Gets or sets the name of the client-side function which will be executed before a new fileinput is added to a RadUpload instance.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientAdding As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.OnClientAdding = value

value = instance.OnClientAdding
C#
public string OnClientAdding {get; set;}

Return Value

The default value is string.Empty.

Example

This example demonstrates how to create a javascript function which is called every time when the used adds a new file input to the RadUpload instance.
C# Copy Code
&lt;radU:RadUpload OnClientAdding="myOnClientAdding" ... /&gt;
...
&lt;script&gt;
function myOnClientAdding()
{
   alert("You just added a new file input.");
}
&lt;/script&gt;

Visual Basic Copy Code
<radU:RadUpload OnClientAdding="myOnClientAdding" ... />
...
<script>
function myOnClientAdding()
{
    alert("You just added a new file input.");
}
</script>

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


OnClientClearing Property

OnClientClearing Property
See Also Example
[image]
Telerik.WebControls Namespace > RadUpload Class : OnClientClearing Property

Gets or sets the name of the client-side function which will be executed before a fileinput field is cleared in a RadUpload instance using the Clear button.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientClearing As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.OnClientClearing = value

value = instance.OnClientClearing
C#
public string OnClientClearing {get; set;}

Return Value

The default value is string.Empty.

Example

This example demonstrates how to create a client side confirmation dialog when clearing a file input item of a RadUpload instance.
C# Copy Code
&lt;radU:RadUpload OnClientClearing="myOnClientClearing" ... /&gt;
...
&lt;script&gt;
function myOnClientClearing()
{
   return confirm("Are you sure you want to clear this input?");
}
&lt;/script&gt;

Visual Basic Copy Code
<radU:RadUpload OnClientClearing="myOnClientClearing" ... />
...
<script>
function myOnClientClearing()
{
    Return confirm("Are you sure you want to clear this input?");
}
</script>

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


OnClientDeleting Property

OnClientDeleting Property
See Also Example
[image]
Telerik.WebControls Namespace > RadUpload Class : OnClientDeleting Property

Gets or sets the name of the client-side function which will be executed before a file input is deleted from a RadUpload instance.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientDeleting As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.OnClientDeleting = value

value = instance.OnClientDeleting
C#
public string OnClientDeleting {get; set;}

Return Value

The default value is string.Empty.

Example

This example demonstrates how to implement a confirmation dialog when removing a file input item.
C# Copy Code
&lt;radU:RadUpload OnClientDeleting="myOnClientDeleting" ... /&gt;
&lt;script language="javascript"&gt;
function myOnClientDeleting()
{
   return prompt("Are you sure?");
}
&lt;/script&gt;

Visual Basic Copy Code
<radU:RadUpload OnClientDeleting="myOnClientDeleting" ... />
<script language="javascript">
function myOnClientDeleting()
{
    Return prompt("Are you sure?");
}
</script>

Remarks

If you want to cancel the deleting of the file input return false in the javascript handler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


OnClientDeletingSelected Property

OnClientDeletingSelected Property
See Also Example
[image]
Telerik.WebControls Namespace > RadUpload Class : OnClientDeletingSelected Property

Gets or sets the name of the client-side function which will be executed before the selected file inputs are removed.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientDeletingSelected As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.OnClientDeletingSelected = value

value = instance.OnClientDeletingSelected
C#
public string OnClientDeletingSelected {get; set;}

Return Value

The default value is string.Empty.

Example

This example demonstrates how to create a client side confirmation dialog when removing the selected file input items from a RadUpload control.
Visual Basic Copy Code
<radU:RadUpload OnClientDeletingSelected="myOnClientDeletingSelected" ... />

<script>
function myOnClientDeletingSelected()
{
    var mustCancel = confirm("Are you sure?");
    return mustCancel;
}
</script>
C# Copy Code
&lt;radU:RadUpload OnClientDeletingSelected="myOnClientDeletingSelected" ... /&gt;

&lt;script&gt;
function myOnClientDeletingSelected()
{
   var mustCancel = confirm("Are you sure?");
   return mustCancel;
}
&lt;/script&gt;

Remarks

You can cancel the removing of the file input items by returning false in the javascript function.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


OnClientFileSelected Property

OnClientFileSelected Property
[image]
Telerik.WebControls Namespace > RadUpload Class : OnClientFileSelected Property

Gets or sets the name of the client-side function which will be executed when a file input value changed.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientFileSelected As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.OnClientFileSelected = value

value = instance.OnClientFileSelected
C#
public string OnClientFileSelected {get; set;}

Return Value

The default value is string.Empty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


OverwriteExistingFiles Property

OverwriteExistingFiles Property
[image]
Telerik.WebControls Namespace > RadUpload Class : OverwriteExistingFiles Property

Gets or sets the value indicating whether RadUpload should overwrite existing files having same name in the TargetFolder.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property OverwriteExistingFiles As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Boolean

instance.OverwriteExistingFiles = value

value = instance.OverwriteExistingFiles
C#
public bool OverwriteExistingFiles {get; set;}

Return Value

true when the existing files should be overwritten; otherwise false. The default value is false.

Remarks

When set to true, the existing files are overwritten, else no action is taken.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
FileExists Event
TargetFolder Property
TargetPhysicalFolder Property

© 2002-2005, telerik. All Rights Reserved.


ReadOnlyFileInputs Property

ReadOnlyFileInputs Property
[image]
Telerik.WebControls Namespace > RadUpload Class : ReadOnlyFileInputs Property

Gets or sets a value indicating if the file input fields should be read-only (e.g. no typing allowed).

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadOnlyFileInputs As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Boolean

instance.ReadOnlyFileInputs = value

value = instance.ReadOnlyFileInputs
C#
public bool ReadOnlyFileInputs {get; set;}

Return Value

true when the file input fields should be read-only; otherwise false.

Remarks

When users type into the box and the filename is not valid, the form submission in Internet Explorer could not proceed or even display a javascript error. This behavior can be avoided by setting the ReadOnlyFileInputs property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


Skin Property

Skin Property
See Also Example
[image]
Telerik.WebControls Namespace > RadUpload Class : Skin Property

Gets or sets the skin name for the RadUpload user interface.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Skin As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.Skin = value

value = instance.Skin
C#
public override string Skin {get; set;}

Return Value

A string containing the skin name for the RadUpload user interface. The default is "Classic".

Example

This example demostrates how to change the skin of a RadUpload object from the SelectedIndexChanged of a DropDownList object.
Visual Basic Copy Code
Private Sub DropdownSkins_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles DropdownSkins.SelectedIndexChanged
    RadUpload1.Skin = ddlSkins.SelectedValue
End Sub
C# Copy Code
private void DropdownSkins_SelectedIndexChanged(object sender, EventArgs e)
{
   RadUpload1.Skin = DropdownSkins.SelectedValue;
}

Remarks

The RadUpload control contains a number of predefined skins, which can be used to specify the look of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


SkinUrl2 Property

SkinUrl2 Property
[image]
Telerik.WebControls Namespace > RadUpload Class : SkinUrl2 Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property SkinUrl2 As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

value = instance.SkinUrl2
C#
protected string SkinUrl2 {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


TargetFolder Property

TargetFolder Property
[image]
Telerik.WebControls Namespace > RadUpload Class : TargetFolder Property

Gets or sets the virtual path of the folder, where RadUpload will automatically save the valid files after the upload completes.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetFolder As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.TargetFolder = value

value = instance.TargetFolder
C#
public string TargetFolder {get; set;}

Return Value

A string containing the virtual path of the folder where RadUpload will automatically save the valid files after the upload completes. The default value is string.Empty.

Remarks

When set to string.Empty, the files must be saved manually to the desired location.

If both TargetPhysicalFolder property and this property are set, the TargetPhysicalFolder will override the virtual path provided by TargetFolder.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
OverwriteExistingFiles Property
FileExists Event
TargetPhysicalFolder Property

© 2002-2005, telerik. All Rights Reserved.


TargetPhysicalFolder Property

TargetPhysicalFolder Property
[image]
Telerik.WebControls Namespace > RadUpload Class : TargetPhysicalFolder Property

Gets or sets the physical path of the folder, where RadUpload will automatically save the valid files after the upload completes.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetPhysicalFolder As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.TargetPhysicalFolder = value

value = instance.TargetPhysicalFolder
C#
public string TargetPhysicalFolder {get; set;}

Return Value

A string containing the physical path of the folder where RadUpload will automatically save the valid files after the upload completes. The default value is string.Empty.

Remarks

When set to string.Empty, the files must be saved manually to the desired location.

If both TargetFolder property and this property are set, the TargetPhysicalFolder will override the virtual path provided by TargetFolder.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
TargetFolder Property
OverwriteExistingFiles Property
FileExists Event

© 2002-2005, telerik. All Rights Reserved.


UploadedFiles Property

UploadedFiles Property
See Also Example
[image]
Telerik.WebControls Namespace > RadUpload Class : UploadedFiles Property

Provides access to the valid files uploaded by the RadUpload instance.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UploadedFiles As UploadedFileCollection
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As UploadedFileCollection

value = instance.UploadedFiles
C#
public UploadedFileCollection UploadedFiles {get;}

Return Value

UploadedFileCollection containing all valid files uploaded using a RadUpload control.

Example

This example demonstrates how to save the valid uploaded files with a RadUpload control.
Visual Basic Copy Code
For Each file As Telerik.WebControls.UploadedFile In RadUpload1.UploadedFiles
    file.SaveAs(Path.Combine("c:\my files\", file.GetName()), True)
Next
C# Copy Code
foreach (Telerik.WebControls.UploadedFile file in RadUpload1.UploadedFiles)
{
   file.SaveAs(Path.Combine(@"c:\my files\", file.GetName()), true);
}

Remarks

The collection contains only the files uploaded with the particular instance of the RadUpload control. If the RadUploadHttpModule is used, the uploaded files are removed from the Request.Files collection in order to conserve the server's memory. Else the Request.Files contains all uploaded files as a HttpPostedFile collection and each RadUpload instance has its own uploaded files as UploadedFileCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


RadUpload Class Events

RadUpload Class Events
[image]
Telerik.WebControls Namespace : RadUpload Class

For a list of all members of this type, see RadUpload members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | FileExists | Occurs after an unsuccessful attempt for automatic saving of a file in the UploadedFiles collection.
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Public Event | ValidatingFile | Occurs before the internal validation of every file in the UploadedFiles collection.
Top

Protected Events

 | Name | Description
Protected Event | RadControlsDirChanged | (Inherited from Telerik.RadUploadUtils.RadControl)
Top

See Also

Reference

RadUpload Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


FileExists Event

FileExists Event
See Also Example
[image]
Telerik.WebControls Namespace > RadUpload Class : FileExists Event

Occurs after an unsuccessful attempt for automatic saving of a file in the UploadedFiles collection.

Example

This example demostrates how to create custom logic for renaming and saving the existing uploaded files.

Event Data

The event handler receives an argument of type UploadedFileEventArgs containing data related to this event. The following UploadedFileEventArgs properties provide information specific to this event.

Property | Description
UploadedFile | Gets the currently processed UploadedFile.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Event FileExists() As UploadedFileEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As UploadedFileEventHandler

AddHandler instance.FileExists, handler
C#
public event UploadedFileEventHandler FileExists()

Syntax

Visual Basic (Declaration)
Public Event FileExists() As UploadedFileEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As UploadedFileEventHandler

AddHandler instance.FileExists, handler
C#
public event UploadedFileEventHandler FileExists()

Event Data

The event handler receives an argument of type UploadedFileEventArgs containing data related to this event. The following UploadedFileEventArgs properties provide information specific to this event.

Property | Description
UploadedFile | Gets the currently processed UploadedFile.

Example

This example demostrates how to create custom logic for renaming and saving the existing uploaded files.
Visual Basic Copy Code
Private Sub RadUpload1_FileExists(ByVal sender As Object, ByVal e As WebControls.UploadedFileEventArgs) Handles RadUpload1.FileExists
    Dim TheFile As Telerik.WebControls.UploadedFile = e.UploadedFile

    TheFile.SaveAs(Path.Combine(RadUpload1.TargetFolder, TheFile.GetNameWithoutExtension() + "1" + TheFile.GetExtension()), true)
End Sub
C# Copy Code
private void RadUpload1_FileExists(object sender, Telerik.WebControls.UploadedFileEventArgs e)
{
   Telerik.WebControls.UploadedFile TheFile = e.UploadedFile;

   TheFile.SaveAs(Path.Combine(RadUpload1.TargetFolder, TheFile.GetNameWithoutExtension() + "1" + TheFile.GetExtension()), true);
}

Remarks

This event should be consumed only when the automatic file saving is enabled by setting the TargetFolder property. In this mode the files are saved in the selected folder with the same name as on the client computer. If a file with such name already exists in the TargetFolder it is either overwritten or skipped depending the value of the OverwriteExistingFiles property. This event is fired if OverwriteExistingFiles is set to false and a file with the same name already exists in the TargetFolder.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
OverwriteExistingFiles Property
TargetFolder Property
TargetPhysicalFolder Property

© 2002-2005, telerik. All Rights Reserved.


ValidatingFile Event

ValidatingFile Event
See Also Example
[image]
Telerik.WebControls Namespace > RadUpload Class : ValidatingFile Event

Occurs before the internal validation of every file in the UploadedFiles collection.

Example

This example demostrates how to implement custom validation for specific file type.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Event ValidatingFile() As ValidateFileEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As ValidateFileEventHandler

AddHandler instance.ValidatingFile, handler
C#
public event ValidateFileEventHandler ValidatingFile()

Syntax

Visual Basic (Declaration)
Public Event ValidatingFile() As ValidateFileEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As ValidateFileEventHandler

AddHandler instance.ValidatingFile, handler
C#
public event ValidateFileEventHandler ValidatingFile()

Example

This example demostrates how to implement custom validation for specific file type.
Visual Basic Copy Code
Private Sub RadUpload1_ValidatingFile(ByVal sender As Object, ByVal e As WebControls.ValidateFileEventArgs) Handles RadUpload1.ValidatingFile
    If e.UploadedFile.GetExtension.ToLower = ".zip" Then
        Dim maxZipFileSize As Integer = 10000000 '~10MB
        If e.UploadedFile.ContentLength > maxZipFileSize Then
            e.IsValid = False
        End If
        'The zip files are not validated for file size, extension and mime type
        e.SkipInternalValidation = True
    End If
End Sub
C# Copy Code
private void RadUpload1_ValidatingFile(object sender, ValidateFileEventArgs e)
{
   if (e.UploadedFile.GetExtension().ToLower() == ".zip")
   {
       int maxZipFileSize = 10000000; //~10MB
       if (e.UploadedFile.ContentLength &gt; maxZipFileSize)
       {
           e.IsValid = false;
       }
       //The zip files are not validated for file size, extension and content type
       e.SkipInternalValidation = true;
   }
}

Remarks

To skip the internal validation of the file, set e.SkipInternalValidation = true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
MaxFileSize Property
AllowedMimeTypes Property
AllowedFileExtensions Property

© 2002-2005, telerik. All Rights Reserved.


RadUploadContext Class

RadUploadContext Class
See Also Members
[image]
Telerik.WebControls Namespace : RadUploadContext Class

Object Model

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RadUploadContext
Visual Basic (Usage) Copy Code
Dim instance As RadUploadContext
C#
public sealed class RadUploadContext

Inheritance Hierarchy

System.Object
Telerik.WebControls.RadUploadContext

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

RadUploadContext Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadUploadContext Class Members

RadUploadContext Class Members
See Also Properties
[image]
Telerik.WebControls Namespace : RadUploadContext Class

The following tables list the members exposed by RadUploadContext.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Current |
Public Property | UploadedFiles |
Top

See Also

Reference

RadUploadContext Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadUploadContext Class Properties

RadUploadContext Class Properties
[image]
Telerik.WebControls Namespace : RadUploadContext Class

For a list of all members of this type, see RadUploadContext members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Current |
Public Property | UploadedFiles |
Top

See Also

Reference

RadUploadContext Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


Current Property

Current Property
[image]
Telerik.WebControls Namespace > RadUploadContext Class : Current Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Current As RadUploadContext
Visual Basic (Usage) Copy Code
Dim value As RadUploadContext

value = RadUploadContext.Current
C#
public static RadUploadContext Current {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUploadContext Class
RadUploadContext Members

© 2002-2005, telerik. All Rights Reserved.


UploadedFiles Property

UploadedFiles Property
[image]
Telerik.WebControls Namespace > RadUploadContext Class : UploadedFiles Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property UploadedFiles As UploadedFileCollection
Visual Basic (Usage) Copy Code
Dim instance As RadUploadContext
Dim value As UploadedFileCollection

instance.UploadedFiles = value

value = instance.UploadedFiles
C#
public UploadedFileCollection UploadedFiles {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUploadContext Class
RadUploadContext Members

© 2002-2005, telerik. All Rights Reserved.


UploadedFile Class

RadUpload FileName%">Send comments on this topic.
UploadedFile Class
See Also Members Example
[image]
Telerik.WebControls Namespace : UploadedFile Class

Provides a way to access individual files that have been uploaded by a client via a RadUpload control.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class UploadedFile
Visual Basic (Usage) Copy Code
Dim instance As UploadedFile
C#
public abstract class UploadedFile

Example

Set the maximum allowable upload file size to 1000kB
Visual Basic Copy Code
<httpRuntime maxRequestLength="1000" />
C# Copy Code
&lt;httpRuntime maxRequestLength="1000" /&gt;

Remarks

The UploadedFileCollection class provides access to all files uploaded from a client via single RadUpload instance as a file collection. UploadedFile provides properties and methods to get information on an individual file and to read and save the file. Files are uploaded in MIME multipart/form-data format and are NOT buffered in the server memory if the RadUploadModule is used.

The RadUpload control must be used to select and upload files from a client.

You can specify the maximum allowable upload file size in a machine.config or Web.config configuration file in the maxRequestLength attribute of the <httpRuntime> Element element.

Inheritance Hierarchy

System.Object
Telerik.WebControls.UploadedFile

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

UploadedFile Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


UploadedFile Class Members

RadUpload FileName%">Send comments on this topic.
UploadedFile Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : UploadedFile Class

The following tables list the members exposed by UploadedFile.

Public Properties

 | Name | Description
Public Property | ContentLength | Gets the size in bytes of an uploaded file.
Public Property | ContentType | Gets the MIME content type of a file sent by a client.
Public Property | FileName | Gets the fully-qualified name of the file on the client's computer (for example "C:\MyFiles\Test.txt").
Public Property | InputStream | Gets a Stream object which points to the uploaded file to prepare for reading the contents of the file.
Top

Public Methods

 | Name | Description
Public Method | GetExtension | Returns the extension of the file on the client's computer.
Public Method | GetFieldValue | Returns the value of a custom field.
Public Method | GetIsFieldChecked | Returns the checked state of a custom field.
Public Method | GetName | Returns the name and extension of the file on the client's computer.
Public Method | GetNameWithoutExtension | Returns the name of the file on the client's computer without the extension.
Public Method | MoveTo | Saves the contents of an uploaded file. You will not be able to save the contents again after calling this method. This method should be generally faster than the SaveAs() method.
Public Method | SaveAs | Overloaded. Saves the contents of an uploaded file.
Top

See Also

Reference

UploadedFile Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


UploadedFile Class Methods

RadUpload FileName%">Send comments on this topic.
UploadedFile Class Methods
See Also
[image]
Telerik.WebControls Namespace : UploadedFile Class

For a list of all members of this type, see UploadedFile members.

Public Methods

 | Name | Description
Public Method | GetExtension | Returns the extension of the file on the client's computer.
Public Method | GetFieldValue | Returns the value of a custom field.
Public Method | GetIsFieldChecked | Returns the checked state of a custom field.
Public Method | GetName | Returns the name and extension of the file on the client's computer.
Public Method | GetNameWithoutExtension | Returns the name of the file on the client's computer without the extension.
Public Method | MoveTo | Saves the contents of an uploaded file. You will not be able to save the contents again after calling this method. This method should be generally faster than the SaveAs() method.
Public Method | SaveAs | Overloaded. Saves the contents of an uploaded file.
Top

See Also

Reference

UploadedFile Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


GetExtension Method

RadUpload FileName%">Send comments on this topic.
GetExtension Method
See Also
[image]
Telerik.WebControls Namespace > UploadedFile Class : GetExtension Method

Returns the extension of the file on the client's computer.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function GetExtension() As String
Visual Basic (Usage) Copy Code
Dim instance As UploadedFile
Dim value As String

value = instance.GetExtension()
C#
public string GetExtension()

Remarks

The extension of the file name is obtained by searching it for a period (.), starting with the last character and continuing toward the start. If a period is found before a DirectorySeparatorChar or AltDirectorySeparatorChar character, the returned string contains the period and the characters after it; otherwise, string.Empty is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFile Class
UploadedFile Members

© 2002-2005, telerik. All Rights Reserved.


GetFieldValue Method

RadUpload FileName%">Send comments on this topic.
GetFieldValue Method
See Also
[image]
Telerik.WebControls Namespace > UploadedFile Class : GetFieldValue Method

fieldName
The name of the field wich value will be retrieved
Returns the value of a custom field.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFieldValue( _
   ByVal fieldName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UploadedFile
Dim fieldName As String
Dim value As String

value = instance.GetFieldValue(fieldName)
C#
public string GetFieldValue(
   string fieldName
)

Parameters

fieldName
The name of the field wich value will be retrieved

Return Value

Check the general help for more information and an example.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFile Class
UploadedFile Members

© 2002-2005, telerik. All Rights Reserved.


GetIsFieldChecked Method

RadUpload FileName%">Send comments on this topic.
GetIsFieldChecked Method
See Also
[image]
Telerik.WebControls Namespace > UploadedFile Class : GetIsFieldChecked Method

fieldName
The name of the field wich checked state will be retrieved
Returns the checked state of a custom field.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIsFieldChecked( _
   ByVal fieldName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UploadedFile
Dim fieldName As String
Dim value As Boolean

value = instance.GetIsFieldChecked(fieldName)
C#
public bool GetIsFieldChecked(
   string fieldName
)

Parameters

fieldName
The name of the field wich checked state will be retrieved

Return Value

Check the general help for more information and an example.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFile Class
UploadedFile Members

© 2002-2005, telerik. All Rights Reserved.


GetName Method

RadUpload FileName%">Send comments on this topic.
GetName Method
See Also
[image]
Telerik.WebControls Namespace > UploadedFile Class : GetName Method

Returns the name and extension of the file on the client's computer.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function GetName() As String
Visual Basic (Usage) Copy Code
Dim instance As UploadedFile
Dim value As String

value = instance.GetName()
C#
public string GetName()

Remarks

The separator characters used to determine the start of the file name are DirectorySeparatorChar and AltDirectorySeparatorChar.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFile Class
UploadedFile Members

© 2002-2005, telerik. All Rights Reserved.


GetNameWithoutExtension Method

RadUpload FileName%">Send comments on this topic.
GetNameWithoutExtension Method
See Also
[image]
Telerik.WebControls Namespace > UploadedFile Class : GetNameWithoutExtension Method

Returns the name of the file on the client's computer without the extension.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function GetNameWithoutExtension() As String
Visual Basic (Usage) Copy Code
Dim instance As UploadedFile
Dim value As String

value = instance.GetNameWithoutExtension()
C#
public string GetNameWithoutExtension()

Remarks

A string containing the string returned by GetFileName, minus the last period (.) and all characters following it.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFile Class
UploadedFile Members

© 2002-2005, telerik. All Rights Reserved.


MoveTo Method

RadUpload fileName%">Send comments on this topic.
MoveTo Method
See Also
[image]
Telerik.WebControls Namespace > UploadedFile Class : MoveTo Method

fileName
Saves the contents of an uploaded file. You will not be able to save the contents again after calling this method. This method should be generally faster than the SaveAs() method.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Sub MoveTo( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As UploadedFile
Dim fileName As String

instance.MoveTo(fileName)
C#
public virtual abstract void MoveTo(
   string fileName
)

Parameters

fileName

Remarks

The maximum allowed uploaded file size is 4MB by default. Maximum file size can be specified in the machine.config or Web.config configuration files in the maxRequestLength attribute of the <httpRuntime> element.

The ASP.NET process must have proper rights for writing on the folder where the files are saved.

When RadMemoryOptimization is enabled the uploaded files are stored on the server hard drive. The SaveAs() methods copy the temporary files into the specified location. This method will move the temporary file to the specified location, which is generally a faster operation. After calling this method the temporary file will be deleted and you will not be able to call SaveAs() or MoveTo() again.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFile Class
UploadedFile Members

© 2002-2005, telerik. All Rights Reserved.


SaveAs Method

RadUpload FileName%">Send comments on this topic.
SaveAs Method
See Also
[image]
Telerik.WebControls Namespace > UploadedFile Class : SaveAs Method

Saves the contents of an uploaded file.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Overload List

Overload | Description
SaveAs(String) | Saves the contents of an uploaded file.
SaveAs(String,Boolean) | Saves the contents of an uploaded file.

Overload List

Overload | Description
SaveAs(String) | Saves the contents of an uploaded file.
SaveAs(String,Boolean) | Saves the contents of an uploaded file.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFile Class
UploadedFile Members

© 2002-2005, telerik. All Rights Reserved.


SaveAs(String) Method

RadUpload fileName%">Send comments on this topic.
SaveAs(String) Method
See Also Example
[image]
Telerik.WebControls Namespace > UploadedFile Class > SaveAs Method : SaveAs(String) Method

fileName
Saves the contents of an uploaded file.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub SaveAs( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As UploadedFile
Dim fileName As String

instance.SaveAs(fileName)
C#
public void SaveAs(
   string fileName
)

Parameters

fileName

Example

The following example saves all the files uploaded by the client to a folder named "C:\TempFiles" on the Web server's local disk.
Visual Basic Copy Code
Dim Loop1 As Integer
Dim TempFileName As String
Dim MyFileCollection As UploadedFileCollection = RadUpload1.UploadedFiles

For Loop1 = 0 To MyFileCollection.Count - 1
    ' Create a new file name.
    TempFileName = "C:\TempFiles\File_" & CStr(Loop1)
    ' Save the file.
    MyFileCollection(Loop1).SaveAs(TempFileName)
Next Loop1
C# Copy Code
String TempFileName;
UploadedFileCollection MyFileCollection = RadUpload1.UploadedFiles;

for (int Loop1 = 0; Loop1 &lt; MyFileCollection.Count; Loop1++)
{
   // Create a new file name.
   TempFileName = "C:\\TempFiles\\File_" + Loop1.ToString();
   // Save the file.
   MyFileCollection[Loop1].SaveAs(TempFileName);
}

Remarks

The maximum allowed uploaded file size is 4MB by default. Maximum file size can be specified in the machine.config or Web.config configuration files in the maxRequestLength attribute of the <httpRuntime> element.

The ASP.NET process must have proper rights for writing on the folder where the files are saved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFile Class
UploadedFile Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


SaveAs(String,Boolean) Method

RadUpload fileName%">Send comments on this topic.
SaveAs(String,Boolean) Method
See Also Example
[image]
Telerik.WebControls Namespace > UploadedFile Class > SaveAs Method : SaveAs(String,Boolean) Method

fileName
The name of the saved file.
overwrite
true to allow an existing file to be overwritten; otherwise, false.
Saves the contents of an uploaded file.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Sub SaveAs( _
   ByVal fileName As String, _
   ByVal overwrite As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As UploadedFile
Dim fileName As String
Dim overwrite As Boolean

instance.SaveAs(fileName, overwrite)
C#
public virtual abstract void SaveAs(
   string fileName,
   bool overwrite
)

Parameters

fileName
The name of the saved file.
overwrite
true to allow an existing file to be overwritten; otherwise, false.

Example

The following example saves all the files uploaded by the client to a folder named "C:\TempFiles" on the Web server's local disk. The existing files are overwritten.
Visual Basic Copy Code
Dim Loop1 As Integer
Dim TempFileName As String
Dim ShouldOverwrite As Boolean = True
Dim MyFileCollection As UploadedFileCollection = RadUpload1.UploadedFiles

For Loop1 = 0 To MyFileCollection.Count - 1
    ' Create a new file name.
    TempFileName = "C:\TempFiles\File_" & CStr(Loop1)
    ' Save the file.
    MyFileCollection(Loop1).SaveAs(TempFileName, ShouldOverwrite)
Next Loop1
C# Copy Code
String TempFileName;
bool ShouldOverwrite = true;
UploadedFileCollection MyFileCollection = RadUpload1.UploadedFiles;

 for (int Loop1 = 0; Loop1 &lt; MyFileCollection.Count; Loop1++)
{
   // Create a new file name.
   TempFileName = "C:\\TempFiles\\File_" + Loop1.ToString();
   // Save the file.
   MyFileCollection[Loop1].SaveAs(TempFileName, ShouldOverwrite);
}

Remarks

The maximum allowed uploaded file size is 4MB by default. Maximum file size can be specified in the machine.config or Web.config configuration files in the maxRequestLength attribute of the <httpRuntime> element.

The ASP.NET process must have proper rights for writing on the folder where the files are saved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFile Class
UploadedFile Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


UploadedFile Class Properties

RadUpload FileName%">Send comments on this topic.
UploadedFile Class Properties
See Also
[image]
Telerik.WebControls Namespace : UploadedFile Class

For a list of all members of this type, see UploadedFile members.

Public Properties

 | Name | Description
Public Property | ContentLength | Gets the size in bytes of an uploaded file.
Public Property | ContentType | Gets the MIME content type of a file sent by a client.
Public Property | FileName | Gets the fully-qualified name of the file on the client's computer (for example "C:\MyFiles\Test.txt").
Public Property | InputStream | Gets a Stream object which points to the uploaded file to prepare for reading the contents of the file.
Top

See Also

Reference

UploadedFile Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


ContentLength Property

RadUpload FileName%">Send comments on this topic.
ContentLength Property
See Also Example
[image]
Telerik.WebControls Namespace > UploadedFile Class : ContentLength Property

Gets the size in bytes of an uploaded file.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property ContentLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As UploadedFile
Dim value As Integer

value = instance.ContentLength
C#
public virtual abstract int ContentLength {get;}

Return Value

The length of the file.

Example

This example validates the file size of an uploaded file.
C# Copy Code
bool isValid = true;
if (file.ContentLength &gt; MaxFileSize)
{
   isValid = false;
}

Visual Basic Copy Code
Dim isValid As Boolean = True;
If file.ContentLength > MaxFileSize Then
    isValid = False;
End If

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFile Class
UploadedFile Members

© 2002-2005, telerik. All Rights Reserved.


ContentType Property

RadUpload FileName%">Send comments on this topic.
ContentType Property
See Also Example
[image]
Telerik.WebControls Namespace > UploadedFile Class : ContentType Property

Gets the MIME content type of a file sent by a client.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property ContentType As String
Visual Basic (Usage) Copy Code
Dim instance As UploadedFile
Dim value As String

value = instance.ContentType
C#
public virtual abstract string ContentType {get;}

Return Value

The MIME content type of the uploaded file.

Example

The following example loops through all the files in the uploaded files collection and takes action when the MIME type of a file is US-ASCII .
Visual Basic Copy Code
Dim Loop1 As Integer
 Dim MyFileCollection As UploadedFileCollection = RadUpload1.UploadedFiles

 For Loop1 = 0 To MyFileCollection.Count - 1
    If MyFileCollection(Loop1).ContentType = "video/mpeg" Then
       '...
    End If
 Next Loop1
C# Copy Code
UploadedFileCollection MyFileCollection = RadUpload1.UploadedFiles;

for (int Loop1 = 0; Loop1 &lt; MyFileCollection.Count; Loop1++)
{
   if (MyFileCollection[Loop1].ContentType == "video/mpeg")
   {
      //...
   }
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFile Class
UploadedFile Members

© 2002-2005, telerik. All Rights Reserved.


FileName Property

FileName Property
See Also Example
[image]
Telerik.WebControls Namespace > UploadedFile Class : FileName Property

Gets the fully-qualified name of the file on the client's computer (for example "C:\MyFiles\Test.txt").

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As UploadedFile
Dim value As String

value = instance.FileName
C#
public virtual abstract string FileName {get;}

Return Value

A string containing the fully-qualified name of the file on the client's computer.

Example

The following example assigns the name of an uploaded file (the first file in the file collection) to a string variable.
C# Copy Code
UploadedFile MyUploadedFile = RadUpload1.UploadedFiles[0];
string MyFileName = MyUploadedFile.FileName;

Visual Basic Copy Code
Dim MyUploadedFile As UploadedFile = RadUpload1.UploadedFiles(0)
Dim MyFileName As String = MyUploadedFile.FileName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFile Class
UploadedFile Members

© 2002-2005, telerik. All Rights Reserved.


InputStream Property

RadUpload FileName%">Send comments on this topic.
InputStream Property
See Also
[image]
Telerik.WebControls Namespace > UploadedFile Class : InputStream Property

Gets a Stream object which points to the uploaded file to prepare for reading the contents of the file.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property InputStream As Stream
Visual Basic (Usage) Copy Code
Dim instance As UploadedFile
Dim value As Stream

value = instance.InputStream
C#
public virtual abstract Stream InputStream {get;}

Return Value

A Stream pointing to the file.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFile Class
UploadedFile Members

© 2002-2005, telerik. All Rights Reserved.


UploadedFileEventArgs Class

UploadedFileEventArgs Class
See Also Members
[image]
Telerik.WebControls Namespace : UploadedFileEventArgs Class

UploadedFileEventArgs is the base class for the RadUpload event data.

Object Model

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Class UploadedFileEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As UploadedFileEventArgs
C#
public class UploadedFileEventArgs : EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.WebControls.UploadedFileEventArgs
Telerik.WebControls.ValidateFileEventArgs

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

UploadedFileEventArgs Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


UploadedFileEventArgs Class Members

UploadedFileEventArgs Class Members
See Also Properties
[image]
Telerik.WebControls Namespace : UploadedFileEventArgs Class

The following tables list the members exposed by UploadedFileEventArgs.

Public Properties

 | Name | Description
Public Property | UploadedFile | Gets the currently processed UploadedFile.
Top

See Also

Reference

UploadedFileEventArgs Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


UploadedFileEventArgs Class Properties

UploadedFileEventArgs Class Properties
[image]
Telerik.WebControls Namespace : UploadedFileEventArgs Class

For a list of all members of this type, see UploadedFileEventArgs members.

Public Properties

 | Name | Description
Public Property | UploadedFile | Gets the currently processed UploadedFile.
Top

See Also

Reference

UploadedFileEventArgs Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


UploadedFile Property

UploadedFile Property
See Also Example
[image]
Telerik.WebControls Namespace > UploadedFileEventArgs Class : UploadedFile Property

Gets the currently processed UploadedFile.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UploadedFile As UploadedFile
Visual Basic (Usage) Copy Code
Dim instance As UploadedFileEventArgs
Dim value As UploadedFile

value = instance.UploadedFile
C#
public UploadedFile UploadedFile {get;}

Return Value

UploadedFile object that contains information about the currently processed file.

Example

The following example demonstrates how to use the UploadedFile property to save a file in the FileExists event.
Visual Basic Copy Code
Private Sub RadUpload1_FileExists(ByVal sender As Object, ByVal e As WebControls.UploadedFileEventArgs) Handles RadUpload1.FileExists
    Dim TheFile As Telerik.WebControls.UploadedFile = e.UploadedFile

    e.UploadedFile.SaveAs(Path.Combine(RadUpload1.TargetFolder, TheFile.GetName + "1" + TheFile.GetExtension))
End Sub
C# Copy Code
private void RadUpload1_FileExists(object sender, Telerik.WebControls.UploadedFileEventArgs e)
{
   Telerik.WebControls.UploadedFile TheFile = e.UploadedFile;

   TheFile.SaveAs(Path.Combine(RadUpload1.TargetFolder, TheFile.GetName() + "1" + TheFile.GetExtension()));
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFileEventArgs Class
UploadedFileEventArgs Members

© 2002-2005, telerik. All Rights Reserved.


ValidateFileEventArgs Class

ValidateFileEventArgs Class
See Also Members
[image]
Telerik.WebControls Namespace : ValidateFileEventArgs Class

Provides data for the ValidatingFile event of the RadUpload control.

Object Model

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Class ValidateFileEventArgs
   Inherits UploadedFileEventArgs
Visual Basic (Usage) Copy Code
Dim instance As ValidateFileEventArgs
C#
public class ValidateFileEventArgs : UploadedFileEventArgs

Remarks

A ValidatingFileEventArgs is passed to the ValidatingFile event handler to provide event data to the handler. The ValidatingFile event event is raised when validation is performed on the server. This allows you to perform a custom server-side validation routine on a file of a RadUpload control.

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.WebControls.UploadedFileEventArgs
Telerik.WebControls.ValidateFileEventArgs

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

ValidateFileEventArgs Members
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


ValidateFileEventArgs Class Members

ValidateFileEventArgs Class Members
See Also Properties
[image]
Telerik.WebControls Namespace : ValidateFileEventArgs Class

The following tables list the members exposed by ValidateFileEventArgs.

Public Properties

 | Name | Description
Public Property | IsValid | Gets or sets whether the value specified by UploadedFile property passed validation.
Public Property | SkipInternalValidation | Gets or sets whether the internal validation should continue validating the file specified by the UploadedFile property.
Public Property | UploadedFile | Gets the currently processed UploadedFile. (Inherited from UploadedFileEventArgs)
Top

See Also

Reference

ValidateFileEventArgs Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


ValidateFileEventArgs Class Properties

ValidateFileEventArgs Class Properties
[image]
Telerik.WebControls Namespace : ValidateFileEventArgs Class

For a list of all members of this type, see ValidateFileEventArgs members.

Public Properties

 | Name | Description
Public Property | IsValid | Gets or sets whether the value specified by UploadedFile property passed validation.
Public Property | SkipInternalValidation | Gets or sets whether the internal validation should continue validating the file specified by the UploadedFile property.
Public Property | UploadedFile | Gets the currently processed UploadedFile. (Inherited from UploadedFileEventArgs)
Top

See Also

Reference

ValidateFileEventArgs Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


IsValid Property

IsValid Property
See Also Example
[image]
Telerik.WebControls Namespace > ValidateFileEventArgs Class : IsValid Property

Gets or sets whether the value specified by UploadedFile property passed validation.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property IsValid As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ValidateFileEventArgs
Dim value As Boolean

instance.IsValid = value

value = instance.IsValid
C#
public bool IsValid {get; set;}

Return Value

true to indicate that the value specified by the UploadedFile property passed validation; otherwise, false

Example

This example demonstrates how to implement validation for filenames.
Visual Basic Copy Code
Private Sub RadUpload1_ValidatingFile(ByVal sender As Object, ByVal e As WebControls.ValidateFileEventArgs) Handles RadUpload1.ValidatingFile
    If e.UploadedFile.GetExtension.ToLower() = ".zip" Then
        'The zip files are not allowed for upload
        e.IsValid = False
    End If
End Sub
C# Copy Code
private void RadUpload1_ValidatingFile(object sender, ValidateFileEventArgs e)
{
   if (e.UploadedFile.GetExtension().ToLower() == ".zip")
   {
       //The zip files are not allowed for upload
       e.IsValid = false;
   }
}

Remarks

Once your validation routine finishes, use the IsValid property to indicate whether the value specified by the UploadedFile property passed validation. This value determines whether the file from the RadUpload control passed validation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ValidateFileEventArgs Class
ValidateFileEventArgs Members

© 2002-2005, telerik. All Rights Reserved.


SkipInternalValidation Property

SkipInternalValidation Property
See Also Example
[image]
Telerik.WebControls Namespace > ValidateFileEventArgs Class : SkipInternalValidation Property

Gets or sets whether the internal validation should continue validating the file specified by the UploadedFile property.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property SkipInternalValidation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ValidateFileEventArgs
Dim value As Boolean

instance.SkipInternalValidation = value

value = instance.SkipInternalValidation
C#
public bool SkipInternalValidation {get; set;}

Return Value

false to indicate that the internal validation should validate the file specified by the UploadedFile property; otherwise, true

Example

This example demostrates how to implement custom validation for specific file type.
Visual Basic Copy Code
Private Sub RadUpload1_ValidatingFile(ByVal sender As Object, ByVal e As WebControls.ValidateFileEventArgs) Handles RadUpload1.ValidatingFile
    If e.UploadedFile.GetExtension.ToLower = ".zip" Then
        Dim maxZipFileSize As Integer = 10000000 '~10MB
        If e.UploadedFile.ContentLength > maxZipFileSize Then
            e.IsValid = False
        End If
        'The zip files are not validated for file size, extension and mime type
        e.SkipInternalValidation = True
    End If
End Sub
C# Copy Code
private void RadUpload1_ValidatingFile(object sender, ValidateFileEventArgs e)
{
   if (e.UploadedFile.GetExtension().ToLower() == ".zip")
   {
       int maxZipFileSize = 10000000; //~10MB
       if (e.UploadedFile.ContentLength &gt; maxZipFileSize)
       {
           e.IsValid = false;
       }
       //The zip files are not validated for file size, extension and content type
       e.SkipInternalValidation = true;
   }
}

Remarks

Once your validation routine finishes, use the SkipInternalValidation property to skip the internal validation provided by the RadUpload control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ValidateFileEventArgs Class
ValidateFileEventArgs Members
MaxFileSize Property (Telerik.WebControls.RadUpload)
AllowedMimeTypes Property (Telerik.WebControls.RadUpload)
AllowedFileExtensions Property (Telerik.WebControls.RadUpload)


FlagCheckedListBox Class

FlagCheckedListBox Class
See Also Members
[image]
Telerik.WebControls.Design.Upload Namespace : FlagCheckedListBox Class

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Class FlagCheckedListBox
   Inherits CheckedListBox
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBox
C#
public class FlagCheckedListBox : CheckedListBox

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ListBox
System.Windows.Forms.CheckedListBox
Telerik.WebControls.Design.Upload.FlagCheckedListBox

Requirements

Namespace: Telerik.WebControls.Design.Upload

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

FlagCheckedListBox Members
Telerik.WebControls.Design.Upload Namespace


FlagCheckedListBox Class Members

FlagCheckedListBox Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls.Design.Upload Namespace : FlagCheckedListBox Class

The following tables list the members exposed by FlagCheckedListBox.

Public Constructors

 | Name | Description
Public Constructor | FlagCheckedListBox Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | (Inherited from System.Windows.Forms.ListBox)
Public Property | BindingContext | (Inherited from System.Windows.Forms.Control)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.ListBox)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | CheckedIndices | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | CheckedItems | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | CheckOnClick | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | ColumnWidth | (Inherited from System.Windows.Forms.ListBox)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | CustomTabOffsets | (Inherited from System.Windows.Forms.ListBox)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | EnumValue |
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.ListBox)
Public Property | ForeColor | (Inherited from System.Windows.Forms.ListBox)
Public Property | FormatInfo | (Inherited from System.Windows.Forms.ListControl)
Public Property | FormatString | (Inherited from System.Windows.Forms.ListControl)
Public Property | FormattingEnabled | (Inherited from System.Windows.Forms.ListControl)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalExtent | (Inherited from System.Windows.Forms.ListBox)
Public Property | HorizontalScrollbar | (Inherited from System.Windows.Forms.ListBox)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | IntegralHeight | (Inherited from System.Windows.Forms.ListBox)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | Items | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MultiColumn | (Inherited from System.Windows.Forms.ListBox)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | PreferredHeight | (Inherited from System.Windows.Forms.ListBox)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.ListBox)
Public Property | ScrollAlwaysVisible | (Inherited from System.Windows.Forms.ListBox)
Public Property | SelectedIndex | (Inherited from System.Windows.Forms.ListBox)
Public Property | SelectedIndices | (Inherited from System.Windows.Forms.ListBox)
Public Property | SelectedItem | (Inherited from System.Windows.Forms.ListBox)
Public Property | SelectedItems | (Inherited from System.Windows.Forms.ListBox)
Public Property | SelectedValue | (Inherited from System.Windows.Forms.ListControl)
Public Property | SelectionMode | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | Sorted | (Inherited from System.Windows.Forms.ListBox)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.ListBox)
Public Property | ThreeDCheckBoxes | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopIndex | (Inherited from System.Windows.Forms.ListBox)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseCompatibleTextRendering | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | UseCustomTabOffsets | (Inherited from System.Windows.Forms.ListBox)
Public Property | UseTabStops | (Inherited from System.Windows.Forms.ListBox)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | (Inherited from System.Windows.Forms.ListBox)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.Control)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Property | DataManager | (Inherited from System.Windows.Forms.ListControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.ListBox)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BeginUpdate | (Inherited from System.Windows.Forms.ListBox)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | ClearSelected | (Inherited from System.Windows.Forms.ListBox)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | EndUpdate | (Inherited from System.Windows.Forms.ListBox)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | FindString | Overloaded. (Inherited from System.Windows.Forms.ListBox)
Public Method | FindStringExact | Overloaded. (Inherited from System.Windows.Forms.ListBox)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetCurrentValue |
Public Method | GetItemChecked | (Inherited from System.Windows.Forms.CheckedListBox)
Public Method | GetItemCheckState | (Inherited from System.Windows.Forms.CheckedListBox)
Public Method | GetItemHeight | (Inherited from System.Windows.Forms.ListBox)
Public Method | GetItemRectangle | (Inherited from System.Windows.Forms.ListBox)
Public Method | GetItemText | (Inherited from System.Windows.Forms.ListControl)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | GetSelected | (Inherited from System.Windows.Forms.ListBox)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | IndexFromPoint | Overloaded. (Inherited from System.Windows.Forms.ListBox)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.ListBox)
Public Method | ResetBackColor | (Inherited from System.Windows.Forms.ListBox)
Public Method | ResetForeColor | (Inherited from System.Windows.Forms.ListBox)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetItemChecked | (Inherited from System.Windows.Forms.CheckedListBox)
Public Method | SetItemCheckState | (Inherited from System.Windows.Forms.CheckedListBox)
Public Method | SetSelected | (Inherited from System.Windows.Forms.ListBox)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.ListBox)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | AddItemsCore | (Inherited from System.Windows.Forms.ListBox)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateItemCollection | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | FilterItemOnProperty | Overloaded. (Inherited from System.Windows.Forms.ListControl)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.ListBox)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.ListControl)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.ListControl)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnClick | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDataSourceChanged | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnDisplayMemberChanged | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDrawItem | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFormat | (Inherited from System.Windows.Forms.ListControl)
Protected Method | OnFormatInfoChanged | (Inherited from System.Windows.Forms.ListControl)
Protected Method | OnFormatStringChanged | (Inherited from System.Windows.Forms.ListControl)
Protected Method | OnFormattingEnabledChanged | (Inherited from System.Windows.Forms.ListControl)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnItemCheck | Overridden.
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMeasureItem | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSelectedIndexChanged | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnSelectedValueChanged | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValueMemberChanged | (Inherited from System.Windows.Forms.ListControl)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | RefreshItem | (Inherited from System.Windows.Forms.ListBox)
Protected Method | RefreshItems | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ListBox)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.ListBox)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetItemCore | (Inherited from System.Windows.Forms.ListBox)
Protected Method | SetItemsCore | (Inherited from System.Windows.Forms.ListBox)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | Sort | (Inherited from System.Windows.Forms.ListBox)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateCheckedItems | Overloaded.
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WmReflectCommand | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | WndProc | (Inherited from System.Windows.Forms.CheckedListBox)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.CheckedListBox)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Format | (Inherited from System.Windows.Forms.ListControl)
Public Event | FormatInfoChanged | (Inherited from System.Windows.Forms.ListControl)
Public Event | FormatStringChanged | (Inherited from System.Windows.Forms.ListControl)
Public Event | FormattingEnabledChanged | (Inherited from System.Windows.Forms.ListControl)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | ItemCheck | (Inherited from System.Windows.Forms.CheckedListBox)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.CheckedListBox)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SelectedIndexChanged | (Inherited from System.Windows.Forms.ListBox)
Public Event | SelectedValueChanged | (Inherited from System.Windows.Forms.ListControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.ListBox)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

FlagCheckedListBox Class
Telerik.WebControls.Design.Upload Namespace


FlagCheckedListBox Constructor

FlagCheckedListBox Constructor
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBox Class : FlagCheckedListBox Constructor

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBox()
C#
public FlagCheckedListBox()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBox()
C#
public FlagCheckedListBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBox Class
FlagCheckedListBox Members

© 2002-2005, telerik. All Rights Reserved.


FlagCheckedListBox Class Methods

FlagCheckedListBox Class Methods
[image]
Telerik.WebControls.Design.Upload Namespace : FlagCheckedListBox Class

For a list of all members of this type, see FlagCheckedListBox members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BeginUpdate | (Inherited from System.Windows.Forms.ListBox)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | ClearSelected | (Inherited from System.Windows.Forms.ListBox)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | EndUpdate | (Inherited from System.Windows.Forms.ListBox)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | FindString | Overloaded. (Inherited from System.Windows.Forms.ListBox)
Public Method | FindStringExact | Overloaded. (Inherited from System.Windows.Forms.ListBox)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetCurrentValue |
Public Method | GetItemChecked | (Inherited from System.Windows.Forms.CheckedListBox)
Public Method | GetItemCheckState | (Inherited from System.Windows.Forms.CheckedListBox)
Public Method | GetItemHeight | (Inherited from System.Windows.Forms.ListBox)
Public Method | GetItemRectangle | (Inherited from System.Windows.Forms.ListBox)
Public Method | GetItemText | (Inherited from System.Windows.Forms.ListControl)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | GetSelected | (Inherited from System.Windows.Forms.ListBox)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | IndexFromPoint | Overloaded. (Inherited from System.Windows.Forms.ListBox)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.ListBox)
Public Method | ResetBackColor | (Inherited from System.Windows.Forms.ListBox)
Public Method | ResetForeColor | (Inherited from System.Windows.Forms.ListBox)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetItemChecked | (Inherited from System.Windows.Forms.CheckedListBox)
Public Method | SetItemCheckState | (Inherited from System.Windows.Forms.CheckedListBox)
Public Method | SetSelected | (Inherited from System.Windows.Forms.ListBox)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.ListBox)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | AddItemsCore | (Inherited from System.Windows.Forms.ListBox)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateItemCollection | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | FilterItemOnProperty | Overloaded. (Inherited from System.Windows.Forms.ListControl)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.ListBox)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.ListControl)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.ListControl)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnClick | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDataSourceChanged | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnDisplayMemberChanged | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDrawItem | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFormat | (Inherited from System.Windows.Forms.ListControl)
Protected Method | OnFormatInfoChanged | (Inherited from System.Windows.Forms.ListControl)
Protected Method | OnFormatStringChanged | (Inherited from System.Windows.Forms.ListControl)
Protected Method | OnFormattingEnabledChanged | (Inherited from System.Windows.Forms.ListControl)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnItemCheck | Overridden.
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMeasureItem | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSelectedIndexChanged | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | OnSelectedValueChanged | (Inherited from System.Windows.Forms.ListBox)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValueMemberChanged | (Inherited from System.Windows.Forms.ListControl)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | RefreshItem | (Inherited from System.Windows.Forms.ListBox)
Protected Method | RefreshItems | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ListBox)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.ListBox)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetItemCore | (Inherited from System.Windows.Forms.ListBox)
Protected Method | SetItemsCore | (Inherited from System.Windows.Forms.ListBox)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | Sort | (Inherited from System.Windows.Forms.ListBox)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateCheckedItems | Overloaded.
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WmReflectCommand | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Method | WndProc | (Inherited from System.Windows.Forms.CheckedListBox)
Top

See Also

Reference

FlagCheckedListBox Class
Telerik.WebControls.Design.Upload Namespace


Add Method

Add Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBox Class : Add Method

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Overload List

Overload | Description
Add(Int32,String) |
Add(FlagCheckedListBoxItem) |

Overload List

Overload | Description
Add(Int32,String) |
Add(FlagCheckedListBoxItem) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBox Class
FlagCheckedListBox Members

© 2002-2005, telerik. All Rights Reserved.


Add(Int32,String) Method

Add(Int32,String) Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBox Class > Add Method : Add(Int32,String) Method

checkboxValue
caption

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Add( _
   ByVal checkboxValue As Integer, _
   ByVal caption As String _
) As FlagCheckedListBoxItem
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBox
Dim checkboxValue As Integer
Dim caption As String
Dim value As FlagCheckedListBoxItem

value = instance.Add(checkboxValue, caption)
C#
public FlagCheckedListBoxItem Add(
   int checkboxValue,
   string caption
)

Parameters

checkboxValue
caption

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBox Class
FlagCheckedListBox Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


Add(FlagCheckedListBoxItem) Method

Add(FlagCheckedListBoxItem) Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBox Class > Add Method : Add(FlagCheckedListBoxItem) Method

item

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Function Add( _
   ByVal item As FlagCheckedListBoxItem _
) As FlagCheckedListBoxItem
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBox
Dim item As FlagCheckedListBoxItem
Dim value As FlagCheckedListBoxItem

value = instance.Add(item)
C#
public FlagCheckedListBoxItem Add(
   FlagCheckedListBoxItem item
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBox Class
FlagCheckedListBox Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


Dispose Method

Dispose Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBox Class : Dispose Method

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Overload List

Overload | Description
Dispose(Boolean) |
Dispose() | (Inherited from System.ComponentModel.Component)

Overload List

Overload | Description
Dispose(Boolean) |
Dispose() | (Inherited from System.ComponentModel.Component)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBox Class
FlagCheckedListBox Members

© 2002-2005, telerik. All Rights Reserved.


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBox Class > Dispose Method : Dispose(Boolean) Method

disposing

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBox
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBox Class
FlagCheckedListBox Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


GetCurrentValue Method

GetCurrentValue Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBox Class : GetCurrentValue Method

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCurrentValue() As Integer
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBox
Dim value As Integer

value = instance.GetCurrentValue()
C#
public int GetCurrentValue()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBox Class
FlagCheckedListBox Members

© 2002-2005, telerik. All Rights Reserved.


OnItemCheck Method

OnItemCheck Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBox Class : OnItemCheck Method

e

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Protected Sub OnItemCheck( _
   ByVal e As ItemCheckEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBox
Dim e As ItemCheckEventArgs

instance.OnItemCheck(e)
C#
protected override void OnItemCheck(
   ItemCheckEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBox Class
FlagCheckedListBox Members

© 2002-2005, telerik. All Rights Reserved.


UpdateCheckedItems Method

UpdateCheckedItems Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBox Class : UpdateCheckedItems Method

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Overload List

Overload | Description
UpdateCheckedItems(Int32) |
UpdateCheckedItems(FlagCheckedListBoxItem,CheckState) |

Overload List

Overload | Description
UpdateCheckedItems(Int32) |
UpdateCheckedItems(FlagCheckedListBoxItem,CheckState) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBox Class
FlagCheckedListBox Members

© 2002-2005, telerik. All Rights Reserved.


UpdateCheckedItems(Int32) Method

UpdateCheckedItems(Int32) Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBox Class > UpdateCheckedItems Method : UpdateCheckedItems(Int32) Method

checkboxValue

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Sub UpdateCheckedItems( _
   ByVal checkboxValue As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBox
Dim checkboxValue As Integer

instance.UpdateCheckedItems(checkboxValue)
C#
protected void UpdateCheckedItems(
   int checkboxValue
)

Parameters

checkboxValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBox Class
FlagCheckedListBox Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


UpdateCheckedItems(FlagCheckedListBoxItem,CheckState) Method

UpdateCheckedItems(FlagCheckedListBoxItem,CheckState) Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBox Class > UpdateCheckedItems Method : UpdateCheckedItems(FlagCheckedListBoxItem,CheckState) Method

composite
cs

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Sub UpdateCheckedItems( _
   ByVal composite As FlagCheckedListBoxItem, _
   ByVal cs As CheckState _
)
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBox
Dim composite As FlagCheckedListBoxItem
Dim cs As CheckState

instance.UpdateCheckedItems(composite, cs)
C#
protected void UpdateCheckedItems(
   FlagCheckedListBoxItem composite,
   CheckState cs
)

Parameters

composite
cs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBox Class
FlagCheckedListBox Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


FlagCheckedListBox Class Properties

FlagCheckedListBox Class Properties
[image]
Telerik.WebControls.Design.Upload Namespace : FlagCheckedListBox Class

For a list of all members of this type, see FlagCheckedListBox members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | (Inherited from System.Windows.Forms.ListBox)
Public Property | BindingContext | (Inherited from System.Windows.Forms.Control)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.ListBox)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | CheckedIndices | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | CheckedItems | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | CheckOnClick | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | ColumnWidth | (Inherited from System.Windows.Forms.ListBox)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | CustomTabOffsets | (Inherited from System.Windows.Forms.ListBox)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | EnumValue |
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.ListBox)
Public Property | ForeColor | (Inherited from System.Windows.Forms.ListBox)
Public Property | FormatInfo | (Inherited from System.Windows.Forms.ListControl)
Public Property | FormatString | (Inherited from System.Windows.Forms.ListControl)
Public Property | FormattingEnabled | (Inherited from System.Windows.Forms.ListControl)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalExtent | (Inherited from System.Windows.Forms.ListBox)
Public Property | HorizontalScrollbar | (Inherited from System.Windows.Forms.ListBox)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | IntegralHeight | (Inherited from System.Windows.Forms.ListBox)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | Items | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MultiColumn | (Inherited from System.Windows.Forms.ListBox)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | PreferredHeight | (Inherited from System.Windows.Forms.ListBox)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.ListBox)
Public Property | ScrollAlwaysVisible | (Inherited from System.Windows.Forms.ListBox)
Public Property | SelectedIndex | (Inherited from System.Windows.Forms.ListBox)
Public Property | SelectedIndices | (Inherited from System.Windows.Forms.ListBox)
Public Property | SelectedItem | (Inherited from System.Windows.Forms.ListBox)
Public Property | SelectedItems | (Inherited from System.Windows.Forms.ListBox)
Public Property | SelectedValue | (Inherited from System.Windows.Forms.ListControl)
Public Property | SelectionMode | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | Sorted | (Inherited from System.Windows.Forms.ListBox)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.ListBox)
Public Property | ThreeDCheckBoxes | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopIndex | (Inherited from System.Windows.Forms.ListBox)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseCompatibleTextRendering | (Inherited from System.Windows.Forms.CheckedListBox)
Public Property | UseCustomTabOffsets | (Inherited from System.Windows.Forms.ListBox)
Public Property | UseTabStops | (Inherited from System.Windows.Forms.ListBox)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | (Inherited from System.Windows.Forms.ListBox)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.Control)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.CheckedListBox)
Protected Property | DataManager | (Inherited from System.Windows.Forms.ListControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.ListBox)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

FlagCheckedListBox Class
Telerik.WebControls.Design.Upload Namespace


EnumValue Property

EnumValue Property
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBox Class : EnumValue Property

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property EnumValue As Enum
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBox
Dim value As Enum

instance.EnumValue = value

value = instance.EnumValue
C#
public Enum EnumValue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBox Class
FlagCheckedListBox Members

© 2002-2005, telerik. All Rights Reserved.


FlagCheckedListBoxItem Class

FlagCheckedListBoxItem Class
See Also Members
[image]
Telerik.WebControls.Design.Upload Namespace : FlagCheckedListBoxItem Class

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Class FlagCheckedListBoxItem
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBoxItem
C#
public class FlagCheckedListBoxItem

Inheritance Hierarchy

System.Object
Telerik.WebControls.Design.Upload.FlagCheckedListBoxItem

Requirements

Namespace: Telerik.WebControls.Design.Upload

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

FlagCheckedListBoxItem Members
Telerik.WebControls.Design.Upload Namespace


FlagCheckedListBoxItem Class Members

FlagCheckedListBoxItem Class Members
See Also Fields Properties Methods
[image]
Telerik.WebControls.Design.Upload Namespace : FlagCheckedListBoxItem Class

The following tables list the members exposed by FlagCheckedListBoxItem.

Public Constructors

 | Name | Description
Public Constructor | FlagCheckedListBoxItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | Caption |
Public Field | Value |
Top

Public Properties

 | Name | Description
Public Property | IsFlag |
Top

Public Methods

 | Name | Description
Public Method | IsMemberFlag |
Public Method | ToString | Overridden.
Top

See Also

Reference

FlagCheckedListBoxItem Class
Telerik.WebControls.Design.Upload Namespace


FlagCheckedListBoxItem Constructor

FlagCheckedListBoxItem Constructor
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBoxItem Class : FlagCheckedListBoxItem Constructor

checkboxValue
caption

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal checkboxValue As Integer, _
   ByVal caption As String _
)
Visual Basic (Usage) Copy Code
Dim checkboxValue As Integer
Dim caption As String

Dim instance As FlagCheckedListBoxItem(checkboxValue, caption)
C#
public FlagCheckedListBoxItem(
   int checkboxValue,
   string caption
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal checkboxValue As Integer, _
   ByVal caption As String _
)
Visual Basic (Usage) Copy Code
Dim checkboxValue As Integer
Dim caption As String

Dim instance As FlagCheckedListBoxItem(checkboxValue, caption)
C#
public FlagCheckedListBoxItem(
   int checkboxValue,
   string caption
)

Parameters

checkboxValue
caption

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBoxItem Class
FlagCheckedListBoxItem Members

© 2002-2005, telerik. All Rights Reserved.


FlagCheckedListBoxItem Class Methods

FlagCheckedListBoxItem Class Methods
[image]
Telerik.WebControls.Design.Upload Namespace : FlagCheckedListBoxItem Class

For a list of all members of this type, see FlagCheckedListBoxItem members.

Public Methods

 | Name | Description
Public Method | IsMemberFlag |
Public Method | ToString | Overridden.
Top

See Also

Reference

FlagCheckedListBoxItem Class
Telerik.WebControls.Design.Upload Namespace


IsMemberFlag Method

IsMemberFlag Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBoxItem Class : IsMemberFlag Method

composite

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function IsMemberFlag( _
   ByVal composite As FlagCheckedListBoxItem _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBoxItem
Dim composite As FlagCheckedListBoxItem
Dim value As Boolean

value = instance.IsMemberFlag(composite)
C#
public bool IsMemberFlag(
   FlagCheckedListBoxItem composite
)

Parameters

composite

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBoxItem Class
FlagCheckedListBoxItem Members

© 2002-2005, telerik. All Rights Reserved.


ToString Method

ToString Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBoxItem Class : ToString Method

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBoxItem
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBoxItem Class
FlagCheckedListBoxItem Members

© 2002-2005, telerik. All Rights Reserved.


FlagCheckedListBoxItem Class Properties

FlagCheckedListBoxItem Class Properties
[image]
Telerik.WebControls.Design.Upload Namespace : FlagCheckedListBoxItem Class

For a list of all members of this type, see FlagCheckedListBoxItem members.

Public Properties

 | Name | Description
Public Property | IsFlag |
Top

See Also

Reference

FlagCheckedListBoxItem Class
Telerik.WebControls.Design.Upload Namespace


IsFlag Property

IsFlag Property
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBoxItem Class : IsFlag Property

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFlag As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBoxItem
Dim value As Boolean

value = instance.IsFlag
C#
public bool IsFlag {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBoxItem Class
FlagCheckedListBoxItem Members

© 2002-2005, telerik. All Rights Reserved.


FlagCheckedListBoxItem Class Fields

FlagCheckedListBoxItem Class Fields
[image]
Telerik.WebControls.Design.Upload Namespace : FlagCheckedListBoxItem Class

For a list of all members of this type, see FlagCheckedListBoxItem members.

Public Fields

 | Name | Description
Public Field | Caption |
Public Field | Value |
Top

See Also

Reference

FlagCheckedListBoxItem Class
Telerik.WebControls.Design.Upload Namespace


Caption Field

Caption Field
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBoxItem Class : Caption Field

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Caption As String
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBoxItem
Dim value As String

value = instance.Caption

instance.Caption = value
C#
public string Caption

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBoxItem Class
FlagCheckedListBoxItem Members

© 2002-2005, telerik. All Rights Reserved.


Value Field

Value Field
[image]
Telerik.WebControls.Design.Upload Namespace > FlagCheckedListBoxItem Class : Value Field

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Value As Integer
Visual Basic (Usage) Copy Code
Dim instance As FlagCheckedListBoxItem
Dim value As Integer

value = instance.Value

instance.Value = value
C#
public int Value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagCheckedListBoxItem Class
FlagCheckedListBoxItem Members

© 2002-2005, telerik. All Rights Reserved.


FlagEnumUIEditor Class

FlagEnumUIEditor Class
See Also Members
[image]
Telerik.WebControls.Design.Upload Namespace : FlagEnumUIEditor Class

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Class FlagEnumUIEditor
   Inherits UITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As FlagEnumUIEditor
C#
public class FlagEnumUIEditor : UITypeEditor

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
Telerik.WebControls.Design.Upload.FlagEnumUIEditor

Requirements

Namespace: Telerik.WebControls.Design.Upload

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

FlagEnumUIEditor Members
Telerik.WebControls.Design.Upload Namespace


FlagEnumUIEditor Class Members

FlagEnumUIEditor Class Members
See Also Properties Methods
[image]
Telerik.WebControls.Design.Upload Namespace : FlagEnumUIEditor Class

The following tables list the members exposed by FlagEnumUIEditor.

Public Constructors

 | Name | Description
Public Constructor | FlagEnumUIEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

FlagEnumUIEditor Class
Telerik.WebControls.Design.Upload Namespace


FlagEnumUIEditor Constructor

FlagEnumUIEditor Constructor
[image]
Telerik.WebControls.Design.Upload Namespace > FlagEnumUIEditor Class : FlagEnumUIEditor Constructor

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FlagEnumUIEditor()
C#
public FlagEnumUIEditor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FlagEnumUIEditor()
C#
public FlagEnumUIEditor()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagEnumUIEditor Class
FlagEnumUIEditor Members

© 2002-2005, telerik. All Rights Reserved.


FlagEnumUIEditor Class Methods

FlagEnumUIEditor Class Methods
[image]
Telerik.WebControls.Design.Upload Namespace : FlagEnumUIEditor Class

For a list of all members of this type, see FlagEnumUIEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

FlagEnumUIEditor Class
Telerik.WebControls.Design.Upload Namespace


EditValue Method

EditValue Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagEnumUIEditor Class : EditValue Method

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object) |
EditValue(IServiceProvider,Object) | (Inherited from System.Drawing.Design.UITypeEditor)

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object) |
EditValue(IServiceProvider,Object) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagEnumUIEditor Class
FlagEnumUIEditor Members

© 2002-2005, telerik. All Rights Reserved.


EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method
See Also
[image]
Telerik.WebControls.Design.Upload Namespace > FlagEnumUIEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

context
provider
itemValue

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceProvider, _
   ByVal itemValue As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As FlagEnumUIEditor
Dim context As ITypeDescriptorContext
Dim provider As IServiceProvider
Dim itemValue As Object
Dim value As Object

value = instance.EditValue(context, provider, itemValue)
C#
public override object EditValue(
   ITypeDescriptorContext context,
   IServiceProvider provider,
   object itemValue
)

Parameters

context
provider
itemValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagEnumUIEditor Class
FlagEnumUIEditor Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


GetEditStyle Method

GetEditStyle Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagEnumUIEditor Class : GetEditStyle Method

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | (Inherited from System.Drawing.Design.UITypeEditor)

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagEnumUIEditor Class
FlagEnumUIEditor Members

© 2002-2005, telerik. All Rights Reserved.


GetEditStyle(ITypeDescriptorContext) Method

GetEditStyle(ITypeDescriptorContext) Method
[image]
Telerik.WebControls.Design.Upload Namespace > FlagEnumUIEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

Namespace: Telerik.WebControls.Design.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As FlagEnumUIEditor
Dim context As ITypeDescriptorContext
Dim value As UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
)

Parameters

context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FlagEnumUIEditor Class
FlagEnumUIEditor Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


UploadedFileCollection Class

UploadedFileCollection Class
See Also Members
[image]
Telerik.WebControls.RadUploadUtils Namespace : UploadedFileCollection Class

Provides access to and organizes files uploaded by a client.

Object Model

Namespace: Telerik.WebControls.RadUploadUtils
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UploadedFileCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As UploadedFileCollection
C#
public sealed class UploadedFileCollection : CollectionBase

Remarks

Clients encode files and transmit them in the content body using multipart MIME format with an HTTP Content-Type header of multipart/form-data. RadUpload extracts the encoded file(s) from the content body into individual members of an UploadedFileCollection. Methods and properties of the UploadedFile class provide access to the contents and properties of each file.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.WebControls.RadUploadUtils.UploadedFileCollection

Requirements

Namespace: Telerik.WebControls.RadUploadUtils

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

UploadedFileCollection Members
Telerik.WebControls.RadUploadUtils Namespace


UploadedFileCollection Class Members

UploadedFileCollection Class Members
See Also Properties Methods
[image]
Telerik.WebControls.RadUploadUtils Namespace : UploadedFileCollection Class

The following tables list the members exposed by UploadedFileCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets an individual UploadedFile object from the file collection. In C#, this property is the indexer for the UploadedFileCollection class.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

UploadedFileCollection Class
Telerik.WebControls.RadUploadUtils Namespace


UploadedFileCollection Class Properties

UploadedFileCollection Class Properties
[image]
Telerik.WebControls.RadUploadUtils Namespace : UploadedFileCollection Class

For a list of all members of this type, see UploadedFileCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets an individual UploadedFile object from the file collection. In C#, this property is the indexer for the UploadedFileCollection class.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

UploadedFileCollection Class
Telerik.WebControls.RadUploadUtils Namespace


Item Property

Item Property
[image]
Telerik.WebControls.RadUploadUtils Namespace > UploadedFileCollection Class : Item Property

Gets an individual UploadedFile object from the file collection.

In C#, this property is the indexer for the UploadedFileCollection class.

Overload List

Overload | Description
Item(Int32) | Gets an individual UploadedFile object from the file collection. In C#, this property is the indexer for the UploadedFileCollection class.
Item(String) |

Overload List

Overload | Description
Item(Int32) | Gets an individual UploadedFile object from the file collection. In C#, this property is the indexer for the UploadedFileCollection class.
Item(String) |

Namespace: Telerik.WebControls.RadUploadUtils
Assembly: RadUpload (in RadUpload.dll)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFileCollection Class
UploadedFileCollection Members

© 2002-2005, telerik. All Rights Reserved.


Item(Int32) Property

Item(Int32) Property
See Also Example
[image]
Telerik.WebControls.RadUploadUtils Namespace > UploadedFileCollection Class > Item Property : Item(Int32) Property

index
The index of the item to get from the file collection.

Gets an individual UploadedFile object from the file collection.

In C#, this property is the indexer for the UploadedFileCollection class.

Namespace: Telerik.WebControls.RadUploadUtils
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As UploadedFile
Visual Basic (Usage) Copy Code
Dim instance As UploadedFileCollection
Dim index As Integer
Dim value As UploadedFile

value = instance.Item(index)
C#
public UploadedFile Item(
   int index
) {get;}

Parameters

index
The index of the item to get from the file collection.

Return Value

The UploadedFile specified by index.

Example

The following example retrieves the first file object (index = 0) from the collection sent by the client and retrieves the name of the actual file represented by the object.
Visual Basic Copy Code
Dim MyUploadedFile As UploadedFile = RadUpload1.UploadedFiles(0)
Dim MyFileName As String = UploadedFile.FileName
C# Copy Code
HttpPostedFile MyUploadedFile = RadUpload1.UploadedFiles[0];
String MyFileName = MyUploadedFile.FileName;

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFileCollection Class
UploadedFileCollection Members
Overload List
UploadedFile Class
UploadedFiles Property (Telerik.WebControls.RadUpload)
InvalidFiles Property (Telerik.WebControls.RadUpload)


Item(String) Property

Item(String) Property
[image]
Telerik.WebControls.RadUploadUtils Namespace > UploadedFileCollection Class > Item Property : Item(String) Property

id

Namespace: Telerik.WebControls.RadUploadUtils
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal id As String _
) As UploadedFile
Visual Basic (Usage) Copy Code
Dim instance As UploadedFileCollection
Dim id As String
Dim value As UploadedFile

value = instance.Item(id)
C#
public UploadedFile Item(
   string id
) {get;}

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UploadedFileCollection Class
UploadedFileCollection Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


Localization Class

Localization Class
See Also Members
[image]
Telerik.WebControls.Upload Namespace : Localization Class

Namespace: Telerik.WebControls.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Class Localization
Visual Basic (Usage) Copy Code
Dim instance As Localization
C#
public class Localization

Inheritance Hierarchy

System.Object
Telerik.WebControls.Upload.Localization

Requirements

Namespace: Telerik.WebControls.Upload

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

Localization Members
Telerik.WebControls.Upload Namespace

© 2002-2005, telerik. All Rights Reserved.


Localization Class Members

Localization Class Members
See Also Properties Methods
[image]
Telerik.WebControls.Upload Namespace : Localization Class

The following tables list the members exposed by Localization.

Public Constructors

 | Name | Description
Public Constructor | Localization Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Localization Class
Telerik.WebControls.Upload Namespace

© 2002-2005, telerik. All Rights Reserved.


Localization Constructor

Localization Constructor
[image]
Telerik.WebControls.Upload Namespace > Localization Class : Localization Constructor

Overload List

Overload | Description
Localization Constructor(String,String,String[]) |
Localization Constructor(XmlDocument) |

Namespace: Telerik.WebControls.Upload
Assembly: RadUpload (in RadUpload.dll)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Localization Class
Localization Members

© 2002-2005, telerik. All Rights Reserved.


Localization Constructor(String,String,String[])

Localization Constructor(String,String,String[])
See Also
[image]
Telerik.WebControls.Upload Namespace > Localization Class > Localization Constructor : Localization Constructor(String,String,String[])

language
path
files

Namespace: Telerik.WebControls.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal language As String, _
   ByVal path As String, _
   ByVal ParamArray files() As String _
)
Visual Basic (Usage) Copy Code
Dim language As String
Dim path As String
Dim files() As String

Dim instance As Localization(language, path, files)
C#
public Localization(
   string language,
   string path,
   params string[] files
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal language As String, _
   ByVal path As String, _
   ByVal ParamArray files() As String _
)
Visual Basic (Usage) Copy Code
Dim language As String
Dim path As String
Dim files() As String

Dim instance As Localization(language, path, files)
C#
public Localization(
   string language,
   string path,
   params string[] files
)

Parameters

language
path
files

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Localization Class
Localization Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


Localization Constructor(XmlDocument)

Localization Constructor(XmlDocument)
See Also
[image]
Telerik.WebControls.Upload Namespace > Localization Class > Localization Constructor : Localization Constructor(XmlDocument)

xml

Namespace: Telerik.WebControls.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal xml As XmlDocument _
)
Visual Basic (Usage) Copy Code
Dim xml As XmlDocument

Dim instance As Localization(xml)
C#
public Localization(
   XmlDocument xml
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal xml As XmlDocument _
)
Visual Basic (Usage) Copy Code
Dim xml As XmlDocument

Dim instance As Localization(xml)
C#
public Localization(
   XmlDocument xml
)

Parameters

xml

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Localization Class
Localization Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


Localization Class Methods

Localization Class Methods
[image]
Telerik.WebControls.Upload Namespace : Localization Class

For a list of all members of this type, see Localization members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Localization Class
Telerik.WebControls.Upload Namespace

© 2002-2005, telerik. All Rights Reserved.


ToString Method

ToString Method
[image]
Telerik.WebControls.Upload Namespace > Localization Class : ToString Method

Namespace: Telerik.WebControls.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Localization
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Localization Class
Localization Members

© 2002-2005, telerik. All Rights Reserved.


Localization Class Properties

Localization Class Properties
[image]
Telerik.WebControls.Upload Namespace : Localization Class

For a list of all members of this type, see Localization members.

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

Localization Class
Telerik.WebControls.Upload Namespace

© 2002-2005, telerik. All Rights Reserved.


Item Property

Item Property
[image]
Telerik.WebControls.Upload Namespace > Localization Class : Item Property

key

Namespace: Telerik.WebControls.Upload
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal key As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Localization
Dim key As String
Dim value As String

instance.Item(key) = value

value = instance.Item(key)
C#
public string this[
   string key
]; {get; set;}

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Localization Class
Localization Members

© 2002-2005, telerik. All Rights Reserved.


Get More Help

Telerik RadUpload v2.4 Send comments on this topic.
Get More Help

Glossary Item Box

In this manual you can find information in the following sections:

  • Getting started with Telerik RadUpload - a summary of the functionality together with some of the most important features.
  • Installation and Deployment - the steps you need to undertake before you start the real game with Telerik RadUpload.

Feedback

You can send us comments on any topic by clicking on the link "Send comments" in the top right corner of the page.

Alternatively, you can send an e-mail to documentation@telerik.com with feedback or inquiries concerning our manuals.

Additional resources of information

In case you cannot find the needed information in this manual, you can also review the following resources:

  • online Knowledge Base - visit http://www.telerik.com/KB/ and browse or search the articles for a solution to your problem;
  • Telerik product forums at http://www.telerik.com/Forums/ - consult with other people who use our products or use the built-in search on that page for existing resolutions.
  • live examples at http://www.telerik.com/Telerik RadControls for ASP.NET/ - use the left pane to navigate to the control and functionality you need. In the right pane, toggle among the various pages (Description, C#, ASPX, etc.) to learn about the functionality displayed.
  • contact Telerik support with a technical question using your Client.NET account at http://www.telerik.com/Default.aspx?PageId=2069.

Before you ask the support for cooperation, please make sure you have passed through all steps above.

© 2002-2008 Telerik. All Rights Reserved.


Glossary

Telerik RadUpload v2.4 Send comments on this topic.
Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

© 2002-2008 Telerik. All Rights Reserved.


Guidelines for Specifying Domain Names

Telerik RadUpload v2.4 Send comments on this topic.
Guidelines for Specifying Domain Names

Glossary Item Box

To create a License key you will need to know the IP and domain/machine name by which you plan to access the control, i.e.

http://123.123.123.123/MyApplication/

http://www.mysite.com/MyApplication/

http://MachineName/MyApplication/

If you plan to sue the control on localhost or 127.0.0.1 you do not need keys - the control will work properly, but a copyright message will be displayed occasionally.

The control checks the URL by which it is accessed and compares this URL to the IP and domain name encoded in the license key. If these do not match, a copyright message will be shown.

Entering domain/machine names

Use only top-level domain names. The control will work on all other subdomains. Do not enter prefixes like www or http://

Original URL | Right | Wrong
http://www.mysite.com | mysite.com | www.mysite.com http://www.mysite.com
http://mysite.com | mysite.com | http://mysite.com
http://support.mysite.com | mysite.com | support.mysite.com
http://mydomain/ | mydomain | http://mydomain
http://machinename/ | machinename | http://machinenam

In case of a complex country-specific domain name (like www.mysite.co.uk, www.mysite.org.bg) you need to enter the actual domain name (mysite) followed by the full extension (co.uk):

Original URL | Right | Wrong
http://www.mysite.co.uk | mysite.co.uk | http://www.mysite.co.uk
http://mysite.gov.tw | mysite.gov.tw | http://mysite.gov.tw
http://www.support.mysite.biz.nl | mysite.biz.nl | http://www.support.mysite.biz.nl

If the the domain/machine name is unknown, or if the control will be used on localhost, use localhost in the domain field when creating the keys.

Entering IPs

Use only the top-level IP address. The control will work on all subdomains and ports. Do not enter prefixes like www or http://

Original URL | Right | Wrong
http://123.123.123.123/ | 123.123.123.123 | http://123.123.123.123
http://123.123.123.123:8080/ | 123.123.123.123 | 123.123.123.123:8080 http://123.123.123.123 http:// 123.123.123.123:8080

Do not enter an IP for the live server (not the development server) in case it has a domain name.

Original URL | Right | Wrong
http://www.mysite.com | mysite.com | http://123.123.123.123

If you have a dynamic DNS/IP, then it would be best to access the control by a domain name, rather than IP. In this case, use 127.0.0.1 in the IP field when creating the keys.

If the IP is unknown, or if the control is to be used on localhost only, use 127.0.0.1 in the IP field when creating the keys.

Other Important Information

If you are behind a firewall, the license ley will still work, as only the URL is checked.

The key will work for the major version of the product it was created for. For example, if the key is created for Telerik RadUpload v2.x it will NOT work on another major version (such as v1.x).

Back to Setting License Keys.

© 2002-2008 Telerik. All Rights Reserved.


More About License

Telerik RadUpload v2.4 Send comments on this topic.
More About License

Glossary Item Box

The LicenseFiles are XML files, which contain the licensing information (Company and LicenseKey) for every component of the Telerik RadControls for ASP.NET web-suite. This approach is much more convenient than setting licensing information directly in the control's properties, especially when you use multiple components on multiple pages. In case you upgrade your component, or implement the same application on a different server (domain) you have to change the Company and LicenseKey information only once – in the LicenseFile. Every Telerik component is shipped with a LicenseFile.XML located in the "~/RadControls" subfolder of the web-application. The LicenseFile property is set by default to point to this file so all you have to do is enter the required properties in the file. Below is a sample LicenseFile.XML:

<root>

<license control="editor" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY1"/>
<license control="spell" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY2"/>
<license control="menu" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY3"/>

</root>

Please, note that you may use a single LicenseFile to unlock more than one Telerik components.

If you place trial and commercial key(s), Standard or Professional edition, the editor will use the commercial key(s).

Note:The values set in the LicenseKey and Company properties of the Telerik RadEditor tag will override the ones set in the LicenseFile. If you want to use the LicenseFile approach make sure you remove the LicenseKey and Company properties from the Telerik RadEditor tag.

© 2002-2008 Telerik. All Rights Reserved.


Support Options

Telerik RadUpload v2.4 Send comments on this topic.
Support Options

Glossary Item Box

© 2002-2008 Telerik. All Rights Reserved.


Get more help

Telerik RadUpload v2.4 Send comments on this topic.
Get more help

Glossary Item Box

In case you cannot find the needed information in this manual, you can also review the following resources:

  • online Knowledge Base - visit http://www.telerik.com/KB/ and browse or search the articles for a solution to your problem;
  • Telerik product forums at http://www.telerik.com/Forums/ - consult with other people who use our products;
    Use the in-built search on the page.
  • live examples at http://www.telerik.com/r.a.d.controls/ - use the left pane to navigate to the control and functionality you need. In the right pane, toggle among the various pages (Description, C#, ASPX, etc.) to learn about the functionality displayed.
  • online code library - visit http://www.telerik.com/community/code-library/default.aspx adn download a growing number of samples, get hands-on experience with the RadControls and submit some of your favorite implementations.
  • contact Telerik support with a technical question using your Client.NET account at http://www.telerik.com/Default.aspx?PageId=2069.

You can also send us comments on any topic by clicking on the link in the top right corner of the page:

The Send comments link

Alternatively, you can send an email to documentation@telerik.com with feedback or inquiries concerning our manuals.

© 2002-2008 Telerik. All Rights Reserved.


ProgressArea not shown using url authentication

Telerik RadUpload v2.4 Send comments on this topic.
ProgressArea not shown using url authentication

Glossary Item Box

SYMPTOMS

Having a web application configured to use URL-mode Forms authentication, when upload started the ProgressArea displays a message stating "Telerik RadUpload Ajax callback error. Source url returned invalid content:..."

CAUSE

The ProgressManager control makes AJAX calls to the Telerik.RadUploadProgressHandler.aspx handler, but the URL does not contain the Forms authentication ticket parameter. The .NET Framework executes the Login page instead of the RadUploadHttpHandler, which does not return a valid Telerik RadUpload AJAX result.

RESOLUTION

Add a location element to your web.config file, allowing all users to access the Telerik.RadUploadProgressHandler.aspx handler:

<configuration>
...
  <location path="Telerik.RadUploadProgressHandler.aspx">
    <system.web>
      <authorization>
        <allow users="*"/>
      </authorization>
    </system.web>
  </location>
...
</configuration>

© 2002-2008 Telerik. All Rights Reserved.


Assembly Overview

RadUpload Assembly

Namespaces

Namespace | Description
Telerik.WebControls |
Telerik.WebControls.Design.Upload |
Telerik.WebControls.RadUploadUtils |
Telerik.WebControls.Upload |


Getting Started - RadUpload

Getting Started

© 2002-2005, telerik. All Rights Reserved.


Introduction - RadUpload

Introduction

© 2002-2005, telerik. All Rights Reserved.


ControlObjectsVisibility Enumeration

ControlObjectsVisibility Enumeration
[image]
Telerik.WebControls Namespace : ControlObjectsVisibility Enumeration

Specifies which control objects will be visible on a RadUpload control.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Enum ControlObjectsVisibility
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ControlObjectsVisibility
C#
public enum ControlObjectsVisibility : Enum

Members

Member | Description
None | Only the file inputs will be visible.
CheckBoxes | Display checkboxes for selecting a file input.
RemoveButtons | Display buttons for removing a file input.
ClearButtons | Display buttons for clearing a file input.
AddButton | Display button for adding a file input.
DeleteSelectedButton | Display button for removing the file inputs with checked checkboxes.
Default | CheckBoxes | RemoveButtons | AddButton | DeleteSelectedButton
All | CheckBoxes | RemoveButtons | ClearButtons | AddButton | DeleteSelectedButton

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.ControlObjectsVisibility

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


FlagCheckedListBox Class Events

FlagCheckedListBox Class Events
[image]
Telerik.WebControls.Design.Upload Namespace : FlagCheckedListBox Class

For a list of all members of this type, see FlagCheckedListBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.CheckedListBox)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Format | (Inherited from System.Windows.Forms.ListControl)
Public Event | FormatInfoChanged | (Inherited from System.Windows.Forms.ListControl)
Public Event | FormatStringChanged | (Inherited from System.Windows.Forms.ListControl)
Public Event | FormattingEnabledChanged | (Inherited from System.Windows.Forms.ListControl)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | ItemCheck | (Inherited from System.Windows.Forms.CheckedListBox)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.CheckedListBox)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SelectedIndexChanged | (Inherited from System.Windows.Forms.ListBox)
Public Event | SelectedValueChanged | (Inherited from System.Windows.Forms.ListControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.ListBox)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

FlagCheckedListBox Class
Telerik.WebControls.Design.Upload Namespace


FlagEnumUIEditor Class Properties

FlagEnumUIEditor Class Properties
[image]
Telerik.WebControls.Design.Upload Namespace : FlagEnumUIEditor Class

For a list of all members of this type, see FlagEnumUIEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

FlagEnumUIEditor Class
Telerik.WebControls.Design.Upload Namespace


Telerik.WebControls.Design.Upload Namespace

Telerik.WebControls.Design.Upload Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
FlagCheckedListBox |
FlagCheckedListBoxItem |
FlagEnumUIEditor |

See Also

Reference

RadUpload Assembly

© 2002-2005, telerik. All Rights Reserved.


Telerik.WebControls.Design.Upload Namespace Inheritance Hierarchy

Telerik.WebControls.Design.Upload Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
Telerik.WebControls.Design.Upload.FlagEnumUIEditor
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ListBox
System.Windows.Forms.CheckedListBox
Telerik.WebControls.Design.Upload.FlagCheckedListBox
Telerik.WebControls.Design.Upload.FlagCheckedListBoxItem

See Also

Reference

RadUpload Assembly

© 2002-2005, telerik. All Rights Reserved.


ProgressIndicators Enumeration

ProgressIndicators Enumeration
[image]
Telerik.WebControls Namespace : ProgressIndicators Enumeration

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Enum ProgressIndicators
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ProgressIndicators
C#
public enum ProgressIndicators : Enum

Members

Member | Description
None |
TotalProgressBar |
TotalProgress |
TotalProgressPercent |
RequestSize |
FilesCountBar |
FilesCount |
FilesCountPercent |
SelectedFilesCount |
CurrentFileName |
TimeElapsed |
TimeEstimated |
TransferSpeed |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.ProgressIndicators

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


RadProgressArea Class Events

RadProgressArea Class Events
[image]
Telerik.WebControls Namespace : RadProgressArea Class

For a list of all members of this type, see RadProgressArea members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

Protected Events

 | Name | Description
Protected Event | RadControlsDirChanged | (Inherited from Telerik.RadUploadUtils.RadControl)
Top

See Also

Reference

RadProgressArea Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


CheckIfScriptsFolderExists Method

CheckIfScriptsFolderExists Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class : CheckIfScriptsFolderExists Method

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function CheckIfScriptsFolderExists() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As Boolean

value = instance.CheckIfScriptsFolderExists()
C#
protected bool CheckIfScriptsFolderExists()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


CheckWorkingConditions Method

CheckWorkingConditions Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class : CheckWorkingConditions Method

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Overload List

Overload | Description
CheckWorkingConditions(WorkingConditionFlags,String) | (Inherited from Telerik.RadUploadUtils.RadControl)
CheckWorkingConditions(String) | (Inherited from Telerik.RadUploadUtils.RadControl)

Overload List

Overload | Description
CheckWorkingConditions(WorkingConditionFlags,String) | (Inherited from Telerik.RadUploadUtils.RadControl)
CheckWorkingConditions(String) | (Inherited from Telerik.RadUploadUtils.RadControl)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


CheckWorkingConditions(String) Method

CheckWorkingConditions(String) Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class > CheckWorkingConditions Method : CheckWorkingConditions(String) Method

errorMessage

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Function CheckWorkingConditions( _
   ByRef errorMessage As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim errorMessage As String
Dim value As Boolean

value = instance.CheckWorkingConditions(errorMessage)
C#
protected bool CheckWorkingConditions(
   out string errorMessage
)

Parameters

errorMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


CheckWorkingConditions(WorkingConditionFlags,String) Method

CheckWorkingConditions(WorkingConditionFlags,String) Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class > CheckWorkingConditions Method : CheckWorkingConditions(WorkingConditionFlags,String) Method

workingConditionFlags
errorMessage

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Function CheckWorkingConditions( _
   ByVal workingConditionFlags As RadControl.WorkingConditionFlags, _
   ByRef errorMessage As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim workingConditionFlags As RadControl.WorkingConditionFlags
Dim errorMessage As String
Dim value As Boolean

value = instance.CheckWorkingConditions(workingConditionFlags, errorMessage)
C#
protected bool CheckWorkingConditions(
   RadControl.WorkingConditionFlags workingConditionFlags,
   out string errorMessage
)

Parameters

workingConditionFlags
errorMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


FormatControlMessage Method

FormatControlMessage Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class : FormatControlMessage Method

message
color
showVersion

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function FormatControlMessage( _
   ByVal message As String, _
   ByVal color As String, _
   ByVal showVersion As Boolean _
) As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim message As String
Dim color As String
Dim showVersion As Boolean
Dim value As String

value = instance.FormatControlMessage(message, color, showVersion)
C#
protected string FormatControlMessage(
   string message,
   string color,
   bool showVersion
)

Parameters

message
color
showVersion

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


IsRemoteUrl Method

IsRemoteUrl Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class : IsRemoteUrl Method

url

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function IsRemoteUrl( _
   ByVal url As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim url As String
Dim value As Boolean

value = instance.IsRemoteUrl(url)
C#
protected bool IsRemoteUrl(
   string url
)

Parameters

url

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


IsUsingWebResourceScripts Method

IsUsingWebResourceScripts Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class : IsUsingWebResourceScripts Method

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function IsUsingWebResourceScripts() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As Boolean

value = instance.IsUsingWebResourceScripts()
C#
protected bool IsUsingWebResourceScripts()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


Localization Property

Localization Property
See Also Example
[image]
Telerik.WebControls Namespace > RadProgressArea Class : Localization Property

Provides access to the localization strings of the control.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Localization As Localization
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As Localization

value = instance.Localization
C#
public Localization Localization {get;}

Return Value

Localization name/value collection.

Example

This example demonstrates how to change the localization strings of RadProgressArea object with code.
C# Copy Code
RadProgressArea1.Localization["CancelButton"] = "Cancel";
RadProgressArea1.Localization["TimeElapsed"] = "Elapsed time: ";
RadProgressArea1.Localization["TimeEstimated"] = "Estimated time: ";
RadProgressArea1.Localization["TransferSpeed"] = "Speed: ";
RadProgressArea1.Localization["CurrentFileName"] = "Uploading file: ";
RadProgressArea1.Localization["Uploaded"] = "Uploaded ";
RadProgressArea1.Localization["UploadedFiles"] = "Uploaded files: ";
RadProgressArea1.Localization["Total"] = "Total ";
RadProgressArea1.Localization["TotalFiles"] = "Total files: ";

Visual Basic Copy Code
RadProgressArea1.Localization("CancelButton") = "Cancel"
RadProgressArea1.Localization("TimeElapsed") = "Elapsed time: "
RadProgressArea1.Localization("TimeEstimated") = "Estimated time: "
RadProgressArea1.Localization("TransferSpeed") = "Speed: "
RadProgressArea1.Localization("CurrentFileName") = "Uploading file: "
RadProgressArea1.Localization("Uploaded") = "Uploaded "
RadProgressArea1.Localization("UploadedFiles") = "Uploaded files: "
RadProgressArea1.Localization("Total") = "Total "
RadProgressArea1.Localization("TotalFiles") = "Total files: "

Remarks

This property is intended to be used when there is a need to access the localization strings of the control from the code behind.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


LocalizationPath Property

LocalizationPath Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : LocalizationPath Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property LocalizationPath As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As String

instance.LocalizationPath = value

value = instance.LocalizationPath
C#
public virtual string LocalizationPath {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


LocalizationScript Property

LocalizationScript Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : LocalizationScript Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property LocalizationScript As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As String

value = instance.LocalizationScript
C#
protected virtual string LocalizationScript {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


OnPreRender Method

OnPreRender Method
[image]
Telerik.WebControls Namespace > RadProgressArea Class : OnPreRender Method

e

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPreRender( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim e As EventArgs

instance.OnPreRender(e)
C#
protected virtual void OnPreRender(
   EventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


RadControlsDirChanged Event

RadControlsDirChanged Event
[image]
Telerik.WebControls Namespace > RadProgressArea Class : RadControlsDirChanged Event

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Event RadControlsDirChanged() As RadControl.RadControlsDirChangedHandler
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim handler As RadControl.RadControlsDirChangedHandler

AddHandler instance.RadControlsDirChanged, handler
C#
protected event RadControl.RadControlsDirChangedHandler RadControlsDirChanged()

Syntax

Visual Basic (Declaration)
Protected Event RadControlsDirChanged() As RadControl.RadControlsDirChangedHandler
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim handler As RadControl.RadControlsDirChangedHandler

AddHandler instance.RadControlsDirChanged, handler
C#
protected event RadControl.RadControlsDirChangedHandler RadControlsDirChanged()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadProgressArea Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressArea
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressArea Class
RadProgressArea Members

© 2002-2005, telerik. All Rights Reserved.


RadProgressManager Class Events

RadProgressManager Class Events
[image]
Telerik.WebControls Namespace : RadProgressManager Class

For a list of all members of this type, see RadProgressManager members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

Protected Events

 | Name | Description
Protected Event | RadControlsDirChanged | (Inherited from Telerik.RadUploadUtils.RadControl)
Top

See Also

Reference

RadProgressManager Class
Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


CheckIfScriptsFolderExists Method

CheckIfScriptsFolderExists Method
[image]
Telerik.WebControls Namespace > RadProgressManager Class : CheckIfScriptsFolderExists Method

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function CheckIfScriptsFolderExists() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As Boolean

value = instance.CheckIfScriptsFolderExists()
C#
protected bool CheckIfScriptsFolderExists()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


CheckWorkingConditions Method

CheckWorkingConditions Method
[image]
Telerik.WebControls Namespace > RadProgressManager Class : CheckWorkingConditions Method

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Overload List

Overload | Description
CheckWorkingConditions(WorkingConditionFlags,String) | (Inherited from Telerik.RadUploadUtils.RadControl)
CheckWorkingConditions(String) | (Inherited from Telerik.RadUploadUtils.RadControl)

Overload List

Overload | Description
CheckWorkingConditions(WorkingConditionFlags,String) | (Inherited from Telerik.RadUploadUtils.RadControl)
CheckWorkingConditions(String) | (Inherited from Telerik.RadUploadUtils.RadControl)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


CheckWorkingConditions(String) Method

CheckWorkingConditions(String) Method
[image]
Telerik.WebControls Namespace > RadProgressManager Class > CheckWorkingConditions Method : CheckWorkingConditions(String) Method

errorMessage

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Function CheckWorkingConditions( _
   ByRef errorMessage As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim errorMessage As String
Dim value As Boolean

value = instance.CheckWorkingConditions(errorMessage)
C#
protected bool CheckWorkingConditions(
   out string errorMessage
)

Parameters

errorMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


CheckWorkingConditions(WorkingConditionFlags,String) Method

CheckWorkingConditions(WorkingConditionFlags,String) Method
[image]
Telerik.WebControls Namespace > RadProgressManager Class > CheckWorkingConditions Method : CheckWorkingConditions(WorkingConditionFlags,String) Method

workingConditionFlags
errorMessage

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Function CheckWorkingConditions( _
   ByVal workingConditionFlags As RadControl.WorkingConditionFlags, _
   ByRef errorMessage As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim workingConditionFlags As RadControl.WorkingConditionFlags
Dim errorMessage As String
Dim value As Boolean

value = instance.CheckWorkingConditions(workingConditionFlags, errorMessage)
C#
protected bool CheckWorkingConditions(
   RadControl.WorkingConditionFlags workingConditionFlags,
   out string errorMessage
)

Parameters

workingConditionFlags
errorMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


ControlCssFiles Property

ControlCssFiles Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : ControlCssFiles Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ControlCssFiles As String()
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value() As String

value = instance.ControlCssFiles
C#
protected virtual string[] ControlCssFiles {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


FormatControlMessage Method

FormatControlMessage Method
[image]
Telerik.WebControls Namespace > RadProgressManager Class : FormatControlMessage Method

message
color
showVersion

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function FormatControlMessage( _
   ByVal message As String, _
   ByVal color As String, _
   ByVal showVersion As Boolean _
) As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim message As String
Dim color As String
Dim showVersion As Boolean
Dim value As String

value = instance.FormatControlMessage(message, color, showVersion)
C#
protected string FormatControlMessage(
   string message,
   string color,
   bool showVersion
)

Parameters

message
color
showVersion

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


IsRemoteUrl Method

IsRemoteUrl Method
[image]
Telerik.WebControls Namespace > RadProgressManager Class : IsRemoteUrl Method

url

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function IsRemoteUrl( _
   ByVal url As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim url As String
Dim value As Boolean

value = instance.IsRemoteUrl(url)
C#
protected bool IsRemoteUrl(
   string url
)

Parameters

url

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


IsUsingWebResourceScripts Method

IsUsingWebResourceScripts Method
[image]
Telerik.WebControls Namespace > RadProgressManager Class : IsUsingWebResourceScripts Method

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function IsUsingWebResourceScripts() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As Boolean

value = instance.IsUsingWebResourceScripts()
C#
protected bool IsUsingWebResourceScripts()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


LocalizationLanguage Property

LocalizationLanguage Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : LocalizationLanguage Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property LocalizationLanguage As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As String

value = instance.LocalizationLanguage
C#
protected virtual string LocalizationLanguage {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


LocalizationScript Property

LocalizationScript Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : LocalizationScript Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property LocalizationScript As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As String

value = instance.LocalizationScript
C#
protected virtual string LocalizationScript {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


RadControlsDirChanged Event

RadControlsDirChanged Event
[image]
Telerik.WebControls Namespace > RadProgressManager Class : RadControlsDirChanged Event

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Event RadControlsDirChanged() As RadControl.RadControlsDirChangedHandler
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim handler As RadControl.RadControlsDirChangedHandler

AddHandler instance.RadControlsDirChanged, handler
C#
protected event RadControl.RadControlsDirChangedHandler RadControlsDirChanged()

Syntax

Visual Basic (Declaration)
Protected Event RadControlsDirChanged() As RadControl.RadControlsDirChangedHandler
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim handler As RadControl.RadControlsDirChangedHandler

AddHandler instance.RadControlsDirChanged, handler
C#
protected event RadControl.RadControlsDirChangedHandler RadControlsDirChanged()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadProgressManager Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadProgressManager
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadProgressManager Class
RadProgressManager Members

© 2002-2005, telerik. All Rights Reserved.


UploadedFileCollection Class Methods

UploadedFileCollection Class Methods
[image]
Telerik.WebControls.RadUploadUtils Namespace : UploadedFileCollection Class

For a list of all members of this type, see UploadedFileCollection members.

Public Methods

 | Name | Description
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

UploadedFileCollection Class
Telerik.WebControls.RadUploadUtils Namespace


Telerik.WebControls.RadUploadUtils Namespace

Telerik.WebControls.RadUploadUtils Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
UploadedFileCollection | Provides access to and organizes files uploaded by a client.

See Also

Reference

RadUpload Assembly

© 2002-2005, telerik. All Rights Reserved.


Telerik.WebControls.RadUploadUtils Namespace Inheritance Hierarchy

Telerik.WebControls.RadUploadUtils Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.WebControls.RadUploadUtils.UploadedFileCollection

See Also

Reference

RadUpload Assembly

© 2002-2005, telerik. All Rights Reserved.


CheckIfScriptsFolderExists Method

CheckIfScriptsFolderExists Method
[image]
Telerik.WebControls Namespace > RadUpload Class : CheckIfScriptsFolderExists Method

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function CheckIfScriptsFolderExists() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Boolean

value = instance.CheckIfScriptsFolderExists()
C#
protected bool CheckIfScriptsFolderExists()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


CheckWorkingConditions Method

CheckWorkingConditions Method
[image]
Telerik.WebControls Namespace > RadUpload Class : CheckWorkingConditions Method

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Overload List

Overload | Description
CheckWorkingConditions(WorkingConditionFlags,String) | (Inherited from Telerik.RadUploadUtils.RadControl)
CheckWorkingConditions(String) | (Inherited from Telerik.RadUploadUtils.RadControl)

Overload List

Overload | Description
CheckWorkingConditions(WorkingConditionFlags,String) | (Inherited from Telerik.RadUploadUtils.RadControl)
CheckWorkingConditions(String) | (Inherited from Telerik.RadUploadUtils.RadControl)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


CheckWorkingConditions(String) Method

CheckWorkingConditions(String) Method
[image]
Telerik.WebControls Namespace > RadUpload Class > CheckWorkingConditions Method : CheckWorkingConditions(String) Method

errorMessage

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Function CheckWorkingConditions( _
   ByRef errorMessage As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim errorMessage As String
Dim value As Boolean

value = instance.CheckWorkingConditions(errorMessage)
C#
protected bool CheckWorkingConditions(
   out string errorMessage
)

Parameters

errorMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


CheckWorkingConditions(WorkingConditionFlags,String) Method

CheckWorkingConditions(WorkingConditionFlags,String) Method
[image]
Telerik.WebControls Namespace > RadUpload Class > CheckWorkingConditions Method : CheckWorkingConditions(WorkingConditionFlags,String) Method

workingConditionFlags
errorMessage

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Overloads Protected Function CheckWorkingConditions( _
   ByVal workingConditionFlags As RadControl.WorkingConditionFlags, _
   ByRef errorMessage As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim workingConditionFlags As RadControl.WorkingConditionFlags
Dim errorMessage As String
Dim value As Boolean

value = instance.CheckWorkingConditions(workingConditionFlags, errorMessage)
C#
protected bool CheckWorkingConditions(
   RadControl.WorkingConditionFlags workingConditionFlags,
   out string errorMessage
)

Parameters

workingConditionFlags
errorMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members
Overload List

© 2002-2005, telerik. All Rights Reserved.


FormatControlMessage Method

FormatControlMessage Method
[image]
Telerik.WebControls Namespace > RadUpload Class : FormatControlMessage Method

message
color
showVersion

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function FormatControlMessage( _
   ByVal message As String, _
   ByVal color As String, _
   ByVal showVersion As Boolean _
) As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim message As String
Dim color As String
Dim showVersion As Boolean
Dim value As String

value = instance.FormatControlMessage(message, color, showVersion)
C#
protected string FormatControlMessage(
   string message,
   string color,
   bool showVersion
)

Parameters

message
color
showVersion

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


IsRemoteUrl Method

IsRemoteUrl Method
[image]
Telerik.WebControls Namespace > RadUpload Class : IsRemoteUrl Method

url

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function IsRemoteUrl( _
   ByVal url As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim url As String
Dim value As Boolean

value = instance.IsRemoteUrl(url)
C#
protected bool IsRemoteUrl(
   string url
)

Parameters

url

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


IsUsingWebResourceScripts Method

IsUsingWebResourceScripts Method
[image]
Telerik.WebControls Namespace > RadUpload Class : IsUsingWebResourceScripts Method

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Function IsUsingWebResourceScripts() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Boolean

value = instance.IsUsingWebResourceScripts()
C#
protected bool IsUsingWebResourceScripts()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


Localization Property

Localization Property
See Also Example
[image]
Telerik.WebControls Namespace > RadUpload Class : Localization Property

Provides access to the localization strings of the control.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Localization As Localization
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Localization

value = instance.Localization
C#
public Localization Localization {get;}

Return Value

Localization name/value collection.

Example

This example demonstrates how to change the localization strings of RadProgressArea object with code.
C# Copy Code
RadProgressArea1.Localization["CancelButton"] = "Cancel";
RadProgressArea1.Localization["TimeElapsed"] = "Elapsed time: ";
RadProgressArea1.Localization["TimeEstimated"] = "Estimated time: ";
RadProgressArea1.Localization["TransferSpeed"] = "Speed: ";
RadProgressArea1.Localization["CurrentFileName"] = "Uploading file: ";
RadProgressArea1.Localization["Uploaded"] = "Uploaded ";
RadProgressArea1.Localization["UploadedFiles"] = "Uploaded files: ";
RadProgressArea1.Localization["Total"] = "Total ";
RadProgressArea1.Localization["TotalFiles"] = "Total files: ";

Visual Basic Copy Code
RadProgressArea1.Localization("CancelButton") = "Cancel"
RadProgressArea1.Localization("TimeElapsed") = "Elapsed time: "
RadProgressArea1.Localization("TimeEstimated") = "Estimated time: "
RadProgressArea1.Localization("TransferSpeed") = "Speed: "
RadProgressArea1.Localization("CurrentFileName") = "Uploading file: "
RadProgressArea1.Localization("Uploaded") = "Uploaded "
RadProgressArea1.Localization("UploadedFiles") = "Uploaded files: "
RadProgressArea1.Localization("Total") = "Total "
RadProgressArea1.Localization("TotalFiles") = "Total files: "

Remarks

This property is intended to be used when there is a need to access the localization strings of the control from the code behind.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


LocalizationPath Property

LocalizationPath Property
[image]
Telerik.WebControls Namespace > RadUpload Class : LocalizationPath Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property LocalizationPath As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.LocalizationPath = value

value = instance.LocalizationPath
C#
public virtual string LocalizationPath {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


OnPreRender Method

OnPreRender Method
[image]
Telerik.WebControls Namespace > RadUpload Class : OnPreRender Method

e

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPreRender( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim e As EventArgs

instance.OnPreRender(e)
C#
protected virtual void OnPreRender(
   EventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadUpload Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


RadControlsDirChanged Event

RadControlsDirChanged Event
[image]
Telerik.WebControls Namespace > RadUpload Class : RadControlsDirChanged Event

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Protected Event RadControlsDirChanged() As RadControl.RadControlsDirChangedHandler
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As RadControl.RadControlsDirChangedHandler

AddHandler instance.RadControlsDirChanged, handler
C#
protected event RadControl.RadControlsDirChangedHandler RadControlsDirChanged()

Syntax

Visual Basic (Declaration)
Protected Event RadControlsDirChanged() As RadControl.RadControlsDirChangedHandler
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim handler As RadControl.RadControlsDirChangedHandler

AddHandler instance.RadControlsDirChanged, handler
C#
protected event RadControl.RadControlsDirChangedHandler RadControlsDirChanged()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


SkinsPath Property

SkinsPath Property
[image]
Telerik.WebControls Namespace > RadUpload Class : SkinsPath Property

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinsPath As String
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As String

instance.SkinsPath = value

value = instance.SkinsPath
C#
public virtual string SkinsPath {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadUpload Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadUpload
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadUpload Class
RadUpload Members

© 2002-2005, telerik. All Rights Reserved.


Telerik.WebControls.Upload Namespace

Telerik.WebControls.Upload Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
Localization |

See Also

Reference

RadUpload Assembly

© 2002-2005, telerik. All Rights Reserved.


Telerik.WebControls.Upload Namespace Inheritance Hierarchy

Telerik.WebControls.Upload Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
Telerik.WebControls.Upload.Localization

See Also

Reference

RadUpload Assembly

© 2002-2005, telerik. All Rights Reserved.


UploadedFileEventHandler Delegate

UploadedFileEventHandler Delegate
[image]
Telerik.WebControls Namespace : UploadedFileEventHandler Delegate

sender
The RadUpload instance which fired the event.
e
An UploadedFileEventArgs that contain the event data.
Represents the method that will handle the event that has an UploadedFileEventArgs event data.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub UploadedFileEventHandler( _
   ByVal sender As Object, _
   ByVal e As UploadedFileEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New UploadedFileEventHandler(AddressOf HandlerMethod)
C#
public delegate void UploadedFileEventHandler(
   object sender,
   UploadedFileEventArgs e
)

Parameters

sender
The RadUpload instance which fired the event.
e
An UploadedFileEventArgs that contain the event data.

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


ValidateFileEventHandler Delegate

ValidateFileEventHandler Delegate
[image]
Telerik.WebControls Namespace : ValidateFileEventHandler Delegate

sender
The RadUpload instance which fired the event.
e
A ValidateFileEventArgs that contain the event data.

Represents the method that will handle the custom validation event.

Namespace: Telerik.WebControls
Assembly: RadUpload (in RadUpload.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub ValidateFileEventHandler( _
   ByVal sender As Object, _
   ByVal e As ValidateFileEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ValidateFileEventHandler(AddressOf HandlerMethod)
C#
public delegate void ValidateFileEventHandler(
   object sender,
   ValidateFileEventArgs e
)

Parameters

sender
The RadUpload instance which fired the event.
e
A ValidateFileEventArgs that contain the event data.

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadUpload (in RadUpload.dll)

See Also

Reference

Telerik.WebControls Namespace

© 2002-2005, telerik. All Rights Reserved.


Telerik.WebControls Namespace

Telerik.WebControls Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
RadProgressArea |
RadProgressContext |
RadProgressManager |
RadUpload | A composite control, allowing you to upload a single or multiple files. The /// RadUpload control allows you to define the number of files to be uploaded, progress display, skin, etc.
RadUploadContext |
UploadedFile | Provides a way to access individual files that have been uploaded by a client via a RadUpload control.
UploadedFileEventArgs | UploadedFileEventArgs is the base class for the RadUpload event data.
ValidateFileEventArgs | Provides data for the ValidatingFile event of the RadUpload control.

Delegates

Delegate | Description
UploadedFileEventHandler | Represents the method that will handle the event that has an UploadedFileEventArgs event data.
ValidateFileEventHandler | Represents the method that will handle the custom validation event.

Enumerations

Enumeration | Description
ControlObjectsVisibility | Specifies which control objects will be visible on a RadUpload control.
ProgressIndicators |

See Also

Reference

RadUpload Assembly

© 2002-2005, telerik. All Rights Reserved.


Telerik.WebControls Namespace Inheritance Hierarchy

Telerik.WebControls Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.WebControls.UploadedFileEventArgs
Telerik.WebControls.ValidateFileEventArgs
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadUploadUtils.RadControl
Telerik.RadUploadUtils.RadSkinnableControl
Telerik.RadUploadUtils.RadLocalizableControl
Telerik.WebControls.RadProgressArea
Telerik.WebControls.RadUpload
Telerik.WebControls.RadProgressManager
Telerik.WebControls.RadProgressContext
Telerik.WebControls.RadUploadContext
Telerik.WebControls.UploadedFile

See Also

Reference

RadUpload Assembly

© 2002-2005, telerik. All Rights Reserved.