At a glance

Telerik RadSplitter v1.3 Send comments on this topic.
At a glance

Glossary Item Box

New major version of RadSplitter is now available as a part of RadControls “Prometheus” for ASP.NET. Its new architecture is based on top the ASP.NET AJAX framework in order to directly benefit from client-side behaviors and capabilities. We strongly recommend using the new version for all new development.

Thank you for choosing Telerik RadSplitter!

Telerik RadSplitter is a very flexible UI component for ASP.NET applications which allows users to manage effectively the size and the layout of your page content.

Browser Support

Telerik RadSplitter supports all major browsers and platforms (both on PC and Mac, where applicable):

  • Internet Explorer 5.5+;
  • all Gecko-based browsers - Mozilla 1.0+, FireFox, Netscape 7+;
  • Opera 8.0+.
  • Safari 1.2+

Key Features

  • Any table layout support.
  • Cross browser compatible.
  • XHTML 1.1 compliant.
  • Horizontal or Vertical Orientation. Nest splitters to get any orientation combination!
  • Content Resizing. Drag a split bar to resize the content of the panes! You can define min/max size and resize step.
  • Pane Collapsing / Expanding. Click the collapse buttons on a split bar to collapse/expand its adjacent panes!
  • External Content support. Load any URL in any pane!
  • Content Printing. Use the client-side API to print the content of any pane!
  • State Persistence. RadSplitter will persist its state and scroller positions across postbacks!
  • Resizing with the browser and ability to fill its container automatically!
  • Sliding Panes. Add sliding zones and panes to simulate the Visual Studio user interface!
  • Ajax/Atlas compatible. Add/Remove/Update splitter elements with asynchronous requests to remove the flicker completely!

Defining the Splitter Structure

You can define the structure of RadSplitter in two ways:
  • Declaratively in the ASPX page (as in the example below)
  • Programatically in the code-behind

The visual appearance of RadSplitter is controlled by using Skins.

© 2002-2008 Telerik. All Rights Reserved.


What's New

Telerik RadSplitter v1.3 Send comments on this topic.
What's New

Glossary Item Box

New major version of RadSplitter is now available as a part of RadControls “Prometheus” for ASP.NET. Its new architecture is based on top the ASP.NET AJAX framework in order to directly benefit from client-side behaviors and capabilities. We strongly recommend using the new version for all new development.

What's new in Telerik RadSplitter v1.2

The current version features numerous bug fixes and performance optimizations.

© 2002-2008 Telerik. All Rights Reserved.


Which license should I use or purchase

Telerik RadSplitter v1.3 Send comments on this topic.
Which license should I use or purchase
See Also
Licensing > Which license should I use or purchase

Glossary Item Box

Telerik offers several different packages for you to choose from:

Trial licenses

Description

If you are a first-time Telerik user, it would be best to create an account in our Client.NET extranet (www.telerik.com/Clientnet) and download a Trial license. The Trial licenses are fully-functional and are identical in functionality to the paid versions. Review the Which file do I need to install? section for further instructions.

Support

A trial license comes with the Bronze Support package, which guarantees a 72-hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used. Mail queries usually take longer to respond.

For more information, review the available Support Options.

Single Developer licenses

Description

A Developer license is granted per developer seat: one developer is allowed to work with the product per license. Developer licenses have no run-time limitations and allow the usage of all Telerik controls in an UNLIMITED number of custom web applications. The controls can be installed on more than one machine as long as only the licensed developer is using the product.

License Keys

Developer licenses come with special builds that work without keys and allow the developer to safely access web applications that use Telerik products. To update your application from a trial license to a Developer license, please review the instructions in the following section: Trial License v1.x to Developer License v1.x

Support

The Single Developer license comes with the Silver Support package which guarantees a 48 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used.
Mail queries usually take longer to respond.

For more information, review the available Support Options.

Single Developer Subscription license

Description

Unlike the Single Developer license, Single Developer Subscription license offers a Subscription. A Subscription license entitles you to receive, for free, all released updates and new products for the duration of one year from the date of purchase. This license is the easiest and most cost-effective way to ensure that you are using the latest versions of our products. With the Subscription license you save more than 70% on Telerik products if purchased separately.

The Single Developer Subscription license is offered for the Telerik RadControls for ASP.NET suite only. Subscriptions are not available for individual products at this time.

You can renew your subscription at approximately 50% of the original price. You will be promptly notified when the Subscription license is about to expire.

All RadControls for ASP.NET subscription holders are entitled to a license to RadControls "Prometheus" suite.

License Keys

The Developer license comes with a special build that work without keys and allow the developer to safely access web applications that use Telerik products. To update your application from Trial to a Developer license, please review the instructions in the following section: Trial License v1.x to Developer License v1.x

Support

The Single Developer Subscription license comes with the Gold Support package which guarantees a 24 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used.
Mail queries usually take longer to respond.

For more information, review the available Support Options.

Telerik maintains a public Product Roadmap, which will give you details on the upcoming products and versions for the next quarter. This guarantees that you see a good return on your investment in the Subscription license.

Source Code license

Description

The Source Code license is an excellent investment if you need to customize our controls to fit a specific requirement, or if your company wishes to own the source code for all products used.

A Source Code license is offered with purchases of five or more Single Developer or Single Developer Subscription licenses for Telerik RadControls for ASP.NET suite. If you have opted for the Subscription license, you will be receiving the source codes for all products released within one year from the date of purchase.

Source Code licenses are offered for the Telerik RadControls for ASP.NET suite only and are not available for individual products at this time.

Support

The Source Code license comes with the Gold Support package, which guarantees a 24 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used. All questions from Source code licensees are treated with priority.

For more information, review the available Support Options.

Custom Source Code modifications are not supported by Telerik.

Discounts Offered

Telerik offers the following volume discounts on all licenses:

  • 3 to 4 licenses - 10%
  • 5 to 9 licenses - 20%
  • 10 to 19 licenses - 30%
  • 20 or more - 40%

Telerik also offers discounts to qualified educational, non-profit, charity and government entities. For more information on how to qualify for a discount, visit our Special pricing page.

See Also

Sales FAQ page
Purchase Online
Support Options
Support FAQ
Client.Net FAQ
License Agreement

© 2002-2008 Telerik. All Rights Reserved.


License Agreement

Telerik RadSplitter v1.3 Send comments on this topic.
License Agreement
Licensing > License Agreement

Glossary Item Box

Telerik End-User License Agreement

By purchasing, installing, or otherwise using the product identified above and/or its related materials, you agree to be bound by the terms and conditions of this License Agreement. Check the box "I have read and agree to the License Agreement" if you agree.

IMPORTANT – READ CAREFULLY: This license agreement ("LICENSE") is a legal agreement between you (either an individual or a single entity, also referred to as "LICENSEE", "YOU") and Telerik Corp., ("TELERIK"), for the software containing this LICENSE which may also include the software’s source code written in a high-level computer language, associated media, printed materials, and "online" or electronic documentation (collectively referred to as “SOFTWARE”).

Any earlier license we may have granted to you for the use of earlier versions of the SOFTWARE is replaced by this LICENSE.

SOFTWARE PRODUCT LICENSE

The SOFTWARE is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties and contains confidential information and trade secrets. TELERIK retains all rights not expressly granted to you in this LICENSE.

I. GRANT OF LICENSE

TELERIK hereby grants to you, and you accept, a non-exclusive, non-transferable license to install, copy, use and modify the SOFTWARE only as authorized below.

This license grants you no rights to the "2007 Microsoft Office System User Interface". For appropriate license, please, contact Microsoft directly.

1. TRIAL LICENSE

You are granted a license for evaluation purposes only. You are authorized to install, copy, and use the SOFTWARE for the sole purpose of testing its functionality. You are not allowed to integrate it in end products or use it for any commercial purpose.

2. DEVELOPER LICENSE

The SOFTWARE is licensed per Developer seat. This means that each individual using or otherwise accessing the SOFTWARE for development purposes must obtain the right to do so by purchasing an individual product license.

You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same licensed developer. The SOFTWARE is in "use" on a computer when it is loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard disk or other storage device) of that computer for development purposes. If you install the SOFTWARE on a network server for the sole purpose of internal distribution among licensed developers this is not considered “use” of the SOFTWARE.

2-1. Redistribution rights:

All product licenses are perpetual and royalty-free. You can ship the SOFTWARE as part of solutions for internal company use, hosted applications, commercial solutions deployed at end-users’ sites or shrink-wrapped software (PACKAGED PRODUCTS) in which the SOFTWARE is integrated.

You may distribute the SOFTWARE provided that:

  • You reasonably ensure that the SOFTWARE is not distributed in any form that allows it to be reused by any application other than your solution. Technical guidelines will be provided upon request, please contact support@telerik.com for more details.
  • You need to duly inform your customers that they are not allowed to use the SOFTWARE independently from your solution. For use of the SOFTWARE in design-time (i.e. within a development environment such as Microsoft Visual Studio) your customers need to purchase the appropriate number of Developer Licenses from TELERIK.
  • You need to include a valid copyright message in your solution in a location viewable by the end-users (e.g. "About" box).

2-2. Silver Support:

As part of your license you are entitled to "Silver" Support Package which guarantees response within 48 hours.

3. DEVELOPER LICENSE PLUS SUBSCRIPTION AND SOURCE CODE LICENSE

You are granted 1 (one) Developer License as defined above. In addition you are entitled to a 1 Year Subscription, Source Code and Gold Support Package.

3-1. Subscription

You are entitled to receive all version updates for the SOFTWARE for a period of 1 (one) year.

  • 3-2. Source Code

    As part of the DEVELOPER PLUS SUBSCRIPTION AND SOURCE CODE LICENSE you are granted the right to view and modify the SOFTWARE's source code only as authorized below:
  • The SOFTWARE's source code is provided to the licensed developer for the sole purposes of education and troubleshooting. The SOFTWARE's source code cannot be used as a basis of development of derivative works or other software products.
  • Under no circumstances may any portion of the SOFTWARE’s source code or any modified version of the source code be distributed, disclosed or otherwise made available to any third party.
  • TELERIK DOES NOT provide technical support for modified source code.
  • The SOFTWARE’s source code is provided as is. Refunds are not available for licenses that include source code.
  • In the event you develop any troubleshooting-related modifications of the SOFTWARE, either independently or jointly with TELERIK, such modifications and all rights associated therewith will be the exclusive property of TELERIK. You are granted the right to use such modifications as set forth in this agreement.
  • You acknowledge that the SOFTWARE’s source code contains valuable and proprietary trade secrets of TELERIK. All individuals employed by or belonging to your entity agree to expend every effort to insure its confidentiality. You agree to assume full responsibility for such employees’ or contractors’ use, or misuse, of such disclosed source code as if it was your use. These obligations shall not apply to any information generally available to the public, independently developed or obtained without reliance on TELERIK information, or approved in writing for release by TELERIK without restriction.

3-3. Gold Support:

As part of your license you are entitled to "Gold" Support Package which guarantees response within 24 hours.

II. OTHER RIGHTS AND LIMITATIONS

  • At no time may the SOFTWARE be used for development purposes by other individuals than the licensed developer(s).
  • The SOFTWARE may not be distributed for use with solutions or PACKAGED PRODUCTS other than those developed by you.
  • The SOFTWARE may not be distributed part of products that have the same or substantially the same primary functionality. (Example for RadControls for ASP.NET: you may purchase Telerik RadEditor for ASP.NET and create a blog application/component. However, you cannot wrap RadMenu and offer it as a SharePoint WebPart or DNN menu skin object, since its primary functionality would be substantially the same as the SOFTWARE.
  • You are not allowed to resell, transfer, rent, lease, or sublicense the SOFTWARE and your associated rights. Under no circumstances shall you grant further redistribution rights to the end-users of your solution.
  • You may not use the TELERIK product names, logos or trademarks to market YOUR SOFTWARE.
  • You are not allowed to disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.
  • You are not allowed to use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.
  • You agree to indemnify, hold harmless, and defend TELERIK and its resellers from and against any and all claims or lawsuits including attorney's fees that arise or result from the use or distribution of YOUR SOFTWARE

III. DELIVERY

TELERIK shall deliver to LICENSEE a master copy of the SOFTWARE licensed hereunder in electronic files only. Documentation shall also be provided in electronic format.

IV. UPGRADES

You are eligible for free minor upgrades (e.g. v.1.5 to v.1.8), patches, and bug-fixes for the SOFTWARE, including source code if applicable. SOFTWARE labeled as an upgrade replaces and/or supplements (and may disable) the product that formed the basis for your eligibility for the upgrade. You may use the resulting upgraded product only in accordance with the terms of this LICENSE.

If you have purchased a "DEVELOPER PLUS SUBSCRIPTION AND SOURCE CODE LICENSE” you are entitled to receive all version updates for the SOFTWARE period of 1 (one) year.

V. TERMINATION

This LICENSE shall last as long as you use the SOFTWARE in compliance with this LICENSE. TELERIK may terminate this LICENSE if you fail to comply with any of the terms and conditions herein. In such event you agree to remove and destroy all copies of the SOFTWARE and any applicable source code.

TELERIK reserves the right to discontinue at any time any product, shall it be offered individually or as a part of a product SUITE. However, TELERIK is obligated to provide the proper level of support for all discontinued products for a period of 1 (one) year after the date of discontinuance.

VI. COPYRIGHT

All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animations, video, audio, music, text, incorporated into the SOFTWARE), the accompanying printed materials, and any copies of the SOFTWARE, and any trademarks or service marks of TELERIK are owned by TELERIK. All title and intellectual property rights in and to the content that may be accessed through use of the SOFTWARE is the property of the respective content owner and may be protected by applicable copyright or other intellectual property laws and treaties. This LICENSE grants you no rights to use such content.

VII. LIMITED WARRANTY

TELERIK warrants solely that the SOFTWARE will perform substantially in accordance with the accompanying written materials for a period of ninety (90) days. TELERIK does not warrant the use of the SOFTWARE will be uninterrupted or error free at all times and in all circumstances, nor that program errors will be corrected. This limited warranty shall not apply to any error or failure resulting from (i) machine error, (ii) LICENSEE's failure to follow operating instructions, (iii) negligence or accident, or (iv) modifications to the SOFTWARE by any person or entity other than TELERIK. In the event of a breach of warranty, LICENSEE 's sole and exclusive remedy, is repair of all or any portion of the SOFTWARE. If such remedy fails of its essential purpose, LICENSEE 's sole remedy and TELERIK's maximum liability shall be a refund of the paid purchase price for the defective SOFTWARE only. This limited warranty is only valid if TELERIK receives written notice of breach of warranty within thirty days after the warranty period expires.

VIII. LIMITATION OF LIABILITY

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT WILL TELERIK BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OF OR INABILITY TO USE THE PRODUCT, INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF, AND REGARDLESS OF THE LEGAL OR EQUITABLE THEORY (CONTRACT, TORT OR OTHERWISE) UPON WHICH THE CLAIM IS BASED. IN ANY CASE, TELERIK'S ENTIRE LIABILITY UNDER ANY PROVISION OF THIS AGREEMENT SHALL NOT EXCEED IN THE AGGREGATE THE SUM OF THE LICENSE FEES LICENSEE PAID TO TELERIK FOR THE PRODUCT GIVING RISE TO SUCH DAMAGES, NOTWITHSTANDING ANY FAILURE OF ESSENTIAL PURPOSE OF ANY LIMITED REMEDY. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS EXCLUSION AND LIMITATION MAY NOT BE APPLICABLE. TELERIK IS NOT RESPONSIBLE FOR ANY LIABILITY ARISING OUT OF CONTENT PROVIDED BY LICENSEE OR A THIRD PARTY THAT IS ACCESSED THROUGH THE PRODUCT AND/OR ANY MATERIAL LINKED THROUGH SUCH CONTENT. ANY DATA INCLUDED IN A PRODUCT UPON SHIPMENT FROM TELERIK IS FOR TESTING USE ONLY AND TELERIK HEREBY DISCLAIMS ANY AND ALL LIABILITY ARISING THEREFROM. THE EXTENT OF TELERIK'S LIABILITY FOR THE LIMITED WARRANTY SECTION SHALL BE AS SET FORTH THEREIN.

IX. MISCELLANEOUS

This License will be governed by the law of the State of Massachusetts, U.S.A. If any provision of this LICENSE is to be held unenforceable, such holding will not affect the validity of the other provisions hereof. Failure of a party to enforce any provision of this LICENSE shall not constitute or be construed as a waiver of such provision or of the right to enforce such provision.

This License represents the entire understanding between the parties with respect to its subject matter.

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, THAT YOU UNDERSTAND THIS AGREEMENT, AND UNDERSTAND THAT BY CONTINUING THE INSTALLATION OF THE SOFTWARE PRODUCT, BY LOADING OR RUNNING THE SOFTWARE PRODUCT, OR BY PLACING OR COPYING THE SOFTWARE ONTO YOUR COMPUTER HARD DRIVE, YOU AGREE TO BE BOUND BY THIS AGREEMENT'S TERMS AND CONDITIONS. YOU FURTHER AGREE THAT, EXCEPT FOR WRITTEN SEPARATE AGREEMENTS BETWEEN TELERIK AND YOU, THIS AGREEMENT IS A COMPLETE AND EXCLUSIVE STATEMENT OF THE RIGHTS AND LIABILITIES OF THE PARTIES.

© 2002-2008 Telerik. All Rights Reserved.


System requirements and browser support

Telerik RadSplitter v1.3 Send comments on this topic.
System requirements and browser support
Installation and deployment > Installation > System Requirements > System requirements and browser support

Glossary Item Box

System Requirements

The following page describes the system requirements needed by Telerik RadControls for ASP.NET:

http://www.telerik.com/support/requirements-and-compliance/system-requirements.aspx

Browser Support

The following page shows all browsers and versions supported by Telerik RadControls for ASP.NET:

http://www.telerik.com/support/requirements-and-compliance/browser-support.aspx

Browser Limitations

The following article explains the browser limitations and what implications they have on Telerik RadControls for ASP.NET:

http://www.telerik.com/support/browser-support/browser-issues.aspx

Files and folders needed by Telerik RadSplitter and Telerik RadControls for ASP.NET to function

The following section explains the files and folders needed to be used in your application in order for Telerik RadControls for ASP.NET to function properly:

Files and folders needed by Telerik RadControls for ASP.NET

© 2002-2008 Telerik. All Rights Reserved.


Which file do I need to install?

Telerik RadSplitter v1.3 Send comments on this topic.
Which file do I need to install?
See Also
Installation and deployment > Installation > Installing Telerik RadSplitter on your computer > Which file do I need to install?

Glossary Item Box

Telerik offers you the following ways to install Telerik RadSplitter:

  • as an individual install, or
  • as part of the complete Telerik RadControls for ASP.NET suite.

If you plan to use only Telerik RadSplitter in your project, we recommend that you install Telerik RadSplitter only. In case you want to use two or more products from the Telerik RadControls for ASP.NET suite, it is probably better to install the full Telerik RadControls for ASP.NET suite.

Each installation package comes in three types:

  • EXE file for automatic installation;
    The EXE files are intended for easy and automatic installation of a product. It installs the control(s) on your computer in a folder in your Program Files named Telerik, and automatically creates the necessary virtual folders and projects. Additionally, the EXE installs the help file(s) in your VS.NET IDE and in your local copy of MSDN (if you have one). The EXE files are best for first-time Telerik users and ASP.NET novices.
  • ZIP file for manual (advanced) installation;
    The ZIP is used for manual (advanced) installs and for upgrading/updating purposes. The folder structure is different from the EXE. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot. Use the ZIP file for installation on shared hosting.
  • DLL and Scripts only (a.k.a. HOTFIX) file for updating/upgrading a product to a newer version;
    This is a bare-bones upgrade option for our controls. The DLL and Scripts files contain only those files that you need to replace in your project to upgrade to the new version of a Telerik control. If you are already using a Telerik product and just want to update it, there is no need to download the complete suite - download the latest HOTFIX for the product and apply it.
The latest EXE and ZIP packages available for download already have all updates/HOTFIXES applied. There is no need to update them further.

If you already have a Telerik control installed from the EXE, you can safely install an updated version of the same control - the installer will keep your existing installation. The new files will be placed in a separate folder and the new installation does not damage the common installer files. The new Telerik RadSplitter installation may have an updated help too: it is registered with the correct splitter namespace. You can see the updated Telerik RadSplitter help in your help2 viewer.

See Also

Installing the Telerik RadControls for ASP.NET suite from EXE file
Installing the Telerik RadControls for ASP.NET suite from ZIP file
Installing Telerik RadSplitter from EXE file
Installing Telerik RadSplitter from ZIP file
Using the 'DLL and Scripts only' file (HOTFIX)

© 2002-2008 Telerik. All Rights Reserved.


Installing the Telerik RadControls for ASP.NET suite from EXE file

Telerik RadSplitter v1.3 Send comments on this topic.
Installing the Telerik RadControls for ASP.NET suite from EXE file
See Also
Installation and deployment > Installation > Installing Telerik RadSplitter on your computer > Installing the Telerik RadControls for ASP.NET suite from EXE file

Glossary Item Box

The EXE files are intended for easy and automatic installation of a product. The EXE installs the suite on your computer to a folder named Telerik in your Program Files, automatically creating the necessary virtual folders and projects. Additionally, it installs the help file(s) in the VS.NET IDE and in your local copy of MSDN, if you have one installed.

The EXE files are best for first-time Telerik users and ASP.NET novices.

The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
The EXE installation will not overwrite previous Telerik RadControls for ASP.NET installations, unless it is of the same version.

Install with Internet Information Services (IIS) Running

To install Telerik RadControls for ASP.NET on your machine from the EXE file, follow the instructions below:

  1. Log into your Client.NET account.
  2. Go to My Licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab and download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadControls EXE file and follow the instructions.

    The wizard will install the Telerik RadControls for ASP.NET component in the following folder unless you specify otherwise:
    C:\Program Files\Telerik\RadControlsQ1 2007.

The wizard will create the necessary virtual folders.

To view live examples of the Telerik RadSplitter functionality, you can launch the Quick-Start Framework in either of the following ways:

  • Open Start Menu -> Programs -> Telerik -> RadControls Q1 2007 for ASP.NET -> ASP.NET 2.X -> RadControls Q1 2007 C#/VB Live Examples,
  • Double-click the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\RadControlsQ1 2007\NET2,
  • or drag the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\RadControlsQ1 2007\NET2 to start the examples in your browser.

Install without Internet Information Services (VS 2005 only)

To install Telerik RadControls on your machine from the EXE file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab to download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadControls EXE file and follow the instructions.

    The wizard will install the Telerik RadControls for ASP.NET component in the following folder unless you specify otherwise:
    C:\Program Files\Telerik\.

When Internet information Services is not running, the product installation will NOT create virtual directories for the QSF, nor will it create any shortcuts for launching the QSF on localhost. To launch the Quick-Start framework, open and Run (Ctrl+F5) its VisualStudio Web Site using the provided shortcut in the Start Menu:
Start Menu -> Programs -> Telerik -> RadControlsQ1 2007 for ASP.NET-> ASP.NET 2.X -> Open Sample Web Site in Visual Studio
VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

The Telerik RadControls for ASP.NET package adds the products automatically to the VS.NET 2005 toolbox. To learn how to add them manually, see Adding Telerik RadSplitter to the Visual Studio 2005 Toolbox.

See Also

Files and folders needed by Telerik RadControls for ASP.NET
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Installing Telerik RadSplitter from EXE file

Telerik RadSplitter v1.3 Send comments on this topic.
Installing Telerik RadSplitter from EXE file
See Also
Installation and deployment > Installation > Installing Telerik RadSplitter on your computer > Installing Telerik RadSplitter from EXE file

Glossary Item Box

The EXE files are intended for easy and automatic installation of a product. The EXE installs the control on your computer to a folder named Telerik in your Program Files, automatically creating the necessary virtual folders and projects. Additionally, it installs the help file(s) in the VS.NET IDE and in your local copy of MSDN, if you have such installed.

The EXE files are best for first-time Telerik users and ASP.NET novices.

The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
The EXE installation will not overwrite previous Telerik RadSplitter installations, unless it is of the same version.

Install with Internet Information Services (IIS) Running

To install Telerik RadSplitter on your machine from the EXE file follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadSplitter.
  4. Go to the Download tab and download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadSplitter_1_3.exe and follow the instructions.

The wizard will create a virtual folder "Telerik RadSplitter1.3NET2" (accessible at http://localhost/Telerik/telerikradsplitter1.3_NET2).

To view live examples of the Telerik RadSplitter functionality, you can launch the Quick Start Framework in either of the following ways:

  • Open Start Menu -> Programs -> Telerik -> Telerik RadSplitter v1.3 -> ASP.NET 2.X -> Telerik RadSplitter v1.3 C#/VB Live Examples,
  • Double-click the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\Telerik RadSplitter v1.3\NET2,
  • or drag the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\Telerik RadSplitter v1.3\NET2 to start the examples in your browser.

Install without Internet Information Services (VS 2005 only)

To install Telerik RadSplitter on your machine from the EXE file follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Locate Telerik RadSplitter, and click on it.
  4. Go to the Download tab to download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadSplitter_1_3.exe and follow the instructions.

When Internet information Services is not running, the product installation will NOT create virtual directories for the QSF, nor will it create any shortcuts for launching the QSF on localhost. To launch the Quick-Start framework, open and Run (Ctrl+F5) its VisualStudio Web Site using the provided shortcut in the Start Menu:
Start Menu -> Telerik -> Telerik RadSplitter v1.3 -> ASP.NET 2.X -> Open Sample Web Site in Visual Studio
VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

Telerik RadSplitter will be added automatically to VS.NET 2005's toolbox. Review the following instructions to add it manually: Adding Telerik RadSplitter to the Visual Studio 2005 Toolbox

The wizard will install the Telerik RadSplitter component in the following folder unless you specify otherwise:
\Program Files\Telerik\Telerik RadSplitter1.3\NET2.

The installation folder contains the following subfolders and files:

  • "bin" - contains the .dll files

  • "Common" - contains JavaScripts and css files

  • "RadControls" - contains the clients-side JavaScript and resource files
    You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.

  • "splitter" - contains the running examples from the Quick-Start framework

  • LiveExamplesCS - a browser link to run the C# version of the examples locally
  • LiveExamplesVB - a browser link to run the VB.NET version of the examples locally

The information below is generic for all Telerik controls. The particular details vary for individual control installations.

The installation folders of some Telerik controls may also contain the following subfolders:

  • "DeploymentActions" - contains the files required for proper deployment of the control
  • "Help" - contains all the files required for generating Help2
  • "Img" - contains system images
  • "InstalledRelated" - contains the files required for proper installation of the control

See Also

Adding Telerik RadSplitter to an ASP.NET WebForm
Add/Remove Telerik RadSplitter to the Global Assembly Cache
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Installing the Telerik RadControls for ASP.NET suite from ZIP file

Telerik RadSplitter v1.3 Send comments on this topic.
Installing the Telerik RadControls for ASP.NET suite from ZIP file
See Also
Installation and deployment > Installation > Installing Telerik RadSplitter on your computer > Installing the Telerik RadControls for ASP.NET suite from ZIP file

Glossary Item Box

Show All Show All
Hide All Hide All

The ZIP is used to install Telerik RadControls for ASP.NET manually for upgrading or updating purposes. The folder structure is different from the EXE installation. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot.

Install without IIS Running (VS 2005 only)

To install the Telerik RadControls for ASP.NET suite on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Hide What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadControls for ASP.NET - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help1
    • HelpNET20 folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadControls for ASP.NET under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadControls for ASP.NET under ASP.NET2.x
    • other files and folders.
  5. The latest package available for download has all latest updates/HOTFIXES applied. There is no need to update it further.
  6. Once the download completes, create a Telerik_RadControls folder in your IIS's inetpub/wwwroot folder.
  7. From the downloaded file, extract the files from the NET2 folder into inetpub/wwwroot/Telerik_RadControls folder. After the process ends, the inetpub/wwwroot/Telerik_RadControls folder should contain the following files and folders:
    • app_themes folder - contains the themes and skins used by Telerik's navigational controls
    • bin folder - contains the controls' .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files, needed by Telerik's controls. You will need to copy this folder in your web application only if you intend to use skins different from the Default or if you plan to modify the JavaScript files.
      Exceptions: Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell, Telerik RadUpload and Telerik RadWindow products.
    • folders, named after Telerik's controls (i.e. Calendar, Chart, Combobox, etc.) - these contain the running examples for each control from the Quick-Start framework
    • other project files and folders.
  8. Create a .NET2 virtual directory for the folder where you extracted the files. Hide How?

    This is accomplished through the Internet Information Services console on your machine:
    Start -> Settings -> Control Panel -> Administrative Tools -> Internet Information Services:
    1. Right-click the folder you have created (Telerik_RadControls).
    2. Select Properties.
    3. Click the Create button. The application name will become Telerik_RadControls.
    4. Click Apply.
    5. Click the ASP.NET tab.
    6. From the drop-down list, select your ASP.NET 2.0 version:

      ASP.NET tab under .NET2.0
    7. Click OK.
  9. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (under IIS6, Windows Server 2003) on the folder where the files were extracted. See Setting ASNET (Network Service) Permissions for more information.

To run the examples paste the following link in your browser: http://localhost/Telerik_RadControls/

To register the MS Help 2 files to VisualStudio and MSDN, please review the following link:
http://www.telerik.com/Default.aspx?PageId=2657

To add any control to the VS.NET toolbox, review Adding Telerik RadSplitter to the Visual Studio 2005 Toolbox
To use any Telerik ASP.NET control in your project, review Adding Telerik RadSplitter to an ASP.NET WebForm

DO NOT include/add the examples in your VS.NET project as this will break the Telerik control(s).

See Also

Files and folders needed by Telerik RadControls for ASP.NET
Trial License Limitations
Register MS Help 2 files

© 2002-2008 Telerik. All Rights Reserved.


Installing Telerik RadSplitter from ZIP file

Telerik RadSplitter v1.3 Send comments on this topic.
Installing Telerik RadSplitter from ZIP file
See Also
Installation and deployment > Installation > Installing Telerik RadSplitter on your computer > Installing Telerik RadSplitter from ZIP file

Glossary Item Box

Show All Show All
Hide All Hide All

The ZIP is used to install Telerik RadSplitter manually for upgrading or updating purposes. The folder structure is different from the EXE installation. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot.

Install Telerik RadSplitter with IIS running

To install Telerik RadSplitter on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadSplitter.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Show What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadSplitter - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadSplitter under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadSplitter under ASP.NET2.x
    The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
  5. Once the download completes, create a RadSplitter folder in your IIS's inetpub/wwwroot folder.
  6. From the downloaded file, extract all files from the NET2 folder into inetpub/wwwroot/RadSplitter folder. After the process ends, the inetpub/wwwroot/RadSplitter/ folder should contain the following files and folders:
    • App_Themes folder - contains some .NET2.0 themes provided by Telerik
    • bin folder - contains the .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files. You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.
      Exceptions: Because of the specific control features, you will always need to copy RadControls for RadChart, RadEditor, RadSpell, RadUpload and RadWindow products.
    • splitter folder - contains the running examples from the Quick-Start framework
    • other project files.
  7. Create a .NET2 virtual directory for the folder where you unzipped the files. Show How?
    This is accomplished through the Internet Information Services console on your machine:
    Start -> Settings -> Control Panel -> Administrative Tools -> Internet Information Services:
    1. Right-click the folder you have created (RadSplitter).
    2. Select Properties.
    3. Click the Create button. The application name will become RadSplitter.
    4. Click Apply.
    5. Click the ASP.NET tab.
    6. From the drop-down list, select your ASP.NET 2.0 version:

      ASP.NET tab under .NET2.0
    7. Click OK.
  8. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (under IIS6, Windows Server 2003) on the folder where the files were unzipped. See Setting ASNET (Network Service) Permissions for more information.

To run the examples, paste the following link in your browser: http://localhost/RadSplitter

Install Telerik RadSplitter without or with IIS stopped (VS 2005 Only)

To install Telerik RadSplitter on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadSplitter.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Show What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadSplitter - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadSplitter under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadSplitter under ASP.NET2.x
    The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
  5. From the downloaded file, extract all files from the NET2 folder into folder at a convenient location on your disk. After the process ends, the folder should contain the following files and folders:
    • App_Themes folder - contains some .NET2.0 themes provided by Telerik
    • bin folder - contains the .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files. You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.
    • splitter folder - contains the running examples from the Quick-Start framework
    • other project files.
  6. Open and Run (Ctrl+F5) Quick-Start Framework VisualStudio Web Site using the provided solution file ControlsExamples.sln in the NET2 folder. VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

To register the MS Help 2 files to VisualStudio and MSDN, please review the following link:
http://www.telerik.com/Default.aspx?PageId=2657

To add Telerik RadSplitter to the VS.NET toolbox, review Adding Telerik RadSplitter to the Visual Studio 2005 Toolbox.

To use the Telerik RadSplitter in your project, please review Adding Telerik RadSplitter to an ASP.NET WebForm.

DO NOT include/add the examples in your VS.NET project as this will break the Telerik control(s).

See Also

Adding Telerik RadSplitter to an ASP.NET WebForm
Add/Remove Telerik RadSplitter to the Global Assembly Cache
Trial License Limitations
Register MS Help 2 files

© 2002-2008 Telerik. All Rights Reserved.


Using the 'DLL and Scripts only' file (HOTFIX)

Telerik RadSplitter v1.3 Send comments on this topic.
Using the 'DLL and Scripts only' file (HOTFIX)
See Also
Installation and deployment > Installation > Installing Telerik RadSplitter on your computer > Using the 'DLL and Scripts only' file (HOTFIX)

Glossary Item Box

Show All Show All
Hide All Hide All

The "DLL and Scripts only" file (a.k.a. HOTFIX file) is a bare-bones upgrade option for our controls - they contain only those files that you need to replace in your project to upgrade to the new version of a Telerik control. If you are already using a Telerik product, there is no need to download the complete suite - download the "DLL and scripts only" version and follow the instructions below for applying the hotfix. The "DLL and Scripts only" file contains the following folders and files:

  • bin folder - contains the DLL file(s)
  • RadControls folder - contains the clients-side JavaScript and resource files for Telerik RadSplitter
If you are installing a Telerik product for the first time, we recommend that you download the complete package (EXE or ZIP file).

To update Telerik RadSplitter to a new version

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases" (or "My Free Trials" if you are a trial user).
  3. Locate the control that you need to install, i.e. Telerik RadSplitter, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. If you have purchased the control, you need to download the file which has the Dev abbreviation in it.
  5. Once the download completes, unzip the files at a convenient location.
  6. If the upgrade is major (i.e. from v1.x to v1.x), check the Changes and Backward Compatibility section in this manual for further instructions.
  7. Back up your application.
  8. Close Visual Studio or any ither IDE which may lock the old assembly.
  9. From the newly downloaded and unzipped files, copy the new DLL (located in the bin folder) to your web-application's bin folder. Replace the old dll.
  10. [Optional. Follow this step only if you intend to use skins different from the default or if you plan to modify the JavaScript files
    Exceptions: Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products. ]
    Copy the new RadControls folder to the root of your web-application. Replace all files and folders when asked. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate the old folder and paste the new RadControls folder over it. Replace all files and folders when asked.
  11. If you are using VS.NET, update the control's reference in your project to point to the new DLL.
  12. Recompile your project.
  13. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadSplitter to the Global Assembly Cache
  14. Run the project.
  15. If you still get the older version of Telerik RadSplitter Hide click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadSplitter's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadSplitter, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....
  16. If you get a copyright message Show click here

    The copyright message appears only when using the trial version of Telerik RadSplitter (the Developer versions of Telerik's controls do not throw copyright messages).

    If you have purchased the control, then you have downloaded the wrong "DLL and Scripts only" file. Make sure you you download the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

See Also

Adding Telerik RadSplitter to an ASP.NET WebForm
Add/Remove Telerik RadSplitter to the Global Assembly Cache
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Setting ASPNET (Network Service) Permissions

Telerik RadSplitter v1.3 Send comments on this topic.
Setting ASPNET (Network Service) Permissions
Installation and deployment > Installation > Installing Telerik RadSplitter on your computer > Setting ASPNET (Network Service) Permissions

Glossary Item Box

In most applications, users typically access Web applications anonymously — that is, they do not initially provide authentication credentials. In that case, the Web application has to assume (impersonate) some identity that it can use to request resources.
By default, when ASP.NET allows anonymous access, the application runs in the context of a special local (not domain) account. The user context depends on the operating system. In Windows 2000 and Windows XP, applications run under the account called ASPNET. In Windows Server 2003, the user context is called NETWORK SERVICE. These user accounts are created during the .NET Framework installation process with a unique, strong password, and are granted only limited permissions. The ASPNET or NETWORK SERVICE user can access only specific folders that are required to run a Web application, such as the \bin directory in which a Web application stores compiled files.

Full information on the topic can be found in MSDN: Security Considerations for ASP.NET Web Applications

Instructions on how to give process permissions on a folder - FAT32 file system

No need to give any permissions on the folder.

Instructions on how to give process permissions on a folder - NTFS file system

Internet Information Services v5.x - name of account: ASPNET user

  1. Right-click on the RadSplitter (or Telerik_RadControls) folder and select Properties.
  2. Click on the Security tab. If you do not see the security tab, click Show here

    The Security tab is not visible because you have Simple File Sharing enabled. You will need to disable it before you continue. To do so:
    1. Open a Windows Explorer.
    2. On the Tools menu, click Folder Options, and then click the View tab.
    3. In the Advanced Settings section, clear the Use simple file sharing (Recommended) check box (at the bottom of the list).
    4. Click OK.
    5. Right-click on the folder you need to add ASPNET permissions to and select Properties. Click on the Security tab.

  3. Click on Add (to add a new user).

  4. Click on Locations to select your local machine. Your screen should look similar to the following:

    Setting ASPNET permissions

  5. Select your local machine and click OK.

  6. Type ASPNET in the textbox and click on Check Names. ASPNET should underline (if it doesn't then you don't have Microsoft's .NET framework installed).

    ASPNET user

  7. Click OK.

  8. Select the LOCAL MACHINE NAME/ASPNET user you just created (it should be named ASP.NET Machine Account (NAME/ASPNET)) and check the Full Control box to give it full permissions.

  9. Click APPLY.

  10. Click Advanced and make sure that the "Inherit from parent ..." check box is checked.

  11. Click OK to close the Advanced properties.

  12. Click OK to close the folder properties.

Internet Information Services v6.x - name of account: Network Service user

Same as above but replace ASPNET with Network Service.

© 2002-2008 Telerik. All Rights Reserved.


Trial License Limitations

Telerik RadSplitter v1.3 Send comments on this topic.
Trial License Limitations
See Also
Installation and deployment > Installation > Installing Telerik RadSplitter on your computer > Trial License Limitations

Glossary Item Box

Developer Licenses

Developer licenses come with modified DLLs, which work without license keys. If you have a Developer license for one or more of the Telerik components, you only need to ensure that you are using the developer build when downloading the control(s). These builds have the Dev abbreviation in their file names.

If your application is displaying a license key error, this means that you are using a trial version of the product. Log in to your Client.net account and download the developer build. To update your project, please take a look at the Upgrading the Trial License to a Production License section for step-by-step instructions.

Trial Licenses

The free trial licenses of all Telerik products are fully functional and will work for an unlimited time but with trial error messages (see below) displayed randomly on the page.

Trial error messages

The trial licenses will occasionally display the following message on your webform:

Telerik RadSplitter 1.3 trial version. Copyright Telerik © 2002-2008. To remove this message, please, purchase a developer version .

See Also

License Agreement

© 2002-2008 Telerik. All Rights Reserved.


Files and folders needed by Telerik RadControls for ASP.NET

Telerik RadSplitter v1.3 Send comments on this topic.
Files and folders needed by Telerik RadControls for ASP.NET
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > Files and folders needed by Telerik RadControls for ASP.NET

Glossary Item Box

Please, review the following KB article on the topic:

Which files and folders are mandatory to be on the server for Telerik RadControls for ASP.NET to function

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


The 'RadControls' Folder

Telerik RadSplitter v1.3 Send comments on this topic.
The 'RadControls' Folder
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > The 'RadControls' Folder

Glossary Item Box

The RadControls folder is an essential part of Telerik RadControls for ASP.NET - it contains all resources needed for the components to function properly (i.e. images, client-side scripts, configuration files, skins, etc.).

You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files. However because of the specific control features, you will always need to copy /RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products.

Each Telerik component seeks its resources in the respective subfolder of RadControls: for example, /RadControls/Splitter is the folder where the resources for Telerik RadSplitter reside.

Copying the RadControls folder to your web application

To work with Telerik RadControls for ASP.NET, you need to copy the RadControls folder to your web application. The folder must contain all the subfolders of the controls you are going to use. Do not copy the subfolders of controls you are not planning to use as this may cause a number of compilation errors: Visual Studio 2005 compiles all files in the web project; errors occur when missing assemblies are not found.

Do not include the RadControls folder in your VS.NET solution! Hide Why?

When the RadControls folder is included in a VB.NET project, VS.NET tends to change some files within the RadControls folder automatically. The extent of these changes depends on the IDE settings; notably, the following controls are affected:
  • Telerik RadEditor
  • Telerik RadSpell
  • Telerik RadChart
Telerik controls are written in C# - hence the several *.CS codebehind files within the RadControls/[control] folder. When such .ASCX/ASPX files are included in the project, VS.NET automatically changes the Language attribute of their Page/Control directive from cs to vb and breaks the control.

To avoid the problem:
  1. In Windows Explorer, do a filtered search to locate all ASPX and ASCX files within the RadControls folder.
  2. Once the search is over, select all files and right-click to get their properties.
  3. Select the Hidden check box and click OK.
Now Visual Studio will not see the files, so errors will not be thrown. At the same time IIS will see the files and will display them fine.

If you have already included the RadControls folder in your VS2005 project:
  1. Open your Visual Studio 2005 project.
  2. In the Solution Explorer locate the RadControls folder and expand it.
  3. Locate the problematic ascx files, right-click them and select "Exclude from project". Unfortunately, this can be done for files only (unlike VS2003), so the process should be repeated for all ascx files.
  4. Open Windows Explorer, navigate to your project's folder.
  5. Back up the RadControls folder from your project, especially any customized files you may have (ConfigFile.xml, ToolsFile.xml, any css files, images. etc).
  6. Delete the damaged RadControls folder.
  7. Navigate to the installation folder of Telerik RadSplitter (for example).
  8. Copy the RadControls folder from the installation folder to the root of your web application.
  9. Rebuild and run your project.

Moving the RadControls folder within your web-application

  1. Manually copy the RadControls folder to the new location within your web application (for example, ~/Resources/).
    Do not use the VS.NET IDE to copy/move the RadControls folder to another location as it changes the namespaces of the files and changes the project language from C# to VB which in turn breaks the application! Use Windows Explorer instead.
  2. Either:
    • Specify its position in the RadControlsDir property in the control's declaration in your ASCX/ASPX file, e.g.
      Copy Code
      <radS:RadSplitter
      RadControlsDir="~/Resources/RadControls/" ...>
      </      radS:RadSplitter>
    • Or set the property globally from the Web.config file of the application:
      Copy Code
      <configuration>
      <appSettings>
      <add key="Telerik.WebControls.RadControlsDir" value="~/Resources/RadControls/"/>
      </appSettings>
      </      configuration>
      Notes.
      • In the above examples, the tilde "~" represents the root of your web application.
      • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.

Moving the RadControls folder outside your web-application

This is the best scenario if you want to have a single RadControls folder for several applications. This mechanism also enables different versions of Telerik products to reside in different web applications:

  1. Manually copy the RadControls to the new location.
    Do not use the VS.NET IDE to copy/move the RadControls folder to another location as it changes the namespaces of the files and changes the project language from C# to VB, which in turn breaks the application! Use Windows Explorer instead.
  2. Create a virtual directory with name RadControls under each application's root which points physically to the same physical RadControls folder. That physical folder should include all the scripts and other required settings of the controls.
    The respective RadControls virtual directory should NOT be a web application but virtual directory only! You can find more information on the topic in the following KB article: (ID#728) Error Message: Could not load type 'Telerik.WebControls.Dialogs.Dialog'.
  3. Either:
    • Specify its position in the RadControlsDir property in the control's declaration in your ASCX/ASPX file, e.g.

    • Or set the property globally from the Web.config file of the application:
      Copy Code
      <configuration>
      <appSettings>
      <add key="Telerik.WebControls.RadControlsDir" value="~/RadControls/"/>
      </appSettings>
      </      configuration>
      Notes.
      • In the above examples, the tilde "~" represents the root of your web application.
      • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.
      • Make sure you set the RadControlsDir property to "~/RadControls/" (with a slash following the folder name).

"You have not copied the RadControls folder to the root folder of your web-application" error message

When opening a page which contains Telerik RadSplitter, the following error message appears:
“Telerik RadSplitter v1.3: You have not copied the RadControls folder to the root folder of your web-application or you have applied an update incorrectly."

This message shows that the control is not able to locate its RadControls/splitter folder. It usually appears after updating the control to a newer version. The causes for the message to appear are:

  • The assembly version and the RadControls/splitter folder version are from different installation downloads, i.e. from different Telerik RadSplitter versions.
    Example: RadSplitter.NET2.DLL is version 1.3.2, whereas the Telerik RadSplitter's RadControls/Splitter folder is from version 1.3.1 or other.
  • The proper assembly is in the bin folder of the application, but the RadControls/splitter folder is missing or misplaced.

To solve the problem:

  1. Check whether the RadControls folder is placed in the root of your web application and that you have NOT set the RadControlsDir property to point to another location.
  2. Check whether the RadControls/splitter folder contains a subfolder, named Scripts, and a subfolder which carries the version of the control as its name.
    For example, if you use Telerik RadSplitter v1.3.2 - the folder should be \RadControls\Splitter\Scripts\1_3_2 and this version number should match the RadSplitter.NET2.dll version placed in the /bin folder.
    If such discrepancy exists between the control's assembly and the RadControls folder, use a DLL and RadControls folder from a working application or download the ZIP file from your Client.net account and use the files from there.
  3. Another reason could be that some files from the RadControls/splitter folder are missing or damaged. Please delete the current RadControls folder and paste the original one from the same download that you have the assembly from.
  4. For some reason your project may still reference the previous version of control's DLL, and not the latest. In this case we suggest removing the old assembly reference from your VS.NET project and adding a new reference to to the new assembly.
  5. If you have added the control in the GAC (Global assembly cache), remove it by running gacUtil and then add the new version.
  6. If you are trying to move the RadControls folder through the RadControlsDir property, please review the following section for resolution:

  7. [not related to Telerik controls] Delete .NET, VS and browser caches because they can cause a problem too:

    1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
    2. Open a Windows Explorer and navigate to
      C:\Windows(WINNT)\Microsoft.NET\Framework\vYOUR_VERSION\Temporary ASP.NET Files
    3. Delete all the folders with names, corresponding to your Telerik projects.
    4. Delete your Visual Studio web project caches as well - they should be located at C:\Documents and Settings\VSWebCache.
    5. Delete your browser cache: Tools -> Internet Options -> Delete Files....

See Also

Setting the RadControlsDir property

© 2002-2008 Telerik. All Rights Reserved.


Setting the RadControlsDir property

Telerik RadSplitter v1.3 Send comments on this topic.
Setting the RadControlsDir property
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > Setting the RadControlsDir property

Glossary Item Box

The RadControlsDir property can be set:

  • either from the ASPX/ASCX page where Telerik RadSplitter resides (or programmatically, from the code behind),
  • or globally, for all controls in the web application, from the Web.config file.

To set RadControlsDir from the Web.config, add the following line inside the appSettings tag:

Notes.
  • In the above example, the tilde "~" represents the root of your web application.
  • You can change the location of the RadControls folder. The path given here is to serve only as an illustration.
  • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.
  • When you set the RadControlsDir property, its value does not automatically update other properties that contain URL strings. You need to update these properties manually.

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


Adding Telerik RadSplitter to the Visual Studio 2005 Toolbox

Telerik RadSplitter v1.3 Send comments on this topic.
Adding Telerik RadSplitter to the Visual Studio 2005 Toolbox
See Also
Installation and deployment > Installation > Adding Telerik RadSplitter to the Visual Studio 2005 Toolbox

Glossary Item Box

Telerik RadControls for ASP.NET are added automatically to the Visual Studio .NET 2005 Toolbox during installation. However if you are using the ZIP distribution, you can do this manually as described below.

To add Telerik RadSplitter to the Toolbox manually and to be able to easily deploy the component in your WebForms in Design mode, follow the steps below:

  1. Open your application in Visual Studio 2005.
  2. Expand the Toolbox.

  3. Expand the General Section.

  4. Right-click in the General section and open Choose Items.

  5. On the .NET Framework Components tab, click Browse.

  6. Browse to the Telerik RadSplitter installation folder, open the NET2 folder and from the bin subfolder, select the RadSplitter.Net2.dll.

    • If the EXE was used to install Telerik RadControls for ASP.NET, the bin folder is located in
      C:\Program Files\Telerik\Telerik RadControls for ASP.NETQ1 2007\NET2\bin

    • If the ZIP was used to install Telerik RadSplitter, the bin folder is located in the folder where the installation files have been unzipped (usually "\Inetpub\wwwroot\RadSplitter_1_3\NET2"

  7. Click Open to confirm. The Telerik RadSplitter icon should appear in the Toolbox.

  8. If you intend to use skins different from the default or if you plan to modify the JavaScript files, do not forget to copy the respective RadControls folder to the root of your application. For more information, see The 'RadControls' Folder.

See Also

Adding Telerik RadSplitter to an ASP.NET WebForm

© 2002-2008 Telerik. All Rights Reserved.


Adding RadControls to the Visual Studio 2008 Toolbox

Telerik RadSplitter v1.3 Send comments on this topic.
Adding RadControls to the Visual Studio 2008 Toolbox
Installation and deployment > Installation > Adding RadControls to the Visual Studio 2008 Toolbox

Glossary Item Box

Telerik RadControls for ASP.NET are added automatically to the Visual Studio .NET 2008 Toolbox during installation. However if you are using the ZIP distribution, you can do this manually as described below.

To add Telerik RadControls "Prometheus" for ASP.NET to the Toolbox manually and to be able to easily deploy the component in your WebForms in Design mode, follow the steps below:

  1. Open your application in Visual Studio 2008.
  2. Expand the Toolbox.

  3. Expand the General Section.

  4. Right-click in the General section and open Choose Items.

  5. On the .NET Framework Components tab, click Browse.

  6. Browse to the Telerik RadControls for ASP.NET installation folder, open the bin35 folder and select the Telerik.Web.UI.dll.

    • If the EXE was used to install Telerik RadControls for ASP.NET, the bin35 folder is located in
      C:\Program Files\Telerik\RadControls for ASPNET\bin35

    • If the ZIP was used to install Telerik RadControls, the bin35 folder is located in the folder where the installation files have been unzipped

  7. Click Open to confirm. The icons for all controls in the suite will appear in the Toolbox. Visual Studio 2008 toolbox

© 2002-2008 Telerik. All Rights Reserved.


Adding Telerik RadSplitter to an ASP.NET WebForm

Telerik RadSplitter v1.3 Send comments on this topic.
Adding Telerik RadSplitter to an ASP.NET WebForm
Installation and deployment > Installation > Adding Telerik RadSplitter to an ASP.NET WebForm

Glossary Item Box

To add Telerik RadSplitter to an ASP.NET WebForm you can use either of the following approaches:

  • Drag the Telerik RadSplitter icon from the Visual Studio Toolbox;

  • Write the Telerik RadSplitter tag manually.

If you intend to use skins different from the default or if you plan to modify the JavaScript files, you also need to manually copy the Splitter subfolder under the RadControls folder from the Telerik RadSplitter installation folder to the root folder of your web application.

Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products.
If your RadControls folder contains multiple subfolders for Telerik controls - for example, if you are using a Telerik RadControls for ASP.NET installation as opposed to a Telerik RadSplitter installation - make sure you copy only the subfolders of the controls you are going to use (Splitter and any other controls you need). Do not copy the subfolders of controls you are not planning to use as this may cause a number of compilation errors: Visual Studio 2005 compiles all files in the web project; errors occur when missing assemblies are not found.

Adding Telerik RadSplitter to a WebForm using Visual Studio .Net

The easiest way to deploy Telerik RadSplitter is by dragging its icon from the Visual Studio .NET Toolbox in Design mode. Visual Studio will automatically copy the RadSplitter.NET2.dll to the bin folder of your web-application and will create the respective references. You only have to copy the RadControls folder to the root folder of your web application as explained above.

Adding Telerik RadSplitter to a WebForm manually

If you are not using Visual Studio .NET, you can deploy Telerik RadSplitter manually. Follow the instructions below:

  1. Copy the RadControls folder from the Telerik RadSplitter installation folder to the folder of your web application.

  2. Copy the RadSplitter.NET2.dll from the bin folder of the Telerik RadSplitter installation to the bin folder of your web application.

  3. Open your aspx/ascx file and add the Telerik RadSplitter Register directive at the top:
    <%@ Register TagPrefix="radS" Namespace="Telerik.WebControls" Assembly="RadSplitter.Net2" %>

    If you plan all pages in your application to use Telerik RadSplitter you can add the following lines in your web.config file. In this case you don't need to add this directive in your pages.

    Copy Code
    <pages>
    <controls>
    <add tagPrefix="radS" namespace="Telerik.WebControls" assembly="RadSplitter.Net2" />
    </controls>
    </    pages>

  4. Write the Telerik RadSplitter tags in the body of the WebForm:

    Copy Code
    <radS:RadSplitter ID="splitter1" Runat="server">
    </    radS:RadSplitter>
  5. Add any additional properties you need between the Telerik RadSplitter tags.

Troubleshooting: the css styles do not apply correctly

If you have a Telerik control in a user control with output caching turned on you should manually register all the required CSS files in the head tag of your page. Otherwise the control will not be displayed correctly. The easiest way to do this is through a LINK element:

<link href="~/RadControls/Splitter/Skins/[SkinName]/styles.css"rel="stylesheet"runat="server">

© 2002-2008 Telerik. All Rights Reserved.


Using IntelliSense in Visual Studio 2005

Telerik RadSplitter v1.3 Send comments on this topic.
Using IntelliSense in Visual Studio 2005
Installation and deployment > Installation > Using IntelliSense in Visual Studio 2005

Glossary Item Box

Visual Studio 2005 automatically enables IntelliSense - through reflection it detects all classes, properties and methods in the dll file(s).

For additional convenience each Telerik control is provided an XML file which contains the comments for its classes, properties and methods.

For example, when Telerik RadSplitter is dragged to the webform the RadSplitter.Net2.xml file is automatically added in the bin directory of the project.

In ASPX, when you start typing or when you insert a space, VisualStudio will show a dropdown with suggestions for autocomplete.

In code-behind, each time a particular class/property/method is being selected from the dropdown of the autocomplete functionality, a tooltip with the comment for this class/property/method is displayed:

Intellisense in VS2005

© 2002-2008 Telerik. All Rights Reserved.


Using IntelliSense in Visual Studio 2008

Telerik RadSplitter v1.3 Send comments on this topic.
Using IntelliSense in Visual Studio 2008
Installation and deployment > Installation > Using IntelliSense in Visual Studio 2008

Glossary Item Box

Visual Studio 2008 automatically enables IntelliSense - it detects all classes, properties and methods in the DLL file and the JavaScript code.

For additional convenience each Telerik control comes with an XML file which contains the comments for its classes, properties and methods.
When the Telerik control is dragged to the webform the XML file is automatically added in the bin directory of the project.
In ASPX, when you start typing or when you insert a space, Visual Studio will show a dropdown with suggestions for autocomplete:

ASPX AutoComplete

Visual Studio 2008 provides full Javascript Intellisense completion in ASPX files, HTM files, as well as in external JS files. It provides rich support for the ASP.NET AJAX client JavaScript framework and JavaScript code built with it:

In code-behind, each time a particular class/property/method is being selected from the dropdown of the autocomplete functionality, a tooltip with the comment for this class/property/method is displayed.

© 2002-2008 Telerik. All Rights Reserved.


Upgrading Telerik RadSplitter v1.x Trial to Telerik RadSplitter v1.x Developer license

Telerik RadSplitter v1.3 Send comments on this topic.
Upgrading Telerik RadSplitter v1.x Trial to Telerik RadSplitter v1.x Developer license
Installation and deployment > Installation > Upgrading Instructions > Upgrading Telerik RadSplitter v1.x Trial to Telerik RadSplitter v1.x Developer license

Glossary Item Box

Follow the steps below to upgrade your Telerik RadSplitter v1.3 Trial license to a Developer (production) license.

THE PROCEDURE DESCRIBED IN THIS MANUAL IS IRREVERSIBLE AND YOU MAY LOSE YOUR DATA IF THE INSTALLATION IS NOT CARRIED OUT CORRECTLY!

1. Back up Your Old Files

We strongly suggest that you back-up your old Telerik RadSplitter files and folders, especially if you would like to use your old settings.

2. Obtain the Necessary File

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases".
  3. Locate the control that you need to install, i.e. Telerik RadSplitter, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. Since you have purchased the control, make sure you are downloading the proper file - the Developer version has the Dev abbreviation in it.

3. Install and Copy the New Files

  1. Unzip the files at a convenient location.
  2. Check the Changes and Backward Compatibility section for introduced changes. If there are such, they should be applied a little later in the upgrade process.
  3. Back up your application if you haven't done so already.
  4. Close Visual Studio or any ither IDE which may lock the old assembly.
  5. From the newly downloaded and unzipped files, copy the new DLL (RadSplitter.NET2.dll located in the bin folder) to your web-application's bin folder. Replace the old dll.
  6. Locate the old RadControls/Splitter folder and delete it manually, i.e. using Windows Explorer. By default, the RadControls/Splitter folder should be in the root of your application. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate it and delete it using Windows Explorer.
    DO NOT use Visual Studio to move, copy or delete the RadControls folder as this will break the Telerik control(s).
  7. If you intend to use skins different from the default or if you plan to modify the JavaScript files, copy the new RadControls/Splitter folder to the same location as above.
  8. If using VS.NET, update the control's reference in your project to point to the new DLL.
  9. Follow the steps in the Changes and Backward Compatibility section in case there are some changes between the versions.
  10. Recompile your project.
  11. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadSplitter to the Global Assembly Cache
  12. Run the project.
  13. If you still get the older version of Telerik RadSplitter Hide click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadSplitter's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadSplitter, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....

  14. If you get a copyright message Hide click here

    The copyright message appears only when using the trial version of Telerik RadSplitter (the Developer versions of Telerik's controls do not throw copyright messages). Make sure you have downloaded the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

5. Using the old ToolsFile.xml File and ConfigFile.xml file [valid for Telerik RadEditor and Telerik RadSpell only]

If you would like to use your old ToolsFile.xml and ConfigFile.xml files (which you backed up in #1 above), you can do so by copying them from the back-up to the RadControls\Editor folder (or RadControls\Spell respectively) of your web-application. When prompted to overwrite the other file, click "YES".

© 2002-2008 Telerik. All Rights Reserved.


Add/Remove Telerik RadSplitter to the Global Assembly Cache

Telerik RadSplitter v1.3 Send comments on this topic.
Add/Remove Telerik RadSplitter to the Global Assembly Cache
See Also
Installation and deployment > Deploying Telerik RadSplitter into ASP.NET Applications > Add/Remove Telerik RadSplitter to the Global Assembly Cache

Glossary Item Box

Add to Global Assembly Cache

There are two ways to add a control to the Global Assembly Cache (GAC):

Automatic

  1. Go to Start -> Settings -> Control Panel -> Administrative Tools -> Microsoft .NET Framework 2.0 Configuration
  2. Expand the nodes and locate Assembly cache
  3. Right-click on it and select Add:

    Microsoft .NET 2.0 Configuration panel
  4. Browse to the Telerik bin directory and ctrl-highlight the needed DLL's (the demo and DictionaryConfiguration DLLs are not needed).
  5. Click Open.

Manual

  1. Run the .NET command prompt (Start -> Programs -> Microsoft VS.NET -> VS.NET Tools -> VS.NET prompt) and start the gacutil.exe tool with -i parameter (install) and the name of the control, e.g.

    Copy Code
    gacutil.exe -i "C:\Program Files\Telerik\Telerik RadSplitter1.3\NET1NET2\bin\RadSplitter.Net2.dll"

    You may also directly copy the dll files to the "\WINDOWS\assembly" (or "\WINNT\assembly") folder of your server - this is equivalent to the effect of the gacutil.exe utility.

  2. Change the machine.config file of the server and add a reference to the assembly in the GAC. The machine.config file is the configuration file for all web applications on the server. It is located at: "\WINDOWS\Microsoft.NET\Framework\[Framework Version]\CONFIG". It is similar in to the web.config file, but the web.config only works for the web application, in which it resides.

    Locate the <assemblies> tag (which should be under <configuration><system.web> <compilation>/<compilers>/<assemblies> ) Between the <assemblies> tag, you should enter something similar to:

    Copy Code
    <add assembly="AssemblyFileName, Version=0.0.0.0, Culture=neutral, PublicKeyToken=5edf592a9c40680c" />

    To get the information that goes into the assembly attribute (version, culture, PublicKeyToken), you can run the gacutil /l command, which will return a list of all the assemblies in the GAC. You will have to look for the one you just added and copy the entire line (minus the Custom=null part at the end).
    For example the following command:

    Copy Code
    gacutil -l RadSplitter.Net2

    will return:

    Copy Code
    RadSplitter, Version=1.3.0.0, Culture=neutral, PublicKeyToken=e8ab424810b6b9b5 Custom=null

    so the correct entry in the machine.config should be:

    Copy Code
    <add assembly="RadSplitter.Net2, Version=1.3.0.0, Culture=neutral, PublicKeyToken=e8ab424810b6b9b5" />

After that you should be able to use the control in all the application on the server without having to copy it to the "bin" folder of each web-application.

Remove from Global Assembly Cache

In order to remove Telerik RadSplitter from GAC, please use the following command:

Copy Code
gacutil.exe -u radsplitter

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


Multi Targeting in Visual Studio 2008

Telerik RadSplitter v1.3 Send comments on this topic.
Multi Targeting in Visual Studio 2008
See Also
Installation and deployment > Deploying Telerik RadSplitter into ASP.NET Applications > Multi Targeting in Visual Studio 2008

Glossary Item Box

In Visual Studio 2008 you are able to build applications targeting multiple versions of the .NET Framework. Apart from ASP.NET 3.5, VS 2008 can open, edit and build ASP.NET 2.0 applications (applications with ASP.NET AJAX 1.0 as well). Visual Studio 2008 can also deploy these application on .NET 2.0 machines. You are able to easily build applications with RadControls targeting both ASP.NET 2.0 and ASP.NET 3.5.

See Also

External Link
See more information on how to use Multi Targeting in VS 2008

© 2002-2008 Telerik. All Rights Reserved.


Deploying Telerik RadSplitter on Shared Hosting

Telerik RadSplitter v1.3 Send comments on this topic.
Deploying Telerik RadSplitter on Shared Hosting
Installation and deployment > Deploying Telerik RadSplitter into ASP.NET Applications > Deploying Telerik RadSplitter on Shared Hosting

Glossary Item Box

All Telerik controls are server controls and have to be installed on the web server in order to function properly. This also means that you will need to create the respective virtual directories and give the proper permissions (ASPNET [IIS5], NEtwork Service [IIS6]) in order to use them on the shared hosting.

If you have already created the application on your development machine

1. Copy/upload the compiled application via FTP to the production server, i.e. on the shared hosting. The application should reside in the inetpub/wwwroot folder.

2. Create a virtual directory for the application folder. Before you do this step, consult with your hosting provider on how this is to be accomplished. If the provider offers thorough instructions, use them instead of the ones below. If you do not have access to the Information Services console, ask your provider to set the application for you. If the provider does not offer instructions, then:

1. Locate the Internet Information Services console;

2. Navigate to the application folder;

3. Find the folder's Properties;

4. Create a virtual directory;

5. Remember the application name and click OK.

3. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (using IIS6 or IIS7, Windows Server 2003, Windows Vista/Longhorn) on the application folder. Again, before doing this step, consult with your hosting provider on how this is to be accomplished. If the provider offers thorough instructions, use them instead of the ones below. Otherwise, contact your provider to set the permissions for you.

4. Run the project.

Notes.

As the proper operation of some Telerik RadEditor elements need some external files to be loaded, a RadControls folder instance is needed for the control to run.

There are two possible RadControls folder usages:

  • Copy the RadControls folder within your web-application:

    Manually copy the RadControls folder to the new location within your web application (for example, ~/Resources/). Specify its position via the RadControlsDir property of the control's declaration: <radE:RadEditor RadControlsDir="~/Resources/RadControls/" ...></radE:RadEditor>, where the "~" (tilde) symbol in the path represents your web-application root directory.
  • Copy the RadControls folder outside your web-application (this is the best scenario if you would like to share the RadControls folder across multiple web applications): Manually copy the RadControls to the new location using Windows Explorer. Create a virtual directory with a preferred name (e.g. RadControls) under each application's root which points physically to the same physical RadControls folder.

    The respective RadControls virtual directory should NOT be a web application but virtual directory only! You can find more information on the topic in the following KB article: (ID#728) Error Message: Could not load type 'Telerik.WebControls.Dialogs.Dialog'.

    If the Virtual subfolder alias is different than RadControls, specify the virtual folder position via the RadControlsDir property in the editor's declaration in your ASCX/ASPX file
    <radE:RadEditor RadControlsDir="~/MyRadControls/" ...></radE:RadEditor>

    More information on the topic is available in the following help article: The 'RadControls' folder.

If you plan to deploy the controls directly on the shared hosting

1. Log in your Client.NET account.

2. Go to "My licenses" and click on "My Purchases" (or "My Free Trials" if you are a trial user).

3. Locate the needed control, and click on it.

4. Click on the "Download" tab to download the Manual installation (ZIP) file.

5. On the server, create a "Telerik" folder in your "inetpub/wwwroot" folder on the server.

6. If you intend to use skins different from the default or if you plan to modify the JavaScript files, create a new folder named RadControls in the inetpub/wwwroot/Telerik folder.

7. Follow the instructions from the first case above.

© 2002-2008 Telerik. All Rights Reserved.


Embedded Resources

Telerik RadSplitter v1.3 Send comments on this topic.
Embedded Resources
Installation and deployment > Deploying Telerik RadSplitter into ASP.NET Applications > Embedded Resources

Glossary Item Box

All Telerik RadControls for ASP.NET have their web resources embedded in the control assembly. Each control automatically fetches the required resources from the web. Embedded Resources are easier to manage because they require that you only maintain a single DLL for each RadControl when you upgrade versions/deploy applications. You no longer need to include the JavaScripts and the other related files with the RadControls folder in the root of your application. If you use external resources, you'll simply need to make sure you keep your DLLs and RadControls folders in sync when you upgrade and deploy.

Note that you still need the RadControls folder if you want to use a skin other than the Default.

You can control this functionality by setting the boolean property UseEmbeddedScripts.

When UseEmbeddedScripts is set to true (by default) web resources are streamed by the built-in web resource handler using a query string (like WebResource.axd?d=HTLSHE...). This scenario is suitable for easier deployment (no RadControls required).
The backside of using the embedded resources is that sometimes web resources are not cached (e.g. when your site is in debug mode <compilation debug="true" />). In addition the long query strings are adding bulk to the HTML you are sending to the client. Using external resources, i.e. the RadControls folder may nearly halve the page size due to the shorter resource paths. Your mileage may vary depending on the RadControls you are using.

If you set UseEmbeddedScripts to false, the control will use the necessary resources (files) from the RadControls folder. This is appropriate for example for cases when the web resource handler is disabled or when you have applied some modifications to the JavaScript or CSS files used by the control.

None of the functionality of the controls will change. Switching this property would only mean that you have to keep a local copy of the RadControls folder with the JS files in your application, since you are not going to use the embedded ones.
You cannot combine both methods for getting web resources, i.e. you cannot make the control take its scripts as embedded resources and skin file from RadControls.

© 2002-2008 Telerik. All Rights Reserved.


Trust level

Telerik RadSplitter v1.3 Send comments on this topic.
Trust level
Installation and deployment > Deploying Telerik RadSplitter into ASP.NET Applications > Trust level

Glossary Item Box

This topic refers the case you are trying to publish a site to a shared environment. The site is using the <RadControlName> component, where only the <RadControlName>.dll file exists in the /bin directory of the application along with the scripts directory (/RadControls/<ControlName>/Scripts) on the root.

All RadControls supports Medium trust level under shared hosting environment.

Note that a requirement for the RadControl is to have the trust level set to Medium at minimum - otherwise you may receive server error like the following:

Could not load type Telerik.RadSplitterDesign.SplitterComponentEditor from assembly mscorlib, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

To modify the trust level setting please follow the instructions below:

Locate the machine.config file placed in the \Microsoft.NET\Framework\v2.0.50727\CONFIG folder on your production server. Open it for editing and change the following line:

machine.config Copy Code
<trust level="Medium" originUrl=""/>

Further information about the different trust level options and their policies you can find in the MSDN:

http://msdn2.microsoft.com/en-us/library/tkscy493.aspx

http://msdn2.microsoft.com/en-us/library/wyts434y.aspx

© 2002-2008 Telerik. All Rights Reserved.


Troubleshooting deployment on the production server

Telerik RadSplitter v1.3 Send comments on this topic.
Troubleshooting deployment on the production server
Installation and deployment > Deploying Telerik RadSplitter into ASP.NET Applications > Troubleshooting deployment on the production server

Glossary Item Box

Since the Q2 2006 release our controls utilize webresources which is a new feature of ASP.NET 2.0. There are cases in which this may cause problems. For some reason requesting the webresource handler (webresource.axd) returns error number 404. This javascript files used by the control should be streamed by the web resource handler. As a result of the aforementioned error this does not happen and you may experience JavaScript errors on the client.

Here some tips how the problem can be solved:

First approach

  1. Open IIS management snap-in ( e.g. run inetmgr.exe)
  2. Right click your website and choose properties
  3. Go to the "Home Directory" tab and click the "Configuration" button
  4. A dialog should pop out and you would see the mappings listbox
  5. Find the entry for the ".axd" extension and edit it by clicking the "Edit" button
  6. In the new dialog uncheck the "Verify if file exist" checkbox - which I suspect is causing the problem.

Second approach

Alternatively, if the steps above don't solve the issue, you can try creating an empty WebResource.axd file in the site root folder.

Third approach

You can try setting UseEmbeddedScripts property to false. Thus the control will use the scripts from RadControls/Splitter/Scripts folder instead the embedded resource.

© 2002-2008 Telerik. All Rights Reserved.


Overview

Telerik RadSplitter v1.3 Send comments on this topic.
Overview
Features > Overview

Glossary Item Box

Splitter Elements

RadSplitter was designed to be as simple as possible, but yet powerful and flexible. It is rendered as a HTML table and that's why it can simulate any table design.

In order to add content to a RadSplitter control you need to add RadPane and RadSplitBar controls to its Items collection. Each RadPane control can also contain RadSplitter or other controls in its Controls collection. The RadSplitBar controls represent the borders which can be dragged in order to resize the panes. Each split bar can have up to two collapse buttons, used to collapse or expand the adjacent panes.

One of the most important specifics of each splitter is its orientation, which defines the orientation of its split bars. Each splitter can be either Horizontal or Vertical. If you want to create more complex structure you need to nest several splitters with different orientations. On the following screenshot are displayed two nested splitters. The outer splitter has Vertical orientation, the inner splitter has Horizontal orientation. The inner splitter is placed in the middle pane of the outer splitter. The visual elements are marked with arrows:

Defining the Splitter Structure

You can define the structure of RadSplitter in two ways:
  • Declaratively in the ASPX page (as in the example below)
  • Programatically in the code-behind

The visual appearance of RadSplitter is controlled by using Skins.

Example

The following example demonstrates how to configure a splitter to look like the screenshot above:

<rad:radsplitter runat="server" id="RadSplitter1"
  orientation="Vertical" width="400px" height="300px">
  <rad:radpane runat="server" id="LeftPane">
    <asp:label runat="server" id="LeftLabel">Left pane</asp:label>
  </rad:radpane>
  <rad:radsplitbar runat="server" id="RadSplitBar1" collapsemode="Backward" />
  <rad:radpane runat="server" id="MiddlePane">
    <rad:radsplitter runat="server" id="InnerSplitter" orientation="Horizontal">
      <rad:radpane runat="server" id="TopPane">Top Pane</rad:radpane>
      <rad:radsplitbar runat="server" id="RadSplitBar2" />
      <rad:radpane runat="server" id="BottomPane">Bottom Pane</rad:radpane>
    </rad:radsplitter>
  </rad:radpane>
  <rad:radsplitbar runat="server" id="RadSplitBar3" collapsemode="Both" />
  <rad:radpane runat="server" id="RightPane">Right pane</rad:radpane>
</rad:radsplitter>

© 2002-2008 Telerik. All Rights Reserved.


Splitter Orientation

Telerik RadSplitter v1.3 Send comments on this topic.
Splitter Orientation
Features > Splitter Orientation

Glossary Item Box

Setting Splitter Orientation

The Orientation property of the RadSplitter control defines the orientation of its split bars: the Horizontal orientation will render horizontal split bars, which can be moved up and down, the Vertical orientation will render vertical split bars, which can be moved left and right.

Example

The following example demonstrates how to create a splitter with horizontal split bars.

Note: If you want to create a splitter which contains both horizontal and vertical split bars you need to nest several splitters with different directions.

<rad:radsplitter runat="server" id="RadSplitter1" orientation="Horizontal">
 <rad:radpane runat="server" id="TopPane">Top pane</rad:radpane>
 <rad:radsplitbar runat="server" id="RadSplitBar1" />
 <rad:radpane runat="server" id="MiddlePane">Middle pane</rad:radpane>
 <rad:radsplitbar runat="server" id="RadSplitBar2" />
 <rad:radpane runat="server" id="BottomPane">Bottom pane</rad:radpane>
</rad:radsplitter>
You can also set the Orientation property of the splitter from the code-behind:
VB.NET

Imports Telerik.WebControls
...

Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
  If Not IsPostBack Then
    RadSplitter1.Orientation = RadSplitterOrientation.Horizontal
  End If
End Sub

C#

using Telerik.WebControls;
...

protected void Page_Load(object sender, EventArgs e)
{
  if (!IsPostBack)
  {
    RadSplitter1.Orientation = RadSplitterOrientation.Horizontal;
  }
}

The result of any of the code snippets will be:
Horizontal Splitter

© 2002-2008 Telerik. All Rights Reserved.


Resizing Panes

Telerik RadSplitter v1.3 Send comments on this topic.
Resizing Panes
Features > Resizing Panes

Glossary Item Box

Resize Mode

When the user drags а split bar, the panes in the splitter will be resized. Use the ResizeMode property of RadSplitter to define how and which the panes will be resized. There are three algorithms for resizing, implemented in RadSplitter:

  • AdjacentPane (default) - only the adjacent panes of the dragged split bar will be affected, e.g. if the split bar is moved to the left, the left adjacent pane width will be decreased and the right adjacent pane width will be increased.
  • EndPane - only the left (top) adjacent pane and the right (bottom) most pane will be affected, e.g. if the split bar is moved to the left, the left adjacent pane width will be decreased and the width of the right most pane in the splitter will be increased.
  • Proportional - all panes that are positioned in the direction where the split bar is moved will decrease their width (height), depending on their current width, and the pane that is adjacent in the oposite direction will increase its width (height).

Note: ResizeMode also affects how the panes are resized when the user collapses / expands them.

Resize Step

The ResizeStep property of RadSplitBar controls sets the step in pixels in which the split bars are snapped while dragging.

Defining Minimum and Maximum Size

You can define the minimum and the maximum allowed size in pixels of a RadPane control using its MinWidth, MaxWidth, MinHeight, MaxHeight properties. When a pane is resized horizontally (Vertical splitter orientation) RadSplitter will comply with its MinWidth and MaxWidth. When a pane is resized vertically (Horizontal splitter orientation) RadSplitter will comply with its MinHeight and MaxHeight.

Scrollbars

If the content of a pane exceeds its size, the RadPane control will display scrollbars. You can control which scrollbars will be displayed when this happen using the Scrolling property.

  • None - RadPane will never display scrollbars.
  • X - RadPane will display only horizontal scrollbar when the content exceeds its size
  • Y - RadPane will display only vertical scrollbar when the content exceeds its size
  • Both - RadPane will display both horizontal and vertical scrollbars when the content exceeds its size

Locked Panes

Use the Locked property of a RadPane to lock the pane. When a pane is locked its size remains unchanged during any of these operations:

  • Resize of the splitter
  • Resize of the panes regardless of the ResizeMode
  • Collapse / Expand of the panes

The size of a locked pane can be changed only from the client-side API when using the SetWidth or SetHeight methods of RadPane client-side object.

LiveResize

By default RadSplitter moves only the split bars when they are dragged. The panes are resized after the user releases the split bar. You can make RadSplitter resize the panes while the split bars are being dragged if you set the LiveResize property to true.

Example

The following example demonstrates how to set various properties of RadSplitter, RadPane and RadSplitBar:

<rad:radsplitter runat="server" id="RadSplitter1" resizemode="Proportional"
  orientation="Horizontal" width="300px" height="400px">
  <rad:radpane runat="server" id="TopPane" scrolling="Both" minheight="30" maxheight="300">
    Top pane<br />
    More content here to demonstrate the scrolling functionality of this pane<br />
    Even more content...
  </rad:radpane>
  <rad:radsplitbar runat="server" id="RadSplitBar1" resizestep="10" collapsemode="Backward" />
  <rad:radpane runat="server" id="MiddlePane">Middle pane</rad:radpane>
  <rad:radsplitbar runat="server" id="RadSplitBar2" collapsemode="Forward" />
  <rad:radpane runat="server" id="BottomPane" minheight="30">Bottom pane</rad:radpane>
</rad:radsplitter>

© 2002-2008 Telerik. All Rights Reserved.


Collapsible Panes

Telerik RadSplitter v1.3 Send comments on this topic.
Collapsible Panes
Features > Collapsible Panes

Glossary Item Box

Setting CollapseMode

Each pane can be collapsed if its adjacent split bars are configured to allow collapsing using their CollapseMode properties. You can define None (default), Forward, Backward and Both collapse modes. Depending on the value of the CollapseMode property the split bar will display up to two collapse buttons.

  • None - will not display collapse buttons, the adjacent panes will not be collapsible
  • Forward - depending on the Orientation property of the parent splitter, the split bar will display either left-to-right or top-to-bottom collapse button. When the user clicks this button, the left (top) adjacent pane will increase its size with the width (height) of the right (bottom) adjacent pane.
  • Backward - depending on the Orientation property of the parent splitter, the split bar will display either right-to-left or bottom-to-top collapse button. When the user clicks this button, the right (bottom) adjacent pane will increase its size with the width (height) of the left (top) adjacent pane.
  • Both - will display both buttons for Forward and Backward collapsing.

Note: the algorithm for collapsing of the panes depends on the ResizeMode property.

Note: if a pane is locked its size will not change even if the user clicks the collapse button of an adjacent split bar.

If a pane was collapsed by clicking a collapse button, this button will change its direction and will allow expanding.

Initialization

By default all panes will be expanded when the page loads for the first time. You can make a pane to be initially collapsed if you set its InitiallyCollapsed property to true.

Example

The following example demonstrates how to set the CollapseMode property of the RadSplitBar controls declaratively:

<rad:radsplitter runat="server" id="RadSplitter1"
  orientation="Vertical" width="400px" height="300px">
  <rad:radpane runat="server" id="LeftPane">
    <asp:label runat="server" id="LeftLabel">Left pane</asp:label>
  </rad:radpane>
  <rad:radsplitbar runat="server" id="RadSplitBar1" collapsemode="Backward" />
  <rad:radpane runat="server" id="MiddlePane">
    <rad:radsplitter runat="server" id="InnerSplitter" orientation="Horizontal">
      <rad:radpane runat="server" id="TopPane">Top Pane</rad:radpane>
      <rad:radsplitbar runat="server" id="RadSplitBar2" />
      <rad:radpane runat="server" id="BottomPane">Bottom Pane</rad:radpane>
    </rad:radsplitter>
  </rad:radpane>
  <rad:radsplitbar runat="server" id="RadSplitBar3" collapsemode="Both" />
  <rad:radpane runat="server" id="RightPane">Right pane</rad:radpane>
</rad:radsplitter>
The result will be:

© 2002-2008 Telerik. All Rights Reserved.


External Content

Telerik RadSplitter v1.3 Send comments on this topic.
External Content
Features > External Content

Glossary Item Box

Setting External Content

You can load any external url into a splitter pane if you specify its ContentUrl property.

If the content of a pane exceeds its size, the RadPane control will display scrollbars. You can control which scrollbars will be displayed when this happen using the Scrolling property.

If you want to use the pane with external content from the other links in your page you can set the target property of the link to be the same as the ClientID property of the pane that is used to display the external content.

Note: if you have any controls or text in a RadPane they will be discarded if you set the ContentUrl property.

Example

The following example demonstrates how to display external url in RadPane and how to change it with hyperlinks. Note that the "Middle pane" text will never be displayed:

<a href="http://www.telerik.com" target="<%= MiddlePane.ClientID %>">Telerik</a><br />
<a href="http://www.msn.com" target="<%= MiddlePane.ClientID %>">MSN</a><br />
<a href="http://www.google.com" target="<%= MiddlePane.ClientID %>">Google</a><br />

<rad:radsplitter runat="server" id="RadSplitter1"
  orientation="Horizontal" width="300px" height="400px">
  <rad:radpane runat="server" id="TopPane">Top pane</rad:radpane>
  <rad:radsplitbar runat="server" id="RadSplitBar1" />
  <rad:radpane runat="server" id="MiddlePane" contenturl="http://www.telerik.com">
    Middle pane</rad:radpane>
  <rad:radsplitbar runat="server" id="RadSplitBar2" />
  <rad:radpane runat="server" id="BottomPane">Bottom pane</rad:radpane>
</rad:radsplitter>

© 2002-2008 Telerik. All Rights Reserved.


Printing Pane Content

Telerik RadSplitter v1.3 Send comments on this topic.
Printing Pane Content
Features > Printing Pane Content

Glossary Item Box

Printing Panes

Telerik RadSplitter provides an interface to print the content of a pane using its client-side API.

If the pane has an external content the url must be from the same domain where is the splitter parent page, because otherwise it can not be printed due the security restrictions of the browsers.

If the pane is not displaying external content then you can specify a stylesheet which will be used to format the printed content.

Example

The following example demonstrates how to print the content of a pane:

<rad:radsplitter id="RadSplitter1" runat="server" height="200">
  <rad:radpane id="LeftPane" runat="server" width="120">
    <p>Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy
    eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam
    voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita
    kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem
    ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor
    invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos
    et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea
    takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet,
    consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et
    dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo
    duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est
    Lorem ipsum dolor sit amet.</p>
  </rad:radpane>
  <rad:radsplitbar id="RadSplitbar1" runat="server"/>
  <rad:radpane id="ExternalContentPane" runat="server" width="300" contenturl="Default.html" />
</rad:radsplitter>

<a href="javascript:PrintPane('<%= LeftPane.ClientID %>');">Print the content of 'Left Pane'</a><br />
<a href="javascript:PrintPane('<%= ExternalContentPane.ClientID %>');">Print the content of 'External Content Pane'</a>

<script type="text/javascript">
function PrintPane (paneID)
{
  var splitter = <%= RadSplitter1.ClientID%>;
  var pane = splitter.GetPaneById(paneID);

  if (!pane) return;

  var cssFileAbsPath = 'http://localhost/printStyles.css';
  var arrExtStylsheetFiles = [
    cssFileAbsPath
  ];

  pane.Print(arrExtStylsheetFiles);
}
</script>

© 2002-2008 Telerik. All Rights Reserved.


Persisting State

Telerik RadSplitter v1.3 Send comments on this topic.
Persisting State
Features > Persisting State

Glossary Item Box

General Principles

RadSplitter automatically persists its state across postbacks, so you do not need to reconfigure it every time to maintain the same appearance. Even if you change the values of the properties below using the client-side api, they will be persisted.

The following RadPane properties are persisted:

  • Width, Height - when the panes are resized using the mouse or the client-side API
  • MinWidth, MaxWidth, MinHeight, MaxHeight - when set using the client-side API
  • Collapsed state - when collapsed using the mouse or the client-side API
  • Locked - when set using the client-side API
  • Scroller positions - This is similar to the .NET framework's Smart Navigation, except it actually works. By default the pane will persist its scroller positions. You can disable the persisting by setting the PersistScrollPosition property of a RadPane control to false.
  • ContentUrl - if a RadPane control was initially configured to display external page and you change its ContentUrl property using the client-side API, the new value will be persisted across postbacks.

The properties above, except the scroller positions, will be updated server-side after a postback, so you can save them in a database or other storage medium if needed.

Example

The following example demonstrates how to save and load the state of all panes in a splitter:

<asp:button runat="server" id="SaveState" text="Save" onclick="SaveState_Click" />
<asp:button runat="server" id="LoadState" text="Load" onclick="LoadState_Click" />
<rad:radsplitter runat="server" id="RadSplitter1">
  <rad:radpane runat="server" id="RadPane1"></rad:radpane>
  <rad:radsplitbar runat="server" id="RadSplitBar1" />
  <rad:radpane runat="server" id="RadPane2"></rad:radpane>
</rad:radsplitter>

VB.NET

Imports Telerik.WebControls

Partial Class SaveState_DefaultVb
 Inherits System.Web.UI.Page

 Public Class PaneSettings
  Public Width As Unit
  Public Height As Unit
  Public MinWidth As Integer
  Public MinHeight As Integer
  Public MaxWidth As Integer
  Public MaxHeight As Integer
  Public InitiallyCollapsed As Boolean
  Public Locked As Boolean
  Public ContentUrl As String

  Private Sub New()
  End Sub

  Private Sub New(ByVal width As Unit, ByVal height As Unit, _
     ByVal minWidth As Integer, ByVal minHeight As Integer, _
     ByVal maxWidth As Integer, ByVal maxHeight As Integer, _
     ByVal initiallyCollapsed As Boolean, ByVal locked As Boolean, _
     ByVal contentUrl As String)
   Me.Width = width
   Me.Height = height
   Me.MinWidth = minWidth
   Me.MinHeight = minHeight
   Me.MaxWidth = maxWidth
   Me.MaxHeight = maxHeight
   Me.InitiallyCollapsed = initiallyCollapsed
   Me.Locked = locked
   Me.ContentUrl = contentUrl
  End Sub

  Public Shared Function GetSettings(ByVal pane As RadPane) As PaneSettings
   Dim paneSettings As New PaneSettings(pane.Width, pane.Height, _
     pane.MinWidth, pane.MinHeight, pane.MaxWidth, pane.MaxHeight, _
     pane.InitiallyCollapsed, pane.Locked, pane.ContentUrl)
   Return paneSettings
  End Function

  Public Sub SetSettings(ByVal pane As RadPane)
   pane.Width = Me.Width
   pane.Height = Me.Height
   pane.MinWidth = Me.MinWidth
   pane.MinHeight = Me.MinHeight
   pane.MaxWidth = Me.MaxWidth
   pane.MaxHeight = Me.MaxHeight
   pane.InitiallyCollapsed = Me.InitiallyCollapsed
   pane.Locked = Me.Locked
   pane.ContentUrl = Me.ContentUrl
  End Sub
 End Class

 Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)
 End Sub

 Protected Sub SaveState_Click(ByVal sender As Object, ByVal e As EventArgs)
  Dim settings As New Hashtable()
  Dim item As RadSplitterItem
  For Each item In RadSplitter1.Items
   If TypeOf item Is RadPane Then
    settings(item.ID) = PaneSettings.GetSettings(CType(item, RadPane))
   End If
  Next item
  Session("Settings") = settings
 End Sub

 Protected Sub LoadState_Click(ByVal sender As Object, ByVal e As EventArgs)
  Dim settings As Hashtable = CType(Session("Settings"), Hashtable)
  If Not (settings Is Nothing) Then
   Dim item As RadSplitterItem
   For Each item In RadSplitter1.Items
    If TypeOf item Is RadPane Then
     Dim paneSettings As PaneSettings = CType(settings(item.ID), PaneSettings)
     paneSettings.SetSettings(CType(item, RadPane))
    End If
   Next item
  End If
 End Sub

End Class

C#

public partial class _Default : System.Web.UI.Page
{
 public class PaneSettings
 {
  public Unit Width;
  public Unit Height;
  public int MinWidth;
  public int MinHeight;
  public int MaxWidth;
  public int MaxHeight;
  public bool InitiallyCollapsed;
  public bool Locked;
  public string ContentUrl;

  private PaneSettings()
  {
  }

  private PaneSettings(Unit width, Unit height, int minWidth,
   int minHeight, int maxWidth, int maxHeight,
   bool initiallyCollapsed, bool locked, string contentUrl)
  {
   Width = width;
   Height = height;
   MinWidth = minWidth;
   MinHeight = minHeight;
   MaxWidth = maxWidth;
   MaxHeight = maxHeight;
   InitiallyCollapsed = initiallyCollapsed;
   Locked = locked;
   ContentUrl = contentUrl;
  }

  public static PaneSettings GetSettings(RadPane pane)
  {
   PaneSettings paneSettings = new PaneSettings(
    pane.Width,
    pane.Height,
    pane.MinWidth,
    pane.MinHeight,
    pane.MaxWidth,
    pane.MaxHeight,
    pane.InitiallyCollapsed,
    pane.Locked,
    pane.ContentUrl);
   return paneSettings;
  }

  public void SetSettings(RadPane pane)
  {
   pane.Width = this.Width;
   pane.Height = this.Height;
   pane.MinWidth = this.MinWidth;
   pane.MinHeight = this.MinHeight;
   pane.MaxWidth = this.MaxWidth;
   pane.MaxHeight = this.MaxHeight;
   pane.InitiallyCollapsed = this.InitiallyCollapsed;
   pane.Locked = this.Locked;
   pane.ContentUrl = this.ContentUrl;
  }
 }

 protected void Page_Load(object sender, EventArgs e)
 {

 }

 protected void SaveState_Click(object sender, EventArgs e)
 {
  Hashtable settings = new Hashtable();
  foreach (RadSplitterItem item in RadSplitter1.Items)
  {
   if (item is RadPane)
   {
    settings[item.ID] = PaneSettings.GetSettings((RadPane)item);
   }
  }
  Session["Settings"] = settings;
 }

 protected void LoadState_Click(object sender, EventArgs e)
 {
  Hashtable settings = (Hashtable)Session["Settings"];
  if (settings != null)
  {
   foreach (RadSplitterItem item in RadSplitter1.Items)
   {
    if (item is RadPane)
    {
     PaneSettings paneSettings = (PaneSettings)settings[item.ID];
     paneSettings.SetSettings((RadPane)item);
    }
   }
  }
 }
}

© 2002-2008 Telerik. All Rights Reserved.


Height 100% (Fill Container)

Telerik RadSplitter v1.3 Send comments on this topic.
Height 100% (Fill Container)
Features > Height 100% (Fill Container)

Glossary Item Box

Overview

A common scenario is the use of RadSplitter to split the whole page, or only a part or a page with variable size. To do this you need to set Width and Height properties to 100%. However, you can encounter problems or strange behavior.

In order to achieve the expected behavior from RadSplitter you need to set the height of all of its parent elements explicitly:

  • <html style="height:100%;">
  • <body style="height:100%;margin:0px;"> - you need to set the margin of the body tag to 0px if you want the splitter to fill the entire page. The default margin of the body is 5 pixels.
  • <form style="height:100%">

Optional setting

  • <body scroll="no"> - this will remove the page scrollers and will bring the application as close as possible to a desktop application.

Example

The following example demonstrates how to configure RadSplitter to fill the entire page and to achieve consistent behavior by setting the height of all of its parent elements. The example is cross browser compatible!

<%@ Page language="c#" AutoEventWireup="false" %>
<%@ Register TagPrefix="rad" Namespace="Telerik.WebControls" Assembly="RadSplitter.Net2" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/tr/xhtml11/dtd/xhtml11.dtd">
<html style="height:100%">
    <head>
        <title>FullWindow</title>
    </head>
    <body style="margin:0px;height:100%;" scroll="no">
        <form id="Form1" method="post" runat="server" style="height:100%" >
            <rad:radsplitter id="RadSplitter1" runat="server"
                height="100%" width="100%">
                <rad:radpane id="LeftPane" runat="server" Width="100px">
                    Left Pane
                </rad:radpane>
                <rad:radsplitbar id="RadSplitBar1" runat="server" />
                <rad:radpane id="RightPane" runat="server" >
                    Right Pane
                </rad:radpane>
            </rad:radsplitter>
        </form>
    </body>
</html>

© 2002-2008 Telerik. All Rights Reserved.


Overview

Telerik RadSplitter v1.3 Send comments on this topic.
Overview
Features > Sliding Panes > Overview

Glossary Item Box

Sliding Elements

RadSlidingZone and RadSlidingPane provide the ability to create sliding panes in your splitter cotnrol, just like the user interface of Visual Studio.

The visual elements of the sliding panes and zones are:

  • Sliding Zone - this is the left (right / top / bottom) most area of the screen. Contains Sliding Zone Tabs for each Sliding Pane.
  • Sliding Pane - a special pane which by default will be collapsed and can be expanded by clicking or moving the mouse over a sliding zone tab. The sliding panes can be docked (permanently expanded) by clicking the Dock / Undock button.
You can define both vertical and horizontal sliding zones.

Defining Structure

You can define sliding zones and panes in two ways:

  • Declaratively in the ASPX page (as in the example below)
  • Programmatically in the code-behind

The visual appearance of the sliding zones is controlled by using Skins

Example

The following demonstrates how to configure a splitter to look like the screenshot above.

<rad:radsplitter id="Radsplitter1" runat="server" height="300" width="400">
 <rad:radpane id="LeftPane" runat="server" width="22">
  <rad:radslidingzone id="RadSlidingZone1" runat="server" width="22">
   <rad:radslidingpane id="PropertiesPane" title="Properties" runat="server" width="150"
    tabview="ImageOnly" iconurl="Properties.gif">
    Properties</rad:radslidingpane>
   <rad:radslidingpane id="ControlPanelPane" title="Control Panel" runat="server"
    width="250" tabview="ImageOnly" iconurl="ControlPanel.gif">
    Control Panel
   </rad:radslidingpane>
   <rad:radslidingpane id="LoginPane" title="Login" runat="server" width="150"
    tabview="ImageOnly" iconurl="Login.gif">
    Login
   </rad:radslidingpane>
  </rad:radslidingzone>
 </rad:radpane>
 <rad:radsplitbar id="RadSplitBar1" runat="server"></rad:radsplitbar>
 <rad:radpane id="MainPane" runat="server">
  Main Pane</rad:radpane>
</rad:radsplitter>

© 2002-2008 Telerik. All Rights Reserved.


Slide Direction

Telerik RadSplitter v1.3 Send comments on this topic.
Slide Direction
Features > Sliding Panes > Slide Direction

Glossary Item Box

Setting Slide Direction

The SlideDirection property of the RadSlidingZone control defines the direction in which the RadSlidingPanes will slide open:

  • The Right direction(default when the Orientation of the RadSplitter is Vertical) configures the RadSlidingPanes to slide from left to right.
  • The Left direction configures the RadSlidingPanes to slide from right to left.
  • The Bottom direction(default when the Orientation of the RadSplitter is Horizontal) configures the RadSlidingPanes to slide from top to bottom.
  • The Top direction configures the RadSlidingPanes to slide from bottom to top.

Example

The following example demonstrates how to create RadSlidingZones with bottom and top slide direction.

<rad:radsplitter id="Radsplitter2" Skin="Default" runat="server" height="400" width="700"
 Orientation="Horizontal">
 <rad:radpane id="Radpane1" runat="server" height="22" scrolling="none">
  <rad:radslidingzone id="Radslidingzone2" runat="server" height="22"
   SlideDirection="Bottom">
   <rad:radslidingpane id="Radslidingpane4" title="Pane1" runat="server" height="150">
    Pane1</rad:radslidingpane>
   <rad:radslidingpane id="Radslidingpane5" title="Pane2" runat="server" height="150">
    Pane2</rad:radslidingpane>
   <rad:radslidingpane id="Radslidingpane6" title="Pane3" runat="server" height="150">
    Pane3</rad:radslidingpane>
  </rad:radslidingzone>
 </rad:radpane>
 <rad:radsplitbar id="Radsplitbar3" runat="server"></rad:radsplitbar>
 <rad:radpane id="Radpane2" runat="server">Main Pane</rad:radpane>
 <rad:radsplitbar id="Radsplitbar4" runat="server"></rad:radsplitbar>
 <rad:radpane id="Radpane3" runat="server" height="22" scrolling="none">
  <rad:radslidingzone id="Radslidingzone3" runat="server" height="22"
   slidedirection="Top" initiallydockedpaneid="Radslidingpane8">
   <rad:radslidingpane id="Radslidingpane7" title="Pane1" runat="server" height="150">
    Pane1 </rad:radslidingpane>
   <rad:radslidingpane id="Radslidingpane8" title="Pane2" runat="server" height="150">
    Pane2</rad:radslidingpane>
   <rad:radslidingpane id="Radslidingpane9" title="Pane3" runat="server" height="150">
    Pane3</rad:radslidingpane>
  </rad:radslidingzone>
 </rad:radpane>
</rad:radsplitter>
The result of the code snippet will be:
Slide Direction

© 2002-2008 Telerik. All Rights Reserved.


Changes and backward compatibility

Telerik RadSplitter v1.3 Send comments on this topic.
Changes and backward compatibility
Changes and backward compatibility > Changes and backward compatibility

Glossary Item Box

Telerik RadSplitter v1.2

There are no major changes and the product is fully backwards compatible.

© 2002-2008 Telerik. All Rights Reserved.


Features Overview

Telerik RadSplitter v1.3 Send comments on this topic.
Features Overview
New to RadSplitter? > Features Overview

Glossary Item Box

This topic outlines the most important general features of Telerik RadSplitter 1.0

Compatibility and Compliance Features

  1. Wide cross-browser support
    Telerik RadSplitter supports all major browsers and platforms (both on PC and Mac, where applicable):
        • Internet Explorer 5.5+;
        • all Gecko-based browsers - Mozilla 1.0+, FireFox, Netscape 7+;
        • Opera 8.0+.
        • Safari 1.2+
  2. Support for ASP.NET 2.0 and Visual Studio 2005
    Telerik RadSplitter can run under both ASP.NET 1.x and ASP.NET 2.x. The control is compiled against both Visual Studio 2003 and 2005 (thus offering new specific features for Microsoft's next-generation IDE, Visual Studio .NET 2005).
  3. Standards Compliance
    In conformance with the W3C Web Accessibility Guidelines 1.0, Telerik RadSplitter is level AA compliant. The default HTML output is fully XHTML 1.1 compliant.

Functionality

  • Horizontal or Vertical Orientation. Nest splitters to get any orientation combination!
  • Content Resizing. Drag a split bar to resize the content of the panes! You can define min/max size and resize step.
  • Pane Collapsing / Expanding. Click the collapse buttons on a split bar to collapse/expand its adjacent panes!
  • External Content support. Load any URL in any pane!
  • Content Printing. Use the client-side API to print the content of any pane!
  • Sliding Panes. Add sliding zones and panes to simulate the Visual Studio user interface!
  • State Persistence. RadSplitter will persist its state and scroller positions across postbacks!
  • Resizing with the browser and ability to fill its container automatically!

Defining the Splitter Structure

You can define the structure of RadSplitter in two ways:
  • Declaratively in the ASPX page (as in the example below)
  • Programatically in the code-behind

The visual appearance of RadSplitter is controlled by using Skins.

© 2002-2008 Telerik. All Rights Reserved.


Simple Example

Telerik RadSplitter v1.3 Send comments on this topic.
Simple Example
New to RadSplitter? > Getting Started > Simple Example

Glossary Item Box

Creating a simple Telerik RadSplitter

If you are new to Telerik RadSplitter, in this topic you will find helpful tips for adding a simple Telerik RadSplitter instance to a page.

  1. Drag and drop a Telerik RadSplitter instance onto the page

  2. Drag and drop a Telerik RadSplitter pane instance onto the RadSplitter

  3. Drag and drop a Telerik RadSplitter split bar instance onto the RadSplitter

  4. Drag and drop a second Telerik RadSplitter pane instance onto the RadSplitter

  5. In the Telerik RadSplitter pane properties grid, set the ContentUrl

  6. Add content to the first RadPane

  7. In the HyperLink properties grid set the Target to the ID of the second RadPane and the NavigateUrl.

  8. The final result is looks like:

  9. The result after you click the HyperLink looks like:

© 2002-2008 Telerik. All Rights Reserved.


Defining Declaratively

Telerik RadSplitter v1.3 Send comments on this topic.
Defining Declaratively
Defining RadSplitter structure > Defining Declaratively

Glossary Item Box

Declarative Syntax

With RadSplitter you can define any table structure.

  • Simple splitters - using one splitter you can define horizontally or vertically split page or area in a page.
  • Complex splitters - you can define complex structures using several nested splitters to provide both horizontally and vertically split page or areas in a page.

Simple Structures with a Single Splitter

The easiest way to define the RadSplitter structure is declaratively in the ASPX page. The example below demonstrates how to create a Vertical splitter with three collapsable panes and split bars with different CollapseMode:

<rad:radsplitter runat="server" id="RadSplitter1"
  orientation="Vertical" width="400px" height="300px">
  <rad:radpane runat="server" id="LeftPane">
    <asp:label runat="server" id="LeftLabel">Left pane</asp:label>
  </rad:radpane>
  <rad:radsplitbar runat="server" id="RadSplitBar1" collapsemode="Backward" />
  <rad:radpane runat="server" id="MidPane">Middle pane</rad:radpane>
  <rad:radsplitbar runat="server" id="RadSplitBar2" collapsemode="Both" />
  <rad:radpane runat="server" id="RightPane">Right pane</rad:radpane>
</rad:radsplitter>
The result will look like this:

© 2002-2008 Telerik. All Rights Reserved.


Defining With Code

Telerik RadSplitter v1.3 Send comments on this topic.
Defining With Code
Defining RadSplitter structure > Defining With Code

Glossary Item Box

Creating Splitter Controls Programmatically

You can define the structure of RadSplitter with code. To do that you need to create RadPane and RadSplitBar objects and add them to the Items collection of their parent RadSplitter.

Note: The Items collection is not persisted in the ViewState and if you create the splitter controls in the code-behind you need to recreate them on every postback!

Example

The example below demonstrates how to create new RadSplitter object, populate its Items collection and add it to the page form. It also shows how to add a dynamically created label in the Controls collection of a RadPane control:

VB.NET

Imports Telerik.WebControls
...
Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs) Handles Me.Load
  Dim splitter As New RadSplitter()
  splitter.ID = "RadSplitter1"
  splitter.Width = New Unit("300px")
  splitter.Height = New Unit("400px")
  splitter.Orientation = RadSplitterOrientation.Horizontal

  Dim topPane As New RadPane()
  topPane.ID = "TopPane"
  Dim topLabel As New Label()
  topLabel.ID = "TopLabel"
  topLabel.Text = "Top pane"
  topPane.Controls.Add(topLabel)
  splitter.Items.Add(topPane)

  Dim splitBar1 As New RadSplitBar()
  splitBar1.ID = "SplitBar1"
  splitter.Items.Add(splitBar1)

  Dim middlePane As New RadPane()
  middlePane.ID = "MiddlePane"
  middlePane.Controls.Add(New LiteralControl("Middle pane"))
  splitter.Items.Add(middlePane)

  Dim splitBar2 As New RadSplitBar()
  splitBar2.ID = "SplitBar2"
  splitter.Items.Add(splitBar2)

  Dim bottomPane As New RadPane()
  bottomPane.ID = "BottomPane"
  bottomPane.Controls.Add(New LiteralControl("Bottom pane"))
  splitter.Items.Add(bottomPane)

  form1.Controls.Add(splitter)
End Sub

C#

using Telerik.WebControls;
...
protected void Page_Load(object sender, EventArgs e)
{
  RadSplitter splitter = new RadSplitter();
  splitter.ID = "RadSplitter1";
  splitter.Width = new Unit("300px");
  splitter.Height = new Unit("400px");
  splitter.Orientation = RadSplitterOrientation.Horizontal;

  RadPane topPane = new RadPane();
  topPane.ID = "TopPane";
  Label topLabel = new Label();
  topLabel.ID = "TopLabel";
  topLabel.Text = "Top pane";
  topPane.Controls.Add(topLabel);
  splitter.Items.Add(topPane);

  RadSplitBar splitBar1 = new RadSplitBar();
  splitBar1.ID = "SplitBar1";
  splitter.Items.Add(splitBar1);

  RadPane middlePane = new RadPane();
  middlePane.ID = "MiddlePane";
  middlePane.Controls.Add(new LiteralControl("Middle pane"));
  splitter.Items.Add(middlePane);

  RadSplitBar splitBar2 = new RadSplitBar();
  splitBar2.ID = "SplitBar2";
  splitter.Items.Add(splitBar2);

  RadPane bottomPane = new RadPane();
  bottomPane.ID = "BottomPane";
  bottomPane.Controls.Add(new LiteralControl("Bottom pane"));
  splitter.Items.Add(bottomPane);

  form1.Controls.Add(splitter);
}

The result will look like this:
Horizontal Splitter

© 2002-2008 Telerik. All Rights Reserved.


Nested Splitters

Telerik RadSplitter v1.3 Send comments on this topic.
Nested Splitters
Defining RadSplitter structure > Nested Splitters

Glossary Item Box

Complex Structures with Nested Splitters

You can define more complex structures, containing both horizontal and vertical split bars if you nest several splitters:

<rad:radsplitter runat="server" id="RadSplitter1"
  orientation="Vertical" width="400px" height="300px">
  <rad:radpane runat="server" id="LeftPane">
    <asp:label runat="server" id="LeftLabel">Left pane</asp:label>
  </rad:radpane>
  <rad:radsplitbar runat="server" id="RadSplitBar1" collapsemode="Backward" />
  <rad:radpane runat="server" id="MiddlePane">
    <rad:radsplitter runat="server" id="InnerSplitter" orientation="Horizontal">
      <rad:radpane runat="server" id="TopPane">Top Pane</rad:radpane>
      <rad:radsplitbar runat="server" id="RadSplitBar2" />
      <rad:radpane runat="server" id="BottomPane">Bottom Pane</rad:radpane>
    </rad:radsplitter>
  </rad:radpane>
  <rad:radsplitbar runat="server" id="RadSplitBar3" collapsemode="Both" />
  <rad:radpane runat="server" id="RightPane">Right pane</rad:radpane>
</rad:radsplitter>
The result will be:

© 2002-2008 Telerik. All Rights Reserved.


Fixed Layouts

Telerik RadSplitter v1.3 Send comments on this topic.
Fixed Layouts
Defining RadSplitter structure > Fixed Layouts

Glossary Item Box

Sometimes it is necessary to create a splitter with nonresizable panes. This can be achieved by placing only RadPane controls in the splitter Items collection. If you need to do some changes to the panes runtime, such as rezising or collapsing, you will have to use the client-side API.

Note: The borders of the panes can be removed by changing the splitter skin.

© 2002-2008 Telerik. All Rights Reserved.


Defining Declaratively

Telerik RadSplitter v1.3 Send comments on this topic.
Defining Declaratively
Defining RadSplitter structure > Sliding Panes > Defining Declaratively

Glossary Item Box

Declarative Syntax

To declare a sliding zone you need to put a RadSlidingZone control into a regular RadPane. Then add as may as you want RadSlidingPane controls to the Items collection of the sliding zone.

Example

The following example demonstrates how to declare left and right sliding zones, contaning three sliding panes each

<rad:radsplitter id="Radsplitter1" runat="server" height="300" width="400">
 <rad:radpane id="LeftPane" runat="server" width="22">
  <rad:radslidingzone id="LeftSlidingZone" runat="server" width="22">
   <rad:radslidingpane id="LeftSlidingPane1" title="Left1" runat="server"
    width="150">Left1</rad:radslidingpane>
   <rad:radslidingpane id="LeftSlidingPane2" title="Left2" runat="server"
    width="250">Left2</rad:radslidingpane>
   <rad:radslidingpane id="LeftSlidingPane3" title="Left3" runat="server"
    width="150">Left3</rad:radslidingpane>
  </rad:radslidingzone>
 </rad:radpane>
 <rad:radsplitbar id="RadSplitBar1" runat="server"></rad:radsplitbar>
 <rad:radpane id="MiddlePane" runat="server">Middle Pane</rad:radpane>
 <rad:radsplitbar id="RadSplitBar2" runat="server"></rad:radsplitbar>
 <rad:radpane id="RightPane" runat="server" width="22">
  <rad:radslidingzone id="RightSlidingZone" runat="server" width="22" slidedirection="left" >
   <rad:radslidingpane id="RightSlidingPane1" title="Right1" runat="server"
    width="150">Right1</rad:radslidingpane>
   <rad:radslidingpane id="RightSlidingPane2" title="Right2" runat="server"
    width="250">Right2</rad:radslidingpane>
   <rad:radslidingpane id="RightSlidingPane3" title="Right3" runat="server"
    width="150">Right3</rad:radslidingpane>
  </rad:radslidingzone>
 </rad:radpane>
</rad:radsplitter>

The result will be:

© 2002-2008 Telerik. All Rights Reserved.


Defining Programmatically

Telerik RadSplitter v1.3 Send comments on this topic.
Defining Programmatically
Defining RadSplitter structure > Sliding Panes > Defining Programmatically

Glossary Item Box

Creating Sliding Panes Programmatically

You can create sliding panes with code. To do that you need to create RadSlidingZone controls and add them to the Controls collection of existing RadPane controls. Then create RadSlidingPane controls and add them to the Items collections of the RadSlidingZone controls.

Note: The Items collections are not persisted in the ViewState and if you create the splitter controls in the code-behind you need to recreate them on every postback!

Example

The example below demonstrates how to declare left and right sliding zones, contaning two sliding panes each. Note that you can create the RadSplitter programmatically instead of declaring it in the ASPX page.

ASPX

<rad:radsplitter id="Radsplitter1" runat="server" height="300" width="400">
 <rad:radpane id="LeftPane" runat="server" width="22" />
 <rad:radsplitbar id="RadSplitBar1" runat="server" />
 <rad:radpane id="MiddlePane" runat="server">Middle Pane</rad:radpane>
 <rad:radsplitbar id="RadSplitBar2" runat="server" />
 <rad:radpane id="RightPane" runat="server" width="22" />
</rad:radsplitter>

VB.NET

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs) Handles Me.Load
  Dim leftZone As New RadSlidingZone()
  leftZone.ID = "LeftZone"
  leftZone.Width = LeftPane.Width

  Dim leftSlidingPane1 As New RadSlidingPane()
  leftSlidingPane1.ID = "LeftSlidingPane1"
  leftSlidingPane1.Title = "Left1"
  leftSlidingPane1.Width = New Unit(150)
  leftZone.Items.Add(leftSlidingPane1)

  Dim leftSlidingPane2 As New RadSlidingPane()
  leftSlidingPane2.ID = "LeftSlidingPane2"
  leftSlidingPane2.Title = "Left2"
  leftSlidingPane2.Width = New Unit(150)
  leftZone.Items.Add(leftSlidingPane2)

  LeftPane.Controls.Add(leftZone)

  Dim rightZone As New RadSlidingZone()
  rightZone.ID = "RightZone"
  rightZone.SlideDirection = RadSplitterSlideDirection.Left
  rightZone.Width = LeftPane.Width

  Dim rightSlidingPane1 As New RadSlidingPane()
  rightSlidingPane1.ID = "RightSlidingPane1"
  rightSlidingPane1.Title = "Right1"
  rightSlidingPane1.Width = New Unit(150)
  rightZone.Items.Add(rightSlidingPane1)

  Dim rightSlidingPane2 As New RadSlidingPane()
  rightSlidingPane2.ID = "RightSlidingPane2"
  rightSlidingPane2.Title = "Right2"
  rightSlidingPane2.Width = New Unit(150)
  rightZone.Items.Add(rightSlidingPane2)

  RightPane.Controls.Add(rightZone)
 End Sub

C#

protected void Page_Load(object sender, EventArgs e)
{
  RadSlidingZone leftZone = new RadSlidingZone();
  leftZone.ID = "LeftZone";
  leftZone.Width = LeftPane.Width;

  RadSlidingPane leftSlidingPane1 = new RadSlidingPane();
  leftSlidingPane1.ID = "LeftSlidingPane1";
  leftSlidingPane1.Title = "Left1";
  leftSlidingPane1.Width = new Unit(150);
  leftZone.Items.Add(leftSlidingPane1);

  RadSlidingPane leftSlidingPane2 = new RadSlidingPane();
  leftSlidingPane2.ID = "LeftSlidingPane2";
  leftSlidingPane2.Title = "Left2";
  leftSlidingPane2.Width = new Unit(150);
  leftZone.Items.Add(leftSlidingPane2);

  LeftPane.Controls.Add(leftZone);

  RadSlidingZone rightZone = new RadSlidingZone();
  rightZone.ID = "RightZone";
  rightZone.SlideDirection = RadSplitterSlideDirection.Left;
  rightZone.Width = LeftPane.Width;

  RadSlidingPane rightSlidingPane1 = new RadSlidingPane();
  rightSlidingPane1.ID = "RightSlidingPane1";
  rightSlidingPane1.Title = "Right1";
  rightSlidingPane1.Width = new Unit(150);
  rightZone.Items.Add(rightSlidingPane1);

  RadSlidingPane rightSlidingPane2 = new RadSlidingPane();
  rightSlidingPane2.ID = "RightSlidingPane2";
  rightSlidingPane2.Title = "Right2";
  rightSlidingPane2.Width = new Unit(150);
  rightZone.Items.Add(rightSlidingPane2);

  RightPane.Controls.Add(rightZone);
}

© 2002-2008 Telerik. All Rights Reserved.


Skins

Telerik RadSplitter v1.3 Send comments on this topic.
Skins
Controlling the visual appearance > Skins

Glossary Item Box

The visual appearance of Telerik RadSplitter is completely controlled with skins.

To select a skin, set the Skin property of the RadSplitter class.

Telerik RadSplitter is installed with a number of preset skins. You can tweak the existing skins, or create your own.

Predefined skins are located in ~/RadControls/Splitter/Skins. To use predefined skins, you need to add the RadControls folder to the root of your web application.If you intend to use skins other than the default, you need to add the RadControls folder to the root of your web application.

Creating custom skins

The fastest way to get started with your own custom skin is by modifying an existing skin. From http://www.telerik.com/skins, you can download all resources necessary to deploy or modify selected skins for the Telerik components. Each skin archive contains the images and the CSS file needed to apply a skin in your project, as well as the original Adobe Photoshop PSD source file you will need to modify the design. For more instructions, please refer to the Readme file in the skin archive.

Organization of skin files and folders

The default location of the Telerik RadSplitter skins is RadControls/Splitter/Skins. Each skin folder contains:

  • Img/ - the sub-folder where the skin images are stored;
  • styles.css - the stylesheet of the skin.
  • nested.css - shared stylesheet used for the nested splitters.

Naming conventions

Upon creating a new skin, have in mind that the folder where the new skin is stored is named after the skin itself. Also, within the Styles.css document, to all classes should be appended a suffix with an underscore and the name of the new skin. For example:

.RadSplitter_MyCustomSkinName
{
    border: 1px solid red;
}

© 2002-2008 Telerik. All Rights Reserved.


Interoperability of Telerik RadSplitter with RadAjax

Telerik RadSplitter v1.3 Send comments on this topic.
Interoperability of Telerik RadSplitter with RadAjax
AJAX Support > Interoperability of Telerik RadSplitter with RadAjax

Glossary Item Box

Remark: The built-in AJAX functionality in telerik RadGrid, RadCombobox, RadTeeview has a higher priority than telerik RadAjax. You should turn it off in order to update outside controls and use AJAX Panel or AJAX Manager.
Important note: telerik RadUpload is unable to upload files with an Ajax call. This is related to the inability of the XmlHttpRequest component to upload files. This component is the core of any Ajax framework, such as telerik RadAjax or Atlas (AJAX extensions for ASP.NET).

Telerik RadSplitter is designed for seamless interoperability with the Telerik AJAX framework, the RadAjax suite enabling developers to implement the following functionality:

  • AJAXify (AJAX-enable) telerik RadSplitter to work with AJAX instead of regular postbacks;
  • Update the telerik RadSplitter control upon an AJAX request made by a control on the page via telerik RadAjax;
  • Make telerik RadSplitter initiate an AJAX request in order to update other controls on the page.

Make telerik RadSplitter work with AJAX requests (Ajax-enable Telerik RadSplitter)

You can ajaxify any member of the telerik RadControls for ASP.NET suite. The ajax-enabled control will work in AJAX mode and will perform callback requests instead of regular postbacks.

To do so, you have two possible options:

  • place the instance of RadSplitter into an AjaxPanel - in this case, the control will update itself and all other controls in the panel via AJAX request
  • place one AJAX Manager on the page and in its property builder set the AJAX pair, i.e. AJAX initiator and the updated control. In this case, as we want Telerik RadSplitter to update itself with AJAX, it should be set as initiator and updated control.

Update telerik RadSplitter upon AJAX request

Telerik RadSplitter is fully compatible with the telerik RadAjax suite and can be updated via callbacks from any other control on the page without any additional coding. You have two possible options:

  • You need to have the AJAX Manager on the page and set the AJAX pair - AJAX initiator and the updated control (telerik RadSplitter in this case). We recommend you do this using the visual editor in VS.NET.
  • Alternatively you can place telerik RadSplitter in AJAX Panel together with the control that should update it.

Initiate an AJAX request and update other controls with Telerik RadSplitter

You may want to initiate a callback request by telerik RadSplitter and update other controls on the page.

To implement this functionality, you need to do the following:

  • Place AJAX Manager on the page. Open its property builder and set the AJAX pair. In this case Telerik RadSplitter will be the AJAX initiator. You can set as many controls as you wish to be updated by a single request.

OR

  • Place both controls (telerik RadSplitter and the control that should be updated) in AJAX Panel. telerik RadSplitter will automatically start updating all controls in the panel (including itself) with AJAX requests.

More integration examples of telerik RadAjax with the other controls from the telerik RadControls for ASP.NET suite can be seen here.

© 2002-2008 Telerik. All Rights Reserved.


Splitter panes AJAX support

Telerik RadSplitter v1.3 Send comments on this topic.
Splitter panes AJAX support
AJAX Support > Splitter panes AJAX support

Glossary Item Box

Splitter Sliding Panes, Panes and SplitBars can not be updated directly with the Ajax Manager control.

When you want to update a RadPane (or RadSlidingPane) contents just add an asp:panel control (or any other container control that runs on the server) inside the pane and update the container control instead the RadPane (or RadSlidingPane).

When you want to change the RadSlidingPane, RadPane or RadSplitBar properties - you can do it with the client-side API or you should update the whole Splitter (or RadSlidingZone) with the Ajax Manager control or with Ajax Panel control.

© 2002-2008 Telerik. All Rights Reserved.


ASP.NET AJAX Framework

Telerik RadSplitter v1.3 Send comments on this topic.
ASP.NET AJAX Framework
AJAX Support > ASP.NET AJAX Framework

Glossary Item Box

Show All Show All
Hide All Hide All

All Telerik controls now provide full support for the new ASP.NET AJAX framework.
Telerik's own patent-pending AJAX mechanism does not interfere in any way with the ASP.NET AJAX framework. Telerik RadAjax, as well as all built-in AJAX features of Telerik RadControls for ASP.NET work with ASP.NET AJAX without any conflict.

To enable ASP.NET AJAX with Telerik RadSplitter:

  1. Make sure you have the ASP.NET AJAX framework installed.
  2. If the control is initially invisible and is shown after an ASP.NET AJAX update, you should manually register all the required CSS files in the head tag of your page. Otherwise the control will not be displayed correctly. The easiest way to do this is through a LINK element:
    Copy Code
    <link href="~/RadControls/Splitter/Skins/[SkinName]/styles.css" rel="stylesheet" runat="server" >
  3. Place the instance of Telerik RadSplitter in an ASP.NET AJAX UpdatePanel.

To enable or disable the ASP.NET AJAX UpdatePanel, set the EnablePartialRendering property of the ScriptManager class to True or False accordingly.

Grid built-in AJAX has higher priority than external AJAX frameworks - ASP.NET AJAX and RadAjax. In case one need the Grid to be updated from an ASP:UpdatePanel, Grid's EnableAJAX should be turned off.

ASP.NET AJAX is not a Telerik product.
For further information about ASP.NET AJAX, refer to ASP.NET AJAX documentation .

Known problems related to ASP.NET AJAX interoperability

Exceptions

If you receive exceptions such as:

System.Web.HttpException: The Controls collection cannot be modified because the control contains code blocks (i.e. <% ... %>)

you need to move the code block outside of the head tag. For example:

Before: Copy Code
<head runat="server">
<script>
var controlClientObject = <%= RadControl1.ClientID %>
...
</script>
</head>

<body>
...
</body>
After: Copy Code
<head runat="server">
</head>
<body>
<script>
var controlClientObject = <%= RadControl1.ClientID %>
...
</script>
...
</body>

© 2002-2008 Telerik. All Rights Reserved.


Basics

Telerik RadSplitter v1.3 Send comments on this topic.
Basics
Client-Side API Reference > Basics

Glossary Item Box

Telerik RadSplitter provides a flexible client-side API. You can easily interact with the splitter in the browser using the splitter client-side object.

1. Getting the RadSplitter client-side object

RadSplitter creates a client-side object with the ClientID of the splitter. You can obtain the reference using the following JavaScript code:

var splitter = <%= RadSplitter1.ClientID %>;

2. Getting the instance of a particular RadPane

Once you get the client-side object of RadSplitter, you can use the GetPaneById() method to get the instance of a particular pane. Example:

var splitter = <%= RadSplitter1.ClientID %>;
var pane = splitter.GetPaneById(paneID);

3. Getting the instance of a particular RadSlidingZone

RadSlidingZone creates a client-side object with the ClientID of the sliding zone. You can obtain the reference using the following JavaScript code:

var slidingZone = <%= RadSlidingZone1.ClientID %>;

4. Getting the instance of a particular RadSlidingPane

Once you get the client-side object of RadSlidingZone, you can use the GetPaneById() method to get the instance of a particular sliding pane. Example:

var slidingZone = <%= RadSlidingZone1.ClientID %>;
var slidingPane = slidingZone.GetPaneById(paneID);

5. Calling a client-side method

When you get the instance of a particular item, you can call a client-side method to perform a task. Consider the following examples:

function CollapsePane()
{
    var splitter = <%= Radsplitter1.ClientID %>;
    var pane = splitter.GetPaneById(paneId);
    if (pane)
    {
        pane. Lock();
    }
    else
    {
        alert( "Pane with ID '" + paneId + "' not found.");
    }
}

The code block <%= ... %> needs to be placed inside the BODY element of the page. See Atlas support for details.

© 2002-2008 Telerik. All Rights Reserved.


RadSplitter client object

Telerik RadSplitter v1.3 Send comments on this topic.
RadSplitter client object
Client-Side API Reference > RadSplitter client object

Glossary Item Box

Methods

Name

Parameters

Return Type

Description

GetWidth | none | integer | Return the splitter's width
GetHeight | none | integer | Return the splitter's height
GetHeightOffset | none | integer | Return the splitter's HeightOffset
SetWidth | (integer width) | none | Set splitter's width
SetHeight | (integer height) | none | Set splitter's height
SetHeightOffset | (integer HeightOffset) | none | Set splitter's HeightOffset
GetInnerWidth | none | integer | Return the width of the splitter excluding the borders.
GetInnerHeight | none | integer | Return the height of the splitter excluding the borders.
GetPanes | none | Array | Return an array of all panes defined in the splitter
GetSplitBars | none | Array | Return an array of all splitBars defined in the splitter
Resize | (integer width, integer height) | none | Resize the splitter to the specified width and height
GetEndPane | none | RadPane | Get the most right (for vertical orientation) or most bottom (for horizontal orientation) pane.
GetStartPane | none | RadPane | Get the most left (for vertical orientation) or most top (for horizontal orientation) pane.
IsVertical | none | Boolean | Return true if the splitter orientation is vertical, false otherwise.
GetMinWidth | none | integer | Return the MinWidth value of the splitter
GetMaxWidth | none | integer | Return the MaxWidth value of the splitter
GetMinHeight | none | integer | Return the MinHeight value of the splitter
GetMaxHeight | none | integer | Return the MaxHeight value of the splitter
GetPaneByIndex | (integer paneIndex) | RadPane | Return the RadPane object which has the specified paneIndex or null of there is no such pane.
GetPaneById | (string paneId) | RadPane | Return the RadPane object which has the specified paneId or null of there is no such pane.
GetSplitBarByIndex | (string splitBarIndex) | RadSplitBar | Return the RadSplitBar object which has the specified Index or null of there is no such object.
GetSplitBarById | (string splitBarId) | RadSplitBar | Return the RadSplitBar object which has the specified Id or null of there is no such object.
GetContainerElement | none | HtmlElement | Return the outer most html element that is used from the splitter
SetResizeMode (RadSplitterNamespace.RAD_SPLITTER_RESIZE_MODE resizeMode) none

Set the ResizeMode of the splitter.

RadSplitterNamespace.RAD_SPLITTER_RESIZE_MODE enumeration has the following values:

  • ADJACENT_PANE
  • PROPORTIONAL
  • END_PANE
GetResizeMode | none | Integer | Return the current ResizeMode property
IsNested | none | Boolean | Return true if the splitter is nested into a RadPane and is the only control that is in this pane.

Properties

Name

 Type Description
ID String

Gets the ClientID of the control.

Example

<script type="text/javascript">
    var splitter = <%=RadSplitter1.ClientID %>
    alert(splitter.ID);
</script>

Events

Name | Event Handler Parameters | Description
OnClientLoaded | (sender, eventArgs) | The client-side event handler is called when the splitter is initialized and is ready for use.
OnClientBeforeResize | (sender, eventArgs) | The client-side event handler is called before the splitter is resized. If false is returned from the event handler, the event will be canceled.
OnClientResized | (sender, eventArgs) | The client-side event handler is called when the splitter is resized.

For more details on handling client events, review the client events section.

© 2002-2008 Telerik. All Rights Reserved.


RadPane client object

Telerik RadSplitter v1.3 Send comments on this topic.
RadPane client object
Client-Side API Reference > RadPane client object

Glossary Item Box

Methods

Name

Parameters

Return Type

Description

Collapse (RadSplitterNamespace.RAD_SPLITTER_DIRECTION direction) Boolean

Collapse the pane in the specified direction. Return true on success, false otherwise.

RadSplitterNamespace.RAD_SPLITTER_DIRECTION enumeration has two values:

  • Forward
  • Backward
Expand (RadSplitterNamespace.RAD_SPLITTER_DIRECTION direction) Boolean

Expand the pane in the specified direction. Return true on success, false otherwise.

RadSplitterNamespace.RAD_SPLITTER_DIRECTION enumeration has the following values:

  • Forward
  • Backward
Resize | (integer delta, RadSplitterNamespace.RAD_SPLITTER_DIRECTION direction) | none | Resize the pane with delta pixels in the specified direction
Print | (array cssFiles) | none | Print the content of the pane. If the pane is not displaying external content the printed content will be formatted using the specified cssFiles.
SaveState | none | none | Save the state of the RadPane object. The state is persisted during postbacks.
GetState | none | JSON string | Return the current state of the RadPane object in JSON format.
GetContent | none | string | Return the html content of the pane. Not for use with external content loaded (when the ContentUrl is specified)
SetContent | (string content) | none | Set the html content of the pane. Not for use with external content loaded (when the ContentUrl is specified)
SetContentUrl | (string src) | none | Set the external content src (the ContentUrl property should be specified declaratively in the aspx page before this property to take effect)
GetContentUrl | none | string | Get the external content src (the ContentUrl property should be specified declaratively in the aspx page before this property to take effect)
IsExternalContent | none | Boolean | Return true if pane is showing an external content (content specified using the ContentUrl property)
SetMinWidth | (integer minWidth) | none | Set the MinWidth property of the RadPane object. This is the minimum width to which the pane can be resized.
GetMinWidth | none | integer | Get the MinWidth property of the RadPane object.
SetMinHeight | (integer minHeight ) | none | Set the MinHeight property of the RadPane object. This is the minimum height to which the pane can be resized.
GetMinHeight | none | integer | Get the MinHeight property of the RadPane object.
SetMaxWidth | (integer maxWidth) | none | Set the MaxWidth property of the RadPane object. This is the maximum width to which the pane can be resized.
GetMaxWidth | none | integer | Get the MaxWidth property of the RadPane object.
SetMaxHeight | (integer maxHeight) | none | Set the MaxHeight property of the RadPane object. This is the maximum height to which the pane can be resized.
GetMaxHeight | none | integer | Get the MaxHeight property of the RadPane object.
SetWidth | (integer width) | none | Set the Width property of the RadPane object.
GetWidth | none | integer | Return the width (in px) of the RadPane object.
SetHeight | (integer height) | none | Set the Height property of the RadPane object.
GetHeight | none | integer | Return the height (in px) of the RadPane object.
GetInnerWidth | none | integer | Return the width of the RadPan object excluding the pane borders. This is the width that is available to the pane content.
GetInnerHeight | none | integer | Return the height of the RadPan object excluding the pane borders. This is the height that is available to the pane content.
GetSplitter | none | RadSplitter | Return a reference to the RadSplitter object in which the pane is displayed.
IsSplitterContainer | none | Boolean | Return true if the pane is used as a splitter container - e.g. the pane has no borders and it is resizing the child splitter.
GetContainerElement | none | HtmlElement | The most outer html element that is holding the pane.
GetContentContainerElement | none | HtmlElement | The element which is holding the pane content.
GetExtContentContainerElement | none | HtmlElement | The element which is holding the pane external content.
IsLocked | none | Boolean | Return true if the pane is locked.
Lock | none | none | Lock the pane This will lead the pane to be not resizable and not collapsible.
UnLock | none | none | Unlock the pane.
IsCollapsed | none | Boolean | Return true if the pane is collapsed.
IsExpanded | none | Boolean | Return true if the pane is expanded.
SetScrollPos | (int scrollLeft, int scrollTop) | none | Set the scroll Left and Top positions of the pane.
GetScrollPos none Object

Return the Left and Top positions of the scroll of the pane. Return value is an object with two properties - scrollLeft and scrollTop.

var scrollPos = pane.GetScrollPos();
var leftPos = scrollPos.left;
var topPos = scrollPos.top;

Properties

Name

 Type Description
ID String

Gets the ClientID of the control.

Example

<script type="text/javascript">
    var splitter = <%=RadSplitter1.ClientID %>
    var pane = splitter.GetPaneById(paneID);

    alert(pane.ID);
</script>

Index Integer

Index property is zero-based and represents the index of the current pane in the panes collection of the splitter.

Example

<script type="text/javascript">
    var splitter = <%=RadSplitter1.ClientID %>
    var pane = splitter.GetPaneById(paneID);

    alert(pane.Index);
</script>

Events

Name | Event Handler Parameters | Description
OnClientPaneCollapsed | (sender, eventArgs) | Fires after the pane has been collapsed.
OnClientPaneExpanded | (sender, eventArgs) | Fires after the pane has been expanded.
OnClientPaneResized | (sender, eventArgs) | Fires after the pane has been resized.
OnClientBeforePaneCollapse | (sender, eventArgs) | Fires before the pane has been collapsed.
OnClientBeforePaneExpand | (sender, eventArgs) | Fires before the pane has been expanded.
OnClientBeforePaneResize | (sender, eventArgs) | Fires before the pane has been resized.

For more details on handling client events, review the client events section.

© 2002-2008 Telerik. All Rights Reserved.


RadSplitBar client object

Telerik RadSplitter v1.3 Send comments on this topic.
RadSplitBar client object
Client-Side API Reference > RadSplitBar client object

Glossary Item Box

Methods

Name | Parameters | Return Type | Description
IsCollapsed | (RadSplitterNamespace.RAD_SPLITTER_DIRECTION direction) | Boolean | Specified whether the splitbar is collapsed for the specified direction.
IsCollapseDirectionEnabled | (RadSplitterNamespace.RAD_SPLITTER_DIRECTION direction) | Boolean | Specifies whether the collapse direction is enabled for the splitbar.
IsResizeEnabled | none | Boolean | Specifies whether the resize action is enabled for the splitbar.
GetContainerElement | none | HtmlElement | Return the splitbar container html element.
GetSplitterBarElement | none | HtmlElement | Return the splitbar container html element.
GetCollapseBarElement | (RadSplitterNamespace.RAD_SPLITTER_DIRECTION direction) | HtmlElement | Return the collapse bar html element for the specified direction.
GetWidth | none | Integer | Return the width of the splitbar.
GetHeight | none | Integer | Return the heigh of the splitbar.

Properties

Name

 Type Description
ID String

Gets the ClientID of the control.

Example

<script type="text/javascript">
    var splitter = <%=RadSplitter1.ClientID %>
    var splitBar = splitter.GetSplitBarById(splitBarID);

    alert(splitBar.ID);
</script>

Index Integer

Index property is zero-based and represents the index of the current splitbar in the splitbars collection of the splitter.

Example

<script type="text/javascript">
    var splitter = <%=RadSplitter1.ClientID %>
    var splitBar = splitter.GetSplitBarById(splitBarID);

    alert(splitBar.Index);
</script>

Events

None

For more details on handling client events, review the client events section.

© 2002-2008 Telerik. All Rights Reserved.


RadSlidingZone client object

Telerik RadSplitter v1.3 Send comments on this topic.
RadSlidingZone client object
Client-Side API Reference > RadSlidingZone client object

Glossary Item Box

Methods

Name | Parameters | Return Type | Description
GetPanes | none | Array | Return an array of all panes defined in the sliding zone
GetPaneById | (string paneId) | RadSlidingPane | Return the RadSlidingPane object which has the specified paneId or null of there is no such pane.
SaveState | none | none | Save the client state of the sliding zone.
GetState | none | string | Get the saved client state as JSON string of the sliding zone.
SetClickToOpen | (bool clickToOpen) | none | Set the clickToOpen property value.
GetClickToOpen | none | Boolean | Get the value of the clickToOpen property.
GetTabsContainer | none | HtmlElement | Get the html element that holds all the pane tab elements.
GetTabContainer | (string paneId) | HtmlElement | Get the html element that holds the tab for the give paneId.
GetZoneContainer | none | HtmlElement | Get the html element that holds all the html for the sliding zone.
GetExpandedPaneId | none | string | Get the id of the current expanded pane or null if there is no expanded pane.
GetDockedPaneId | none | string | Get the id of the current docked pane or null if there is no docked pane.
DockPane | (string paneId) | Bool | Dock a pane with the given Id. Returns true on success, false otherwise.
UnDockPane | (string paneId) | Bool | UnDock a pane with the given Id. Returns true on success, false otherwise.
ExpandPane | (string paneId) | Bool | Expand a pane with the given Id. Returns true on success, false otherwise.
CollapsePane | (string paneId) | Bool | Collapse a pane with the given Id. Returns true on success, false otherwise.
HideTab | (string paneId) | none | Hide the tab of a pane with the given Id.
ShowTab | (string paneId) | none | Shows the tab of a pane with the given Id.
IsTabDisplayed | (string paneId) | Bool | Return true if the tab for the given pane is displayed, false otherwise.
IsLeftDirection | none | Bool | Returns true if the direction of the slide is from right to left, false otherwise.
IsRightDirection | none | Bool | Returns true if the direction of the slide is from left to right, false otherwise.
IsTopDirection | none | Bool | Return true if the direction of the slide is from bottom to top, false otherwise.
IsBottomDirection | none | Bool | Return true if the direction of the slide is from top to bottom, false otherwise.

Properties

Name

 Type Description
ID String

Gets the ClientID of the control.

Example

<script type="text/javascript">
    var slidingZone = <%=RadSlidingZone1.ClientID %>
    alert(slidingZone.ID);
</script>

Events

Name | Event Handler Parameters | Description
OnClientLoaded | (sender, eventArgs) | The client-side event handler is called when the splitter is initialized and is ready for use.

For more details on handling client events, review the client events section.

© 2002-2008 Telerik. All Rights Reserved.


RadSlidingPane client object

Telerik RadSplitter v1.3 Send comments on this topic.
RadSlidingPane client object
Client-Side API Reference > RadSlidingPane client object

Glossary Item Box

Methods

Name | Parameters | Return Type | Description
SaveState | none | none | Save the client state of the pane.
GetState | none | string | Get the saved client state as JSON string of the pane.
SetTitle | (string title) | none | Set the title of the pane.
GetTitle | none | string | Get the title of the pane.
GetContentContainer | none | HtmlElement | Get the container for the pane content.
GetSlideContainer | none | HtmlElement | Get the html element that is a container for the slide layer.
GetDockIconElement | none | HtmlElement | Return the img element which displays the dock icon.
GetUnDockIconElement | none | HtmlElement | Return the img element which displays the undock icon.
GetCollapseIconElement | none | HtmlElement | Return the img element which displays the collapse icon.
SetContent | (htmlString content) | none | Set the html content of the pane.
GetContent | none | HtmlString | Get the html content of the pane.
SetMinWidth | (integer minWidth) | none | Set the MinWidth property of the RadSlidingPane object. This is the minimum width to which the pane can be resized.
GetMinWidth | none | integer | Get the MinWidth property of the RadSlidingPane object.
SetMaxWidth | (integer maxWidth) | none | Set the MaxWidth property of the RadSlidingPane object. This is the maximum width to which the pane can be resized.
GetMaxWidth | none | integer | Get the MaxWidth property of the RadSlidingPane object.
SetMinHeight | (integer minHeight) | none | Set the MinHeight property of the RadSlidingPane object. This is the minimum height to which the pane can be resized.
GetMinHeight | none | integer | Get the MinHeight property of the RadSlidingPane object.
SetMaxHeight | (integer maxHeight) | none | Set the MaxHeight property of the RadSlidingPane object. This is the maximum height to which the pane can be resized.
GetMaxHeight | none | integer | Get the MaxHeight property of the RadSlidingPane object.
GetWidth | none | integer | Return the width (in px) of the RadSlidingPane object.
SetWidth | (integer pxWidth) | none | Set the width (in px) of the RadSlidingPane object.
GetHeight | none | integer | Return the height (in px) of the RadSlidingPane object.
SetHeight | (integer pxHeight) | none | Set the height (in px) of the RadSlidingPane object.
IsResizable | none | Bool | Return true if the pane is re-sizable, false otherwise.
IsDockable | none | Bool | Return true if the pane is dockable, false otherwise.
SetDockable | (bool isDockable) | none | Set the EnableDock property.
SetResizable | (bool isResizable) | none | Set the EnableResize property.
IsExpanded | none | Bool | Return true if the pane is expanded, false otherwise.
IsDocked | none | Bool | Return true if the pane is docked, false otherwise.
GetSlidingContainerTitle | none | HtmlElement | Get the container for the title content.
GetSlidingPaneResizeContainer | none | HtmlElement | Get the html element that is a container for the resize layer.

Properties

Name

 Type Description
ID String

Gets the ClientID of the control.

Example

<script type="text/javascript">
    var slidingZone= <%=RadSlidingZone1.ClientID %>
    var pane = slidingZone.GetPaneById(paneID);

    alert(pane.ID);
</script>

Index Integer

Index property is zero-based and represents the index of the current pane in the panes collection of the sliding zone.

Events

Events

Name | Event Handler Parameters | Description
OnClientPaneCollapsed | (sender, eventArgs) | Fires after the pane has been collapsed.
OnClientPaneExpanded | (sender, eventArgs) | Fires after the pane has been expanded.
OnClientPaneResized | (sender, eventArgs) | Fires after the pane has been resized.
OnClientPaneDocked | (sender, eventArgs) | Fires after the pane has been docked.
OnClientPaneUnDocked | (sender, eventArgs) | Fires after the pane has been undocked.
OnClientBeforePaneCollapse | (sender, eventArgs) | Fires before the pane has been collapsed.
OnClientBeforePaneExpand | (sender, eventArgs) | Fires before the pane has been expanded.
OnClientBeforePaneResize | (sender, eventArgs) | Fires before the pane has been resized.
OnClientBeforePaneDock | (sender, eventArgs) | Fires before the pane has been docked.
OnClientBeforePaneUnDock | (sender, eventArgs) | Fires before the pane has been undocked.

© 2002-2008 Telerik. All Rights Reserved.


Client side events

Telerik RadSplitter v1.3 Send comments on this topic.
Client side events
Client-Side API Reference > Client side events

Glossary Item Box

Events

RadSplitter

Name Event Handler Parameters Description
OnClientLoaded (sender, Object eventArgs)

The client-side event handler is called when the splitter is initialized and is ready for use.

eventArgs parameter has the following properties:

  • splitterObj - the instance of the RadSplitter which fired the event

Usage:

<script type="text/javascript">
function OnSplitterLoadHandler(sender, eventArgs)
{
alert(eventArgs.splitterObj.ID);
}
</script>
<rad:RadSplitter ID="RadSplitter1"
runat= "server"
OnClientLoaded="OnSplitterLoadHandler">
....
</rad:RadSplitter>
OnClientBeforeResize (sender, Object eventArgs)

The client-side event handler is called before the splitter is resized.

eventArgs parameter has the following properties:

  • splitterObj - the instance of the RadSplitter which fired the event

  • newWidth - the new width that will be applied to the RadSplitter object

  • newHeight - the new height that will be applied to the RadSplitter object

The event can be canceled.

Usage:

<script type="text/javascript">
function OnClientBeforeResizeHandler (sender, eventArgs)
{
alert(eventArgs.splitterObj.ID);
return true;//false to cancel the event
}
</script>

<rad:RadSplitter ID="RadSplitter1"
runat= "server"
OnClientBeforeResize ="OnClientBeforeResizeHandler">
....
</rad:RadSplitter>
OnClientResized (sender, Object eventArgs)

The client-side event handler is called after the splitter is resized.

eventArgs parameter has the following properties:

  • splitterObj - the instance of the RadSplitter which fired the event

  • newWidth - the new width that will be applied to the RadSplitter object

  • newHeight - the new height that will be applied to the RadSplitter object

  • oldWidth - the old width of the RadSplitter object

  • oldHeight - the old height of the RadSplitter object

The event can not be canceled.

Usage:

<script type="text/javascript">
function OnClientResizesHandler(sender, eventArgs)
{
alert(eventArgs.splitterObj.ID);
}
</script>

<rad:RadSplitter ID="RadSplitter1"
runat= "server"
OnClientResized="OnClientResizesHandler">
....
</rad:RadSplitter>

RadPane

Name Event Handler Parameters Description
OnClientPaneCollapsed (sender, Object eventArgs)

Fires after the pane has been collapsed.

eventArgs parameter has the following properties:

  • paneObj - the instance of the RadPane which fired the event

Usage:

<script type="text/javascript">
function OnClientPaneCollapsedHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<rad:RadPane ID="RadPane1"
runat= "server"
OnClientPaneCollapsed="OnClientPaneCollapsedHandler">
....
</rad:RadPane>

OnClientPaneExpanded (sender, Object eventArgs)

Fires after the pane has been expanded.

eventArgs parameter has the following properties:

  • paneObj - the instance of the RadPane which fired the event

Usage:

<script type="text/javascript">
function OnClientPaneExpandedHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<rad:RadPane ID="RadPane1"
runat= "server"
OnClientPaneExpanded="OnClientPaneExpandedHandler">
....
</rad:RadPane>
OnClientPaneResized (sender, Object eventArgs)

Fires after the pane has been resized.

eventArgs parameter has the following properties:

  • paneObj - the pane object that has been resized
  • oldWidth - the width of the pane before the resize
  • oldHeight - the height of the pane before the resize
  • newWidth - the current pane width
  • newHeight - the current pane height

Usage:

<script type="text/javascript">
function OnClientPaneResizedHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<rad:RadPane ID="RadPane1"
runat= "server"
OnClientPaneResized="OnClientPaneResizedHandler">
....
</rad:RadPane>
OnClientBeforePaneCollapse (sender, Object eventArgs)

Fires before the pane collapse.

eventArgs parameter has the following properties:

  • paneObj - the instance of the RadPane which fired the event

The event can be canceled.

Usage:

<script type="text/javascript">
function OnClientBeforePaneCollapseHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
return true;//false to cancel the event
}
</script>
<rad:RadPane ID="RadPane1"
runat= "server"
OnClientBeforePaneCollapse="OnClientBeforePaneCollapseHandler">
....
</rad:RadPane>
OnClientBeforePaneExpand (sender, Object eventArgs)

Fires before the pane expand.

eventArgs parameter has the following properties:

  • paneObj - the instance of the RadPane which fired the event

The event can be canceled.

Usage:

<script type="text/javascript">
function OnClientBeforePaneExpandHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
return true;//false to cancel the event
}
</script>
<rad:RadPane ID="RadPane1"
runat= "server"
OnClientBeforePaneExpand="OnClientBeforePaneCollapseHandler">
....
</rad:RadPane>
OnClientBeforePaneResize (sender, Object eventArgs)

Fires before the pane resize.

eventArgs parameter has the following properties:

    • paneObj - the pane object that has been resized
    • newWidth - the new pane width
    • newHeight - the new pane height

The event can be canceled.

Usage:

<script type="text/javascript">
function OnClientBeforePaneResizeHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
return true;//false to cancel the event
}
</script>
<rad:RadPane ID="RadPane1"
runat= "server"
OnClientBeforePaneResize="OnClientBeforePaneResizeHandler">
....
</rad:RadPane>

RadSlidingZone

Name Event Handler Parameters Description
OnClientLoaded (sender, Object eventArgs)

The client-side event handler is called when the splitter is initialized and is ready for use.

eventArgs parameter has the following properties:

  • splitterObj - the instance of the RadSplitter which fired the event

Usage:

<script type="text/javascript">
function OnSplitterLoadHandler(sender, eventArgs)
{
alert(eventArgs.splitterObj.ID);
}
</script>
<rad:RadSplitter ID="RadSplitter1"
runat= "server"
OnClientLoaded="OnSplitterLoadHandler">
....
</rad:RadSplitter>

RadSlidingPane

Name Event Handler Parameters Description
OnClientPaneCollapsed (sender, Object eventArgs)

Fires after the pane has been collapsed.

eventArgs parameter has the following properties:

  • paneObj - the instance of the RadPane which fired the event

Usage:

<script type="text/javascript">
function OnClientPaneCollapsedHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<rad:RadPane ID="RadPane1"
runat= "server"
OnClientPaneCollapsed="OnClientPaneCollapsedHandler">
....
</rad:RadPane>

OnClientPaneExpanded (sender, Object eventArgs)

Fires after the pane has been expanded.

eventArgs parameter has the following properties:

  • paneObj - the instance of the RadPane which fired the event

Usage:

<script type="text/javascript">
function OnClientPaneExpandedHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<rad:RadPane ID="RadPane1"
runat= "server"
OnClientPaneExpanded="OnClientPaneExpandedHandler">
....
</rad:RadPane>
OnClientPaneResized (sender, Object eventArgs)

Fires after the pane has been resized.

eventArgs parameter has the following properties:

  • paneObj - the pane object that has been resized
  • oldWidth - the width of the pane before the resize
  • oldHeight - the height of the pane before the resize
  • newWidth - the current pane width
  • newHeight - the current pane height

Usage:

<script type="text/javascript">
function OnClientPaneResizedHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<rad:RadPane ID="RadPane1"
runat= "server"
OnClientPaneResized="OnClientPaneResizedHandler">
....
</rad:RadPane>
OnClientPaneDocked (sender, Object eventArgs)

Fires after the pane has been docked.

eventArgs parameter has the following properties:

  • paneObj - the instance of the RadSlidingPane which fired the event

Usage:

<script type="text/javascript">
function OnClientPaneDockedHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<rad:RadSlidingPane ID="RadPane1"
runat= "server"
OnClientPaneDocked="OnClientPaneDockedHandler">
....
</rad:RadSlidingPane>
OnClientPaneUnDocked (sender, Object eventArgs)

Fires after the pane has been undocked.

eventArgs parameter has the following properties:

  • paneObj - the instance of the RadSlidingPane which fired the event

Usage:

<script type="text/javascript">
function OnClientPaneUnDockedHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<rad:RadSlidingPane ID="RadPane1"
runat= "server"
OnClientPaneUnDocked="OnClientPaneUnDockedHandler">
....
</rad:RadSlidingPane>
OnClientBeforePaneCollapse (sender, Object eventArgs)

Fires before the pane collapse.

eventArgs parameter has the following properties:

  • paneObj - the instance of the RadPane which fired the event
  • goingToDock - true if the pane will going to dock after the collapse.

The event can be canceled.

Usage:

<script type="text/javascript">
function OnClientBeforePaneCollapseHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
return true;//false to cancel the event
}
</script>
<rad:RadPane ID="RadPane1"
runat= "server"
OnClientBeforePaneCollapse="OnClientBeforePaneCollapseHandler">
....
</rad:RadPane>
OnClientBeforePaneExpand (sender, Object eventArgs)

Fires before the pane expand.

eventArgs parameter has the following properties:

  • paneObj - the instance of the RadPane which fired the event

The event can be canceled.

Usage:

<script type="text/javascript">
function OnClientBeforePaneExpandHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
return true;//false to cancel the event
}
</script>
<rad:RadPane ID="RadPane1"
runat= "server"
OnClientBeforePaneExpand="OnClientBeforePaneCollapseHandler">
....
</rad:RadPane>
OnClientBeforePaneResize (sender, Object eventArgs)

Fires before the pane resize.

eventArgs parameter has the following properties:

    • paneObj - the pane object that has been resized
    • newWidth - the new pane width
    • newHeight - the new pane height

The event can be canceled.

Usage:

<script type="text/javascript">
function OnClientBeforePaneResizeHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
return true;//false to cancel the event
}
</script>
<rad:RadPane ID="RadPane1"
runat= "server"
OnClientBeforePaneResize="OnClientBeforePaneResizeHandler">
....
</rad:RadPane>
OnClientBeforePaneDock (sender, Object eventArgs)

Fires before the pane dock.

eventArgs parameter has the following properties:

  • paneObj - the instance of the RadSlidingPane which fired the event

The event can be canceled.

Usage:

<script type="text/javascript">
function OnClientBeforePaneDockHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<rad:RadSlidingPane ID="RadPane1"
runat= "server"
OnClientBeforePaneDock="OnClientBeforePaneDockHandler">
....
</rad:RadSlidingPane>
OnClientBeforePaneUnDock (sender, Object eventArgs)

Fires before the pane undock.

eventArgs parameter has the following properties:

  • paneObj - the instance of the RadSlidingPane which fired the event

The event can be canceled.

Usage:

<script type="text/javascript">
function OnClientBeforePaneUnDockHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<rad:RadSlidingPane ID="RadPane1"
runat= "server"
OnClientBeforePaneUnDock="OnClientBeforePaneUnDockHandler">
....
</rad:RadSlidingPane>

© 2002-2008 Telerik. All Rights Reserved.


Reference content page in a splitter pane from the parent page and vice versa

Telerik RadSplitter v1.3 Send comments on this topic.
Reference content page in a splitter pane from the parent page and vice versa
How-to > Reference content page in a splitter pane from the parent page and vice versa

Glossary Item Box

Consider that you have inserted a RadSplitter control in an aspx page. Let us call that page a parent page. Additionally, assume that the ContentUrl property of one of the splitter panes is set to another aspx page (content page). On various occasions you may need to reference the content page from within the parent page or to reference the parent page from within the content page. Here, you will find detailed instructions on how to deal with such situations.

Note that you can apply these solutions only in case both the parent page and the content page are in the same security domain.

  1. Let us first refer to the case in which you want to reference the parent page from within the content page of RadSplitter. In this situation you can get a reference to the page that contains the RadSplitter control (the parent page) by using the "parent" keyword in your javascript function. You can further use this reference in order to obtain a reference to the RadSplitter object itself. The following code fragment demonstrates the usage of the "parent" keyword in the context of the discussed scenario:
    <script> <!-- //parent page script
       //obtain reference to the RadSplitter object-->
       function GetRadSplitter ()
       {
          return <%= [RadSplitter_ID].ClientID %>;
       }
    </script>
    <script> <!-- //content page script
          ...
          //obtain reference to the parent page
          var splitterPageWnd = window.parent;
          //call a method from the parent page-->
          var splitterObject = splitterPageWnd.GetRadSplitter();
          ...
    </script>
  2. Now we will refer to the second case, namely when you would like to obtain reference to the content page from within the parent page.
    When you set the ContentUrl property of the pane of your choice, you actually insert an iframe element into the pane. So in order to get a reference to the content page you have to get a reference to the iframe window. Below is a simple example demonstrating how this can be done:
    <script>
       ...
       var splitter = <%= [Your_Splitter_ID].ClientID %>;
       var pane = splitter.GetPaneById("<%= [Your_Pane_ID].ClientID %>");
       var iframe = pane.GetExtContentContainerElement();
       var contentWindow = iframe.contentWindow;
       ...
    </script>

For a simple example that demonstrates both functionalities, please download the attached zip archive from our online article.

© 2002-2008 Telerik. All Rights Reserved.


RadPane Class

RadSplitter Send comments on this topic.
RadPane Class
See Also Members
[image]
Telerik.WebControls Namespace : RadPane Class

Object Model

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Class RadPane
   Inherits RadPaneBase
Visual Basic (Usage) Copy Code
Dim instance As RadPane
C#
public class RadPane : RadPaneBase

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadSplitterUtils.RadControl
Telerik.WebControls.RadSplitterItem
Telerik.WebControls.RadPaneBase
Telerik.WebControls.RadPane

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPane Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadPane Class Members

RadPane Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadPane Class

The following tables list the members exposed by RadPane.

Public Constructors

 | Name | Description
Public Constructor | RadPane Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Collapsed | Sets/gets whether the pane is collapsed
Public Property | ContentUrl | The URL of the page to load inside the pane.
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden. Get/Set the Height of the pane.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Index | This property is being used internally by the RadSplitter control. Setting it may lead to unpredictable results. (Inherited from RadSplitterItem)
Public Property | InitiallyCollapsed | Sets/gets whether the pane is initially collapsed
Public Property | Locked | Sets/gets whether the pane is locked
Public Property | MaxHeight | Sets/gets the max height to which the pane can be resized (Inherited from RadPaneBase)
Public Property | MaxWidth | Sets/gets the max width to which the pane can be resized (Inherited from RadPaneBase)
Public Property | MinHeight | Sets/gets the min height to which the pane can be resized (Inherited from RadPaneBase)
Public Property | MinWidth | Sets/gets the min width to which the pane can be resized (Inherited from RadPaneBase)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientBeforePaneCollapse | Gets or sets a value indicating the client-side event handler that is called before the RadPane is collapsed. (Inherited from RadPaneBase)
Public Property | OnClientBeforePaneExpand | Gets or sets a value indicating the client-side event handler that is called before the RadPane is expanded. (Inherited from RadPaneBase)
Public Property | OnClientBeforePaneResize | Gets or sets a value indicating the client-side event handler that is called before the RadPane is resized. (Inherited from RadPaneBase)
Public Property | OnClientPaneCollapsed | Gets or sets a value indicating the client-side event handler that is called when the RadPane is collapsed. (Inherited from RadPaneBase)
Public Property | OnClientPaneExpanded | Gets or sets a value indicating the client-side event handler that is called when the RadPane is expanded. (Inherited from RadPaneBase)
Public Property | OnClientPaneResized | Gets or sets a value indicating the client-side event handler that is called when the RadPane is resized. (Inherited from RadPaneBase)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | PersistScrollPosition | Sets/gets whether the scrolls position will be persisted acrosss postbacks (Inherited from RadPaneBase)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Scrolling | Sets/gets whether the content of the pane will get a scrollbars when it exceeds the pane area size (Inherited from RadPaneBase)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Splitter | Reference to the parent Splitter object
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden. Get/Set the Width of the pane.
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadPane Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadPane Constructor

RadPane Constructor
See Also
[image]
Telerik.WebControls Namespace > RadPane Class : RadPane Constructor

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadPane()
C#
public RadPane()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadPane()
C#
public RadPane()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPane Class
RadPane Members

© telerik 2002-2008. All Rights Reserved.


RadPane Class Properties

RadPane Class Properties
[image]
Telerik.WebControls Namespace : RadPane Class

For a list of all members of this type, see RadPane members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Collapsed | Sets/gets whether the pane is collapsed
Public Property | ContentUrl | The URL of the page to load inside the pane.
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden. Get/Set the Height of the pane.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Index | This property is being used internally by the RadSplitter control. Setting it may lead to unpredictable results. (Inherited from RadSplitterItem)
Public Property | InitiallyCollapsed | Sets/gets whether the pane is initially collapsed
Public Property | Locked | Sets/gets whether the pane is locked
Public Property | MaxHeight | Sets/gets the max height to which the pane can be resized (Inherited from RadPaneBase)
Public Property | MaxWidth | Sets/gets the max width to which the pane can be resized (Inherited from RadPaneBase)
Public Property | MinHeight | Sets/gets the min height to which the pane can be resized (Inherited from RadPaneBase)
Public Property | MinWidth | Sets/gets the min width to which the pane can be resized (Inherited from RadPaneBase)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientBeforePaneCollapse | Gets or sets a value indicating the client-side event handler that is called before the RadPane is collapsed. (Inherited from RadPaneBase)
Public Property | OnClientBeforePaneExpand | Gets or sets a value indicating the client-side event handler that is called before the RadPane is expanded. (Inherited from RadPaneBase)
Public Property | OnClientBeforePaneResize | Gets or sets a value indicating the client-side event handler that is called before the RadPane is resized. (Inherited from RadPaneBase)
Public Property | OnClientPaneCollapsed | Gets or sets a value indicating the client-side event handler that is called when the RadPane is collapsed. (Inherited from RadPaneBase)
Public Property | OnClientPaneExpanded | Gets or sets a value indicating the client-side event handler that is called when the RadPane is expanded. (Inherited from RadPaneBase)
Public Property | OnClientPaneResized | Gets or sets a value indicating the client-side event handler that is called when the RadPane is resized. (Inherited from RadPaneBase)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | PersistScrollPosition | Sets/gets whether the scrolls position will be persisted acrosss postbacks (Inherited from RadPaneBase)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Scrolling | Sets/gets whether the content of the pane will get a scrollbars when it exceeds the pane area size (Inherited from RadPaneBase)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Splitter | Reference to the parent Splitter object
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden. Get/Set the Width of the pane.
Top

See Also

Reference

RadPane Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Collapsed Property

Collapsed Property
[image]
Telerik.WebControls Namespace > RadPane Class : Collapsed Property

Sets/gets whether the pane is collapsed

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property Collapsed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPane
Dim value As Boolean

instance.Collapsed = value

value = instance.Collapsed
C#
public bool Collapsed {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPane Class
RadPane Members

© telerik 2002-2008. All Rights Reserved.


ContentUrl Property

ContentUrl Property
[image]
Telerik.WebControls Namespace > RadPane Class : ContentUrl Property

The URL of the page to load inside the pane.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property ContentUrl As String
Visual Basic (Usage) Copy Code
Dim instance As RadPane
Dim value As String

instance.ContentUrl = value

value = instance.ContentUrl
C#
public string ContentUrl {get; set;}

Remarks

Use the ContentUrl property if you want to load external page into the pane content area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPane Class
RadPane Members

© telerik 2002-2008. All Rights Reserved.


Height Property

Height Property
[image]
Telerik.WebControls Namespace > RadPane Class : Height Property

Get/Set the Height of the pane.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As RadPane
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public override Unit Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPane Class
RadPane Members

© telerik 2002-2008. All Rights Reserved.


InitiallyCollapsed Property

InitiallyCollapsed Property
[image]
Telerik.WebControls Namespace > RadPane Class : InitiallyCollapsed Property

Sets/gets whether the pane is initially collapsed

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property InitiallyCollapsed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPane
Dim value As Boolean

instance.InitiallyCollapsed = value

value = instance.InitiallyCollapsed
C#
public bool InitiallyCollapsed {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPane Class
RadPane Members

© telerik 2002-2008. All Rights Reserved.


Locked Property

Locked Property
[image]
Telerik.WebControls Namespace > RadPane Class : Locked Property

Sets/gets whether the pane is locked

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property Locked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPane
Dim value As Boolean

instance.Locked = value

value = instance.Locked
C#
public bool Locked {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPane Class
RadPane Members

© telerik 2002-2008. All Rights Reserved.


Splitter Property

Splitter Property
[image]
Telerik.WebControls Namespace > RadPane Class : Splitter Property

Reference to the parent Splitter object

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Splitter As RadSplitter
Visual Basic (Usage) Copy Code
Dim instance As RadPane
Dim value As RadSplitter

value = instance.Splitter
C#
public RadSplitter Splitter {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPane Class
RadPane Members

© telerik 2002-2008. All Rights Reserved.


Width Property

Width Property
[image]
Telerik.WebControls Namespace > RadPane Class : Width Property

Get/Set the Width of the pane.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As RadPane
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public override Unit Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPane Class
RadPane Members

© telerik 2002-2008. All Rights Reserved.


RadPaneBase Class

RadPaneBase Class
See Also Members
[image]
Telerik.WebControls Namespace : RadPaneBase Class

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class RadPaneBase
   Inherits RadSplitterItem
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
C#
public abstract class RadPaneBase : RadSplitterItem

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadSplitterUtils.RadControl
Telerik.WebControls.RadSplitterItem
Telerik.WebControls.RadPaneBase
Telerik.WebControls.RadPane
Telerik.WebControls.RadSlidingPane

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadPaneBase Class Members

RadPaneBase Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadPaneBase Class

The following tables list the members exposed by RadPaneBase.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Index | This property is being used internally by the RadSplitter control. Setting it may lead to unpredictable results. (Inherited from RadSplitterItem)
Public Property | MaxHeight | Sets/gets the max height to which the pane can be resized
Public Property | MaxWidth | Sets/gets the max width to which the pane can be resized
Public Property | MinHeight | Sets/gets the min height to which the pane can be resized
Public Property | MinWidth | Sets/gets the min width to which the pane can be resized
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientBeforePaneCollapse | Gets or sets a value indicating the client-side event handler that is called before the RadPane is collapsed.
Public Property | OnClientBeforePaneExpand | Gets or sets a value indicating the client-side event handler that is called before the RadPane is expanded.
Public Property | OnClientBeforePaneResize | Gets or sets a value indicating the client-side event handler that is called before the RadPane is resized.
Public Property | OnClientPaneCollapsed | Gets or sets a value indicating the client-side event handler that is called when the RadPane is collapsed.
Public Property | OnClientPaneExpanded | Gets or sets a value indicating the client-side event handler that is called when the RadPane is expanded.
Public Property | OnClientPaneResized | Gets or sets a value indicating the client-side event handler that is called when the RadPane is resized.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | PersistScrollPosition | Sets/gets whether the scrolls position will be persisted acrosss postbacks
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Scrolling | Sets/gets whether the content of the pane will get a scrollbars when it exceeds the pane area size
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadPaneBase Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadPaneBase Class Properties

RadPaneBase Class Properties
[image]
Telerik.WebControls Namespace : RadPaneBase Class

For a list of all members of this type, see RadPaneBase members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Index | This property is being used internally by the RadSplitter control. Setting it may lead to unpredictable results. (Inherited from RadSplitterItem)
Public Property | MaxHeight | Sets/gets the max height to which the pane can be resized
Public Property | MaxWidth | Sets/gets the max width to which the pane can be resized
Public Property | MinHeight | Sets/gets the min height to which the pane can be resized
Public Property | MinWidth | Sets/gets the min width to which the pane can be resized
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientBeforePaneCollapse | Gets or sets a value indicating the client-side event handler that is called before the RadPane is collapsed.
Public Property | OnClientBeforePaneExpand | Gets or sets a value indicating the client-side event handler that is called before the RadPane is expanded.
Public Property | OnClientBeforePaneResize | Gets or sets a value indicating the client-side event handler that is called before the RadPane is resized.
Public Property | OnClientPaneCollapsed | Gets or sets a value indicating the client-side event handler that is called when the RadPane is collapsed.
Public Property | OnClientPaneExpanded | Gets or sets a value indicating the client-side event handler that is called when the RadPane is expanded.
Public Property | OnClientPaneResized | Gets or sets a value indicating the client-side event handler that is called when the RadPane is resized.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | PersistScrollPosition | Sets/gets whether the scrolls position will be persisted acrosss postbacks
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Scrolling | Sets/gets whether the content of the pane will get a scrollbars when it exceeds the pane area size
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

RadPaneBase Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


MaxHeight Property

MaxHeight Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : MaxHeight Property

Sets/gets the max height to which the pane can be resized

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As Integer

instance.MaxHeight = value

value = instance.MaxHeight
C#
public int MaxHeight {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


MaxWidth Property

MaxWidth Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : MaxWidth Property

Sets/gets the max width to which the pane can be resized

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As Integer

instance.MaxWidth = value

value = instance.MaxWidth
C#
public int MaxWidth {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


MinHeight Property

MinHeight Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : MinHeight Property

Sets/gets the min height to which the pane can be resized

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property MinHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As Integer

instance.MinHeight = value

value = instance.MinHeight
C#
public virtual int MinHeight {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


MinWidth Property

MinWidth Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : MinWidth Property

Sets/gets the min width to which the pane can be resized

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property MinWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As Integer

instance.MinWidth = value

value = instance.MinWidth
C#
public virtual int MinWidth {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


OnClientBeforePaneCollapse Property

OnClientBeforePaneCollapse Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : OnClientBeforePaneCollapse Property

Gets or sets a value indicating the client-side event handler that is called before the RadPane is collapsed.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientBeforePaneCollapse As String
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As String

instance.OnClientBeforePaneCollapse = value

value = instance.OnClientBeforePaneCollapse
C#
public string OnClientBeforePaneCollapse {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientBeforePaneCollapse property.

<script type="text/javascript">
function OnClientBeforePaneCollapseHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
return true;//false to cancel the event
}
</script>
<radspl:RadPane ID="RadPane1"
runat= "server"
OnClientBeforePaneCollapse="OnClientBeforePaneCollapseHandler">
....
</radspl:RadPane>

Remarks

If specified, the OnClientBeforePaneCollapse client-side event handler is called before the RadPane is collapsed. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with one property, paneObj (the instance of the RadPane).

This event can be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


OnClientBeforePaneExpand Property

OnClientBeforePaneExpand Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : OnClientBeforePaneExpand Property

Gets or sets a value indicating the client-side event handler that is called before the RadPane is expanded.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientBeforePaneExpand As String
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As String

instance.OnClientBeforePaneExpand = value

value = instance.OnClientBeforePaneExpand
C#
public string OnClientBeforePaneExpand {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientBeforePaneExpand property.

<script type="text/javascript">
function OnClientBeforePaneExpandHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
return true;//false to cancel the event
}
</script>
<radspl:RadPane ID="RadPane1"
runat= "server"
OnClientBeforePaneExpand="OnClientBeforePaneExpandHandler">
....
</radspl:RadPane>

Remarks

If specified, the OnClientBeforePaneExpand client-side event handler is called before the RadPane is expanded. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with one property, paneObj (the instance of the RadPane).

This event can be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


OnClientBeforePaneResize Property

OnClientBeforePaneResize Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : OnClientBeforePaneResize Property

Gets or sets a value indicating the client-side event handler that is called before the RadPane is resized.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientBeforePaneResize As String
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As String

instance.OnClientBeforePaneResize = value

value = instance.OnClientBeforePaneResize
C#
public string OnClientBeforePaneResize {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientBeforePaneResize property.

<script type="text/javascript">
function OnClientBeforePaneResizeHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
return true;//false to cancel the event
}
</script>
<radspl:RadPane ID="RadPane1"
runat= "server"
OnClientBeforePaneResize="OnClientBeforePaneResizeHandler">
....
</radspl:RadPane>

Remarks

If specified, the OnClientBeforePaneResize client-side event handler is called before the RadPane is resized. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with the following properties:
    • paneObj - the pane object that will be resized
    • delta - the delta with which the pane will be resized
    • direction - the direction in which the pane will be resized. You can use the RadSplitterNamespace.RAD_SPLITTER_DIRECTION hash to check the direction. The 2 possible values are : Forward and Backward

This event can be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


OnClientPaneCollapsed Property

OnClientPaneCollapsed Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : OnClientPaneCollapsed Property

Gets or sets a value indicating the client-side event handler that is called when the RadPane is collapsed.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientPaneCollapsed As String
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As String

instance.OnClientPaneCollapsed = value

value = instance.OnClientPaneCollapsed
C#
public string OnClientPaneCollapsed {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientPaneCollapsed property.

<script type="text/javascript">
function OnClientPaneCollapsedHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<radspl:RadPane ID="RadPane1"
runat= "server"
OnClientPaneCollapsed="OnClientPaneCollapsedHandler">
....
</radspl:RadPane>

Remarks

If specified, the OnClientPaneCollapsed client-side event handler is called when the RadPane is collapsed. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with one property, paneObj (the instance of the RadPane).

This event cannot be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


OnClientPaneExpanded Property

OnClientPaneExpanded Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : OnClientPaneExpanded Property

Gets or sets a value indicating the client-side event handler that is called when the RadPane is expanded.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientPaneExpanded As String
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As String

instance.OnClientPaneExpanded = value

value = instance.OnClientPaneExpanded
C#
public string OnClientPaneExpanded {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientPaneExpanded property.

<script type="text/javascript">
function OnClientPaneExpandedHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<radspl:RadPane ID="RadPane1"
runat= "server"
OnClientPaneExpanded="OnClientPaneExpandedHandler">
....
</radspl:RadPane>

Remarks

If specified, the OnClientPaneExpanded client-side event handler is called when the RadPane is expanded. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with one property, paneObj (the instance of the RadPane).

This event cannot be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


OnClientPaneResized Property

OnClientPaneResized Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : OnClientPaneResized Property

Gets or sets a value indicating the client-side event handler that is called when the RadPane is resized.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientPaneResized As String
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As String

instance.OnClientPaneResized = value

value = instance.OnClientPaneResized
C#
public string OnClientPaneResized {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientPaneResized property.

<script type="text/javascript">
function OnClientPaneResizedHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<radspl:RadPane ID="RadPane1"
runat= "server"
OnClientPaneResized="OnClientPaneResizedHandler">
....
</radspl:RadPane>

Remarks

If specified, the OnClientPaneResized client-side event handler is called when the RadPane is resized. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with the following properties:
    • paneObj - the pane object that has been resized
    • oldWidth - the width of the pane before the resize
    • oldHeight - the height of the pane before the resize
    • newWidth - the current pane width
    • newHeight - the current pane height

This event cannot be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


PersistScrollPosition Property

PersistScrollPosition Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : PersistScrollPosition Property

Sets/gets whether the scrolls position will be persisted acrosss postbacks

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property PersistScrollPosition As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As Boolean

instance.PersistScrollPosition = value

value = instance.PersistScrollPosition
C#
public bool PersistScrollPosition {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


Scrolling Property

Scrolling Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : Scrolling Property

Sets/gets whether the content of the pane will get a scrollbars when it exceeds the pane area size

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property Scrolling As RadSplitterPaneScrolling
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As RadSplitterPaneScrolling

instance.Scrolling = value

value = instance.Scrolling
C#
public RadSplitterPaneScrolling Scrolling {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


RadSlidingPane Class

RadSlidingPane Class
See Also Members
[image]
Telerik.WebControls Namespace : RadSlidingPane Class

Object Model

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Class RadSlidingPane
   Inherits RadPaneBase
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
C#
public class RadSlidingPane : RadPaneBase

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadSplitterUtils.RadControl
Telerik.WebControls.RadSplitterItem
Telerik.WebControls.RadPaneBase
Telerik.WebControls.RadSlidingPane

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSlidingPane Class Members

RadSlidingPane Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadSlidingPane Class

The following tables list the members exposed by RadSlidingPane.

Public Constructors

 | Name | Description
Public Constructor | RadSlidingPane Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableDock | Sets/gets whether the pane can be docked
Public Property | EnableResize | Sets/gets whether the resize bar will be active
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden. Sets/gets the height of the sliding pane
Public Property | IconUrl | Gets or sets the path to an image to display for the item.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Index | This property is being used internally by the RadSplitter control. Setting it may lead to unpredictable results. (Inherited from RadSplitterItem)
Public Property | MaxHeight | Sets/gets the max height to which the pane can be resized (Inherited from RadPaneBase)
Public Property | MaxWidth | Sets/gets the max width to which the pane can be resized (Inherited from RadPaneBase)
Public Property | MinHeight | Overridden. Sets/gets the min height to which the pane can be resized
Public Property | MinWidth | Overridden. Sets/gets the min width to which the pane can be resized
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientBeforePaneCollapse | Gets or sets a value indicating the client-side event handler that is called before the RadPane is collapsed. (Inherited from RadPaneBase)
Public Property | OnClientBeforePaneDock | Gets or sets a value indicating the client-side event handler that is called before the RadSlidingPane is docked.
Public Property | OnClientBeforePaneExpand | Gets or sets a value indicating the client-side event handler that is called before the RadPane is expanded. (Inherited from RadPaneBase)
Public Property | OnClientBeforePaneResize | Gets or sets a value indicating the client-side event handler that is called before the RadPane is resized. (Inherited from RadPaneBase)
Public Property | OnClientBeforePaneUnDock | Gets or sets a value indicating the client-side event handler that is called before the RadSlidingPane is undocked.
Public Property | OnClientPaneCollapsed | Gets or sets a value indicating the client-side event handler that is called when the RadPane is collapsed. (Inherited from RadPaneBase)
Public Property | OnClientPaneDocked | Gets or sets a value indicating the client-side event handler that is called when the RadSlidingPane is docked.
Public Property | OnClientPaneExpanded | Gets or sets a value indicating the client-side event handler that is called when the RadPane is expanded. (Inherited from RadPaneBase)
Public Property | OnClientPaneResized | Gets or sets a value indicating the client-side event handler that is called when the RadPane is resized. (Inherited from RadPaneBase)
Public Property | OnClientPaneUnDocked | Gets or sets a value indicating the client-side event handler that is called when the RadSlidingPane is undocked.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | PersistScrollPosition | Sets/gets whether the scrolls position will be persisted acrosss postbacks (Inherited from RadPaneBase)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Scrolling | Sets/gets whether the content of the pane will get a scrollbars when it exceeds the pane area size (Inherited from RadPaneBase)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SlidingZone | Reference to the parent SlidingZone object
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabView | Sets/gets way the tab of the pane is rendered
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Title | The title that will be displayed when the pane is docked/docked
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden. Sets/gets the width of the sliding pane
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSlidingPane Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSlidingPane Constructor

RadSlidingPane Constructor
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : RadSlidingPane Constructor

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane()
C#
public RadSlidingPane()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane()
C#
public RadSlidingPane()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


RadSlidingPane Class Properties

RadSlidingPane Class Properties
[image]
Telerik.WebControls Namespace : RadSlidingPane Class

For a list of all members of this type, see RadSlidingPane members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableDock | Sets/gets whether the pane can be docked
Public Property | EnableResize | Sets/gets whether the resize bar will be active
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden. Sets/gets the height of the sliding pane
Public Property | IconUrl | Gets or sets the path to an image to display for the item.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Index | This property is being used internally by the RadSplitter control. Setting it may lead to unpredictable results. (Inherited from RadSplitterItem)
Public Property | MaxHeight | Sets/gets the max height to which the pane can be resized (Inherited from RadPaneBase)
Public Property | MaxWidth | Sets/gets the max width to which the pane can be resized (Inherited from RadPaneBase)
Public Property | MinHeight | Overridden. Sets/gets the min height to which the pane can be resized
Public Property | MinWidth | Overridden. Sets/gets the min width to which the pane can be resized
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientBeforePaneCollapse | Gets or sets a value indicating the client-side event handler that is called before the RadPane is collapsed. (Inherited from RadPaneBase)
Public Property | OnClientBeforePaneDock | Gets or sets a value indicating the client-side event handler that is called before the RadSlidingPane is docked.
Public Property | OnClientBeforePaneExpand | Gets or sets a value indicating the client-side event handler that is called before the RadPane is expanded. (Inherited from RadPaneBase)
Public Property | OnClientBeforePaneResize | Gets or sets a value indicating the client-side event handler that is called before the RadPane is resized. (Inherited from RadPaneBase)
Public Property | OnClientBeforePaneUnDock | Gets or sets a value indicating the client-side event handler that is called before the RadSlidingPane is undocked.
Public Property | OnClientPaneCollapsed | Gets or sets a value indicating the client-side event handler that is called when the RadPane is collapsed. (Inherited from RadPaneBase)
Public Property | OnClientPaneDocked | Gets or sets a value indicating the client-side event handler that is called when the RadSlidingPane is docked.
Public Property | OnClientPaneExpanded | Gets or sets a value indicating the client-side event handler that is called when the RadPane is expanded. (Inherited from RadPaneBase)
Public Property | OnClientPaneResized | Gets or sets a value indicating the client-side event handler that is called when the RadPane is resized. (Inherited from RadPaneBase)
Public Property | OnClientPaneUnDocked | Gets or sets a value indicating the client-side event handler that is called when the RadSlidingPane is undocked.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | PersistScrollPosition | Sets/gets whether the scrolls position will be persisted acrosss postbacks (Inherited from RadPaneBase)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Scrolling | Sets/gets whether the content of the pane will get a scrollbars when it exceeds the pane area size (Inherited from RadPaneBase)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SlidingZone | Reference to the parent SlidingZone object
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabView | Sets/gets way the tab of the pane is rendered
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Title | The title that will be displayed when the pane is docked/docked
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden. Sets/gets the width of the sliding pane
Top

See Also

Reference

RadSlidingPane Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


EnableDock Property

EnableDock Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : EnableDock Property

Sets/gets whether the pane can be docked

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableDock As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As Boolean

instance.EnableDock = value

value = instance.EnableDock
C#
public bool EnableDock {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


EnableResize Property

EnableResize Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : EnableResize Property

Sets/gets whether the resize bar will be active

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableResize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As Boolean

instance.EnableResize = value

value = instance.EnableResize
C#
public bool EnableResize {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


Height Property

Height Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : Height Property

Sets/gets the height of the sliding pane

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public override Unit Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


IconUrl Property

IconUrl Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : IconUrl Property

Gets or sets the path to an image to display for the item.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property IconUrl As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As String

instance.IconUrl = value

value = instance.IconUrl
C#
public string IconUrl {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


MinHeight Property

MinHeight Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : MinHeight Property

Sets/gets the min height to which the pane can be resized

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property MinHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As Integer

instance.MinHeight = value

value = instance.MinHeight
C#
public override int MinHeight {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


MinWidth Property

MinWidth Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : MinWidth Property

Sets/gets the min width to which the pane can be resized

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property MinWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As Integer

instance.MinWidth = value

value = instance.MinWidth
C#
public override int MinWidth {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


OnClientBeforePaneDock Property

OnClientBeforePaneDock Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : OnClientBeforePaneDock Property

Gets or sets a value indicating the client-side event handler that is called before the RadSlidingPane is docked.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientBeforePaneDock As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As String

instance.OnClientBeforePaneDock = value

value = instance.OnClientBeforePaneDock
C#
public string OnClientBeforePaneDock {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientBeforePaneDock property.

<script type="text/javascript">
function OnClientBeforePaneDockHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
return true;//false to cancel the event
}
</script>
<radspl:RadSlidingPane ID="RadSlidingPane1"
runat= "server"
OnClientBeforePaneDock="OnClientBeforePaneDockHandler">
....
</radspl:RadSlidingPane>

Remarks

If specified, the OnClientBeforePaneDock client-side event handler is called before the RadSlidingPane is docked. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with the following properties:
    • paneObj - the pane object that will be docked

This event can be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


OnClientBeforePaneUnDock Property

OnClientBeforePaneUnDock Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : OnClientBeforePaneUnDock Property

Gets or sets a value indicating the client-side event handler that is called before the RadSlidingPane is undocked.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientBeforePaneUnDock As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As String

instance.OnClientBeforePaneUnDock = value

value = instance.OnClientBeforePaneUnDock
C#
public string OnClientBeforePaneUnDock {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientBeforePaneUnDock property.

<script type="text/javascript">
function OnClientBeforePaneUnDockHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
return true;//false to cancel the event
}
</script>
<radspl:RadSlidingPane ID="RadSlidingPane1"
runat= "server"
OnClientBeforePaneUnDock="OnClientBeforePaneUnDockHandler">
....
</radspl:RadSlidingPane>

Remarks

If specified, the OnClientBeforePaneUnDock client-side event handler is called before the RadSlidingPane is undocked. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with the following properties:
    • paneObj - the pane object that will be undocked

This event can be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


OnClientPaneDocked Property

OnClientPaneDocked Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : OnClientPaneDocked Property

Gets or sets a value indicating the client-side event handler that is called when the RadSlidingPane is docked.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientPaneDocked As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As String

instance.OnClientPaneDocked = value

value = instance.OnClientPaneDocked
C#
public string OnClientPaneDocked {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientPaneDocked property.

<script type="text/javascript">
function OnClientPaneDockedHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<radspl:RadSlidingPane ID="RadSlidingPane1"
runat= "server"
OnClientPaneDocked="OnClientPaneDockedHandler">
....
</radspl:RadSlidingPane>

Remarks

If specified, the OnClientPaneDocked client-side event handler is called when the RadSlidingPane is docked. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with one property, paneObj (the instance of the RadSlidingPane).

This event cannot be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


OnClientPaneUnDocked Property

OnClientPaneUnDocked Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : OnClientPaneUnDocked Property

Gets or sets a value indicating the client-side event handler that is called when the RadSlidingPane is undocked.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientPaneUnDocked As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As String

instance.OnClientPaneUnDocked = value

value = instance.OnClientPaneUnDocked
C#
public string OnClientPaneUnDocked {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientPaneUnDocked property.

<script type="text/javascript">
function OnClientPaneUnDockedHandler(sender, eventArgs)
{
alert(eventArgs.paneObj.ID);
}
</script>
<radspl:RadSlidingPane ID="RadSlidingPane1"
runat= "server"
OnClientPaneUnDocked="OnClientPaneUnDockedHandler">
....
</radspl:RadSlidingPane>

Remarks

If specified, the OnClientPaneUnDocked client-side event handler is called when the RadSlidingPane is docked. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with one property, paneObj (the instance of the RadSlidingPane).

This event cannot be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


SlidingZone Property

SlidingZone Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : SlidingZone Property

Reference to the parent SlidingZone object

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SlidingZone As RadSlidingZone
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As RadSlidingZone

value = instance.SlidingZone
C#
public RadSlidingZone SlidingZone {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


TabView Property

TabView Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : TabView Property

Sets/gets way the tab of the pane is rendered

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property TabView As RadSplitterSlidePaneTabView
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As RadSplitterSlidePaneTabView

instance.TabView = value

value = instance.TabView
C#
public RadSplitterSlidePaneTabView TabView {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


Title Property

Title Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : Title Property

The title that will be displayed when the pane is docked/docked

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


Width Property

Width Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : Width Property

Sets/gets the width of the sliding pane

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public override Unit Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


RadSlidingZone Class

RadSlidingZone Class
See Also Members
[image]
Telerik.WebControls Namespace : RadSlidingZone Class

Object Model

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Class RadSlidingZone
   Inherits RadSplitterItemsContainer
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
C#
public class RadSlidingZone : RadSplitterItemsContainer

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadSplitterUtils.RadControl
Telerik.RadSplitterUtils.RadSkinnableControl
Telerik.WebControls.RadSplitterItemsContainer
Telerik.WebControls.RadSlidingZone

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSlidingZone Class Members

RadSlidingZone Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadSlidingZone Class

The following tables list the members exposed by RadSlidingZone.

Public Constructors

 | Name | Description
Public Constructor | RadSlidingZone Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClickToOpen | Sets/gets whether the pane should be clicked in order to open
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DockedPaneId | Sets/gets the id of the pane that is will be displayed docked
Public Property | EnableClientDebug | Sets/gets whether the debug console will be enabled (Inherited from RadSplitterItemsContainer)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | ExpandedPaneId | Sets/gets the id of the pane that is will be expanded
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden. Sets/gets the height of the sliding zone
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitiallyDockedPaneId | Sets/gets the id of the pane that is will be displayed docked
Public Property | InitiallyExpandedPaneId | Sets/gets the id of the pane that is will be expanded
Public Property | Items | Gets the collection of child items in the RadSplitter control. (Inherited from RadSplitterItemsContainer)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientLoaded | Gets or sets a value indicating the client-side event handler that is called when the RadSlidingZone control is initialized.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | ResizeStep | Sets/gets the step in px in which the resize bar will be moved when dragged.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | (Inherited from Telerik.RadSplitterUtils.RadSkinnableControl)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | (Inherited from Telerik.RadSplitterUtils.RadSkinnableControl)
Public Property | SlideDirection | Sets/gets the direction in which the panes will slide
Public Property | SlideDuration | Sets/gets the duration of the slide animation in milliseconds.
Public Property | Splitter | Reference to the parent Splitter object
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden. Sets/gets the width of the sliding zone
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetItemById | (Inherited from RadSplitterItemsContainer)
Public Method | GetPaneById |
Public Method | GetPanes |
Public Method | GetParentPane | (Inherited from RadSplitterItemsContainer)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSlidingZone Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSlidingZone Constructor

RadSlidingZone Constructor
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : RadSlidingZone Constructor

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone()
C#
public RadSlidingZone()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone()
C#
public RadSlidingZone()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


RadSlidingZone Class Methods

RadSlidingZone Class Methods
[image]
Telerik.WebControls Namespace : RadSlidingZone Class

For a list of all members of this type, see RadSlidingZone members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetItemById | (Inherited from RadSplitterItemsContainer)
Public Method | GetPaneById |
Public Method | GetPanes |
Public Method | GetParentPane | (Inherited from RadSplitterItemsContainer)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSlidingZone Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


GetPaneById Method

GetPaneById Method
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : GetPaneById Method

paneId

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPaneById( _
   ByVal paneId As String _
) As RadSlidingPane
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim paneId As String
Dim value As RadSlidingPane

value = instance.GetPaneById(paneId)
C#
public RadSlidingPane GetPaneById(
   string paneId
)

Parameters

paneId

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


GetPanes Method

GetPanes Method
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : GetPanes Method

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPanes() As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As ArrayList

value = instance.GetPanes()
C#
public ArrayList GetPanes()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


RadSlidingZone Class Properties

RadSlidingZone Class Properties
[image]
Telerik.WebControls Namespace : RadSlidingZone Class

For a list of all members of this type, see RadSlidingZone members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClickToOpen | Sets/gets whether the pane should be clicked in order to open
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DockedPaneId | Sets/gets the id of the pane that is will be displayed docked
Public Property | EnableClientDebug | Sets/gets whether the debug console will be enabled (Inherited from RadSplitterItemsContainer)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | ExpandedPaneId | Sets/gets the id of the pane that is will be expanded
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden. Sets/gets the height of the sliding zone
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | InitiallyDockedPaneId | Sets/gets the id of the pane that is will be displayed docked
Public Property | InitiallyExpandedPaneId | Sets/gets the id of the pane that is will be expanded
Public Property | Items | Gets the collection of child items in the RadSplitter control. (Inherited from RadSplitterItemsContainer)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientLoaded | Gets or sets a value indicating the client-side event handler that is called when the RadSlidingZone control is initialized.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | ResizeStep | Sets/gets the step in px in which the resize bar will be moved when dragged.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | (Inherited from Telerik.RadSplitterUtils.RadSkinnableControl)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | (Inherited from Telerik.RadSplitterUtils.RadSkinnableControl)
Public Property | SlideDirection | Sets/gets the direction in which the panes will slide
Public Property | SlideDuration | Sets/gets the duration of the slide animation in milliseconds.
Public Property | Splitter | Reference to the parent Splitter object
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden. Sets/gets the width of the sliding zone
Top

See Also

Reference

RadSlidingZone Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


ClickToOpen Property

ClickToOpen Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : ClickToOpen Property

Sets/gets whether the pane should be clicked in order to open

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property ClickToOpen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As Boolean

instance.ClickToOpen = value

value = instance.ClickToOpen
C#
public bool ClickToOpen {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


DockedPaneId Property

DockedPaneId Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : DockedPaneId Property

Sets/gets the id of the pane that is will be displayed docked

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property DockedPaneId As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As String

instance.DockedPaneId = value

value = instance.DockedPaneId
C#
public string DockedPaneId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


ExpandedPaneId Property

ExpandedPaneId Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : ExpandedPaneId Property

Sets/gets the id of the pane that is will be expanded

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property ExpandedPaneId As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As String

instance.ExpandedPaneId = value

value = instance.ExpandedPaneId
C#
public string ExpandedPaneId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


Height Property

Height Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : Height Property

Sets/gets the height of the sliding zone

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public override Unit Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


InitiallyDockedPaneId Property

InitiallyDockedPaneId Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : InitiallyDockedPaneId Property

Sets/gets the id of the pane that is will be displayed docked

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property InitiallyDockedPaneId As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As String

instance.InitiallyDockedPaneId = value

value = instance.InitiallyDockedPaneId
C#
public string InitiallyDockedPaneId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


InitiallyExpandedPaneId Property

InitiallyExpandedPaneId Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : InitiallyExpandedPaneId Property

Sets/gets the id of the pane that is will be expanded

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property InitiallyExpandedPaneId As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As String

instance.InitiallyExpandedPaneId = value

value = instance.InitiallyExpandedPaneId
C#
public string InitiallyExpandedPaneId {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


OnClientLoaded Property

OnClientLoaded Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : OnClientLoaded Property

Gets or sets a value indicating the client-side event handler that is called when the RadSlidingZone control is initialized.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientLoaded As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As String

instance.OnClientLoaded = value

value = instance.OnClientLoaded
C#
public string OnClientLoaded {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientLoaded property.

<script type="text/javascript">
function OnSlidingZoneLoadHandler(sender, eventArgs)
{
alert(eventArgs.slidingZoneObj.ID);
}
</script>
<radspl:RadSlidingZone ID="RadSlidingZone1"
runat= "server"
OnClientLoaded="OnSlidingZoneLoadHandler">
....
</radspl:RadSlidingZone>

Remarks

If specified, the OnClientLoaded client-side event handler is called when the RadSlidingZone is initialized. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with one property, slidingZoneObj (the instance of the RadSlidingZone object).

This event cannot be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


ResizeStep Property

ResizeStep Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : ResizeStep Property

Sets/gets the step in px in which the resize bar will be moved when dragged.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property ResizeStep As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As Integer

instance.ResizeStep = value

value = instance.ResizeStep
C#
public int ResizeStep {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


SlideDirection Property

SlideDirection Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : SlideDirection Property

Sets/gets the direction in which the panes will slide

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property SlideDirection As RadSplitterSlideDirection
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As RadSplitterSlideDirection

instance.SlideDirection = value

value = instance.SlideDirection
C#
public RadSplitterSlideDirection SlideDirection {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


SlideDuration Property

SlideDuration Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : SlideDuration Property

Sets/gets the duration of the slide animation in milliseconds.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property SlideDuration As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As Integer

instance.SlideDuration = value

value = instance.SlideDuration
C#
public int SlideDuration {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


Splitter Property

Splitter Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : Splitter Property

Reference to the parent Splitter object

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Splitter As RadSplitter
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As RadSplitter

value = instance.Splitter
C#
public RadSplitter Splitter {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


Width Property

Width Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : Width Property

Sets/gets the width of the sliding zone

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public override Unit Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


RadSplitBar Class

RadSplitBar Class
See Also Members
[image]
Telerik.WebControls Namespace : RadSplitBar Class

Object Model

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Class RadSplitBar
   Inherits RadSplitterItem
Visual Basic (Usage) Copy Code
Dim instance As RadSplitBar
C#
public class RadSplitBar : RadSplitterItem

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadSplitterUtils.RadControl
Telerik.WebControls.RadSplitterItem
Telerik.WebControls.RadSplitBar

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitBar Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitBar Class Members

RadSplitBar Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadSplitBar Class

The following tables list the members exposed by RadSplitBar.

Public Constructors

 | Name | Description
Public Constructor | RadSplitBar Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | CollapseMode | Sets/gets the collapse mode of the splitbar
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableResize | Sets/gets whether the resize bar will be active
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Index | This property is being used internally by the RadSplitter control. Setting it may lead to unpredictable results. (Inherited from RadSplitterItem)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | ResizeStep | Sets/gets the step in px in which the resize bar will be moved when dragged.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Splitter | Reference to the parent Splitter object
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSplitBar Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitBar Constructor

RadSplitBar Constructor
[image]
Telerik.WebControls Namespace > RadSplitBar Class : RadSplitBar Constructor

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadSplitBar()
C#
public RadSplitBar()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadSplitBar()
C#
public RadSplitBar()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitBar Class
RadSplitBar Members

© telerik 2002-2008. All Rights Reserved.


RadSplitBar Class Properties

RadSplitBar Class Properties
[image]
Telerik.WebControls Namespace : RadSplitBar Class

For a list of all members of this type, see RadSplitBar members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | CollapseMode | Sets/gets the collapse mode of the splitbar
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableResize | Sets/gets whether the resize bar will be active
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Index | This property is being used internally by the RadSplitter control. Setting it may lead to unpredictable results. (Inherited from RadSplitterItem)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | ResizeStep | Sets/gets the step in px in which the resize bar will be moved when dragged.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Splitter | Reference to the parent Splitter object
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

RadSplitBar Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


CollapseMode Property

CollapseMode Property
[image]
Telerik.WebControls Namespace > RadSplitBar Class : CollapseMode Property

Sets/gets the collapse mode of the splitbar

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property CollapseMode As RadSplitBarCollapseMode
Visual Basic (Usage) Copy Code
Dim instance As RadSplitBar
Dim value As RadSplitBarCollapseMode

instance.CollapseMode = value

value = instance.CollapseMode
C#
public RadSplitBarCollapseMode CollapseMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitBar Class
RadSplitBar Members

© telerik 2002-2008. All Rights Reserved.


EnableResize Property

EnableResize Property
[image]
Telerik.WebControls Namespace > RadSplitBar Class : EnableResize Property

Sets/gets whether the resize bar will be active

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableResize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSplitBar
Dim value As Boolean

instance.EnableResize = value

value = instance.EnableResize
C#
public bool EnableResize {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitBar Class
RadSplitBar Members

© telerik 2002-2008. All Rights Reserved.


ResizeStep Property

ResizeStep Property
[image]
Telerik.WebControls Namespace > RadSplitBar Class : ResizeStep Property

Sets/gets the step in px in which the resize bar will be moved when dragged.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property ResizeStep As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadSplitBar
Dim value As Integer

instance.ResizeStep = value

value = instance.ResizeStep
C#
public int ResizeStep {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitBar Class
RadSplitBar Members

© telerik 2002-2008. All Rights Reserved.


Splitter Property

Splitter Property
[image]
Telerik.WebControls Namespace > RadSplitBar Class : Splitter Property

Reference to the parent Splitter object

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Splitter As RadSplitter
Visual Basic (Usage) Copy Code
Dim instance As RadSplitBar
Dim value As RadSplitter

value = instance.Splitter
C#
public RadSplitter Splitter {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitBar Class
RadSplitBar Members

© telerik 2002-2008. All Rights Reserved.


RadSplitter Class

RadSplitter Class
See Also Members
[image]
Telerik.WebControls Namespace : RadSplitter Class

Telerik RadSplitter is a flexible UI component for ASP.NET applications which allows users to manage effectively the content size and layout.

Object Model

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Class RadSplitter
   Inherits RadSplitterItemsContainer
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
C#
public class RadSplitter : RadSplitterItemsContainer

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadSplitterUtils.RadControl
Telerik.RadSplitterUtils.RadSkinnableControl
Telerik.WebControls.RadSplitterItemsContainer
Telerik.WebControls.RadSplitter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitter Class Members

RadSplitter Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadSplitter Class

The following tables list the members exposed by RadSplitter.

Public Constructors

 | Name | Description
Public Constructor | RadSplitter Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderSize | Set/Get size of the splitter border
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableClientDebug | Sets/gets whether the debug console will be enabled (Inherited from RadSplitterItemsContainer)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | FullScreenMode | Resize the splitter in 100% of the page
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden. Sets/gets the height of the splitter
Public Property | HeightOffset | Sets/gets the pixels that should be substracted from the splitter height when its height is defined in percent
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Items | Gets the collection of child items in the RadSplitter control. (Inherited from RadSplitterItemsContainer)
Public Property | LiveResize | Sets/gets whether the rendering of the splitter panes is previewed during the resize
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientBeforeResize | Gets or sets a value indicating the client-side event handler that is called before the RadSplitter is resized.
Public Property | OnClientLoaded | Gets or sets a value indicating the client-side event handler that is called when the RadSplitter control is initialized.
Public Property | OnClientResized | Gets or sets a value indicating the client-side event handler that is called when the RadSplitter is resized.
Public Property | Orientation | Specify the orientation of the panes inside the splitter
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | PanesBorderSize | Set/Get size of the splitter panes border
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | ResizeMode | Set/Get the way the panes are resized
Public Property | ResizeWithBrowserWindow | Sets/gets whether the splitter will be resized when the browser window is resized. The Width or Height properties should be defined in percent.
Public Property | ResizeWithParentPane | Sets/gets whether the splitter will resize when the parent pane is resized
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | Overridden. Gets or sets the skin used by RadSplitter.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | Overridden. Gets or sets the relative path to the Skin folder.
Public Property | SplitBarsSize | Set/Get size of the split bars - in pixels
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | VisibleDuringInit | Whether the Splitter should be visible during its initialization or not
Public Property | Width | Overridden. Sets/gets the width of the splitter
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetItemById | (Inherited from RadSplitterItemsContainer)
Public Method | GetPaneById |
Public Method | GetPanes |
Public Method | GetParentPane | (Inherited from RadSplitterItemsContainer)
Public Method | GetSplitBarById |
Public Method | GetSplitBars |
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsHorizontal |
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSplitter Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitter Constructor

RadSplitter Constructor
[image]
Telerik.WebControls Namespace > RadSplitter Class : RadSplitter Constructor

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter()
C#
public RadSplitter()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter()
C#
public RadSplitter()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


RadSplitter Class Methods

RadSplitter Class Methods
[image]
Telerik.WebControls Namespace : RadSplitter Class

For a list of all members of this type, see RadSplitter members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetItemById | (Inherited from RadSplitterItemsContainer)
Public Method | GetPaneById |
Public Method | GetPanes |
Public Method | GetParentPane | (Inherited from RadSplitterItemsContainer)
Public Method | GetSplitBarById |
Public Method | GetSplitBars |
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsHorizontal |
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSplitter Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


GetPaneById Method

GetPaneById Method
[image]
Telerik.WebControls Namespace > RadSplitter Class : GetPaneById Method

paneId

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPaneById( _
   ByVal paneId As String _
) As RadPane
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim paneId As String
Dim value As RadPane

value = instance.GetPaneById(paneId)
C#
public virtual RadPane GetPaneById(
   string paneId
)

Parameters

paneId

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


GetPanes Method

GetPanes Method
[image]
Telerik.WebControls Namespace > RadSplitter Class : GetPanes Method

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPanes() As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As ArrayList

value = instance.GetPanes()
C#
public ArrayList GetPanes()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


GetSplitBarById Method

GetSplitBarById Method
[image]
Telerik.WebControls Namespace > RadSplitter Class : GetSplitBarById Method

splitBarId

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSplitBarById( _
   ByVal splitBarId As String _
) As RadSplitBar
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim splitBarId As String
Dim value As RadSplitBar

value = instance.GetSplitBarById(splitBarId)
C#
public RadSplitBar GetSplitBarById(
   string splitBarId
)

Parameters

splitBarId

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


GetSplitBars Method

GetSplitBars Method
[image]
Telerik.WebControls Namespace > RadSplitter Class : GetSplitBars Method

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSplitBars() As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As ArrayList

value = instance.GetSplitBars()
C#
public ArrayList GetSplitBars()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


IsHorizontal Method

IsHorizontal Method
[image]
Telerik.WebControls Namespace > RadSplitter Class : IsHorizontal Method

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function IsHorizontal() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As Boolean

value = instance.IsHorizontal()
C#
public bool IsHorizontal()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


RadSplitter Class Properties

RadSplitter Class Properties
[image]
Telerik.WebControls Namespace : RadSplitter Class

For a list of all members of this type, see RadSplitter members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderSize | Set/Get size of the splitter border
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableClientDebug | Sets/gets whether the debug console will be enabled (Inherited from RadSplitterItemsContainer)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | FullScreenMode | Resize the splitter in 100% of the page
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden. Sets/gets the height of the splitter
Public Property | HeightOffset | Sets/gets the pixels that should be substracted from the splitter height when its height is defined in percent
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Items | Gets the collection of child items in the RadSplitter control. (Inherited from RadSplitterItemsContainer)
Public Property | LiveResize | Sets/gets whether the rendering of the splitter panes is previewed during the resize
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | OnClientBeforeResize | Gets or sets a value indicating the client-side event handler that is called before the RadSplitter is resized.
Public Property | OnClientLoaded | Gets or sets a value indicating the client-side event handler that is called when the RadSplitter control is initialized.
Public Property | OnClientResized | Gets or sets a value indicating the client-side event handler that is called when the RadSplitter is resized.
Public Property | Orientation | Specify the orientation of the panes inside the splitter
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | PanesBorderSize | Set/Get size of the splitter panes border
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | ResizeMode | Set/Get the way the panes are resized
Public Property | ResizeWithBrowserWindow | Sets/gets whether the splitter will be resized when the browser window is resized. The Width or Height properties should be defined in percent.
Public Property | ResizeWithParentPane | Sets/gets whether the splitter will resize when the parent pane is resized
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | Overridden. Gets or sets the skin used by RadSplitter.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | Overridden. Gets or sets the relative path to the Skin folder.
Public Property | SplitBarsSize | Set/Get size of the split bars - in pixels
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | VisibleDuringInit | Whether the Splitter should be visible during its initialization or not
Public Property | Width | Overridden. Sets/gets the width of the splitter
Top

See Also

Reference

RadSplitter Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


BorderSize Property

BorderSize Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : BorderSize Property

Set/Get size of the splitter border

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property BorderSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As Integer

instance.BorderSize = value

value = instance.BorderSize
C#
public int BorderSize {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


FullScreenMode Property

FullScreenMode Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : FullScreenMode Property

Resize the splitter in 100% of the page

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property FullScreenMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As Boolean

instance.FullScreenMode = value

value = instance.FullScreenMode
C#
public bool FullScreenMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


Height Property

Height Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : Height Property

Sets/gets the height of the splitter

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public override Unit Height {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


HeightOffset Property

HeightOffset Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : HeightOffset Property

Sets/gets the pixels that should be substracted from the splitter height when its height is defined in percent

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property HeightOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As Integer

instance.HeightOffset = value

value = instance.HeightOffset
C#
public int HeightOffset {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


LiveResize Property

LiveResize Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : LiveResize Property

Sets/gets whether the rendering of the splitter panes is previewed during the resize

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property LiveResize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As Boolean

instance.LiveResize = value

value = instance.LiveResize
C#
public bool LiveResize {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


OnClientBeforeResize Property

OnClientBeforeResize Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : OnClientBeforeResize Property

Gets or sets a value indicating the client-side event handler that is called before the RadSplitter is resized.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientBeforeResize As String
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As String

instance.OnClientBeforeResize = value

value = instance.OnClientBeforeResize
C#
public string OnClientBeforeResize {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientBeforeResize property.

<script type="text/javascript">
function OnClientBeforeResizeHandler(sender, eventArgs)
{
alert(eventArgs.splitterObj.ID);
return true;//false to cancel the event
}
</script>
<radspl:RadSplitter ID="RadSplitter1"
runat= "server"
OnClientBeforeResize="OnClientBeforeResizeHandler">
....
</radspl:RadSplitter>

Remarks

If specified, the OnClientBeforeResize client-side event handler is called before the RadSplitter is resized. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with the following properties:
    • splitterObj - the splitter object that will be resized
    • newWidth - the new width that will be applied to the RadSplitter object
    • newHeight - the new height that will be applied to the RadSplitter object

This event can be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


OnClientLoaded Property

OnClientLoaded Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : OnClientLoaded Property

Gets or sets a value indicating the client-side event handler that is called when the RadSplitter control is initialized.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientLoaded As String
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As String

instance.OnClientLoaded = value

value = instance.OnClientLoaded
C#
public string OnClientLoaded {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientLoaded property.

<script type="text/javascript">
function OnSplitterLoadHandler(sender, eventArgs)
{
alert(eventArgs.splitterObj.ID);
}
</script>
<radspl:RadSplitter ID="RadSplitter1"
runat= "server"
OnClientLoaded="OnSplitterLoadHandler">
....
</radspl:RadSplitter>

Remarks

If specified, the OnClientLoaded client-side event handler is called when the RadSplitter is initialized. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with one property, splitterObj (the instance of the RadSplitter object).

This event cannot be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


OnClientResized Property

OnClientResized Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : OnClientResized Property

Gets or sets a value indicating the client-side event handler that is called when the RadSplitter is resized.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property OnClientResized As String
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As String

instance.OnClientResized = value

value = instance.OnClientResized
C#
public string OnClientResized {get; set;}

Return Value

A string specifying the name of the JavaScript function that will handle the event. The default value is empty string.

Example

The following example demonstrates how to use the OnClientResized property.

<script type="text/javascript">
function OnClientResizedHandler(sender, eventArgs)
{
alert(eventArgs.splitterObj.ID);
}
</script>
<radspl:RadSplitter ID="RadSplitter1"
runat= "server"
OnClientResized="OnClientResizedHandler">
....
</radspl:RadSplitter>

Remarks

If specified, the OnClientResized client-side event handler is called when the RadSplitter is resized. Two parameters are passed to the handler:

  • event, the event object;
  • eventArgs with the following properties:
    • splitterObj - the splitter object that has been resized
    • oldWidth - the width of the splitter before the resize
    • oldHeight - the height of the splitter before the resize
    • newWidth - the current splitter width
    • newHeight - the current splitter height

This event cannot be cancelled.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


Orientation Property

Orientation Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : Orientation Property

Specify the orientation of the panes inside the splitter

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property Orientation As RadSplitterOrientation
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As RadSplitterOrientation

instance.Orientation = value

value = instance.Orientation
C#
public RadSplitterOrientation Orientation {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


PanesBorderSize Property

PanesBorderSize Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : PanesBorderSize Property

Set/Get size of the splitter panes border

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property PanesBorderSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As Integer

instance.PanesBorderSize = value

value = instance.PanesBorderSize
C#
public int PanesBorderSize {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


ResizeMode Property

ResizeMode Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : ResizeMode Property

Set/Get the way the panes are resized

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property ResizeMode As RadSplitterResizeMode
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As RadSplitterResizeMode

instance.ResizeMode = value

value = instance.ResizeMode
C#
public RadSplitterResizeMode ResizeMode {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


ResizeWithBrowserWindow Property

ResizeWithBrowserWindow Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : ResizeWithBrowserWindow Property

Sets/gets whether the splitter will be resized when the browser window is resized. The Width or Height properties should be defined in percent.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property ResizeWithBrowserWindow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As Boolean

instance.ResizeWithBrowserWindow = value

value = instance.ResizeWithBrowserWindow
C#
public bool ResizeWithBrowserWindow {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


ResizeWithParentPane Property

ResizeWithParentPane Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : ResizeWithParentPane Property

Sets/gets whether the splitter will resize when the parent pane is resized

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property ResizeWithParentPane As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As Boolean

instance.ResizeWithParentPane = value

value = instance.ResizeWithParentPane
C#
public bool ResizeWithParentPane {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


Skin Property

Skin Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : Skin Property

Gets or sets the skin used by RadSplitter.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Skin As String
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As String

instance.Skin = value

value = instance.Skin
C#
public override string Skin {get; set;}

Return Value

A String specifying the skin. The default value is empty string ("").

Remarks

If the value is empty string ("") no skin is used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


SkinsPath Property

SkinsPath Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : SkinsPath Property

Gets or sets the relative path to the Skin folder.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property SkinsPath As String
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As String

instance.SkinsPath = value

value = instance.SkinsPath
C#
public override string SkinsPath {get; set;}

Remarks

The ~ at the begining of the SkinPath denotes the application root path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


SplitBarsSize Property

SplitBarsSize Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : SplitBarsSize Property

Set/Get size of the split bars - in pixels

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property SplitBarsSize As Unit
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As Unit

instance.SplitBarsSize = value

value = instance.SplitBarsSize
C#
public Unit SplitBarsSize {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


VisibleDuringInit Property

VisibleDuringInit Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : VisibleDuringInit Property

Whether the Splitter should be visible during its initialization or not

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property VisibleDuringInit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As Boolean

instance.VisibleDuringInit = value

value = instance.VisibleDuringInit
C#
public bool VisibleDuringInit {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


Width Property

Width Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : Width Property

Sets/gets the width of the splitter

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public override Unit Width {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


RadSplitterItem Class

RadSplitterItem Class
See Also Members
[image]
Telerik.WebControls Namespace : RadSplitterItem Class

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class RadSplitterItem
   Inherits RadControl
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItem
C#
public abstract class RadSplitterItem : RadControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadSplitterUtils.RadControl
Telerik.WebControls.RadSplitterItem
Telerik.WebControls.RadPaneBase
Telerik.WebControls.RadSplitBar

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItem Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterItem Class Members

RadSplitterItem Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadSplitterItem Class

The following tables list the members exposed by RadSplitterItem.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Index | This property is being used internally by the RadSplitter control. Setting it may lead to unpredictable results.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSplitterItem Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterItem Class Properties

RadSplitterItem Class Properties
[image]
Telerik.WebControls Namespace : RadSplitterItem Class

For a list of all members of this type, see RadSplitterItem members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Index | This property is being used internally by the RadSplitter control. Setting it may lead to unpredictable results.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

RadSplitterItem Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Index Property

Index Property
[image]
Telerik.WebControls Namespace > RadSplitterItem Class : Index Property

This property is being used internally by the RadSplitter control. Setting it may lead to unpredictable results.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItem
Dim value As Integer

instance.Index = value

value = instance.Index
C#
public int Index {get; set;}

Remarks

The Index property is used internally.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItem Class
RadSplitterItem Members

© telerik 2002-2008. All Rights Reserved.


RadSplitterItemsCollection Class

RadSplitterItemsCollection Class
See Also Members
[image]
Telerik.WebControls Namespace : RadSplitterItemsCollection Class

A collection of RadSplitterItem objects in a RadSplitter control.

Object Model

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Class RadSplitterItemsCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsCollection
C#
public class RadSplitterItemsCollection : CollectionBase

Remarks

The RadSplitterItemsCollection class represents a collection of RadSplitterItem objects. The RadSplitterItem objects in turn represent panes items within a RadSplitter control.

  • Use the indexer to programmatically retrieve a single RadSplitterItem from the collection, using array notation.
  • Use the Count property to determine the total number of panes in the collection.
  • Use the Add method to add panes in the collection.
  • Use the Remove method to remove panes from the collection.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.WebControls.RadSplitterItemsCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsCollection Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterItemsCollection Class Members

RadSplitterItemsCollection Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : RadSplitterItemsCollection Class

The following tables list the members exposed by RadSplitterItemsCollection.

Public Constructors

 | Name | Description
Public Constructor | RadSplitterItemsCollection Constructor | Initializes a new instance of the RadSplitterItemsCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets a RadSplitterItem at the specified index in the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Appends a RadSplitterItem to the end of the collection.
Public Method | AddAt | Overloaded.
Public Method | Clear | Removes all items from the collection.
Public Method | Contains | Determines whether the collection contains the specified item.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index value that represents the position of the specified item in the collection.
Public Method | Insert | Inserts the specified RadSplitterItem in the collection at the specified index location.
Public Method | Remove | Removes the specified item from the collection.
Public Method | RemoveAt | Removes the RadSplitterItem at the specified index from the collection.
Top

See Also

Reference

RadSplitterItemsCollection Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterItemsCollection Constructor

RadSplitterItemsCollection Constructor
[image]
Telerik.WebControls Namespace > RadSplitterItemsCollection Class : RadSplitterItemsCollection Constructor

container
The container of the collection.
Initializes a new instance of the RadSplitterItemsCollection class.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As RadSplitterItemsContainer _
)
Visual Basic (Usage) Copy Code
Dim container As RadSplitterItemsContainer

Dim instance As RadSplitterItemsCollection(container)
C#
public RadSplitterItemsCollection(
   RadSplitterItemsContainer container
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As RadSplitterItemsContainer _
)
Visual Basic (Usage) Copy Code
Dim container As RadSplitterItemsContainer

Dim instance As RadSplitterItemsCollection(container)
C#
public RadSplitterItemsCollection(
   RadSplitterItemsContainer container
)

Parameters

container
The container of the collection.

Remarks

Use the constructor to create a new RadSplitterItemsCollection class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsCollection Class
RadSplitterItemsCollection Members

© telerik 2002-2008. All Rights Reserved.


RadSplitterItemsCollection Class Methods

RadSplitterItemsCollection Class Methods
[image]
Telerik.WebControls Namespace : RadSplitterItemsCollection Class

For a list of all members of this type, see RadSplitterItemsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Appends a RadSplitterItem to the end of the collection.
Public Method | AddAt | Overloaded.
Public Method | Clear | Removes all items from the collection.
Public Method | Contains | Determines whether the collection contains the specified item.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index value that represents the position of the specified item in the collection.
Public Method | Insert | Inserts the specified RadSplitterItem in the collection at the specified index location.
Public Method | Remove | Removes the specified item from the collection.
Public Method | RemoveAt | Removes the RadSplitterItem at the specified index from the collection.
Top

See Also

Reference

RadSplitterItemsCollection Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Add Method

Add Method
See Also Example
[image]
Telerik.WebControls Namespace > RadSplitterItemsCollection Class : Add Method

item
Appends a RadSplitterItem to the end of the collection.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As RadSplitterItem _
)
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsCollection
Dim item As RadSplitterItem

instance.Add(item)
C#
public void Add(
   RadSplitterItem item
)

Parameters

item

Example

The following example demonstrates how to programmatically add items in a RadSplitter control.

C# Copy Code
RadPane pane = new RadPane();

RadMenu1.Panes.Add(pane);

Visual Basic Copy Code
Dim pane As RadPane = New RadPane()

RadMenu1.Panes.Add(pane)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsCollection Class
RadSplitterItemsCollection Members

© telerik 2002-2008. All Rights Reserved.


AddAt Method

AddAt Method
[image]
Telerik.WebControls Namespace > RadSplitterItemsCollection Class : AddAt Method

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Overload List

Overload | Description
AddAt(Int32,RadSplitterItem) |
AddAt(Int32,RadSplitterItem,Boolean) |

Overload List

Overload | Description
AddAt(Int32,RadSplitterItem) |
AddAt(Int32,RadSplitterItem,Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsCollection Class
RadSplitterItemsCollection Members

© telerik 2002-2008. All Rights Reserved.


AddAt(Int32,RadSplitterItem) Method

AddAt(Int32,RadSplitterItem) Method
[image]
Telerik.WebControls Namespace > RadSplitterItemsCollection Class > AddAt Method : AddAt(Int32,RadSplitterItem) Method

index
item

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddAt( _
   ByVal index As Integer, _
   ByVal item As RadSplitterItem _
)
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsCollection
Dim index As Integer
Dim item As RadSplitterItem

instance.AddAt(index, item)
C#
public void AddAt(
   int index,
   RadSplitterItem item
)

Parameters

index
item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsCollection Class
RadSplitterItemsCollection Members
Overload List

© telerik 2002-2008. All Rights Reserved.


AddAt(Int32,RadSplitterItem,Boolean) Method

AddAt(Int32,RadSplitterItem,Boolean) Method
[image]
Telerik.WebControls Namespace > RadSplitterItemsCollection Class > AddAt Method : AddAt(Int32,RadSplitterItem,Boolean) Method

index
item
regenerateIndexes

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Overloads Public Sub AddAt( _
   ByVal index As Integer, _
   ByVal item As RadSplitterItem, _
   ByVal regenerateIndexes As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsCollection
Dim index As Integer
Dim item As RadSplitterItem
Dim regenerateIndexes As Boolean

instance.AddAt(index, item, regenerateIndexes)
C#
public void AddAt(
   int index,
   RadSplitterItem item,
   bool regenerateIndexes
)

Parameters

index
item
regenerateIndexes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsCollection Class
RadSplitterItemsCollection Members
Overload List

© telerik 2002-2008. All Rights Reserved.


Clear Method

Clear Method
[image]
Telerik.WebControls Namespace > RadSplitterItemsCollection Class : Clear Method

Removes all items from the collection.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsCollection

instance.Clear()
C#
public void Clear()

Remarks

Use the Clear method to remove all items from the collection. The Count property is set to 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsCollection Class
RadSplitterItemsCollection Members

© telerik 2002-2008. All Rights Reserved.


Contains Method

Contains Method
[image]
Telerik.WebControls Namespace > RadSplitterItemsCollection Class : Contains Method

item
A RadSplitterItem to search for in the collection.
Determines whether the collection contains the specified item.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As RadSplitterItem _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsCollection
Dim item As RadSplitterItem
Dim value As Boolean

value = instance.Contains(item)
C#
public bool Contains(
   RadSplitterItem item
)

Parameters

item
A RadSplitterItem to search for in the collection.

Return Value

true if the collection contains the specified item; otherwise, false.

Remarks

Use the Contains method to determine whether the RadSplitterItem specified by the item parameter is in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsCollection Class
RadSplitterItemsCollection Members

© telerik 2002-2008. All Rights Reserved.


IndexOf Method

IndexOf Method
[image]
Telerik.WebControls Namespace > RadSplitterItemsCollection Class : IndexOf Method

item
A RadSplitterItem to search for in the collection.
Determines the index value that represents the position of the specified item in the collection.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As RadSplitterItem _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsCollection
Dim item As RadSplitterItem
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   RadSplitterItem item
)

Parameters

item
A RadSplitterItem to search for in the collection.

Return Value

The zero-based index position of the specified RadSplitterItem in the collection.

Remarks

Use the IndexOf method to determine the index value of the RadSplitterItem specified by the item parameter in the collection. If an item with this criteria is not found in the collection, -1 is returned.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsCollection Class
RadSplitterItemsCollection Members

© telerik 2002-2008. All Rights Reserved.


Insert Method

Insert Method
[image]
Telerik.WebControls Namespace > RadSplitterItemsCollection Class : Insert Method

index
The location in the collection to insert the RadSplitterItem.
item
The RadSplitterItem to add to the collection.
Inserts the specified RadSplitterItem in the collection at the specified index location.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As RadSplitterItem _
)
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsCollection
Dim index As Integer
Dim item As RadSplitterItem

instance.Insert(index, item)
C#
public void Insert(
   int index,
   RadSplitterItem item
)

Parameters

index
The location in the collection to insert the RadSplitterItem.
item
The RadSplitterItem to add to the collection.

Remarks

Use the Insert method to add a RadSplitterItem to the collection at the index specified by the index parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsCollection Class
RadSplitterItemsCollection Members

© telerik 2002-2008. All Rights Reserved.


Remove Method

Remove Method
See Also Example
[image]
Telerik.WebControls Namespace > RadSplitterItemsCollection Class : Remove Method

item
Removes the specified item from the collection.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As RadSplitterItem _
)
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsCollection
Dim item As RadSplitterItem

instance.Remove(item)
C#
public void Remove(
   RadSplitterItem item
)

Parameters

item

Example

The following example demonstrates how to programmatically remove a RadSplitterItem from a RadSplitter control.
C# Copy Code
RadPane pane = RadSplitter1.GetPaneById("pane1");
if (pane != null)
{
   RadSplitter1.Panes.Remove(pane);
}

Visual Basic Copy Code
Dim pane As RadPane = RadSplitter1.GetPaneById("pane1")
If Not pane Is Nothing Then
    RadSplitter1.Panes.Remove(pane)
End If

Remarks

Use the Remove method to remove a RadSplitterItem from the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsCollection Class
RadSplitterItemsCollection Members

© telerik 2002-2008. All Rights Reserved.


RemoveAt Method

RemoveAt Method
[image]
Telerik.WebControls Namespace > RadSplitterItemsCollection Class : RemoveAt Method

index
The index of the RadSplitterItem to remove.
Removes the RadSplitterItem at the specified index from the collection.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)

Parameters

index
The index of the RadSplitterItem to remove.

Remarks

Use the RemoveAt method to remove the RadSplitterItem at the specified index from the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsCollection Class
RadSplitterItemsCollection Members

© telerik 2002-2008. All Rights Reserved.


RadSplitterItemsCollection Class Properties

RadSplitterItemsCollection Class Properties
[image]
Telerik.WebControls Namespace : RadSplitterItemsCollection Class

For a list of all members of this type, see RadSplitterItemsCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets a RadSplitterItem at the specified index in the collection.
Top

See Also

Reference

RadSplitterItemsCollection Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


Item Property

Item Property
[image]
Telerik.WebControls Namespace > RadSplitterItemsCollection Class : Item Property

index
The zero-based index of the RadSplitterItem to retrieve from the collection.

Gets a RadSplitterItem at the specified index in the collection.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As RadSplitterItem
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsCollection
Dim index As Integer
Dim value As RadSplitterItem

instance.Item(index) = value

value = instance.Item(index)
C#
public RadSplitterItem this[
   int index
]; {get; set;}

Parameters

index
The zero-based index of the RadSplitterItem to retrieve from the collection.

Remarks

Use this indexer to get a RadSplitterItem from the collection at the specified index, using array notation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsCollection Class
RadSplitterItemsCollection Members

© telerik 2002-2008. All Rights Reserved.


RadSplitterItemsContainer Class

RadSplitterItemsContainer Class
See Also Members
[image]
Telerik.WebControls Namespace : RadSplitterItemsContainer Class

Object Model

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class RadSplitterItemsContainer
   Inherits RadSkinnableControl
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsContainer
C#
public abstract class RadSplitterItemsContainer : RadSkinnableControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadSplitterUtils.RadControl
Telerik.RadSplitterUtils.RadSkinnableControl
Telerik.WebControls.RadSplitterItemsContainer
Telerik.WebControls.RadSlidingZone
Telerik.WebControls.RadSplitter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsContainer Members
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterItemsContainer Class Members

RadSplitterItemsContainer Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadSplitterItemsContainer Class

The following tables list the members exposed by RadSplitterItemsContainer.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableClientDebug | Sets/gets whether the debug console will be enabled
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Items | Gets the collection of child items in the RadSplitter control.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | (Inherited from Telerik.RadSplitterUtils.RadSkinnableControl)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | (Inherited from Telerik.RadSplitterUtils.RadSkinnableControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetItemById |
Public Method | GetParentPane |
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSplitterItemsContainer Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterItemsContainer Class Methods

RadSplitterItemsContainer Class Methods
[image]
Telerik.WebControls Namespace : RadSplitterItemsContainer Class

For a list of all members of this type, see RadSplitterItemsContainer members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetItemById |
Public Method | GetParentPane |
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSplitterItemsContainer Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


GetItemById Method

GetItemById Method
[image]
Telerik.WebControls Namespace > RadSplitterItemsContainer Class : GetItemById Method

itemId

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetItemById( _
   ByVal itemId As String _
) As RadSplitterItem
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsContainer
Dim itemId As String
Dim value As RadSplitterItem

value = instance.GetItemById(itemId)
C#
public RadSplitterItem GetItemById(
   string itemId
)

Parameters

itemId

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsContainer Class
RadSplitterItemsContainer Members

© telerik 2002-2008. All Rights Reserved.


GetParentPane Method

GetParentPane Method
[image]
Telerik.WebControls Namespace > RadSplitterItemsContainer Class : GetParentPane Method

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Function GetParentPane() As RadPane
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsContainer
Dim value As RadPane

value = instance.GetParentPane()
C#
public RadPane GetParentPane()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsContainer Class
RadSplitterItemsContainer Members

© telerik 2002-2008. All Rights Reserved.


RadSplitterItemsContainer Class Properties

RadSplitterItemsContainer Class Properties
[image]
Telerik.WebControls Namespace : RadSplitterItemsContainer Class

For a list of all members of this type, see RadSplitterItemsContainer members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableClientDebug | Sets/gets whether the debug console will be enabled
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | Items | Gets the collection of child items in the RadSplitter control.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | Skin | (Inherited from Telerik.RadSplitterUtils.RadSkinnableControl)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SkinsPath | (Inherited from Telerik.RadSplitterUtils.RadSkinnableControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadSplitterUtils.RadControl)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top

See Also

Reference

RadSplitterItemsContainer Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


EnableClientDebug Property

EnableClientDebug Property
[image]
Telerik.WebControls Namespace > RadSplitterItemsContainer Class : EnableClientDebug Property

Sets/gets whether the debug console will be enabled

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableClientDebug As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsContainer
Dim value As Boolean

instance.EnableClientDebug = value

value = instance.EnableClientDebug
C#
public bool EnableClientDebug {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsContainer Class
RadSplitterItemsContainer Members

© telerik 2002-2008. All Rights Reserved.


Items Property

Items Property
See Also Example
[image]
Telerik.WebControls Namespace > RadSplitterItemsContainer Class : Items Property

Gets the collection of child items in the RadSplitter control.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As RadSplitterItemsCollection
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsContainer
Dim value As RadSplitterItemsCollection

value = instance.Items
C#
public RadSplitterItemsCollection Items {get;}

Return Value

A RadSplitterItemsCollection that represents the children within the RadSplitter control. The default is empty collection.

Example

The following example demonstrates how to programmatically add items.
C# Copy Code
void Page_Load(object sender, EventArgs e)
{
   if (!Page.IsPostBack)
   {
       RadPane pane1 = new RadPane();
       RadSplitter1.Items.Add(pane1);

       RadSplitbar splitBar1 = new RadSplitBar();
       RadSplitter1.Items.Add(splitBar1);

       RadPane pane2 = new RadPane();
       RadSplitter1.Items.Add(pane2);
   }
}

Visual Basic Copy Code
Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
    If Not Page.IsPostBack Then
        Dim pane1 As RadPane = New RadPane()
        RadSplitter1.Items.Add(pane1)

        Dim splitBar1 As RadSplitbar = New RadSplitBar()
        RadSplitter1.Items.Add(splitBar1)

        Dim pane2 As RadPane = New RadPane()
        RadSplitter1.Items.Add(pane2)

    End If
End Sub

Remarks

Use this property to retrieve the child items of the RadSplitter control. You can also use it to programmatically add or remove items.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsContainer Class
RadSplitterItemsContainer Members

© telerik 2002-2008. All Rights Reserved.


Get more help

Telerik RadSplitter v1.3 Send comments on this topic.
Get more help

Glossary Item Box

In case you cannot find the needed information in this manual, you can also review the following resources:

  • online Knowledge Base - visit http://www.telerik.com/KB/ and browse or search the articles for a solution to your problem;
  • Telerik product forums at http://www.telerik.com/Forums/ - consult with other people who use our products;
    Use the in-built search on the page.
  • live examples at http://www.telerik.com/r.a.d.controls/ - use the left pane to navigate to the control and functionality you need. In the right pane, toggle among the various pages (Description, C#, ASPX, etc.) to learn about the functionality displayed.
  • online code library - visit http://www.telerik.com/community/code-library/default.aspx adn download a growing number of samples, get hands-on experience with the RadControls and submit some of your favorite implementations.
  • contact Telerik support with a technical question using your Client.NET account at http://www.telerik.com/Default.aspx?PageId=2069.

You can also send us comments on any topic by clicking on the link in the top right corner of the page:

The Send comments link

Alternatively, you can send an email to documentation@telerik.com with feedback or inquiries concerning our manuals.

© 2002-2008 Telerik. All Rights Reserved.


Glossary

Telerik RadSplitter v1.3 Send comments on this topic.
Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

© 2002-2008 Telerik. All Rights Reserved.


How-to

Telerik RadSplitter v1.3 Send comments on this topic.
How-to

Glossary Item Box

© 2002-2008 Telerik. All Rights Reserved.


Guidelines for Specifying Domain Names

Telerik RadSplitter v1.3 Send comments on this topic.
Guidelines for Specifying Domain Names

Glossary Item Box

To create a License key you will need to know the IP and domain/machine name by which you plan to access the control, i.e.

http://123.123.123.123/MyApplication/

http://www.mysite.com/MyApplication/

http://MachineName/MyApplication/

If you plan to sue the control on localhost or 127.0.0.1 you do not need keys - the control will work properly, but a copyright message will be displayed occasionally.

The control checks the URL by which it is accessed and compares this URL to the IP and domain name encoded in the license key. If these do not match, a copyright message will be shown.

Entering domain/machine names

Use only top-level domain names. The control will work on all other subdomains. Do not enter prefixes like www or http://

Original URL | Right | Wrong
http://www.mysite.com | mysite.com | www.mysite.com http://www.mysite.com
http://mysite.com | mysite.com | http://mysite.com
http://support.mysite.com | mysite.com | support.mysite.com
http://mydomain/ | mydomain | http://mydomain
http://machinename/ | machinename | http://machinenam

In case of a complex country-specific domain name (like www.mysite.co.uk, www.mysite.org.bg) you need to enter the actual domain name (mysite) followed by the full extension (co.uk):

Original URL | Right | Wrong
http://www.mysite.co.uk | mysite.co.uk | http://www.mysite.co.uk
http://mysite.gov.tw | mysite.gov.tw | http://mysite.gov.tw
http://www.support.mysite.biz.nl | mysite.biz.nl | http://www.support.mysite.biz.nl

If the the domain/machine name is unknown, or if the control will be used on localhost, use localhost in the domain field when creating the keys.

Entering IPs

Use only the top-level IP address. The control will work on all subdomains and ports. Do not enter prefixes like www or http://

Original URL | Right | Wrong
http://123.123.123.123/ | 123.123.123.123 | http://123.123.123.123
http://123.123.123.123:8080/ | 123.123.123.123 | 123.123.123.123:8080 http://123.123.123.123 http:// 123.123.123.123:8080

Do not enter an IP for the live server (not the development server) in case it has a domain name.

Original URL | Right | Wrong
http://www.mysite.com | mysite.com | http://123.123.123.123

If you have a dynamic DNS/IP, then it would be best to access the control by a domain name, rather than IP. In this case, use 127.0.0.1 in the IP field when creating the keys.

If the IP is unknown, or if the control is to be used on localhost only, use 127.0.0.1 in the IP field when creating the keys.

Other Important Information

If you are behind a firewall, the license ley will still work, as only the URL is checked.

The key will work for the major version of the product it was created for. For example, if the key is created for Telerik RadSplitter v1.x it will NOT work on another major version (such as v1.x).

Back to Setting License Keys.

© 2002-2008 Telerik. All Rights Reserved.


More About License

Telerik RadSplitter v1.3 Send comments on this topic.
More About License

Glossary Item Box

The LicenseFiles are XML files, which contain the licensing information (Company and LicenseKey) for every component of the Telerik RadControls for ASP.NET web-suite. This approach is much more convenient than setting licensing information directly in the control's properties, especially when you use multiple components on multiple pages. In case you upgrade your component, or implement the same application on a different server (domain) you have to change the Company and LicenseKey information only once – in the LicenseFile. Every Telerik component is shipped with a LicenseFile.XML located in the "~/RadControls" subfolder of the web-application. The LicenseFile property is set by default to point to this file so all you have to do is enter the required properties in the file. Below is a sample LicenseFile.XML:

<root>

<license control="editor" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY1"/>
<license control="spell" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY2"/>
<license control="menu" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY3"/>

</root>

Please, note that you may use a single LicenseFile to unlock more than one Telerik components.

If you place trial and commercial key(s), Standard or Professional edition, the editor will use the commercial key(s).

Note:The values set in the LicenseKey and Company properties of the Telerik RadEditor tag will override the ones set in the LicenseFile. If you want to use the LicenseFile approach make sure you remove the LicenseKey and Company properties from the Telerik RadEditor tag.

© 2002-2008 Telerik. All Rights Reserved.


Support Options

Telerik RadSplitter v1.3 Send comments on this topic.
Support Options

Glossary Item Box

© 2002-2008 Telerik. All Rights Reserved.


Upgrading Telerik RadSplitter v1.x Developer to Telerik RadSplitter v1.x Developer license

Telerik RadSplitter v1.3 Send comments on this topic.
Upgrading Telerik RadSplitter v1.x Developer to Telerik RadSplitter v1.x Developer license

Glossary Item Box

Follow the steps below to upgrade your Telerik RadSplitter v1.x Developer license to Telerik RadSplitter v1.3 Developer license.

These instructions are also valid for upgrading Telerik RadSplitter v1.x Developer license to a newer Telerik RadSplitter minor version.

THE PROCEDURE DESCRIBED IN THIS MANUAL IS IRREVERSIBLE AND YOU MAY LOSE YOUR DATA IF THE INSTALLATION IS NOT CARRIED OUT CORRECTLY!

1. Back up Your Old Files

We strongly suggest that you back-up your old Telerik RadSplitter files and folders, especially if you would like to use your old settings.

2. Obtain the Necessary File

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases".
  3. Locate the control that you need to install, i.e. Telerik RadSplitter, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. Since you have purchased the control, make sure you are downloading the proper file - the Developer version has the Dev abbreviation in it.

3. Install and Copy the New Files

  1. Unzip the files at a convenient location.
  2. Check the Changes and Backward Compatibility section for introduced changes. If there are such, they should be applied a little later in the upgrade process.
  3. Backup your application if you haven't done so already.
  4. Close Visual Studio or any ither IDE which may lock the old assembly.
  5. From the newly downloaded and unzipped files, copy the new DLL (RadSplitter.NET2.dll located in the bin folder) to your web-application's bin folder. Replace the old dll.
  6. Locate the old RadControls/Splitter folder and delete it manually, i.e. using Windows Explorer. By default, the RadControls/Splitter folder should be in the root of your application. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate it and delete it using Windows Explorer.
    DO NOT use Visual Studio to move, copy or delete the RadControls folder as this will break the Telerik control(s).
  7. If you intend to use skins different from the default or if you plan to modify the JavaScript files, copy the new RadControls/Splitter folder to the same location as above.
  8. If using VS.NET, update the control's reference in your project to point to the new DLL.
  9. Follow the steps in the Changes and Backward Compatibility section in case there are some changes between the versions.
  10. Recompile your project.
  11. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadSplitter to the Global Assembly Cache
  12. Run the project.
  13. If you still get the older version of Telerik RadSplitter Show click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadSplitter's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadSplitter, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....

  14. If you get a copyright message Show click here

    The copyright message appears only when using the trial version of Telerik RadSplitter (the Developer versions of Telerik's controls do not throw copyright messages). Make sure you have downloaded the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

4. Using the old ToolsFile.xml File and ConfigFile.xml file [valid for Telerik RadEditor and Telerik RadSpell only]

If you would like to use your old ToolsFile.xml and ConfigFile.xml files (which you backed up in #1 above), you can do so by copying them from the back-up to the RadControls\Editor folder (or RadControls\Spell respectively) of your web-application. When prompted to overwrite the other file, click "YES"

© 2002-2008 Telerik. All Rights Reserved.


Introduction

Telerik RadSplitter v1.3 Send comments on this topic.
Introduction

Glossary Item Box

Last Revised: 4/11/2008

© 2002-2008 Telerik. All Rights Reserved.


Assembly Overview

RadSplitter Assembly

Namespaces

Namespace | Description
Telerik.WebControls |


Getting Started - RadSplitter

Getting Started

© telerik 2002-2008. All Rights Reserved.


Introduction - RadSplitter

Introduction

© telerik 2002-2008. All Rights Reserved.


RadPane Class Events

RadPane Class Events
[image]
Telerik.WebControls Namespace : RadPane Class

For a list of all members of this type, see RadPane members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadPane Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadPane Class Methods

RadPane Class Methods
[image]
Telerik.WebControls Namespace : RadPane Class

For a list of all members of this type, see RadPane members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadPane Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadPaneBase Class Events

RadPaneBase Class Events
[image]
Telerik.WebControls Namespace : RadPaneBase Class

For a list of all members of this type, see RadPaneBase members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadPaneBase Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadPaneBase Class Methods

RadPaneBase Class Methods
[image]
Telerik.WebControls Namespace : RadPaneBase Class

For a list of all members of this type, see RadPaneBase members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadPaneBase Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadPaneBase Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPaneBase
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPaneBase Class
RadPaneBase Members

© telerik 2002-2008. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadPane Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadPane
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPane Class
RadPane Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadPane Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadPane
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadPane Class
RadPane Members

© telerik 2002-2008. All Rights Reserved.


RadSlidingPane Class Events

RadSlidingPane Class Events
[image]
Telerik.WebControls Namespace : RadSlidingPane Class

For a list of all members of this type, see RadSlidingPane members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSlidingPane Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSlidingPane Class Methods

RadSlidingPane Class Methods
[image]
Telerik.WebControls Namespace : RadSlidingPane Class

For a list of all members of this type, see RadSlidingPane members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSlidingPane Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadSlidingPane Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingPane
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingPane Class
RadSlidingPane Members

© telerik 2002-2008. All Rights Reserved.


RadSlidingZone Class Events

RadSlidingZone Class Events
[image]
Telerik.WebControls Namespace : RadSlidingZone Class

For a list of all members of this type, see RadSlidingZone members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSlidingZone Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


Skin Property

Skin Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : Skin Property

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Skin As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As String

instance.Skin = value

value = instance.Skin
C#
public virtual string Skin {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


SkinsPath Property

SkinsPath Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : SkinsPath Property

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinsPath As String
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As String

instance.SkinsPath = value

value = instance.SkinsPath
C#
public virtual string SkinsPath {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadSlidingZone Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSlidingZone
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSlidingZone Class
RadSlidingZone Members

© telerik 2002-2008. All Rights Reserved.


RadSplitBar Class Events

RadSplitBar Class Events
[image]
Telerik.WebControls Namespace : RadSplitBar Class

For a list of all members of this type, see RadSplitBar members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSplitBar Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitBar Class Methods

RadSplitBar Class Methods
[image]
Telerik.WebControls Namespace : RadSplitBar Class

For a list of all members of this type, see RadSplitBar members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSplitBar Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitBarCollapseMode Enumeration

RadSplitBarCollapseMode Enumeration
[image]
Telerik.WebControls Namespace : RadSplitBarCollapseMode Enumeration

Specifies the collapse mode of a splitbar

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Enum RadSplitBarCollapseMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RadSplitBarCollapseMode
C#
public enum RadSplitBarCollapseMode : Enum

Members

Member | Description
None | No collapse is available
Forward | Forward collapse availalbe only
Backward | Backward collapse availalbe only
Both | Both - forward and backward collapse available

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.RadSplitBarCollapseMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadSplitBar Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadSplitBar
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitBar Class
RadSplitBar Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadSplitBar Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSplitBar
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitBar Class
RadSplitBar Members

© telerik 2002-2008. All Rights Reserved.


RadSplitter Class Events

RadSplitter Class Events
[image]
Telerik.WebControls Namespace : RadSplitter Class

For a list of all members of this type, see RadSplitter members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSplitter Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterCollapseDirection Enumeration

RadSplitterCollapseDirection Enumeration
[image]
Telerik.WebControls Namespace : RadSplitterCollapseDirection Enumeration

Specifies the collapse direction options of the splitter bar

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Enum RadSplitterCollapseDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterCollapseDirection
C#
public enum RadSplitterCollapseDirection : Enum

Members

Member | Description
Forward | On collapse the current pane is collapsed
Backward | On collapse the next pane is resized

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.RadSplitterCollapseDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterItem Class Events

RadSplitterItem Class Events
[image]
Telerik.WebControls Namespace : RadSplitterItem Class

For a list of all members of this type, see RadSplitterItem members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSplitterItem Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterItem Class Methods

RadSplitterItem Class Methods
[image]
Telerik.WebControls Namespace : RadSplitterItem Class

For a list of all members of this type, see RadSplitterItem members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSplitterItem Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterItemsContainer Class Events

RadSplitterItemsContainer Class Events
[image]
Telerik.WebControls Namespace : RadSplitterItemsContainer Class

For a list of all members of this type, see RadSplitterItemsContainer members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadSplitterItemsContainer Class
Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadSplitterItemsContainer Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsContainer
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsContainer Class
RadSplitterItemsContainer Members

© telerik 2002-2008. All Rights Reserved.


Skin Property

Skin Property
[image]
Telerik.WebControls Namespace > RadSplitterItemsContainer Class : Skin Property

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Skin As String
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsContainer
Dim value As String

instance.Skin = value

value = instance.Skin
C#
public virtual string Skin {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsContainer Class
RadSplitterItemsContainer Members

© telerik 2002-2008. All Rights Reserved.


SkinsPath Property

SkinsPath Property
[image]
Telerik.WebControls Namespace > RadSplitterItemsContainer Class : SkinsPath Property

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SkinsPath As String
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsContainer
Dim value As String

instance.SkinsPath = value

value = instance.SkinsPath
C#
public virtual string SkinsPath {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsContainer Class
RadSplitterItemsContainer Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadSplitterItemsContainer Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItemsContainer
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItemsContainer Class
RadSplitterItemsContainer Members

© telerik 2002-2008. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadSplitterItem Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItem
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItem Class
RadSplitterItem Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadSplitterItem Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterItem
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitterItem Class
RadSplitterItem Members

© telerik 2002-2008. All Rights Reserved.


RadSplitterOrientation Enumeration

RadSplitterOrientation Enumeration
[image]
Telerik.WebControls Namespace : RadSplitterOrientation Enumeration

Specifies Orientation options for the RadSplitter object

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Enum RadSplitterOrientation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterOrientation
C#
public enum RadSplitterOrientation : Enum

Members

Member | Description
Vertical | Splitter panes are rendered verticaly
Horizontal | Splitter panes are rendered horizontaly

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.RadSplitterOrientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterPaneScrolling Enumeration

RadSplitterPaneScrolling Enumeration
[image]
Telerik.WebControls Namespace : RadSplitterPaneScrolling Enumeration

Specifies the scrolling options for the RadPane object

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Enum RadSplitterPaneScrolling
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterPaneScrolling
C#
public enum RadSplitterPaneScrolling : Enum

Members

Member | Description
Both | Both X and Y scrolls are displayed
X | Only the scroll on X dimension is displayed
Y | Only the scroll on Y dimension is displayed
None | No scrolls are displayed

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.RadSplitterPaneScrolling

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterResizeMode Enumeration

RadSplitterResizeMode Enumeration
[image]
Telerik.WebControls Namespace : RadSplitterResizeMode Enumeration

Specifies resize mode options for the RadSplitter object

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Enum RadSplitterResizeMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterResizeMode
C#
public enum RadSplitterResizeMode : Enum

Members

Member | Description
AdjacentPane | On resize of a pane the adjacent pane is resized also
Proportional | On resize of a pane the other panes are resize proportionaly
EndPane | On resize of a pane the end pane in the splitter is resized also

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.RadSplitterResizeMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterSlideDirection Enumeration

RadSplitterSlideDirection Enumeration
[image]
Telerik.WebControls Namespace : RadSplitterSlideDirection Enumeration

Specifies the available directions for the slide panes

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Enum RadSplitterSlideDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterSlideDirection
C#
public enum RadSplitterSlideDirection : Enum

Members

Member | Description
Right | Slide panes are sliding from left to right
Left | Slide panes are sliding from right to left
Top | Slide panes are sliding from top to bottom
Bottom | Slide panes are sliding from bottom to top

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.RadSplitterSlideDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadSplitterSlidePaneTabView Enumeration

RadSplitterSlidePaneTabView Enumeration
[image]
Telerik.WebControls Namespace : RadSplitterSlidePaneTabView Enumeration

Specifies views of the pane tab

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Enum RadSplitterSlidePaneTabView
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RadSplitterSlidePaneTabView
C#
public enum RadSplitterSlidePaneTabView : Enum

Members

Member | Description
TextAndImage | Pane tab is displayed using its Title and Icon
TextOnly | Pane tab is displayed using only its Title
ImageOnly | Pane tab is displayed using only its Icon

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.RadSplitterSlidePaneTabView

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Telerik.WebControls Namespace

© telerik 2002-2008. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadSplitter Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadSplitter (in RadSplitter.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadSplitter
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadSplitter Class
RadSplitter Members

© telerik 2002-2008. All Rights Reserved.


Telerik.WebControls Namespace

Telerik.WebControls Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
RadPane |
RadPaneBase |
RadSlidingPane |
RadSlidingZone |
RadSplitBar |
RadSplitter | Telerik RadSplitter is a flexible UI component for ASP.NET applications which allows users to manage effectively the content size and layout.
RadSplitterItem |
RadSplitterItemsCollection | A collection of RadSplitterItem objects in a RadSplitter control.
RadSplitterItemsContainer |

Enumerations

Enumeration | Description
RadSplitBarCollapseMode | Specifies the collapse mode of a splitbar
RadSplitterCollapseDirection | Specifies the collapse direction options of the splitter bar
RadSplitterOrientation | Specifies Orientation options for the RadSplitter object
RadSplitterPaneScrolling | Specifies the scrolling options for the RadPane object
RadSplitterResizeMode | Specifies resize mode options for the RadSplitter object
RadSplitterSlideDirection | Specifies the available directions for the slide panes
RadSplitterSlidePaneTabView | Specifies views of the pane tab

See Also

Reference

RadSplitter Assembly

© telerik 2002-2008. All Rights Reserved.


Telerik.WebControls Namespace Inheritance Hierarchy

Telerik.WebControls Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Telerik.WebControls.RadSplitterItemsCollection
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Telerik.RadSplitterUtils.RadControl
Telerik.RadSplitterUtils.RadSkinnableControl
Telerik.WebControls.RadSplitterItemsContainer
Telerik.WebControls.RadSlidingZone
Telerik.WebControls.RadSplitter
Telerik.WebControls.RadSplitterItem
Telerik.WebControls.RadPaneBase
Telerik.WebControls.RadPane
Telerik.WebControls.RadSlidingPane
Telerik.WebControls.RadSplitBar

See Also

Reference

RadSplitter Assembly

© telerik 2002-2008. All Rights Reserved.