introduction

Telerik RadRotator v2.7 Send comments on this topic.
introduction

Glossary Item Box

Thank you for choosing Telerik RadRotator!

Telerik RadRotator is a multipurpose component for DHTML content rotation and personalization. From stock tickers and news scrollers, to product spotlights, weather forecasts, testimonials, running promotions and banner ads, Telerik RadRotator delivers high interactivity and user involvement.

Telerik RadRotator is available individually or as part of the Telerik RadControls for ASP.NET and Telerik RadNavigation suites - the Telerik collections of UI essentials for rapid ASP.NET development.

This document contains information about the following:

  • What's New

  • Standards Compliance (XHTML and Accessibility)

  • Installation and Deployment

  • Setting and Customizing Telerik RadRotator

  • Telerik RadRotator Client-Side

  • Telerik RadRotator Server-Side

  • API Reference

If you need further assistance, please contact clientservice@telerik.com

Revised: 4/15/2008

© 2002-2008 Telerik. All Rights Reserved.


General Features

Telerik RadRotator v2.7 Send comments on this topic.
General Features
See Also

Glossary Item Box

  1. Wide cross-browser support - Telerik RadRotator supports all major browsers and platforms: Internet Explorer 5.5+; all Gecko-based browsers - Mozilla 1.0+, FireFox, Netscape 7+, and Opera 7.5x+
  2. Fully Customizable Appearance through CSS and Images - the visual appearance of Telerik RadRotator can be easily customized using CSS and images. All you need to do is to specify the path to the CSS file containing the CSS styles applied to the Telerik RadRotator.

    CSS
  3. Content Template Support - the content of each item can be easily defined through Content Templates. They can accommodate both HTML elements and ASP.NET WebControls. A Template can be populated both in Visual Studio® .NET design mode and manually with the code.

    Content Template
  4. Multiple rotators on a Single Page are Allowed - Telerik RadRotator allows the use of multiple rotators on one page, reusing a single code library for faster development and speed on the client.
  5. Enhanced Server-Side API - Telerik RadRotator features a richer server-side API. For example, Telerik RadRotator can be bound to a DataSet, DataTable or an XML document.
  6. Tickers and Ticklines - you can place unlimited number of tickers in a rotator as well as unlimited number of ticklines in a ticker.

See Also

What's New

© 2002-2008 Telerik. All Rights Reserved.


Accessibility Compliance

Telerik RadRotator v2.7 Send comments on this topic.
Accessibility Compliance
Standards Compliance > Accessibility Compliance

Glossary Item Box

Compliance Level

  1. Telerik RadRotator is Level AA content compliant (in conformance with the W3C Web Accessibility Guidelines 1.0).
  2. Telerik RadRotator satisfies the requirements of "Section 508" for software accessibility. As a result, the component can be used in US Federal Institutions and other organizations, which require software to be accessible to people with disabilities. The following feature is essential for Telerik RadRotator accessibility:

    ToolTip - shows extra information, when the user holds the mouse over the rotator for 1 second.

Section 508

The USA federal mandate requires that information technology be made accessible to people with disabilities. Much of Section 508 compliance concerns making Web sites, intranets, and web-enabled applications accessible. Section 508 compliance has since become a major prerequisite not only in government related software, but also in most enterprise and corporate software solutions.

W3C Web Content Accessibility Guidelines 1.0

The main goal of these guidelines is to encourage developers in creating applications providing accessible contents. Moreover, adhering to these guidelines will also make web content more accessible to all kind of users, using different devices and interfaces: desktop browser, voice browser, mobile phone, automobile-based personal computer, etc.

In accordance with these guidelines W3C defines three levels of conformance developers may implement in order to provide some level of content compliance to their products:

• Conformance Level "A"
• Conformance Level "Double-A"
• Conformance Level "Triple-A"

For more details on W3C "Web Content Accessibility Guidelines 1.0" see http://www.w3.org/TR/WAI-WEBCONTENT/

In our attempt to make our products content compliant, each web-control we develop and its QSF strive to obtain at least one of conformance levels listed above.

© 2002-2008 Telerik. All Rights Reserved.


XHTML Compliance

Telerik RadRotator v2.7 Send comments on this topic.
XHTML Compliance
See Also
Standards Compliance > XHTML Compliance

Glossary Item Box

Compliance Level

Telerik RadRotator now provides complete XHTML compliance.

The HTML output that is generated by default is fully XHTML 1.1 compliant.

If the content of Telerik RadRotator's FrameTemplate is not XHTML compliant, then the output of the rotator will also not be XHTML 1.1 content compliant.

XHTML

XHTML stands for EXtensible HyperText Markup Language and it is a stricter and cleaner version of HTML recommended by W3C (World Wide Web Consortium). XHTML is the effective inheritor of HTML 4.01 and although it is almost identical to its predecessor it is aimed to replace it.

See Also

New Classes and Properties in v2.x

© 2002-2008 Telerik. All Rights Reserved.


What is DNN (DotNetNuke)

Telerik RadRotator v2.7 Send comments on this topic.
What is DNN (DotNetNuke)
DNN > What is DNN (DotNetNuke)

Glossary Item Box

DotNetNuke (DNN) is an open source Portal and Content Management Framework, based on Microsoft's .NET technology. DNN offers a robust, extensible and fully functional framework for the development of a broad range of commercial portal applications.

For more information on DNN, visit the official DotNetNuke web site here.

DotNetNuke is able to create the most complex content management systems entirely with its built-in features, yet also allows administrators to work effectively with add-ons, third party assemblies, and custom tools. DNN modules and skins are easy to find, purchase, or build. Site customization and functionality are limitless.

© 2002-2008 Telerik. All Rights Reserved.


DNN Concepts

Telerik RadRotator v2.7 Send comments on this topic.
DNN Concepts
DNN > DNN Concepts

Glossary Item Box

What is a skinobject?

Skins Objects are active elements which can be included in the static HTML markup of a skin file to produce a dynamic user interface. There are a number of default skin objects included with DotNetNuke for common portal functions such as login, status, and navigation.

Custom skin objects are packaged and installed using the same process as Custom Modules ( Private Assemblies ). All of the necessary skin object resource files are combined with a DotNetNuke manifest file (*.dnn ) and packaged into a ZIP file. Example of a manifest file:

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<dotnetnuke version="2.0" type="SkinObject">
<folders>
<folder>
<name>CompanyName - PageTitle</name>
<modules>
<module>
<controls>
<control>
<key>PAGETITLE</key>
<src>PageTitle.ascx</src>
<type>SkinObject</type>
</control>
</controls>
</module>
</modules>
<files>
<file>
<name>PageTitle.ascx</name>
</file>
<file>
<name>YourCompanyName.PageTitle.dll</name>
</file>
</files>
</folder>
</folders>
</dotnetnuke>

For ASCX skins then you will need to specify the @Register and actual user control tag in your skin file ( ie. <dnn:Login runat="server" id="dnnLogin" /> ). If you are creating HTML skins then you simply need to specify the token ( ie. [LOGIN] ).

Skin objects support the concept of named instances. For example, if you want to have two menu controls in your skin, you can specify [MENU:1] and [MENU:2] in your skin file. In most cases you will only be using a single instance of a skin object in your skin and in this case it is fine to use a singleton instance specification ( ie. [MENU] ).

Skin objects also contain attributes. Each skin object has its own set of supported attributes. If you are creating ASCX skins then you will need to specify the attribute directly in your skin file ( ie. <dnn:Login runat=”server” id=”dnnLogin” Text=”Signin” /> ). If you are creating HTML skins then you must include your attributes specifications in a separate file – this preserves the presentation of the HTML skin file for the designer. A skin package can contain a global attributes specification named “skin.xml” (or “container.xml” for containers) which applies to all skin files in the package. In addition, you can also override the global skin attribute specification with a skin specific attribute specification by providing a “skinfilename.xml” file. The skin uploader will merge the skin attributes with the HTML presentation file to create an ASCX skin file. The following XML fragment represents the structure of the attributes file:

Copy Code
<Objects>
<Object>
<Token>[LOGIN]</Token>
<Settings>
<Setting>
<Name>Text</Name>
<Value>Sign in</Value>
</Setting>
</Settings>
</Object>
</Objects>

There is a one to one correspondence of skin object declarations in your skin file (i.e. [MENU]) with the attribute specification in the XML file. This is also true for named instances.

What is a skin?

Skins are customized and interchangeable sets of graphics which allow administrators to easily change the look of their websites, without having to reorganize their content. In "skinning" a site, administrators can completely change the look of their portal without the need to reorganize content – all at the click of a button.

NOTE:

Since skins are based on ASCX files which are essentially executable once they are added to an ASPX page, there is some risk that malicious script could be inserted into the skin files – putting the entire installation in danger. Be sure to download skins only from trusted locations.

How do skins work?

DNN uses placeholders to separate the skin objects from the static markup which designers can then include in their skin. Placeholders are simply [TOKEN] text, which uniquely identify a skin object. To mitigate the performance impact of replacing these placeholders at runtime, DNN features a simple skin upload mechanism which does the substitution of placeholders with the skin objects to produce a user control file (.ascx) which can then be rendered by the engine. This pre-processing occurs only once when the skin is uploaded.

Skins can be applied at a host (the whole DNN install), portal (only one site), or tab (single page) level. Skins can also be applied at the module level (in this case they are referred to as Containers). All skin files are organized under the Portals folder. Child assignments are able to override parent assignments (i.e. a skin applied at the tab level should override a skin applied at the portal level).

A skin or container package is comprised of multiple files which constitute a complete skin:

*.htm, *.html files – abstract skin definition files which will be processed by the skin uploader to create an *.ascx file

*.ascx files – skin definition user controls which are precompiled in the format required by the skin engine.

*.css files – styles sheets related to skins

*.gif, *.jpg, *.jpeg, *.png – supporting graphics files

*.* – any other resource files required for the skin (allowable file extensions are secured by the Host “File Upload Extensions” setting)

Skin definitions can be created using two different methods, HTML or ASCX ( user controls ). Basically the only difference between the two methods is the file extension of the skin definition file and the use of tokens versus actual user control tags.

Content panes are the containers for the content modules which are automatically injected at runtime. Content panes are simply HTML tags with some custom attributes specified specifically an ID and a RUNAT=”SERVER” attribute ( ie. <TD ID=”ContentPane” RUNAT=”SERVER”>).

What is a Container?

As mentioned earlier, containers are skin definitions which can be applied to content modules. A container is defined in exactly the same manner as a skin except for the fact that there are a different set of skin objects used in containers.

What is a module?

Simply, they are modular pieces of code which provide some form of specific functionality to the user, and are grouped together in units to form complete web pages. These modules can be easily added, edited, deleted, restored, moved around on a page, or transferred to other pages. DotNetNuke installation includes over 25 free modules. These are: Account LogIn, Announcements, Banners, Contacts, Discussion, Documents, Events List/Calendar, FAQs, Feedback, IFrame, Image, Links, News Feed (RSS), Search Input, Search Results, Service Directory, Survey, Text/HTML, User Accounts, User Defined Table, Users Online, Weblog Calendar, Weblog Recent List, Weblog Referrals List, Weblogs, and XML/XSL.

© 2002-2008 Telerik. All Rights Reserved.


RadControls for DNN

Telerik RadRotator v2.7 Send comments on this topic.
RadControls for DNN
DNN > RadControls for DNN

Glossary Item Box

The Telerik RadControls suite is the most innovative and comprehensive tool set for ASP.NET development, tailored for seamless integration with the DotNetNuke project. This integrated collection of controls allows professionals to build web-solutions with the UI richness and responsiveness of desktop applications. From the WYSIWYG editor, to navigation, the RadControls DotNetNuke Edition allows you to substantially enhance the interface and usability of your DotNetNuke projects.

Telerik offers the following products for DNN:

  • RadMenu - SkinObject and a sample skin
  • RadPanelbar - SkinObject and a sample skin
  • RadTabstrip - SkinObject and and a sample skin
  • RadTreeview - SkinObject, a sample skin, and a module
  • RadEditor - HtmlEditorProvider (which can be used instead of the default DNN editor)
  • RadCalendar - SkinObject(which can be used instead of the default DNN calendar) and a module
  • RadGrid - a sample module
  • RadRotator - a module
  • RadAjax - a sample module

A SkinObject can be used as a component of a DNN skin. A SkinObject by itself is useless unless you make it a part of a skin. For example, consider the sample RadMenu skin:

SkinObject and skin
Enlarge Click to enlarge

A module can be inserted in a pane to provide some functionality. For example consider the RadCalendar module:

RadCalendar module
Enlarge Click to enlarge

© 2002-2008 Telerik. All Rights Reserved.


How to download RadRotator for DNN

Telerik RadRotator v2.7 Send comments on this topic.
How to download RadRotator for DNN
DNN > How to download RadRotator for DNN

Glossary Item Box

  1. Log in your Client.NET account.
  2. Go to Products -> RadControls for ASP.NET -> Download Trial
  3. Click on the individual products tab to expand the list of controls

    Enlarge Click to enlarge
  4. Click on a control to expand the list of available files for download

    Enlarge Click to enlarge
  5. Download the DNN module or skin

    Enlarge Click to enlarge

© 2002-2008 Telerik. All Rights Reserved.


Overview

Telerik RadRotator v2.7 Send comments on this topic.
Overview
See Also
ASP.Net 2.0 Features > Overview

Glossary Item Box

This version of Telerik RadRotator is complied against the .NET 2.0 framework and offers new specific features for Microsoft's next-generation IDE - Visual Studio .NET 2005. The new release will enable developers to enjoy significant productivity gains, while delivering feature-rich, standards-compliant, AJAX-enabled, and cross-browser compatible web applications.

Feature Highlights

  • More powerful VS.NET design-time support - the design-time functionality of r.a.d.rotator has been enhanced to support the new version of Visual Studio .NET 2005, along with its new productivity features like Smart Tags.
  • Smart Tags - r.a.d.rotator takes advantage of the Smart Tags, which provide quick access to commonly used configurations from a convenient panel right within the design surface of Visual Studio .Net.
  • Declarative DataSource support - using the Data access model in ASP.NET 2.0, the data access in r.a.d.rotator for .NET 2.0 can be accomplished in a declarative completely manner (no code) using the new data-bound and data-source controls. They significantly simplify the representation of different data back-ends such as SQL databases, business objects, and XML files.
  • Support for .NET 2.0 Themes - the themes and skins features in ASP.NET 2.0 allow for easy customization of controls appearance. You can define style information in a common location called "Theme", and apply that style information globally to pages or controls in your site. Just like Master Pages, Themes improve the maintainability of your applications and eliminate the unnecessary duplication of code for shared styles.

Product Versions

With the release of Telerik RadControls for ASP.NET for .NET 2.0, Telerik will be maintaining two separate versions - one for .NET 1.x and one for .NET 2.0. The two versions will be identical in terms of features except where mandated by the platform.

Updates

Telerik RadRotator for .NET 2.0 will be available to customers who own a current Subscription license or have a Single Developer License, volume Q3 2005.

See Also

Smart Tags
Data Source
SiteMapDataSource Control
Support for .Net 2.0 Themes

© 2002-2008 Telerik. All Rights Reserved.


Smart Tags

Telerik RadRotator v2.7 Send comments on this topic.
Smart Tags
See Also
ASP.Net 2.0 Features > Smart Tags

Glossary Item Box

r.a.d.rotator takes full advantage of the Smart Tags introduced in Visual Studio 2005. In the IDE infrastructure Smart Tag entries are called "designer action items" and are shuttled around the design time in groups known as "designer action lists". As a requirement for Smart Tag support, r.a.d.rotator passes a "designer action list" containing at least one "designer action item" to the Web Forms designer. The same "designer action list" is then passed to the Smart Tag panel, which converts each designer action item into an equivalent visual task.

Using the Smart Tag Panel

When an instance of Telerik RadRotator is selected on the Web Form's design surface, a Smart Tag anchor is displayed in its top-right corner. The anchor is a button that opens the Smart Tag panel.
A Smart Tag panel is a designer-managed UI that exposes component configurations as a set of Smart Tag entries.

The screenshot below shows the Smart Tag panel for an instance of a Telerik RadRotator control.

See Also

Overview

© 2002-2008 Telerik. All Rights Reserved.


Data Source

Telerik RadRotator v2.7 Send comments on this topic.
Data Source
See Also
ASP.Net 2.0 Features > Declarative DataSource Support > Data Source

Glossary Item Box

The ASP.NET 2.0 platform provides an entirely new approach to data binding, which eliminates the coding necessary for connecting a control to its underlying data source. Telerik r.a.d.rotator employs this new way for accessing data, so that its data binding can be accomplished in a completely declarative manner using the new data source controls.

Declarative data source controls expose data from a back-end store (SQL database, middle-tier business object, XML file, XML Web Service) to data-bound UI control on a page. Data Source controls also provide new capabilities such as sorting, paging, caching, updating, inserting, and deleting data, which UI controls can automatically use of without any additional code.

Data Source Controls

Data source controls have no rendering, but instead represent a particular backend data store, for example a database, business object, XML file, or XML Web Service. ASP.NET includes the following server controls out-of-the-box supported by Telerik RadRotator:

  • SqlDataSource - Enables binding to a SQL database represented by an ADO.NET provider, such as Microsoft™ SQL Server, OLEDB, ODBC, or Oracle.

SqlDataSource is intended to replace the ADO.NET code you would normally write in a page to create a connection and command to query a database. Because the data queries are specified directly as properties of the data source control, this is sometimes called a two-tier model, because the data queries are still maintained in page code.

  • ObjectDataSource - Enables binding to a middle-tier object such as a data access layer or business component.

The ObjectDataSource control object model is similar to the SqlDataSource control. Instead of a ConnectionString property, ObjectDataSource exposes a TypeName property that specifies an object type (class name) to instantiate for performing data operations. Similar to the command properties of SqlDataSource, the ObjectDataSource control supports properties such as SelectMethod, UpdateMethod, InsertMethod, and DeleteMethod for specifying methods of the associated type to call to perform these data operations.

  • AccessDataSource - Enables binding to a Microsoft™ Access (Jet) database.
  • SiteMapSource - Enables binding to the hierarchy exposed by an ASP.NET 2.0 site navigation provider.

The SiteMapDataSource control is associated to a data-bound control through the control's DataSourceID property. For general information on site navigation in ASP.NET, refer to the SiteMap topic of this manual.

  • XmlDataSource - Enables binding to an XML file or document.

XmlDataSource supports a DataFile property for specifying the path to an XML data file to be used as input. You may also specify a TranformFile property to apply an XSLT transformation to the data and an XPath property for specifying a subset of nodes to expose from the data source.

See Also

Smart Tags
SiteMapDataSource Control

© 2002-2008 Telerik. All Rights Reserved.


SiteMapDataSource Control

Telerik RadRotator v2.7 Send comments on this topic.
SiteMapDataSource Control
See Also
ASP.Net 2.0 Features > Declarative DataSource Support > SiteMapDataSource Control

Glossary Item Box

SiteMapDataSource control lets you define the structure of your site and bind any navigational control to it. You can have only one site map per site. By default the SiteMapDataSource control will use the default Site Navigation Provider. This provider lets you define the structure of your site separately of the real page structure of the site from one side, and the UI presentation from the other. The default site navigation provider is XML-based. It should stay in the root level of your project and should be named web.sitemap. Using the Site navigation API provided in ASP.NET v2.0 you can write your own Site Navigation Provider and expose the navigation information from any back-end system if needed.

Setting the SiteMapDataSource control

Before you add the SiteMapDataSource control to your page, you need to add the Site Navigation Provider.

Setting the default Site Navigation Provider

Use the solution explorer and [Add New Item...] command. In the templates dialog choose Site Map.

When the web.sitemap file is created, Visual Studio generates the default initial code.

Copy Code
<?xml version="1.0" encoding="utf-8" ?>

<siteMap xmlns="http://schemas.microsoft.com/AspNet/SiteMap-File-1.0" >
<siteMapNode url="" title="" description="">
<siteMapNode url="" title="" description="" />
<siteMapNode url="" title="" description="" />
</siteMapNode>
</siteMap>

Each siteMapNode has three attributes:

  • url - the URL of the page. It can be either a relative (using the ~/) or an absolute path.
  • title - the string that will appear in the navigational control.
  • description - a short text that will appear as a tooltip if the navigational control supports this feature.

You cannot have more than one siteMapNode pointing to the same page.

Below is an example of a site map file, which you can paste in your test project:

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<siteMap xmlns="http://schemas.microsoft.com/AspNet/SiteMap-File-1.0" >
<siteMapNode url="http://www.telerik.com" title="Telerik" description="Telerik home page">
<siteMapNode url="http://www.telerik.com/radcontrols" title="Telerik RadControls for ASP.NET" description="Telerik RadControls for ASP.NET" >
<siteMapNode url="http://www.telerik.com/radeditor" title="Telerik RadEditor" description="Telerik RadEditor control"/>
</siteMapNode>
<siteMapNode url="http://www.telerik.com/radnavigation" title="Telerik RadNavigation controls" description="Telerik RadNavigation controls" />
</siteMapNode>
</siteMap>

Setting the SiteMapDataSource control

After you have successfully set the Site Navigation Provider, you can set the SiteMapDataSource control to use it. Point to a navigation control on your site (e.g. treeview, rotator, etc.) and expand the Smart Tag panel of that control. Open the "Choose Data Source" dropdown and select the <New data source...> option.

Then choose the SiteMapDataSource control:

Visual Studio .NET will create the control and bind it to the navigational control.

The screenshot below shows a treeview and a menu bound to the site map described in this example:

See Also

Data Source

© 2002-2008 Telerik. All Rights Reserved.


What's New

Telerik RadRotator v2.7 Send comments on this topic.
What's New
See Also
Already Using the Control > What's New

Glossary Item Box

What's new in Telerik RadRotator v2.6

The current version features numerous bug fixes and performance optimizations.

What's new in Telerik RadRotator v2.5

  1. Seamless interoperability with ASP.NET AJAX Release Candidate
  2. Full compatibility with Visual Studio .NET 2005 Service Pack 1 and ASP.NET Web Application Project template
  3. Telerik RadRotator now works outside server-side forms (does not require nesting inside <form runat="server">)

What's new in Telerik RadRotator v2.4

ItemDataBound() event is implemented

What's new in Telerik RadRotator v2.3

As of our Q2 2006 release all resources (scripts, the default skin, etc) are implemented as Embedded WebResources in ASP.NET 2.0 for a very easy and convenient deployment. The only thing you now need to do is drag r.a.d.rotator from your toolbox onto your web page (no external files will be required). The /RadControls folder will only be needed if you plan to use a skin other than the default or if you make any modifications to the script files.

Due to the significant changes in the system architecture of Telerik RadRotator v2.x, the component is not 100% backward compatible with v1.x. Please review section "Upgrading Instructions - Telerik RadRotator v1.x to Telerik RadRotator v2.x".

What's new in Telerik RadRotator v2.2

Telerik RadRotator is now compatible with Atlas. See Atlas support.

What's new in Telerik RadRotator v2.1

  1. Full support for ASP.NET 2.0

    The present version of Telerik RadRotator is compiled against the .NET 2.0 framework and offers new specific features for Microsoft's next-generation IDE - Visual Studio .NET 2005. The new release will enable developers to enjoy significant productivity gains, while delivering feature-rich, standards-compliant, AJAX-enabled, and cross-browser compatible web applications.

  2. Enhanced Design Time Support

    Telerik RadRotator now provides full support for the design mode of Visual Studio. It takes full advantage of the Smart Tags introduced in Visual Studio 2005. When an instance of Telerik RadRotator is selected on the Web Form's design surface, a Smart Tag anchor is displayed on its top-right corner. The anchor is a button that opens the Smart Tag panel. A Smart Tag panel is a designer-managed UI that exposes component configurations as a set of Smart Tag entries.

  3. Declarative DataSource Support under ASP.NET 2.0

    r.a.d.rotator employs this new way for accessing data, so that its data binding can be accomplished in a completely declarative manner using the new data source controls.

    Declarative data source controls expose data from a back-end store (SQL database, middle-tier business object, XML file, XML Web Service) to data-bound UI control on a page. Data Source controls also provide new capabilities such as sorting, paging, caching, updating, inserting, and deleting data, which UI controls can automatically use of without any additional code.

    However if need be, you can still use the powerful API to populate the rotator(add, delete, disable/enable, check/uncheck items) programmatically at code behind. This functionality has been available since version 2.x.

What's new in Telerik RadRotator v2.0

  1. Accessibility Compliance

    Telerik RadRotator is "Level AA" content compliant (in accordance with the W3C Web Accessibility Guidelines 1.0).
  2. XHTML Compliance

    Telerik RadRotator provides XHTML compliance depending on the content of the HTML structure in the FrameTemplate. If the content in Telerik RadRotator's FrameTemplate is XHTML 1.1 is compliant, then the output of the rotator will be XHTML 1.1 content compliant as well.

  3. Effortless Data Binding

    Telerik RadRotator fully supports native .NET connectivity with various data sources. You can bind an instance of Telerik RadRotator to any one of the following data sources:

    1- Ienumerable(Array, ArrayList, Queue, Stack, etc.)

    2- IListSource(DataSets, DataTables and DataViews)

    3- Static XML file

    4- Live XML data source

    In order to bind an instance of Telerik RadRotator to some data source, all you need is to create an object (for example an IListSource) to hold the data you want bind to the rotator and set the DataSource property as well as the DataBind() method.

  4. Flexible Client-Side API

    Telerik RadRotator offers client-side API which allows the developer to create rotators with rich functionality, whose behaviors can be easily manipulated at client-side. For example you can specify whether scrolling or slideshows should pause when the mouse hovers over the control. You can also readily adjust the speeds of scrolling and smooth-scrolling. (See live demo)

    The RadRotator class provides eight functions: StartRotator, StopRotator, ShowPrevFrame, ShowNextFrame, ScrollUpNextFrame, ScrollDownNextFrame, ScrollLeftNextFrame and ScrollRightNextFrame you can use to manipulate the state of the rotator.

  5. Support for Relative Sizes

    The width and heigh of Telerik RadRotator can now be specified in percentage as well.

  6. Client-Side Events

    Telerik RadRotator provides two client-side events: OnClientFrameChanging and OnClientFrameChanged which allow the developer to control the behavior of the rotator from client-side.

    The OnClientFrameChanging event is used to control the behavior of the frame. It fires whenever a frame of Telerik RadRotator is about to change. However if the user returns false in the event handler, the frame will not change. On the other hand the OnClientFrameChanged event fires after the frame is changed.
    Client API

  7. Server-Side Events

    Telerik RadRotator implements postback event used to control the behavior of the rotator at runtime. The property "PostBack" instructs Telerik RadRotator to send a postback event with the respective item instance to the server, and the custom code can handle the event as needed - for example whenever the user clicks with the mouse.

  8. Scrolling and Sliding Items

    you can easily specify the transition type and effects. Transition can be specified as either scrolling or sliding; and you can specify the order of the transition to be either random or follow a predefined pattern.
    For scrolling items you have to set the TransitionType property to either slide or scroll. There are three properties: ScrollDirection, ScrollSpeed and SmoothScroll used for specifying the transition effects.
  9. Transition Effects

    You can easily specify the transition type and effects. Transition can be specified as either scrolling or sliding; and you can specify the order of the transition to be either random or follow a predefined pattern.
    For scrolling items you have to set the TransitionType property to either slide or scroll. There are three properties: ScrollDirection, ScrollSpeed and SmoothScroll used for specifying the transition effects.
  10. IE DXTransformFilter

    Telerik RadRotator provides a single IE filter allowing the developer to easily create fancy transition effects such as fading, pixelate, etc.

  11. Unlimited nesting of Tickers and Ticklines

    You can place unlimited number of tickers in a rotator as well as unlimited number of ticklines in a ticker.

See Also

General Features

© 2002-2008 Telerik. All Rights Reserved.


Changes and Backward Compatibility

Telerik RadRotator v2.7 Send comments on this topic.
Changes and Backward Compatibility
Already Using the Control > Changes and Backward Compatibility

Glossary Item Box

Telerik RadRotator v2.5 to Telerik RadRotator v2.7 (part of Q2 2007)

There are no major changes and the product is fully backwards compatible.

Telerik RadRotator v2.5

This section provides information about the following changes in Telerik RadRotator v2.x:

New Classes and Properties

Deprecated Classes and Properties

Atlas compatibility note
Atlas support may pose problems with the functionality of your web site, whether you are using Atlas or not. See Atlas support for more details.

© 2002-2008 Telerik. All Rights Reserved.


New Classes and Properties in v2.x

Telerik RadRotator v2.7 Send comments on this topic.
New Classes and Properties in v2.x
See Also
Already Using the Control > New Classes and Properties in v2.x

Glossary Item Box

Due to the significant changes in the system architecture of Telerik RadRotator v2.x, the component is not 100% backward compatible with v1.x. Please review section "Upgrading Instructions - Telerik RadRotator v1.x to Telerik RadRotator v2.x".

New Classes in Telerik RadRotator

The following two new classes are added to Telerik RadRotator:

  • RadRotatorClickEventArgs
  • RadRotatorFrame

New Properties in RadRotator Class

Property

Description

AutoAdvance | Specifies whether RadRotator will advance through its slides automatically.

AutoPostBack

Specifies wether the control will require postback event handling.

FramesToShow | Specifies how many frames are visible in rotator.

PauseOnMouseOver

Specifies wether scrolling or slideshows pause when the user hovers the mouse cursor over the control.

SmoothScrollDelay | Specifies the smooth-scrolling effect delay of the RadRotator instance.

TransitionEffect

Specifies the transition effect for the slideshow mode.

TransitionType

Specifies the transition type. Could be Scroll or Slideshow.

UseRandomSlide

Specifies wether the rotator will choose a random slide when in Slideshow mode.

UseSmoothScroll

Specifies wether the Scrolling effect smooth.

New Properties in RadTicker Class

Property

Description

AutoAdvance

Specifies whether RadRotator will advance through its slides automatically.

AutoPostBack

Specifies wether the control will require postback event handling.

AutoStart

Specifies the CSS class that should be used for the rotator <DIV> element. If not specified, the default item CSS

class is used as defined in DefaultItemCss property of RadRotator.

LineDuration

Specifies the path to the CSS file containing the CSS styles applied to the Telerik RadRotator. The path is relative to

application root.

Loop

 Specifies whether or not RadTicker will repeat the first tickerline after displaying the last one.

TickSpeed

Specifies wether scrolling or slideshows pause when the user hovers the mouse cursor over the control.

See Also

XHTML Compliance

© 2002-2008 Telerik. All Rights Reserved.


Deprecated Classes and Properties

Telerik RadRotator v2.7 Send comments on this topic.
Deprecated Classes and Properties
See Also
Already Using the Control > Deprecated Classes and Properties

Glossary Item Box

Due to the significant changes in the system architecture of Telerik RadRotator v2.x, the component is not 100% backward compatible with v1.x. Please review section "Upgrading Instructions - Telerik RadRotator v1.x to Telerik RadRotator v2.x".

Deprecated Classes in Telerik RadRotator

The following two classes are not in use any more:

  • RotatorDataItem
  • TickerLine

Deprecated Properties in RadRotator Class

Property

Description

Company

FrameChangeType

"Scroll" or "Frame". "Scroll" instructs Telerik RadRotator to scroll different slide, while "Frame" shows then one at a time

in a slideshow.

FrameEffect

The transition effect applied to frames when FrameChangeType is set to "Frame".

GroupFilter

NextFrameDelay

The delay in ms to display/scroll the next frame.

PathToJavaScript

Used for client side script caching. If set, Telerik RadRotator will search for the JavaScript file (radrotator_client.js) and

link it externally instead of directly embedding JavaScript code into the page.

ScrollHeight

How many pixels to scroll when ScrollDirection is Vertical.

ScrollWidth

How many pixels to scroll when ScrollDirection is Horizontal.

Deprecated Properties in RadTicker Class

Property

Description

Controls

CssClass

The Css Style applied to the ticker

NewCharDelay

The pause in ms the ticker waits to display the next character of the current line.

StatusBar

If set to true, the ticker text is displayed in the status bar.

Text

The line to display. Use only when the ticker is nested in a rotator or when there's only one line. Otherwise use

nested TickerLine controls.

See Also

New Classes and Properties in v2.x

© 2002-2008 Telerik. All Rights Reserved.


Which license should I use or purchase

Telerik RadRotator v2.7 Send comments on this topic.
Which license should I use or purchase
See Also
Licensing > Which license should I use or purchase

Glossary Item Box

Telerik offers several different packages for you to choose from:

Trial licenses

Description

If you are a first-time Telerik user, it would be best to create an account in our Client.NET extranet (www.telerik.com/Clientnet) and download a Trial license. The Trial licenses are fully-functional and are identical in functionality to the paid versions. Review the Which file do I need to install? section for further instructions.

Support

A trial license comes with the Bronze Support package, which guarantees a 72-hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used. Mail queries usually take longer to respond.

For more information, review the available Support Options.

Single Developer licenses

Description

A Developer license is granted per developer seat: one developer is allowed to work with the product per license. Developer licenses have no run-time limitations and allow the usage of all Telerik controls in an UNLIMITED number of custom web applications. The controls can be installed on more than one machine as long as only the licensed developer is using the product.

License Keys

Developer licenses come with special builds that work without keys and allow the developer to safely access web applications that use Telerik products. To update your application from a trial license to a Developer license, please review the instructions in the following section: Trial License v1.x to Developer License v2.x

Support

The Single Developer license comes with the Silver Support package which guarantees a 48 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used.
Mail queries usually take longer to respond.

For more information, review the available Support Options.

Single Developer Subscription license

Description

Unlike the Single Developer license, Single Developer Subscription license offers a Subscription. A Subscription license entitles you to receive, for free, all released updates and new products for the duration of one year from the date of purchase. This license is the easiest and most cost-effective way to ensure that you are using the latest versions of our products. With the Subscription license you save more than 70% on Telerik products if purchased separately.

The Single Developer Subscription license is offered for the Telerik RadControls for ASP.NET suite only. Subscriptions are not available for individual products at this time.

You can renew your subscription at approximately 50% of the original price. You will be promptly notified when the Subscription license is about to expire.

All RadControls for ASP.NET subscription holders are entitled to a license to RadControls "Prometheus" suite.

License Keys

The Developer license comes with a special build that work without keys and allow the developer to safely access web applications that use Telerik products. To update your application from Trial to a Developer license, please review the instructions in the following section: Trial License v1.x to Developer License v2.x

Support

The Single Developer Subscription license comes with the Gold Support package which guarantees a 24 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used.
Mail queries usually take longer to respond.

For more information, review the available Support Options.

Telerik maintains a public Product Roadmap, which will give you details on the upcoming products and versions for the next quarter. This guarantees that you see a good return on your investment in the Subscription license.

Source Code license

Description

The Source Code license is an excellent investment if you need to customize our controls to fit a specific requirement, or if your company wishes to own the source code for all products used.

A Source Code license is offered with purchases of five or more Single Developer or Single Developer Subscription licenses for Telerik RadControls for ASP.NET suite. If you have opted for the Subscription license, you will be receiving the source codes for all products released within one year from the date of purchase.

Source Code licenses are offered for the Telerik RadControls for ASP.NET suite only and are not available for individual products at this time.

Support

The Source Code license comes with the Gold Support package, which guarantees a 24 hour response time from the Telerik support staff on business days (Monday thru Friday) when the Online Support Ticketing System is used. All questions from Source code licensees are treated with priority.

For more information, review the available Support Options.

Custom Source Code modifications are not supported by Telerik.

Discounts Offered

Telerik offers the following volume discounts on all licenses:

  • 3 to 4 licenses - 10%
  • 5 to 9 licenses - 20%
  • 10 to 19 licenses - 30%
  • 20 or more - 40%

Telerik also offers discounts to qualified educational, non-profit, charity and government entities. For more information on how to qualify for a discount, visit our Special pricing page.

See Also

Sales FAQ page
Purchase Online
Support Options
Support FAQ
Client.Net FAQ
License Agreement

© 2002-2008 Telerik. All Rights Reserved.


License Agreement

Telerik RadRotator v2.7 Send comments on this topic.
License Agreement
Licensing > License Agreement

Glossary Item Box

Telerik End-User License Agreement

By purchasing, installing, or otherwise using the product identified above and/or its related materials, you agree to be bound by the terms and conditions of this License Agreement. Check the box "I have read and agree to the License Agreement" if you agree.

IMPORTANT – READ CAREFULLY: This license agreement ("LICENSE") is a legal agreement between you (either an individual or a single entity, also referred to as "LICENSEE", "YOU") and Telerik Corp., ("TELERIK"), for the software containing this LICENSE which may also include the software’s source code written in a high-level computer language, associated media, printed materials, and "online" or electronic documentation (collectively referred to as “SOFTWARE”).

Any earlier license we may have granted to you for the use of earlier versions of the SOFTWARE is replaced by this LICENSE.

SOFTWARE PRODUCT LICENSE

The SOFTWARE is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties and contains confidential information and trade secrets. TELERIK retains all rights not expressly granted to you in this LICENSE.

I. GRANT OF LICENSE

TELERIK hereby grants to you, and you accept, a non-exclusive, non-transferable license to install, copy, use and modify the SOFTWARE only as authorized below.

This license grants you no rights to the "2007 Microsoft Office System User Interface". For appropriate license, please, contact Microsoft directly.

1. TRIAL LICENSE

You are granted a license for evaluation purposes only. You are authorized to install, copy, and use the SOFTWARE for the sole purpose of testing its functionality. You are not allowed to integrate it in end products or use it for any commercial purpose.

2. DEVELOPER LICENSE

The SOFTWARE is licensed per Developer seat. This means that each individual using or otherwise accessing the SOFTWARE for development purposes must obtain the right to do so by purchasing an individual product license.

You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same licensed developer. The SOFTWARE is in "use" on a computer when it is loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard disk or other storage device) of that computer for development purposes. If you install the SOFTWARE on a network server for the sole purpose of internal distribution among licensed developers this is not considered “use” of the SOFTWARE.

2-1. Redistribution rights:

All product licenses are perpetual and royalty-free. You can ship the SOFTWARE as part of solutions for internal company use, hosted applications, commercial solutions deployed at end-users’ sites or shrink-wrapped software (PACKAGED PRODUCTS) in which the SOFTWARE is integrated.

You may distribute the SOFTWARE provided that:

  • You reasonably ensure that the SOFTWARE is not distributed in any form that allows it to be reused by any application other than your solution. Technical guidelines will be provided upon request, please contact support@telerik.com for more details.
  • You need to duly inform your customers that they are not allowed to use the SOFTWARE independently from your solution. For use of the SOFTWARE in design-time (i.e. within a development environment such as Microsoft Visual Studio) your customers need to purchase the appropriate number of Developer Licenses from TELERIK.
  • You need to include a valid copyright message in your solution in a location viewable by the end-users (e.g. "About" box).

2-2. Silver Support:

As part of your license you are entitled to "Silver" Support Package which guarantees response within 48 hours.

3. DEVELOPER LICENSE PLUS SUBSCRIPTION AND SOURCE CODE LICENSE

You are granted 1 (one) Developer License as defined above. In addition you are entitled to a 1 Year Subscription, Source Code and Gold Support Package.

3-1. Subscription

You are entitled to receive all version updates for the SOFTWARE for a period of 1 (one) year.

  • 3-2. Source Code

    As part of the DEVELOPER PLUS SUBSCRIPTION AND SOURCE CODE LICENSE you are granted the right to view and modify the SOFTWARE's source code only as authorized below:
  • The SOFTWARE's source code is provided to the licensed developer for the sole purposes of education and troubleshooting. The SOFTWARE's source code cannot be used as a basis of development of derivative works or other software products.
  • Under no circumstances may any portion of the SOFTWARE’s source code or any modified version of the source code be distributed, disclosed or otherwise made available to any third party.
  • TELERIK DOES NOT provide technical support for modified source code.
  • The SOFTWARE’s source code is provided as is. Refunds are not available for licenses that include source code.
  • In the event you develop any troubleshooting-related modifications of the SOFTWARE, either independently or jointly with TELERIK, such modifications and all rights associated therewith will be the exclusive property of TELERIK. You are granted the right to use such modifications as set forth in this agreement.
  • You acknowledge that the SOFTWARE’s source code contains valuable and proprietary trade secrets of TELERIK. All individuals employed by or belonging to your entity agree to expend every effort to insure its confidentiality. You agree to assume full responsibility for such employees’ or contractors’ use, or misuse, of such disclosed source code as if it was your use. These obligations shall not apply to any information generally available to the public, independently developed or obtained without reliance on TELERIK information, or approved in writing for release by TELERIK without restriction.

3-3. Gold Support:

As part of your license you are entitled to "Gold" Support Package which guarantees response within 24 hours.

II. OTHER RIGHTS AND LIMITATIONS

  • At no time may the SOFTWARE be used for development purposes by other individuals than the licensed developer(s).
  • The SOFTWARE may not be distributed for use with solutions or PACKAGED PRODUCTS other than those developed by you.
  • The SOFTWARE may not be distributed part of products that have the same or substantially the same primary functionality. (Example for RadControls for ASP.NET: you may purchase Telerik RadEditor for ASP.NET and create a blog application/component. However, you cannot wrap RadMenu and offer it as a SharePoint WebPart or DNN menu skin object, since its primary functionality would be substantially the same as the SOFTWARE.
  • You are not allowed to resell, transfer, rent, lease, or sublicense the SOFTWARE and your associated rights. Under no circumstances shall you grant further redistribution rights to the end-users of your solution.
  • You may not use the TELERIK product names, logos or trademarks to market YOUR SOFTWARE.
  • You are not allowed to disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.
  • You are not allowed to use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.
  • You agree to indemnify, hold harmless, and defend TELERIK and its resellers from and against any and all claims or lawsuits including attorney's fees that arise or result from the use or distribution of YOUR SOFTWARE

III. DELIVERY

TELERIK shall deliver to LICENSEE a master copy of the SOFTWARE licensed hereunder in electronic files only. Documentation shall also be provided in electronic format.

IV. UPGRADES

You are eligible for free minor upgrades (e.g. v.1.5 to v.1.8), patches, and bug-fixes for the SOFTWARE, including source code if applicable. SOFTWARE labeled as an upgrade replaces and/or supplements (and may disable) the product that formed the basis for your eligibility for the upgrade. You may use the resulting upgraded product only in accordance with the terms of this LICENSE.

If you have purchased a "DEVELOPER PLUS SUBSCRIPTION AND SOURCE CODE LICENSE” you are entitled to receive all version updates for the SOFTWARE period of 1 (one) year.

V. TERMINATION

This LICENSE shall last as long as you use the SOFTWARE in compliance with this LICENSE. TELERIK may terminate this LICENSE if you fail to comply with any of the terms and conditions herein. In such event you agree to remove and destroy all copies of the SOFTWARE and any applicable source code.

TELERIK reserves the right to discontinue at any time any product, shall it be offered individually or as a part of a product SUITE. However, TELERIK is obligated to provide the proper level of support for all discontinued products for a period of 1 (one) year after the date of discontinuance.

VI. COPYRIGHT

All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animations, video, audio, music, text, incorporated into the SOFTWARE), the accompanying printed materials, and any copies of the SOFTWARE, and any trademarks or service marks of TELERIK are owned by TELERIK. All title and intellectual property rights in and to the content that may be accessed through use of the SOFTWARE is the property of the respective content owner and may be protected by applicable copyright or other intellectual property laws and treaties. This LICENSE grants you no rights to use such content.

VII. LIMITED WARRANTY

TELERIK warrants solely that the SOFTWARE will perform substantially in accordance with the accompanying written materials for a period of ninety (90) days. TELERIK does not warrant the use of the SOFTWARE will be uninterrupted or error free at all times and in all circumstances, nor that program errors will be corrected. This limited warranty shall not apply to any error or failure resulting from (i) machine error, (ii) LICENSEE's failure to follow operating instructions, (iii) negligence or accident, or (iv) modifications to the SOFTWARE by any person or entity other than TELERIK. In the event of a breach of warranty, LICENSEE 's sole and exclusive remedy, is repair of all or any portion of the SOFTWARE. If such remedy fails of its essential purpose, LICENSEE 's sole remedy and TELERIK's maximum liability shall be a refund of the paid purchase price for the defective SOFTWARE only. This limited warranty is only valid if TELERIK receives written notice of breach of warranty within thirty days after the warranty period expires.

VIII. LIMITATION OF LIABILITY

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT WILL TELERIK BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OF OR INABILITY TO USE THE PRODUCT, INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF, AND REGARDLESS OF THE LEGAL OR EQUITABLE THEORY (CONTRACT, TORT OR OTHERWISE) UPON WHICH THE CLAIM IS BASED. IN ANY CASE, TELERIK'S ENTIRE LIABILITY UNDER ANY PROVISION OF THIS AGREEMENT SHALL NOT EXCEED IN THE AGGREGATE THE SUM OF THE LICENSE FEES LICENSEE PAID TO TELERIK FOR THE PRODUCT GIVING RISE TO SUCH DAMAGES, NOTWITHSTANDING ANY FAILURE OF ESSENTIAL PURPOSE OF ANY LIMITED REMEDY. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS EXCLUSION AND LIMITATION MAY NOT BE APPLICABLE. TELERIK IS NOT RESPONSIBLE FOR ANY LIABILITY ARISING OUT OF CONTENT PROVIDED BY LICENSEE OR A THIRD PARTY THAT IS ACCESSED THROUGH THE PRODUCT AND/OR ANY MATERIAL LINKED THROUGH SUCH CONTENT. ANY DATA INCLUDED IN A PRODUCT UPON SHIPMENT FROM TELERIK IS FOR TESTING USE ONLY AND TELERIK HEREBY DISCLAIMS ANY AND ALL LIABILITY ARISING THEREFROM. THE EXTENT OF TELERIK'S LIABILITY FOR THE LIMITED WARRANTY SECTION SHALL BE AS SET FORTH THEREIN.

IX. MISCELLANEOUS

This License will be governed by the law of the State of Massachusetts, U.S.A. If any provision of this LICENSE is to be held unenforceable, such holding will not affect the validity of the other provisions hereof. Failure of a party to enforce any provision of this LICENSE shall not constitute or be construed as a waiver of such provision or of the right to enforce such provision.

This License represents the entire understanding between the parties with respect to its subject matter.

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, THAT YOU UNDERSTAND THIS AGREEMENT, AND UNDERSTAND THAT BY CONTINUING THE INSTALLATION OF THE SOFTWARE PRODUCT, BY LOADING OR RUNNING THE SOFTWARE PRODUCT, OR BY PLACING OR COPYING THE SOFTWARE ONTO YOUR COMPUTER HARD DRIVE, YOU AGREE TO BE BOUND BY THIS AGREEMENT'S TERMS AND CONDITIONS. YOU FURTHER AGREE THAT, EXCEPT FOR WRITTEN SEPARATE AGREEMENTS BETWEEN TELERIK AND YOU, THIS AGREEMENT IS A COMPLETE AND EXCLUSIVE STATEMENT OF THE RIGHTS AND LIABILITIES OF THE PARTIES.

© 2002-2008 Telerik. All Rights Reserved.


System requirements and browser support

Telerik RadRotator v2.7 Send comments on this topic.
System requirements and browser support
Installation and deployment > Installation > System Requirements > System requirements and browser support

Glossary Item Box

System Requirements

The following page describes the system requirements needed by Telerik RadControls for ASP.NET:

http://www.telerik.com/support/requirements-and-compliance/system-requirements.aspx

Browser Support

The following page shows all browsers and versions supported by Telerik RadControls for ASP.NET:

http://www.telerik.com/support/requirements-and-compliance/browser-support.aspx

Browser Limitations

The following article explains the browser limitations and what implications they have on Telerik RadControls for ASP.NET:

http://www.telerik.com/support/browser-support/browser-issues.aspx

Files and folders needed by Telerik RadRotator and Telerik RadControls for ASP.NET to function

The following section explains the files and folders needed to be used in your application in order for Telerik RadControls for ASP.NET to function properly:

Files and folders needed by Telerik RadControls for ASP.NET

© 2002-2008 Telerik. All Rights Reserved.


Which file do I need to install?

Telerik RadRotator v2.7 Send comments on this topic.
Which file do I need to install?
See Also
Installation and deployment > Installation > Installing Telerik RadRotator on your computer > Which file do I need to install?

Glossary Item Box

Telerik offers you the following ways to install Telerik RadRotator:

  • as an individual install, or
  • as part of the complete Telerik RadControls for ASP.NET suite.

If you plan to use only Telerik RadRotator in your project, we recommend that you install Telerik RadRotator only. In case you want to use two or more products from the Telerik RadControls for ASP.NET suite, it is probably better to install the full Telerik RadControls for ASP.NET suite.

Each installation package comes in three types:

  • EXE file for automatic installation;
    The EXE files are intended for easy and automatic installation of a product. It installs the control(s) on your computer in a folder in your Program Files named Telerik, and automatically creates the necessary virtual folders and projects. Additionally, the EXE installs the help file(s) in your VS.NET IDE and in your local copy of MSDN (if you have one). The EXE files are best for first-time Telerik users and ASP.NET novices.
  • ZIP file for manual (advanced) installation;
    The ZIP is used for manual (advanced) installs and for upgrading/updating purposes. The folder structure is different from the EXE. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot. Use the ZIP file for installation on shared hosting.
  • DLL and Scripts only (a.k.a. HOTFIX) file for updating/upgrading a product to a newer version;
    This is a bare-bones upgrade option for our controls. The DLL and Scripts files contain only those files that you need to replace in your project to upgrade to the new version of a Telerik control. If you are already using a Telerik product and just want to update it, there is no need to download the complete suite - download the latest HOTFIX for the product and apply it.
The latest EXE and ZIP packages available for download already have all updates/HOTFIXES applied. There is no need to update them further.

If you already have a Telerik control installed from the EXE, you can safely install an updated version of the same control - the installer will keep your existing installation. The new files will be placed in a separate folder and the new installation does not damage the common installer files. The new Telerik RadRotator installation may have an updated help too: it is registered with the correct rotator namespace. You can see the updated Telerik RadRotator help in your help2 viewer.

See Also

Installing the Telerik RadControls for ASP.NET suite from EXE file
Installing the Telerik RadControls for ASP.NET suite from ZIP file
Installing Telerik RadRotator from EXE file
Installing Telerik RadRotator from ZIP file
Using the 'DLL and Scripts only' file (HOTFIX)

© 2002-2008 Telerik. All Rights Reserved.


Installing the Telerik RadControls for ASP.NET suite from EXE file

Telerik RadRotator v2.7 Send comments on this topic.
Installing the Telerik RadControls for ASP.NET suite from EXE file
See Also
Installation and deployment > Installation > Installing Telerik RadRotator on your computer > Installing the Telerik RadControls for ASP.NET suite from EXE file

Glossary Item Box

The EXE files are intended for easy and automatic installation of a product. The EXE installs the suite on your computer to a folder named Telerik in your Program Files, automatically creating the necessary virtual folders and projects. Additionally, it installs the help file(s) in the VS.NET IDE and in your local copy of MSDN, if you have one installed.

The EXE files are best for first-time Telerik users and ASP.NET novices.

The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
The EXE installation will not overwrite previous Telerik RadControls for ASP.NET installations, unless it is of the same version.

Install with Internet Information Services (IIS) Running

To install Telerik RadControls for ASP.NET on your machine from the EXE file, follow the instructions below:

  1. Log into your Client.NET account.
  2. Go to My Licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab and download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadControls EXE file and follow the instructions.

    The wizard will install the Telerik RadControls for ASP.NET component in the following folder unless you specify otherwise:
    C:\Program Files\Telerik\RadControlsQ1 2007.

The wizard will create the necessary virtual folders.

To view live examples of the Telerik RadRotator functionality, you can launch the Quick-Start Framework in either of the following ways:

  • Open Start Menu -> Programs -> Telerik -> RadControls Q1 2007 for ASP.NET -> ASP.NET 2.X -> RadControls Q1 2007 C#/VB Live Examples,
  • Double-click the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\RadControlsQ1 2007\NET2,
  • or drag the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\RadControlsQ1 2007\NET2 to start the examples in your browser.

Install without Internet Information Services (VS 2005 only)

To install Telerik RadControls on your machine from the EXE file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab to download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadControls EXE file and follow the instructions.

    The wizard will install the Telerik RadControls for ASP.NET component in the following folder unless you specify otherwise:
    C:\Program Files\Telerik\.

When Internet information Services is not running, the product installation will NOT create virtual directories for the QSF, nor will it create any shortcuts for launching the QSF on localhost. To launch the Quick-Start framework, open and Run (Ctrl+F5) its VisualStudio Web Site using the provided shortcut in the Start Menu:
Start Menu -> Programs -> Telerik -> RadControlsQ1 2007 for ASP.NET-> ASP.NET 2.X -> Open Sample Web Site in Visual Studio
VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

The Telerik RadControls for ASP.NET package adds the products automatically to the VS.NET 2005 toolbox. To learn how to add them manually, see Adding Telerik RadRotator to the Visual Studio 2005 Toolbox.

See Also

Files and folders needed by Telerik RadControls for ASP.NET
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Installing Telerik RadRotator from EXE file

Telerik RadRotator v2.7 Send comments on this topic.
Installing Telerik RadRotator from EXE file
See Also
Installation and deployment > Installation > Installing Telerik RadRotator on your computer > Installing Telerik RadRotator from EXE file

Glossary Item Box

The EXE files are intended for easy and automatic installation of a product. The EXE installs the control on your computer to a folder named Telerik in your Program Files, automatically creating the necessary virtual folders and projects. Additionally, it installs the help file(s) in the VS.NET IDE and in your local copy of MSDN, if you have such installed.

The EXE files are best for first-time Telerik users and ASP.NET novices.

The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
The EXE installation will not overwrite previous Telerik RadRotator installations, unless it is of the same version.

Install with Internet Information Services (IIS) Running

To install Telerik RadRotator on your machine from the EXE file follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadRotator.
  4. Go to the Download tab and download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadRotator_2_7.exe and follow the instructions.

The wizard will create a virtual folder "Telerik RadRotator2.7NET2" (accessible at http://localhost/Telerik/telerikradrotator2.7_NET2).

To view live examples of the Telerik RadRotator functionality, you can launch the Quick Start Framework in either of the following ways:

  • Open Start Menu -> Programs -> Telerik -> Telerik RadRotator v2.7 -> ASP.NET 2.X -> Telerik RadRotator v2.7 C#/VB Live Examples,
  • Double-click the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\Telerik RadRotator v2.7\NET2,
  • or drag the LiveExamplesCS or LiveExamplesVB file located in C:\Program Files\Telerik\Telerik RadRotator v2.7\NET2 to start the examples in your browser.

Install without Internet Information Services (VS 2005 only)

To install Telerik RadRotator on your machine from the EXE file follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Locate Telerik RadRotator, and click on it.
  4. Go to the Download tab to download the Automatic installation (EXE) file.
  5. Once the download completes, run the RadRotator_2_7.exe and follow the instructions.

When Internet information Services is not running, the product installation will NOT create virtual directories for the QSF, nor will it create any shortcuts for launching the QSF on localhost. To launch the Quick-Start framework, open and Run (Ctrl+F5) its VisualStudio Web Site using the provided shortcut in the Start Menu:
Start Menu -> Telerik -> Telerik RadRotator v2.7 -> ASP.NET 2.X -> Open Sample Web Site in Visual Studio
VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

Telerik RadRotator will be added automatically to VS.NET 2005's toolbox. Review the following instructions to add it manually: Adding Telerik RadRotator to the Visual Studio 2005 Toolbox

The wizard will install the Telerik RadRotator component in the following folder unless you specify otherwise:
\Program Files\Telerik\Telerik RadRotator2.7\NET2.

The installation folder contains the following subfolders and files:

  • "bin" - contains the .dll files

  • "Common" - contains JavaScripts and css files

  • "RadControls" - contains the clients-side JavaScript and resource files
    You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.

  • "rotator" - contains the running examples from the Quick-Start framework

  • LiveExamplesCS - a browser link to run the C# version of the examples locally
  • LiveExamplesVB - a browser link to run the VB.NET version of the examples locally

The information below is generic for all Telerik controls. The particular details vary for individual control installations.

The installation folders of some Telerik controls may also contain the following subfolders:

  • "DeploymentActions" - contains the files required for proper deployment of the control
  • "Help" - contains all the files required for generating Help2
  • "Img" - contains system images
  • "InstalledRelated" - contains the files required for proper installation of the control

See Also

Adding Telerik RadRotator to an ASP.NET WebForm
Add/Remove Telerik RadRotator to the Global Assembly Cache
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Installing the Telerik RadControls for ASP.NET suite from ZIP file

Telerik RadRotator v2.7 Send comments on this topic.
Installing the Telerik RadControls for ASP.NET suite from ZIP file
See Also
Installation and deployment > Installation > Installing Telerik RadRotator on your computer > Installing the Telerik RadControls for ASP.NET suite from ZIP file

Glossary Item Box

Show All Show All
Hide All Hide All

The ZIP is used to install Telerik RadControls for ASP.NET manually for upgrading or updating purposes. The folder structure is different from the EXE installation. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot.

Install without IIS Running (VS 2005 only)

To install the Telerik RadControls for ASP.NET suite on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadControls for ASP.NET.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Hide What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadControls for ASP.NET - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help1
    • HelpNET20 folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadControls for ASP.NET under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadControls for ASP.NET under ASP.NET2.x
    • other files and folders.
  5. The latest package available for download has all latest updates/HOTFIXES applied. There is no need to update it further.
  6. Once the download completes, create a Telerik_RadControls folder in your IIS's inetpub/wwwroot folder.
  7. From the downloaded file, extract the files from the NET2 folder into inetpub/wwwroot/Telerik_RadControls folder. After the process ends, the inetpub/wwwroot/Telerik_RadControls folder should contain the following files and folders:
    • app_themes folder - contains the themes and skins used by Telerik's navigational controls
    • bin folder - contains the controls' .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files, needed by Telerik's controls. You will need to copy this folder in your web application only if you intend to use skins different from the Default or if you plan to modify the JavaScript files.
      Exceptions: Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell, Telerik RadUpload and Telerik RadWindow products.
    • folders, named after Telerik's controls (i.e. Calendar, Chart, Combobox, etc.) - these contain the running examples for each control from the Quick-Start framework
    • other project files and folders.
  8. Create a .NET2 virtual directory for the folder where you extracted the files. Hide How?

    This is accomplished through the Internet Information Services console on your machine:
    Start -> Settings -> Control Panel -> Administrative Tools -> Internet Information Services:
    1. Right-click the folder you have created (Telerik_RadControls).
    2. Select Properties.
    3. Click the Create button. The application name will become Telerik_RadControls.
    4. Click Apply.
    5. Click the ASP.NET tab.
    6. From the drop-down list, select your ASP.NET 2.0 version:

      ASP.NET tab under .NET2.0
    7. Click OK.
  9. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (under IIS6, Windows Server 2003) on the folder where the files were extracted. See Setting ASNET (Network Service) Permissions for more information.

To run the examples paste the following link in your browser: http://localhost/Telerik_RadControls/

To register the MS Help 2 files to VisualStudio and MSDN, please review the following link:
http://www.telerik.com/Default.aspx?PageId=2657

To add any control to the VS.NET toolbox, review Adding Telerik RadRotator to the Visual Studio 2005 Toolbox
To use any Telerik ASP.NET control in your project, review Adding Telerik RadRotator to an ASP.NET WebForm

DO NOT include/add the examples in your VS.NET project as this will break the Telerik control(s).

See Also

Files and folders needed by Telerik RadControls for ASP.NET
Trial License Limitations
Register MS Help 2 files

© 2002-2008 Telerik. All Rights Reserved.


Installing Telerik RadRotator from ZIP file

Telerik RadRotator v2.7 Send comments on this topic.
Installing Telerik RadRotator from ZIP file
See Also
Installation and deployment > Installation > Installing Telerik RadRotator on your computer > Installing Telerik RadRotator from ZIP file

Glossary Item Box

Show All Show All
Hide All Hide All

The ZIP is used to install Telerik RadRotator manually for upgrading or updating purposes. The folder structure is different from the EXE installation. You need to be familiar with with ASP.NET, IIS, setting permissions and creating virtual folders. Commonly, the ZIP is installed directly in inetpub/wwwroot.

Install Telerik RadRotator with IIS running

To install Telerik RadRotator on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadRotator.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Show What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadRotator - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadRotator under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadRotator under ASP.NET2.x
    The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
  5. Once the download completes, create a RadRotator folder in your IIS's inetpub/wwwroot folder.
  6. From the downloaded file, extract all files from the NET2 folder into inetpub/wwwroot/RadRotator folder. After the process ends, the inetpub/wwwroot/RadRotator/ folder should contain the following files and folders:
    • App_Themes folder - contains some .NET2.0 themes provided by Telerik
    • bin folder - contains the .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files. You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.
      Exceptions: Because of the specific control features, you will always need to copy RadControls for RadChart, RadEditor, RadSpell, RadUpload and RadWindow products.
    • rotator folder - contains the running examples from the Quick-Start framework
    • other project files.
  7. Create a .NET2 virtual directory for the folder where you unzipped the files. Show How?
    This is accomplished through the Internet Information Services console on your machine:
    Start -> Settings -> Control Panel -> Administrative Tools -> Internet Information Services:
    1. Right-click the folder you have created (RadRotator).
    2. Select Properties.
    3. Click the Create button. The application name will become RadRotator.
    4. Click Apply.
    5. Click the ASP.NET tab.
    6. From the drop-down list, select your ASP.NET 2.0 version:

      ASP.NET tab under .NET2.0
    7. Click OK.
  8. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (under IIS6, Windows Server 2003) on the folder where the files were unzipped. See Setting ASNET (Network Service) Permissions for more information.

To run the examples, paste the following link in your browser: http://localhost/RadRotator

Install Telerik RadRotator without or with IIS stopped (VS 2005 Only)

To install Telerik RadRotator on your machine from the ZIP file, follow the instructions below:

  1. Log in your Client.NET account.
  2. Go to My licenses and click My Purchases (or My Free Trials if you are a trial user).
  3. Click Telerik RadRotator.
  4. Go to the Download tab to download the Manual installation (ZIP) file. Show What does the ZIP contain?
    The ZIP file contains the following folders:
    • DeploymentActions folder - contains the files required for the automatic deployment of Telerik RadRotator - this folder is not needed when installing the control from the ZIP
    • Help folder - contains all files and folders required for generating Help2
    • NET1 folder - contains the needed files and folders for deploying Telerik RadRotator under ASP.NET1.x
    • NET2 folder - contains the needed files and folders for deploying Telerik RadRotator under ASP.NET2.x
    The latest package available for download already has all updates/HOTFIXES applied. There is no need to update it further.
  5. From the downloaded file, extract all files from the NET2 folder into folder at a convenient location on your disk. After the process ends, the folder should contain the following files and folders:
    • App_Themes folder - contains some .NET2.0 themes provided by Telerik
    • bin folder - contains the .dll file(s)
    • Common folder - contains JavaScripts, css files and/or ascx files
    • Img folder - contains system images
    • RadControls folder - contains the clients-side JavaScript and resource files. You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files.
    • rotator folder - contains the running examples from the Quick-Start framework
    • other project files.
  6. Open and Run (Ctrl+F5) Quick-Start Framework VisualStudio Web Site using the provided solution file ControlsExamples.sln in the NET2 folder. VisualStudio 2005 will start the QSF locally using the integrated ASP.NET Development Server.

To register the MS Help 2 files to VisualStudio and MSDN, please review the following link:
http://www.telerik.com/Default.aspx?PageId=2657

To add Telerik RadRotator to the VS.NET toolbox, review Adding Telerik RadRotator to the Visual Studio 2005 Toolbox.

To use the Telerik RadRotator in your project, please review Adding Telerik RadRotator to an ASP.NET WebForm.

DO NOT include/add the examples in your VS.NET project as this will break the Telerik control(s).

See Also

Adding Telerik RadRotator to an ASP.NET WebForm
Add/Remove Telerik RadRotator to the Global Assembly Cache
Trial License Limitations
Register MS Help 2 files

© 2002-2008 Telerik. All Rights Reserved.


Using the 'DLL and Scripts only' file (HOTFIX)

Telerik RadRotator v2.7 Send comments on this topic.
Using the 'DLL and Scripts only' file (HOTFIX)
See Also
Installation and deployment > Installation > Installing Telerik RadRotator on your computer > Using the 'DLL and Scripts only' file (HOTFIX)

Glossary Item Box

Show All Show All
Hide All Hide All

The "DLL and Scripts only" file (a.k.a. HOTFIX file) is a bare-bones upgrade option for our controls - they contain only those files that you need to replace in your project to upgrade to the new version of a Telerik control. If you are already using a Telerik product, there is no need to download the complete suite - download the "DLL and scripts only" version and follow the instructions below for applying the hotfix. The "DLL and Scripts only" file contains the following folders and files:

  • bin folder - contains the DLL file(s)
  • RadControls folder - contains the clients-side JavaScript and resource files for Telerik RadRotator
If you are installing a Telerik product for the first time, we recommend that you download the complete package (EXE or ZIP file).

To update Telerik RadRotator to a new version

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases" (or "My Free Trials" if you are a trial user).
  3. Locate the control that you need to install, i.e. Telerik RadRotator, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. If you have purchased the control, you need to download the file which has the Dev abbreviation in it.
  5. Once the download completes, unzip the files at a convenient location.
  6. If the upgrade is major (i.e. from v1.x to v2.x), check the Changes and Backward Compatibility section in this manual for further instructions.
  7. Back up your application.
  8. Close Visual Studio or any ither IDE which may lock the old assembly.
  9. From the newly downloaded and unzipped files, copy the new DLL (located in the bin folder) to your web-application's bin folder. Replace the old dll.
  10. [Optional. Follow this step only if you intend to use skins different from the default or if you plan to modify the JavaScript files
    Exceptions: Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products. ]
    Copy the new RadControls folder to the root of your web-application. Replace all files and folders when asked. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate the old folder and paste the new RadControls folder over it. Replace all files and folders when asked.
  11. If you are using VS.NET, update the control's reference in your project to point to the new DLL.
  12. Recompile your project.
  13. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadRotator to the Global Assembly Cache
  14. Run the project.
  15. If you still get the older version of Telerik RadRotator Hide click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadRotator's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadRotator, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....
  16. If you get a copyright message Show click here

    The copyright message appears only when using the trial version of Telerik RadRotator (the Developer versions of Telerik's controls do not throw copyright messages).

    If you have purchased the control, then you have downloaded the wrong "DLL and Scripts only" file. Make sure you you download the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

See Also

Adding Telerik RadRotator to an ASP.NET WebForm
Add/Remove Telerik RadRotator to the Global Assembly Cache
Trial License Limitations

© 2002-2008 Telerik. All Rights Reserved.


Setting ASPNET (Network Service) Permissions

Telerik RadRotator v2.7 Send comments on this topic.
Setting ASPNET (Network Service) Permissions
Installation and deployment > Installation > Installing Telerik RadRotator on your computer > Setting ASPNET (Network Service) Permissions

Glossary Item Box

In most applications, users typically access Web applications anonymously — that is, they do not initially provide authentication credentials. In that case, the Web application has to assume (impersonate) some identity that it can use to request resources.
By default, when ASP.NET allows anonymous access, the application runs in the context of a special local (not domain) account. The user context depends on the operating system. In Windows 2000 and Windows XP, applications run under the account called ASPNET. In Windows Server 2003, the user context is called NETWORK SERVICE. These user accounts are created during the .NET Framework installation process with a unique, strong password, and are granted only limited permissions. The ASPNET or NETWORK SERVICE user can access only specific folders that are required to run a Web application, such as the \bin directory in which a Web application stores compiled files.

Full information on the topic can be found in MSDN: Security Considerations for ASP.NET Web Applications

Instructions on how to give process permissions on a folder - FAT32 file system

No need to give any permissions on the folder.

Instructions on how to give process permissions on a folder - NTFS file system

Internet Information Services v5.x - name of account: ASPNET user

  1. Right-click on the RadRotator (or Telerik_RadControls) folder and select Properties.
  2. Click on the Security tab. If you do not see the security tab, click Show here

    The Security tab is not visible because you have Simple File Sharing enabled. You will need to disable it before you continue. To do so:
    1. Open a Windows Explorer.
    2. On the Tools menu, click Folder Options, and then click the View tab.
    3. In the Advanced Settings section, clear the Use simple file sharing (Recommended) check box (at the bottom of the list).
    4. Click OK.
    5. Right-click on the folder you need to add ASPNET permissions to and select Properties. Click on the Security tab.

  3. Click on Add (to add a new user).

  4. Click on Locations to select your local machine. Your screen should look similar to the following:

    Setting ASPNET permissions

  5. Select your local machine and click OK.

  6. Type ASPNET in the textbox and click on Check Names. ASPNET should underline (if it doesn't then you don't have Microsoft's .NET framework installed).

    ASPNET user

  7. Click OK.

  8. Select the LOCAL MACHINE NAME/ASPNET user you just created (it should be named ASP.NET Machine Account (NAME/ASPNET)) and check the Full Control box to give it full permissions.

  9. Click APPLY.

  10. Click Advanced and make sure that the "Inherit from parent ..." check box is checked.

  11. Click OK to close the Advanced properties.

  12. Click OK to close the folder properties.

Internet Information Services v6.x - name of account: Network Service user

Same as above but replace ASPNET with Network Service.

© 2002-2008 Telerik. All Rights Reserved.


Trial License Limitations

Telerik RadRotator v2.7 Send comments on this topic.
Trial License Limitations
See Also
Installation and deployment > Installation > Installing Telerik RadRotator on your computer > Trial License Limitations

Glossary Item Box

Developer Licenses

Developer licenses come with modified DLLs, which work without license keys. If you have a Developer license for one or more of the Telerik components, you only need to ensure that you are using the developer build when downloading the control(s). These builds have the Dev abbreviation in their file names.

If your application is displaying a license key error, this means that you are using a trial version of the product. Log in to your Client.net account and download the developer build. To update your project, please take a look at the Upgrading the Trial License to a Production License section for step-by-step instructions.

Trial Licenses

The free trial licenses of all Telerik products are fully functional and will work for an unlimited time but with trial error messages (see below) displayed randomly on the page.

Trial error messages

The trial licenses will occasionally display the following message on your webform:

Telerik RadRotator 2.7 trial version. Copyright Telerik © 2002-2008. To remove this message, please, purchase a developer version .

See Also

License Agreement

© 2002-2008 Telerik. All Rights Reserved.


Files and folders needed by Telerik RadControls for ASP.NET

Telerik RadRotator v2.7 Send comments on this topic.
Files and folders needed by Telerik RadControls for ASP.NET
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > Files and folders needed by Telerik RadControls for ASP.NET

Glossary Item Box

Please, review the following KB article on the topic:

Which files and folders are mandatory to be on the server for Telerik RadControls for ASP.NET to function

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


The 'RadControls' Folder

Telerik RadRotator v2.7 Send comments on this topic.
The 'RadControls' Folder
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > The 'RadControls' Folder

Glossary Item Box

The RadControls folder is an essential part of Telerik RadControls for ASP.NET - it contains all resources needed for the components to function properly (i.e. images, client-side scripts, configuration files, skins, etc.).

You will need to copy this folder in your web application only if you intend to use skins different from the default or if you plan to modify the JavaScript files. However because of the specific control features, you will always need to copy /RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products.

Each Telerik component seeks its resources in the respective subfolder of RadControls: for example, /RadControls/Rotator is the folder where the resources for Telerik RadRotator reside.

Copying the RadControls folder to your web application

To work with Telerik RadControls for ASP.NET, you need to copy the RadControls folder to your web application. The folder must contain all the subfolders of the controls you are going to use. Do not copy the subfolders of controls you are not planning to use as this may cause a number of compilation errors: Visual Studio 2005 compiles all files in the web project; errors occur when missing assemblies are not found.

Do not include the RadControls folder in your VS.NET solution! Hide Why?

When the RadControls folder is included in a VB.NET project, VS.NET tends to change some files within the RadControls folder automatically. The extent of these changes depends on the IDE settings; notably, the following controls are affected:
  • Telerik RadEditor
  • Telerik RadSpell
  • Telerik RadChart
Telerik controls are written in C# - hence the several *.CS codebehind files within the RadControls/[control] folder. When such .ASCX/ASPX files are included in the project, VS.NET automatically changes the Language attribute of their Page/Control directive from cs to vb and breaks the control.

To avoid the problem:
  1. In Windows Explorer, do a filtered search to locate all ASPX and ASCX files within the RadControls folder.
  2. Once the search is over, select all files and right-click to get their properties.
  3. Select the Hidden check box and click OK.
Now Visual Studio will not see the files, so errors will not be thrown. At the same time IIS will see the files and will display them fine.

If you have already included the RadControls folder in your VS2005 project:
  1. Open your Visual Studio 2005 project.
  2. In the Solution Explorer locate the RadControls folder and expand it.
  3. Locate the problematic ascx files, right-click them and select "Exclude from project". Unfortunately, this can be done for files only (unlike VS2003), so the process should be repeated for all ascx files.
  4. Open Windows Explorer, navigate to your project's folder.
  5. Back up the RadControls folder from your project, especially any customized files you may have (ConfigFile.xml, ToolsFile.xml, any css files, images. etc).
  6. Delete the damaged RadControls folder.
  7. Navigate to the installation folder of Telerik RadRotator (for example).
  8. Copy the RadControls folder from the installation folder to the root of your web application.
  9. Rebuild and run your project.

Moving the RadControls folder within your web-application

  1. Manually copy the RadControls folder to the new location within your web application (for example, ~/Resources/).
    Do not use the VS.NET IDE to copy/move the RadControls folder to another location as it changes the namespaces of the files and changes the project language from C# to VB which in turn breaks the application! Use Windows Explorer instead.
  2. Either:
    • Specify its position in the RadControlsDir property in the control's declaration in your ASCX/ASPX file, e.g.
      Copy Code
      <radR:RadRotator
      RadControlsDir="~/Resources/RadControls/" ...>
      </      radR:RadRotator>
    • Or set the property globally from the Web.config file of the application:
      Copy Code
      <configuration>
      <appSettings>
      <add key="Telerik.WebControls.RadControlsDir" value="~/Resources/RadControls/"/>
      </appSettings>
      </      configuration>
      Notes.
      • In the above examples, the tilde "~" represents the root of your web application.
      • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.

Moving the RadControls folder outside your web-application

This is the best scenario if you want to have a single RadControls folder for several applications. This mechanism also enables different versions of Telerik products to reside in different web applications:

  1. Manually copy the RadControls to the new location.
    Do not use the VS.NET IDE to copy/move the RadControls folder to another location as it changes the namespaces of the files and changes the project language from C# to VB, which in turn breaks the application! Use Windows Explorer instead.
  2. Create a virtual directory with name RadControls under each application's root which points physically to the same physical RadControls folder. That physical folder should include all the scripts and other required settings of the controls.
    The respective RadControls virtual directory should NOT be a web application but virtual directory only! You can find more information on the topic in the following KB article: (ID#728) Error Message: Could not load type 'Telerik.WebControls.Dialogs.Dialog'.
  3. Either:
    • Specify its position in the RadControlsDir property in the control's declaration in your ASCX/ASPX file, e.g.

    • Or set the property globally from the Web.config file of the application:
      Copy Code
      <configuration>
      <appSettings>
      <add key="Telerik.WebControls.RadControlsDir" value="~/RadControls/"/>
      </appSettings>
      </      configuration>
      Notes.
      • In the above examples, the tilde "~" represents the root of your web application.
      • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.
      • Make sure you set the RadControlsDir property to "~/RadControls/" (with a slash following the folder name).

"You have not copied the RadControls folder to the root folder of your web-application" error message

When opening a page which contains Telerik RadRotator, the following error message appears:
“Telerik RadRotator v2.7: You have not copied the RadControls folder to the root folder of your web-application or you have applied an update incorrectly."

This message shows that the control is not able to locate its RadControls/rotator folder. It usually appears after updating the control to a newer version. The causes for the message to appear are:

  • The assembly version and the RadControls/rotator folder version are from different installation downloads, i.e. from different Telerik RadRotator versions.
    Example: RadRotator.NET2.DLL is version 2.7.2, whereas the Telerik RadRotator's RadControls/Rotator folder is from version 2.7.1 or other.
  • The proper assembly is in the bin folder of the application, but the RadControls/rotator folder is missing or misplaced.

To solve the problem:

  1. Check whether the RadControls folder is placed in the root of your web application and that you have NOT set the RadControlsDir property to point to another location.
  2. Check whether the RadControls/rotator folder contains a subfolder, named Scripts, and a subfolder which carries the version of the control as its name.
    For example, if you use Telerik RadRotator v2.7.2 - the folder should be \RadControls\Rotator\Scripts\2_7_2 and this version number should match the RadRotator.NET2.dll version placed in the /bin folder.
    If such discrepancy exists between the control's assembly and the RadControls folder, use a DLL and RadControls folder from a working application or download the ZIP file from your Client.net account and use the files from there.
  3. Another reason could be that some files from the RadControls/rotator folder are missing or damaged. Please delete the current RadControls folder and paste the original one from the same download that you have the assembly from.
  4. For some reason your project may still reference the previous version of control's DLL, and not the latest. In this case we suggest removing the old assembly reference from your VS.NET project and adding a new reference to to the new assembly.
  5. If you have added the control in the GAC (Global assembly cache), remove it by running gacUtil and then add the new version.
  6. If you are trying to move the RadControls folder through the RadControlsDir property, please review the following section for resolution:

  7. [not related to Telerik controls] Delete .NET, VS and browser caches because they can cause a problem too:

    1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
    2. Open a Windows Explorer and navigate to
      C:\Windows(WINNT)\Microsoft.NET\Framework\vYOUR_VERSION\Temporary ASP.NET Files
    3. Delete all the folders with names, corresponding to your Telerik projects.
    4. Delete your Visual Studio web project caches as well - they should be located at C:\Documents and Settings\VSWebCache.
    5. Delete your browser cache: Tools -> Internet Options -> Delete Files....

See Also

Setting the RadControlsDir property

© 2002-2008 Telerik. All Rights Reserved.


Setting the RadControlsDir property

Telerik RadRotator v2.7 Send comments on this topic.
Setting the RadControlsDir property
See Also
Installation and deployment > Installation > Files and Folders needed by Telerik RadControls > Setting the RadControlsDir property

Glossary Item Box

The RadControlsDir property can be set:

  • either from the ASPX/ASCX page where Telerik RadRotator resides (or programmatically, from the code behind),
  • or globally, for all controls in the web application, from the Web.config file.

To set RadControlsDir from the Web.config, add the following line inside the appSettings tag:

Notes.
  • In the above example, the tilde "~" represents the root of your web application.
  • You can change the location of the RadControls folder. The path given here is to serve only as an illustration.
  • If the RadControlsDir property has been set in more than one way, the value set from Web.config is overridden.
  • When you set the RadControlsDir property, its value does not automatically update other properties that contain URL strings. You need to update these properties manually.

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


Adding Telerik RadRotator to the Visual Studio 2005 Toolbox

Telerik RadRotator v2.7 Send comments on this topic.
Adding Telerik RadRotator to the Visual Studio 2005 Toolbox
See Also
Installation and deployment > Installation > Adding Telerik RadRotator to the Visual Studio 2005 Toolbox

Glossary Item Box

Telerik RadControls for ASP.NET are added automatically to the Visual Studio .NET 2005 Toolbox during installation. However if you are using the ZIP distribution, you can do this manually as described below.

To add Telerik RadRotator to the Toolbox manually and to be able to easily deploy the component in your WebForms in Design mode, follow the steps below:

  1. Open your application in Visual Studio 2005.
  2. Expand the Toolbox.

  3. Expand the General Section.

  4. Right-click in the General section and open Choose Items.

  5. On the .NET Framework Components tab, click Browse.

  6. Browse to the Telerik RadRotator installation folder, open the NET2 folder and from the bin subfolder, select the RadRotator.Net2.dll.

    • If the EXE was used to install Telerik RadControls for ASP.NET, the bin folder is located in
      C:\Program Files\Telerik\Telerik RadControls for ASP.NETQ1 2007\NET2\bin

    • If the ZIP was used to install Telerik RadRotator, the bin folder is located in the folder where the installation files have been unzipped (usually "\Inetpub\wwwroot\RadRotator_2_7\NET2"

  7. Click Open to confirm. The Telerik RadRotator icon should appear in the Toolbox.

  8. If you intend to use skins different from the default or if you plan to modify the JavaScript files, do not forget to copy the respective RadControls folder to the root of your application. For more information, see The 'RadControls' Folder.

See Also

Adding Telerik RadRotator to an ASP.NET WebForm

© 2002-2008 Telerik. All Rights Reserved.


Adding RadControls to the Visual Studio 2008 Toolbox

Telerik RadRotator v2.7 Send comments on this topic.
Adding RadControls to the Visual Studio 2008 Toolbox
Installation and deployment > Installation > Adding RadControls to the Visual Studio 2008 Toolbox

Glossary Item Box

Telerik RadControls for ASP.NET are added automatically to the Visual Studio .NET 2008 Toolbox during installation. However if you are using the ZIP distribution, you can do this manually as described below.

To add Telerik RadControls "Prometheus" for ASP.NET to the Toolbox manually and to be able to easily deploy the component in your WebForms in Design mode, follow the steps below:

  1. Open your application in Visual Studio 2008.
  2. Expand the Toolbox.

  3. Expand the General Section.

  4. Right-click in the General section and open Choose Items.

  5. On the .NET Framework Components tab, click Browse.

  6. Browse to the Telerik RadControls for ASP.NET installation folder, open the bin35 folder and select the Telerik.Web.UI.dll.

    • If the EXE was used to install Telerik RadControls for ASP.NET, the bin35 folder is located in
      C:\Program Files\Telerik\RadControls for ASPNET\bin35

    • If the ZIP was used to install Telerik RadControls, the bin35 folder is located in the folder where the installation files have been unzipped

  7. Click Open to confirm. The icons for all controls in the suite will appear in the Toolbox. Visual Studio 2008 toolbox

© 2002-2008 Telerik. All Rights Reserved.


Adding Telerik RadRotator to an ASP.NET WebForm

Telerik RadRotator v2.7 Send comments on this topic.
Adding Telerik RadRotator to an ASP.NET WebForm
Installation and deployment > Installation > Adding Telerik RadRotator to an ASP.NET WebForm

Glossary Item Box

To add Telerik RadRotator to an ASP.NET WebForm you can use either of the following approaches:

  • Drag the Telerik RadRotator icon from the Visual Studio Toolbox;

  • Write the Telerik RadRotator tag manually.

If you intend to use skins different from the default or if you plan to modify the JavaScript files, you also need to manually copy the Rotator subfolder under the RadControls folder from the Telerik RadRotator installation folder to the root folder of your web application.

Because of the specific control features, you will always need to copy RadControls for Telerik RadChart, Telerik RadEditor, Telerik RadSpell and Telerik RadWindow products.
If your RadControls folder contains multiple subfolders for Telerik controls - for example, if you are using a Telerik RadControls for ASP.NET installation as opposed to a Telerik RadRotator installation - make sure you copy only the subfolders of the controls you are going to use (Rotator and any other controls you need). Do not copy the subfolders of controls you are not planning to use as this may cause a number of compilation errors: Visual Studio 2005 compiles all files in the web project; errors occur when missing assemblies are not found.

Adding Telerik RadRotator to a WebForm using Visual Studio .Net

The easiest way to deploy Telerik RadRotator is by dragging its icon from the Visual Studio .NET Toolbox in Design mode. Visual Studio will automatically copy the RadRotator.NET2.dll to the bin folder of your web-application and will create the respective references. You only have to copy the RadControls folder to the root folder of your web application as explained above.

Adding Telerik RadRotator to a WebForm manually

If you are not using Visual Studio .NET, you can deploy Telerik RadRotator manually. Follow the instructions below:

  1. Copy the RadControls folder from the Telerik RadRotator installation folder to the folder of your web application.

  2. Copy the RadRotator.NET2.dll from the bin folder of the Telerik RadRotator installation to the bin folder of your web application.

  3. Open your aspx/ascx file and add the Telerik RadRotator Register directive at the top:
    <%@ Register TagPrefix="radR" Namespace="Telerik.WebControls" Assembly="RadRotator.Net2" %>

    If you plan all pages in your application to use Telerik RadRotator you can add the following lines in your web.config file. In this case you don't need to add this directive in your pages.

    Copy Code
    <pages>
    <controls>
    <add tagPrefix="radR" namespace="Telerik.WebControls" assembly="RadRotator.Net2" />
    </controls>
    </    pages>

  4. Write the Telerik RadRotator tags in the body of the WebForm:

    Copy Code
    <radR:RadRotator ID="rotator1" Runat="server">
    </    radR:RadRotator>
  5. Add any additional properties you need between the Telerik RadRotator tags.

Troubleshooting: the css styles do not apply correctly

If you have a Telerik control in a user control with output caching turned on you should manually register all the required CSS files in the head tag of your page. Otherwise the control will not be displayed correctly. The easiest way to do this is through a LINK element:

<link href="~/RadControls/Rotator/Skins/[SkinName]/styles.css"rel="stylesheet"runat="server">

© 2002-2008 Telerik. All Rights Reserved.


Using IntelliSense in Visual Studio 2005

Telerik RadRotator v2.7 Send comments on this topic.
Using IntelliSense in Visual Studio 2005
Installation and deployment > Installation > Using IntelliSense in Visual Studio 2005

Glossary Item Box

Visual Studio 2005 automatically enables IntelliSense - through reflection it detects all classes, properties and methods in the dll file(s).

For additional convenience each Telerik control is provided an XML file which contains the comments for its classes, properties and methods.

For example, when Telerik RadRotator is dragged to the webform the RadRotator.Net2.xml file is automatically added in the bin directory of the project.

In ASPX, when you start typing or when you insert a space, VisualStudio will show a dropdown with suggestions for autocomplete.

In code-behind, each time a particular class/property/method is being selected from the dropdown of the autocomplete functionality, a tooltip with the comment for this class/property/method is displayed:

Intellisense in VS2005

© 2002-2008 Telerik. All Rights Reserved.


Using IntelliSense in Visual Studio 2008

Telerik RadRotator v2.7 Send comments on this topic.
Using IntelliSense in Visual Studio 2008
Installation and deployment > Installation > Using IntelliSense in Visual Studio 2008

Glossary Item Box

Visual Studio 2008 automatically enables IntelliSense - it detects all classes, properties and methods in the DLL file and the JavaScript code.

For additional convenience each Telerik control comes with an XML file which contains the comments for its classes, properties and methods.
When the Telerik control is dragged to the webform the XML file is automatically added in the bin directory of the project.
In ASPX, when you start typing or when you insert a space, Visual Studio will show a dropdown with suggestions for autocomplete:

ASPX AutoComplete

Visual Studio 2008 provides full Javascript Intellisense completion in ASPX files, HTM files, as well as in external JS files. It provides rich support for the ASP.NET AJAX client JavaScript framework and JavaScript code built with it:

In code-behind, each time a particular class/property/method is being selected from the dropdown of the autocomplete functionality, a tooltip with the comment for this class/property/method is displayed.

© 2002-2008 Telerik. All Rights Reserved.


Upgrading Telerik RadRotator v2.x Trial to Telerik RadRotator v2.x Developer license

Telerik RadRotator v2.7 Send comments on this topic.
Upgrading Telerik RadRotator v2.x Trial to Telerik RadRotator v2.x Developer license
Installation and deployment > Installation > Upgrading Instructions > Upgrading Telerik RadRotator v2.x Trial to Telerik RadRotator v2.x Developer license

Glossary Item Box

Follow the steps below to upgrade your Telerik RadRotator v2.7 Trial license to a Developer (production) license.

THE PROCEDURE DESCRIBED IN THIS MANUAL IS IRREVERSIBLE AND YOU MAY LOSE YOUR DATA IF THE INSTALLATION IS NOT CARRIED OUT CORRECTLY!

1. Back up Your Old Files

We strongly suggest that you back-up your old Telerik RadRotator files and folders, especially if you would like to use your old settings.

2. Obtain the Necessary File

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases".
  3. Locate the control that you need to install, i.e. Telerik RadRotator, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. Since you have purchased the control, make sure you are downloading the proper file - the Developer version has the Dev abbreviation in it.

3. Install and Copy the New Files

  1. Unzip the files at a convenient location.
  2. Check the Changes and Backward Compatibility section for introduced changes. If there are such, they should be applied a little later in the upgrade process.
  3. Back up your application if you haven't done so already.
  4. Close Visual Studio or any ither IDE which may lock the old assembly.
  5. From the newly downloaded and unzipped files, copy the new DLL (RadRotator.NET2.dll located in the bin folder) to your web-application's bin folder. Replace the old dll.
  6. Locate the old RadControls/Rotator folder and delete it manually, i.e. using Windows Explorer. By default, the RadControls/Rotator folder should be in the root of your application. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate it and delete it using Windows Explorer.
    DO NOT use Visual Studio to move, copy or delete the RadControls folder as this will break the Telerik control(s).
  7. If you intend to use skins different from the default or if you plan to modify the JavaScript files, copy the new RadControls/Rotator folder to the same location as above.
  8. If using VS.NET, update the control's reference in your project to point to the new DLL.
  9. Follow the steps in the Changes and Backward Compatibility section in case there are some changes between the versions.
  10. Recompile your project.
  11. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadRotator to the Global Assembly Cache
  12. Run the project.
  13. If you still get the older version of Telerik RadRotator Hide click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadRotator's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadRotator, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....

  14. If you get a copyright message Hide click here

    The copyright message appears only when using the trial version of Telerik RadRotator (the Developer versions of Telerik's controls do not throw copyright messages). Make sure you have downloaded the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

5. Using the old ToolsFile.xml File and ConfigFile.xml file [valid for Telerik RadEditor and Telerik RadSpell only]

If you would like to use your old ToolsFile.xml and ConfigFile.xml files (which you backed up in #1 above), you can do so by copying them from the back-up to the RadControls\Editor folder (or RadControls\Spell respectively) of your web-application. When prompted to overwrite the other file, click "YES".

© 2002-2008 Telerik. All Rights Reserved.


Upgrading Telerik RadRotator v1.x Developer to Telerik RadRotator v2.x Developer license

Telerik RadRotator v2.7 Send comments on this topic.
Upgrading Telerik RadRotator v1.x Developer to Telerik RadRotator v2.x Developer license
Installation and deployment > Installation > Upgrading Instructions > Upgrading Telerik RadRotator v1.x Developer to Telerik RadRotator v2.x Developer license

Glossary Item Box

Follow the steps below to upgrade your Telerik RadRotator v1.x Developer license to Telerik RadRotator v2.7 Developer license.

These instructions are also valid for upgrading Telerik RadRotator v2.x Developer license to a newer Telerik RadRotator minor version.

THE PROCEDURE DESCRIBED IN THIS MANUAL IS IRREVERSIBLE AND YOU MAY LOSE YOUR DATA IF THE INSTALLATION IS NOT CARRIED OUT CORRECTLY!

1. Back up Your Old Files

We strongly suggest that you back-up your old Telerik RadRotator files and folders, especially if you would like to use your old settings.

2. Obtain the Necessary File

  1. Log in your Client.NET account.
  2. Go to "My licenses" and click on "My Purchases".
  3. Locate the control that you need to install, i.e. Telerik RadRotator, and click on it.
  4. Click on the "Download" tab and download the "DLL and Scripts only" file. Since you have purchased the control, make sure you are downloading the proper file - the Developer version has the Dev abbreviation in it.

3. Install and Copy the New Files

  1. Unzip the files at a convenient location.
  2. Check the Changes and Backward Compatibility section for introduced changes. If there are such, they should be applied a little later in the upgrade process.
  3. Backup your application if you haven't done so already.
  4. Close Visual Studio or any ither IDE which may lock the old assembly.
  5. From the newly downloaded and unzipped files, copy the new DLL (RadRotator.NET2.dll located in the bin folder) to your web-application's bin folder. Replace the old dll.
  6. Locate the old RadControls/Rotator folder and delete it manually, i.e. using Windows Explorer. By default, the RadControls/Rotator folder should be in the root of your application. If you moved the RadControls folder through the RadControlsDir property to another location (different from the root), then locate it and delete it using Windows Explorer.
    DO NOT use Visual Studio to move, copy or delete the RadControls folder as this will break the Telerik control(s).
  7. If you intend to use skins different from the default or if you plan to modify the JavaScript files, copy the new RadControls/Rotator folder to the same location as above.
  8. If using VS.NET, update the control's reference in your project to point to the new DLL.
  9. Follow the steps in the Changes and Backward Compatibility section in case there are some changes between the versions.
  10. Recompile your project.
  11. If you have added the control in GAC, remove it by running a gacUtil to remove the old copy and then add the new one. More information on the topic can be located here: Add/Remove Telerik RadRotator to the Global Assembly Cache
  12. Run the project.
  13. If you still get the older version of Telerik RadRotator Show click here

    • Sometimes the .NET Framework wrongly caches the Telerik RadRotator's DLL and therefore the update may seem to have failed. Try the following to ensure that this is not the case:

      1. Terminate the aspnet_wp.exe process (from the Windows Task Manager)
      2. Open a Windows Explorer and navigate to C:\Windows(WINNT)\Microsoft.NET\Framework\v[YOUR_VERSION]\Temporary ASP.NET Files
      3. Delete all folders with names, corresponding to your Telerik projects, i.e. RadRotator, etc.
    • Delete your Visual Studio web project cache(s) - it should be located in C:\Documents and Settings\[YOUR USER]\VSWebCache.
    • Delete your browser cache: Tools -> Internet Options -> Delete Files....

  14. If you get a copyright message Show click here

    The copyright message appears only when using the trial version of Telerik RadRotator (the Developer versions of Telerik's controls do not throw copyright messages). Make sure you have downloaded the proper, Developer "DLL and Scripts only" file. You will recognize it by the Dev abbreviation in the file name.

4. Using the old ToolsFile.xml File and ConfigFile.xml file [valid for Telerik RadEditor and Telerik RadSpell only]

If you would like to use your old ToolsFile.xml and ConfigFile.xml files (which you backed up in #1 above), you can do so by copying them from the back-up to the RadControls\Editor folder (or RadControls\Spell respectively) of your web-application. When prompted to overwrite the other file, click "YES"

© 2002-2008 Telerik. All Rights Reserved.


Add/Remove Telerik RadRotator to the Global Assembly Cache

Telerik RadRotator v2.7 Send comments on this topic.
Add/Remove Telerik RadRotator to the Global Assembly Cache
See Also
Installation and deployment > Deploying Telerik RadRotator into ASP.NET Applications > Add/Remove Telerik RadRotator to the Global Assembly Cache

Glossary Item Box

Add to Global Assembly Cache

There are two ways to add a control to the Global Assembly Cache (GAC):

Automatic

  1. Go to Start -> Settings -> Control Panel -> Administrative Tools -> Microsoft .NET Framework 2.0 Configuration
  2. Expand the nodes and locate Assembly cache
  3. Right-click on it and select Add:

    Microsoft .NET 2.0 Configuration panel
  4. Browse to the Telerik bin directory and ctrl-highlight the needed DLL's (the demo and DictionaryConfiguration DLLs are not needed).
  5. Click Open.

Manual

  1. Run the .NET command prompt (Start -> Programs -> Microsoft VS.NET -> VS.NET Tools -> VS.NET prompt) and start the gacutil.exe tool with -i parameter (install) and the name of the control, e.g.

    Copy Code
    gacutil.exe -i "C:\Program Files\Telerik\Telerik RadRotator2.7\NET1NET2\bin\RadRotator.Net2.dll"

    You may also directly copy the dll files to the "\WINDOWS\assembly" (or "\WINNT\assembly") folder of your server - this is equivalent to the effect of the gacutil.exe utility.

  2. Change the machine.config file of the server and add a reference to the assembly in the GAC. The machine.config file is the configuration file for all web applications on the server. It is located at: "\WINDOWS\Microsoft.NET\Framework\[Framework Version]\CONFIG". It is similar in to the web.config file, but the web.config only works for the web application, in which it resides.

    Locate the <assemblies> tag (which should be under <configuration><system.web> <compilation>/<compilers>/<assemblies> ) Between the <assemblies> tag, you should enter something similar to:

    Copy Code
    <add assembly="AssemblyFileName, Version=0.0.0.0, Culture=neutral, PublicKeyToken=5edf592a9c40680c" />

    To get the information that goes into the assembly attribute (version, culture, PublicKeyToken), you can run the gacutil /l command, which will return a list of all the assemblies in the GAC. You will have to look for the one you just added and copy the entire line (minus the Custom=null part at the end).
    For example the following command:

    Copy Code
    gacutil -l RadRotator.Net2

    will return:

    Copy Code
    RadRotator, Version=2.7.0.0, Culture=neutral, PublicKeyToken=e8ab424810b6b9b5 Custom=null

    so the correct entry in the machine.config should be:

    Copy Code
    <add assembly="RadRotator.Net2, Version=2.7.0.0, Culture=neutral, PublicKeyToken=e8ab424810b6b9b5" />

After that you should be able to use the control in all the application on the server without having to copy it to the "bin" folder of each web-application.

Remove from Global Assembly Cache

In order to remove Telerik RadRotator from GAC, please use the following command:

Copy Code
gacutil.exe -u radrotator

See Also

The 'RadControls' Folder

© 2002-2008 Telerik. All Rights Reserved.


Multi Targeting in Visual Studio 2008

Telerik RadRotator v2.7 Send comments on this topic.
Multi Targeting in Visual Studio 2008
See Also
Installation and deployment > Deploying Telerik RadRotator into ASP.NET Applications > Multi Targeting in Visual Studio 2008

Glossary Item Box

In Visual Studio 2008 you are able to build applications targeting multiple versions of the .NET Framework. Apart from ASP.NET 3.5, VS 2008 can open, edit and build ASP.NET 2.0 applications (applications with ASP.NET AJAX 1.0 as well). Visual Studio 2008 can also deploy these application on .NET 2.0 machines. You are able to easily build applications with RadControls targeting both ASP.NET 2.0 and ASP.NET 3.5.

See Also

External Link
See more information on how to use Multi Targeting in VS 2008

© 2002-2008 Telerik. All Rights Reserved.


Deploying Telerik RadRotator on Shared Hosting

Telerik RadRotator v2.7 Send comments on this topic.
Deploying Telerik RadRotator on Shared Hosting
Installation and deployment > Deploying Telerik RadRotator into ASP.NET Applications > Deploying Telerik RadRotator on Shared Hosting

Glossary Item Box

All Telerik controls are server controls and have to be installed on the web server in order to function properly. This also means that you will need to create the respective virtual directories and give the proper permissions (ASPNET [IIS5], NEtwork Service [IIS6]) in order to use them on the shared hosting.

If you have already created the application on your development machine

1. Copy/upload the compiled application via FTP to the production server, i.e. on the shared hosting. The application should reside in the inetpub/wwwroot folder.

2. Create a virtual directory for the application folder. Before you do this step, consult with your hosting provider on how this is to be accomplished. If the provider offers thorough instructions, use them instead of the ones below. If you do not have access to the Information Services console, ask your provider to set the application for you. If the provider does not offer instructions, then:

1. Locate the Internet Information Services console;

2. Navigate to the application folder;

3. Find the folder's Properties;

4. Create a virtual directory;

5. Remember the application name and click OK.

3. Give full permissions to the ASPNET user (if you are using IIS5) or to the Network Service account (using IIS6 or IIS7, Windows Server 2003, Windows Vista/Longhorn) on the application folder. Again, before doing this step, consult with your hosting provider on how this is to be accomplished. If the provider offers thorough instructions, use them instead of the ones below. Otherwise, contact your provider to set the permissions for you.

4. Run the project.

Notes.

As the proper operation of some Telerik RadEditor elements need some external files to be loaded, a RadControls folder instance is needed for the control to run.

There are two possible RadControls folder usages:

  • Copy the RadControls folder within your web-application:

    Manually copy the RadControls folder to the new location within your web application (for example, ~/Resources/). Specify its position via the RadControlsDir property of the control's declaration: <radE:RadEditor RadControlsDir="~/Resources/RadControls/" ...></radE:RadEditor>, where the "~" (tilde) symbol in the path represents your web-application root directory.
  • Copy the RadControls folder outside your web-application (this is the best scenario if you would like to share the RadControls folder across multiple web applications): Manually copy the RadControls to the new location using Windows Explorer. Create a virtual directory with a preferred name (e.g. RadControls) under each application's root which points physically to the same physical RadControls folder.

    The respective RadControls virtual directory should NOT be a web application but virtual directory only! You can find more information on the topic in the following KB article: (ID#728) Error Message: Could not load type 'Telerik.WebControls.Dialogs.Dialog'.

    If the Virtual subfolder alias is different than RadControls, specify the virtual folder position via the RadControlsDir property in the editor's declaration in your ASCX/ASPX file
    <radE:RadEditor RadControlsDir="~/MyRadControls/" ...></radE:RadEditor>

    More information on the topic is available in the following help article: The 'RadControls' folder.

If you plan to deploy the controls directly on the shared hosting

1. Log in your Client.NET account.

2. Go to "My licenses" and click on "My Purchases" (or "My Free Trials" if you are a trial user).

3. Locate the needed control, and click on it.

4. Click on the "Download" tab to download the Manual installation (ZIP) file.

5. On the server, create a "Telerik" folder in your "inetpub/wwwroot" folder on the server.

6. If you intend to use skins different from the default or if you plan to modify the JavaScript files, create a new folder named RadControls in the inetpub/wwwroot/Telerik folder.

7. Follow the instructions from the first case above.

© 2002-2008 Telerik. All Rights Reserved.


Embedded Resources

Telerik RadRotator v2.7 Send comments on this topic.
Embedded Resources
Installation and deployment > Deploying Telerik RadRotator into ASP.NET Applications > Embedded Resources

Glossary Item Box

All Telerik RadControls for ASP.NET have their web resources embedded in the control assembly. Each control automatically fetches the required resources from the web. Embedded Resources are easier to manage because they require that you only maintain a single DLL for each RadControl when you upgrade versions/deploy applications. You no longer need to include the JavaScripts and the other related files with the RadControls folder in the root of your application. If you use external resources, you'll simply need to make sure you keep your DLLs and RadControls folders in sync when you upgrade and deploy.

Note that you still need the RadControls folder if you want to use a skin other than the Default.

You can control this functionality by setting the boolean property UseEmbeddedScripts.

When UseEmbeddedScripts is set to true (by default) web resources are streamed by the built-in web resource handler using a query string (like WebResource.axd?d=HTLSHE...). This scenario is suitable for easier deployment (no RadControls required).
The backside of using the embedded resources is that sometimes web resources are not cached (e.g. when your site is in debug mode <compilation debug="true" />). In addition the long query strings are adding bulk to the HTML you are sending to the client. Using external resources, i.e. the RadControls folder may nearly halve the page size due to the shorter resource paths. Your mileage may vary depending on the RadControls you are using.

If you set UseEmbeddedScripts to false, the control will use the necessary resources (files) from the RadControls folder. This is appropriate for example for cases when the web resource handler is disabled or when you have applied some modifications to the JavaScript or CSS files used by the control.

None of the functionality of the controls will change. Switching this property would only mean that you have to keep a local copy of the RadControls folder with the JS files in your application, since you are not going to use the embedded ones.
You cannot combine both methods for getting web resources, i.e. you cannot make the control take its scripts as embedded resources and skin file from RadControls.

© 2002-2008 Telerik. All Rights Reserved.


Trust level

Telerik RadRotator v2.7 Send comments on this topic.
Trust level
Installation and deployment > Deploying Telerik RadRotator into ASP.NET Applications > Trust level

Glossary Item Box

This topic refers the case you are trying to publish a site to a shared environment. The site is using the <RadControlName> component, where only the <RadControlName>.dll file exists in the /bin directory of the application along with the scripts directory (/RadControls/<ControlName>/Scripts) on the root.

All RadControls supports Medium trust level under shared hosting environment.

Note that a requirement for the RadControl is to have the trust level set to Medium at minimum - otherwise you may receive server error like the following:

Could not load type Telerik.RadRotatorDesign.RotatorComponentEditor from assembly mscorlib, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

To modify the trust level setting please follow the instructions below:

Locate the machine.config file placed in the \Microsoft.NET\Framework\v2.0.50727\CONFIG folder on your production server. Open it for editing and change the following line:

machine.config Copy Code
<trust level="Medium" originUrl=""/>

Further information about the different trust level options and their policies you can find in the MSDN:

http://msdn2.microsoft.com/en-us/library/tkscy493.aspx

http://msdn2.microsoft.com/en-us/library/wyts434y.aspx

© 2002-2008 Telerik. All Rights Reserved.


Troubleshooting deployment on the production server

Telerik RadRotator v2.7 Send comments on this topic.
Troubleshooting deployment on the production server
Installation and deployment > Deploying Telerik RadRotator into ASP.NET Applications > Troubleshooting deployment on the production server

Glossary Item Box

Since the Q2 2006 release our controls utilize webresources which is a new feature of ASP.NET 2.0. There are cases in which this may cause problems. For some reason requesting the webresource handler (webresource.axd) returns error number 404. This javascript files used by the control should be streamed by the web resource handler. As a result of the aforementioned error this does not happen and you may experience JavaScript errors on the client.

Here some tips how the problem can be solved:

First approach

  1. Open IIS management snap-in ( e.g. run inetmgr.exe)
  2. Right click your website and choose properties
  3. Go to the "Home Directory" tab and click the "Configuration" button
  4. A dialog should pop out and you would see the mappings listbox
  5. Find the entry for the ".axd" extension and edit it by clicking the "Edit" button
  6. In the new dialog uncheck the "Verify if file exist" checkbox - which I suspect is causing the problem.

Second approach

Alternatively, if the steps above don't solve the issue, you can try creating an empty WebResource.axd file in the site root folder.

Third approach

You can try setting UseEmbeddedScripts property to false. Thus the control will use the scripts from RadControls/Rotator/Scripts folder instead the embedded resource.

© 2002-2008 Telerik. All Rights Reserved.


Telerik RadRotator Basics

Telerik RadRotator v2.7 Send comments on this topic.
Telerik RadRotator Basics
See Also
Telerik RadRotator Overview > Telerik RadRotator Basics

Glossary Item Box

Telerik RadRotator consists of two main parts - RadRotator and RadTicker.

RadRotator

A rotator represents a template-driven ASP.NET control that displays any number of data-bound "frames" in a particular static HTML area. In order to use the rotator you need to first define a frame template for the area (the layout of the frame) and then to bind the instance of Telerik RadRotator to a data source containing the information that will be used to "fill" the template area.

The structure of Telerik RadRotator can be defined in one of the following methods:

  • Using a static XML File

  • Using live XML

  • Through DataBinding (ArrayList, DataSets, DataTables and DataViews, etc.)

The following animation illustrates a Rotator example:

As shown by the animation, Telerik RadRotator allows you to display all of the information from a given data source in the same page without reloading: in portions, one at a time. You can also apply special filter effects and scrolling.

RadTicker

A ticker is a control that displays text by outputting only a single character of the text per given interval, thus simulating a "typewriter" effect on the screen. A ticker may consist of multiple TickerLines. When the end of the current line is reached, the ticker continues on the next line.

The following animation illustrates a Ticker example:

See Also

RadRotator
RadTicker

© 2002-2008 Telerik. All Rights Reserved.


Most Important Properties

Telerik RadRotator v2.7 Send comments on this topic.
Most Important Properties
Telerik RadRotator Overview > Most Important Properties

Glossary Item Box

RadRotator Class Properties

Property

Description

AutoAdvance | Specifies whether RadRotator will advance through its slides automatically.

AutoPostBack

Specifies wether or not the control will require postback event handling.

CssClass

Specifies the CSS class that should be used for the rotator <DIV> element. If not specified, the default item CSS

class is used as defined in DefaultItemCss property of RadRotator.

ContentFile

The location (path + filename) of the XML content file used to populate the menu.

CustomTransitionFilter

Specifies a custom transition effect that overrides the default filter strings used when TransitionEffect is set. Using

this propery you can fine tune the DXTransform filters to your liking.

DataSource

The data source for ASP.NET data binding.

DataMember

If the assigned DataSource is a DataSet this property specifies the name of table from the DataSet.

FrameTimeout

Specifies the frame timeout in milliseconds.

FramesToShow | Specifies how many frames are visible in rotator.

PauseOnMouseOver

Specifies wether scrolling or slideshows pause when the user hovers the mouse cursor over the control.

ScrollDirection

Specifies the direction for the scroller.

ScrollSpeed

Specifies the speed with which scrolling occurs. The duration is in milliseconds of pause between sequential scrolls.

TransitionEffect

Specifies the transition effect for the slideshow mode.(Works only in Internet Explorer!!)

TransitionType

Specifies the transition type. Could be scroll or slideshow.

UseRandomSlide

Specifies wether the rotator will choose a random slide when in slideshow mode.

RadTicker Class Properties

Property

Description

AutoAdvance

If you set the AutoAdvance property to false, then you will have to use a client API Call

ticker_id.TickNextLine()

AutoStart

A boolean property when set to true, automatically causes the Ticker to start ticking upon loading the web form.

LineDuration

Specifies in milliseconds the pause RadTicker makes before starting to tick the next line (if AutoAdvance=True).

Loop

If you set this property to true RadTicker will never finish ticking. This may have possible implications when having

more than one RadTicker instances in a RadRotator. The way RadRotator works is that when the first ticker on a

frame has finished ticking it will start ticking the next ticker on the frame. If a RadTicker instance is ticking (

Loop=true) it will never finish and the next ticker on the frame will not get started.

TickSpeed

Specifies the speed with which ticking occurs. The duration is in milliseconds of pause between sequential ticks.

© 2002-2008 Telerik. All Rights Reserved.


RadRotator

Telerik RadRotator v2.7 Send comments on this topic.
RadRotator
See Also
Telerik RadRotator Components > RadRotator

Glossary Item Box

A rotator represents a template-driven ASP.NET control that displays any number of data-bound "frames" in a particular static HTML area. In order to use the rotator you need to first define a frame template for the area (the layout of the frame) and then to bind the instance of Telerik RadRotator to a data source containing the information that will be used to "fill" the template area.

Creating a rotator programmatically

The following source code illustrates how you can create the content for a rotator from a DataTable:

C# Copy Code
private void Page_Load(object sender, System.EventArgs e)
{
DataTable table = new DataTable();

table.Columns.Add("FirstName");
table.Columns.Add("LastName");

table.Rows.Add(new string [] {"John", "Smith"} );
table.Rows.Add(new string [] {"John", "Doe Senior"} );
table.Rows.Add(new string [] {"John", "Doe Junior"} );

RadRotator1.DataSource = table;
RadRotator1.DataBind();
}

Creating a rotator from data defined in an XML file.

The source code below illustrates how you can create content for a rotator from data defined in a static XML file.

To bind the XML file to the rotator, simply specify the location of the content file by setting the ContentFile property.

ASPX Copy Code
<rad:RadRotator id="RadRotator1"
runat="server" ContentFile="news.xml"
TransitionType="slideshow"
TransitionEffect="fade">
<FrameTemplate>
<div class="module">
<%# DataBinder.Eval(Container.DataItem, "Title") %>
</div>
</FrameTemplate>
</rad:RadRotator>

See Also

RadTicker

© 2002-2008 Telerik. All Rights Reserved.


RadTicker

Telerik RadRotator v2.7 Send comments on this topic.
RadTicker
See Also
Telerik RadRotator Components > RadTicker

Glossary Item Box

A Ticker is a control that displays text by outputting only a single character of the text per given interval, thus simulating a "typewriter" effect on the screen. A Ticker may consist of multiple TickerLines. When the end of the current line is reached, the ticker continues on the next line.

RadTicker supports plain text only. You cannot insert images or markup in a ticker.

There are two ways for creating tickers:

  • in design mode, using the Properties Window;
  • programmatically.

In either case, you will need to set the following properties: AutoAdvance, AutoStart, LineDuration, Loop and TickSpeed.

ASP

The source code below illustrates you can create a ticker with multiple tickerlines in html mode. Simply define the instance of the ticker you want and feed different lines to the control by using the <RadTickerLine> tag. Telerik RadTicker is also able to read literal content that is inside the <RadTickerLine> tags. This way you can construct your tickers easily, and you don't have worry about whether or not you have template tags.

ASPX Copy Code
<rad:RadTicker AutoStart="true" runat="server" ID="Radticker1" loop="true">
<RadTickerLine> line one</RadTickerLine>
<RadTickerLine> line two</RadTickerLine>
<RadTickerLine> line three</RadTickerLine>
</rad:RadTicker>

C#

The source code below illustrates you can create a ticker with multiple tickerlines programmatically.

C# Copy Code
string[] SomeTickerLines = {"line one","line two ","line three "};
Telerik.WebControls.RadTicker aTickerLine = new Telerik.WebControls.RadTicker();
aTickerLine.UserTickerLines = SomeTickerLines;
aTickerLine.AutoStart = true;
this.Controls.Add(aTickerLine);

See Also

RadRotator

© 2002-2008 Telerik. All Rights Reserved.


Integrating Rotators with Tickers

Telerik RadRotator v2.7 Send comments on this topic.
Integrating Rotators with Tickers
See Also
Telerik RadRotator Components > Integrating Rotators with Tickers

Glossary Item Box

Rotators and Tickers can easily be integrated to work together. In order for rotators and tickers to work together, you can embed any number of tickers in the FrameTemplate of Telerik RadRotator.

The source code below shows how you can embed a ticker in the FrameTemplate of Telerik RadRotator:

Copy Code
<rad:RadRotator id="RadRotator1"
ScrollDirection="Left"
SmoothScrollDelay="15"
runat="server"
ContentFile="news.xml"
TransitionType="scroll">
<FrameTemplate>
<rad:RadTicker runat="server">
<%# DataBinder.Eval(Container.DataItem, "Title") %>
</rad:RadTicker>
</FrameTemplate>
</rad:RadRotator>

See Also

RadRotator
RadTicker

© 2002-2008 Telerik. All Rights Reserved.


Defining the Structure from XML File

Telerik RadRotator v2.7 Send comments on this topic.
Defining the Structure from XML File
See Also
Defining Telerik RadRotator Structure > Defining the Structure from XML File

Glossary Item Box

One of the ways for specifying the Telerik RadRotator structure is by using XML: the most convenient and widespread format for hierarchical data. The XML menu structure consists of a number of nested Item nodes. These item nodes must be encapsulated in a root node.

You can bind an instance of Telerik RadRotator to an XML file in two ways:

  • Using the static XML File
  • Using live XML feed

A typical example of an XML structure for Telerik RadRotator is described below as follows:

Copy Code
<News>
<NewsItem>
<Title>TURKEY: Stocks go up after a surge in investor confidence</Title>
<Date>July, 19th, 2003</Date>
</NewsItem>
<NewsItem>
<Title>ROMANIA: Privatization drives the stock market this week</Title>
<Date>July, 18th, 2003</Date>
</NewsItem>
<NewsItem>
<Title>BULGARIA: \'Government\' plans for a new wave of privatization</Title>
<Date>July, 17th, 2003</Date>
</NewsItem>
</News>

Using Static XML Example

To bind the XML file to the rotator, simply specify the location of the content file by setting the ContentFile property.

Copy Code
<rad:RadRotator id="RadRotator1" runat="server" ContentFile="news.xml" TransitionType="slideshow" TransitionEffect="fade">
<FrameTemplate>
<div class="module">
<%# DataBinder.Eval(Container.DataItem, "Title") %>
</div>
</FrameTemplate>
</rad:RadRotator>

Using Live Feed Example

Binding the rotator to live data source such RSS is very similar to binding it to a static XML file. You need to specify the URL of the data source by setting the ContentFile property.

Copy Code
<rad:RadRotator id="RadRotator1" runat="server" DataMember="item" ContentFile="http://www.telerik.com/support.rss"
TransitionType="slideshow" TransitionEffect="gradientwipe" width="500">
<FrameTemplate>
<div class="module">
<b>
<%# DataBinder.Eval(Container.DataItem,"pubDate") %>
</b>-
<%# DataBinder.Eval(Container.DataItem,"title") %>
</div>
</FrameTemplate>
</rad:RadRotator>

See Also

Defining the Structure through Data Binding

© 2002-2008 Telerik. All Rights Reserved.


Defining the Structure through Data Binding

Telerik RadRotator v2.7 Send comments on this topic.
Defining the Structure through Data Binding
Defining Telerik RadRotator Structure > Defining the Structure through Data Binding

Glossary Item Box

Telerik RadRotator fully supports native .NET connectivity with various data sources. You can bind an instance of Telerik RadRotator to any one of the following data sources:

  • Ienumerable(Array, ArrayList, Queue, Stack, etc.)
  • IListSource(DataSets, DataTables and DataViews)
  • Static XML file
  • Live XML feed

To bind an instance of Telerik RadRotator to a data source:

  1. Create an object (for example, an IListSource) to hold the data you want to bind.
  2. Set the DataSource property, as well as the DataBind() method.

The following source code illustrates how an instance of Telerik RadRotator can be bound to a DataTable:

C# Copy Code
private void Page_Load(object sender, System.EventArgs e)
{
DataTable table = new DataTable();

table.Columns.Add("FirstName");
table.Columns.Add("LastName");

table.Rows.Add(new string [] {"John", "Smith"} );
table.Rows.Add(new string [] {"John", "Doe Senior"} );
table.Rows.Add(new string [] {"John", "Doe Junior"} );

RadRotator1.DataSource = table;
RadRotator1.DataBind();
}

The following source code illustrates how an instance of Telerik RadRotator can be bound to an ArrayList:

C# Copy Code
private void Page_Load(object sender, System.EventArgs e)
{
ArrayList al = new ArrayList();
al.Add("John Smith");
al.Add("John Doe Senior");
al.Add("John Doe Junior");
RadRotator1.DataSource = al;
RadRotator1.DataBind();
}

© 2002-2008 Telerik. All Rights Reserved.


Scrolling and Sliding Items

Telerik RadRotator v2.7 Send comments on this topic.
Scrolling and Sliding Items
See Also
General Functionality > Scrolling and Sliding Items

Glossary Item Box

You can select between two modes of displaying items in a rotator:

  • Scrolling

To allow the user to scroll through items, you need to set the TransitionType property to Scroll. Three properties - SmoothScroll, ScrollDirection, and ScrollSpeed - are used for setting how the items will scroll.

  • Sliding

To have items slide on and off the page, you need to set the TransitionType property to Slideshow. Additionally, you can set the UseRandomSlide property to either true or false, to specify whether or not the rotator will choose a random slide when in slideshow mode.

When in slideshow mode, you can apply various transition effects (Pixelate, Inset, Fade, etc).

The example shown by the screenshot below illustrates a rotator used as a gallery with images scrolling horizontally.

The extract of the source code from the ASPX file of the above example is shown below.

Copy Code
<rad:RadRotator id="RadRotator1" runat="server" ContentFile="forecast.xml" FrameTimeout="4000"
TransitionType="scroll"
height="120px"
width="403px">
....
</rad:RadRotator>

See Also

Using Templates

© 2002-2008 Telerik. All Rights Reserved.


Using Templates

Telerik RadRotator v2.7 Send comments on this topic.
Using Templates
See Also
General Functionality > Using Templates

Glossary Item Box

The content of each Item of Telerik RadRotator can be defined through Content Templates. They can accommodate both HTML elements and ASP.NET WebControls.

In the example shown below, we have defined the frame template (layout) of the product showcase area. It represents a table with three rows:

  • Row 1: the name of the product
  • Row 2: the price
  • Row 3: an image of the product

The <FrameTemplate> portion of Telerik RadRotator defines the actual appearance of the data. The data itself is bound to the template using DataBinder.Eval expressions (similar to DataGrid, DataList, Repeater, etc).

Next, the content is fed to the rotator using a data-binding method.

Copy Code
<rad:RadRotator ScrollDirection="up" ContentFile="rotator.xml" Width="250" Height="150"
FrameChangeType="scroll" id="Rotator1" runat="server">
<FrameTemplate>
<table width=250 height=150>
<tr><td align="center"><b><%# DataBinder.Eval(Container.DataItem, "[Name]") %></b></td></tr>
<tr><td align="center"><%# DataBinder.Eval(Container.DataItem, "[Price]") %></td></tr>
<tr><td align="center"><img src="<%# DataBinder.Eval(Container.DataItem, "[Name]") %>"></td></tr>
</table>
</FrameTemplate>
</rad:RadRotator>

See Also

Scrolling and Sliding Items

© 2002-2008 Telerik. All Rights Reserved.


Localization

Telerik RadRotator v2.7 Send comments on this topic.
Localization
General Functionality > Localization

Glossary Item Box

Telerik RadRotator fully supports foreign languages. To implement localization, you need to create a separate content file for each language and then bind the appropriate one dynamically by setting the DataSource property and the DataBind() method.
You must ensure that you set the proper encoding of the XML content file. In case you are building the rotator structure programmatically, you need to set the encoding in the ASPX file. Alternatively, you can create multiple instances of Telerik RadRotator, each localized for a different language.

© 2002-2008 Telerik. All Rights Reserved.


Multiple Rotators in a Web Page

Telerik RadRotator v2.7 Send comments on this topic.
Multiple Rotators in a Web Page
See Also
General Functionality > Multiple Rotators in a Web Page

Glossary Item Box

Telerik RadRotator allows the developer to easily create multiple instances of the control in the same web form. Simply drag any number of instances of Telerik RadRotator onto the web form and set their relevant properties.

The example shown by the screenshot below illustrates the use of multiple rotators on a single page.

The extract of the source code from the aspx file of the example above is shown below.

Copy Code
<rad:RadRotator id="RadRotator1" runat="server"... >

<rad:RadRotator id="RadRotator2" runat="server" ...>

See Also

Using Templates

© 2002-2008 Telerik. All Rights Reserved.


Ticker Lines

Telerik RadRotator v2.7 Send comments on this topic.
Ticker Lines
See Also
General Functionality > Ticker Lines

Glossary Item Box

The RadTicker class provides a property which allows you to easily add tickerlines to already existing data-bound tickerlines. Essentially, there are two ways for adding tickerlines:

  1. Defining TickerLines Programmatically
    In code-behind you need to define the tickerlines as an array of strings. Afterwards you have to assign the name of the array you have just defined, as a value to the UserTickerLines property.
  2. Defining TickerLine directly in aspx file
    You can also define the tickerlines in the ASPX file directly, by assigning them as a value to the UserTickerlines property:
Copy Code
<rad:radticker id="RadTicker2" runat="server" UserTickerLines="Line one, Line two, Line three" autostart="True">
</rad:radticker>

Notes.

  • Please bear in mind that if you set the property declaratively (as shown in the code above), you need to separate the tickerlines by commas.
  • The property allows design-time support as well.

See Also

RadTicker

© 2002-2008 Telerik. All Rights Reserved.


Displaying a random frame on initial page load

Telerik RadRotator v2.7 Send comments on this topic.
Displaying a random frame on initial page load
See Also
General Functionality > Displaying a random frame on initial page load

Glossary Item Box

The code below binds the rotator to an array list with one element only. This element is randomly selected from the original array list with the GetRandomSlideArrayList function.

C# Copy Code
protected void Page_Load(object sender, System.EventArgs e) {
ArrayList al = new ArrayList();
al.Add("Line One");
al.Add("Line Two");
al.Add("Line Three");
al.Add("Line Four");
al.Add("Line Five");
al.Add("Line Six");
// RadRotator1.DataSource = al
RadRotator1.DataSource = GetRandomSlideArrayList(al);
RadRotator1.DataBind();
RadRotator1.UseRandomSlide = true;
}
protected void GetRandomSlideArrayList(ref ArrayList arrayList) {
ArrayList result = new ArrayList();
Random random = new Random(System.DateTime.Now.Millisecond);
string item = arrayList(random.Next(arrayList.Count)).ToString();
result.Add(item);
return result;
}
VB.NET Copy Code
Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load

Dim al As New ArrayList
al.Add("Line One")
al.Add("Line Two")
al.Add("Line Three")
al.Add("Line Four")
al.Add("Line Five")
al.Add("Line Six")
'RadRotator1.DataSource = al
RadRotator1.DataSource = GetRandomSlideArrayList(al)
RadRotator1.DataBind()
RadRotator1.UseRandomSlide = True
End Sub

Protected Function GetRandomSlideArrayList(ByRef arrayList As ArrayList)
Dim result As ArrayList = New ArrayList()
Dim random As Random = New Random(System.DateTime.Now.Millisecond)
Dim item As String = arrayList(random.Next(arrayList.Count)).ToString()
result.Add(item)
Return result
End Function

See Also

Scrolling and Sliding Items
Using Templates

© 2002-2008 Telerik. All Rights Reserved.


Interoperability of Telerik RadRotator with RadAjax

Telerik RadRotator v2.7 Send comments on this topic.
Interoperability of Telerik RadRotator with RadAjax
AJAX Support > Interoperability of Telerik RadRotator with RadAjax

Glossary Item Box

Remark: The built-in AJAX functionality in telerik RadGrid, RadCombobox, RadTeeview has a higher priority than telerik RadAjax. You should turn it off in order to update outside controls and use AJAX Panel or AJAX Manager.
Important note: telerik RadUpload is unable to upload files with an Ajax call. This is related to the inability of the XmlHttpRequest component to upload files. This component is the core of any Ajax framework, such as telerik RadAjax or Atlas (AJAX extensions for ASP.NET).

Telerik RadRotator is designed for seamless interoperability with the Telerik AJAX framework, the RadAjax suite enabling developers to implement the following functionality:

  • AJAXify (AJAX-enable) telerik RadRotator to work with AJAX instead of regular postbacks;
  • Update the telerik RadRotator control upon an AJAX request made by a control on the page via telerik RadAjax;
  • Make telerik RadRotator initiate an AJAX request in order to update other controls on the page.

Make telerik RadRotator work with AJAX requests (Ajax-enable Telerik RadRotator)

You can ajaxify any member of the telerik RadControls for ASP.NET suite. The ajax-enabled control will work in AJAX mode and will perform callback requests instead of regular postbacks.

To do so, you have two possible options:

  • place the instance of RadRotator into an AjaxPanel - in this case, the control will update itself and all other controls in the panel via AJAX request
  • place one AJAX Manager on the page and in its property builder set the AJAX pair, i.e. AJAX initiator and the updated control. In this case, as we want Telerik RadRotator to update itself with AJAX, it should be set as initiator and updated control.

Update telerik RadRotator upon AJAX request

Telerik RadRotator is fully compatible with the telerik RadAjax suite and can be updated via callbacks from any other control on the page without any additional coding. You have two possible options:

  • You need to have the AJAX Manager on the page and set the AJAX pair - AJAX initiator and the updated control (telerik RadRotator in this case). We recommend you do this using the visual editor in VS.NET.
  • Alternatively you can place telerik RadRotator in AJAX Panel together with the control that should update it.

Initiate an AJAX request and update other controls with Telerik RadRotator

You may want to initiate a callback request by telerik RadRotator and update other controls on the page.

To implement this functionality, you need to do the following:

  • Place AJAX Manager on the page. Open its property builder and set the AJAX pair. In this case Telerik RadRotator will be the AJAX initiator. You can set as many controls as you wish to be updated by a single request.

OR

  • Place both controls (telerik RadRotator and the control that should be updated) in AJAX Panel. telerik RadRotator will automatically start updating all controls in the panel (including itself) with AJAX requests.

More integration examples of telerik RadAjax with the other controls from the telerik RadControls for ASP.NET suite can be seen here.

© 2002-2008 Telerik. All Rights Reserved.


ASP.NET AJAX Framework

Telerik RadRotator v2.7 Send comments on this topic.
ASP.NET AJAX Framework
AJAX Support > ASP.NET AJAX Framework

Glossary Item Box

Show All Show All
Hide All Hide All

All Telerik controls now provide full support for the new ASP.NET AJAX framework.
Telerik's own patent-pending AJAX mechanism does not interfere in any way with the ASP.NET AJAX framework. Telerik RadAjax, as well as all built-in AJAX features of Telerik RadControls for ASP.NET work with ASP.NET AJAX without any conflict.

To enable ASP.NET AJAX with Telerik RadRotator:

  1. Make sure you have the ASP.NET AJAX framework installed.
  2. If the control is initially invisible and is shown after an ASP.NET AJAX update, you should manually register all the required CSS files in the head tag of your page. Otherwise the control will not be displayed correctly. The easiest way to do this is through a LINK element:
    Copy Code
    <link href="~/RadControls/Rotator/Skins/[SkinName]/styles.css" rel="stylesheet" runat="server" >
  3. Place the instance of Telerik RadRotator in an ASP.NET AJAX UpdatePanel.

To enable or disable the ASP.NET AJAX UpdatePanel, set the EnablePartialRendering property of the ScriptManager class to True or False accordingly.

Grid built-in AJAX has higher priority than external AJAX frameworks - ASP.NET AJAX and RadAjax. In case one need the Grid to be updated from an ASP:UpdatePanel, Grid's EnableAJAX should be turned off.

ASP.NET AJAX is not a Telerik product.
For further information about ASP.NET AJAX, refer to ASP.NET AJAX documentation .

Known problems related to ASP.NET AJAX interoperability

Exceptions

If you receive exceptions such as:

System.Web.HttpException: The Controls collection cannot be modified because the control contains code blocks (i.e. <% ... %>)

you need to move the code block outside of the head tag. For example:

Before: Copy Code
<head runat="server">
<script>
var controlClientObject = <%= RadControl1.ClientID %>
...
</script>
</head>

<body>
...
</body>
After: Copy Code
<head runat="server">
</head>
<body>
<script>
var controlClientObject = <%= RadControl1.ClientID %>
...
</script>
...
</body>

© 2002-2008 Telerik. All Rights Reserved.


Client-Side API

Telerik RadRotator v2.7 Send comments on this topic.
Client-Side API
Telerik RadRotator Client-Side > Client-Side API

Glossary Item Box

Telerik RadRotator offers a client-side API which allows the developer to create rotators with rich functionality, whose behaviors can be easily manipulated at client-side. For example, you can specify whether or not scrolling or slideshows should pause when the mouse hovers over the control. You can also readily adjust the speeds of scrolling and smooth-scrolling.

The RadRotator class provides eight functions: StartRotator, StopRotator, ShowPrevFrame, ShowNextFrame, ScrollUpNextFrame, ScrollDownNextFrame, ScrollLeftNextFrame and ScrollRightNextFrame you can use to manipulate the state of the rotator.

The example shown by the screenshot below illustrates how the user can manipulate the state of the rotator.

The extract of the source code from the aspx file of the example above is shown below.

Copy Code
<button onclick="RadRotator1.StopRotator();" type="button" class="stop"></button>
<button onclick="RadRotator1.StartRotator();" type="button" class="start"></button>
<button onclick="RadRotator1.ScrollUpNextFrame();" type="button" class="up"></button>
<button onclick="RadRotator1.ScrollDownNextFrame();" type="button" class="down"></button>

<button onclick="Radrotator2.StopRotator();" type="button" class="stop"></button>
<button onclick="Radrotator2.StartRotator();" type="button" class="start"></button>
<button onclick="Radrotator2.ScrollLeftNextFrame();" type="button" class="left"></button>
<button onclick="Radrotator2.ScrollRightNextFrame();" type="button" class="right"></button>

<button onclick="Radrotator3.StopRotator();" type="button" class="stop"></button>
<button onclick="Radrotator3.StartRotator();" type="button" class="start"></button>
<button onclick="Radrotator3.ShowPrevFrame();" type="button" class="left"></button>
<button onclick="Radrotator3.ShowNextFrame();" type="button" class="right"></button>

© 2002-2008 Telerik. All Rights Reserved.


OnClientFrameChanging

Telerik RadRotator v2.7 Send comments on this topic.
OnClientFrameChanging
See Also
Telerik RadRotator Client-Side > Client-Side Events > OnClientFrameChanging

Glossary Item Box

Fired by

It is fired whenever a frame of Telerik RadRotator is about to change. However if the user returns false in the event handler, the frame will not change.

Arguments

Two arguments - the name of the event and the event hander respectively.

Can be canceled

Yes

Example
ASPX/ASCX Copy Code
<rad:RadRotator id="RadRotator1" runat="server" ... >

The client-side handler (called OnClientFrameChanging) implements the following JavaScript logic:

JavaScript Copy Code
<script>
RadRotator1.attachEvent("OnClientFrameChanging", "bchange_handler");
function bchange_handler(sender, args)
{
event_log.innerHTML += sender.ClientID + " is about to change a frame<br/>";
}
</script>
Remarks

In order to trigger this event, you need to define a custom JavaScript function in the aspx file to call the event handler of OnClientFrameChanging. This function should have two parameters (corresponding to the name of event and the event hander respectively).

See Also

OnClientFrameChanged

© 2002-2008 Telerik. All Rights Reserved.


OnClientFrameChanged

Telerik RadRotator v2.7 Send comments on this topic.
OnClientFrameChanged
See Also
Telerik RadRotator Client-Side > Client-Side Events > OnClientFrameChanged

Glossary Item Box

Fired by

This event is fired whenever a frame of Telerik RadRotator has changed.

Arguments

Two arguments - the name of the event and the event hander respectively.

Can be canceled

Yes

Example
ASPX/ASCX Copy Code
<rad:RadRotator id="RadRotator1" runat="server" ... >

The client-side handler (called OnClientFrameChanged) implements the following JavaScript logic:

JavaScript Copy Code
<script>
RadRotator1.attachEvent("OnClientFrameChanged", "achange_handler");
function achange_handler(sender, args)
{
event_log.innerHTML += sender.ClientID + " has changed a frame<br/>";
}
</script>
Remarks

In order to trigger this event, you need to define a custom JavaScript function in the aspx file to call the event handler of OnClientFrameChanged. This function should have two parameters (corresponding to the name of event and the event handler respectively).

See Also

OnClientFrameChanging

© 2002-2008 Telerik. All Rights Reserved.


ItemClick

Telerik RadRotator v2.7 Send comments on this topic.
ItemClick
See Also
Telerik RadRotator Server-Side > Server-Side Events > ItemClick

Glossary Item Box

Fired

Whenever the user clicks on the RadRotator instance.

Arguments

This event supplies an argument class called RadRotatorClickEventArgs which contains reference to the frame that was clicked by the user. You can use that reference to obtain the ItemIndex of the frame and use it in your own event handling logic.

Return Type

Example

Initial state of the rotator - before clicking on it.

Upon clicking on the rotator the ItemClicked event is triggered as result the additional information in the relevant <div> </div> is displayed.

The source code below illustrates the implementation of the ItemClicked event.

C# Copy Code
private void Rotator1_ItemClicked(object o, Telerik.WebControls.RadRotatorClickEventArgs e)
{
Telerik.WebControls.RadRotatorFrame frame = e.Item;
int index = frame.ItemIndex;
this.HideDivs(); //hides the div that's corresponding to the frame clicked
switch(frame.ItemIndex)
{

//Show the div that's corresponding to the frame clicked
case 0:
{
Div1.Style["display"] = "block";
break;
}
case 1:
{
Div2.Style["display"] = "block";
break;
}
case 2:
{
Div3.Style["display"] = "block";
break;
}
}
}
Remarks

You should set the AutoPostBack property to true in order for this event to work.

See Also

OnClientFrameChanging
OnClientFrameChanged

© 2002-2008 Telerik. All Rights Reserved.


How to bind ticker programmatically

Telerik RadRotator v2.7 Send comments on this topic.
How to bind ticker programmatically
How to > How to bind ticker programmatically

Glossary Item Box

Telerik RadRotator consists of two components - a rotator and a ticker. It is possible to use only the ticker component. Please take into account that when you databind a rotator, the ticker can "consume" the data that is bound to the parent rotator control. When used alone, the ticker cannot be databound. However, this is not a major obstacle as tickerlines can be declaratively defined in the .aspx page, like:

ASPX Copy Code
<rad:RadTicker AutoStart="true" runat="server" ID="Radticker1" Loop="true">
<RadTickerLine>Nov 30, 2006 - Telerik Partners with Microsoft to Deliver Rich 2007 Office UIs
</RadTickerLine>
<RadTickerLine>Nov 10, 2006 - Visit Telerik’Booth at TechEd: Developers 2006
</RadTickerLine>
<RadTickerLine>Oct 10, 2006 - Telerik RadControls for ASP.NET Q3 2006 –Next Generation UIs for Web and Desktop Applications
</RadTickerLine>
</rad:RadTicker>

A problem might appear when you need to create a ticker in code behind and dynamically add it to the page. To solve the issue we added the UserTickerLines property to the ticker class. It is used in the following way:It can also be used in the .aspx file if you find it more convenient:

C# Copy Code
protected void Page_Load(object sender, EventArgs e)
{
string[] SomeTickerLines = { "line one", "line two ", "line three " };
Telerik.WebControls.RadTicker aTickerLine = new Telerik.WebControls.RadTicker();
aTickerLine.UserTickerLines = SomeTickerLines;
aTickerLine.AutoStart = true;
aTickerLine. Loop = true;
this.Controls.Add(aTickerLine);
}
VB.NET Copy Code
Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
Dim SomeTickerLines As String() = {"line one", "line two ", "line three "}
Dim aTickerLine As New Telerik.WebControls.RadTicker()
aTickerLine.UserTickerLines = SomeTickerLines
aTickerLine.AutoStart = True
aTickerLine. Loop = True
Me.Controls.Add(aTickerLine)
End Sub

It can also be used in the .aspx file if you find it more convenient:

Copy Code
<rad:radticker id="RadTicker2" runat="server"
UserTickerLines="Line one, Line two, Line three"
autostart="True">
</rad:radticker>
This property can be also set at design time.

© 2002-2008 Telerik. All Rights Reserved.


Create RadRotator Programmatically

Telerik RadRotator v2.7 Send comments on this topic.
Create RadRotator Programmatically
See Also
How to > Create RadRotator Programmatically

Glossary Item Box

This tutorial is from Todd Anglin's blog post.

Step 1: Define your template

Defining a template for RadRotator in code is very similar to the process involved in programmatically creating a template for RadGrid. Basically, you just need to create a class that implements ITemplate and that renders controls where you want them. The complexity of your template class depends entirely on how many controls you render and how many of them need to be data bound, but with basic knowledge you can scale the principles involved to handle any situation.

In today's demo, we want to create a RadRotator in code that rotates through a collection of images. To do that, we need to create a template class that renders an Image control and bind the ImageURL to our data source. The basic shell of our template will look something like this:

C# Copy Code
public class RadRotatorTemplate : ITemplate
{
public RadRotatorTemplate() { }
}
VB Copy Code
Public Class RadRotatorTemplate
Implements ITemplate
Public Sub RadRotatorTemplate()
'Controls
End Sub
End Class

To begin working with our new class, we can use Visual Studio's helpful template implementer by right-clicking on "ITemplate" and selecting "Implement interface", like this (C# only, VB will automatically implement the interface if you hit the tab key after adding it):

After you select "Implement Interface", Visual Studio will automatically add the methods to your class that need to exist for you to completely satisfy the interface's contract. Each method stub will also contain a "throw" statement that will cause an exception if you do not manually add some logic to each method's body. With the interface implemented, our class now looks like this:

C# Copy Code
public class RadRotatorTemplate:ITemplate
{
public RadRotatorTemplate() {}
#region ITemplate Members
public void InstantiateIn(Control container)
{
throw new Exception("The method or operation is not implemented.");
}
#endregion
}
VB Copy Code
Public Class RadRotatorTemplate
Implements ITemplate
Public Sub InstantiateIn(ByVal container As System.Web.UI.Control) Implements System.Web.UI.ITemplate.InstantiateIn
End Sub
End Class

Now we need to add some "real" code to the InstantiateIn method. This is were we define and layout the controls that we want to display in our template. In this demo, we simply need to add a single Image control, but you could anything here (like new tables, divs, server controls, etc.). For completeness, we'll render our Image control in an HTML div, producing code that looks like this:

C# Copy Code
public void InstantiateIn(Control container)
{
LiteralControl lc1 = new LiteralControl("<div>");
container.Controls.Add(lc1);
Image img = new Image();
img.AlternateText = "RadRotator Demo";
img.Width = Unit.Pixel(350);
img.DataBinding += img_DataBinding;
container.Controls.Add(img);
LiteralControl lc2 = new LiteralControl("</div>");
container.Controls.Add(lc2);
}
VB Copy Code
Public Sub InstantiateIn(ByVal container As System.Web.UI.Control) Implements System.Web.UI.ITemplate.InstantiateIn
Dim lc1 As New LiteralControl("<div>")
container.Controls.Add(lc1)
Dim img As New Image()
img.AlternateText = "RadRotator in SharePoint"
img.Width = Unit.Pixel(350)
AddHandler img.DataBinding, AddressOf img_DataBinding
container.Controls.Add(img)
Dim lc2 As New LiteralControl("</div>")
container.Controls.Add(lc2)
End Sub

Nothing in this code should be too tricky, but the important line to look at in more detail is the DataBinding. Here you define a new EventHandler that will fire whenever the template needs to bind your control to your RadRotator's data source. Every control that you add to your template that needs to be bound to data needs to follow this same approach. The data binding method for this demo will look like this:

C# Copy Code
void img_DataBinding(object sender, EventArgs e)
{
Image img = sender as Image;
RadRotatorFrame frame = img.NamingContainer as RadRotatorFrame;
img.ImageUrl = (string)frame.DataItem;
}
VB Copy Code
Sub img_DataBinding(ByVal sender As Object, ByVal e As EventArgs)
Dim img As Image = TryCast(sender, Image)
Dim frame As RadRotatorFrame = TryCast(img.NamingContainer, RadRotatorFrame)
img.ImageUrl = DirectCast(frame.DataItem, String)
End Sub

Here's where things get a little more specific to RadRotator. Notice in the above code snippet that we have to get a reference to the RadRotatorFrame that contains our data bound Image control. To do that, we reference the Image control's NamingContainer and store it in a local variable. With the reference to the RotatorFrame in hand, we finally have access the the DataItem for the current Rotator frame that we can use to data bind our control. The DataItem type depends entirely on your data source. If your RadRotator data source is an array of strings, the DataItem will be of type String. If the data source is a DataTable, your DataItem type will probably be DataRowView. This is an important thing to keep in mind when working with a Rotator programmatically and databinding to different data source types.

Step 2: Define your RadRotator

Now that you have a programmatic Rotator template defined, the next (and final) step is to define your RadRotator. This is usually done in a page's PageLoad method, but you can do it wherever you're defining the controls that should be rendered at runtime (if it's a WebPart, for instance, this may be the CreateChildControls method). You can define a wide range of properties when you create your Rotator, but for this demo we'll accept most of the control's default settings and focus on the code that is required to data bind our control. In the PageLoad method, we'll add the following code:

C# Copy Code
protected void Page_Load(object sender, EventArgs e)
{
RadRotator rr = new RadRotator();
rr.ID = "RadRotator1";
rr.FrameTemplate = new RadRotatorTemplate();
rr.DataSource = CreateRotatorData();
rr.DataBind();
this.Controls.Add(rr);
}
VB Copy Code
Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
If Not Page.IsPostBack Then
Dim rr As RadRotator = New RadRotator()
rr.ID = "RadRotator1"
rr.FrameTemplate = New RadRotatorTemplate
rr.DataSource = CreateRotatorData()
rr.DataBind()
Me.Controls.Add(rr)
End If
End Sub

You can see that we set the FrameTemplate property to a new instance of our RadRotatorTemplate to define our Rotator's template. If you are binding to a data source that requires dynamic input in the template (such as column names), you can add code the RadRotatorTemplate constructor to accept those values and make them available to the class' data binding methods. In this case, our data binding is simple and we simply create an array of image paths in the "CreateRotatorData" method:

Example Title Copy Code
private ArrayList CreateRotatorData()
{
ArrayList al = new ArrayList();
al.Add(ResolveUrl("~/images/sharePointRt2.png"));
al.Add(ResolveUrl("~/images/sharePointRt1.png"));
return al;
}
VB Copy Code
Private Function CreateRotatorData() As ArrayList
Dim al As New ArrayList()
al.Add(ResolveUrl("~/images/sharePointRt2.png"))
al.Add(ResolveUrl("~/images/sharePointRt1.png"))
Return al
End Function

And that's it! When you run your page, the RadRoator will be displayed and the template area will bind controls in each Rotator frame to your data source. In general, that means one frame will be rendered per "row" (or entry) in your data source.

With this simple example, you should be able to confidently add RadRotators via code anywhere you need them and no longer feel constrained to design-time only solutions. If you want to see another example of creating templates programmatically, check out page 584 in the RadControls Learning Guide. The Learning Guide example binds the Rotator to a DataTable, so it is a good next step if you're comfortable with the code in this demo.

Download demo project in C#
Download demo project in VB

See Also

Defining the Structure from XML File
Defining the Structure through Data Binding

© 2002-2008 Telerik. All Rights Reserved.


Telerik RadRotator on a web page stretches it several pages when printing under IE

Telerik RadRotator v2.7 Send comments on this topic.
Telerik RadRotator on a web page stretches it several pages when printing under IE
Troubleshooting > Telerik RadRotator on a web page stretches it several pages when printing under IE

Glossary Item Box

This problem happens when the the rotator has many frames. It appears that the page count under IE depends on the frame count of the rotator and all frames are placed one after another.

To workaround this problem, use the following css:

Copy Code
<head runat="server">

<style media="print">
#RadRotator1_wrapper
{
position:absolute;
height:125px;
overflow:hidden;
}
</style>

</head>

Also, you need to put the rotator in a relatively positioned div with equal height:

Copy Code
<div style="position:relative;height:125px">
<rad:RadRotator ID="RadRotator1" runat="server" Height="125px" Width="225px" TransitionType="Scroll">
<FrameTemplate>
<img src="http://www.telerik.com/images/banners/<%# Eval("MerchantID") %>.jpg" />
</FrameTemplate>
</rad:RadRotator>
</div>

© 2002-2008 Telerik. All Rights Reserved.


rotator Udefined

Telerik RadRotator v2.7 Send comments on this topic.
rotator Udefined
Troubleshooting > rotator Udefined

Glossary Item Box

Symptoms

Causes and Solutions

Telerik RadRotator cannot find its java script file. The necessary file is fetched either from the WebResource.axd file or from the RadControls folder, depending on the control's settings.

Case 1: UseEmbeddedScripts property of Telerik RadRotator is set to false

In this case Telerik RadRotator will search for its java script file in the RadControls folder:

The following script will be part of the rendered output of the rotator:

Copy Code
<div id="RadRotator1_wrapper">
<!-- 2.5.2 --><script type="text/javascript" src="/WebSite5/RadControls/Rotator/Scripts/2_5_2/RadRotator.js"></script>

If the file is not physically in the location specified by the src property, or there is a version mismatch, or the file is unaccessible, you will experience 'RadRotator' is undefined error. To make sure that this is really the case, you can copy the path to the RadRotator.js file in the browser and see if you have access to this file. If you cannot retrieve this file you will see the following error message:

Enlarge Click to enlarge

The solution is to make sure that the file is intact, its version matches that of the DLL of the control, and it is in the location specified by the src property. If the file is accessible you will be able to view it or download it:

Enlarge Click to enlarge

Case 2: UseEmbeddedScripts property of Telerik RadRotator is set to true (Default case)

In this case Telerik RadRotator will search for its java script file embedded in the WebResource.axd as part of the DLL of the control.

The following script will be part of the rendered output of the rotator:

Copy Code
<div id="RadRotator1_wrapper">
<!-- 2.5.2 --><script type="text/javascript"
src="/WebSite5/WebResource.axd?d=6zLjUgkPuJgpIgqKz5JRIPzwsH8Ke9TrZvO5YQX-
TlOar0qKjKPp2V2J7eVJfoGIIqsMn6Nzwq3x_U_v9BD268NhHZOv7wLYuLtJe2qH5kM1&
t=633082608840000000">
</script>

If you try to view the file from the location specified by the src property, but it is not accessible, you will get the following error:

Enlarge Click to enlarge

The following articles discuss possible causes and solutions of the problem:

  • Troubleshooting WebResource.axd
  • Getting CryptographicException exception "Padding is invalid and cannot be removed" after Migrating to ASP.NET 2.0
  • How To: Configure MachineKey in ASP.NET 2.0

© 2002-2008 Telerik. All Rights Reserved.


The Controls collection cannot be modified because the control contains code blocks (i.e.

Telerik RadRotator v2.7 Send comments on this topic.
The Controls collection cannot be modified because the control contains code blocks (i.e. <% ... %>)
Troubleshooting > The Controls collection cannot be modified because the control contains code blocks (i.e. <% ... %>)

Glossary Item Box

If you receive exceptions such as:

System.Web.HttpException: The Controls collection cannot be modified because the control contains code blocks (i.e. <% ... %>)

you need to move the javascript code block outside of the head tag. For example:

Before: Copy Code
<head runat="server">
<script>
var controlClientObject = <%= RadControl1.ClientID %>
...
</script>
</head>

<body>
...
</body>
After: Copy Code
<head runat=a?servera?>
</head>
<body>
<script>
var controlClientObject = <%= RadControl1.ClientID %>
...
</script>
...
</body>

© 2002-2008 Telerik. All Rights Reserved.


Known Issues

Telerik RadRotator v2.7 Send comments on this topic.
Known Issues
Troubleshooting > Known Issues

Glossary Item Box

RadRotator skips frames when changing scroll direction

The problem can be reproduced in the Scroller online example. This is a well known issue which will be fixed for the next major version of the control.

© 2002-2008 Telerik. All Rights Reserved.


RadRotator Class

RadRotator Send comments on this topic.
RadRotator Class
See Also Members
[image]
Telerik.WebControls Namespace : RadRotator Class

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Class RadRotator
   Inherits RadControl
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
C#
public class RadRotator : RadControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.BaseDataBoundControl
System.Web.UI.WebControls.DataBoundControl
Telerik.RadRotatorUtils.RadControl
Telerik.WebControls.RadRotator

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

RadRotator Members
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotator Class Members

RadRotator Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadRotator Class

The following tables list the members exposed by RadRotator.

Public Constructors

 | Name | Description
Public Constructor | RadRotator Constructor | The default contructor for RadRotator.
Top

Public Properties

 | Name | Description
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoAdvance | Specifies whether RadRotator will advance through its slides automatically.
Public Property | AutoPostBack | Specifies whether the control will require postback event handling.
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ContentFile | The location (path + filename) of the XML content file used to populate the menu.
Public Property | Controls | Overridden. Returns a reference to the controls collection of the RadRotator instance.
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CustomTransitionFilter | Specifies a custom transition effect that overrides the default filter strings used when the TransitionEffect property is set. Use the CustomTransitionFilter propery to fine-tune the DXTransform filters to your liking.
Public Property | DataMember | If databinding to a dataset, this field indicates the table to bind data to.
Public Property | DataSource | Overridden. Specifies or retrieves the data source for the control.
Public Property | DataSourceID | (Inherited from System.Web.UI.WebControls.DataBoundControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | FramesToShow | Specifies how many frames are visible in the rotator.
Public Property | FrameTemplate | This property is used for templating. You should not use this. Try creating <FrameTemplate> tags in the control instead.
Public Property | FrameTimeout | Specifies the frame timeout in ms.
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden. Specifies the height of the RadRotator instance.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | NumberOfFrames | Read only. Gets the number of frames currently instantiated in the rotator.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | PauseOnMouseOver | Specifies whether scrolling or slideshows pause when the user hoovers the mouse cursor over the control.
Public Property | RadControlsDir | (Inherited from Telerik.RadRotatorUtils.RadControl)
Public Property | ScrollDirection | Specifies the direction for the scroller.
Public Property | ScrollSpeed | Specifies the duration of a scroll in ms. The measured time interval is the pause between two sequential scrolls.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SmoothScrollDelay | Specifies a delay for the smoothscroll effect of the RadRotator instance.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | Overridden. Specifies the tooltip that appears when the user moves the mouse over the control.
Public Property | TransitionEffect | Specifies the transition effect for the slideshow mode.
Public Property | TransitionType | Specifies the type of transition. Could be set to either Scroll or Slideshow.
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadRotatorUtils.RadControl)
Public Property | UseRandomSlide | Specifies whether RadRotator will display a random slide when in Slideshow mode.
Public Property | UseSmoothScroll | Specifies whether the RadRotator will use a smoothscroll effect when in Scroll mode.
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden. Specifies the width of the RadRotator instance.
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.WebControls.BaseDataBoundControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overridden. Finds a control inside the control hierarchy.
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | DataBound | (Inherited from System.Web.UI.WebControls.BaseDataBoundControl)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | ItemClicked | This event fires whenever the user performs a mouseclick on the RadRotator instance.
Public Event | ItemDataBound | Occurs after a frame is data bound.
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadRotator Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotator Constructor

RadRotator Constructor
See Also
[image]
Telerik.WebControls Namespace > RadRotator Class : RadRotator Constructor

The default contructor for RadRotator.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadRotator()
C#
public RadRotator()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadRotator()
C#
public RadRotator()

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


RadRotator Class Methods

RadRotator Class Methods
[image]
Telerik.WebControls Namespace : RadRotator Class

For a list of all members of this type, see RadRotator members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.WebControls.BaseDataBoundControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overridden. Finds a control inside the control hierarchy.
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadRotator Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


FindControl Method

FindControl Method
[image]
Telerik.WebControls Namespace > RadRotator Class : FindControl Method

id
The ID of the searched control.
Finds a control inside the control hierarchy.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function FindControl( _
   ByVal id As String _
) As Control
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim id As String
Dim value As Control

value = instance.FindControl(id)
C#
public override Control FindControl(
   string id
)

Parameters

id
The ID of the searched control.

Return Value

Reference to the found control or null if no control was found.

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


RadRotator Class Properties

RadRotator Class Properties
[image]
Telerik.WebControls Namespace : RadRotator Class

For a list of all members of this type, see RadRotator members.

Public Properties

 | Name | Description
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoAdvance | Specifies whether RadRotator will advance through its slides automatically.
Public Property | AutoPostBack | Specifies whether the control will require postback event handling.
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ContentFile | The location (path + filename) of the XML content file used to populate the menu.
Public Property | Controls | Overridden. Returns a reference to the controls collection of the RadRotator instance.
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CustomTransitionFilter | Specifies a custom transition effect that overrides the default filter strings used when the TransitionEffect property is set. Use the CustomTransitionFilter propery to fine-tune the DXTransform filters to your liking.
Public Property | DataMember | If databinding to a dataset, this field indicates the table to bind data to.
Public Property | DataSource | Overridden. Specifies or retrieves the data source for the control.
Public Property | DataSourceID | (Inherited from System.Web.UI.WebControls.DataBoundControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | FramesToShow | Specifies how many frames are visible in the rotator.
Public Property | FrameTemplate | This property is used for templating. You should not use this. Try creating <FrameTemplate> tags in the control instead.
Public Property | FrameTimeout | Specifies the frame timeout in ms.
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden. Specifies the height of the RadRotator instance.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | NumberOfFrames | Read only. Gets the number of frames currently instantiated in the rotator.
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | PauseOnMouseOver | Specifies whether scrolling or slideshows pause when the user hoovers the mouse cursor over the control.
Public Property | RadControlsDir | (Inherited from Telerik.RadRotatorUtils.RadControl)
Public Property | ScrollDirection | Specifies the direction for the scroller.
Public Property | ScrollSpeed | Specifies the duration of a scroll in ms. The measured time interval is the pause between two sequential scrolls.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SmoothScrollDelay | Specifies a delay for the smoothscroll effect of the RadRotator instance.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | Overridden. Specifies the tooltip that appears when the user moves the mouse over the control.
Public Property | TransitionEffect | Specifies the transition effect for the slideshow mode.
Public Property | TransitionType | Specifies the type of transition. Could be set to either Scroll or Slideshow.
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadRotatorUtils.RadControl)
Public Property | UseRandomSlide | Specifies whether RadRotator will display a random slide when in Slideshow mode.
Public Property | UseSmoothScroll | Specifies whether the RadRotator will use a smoothscroll effect when in Scroll mode.
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden. Specifies the width of the RadRotator instance.
Top

See Also

Reference

RadRotator Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


AutoAdvance Property

AutoAdvance Property
[image]
Telerik.WebControls Namespace > RadRotator Class : AutoAdvance Property

Specifies whether RadRotator will advance through its slides automatically.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoAdvance As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Boolean

instance.AutoAdvance = value

value = instance.AutoAdvance
C#
public bool AutoAdvance {get; set;}

Return Value

Default: True

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


AutoPostBack Property

AutoPostBack Property
[image]
Telerik.WebControls Namespace > RadRotator Class : AutoPostBack Property

Specifies whether the control will require postback event handling.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoPostBack As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Boolean

instance.AutoPostBack = value

value = instance.AutoPostBack
C#
public bool AutoPostBack {get; set;}

Return Value

Default: False

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


ContentFile Property

ContentFile Property
[image]
Telerik.WebControls Namespace > RadRotator Class : ContentFile Property

The location (path + filename) of the XML content file used to populate the menu.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property ContentFile As String
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As String

instance.ContentFile = value

value = instance.ContentFile
C#
public string ContentFile {get; set;}

Return Value

Default: string.Empty

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


Controls Property

Controls Property
[image]
Telerik.WebControls Namespace > RadRotator Class : Controls Property

Returns a reference to the controls collection of the RadRotator instance.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Controls As ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As ControlCollection

value = instance.Controls
C#
public override ControlCollection Controls {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


CustomTransitionFilter Property

CustomTransitionFilter Property
[image]
Telerik.WebControls Namespace > RadRotator Class : CustomTransitionFilter Property

Specifies a custom transition effect that overrides the default filter strings used when the TransitionEffect property is set. Use the CustomTransitionFilter propery to fine-tune the DXTransform filters to your liking.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomTransitionFilter As String
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As String

instance.CustomTransitionFilter = value

value = instance.CustomTransitionFilter
C#
public string CustomTransitionFilter {get; set;}

Return Value

Default: string.Empty

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


DataMember Property

DataMember Property
[image]
Telerik.WebControls Namespace > RadRotator Class : DataMember Property

If databinding to a dataset, this field indicates the table to bind data to.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
public string DataMember {get; set;}

Return Value

Default: string.Empty

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


DataSource Property

DataSource Property
[image]
Telerik.WebControls Namespace > RadRotator Class : DataSource Property

Specifies or retrieves the data source for the control.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
public override object DataSource {get; set;}

Return Value

Default: string.Empty

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


FramesToShow Property

FramesToShow Property
[image]
Telerik.WebControls Namespace > RadRotator Class : FramesToShow Property

Specifies how many frames are visible in the rotator.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property FramesToShow As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Integer

instance.FramesToShow = value

value = instance.FramesToShow
C#
public int FramesToShow {get; set;}

Return Value

Default: 1

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


FrameTemplate Property

FrameTemplate Property
[image]
Telerik.WebControls Namespace > RadRotator Class : FrameTemplate Property

This property is used for templating. You should not use this. Try creating <FrameTemplate> tags in the control instead.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property FrameTemplate As ITemplate
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As ITemplate

instance.FrameTemplate = value

value = instance.FrameTemplate
C#
public ITemplate FrameTemplate {get; set;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


FrameTimeout Property

FrameTimeout Property
[image]
Telerik.WebControls Namespace > RadRotator Class : FrameTimeout Property

Specifies the frame timeout in ms.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property FrameTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Integer

instance.FrameTimeout = value

value = instance.FrameTimeout
C#
public int FrameTimeout {get; set;}

Return Value

Default: 4000ms

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


Height Property

Height Property
[image]
Telerik.WebControls Namespace > RadRotator Class : Height Property

Specifies the height of the RadRotator instance.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public override Unit Height {get; set;}

Return Value

Default: Unit.Pixel(100)

Remarks

The RadRotator control has a default size of 100px (height) and 300px (width). If you don't set the height and width properties they will persist their defualt values. Having a default value in pixels provides a work-around to a well known Internet Explorer issue that DXTransform effects fails for objects that have relative or no size.

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


NumberOfFrames Property

NumberOfFrames Property
[image]
Telerik.WebControls Namespace > RadRotator Class : NumberOfFrames Property

Read only. Gets the number of frames currently instantiated in the rotator.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NumberOfFrames As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Integer

value = instance.NumberOfFrames
C#
public int NumberOfFrames {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


PauseOnMouseOver Property

PauseOnMouseOver Property
[image]
Telerik.WebControls Namespace > RadRotator Class : PauseOnMouseOver Property

Specifies whether scrolling or slideshows pause when the user hoovers the mouse cursor over the control.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property PauseOnMouseOver As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Boolean

instance.PauseOnMouseOver = value

value = instance.PauseOnMouseOver
C#
public bool PauseOnMouseOver {get; set;}

Return Value

Default: True

Remarks

Currently, when RadRotator is in SlideShow mode, this feature only works on Microsoft Internet Explorer

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


ScrollDirection Property

ScrollDirection Property
[image]
Telerik.WebControls Namespace > RadRotator Class : ScrollDirection Property

Specifies the direction for the scroller.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property ScrollDirection As RadRotator.RotatorScrollDirection
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As RadRotator.RotatorScrollDirection

instance.ScrollDirection = value

value = instance.ScrollDirection
C#
public RadRotator.RotatorScrollDirection ScrollDirection {get; set;}

Return Value

Default: RotatorScrollDirection.Up

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members
RadRotator.RotatorScrollDirection Enumeration


ScrollSpeed Property

ScrollSpeed Property
[image]
Telerik.WebControls Namespace > RadRotator Class : ScrollSpeed Property

Specifies the duration of a scroll in ms. The measured time interval is the pause between two sequential scrolls.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property ScrollSpeed As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Integer

instance.ScrollSpeed = value

value = instance.ScrollSpeed
C#
public int ScrollSpeed {get; set;}

Return Value

Default: 10ms

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


SmoothScrollDelay Property

SmoothScrollDelay Property
[image]
Telerik.WebControls Namespace > RadRotator Class : SmoothScrollDelay Property

Specifies a delay for the smoothscroll effect of the RadRotator instance.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property SmoothScrollDelay As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Integer

instance.SmoothScrollDelay = value

value = instance.SmoothScrollDelay
C#
public int SmoothScrollDelay {get; set;}

Return Value

Default: 10

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


ToolTip Property

ToolTip Property
[image]
Telerik.WebControls Namespace > RadRotator Class : ToolTip Property

Specifies the tooltip that appears when the user moves the mouse over the control.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public override string ToolTip {get; set;}

Return Value

Default: string.Empty

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


TransitionEffect Property

TransitionEffect Property
[image]
Telerik.WebControls Namespace > RadRotator Class : TransitionEffect Property

Specifies the transition effect for the slideshow mode.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property TransitionEffect As RadRotator.RotatorTransitionEffect
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As RadRotator.RotatorTransitionEffect

instance.TransitionEffect = value

value = instance.TransitionEffect
C#
public RadRotator.RotatorTransitionEffect TransitionEffect {get; set;}

Return Value

Default: RotatorTransitionEffect.NONE

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members
RadRotator.RotatorTransitionEffect Enumeration


TransitionType Property

TransitionType Property
[image]
Telerik.WebControls Namespace > RadRotator Class : TransitionType Property

Specifies the type of transition. Could be set to either Scroll or Slideshow.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property TransitionType As RadRotator.RotatorTransitionType
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As RadRotator.RotatorTransitionType

instance.TransitionType = value

value = instance.TransitionType
C#
public RadRotator.RotatorTransitionType TransitionType {get; set;}

Return Value

Default: RotatorTransitionType.Slideshow

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members
RadRotator.RotatorTransitionType Enumeration


UseRandomSlide Property

UseRandomSlide Property
[image]
Telerik.WebControls Namespace > RadRotator Class : UseRandomSlide Property

Specifies whether RadRotator will display a random slide when in Slideshow mode.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property UseRandomSlide As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Boolean

instance.UseRandomSlide = value

value = instance.UseRandomSlide
C#
public bool UseRandomSlide {get; set;}

Return Value

Default: False

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


UseSmoothScroll Property

UseSmoothScroll Property
[image]
Telerik.WebControls Namespace > RadRotator Class : UseSmoothScroll Property

Specifies whether the RadRotator will use a smoothscroll effect when in Scroll mode.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property UseSmoothScroll As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Boolean

instance.UseSmoothScroll = value

value = instance.UseSmoothScroll
C#
public bool UseSmoothScroll {get; set;}

Return Value

Default: True

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


Width Property

Width Property
[image]
Telerik.WebControls Namespace > RadRotator Class : Width Property

Specifies the width of the RadRotator instance.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public override Unit Width {get; set;}

Return Value

Default: Unit.Pixel(300)

Remarks

The RadRotator control has a default size of 100px (height) and 300px (width). If you don't set the height and width properties they will persist their defualt values. Having a default value in pixels provides a work-around to a well known Internet Explorer issue that DXTransform effects fails for objects that have relative or no size.

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


RadRotator Class Events

RadRotator Class Events
[image]
Telerik.WebControls Namespace : RadRotator Class

For a list of all members of this type, see RadRotator members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | DataBound | (Inherited from System.Web.UI.WebControls.BaseDataBoundControl)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | ItemClicked | This event fires whenever the user performs a mouseclick on the RadRotator instance.
Public Event | ItemDataBound | Occurs after a frame is data bound.
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadRotator Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


ItemClicked Event

ItemClicked Event
[image]
Telerik.WebControls Namespace > RadRotator Class : ItemClicked Event

This event fires whenever the user performs a mouseclick on the RadRotator instance.

Event Data

The event handler receives an argument of type RadRotatorClickEventArgs containing data related to this event. The following RadRotatorClickEventArgs properties provide information specific to this event.

Property | Description
Item | This property exposes a reference to the RadRotatorFrame which raised the event.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Event ItemClicked() As RadRotator.RadRotatorClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim handler As RadRotator.RadRotatorClickEventHandler

AddHandler instance.ItemClicked, handler
C#
public event RadRotator.RadRotatorClickEventHandler ItemClicked()

Syntax

Visual Basic (Declaration)
Public Event ItemClicked() As RadRotator.RadRotatorClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim handler As RadRotator.RadRotatorClickEventHandler

AddHandler instance.ItemClicked, handler
C#
public event RadRotator.RadRotatorClickEventHandler ItemClicked()

Event Data

The event handler receives an argument of type RadRotatorClickEventArgs containing data related to this event. The following RadRotatorClickEventArgs properties provide information specific to this event.

Property | Description
Item | This property exposes a reference to the RadRotatorFrame which raised the event.

Remarks

You should set the AutoPostBack property to true in order for this event to work.

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members
RadRotator.RadRotatorClickEventHandler Delegate


ItemDataBound Event

ItemDataBound Event
See Also Example
[image]
Telerik.WebControls Namespace > RadRotator Class : ItemDataBound Event

Occurs after a frame is data bound.

Example

The following example demonstrates how to use the ItemDataBound event.

Event Data

The event handler receives an argument of type RadRotatorItemEventArgs containing data related to this event. The following RadRotatorItemEventArgs properties provide information specific to this event.

Property | Description
Item |

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Event ItemDataBound() As RadRotator.RadRotatorItemEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim handler As RadRotator.RadRotatorItemEventHandler

AddHandler instance.ItemDataBound, handler
C#
public event RadRotator.RadRotatorItemEventHandler ItemDataBound()

Syntax

Visual Basic (Declaration)
Public Event ItemDataBound() As RadRotator.RadRotatorItemEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim handler As RadRotator.RadRotatorItemEventHandler

AddHandler instance.ItemDataBound, handler
C#
public event RadRotator.RadRotatorItemEventHandler ItemDataBound()

Event Data

The event handler receives an argument of type RadRotatorItemEventArgs containing data related to this event. The following RadRotatorItemEventArgs properties provide information specific to this event.

Property | Description
Item |

Example

The following example demonstrates how to use the ItemDataBound event.
C# Copy Code
protected void RadRotator1_ItemDataBound(object sender, Telerik.WebControls.RadRotatorItemEventArgs e)
{
   TextBox textBox = (TextBox)e.Item.FindControl("TextBox1");
   textBox.Text = (string)DataBinder.Eval(e.Item.DataItem, "Text");
}

Visual Basic Copy Code
Protected Sub RadRotator1_ItemDataBound(ByVal sender As Object, ByVal e As Telerik.WebControls.RadRotatorItemEventArgs) Handles RadRotator1.ItemDataBound
    Dim textBox As TextBox = e.Item.FindControl("TextBox1")
    textBox.Text = CStr(DataBinder.Eval(e.Item.DataItem, "Text"))
End Sub

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


RadRotator.DummyDataSource Class

RadRotator.DummyDataSource Class
See Also Members
[image]
Telerik.WebControls Namespace : RadRotator.DummyDataSource Class

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Private NotInheritable Class RadRotator.DummyDataSource
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.DummyDataSource
C#
private sealed class RadRotator.DummyDataSource

Inheritance Hierarchy

System.Object
Telerik.WebControls.RadRotator.DummyDataSource

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

RadRotator.DummyDataSource Members
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotator.DummyDataSource Class Members

RadRotator.DummyDataSource Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : RadRotator.DummyDataSource Class

The following tables list the members exposed by RadRotator.DummyDataSource.

Public Constructors

 | Name | Description
Public Constructor | RadRotator.DummyDataSource Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | IsSynchronized |
Public Property | SyncRoot |
Top

Public Methods

 | Name | Description
Public Method | CopyTo |
Public Method | GetEnumerator |
Top

See Also

Reference

RadRotator.DummyDataSource Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotator.DummyDataSource Constructor

RadRotator.DummyDataSource Constructor
[image]
Telerik.WebControls Namespace > RadRotator.DummyDataSource Class : RadRotator.DummyDataSource Constructor

dataItemCount

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataItemCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim dataItemCount As Integer

Dim instance As RadRotator.DummyDataSource(dataItemCount)
C#
public RadRotator.DummyDataSource(
   int dataItemCount
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataItemCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim dataItemCount As Integer

Dim instance As RadRotator.DummyDataSource(dataItemCount)
C#
public RadRotator.DummyDataSource(
   int dataItemCount
)

Parameters

dataItemCount

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator.DummyDataSource Class
RadRotator.DummyDataSource Members

© 2002-2006, telerik. All Rights Reserved.


RadRotator.DummyDataSource Class Methods

RadRotator.DummyDataSource Class Methods
[image]
Telerik.WebControls Namespace : RadRotator.DummyDataSource Class

For a list of all members of this type, see RadRotator.DummyDataSource members.

Public Methods

 | Name | Description
Public Method | CopyTo |
Public Method | GetEnumerator |
Top

See Also

Reference

RadRotator.DummyDataSource Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


CopyTo Method

CopyTo Method
[image]
Telerik.WebControls Namespace > RadRotator.DummyDataSource Class : CopyTo Method

array
index

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.DummyDataSource
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array
index

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator.DummyDataSource Class
RadRotator.DummyDataSource Members

© 2002-2006, telerik. All Rights Reserved.


GetEnumerator Method

GetEnumerator Method
[image]
Telerik.WebControls Namespace > RadRotator.DummyDataSource Class : GetEnumerator Method

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.DummyDataSource
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator.DummyDataSource Class
RadRotator.DummyDataSource Members

© 2002-2006, telerik. All Rights Reserved.


RadRotator.DummyDataSource Class Properties

RadRotator.DummyDataSource Class Properties
[image]
Telerik.WebControls Namespace : RadRotator.DummyDataSource Class

For a list of all members of this type, see RadRotator.DummyDataSource members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | IsSynchronized |
Public Property | SyncRoot |
Top

See Also

Reference

RadRotator.DummyDataSource Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


Count Property

Count Property
[image]
Telerik.WebControls Namespace > RadRotator.DummyDataSource Class : Count Property

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.DummyDataSource
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator.DummyDataSource Class
RadRotator.DummyDataSource Members

© 2002-2006, telerik. All Rights Reserved.


IsReadOnly Property

IsReadOnly Property
[image]
Telerik.WebControls Namespace > RadRotator.DummyDataSource Class : IsReadOnly Property

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.DummyDataSource
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator.DummyDataSource Class
RadRotator.DummyDataSource Members

© 2002-2006, telerik. All Rights Reserved.


IsSynchronized Property

IsSynchronized Property
[image]
Telerik.WebControls Namespace > RadRotator.DummyDataSource Class : IsSynchronized Property

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.DummyDataSource
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator.DummyDataSource Class
RadRotator.DummyDataSource Members

© 2002-2006, telerik. All Rights Reserved.


SyncRoot Property

SyncRoot Property
[image]
Telerik.WebControls Namespace > RadRotator.DummyDataSource Class : SyncRoot Property

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.DummyDataSource
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator.DummyDataSource Class
RadRotator.DummyDataSource Members

© 2002-2006, telerik. All Rights Reserved.


RadRotator.DummyDataSource.DummyDataSourceEnumerator Class

RadRotator.DummyDataSource.DummyDataSourceEnumerator Class
See Also Members
[image]
Telerik.WebControls Namespace : RadRotator.DummyDataSource.DummyDataSourceEnumerator Class

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Private Class RadRotator.DummyDataSource.DummyDataSourceEnumerator
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.DummyDataSource.DummyDataSourceEnumerator
C#
private class RadRotator.DummyDataSource.DummyDataSourceEnumerator

Inheritance Hierarchy

System.Object
Telerik.WebControls.RadRotator.DummyDataSource.DummyDataSourceEnumerator

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

RadRotator.DummyDataSource.DummyDataSourceEnumerator Members
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotator.DummyDataSource.DummyDataSourceEnumerator Class Members

RadRotator.DummyDataSource.DummyDataSourceEnumerator Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : RadRotator.DummyDataSource.DummyDataSourceEnumerator Class

The following tables list the members exposed by RadRotator.DummyDataSource.DummyDataSourceEnumerator.

Public Constructors

 | Name | Description
Public Constructor | RadRotator.DummyDataSource.DummyDataSourceEnumerator Constructor |
Top

Public Properties

 | Name | Description
Public Property | Current |
Top

Public Methods

 | Name | Description
Public Method | MoveNext |
Public Method | Reset |
Top

See Also

Reference

RadRotator.DummyDataSource.DummyDataSourceEnumerator Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotator.DummyDataSource.DummyDataSourceEnumerator Constructor

RadRotator.DummyDataSource.DummyDataSourceEnumerator Constructor
See Also
[image]
Telerik.WebControls Namespace > RadRotator.DummyDataSource.DummyDataSourceEnumerator Class : RadRotator.DummyDataSource.DummyDataSourceEnumerator Constructor

count

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim count As Integer

Dim instance As RadRotator.DummyDataSource.DummyDataSourceEnumerator(count)
C#
public RadRotator.DummyDataSource.DummyDataSourceEnumerator(
   int count
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim count As Integer

Dim instance As RadRotator.DummyDataSource.DummyDataSourceEnumerator(count)
C#
public RadRotator.DummyDataSource.DummyDataSourceEnumerator(
   int count
)

Parameters

count

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator.DummyDataSource.DummyDataSourceEnumerator Class
RadRotator.DummyDataSource.DummyDataSourceEnumerator Members


RadRotator.DummyDataSource.DummyDataSourceEnumerator Class Methods

RadRotator.DummyDataSource.DummyDataSourceEnumerator Class Methods
See Also
[image]
Telerik.WebControls Namespace : RadRotator.DummyDataSource.DummyDataSourceEnumerator Class

For a list of all members of this type, see RadRotator.DummyDataSource.DummyDataSourceEnumerator members.

Public Methods

 | Name | Description
Public Method | MoveNext |
Public Method | Reset |
Top

See Also

Reference

RadRotator.DummyDataSource.DummyDataSourceEnumerator Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


MoveNext Method

MoveNext Method
[image]
Telerik.WebControls Namespace > RadRotator.DummyDataSource.DummyDataSourceEnumerator Class : MoveNext Method

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.DummyDataSource.DummyDataSourceEnumerator
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator.DummyDataSource.DummyDataSourceEnumerator Class
RadRotator.DummyDataSource.DummyDataSourceEnumerator Members


Reset Method

Reset Method
[image]
Telerik.WebControls Namespace > RadRotator.DummyDataSource.DummyDataSourceEnumerator Class : Reset Method

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.DummyDataSource.DummyDataSourceEnumerator

instance.Reset()
C#
public void Reset()

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator.DummyDataSource.DummyDataSourceEnumerator Class
RadRotator.DummyDataSource.DummyDataSourceEnumerator Members


RadRotator.DummyDataSource.DummyDataSourceEnumerator Class Properties

RadRotator.DummyDataSource.DummyDataSourceEnumerator Class Properties
See Also
[image]
Telerik.WebControls Namespace : RadRotator.DummyDataSource.DummyDataSourceEnumerator Class

For a list of all members of this type, see RadRotator.DummyDataSource.DummyDataSourceEnumerator members.

Public Properties

 | Name | Description
Public Property | Current |
Top

See Also

Reference

RadRotator.DummyDataSource.DummyDataSourceEnumerator Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


Current Property

Current Property
[image]
Telerik.WebControls Namespace > RadRotator.DummyDataSource.DummyDataSourceEnumerator Class : Current Property

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.DummyDataSource.DummyDataSourceEnumerator
Dim value As Object

value = instance.Current
C#
public object Current {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator.DummyDataSource.DummyDataSourceEnumerator Class
RadRotator.DummyDataSource.DummyDataSourceEnumerator Members


RadRotatorClickEventArgs Class

RadRotatorClickEventArgs Class
See Also Members
[image]
Telerik.WebControls Namespace : RadRotatorClickEventArgs Class

This is a container class which inherits System.EventArgs and provides functionality specific to RadRotator

Object Model

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Class RadRotatorClickEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorClickEventArgs
C#
public class RadRotatorClickEventArgs : EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.WebControls.RadRotatorClickEventArgs

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

RadRotatorClickEventArgs Members
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotatorClickEventArgs Class Members

RadRotatorClickEventArgs Class Members
See Also Properties
[image]
Telerik.WebControls Namespace : RadRotatorClickEventArgs Class

The following tables list the members exposed by RadRotatorClickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | RadRotatorClickEventArgs Constructor | Default Constructor of RadRotatorClickEventArgs As a developer using RadRotator you do not need to ever worry about this constructor.
Top

Public Properties

 | Name | Description
Public Property | Item | This property exposes a reference to the RadRotatorFrame which raised the event.
Top

See Also

Reference

RadRotatorClickEventArgs Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotatorClickEventArgs Constructor

RadRotatorClickEventArgs Constructor
[image]
Telerik.WebControls Namespace > RadRotatorClickEventArgs Class : RadRotatorClickEventArgs Constructor

_item
The instance of the RadRotatorFrame from which the event originated
Default Constructor of RadRotatorClickEventArgs As a developer using RadRotator you do not need to ever worry about this constructor.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal _item As RadRotatorFrame _
)
Visual Basic (Usage) Copy Code
Dim _item As RadRotatorFrame

Dim instance As RadRotatorClickEventArgs(_item)
C#
public RadRotatorClickEventArgs(
   RadRotatorFrame _item
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal _item As RadRotatorFrame _
)
Visual Basic (Usage) Copy Code
Dim _item As RadRotatorFrame

Dim instance As RadRotatorClickEventArgs(_item)
C#
public RadRotatorClickEventArgs(
   RadRotatorFrame _item
)

Parameters

_item
The instance of the RadRotatorFrame from which the event originated

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorClickEventArgs Class
RadRotatorClickEventArgs Members

© 2002-2006, telerik. All Rights Reserved.


RadRotatorClickEventArgs Class Properties

RadRotatorClickEventArgs Class Properties
[image]
Telerik.WebControls Namespace : RadRotatorClickEventArgs Class

For a list of all members of this type, see RadRotatorClickEventArgs members.

Public Properties

 | Name | Description
Public Property | Item | This property exposes a reference to the RadRotatorFrame which raised the event.
Top

See Also

Reference

RadRotatorClickEventArgs Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


Item Property

Item Property
[image]
Telerik.WebControls Namespace > RadRotatorClickEventArgs Class : Item Property

This property exposes a reference to the RadRotatorFrame which raised the event.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Item As RadRotatorFrame
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorClickEventArgs
Dim value As RadRotatorFrame

value = instance.Item
C#
public RadRotatorFrame Item {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorClickEventArgs Class
RadRotatorClickEventArgs Members

© 2002-2006, telerik. All Rights Reserved.


RadRotatorFrame Class

RadRotatorFrame Class
See Also Members
[image]
Telerik.WebControls Namespace : RadRotatorFrame Class

This class represents a RadRotator frame.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Class RadRotatorFrame
   Inherits Control
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrame
C#
public class RadRotatorFrame : Control

Inheritance Hierarchy

System.Object
System.Web.UI.Control
Telerik.WebControls.RadRotatorFrame

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

RadRotatorFrame Members
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotatorFrame Class Members

RadRotatorFrame Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadRotatorFrame Class

The following tables list the members exposed by RadRotatorFrame.

Public Constructors

 | Name | Description
Public Constructor | RadRotatorFrame Constructor | Overloaded. Default constructor of RadRotatorFrame
Top

Public Properties

 | Name | Description
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | DataItem | Retrieves or specifies the data item of the RadRotatorFrame Class.
Public Property | EnableTheming | (Inherited from System.Web.UI.Control)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ItemIndex | Retrieves or specifies the index of the frame.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.Control)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadRotatorFrame Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotatorFrame Constructor

RadRotatorFrame Constructor
[image]
Telerik.WebControls Namespace > RadRotatorFrame Class : RadRotatorFrame Constructor

Default constructor of RadRotatorFrame

Overload List

Overload | Description
RadRotatorFrame Constructor() | Default constructor of RadRotatorFrame

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorFrame Class
RadRotatorFrame Members

© 2002-2006, telerik. All Rights Reserved.


RadRotatorFrame Constructor()

RadRotatorFrame Constructor()
See Also
[image]
Telerik.WebControls Namespace > RadRotatorFrame Class > RadRotatorFrame Constructor : RadRotatorFrame Constructor()

Default constructor of RadRotatorFrame

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrame()
C#
public RadRotatorFrame()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrame()
C#
public RadRotatorFrame()

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorFrame Class
RadRotatorFrame Members
Overload List

© 2002-2006, telerik. All Rights Reserved.


RadRotatorFrame Class Properties

RadRotatorFrame Class Properties
[image]
Telerik.WebControls Namespace : RadRotatorFrame Class

For a list of all members of this type, see RadRotatorFrame members.

Public Properties

 | Name | Description
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | DataItem | Retrieves or specifies the data item of the RadRotatorFrame Class.
Public Property | EnableTheming | (Inherited from System.Web.UI.Control)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ItemIndex | Retrieves or specifies the index of the frame.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.Control)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadRotatorFrame Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


DataItem Property

DataItem Property
[image]
Telerik.WebControls Namespace > RadRotatorFrame Class : DataItem Property

Retrieves or specifies the data item of the RadRotatorFrame Class.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataItem As Object
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrame
Dim value As Object

value = instance.DataItem
C#
public object DataItem {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorFrame Class
RadRotatorFrame Members

© 2002-2006, telerik. All Rights Reserved.


ItemIndex Property

ItemIndex Property
[image]
Telerik.WebControls Namespace > RadRotatorFrame Class : ItemIndex Property

Retrieves or specifies the index of the frame.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrame
Dim value As Integer

value = instance.ItemIndex
C#
public int ItemIndex {get;}

Remarks

Please, only use this property to get the item index.

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorFrame Class
RadRotatorFrame Members

© 2002-2006, telerik. All Rights Reserved.


RadRotatorFrameCollection Class

RadRotatorFrameCollection Class
See Also Members
[image]
Telerik.WebControls Namespace : RadRotatorFrameCollection Class

Object Model

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Class RadRotatorFrameCollection
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrameCollection
C#
public class RadRotatorFrameCollection

Inheritance Hierarchy

System.Object
Telerik.WebControls.RadRotatorFrameCollection

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

RadRotatorFrameCollection Members
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotatorFrameCollection Class Members

RadRotatorFrameCollection Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : RadRotatorFrameCollection Class

The following tables list the members exposed by RadRotatorFrameCollection.

Public Constructors

 | Name | Description
Public Constructor | RadRotatorFrameCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | IsSynchronized |
Public Property | Item |
Public Property | SyncRoot |
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | CopyTo |
Public Method | GetEnumerator |
Top

See Also

Reference

RadRotatorFrameCollection Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotatorFrameCollection Constructor

RadRotatorFrameCollection Constructor
[image]
Telerik.WebControls Namespace > RadRotatorFrameCollection Class : RadRotatorFrameCollection Constructor

items

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items As ArrayList _
)
Visual Basic (Usage) Copy Code
Dim items As ArrayList

Dim instance As RadRotatorFrameCollection(items)
C#
public RadRotatorFrameCollection(
   ArrayList items
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items As ArrayList _
)
Visual Basic (Usage) Copy Code
Dim items As ArrayList

Dim instance As RadRotatorFrameCollection(items)
C#
public RadRotatorFrameCollection(
   ArrayList items
)

Parameters

items

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorFrameCollection Class
RadRotatorFrameCollection Members

© 2002-2006, telerik. All Rights Reserved.


RadRotatorFrameCollection Class Methods

RadRotatorFrameCollection Class Methods
[image]
Telerik.WebControls Namespace : RadRotatorFrameCollection Class

For a list of all members of this type, see RadRotatorFrameCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | CopyTo |
Public Method | GetEnumerator |
Top

See Also

Reference

RadRotatorFrameCollection Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


Add Method

Add Method
[image]
Telerik.WebControls Namespace > RadRotatorFrameCollection Class : Add Method

item

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As RadRotatorFrame _
)
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrameCollection
Dim item As RadRotatorFrame

instance.Add(item)
C#
public void Add(
   RadRotatorFrame item
)

Parameters

item

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorFrameCollection Class
RadRotatorFrameCollection Members

© 2002-2006, telerik. All Rights Reserved.


CopyTo Method

CopyTo Method
[image]
Telerik.WebControls Namespace > RadRotatorFrameCollection Class : CopyTo Method

array
index

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrameCollection
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array
index

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorFrameCollection Class
RadRotatorFrameCollection Members

© 2002-2006, telerik. All Rights Reserved.


GetEnumerator Method

GetEnumerator Method
[image]
Telerik.WebControls Namespace > RadRotatorFrameCollection Class : GetEnumerator Method

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrameCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorFrameCollection Class
RadRotatorFrameCollection Members

© 2002-2006, telerik. All Rights Reserved.


RadRotatorFrameCollection Class Properties

RadRotatorFrameCollection Class Properties
[image]
Telerik.WebControls Namespace : RadRotatorFrameCollection Class

For a list of all members of this type, see RadRotatorFrameCollection members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | IsSynchronized |
Public Property | Item |
Public Property | SyncRoot |
Top

See Also

Reference

RadRotatorFrameCollection Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


Count Property

Count Property
[image]
Telerik.WebControls Namespace > RadRotatorFrameCollection Class : Count Property

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrameCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorFrameCollection Class
RadRotatorFrameCollection Members

© 2002-2006, telerik. All Rights Reserved.


IsReadOnly Property

IsReadOnly Property
[image]
Telerik.WebControls Namespace > RadRotatorFrameCollection Class : IsReadOnly Property

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrameCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorFrameCollection Class
RadRotatorFrameCollection Members

© 2002-2006, telerik. All Rights Reserved.


IsSynchronized Property

IsSynchronized Property
[image]
Telerik.WebControls Namespace > RadRotatorFrameCollection Class : IsSynchronized Property

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrameCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorFrameCollection Class
RadRotatorFrameCollection Members

© 2002-2006, telerik. All Rights Reserved.


Item Property

Item Property
[image]
Telerik.WebControls Namespace > RadRotatorFrameCollection Class : Item Property

index

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As RadRotatorFrame
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrameCollection
Dim index As Integer
Dim value As RadRotatorFrame

value = instance.Item(index)
C#
public RadRotatorFrame this[
   int index
]; {get;}

Parameters

index

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorFrameCollection Class
RadRotatorFrameCollection Members

© 2002-2006, telerik. All Rights Reserved.


SyncRoot Property

SyncRoot Property
[image]
Telerik.WebControls Namespace > RadRotatorFrameCollection Class : SyncRoot Property

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorFrameCollection
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorFrameCollection Class
RadRotatorFrameCollection Members

© 2002-2006, telerik. All Rights Reserved.


RadRotatorItemEventArgs Class

RadRotatorItemEventArgs Class
See Also Members
[image]
Telerik.WebControls Namespace : RadRotatorItemEventArgs Class

Object Model

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Class RadRotatorItemEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorItemEventArgs
C#
public class RadRotatorItemEventArgs : EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.WebControls.RadRotatorItemEventArgs

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

RadRotatorItemEventArgs Members
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotatorItemEventArgs Class Members

RadRotatorItemEventArgs Class Members
See Also Properties
[image]
Telerik.WebControls Namespace : RadRotatorItemEventArgs Class

The following tables list the members exposed by RadRotatorItemEventArgs.

Public Constructors

 | Name | Description
Public Constructor | RadRotatorItemEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

RadRotatorItemEventArgs Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotatorItemEventArgs Constructor

RadRotatorItemEventArgs Constructor
[image]
Telerik.WebControls Namespace > RadRotatorItemEventArgs Class : RadRotatorItemEventArgs Constructor

item

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal item As RadRotatorFrame _
)
Visual Basic (Usage) Copy Code
Dim item As RadRotatorFrame

Dim instance As RadRotatorItemEventArgs(item)
C#
public RadRotatorItemEventArgs(
   RadRotatorFrame item
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal item As RadRotatorFrame _
)
Visual Basic (Usage) Copy Code
Dim item As RadRotatorFrame

Dim instance As RadRotatorItemEventArgs(item)
C#
public RadRotatorItemEventArgs(
   RadRotatorFrame item
)

Parameters

item

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorItemEventArgs Class
RadRotatorItemEventArgs Members

© 2002-2006, telerik. All Rights Reserved.


RadRotatorItemEventArgs Class Properties

RadRotatorItemEventArgs Class Properties
[image]
Telerik.WebControls Namespace : RadRotatorItemEventArgs Class

For a list of all members of this type, see RadRotatorItemEventArgs members.

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

RadRotatorItemEventArgs Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


Item Property

Item Property
[image]
Telerik.WebControls Namespace > RadRotatorItemEventArgs Class : Item Property

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Item As RadRotatorFrame
Visual Basic (Usage) Copy Code
Dim instance As RadRotatorItemEventArgs
Dim value As RadRotatorFrame

value = instance.Item
C#
public RadRotatorFrame Item {get;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotatorItemEventArgs Class
RadRotatorItemEventArgs Members

© 2002-2006, telerik. All Rights Reserved.


RadTicker Class

RadTicker Class
See Also Members
[image]
Telerik.WebControls Namespace : RadTicker Class

RadTicker v2.1

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Class RadTicker
   Inherits RadControl
Visual Basic (Usage) Copy Code
Dim instance As RadTicker
C#
public class RadTicker : RadControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.BaseDataBoundControl
System.Web.UI.WebControls.DataBoundControl
Telerik.RadRotatorUtils.RadControl
Telerik.WebControls.RadTicker

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

RadTicker Members
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadTicker Class Members

RadTicker Class Members
See Also Properties Methods Events
[image]
Telerik.WebControls Namespace : RadTicker Class

The following tables list the members exposed by RadTicker.

Public Constructors

 | Name | Description
Public Constructor | RadTicker Constructor |
Top

Public Properties

 | Name | Description
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoAdvance | Specifies whether RadTicker will begin ticking the next tickerline (if any) after it has finished ticking the current one.
Public Property | AutoStart | Specifies whether the ticker begins ticking automatically.
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Overridden. The CSS Class name applied to the ticker.
Public Property | DataMember | (Inherited from System.Web.UI.WebControls.DataBoundControl)
Public Property | DataSource | (Inherited from System.Web.UI.WebControls.BaseDataBoundControl)
Public Property | DataSourceID | (Inherited from System.Web.UI.WebControls.DataBoundControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | LineDuration | Specifies in milliseconds the pause RadTicker makes before starting to tick the next line (if AutoAdvance=True).
Public Property | Loop | Specifies whether RadTicker will repeat the first tickerline after displaying the last one.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadRotatorUtils.RadControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | TickSpeed | Specifies the duration in milliseconds between ticking each character of a tickerline. The lower the value the faster a line will finish ticking.
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadRotatorUtils.RadControl)
Public Property | UserTickerLines | Allows the user to add tickerlines programmatically.
Public Property | Visible | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overridden.
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | DataBound | (Inherited from System.Web.UI.WebControls.BaseDataBoundControl)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadTicker Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadTicker Constructor

RadTicker Constructor
[image]
Telerik.WebControls Namespace > RadTicker Class : RadTicker Constructor

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadTicker()
C#
public RadTicker()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadTicker()
C#
public RadTicker()

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTicker Class
RadTicker Members

© 2002-2006, telerik. All Rights Reserved.


RadTicker Class Methods

RadTicker Class Methods
[image]
Telerik.WebControls Namespace : RadTicker Class

For a list of all members of this type, see RadTicker members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overridden.
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadTicker Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


DataBind Method

DataBind Method
[image]
Telerik.WebControls Namespace > RadTicker Class : DataBind Method

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As RadTicker

instance.DataBind()
C#
public override void DataBind()

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTicker Class
RadTicker Members

© 2002-2006, telerik. All Rights Reserved.


RadTicker Class Properties

RadTicker Class Properties
[image]
Telerik.WebControls Namespace : RadTicker Class

For a list of all members of this type, see RadTicker members.

Public Properties

 | Name | Description
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoAdvance | Specifies whether RadTicker will begin ticking the next tickerline (if any) after it has finished ticking the current one.
Public Property | AutoStart | Specifies whether the ticker begins ticking automatically.
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Overridden. The CSS Class name applied to the ticker.
Public Property | DataMember | (Inherited from System.Web.UI.WebControls.DataBoundControl)
Public Property | DataSource | (Inherited from System.Web.UI.WebControls.BaseDataBoundControl)
Public Property | DataSourceID | (Inherited from System.Web.UI.WebControls.DataBoundControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | LineDuration | Specifies in milliseconds the pause RadTicker makes before starting to tick the next line (if AutoAdvance=True).
Public Property | Loop | Specifies whether RadTicker will repeat the first tickerline after displaying the last one.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | RadControlsDir | (Inherited from Telerik.RadRotatorUtils.RadControl)
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | TickSpeed | Specifies the duration in milliseconds between ticking each character of a tickerline. The lower the value the faster a line will finish ticking.
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UseEmbeddedScripts | Gets or sets a value indicating whether to use the embedded JavaScript files or not. (Inherited from Telerik.RadRotatorUtils.RadControl)
Public Property | UserTickerLines | Allows the user to add tickerlines programmatically.
Public Property | Visible | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadTicker Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


AutoAdvance Property

AutoAdvance Property
[image]
Telerik.WebControls Namespace > RadTicker Class : AutoAdvance Property

Specifies whether RadTicker will begin ticking the next tickerline (if any) after it has finished ticking the current one.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoAdvance As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTicker
Dim value As Boolean

instance.AutoAdvance = value

value = instance.AutoAdvance
C#
public bool AutoAdvance {get; set;}

Return Value

Default: True

Remarks

If you set the AutoAdvance property to false, then you will have to use a client API Call ticker_id.TickNextLine()

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTicker Class
RadTicker Members

© 2002-2006, telerik. All Rights Reserved.


AutoStart Property

AutoStart Property
[image]
Telerik.WebControls Namespace > RadTicker Class : AutoStart Property

Specifies whether the ticker begins ticking automatically.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoStart As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTicker
Dim value As Boolean

instance.AutoStart = value

value = instance.AutoStart
C#
public bool AutoStart {get; set;}

Return Value

Default: False

Remarks

You should leave this set to false if you are using the ticker within a RadRotator If you use the ticker independently and leave this setting to false you should use the client API call ticker_id.StartTicker() to start it.

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTicker Class
RadTicker Members

© 2002-2006, telerik. All Rights Reserved.


CssClass Property

CssClass Property
[image]
Telerik.WebControls Namespace > RadTicker Class : CssClass Property

The CSS Class name applied to the ticker.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Property CssClass As String
Visual Basic (Usage) Copy Code
Dim instance As RadTicker
Dim value As String

instance.CssClass = value

value = instance.CssClass
C#
public override string CssClass {get; set;}

Return Value

Default: string.Empty

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTicker Class
RadTicker Members

© 2002-2006, telerik. All Rights Reserved.


LineDuration Property

LineDuration Property
[image]
Telerik.WebControls Namespace > RadTicker Class : LineDuration Property

Specifies in milliseconds the pause RadTicker makes before starting to tick the next line (if AutoAdvance=True).

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property LineDuration As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadTicker
Dim value As Integer

instance.LineDuration = value

value = instance.LineDuration
C#
public int LineDuration {get; set;}

Return Value

Default: 2000ms

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTicker Class
RadTicker Members

© 2002-2006, telerik. All Rights Reserved.


Loop Property

Loop Property
[image]
Telerik.WebControls Namespace > RadTicker Class : Loop Property

Specifies whether RadTicker will repeat the first tickerline after displaying the last one.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property Loop As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTicker
Dim value As Boolean

instance.Loop = value

value = instance.Loop
C#
public bool Loop {get; set;}

Return Value

Default: False

Remarks

If you set this property to true RadTicker will never finish ticking. This may have possible implications when having more than one RadTicker instance in a RadRotator. They way RadRotator works is that when the first ticker on a frame has finished ticking it will start ticking the next ticker on the frame. If a RadTicker instance is ticking (has Loop=true) it will never finish and the next ticker on the frame will not get started.

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTicker Class
RadTicker Members

© 2002-2006, telerik. All Rights Reserved.


TickSpeed Property

TickSpeed Property
[image]
Telerik.WebControls Namespace > RadTicker Class : TickSpeed Property

Specifies the duration in milliseconds between ticking each character of a tickerline. The lower the value the faster a line will finish ticking.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property TickSpeed As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadTicker
Dim value As Integer

instance.TickSpeed = value

value = instance.TickSpeed
C#
public int TickSpeed {get; set;}

Return Value

Default: 20ms

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTicker Class
RadTicker Members

© 2002-2006, telerik. All Rights Reserved.


UserTickerLines Property

UserTickerLines Property
[image]
Telerik.WebControls Namespace > RadTicker Class : UserTickerLines Property

Allows the user to add tickerlines programmatically.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property UserTickerLines As String()
Visual Basic (Usage) Copy Code
Dim instance As RadTicker
Dim value() As String

instance.UserTickerLines = value

value = instance.UserTickerLines
C#
public string[] UserTickerLines {get; set;}

Return Value

Default: null

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTicker Class
RadTicker Members

© 2002-2006, telerik. All Rights Reserved.


RadTickerLineControlBuilder Class

RadTickerLineControlBuilder Class
See Also Members
[image]
Telerik.WebControls Namespace : RadTickerLineControlBuilder Class

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Private Class RadTickerLineControlBuilder
   Inherits ControlBuilder
Visual Basic (Usage) Copy Code
Dim instance As RadTickerLineControlBuilder
C#
private class RadTickerLineControlBuilder : ControlBuilder

Inheritance Hierarchy

System.Object
System.Web.UI.ControlBuilder
Telerik.WebControls.RadTickerLineControlBuilder

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

RadTickerLineControlBuilder Members
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadTickerLineControlBuilder Class Members

RadTickerLineControlBuilder Class Members
See Also Properties Methods
[image]
Telerik.WebControls Namespace : RadTickerLineControlBuilder Class

The following tables list the members exposed by RadTickerLineControlBuilder.

Public Constructors

 | Name | Description
Public Constructor | RadTickerLineControlBuilder Constructor |
Top

Public Properties

 | Name | Description
Public Property | BindingContainerType | (Inherited from System.Web.UI.ControlBuilder)
Public Property | ControlType | (Inherited from System.Web.UI.ControlBuilder)
Public Property | CurrentFilterResolutionService | (Inherited from System.Web.UI.ControlBuilder)
Public Property | DeclareType | (Inherited from System.Web.UI.ControlBuilder)
Public Property | HasAspCode | (Inherited from System.Web.UI.ControlBuilder)
Public Property | ID | (Inherited from System.Web.UI.ControlBuilder)
Public Property | Localize | (Inherited from System.Web.UI.ControlBuilder)
Public Property | NamingContainerType | (Inherited from System.Web.UI.ControlBuilder)
Public Property | ServiceProvider | (Inherited from System.Web.UI.ControlBuilder)
Public Property | TagName | (Inherited from System.Web.UI.ControlBuilder)
Public Property | ThemeResolutionService | (Inherited from System.Web.UI.ControlBuilder)
Top

Public Methods

 | Name | Description
Public Method | AllowWhitespaceLiterals | Overridden.
Public Method | AppendLiteralString | (Inherited from System.Web.UI.ControlBuilder)
Public Method | AppendSubBuilder | (Inherited from System.Web.UI.ControlBuilder)
Public Method | BuildObject | (Inherited from System.Web.UI.ControlBuilder)
Public Method | CloseControl | (Inherited from System.Web.UI.ControlBuilder)
Public Method | GetChildControlType | Overridden.
Public Method | GetObjectPersistData | (Inherited from System.Web.UI.ControlBuilder)
Public Method | GetResourceKey | (Inherited from System.Web.UI.ControlBuilder)
Public Method | HasBody | (Inherited from System.Web.UI.ControlBuilder)
Public Method | HtmlDecodeLiterals | Overridden.
Public Method | Init | (Inherited from System.Web.UI.ControlBuilder)
Public Method | NeedsTagInnerText | (Inherited from System.Web.UI.ControlBuilder)
Public Method | OnAppendToParentBuilder | (Inherited from System.Web.UI.ControlBuilder)
Public Method | ProcessGeneratedCode | (Inherited from System.Web.UI.ControlBuilder)
Public Method | SetResourceKey | (Inherited from System.Web.UI.ControlBuilder)
Public Method | SetServiceProvider | (Inherited from System.Web.UI.ControlBuilder)
Public Method | SetTagInnerText | (Inherited from System.Web.UI.ControlBuilder)
Top

See Also

Reference

RadTickerLineControlBuilder Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadTickerLineControlBuilder Constructor

RadTickerLineControlBuilder Constructor
[image]
Telerik.WebControls Namespace > RadTickerLineControlBuilder Class : RadTickerLineControlBuilder Constructor

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadTickerLineControlBuilder()
C#
public RadTickerLineControlBuilder()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadTickerLineControlBuilder()
C#
public RadTickerLineControlBuilder()

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTickerLineControlBuilder Class
RadTickerLineControlBuilder Members

© 2002-2006, telerik. All Rights Reserved.


RadTickerLineControlBuilder Class Methods

RadTickerLineControlBuilder Class Methods
[image]
Telerik.WebControls Namespace : RadTickerLineControlBuilder Class

For a list of all members of this type, see RadTickerLineControlBuilder members.

Public Methods

 | Name | Description
Public Method | AllowWhitespaceLiterals | Overridden.
Public Method | AppendLiteralString | (Inherited from System.Web.UI.ControlBuilder)
Public Method | AppendSubBuilder | (Inherited from System.Web.UI.ControlBuilder)
Public Method | BuildObject | (Inherited from System.Web.UI.ControlBuilder)
Public Method | CloseControl | (Inherited from System.Web.UI.ControlBuilder)
Public Method | GetChildControlType | Overridden.
Public Method | GetObjectPersistData | (Inherited from System.Web.UI.ControlBuilder)
Public Method | GetResourceKey | (Inherited from System.Web.UI.ControlBuilder)
Public Method | HasBody | (Inherited from System.Web.UI.ControlBuilder)
Public Method | HtmlDecodeLiterals | Overridden.
Public Method | Init | (Inherited from System.Web.UI.ControlBuilder)
Public Method | NeedsTagInnerText | (Inherited from System.Web.UI.ControlBuilder)
Public Method | OnAppendToParentBuilder | (Inherited from System.Web.UI.ControlBuilder)
Public Method | ProcessGeneratedCode | (Inherited from System.Web.UI.ControlBuilder)
Public Method | SetResourceKey | (Inherited from System.Web.UI.ControlBuilder)
Public Method | SetServiceProvider | (Inherited from System.Web.UI.ControlBuilder)
Public Method | SetTagInnerText | (Inherited from System.Web.UI.ControlBuilder)
Top

See Also

Reference

RadTickerLineControlBuilder Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


AllowWhitespaceLiterals Method

AllowWhitespaceLiterals Method
[image]
Telerik.WebControls Namespace > RadTickerLineControlBuilder Class : AllowWhitespaceLiterals Method

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function AllowWhitespaceLiterals() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTickerLineControlBuilder
Dim value As Boolean

value = instance.AllowWhitespaceLiterals()
C#
public override bool AllowWhitespaceLiterals()

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTickerLineControlBuilder Class
RadTickerLineControlBuilder Members

© 2002-2006, telerik. All Rights Reserved.


GetChildControlType Method

GetChildControlType Method
[image]
Telerik.WebControls Namespace > RadTickerLineControlBuilder Class : GetChildControlType Method

tagName
attribs

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function GetChildControlType( _
   ByVal tagName As String, _
   ByVal attribs As IDictionary _
) As Type
Visual Basic (Usage) Copy Code
Dim instance As RadTickerLineControlBuilder
Dim tagName As String
Dim attribs As IDictionary
Dim value As Type

value = instance.GetChildControlType(tagName, attribs)
C#
public override Type GetChildControlType(
   string tagName,
   IDictionary attribs
)

Parameters

tagName
attribs

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTickerLineControlBuilder Class
RadTickerLineControlBuilder Members

© 2002-2006, telerik. All Rights Reserved.


HtmlDecodeLiterals Method

HtmlDecodeLiterals Method
[image]
Telerik.WebControls Namespace > RadTickerLineControlBuilder Class : HtmlDecodeLiterals Method

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Overrides Public Function HtmlDecodeLiterals() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTickerLineControlBuilder
Dim value As Boolean

value = instance.HtmlDecodeLiterals()
C#
public override bool HtmlDecodeLiterals()

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTickerLineControlBuilder Class
RadTickerLineControlBuilder Members

© 2002-2006, telerik. All Rights Reserved.


RadRotator.TickerInRotator Structure

RadRotator.TickerInRotator Structure
See Also Members
[image]
Telerik.WebControls Namespace : RadRotator.TickerInRotator Structure

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Private Structure RadRotator.TickerInRotator
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.TickerInRotator
C#
private struct RadRotator.TickerInRotator : ValueType

Syntax

Visual Basic (Declaration)
Private Structure RadRotator.TickerInRotator
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.TickerInRotator
C#
private struct RadRotator.TickerInRotator : ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Telerik.WebControls.RadRotator.TickerInRotator

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

RadRotator.TickerInRotator Members
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotator.TickerInRotator Structure Members

RadRotator.TickerInRotator Structure Members
See Also Methods
[image]
Telerik.WebControls Namespace : RadRotator.TickerInRotator Structure

The following tables list the members exposed by RadRotator.TickerInRotator.

Public Constructors

 | Name | Description
Public Constructor | RadRotator.TickerInRotator Constructor |
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.ValueType)
Public Method | GetHashCode | (Inherited from System.ValueType)
Public Method | ToString | (Inherited from System.ValueType)
Top

See Also

Reference

RadRotator.TickerInRotator Structure
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotator.TickerInRotator Constructor

RadRotator.TickerInRotator Constructor
[image]
Telerik.WebControls Namespace > RadRotator.TickerInRotator Structure : RadRotator.TickerInRotator Constructor

_parent
_ticker

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal _parent As Control, _
   ByVal _ticker As RadTicker _
)
Visual Basic (Usage) Copy Code
Dim _parent As Control
Dim _ticker As RadTicker

Dim instance As RadRotator.TickerInRotator(_parent, _ticker)
C#
public RadRotator.TickerInRotator(
   Control _parent,
   RadTicker _ticker
)

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal _parent As Control, _
   ByVal _ticker As RadTicker _
)
Visual Basic (Usage) Copy Code
Dim _parent As Control
Dim _ticker As RadTicker

Dim instance As RadRotator.TickerInRotator(_parent, _ticker)
C#
public RadRotator.TickerInRotator(
   Control _parent,
   RadTicker _ticker
)

Parameters

_parent
_ticker

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator.TickerInRotator Structure
RadRotator.TickerInRotator Members

© 2002-2006, telerik. All Rights Reserved.


Get more help

Telerik RadRotator v2.7 Send comments on this topic.
Get more help

Glossary Item Box

In case you cannot find the needed information in this manual, you can also review the following resources:

  • online Knowledge Base - visit http://www.telerik.com/KB/ and browse or search the articles for a solution to your problem;
  • Telerik product forums at http://www.telerik.com/Forums/ - consult with other people who use our products;
    Use the in-built search on the page.
  • live examples at http://www.telerik.com/r.a.d.controls/ - use the left pane to navigate to the control and functionality you need. In the right pane, toggle among the various pages (Description, C#, ASPX, etc.) to learn about the functionality displayed.
  • online code library - visit http://www.telerik.com/community/code-library/default.aspx adn download a growing number of samples, get hands-on experience with the RadControls and submit some of your favorite implementations.
  • contact Telerik support with a technical question using your Client.NET account at http://www.telerik.com/Default.aspx?PageId=2069.

You can also send us comments on any topic by clicking on the link in the top right corner of the page:

The Send comments link

Alternatively, you can send an email to documentation@telerik.com with feedback or inquiries concerning our manuals.

© 2002-2008 Telerik. All Rights Reserved.


Applying Themes

Telerik RadRotator v2.7 Send comments on this topic.
Applying Themes

Glossary Item Box

© 2002-2008 Telerik. All Rights Reserved.


Support for .Net 2.0 Themes

Telerik RadRotator v2.7 Send comments on this topic.
Support for .Net 2.0 Themes
See Also

Glossary Item Box

Among the numerous innovations of the .NET 2.0 Framework are the so-called Themes. They enable the separation of a control's look from its functionality. As a result, developers will be able to completely change the look of a control in an easy declarative manner. This improves the maintainability of your applications and eliminate the unnecessary duplication of code for shared styles.

Each Theme is a folder with one .skin file and any additional resources (such as .CSS files, images, etc). The skin file contains XML tags that are used to configure the controls on the page.

Assigning a Theme to a Page

An individual page can be assigned a Theme by setting the <%@ Page Theme="..." %> directive to the name of a global or application-level. A page can only have one Theme applied, but there may be multiple skin files in the theme that apply style settings to controls in the page.

You can also define the applied theme for all pages in an application by specifying the <pages theme="..."/> section in Web.config. To unset this theme for a particular page, you can set the Theme attribute of the Page directive to empty string ("").

Using Themes global to the system

Global Themes reside in a "Themes" folder under an ASP.NETClientFiles folder under the ASP.NET installation directory, for example %WINDIR%\Microsoft.NET\Framework\<version>\ASP.NETClientFiles\Themes. The location of global themes is Inetpub\wwwroot\aspnet_client\system_web\<version>\Themes for IIS web sites.

Using Themes local to the application

Local Themes reside in the App_Themes folder directly under the application root directory. A Theme consists of a named subdirectory which may contain CSS file and/or subdirectories for static files like images. Each theme should have one or more skin files, with the .skin extension. The contents of a skin file are simply definitions of the properties of the controls, used to specify how the controls will appear and behave on the page. A skin file can contain multiple control definitions, for example one definition for each control type.

Skins can be organized in a variety of ways inside a Theme's skin files. Since a Theme can contain multiple skin files, you might divide up named skins into separate files, where each skin file contained multiple control definitions with the same SkinID.

The example below shows two ways how skin files are arranged in the Theme folder.

Three skin files in a Theme each named according to a particular SkinID value

Skin files grouped by control type, where each skin contains a set of skin definitions for a particular control

Copy Code
/MySite1
/App_Themes
/MyThemes
Default.skin
Yellow.skin
Green.skin
Copy Code
/MySite1
/App_Themes
/MyThemes
radmenu.skin
radpanelbar.skin
rad.tabstrip.skin

Currently r.a.d.rotator does not support ASP.Net 2.0 Themes.

See Also

Overview

© 2002-2008 Telerik. All Rights Reserved.


Telerik RadRotator v2.7 Send comments on this topic.

Glossary Item Box

© 2002-2008 Telerik. All Rights Reserved.


Creating Telerik RadRotator at Design Time

Telerik RadRotator v2.7 Send comments on this topic.
Creating Telerik RadRotator at Design Time

Glossary Item Box

Not yet available

© 2002-2008 Telerik. All Rights Reserved.


Glossary

Telerik RadRotator v2.7 Send comments on this topic.
Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

© 2002-2008 Telerik. All Rights Reserved.


Guidelines for Specifying Domain Names

Telerik RadRotator v2.7 Send comments on this topic.
Guidelines for Specifying Domain Names

Glossary Item Box

To create a License key you will need to know the IP and domain/machine name by which you plan to access the control, i.e.

http://123.123.123.123/MyApplication/

http://www.mysite.com/MyApplication/

http://MachineName/MyApplication/

If you plan to sue the control on localhost or 127.0.0.1 you do not need keys - the control will work properly, but a copyright message will be displayed occasionally.

The control checks the URL by which it is accessed and compares this URL to the IP and domain name encoded in the license key. If these do not match, a copyright message will be shown.

Entering domain/machine names

Use only top-level domain names. The control will work on all other subdomains. Do not enter prefixes like www or http://

Original URL | Right | Wrong
http://www.mysite.com | mysite.com | www.mysite.com http://www.mysite.com
http://mysite.com | mysite.com | http://mysite.com
http://support.mysite.com | mysite.com | support.mysite.com
http://mydomain/ | mydomain | http://mydomain
http://machinename/ | machinename | http://machinenam

In case of a complex country-specific domain name (like www.mysite.co.uk, www.mysite.org.bg) you need to enter the actual domain name (mysite) followed by the full extension (co.uk):

Original URL | Right | Wrong
http://www.mysite.co.uk | mysite.co.uk | http://www.mysite.co.uk
http://mysite.gov.tw | mysite.gov.tw | http://mysite.gov.tw
http://www.support.mysite.biz.nl | mysite.biz.nl | http://www.support.mysite.biz.nl

If the the domain/machine name is unknown, or if the control will be used on localhost, use localhost in the domain field when creating the keys.

Entering IPs

Use only the top-level IP address. The control will work on all subdomains and ports. Do not enter prefixes like www or http://

Original URL | Right | Wrong
http://123.123.123.123/ | 123.123.123.123 | http://123.123.123.123
http://123.123.123.123:8080/ | 123.123.123.123 | 123.123.123.123:8080 http://123.123.123.123 http:// 123.123.123.123:8080

Do not enter an IP for the live server (not the development server) in case it has a domain name.

Original URL | Right | Wrong
http://www.mysite.com | mysite.com | http://123.123.123.123

If you have a dynamic DNS/IP, then it would be best to access the control by a domain name, rather than IP. In this case, use 127.0.0.1 in the IP field when creating the keys.

If the IP is unknown, or if the control is to be used on localhost only, use 127.0.0.1 in the IP field when creating the keys.

Other Important Information

If you are behind a firewall, the license ley will still work, as only the URL is checked.

The key will work for the major version of the product it was created for. For example, if the key is created for Telerik RadRotator v2.x it will NOT work on another major version (such as v1.x).

Back to Setting License Keys.

© 2002-2008 Telerik. All Rights Reserved.


More About License

Telerik RadRotator v2.7 Send comments on this topic.
More About License

Glossary Item Box

The LicenseFiles are XML files, which contain the licensing information (Company and LicenseKey) for every component of the Telerik RadControls for ASP.NET web-suite. This approach is much more convenient than setting licensing information directly in the control's properties, especially when you use multiple components on multiple pages. In case you upgrade your component, or implement the same application on a different server (domain) you have to change the Company and LicenseKey information only once – in the LicenseFile. Every Telerik component is shipped with a LicenseFile.XML located in the "~/RadControls" subfolder of the web-application. The LicenseFile property is set by default to point to this file so all you have to do is enter the required properties in the file. Below is a sample LicenseFile.XML:

<root>

<license control="editor" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY1"/>
<license control="spell" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY2"/>
<license control="menu" company="YOUR COMPANY" licenseKey="YOUR LICENSE KEY3"/>

</root>

Please, note that you may use a single LicenseFile to unlock more than one Telerik components.

If you place trial and commercial key(s), Standard or Professional edition, the editor will use the commercial key(s).

Note:The values set in the LicenseKey and Company properties of the Telerik RadEditor tag will override the ones set in the LicenseFile. If you want to use the LicenseFile approach make sure you remove the LicenseKey and Company properties from the Telerik RadEditor tag.

© 2002-2008 Telerik. All Rights Reserved.


Support Options

Telerik RadRotator v2.7 Send comments on this topic.
Support Options

Glossary Item Box

© 2002-2008 Telerik. All Rights Reserved.


Multiple Rotators on a Single Page

Telerik RadRotator v2.7 Send comments on this topic.
Multiple Rotators on a Single Page

Glossary Item Box

Not yet available

© 2002-2008 Telerik. All Rights Reserved.


Getting Started - RadRotator

Getting Started

© 2002-2006, telerik. All Rights Reserved.


Introduction - RadRotator

Introduction

© 2002-2006, telerik. All Rights Reserved.


RadRotator.RadRotatorClickEventHandler Delegate

RadRotator.RadRotatorClickEventHandler Delegate
[image]
Telerik.WebControls Namespace : RadRotator.RadRotatorClickEventHandler Delegate

o
e
This is the event handler for the RadRotator.ItemClicked event.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub RadRotator.RadRotatorClickEventHandler( _
   ByVal o As Object, _
   ByVal e As RadRotatorClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New RadRotatorClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void RadRotator.RadRotatorClickEventHandler(
   object o,
   RadRotatorClickEventArgs e
)

Parameters

o
e

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

Telerik.WebControls Namespace
ItemClicked Event
RadRotatorClickEventArgs Class

© 2002-2006, telerik. All Rights Reserved.


RadRotator.RadRotatorItemEventHandler Delegate

RadRotator.RadRotatorItemEventHandler Delegate
[image]
Telerik.WebControls Namespace : RadRotator.RadRotatorItemEventHandler Delegate

sender
e

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub RadRotator.RadRotatorItemEventHandler( _
   ByVal sender As Object, _
   ByVal e As RadRotatorItemEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New RadRotatorItemEventHandler(AddressOf HandlerMethod)
C#
public delegate void RadRotator.RadRotatorItemEventHandler(
   object sender,
   RadRotatorItemEventArgs e
)

Parameters

sender
e

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotator.RotatorScrollDirection Enumeration

RadRotator.RotatorScrollDirection Enumeration
[image]
Telerik.WebControls Namespace : RadRotator.RotatorScrollDirection Enumeration

This enumeration lists the possible directions for scrolling

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Enum RadRotator.RotatorScrollDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.RotatorScrollDirection
C#
public enum RadRotator.RotatorScrollDirection : Enum

Members

Member | Description
Up |
Down |
Left |
Right |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.RadRotator.RotatorScrollDirection

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotator.RotatorTransitionEffect Enumeration

RadRotator.RotatorTransitionEffect Enumeration
[image]
Telerik.WebControls Namespace : RadRotator.RotatorTransitionEffect Enumeration

This enumeration contains the different effects that RadRotator could use

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Enum RadRotator.RotatorTransitionEffect
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.RotatorTransitionEffect
C#
public enum RadRotator.RotatorTransitionEffect : Enum

Members

Member | Description
RANDOM |
NONE |
Barn |
Blinds |
Checkerboard |
Fade |
GradientWipe |
Inset |
Iris |
Pixelate |
RadialWipe |
RandomBars |
RandomDissolve |
Slide |
Spiral |
Stretch |
Strips |
Wheel |
ZigZag |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.RadRotator.RotatorTransitionEffect

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotator.RotatorTransitionType Enumeration

RadRotator.RotatorTransitionType Enumeration
[image]
Telerik.WebControls Namespace : RadRotator.RotatorTransitionType Enumeration

This enumeration lists the possible modes of rotation

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Enum RadRotator.RotatorTransitionType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RadRotator.RotatorTransitionType
C#
public enum RadRotator.RotatorTransitionType : Enum

Members

Member | Description
Scroll |
Slideshow |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Telerik.WebControls.RadRotator.RotatorTransitionType

Requirements

Namespace: Telerik.WebControls

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: RadRotator (in RadRotator.dll)

See Also

Reference

Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotator.TickerInRotator Structure Methods

RadRotator.TickerInRotator Structure Methods
[image]
Telerik.WebControls Namespace : RadRotator.TickerInRotator Structure

For a list of all members of this type, see RadRotator.TickerInRotator members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.ValueType)
Public Method | GetHashCode | (Inherited from System.ValueType)
Public Method | ToString | (Inherited from System.ValueType)
Top

See Also

Reference

RadRotator.TickerInRotator Structure
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotatorFrame Class Events

RadRotatorFrame Class Events
[image]
Telerik.WebControls Namespace : RadRotatorFrame Class

For a list of all members of this type, see RadRotatorFrame members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadRotatorFrame Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadRotatorFrame Class Methods

RadRotatorFrame Class Methods
[image]
Telerik.WebControls Namespace : RadRotatorFrame Class

For a list of all members of this type, see RadRotatorFrame members.

Public Methods

 | Name | Description
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadRotatorFrame Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadRotator Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadRotator Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadRotator
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadRotator Class
RadRotator Members

© 2002-2006, telerik. All Rights Reserved.


RadTicker Class Events

RadTicker Class Events
[image]
Telerik.WebControls Namespace : RadTicker Class

For a list of all members of this type, see RadTicker members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | DataBound | (Inherited from System.Web.UI.WebControls.BaseDataBoundControl)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

RadTicker Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadTickerLineControlBuilder Class Properties

RadTickerLineControlBuilder Class Properties
[image]
Telerik.WebControls Namespace : RadTickerLineControlBuilder Class

For a list of all members of this type, see RadTickerLineControlBuilder members.

Public Properties

 | Name | Description
Public Property | BindingContainerType | (Inherited from System.Web.UI.ControlBuilder)
Public Property | ControlType | (Inherited from System.Web.UI.ControlBuilder)
Public Property | CurrentFilterResolutionService | (Inherited from System.Web.UI.ControlBuilder)
Public Property | DeclareType | (Inherited from System.Web.UI.ControlBuilder)
Public Property | HasAspCode | (Inherited from System.Web.UI.ControlBuilder)
Public Property | ID | (Inherited from System.Web.UI.ControlBuilder)
Public Property | Localize | (Inherited from System.Web.UI.ControlBuilder)
Public Property | NamingContainerType | (Inherited from System.Web.UI.ControlBuilder)
Public Property | ServiceProvider | (Inherited from System.Web.UI.ControlBuilder)
Public Property | TagName | (Inherited from System.Web.UI.ControlBuilder)
Public Property | ThemeResolutionService | (Inherited from System.Web.UI.ControlBuilder)
Top

See Also

Reference

RadTickerLineControlBuilder Class
Telerik.WebControls Namespace

© 2002-2006, telerik. All Rights Reserved.


RadControlsDir Property

RadControlsDir Property
[image]
Telerik.WebControls Namespace > RadTicker Class : RadControlsDir Property

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property RadControlsDir As String
Visual Basic (Usage) Copy Code
Dim instance As RadTicker
Dim value As String

instance.RadControlsDir = value

value = instance.RadControlsDir
C#
public string RadControlsDir {get; set;}

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTicker Class
RadTicker Members

© 2002-2006, telerik. All Rights Reserved.


UseEmbeddedScripts Property

UseEmbeddedScripts Property
[image]
Telerik.WebControls Namespace > RadTicker Class : UseEmbeddedScripts Property

Gets or sets a value indicating whether to use the embedded JavaScript files or not.

Namespace: Telerik.WebControls
Assembly: RadRotator (in RadRotator.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEmbeddedScripts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTicker
Dim value As Boolean

instance.UseEmbeddedScripts = value

value = instance.UseEmbeddedScripts
C#
public bool UseEmbeddedScripts {get; set;}

Return Value

True if embedded JavaScript files are to be used; otherwise false. The default value is true.

Remarks

Use this property for debugging purposes or to apply any modifications to the JavaScript files.

Requirements

Platforms: Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTicker Class
RadTicker Members

© 2002-2006, telerik. All Rights Reserved.


Telerik.WebControls Namespace

Telerik.WebControls Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
RadRotator |
RadRotator.DummyDataSource |
RadRotator.DummyDataSource.DummyDataSourceEnumerator |
RadRotatorClickEventArgs | This is a container class which inherits System.EventArgs and provides functionality specific to RadRotator
RadRotatorFrame | This class represents a RadRotator frame.
RadRotatorFrameCollection |
RadRotatorItemEventArgs |
RadTicker | RadTicker v2.1
RadTickerLineControlBuilder |

Structures

Structure | Description
RadRotator.TickerInRotator |

Delegates

Delegate | Description
RadRotator.RadRotatorClickEventHandler | This is the event handler for the RadRotator.ItemClicked event.
RadRotator.RadRotatorItemEventHandler |

Enumerations

Enumeration | Description
RadRotator.RotatorScrollDirection | This enumeration lists the possible directions for scrolling
RadRotator.RotatorTransitionEffect | This enumeration contains the different effects that RadRotator could use
RadRotator.RotatorTransitionType | This enumeration lists the possible modes of rotation

See Also

Reference

RadRotator Assembly

© 2002-2006, telerik. All Rights Reserved.


Telerik.WebControls Namespace Inheritance Hierarchy

Telerik.WebControls Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
System.EventArgs
Telerik.WebControls.RadRotatorClickEventArgs
Telerik.WebControls.RadRotatorItemEventArgs
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.BaseDataBoundControl
System.Web.UI.WebControls.DataBoundControl
Telerik.RadRotatorUtils.RadControl
Telerik.WebControls.RadRotator
Telerik.WebControls.RadTicker
Telerik.WebControls.RadRotatorFrame
System.Web.UI.ControlBuilder
Telerik.WebControls.RadTickerLineControlBuilder
Telerik.WebControls.RadRotator.DummyDataSource
Telerik.WebControls.RadRotator.DummyDataSource.DummyDataSourceEnumerator
Telerik.WebControls.RadRotatorFrameCollection

See Also

Reference

RadRotator Assembly

© 2002-2006, telerik. All Rights Reserved.


Telerik RadRotator stops after callback

Telerik RadRotator v2.7 Send comments on this topic.
Telerik RadRotator stops after callback

Glossary Item Box

© 2002-2008 Telerik. All Rights Reserved.


Server-Side API

Telerik RadRotator v2.7 Send comments on this topic.
Server-Side API

Glossary Item Box

Telerik RadRotator API provides two classes: RadRotator and RadTicker which expose several properties and methods which allows you to create and customize a RadRotator or RadTicker programmatically in code-behind.

RadRotator Classs

This class exposes several properties you can easily customize the look and behavior in code-behind.

Example

The extract of the source code below illustrates how you can customize a rotator programmatically in code-behind.

RadTicker class

This class exposes properties you can easily use to customize the look and behavior in code-behind.

Example

The extract of the source code below illustrates how you can customize a ticker programmatically in code-behind.

© 2002-2008 Telerik. All Rights Reserved.


Themes

Telerik RadRotator v2.7 Send comments on this topic.
Themes

Glossary Item Box

As of Q2 2006 we have introduced a variety of new common skins (themes in ASP.NET 2.0) for all Telerik RadControls for ASP.NET. By default all controls take a new polished look and feel which is consistent across the whole product line. Five other new common skins (Outlook, Mac, Inox, Telerik and WebBlue) have been added to all Telerik RadControls for ASP.NET for a richer set of interface designs to choose from.

Please, note that if you want to use the old default skins of any product you can still find them in RadControls/[ProductName]/Skins. A preview of all the provided skins is available in our Live Examples.

© 2002-2008 Telerik. All Rights Reserved.


Customizing Appearance with CSS

Telerik RadRotator v2.7 Send comments on this topic.
Customizing Appearance with CSS
Customizing Appearance > Customizing Appearance with CSS

Glossary Item Box

Once you have defined the Telerik RadRotator structure, you need to customize its appearance. If you don't do this, the default appearance will be used.

Telerik RadRotator uses cascading style sheets (CSS) that can be applied to the rotator structure elements. To do so, you need to set the property CssClass, which is used to specify the path to the CSS file.

Example Code

The definition of the CssClass property in the ASPX file:

Copy Code
<rad:RadRotator id="Rotator1" runat="server" ContentFile="rotator.xml" CssClass = "DemoNewsTitle"
Width="430px"
Height="33px">
</rad:RadRotator>

The source code of the CSS class used for customizing the appearance:

Copy Code
.DemoNewsTitle
{
font-family : Verdana, Arial; font-size : 10px;
}

.DemoNewsText
{
font-family:Verdana;
font-size:10px;
color:#E6E573;
}

.BorderStyle
{
border:1px;
border-style:solid;
border-left-color:#F8CB75;
border-top-color:#F8CB75;
border-right-color:#842402;
border-bottom-color:#842402;
}

© 2002-2008 Telerik. All Rights Reserved.


Using Themes

Telerik RadRotator v2.7 Send comments on this topic.
Using Themes
See Also

Glossary Item Box

Among the numerous innovations the .NET Framework v2.0 introduces are the so-called Themes. They enable the separation of a control's look from its functionality. As a result, developers will be able to completely change the look [and behavior] of a control in an easy declarative manner.

Each Theme is a folder with one or more .skin files and any additional necessary resources (such as .CSS files, images, etc). The skin files contain XML tags that are used to configure the controls on the page. Those tags look almost identically to regular ASP.NET tags so you can very conveniently copy paste settings between the Theme and your controls file (ASPX/ASCX).

Using Themes local to the application

Themes can be local for the application (each theme resides in a separate folder under the "app_themes" folder in the root of the web application).

To use Themes you need to copy the "app_themes" directory (if available for the specific component) under the same name to your application's root directory.

The "app_themes" directory is available for copying from your Telerik RadRotator directory:
Example: C:\Program Files\Telerik\Telerik RadRotator2.1\Net2\app_themes

Using Themes global to the system

Themes are globally accessible from .NET 2.0 applications if they reside in the .NET framework directory, under a special folder called "app_themes". This feature is supported by Telerik controls, however requires special lowered security settings, until standard access mechanisms are provided in .NET Framework final release.

Telerik RadRotator themes are constructed from CSS classes and Images only. To fine-tune the look of an item, after the Theme is applied, one could use the API and all of the properties like Logos, CSS styles, etc.

Overriding the default Themes folder

You can change the default location of the "app_themes" folder using the ThemesDir property of RadRotator. The default value for this property is "~/app_themes/" where "~/" represents your web application root. You can change the value of the property and Telerik RadRotator will search its theme in the specified folder. However, since the shipped themes are created to use the app_themes folder, you should change manually the .skin files in order to reflect the change.

For example you might have to change the values of the ImagesBaseDir and CssFile, which by default start with "~/app_themes/".

See Also

Customizing Appearance with CSS

© 2002-2008 Telerik. All Rights Reserved.